5

IBM System Storage

Quick Start Guide

Quick reference for the DS5100 and DS5300,
and for the EXP5000

(P) IBM PN: 59Y7236 GC53-1134-02

Color Key: IBM customer tasks are documented in the sections with the

purple headings. Service Support Representative tasks are documented in
the sections with the blue headings.

1.1 Before you begin

A _’Dﬁ Safety Information

Management methods are specific to the installation steps found in
Sections 5 and 7.

Note: For detailed network and management configuration
information, see the IBM System Storage DS5100 and DS5300
Installation, User's, and Maintenance Guide.

Learn about management methods:

In-band management — Management using the 1/0O connections
between the host and the storage subsystem. Note that the host must
still have network capabilities.

Out-of-band management — Management directly through the
Ethernet connections on each controller, using one of the network
configurations from the list below:
«DHCP Server
*Default Ethernet port 1 IP address:
=Controller A: 192.168.128.101
=Controller B: 192.168.128.102
=Subnet Mask: 255.255.255.0
= Static IP

Learn about iSCSI port network configuration:
Use one of the following network configurations to set up an iSCSI
port network:

« DHCP Server

= Default Ethernet port 1 IP address:
Controller A: P1:192.168.130.101, P2:192.168.131.101,
P3:192.168.132.101, P4:192.168.133.101
Controller B: P1:192.168.130.102, P2:192.168.131.102,
P3:192.168.132.102, P4:192.168.133.102
Subnet Mask: 255.255.255.0

= Static IP

For educational information about the DS5020 and other IBM System
Storage products, go to
http://ibmdsseriestraining.com/.

1.2 Install the software

At this time, check your current Fibre Channel and iSCSI (if applicable)
Host Bus Adapters (HBAs), BIOS, and device driver versions. If
necessary, update before proceeding. For IBM HBAs, the BIOS and
device drivers are located in the HostAdapter directory on the DS
Storage Manager software DVD. For the latest IBM HBA BIOS and
drivers follow the steps under Accessing the IBM Support/Download
Web site. Refer to the HBA READMEs for installation instructions.

Note: For Windows installations, install the StorPort device driver.

On the DS Storage Manager software DVD, locate the applicable
operating system directory (Win32, WS03 x86_32bit, WS03 |A64,
WSO03_x64, Linux, Linux_IA64, AlX, Solaris, HP-UX, or LoP). Before
launching the SMIA executable file in the folder, verify that it is the
latest DS Storage Manager available.

Access the IBM Support/Download Web site:

1. Go to http://www-03.ibm.com/systems/storage/disk/.

2. Choose a storage subsystem under DS5000 to access the correct
support page, then click Product Support.

3. Click on the Download tab, then click on Storage Manager. Choose
the Storage Manager product specific to your version and host
operating system.

4. On the subsequent browser page, choose the Storage Manager file
(including the README) you wish to download, and click on that File
link.

5. Download and unzip the packages into a directory that you can point
to later.

Note: For detailed information about driver and firmware versions,
make sure you consult the README files that are posted with each
package.

Which Computer?

. Every attached I/O host - All computers that are attached to the
storage subsystem and will be sending 1/0.

= Management Work Station - Computer(s) that you will use to
manage the storage subsystem.

Notes:

. For Windows installations, select the MPIO multipath driver.

. Review the appropriate OS and Device Driver READMEs included
on the Storage Manager CD, and refer to the IBM System Storage
DS Storage Manager Installation and Host Support Guide on the
documentation CD for more detailed instructions.

Launch the SMIA executable file. Follow the wizard, and select the
following installation methods:

. Forone I/O host designated as a Monitor (for monitoring and
sending alert notifications):
= Choose Typical (full installation), and when prompted, click
Automatically Start Monitor.
« For all other I/O hosts attached to the storage subsystem:
» Choose Host.
. For the computers you will use to manage the storage subsystem:
. Choose Management Station, and when prompted, click Do Not
Automatically Start the Monitor.

EXP5000 ship group:

. Two SFP modules (eight included with the DS5100 and DS5300)

= 3-U EXP5000 Drive Expansion Enclosure (1818-D1A)

= One rack mounting hardware kit, with twelve (12) M5 black hex-head slotted
screws and eight (8) washers

Options:

= Disk Drive Modules (DDMs) (two minimum for each EXP5000 expansion
enclosure)

= Two SFP modules for each fiber-optic cable (only one SFP is required for
direct attachment to host HBA)

= Two fiber-optic cables for each Fibre Channel host connection (direct
connection) or four fiber-optic cables for each redundant Fibre Channel switch
connection (fabric connection)

= Two fiber-optic cables for each EXP5000 connection

= Two HBAs installed in each host

= Two installed Fibre Channel switches (fabric connection only)

= Two Ethernet cables, one per controller (out-of-band management only)

= Four Cat5A/Cat6 Ethernet cables for each redundant switch connection
(iISCSI host connection only)

= Two installed Ethernet switches (iISCSI host connection only)

Tools:

. Internet connection

« Medium flat-blade screwdriver, #2 Phillips screwdriver, and 5/16 hex nut
driver

3 Install the enclosure

A Statement 4

CAUTION:
Use safe practices when lifting.
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1.3 What you need
" for assembly

DS5100 and DS5300 ship group:

One 4-U DS5100 Storage Subsystem (1818-51A)
One 4-U DS5300 Storage Subsystem (1818-53A)

= Two CDs:
= DS Storage Manager Software/Firmware/Drivers/BIOS
= DS5100 and DS5300 User’s Guide

= Two power cord jumpers
= One rack-mounting hardware kit, including:

= Two rails (right and left assemblies) and eight (8) M5 black
hex-head screws with wide flanges

2 Install the
support rails

« For proper weight distribution, install the rails from the DS5100 and DS5300 in
the lower portion of the rack cabinet.

= Allow room above and below the DS5100 and DS5300 for drive expansion
enclosures, as required.

= Use rack mounting template A, to locate the correct rail mounting holes for

EXP5000 expansion enclosure units.
= Use rack mounting template B, to locate the correct rail mounting holes for the

DS5100 or the DS5300 storage subsystem units.

Note: For the DS5100 or DS5300, use the M5 black broad flange hex-head
screws and template B. For the EXP5000, use the M5 black hex-head slotted
screws and template A. For both templates, rack mounting holes labeled 1
should be used first, followed by rack mounting holes labeled 2.

2.1 Starting with the left rail, use a medium flat-blade
screwdriver to loosen the two flat-head rail adjustment
screws. Hold the front of the left rail against the inside of
the front rack-mounting flange, and then extend the rear
of the support rail until it makes contact with the rear
rack mounting flange. The alignment pins at the rear of
the rail should slide into the holes at the rear of the rack.

2.2 From the front of the
rack, with the rail-mounted
flanges inside of the front rack
mounting flange, use either
the 5/16 (8mm) hex nut driver
or the #2 Phillips screwdriver
to loosely tighten the lower M5
screw only.
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Note: The type of tool depends
on the unit you are installing.
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2.3 From the back of the
rack, tighten two M5 screws
halfway for the unit being
installed, using either the 5/16
(8mm) hex nut driver or the #2
Phillips screwdriver.

Attention:

Make sure that the screws are
tight enough to support the
weight of the device. Do not
completely tighten the screws
until you have installed the
storage subsystem in the rack —
cabinet.

24 Repeat steps 2.1 through 2.3
with the right side rail.

25 Tighten the rail
adjustment screws on both rails.
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> 18 kg (39.7 Ib) >32kg (70.5 Ib) >55kg (121.2 Ib)
Unit Weight
Ds5100 Empty Maximum Shipping
DS5300 11.1 kg (24.5 Ib) 36.52 kg (80.7 Ib) 53.8 kg (118.4 Ib)
EXP5000 Empty Maximum Shipping
16.4 kg (36.1 Ib) 38.1 kg (84 Ib) 50.5 kg (111 Ib)

31 Remove the front bezel by grasping the sides and pulling the
bezel toward you.

Important: The following illustration shows a DS5100 or DS5300 with
Fibre Channel host interface cards. Depending on the storage
subsystem configuration you ordered, you might have only iSCS or a
mix of iISCSI and Fibre Channel host interface cards.
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Front bezel, off the unit

Power supply-fan, front view of unit
Interconnect-battery, front view of unit
Controller A, rear view of unit
Controller B, rear view of unit
Attention LED
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3.2 Remove the components. Each component of the DS5100 or
DS5300, including power supplies, interconnect-battery unit, and
controllers, is held in place by two locking levers.

To release both latches:
1. Push the latches to the side until the latches release the levers.

2. Rotate both levers out simultaneously. When the levers are
completely free, use the levers to pull the component from the
DS5100 or DS5300. Label controller A and controller B so that you
can replace each controller in the correct location after the DS5200
or DS5300 is installed. Controller A is in the upper-left location and
controller B is in the lower-right location.

3.3 Remove the empty DS5100 or DS5300 from the shipping box.
With the help of another person, place the back of the subsystem on
the support rails. Slide the subsystem into the cabinet, and verify that
the back of it is secured by the hold-down clips at the back of each
rail.

Note: If you remove the components before installation, you can lift
the enclosure into the rack with the help of one other person. If you do
not remove the components, you should have at least two other
people available to help you lift the enclosure into the rack.
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4 Secure the enclosure

A Statement 26

CAUTION:
Do not place any object on top of rack-mounted devices.

4.1 Align the front mounting holes on the DS5100, DS5300, or the
EXP5000 with the mounting holes on the cabinet.

1 Support rail
2 Mounting hole
3 Screws

4.2 Using the 5/16 (8mm) hex nut driver, insert one M5 screw into the

hole on each flange, and tighten the screws completely to secure the front
of the DS5100, DS5300, or EXP5000 to the cabinet.

4.3 At the front and the rear of the rack cabinet, use the 5/16 (8mm)
hex nut driver to finish tightening the other three M5 screws for each rail.

44 Replace the power supplies, the interconnect-battery unit, and the
controllers. Make sure that controller A is in the upper slot and controller B
is in the lower slot. Controller B is installed in the opposite orientation to
controller A.

45 Attach the DS5100 or DS5300 front bezel by aligning the pins on

the DS5100/DS5300 with the retainers on the cover, and press the cover
until the pins snap into place.

Note: For complete instructions about how to install EXP5000
enclosures, see the IBM System Storage DS5000 EXP5000 Storage
Expansion Enclosure Installation, User's, and Maintenance Guide.

B Install the cables
A Statement 3

CAUTION:

When laser products (such as CD-ROMs, DVD drives, fiber optic
devices, or transmitters) are installed, note the following:

- Do not remove the covers. Removing the covers of the
laser product could result in exposure to hazardous
laser radiation. There are no serviceable parts inside the
device.

- Use of controls or adjustments or performance of
procedures other than those specified herein might
result in hazardous radiation exposure.

A DANGER

Some laser products contain an embedded Class 3A or Class 3B
laser diode. Note the following:
- Laser radiation when open. Do not stare into the beam, do not
view directly with optical instruments, and avoid direct exposure
to the beam.

ATTENTION:

Do not bend or loop the cables to a diameter of less than 76 mm (3 in.) or a
radius of less than 38 mm (1.5 in.).
Host Cables

5.1 ifnot already installed in Fibre Channel host interface cards,
insert an SFP module into the required host ports on both controllers.
Remove any extra SFPs from host ports that won't be used. SFP
modules are needed only for Fibre Channel ports.

52 Choose the host connection configuration.

Direct Connection (Fibre Channel only): Connect the fiber-optic cable
from the host port on the controller to an HBA port on the host.

Switch Connection (Fibre Channel and iSCSI): Connect the fiber-
optic or Ethernet cable from the host port on the controller to a port on
the switch and make sure that the HBA and the controller are in the
same zone at the switch.

53 Repeat for each controller-to-host connection.

54 When finished, label each cable with to/from information.

Direct connection (Fibre Channel only)
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1and 4 Drive ports
2and 5 Ethernet ports
3and7 Host ports

6 Controller B

8 Controller A

9 SFP

10 Host 1, host adapters 1 and 2
1 Host 2, host adapters 1 and 2

Switch connection (Fibre Channel and iSCSI)

5.8 From the DS5100 or DS5300, connect the fiber-optic cable from
drive port 3 (drive channel 6) of controller B to the 1B port on the right
ESM board of the second storage expansion enclosure.
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Controller A
Controller B

EXP5000 left ESMs
EXP5000 right ESMs
ESM 1B ports
Controller drive ports
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Ethernet Cables - Out-of-Band Management Only

Steps to connect:

59 Connect one end of the Ethernet cable to the Ethernet port 1
connector on Controller A.

51 0 Connect the other end of the Ethernet cable to the applicable
network connection.

51 1 Repeat for controller B.

Notes:

= If not already installed, insert SFP modules into the required DS5100 or
DS5300 and EXP5000 drive ports. Remove any extra SFPs from drive
ports that won’t be used.

« Install a minimum of two drives per EXP5000. Start with the left slot.

01

Controller A

Controller B

Host 1, Fibre Channel host adapters 1 and 2
Host 2, iISCSI host adapters 1 and 2

Zoned Fibre Channel switches

Ethernet switches
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DS5100 or DS5300 and EXP5000 Drive Expansion Cabling

Steps to connect one EXP5000 storage expansion enclosure:

5.5 Starting on the DS5100 or DS5300, connect the fiber-optic cable

from drive port 8 (drive channel 1) of controller A to the 1B port on the
left ESM board of the first storage expansion enclosure.

56 From the DS5100 or DS5300, connect the fiber-optic cable from
drive port 1 (drive channel 5) of controller B to the 1B port on the right
ESM board of the first storage expansion enclosure.

Steps to connect a second EXP5000 storage expansion enclosure:

5.7 Starting on the DS5100 or DS5300, connect the fiber-optic cable

from drive port 6 (drive channel 2) of controller A to the 1B port on the
left ESM board of the second storage expansion enclosure.

6 Turn on the
storage subsystem

/!\ /&\ Statement 5

CAUTION:

The power control button on the device and the power switch on the power
supply do not turn off the electrical current supplied to the device. The
device also might have more than one power cord. To remove all electrical
current from the device, ensure that all power cords are disconnected from
the power source.
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IMPORTANT:

You must follow the power sequence in the order provided below. To
establish power redundancy for enclosures with two power supplies, use at
least two different power distribution units (PDUs) in the rack cabinet. Split
the power connections from each enclosure into the separate PDUs. Then
connect the PDUs to external power receptacles that are on different
circuits.

61 Connect a power cable to each power supply in the storage
subsystem, and then connect the other end to the rack cabinet power
receptacle.

6.2 Turn on the power to fabric devices, if applicable.

63 Turn on both power switches of all attached EXP5000s, and wait 60
seconds.

6.4 Turn on both power switches of the DS5100 or DS5300.

6.5 ifamber lights are visible, see the DS5100 or DS5300 Storage

Subsystems Installation, Maintenance, and User’s Guide to diagnose
potential issues.

Note: Turn off the power to the storage subsystem in the reverse order;
first the DS5100 or DS5300 and then the storage expansion enclosures.

7 Discover the
storage subsystem

To discover and set up the storage subsystem, complete the following steps:

71 Start the DS Storage Manager software from your management station.
The Enterprise Management and Confirm Initial Automatic Discovery
windows open.

7 .2 select Automatic Discovery from the Enterprise Management Window
to discover the storage subsystem. After the initial automatic discovery is
complete, the Enterprise Management window displays all hosts and storage
subsystems that are attached to the local sub network. Note: To discover
storage subsystems that are outside of the local sub network, click View >
Task Assistant > Add Storage Subsystems.

73 Click Rename the Storage Subsystem. Use the serial number of the
DS5100 or DS5300 as the first part of the subsystem name.

7 .4 Ciick Locate the Storage Subsystem. A blue LED flashes on the front
of the selected storage subsystem. Label the storage subsystem with its
associated name. Note: If the storage subsystem is not discovered
automatically, add the storage subsystem manually by typing the IP address.

7.5 Highlight the storage subsystem and click Tools > Manage Storage

Subsystem to open the Subsystem Management window and the Task
Assistant.

76 If the storage subsystem is not in Optimal state, click the Recover from
Failure icon in the Task Assistant. Follow the steps in the Recovery Guru.
When the subsystem is Optimal, close the Task Assistant.

7.7 inthe Subsystem Management window, click Storage Subsystem >
View Profile. Click the Controller Firmware, NVSRAM, ESM Firmware,
Drive Product ID, and Firmware Versions tabs, and write each number
down for future use.

7.8 save the profile for future use and close the profile window. Note: Save
a copy of the storage subsystem profile and the Collect All Support Data
bundle when you make configuration changes to the storage subsystems.

79 Make a direct management connection to the DS5000 storage

subsystem by using the default TCP/IP addresses:
Controller A: 192.168.128.101
Controller B: 192.168.128.102

7.9.1 Start the SMclient. The Enterprise Management window opens.

7.9.2 In the Enterprise Management window, click on the name of the default
storage subsystem. The Subsystem Management window opens.

7.9.3 In the Subsystem Management window, right-click the Controller icon;
click Change > Network Configuration. The Change Network Configuration
window opens.

7.9.4 In the Change Network Configuration window, click on the Controller A
and Controller B tabs; type the new TCP/IP addresses in the applicable
fields. Click OK.

7.9.5 Close the Subsystem Management window; wait five minutes, then
delete the default DS5000 Storage Subsystem entry in the Enterprise
Management window.

7.9.6 Add a new storage subsystem entry in the Enterprise Management
window using the new TCP/IP address. Note: To manage storage subsystems
through a firewall, configure the firewall to open port 2463 to TCP data.

8 Update the storage
subsystem firmware

Note: The Storage Manager host code and HBA BIOS/driver should be up-
to-date, if you completed all the steps in Section 1.2.

From the Subsystem Management Window, select Advanced >
Maintenance > Download. Click the following options in the order listed:

Controller firmware
Controller NVSRAM
ESM firmware
Drive firmware
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9 Configure the
storage subsystem

From the Subsystem Management Window, click View > Task Assistant. If
the storage subsystem is Optimal, complete the following tasks in the order
listed:

1. Configure alert notification for problems in the storage subsystem

2. Define hosts

3. Create new storage partitions

4. Save configuration

5. Set/change password
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