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Creating report templates with Report Designer

WebSphere Business Modeler enables you to build report templates that you can
use to generate detailed reports on your processes, resources, organizations,
simulations, and other modeling elements. Using Report Designer, you can add
specific fields to your report templates, creating the exact information and design
that you require in your reports.

This tutorial will demonstrate a common and efficient template design practice. It
will show you how to use Report Designer to build a generic report template, and
then use that basic template to make a more specific template. You will add a
variety of fields, polish your report’s design, and include a process diagram. You
will use your new template to generate a report for the Customer Order Handling
process that is part of the sample ABC Project included with WebSphere Business
Modeler.

First, you will learn how to create a report template and set general template
preferences. You will then use Report Designer to populate your template. Report
Designer provides a graphical editor and a Fields view for you to select the
specific fields to include in your template. You will include the following elements
in your report templates:

* Pages and page breaks

* DPage headers and footers
 Tables

* Static text fields

* Data fields

* Pictures

¢ Table of contents

* Summary statistics fields (such as counts, sums, and averages for selected data
fields)

* Report special fields (such as page numbers, print date, and record number)

You can also group reporting elements in a report template. For example, you can
group a set of labels and data fields and repeat it multiple times in a generated
report. If you want your report to display details about tasks, for example, you can
create a group that will be repeated once for each task that is selected for inclusion
in the generated report.

Report Designer also provides many options for you to customize the appearance
of elements that you add to the report template. When you select an element in the
report template, the Attributes view displays the editable properties for that
element. You can align, size, and space multiple elements at the same time,
enabling you to create polished, professional-looking reports.

Why do | need a report template?
A report template is an efficient way to create multiple reports that contain the
specific information that you want to display. For example, if every report that you

create requires your company name, address, and the date that the report was
generated, you want to be able to include that information on each report
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automatically, rather than adding it to each individual report that you generate. A
report template enables you to define your required information once, and then
generate it as many times as you want.

Templates are especially important when you are ready to generate more complex
business reports. Although it can take some time to create and polish a template’s
design, the effort invested in building a template will give you the flexibility to
generate any number of reports, either from the original template or by making a
copy or copies and adding more specific details.

Before you begin

Before beginning this tutorial, you must import the sample ABC Project into your
workspace. See the help documentation for instructions. You should also be
familiar with the basic functions of WebSphere Business Modeler, such as creating
catalogs, opening views, and adding elements from an editor’s palette to a viewing
area.

This tutorial should take no longer than 30 minutes to complete.

Setting Report Designer preferences

Report Designer preferences enable you to control the style features of your new
report template.

The preferences for your report templates are similar to the preferences that you
can set in most word processing programs. You can update such features as fonts,
margins, and page orientation. For this tutorial, you need only update the
preferences for fonts and margins, but you can set any other preferences that you
choose in order to get familiar with your options.

To set preferences for the Report Designer, complete the following steps:
1. If you have not already done so, load the available fonts from your system:

a. On the menu bar, click Window > Preferences . The Preferences window
opens.

b. In the tree, click Business Modeling » Report Designer > Fonts. The fonts
preferences are displayed.

c. Click Add. The Fonts Folder window opens. In the window, browse to the
folder on your machine that contains the fonts (such as
CAWINDOWS\Fonts or C:\WINNT\Fonts). Click OK. The fonts in the
folder are displayed in the Available Fonts list.

d. Select the font that you want to use as the default font and the fonts you
want to use in custom reports and then click the arrow to moves the fonts
to the Installed Fonts list. For this tutorial, select the Lucida Sans Unicode
font to move it to the Installed Fonts list.

2. Select a default font for your report template:

a. In the list of fonts, select the Lucida Sans Unicode font, then click the arrow
above the Installed Fonts list to move it into the Default Font field.

3. Set the measurement unit for your report template:
a. In the tree, click Report Designer » General.
b. In the Measurement Units field, select Inches, and then click Apply.

4. Set the page size and margins for your report template:
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a. In the tree, click Report Designer » Page Setup. The Page Setup window
opens.

b. In the Paper Size list, select Letter.

c. Set each of the margins to 1 inch.

d. Click OK to save your changes.

Now that you have set your Report Designer preferences, you are ready to create a
report template.

Creating a report template

You can choose to create a report template either with or without a data source to
supply the report’s fields and attributes. Your first goal is to create a generic
"skeleton” template that you can use as the basis for other report templates. Later
in this tutorial you will use a data source to provide specific fields but for this
exercise, you will create a report template with no data source.

To create a new report template, complete the following steps:

1.

w

6.
7.

If you have not already done so, create a new catalog to hold your report
templates:

a.

In the Project Tree, right click the Reports node and then click New -
Report Catalog.

In the New Report Catalog window, enter a name for your new catalog. In
this tutorial, we will use My Templates as the catalog name.

When you have entered a catalog name, click Finish to create the new
catalog.

Right-click the My Templates report catalog and select New » Report Template.

In the Name of new report template field, type Generic Report Template.

Type a description of your report template: Generic template information for
other report templates. Click Next.

For now, leave No Data Source selected in the Data Source tree. Later in the
tutorial you will use a data source to create a report template.

Select WebSphere Modeler as the report designer.

Click Finish. The report template is created and is displayed in the Project Tree.

Now that you have created a report template, you can add fields and define the
information that you want to include in your reports.
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4 Creating Report Templates



Building a generic report template

After you have created your report template, you can begin to populate it with
various report elements. At this stage, it is a good practice to add the elements that
you know you will want to display in every report that you generate. For example,
regardless of what type of report you are generating, you will most likely want to
include a title, page numbers, headers and footers, and a table of contents. By
building a generic report template now, you will have a "skeleton” that you can
copy repeatedly when you want to create more specific templates.

Adding text fields

Fields enable you to specify the information and data that you want to include in
your template. You can add static text that will appear on each report, or you can
add fields that will be updated when each report is generated. At this point in the
tutorial, you are building a generic report template to act as the basis for a more
specific template. First, you will add some static text fields that will be included in
any report that you generate using the template.

To add static text fields, complete the following steps:
1. Click the Create a new static text button on the Report Designer palette.

2. Position the cursor on the report template at the position where you want the
text label to begin and click to add the static text field.

3. Double-click the empty text label and then type the following: ABC Co. Ltd..
Use the text box handles to resize the box as necessary. Note: You can also edit
the text of the text label in the Attributes view.

4. In the Attributes view, change the font size to 16 point. To increase the size of
the text box so that you can see the full text that you have entered, click and
drag the text box handles as required.

5. Using the same method, add another text box immediately below the one you
just added and type the following text: Process Report:. In the Attributes view,
change the point size to 24.

Your report template should look like the one in the following image:
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BEC Co. Lid.

Process Report:

6. Click File » Save to save the report template.
The two text strings that you have added to the report, "ABC Co. Ltd.” and
"Process Report:”, will appear on every report that you generate using this

template, and every copy of the template that you make.

Next, you will learn to use the layout guidelines to align your text.

Aligning elements using guidelines

Report Designer enables you to align different fields in your template by using
guidelines.

The two text fields that you just added to the report template title page are
probably not perfectly aligned, and this misalignment might give your reports an
unpolished look and feel. You could use the Attributes view to ensure that all your
fields are aligned, but that method is not always efficient, especially if you have a
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large number of fields that you want to align. Report Designer provides guidelines
that enable you to quickly align your fields (plus a number of convenient
alignment options that you will use later in the tutorial).

To align the two text fields, complete the following steps:

1. Click a position on the horizontal ruler to add a new guideline. A guideline
marker appears in the ruler. From this marker, a dashed line crosses the report
template. To change the position of a guideline you have added, drag the
guideline marker to the position on the ruler where you want it to appear.

2. Click the report title text box and drag it so that the left side of the text box is
close to the dashed line extending from the guideline. When the text box
approaches the guideline, the guideline changes from a dashed line to a solid
red line, indicating that the text box will snap to position on the line. Drop the
text box at the guideline.

3. Click the company name text box and drag it to the guideline. When the
guideline changes from a dashed line to a solid red line, drop the text box.

4. Move your cursor back to the guideline in the horizontal ruler. Click and drag
the guideline slightly to the left and drop it. Notice that the two text boxes
move with the guideline when you drag it to a new position.

5. Click File » Save to save the report template.

Guidelines are extremely useful when you are trying to align a large number of
report elements on one or more pages. You can remove a guideline at any time by
clicking it and dragging it off the ruler.

Adding tables

A table in a report enables you to group text and data in any required
configuration. Just as in a spreadsheet or word processing document, tables in
reports help you to organize your information to improve the presentation of your
data. Table cells can include static text, parameter fields, or data fields. In this
exercise you will create a table and add static text to specific cells.

To add a table to your report catalog, complete the following steps:
1. Click the Create a new table button on the Report Designer palette.

2. Move your cursor to the lower right corner of your template and click to add
the table.

3. In the Create Table window, update the values so that your table has two
columns and three rows. Click OK.

4. Double-click the top cell in the left column of the table and type: Department. In
the Attributes view, select the Bold check box in the Fonts section.

5. Repeat the preceding step for the remaining cells in the first column, typing the
following:

* Process Name
e Process Owner

6. In the Attributes view, update the formatting of each text cell by clicking on the
Alignment tab and changing the vertical alignment to Middle. Remember that
you can resize the table by first selecting it and then clicking and dragging any
or the handles. Your table should now look like the one in the following image:
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AEC Co. Ltd.

)

:Prucess Report:

Cspartivmnt

Frocass Hanm

Frocass Ownar

7. Click File » Save to save your report template.

You have added a table to your report template and populated several cells with
static text. Next, you will learn how to add parameter fields to the remaining table
cells.

Adding parameter fields

Parameter fields enable you to display a value that you specify or that the user
will be prompted to supply when generating the report. You have already added
static text to the left column of your table. Now, you will add parameter fields to
the right side so that whoever generates a report using the template will be
prompted to enter values specific to that report.

To add parameter fields, you will need to use the Fields view.
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. Right-click on the report template and select Show > Fields View. The Fields

view opens. Expand the Report Fields node.

Right-click the Parameter Fields node and select New » Parameter Field. The

Create Parameter Field window opens.

3. Type the following values:

Option Description

Name Department

Description The department responsible for this report
Default Value Sales and Marketing

4. Leave the Prompt before generation check box selected. By leaving this check

box selected, you are indicating that the user will be prompted to supply
values each time a report is generated.

Click OK. The new Department parameter field is added to the tree in the
Fields view.

Click and drag the new Department parameter field from the Fields view to the

top cell in the right column of the table, opposite the "Department” static text

label.

Now, you need to repeat these steps to add parameter fields for the Process

Name and Process Owner:

a. Right-click the Parameter Fields node and select New » Parameter Field.

The Create Parameter Field window opens.

b. Type Process Name as the name of the parameter field, and then type a
description: The name of the process for which this report is being
generated. Leave the default value blank.

c. Ensure that the Prompt before generation check box is selected, and then
click OK. The Process Name parameter field is added to the Fields view.

d. Click and drag the Process Name parameter field to the table cell in the
right column opposite the static text "Process Name".

e. Repeat these steps to create a Process Owner parameter field. Your table

should now resemble the one in the following image:

Building a generic report template
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AEC Co. Ltd.

a

Process Report:

Department Department

Process Mame |Process Mame

Process Owner |Process Owher

8. When you have added parameter fields to each of the cells in the right column
of the table, click File » Save to save your report template.

Now that you have added parameter fields, you can generate your report to see
how the parameters receive values.

Generating a report

To this point, you have set up your title page and added a table with static text
fields and parameter fields. To understand how parameter fields work, you can try
generating your report. Obviously, you will not have any data to include in your
report yet, but it is a good practice to frequently generate reports as you build
your template; by generating your report periodically, you will be able to ensure
that each reporting element you add is providing the intended result.

To generate a report using your new report template, complete the following steps:
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1. Right-click in the report template and select Generate. The Parameter Values
window opens.

2. Enter values for the parameter fields that you previously added to your report
template:

a. In the Parameter Fields list, ensure that Department is selected and that the
Parameter Field Value is Sales and Marketing. This is the default value that
you added when you created the parameter field.

b. In the Parameter Fields list, select Process Name, and in the Parameter Field
Value field type Customer Order Handling.

c. In the Parameter Fields list, select Process Owner, and in the Parameter
Field Value field type your own name.

d. Click OK to generate the report. (Note that the report might take a few
moments to display.) Your report should now look like the one in the
following image:

ARC Co. Ltd.

Process Report:

Department Sales and Marketing
FProcess Mame Customer Order Handling
Frocess Cwner John Smith

You might have to resize your table and generate again to get the results that you
want. Make any size, alignment, or text adjustments necessary to produce a report
that is presented the way you intend. You can bold the static text to make your
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labels stand out from the values, you can increase the point size of the text, or you
can move the table to the other side of the page. You should get used to generating
reports continually until you have the design that meets your standards.

Now you are ready to add pages and determine the content of your report
template.

Adding new pages

You can add new pages when you want to change formatting options for a
particular page, or add different page headers and footers. You have already
created a title page for your report template; however, the formatting for the title
page will not be repeated in the following pages of the report. You need to add a
new page to the report template, after which you can set the formatting, headers
and footers, and appropriate fields.

To add a new page to the report template, complete the following steps:

1. In the palette, click the Create a new page D button. Move your cursor to
the lower margin of the title page and click. (Alternatively, you can right-click
on the margin of the title page and select New » Page Below.) A new page is
added below the page you had selected.

2. Click File » Save to save the template.

Now that you have added a new page, you can create a header and footer for the
page.

Adding headers and footers

Headers and footers enable you to include fields at the top and bottom of your
report template pages, so that the same information will be appear on your
generated report pages. For example, you can use the header and footer to display
the appropriate department name at the top of your report pages.

You must add a new header and footer to each template page that you create. If
you do not add headers and footers to subsequent template pages, any report data
generated from those pages will not contain your header and footer information.

To add a header and footer to your new page, complete the following steps:

1. Right-click in the margin of the page that you just added, and select New -
Page Header. Note that you have to click near the top margin of your page to
see the new header box that has been added to the page.

2. Right-click in the margin again and select New > Page Footer. As with the
header, if you click the page near the bottom margin, you will see the footer
box that you just added.

Now that you have set up your header and footer, you can add the information
fields that will appear in your generated reports.
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Adding information fields

Report information fields are predefined fields you can add to a report template
that contain information on the report itself. These fields can provide useful
information such as page numbers, the date that the report was printed, or the
time the report was last modified.

For this tutorial, you will add one information field each to the header and footer.
In the header, you will add a field to provide the date that the report is generated.
In the footer, you will add a page number field. (Note that you can add
information fields anywhere in your report template, not just in the header and
footer.)

To add information fields, complete the following steps:

1.
2.

In the Fields view, expand the Special Fields node.

Click the Print Date field and drag it to the header section of the template
page. Drop the field on the right side of the header. When you generate a
report, this field will display the current date.

In the Fields view, click the Page Number field and then drag and drop it in
the footer section.

Align the Page Number field:

a. Right-click in the Page Number field that you just added to the template
and select Format » Center » Center Horizontally. This selection will center
the field on the template page.

b. Right-click in the Page Number field again and select Format » Text
Horizontal Alignment » Center. This selection will center the text within
the field.

Click File » Save to save the template.

Right-click in the template and click Generate. (Note that you have the option
of leaving your parameters empty if you are simply checking the result of the
new information fields.) The second page of the report should look like the one
in the following image:
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Sunday, June 11, 2008

Page 2

Remember that you can resize the fields that you have added to the template page.
For example, if the date in the header is breaking to two lines, you can make the
Print Date field longer horizontally to keep the generated information on a single
line.

Adding a table of contents

A table of contents can help you quickly find information in your generated
reports, especially if those reports are lengthy. Because you are still setting up the
generic information that will be used in all subsequent report templates that you
create, a table of contents is a useful page to add at this point. Later, when you
copy this generic template and create a more specific template, the table of
contents will be automatically generated.

To add a table of contents to your Generic Report Template, complete the
following steps:

1. Right-click in the margin of the title page and select New » Page Below. A new
blank page is added below the title page.
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2. Click the new page to select it. In the Attributes view, select the Table of
Contents Page check box.

3. Click File » Save to save the template.

You will notice that the table of contents page that you just added is blank, and
you may be tempted to add fields to it. However, you must not add any further
content to the table of contents page. The table of contents will be generated
dynamically when you generate a report using your report template; any
additional fields that you add to this page will be ignored.

Building a generic report template
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Building a specific report template

At this point, your report template contains generic information which can be
applied to all your reports. You could proceed to add data fields to this template;
however, if you make a copy of the template as it now stands and then add
specific data fields to the copy, you can save this "skeleton” to use when you want
to create more templates. This practice can save you set-up and design time,
especially if you want to create a large number of report templates that contain the
same generic fields.

Copying report templates

The first step in creating a more specific report template is to copy and rename the
Generic Report Template that you have just built.

To make a copy of the report template that you have created, complete the
following steps:

1. In the Project Tree, right-click the Generic Report Template and select Copy.

2. Right-click the My Templates catalog and select Paste. A copy of the Generic
Report Template is added to the catalog.

3. Right-click the copy of the template and select Rename.

4. Type the following name for the new copy: Task Summary. Press Enter on your
keyboard to rename the report template.

5. Double-click the Task Summary report template to open it in the Report
Designer editor.

6. Add a new static text field to the title page:
a. Click the Create a new static text button on the Report Designer palette.

b. Position the cursor on the title page immediately below the Process Report:
static text field and click to add a new static text field. Remember that you
can use the template guidelines to properly align your template fields.

c. Double-click the empty text label and then type the following: Task
Summary. Use the text box handles to resize the box as necessary. Note: You
can also edit the text of the text label in the Attributes view.

d. In the Attributes view, change the font size to 18 point.

7. Click File » Save to save the report template. Your title page should now look
like the one in the following image:
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REC Co. Led,

L a

Process Report:

Task summary

L -

Department Department
Process Name Process Narme
Process Owner Frocess Cwher

You can keep the original Generic Report Template and use it to create as many
copies as you require. Each copy that you make will inherit all of the fields that
you have added to the original, so you will not have to start from the beginning
each time.

Now you can add a data source to your new Task Summary report template.

Adding a data source

Data sources are predefined sets of fields that you can use to derive information
from the elements of your project. You can use data sources as the basis for
defining all of your report templates.

When you first created your generic report template, you did not use a data
source. Now that you have made a copy of your generic template and want to
populate it with specific information, you will need to add a data source to supply
the appropriate data fields. The key to choosing the right data source for your
report template is in considering what information you want your reports to
provide. For example, if you are creating reports only on the resources in your
model, you might choose the Resource Specification Data Source. For this tutorial,
you will need to add fields to provide information at a high level, plus information
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on both global and local elements. For this reason, you will add the Process
Specification data source. The Process Specification data source contains a broad
range of data pertaining to the process as a whole, as well as to specific component
elements of the process, such as global and local tasks.

To add a data source to your Task Summary report template, complete the

following steps:

1. In the Fields view, right-click the Data Fields folder and click New » Data
Fields. A window opens.

2. In the Data Source Selection window, click Business Model » Process

Specification Data Source, and then click OK. The Process Specification data
fields are added to the Fields view.

You can now use any of the Process Specification data fields in your report
template.

Adding data fields

Data fields provide specific information about your model elements. You can add
any available data field from the chosen data source to your report template.

You are going to use the Task Summary report template to generate reports about
a process’s tasks. To do so, you will add a number of data fields to supply that
specific information.

You can add data fields to a report template in any order that makes sense to you.
In this tutorial, you will add the elements in the order that they will appear in
your completed report, but you can revise a template by changing the order of
fields, inserting pages, or adding diagrams. There is no single correct sequence to
adding elements to your template. Remember it is a good practice to generate
reports regularly as you build your template so that you can see the results of
what you have added.

Important: Ensure that you add your data fields to the page following the table of
contents page. If you add them to the table of contents, they will not appear in
generated reports.

To add data fields to your Global Task Summary report template, complete the
following steps:

1. Add a heading for your data fields:

a. Ensure that you are working on a blank content page in your template and
not the table of contents page. Click the Create a new static text button on
the Report Designer palette.

b. Position the cursor the towards the left margin of the page and click to add
the static text field.

c. Double-click the empty text label and then type the following: Global
Tasks. Use the text box handles to resize the box as necessary. Note: You can
also edit the text of the text label in the Attributes view.

d. Ensure that the static text field is still selected. In the Attributes view, select
the Use as Heading check box on the General tab and update the heading
level to 1. By making this static text field a heading, you are ensuring that it
will be listed in the table of contents.
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e.

On the Padding tab, update the left padding to 0.2 inches. On the Colors
tab, add a text background color of light blue. Tip: You can adjust the
formatting in any other way that you would like. Adding formatting to
your headings can help them stand out in a lengthy report.

2. Add the global task name:

a.

b.

In the Fields view, expand the data source: Data Fields > Model ~» Process
Model » Tasks » Task » name.

Click and drag the name node to the template page and drop it below the
Global Tasks heading. This data field will hold the name of the global tasks
in the process that you specify when you generate the report. The Data
Field Path, which is displayed in the Attributes view, indicates the location
in your process model where the data for this field is located. If you
generate your report now for the sample ABC Project’s Customer Order
Handling process, the page will display the Global Tasks heading and the
name of the first global task in the process, Input Customer Order.

Ensure that the data field is still selected. In the Attributes view, select the
Use as Heading check box and update the heading level to 2. Refer to step
1, above, if you need instructions on how to specify the static text field as a
heading.

3. Add an Inputs table:

a.

Add a new static text field below the data field that you just added. Type
Inputs: as the field text.

Right-click in the template page and select New = Table. Specify 2 rows and
2 columns for the table, and then position it immediately below the Inputs
text field.

In the top left cell of the table, add a static text field and type Name. In the
top right cell of the table, add a static text field and type Associated Data.
These two static text fields will act as headings for your table columns.

In the Attributes view, update the horizontal alignment of the two text
fields to Center.

In the Fields view, expand the data source: Data Fields > Model ~» Process
Model > Tasks » Task > Inputs » Input » name. Click and drag this node to
the bottom left cell of the table.

In the Fields view, expand the data source: Data Fields > Model > Process

Model - Tasks » Task » Inputs » Input » associatedData. Click and drag
this node to the bottom right cell of the table.

4. Repeat step 3 above, but this time create an Outputs table. Add a static text
field heading, create the table with column headings, and add the name and
associatedData data fields for the global task outputs. Your template page
should look similar to the one in the following image:
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:Outputs: :
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5. Click File » Save to save the report template.
6. Right-click on the template and select Generate.

7. Enter the required parameter values, and select Customer Order Handling as
the process on which to generate the report. Click OK. Your report is generated
and displayed.

Your generated report should contain a title page, a table of contents, and content

generated from the static text and data fields that you have added. The generated
content should look like the following image:
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Tuesday, June 13, 2006

Global Tasks

Input Customer Information

Inputs:
Mame Associated Data
Input Order Eequest
Cutputs:
Marme Associated Data
Cutput Custo mer Fecord

Notice that data was generated for only one global task. However, the Customer
Order Handling process contains a total of three global tasks (including one
contained within the Order Verification global process). To enable your report
template to generate data for all of the global tasks in a specified process, you need
to add your data fields to a group.

Adding a group

A group contains information on a modeling artifact whose type you specify when
you set up the group. It enables you to repeat the same information for as many
instances of the artifact that appear in your model. For example, if you create a
group that displays details about a resource, the generated report will contain
resource information for each reported resource.

In this tutorial, you have already added data fields which provide information
about global tasks in a specified process. However, those data fields will only
provide data for a single global task. You will now create a group, which will
enable you to generate information on all global tasks.

To create a new group to contain the data fields, complete the following steps:

1. In the palette, click the Create a new group E:' button.

2. In the report template, click and drag the group box so that it contains the task
name data field and the input and output tables. Be careful not to include the
Global Tasks static text field in the group box, or that text will repeat when you
generate your report.

3. In the Attributes view, click the ... button next to Grouped By Field, select
Model » Process Model » Tasks » Task, and then click OK. This node is the
immediate parent of the global task data records that you want to show in the

group
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4. Click File » Save to save the report template.

5. Right-click the report template and select Generate. Add the appropriate
parameters, select the Customer Order Handling process, and then click OK.

Notice that your report now shows information for three separate global tasks.
(Remember that there is a global task in Order Verification, one of the global
processes used in Customer Order Handling.) Note, too, that each of the global
task names appears in the table of contents—any static text field or data field that
you list as a heading will appear in the table of contents.

Adding a group to a table

A table is, in effect, a self-contained group. However, you need to specify the field
that the table is grouped by before it will display multiple instances of a particular
element.

In this tutorial, you have added tables to display task inputs and outputs. You will
now specify the fields that these tables must be grouped by in order to show
multiple inputs or outputs for any task that has more than one.

To group a table by a field, complete the following steps:

1. In the report template, click the Inputs table to select it. Tip: You can select the
table by clicking on its outside border. The shape of the cursor will show you
whether you are selecting the full table, a row, or a column.

2. In the Attributes view, click the ellipsis ... button next to the Grouped by Field
field.

3. Expand the data source to the following node: Model » Process Model > Tasks
> Task » Inputs » Input. Select the node and then click OK. The field and path
are added to the Attributes view.

4. Repeat these steps for the Outputs table, only this time select Model » Process
Model > Tasks » Task » Outputs > Output as the field to group by.

5. Click File » Save to save the template.

If you generate your report again at this point, you will not notice any difference
in the two tables because none of the global tasks contained within Customer
Order Handling has multiple inputs or outputs. However, if you were to add
inputs or outputs to any of the global tasks, or if you generated a report for a
process that contained global tasks with multiple inputs or outputs, your template
would enable you to display information for those multiple elements. Later in this
tutorial, you will complete an exercise that will demonstrate the results of
grouping a table by a particular field.

Adding a summary field

Summary fields enable you to display values calculated for any type of item in a
generated report. You can perform different calculations on a particular data
element, such as count, sum, or average, depending on the data element you
choose. For example, you can count the number of tasks in a process, or display
the average start-up cost per task.

You have already displayed details for global tasks in your report template. Now

you are going to add a summary field that will display the total number of global
tasks in your specified process.
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To add a summary field to the report template, complete the following steps:
1. Add a text label for the summary field:
a. Add a new static text field immediately below the group that you created,

and type Total number of global tasks:. Be careful not to include the field
within the group, or the text will be repeated in any generated report.

b. In the Attributes view, select the Use as Heading check box and set the
heading level to 2. The text field will be added to the table of contents.

2. In the palette, click the Create a new summary field ﬁi‘ button.

3. DPosition the cursor on the report template to the right of the static text field
that you added, and drop the field on the template page. The Create Summary
Statistics window opens.

4. Click the ellipsis button next to the Summary Field field. The Data Field
Selection window opens.

5. Select Data Fields > Model » Process Model » Tasks ~» Task, and then click
OK.

6. Leave the Summary Type field as the default Count, and then click OK. The
summary field is added to the report template.

7. Use guidelines to align the static text and summary fields. The template page
should now look like the one in the following image:
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E :Outputs: )
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fl'l:ntal Mumber of Global Tasks: : E:ount(,-fMDdEI,u"PrDcESS...

8. Generate the report with your parameters, using Customer Order Handling as
the specified process.

The key to using a summary field is in specifying the correct node in the data
source on which to perform your calculations. By selecting the Task node within
the Process Model, you specified that the summary field would show information
for global tasks that exist independently and can be used in any number of
processes. If, for example, you specify the Model > Process Model » Processes -
Process » Flow Content » Task node as your summary field, you will receive a
count of the local tasks within the Customer Order Handling process.
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Adding a page break

Page breaks enable you to specify that particular elements and sections in your
reports will begin on a new page.

To this point, you have added several fields to your template. Depending on the
process, the reports you generate with the template might be many pages long.
However, the template content itself is less than one page long. If you want to add
more fields to your template, but you want the resulting data to appear on a new
page in the generated report, you can add a page break to the template before
adding the additional fields.

In this exercise, you will first add a page break to your template page, and then
add elements to provide information on local tasks after the break. These template
elements will be the same as the ones that you have already added for global
tasks, but will use data fields from a different node in the data source.

To add a page break and additional fields to your report template, complete the
following steps:

1. In the palette, click the Create a new page break LI button.

2. In the template page, click immediately below the Total Number of Global
Tasks field and associated summary field to add a page break. Any fields that
you add below the page break will start on a new page when you generate a
report.

3. Add elements to the new section of the template page to provide information
about local tasks. To locate the fields you will need, go to the Fields view and
expand the data source: Model » Process Model > Processes > Process » Flow
Content ~» Task. The Flow Content node contains information on elements that
are used only in the specific process flow, as opposed to global elements that
can be used in multiple processes. Refer back to previous exercises if you need
help adding any of the template elements.

a. Add a static text field and type Local Tasks. Specify it as heading level 1,
and add the same background color as the Global Tasks heading.

b. Add a data field to contain the name of the local task.

C. Add tables to contain information on task inputs and outputs. Use the same
column headings and data fields as you used for the Global Tasks section,
ensuring that you use the data fields from the Model » Process Model »
Processes » Process » Flow Content » Task node.

d. Create a group to contain the local task name and both the Inputs and
Outputs tables. Remember to update the Grouped by Field in the
Attributes view with the appropriate field, in this case Model » Process
Model » Processes > Process » Flow Content > Task.

e. Click on the Inputs table to select it, and in the Attributes view update the
Grouped by Field field with the appropriate data source node, Model »
Process Model » Processes » Process » Flow Content » Task » Inputs -
Input.

Repeat the step above for the Outputs table.

g. Add a Total Number of Local Tasks static text field, and then add a

summary field to contain the data. Remember to leave the summary field
function as the default Count.

—n

4. Click File » Save to save the template.
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5. Right-click and select Generate to generate a report for the Customer Order
Handling process.

Note that the Local Tasks section begins on a new page in the generated report.
Page breaks enable you to display data on a new page in your reports without
having to add new template pages and headers and footers.

You should notice that there are several local tasks that contain multiple inputs
and outputs. They are displayed in your report because you updated the Grouped
by Field field for each table.

You may also notice that the alignment and layout of your fields contain slight
inconsistencies between the Global Tasks and Local Tasks sections. In the next
exercise, you will fine-tune the layout of the elements in your template.

Finalizing the template layout

Report Designer provides several tools to help you polish and finalize that layout
of your template.

When you have added a large number of elements to your template, the generated
reports can contain slightly misaligned headings and data that detract from the
overall presentation of your information. Even if you have been using guidelines to
align your fields, subtle differences in alignment, field size, and spacing can creep
into your template. There are a number of tools in Report Designer that you can
use to select and adjust multiple template elements, and in so doing polish the
look and feel of your generated reports.

In this tutorial, you have added two sections that display the same information
about two different types of tasks. You want the presentation of similar elements in
these sections to be uniform.

To finalize the layout of your template, complete the following steps:
1. Click the Global Tasks static text field to select it.

2. Press the Ctrl button on your keyboard and click the Local Tasks static text
field. Both text fields should now be selected.

3. Ensure that your cursor is hovering on one of the selected fields, and then
right-click and select Format » Size » Same Height/Width. The two fields are
adjusted to exactly the same height and width.

4. In the Local Tasks section, click the Inputs text field.

5. Press the Ctrl button on your keyboard and click the Inputs table, the Outputs
text field, and the Outputs table.

6. Ensure that your cursor is hovering on one of the selected fields, and then
right-click and select Format » Vertical Spacing » Equal. The spaces between
the selected elements are automatically made equal.

7. Click the Total Number of Global Tasks static text field to select it.

8. Press the Ctrl button on your keyboard and click the Total Number of Local
Tasks static text field. Both text fields should now be selected.

9. Ensure that your cursor is hovering on one of the selected fields, and then
right-click and select Format » Font Style » Italic. Both fields now display
italicized text. (Note that if you italicize or bold a field that has been
designated as a heading, that formatting will also appear in the table of
contents.)
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10. Click File » Save to save the template.
11. Right-click and select Generate to generate your report.

There are numerous alignment and spacing options available in Report Designer.
You should continue to experiment with the different options available to you in
the right-click pop-up menu. Using the available options, adjust the alignment,
size, and spacing of your template elements until you are satisfied with the look
and feel of your generated reports. As you have done throughout this tutorial,
remember to generate reports frequently so you can determine if your adjustments
are providing the results that you intend.

Adding a process diagram

You can include a process diagram in your report template. Any report that you
generate using the template will contain a diagram of the process for which you
are generating data.

You can choose how you want to display the diagram. Normally, you will include
it on a separate page in a report so that you can keep the diagram as large as
possible. However, you can experiment with layout and diagram size to determine
what works best for you. In this tutorial, you will add a new page to contain your
diagram.

To add a process diagram to your report template, complete the following steps:

1. In the palette, click the Create a new page D button. Move your cursor to
the lower margin of the final template page and click. (Alternatively, you can
right-click on the margin of the title page and select New > Page Below.) A
new page is added below the existing template pages.

2. Click the new page to select it. In the Attributes view on the Orientation tab,
select the Landscape radio button. This layout will give you a larger horizontal
area in which to position your diagram.

3. Add a header and footer to the page containing the same information fields
that you used earlier in the tutorial. Tip: Refer to the previous exercises on
adding headers and footers and adding information fields if you need
instructions.

4. Add a heading for the diagram:

a. Add a static text field near the top left of the page and type Process
Diagram.

b. In the Attributes view, select the Use as Heading check box, and specify the
heading level as 1.

5. In the Fields view, expand the Data Fields folder and go to the following node:
Model » Process Model » Processes > Process » Diagram » Pages » Img Src.

6. Click the Img Src node and drag it to a point on the template page below the
Process Diagram text field. A placeholder image is added to the template.

7. Click File » Save to save the template.
8. Generate a report for the Customer Order Handling process.

When you generate the report, you should see the Customer Order Handling
process on the final page, resembling the following image:
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Thursday, lune 15, 2008

Frocess Diagram

Note that the page has a landscape layout, as you specified. You may need to
adjust the alignment of the diagram compared with the heading, or you might
need to make the diagram smaller in order to have it and the heading fit on the
same page. As with the layout of other fields, you might need to generate the
report several times before you are happy with how your reports are displayed.

This is the final exercise of this tutorial.

Summary

In this tutorial, you have learned the basic process of creating and designing a
report template using Report Designer. The methods that you have learned can be
applied to any report templates that you create. You should always plan the design
of your template before you get started adding elements, as this preparation will
save you time later on. If you will be creating several templates, start with a
generic "skeleton” template that contains general information fields. When you are
comfortable with the look and feel of this skeleton framework, copy that generic
template to make your more specific templates.

By completing the exercises in the tutorial, you have learned how to add and use
many Report Designer elements. You should continue to experiment with your
own templates, adding and manipulating the following:

* Pages and page breaks

* Page headers and footers
* Tables

* Static text fields

* Data fields

* Table of contents

* Summary statistics fields (such as counts, sums, and averages for selected data
fields)

* Report special fields (such as page numbers, print date, and record number)
* Groups

Remember that effective report template design also means generating your report
many times over to examine your results and make adjustments. It is a good
practice to generate your reports after adding just a few elements; again, it will
save you time by letting you see your progress and make corrections before any
errors or design flaws propagate through the template. By using all the Report
Designer tools and functions available, you can create accurate, informative, and
professional reports.
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Notices and Trademarks

Notices

This information was developed for products and services offered in the U.S.A.
IBM may not offer the products, services, or features discussed in this
documentation in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or imply
that only that IBM product, program, or service may be used. Any functionally
equivalent product, program, or service that does not infringe any IBM intellectual
property right may be used instead. However, it is the user’s responsibility to
evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this documentation. The furnishing of this documentation does not
grant you any license to these patents. You can send license inquiries, in writing,
to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

Lab Director

IBM RTP Laboratory
3039 Cornwallis Road
P.O. BOX 12195
Raleigh, NC 27709-2195
US.A

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs.
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Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

(C) (your company name) (year). Portions of this code are derived from IBM
Corp. Sample Programs. (C) Copyright IBM Corp. 20004, 2006. All rights
reserved.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States or other countries, or both:

IBM

IBM (logo)
AIX
ClearCase
Cloudscape
Cube Views
DB2

DB2 Universal Database
FlowMark
Notes
Rational
Redbooks
ViaVoice
WebSphere
XDE

Microsoft, Windows, Windows XP, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

Intel, Intel Inside (logos), and Pentium are trademarks or registered trademarks of
Intel Corporation in the United States, other countries, or both.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Linux is a trademark of Linus Torvalds in the United States, other countries, or
both.

Other company, product, or service names may be trademarks or service marks of
others.
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