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Installation guide

This document describes how to install and configure components of the Item
Synchronization for Suppliers solution. In order to implement the solution, you
will need to refer to and be familiar with the following core documents:

* System Installation Guide for Windows®

* System Installation Guide for UNIX®

* System Administration Guide

+ Technical Introduction to IBM® WebSphere® InterChange Server
* Implementation Guide for WebSphere InterChange Server

Deployment of the Item Synchronization for Suppliers solution involves a series of
product installations and configurations. Several elements are common to all
engagements; other elements depend on your individual topology, set of installed
enterprise applications, and on the marketplaces in which you participate.

Obtaining solution components

Before following the installation procedure, obtain the IBM WebSphere Business
Integration Collaboration for UCCnet® Item Synchronization by downloading it
from Passport Advantage (www.lotus.com /passportadvantage)). Refer to Passport
Advantage for downloading instructions.

Solution components

The following tables list the components used to develop the Item Synchronization
for Suppliers solution. Note that there are many other existing components that
can be utilized in your customized solution.

Table 1. Collaboration templates

Name

Location

UCCnet_ItemSync

BIA_Retail _CT_ItemSync.jar repository file

UCCnet_requestWorklist

BIA_Retail CT_ItemSync.jar repository file

UCCnet_processWorklist

BIA_Retail _CT_ItemSync.jar repository file

Notify_by_eMail

BIA_Retail CT_ItemSync.jar repository file

ItemCommandRouter

BIA_Retail _CT_ItemSync.jar repository file

CIN_CIP_Dispatcher

BIA_Retail CT_ItemSync.jar repository file

Table 2. Business objects

Name

Location

UCCnetGBO_envelope

BIA_Retail_BO_ItemSync jar repository file

UCCnetDTD_envelope

BIA_Retail_BO_ItemSync.jar repository file

UCCnetXSD_envelope

BIA_Retail_BO_ItemSync jar repository file

UCCnetTPIDTD_envelope

BIA_Retail_BO_ItemSync.jar repository file

UCCnetTPIXSD_envelope

BIA_Retail_BO_ItemSync jar repository file

UCCnet]MSDTD_envelope

BIA_Retail_BO_ItemSync.jar repository file

UCCnet]MSXSD_envelope

BIA_Retail_BO_ItemSync jar repository file
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Table 2. Business objects (continued)

Name Location

SAP4_MatlBasic BIA_Retail BO_ItemSyncSamples.jar repository file
Table 3. Maps

Name Location

CwltemBasic_to_UCCnetJ]MSDTD_envelope_documentCommand_item

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetTPIDTD_envelope_documentCommand_item

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetGBO_envelope_notifyCommand_catalogueltem

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetXSD_envelope_publicationCommand_catalogueltem

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetXSD_envelope_registerCommand_CIP_item AddChange

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnet]MSXSD_envelope_publicationCommand_catalogueltem

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetTPIXSD_envelope_publicationCommand_catalogueltem

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetTPIXSD_envelope_registerCommand_CIP_item AddChange

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetGBO_env_publicationCommand_catalogueltemPublication

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetDTD_envelope_documentCommand_item

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetDTD_envelope_publishCommand_documentIdentifier

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetJ]MSDTD_envelope_publishCommand_documentIdentifier

BIA_Retail NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetTPIDTD_envelope_publishCommand_documentIdentifier

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetXSD_envelope_registerCommand_itemAddChange

BIA_Retail NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetfMSXSD_envelope_registerCommand_itemAddChange

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnetTPIXSD_envelope_registerCommand_itemAddChange

BIA_Retail_NM_ItemSync.jar repository file

CwltemBasic_to_UCCnet]MSXSD_envelope_registerCommand_CIP_itemAddChange

BIA_Retail_NM_ItemSync.jar repository file

RouterMap_CwlItemBasic_to_UCCnetDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

RouterMap_CwlItemBasic_to_UCCnetfMSDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

RouterMap_CwlItemBasic_to_UCCnetTPIDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

RouterMap_UCCnetGBO_envelope_to_UCCnetDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

RouterMap_UCCnetGBO_envelope_to_UCCnet]MSDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

RouterMap_UCCnetGBO_envelope_to_UCCnetTPIDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetGBO_envelope_to_UCCnetDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetGBO_envelope_to_UCCnet]MSDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetGBO_envelope_to_UCCnetTPIDTD_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetGBO_envelope_to_UCCnetXSD_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetGBO_envelope_to_UCCNnet]MSXSD_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetGBO_envelope_to_UCCnetTPIXSD_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetDTD_envelope_to_UCCnetGBO_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnet]MSDTD_envelope_to_UCCnetGBO_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetTPIDTD_envelope_to_UCCnetGBO_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetXSD_envelope_to_UCCnetGBO_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnet]MSXSD_envelope_to_UCCnetGBO_envelope

BIA_Retail_NM_ItemSync.jar repository file

UCCnetTPIXSD_envelope_to_UCCnetGBO_envelope

BIA_Retail_NM_ItemSync jar repository file

UCCnetGBO_envelope_notification_to_UCCnetDTD_envelope_publishCommand

BIA_Retail_NM_ItemSync.jar repository file

UCCnetGBO_envelope_notification_to_UCCnetTPIDTD_envelope_publishCommand

BIA_Retail_NM_ItemSync jar repository file

UCCnetGBO_envelope_notification_to_UCCnet/MSDTD_envelope_publishCommand

BIA_Retail_NM_ItemSync jar repository file

CwSadltemBasic

BIA_Retail_NM_ItemSyncSamples jar repository file

Sa4CwltemBasic

BIA_Retail_NM_ItemSyncSamples jar repository file

Table 4. Relationships

Name Location
GTIN BIA_Retail REL_ItemSync.jar repository file
LiUT BIA_Retail _REL_ItemSync.jar repository file
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Table 4. Relationships (continued)

Name Location

PrTyNT BIA_Retail REL_ItemSync.jar repository file
SiuT BIA_Retail _REL_ItemSync.jar repository file
TPTable BIA_Retail REL_ItemSync.jar repository file
UDEX BIA_Retail _REL_ItemSync.jar repository file
UpcTyT BIA_Retail REL_ItemSync.jar repository file
VoUT BIA_Retail REL_ItemSync.jar repository file
WeUT BIA_Retail REL_ItemSync.jar repository file

Table 5. Repository files

Name

BIA_Retail_BO_ItemSync.jar

BIA_Retail_BO_ItemSyncSamples.jar

BIA_Retail CT_ItemSync jar

BIA_Retail_NM_ItemSync.jar

BIA_Retail NM_ItemSyncSamples.jar

BIA_Retail_REL_ItemSync.jar

Table 6. Database scripts for DB2®, Microsoft® SQL Server, and Oracle

Name

audit_log.sql (one copy supplied for each database type)

InitializeRelationshipTables.sql (one copy supplied for each database type)

InitializeRelationshipTablesForXSD.sql (one copy supplied for each database type)

Table 7. Library file for collaboration templates

Name

CSTAuditLogger.jar

Table 8. InterchangeSystem.UCChnet file

Name

InterchangeSystem.UCCnet

Table 9. Email sample files

Name

UCCnet_processWorklist AUTHORIZATION_RESPONSES.mail

UCCnet_processWorklist CATEGORY_ADD_CHANGE.mail

UCCnet_processWorklist_ CATEGORY_ADD_CHANGESubject.mail

UCCnet_processWorklist CATALOGUE_ITEM_CONFIRMATION.mail

UCCnet_processWorklist. DEAD_LETTER_PUB_RECEIPT.mail

UCCnet_processWorklist SIMPLE_RESPONSE.mail

UCCnet_processWorklist UNKNOWN_MESSAGES.mail

UCCnet_processWorklist UNKNOWN_RESPONSE.mail

Installation guide
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Table 9. Email sample files (continued)

Name

UCCnet_processWorklist CIN_RESPONSE.mail
UCCnet_processWorklist_CI_RESPONSE.mail
UCCnet_processWorklist_ CIP_RESPONSE.mail
UCCnet_processWorklist RCIR_QUERY_RESPONSE.mail
UCCnet_processWorklist FAILURE_RESPONSE.mail
ItemCommandRouter_DE_LIST_WITHDRAW.mail

Supported operating environments

The following operating environments are supported in this release:

* Windows 2000 (Professional, Server, or Advanced Server) with Service Pack 4
* IBM AIX® 5.2

* Solaris " 8 (2.8)

Hardware prerequisites

The Item Synchronization for Suppliers solution has the same processor, memory,
disk space, and high-availability requirements as an IBM WebSphere InterChange
Server installation, as detailed in the System Installation Guide for Windows and
System Installation Guide for UNIX. To download, expand, and install this
solution, you require 56.2 MB of free space. After the installation, you can remove
the downloaded installation files and leave only the solution on your machine. The
installed solution takes up 6.6 MB of space.

Software prerequisites

Ensure that you have installed the following prerequisites appropriately for your
platform:

* IBM WebSphere InterChange Server V4.2.2. Ensure that you select the IBM
WebSphere Business Integration Collaboration for Automotive and
Manufacturing - Item Manager during installation of IBM WebSphere
InterChange Server V4.2.2. The Item Manager collaboration contains the
ItemBasic business object, which is used by the Item Synchronization for
Suppliers solution.

Note:

The IBM WebSphere Interchange Server installer includes Retail
collaborations, but the version included may not be the latest available.
The latest version of the Item Synchronization for Suppliers collaboration
can be downloaded from Passport Advantage

(www.lotus.com /passportadvantage)). See [“Obtaining solution|
[components” on page 1|for more information. If you use the version
provided by the IBM WebSphere Interchange Server installer, make sure
that the version of documentation you use is correct for the version of the
Item Synchronization for Suppliers collaboration.
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Additionally, you must not install the IBM WebSphere Business
Integration Collaboration for Product Information Management or the
IBM WebSphere Business Integration Collaboration for UCCnet Message
Manager.

* IBM WebSphere Business Integration Toolset V4.2.2

+ IBM DB2® Universal Database™ Enterprise Server Edition V8.1.2 (Fix Pack 2)
(Oracle and Microsoft SQL Server databases are also supported)

Note: When using DB2, a C compiler must be installed on the same server on
which the InterChange Server resides so that the stored procedures can be
compiled during the relationship deployment. This is not required for
Microsoft SQL Server or Oracle databases.

* IBM WebSphere MQ V5.3.0.2 with CSD 5
* IBM WebSphere Business Integration Data Handler for XML V2.5.0

* IBM WebSphere Business Integration Adapters V2.4.0, which include the
following:

— IBM WebSphere Business Integration Adapter for e-Mail V5.2.0

— IBM WebSphere Business Integration Adapter for Java' Message Service
(JMS) V2.5.0

— IBM WebSphere Business Integration Adapter for JText V5.4.0

— IBM WebSphere Business Integration Adapter for Trading Partner Interchange
V3.4.0

— IBM WebSphere Business Integration Adapter for iSoft V1.3.0

— Any specific ERP to be used. (the sample configuration in this document uses
the IBM WebSphere Business Integration Adapter for mySAP.com, SAP R/3
V.4.x)

Installation instructions for IBM WebSphere InterChange Server, IBM WebSphere
Business Integration Toolset, and IBM WebSphere MQ, are provided in the System
Installation Guide for Windows or System Installation Guide for UNIX. Installation
instructions for IBM WebSphere Business Integration Data Handler for XML, the
database, and individual IBM WebSphere Business Integration Adapters, are
detailed in their respective installation documents.

Note: Systems supporting the UCCnet Document Type Definition (DTD) only
(such as those using IBM WebSphere Business Integration Collaborations
V4.2.x), are not upward-compatible with systems supporting both the
UCCnet Document Type Definition (DTD) and UCCnet XML Schema
Definition (XSD) (such as those based on IBM WebSphere Business
Integration Collaborations V4.2.1.1 and later).

Installing and configuring the solution

This installation guide provides step-by-step instructions for installing and
configuring the Item Synchronization for Suppliers solution. It is recommended
that you proceed through the sections in order:

1. [‘Planning the configuration” on page 6|details the set up decisions that must
be made regarding connectivity and messaging method.

2. [‘Configuring the system environment” on page 7] details how to set up the
system environment to run the Item Synchronization for Suppliers on all
supported platforms.
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3. |“Installing the components” on page 8|instructs how to load artifacts and
install them in the InterChange Server repository, ensuring that the solution
code is accessible to your system.

4. [“Creating the audit_log table” on page 9| describes how to create the audit_log
table, a relational table provided with the solution.

5. [‘Configuring the metaobjects” on page 11|instructs how to create and
configure the business objects required to properly process UCCnet messages.

6. [‘Creating and configuring the connectors” on page 16| describes how to create
and configure the connectors needed to operate the Item Synchronization for
Suppliers solution.

Note: The term "connector” used throughout refers to the runtime portion of
an IBM WebSphere Business Integration Adapter. References to specific
connectors are related to specific adapters, for example,
“EmailConnector” refers specifically to the runtime component of an
IBM WebSphere Business Integration Adapter for e-Mail.

7. |“Creating and configuring the collaboration objects” on page 43|details the
collaboration objects that must be created from the collaboration templates,
and how to set each collaboration object’s port connections and configuration
properties.

8. [“Configuring the relationships before deployment” on page 54 describes the
database configuration entries needed for each relationship.

9. [“Deploying the solution” on page 55|details how to deploy the solution.

10. [“Populating the relationships after deployment” on page 55| instructs how to
populate the relationship table with default values after system deployment.

Planning the configuration

Installation Guide

Before you install and configure the Item Synchronization for Suppliers solution,
you must determine how you will connect to UCCnet and what message format
and protocols you will use.

Connectors

The way you connect to UCCnet determines the connector that you use to
communicate with it. If you exchange messages with UCCnet using an
AS2/EDIINT interface protocol, you can use a TPIConnector, an ISoftConnector, or
you can use WebSphere Business Integration Connect in conjunction with a
JMSConnector. Use the TPI connector if you communicate with UCCnet through
Trading Partner Interchange servers. Use the IsoftConnector if you communicate
with UCCnet through an iSoft Peer-to-Peer Agent. Use the JMS connector if you
communicate with UCCnet through WebSphere Business Integration Connect. If
you exchange messages through the UCCnet Command Line Utility (CLU) or are
testing your installation, you can use either a JTextTPIConnector, a
JTextISoftConnector, or a JTextfMSConnector.

Since the actual connector you use is dependent on your set up, this
documentation uses “AS2 channel connector” as a general term for any of the
TPIConnector, iSoftConnector, JTextTPIConnector, JTextISoftConnector,
JMSConnector and JTextfMSConnector.

Messages

Messages are exchanged with UCCnet in Extensible Markup Language (XML)
documents. The XML document format and the protocol that you select for
communication with UCCnet significantly impact the way that you set up your
solution. The following options are available:



DTD message format

The format of the XML documents exchanged with UCCnet is defined by a

Document Type Definition (DTD). The DTD mode of operation has one

protocol available.

Schema message format

The format of the XML documents exchanged with UCCnet is defined by

an XML Schema Definition (XSD). The XSD mode of operation has two

command protocols available:

CIN operation
The supplier implements its own subscriber data pool.
Catalogue_Item_Notification (CIN) messages are sent from the
supplier directly to trading partners subscribed to the product
categories.

CIP operation
The supplier uses UCCnet as the subscriber data pool.
Catalogue_Item (CI) messages containing additional item
information that is not included in the UCCnet registry data are
sent from the supplier to UCCnet. Catalogue_Item_Publication
messages are then sent to UCCnet to identify the subscribers to
whom UCCnet needs to send CIN messages.

Configuring the system environment

To configure the system environment, complete the following steps. Be sure to
follow the instructions appropriate for your platform where indicated.

1. Edit the CWCLASSES path, as follows:
Windows operating systems:

Windows: Edit the <WebSphereICS_installation_dir>\bin\start_server.bat
file by appending the end of the CWCLASSES path to include the
CSIAuditLogger;jar file, as shown in the following example:

CWCLASSES=...;%CROSSWORLDS%\1ib\CSIAuditLogger.jar
UNIX operating systems:

Edit the <WebSphereICS installation_dir>/bin/CWSharedEnv.sh file and alter
the CWCLASSES path to include the CSIAuditLoggerjar file, as shown in the
following example:

CWCLASSES=${CWCLASSES} :${CROSSWORLDS}/11b/CSIAuditLogger.jar

Note: The CSIAuditLogger.jar file must be copied from the Windows system to
the UNIX system.

2. If you are running the System Manager from the WebSphere Studio Workbench
SDK, edit the <WebSphereICS_installation_dir>\bin\cwtools.cfg file by
adding the CSIAuditLogger.jar file and its appropriate path information to the
line classpath= in this file, as in the following example:

classpath=<directory location_of CSIAuditlLogger.jar_file>CSIAuditLogger.jar

3. Configure the InterChange Server with email information by doing the
following:

a. Open the System Manager.

Connect to the InterChange Server.

Right-click on the InterChange Server name and select Edit Configuration.
On the E-mail tab, select Connector mail from the E-mail send type menu.

® oo o

Close the Edit Configuration window and save it when prompted.
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Note: The EmailConnector requires that the E-mail collaboration template be
active on the server. The E-mail collaboration template is installed by
default during installation of the InterChange Server, and must always
be active, although it might not appear in any Component Library, and
does not appear in the System Manager System View window. If it is
necessary to drop the InterChange Server repository and redeploy the
Item Synchronization for Suppliers solution from the System Manager,
you must restore the E-mail collaboration template to the repository by
entering the following command:

* Windows operating systems:

repos_copy -sICS_server_name -uICS_admin_ID -pICS_admin_password \
-ai -i<ICS_installation_path>\repository\Email.jar -xcompilepackage

e UNIX operating systems:
repos_copy -sICS server_name -uICS admin_ID -pICS_admin_password \
-ai -i<ICS_installation_path>/repository/Email.jar -xcompilepackage
This command activates the E-mail collaboration template and does not
require a restart of the InterChange Server.
4. Stop the InterChange Server.

Installing the components

Installation Guide

Complete the following steps to ensure that the solution code is accessible to your
system. Be sure to follow the instructions appropriate for your platform where
indicated.

1. Start the InterChange Server in design mode (-design parameter).

2. Install the artifacts downloaded from [www.lotus.com/passportadvantage|into
the same directory in which the InterChange Server is installed by performing

the following steps (see the section [“Obtaining solution components” on page 1|
for information on how to obtain the artifacts from Passport Advantage):

a. Move the downloaded .exe file to a temporary directory.
b. Run the executable file. The following are extracted:
* media.inf
* setup.jar
* setupwin32.exe (installer executable file for Windows operating systems)
* an English readme file and translated versions of it
C. Run the executable file to install the components.

3. Verify that the CSIAuditLoggerjar file is in the Windows directory specified in
the classpath on the machine where the System Manager is installed. This
ensures that the templates can be compiled successfully in the System Manager
before deployment to the InterChange Server.

4. On UNIX systems, transfer the file

<WebSpherelICS_installation_dir>\1ib\CSIAuditLogger.jar from the Windows
system to the UNIX system by using File Transfer Protocol (FTP) in binary
mode. Place it in the <WebSphereICS_installation_dir>/1ib/ directory.

5. Import the repository files into the System Manager as follows:
a. Create a new Integration Component Library (ICL).
b. Right-click the new ICL name, and select Import Repository File.

c. Use the Browse button to navigate to where the repository .jar files are
located and select one of the files.

d. Click Open.
e. Click Finish.
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f. Repeat this process for each of the remaining repository files.

Creating the audit_log table

To create the audit_log table, complete the following steps. Be sure to follow the
instructions appropriate for your platform where indicated.

1. Create the audit_log table by running one of the following scripts, depending
on the database you are using:

* Windows operating systems:
- DB2 —

a.

Start a DB2 session by opening a DB2 command window by clicking
Start > Programs > IBMDB2 > Command Line Tools > Command
Window.

b. Move to the following directory:
<ICS_installation_path>\collaborations\dependencies\db2

C. At the prompt, enter the following command: db2 connect to
<repository_name> USER <userid> USING <password> where
<repository_name> is the name of your WebSphere InterChange Server
repository database, and <userid> and <password> are the ID and
password that were used to create it.

d. After you are connected, enter the command db2 < audit_log.sql to
run the script. You will receive error messages from the DROP
commands in the script. This is expected and the errors can be
ignored.

— Oracle —

a. Move to the following directory:
<ICS installation_path>\collaborations\dependencies\ \
UCCnet\oracle

b. Enter the following command:

sqlplus dbuser/passwd@SID @audit_log.sql

You might have to enable autoextension of the CWRepository data file.
Select the AUTOEXTEND option on the Storage tab for the data file in
the DBA Studio.

— Microsoft SQL Server —

a. Move to the following directory:
<ICS installation_path>\collaborations\dependencies\ \
UCCnet\mss
b. Select the CWRepository database in the drop-down in the menu bar.
c. Execute the audit_log.sql script by using the Query Analyzer tool.
* UNIX operating systems:
- DB2 —
a. Transfer the file

<ICS installation_path>\collaborations\dependencies\UCCnet\db2
\audit_log.sql to the UNIX system using FTP in ASCII mode. Place
the file in the

<ICS installation path>/collaborations/dependencies/UCCnet/db2
directory.

Move to the following directory of the UNIX system:

<ICS installation_path>/collaborations/dependencies/ \
UCCnet/db2

Installation guide 9
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C. Start a DB2 session by entering the command db2.

d. At the prompt, enter the command connect to repository_name.

e. After you are connected, enter the command < audit_log.sql to run the
script.

Oracle —

a. Transfer the file
<ICS_installation_path>\collaborations\dependencies\UCCnet
\oracle\audit_log.sql to the UNIX system using FTP in ASCII mode.
Place the file in the
<ICS_installation_path>/collaborations/dependencies
/UCCnet/oracle directory.

b. Move to the following directory of the UNIX system:

<ICS_installation_path>/collaborations/dependencies/ \
UCCnet/oracle

c. Enter the following command:
sqlplus dbuser/passwd@SID @audit_log.sql

You might have to enable autoextension of the CWRepository data file.
Select the AUTOEXTEND option on the Storage tab for the data file in
the DBA Studio.

2. The UCCnet property provides the collaboration objects with the information
they require to access the audit_log table. Add the UCCnet property to the
InterchangeSystem.cfg file by doing the following.

* Windows operating systems:

a.
b
C.
d. Paste the UCCnet property into the InterchangeSystem.cfg file, just before

Move to the directory <ICS_installation_path>\samples\UCCnet.

. Copy the contents of the InterchangeSystem.UCCnet file

Move to the directory <ICS_installation_path>.

the cw:ServerConfig tag at the end of the file.

Modify the values for the following UCCnet properties to match your
repository database installation:

— USER_NAME

— DRIVER

- PASSWORD

— DATA_SOURCE_NAME

* UNIX operating systems:

a.

® 200

Copy the InterchangeSystem.UCCnet from the Windows system to the
UNIX system.

Move to the directory <ICS_installation_path>/UCCnet.
Copy the contents of the InterchangeSystem.UCCnet file
Move to the directory <ICS_installation_path>.

Paste the UCCnet property into the InterchangeSystem.cfg file, just before
the cw:ServerConfig tag at the end of the file.

Modify the values for the following UCCnet properties to match your
repository database installation:

USER_NAME

DRIVER

PASSWORD
DATA_SOURCE_NAME



g. Modify the TARGETHLQ property so that it points to a local directory.

Configuring the metaobjects

You must configure (and in some cases create) the following metaobjects to

properly process UCCnet XML messages. To perform these tasks, complete the

following steps:

1. Edit the MO_DataHandler_DefaultXMLConfig metaobject by setting or adding
the following attributes, then save it as MO_DataHandler_UCCnetXMLConfig.

Table 10. Selected attribute values for MO_DataHandler_UCCnetXMLConfig metaobject

Attribute name Column Setting

BOPrefix Default ¢+ UCCnetDTD (for iSoft connectivity using the DTD XML definition)
* UCCnetXSD (for iSoft connectivity using XSD XML definition)

¢ UCCnetTPIDTD (for TPI connectivity using DTD XML definition)
¢ UCCnetTPIXSD (for TPI connectivity using XSD XML definition)

¢ UCCnet]MSDTD (For WebSphere Business Integration Connect-Java
Message Service connectivity using DTD XML definition.)

¢ UCCnet]MSXSD (For WebSphere Business Integration Connect-Java
Message Service connectivity using XSD XML definition.)

DefaultEscapeBehavior Default true

DTDPath Default DTD support

Path to Envelope.dtd file. For example,
<ICS_installation_path>\UCCnet\DTDs\2.2\Envelope.dtd

XSD support
Path to Envelope.xsd file. For example,
<ICS installation path>\UCCnet\XSDs\uccnet\2.2\Envelope.xsd

Note: The value of this attribute assumes use of the UCCnet 2.2 DTD.
The attribute values shown are examples only. The actual value must be
the fully qualified path to the Envelope.dtd or Envelope.xsd file on your
system. The Envelope files are available from the UCCnet eRoom. You
must have a valid UCCnet eRoom user ID and password to obtain them.

IgnoreUndefinedElements | Default true

Validation Default false

2. Edit the MO_DataHandler_Default metaobject by setting the following
attribute, then save it as MO_DataHandler_UCCnet_envelope.

Table 11. Selected attribute value for MO_DataHandler_UCCnet_envelope metaobject

Attribute name Column Setting
text_xml Type MO_DataHandler_UCCnetXMLConfig

3. Edit the MO_]JTextConnector_Default metaobject by setting the following
attributes, then save it as MO_JTextRWLConnector_Default.

Table 12. Selected attribute values for MO_JTextRWLConnector_Default metaobject

Attribute name Column Setting

ArchiveDir Default <Name of the directory where archive XML files will be written>
(for example, C:\IBM\WebSphereICS\UCCnet\]JTextRWL\archive).
Create this directory if it does not already exist.

EndBODelimiter Default EOF
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Table 12. Selected attribute values for MO_JTextRWLConnector_Default metaobject (continued)

Attribute name Column Setting

EventDataHandler Type MO_DataHandler_UCCnetXMLConfig

EventDir Default <Name of the directory to obtain input XMLs (Events)> (for
example, C:\IBM\WebSphereICS\UCCnet\]JTextRWL\event). Create
this directory if it does not already exist.

EventExt Default xml

OutputDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDir Default <Name of the directory where the XML files will be written> (for
example, C:\IBM\WebSphereICS\UCCnet\]JTextRWL\out). Create
this directory if it does not already exist.

OutputExt Default xml

4. Configure the following objects, depending on what protocol and connectivity
you are using:

If you are exchanging messages through the UCCnet CLU or testing your
installation, carry out the instructions that apply to the connectivity that you
are using;:

iSoft connectivity:

Edit the MO_JTextRWLConnector_Default metaobject by setting the following
attributes, then save it as MO_JTextISoftConnector_Default.

Table 13. Selected attribute values for MO_JTextlSoftConnector_Default metaobject

Attribute name Column Setting

EventDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDir Default <Name of the directory where the XML files will be written> (for
example, C:\IBM\ WebSpherel CS\UCCnet\]JTextISoft\out). Create
this directory if it does not already exist.

OutputExt Default xml

ArchiveDir Default <Name of the directory where archive XML files will be written>
(for example, C:\IBM\WebSphereICS\UCCnet\]JTextISoft\archive).
Create this directory if it does not already exist.

EventDir Default <Name of the directory to obtain input XML (Events)> (for example,
C\IBM\WebSphereICS\UCCnet\JTextISoft\event). Create this
directory if it does not already exist.

EventExt Default xml

EndBODelimiter Default EOF

If you are planning to use the schema-supported Catalogue Item Publication
functionality, you must create a second instance of both the JTextISoft
connector and the JTextISoft connector metaobjects. Edit the
MO_]JTextISoftConnector_Default by setting the following attributes, then
save it as MO_JTextISoft2Connector_Default.

Table 14. Selected attribute values for MO_JTextlSoft2Connector_Default metaobject

Attribute name Column Setting
EventDataHandler Type MO_DataHandler_UCCnetXMLConfig
OutputDataHandler Type MO_DataHandler_UCCnetXMLConfig
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Table 14. Selected attribute values for MO_JTextISoft2Connector_Default metaobject (continued)

Attribute name Column Setting

OutputDir Default <Name of the directory where the XML files will be written> (for
example, C:\IBM\ WebSphereICS\UCCnet\]JTextISoft2\out). Create
this directory if it does not already exist.

OutputExt Default xml

ArchiveDir Default <Name of the directory where archive XML files will be written>
(for example, C:\IBM\ WebSphereICS\UCCnet\]JTextISoft2\archive).
Create this directory if it does not already exist.

EventDir Default <Name of the directory to obtain input XML (Events)> (for example,
CA\IBM\WebSphereICS\UCCnet\]JTextISoft2\event). Create this
directory if it does not already exist.

EventExt Default xml

EndBODelimiter Default EOF

TPI connectivity:

Edit the MO_]JTextRWLConnector_Default metaobject by setting the following
attributes, then save it as MO_]JTextTPIConnector_Default.

Table 15. Selected attribute values for MO_JTextTPIConnector_Default metaobject

Attribute name Column Setting

EventDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDir Default <Name of the directory where the XML files will be written> (for

example, C:\IBM\WebSphereICS\UCCnet\]JTextTPI\out). Create
this directory if it does not already exist.

OutputExt Default xml

ArchiveDir Default <Name of the directory where archive XML files will be written>
(for example, C:\IBM\WebSphereICS\UCCnet\]JTextTPI\archive).
Create this directory if it does not already exist.

EventDir Default <Name of the directory to obtain input XML (Events)> (for example,
C\IBM\WebSphereICS\UCCnet\JTextTPI\event). Create this
directory if it does not already exist.

EventExt Default xml

EndBODelimiter Default EOF

If you are planning to use the schema-supported Catalogue Item Publication
functionality, you must create a second instance of both the JTextTPI
connector and the JTextTPI connector metaobjects. Edit the
MO_JTextTPIConnector_Default by setting the following attributes, then save
it as MO_JTextTPI2Connector_Default.

Table 16. Selected attribute values for MO_JTextTPI2Connector_Default metaobject

Attribute name Column Setting

EventDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDir Default <Name of the directory where the XML files will be written> (for
example, C:\IBM\ WebSphereICS\UCCnet\JTextTPI2\out). Create
this directory if it does not already exist.
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Table 16. Selected attribute values for MO_JTextTPI2Connector_Default metaobject (continued)

Attribute name Column Setting
OutputExt Default xml
ArchiveDir Default <Name of the directory where archive XML files will be written>

(for example, C:\IBM\ WebSphereICS\UCCnet\]JTextTPI2\archive).
Create this directory if it does not already exist.

EventDir Default <Name of the directory to obtain input XML (Events)> (for example,
CA\IBM\WebSphereICS\UCCnet\]JTextTPI2\event). Create this
directory if it does not already exist.

EventExt Default xml
EndBODelimiter Default EOF

Websphere Business Integration Connect-Java Message Service
connectivity:

Edit the following attributes of the MO_]JTextRWLConnector_Default
metaobject and save it as MO_]JTextfMSConnector_Default:

Table 17. Selected attribute values for MO_JTextIMSConnector_Default metaobject

Attribute name Column Setting

EventDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDir Default The name of the directory to write XML files to. For example,

C:\IBM\WebSphereICS\connectors\JTextIJMS\output. Create this
directory if it does not already exist.

OutputExt Default xml

ArchiveDir Default The name of the directory to archive XML files in. For example,
C:\IBM\WebSphereICS\connectors\JTextJMS\archive. Create this
directory if it does not already exist.

EventDir Default The name of the directory to obtain input XMLs (events) from. For
example, C:\IBM\WebSphereICS\connectors\JTextIMS\event). Create
this directory if it does not already exist.

EventExt Default xml
EndBODelimiter Default EOF

If you are planning to use the schema-supported Catalogue Item Publication
functionality, you must create a second instance of both the JText]MS
connector and the JTextfMS connector metaobjects. Edit the
MO_]JText]MSConnector_Default by setting the following attributes, then save
it as MO_JTextJMS2Connector_Default.

Table 18. Selected attribute values for MO_JTextJMS2Connector_Default metaobject

Attribute name Column Setting

EventDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDataHandler Type MO_DataHandler_UCCnetXMLConfig

OutputDir Default The name of the directory to write XML files to. For example,

C:\IBM\WebSphereICS\connectors\JTextJMS2\output. Create this
directory if it does not already exist.

OutputExt Default xml
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Table 18. Selected attribute values for MO_JTextJIMS2Connector_Default metaobject (continued)

Attribute name Column Setting

ArchiveDir Default The name of the directory to archive XML files in. For example,
C:\IBM\WebSphereICS\connectors\JTextJMS2\archive. Create this
directory if it does not already exist.

EventDir Default The name of the directory to obtain input XMLs (events) from. For
example, C:\IBM\WebSphereICS\connectors\JTextIMS2\event). Create
this directory if it does not already exist.

EventExt Default xml

EndBODelimiter Default EOF

5. If you are exchanging messages with UCCnet through an AS2/EDIINT
interface protocol, carry out the instructions that apply to the connectivity that
you are using;:
iSoft connectivity:

Use the Business Object Designer to create a metaobject called
MO_ISoftAdapterConfig with the attributes shown in the following table. If
you are using XSD CIP operation, you will need two instances of the iSoft
connector. However, both instances use the same metaobject, so only one
metaobject is needed.

Table 19. Attribute values for MO_ISoftAdapterConfig

Attribute name Type Key Application Specific Information

Default String X OutputQueue=queue://
my_p2p_agent_queie_manager_name/
my_outbox_queue_name; DataEncoding=Text

UCCnetDTD_envelope_Create | String If the application specific information provided
(for DTD support) or for the Default attribute is insufficient for your
UCCnetXSD_envelope_Create installation, additional information on this

(for schema support) metaobject is available in the Adapter for iSoft

Peer-to-Peer Agent User Guide.

TPI connectivity:
If TPI connectivity is used, No configuration metaobject is required.
WebSphere Business Integration Connect-Java Message Service connectivity:

Use the Business Object Designer to create a metaobject called
MO_JMSAdapterConfig with the attributes shown in the following table.

Table 20. Attribute values for MO_JMSAdapterConfig

Attribute name Type Key Application specific information

Default String X OutputQueue=my_output_queue_name; where
my_output_queue_name specifies where to deliver the
messages.

UCCnet]MSDTD_envelope_create | String The application specific information provided for

(for DTD support) or the Default attribute might be sufficient for your

UCCnet]MSXSD_envelope_create installation. For additional information on this

(for XSD support) metaobject, refer to the Adapter for Java Message
Service Agent User Guide.

6. Set the following attributes in the EmailNotification business object:
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Table 21. Selected attribute values for EmailNotification business object

Name Column Setting
RecipientName Default Email address of recipient.
FromAddress Default Email address of sender.

Creating and configuring the connectors

The connectors that must be created and/or configured depend on the individual
installation, as follows:

16 Installation Guide

* Create and configure the JTextRWLConnector in every installation, as detailed in
the section [“Creating and configuring the JTextRWLConnector” on page 17.|

* Configure, or if necessary, create and configure one of the following connectivity
connectors depending on the connectivity type you are using and the protocol
you are using to exchange messages:

If you are exchanging messages with UCCnet through an AS2/EDIINT
interface protocol and are using iSoft connectivity, configure the
iSoftConnector, as detailed in the section [“Creating and configuring the
[iSoftConnector” on page 19

If you are exchanging messages with UCCnet through an AS2/EDIINT
interface protocol and are using TPI connectivity, configure the TPIConnector,
as detailed in the section [“Creating and configuring the TPIConnector” onl|
-a ge 23.

If you are exchanging messages with UCCnet through an AS2/EDIINT
interface protocol and are using the WebSphere Business Integration Connect
interface, configure the JMSConnector, as detailed in the sectionl”Creating andl
fconfiguring the first instance of the JMSConnector” on page 32|

If you are exchanging messages through the UCCnet CLU or testing your
installation, and are using iSoft connectivity, create and configure the
JTextISoftConnector, as detailed in the section |“Creating and configuring the|
[ TextISoftConnector” on page 26)

If you are exchanging messages through the UCCnet CLU or testing your
installation, and are using TPI connectivity, create and configure the
JTextTPIConnector, as detailed in the section [“Creating and configuring thel
[ TextTPIConnector” on page 29

If you are exchanging messages with through the UCCnet CLU or are testing
your installation and are using the WebSphere Business Integration Connect
interface, configure the JTextfMSConnector, as detailed in the section
[‘Creating and configuring the JTextfMSConnector” on page 39

* Configure the PortConnector in every installation, as detailed in the section

[“Configuring the PortConnector” on page 42

* If you want to use the email capabilities of the Item Synchronization for
Suppliers solution, configure the EmailConnector, as detailed in the section

[“Configuring the EmailConnector” on page 42.|

* Configure the connector for the source of your item information. The
SAPConnector is included here as an example, as detailed in the section

[“Configuring the SAPConnector” on page 43]If you want to test the solution

without a live connection to the source of your item information, configure a
TestConnector. A sample TestConnector configuration is detailed in the section

[“Configuring the TestConnector” on page 43.

The connector configuration procedures defined in the following sections assume
the connector configuration information is saved to the project, where it is accessed



by the connector at startup time. As an alternative, the connector configuration
information can be saved to a file and the connector startup procedure can be

altered to access that file. For additional information on options for starting your

connectors, refer to the System Administration Guide.

Creating and configuring the JTextRWLConnector
The JTextRWLConnector is the input connector for a UCCnet_requestWorklist

collaboration object. The UCCnet_requestWorklist collaboration object passes a
UCCnet worklist request to UCCnet from a file system folder. To poll for the
worklist, a scheduler operation performed by an operating system must be
configured to periodically drop a fresh copy of the request .xml into the event file
system folder for the JTextRWLConnector.

Creating the JTextRWLConnector: To create the JTextRWLConnector, complete the

following steps:
1. Open the System Manager.

2. Save the JTextRWLConnector by doing the following:

a. Open the JTextConnector.

b. Click File > Save As > To Project.
C. Save the connector as JTextRWLConnector.

Configuring the JTextRWLConnector: Perform the following steps to configure

the JTextRWLConnector:

1. Configure this connector to include the standard configuration property and
appropriate business objects. Use the values shown in the following tables.

Table 22. Standard property

Property name

Value

ApplicationName

JTextRWLConnector

Table 23. Supported business objects

Business object name

Agent support required?

MO_JTextRWLConnector_Default

Yes

MO_DataHandler_UCCnet_envelope

Yes

One of the following:

* UCCnetDTD_envelope (when iSoft connectivity and DTD XML
definition type are used)

* UCCnetTPIDTD_envelope (when TPI connectivity and DTD
XML definition type are used)

* UCCnet]MSDTD_envelope (when WebSphere Business
Integration Connect connectivity and DTD XML definition type
are used)

* UCCnetXSD_envelope (when iSoft connectivity and XSD XML
definition type are used)

* UCCnetTPIXSD_envelope (when TPI connectivity and XSD
XML definition type are used)

* UCCnet]MSXSD_envelope (when WebSphere Business
Integration Connect connectivity and XSD XML definition type
are used)

Yes

UCCnetGBO_envelope

No
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2. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 24. Associated maps

Business object name

Map name

UCCnetDTD_envelope (when
iSoft connectivity and DTD XML
definition type are used)

UCCnetDTD_envelope_to_UCCnetGBO_envelope

UCCnetTPIDTD_envelope
(when TPI connectivity and
DTD XML definition type are
used)

UCCnetTPIDTD_envelope_to_UCCnetGBO_envelope

UCCnet]MSDTD_envelope(when
WebSphere Business Integration

Connect is used with DTD XML
definition type)

UCCnet]MSDTD_envelope_to_UCCnetGBO_envelope

UCCnetXSD_envelope (when
iSoft connectivity and XSD XML
definition type are used)

UCCnetXSD_envelope_to_UCCnetGBO_envelope

UCCnetTPIXSD_envelope (when
TPI connectivity and XSD XML
definition type are used)

UCCnetTPIXSD_envelope_to_UCCnetGBO_envelope

UCCnet]MSXSD_envelope(when
WebSphere Business Integration
Connect is used with XSD XML
definition type)

UCCnet]MSXSD_envelope_to_UCCnetGBO_envelope

UCCnetGBO_envelope

* When iSoft connectivity and DTD XML definition type are used:
RouterMap_UCCnetGBO_envelope_to_UCCnetDTD_envelope

* When TPI connectivity and DTD XML definition type are used:
RouterMap_UCCnetGBO_envelope_to_UCCnetTPIDTD_envelope

* When WebSphere Business Integration Connect is used with DTD XML
definition: RouterMap_UCCnetGBO_envelope_to_UCCnet]MSDTD_envelope

* When iSoft connectivity and XSD XML definition type are used:
UCCnetGBO_envelope_to_UCCnetXSD_envelope

* When TPI connectivity and XSD XML definition type are used:
UCCnetGBO_envelope_to_UCCnetTPIXSD_envelope

* When WebSphere Business Integration Connect is used with XSD XML
definition: UCCnetGBO_envelope_to_UCCnet]MSXSD_envelope

3. Save the configuration file (File > Save > To Project), then close the Connector
Configurator.

4. Create the JTextRWLConnector Agent, as follows:
Windows operating systems:
a. In the Windows task bar, right-click Start and select Open All Users.

b. Navigate to the folder on your system that contains the installed connectors
by clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.

c. Copy the JText Connector short cut and rename it to JTextRWL Connector.
Right-click the JTextRWL Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command line
argument to JTextRWL, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:
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<install_path>\IBM\WebSphereICS\connectors\JText\start JText.bat \
JTextRWL ICS_server_name

UNIX operating systems:

a. Access the JTextConnector Agent program located in the following
directory: <install_path>/IBM/WebSpherelCS/connectors/JText/.

b. Run JTextRWL by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JTextRWL ICS_server_name

If you are using WebSphere MQ as your connector transport, create the
JTextRWLConnector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmgsc local_WebSphere_ICS_queue_manager_name

DEFINE QLOCAL (AP/JTEXTRWLCONNECTOR/ICS server name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS_server_name/JTEXTRWLCONNECTOR) USAGE (NORMAL)
END

Creating and configuring the iSoftConnector
Open the iSoft connector in the Connector Configurator and configure this

connector only if you are using the iSoft Peer-to-Peer Agent and are
communicating with UCCnet through an AS2/EDIINT interface protocol.

Creating and configuring the first instance of the iSoftConnector: Perform the
following steps to configure the first instance of the iSoftConnector:

1. Set the value of the MQSERIES_JAVA_LIB attribute in the connector startup file

(start_ISoft.bat on Windows, start_ISoft.sh on UNIX) to the location of your
WebSphere MQ Java client libraries (for instance, C:\Program
Files\IBM\WebSphere MQ\Java\lib).

Configure this connector to include the connector-specific configuration
properties and appropriate business objects. Use the values shown in the
following tables.

Table 25. Connector-specific properties

Property name

Value

ArchiveQueue Queue to which copies of successfully processed messages are sent (for
instance, queue://my_p2p_agent_queue_manager_name/archive)
Channel WebSphere MQ server connector channel for your iSoft Peer-to-Peer Agent

queue manager.

ConfigurationMetaObject

MO_ISoftAdapterConfig

DataHandlerConfigMO MO_DataHandler_UCCnet_envelope

DefaultVerb Create (add this property if it does not appear in the list of
connector-specific properties)

ErrorQueue Queue to which messages that could not be processed are sent (for
instance, queue://my_p2p_agent_queue_manager_name/error)

HostName The name of the host running the iSoft Peer-to-Peer Agent WebSphere MQ

queue manager.
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Table 25. Connector-specific properties (continued)

Property name Value

InputQueue Semi-colon-delimited list of message queues that are polled by the
connector for new messages (for instance,
queue://my_p2p_agent_queue_manager_name/inbox1;
queue://my_p2p_agent_queue_manager_name/inbox2)

InProgressQueue Message queue where messages are held during processing (for instance,
queue://my_p2p_agent_queue_manager_name/in_progress)
Port Port established for the WebSphere MQ listener of the iSoft Peer-to-Peer

Agent’s queue manager.

UnsubscribedQueue Queue to which messages that are not subscribed are sent (for instance,
queue://my_p2p_agent_queue_manager_name/unsubscribed)

UseDefaults true (add this property if it does not appear in the list of
connector-specific properties)

Table 26. Supported business objects

Business object name Agent support required?
MO_DataHandler_UCCnet_envelope Yes
MO_ISoftAdapterConfig Yes
UCCnetDTD_envelope (used only for DTD support) Yes
UCCnetXSD_envelope (used only for XSD support) Yes
UCCnetGBO_envelope No
ItemBasic No

3. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 27. Associated maps

Business object name | Map name

ItemBasic DTD support

RouterMap_CwlItemBasic_to_UCCnetDTD_envelope

XSD support, CIN operation
CwltemBasic_to_UCCnetXSD_envelope_registerCommand_itemAddChange

XSD support, CIP operation
CwltemBasic_to_UCCnetXSD_envelope_registerCommand_CIP_itemAddChange

UCCnetDTD_envelope | UCCnetDTD_envelope_to_UCCnetGBO_envelope
(used only for DTD

support)

UCCnetGBO_envelope | oy o obort

RouterMap_UCCnetGBO_envelope_to_UCCnetDTD_envelope

XSD support
UCCnetGBO_envelope_to_UCCnetXSD_envelope

UCCnetXSD_envelope | UCCnetXSD_envelope_to_UCCnetGBO_envelope
(used only for XSD
support)

4. Save the configuration (File > Save > To Project) then close the Connector
Configurator.
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5. If you are using WebSphere MQ as your connector transport, create the
iSoftConnector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmqgsc local_WebSphere_ICS_queue_manager_name
DEFINE QLOCAL (AP/ISOFTCONNECTOR/ICS server_name) USAGE (NORMAL)
DEFINE QLOCAL (IC/ICS_server_name/ISOFTCONNECTOR) USAGE (NORMAL)

END

Creating and configuring the second instance of the iSoftConnector: If you are
setting up for XSD CIP operation, you need two instances of the iSoft connector.
Perform the following steps to configure the second instance:

1. Open the System Manager.

2. Save the ISoft2Connector by doing the following:

a.
b.
c.

Open the ISoftConnector.
Click File > Save As > To Project.

Save the connector as ISoft2Connector.

3. Create the ISoft2Connector Agent, as follows:

Windows operating systems:

a.
b.

In the Windows task bar, right-click Start and select Open All Users.

Navigate to the folder on your system that contains the installed connectors
by clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.

Copy the ISoftConnector short cut and rename it to ISoft2Connector.
Right-click the ISoft2Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command line
argument to ISoft2, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install_path>\connectors\JText\start_ISoft.bat ISoft2 ICS server_name

UNIX operating systems:

a.

Access the ISoft2Connector Agent program located in the following
directory: <install_path>/IBM/WebSpherelCS/connectors/Isoft/.

Run ISoft2 by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh ISoft2 ICS_server_name

Open the ISoft2Connector in the Connector Configurator and configure this
connector to include the connector-specific configuration properties and
appropriate business objects. Use the values shown in the following tables.

Table 28. Connector-specific properties

Property name

Value

ArchiveQueue Queue to which copies of successfully processed messages are sent (for
instance, queue://my_p2p_agent_queue_manager_name/archive2)
Channel WebSphere MQ server connector channel for your iSoft Peer-to-Peer Agent

queue manager.

ConfigurationMetaObject

MO_ISoftAdapterConfig

DataHandlerConfigMO

MO_DataHandler_UCCnet_envelope
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Table 28. Connector-specific properties (continued)

Property name

Value

DefaultVerb

Create (add this property if it does not appear in the list of
connector-specific properties)

ErrorQueue

Queue to which messages that could not be processed are sent (for
instance, queue://my_p2p_agent_queue_manager _name/error2)

HostName

The name of the host running the iSoft Peer-to-Peer Agent WebSphere MQ
queue manager.

InputQueue

Semi-colon-delimited list of message queues that are polled by the
connector for new messages (for instance,
queue://my_p2p_agent_queue_manager_name/inbox3;
queue://my_p2p_agent_queue_manager_name/inbox4)

Note: The inbox for the second instance of the iSoft connector must not be
the same as the inbox for the first instance of the iSoft connector. This
instance of the connector is not configured to receive business objects.

InProgressQueue

Message queue where messages are held during processing (for instance,
queue://my_p2p_agent_queue_manager_name/in_progress2)

Port

Port established for the WebSphere MQ listener of the iSoft Peer-to-Peer
Agent’s queue manager.

UnsubscribedQueue

Queue to which messages that are not subscribed are sent (for instance,
queue://my_p2p_agent_queue_manager_name/unsubscribed2)

UseDefaults

true (add this property if it does not appear in the list of
connector-specific properties)

Table 29. Supported business objects

Business object name Agent support required?
MO_DataHandler_UCCnet_envelope Yes
MO_ISoftAdapterConfig Yes
UCCnetXSD_envelope Yes
ItemBasic No

5. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 30. Associated maps

Business object name

Map name

ItemBasic

CwltemBasic_to_UCCnetXSD_envelope_publicationCommand_catalogueltem

6. Save the configuration (File > Save > To Project) then close the Connector
Configurator.

7. If you are using WebSphere MQ as your connector transport, create the
ISoft2Connector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used
by the IBM WebSphere InterChange Server and ICS_server_name refers to the
name of the InterChange Server. Enter the following at a command prompt:

runmgsc local_WebSphere_ICS_queue_manager_name
DEFINE QLOCAL (AP/ISOFT2CONNECTOR/ICS_server_name) USAGE (NORMAL)
DEFINE QLOCAL (IC/ICS_server_name/ISOFT2CONNECTOR) USAGE (NORMAL)

END
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Refer to the Adapter for iSoft Peer-to-Peer Agent User Guide for more information
about this connector.

Creating and configuring the TPIConnector

Configure this connector only if you are using the TPI server and are
communicating with UCCnet through an AS2/EDIINT interface protocol. If you
are setting up for XSD CIP operation, you will need two instances of the TPI
connector. Otherwise, you only require one. Perform the following steps to
configure the TPIConnector:

Creating and configuring the first instance of the TPIConnector:

1. Create the trading partner configuration file tpcfg.txt, which includes one
tab-delimited line for each trading partner formatted as follows:

Trading Partner ID (tab) XML MIME type

A sample file might look like the following example:

#Comment lines start with #
TP1 text/xml
TP2 text/xml

2. Set the value of the CYCLONEHOMEDIR attribute in the connector startup file
(start_TPILbat on Windows, start_TPL.sh on UNIX) to the location of the home
directory for your TPI server installation (for instance, c:\TPISolo\).

3. Configure this connector to include the connector-specific configuration
properties and appropriate business objects. Use the values shown in the
following tables.

Table 31. Connector-specific properties

Property name

Value

ArchiveProcessedDocDir

Directory where processed document metaevents are archived (for
instance, C:\TPISolo\data\uccnet2\archive).

DataHandlerConfigMO MO_DataHandler_UCCnet_envelope

DefaultXMLMimeType text/xml

DocumentOutDir Directory location where outbound documents are written temporarily
before TPI processes them (for instance, C:\TPISolo\data\uccnet2\xmlout).

MetaEventDir Directory used to persist the TPI event information for recovery purposes
(for instance, C:\TPISolo\data\uccnet2\xmlin).

PollQuantity 1 (add this property it does not appear in the list of connector-specific

properties).

TradingPartnerConfigurationFile

Fully qualified name of the trading partner configuration file created in
Step 1 above (for instance,
C:\IBM\WebSphereICS\connectors\TPI\tpcfg.txt).

WaitForMDN

false (MDNs are not supported by this solution).

Table 32. Supported business objects

Business object name Agent support required?
MO_DataHandler_UCCnet_envelope Yes
* UCCnetTPIDTD_envelope (when the DTD XML definition type Yes
is used)
* UCCnetTPIXSD_envelope (when the XSD XML definition type is
used)
[temBasic No
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Table 32. Supported business objects (continued)

Business object name

Agent support required?

UCCnetGBO_envelope

No

Table 33. Associated maps

4. Save the configuration (File > Save > To Project), then go back to the

Associated Map tab and set the explicit bindings.

Business object name

Map name

ItemBasic

DTD support
RouterMap_CwlItemBasic_to_UCCnetTPIDTD_envelope

XSD support, CIN operation
CwltemBasic_to_UCCnetTPIXSD_envelope_registerCommand
_itemAddChange

XSD support, CIP operation
CwltemBasic_to_UCCnetTPIXSD_envelope_registerCommand
_CIP_itemAddChange

UCCnetGBO_envelope

DTD support
RouterMap_UCCnetGBO_envelope_to_UCCnetTPIDTD_envelope

XSD support
UCCnetGBO_envelope_to_UCCnetTPIXSD_envelope

UCCnetTPIDTD_envelope
(used only for DTD support)

UCCnetTPIDTD_envelope_to_UCCnetGBO_envelope

UCCnetTPIXSD_envelope
(used only for XSD support)

UCCnetTPIXSD_envelope_to_UCCnetGBO_envelope
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5.

6.

Save the configuration (File > Save > To Project), then close the Connector
Configurator.

If you are using WebSphere MQ as your connector transport, create the
TPIConnector queues in WebSphere MQ. You must create the following queues
as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmgsc local WebSphere ICS queue manager name

DEFINE QLOCAL  (AP/TPICONNECTOR/ICS server name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS server name/TPICONNECTOR) USAGE (NORMAL)

END

When a message is sent to UCCnet, the Senderld and Receiverld values in the
UCCnetTPIDTD_envelope and UCCnetTPIXSD_envelope business objects are
set by the maps when these business objects are created. For the following
maps, use the Map Designer to modify the "Set value” rules for the
TPIRoutelnfo child business object with the correct Senderld and Receiverld
values for your installation.

CwltemBasic_to UCCnetGBO _envelope notifyCommand catalogueltem
CwItemBasic_to_UCCnetGBO_env_publicationCommand_catalogueltemPublication
CwItemBasic_to_UCCnetTPIXSD_envelope_publicationCommand_catalogueltem
CwItemBasic_to_UCCnetTPIXSD_envelope_registerCommand_CIP_itemAddChange
CwItemBasic_to_UCCnetTPIXSD_envelope_registerCommand_itemAddChange
RouterMap CwItemBasic_to UCCnetTPIDTD envelope

RouterMap UCCnetGBO envelope to UCCnetTPIDTD envelope




To implement multiple trading partners, you need either multiple versions of
these maps or you need to set these values in the collaboration object.

Creating and configuring the second instance of the TPIConnector: This
connector is only required if you are setting up for XSD CIP operation.

1. Create the TPI2Connector using the System Manager, as follows:

a. Open the System Manager.

b. Save the TPI2Connector by doing the following:
1) Open the TPIConnector.
2) Click File > Save As > To Project.
3) Save the connector as TPI2Connector.

c. Create the TPI2Connector Agent, as follows:

Windows operating systems:

1)
2)

3)
4)
5)

In the Windows task bar, right-click Start and select Open All Users.

Navigate to the folder on your system that contains the installed
connectors by clicking Programs > IBM WebSphere Business
Integration Adapters > Adapters > Connectors.

Copy the TPIConnector short cut and rename it to TPI2Connector.
Right-click the TPIConnector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command

line argument to TPI2, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install_path>\connectors\JText\start_TPI.bat TPI2 ICS_server_name

UNIX operating systems:

1)

2)

Access the TPI Agent program located in the following directory:
<install_path>/1BM/WebSpherelCS/connectors/TPI/.

Run TPI by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_TPI.sh TPI2 ICS_server_name

Configure the TPI2Connector as follows:

1. Open the TPI2Connector in the Connector Configurator and configure this
connector to include the connector-specific configuration properties and
appropriate business objects. Use the values shown in the following tables.

Table 34. Connector-specific properties

Property name

Value

ArchiveProcessedDocDir

Directory where processed document metaevents are archived (for
instance, C:\TPISolo\data\uccnet2\archive2).

DataHandlerConfigMO MO_DataHandler_UCCnet_envelope

DefaultXMLMimeType text/xml

DocumentOutDir Directory location where outbound documents are written temporarily
before TPI processes them (for instance, C:\TPISolo\data\uccnet2\xmlout).
Note: The output directory for this instance of the connector is the same
as the output directory for the first instance of the connector.

MetaEventDir Directory used to persist the TPI event information for recovery purposes

(for instance, C:\TPISolo\data\uccnet2\xmlin2).
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Table 34. Connector-specific properties (continued)

Property name Value

PollQuantity 1 (add this property it does not appear in the list of connector-specific
properties).

TradingPartnerConfigurationFile Fully qualified name of the trading partner configuration file created in
Step 1 above (for instance,
C:\IBM\WebSphereICS\connectors\TPI\tpcfg.txt).

WaitForMDN false (MDNs are not supported by this solution).

Table 35. Supported business objects

Business object name Agent support required?
MO_DataHandler_UCCnet_envelope Yes
UCCnetTPIXSD_envelope Yes
ItemBasic No

2. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 36. Associated maps

Business object name

Map name

ItemBasic

CwltemBasic_to_UCCnetTPIXSD_envelope_publicationCommand_catalogueltem
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3. Save the configuration (File > Save > To Project), then close the Connector
Configurator.

4. If you are using WebSphere MQ as your connector transport, create the
TPI2Connector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:
runmgsc local WebSphere ICS queue _manager name
DEFINE QLOCAL (AP/TPI2CONNECTOR/ICS server name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS_server_name/TPI2CONNECTOR) USAGE (NORMAL)
END

Refer to the Adapter for Trading Partner Interchange User Guide for more
information about this connector.

Creating and configuring the JTextlSoftConnector

Create and configure this connector only if you are using the iSoft Peer-to-Peer
Agent and are communicating with UCCnet through the UCCnet CLU or testing
your installation. This is a copy of the JTextConnector used to simulate the
iSoftConnector. Like the iSoftConnector, the JTextISoftConnector uses the IBM
WebSphere Business Integration Data Handler for XML and generates the same
XML output. If you are setting up for XSD CIP operation, you need to configure
two instances of the JTextISoft connector. Otherwise, you only need to create and
configure the first instance.

Creating and configuring the first instance of the JTextISoftConnector:
1. Create the JTextISoftConnector using the System Manager, as follows:
a. Open the System Manager.
b. Save the JTextISoftConnector by doing the following:




1)
2)
3)

Open the JTextConnector.
Click File > Save As > To Project.
Save the connector as JTextISoftConnector.

c. Create the JTextISoftConnector Agent, as follows:

Windows operating systems:

1)
2)
3)

4)
5)

In the Windows task bar, right-click Start and select Open All Users.

Navigate to the folder on your system that contains the installed
connectors by clicking Programs > IBM WebSphere Business
Integration Adapters > Adapters > Connectors.

Copy the JText Connector short cut and rename it to JTextISoft
Connector.
Right-click the JTextISoft Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command
line argument to JTextISoft, where ICS_server_name refers to the name of
the InterChange Server, as shown in the following example:

<install_path>\connectors\JText\start_JText.bat JTextISoft ICS_server_name

UNIX operating systems:

1)

2)

Access the JTextISoftConnector Agent program located in the following

directory: <install_path>/IBM/WebSpherelCS/connectors/JText/.

Run JTextISoft by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JTextISoft ICS_server_name

Perform the following steps to configure the JTextISoftConnector:

1. Configure this connector to include the standard configuration property and
appropriate business objects. Use the values shown in the following tables.

Table 37. Standard property

Property name

Value

ApplicationName

JTextISoftConnector

Table 38. Supported business objects

Business object name

Agent support required?

MO_JTextISoftConnector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
* UCCnetDTD_envelope (when the DTD XML definition type is Yes
used)
* UCCnetXSD_envelope (when the XSD XML definition type is
used)
ItemBasic No
UCCnetGBO_envelope No

2. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.
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Table 39. Associated maps

Business object name

Map name

ItemBasic

DTD support
RouterMap_CwlItemBasic_to_UCCnetDTD_envelope

XSD support, CIN operation
CwltemBasic_to_UCCnetXSD_envelope_to_registerCommand_itemAddChange

XSD support, CIP operation
CwltemBasic_to_UCCnetXSD_envelope_registerCommand_CIP_itemAddChange

UCCnetDTD_envelope

UCCnetDTD_envelope_to_UCCnetGBO_envelope

UCCnetGBO_envelope

DTD support
RouterMap_UCCnetGBO_envelope_to_UCCnetDTD_envelope

XSD support
UCCnetGBO_envelope_to_UCCnetXSD_envelope

UCCnetXSD_envelope

UCCnetXSD_envelope_to_UCCnetGBO_envelope
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3. Save the configuration (File > Save > To Project), then close the Connector
Configurator.

4. If you are using WebSphere MQ as your connector transport, create the
JTextISoftConnector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmqsc local_WebSphere_ICS_queue_manager_name

DEFINE QLOCAL (AP/JTEXTISOFTCONNECTOR/ICS_server_name) USAGE (NORMAL)
DEFINE QLOCAL (IC/ICS server_name/JTEXTISOFTCONNECTOR) USAGE (NORMAL)
END

Creating and configuring the second instance of the JTextISoftConnector: The
second instance of the JTextISoftConnector is only used for XSD CIP operation. If it
is required, create it as follows:

1. Create the JTextISoft2Connector using the System Manager, as follows:

a. Open the System Manager.

b. Save the JTextISoft2Connector by doing the following:
1) Open the JTextISoftConnector.
2) Click File > Save As > To Project.
3) Save the connector as JTextISoft2Connector.

c. Create the JTextISoft2Connector Agent, as follows:
Windows operating systems:
1) In the Windows task bar, right-click Start and select Open All Users.

2) Navigate to the folder on your system that contains the installed
connectors by clicking Programs > IBM WebSphere Business
Integration Adapters > Adapters > Connectors.

3) Copy the JTextISoftConnector short cut and rename it to
JTextISoft2Connector.
4) Right-click the JTextISoft2Connector short cut and select Properties.

5) Click the Short cut tab, edit the Target field, and set the first command
line argument to JTextISoft2, where ICS_server_name refers to the name
of the InterChange Server, as shown in the following example:




<install_path>\connectors\JText\start_JText.bat JTextISoft2 ICS_server_name

UNIX operating systems:

1) Access the JTextISoft2Connector Agent program located in the following
directory: <install_path>/IBM/WebSpherelCS/connectors/JText/.

2) Run JTextISoft2 by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JTextISoft2 ICS_server_name

Perform the following steps to configure the JTextISoft2Connector:

1. Configure this connector to include the standard configuration property and
appropriate business objects. Use the values shown in the following tables.

Table 40. Standard property

Property name

Value

ApplicationName

JTextISoft2Connector

Table 41. Supported business objects

Business object name

Agent support required?

MO_JTextISoftConnector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
UCCnetXSD_envelope Yes
ItemBasic No

2. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 42. Associated maps

Business object name

Map name

ItemBasic

CwltemBasic_to_UCCnetXSD_envelope_publicationCommand_catalogueltem

3. Save the configuration (File > Save > To Project), then close the Connector
Configurator.

4. If you are using WebSphere MQ as your connector transport, create the
JTextISoft2Connector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:
runmqsc local_WebSphere_ICS_queue_manager_name
DEFINE QLOCAL (AP/JTEXTISOFT2CONNECTOR/ICS server_name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS_ser‘ver‘_name/JTEXTISOI_:TZCONNECTOR) USAGE (NORMAL)
END

Creating and configuring the JTextTPIConnector

Create and configure this connector only if you are using the TPI server and are
communicating with UCCnet through the UCCnet CLU or testing your installation.
This is a copy of the JTextConnector used to simulate the TPIConnector. Like the
TPIConnector, the JTextTPIConnector uses the IBM WebSphere Business Integration
Data Handler for XML and generates the same XML output. If you are setting up
your system to use the XSD CIP operation, you must create and configure two
instances of the JTextTPI connector.
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Creating and configuring the first instance of the JTextTPIConnector: To create
the JTextTPIConnector, complete the following steps:

1.
2.

Open the System Manager.

Save the JTextTPIConnector by doing the following:
a. Open the JTextConnector.

b. Click File > Save As > To Project.

c. Save the connector as JTextTPIConnector.

To configure the JTextTPIConnector, complete the following steps::

1.

Configure this connector to include the standard configuration property and
appropriate business objects. Use the values shown in the following tables.

Table 43. Standard property

Property name

Value

ApplicationName

JTextTPIConnector

Table 44. Supported business objects

Business object name

Agent support required?

MO_JTextTPIConnector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
+ UCCnetTPIDTD_envelope (when the DTD XML definition type | Yes
is used)
* UCCnetTPIXSD_envelope (when the XSD XML definition type
is used)
UCCnetGBO_envelope No
ItemBasic No

2.

Table 45. Associated maps

Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Business object name

Map name

UCCnetTPIDTD_envelope

UCCnetTPIDTD_envelope_to_UCCnetGBO_envelope

UCCnetTPIXSD_envelope

UCCnetTPIXSD_envelope_to_UCCnetGBO_envelope

UCCnetGBO_envelope

DTD support
RouterMap_UCCnetGBO_envelope_to_UCCnetTPIDTD_envelope

XSD support
UCCnetGBO_envelope_to_UCCnetTPIXSD_envelope

ItemBasic

DTD support
RouterMap_CwlItemBasic_to_UCCnetTPIDTD_envelope

XSD support, CIN operation
CwltemBasic_to_UCCnetTPIXSD_envelope_registerCommand_itemAddChange

XSD support, CIP operation
CwltemBasic_to_UCCnetTPIXSD_envelope_registerCommand_CIP_itemAddChange
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Save to the configuration (File > Save > To Project), then close the Connector
Configurator.

Create the JTextTPIConnector Agent, as follows:
Windows operating systems:




a. In the Windows task bar, right-click Start and select Open All Users.

b. Navigate to the folder on your system that contains the installed connectors
by clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.

c. Copy the JText Connector short cut and rename it to JTextTPI Connector.
Right-click the JTextTPI Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command line
argument to JTextTPI, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install_path>\connectors\JText\start_JText.bat JTextTPI ics_server_name

UNIX operating systems:

a. Access the JTextTPIConnector Agent program located in the following
directory: <install_path>/IBM/WebSpherelCS/connectors/JText/.

b. Run JTextTPI by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JTextTPI ICS_server_name

If you are using WebSphere MQ as your connector transport, create the
JTextTPIConnector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmgsc local_WebSphere_ICS_queue_manager_name

DEFINE QLOCAL (AP/JTEXTTPICONNECTOR/ICS_server_name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS_server_name/JTEXTTPICONNECTOR) USAGE (NORMAL)
END

Creating and configuring the second instance of the JTextTPIConnector: To
create the JTextTPI2Connector, complete the following steps:

1. Open the System Manager.

2. Save the JTextTPI2Connector by doing the following:

a. Open the JTextTPIConnector.
b. Click File > Save As > To Project.
c. Save the connector as JTextTPI2Connector.

Perform the following steps to configure the JTextTPI2Connector:

1. Configure this connector to include the standard configuration property and

appropriate business objects. Use the values shown in the following tables.

Table 46. Standard property

Property name

Value

ApplicationName

JTextTPI2Connector

Table 47. Supported business objects

Business object name

Agent support required?

MO_JTextTPI2Connector_Default

Yes

MO_DataHandler_UCCnet_envelope Yes
UCCnetTPIXSD_envelope Yes
ItemBasic No
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Table 48. Associated maps

2. Save the configuration (File > Save > To Project), then go back to the

Associated Map tab and set the explicit bindings.

Business object name

Map name

ItemBasic

CwltemBasic_to_UCCnetTPIXSD_envelope_publicationCommand_catalogueltem
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Save to the configuration (File > Save > To Project), then close the Connector
Configurator.

Create the JTextTPI2Connector Agent, as follows:
Windows operating system:
a. In the Windows task bar, right-click Start and select Open All Users.

b. Navigate to the folder on your system that contains the installed connectors
by clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.

c. Copy the JText Connector short cut and rename it to JTextTPI2 Connector.
Right-click the JTextTPI2Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command line
argument to JTextTPI2, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install_path>\connectors\JText\start_JText.bat JTextTPI2 ics_server_name

UNIX operating system:

a. Access the JTextTPIConnector Agent program located in the following
directory: <install_path>/1BM/WebSpherelCS/connectors/]Text/.

b. Run JTextTPI2 by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JTextTPI2 ICS_server_name

If you are using WebSphere MQ as your connector transport, create the
JTextTPI2Connector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmgsc local_WebSphere_ICS_queue_manager_name

DEFINE QLOCAL (AP/JTEXTTPI2CONNECTOR/ICS_server_name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS server name/JTEXTTPI2CONNECTOR) USAGE (NORMAL)
END

Creating and configuring the JMSConnector

Create and configure this connector only if you are using the TPI server and are
communicating with are communicating with UCCnet through a WebSphere
Business Integration Connect interface. If you are setting up your system to use the
XSD CIP operation, you must create and configure two instances of the
JMSConnector connector.

Creating and configuring the first instance of the JMSConnector: To create and
configure the J]MSConnector, complete the following steps:

1. Create the following channels and queues using MQ Explorer, or the runmgsc

tool:

a. Start runmgsc:




runmgsc local_queue_manager name
b. Define a transmission queue
o DEFINE QLOCAL(xmit g_name) USUAGE(XMITQ) MAXMSGL(10485760)

C. Define a sender channel for sending messages to WebSphere Business
Integration Connect

DEFINE CHANNEL(channel_name) CHLTYPE(SDR) XMITQ(xmit q_name) CONNAME
('IP_address_of Business_Integration_Conenct_machine (listener_port)%csq;) MAXMSGL(10485760)

Note: On the Business Integration Connect machine, you must have a
channel of type “Server Connection” defined with the same name
you define for the channel here.

d. Define a receiver channel for receiving messages from WebSphere Business
Integration Connect
DEFINE CHANNEL (channel_name) CHLTYPE (RCVR) MAXMSGL(10485760)

e. Define a Remote queue

DEFINE QREMOTE(q_name) RNAME(name_of input_queue_for_Business_Integration_Connect)
RQMNAME (QM_name_used_by Business_Integration_Connect) XMITQ(name_of_transmission_queue)

f. Define a local queue for receiving messages
DEFINE QLOCAL(Input_gname) MAXMSGL(10485760) DEFPSIST(YES);
2. Create the JMS bindings files:
a. Modify the <MQ_JAVA_INSTALL_PATH>\bin\JMSAdmin.config file as follows:
1) Comment out the following line:
INITIAL_CONTEXT_FACTORY=com.sub.jndi.ldap.LdapCtxFactory
2) Uncomment the following line:
INITIAL_CONTEXT_FACTORY=com.sub.jndi.fscontext.RefFSContextFactory

3) Set the PROVIDER_URL variable to point to the directory that where
you want the JMS bindings file to be placed. For example:

PROVIDER_URL=file:/C:/IBM/WebSphereICS/connectors/JMS

Note: This directory must exist, and you must have write permission
for it.

4) Leave the rest of the file as it is.
b. Save your changes.
Create a new file called WBIRetail.jdni with the following content:

JDNI Configured Objects for Information Pipeline
Used by MQSeries JMS*

* ok % X

*

DEFINE QCF(WBIC_JMSQCF) +

TRAN(client) HOST(HOST NAME) PORT(1414) +
CHANNEL (CHANNEL_NAME) ~CLIENTID(' ')

*

* Queues

*

DEFINE Q(INPUTQ) +
QUEUE (INPUTQ) +
TARGCLIENT (JMS)

*

DEFINE Q(REPLYQ) +
QUEUE(REPLYQ) +
TARGCLIENT (JMS)

*

DEFINE Q(REMOTEQ) +
QUEUE (REMOTEQ) +
TARGCLIENT (JMS)
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*

DEFINE Q(ERRORQ) +

QUEUE (ERRORQ) +
TARGCLIENT (JMS)

*

DEFINE Q(IN_PROGRESSQ) +
QUEUE (IN_PROGRESSQ) +
TARGCLIENT (JMS)

*

DEFINE Q(REPLYQ) +

QUEUE (REPLYQ) +
TARGCLIENT (JMS)

*

DEFINE Q(UNSUBSCRIBEQ) +
QUEUE (UNSUBSCRIBEQ) +
TARGCLIENT (JMS)

If you are setting up for setting up for XSD CIP operation, you must also
include the following additional queue declarations:

DEFINE Q(INPUTQ2) +
QUEUE (INPUTQ2) +
TARGCLIENT (JMS)

*

DEFINE Q(REPLYQ2) +
QUEUE (REPLYQ2) +
TARGCLIENT (IMS)

*

DEFINE Q(REMOTEQ2) +
QUEUE (REMOTEQ2) +
TARGCLIENT (JMS)

*

DEFINE Q(ERRORQ2) +
QUEUE (ERRORQ2) +
TARGCLIENT (JMS)

*

DEFINE Q(IN_PROGRESSQ2) +
QUEUE (IN_PROGRESSQ2) +
TARGCLIENT (IMS)

*

DEFINE Q(REPLYQ2) +
QUEUE (REPLYQ2) +
TARGCLIENT (JMS)

*

DEFINE Q(UNSUBSCRIBEQ2) +
QUEUE (UNSUBSCRIBEQ2) +
TARGCLIENT (JMS)

Where HOST _NAME is the name of the host machine, CHANNEL_NAME is
the name of the communications channel, and INPUTQ, REPLYQ,
REMOTEQ , and the other indicated variables are the queue names.

. Save the file. The location that you save the file to does not matter, as long

as it is available when you run the batch file in step

. Move to the <MQ_JAVA_INSTALL_PATH>\bin directory.

On UNIX operating systems:
Run the JMSAdmin.bat file with the following syntax:
./IMSAdmin.sh < WBIRetail.jndi

where WBIRetail.jndi is the file that you created in step



On Windows operating systems:

Run the JMSAdmin.bat file with the following syntax:
JMSAdmin.bat < WBIRetail.jndi

Where WBIRetail.jndi is the file that you created in step The

JMSAdmin.bat and JMSAdmin.sh files create the JMS bindings files, called
.bindings, and puts it in the directory specified by the PROVIDER_URL
variable of the JMSAdmin.config file.

3. Configure this connector to include the connector-specific configuration
properties and appropriate business objects. Use the values shown in the
following tables. The variable my_queue_manager_name represents the name of
the name of the queue manager defined for the WebSphere Interchange Server.

Table 49. Connector-specific properties

Property name

Value

CTX_InitialContextFactory

com.sun.jndi.fscontext.RefFSContextFactory (This is the same name that

you uncommented in the JMSAdmin.config file in step [2a2 on page 33

ReplyToQueue The name of the queue, in full URL format, to which replies are sent. For
example,
queue://my_queue_manager_name/REPLYQ

UnsubscribedQueue The name of the queue, in full URL format, that receives unsubscribed

messages. For example,

queue://my_queue_manager_name/UNSUBSCRIBEQ

CTX_ProviderURL

The fully-qualified path, in full URL format, to the directory that contains
the JMS bindings file. This name must match the value of the
PROVIDER_URL in the JMSAdmin.config file. For example,

file:/C:/IBM/WebSphereICS/connectors/JMS

InProgressQueue

The name of the queue, in full URL format, that holds messages during
processing. For example,

queue//my_queue_manager_name/IN_PROGRESSQ

Error Queue

The name of the queue, in full URL format, that receives messages that
cannot be processed. For example,

queue://my_queue_manager_name/ERROR

DataHandlerConfigMO MO_DataHandler_UCCnet_envelope
ConfigurationMetaObject MO_JMSAdapterConfig
DataHandlerMimeType text/xml

QueueConnectionFactoryName

The name of the queue connection factory. For example, WBIC_JMSQCF.

DefaultVerb

Create

InputQueue The name of the queue, in full URL format, that the connector polls for
new messages. For example,
queue://my_queue_manager_name/INPUTQ
PollQuantity 1
Notes:
a. Add the PollQuantity property if it does not appear in the list of
connector-specific properties.
b. All the queue names defined by the connector-specific properties must be

listed in the WBI Retail.jndi file
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Table 50. Supported business objects

Business object name

Agent support required?

MO_DataHandler_UCCnet_envelope Yes

MO_]JMSAdapterConfig Yes

UCCnetGBO_envelope No
UCCnet]MSDTD_envelope (for DTD support) Yes
UCCnet]MSXSD_envelope (for XSD XML support)

ItemBasic No

4.

Table 51. Associated maps

Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Business object name

Map name

UCCnet]MSDTD_envelope
(when the DTD XML definition
type is used)

UCCnet]MSDTD_envelope_to_UCCnetGBO_envelope

UCCnet]MSXSD_envelope
(when the XSD XML definition
type is used)

UCCnet]MSXSD_envelope_to_UCCnetGBO_envelope

UCCnetGBO_envelope

DTD support
RouterMap_UCCnetGBO_envelope_to_UCCnet)MSDTD_envelope

XSD support
UCCnetGBO_envelope_to_UCCnet]MSXSD_envelope

ItemBasic

DTD support
RouterMap_CwlItemBasic_to_UCCnet)MSDTD_envelope

XSD support, CIN operation
CwltemBasic_to_UCCnet]MSXSD_envelope_registerCommand_item AddChange

XSD support, CIP operation
CwltemBasic_to_UCCnet]MSXSD_envelope_registerCommand_CIP_itemAddChange

5.

6.

Save the configuration (File > Save > To Project), then close the Connector
Configurator.

If you are using WebSphere MQ as your connector transport, create the
JMSConnector queues in WebSphere MQ. To do this, type the following
statements at a command prompt:

runmgsc local_queue_manager_name

DEFINE QLOCAL (AP/JMSCONNECTOR/server name) USAGE (NORMAL)

DEFINE QLOCAL (IC/server_name/JMSCONNECTOR) USAGE (NORMAL)
END

where local_queue_manager is the name of the queue manager used by the IBM
WebSphere Interchange Server, and server_name is the interchange server’s
name.

Refer to the Adapter for JMS User Guide for more information about this connector.

Creating and configuring the second instance of the JMSConnector: If you are
setting up for XSD CIP operation, you need two instances of the JMS connector.
Perform the following steps to configure the second instance:

1.
2.

36 Installation Guide

Open the System Manager.
Save the J]MS2Connector by doing the following:




a.
b.
c.

Open the J]MSConnector.
Click File > Save As > To Project.
Save the connector as JMS2Connector.

3. Create the JMS2Connector Agent, as follows:
On Windows operating systems:

a.
b.

In the Windows task bar, right-click Start and select Open All Users.

Navigate to the folder on your system that contains the installed connectors
by clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.

Copy the JMSConnector short cut and rename it to JMS2Connector.
Right-click the JMS2Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command line
argument to JMS2, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install _path>\connectors\JText\start JMS.bat JMS2 ICS server_ name

On UNIX operating systems:

a.

Access the JMS2Connector Agent program located in the following
directory: <install_path>/IBM/WebSpherelCS/connectors/JMS/.

Run JMS2 by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JMS2 ICS_server_name

Open the JMS2Connector in the Connector Configurator and configure it to
include the connector-specific configuration properties and appropriate business
objects. Use the values shown in the following tables.

Table 52. Connector-specific properties

Property name

Value

CTX_InitialContextFactory

com.sun.jndi.fscontext.RefFSContextFactory (This is the same name that

you uncommented in the JMSAdmin.config file in step [2a2 on page 33

ReplyToQueue The name of the queue, in full URL format, to which replies are sent. For
example,
queue://my_queue_manager_name/REPLYQ2

UnsubscribedQueue The name of the queue, in full URL format, that receives unsubscribed

messages. For example,

queue://my_queue_manager_name/UNSUBSCRIBEQ2

CTX_ProviderURL

The fully-qualified path, in full URL format, to the directory that contains
the JMS bindings file. This name must match the value of the
PROVIDER_URL in the JMSAdmin.config file. For example,

file:/C:/IBM/WebSphereICS/connectors/JMS

InProgressQueue

The name of the queue, in full URL format, that holds messages during
processing. For example,

queue//my_queue_manager_name/IN_PROGRESSQ2

Error Queue

The name of the queue, in full URL format, that receives messages that
cannot be processed. For example,

queue://my_queue_manager_name/ERROR2

DataHandlerConfigMO

MO_DataHandler_UCCnet_envelope

ConfigurationMetaObject

MO_JMSAdapterConfig
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Table 52. Connector-specific properties (continued)

Property name Value

DataHandlerMimeType text/xml

QueueConnectionFactoryName The name of the queue connection factory. For example, WBIC_JMSQCF.
InputQueue The name of the queue, in full URL format, that the connector polls for

new messages. For example,

queue://my_queue_manager_name/INPUTQ2

PollQuantity 1

Notes:

a. Add the PollQuantity property if it does not appear in the list of
connector-specific properties.

b. All the queue names defined by the connector-specific properties must be
listed in the WBI Retail.jndi file

Table 53. Messaging properties

Property name Value

MessagingType MQSERIES

HostName The name of the machine running the WebSphere
Interchange Server.

QueueManagerName The name of the queue manager defined for the
WebSphere Interchange Server.

ClientChannel The name of the MQ channel defined for

WebSphere Interchange Server communication.

Port The port number that the WebSphere Interchange
Server listens on.

Table 54. Supported business objects

Business object name Agent support required?
MO_DataHandler_UCCnet_envelope Yes
MO_]JMSAdapterConfig Yes
UCCnet]MSXSD_envelope Yes
ItemBasic No

5. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 55. Associated maps

Business object name Map name

ItemBasic CwltemBasic_to_UCCnet]MSXSD_envelope_publicationCommand_catalogueltem

6. Save the configuration (File > Save > To Project) then close the Connector
Configurator.

7. If you are using WebSphere MQ as your connector transport, create the
JMS2Connector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:
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runmgsc local_WebSphere ICS_queue_manager_name

DEFINE QLOCAL (AP/JMS2CONNECTOR/ICS server name) USAGE (NORMAL)
DEFINE QLOCAL (IC/ICS_server_name/JMS2CONNECTOR) USAGE (NORMAL)
END

Refer to the Adapter for JMS User Guide for more information about this connector.

Creating and configuring the JTextJMSConnector

Create and configure this connector only if you are using WebSphere Business
Integration Connect and are communicating with UCCnet through the UCCnet
CLU or testing your installation. This is a copy of the JTextConnector used to
simulate the J]MSConnector. Like the JMSConnector, the JTextfMSConnector uses
the IBM WebSphere Business Integration Data Handler for XML and generates the
same XML output. If you are setting up your system to use the XSD CIP operation,
you must create and configure two instances of the JTextfMS connector.

Creating and configuring the first instance of the JTextfMSConnector: To create
the JTextfMSConnector, complete the following steps:

1. Open the System Manager.

2. Save the JTextfMSConnector by doing the following:
a. Open the JTextConnector.
b. Click File > Save As > To Project.
c. Save the connector as JTextfMSConnector.

To configure the JTextfMSConnector, complete the following steps::

1. Configure this connector to include the standard configuration property and
appropriate business objects. Use the values shown in the following tables.

Table 56. Standard property

Property name

Value

ApplicationName

JTextfMSConnector

Table 57. Supported business objects

Business object name

Agent support required?

MO_JTextJMSConnector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
* UCCnet]MSDTD_envelope (when the DTD XML definition Yes

type is used)

* UCCnet]MSXSD_envelope (when the XSD XML definition type

is used)
UCCnetGBO_envelope No
[temBasic No

2. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 58. Associated maps

Business object name

Map name

UCCnet]MSDTD_envelope

UCCnet]MSDTD_envelope_to_UCCnetGBO_envelope

UCCnet]MSXSD_envelope

UCCnet]MSXSD_envelope_to_UCCnetGBO_envelope
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Table 58. Associated maps (continued)

Business object name

Map name

UCCnetGBO_envelope

DTD support
RouterMap_UCCnetGBO_envelope_to_UCCnetfMSDTD_envelope

XSD support
UCCnetGBO_envelope_to_UCCnet]MSXSD_envelope

ItemBasic

DTD support
RouterMap_CwlItemBasic_to_UCCnetfMSDTD_envelope

XSD support, CIN operation
CwltemBasic_to_UCCnet]MSXSD_envelope_registerCommand_itemAddChange

XSD support, CIP operation
CwltemBasic_to_UCCnet]MSXSD_envelope_registerCommand_CIP_itemAddChange
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3. Save to the configuration (File > Save > To Project), then close the Connector
Configurator.

4. Create the JTextfMSConnector Agent, as follows:
Windows operating systems:
a. In the Windows task bar, right-click Start and select Open All Users.

b. Navigate to the folder on your system that contains the installed connectors
by clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.

c. Copy the JText Connector short cut and rename it to JTextfMS Connector.
Right-click the JTextfMS Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command line
argument to JText]MS, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install_path>\connectors\JText\start_JText.bat JTextIMS ics_server_name

UNIX operating systems:

a. Access the JTextfMSConnector Agent program located in the following
directory: <install_path>/IBM/WebSpherelCS/connectors/]Text/.

b. Run JText]MS by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JTextJMS ICS_server_name

5. If you are using WebSphere MQ as your connector transport, create the
JTextfMSConnector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:
runmgsc local_WebSphere_ICS_queue_manager_name
DEFINE QLOCAL (AP/JTEXTJMSCONNECTOR/ICS_server_name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS_ server_name/JTEXTJMSCONNECTOR) USAGE (NORMAL)
END

Creating and configuring the second instance of the JTextfMSConnector: To
create the JTextfMS2Connector, complete the following steps:

1. Open the System Manager.

2. Save the JTextfMS2Connector by doing the following:

a. Open the JTextfMSConnector.




b.
c.

Click File > Save As > To Project.
Save the connector as JTextfMS2Connector.

Perform the following steps to configure the JTextfMS2Connector:

1. Configure this connector to include the standard configuration property and
appropriate business objects. Use the values shown in the following tables.

Table 59. Standard property

Property name

Value

ApplicationName

JTextfMS2Connector

Table 60. Supported business objects

Business object name

Agent support required?

MO_JTextJMS2Connector_Default Yes
MO_DataHandler_UCCnet_envelope Yes
UCCnet]MSXSD_envelope Yes
ItemBasic No

2. Save the configuration (File > Save > To Project), then go back to the
Associated Map tab and set the explicit bindings.

Table 61. Associated maps

Business object name

Map name

ItemBasic

CwltemBasic_to_UCCnet]MSXSD_envelope_publicationCommand_catalogueltem

Save to the configuration (File > Save > To Project), then close the Connector
Configurator.

Create the JTextfMS2Connector Agent, as follows:

Windows operating systems:

a.
b.

In the Windows task bar, right-click Start and select Open All Users.

Navigate to the folder on your system that contains the installed connectors
by clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.

Copy the JText Connector short cut and rename it to JTextfMS2 Connector.
Right-click the JTextfMS2Connector short cut and select Properties.

Click the Short cut tab, edit the Target field, and set the first command line

argument to JTextfMS2, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install_path>\connectors\JText\start_JText.bat JTextIMS2 ics_server_name

UNIX operating systems:

a.

Access the JTextfMSConnector Agent program located in the following
directory: <install_path>/IBM/WebSpherelCS/connectors/JText/.

Run JText]MS2 by switching to this directory and entering the following
command, where ICS_server_name refers to the name of the InterChange
Server:

start_JText.sh JTextJIMS2 ICS server_name

If you are using WebSphere MQ as your connector transport, create the
JTextIMS2Connector queues in WebSphere MQ. You must create the following
queues as local queues and accept the defaults, where
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local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmgsc local WebSphere ICS queue _manager _name

DEFINE QLOCAL (AP/JTEXTIMS2CONNECTOR/ICS server name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS_server_name/JTEXTJMS2CONNECTOR) USAGE (NORMAL)
END

Configuring the PortConnector
Perform the following steps to configure the PortConnector:

1. Configure this connector to include the appropriate business object. Use the

value shown in the following table.

Table 62. Supported business object

Business object name

Agent support required?

ItemBasic

Yes

UCCnetGBO_envelope

Yes

Save the configuration file (File > Save > To Project).

If you are using WebSphere MQ as your connector transport, create the
PortConnector queues in WebSphere MQ. You must create the following queues
as local queues and accept the defaults, where
local_WebSphere_ICS_queue_manager_name refers to the queue manager used by
the IBM WebSphere InterChange Server and ICS_server_name refers to the name
of the InterChange Server. Enter the following at a command prompt:

runmqgsc local_WebSphere_ICS_queue_manager_name

DEFINE QLOCAL (AP/PORTCONNECTOR/ICS server_name) USAGE (NORMAL)

DEFINE QLOCAL (IC/ICS server_name/PORTCONNECTOR) USAGE (NORMAL)
END

Configuring the EmailConnector
To create the EmailConnector, complete the following steps:

1. In the Windows task bar, right-click Start and select Open All Users.
2. Navigate to the folder on your system that contains the installed connectors by

clicking Programs > IBM WebSphere Business Integration Adapters >
Adapters > Connectors.
Right-click the Email Connector and select Properties > Modify.

Click the Short cut tab, edit the Target field, and set the first command line
argument to EMail, where ICS_server_name refers to the name of the
InterChange Server, as shown in the following example:

<install _path>\connectors\email\start _email.bat

EMail ICS_server_name

Configure the EmailConnector to include the following configuration property.
Use the value shown in the following table.

Table 63. Connector-specific property

Property name

Property value

SMTP_MailHost

Hostname or IP address of a mail server.

42  Installation Guide

6. Save the configuration (File > Save > To Project).



Configuring the SAPConnector

If you are using SAP as the source for your item information, configure the
SAPConnector according to the Adapter for mySAP.com (SAP R/3 V.4.x) User
Guide. Configure the connector to include the appropriate business objects. Use the
values shown in the following table.

Table 64. Supported business objects

Business object name

Agent support required?

SAP4_MatlBasic

Yes

ItemBasic

No

Save the configuration (File > Save > To Project), then go back to the Associated
Map tab and set the explicit bindings.

Table 65. Associated maps

Business object name Map name
SAP4_MatlBasic Sa4CwltemBasic
ItemBasic CwSa4ltemBasic

Save the configuration (File > Save > To Project).

A TestConnector can be used to simulate a SAP connection (refer to
the TestConnector”| for details). If you are going to use the TestConnector, you
must also save the SAP connector configuration to a file (File > Save > To File).
However, if you are connecting to a live SAP system, refer to the document
Adapter for mySAP.com (SAP R/3 V.4.x) User Guide for additional configuration
steps.

Configuring the TestConnector
The SAPConnector Agent can be simulated using a TestConnector if a live SAP
installation is not available.

1. By referring to the section [‘Configuring the SAPConnector,”| configure the
SAPConnector to include the appropriate business objects and save the
configuration to a file.

2. Start the Start > Programs > IBM WebSphere InterChange Server > IBM
WebSphere Business Integration Toolset > Development > Test Connector
shortcut.

3. Select File > Create/Select Profile.
4. On the Connector Profile window, select File > New Profile.

5. In the New Profile window, provide the path to the connector configuration file
saved in Step 1 above. The Connector Name for this example is SAPConnector.
Choose the Broker Type from the drop-down list, and fill in the InterChange
Server name and password. Finally, click OK to save the profile.

6. In the Connector Profile window, select the profile just created.

7. Click OK at the bottom of the window, which will return to the main VTC
window.

8. To make the connection with the InterChange Server, select File > Connect.
When the connection is complete, the message SAPConnector Ready and the
date and time are displayed at the bottom of the window.

Creating and configuring the collaboration objects

Use the information provided in this section to bind the ports and set the attribute
values of various collaboration objects. When you have completed creating and
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configuring the collaboration objects, proceed to the section [‘Configuring the|

frelationships before deployment” on page 54

Note: In the tables in this section, some values in the table columns might include
spaces to allow them to fit in the table cells. The actual values do not
include spaces.

Creating and configuring a UCCnet_ItemSync collaboration
object and making its port connections
1. Create and configure the following collaboration object based on the

UCCnet_ItemSync collaboration template.

Table 66. Collaboration object name: UCCnet_ltemSyncObject

Port Type Bind to
DestinationAppRetrieve | Connector PortConnector

From Connector Source application’s connector
To

DTD support

XSD support

Connector

Collaboration object

DTD support

XSD support

AS2 channel connector

ItemCommandRouter_Obj:From

2. Set the tracing level for the object.

3. Configure the collaboration object properties using the values from the

following table.

Table 67. UCCnet_ltemSyncObject collaboration object configuration properties

Property name

Property description

Required

AUDITLOG_INSTANCE_NAME

Identifies the tag in the UCCnet section
within the InterchangeServer.cfg file under
which other tags needed for audit logging
are contained. The default value is UCCnet.
This value must be correct for the
CSIAuditLogger class to find the database
information to make audit log entries.

Yes

GtinDB_USER

The user ID used to connect to the
database containing the
PROCESSED_GTIN and trading_partner
tables.

Yes

GtinDB_PASSWORD

The password for the GtinDB_USER.

Yes

JDBC_DRIVER

Pointer to the driver used to connect to the
database containing the
PROCESSED_GTIN and trading_partner
tables.

It is required if the
InterChange Server
does not register the
driver in the Java
Virtual Machine (JVM).
The Microsoft SQL
driver, for example, is
already registered in the
JVM by the InterChange
Server and does not
need to be specified.

JDBC_URL

The JDBC URL corresponding to the
JDBC_DRIVER specified.

Yes
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Table 67. UCCnet_ltemSyncObject collaboration object configuration properties (continued)

Property name Property description Required

SEND_EMAIL_TO Defines the email address to which No. Requires the Email
problems detected during execution of Connector to run if
collaboration object processing are sent. email is entered. The
This entry is for InterChange Server SEND_EMAIL property
administrators. Do not confuse this must be set also.

property with the Email notification
address field, which is configured from the
Collaboration General Properties tab when
creating a collaboration object.

SEND_EMAIL Dictates whether email is sent to the Yes, if you want to send
address set in the SEND_EMAIL_TO email. To send email,
property. set it to the value all.

Otherwise, set the value
to none.

SUPPLIER_NAME The name of the partner that is No

synchronizing item information with
UCCnet. This value is logged in audit
entries. A sample entry is SAP.

Creating and configuring the temCommandRouter collaboration
object and making its port connections

This object is only required for schema (XSD) support. It is not used for DTD
support. There are two possible ways to configure this collaboration object,
depending on whether you implement your own data pool (CIN operation) or use
UCCnet as a data pool (CIP operation).

1. Create and configure the following collaboration object based on the
ItemCommandRouter collaboration template:

Table 68. Collaboration object name: ItemCommandRouter_Obj

Port Type Bind to
From Collaboration object UCCnet_ItemSyncObject:To
ToCIN_CI Collaboration object

For CIN operation
CIN_CIP_Dispatcher_forICR_Obj:From

For CIP operation
ItemCommandRouter_DE_LIST_WITHDRAWODbject:
FromItemBasic

ToRCIR Connector AS2 channel connector

Note: For CIP operation, the ToCin_CI port is configured to send an email
indicating that delist and withdrawal actions are not supported.

2. Set the tracing level for the object.

Creating and configuring CIN_CIP_Dispatcher collaboration
objects and making their port connections

This collaboration object is only created if you are using schema (XSD) support. If
you are setting up for CIN operation, you will need to create two objects. If you
are setting up for CIP operation, you only need one. Complete the following steps:

1. Create and configure the following collaboration objects based on the
CIN_CIP_Dispatcher collaboration template:

Installation guide 45



Table 69. Collaboration object name: CIN_CIP_Dispatcher_forPWL_Obj. Used for both CIN and CIP operation

Port Type Bind to
From Collaboration object CIN operation
UCCnet_processWorklist:
RCIR_RESPONSE
CIP operation
UCCnet_processWorklist:
PUBLICATION_CMD_RESPONSE
To Connector AS2 channel connector
DestinationAppRetrieve Connector PortConnector

Table 70. Collaboration object name: CIN_CIP_Dispatcher_forlCR_Obj.

Used for CIN operation only

Port Type Bind to

From Collaboration object ItemCommandRouter_Obj:ToCIN_CI
To Connector AS2 channel connector
DestinationAppRetrieve Connector PortConnector

2. Set the tracing level for each object.

3. Configure the collaboration object properties using the values from the
following table. Both collaboration objects use the same property values.

Table 71. CIN_CIP_Dispatcher_forPWL_Obj and CIN_CIP_Dispatcher_forlICR_Obj collaboration object configuration

properties

Property name

Property description

Required

AUDIT_LOG_INSTANCE_NAME

Identifies the tag in the UCCnet section the
InterchangeServer.cfg file that contains the
other tags needed for audit logging. This
value must be correct for the
CSIAuditLogger class to find the database
information to make audit log entries.
Default:

UCCnet

Yes

DISPATCHER_GLN_FILE

The fully qualified name of the file that holds
the GLNs subscribed to each category code.
Default:

C:\IBM\WebSphereICS\UCCnet \
\dispatcher_gin_file.txt

Yes

GLN_ATTRIBUTE

Identifies where in the UCCnetGBO business
object the GLN retrieved from the Dispatcher
GLN file should be placed. Values to use:

For CIN operation (default):

ROOT.body[0] .transaction.command
[0] .notifyCommand.notifyCommand
Operand.catalogueltemNotificati
on.catalogueltem.dataRecipient

—

For CIP operation:

ROOT.body[0] . transaction.command
[0] .pubTicationCommand.publicat
ionCommandOperand.catalogueltem
Publication.publishToGLN

—
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Table 71. CIN_CIP_Dispatcher_forPWL_Obj and CIN_CIP_Dispatcher_forICR_Obj collaboration object configuration
properties (continued)

Property name Property description Required

SUPPLIER_NAME The name of the partner responsible for No
synchronizing item information with
UCCnet. SAP, for example. This value is
logged in audit entries. No default value.

TO_UCCNETGBO_PROCESSING_MAP Called by the CIN_CIP_Dispatcher object to | Yes
map incoming item basic objects to the
outgoing Catalogue Item Notification or
Cataloge Item Publication message. Value:

For CIN operation (default):

CwItemBasic_to UCCnetGBO_envel \
ope_notifyCommand_catalogu \
eltem

For CIP operation

CwItemBasic_to_UCCnetGBO_env_pub \
TicationCommand_catalogueltemPu \
blication

TOPIC_ATTRIBUTE Identifies where in the UCCnetGBO business
object the collaboration should get the topic
value used for audit logging. Values to use:

For CIN operation (default):

ROOT.body[0] .transaction.command
[0] .notifyCommand.notifyComman
dOperand.catalogueltemNotifica
tion.notificationTopic.topic

—

For CIP operation:

ROOT.body[0].transaction.comman \
d[0] .publicationCommand.publi \
cationCommandHeader.type

Note: The GLN_DISPATCHER file contains one or more category codes with a
list of subscribing retailers after each category code. For example:

UDEX.01.0020.0855
7789333000026
7789333000027
7789333000028

UDEX.05.0139.0334
7789333000026
7789333000027
7789333000028
7789333000029
7789333000030
7789333000031

Here, UDEX.01.0020.0855 and UDEX.05.0139.0334 are the category codes.

The numbers underneath each category code are the GLNs for the
subscribing retailers.
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Creating and configuring a UCCnet_requestWorklist
collaboration object and making its port connections

1. Create and configure the following collaboration object based on the
UCCnet_requestWorklist collaboration template.

Table 72. Collaboration object name: UCCnet_requestWorklistObject

Port Type Bind to
DestinationAppRetrieve Connector PortConnector

From Connector JTextRWLConnector
To Connector AS2 channel connector

2. Set the tracing level for the object.

3. Configure the collaboration object properties using the values from the

following table.

Table 73. UCCnet_requestWorklistObject collaboration object configuration properties

Property name

Property description

Required

DTD_URL

Sets the value for the DocType line in outgoing XML.

The default value is:

DOCTYPE envelope SYSTEM "http://www.uccnet.net/ \

xmlschema/2.2/Envelope.dtd"

For schema support, the value is left blank.

No, unless the default value is
incorrect for the environment
to which the XML messages
are being sent.

SET_UNIQUE_IDS

Controls whether unique IDs
uniqueCreateorIdentification)

XML messages. Possible values for this property are:
* ALL (the default value — set all three unique IDs)

* NONE

* BLANK (set unique ID only if it is blank in the input)

No, unless the default value
needs to be changed.

(messageldentifier and
are set in the output

Creating and configuring a UCCnet_processWorklist
collaboration object and making its port connections

1. Create and configure the following collaboration object based on the
UCCnet_processWorklist collaboration template:

Table 74. Collaboration object name: UCCnet_processWorklistObject

Port

Type

Bind to

AUTHORIZATION_RESPONSES

Collaboration object

UCCnet_processWorklist AUTHORIZATION _RESPONSESObject:From

CATALOGUE_ITEM
_CONFIRMATION

DTD support
Connector

XSD support
Collaboration object

DTD support
PortConnector

XSD support
UCCnet_processWorklist CATALOGUE_ITEM
_CONFIRMATIONODbject:From

CATEGORY_ADD_CHANGE

Collaboration object

UCCnet_processWorklist CATEGORY_ADD _CHANGEODject:From

CI_RESPONSE

DTD support
Connector

XSD support, CIN operation
Connector

XSD support, CIP operation
Collaboration object

DTD support
PortConnector

XSD support, CIN operation
PortConnector

XSD support, CIP operation
UCCnet_processWorklist_CI_RESPONSEObject:From
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Table 74. Collaboration object name: UCCnet_processWorklistObject (continued)

Port

Type

Bind to

CIN_RESPONSE

DTD support
Connector

XSD support, CIN operation
Collaboration object

XSD support, CIP operation
Connector

DTD support
PortConnector

XSD support, CIN operation
UCCnet_processWorklist_CIN_RESPONSEODbject:From

XSD support, CIP operation
PortConnector

CIP_RESPONSE

DTD support
Connector

XSD support, CIN operation
Connector

XSD support, CIP operation
Collaboration object

DTD support
PortConnector

XSD support, CIN operation
PortConnector

XSD support, CIP operation
UCCnet_processWorklist_CIP_RESPONSEODbject:From

DEAD_LETTER_PUB_RECEIPT

Collaboration object

UCCnet_processWorklist DEAD_LETTER_PUB _RECEIPTObject:From

DestinationAppRetrieve

Connector

PortConnector

FAILURE Collaboration object UCCnet_processWorklist_ FAILURE_RESPONSEODbject:From
From Connector AS2 channel connector
INITIAL_ITEM_LOAD _REQUEST Connector AS2 channel connector
ITEM_ADD_CHANGE Connector AS2 channel connector
NEW_ITEM_PUBLICATION Connector AS2 channel connector

_REQUEST

PUBLICATION_CMD_RESPONSE

DTD support
Connector

XSD support, CIN operation
Connector

XSD support, CIP operation
Collaboration object

DTD support
PortConnector

XSD support, CIN operation
PortConnector

XSD support, CIP operation
CIN_CIP_Dispatcher_forPWL_Obj:From

RCIR_RESPONSE

DTD support
Connector

XSD support, CIN operation
Collaboration object

XSD support, CIP operation
Connector

DTD support
PortConnector

XSD support, CIN operation
CIN_CIP_Dispatcher_forPWL_Obj:From

XSD support, CIP operation
Second instance of the AS2 channel connector

RCIR_QUERY_RESPONSE

DTD support
Connector

XSD support
Collaboration object

DTD support
PortConnector

XSD support
UCCnet_processWorklist_RCIR_QUERY
_RESPONSEODbject:From

SIMPLE_RESPONSE

Collaboration object

UCCnet_processWorklist_SIMPLE_RESPONSEObject:From

UNKNOWN_MESSAGES

Collaboration objet

UCCnet_processWorklist UNKNOWN_MESSAGESObject:From

UNKNOWN_RESPONSE

Collaboration object

UCCnet_processWorklist UNKNOWN_RESPONSEObject:From

2. Set the tracing level for the object.

3. Configure the collaboration object properties using the values from the

following table.
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Table 75. UCCnet_processWorklistObject collaboration object configuration properties

Property name

Property description

Required

AUDITLOG_INSTANCE_NAME

Identifies the tag in the UCCnet section
within the InterchangeServer.cfg file under
which other tags needed for audit logging
are contained. The default value is UCCnet.
This value must be correct for the
CSIAuditLogger class to find the database
information to make audit log entries.

Yes

AUTO_RESPOND

Controls whether an automatic response is
sent to UCCnet. The default value is: YES.

No, unless the default
value needs to be

outgoing XML. The default value is:

DOCTYPE envelope SYSTEM \
"http://www.uccnet.net/ \
xmlschema/2.2/Envelope.dtd"

For schema support, the value is left blank.

changed.
DB_PASSWORD The password for the DB_USER. Yes
DB_USER The user of the database associated with Yes
the WebSphere business integration system.
DTD_URL Sets the value for the DocType line in No, unless the default

value is incorrect for the
environment to which
the XML messages are
being sent.

JDBC_DRIVER

Pointer to the driver code used to connect
to the database associated with the
WebSphere business integration system.

Only if the InterChange
Server does not register
the driver in the JVM.
The Microsoft SQL
driver, for example, is
already registered in the
JVM by the InterChange
Server and does not
need to be specified.

JDBC_URL

The JDBC URL corresponding to the
JDBC_DRIVER specified.

Yes

SEND_EMAIL_TO

Defines the email address to which
problems detected during execution of the
collaboration object are sent. This entry is
for InterChange Server administrators. Do
not confuse this property with the Email
notification address field, which is
configured from the Collaboration General
Properties tab when creating a
collaboration object.

No. Requires the Email
Connector and a valid
entry in this field to
send email. If this field
is left blank, no email is
sent.

SUPPLIER_NAME

The name of the partner that is
synchronizing item information with
UCCnet. This value is logged in audit
entries. A sample entry is SAP.

Creating and configuring Notify_by eMail collaboration objects
and making their port connections
When using a DTD implementation, you must create and configure seven
collaboration objects based on the Notify_by_eMail collaboration template. When
using a schema implementation, you must create and configure either ten or
twelve, depending on whether you are using CIN or CIP operation. To do this,
complete the following steps:
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1. Create and configure the following collaboration objects based on the
Notify_by_eMail collaboration template:

Table 76. Collaboration object name: UCCnet_processWorklist. AUTHORIZATION_RESPONSESODbject. Used for
both DTD and XSD support

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject: AUTHORIZATION_RESPONSES
FromlItemBasic Connector PortConnector

Table 77. Collaboration object name: UCCnet_processWorklist. CATEGORY_ADD_CHANGEObject. Used for both
XSD and DTD support

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject: CATEGORY_ADD_CHANGE
FromItemBasic Connector PortConnector

Table 78. Collaboration object name: UCCnet_processWorklist DEAD_LETTER_PUB_RECEIPTObject. Used for

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject: DEAD_LETTER_PUB_RECEIPT
FromlItemBasic Connector PortConnector

Table 79. Collaboration object name: UCCnet_processWorklist SIMPLE_RESPONSEObject. Used for both DTD and

XSD support

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject:SIMPLE_RESPONSE
FromItemBasic Connector PortConnector

Table 80. Collaboration object name: UCCnet_processWorklist. UNKNOWN_MESSAGESObject. Used for both DTD

and XSD support

Port

Type

Bind to

From

Collaboration object

UCCnet_processWorklistObject: UNKNOWN_MESSAGES

FromlItemBasic

Connector

PortConnector

Table 81. Collaboration object name: UCCnet_processWorklist UNKNOWN_RESPONSEObject. Used for both DTD

and XSD support

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject: UNKNOWN_RESPONSE
FromItemBasic Connector PortConnector

Table 82. Collaboration object name: UCCnet_processWorklist FAILURE_RESPONSEObject. Used for both DTD

and XSD support

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject:FAILURE
FromItemBasic Connector PortConnector
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Table 83. Collaboration object name: UCCnet_processWorklist. CATALOGUE_ITEM_CONFIRMATIONObject. Used
for XSD support only (CIN and CIP operation)

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject: CATALOGUE_ITEM_CONFIRMATION
FromlItemBasic Connector PortConnector

Table 84. Collaboration object name: UCCnet_processWorklist. RCIR_QUERY_RESPONSEObject. Used for XSD
support only (CIN and CIP operation)

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject:RCIR_QUERY_RESPONSE
FromItemBasic Connector PortConnector

Table 85. Collaboration object name: UCCnet_processWorklist CI_ RESPONSEObject. Used for XSD support only

(CIP operation)

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject:CI_RESPONSE
FromlItemBasic Connector PortConnector

Table 86. Collaboration object name: UCCnet_processWorklist_ CIP_RESPONSEObject. Used for XSD support only

(CIP operation)

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject:CIP_RESPONSE
FromItemBasic Connector PortConnector

Table 87. Collaboration object name: ItemCommandRouter_DE_LIST_WITHDRAWODbject. Used for XSD support

only (CIP operation)

Port Type Bind to
From Connector PortConnector
FromItemBasic Collaboration object |ItemCommandRouter_Obj:ToCIN_CI

Table 88. Collaboration object name: UCCnet_processWorklist_ CIN_RESPONSEObject. Used for XSD support only

(CIN operation)

Port Type Bind to
From Collaboration object | UCCnet_processWorklistObject:CIN_RESPONSE
FromItemBasic Connector PortConnector
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2. Set the tracing level for each object.

3. Configure each collaboration object’s properties using the values from the
following table.

Note: Several sample email files exist in the following directory:

Windows operating systems

<ICS installation_path>\Samples\UCCnet\collaborations\eMail

UNIX operating systems

You must FTP (ASCII mode) the email files to a directory on
your UNIX system.




All of the collaboration objects based on the Notify_by_eMail
collaboration template must have their properties updated to point to the
correct location of these sample files or to your own custom email files.

Table 89. Notify_by eMail collaboration object configuration properties. Use the values in this table for all of the
following collaboration objects:

ItemCommandRouter_DE_LIST_WITHDRAWODbject

UCCnet_processWorklist. AUTHORIZATION_RESPONSESObject

UCCnet_processWorklist. CATALOGUE_ITEM_CONFIRMATIONObject
UCCnet_processWorklist. CATEGORY_ADD_CHANGEODbiject
UCCnet_processWorklist DEAD _LETTER_PUB_RECEIPTObject
UCCnet_processWorklist_FAILURE_RESPONSEObject

UCCnet_processWorklist SIMPLE_RESPONSEODbject

UCCnet_processWorklist. UNKNOWN_MESSAGESObject

UCCnet_processWorklist UNKNOWN_RESPONSEObject

UCCnet_processWorklist. CATALOGUE_ITEM_CONFIRMATIONODbject (used with schema support only)
UCCnet_processWorklist_Cl_RESPONSEODbject (used with schema support only)
UCCnet_processWorklist_CIP_RESPONSEODbject (used with schema support only)
UCCnet_processWorklist CIN._ RESPONSEObject (used with schema support only)
UCCnet_processWorklist. RCIR_QUERY_RESPONSEODbject (used with schema support only)

Property name Property description Required

EMAIL_MESSAGE Body of the email. The processing of this field uses the Yes
same variables as the EMAIL_SUBJECT property. It also
processes values beginning with the @ sign in the same
manner. For example, in the following, the first character
of the string is an @ sign, so the collaboration object loads
the text from the filename following the @ sign:
@c:\IBM\WebSphereICS\UCCnet\collaborations\eMail\ \
UCCnet_processWorklist_AUTHORIZATION_RESPONSES.mail

EMAIL_NOTIFICATION_RCPTS Email address of the recipients. Yes
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Table 89. Notify_by eMail collaboration object configuration properties (continued). Use the values in this table for
all of the following collaboration objects:

ltemCommandRouter_DE_LIST_WITHDRAWObject

UCCnet_processWorklist. AUTHORIZATION_RESPONSESODbject

UCCnet_processWorklist. CATALOGUE_ITEM_CONFIRMATIONODbject
UCCnet_processWorklist. CATEGORY_ADD_CHANGEObject

UCCnet_processWorklist DEAD_LETTER_PUB_RECEIPTObject

UCCnet_processWorklist FAILURE_RESPONSEObject

UCCnet_processWorklist_ SIMPLE_RESPONSEODbject

UCCnet_processWorklist UNKNOWN_MESSAGESODbject

UCCnet_processWorklist UNKNOWN_RESPONSEObject

UCCnet_processWorklist_ CATALOGUE_ITEM_CONFIRMATIONODbject (used with schema support only)
UCCnet_processWorklist_ Cl_RESPONSEObject (used with schema support only)
UCCnet_processWorklist_CIP_RESPONSEODbject (used with schema support only)
UCCnet_processWorklist_ CIN_RESPONSEObject (used with schema support only)
UCCnet_processWorklist_ RCIR_QUERY_RESPONSEObject (used with schema support only)

Property name

Property description Required

EMAIL_SUBJECT

Subject line of the email. This value can contain variables | Yes
in the form ${variable_name} into which the collaboration
object substitutes data from the business object
dynamically. Type text using the following escape codes:

+ ${getRoot} — substitutes the entire triggering business
object.

* ${getDate} — substitutes the current date and time.

* ${getName} — substitutes the name of the triggering
business object.

+ ${getVerb} — substitutes the verb of the triggering
business object.

e ${attribute} — substitutes the value of the named
attribute from the triggering business object. If the value
for the variable_name does not match one of the specific
values above, the collaboration object interprets it as the
name of a business object attribute.

If the first character of the string for this value is an @
sign, the collaboration object loads the text from a
filename following the @ sign.

See the [Solution development guide for information about
how the solution handles sending email and for a sample
value for this property.

Configuring the relationships before deployment
Set up the relationships, as follows:
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1.

2.

In the System Manager, navigate to the Static relationships in the Integration
Component Library.

Open the Relationship Designer tool by selecting a relationship and choosing

Edit Definition from the right-click menu or, alternatively, by double-clicking
any one of the static relationships directly.




3. Verify the URL and DBMS type values for each relationship in the Advanced
Settings view by selecting each relationship and choosing Advanced Settings
from the right-click menu. These values must agree with the global DBMS
settings for the rest of the server configuration.

4. Save any revised settings. Note that each relationship must be saved
individually (do not use the Save All menu option).

5. Select each relationship to be saved and choose Save from right-click menu.

Note: If you are using DB2, the relationships contain SQL stored procedures.
DB2 requires that a C compiler be installed on the same server on which
the InterChange Server resides so that the stored procedures can be
compiled during the relationship deployment. This is not required for
Microsoft SQL Server or Oracle databases.

Note: After the relationships have been deployed as a result of the steps in the
section [“Deploying the solution,”] you must then populate the relationships
with default values and make modifications needed in the default schemas.
See the section [“Populating the relationships after deployment”| for more
information.

Deploying the solution
Deploy the solution, as follows:

1. After all of the components of the solution have been configured, compile the
maps and collaboration templates in the System Manager.

2. Create a User Project that contains all of the solution components.

3. Use the Deploy wizard to deploy the solution to the WebSphere InterChange
Server (running in design mode). The wizard allows you to choose what parts
of the solution to deploy. It is recommended that you deploy the solution in
stages, as follows:

a. Deploy the business objects.

b. Deploy the maps. Ensure that you have checked the Compile option.

c. Deploy the relationships. Ensure that you have checked the Create schema
option.

d. Deploy the connectors.

e. Deploy the collaboration templates. Ensure that you have checked the
Compile option.

f. Restart the WebSphere InterChange Server.

g. From the Component Management window of the System Manager, start
the relationships.

h. Deploy the collaboration objects.

Populating the relationships after deployment

After the relationships have been deployed as a result of the steps in the section
|”Deploying the solution,”| you must then populate the relationships with default
values and make modifications needed in the default schemas by completing the
following steps. Be sure to follow the instructions appropriate for your platform
where indicated.

Windows operating systems

DB2:
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Start a DB2 session by opening a DB2 command window by clicking Start >
Programs > IBMDB2 > Command Line Tools > Command Window.
Move to the following directory:

<ICS_installation_path>\collaborations\dependencies\ \

UCCnet\db2

At the prompt, enter the following command: db2 connect to <repository_name>
USER <userid> USING <password> where <repository_name> is the name of
your WebSphere InterChange Server repository database, and <userid> and
<password> are the ID and password that were used to create it.

After you are connected:

* For solutions implemented with DTD support, enter the command db2 <
InitializeRelationshipTables.sql to run the script.

* For solutions implemented with schema support, enter the command db2 <
InitializeRelationshipTablesForXSD.sql to run the script.

Oracle:

1.

Move to the following directory:

<ICS_installation_path>\collaborations\dependencies\ \
UCCnet\oracle

Enter the following command:
* For solutions implemented with DTD support:
sqlplus dbuser/passwd@SID @InitializeRelationshipTables.sql
 For solutions implemented with schema support:
sqlplus dbuser/passwd@SID @InitializeRelationshipTablesForXSD.sql
You might have to enable autoextension of the CWRepository data file. Select

the AUTOEXTEND option on the Storage tab for the data file in the DBA
Studio.

Microsoft SQL Server:

1.

Move to the following directory:

<ICS_installation_path>\collaborations\dependencies\ \
UCCnet\mss

Select the CWRepository database in the drop-down in the menu bar.
Execute the following script by using the Query Analyzer tool:

* For solutions implemented with DTD support,
InitializeRelationshipTables.sql

* For solutions implemented with schema support,
InitializeRelationshipTablesForXSD.sql

UNIX operating systems

DB2:

1.

2.

Transfer the

<ICS installation_path>\collaborations\dependencies\UCCnet\db2
\InitializeRelationshipTables file or
<ICS_installation_path>\collaborations\dependencies\UCCnet\db2
\InitializeRelationshipTablesForXSD file to the UNIX system using FTP in
ASCII mode. Place it in the
<ICS_installation_path>/collaborations/dependencies/UCCnet/db2 directory.

Move to the following directory on the UNIX system:



<ICS_installation_path>/collaborations/dependencies/ \
UCCnet/db2

3. Start a DB2 session by entering the command db2.
4. At the prompt, enter the command connect to repository_name.
5. After you are connected:
* For solutions implemented with DTD support, enter the command
<InitializeRelationshipTables.sql to run the script.

 For solutions implemented with schema support, enter the command
<InitializeRelationshipTablesForXSD.sql to run the script.

Oracle:
1. Transfer the <ICS_installation_path>\collaborations\dependencies\UCCnet
\oracle\InitializeRelationshipTables file or
<ICS installation_path>\collaborations\dependencies\UCCnet\db2
\InitializeRelationshipTablesForXSD file to the UNIX system using FIP in
ASCII mode. Place it in the
<ICS_installation_path>/collaborations/dependencies /UCCnet/oracle
directory.
2. Move to the following directory on the UNIX system:
<ICS installation_path>/collaborations/dependencies/ \
UCCnet/oracle
3. Enter the following command:
¢ For solutions implemented with DTD support:
sqlplus dbuser/passwd@SID @InitializeRelationshipTables.sql
* For solutions implemented with schema support:
sqlplus dbuser/passwd@SID @InitializeRelationshipTablesForXSD.sql

You might have to enable autoextension of the CWRepository data file. Select
the AUTOEXTEND option on the Storage tab for the date file in the DBA
Studio.

Populating the trading_partner table
After running the InitialiseRelationshipTables or InitialiseRelationshipTablesForXSD

script, you must manually populate the trading_partner table with the correct GLN
SOURCE and TARGET information.

The following example adds a SOURCE row. The SOURCE entry indicates your
own GLN, and so the table should have only one SOURCE record.

insert into trading_partner (gln_code, trading_partner_name, trading_partner_contact,
trading_partner_group, trading_partner_type, initial_load_flag)
values ('0000000000001',"'ACME Inc.','Mr. Acme', 'Group 1','SOURCE','Y')

The next example adds a TARGET entry to the table. The TARGET entries record
your trading partners” GLNs, so table can have multiple TARGET records.

insert into trading_partner (gln_code, trading_partner_name, trading_partner_contact,
trading_partner_group, trading_partner_type, initial_load_flag)
values ('0000000000002','Green Co.','Ms. Green','Group 1','TARGET','N')
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Notices and Trademarks

Proprietary Information
US Government Users Restricted Rights - Use, duplication or disclosure restricted
by GSA ADP Schedule Contract with IBM Corp.

Notices

IBM may not offer the products, services, or features discussed in this document in
all countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
US.A.

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or program(s) described in this publication
at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
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programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Burlingame Laboratory Director
IBM Burlingame Laboratory

577 Airport Blvd., Suite 800
Burlingame, CA 94010

US.A

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurement may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not necessarily tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

This information may contain examples of data and reports used in daily business

operations. To illustrate them as completely as possible, the examples may include

the names of individuals, companies, brands, and products. All of these names are

fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

COPYRIGHT LICENSE

This information may contain sample application programs in source language,
which illustrates programming techniques on various operating platforms. You
may copy, modify, and distribute these sample programs in any form without
payment to IBM, for the purposes of developing, using, marketing or distributing
application programs conforming to the application programming interface for the
operating platform for which the sample programs are written. These examples
have not been thoroughly tested under all conditions. IBM, therefore, cannot
guarantee or imply reliability, serviceability, or function of these programs.

Programming interface information

Programming interface information, if provided, is intended to help you create
application software using this program.
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General-use programming interfaces allow you to write application software that
obtain the services of this program’s tools.

However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.

Warning: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks and service marks

The following terms are trademarks or registered trademarks of International
Business Machines Corporation in the United States or other countries, or both:

IBM

the IBM logo
AIX

AS/400e
CrossWorlds
DB2

DB2 Universal Database
iSeries

Lotus

Lotus Notes
MQIntegrator
MQSeries
0S/400
Tivoli
WebSphere

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

MMX, Pentium, and ProShare are trademarks or registered trademarks of Intel
Corporation in the United States, other countries, or both.

Solaris, Java, and all Java-based trademarks are trademarks of Sun Microsystems,
Inc. in the United States, other countries, or both.

UCC and UCCnet are trademarks of Uniform Code Council, Inc., UCCnet, Inc. or
both, in the United States, other countries, or both.

UCCnet Messaging is a product and/or trademark of UCCnet and is used with
permission.

Other company, product, or service names may be trademarks or service marks of
others.

IBM WebSphere InterChange Server Version 4.2.2

IBM WebSphere Business Integration Toolset Version 4.2.2

IBM WebSphere Business Integration Adapters Version 2.4 J AVA
COMPATIBLE ®
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