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Using the IBM® ILOG® JViews BPMN
Modeler

Contains a concise description of the features and capabilities of the IBM® ILOG® JViews
BPMN Modeler. It is assumed that you are familiar with BPMN notation and, therefore, the
meanings of the symbols or the best practices for defining business processes are not
described. For more information about BPMN notation, go to http://www.bpmn.org/.

In this section

Overview
Provides an overview of the IBM® ILOG® JViews BPMNModeler which allows you to model
business processes using standard BPMN notation.

IBM® ILOG® JViews BPMN Modeler GUI description
Describes the IBM® ILOG® JViews BPMN Modeler GUI elements.

Format of XML files for BPMN objects
Describes the XML elements for BPMN objects. The contents of Business Process Diagrams
(BPDs) are saved in an XML file.

Extending the IBM® ILOG® JViews BPMN Modeler
Shows how to extend the IBM® ILOG® JViews BPMN Modeler.
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Overview

Thank you for using the IBM® ILOG® JViews BPMN Modeler. By using this software
application, technical and business users can model business processes using standard
BPMN notation.

The essential benefits of this software are as follows:

♦ It uses BPMN notation to represent business processes. This notation, created and
specified by BPMI.org and published by the OMG, is widely recognized to be
comprehensive, and sufficiently intuitive to be used by both business and technical users.
For more information about BPMN, go to http://www.bpmn.org/

♦ The nodes (activities, gateways, sub-processes, and so on) and edges of the diagram can
be positioned automatically by the modeler to produce readable diagrams whatever their
size and complexity. The underlying technique, named Graph Layout, is used to
automatically arrange complex graphs.

♦ The modeler generates and reads a simple yet complete XML format that describes the
content of the business process; see Format of XML files for BPMN objects. This XML
can be used by an application to read the process being modeled, or to supply content to
the IBM® ILOG® JViews BPMNModeler. Contrary to many diagramming tools, the output
is not just a drawing that can only be used for documentation purposes.

♦ If needed, the modeler can be modified or enriched by a Java™ developer. The look and
feel, the interactions, and the data model can be adapted to specific needs. To achieve
this, Java developers can use JViews Diagrammer, the leading commercial Java software
component for developing diagramming applications. For more info go to
http://www.ilog.com/products/jviews/workflow/and
http://www.ilog.com/products/jviews/diagrammer/.
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IBM® ILOG® JViews BPMN Modeler GUI
description

Describes the IBM® ILOG® JViews BPMN Modeler GUI elements.

In this section

The Modeler GUI
Presents the elements of the IBM® ILOG® JViews BPMN Modeler graphical user interface
(GUI).

Menus
Describes the menus of the IBM® ILOG® JViews BPMN Modeler GUI.

The Palette toolbars
Describes the palettes of objects provided by IBM® ILOG® JViews BPMN Modeler in the
form of toolbars.
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The Modeler GUI

The IBM® ILOG® JViews BPMN Modeler GUI

The Modeler GUI contains the following elements:

♦ Menus, see Menus

♦ Toolbars, see The Document toolbar and The Palette toolbars

♦ View windows, see The View menu

♦ A Diagram window
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Menus

Describes the menus of the IBM® ILOG® JViews BPMN Modeler GUI.

In this section

The File menu
Describes the contents of the File menu of the IBM® ILOG® JViews BPMN Modeler GUI.

The Edit menu
Describes the contents of the Edit menu of the IBM® ILOG® JViews BPMN Modeler GUI.

The View menu
Describes the contents of the View menu of the IBM® ILOG® JViews BPMN Modeler GUI.

The Options menu
Describes the contents of the Options menu of the IBM® ILOG® JViews BPMN Modeler
GUI.

The Help Menu
Describes the contents of the Help menu of the IBM® ILOG® JViews BPMN Modeler GUI.

The Document toolbar
Describes the contents of the Document toolbar in the IBM® ILOG® JViews BPMNModeler
GUI.
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The File menu

Use this menu to create a new document, open, close, or save a document, define the printing
parameters, and exit the application. See the following figure.

The File menu
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The Edit menu

This menu provides basic editing commands such as Copy, Paste, and Delete. There are
also other commands, which are described in more detail in this section.

The Edit menu

Group and Ungroup
TheGroup andUngroup commands are useful for creating ad-hoc subprocesses from tasks
and other elements in your diagram:

♦ The Group command creates a subprocess and moves the selected objects into this
subprocess.

Before grouping
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After grouping

♦ The Ungroup command extracts the elements of a subprocess. It places them in the
parent of the subprocess, and deletes the subprocess.

Layout All Nodes
This command arranges the entire diagram to remove overlaps and to provide an easy-to-read
diagram. The function is particularly useful in the following circumstances:

♦ During prototyping, when it enables you to add new elements without needing to move
nodes manually.

♦ When complex processes are loaded from a business process management system. In
this case, there is often no graphics information within the process, and they would appear
visually disorganized without the graph layout.

♦ When you are working with complex diagrams. Simple diagrams may give better results
when arranged manually.

Before performing a Layout All Nodes operation, you may sometimes need to
set the Automatic Link Layout option to OFF. See The Document toolbar.

Note:

The figures Before automatic layout and After automatic layout show a Layout All Nodes
operation.
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Before automatic layout

After automatic layout

Layout Selected Nodes
This command lets you arrange selected objects without moving unselected objects. This is
useful when you have manually arranged a portion of the diagram, and you want the system
to automatically arrange another portion.

You have to keep the Automatic Link Layout option set to ON during this operation.
See The Document toolbar.

Note:
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Layout Selected Nodes

Alignment
This menu gives access to a list of alignment commands that you can use to arrange nodes
manually. They are complementary to the automatic layout commands. See Layout All Nodes
and Layout Selected Nodes.

The Alignment options

I B M ®  I L O G ®  J V I E W S  B P M N  M O D E L E R  1 . 1 . 214



The View menu

The View menu gives access to:

♦ Commands for zooming in or out, and for resetting the initial zoom level.

♦ Alternative views of the diagram information. They are described in more detail in this
section.

The View Menu

Tree View
The Tree View displays the elements of the diagram as a tree. Objects selected in the Tree
View are also selected in the Diagram View. Subprocesses are displayed as branches that
can be expanded or collapsed.
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The Tree view

Properties view
The Properties View displays the properties of the selected object.

The Properties view

You can use this view to:

♦ Change property values, for example, to set the names of the activities.
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♦ Remove a property for a selected element of the diagram. Removing pre-defined properties
should be done carefully as it may have an impact on the diagram meaning and
representation.

♦ Add new properties to the selected element of the diagram; see the following figure. The
property is saved in the XML document.

Adding a new property

Overview
The overviewwindow displays an entire diagram. A rectangle with resizing handles represents
the area displayed in the Diagram View. When moving the rectangle or when resizing it,
you can zoom-in, zoom-out, and pan in the Diagram View.
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The Overview

Table View
The Table View displays the elements of the diagram and their properties in a table. The
Table View provides a filter that allows you to display only those elements that match a
certain type.

The Table view
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The Options menu

The Options menu contains action, editing, and display options.

The Options menu

It allows you to define the following options:

Sticky Actions
When this option is ON, the last command remains active until a new command is triggered.
This is useful when performing repetitive commands.

When this option is OFF, the modeler brings back the Select command after each action.

Auto-Edit Labels
When this option is ON, you are asked to enter object labels (for instance the name of a
task) as they are added to the diagram.

When this option is OFF, the labels are edited either through the Properties View (see
Properties view), or by selecting the Edit Label command (see The Document toolbar).

Grid Spacing
This option allows you to change the grid spacing. The grid is set ON/OFF through the Grid
option on the View menu. See The View menu.

Allow Resizing
When this option is ON, the elements of the diagram can be resized manually. The selected
objects are displayed in a selection rectangle with resizing handles.

When this option is OFF, the size of the elements of the diagram are automatically determined
to ensure that the label text fits the elements. Subprocesses cannot be resized manually;
their size depends on the size and position of their elements.
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The Help Menu

The Help menu displays information about the IBM® ILOG® JViews BPMN modeler. If you
use the online version of the modeler, the Help menu also gives access to this documentation,
and to a series of Web pages where you can obtain additional information.
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The Document toolbar

The Document toolbar

The Document toolbar includes the following commands:

♦ Create, Open, Save, and Print a diagram.

♦ Undo/Redo.

♦ Group and Ungroup commands, see Group and Ungroup.

♦ The graph layout commands, see Layout All Nodes and Layout Selected Nodes.

♦ Automatic Link Layout. This command routes the links to reduce the number of crossings
between links. The command is useful when you add a new link, when you move a node
that is linked, and when you do not want to re-layout all the nodes.

You may get better results by setting this option to OFF when performing the
Layout All Nodes command. See Layout All Nodes.

Note:

♦ Edit Label. This command lets you edit the label of the object that you select. To do this,
click the Edit Label button, then select the object.

♦ Hide/Show Property Sheet. This command allows you to hide or show the properties
of the object that you select.
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The Palette toolbars

Describes the palettes of objects provided by IBM® ILOG® JViews BPMN Modeler in the
form of toolbars.

In this section

The Activity toolbar
Describes the Activity toolbar of the IBM® ILOG® JViews BPMN Modeler GUI.

The Events toolbar
Describes the Events toolbar of the IBM® ILOG® JViews BPMN Modeler GUI.

The Gateway toolbar
Describes the Gateway toolbar of the IBM® ILOG® JViews BPMN Modeler GUI.

The Links toolbar
Describes the Links toolbar of the IBM® ILOG® JViews BPMN Modeler GUI.

The Artifacts and Association toolbar
Describes the Artifacts and Association toolbar of the IBM® ILOG® JViews BPMNModeler
GUI.

The Lanes toolbar
Describes the Lanes toolbar of the IBM® ILOG® JViews BPMN Modeler GUI.
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The Activity toolbar

The Activity toolbar

The Activity toolbar includes the various types of task offered in BPMN:

♦ Task

♦ Subprocess

♦ Loop

♦ Loop subprocess

♦ Parallel

♦ Parallel subprocess

♦ Compensation

♦ Compensation subprocess

♦ Ad-hoc subprocess

To add a new activity, select the type of activity in the palette, and position the activity
within the diagram.

Subprocesses
The main characteristics of subprocesses are as follows:

♦ They are diagrams encapsulated in a subprocess element.

♦ They can be inserted into subprocesses.

♦ Diagram elements can be added into a subprocess by simply dropping them inside the
subprocess.

♦ The extent (the size) of a subprocess is determined by the position of its elements.

♦ They can be expanded or collapsed by clicking on the button.
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The Events toolbar

The Events toolbar gives access to several types of event that can occur within a BPMN
process:

♦ Message

♦ Timer

♦ Exception

♦ Cancel

♦ Compensation

♦ Rule

♦ Link

♦ Multiple

♦ Signal

♦ Terminate

These events can start or terminate a process, or they can occur during the process. There
are three distinct representations for each case.

Start events

The Start events toolbar

These events trigger the start of a process. They should be placed directly onto the diagram,
and linked to the activities representing the tasks to be performed when the event occurs.

End events

The End events toolbar

These events terminate a process. They should be placed directly onto the diagram.

Intermediate events

The Intermediate events toolbar
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Intermediate events can be either placed onto the diagram or directly onto an activity. For
example:

♦ When placed within the diagram, a message event specifies that the process is waiting
for a message in order to resume its activity. There are usually flow links before and/or
after this event.

A Message event

♦ When placed onto an activity, the event represents something that can occur during the
execution of an activity. There is usually a link (flow, message) going out of the event to
specify the action to perform if such an event occurs. To create these types of event, click
the event command you require on the toolbar. In the diagram, select the task onto which
you want to place the event. When you do this, the event sticks to the activity.

Timer event during activity execution
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The Gateway toolbar

This toolbar lets you add gateways inside the diagram.

The Gateway toolbar

BPMN gateways are:

♦ Data-XOR

♦ Event-XOR

♦ OR

♦ Complex

♦ AND
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The Links toolbar

The Links toolbar

The Links toolbar gives access to several types of BPMN link:

♦ Flow

♦ Conditional Flow

♦ Message

♦ Compensation Association

To create a link, click one of the link creation commands. In the Diagram View, select the
source element and then select the destination element.

There are restrictions on objects that can be linked together. For instance flow links
cannot traverse subprocesses or pools.

Note:
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The Artifacts and Association toolbar

The Artifacts and Association toolbar

These commands let you add Artifacts (Annotation, Data Object and Group objects) and
Association elements to the diagram.
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The Lanes toolbar

The Lanes toolbar

BPMN supports the notion of Pools for representing organizations, and Lanes for representing
departments within an organization. IBM® ILOG® JViews BPMN Modeler supports both
concepts.

Lanes
To create Lanes in a diagram, click the Create Lane command, and place the lane onto the
diagram. Then, drop your diagram objects into the lane. The property of the object (see
Properties view), is then updated to indicate that it belongs to the lane.

Lanes

To remove an object from a Lane, select the object and remove its Lane property; see
Properties view.

The size of the lane is determined by the position of the objects within the lane. In some
cases, an object may appear to be inside a lane to which it does not belong. This can happen
if a lane is enlarged when one of its elements is moved.

Pools
Pools are similar to lanes but they can include lanes within them.

To add a Lane into a Pool, just drop a Lane into the pool
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Pools
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Format of XML files for BPMN objects

Describes the XML elements for BPMN objects. The contents of Business Process Diagrams
(BPDs) are saved in an XML file.

In this section

Activity
Defines the properties of an Activity, which can be a Task or a Subprocess.

Gateway
Defines the properties of a Gateway element.

Event
Defines the properties of the Start, End, and Intermediate elements of an Event.

Flow
Defines the Sequence Flow and Message Flow elements of the Flow element of an Event.

Compensation Association
Describes the CompensationAssociation element of an Event.

Artifacts and Association
Describes the properties of Artifacts and Association elements.

Pool and Lane
Describes the Pool and Lane elements of an Event.
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Activity

An Activity can be a Task or a Subprocess.

Task
The properties for a Task element

DescriptionProperty Name

The label of the object.Name

The x-coordinate of the location.x

The y-coordinate of the location.y

Subprocess
The properties for a Subprocess element

DescriptionProperty Name

The label of the object.Name

The x-coordinate of the location.x

The y-coordinate of the location.y
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Gateway

The properties for a Gateway element
DescriptionProperty Name

The label of the object.Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The type of the gateway.GatewayType

This property can be set to “XOR”, “OR”, “Complex”, or “AND”. If it is not set, the
Gateway is a data-based XOR Gateway.

When the GatewayType property is set to “XOR”, the XORType property is also
relevant.

Specifies whether the Gateway is data-based or event-based (for XOR-type gateways
only).

XORType

This property can be set to “Event-XOR” for event-based XOR Gateways. If it is not
set, the XOR Gateway is a data-based XOR Gateway.
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Event

An Event can be a Start Event (Start), an End Event (End), or an Intermediate Event
(Intermediate).

Start events
The properties for a Start element

DescriptionProperty Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The type of event trigger: Message, Timer, Rule, Link, or Multiple.Trigger

If this property is not set, the type of Event is not displayed.

End events
The properties for an End element

DescriptionProperty Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The type of event trigger: Message, Exception, Cancel, Compensation, Link, Multiple,
or Terminate.

Trigger

If this property is not set, the type of Event is not displayed.

Intermediate events
The properties for an Intermediate element

DescriptionProperty Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The type of event trigger: Message, Timer, Exception, Cancel, Compensation, Rule,
Link, or Multiple.

Trigger

If this property is not set, the type of Event is not displayed.

Set to true if the event must be attached to the boundary of its Activity.Interrupt

Set to true if the event is a Throwing event.Throwing
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Flow

The from and to attributes of the XML element specify the two objects connected by a flow.

A flow can be a Sequence Flow or a Message Flow.

Sequence Flow
The properties for a Flow element

DescriptionProperty Name

Set to true to specify a Default Flow.Default

Set to true to specify a Conditional Flow.Condition

Message Flow
The properties for a Message element

DescriptionProperty Name

The message.Message
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Compensation Association

A CompensationAssociation element is used to connect an Interrupt Intermediate Event of
type Compensation to its associated Compensation Activity.

The from and to attributes of the XML element specify the two objects connected by the
association.

There are no properties.
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Artifacts and Association
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Annotation
The properties for a TextAnnotation element

DescriptionProperty Name

The label of the object.Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The value must be set to Annotation.ArtifactType

Data Object
The properties for a DataObject element

DescriptionProperty Name

The label of the object.Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The value must be set to DataObject.ArtifactType

Group
The properties for a Group element

DescriptionProperty Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The width of the Group shape.width

The height of the Group shape.height

The value must be set to Group.ArtifactType

Association
The properties for an Association element

DescriptionProperty Name

The first object, which should be the callout.callout

The second object, which should be the object to which the callout text refers.anchor
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Pool and Lane

Pool
The properties for a Pool element

DescriptionProperty Name

The label of the object.Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The width of the object.Size

The length of the object.Length

Lane
The properties for a Lane element

DescriptionProperty Name

The label of the object.Name

The x-coordinate of the location.x

The y-coordinate of the location.y

The width of the object.Size

The length of the object.Length
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Extending the IBM® ILOG® JViews BPMN Modeler

IBM® ILOG® JViews BPMN Modeler is an application that can be used by business and
technical professionals within their organization.

This application provides convenient editing tools such as Automatic Graph Layout commands
that help to keep complex diagrams readable.

Contrary to many diagramming tools, IBM® ILOG® JViews BPMN Modeler is not just a
drawing tool that generates pictures: it generates an XML file that can be used by another
application.

IBM® ILOG® JViews BPMN Modeler has been developed by IBM® ILOG® to promote the
BPMN notation, and to demonstrate the power of its Java™ Toolkit: JViews Diagrammer.

JViews Diagrammer is used by the major BPM vendors to develop their process modelers.
It provides most of the features required to develop a modeler such as IBM® ILOG® JViews
BPMN Modeler:

♦ Editing commands

♦ Graph layout

♦ BPMN support

♦ XML generation

♦ Styling to define the look and feel of the diagram

IBM® ILOG® JViews BPMNModeler can be extended to support specific needs. The source
code of this application is given with JViews Diagrammer, and the new features can be
inserted rapidly using the JViews Diagrammer library. For more information on JViews
Diagrammer, go to http://www.ilog.com/products/jviews/workflow/and
http://www.ilog.com/products/jviews/diagrammer/.
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