CBIND Check Failed
 Technote (FAQ)
 
Problem
When activating a new conversation in the System Management User Interface, a pop-up window appears stating that activation failed.
 
Cause
For this customer the problem occurred when the customer enabled client security, but did not permit the J2EE server to the CBIND class profiles used to enforce client security.
 
Solution
Examine the message log in the System Management User Interface (File -> message log). If you don’t see message BBONO449I Conversation xxxxxxwas activated,and there are no indications of any other problems in the message log, the problem is on the System Management (SM) server. Go to the end of the System Management server's SYSLOG and look for any errors associated with the server you were trying to activate.

For example, if you were working wiith server BBOASR2, you might see the following message:

Server BBOASR2” open for business

This message indicates that the J2EE server region started successfully. Check the BBOASR2 control region and server region JOBLOGs. In the JOBLOG for the BBOASR2 control region, look for any messages that look like errors. In this case you might see the following message:

BBOU0086E CBIND CHECK FAILED WITH SAF RETURN CODE=00000008, RACF RETURN CODE=00000008, RACF REASON CODE=00000000.

This message points to the problem. Client security is enabled for the WebSphere Application Server runtime, but the administrative userid has not been authorized to the BBOASR2 server.

To correct the problem either turn off client security by deactivating the CBIND class, or Issue the following PERMIT commands to allow the System Management userids access to the new server:

PERMIT CB.BBOASR2 CLASS(CBIND) ID(CBADMIN) ACCESS(READ)

PERMIT CB.BIND.BBOASR2 CLASS(CBIND) ID(CBADMIN) ACCESS(READ).

These commands assume the default System Management ID, CBADMIN, has been used.

Related information:

WebSphere Application Server V4.0.1 for z/OS and OS?390: Installation and Customization, GA22-7837

 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server for z/OS > Deploy (for example: AAT or ANT or EAR/WAR/JAR)
Operating system(s): z/OS
Software version: 4.0.1
Software edition:
Reference #: 1137109
IBM Group: Software Group
Modified date: Sep 25, 2003