BBOJ0037E and BBOJ0036E issued after an application is deployed
 Technote (FAQ)
 
Problem
If you receive error messages BBOJ0036E and BBOJ0037E after deploying an application, you might have this problem.
 
Cause
When the HTTP Server is used instead of an HTTP Transport Handler to send requests to a J2EE™ server, there is a time delay during which the Web server polls for J2EE servers and applications. (By default, this polling occurs every 10 minutes.)

You can change the length of the time period between polls by specifying a different value on either of the follow parameters: appserver.java.extraparm=-Dcom.ibm.ws390.wc.serverCheckInterval= property in the was.conf file, or the com.ibm.ws390.wc.serverCheckInterval= property in the current.env file. However, if changing the length of time between polls does not prevent the errors from occurring you might have to restart the HTTP Server, or use one of the alternative solutions that follow.

 
Solution
You can stop and restart the HTTP Server; however, this can very disruptive to a production system.
Alternative solutions are:

Set the com.ibm.websphere.naming.jndicache.cacheobject= JNDI property to cleared in either:
  • An environment Hashtable in the client code, or
  • The jndi.properties resource file

or

Set the WebSphere Application Server was.conf file property
appserver.java.extraparm=-Dcom.ibm.websphere.naming.jndicache.cacheobject= to cleared.

Either of these actions turns off JNDI lookup caching, which eliminates the problem.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server for z/OS > Deploy (for example: AAT or ANT or EAR/WAR/JAR)
Operating system(s): z/OS
Software version: 4.0.1
Software edition:
Reference #: 1137439
IBM Group: Software Group
Modified date: Mar 27, 2006