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Problem |
If you receive error messages BBOJ0036E and BBOJ0037E
after deploying an application, you might have this problem. |
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Cause |
When the HTTP Server is used instead of an HTTP Transport
Handler to send requests to a J2EE™ server, there is a time delay during
which the Web server polls for J2EE servers and applications. (By default,
this polling occurs every 10 minutes.)
You can change the length of the time period between polls by
specifying a different value on either of the follow parameters:
appserver.java.extraparm=-Dcom.ibm.ws390.wc.serverCheckInterval=
property in the was.conf file, or the
com.ibm.ws390.wc.serverCheckInterval= property in the current.env
file. However, if changing the length of time between polls does not
prevent the errors from occurring you might have to restart the HTTP
Server, or use one of the alternative solutions that follow.
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Solution |
You can stop and restart the HTTP Server; however, this
can very disruptive to a production system.
Alternative solutions are:
Set the com.ibm.websphere.naming.jndicache.cacheobject= JNDI
property to cleared in either:
- An environment Hashtable in the client code, or
- The jndi.properties resource file
or
Set the WebSphere Application Server was.conf file property
appserver.java.extraparm=-Dcom.ibm.websphere.naming.jndicache.cacheobject=
to cleared.
Either of these actions turns off JNDI lookup caching, which eliminates
the problem. |
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