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Problem |
This error message appears in the
browser. |
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Cause |
The Uniform Resource Identifier (URI)
did not match the Service directive in your httpd.conf for the Local
Redirector Plug-in. Without a match on a Service directive, the request is
evaluated against the URI matching directives further down in the
httpd.conf file, such as Pass, Exec, Map, and so forth. Eventually the
HTTP Server fails to find a match on any URI-matching directive, or the
HTTP Server matches the request against the Pass /* directive (typical
coding convention) and does not find the implied static file in the
HFS.
In both cases, an Error
404: File Not Found error
results.
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Solution |
Check the following:
- Visually inspect the httpd.conf file and verify that the
URL issued matches a Service directive. URI-matching is case sensitive. If you determine
that you do not have a Service directive, edit the httpd.conf file, save, then restart
the HTTP Server.
- Validate that the HTTP Server is restarted;
the Service directive was added and changes to
the httpd.conf do not
take effect until the HTTP Server is restarted.
- Turn the VV trace on and off using the console commands:
F WEBSERVER_PROC,APPL=-VV
F WEBSERVER_PROC,APPL=-NODEBUG
respectively, then investigate URL's
evaluation against directives.
- Supply valid service directive to the local
redirector plug-in environment.
- URI matching is done sequentially in the IBM HTTP
Server, so make sure that the Service Directive appears above the Pass /*
in the httpd.conf.
Note: Beware the 404 that is issued
by the local redirector plug-in. You can tell which component issued the
404 by the error page. The HTTP Server identifies itself on its default
error page. The local redirector plug-in error page shows Target Servlet: File. If you
see servlet in the error, this indicates that the plug-in has been invoked
and that the error was issued from the plug-in. |
Related information
IBM HTTP Server Planning, Installing, and
Using, SC34-4826. |
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