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Problem |
If you experience the following error:
IEF352I Address Space Unavailable condition and you see that a high number
of reserved address spaces are being used this is a hardware problem. |
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Cause |
The root cause of this problem stems from the hardware.
Review the MVS®
Extended Addressability Guide for an explanation on RSVNONR.
There is a LXSET SYSTEM(YES) macro in the WebSphere® Application Server
Daemon. The MVS Extended Addressability guide points out that address
spaces that use SYSTEM(YES) on the LXSET will be non-reusable for the life
of the IPL.
The WebSphere Application Server Control Regions (CRs) use SYSTEM(NO).
However, the RRS address space PC's over to the CRs and the CRs PC over to
RRS. Since the WebSphere CR address space IDs are "known" by the RRS
address space, these WebSphere CR ASIDs that were brought down will not be
reused until RRS (and other resource managers involved) is recycled or you
IPL.
This may be a condition more limited to a test system in that in a
production system since you are more likely to recycle WebSphere
Application Server Control Regions in a test system whereas in production
they would be recycled less frequently.
This behavior of reserving ASIDs from reuse is dictated by the current
hardware design. The hardware is attempting to prevent a PC into an
address space which has been dismantled and reconstructed for some other
purpose like a TSO user or OMVS shell.
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Solution |
You can resolve or avoid this problem by doing one of the
following:
1. You can increase RSVNONR in your IEASYSxx PARMLIB member. See the MVS
Initialization and Tuning Reference for the details. Find a
balance between the MAXUSER and RSVNONR parameters in the parmlib member
IEASYSxx. If you increase the value of RSVNONR this will increase the
number of ASIDs that are available. The combination of MAXUSR, RSVNONR and
RSVSTRT must not exceed the maximum number. The balance comes in making
sure there is enough CSA storage to handle the numbers you choose. If you
make changes to these IEASYSxx settings, you will need to IPL to pick up
the changes.
2. The other alternative is to shut down and restart RRS and the other
resource managers(DB2®,WebSphere MQ, etc) to allow the ASIDs to be added
back to the pool. The WebSphere Application Server for z/OS environment
should be stopped also prior to shutting down RRS. You can determine how
disruptive this is in your environment. |
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