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Problem |
You do not know why the application server restarts, and
you notice the following entry in the tracefile:
[02.08.23 02:02:53:567 EDT] 876dc41c ActiveServerP A ADMS0028I: Restarting
server: "Internet" |
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Cause |
An application server restarts because of the Ping Timeout
or because the process crashed. This document describes how to determine
why the application server has been restarted. |
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Solution |
If it is determined that the application server crashed,
see the links under the Related
information section below for the document that pertains to your
operating system.
If it is determined that the application server was restarted because of
a Ping Timeout, see the link under the Related information section below.
- Ping Timeout:
- If you are running WebSphere® Application Server version
3.5.5 and higher, or any release of version 4.0, the "Restarting
server" message will be preceded by the following line:
[02.08.23 02:02:53:567 EDT] 876dc41c
ActiveServerP A No Ping Received - Stopping server: "Internet" |
|
- If you are running WebSphere Application Server version
3.5.4 or lower, the "Restarting server" message will NOT be
preceded by the "No Ping Received" message. You will then need to
determine if the application server crashed. If there is no evidence of a
crash, then it most likely restarted due to the ping timeout. Follow
section B below to determine if the application server crashed. If there
is no evidence of a crash, see the link for a restart due to a Ping
Timeout under the Related
information section below.
- How to determine if the application server crashed:
- For AIX®:
Run the following command to determine if a process crashed on AIX:
errpt -a >errpt.out |
|
The following is sample output from the
errpt.out file. The process ID can then be compared to the PIDs
in the tracefile. |
|
LABEL: CORE_DUMP
IDENTIFIER: C60BB505
Date/Time: Sat Jul 13 00:34:27
Sequence Number: 171
Machine Id: 000B63BA4C00
Node Id: nmdol-ui-integ
Class: S
Type: PERM
Resource Name: SYSPROC
Description
SOFTWARE PROGRAM ABNORMALLY TERMINATED
Probable Causes
SOFTWARE PROGRAM
User Causes
USER GENERATED SIGNAL
Recommended Actions
CORRECT THEN RETRY
Failure Causes
SOFTWARE PROGRAM
Recommended Actions
RERUN THE APPLICATION PROGRAM
IF PROBLEM PERSISTS THEN DO THE FOLLOWING
CONTACT APPROPRIATE SERVICE REPRESENTATIVE
Detail Data
SIGNAL NUMBER
11
USER'S PROCESS ID:
47762
FILE SYSTEM SERIAL NUMBER
6
INODE NUMBER
808981
PROGRAM NAME
java
ADDITIONAL INFORMATION
Unable to generate symptom string.
Too many stack elements. |
|
- For Solaris™:
To determine if the process crashed, check the /var/adm
directory for a file named "messages".
- For Windows®:
To determine if the process crashed, check the drwtsn32.log
file for the PID of the Application Server. The default location is the
\Winnt\System32 directory on Windows NT 4.0 and \Documents
and Settings\All Users\Documents\DrWatson on Windows 2000.
Following is sample output from drwtsn32.log:
Microsoft (R) Windows 2000 (TM)
Version 5.00 DrWtsn32
Copyright (C) 1985-1999 Microsoft Corp. All rights reserved.
Application exception occurred:
App:
(pid=1652)
When: 9/11/2002 @ 02:49:54.788
Exception number: c0000005 (access violation)
*----> System Information <----*
Computer Name: ASTPXDWS06
User Name: SYSTEM
Number of Processors: 4
Processor Type: x86 Family 6 Model 10 Stepping
1
Windows 2000 Version: 5.0
Current Build: 2195
Service Pack: 2
Current Type: Multiprocessor Free
Registered Organization: IBM
Registered Owner: IBM
*----> Task List <----*
0 Idle.exe
8 System.exe
232 smss.exe
916 llssrv.exe
960 bpinetd.exe
1032 regsvc.exe
1044 mstask.exe
1084 snmp.exe
1124 sysdown.exe
1168 winmgmt.exe
1184 cpqnimgt.exe
1208 cqmgserv.exe
1220 cqmgstor.exe
1408 inetinfo.exe
1272 cqmghost.exe
1616 cpqwmgmt.exe
1652 java.exe
2020 java.exe
2024 java.exe
2980 java.exe
664 cidaemon.exe
3496 logon.scr.exe
1732 drwtsn32.exe
0 _Total.exe |
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Related Information
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