Administrative server fails to start after enabling security because of a corrupt sas.server.props file
 Technote (FAQ)
 
Problem
Missing or corrupted lines in the WebSphere® Application Server V4.0 $WAS_HOME/properties/sas.server.props file can cause various symptoms with the administrative server and result in startup failures.
 
Cause
As additional symptoms are found, IBM Level 2 support will add them to this technote.

Symptom 1: WSVR0033E: Failed to load security collaborator

If the following line is missing:
com.ibm.CORBA.delegateCredentials=methodDefined

it causes the following problem:


<date/time> <thread Id> EJBEngine F WSVR0033E: Failed to load security collaborator,
com.ibm.ejs.security.EJSSecurityCollaborator
java.lang.nullPointerException
at com.ibm.ejs.security.EJSSecurityCollaborator.<init>(EJSSecurityCollaborator,java:81)
at java.lang.Class.newInstance0(Native Method)
at java.lang.Class.newInstance(class.java:262)
at com.ibm.ws.runtime.EJBEngine.loadClass(EJBEngine.java:573)
at com.ibm.ws.runtime.EJBEngine.init(EJBEngine.java:149)
at com.ibm.ws.runtime.Server.initializeEjbContainer(Server,java:367)
at com.ibm.ws.runtime.Server.startModule(Server.java:603)
.... rest of stack trace not shown.

 
Solution
Compare the $WAS_HOME/properties/sas.server.props file with a file from a system that has security properly functioning, and replace the missing lines in the sas.server.props and the sas.server.props.future files.
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Security
Operating system(s): Windows
Software version: 4.0
Software edition:
Reference #: 1109327
IBM Group: Software Group
Modified date: Jan 15, 2004