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Problem |
When accessing WebSphere® Application Server content
through Microsoft® Internet Information Services (IIS), the client is
prompted to download a file rather than loading the requested page. |
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Cause |
This can be due to one of two problems:
- There are other ISAPI filters loaded that handle the request before
the WebSphere Application Server plug-in.
- The WebSphere Application Server plug-in is not configured correctly
within IIS.
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Solution |
If there are no other ISAPI filters loaded within the IIS
Web site, and the problem continues, then verification of the WebSphere
Application Server plug-in configuration is necessary.
The following URLs provide instructions for manually setting up the
WebSphere Application Server plug-in within IIS:
When following the instructions within the preceding URLs, pay careful
attention to step 3 that directs the following (this must be followed to
ensure proper configuration):
3. |
Select the Allow Execute
Access check box in the What access
permissions do you want to set for this
directory field. |
If after verifying every step of the manual install of the WebSphere
Application Server plug-in to IIS, you still continue to experience this
problem, perform the following steps:
- Go to the following MustGather document to collect the necessary
information for troubleshooting:
MustGather:
Problems with plug-in (remote) install
- Collect the following:
- Download the file when prompted by the client browser and
save it for sending into support.
- Screen shot showing the permission's for the ISAPI
plug-in.
- Call into the 1-800-IBM-Serv number with the collected data and the
Reference # of this technote.
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