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Problem |
When security is enabled on WebSphere®
Application Server with Basic Challenge Type, and the Microsoft® Internet
Information Server is enabled with Challenge/Response and Basic
Authentication, valid usernames and passwords fail when trying to log in
and access a secured resource. |
|
Cause |
This symptom occurs when WebSphere
Application Server security is enabled and Basic Challenge Type is chosen.
Logging in with a valid username and password fails when you try to access
secured resources.
The reason might be that in IIS, the Windows
NT® challenge/response and basic authentication is enabled on the
Microsoft Management Console. |
|
Solution |
Environment:
- Microsoft Windows NT or Windows®
2000
- WebSphere Application
Server
- Microsoft Internet Information Server
(IIS) 4.x or 5.x
For Windows NT running IIS 4.x:
- Start the Microsoft Management Console.
- Disable the IIS Windows NT challenge/response and basic
authentication.
- Use WebSphere Application Server to handle these activities.
For Windows 2000 running IIS 5.x:
- Start the Windows 2000 Administrative Tool.
- Select Internet Services Manager.
- Highlight the Web site service.
- Display properties.
- Click the Directory Security tab.
- Click Edit for Anonymous access and authentication control.
- Clear all check boxes in the Authenticated access section.
- Click OK.
- Cancel the dialog box that asks what else should be default for
authenticated access.
- Use WebSphere Application Server to handle these activities.
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