StaleConnectionException causes Web application to not respond (or hang) when using Informix® Java™ Database Connectivity (JDBC™) Driver
 Technote (FAQ)
 
Problem
Your application connects to an Informix database using the Informix JDBC Driver V2.21.JC5 (or earlier). When your database server becomes unavailable, you receive a StaleConnectionException. The exception causes your application to fail recovery even when your database becomes available again.
 
Cause
This is a defect with the Informix JDBC Driver version 2.21.JC5 (or earlier versions).

Below is an excerpt of the hang thread from the thread dump (javacore) of your application server Java Virtual Machine (JVM™):

at
com.informix.jdbcx.IfxSqliConnReUsableConnection.close(IfxSqliConnReUsableConnection.java:120)
at
com.ibm.ws.rsadapter.spi.WSRdbManagedConnectionImpl.destroy(WSRdbManagedConnectionImpl.java:1738)
at
com.ibm.ejs.j2c.MCWrapper.destroy(MCWrapper.java:1304)
at
com.ibm.ejs.j2c.poolmanager.FreePool.cleanupAndDestroyMCWrapper(FreePool.java:463)
at
com.ibm.ejs.j2c.poolmanager.FreePool.returnToFreePool(FreePool.java:275)

 
Solution
Obtain Informix JDBC Driver version 2.21.JC5X8 (or higher) from Informix support, referencing Informix case 385213.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > DB Connections/Connection Pooling
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1162299
IBM Group: Software Group
Modified date: Jun 9, 2004