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Problem |
When you use two machines, one running the WebSphere®
Application Server client and the other running the server, and the
network connection breaks on the client box, the client application can
hang for a long time. This can happen regardless of whether Workload
Management (WLM) is enabled.
In a typical failure scenario, there is a WLM-enabled client with multiple
back-end EJB™ servers. When one of the EJB servers is unreachable, the
client hangs for a long time before finally switching to a working
clone. |
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Cause |
When one of the back-end servers is unavailable, the
WLM-enabled client is unable to detect the TCP/IP failure, with a possible
hang in the Object Request Broker (ORB) layer. |
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Solution |
Apply PQ67826
for the socket object to enable so_keepalive. This will fix the problem.
In addition to applying this fix, adjusting the following settings can
also prevent this condition:
- Set -tcp_keepidle to 'no' in the JVM™ and TCP/IP® layer to
allow the socket timeout to take effect.
- Change the TCP/IP timeout to a smaller value.
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