"java.sql.SQLException: invalid arguments in call" issued during WebSphere Application Server V4 XA recovery
 Technote (FAQ)
 
Problem
When WebSphere® Application Server V4 starts, the following exception is issued:

WTRN0005W: Encountered an error while creating XAConnection and XAResource
java.sql.SQLException: invalid arguments in call
...
 
Cause
This indicates that WebSphere did not shut down cleanly and there were in-doubt XA transactions when it shut down. When WebSphere starts up again, it tries to recover these in-doubt transactions.

When this exception is issued, the WebSphere Transaction Manager does not have the correct user ID and password to connect to the database. Most likely, the user and password fields were left blank in the data source configuration within the WebSphere administrative console. These fields are required for XA recovery to work correctly.

 
Solution
To solve the problem, set the user and password for all XA data sources defined in the administrative console.

If there is concern about the security impact of setting a default user and password for the data source, apply the latest cumulative Connection Manager (CM) interim fix from the WebSphere Application Server support site.

This interim fix adds a new data source property called secureXACredential. If this is set to true, and the user and password fields are set, the user ID and password is used only for XA recovery and not application connections to prevent the security exposure.

 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > DB Connections/Connection Pooling
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1139464
IBM Group: Software Group
Modified date: Aug 27, 2004