Administrative Console will not start when security is enabled
 Technote (FAQ)
 
Problem
After enabling security, the following message appears in the trace file, and the administrative console will no longer start.

[01.04.30 17:56:04:325 PDT] a4a69186 ORBRas A 2001.04.30 17:56:04.179 IIOPSSLConnection createSSLServerSocket IBM WebSphere ORB JORB0027: Method "new SSLServerSocket(...)" throws java.net.BindException: The socket name is already in use. which is rethrown as an INTERNAL exception.
[01.04.30 17:56:04:332 PDT] a4a69186 IExtendedSecu A 2001.04.30 17:56:04.332
SecurityTaggedComponentAssistorImpl register IBM WebSphere Security The BasicAuth expiration time is smaller than the ORB request timeout; A method request could take longer than the period over which the requesting credentials will remain valid.
 
Cause
Port in use conflict.
 
Solution
Add the following line in the admin.config file to set an alternate port, then re-enable security and restart the admin server.

(Make sure that the port is not used by using netstat -a)
com.ibm.CORBA.SSLPort=unusedPort-1

Additionally you may also want to set:
com.ibm.CORBA.LSDSSLPort=unusedPort-2
com.ibm.CORBA.BootstrapPort=unusedPort-3

(Where unusedPort-n are between 1200 and 8000)
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Security
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1030971
IBM Group: Software Group
Modified date: Jan 5, 2005