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Problem |
MustGather for troubleshooting WebSphere® Application
Server java.lang.OutOfMemory exceptions on the HP-UX platform. Gathering
this information before calling IBM support will help familiarize you with
the troubleshooting process and save you time. |
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Cause |
Two conditions can cause a java.lang.OutOfMemory
exception:
- The Java™ virtual machine (JVM™) might run out of Java heap space to
allocate a Java object.
- The JVM might not be able to allocate the native memory that it needs
to create or execute its threads.
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Solution |
If you have already contacted support, continue on to the
component-specific MustGather information. Otherwise, refer to MustGather:
Read first for all WebSphere Application Server products.
Out of Memory specific MustGather information
The following instructions will take you through setting up the
failing system for capturing required information:
1. Recycle WebSphere Application Server logs.
2. Enable the following:
3. Restart the application server.
4. Run the application until reoccurrences of java.lang.OutOfMemory
exceptions occur.
5. Stop the application server.
6. Collect the following information:
- Xverbosegc.out
- For WebSphere V6.0:
- All files in the following directory:
install_root/profiles/profile_name/logs/server_name |
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- All files in the following directory:
install_root/profiles/profile_name/logs/ffdc |
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- A copy of server.xml located in the following
directory:
install_root/profiles/profile_name/config/cells/
cell_name/nodes/node_name/servers/server_name |
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- Include all of the files from the following directory:
- For WebSphere V5.0 and V5.1:
- Include all of the files from the following directory:
install_root/logs/server_name |
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- All files in the following directory:
- A copy of server.xml located in the following
directory:
install_root/config/cells/cell_name/nodes/
node_name/servers/server_name |
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- For V3.5 and V4.0 releases:
- Include all of the files from the following directory:
- A copy of XMLExport for the server configuration.
- Note: For all versions, If you have configured the
application server to write logs into a different location, send them
accordingly.
7. Follow instructions to Submitting
Diagnostic Information to IBM Technical Support for Problem
Determination.
For a listing of all technotes, downloads, and educational materials
specific to the Out of Memory component, search the WebSphere
Application Server support site. |
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