Object Requester Broker (ORB) version conflict with Fix Pack 7
 Technote (FAQ)
 
Problem
After upgrading from a previous V4.0 release to V4.0.7, the server does not start. An administrative server trace is run, resulting in this error is in adminServer.trace:

WSVR0009E: Error occurred during startup
java.lang.NoSuchFieldError: codeBaseSupported
 
Cause
Possible reasons why there are two versions of the ORB:
  1. V4.0.7 was shipped with 2 different ORBs.

  2. V4.0.7 was shipped with the correct ORB versions but they were not installed correctly during the fix pack installation.
 
Solution
The solution is to install the latest Java™ SDK. The problem is resolved by upgrading the SDK with an ORB build date later than November 2003.
One ORB version has a build date prior to November 2003 and the other ORB has a build date after November 2003. To resolve this problem, both ORBs must have a build date after November 2003.

Here is a link to upgrade the JDK :
http://www-1.ibm.com/support/docview.wss?uid=swg24006479

Download the SDK and the installation instructions for your operating system.
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Install
Operating system(s): Windows
Software version: 4.0.7
Software edition:
Reference #: 1169019
IBM Group: Software Group
Modified date: May 14, 2004