|
Problem |
At one point in time, the SequeLink® JDBC™ Driver and a
data source using the SequeLink JDBC Driver were configured and used by
some application. Later on, the SequeLink JDBC Driver and its data source
were removed, and no application used the SequeLink JDBC Driver.
Now when starting the Application Server, you receive the error,
WTRN0005W. |
|
Cause |
The application servers and administrative server did not
shutdown properly at the time the SequeLink JDBC Driver and its data
source were configured and used. As a result, there are some in-doubt
transactions in the database. When WebSphere® Application Server (for
example: DefaultServer) tries to recover the transactions on
startup, the following exception appears:
[4/28/03 3:31:12:750 CDT] 25c3db5b CMXAResourceF W WTRN0005W:
Encountered an error while creating XAConnection and XAResource
java.sql.SQLException: [MERANT][SequeLink JDBC Driver]Insufficient
information to log on the database. Missing parameters are: USER PASSWORD.
at com.merant.sequelink.SqlMessage.getSqlException(Unknown Source)
at com.merant.sequelink.SqlMessage.getSqlException(Unknown Source)
at com.merant.sequelink.ctxt.conn.SessionContext.logon(Unknown Source)
at com.merant.sequelink.ctxt.conn.SessionContext.<init>(Unknown
Source)
at com.merant.sequelink.ctxt.conn.ConnectionContext.connect(Unknown
Source)
at com.merant.sequelink.jdbc.SequeLinkConnection.<init>(Unknown
Source)
at
com.merant.sequelink.jdbcx.pooling.SequeLinkPooledConnection.<init>(Unknown
Source)
at
com.merant.sequelink.jdbcx.xa.SequeLinkXAConnection.<init>(Unknown
Source)
at
com.merant.sequelink.jdbcx.datasource.ConnectionStartup.CreateConnection(Unknown
Source)
at
com.merant.sequelink.jdbcx.datasource.SequeLinkDataSource.getXAConnection(Unknown
Source)
at
com.ibm.ejs.cm.CMXAResourceFactory.getXAResource(CMXAResourceFactory.java:69)
at com.ibm.ejs.jts.jta.JTSXA.recover(JTSXA.java:841)
at
com.ibm.ejs.jts.jta.recovery.XARecoveryManager.xaRestartRecovery(XARecoveryManager.java:248)
at
com.ibm.ejs.jts.jta.recovery.XARecoveryManager.duringRestart(XARecoveryManager.java:230)
at com.ibm.ejs.jts.tran.Tran.ready(Tran.java:193)
at com.ibm.ejs.jts.jts.CurrentSet.ready(CurrentSet.java:164)
at com.ibm.ejs.jts.jts.Jts.ready(Jts.java:150)
at com.ibm.ws.runtime.Server.initializeTran0(Server.java:1654)
at
com.ibm.ejs.sm.server.ManagedServer.initializeTran0(ManagedServer.java:661)
at com.ibm.ws.runtime.Server.initializeTran(Server.java:1596)
at com.ibm.ws.runtime.Server.initializeRuntime0(Server.java:943)
at
com.ibm.ejs.sm.server.ManagedServer.initializeRuntime0(ManagedServer.java:408)
at com.ibm.ws.runtime.Server.initializeRuntime(Server.java:884)
at com.ibm.ejs.sm.server.ManagedServer.main(ManagedServer.java:168)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:158)
|
|
Solution |
- Stop all the application servers and administrative server to make
sure no in-doubt transactions exist.
- Delete all the files from
install_root/tranlog directory.
- Go to the install_root/properties directory
and delete all the files with the following name:
AppServerXAResources
where:
AppServer is the name of the Application Server.
For example: DefaultServerXAResources
|
|
|
|
|
|
|