Login fails for new users attempting to login to IBM® WebSphere® Portal
 Technote (FAQ)
 
Problem
If you install IBM WebSphere Portal with default settings in the admin.config file, users logging in for the first time might receive the following error:

"JSAS0240E: Login failed. Verify the userid/password is correct. Check the properties file to ensure the login source is valid. If this error occurs on the server, check the server properties to ensure the principalName has a valid realm and userid."
 
Cause
The time required to process the first login attempt for a user ID is substantially longer than for subsequent attempts. The default value of jndi.LDAP.SearchControl.TimeLimit=1000 is too low for a first attempt and might cause a Lightweight Directory Access Protocol (LDAP) search timeout.
 
Solution
Increase the setting for jndi.LDAP.SearchControl.TimeLimit.

jndi.LDAP.SearchControl.TimeLimit=60000

The setting is specified in the admin.config file. The time is specified in milliseconds. This example shows a setting for 1 minute, or 60 seconds.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Security
Operating system(s): HP-UX
Software version: 4.0.5
Software edition:
Reference #: 1136807
IBM Group: Software Group
Modified date: Mar 29, 2004