Unable to start WebSphere® Application Server Java™ virtual machine (JVM™) after upgrading Java 2 SDK
 Technote (FAQ)
 
Problem
You have upgraded your Java 2 SDK in a Windows® environment. When you try to start your V4.0 or V5.0 WebSphere Application Server JVM, the following exception displays in the tracefile of the Administrative Server:

Exception in thread "main" java.lang.NoClassDefFoundError: com/ibm/crypto/provider/IBMJCE
 
Cause
This exception pertains to the ibmjceprovider.jar file, and is thrown when instructions are not followed according to step 2 of the SDK upgrade Readme. An alternate method is used to backup the old SDK, and therefore the file ibmjceprovider.jar is not carried over to the upgraded SDK.
 
Solution
Issue the exact command documented in step 2 of the Java 2 SDK upgrade Readme:

xcopy java java_bu /E

Alternatively, you can do the following:
  1. Locate the copy of ibmjceprovider.jar in the java_bu\jre\lib\ext directory.
  2. Copying all .jars (except indicim.jar) from the java_bu\jre\lib\ext directory to the java\jre\lib\ext directory.

Note: The Readme has been altered to stress the importance of issuing this command.
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Java SDK
Operating system(s): Windows
Software version: 5.0
Software edition:
Reference #: 1140519
IBM Group: Software Group
Modified date: Feb 5, 2004