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Problem |
When starting the Resource Analyzer, an error occurs
indicating that the Resource Analyzer cannot connect to the administrative
server. "PMON3002W: The WebSphere admin server is not running. Please
start the admin server if you want to use Resource Analyzer to display
current data. The server is not required for replaying log files." |
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Cause |
This error will occur if the
PmiSingleServerBean.ear is not installed, was installed
improperly, or the administrative server is not running. If you already
installed this EAR file but did not use the -ejbdeploy option,
uninstall the EAR and re-install it with the instructions below. If you
have not installed the EAR, follow these instructions to install it: |
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Solution |
Resource Analyzer does not ship with versions of
WebSphere® Application Server Advanced Single Server Edition prior to
V4.0.2.
To use the Resource Analyzer with the Advanced Single Server
Edition of WebSphere® Application Server Version 4.0.2 or higher, do the
following:
- Install the PmiSingleServerBean.ear file (available under the
$WAS_HOME/installableApps directory):
- Go to the $WAS_HOME/bin directory.
- Enter the command:
seappinstall -install
$WAS_HOME\installableApps\PmiSingleServerBean.ear
-ejbdeploy false
- Click Enter when prompted for the Default data source Java™
Naming and Directory Interface (JNDI) name and the JNDI name. This allows
the use of default values as required by the Resource Analyzer.
- Restart the application server.
- Start the Resource Analyzer:
- Go to the $WAS_HOME\bin directory.
- Enter the command:
For Windows®: ra hostname 900 AES
For UNIX®: ./ra.sh hostname 900 AES
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