JavaServer Pages (JSP) request produces a 404 error in the browser, but no error message appears in the WebSphere® Application Server logs
 Technote (FAQ)
 
Problem
JavaServer Pages (JSP) requests that produce a 404 error in the browser, but no error message in the WebSphere logs can be caused by incorrect file permission settings on the temporary space used by the JSP compiler. You might not see entries concerning the JSP request in the standard out or standard error logs. However, the following error might appear in the standard out file:

[3/6/02 16:04:32:007 CST] 662b85e7 WebGroup I SRVE0091I: [Servlet
LOG]: JSP 1.1 Processor: init jsp.error.bad scratch dir
 
Cause
This error is probably caused by incorrect file permission settings on the temporary space used by the JSP compiler.
 
Solution
File permissions that are set in the WebSphere admininistrative console also impact the temporary space used by the JSP compiler. In this case, the JSP file cannot write the servlet files, so a failure occurs when trying to access the servlet file that was not created. Configuration might include the administrative server process running as non-root.

Update the permissions in the administrative console for the WebSphere Application Server to support write and execute for the user ID that is running the Application Server. Also add those permissions to the $WAS_HOME/tmp directory.

 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Servlet Engine/Web Container
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1050864
IBM Group: Software Group
Modified date: Jan 14, 2004