Error "jspg0103e opening a tag library" using JSP and xerces/struts
 Technote (FAQ)
 
Problem
After upgrading to WebSphere® Application Server V4.0.6, browser displays error 500 when running a JSP that uses Xerces and Struts. Log shows error "jspg0103e unable to open tag library".

Problem does not occur after removing fix pack 6 and running under WebSphere Application Server V4.0.5.
 
Cause
Duplicate versions of Xerces JAR files were located in the application ear directory
 
Solution
This problem occurs when there are classes loaded by the application that are also loaded from different directories by the Application Server.
In the installedApps/lib directory for the EAR file, it contained duplicate Xerces JAR files that were different sizes than the ones that were in the WebSphere/appserver/lib directory. The following files were removed from installedApps/lib:
ibmxml.jar
jaxp.jar
xercesimpl.jar
xercessamples.jar
xml-apis.jar
xmlparserapis.jar


Once the 6 files were removed and the EAR was redeployed, the application no longer got the error.
WebSphere Application Server routinely updates classes. If the version of the class use by the Application Server is different than the class deployed in the EAR, problems will occur. Avoid including classes that are deployed by WebSphere Application Server.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Deploy (for example: AAT or ANT or EAR/WAR/JAR)
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1175349
IBM Group: Software Group
Modified date: Jul 27, 2004