"Failed to Start Transport." error appears when starting V4.0 Single Server Edition on AIX 5.1
 Technote (FAQ)
 
Problem
When starting WebSphere® Application Server V4.0, Single Server Edition, the following error appears in stdout:

Failed to Start Transport. The most likely cause is that the port is already in use. Please ensure that no other applications are using this port and restart the server. com.ibm.servlet.engine.TransportException: Failed to start transport http: java.net.BindException: The socket name is already in use.

 
Cause
This is because AIX® 5.1 comes with a Web-based System Manager that listens on port 9090 by default, which is the same port as the WebSphere Application Server V4.0 Single Server Edition administrative server. As a result, WebSphere Application Server will start, but you cannot reach the administrative console through http://server_name:9090/admin/
 
Solution
  1. Change the entry in the services file for this AIX service.

  2. Change websm.cfg, in the /usr/websm direcory. Within this file you can specify "port=xxxx", where xxxx is the port number for this service.

  3. Change the services file entry to the same port.

  4. Restart the operating system.

Websphere Application Server should now start.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Administrative Console (all non-scripting)
Operating system(s): AIX
Software version: 4.0
Software edition:
Reference #: 1105589
IBM Group: Software Group
Modified date: Mar 16, 2003