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Problem |
Slow systems and large trace activity can cause the Ping
Timeout and/or Initial Ping Timeout to expire during AdminServer
initialization. When this occurs, the Application Server fails to start
with a Corba COMM_FAILURE exception:
Example: 827.457 60d1788 ActiveEJBServ W Failed to initialize a server:
"Default Server"
java.rmi.MarshalException: CORBA COMM_FAILURE 1 Maybe; nested exception
is:
at java.lang.Exception.<init>(Compiled Code)
at java.io.IOException.<init>(Compiled Code)
at java.rmi.RemoteException.<init>(Compiled Code)
at java.rmi.MarshalException.<init>(Compiled Code)
at javax.rmi.CORBA.Util.mapSystemException(Compiled Code)
at com.ibm.ejs.sm.agent._AdminAgent_Stub.invokeActiveObject(Compiled
Code)
at com.ibm.ejs.sm.active.ActiveEJBServerProcess.configureServer(Compiled
Code)
at com.ibm.ejs.sm.active.ActiveEJBServerProcess.startAction(Compiled
Code)
at com.ibm.ejs.sm.active.ActiveObject.startObject(Compiled Code)
at com.ibm.ejs.sm.active.ActiveObject.start(Compiled Code)
at com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(Compiled
Code)
at com.ibm.ejs.sm.active.ActiveObject.invokeContainedObject(Compiled
Code)
at com.ibm.ejs.sm.agent.AdminAgentImpl.activeObjectInvocation(Compiled
Code)
at com.ibm.ejs.sm.agent.AdminAgentImpl.invokeActiveObject(Compiled Code)
at com.ibm.ejs.sm.agent._AdminAgent_Stub.invokeActiveObject(Compiled
Code)
at
com.ibm.ejs.sm.beans.LiveRepositoryObjectImpl$StartTask.execute(Compiled
Code)
at com.ibm.ejs.sm.util.task.AsyncTaskEngine$WorkerThread.run(Compiled
Code)
----- Begin backtrace for detail
org.omg.CORBA.COMM_FAILURE: minor code: 1 completed: Maybe
at java.lang.Exception.<init>(Compiled Code)
at java.lang.RuntimeException.<init>(Compiled Code)
at org.omg.CORBA.SystemException.<init>(Compiled Code)
at org.omg.CORBA.COMM_FAILURE.<init>(Compiled Code)
at org.omg.CORBA.COMM_FAILURE.<init>(Compiled Code)
at com.ibm.CORBA.iiop.IIOPConnection.purge_calls(Compiled Code)
at com.ibm.CORBA.iiop.ReaderThread.run(Compiled Code)
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Cause |
The Ping Timeout and/or Initial Ping Timeout settings can
be too short.
This error can occur if the Domino® LDAP server is misconfigured.
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Solution |
For each Application Server on the node, increase the
Initial Ping Timeout and the Ping Timeout. These values can be found in
the administrative console:
- Select an Application_Server,
- Select the Advanced tab,
- Scroll down to the Ping Timeout and Initial Ping Timeout
fields.
The default is 200 for Ping Timeout and 300 for Initial Ping
Timeout. Start by changing this to 2000 for Ping Timeout and
3000 for Initial Ping Timeout. This may be more than needed so use
your discretion when setting these values.
This error has also been seen with customers who are using Domino® LDAP,
WebSphere Portal Server, and WebSphere Application Server. |
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