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Problem |
WebSphere® Application Server's administration server
process fails to start, and there is no error message that shows root
cause. |
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Cause |
Error in the administrative server that has an unclear
root cause |
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Solution |
Administrative Server
Here is an example of a trace specification to add to the admin.config
file that traces applicable administration server threads:
# Tracing ORB, system management, naming and connection management:
com.ibm.ejs.sm.adminServer.traceString="com.ibm.ejs.cm.*=all=enabled:com.ibm.ejs.sm.*=all=enabled:com.ibm.ws.naming.*=all=enabled:com.ibm.ejs.ns.*=all=enabled:ORBRas=all=enabled"
com.ibm.ejs.sm.adminServer.traceOutput=/usr/WebSphere/AppServer/logs/adminServer.trace
Add the following lines for ORB COMM and Debug tracing:
com.ibm.CORBA.Debug=true
com.ibm.CORBA.CommTrace=true
Java™ SDK
The following is also helpful:
- Capture Java SDK information.
- Disable JIT Compiler.
- Turn on verbose:class to see what classes are
loaded.
These changes simplify the Java runtime environment and potentially list
the class file that is about to run. Follow the instructions provided in
Java
SDK MustGather technotes.
Also make this change in admin.config:
Before:
com.ibm.ejs.sm.util.process.Nanny.adminServerJvmArgs=-Xmx128m -Xminf0.15
-Xmaxf0.25 -Xms17M
After:
com.ibm.ejs.sm.util.process.Nanny.adminServerJvmArgs=-Xmx128m -Xminf0.15
-Xmaxf0.25 -Xms17M -verbose:class -Djava.compiler=NONE
Output:
The extra output is written to two files:
- adminServer.trace
- tracefile
Also review the nanny.trace (UNIX®) for failures. |
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