Admin Client Will Not Connect After Applying PTF3
 Technote (FAQ)
 
Problem
Customers have reported that after applying PTF3 that the admin server, with security enabled, starts up properly but when trying to launch the admin client they get the following message:
"ADGU2008E: The Administration Client failed to connect to the
Administration Server. Start the local or remote Administration Server
service before launching the Administration Client."

One customer had been using the same self signed certificates with WebSphere Application Server 4.0.1 and 4.0.2, but after moving to PTF3 this problem occurs. They did not have a problem when they used the default dummykeys shipped with WebSphere.
 
Cause
Where it was OK in earlier versions to have the signer certificates in the client key file and have nothing in trustfile, this no longer works with 4.0.3.
 
Solution
The following configuration works with 4.0.3:

Serverkey.jks contains the self-signed certificate and can have the signer certificate but is not necessary.

ServerTrustkey.jks needs to have the signer certificate for the self signed certificate.

Clientkey.jks must NOT have the signer certificate, the file can be empty.

ClientTrustkey.jks needs to have the signer certificate for the self signed certificate.

There is more information on using the IKeyman Tool for creating self signed certificates in the infocenter: www.ibm.com/software/webservers/appserv/doc/v40/ae/infocenter/

Sections 5.5.6.2.& 5.5.6.2.1

 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Security
Operating system(s): HP-UX
Software version: 4.0.3
Software edition:
Reference #: 1054655
IBM Group: Software Group
Modified date: Aug 14, 2004