Downloading and installing AIX Filesets is required to meet WebSphere Application Server prerequisites
 Technote (FAQ)
 
Problem
Some WebSphere® Application Server problems are resolved by applying operating system patches, also know as filesets or fixes. Following are directions for applying AIX® patches
 
Cause
AIX fixes are published as installp images on an external Web site.


Fixes are packaged differently for each AIX Maintenance Level, so correctly identifying the current Maintenance Level is necessary to insure that the fix resolves the WebSphere Application Server problem.

 
Solution
For example, installation of IY19277 resolves a problem where IBM® HTTP Server does not start after upgrading the WebSphere Application Server plug-in, and when upgrading to AIX 4.3.3.0, Maintenance Level 6 or higher. In this case, the indication is that the httpd process fails to start with a SIGSEGV.

The main link for finding AIX fixes is located at:

http://www.ibm.com/servers/eserver/support/pseries/aixfixes.html

Resolving the problem requires downloading and applying an AIX fix:
  1. Click the above link.

  2. Choose the OS level in the Specific Fixes line.

  3. Choose APAR Number or Abstract in the Search by box from the dropdown list.

  4. Type IY19277, or the appropriate fix number, into the Search string field.

  5. Click Go.

  6. Highlight the fix number; for example: IY19277.

  7. Click Add to my download list,

  8. Click Continue.

  9. Select your current maintenance level; for example: 4.3.3.0.06 is Maintenance Level 6.

    • You can determine your AIX Maintenance Level with the following command:

      instfix -i | grep AIX_ML

    • Usually, the last line of output identifies your current level. Not all filesets are required for WebSphere Application Server to run correctly. Here is an example:

      All filesets for 4.3.1.0_AIX_ML were found

      All filesets for 4330-06_AIX_ML were found

      Not all filesets for 4330-07_AIX_ML were found

      Not all filesets for 4330-08_AIX_ML were found

    • If the value returned is Not all filesets for 4330-09_AIX_ML were found, run the following command:

      instfix -icqk 4330-09_AIX_ML | grep ":-:"

      The components on t
      he list returned are components that must be installed to change the message from "Not all filesets..." to "All filesets...".

  10. Click Continue.

  11. Download the required filesets.
    1. Download into an empty directory.
      Use ls -a to make sure .toc is not present.
    2. Each item for download is a separate installation image for a specific component of AIX or an AIX product. SMIT installs only updates (these installp files) for products that are actually installed.
    3. Use SMIT to install; you do not need to commit.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Install
Operating system(s): AIX
Software version: 5.0.2.8
Software edition:
Reference #: 1041164
IBM Group: Software Group
Modified date: Oct 12, 2004