Admin server fails to start after security is enabled within WebSphere Application Server
 Technote (FAQ)
 
Problem
When security is enabled within WebSphere® Application Server, then the processes restarted, these exceptions appear:

[2/21/02 11:16:21:681 EST] 763a4f SecurityColla A SECJ0053E:
Authorization failed for ldap:389/runwas while invoking (Bean)ejsadmin/homes/SeriousEventLoggerHome log(com.ibm.ejs.sm.beans.SeriousEvent):1 securityName:
ldap:389/runwas;accessID: dummy-access-id is not granted any of the required roles: AdminRole
[2/21/02 11:16:21:706 EST] 763a4f ExceptionUtil X CNTR0019E:
Non-application exception occurred while processing method log: com.ibm.websphere.csi.CSIException: SECJ0053E: Authorization failed for ldap:389/runwas while invoking (Bean)ejsadmin/homes/SeriousEventLoggerHome log(com.ibm.ejs.sm.beans.SeriousEvent):1 securityName:ldap:389/runwas;accessID: dummy-access-id is not granted any of the required roles: AdminRole
at
com.ibm.ejs.security.SecurityCollaborator.performAuthorization(SecurityCollaborator.java:555)
at
com.ibm.ejs.security.EJSSecurityCollaborator.preInvoke(EJSSecurityCollaborator.java:139)
 
Cause
WebSphere Application Server fails to start after security is enabled
 
Solution
When setting up security in the Security Center, add the user name that is setup as the Security ID in the AdminRole.

For example, the user name "runwas" is defined as the Security ID and also in the AdminRole tab.

 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Security
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1066519
IBM Group: Software Group
Modified date: Mar 22, 2004