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Problem |
1.Environment:
Remote Admin Console running on Linux machine.
WebSphere Admin Server running on a remote AIX machine.
Global Security is enabled on the Admin Server.
2. When running the admin console on Linux, this error occurs:
"ADGU2008E: The Administration Client failed to connect to the
Administration Server. Start the local or remote Administration Server
service before launching the Administration Client."
3. Remote admin console works fine when security is NOT enabled.
4. The WebSphere version and edition on both boxes are identical.
5. Both the admin console and admin server are running as root, so file
permissions are not the problem. |
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Cause |
Linux has problems expanding
$(WAS_HOME), in sas.client.props. |
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Solution |
Check sas.client.props on the client
machine for these two lines:
com.ibm.ssl.keyStore=$(WASROOT)/etc/DummyClientKeyFile.jks
com.ibm.ssl.trustStore=$(WASROOT)/etc/DummyClientTrustFile.jks
Change these to specify the fully qualified path to
DummyClientTrustFile.jks and DummyClientKeyFile.jks
For example,
opt/WebSphere/AppServer/etc/DummyClientTrustFile.jks. |
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