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Problem |
Fix Installer generated an error when attempting to
install an fix on a Web server system in an HTTP remote configuration.
WebSphere® Application Server is installed on a different server than Web
server. |
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Cause |
When only the WebSphere Application Server plug-in and
Java™ SDK are installed, there can be problems with prerequisite checking
that result errors being reported by the eFixInstaller.
Example of an error message in extractor.log:
001/11/20 19:05:39 Error 128 -- Unable to determine container type at
location /opt/WAS4.0, process can not continue.
...
errors were noted, functionality may be compromised.
2001/11/20 19:05:39
2001/11/20 19:05:39 Please view the activity log for details.
2001/11/20 19:09:21 Error 128 -- Unable to determine container type
at location /opt/WAS4.0, process can not continue.
...
This is a limitation of the FixInstaller packaged with fixes prior to
PQ55839. |
|
Solution |
WebSphere Application Server server code does not need to
be installed on the Web server with a remote HTTP configuration.
- In most cases, changing the syntax of the command that installs the
interim fix will correct the problem:
java -jar PQ65742_eFix_AEServer_AEsServer.jar -target
install_root -skipContainerCheck -updatexml no
-dupcheck no
- The workaround is to use a tool like WinZip to remove the file(s )
containing the fix and to copy them manually.
Note: The Fix Installer code is bundled with the interim fix (most of the
files in the interim fix JAR are for the Fix Installer). |
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Historical Number |
PMR 78838
344
000 |
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