|
Problem |
WebSphere® Application Server V4.0 administrative server
fails to start with the following errors in the tracefile:
[2/2/04 8:19:34:996 PST] 4f3f2b58 AdminServer X WSVR0009E: Error occurred
during startup
java.lang.RuntimeException: com.ibm.ejs.EJSException: Could not register
with Location
[2/2/04 8:19:35:018 PST] 4f3f2b58 AdminServer F WSVR0067E: Failed to
initialize WebSphere Administration server |
|
Cause |
This can be caused by incorrect entries in the etc/hosts
file.
127.0.0.1 loopback localhost
11.25.220.27 washost
11.25.220.87 washost
To troubleshoot this problem, trace the administrative server by placing
the following lines in the admin.config:
com.ibm.CORBA.Debug=true
com.ibm.CORBA.CommTrace=true
com.ibm.ejs.sm.adminServer.traceString=ORBRas=all=enabled:com.ibm.ejs.sm.*=all=enabled
com.ibm.ejs.sm.adminServer.traceOutput=/usr/WebSphere/AppServer/logs/adminServer.trace
This should produce an error similar to the following:
ORBRas D
com.ibm.CORBA.iiop.ConnectionTable get(host=11.25.220.27 port=9000)
P=263586:O=0:CT caught exception ex=java.net.ConnectException: A remote
host refused an attempted connect operation.
In the example given, this is due to conflicting entries in the
etc/hosts file. The real IP address for this hostname is
11.25.220.87, not 11.25.220.27. |
|
Solution |
Remove the incorrect entry in the etc/hosts file and
restart the administrative server.
Also add the localhost entry if it is not present as this can also
cause the same problem.
Click the link below to see the full text of the error message.
|
|