MustGather: Out of Memory errors on Windows, Part 1
 Technote (FAQ)
 
Problem
MustGather for problems with the WebSphere® Application Server Out of Memory component on a Microsoft® Windows® platform. Gathering this information before calling IBM® support helps familiarize you with the troubleshooting process and saves you time.
 
Cause
Two conditions can cause a java.lang.OutOfMemoryError:
  • The Java™ Virtual Machine (JVM™) might run out of Java heap space to allocate a Java object.

  • The JVM might not be able to allocate the native memory needed for all threads to execute.
 
Solution
If you have already contacted IBM Support, continue gathering the MustGather information for the applicable component. Otherwise, please refer to MustGather: Read first for all WebSphere Application Server products.

Out of Memory errors specific MustGather information
Follow these steps to set up the failing system for capturing required information:
  1. Refer to the instructions in the following Technote: Enabling verbosegc in WebSphere Application Server.

  2. Stop the Application Server.

  3. Clear all Application Server log files before starting your test.

  4. Restart the Application Server.

  5. Wait for your problem to re-occur.

  6. Collect the following:
    • For WebSphere V6.0:
      1. All files in install_root\profiles\profile_name\logs\ffdc.
      2. All files in install_root\profiles\profile_name\logs\server_name.
      3. A copy of server.xml located in install_root\profiles\
        profile_name
        \config\cells\cell_name\nodes\node_name
        \servers\
        server_name.

    • For WebSphere V5.0 and V5.1:
      1. All files in install_root\logs\server_name.
      2. All files in install_root/logs/ffdc.
      3. A copy of server.xml located in install_root\config\cells\
        cell_name
        \nodes\node_name\servers\server_name.

    • For WeSphere V3.5 and V4.0:
      1. All files in install_root\logs.
      2. A copy of XMLExport for the server configuration.

    • For all versions of WebSphere:
      • All heapdump*.* and javacore*.* files if any were generated by the Out Of Memory condition.
      • Note: For all versions, if you have configured the Application Server to write logs into a different location, send them accordingly.

  7. Determine if the source of the leak is the Java heap or native memory:
    1. If available memory does NOT drop, follow the instructions in:
      MustGather: Out of Memory errors on Windows, Part 2a - Native Leak

    2. If available memory listed in heap drops over time, follow the instructions in:
      MustGather: Out of Memory errors on Windows, Part 2b - Heap Leak

  8. Follow the instructions in: Submitting Diagnostic Information to IBM Technical Support for Problem Determination.


For a listing of all technotes, downloads, and educational materials specific to the Out of Memory component, search the WebSphere Application Server Support site.
 
Related information
How to enable verbosegc in WebSphere
Submitting information to IBM support
Steps to getting support
MustGather: Readme first
Troubleshooting guide
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Out of Memory
Operating system(s): Windows
Software version: 6.0
Software edition:
Reference #: 1055371
IBM Group: Software Group
Modified date: Apr 5, 2006