Fix pack does not successfully install on Windows
 Technote (FAQ)
 
Problem
Certain third-party products, such as enterprise management software, might lock some Windows® files, resulting in the failure of a fix pack upgrade.
 
Cause
Certain products can cause WebSphere® Application Server .dll files to lock and not be upgraded when the fix pack (V6.0) or cumulative fix (previous releases) is installed. The lock can occur even if WebSphere Application Server and the Web server are not running during fix pack/cumulative fix installation. Errors for upgrading certain files show up in the WebSphere Application Server installation logs. An example of this is NTRegistry.dll failing to upgrade on the installation.
 
Solution
If this occurs, follow these steps:
  1. Uninstall the fix pack.
  2. Delete or rename the backup Java™ archive (JAR) file when the uninstall is successful.
  3. Set the WebSphere Application Server and Web server services, in the Windows Control Panel, to MANUAL.
  4. Reboot the system.

Now you can apply the fix pack successfully and start the Web server and Application Server.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Install
Operating system(s): Windows
Software version: 6.0
Software edition:
Reference #: 1048990
IBM Group: Software Group
Modified date: Jul 30, 2005