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Problem |
A trace of system calls and signals
indicates the interaction between WebSphere® Application Server's Java™
processes and the Linux® operating system. |
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Cause |
WebSphere Application Server runtime errors can be
associated with entries in the Linux syslog or the Application Server
logs. |
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Solution |
Use the strace utility to
trace system calls and signals.
Following explains how to use strace
against an Application Server process:
- Open the WebSphere Application Server advanced administrative console.
- Click an Application Server in a node:
Select WebSphere Administrative Domain > Nodes > node name
> Application Servers > application server name
- On the General tab, click Environment. Add the environment variable,
DEBUG_PROG, with value(strace command arguments), for example:
Name |
Value |
DEBUG_PROG |
/usr/bin/strace -ff -o filename -F
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- Click Apply, then restart the Application Server
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