SQL1224N error on startup of V4.0 when using IBM DB2 V8 administrative repository
 Technote (FAQ)
 
Problem
WebSphere® Application Server V4.0 (all releases) startup results in SQL1224N StaleConnectionException when using an IBM® DB2® V8 administrative repository.
 
Cause
When using a DB2 V8 administrative repository, the following error can occur:


[8/20/03 11:16:07:760 CDT] 4842b622 StaleConnecti A CONM7007I: Mapping the following SQLException, with ErrorCode -1,224 and SQLState 40003, to a StaleConnectionException: COM.ibm.db2.jdbc.DB2Exception: [IBM][CLI Driver] SQL1224N  A database agent could not be started to service a request, or was terminated as a result  of a database system shutdown or a force command.  SQLSTATE=55032

This error can occur with a remote database or a local database that is configured through TCP/IP loopback adapter.

DB2 APAR IY47905 reports this error against DB2 and relates to the db2checkclientinterval setting. In DB2 V8, the default value for db2checkclientinterval is 100.

 
Solution
Change the value of db2checkclientinterval to 0 using the following DB2 command:

db2setregistry db2checkclientinterval=0

Or install fix pack 4 or above to DB2/2.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > DB Connections/Connection Pooling
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1143909
IBM Group: Software Group
Modified date: Feb 1, 2005