How to trace system calls and signals from a WebSphere Application Server process
 Technote (FAQ)
 
Problem
A trace of system calls and signals indicates the interaction between WebSphere® Application Server's Java™ processes and the Linux® operating system.
 
Cause
WebSphere Application Server runtime errors can be associated with entries in the Linux syslog or the Application Server logs.
 
Solution
Use the strace utility to trace system calls and signals.

Following explains how to use strace against an Application Server process:


  1. Open the WebSphere Application Server advanced administrative console.


  2. Click an Application Server in a node:

    Select WebSphere Administrative Domain > Nodes > node name > Application Servers > application server name


  3. On the General tab, click Environment. Add the environment variable, DEBUG_PROG, with value(strace command arguments), for example:

    Name Value
    DEBUG_PROG /usr/bin/strace -ff -o filename -F


  4. Click Apply, then restart the Application Server
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Java SDK
Operating system(s): Linux
Software version: 4.0
Software edition:
Reference #: 1173062
IBM Group: Software Group
Modified date: Jun 28, 2004