WebSphere Application Server 4.0.x AEs applications are not "runnable", so shutdown fails
 Technote (FAQ)
 
Problem
Application server starts but all applications installed show up as not runnable.

Also the shutdown of the application server fails with the following error:
Stopping server.
Failed to open socket
WSRU0054E: Exception: java.net.ConnectException: Connection refused:
connect
 
Cause
In server-cfg.xml file the following line is seen
traceSpecification="com.ibm.*=all=disabled"
traceOutputFilename="${WAS_ROOT}/logs/stdout_trace"
diagThreadPort="7000"/>
 
Solution
Change the enable="false" to enable="true"

Example:

<traceService xmi:id="TraceServiceConfig_1" enable="true"
traceSpecification="com.ibm.*=all=disabled"
traceOutputFilename="${WAS_ROOT}/logs/stdout_trace"
diagThreadPort="7000"/>

 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Servlet Engine/Web Container
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1114292
IBM Group: Software Group
Modified date: Jul 9, 2003