WWLM0019: Method getNextClone found no usable proxies in the list
 Technote (FAQ)
 
Problem
What is Workload Management trying to tell us with this warning message?
 
Cause
The reason that this message displays is because all of the clones in the clients' application server group are marked as unavailable. There are several possible reasons why the clones are marked unavailable. Refer to the Common culprit section below for a list of the possible reasons.

When this message is reported, WLM attempts to contact the administrative server to get updated server group information. If WLM is unable to contact the administrative server, it uses a different administrative server from the server group (as long as administrative server failover is not disabled). If the last administrative server is unavailable, the WLM code displays this message again, but this time for the administrative server group information. WLM then continues to attempt to contact an administrative server until it is either successful, or the client application stops. If it is unsuccessful, the message is logged over and over again until success or until the client application ends.

After the WLM code contacts the administrative server, it gets updated server group information for the client application server group. After it has the updated client application server group information, it either routes the method request to an available clone, or if no clones are available, returns an exception to the client application.

View this as a Warning message, not an Error message. It is a warning message because it is an indicator that something is causing clones to be marked as unavailable that might not actually be unavailable. The client application can run normally, although routing of client requests might not be optimal or reflective of a Round Robin behavior if that routing policy is selected. If the client receives an exception back from WLM in regards to this warning, the customer must determine why client-to-server communications are being interrupted.

 
Solution
Error
[8/19/02 22:04:21:359 SGT] 866e978 MasterProxy W WWLM0019: Method getNextClone found no usable proxies in the list. Current exception:
Message:
WWLM0019: Method getNextClone found no usable proxies in the list.
Stack trace:
com.ibm.ws.wlm.client.proxy.NoUsableProxyException
at com.ibm.ws.wlm.client.proxy.RoundRobinProxySelector.getNextClone(RoundRobinProxySelector.java:95)
at com.ibm.ws.wlm.client.proxy.RoundRobinPreferLocalProxySelector.getNextClone(RoundRobinPreferLocalProxySelector.java:82)
at com.ibm.ws.wlm.client.proxy.MasterProxy.getNextClone(MasterProxy.java:165)
at com.ibm.ws.wlm.client.proxy.ProxyManager.getTarget(ProxyManager.java:103)
at com.ibm.ws.wlm.client.WLMClient.getNextTarget(WLMClient.java:205)
at com.ibm.CORBA.iiop.ClientDelegate.createRequest(ClientDelegate.java:1003)
at com.ibm.CORBA.iiop.ClientDelegate.request(ClientDelegate.java:1820)
at org.omg.CORBA.portable.ObjectImpl._request(ObjectImpl.java:245)
at com.ibm.ejs.sm.beans._SeriousEventLogger_Stub.log(_SeriousEventLogger_Stub.java:234)
at com.ibm.ejs.sm.server.SeriousEventListener$DeliveryThread.run(SeriousEventListener.java:319)


Common Culprits
  1. Networking issues, the client is unable to reach the server through the network.

    Examples:
    1. The network is bogged down and not routing traffic correctly.
    2. The LAN connection has a bad cable/connection and might be acting as if it is unavailable from time to time, resulting in intermittent unavailability.

  2. If security is enabled or if firewalls are used, confirm that the ports are open (and staying open) and that they are available and not in service by another application.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Workload Management (WLM)
Operating system(s): Windows
Software version: 4.0
Software edition:
Reference #: 1063613
IBM Group: Software Group
Modified date: Mar 27, 2006