SOAP Fault is written to the WebSphere JVM logs
 Technote (FAQ)
 
Problem
In an application, if the server side implementation class throws a SOAPException
the WebSphere runtime generates a SOAP Fault and sends it to the client. The exception is written to SystemOut.log. An example of this type of exception would be this:

[5/12/04 9:19:37:356 EDT] 3deac201 WebServicesSe E com.ibm.ws.
webservices.engine.transport.http.WebServicesServlet WSWS3227E: Error: Exception:
[5/12/04 9:19:37:376 EDT] 3deac201 WebServicesSe E com.ibm.ws.
webservices.engine.transport.http.WebServicesServlet TRAS0014I: The following exception was logged WebServicesFault faultCode: {http://api.dms.tivoli.com}DeviceManagerException
faultString: com.tivoli.dms.api.DeviceManagerException: DYM2069E: The
target device id does not exist.

The exception itself is normal and expected. Is there a way to prevent the exception from being written to the WebSphere SystemOut.log?
 
Cause
In WebSphere Application Server versions 5.1 releases and below, there is no way to avoid having these types of exceptions show up in the SystemOut.log.
 
Solution
IBM is considering adding a feature in a future release to allow you to turn off logging SOAP Faults to the JVM logs.
 
 
Historical Number
71893. 499. 000
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Web Services (for example: SOAP or UDDI or WSGW or WSIF)
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1176632
IBM Group: Software Group
Modified date: May 20, 2005