Remote Admin Console Fails to Connect to Admin Server
 Technote (FAQ)
 
Problem
Attempting to run a remote admin console (from Linux, AIX, or Windows) fails. The login prompt is never displays.
 
Cause
This was working ok until WebSphere adminserver was restarted (after running without change for about 2 weeks).

Error displayed is:
ADGU2008E: The Admin Client failed to connect to the Admin Server. Start the local or remote Admin Server service before launching the Admin Client.

ORB trace shows the following:

[11/14/02 16:46:59:499 EST] 44b46c0d ORBRas >
com.ibm.CORBA.iiop.sslight.IIOPSSLConnection ijavaorb P=812764:O=0:CT
Entry

ctor(orb,server,ConnectionTable,host,port)
Host[127.0.0.1] Port[9001]
[11/14/02 16:46:59:500 EST] 44b46c0d ORBRas >
com.ibm.CORBA.iiop.sslight.IIOPSSLConnection ijavaorb P=812764:O=0:CT
Exit

ctor(orb,server,ConnectionTable,host,port)
[11/14/02 16:47:00:358 EST] 44b46c0d WsnInitCtxFac D
mergeWsnNSProperties: COMM_FAILURE:
org.omg.CORBA.COMM_FAILURE: Could not
create Client Side Socket java.net.ConnectException: Connection refused
minor code: 1 completed: No


The problem was in the /etc/services file where an install of a fileset (to do with CDE or graphics services, it seems) has included this entry: x_st_mgrd 9000/tcp # IBM X Terminal

Port 9000 is the default lsdPort used by WebSphere Application Server; the entry in etc/services for this port inserted by another software product caused the conflict.

 
Solution
Remove the entry on the adminserver side. Stop and start WebSphere the remote access should now work.
 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Administrative Console (all non-scripting)
Operating system(s): HP-UX
Software version: 4.0
Software edition:
Reference #: 1078856
IBM Group: Software Group
Modified date: Aug 28, 2004