|
Problem |
In WebSphere® Application Server 3.5.x, a problem might
occur after redeploying an EJB™ that has previously been deployed, and
starting the EJB from the administrative console. An error similar to the
following might occur:
com.ibm.websphere.csi.CSIException: failed to get home instance; nested
exception is:
com.ibm.ejs.container.ContainerException: loading bean meta data failed;
nested exception is:
java.lang.ArrayIndexOutOfBoundsException: 11 |
|
Cause |
Most likely, the EJB was not correctly removed before it
was redeployed. |
|
Solution |
To fix this problem, follow these steps:
- Ensure that the Application Server starts without a problem.
- From the administrative console, stop the Application Server.
- From the administrative console, right-click on the enterprise beans
that are having the problem, then click Remove.
- Remove the EJB JAR files from the directory where they are installed.
- From the administrative console, right-click the Container, then click
create > Enterprise Bean.
- Click Browse, then choose the EJB JAR file. Click Select.
- Click Yes, then click OK. This creates the EJB, which is displayed in
the administrative console.
- Start the application server. The Application Server and EJB now start
without a problem.
|
|
|
|
|
|
|