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Problem |
WebSphere® Administration Server does not start due to
DrAdmin not being able to obtain a valid port. The tracefile reports a “
DrAdminServer I WSVR0054E: Failed to create a server socket, the port 0
maybe in use: The socket name is not available on this system.”
error. |
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Cause |
This error is outside of WebSphere code and is either in
the operating system configuration or the network (DNS) configuration
area. In two observed cases, both networks required changes to their
DNS. |
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Solution |
Possible Scenarios
- Application hangs and won’t restart and attempt to recycle the
Administrative Server fails with the error message below.
- Administrative Server hangs and attempt to recycle it fails with the
error message below.
Note: On UNIX® platforms a core file is produced in both
situations. Run either DBX or GDB against the core file before sending to
support (weblev2@us.ibm.com) for review.
Error Message
[8/1/02 12:00:30:079 MDT] 7c6ec35c DrAdminServer I WSVR0054E: Failed to
create a server socket, the port 0 maybe in use: The socket name is not
available on this system.
java.lang.NullPointerException
at com.ibm.ejs.sm.util.debug.DrAdminServer$2.run(DrAdminServer.java:350)
at java.security.AccessController.doPrivileged(Native Method)
at com.ibm.ejs.sm.util.debug.DrAdminServer.listen(DrAdminServer.java:347)
at
com.ibm.ejs.sm.util.debug.DrAdminServer$ServerRunner.run(DrAdminServer.java:243)
[8/1/02 12:00:30:373 MDT] 7c6ec35c AdminServer X WSVR0009E: Error
occurred during startup
java.lang.NullPointerException
at
com.ibm.ejs.sm.util.debug.DrAdminServer.getServerPort(DrAdminServer.java:326)
at
com.ibm.ejs.sm.util.debug.DrAdminServer$ServerRunner.getServerPort(DrAdminServer.java:248)
at
com.ibm.ejs.sm.util.debug.DrAdminServer.runServer(DrAdminServer.java:228)
at com.ibm.ws.runtime.Server.initializeDiagnosticThread(Server.java:1628)
at com.ibm.ws.runtime.Server.initializeRuntime0(Server.java:959)
at
com.ibm.ejs.sm.server.ManagedServer.initializeRuntime0(ManagedServer.java:408)
at
com.ibm.ejs.sm.server.AdminServer.initializeRuntime0(AdminServer.java:1125)
at com.ibm.ws.runtime.Server.initializeRuntime(Server.java:884)
at com.ibm.ejs.sm.server.AdminServer.main(AdminServer.java:392)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:158)
[8/1/02 12:00:30:549 MDT] 7c6ec35c AdminServer F WSVR0067E: Failed to
initialize WebSphere Administration server
[8/1/02 12:00:30:731 MDT] 7c6ec35c SystemOut U WSVR0067E: Failed to
initialize WebSphere Administration server
java.lang.Throwable
at
com.ibm.ejs.ras.TraceEventGeneratorImpl.fireTraceEvent(Tr.java(Compiled
Code))
at
com.ibm.ejs.ras.TraceEventGeneratorImpl.fireTraceEvent(Tr.java(Compiled
Code))
at com.ibm.ejs.ras.Tr.fatal(Tr.java:880)
at com.ibm.ejs.sm.server.AdminServer.main(AdminServer.java:406)
at java.lang.reflect.Method.invoke(Native Method)
at com.ibm.ws.bootstrap.WSLauncher.main(WSLauncher.java:158)
Note: If in the admin.config file, you have the DrAdmin port
number defined such as
com.ibm.ejs.sm.adminServer.diagThreadPort=1224, this portion of the
error: "the port 0 maybe in use" becomes: “the port 1224 maybe in use.”
The port 0 means that DrAdmin asked to have the next available port on the
system opened and it was declined because no ports were available.
Resolutions
1. Ensure the /etc/hosts file exists and has an entry (TECHNOTE XXXXX)
#vi /etc/hosts
127.0.0.1 loopback localhost
If it’s not listed, add it, if it looks different from this edit to
match.
2. Do a network statistic:
#netstat -in
lo0
en0
tr0
Ensure that you do not have an * listed by any of your interfaces,
especially lo0.
3. Call the localhost:
#host localhost
localhost is 212.15.64.41 (problem!!)
What we want it to look like is:
loopback is 127.0.0.1 aliases: localhost
4. Edit the netsvc.conf file and add the following line:
#vi netsvc.conf
hosts=local,bind4 (suppress ipv6 queries to the Name Server)
5. Call the localhost:
#host localhost
loopback is 127.0.0.1 aliases: localhost
6. You can now start WebSphere.
7. If you still encounter problems, call IBM AIX® Support at 800-225-5249
for further assistance. |
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