Java process exits without leaving a footprint in WebSphere log files
 Technote (FAQ)
 
Problem
When a Java™ process exits, no log files are produced. This technote explains how to debug the Java process by disabling the Just-In-Time (JIT) compiler and enabling Java Native Interface (JNI) tracing.
 
Cause
There are two known causes of a Java process exiting without a footprint (no core file produced on UNIX® or no user.dmp file produced on Windows®). This can be caused by Java Native Interface (JNI) code exiting gracefully or through a failure in Just-In-Time (JIT) compilation.
 
Solution
Debugging this problem involves disabling the JIT compiler and enabling JNI tracing. Verbose JNI trace reports information about use of native methods and other Java Native Interface activity.

Follow the section that applies to the version of WebSphere Application Server that is installed on your system.

For releases of WebSphere Application Server V5:

  • How to disable Just-In-Time (JIT) compiler

  • How to enable verboseJNI:
    1. In the administrative client, expand Servers, then click on Application Servers.
    2. Click on the server that is encountering the problem.
    3. Under the Additional Properties section, click Process Definition.
    4. Under the Additional Properties section, click Java Virtual Machine.
    5. Place a check mark next to Verbose JNI.
    6. Click apply.
    7. At the top of the administrative client, click Save to save the changes to your configuration.
    8. Stop and start the application server.
    9. The verbose JNI output will be placed in the native_stderr.log file for the application server.

For releases of WebSphere Application Server V4.0:

  • How to disable Just-In-Time (JIT) compiler

  • How to enable verboseJNI on Advanced Edition
    1. In the administrative client, navigate to the application server and select it.
    2. Click on the JVM Settings tab.
    3. Click Advanced JVM Settings.
    4. Check the box verbose JNI.
    5. Click OK.
    6. Click apply.
    7. Stop and start the application server.
    8. The verbose JNI trace will be placed in the stderr file for the Application Server

  • How to enable verboseJNI on Advanced Edition Single Server
    1. In the administrative client, expand your node and then expand the application servers folder.
    2. Select the application server and expand it.
    3. Expand Process Definition.
    4. Select JVM Settings.
    5. Place a check mark next to verbose JNI.
    6. Click OK.
    7. At the top of the administrative client, click Save to save the changes to your configuration.
    8. Stop and start the application server.
    9. The verbose JNI trace will be placed in the stderr file for the Application Server

Note: Verbose JNI trace logs to the application server native_stderr file in releases of WebSphere Application Server V5 and stderr in releases of WebSphere Application Server V4.

 
 
 


Document Information


Product categories: Software > Application Servers > Distributed Application & Web Servers > WebSphere Application Server > Java SDK
Operating system(s): HP-UX
Software version: 4.0.7
Software edition:
Reference #: 1144595
IBM Group: Software Group
Modified date: May 29, 2004