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Chapter 1

Introduction
About This Manual

This guide tells you how to use TeamXpress. It refers to the version of TeamXpress that runs on the 
Solaris and Windows NT® or Windows 2000® server platforms and a variety of client platforms—
Windows 95, 98, NT or 2000, Macintosh, or several types of UNIX. For more information on 
supported client platforms, see the “Getting Started” chapter of this manual.

Notation Conventions

This manual uses the following notation conventions:

Boldface text represents the exact text that appears in a GUI element (e.g. a menu item, button, or 
element of a dialog box). For example:

Click the Edit File button in the Button Bar.

Monospaced text represents command-line output, or file names. For example:

The iwextattr command-line tool allows you to set and look up extended attributes on a file.

Monospaced italic text represents a command-line variable. For Windows NT or Windows 
2000, the commonest example of this is iw-home, which refers to the directory where TeamXpress is 
installed. 

For example:

iw-home\etc\iw.cfg

is the path to the main TeamXpress configuration file, iw.cfg, which is located in the etc directory 
under the TeamXpress installation directory.

iwckrole role user
7



Introduction
means that you must insert the values of role and user yourself.

Monospaced bold  text represents user input. The  character that appears before a line of user 
input—% for Solaris or > for NT/2000—represents the command prompt, and should not be typed. 
For example:

http://TeamXpress_hostname/iw

means that you must enter the above text as represented, inserting the TeamXpress hostname in place 
of the italicized text.

Square brackets [] surrounding a command-line argument mean that the argument is optional.

A | character separating command-line arguments means that only one of the arguments should be 
used.

Support Information

For support information concerning IBM TeamXpress, refer to the following URL: 
http://www-4.ibm.com/software/webservers/teamxpress/support.html.

Overview

TeamXpress Structure

TeamXpress allows you to structure your Web development into different branches. Each branch 
contains private workareas, which contain complete virtual copies of the Web site; a staging area, where 
contributors integrate their work; and editions, which are read-only snapshots of the Web site at 
various points in its development. Each area contains a virtual copy of the entire Web site. Content is 
submitted from workareas to the staging area, and the staging area is then published as an edition. 
Editions may then be deployed to your production server.
8 TeamXpress User’s Guide
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Introduction
Branches

TeamXpress allows you to structure your Web site into various branches of development. Branches may 
be related to each other (e.g. alternate language versions of the same Web site) or they may be 
completely independent (e.g. internet and intranet Web sites). Each branch contains all the content 
for a Web site. In TeamXpress, you cannot create workareas off of the main branch. Additionally, 
depending on the licensing agreement, you may not be able to add branches or sub-branches.

A single branch contains archived copies of the Web site as editions, a staging area for content 
integration, and individual workareas where users may develop content without disturbing one 
another. Branches can also contain sub-branches, so that teams may keep alternate paths of 
development separate from each other. Content can be easily shared and synchronized across branches 
and sub-branches. Users may work on one branch or on several, and the number of branches on a 
system is not limited.

Branches allow separate teams to work independently on different jobs. Because all branches are 
located on the same TeamXpress server, it is easy for one team to incorporate the work of another 
into their job. 

Branches are depicted in TeamXpress with the  icon. 

Sub-branches

A sub-branch is a branch subordinate to a major branch. Each sub-branch receives its own unique 
staging area and workareas and generates its own editions, and it may contain sub-branches of its own. 
Editions published on a sub-branch can be integrated back into work on the higher branch, or released 
as stand-alone Web sites.

Workareas

A workarea is a virtual copy of the entire Web site. Contributors can create content within workareas 
and see their changes within the context of the Web site without affecting the actual site or the work 
of other contributors. Users who have access to a workarea may modify files within that workarea and 
view their changes within the context of the entire Web site before integrating their work with that of 
other contributors (this process is known as SmartContext™ QA). Users can lock files in each 
workarea, eliminating the possibility of conflicting edits.
10 TeamXpress User’s Guide



Overview
All changes that are made to files in a workarea are kept completely separate from other workareas 
and the staging area until the user chooses to promote his changes to the staging area. Within a 
workarea, users may add, edit, or delete files, or revert to older versions of files without affecting 
other users. 

Workareas are depicted in TeamXpress with the  icon.

Staging Areas

A staging area is where the work of different contributors is coordinated. Contributors can submit the 
contents of their workareas to the staging area to confirm that their work is well integrated with that 
of other contributors. 

Staging areas are depicted in TeamXpress with the  icon.

Editions

An edition is an archived, read-only version of the Web site that can be deployed to the Web server. 
Editions are “snapshots” of the staging area at a particular point in time. Older editions are kept in the 
branch along with the current version. Contributors can create new editions any time they feel their 
work is well integrated, or any time they want to create an update to the Web site for reference or 
deployment. Each edition is a fully functional version of the Web site, so that users may see the 
development of the Web site over time and compare it with current work.

Editions are depicted in TeamXpress with the  icon. Editions that have been compressed to save 

disk space are depicted with the  icon.
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Introduction
TeamXpress Users

TeamXpress has four classes of users: Authors, Editors, Administrators, and Master users. Each of 
these types has different abilities and levels of influence within the structure of TeamXpress.

Authors

Authors are primary content creators. All work done by Authors goes through an explicit approval step. 
They can receive assignments from Editors, which are displayed in Task lists when Authors log in to 
TeamXpress. Authors can access TeamXpress from a simple browser-based interface, and do not need 
to be sophisticated computer users.

In order to test and QA their work, Authors have full access to the content in their Editors’ 
workareas, but do not need to concern themselves with the larger structure and functionality of 
TeamXpress. The Author role is appropriate for non-technical users, or for more technical 
contributors who do not need access to TeamXpress’s extended functionality, such as TeamXpress’s 
advanced version management features.

Editors

Editors own workareas. They create and edit content, just as Authors do, but they are primarily 
responsible for managing the development taking place within their workareas. This includes advanced 
version management, participation in workflow processes and submitting completed content to the 
staging area, and it may include publishing editions.

Editors have access to specialized TeamXpress content and workflow management functions. Editors 
are generally “managerial” users, who primarily supervise the work of Authors, or self-managing 
“power” users, who need TeamXpress’s extended functionality to manage their own content.

Administrators

Administrators own branches. They have all the abilities of Editors, but they are primarily responsible 
for the content and functioning of their branch. Administrators can manage project workflow by 
creating new workareas for Editors and groups, and by creating sub-branches of their own branch to 
explore separate paths of development.

An Administrator is the supervisor of the project being developed on his branch. He may be the Web 
master for a particular version of the Web site, or a project manager.
12 TeamXpress User’s Guide
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Masters

Master users own the Web site. They can perform all the functions of Editors and Administrators on any 
branch. The Master user owns the main branch, from which all sub-branches are created. The Master 
user is generally involved in the installation of TeamXpress, and can reconfigure TeamXpress on a 
system-wide basis.

TeamXpress Workflow

Workflow Models

A workflow model is a general workflow configuration that can be used repeatedly. Each workflow 
model describes a process which may include user tasks and a wide variety of automated tasks. 
Workflow models are configured by the system administrator. For more information about 
configuring different workflow models, consult Administering TeamXpress.

Below is a diagram of a very simple assign-edit-approve workflow model. Email is sent to the 
participants at every stage of the process, and some automated tasks are performed at the end.

Workflow model
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Introduction
Jobs

A job is a set of interdependent tasks. One example of a TeamXpress job would be the set of tasks 
needed to prepare a new section in a marketing Web site to support a new product launch.

Each job is a specific instance of a workflow model. When a job is created, the job creator must supply 
all the specific information for that job. For example, the workflow model above might be used to 
create the job below. 

Job model

Because jobs follow predefined workflow models, tasks cannot be added to or removed from 
individual jobs.

Tasks

A task is a unit of work performed by a single user or process. Each task in a job is associated with a 
particular TeamXpress workarea and carries a set of files with it. The user or process owning a task can 
modify, add files to, or remove files from the task. 

Tasks have two possible states: active and inactive. A task becomes active when its predecessor tasks 
signal it to do so (predecessor tasks and conditions for activation are all configured as part of the 
workflow model). Once the task has been activated, users or external programs can do work on it. 
For example, once a user task has been activated, the user can work on the files contained in the task. 
Once an external task has been activated, the appropriate external program can run on the files 
contained in the task. Inactive tasks are tasks that have been completed, or that have not been 
activated yet.
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Chapter 2

Getting Started
The TeamXpress graphical user interface (GUI) gives you full access to TeamXpress through a simple 
browser-based interface. The GUI is used to perform all functions specific to TeamXpress, as well as 
some general file management functions such as creating new files and directories. The GUI is also 
used to edit files and perform in-context QA. TeamXpress supports the input of multiple languages 
through the GUI. For details, see Appendix B, “Internationalization”.

TeamXpress branch structure, as seen through the GUI
15



Getting Started
Choosing a Browser

The TeamXpress GUI runs through a browser such as Netscape or Internet Explorer. The TeamXpress 
thin-client interface does not require you to install any other client software unless you will be editing 
files through the TeamXpress GUI. If you will be editing files, you will need to install a small utility 
called LaunchPad (see page 18).

Not all TeamXpress features are compatible with all browsers on all client platforms. The following 
tables show compatibility for most popular browsers on all supported client platforms: 

Windows 95, 98, 2000, and NT

Netscape Internet 
Explorer

4.06-
4.08

4.5x 4.6 4.7 4.x 5.0

TeamXpress 
GUI Yes Yes Yes Yes1

1. Recommended

Yes Yes*

SmartContext 
Editing No Yes Yes Yes Yes Yes

Merge Yes Yes Yes Yes Yes Yes

Solaris

Netscape Internet 
Explorer

4.06-
4.08

4.5x 4.6 4.7 4.x 5.0

TeamXpress 
GUI Yes Yes Yes Yes* No Yes*

SmartContext 
Editing No Yes No Yes No Yes

Merge Yes Yes Yes Yes No Yes
16 TeamXpress User’s Guide



Logging In to TeamXpress
Logging In to TeamXpress

1. Access TeamXpress through your browser:

http://TeamXpress_hostname/iw/

2. The TeamXpress login screen will appear. If this is your first time using TeamXpress, and you are 
using Windows 95, 98, NT, or 2000, TeamXpress’s helper application, LaunchPad, will auto-
install on your computer. If you are not using Windows, you will need to install LaunchPad manu-
ally (Macintosh users: see page 20, UNIX users: see page 24).

3. Select your user type (Author, Editor, Administrator, or Master) using the pulldown menu.

4. Enter your username and password, and select your Domain (Solaris only) from the pull-down 
menu.

Macintosh

Netscape Internet 
Explorer

4.06-
4.08

4.5x 4.6 4.7 4.01 4.5

TeamXpress 
GUI Yes Yes Yes Yes1

1. Recommended

Yes Yes*

SmartContext 
Editing No No No No No No

Merge No No No No Yes Yes
17



Getting Started
5. Click the Login button.

TeamXpress login screen for NT/2000

TeamXpress login screen for Solaris

6. The TeamXpress window will appear. The view that appears is called your Home page and can be 
returned to at any time by clicking the Home button in the Button Bar. You can set the Home but-
ton to go to any location in TeamXpress where you have access (see page 42).

If you have not set your Home page, TeamXpress will show you a list of the jobs that you own. If 
you are an Author, TeamXpress will show you a list of the tasks that you own.

In future logins, TeamXpress will “remember” your latest settings through a cookie it sets on your 
computer.

Installing and Configuring LaunchPad

If you are going to edit files or view them in an editing application, you need to install LaunchPad. 
LaunchPad is a small helper application that resides on your local computer, which allows you to make 
associations between file types and the editing applications you want to use. For example, your 
computer may automatically be configured to always open HTML files in a browser. You can configure 
LaunchPad so that when you open an HTML file through the TeamXpress GUI, it will open in your 
editing application instead. 
18 TeamXpress User’s Guide



Installing and Configuring LaunchPad
If you are using Windows 95, 98, NT, or 2000, LaunchPad will automatically install itself the first 

time you log in to TeamXpress1. For all other platforms, or if your site has auto-install disabled, see 
page 19. Consult the following sections about configuring and using LaunchPad on all platforms.

LaunchPad is available for:

• Windows 95, 98,NT, or 2000 (see page 19)

• Macintosh (see page 20)

• UNIX (see page 24)

LaunchPad for Windows 95, 98, 2000 or NT

The first time you log in to TeamXpress, LaunchPad will automatically download and install on your 
local computer.

For LaunchPad to auto-install, your browser must be running on Windows NT, 95, 98, or 2000, and 
(if you are using Netscape) Java and auto-install must both be enabled.

To enable Java with Netscape:

1. Select Edit > Preferences. 

2. In the left-hand pane, click Advanced. 

3. Make sure the check box next to Enable Java is checked.

To enable auto-install with Netscape:

1. Select Edit > Preferences. 

2. In the left-hand pane, double-click Advanced. 

3. Select SmartUpdate.

4. Make sure the check box next to Enable SmartUpdate is checked.

If you have difficulties with the auto-install process, or if LaunchPad auto-installation has been 
disabled on your TeamXpress server, you can also install LaunchPad manually. Select Edit > 
LaunchPad Setup in the TeamXpress GUI, and follow the instructions for your platform.

1. If you uninstall LaunchPad, it may not automatically reinstall itself the next time you log in to TeamXpress.
19



Getting Started
LaunchPad for Macintosh

1. Before you install LaunchPad, you must download it. Select LaunchPad Setup from the Edit 
menu. The Install window will appear.

Install LaunchPad window

2. Find the section for your platform. 

3. Click or shift-click the link for your platform to download the file.

4. Your browser will ask you where to save the file. Locate the directory you want to download the 
LaunchPad installation file to, and click OK. If you are reinstalling LaunchPad, it is usually safest to 
download the new version to the same location as the old version.

After you have downloaded LaunchPad, you will need to set up your browser. LaunchPad can be used 
with Netscape 4.x for the Macintosh, or Internet Explorer 4.01 or later. 
20 TeamXpress User’s Guide
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Installing LaunchPad for Macintosh: Netscape 4.x

1. In Netscape 4.x, choose Preferences from the Edit menu. If Applications is not already displayed 
in the left-hand (Category) panel, click the triangle next to Navigator in the Category panel.

2. Click Applications in the Category panel.

User Preferences window

3. Click the New button. An Edit Type window will appear.

Edit Type window
21



Getting Started
4. Fill in the boxes as shown above. Use “application/x-TeamXpress-launch” for the MIME type and 
“tsl” for the suffix.

5. Click the Application radio button, then click the Choose button.

6. Navigate to the location of LaunchPad on your hard drive. Select LaunchPad and click Open.

7. Click OK.

8. LaunchPad will now appear as a Netscape helper application.

Installing LaunchPad for Macintosh: Internet Explorer

1. In Internet Explorer, select Edit > Preferences. The Internet Explorer Preferences window will 
appear. In the left-hand panel of the Preferences window, locate the Receiving Files heading. 
Under this heading, click on File Helpers.

Internet Explorer Preferences window
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Installing and Configuring LaunchPad
2. Click Add. The Edit File Helper window will appear.

Edit File Helper window

3. Fill in the boxes as shown above.

4. In the File Type section of the Edit File Helper window, select Browse. Navigate to the location of 
LaunchPad on your hard drive. Select LaunchPad and click Open.

5. Select View with Application in the Handling section.

6. Click OK.

7. LaunchPad will now appear as an Internet Explorer helper application.

Troubleshooting LaunchPad for Macintosh

The most common cause of difficulties with LaunchPad on the Macintosh is improper browser 
configuration. If, when you edit files, your Macintosh does not download them correctly, check your 
browser setting as described in “Installing LaunchPad for Macintosh: Netscape 4.x” or “Installing 
LaunchPad for Macintosh: Internet Explorer”.
23
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LaunchPad for UNIX

1. Before you install LaunchPad, you must download it. Select LaunchPad Setup from the Edit 
menu. The Install window will appear.

Install LaunchPad window

2. Find the section for your platform. 

3. Click or shift-click the link for your platform to download the file.

4. Your browser will ask you where to save the file. Locate the directory you want to download the 
LaunchPad installation file to, and click OK. If you are reinstalling LaunchPad, it is usually safest to 
download the new version to the same location as the old version.

5. After you have downloaded LaunchPad, type the command that corresponds with your platform:

Solaris for Sparc:
% sh launch-solaris-sparc.shar

Solaris for Intel:
% sh launch-solaris-intel.shar 
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Installing and Configuring LaunchPad
Irix5.3 and later: 
% sh launch-irix5.3-mips.shar

6. Exit all browsers.

Type: 

% cd launch

Type: 

% ./install

Configuring LaunchPad

When you edit, view, create, or import a file, TeamXpress will start LaunchPad. You do not need to 
start LaunchPad manually unless you are installing or configuring it.

LaunchPad has several options that allow you to customize the way that you work. First, you will 
probably need to configure which file types are associated with your editing applications. To configure 
file types for Windows 95, 98, NT, or 2000 client platforms, see page 25. To configure file types for 
Macintosh client platforms, see page 29. To configure file types for UNIX client platforms, see 
page 32.

You can also configure whether you edit files locally or remotely. You can choose to use Direct Edit, 
where you edit files directly on the server, or Remote Edit, which downloads files to your computer 
where you can edit them, then upload them to the server via LaunchPad. 

Configuring File Types for Windows 95, 98, NT, or 2000

Windows associates different applications with different file types, so that when you double-click on a 
file, it knows what application to use to open it. You will only need to configure LaunchPad 
preferences for file types if they are different from your Windows preferences. For example, you may 
have a particular graphics editor set to open JPEG files in your Windows preferences, and want to use 
the same graphics editor to open JPEGs from TeamXpress, as well. In that case, you would not need to 
set preferences for JPEGs in LaunchPad.
25
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However, you may have a browser set to open HTML files in your Windows preferences, but you 
may want to use a text editor or a WYSIWYG editor to open HTML files from TeamXpress. In that 
case, you would need to set preferences for HTML files in LaunchPad.

Additionally, TeamXpress may be configured to automatically associate a particular application with a 
particular file type for all Windows clients. If this has been done, the Auto-Update checkbox in the 
File Type window will be checked in the dialog box for each auto-configured extension. You can 
override this association by unchecking the checkbox and manually configuring the association (see 
page 28).

Adding File Types

To add a new type of file to your LaunchPad preferences:

1. From the LaunchPad window, select Properties from the File menu. The LaunchPad Preferences 
window will appear.

2. Click the File Types tab. A list of all file types configured specifically for LaunchPad will appear.

LaunchPad Preferences: File Types tab

3. Click the New Type button. An empty File Type window will appear.
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File Type window

4. Unless you are familiar with DDE settings for your editing application, it is usually safest to copy all 
necessary information from an existing setting. Click the Copy From button.

5. A Choose Extension window will appear. Scroll down until you find an entry that uses the editing 
application that you want to use. Click the entry, then click OK.

Extensions window
27
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6. All the necessary information will be copied into the File Type window. Edit the Description of 
type and the Associated extension boxes as necessary. The file extension must begin with a 
period (e.g. .html, .jpg, .gif). 

Note: You can only configure one extension per entry. For example, although you might want to 
use the same editor for .htm and .html files, you would still need to create two different entries.

7. Click OK.

8. The new file type will appear in the File Types window. Click OK.

Editing File Types

To change the settings for an existing entry:

1. From the LaunchPad window, select Properties from the File menu. The LaunchPad Preferences 
window will appear.

2. Click on the File Types tab. A list of all file types configured specifically for LaunchPad will appear.

LaunchPad Preferences: File Types tab

3. Select the file type you want to change.
28 TeamXpress User’s Guide
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4. Click Edit. The File Type window containing the settings for that file type will appear.

File Type window

5. From the File Type Window, you can change settings using the Copy From button, as described 
above, or you can edit them manually. Click OK.

6. The edited file type will appear in the File Type window. Click OK. 

Configuring File Types for Macintosh

LaunchPad uses an application called Internet Config to configure file type associations with editing 
applications. Internet Config is often bundled with other applications, as well. You may want to search 
for other copies of Internet Config and remove them.

1. Double-click the Internet Config application inside the LaunchPad folder. The Internet 
Preferences window will appear.

Internet Preferences window
29
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2. Click the File Mappings button. The File Mappings window will appear, containing a list of file 
types and the applications currently associated with them.

File Mappings window

You can sort the lists by extension, by application, or by name. 

Adding File Types

To add a new file type:

1. Click the Add button in the File Mappings window. The Mapping Entry window will appear.

2. Enter the name of the file type in the Name box.

3. Enter the extension (e.g. .html, .htm, .gif) in the Extension box.

4. Click the Defaults button. The Internet Config default settings for your extension will appear.

5. If you do not want to use these settings, you can choose a sample file. Click Choose Example and 
navigate to a file that can be opened by the application you want to use. The safest way to choose 
this file is to create a new file of the appropriate type with the application that you want to use. 
Click OK.

6. In the Mapping Entry window, check the settings to make sure they’re correct. Click OK.
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If you experience problems opening files with LaunchPad, try rebuilding your Desktop (restart the 
computer and hold down -Option as it starts back up).

Editing File Types

To change the application associated with an extension:

1. Scroll down the list of file mappings until you find the entry that you want to change. 

2. Click on the entry, then click the Change button. The Mapping Entry window will appear.

Mapping Entry window

3. Check the existing settings. If you do not want to use these settings, click the Defaults button. The 
Internet Config default settings for your extension will appear.

4. If you do not want to use these settings, you can choose a sample file. Click Choose Example and 
navigate to a file that can be opened by the application you want to use. The safest way to choose 
this file is to create a new file of the appropriate type with the application that you want to use. 
Click OK.

5. In the Mapping Entry window, check the settings to make sure they’re correct. Click OK.
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Configuring File Types for UNIX

To customize LaunchPad you will need to edit the .iwlaunch.cfg file in your home directory:
[filetypes]
default=prog_name [args] %1
.extension=prog_name [args] %1

[preferences]
mountMode=mode
localMountFolderPref=path

The [filetypes] section of .iwlaunch.cfg contains one default line, which sets the default 
editor, and any number of extension lines of the form:

extension=prog_name [args] %1

where extension is the extension of the file type that prog_name knows how to edit. [args] are 
any arguments (or none) that you want passed to prog_name when it is invoked. %1 is a placeholder 
for the filename that gets passed to prog_name.

If the program you want to run expects to run in a terminal, wrap its execution in an xterm, e.g.:

extension=xterm -e an_editor %1

Direct Edit: Saving Files Directly to the Server

You can use this option if you are using Windows and can access the TeamXpress server on your LAN 
(see below), or if you are using UNIX (see page 34). Direct Edit is not recommended for Macintosh 

users.1

Direct Edit for Windows

With Direct Edit for Windows, you can map a network drive, which may also be useful for file system 
access. However, if you do not want to map a network drive, you can still use Direct Edit for 
Windows.

1. Certain Macintosh applications are incompatible with LaunchPad Direct Edit due to differences in the way they handle file types. Text 
editors such as BBEdit and SimpleText will usually work with Direct Edit for the Macintosh.
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To use Direct Edit with a mapped network drive

1. Using Windows Explorer, map your TeamXpress server to a  network drive. In the Path field, type 
in the directory for your main branch . For example, for NT, type 
\\SERVERNAME\IWServer\default\main. For Solaris, type IWDEFAULT\MAIN or

\\SERVERNAME\IWMAIN).

Map Network Drive window

2. From the LaunchPad window, select Properties from the File menu. The LaunchPad Preferences 
window will appear.

3. Select the Remote Setup tab.

4. Select “Use locally mounted TeamXpress server”. Enter the letter of the networked drive that the 
TeamXpress server is mapped to (e.g. I:). If you have multiple TeamXpress servers, you can only 
access one at a time with Direct Edit, but you can change from one to another as needed.

If you do not want to map a network drive:

1. Select Properties from the File menu in the LaunchPad window. The LaunchPad Preferences 
window will appear. Select the Remote Setup tab.

2. Select “Use locally mounted TeamXpress server”. Enter the directory for your main branch, e.g. 
\\SERVERNAME\ for Solaris, or IWServer\default main for NT/2000. Before 
you start editing files for the first time, you will need to go into Network Neighborhood, double-
click on the TeamXpress server, and enter your username and password when prompted.

Future edits will be saved directly to the server. You will not need to upload files from LaunchPad.
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Direct Edit for UNIX

To have LaunchPad use Direct Edit, set the mountMode line of .iwlaunch.cfg to read:

mountMode=local

Set the localMountFolderPref line to point to the main branch of the TeamXpress mount, e.g.:

localMountFolderPref=/iwmnt/default/main/

With Direct Edit, each time you save a file, it will be saved directly to the TeamXpress server.

Remote Edit: Editing Files on Your Computer

All users can edit files remotely with LaunchPad. You should use this option if you are using a 
Macintosh, if you are using Windows and cannot access the TeamXpress server via a LAN, or if you 
use multiple TeamXpress servers on a regular basis.

With Remote Edit, when you edit a file, LaunchPad downloads a temporary copy of the file to your 
local computer. LaunchPad then opens the file in the editing application that you have configured. 

(Windows and Macintosh) When you have finished editing the file, you must tell LaunchPad to upload 
the temporary copy to the TeamXpress server. 

(UNIX) When you save the file, LaunchPad will upload the temporary copy to the TeamXpress 
server.

Configuring Remote Edit Preferences for Windows or Macintosh

You can tell LaunchPad whether to remove or keep the temporary copies of files that you have edited 
when you upload these files. To set this preference, select Properties from the File menu. The 
LaunchPad Preferences window will appear with the General Preferences tab showing. This tab allows 
you to change the directory for TeamXpress temporary files. However, if you change this directory, 
LaunchPad may not work properly. 
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Setting preferences in LaunchPad

Under “What to do with the temporary local files after uploading them,” select the option that best 
describes the behavior you want. If you select “Always remove” or “Always keep” LaunchPad will not 
query you at the time of upload. “Always remove” only removes the temporary copies of files that 
LaunchPad has downloaded from TeamXpress. It will not affect any other copies of the files that you 
have on your computer. “Always keep” leaves the temporary files on your computer for further use. 
You may want to use this option if you want to edit the files again after uploading them. If you use this 
option, you will need to remove the files manually at some point.

Configuring Remote Edit for UNIX

With Remote Edit, any file you edit through the TeamXpress GUI will not be uploaded to the 
TeamXpress server until you quit your editing application.

To have LaunchPad use Remote Edit, set the mountMode line of .iwlaunch.cfg to read:

mountMode=remote
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Using Remote Edit

To edit files on your local computer:

1. From the LaunchPad window, select Properties from the File menu. The LaunchPad Preferences 
window will appear.

2. Select the Remote Setup tab.

3. Select “Use TeamXpress remotely”. 

Future edits will download a temporary copy of the file to your computer and automatically open it in 
the editing application that you have configured LaunchPad to use. You will then need to upload the 
file for your changes to show up in TeamXpress.

If you have closed a file or quit your editing application, and you want to edit the file again:

1. Click the file name in the LaunchPad window.

2. Click Edit.

3. The file will open in your editing application.

Using a Different Editing Application

You can also choose a different editing application than the one you have set in your LaunchPad 
Preferences.

1. Click the file name in the LaunchPad window.

2. Click Edit With.

3. A browsing window will appear. Browse your computer until you locate the editing application 
that you want to use, and click its name. 

4. Click OK. The file will open in the application that you have chosen.
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Uploading Files

LaunchPad permits you to upload the files you have edited to the TeamXpress server whenever you are 
connected to the TeamXpress server.

A file that has been edited since it was last uploaded will be displayed in the LaunchPad window with a 

 (Changed) icon. A file that has not been edited, or that has been uploaded since it was last edited, 

will be displayed with an  (Unchanged) icon. 

LaunchPad window

To upload files:

1. Save your changes.

2. Go to the LaunchPad window and click the names of the files you want to upload.

3. Click Upload.

4. A dialog box will appear asking if you want to delete the copy of the files on your hard disk. If you 
want to continue editing the files, click Keep. If you are finished with the files, click Remove. To 
cancel the operation and close the dialog box, click Cancel.

5. TeamXpress will upload the files you have just edited to the TeamXpress server. 
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To automatically upload all changed files, select Upload Changed Files from the LaunchPad File 
menu.

If you are finished with the files that appear in the LaunchPad window and do not want to upload 
them, you can delete them from your hard disk without uploading them first. 

1. Click the file names in the LaunchPad window.

2. Click the Delete button.

3. A dialog box will appear asking for confirmation. Click Delete to remove the files from your hard 
disk.

To automatically remove all unchanged files, select Remove Unchanged Files from the LaunchPad 
File menu.

Logging Out of TeamXpress

When you have finished your work and want to log out of TeamXpress, click the Logout button in the 
lower left hand corner of the TeamXpress window. A confirmation window will appear. Click OK. 
TeamXpress will log you out and return you to the login screen.

Understanding the Workflow and Branch Views

TeamXpress has two main views: the Workflow view, which displays information about jobs and tasks, 
and the Branch view, which allows you to navigate through TeamXpress areas. In the Workflow view, 
you can learn about the jobs and tasks relating to you by clicking the To Do button in the Button Bar. 
To view the details of an individual job or task, click its underlined name.

You can move from the Workflow view to the Branch view by clicking the Workarea button in the 
Button Bar. TeamXpress will display a list of the branches and workareas where you have access. To 
navigate into a branch or workarea, click its name. The TeamXpress window will display the Branch 
view.
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In the Branch view, the left-hand pane (the Navigation Window) allows you to navigate through 
TeamXpress. The right-hand pane (the Work Window) will be updated as you navigate through the 
system. The top of the screen contains a Button Bar, containing buttons for the most frequently used 
commands, and a Menu Bar, containing drop-down menus for all TeamXpress commands. To return 
to the Workflow view, click the To Do button in the Button Bar. 

The TeamXpress window, displaying a branch view

The Button Bar

The Menu Bar

Your Servername

Your Username
Your Role

Comment Attached
to a Branch

The Work Window

The Navigation
Window
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Using the TeamXpress Workflow View

The TeamXpress Workflow view allows you to track your current jobs and tasks, to see the history of 
a job, and to see what files make up a task. To see jobs and tasks that you own, click the To Do button 
in the Button Bar. To further refine this view, select one of the options in the View menu.

A Task list

To go to the Branch view, click the Workarea button in the Button Bar.
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Navigating Through the TeamXpress Branch View

To navigate through TeamXpress, single-click the underlined name of a branch, workarea, or directory 
in the Navigation Window (the left-hand pane of the TeamXpress window). The contents of that branch, 
workarea, or directory will be displayed in the Work Window (the right-hand pane of the TeamXpress 
window). Click the name of a workarea, staging area, edition, or directory in the Work Window to 
display its contents in the Work Window and to update the Navigation Window to show your current 
position in TeamXpress. The Navigation Window will show the branch elements or directories at your 
current level, and your current location will be highlighted with a red dot. Click the Back button in 
the Button Bar to return to the previous view. 

While both the Work Window and the Navigation Window can be used to navigate, you can only 
manipulate individual files in the Work Window. To view a file in a separate browser window, click 
its underlined name. To navigate into a directory, click its underlined name. To perform an operation 
on a file or directory, click the checkbox next to the file name. You can sort files and directories by 
name, owner or publisher, and date by clicking on the underlined attribute names in the Work 
Window. By default, files are sorted by name.

In a workarea, files and directories may be displayed with several different icons. Each icon contains 
information about that file or directory’s status. See the “TeamXpress Icon Reference” on page 169 
for a complete list of TeamXpress icons.

You may sometimes need to refresh the Work Window to see changes that have been made. You can do 
this by clicking the name of your current directory in the Navigation Window.

To return to the Workflow view, click the To Do button in the Button Bar.
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A workarea containing modified, assigned, locked, and private files

Setting Your Home Page

To set your Home page:

1. In the TeamXpress GUI, navigate to the location or workflow view that you would like to go to 
automatically when you first log in. 

2. Select Edit > Set Home Page.

Your Home page setting will be stored on the TeamXpress server. You can change this setting at any 
time, or reset it to the default setting. If you change the name of the path to your Home page (e.g., if 
you rename a directory in the path), you will need to set your Home page again.

To reset your Home page to the default setting, select Edit > Reset Home Page.
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Using Menus and Buttons

The Tool Bar consists of a Button Bar, containing the most frequently used commands, and a Menu 
Bar which displays drop-down menus containing all available commands. Various commands are 
displayed in the Menu Bar and Button Bar at different times according to when you can use them. 

Editor’s Tool Bar

The Menu Bar contains three drop-down menus: File, Edit, and View. Each menu is displayed only 
when you can use at least one of the commands that it contains. Individual commands within the 
menus are displayed only when you can use them. Your TeamXpress server may have some custom 
menu items not described in this manual.

Using SmartContext Editing

When you click the name of a file in the TeamXpress GUI, the file will appear in a new browser 

window containing the TeamXpress SmartContext Editing tab.1 This tab displays information about 
the current status of the file shown in the browser window. To use SmartContext Editing, click the 
tab. A pull-out bar will appear, containing buttons and menus which will allow you to edit the page.

1. The SmartContext Editing tab is not supported by all browsers. To find out if your browser supports SmartContext Editing, see 
page 16.
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A browser window with the SmartContext Editing tab

The SmartContext Editing tab contains a Color Bar which tells you about the file’s status. If a pencil is 
also displayed, it means that the file has been modified.

 
The SmartContext Editing tab

To learn more about the file’s status, move your mouse arrow over the SmartContext Editing tab. A 
ToolTip will appear with more detailed information. Or, pull out the tab and select Advanced > File 
> File Properties.

Color Bar Status

Gray You cannot modify this file (it is 
locked or you do not have 
permission).

Green You can modify this file.

Yellow You can modify this file, but a 
newer version is in the staging 
area.

Red You can modify this file, but it is in 
conflict with the staging area.

Color Bar

Pencil
44 TeamXpress User’s Guide



Using SmartContext Editing
When you pull out the SmartContext Editing tab, you gain access to several features:

The pulled-out SmartContext Editing tab

The SmartContext Editing tab contains four buttons: Get Latest, Edit, Refresh, and Submit. These 
buttons are displayed as active or grayed out according to whether or not you can use them. The tab 
also contains a pull-down menu called Advanced. This menu allows you to access several other 
features, such as viewing a file’s properties, configuring the SmartContext Editing tab, and editing 
images. When selecting menu items in the Advanced menu, you may need to click on the text of the 
menu item itself.

Minimizing the SmartContext Editing Tab

If you don’t need to use the SmartContext Editing tab, you can minimize it to reduce its footprint and 

loading time. To minimize the SmartContext Editing tab, open the tab and click the  (Minimize) 
button. The page will reload, and the minimized version of the tab will replace the full version of the 
tab.

A browser window with the minimized SmartContext Editing tab

To re-activate the SmartContext Editing tab, click the minimized tab.
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Configuring SmartContext Editing

Configuring LaunchPad

When you are using SmartContext Editing, if you have LaunchPad set to use Remote Edit, you should 
configure your LaunchPad to Always Remove uploaded files (see page 34). If you do not set this 
option, the LaunchPad window will rapidly fill up with the files that you edit, and they will not be 
automatically removed. You can, however, remove these files manually.

Setting Your Launch Page

You can set SmartContext Editing to bring up a certain page as soon as you log in to TeamXpress. To 
set this option, navigate to the page you want to appear when you log in, and select Advanced > 
Options > Launch Page > Set Launch Page in the SmartContext Editing tab. The next time you log 
in to TeamXpress, this page will appear immediately.

To change this setting, navigate to another page and select Advanced > Options > Launch Page > 
Set Launch Page in the SmartContext Editing tab.

To turn this feature off, select Advanced > Options > Launch Page > Unset Launch Page in the 
SmartContext Editing tab.

Setting Tab Defaults

You can set the default position of the SmartContext Editing tab. Select Advanced > Options > Tab 
Defaults in the SmartContext Editing tab, and select one of Position: Left, Position: Right, or 
Position: Top. The tab will then appear from the left, right, or top of the browsing window, by 
default.

You can also set the default mode of the SmartContext Editing tab. Select Advanced > Options > 
Tab Defaults in the SmartContext Editing tab, and select one of Mode: Lite or Mode: Full. The tab’s 
default size will then be either minimized or full.
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The SmartContext Editing tab, configured to appear from the right-hand side of a window

Synchronizing the TeamXpress Window

If, while using SmartContext Editing, you navigate away from the directory displayed in the main 
TeamXpress GUI, you can synchronize the main TeamXpress window so that it displays the directory 
containing the file shown in the SmartContext Editing window. 

To synchronize the main TeamXpress window with the SmartContext Editing window, select 
Advanced > Sync Window in the SmartContext Editing tab.

Using the File System Interface

The file system interface allows you to manage your Web content in TeamXpress as if it were on a 
mounted drive on the network. The file system interface is used primarily for file management 
functions such as moving and copying files, and it can also be used to edit files. It also allows the use of 
links checkers and scripts that need to be able to access and/or create files. In addition, most 
TeamXpress operations can be performed from a command-line interface.

Accessing the TeamXpress File System Interface

You can access TeamXpress as you would any networked server: 

Windows Client to NT/2000 Server

To access TeamXpress from Windows, use Network Neighborhood to locate the TeamXpress server. 
You can navigate to any directory in TeamXpress (for example, the top level of a workarea, or a 
directory within a workarea), and create a shortcut to that directory.
47



Getting Started
You can also mount the TeamXpress server as a networked drive:

1. In Windows Explorer, select Map Network Drive from the Tools menu.

2. Select the drive letter you want to map the TeamXpress server to from the pull-down Drive menu. 

3. Locate the TeamXpress server in the Shared Directories list. Double-click on the TeamXpress 
server.

4. Double-click on IWServer.

The TeamXpress server will now be mounted as a networked drive.

Windows Client to Solaris Server

1. Use Network Neighborhood to locate the TeamXpress server. Alternatively, select 
Find…Computer from the Start menu to locate the server. 

2. Double-click the server name to open it. If you are asked for a username and password, enter your 
TeamXpress username and password. The TeamXpress server will appear on your desktop.

Macintosh Client to NT/2000 Server

To access TeamXpress, you will need client software such as DAVE. Install DAVE (or other client 
software that allows you to access a Windows NT/2000 server), and use it to mount your TeamXpress 
server. 

Macintosh Client to Solaris Server

1. In the Chooser, select Appleshare. 

2. Select the name of the TeamXpress server. Click OK. 

3. If you are asked for your username and password, enter your TeamXpress username and password, 
and click OK. 

4. Select the items you want to use, and click OK. The TeamXpress server will appear on your desk-
top.
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UNIX client to NT/2000 or Solaris Server

Log in to the TeamXpress server using your TeamXpress username and password. For an NT/2000 
server, you need to install an SMB client in order to access the server.

Navigating Through TeamXpress

You can navigate through the file system in your workarea in the same manner that you would navigate 
through any Web site file system on a networked server. Using the file system interface, you can add 
or replace files (using drag and drop if your file system is represented graphically, as it is in Windows 
95 or MacOS), rename them, edit them, and create new files or directories. 

Once you have accessed the TeamXpress server, you will need to locate your workarea. The file 
system structure of the branch shown on the first page of this chapter is shown below.

Here, the main branch (main) contains a sub-branch (dev). The sub-branch contains three workareas 
(andre, pat, and chris), a staging area, and two editions. Each workarea, staging area, and edition 
contains a complete virtual copy of the Web site, so you must first navigate to your workarea, then 
navigate to the portion of the Web site you are working on. You can create shortcuts (Windows) or 
aliases (Macintosh) to files or directories within TeamXpress, as you normally would for files or 
directories on your local computer.

Sample TeamXpress file system structure

main

dev

INITIALed_0001chris

STAGINGWORKAREA

andre pat

default

iwserver

EDITION
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Chapter 3

TeamXpress Basics
This chapter discusses basic TeamXpress functionality such as editing files, creating and deleting files 
and directories, renaming files, importing files into your workarea, viewing files, submitting files to 
your workarea, and updating your workarea. 

TeamXpress supports the input of multiple languages through the GUI. For details, see Appendix B, 
“Internationalization”.

Creating New Files

You can only create new files in directories where you have write permissions.

Before you create or edit files with TeamXpress, you must install and configure TeamXpress’s helper 
application, LaunchPad (see “Installing and Configuring LaunchPad” on page 18).

To create a new file in a workarea where you have access:

1. Go into the workarea by clicking its name. When you are in a workarea, the New File command 
will appear in the File menu. Within the workarea, navigate to the directory where you want to 
place the new file. 

2. Select File > New File. The New File dialog box will appear.

In the New File dialog box, if the current directory location is not where you want to put the new 
file, navigate to the directory where you want to put the file. 
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The New File window

3. Select the type of template you want to use, then select the specific template that you want to use.1 
If you do not want to use a template, select Plain File.

4. In the File Name box, type the name of the file you want to create. You will need to include the 
suffix (e.g. filename.html). You should avoid using any of the following characters in filenames:

\ / : * ? " < > |

If a file with the same name exists in another workarea and is locked, you will not be able to create 
the file. If a file with this name exists in the staging area, you will be asked whether you want to 
create a new file or bring a copy of the file in the staging area into your workarea. Follow the 
directions in the dialog boxes that appear.

5. Click OK. 

1. The templates you select through the New File window are not TeamXpress Templating templates. For more information about New 
File templates, see page 180. For more information about TeamXpress Templating, consult Using and Configuring TeamXpress Templating.
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Creating New Directories
UNIX users:  The file will open in the application associated with its file extension. Edit the file as you 
normally would, and save your changes. If you are using Direct Edit (see page 32), the file will be 
saved to the TeamXpress server each time you save it. If you are using Remote Edit (see page 34), 
your changes will not be uploaded until you quit your editing application.

Windows and Macintosh users:  The file will open in the application associated with its file extension. If 
you are using Direct Edit (see page 32), changes will be saved to the TeamXpress server when you 
save the file. If you are using Remote Edit (see page 34), its name will appear in the LaunchPad 
window, and you must upload it after you have saved it. 

Creating New Directories

You can only create directories inside directories where you have write permissions. 

To create a new directory in a workarea that you have access to:

1. Go into the workarea by clicking on its name. Within the workarea, navigate to where you want to 
place the new directory. When you are in a workarea, the New Directory command will appear in 
the File menu.

2. Select File > New Directory. A dialog box will appear, asking you to enter the name of the new 
directory. 

3. Type the name of the directory you want to create. You should avoid using any of the following 
characters in directory names:

\ / : * ? " < > |

4. Click OK. An empty directory will be created.
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Deleting Files and Directories

To delete files or directories in your workarea:

1. Click the checkboxes next to the files or directories that you want to delete in your workarea. 

2. Select File > Delete. A dialog box will appear asking you to confirm these deletions. 

3. Click OK.

The list of files in your workarea will be updated to reflect the deletions.

Editing Files

TeamXpress allows you to edit files from the TeamXpress GUI in two ways: through SmartContext 
Editing, where you browse the Web site and edit pages as you view them, or through the main 
TeamXpress GUI, where you browse the directory structure of the Web site and edit individual files.

Before you create or edit files with TeamXpress, you must install LaunchPad on your computer (see 
“Installing and Configuring LaunchPad” on page 18).

Editing Files Through SmartContext™ Editing

1. To edit a file using TeamXpress SmartContext Editing, click the name of a file in the Work 
Window or a Task Details window in the TeamXpress GUI. The file will open in a new browser 
window containing the TeamXpress SmartContext Editing Tab.

2. Navigate through the Web site by clicking links until you reach the page you want to edit. 

3. When you reach the page you want to edit, click the SmartContext Editing Tab so that it opens, as 
shown below.
54 TeamXpress User’s Guide



Editing Files
A browser window with the SmartContext Editing tab pulled out

4. Click the Edit button on the pulled-out tab. The file will open in your editing application.

5. Edit the file as you normally would. When you are done editing the file, save it. 

6. To see the changes you made, return to the SmartContext Editing window and click the Refresh 
button on the pulled-out tab. Your changes will be uploaded at this time.

Editing Images with SmartContext Editing

To edit the images that appear in a page:

1. To edit a file using TeamXpress SmartContext Editing, click the name of a file in the Work 
Window or a Task Details window in the TeamXpress GUI. The file will open in a new browser 
window containing the TeamXpress SmartContext Editing Tab.

2. Navigate through the Web site by clicking links until you reach the page you want to edit. 

3. When you reach the page containing the images you want to edit, click the SmartContext Editing 
Tab so that it opens.
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4. Select Advanced > Image List on the pulled-out tab. An Image List window will appear, contain-
ing all the images that appear on the page. 

The Edit Images window

5. In the Image List window, click the image you want to edit. A new window will appear, displaying 
the image and the SmartContext Editing tab. 

6. Edit the file using SmartContext Editing (see page 54). When you are done editing the file, save it.

7. To see the changes you made, return to the SmartContext Editing window and click the Refresh 
button on the pulled-out tab.
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SmartContext Editing and Framesets

If you are editing a frame-based page, a SmartContext Editing tab will appear in each frame so that you 
can select which file to edit. However, you can also edit the frameset file itself.

To edit a frame-based page’s frameset file:

1. Select Advanced > Frame Mode on/off in the SmartContext Editing tab. Frameset Mode will 
appear in the blue portion of the bar. While Frameset Mode is turned on, all actions you take 
through SmartContext Editing will apply to the frameset file, not to the file that appears in a 
portion of a page.

The SmartContext Editing tab, with Frameset Mode turned on

2. Click the Edit button on the SmartContext Editing tab. The file will open in your editing applica-
tion.

3. Edit the file as you normally would. When you are done editing the file, save it.

4. To see the changes you made, return to the SmartContext Editing window and click the Refresh 
button on the pulled-out tab.
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Editing Files Through the TeamXpress GUI

To edit a file through the main TeamXpress GUI using your default editing application:

UNIX users:

1. In the TeamXpress GUI, navigate to the directory containing the file you want to edit. 

2. Click the checkbox next to that file.

3. Click the Edit File button in the Button Bar or select Edit > Edit File.

4. The file will open in your editing application. Edit the file as you normally would. If you are using 
Direct Edit, the file will be saved to the TeamXpress server each time you save it. If you are using 
Remote Edit, your changes will not be uploaded until you quit your editing application.

Macintosh and Windows users:

1. In the TeamXpress GUI, navigate to the directory containing the file you want to edit. 

2. Click the checkbox next to that file. 

3. Click the Edit File button in the Button Bar or select Edit > Edit File. 

If you are using LaunchPad’s Direct Edit feature (see page 32), changes will appear on the server as 
soon as you save them. If you are using Remote Edit (see page 34), a temporary version of the file 
will be downloaded to your computer, and its name will appear in the LaunchPad window. 
Changes will not appear until you upload the files from LaunchPad.

4. The file will open in your editing application. Edit the file as you normally would. If you are using 
Remote Edit, you will need to upload the file from LaunchPad after you have saved it.

Editing Files With an Alternate Application

To edit a file using an alternate editing application:

Macintosh and Windows users only:

1. Navigate to the directory containing the file you want to edit. Click the checkbox next to that file. 

2. Select Edit > Edit With.
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Editing Files
An Open With window will appear. Select the editing application you want to use from the list 
displayed.

The Open With window

If you cannot find the application you want to use, click the Other button and navigate to the 
location of the editing application. Click Open.

Locating an editing application

3. The file will open in your editing application. Edit the file as you normally would. If you are not 
using Direct Edit, you will need to upload the file from LaunchPad after you have saved it.
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Importing Files Into Your Workarea

TeamXpress lets you import any file or files residing on your hard drive into the TeamXpress system. 
You must have LaunchPad installed (see “Installing and Configuring LaunchPad” on page 18) to import 
files.

Windows 95, 98, or NT Client

1. Select File > Import Files.

2. LaunchPad will open, and a Select File window will appear. In the Select File window, navigate to 
the directory containing the files you want to import. Select the files (hold down the shift key to 
select multiple files) and click OK. 

The files will be uploaded to TeamXpress.

If you want to import files that have the same names as existing files, click the Overwrite button 
before selecting File > Import Files. The files in your workarea will be overwritten by the imported 
files with the same names.

Macintosh Client

1. Select File > Import Files.

2. LaunchPad will open, and a Select File window will appear. In the Select File window, navigate to 
the file you want to import. Select the file and click Open. 

The Select File window
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3. The Select File window will reappear. Continue to select files to import, clicking OK after each 
one. When you are finished selecting files, click Cancel. The files will be uploaded to TeamXpress.

If you want to import files that have the same names as existing files, click the Overwrite button 
before selecting File > Import Files. The files in your workarea will be overwritten by the imported 
files with the same names.

Renaming Files

The TeamXpress Rename command gives a file a new name, but does not change the directory path to 
the file. If you want to both rename and move a file, you must use the Move command.

You can only rename files if you have write permissions for the directory containing the files. To 
rename a file:

1. Select the checkbox next to the name of the file that you want to rename.

2. Select File > Rename.

3. A dialog box will appear. Type the new name (not the full path) of the file, including extension. 
You should avoid using the following characters in the file’s name:

\ / : * ? " < > |

4. The file will appear in the workarea with a  (Modified) icon. 

Renaming a file actually creates a new file with the new name and deletes the old file. The version 
history of the file will keep track of the name change—older versions of the file will not be lost.

You should submit the deleted file to the staging area (see page 105).
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Moving Files

To move a file from one directory to another:

1. Select the checkbox next to the name of the file that you want to move.

2. Select File > Move.

3. A dialog box will appear asking you for the new name or path. Type the full path of the directory 
where you want the file to be moved to. Be sure to include the filename in the path. You can use an 
absolute path (rooted in the workarea’s root directory) or a relative path, and you can change the 
name of the file.

/htdocs/products/index.html would specify an absolute path.

products/index.html would specify a relative path.

../support/index.html would specify a relative path.

4. The file will appear in the new location with a  (Modified) icon.

The version history of the file will keep track of the change in location—older versions of the file will 
not be lost.

Copying Files

To copy a file from one directory to another:

1. Select the checkbox next to the name of the file that you want to copy.

2. Select File > Copy.
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3. A dialog box will appear asking you for the new name or path. Type the full path of the directory 
where you want the file to be copied. Be sure to include the filename in the path. You can use an 
absolute path (rooted in the workarea’s root directory) or a relative path, and you can change the 
name of the file.

/htdocs/products/index.html would specify an absolute path.

products/index.html would specify a relative path.

../support/index.html would specify a relative path.

4. A copy of the file will appear in the new location with a  (Modified) icon. 

Viewing Files

You can view any file that you have read access to, whether or not it is locked by another user.

Browser View

To view a file within the context of the Web site, click its underlined filename within a workarea, 
staging area, or edition. The file will appear in a new browser window. You may need to clear the disk 
cache in order to see changes immediately.

If your Web site uses frames, you may need to click the top-level file (often index.html) and 
navigate to the file you need within the frame.

If you need to see the end of the page’s URL (for example, if you need to see the name of the 
displayed file), click the browser’s Location text box, then press the End key. To return to the 
beginning of the URL, press the Home key.

Source View

To view a read-only copy of a document in your preferred editing application, click the checkbox next 
to that file, then click the View File button in the Button Bar or select Edit > View File. A read-only 
copy of the file will be opened in your preferred editing application. You will be able to edit this copy, 
but you will not be able to save any changes you make to the TeamXpress server.
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Submitting Files to the Staging Area

Submitting Files Using SmartContext Editing

If you have been using SmartContext Editing and want to submit the file you have just edited:

1. Click the Submit button in the SmartContext Editing tab for the file you want to submit. 

2. A dialog box will appear. Enter any comment you want to attach to the file’s history, and click OK. 

Your changes will be uploaded (if they haven’t been already) and the file will be submitted to the 
staging area.

Submitting Files Using the TeamXpress GUI

When submitting files to the staging area, you can either submit them directly, or invoke a workflow 
process (via a submit job template) which will submit the files.

Submit job templates are configured on an individual site basis. They may perform automated tasks 
such as post-processing or links checking before submitting your files. To find out what submit job 
templates are available on your system, consult your system administrator. 

The Submit button in the TeamXpress GUI may be configured to use either the direct submit or the 
workflow process submit (see below). Consult your system administrator to find out how your 
system is configured.
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Submitting Files Directly

To submit files or a directory to the staging area (you can only submit one directory at a time):

1. Select the checkboxes next to the items that you want to submit in your workarea. If no items are 
selected, TeamXpress will submit your entire current directory. To submit an entire workarea, go 
to the top level of the workarea and do not select any checkboxes.

2. Select File >Submit--Direct. A Submit window will appear. 

3. Enter any comments you have in the comment boxes. The Submit window contains two sections: a 
Submit Comments section, which consists of a section where you can enter comments for the 
entire Submit operation and a field where you can enter keywords, e.g. for automatic triggers, and 
an Individual Comments section, where you can attach comments to each file’s history.

4. If you want to overwrite files and directories in the staging area with the files in your workarea, 
regardless of which version is newer, click the OverWrite Staging Area Files checkbox. If you are 
submitting a directory, this operation is equivalent to deleting the directory from the staging area 
and then submitting the directory from your workarea. Any files that are in that directory in the 
staging area but which are not in the directory in your workarea will be deleted from the staging 
area.

5. If you want to retain any locks you have on files being submitted, click the Keep Locks checkbox. 
If you do not select this option, all locks will automatically be released upon submission.

6. Click the Submit Files button.
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Submit Comments window
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Submitting Through a Workflow Process

To submit files using TeamXpress workflow:

1. Select the checkboxes next to the items that you want to submit in your workarea. If no items are 
selected, TeamXpress will submit your entire current directory. To submit an entire workarea, go 
to the top level of the workarea and do not select any checkboxes.

2. Select File > Submit. 

3. If there are multiple submit job templates available for your system, you will be asked to choose 
one. If there is only one, its Submit window will appear. The Submit window’s appearance may vary 
from one job template to another. The rest of this section refers to the default submit job template.

4. Enter any comments you have in the comment boxes. The Submit window contains two sections: a 
Submit Comments section, which consists of a section where you can enter comments for the 
entire Submit operation and a field where you can enter keywords, e.g. for automatic triggers, and 
an Individual Comments section, where you can attach comments to each file’s history.

5. If you want to overwrite files and directories in the staging area with the files in your workarea, 
regardless of which version is newer, click the OverWrite Staging Area Files checkbox. If you are 
submitting a directory, this operation is equivalent to deleting the directory from the staging area 
and then submitting the directory from your workarea. Any files that are in that directory in the 
staging area but which are not in the directory in your workarea will be deleted from the staging 
area.

6. If you want to retain any locks you have on files being submitted, click the Keep Locks checkbox. 
If you do not select this option, all locks will automatically be released upon submission.

7. Click the Submit button to continue with the Submit operation. You also have the option of hold-
ing the submit job and submitting the files later, or cancelling it.
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Default Submit job window

After You Submit

Submitting Conflicting Files
If you are submitting a workarea or directory and there are conflicts, the Compare screen will appear. 
In this screen, you have the option to merge files (see page 87), overwrite your changes (see page 79), 
or overwrite the changes in the staging area.
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To overwrite changes in the staging area with your modifications:

1. In the Compare screen, the Overwrite button in the Button Bar will already be selected. Select the 
checkboxes next to the files that you want to overwrite in the staging area.

2. Click Submit. This will overwrite the files in the staging area with the selected files in your 
workarea and submit any files that were not in conflict from the original submission.

Submitting Directories
When you submit a directory, only the files that have been changed are actually submitted (including 
modified files in subdirectories). For a complete list of which individual files were submitted from a 
workarea, go into that workarea and select Submit Log from the View menu. 

Viewing Submit Logs
To learn which files have been changed in the staging area since it was last published, go into the 
staging area and select View > Submit Log. 

Submit Log
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Updating Your Workarea

Files in the staging area can be changed by other users without ever affecting your workarea. If you 
want to be working on the latest versions of all the files in your branch, you will need to update your 
workarea from the staging area. If you want to continue working on the version of your files already in 
your workarea, do not update your workarea. However, if you do not update your workarea, you may 
encounter conflicts when you edit files and submit them to the staging area. 

To update your workarea:

1. Click the checkbox next to the files or directory in your workarea that you want to update from 
the staging area. If no files or directory is selected, your current directory will be updated. If you 
are the top level of your workarea and no items are selected, your entire workarea will be updated.

2. Click the Get Latest button in the Button Bar, or choose File > Get Latest. 

If there are no conflicts, the Get Latest command compares all of the files in the selected area with the 
corresponding files in the staging area and updates your workarea with the latest versions. If a file in 
your workarea is a newer version than the file in the staging area, it will be left alone.

If there are conflicts (corresponding files have been changed both in your workarea and in the staging 
area), a Compare screen will appear. For more information about the Compare screen, see page 79. 
Using the Compare screen, you can merge the two versions or choose one over the other (see 
page 79). To overwrite the files in your workarea with files from the staging area, regardless of which 
version is newer, select the Overwrite button in the Button Bar (it will turn red), then choose Get 
Latest. Use this option only if you want to throw away modifications that you have made. 

If you use the Overwrite button to overwrite a directory, this operation is equivalent to deleting the 
directory from the workarea and then copying the directory from the staging area. Any files that are in 
that directory in the workarea but which are not in the corresponding directory in the staging area will 
be deleted from the workarea.

To learn what files the Get Latest command has updated in your workarea, select Update Log from 
the View menu. Click underlined entries in the Update Log window to see a list of the files that were 
updated in each Get Latest operation. Click individual filenames to view the version of the file that 
was submitted.
70 TeamXpress User’s Guide



Updating Your Workarea
The entries are sorted by date.

Update Log
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Publishing Your Work

To create a new edition from the contents of the staging area:

1. Select File > Publish from anywhere within your branch. The Publish window will appear.

2. TeamXpress will suggest a name for the new edition. If you want to give the edition a different 
name, enter the name of the new edition in the Name box in the Publish window.

Publish window

3. Enter any comments you have in the Comments box.

4. Click OK. The staging area will be published as a new edition.

To find out which files in an edition have changed from the previous edition, go into the edition and 
select View > Submit Log. You can also use the Compare function to find differences between 
editions. 
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Chapter 4

Managing File Versions
Viewing File Properties

TeamXpress’s File Properties feature allows you to determine basic file properties such as the size of a 
file, when it was created and by whom, whether you have write access to it, what exactly the 
permissions are, what user and group have access to it, whether you have access to the area it resides 
in, who the owner and group for that area are, whether it is locked (and by whom and in what 
workarea), whether it is part of a task, and what comments and metadata are currently attached to it.

To view the properties of a file:

1. Select the checkboxes next to the files whose properties you want to view.

2. Select File > File Properties.

3. The File Properties window will appear.

Look in this window to find the properties you’re most interested in.
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The File Properties window
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About the File Properties Window
About the File Properties Window

Basic

File Security

Area Security

Workflow

Modified Tells whether the file has been 
modified in the current workarea

Size Size of the file

Creator Username of the creator of the file

Creation Date Date the file was created

Writable Tells whether you can write to the file

Permissions Access permissions for the file 

Owner Owner of the file

Group (UNIX 
only)

Group which has access to the file 
(according to UNIX permissions)

Writable Tells whether you can edit files in the 
current workarea

Permissions Access permissions for the workarea 

Owner Owner of the workarea

Group Group which has access to the 
workarea

Job (ID) Name and ID of the job (if any) 
associated with this file

Job Owner Username of the owner of the job (if 
any) associated with this file
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Lock

Metadata

Metadata that has been set on this file. Metadata will vary from site to site and from file to file.

Copying Files to Other Workareas

The Copy To Area command allows you to select a version of a file or directory in a workarea, staging 
area, or edition and copy it to the corresponding directory in another workarea. If this workarea 
already contains an older version of the same file or directory, it (and, for a directory, its contents) will 
be overwritten. The Copy To Area command will take both the file’s name and its directory path into 
account when copying.

To cancel a Copy To Area operation, click the name of a directory or area in the Navigation Window 
at any step.

To copy a file or directory:

1. Navigate through the TeamXpress file system until you have located the file or directory you want 
to copy.

2. Click the checkbox next to this item. If you do not select anything, TeamXpress will assume that 
you want to copy the entire contents of your current directory.

3. Select File > Copy To Area.

Task (ID) Name and ID of the task (if any) 
associated with this file

Task Owner Username of the owner of the task (if 
any) associated with this file

Workarea Workarea (if any) in which the file is 
locked

Lock Holder Username of the lock owner

Lock Time Time the file was locked 
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4. A Choose Area window will appear. Using this window, navigate to the workarea you want to copy 
the item to. To find a workarea on another branch, click the name of the branch.

Choose Area window

5. Click the underlined name of the workarea. The item will be copied, and TeamXpress will return 

you to the location you were copying from. The file will appear in the new location with a  
(Modified) icon.

To learn what files the Copy To Area command has changed in your workarea, select View > Update 
Log. Click underlined entries in the Update Log window to see a list of the files that were updated in 
each operation (see page 70).
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Copying Over Newer Files

If you use the Copy To Area command to overwrite more recent version than the one you want to 
copy, one of two things will happen: 

• If the file has only been modified in the destination workarea, the message “filename is newer in 
workarea workareaname” will appear, and the operation will fail.

• If the file has been modified in both the source area and the destination workarea, TeamXpress will 
take you to the Conflicts screen. From there, you can choose to overwrite one version (see 
page 87) or to merge the two versions (see page 87). 

TeamXpress will not overwrite a newer version of a file with an older one unless specifically directed 
to do so. To overwrite a newer file, you must use the Overwrite button, as described below. Be 
careful when using this command, because it cannot be undone. If you use the Overwrite button to 
overwrite a directory, this operation is equivalent to deleting the directory from the destination area 
and then copying the directory from the source area. Any files that are in that directory in the 
destination area but which are not in the directory in the source area will be deleted from the 
destination area.

To copy over newer files:

1. Navigate through the TeamXpress file system until you have located the files or directories you 
want to copy.

2. Click the checkboxes next to these items.

3. Click the Overwrite button in the Button Bar. The Overwrite button will turn red.

4. Select File > Copy To Area.

5. A Choose Area window will appear. Using this window, navigate to the workarea you want to copy 
these items to. 

6. Click the underlined name of the workarea. The files or directories you have selected will over-
write the corresponding files or directories in this workarea (directories will be copied with all 
their contents and all contents of the previously existing directory will be removed), and TeamX-
press will return you to the location you were copying from.
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Restoring Deleted Files

If you have accidentally deleted a file in your workarea and want to restore it with a file from the 
staging area, an edition, or from another workarea, TeamXpress will consider your deleted file to be 
more recently modified than the file you are trying to overwrite it with, and it will return a warning. 
You must therefore use the Overwrite command, as described above.

Comparing Files

You can compare a file or directory in any workarea, staging area, or edition to a corresponding file or 
directory in any other workarea, staging area, or edition. The Compare function checks 
corresponding files in each workarea, staging area, or edition and tells you which files have changed in 
one, the other, or both workareas, staging areas, or editions. 

You can use this feature to see what items have changed between one edition and the next, how one 
person’s workarea differs from another’s, or whether there will be conflicts between a workarea and 
the staging area.

Using TeamXpress File Comparison

You can compare individual files and directories, or you can compare the entire contents of workareas, 
staging areas, or editions. If you are comparing individual files or directories, you can only compare 
one file or directory at a time. If you are comparing directories, the entire contents of the directory 
you select (including subdirectories) will be compared. 

To cancel the Compare operation, click the name of a directory or area in the Navigation Window at 
any step.

Comparing Individual Files or Directories

To compare individual files or directories in a workarea, staging area, or edition:

1. Navigate into the workarea, staging area, or edition containing the item that you want to compare. 
Find the first file or directory that you want to compare, and select its checkbox. If no item is 
selected, TeamXpress will compare the entire current directory.

2. Select File > Compare Any.
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3. TeamXpress will ask you to select the workarea, staging area, or edition containing the file or 
directory that you want to compare the first item against. Using the Choose Area window (see 
page 77), navigate through the site until you have found the area containing this item. If the area is 
on another branch, click the branch’s name to access its workareas, staging areas, editions, or sub-
branches.

4. Click the name of the workarea, staging area, or edition. TeamXpress will compare the first file or 
directory you selected with the corresponding file or directory in this location and display the 
results in the Compare Results window.

5. If files have only changed in one area, TeamXpress will display the results immediately. If files have 
changed in both areas, TeamXpress will ask you which set of results you want to view. You may 
switch from one set of results to another at any time by clicking the underlined text.

Comparing Entire Areas

To compare the entire contents of workareas, staging areas, or editions:

1. From the branch view, select File > Compare Any.

2. TeamXpress will ask you to select the first area that you want to compare. Using the Choose Area 
window, navigate through the site until you have found the workarea, staging area, or edition that 
you want to compare.

3. Click the name of the area that you want to compare.

4. TeamXpress will ask you to select the second area that you want to compare. Using the Choose 
Area window, navigate through the site until you have found the workarea, staging area, or edition. 
If the area is on another branch, click the branch’s name to access its workareas, staging areas, edi-
tions, or sub-branches.

5. Click the name of the workarea, staging area, or edition. TeamXpress will compare the first set of 
files you selected with the corresponding files in this location and display the results in the Com-
pare Results window.
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6. If files have only changed in one area, TeamXpress will display the results immediately. If files have 
changed in both areas, TeamXpress will bring up a Choose Results window where you may choose 
which set of results you want to view: changes that have been made in one area, changes that have 
been made in the other area, or conflicts where files have been changed in both areas. You may 
switch from one set of results to another at any time by clicking the underlined text.

Comparing Files with the Staging Area

To compare files or directories in a workarea or edition with the staging area on that branch:

1. In the workarea or edition, find the file or directory that you want to compare, and select its 
checkbox. If no item is selected, TeamXpress will compare the entire current directory.

2. Click the Compare button in the Button Bar.

3. TeamXpress will automatically compare the first item you selected with the corresponding file or 
directory in the staging area on that branch and display the results in the Compare Results window.

4. If files have only changed in one area, TeamXpress will display the results immediately. If files have 
changed in both areas, TeamXpress will ask you which set of results you want to view. You may 
switch from one set of results to another at any time by clicking the underlined text.

Viewing the Results of Your Comparison

If files have changed in both areas, TeamXpress will bring up a Choose Results window where you may 
choose which set of results you want to view: changes that have been made in one area, changes that 
have been made in the other area, or conflicts where files have been changed in both areas. You may 
switch from one set of results to another at any time by clicking the underlined text. Note that the sets 
of files are non-overlapping. That is, a link for changes in one area does not include the files that 
conflict with the other area. 

For example, the following screenshot shows the results of comparing workareas andre and chris. 
The Compare Results screen contains a line that says, No changes in “chris.” This means that 
there are no changes in chris other than those changes that conflict with andre.
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Choose Results window

In the Compare Results window, unchanged files are marked with an  (Unchanged) icon.

Modified files or newer versions of a file are marked with a  (Modified) icon or with one of the 
Modified icon variants, as appropriate (see “TeamXpress Icon Reference”).

Deleted files and directories are marked with a  (Deleted) icon.
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From the Compare Results window, you can see information about the two versions, such as 
modification date, user information, and version. You can display the two versions of a file side by 
side, either as it will be displayed in a browser window (see page 85), or as source code (see page 86). 
You can also copy files from one area that you are comparing into the other (see page 87), or merge 
the two versions (see page 87).

Compare Results window
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Viewing Version Details of Compared Files

To see information such as modification date, user information, and version on two versions of a file 
that you have compared, click the Details button next to those files in the Compare Results window. A 
popup window will appear with the information for each version of the file.

Compare Details window
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Visually Comparing Files

When you are comparing files in different workareas, staging areas, or editions, you can view 
corresponding files side by side, in the context of their respective versions of the Web site. Click the 
VDIFF button next to the pair of corresponding files you want to view in the Compare Results 
window. A Visual Difference window will appear, displaying the two versions side by side.

You can also use this function with SmartContext Editing: select Advanced > File > Vdiff with 
Staging, and a Visual Difference window will appear that displays the current version of the file side-
by-side with the version in the staging area. 

Visual Difference window
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Visually Comparing Source Files

To view the HTML or text source of the two documents, click the Source Diff button in the Visual 
Difference window. A Source Diff window will appear, displaying the source of the two documents 
side by side. Changes will be highlighted in red. You can jump from one change to another using the 
buttons at the bottom of the screen. Source Differencing is only available for text files, and will not 
work for other formats such as graphics or sound files.

Source Difference window
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Copying Files From the Compare Results Window

To copy files from the Compare Results window:

1. Select the checkboxes next to the files you want to update. 

2. Click the  (Copy Left) or the  (Copy Right) button in the Button Bar. 

If you click the Copy Left button, the selected files in the right-hand column will be copied over the 
files in the left-hand column. If you click the Copy Right button, the selected files in the left-hand 
column will be copied over the files in the right-hand column. The Copy Left and Copy Right 
buttons are only available when you are comparing one or more workareas.

If you want to copy older files over newer or conflicting versions, you will need to click the 
Overwrite button before clicking one of the Copy buttons. The Overwrite button is automatically 
turned on when you view the Conflicts section of the Compare Results window.

Merging Files

If two files are in conflict and you want to combine both sets of changes, you can use Merge to 
reconcile them. If you are using Netscape 4.07 or later or Internet Explorer 4.01 or later, you do not 
need to install any additional software to use Merge. If you are using an earlier browser, you must 
install a Java plug-in and Java class files. 

Merging is only available for text files, and will not work for other formats such as graphics or sound 
files.
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Installing Merge

Netscape

For versions of Netscape earlier than 4.07:

1. The first time you click the Merge button in the Compare Results window, a dialog box will appear 
telling you that you need to install the Java Plug-in, which is needed for Merge. Click Get the 
Plug-in.

2. A new browser window will appear, taking you to the Plug-in Download page. On this page, click 
the Java Plug-in Download link. Follow directions to download the plug-in.

3. Close the Java Download browser window, and double-click the downloaded file. The Java Plug-in 
will install itself on your computer.

4. In the TeamXpress window, click the Merge button again. A dialog box will appear, telling you 
that if you want to bring up Merge faster, it needs to install some more software. Click OK. 

5. Click the Merge button again. A Java Security window will appear, asking if you want install soft-
ware on your computer. Click Grant.

6. Merge software will install itself on your computer.

Internet Explorer

For versions of Internet Explorer before 4.01:

1. The first time you click the Merge button in the Compare Results window, a dialog box will appear 
asking if you want to install Merge software. Click Yes. 

2. Another dialog box will appear, asking if you want to permit Sun to install software on your com-
puter. Click Grant.

3. Merge will install itself on your computer, and the Merge window will open.
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About Merge

Merge compares each of the two conflicting file versions against their common ancestor, and is 
therefore able to determine which version contains a particular change. This allows Merge to 
intelligently recommend which changes to incorporate into the merged file.

For example, Chris and Andre might both change the same file (index.html) in their own private 
workareas. The common ancestor of this file might reside in an earlier edition (Edition_1), as 
shown below.

In this case, Merge would check Version 2+ of index.html in both workareas against Version 2, 
which happens to be located in Edition_1. This way, Merge can tell which lines in each new version 
have changed from the original version. If a line changed in Andre’s version but not in Chris’s, Merge 
will recommend that you accept that change. And if a line changed in Chris’s version but not in 
Andre’s, Merge will recommend that you accept that change, as well. However, if a line changes in 
both versions, then Merge will ask you to reconcile the change.
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Branch structure showing the version history of a file that has been modified in two workareas

Initial

Staging Area

index.html

index.html

andre

index.html
Version 2+

chris

index.html
Version 2+

Version 2

Edition 1

index.html
Version 2

Version 1

Common ancestorModified file in conflict
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Using Merge

To use Merge, click the Merge button next to the two files in the Compare Results window. The 
Merge window will appear, showing the changes you have made, the changes another user has made, 
the common ancestor of the file, and the file that results from reconciling changes.

The Merge window

You can also view a subset of these files by selecting any of the options in the View menu.

Differences found between the three versions will be highlighted in red. The lines containing the 
differences will be colored gray. You can use the Next Difference and Prev Difference buttons to 
jump from difference to difference, or you scroll through the files using the scroll bars.

Your

Common

Merged

Other user’s
changes

ancestor

changes

changes
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If a line has been changed in only one version, when you select that difference it will be highlighted 
strongly, as shown below. The corresponding lines in the other versions of the file will be highlighted 
weakly:

The Merge window, showing a change made to a single file
92 TeamXpress User’s Guide



Merging Files
If a line has been changed in both versions, when you select that difference the corresponding line will 
be highlighted weakly in all versions, as shown below:

The Merge window, showing changes made in both files

For each change, you have three choices:

• Click the Accept New Change button to keep the change you have made, discarding any changes 
that have been made to the corresponding line in the other version. 

• Click the Accept Other Change button to keep the change that the other user made, discarding 
your own changes. 

• Or, click the Keep Original button to discard the changes that both you and the other user made 
to the file. 
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The Merged Changes window will be updated to reflect your decisions. After you have chosen which 
change to keep, you can still go back and choose another option. You can also manually edit the file in 
the Merged Changes window.

Once you have resolved all the differences between the different versions of the file, you can save it 
and exit Merge. To save your file and exit, select File > Save and Exit. The merged file will be saved 
in your workarea, and a backup copy of the original file will be placed in your workarea under the 
name filename.original.

Listing Modified Files

To view a list of all the files that have been modified in a workarea:

1. Go into the workarea.

2. Select View > List Modified. A list of all files that have been modified since the last time they 
were submitted will appear, including statistics such as size, modification date, and the username of 
the person who modified them.

To view a list of all the files that have been modified in multiple workareas:

1. Go to a view of the branch containing these workareas.

2. Click the checkboxes next to the workareas whose modified files you want to view.

3. Select View > List Modified. A list of all files in these workareas that have been modified since the 
last time they were submitted will appear, including statistics such as size, modification date, and 
the username of the person who modified them.

To view a list of all the files that have been modified on a branch:

1. Go to the branch view.

2. Select View > List Modified. A list of all files on the branch that have been modified since the last 
time they were submitted will appear, including statistics such as size, modification date, and the 
username of the person who modified them.
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Using this list, you can select files in order to view their histories (see page 99), lock or unlock them 
(see page 96), or submit them (see page 64).

List Modified Files window
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Locking Files

TeamXpress supports three different types of file locking: Submit Locking, Optional Write Locking, 
and Mandatory Write Locking. Ask your Branch Administrator which type you are using. Different 
branches on your Web site may use different types of locking. All workareas on a branch use the same 
type of locking.

In the browser interface, the TeamXpress commands New File, Import File, Rename, and Edit all 
automatically lock the files they are operating on. Some tasks may also try to lock files.

When a file is locked, it is locked for a particular workarea. That is, all users who have access to that 
workarea can edit the file. In addition, all users who have previously modified the file can edit it in 
their workareas (but not lock it).

Submit Locking

Submit locking means that if a file is locked, only users within the workarea where it is locked may 
submit the file to the staging area. Users are still allowed to edit the file within the context of other 
workareas but may not submit it until the user who holds the lock has submitted his version or 
manually released the lock. 

If a file is not locked, anyone may submit it.

If someone else has the lock on a file that you are editing, and you try to submit a workarea or 
directory containing your version after the lock holder has submitted the file and released the lock, the 
Compare Results window will appear showing the conflicting versions of the file. From this window, 
you can choose to merge the two files, or to overwrite the version in the staging area with your own.

If someone else has locked a file, and you edit it through the TeamXpress GUI, a warning will appear:
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You can continue to edit the file, but you will have to merge your changes with those of the lock 
owner after he submits it.

Write Locking

Write locking means that a locked file may only be edited in the workarea where it is locked. Users in 
other workareas may not edit the same file even within the context of their own workareas, but they 
may view a read-only copy if they have the necessary permissions. Write locking may be optional, in 
which case the user may choose whether or not to lock the file that he edits, or mandatory, in which 
case a user cannot edit a file without locking it first. Under Mandatory Write Locking, all files in a 
workarea are read-only until a user locks them for editing. Once you’ve modified a file while holding a 
lock, you will be able to continue to modify the file even after releasing the lock. Once you submit the 
file, it will become read-only again.

If you edit an unlocked file, and somebody edits the file at the same time but in a different workarea, 
the second person to submit the file to the staging area will have a conflict and will need to either 
merge the two versions (see page 87), overwrite the version in the staging area with his own, or 
overwrite his own version with the version in the staging area (see page 78).

Locking and Unlocking Files

To lock files:

1. Click the checkbox next to the file or files that you want to lock in your workarea.

2. Select Edit > Lock.

3. A Lock window will appear. Type any comments you have in the comment box next to each item. 

4. The Lock function will automatically compare the version in the workarea and the version in the 
staging area, and take the most recent. If you want to keep the version in your workarea, whether 
or not it is newer, deselect the Get Latest checkbox.

5. Click OK. TeamXpress will lock the files.
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To unlock files:

1. Click the checkbox next to the file or files that you want to edit in your workarea.

2. Select Edit > Unlock.

Viewing Locks

To list locks in your workarea:

1. Go into your workarea.

2. Select View > List Locks. A list of all files that have been locked in your workarea will appear.

To list locks in multiple workareas:

1. Navigate to the branch view of the branch containing the workareas. 

2. Click the checkboxes of the workareas in question. If you are in the branch view and you do not 
select any checkboxes, TeamXpress will display all the locks on that branch.

3. Select View > List Locks. 

To list all locks on a branch:

1. Go to the branch view.

2. Select View > List Locks. A list of all locked files on the branch will appear.

A  (Key) or  (Modified Key) icon is displayed next to files that are locked in your current 
workarea.

A  (Locked) or  (Modified Locked) icon is displayed next to files that are locked in other 
workareas.
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Locking Files and the Overwrite Button

If you click the Overwrite button and then try to lock a file, TeamXpress will take the version of the 
file in the staging area regardless of whether or not it is newer than the version in your workarea, copy 
it into the workarea, and lock it (if the file is not already locked).

Viewing File Histories

TeamXpress’s History feature allows you to view any previous version of a file, along with such 
statistics as dates of modification and usernames of the people who modified the file. Further, it allows 
you to revert to any previous version of the file. History only displays versions that have been 
submitted to the staging area, and it does not display sibling versions of the file that may appear on 
other branches.

To view the modification history of a file or files:

1. Click the checkboxes next to those files in your workarea. 

2. Select View > History. A Version History window will appear, displaying statistics such as revision 
ID, the area that contains that version of the file, size, modification date, comments that were 
attached at the time of submission, and the username of the person who submitted the files. For 
each file, the version at the top of the list is the version that currently appears in your workarea.
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Version History window

The revision ID is unique for each version of a given file, and it has the format branchpath/
versionnumber, where branchpath is the path to the branch (e.g. main/branch1) and 
versionnumber is the number of the revision of the file on that branch. If you copy the file to 
another branch, it will have a different version number there. A + after the version number means 
that it is a version that has been modified in a workarea but not yet submitted to the staging area.

If this file has been copied from another branch, it will be noted in the entry for the version that 
was copied. You can click the link to see the revision history of the file on the other branch.

You can view older versions of files by clicking their underlined file names.
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Comparing Versions

You can compare the source of any two versions of a text file, side by side, using Source Differencing.1

To compare two versions of a file:

1. In the History window, click the check boxes next to the two versions you want to compare.

2. Click the Source Diff button in the Button Bar.

3. The Source Differencing window will appear. You can jump from difference to difference by click-
ing the Prev Difference and Next Difference buttons.

Version History Source Differencing window

1. Requires a browser that will support Merge. See “Choosing a Browser” on page 16.
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Reverting to an Older Version

The Version History window will allow you to revert to any previous version of a file that appears in 
the window. This version will then appear at the top of the History list. This type of modification, like 
all modifications, does not become a permanent part of the file’s history until it is submitted to the 
staging area. Therefore, you can revert to an older version and view it in the context of the current 
Web site, then go back to a newer version.

If you have a modified version of the file in your workarea and you revert it, the modification will be 
lost. Revert will overwrite the file, and you will only be able to go back to a version that has been 
submitted to the staging area.

To revert a file to an older version:

1. In the Version History window, click the Revert button next to the version you want to revert to. 
A confirmation dialog box will appear.

2. Click OK.

TeamXpress will return you to the Version History window, showing the change that you have made. 
The file in your workarea will be reverted to the selected version. 
102 TeamXpress User’s Guide



Marking Files and Directories Public or Private
Reverted file in the Version History window

Marking Files and Directories Public or Private

By default, files in your workarea are public. That is, they can be submitted to the staging area, so that 

other users can access them when they update their workareas.1 Private files are files in your workarea 
that are not made available to other workareas. They are ignored during all submissions to the staging 
area and when you use Copy To to copy files from your workarea to another location. However, 
private files may be overwritten if you copy files into your workarea or use the Get Latest command. 
To deliberately overwrite a private file, click the Overwrite button before a Copy To or Get Latest 
operation.

1. You can only edit a file if you have permissions, whether the file is public or private.
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You can also mark a directory as private, and everything inside the directory will be treated as private 
when you are performing a Submit, Get Latest, Compare, or other operation on the directory. 
However, if you go inside the directory and perform these operations on the individual files and 
directories that it contains, they will not be treated as private unless they are specifically marked so.

For example, if you submit a directory that contains a private directory to the staging area, the private 
directory and all of its contents will not be submitted. However, if you go inside the private directory 
and submit any public files or directories, they will appear in the staging area with the same directory 
path that they have in the workarea.

To make a file or directory private:

1. Click the checkboxes next to the files or directories that you want to make private in your 
workarea.

2. Select Edit > Private.

A  (Private File) icon appears next to each file that you have selected, signifying that the file is 
private.

A  (Private Directory) icon appears next to each directory that you have selected, signifying that 
the directory is private.

To make private files or directories public:

1. Click the checkbox next to the file or files that you want to edit in your workarea.

2. Select Edit > Public.

All files not marked with the  or  icons are public by default.

Autoprivate

Autoprivate may or may not be implemented on your system. Autoprivate automatically marks certain 
files in your workarea as private, so that they won’t be propagated into the staging area and editions. 
Examples of files that Autoprivate may mark as private are: temporary files, backup files, and resource 
forks. Autoprivate is configured by your system administrator on a system-wide basis.
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Deleting Files and Directories from the Staging Area

The staging area is read-only, so if you submit a file in error, you cannot delete it directly. 

To delete a file from the staging area:

1. Delete the file from your workarea.

2. List modified files in that workarea (see page 94). The deleted file in your workarea will have a  
(Deleted File) icon.

3. From the list of modified files, select the deleted file. Click the Submit button in the Button Bar or 
select File > Submit.

To delete a directory from the staging area:

1. Delete the directory from your workarea.

2. List modified files in that workarea (see page 94). The deleted directory in your workarea will have 

a  (Deleted File) icon.

3. From the list of modified files, select the deleted directory. Click the Overwrite button in the But-
ton Bar, then click the Submit button or select File > Submit.

Setting Metadata

Metadata capture may or may not be implemented on your system.

You can set metadata on a file or set of files via the GUI. Different files may require different types of 
metadata to be set (this may be configured on an individual basis). Information about configuring rules 
for capturing metadata is available in Administering TeamXpress.

You can also use the iwextattr command-line tool to set metadata (extended attributes). 
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To set metadata through the GUI:

1. Select the check boxes next to the files you want to set metadata on, then select File > Metadata. 
The TeamXpress Metadata window will appear. 

Metadata Capture window—Rules view

2. The initial window that appears allows you to set metadata on all the selected files, according to the 
rules that have been configured for those files. All the files will have the same metadata.

3. To set different metadata on different files, click the Switch to File View button in the Button Bar. 
The Metadata File view will appear. 
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Setting Metadata
Metadata Capture window—File view
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If you want to set similar metadata on a group of files, set the metadata in the Rules view, then 
switch to the File view to make any necessary changes in individual files’ metadata.

4. When you are finished setting metadata, click Set Metadata.

Searching by Metadata

Metadata search may or may not be implemented on your system.

You can search for files based on metadata set for them. For instance, if a file’s metadata categorizes it 
as a “Press Release” and associates the key words “July” and “Acquisition” with it, then a search based 
on any one or any combination of those values retrieves that file (provided that document type and 

keywords are configured as searchable attributes).1 A metadata search must be conducted within a 
workarea and is recursive through the selected directory and its subdirectories. Text fields in search 
forms are case-sensitive. 

To search metadata through the TeamXpress GUI:

1. Within your workarea, navigate to the directory where you want to begin your search.

2. Select View > Search Metadata (located past the third separator in the menu).

The TeamXpress Metadata Search window appears in a new browser window.

1. Note that some metadata attributes may be set by your administrator as non-searchable. Therefore, the fact that you can set a particular 
metadata attribute on a file does not necessarily mean you can search against that attribute.
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TeamXpress Metadata Search Window

3. Decide whether you want your search to match all or any of your criteria and select the appropri-
ate radio button at the top of the TeamXpress Metadata Search window.

4. Set the criteria for your search. You may set just one or several search criteria. Focus your search 
by selecting operators from the drop down menus. Also, remember that text fields are case-sensi-
tive.

Note that dates must be entered in YYYY-MM-DD format with dashes between year, month and 
day. Also, when you use the Between operator for a numerical range, you must enter a starting 
value in the first field and an ending value in the second. When you use operators other than 
Between you need only enter a value in the first field.

5. When you have set your criteria, click Search.
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The results display in the right frame of the main TeamXpress GUI. Although the results display in 
order by file name, be aware that regardless of where you initiate your search the relative path from 
the workarea to the file is included in the file name. For example, a search hit that retrieves a file 
named Zeus.html in a directory named Apollo in a workarea named Janus displays the file as 
/Apollo/Zeus.html even if the search was initiated in Apollo.
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Chapter 5

Managing Workflow Tasks and 
Jobs
TeamXpress workflow begins when a user creates a job, based on a workflow template. A workflow 
template describes a particular workflow model. For information about configuring workflow 
templates, consult Administering TeamXpress.

The user who creates the job specifies the parameters of this job, such as the users who are to perform 
specific tasks, the workarea a task is to take place in, and the files associated with a task.

The users who are assigned specific tasks may be notified by email (if the workflow template is 
configured to do this) or by checking their To Do lists in the TeamXpress GUI. 

When users complete tasks, they send them to the next step of the workflow process by selecting a 
transition. If the task is a decision point within this workflow model, they may need to select from 
several possible transitions (e.g. if the task is an approval task, they will need to decide whether to 
approve or reject the file).

When all the tasks in a job have finished, the job will no longer appear in the TeamXpress GUI.

Managing Tasks

Viewing Your To Do List

To see which tasks and jobs you own that are currently pending, click the To Do button in the Button 
Bar. TeamXpress will take you to the To Do list in the Workflow view and show you all the tasks and 
jobs that are assigned to you. You can filter your list by using the drop-down menus in the title bar. 
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A To Do list using filtering

The To Do List defaults to a maximum of 55 jobs per page. If you have more than 55 jobs, navigation 
buttons at the bottom of the screen allow you to view the other jobs.

The To Do list gives you two new menus: Job Options and Task Options. These menus allow you to 
get further information on tasks or jobs, edit the attributes of a job, perform tasks (see ), edit tasks 
(see page 115), or complete tasks (see page 120).

Viewing Task Details

To view the Task Details window, select either Start Task or Edit Task from the Task Options menu.

TeamXpress 4.5 includes all custom File menu items in the File Options drop-down list for each file 
listed in the Task Details screen. These custom menu items are configured by your administrator 
during the installation process. Custom menu items for other menus (Edit and View) are not included 
in the Task Details screen.
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Performing Tasks

TeamXpress workflow includes many kinds of tasks. Tasks may require you to add files to the task, edit 
files or set metadata, or they may be performed by external programs that require no user input. 
Some tasks may require review and approval or rejection (these tasks are often marked as read-only).

To perform a task, select Task Options > Start Task. If the task involves file operations such as 
editing or adding files, or task operations such as approving files, the Task Files window will appear. 
Do these things as described elsewhere in this manual (see page 113 for information on editing files, 
page 116 for information on adding files, and page 120 for information on approving tasks). When 
you are finished, you will need to complete the task (see page 120).

Tasks performed by external programs often do not require user input, and may run invisibly to the 
user. Some automated tasks may require user input, in which case a separate form will appear when 
needed for data entry. When you select Task Options > Start Task, the task window will appear. 
Enter information as it directs you.

Editing Task Files

To edit a file in a task, go to the Task Details page (select Task Options > Start Task from your To Do 
list). Locate the file you want to edit, and select File Options > Edit File/Data Record. Edit the file 
as described in “Editing Files” on page 54.

Adding Comments to Task Files

At any point in a task, you can add information in the form of comments on the files contained in the 
task. These comments may convey information to other users involved with the job (e.g. content 
contributors or approvers).

To add a comment to a task file:

1. Go to the Task Details page (select Task Options > Edit Task from your To Do list). 

2. Locate the file you want to add the comment to. Select File Options > Edit Comment.
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3. The File Comments page will appear, containing a list of the task’s existing comments at the bot-
tom of the page, and a text box at the top of the page. Enter your comments in the text box and 
click Add File Comment.

4. You will be returned to the File Comments page, where you can enter another comment. To exit 
this page, click the Close button.

The File Comments page

Renaming Task Files

To rename a file in one of your tasks:

1. Go to the Task Details page (select Task Options > Edit Task from your To Do list). 

2. Locate the file whose name you want to change. Select File Options > Rename.

3. A dialog box will appear. Type the new name into the space provided. Click OK.

The file will appear in the Task Details page with the new name. A deleted file with the old name 
will also appear in the Task Details page, for future submission to the staging area.
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Editing Tasks

To view task information or edit tasks:

1. Go to your To Do list and locate the task you want to view.

2. Select Task Options > Edit Task. The Task Details window will appear.

The Task Details window

In this window, you can perform file operations and task operations. File operations include editing 
task files, removing task files, and adding comments to task files. Task operations include adding and 
removing files from tasks, adding comments to tasks, completing tasks, and comparing task files to the 
staging area.
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Adding and Removing Files from Tasks

Adding a New File to a Task

To add a new file to a task:

1. In your To Do list, select Task Options > Edit Task.

2. The Task Details window will appear. Select Task Operation > Add New File.

Adding new files to a task
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3. A New File window will appear. Enter the name of the new file, and if necessary, navigate to the 
directory where you want to put the file. Select the type of template you want to use (if you do not 
want to use a template, make sure Plain File is selected), and select the specific template you want 

to use.1 Click OK.

4. The file will be added to the task, and it will open in your editing application.

This file will not be visible in the Task Details window until you select Task Operation > Refresh.

Adding Existing Files to a Task

To add existing files to a task:

1. In your To Do list, select Task Options > Edit Task.

2. The Task Details window will appear. Select Task Operation > Add Existing File.

3. The Add Files to Task window will appear. Use the left-hand pane to locate the file or files you 
want to add to the task. When you have located them, check the check boxes next to them and 
click Add Files to List. They will appear in the right-hand pane.

If you add files to the list in error, click the check boxes next to the files you want to remove in the 
right-hand pane and click Remove Files from List.

1. The templates you select through the New File window are not TeamXpress Templating templates. For more information about New 
File templates, see page 180. For more information about TeamXpress Templating, consult Using and Configuring TeamXpress Templating.
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The Add Files to Task window

4. When the list in the right-hand pane contains all the files you want to add to the task, click Add 
Listed Files to Task. The files will be added to the task.

Removing Files from Tasks

To remove files from a task:

1. In your To Do list, select Task Options > Edit Task.

2. The Task Details window will appear. Locate the file you want to remove, and select File Opera-
tion > Remove From Task.

3. A confirmation box will appear; click OK.

4. The file will be removed from the task.
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Adding Comments to Tasks

At any point in a task, you can add information in the form of comments. These comments may 
convey information to other users involved with the job (e.g. content contributors or approvers).

To add a comment to a task:

1. Go into your To Do list (click the To Do button in the Button Bar).

2. Locate the task you want to add the comment to. Select Task Options > Add Task Comment.

3. The Task Comments page will appear, containing a list of the task’s existing comments at the bot-
tom of the page, and a text box at the top of the page. Enter your comments in the text box and 
click Add Task Comment.

The Add Comments page

4. You will be returned to the Task Comments page, where you can enter another comment. To exit 
this page, click the Return to List button.
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Editing Task Descriptions

To change the task description that appears in your To Do list:

1. Go to your To Do list (click the To Do button in the Button Bar). 

2. Locate the task whose description you want to change. Select Task Options > Change Descrip-
tion.

3. A dialog box will appear. Type the new description into the space provided. Click OK.

The new task description will appear in your To Do list.

Renaming Tasks

To rename a task that appears in your To Do list:

1. Go to your To Do list (click the To Do button in the Button Bar). 

2. Locate the task whose name you want to change. Select Task Options > Rename.

3. A dialog box will appear. Type the new name into the space provided. Click OK.

The new task name will appear in your To Do list.

Approving Tasks

Approval tasks require you to review the files, and then approve or reject them. To approve or reject 
the task, select the appropriate successor option (see “Completing Tasks” on page 120). Confirmation 
of your choice will appear in the TeamXpress window. 

Completing Tasks

When you have completed a task, you need to select a transition to move the job along the workflow 
process.

To select a transition:

1. Go to the Task Details page (select Task Options > Edit Task from your To Do list). 
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2. Select the Task Operation menu. All possible task transitions will appear at the bottom of the 
menu. These transitions will vary from task to task (e.g. Approve, Reject, Done). 

3. Select a transition.

The job will now move on to the next task. The task will appear in your To Do list with an updated 
status.

Some tasks may be retrieved after you have selected a transition (this is only possible if the next task 
has not been activated). If you want to take a task back, go to your To Do list and select Task Options 
> Take back task (if available). If this menu option is not available, then this task cannot be retrieved.

Taking Ownership of Tasks

You can only take ownership of group tasks, which are created without a specific owner. These tasks 
will say <no user> in the Owner column of the Job History window.

To take ownership of a task:

1. Go to your To Do list (click the To Do button in the Button Bar). Select View > Unassigned 
Tasks.

2. Locate the task you want to own. Select Task Options > Take Ownership of Task.

3. The task will now appear in your To Do list.

Resolving Task Conflicts

If, during the course of a workflow operation, you create conflicts1 in a file or files, and a task tries to 
submit the conflicting files to the staging area, you will be taken to the Compare Tasks page to resolve 
the conflict (see page 122).

You can resolve the conflict by merging the two versions of the file (see page 124), by overwriting the 
version in the staging area (see below), or by overwriting your version with the one in the staging 
area.

1. See “Comparing Files” on page 79.
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To overwrite the version in the staging area with your own version, select the checkbox next to the 
file, click the Overwrite button, then click Submit.

To overwrite your version with the version in the staging area, select the checkbox next to the file, 
click the Overwrite button, then click the Copy button.

Comparing Tasks to the Staging Area

To compare the files in a task to the versions of those files contained in the staging area, go into the 
Task Details window and select Task Operation > Compare to Staging.

The Compare Tasks page

The Compare Tasks page allows you to see the differences between two versions of a set of files (in 
this case, the version of the files in the task, and the version of the files in the staging area). You can 
view the differences in the file properties and metadata, you can view the two versions of a page side 
by side, or you can view the source of two files side by side (available only for text files). You can also 
merge the two versions of the files (available only for text files).
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Viewing File Properties of Two Versions of a File

To view the properties of two versions of a file, side by side:

1. Select the check box next to the file in the Compare Tasks page.

2. Click the Properties button in the Button Bar.

3. The Compare File Details window will appear, showing you information such as name, type, size, 
permissions, status, extended attributes, and metadata side by side.

The Compare File Details page

Visually Comparing Files

To use the Visual Difference feature with the files in your task, select the check box next to a file in the 
Compare Tasks page, then click the Visual Diff button in the Button Bar. For more information about 
Visually Comparing Files, see page 85.
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Visually Comparing Source Files

You can view the differences between the source of any two files.1 To use the Source Difference 
feature with the files in your task, select the check box next to a file in the Compare Tasks page, then 
click the Source Diff button in the Button Bar. For more information about Source Differencing, see 
page 86.

Merging Files

If you have been brought to the Compare Tasks page because you need to resolve a conflict in a task, 
and you want to merge the two files, click the check box next to the file, then click the Merge button 

in the Button Bar.2 For more information about merging files, see page 87.

1, 2.Requires a browser that will support Merge. See “Choosing a 
Browser” on page 16.
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Managing Jobs

Viewing Jobs

To view all the jobs that you have created, select View > My Jobs. The TeamXpress window will 
display all the jobs you own, with information about the tasks contained in each job.

The Jobs window

A general outline of future tasks will be shown. However, this outline is subject to change, as some 
workflow models permit different paths to be taken through a job.

You can also view all jobs currently active in the system; to do this, select View > All Jobs.
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Creating Jobs

To create a new job:

1. Select File > New Job. A new window will appear, asking you to select the workflow template you 
want to base the job on.

The workflow templates that appear in this window are the templates that have been configured for 
your system. They may therefore differ from the example shown.

The New Job window

2. Select the radio button next to the workflow template you want to use, and enter descriptive com-
ments in the text boxes. Click New Job.

3. A Job Template window will appear (this window will look different for different workflow tem-
plates). Enter the parameters of the new job in this window. The required parameters may differ 
for each workflow template. Click Create Job.

If you have not entered data in required fields, or if you have entered invalid data, the fields that 
require your attention will be highlighted. Correct the data and click Create Job again.
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Viewing Job Details

To view the tasks contained in a job you own, select View > My Jobs. All the previous and current 
tasks will appear, with their status indicated. Note that this outline is subject to change, as some 
workflow models permit different paths to be taken through a job.

A “My Jobs” view

You can get more information about a job by selecting Job Options > Job Details.
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Job Details window

The Job Details window shows the job owner, name, description, and past tasks. To view information 
about a particular task, click its name in this window. The Task Details window will appear (see 
page 115).
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Chapter 6

Administering TeamXpress
An Administrator can perform all the functions of an Author or an Editor. In addition, an 
Administrator can create and delete new branches, sub-branches, and workareas. An Administrator 
also determines the type of locking used on a branch, can compress and uncompress old editions, and 
can view custom reports of user activities. In TeamXpress, you cannot create workareas off of the 
main branch. Additionally, depending on the licensing agreement for your product, you may not be 
able to add branches or sub-branches.

Using the Tool Bar

The Administrator’s Tool Bar contains all the functions that an Editor has access to, in addition to some 
more advanced branch management functions. The Tool Bar consists of a Button Bar, containing the 
most frequently used commands, and a Menu Bar, which displays drop-down menus containing all the 
commands. Various commands are displayed at different times according to when you can use them. 

The Administrator’s Tool Bar

The Menu Bar contains three drop-down menus: File, Edit, and View. Each menu is displayed only 
when you can use at least one of the commands that it contains. Individual commands within the 
menus are displayed only when you can use them. 
129



Administering TeamXpress
Creating Branches

When you create a branch, you can choose to base it on any edition of another branch. Your current 
software version and license agreement may limit the total number of branches you are allowed to 
create.

To create a branch:

1. Select File > New Branch.

2. You will be asked what edition you want to base the new branch on. Click the name of the edition 
you want to use as a starting point.

3. A Create Branch window will appear.

4. Enter the name of the branch in the Name box.

5. Your username will appear in the Owner box. If you want to assign the branch to someone else, 
enter the owner’s name (including domain if using UNIX) in this box (e.g. WEBSTER\andre).

6. If you want this branch to have multiple Administrators, enter the name of the group who will be 
able to administer this branch in the Group for Sharing box.

7. Use the pull-down menu to select the type of locking you want to be used on this branch (see 
page 96 for an explanation of the different types of locking).

8. Add any comments in the Comment box.

9. Click OK.

Your newly created branch will contain no workareas, a staging area, and an edition called INITIAL, 
which will be a copy of the edition you used as a starting point. 
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Create Branch window

Creating Workareas

Based on the version of software you have licensed, there will be limitations on the number of 
workareas you can create. Additionally, you cannot create workareas under the main branch.

To create a workarea:

1. Select File > New Workarea.

2. If there are multiple editions on the branch, TeamXpress will ask you what edition you want to 
base the new workarea on. Click the name of the edition you want to use as a starting point.

3. The Create Workarea window will appear. Enter the name you want to give the workarea in the 
Name box, and the username of the workarea’s owner (including domain if using UNIX) in the 
Owner box (e.g. WEBSTER\andre). 
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4. If you want a group to be able to share this workarea, enter the name of the group in the Group for 
Sharing box. If you want this workarea to be private, so that only the owner can modify files in it, 
type none in the Group for Sharing box. For a Windows NT/2000 server, if you want all users to 
have access to this workarea, type everyone in the Group for Sharing box.If you want all users to 
have access to this workarea, type everyone in the Group for Sharing box.

5. Add any comments in the Comments box.

6. Click OK.

If you want this workarea to have the most recent content, you will need to use Get Latest on the 
entire workarea, because changes may have been made to the staging area since the edition you 
selected in Step 2 was published. If you want to work on the older version of the Web site content, do 
not use Get Latest.

Create Workarea window
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Deleting Workareas, Branches, and Editions

To delete a workarea, branch, or edition:

1. In the branch view, click the checkbox next to the item you want to delete.

2. Select File > Delete.

3. A confirmation window will appear. Click OK.

The workarea, branch, or edition will be deleted together with all its contents. Deleting a branch will 
delete all editions, workareas, and subordinate branches contained in that branch. In addition, 
deleting a branch or edition will delete all versions of a file that are contained within that branch or 
edition.

When you delete an edition, all Submit Log entries will be transferred to the next most recent 
edition. If the edition you have deleted is the newest one, the Submit Log entries will be transferred to 
the staging area.

Compressing and Uncompressing Editions

TeamXpress allows you to automatically compress all editions except the current one in order to 
conserve disk space. This behavior can be specified at the time of installation.

To compress an edition or editions:

1. Click the checkboxes next to the items you want to compress.

2. Select Edit > Compress.

The selected editions will be compressed. Compressed editions will appear in the Work Window with 

a  (Compressed Edition) icon. Older editions are automatically compressed when newer editions 
are created.
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To uncompress an edition or editions:

1. Click the checkboxes next to the items you want to uncompress.

2. Select Edit > Uncompress.

The selected editions will be uncompressed. Uncompressed editions will appear in the Work Window 

with an  (Uncompressed Edition) icon.

Viewing Reports

TeamXpress’s Global Report Center lets you view reports of most common user activities in any 
TeamXpress area or branch. You can select from three quick reports, or you can generate a custom 
report.

Quick Reports

The three quick reports show lists of all files submitted, deleted, or created on the entire TeamXpress 
server for today’s date.

To generate a report of all files submitted, deleted, or added today:

1. Select View > Reports.

2. The Event Reporting window will appear. Select one of: Today’s Submissions, Today’s Dele-
tions, or Today’s Additions from the Quick Reports pull-down menu.

3. Click the Go! button.

4. Your report will appear in the Event Reporting window.

Custom Reports

Custom reports allow you to specify the type of event to report on, the area affected, the users 
involved, and the timespan for the events covered by the report, and the order in which you want this 
data sorted. You can select from two quick reports, or you can generate a custom report.
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To generate a custom report:

1. In the Custom Report section of the Event Reporting window, select the type of report you want 
(Submit or General).

2. From the Event Condition pull-down menu, select the event you want to report on. Different 
events appear according to which type of custom report you have selected:

3. In the Version Path box, type the vpath (version path) of the file, directory, or TeamXpress area 
you want to be included in the report. If you do not specify a vpath, it will default to your current 
location within TeamXpress.

4. In the User(s) box, type the usernames of the users whose activities you want the report to cover. 
Separate usernames by commas, e.g.:

andre,chris,pat

If you do not specify a username, it will default to all users.

5. In the Time section, use the drop-down menus to select the start and end times for the time period 
to be covered by the report. If you do not specify a time, it will default to the entire time since 
TeamXpress was installed.

Submit General

Add Create Branch

ForceAdd Delete Branch

Modify Create Workarea

ForceModify Delete Workarea

Delete Compress Edition

ForceDelete Uncompress Edition

All Publish Staging Area

Reset Config

All
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6. Select the sort order for your results. You can sort by time, user, and version path.

7. Click Generate Report. Your report will appear in the Event Reporting window. You can re-sort 
your results by clicking on the underlined Time, User, or Version Path headings.

The Event Reporting window
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Chapter 7

Using TeamXpress Templating
TeamXpress Templating provides a highly flexible way to publish XML through easy-to-use templates 
and then display that content based on one or more presentation formats. Because TeamXpress 
Templating separates content entry from presentation, you can reuse content after it is captured and 
stored. TeamXpress Templating also lets you present the same content in different ways by using the 
same content with different templates. This chapter tells you how to install and use TeamXpress 
Templating.

Installing TeamXpress Templating 

The TeamXpress Templating client software must be installed on your computer before you can begin 
creating and editing data content records. Your computer is referred to as a TeamXpress Templating 
Client. The following sections describe how to install the TeamXpress Templating Client software on 
different computer platforms using either an Internet Explorer browser or a Netscape browser.

Installing on Windows Platforms Using Internet Explorer

To install TeamXpress Templating on a Windows Platform using Internet Explorer:

1. Log on to TeamXpress through Internet Explorer (see “Logging In to TeamXpress” on page 17).

2. Navigate to your workarea.

3. Select File > New Data Record.

A message displays telling you that TeamXpress Templating is not installed on your machine. 

4. Click Install to start the software installation.

The install program displays with a button labeled Start Installer for Windows 95, 98, NT. 

5. Verify that the Include VM in download checkbox is checked.
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6. Click the Start Installer button. Normally you should accept the defaults and click Next to 
continue through the installation program.

7. Click Done when the installation finishes. You may minimize the TeamXpress Templating window. 

8. Close the browser window containing the installation program.

When you complete the installation, the New Data Content Record dialog box displays and you are 
ready to select a data capture template and enter data as described in “Entering Data” on page 152

Installing on Windows Platforms using Netscape

To install TeamXpress Templating on Windows platforms using Netscape:

1. Log on to TeamXpress through Netscape (see “Logging In to TeamXpress” on page 17).

2. Navigate to your workarea. 

3. Select File > New Data Record. 

A message displays telling you that TeamXpress Templating is not installed on your machine. 

4. Click Install to start the software installation.

One or more Java digital security screens display. These screens indicate that a Java application 
wants to download and execute the install program on your computer. 

5. Click Grant on each screen to continue.

The install program displays with a button labeled Start Installer for Windows 95, 98, NT. Verify 
that the Include VM in download checkbox is checked. 

6. Click the Start Installer button. Normally you should accept the defaults and click Next to 
continue through the installation program. 

7. Click Done when the installation finishes. You may minimize the TeamXpress Templating window. 

8. Close the browser window containing the installation program.
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Additional Java digital security screens may display. Again, click Grant to continue. You may see 
these screens whenever you restart TeamXpress Templating. If desired, you may turn on the 
checkbox to remember these permissions.

When you complete the installation, the New Data Content Record dialog box displays and you are 
ready to select a data capture template and enter data as described in “Entering Data” on page 152

Installing on Solaris Platforms using Internet Explorer

Note: Before attempting to install on Solaris version 2.6 or earlier, install the Solaris patches that 
allow you to run Java 1.2.

To install TeamXpress Templating on Solaris platforms using Internet Explorer:

1. Log on to TeamXpress through Internet Explorer (see “Logging In to TeamXpress” on page 17). 

2. Navigate to your workarea. Select File > New Data Record. 

A message displays telling you that TeamXpress Templating is not installed on your machine. 

3. Click Install to start the software installation.

The install program displays with a button labeled Start Installer for Solaris Sparc. 

4. Verify that the Include VM in download checkbox is checked. 

5. Click the Start Installer button. Normally you should accept the defaults and click Next to 
continue through the installation program. 

6. Click Done when installation finishes. You may minimize the TeamXpress Templating window. 

7. Close the browser window containing the installation program.

When you complete the installation, the New Data Content Record dialog box displays and you are 
ready to select a data capture template and enter data as described in “Entering Data” on page 152
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Installing on Solaris Platforms using Netscape

Note: Before attempting to install on Solaris version 2.6 or earlier, install the Solaris patches that 
allow you to run Java 1.2.

To install TeamXpress Templating on Solaris platforms using Netscape:

1. Log on to TeamXpress through Netscape (see “Logging In to TeamXpress” on page 17). 

2. Navigate to your workarea. Select File > New Data Record. 

A message displays telling you that TeamXpress Templating is not installed on your machine. 

3. Click Install to start the software installation.

One or more Java digital security screens display. These screens indicate that a Java application 
wants to download and execute the install program on your computer. 

4. Click Grant on each screen to continue.

The install program displays with a button labeled Start Installer for Solaris SPARC. 

5. Verify that the Include VM in download checkbox is checked. 

6. Click the Start Installer button. Normally you should accept the defaults and click Next to 
continue through the installation program. 

7. Click Done when installation finishes. You may minimize the TeamXpress Templating window. 

8. Close the browser window containing the installation program.

Additional Java digital security screens may display. Again, click Grant to continue. You may see 
these screens whenever you restart TeamXpress Templating. If desired, you may turn on the 
checkbox to remember these permissions.

When you complete the installation, the New Data Content Record dialog box displays and you are 
ready to select a data capture template and enter data as described in “Entering Data” on page 152
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Installing on Mac OS Platforms using Internet Explorer

Internet Explorer allows a choice of two Java virtual machines. Check this setting prior to logging 
onto TeamXpress and attempting to install the TeamXpress Templating Client application. Go to 
Preferences > Web Browser > Java. The Java virtual machine field will show either Apple MRJ or 
Microsoft Virtual Machine. If Apple MRJ is selected, the version must be MRJ 2.2 and above. No 
special setup is required; proceed with the install program.

If Microsoft Virtual Machine is selected, perform the following steps before installation:

• In the Java panel of the Internet Explorer Preferences, add an entry to the Class Path field that 
points to the directory <TeamXpress Templating install folder>/For Microsoft

VM.

• Select Web Browser >Security Zones Preference. 

–  Set Zone to Trusted sites zone. 

–  Click Add Sites and add http://<TeamXpress server address>; click OK. 

–  Select Custom (for expert users) and click Settings. Go to Java > Java Permissions and select 
Unrestricted. Click OK to close dialog boxes.

To install TeamXpress Templating on Mac OS platforms using Internet Explorer:

1. Log on to TeamXpress through Internet Explorer (see “Logging In to TeamXpress” on page 17). 

2. Navigate to your workarea. Select File > New Data Record. 

A message displays telling you that TeamXpress Templating is not installed on your machine. 

3. Click Install to start the software installation.

The install program displays with a button labeled Start Installer for Mac OS. 

4. Verify that the Include VM in download checkbox is checked. 

5. Click the Start Installer button. Normally you should accept the defaults and click Next to 
continue through the installation program. 
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6. Click Done when installation finishes. You may minimize the TeamXpress Templating window. 

7. Close the browser window containing the installation program.

When you complete the installation, the New Data Content Record dialog box displays and you are 
ready to select a data capture template and enter data as described in “Entering Data” on page 152

Installing on Mac OS Platforms using Netscape

To install TeamXpress Templating on Mac OS platforms using Netscape:

1. Log on to TeamXpress through Netscape (see “Logging In to TeamXpress” on page 17). 

2. Navigate to your workarea. Select File > New Data Record. 

A message displays telling you that TeamXpress Templating is not installed on your machine. 

3. Click Install to start the software installation.

One or more Java digital security screens display. These screens indicate that a Java application 
wants to download and execute the install program on your computer. 

4. Click Grant on each screen to continue.

The installation Web page displays with a button labeled Download Installer for Mac OS. 

5. Verify that the Include VM in download checkbox is checked. 

6. Click the Download Installer button. 

7. Save the TSTP.bin file. 

8. Double-click on TSTP.bin to decode. 

9. Click the TSTP icon to install the file. 

10.Close the browser window containing the installation program.

To actually start TeamXpress Templating, click on the TeamXpress Templating Client icon on your 
desktop. A TeamXpress Templating window displays; you may minimize it. 
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Select File > New Data Record from the TeamXpress GUI to begin entering data.The New Data 
Content Record dialog box displays and you are ready to select a data capture template and enter data 
as described in “Entering Data” on page 152

Additional Java digital security screens may display. Again, click Grant to continue. You may see these 
screens whenever you restart TeamXpress Templating. If desired, you may turn on the checkbox to 
remember these permissions.

Understanding Templating Concepts and Definitions

The following sections define key TeamXpress Templating concepts and terms. Italicized items are 
explained in detail in their own sections. See the diagram below for more information about how these 
items interact with each other.

TeamXpress Templating Model

TeamXpress Templating is based on two overall concepts: data capture and data presentation. The 
following diagram and sections provide a high-level overview of this architecture.
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TeamXpress Templating Overview
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Data Capture

Data capture occurs when you enter and save data. Data is stored as XML and used later to fill in 
presentation templates to generate multiple renderings of the content, including for the Web and 
wireless devices. You enter data through the TeamXpress Templating GUI by selecting and filling in a 
form based on a data capture template (this form is displayed in the data content record window). When 
the captured data is saved, it is stored as a data content record in the TeamXpress file system. After a data 
content record is created and stored, it can be displayed via a presentation template, or optionally 
deployed to a database via DataDeploy.

Data Presentation

After data is captured and stored as a data content record, you can combine the data content record 
with a presentation template. The result is a generated output file that displays the data content in a 
way defined by the presentation template. The generated output file can optionally be deployed to a 
production Web server via OpenDeploy.

Definitions

The following sections define key TeamXpress Templating terms.

Data Category and Type

TeamXpress Templating organizes data based on category and type. Data categories are at the top level 
of the data organization hierarchy. Each data category contains one or more data types, which 
represent more specific groupings of data. For example, the data category beverages could contain 
the data types tea, coffee, milk, etc.

Data Capture Template

A data capture template defines the structure of the form that is displayed in the data content record 
window, which you use to enter data. A data capture template is associated with a data category and 
type. The data category and type define what needs to be entered into the data capture template.The 
data that you enter is saved in the TeamXpress file system in the form of a data content record. See 
“Entering Data” on page 152 for information about how to enter data in a form based on a data capture 
template.
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Presentation Template

A presentation template is an XML file that defines how captured data will appear when displayed. A 
presentation template is “populated” with an existing data content record plus any additional 
information that may be stored in a database. You can use any available data content record to populate 
any available presentation template that has been configured for the data content record’s data capture 
template. You can also use a single data content record to populate more than one presentation 
template, resulting in a different look and feel for the same data content record, including versions for 
your internet and wireless Web sites. See “Previewing and Generating Output” on page 159 for 
information about how to combine a data content record with a presentation template to create an 
output file.

Data Content Record

A data content record contains the data entered via the TeamXpress Templating GUI for a specific 
category and type. You name a data content record when you save it. A data content record is an XML 
document whose elements can be mapped on an optional element-by-element basis to any relational 
database using DataDeploy Database Auto-Synchronization.

Understanding Data Storage Hierarchy

TeamXpress Templating uses a data storage hierarchy based on data categories and types. The directory 
structure supporting this hierarchy resides in the workarea for each TeamXpress Templating user. The 
directory structure is as follows. Items in boxes are directories; items not in boxes are files.
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TeamXpress Templating Directory Structure

The templatedata directory is at the highest level in the hierarchy within the workarea. 

Data categories are at the next level in the hierarchy and contain one or more data types. Data type 
directories each contain the subdirectories data and presentation as well as other files. The data 
content records you create are stored in the data directory or a subdirectory. The presentation 
templates you can use are stored in the presentation directory.

The following directory structure is created by default when TeamXpress Templating is installed. The 
examples in this manual are based on this directory structure. While your production directories will 
be different, this provides an example of how TeamXpress Templating directories are structured.

Workarea

templatedata

data_category_1

data_type_1

data_category_2

data_type_2

. . .

. . .

data presentation

content_record_1

content_record_2
. . .

pres_template_1.tpl

pres_template_2.tpl
. . .
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Example TeamXpress Templating Directory Structure

README

README

README
templating.cfg.example

examples
Templating

config

templatedata

internet
auction

README

data

datacapture.cfg

presentation

auction.tpl
book

careers

medical

periodic

pr

intranet

deptinfo

workflow
README
author_submit_dcr-0.ipl

author_submit_dcr-3.ipl
author_submit_dcr.wft

iw-home

...

...

...

...

...

...

Data Category: internet

Data Category: intranet

Data Types:
• auction

• book

• careers

• medical

• periodic

• pr

• yacht

weather
...

Data Types:
• deptinfo

• weather

}
custom-dtd-examples

PressRelease

Data Category: 
custom-dtd-examples

Data Type:
PressRelease
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Creating a New Data Content Record

The following diagram shows the actions that take place when you create a new data content record. 
Sections following the diagram explain each diagram step and component.

1. A content contributor clicks File > New Data Record in the TeamXpress GUI. 

2. TeamXpress Templating displays the available list of data categories in the New Data Content 
Record dialog box.

3. The content contributor selects a data category and data type.

4. TeamXpress Templating displays the data capture template in the data capture form window.

5. The content contributor enters data in the data capture template and selects File > Save. 

6. Using the data provided by the content contributor, TeamXpress Templating writes a data content 
record to the data subdirectory (or to a subdirectory of data) in the TeamXpress file system. 

7. If creating the data content record is a task associated with a TeamXpress Workflow job, the user is 
prompted to start (or continue) the workflow when the newly created document is closed.

Displays categories in 

Selects File > New 
Data Record.

Open dialog box.

Displays data capture 
Enters and saves data in 
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Generating a Web File

The following diagram shows the actions that take place when you generate a new Web file by 
populating a presentation template with a previously captured data content record. Sections following 
the diagram explain each diagram step and component.

1. A content contributor clicks File > Generate Page or File >Preview/Generate Page With in the 
TeamXpress Templating GUI. 

2. The Preview/Generate Page dialog box displays. 

3. The content contributor locates the data content record in the left pane.

4. TeamXpress Templating determines which presentation templates are associated with the selected 
data type and displays the list of the appropriate presentation templates in the right pane.

5. The content contributor selects a presentation template, clicks Generate, and provides a path and 
filename to save the generated page.

Reads file and displays

Selects File > Generate
Page.

list of presentation
Selects presentation
template and enters

Generates and saves
Web page.

Locates data content
record.

Optionally starts
Workflow job

Workflow

1
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Accessing TeamXpress Templating
6. TeamXpress Templating generates the Web page by populating the chosen presentation template 
with data from the chosen data content record. The Web page is saved and displayed in a browser.

7. If creating the generated Web file is a task associated with a TeamXpress Workflow job, the user is 
prompted to start (or continue) the workflow once the Web file is generated.

Accessing TeamXpress Templating

1. Log into TeamXpress.

2. Click the Workarea button and navigate to your workarea using the Navigation Window (the left 
pane on your screen).

3. After navigating to your workarea, you may want to select Edit > Set Home Page to set 
TeamXpress to automatically go to this workarea every time you log in.
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Entering Data

To create a new data content record:

1. In the TeamXpress GUI, select File > New Data Record. 

2. A New Data Content Record dialog box appears. Select the category of data and the data type you 
want to enter; click Select.

Note: The data types listed are the ones that are specified in the templating.cfg file and that 
exist as directories under the templatedata directory in your workarea.

New Data Content Record Dialog Box
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Entering Data
3. The data capture form displays.

The Data Capture Form Window with the Press Release

Menu bar

Tool bar: Save Open Cut Copy Paste Bold Italics Underline Hyperlink

Compound
elements

Special
format

Required
fields
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You may use the Cut, Copy, and Paste commands in the Edit menu or on the tool bar to cut or 
copy information to the clipboard. You can paste it in another field or into another application. You 
may also copy information from another source and paste it into a data content record. Many of the 
menu items have keyboard shortcuts; press the Alt key, then the underlined letters. For example, 
Alt+F+O is equivalent to File > Open and displays the Open File dialog box.

The fields that display in red are required fields. If a field, such as a date, requires a specific format, 
that format may be shown above the field (for example, the date format shown above the Publish 
Date field). If you enter invalid data in a field with a specific format, the entry turns red and a tool 
tip also displays to indicate the error. You cannot save a data content record until all required fields 
contain valid data.

Some fields have an expand/collapse button in the upper left corner. These fields can be expanded 
to show the entire contents or collapsed to show only the field label. These areas are referred to as 
compound elements. The fields within a compound element can be duplicated or deleted. Fields 
can also be reordered by dragging (see page 156).

Some fields may have a Browse button next to them. Use this button to locate a file. Click the 
Browse button; the Select File dialog box displays. The directory that displays was set up in the 
datacapture.cfg file that defines the data capture form. Navigate to the file you want to use. If 
the selected file is a .gif or .jpg file, a thumbnail of the file displays in the Select File dialog box. 
The path to the file displays in the field in the data capture form. 

4. When you finish entering data, save the form by selecting File > Save or File > Save As (refer to 
page 158).

5. To preview your data with a presentation template or to generate an output file, select 
File > Generate/Preview With (refer to page 159 for details). 
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Entering Data
Formatting Text

Text areas may have been set up by the template designer so you can mark text to be bold, italicized, 
or underlined. When a text area accepts these text types, the icons in the tool bar are active. 

Highlight the text and click on the appropriate button from the tool bar to format the text. You can 
also select these items from the Style menu.

You can also specify a hypertext link. Enter the text you want to use as the link. Highlight the text and 
click the Link button (or select Style > Link). A dialog box displays so you can enter the URL to link 
to. When you click OK, the text you highlighted displays as a hypertext link.

Example Showing Text Area Styles

Enter the hypertext 
link in the Link URL 
dialog box.

The typed paragraph shows text in bold, 
italics, and underlined styles.

The text showing the hypertext link. 

Enter the 
text for the 
hypertext link and 
highlight it.
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Working within Compound Elements

A compound element contains fields that can be duplicated within the data capture form. For 
example, if you are preparing a press release, you would probably need to duplicate the Subheading 
and Paragraph fields. You can add additional compound elements or fields within the compound 
element. You can also reorder the fields within a compound element. The Edit menu is used within 
compound elements to insert and delete fields. A right-click menu from within compound elements 
also accesses these commands.

Compound Element in Data Capture Form

Story compound element with 
two subheadings and 
paragraphs added to original 
subheading and paragraph

Second paragraph 
added to first 
subheading

Second and third 
subheading and 
paragraph positions 
swapped by 
dragging

Paragraphs under 
Second subheading 
collapsed by 
clicking on the – 

Right click menu

Outline around 
selected compound 
element
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To add additional compound elements:

1. Click to select the compound element to be duplicated. Because there may be compound elements 
within compound elements, be sure you have the correct one selected. You may find it helpful to 
click near the field name.

2. Select Edit > Insert Above to add a compound element above the highlighted one. Select Edit > 
Insert Below to add a compound element below the highlighted one. You can alternately select 
Insert Above or Insert Below from the menu displayed by clicking the right mouse button within 
a compound element.

The number of compound elements that can be added and/or deleted is specified in the data capture 
template. If you cannot insert or delete any more items, the menu items will be grayed out.

You can reorder fields within a compound element. To reorder compound elements:

1. Click to select the compound element to be moved. 

2. Drag the selected compound element to the new position.

To delete compound elements:

1. Click to select the compound element to be deleted.

2. Select Edit > Delete (or select Delete from the menu displayed by clicking the right mouse 
button) to remove the compound element.
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Saving Data Content Records

If you select File > Save As or if you select File > Save for a data content record that has not yet been 
saved, the Save File dialog box displays. Enter a file name and click Save. Once a data content record is 
saved, its name displays in the banner at the top of the data capture form.

Save File Dialog Box

The Save File dialog box and, similarly, the Open File dialog box provide several features.

• You can change information in the dialog box using the icons in the upper right corner of the dialog 
box to:

–  Move up one level in the directory structure.

–  Create a new directory.

–  Display only the names of files.

–  Display the name, size, type, and date modified for files.

• You can rename a file by highlighting a file and typing in a new name in the Name column.

• You can delete an existing file by highlighting the name and pressing the Delete key.

You may delete data content records in the Open File, Save File, and Generate/Preview File dialog 
boxes. Select the data content record, and press the Delete key (on Sun and PC keyboards). If you 
have a standard MacIntosh keyboard, this feature is not available.
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Previewing and Generating Output
Previewing and Generating Output

You can preview how your data will look in a browser with a particular template. If you have not saved 
the data record, you will be prompted to do so before the file is previewed or generated.

To preview the data content record:

1. From the data capture form, select File > Generate/Preview Page With; the Generate/Preview 
File dialog box displays. 

2. In the left pane of the Generate/Preview File dialog box, highlight the data content record to be 
used to generate the Web page.

3. The right pane of the Generate/Preview dialog box shows the presentation templates (file.tpl) 
that may be used with the selected data content record; highlight the presentation template you 
want to use.

4. To display the output in a browser window, click Preview. Your data, combined with the selected 
template, displays. When you finish previewing, close the browser window.

To generate an output file:

1. Repeat steps 1 through 3, above.

2. To generate and save the output file, click Generate. The Select Output File dialog box displays; 
enter the name of the generated file. The page appears in a file browser window (if it is not already 
displayed), and the generated file is saved in the specified location in your workarea.
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Generate/Preview File Dialog Box

Generating Web Pages

If you regenerate output files that already have a presentation template associated with them, you are 
not prompted to select a presentation template. 

To generate a Web page: 

1. From the data capture form, select File > Generate Page; the Select Output File dialog box 
displays; enter the name of the generated file.

2. The page appears in a browser window, and the generated file is saved in the specified location in 
your workarea.
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Changing Templates
If you select the File > Generate Page command and you have not selected a presentation template, 
the Generate/Preview dialog box displays so you can select the data content record and presentation 
template (refer to page 159). 

To generate a file using a different presentation template, use the File > Generate/Preview With 
command.

Changing Templates

You can generate Web pages using any possible combination of data content records and presentation 
templates that are configured for their data type. If you want to change a template after generating an 
output file, generate a new output file with the presentation template you want to use and optionally 
delete the old output file.

Editing Data

You can access data content records for editing from either the TeamXpress Templating GUI or from 
the TeamXpress GUI.

To edit an existing data content record from the TeamXpress Templating GUI:

1. With a data capture record open, select File > Open.

2. In the Open File dialog box, navigate to the data content record you want to edit; click Open.

3. The data capture form appears, containing the existing data. Edit this data as described in “Entering 
Data” on page 152. Then save and preview or generate the output.

You can have multiple data content records open for creation or editing.
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Initiating Workflows

When workflows have been configured and the data content record is part of a workflow, you can 
initiate the workflow through TeamXpress Templating. When you save and close a data content record 
or generate an output file, you are asked whether you want to start a workflow. If you start a 
workflow, you are asked to select a workflow. Normally you would start a workflow when you had a 
task create a data content record or generate an output file.

Using Templating from the TeamXpress GUI

In addition to the File > New Data Record menu item that you use to begin create data content 
records, a number of other commands available from the TeamXpress GUI provide access to 
TeamXpress Templating data content records.

Viewing Data Content Records

To view an existing data content record from the TeamXpress GUI:

1. Navigate to the data content record you want to view. 

2. Turn on the checkbox next to the name of the data content record you want to delete.

3. Click View File.

The data content record is opened in read-only mode and File > Save from the Templating GUI is 
disabled. File > Save As is enabled so you can save the data content record under a new name and 
then modify it to create a different record.
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Editing Data Content Records

To edit an existing data content record from the TeamXpress GUI:

1. Select Edit > Edit Data Record or click the Edit button.

2. In the Open File dialog box, navigate to the data content record you want to edit; click Open.

3. The data capture form appears, containing the existing data.

Alternately, you can navigate through the directories in TeamXpress to the appropriate data content 
record in the data subdirectory. Select the checkbox next to the name of the data content record you 
want to edit. Select Edit > Edit Data Record or click the Edit File button and the selected data 
content record displays.

Deleting Data Content Records

To delete a data content record from the TeamXpress GUI:

1. Navigate to the data content record you want to delete. 

2. Turn on the check box next to the name of the data content record.

3. Select File > Delete or press the Delete key on the keyboard.

4. A confirmation window appears. Click OK.

Generating Web Pages

When generating Web pages, first make sure that no items are selected in the TeamXpress GUI. To 
generate a Web page, from the TeamXpress GUI, select File > Generate HTML. The Generate/
Preview File dialog box displays. Following the instructions provided in “Previewing and Generating 
Output” on page 159.
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Regenerating Web Pages

If the data content record or the presentation template used for a Web page has changed, you need to 
regenerate the Web page. 

1. From the TeamXpress GUI, select the output file or files that you want to regenerate by clicking on 
the checkbox next to the filename, and select File > Regenerate HTML. 

The selected files that were generated by TeamXpress Templating are regenerated. Regenerating a 
file does not instantiate a new workflow job or add the file to an existing workflow task.

2. A success message appears. Click OK.

Note: The Refresh button in the TeamXpress GUI and the Refresh button in the Smart Context 
Editing tab have different functions than File > Regenerate HTML; they simply refresh or 
redisplay the current window.

Searching Data Records 

Data Record Search is available from the TeamXpress GUI when you have TeamXpress Templating and 
DataDeploy Database Auto Synchronization installed and configured to submit data content records to 
a database.

You can search for data content records based on the data entered for them. For example, the form 
for creating a new press release data content record contains such entry fields as Publish Date, 
Headline, Secondary Headline, Author, Email, and Language. If you choose to search among the press 
release data types for a particular data record, your search form will display these fields.

A Data Record search must be conducted within a workarea. You can initiate the search from 
anywhere within the workarea. The search is performed on data content records in the entire area and 
all subareas from which it was executed. For example, if you execute a search from 
\default\main\www\WORKAREA\w1\templatedata\internet, all files in internet and its 
subdirectories are searched. If you execute a search from \default\main\www\
WORKAREA\w1\templatedata\internet\pr, all files in pr and its subdirectories are searched.
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To search Data Content Records through the TeamXpress GUI:

1. Navigate to the workarea where you want to search. Note that the place within the workarea is 
irrelevant; the search continues through the category you choose regardless of where in the 
workarea you initiate the search.

2. Select View > Search Data Records.

3. In the Data Record Search window, select the data category and type.

4. Click Continue.

The Data Record Search window appears in a new browser window. Notice that category name, 
data type, and workarea path name are displayed under the form’s title.

TeamXpress Data Record Search Window
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5. Decide whether you want your search to match all of the items you set or any of the items.

6. Set the criteria for your search. You may set just one or several search criteria. Focus your search 
by selecting operators from the drop-down menus (refer to “Search Criteria”) and then providing 
or selecting values.

7. After you set your criteria, click Search.

The results display in the right frame of the main TeamXpress GUI. The results display in order by file 
name. Regardless of where you initiate your search, the relative path from the templatedata 
directory to the file is included in the file name. For example, a search that retrieves a file named 
June_11 in the pr directory in the internet directory under the templatedata directory in a 
workarea displays the file as /templatedata/internet/pr/data/June_11.

Search Criteria

The following guidelines apply to data content record searches:

• The default is that records must match all of the criteria you specify. You may change the selection 
so that a record matches any of the specified criteria.

• Text fields are case-sensitive.

• Dates must be entered in YYYY-MM-DD format with dashes between year, month, and day. 

• The pull-down for date fields allows you to select any of the following:

–  Equals
–  Does not equal
–  Between
–  Not between
–  Greater than
–  Greater or equal
–  Less than
–  Less or equal

When you use the Between or Not Between operators for a numerical range, such as a date, you 
must enter a starting value in the first field and an ending value in the second. When you use 
operators other than Between/Not Between, you need only enter a value in the first field.
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• The pull-down for text fields such as titles, descriptions, sources, and keywords allows you to 
select from the following:

–  Exactly matches
–  Does not match
–  Begins with
–  Ends with
–  Contains
–  Does not contain

• The pull-down for fields with selected choices (such as radio buttons) allows you to select from the 
following:

–  Matches any
–  Matches all
–  Does not match
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Appendix A

TeamXpress Icon Reference
TeamXpress Areas

Branch

Workarea

Staging Area

Edition

Files and Directories in TeamXpress

File

Directory

 Deleted File or Directory

Modified File

Locked File (locked by you) (see page 97)

Modified Locked File

Locked File (not available to you) (see 
page 97)

Modified Locked File

Private File (see page 103)

Private Directory (see page 103)
169



TeamXpress Icon Reference
170 TeamXpress User’s Guide



Appendix B

Internationalization
This appendix contains the following information:

• An overview of TeamXpress multibyte character support.

• General recommendations and information regarding specifying the encoding of web assets and the 
browser behavior when interpreting encoding.

• Information regarding multibyte support for TeamXpress Templating, DataDeploy, and 
OpenDeploy.

Overview

End users can input data into TeamXpress in any of four languages.

TeamXpress GUI elements, such as buttons and drop down menus, retain English names but may look 
slightly different because all HTML pages of our browser-based GUI are now UTF-8 encoded, even 
for US English installations. Your client browsers may therefore choose different fonts to render 
UTF-8 HTML pages.

TeamXpress supports the following four languages:

• US English

• Japanese

• Traditional Chinese

• Simplified Chinese

Note that TeamXpress users can interact with the GUI using any one of the supported four languages, 
but the TeamXpress server must use an US English operating system. All TeamXpress configuration 
files (including workflow templates) must be ASCII. TeamXpress does not currently support non-
ASCII characters in branch, area, directory, or file names.
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About UTF-8

UTF-8 is the encoding for Unicode. Unicode is a system for exchanging, processing, and displaying 
diverse written languages. Unicode supports the principal written languages of the world as well as 
many classical languages.

Recommendations

It is strongly recommends that all pages specify their encoding. This can be done by using the 
charset parameter within the META tag:

<META HTTP-EQUIV="Content-type" CONTENT="text/html; charset=UTF-8">

Specify the encoding of your Web content so that browsers may display this content consistently 
without error. When passed content that is not specified, browsers rely on default settings to 
interpret content encoding; if the default does not match the passed content’s encoding, the browser 
may display nonsense.

When Using Notepad and Wordpad

Notepad on Windows 2000 defaults to ANSI when a file is saved; Wordpad defaults to Rich Text 
Format (RTF). When using Notepad, select File> Save As, then select UTF-8 in the Encoding drop 
down menu. When using Wordpad, select File> Save As,, then select Unicode Text Document in 
the Save as type drop down menu.

Wordpad on both the Traditional and Simplified Chinese versions of Windows NT 4.0 can neither 
save nor render text as UTF-8.

In Notepad, you can begin the first line of text with a š character. In Wordpad, do not begin the first 
line of text with š.

Behavior of Netscape Navigator 

Once Netscape finds a UTF-8 page, it uses UTF-8 as its default encoding for pages that do not specify 
their encoding. This may cause the browser to display pages incorrectly if you browses pages that do 
not specify their encoding, or create pages without specifying the encoding.
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Scenario 1

1. A Japanese user goes to a Japanese site which does not specify its encoding. Netscape defaults to 
‘Japanese (Auto-Detect).’

2. The Japanese user logs into TeamXpress (UTF-8 pages). Netscape switches to UTF-8.

3. The Japanese user opens a new window and returns to the Japanese site which does not specify its 
encoding. Now Netscape defaults to UTF-8.

4. This would not happen if the site specified the encoding of its Web pages.

Scenario 2

1. A Japanese user logs into TeamXpress (UTF-8 pages). Netscape switches to UTF-8.

2. The Japanese user’s content in TeamXpress does not include the ‘Content-type’ META tag.

3. Upon entering SmartContext QA, Netscape tries to render the content as UTF-8, which is proba-
bly wrong. The solution to this problem is to always specify the encoding for all HTML content.

Summary
When trying to read Web pages without an explicit declaration of encoding, all browsers rely on 
default settings to “guess” the encoding of the page. The default setting is established differently in 
Internet Explorer than in Netscape Navigator. If the browser’s default setting is different than that of 
the actual encoding of the page passed to the browser, the browser may render the page incorrectly. 
Therefore, your Web pages should always declare their encoding. Not only will this prevent Netscape 
from guessing incorrectly when you use TeamXpress, but it will also ensure that your Web site 
viewers’ browsers will not have to guess which encoding they should use. 

Multiple Languages, One Web Site

TeamXpress allows contributors to use any or all of the four supported languages in its GUI. However, 
users who want to see multi-language content must have browsers capable of doing this. For example:

1. In TeamXpress, a Japanese user enters some submit comments in Japanese.

2. If an American user wants to view the version history, then the American user’s browser must be 
capable of correctly displaying Japanese characters.
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Glossary
Administrator
The owner of a branch, responsible for the project being developed on it. An Administrator can 
perform all the functions that an Author or an Editor can, and can also create and delete new sub-
branches and workareas on his branch. Administrators exercise control over workflow by giving 
workareas to editors and sub-branches to other administrators.

Advanced File Merging
TeamXpress can automatically merge two separately modified versions of a file, producing a new file 
containing the changes made by both users. Advanced File Merging is completely automatic if the 
edits were made to different parts of the file (non-conflicting edits).

Author 
A primary Web content contributor with limited access to the TeamXpress system. Authors can 
access, create, and modify Web content through their Editors’ workareas. An Editor can assign 
specific files to an Author, which will appear in the Author’s To Do list.

Autoprivate
The Autoprivate feature helps minimize clutter on the development server. Autoprivate 
automatically identifies file types that should not be submitted to the staging area and marks them as 
Private. These files typically include Macintosh resource forks (.FRK), Microsoft temporary files 
(.TMP) and various backup files (.BAK).

branch

A path of development for a body of content developed and maintained by a team. Each branch 
contains one or more workareas, a staging area, and a published edition and may contain sub-branches 

and previous editions. Branches are depicted in TeamXpress with the  icon. Workareas cannot be 
created under the main branch.
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comment
A note attached to a file, directory, workarea, branch, edition, job, or task. Comments can be 
attached to workareas, branches and editions when they are created. Comments can be attached to 
files and directories when they are assigned, returned, rejected, locked or submitted. Global 
comments can be set when these functions involve multiple files.

Compare
A function that displays a list of the differences between any two TeamXpress objects. Objects that 
can be compared include workareas, staging areas, or editions. 

conflict
Occurs when multiple users make changes to the same file in multiple locations, e.g. when a file has 
been changed in two different workareas.

conflicting edits
Occur when multiple users make changes to the same parts of the same file, producing two versions 
of the file that cannot be automatically merged. Conflicting edits require users to specify which 
individual changes will go into the merged version.

contributor
Any user of TeamXpress that modifies or creates content for the Web site. “Contributor” is a generic 
term that does not designate any specific TeamXpress role (e.g. Author, Editor, Administrator, or 
Master).

edition
A frozen, read-only snapshot of a branch of development. An edition contains a copy of all the files in 
the staging area at the time it was published. New editions can be released to production servers as 
complete, functional Web sites. Editions also serve as rollback points for projects in development, 
and they provide permanent archives of the Web site for Site Rollback. Editions are depicted in 

TeamXpress with the  icon. Editions that have been compressed to save disk space are depicted 

with the  icon.
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Editor
The owner of a workarea or workareas. Editors assign files to Authors, manage files, and edit and 
create files, submit content to the staging area, and may publish editions. Editors may have access to 
workareas that they do not own, but they cannot assign files in these workareas.

history
A complete record of all changes that have been made to a file through time. A user can see the 
complete history of a file by selecting it and selecting History from the View menu.

Home page
A user’s overview of the TeamXpress system. By default, an Author’s Home page will display his 
Task list. An Editor’s or Administrator’s Home page will display an overview of the TeamXpress 
system. The Home page can be set to any directory where the user has access.

initial edition
The first edition on a newly created branch. The initial edition serves as the original source of content 
for all workareas on a new branch. This edition may be empty, or it may be a copy of an edition from 
another branch.

job
A set of interdependent tasks. Each job is a specific instance of a workflow model. 

locking
Restricting file access within a branch. Locking a file reduces the possibility of conflicting edits but 
also reduces the team’s ability to work on files simultaneously. Every time a file is locked, the version 
in the workarea is compared with the version in the staging area and the latest is taken (although this 
behavior can be overridden). TeamXpress supports three types of locking, or locking models: Submit 
Locking, Optional Write Locking, and Mandatory Write locking. The locking model is defined at the 
branch level by the Administrator.

main branch
The first branch created when TeamXpress is installed. The Main Branch is owned by the Master 
user. All branches in the TeamXpress system are subordinate to the main branch.
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Mandatory Write locking
A type of locking where users are required to lock a file in order to edit it. Until a user locks a file, 
all files in his workarea are read-only. Taking the write lock allows only a single person to modify the 
file at a given time, ensuring serial development and eliminating conflicting edits.

Master
The owner of the main branch. The Master user is responsible for the entire Web site. The Master 
organizes the structure of the TeamXpress system and coordinates the activities of all users, and can 
also perform all functions on all branches.

merge
The process of reconciling conflicts between versions of a file that have been edited by two people. 
The two versions can be merged in the staging area to produce a new version of the file, 
incorporating changes made by both users. Merging can be automated with TeamXpress’s Advanced 
File Merging.

Navigation Window
The left-hand side of the TeamXpress window, which allows you to navigate through TeamXpress by 
clicking on the underlined names of branches, workareas, staging areas, editions, or directories.

Optional Write Locking
A type of locking in which users can choose to lock a file to ensure no other users edit the file, even 
within their own workareas. When a user locks a file, it becomes read-only to all other users. Under 
the Optional Write Lock model, locking files ensures serial development of those files and reduces 
the risk of conflicting edits

Private
Within a workarea, a user can mark a file as Private, which prevents the file from being submitted to 
the staging area if the file is a part of a workarea or directory that is submitted. It also prevents the 
file from being copied to another workarea during a Copy To operation.

Public
The opposite of Private, the Public function removes the private marking on a file. All files are public 
by default.
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publish
To create a new edition based on the current staging area.

Site Rollback
The process of deploying a previous edition in place of the current Web site. Because TeamXpress 
editions are complete copies of the entire Web site at the time of publication, they can be referenced 
to revert to prior versions of files, directories, or the entire Web site.

SmartContext™ QA
The use of individual workareas and staging areas to allow users to test their work in the context of 
the entire Web site without actually deploying the Web site. This allows Authors, Editors and 
Administrators to catch and fix their own mistakes at an early stage.

SmartContext™ Editing
The ability to edit a file while browsing the Web site. This provides a simple, intuitive way of finding 
the file you want to edit, editing it in context and see your changes immediately.

staging area
The area where users integrate the contents of their workareas. Users submit read-only copies of files 
from their workareas to the staging area to integrate with other contributions, and test the integrity 

of the resulting Web site. Staging areas are depicted in TeamXpress with the  icon.

sub-branch
A branch subordinate to a major branch. To separate development efforts among teams or team 
members, an Administrator can create sub-branches. The sub-branch receives its own unique staging 
area and workareas and generates its own editions. Editions published on a sub-branch can be 
integrated back into work on the higher branch, or released as stand-alone Web sites.

submit
The act of transferring Web site content from a workarea to the staging area.
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Submit Locking
A type of locking in which users can choose to lock a file to insure that their changes will be 
submitted to the staging area. While a file is locked, other users can edit their own version of the 
locked file within their workarea, but they cannot submit to the staging area. Once the lock holder 
has released the file lock, other users can merge their modifications with the new file version.

task
A unit of work performed by a single user or process. Each task in a job is associated with a particular 
TeamXpress workarea and carries a set of files with it. 

task transition
Selecting a task transition moves the job along the workflow process by activating successor task(s). 

TeamXpress templating
A TeamXpress module that allows you to configure the look and feel of your Web pages. For more 
information, consult Using and Configuring TeamXpress Templating.

template
A file that specifies attributes of another file, such as look and feel. When you create a file, you can 
choose to base that file on a template.

To Do list
A user’s initial view of the TeamXpress system. The To Do list shows the user which tasks and jobs 
he is responsible for, and allows the user to do the necessary work to complete the tasks.

unlock
To remove a lock from a file. If an Editor has locked a file, the branch Administrator or Master user 
can also remove the lock. The Master user can remove any lock from any file.

user
A TeamXpress Author, Editor, Administrator, or Master.
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Web site
A generic term, meaning a set of interrelated files viewed through a browser. In TeamXpress, the 
term “Web site” generally refers to all the contents on a branch of development, though these may be 
a superset or a subset of an organization’s actual Web site.

workarea
A virtual copy of a Web site, which may be worked on independently without affecting the actual site 
or the work of other contributors. A workarea can be owned by a single user or a number of users 
together. Editors and Administrators can own workareas, but Authors cannot. Workareas are 

depicted in TeamXpress with the  icon. Workareas cannot be created under the main branch.

workflow
A system for defining the necessary processes for content creation and approval. See also “workflow 
model,” “job,” and “task.”

workflow model
A general workflow configuration that can be used repeatedly. Each workflow model describes a 
process which may include user tasks and a wide variety of automated tasks.

Work Window
The right-hand side of the TeamXpress screen, which allows you both to navigate through 
TeamXpress and to manipulate files.
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Index

A
adding comments to tasks 113, 

119
adding file types

Macintosh 30
UNIX 32
Windows 26

adding files to tasks 116, 117
Administrators

defined 12, 175
special abilities of 129–136

aliases
creating 49

approving files in tasks 120
Authors

and approval processes 12
defined 12, 175

Autoprivate 104
defined 175

B
branches

creating 130
defined 10, 175
deleting 133
groups for sharing 130
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in the graphical user 

interface 15
locking models on 96
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and frames 63
of files 63

browsers
available features 16
choosing 16
configuring (Macintosh) 21, 22
troubleshooting 

(Macintosh) 23
Button Bar 39, 43

Administrator’s 129

C
category 147
changes

viewing 57
charset parameter

specifying web content 
encoding 172

choosing browsers 16
comments

adding to tasks 113, 119
defined 176
lock 97
publish 72
submit

individual file 65, 67
keywords 65, 67
submit operation 65, 67
common ancestors 89
comparing

defined 176
file properties 84, 123
file versions 101
files 79–87

and copying 87
merging 87
overview 79
source differencing 86
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to the staging area 81
viewing results 80, 81, 82, 

96
visual differencing 85

tasks, to the staging area 122
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completing tasks 120
compressing editions 133
configuring

file types 18
conflicting edits 96, 97

defined 176
merging 93

conflicts
and updating your workarea 70
defined 176
merging 87
submitting 68
task 121
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viewing 81
content

creating 149
creating records 145

contributors
defined 176

cookies 18
copying files

cancelling 76
over newer versions 78
to areas 76–79
to other directories 62
versions 87
while comparing 87

creating
branches 130
directories 53
files 51
jobs 125
workareas 131

custom reports 134

D
data capture record

previewing 154
data capture subsystem 145
data capture template 145
data category 145, 147
data content record 146, 154

creating 149, 152
data type 145, 147
deleted

directories 82
icons 169

files 82
icons 82, 105, 169
restoring 79

deleting
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directories, from a 

workarea 54
editions 133
files

from a workarea 54
from the staging area 105
temporary, from your lo-

cal hard drive 38
workareas 133

Direct Edit 32, 58
configuring

UNIX 34
Windows 32

directories
deleted 82
deleting 54

from the staging area 105
icons 169
new 49, 53
restrictions on names 53
submitting 69

directory structure
contents 147
sample 147

E
editing

and locking files 96
file types

Macintosh 31
UNIX 32
Windows 28

files 54
in tasks 113
on the server see Direct 

Edit
on your computer see Re-

mote Edit
through SmartContext 
Editing 54

through the main GUI 58
with different editing 

applications 36
tasks 115

editions
compressed

icons 11
compressing 133
defined 11, 176
deleting 133

and Submit logs 133
differences between 72
icons 11, 169
initial 130
uncompressing 133

Editors
defined 12, 177

encoding
charset parameter 172
META tag 172
specifying 172
Unicode 172
UTF-8 172

event conditions, in reports 135
example templating 

environment 147

F
file names

restrictions on 52, 61
file properties

about 75
comparing 84, 123
metadata 76
viewing 73

file system interface 47
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accessing 47
Macintosh 48
UNIX 49
Windows 47

navigating 49
structure 49

file types
about 18

Macintosh 29
UNIX 32
Windows 25

adding
Macintosh 30
UNIX 32
Windows 26

editing
Macintosh 31
UNIX 32
Windows 28

files
comparing 79–87
conflicting

merging 87
submitting 68

copying 62
over newer versions 78

copying to areas 76–79
cancelling 76

deleted 82
icons 82, 105, 169
restoring 79

deleting 54
from the staging area 105

editing 49, 54
in tasks 113
on the server see Direct 

Edit
on your computer see Re-

mote Edit
through SmartContext 
Editing 54

using different editing 
applications 36

histories 99
defined 177

icons 82, 169
importing 60

and overwriting 60
Macintosh 60
overwriting 61
Windows 60

listing modified 94–95
multiple workareas 94
on a branch 94

locking 95, 96–99
merging 87

and Submit locking 96
and Write locking 97

metadata capture 105
metadata search 108
moving 62

and version histories 62
multibyte content 172
new 49, 51
permissions 51
previous versions 99
renaming 49, 61

and version histories 61
restoring deleted 79
source differencing 86
submitting 64, 95

directly 65
through SmartContext 

Editing 64
through the graphical user 

interface 64
through workflow 67

temporary 36
unlocking 97
uploading 36, 37
viewing 63

in browsers 63
locked 63
source 63

G
generated HTML files 145, 150, 

160, 163
generating data 154
Get Latest command 70
Global Reports Center 134

custom reports 134
quick reports 134

graphical user interface
about 38
available functions 15
branch view 41
Navigation Window 41
Work Window 41
workflow view 40

groups for sharing
branches 130
workareas 132

H
histories

defined 177
file 99

Home page
defined 177
resetting to default 42
setting 42

HTML pages
generating 150, 160, 163
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I
icons 169

branch 10, 169
compressed edition 11
deleted file 105
deleted file or directory 169
deleted files or directories 82, 

105
directory 169
edition 11, 169
file 82, 169
in LaunchPad 37
key 98, 169
lock 98, 169
modified file 61, 62, 63, 77, 82, 

169
modified key 98, 169
modified lock 98, 169
private directory 104, 169
private file 104, 169
staging area 11, 169
workarea 11, 169

importing files 60
Macintosh 60
overwriting 60, 61
Windows 60

in-context QA
see SmartContext QA

initial edition 130
defined 177

installing
Merge 88

installing LaunchPad
Macintosh 19
UNIX 24
Windows 17, 19

internationalization
browser behavior 172
186
languages supported 171
recommendations 172
Unicode 172
using Notepad and 

Wordpad 172
UTF-8 172

J
jobs

creating 125
defined 14, 177
details 127
managing 125
templates 126
viewing 111, 125, 127

K
key icons 98, 169

L
languages

browser behavior when 
interpreting web content 
encoding 172

support for 171
LaunchPad

about 18
and editing files 54
and SmartContext Editing 46
configuring

Macintosh 29
UNIX 32
Windows 25

Direct Edit 32
file icons in 37
installing

Macintosh 19
UNIX 24
Windows 17, 19
preferences 36
Remote Edit 34
troubleshooting

autoinstallation 
(Windows) 19

Macintosh 23
window 37

listing
locks 98
modified files 94–95

multiple workareas 94
on a branch 94

locked files
icons 98, 169
submitting 65, 67
viewing 63

locking
defined 177
files 95, 96–99
in workareas 96
Optional Write 97
setting, on a branch 130
Submit 96
types of 96
Write 97

locks
listing 98
viewing 98

logging in 17
logging out of TeamXPress 38
logs

Submit 69, 72
Update 70, 77

M
main branch

defined 177
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managing workflow
jobs 125
tasks 111

Mandatory Write locking
defined 178

Master users
defined 13, 178

Menu Bar 39, 43
Administrator’s 129

merging files
about 87, 89
and Submit locking 96
and viewing differences 91
and Write locking 97
conflicting edits 93
defined 178
installing the merge tool 88
task files 124

META tag
specifying web asset 

encoding 172
metadata

about 105
command-line tool 105
entering

file view 107
rules view 106

search 108
viewing, in file properties 76

minimizing
SmartContext Editing tab 45

modification history 99
modified files

icons 61, 62, 63, 77, 82, 169
viewing 94

modified key icons 98, 169
modified lock icons 98, 169
moving files 62
and version histories 62
multibyte characters

browser behavior when 
interpreting web content 
encoding 172

languages supported 171

N
Navigation Window 41

defined 39, 178
using 41

new
branches 130
directories 49, 53
files 49, 51, 96
jobs 125
workareas 131

notation conventions
defined 7

Notepad
saving documents as UTF-

8 172

O
older versions

reverting to 102
viewing 100

opening files
for editing 54
for viewing 63

Optional Write locking 97
defined 178

overwriting
and comparing files 87
and copying files 78
and getting latest versions 70
and importing files 60, 61
and locking files 99
and submitting files 65
workflow 67

copying over newer files 79

P
page generation subsystem 145, 

150
performing tasks 113
platforms

server 7
presentation template

definition 146
selecting for preview 159

previewing data 154, 159
private

defined 178
directories 103

icons 104, 169
files 103

icons 104, 169
submitting 103

see also Autoprivate
public

defined 178
directories 104
files 104

publishing 12, 72
and differences between 

editions 72
defined 179

Q
quick reports 134

R
refreshing your view 57
Remote Edit 34, 58, 59

configuring
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Macintosh 34
UNIX 35
Windows 34

using 35
removing files from tasks 118
renaming files 61

and version histories 61
repeating fields 154
reports

event conditions 135
viewing 134

custom 134
quick 134

resolving conflicts
task 121

restoring deleted files 79
retrieving tasks 121
reverting

modified files 102
to older versions

of files 102
revision ID 100

S
search metadata 108
server platforms, discussed 7
setting up

LaunchPad 18
shortcuts

creating 49
Site Rollback

defined 179
SmartContext Editing

activating 43, 45
advanced features 45
and LaunchPad 46
configuring 46
defined 179
188
editing files with 54
editing images with 55
features 45
file status 44
framesets 57
launch page 46
submitting files 64
synchronizing main window 47
tab

Color Bar 44
minimizing 45

tab defaults 46
task files 54

SmartContext QA 15
defined 179

sorting
in the graphical user 

interface 41
source differencing

file versions 101
files 86
tasks 124

source view
of files 63

staging area
and private files 103
defined 11, 179
icons 11, 169
updating your workarea 70

sub-branches 10
defined 10, 179

submit job
cancelling 67
holding 67
templates 64, 67

Submit locking 96
defined 180
submitting files 96
Submit logs 69, 72
and deleted branches 133
viewing 69

submitting
conflicting files 68
defined 179
directly to the staging area 65
directories 69
files 64, 95

through the graphical user 
interface 64

using SmartContext 
Editing 64

locked files 65, 67
private directories 104
private files 104
through a workflow process 67
under Submit locking 96
under Write locking 97
workareas 65, 67

T
taking ownership of tasks 121
tasks

adding comments 113, 119
adding existing files to 117
adding new files to 116
approval 120
comparing to the staging 

area 122
completing 120
defined 14, 180
editing 115
editing files 113
external 14
managing 111
merging files 124
performing 113
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removing files from 118
resolving conflicts 121
retrieving 121
source differencing 124
taking ownership of 121
transitions 111, 120

defined 180
user 14
viewing 111
visual differencing 123

TeamXpress structure, defined 8
templates

defined 180
selecting 52

temporary files 36
Remote Edit 34

To Do list 111
defined 180
viewing 111

Tool Bar
Administrator’s 129

Top View
resetting 42
setting 42

troubleshooting
creating new files 51
LaunchPad

Macintosh 23
type 147

U
uncompressing editions 133
Unicode 172
unlocking files 97
Update logs 70, 77

viewing 70
updating

workareas 70
see also Get Latest
uploading files 36, 37, 58, 59
users

defined 180
UTF-8 172

recommendations 172

V
version histories

viewing 99
version ID 100
version path 135
versions

comparing 101
source differencing 101
viewing older 100

viewing
changes 57
comparison results 81
file histories 99
file properties 73
files 63

in a browser 63
source 63

job details 127
jobs 125
locked files 63
locks 98
modified files 94
older versions 100
reports 134

custom 134
quick 134

submit logs 69
To Do lists 111
update logs 70
URLs 63
version histories 99
visual differencing
defined 85
files 85
SmartContext Editing 85
tasks 123

vpath 135

W
web browsers

behavior when interpreting 
web content encoding 172

web content
recommendation for specify 

the encoding of 172
specifying the encoding of 172

web page, generating 160
websites

and branches 10
Wordpad

saving documents as UTF-
8 172

Work Window 41
defined 181

workareas
creating 131
defined 10, 181
deleting 133
files in 70
groups for sharing 132
icons 11, 169
locking files in 96, 97
modified files in 94
owners 131
private 132
private files in 103
shared 132
submitting 64, 65, 67
submitting files from 65
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updating 70, 132
viewing 41
viewing locks in 98
viewing modified files 94

workflow
defined 181

workflow models
and jobs 14
defined 13, 181

workflow templates
choosing 126
defined 111

Write locking 97
submitting files 97
see also Optional Write 

locking, Mandatory Write 
locking
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