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Creating a Traffic Light in MicroC

Thistutorial walks through the process of creating MicroC code using | BM® Rational®

Statemate®. The example project isatraffic light with red, yellow, and green indicators. The
designissimple so you can fully concentrate on MicroC code generation, rather than on the design
problem itself.

Thistutoria contains the following topics:

¢ Tutorial Setup

¢ Exercise 1 - Constructing an Activity Chart

¢ Exercise 2 - Defining Textual Elements

¢ Exercise 3 - Defining Design Attributes

¢ Exercise 4 - Constructing Statecharts

¢ Exercise 5 - Constructing a Panel

¢ Exercise 6 - MicroC Code Generation

¢ Exercise 7 - Using the Test Driver
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Creating a Traffic Light in MicroC

Tutorial Setup

Prior to starting the exercises, you must set up your system and create a project within Rational
Statemate following these steps:

1. Create afolder/directory called “stm_projects’ on your system in which to store your
project data.

2. To begin to create a project prior to starting the lab exercises, start Rational Statemate.
a. From Windows select Sart > 1BM Rational > Rational Statemate <version>.

b. From UNIX select $STM ROOT/ r un_st nm bat .
The Rational Statemate Main windows opens.

3. Select File> New Project. The Create New Project window opens.

Create New Project

[ CreoteNewproject ]
Mams TREFFIC_LIGHT
Harager: |Ejlnh j
d H H ] ) ]
Databank: | Cihstm_projectshtraffic light, db s CIICkIng on the -+ Opens
an explorer window for

CH tools | STATEMATE j browsing.

RT project: }ﬁ The explorer window
might become minimized.

05 Implenentations |I’IF|INLIIIP_SC j
Description:

A Expand

[ L33 ! Cancel Help |

4. Enter the following datain the Create New Project window. See the figure.
Note: Blank spaces are not allowed within the form.

¢ Databank - <pat h>\st m projects\traffic_light.db
¢ Name- TRAFFI C LI GHT
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Tutorial Setup

¢ OSImplementation - MAI NLOOP_SC
Note: Leaveal other entries with their default value.

Click OK to create the project. The Open Project window opens.
Click OK to open the project.
Select the project that you just created, TRAFFIC _LIGHT.

© N o U

Create a Workarea for the project by typing <pat h>\ st m proj ects\traffic_|ight.wa
in the “Workarea:” field. See the figure.

Open Project Window

[ OpenProject
Projects Hiordaraas

CRLLE4942 Fal
CALLEBS11S
DH_MOTE _fALLOCATD
FIFD

GiREsGE _DO0R_EX
REAR_DEFDOC_JB J

TAIL_LIGHT

i)

|

Ii_fq Tl [

Warkarsa: | Ciszto_projectshtraffic_lightws

0K | Caiwal Help I

9. Click OK. A Question window displays asking if you want to create the Workarea.

10. Click Yes. The work area opens.
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Creating a Traffic Light in MicroC

Exercise 1 - Constructing an Activity Chart

In this exercise, the top-level system diagram for the traffic light system is developed, as shown in
the following figure.

activity Chart - TRAFFIC_LIGHT_SS

i AGE_4:TRAFFIC_LIGHT 55 [Update] - (o x|

File Edit View Lawowt Tools Dptions HMindow Help

IDEESER | 2R X B Q| #HEEgE

d

TRAFFIC LIGHT 5%

veelir.g=

Jeée 070

|
?@

|

TRAFFIC_LIGHT_CTRE 1 YELLOW_L IGHT

= |

-

To create the activity chart:

1. Click the Graphic Editorsiconin the Rational Statemate Main window.
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Exercise 1 - Constructing an Activity Chart

2. Create an activity chart called TRAFFIC_LIGHT _SS based on the selections shown in
thefigure.

Note: No spaces are alowed for chart names.
¢ Type- Activity Chart
¢ Usage- Regular
¢ Name Pattern - TRAFFIC_LIGHT_SS
Open/Create Chart

Opin Chiark

A TreererEn
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Creating a Traffic Light in MicroC

3. Click New to create and open a new diagram. See the figure. You can now edit the chart.

4. Click Create Internal Activity.

Draw the Internal Activity

To draw the internal activity, place the cursor at the upper-left corner of the diagram, click and
drag the cursor to the lower-right corner of the activity. A ghost image shows the activity outline.

Name the Activity

To name the internal activity you created:

1
2.

Click Name Existing Activity [HI.

Click inthe location where you want the Activity name or type the Activity name and then
place it where you want.

Note: Enter the names for objects using lowercase letters. Rational Statemate, where
appropriate, automatically performsthe conversion to uppercase letters. Do not
enter words in uppercase letters. Doing so might prevent you from making
further selections.

Typethenametraffic_light_ss. You can select the standard pointer % and click-and-
dragtraffic_light_ss toplaceit.

Click Create External Activity.

Draw the external activities for the TRAFFIC_LIGHT_SS. The same drawing rules apply
for drawing and naming external activities. Use the following figure as a guide.

MicroC Tutorial



Exercise 1 - Constructing an Activity Chart

Partial Chart Design

N — T

Go ahead,.. =

6. Click Create Data-Flow.

7. Draw aflow line from the external activity called 'INPUTS to the internal activity called
TRAFFIC_LIGHT_SS. Refer the following sections.
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Creating a Traffic Light in MicroC

Drawing Flow Lines

To draw flow linesfor the activities:

A 0w D P

L ocate the external activity called INPUTS. Thisisthe source activity.
Click on the edge of the box to enter the tail of the arrow.
Locate theinterna activity called TRAFFIC_LIGHT_SS. Thisisthe target activity.

Place the cursor on the edge of the box and click to enter the arrowhead.

Note

In order to create flow lines with angles, you can click at each location an angle is wanted
prior to clicking/rel easing the middle mouse button.

Labeling and Placing Flow Line Labels

To label and place the flow line labels:

1
2.

Click Label Existing Flow-Line 1.

Click on the flow line that you want to label and type the name change or type the name
change before clicking on the flow line and then place the label onto the flow line.

Click Pointer &, and move the label if you want.

Draw aflow line from theinternal activity called TRAFFIC_LIGHT_SSto the external
activity OUTPUT S and label the flow red_light.

Draw aflow line from the internal activity caled TRAFFIC_LIGHT_SSto the external
activity OUTPUT S and label the flow yellow_light.

Draw aflow line from theinterna activity called TRAFFIC_LIGHT_SSto the external
activity OUTPUT S and label the flow green_light.

Click Create Control Activity.

Draw and name the control activity, traffic_light_ctrl Use the same drawing techniques
to draw the other activities.

Select File > Save from the chart and then File > Exit.

MicroC Tutorial



Exercise 2 - Defining Textual Elements

Exercise 2 - Defining Textual Elements

This exercise describes how to define the textual elements that were entered into the activity chart
TRAFFIC_LIGHT_SS.

1. Fromthe Chart Tab, click onthechart caled TRAFFIC _LIGHT _SS. The element matrix
opensin the right pane. See the figure.
Element Matrix for Chart TRAFFIC_LIGHT_SS

i AGE_2:TRAFFIC_LIGHT S5 [Update] i =10} =i
Fila Edit “iew Lawout Tools Options  Hirdow  Help

[l

b TRAFFIC_LIGHT S8
B, 4 i
]

& @ Element Matrix

= L

-4
Hessages
Go ahead. ..

oLl |

2. Sdect the e ement called CHANGE from within the e ement matrix.

3. Select Edit > Properties. This invokes the Properties window for this element. See the
following figure.
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Creating a Traffic Light in MicroC

Note
Double-clicking on the element name also opens the properties window for this element.

Properties - CHANGE

CHANGE {Unresolved Element) x|
DB B X B Nl o 0 R m|
Hame: Defined In Def || Hode a
CHANGE TRAFFIC_LIGHT S5  Textual
=]
General Definition ]ﬂl‘l‘!"!?.hxi".'t' |Il-.-1.~'ec_z~. AR P bl [Ilsscr*iptim | R T R |
Tupe: Infornat ion-Flow — |
Conzists of
Insert |
Delete |

4. Define the textua element CHANGE using the following steps:
a. Changethe Type: of the element from Information Flow to Event. See the figure.
b. Click Save [
c. Exit
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Exercise 2 - Defining Textual Elements

Unresolved Element - CHANGE

CHANGE (Unresolved Elenent ) ZH |
| O Wy @] X B e T %50 | B | 2| s
HName Tatatiiem | Def ined In | Def || Hoda || =]
-l TREFFIC GHT_SS Textis Mo Updata
PORRAONNIN | (7 IC LIGHT S5 Tessual o Update
Condition =
—— 1 Event
Gemeral Defy |Besigm fetmibutes | Deseription | Impslemmitation |
Typ=:
St gl e }
Conelsts of
Inzert |
Delete ]

Type Men

5. Set the Type: to Condition for the other three elements (RED_LIGHT,
YELLOW_LIGHT, GREEN_LIGHT), and save the settings.

6. Open the external activities, INPUTS and OUTPUTS, and set the Type: to Environment.
a. Changethe Typefrom External to Environment
b. Click Save
c. Exit

Rational Statemate 11



Creating a Traffic Light in MicroC

Exercise 3 - Defining Design Attributes

In this exercise describes how to add design attributes to selected elements within the model.

1. Select the activity called TRAFFIC_LIGHT_SS from within the element matrix and

then select Edit > Properties. Thisinvokes the Properties window for this element. See
thefigure.

Note: Double-clicking on the element name also opens the properties window for this
element.

TRAFFIC_LIGHT_SS Properties

TRAFFIC_LIGHT_SS {Ackivity} e |
O & Wy ] > B afp %5 % 53 08| B 43 r% | e
Hame | Defired In | Def || Hade || =]
TROFFIC LIGHT 55 TRAFFIC_LIGHT 55  fictivity

General DeFinition Iﬁttrjhute-t IDa:ign Atkributes ID&mriptim |Inplzment-aunn |

Termination Tuyps: Reactive-Controlled — [

Conbs, As=ighment, . .

I= Bctivity: F: Inplenentsd by Hoduls: F:

2. Select the Design Attributes tab within the properties window.
a. Changethe Value of Typeto Task.
b. Click Save

c. Exit

3. Open the properties window for the element called CHANGE and select the Design
Attributestab.
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Exercise 3 - Defining Design Attributes

4. Select the Name Its Task and then click Choose to select the task for the event change.

a. The Choose window opens. Click Dismiss to close the window.

b. Click Save.
c. Exit.
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Creating a Traffic Light in MicroC

Exercise 4 - Constructing Statecharts

This exercise describes how to construct a statechart that d
traffic light system. See the figure.

emonstrates behavioral aspects of the

Statechart TRAFFIC_LIGHT_CTRL

i SGE_1:TRAFFIC_LIGHT_CTRL [Update]

=101 |
File Edit Mies Layout Tools Options Mindow Help
Copy {to Paste Buffer)| Paszte| Saus|
DS ES 6 R 0 |5 0@ X (DR Q| 5§D
=1 0
om
LA
=y L
- /' TRAFFFC_ETGHT_CTRE ™
& @
L JRED_LIGHT=true;
@ o mm_xmm’-:t’ﬁa:
& YELLOU_LIGHT=false;
[ RED_ETGHT 0N I CHRNOE/ ‘—'{ GREEN _EXGRT oK |
7 RED_LIGHT=fal=me;
GREEN_LIGHT-true; |
| YELLOW LIGHT=fnalme;
/
by j"
CHANGE/ /' CHANGE
RED_L IGHT=txume; S, IGHT H
LIGHT=false; - ~| YELLOW _ETGHT_ON |""" ﬁﬁl‘} le:'rf:';:z;c:
YELLOW _LIGHT=false: YELLOW_L IGHT=truve;
K
=] Ed
Heszages
2l
u
¥

1. Click Graphic Editor from the main Rational Statemate window.

14
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Exercise 4 - Constructing Statecharts

2. Namethe statechart TRAFFIC_LIGHT_CTRL based on the selectionsin the figure.
Note: No spaces are alowed for chart names.
¢ Type- Statechart
¢ Usage- Regular

¢ NamePattern - TRAFFIC LIGHT_CTRL
Open/Create Chart

Open Chark

3. Select New from the Open Chart window to create and open anew diagram. The chart is
now available for editing.

4. Click Create Sate.

Rational Statemate 15



Creating a Traffic Light in MicroC

5. Draw astate caled TRAFFIC_LIGHT_CTRL. Seethefigure Statechart
TRAFEIC_LIGHT_CTRL.

Drawing States

To draw states in the statechart, follow these steps, place the cursor in the upper-left corner of the
state and click and drag to the lower-right corner of the state. A ghost image shows the state
outline.

Naming States

To name the newly created states in the statechart:

1. Click the Create Sate or Name Existing State icon and begin typing the state name
traffic_light_ctrl. The name of the state displays next to the cursor.

2. Click where you want the state name to reside.

Note: Enter the names for boxes using lowercase letters. Rational Statemate, where
appropriate, automatically performs the conversion to uppercase letters. DO
NOT select the CAPS LOCK key before typing.

3. Using the Statechart TRAFFIC_LIGHT CTRL figure as a guideline, create and name the
other states within your chart.

4. Click Create Transition.

5. Draw atransition from the RED_STATE_ON state to the GREEN_STATE_ON state.

Drawing Transitions

To draw transitions in the statechart:

1. Locatethe state called RED_STATE_ON. Thisisthe source state. Click on the edge of
the box to enter the tail of the arrow.

2. Locatethe state called GREEN_STATE_ON. Thisisthetarget state. Click on the edge of
the box and click to enter the arrowhead.

3. With the Create Transition icon still selected, abel the transition:

CHANGE/RED_LIGHT=falsg;
GREEN_LIGHT=true;
YELLOW_LIGHT=false;'
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Exercise 4 - Constructing Statecharts

Labeling Transitions and Placing Labels

To label the transitions in the statechart:

1

a M w D

Click on the Create Transition tool or the Label Existing Transition tool f,, and type the
label name.

The label displays next to the cursor and follows the cursor.
Click on the transition line you want to label to place the label.
Select the Create Default Transition icon.

Draw a Default Transition into the state RED_STATE_ON. Default transitions do not
have a source state and cannot have triggers. Use the Statechart TRAFFIC_LIGHT_CTRL
figure as aguide as where to draw the default transition.

With the Create Default Transition icon still selected, type the following label for the
transition:

''RED_LIGHT=falsg;
GREEN_LIGHT=true;
YELLOW_LIGHT=false;'

Place the transition label on the transition if you have not already done so.

Using the techniques in the above steps compl ete the design of the statechart based on the
Statechart TRAFFIC_LIGHT_CTRL figure.

Select File > Save from the chart and then File > Exit.
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Creating a Traffic Light in MicroC

9. The statechartsthat were developed in this exerciseis used to describe the behavior for the
activity TRAFFIC_LIGHT _SS. To associate the statecharts with the activity complete

the following steps:
a. Open the activity chart called TRAFFIC_LIGHT_SS.

b. Maodify the name of the control activity by placing an @ symbol in front of the name
as shown in the figure.

c. Seect File> Save from the chart and then File > Exit.

Control Activity TRAFFIC_LIGHT_CTRL

B AGE_1:TRAFFIC_LIGHT 55 [Update] =10l =]
File Edit Wiew Lajout Tools Options Hirdow Help

IDSEHE &R v ol b Bl X|BEe e |## gl

> | 4

W

Wyl —

o TRAFFEC_LTGHT_§5*

on

e @

® @

& & il o L 1 | '1|

= . s RED_LTGHT !
' ' ETRAFFIC LIGHT CTRE 3 YFLLOU_L TEHT
e _ CHARMGE | — ———! GREEN_LIGHT

_________________

Heszzagas

S INE
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Exercise 5 - Constructing a Panel

Exercise 5 - Constructing a Panel

This exercise takes you through the process of constructing the panel as shown in the following

figure.

Traffic Light Panel

2 PGE_2: TRAFFIC_LIGHT_PNL [Update]

B[EX]

File Edit Wiew Layout Transform Group Tools Options  Window Help

Edit Text| Fort... | |

DEEE - =i =e X Byl

Fy

|

Rational Statemate
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Creating a Traffic Light in MicroC

Select Panel Editor from the main Rational Statemate window. The Open Panel window
opens.

Enter the name TRAFFIC_LIGHT_PNL for the Panel Name.

To begin the panel design, add a background to separate the input and output elements.
Select Create Filled Box from the Panel Graphic Editor and stretch thisto fill the panel
canvas.

Select the new Filled Box and select Tools >Properties. The Bindings/Properties
window opens.

Change the Line Width to 3.

Select the Fill Color field and click Choose... The Color Viewer for PGE window opens.
Seethefigure.

Select acolor and click OK.
Click Create Free Text, and type Traffic Light System

Add the text to the panel by clicking on the top of the panel canvas. The text follows the
cursor.

20
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Exercise 5 - Constructing a Panel

10. Click Push Button and add this element to the panel. See the figure.

Push Button

B PGE_1:TRAFFIC_LIGHT_PHL  [Update] R
Eile Edit Wiew Laout Teasifors Groop Toole Opflors Window  Help
Craatn Fush Butbon | | |

IDEHS w3 R ¥ EE e e

=5
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Creating a Traffic Light in MicroC

11. Click Label Existing Interactor, type the word CHANGE. The label name follows the
cursor. Place the label over the push button object and click.

12. Select the push button object that you created and then select Tools > Bind. Select the
following for the binding values for the object |abeled CHANGE. Seethefigure.

*

*

*

*

Bind Method - Input Output
Controlled by - CHANGE
Element type - Event
Button type - Flash

Note: The Controlled by: value must be manually typed into the field. All other

values are selected from the drop-down menu that opens when clicking on the
value.

Push Button Bindings

tindings,/Properties il =10 *|

Unrued

Bindirgs = | Lo I ﬂ

Label 1.1, Tups=

r'l.I!. i Button

I B

i i I Pt Saue
Bind Hethod: Irput Dutpul
Controllad bus Values ErmriE uﬂ“‘ :
Elawant, Lypel Esant;
Button tuper Flazh Fill Defaults
w | | _Feply Carcs] Halp
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Exercise 5 - Constructing a Panel

13. Click Create Lamp Interactor and create three lamps as shown in the figure.

Lamp Interactors

E PGE_1:TRAFFIC_LIGHT_PHL [Updalbe]

s _I_I— 0 il
Fils Edit WYiew Lagost Transfors Group  Tools Opbions  Mindow  Help

Bird...| P‘upl.ll;clt-u...i |

)
W
L
¥
3

e | O B @ @

i
H

() B8 [

C
3
=

&
s AOOFEEED

Aonx00

-1 =
Hezzsmme

14. Select the top lamp interactor and then select Tools > Bind to invoke the object's
Bindings/Properties window.

Enter the following information as the Binding values for the object:

¢ Bind Method - Output
¢ Controlled by - RED_LIGHT
¢ Element type - Condition
¢ Button type- Toggle
15. Click Apply.
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16. Switch to the Properties page by selecting the Bindings/Properties tab. See the figure.

Bindings Page

[!EI]J_IEHT
Condition
Tozale

17. Make sureyour settings reflect those shown in the figure. The Properties values appear.
18. Click OK.
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Exercise 5 - Constructing a Panel

Properties Page

Bindings, Progeerties =101 =1
Hame Lebsl/T.T. [T | }I
=l
I Properties I I:r.'.-u!-'.| fl
Il ] - Auto Sawe
M
Wigibility Mode: Wizible Choame, . . I
FareGround Color: BLACE
Fill Colar: LICHTCREY
Line Midth: Thin
Highlight Colar; RED
| 0% I Feply | Cancel i Help

19.

20.
21.

22.
23.

24,

Select the middle lamp interactor and then select Tools > Bind to invoke the object’s
Bindings/Properties window. Enter the following for the Binding values for the object:

¢+ Bind Method: Output
¢ Controlled by: YELLOW_LIGHT
¢ Element type: Condition
+ Button type: Toggle
Click Apply.

Switch to the Properties page by selecting the Bindings/Properties tab and enter the
following information for the Property values:

¢ Highlight Color: YELLOW
Click OK.

Select the bottom Lamp Interactor and then select Tools > Bind to invoke the object's
Bindings/Properties window.

Enter the following for the Binding values for the object:

¢+ Bind Method - Output
¢ Controlled by - GREEN_LIGHT
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25.
26.

27.
28.

¢ Element type - Condition
¢ Button type- Toggle
Click Apply.

Switch to the Properties page by selecting the Bindings/Properties tab and enter the

following for the Property values for the object:

¢+ Bind Method - Output
¢+ Highlight Color - GREEN
Click OK.

Select File > Save from the PGE and then File > Exit.

26
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Exercise 6 - MicroC Code Generation

Exercise 6 - MicroC Code Generation

This exercise builds a MicroC Code generation profile and generates code for the traffic light
system.

1. Click Satemate MicroC Code Gener ation tool from the main Rational Statemate
window.

2. If no profiles currently exist, the New Compilation Profile window automatically opens. If
other profiles exist, select File > New Profile. The New Compilation Profile window

opens.
3. Typethe name TRAFFI C_LI GHT_ucin the Profile Name: field.

MicroC Profile
[ B =1l x|

File Bt Fiee Cozpile Tools  Opbisse Hindow Help |

| &) e ] B ] & |

Szope Definttion

M Compilation Profils x|

Frofiles

Pae]

Frofils Nemes
| TReFFIC_LIGHT_UT

q

i

g
il

L]

L

"'\-.l_\u-

4. Click Create New SW M odule and name the module TRAFFICLIGHT_MOD in the
Create Module window.
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5. Click on the module and then click Add Selected Chart with Descendentsto Profile.
This opens a Chart Tree View of your current design. See the figure.

Chart Tree View

Charts Teee KI
|E;ﬁl TRAFFIC_LIGHT_53

.;.':- TRAFFIC _LIGHT _CTRI

[_w | _Aeply | _Cancel |
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Exercise 6 - MicroC Code Generation

10.
11
12.

13.
14.

15.
16.
17.

18.

Select the chart called TRAFFIC_LIGHT_SS from the Chart Tree View then click OK.

Click Add Selected Pandl to Profile from the MicroC profile window. The Add Panelsto
Profile window opens.

Select the TRAFFIC_LIGHT_PNL that was created earlier in the exercise.
Click OK.

Select the Options > Set Tar get Configuration from the MicroC Profile window.
Select the MAINLOOP_SC_NT configuration. See the figure.

Click OK.

Set Target Configuration

Target Configuration x|

Target Configurations

MATMLOOR_SC_MT

EFALLT

L _FFHCLE_FUJITSU_SOFTUNE
L _HCO2_COSHMIC
L_HCO2_METROWERES

L HC1Z COSMIC —

| I—

Select File > Save from the MicroC Profile window.

Select Generate Codefor Current Profilein the MicroC Profile Window. This opensthe
Output directory for the generated code.

Click OK in the Output Directory window to accept the location for the generated code.
Click Dismissin the generated Code window.

Select Compile Generated Codein the MicroC Profile window to compile the generated
code. This opens the Selected Makefile window.

Select Open to begin compilation of the code.

The resulting compilation output is sent to a*“Command Prompt Window.” Once
compilation is completed, exit out of the command prompt window.
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Creating a Traffic Light in MicroC

19. The GBA Server alows you to open charts for animation. Select Tools > Open GBA
from the MicroC Profile window. The GBA Server window opens. See the figure.

GBA Server

20. Click Execute Compiled Code from the MicroC Profile window and then select the
Open option from the Run Command window to start the code execution.

Note: The model is now running as an executable with the panel available to provide
user interaction.
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Exercise 6 - MicroC Code Generation

21. Click CHANGE multiple times. Different light indicators illuminate with their respective
colors. See the figure.

Panel Execution

Ml Panel: TRAFFIC_LIGHT _PHNL Y [m]
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Creating a Traffic Light in MicroC

Exercise 7 - Using the Test Driver

This exercise describes how to test the dynamic behavior of the devel oped application
non-interactively, using test vector inputs and outputs.

1

N e A

Select Options > Settings from the MicroC Profile window to open the Properties for
Code Generation window.

Select the Test Driver tab and then check the Enabled check box.
Click OK.

Regenerate and recompile the model as done in the previous exercise.
Select Tools > Open GBA from the MicroC Profile window.

Click Execute Compiled Code from the MicroC Profile window and when the panel is
available press the CHANGE push button any number of times. Within the Command
Prompt you can view the Test Driver data stream output.

Stop the model execution.

Use atext editor such as WordPad (or Notepad) to create a batch file named dos_box. bat
in the code directory. See the figure.

Dos_box.bat File

PP dos_box.bat - Notepad I =] 4
Fila Edit Format iew Help
@rem SET TESTDRIVER_IM_FILE=TESTDRIVER_IMN_FILE.TXT =]
SET TESTDRIVER_IMPUT_FROM_PML_FILE=TESTDRIVER_IMPUT_FROM_PNL_FILE.TXT
SET TESTDRIVER_OUT_FILE=TESTDRIVER_OUT_FILE.Txt
dir *.exe
L | ¥ _.-é
Note: Setting these environment variables redirects the standard input and output to
files, making it possible to post-process the results.
9. Select Tools> Open GBA from the MicroC Profile window.
10. Click Execute Compiled Code from the MicroC Profile window.
11.  Within the Run Command window, select the dos_box. bat file.
A Command Prompt window opens as a result. See the following figure.
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Exercise 7 - Using the Test Driver

12. Enter the name of the executable image (inthiscase, traf fic_| i ght _uc. exe).

13. Click the CHANGE push button any number of times when the panel isinvoked.

Note: Each time you click the CHANGE push button, information is written to the
files TESTDRI VER | NPUT_FROM PNL_FI LE. t xt and
TESTDRI VER_QUT_FI LE. t xt . These files can be viewed once the model
execution has been stopped.

Thefiles are both of asimilar format and are explained in the following tables.

Time

Variable

Name Variable Type

Variable Value

Comments

Absolute (Default)

As in Properties | See the following

The new value it

As shown in file.

or Relative table. is set to.
Data Type Identifier
INTEGER_DATA_ITEM 0
REAL_DATA_ITEM 1
BIT 2
BIT_ARRAY 3
STRING_DATA_ITEM 4
CONDITION 5
EVENT 6
STATE 7
ACTIVITY 8
ENUM_DATA_ITEM 9
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14. Edit thedos_box. bat fileto enable the line that was commented out.
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Exercise 7 - Using the Test Driver

15.

16.

Rename the file in the code directory called TESTDRI VER | NPUT_FROM PNL_FI LE. t xt tO
TESTDRI VER | N_FI LE. txt.

Open the file that was just renamed and modify the header (first line) of the file. See the
figure.

Modified TestDriver In File

-0/ x|
File Edit Farmat  Wiew Help

Test Driver Header: MULTI_RUN ABSOLUTE_TIME| .
14570 CHAMGE & 1 Input From Panel —
23778 CHANGE & 1 Input From Panel

28360 CHANGE & 1 Input From Panel

32040 CHANGE & 1 Input From Panel

35480 CHANGE & 1 Input From Panel

44070 CHANGE & 1 Input From Panel

49319 CHAMGE 6 1 Input From Panel

54574 CHAMWGE & 1 Input From Panel

60770 CHANGE & 1 Input From Panel -
64530 CHANGE & 1 Input From Panel -
1 | W

17.
18.

19.
20.

Click Execute Compiled Code from the MicroC Profile window.

Select the dos_box. bat filein the Run Command window. A Command Prompt window
opens.

Enter the name of the executableimage (inthiscase, traffic_I i ght _uc. exe).

When the panel isinvoked, the TESTDRI VER_I N_FI LE. t xt isresponsible for providing
the inputs to the system. The files TESTDRI VER | NPUT_FROM PNL_FI LE. t xt and
TESTDRI VER_QUT_FI LE. t xt iscreated. These files can be viewed once the model
execution has been stopped.
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