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Rhapsody DoDAF Tutorial

Welcome to the Rhapsody DoDAF Tutorial. Rhapsody® is the Model-Driven Devel opment
environment of choice for systems engineers and software developers of either embedded or
real-time systems.

While no prior knowledge of Rhapsody is required to complete thistutorial, a basic understanding
of DoDAF (Department of Defense Architectural Framework) allows better understanding of the
architecture model.

DoDAF Tutorial Overview

Thistutorial provides hands-on step-by-step instructions on how to create a DoDAF-compliant
architecture model of the operational view for asimplified land and sea-based attack capability.

Before you do this tutorial you may find it helpful to review the Getting Sarted Guide for the
Rhapsody product. It provides afunctional overview for the Rhapsody product for system
designers, system engineers, and software developers with more functions (meaning how to do
something), explanations, and details than this tutorial provides.

In addition, references are made to other Rhapsody documentation where appropriate in this
tutorial. Note al so that the Rhapsody User Guide has a Glossary section that you may find useful.

Thistutorial is provided as part of the Rhapsody DoDAF Add-on. Thistutorial isintended to get
you familiar with the Rhapsody product and DoDAF. You should consider thistutorial as part of
the Rhapsody learning process, in addition, for example, to the Rhapsody Essential Tool Training
class and the Rhapsody el earning courses, both of which are available at an additional cost.
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Rhapsody DoDAF Tutorial

Required Software

The Rhapsody DoDAF Add-on can be used on Windows XP SP1 or newer. Thistutorial requires
the following application software to be properly installed and licensed on your system.

Required Application Version
Rhapsody 7.3 or later
Rhapsody DoDAF Add-on 7.3 or later
Adobe Acrobat Reader 6.0 or later
Microsoft Word 20083 or later
Microsoft Excel 20083 or later
Microsoft Paint (or another bitmap image N/A
viewer)

Microsoft .NET Framework 1.1.4322 or later

Note

Thistutorial does not include the Microsoft Excel, Microsoft Word, or Microsoft Paint
software (these can be purchased from Microsoft Corporation). This tutorial does not
include Adobe Acrobat Reader, which can be downloaded for free from the Adobe Web site.

2 DoDAF Tutorial



About the Rhapsody Product

About the Rhapsody Product

The Rhapsody product is avisual design tool for developing object-oriented embedded software,
and performing structural and systems modeling. It enables you to perform these tasks:

*

*

*

Analyze, during which you can define, analyze, and validate the system requirements.
Design, during which you can specify and design the architecture.

I mplement, during which you can automatically generate code, then build and run it
within the Rhapsody product.

Model Execution, during which you can animate the model on the local host or aremote
target to perform design-level debugging within animated views.

UML Diagrams

Thefollowing are the UML diagramsin Rhapsody:

*

Use Case Diagrams show the main functions of the system (use cases) and the entities
(actors) outside the system.

Sructure Diagrams show the system structure and identify the organizational pieces of
the system.

Object M odel Diagrams show the structure of the system in terms of classes, objects, and
the relationships between these structural elements.

Seguence Diagrams show sequences of steps and messages passed between structural
elements when executing a particular instance of a use case.

Activity Diagrams specify aflow for classifiers (classes, actors, use cases), objects, and
operations.

Satecharts show the behavior of a particular classifier (class, actor, use case) or object
over itsentire life cycle.

Collaboration Diagrams provide the same information as sequence diagrams,
emphasizing structure rather than time.

Component Diagrams describe the organization of the software units and the
dependencies among units.

Deployment Diagrams show the nodes in the final system architecture and the
connections between them.

In addition, Flow Charts are available in the Rhapsody product. Flow charts are not in UML.
They are a subset of activity diagrams with parts (of the functionality for activity diagrams)
excluded. Flow charts have specifically event-driven behavior. You can use aflow chart to
describe afunction or class operation and for code generation.

Rhapsody



Rhapsody DoDAF Tutorial

About a Rhapsody Project

A Rhapsody project includes the UML diagrams, packages, and code generation configurations
that define the model and the code generated from it. When you create a new project, Rhapsody
creates a project folder that contains the project files in the specified location. The name you

choose for your new project is used to name project files and folders, as shown in the following

figure:
Folders | Date Modified Size | Tvpe |
B I3 Telelogic 6/5/2007 12:34 PM File Folder
5 £ Rhapsady 7.1 & DoDAF _Tutorial.ehl 4/30/2007 2:20 PM 1KE EHLFile
3 Addon DoDAF_Tutorial.rpw £/6/2007 5:29 FM BKE RPW File
) Atg rR', DoDAF_Tutarial.rpy 4/30/2007 2:20 PM 3KE Rhapsody Project
© Dax DoDAF_Tutorial.vba 4/30/2007 2:20 PM ZKE WEBA File

|2 Gateway
|2 Harmony Toolkit
|20 reporterplus
5 RER
|2) Rhapsody 7.1
12 Samples
|20 Share
120 Sodius

1) license
I2) templates
= 12 Tutorial
= |22 DoDAF_Tutorial_Maodel

Kl |

= I2) Telelogic Rhapsody DoDAF Pack

|2 DoDaF_Tutorial _rpy

s

IE_I]DDDAF_TutoriaI_DoDAFreport.doc
@_]DODAF_TutoriaI_DoDAFreport.xIs
E] lnad.log

m omFileLastModifiedTime, dat

E] Plugins.log

E] rtc.log

4/30/2007 2:20 PM
4/30/2007 2:20 PM
£6/2007 4:51 FM
4/30/2007 2:20 PM
£6/2007 4:51 FM
£6/2007 4:51 FM

450KE  Microsoft Word Doc...
19KB  Microsoft Excel Wor...
Z25KE  Text Document
1KE DAT File
1KE Text Document
0KE  Text Document

For more information about the folders and files that are part of a Rhapsody model, see About

Project Files and Folders.
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About the Rhapsody Product

In addition, the name appears at the top level of the project hierarchy on the Rhapsody browser.
The following figure shows the Rhapsody browser for the DODAF_Tutorial model.

[ =
Entire Model View - | + + |

=40 DoDaF_Tutarial (RO
-av| Allviews
{:l Components
L—‘_Igﬂ Operationalviews
Elgﬂ Operationalvisw (RO)
H-B) DocBoxs
& InformationElements
=" InformationExchanges
@ MissionObjectives
% Meedines
=1-{E} Operationalactivities
LBy opdtkack (RO
- ¥} opCreatedttackReport (RO
- opSkandDown (RO
=142} Operationaliodes
{23 DARD (RO
{23 DOCC (RO)
[-423 105 (R
{23 JFMCC (RO)
ey JIC (RO
ey JIPS (RO
=9 ov-1s
S| ow-1 High-Level Graphic (RO)
V| -1 Mission Concept (RO
O-25
oY-3s
OV-Bs
oN-7s
i-{_7] Packages
f-Z7 Profiles

H--8V | Syskemsyiews
t-- TV | TechnicalVisws

[ s s B |
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Rhapsody DoDAF Tutorial

About Project Files and Folders

The Rhapsody product creates the following files and subfolders in the project folder. Some
folders and files are created when you initially create a project, others only when applicable.

*

A project folder, called <project_name>_rpy, which contains the unit files for the
project, including UML diagrams, packages, and code generation configurations.

A project file, called <project_name>.rpy.

A subfolder, called <project_name>_auto_rpy, which appears only when necessary
(after ten minutes if a save has not been made) and disappears after you save.

An event history file, called <project_name>.ehl, which contains arecord of events
injected during animation, and active and nonactive breakpoints. This file appears after
your first save of a project.

Log files, which record when projects were loaded and saved in the product; for example,
load.log and store.log.

A .vbafile, called <project_name_>.vba, which contains macros or wizards.

Backup project files and folders (<project_name>_bak1 rpy,
<project_name> bak2 rpy), which are optional, depending on project settings.

An_RTC subfolder, when applicable, which holds any tests created using the Rhapsody
TestConductor™ add-on.

The <project_name>.rpy file and the <project_name>_rpy folder are necessary for the
generation of source code.

DoDAF Tutorial



Rhapsody User Interface

Rhapsody User Interface

Before proceeding with this tutorial, you should become familiar with the main features of the
Rhapsody graphical user interface (GUI). The Rhapsody GUI is made up of three key windows
and different toolbars for each of the UML diagram types. The following figure shows the
Rhapsody GUI.

Toolbars —3»
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% Needlines @ cCperationalModes o N | |
--@ Operationalactivities e . =
[#-(2£} Operationaliodes {1 < _~“AssessThreat
<
JIPS e
s eMissionObjectives
---°7V -5 i / -
-] Packages ¢ «OperatmnaINode» -
-1 Profiles 4 -
[ 8% | SystemsWiews ———
s ‘

AttackTarget

-

0.

I_I_I_I_I_I_I_I_I

Output Window
(partially shown)

k|

1
]'IN“ I3 }II\Build j{ heck Model }\ Configuration Management ,}\ Animatian }\ Search Results ,"

Rhapsody



Rhapsody DoDAF Tutorial

Toolbars

The Rhapsody toolbars provide quick access to the commonly used commands. These commands
are also available from the menus. The Rhapsody product has the following toolbars:

*

Sandard hasiconsfor the frequently used options on the File, Edit, and Help menus.
Examples: New, Open, Save; Copy, Paste, Locatein Browser; About.

Code hasiconsfor the frequently used options on the Code menu, such as Make, Run
executable and G/M/R (for Gener ate/M ake/Run).

Windows hasiconsfor the frequently used options on the View menu, such as Show/Hide
Browser and Show/Hide output window.

Diagrams hasicons for the part of the Tools menu that give you quick access to the
diagrams in the project, such as Sequence Diagrams and Open Statechart.

VBA provides access to the VBA options, such as VBA Editor and Show M acros
Dialog. Note that VBA isfor Windows only.

Animation hasicons for the animation options during an animation session, such as Go,
Animation Break, and Quit Animation.

L ayout hasiconsthat help you with the layout of elementsin your diagram, such as Snap
to Grid, Align Top, and Align L eft.

Drawing hasiconsfor the graphics editor used to create and edit diagrams. Each Drawing
toolbar is unique to its particular diagram type. For example, the Drawing toolbar for a
sequence diagram is different from that for a statechart.

Common Drawing has icons to add requirements, comments, and other annotations to
any diagram, such as Note and Requirement.

Free Shapes has icons for basic drawing shapes, such as Polyline and Polycurve.
Zoom has icons to zoom options, such asZoom In, Zoom Out, and Pan.

Format hasicons for various text formatting options and line/fill options, such aslItalic
and Font Color.

Refer to the Rhapsody User Guide for detailed information about the toolbars.

DoDAF Tutorial



Rhapsody User Interface

Browser

The Rhapsody browser shows the contents of the project in an expandable tree structure. By
default, it isthe upper, left-hand part of the Rhapsody interface. The top-level folder, which
contains the name of the project, isthe project folder or project node. Although thisfolder contains
no elements, the folders that reside under it contain e ements that have similar characteristics.
These folders are referred to as categories.

A project consists of at |east one package in the Packages category. A package contains UML
elements, such as classes, files, and diagrams. Rhapsody automatically creates a default package
called Default, which it usesto save model parts unless you specify a different package.

Opening the Rhapsody Browser

By default, the Rhapsody browser is displayed the first time you open a project. In subsequent
work sessions, Rhapsody consults your workspace file (<project names. r pw) to determine
whether to open the browser when it opens a project. To open the Rhapsody browser manually,
follow these steps:

¢ Click the Show/Hide Browser icon on the Rhapsody Windows toolbar.
¢ Select View > Browser.
¢  Press Alt+0 (zero).

Rhapsody 9



Rhapsody DoDAF Tutorial

Filtering the Browser

The large size and nested hierarchy of a Rhapsody project may complicate the process of locating
and working with model elements. To help you navigate the Rhapsody browser more easily, the
browser has afiltering mechanism that you can use to display only the elements relevant to your
current task.

To display the filter menu, as shown in the following figure, click the down arrow at the top of the
browser. Whatever view you have selected is reflected in the label to the left of the arrow.

I £
Enkire Madel View F + 3

Entire Model View

Lse Case Yiew

Camponent Yiew

Diagram View

Linit Yiew

Laaded Units Yiew

Requirernent Yiew

Cwverridden Properties Yiew

Refer to the Rhapsody User Guide for information on the view options.

Repositioning the Browser

To make more room for you to work on diagrams, you can move the browser outside of the
Rhapsody GUI and reposition it as a separate window on the desktop. To reposition the Rhapsody
browser, click the bar at the top of the browser and drag it to another desktop location.
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Rhapsody User Interface

Drawing Area

The drawing area displays the graphic editors and code editors, and it is the region for drawing
diagrams. By default, it is the upper, right-hand section of the Rhapsody interface. Rhapsody
displays each diagram with atab that includes the name of the diagram and an icon that denotesthe
diagram type. When you make changes to a diagram, Rhapsody displays an asterisk after the name
of the diagram in the title bar to indicate that you must save your changes.

Output Window

The Output window is where Rhapsody displays various output messages. Tabs on the Output
window enable you to navigate easily among the different types of output messages:

¢ ThelL ogtab shows all the messages from all the other tabs of the Output window (except
for Search Results) in text—meaning non-tabular—format.

¢ TheBuild tab shows the messages related to building an application in tabular format.

¢ The Check Model tab shows the messages related to checking the code for amaodel in
tabular format.

¢ The Configuration Management tab shows the messages related to configuration
management actions for amodel in text format.

¢ TheAnimation tab shows the message related to animating a model in text format.

¢ The Search Results tab shows the results from searches of your model in tabular format.
Note that this tab may not appear until you perform a search.

By default, the Output window is located at the bottom portion of the main Rhapsody window.
Also by default, when you generate, build, or run an application; do a search, a configuration
management action, or a check model, Rhapsody opens the Output window. To open the Output
window manually, select View > Output Window.

Drawing Toolbars

The Drawing toolbar provides access to tools (shown asicons) used in creating and editing
diagrams in the graphic editors. Each graphic editor has a unique drawing toolbar. To display or
hide the Drawing toolbar for the current diagram, select View > Toolbars > Drawing.

To view the complete set of drawing tools available for al the different diagrams, select View >
Toolbars > All Drawing.

Rhapsody 11
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Features

Dialog Box

The Features dialog box lets you view and edit the features of an element in the Rhapsody product.

To open the Features dialog box, do one of the following:

*

*

*

*

Double-click an element (for example, attack SatusReport [an information element])
Right-click an element (for example, OV-1 Mission Concept), then select Features
Select an element and press Alt + Enter

Select an element and select View > Features

You can resize the Features dialog box and hide the tabs on it if you want. For more information
about the Features dialog box, refer to the section on it in the Rhapsody User Guide.

Keeping Open the Features Dialog Box

Once you open the Features dialog box, you can leave it open and select other elementsto view
their features. This meansthat after you make changes to the Features dialog box for an element in
your drawing or on the Rhapsody browser, you can click Apply. Then, without closing the dialog
box, you can select another element to view its features. Once you are done with the Features
dialog box, you click OK to closeit.

Note

Even though you clicked Apply or OK for your changes in the Features dialog box, you
must still save your model to save all the changes you made. Clicking Apply or OK applies
any changesto the currently opened model. However, to save the changes for the model so
that they are in effect the next time you open it, you must save your model.

Note the following about the Apply and OK on the Features dialog box:

*

*

Click Apply when you want to apply any changes you made to the Features dialog box but
want keep it open. For example, you may need to apply a change before you can continue
with using the Features dialog box, or you want to apply a change and seeiits effect before
continuing making any more changes on the dialog box.

Click OK when you want to apply your changes and close the Features dialog box at the
same time.

12
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Rhapsody User Interface

Tabs for the Features Dialog Box

The Features dialog box has different tabs at the top of the dialog box and different boxes on the
tabs depending on the element type.

Thefollowing tabs are common to all types of elements. For more information about these tabs, as
well as the other tabs that you may see in the Features dialog box, refer to the section on it in the
Rhapsody User Guide.

*

Operational Node : DARD in Operational¥iew |

e
General I Descriptiunl Attributes Dperatiansl Portz | Helationsl Tagz | Prupertiesl _

Sterentype: I j !Iil
<]

b ain Diagram: IDV-1 Mizzion Concept in Operationalyisw

M ame:

Concurrency: Isequential j
Type: [<irmpiicit- =1 =
huitiplicity: |1 =]

| mitialization: I |

Relation to whole

[T | Knows its whale as;

Locate | 1] 4 | Apply | ‘

Description, asitstitleimplies, contains the description of the element, if it has been
included.

¢ General typically contains the name of the element and other general options, asshownin
the following figure:

Rhapsody
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Rhapsody DoDAF Tutorial

*

Relationslists al the relationships (dependencies, associations, and so on) an element is

engaged with, as shown in the following figure:

Operational Node : DARD in Operational¥iew 1 |
Genetall Descriptionl .-'-‘-.ttril:nutesl Dperatiansl Pote  Felations |Tag$ | F'mpertiesl
Yiew Relations ~
M ame | Type | Direction | From/T o
*sj DARD in Dperationaffiew: TopLey... Dependency From AzzeszT hreat
< | o

Locate | Ok | Apply | ‘
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Rhapsody User Interface

+ Tagslistsany tags available for an element. Tags enable you to add information to certain
kinds of elements to reflect characteristics of the specific domain or platform for the
modeled system. Refer to the Rhapsody User Guide for more information about tags.

Operational Node : DARD in Operational¥iew |
Generall Descriptianl .ﬁ.ttributesl Dperationsl Portz | Felations Tags |Pr0petties|
i by

[=I| ElementStereotypes

=l OperationalMods

Level Identifier

SecurityvLevel

SecurityLocality

SecurityModifier

= Huick sdd

M arne: I YW alue: Add

Lucatel 1] 4 | Apply ||
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* Propertiesliststhe properties associated with the Rhapsody element.
— Thetop left column on this tab shows the metaclass and property (for
example, Dependency and UsageType).

— Thetop right column shows the default for the selected property, if thereis
one (for example, Specification).

— The box at the bottom portion of the Properties tab shows the definition for
the property selected in the upper left column of the tab. The definition
display shows the names of the subject, metaclass, property, and the definition
for the property, as shown in the following figure:

Information Element : attackStatusReport in Operational¥iew

|
General I Dezcription I Attributes I Operations I Partz I Relations I Tags Froperties
Wiew ol -
Attribute ;l
=l Dependency J
ConfigurationDependencies
GenerakeRelationithActors WhendctorlsGenerated
PropagatelmplementationToDerivedClasses
Specification _l
h
CG:Dependency:UsageT ype
The UzageT ype property specifies how a provider iz to be made available to a dependent clazs or package if
the zage stereotype iz attached to the dependency. The possible values are az follows:
* Enistence - If the provider is a clazs, a forward class declaration iz generated in the dependent.
* Implementation - &n Hinclude statement iz generated in the implementation file of the dependent.
* Specification - An Binclude statement iz generated in the specification file of the dependent.
[Default = Specification]

Lucatel 1] 4 | Apply ||

Note: Rhapsody documentation uses a notation method with double colonsto identify
the location of a specific property. For example, for the property in the above
figure, the location is CG: : Dependency: : UsageType where ce isthe
subject, pependency isthe metaclass, and usageType isthe property.
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Rhapsody User Interface

Moving the Features Dialog Box

The Features dialog box is a floating window that can be positioned anywhere on the screen, or
docked to the Rhapsody GUI.

To dock the Features dialog box in the Rhapsody window, do one of the following:

*

Double-click thetitle bar. The dialog box docks. You can now drag it to another location if
you want.

Right-click thetitle bar and select Docking by Drag. Then drag the dialog box to another
location.

To undock the Features dialog box, do one of the following:

+ Double-click thetitle bar to undock it.

+ Right-click thetitle bar and clear Docking by Drag, then drag the dialog box to another
location.
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DoDAF Basics

The model created in this tutorial uses the “ out-of-the-box” version of the Rhapsody DoDAF Add-
on. The DoDAF Add-on isatemplate-driven solution that can be customized and extended to meet
specific customer requirements and development processes. You can contact Rhapsody support
(http://modeling.telelogic.com/) for additional information on the Rhapsody DoDAF Add-on.

DoDAF defines four views:

¢ Operational View
¢ SystemsView
¢ Technica View
+ All View
The architecture model created in this tutorial includes the architecture products listed in the

following table:

Architecture

View Product Name Product Description
Product
All Views Package AllViews This optional stereotyped package allows you to add
in AV products and other views and packages, if
desired.
AV-1 All Overview and This product is typically a text (Word, FrameMaker,
Summary HTML) document. You can add AV-1documents and
Information launch them by clicking on them.
AV-2 All Integrated This is a DoDAF-generated text product (report).
Dictionary
Operational View | Package This optional stereotyped package is similar to the
All View product. It supports all the operational
products.
Oov-1 Operational High-Level This High-level graphical/textual description of the
Operational operational concept allows you to import pictures
Concept Graphic and other operational elements, such as Operational
Nodes, Human Operational Nodes, Operational
Activities, and the relations among them.
OoV-2 Operational Operational Node | This product shows the connections and flows

Connectivity
Description

among operational nodes and operational activities.
If desired, the behavior of operational nodes and
operational activities can be shown by adding OV-5,
QOV-6a, OV-6b, and OV-6¢ diagrams. These
diagrams are the primary source of information used
by the DoDAF add-on to create the OV-3 diagram.

DoDAF Tutorial
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Architecture

Matrix

View Product Name Product Description
Product
OoV-3 Operational Operational This product shows information exchanged between

Information nodes and the relevant attributes of that exchange.

Exchange Matrix OV-3 is generated from the information shown in
OV-2 and other operational diagrams. This
information is stored as a CSV file and can be added
to any product.

OV-5 Operational Operational This product details the behavior of operational

Activity Model nodes or more commonly, operational activities.

OV-6a Operational Operational Rules | This product is a textual description of “business

Model rules” for the operation. It is a controlled file. One of
three products used to describe the mission
objective.

OV-6b Operational Operational State | This product is a statechart that can be used to

Transition depict the behavior of an operational element (node
Description or activity). One of three products used to describe
the mission objective.

OV-6¢ Operational Operational Event | This product is a sequence diagram that captures

Trace Description | the behavioral interactions among and between
operational elements and (in the Harmony process)
captures the operational contracts among them.
One of the three products used to describe the
mission objective.

Oov-7 Operational Logical Data Model | This product is a class diagram that shows the
relations among Informational Elements (data
classes). This is similar to entity relationship
diagrams, but is more powerful.

System View Package This optional stereotyped package is similar to other
views, but contains system elements.

Sv-1 Systems Systems This product is a diagram that contains System

Interface nodes, systems, system parts and the connections

Description between them (links). These can be used with or
without ports.

SV-2 Systems Systems This product is a diagram that shows the

Communications connections among systems via the

Description communications systems and networks.

SV-3 Systems Systems-Systems | This product is generated from the information in the

other system views. SV-3 assumes that there are
links between items stereotyped SystemNode,
System, or System Part and represents these in an

N2 diagram.

Rhapsody
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Architecture View Product Name Product Description
Product
Sv-4 Systems Systems This product represents the connection between
Functionality System Functions and Operational Activities. The
Description connection is made by drawing a Realize
dependency line from the System Function to the
Operational activity on the diagram. System
Functions are mapped onto the system elements
that support them by making System Functions parts
of the system elements (that is, System Functions
are drawn within the other system elements).
System elements can also realize system functions.
Note that here, as in almost all the other views, you
can use Performance Parameters (bound to their
constrained elements via anchors) to add
performance data. This is summarized in SV--7.
SV-5 Systems Operational This product is a spreadsheet-like generated view
Activity to summarizing the relations among system elements
Systems (system nodes, systems and system parts), system
Function functions that they support, and the mapping to
Traceability Matrix | operational activities.
SV-6 Systems Systems Data This product shows the information in the flows
Exchange Matrix (information exchanges) between system elements.
They may be embedded flows (bound to the links) or
they may be flows independent of links. This is a
spreadsheet-like generated product.
SV-7 Systems Systems This is a generated spreadsheet-like product,
Performance showing all the performance parameters and the
Parameters Matrix | elements that they constrain.
SV-8 Systems Systems This product is the system evolution description.
Evolution This is an activity diagram (there is a SystemProject
Description element stereotype to serve as the “base” for this
activity diagram). SV-8 depicts the workflow for
system development, object nodes for products
released, and performance parameters for things
like start and end dates, slack time, and so forth.
SV-9 Systems Systems This product is a text document - a stereotype of a
Technology Controlled File.
Forecast
SV-10a, Systems Systems Rules These products are similar to the OV-6a, OV-6b,
SV-10b, Model, and OV-6¢ products, but they are separately
SV-10c Systems State identified, even though they are structurally identical.
Transition
Description,
Systems Event
Trace Description
SV-11 Systems Physical Schema | This product is similar to the OV-7 class diagram.
This product uses a class diagram to show physical
schema (data representation).
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Getting Started with DoDAF Architecture

In thistutorial, you are provided with an AV-1 Word document and OV -1 bitmap image file to be

included with the architecture model. You will create the following Operational View Products

using UML diagrams based on the following mapping.

Architecture

Description
Product P

AV-1 Overview and Summary Information

AV-2 Integrated Dictionary
Note: The Rhapsody model is a dynamic integrated dictionary of the
architecture. A snapshot of the AV-2 product is also included in the
DoDAF report generated from the model.

OV-1 High Level Operational Concept Graphic

OV-2 Operational Node Connectivity Description

OV-3 Operational Information Exchange Matrix
Note: The OV-3 and SV-5 products are not manually created, but rather
are automatically derived from the architecture model. Since the creation
of the Systems View has many parallels with the creation of the
Operational View, this tutorial includes some hands-on work in this area,
as well as a discussion on creating additional Systems View products.

OV-5 Mission Objective Model

OV-6b Operational State Transition Description

OV-6¢ Operational Event-Trace Description

OV-7 Logical Data Model

Sv-1 Systems Interface Description

Sv-4 Systems Functionality Description

SV-5 Operational Activity to Systems

Function Traceability Matrix

Note: The SV-5 and OV-3 products are not manually created, but rather
are automatically derived from the architecture model. Since the creation
of the Systems View has many parallels with the creation of the
Operational View, this tutorial includes some hands-on work in this area,
as well as a discussion on creating additional Systems View products.

Rhapsody
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Creating a New Rhapsody Project

Start Rhapsody and create a new project for your Coordinated Land and Sea Attack architecture
model.

1. To start Rhapsody, from the Windows Start menu, select Programs > Telelogic >
Telelogic Rhapsody Version# > Rhapsody Development Edition > Rhapsody in C++.
The Rhapsody graphical user interface (GUI) opens.

2. Select File > New. The New Project dialog box opens.
3. Typeyour Project name (project 1 inthisexample), specify afolder location

(directory), and select DoDAF from the drop-down list as the project Type (profile)
menu, as shown in the following example:

) New Project R|

Project narne: |Pr0ject_1

In folder: |C:\Rhapsudy\Prujed_1 Browse. .

Type:

Thig is the Rhapsody profile for DoDAF 1.0,

(0]4 | Cancel Help

4. Click OK.

5. If thefolder you specified does not exist, you are asked if you want to createit. Click Yes.
This new project is the standard starting point for a Rhapsody project.
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6. Expand OV-1s, Packages and Profiles by clicking the corresponding + signin the
Rhapsody browser, as shown below. The packages and profiles, shown in your diagram,
may vary depending on your site properties and product licensing.

Entire Model Yiew bt

-1 Components
+ # DefaultComponent
-3 ov-1s
9] Model1
-1 Packages
B9 Defauilt
+-89 PredefinedTypes (REF)
+-£9 PredefinedTypesCpp (REF)
=1 Profiles
+ 5 DoDAF (REF)
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7. Toinitialize the DoDAF project, right-click your project folder (named project 1 inthis
example) and select Setup DoDAF Packages. If you do not see this menu item, see
Manually Adding the DoDAF Helpers in the “ Troubleshooting” section of this tutorial.

Entire Model Wiew -

FeatLres
Features in Mew Window

Add Mew 4

Search...

Search inside...

- Profle Locate On Diagram
+FAD]  References...

Add to Fawvorites

Bromise from here

Edit Unit...
Change to 4

Configuration Management 4
Format...

Generate Data-Flow Based &-3 Table
Generate SY-3 Matrix

Generate SY-5 Summary Matrix
Generate SY-5 Full Matrix

Generate Service Based SW-6 Matrix
Generate Data-Flow Based Sv-6& Table
Generate 5Y-7 Table

DoDAF Report Generator
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8. The DoDAF helper adds some new packages, views, and overviews to the project (as

shown in the example). Expand the folders to examine these project additions.

=1-av| Allyiews

v Alview
=0 Components
+ E OperationalExecution
&1 SystemsExecution
=-ov| Operationabiiews
+-gv| Cperationahiew
=1 Packages
B9 Default
B9 operationallnterfaces
+-B9 PredefinedTypes (REF)
+-E9 PredefinedTypesCpp (REF)
9 svystemsinterfaces
=3 Profiles
=5 DoDAF (REF)
=0 ProjectCrverviews
| Project_1
=1 sv| Systernsyiews
8| Systemsiiew
= 1v| Technicalviews
¥| Technicalyiew

Rhapsody
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Example DoDAF Model Information

Thistutorial guides you through the creation of an as-is architecture model for Coordinated Land
and Sea attacks. All information used to create this architecture model is open-source.

This model assumes the viewpoint of battle commanders, providing visibility to the chain of
command followed in Coordinated Land and Sea attacks. The model considers several missionsin
creating your architecture model, including reconnaissance, mobilization, covert entry team
attacks, missile attacks, and damage assessment.

The operational nodes involved in this architecture include the following:
¢+ DARO - Defense Airborne Reconnaissance Office, responsible for Airborne
Reconnaissance
¢ DOCC - Deep Operations Coordination Cell, responsible for undercover operations
¢ JCS- Joint Chiefs of Staff, responsible for making decisions regarding multiple forces

¢ JFMCC - Joint Force Maritime Component Commander, responsible for commanding the
naval component of an Attack

¢ JIC- Joint Intelligence Committee, responsible for assessing intelligence from the field
¢ JIPS- Joint Intelligence Image Processing Service, responsible for processing image data

26
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DoDAF Project Overview

The ProjectOverviews folder is listed after the Profiles folder. The ProjectOverviews folder
contains the Project_1 file which contains a high-level overview of the entire model. The
Project_1 file can be renamed by being clicking on twice.

To enter information into the project overview file, follow these steps:
1. Double-click the Project_1 filein the browser.

2. Click the Diagram (Documentation Box) icon on the Drawing toolbar and click in the
right pane to create a starting point <<DocBox>>, as shown in this example:

= «DocBoxs

docbox_1

# Author-RhpString=Your Name

# Date Created:RhpString=08-26-2008

. Diagram Mame:RhpString=Mission Concept
# Mission:RhpString=Complete Mission

¥, Postconditions:RhpString

#. Preconditions:RhpString

=

a1 |Pl2lzlez| 0D

3. Right-click <<DocBox>> in your drawing area and select Features.
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4. Onthe Tagstab, enter the appropriate information for the Author, Date Created,
Diagram Name, and Mission you are documenting DocBox fields:

Doc Box : docbhox_1 in Default (=]
General || Description || Relations | Tags | Froperties
e b
[=!| ElementSterectypes
[=l| DocBox
Author ‘four Mame
Date Created 08-25-2008
Diagram Name Mission Concept
Mission Complete Mission
Postconditions
Preconditions
Gluick Add
Mame: | Value:
Locate oK Appky

5. Click OK when finished.

6. Returnto the diagram and click twicein the middle cell of <<DocBox>> on your drawing
area and type in the name of the object, element, reference, or note you want the
<<DocBox>> to represent. Thisexample usesov-1 Mission Concept.
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To create a hyperlink to the object, element, reference, or note you entered in <<DocBox>>,

follow these steps:

1. Highlight the text in the middle cell <<DocBox>>, right-click, and select Hyperlink. A
Hyperlink dialog box displays, as shown in the following figure:

i Hyperlink

-

Test ta dizplay:
(%) Free test
0%-1 Mizzion Concept

() Target name

Link target
Enter a file, web page, zelect a model element:

[ Cancel ]

l

Help

]

2. Using theradio buttons, select either the Freetext to display or the Tar get name and click
the Link target drop-down menu (see the example below) to select the model object,

element, or reference for thislink.

= D Project_1
+-av| AllViews
+-{_] Components
= ﬂ CperationalViews
= gﬂ Operationalview
=¥ ov-1s
%‘ OV-1 High-Level Graphic

18
+-(_7] Packages
+-[_] Profies
= D ProjectOwverviews

ﬁ] Project_1

+-- 8V | SystemsViews
+-T¥ | TechnicalViews

ak. Cancel
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3. Click OK twice and observe the added hyperlink, as shown in this example.

{1

Ct

O
aDocBoxe
dochox_1

OW-1 Mission Concept

L # Author:RhpString=Your Name
# Date Created:RhpString=08-26-2008

@ Diagram Mame:RhpString=Mission Concept
@ Mission-RhpString=Complete Mission

¥ Postconditions:RhpString
¥ Preconditions:RhpString

1

(m,

T
Tt

4. Click the new hyperlink and the OV-1 Mission Concept diagram displays.
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Adding the AV-1 to the Rhapsody Model

The AV-1 Overview and Summary Information product provides on overview of the architecture,
including the purpose, context, scope, and mission scenarios. In this tutorial, you provide a Word
Document to use as the AV-1 for your architecture model.

Note

Before proceeding, locate the av-1.doc and ov-1.bmp files using Windows Explorer. If you
are unsure about where the Rhapsody DoDAF Add-on Tutorial isinstalled on your
computer, see Verifying the Rhapsody DoDAF Add-on Installation in the Troubleshooting
section of thistutorial.

To add the AV-1 Overview and Summary Document to the model, follow these steps:

In the Rhapsody browser, expand AllViews.

Right-click AllView and select Add New > All View Diagram > AV-1, as shown in the
following figure:

1 ay] Altiews ||
T i 'D'”\FIIE Feaktures
-8 Compnljer Features in Mew Window
—]---E}il Cperation
Egﬂ Operal  Add Mew ¥ Package
E|<:|1v S., Qpen Main Diagran ... ControllzdFile
L % Search, .. All Yiew Diagram r Allvigw
3427 Packages Search inside... Cperational Diagram B AN
..... EI Defau  References... System Diagram BoAN-2 i
----- EI Interf,  Unit b Technical View Diagram  #
EI Preds Change ta »
------ E Syste
‘]D Profiles Generake Allvisw
s DODAE it Allview
@ DoDA Foundtrip Allview
]ﬂ Technical

Edit Twpe Crder...

Configuration Management  #
Farmat.,.

frrmmizba Trazma
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3. The Controlled File dialog box appears. Select av-1.doc and click Open.

Controlled File

Look i | - DoDAF j - £F B2~

File name: |av-‘| .doc
Files of type: |".dcu:,'”.pdf,'".htm;".html;".ppt;".frm j Cancel

4. A message appears asking you to click OK to copy the AV-1.doc fileto the _rpy directory,
as shown in the following figure. Click OK to continue. By clicking OK, the AV-1.doc
fileis now maintained as part of the Rhapsody model repository.

Rhapsody

Controlled Files need to be located under the _rpy directon.
[ Click 0K to copy the file naw. Click Cancel to cancel the operation.

[ Don't ask me again. Use my curent reply as default.

ak. | Cancel
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5. Your Rhapsody browser should resemble the following figure:

Entire Model Yiew -

= D Project_1

—-av| Allvigws
| Allig
—-AY] av-1s
ﬂ
+ D Components
- ﬂ Operationalvisws
= gﬂ Operationalview
=% ow-1s
OV -1 High-Level Graphic
‘:'1“' oY-1 Mission Concepk
=[] Packages
ﬁ Default
ﬁ Interfaces
+ ﬁ PredefinedTypes (RO
-2 Profiles
+-F5 DoDaF (RO
+ [:l ProjeckOverviews

+-8v | Swstemsiiews
+- TV | Technicalviews

Rhapsody 33



Rhapsody DoDAF Tutorial

6. Testtheav-1 file by double-clicking it in the Rhapsody browser and confirm the av-1.doc

fileis displayed, as shown in the following figure:

@ av-1.doc - Microsoft Word

File Edit “iew Insert Format Tools Table ‘Webwforks ‘Window Help Adobe POF
== =T 52! @ Otz - [3) 2 Narmal ~ Arial -1z -|B I U

4 Save to iMNation, .

ke

|Architecture Project Identification

Thiz is an as-is architecture model for Coarindated Land and Sea attacks based in information gathered
an the internet. Seweral assumptions and extensions hawve heen made to provide a more interesting
demonstration. This architecture model was created by I-Logix Inc to demonstrate the creation of a
DoDAF Architecture Model Using a Standards Based Model-Driven Development Frocess.

Purpose and Viewpoint

This architecture model was created by |-Logix Inc to demonstrate the creation of a DoDAF Architecture
Model Using a Standards Based Model-Driven Development Process. The wviewpoint is of the hattle
comanders, providing visikility to the chain of cormmand followed in Coorindated Land and Sea attacks.

Context

Several missions are considered, including reconnaissance, mobilization, covert entry team attacks,
missile attacks, and damage assessment.

Scope:

The arganizations involved in this architecture include the fallowing:

« [DARC - Defense Airbaorne Reconnaissance Office, responsible for Airbome Reconnaissance
s [DOCC - Deep Cperations Coordination Cell, responsible for undercover operations

r qu - lnint Mhirfe of Staff resnnnsible for maldina decizinns reaardinn moiltinde farces
EI Rlm= _—,l F
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Creating the Operational View Model

Now that you have associated AV-1 with the project, you can add OV-1, the High-Level
Operational Concept Graphic.

Adding the OV-1 High Level Concept Graphic

Traditionally, the OV-1 is a picture depicting the mission and the main operational nodes. In your
architecture model, both atraditional picture as well as adiagram to communicate the high level
mission concept are used, as shown in this example.

=/ gv-1.bmp - Windows Picture and Fax Viewer Q@E
COHHUNICATIONS SUBHARTHE COHOPS
POSITIONING HISSILE ATTACK

COYERT OPS ATTACK

ATTACK PATH GPS
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Begin by opening OV-1 High-L evel Graphic, which was created when you set up your Rhapsody
DoDAF project.

To do this, follow these steps:

1. Inthe Rhapsody browser, double-click OV-1 High-Level Graphic, as shown in the
following figure:

Entire Model Yiew -

- D Project_1

- ﬂ allviews

-] Allvigw
- A av-1s
AV -1, doc)

+ D Components
- ﬂ Operationaltiews
= Eﬂ Cperationalyiew
=] oy-1s
V| -1 High-Level Graphic |<a—

mﬁ -1 Mission Concepk

--[_1 Packages

ﬁ Default

ﬁ Interfaces
+ ﬁ PredefinedTvpes (RO

—-{_1 Profiles
+-f'5 DoDaF (RO)
+ I:I ProjectOnverviews

+-- 8| Syskemnsiiews
+--1v| Technicalviews

2. Maximize the diagram window using the (@] iconif it is not maximized.
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3. Clickthelmageicon on the Free Shapestoolbar, as shown in the following figure, to
open the Open dialog box.

NLhOv e O Ald [geia ][0 =

4. Select the ov-1.bmp image file, as shown in the following figure.

Note: You may haveto select All Filesfrom the Files of type drop-down list to see
.bmp files. You can use .jpg and image formats other than bitmaps.

' Open ‘
Laok in: |_-" Project_1_rpyp j L c E- Preview:
N ov-1.bmp R

File name: |Dv-'| bmp
Files of type: | Bitmap Files (*.bmp.”.dib] ~| Cancel

5. Click Open.
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6. A square graphic icon attached to the mouse pointer appears, as shown in the following

figure:

7. Click the drawing area on the right side of the Rhapsody window to place the image. The

ov-1.bmp appears, as shown in the following figure:
vindaw  Help -8 x
LT IR RS- - R
;”Animate LI H] i} = |“\ ‘ H | =
Sl=gBlWE NLNOLeOAD [remamec]0 Zl~ B |2 2 =428
SUBHARTHE CONOPS
HISSILE ATTACK
o COYERT OP5 ATTACK

COHHUNICATIONS
POSITIONING
%0

ATTACK PATH

DoDAF Tutorial
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8. UsetheZoomto Fiticon E¥, or the zoom setti ng = -1, as needed to view the entire
image.

9. Now that the OV-1 High-Level Graphicis complete, save the architecture model by
choosing File >Save.

Creating the OV-1 Mission Concept Diagram

In addition to the picture for the OV-1, you will add a mission concept diagram to depict the
primary missions and operational nodes for the project. The OV-1 Mission Concept diagram was
created when you set up your Rhapsody project for DoDAF in the Rhapsody browser, as shownin
the following figure:

Enkire Madel Yiew -

- D Project_1

—|-av | Allisws

+ I:l Camponents
- ﬂ Cperationalyisws
- ,gﬂ Operationalyiew
=3 o1
SV oy-1 High-Level Graphic
‘:'1” OY-1 Mission Concept
--[_] Packages
& Defaul:
ﬁ Interfaces
+ & PredefinedTvpes (RO}
=1-[_ Profiles
+-E'5 DoDAF (RO)
+ D Projectlrverviews

+- 8| SystemsViews
+-Tw | Technicalviews

For this architecture model, you will define two operational nodes:

¢ AssessThreat Mission Objective

¢ AttackTarget Mission Objective
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AssessThreat Mission Objective
The AssessThreat Operational Node contains the following operations in sequential order.

1. TheJoint Intelligence Committee (JI C) detects threats.

2. The JC then informsthe Joint Chiefs of Staff (JCS) if JC determines the threat may
require action.

3. JCS can then request additional information such as reconnaissance from the Defense
Airborne Reconnaissance Office (DARO).

4. DARO gathers reconnaissance data, and then sendsit to the Joint Intelligence Image
Processing Service (JIPS) for processing.

5. JIPS sends the results to JCS who then determines if an attack on the threat is necessary.
AttackTarget Mission Objective
The AttackTarget Operational Node contains the following operations in sequential order.

1. When athreat is assessed and determined to be a target, then an attack needs to be:
a. Planned
b. Executed
c. Assessed

2. JCS plans the attack, including choosing an attack method.

3. JCSthen issues attack orders to the Joint Force Maritime Component Commander
(JFMCC).

4. JCS requests the Deep Operations Coordination Cell (DOCC) to perform damage
assessment.

5. JFMCC then executes amissile or covert entry team attack on the target.
6. After JFMCC executes the attack on the target, DOCC reports damage to JCS.

7. JCSissues another attack order or ends the attack by ordering a stand-down.
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From the two Mission Objectives above (AssessThreat Mission Objective and AttackTarget Mission
Objective), you have enough information to create the OV-1 mission concept diagram.

Note

Whenever you begin a new diagram, adding a docbox that includes the name and purpose
(mission) of the diagram can be very helpful.

To draw the six Operational Nodes and show their association with the two Mission Objectives,

follow these steps:

1. Doubleclick OV-1Mission Concept in the Rhapsody browser.

2. Usethe Operational Nodeicon <3 on the Drawing toolbar to draw Operational Nodes
called: paro, g1Ps, Jcs, Jg1c, JFMce, and pocc, as shown in the following figure. As each
node is drawn, the name is highlighted and can immediately be changed.

gOperationalModes:

< —

@

DARD

¢0perationalModes /

E_,/

@

JIPS

«Operatmnaand

La
L

@

JCS

/

Coordinated Land and Sea Attacl:

«hissionObjectives

G

/r AzcessThreat

gMissionChjectives

G

AttackTarget

¢0perationalkodes

é

JIC

¢0perationalkodes

é

JERICC

¢0perationalModes

é

DoCc
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3. Usethe Mission Objective @ icon on the Drawing toolbar to draw the two Mission

Objectives. assessThreat and attackTarget. ASwith Operational Nodes, when each

Mission Objective is drawn, the name is highlighted and can immediately be changed
from the default name.

Note: The Rhapsody DoDAF add-on provides a military clipart image library that
allows you to substitute appropriate images for various elementsin the model.
Right-click the desired element in the model, select Display Options, then
select both Enable Image View and Select an I mage and click the Ellipsis

button .- to browse for images. The military clipart library islocated at in the
<(Rhapsody installation path>\Share\Profiles\DoDAFR\Images subfolder.

4. Usethe Dependency icon s to draw lines from the AssessThreat Mission Objective to

5.

the Operational Nodes DARO, JIC, JCSand JI PS. Also draw dependency linesfrom the
AttackTarget Mission Objective to the Operational Nodes JCS, JFM CC, and DOCC.

Usethe Text icon A on the Free Shapes toolbar to add thetitle coordinated Land and
Sea Attack tothe diagram.

Note the following:

*

You may find it helpful to turn on the grid and enable snap to grid when drawing the
diagram. The grid is turned on using the i icon, and snap to grid is enabled using the L
icon.

In order to change the name of an operational node or activity, ssmply double-click the

name and it will become editable. You can aso double-click the node or activity to open
the Features dialog box, and then change the name in the name field.

If you want to completely delete anything you've drawn in the diagram, right-click the
item and select Delete from Maodel.
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Now that the OV-1 Mission Concept diagram is drawn, add descriptions to the Mission
Objectives.

To add a description to a Mission Objective, follow these steps:

1. Double-click the Mission Objective in the OV-1 Mission Objective diagram to open the
Features dialog box, as shown in the following figure:

Mission Objective : AssessThreat in Dperatiunal\fiewl’% 3|

General lHeIatiDns] Tags ] F'mpelties]

M ame: |sszessThreat L
Stereotype: |

[]
Main Diagram: | ﬂ

Extenszion Points:

Mame Mew

Delete

Dezcription

The &AssessThreat Operational Mode
contans the following operations m
sequential order. The Joint Inteligence
Cotnnittee (JIC) detects threats. The JIC
then mformes the Jomt Cliefs of Staff (JC35)
1if JIC determines the threat may require
action. JCS can then request additional hdl J

Locate | 0K ‘ |

2. Using the Ctrl+C (copy) and Ctrl+V (paste) keystrokes on the keyboard, copy and paste
the Mission Objective descriptions (starting with AssessThreat Mission Objective)
presented earlier in this section of the tutorial into the description area of the Features
dialog box for each Mission Objective. You may have to touch-up the text for formatting
purposes.

3. Click OK to close the Features dialog box.
4. Savethe architecture model using File > Save.

Your OV-1 Mission Concept diagram is now complete. Aswith the OV-1 High-L evel Graphic
diagram, alink from the Oper ational View package to this diagram was automatically added for
you when the DoDAF project was created.
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Creating the OV-5 Mission Objective Model Diagram

The OV-5 Mission Objective Model diagram is used to display the operations that are normally

conducted in the course of achieving amission. Based on the Mission Objective descriptions from
the previous section, you have enough information to create the OV-5 Mission Objective M odel

diagram for the Mission Objectives in the model.

The OV-5isclosely associated to the Mission Objective, and in practice, each Mission Objective
in the OV-1 Mission Concept diagram will have an OV-5 associated with it. Use an activity
diagram to capture the OV-5 information. Focus only on the Attack Tar get Mission Objective;
you can create an OV-5 for the AssessT hreat Mission Objective on your own as an exercise. The
OV-5you createfor the Attack Tar get Mission Objectivewill later serve asaguide for developing
the Event Trace Descriptions (OV-6c) for the Mission Objective.

To create the OV-5, follow these steps:
1. Right-click the Attack Tar get Mission Objective, and select New OV-5.

2. A new window appears, as shown in the following figure:

X

B O
=@
@ O
i~}

R
-, o
(o) &
¥ #
3 (]

o O

d |

S¥|0v-1 HighL..] % 01 Missio..| 2] Operational...
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3. Right-click anywhere on the drawing area and select Diagram Properties. The Diagram
Properties dialog box opens.

4. Onthe General tab, select the Analysis Only check box, as shown in the following
figure:

0¥-5: O¥-50fAattackTarget in AttackTarget *

E3 &

General lHeIatiDnsl Tags ] F'n:nperties]

Marne: | J
Stereotype: | J

I Analyzis Dnly

Dezcription:

\
:< I } .
Locate ‘ 0K | Apply ‘

5. Click OK.

6. A prompt appears asking you to verify the operation. Click OK.
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Based on the AttackTarget Mission Objective description, you know the basic flow of operationsis
to:

1. Createthe attack plan.

2. JFMCC carries out the attack and reportsto JCS.

3. DOCC performs damage observation and reportsto JCS.

4. JCS starts another phase in the attack plan or decides to end the attack by standing down.

The completed OV-5 activity diagram is shown in the following figure.

I

( createsttackPlan )

¥

I

) 4 ¥

=) =)

¥ ¥
cresteAttackRepor ‘ { createtbserveReport

¥

F
[ azzezsAftackResuts j

yle} /l 54
[nel endattack i '.i{ﬂandDu:uwn j—p@
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In the activity diagram, the flow of execution is asfollows:

Note

Whenever you begin a new diagram, adding a dochox that includes the name and purpose
(mission) of the diagram can be very helpful.

1. Creating an attack plan (createAttackPlan in the diagram).

2. After the attack plan is created, a Fork Sync Bar is used to show that the:
a. Attack (attack)
b. Creation of the attack report (createAttackReport)
c. Observation (observe)

d. Creation of the observation report (createObserveReport)

All happen simultaneously

e. A termination state is added to show the end of the simultaneous actions.
f. The attack results are assessed (assessAttackResults)
g. A decision to continue the attack or stand down happens (“endAttack” in diamond)

h. A “no” response to the “endAttack” question repeats the attack scenario (transition
line)

i. A “yes’ responseresultsin astand down (standDown) and terminates the flow of
execution (termination state ¢sy).
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To create the OV-5 diagram, follow these steps:

1

10.

11.

Usethe Action icon ¢ on the Drawing toolbar to draw the operations:
createAttackPlan, attack, createAttackReport, observe, createObserveReport,
assessAttackResults, and standDown.

Note: You can right-click any mission objective and select Edit Text to create or
change the name.

Use the Condition Connector icon =+ on the Drawing toolbar to draw the conditional
branch below the assessAttackResults operation.

Use the Termination Stateicon sy on the Drawing toolbar to draw the termination state
next to the standDown operation.

Usethe Fork Sync Bar icon # on the Drawing toolbar and click and drag horizontally
from left to right to draw the fork below the createAttackPlan operation.

Use the Join Sync Bar icon %= on the Drawing toolbar and click and drag horizontally
from left to right to draw the join line above the assessAttack Results operation.

Use the Action Block icon on the Drawing toolbar to draw the box around attack,
createAttackReport, observe, and createObserveReport. You use the action block
because there are multiple control paths that execute the actions within the block.

Draw atermination state below the join sync bar to indicate the end of the actionsin the
action block.

Use the Default Flow icon *s on the Drawing toolbar to draw the default arrow to the
createAttackPlan action and the ForkSync Bar.

Use the Activity Flow icon *, on the Drawing toolbar to draw the remaining flows
shown in the diagram.

Note: To change the Activity Flow line style (curved splines, straight, rectilinear, and
so forth) right-click an Activity Flow line, and then select Line Shape and
Rectilinear.

Double-click an Activity Flow to add the yes and no transition labels (located in the
Guard field).

Save the completed architecture model using File > Save.
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Note

To change the name of an operation, double-click the object (action box, condition
connector, and so forth) to open the Features dialog box, as shown in the following figure.
Change the name in the Action field of the Features dialog box, and then click OK.

Action : createAttackPlan in O¥-50fAttackTarget [

General ]Flelations] Tags ] F'ru:uperties]

Marne: |create.ﬁ.ttackF'Ian L

Sterentype: | ﬂ

Action

createldttackPlan I
[rescription:

|

Although it is not required, it is possible to use swimlanes in the activity diagram to show which
operational nodes are responsible for performing the operations. Swimlanes are added using the
Swimlanes Frameicon [ and the Swimlanes Divider icon [4] on the Drawing toolbar. You
assign operations to operational nodes when you create the OV-6¢ Event Trace Descriptions.
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Creating the OV-2 Operational Node Connectivity Diagram

The Operational Node Connectivity diagram shows the operational nodes and the needlines
(“communication pipes’) between them. A diagram captures the OV-2 information for the
AttackTarget mission objective. You can create an OV-2 for the AssessT hreat mission objective
on your own as an exercise. Several stepsin creating this architecture product are automated by
helpers. In this section, you use a helper to create an initial OV -2 that includes the mission
objectives (AssessThreat Mission Objective, AttackTarget Mission Objective).

Later, after creating the OV-6¢ Event Trace Description diagram, needline information is added
to the OV-2 diagram.

To create the initial OV -2 diagram, follow these steps:

1. OpentheOV-1Mission Concept diagram from the Rhapsody browser, or by selecting the
OV-1 diagram tab from the bottom of the diagram paneif it is already open.

2. Right-click the AttackTarget Mission Objective and select Create OV-2 from Mission
Objective. If you do not see Create OV-2 from Mission Objective menu item, see
Manually Adding the DoDAF Helpers in the Troubleshooting section.

3. Click OK to dismiss the confirmation message.
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In the browser, expand MissionObj ectives, Oper ationalNodes, OV-1s, and OV-2s, asshown in
the following figure.

B o] Operationalview
- @ MissionCbjectives

t AssessThreat
- iAtbackTarget:

+-"s) Dependencies
* Hyperlinks
B g
—|-{*3 OperationalModes
+ {23 DARD
+- ) DiOCC
+-{a) ICS
+ {23 FMCC
+-3 JIC
+ {33 TIPS
- ow-1s
9| o-1 High-Level Graphic
<:|1'..r -1 Mission Concept
-] on-2s
Y| ow-z AttackTarget
+-1771 Packanes
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To complete thisinitial OV-2 diagram, follow these steps:

1. If the OV-2 AttackTarget diagram is not already open, open it by double-clicking on its
icon in the Rhapsody browser.

2. Drag and drop each of the blocks: DOCC, JCS, and JFM CC from the browser onto the
diagram. The following figure shows the initial OV-2 diagram:

Entire Model Yiew - «Djémtional 1 «UpeEiSonalNode» 1 oOperational
o Project — poce
—|-av| Alliews
+-gv| Bllview
+ [:l Cornponents
= ﬂ Operationalviews
= gﬂ Operationalview
= @ MissionObjeckive
+ AssessThre:
+ AttackTarge
-3 Operationaliod:
+-{2) DARC
+-(3) DOCC
+42) 105
+£E) IFMCC
+ {2} 11T

- Y| ov-1s \
S| Oy-1 High-Lr | s
SV ov-1 Missior| | 2o

=Y oy-2s

O}
2 av-z attack 1
4

B0 @o®l .

«Operational
DaRO

)

¢ <54

«Operational 1 «Operational
JIPS JERCE

+-[] Packages
4[] Profiles el
| - .

L
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Note: To change the appearance of an operational node, select one or more nodes and
right-click one. Select Display Options and clear the Enable Image View
check box or select the Select An I mage radio button and click the Ellipsis

button | to browse to the desired image, as shown in the following figure:

Display options of JCS

General ] Attributes ] Operations ]

Digplay name

(" Fullpath ¢ Relative © Wameonly * Label

v Show Stereatype Label Compartments. .

Image “iew
v Enable Image Wiew

* Use Associated Image © Select An Image
Image File Path;

|$D MEOO T PrafileshD oDAF I mages operatio J

Advanced...

Parts

Show Mew Ports [ Show Ports Interfaces |

K | Cancel Help

Note: Needlines connecting the operational nodes will be added later in the tutorial

after the OV-6¢ Operational Event Trace Description diagram has been
created.

3. Savethe architecture model using File > Save.
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Creating an OV-6¢ Operational Event Trace Description

The Operational Event Trace Description diagram isavertical time-ordered diagram of the
information exchanges between operational nodes during a particular scenario. Use a sequence
diagram to capture the OV-6¢ information. Use the OV-5 diagram as a guide to create the OV-6¢
diagram. Each Event Trace Description focuses on an individual operational scenario.

Several OV-6¢ diagrams are used to describe the various operational scenarios, including nominal
operations as well as failures and exceptions. In this exercise, one scenario is added to your
architecture model. This scenario shows the event trace for a two-phase attack and allows you to
explore the complete functional flow shown in the OV-5 diagram. You can create an additional
Event Trace Description on your own as practice, if you so desire.

Here, too, you can use a helper to assist you in creating the initial OV-6¢ diagram.
To create theinitial OV-6¢ diagram, follow these steps:

1. Right-click the AttackTarget Mission Objective from either the Rhapsody browser or in
the OV-1 Mission Concept diagram.

2. Choose Create OV-6c¢ from Mission Objective. If you do not see this menu item, see
Manually Adding the DoDAF Helpers in the Troubleshooting section of this tutorial.

| Open Main Diagram
| Make an Objeck

Display Options ...

Zuk

Copy
Copy With Model

Remove From Yiew
Delete Fram Model
Farmat. .,

sttag|  Make Defaulk...

—  Locate

— Image Yiew 4
Create OY-2 from Mission Objective

I,g #  Create OW-5c from Mission Objective -

54

DoDAF Tutorial



Getting Started with DoDAF Architecture

3. Thenew OV-6¢ diagram will be displayed, as shown in the following figure. Click OK to

dismiss the confirmation message.

JCS | JFMcc | pocc |

JCE JEMCT nococ

|
|
|
|
£ |
|
|

-

« | o] |

4. Open the Diagram Properties dialog box to rename the diagram, enter a description for the

scenario, and change the display settings for the nodes. Right-click a blank part of the
sequence diagram and select Diagram Properties.

Rhapsody
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5. Onthe General tab, change the diagram hameto ovéc Two Phased Attack inthe Name
field, as shown in the following figure:

0¥-6¢ : 0¥6c Two Phased Attack in Operational¥iew ]
.
General l Fielations ] Tags ] Properties ]
M arne: |DVEC Two Phased Attack. || L
Stereotype: | J
Default Package: |Dperati0naNiew j £
Dezcription

The two phased attack scenario shows the
interaction between JCS, JFMCC, and DOCC to
plan, execute, and assess an initial attack, and

then follow up with a second attack before
standing down.

vl
Lucate‘ 0K | ‘

6. Add thefollowing description in the Description field: The two phased attack
scenario shows the interaction between JCS, JFMCC, and DOCC to plan,
execute, and assess an initial attack, and then follow up with a second
attack before standing down.

7. Click OK.
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Before you begin adding the scenario messages to the diagram, refer to the recommended event
trace naming conventions for the messages that go between operationa nodesin the following

table.

Message Type Message Prefix

Request Operational Activity req

Notification and Reporting ev

Review the OV-5 diagram and focus on the first attack sequence. You can identify six operational
activities for the attack sequence:

*

*

*

*

*

*

createAttackPlan
attack
createAttackReport
observe
createObserveReport
assessAttackResults

Keep in mind the operational event trace diagram is time ordered from top to bottom, and which
node is responsible for what part of the mission objective is shown by attaching the appropriate
operational activity to the appropriate node.

To add these operational activity messages to the Event Trace, follow these steps:

1

Space out the JCS, JFM CC, and DOCC nodes by dragging each of them horizontally
across from left to right.

Rhapsody
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&7
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2. Usethe Message icon “y on the Drawing toolbar, draw the createAttackPlan and
assessAttack Results messages on the JCS node. Start drawing on the instance line and
form a“box” that ends on the same instance line, as shown in the following figure. The
message names can be edited as the messages are drawn on the diagram.

Jcs | JFMCC | pocc |

JC5 JFMCC Docc

createAttackPlang

]

Messag

icon attacki

ohserned)

createAttackReport)

createCbs

|
|
|
|
i
|
|
|
|
|
|
|
|
|
|
|
|

assessAttackResults))

I L

R A R

f—
3. Draw the attack and createAttackReport messages to the JFM CC node, as shown in the
figure above.

4. Draw the observe and createObser veReport messages to the DOCC node.

Note: To change a message name after the message has been drawn, double-click the
message name.
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You have now shown the six mission objectives for the attack sequence, identified the nodes that
perform these activities, and provided the proper time ordering of these activities for this scenario.
Next, you need to identify and draw the messages between the nodes where requests for each
mission objective are made.

Also, JCS requests that DOCC carry out the observe mission objective by sending it the
reqObser ve command. By examining the sequence diagram, one can see that JCS requests
JFMCC to carry out the attack mission objective by sending it the reqAttack message.
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To add these request mission objective messages to the diagram, follow these steps:

1. Draw theregObserve() message from JCS to DOCC. The reqObser ve message contains
datain the form of two parameters: Coordinate and Time. These parameters are used
later in the tutorial to create the OV-7.

Note: You do not have to type the “()” parentheses when naming a message without
parameters. Rhapsody does this automatically. Messages that contain

parameters require you to type the parentheses.

2. Draw theregAttack message from JCSto JFMCC. In the parenthesis, add the parameters
Coordinate, Time, and attackType t0 indicate the data being sent to JFMCC, as shown
in the following figure:

Note: To move agroup of messages up or down in the sequence diagram, first select
the group of messages by clicking on them while pressing the Ctrl key. Then

move the cursor over one of the sel ected messages, and while holding the Shift
key, click and drag the selection.

JCS

| createAttackPlang

JFMCC

Doco

| regObserelCoordinate, Time)

| regAttack{Coordinate, Time, attackType

e — — —

i

assessAttackResultsd

i

- vt

attackd

cregteAttackReport()

D B A

obsemed

createChserveReport()
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You have extended the sequence diagram to show how and when JCS requests JFMCC and DOCC
carry out their mission objectives for the attack sequence. The last set of messages that need to be
added are the notification messages, typically indicating the mission objective has been completed.
Examination of the sequence diagram shows that JFM CC sends the evAttack Completed message
indicating when the attack is complete. JFM CC must report it has completed the attack to both JCS
and DOCC. DOCC sends the evObser veCompleted message to JCS, indicating it has completed
its observation.

To add these notification messages to the diagram, follow these steps:

1

Use the M essage icon on the Drawing toolbar to draw the evAttack Completed message
from JFMCC to JCS and also from JFMCC to DOCC. In the parenthesis, add the
parameter attackstatusReport t0 indicate a status report is being sent to both
operational nodes.

Use the M essage icon on the Drawing toolbar to draw the evObser veCompleted
message from DOCC to JCS, as shown in the following figure. In the parenthesis, add the
parameter observeReport t0 indicate a status report is being sent to JCS.

JTE

JEMCE Docc

| createAttackPlang

reqObseneiCoordinate, Time)

o— 4 — —

|

|
I I
| regAttackiCoordinate, Tirme, attackType) |
| | L
| — . |
| l<— attac |

ohsernel)

: L__ createsttackReport() :
| | evaAttackCormpletediattackStatus |
[ ehttackCompletediattackStatus | Reporl) |
= Fepaorfy
| | =
| | l_ createdbseneRepal
| | L]
I epObsereCompleted{obserneRepar) |
- I 1
| | |
L | |
| assessAttackResultsd | |
r— | |
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With these messages added, you have now completed the interaction between JCS and JFMCC
and DOCC in carrying out the first phase of the attack sequence. You can now focus on the second
phase of the attack sequence. The second phase of the attack is identical to the first, except that
JCS does not create a new attack plan.

To add the messages for the second phase of the attack, follow these steps:
1. Using the vertical scroll bar, scroll down in the OV-6¢ sequence diagram.
2. Create the second phase of the attack sequence by repeating (redrawing) the first phase

attack sequence, but omit the createAttack Plan mission objective, as shown in the
following figure:

:| assesshttackResults) |
|
|

reqhseneiCoordinate, Time)

regattacki{Coordinate, Time, attau:kTypgl}

attackd

ahsered
createpttackReportd

tie )

| evattackCompletediattackStatus

evdttackCompletediattackStatus | Feport)
Feport)

createChsernveRepo

I

e}xOhseweCnmpleted{nhseweRepnn}
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Sequences like this attack sequence that repeat can be captured by using what iscalled a
referenced sequence diagram, which allows a sequence to be drawn once and then reused multiple
times in other sequence diagrams or the same sequence diagram.

To complete the scenario, you need to add some additional messages after the second phase of the
attack to address the stand down sequence. For stand down, JCS sends the reqgStandDown
message to JFMCC and DOCC, then both JFM CC and DOCC execute their SandDown mission
objectives, and finally send a notification message back to JCS.

To complete the scenario for this OV-6c, follow these steps:

1. Using the vertical scroll bar, scroll down in the OV-6¢ sequence diagram.

2. Add the remaining sequence as shown in the following figure.

3. You can add the StandDown note shown in the diagram using the Note icon [ on the
Common Drawing toolbar, as shown in the following figure:

Jcs | JFMCC

|
|
|
|
|
|
| evAttackCompletediattackStatus | Report)

Report)

| pocc |
T |
| attack( |
— |
}_ | obserel
I"_ createAttackReports |
| evittackCompletediattackStatus |
| |
| ]
I L__ createOhserveRepart?
epObseneCompletediobserneRepar |

assessAttackResults0

)

|

|

<
|_
.

reqstandCiown

|
| reqStandDownd

|
|
|
|
|
-

evDOCCStandDownCompleted(

StandDoan
| standDowni
standDown)

|
|
|
|
L ev._IFMCCBtananwnCnmpleted(}!
[~ I
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The last step in creating the OV-6¢ isto change some of its printing settings. Since thisdiagram is
rather tall and narrow, you need to change the print settings to make it look better for when it
appears in agenerated DoDAF report.

To change the print settings, follow these steps:

1. Right-click an empty areaof the diagram and choose Printing > Print Settings. The Print
Settings dialog box opens, as shown in the following figure:

OVoc Two Phased Attack Print Settings

Origntation

+ Partrait " Landscape
Scaling %

& ddustto: [70 % nomal size

(" If diagram spans across multiple pages, shiink to fit on single page
Optionz
[ Print background colar

Iv Add diagram name in header

Custam header: |

[v Add page number in footer

Cusztom footer: |

[ ¥ Eave settings in the diagran

Default... (] | Cancel Help

Set the Scaling to 70% of normal size.

Select Save settingsin the diagram.
Click OK to close the Print Settings dialog box.

a b~ w N

Move your cursor to an empty area on the diagram, right-click, and choose Printing >
Print Preview. The Print Settings dialog box opens.

S

If necessary, repeat these steps until you are satisfied with the scaling of the diagram.

7. Besureto save the architecture model using File > Save.
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Creating an OV-7 Logical Data Model

OV-7 Logical Data Moddl is aclass diagram that shows the relations among Informational

Elements (data classes).

To create the OV-7 informational elements coordinate and missionTime, follow these steps:

1. Right-click OperationalView in the browser and select Add New > Oper ational
Diagram > QV-7, as shown in the following figure:

T Il..u' é’(_"lnn:ral'inn.:-“n'ipl.ui
¢ Packl Features

f-27 Profi

- 8% | Sysh
H-TW| Tech

Features in Mew Window

Add Mew
Open Main Diagram ...

Search, .,
Search inside. ..
References...
Unit

“hange to

Generate Operationalview
Edit Operationaltiew
Roundtrip Operationalview

Edit Tvpe Crder. ..

Configuration Management
Farmat. .
Associate Image

Delete From Model

I

2

L
createsttackPlan)
{...
| reqObserve(Coordingte, Time)
Package
Object
Class
Type
Interface
Camment
Conskraink
Requirement
ControlledFile
InformationElernent EitaligthihnpEEL
PhysicalDataType
InformationExchange
PerformanceParameter
Al View Diagram ¥
Cperational Diagram r Operationalview
Operational Element * oh-1
Swskem Diagram 4 -2
Syskemn Element ¥ oN-3
Technical View Diagram # ov-4
'r_l CV-63
\_‘ OW-Be
.l R T N
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2. Now open the OV-7 diagram and use the | nformational (Data) Element icon g onthe

Drawing toolbar to draw the informational elements coordinate and missionTime, 8S
shown in the following figure:

wlnfarmationElements zInformationElements
Coordinate missionTime

3. Usethelnformational (Data) Element icon to draw the informational elements

Latitude, Longitude, Hours and Minutes and use the Composition Lineicon ¢ to
draw connecting lines between the informational elements. Next, draw the informational
elements attackStatus, attackType, aNd observeReport, as shown in the following

figure:
«lnfarmationElements «InformationElementx
Coordinate missionTime
1 1 1 1
i — . -
1 1 1 1
““"fﬂf'_""aﬁf""E“’—' «InfarmationEle «InformationEle sInfarmationEle
Latitude Longitude Hours

Minutes

alnformationElements

attackStatusRepo

wlnformationElements

attackType

wlnformationElements
ohserveReport
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Adding Needline Information and Mission Objectives to the OV-2

The OV-2 created earlier did not include needlines. The reason for thisisthat the information
needed to create the needlines is contained in the Oper ational Event Trace Description diagram
(OV-6¢) which aso includes the information necessary to assign mission objectivesto each of the
operational nodes in the OV-2 diagram.

In the following steps, one of the DODAF helpersis used to assist you in adding the needlines so
that you do not have to enter the information manually. Before you can update the OV-2 diagram,
you must change the type (PrimitiveOper ation, TriggeredOper ation, Event) of some of the
messages in the OV-6¢ diagram.

Messages are represented by arrows between the operational hodes in the OV-6¢ diagram.
Different messages show different things. PrimitiveOper ation is the default type of message and
shows a mission objective being executed, such as attacking atarget. PrimitiveOper ation
messages occur on one operational node only and are not sent to others. All the messages drawnin
the OV-6¢ diagram were PrimitiveOper ation messages and some must be changed.

Communication between operational nodes are called ‘ Event’ messages. All Messages sent
between operational nodes must be changed from type PrimitiveOper ation to type Event.
Afterwards the diagram must ‘realize’ al of the message type changes.

By realizing these messages, you're indicating that you want the messages to be formally
recognized as elements in the architecture model . Without realizing the messages, they are treated
as informal notes rather than actual elements of the architecture model.
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To change the appropriate message typesin the OV-6c¢ diagram, follow these steps:

1. Openthe OV-6c Two-Phased Attack sequence diagram from the browser if it is not
already open.

2. Right-click the reqObser ve message and select Features. The Features dialog box opens.

3. Change the Message Type from Primitive Oper ation to Event, as shown in the following

figure:
Message : reqDbsery |:|
~
General lHeIatiDns] Tags ] Plaperties]
Narme: |rqubsew L
Stereotype: | j
fezzage Type: |Event _‘[\lf
: Primitivel peration .
Sequence: Triggered] peration
Argurments: Exvent
 Return Value: | e
S )
Locate | oK | ‘

4. Repeat the above steps for ALL occurrences of the following messages:
a. reqObserve
b. regAttack
c. evAttackCompleted
d. evObserveCompleted
e. reqSandDown
f. evDOCCSandDownCompleted
g. evJFMCCSandDownCompleted
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Note

Before proceeding, review the OV-6¢ diagram and make sure all the messages going from
one operational node to another have a hollow arrowhead =+, and the mission objective
messages (starting and ending at the same node) have a solid arrowhead st .

To realize the messages in the OV -6¢ diagram, follow these steps:
1. Select dl the elementsin the diagram using Edit > Select > Select All.

2. Realize the messages using Edit > Auto Realize. After realizing, you will see afolder in
the Operational View named Events, as shown in the following figure:

= D Project_1
+ |:| Campanents
--[_] Packages

+ B allview
& Default

ﬁ Interfaces

- & Cperationaliiewm
+-[E] DocBoxs
+ Events

+-£23 OperationalNodes
9V oy-15
¥ oy-zs
2] ov-aes

3. Savethe architecture model using File > Save.

][] [+

Note

If you create additional OV-6¢ diagrams, Rhapsody provides a shortcut for typing in the
names of messages you have previoudly realized. After drawing the arrow and leaving the
default message name (message_0), right-click the message name and choose Select

M essage to see alist of previously realized message names.
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Now that the messages have been realized, you can use the helper to update the OV-2 diagram
with the needline and mission objective information in the OV -6c.

To update the OV -2, follow these steps:

1. Select the OV-6¢ Two Phased Attack sequence diagram from the Rhapsody browser.

2. With the mouse over the OV-6¢ icon, right-click and choose Update OV-2 from OV-6c.
If you do not see this menu item, see Manually Adding the DoDAF Helpers in the
Troubleshooting section of this tutorial.

After afew moments, you will be prompted with a message dialog box indicating the OV-2
diagram was updated. You can now look at the OV -2 diagram and see what has been added to it.

To see what has changed, follow these steps:

1. Openthe OV-2 AttackTarget diagram by double-clicking onitsicon in the Rhapsody
browser, or select it from among the diagram tabs at the bottom of the screen if itis

already open.
1 wOperationalt 1 «Operationalt 1 wOperationalt
JIC JCE Cocc
ACS
Hcreate. Hobsere[]
B evitta... Hereate. .
& evobs... & reqoh...
Hasses.. B eyatta
1 wDperationalt W asses.. ;:uJFIuH.?C'_I
DARD & evDO...
WevFM.. hpoco
L]
1 wOperationalt
1 «Operationalt JFMCC Jos
JBS Hattack [
Screate...
B re At
Enrﬁm
pDOCC
[l
pJFMCC
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2. Re-arrange and stretch the nodes so that the diagram resembles the following figure:

1 aOperationalModex 1 aOperationalModex
JCS JEMCC

W createattackPlan b attack
EevﬂxﬂackCnmpleted BcreateattackRepart
B evOhserveCompleted B regattack

B assessAttackResults pJFMCC pJCS| BEreqStandDown

B evDOCCStandDownCormp... [ ] [ gstandDown

B ev FMCCStandDownCom...

_
pDOCT

pJCEl_l

1 «DperatﬁalNodex %
Docc

B ohsere
BcreateObsernveReport
B evattackCompleted

B reqObserve

L]
B reqStandDown nJFMCC poocc
& standDawn

3. Tomoveanode, simply click it and drag it (while holding down the mouse button).

4. Tostretch anode, select it by clicking on it and then move the cursor over any of the eight
control points and drag the point while holding down the mouse button.

5. To move aport, which are the small boxes on the edges of the nodes, simply click it and
drag it as you would a node.

Asyou look inside the OV-2 nodes, you will see the mission objectives have been added to the

appropriate node, and are marked with the operation symbol &. Other message labels you added
to the OV-6c are visible, and these are related to the needline and information exchange between
nodes.

Note

If any of the information exchange messages (reqObserv, reqSandDown) appear as
mission objectives (observe, standDown) in your model, see Fixing the Model if Messages
Appear as Mission Objectives in the Troubleshooting section of this tutorial.

Rhapsody 71



Rhapsody DoDAF Tutorial

Focus on the JCS node. Inside the JCS node, you see the createAttackPlan and assessAttack
mission objectives. Along with the mission objectives, you see four notification messages.
evAttack Completed, evObserveCompleted, evDOCCSandDownCompleted, and

evJFM CCSandDownCompleted. While the mission objectives are performed at the JCS node,
the notification messages imply an information exchange with the DOCC or JFM CC node.

Notice the two small boxes on the edge of JCS. The boxes are the JCS ports; oneis labeled
pJFM CC and the other pDOCC. The pJFM CC port was created to contain the information
exchange between JCS and JFM CC. The naming convention for portsis

p<OperationalNodeClassName>.
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To see what information flows through the pJFM CC port, double-click the port and look at the
Contract tab in the Features dialog box, as shown in the following figure. The contract describes
the type of information exchange.

Port : pJFMCC in JCS X
~

General Contract lHeIatiDns] Tags ] Propetties]
Frovided Interfaces

|_] Provided Add...
-8 UCS_IFMCE

B evittackCompleted

E evl FMCCStandDownCompleted

Hi

Required Interfaces

|_71 Required Add...
-8B UFMCC_ICS

E reqittack —_—
B reqStandDown

Locate ‘ OK | |

JCS has one provided interface with JFMCC named iJCS _JFM CC. The naming convention for
interfacesis i<ReceiverClassName> <SenderClassName>. TheiJCS JFMCC interface

contains the two messages evAttack Completed and evJFM CCSandDownCompleted. By
providing thisinterface, JCS provides the ability to receive these two messages sent from JFM CC.
JCS aso has arequired interface with JFMCC named iJFM CC_JCS. This interface contains the
two messagesregAttack and regSandDown. By requiring thisinterface, JCS requires JFMCC to
be able to receive these two messages. These contracts are consistent with the manner in which
you created the OV-6¢ diagram.
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Examine the pJCS port on the JFM CC node. Notice that the provided and required interfaces on
this port are the reverse of those on the pJFM CC port. The figure pJCS Port Contracts shows the
port contracts for the pJCS port. The complementary nature of the contracts of these two ports
shows the interfaces are consistent on both ends. Examine the ports on the diagram to ensure they
are also complementary.

Port : pICS in JFMCC X
L

General Contract lHeIatinns] Tags ] Propertie&]

Provided Interffaces

|_ Provided Add..
-8 FMCC_ICS

B reghttack
B reqStandDown

[

Fiequired Interfaces

|_1 Required Add..
-8 UCS_IFMCC

B eviitackCompleted

B evlFMCCStandDownCompleted

Locate ‘ 0OK | |
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Connecting the Ports

Now that you have examined the changes to the OV -2, and seen how the mission objective
information and needline information have been added, draw the links between the nodes and
connect the ports.

To draw the links, follow these steps.

1. Select the Needlineicon %y on the Drawing toolbar.

2. Connect the ports as shown in the figure by clicking on one port, dragging the line to the
connecting port, and releasing the mouse button, as shown on the following figure:

1 aOperationalModex 1 aOperationalModex
JCS JEMCC

W createattackPlan b attack
EevﬂxﬂackCnmpleted BcreateattackRepart
B evOhserveCompleted B regattack

B assessAttackResults pJFMCC pJCS| BEreqStandDown

B evDOCCStandDownCormp... [ [ gstandDown

B ev FMCCStandDownCom...

phocc

pJCS

ocheratlonaINodex

DocC

B ohsere
BcreateObsernveReport
B evattackCompleted

B reqObserve ]
B reqStandDown nJFMCC poocc
& standDawn

1
LT

3. Savethe architecture model using File > Save in the Rhapsody main window.

Note

You must repeat the stepsin this section of the tutorial for any other OV-6¢ diagrams you
create.
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Adding Information Exchanges

Now it istime to add the information exchanges into the OV-2 diagram that represent the
missionTime and Coor dinates parameters.

To create the information elements you plan to use, follow these steps:

1. For thefirstinformation element, you must right-click Oper ationalView in the Rhapsody
browser and select Add New > | nfor mationElement, as shown in the following figure:

R I I S (PN [ FI

Features
Features in Mew Window

Add Mew
Open Main Diagram ...

Search...
Search inside. ..
References, ..
Lnik

Change to

Generate Operationaliiew
Edit Operationalview
Roundtrip Operationalview

Edit Type Order...

e R R

Configuration Management
Farmat. ..
Associake Image

Delete From Model

4

L

(]

=
Package
Cbject
Class
Tvpe
Interface
Camrmenkt
Zonskraink

Requirernent
ControlledFile

B ev
Bas
Bas

i’

"

InformationElement L\b |

PhysicalDataType
InformationExchange
PerformanceParameter

Al Wiew Diagram
Cperational Diagram
Cperational Element
Swskem Diagram
Syskem Element

»
b
»
»
»
Technical Yiew Diagram ¥

.

2. For dl additional information elements, right-click Infor mationElements and select Add
New I nformationElement, as shown in the following figure:

- gﬂ Cperationalview

+ ﬂ' Informat
+ @ MissionObjectives

+ % Meedlines

(.
dd Mew Inform

——

(]

ationElzment
[

{n}

3. Createthefollowing information elements: attackstatus, attackType, Coordinate,
Hours, Latitude, Longitude, Minutes, observeReport, and missionTime.

76

DoDAF Tutorial



Getting Started with DoDAF Architecture

4. Using the information exchange tool %, move the mouse pointer over the needlinein the
diagram between the JCS and JFM CC Operational Nodes, until the mouse pointer
assumes the appearance of a bullseye -s- and then click the needline.

5. Anarrow appears accompanied by ablinking cursor. Type the words coordinate,
missionTime, attackType, & shown on thefollowing figure.

Note: To remove the <<InformationExchange>> label, right-click it and select

Display Options. Clear the <<flow>> keyword or Ster eotype check box.

6. Repeat the previous two steps to create two information exchanges between the JCS and
DOCC operational nodes, and another information exchange between the JFM CC and
JCS nodes, as shown in the following figure:

1 «OperationalNodex 1 gOperationalModex
JCS JEMCC
B createdttackPlan B attack
& evAttackCompleted W createAttackRepart
& evObsereCormpleted B regAttack
H assessAttackResults pdFRACC pdCS| B reqStandDown
& evDOCCStandDownCormpl.. [ —» < [ 18 standDown
! attack=tatusReport
ewFMCCStandDownGorn,., | “oordinate kStatusRep
rrissionTirme,
attackType

pDOCC

Coordinate, missionTime

ohsereReport

D—)—(—[]

pJCS

aDpemhona

Modew

B obsene

E createObszernveRepon
B evAttackCompleted
B reqObserve

B8 regStandDown

B standDown

-
s

attackStatusReport i

L

L
pJFRCC phoOCC
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7. To change the direction of the information exchange (shown by arrows), double-click the
information exchange arrow, and in the dialog box that appears, select the appropriate
direction from the Direction drop-down list, as shown in the following figure:

Information Exchange : JCS_JFMCC in Operational¥iew =]
A
General lDetaiIs] Tags ] F'n:nperties]
M ame: [JC5_JFMCC H
Stereotype: | J
Flow Endz
Endl:  |pIFMCC in Operationah/iew::)C | =
EndZ: |pJES i DperatiunaNiew::JFMEj
Direction: |From pJFMCC To pJCS |
Dezcription:
[ae]
Locate ‘ oK | ‘
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Adding Another OV-2 Diagram

At this point you will now add another OV -2 diagram. Parts of this diagram are used for
developing the SV-4 Systems Functionality Description at alater point.

1
2.

In the browser, expand MissionObj ectives.

Right-click attack Tar get and select Create OV-2 from Mission Objective, as shown on
the following figure:

=g PSS

+ [
3

+ % Meed
F-E Oper
=23 Opet
0

-
—_

PERE2 2 (OEE0

PN % TSR PR PR R

-] on-7
‘ackages
rofiles
wskemsYiew
‘echnicalyie

Add Mew

Search...
Search inside. ..
References. ..

Create Unit

Change to
Expose Class

Open OY-5

Delete OY-5

Generate Mission Objective
Edit Mission Objective

Edit: Type Crder...
Associated Image

Configuration Management

Delete From Maodel

Create OY-2 fram Mission Objective
Create OW-6c from Mission Objective

In the browser, expand Oper ationalNodes and drag the JFM CC operational node into the
drawing area.

Customize the JFM CC operational node as it exists in the drawing pane to look as you
desire. To achieve the recommended view, right-click the JFM CC node and select
Display Options. Clear the Enable Image View check box and click OK. Thisview
alows you to see all the operations the node contains.

Using the Operational Activity tool &, insert three operational activitiesinto the diagram.
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6. Namethe operational activities opattack, opCreateAttackReport, aNd opStandDown, aS
shown in the following figure. The “op” prefix stands for “ operation,” and keeps

Rhapsody from confusing like system function and operation names when generating
code.

7. Using the Realizeicon 4, on the Drawing toolbar, draw arealize line from the JFMCC
Operational Node to each operational activity.

1 «Operational Nodex

pJCS JEMCC

& attack):void

E createattackR epartt:vaid
B regattackivoid

8 reqStandDown ) void

& standDownivaid

zRealizes

.
4Realizes «Realizes

OperatiogslActivi :
«0peratiopalActivitys «OperaticmalActivitys

opCreateAttackReport it opStandDown

Note

The above example was described for informational purposes. If you want to build a correct

and working model, you must repeat the steps above for all of the other operational nodesin
your mode!.
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Creating the OV-6b Operational State Transition Description

The last diagram created in thistutorial is the Operational State Transition Description diagram
(OV-6b). The Operational State Transition Description diagram uses multiple state machine
diagrams to show how an operational node responds to various input events. Statecharts are used
to represent the Operational State Transition Description. In this tutorial, the DOCC nodeisthe
focus point. You can create Operational State Transition Descriptions for other operational nodes
0N your own as an exercise, if you wish.

Before you create the statechart for DOCC node, think about what the modes of operation are for
the DOCC node. A good way to identify the modes of operationisto look at the OV-6¢ diagrams,
paying attention to the mission objectives, which often indicate a mode of operation. Also, the

messages going between nodes typically indicate when the message receiver should enter a new
mode.

Note

Unlike OV -6¢, which reflects many nodes across one mission objective, the OV-6b reflects
one node across all mission objectives.

From viewing the OV-6¢ diagram, it can be seen that DOCC may be awaiting orders, observing,
preparing an observation report, or standing down. This means there are four main modes (states)
in your statechart, one for each of the modes you identified.

To create the statechart and draw the modes, follow these steps:

1. Openthe OV-2 AttackTarget diagram by double-clicking on itsicon in the Rhapsody
browser, or by selecting it from among the diagram tabs at the bottom of the window if it
is aready open.

2. Click the DOCC nodeto select it.

3. Right-click the DOCC node and select New OV-6b.
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4. Using the State icon [—] on the Drawing toolbar, draw the four states. awaitingorders,
Observing, CreatingObsReport, and standingDown, as shown in the following figure.
Typein the names of each state as you draw them.

AwraitingOrders Obserning |

CreatingObsReport |

| standingDown |

With the states drawn, consider the logic for the transition labels. The logic that moves you from
state to state can include an event trigger and a guard condition. The operations that must be
performed as you change states are called actions. The logic clearly startsin the AwaitingOrders
state.

From AwaitingOrders, DOCC moves to the Observing state when it receives the reqObserve
message. To reflect this you will add the label reqobserve to the transition that connects the
AwaitingOr der s state to the Observing state.

Upon entering the Observing state, you will transition to the CreatingObsReport state when the
evAttackCompleted message isreceived. So, you will add the label evattackcompleted to the
transition that connects the Obser ving state to the PreparingObsReport state.

From PreparingObsReport, DOCC can only change to the AwaitingOr der s state. DOCC
changes to the AwaitingOr der s state when it has compl eted creating the observation report, and it
will also send the evObser vationCompleted message to JCS.
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The following transition label will be added to the transition from the PreparingObsReport state
to the AwaitingOrder s state:

/OPORT (pJCS) - >GEN (evObserveCompleted (observeReport) )

which trandatesto 'generate the evObserveCompleted() message on the JCS port and
send the data observeReport with the message'. By sending the evObserveCompleted()
out of the pJCS port, it is certain JCS will receive this message.

You must now consider the transitions between the AwaitingOr der s state and the StandingDown
state. DOCC will transition to StandingDown when it receives the regSandDown message. So,
you will add the label regstandpown to the transition that connects the AwaitingOr der s state to
the StandingDown state.

Thefinal transition is from StandingDown back to AwaitingOrders. DOCC will make this
transition when it has completed standing down. So, you will use the following label on the
transition that connects the SandingDown state to the AwaitingOr der s state:

/OPORT (pJCS) - >GEN (evDOCCStandDownCompleted () )

which trandatesto 'generate the evbDoCCStandDownCompleted() message on the JCS
port '. Recal that by sending the evDOCCStandDownCompleted() message out of the pJCS port,
itiscertain JCSwill receive this message.
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With the transition labels identified, you can add them to the OV-6b statechart. To do this, follow
these steps:

1. Using the Default Connector icon *, on the Drawing toolbar, draw the default
transitions to the AwaitingOr der s state.

2. Using the Transition icon s on the Drawing toolbar, draw the transitions listed below
in order, as shown in the following diagram. Label the transitions by selecting the

Transition Label icon & on the Drawing toolbar and clicking on them.
a. regqObserve: Draw from AwaitingOrdersto Observing
b. evAttackCompleted: Draw from Observing to CreatingObsReport

c. /OPORT (pJCS)->GEN(evObserveCompleted(observeReport)): Draw from
CreatingObsReport to Awaiting Orders

d. reqSandDown: Draw from AwaitingOrdersto SandingDown

e. /OPORT (pJCS)->GEN(evDOCCStandDownCompleted()): Draw from
SandingDown to AwaitingOrders

!

-
Asovaiting O .
weatingOrders T Obzery | r?UT
reqiobserve f

ervel) 43
N
l evAttackComplete

[ CreatingOhsReport 'r‘f::':

- Report)

SOPORT(RJCSE)-= I
GEM{evObzerveCompleted [
[obzerveRepart])

StandingD  vn I!'*::;l'
req=tandbown

0oyl

et
. A IOPORT(pJCSE)-=
GEN(evDOCCStandDowenCompleted!)
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Note: Rhapsody provides assistance in selecting the names of defined messages when
labeling transitions. To activate this feature, follow the steps above, but use the
Ctrl+Spacebar key sequence before, or at any point while typing in the label.

You will be presented with a subwindow showing allowable message names
you can select from. Seethe figure.

B = Select...» -
EcreateObserveReport() in Oper ationalyiew: :DioCC

CEDARD in Operationalview

(00O in Operationalview

= GEMN

=I5 IN

L itsattackTarget in Operationalview: : DOCC

L its3C5 in Operationalyiew: :DOCC

{$31C5 in Operationalview b

3. Double-click the reqObserve transition. The dialog box that appears should closely

resemble the following figure. If the dialog box looks different, make sure you selected
the correct name to the appropriate transition.

Transition : 1 in 0O¥-6BOfDOCC

General lTags ] Pn:uperties]

e |
Stereolype: | -]

Target | J ]

Trigger: g in Interfaces: TO_DOCC_Pkg ~ |

Guard: | r
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With the transition labelsin place, add the execution of the mission objectives to the Observe,
PreparingObservationReport, and SandingDown states.

To add these mission objectivesto be performed in a state, follow these steps:

1. Right-click the Observing state, and select Features.

2. Inthe Features dialog box, enter observe () inthe Action on entry box, as shown in the
following figure:
State : Observing in O¥-6B0OfDOCC * =]
-
General l Helatin:nns] Tags ] F'rn:nperties]
Mame: |Dbserving L
Stereotype: | j
Achion on entny
ohzerwve () [

Action on exit : .
1| il
<] £d

Locate | 1] .4 | Apply |

3. You will seethe state reaction icon iZ} in the top right corner of the Observing state. Click

the icon to toggle the display of the observe() mission objective on the diagram, as shown
in the following figure:

T Dbserﬁng E*_JTI Chserving ltc'_J

I i Eubserve(j
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4. Repeat steps the above steps to add the createObser vationReport() mission objective to
the CreatingObsReport state, and the standDown() mission objective to the
SandingDown state, as shown in the following figure:

I

.
AvvaitingOrd O
vralingirders T Cheerving I';=*"_JL|’:|
reqObserve
Hfl]‘"hu:ubserve(j I{J
b o b
l evAttackCamplete
i CreatingObzReport f%_l'
o “5u:reateObservaticunﬁepurt(uhserveﬁepurtj
IOPORTRJCSE)-=
GEM{evObzerveCompleted
[obzerveReport) s
StandingDawwn I%I'
reqstandbowen »
&, standDoweni)
et
. A IOPORT(pJCSE)-=

GEN(evDOCCStandDownCompleted)

5. Savethe architecture model, select File > Save.
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Generating the OV-3 Operational Information Exchange Matrix

The OV-3 Operational Information Exchange Matrix provides a detailed report of the
information exchange between operational nodes.

To automatically generate the OV-3 Matrix, follow these steps:

1. Right-click the Project folder and select Gener ate Service Based OV-3 Matrix, asshown
in the following figure. The Create dialog box opens.

av| Allvies Features
+-@v| A Features in Mew 'Window
Cam
L I b
+ E ld
ﬂ OPers  cearch...
@YY search inside...
+ l::_\ References...
N
w3 Edit Unit...
= '5'1'
= Change to 3
o Configuration Managemenkt L4
e Format. ..

-8l Rhapsody Gateway
Setup DoDAF Packages

+ -] Generate Service Based OY-3 Matrix
_1 Packs  Generate Data-Flow Based O%-3 Table %
&l v Genetrakte SY-3 Matrix
A1 Generate 5v-5 Surnmary Makrix
3Pl Generate SY-5 Full Matrix
:l Profil Generate Service Based SW-6 Matrix
* ﬁ D Generate Data-Flow Based SV-6 Table
+ % D ol s L B I i B

Note: Given the content of the model in thistutorial, you can also generate the
Data-Flow Based OV-3 Table.
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2. Enter the name of the OV-3 fileand click OK.

Create

Mame of 0%-3 file to create?
Cancel

\DoDAF_Tutorial -3

3. A message appears stating that the OV-3 has been created successfully. Click OK.

4. The browser now reflects the changes made, as shown in the following figure:

Entire Model Yiew -

=|- {1 DoDAF _Tutarial
—|--av | AllYiews
| Al
= [:I Componenks
+- 2 ModelExecution
- ﬂ Cperationalviews
- gﬂ Cperationalview
+ DocBoxs
+ “ Meedlines
+-{%} OperationalModes
-] on-1s
Y| ow-1 High-Lewvel Graphi
SV ow-1 Mission Concepk
=] ow-25
2| ow-2 AttackTargst
=] ov-3s
3| 'DoDAF_Tutorial OY-3,%
= 8¥| ow-gis
M| owee Two Phased Atta

Rhapsody
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Creating the SV-4 System Function Description Diagram

In the Systems View, the Operational Activities are closely related to the SV-4 Systems
Functionality Description. The SV-4 is arefinement of the OV-5 Mission Objective Model where
the mission objective flow is trandated to aflow of systems functions.

To create an SV-4 System Function Description Diagram, follow these steps:

1. Expand SystemsView in the Rhapsody browser.

2. Right-click SystemsView and select Add New > System Diagram >SV-4, as shown in

the following figure.

3. Namethediagram sv-4 attack and pressthe Enter key. The SV-4 icon appearsin the

browser.

ﬁu PR S SAL
— & Features

Features in Mew Window

-0 Add Mew r
Open Main Diagram ...

Search. ..
Tech  Search inside...
References, .,
Unik 3
Change to 4

Generate Systemsiiew
Edit Systemstiew

Edit Type Crder...

Configuration Management  »

Package
Chject

Class
Type

ControlledFile

InfFormationElement
PhysicalDataType
InformationExchange
Performancerarameter

Al Wieww Diagram
Cperational Diagram
Cperational Element
Syskbem Diagram

r rF v v

SwskemsYiew |
Sh-1

oN-2

V-3

Sh-4

V-5 %
V-6

SN-T

V-9

SV-10a
SV-10c

Sh-11

4, Expand Operational View and Oper ational Activities in the Rhapsody browser.

5. Drag-and-drop the attack operational activity onto the drawing area.

For each operational activity, the SV-4 diagram is the main connection point between the

operational view and the systems view.

The “attack” operational activity isthe center of this diagram. You must now display the systems
which are needed to perform, or “execute” the “attack” operationa activity. You have dragged the
“attack” operational activity into the drawing area. You must now show which system functions

must be performed to realize the “attack” operational activity.
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The system functions reside within unique Systems. Each System residesin a SystemsNode.

The Systems involved in this SV-4 diagram, are the Submarine and Missile Systems. The
Submarine system performs the following functions: select silo, open silo door, and extend launch
tube. The Missile system performs the following functions. arm, launch, and guidance.

To add the Submarine and Missile Systems and their corresponding functions, follow these steps:

1. Using the System icon [ on the Drawing toolbar, draw two narrow rectangles (systems)
on either side of the attack operational activity. Name the left system submarine and the
right system missile, as shown in the following figure:

2. For functionality purposes, change the appearance of each System. Right-click a system
“rectangle” and select Display Options. Clear the Enable Image View check box. Click
OK to close the Display Options dialog box. Repeat this step for the other System in the

diagram.
1 w5y Samx D1 ocS?stemx i
JEMEC:: Subtnating JEMEC:: Mizsile

wperationaldctivitys

E}E}C}QD

Operationalyiew: apattack
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Select each system and click the Specification/Structured View icon £ to enter
“Structured” mode. This enables Rhapsody to “assign” the system functionsto their
respective systems.

If Rhapsody isin “ Specification” mode, Rhapsody does not associate the system
functions with their respective Systems, and the browser displays the system functions as
being independent of each system.

The figure below displays the browser with the system functions assigned to their
respective systems.

+- 5| Sv-4s
- ﬁ Swstems
- @ Missile
-0 SystemFunctions
+-- Fnarm
+- [ fnGuidance
+-- FnLaunch
- @ Submarine
=[O SystemFunctions
+- FnExtendLaunchTube
+-0 fnopensiloDoor
+- O Frselectsilo
+ @ Systemshodes
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4. Using the System Function icon & on the Drawing toolbar, draw the system functions
fnSelectSilo, fnOpenSiloboor, and fnExtendLaunchTube iN the Submarine System
rectangle.

Draw the system functions fnarm, fnLaunch, and fnGuidance in the Missile System.

The“fn” prefix on each name stands for “function” and keeps Rhapsody from confusing
like system function and operation names when generating code.

1 w5y stem 1 afy Stemm
JEMCC:: Submatine JEMICC::Miszile
«SystemFunctions wSystemPunction:
fnSelectSio fnarm
ziDperational Activitys .
s=ystemPunction: #SystemPFunction:
Moo = 3
=l oodhoa j=!
e
tnCpensilaDoor Operatioralyiew:: opsttack frL&unch
w=ystemPunction: w=ystemFunction:
p——
fnExtendlaunchTube fnGUidance
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5. Using therealizetool -,, draw realize lines from each system function to the attack
operational activity, as shown in the following figure:

1 w5y steman
JEMCC: Submatine

wmystemFunction:

fnzelectSio

zEystemFunctions
e ——

M——
TnopenziloDoor

«SystemFunction:

is!

fnExtendLaunchTube

Fealizes - _

s..  aOperationalActivitys .- ~Realizes
- -_él é\: -
________ s e -
#Realizes sRealizes
7 o
.- Dperational’iew: opAttack. | )
A wRealizes «Reélfm ‘

afysterm
JEMEC:  Miszile

eoyvatemFunction:

fn&rm

soyatemPunction:

fnLaunch

w=ystemFunction:

Tnzuidance
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Creating the SV-1 System Interface Description Diagram

The starting point for the SV-1 Systems I nterface Description isthe OV-2 Operational Node
Connectivity diagram. The OV-2 diagram provides a guide for developing the SV-1, where the
Operational Nodes can be detailed with the systems contained by the nodes (recall the systems
have been identified in the mission objective diagram as described above).

To create an SV-1 System | nter face Description that is consistent with the attack Tar get mission

objective, follow these steps:

1. Expand the SystemsView package in the Rhapsody browser.

2. Right-click SystemsView and select Add New > System Diagram > SV-1, as shown in

the following figure:

I‘jﬂ g fro
' Features
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Features in Mew Window
Add Mew 3

Open Main Diagram ...

Search...

Search inside. ..
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Edit Type Order...

Configuration Management  #
Farmat...
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©
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InformationElerment
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3
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3. Namethediagram sv-1 attackTarget.
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4. To add the first system nodes onto the diagram, right-click SystemsView and select Add

New > System Element > SystemsNode, as shown in the following figure. Name the
node pocc and press Enter.

¢ Features E]
{  Features in Mew Window
E =1
5 Add Mew 4 Package
Cpen Main Diagram .. Chject
Class
search... Tvpe
Seatch inside. .. i
References. .. ControlledFile
Unik 4 .
InformationElemnent
Change to 4 PhysicalDataType
i InformationExchange
Generate Systemsiiew
_ ) PerformanceParameter
Edit Syskemshisw
Al Wiews Diagram 4
Operational Diagram 3
Edit T Crder. ..
" Type reer Cperational Element 4
Configuration Management. ¥ Syskem Diagram 4
Format. .. Syskem Element 4 Systemshode
Associake Image Technical View Diagram  # Tys
SyskemPark
Delete From Model .
SystemFunction
SystemPraoject
4 Capability

The DOCC system node appears in the browser. Drag-and-drop the DOCC system node
icon from the browser onto the drawing area.

For the next system node, right-click SystemsNodes and select Add New SystemsNode,
as shown in the following figure:

El1 I ay=1 guidLk] arygew

- ) Esiesidee |
m Do add Mew Systemshode
Technicalviews %

Name the next system node grmcc and press Enter. The JFM CC system node appearsin
the browser under the DOCC system node icon. Drag the JFM CC system node icon from
the browser onto the drawing area.

To create the JCS system node, repeat the previous two steps.

Select al three system node and right-click one of them. Select Display Optionsand clear
the Enable | mage View check box.
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10. With all three system nodes still selected, click the Specification/Structured View icon &

to enter “ Structured” mode.

11. Enlargethe JFMCC system node.

12. Drag-and-drop the Missile and Submarine systems from the browser into the JFMCC

system node rectangle in the drawing area, as shown in the following figure:

1 whystems Modes
JEMCC 1 «SystemsMNodes
Docc
«3ystems
Missile
«Systems
1  eSystemshode:
JCS
Subrnarine
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13.  Your Rhapsody browser should now appear as shown in the following figure:

- ﬂ%ﬁ‘}s
2| Sw-4 Akkack
- @ SyskemsModes
D
aCs
= JFMICC

-~ SvskemFunctions
+- [ Fnarm
+- () FnGuidance
+- (O FnLaunch

- @ Submatine

-~ SystemFunctions
+- (0 FnExtendLaunchTube
+1- 2 FrOpensiloDoor
+- (0 FnSelectSio
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Creating the SV-5 Operational Activity to Systems Function
Traceability Matrix

The SV-5 Matrix summarizes the mapping between system functions and operational activities
based on the information contained in the SV-4 diagram(s).

To generate the SV-5 Operational Activity to Systems Function Traceability Matrix, use the
following steps:

1. Inthe Rhapsody browser, right-click the project folder (in this example
DoDAF_Tutorial), and select Generate SV-5 Full Matrix, as shown in the following

figure:
b DDA Tutori=t —
- ﬂIF\II\I‘iews Features b
= @ﬂ.ﬁll'u‘ie Features in Mew Window )
=AY a
Add Mew bl

A
+-(23 Compon_e Search...

+ ﬂOperatin Search inside. ..
+-(] Packages  Refersnces. ..

+-[_] Profiles
- ﬂ Syshems' Edit Unit...
=@V | Syste |
':ﬁ_JSV | “hange to v
ms Configuration Management »
=59 Format...

5
m.: Rhapsody Gateway
C Setup DoDAF Packages |
E Generate Service Based OY-3 Matrix |
Generate Data-Flow Based OY-3 Table
Generate SY-3 Matrix
Generate V-5 Surmmary Matrix
Generate SY-5 Full Matrix
Generate Service Based SY-6 Matrix [}5
Generate Data-Flow Based SY-6 Table
Generate SY-7 Table
DoDAF Report Generakor

i

2. Click OK at the prompt.

3. Namethe SV-5 at the next prompt. For this example, namethe Matrix coordinated Land
and Sea Attack SVS5.
Note

Do not use adash in your SV-5 name, as conflicts may arise with some configuration
management tools.
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4. The SV-5window appears, as shown in the following figure:

SYSTEM | svsTEMFUMCTION | Dar0 [Jips [acs [uic | JrMce | Doce | opattack | opCreatesttackReport | opStanc
O Migzile fruturm Fealizez
O Mizzile frLaunch Fealizes
O Migsile frGuidance Realizez
O3 Submanine  fnSelectSilo Realizes
O Submarine  fn0penSiloDoor Realizesz
O Submarine  frExtendLaunchTube Realizez
ﬂ Docc <no function:

W] IFMCC <nn function:
ﬂ M izzile <no funchion:
ﬂ Submarine  <no function:
EJCS <o function:
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Information on Creating the SV-10b and SV-10c
Descriptions

This section gives high-level guidance on creating the SV-10b and SV-10c. Given that these
products are very similar to their OV-6 counterparts, this tutorial does not give explicit
step-by-step instruction on how to create these products. The SV-10c Systems Event Trace
Description is arefinement of the OV-6¢c Operational Event Trace Description. To create the
SV-10c, copy the OV -6¢ sequence diagram(s) into the SystemsView package, and then replace the
operational node lifelines (the vertical lines) with the set of lifelines showing all the systems at the
system node that participate in each specific event trace. Mission objectives are broken into one or
more system functions, and additional messaging (communication) from system to systemis
added as needed. See the following figure for an example of the attack operational activity being
performed by the Submarine and Missile systems within the JFMCC system node.

Jcs %JFMCC.Submarine % JFMCC Missile DOCC

| createAttackPland

[ reqObsene(Coordinate, Time) |

|
|
|
| regattack{Coordinate Time, at‘t@l:kTvp 2l |

L

openSiloDoord obsemed

extendLaunchTubed

|

|

|

|

| F

I reglaunchiissiled ~
|

|

|

I

|
|
|
|
|
selectSilag |
|
|
|
|
|

Lgi—iti‘anu:eo
The SV-10b System State Transition Description can be based on the OV-6b Operational State

Transition Descriptionsif the systems within an operational node are loosely coupled. In this case,
the OV-6b statechart diagrams can be copied into the SystemsView package and then modified as

needed. In other cases where these systems are tightly coupled, it is often preferable to create new
statecharts for the systems.

@
=
=
i)
=
o
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Gercllerlating the DoDAF Report from the Architecture
Mode

The last procedure in thistutorial isto generate a DoDAF report from the architecture model.
Using another helper, you can generate a DoDAF report from the architecture model that includes
all of the products utilized in the model. The AV-2 is generated for you automatically from the
architecture model data. Keep in mind that the Rhapsody model itself is adynamic and searchable
AV-2 including all elements of the architecture model.

To generate the DoDAF report, right-click your project folder in the Rhapsody browser and select
DoDAF Report Generator, as shown in the following figure:

rcaudrcs

av| gl , _
[:l can Features in Mew Window
+ E Add Mew >
ou| Ope
= Eﬂ Search...
Search inside. ..
References, ..
[:l Par Edit Unit...
% Change to 3
T El Canfiguration Management 3
[ Prol  Format...
¥
. % Rhapsody Gateway
3 Pro Setup DoDaF Packages
= S';.n's- Generate Service Based OY-3 Matrix
E‘ Ter ‘3enerate Data-Flow Based OY-3 Table
zenerate 5v-3 Matrix
Generate SYW-5 Surmmary Matrix
Generate Sv-5 Full Matrix

Generate Service Based SY-6 Matrix

Generate Data-Flow Based SW-6 Table
—  Generate V-7 Table |
DoDAF Report Generator I

The DoDAF Report Generator window appears, and ReporterPLUS starts to load the model and
generate the document. This process may take afew minutes. After the document has been
created, it is displayed, and the document is formatted.
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Asthe last step in generating the report, Microsoft Word displays a message indicating where the
files have been saved in the Rhapsody project directory, as shown in the following figure. The
OV -3 spreadsheet is saved as aworksheet in the Excel workbook file in the Rhapsody project
directory with name <projectName>_DoDAFreport.xls. Click OK to complete the report
generation.

-~

I DoDAFPack

DaDAF Repart Generation Completed. Files Created:
C:\Documentatiomisteve dodaf modelDoDdF_Tukorial_ModehDoDAF_Tutorial_DoDaFreport, doc
C:\Documentatiomisteve dodaf modehDoDaF_Tutorial_ModehDoDaF_Tukorial_CoDaFreport, xls

The generated .doc Word file contains a hyperlink to the excel workbook containing the OV -3
Matrix, as shown in the following figure:

@ DolAF_Tutorial_DoDAFreport. doc - Microsoft Word E]@E
Eile Edit Wiew Insert Format Tools Table ‘webWorks ‘Window Help

D s & B - @M 1w - [2) 2 Hyperlink -

4+ Save to iMotion...,

[E¥

k

0V-3 Operational Information Data Exchange Matrix

Click to iew O%-3 Diagrarn: DoDAF Tutogal OW-3 uls

4
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It is possible to navigate to the definition of any interfaces displayed in the OV-3 Matrix.
Double-clicking an interface name in the OV-3 Excd file or in the OV-3 tablesin the Word
document will bring you to the corresponding definition of the interface in the AV-2 Data
Dictionary. The Back Button on the Word Web Toolbar can be used to return to the OV-3.

Note

The Word document can be converted to other formatsincluding HTML and PDF using
third party software (not provided by IBM).

Summary

Congratul ations on completing the Rhapsody DoDAF Add-on Tutorial! In thistutorial, you used
Rhapsody to create a DoDAF-compliant architecture model of the operational view for a
simplified land and sea-based attack capability.

Thetutorial started with the creation of a new DoDAF project using one of the helpersin the
Rhapsody DoDAF Add-on. Next, you were introduced to the AV-1 Overview and Summary for
the architecture model

The AV-1, which was created for you, was associated to the architecture model using a hyperlink.

After working with the AV-1, you began the work of building the architecture model using UML
diagrams in Rhapsody. Starting with two mission objective diagrams, you created a traditional
OV-1High Level Operational Concept Graphic, aswell asan OV-1 High Level Mission

Obj ective diagram. Both diagrams helped you describe the mission and main operational nodesin
the architecture. In the mission objective diagram, you identified the two primary mission
objectives for this architecture: Assess Threat and Attack Target. In the remainder off the tutorial,
you focused your attention on the Attack Target mission objective.

From the OV-1, you moved to the OV-5 Mission Objective M odel, used to describe the
operations that are normally conducted in the course of achieving amission. You used an Activity
diagram to capture the OV-5 information. The Activity diagram shows the functional flow of
operationsincluding control logic for achieving the Attack Target mission objective.

You then started your OV-2 Oper ational Node Connectivity diagram. Using another helper from
the Rhapsody DoDAF Add-on, you created the initial OV-2 showing the operational nodes you
documented in the OV-1 mission objective diagram. You used a diagram to capture the OV-2
information. Next, you created the OV-6c¢, which you later used to add the mission objective and
needline information to the OV-2.

The Operational Event Trace Description is used to show a sequence-ordered graph of the
information exchanges between operational nodes as a result of a particular operationa scenario.
In constructing the OV-6¢ Event Trace Description, you referred to the OV-5 to guide you along.
While there are many event traces you can construct for the Attack Target mission objective, you
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focused on one that covered all the operations you documented in the OV -5. In constructing the
Two Phased Attack Event Trace, you used a helper in the DoODAF Add-on to create the initial
sequence diagram showing the Operational Node lifelines. Next, you added the appropriate
mission objectives. You then added messages that are sent between operational nodes to request a
node carry out an mission objective. Last, you added messages that are sent between operational
nodes to provide notification and reporting information.

With the OV-6¢ completed, you were then able to complete the OV-2. You used another helper to
update the OV -2 nodes with mission objectives and needline information. You examined the ports
and interfaces created by the hel per to see how the messages you created in the OV-6¢ were
trandated into needlines and information exchanges. All that you had to do manually was layout
the nodes and add the links to connect the ports.

After completing the OV-2, you moved on to the OV-7 Logical Data Model. In the OV-7, you
documented the data exchanged in the OV-6c¢ event traces. Some of this data were further
decomposed in the OV-7 diagram.

You then created the OV-6b Operational State Transition Description. The OV-6b shows how
an operational node responds to input messages. You started your statechart by reviewing the
OV-6¢ and identifying the modes of operation. You added the state transitions, and discussed the
trigger, guards, and actions used on the transition labels.

You created the OV-3 Operational I nformation Exchange Matrix. This matrix documents the
information exchanged among the operational nodes. This was the last operational view product
created. The OV-3 is generated using a DoDAF helper.

At this point you transitioned to the Systems View products. You started by creating the SV-4
Systems Functionality Description where operational activities were mapped to system functions
and system functions allocated to systems.

You created the SV-1 System | nterface Description. This product contained the system nodes
which corresponded to operational nodes. These system nodes house the individual systems
identified in the SV-4 product. These individual systems in turn contain system functions.

The last systems view product created was the SV-5 Operational Activity to Systems Function
Traceability Matrix. This product showed the mapping of operational activitiesto system
functions. The SV-5 is generated using a DoDAF hel per.

Thelast step in the tutorial wasto generate aDoDAF report from the architecture model. Here too,
you used a helper from the Rhapsody DoDAF Add-on. The generated report documents al of the
architecture products you created in building your architecture model. In addition, the report
includes the hyperlinked AV-1, and the AV-2 and OV -3, which are generated from the architecture
model data. Keep in mind that the Rhapsody model itself is a dynamic and searchable AV-2
including all elements of the architecture model.
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With just alittle more effort, you can simulate your architecture model with a user-friendly
Web-based interface that provides stimulus to the model and displays the model's response. You
can use Rhapsody's Sequence diagram Compare capability to ensure the model's actual behavior
matches what you captured in your OV-6¢ Event Trace Descriptions. You can use Rhapsody Test
Conductor to run regressions tests as you modify the architecture model and ensure you do not
break any of it's capabilities, or to compare the behavioral performance of alternative architectures.
You can also use the Rhapsody Gateway to provide full requirements traceability and impact
analysis as you consider alternative architectures. Thistutorial just scratches the surface of what
you can do when you build a DoDAF compliant architecture model with Rhapsody.

The solution presented in this tutorial is based on the Rhapsody Harmony Process for Systems and
Software Engineering, and is immediately available when purchasing the Rhapsody DoDAF Add-
on. You have created this solution to be customizable and extensible to meet the needs of awide
variety of customers, including those needing to develop models compliant with architecture
frameworks other than DoDAF. All of the automation provided in this solution is based on the
Rhapsody COM API and the ReporterPLUS document generator, making it easy to tailor to other
approaches for architecture modeling.
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Troubleshooting

The following examples are possible problems users may encounter when using the DoDAF Add-
on.

Verifying the Rhapsody DoDAF Add-on Installation

Thefirst step in verifying the installation is to examine the targets for the shortcuts in your start
menu under Start > All Programs > Rhapsody DoDAF Add-on. If your start menu does not
include an entry for the Rhapsody DoDAF Add-on, then use the Add or Remove Programs utility
in the Windows Control Panel to seeif the DODAF Add-on isinstalled, as shown in the following

figure:
iy Add or Remove Programs E]@
~ ~
"f'-%! Currently installed programs: Sort by! | Mame
Change or '
Rermove Rhapsody DoDAF Pack 6,1 Size  25.42ME
Frograms M Rhapsody LaunchPad Spe  0.17MB
j Rhapsody ReporterPLUS 6.1 Size  40.46ME
F\.d:l :Mew - ﬂ Rhapsody TestConduckor Size 4,17ME | ¥

If you find the Rhapsody DoDAF Add-on is not installed on your system, install it. If the
Rhapsody DoDAF Add-onisinstalled on your system, then the next step isto check your system’s
registry to find where the DoDAF Add-on isinstalled. To examine your system’s registry, you use
the RegEdit program.

Note

Use care whenever you access your system’sregistry as inadvertent changes can render
your system unusable. For this tutorial, you are not making any changes to your system’s
registry, just examining one of the registry settings.
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To launch RegEdit and check your system'’s settings, follow these steps:
1. Sdlect Sart > Run from the Windows Taskbar.
2. Typein regedit for the program name, and click OK.

3. InRegistry Editor window, locate the HKEY LOCAL MACHINE\SOFTWARE\
I-Logix\Rhapsody DoDAF Add-on Key, asshown in the following figure:

¥ Registry Editor E]@E

ile  Edit Wiew Favorites Help

= GTK | Mame Type Data

=1 HEW'?tt'PaCkﬂfd (DeFauIt} REG_SZ (walue not set)

= Togix F‘ath REa_SZ C:\RhapsodyAcqualfthapsodyDoDAFFack),
#- (] Rhapsody [ab]version  REG_SZ 6.1

+-[_] Rhapsody 6.1
+-[_] Rhapsody Documentation 6.1
£ Rhapsody DoDAF Pack 6.1
+-[_] Rhapsody RepaorterPLUS 6,1
+-[_] sStatemate 4.0
+-[27 IMsI
4[] Installedoptions hdl
w ComputeriHEEY _LOCAL_MACHIMEVSOFTWAREYI-Logix\Rhapsody DoDaF Pack 6.1

4. Make surethe Version setting shows you are using version 1.4.0 or newer. If you are using
an older version of the Rhapsody DoDAF Add-on, please upgrade to the latest version.

5. Make note of the Path setting for the Rhapsody DoDAF Add-on.
6. Close Regedit using File > Exit from the drop-down menus.

Using Windows Explorer, locate the folder specified by the path setting, and verify this tutorial,
the av-1.doc and ov-1.bmp files are located in the Tutorial subfolder in this path. If these files are
not found, or if you cannot find the key in your registry, then your Rhapsody DoDAF Add-on
installation has been damaged. Uninstall and then re-install the Rhapsody DoDAF Add-on to
repair your installation if it has been damaged.
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Manually Adding the DoDAF Helpers

Typicaly, the Rhapsody DoDAF Add-on installer will automatically configure the Rhapsody
DoDAF Add-on helpersfor you.

There are thirteen helpers provided with the Rhapsody DoDAF Add-on. The table below
summarizes the helpers and their settings:

Helper Name Command Arguments Applicable To
Setup DoDAF <Path>\DoDAFPack.exe | -dodaf -i DoDAF
Packages
Create OV-2 from <Path>\DoDAFPack.exe | -dodaf -uc MissionObjective
Mission Objective
Create OV-6¢ from <Path>\DoDAFPack.exe | -dodaf -sd MissionObijective
Mission Objective
Update OV-2 from OV- | <Path>\DoDAFPack.exe | -dodaf -d OV-6¢
6¢c
Generate Service Based | <Path>\DoDAFPack.exe | -dodaf-ov3m DoDAF
QOV-3 Matrix
Generate Data-Flow <Path>\DoDAFPack.exe | -dodaf -ov3t DoDAF
Based OV-3 Table
Generate SV-3 Matrix <Path>\DoDAFPack.exe | -dodaf -sv3 DoDAF
Generate SV-5 <Path>\DoDAFPack.exe | -dodaf -sv5short DoDAF
Summary Matrix
Generate SV-5 Full <Path>\DoDAFPack.exe | -dodaf -sv5long DoDAF
Matrix
Generate Service Based | <Path>\DoDAFPack.exe | -dodaf -svém DoDAF
SV-6 Matrix
Generate Data-Flow <Path>\DoDAFPack.exe | -dodaf -sv6t DoDAF
Based SV-6 Table
Generate SV-7 Table <Path>\DoDAFPack.exe | -dodaf -sv7 DoDAF
DoDAF Report <Path>\DoDAFPack.exe | -dodaf -report Project
Generator

Rhapsody
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If you find that any of the DODAF helpers are missing from the submenus in Rhapsody, first make
sure you have verified the Rhapsody DoDAF Add-on installation as described in the previous
section. Once you have verified the installation, manually configure the helpers using the
instructions that follow. While verifying the installation, make sure you have noted the path where
the Rhapsody DoDAF Add-on isinstalled.

To install the Rhapsody DoDAF Add-on helpers, follow these steps:

1. Select Tools > Customize from the Rhapsody main window to open the Helpers dialog
box, as shown in the following figure:

&4 Helpers
Menu content: S O S
Create Harmony Froject |~
Create Ports And Interfaces With Delegation
Create Systern Model From Use Caze

Create OpCon Allocation T able

Perform OpCon Conzistency Check New Hel per lcon
Create Ports And Interfaces Mo Delegation

Create Uze Caze Scenario

Create System kModel From Uze Caze Diagram

Link *#fizard |

[]
[]
|

2. Usethe Create New Helper Icon to create a new helper, and enter the appropriate helper
name from the There are thirteen helpers provided with the Rhapsody DoDAF Add-on. The
table below summarizes the helpers and their settings: table.

3. Set the Command, Arguments, and Applicable To: as set in the There are thirteen helpers

provided with the Rhapsody DoDAF Add-on. The table below summarizes the helpers and
their settings: table on the previous page. For the command, replace <Path> with the path

where the Rhapsody DoDAF Add-on isinstalled.

4. Set Typeto External Program and select the Show in popup menu box.
5. Click Apply to apply the changes.

6. If needed, configure another helper by repeating steps 2-5, or click OK to close the
Helpers dialog box.
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Fixing the Model if Messages Appear as Mission Objectives

After updating the OV-2 from an OV-6c, you should check the OV -2 and make sure the messages
between nodes are correctly appearing as events. If you find a message going between operational
nodes appears in the OV-2 as an operation rather than an event, this indicates the message type
was not changed to Event in the OV-6¢ diagram.The following figure shows an exampl e of
evJFM CCStandDownCompl eted appearing with the private operation symbol g, but should have
the event symbol .

1 wlperational Modes 1 wperational Modes
JES JEMEC

B createtttackPlan B attack
Eev.&ﬂackcgmpleted H crestetttackReport
iethserveCnmpleted ireq.ﬂ.ﬁack
HazsessattackResults pJFMCE pJCE H crestattackReport
B asseszittackResutls [1 [ ] B regStandDown
ﬁevJFMCCS‘tananwnCnmpl... g standbowen

& evDOCCStandDovenComgl ..

-

1

PO

RICS

1 wOperatioalModes A
DoCC

B observe

H createCbserveReport
@ reqobzery

[ v AttackCompleted L]
B regObzerve RAFRCC
E req=tandDown
& standCowen

4
| .

-
pDOCC
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To fix this problem, follow these steps:

1. Expand the Rhapsody browser to see the operation under the appropriate operational node.
In this case, you need to expand thefolder project 1\OperationalViews\Operational
View\Operational Nodes\JCS\Operations\evDOCCStandDownCompleted.

2. Delete the operation by right-clicking on the incorrect operation and selecting Delete
from Model.

3. Openthe OV-6¢ diagram and check all the messages with the message name in question.

Note

To spot the problematic message, make sure messages that connect operational nodes have a
hollow arrowhead -, and mission objective messages (messages that start and end on the
same node) have a solid arrowhead l«-.
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4. To change the incorrect message, change the message type by double-clicking the

message and selecting Event from the M essage Type drop-down list, as shown in the

following figure. Click OK.

Message : e¥DOCCStandDownCompleted X
~
General lHeIatiDnsl Tags ] F'rapelties]
Mame: |evDDEEStananwnEompleled L
Stereotype: | ﬂ
Meszage Type: |Event j
Sequence: |
Arguments: | =
Return Walue: |
Realization : | <Unspecified: j
El Sender DOCCDOCC
E Feceiver JCS:JCS
Dezcription:
| -
:< 1 >:
Locate ‘ OK | |

the message.

6. Select OV-6¢ Two Phased Attack from the Rhapsody browser.

5. With the message selected, use Edit > Auto Realize from the pull-down menusto redlize

Rhapsody
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1 wlperational Modes
JES

E crestesttackPlan
Eev.&ﬁackﬂnmpleted
ievaseweCDmple’[ed
HazseszattackResutts

H azzeszattackResutls
EevJFMCCStandDuwnCDmpl...
@ = DOCCStandDownCompl. .

1

L

pJFMCE

7. Right-click the OV-6¢ icon and select Update OV-2 from OV-6c. See the figure.

1 wllperational Modes
JEMEC

pICS |

bz

pICS

1 sDperatioral Nodes o

DoCe

Eobzerve

B cresteChzerveReport
B reqobsery

[ e attackCompleted
Ererbserve
EreqStananwn

B standDowen

-

]
pJFMCC

8. You have repaired the OV-6¢ and OV-2 diagrams.

-
pDOCC

4
L

Eattack

H createittackRepart

ireq.&.ﬁack

H creatattackReport
1 B reqstandDown

H standDown
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OV-3, SV-3, SV-5, SV-6, Captions, or Table of Figures are Not Visible in
the Document

If the final document does not include an OV-3 matrix, figure captions, or table of figures, the
macrosin the DoDAFReportRTF.dot Word Document Template file are not being executed. Make
sure the security settings for Word are set to medium security to allow macros to be run. You can
change the security setting using Tools > Macro > Security (see the figure).

Security

Trusted Sources

" High. Only signed macros from trusked sources will be
allowed ta run. Unsigned macros are automatically
disabled.

* Medium. You can choose whether or not ko run
potentially unsafe macros.

" Low (not recommended). You are not prokected from
patentially unsafe macros. Use this setting anly if wou
hawe virus scanning software installed, or you are sure
all documnents vou open are safe.

Mo virus scanner installed.

(84 | Cancel |

Microsoft Word may prompt you to enable macros in the generated DoDAF report when it is
opened. You will need to select Enable Macros in this dialog box when opening the DoDAF report
in order for the macros to run (see the figure).

Microsoft Word

CiAI-Logixivssi DoDAF \RhapsodyDoDAFPack. rootRhapsodyDoDAFPackitempl
atesiDoDAFReportRTF. dot contains macros.

Macros may contain viruses, It is always safe to disable macros, but if the
macros are legitimate, you might lose some Functionality .

Enable Macros More Info
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A

Activity diagrams 3, 20, 44, 46, 47, 49

Adobe Acrobat Reader 2
Architecture 21

AV-1 18, 21, 31, 34
AV-2 18, 21

B

Bitmap viewer 2

Browsers 5, 9, 10, 33
filtering views 10
new DoDAF project in 23
opening 9

C

Categories 9
Collaboration diagrams 3
Component diagrams 3

D

DARO 26, 40
Deployment diagrams 3
Description tab 13
Diagrams 3

Ov-1 39

Ov-2 50

OV-5 44, 57

OV-6c 54, 63

OV-7 65

UML 3
Directories 22

Index

project 32
TestConductor 6
DOCC 26
DoDAF 1
architecture 21
basic features 18
create new project 22
helper 25
initializing the project 24
model information 26
new project browser 23
project overview 27
required software 2
Drawing area 11
Drawing tool bar
selecting adrawing icon 27

E
Event Trace 57

F

Features dialog box 12
Apply and OK buttons 12
Description tab 13
docking 17
General tab 13
keeping open 12
moving 17
Propertiestab 16
Relationstab 14
tabs 13
Tagstab 15, 28
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Files 6

_rpy 6

event history 6

log 6

project 4

rpy project 6

VBA 6
Filters

browser views 10
Flow charts 3
Folders 6

G
General tab 13

H
Helpers 25, 70

J

JCS 26, 40
JFMCC 26
JC 26

JPS 26, 40

L
Log files 6

M

Messages 57, 62
notification 61
Microsoft

.NET Framework 2

Excel 2, 103
Windows 2
Word 2, 103
Models
DoDAF 26

N

Needlines 50

Nodes
connectivity 50
OV-1 operationa 41

O

Object model diagrams 3
Output window 11
Ov-1 18, 21, 35, 39
operational nodes 41
Ov-2 18, 21, 50
Oov-3 19, 21
matrix 103
Spreadsheet 103
OV-5 19, 21, 44, 57
OV-6a 19
Ov-6b 19, 21
Ov-6c 19, 21, 54, 62, 63
OvVv-7 19, 21, 65

P

Packages 9
Profiles 22, 23
Projects 4
browsers 5
creating new 22
creating overview 27
files 4, 6
folders 6, 9
initializing DODAF 24
node 9
Propertiestab 16

R

Relationstab 14

Repository directory 6

Rhapsody 3, 7
browser 5, 9, 10
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DoDAF 18 SV-4 20, 21
drawing area 11 SV-5 20
graphical user interface (GUI) 7, 22 SV-6 20
projects 4 SV-7 20
toolbars 8 Sv-8 20
UML diagrams 3 SV-9 20
Swimlanes 49
S
Sequence diagrams 3, 19, 54, 61, 62, 63, |
68, 70, 101 Tagstab 15
Spreadsheets 20, 103 TestConductor 6
Statecharts 3, 19, 81, 84, 101 Toolbars 8
Structure diagrams 3
Subfolders 6 U
Sv-1 19, 21 :
SV-10 20 Use case diagrams 3
Sv-11 20
Sv-2 19 V
Sv-3 19 VBA file 6
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