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1 About this manual
Welcome to IBM® Rational® DOORS® for ClearQuest Interface.
This manual describes how to use version 2.2.1 of Rational DOORS for 
ClearQuest Interface. It assumes that you know how to use both Rational 
DOORS and ClearQuest®.

Typographical conventions
The following typographical conventions are used in this manual:

Related documentation
The following table describes where to find information in the documentation 
set:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus. For example: Click Yes to continue.

Italics Book titles

Courier Commands, files, and directories; computer output. For 
example: Edit your .properties file.

> A menu choice. For example: Select File > Open. This means 
select the File menu, then select the Open command from it.

For information on See

How to use Rational DOORS The Rational DOORS documentation 
set

How to use ClearQuest The ClearQuest documentation set

How to install Rational DOORS for 
ClearQuest Interface

Rational DOORS Installation Guide
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These documents are on the Rational Information Center at 
http://publib.boulder.ibm.com/infocenter/rsdp/v1r0m0/index.jsp.
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2 Concepts
This chapter introduces Rational DOORS for ClearQuest Interface and explains 
the concepts you need to understand before you use it:

• About Rational DOORS for ClearQuest Interface

• About Rational DOORS for ClearQuest Interface functions

• Configuring Rational DOORS for ClearQuest Interface

About Rational DOORS for ClearQuest Interface
Rational DOORS is the world’s leading tool for creating, structuring, and 
managing complex sets of requirements, such as those for a typical software 
development project. ClearQuest is a defect and change tracking tool.
Rational DOORS for ClearQuest Interface is a bridge between these two 
products, enabling users to co-ordinate defect tracking and requirements 
management. This integration is not supported on a ClearQuest MultiSite 
configuration.

About Rational DOORS for ClearQuest Interface functions
Rational DOORS for ClearQuest Interface allows you to:

• Query a ClearQuest database from a Rational DOORS project

• Edit ClearQuest records

• Link ClearQuest records to Rational DOORS objects, and track these links

• Attach files to a ClearQuest record using Rational DOORS for ClearQuest 
Interface

Configuring Rational DOORS for ClearQuest Interface
You can configure Rational DOORS for ClearQuest Interface so that a different 
ClearQuest database is used for each Rational DOORS project. This means that 
different ClearQuest databases and different form settings can be used on 
different Rational DOORS projects. 
You can configure:

• Database
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ClearQuest supports multiple databases. A ClearQuest database must be 
associated with each Rational DOORS Project that uses Rational DOORS 
for ClearQuest Interface.

• Type Selection
ClearQuest supports many different types and schemas. You can select the 
ClearQuest types that you want to make available to Rational DOORS for 
ClearQuest Interface for each Rational DOORS project. You make a 
ClearQuest type available by associating it with a Rational DOORS for 
ClearQuest Interface type. There are two Rational DOORS for ClearQuest 
Interface types: Enhancement Request (ER) and Defect, which can be 
associated with any available ClearQuest types.

• Query
You can configure Rational DOORS for ClearQuest Interface to display 
selected ClearQuest fields on the Query tab of the integration form. You can 
query the ClearQuest database on a single ClearQuest field, or on multiple 
ClearQuest fields. Rational DOORS for ClearQuest Interface supports the 
use of And or Or logic when querying on multiple fields.

• Report Details
The results of a query are displayed on the Reports/Details tab of the 
integration form. You can configure Rational DOORS for ClearQuest 
Interface to display selected ClearQuest fields on the Report/Details tab of 
the integration form. ClearQuest records are displayed in a list in the top 
section of the tab. When a record is selected in the list, the details of that 
record are displayed in the lower section of the tab. You can control which 
of the fields in the bottom section of the tab you want users to be able to 
edit. ClearQuest system fields, for example id or Submitter cannot be 
edited.

• Edit Records
You can configure Rational DOORS for ClearQuest Interface to display 
selected ClearQuest fields on the Edit Record tab of the integration form. 
You can control which of these fields you want users to be able to edit. 
ClearQuest system fields, for example id or Submitter cannot be edited.
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3 Configuring Rational DOORS for ClearQuest 
Interface

This chapter describes: 

• Configuring projects

• Configuring forms

Configuring projects
When you configure a Rational DOORS project to use Rational DOORS for 
ClearQuest Interface, you select the ClearQuest database you want to associate 
with the Rational DOORS project. You can then select the ClearQuest types that 
you want to make available to Rational DOORS for ClearQuest Interface for 
that project.
You make a ClearQuest type available by associating it with a Rational DOORS 
for ClearQuest Interface type. There are two Rational DOORS for ClearQuest 
Interface types: Enhancement Request (ER) and Defect, which can be 
associated with any available ClearQuest types. The ClearQuest types will be 
referred to in Rational DOORS for ClearQuest Interface by their Rational 
DOORS for ClearQuest Interface labels, i.e. Enhancement Request and Defect.
To configure a project you must be one of the following Rational DOORS users:

• Administrator user

• Database Manager
• Project Manager
Once you have configured Rational DOORS for ClearQuest Interface, any 
Rational DOORS users with access to the associated ClearQuest database will be 
able to use Rational DOORS for ClearQuest Interface.

1. Select the correct Rational DOORS Project in the left pane of the Rational 
DOORS Explorer. 

2. Select ClearQuest > Configure Project.
The ClearQuest Database Configuration dialog box opens, displaying the 
names of the available ClearQuest schema repositories in the top pane.

3. In the top pane of the dialog box, select the ClearQuest schema repository 
that contains the database you want to use.
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A list of the databases that are available for that schema repository is 
displayed in the Database Name pane.

4. Select the ClearQuest database that is to be associated with the Rational 
DOORS project selected in the Rational DOORS explorer.

The ClearQuest login dialog box is displayed.

5. Enter your ClearQuest username and password and click Login.

You can configure the ClearQuest login to save your ClearQuest username 
and/or password by selecting the appropriate checkboxes:

• If you save your username, you will be prompted for your password 
each time Rational DOORS for ClearQuest Interface accesses the 
ClearQuest database.

• If you save your username and password, you will not be prompted to 
login again, unless the login fails.

• You can login again during a session, or change your login options by 
selecting ClearQuest > Login from the explorer, or from the right 
click menu in a module.

Rational DOORS for ClearQuest Interface retrieves the available 
ClearQuest database types for the current database and displays them in the 
lower panes of the dialog box. You use the Enhancement Request Type 
Name pane to associate a ClearQuest type with the Rational DOORS for 
ClearQuest Interface type ER, and the Defect Type Name pane to 
associate a ClearQuest type with the Rational DOORS for ClearQuest 
Interface type Defect.

6. Associate a ClearQuest Database type with the Rational DOORS for 
ClearQuest Interface type ER by selecting the ClearQuest database type 
from the list in the Enhancement Request Type Name pane. Associate a 
ClearQuest database type with the Rational DOORS for ClearQuest 
Interface type Defect by selecting the ClearQuest database type from the list 
in the Defect Type Name pane. You can create associations for either or 
both of the Rational DOORS for ClearQuest Interface types.

7. Click Apply to save the configuration information.

Configuring forms
You can configure a form for each ClearQuest type that is associated with a 
Rational DOORS for ClearQuest Interface type. When the form is configured it 
provides the interface between the Rational DOORS project and the associated 
ClearQuest database. For information on associating a ClearQuest type with a 
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Configuring forms

Rational DOORS for ClearQuest Interface type, see “Configuring projects,” on 
page 5.
To configure a form you must be one of the following Rational DOORS users:

• Administrator user 

• Database Manager
• Project Manager
Once you have configured Rational DOORS for ClearQuest Interface, any 
Rational DOORS users with access to the associated ClearQuest database will be 
able to use Rational DOORS for ClearQuest Interface.

1. Select ClearQuest > Configure Forms in the Rational DOORS Explorer.

The ClearQuest Forms Configuration dialog box is displayed. There are 
five tabs in the dialog box: 

• Query Configuration
• Report Configuration
• Detail Configuration
• Data Entry Configuration
• View Fields

2. Click to display the drop down Form list at the top of the ClearQuest Form 
Configuration dialog box. The ClearQuest types that were associated with 
Rational DOORS for ClearQuest Interface types during the Project 
Configuration are displayed. In this example they are EnhancementRequest 
and Defect.

3. Select the ClearQuest type you want to configure.

Rational DOORS for ClearQuest Interface retrieves the field list for the 
selected ClearQuest type from the ClearQuest database. The field list is 
displayed in the Available Field list on each of the tabs in the ClearQuest 
Form Configuration dialog box. You can select which of these fields you 
want to be displayed on the Rational DOORS for ClearQuest Interface 
form.

4. Select the Query Configuration tab.

You use the Query Configuration tab to define what ClearQuest fields are 
available to users when they use Rational DOORS for ClearQuest Interface 
to query the ClearQuest database. These fields are displayed on the Query 
tab of the Rational DOORS for ClearQuest Interface form.
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• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Rational DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form in the same order that they are displayed in the Selected 
Item Order list. To reorder the list, select a field and move it using the 
up and down arrows.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

• Select the Report Configuration tab.

You can define what ClearQuest fields will be available in Rational DOORS 
for ClearQuest Interface as a result of a query. These are displayed as 
column headers in the upper pane of the Report/Details tab of the 
Rational DOORS for ClearQuest Interface form.

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Rational DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form in the same order as they are displayed in the Selected 
Item Order list. To reorder the list, select a field and move it using the 
up and down arrows.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

5. Select the Detail Configuration tab.

You can define what additional ClearQuest fields are available in Rational 
DOORS for ClearQuest Interface as a result of a query. These fields are 
displayed in the lower pane of the Reports/Details tab of the Integration 
form, and show the values of the record that is selected in the upper pane.

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Rational DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form in the same order as they appear in the Selected Item 
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Configuring forms

Order list. To reorder the list, select a field and move it using the up and 
down arrows.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

• By default, the ClearQuest fields in the Details section of the Rational 
DOORS for ClearQuest Interface form are editable. To disallow edits to 
a ClearQuest field select it in the Selected Item Order list and clear the 
Editable checkbox.

Note  ClearQuest system generated fields, for example id or 
Submitter are not editable. The Editable checkbox is 
cleared and dimmed when fields of this type are selected.

6. Select the Data Entry Configuration tab.

You can define what ClearQuest fields are available for editing in Rational 
DOORS for ClearQuest Interface as a result of a query. These are displayed 
on the Edit Record tab of the Rational DOORS for ClearQuest Interface 
form.

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Rational DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form in the same order as they appear in the Selected Item 
Order list. To reorder the list, select a field and move it using the up and 
down arrows.

• The fields are displayed on the Rational DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

• By default, the ClearQuest fields in the Details section of the Rational 
DOORS for ClearQuest Interface form are editable. To disallow edits to 
a ClearQuest field select it in the Selected Item Order list and clear the 
Editable checkbox.

Note  ClearQuest system generated fields, for example id or 
Submitter are not editable. The editable checkbox is 
cleared and dimmed when fields of this type are selected.

7. Select the View Fields tab.
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Users can create links between ClearQuest records and Rational DOORS 
objects using Rational DOORS for ClearQuest Interface. The link 
information is stored in the Rational DOORS module in an attribute called 
CQ Links. This attribute is created automatically the first time a user creates 
a link. You can define what ClearQuest fields you want to be stored in the 
CQ Links attribute for each link that is created. The default is the 
ClearQuest record’s id if no fields are identified.

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to be stored in the CQ Links attribute for each link that is created.

• The fields are listed in the CQ Links attribute in the same order as they 
appear in the Selected Item Order list. To reorder the list, select a field 
and move it using the up and down arrows.

8. You can preview the form by clicking the Preview Form button.

The Rational DOORS for ClearQuest Interface form is generated, and the 
fields you specified during the configuration are displayed.

9. Click Close to close the Preview form.

Note  You can query the ClearQuest database using the 
Preview form, and records matching the query will 
display. However, you cannot edit any fields when in 
Preview mode.

10. Click Save, then Close in the ClearQuest Form Configuration dialog box.
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4 Using Rational DOORS for ClearQuest 
Interface

This chapter describes:

• Querying the ClearQuest database

• Viewing query results

• Editing a ClearQuest record

• Linking a ClearQuest record to a Rational DOORS object

• Displaying link information in a Rational DOORS module

• Finding Rational DOORS objects linked to a ClearQuest record

• Finding ClearQuest records linked to a Rational DOORS object

• Deleting links

Querying the ClearQuest database 
To use Rational DOORS for ClearQuest Interface you must have access to:

• The configured Rational DOORS project

• The ClearQuest database that has been associated with that project

To query the ClearQuest database:
1. In a formal module, right click and select ClearQuest > Reports > Show 

Defect Query Form or ClearQuest > Reports > Show Enhancement 
Request Query Form. 
The ClearQuest Login screen is displayed.

Note  If the current Rational DOORS project has not been 
configured for Rational DOORS for ClearQuest 
Interface, an error message is displayed. The Rational 
DOORS Administrator user, a Rational DOORS 
Database Manager or Rational DOORS Project Manager 
must run the Configure Project and Configure Forms 
options from the Rational DOORS Explorer before 
Rational DOORS for ClearQuest Interface can be used.

2. Enter your ClearQuest username and password.
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You will be prompted to log into the ClearQuest database each time Rational 
DOORS for ClearQuest Interface accesses the ClearQuest database. You 
can choose to save your ClearQuest username and/or password when you 
log in by ticking the appropriate checkbox on the login dialog box.

• If you save your username you will be prompted for your password each 
time Rational DOORS for ClearQuest Interface accesses the 
ClearQuest database.

• If you save your username and password you will not be prompted to 
login unless the login fails.

• You can login again during a session, or change your login options by 
selecting ClearQuest > Login from the Rational DOORS explorer, or 
from the right click menu in a Rational DOORS module.

The Rational DOORS for ClearQuest Interface form opens, displaying the 
ClearQuest fields you can use to query the ClearQuest database. The 
ClearQuest fields that are displayed on the Rational DOORS for ClearQuest 
Interface form are those that were specified when Rational DOORS for 
ClearQuest Interface was configured.

3. Select the Query tab.

Specify the criteria for your query. Rational DOORS for ClearQuest 
Interface only supports And or Or logic when you enter a value in more 
than one field.

4. Click Perform Query.

Rational DOORS for ClearQuest Interface queries the ClearQuest database. 
When the information has been retrieved from the ClearQuest database, the 
Report/Details tab of the integration form is activated and the results of the 
query are displayed.

Viewing query results
The results of the query are listed in the upper section of the Reports/Details 
tab. When a record is selected in the list, the details of that record are displayed in 
the lower section of the tab.
Depending on how the Report/Details tab has been configured, you may be able 
to edit the fields in the lower section of the form. If a field in this section is read 
only, it is dimmed.
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Editing a ClearQuest record

Editing a ClearQuest record
You can edit a ClearQuest record using the Edit Record tab on the integration 
form.
To edit a ClearQuest record:
1. Select the record you want to edit in the list on the Report/Details tab.

2. Select the Edit Record tab or click the Edit button.

The fields on the Edit Record tab are populated with values from the 
ClearQuest record you selected in the previous step. If a field on the Edit 
Record tab is read only, it is dimmed.

3. Make the required changes and click Apply to save them to the ClearQuest 
database.

Linking a ClearQuest record to a Rational DOORS object
To link a ClearQuest record to a Rational DOORS object:
1. Select the ClearQuest record on the Report/Details tab of the integration 

form dialog box.

2. In the formal module, select the Rational DOORS object to which you want 
to link the record.

3. Right click in the Rational DOORS formal module and select ClearQuest > 
Linking > Create Link.

The link is created.

Displaying link information in a Rational DOORS module
ClearQuest link information is stored in the Rational DOORS module in an 
attribute called CQ Links. This attribute is created automatically the first time a 
link is created between a ClearQuest record and a Rational DOORS object. The 
CQ Links attribute holds information about the ClearQuest record that is linked 
to the Rational DOORS object. The information held in the attribute depends 
on the ClearQuest fields selected when Rational DOORS for ClearQuest 
Interface is configured.
You can use Rational DOORS for ClearQuest Interface to create a view called 
ClearQuest Status View. The CQ Links attribute is displayed in a column in 
the ClearQuest Status View. To create this view select ClearQuest > Status 
View > Create Status View from the right click menu within the module.
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You can refresh the view to show new link information by selecting ClearQuest 
> Status View > Update Status View from the right click menu. The latest link 
information for the current Rational DOORS project is retrieved from 
ClearQuest, and an information dialog is displayed stating that the CQ Status 
Files have been updated successfully.

Note  Rational DOORS for ClearQuest Interface has to access the 
ClearQuest database to retrieve this information. You may be 
prompted to log into the ClearQuest database.

Finding Rational DOORS objects linked to a ClearQuest record
You can trace links from a ClearQuest record to a Rational DOORS object using 
Rational DOORS for ClearQuest Interface.
To trace linked Rational DOORS objects:
1. On the Report/Details tab of the integration form, select the ClearQuest 

record you want to check for links.

2. Click the Requirements button.

Any Rational DOORS modules that contain objects that are linked to the 
selected record are opened in read-only mode and filtered to display only the 
linked objects.

Finding ClearQuest records linked to a Rational DOORS object
You can trace links from a Rational DOORS object to a ClearQuest record using 
Rational DOORS for ClearQuest Interface.
To trace linked ClearQuest records:
1. In the Rational DOORS formal module, select the ClearQuest Status 

View from the Views drop down list.

ClearQuest link information is displayed in the CQ Links attribute column 
in this view.

2. Right click on an object that has a link to a ClearQuest record and select 
ClearQuest > Reports > Show Enhancement Requests or ClearQuest 
> Reports > Show Defects.

The Rational DOORS for ClearQuest Interface form is opened. The 
Report/Details tab is displayed and ClearQuest records that are linked to 
the selected Rational DOORS object are listed.
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Deleting links

Deleting links
To delete links between Rational DOORS objects and ClearQuest 
records:
1. Select the ClearQuest Status View from the drop down views list in the 

Rational DOORS formal module

2. Select the Rational DOORS object containing the link that you want to 
delete.

3. Right click and select ClearQuest > Reports > Show Defects or 
ClearQuest > Reports > Show Enhancement Requests.

The Rational DOORS for ClearQuest Interface form is opened. The 
Report/Details tab is displayed and ClearQuest records that are linked to 
the selected Rational DOORS object are listed.

4. Select the ClearQuest record that is the target of the link you want to delete.

5. In the formal module right click on the Rational DOORS object that was 
selected in Step 2 and select ClearQuest > Linking > Delete Link.

The link is deleted and the a message is displayed.

Note  The deleted link is displayed in the ClearQuest Status 
View until you update the view. To update the status 
view select ClearQuest > Status View > Update 
Status View from the right click menu in the formal 
module.
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5 Contacting support
This chapter contains the following topics:

• Contacting IBM Rational Software Support

• Prerequisites

• Submitting problems

• Other information

Contacting IBM Rational Software Support
If the self-help resources have not provided a resolution to your problem, you 
can contact IBM Rational Software Support for assistance in resolving product 
issues.

Note  If you are a heritage Telelogic customer, you can go to 
http://support.telelogic.com/toolbar and download the 
IBM Rational Telelogic Software Support browser toolbar. 
This toolbar helps simplify the transition to the IBM Rational 
Telelogic product online resources. Also, a single reference 
site for all IBM Rational Telelogic support resources is 
located at 
http://www.ibm.com/software/rational/support/telelogic/

Prerequisites
To submit your problem to IBM Rational Software Support, you must have an 
active Passport Advantage® software maintenance agreement. Passport 
Advantage is the IBM comprehensive software licensing and software 
maintenance (product upgrades and technical support) offering. You can enroll 
online in Passport Advantage from 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html.

• To learn more about Passport Advantage, visit the Passport Advantage 
FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_
quickguides.html.

• For further assistance, contact your IBM representative.

To submit your problem online (from the IBM Web site) to IBM Rational 
Software Support, you must additionally:
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• Be a registered user on the IBM Rational Software Support Web site. For 
details about registering, go to 
http://www-01.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.

Submitting problems
To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a 
problem to IBM, you are asked to supply a severity level. Therefore, you 
need to understand and assess the business impact of the problem that you 
are reporting.

Use the following table to determine the severity level.

2. Describe your problem and gather background information, When 
describing a problem to IBM, be as specific as possible. Include all relevant 
background information so that IBM Rational Software Support specialists 
can help you solve the problem efficiently. To save time, know the answers 
to these questions:

• What software versions were you running when the problem occurred?

To determine the exact product name and version, use the option 
applicable to you: 

Severity Description

1 The problem has a critical business impact: You are unable to 
use the program, resulting in a critical impact on operations. 
This condition requires an immediate solution.

2 This problem has a significant business impact: The program 
is usable, but it is severely limited.

3 The problem has some business impact: The program is 
usable, but less significant features (not critical to 
operations) are unavailable.

 4 The problem has minimal business impact: The problem 
causes little impact on operations or a reasonable 
circumvention to the problem was implemented.
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Submitting problems

• Start the IBM Installation Manager and click File > View Installed 
Packages. Expand a package group and select a package to see the 
package name and version number. 

• Start your product, and click Help > About to see the offering 
name and version number. 

• What is your operating system and version number (including any 
service packs or patches)? 

• Do you have logs, traces, and messages that are related to the problem 
symptoms? 

• Can you recreate the problem? If so, what steps do you perform to 
recreate the problem? 

• Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components? 

• Are you currently using a workaround for the problem? If so, be 
prepared to describe the workaround when you report the problem.

3. Submit your problem to IBM Rational Software Support. You can submit 
your problem to IBM Rational Software Support in the following ways:

• Online: Go to the IBM Rational Software Support Web site at 
https://www.ibm.com/software/rational/support/ and in the Rational 
support task navigator, click Open Service Request. Select the 
electronic problem reporting tool, and open a Problem Management 
Record (PMR), describing the problem accurately in your own words.

For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html

You can also open an online service request using the IBM Support 
Assistant. For more information, go to 
http://www-01.ibm.com/software/support/isa/faq.html.

• By phone: For the phone number to call in your country or region, go 
to the IBM directory of worldwide contacts at 
http://www.ibm.com/planetwide/ and click the name of your country 
or geographic region. 

• Through your IBM Representative: If you cannot access IBM 
Rational Software Support online or by phone, contact your IBM 
Representative. If necessary, your IBM Representative can open a 
service request for you. You can find complete contact information for 
each country at http://www.ibm.com/planetwide/.
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If the problem you submit is for a software defect or for missing or inaccurate 
documentation, IBM Rational Software Support creates an Authorized Program 
Analysis Report (APAR). The APAR describes the problem in detail. Whenever 
possible, IBM Rational Software Support provides a workaround that you can 
implement until the APAR is resolved and a fix is delivered. IBM publishes 
resolved APARs on the IBM Rational Software Support Web site daily, so that 
other users who experience the same problem can benefit from the same 
resolution.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software Web site on http://www.ibm.com/software/rational/.
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6 Notices
© Copyright IBM Corporation 1993, 2009
US Government Users Restricted Rights - Use, duplication, or disclosure 
restricted by GSA ADP Schedule Contract with IBM Corp.
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user’s responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan  
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
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THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
1 Rogers Street 
Cambridge, Massachusetts 02142 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 



Using Rational DOORS for ClearQuest Interface           23

Trademarks

may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of 
International Business Machines Corp., registered in many jurisdictions 
worldwide. Other product and service names might be trademarks of IBM or 
other companies. A current list of IBM trademarks is available on the Web at 
www.ibm.com/legal/copytrade.html.
FLEXnet is a registered trademark or trademark of Macrovision Corporation.
Microsoft and Windows are trademarks of Microsoft Corporation in the United 
States, other countries, or both.
Other company, product or service names may be trademarks or service marks 
of others.



Notices

24    Using Rational DOORS for ClearQuest Interface



Using Rational DOORS for ClearQuest Interface           25

Index

C
ClearQuest

editing,   13
finding records linked to DOORS,   14
linking to DOORS,   13
query results,   12
querying,   11

configuring
forms,   6
projects,   5

F
forms, configuring,   6

I
IBM Customer Support,   17
integration types,   5

L
links

deleting,   15
displaying,   13
finding,   14

P
projects, configuring,   5

R
Rational DOORS for ClearQuest Interface

configurations,   3
functions,   3
introduction,   3



Index

26    Using Rational DOORS for ClearQuest Interface


	Table of contents
	About this manual
	Typographical conventions
	Related documentation

	Concepts
	About Rational DOORS for ClearQuest Interface
	About Rational DOORS for ClearQuest Interface functions
	Configuring Rational DOORS for ClearQuest Interface

	Configuring Rational DOORS for ClearQuest Interface
	Configuring projects
	Configuring forms

	Using Rational DOORS for ClearQuest Interface
	Querying the ClearQuest database
	Viewing query results
	Editing a ClearQuest record
	Linking a ClearQuest record to a Rational DOORS object
	Displaying link information in a Rational DOORS module
	Finding Rational DOORS objects linked to a ClearQuest record
	Finding ClearQuest records linked to a Rational DOORS object
	Deleting links

	Contacting support
	Contacting IBM Rational Software Support
	Prerequisites
	Submitting problems
	Other information

	Notices
	Trademarks

	Index

