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1 About this manual
Welcome to Telelogic® DOORS® 9.1, a powerful tool that helps you to capture, 
track and manage your user requirements.
This book describes how to use the basic features of Telelogic DOORS 
(DOORS). It assumes that you’ve read Getting Started with Telelogic DOORS, 
which introduces DOORS and explains the concepts behind it.

Typographical conventions
The following typographical conventions are used in this manual:

Related documentation
The following table describes where to find information in the documentation 
set:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus. For example: Click Yes to continue.

Italics Book titles

Courier Commands, files, and directories; computer output. For 
example: Edit your .properties file.

> A menu choice. For example: Select File > Open. This means 
select the File menu, then select the Open command from it.

For information on See

What’s new in version 9.1 of DOORS The Telelogic DOORS readme file

How to install DOORS Telelogic DOORS Installation Guide

How to set up licenses to use DOORS Telelogic Lifecycle Solutions Licensing 
Guide
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You’ll find PDF versions of these manuals on:

• The Telelogic Lifecycle Solutions DVD

• The support website at https://support.telelogic.com

How to use DOORS Getting Started with Telelogic DOORS 
Using Telelogic DOORS

How to write requirements Get it Right the First Time

How to set up and manage DOORS Managing Telelogic DOORS

The DXL programming language DXL Reference manual

How to integrate DOORS with other 
applications

Telelogic DOORS API Manual

For information on See
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2 Basics
This chapter contains the following topics:

• Starting DOORS

• Changing the DOORS Explorer display

• Making selections in the DOORS Explorer

• Changing the appearance of the module toolbar

• Understanding location

• Understanding favorites

• Opening a module

• Requesting a module lock

• Making selections in a module window

• Using drag-and-drop

• Cutting, copying and pasting

• Closing a module

• Stopping DOORS

Starting DOORS
To start DOORS:
1. On Windows® computers, click Start > Programs > Telelogic > DOORS 

9.1.

2. When the DOORS Login screen is displayed, type in your DOORS 
username and password, and click OK.

Note  Your username and password are case sensitive.
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If the username or password box is unavailable, you don’t have to type your 
username or password.

3. If a message is displayed telling you that your password has expired, go to 
Step 4. This message is displayed if you have not run DOORS before.

If this message is not displayed, go to Step 5.

4. Change your password:

a. Click OK to dismiss the message.

b. In the Old password box, type your current password. If you have not 
logged on to DOORS before and do not have a password, leave the Old 
password box blank.

c. In the New password and Confirm new password boxes, type the 
new password you want to use.

d. Click OK.

e. Click OK.

5. The DOORS Explorer is displayed.

Your username and user type are shown on the status bar at the bottom of the 
window.

Note  When your password expires, the next time you log on to 
DOORS, you’ll be asked to change your password. If you 
want to change it before it expires, in the DOORS Explorer, 
click Tools > Options. Then click the Password tab, and 
click Change Password.
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Changing the DOORS Explorer display

Changing the DOORS Explorer display
Use the following options on the DOORS Explorer’s view menu to change the 
way your screen looks and control what data is displayed.

View menu option Description

Database View
Project View

Switches between Database view and Project view. 
When you start DOORS, the top-level items that are 
displayed in the left pane of the DOORS Explorer 
depend on your view:

• In Database view, the root of the database tree  is 
displayed. Below this, the parts of the database you’re 
allowed to access are displayed.

• In Project view, a list of the projects you’re allowed to 
access is displayed.

Show Projects Controls whether projects are displayed. Projects have 
icons like this: 

Show Folders Controls whether folders are displayed. Folders have icons 
like this .

Show Formal Modules Controls whether formal modules are displayed. Formal 
modules have icons like this .

Show Link Modules Controls whether link modules are displayed. Link 
modules have icons like this .

Show Descriptive 
Modules

Controls whether descriptive modules are displayed. 
Descriptive modules have icons like this .

Show Deleted Items Controls whether deleted projects, folders and modules 
are displayed.
A deleted item has a red cross in the corner of its icon. 
For example, the icon for a deleted formal module looks 
like this .

Sort by Name Sorts the items in the right pane using the values in the 
Name column.
It sorts folders and projects first, followed by a sorted list 
of modules.
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Making selections in the DOORS Explorer
The DOORS Explorer works like Windows Explorer:

• In the left pane, click an item to select and open it. Its contents are displayed 
in the right pane.

In Project view, the left pane contains one or more top-level projects . In 
Database view, the left pane contains a single top-level item (Database ).

• The menu options apply to whatever is currently selected.

For example, if you select the folder Myfolder and then you right-click 
Properties, the properties sheet for Myfolder is displayed.

• Some project and folder options, such as Delete and Purge, are only available 
if you select the project or folder in the right pane. This is because the 
options are not available when the project or folder is open.

The project or folder you select in the left pane is open. It has an open 
project  or open folder icon .

• Modules are only shown in the right pane. 

Double-click a module to select and open it. Each module you double-click 
is opened in a separate module window.

Sort by Type Sorts the items in the right pane using the values in the 
Type column.

Sort by Description Sorts the items in the right pane using the values in the 
Description column.

Sort by Deleted Sorts the items in the right pane using the values in the 
Deleted column.

Customize Toolbars Controls which toolbars are displayed. For more 
information, see “Changing the appearance of the 
DOORS Explorer toolbar,” on page 7.

Refresh Refreshes the screen display.

View menu option Description
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Changing the appearance of the DOORS Explorer toolbar

Selecting multiple items

To select multiple items in the right pane of the DOORS Explorer, use 
CTRL+Click (hold down the CTRL key, and then click each item you want to 
select).
To quickly select a group of items that are next to each other, use 
SHIFT+Click:

1. Click the first item in the group.

2. Press and hold down SHIFT, and then click the last item in the group.L

3. Release SHIFT.

Changing the appearance of the DOORS Explorer toolbar
To allow you to customize the appearance of the DOORS Explorer toolbar, 
buttons are arranged in logical groups that you can choose to hide or display. For 
example, buttons that can control favorites are grouped together on a separate 
Favorites toolbar.
You can change the appearance of the toolbar in two ways. You can either use 
the Customize Toolbars dialog box or right-click the DOORS Explorer 
toolbar.
To change the appearance of the toolbar using the Customize Toolbars 
dialog box:
1. In the DOORS Explorer, either click View > Customize Toolbars or press 

CTRL+O.

The Customize Toolbars dialog box is displayed.

2. Select or clear the check box for each group.

3. If you want to display the default toolbars, select Reset to Default.
The toolbars that are displayed by default are:

• Favorites
• Location
• Project

4. Click Close.

To change the appearance of the toolbar by right-clicking the DOORS 
Explorer toolbar:
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• Right-click the DOORS Explorer toolbar, and select or clear the check box 
for each group:

Changing the appearance of the module toolbar
To allow you to customize the appearance of the module toolbar, buttons are 
arranged in logical groups that you can choose to hide or display. For example, 
buttons that can control the alignment of columns are grouped together on a 
separate Column Alignment toolbar, buttons for use when working with tables 
are on the Table toolbar, and so on.
You can change the appearance of the toolbar in two ways. You can either use 
the Customize Toolbars dialog box or right-click the module toolbar.
To change the appearance of the toolbar using the Customize Toolbars 
dialog box:
1. In the module, either click View > Customize Toolbars or press 

CTRL+O.

The Customize Toolbars dialog box is displayed.

2. Select or clear the check box for each group.

3. If you want to display the default toolbars, select Reset to Default.
The toolbars that are displayed by default are:

• Column
• Display
• Link
• Module
• Object
• Object Edit
• View

4. Click Close.

To change the appearance of the toolbar by right-clicking the module 
toolbar:
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Understanding location

• Right-click the module toolbar, and select or clear the check box for each 
group:

Understanding location
The path to the project or folder that is currently open is displayed in the 
Location field of the DOORS Explorer.

Note  The path is from the nearest parent project, not from the 
database root.
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As you navigate around the database, the path to each project and folder that you 
open is stored in the Location field. If you want to return to a folder or project 
you have opened previously, you can select it from the Location drop-down list. 
The project or folder is opened in the left pane of the Explorer, and its contents 
are displayed in the right pane.

Note  The Location field is cleared when you close your current 
DOORS session. If you want to be able to easily access a 
project, folder or module across sessions, you should add it 
to your favorites list. For more information on favorites, see 
“Understanding favorites,” on page 10.

If you know the path to the project, folder or module you want to open, type the 
path into the Location field and press Enter. Alternatively, you can paste the 
DOORS URL of an item into the Location field and press Enter. Projects and 
folders are opened in the left pane of the DOORS Explorer, modules are opened 
in default edit mode.

Understanding favorites
If you use certain projects, folders or modules regularly, you can add them to 
your Favorites list. Instead of navigating through the database hierarchy to access 
your data, you can select the project, folder or module from your favorites list in 
the DOORS Explorer.

• If you select a project or folder from your favorites list, it is opened in the 
left pane of the DOORS Explorer and its contents are displayed in the right 
pane.

• If you select a module from you favorites list, it is opened. The edit mode in 
which the module is opened depends on your access rights and your default 
edit mode.

Note  Your location in the database does not change when you 
open a module from your favorites list. This means you can 
open a module in a different project or folder without having 
to navigate back through the database hierarchy to your 
original location.

To add a project, folder or module to your favorites list:
1. In the DOORS Explorer, select the project, folder or module you want to 

add to Favorites.

2. Either:
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Understanding favorites

• Click File > Favorites > Add to Favorites.
• Click Add to Favorites  on the Project toolbar.

The item is added to your favorites list.

Organizing your favorites list
As your favorites list grows, you can maintain it using Organize Favorites. 
Click Favorites > Organize Favorites to open the Organize Favorites dialog 
box.
The buttons on the Organize Favorites dialog box are described in the table 
below.

Button Description

Edit Select an item and click Edit to change its label in your favorites 
list. For example, you may want to distinguish between two 
identically named modules, or between a folder and module of the 
same name.
Note You are not changing the actual name of the project, folder 

or module, just the label that is displayed in your favorites 
list.

Remove Select an item and click Remove to remove it from your favorites 
list.

Refresh Click this button to redraw your favorites list.
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How changes to the database affect Favorites
The following table describes how changes to the database are reflected in your 
favorites list.

Arrow buttons Select an item and click the up or down arrow to move it. The 
order in which the items appear in the Organize Favorites dialog is 
the order in which they appear in the drop down list on the 
DOORS Explorer.

If Then

A project, folder or 
module is moved

DOORS automatically updates the path in your favorites 
list. 

A project, folder or 
module is renamed

The name of the item in your favorites list does not 
change. You can still access it by selecting its old name 
from your favorites list.

A project, folder or 
module is deleted

The item is not removed from the drop down list in the 
Explorer, but if you select it, a message informs you that 
the item has been deleted. The item is marked as deleted 
in the Organize Favorites dialog box.

Your access to a 
project, folder or 
module is removed

The project, folder or module is removed from your 
favorites list.

Button Description
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Opening a module

Opening a module
To open a module, do one of the following:
• Double-click it in the DOORS Explorer. 

The module is opened in your default edit mode, which is normally exclusive 
edit mode. For more information, see “Understanding edit modes,” on page 
38.

• Single-click the module in the DOORS Explorer to select it. Click File > 
Open, then either Read-only, Shareable Edit or Exclusive Edit 
depending on which edit mode you want.

• Single-click the module in the DOORS Explorer to select it. Right-click 
Open, then either Read-only, Shareable Edit or Exclusive Edit 
depending on which edit mode you want.

• Click the File menu in the DOORS Explorer. If DOORS has been 
configured to display recently opened modules, and you have opened 
modules previously, a list of those modules is displayed in the File menu. 
Click on a module to open it in your default edit mode. For information 
about configuring the recent module list display, see “Showing your user 
options,” on page 391.

The title bar of the module window shows the module name followed by either 
Current or Baseline, the module version and the path to the module from the 
nearest project above it in the database tree. The path starts with a slash (/) 
followed by the name of the project.
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This example shows the User Requirements module, which is in the 
Requirements folder of the Sports utility vehicle 4x2 project.

Requesting a module lock
If you try to open a module that another user already has open, the Request 
Lock dialog box is displayed. The options on the dialog box are described in the 
following table. Select the options you want, then click OK.

Select... To...

Open module Enable the edit mode drop down list. 
If another user has an exclusive edit lock on the module, 
the only option available is read-only. If one or more users 
have shareable edit locks on the module, you can select 
whether to open in shareable edit mode or read-only 
mode. When you click OK, the module is opened in the 
selected edit mode.
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Making selections in a module window

Note  Lock request messages are not delivered to DOORSnet 
users. However, if you select Alert me when lock is 
available, you will receive an alert when the DOORSnet user 
releases the lock.

Making selections in a module window
In a module window, you click an object to make it the current object. The way 
in which the current object is differentiated from other objects depends on 
which display scheme you’re using:

• In the Modern display scheme, the current object has a line above and below 
it.

• In the Classic display scheme, it is highlighted with a dark blue background.

To select an object, use SHIFT+Click. The selected object’s text turns a 
maroon color.

Selecting multiple objects

CTRL+Click does not work in module windows. You can’t select objects that 
aren’t next to each other.
To select a group of objects that are next to each other, use SHIFT+Click:

1. Click the first object in the group.

2. Press and hold down SHIFT, and then click the last object in the group.

3. Release SHIFT.

The objects that have been selected are displayed in a different color.

Send a message Open a Lock Request Message dialog box when you 
click OK. 
You can type a message into the Lock Request Message 
dialog box, which will be displayed to the user or users 
who currently hold a lock. Those users can optionally 
reply to your message.

Alert me when lock is 
available

Receive a message alert when the lock on the module is 
released. You can open the module directly from the 
message alert.

Select... To...
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The object trees below the first and last objects that you select are automatically 
selected too. And if the first and last objects are at different levels in the database 
tree, additional objects are selected so that all selected objects have a common 
ancestor. This ensures that subsequent operations on the selected objects 
preserve the integrity of your data.
If you have a filter applied to the module, and you select multiple objects, the 
selection also includes objects that are hidden by the filter, but that exist between 
the first and last object in your selection.

Selecting everything

To select all the objects in a module:
1. Press HOME to go to the start of the module.

2. Press and hold down SHIFT while using the scroll bar to go to the end of 
the module.

3. Click the last object in the module.

The text in all the objects is displayed in a different color.

Using drag-and-drop
You can use drag-and-drop in the DOORS Explorer and in formal module 
windows.
For information on what happens to links when you use drag-and-drop, see 
“Understanding how copy and move affect links,” on page 223.

In the DOORS Explorer

Use drag-and-drop to move or copy projects, folders and modules:

• To move an item, click it and then drag it to the target location.

You can’t move a module if it’s open. You can’t move a folder or project if 
the folder or project, or anything in it, is open. For example, you can’t move 
a folder if it contains a module that’s open.

• To copy an item, hold down CTRL while you drag-and-drop the item.

You can’t copy a module if it’s open in exclusive edit mode. You can’t copy a 
folder or project if the folder or project contains a module that’s open in 
exclusive edit mode.

In a module window

Use drag-and-drop to either:
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Using drag-and-drop

• Move objects within a module.

• Copy objects within a module or between modules.

• Copy then link objects within a module or between modules.

You cannot use drag and drop to copy or move objects within a module if a sort 
is applied. If you are using drag and drop to copy objects between modules, the 
source module can have a sort applied but the target module must have sorting 
turned off. 
You can copy or move tables within a module or between modules using 
drag-and-drop. The Below and Below with hierarchy options are unavailable 
for all operations. To copy or move a table using drag-and-drop, click on any cell 
in the table, and follow the instructions below.
Click the object you want to move or copy, then drag it to the target location. If 
you want to copy the current object after or below itself, drag it over the current 
object. When you release the mouse button, a pop-up menu is displayed that 
includes the following options:

Pop-up menu option Description

Move > After Moves the selected object and all the objects in the tree 
below it to the same level as, and immediately after, the 
target object.

Move > Below Moves the selected object and all the objects in the tree 
below it to one level below the target object.
If the target object already has children, the copied object 
becomes its first child.

Copy > After (with 
hierarchy)

Copies the selected object and all the objects in the tree 
below it to the same level as, and immediately after, the 
target object.

Copy > Below (with 
hierarchy)

Copies the selected object and all the objects in the tree 
below it to one level below the target object.
If the target object already has children, the copied object 
becomes its first child.

Copy > After Copies the selected object to the same level as, and 
immediately after, the target object.
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To drag multiple objects, don’t release the mouse button after making the 
multiple object selection. You lose your selection if you release the mouse button 
between selecting the objects and dragging them.
When you use drag-and-drop to copy objects between modules, only the Object 
Heading, Object Text and Object Short Text attributes are copied. If you 
want to copy other attributes between modules, use the object copier (see “Using 
the object copier,” on page 68).

Copy > Below Copies the selected object to one level below the target 
object.
If the target object already has children, the copied object 
becomes its first child.

Copy then link from 
Start > After (with 
hierarchy)

Same as the Copy after (with hierarchy) option, except 
it also creates a link from each source object to its copy.

Copy then link from 
Start > Below (with 
hierarchy)

Same as the Copy below (with hierarchy) option, except 
it also creates a link from each source object to its copy.

Copy then link from 
Start > After

Same as the Copy after option, except it also creates a 
link from the source object to its copy.

Copy then link from 
Start > Below

Same as the Copy below option, except it also creates a 
link from the source object to its copy.

Copy then link to Start 
> After (with hierarchy)

Same as the Copy after (with hierarchy) option, except 
it also creates a link to each source object from its copy.

Copy then link to Start 
> Below (with 
hierarchy)

Same as the Copy below (with hierarchy) option, except 
it also creates a link to each source object from its copy.

Copy then link to Start 
> After

Same as the Copy after option, except it also creates a 
link to the source object from its copy.

Copy then link to Start 
> Below

Same as the Copy below option, except it also creates a 
link to the source object from its copy.

Pop-up menu option Description
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Cutting, copying and pasting

When you use the Copy then link to Start and the Copy then link from Start 
options, the usual rules that control linking apply. You need to have the 
necessary access rights to make the links.

Cutting, copying and pasting
You can cut, copy and paste in the DOORS Explorer and in formal module 
windows.
For information on what happens to links when you cut, copy and paste, see 
“Understanding how copy and move affect links,” on page 223.

In the DOORS Explorer

Use the Edit menu or keyboard shortcuts to cut, copy and paste projects, folders 
and modules.

Edit menu Keyboard Description

Cut CTRL+X Cuts the currently selected items, and places them on 
the DOORS Explorer clipboard.

Copy CTRL+C Copies the currently selected items to the DOORS 
Explorer clipboard.

Paste CTRL+V Pastes the contents of the DOORS Explorer 
clipboard to the DOORS Explorer window.

Paste Special Provides advanced options for pasting a module. This 
option is not available when a project or folder has 
been copied.
For more information, see “Paste special,” on page 
27.

Undo Cut
Undo Copy

CTRL+Z Undoes the last cut or copy operation.

Clear Clears the DOORS Explorer clipboard. 
You should clear the clipboard after you finish pasting 
to avoid leaving share locks on modules. Share locks 
are not normally problematic, but can prevent users 
from changing edit modes within the module.
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You can’t cut a module if it’s open. You can’t cut a folder or project if the folder 
or project, or anything in it, is open. For example, you can’t cut a folder if it 
contains a module that’s open.
You can’t copy a module if it’s open in exclusive edit mode. You can’t copy a 
folder or project if the folder or project contains a module that’s open in 
exclusive edit mode.
When you cut data to the DOORS Explorer clipboard, if you have not yet pasted 
it back and then do anything that could overwrite the data on the clipboard, such 
as copying other data to the clipboard, your original cut operation is 
automatically undone.

Note  Copying a module does not copy the baselines associated 
with the module. Copying a project containing modules that 
have baselines does not retain those baselines.

In a module window
In a module window, use the Edit menu or keyboard shortcuts to cut, copy and 
paste objects within a module.

Note  If you want to copy objects between modules, use the object 
copier (see “Using the object copier,” on page 68).

Edit menu Keyboard Description

Cut CTRL+X Cuts the current object and all the objects in the tree 
below it.
The objects are removed from the module and placed 
on the object clipboard for that module.

Copy CTRL+C Copies objects to the module’s object clipboard:

• To copy the current object only, either press 
CTRL+C or click Copy > Copy. 

• To copy the current object and all the objects in 
the tree below it, click Copy > Copy with 
Hierarchy.
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Closing a module

Each module has its own object clipboard.

Note  When you’re editing the attributes of an object, you can also 
use the keyboard shortcuts to cut, copy and paste selected 
text in the object. This uses your computer’s system 
clipboard. You can paste the contents of the system 
clipboard to other applications, such as Microsoft Word.

When you cut data to the object clipboard, if you have not yet pasted it back to 
the module and then do anything that could overwrite it, such as copying another 
object to the clipboard, a message is displayed warning that you haven’t pasted 
the data currently on the clipboard. You are offered three choices:

• Delete

This overwrites the data currently on the clipboard with the new data.

• Restore

This pastes the data currently on the clipboard back to where it was cut 
from, then writes the new data to the clipboard.

• Cancel

This cancels the operation, leaving the data currently on the clipboard 
unchanged.

Closing a module
To close a module:
1. In the module window, click File > Close.

2. If you’ve made any changes that you haven’t saved yet, a message is displayed 
asking if you want to save your changes.

Paste CTRL+V Pastes the contents of the module’s object clipboard:

• To paste to the same level as, and immediately 
after, the current object, either press CTRL+V or 
click Paste, then Paste.

• To paste to one level below the current object, 
click Paste > Paste Below.

Clear Clears the contents of the module’s object clipboard.

Edit menu Keyboard Description
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Click Yes to save your changes, or No to discard them.

Note  Whenever you make any changes to a module, your changes 
are stored temporarily in your local computer’s memory. 
They aren’t saved in the database until you explicitly ask to 
save them. They are marked with a red change bar  or , to 
show that they haven’t yet been saved in the database. 
As with all windows, you can also close a module by clicking 
the  in the top right corner.

Stopping DOORS
To stop DOORS:
1. In the DOORS Explorer, click File > Exit.

All the modules you opened are automatically closed.

2. If you edited a module and haven’t saved your changes, a dialog box is 
displayed asking if you want to save your changes before the module is 
closed.

Click Yes to save your changes, or No to discard them.
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3 Managing formal modules
This chapter contains the following topics:

• Creating a formal module

• Controlling access to a formal module

• Paste special

• Showing module properties

• Showing module statistics

• Deleting, undeleting and purging a module

• Managing open modules

Creating a formal module
This topic describes how to create an empty new module. You can also create a 
module by either:

• Copying an existing module in the DOORS Explorer, for example, using 
copy and paste.

• Cloning an existing module. This lets you select which bits of the module 
you want to copy. For example, you can select which attributes you want to 
copy. See “Paste special,” on page 27.

• Copying a baseline (see “Copying a baseline,” on page 289).

To create an empty formal module:
1. In the DOORS Explorer, select the folder or project in which you want to 

create the new module. This is the module’s parent.

You must have create access to the parent.

2. Click File > New > Formal Module.

3. Type the name of the new module in the Name box. 

The name is case-sensitive. For example, the names Mymodule and 
MyMODULE are different.

The name must be unique within the parent project or folder. All the 
projects, folders and modules in the parent must have different names.

The name can contain the following characters:
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• Alphanumeric characters (letters of the alphabet and numbers)
• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

4. If you want to give the module a description, type it in the Description box. 
The description is used as the heading of the main column.

5. By default, the module’s object identifiers start at 1 and have no prefix. If 
you want to override the default, use the Start at and Prefix boxes.

6. If you want to use a template to populate the new module, select the Use a 
template check box, then use Browse to locate it.

DOORS provides a library of templates to help get you up and running 
quickly. For example, there are DoD-STD and MIL-STD templates.

Templates help you keep your modules consistent by encouraging people to 
use a standard structure and headings.

You can create your own templates and add them to the library, which is in 
the DOORS home directory, in \doors_9.1\lib\dxl\standard. For 
more information, see the DXL Reference Manual, which can be accessed 
from DOORS by clicking Help > DXL Reference Manual.
Note  You can also insert a template into an existing module. 

For more information, see “Inserting templates,” on 
page 67.

7. Click OK.

The module is created. It inherits its access rights from its parent.

Note  If you receive the error Cannot create this Module: Lock 
request timed out when you try to create the module, wait a 
moment, then try again. This error is generated if another 
DOORS user is performing a paste operation when you click 
OK to create the module.

Controlling access to a formal module
To change the access rights for a formal module, you must have admin access to 
the module.
To change the access rights for a formal module:
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Controlling access to a formal module

1. You can change the access rights for a module from either the DOORS 
Explorer or the module window:

• In the DOORS Explorer, select the module then right-click Properties. 
• In the module window, click File > Module Properties.

2. Click the Access tab.

The current access rights for the module are displayed.

Note  You cannot open a module unless you have read access 
to the parent project or folder.

If the module is partitioned in, the access rights associated with the partition 
are displayed. These describe the maximum access that any user has. They 
override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RCMDA), but the module is 
partitioned in read only, in practice the user only has read (R) access.

You need this 
access right

To

Read (R) See the module. If you don’t have read access, the module 
is not displayed in your DOORS Explorer.
Set your own default view for the module (see “Setting 
default views,” on page 82).

Create (C) Create top-level objects in the module.
Create attribute types and attribute definitions for the 
module.

Modify (M) Change the module’s name, description, attribute values, 
default view.
Create baselines of the module.

Delete (D) Delete, undelete and purge the module.
Cut the module to the DOORS Explorer clipboard.

Admin (A) Partition the module out.
Change the access rights for the module.
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3. Make the changes you want.

4. Click OK.

Access tab Description

Inherit from parent Select this check box if you want the module to inherit its 
access rights from the project or folder that it’s in.
When this check box is selected, the list of access rights is 
unavailable, and shows what access rights the module is 
inheriting.

Add To add a new entry to the list of access rights:
a. Click Add.

The Add Access window is displayed.
b. In the Name box, select the name of the user or 

group that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select 
the entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit.

The Edit Access window is displayed.
b. Select the access rights you want to give them, then 

click OK.

Additional access Select the additional access rights that you want to 
propagate with create access.
The additional rights are propagated to the objects in the 
module that inherit their access rights from the module.
Note Module attributes cannot inherit access rights, so 

additional access rights do not apply to module 
attributes and their values.

For more information, see the section topic on 
propagating extra access rights in Getting started with 
Telelogic DOORS, which is available on the Telelogic 
Lifecycle Solutions DVD.
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Paste special

Paste special
When you select Paste Special, you create a new module by copying the 
structure of an existing module. You can copy:

• Object Heading and Object Text

• The heading structure only, including the heading text

• The columns in a particular view

• Attribute types and definitions

Baselines are not copied.
To use Paste Special:
1. In the DOORS Explorer, select the module you want to copy.

2. Click Edit > Copy.

3. Select the folder or project to which you want to copy the module and click 
Edit > Paste Special.
You must have create access to the folder or project.

4. In the New module name box, type the name you want to give the new 
module.
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The name is case-sensitive. For example, the names Mymodule and 
MyMODULE are different.

The name must be unique within the parent project or folder. All the 
projects, folders and modules in the parent must have different names.

The name can contain the following characters:

• Alphanumeric characters (letters of the alphabet and numbers)
• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

The name cannot be more than 460 characters in length.

5. If you want to give the new module a description, type it in the Description 
box. The description is used as the heading of the main column.

6. By default, the new module’s object identifiers start at 1 and have no prefix. 
If you want to override the default, use the Start at and Prefix boxes.

7. In the list of views, select the view you want to copy.

Note  The standard view is always copied. If you select another 
view, you get the standard view as well as the view you 
select.

8. You can choose whether to copy Object Heading and Object Text, or just 
the Object Heading.

• If you want to copy both Object Heading and Object Text select All 
objects.

• If you only want to copy the Object Heading structure and text select 
Objects with object heading.

• If you do not want to copy any objects, clear the Objects with object 
heading and All objects boxes.

9. By default, the main column is copied.

Select the Columns check box if you want to copy all the columns in the 
selected view.

10. By default, no attribute types or definitions are copied.

If you want to copy attribute types and definitions:

a. Select the appropriate Copy check box.

b. Click Select.
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Showing module properties

A list of all the non-system attribute definitions or types is displayed.

c. Select the ones you want to copy, then click Close.

11. By default, the copied links in the new module use the same link modules as 
the links in the original module.

If you want to use a different link module:

a. Select the Links Copy check box.

b. Click Select.
c. Clear the Through same link module check box.

d. Select the link module you want to use, then click Close.

12. By default, external links are not copied. If you want to copy external links 
select the External Links Copy check box. If the module does not contain 
any external links, the check box is not available.

13. Click OK.

Showing module properties
To show the properties of a formal module:
Either:

• In the module window, click File > Module Properties.
• In the DOORS Explorer, select the module in the right pane, then 

right-click Properties.
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The properties sheet for the module is displayed.

General tab Description

Name The name of the module.

Description Additional information about the module.

Type The type of item whose properties are being displayed. This is 
Formal and can’t be edited.

URL The URL of the module.

Copy URL Copies the URL to the system clipboard. For more 
information about DOORS URLs see “Understanding 
DOORS URLs,” on page 259.
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Showing module properties

List of attributes This is a list of all the module’s attributes. For each attribute, it 
shows the name of the attribute, the description and its value.
If you want to edit module attributes from the Properties 
window, open the module before you open the Module 
Properties dialog box.

View/Edit To change the value of an attribute:
a. Select the attribute in the list of attributes, and then 

click View/Edit.
b. Enter the new attribute value.

c. Click OK.

List of Baseline Set 
Definitions

The baseline set definitions that include the module

View Select a baseline set definition and click View to view the 
definition

Generate history 
for the creation and 
deletion of links

Select this option if you want to record the creation and 
deletion of links in the module history.

For information 
on this tab

See

Access Either:

• The help for the Access tab (click the Access tab, then 
click Help).

• “Controlling access to a formal module,” on page 24.

History Either:

• The help for the History tab (click the History tab, then 
click Help).

• “Showing module history,” on page 263.

General tab Description
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Showing module statistics
The statistics for a formal module record the number of words and characters in 
the module. If you have a filter applied to the module, the statistics function only 
calculates results for the displayed objects.
To show the statistics for a module:
1. In the module window, click File > Module Properties.
2. Click the Statistics tab.

Linksets Either:

• The help for the Linksets tab (click the Linkset tab, then 
click Help).

• “Using links,” on page 213.

Statistics Either:

• The help for the Statistics tab (click the Statistics tab, then 
click Help).

• “Showing module statistics,” on page 32.

Discussions Either:

• The help for the Discussions tab (click the Discussions 
tab, then click Help).

• “Viewing a module discussion,” on page 249.

Discussions Access 
List

Either:

• The help for the Discussions Access List tab (click the 
Discussions tab, then click Help).

• “Controlling access for discussions in a module,” on page 
247.

For information 
on this tab

See
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Deleting, undeleting and purging a module

3. Click Refresh. DOORS fills in the values on the tab. For large modules, this 
can take some time.

Deleting, undeleting and purging a module
Deleting a module doesn’t destroy any of the module data. It simply marks the 
module as deleted, and stops users from being able to access it. To destroy the 
module, you must purge it once you’ve deleted it.
Purging deleted modules removes them permanently from the database.
You can’t delete a module if any user is accessing the module.
To delete, undelete or purge a module, you must have delete access to the 
module. 
To delete a module:
1. If you currently have the module open, close it (click File > Close).

2. In the DOORS Explorer, select the module you want to delete, then click 
File > Delete.

Statistics tab Description

Total objects Number of objects in the module.

Words in heading 
and text

Number of words in the Object Heading, Object Text and 
Object Short Text attributes.

Characters in 
heading and text

Number of characters in the Object Heading, Object Text 
and Object Short Text attributes.

Words in other 
attributes

Number of words in other attributes of type Text or String.

Characters in other 
attributes

Number of characters in other attributes of type Text and 
String.

Total words Total number of words in attributes of type Text and String, 
including the Object Heading, Object Text and Object 
Short Text.

Total characters Total number of characters in attributes of type Text and 
String, including the Object Heading, Object Text and 
Object Short Text.

Refresh Refreshes the display. This may take a few minutes.
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You can also click Delete  on the Project toolbar, right-click Delete or 
press DELETE.

To undelete a module:
1. In the DOORS Explorer, make sure that deleted items are being displayed.

If necessary, click View > Show Deleted.

2. Select the module you want to undelete, then either click File > Undelete 
or right-click Undelete.

To purge a module:
1. In the DOORS Explorer, make sure that deleted items are being displayed.

If necessary, click View > Show Deleted.

2. Select the module you want to purge then click File > Purge.

A message is displayed asking if you really want to purge the module.

3. Click Yes.

The module is permanently removed from the database.

Managing open modules
Sometimes DOORS or DXL programs open modules in the background 
without displaying them on your screen. This topic describes how to close these 
modules or change their edit mode to read only.
To close a module you can't see or set its edit mode to read only:
1. In the DOORS Explorer, click Tools > Manage Open Modules.

A list of all the modules that you currently have open is displayed.

The modules that were opened but not displayed on your screen have No in 
the Displayed column. 

2. To close a module, select the module, then click Close Modules.

If you have made changes that have not yet been saved, a message is 
displayed asking if you want to save the changes.

3. Click Yes to save your changes, or No to discard them.

4. To change the edit mode of a module to read only, select the module, then 
click Set Modules Read-Only.

If you have made changes that have not yet been saved, a message is 
displayed asking if you want to save the changes.
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Managing open modules

5. Click Yes to save your changes, or No to discard them.

6. To refresh the display, click Refresh.

7. When you have finished, click Close.
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4 Editing
This chapter contains the following topics:

• Understanding edit modes

• Changing the edit mode

• Understanding editable sections

• Setting up a module for sharing

• Working in shareable edit mode

• Requesting a section lock

• In-place editing

• Editing using the object properties sheet

• Undoing edits

• Extended undo

• Saving your changes

• Creating objects

• Controlling access to an object

• Promoting and demoting objects

• Swapping Object Heading and Object Text attributes

• Splitting Object Heading from Object Text

• Deleting, undeleting and purging objects

• Understanding the spelling checker

• Checking spelling

• Inserting symbols

• Inserting URLs

• Inserting templates

• Using the object splitter

• Using the object copier

• Merging object text
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Understanding edit modes
When you work with formal modules, you can use one of three edit modes.

You must have modify access to a module to open it in either shareable or 
exclusive edit mode.
If you open a module by double-clicking it in the DOORS Explorer, it is opened 
in your default edit mode. By default this is exclusive edit mode. For information 
on how to change your default edit mode, see “Configuring DOORS,” on page 
391.
When you open a module using the File menu in the DOORS Explorer, you can 
select the mode in which you want to open the module. For example, if you want 
to open it in exclusive edit mode, click File > Open > Exclusive Edit.
You can change the edit mode of a module once it’s open.

Changing the edit mode
The edit mode you are currently using is shown on the status bar at the bottom 
of the module window.
You must have modify access to a module to open it in either shareable or 
exclusive edit mode.

Edit mode Description

Read only You can read (look at) the module, but you can’t edit it.

Exclusive You can edit the module, but other users can only read it.

Shareable While you’re editing one section of the module, another user can 
edit another section.
You have to lock the section of the module that you want to edit, 
to stop other users from editing it. While you have the section 
locked, other users can only read the data in it. When you’ve 
finished, you unlock the section to allow another user to edit it.
For more information, see “Setting up a module for sharing,” on 
page 41 and “Working in shareable edit mode,” on page 42.
Note In shareable edit mode, you can’t create top-level objects in 

the module. And you can’t create, delete or edit attribute 
definitions or attribute types. You can only do these tasks in 
exclusive edit mode.
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Understanding editable sections

To change the edit mode of an open module:
1. In the module window, click Edit > Edit Mode, then whichever edit mode 

you want (Read-only, Shareable Edit or Exclusive Edit).
If you are changing the edit mode to read only and you have made changes 
that you haven’t saved, a message is displayed asking if you want to save your 
changes. 

2. Click Yes to save your changes, or No to discard them.

3. If you have copied an object, and you change edit modes, a message is 
displayed stating that the clipboard will be cleared when the edit mode is 
changed. Click Confirm to change edit mode and clear the clipboard, or 
Cancel to stay in the same edit mode and keep the contents of the 
clipboard.

Note  If you have opened a link module in read only mode, you 
cannot change the edit mode from within the module. To 
change from read only mode, you have to close the link 
module and reopen it in your chosen edit mode. This is only 
the case for link modules.

Understanding editable sections
If you want to work in shareable edit mode, you first need to set up the module 
for sharing. This involves dividing the module into editable sections. While one 
user is editing one section, another user can edit another section.
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For example, you might want different users to be able to edit different top-level 
sections within a module.

In this example, if each top-level section of the module is an editable section, one 
user can edit the User types section, while another user edits the Project 
Structure section.

Note  Try not to set up editable sections unless you need them. 
Performance gets poorer as the number of editable sections 
increases, because each editable section is stored in a separate 
file in the database.

To set up an editable section, you have to set up specific access rights for the 
object at the top of the section. To do this you stop the object inheriting access 
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Setting up a module for sharing

rights from its parent. On the Access tab of the object properties sheet, you 
clear the Inherit from parent check box.

In this picture two objects, A and D, are not inheriting access rights from their 
parents, so there are two editable sections:

• A’s section consists of A plus all the objects that inherit their access rights 
from A. These are the red objects.

• D’s section consists of D plus all the objects that inherit their access rights 
from D. These are the green objects.

If you select A and D at a later date to inherit their access rights, editable sections 
will be switched off and performance will be improved.

Setting up a module for sharing
To set up a module for sharing, you create editable sections in the module (see 
“Understanding editable sections,” on page 39).
You can either:

• Divide a module into editable sections based on its current object section 
levels. For example, you can make an editable section for each level 1 
section. Or you can make an editable section for each level 2 section.

• Create custom editable sections.
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You must have modify access to the module, and admin access to the objects at 
the start of each new section. 
To divide a module into editable sections based on current section levels:
1. Open the module in exclusive edit mode.

For example, select the module in the DOORS Explorer, then click File > 
Open > Exclusive Edit.

2. Click Tools > Setup for Sharing.

3. Select the section level that you want to make editable sections for, then click 
OK.

Note  If you subsequently add a new section at the specified level, 
you must manually create an editable section for it. Follow 
the steps below to create a custom editable section. 
For example, if you made editable sections at level 1 and you 
add a new level 1 section, you need to make a custom 
editable section for the new level 1 section.

To create custom editable sections for a module:
1. Open the module in exclusive edit mode.

For example, select the module in the DOORS Explorer, then click File > 
Open > Exclusive Edit.

2. Select the object where you want a new editable section to start, then click 
Edit > Object > Properties or right-click Properties.
The new editable section consists of this object and all objects in the tree 
below it that inherit their access rights from it.

3. Click the Access tab.

4. Clear the Inherit from parent check box.

5. Click OK.

6. Repeat Step 2 to Step 5 for each editable section.

7. Save the module to make the changes permanent (click File > Save).

Working in shareable edit mode
Once you’ve set up a module for sharing, you can work in shareable edit mode 
(see “Setting up a module for sharing,” on page 41).
You need to lock a section before you can edit the objects in it, create objects in 
it, or delete objects from it.
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Working in shareable edit mode

To lock a section:
1. In the module window, select any object in the section you want to lock.

2. Click Edit > Section > Lock.

The section containing the current object is locked. If someone else has 
edited the data in the section since you opened the module, DOORS 
refreshes your screen to display the latest data before it locks the section.

If another user already has the section locked, a Request Lock dialog box is 
displayed. Fore more information, see “Requesting a section lock,” on page 
44.

No other users can edit the section until you unlock it. 
To unlock a section:
1. Select any object in the section you want to unlock, then click Edit > 

Section > Unlock.

If you’ve made any changes that you haven’t saved, a message is displayed 
asking if you want to save your changes.

2. Click Yes to save your changes, or No to discard them.

All sections are automatically unlocked when you close the module.

Saving changes when editing in shareable mode

When you are editing in shareable edit mode:

Colors of locked and unlocked sections

The colors used for locked and unlocked sections depend on which display 
scheme you’re using. For example:

• In the Modern scheme, the background color is pale gray for objects that are 
read only, dark gray for objects in sections you have not locked, and white 
for objects in sections you have locked.

To... Click...

Save sections without unlocking. File > Save, click Save  or press 
CTRL+S.

Save changes and unlock all the 
sections you currently have locked.

File > Save and Unlock All Sections.
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• In the Classic scheme, the text is black for objects that are read only and blue 
for objects in sections you have locked. The background color is a pale blue 
for objects in sections, and doesn’t change when you lock the sections.

Requesting a section lock
If you try to lock a section that another user already has locked, the Request 
Lock dialog box is displayed. The options on the dialog box are described in the 
following table. Select the options you want, then click OK.

Note  Lock request messages are not delivered to DOORSnet 
users. However, if you select Alert me when lock is 
available, you will receive an alert when the DOORSnet user 
releases the lock.

In-place editing
There are two ways to edit the values of object attributes:

• Editing objects in-place (described in this topic)

• Using the object properties sheet (see “Editing using the object properties 
sheet,” on page 48)

If you want to change the values of an attribute for lots of objects or for all the 
objects in a module, it’s quicker to use the object properties sheet.
To edit in-place, double-click the attribute you want to edit, then change its value.
Alternatively, just start typing and DOORS appends your text to the end of the 
text in the current object’s main column.

Select... To...

Send a message Open a Lock Request Message dialog box when you 
click OK. 
You can type a message into the Lock Request Message 
dialog box, which will be displayed to the user who 
currently holds the lock. The user can optionally reply to 
your message.

Alert me when lock is 
available

Receive a message alert when the lock is released. You can 
lock the section directly from the message alert.
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In-place editing

To edit the value of an attribute, you must have modify access to both the object 
and the attribute value.

Selecting and editing
The following table describes the features you can use when you edit in-place:

To Do this

Select another 
object

Either:

• Single-click the other object to make it the current object.

• Double-click the other object to make it the current object 
and edit it in-place.

• Press SHIFT+RETURN to make the next object the 
current object and edit it in-place.

• Press the up or down arrow keys to make the previous or 
next object the current object and edit it in-place.

Select another 
attribute

Click or double-click the attribute. 
If you want to edit the next attribute, click Edit > In-Place > 
Edit Next Attribute, or press CTRL+A.

Accept the edits 
you made to the 
current object

Either:

• Click Accept changes  on the Commit toolbar.

• Press CTRL+M (the letter M is for Make the change).

• Click Edit > In-Place > Accept Changes.

• Click on another object or another attribute.

Discard the edits 
you made to the 
current object

Either:

• Click Discard changes  on the Commit toolbar.

• Press CTRL+D.

• Click Edit > In-Place > Discard Changes.

Change the value of 
the current 
attribute to the 
default value for 
that attribute

Click Edit > In-Place > Reset to Default.
If the attribute doesn’t have a default value, this changes its 
value to no value.
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If you don’t discard the edits you make to the current object, your changes are 
stored temporarily in your local computer’s memory. They are marked with a red 
change bar , to show that they haven’t yet been saved in the database.
To save them in the database, save the module (see “Saving your changes,” on 
page 55).

Formatting text

When you edit a Text or String attribute, you can select some text then apply 
formatting to it.

Edit the Object 
Heading for the 
current object

Either:

• Double-click the existing heading.

• Click Edit Object Heading  on the Object Edit 
toolbar.

• Press CTRL+H.

• Click Edit > In-Place > Edit Heading.

Edit the Object 
Text for the current 
object

Either:

• Double-click the existing text.

• Click Edit Object Text  on the Object Edit toolbar.

• Press CTRL+T.

• Click Edit > In-Place > Edit Text.

To make the currently 
selected text

Do this

Bold Either:

• Click Bold  on the Formatting toolbar.

• Press CTRL+B.

• Right-click Bold.

To Do this
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Text can contain standard bullets and can be indented. Place the cursor in the 
text you want to apply the paragraph format to and do the following:

Italic Either:

• Click Italic  on the Formatting toolbar.

• Press CTRL+I.

• Right-click Italic.

Underlined Either:

• Click Underline  on the Formatting toolbar.

• Press CTRL+U.

• Right-click Underline.

Strikethrough Either:

• Click Strikethrough  on the Formatting 
toolbar.

• Press CTRL+SHIFT+S.

• Right-click Strikethru.

Superscript Right-click Superscript.

Subscript Right-click Subscript.

To Do this

Apply bullet points Click Bullets  on the Formatting toolbar.

Increase indent Click Increase Indent  on the Formatting toolbar.

Decrease indent Click Decrease Indent  on the Formatting toolbar.

To make the currently 
selected text

Do this
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Cut, copy and paste

You can cut and copy the currently selected text to the system clipboard, and 
paste the contents of the system clipboard.

You can also copy text from other applications and paste it into DOORS 
attributes. For example, you may want to copy some text from a Word document 
and paste it into a DOOR object.

Note  If you copy an Omega symbol from a FrameMaker 
document and paste it into DOORS, it loses its font family, 
and is pasted as W.

Editing using the object properties sheet
There are two ways to edit the values of object attributes:

• Editing objects in-place (see “In-place editing,” on page 44)

• Using the object properties sheet (described in this topic)

To Do this

Copy Either:

• Click Copy objects or selected text  on the Clipboard toolbar.

• Press CTRL+C.

• Right-click Copy.

• Click Edit > Copy.

Cut Either:

• Click Cut objects or selected text  on the Clipboard toolbar.

• Press CTRL+X.

• Right-click Cut.
• Click Edit > Cut.

Paste Either:

• Click Paste objects or text  on the Clipboard toolbar.

• Press CTRL+V.

• Right-click Paste.

• Click Edit > Paste.
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Editing using the object properties sheet

The properties sheet for an object shows various information, including all its 
attributes and their values.
To edit the value of an attribute, you must have modify access to the module, the 
object and the attribute value.
To edit an object using its properties sheet:
1. In the module window, select the object you want to edit, then right-click 

Properties.

The properties sheet for the object is displayed.

The status of the object is displayed as part of the title of the properties 
sheet:

Possible values are:

• Saved
• Unsaved
• New
• Baselined
• Deleted

If you change the current object in the module window, the object properties 
sheet is updated to display the properties of the object you have selected.

2. Use the General tab to edit the attribute values.
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The following table lists the attribute values you can edit.

We recommend that each object is either a heading (its Object Text is blank) 
or normal text (its Object Heading is blank), but not both. This gives a 
cleaner and more manageable structure to your module. It also means that if 
you export from DOORS to other applications that don’t have the concept 
of multi-attribute objects, you get what you expect.

For example, word processors don’t let you combine heading and text in the 
same paragraph. If you don’t combine heading and text in your DOORS 

General tab Description

Heading The Object Heading attribute.
This is displayed in the module’s main column in Document 
mode. By default, heading text is displayed in the module in 
bold. This default is set in the display scheme (for information 
on changing it, see “Changing your display scheme,” on page 
398).
Do not make it bold in the object properties sheet unless you 
have changed the display scheme.
DOORS automatically generates and displays a heading 
number, which shows the object’s position in the hierarchy. If 
you move the object or add new objects, the heading number 
is automatically updated.
Note You cannot insert new lines in the Object Heading 

attribute. However, text with new lines can be copied 
into the attribute, and the new lines are preserved. 
When you view Object Heading text that has new 
lines in the object properties sheet, only the first line of 
the text is displayed. If you edit this text in the object 
properties sheet, the text that is not displayed is 
removed from the attribute.

Short Text The Object Short Text attribute.
This is the default value displayed in the object box in 
Graphics mode.

Object Text The Object Text attribute.
This is displayed in the module’s main column in Document 
mode.
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objects, each object is exported as a separate paragraph, which is what you’d 
expect. If you combine heading and text in one object, when you export to a 
word processor, the object is exported as two paragraphs, one that contains 
the heading and another that contains the text.

Note  The General tab of the object properties sheet also 
displays the URL of the object and a Copy URL button. 
Clicking Copy URL copies the object’s URL to the 
system clipboard. For more information about DOORS 
URLs see “Understanding DOORS URLs,” on page 
259.

3. To edit other attribute values, click the Attributes tab.

A list of all the attributes that apply to objects is displayed, along with the 
values they have for this particular object.

Read-only  is displayed to the left of attributes you can’t edit.

4. Select the attribute you want to view or edit, then click View/Edit.
5. The screen that is displayed depends on the type of attribute that you’re 

viewing.

At the top, the name, description and type of the attribute is displayed.

If you only have read access to the attribute, you cannot edit the value but 
you can select and copy it.

6. Select the Inherit check box if you want the object to inherit the value of 
this attribute:

• The object inherits the value from the nearest ancestor object that is not 
inheriting the value of this attribute.

• If all its ancestors are inheriting the value of this attribute, you get the 
default value of the attribute.

If the attribute doesn’t have a default value, you get no value.

7. If you clear the Inherit check box:

a. Enter the value you want the object to have. If you are editing a 
multivalued enumerated attribute and want to maintain the current 
settings for the affected objects, but select or clear certain values for all 
objects, go to Step 8.

b. Use the Apply to radio buttons to specify which objects you want the 
new value to apply to:
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• Click Current object to apply the new value to the current object 
only.

• Click Selected objects to apply the new value to all currently 
selected objects.

• Click Objects in current view to apply the new value to every 
object in the current view.

8. You can edit the multi-valued enumerated attribute value of multiple objects 
without affecting the individual attribute values of those objects.

For example, you have a multi-valued enumerated attribute, with the values 
A, B and C. There are three objects in your current view, which have the 
following values set for this attribute:

• Object 1: A,B
• Object 2: A,C
• Object 3: B,C

You want to remove value A from all the objects, while retaining the other 
values that are set. To do this:

a. Select B and C in the list of values, and clear A.

a. Select Objects in current view.

b. Select the Remove unchecked values check box, and make sure the 
Add checked values check box is cleared.

c. Click OK.

d. The objects now have values as follows:

• Object 1: B
• Object 2: C
• Object 3: B, C

A is removed from all the objects, but B and C are not added to the 
objects because the Add checked values check box was not selected.

In a similar way you can add values to selected objects, or objects in the 
current view by selecting the values you want to add, clearing the values you 
want to leave unchanged, and making sure that Add checked values is 
selected and Remove unchecked values is cleared.

The Add checked values and Remove unchecked values check boxes are 
unavailable if Current object is selected, or if the attribute you are editing is 
not a multi-valued enumerated attribute.

9. Click OK.
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10. Click Next or Previous to display the properties sheet for the next or 
previous object in the current view.

11. When you have finished, click OK.

12. Save the module to make the changes permanent (click File > Save).

Undoing edits
To undo an edit, click Edit > Undo.
You can’t use this feature while you’re editing in-place. To stop editing in-place, 
click another object or attribute (don’t double-click it or you remain editing 
in-place).

Note  If you can’t undo the last edit, the Undo option is 
unavailable.

Extended undo 
Any change made to a DOORS object that has been captured in the current 
history listing can be reversed (with the exception of Move operations and links). 
This gives you the power to undo all changes recorded in history, in any order.
To use the extended undo facility:
1. Click Edit > Object > Properties.

You can also select the object and right-click Properties or double-click the 
object’s change bar.

The object properties sheet is displayed.

2. Select the History tab.
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The Object History window is displayed.

3. Select the history record you want to restore. Select the View changes as 
redlining check box to see the changes as redlined text.

4. Click the Details button to display the information about the selected 
history item in a separate window.

Select the View change as redlining check box to turn redlining on, or 
clear the check box to view the history record without redlining.

5. Click the OK to return to the object properties sheet

6. Click Restore.

The object will now be restored to the previous state. Links are not affected 
when you restore a history record. All links are retained, including those that 
have been created between the date of the history record you are restoring 
and the present time.
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If the change you want to restore is not the most recent change, a warning 
message may be displayed:

Click Continue to restore the change.

You can control whether the message is displayed by selecting or clearing the 
Warn when restoring a change other than the most recent from history 
check box on the Settings tab of the Options dialog box (Tools > 
Options). For more information on the Options dialog box, see “Showing 
your user options,” on page 391.

Note  You cannot cancel a Restore operation because the 
restore takes effect immediately. You can undo by 
closing the dialog, rerunning the process, and selecting 
the most recent history record.

Saving your changes
When you edit data in a module, your changes are stored temporarily in your 
local computer’s memory. They aren’t saved in the database until you explicitly 
save them.
To save your changes when you're editing a module, either:
• Click Save  on the Commit toolbar.

• Click File > Save.

• Press CTRL+S.

When you close a module or exit DOORS, if you’ve made changes that you 
haven’t saved, a message is displayed asking if you want to save the changes. Click 
Yes to save your changes, or No to discard them.

Creating objects
To create an object, you need create access to its parent.
To create a top-level object:
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• You need create and modify access to the module

• You must be in exclusive edit mode

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

Note  Remember to save the module after you’ve created new 
objects.

Each object you create has a unique Absolute Number. Once an absolute 
number has been assigned to an object, that number is not used again in the 
module, even if the module is closed without saving the new object.

Controlling access to an object
To change the access rights for an object, you must have admin access to it.
To change the access rights for an object:
1. In the module window, select the object, then right-click Properties.

2. Click the Access tab.

To create an object Do this

At the same level as the 
current object

Either:

• Click Insert > Object.
• Press CTRL+N.

• If you’re editing the current object in-place, press 
CTRL+RETURN.

• Click New object at this level  on the Object 
toolbar.

One level below the 
current object

Either:

• Click Insert, then Object Below.

• Press CTRL+L (the letter L is for one Level below).

• Click New object below  on the Object toolbar.

If the current object already has children, the new object 
becomes the first child.
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The current access rights for the object are displayed.

If the module is partitioned in, the access rights associated with the partition 
are displayed. These describe the maximum access that any user has. They 
override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMCDA), but the module is 
partitioned in read only, in practice the user has only read (R) access to the 
object.

3. Make the changes you want.

You need this 
access right

To

Read (R) See the object.

Modify (M) Change the value of any attribute.
Create and delete links from this object to other objects.

Create (C) Create objects one level below the object.
Move another object to one level below the object.

Delete (D) Delete, undelete and purge the object.
Move the object.

Admin (A) Change the access rights for the object.

Access tab Description

Inherit from 
parent

Select this check box if you want the object to inherit its 
parent’s access rights. If it’s a top-level object, it inherits access 
rights from the module.
Note If you clear this check box you create an editable section 

for the current object. For best performance, try to use 
the DOORS inheritance mechanism whenever possible, 
and avoid creating editable sections unless you need 
them. For more information, see “Understanding 
editable sections,” on page 39.
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4. Click OK.

5. Save the module to make the changes permanent (click File > Save).

Promoting and demoting objects
You can manipulate the object hierarchy by promoting and demoting objects.

• When you promote an object it becomes the next sibling of the object that 
was its parent. 

• When you demote an object it becomes the last child of the object that was 
its preceding sibling.

Add To add a new entry to the list of access rights:
a. Click Add.

The Add Access window is displayed.
b. In the Name box, select the name of the user or group 

that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select the 
entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit.

The Edit Access window is displayed. 
b. Select the access rights you want to give them, then 

click OK.

Additional 
access

Select the additional access rights that you want to propagate 
with create access.
The additional rights are propagated to the child objects in the 
tree below this object that inherit their access rights from this 
object.
For more information, see the section topic on propagating 
extra access rights in Getting started with Telelogic DOORS, 
which is available on the Telelogic Lifecycle Solutions 
DVD.

Access tab Description
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Swapping Object Heading and Object Text attributes

An object can’t be demoted to be the child of a deleted object, so the object 
must have an undeleted preceding sibling.

Children of objects that are being promoted or demoted move with their parent 
to the new location in the hierarchy.
Promotion and demotion of objects is restricted as follows to ensure that object 
ordering (with no sort applied) is not changed:

• You can’t promote or demote deleted objects. However, if you select an 
undeleted object and it has deleted children, the object can be promoted or 
demoted and its deleted children are promoted or demoted along with it.

• You cannot promote or demote objects when a sort or filter is applied to the 
module.

To promote an object:
1. Select the object or objects you want to promote.

2. Click Edit > Object > Promote, or click Promote  on the Object 
toolbar.

The object is promoted, and becomes the next sibling of its former parent.

To demote an object:
1. Select the object or objects you want to demote.

The object must have an undeleted preceding sibling.

2. Click Edit > Object > Demote, or click Demote  on the Object 
toolbar.

The object is demoted and becomes the last child of the object that was its 
preceding sibling.

Swapping Object Heading and Object Text attributes
You can swap the Object Heading and Object Text attributes. When you swap 
the attributes the contents of the Heading attribute becomes Object Text and 
the contents of the Text attribute becomes Object Heading.
This operation can be used on objects that contain both Object Heading and 
Object Text, and on objects that contain one or other.

Caution  When you swap Object Text with Object Heading, the 
text may be truncated, as the Object Heading attribute 
cannot hold as many characters as the Object Text 
attribute.
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To swap attributes:
1. Select the object that contains the Object Heading and/or Object Text 

you want to swap. You must have read and modify access to the Object 
Heading and Object Text attributes in the module.

2. Click Edit > Object > Swap, or click Swap  on the Object Edit 
toolbar.

The contents of the Object Heading attribute becomes Object Text and 
the contents of the Object Text attribute becomes Object Heading. 

Splitting Object Heading from Object Text
When you split an object, a new object is created to replace the selected object, 
and the text in the Object Heading is moved into the new object. The selected 
object retains the Object Text, and becomes the first child of the new object. 
If the selected object has any children, they become siblings of the selected 
object, with the new object containing the Object Heading as their parent.

Note  If you have a module open in shareable edit mode, you can’t 
split the top object in a locked section. However, you can 
split child objects.

To split Object Heading from Object Text:
1. Select the object you want to split. You must have read and modify access to 

the Object Heading attribute and read access to the Object Text attribute.

2. Click Edit > Object > Split.
A new object is created to replace the selected object. The text in the Object 
Heading is moved into the new object.

Deleting, undeleting and purging objects
Deleting an object doesn’t destroy the object. It simply marks the object and all 
the objects in the tree below it as deleted, which stops users from being able to 
easily access them. To destroy the object, you must purge it once you’ve deleted 
it.
Purging deleted objects removes them permanently from the database.
If the object you want to delete has an in-link, this link must be deleted before 
the object can be deleted. If the object has descendants, any in-links to those 
objects must also be deleted before the parent object can be deleted. This 
prevents dangling links being left at the source object.
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To delete the link:

• The link module and the module containing the source object must be open. 

• You must have modify access to the source object and the link module.

When you delete an object that has an out-link, the link is not actually deleted 
until you purge the object and then save the module after purging the object.
To delete, undelete or purge an object, you must have delete access to the object 
and to all objects in the tree below it.

Note  You can’t delete or purge objects that have descendants if 
sorting is turned on. Leaf objects can be deleted when 
sorting is on.

To delete an object:
1. In the module window, select the object you want to delete, then click Edit 

> Object > Delete.

You can also right-click Delete or press DELETE.

2. Save the module to make the change permanent (click File > Save).

The object is deleted. Its object identifier is never reused by any future 
objects.

To undelete an object:
1. In the module window, make sure that deleted objects are being displayed.

If necessary, click View > Show > Deletions.

Deleted objects have red text, and their change bars are black .

2. Select the object you want to undelete, then click Edit > Object > 
Undelete. You can also right-click Undelete.

3. Save the module (click File > Save).

To purge an object:
1. In the module window, make sure that deleted objects are being displayed.

If necessary, click View > Show > Deletions.

2. Select the deleted object you want to purge, then click Edit > Object > 
Purge. You can also right-click Purge.

Deleted objects are colored red, and their change bars are black .

3. A message is displayed asking if you really want to purge the objects. Click 
Yes.
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4. Save the module to make the change permanent (click File > Save).

The object and all objects in the tree below it are permanently removed from 
the database.

To purge all deleted objects:
1. In the module window, click Edit > Purge All.

A confirmation message is displayed.

2. Click Yes to purge all the deleted objects in the module.

Deleted objects are purged even if they are not being displayed.

Understanding the spelling checker
The spelling checker allows you to check the spelling of Text and String 
attributes in any of the language dictionaries that are supported by DOORS. For 
information on supported languages, see “Configuring the spelling checker,” on 
page 403.
Each attribute has a locale language, which is displayed beside the attribute name 
in the spelling checker. You can check more than one attribute at a time, but 
attributes that are checked together must have either the same locale or have no 
locale set.
The language that will be used for the spelling check is displayed in the Selected 
Language list box. By default, the attribute is checked in its locale language, as 
displayed in the attribute list. If the selected attribute does not have an associated 
language, or if the language is not supported, the language that is used by default 
depends a setting on the Spelling tab of the Options dialog box. For 
information about this setting, see “Understanding default language selection in 
DOORS,” on page 407.
If you want to check the attribute in a different language, you can select the 
language you want to use from the Selected Languages list box.

Checking spelling
To check the spelling of the text in your module:
1. In the module window, click Tools > Spelling.
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The Check Spelling dialog box is displayed.

2. The attributes that can be checked are listed in the Check box. The list only 
contains Text and String attributes that are displayed in the current view. The 
locale of each attribute is displayed in the Language column.

By default, DOORS checks the spelling and grammar for the Object Text 
attribute. You can check additional attributes by selecting them from the list. 
You can only check attributes at the same time if they have the same locale 
or if they do not have a locale set. If you want to check the spelling in 
attributes that have different locales, you have to check them individually.

3. The language that will be used for the spelling check is displayed in the 
Selected Language list. If you want to check in a different language, select 
it from the list.

Note  If you want to correct an error, you must have an edit 
lock on the object or attribute and have modify access to 
it. 
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4. By default, all the objects in the current view are checked.

Select Current Object Only or Current Object And Children, if you want 
to limit the objects that are checked.

5. Click Start to start checking spelling and grammar.

When an error is detected: 

• The sentence that contains the error is displayed in the Sentence box, 
with the error highlighted.

• A description of the error is given in the Explanation box. 
• If there are any suggested corrections, these are listed in the 

Alternatives box.

Click To

Ignore Leave the highlighted error unchanged, and continue 
checking.

Ignore All/ 
Ignore Rule

Leave the highlighted error unchanged, and ignore any 
further occurrences of the highlighted word, or type of 
grammar error.

Ignore attribute Leave the highlighted error unchanged, and ignore the 
attribute for the remainder of the spelling check.

Skip Sentence Ignore any errors in the current sentence, and continue 
checking in the next sentence.

Add Add the selected word to the client dictionary or the 
database dictionary. You must have modify access to the 
database dictionary to add words to it.
If you select Client, the selected word is added to the 
client dictionary. This dictionary is not available to other 
DOORS clients.
If you select Database, the selected word is added to the 
database dictionary. This dictionary is available to all of 
the DOORS clients that access the database.
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If an error is found in an object or attribute to which you have read only 
access, you can choose to continue checking values to which you have read 
only access, or only check the values to which you have modify access. You 
cannot correct errors unless you have modify access to the object or 
attribute.

6. Save the module to make the changes permanent (click File > Save).

You can configure the spelling checker using the Options dialog box. For more 
information, see “Configuring the spelling checker,” on page 403.
For more information about locales, see Understanding locales and unicode 
options in the Managing Telelogic DOORS manual, which is available on the 
Telelogic Lifecycle Solutions DVD.

International Proofreader ™ English (US and UK) text proofing system © 2003 by Vantage Technology 
Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.  
For full copyright information, see “Text proofing system copyrights,” on page 443.

Inserting symbols
When you edit an object in-place, you can insert symbols, such as square root 
symbols, and Greek characters.
You can only insert symbols into attributes of type Text or String.
To insert a symbol:
1. In the module window, double-click the text you want to edit. 

Replace Replace the highlighted word with the word you have 
selected in the Alternatives box.
You can also edit the text in the Sentence box and apply 
rich text formatting to it, then click Replace to commit 
the change. 
The sentence is checked again if you edit text in the 
Sentence box.

Replace All Replace every occurrence of the highlighted word in the 
object with the word you have selected in the 
Alternatives box.

Stop Stop the spelling check.

Close Finish the spelling check.

Click To
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2. Position your cursor at the place where you want to insert the symbol.

3. Click Insert > Symbol.
4. In the Character set box, select the character set you want to use.

5. Click the symbol you want to insert.

The symbol is inserted at the position of your cursor.

6. Click Close.

7. Save the module to make the changes permanent (click File > Save).

Symbols are not displayed in the left pane of the Module Explorer. In the left 
pane, a text description of the symbol is displayed. For example, the text 
diamond is displayed instead of the diamond symbol.

Note  The symbol  is not displayed when it is inserted in text. 
This symbol inserts a soft hyphen in a word, which tells the 
text reader that the word can break across a line at this point.

Inserting URLs
The values of attributes of type Text or String can include live URLs. The URLs 
can have the following formats:
• http://

• https://

• ftp://

• file:// 

To insert a URL, simply type the URL. For example, type 
http://www.ibm.com/software/rational/support/.
The URL is automatically highlighted in blue.
The URL is live. If you double-click it, your browser opens the web page 
associated with URL.
A URL that is displayed in a traceability column is not live. To activate the URL, 
you must follow the link to the source or target object, and double-click on the 
URL there.
You can also insert URLs as external links. For more information about external 
links see “Understanding external links,” on page 214.

Note  Microsoft Project bookmarks are not supported in DOORS.

Note  Your user options specify which browser is used when you 
double-click a URL in DOORS. To change the browser, in 
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the DOORS Explorer, click Tools > Options, then use the 
Settings tab to specify the browser you want to use.

Inserting templates
DOORS provides a library of templates to help get you up and running quickly. 
For example, there are DoD-STD and MIL-STD templates. 
Templates help you keep your modules consistent by encouraging people to use 
a standard structure and headings. 
You can create your own templates and add them to the library, which is in the 
DOORS home directory, in doors\lib\dxl\standard\template. Template 
DXL must be Latin1 or UTF8 encoded. For more information, see the DXL 
Reference Manual, which is on the Telelogic Lifecycle Solutions DVD, and 
available from the Help menu.

Note  You can also use a template to create a new module (see 
“Creating a formal module,” on page 23).

To insert a template into your current module:
1. Select the object after which you want to insert the template.

2. Click Insert > Template.

3. Locate the template you want to insert, then either double-click it, or select it 
and click OK.

Using the object splitter
Use the object splitter to:

• Split an object into two or more objects; you split the contents of its Object 
Text attribute across multiple objects.

• Optionally, create links between the original object and the new objects.

To use the object splitter:
1. In the module window, make the object you want to split the current object.

2. Click Tools > Functions > Split Object Text.
3. In the Object Text box, select the text to specify where you want to make 

the split.
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For example, if the Object Text is ABCDEFGHIJK, the following table 
shows the different ways you can split the object.

4. Use the New position radio buttons to specify where you want to create the 
copies:

• Click After to create the copies at the same level as, and immediately 
after, the current object.

• Click One level down to create the copies one level below the current 
object.

5. If you want to create links between the original object and the copied 
objects:

a. Select the Create links check box.

b. In the Link direction drop-down list, select the direction of the links. 

6. Click Apply to split the object.

7. Click Next or Previous to move to the next or previous object in the 
current view.

8. When you have finished, click OK.

9. Save the module to make the changes permanent (click File > Save).

Using the object copier
Use the object copier if you want to:

• Copy objects between modules, and you want to copy attributes other than 
the Object Heading, Object Text and Object Short Text attributes.

If you only want to copy these three attributes, you’ll find it easier to use 
drag-and-drop (see “Using drag-and-drop,” on page 16).

If you select this text The original object 
contains

And the new objects 
contain

ABCD ABCD EFGHIJK

EFG ABCD EFG
HIJK

JK ABCDEFGHI JK
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• Copy every object in a module or every object in the current view to another 
module.

To use the object copier:
1. Open both the source and target modules.

2. In the target module, make the current object the one where you want to 
copy the data to. 

You can copy the data to either the same level or one level below this object.

3. In the source module, if you want to copy a particular object, select that 
object. 

If you want to copy either the entire module or all objects in the current 
view, it doesn’t matter which object you select.

4. In the source module, click Tools > Functions > Copy Objects. 

5. The Source module box shows you the name of the source module.

6. In the Target module box enter the name of the target module (specify the 
path from its nearest ancestor project), or use Browse to locate it.

7. Use the Copy drop-down list to select what you want to copy

• Select Current object only to copy only the current object
• Select Current object with children to copy the current object and all 

objects in the tree below it
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• Select Current display set to copy all objects in the current view
• Select All objects to copy all objects in the module.

8. Use the New position radio buttons to specify where you want to create the 
copies in the target module:

• Select After to create the copies at the same level as, and immediately 
after, the current object

• Select One level below to create the copies one level below the current 
object

• Select the attributes you want to copy

Use SHIFT+Click or CTRL+Click to select multiple attributes.

9. If you want to create links between the original objects and the copied 
objects:

• Select the Create links check box
• Use the Link direction drop-down list to select the direction of the 

links

10. Click OK.

11. Save the module that you copied the objects to (click File > Save).

Merging object text
You can create a new object whose Object Text consists of the Object Text of 
one or more objects in the same or another module.
To merge object text:
1. Open the module that contains the objects whose Object Text you want to 

merge.

2. Click Tools > Functions > Merge Objects.

3. A list of all the objects in the current module is displayed. Select the ones 
whose Object Text you want to merge.

4. Specify where you want to create the new object:

• In the Target module box, type the name of the target module, or use 
Browse to locate it. You must specify the path to the module from its 
nearest ancestor project.

• Open the target module and select the object you want to create the new 
object below or after.

• In the Merge Objects window, use the New position radio buttons to 
specify where you want to create the new object in the target module:
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Merging object text

• Click After to create the new object at the same level as, and 
immediately after, the current object.

• Click Below to create the new object one level below the current 
object.

5. If you want to create links between each of the source objects and the new 
object:

• Select the Create links check box.
• Use the drop-down list to select the direction of the links.

6. Click OK.
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5 Editing using forms
• Overview

• Creating a new form

• Editing forms

• Running forms

• Deleting forms

Overview
You can create forms for viewing and editing data in modules. You select the 
attributes you want to display in the form and optionally create a view of those 
attributes in the module. Forms can be saved and accessed from the module at 
any time.

Creating a new form
1. In the module window, click Tools > Forms > New Form.

The Form Generator dialog box is displayed. The following table describes 
the options that are available:

Option Description

Form name The name you want to give the form.

Object attributes The attributes in the module that are available to display in 
the form.

Form attributes The attributes that will be displayed in the form.

Add Adds the attributes selected in the Object attributes list 
to the Form attributes list.

Remove Removes the attributes selected in the Form attributes 
list.

Move Up Moves the selected attribute up the Forms attribute list. 
The attributes are displayed on the form in the order they 
appear in the Form attributes list.
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2. Select the attributes you want to display on the form from the Object 
Attributes list and click Add.

3. Select the check box in the  column of the Form attributes panel for 
any attributes that you want to display on the form, but that you don’t want 
to be editable. This does not change the access rights to the attribute, it just 
makes it read only on the form.

4. If you want to preview the form before you create it, click Preview.

5. If you want to create a module view that displays the attributes you have 
added to the form:

a. Click Create View.

The Save View dialog box is displayed.

Move Down Moves the selected attribute down the Forms attribute 
list.
The attributes are displayed on the form in the order they 
appear in the Form attributes list.

Use spacer to align 
elements

Use the slider to dictate the distance between the left hand 
edge of the form and the input boxes for the attributes 
you have selected. 
The form is not automatically formatted, so if you don’t 
use the slider to space the elements, the input boxes will 
overlap their labels.

Read-only form Makes the form read-only. This doesn’t change the access 
rights to the attributes that are displayed, it just prevents 
users from editing the attributes using the form.

Attributes in 
current view only

Changes the Object attributes list to only display the 
attributes that are displayed in the current view. 
If you want to display system attributes on the form, add 
them as columns to the module view, then select this 
check box on the form.

Create View Creates a view in the module that displays in columns the 
attributes you have added to the form.

Preview Pre the form.

Option Description
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b. Type a name for the view and click OK.

If a view with that name already exists, you will be prompted to 
overwrite the view.

6. Click OK to create the form.

Editing forms
You can edit forms that you have created previously.
To edit a form:
1. In the module window, click Tools > Forms > Edit Forms.

2. Select the form you want to edit from the list and click OK.

3. You can change the attributes that you want to display on the form, and the 
options that apply to the form, but not the name of the form.

4. Click OK when you are finished.

The form is updated. 

Running forms
When you have created a form, you can use it to view and edit the attributes that 
are included in the form. You can only edit attribute values if you have modify 
access to them and if they have not been set to display as read-only on the form.
To view and edit attributes using a form:
1. In the module window, click Tools > Forms > Run Forms.

2. Select the form you want to view and click OK.

The form opens. The attributes are those that were selected to be displayed 
on the form when it was created or last edited. The attribute values displayed 
are those of the currently selected object. Some or all attribute values may be 
read-only, depending on your access rights, and whether they were set to be 
read-only when the form was created or last edited.

3. Select Automatically copy changes to module if you do not want to be 
prompted to save your changes each time you move to a different object.

4. Use the form to edit different objects in the module by clicking the 
Previous, Next and Go To buttons. If you have not selected to 
automatically write changes to the module, you will be prompted to save any 
changes you have made.

5. Click OK to save changes and close the form.
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Deleting forms
To delete a form:
1. In the module window, click Tools > Forms > Delete Form.

A list of the available forms is displayed.

2. Select the form you want to delete and click OK.

The form is deleted.
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6 Using views
This chapter contains the following topics:

• Understanding views

• Saving your current view

• Understanding inheritance in views

• Setting default views

• Editing a view

• Controlling access to a view

• Deleting a view

Understanding views
When you create a formal module, the default view of the module is the 
Standard view. This displays the Module Explorer, the ID column, and the 
main column. 

You can edit the Standard view and save it with a different name, but you cannot 
save a view and name it Standard view.
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When you work with modules, your current view is what’s currently displayed 
on your screen. It’s a combination of the columns that you can see, the sort or 
filter you are currently using, and so on.
You can save your current view, so you can use it again later, for example in your 
next DOORS session. This saves you having to set up all the display options 
again.

The names of all the views that have been created for a module are shown in the 
Views drop-down list on the View toolbar. The full name of the view that is 
currently selected and its description are displayed when you roll over the list 
box.
To load a different view, select it from the drop-down list. Click away from the 
drop down list to cancel a selection.
To reload the current view, click View > Reload.

Note  A warning is displayed if you make changes to the display 
that will be lost when you select a different view or close the 
module. You can stop this message being displayed by 
changing your user options. For more information see 
“Showing your user options,” on page 391.
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Saving your current view

Saving your current view
To save your current view:
1. In the module window, click View > Save As.

2. In the Name box, type the name you want. If you want to overwrite an 
existing view, type the name of the view you want to overwrite. 

Note  View names are case sensitive, so if you want to 
overwrite an existing view, you must type the name 
exactly as it appears in the Views list.

3. If you want to enter additional information about the view, type it in the 
Description box.

4. Select the display settings you want to save with the view.

The saved settings are automatically applied whenever you load the view. If a 
check box is not selected, loading the view doesn’t change the associated 
display setting.

For example:

Setting Description

Current object Select this check box if you want the view to remember 
the settings for the current object.

Window size and 
position

Select this check box if you want the view to remember 
the current window size and position.

Filtering Select this check box if you want the view to remember 
the current filtering settings (whether filtering is turned on 
and what the current filter is).

Sorting Select this check box if you want the view to remember 
the current sorting settings (whether sorting is turned on 
and what the current sort is).

Inherit undefined 
settings from

Select a view from which “remember” settings are 
inherited if they are not defined in the current view.
For more information see“Understanding inheritance in 
views,” on page 81.
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• If the Filtering check box is not selected, loading the saved view does 
not change the current filtering settings.

• If the Filtering check box is selected, when you subsequently load the 
saved view, the filtering settings are changed to be the same as they are 
now. If filtering is off now, then filtering is off when you load the saved 
view. If filtering is on now, then filtering is on when you load the saved 
view. 

5. Use the Default check boxes if you want the saved view to be a default view 
for the module:

• Select For module if you want it to be the module default view. You 
must have modify access to the module to be able to select or clear this 
check box. This option is not available if Private is selected in the 
Access to this view pane.

• Select For current user if you want it to be your own user default view.

6. Use the Access to this view section to define the access rights for the view.

If you select Then

Private You will have full access to the view, and everyone else will 
have no access. 
You cannot make the view private if the For Module check 
box is selected in the Default pane of this dialog box.

Public You will have full access to the view, and everyone else will 
have read access. 

Custom You will have full access to the new view. The custom access 
rights for all other users and groups that are defined in the 
view that is currently displayed in the module are inherited by 
the new view. 
If you are overwriting an existing view, the access rights for the 
existing view are overwritten with the access rights of the view 
that is currently displayed in the module.
If the view that is displayed in the module when you save a 
new view is the Standard view, you cannot select Custom for 
the Access to this view. This is because the Standard view 
cannot have custom access rights, so there are no custom 
access rights for your new view to copy.
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Understanding inheritance in views

You can edit the access rights for a view using the Manage views dialog 
box. For example, you might have created a private view, but want to allow 
specific DOORS users access to it. See “Controlling access to a view,” on 
page 86 for details.

7. Use the Advanced tab if you don’t want to save other display options with 
the view. For more information, see “Editing a view,” on page 83.

8. Click OK.

Understanding inheritance in views
When you create a view you can make it inherit undefined settings from a 
different view in the module. Undefined settings mean any of the options that 
are not selected in the Remember settings for frames on the General and 
Advanced tabs when you save a view. This is useful if you want to save a new 
view of a module, but use a setting that has been saved with an existing view. 
For example if you already have a filter saved with View X and you want to use 
that filter again in View Y, you can select View X in the Inherit undefined 
settings from list when you create View Y. As long as you make sure that 
Filtering is not selected in the Remember settings for pane of View Y, it will 
inherit the filter from View X.
When you select View Y, View X is pre-loaded:

• Settings that are selected in View X are applied to the view.

• When View Y is loaded, any settings that are selected in View Y overwrite 
settings in View X.

• Any settings that are not selected in View Y are inherited from View X. If a 
setting is not selected in either View Y or View X, the module default is 
used.

So, you could create a sort in the current view and inherit a filter from an existing 
view. As long as the Sorting check box is selected and the Filtering check box is 
cleared in the Remember settings for pane of the current view, both the sort 
and the filter will be applied when you select the view.

Views inheritance and access controls

When you set a view to inherit settings from another view, all the users that have 
read access to the current view must also have read access to the view from 
which it inherits settings. When you save a new view, only the existing views that 
allow the same users read access as the new view are displayed in the Inherit 
undefined settings from list.
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A view that inherits access controls from the module cannot inherit settings 
from a view which does not, and to which any users may not have Read access.
If you change the access rights on an existing view that is inheriting settings, so 
that you give read access to users who do not have read access to the view from 
which it inherits settings, then the inheritance is invalid. You are prompted to 
either confirm the change in access and remove the inheritance, or cancel the 
change in access.
If you remove read access from a view that has its settings inherited by other 
views, so that users who have read access to inheriting views do not have read 
access to this view, then the inheritance is invalid. You are prompted to either 
confirm the change in access and remove the inheritance from views which are 
affected, or cancel the change in access.

Setting default views
A module has two different types of default view:

• User default view
Each user can set their own default view for the module. If you’ve defined a 
user default view for a module, that view is displayed when you open the 
module.

• Module default view
This is the view that a user sees when they open a module and they haven’t 
defined a user default view for the module.

Note  If you make the module default view read only, other 
users cannot change the settings within the view. 
However, a user with modify access to the module can 
overwrite the module default view with a different view.

To set the default views for a module:
1. In the module window, click View > Manage Views.

2. On the left of the screen, select the view that you want to be the default.

3. On the General tab on the right:

a. Select the For module check box to make the view the module default.

You must have modify access to the module to be able to select or clear 
this check box.

b. Select the For current user check box to make the view your personal 
user default.
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Editing a view

4. Click OK.

Editing a view
To edit a view:
1. In the module window, click View > Manage Views.

2. On the left of the screen, select the view you want to edit.

You must have modify access to the view.

3. Select the General tab.

4. In the Name box, edit the name if you want.

Note  View names are case sensitive.

5. In the Description box, edit the description if you want.

6. Edit the display settings:

Check box Description

Current object Clear this check box if you don’t want the view to 
remember the settings for the current object.
Note If this check box was cleared when the view was 

created, you cannot select it. If you want to select 
this check box, you will need to use View > Save 
As.

Window size and 
position

Clear this check box if you don’t want the view to 
remember the settings for the current window size and 
position.
Note If this check box was cleared when the view was 

created, you cannot select it. If you want to select 
this check box, you will need to use View > Save 
As.

Filtering Clear this check box if you don’t want the view to 
remember the current filtering settings (whether filtering 
is turned on and what the current filter is).
Note If this check box was cleared when the view was 

created, you cannot select it. If you want to select 
this check box, you will need to use View > Save 
As.
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The saved settings are automatically applied whenever you load the view. If a 
check box is not selected, loading the view doesn’t change the associated 
display setting.

For example:

• If the Filtering check box is not selected, loading the saved view does 
not change the current filtering settings.

• If the Filtering check box is selected, when you subsequently load the 
saved view, the filtering settings are changed to be the same as they are 
now. If filtering is off now, then filtering is off when you load the saved 
view. If filtering is on now, then filtering is on when you load the saved 
view. 

7. Edit the default settings:

• Select For module to make the view the module default.

You must have modify access to the module to be able to select or clear 
this check box.

You can only select this check box if the view is a Public view.

• Select For current user to make the view your personal user default.

8. To edit the access rights for the view, click the Access tab.

For more information, see “Controlling access to a view,” on page 86.

9. To edit the advanced properties of the view, click the Advanced tab.

Sorting Clear this check box if you don’t want the view to 
remember the current sorting settings (whether sorting is 
turned on and what the current sort is).
Note If this check box was cleared when the view was 

created, you cannot select it. If you want to select 
this check box, you will need to use View > Save 
As.

Inherit undefined 
settings from

Select a view from which “remember” settings are 
inherited if they are not defined in the current view. 
For more information see“Understanding inheritance in 
views,” on page 81.

Check box Description
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Select the display settings you want to save with the view. The saved settings 
are automatically applied whenever you load the view.

Select To

Outlining Save the outlining setting (shown on the View menu) with 
the view.

Compression Save compression settings with the view.

Graphics mode Save the display mode setting (shown on the View menu) 
with the view.

Graphics links Save the Show Graphics Links setting (shown on the 
View menu) with the view.

Module Explorer Save the Module Explorer setting (shown on the View 
menu) with the view.

Apply Filtering to 
Explorer

Save the Apply Filtering to Explorer setting (shown on 
the View menu) with the view.

Link arrows Save the Show Link Arrows setting (shown on the View 
menu) with the view.

Deleted objects Save the Show Deletions setting (shown on the View 
menu) with the view.

Table cells Save the Show Table Cells setting (shown on the View 
menu) with the view.

Filter table contents Save the advanced filter option for hiding non-matching 
table cells (see “Using an advanced filter,” on page 97) 
with the view.

Default table cell 
attribute

Save the Table Attribute setting (see “Controlling table 
attribute display,” on page 141) with the view.

Pictures Save the Show Pictures setting (shown on the View 
menu) with the view.

Display level Save the display level setting (shown on the View menu) 
with the view.

Columns Save information about columns with the view.
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10. Click OK.

Controlling access to a view
To change the access rights for a view, you must have admin access to it.
To change the access rights for a view:
1. Open the module that contains the view you want to change.

2. Click View > Manage Views.

3. Select the view, then click the Access tab.

The current access rights for the view are displayed.

Graphics column Save information about which column’s values are 
displayed in the object boxes in Graphics mode.

Graphics datatip Save information about which column’s values are 
displayed in the datatip in Graphics mode.

Indentation of 
main column

Save the auto-indentation setting for the main column.

Current selection Save information about currently selected objects with the 
view.

Filtered objects’ 
ancestors

Save the advanced filter option for showing ancestors 
(see “Using an advanced filter,” on page 97) with the view.

Filtered objects’ 
descendants

Save the advanced filter option for showing descendants 
(see “Using an advanced filter,” on page 97) with the view.

Set All Select all the check boxes on the tab.

Clear All Clear all the check boxes on the tab.

You need this access right To

Read (R) See the view.
Make it your user default view.

Modify (M) Change the view in any way.

Select To
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If the module is partitioned in, the access rights associated with the partition 
are displayed. These describe the maximum access that any user has. They 
override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMDA), but the view is 
partitioned in read only, in practice the user has only read (R) access.

4. Make the changes you want.

5. Click OK.

Delete (D) Delete the view.

Admin (A) Change the access rights for the view.

Access tab Description

Inherit from parent Select this check box if you want the view to inherit its 
access rights from the module.
When this check box is selected, the list of access rights is 
unavailable, and shows what access rights the view is 
inheriting.

Add To add a new entry to the list of access rights:
a. Click Add. 

The Add Access window is displayed.
b. In the Name box, select the name of the user or 

group that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select 
the entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit.

The Edit Access window is displayed.
b. Select the access rights you want to give them, then 

click OK.

You need this access right To
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If you change the access rights on a view that is inheriting settings, so that 
you give read access to users who do not have read access to the view from 
which it inherits settings, then the inheritance is invalid. You are prompted to 
either confirm the change in access and remove the inheritance, or cancel 
the change in access.

If you remove read access from a view that has its settings inherited by other 
views, so that users who have read access to inheriting views do not have 
read access to this view, then the inheritance is invalid. You are prompted to 
either confirm the change in access and remove the inheritance from views 
which are affected, or cancel the change in access.

Deleting a view
Note  You can’t undelete a view once you’ve deleted it.

To delete a view:
1. In the module window, click View > Manage Views. 

2. On the left of the screen, select the view you want to delete, then click 
Delete.

You must have delete access to both the module and the view.

3. A message is displayed asking if you really want to delete the view.

Click Yes.

4. Click OK.
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7 Finding, filtering and sorting
This chapter contains the following topics:

• Searching with the DOORS Explorer

• Finding text in a module

• Finding and replacing text

• Going to a particular object

• Understanding filters

• Using a simple filter

• Using an advanced filter

• Applying filtering to the Module Explorer

• Turning filtering on and off

• Understanding sorts

• Using a sort

• Turning sorting on and off

• Using regular expressions

Searching with the DOORS Explorer
In the DOORS Explorer, you can:

• Search for projects, folders and modules that have a particular name

• Search for formal modules that contain specific text in their Object 
Heading or Object Text attribute

To search with the DOORS Explorer:
1. In the DOORS Explorer, select the project, folder or module that you want 

to search.

2. Click Tools > Find.

3. If you want to search for projects, folders or modules with a particular name:

a. Type the name in the Named box.

The name can include asterisk (*) and question mark (?) wildcard 
characters.
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b. Select Search description to search the project, folder and module 
descriptions.

c. Select the Match case check box if you want a case-sensitive search.

4. The Look in box shows the project or folder to be searched.

By default, the search includes all the projects and folders under this project 
or folder. Clear the Include Subfolders check box if you only want to 
search the modules in this project or folder.

If you selected a module in Step 1, the Look in box contains the name of 
the folder or project that it’s in.

5. If you want to search for modules that contain specific text in their Object 
Heading or Object Text attribute:

a. Type the text you want to search for in the Containing text box.

b. Select the Use Wildcards check box if the text you typed in the 
Containing text box includes asterisk (*) or question mark (?) wildcard 
characters.

c. Select the Match case check box if you want a case-sensitive search.

6. Click Find Now to start the search.

A list of all the items that matched your search is displayed.

Double-click an item to open it.

Finding text in a module
This topic describes how to search a formal module for all the objects that 
contain specific text. For example, you can search for objects that contain the 
word accelerate.
To search a module for objects that contain specific text:
1. Open the module you want to search.

2. In the module window, click Edit > Find.
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Finding text in a module

The Find and Replace dialog box is displayed.

Any search options that have already been set are displayed. In this example, 
Highlight matches, Match case and User regular expression have 
already been set.

Note  You cannot search using standard Windows wildcards.

3. In the Find what box, type the text you want to search for.

4. If you to change the search options, select Advanced and select or clear the 
appropriate check boxes:

• Select Highlight matches if you want matches to be highlighted in the 
module window. When a match is found:
• If the match is in an attribute that is displayed in the current view, 

and that attribute can be edited in-place, the matching text is 
highlighted. The object and attribute in which the match is found is 
also highlighted with a colored outline.

• If the match is in an attribute that is displayed in the current view, 
but cannot be edited in-place, for example an enumerated attribute, 
the object and attribute in which the match occurs is highlighted 
with a colored outline, but the matching text is not highlighted.

• If the match is in an attribute that is not displayed in the current 
view, you are prompted to add the attribute to the current view. If 
you add the attribute, the rules described above apply. If you do not 
add the attribute, this match and any other matches found in the 
attribute are highlighted with a colored line above and below the 
object containing the match.

• Select Match case if you want to perform a case-sensitive search.
• Select Use regular expression if you want to use a regular expression 

in the Find what box.

For information on regular expressions, see “Using regular expressions,” 
on page 102.
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5. In the Find in box, select the attributes or Layout DXL you want to search. 
By default, all the attributes in the view are selected.

• Click All in View to select all the attributes displayed in your current 
view.

• Click Select All to select all the attributes in the list.
• Click Clear All to clear all the attributes in the list.

6. Click Find Next to find the next object that contains the specified text, or 
click Find Previous to search backwards.

7. When you have finished, click Close.

Finding and replacing text
You can search for and replace text within a formal module. For example, you 
can search for the word petrol and replace it with gas.
To find and replace text within a formal module:
1. In the module window, click Edit > Replace.

The Find and Replace dialog box is displayed.

Any search options that have already been set are displayed. In this example, 
Match case and User regular expression have already been set.

2. In the Find what box, type the text you want to search for, and in the 
Replace with box, type the text you want to replace it with.

3. If you to change the search options, select Advanced and select or clear the 
appropriate check boxes:

• Select Match case if you want to perform a case-sensitive search.
• Select Use regular expression if you want to use a regular expression 

in the Find what box.



Using Telelogic DOORS           93

Going to a particular object

For information on regular expressions, see “Using regular expressions,” 
on page 102.

4. In the Replace in box, select the attributes you want to search. By default, 
only Object Heading and Object Text are selected.

• Click All in View to select all the attributes displayed in your current 
view.

• Click All to select all the attributes in the list.

Note  You can only use the Replace function if you have 
modify access to the attributes being searched.

5. Click Find Next to find the next object that contains the specified text, or 
click Find Previous to search backwards. 

• Click Replace to replace every occurrence of the specified text in the 
current object

• Click Replace All to replace every occurrence of the specified text 
throughout the module

6. When you have finished, click Close.

Going to a particular object
When you have a module open, you can go directly to a particular object in the 
module if you know its absolute number or its section number.

Note  You can only go to an object in the current view.

To go directly to a particular object:
1. In the module window, either:

• Click Edit > Go To.
• Press CTRL+G.

2. Type in the section number or absolute number of the object you want to go 
to, or select a number that you previously entered from the list. 

• If you enter a number containing a decimal point, for example 5.2 or 6., 
DOORS goes to the object with that section number.

• If you enter a whole number, for example 5, DOORS goes to the object 
with that absolute number. 

• If you enter a valid module prefix followed by valid object number, 
DOORS goes to the object with that Object Identifier.

3. Click Go To.
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If the object with the specified absolute number or section number is in your 
current view, it becomes the current object.

The last seven numbers that you have typed are stored in the list until you 
close the module. They can be accessed by clicking the down arrow.

4. Click Close.

Understanding filters
Filters let you control what data is displayed in a module. You can use them to 
filter out data you don’t want to see.
For example, you can filter out all objects except those that contain the word 
steering. Or you can filter out all objects except those that have links.
There are two types of filter, simple and advanced.

Simple filters
With a simple filter, you can either:

• Filter on the contents of every attribute of type Text or String.

• Filter on the Object Heading number.

• Filter on the contents of any column, whether it is a traceability column or 
any other custom column created by DXL.

• Filter on the value of a single attribute of any type.

• Filter on the basis of whether the object has links.

• Filter on the basis of whether the object is either the current object or a leaf 
object. 

An object is a leaf object if it doesn’t have any children.

Advanced filters

With an advanced filter, you can:

• Combine together simple filters to create a complex filter.

For example, you can display objects that contain the word steering and that 
also have links.

• Specify filter options that control what is displayed.

For example, you can control whether only the objects that match your filter 
are displayed, or whether their ancestors or descendants are displayed too.
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By default, the filter only affects what is displayed in the module window. If you 
want the filter to affect the Module Explorer, you can use either the Apply 
Filtering to Explorer menu option on the View menu or the Apply Filtering 
to Explorer button  on the Display toolbar to set the Module Explorer to 
display only the results of the filter. Objects that are excluded from the filter are 
grayed out in the Module Explorer.

Using a simple filter
For information on filters, see “Understanding filters,” on page 94. 
For information on using advanced filters, see “Using an advanced filter,” on 
page 97.
To use a simple filter:
1. In the module window, click Tools > Filter > Define, or click Filter 

properties  on the Display toolbar.

2. Use the Attributes tab if you want to filter on an attribute.

Note  If you are filtering on a date, you can use the legacy date 
format, which is dd month yyyy with the month name 
in english, or dd month yy. You can also use 
mm/dd/yy. If you want to add a specific time, use the 
following format, hh:mm:ss.

Specify the attribute you want to use for your filter. For example, if you want 
to only display objects that contains the word steering:

a. Select Any string or text attribute in the Attribute box.

b. Select contains in the Condition box.

c. Type steering in the Value box.

3. If the value in the Condition box is contains:

a. Select the Match case check box if you want to set up a case-sensitive 
filter.

b. Select the Regular Expression check box if you want to use a regular 
expression. For information on regular expressions, see “Using regular 
expressions,” on page 102. 

4. If you want to filter objects on the basis of what links they have, click the 
Links tab, then define your link criteria.

For example, if you only want to display objects that have in-links, select 
have and in-links in the top two boxes. To show:
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• All the objects in the module that have inlinks select going through 
any link module. 

• Only in-links contained in a specific link module, select going through 
link module, then browse to the link module.

5. If you want to filter objects on the basis of whether they are either the 
current object or leaf objects, click the Objects tab, then click the 
appropriate radio button.

An object is a leaf if it doesn’t have any children.

6. Alternatively, if you want to filter the contents of columns, click the 
Columns tab. 

a. Select the column you want to filter in the Column box.

b. Type what you want to filter for in the Contains box.

c. Select the Match case check box if you want to set up a case-sensitive 
filter.

d. Select the Regular Expression check box if you want to use a regular 
expression. For information on regular expressions, see “Using regular 
expressions,” on page 102.

7. Click Apply or OK.

The module background color changes to show that a filter is being applied to 
the data. The color depends on the display scheme you are using. For example, in 
the Modern display scheme the background changes to gray, and in the Classic 
display scheme it changes to green.
If a simple filter is currently applied to the module, the filter settings are 
displayed in the filter dialog when it is opened.
By default, the filter only affects what is displayed in the module window. If you 
want the filter to affect the Module Explorer, you can use either the Apply 
Filtering to Explorer menu option on the View menu or the Apply Filtering 
to Explorer button  on the Display toolbar to set the Module Explorer to 
display only the results of the filter. Objects that are excluded from the filter are 
grayed out in the Module Explorer.

Statistics

If you click Apply after defining your filter, the statistics box will display the 
following information:

Total Objects The total number of objects in the current module.
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Using an advanced filter
For information on filters, see “Understanding filters,” on page 94. 
For information on using simple filters, see “Using a simple filter,” on page 95.
To use an advanced filter:
1. In the module window, either:

• Click Tools > Filter > Define.
• Click Filter properties  on the Display toolbar.

2. Click Advanced.

3. There are four tabs at the top of the screen: Attributes, Links, Objects, and 
Columns.

4. Use these tabs to define simple filtering criteria, then click Add to add it to 
the list of rules. For information on these tabs, see “Using a simple filter,” on 
page 95.

5. Use the And, Or and Not buttons to define complex filtering criteria.

The following table describes the buttons on the Advanced Filter window.

Accepted The number of objects that fulfill the filter criteria.

Rejected The number of objects that do not fulfill the filter criteria.

Use If you want to

And Include all the objects that match two or more filtering 
criteria.
For example, you want to include all objects that have a 
priority greater than 3 and that contain the word steering.
Select the rules you want to and together, then click And.

Or Include all the objects that match one or more filtering 
criteria.
For example, you want to include all objects that either have a 
priority greater than 3 or contain the word steering, or both.
Select the rules you want to or together, then click Or.
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And, Or, and Not add a new rule to the list.

To delete one or more filter rules from the list, select the rule then click 
Delete. If you delete a filter rule that has been applied to the module, the 
rule is displayed again the next time you open the Advanced Filter dialog 
box.

6. Select the rule you want to apply to your current view.

If you have created a complex and lengthy rule, it may be difficult to view 
the complete definition in the Filter Definition window. If you want to 
view the complete definition, select it in the filter definition pane and click 
the Description button. A dialog box containing the complete filter 
definition is displayed.

Use the following filter options to control what’s displayed on your screen.

Not Include all the objects that don’t match a particular filtering 
criterion.
For example, you want to include all objects that don’t contain 
the word steering.
Select the rule, then click Not.

Select To

Show ancestors Display all the ancestors of the objects that match the 
filter, as well as the objects themselves.
For each object that matches the filter, DOORS displays 
its parent, grandparent, and so on. This lets you see where 
the objects that match the filter fit in the object hierarchy.

Show descendents Display all the descendents of the objects that match the 
filter criteria, as well as the objects themselves.
For each object that matches the criteria, DOORS 
displays the tree of objects below it.

Display all table 
cells

To display all table cells and their contents regardless of 
whether they match the filter definition. 
If you wish to retain the structure of tables in the module 
when filtering, ensure this check box is selected. 

Use If you want to
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7. When you have finished, click Apply or OK
The module background color changes to show that a filter is being applied 
to the data. The color depends on the display scheme you are using. For 
example, in the Modern display scheme the background changes to gray, and 
in the Classic display scheme it changes to green.

Statistics
If you click Apply after defining your filter, the statistics box will display the 
following information:

Applying filtering to the Module Explorer
When you set a filter you can determine whether the Module Explorer displays 
all the objects in the module, or only those objects that are displayed by the filter.
Objects that are excluded from the filter are grayed out.
To apply filtering to the Module Explorer, either:
• Click View > Apply Filtering to Explorer.
• Click Apply Filtering to Explorer  on the Display toolbar.

Turning the Module Explorer filter off and on again shows the results of the last 
filter. It doesn’t reapply the filter.
For example, you filter a module to show only the objects that have a high 
priority and apply the filter to the Module Explorer. Object 13 has a high priority, 
so it’s displayed on your screen. You turn filtering off, then edit object 13 and 
change its priority to medium. When you turn the filter back on, you still see 
object 13 because it matched the filter when you first applied the filter. To filter 
the data using the current values, you must reapply the filter.
To reapply your filter, click Tools > Filter > Reapply or click Reapply filter 

 on the Display toolbar.

Turning filtering on and off
To turn filtering on and off, either:

Total Objects The total number of objects in the current module

Accepted The number of objects that fulfill the filter criteria

Rejected The number of objects that do not fulfill the filter criteria
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• Click View > Show > Filter.
• Click Turn filtering on or off  on the Display toolbar.

Turning the filter off and on again shows the results of the last filter. It doesn’t 
reapply the filter.
For example, you filter a module to show only the objects that have a high 
priority. Object 13 has a high priority, so it’s displayed on your screen. You turn 
filtering off, then edit object 13 and change its priority to medium. When you 
turn the filter back on, you still see object 13 because it matched the filter when 
you first applied the filter. To filter the data using the current values, you must 
reapply the filter.
To reapply your filter, click Tools > Filter > Reapply or click Reapply filter 

 on the Display toolbar.

Understanding sorts
Sorting lets you control the order in which objects are displayed on your screen.
By default, objects are displayed in an order that shows their structure in the tree, 
like sections in a book. First there’s section 1, then section 2, and so on. Section 
1 is subdivided first into section 1.1, then section 1.2, and so on.
Use a sort if you want to use the value of one or more attributes to sort your 
data. For example, sort on the Priority attribute to display objects in order of 
either ascending or descending priority, or sort first on the Priority attribute, and 
then on the Risk attribute. When two objects have the same priority, they are 
sorted in risk order.

Note  Tables are ignored when you sort. >> Table is displayed 
instead of a table whenever sorting is turned on. Sorting only 
affects what is displayed in the module window. The Module 
Explorer always shows the data in the standard order.

Using a sort
For information on sorting, see “Understanding sorts,” on page 100.
To use a sort:
1. In the module window, click Tools > Sort, or right-click a column title bar 

and click Sort > Advanced Sort.
2. Define each sort you want to use:

a. In the Sort on box, select the attribute you want to sort on.
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b. In the Order box, select the order you want to sort in, Ascending or 
Descending.

c. Click Add to add it to the Sort List.

3. The sorts are applied in the order in which they’re listed in the Sort List.
To change the order of the items in the list, select an item then click Up or 
Down.

4. To remove an item from the list, select it then click Remove.

5. Click Apply if you want to keep the Sort dialog box open when the sort is 
applied, or OK to apply the sort and close the Sort dialog box.

If you change the current sort and click Apply, you can revert to the original 
sort by clicking the Revert button.

The objects are sorted. An arrow is displayed in the column title bar, showing 
whether the sort is ascending (up arrow) or descending (down arrow). The 
number to the right of the arrow shows the sort order.

Note  Sorting only affects what is displayed in the module window. 
The Module Explorer always shows the data in the standard 
order.

To sort on an attribute that is displayed in a column in your current view:
Right-click on the column heading and click Sort > Ascending or Sort > 
Descending. The module is sorted according to the contents of the column, 
and an arrow and the number 1 (one) is displayed in the column title bar to show 
that a sort has been applied. Any other sort that was applied to the module is 
removed.
If you open the Sort dialog box, the sort is displayed in the Sort List box.

Note  Sorting only affects what is displayed in the module window. 
The Module Explorer always shows the data in the standard 
order.

Turning sorting on and off
To turn sorting on and off, either:
• Click View > Show > Sort.
• Click Turn sorting on or off  on the on the Display toolbar.

Turning the sort off and on again shows the results of the last sort. It doesn’t 
reapply the sort.



Finding, filtering and sorting

102    Using Telelogic DOORS

For example, you apply a sort, then you turn sorting off and edit the values of the 
attribute you sorted on. If you turn sorting on again, the objects are displayed in 
exactly the same order as when you applied the sort, based on the values of the 
attribute at that time. To sort the data on the current values of the attribute, you 
must reapply the sort.
To reapply your sort:
1. In the module window, click Tools > Sort.

Your current sort is displayed in the Current sort box.

2. Click Apply or OK to reapply the sort.

Using regular expressions
You can use UNIX®-style regular expressions when you are searching for text in 
module windows. For example:

• Use c.t to search for all three letter words that start with c and end in t.
• Use 200[1|2|3] if you want to search for either 2001, 2002 or 2003.

Note  In the DOORS Explorer, the Find tool uses both standard 
Windows wildcards and regular expressions. In module 
windows, the Find tool uses regular expressions, not 
wildcards.

The following table shows the characters you can use to build regular 
expressions:

Meaning Example Matches

* zero or more 
occurrences

a* zero or more a characters (every 
string matches this expression)

+ one or more 
occurrences

a+ one or more a characters

. any single character 
except newline

* any number of any characters except 
for newline characters (in other 
words, any string)

\ escape (turns off the 
special meaning 
associated with a 
character)

\. a period (.) character
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^ beginning of line (if it’s 
at the start of the 
expression)

^The.* any line that starts with the string 
The

$ end of line (if it’s at the 
end of the expression)

Monday\.$ any line that ends with the string 
Monday followed by a period (.)

( ) groupings (ref)+(bind

)*

at least one ref string then zero or 
more bind strings

[ ] character range (letters 
or digits)

[sS]hall.*\

.$

any line that contains either shall or 
Shall and that ends with a period (.)

[^abc] any character except a, b, or c

[a-zA-Z] any alphabetic character (upper or 
lower case)

[0-9] any numeric character (number 
between 0 and 9)

| alternative (dat|doc) either the string dat or the string 
doc

Meaning Example Matches
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8 Using attributes
This chapter contains the following topics:

• Understanding system attributes

• Understanding attribute types

• Showing attribute types

• Creating an attribute type

• Controlling access to an attribute type

• Editing an attribute type

• Deleting an attribute type

• Showing attribute definitions

• Creating an attribute definition

• Controlling access to an attribute definition

• Controlling access to an attribute value

• Editing an attribute definition

• Sharing attribute and type definitions

• Deleting an attribute definition

• Understanding DXL attributes and layout DXL columns

• Copying attribute values

• Measuring the frequency of attribute values

Understanding system attributes
System attributes are attributes that are automatically created by DOORS.
For example, when you create a new module, DOORS automatically creates a 
system attribute, called Created On, that contains the date when the module was 
created.

Note  DOORS allows you to edit a new drop-down checklist by 
checking and clearing the values you want to store for the 
attribute.
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The following table lists the system attributes for modules. You can’t edit the 
ones that are read only:

System attributes for 
modules

Description Read only

Created By The username of the person who created 
the module.

Yes

Created On The date when the module was created. Yes

Description Additional information about the 
module.

No

Last Modified By The username of the person who last 
modified the module.

Yes

Last Modified On The date when the module was last 
modified.
This attribute value can be used together 
with the module history to provide 
information about changes to the 
module.

Yes

Mapping The type of link mapping, for example 
one-to-one or many-to-many (link 
modules only).

Yes

Name The name of the module. No

Prefix The prefix part of the module’s object 
identifiers. 
An object identifier consists of an 
optional prefix, followed by an absolute 
number that is automatically generated 
by DOORS.

No
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The following table lists the system attributes for objects. You can’t edit the ones 
that are read only:

System attributes for 
objects

Description Read only

Absolute Number The unique number that was 
automatically generated by DOORS 
when you created the object.

Yes

Created By The username of the person who created 
the object.

Yes

Created On The date when the object was created. Yes

Created Thru Whether the object was created by 
copying, extraction, or manual input 
(formal modules only).

Yes

Last Modified By The username of the person who last 
modified the object.

Yes

Last Modified On The date when the object was last 
modified.

Yes

Object Heading The object heading (formal modules 
only).

No

Object Short Text The text that is used by default in 
Graphics mode in object boxes (formal 
modules only).

No

Object Text The object text (formal and link modules 
only).

No
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Understanding attribute types
Each attribute has a type, which controls the type and range of values that you 
can store in it. For example, you can only store integer values in attributes of type 
Integer, and dates in attributes of type Date.

OLE
OLEIconic
Picture
PictureName
PictureNum

Advanced system attributes that show 
status information (formal modules 
only). For example, Picture is a boolean 
attribute that has the value True if the 
object contains a picture.
These attributes are normally hidden. 
To display them:
a. Click Tools > Options. 
b. Click the Settings tab.

c. Select the Show advanced 
system attributes check box.

d. Click OK.

Yes

TableBottomBorder
TableCellAlign
TableCellWidth
TableChangeBars
TableLeftBorder
TableLinkIndicators
TableRightBorder
TableShowAttrs
TableShowBookform
TableShowWide
TableTopBorder
TableType

Advanced system attributes that show 
status information (formal modules 
only).
To display them:
a. Click Tools > Options. 
b. Click the Settings tab.

c. Select the Show advanced 
system attributes check box.

d. Click OK.

No

System attributes for 
objects

Description Read only
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DOORS provides the base types shown in the following table:

This base type Can store this type of value

Text Text.
A Text attribute type can include paragraphs (newline 
characters), and there is no restriction on the number of 
characters that can be entered.

String Text.
A String attribute type cannot include paragraphs (newline 
characters), and there is an upper limit of 968 on the number 
of characters that can be entered.
The upper limit of 968 includes hidden characters and not just 
visible characters. For example, rich text contains hidden 
characters and these are included as part of the 968 characters; 
unicode and upper ASCII characters take up more internal 
storage space then plain ASCII characters. If you try to enter a 
value that contains more than 968 characters, an error will be 
reported, and the value will be truncated. If you need to enter 
a large number of characters, use a Text attribute as there is no 
restriction on the number of characters that can be stored in a 
Text attribute.

Integer An integer (a whole number, such as 4 or 57). It can be 
positive or negative.

Real A decimal value (for example, 5.619). It can be positive or 
negative.

Date A date, for example, 15 May 2005.
For more information, see the section on understanding how 
dates and times are recorded in Managing Telelogic DOORS, 
which is part of the DOORS documentation set.

Enumeration One of a predefined list of values. 
For example, you can define an attribute called Priority 
whose:

• Base type is Enumeration.

• Values are High, Medium, and Low.
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You can construct your own types from these base types.
For example, you create a type called Percentage that has a base type of Integer 
and that can have values in the range 0 to 100. You then create various attributes 
of type Percentage. You know that users can only assign integer values between 
0 and 100 to those attributes. DOORS automatically rejects any other values as 
invalid.
You can also use types as a way of letting users know what units of measurement 
an attribute’s values should use. For example, you create a type called Kg that has 
a base type of Integer, and then create an attribute called Weight of type Kg. If 
an experienced DOORS user is looking at your Weight values, and isn’t sure 
what units the weight is measured in, they can check the attribute type and see 
that the units are Kg.
The following table shows examples of attribute types you might want to create:

Showing attribute types
To show attribute types:
1. In the module window, click Edit > Types.

2. A list of all the attribute types for the module is displayed.

Username A DOORS username.

Example type Description

Kg A type of base type Integer, used for storing weights.

Dollar A type of base type Integer, used for storing costs.

Percentage A type of base type Integer, with a minimum value of 0 and a 
maximum value of 100.

Deviation A type of base type Real, with a minimum value of 0.5 and a 
maximum value of 1.5.

Priority A type of base type Enumeration, with the values Mandatory, 
Desirable and Luxury.

Project Span A type of base type Date, with a minimum value of 1 January 
2005 and maximum value of 31 December 2005.

This base type Can store this type of value
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Creating an attribute type
To create an attribute type, you must have create and modify access to the 
module.
To create an attribute type:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click Edit > Types.

3. Either click New to create a new type from scratch, or select the type you 
want to copy, then click Copy.

4. Type the name of the new attribute type in the Type name box.

5. Select the base type in the Base type box.

6. If the base type allows a range of values to be defined, you can type 
minimum and maximum values in the Minimum value and Maximum 
value boxes.

7. If the base type is Enumeration, click the Enumerations tab, then define 
the values that attributes of this type can have.

Enumerations tab Description

Value Enter a value for the attribute in the Value box, then click 
Add.

Related number If you want, you can enter a number that you want to 
assign to the value. This number is used when you sort or 
filter using an operator that uses a numeric value. For 
example, you can filter on values greater than 5.

Default Click this radio button if you want to use the default color 
for the attribute value.

Specified Click this radio button if you don’t want to use the default 
color for the value, then select the color you want from 
the drop-down list.
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8. By default, the new attribute type inherits its access rights from the module.

If you want to change its access rights use the Access tab. For more 
information see “Controlling access to an attribute type,” on page 112.

9. Click OK.

10. Click Close.

Controlling access to an attribute type
Use access rights to control who can edit an attribute type. 
For example, the delivery dates for a project must fall within fixed dates. The 
Project Manager creates an attribute type called Delivery, that can have a range 
of date values. She gives other users read-only access to the attribute type, so that 
they can’t change the date ranges.
To change the access rights for an attribute type, you must have admin access to 
it.
To change the access rights for an attribute type:
1. Open the module that contains the attribute type you want to change.

2. Click Edit > Types.

3. Select the attribute type, then click Edit.
4. Click the Access tab.

Add Adds the value in the Value box (and optionally also the 
number in the Related number box) to the list of 
attribute values in the right box.

Replace Replaces the selected entry in the list of attribute values in 
the right box, with the contents of the Value and Related 
number boxes on the left.

Delete Deletes the selected entry from the list of attribute values 
in the right box.

 Changes the order of the entries in the list of attribute 
values in the right box.

Enumerations tab Description
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The current access rights for the attribute type are displayed.

If the module is partitioned in, the access rights associated with the partition 
are displayed. These describe the maximum access that any user has. They 
override the RMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMDA), but the module is 
partitioned in read only, in practice the user has only read (R) access to the 
attribute type.

5. Make the changes you want.

You need this 
access right

To

Read (R) See the attribute type.

Modify (M) Change the attribute type in any way.

Delete (D) Delete the attribute type.

Admin (A) Change the access rights for the attribute type.

Access tab Description

Inherit from parent Select this check box if you want the attribute type to 
inherit its access rights from the module.
When this check box is selected, the list of access rights is 
unavailable, and shows what access rights the attribute 
type is inheriting.

Add To add a new entry to the list of access rights:
a. Click Add. 

The Add Access window is displayed.
b. In the Name box, select the name of the user or 

group that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select 
the entry, and then click Remove.
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6. Click OK.

7. Click Close.

Save the module to make the changes permanent (click File > Save).

Editing an attribute type
To edit an attribute type, you must have modify access to both the attribute type 
and the module.
To edit an attribute type:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click Edit > Types.

3. Select the type you want to edit, then click Edit. Base types are read only.

4. Make the changes you want. For information on the boxes and tabs on the 
screen, see “Creating an attribute type,” on page 111.

5. Click OK.

If you made the range of values more restrictive for an attribute type, any 
values in the module that are now out of range are unchanged until the 
object containing them is edited. At that point the user is forced to change 
the value so it falls within the new range 

6. If you edited the values of an enumerated attribute type:

• If you replaced a value, DOORS automatically updates the value of any 
attribute that had that enumerated value.

• If you delete a value:

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit. 

The Edit Access window is displayed.
b. Select the access rights you want to give them, then 

click OK.

Access tab Description
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• DOORS automatically updates the value of any attribute that had 
that value. The value is set to the attribute’s default value.

• If the attribute doesn’t have a default value, the value is deleted and 
left empty.

Note  If you delete an enumeration value that is still set as 
the attribute value of an object then the attribute 
value of the object will be lost.

7. Click Close.

Deleting an attribute type
You cannot delete an attribute type that is being used in an attribute definition.
To delete an attribute type, you must have delete access to the attribute type and 
modify access to the module.
To delete an attribute type:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click Edit > Types.

3. Select the type you want to delete, then click Delete.

A message is displayed asking if you really want to delete the attribute type.

4. Click Yes.

5. Click Close.

Showing attribute definitions
To show attribute definitions:
1. In the module window, click Edit > Attributes.

2. A list of attribute definitions is displayed:

• The Name column shows the name of the attribute definition.
• The Type column shows the attribute type.
• The Default value column shows its default value. 
• The Inherits value column shows whether it inherits its value.
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• The Exists for column shows whether it’s an object attribute a module 
attribute, or both.

• If it’s an enumerated attribute, the Multi-valued column tells you 
whether it can have multiple values. 

Creating an attribute definition
To create an attribute definition, you must have create and modify access to the 
module.
To create an attribute definition:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click Edit > Attributes.

On the Attributes tab, a list of attributes is displayed.

3. If you want the new attribute to have a type that doesn’t already exist, click 
the Types tab and create the type (see “Creating an attribute type,” on page 
111). 

4. On the Attributes tab, either click New to create an attribute from scratch, 
or select the attribute you want to copy, then click Copy.

5. Type the name of the new attribute in the Name box, and type a description 
in the Description box.

6. Select the other options on the General tab.

General tab Description

Name The name you want to give the new attribute.
The name must be unique within the module.

Description Additional information about the new attribute.

Type The type of the new attribute.
The options in the dialog box change depending on what 
type you select.
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Locale This option is displayed when either Text or String attribute 
types are selected.
Select a locale for the attribute. By default this is the current 
locale on the client machine. For more information, see the 
section on understanding locales in Managing Telelogic 
DOORS, which is part of the DOORS documentation set.

DXL attribute Select this check box if you want to use a DXL program to 
assign values to the attribute. Click Browse to select the DXL 
program you want to use, or Wizard to create a DXL 
attribute using the DXL Attribute Wizard. For information 
on the DXL Attribute Wizard, see “Creating a new DXL 
attribute,” on page 119

Browse If you selected the DXL attribute check box:
a. Click Browse to select the DXL program.

A list of all predefined DXL programs that can be used to 
set attribute values is displayed.

b. Select the program you want to use, then click Apply. 
Alternatively, if you want to define a new program, 
click New.

Multi-valued Select this check box if the attribute type has a base type of 
Enumeration, and you want to be able to store more than one 
value in the attribute.

Default value If you want the new attribute to have a default value, select 
the Default value check box, then type the value in the box.
If the new attribute has an attribute type of Date, you can 
type the default value, or select a date from the drop down 
calendar.

Include time 
of day

This option is available when date attribute types are selected.
If you select this box, date and time values are displayed using 
the default short date format for your current locale, and a 
24-hour clock.
If you clear this box, date values are displayed using the 
default long date format for your current locale.

General tab Description
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7. By default, the attribute inherits its access rights from the module. 

If you want to change its access rights use the Access (Definition) and 
Access (Value) tabs. For more information see “Controlling access to an 
attribute definition,” on page 119 and “Controlling access to an attribute 
value,” on page 121.

8. Click OK.

9. Click Close.

10. Save the module to make the change permanent (click File > Save).

Objects Select this check box if you want the attribute to apply to the 
objects in the module.

Module Select this check box if you want the attribute to apply to the 
module.

Inherit value Select this check box if the attribute applies to objects, and if 
you want objects to be able to inherit the attribute value from 
their parent objects.
Note that if the attribute applies to both the module and 
objects in it, top-level objects don’t inherit the value from the 
module.

Affect change 
bars

Select this check box if you want DOORS to update an 
object’s change bar when anyone edits the attribute values.

Affect change 
dates

Select this check box if you want DOORS to update an 
object’s last modified date when anyone edits the attribute 
values.

Generate 
history

Select this check box if you want DOORS to update the 
database history when anyone edits the attribute values.

Add new 
attribute to 
current view

Select this check box if you want to add a column for the new 
attribute to your current view.

General tab Description
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Creating a new DXL attribute

You can use the DXL Attribute Wizard to create a DXL attribute that contains 
the values of other attributes in the module. This is particularly useful for 
displaying the values of more than one attribute in table cells.

1. Click Edit > Attributes, and click New.

2. Type a name for the attribute in the Name box.

3. Select Text in the Type box.

4. Select DXL attribute and click Wizard.

The DXL Attribute Wizard opens.

5. Click Next.
The Attribute Selection screen is displayed. 

6. Select the attributes you want to include in the DXL attribute and click 
Next.
The Attribute Ordering screen is displayed.

7. Move the attributes up or down the list by selecting the attribute name and 
clicking the up or down arrow. Click Next.
The Other Information screen is displayed.

8. The following options are available:

• One attribute per line
• Show attribute names
• Include OLE objects in text.

Select or clear the options as required and click Next.
The Finish screen is displayed

9. Click Finish.

The new attribute is created. If you do not want the attribute displayed in a 
column in the module, clear the Add new attribute to current view check 
box on the New attribute dialog box.

10. Click OK.

Controlling access to an attribute definition
Use access rights to control who can edit an attribute definition.
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For example, you might want to lock Generate history on for an attribute 
definition. If users can edit the attribute definition, a dishonest user could 
conceal a change to an attribute value by temporarily turning Generate history 
off, changing the attribute value, and then turning Generate history on again. 
Although the modification of the attribute definition would be recorded in the 
module’s history, you would miss the change to the attribute value. By setting 
strict access rights, this unlikely event becomes impossible.
To change the access rights for an attribute definition, you must have admin 
access to it.
To change the access rights for an attribute definition:
1. Open the module that contains the attribute definition you want to change.

2. Click Edit > Attributes.

3. Select the attribute, then click Edit.
4. Click the Access (Definition) tab.

The current access rights for the attribute definition are displayed.

If the module is partitioned in, the access rights associated with the partition 
are displayed. These describe the maximum access that any user has. They 
override the RMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RMDA), but the attribute is 
partitioned in read only, in practice the user has only read (R) access.

You need this 
access right

To

Read (R) See the attribute definition

Modify (M) Change the attribute definition in any way

Delete (D) Delete the attribute definition

Admin (A) Change the access rights for the attribute definition
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5. Make the changes you want.

6. Click OK.

7. Click Close.

8. Save the module to make the changes permanent (click File > Save).

Controlling access to an attribute value
Use access rights on an attribute’s values to control who can edit the values. To 
edit the value of an attribute for a particular object, you need modify access to 
both the object and the attribute’s values.
For example, you give everyone read-only access to the Priority attribute’s 
values. This lets everyone see the priority of each object, but they can’t change 
the priority even if they have modify access to the object.

Access tab Description

Inherit from 
parent

Select this check box if you want the attribute definition to 
inherit its access rights from the module.
When this check box is selected, the list of access rights is 
unavailable, and shows what access rights the attribute 
definition is inheriting.

Add To add a new entry to the list of access rights:
a. Click Add. 

The Add Access window is displayed.
b. In the Name box, select the name of the user or 

group that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select the 
entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit. 

The Edit Access window is displayed.
b. Select the access rights you want to give them, then 

click OK.
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To change the access rights for an attribute value, you must have admin access to 
it.
To change the access rights for an attribute value:
1. Open the module that contains the attribute value you want to change.

2. Click Edit > Attributes.

3. Select the attribute, then click Edit.
4. Click the Access (Value) tab.

The current access rights for the attribute values are displayed.

If the module is partitioned in, the access rights associated with the partition 
are displayed. These describe the maximum access that any user has. They 
override the RM access rights displayed for users and groups.

For example, if a user’s entry says full access (RMA), but the attribute is 
partitioned in read only, in practice the user has only read (R) access.

5. Make the changes you want.

You need this 
access right

To

Read (R) See the value of the attribute for any object.

Modify (M) Change the value of the attribute for any object.

Admin (A) Change the access rights for the attribute value.

Access tab Description

Inherit from 
parent

Select this check box if you want the attribute value to inherit 
its access rights from the module.
When this check box is selected, the list of access rights is 
dimmed, and shows what access rights the attribute value is 
inheriting.
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6. Click OK.

7. Save the module to make the changes permanent (click File > Save).

Editing an attribute definition
To edit an attribute definition, you must have modify access to both the attribute 
definition and the module it’s in.
To edit an attribute definition:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click Edit > Attributes.

3. Select the attribute you want to edit, then click Edit.

Add To add a new entry to the list of access rights:
a. Click Add. 

The Add Access window is displayed.
b. In the Name box, select the name of the user or group 

that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select the 
entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit.

The Edit Access window is displayed.
b. Select the access rights you want to give them, then 

click OK.

Access tab Description
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4. On the General tab, make the changes you want.

General tab Description

Name The name of the attribute definition.
Note When you change the name of an attribute definition, it 

is no longer recognized by any of the views it’s in. 
Update each view to add a column for the attribute, 
then save the view.

Description Additional information about the attribute definition.

Type The type of the attribute. Once an attribute has been created, 
you cannot change its type, so this field is always unavailable.

Locale This option is displayed when either Text or String attribute 
types are selected.
Select a locale for the attribute. By default this is the current 
locale on the client machine. For more information, see the 
section on understanding locales in Managing Telelogic 
DOORS, which is part of the DOORS documentation set.

DXL attribute Select this check box if you want to use a DXL program to 
assign values to a text attribute. Click Browse to select the 
DXL program you want to use, or Wizard to create a DXL 
attribute using the DXL Attribute Wizard. 
If you are editing an existing DXL attribute, see “Editing a 
DXL attribute definition,” on page 126.

Browse If the DXL attribute check box is selected:
a. Click Browse. 

A list of all the predefined DXL programs that can be used 
to set attribute values is displayed.

b. Select the program you want to use, then click OK.

Alternatively, if you want to define a new program, click New.
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Wizard If the DXL attribute check box is selected:
a. Click Wizard.

b. Step through the DXL Attribute Wizard, selecting the 
attributes that you want to display in the DXL attribute, 
the order in which you want them displayed, and how 
you want the information to be displayed.

c. Click Finish to create the DXL attribute.

Multi-valued Select this check box if the attribute type has a base type of 
Enumeration, and you want to be able to store more than one 
value in the attribute.

Default value If you want the attribute to have a default value, select the 
Default value check box, then type the value in the box.
If the attribute has an attribute type of Date, you can type the 
default value, or select a date from the drop down calendar.
When you change the default value of an attribute definition, 
the values of any attributes that have been assigned the 
previous default value are updated.

Include time of 
day

This option is available when date attribute types are selected.
If you select this box, date and time values are displayed using 
the default short date format for your current locale, and a 
24-hour clock.
If you clear this box, date values are displayed using the default 
long date format for your current locale.

Objects Select this check box if you want the attribute to apply to the 
objects in the module.

Module Select this check box if you want the attribute to apply to the 
module.

Inherit value Select this check box if the attribute applies to objects, and if 
you want the objects to be able to inherit the attribute value 
from their parent objects.
Note that if the attribute applies to both the module and 
objects in it, top-level objects don’t inherit the value from the 
module.

General tab Description
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5. Use the Access (Definition) tab if you want to change who can see or 
modify the definition of the attribute. For more information, see 
“Controlling access to an attribute definition,” on page 119.

6. Use the Access (Values) tab if you want to change who can read or modify 
the attribute’s values. For more information, see “Controlling access to an 
attribute value,” on page 121.

7. Click OK.

8. Click Close.

9. Save the module to make the changes permanent (click File > Save).

Editing a DXL attribute definition

If the DXL attribute you are editing was created using the DXL Attribute 
Wizard, edit it using the wizard. Edit any other DXL attributes by clicking the 
Browse button. 
If the DXL attribute was created using the DXL Attribute Wizard:
1. Select the DXL attribute you want to edit.

2. Click Wizard.

The DXL Attribute Wizard is displayed.

3. Click Next.
The Attribute Selection screen is displayed. The attributes that are 
currently included in the DXL attribute definition are selected.

Note  If no attributes are selected on this screen, the DXL 
attribute was probably not created using the wizard. If 
you continue, any DXL that is currently associated with 
the attribute will be overwritten. If you do not want to 

Affect change 
bars

Select this check box if you want change bars to be updated 
when you edit the attribute values.

Affect change 
dates

Select this check box if you want last modified dates to be 
updated when you edit the attribute values.

Generate 
history

Select this check box if you want changes to the attribute’s 
values to be recorded in the database history.

General tab Description
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overwrite the existing DXL, click Cancel and use the 
Browse button to edit the DXL attribute.

4. Select the attributes you want to add to the DXL attribute definition, and 
clear the attributes that you want to remove from the attribute definition.

5. Click Next.
The Attribute Ordering screen is displayed.

6. Move the attributes up or down the list by selecting the attribute name and 
clicking the up or down arrow. 

7. Click Next.
The Other Information screen is displayed.

8. The following options are available:

• One attribute per line
• Show attribute names
• Include OLE objects in text

Select or clear the options as required and click Next.
The Finish screen is displayed.

9. Click Finish.

The DXL attribute definition is updated.

If the DXL attribute definition was not created using the DXL Attribute 
Wizard:
1. Select the DXL Attribute you want to edit.

2. Click Browse.

The Browse DXL dialog box is displayed.

3. Click Current.
The Edit Attribute DXL window opens, and the DXL associated with the 
attribute is displayed for editing and checking. 

Note  If the DXL was created by the DXL Attribute Wizard, 
this is indicated in the first line of the code. If you make 
manual changes to code that was generated by the 
wizard, and you subsequently edit the attribute using the 
wizard, the manual changes will not be recognized, and 
will be overwritten.
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Sharing attribute and type definitions
DOORS allows you import attribute types or attribute definitions into your 
current module from any module in the DOORS database that you have read 
access to. 
To import attribute definitions into an open module:
1. Click Edit > Attributes.

The Columns and Attributes window is displayed.

2. Select the Attributes tab.

The attributes that are available in the module are listed.

3. Click Import.
The Import Attribute dialog box is displayed.

4. Click Browse.

A Mini-Explorer window opens.

5. Browse to the source module containing the attribute definitions you want 
to import, and then click OK.

The source module’s attributes are listed in the Import Attribute dialog 
box.

6. Select the attribute definition or definitions that you want to import, then 
click OK.

The dialog box closes. The attribute definitions are added to your open 
module and the display returns to the Columns and Attributes window.

7. Click Close.

To import type definitions into an open module:
1. Click Edit > Types.

The Columns and Attributes window is displayed.

2. Select the Types tab.

The types that are available in the module are listed.

3. Click Import.
The Import Type dialog box is displayed.

4. Click Browse
A Mini-Explorer window opens.
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5. Browse to the source module containing the type definitions you want to 
import, and then click OK.

The source module’s types are listed in the Import Types dialog box. 

6. Select the type definition(s) you want to import, then click OK.

The window closes. The type definitions are added to your open module and 
the display returns to the Columns and Attributes window.

7. Click Close.

Deleting an attribute definition
To delete an attribute definition, you must have delete access to the attribute 
definition, and modify access to the module.

Note  You can’t undelete an attribute definition once you’ve deleted 
it.

To delete an attribute definition:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click Edit > Attributes.

3. Select the attribute you want to delete, then click Delete.

4. A message is displayed asking if you really want to delete the attribute. Click 
Yes. 

5. Click Close.

6. Save the module to make the change permanent (click File > Save).

Understanding DXL attributes and layout DXL columns
Both DXL attributes and layout DXL columns use DXL programs to calculate 
values displayed on your screen. For example, DOORS provides DXL programs 
that calculate the number of days since an object was last modified, and the 
number of in-links and out-links for an object.
The differences between DXL attributes and layout DXL columns are subtle.
With a DXL attribute, the DXL program is associated with an attribute 
definition. You can use the attribute in multiple columns and in multiple views.
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With a layout DXL column, the DXL program is associated with a single 
column, but not with any attribute. A layout DXL column is a column that 
doesn’t contain an attribute. Instead, it uses the DXL program to calculate what 
to display on your screen.

Note  Layout DXL does not process table objects.

The values of an object’s DXL attributes are automatically calculated only when 
the object is first displayed on your screen. To make DOORS recalculate the 
values, click Tools > Refresh DXL Attributes. This updates the values of all of 
the DXL attributes in the module by re-running the DXL programs associated 
with them in the background.
The values displayed in a layout DXL column are automatically recalculated 
whenever DOORS refreshes your screen. If the DXL program associated with 
the column is compute intensive, the constant recalculation of the values can 
lead to poor performance. In this case you should consider using a DXL 
attribute instead of a layout DXL column.
You should also use attribute DXL, or convert your layout DXL column to 
attribute DXL, if a large amount of data is displayed in the column. This is 
because you cannot scroll layout DXL if the object contains more data than can 
be displayed on the screen, but you can scroll attribute DXL.
For more information, see the DXL attributes section of the DXL Reference 
Manual. This manual is available from the Help menu in DOORS, and also as a 
PDF from the Telelogic Lifecycle Solutions DVD, and our web site at 
https://support.telelogic.com.

Copying attribute values
To copy values from one attribute to another, within the same module:
1. In the module window, click Tools > Functions > Copy Attributes.

2. In the Source attribute box, select the attribute that contains the values you 
want to copy.

3. In the Destination attribute box, select the attribute whose values you 
want to overwrite.

4. Click OK.

5. Save the module to make the changes permanent (click File > Save).
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Measuring the frequency of attribute values
You can display a graph that shows the frequency of attribute values for all the 
objects in the current view. 
This function is useful for monitoring attributes that have a small number of 
finite values, for example priority or pass/fail attributes. If you use it to monitor 
attributes that have a large number of values, for example Object Text, the 
resulting graph will not provide any useful information.
To display a graph of an attribute:
1. In the module window, click Tools > Functions > Statistics.
2. In the Attribute box, select the attribute you want to look at.

The frequency of the attribute’s values for all objects in the current view are 
displayed graphically.

3. If you want to print the information or export it to a file, click Publish.

If you want to print the page, you can control:

• The page orientation
• The horizontal and vertical scale
• The top and left margins



Using attributes

132    Using Telelogic DOORS



Using Telelogic DOORS     133

9 Viewing data in formal modules
This chapter contains the following topics:

• Navigating using the keyboard

• Using the view menu

• Using the Module Explorer

• Understanding display modes

• Changing the display mode

• Controlling display levels

• Controlling table attribute display

• Using outlining

• Using compression

• Working with columns

• Showing column information

• Adding a column

• Editing column information

• Color-coding your data

• Adding a graph column

• Adding an icon column

Navigating using the keyboard
The following table shows the keys you can use on your keyboard to navigate 
formal modules:

Press To

HOME Go to the first object in the module.

END Go to the last object in the module.

PAGE UP Scroll up one screen in Document mode. 
Rotate the tree clockwise through 90 degrees in Graphics 
mode.
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Using the view menu
In a module window, use the following options on the View menu to change the 
way your screen looks and control what data is displayed:

PAGE DOWN Scroll down one screen in Document mode.
Rotate the objects clockwise in Graphics mode.

UP ARROW
DOWN ARROW

Go to the next or previous object in Document mode.
Move up or down the tree hierarchy in Graphics mode.

CTRL+UP 
ARROW
CTRL+DOWN 
ARROW

Move from the current object to the sibling above or below it.
Scroll, if the focus is on the left pane of the Module Explorer.

CTRL+LEFT 
ARROW
CTRL+RIGHT 
ARROW

Go to the current object’s parent (left arrow) or first child 
(right arrow).
Scroll if the focus is on the left pane of the Module Explorer.

SHIFT+RETURN Edit the current object in-place in Document mode.
Go to the next object if you’re already editing in-place.
Note It does nothing if you’re in Graphics mode, or if the 

focus is on the left pane of the Module Explorer.

View menu Description

Module 
Explorer

Turns the Module Explorer on or off. For more information, see 
“Using the Module Explorer,” on page 136.

Graphics Mode Turns Graphics mode on or off. For more information, see 
“Understanding display modes,” on page 137 and “Changing the 
display mode,” on page 139.

Outline Turns outlining on or off. For more information, see “Using 
outlining,” on page 142.

Press To
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Compress Compresses (or hides) parts of the data hierarchy when outlining 
is turned on. For more information, see “Using compression,” on 
page 143.

Level Controls how many levels of the hierarchy are displayed.
For more information, see “Controlling display levels,” on page 
140.

Tables Controls the default attribute that is displayed in all tables in the 
module. 
For more information, see “Controlling table attribute display,” 
on page 141.

View menu Description
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Using the Module Explorer
To turn on the Module Explorer, do one of the following:
• Click View > Module Explorer.
• Click Module Explorer  on the Display toolbar.

Show Controls what is shown on your screen:

• Use Sort to control whether the display reflects the current 
sort criteria. It turns sorting on and off.

• Use Filter to control whether the display reflects the current 
filter criteria. It turns filtering on and off.

• Use Deletions to control whether deleted objects are 
displayed. Deleted objects are colored red and have black 
change bars .

• Use Pictures to control whether pictures are displayed.

• Use Table Cells to control whether tables are displayed. 
When a table is hidden, a table marker object (>> Table) is 
displayed instead of the table. Tables are automatically hidden 
when sorting is turned on. The left pane of the Module 
Explorer always displays table marker objects.

• Use Link Arrows to control whether link arrows are 
displayed. These are triangular arrows like this . Note that 
you can’t use this option to show hidden link arrows in table 
cells, but you can use it to hide shown link arrows in table cells.

• Use Change Bars to control whether change bars are 
displayed.

• Use Graphics Links to control whether lines between linked 
objects in Graphics mode are displayed. You can click these 
lines to go to the source or target object.

• Use Graphics Datatips to control whether datatips are 
displayed in Graphics mode.

Refresh 
Explorer

Updates the left pane of the Module Explorer, so that it displays 
the current object.

Refresh Refreshes the screen display.

View menu Description
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Understanding display modes

When you turn the Module Explorer on, two panes are displayed:

• The left pane has a Windows Explorer style display that lets you quickly 
navigate the object tree within the module.

• What’s displayed in the right pane depends on whether you’re in Document 
or Graphics mode and what display options, such as outlining, you’re using.

When you turn the Module Explorer off, the left pane disappears and the right 
pane fills your screen.

Understanding display modes
You can use the following display modes:

• Document mode

• Graphics mode

Document mode is the default. It displays the module data as a table, with rows 
and columns, as shown in this screenshot.
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In Graphics mode each object is displayed as a box that contains one attribute, as 
shown in the following screenshot:

You can choose which attribute is displayed in the box (see “Changing the 
display mode,” on page 139). By default, it’s the Object Short Text attribute. If 
the object doesn’t have an Object Short Text, one of the following is used, in 
order of priority: Object Heading, then Object Text, then Object Identifier.
The box at the left shows the title of the main column, User requirements for 
SUV 4x2.
In Graphics mode:

• The current object has a pink border, and is always visible on your screen.

As you navigate around the module, the display changes to keep the current 
object near the center of your screen. On a large screen, it magnifies the 
objects in the center and makes the objects at the edge smaller, as if you were 
looking through a fish-eye lens.

• If you roll your mouse over an object, a datatip is displayed.

By default, the datatip shows the Object Heading and Object Text 
attributes. You can choose to display another attribute in the datatip (see 
“Changing the display mode,” on page 139).

• A red square or triangle is displayed if there are child objects that are hidden 
because they don’t fit on your screen. Click the red square or triangle to 
display the hidden objects.



Using Telelogic DOORS           139

Changing the display mode

Note  A red square means a single object tree is hidden. A red 
triangle means two or more object trees are hidden.

Changing the display mode
For information on display modes, see “Understanding display modes,” on page 
137.
To turn Graphics mode on or off, either:
• Click View > Graphics Mode.

• Click Turn Graphics mode on or off  on the Display toolbar.

This switches between Graphics mode and Document mode. When Graphics 
mode is off, you get the default mode, which is Document mode.

Selecting the attributes shown in graphics mode
To change the attribute shown in the object boxes in Graphics mode:
1. Turn Graphics mode off.

2. Select the title of the column that contains the data you want to display in 
the object boxes in Graphics mode, then right-click Use in Graphics mode 
boxes. 

A white marker is displayed at the top right edge of the column’s title bar, as 
shown in the next screenshot.

To change the attribute shown in the datatips in Graphics mode:
1. Turn Graphics mode off.

2. Select the title of the column that contains the data you want to use, then 
right-click Use in Graphics mode datatips. 
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An orange marker is displayed at the bottom right edge of the column’s title 
bar, as shown in the following screenshot.

Controlling display levels
The object hierarchy in a module is often too complex to see at once.
You can specify how many levels of the hierarchy you want to see. For example, 
you may only want to see level 1 and level 2 objects.
To change the display level either:
• Click View > Level, then select the level you want.

• Select the display level from the Display to level drop-down list on the 
View toolbar.
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Controlling table attribute display

Objects lower than the selected level are hidden. For example, if you select level 
2, you only see level 1 and 2 objects.

Notice that an object is marked with a > symbol if it has children that are hidden 
because they’re at a lower level than the selected display level.

Note  The display level only affects what is shown in the module 
window. The Module Explorer always shows all the objects 
in the current view.

Controlling table attribute display
By default, table cells display the main column attributes: Object Heading and 
Object Text. If you want to display a different attribute in table cells, either:

• Use the table properties to specify which attribute you want to display in that 
table’s cells. This allows you to display a different attribute in each table in 
the module. For more information about this option, see “Changing table 
properties,” on page 169.

• Use the Table Attributes option under the View menu to set an attribute 
other than the main column attributes to be the default displayed in tables in 
the module. You can choose to make this setting override table settings for 
individual tables in the module.

To change the default attribute displayed in table cells:
1. In the formal module, click View > Table Attributes.

The Table Attributes dialog box is displayed.

2. Select Enable default table attribute, and select the attribute that you want 
to display from the list.
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3. If you want this setting to override any attribute settings that have been 
made in the table properties of individual tables, select the Default attribute 
overrides table settings check box.

4. Click OK.

If you want this setting to persist through different sessions, you must save the 
view. For more information, see “Saving your current view,” on page 79.

Using outlining
Outlining reduces the amount of information displayed on your screen.
When outlining is turned on:

• Only objects that have a heading are displayed.

• Only the Object Heading of those objects is displayed. Their Object Text 
attribute is hidden.

You can use outlining in Document or Graphics mode.

Note  Outlining only affects what is shown in the module window. 
The Module Explorer always shows all the objects in the 
current view.

To turn outlining on or off, do one of the following:
• Click View > Outline
• Click Turn outlining on or off  on the Display toolbar

Note  Tables are always hidden when outlining is turned on.
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Using compression
When outlining is turned on, you can compress or hide parts of the hierarchy.

For example, in this picture section 3 is compressed. It has a plus sign to show 
that its objects are hidden.
To turn compression on or off for the current object, click View > Compress.

Working with columns
When you’re in Document mode, module data is displayed in rows and columns.

To Do this

Move a column Drag the column’s title to the new position.

Change the width of a 
column

Drag the column separator at the edge of the 
column’s title bar.

Select a column Click the column’s title.

De-select a column Click its title again.
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Change the alignment of the 
contents of a column

Select the column, then either:

• Right-click Left, or click Left align column  
on the Column Alignment toolbar.

• Right-click Right, or click Right align column 
 on the Column Alignment toolbar.

• Right-click Center, or click Center column  
on the Column Alignment toolbar.

• Right-click Justify, or click Justify column  
on the Column Alignment toolbar.

Auto-indent the main 
column

Select the column, then either:

• Right-click Auto Indent, or click Auto-indent 
main column on the Column Alignment 
toolbar.

The contents of the main column are indented 
according to the object’s position in the hierarchy: the 
lower down the hierarchy the object is, the further it is 
indented. This allows users to see at a glance the 
structure of the module.

Sort the module on the 
contents of a column

Right-click on the column heading and click Sort > 
Ascending or Sort > Descending. The module is 
sorted according to the contents of the module. For 
more information about using sorting, see 
“Understanding sorts,” on page 100.

Remove a column Either:

• Select the column’s title, then right-click Remove.

• Select the column, then click Remove column 
 on the Column toolbar.

Add a column Follow the instructions in “Adding a column,” on 
page 145.

Use a column in Graphics 
mode

Select the column, then either:

• Right-click Use in Graphics mode object boxes.
• Right-click Use in Graphics mode datatips.

To Do this
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Showing column information

Showing column information
When you’re in Document mode, you can control what columns are displayed on 
your screen, what’s displayed in each column, what the column titles are, and so 
on.
To show column information:
1. In the module window, click Edit > Columns.

2. On the Columns tab, a list is displayed of all the columns currently 
displayed on your screen:

• The Title column shows the title of the column.
• The Attribute column shows the name of the attribute. If the column 

doesn’t contain an attribute, words in angle brackets are displayed. For 
example, if it contains layout DXL, <Layout DXL> is displayed.

• The Type column shows the type of the attribute. It’s empty if the 
column doesn’t contain an attribute.

3. To remove a column, select it, then click Remove.

Note  You can also remove a column, by selecting the column’s title 
in the module window, then either right-clicking Remove, or 
clicking Remove column  on the Column toolbar.

Adding a column
When you’re in Document mode, you can control what columns are displayed on 
your screen.

Note  The maximum number of columns you can display in a view 
is 32. 

To add a column:
1. In the module window, click Insert > Column.

Alternatively, click Insert column  on the Column toolbar.

Note  You can also click Edit > Columns, which displays the 
Columns and Attributes window, with the Columns 
tab selected. This shows a list of all the columns 
currently displayed on your screen, in the order in which 
they are displayed. Select the column that you want to 
insert the new column before, then click New or Copy. 
If you don’t select a column, the new column is added to 
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the bottom of the list and is displayed at the extreme 
right of the module window.

2. In the New Column window, use the Contents radio buttons to specify 
what you want to display in the column:

• To display an attribute in the column, click Attribute, then select the 
attribute from the drop-down list.

• To display layout DXL in the column:

i. Click Layout DXL 

ii. Click Browse to specify the DXL. A list of all the predefined DXL 
programs you can use is displayed.

iii. Select the program you want to use, then click Apply. Alternatively, 
if you want to define a new program, click New and define the 
program.

Note  Layout DXL columns do not display 
information about table objects.

• To display the Object Heading and Object Text attributes in the 
column (like a main column), click Object Heading and Object Text.

• To display a discussion in the column:

i. Click Discussion.

ii. Click Browse to specify the type of discussion. A list of all the 
available discussion types is displayed.

iii. Select the discussion type you want to use, then click OK.

Note  Discussion columns do not display discussions 
about table objects.

3. If you want to color-code the data that is displayed in the column, click By 
attribute in the Text Color box, then select the attribute from the 
drop-down list.

Only attributes that have a color defined as part of their definition are 
included in the drop-down list.

For information on color-coding, see “Color-coding your data,” on page 
148.

4. In the Column Title box, type the title you want the column to have. 
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Editing column information

You can leave this box blank if you’re displaying an attribute in the column. 
By default, the title of the column is the same as the name of the attribute.

5. Click Insert.
6. If you want to add more columns to the view, add them and click Insert.
7. When you have finished adding columns, click Close.

If you want to permanently add the new column to your view, follow the 
instructions in “Saving your current view,” on page 79.

Editing column information
See also “Working with columns,” on page 143.
To edit column information:
1. In the module window, click Edit > Columns.

2. A list of all the columns currently displayed on your screen is displayed. 
Select the column you want to edit, then click Edit.

The following table describes the options on the Edit Column dialog box.

Option Description

Title The title of the column.

Attribute Selected if the column contains an attribute. The drop-down 
list shows the name of the attribute.

Layout DXL Selected if the column contains layout DXL. Click Browse to 
see the name of the DXL program.

Object Heading 
and Object Text

Selected if the column contains both the Object Heading 
and Object Text attributes, like a main column.

Discussion Selected if the column contains a type of discussion. Click 
Browse to see the discussion type.

Default Selected if the data displayed in the column isn’t color-coded 
using the values of another attribute.
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Color-coding your data
For enumerated attribute types you can define the color associated with each 
value that the attribute can have.
For example, you have an enumerated attribute type called Yes or No, and you 
define its values and their colors like this:

You create an attribute called Approved that has the type Yes or No. You can 
then edit the properties of any of the columns in the view so that the data in the 
column is color-coded according to the value of the Approved attribute. For 
example, right-click on the main column title bar and select Properties. In the 
Color pane, select By attribute and select Approved from the list.
The main column is color-coded using the Approved attribute. Items that are 
approved are green, and items that are not approved are red.
In this case, you don’t need to display the Approved attribute in its own column, 
because you can see at a glance which items are approved from their color in the 
main column.
If you want this setting to persist through different sessions, you must save the 
view. For more information, see “Saving your current view,” on page 79.

By attribute Selected if the data displayed in the column is color-coded 
using the values of another attribute.
Only attributes that have color set up as part of their 
definition are included in the drop-down list.
The drop-down list shows the name of the other attribute. For 
more information, see “Color-coding your data,” on page 148.

Column title The column title that is displayed in the view. If you leave this 
blank, the attribute name is displayed as the column title.

Value Color

Yes Green

No Red

Option Description
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Adding a graph column

Adding a graph column
A graph column is a column that contains one or more bar charts. Each bar 
chart displays the values of an attribute. The attribute must have numeric values; 
it must be of base type integer or real.

In this picture the Impact vs Volatility column is a graph column that displays 
bar charts.
Graph columns are layout DXL columns. If you edit the values of the attributes 
shown in the columns, the bar charts are immediately updated to show the new 
values.
To add a graph column to your current view:
1. Click Tools > Wizards > Graph.

The Graph Wizard’s Welcome screen is displayed.

2. Click Next.
3. Select the attributes that you want to display as bar charts in the column.

The available attributes are listed in the Existing attributes box. You can 
add and remove attributes from the Attributes to graph list by selecting an 
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attribute and clicking Add, Insert or Delete. The buttons are described in 
the following table.

4. Click Next.
5. You can change the scaling factor for your bar charts. The Preview box 

shows what your bar charts look like for the current object.

The following table describes the options on the Preview box.

Click To

Add Put the attribute after the selected entry in the Attributes to 
graph box

Insert Put the attribute before the selected entry in the Attributes 
to graph box

Delete Delete the attribute from the Attributes to graph box

Save Save the list of attributes to a file

Load Load a list of previously saved attributes from a file

Option Description

Minimum 
value
Maximum 
value

You can’t edit these boxes.
Initially they show the value for the current object (the 
minimum value is 0, and the maximum is the value for the 
current object).
Clicking Rescale for all objects shows the minimum and 
maximum values for all the attributes selected in the previous 
screen.

Minimum scale
Maximum 
scale

These show the minimum and maximum values that are 
shown in the bar charts.
Initially the minimum is 0, and the maximum is the value for 
the current object.
To change the values, type new numbers, then click Rescale.

Rescale Use this when you have typed new numbers in the Minimum 
scale or Maximum scale boxes. It rescales the bar charts 
using the new numbers.
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Adding a graph column

6. Click Next.
7. Select the type of bar charts you want and the width and height of each bar 

chart. The Preview box shows what they look like.

The following table describes the options on the wizard screen.

8. Click Next.
9. If you want labels on your bar charts, select the Labels box, then specify 

what labels you want. The Preview box shows what your bar charts look like.

Percentage 
values

Changes the Minimum scale and Maximum scale values to 
0 and 100 respectively, then rescales the bar charts using the 
new numbers.

Rescale for all 
objects

Changes the Minimum scale and Maximum scale values to 
the minimum and maximum values for all the attributes 
selected in the previous screen, then rescales the bar charts 
using the new numbers.
It also changes the Minimum value and Maximum value to 
the minimum and maximum values for all the attributes 
selected in the previous screen.

Option Description

Graph type Select either Vertical 3D bar chart, Horizontal 3D bar chart, 
Vertical bar chart, or Horizontal bar chart.

Width Type the width in pixels, then click Resize.
Note Pixels are used to measure distances on computer 

screens. Open Display in the Control Panel, then the 
Settings tab to find out how big your screen is in pixels.

Height Type the height in pixels, then click Resize.

Resize Changes the size of the bar charts, using the values shown in 
the Width and Height boxes.

Option Description
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The following table describes the options on the wizard screen.

10. Click Next.
11. Specify the colors you want in your bar charts. The Preview box shows what 

they look like.

You can specify the color of the label text, the background color, and the 
color of the bars. For a 3D bar chart, you can specify the colors of the front, 
top, and sides of each bar.

Option Description

Labels Select this check box if you want labels on the bar charts.
The default label is the name of the attribute.

Include values Select this check box to display the value, in parentheses, after 
the label.

Position Specify whether you want the labels below the bars of the 
charts (out of bars) or inside them (in bars).

Alignment If you select the in bars position, specify whether you want 
the label at the top, bottom or center of the bars.

Attribute Lists the attributes that are shown in the bar charts.

Label Shows the label for the attribute selected in the Attribute 
drop-down list. By default, the label is the name of the 
attribute.
To change the label, type a new label, then click Apply label.

Apply label Use this when you have typed a new label in the Label box. It 
changes the label of the attribute selected in the Attribute 
drop-down list to the value shown in the Label box.

Option Description

Change the 
color of

Select either Text, Background, or one of the attributes in 
the bar chart.

Side For a 3D bar chart, select Front, Top, or Side.

List of colors Click the color you want.
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Adding an icon column

12. Click Next.
13. In the Column title box, type a title for the graph column.

14. Use the Insert radio buttons and the Column box to specify where you 
want to insert the column.

15. Click Finish to add the column to your current view.

If you want to permanently add the new column to your view, follow the 
instructions in “Saving your current view,” on page 79.

Adding an icon column
An icon column uses an icon to display the value of an attribute. For example, 
this picture uses an icon to display the value of the Progress attribute.

You can use an icon to display either:

• An attribute whose values are numbers (attributes of type Integer or Real).
• An enumerated attribute.

Note  You can only display one attribute in an icon column, unlike a 
graph column that can display multiple attributes.

Icon columns are layout DXL columns. If you edit the values of the attributes 
shown in the columns, the icons are immediately updated to show the new 
values.
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To add an icon column to your current view:
1. Click Tools > Wizards > Icon.

The Iconizer Wizard’s Welcome screen is displayed.

2. Click Next.
3. Select the attribute you want to show in the icon column. 

4. Click Next.
5. Select the style of icon you want to use.

You can only select styles that have a pink background. Click a style to select 
it.

6. If the Use color check box is available, you can clear it if you only want to 
use one color in the icon.

7. If the Horizontal check box is available, select it to rotate the icon through 
90 degrees.

8. Click Next to display the next wizard screen.

9. In the Column title box, type a title for the icon column.

10. Use the Insert radio buttons and the Column box to specify where you 
want to insert the column.

11. Click Finish to add the column to your current view.

If you want to permanently add the new column to your view, follow the 
instructions in “Saving your current view,” on page 79.
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10 Using the Module Comparison Wizard
This chapter contains the following topics:

• What is the Module Comparison Wizard used for?

• How does the Module Comparison Wizard work?

• Running the Module Comparison Wizard

• Understanding the redline markup column

What is the Module Comparison Wizard used for?
You can use the Module Comparison Wizard to compare two modules and 
identify objects that have been inserted, deleted, moved or edited. For example, a 
set of requirements for a project may be updated several times by the customer. 
You can import the updated requirements into a new DOORS module, then 
compare the new module to the original module. Identical and almost identical 
objects are matched, and any changes that have been made are displayed in a 
column in the new module with redline markup.
The wizard only compares plain text. Rich text formatting, pictures and OLE 
objects cannot be compared. OLE objects embedded in text are also ignored 
when the text is compared.

How does the Module Comparison Wizard work?
The Module Comparison Wizard uses approximate matching techniques that 
work best when about 75% of the heading structure of the modules being 
compared is identical.
The Module Comparison Wizard creates links between the objects that it 
matches. When the module comparison is complete, the wizard can apply a filter 
to both modules so that only objects that have not been matched are displayed.

Note  You must run the Module Comparison Wizard from the 
current version of the newer of the two modules that you are 
comparing. If you run the wizard from the older module, the 
redline markup will be incorrect because the wizard treats the 
module from which it is being run as the most recent, and 
marks up the text accordingly.
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The module comparison is performed in four stages. Stages one and three are 
compulsory; stages two and four are optional. You can select the attributes that 
the wizard will compare. 

When the comparison is complete the results can be displayed in a column in the 
newer module. Changes to the attributes that are compared by the wizard are 
displayed with redline markup. A filter can also be applied to both modules to 
display objects that have not been matched by the wizard.

Running the Module Comparison Wizard
To run the Module Comparison Wizard:

Stage The wizard...

One Matches objects that are identical. In this stage, only identical 
objects that appear in the same order in both modules are 
matched. Objects that have been moved are not matched during 
this stage.
If a large proportion of objects remain unmatched after this stage 
is complete, the remaining phases will be slow.

Two Matches objects that have been edited. Objects are matched if they 
appear in the same order in both modules, and if a percentage of 
the words being compared are identical. Objects that have been 
moved are not matched during this stage.
You can define what percentage of the text must be identical for 
objects to be matched. The percentage is calculated by the number 
of identical words in the object, and is approximate.

Three Compares the remaining objects and matches identical objects, 
regardless of their position in the module. Objects that have not 
been edited, but have been moved are matched during this stage.

Four Compares any objects that have not yet been matched and 
matches them if a percentage of the text being compared is 
identical. Objects that have been edited and moved are matched 
during this stage.
You can define what percentage of the text must be identical for 
objects to be matched. The percentage is calculated by the number 
of identical words in the object, and is approximate.
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Running the Module Comparison Wizard

1. Open the current version of the newer module in exclusive edit mode.

2. Create a view to which the comparison wizard can add a column. This 
column is used to display the changes with redline markup. The view must 
contain the main column. The comparison column is added to the right of 
the main column.

3. Click Tools > Compare Modules.

The Welcome screen is displayed. The name of the current module is 
displayed in the Newer Module box.

4. Click Next.
The module selection screen is displayed.

5. In the Older Module box, type the name of the module you want to 
compare, including the path from its nearest parent project, or click Browse 
to locate it.

Note  When the module selection screen is displayed, the name 
of the current module is displayed in the Older module 
box, and any baselines of the current module are 
displayed in the Baseline of older module box. If you 
want to compare the module to one of its baselines, 
select the baseline version and click Next.

6. Select the version of the older module you want to compare from the 
Baseline of Older Module list.

7. Click Next.
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The attribute selection screen is displayed.

The list in the Attributes to Compare box includes all of the attributes in 
both modules. 

The Absolute Number, Object Heading and Object Text attributes are 
always compared. Select any additional attributes that you want to compare. 
Changes to attributes that are not selected are ignored. If you select an 
attribute that only exists in one of the modules, the Module Comparison 
Wizard treats it as being empty. 

8. Click Next.
The performance parameters screen is displayed.

There are three limits that you can set on the module comparison to 
improve its performance:

• Limit on size of similar objects to compare

If an object’s text contains more characters than you specify here, and if 
the text is not identical, the wizard does not attempt to match the object. 
It is useful to set a limit here if objects contain large amounts of text that 
are substantially different. 

• Limit on number of similar object comparisons

If the number of object comparisons required in stage four exceeds the 
limit you specify here, you will be prompted to confirm whether you 
want to run stage four of the comparison. The number of comparisons 
is calculated by multiplying the number of unmatched objects that 
remain in the two modules after stage three.

For information about the matches that are made during stage four of 
the wizard, see “How does the Module Comparison Wizard work?,” on 
page 155.

• Maximum difference in similar objects

If objects that are compared have more unmatched text than you specify 
here, they are not matched. For example, if you specify the maximum 
percentage difference to be 40%, at least 60% of the object’s text must 
be identical for the objects to be matched.

Note  The percentage is approximate, and is based on the 
number of matching words in each object.

9. Click Next.
The links screen is displayed.
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Running the Module Comparison Wizard

Note  If the module’s default linkset pairings define the link 
module in which links from this module are stored, the 
link module selection box is unavailable, and links will be 
created in the default linkset for the module.

Type the name of the link module you want to use for the links, including the 
path from the nearest parent project, or click Browse to locate it. 

If you want to create a new link module for the comparison links:

a. Click Create link module.

b. In the Link module path box, type the path from the nearest parent 
project to the project or folder where you want to create the link 
module, or click Browse to locate it.

c. In the Link module name box, type a name for the new link module.

d. In the Link module description box, type a description for the new 
link module, if required.

e. Click Create.

The link module is created in the folder you specified.

10. Click Next.
The display options screen is displayed.

The following options are available for displaying the results of the module 
comparison:

• Filter both modules to show unmatched objects

Select this option to apply a filter to both modules when the module 
comparison is complete. The objects that are displayed in this filter are 
those that have not been matched by the wizard.

• Always treat pictures as different

The wizard cannot compare pictures. If you select this option, objects 
containing pictures will not be matched. If you select Filter both 
modules to show unmatched objects, objects containing pictures will 
be displayed in the filter. You can then manually compare them for 
changes.

• Show differences in a view in the newer module

Select this option to insert a column in the newer module. Changes to 
the attributes that are compared by the wizard are displayed with redline 
markup.
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11. Click Next.
The Finish screen is displayed.

Select the matching stages that you want the wizard to perform. Stages one 
and three are mandatory; stages two and four are optional.

Note  If you select to perform stage four, stage two is selected 
and made unavailable. In performing stage four, the 
wizard automatically performs stage two.

For information on the comparisons that are made during each stage, see 
“How does the Module Comparison Wizard work?,” on page 155.

12. Click Finish.
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Running the Module Comparison Wizard

The Module Comparison Wizard starts, and a progress bar indicates the 
progress of each stage. When the comparison is complete, a dialog box is 
displayed, providing information about the module comparison.

13. Click OK.

The dialog box is closed. 

If you selected to filter the modules to show unmatched objects, those 
objects are displayed. If you ran all four stages of the wizard:

• The objects that are displayed in the filter in the newer module have 
probably been inserted since the creation of the older module.

• The objects that are displayed in the older module have probably been 
deleted from the newer module.

Note  Objects that have more unmatched text than you 
specified in the Maximum percentage difference in 
matched objects box are also displayed.

14. Adjust the linking if necessary. You can manually link any objects that have 
not been matched by the wizard, or delete any links that you don’t want.
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Understanding the redline markup column
If you selected to show differences in a view in the newer module, a column has 
been added to that module. Switch off the filter to see the changes with redline 
markup. The changes are marked up as follows:

For a description of how redline markup is implemented in DOORS see 
“Understanding redlining,” on page 267.

If Then

An object has been inserted The object heading and/or object text of the inserted 
object is displayed in the comparison column in blue, 
underlined text.

An object has been deleted The object immediately above the deleted object 
contains red, italicized text similar to the following:
Deleted object <object ID> follows here
This is followed by the object heading and/or object 
text of the deleted object, in red text with 
strikethrough.

An object has been moved Text such as (Parent object differs), (Preceding 
object differs) or (Following object differs) is 
displayed in blue italics in the comparison column of 
the object that appears to have moved. The old 
heading number, which changed when the object was 
moved to its new location, is displayed with 
strikethrough to show the old number, and 
underlined to show the new number.

An object’s heading number 
has changed as a result of 
changes to the module 
structure

The old heading number is displayed in red with 
strikethrough, and the new heading number is blue 
and underlined. 

An object has been edited Deletions within text are shown in red with 
strikethrough, and additional text is blue and 
underlined.
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Understanding the redline markup column

The following screenshot shows the results of a module comparison:

The new column is a layout DXL column. Layout DXL can be memory 
intensive, as the associated DXL is recalculated each time DOORS refreshes the 
display. If you do not want to the DXL to be recalculated on each refresh, you 
can convert the layout DXL column to attribute DXL. The DXL is then 
associated with an attribute, and is recalculated each time the module is opened. 
You can refresh attribute DXL during a session by selecting Tools > Refresh 
DXL Attributes in the module window.
To convert the column to attribute DXL, click Tools > Support Tools > 
Convert Layout DXL to Attribute DXL. In the Convert Layout DXL dialog 
box, select the comparison column and click Convert. A message is displayed 
stating that the DXL has been successfully converted, and the new Attribute 
DXL column is added to the view. 

Note  The attribute DXL column does not contain redline markup, 
and only provides information about changes to the 
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structure of the module. Changes to text within objects are 
not recorded.
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11 Working with tables
This chapter contains the following topics:

• Understanding tables

• Creating a table

• Inserting a module as a table

• Inserting rows

• Inserting columns

• Changing table properties

• Deleting, undeleting and purging tables

Understanding tables
When you insert a table in a module, DOORS creates an object for each cell in 
the table. It also creates a table marker object, which contains the table cell 
objects.
You can see the table marker object in the left pane of the Module Explorer, as 
shown in this picture. It has >> Table as its text.
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In the right pane, the table marker object is hidden by default. Instead the table 
cells is displayed are displayed.
You can turn the display of table cells on and off in the right pane by clicking 
View > Show > Table Cells. When it’s off, >> Table is displayed in the right 
pane as well as the left.

Note  If you want to copy a table, turn the display of table cells off. 
When it’s turned on, the Copy option is unavailable when 
you select a table.

By default, the whole table is displayed in the main column of the module. It’s 
truncated if it is too wide to fit in the main column. Use the table properties 
sheet to override the default behavior and use the full screen width to display the 
table (see “Changing table properties,” on page 169).

Note  You can’t create a table within an existing table cell.

You can use drag-and-drop to copy tables between modules. Select all the cells in 
the table (click the first cell, then SHIFT+Click the last cell) then drag them to 
the target module.

Creating a table
This topic describes how to create an empty table. You can also create a table 
from another module (see “Inserting a module as a table,” on page 167).
To create a table:
1. In the module window, select the object where you want to create the table.

You can create a table at either the same level as the current object or one 
level below the current object.

You must have create access to the current object to create a table one level 
below it. You must have create access to the parent of the current object to 
create a table at the same level as the current object.

2. Click Table > Insert then either After or Below.

3. Optionally type the number of rows and columns you want in your table.

4. Optionally type the column width, in pixels.

Pixels are used to measure distances on computer screens. Open Display in 
the Control Panel, then the Settings tab to find out how big your screen is 
in pixels. 

5. Click OK.
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Inserting a module as a table

6. Save the module to make the changes permanent (click File > Save).

Inserting a module as a table
This topic describes how to insert a whole module as a table in another module, 
as shown in the example. Both modules must be in the same folder, and the 
inserted module must not contain any tables.

To insert an empty table, see “Creating a table,” on page 166.
To insert a module as a table in the current module:
1. Select the object that you want to insert the module after.

2. Click Table > Insert > Module as Table.

The Insert Module as Table dialog box is displayed.

3. In the Source module box, click Browse and select the module you want to 
insert.

Note  The module you want to insert must not contain any 
tables.

4. In the Views box, select the view you want to insert.
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5. Select the Object Identifiers check box if you want the inserted table to 
include a column that contains the object identifiers for the objects in the 
source module.

6. Select the Borders check box if you want the inserted table to have borders 
around its cells.

7. Click OK.

Inserting rows
To insert a new row in a table:
1. In the module window, select the row where you want to insert a new row.

Note  You must have create access to the table marker object.

You can insert a row above or below the current row.

The inserted row has the same number of cells and the same settings as the 
current row. For example, it has the same width and alignment as the current 
row.

2. Click Table > Insert > Row, then either Above or Below.

3. Save the module to make the changes permanent (click File > Save).

Inserting columns
To insert a new column in a table:
1. In the module window, select the cell where you want to insert a new 

column.

Note  You must have create access to the table marker object.

You can insert a column to the left of the current cell, or to the right of the 
current cell.

The inserted column has the same number of cells and the same settings as 
the current column. For example, it has the same width and alignment as the 
current column.

2. Click Table > Insert > Column, then either To the Left or To the Right.
3. Save the module to make the changes permanent (click File, then Save).

Note  In a table with unequal row lengths, cells in the inserted 
column may not be horizontally aligned. Each cell in the new 
column is positioned relative to the start of the row that it’s 
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in. For example, if the current cell is the third cell in the row 
and you insert a column to the left of it, then a new cell is 
added to the left of the third cell in each row.

Changing table properties
To change the properties of a table:
1. Click in a table cell:

• If you want to change the properties of the whole table, click any table 
cell.

• If you want to change the properties of a particular row or column, click 
any cell in that row or column.

• If you want to change the properties of a particular cell, click that cell.

2. Click Table > Properties. 

3. To change the settings for every cell in the entire table, click the Table tab 
and select the settings you want.

Table tab Description

Display in module 
main column only

Clear this check box to display the table across all the 
columns in the module, not just in its main column.

Preferred Width If you want to specify a cell width, select the Preferred 
Width check box, then enter the cell width in pixels, or 
use the slider bar to change the width of all the cells in the 
table graphically.
Note Pixels are used to measure distances on computer 

screens. Open Display in the Control Panel, then 
the Settings tab to find out how big your screen is 
in pixels.

Alignment Select the alignment of text within the cells.

Change bars Show or hide change bars for the cells.

Link arrows Show or hide link arrows in the cells.
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4. To change the settings for every cell in the current row, click the Row tab 
and select the settings you want. 

5. To change the settings for every cell in the current column, click the 
Column tab and select the settings you want. 

Row tab Description

Preferred Width If you want to specify a cell width, select the Preferred 
Width check box, then enter the cell width in pixels, or 
use the slider bar to change the width of the cells in the 
selected row graphically.
Note Pixels are used to measure distances on computer 

screens. Open Display in the Control Panel, then 
the Settings tab to find out how big your screen is 
in pixels.

Alignment Select the alignment of text within the cells.

Change bars Show or hide change bars for the cells.

Link arrows Show or hide link arrows in the cells.

Column tab Description

Preferred Width If you want to specify a cell width, select the Preferred 
Width check box, then enter the cell width in pixels, or 
use the slider bar to change the width of the cells in the 
selected row graphically.
Note Pixels are used to measure distances on computer 

screens. Open Display in the Control Panel, then 
the Settings tab to find out how big your screen is 
in pixels.

Alignment Select the alignment of text within the cells.

Change bars Show or hide change bars for the cells.

Link arrows Show or hide link arrows in the cells.
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6. To change the settings for the current cell only, click the Cell tab and select 
the settings you want.

7. To change the borders of the table, click the Borders tab and select the 
settings you want.

8. To change the attribute that is displayed in the table cell, click the Attributes 
tab and select the attribute you want to display from the list, or click Object 

Cell tab Description

Preferred Width If you want to specify a cell width, select the Preferred 
Width check box, then enter the cell width in pixels, or 
use the slider bar to change the width of the selected cell 
graphically.
Pixels are used to measure distances on computer screens. 
Open Display in the Control Panel, then the Settings 
tab to find out how big your screen is in pixels.

Alignment Select the alignment of text within the cell.

Change bars Show or hide change bars for the cell.

Link arrows Show or hide link arrows in the cell.

Borders tab Description

None Click None if you don’t want any borders.

Box Click Box if you want a border around the outside edge 
only.

All Click All if you want border around all edges, including 
internal cells.

Custom Click Custom to set up custom borders, then in the 
Preview box, click the buttons to specify where you want 
borders.

Apply to Specify whether you want your settings to apply to the 
whole table, the current row, the current column, or the 
current cell. By default, settings are applied to the current 
cell.
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Heading and Object Text to display those attributes. By default, Object 
Heading and Object Text are displayed in table cells.

Note  If an attribute to display in table cells has been specified 
using the View > Tables Attributes option, that setting 
may have been set to override individual table settings.

If you want to display more than one attribute in table cells, you can use the 
DXL Attribute Wizard to create a DXL attribute that contains all the 
attributes you want to display. For more information about the DXL 
Attribute Wizard, see “Creating a new DXL attribute,” on page 119.

If you select a DXL attribute from the drop down list, the Edit using 
Wizard button becomes available. If the DXL attribute was created using 
the DXL Attribute Wizard, you can view and edit it by clicking this button to 
open the wizard.

Note  If the module is displayed in DOORSnet, the Object 
Heading and Object Text attributes are displayed 
regardless of what is selected on this tab.

9. Click OK.

10. Save the module to make the changes permanent (click File > Save).

Deleting, undeleting and purging tables
You can delete an entire table, or just a row, column or cell within the table.
Deleting a table cell doesn’t destroy any of it data. It simply marks the cell as 
deleted, and stops users from being able to access it. To destroy the table cell, 
you must purge it once you’ve deleted it. 
Purging deleted table cells removes them permanently from the database.
When you delete a table cell that has an in-link, the source object is automatically 
modified to remove the link, so you must have modify access to the source 
object.
You can’t delete the table cell if you don’t have modify access to the source 
object. This ensures that you don’t end up with a dangling link at the source 
object that goes nowhere. The link between the object and the table cell means 
there is some kind of dependency between them. You must resolve this 
dependency before you delete the table cell and lose the dependency.
To delete, undelete or purge a table cell, you must have delete access to the table 
marker object.
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Deleting, undeleting and purging tables

To delete all or part of a table:
1. Click the appropriate table cells:

• If you want to delete the entire table, click any cell in the table.
• If you want to delete a particular row or column, click any cell in that 

row or column.
• If you want to delete a particular cell, click that cell.

2. Click Table > Delete, then either Table or Row or Column or Cell.
3. Save the module to make the change permanent (click File > Save).

Note  Cells to the right of the deleted cells are shifted left.

To undelete all or part of a table:
1. In the module window, make sure that deleted items are being displayed.

If necessary, click View > Show > Deletions.

Deleted cells have red text, and their change bars are black .

2. Select the table cells you want to undelete:

• If you want to undelete the entire table, click any cell in the table.
• If you want to undelete a particular row or column, click any cell in that 

row or column.
• If you want to undelete a particular cell, click that cell.

3. Click Table > Undelete, then either Table or Row or Column or Cell.
4. Save the module to make the change permanent (click File > Save).

To purge all or part of a table:
1. In the module window, make sure that deleted items are being displayed.

If necessary, click View > Show > Deletions.

Deleted cells have red text, and their change bars are black .

2. Select the deleted table cells you want to purge:

• If you want to purge the entire table, click any cell in the table.
• If you want to purge a particular row or column, click any cell in that 

row or column.
• If you want to purge a particular cell, click that cell.

3. Click Table > Purge, then either Table or Row or Column or Cell.
A message is displayed asking you to confirm that you want to purge the 
cells.



Working with tables

174    Using Telelogic DOORS

4. Click Confirm.

5. Save the module to make the change permanent (click File > Save).

The cells are permanently removed from the database.
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12 Working with pictures and OLE objects
This chapter contains the following topics:

• Working with pictures

• Understanding OLE objects

• Activating and deactivating an OLE object

• Inserting a new OLE object

• Inserting an existing file as an OLE object

• Resizing OLE objects

• Cutting, copying and pasting OLE objects

• Editing OLE object properties

• Deleting OLE objects

• OLE objects and history

• Setting the OLE open limit

• Registered and Unregistered OLE Objects

• Actions affected by changes to the handling of OLE objects

• Actions unaffected by changes to the handling of OLE objects

Working with pictures
You can insert the following picture formats into DOORS objects:

• bmp 

• wmf

• jpg, jpeg, jfif, jpe

• png

• gif

• tif, tiff

• dib, rle, bmz

• emz

• wmz
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To insert a picture:
1. In the module window, select the appropriate object.

2. Click Insert > Picture.

3. In the File name box, type the name of the file that contains the picture, or 
use Browse to locate it.

4. If you’re creating a new object, specify where you want to create it:

• Click Same level to create it at the same level as, and immediately after, 
the current object. You need create access to the current object’s parent 
to do this.

• Click One level below to create it one level below the current object. 
You need create access to the current object to do this.

If the current object already contains a picture, you will see a Replace 
current picture option on the Insert Picture dialog box.

5. If you want to replace your picture, select the Replace current picture 
option.

6. Click OK.

Understanding OLE objects
You can insert OLE objects into any text attribute in DOORS. There is no limit 
to the number of OLE objects that can be inserted into a text attribute. Use 
OLE objects carefully, however. They can diminish the performance of your 
application.
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Activating and deactivating an OLE object

If an attribute is displayed in a traceability column in another module, any OLE 
objects that have been inserted in the attribute are also displayed.

Note  You cannot insert an OLE object into the Object Heading 
attribute.

You have several options when inserting an OLE object:

Activating and deactivating an OLE object
When you activate an OLE object, the application with which it is associated is 
opened. You can either edit the OLE object in a new window, or in-place in the 
formal module. 

Option Description

Insert as an icon The icon that is associated with the program is inserted. For 
example, if you insert a Word document as an icon, a Word 
icon is inserted in the attribute. You double-click the icon to 
activate the OLE object.

Insert as a picture The OLE object is displayed as it appeared when it was last 
saved. For example, if you insert an Excel chart as a picture, 
the chart is displayed in the attribute. You double- the picture 
to activate the OLE object.

Create New This inserts a blank OLE object of the type you select into the 
attribute. You can then double-click the OLE object to 
activate and edit it.

Create from File This lets you browse to and insert a file that already exists on 
your system.

Link or Embed If you create the OLE object from file you can either link it to 
the file on your system, or embed it. 
If you link an OLE object, the path to the file on your system 
is stored with the OLE object, so you have a hot-link between 
the file and the OLE object in DOORS. If someone 
subsequently updates the file, the change is reflected in 
DOORS.
If you embed an OLE object, you copy the file to the DOORS 
attribute. If someone subsequently updates the original file, 
the change is not reflected in the copy of it in DOORS.
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To activate an OLE object:
1. Double-click the attribute in which the OLE object has been inserted to 

enter in-place edit mode.

2. Select the OLE object.

The Edit menu now contains an additional option for the OLE object that 
you have selected. For example, if you select a Microsoft Visio OLE object, 
the last item on the Edit menu is VISIO object.

3. Click the OLE object name on the Edit menu, then either:

• Click Edit to edit the OLE object in the formal module window. The 
menus and toolbars of the application associated with the OLE object 
replace the DOORS menus and toolbars. To deactivate the OLE object, 
click on another DOORS object.

• Click Open to open the application associated with the OLE object in a 
new window, and edit the OLE object in that window. When you have 
finished editing, save and close the file. The OLE object in DOORS is 
updated with your changes.

Note  Menu items may vary depending on the type of OLE 
object that is selected. For example, if you select a 
PowerPoint Presentation, the additional option 
Show is displayed. Select this option to show the 
presentation. 

You can also double-click the OLE object in-place to activate it:

• If the OLE object is displayed as an icon, the application associated with the 
OLE object is opened in a new window. When you have finished editing, 
save and close the file. The OLE object in DOORS is updated with your 
changes.

• If the OLE object is not displayed as an icon, it becomes editable in the 
module window. The menus and toolbars of the application associated with 
the OLE object replace the DOORS menus and toolbars. To deactivate the 
OLE object, click on another DOORS object.

Note  Double-clicking on a PowerPoint presentation OLE object 
runs the presentation slide show. If you want to edit a 
PowerPoint presentation OLE object, you must use the Edit 
menu to activate it.



Using Telelogic DOORS           179

Inserting a new OLE object

Inserting a new OLE object
If you want to insert an OLE object into an attribute, you must have modify 
access to the attribute. 
To insert a new OLE object into a DOORS attribute:
1. In the module window, select the DOORS object into which you want to 

insert the OLE object.

2. Double-click the attribute into which you want the OLE object inserted, and 
position the cursor where you want the OLE object to appear.

3. Click Insert > OLE Object.
4. Select the type of OLE object you want to insert from the Object Type list.

Information about the type that is currently selected is displayed in the 
Result pane.

5. Select the Display as Icon check box if you want the OLE object to be 
displayed as an icon in DOORS. The icon that is currently associated with 
the selected object type is displayed below the check box. If you want 
DOORS to use a different icon and title, click Change Icon, and specify a 
new icon and title.

If you want the OLE object to display as editable information, leave the 
Display as Icon check box clear.

6. Click OK.

DOORS creates an empty OLE object of the specified type, embeds it in the 
current object, and then runs the appropriate program to let you edit the 
OLE object.

Inserting an existing file as an OLE object
You can use any of the following methods to insert an existing file into a 
DOORS attribute as an OLE object.

• Click Insert > OLE object on the formal module menu bar.

• Copy and paste, using the Paste Special option in DOORS.

• Drag and drop. You cannot link the OLE object if it is inserted using drag 
and drop.

To insert an existing OLE object using the Insert > OLE object menu 
option:
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1. In the module window, select the DOORS object into which you want to 
insert the OLE object.

2. Double-click the attribute into which you want the OLE object inserted, and 
position the cursor where you want the OLE object to appear.

3. Click Insert > OLE Object, and select the Create from File radio button.

4. Enter the path to the file you want to insert, or click Browse to select it.

5. Select the Link check box to link the OLE object to the source file, or clear 
it to embed the OLE object in the DOORS module. For information on 
linking and embedding files see “Understanding OLE objects,” on page 176.

6. If you want the OLE object to be displayed as an icon in DOORS, select the 
Display as Icon check box. The icon that is currently associated with the 
selected object type is displayed below the check box. If you want DOORS 
to use a different icon and title, click Change Icon, and specify a new icon 
and title.

If you want the OLE object to display as editable information, leave the 
Display as Icon check box clear.

7. Click OK.

The file is inserted into the current object as an OLE object.

To insert an existing OLE object using copy and paste:
1. You can either:

• In the Windows Explorer, select the file you want to insert and copy it
• Open the file and select the contents that you want to insert and copy 

them

2. In the module window, select the DOORS object into which you want to 
insert the OLE object.

3. Double-click the attribute into which you want the OLE object inserted, and 
position the cursor where you want the OLE object to appear.

4. Click Edit > Paste Special.
5. Select Paste to embed the OLE object in the DOORS module, or Paste 

Link to link the OLE object to the source file. For information on linking 
and embedding files see “Understanding OLE objects,” on page 176.

6. If you want the OLE object to be displayed as an icon in DOORS, select the 
Display as Icon check box. The icon that is currently associated with the 
selected object type is displayed below the check box. If you want DOORS 



Using Telelogic DOORS           181

Resizing OLE objects

to use a different icon and title, click Change Icon, and specify a new icon 
and title.

If you want the OLE object to display as editable information, leave the 
Display as Icon check box clear.

7. Click OK.

The contents of the clipboard are pasted into the attribute as an OLE object.

Note  Some OLE objects can be pasted but not activated. For 
example, if you copy a picture from a browser window and 
paste it into DOORS, it is displayed but it cannot be 
activated. These metafiles are static OLE objects.

To insert an existing OLE object using drag and drop:
1. In the module window, select the DOORS object into which you want to 

insert the OLE object.

2. Double-click the attribute into which you want the OLE object inserted, and 
position the cursor where you want the OLE object to appear.

3. Using the Windows Explorer, navigate to the file you want to embed, select 
it, then drag it onto the target object in DOORS.

The file is embedded in the current object as an OLE object.

Note  You cannot link the OLE object if it is inserted using drag 
and drop.

Resizing OLE objects
If an inserted OLE object is too large to fit in the column into which it has been 
inserted, you can resize it to fit the column. The object will resize itself 
proportionally, taking its width from the width of the column.
You can choose to change either:

• The size of an OLE object or objects in a single object

• The size of all of the OLE objects in the module

To resize an OLE object or objects in a single object:
1. Select the object containing the OLE object or objects you want to resize.

2. Click Tools > Support Tools > Set OLE Size For Current Object.
The OLE object or objects are resized to fit in the column.



Working with pictures and OLE objects

182    Using Telelogic DOORS

To reset the OLE object or objects to their original size, select the object 
containing the OLE object or objects, then click Tools > Support Tools > 
Reset OLE Size In Current Object.
To resize all the OLE object in a module:
1. Select any object in the module.

2. Click Tools > Support Tools > Set OLE Size In All Objects.

All the OLE objects in the module are resized to fit in the column.
To reset the OLE objects to their original size, select any object in the module, 
then click Tools > Support Tools > Reset OLE Size In All Objects.

Cutting, copying and pasting OLE objects
You can cut and paste or copy and paste OLE objects.
The following steps describe how to do this:
1. In the module window, select the DOORS object containing the OLE object 

you want to cut or copy.

2. Double-click the attribute containing the OLE object to enter edit mode, 
and select the OLE object.

3. Select Cut or Copy.

4. Double-click the attribute you want to paste to and right-click Paste to 
insert the OLE object.

You can also use cut or copy if you want to paste OLE objects from DOORS to 
external applications.

Note  You need to be in in-place edit mode to insert an OLE 
object. Consequently, you cannot cut and paste OLE objects 
between different attributes. You can, however, cut and paste 
within the same attribute.

Editing OLE object properties
You can change the properties of an OLE object using the OLE Object 
Properties. The options that are available depend on whether the OLE object is 
embedded or linked.
Editing the properties of an OLE object:
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Editing OLE object properties

1. In the module window, select the DOORS object containing the OLE object 
whose properties you want to edit, and double-click to enter in-place edit 
mode.

2. Select the OLE object, then click Edit > OLE Object Properties.
3. The General tab displays the file information for the OLE object. 

The Convert button is unavailable.

4. Use the View tab to change the appearance of the OLE object in the 
module.

5. Use the Link tab to edit the link properties of the OLE object.

Note  This tab is not present if the selected OLE object is 
embedded in the module. For information on embedding 
and linking OLE objects see “Understanding OLE objects,” 
on page 176.

The link tab displays:

• The path to the linked file on your system

Field Description

Display as editable 
information

If the OLE object is currently displayed in the 
module as an icon, select this button to display it as 
editable information. This allows you to see the 
contents of the file displayed in the module. You 
double-click in the contents of the file to activate the 
OLE object.

Display as icon If the OLE object is currently displayed in the 
module as editable information, select this button to 
display it as an icon. You double-click the icon to edit 
the OLE object.

Change icon If the OLE object is displayed as an icon, click this 
button to change the icon or the icon’s label.

Scale This field is unavailable. If you want to resize an OLE 
object, select the OLE object and drag the sizing 
handles.

Relative to original size This field is unavailable.
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• The date and time that the file was last updated

The following options are also available:

Deleting OLE objects
There are two ways to delete an OLE object. You can:

• Delete an OLE object as well as the DOORS object that contains it.

Select the object, then either:

• Press DELETE.
• Click File > Delete.

You must have delete access to the object to do this.

• Delete an OLE object but not the DOORS object that contains it.

a. Select the object then double-click the attribute where the OLE object 
has been placed to enter edit mode. 

b. Select the OLE object you want to delete. It will become highlighted.

c. Press DELETE.

You must have modify access to the object to do this.

Use To

Automatically or 
Manually

This functionality is not supported in DOORS. Linked OLE 
objects in DOORS are automatically updated regardless of 
this setting.

Change Source Manually update the path to a file that has been moved. You 
can also use this button if you want to replace the existing 
OLE object.
Click the button, navigate to the new file location, select the 
file and click OK. The path is updated.

Open Source Open the source file.

Update Now Redraw the OLE object.

Break Link This functionality is not supported in DOORS. Clicking Break 
Link does not remove the link between the OLE object and 
the source object. If you want to remove the link from the 
OLE object, delete it and insert it again without linking.
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OLE objects and history
OLE objects can now be saved as part of a history record. This allows users to 
compare a current OLE object (or set of OLE objects) with that which preceded 
it.
Using this setting can have a major effect on performance and disk space 
requirements, so by default it is switched off.
To enable it:
1. Right-click on Database , and select Properties.
2. In the OLE in history section, select the Save OLE objects in attribute 

history option.

Now when you view the history of a particular object, you can determine how an 
OLE object has changed over time. 

Setting the OLE open limit
When you open a module, the OLE objects in the module are pre-loaded from 
the database into memory. By default, up to five OLE objects can be pre-loaded 
into memory at any one time.
The demands of these OLE objects on memory can result in poor performance. 
To improve performance, you can reduce the number of OLE objects that are 
pre-loaded.
To do this:
• Edit the oleopenlimit entry in your registry.

The default value of oleopenlimit is 5. A value of 0 means there is no limit.

Registered and Unregistered OLE Objects
There have been problems with data loss related to OLE objects in previous 
versions of DOORS. 
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The following sections describe how DOORS now behaves when it encounters 
OLE objects. The terminology used is explained in the table below.

Actions affected by changes to the handling of OLE objects
DOORS now displays warnings if objects containing unregistered OLE objects 
are accessed. The warnings and behavior for each action that is affected are listed 
below.

OLE Type Definition

Registered OLE objects If the application associated with an OLE object in 
DOORS is installed on the DOORS client, the OLE 
object is registered. It can be opened from DOORS 
and edited. 
For example, if a DOORS module you are working 
on contains a Word document, and you have 
Microsoft Word installed on your machine, that Word 
document is a registered OLE object.

Unregistered OLE objects If the application associated with an OLE object in 
DOORS is not installed on the DOORS client, the 
OLE object is unregistered. It cannot be opened 
from DOORS and edited. For example, if a DOORS 
module you are working on contains a Word 
document and you do not have Microsoft Word 
installed on your machine, the Word document is an 
unregistered OLE object.

Static OLE objects A static OLE object is a picture which cannot be 
edited regardless of what applications you have 
installed on your machine. For example, if you take a 
screenshot and paste it into a DOORS object, it is a 
static OLE object.
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Edit in-place or using the object properties sheet.

Caution  If you edit an object that contains an unregistered OLE 
object using the change proposal system, and that change 
is approved and applied, the unregistered OLE object is 
converted to a static OLE object and data contained in 
that OLE object is lost. See “Change Proposal System,” 
on page 190 for more information.

Action Result

Double-click on an 
unregistered OLE object

The following message is displayed:

Attempting to activate an unregistered OLE object 
does not cause any data loss.

Edit text surrounding an 
unregistered OLE object

If you edit text contained in the same attribute as an 
unregistered OLE object, the OLE object is 
unaffected. It remains unregistered on your machine, 
but can be accessed on machines that have the 
associated application installed.
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Copy and paste in-place or using the object properties sheet

Cut and paste in-place or using the Object properties sheet

Action Result

Copy an unregistered OLE 
object on its own

The original OLE and the copied OLE remain 
unregistered and can be accessed on machines that 
have the associated application installed.

Copy an unregistered OLE 
object and some 
surrounding text

The following warning is displayed:

When you click OK the copy operation is reversed 
and the data is unaffected.

Copy a selection of OLE 
objects, where one or more 
of them are unregistered.

The following warning is displayed:

When you click OK the copy operation is reversed 
and the data is unaffected.

Action Result

Cut an unregistered OLE 
object on its own

When you paste the OLE object, it remains 
unregistered and can be accessed on machines that 
have the associated application installed.
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Cut an unregistered OLE 
object and some 
surrounding text

The following warning is displayed:

If you click Yes, the unregistered OLE object is 
converted to a static object when it is pasted, and 
information held in the OLE object is lost.
If you click No, the cut operation is reversed and the 
data is not affected.

Cut a selection of OLE 
objects, where one or more 
of them are unregistered.

The following warning is displayed:

If you click Yes, any unregistered OLE objects are 
converted to static OLE objects when they are 
pasted, and information held in the OLE objects is 
lost.
If you click No, the cut operation is reversed and the 
data is not affected.

Action Result
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Copy or cut a DOORS object containing an unregistered OLE object in an attributes

Note  This is the case for all methods of copying and cutting 
objects within a module, i.e using keyboard shortcuts, drag 
and drop or the menu items.

Copy objects using the Object Copier

If you copy an object that contains one or more unregistered OLE objects to 
another module using the Object Copier (Tools > Functions > Copy Objects), 
the object and OLE objects are copied successfully and no data is lost.

Change Proposal System

Submit a change proposal

If you select an object that contains an unregistered OLE object and click Tools 
> Change Proposal System > Submit Change Proposal, the following 
message is displayed:

You can continue, and submit a change proposal. However, if your change 
proposal is approved and applied, any unregistered OLE objects that are held in 
the object are changed to static OLE objects and data stored in them is lost.

Action Result

Copy or cut and paste an object 
containing an unregistered OLE object

The OLE in the original object, and in 
the copied or moved object remains 
unregistered and can be accessed on 
machines that have the associated 
application installed
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Review Change Proposals

If you change the status of a change proposal made against an object that 
contains an unregistered OLE object in one of its attributes, the following 
message is displayed:

You can continue, but if you approve a change proposal and that change 
proposal is then applied, any unregistered OLE objects that are held in the object 
are changed to static OLE objects and data stored in them is lost.

Apply Change Proposals

If you apply a change proposal that has been made against an object that 
contains in one of its attributes an unregistered OLE object, the following 
message is displayed:

Applying change proposals for objects that contain one or more unregistered 
OLE objects in any of their attributes results in the OLE object being converted 
to a static OLE object. All data held in the OLE object is lost.

DXL
You cannot manipulate unregistered OLE objects using DXL.

History
If you double-click an unregistered OLE object in the History window a 
message is displayed stating that the object is a static OLE object. This message 
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is incorrect - if an OLE object was unregistered when it was current, it remains 
unregistered in the history. If you restore the history entry containing that OLE 
object, it is restored as an unregistered OLE object and no data is lost.

Split Object

If you attempt to split an object that contains an unregistered OLE object, the 
following error is displayed:

If you click Confirm, the object is split, and the unregistered OLE object is 
converted to a static OLE object. Data held in the OLE object is lost. 
If you click Cancel, the data is unaffected, and the OLE object can be accessed 
by machines that have the associated application installed.

Export data from DOORS
If you export a module from DOORS to any other application, unregistered 
OLE objects are exported as pictures. The unregistered OLE objects in the 
DOORS module are unaffected by the export and no data is lost in DOORS.
If DOORS encounters unregistered OLE objects during an export to another 
application, a message is displayed to inform the user that the exported OLE 
objects will be converted to pictures:
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If the application to which you want to export the module supports OLE, a new 
check box is displayed on the Export dialog box. For example, the Export to 
Word dialog box now looks like this:

The Issue a warning when an unregistered OLE Object is exported as a 
picture check box is selected by default. Clear the check box if you do not want 
to receive warnings during export.

Paste unregistered OLE objects into other applications

If you cut or copy an unregistered OLE object to the clipboard, then paste it into 
another application, the OLE Object is pasted as a picture, and data contained in 
the OLE object is lost. If the OLE object is copied, the original remains 
unregistered and no data is lost in DOORS.
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Spelling checker

You cannot edit text in the Check Spelling window if the object contains an 
unregistered or static OLE object. A message is displayed on the Check 
Spelling window if this is the case, as shown in the following screenshot:

You can use Replace to correct spelling mistakes, and the unregistered OLE 
object is unaffected.

Actions unaffected by changes to the handling of OLE objects
The following areas of functionality were unaffected in previous versions of 
DOORS by the data loss problem related to OLE objects. They remain 
unchanged.
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Merge Objects

When you merge objects in DOORS, OLE objects are not included in the 
resulting object. This is the case whether the OLE objects are registered, 
unregistered or static. The following message is displayed when you merge 
objects containing OLE Objects:

When you merge objects, the OLE objects in the original objects are unaffected, 
and no data is lost.

Create a Baseline
Baselining a module that contains unregistered OLE objects does not affect the 
OLE objects. They remain unregistered in both the baseline and the current 
version of the module. No data is lost.

Copy a baseline
When you copy a baseline of a module that contains unregistered OLE objects, 
the new module contains the unregistered OLE objects, and no data is lost. The 
data can be accessed on machines that have the associated application installed.

Clone a module

The clone module functionality is not designed to clone OLE objects, so any 
unregistered OLE objects in the original module are unaffected and no data is 
lost. This is the case in all previous versions of DOORS and there is no change 
in functionality in this patch.

Cut or Copy modules in the database explorer
When you copy and paste a module that contains unregistered OLE objects in 
the DOORS database explorer, the OLE objects are copied successfully and no 
data is lost.
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Import data to DOORS

You cannot import an unregistered OLE object to DOORS. This is the case in 
all previous versions of DOORS and there is no change in functionality in this 
patch.

Archive and restore
Unregistered OLE objects are unaffected by archive and restore operations, and 
no data is lost

Partition/Rejoin
Unregistered OLE objects are unaffected by partition/rejoin operations, and no 
data is lost

Find and Replace

Edits made to text contained in the same attribute as unregistered OLE objects 
during Find and Replace operations have no affect on unregistered OLE objects 
and no data is lost.

Linking
Creating, editing and navigating links does not affect unregistered OLE objects.
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13 Understanding access rights
This chapter contains the following topics:

• About access rights

• About groups

• How group rights and user rights interact

• About inheritance

• Inheritance example

• Propagating extra access rights with create

Note  You can skip this chapter if you’re only going to use DOORS 
to look at data, and you don’t want to create or edit data. You 
can also ignore this chapter if your site isn’t using access 
controls; that is, if your database is set up to allow everyone 
full access to all data.

About access rights
Access rights control who can do what to each item of data in your DOORS 
database. DOORS provides five access rights.

For example, to be able to see a folder, you need read access to it. 
You have read access to everything you can see in the DOORS Explorer. If you 
can see a project, folder or module in the DOORS Explorer, then you have read 
access to it.
Create access lets you create new things one level down in the database tree:

You need this access right To

Read (R) Read (look at) data.

Create (C) Create new data.

Modify (M) Edit existing data.

Delete (D) Delete data.

Admin (A) Change the access rights for data.
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• If you have create access to a project or folder, you can create new projects, 
folders and modules in the project or folder.

• If you have create access to a module, you can create new top-level objects in 
the module.

• If you have create access to an object, you can create new objects one level 
below the object.

Modify access lets you edit existing data. For example, if you have modify access 
to an object, you can edit the object and change the values of its attributes. To be 
able to delete something, you need delete access to it. And to be able to change 
the access rights for something, you need admin access to it.

Full access and no access 
If you have full access to something, it means you have all five access rights to 
it. Full access is just a shorthand for the five access rights.
If you have no access to a project, folder or module, you can’t see the project, 
folder or module, so you don’t even know it exists.

If you have read access to a module, it doesn’t mean that you can see all the data 
in the module. You may have no access to some of the objects or attributes in the 
module. When you have no access to an object or attribute, you see Read 
Locked Data instead of the object or attribute, as shown in the previous picture.
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About groups
Often you need to allow a group of users the same access to a particular piece of 
data. For example, you may want all the engineers in your company to have full 
access to a particular module.
The Database Manager creates the Engineering group, which contains all the 
engineers in your company. Then you can quickly set up the access rights for the 
module. Instead of having to set up the access rights for each user individually, 
you set up the access rights for the whole Engineering group.
And when a new engineer joins your company, the Database Manager just adds 
them to the Engineering group, and they automatically get access to your 
module.

Each user can be in lots of different groups. For example, Sue is in the 
Engineering group and the Boston group.
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How group rights and user rights interact
Let’s look at the access rights for the car project’s System Requirements module.

There are three entries:

• At the top of the list there is an entry for an individual user, Tony Hill. He 
has read access (R).

• Then there is an entry for the Review group. It has full access (RMCDA).

• At the bottom of the list is Everyone else, with no access (None).

The following picture shows how the different types of entry for individual 
users, groups, and everyone else interact. It shows how to figure out what access 
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rights you have to a piece of data. It assumes that you have read access to the 
data, otherwise you can’t see it and so you can’t click its Access tab.

In the previous example, there is an entry for John, so John gets the access rights 
defined in that entry (read access).
John is also in the Engineering group, which has full access (RMCDA). But 
because John has his own entry, he doesn’t get the access rights defined for the 
group.
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The other users in the Engineering group, Sue and Mark, don’t have their own 
entries. So they get the access rights defined for the Engineering group—full 
access.

Anne and Richard don’t have their own user entries and they aren’t in a group 
that has an entry, so they get the access rights for Everyone else—no access. 
Anne and Richard can’t even see the module.

When you're in several groups

If you don’t have your own entry and you’re in two or more groups that have 
entries, you get the access rights for all your group entries combined. 
For example, if one of your groups has read and modify access, and another has 
read and create access, you get read, modify and create access.

About inheritance
To make it easy to set up access rights, DOORS provides a powerful inheritance 
mechanism.
Whenever you create anything, by default it automatically inherits its access 
rights from its parent.
For example, when you create a top-level object in the car project’s System 
Requirements module, by default the new object inherits the same access rights 
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as its parent, the module. If you click the Access tab on the object’s properties 
sheet, you’ll see that it has exactly the same access rights as the module.

The Inherit from parent check box is selected, and the entries in the list of 
access rights are unavailable. You can see what access rights the object is 
inheriting from the module, but you can’t edit them.
To turn inheritance off, clear the Inherit from parent check box. Now the 
access rights are available—you can edit them and set up whatever access rights 
you want the object to have.
Although the object is no longer inheriting access rights from its parent, 
whenever you create new objects under it, the new objects initially have 
inheritance turned on. By default, children automatically inherit the access rights 
you set up for their parent.
If you change the access rights for the parent, this change automatically applies 
to all its children, grandchildren, and so on who are inheriting their access rights 
from the parent.
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The change ripples all the way down through the database tree, but it doesn’t 
affect any items that have inheritance turned off, or their direct descendants.

In this picture a tree of items have a common ancestor A. The Inherit from 
parent check box shows which items have inheritance turned on. All the items 
have inheritance turned on except A and D.
The red items inherit their access rights from A. The green items inherit access 
rights from D.
If you change A’s access rights, the change automatically applies to the other red 
items (B, C, E and H). The change ripples down through the tree to all items that 
inherit their access rights from A.
Similarly, if you change D’s access rights, the change automatically applies to the 
other green items (F and G).

Inheritance example
Let’s look at how you might use access inheritance.
Say you want everyone in the Engineering group to have full access to all the data 
in the car project:

• You set up the access rights for the car project. You add an entry to give the 
Engineering group full access to the project.
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• Inheritance is turned on whenever you create new data in the project. So the 
new data inherits the access rights for the Engineering group, which gives 
the group full access to the data.

Later, you change your mind and decide that you want John to have full access to 
the data in the car project, and the rest of the group to have only read access. 
So you change the access rights for the car project:

• You change the Engineering group entry to read access.

• You add an entry for John, giving him full access.

These changes automatically apply to all the data in car project because all the 
data has inheritance turned on.
But Sue and Mark are writing the Design module, so you want to give them full 
access to that one module. Easy. You just turn inheritance off for the Design 
module, and add an access entry for Sue that gives her full access to the module, 
and an access entry for Mark that gives him full access to the module.

Propagating extra access rights with create
Let’s look at another scenario:

• You want to let Mark create modules in a folder. So Mark needs create access 
to the folder.

• You also want Mark to be able to delete the modules he creates in the folder, 
but you don’t want him to be able to delete the folder itself.

You can’t do this using standard inheritance.
One way around this would be to turn inheritance off for every module that 
Mark creates in the folder, and then set up the access rights for these modules to 
give Mark delete access to them. That would be very time consuming.
So DOORS lets you treat create access in a special way. You can choose to 
propagate extra access rights with create access.
This option is only available if the item has inheritance turned off. In our 
example, the folder must have inheritance turned off.
You can choose which extra access rights to propagate with create access:

• Modify (M)

• Modify and delete (MD)

• Modify, delete, and admin (MDA)
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The extra access rights are not specific to a particular user or group. They are 
propagated with every access rights entry that includes the create access right.
For example, item X has four access rights entries, two of which (for Anne and 
Engineering) include the create access right.

You decide to propagate modify, delete and admin (MDA) access with create. 
This means that the access rights entries for items that inherit their access rights 
from X look like this:

The only entries affected are the ones that included the create access. They gain 
modify, delete and admin (MDA) if they don’t already have them:

• The entry for Anne gains MDA.

• The entry for Engineering gains A.

As always with access rights, the extra access rights are only propagated to 
descendants (folders, projects, modules or objects) that have inheritance turned 
on.

Name Access rights

Anne RC

John R

Engineering RCMD

Everyone else RM

Name Access rights

Anne RCMDA

John R

Engineering RCMDA

Everyone else RM
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14 Managing folders
This chapter contains the following topics:

• Creating a folder

• Controlling access to a folder

• Editing folder properties

• Deleting, undeleting and purging a folder

• Managing locks

For information on how to convert a folder to a project, and vice versa, see the 
DOORS online help or Managing Telelogic DOORS on the Telelogic Lifecycle 
Solutions DVD.

Creating a folder
To create a folder:
1. In the left pane of the DOORS Explorer, select the folder or project in 

which you want to create the new folder. This is the new folder’s parent.

You must have create access to the parent.

2. Click File > New > Folder.
3. In the Name box, type the name of the new folder.

The name is case-sensitive. For example, the names Myfolder and 
MyFOLDER are different.

The name must be unique within the parent project or folder. All the 
projects, folders and modules in the parent must have different names.

The name can contain the following characters:

• Alphanumeric characters (letters of the alphabet and numbers)
• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

4. If you want to enter additional information about the new folder, type it in 
the Description box.

5. Click OK.
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The folder is created. It inherits its access rights from its parent. 

Note  If you receive the error Cannot create this Folder: Lock 
request timed out when you try to create the folder, wait a 
moment, then try again. This error is generated if another 
DOORS user is performing a paste operation when you click 
OK to create the folder.

Controlling access to a folder
To change the access rights for a folder, you must have admin access to the 
folder.
To change the access rights for a folder:
1. Select the folder in the DOORS Explorer, then right-click Properties.

2. Click the Access tab.

The current access rights for the folder are displayed.

You need this 
access right

To...

Read (R) See the folder. If you don’t have read access, the folder is 
not displayed in your DOORS Explorer.

Create (C) Create new modules, folders and projects in the folder.
Paste existing modules, folders and projects into the 
folder.

Modify (M) Change the name or description of the folder.

Delete (D) Delete, undelete and purge the folder.
Cut the folder to the DOORS Explorer clipboard.

Admin (A) Change the access rights for the folder.
Change the default linkset pairings for links from 
top-level modules within the folder.
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3. Make the changes you want.

4. Click OK.

Access tab Description

Inherit from parent Select this check box if you want the folder to inherit its 
access rights from the project or folder that it’s in. If it’s a 
top-level folder, it inherits its access rights from the 
database root.
When this check box is selected, the list of access rights is 
unavailable, and shows what access rights the folder is 
inheriting.

Add To a new entry to the list of access rights:
a. Click Add.

The Add Access window is displayed.
b. In the Name box, select the name of the user or 

group that you want to add an entry for. 

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select 
the entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit.

The Edit Access window is displayed.
b. Select the access rights you want to give them, then 

click OK.

Additional access Select the additional access rights that you want to 
propagate with create access.
The additional rights are propagated to the items in the 
tree below the folder that inherit their access rights from 
it.
For more information, see the section topic on 
propagating extra access rights in Getting started with 
Telelogic DOORS, which is available on the Telelogic 
Lifecycle Solutions DVD.
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Editing folder properties
To edit the properties of a folder, you must have modify access to the folder.
To edit the properties of a folder:
1. Select the folder in the right pane of the DOORS Explorer, then right-click 

Properties.

2. Select the options you want. 

For information about the options on the Access tab, see either:

• The help for the Access tab (click the Access tab, then click Help).
• “Controlling access to a folder,” on page 208.

3. Click OK.

Deleting, undeleting and purging a folder
Deleting a folder doesn’t destroy any of the data in the folder. It simply marks 
the folder as deleted, and stops users from being able to access its data. To 
destroy the data, you must purge the folder once you’ve deleted it. 
Purging deleted folders removes them permanently from the database.

General tab Description

Name The name of the folder.
You can’t change the name of a folder if any of the folders, 
projects or modules in the tree below it are open.
If the folder contains a link module, and the link module is 
named in any formal module filter that has been saved as a 
view, no objects will be displayed in the view if the folder 
name is changed.

Description Additional information about the folder.

Type The type of item whose properties are being displayed. In this 
case the type is Folder and it can’t be edited.

URL The URL of the folder.

Copy URL Copies the URL to the system clipboard. For more 
information about DOORS URLs see “Understanding 
DOORS URLs,” on page 259.
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You can’t delete a folder if the folder or anything in it is open.
In the DOORS Explorer, the folder or project selected in the left pane is open 
and has an open folder icon  or an open project icon . Its parent folder or 
project is also open, and so are all the folders and projects above it in the 
database tree, although they don’t have open folder or open project icons.
When a module is open, all the folders and projects above it in the database tree 
are also open.
To delete, undelete or purge a folder, you must have delete access to the folder 
and to all the folders, projects and modules in it. 
To delete a folder:
• In the right pane of the DOORS Explorer, select the folder you want to 

delete , then click File > Delete.

You can also click Delete  on the Project toolbar, right-click Delete or 
press DELETE.

To undelete a deleted folder:
1. In the DOORS Explorer, make sure that deleted items are being displayed.

If necessary, click View > Show Deleted.

2. Select the folder you want to undelete , then either click File > 
Undelete or right-click Undelete.

To purge a folder:
1. In the DOORS Explorer, make sure that deleted items are being displayed.

If necessary, click View > Show Deleted.

2. Select the folder you want to purge , then click File > Purge.

A message is displayed asking if you really want to purge the folder.

3. Click Yes.

The folder and all the data in it are permanently removed from the database.

Managing locks
If your DOORS session ends abnormally, for example, if your computer crashes:

• Any modules that you were editing are locked.

No-one can edit these modules until they are unlocked. They can open them 
in read only mode, but not in shareable or exclusive edit mode.

• Projects and folders you had open are locked. 
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No-one can move, rename or delete these projects or folders until they are 
unlocked.

To unlock projects, folders and modules:
1. In the DOORS Explorer, click Tools > Manage Locks.

A list of the items that are currently locked is displayed.

The list does not include the locks associated with your current DOORS 
session, because you must not delete these locks. If you deleted them you 
would corrupt your data.

If you’re a Standard user, you only see the items that you locked in previous 
DOORS sessions. If you’re a Database Manager or a Custom user with the 
power to manage the database, items locked by all database users are 
displayed.

If you have a chain of locks from the root of the database, you only see the 
lock at the end of the chain.

Note  By default, the Current folder only check box is 
selected. This shows locks in the current folder that have 
been partially removed, and that are not displayed 
otherwise. If you want to see all the locks in the database, 
clear this check box.

2. Click Refresh to refresh the display.

3. Select the items you want to unlock, then click Unlock.

Note  When you open a module, you lock all the folders and 
projects above the module in the database tree. But on 
this screen, you only see the lock for the module, not the 
associated locks in the tree above it. When you unlock 
the module, you also remove any associated locks that 
aren’t needed by other data that is locked elsewhere in 
the database tree. 

A message is displayed asking if you really want to unlock the items.

4. Click Yes.

5. Click Close.
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15 Using links
This chapter contains the following topics:

• Understanding links

• Understanding external links

• Using link arrows

• Creating links

• Creating external links

• Clearing the link start

• Understanding link modules and linksets

• Controlling access to a link module

• Understanding how copy and move affect links

• Editing links

• Creating link attributes

• Deleting links

• Using the create links tool

• Linking by attribute

• Understanding link module defaults

• Creating default linkset pairings

• Control on links for process management

• Showing link module information

• Creating a link module

• Creating a linkset

• Deleting a linkset

Understanding links
DOORS lets you link together related information. You can follow links by 
simply clicking them.
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For example, you can link a user requirement to the design features that fulfill 
that requirement. And you can link the design features to the tests that are 
carried out to verify the design features.
Links give you traceability. You can check that what you’re building satisfies your 
user requirements.
You can follow links in both directions. For example, if a test fails, you can find 
out which requirements are affected by tracing the links from the test back to the 
design features, and from the design features back to the requirements.
Links allow you to effectively manage change. You can quickly trace the impact 
of a change to a single piece of data on the rest of your system.
For example, the engineering department tell you that they can’t deliver the 
solar-powered battery you were expecting. You can trace the links from the 
battery object back to the requirements that depend on it, and forward to the 
other features of the car that depend on having a solar-powered battery. You can 
quickly see the full impact of not having a solar-powered battery. You can make 
an informed decision about whether to just use a conventional battery or 
whether to invest more money and resources to help deliver a solar-powered 
battery.

Understanding external links
You use external links to create a link from a DOORS object to an entity or 
resource that is outside the current DOORS database. For example, you might 
create an external link to a website, or to a different DOORS database.
External links can be marked as URLs. Where an external link is a URL, it is 
treated like a hyperlink and is opened by the default browser. 
If an external link is not marked as a URL, nothing happens when the external 
link is selected.

Note  If you are running DOORS through Citrix, the application 
referenced by the external link must also be running through 
Citrix or the external link will not work.

An external link is a one way link to the resource it references. No corresponding 
link is created in the linked resource, although you can create a link in the 
resource back to the DOORS object by inserting the DOORS URL in the 
resource. For information on DOORS URLs see “Understanding DOORS 
URLs,” on page 259.
External links do not use link modules. All of the information about the link is 
stored with the external link. External links are not a property of the object to 
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which they are attached. They behave as separate objects, and can have different 
attribute values than the objects to which they are attached.

Using link arrows
Linked objects have link arrows in the main column:

• Out-links have red link arrows 

• In-links have yellow link arrows 

Some module baselines may display link arrows that look like this:  . These 
arrows signify links to and from modules that are not in the same baseline set 
definition, and are called echoed links. For more information on links in 
baseline sets, see Managing incremental development using Intelligent 
Traceability in the online help and in Managing Telelogic DOORS on the 
Telelogic Lifecycle Solutions DVD.

Note  You can turn off link arrows. If you can’t see any link arrows, 
select the module’s view settings. Click View > Show > 
Link Arrows.

Roll over the link arrow to see how many in-links, out-links and external links the 
object has. Only information about modules that you have read access to is 
displayed.

Right-click the link arrow to see a pop-up menu that shows the names of the 
modules that contain the objects at the other end of the links. If the object has 
external links, they are listed in alphabetical order in the External Links 
submenu

For example, in this picture, the current object has out-links to 2 objects in the 
Functional Requirements module. This module isn’t open, so n: <unloaded> is 
displayed, where n is the object number. It also has one or more external links. If 
you roll over the External Links menu item, the description of each external 
link is displayed. External links are displayed in alphabetical order.
To follow a link, select it from the pop-up menu:
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• If the link is to a DOORS object, the module that it’s in is automatically 
opened if it’s not already open and the linked object is selected.

• If the link is an external link and the external link is a URL, the linked 
resource is opened by your default browser. If the external link is not a URL 
it cannot be opened, and a message is displayed.

Note  There is a limitation in the Microsoft richedit control which 
results in double-byte characters not being automatically 
highlighted when they are part of a URL. This affects 
external links in DOORS, so that if an external link URL 
contains double-byte characters it cannot be followed from 
DOORS by clicking the external link. You can copy and 
paste the URL into a browser window and the item referred 
to by the link will open as expected.

Creating links
You can only create a link if you have modify access to the source object and 
read access to the target object.
This topic describes two ways to create a link:

• Using drag-and-drop

• By explicitly defining the link start

Using drag-and-drop

You can use drag-and-drop to create links from multiple objects to a single 
object. You can’t use it to create links to multiple objects.
To create a link using drag-and-drop:
1. If the objects you’re creating links between are in different modules, open 

both modules and re-size their windows so that you can see both modules 
on your screen at the same time.

2. Select the objects that you want to link to or from and then, without 
releasing the mouse button, drag your cursor to the object you want to link.

If you want to link from multiple objects, don’t release the mouse button 
after making the multiple object selection. You lose your selection if you 
release the mouse button between selecting the objects and dragging the 
mouse.

3. Release the mouse button.

A pop-up menu is displayed. 
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• Click Make Link from Start to create links from the objects you 
selected

• Click Link > Make Link to Start to create links to the objects you 
selected

While you are dragging the mouse, the objects you selected in step 2 are 
highlighted with a pink background, showing that they are the link start.

If you select Cancel on the pop-up menu, the source objects stay pink.

Note  The quickest way to create a link between single objects, 
is to hold down both the SHIFT and CTRL keys when 
you release the mouse button over the target object in 
Step 3. This bypasses the pop-up menu and creates a link 
from the source object to the target object.

4. You may see a message saying that a default link module doesn’t exist. Click 
Yes to create it.

5. You may see a message saying that a linkset doesn’t exist. Click Yes to create 
it.

Explicitly defining the link start

To create a link by explicitly defining the link start:
1. Select the object or objects that you want to link to or from.

2. Click Link > Start Link.

If you selected multiple objects in Step 1, a message is displayed asking if you 
want to link to or from all of the selected objects or the current object only. 
Select the appropriate option.

The link start objects turn pink.

3. Select the object or objects that you want to link to or from.

• Click Link > Make Link from Start to create links from the objects 
you selected in step 1. You can also use the keyboard shortcut 
CTRL+SHIFT+F to create the links.

• Click Link > Make Link to Start to create links to the objects you 
selected in step 1. You can also use the keyboard shortcut 
CTRL+SHIFT+M to create the links.

If you selected multiple objects in Step 3, a message is displayed asking if you 
want to create links to all of the selected objects or to the current object 
only. Select the appropriate option.
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4. You may see a message saying that a default link module doesn’t exist. Click 
Yes to create it.

5. You may see a message saying that a linkset doesn’t exist. Click Yes to create 
it.

Creating external links
This section describes how to create external links that are URLs, for example 
links to web pages, or other DOORS databases. To create external links you 
must have create or modify access to the object.
There are two options for creating external links. You can use:

• The New External Link menu option to create external links to any URL.

• Drag-and-drop to create external links to formal module objects in other 
databases or to URLs that are displayed in Internet Explorer or Firefox 
browser windows. You cannot use drag-and -drop to create external links if 
you are in-place editing an object.

When you drag-and-drop a browser URL, you must drag the icon in the 
address bar, not the address itself, as shown in the following example:

Note  External links can also be used to facilitate integration 
between DOORS and other applications. This use of 
external links is not discussed here, but information and 
examples are available in a white paper, which can be 
downloaded from our website at 
https://support.telelogic.com/doors.

To create an external link using the menu option:
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1. Select the object that you want to contain the external link, and click Link > 
New External Link.

2. In the New External Link dialog box, type a Name and Description for 
the link. The description will be displayed in the External Link sub-menu 
when you right-click on the link arrow.

3. Enter the URL for the link in the Link Path box.

If you want to create an external link to an item in DOORS, right-click on 
the item you want to link to and click Copy URL. This copies the item’s 
URL to the system clipboard. You can then paste the URL into the Link 
Path box on the New External Link dialog box.

Note  The link path must be no more than 256 characters long. 
If the link path contains spaces or special characters, the 
upper limit is less than 256.

4. Select Open URL with default browser.
5. Select whether you want the link to be displayed as an in-link or out-link in 

the module. 

This does not affect the link behavior. In either case, when you select the 
link the resource referenced by it is opened by the default browser. No 
corresponding link is created in the resource.

6. Click OK.

You can create a corresponding link in the resource back to the DOORS object 
by copying the DOORS URL from the object properties sheet and pasting it 
into the resource. If the resource is a DOORS object, you can create a two-way 
link by creating an external link in that object.
To create an external link using drag-and-drop:
1. Drag-and-drop the DOORS formal module object, or the icon in the 

browser address bar to the object in which you want to create the external 
link.

2. Click Confirm.

The Edit External Link dialog box is displayed. The Name, Description 
and Link Path text boxes are populated with information about the object 
or URL. The external link is created as an out-link by default.

Note  The link path must be no more than 256 characters long. 
If the link path contains spaces or special characters, the 
upper limit is less than 256.
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3. Edit the Name, Description, Link Path and Direction if necessary, then 
click OK.

The external link is created, and the external link description is displayed in 
the External Link sub-menu when you right-click on the link arrow in the 
object.

Clearing the link start
The object or objects that are currently defined as your link start are highlighted 
with a pink background.
To clear the link start, either:
• Click Link > Clear Start.
• Define a new link start by selecting another object or objects.

You can do this in any formal module. You don’t have to do it in the one that 
contains the current link start.

Understanding link modules and linksets
Link modules store information about normal DOORS links.
Within each link module, the information is subdivided into linksets. Each 
linkset contains information about the links from one particular module to 
another.
For example, a link module has four linksets, which contain information about 
links for two modules, A and B:

Notice that the direction of the links matters. Links from module A to B are not 
stored in the same linkset as links from module B to A.

Note  External links are not stored in link modules.

This linkset Contains information about links from

A => B Module A to module B

B => A Module B to module A

A => A Module A to module A (links between objects within module A)

B => B Module B to module B (links between objects within module B)
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DOORS Links, the default link modules

By default, DOORS uses link modules called DOORS Links: 

• The first time you create a link from a particular module, DOORS offers to 
create a link module called DOORS Links in the same folder as the module 
(if it doesn’t already exist), and a linkset in DOORS Links.

• Next time you create a link from the module, DOORS uses the DOORS 
Links module in the local folder. It offers to create a linkset in DOORS 
Links if the linkset doesn’t already exist.

For more information, see “Understanding link module defaults,” on page 238.

Why use other link modules?

The DOORS defaults are designed to meet the needs of most users. Most users 
won’t even know what link modules and linksets they are using.
You should use other link modules if you want to use links to express different 
types of relationship, and you need to analyze your data according to the type of 
the link.
To do this, you create your own link modules, and use different link modules for 
different types of links. For example, you create a link module called Traceability 
Links for your traceability links, and a link module called Accounting Links for 
your accounting links.

You can then run traceability and other analyses on a particular type of link. You 
specify the link module you want to use for the analysis, so you only analyze links 
of the type that are stored in that link module.

Note  If you want to create links in this way, you must use the 
Links > Create Links option from your module, and the 
module must not be set up to use mandatory linkset pairings.
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Controlling access to a link module
To change the access rights for a link module, you must have admin access to the 
module.
To change the access rights for a link module:
1. You can change the access rights for a module from either the DOORS 

Explorer or the module window:

• In the DOORS Explorer, select the module then right-click Properties
• In the module window, click File > Module Properties

2. Click the Access tab.

The current access rights for the module are displayed.

If the module is partitioned in, the access rights associated with the partition 
are displayed. These describe the maximum access that any user has. They 
override the RCMD access rights displayed for users and groups.

For example, if a user’s entry says full access (RCMDA), but the module is 
partitioned in read only, in practice the user has only read (R) access.

You need this 
access right

To

Read (R) See the module. If you don’t have read access, the module 
is not displayed in your DOORS Explorer.

Create (C) Create linksets in the module.
Create attribute types and attribute definitions for the 
module.

Modify (M) Change the module’s name, description, or attribute 
values.
Create a link in the link module.

Delete (D) Delete, undelete and purge the module.
Delete a linkset from the module.
Cut the module to the DOORS Explorer clipboard.

Admin (A) Change the access rights for the module.
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3. Make the changes you want.

4. Click OK.

Understanding how copy and move affect links
This topic looks at what happens when you copy or move objects that have links.
When you use cut and paste:

• The first time you paste, you simply move the thing you’re pasting. 

• If you paste it again, you copy it. 

The following table describes the rules that apply when you copy or move 
objects by using either drag-and-drop or copy, cut and paste in the DOORS 
Explorer or module windows. External links are always copied because all of the 

Access tab Description

Inherit from parent Select this check box if you want the module to inherit its 
access rights from the project or folder that it’s in.
When this check box is selected, the list of access rights is 
grayed out, and shows what access rights the module is 
inheriting.

Add To add a new entry to the list of access rights:
a. Click Add. 

The Add Access dialog box is displayed.
b. In the Name box, select the name of the user or 

group that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select 
the entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit.

The Edit Access dialog box is displayed.
b. Select the access rights you want to give them, then 

click OK.
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information about them is contained in the object, and they do not use link 
modules.

If you Then

Move an object, 
module, folder or 
project that 
contains links

All of the links are preserved.

Copy an object that 
has links

Out-links are copied if you copy the object within the same 
module. Each copied out-link uses the same link module as 
the original out-link.
The following rules apply to in-links:

• If you’re copying the object to another module, links are 
not copied.

• If you’re copying the object within the same module, an 
in-link is only copied if you have modify access to the 
(source) object at the other end of the link. 

If you have modify access, a message is displayed asking if 
you want to copy the in-link. If you don’t have modify 
access, a message is displayed telling you that the in-link will 
not be copied and asking if you want to continue with the 
copy operation.

If an object you copy has a link that uses a mandatory linkset 
pairing, which goes through a link module that has one-to-one 
mapping, the following message is displayed when you paste 
the object:

• Click Yes to copy the object without the link

• Click No to cancel the copy operation
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Copy a formal or 
descriptive module 
that contains links

Out-links are always copied.
An in-link is only copied if you also copy the module that 
contains the (source) object at the other end of the link.
The link module used by the out-link in the copied module 
depends on two things:

• Whether the out-link in the source module uses a link 
module that is also being copied.

• If the link module is not being copied, whether the link 
module is local (a local link module has the same parent 
folder or project as the module itself).

If the out-link uses a link module that is also being copied, 
then the out-link in the copied module uses the copied link 
module.
If the out-link uses a local link module, L, that is not being 
copied, then the out-link in the copied module also uses a 
local link module. This link module is also called L, and is 
created if it doesn’t already exist.
If the out-link uses a non-local link module that is not being 
copied, then the out-link in the copied module uses the same 
link module as the out-link in the source module.

If you Then
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Editing links
This topic describes how to use the object properties sheet to:

• Show information about links.

• Delete links.

• Edit link attributes values (out-links and external links only).

Note  You can use link attributes to record information about your 
links. For example, you might create an attribute called 
Purpose which you use to record why the link was created. 
For information on how to create a link attribute, see 
“Creating link attributes,” on page 229.

To edit links:

Copy a folder or 
project that 
contains links

Out-links are always copied.
An in-link is only copied if you also copy the module that 
contains the (source) object at the other end of the link.
The link module used by the out-link in the copied module 
depends on two things:

• Whether the out-link in the source module uses a link 
module that is also being copied.

• If the link module is not being copied, whether the link 
module is local (in this case, a local link module is one that 
has the same parent as the folder or project you’re 
copying).

If the out-link uses a link module that is also being copied, 
then the out-link in the copied module uses the copied link 
module.
If the out-link uses a local link module, L, that is not being 
copied, then the out-link in the copied module also uses a 
local link module. This link module is also called L, and is 
created if it doesn’t already exist.
If the out-link uses a non-local link module that is not being 
copied, then the out-link in the copied module uses the same 
link module as the out-link in the source module.

If you Then
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1. In the module window, select the object whose links you want to edit.

2. Click Link > Edit Links.

The object properties sheet is displayed, with the Links tab selected.

A list of all the links in and out of the object is displayed. 

For each link:

• The In/Out column tells you the direction of the link, and whether it is 
a normal DOORS link or an external link.

• The Module/Description column tells you:
• For normal DOORS links, the module that contains the object at 

the other end of the link. The path from the module’s nearest 
ancestor project is displayed.

• For external links, the external link description
• The Baseline column tells you what version of the source or target 

module the object is linked to. For external links this column is blank.
• The Object Heading/Text column displays:

• For normal DOORS links, the first part of the Object Heading, if 
the object at the other end of the link has Object Heading. If it 
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does not have Object Heading, the first part of the Object Text is 
displayed.

• For external links, the external link name.
• The ID column shows the object identifier of the object at the other 

end of the link. For external links, this column is blank.
• The Link Module column tells you the link module that contains the 

link. The path from the link module’s nearest ancestor project is 
displayed. For external links, this column displays N/A.

• The Link Module Baseline column tells you what version of the link 
module contains the link. For external links, this column displays N/A.

3. To follow a link, select it, then click Follow Link.

4. To delete a link, select it, then click Delete.

Note  You can’t undelete a link once you’ve deleted it.

5. To see information about a link’s attribute or edit that information:

a. Select the link, then click Details.

If it’s an out-link or an external link, you can edit any attribute values 
that you have modify access to.

Note  Links have default system attributes that you can’t 
edit. Read-only  is displayed at the left.
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b. Select the attribute, then click Edit. Edit the attribute value, then click 
OK.

c. Click OK.

6. Click OK.

7. Click OK.

Creating link attributes
To create a link attribute, you must have create and modify access to the module.
To create a link attribute:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click Edit > Attributes.
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3. On the Attributes tab, a list of attributes is displayed.

4. If you want the new attribute to have a type that doesn’t already exist, click 
the Types tab and create the type (see “Creating an attribute type,” on page 
111).
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5. On the Attributes tab, either click New to create an attribute from scratch, 
or select the attribute you want to copy, then click Copy.

6. Type the name of the new attribute in the Name box, and enter additional 
information in the Description box.

7. Select the other options on the General tab.

General tab Description

Name The name you want to give the new attribute.
The name must be unique within the module.

Description Additional information about the new attribute.

Type The type of the new attribute.

DXL attribute Select this check box if you want to use a DXL program 
to assign values to the attribute. Then use Browse to 
select the DXL program you want to use.
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Browse If you selected the DXL attribute check box:
a. Click Browse to select the DXL program.

A list of all predefined DXL programs that can be used 
to set attribute values is displayed.

b. Select the program you want to use, then click 
Apply. Alternatively, if you want to define a new 
program, click New.

Multi-valued Select this check box if the attribute type has a base type 
of Enumeration, and you want to be able to store more 
than one value in the attribute.

Default value If you want the new attribute to have a default value, 
select the Default value check box, then type the value in 
the box.

Objects Select this check box if you want the attribute to apply to 
the objects in the module.

Module Select this check box if you want the attribute to apply to 
the module.

Inherit value Select this check box if the attribute applies to objects, and 
if you want objects to be able to inherit the attribute value 
from their parent objects.
Note that if the attribute applies to both the module and 
objects in it, top-level objects don’t inherit the value from 
the module.

Affect change bars Select this check box if you want DOORS to update an 
object’s change bar when anyone edits the attribute values.

Affect change dates Select this check box if you want DOORS to update an 
object’s last modified date when anyone edits the attribute 
values.
For more information, see the section on understanding 
how dates and times are recorded in Managing Telelogic 
DOORS, which is part of the DOORS documentation set.

General tab Description
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8. By default, the attribute inherits its access rights from the module. 

If you want to change its access rights use the Access (Definition) and 
Access (Value) tabs. For more information, see “Controlling access to an 
attribute definition,” on page 119 and “Controlling access to an attribute 
value,” on page 121.

9. Click OK.

10. Click Close.

11. Save the module to make the change permanent (click File > Save).

Deleting links
This topic describes how to delete links in bulk:

• You can delete normal DOORS links from the current module to a 
particular module.

• You can delete all the normal DOORS links in the current module.

• You can delete all the external links in the current module.

You can also delete links using the object properties sheet (see “Editing 
links,” on page 226).

Note  You can’t undelete a link once you’ve deleted it.

To delete a normal DOORS link you must have:

• Modify access to the source object and the link module.

• Read access to the target object. 

To delete an external link you must have create or modify access to the object 
containing the link.
To delete normal DOORS links from the current module to a particular 
module:
1. In the current module, select the objects you want to delete links from.

Note  You can ignore this step if you want to delete links from 
every object in the current view.

Generate history Select this check box if you want DOORS to update the 
database history when anyone edits the attribute values.

General tab Description
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2. Click Link > Delete Links.

3. Specify which objects you want to delete links to:

• In the Target module box, type the name of the target module, or use 
Browse to locate it. You must specify the path to the module from its 
nearest ancestor project.

• Click Raise to open the target module if it’s not already open, or to raise 
it to the front of your screen if it is already open.

• If you want to delete links to a subset of the objects in the current view, 
select the objects in the target module window.

4. In the Link module box, type the name of the link module, or use Browse 
to locate it. You must specify the path to the module from its nearest 
ancestor project.

To delete links the link module must be open. Click Raise to open it. If the 
link module is already open, clicking Raise will bring it to the front of your 
screen.

5. Use the Link drop-down list to specify what links you want to delete:

• Select Selection to selection to delete links from all objects currently 
selected in the source module to all objects currently selected in the 
target module.

• Select Selection to display set to delete links from all objects currently 
selected in the source module to all objects in the target module’s 
current view.

• Select Display set to selection to delete links from all objects in the 
source module’s current view to all objects currently selected in the 
target module.
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• Select Display set to display set to delete links from all objects in the 
source module’s current view to all objects in the target module’s current 
view.

6. Select the Confirm check box if you want to get a confirmation message 
that tells you how many links are about to be deleted.

7. Click OK.

To delete all the normal DOORS links in a module:
1. In the module window, click Link > Delete All Links.

2. A message is displayed asking if you really want to delete all the in- and 
out-links. Click Confirm to delete all links.

To delete all external links in a module:
1. In the module window, click Link > Delete All External Links.

2. A message is displayed asking if you really want to delete all the external in- 
and out-links. Click Confirm to delete all external links.

Using the create links tool
This topic describes how to create links in bulk, from the current module to 
another module. You cannot use this tool to create external links in bulk.

Note  You can also create links using drag-and-drop and the Link 
menu options (see “Creating links,” on page 216).

To create links from the current module to a particular module:
1. In the current module, select the objects you want to create links from.

Note  You can ignore this step if you want to create links from 
every object in the current view. 
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2. Click Link > Create Links.

3. Specify which objects you want to create links to:

• In the Target module box, enter the target module, or use Browse to 
locate it. You must specify the path to the module from its nearest 
ancestor project.

• Click Raise to open the target module if it’s not already open, or to 
bring it to the front of your screen if it is already open.

• If you want to create links to a subset of the objects in the current view, 
select the objects in the target module window.

4. In the Link module box, enter the link module you want to use, or use 
Browse to locate it. You must specify the path to the module from its 
nearest ancestor project. 

If you want to look at the link module, click Raise to open it. If the link 
module is already open, clicking Raise will bring it to the front of your 
screen.

5. Use the Link drop-down list to specify what links you want to create:

• Select Selection to selection to create links from all objects currently 
selected in the source module to all objects currently selected in the 
target module.

• Select Selection to display set to create links from all objects currently 
selected in the source module to all objects in the target module’s 
current view.

• Select Display set to selection to create links from all objects in the 
source module’s current view to all objects currently selected in the 
target module.

• Select Display set to display set to create links from all objects in the 
source module’s current view to all objects in the target module’s current 
view.
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6. Select the Confirm check box if you want to get a confirmation message 
that tells you how many links are about to be created.

7. Click OK.

Linking by attribute
If you have a module that contains an attribute whose values are the absolute 
numbers of objects in another module, you can automatically create links 
between the two modules.

For example, in this diagram module A has an attribute Relates to that stores 
the absolute number of the related object in module B. You can automatically 
create links between the related objects, as shown in the diagram above.

Note  In the source module, the attribute that you use for linking 
must be of type Text. If it contains more than one absolute 
number, each number must be on a separate line.

To link by attribute:
1. In the source module window, click Link, then Link by Attribute.

2. In the Target module box, type the name of the target module, or use 
Browse to locate it. You must specify the path to the module from its 
nearest ancestor project.

3. In the Link module box, type the name of the link module you want to use 
for the links, or use Browse to locate it. You must specify the path to the 
module from its nearest ancestor project
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4. In Existing attributes, select the attribute in the source module that you 
want to use. This is the attribute whose values are the absolute numbers of 
objects in the target module.

5. In the Link direction box, select the direction of the links.

You can create links from the source module to the target module, from the 
target module to the source module, or in both directions.

6. Click OK.

Understanding link module defaults
For each pair of modules, you can define the default link modules that are used 
whenever anyone creates a link between the two modules.
If you have two modules, A and B, you can define two default link modules:

• The default link module that is used for links from A to B

• The default link module that is used for links from B to A

We call these default linkset pairings.
For example, links from requirements to use cases might be stored in the design 
link module, and links from requirements to test in the verification link module.
For information on how to define default linkset pairings, see “Creating default 
linkset pairings,” on page 239. 

Using default link modules

Your user default link module is used whenever you create a link and there isn’t 
a default linkset pairing for the source-to-target module pair.
By default, your default link module is DOORS Links.
If you change your user default link module to say, Mylinks, then whenever you 
create links between modules that don’t have a default linkset pairing, DOORS 
uses Mylinks in the source module’s folder. If the folder doesn’t already contain 
a link module called Mylinks, DOORS automatically creates it.
Alternatively, you can set your default link module to a particular link module in 
your DOORS database, by specifying the full path of the link module, starting 
with its nearest ancestor project. Whenever you create links between modules 
that don’t have a default linkset pairing, DOORS uses this particular link module, 
regardless of which folder or project the source module is in.
To change your default link module:
1. In the DOORS Explorer, click Tools > Options. 
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2. Click the Settings tab.

3. In the Default link module box, type the default link module you want to 
use.

4. Click OK.

Creating default linkset pairings
For information on default linkset pairings, see “Understanding link module 
defaults,” on page 238.
A module’s properties sheet shows the default linkset pairings for links from that 
module to other modules. To change the pairings you must have admin access to 
the folder or project that the module is in.
To create or change the default linkset pairings:
1. In the module window, click File > Module Properties.
2. Click the Linksets tab.

A list of all the default linkset pairings for links from the current module is 
displayed.

3. To remove a pairing, select it then click Remove.

4. To add a new pairing:

a. Click Add.

b. In the Target module box, type the name of the target for the pairing, 
or use Browse to locate it. You can enter a target module that does not 
exist in the database. The module is not created, but the pairing is valid 
when the module is created.

c. In the Link module box, type the name of the link module that you 
want to be the default for links from the current module to the specified 
target module, or use Browse to locate it. You can enter a module that 
does not exist in the database. The module is not created, but the linkset 
is valid when the module is created.

d. Click OK.

If the linkset pairing already exists in the module, an error message is 
displayed. Click OK to return to the Add Linkset Pairing dialog and 
amend your settings.

5. To edit a pairing:

a. Select the entry you want to edit, then click Edit.
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b. Edit the entry in the Target module or Link module box.

c. Click OK.

6. Click OK.

Control on links for process management
An important aspect of requirements management is the organization of 
relationships between the data. DOORS lets you control the type and direction 
of all links, created by all users. This feature helps to enforce and support your 
project process. 
With Linkset Control, you define which links between documents are allowed 
and prohibit any other combinations. Consequently, users and project managers 
can be assured that they create the correct types of link.
You can also control where link information is stored for each source and target 
combination by specifying a default link module for that particular module 
pairing.
For the greatest control, you can specify that use of this link module is 
mandatory, forcing all users to store link information there, regardless of 
whether they have defined their own default link module. If that degree of 
control is not needed, you can make the link module overridable, so users can 
store information about their links in their own default link modules.
You must have administrative access to the parent folder of the source module to 
configure linkset definitions and enable linkset control.
To create linkset definitions:
1. Open your source module.

2. Click File > Module Properties.

The Module Properties dialog box is displayed.

3. Click the Linksets tab.

4. Click Add.

The Linkset Pairing dialog box is displayed.

5. In the Target module box, type the name of the target for the pairing, or 
use Browse to locate it.

6. In the Link module box, type the name of the link module that you want to 
use, or click Browse to locate it. 

7. (Optional) Select the Link Module options you wish to use for this linkset:
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• If you select Mandatory, link information for this linkset can only be 
stored in the specified link module.

• If you select Overridable, a user’s personal default link module will be 
used to store information about their links. 

8. Click OK.

To enable linkset control on a module:
1. Open your source module.

2. Click File > Properties.

The Module Properties dialog box is displayed.

3. Click the Linksets tab.

4. Select the option Only allow outgoing links as specified in the above 
list.

5. Click Apply, then OK.

By default, linkset control is turned off.
Outgoing links use only those linkset pairings in the list—no others are allowed.

Showing link module information
To show the properties of a link module:
1. In the DOORS Explorer, make sure that link modules are being displayed.

If necessary, click View > Show Link Modules.

2. Select the link module whose properties you want to show, then right-click 
Properties.

3. The properties sheet for the module is displayed.

The following table describes the options on the General tab.

General tab Description

Name The name of the module.

Description Additional information about the module.

Type The type of item whose properties are being displayed. This is 
Link Module, and can’t be edited.

URL The URL of the module.
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For information on the Access tab, see “Controlling access to a link module,” 
on page 222.

Creating a link module
To create a link module:
1. In the DOORS Explorer, select the folder or project you want to create the 

module in. This is the module’s parent.

You must have create access to the parent.

2. Click File > New > Link Module.

3. In the Name box, type the name of the new module.

The name can contain the following characters:

• Alphanumeric characters (letters of the alphabet and numbers)
• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

4. If you want to enter additional information about the module, type it in the 
Description box.

5. In the Mapping box, specify what kind of links you want to store in the link 
module. You cannot change the link mapping after the module has been 
created.

List of attributes This is a list of all the module’s attributes. For each attribute, it 
shows the name of the attribute and its value.

View/Edit To change the value of an attribute:
a. Select the attribute in the list of attributes, and then 

click Edit. 
b. Enter the new attribute value.

c. Click OK.

General tab Description
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The following table describes each mapping.

6. Click OK.

Note  If you receive the error Cannot create this Module: Lock 
request timed out when you try to create the module, wait a 
moment, then try again. This error is generated if another 
DOORS user is performing a paste operation when you click 
OK to create the module.

Working with link modules

By default, link modules are hidden in the DOORS Explorer. To show link 
modules, click View > Show Link Modules.
To open a link module, double-click it in the DOORS Explorer. A screen similar 
to the following example is displayed:

Mapping Description

Many-to-many Each object can have any number of in-links and 
out-links.

Many-to-one Each object can have any number of out-links, but only 
one in-link.

One-to-many Each object can have only one out-link, but any number 
of in-links.

One-to-one Each object can have only one out-link, and one in-link. 
So each object can be linked to only one other object.
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Use the Linkset drop-down list on the link module’s Linkset toolbar to select 
which linkset you want to display. The full name of the linkset that is currently 
selected is displayed when you roll over the list box. 

By default, the linkset in Matrix mode is displayed. A matrix of all the objects in 
the source and target modules is displayed. The source objects are shown 
vertically on the left, and the target objects are shown horizontally along the top.
A highlighted square on the matrix means there’s a link between the two objects 
that intersect at that position. 
If you select a highlighted square, you can use Go to link source  and Go to 
link target  on the Link toolbar to open the source or target module and go 
to the source or target object. 

Note  When you select a linkset in the link module, the source 
module of the linkset is opened in exclusive edit mode, but is 
not displayed. If you then try to open that module in 
read-only mode from the DOORS Explorer, it is displayed in 
exclusive edit mode. You can change to read-only mode by 
selecting Edit > Edit Mode > Read-Only in the formal 
module window.
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To view linksets in Graphics mode, click View > Graphics Mode.

Just as with Graphics mode in formal modules, objects are shown as boxes. 
Links are shown as red arrows connecting the source and target objects, with the 
current link highlighted as a black arrow.
Use Turn Graphics mode on or off  on the Graphics toolbar to switch 
between Graphics mode and Matrix mode.

Creating a linkset
When you create a link, DOORS automatically creates a linkset between the 
source and target modules, if it does not already exist. You can, however, create a 
new linkset yourself.
To create a linkset:
1. In the DOORS Explorer, make sure that link modules are being displayed.

If necessary, click View > Show Link Modules.

2. Select the link module you want to create the linkset in, then click File > 
Open > Exclusive Edit.
You must have create access to the link module.



Using links

246    Using Telelogic DOORS

3. In the link module window, click File > New > Linkset.
4. In the Source module box, type the name of the source module, or use 

Browse to locate it.

5. In the Target module box, type the name of the target module, or use 
Browse to locate it.

6. Click OK. 

A linkset is created, which you can use for storing links from the specified source 
module to the specified target module.
The linkset is opened in Matrix mode.

Deleting a linkset
Deleting a linkset deletes all the links and link attributes it contains.
To delete a linkset you must have delete access to the link module, and for each 
link in the linkset, you need:

• Modify access to the source object

• Read access to the target object

To delete a linkset:
1. In the link module window, open the linkset you want to delete, using the 

Show linkset drop-down list on the Linkset toolbar.

2. Click File > Delete > Linkset.
A message is displayed asking if you really want to delete the linkset. 

3. Click Yes.
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16 Discussions
• About discussions

• Controlling access for discussions in a module

• Creating a module discussion

• Viewing a module discussion

• Adding a comment to a module discussion

• Closing a module discussion

• Deleting a module discussion

• Reopening a module discussion

• Creating an object discussion

• Viewing an object discussion

• Adding a comment to an object discussion

• Closing an object discussion

• Deleting an object discussion

• Reopening an object discussion

About discussions
Discussions is a mechanism for reviewers to exchange views about the content 
of a module or an object within the module or object itself.
Instead of setting up linked review documents, or adding new text attributes to 
the module under review, DOORS allows you to maintain running discussions 
about objects and modules. The discussions are presented to you as part of the 
properties of the object or module.
You can create, view and modify discussions for modules and for objects in 
modules.

Controlling access for discussions in a module
You can control the access for the discussions in a module on the module 
properties sheet.
You can either allow everyone to create discussions or allow individual users and 
groups to create discussions.
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To control the access for the discussions in a module, you must have admin 
access to the module.
To control the access for the discussions in a module:
1. Either:

• In the module window, click File > Module Properties, and select the 
Discussions Access List tab.

• In the DOORS Explorer, select the module in the right pane, right-click 
Properties, and select the Discussions Access List tab.

The Discussions Access List is displayed.

If the list is grayed out, either:

• Discussions are not allowed for the database

If you want to allow discussions for the database, and control access to 
discussions in this module, you need to open Database Properties, select 
the Discussions Access tab, and select the Allow Discussions 
(access restrictions can be set on modules) radio button.

• Discussions are allowed for the database, and you cannot control access 
to discussions.

If you want to control access to the discussions in this module, you need 
to open Database Properties, select the Discussions Access tab, and 
select the Allow Discussions (access restrictions can be set on 
modules) radio button.

2. If you want all users to participate in discussions in this module, select Allow 
everyone to create discussions.

3. If you want only specific users to participate in discussions:

a. Clear Allow everyone to create discussions.
b. Click Add.

The Add User window is displayed.

c. Select users and groups and add them to the list.

4. Click OK.

Creating a module discussion
You can create a module discussion using:

• The New Module Discussion menu option.
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• The Create new discussion for module button  on the Discussion 
toolbar.

• The New Discussion button on the Discussions tab on the properties 
sheet for the module.

To create a module discussion:
1. Either:

• In the module window, click Discussions > New Module 
Discussion.

• In the module window, click Create new discussion for module  
on the Discussion toolbar.

• In the module window, click File > Module Properties, select the 
Discussions tab, then press the New Discussion button.

• In the DOORS Explorer, select the module in the right pane, right-click 
Properties, select the Discussions tab, then press the New 
Discussion button.

The New Discussion dialog box is displayed.

2. Enter a summary and your comment.

3. Click Save.

The comment is saved and the discussion created.

Viewing a module discussion
To view a module discussion:
1. Either:

• In the module window, click Discussions > View Module 
Discussions.

• In the module window, click View discussions for module  on the 
Discussion toolbar.

• In the module window, click File > Module Properties, then select the 
Discussions tab.

• In the DOORS Explorer, select the module in the right pane, right-click 
Properties, then select the Discussions tab.

The properties sheet for the module is displayed with the Discussions tab 
selected.

2. If you want to view all the discussions for the module, select View Closed 
Discussions.
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3. Click the discussion you want to view.

The full discussion is displayed.

Adding a comment to a module discussion
To add a comment to a module discussion:
1. Either:

• In the module window, click Discussions > View Module 
Discussions.

• In the module window, click View discussions for module  on the 
Discussion toolbar.

• In the module window, click File > Module Properties, then select the 
Discussions tab.

• In the DOORS Explorer, select the module in the right pane, right-click 
Properties, then select the Discussions tab.

The properties sheet for the module is displayed with the Discussions tab 
selected.

2. If you want to view all the discussions for the module, select View Closed 
Discussions.

3. Click the discussion you want to add the comment to.

The full discussion is displayed.

4. Click Add comment.
5. Enter you comment and click Submit.
The comment is added.

Closing a module discussion
Note  Only the person who created the discussion, or a Database 

Manager, Project Manager or a Custom user whose set of 
powers includes Archive Data, Partition Data and Create 
Groups can close a discussion.

To close a module discussion:
1. Either:

• In the module window, click Discussions > View Module 
Discussions.
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• In the module window, click View discussions for module  on the 
Discussion toolbar.

• In the module window, click File > Module Properties, then select the 
Discussions tab.

• In the DOORS Explorer, select the module in the right pane, right-click 
Properties, then select the Discussions tab.

The properties sheet for the module is displayed with the Discussions tab 
selected.

2. Click the discussion you want to close.

The full discussion is displayed.

3. Select Close discussion, and enter a comment.

4. Click Submit.
The comment is added and the discussion is closed.

Deleting a module discussion
Note  Only a Database Manager, Project Manager or a Custom user 

whose set of powers includes Archive Data, Partition Data 
and Create Groups can delete a discussion. 
You can also delete the discussion if you are the person who 
created the discussion, and you are included in the 
Discussions Access list for the module. For information on 
the Discussions Access list, see “Controlling access for 
discussions in a module,” on page 247.

To delete a module discussion:
1. Either:

• In the module window, click Discussions > View Module 
Discussions.

• In the module window, click View discussions for module  on the 
Discussion toolbar.

• In the module window, click File > Module Properties, then select the 
Discussions tab.

• In the DOORS Explorer, select the module in the right pane, right-click 
Properties, then select the Discussions tab.

The properties sheet for the module is displayed with the Discussions tab 
selected.
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2. Click the discussion you want to delete.

The full discussion is displayed.

3. Select Delete discussion.

A message is displayed asking if you really want to delete the discussion.

4. Click OK.

The discussion is deleted.

Reopening a module discussion
To reopen a module discussion:
1. Either:

• In the module window, click Discussions > View Module 
Discussions.

• In the module window, click View discussions for module  on the 
Discussion toolbar.

• In the module window, click File > Module Properties, then select the 
Discussions tab.

• In the DOORS Explorer, select the module in the right pane, right-click 
Properties, then select the Discussions tab.

The properties sheet for the module is displayed with the Discussions tab 
selected.

2. Select View Closed Discussions.

3. Click the discussion you want to reopen.

The full discussion is displayed.

4. Select Re-open discussion, and enter a comment.

5. Click Submit.
The comment is added and the discussion is reopened.

Creating an object discussion
You can create an object discussion using:

• The New Object Discussion menu option.

• The Create new discussion for object button  on the Discussion 
toolbar.
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• The New Discussion button on the Discussions tab on the properties 
sheet for the object.

To create an object discussion:
1. Select the object in the module window, then either:

• Click Discussions > New Object Discussion.
• Click Create new discussion for object  on the Discussion 

toolbar.
• Right-click New Object Discussion.
• Click Edit > Object > Properties, select the Discussions tab, then 

press New Discussion.
• Right-click Properties, select the Discussions tab, then press New 

Discussion.
• Double-click the object’s change bar, select the Discussions tab, then 

press New Discussion.

The New Discussion dialog box is displayed.

2. Enter a summary and your comment.

3. Click Save.

The comment is saved and the discussion created.

Viewing an object discussion
To view an object discussion:
1. Select the object in the module window, then either:

• Click Discussions > View Object Discussions.
• Click View discussions for object  on the Discussion toolbar.
• Click Edit > Object > Properties, then select the Discussions tab.
• Right-click Properties, then select the Discussions tab.
• Double-click the object’s change bar, then select the Discussions tab.

The properties sheet for the object is displayed with the Discussions tab 
selected.

2. If you want to view all the discussions for the object, select View Closed 
Discussions.

3. Click the discussion you want to view.

The full discussion is displayed.
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When you have finished viewing the discussion, you can use Next or 
Previous to display the discussions for the next or previous object.

Adding a comment to an object discussion
To add a comment to an object discussion:
1. Select the object in the module window, then either:

• Click Discussions > View Object Discussions.
• Click View discussions for object  on the Discussion toolbar.
• Click Edit > Object > Properties, then select the Discussions tab.
• Right-click Properties, then select the Discussions tab.
• Double-click the object’s change bar, then select the Discussions tab.

The properties sheet for the object is displayed with the Discussions tab 
selected.

2. If you want to view all the discussions for the object, select View Closed 
Discussions.

3. Click the discussion you want to comment on.

4. Click Add comment.
5. Enter you comment and click Submit.
The comment is added.
You can use Next or Previous to display the discussions for the next or 
previous object.

Closing an object discussion
Note  Only the person who created the discussion, or a Database 

Manager, Project Manager or a Custom user whose set of 
powers includes Archive Data, Partition Data and Create 
Groups can close a discussion.

To close an object discussion:
1. Select the object in the module window, then either:

• Click Discussions > View Object Discussions.
• Click View discussions for object  on the Discussion toolbar.
• Click Edit > Object > Properties, then select the Discussions tab.
• Right-click Properties, then select the Discussions tab.
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• Double-click the object’s change bar, then select the Discussions tab.

The properties sheet for the object is displayed with the Discussions tab 
selected.

2. Click the discussion you want to close.

The full discussion is displayed.

3. Select Close discussion, and enter a comment.

4. Click Submit.
The comment is added and the discussion is closed.
You can use Next or Previous to display the discussions for the next or 
previous object.

Deleting an object discussion
Note  Only a Database Manager, Project Manager or a Custom user 

whose set of powers includes Archive Data, Partition Data 
and Create Groups can delete a discussion. 
You can also delete the discussion if you are the person who 
created the discussion, and you are included in the 
Discussions Access list for the module. For information on 
the Discussions Access list, see “Controlling access for 
discussions in a module,” on page 247.

To delete an object discussion:
1. Select the object in the module window, then either:

• Click Discussions > View Object Discussions.
• Click View discussions for object  on the Discussion toolbar.
• Click Edit > Object > Properties, then select the Discussions tab.
• Right-click Properties, then select the Discussions tab.
• Double-click the object’s change bar, then select the Discussions tab.

The properties sheet for the object is displayed with the Discussions tab 
selected.

2. Click the discussion you want to delete.

The full discussion is displayed.

3. Select Delete discussion.

A message is displayed asking if you really want to delete the discussion.
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4. Click OK.

The discussion is deleted.

Reopening an object discussion
To reopen an object discussion:
1. Select the object in the module window, then either:

• Click Discussions > View Object Discussions.
• Click View discussions for object  on the Discussion toolbar.
• Click Edit > Object > Properties, then select the Discussions tab.
• Right-click Properties, then select the Discussions tab.
• Double-click the object’s change bar, then select the Discussions tab.

The properties sheet for the object is displayed with the Discussions tab 
selected.

2. Select View Closed Discussions.

3. Click the discussion you want to reopen.

The full discussion is displayed.

4. Select Re-open discussion, and enter a comment.

5. Click Submit.
The comment is added and the discussion is reopened.
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17 Tracking changes and traceability
This chapter contains the following topics:

• Understanding baselines

• Understanding change bars

• Understanding DOORS URLs

• Showing module history

• Understanding redlining

• Understanding link analysis

• Running a link analysis

• Understanding traceability columns

• Adding a traceability column

• Using the traceability explorer

• Understanding suspect links

• Showing suspect links

• Clearing suspect links

• Checking data against history

Understanding baselines
A baseline is a read-only version of a module. It captures a moment in time and 
preserves it until you delete the module.
When you create a baseline of a module, you create a copy of the module, which 
no-one can edit.
The baseline includes the history of the module:

• Information about all the attribute definitions and types that have been 
created, deleted or edited since the module’s most recent baseline.

• Information about all the objects that have been created, deleted or edited 
since the module’s most recent baseline.

• Information about every module session (every time the module has been 
opened) since it was first created.
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For more information on creating and using baselines, see “Using baselines,” on 
page 287.

Understanding change bars
Change bars let you track the changes to objects.
The color of an object’s change bar, a symbol and a tool-tip tell you the status of 
an object.

You can control whether the symbol is displayed in the change bar by selecting 
or clearing the Show symbols in change bars check box on the Settings tab of 
the Options dialog box (Tools > Options). For more information on the 
Options dialog box, see “Showing your user options,” on page 391.

Change bar Example tool-tip Description

You’ve created the object 
during the current session and 
have not yet saved the changes.

You’ve edited the object during 
the current session and have 
not yet saved the changes.

The object has been changed 
since the module was last 
baselined, and the changes 
have been saved.

The object has not been 
changed since the module was 
last baselined.

Either the object was deleted 
before the module was last 
baselined or history has not 
been loaded.

The object was deleted after 
the module was last baselined 
and history has been loaded.
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Note  The New Object symbol is always displayed, even if the 
Show symbols in change bars check box is cleared.

In the following example, the Power car heading has the red Unsaved Changes 
change bar at the left, showing that it has been edited during the current session, 
but the changes have not yet been saved.

All the other objects have yellow change bars, which means they have been 
edited since the module was last baselined.
Double-click an object’s change bar to show the history of changes for the 
object. 

Note  You can control what edits are associated with change bars. If 
you don’t want to know when users edit a particular attribute, 
you can change the attribute’s definition to turn change bars 
off for that attribute.

Understanding DOORS URLs
The DOORS database, and each project, folder, module, module baseline and 
object in the database has a unique identifier, which is expressed as a URL, 
beginning doors:. The URL of each item is stored in its properties sheet, and can 
be copied from there. You can also right-click on any item and select Copy 
URL.
For formal module objects only, you can use drag-and-drop to create external 
links to objects in other DOORS modules, or to copy the object URL to 
Microsoft Word. The object URL may also be copied to other applications using 
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drag-and-drop, but the behavior is governed by the application to which you 
drag-and-drop, not by DOORS.
For example, you can use drag-and-drop to insert a hyperlink to a DOORS 
object into a Microsoft Word document, or any application that supports 
HTML, and the hyperlink would look like this:

When you select the hyperlink the full URL is displayed.

If you use drag-and-drop to copy a hyperlink into an application that doesn’t 
support HTML, for example Notepad or WordPad, the full URL is displayed.
When you copy the URL of a module, baseline or object and the current view is 
not the Standard view, view information is copied with the URL. When the URL 
is followed, the module, baseline or object is displayed with the view that was 
selected when the URL was copied.
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Note  View information is not copied with the module URL if the 
URL is copied from the DOORS Explorer.

DOORS URLs can be inserted into a web page, stored as favorites or 
bookmarks in your browser, or simply pasted into other applications. You can 
also use DOORS URLs for linking objects in different DOORS databases, by 
inserting the DOORS URL as an external link.
When DOORS is installed, the DOORS protocol scheme is registered with the 
operating system. This means that any URLs beginning doors: are recognized by 
the operating system and opened by the default browser. The browser looks for 
the DOORS database that is referenced by the URL, and either starts a new 
client session for that database, or if a suitable session is already running, it will 
use that.

Following a DOORS URL

When you follow a DOORS URL, the URL handler identifies which DOORS 
database is referenced by the URL, and checks if a suitable session is running on 
the computer. A session running as one of the following is not a suitable session, 
and will not be used:

• A DOORSnet session.

• DOORS running in batch mode.

• A pre-8.1 version of DOORS.

• A session that has not been authenticated. If a DOORS session has been 
initiated, but you have not logged on, the browser ignores that session and 
starts a new one.

• A session that is running against a database other than the one referenced by 
the URL.

If the URL handler finds a suitable session, the item referenced by the URL is 
opened and displayed. If you don’t have access to the item that is referenced, an 
error message is displayed.

Note  When you try to follow an external link from an object in a 
DOORS 9.x database to an object in a DOORS 8.3 database, 
you need to make sure that a DOORS 8.3 client is already 
running. Otherwise, an error will be displayed.

If the URL handler does not find a suitable session, it initiates a DOORS client. 
The DOORS splash screen is displayed, followed by the DOORS Login dialog 
box. Once you have entered your DOORS username and password, the item 
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referenced by the URL is opened. The following table describes what happens 
for the different types of items.

Item referenced 
by URL

Description

Database The database is opened and the database icon is selected

Project The project is selected in the left pane of the DOORS 
Explorer window, and its contents are displayed in the right 
pane.

Folder The folder is selected in the left pane of the DOORS 
Explorer window, and its contents are displayed in the right 
pane.

Module The module is opened in the default edit mode. If view 
information has been copied with the module URL, and the 
user has read access to the view, that view is displayed.
If view information has not been copied with the module 
URL, or the user does not have read access to the view 
specified by the URL, or the view specified by the URL has 
been deleted, the default view is displayed.
If the module is already open and the URL specifies a view 
other than the current view, the behavior is dictated by the 
options that are set for the current user. For more 
information, see “Showing your user options,” on page 391.

Module Baseline The module baseline is opened.
If view information has been copied with the baseline URL, 
and the user has read access to the view, that view is displayed.
If view information has not been copied with the baseline 
URL, or the user does not have read access to the view 
specified by the URL, or the view specified by the URL has 
been deleted, the default view is displayed.
If the baseline is already open and the URL specifies a view 
other than the current view, the behavior is dictated by the 
options that are set for the current user. For more 
information, see “Showing your user options,” on page 391.
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Note  The DOORS splash screen, Login dialog box, database 
explorer and module windows display in the normal way. 
They are not displayed in the browser window.

By default, you have 60 seconds from the time the DOORS Login dialog box is 
displayed to enter your username and password. If you do not log on within this 
time limit, the URL expires. You can still log on after the time limit expires, but 
an error is displayed and the item referenced by the URL is not displayed.

Showing module history
You can control what changes to objects are recorded in the history. If you don’t 
want to know when users edit a particular attribute, you can change the 
attribute’s definition to turn history off for that object. You can choose whether 
to record the creation and deletion of links in the module history. By default, link 
history is generated. If you don’t want to generate link history, clear Create link 
history on the General tab of module properties. 
You can filter the history by username or date, and you can export the history to 
a text file, so you can print it or insert it in other files.

Object The module containing the object is opened in the default edit 
mode with the object selected. 
If view information has been copied with the object URL, and 
the user has read access to the view, that view is displayed.
If view information has not been copied with the object URL, 
or the user does not have read access to the view specified by 
the URL, or the view specified by the URL has been deleted, 
the default view is displayed.
If the module is already open and the URL specifies a view 
other than the current view, the behavior is dictated by the 
options that are set for the current user. For more 
information, see “Showing your user options,” on page 391.
If the object is not visible in either the default view or the view 
specified by the URL, a message is displayed prompting the 
user to change to the Standard view.

Item referenced 
by URL

Description
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For more information, see the section on understanding how dates and times are 
recorded in Managing Telelogic DOORS, which is part of the DOORS 
documentation set.
To show the history of a module:
1. In the module window, click File > Module Properties.
2. Click the History tab
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The following table describes the options on the History tab.

History tab Description

View change as 
redlining

Select this check box to show the details of the change as 
redlined text. The example above shows the details of the 
history record with redlining turned on. Deletions are 
shown as red text with strikethrough, and insertions as 
blue text with underlining.

Goto Target Object If you have selected to record history for the creation and 
deletion of links in the current module and you select a 
link history, the Details of selected history record 
displays the name and path to the link module and target 
module for the link. Click Goto Target Object to open 
the target module (if it is not already open) and display the 
target object.
The Goto Target Object button is only displayed when a 
link history is selected.

All This shows module and object history.
The object history tells you about all the objects that have 
been created, deleted or edited since the module’s most 
recent baseline.
If Create link history is selected, information about links 
that have been created or deleted since the module’s most 
recent baseline is displayed.
Note You can also see an object’s history by 

double-clicking its change bar.

Module This is the default. It shows the module history.
Information about all the changes to module attributes is 
displayed, along with the attribute definitions and types 
that have been created, deleted or edited since the 
module’s most recent baseline.
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Sessions Select this box to show the module session history, then 
click Refresh.
The following information about everyone who has 
opened the module since the module was created is 
displayed:

• The person’s DOORS username.

• A unique session identifier.

• When they opened the module.

• If they created a baseline, the name of the baseline.

Dates If you only want to see history information after a 
particular date or within a range of dates:
a. Select the Dates check box.

b. Type the appropriate dates in the From and To 
boxes, or select them from the drop down 
calendars.

c. Click Refresh.

User If you only want to see history information for a 
particular user:
a. Select the User check box.

b. Type the username. 

c. Click Refresh.

Details Shows full information about the selected history item. 
The information is displayed in a separate window. Select 
the View change as redlining check box to display 
changes as redlined text.
If the selected history item is a link creation or deletion, 
you must have read access to the associated link module 
and target module to view the history details.

Refresh Updates the screen to show the history associated with 
whichever Show history boxes are selected.

History tab Description
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Understanding redlining
Some changes in DOORS can be viewed with redline markup. This makes it easy 
to see at a glance the changes that have been made to an attribute. Redline 
markup is available in:

• Module and object history 

• The spelling checker

• The change proposal system

• The Module Comparison Wizard

• Details of suspect links

The comparison that generates the redline markup in DOORS is made on a 
word by word basis between two static pieces of text using a longest common 
subsequence algorithm. DOORS does not save information about individual 
keystrokes, so the redline markup may not reflect the sequence of changes 
performed by the user.
As the comparison is word by word, the redline markup may differ from what 
you might expect. For example, if DOORS is comparing ship wreck to 
shipwreck, the redline markup will show ship as deleted, wreck as deleted and 
shipwreck as inserted.
DOORS uses word level analysis rather than character level analysis for 
performance reasons.

Export To save the history information in a file:
a. Click Export.
b. Enter or select the file you want to save the 

information in.

c. Clear the Include details check box if you don’t 
want full details of each history record. 

d. Click OK.

The complete module and object history are exported, 
regardless of the display settings.

History tab Description
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Understanding link analysis
Link analysis tell you about links to or from the current module. It is an analysis 
of normal DOORS links. External links are ignored during link analysis.
You can choose whether to analyze in-links or out-links. 

• If you analyze in-links, information about the objects in the chain of links 
coming into the current module is displayed. Changes to these objects affect 
the current module.

• If you analyze out-links, information about the objects in the chain of links 
going out from the current module is displayed. These are the objects that 
are affected if you make any changes to the current module.

You can specify how far you want to travel down the chain of linked objects. 
This is the depth of the analysis.
For example, if you run an analysis with a depth of 2, information about the 
objects that are linked to the objects in the current module is displayed, along 
with the objects that are linked to those objects.

Running a link analysis
This topic describes how to run a link analysis for the current object that:

• Opens every module that contains a linked object

• Applies a filter so that only the linked objects are displayed

For more information, see “Understanding link analysis,” on page 268.
To run the link analysis:
1. Select the object whose links you want to analyze.
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2. Click Analysis > Links.
3. Use the Link direction radio buttons to specify whether you want to 

analyze in- or out-links.

4. Use the Select link module radio buttons to specify whether you want to 
restrict the analysis to links that use a specific link module:

• Click All modules if you don’t want to restrict the analysis.
• If you want to restrict the analysis to links that use a particular link 

module, click Specific, then either type the name of the module (specify 
the path from its nearest ancestor project), or use Browse to locate it.

5. In the Depth box, type the depth of analysis you want to use.

The default of 1 limits the analysis to objects that are directly linked to the 
current object in either the current module or other modules.

Greater levels of depth look at links that are 2 or more link jumps on from 
the current object. Again, these can be links in either the current module or 
other modules.

If the depth is 0, the analysis only looks for links in the current module.

6. Click OK to run the analysis.

If a source or target object is in another module, and the module is not already 
open, it is opened in read only mode. The data in both modules is filtered to 
show only the linked objects.

Note  If the source or target module is opened in read only mode, 
and you change to exclusive edit mode, the filter applied by 
the link analysis is removed, and the current module view is 
loaded.

Understanding traceability columns
A traceability column contains information about objects that are linked to or 
from objects in the current module.
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This picture shows two traceability columns. They contain information about 
linked objects in the System Requirements and Tests modules.

Traceability columns are layout DXL columns. The values displayed in them are 
calculated by a DXL program that runs an impact or traceability analysis and 
then displays information about the linked objects.
By default traceability columns display the following information about each 
linked object:

• The name of the module that the linked object is in

• The value of its Object Heading attribute

• Its object identifier

You can display other information if you want. You can display other attribute 
values for the linked object, and you can display information about the attributes 
of the link itself, such as when the link was created.

Note  If you archive a project that contains modules with 
traceability columns containing values calculated using DXL 
attributes, and restore it to another database, the traceability 
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columns will not display any information. To display the 
traceability information in the restored project, you must add 
the traceability column again. The same is also true for 
partitions, when they are imported to another database.

Adding a traceability column
For information on traceability columns, see “Understanding traceability 
columns,” on page 269.
To add a traceability column to your current view:
1. Click Analysis > Wizard.

The wizard’s Welcome screen is displayed.

2. Define the type of links you want to analyze.

• Click In-links or Out-links in the Link direction frame.
• Select the link types you want to analyze. These can be either DOORS 

links, External links or both.

3. Click Next.
If you have selected to include DOORS Links in the analysis, the Scope of 
analysis screen is displayed. If you are only analyzing external links, go to 
Step 7.

4. Use the Select formal module radio buttons to select which formal 
modules you want to analyze:

• Click All open modules to analyze linked objects in all formal modules 
that are currently open.

• Click All modules to analyze linked objects in all formal modules, 
regardless of whether they are open or not. 

• To analyze linked objects in a specific formal module, click Specific, 
then either type the name of the module (specify the path from its 
nearest ancestor project), or use Browse to locate it.

5. Use the Select link module radio buttons to specify whether you want to 
restrict the analysis to links that use a specific link module:

• Click All modules if you don’t want to restrict the analysis.
• To restrict the analysis, click Specific, then either type the name of the 

link module (specify the path from its nearest ancestor project), or use 
Browse to locate it.

6. Click Next.
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7. The information that is displayed on this screen depends on whether you are 
analyzing DOORS links, external links or both. If you have included 
DOORS links in your analysis, the Module and object attributes list and 
the DOORS link attributes list are available. If you have included external 
links, the External link attributes list is available. 

If you are only analyzing external links, got to Step 9.

By default, the traceability columns display the following information for 
each object that is the source or target of a DOORS link:

• The object heading.
• The object identifier.
• Module Name (including path for other folders).

This option only displays the path to the module if it is in a different 
folder to the current module.

If you want to display the path regardless of the module’s location, clear 
Module Name (including path for other folders) and Module 
Name (no path) and select Module Name (including path).
If you do not want to display the path to the module, clear Module 
Name (including path for other folders) and Module Name 
(including path) and select Module Name (no path).

If you want to display other items, select them in the list of Module and 
object attributes. Click an item to select it. Click it again to de-select it.

If you selected all formal modules or all open formal modules in Step 4, the 
list only shows system attributes.

8. By default, the traceability columns don’t display any attribute values for the 
links themselves.

If you want to display link attribute values, select the attributes in the list of 
Link attributes. Click an item to select it. Click it again to de-select it.

9. By default the traceability column displays the description of any external 
links. If you want to include information from other attributes in the 
traceability column, select the attributes from the External link attributes 
list. Click an item to select it. Click it again to de-select it.

10. Click Next.
11. In the Column width box, specify how wide you want each traceability 

column to be, in pixels.
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Note  Pixels are used to measure distances on computer 
screens. Open Display in the Control Panel, then the 
Settings tab to find out how big your screen is in pixels.

12. Specify how the results of the analysis are to be displayed in the traceability 
columns:

• By default, every attribute is displayed on a new line. 

Clear the One attribute per line check box if you want the attributes 
displayed in a continuous paragraph without line breaks between them.

• By default, only attribute values are displayed in the columns, but not 
the names of the attributes.

Select the Show attribute names check box if you want to see the 
names of the attributes as well as their values.

• By default, OLE objects are not displayed in the columns.

Select Include OLE objects in text if you want to see OLE objects.

• If you want to truncate the value of each attribute that is displayed to a 
specified number of characters, select the Trim each datum to check 
box and type the number.

• If you want to truncate the entire string that is displayed to a specified 
number of characters, select the Trim entire string to check box and 
type the number.

13. Specify whether you want recursive analysis.

If you want analysis of more than one level, select the Recursive analysis 
check box.

14. Specify whether you want the recursive analysis to be displayed in one 
column or in multiple columns.

If you want the recursive analysis to be displayed in one column, clear the 
Multiple columns check box.

15. In the Depth of analysis box, specify the depth of the analysis. If you are 
only analyzing external links, only analyzing to one level, or want to display 
traceability information only from specified modules this check box is 
unavailable. The maximum depth is 10.

16. Determine whether you only want to display information about links to and 
from specific modules.

Select or clear the Display information only from selected modules 
check box. If you are only analyzing external links, only analyzing to one 
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level, or have specified a number of levels in the Depth of analysis box, this 
check box is unavailable.

If you select this check box, click Next to go to the next screen to specify 
the modules. For information on the next screen of the wizard, go to the 
next step.

If you do not select this check box, click Finish to add the traceability 
column to your current view. By default, the first column displays 
information about objects that are one link hop from the current object, the 
second column displays information about objects that are two link hops 
from the current object, and so on.

17. Specify the modules that you want to display link information about.

Select a module in Module Name. The link information from or to this 
module will be displayed in the first traceability column. Select another 
module. The link information from or to this module will be displayed in the 
second traceability column, and so on until you have selected all the modules 
you want.

For example, you assign the first column to Module A, the second column to 
module B, and so on. Column 1 shows objects in Module A that are linked 
to the current module (the one you’re analyzing). Column 2 shows objects in 
Module B that are linked to objects in Module A. Column 3 shows objects in 
Module C that are linked to objects in Module B, and so on. 

For each object in the module you’re analyzing, you can follow the chain of 
links through the various modules. You can see what objects in Module A it’s 
linked to, and what objects in Module B those objects are linked to, and so 
on.

To specify a chain of modules:
a. Select the module you want to display in column 1, then click Next.
b. Select the module you want to display in column 2, then click Next.
c. Repeat until you’ve finished building up the chain of modules.

18. Click Finish to add the traceability column to your current view.

Note  If you want to permanently add the new column to your 
view, follow the instructions in “Saving your current view,” 
on page 79.
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Using the traceability explorer
Use the traceability explorer to see which objects in your current module have 
links and to navigate to the linked objects.
To use the traceability explorer:
1. In the module window, click Analysis > Traceability Explorer. 

A flat list of all the objects in your current view is displayed. 

If an object has a link, it has a plus sign (+) to the left. In this example, three 
objects have links.

2. By default, the Traceability Explorer shows objects that have in-links from 
modules that are open.

To change the default, use the options on the View menu.

View menu option Description

In-links Only shows in-links.

Out-links Only shows out-links.

Open Modules Only shows links from or to modules that are currently 
open.

All Modules Shows links from or to modules that are closed as well as 
modules that are open.

Refresh Refreshes your screen.
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3. Click the plus sign (+) to show the linked objects.

In this example, the selected object has links to 2 objects.

• The arrow shows the direction of the links.
• The status bar at the bottom on the screen shows the name of the 

module that the currently selected object is in.

4. To show the selected object, right-click Show Object.
If it’s in a module that is not currently open, the module is opened read only 
with its current object set to the selected object.

Navigating
To navigate within the traceability explorer:
• Use the Page Up, Page Down and arrow keys

• Use the scroll bars

• Use the HOME and END keys to move to the first or last object in the 
current view

Understanding suspect links
In a large database with multiple links, a change to one object may affect many 
other objects in the database. DOORS prevents such changes being overlooked 
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by marking objects that are linked to objects that have changed as having a 
suspect link. Users can check modules for suspect links, identify the change that 
has caused the link to become suspect, and update the objects accordingly. 

Note  The object that is changed is not marked as having a suspect 
link, but any objects that are linked to that object are marked 
as having a suspect link.

For example, if a user requirement is linked to a system requirement a change to 
the user requirement may require a change to the linked system requirement. The 
system requirement is marked as having a suspect link. but the user requirement 
does not have a suspect link. When the system requirement has been checked 
and updated as required, the suspect link can be cleared from the system 
requirement. 
If changes are made to both the source object and target object of a link, then 
the link will be marked as suspect at both ends. If you clear the suspect link at the 
source it also clears the suspect link at the target.

Caution  Only those attributes that have been set to affect change 
dates cause a link to be marked as suspect when they are 
edited. The Affect change dates setting can be selected 
by editing the attribute definition.

Note  In version 8 of DOORS, date values are stored on the server 
in UTC (Universal Coordinated Time), and are displayed on 
the client according to the client time zone. In pre-8.0 
versions of DOORS, date attribute values did not include the 
information to make time zone adjustments, so date attribute 
values in migrated data may not display as expected. For 
example, if clients in multiple time zones were working on 
data, suspect links may not operate as you would expect. For 
more information, see the section on understanding how 
dates and times are recorded in Managing Telelogic DOORS, 
which is part of the DOORS documentation set.

Showing suspect links
Objects with suspect links can be identified by:

• Filtering on suspect links

• Displaying suspect link indicators

• Displaying the last change
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• Displaying all suspect link information

Filtering on suspect links
You can apply a filter to your module so that only objects with suspect links are 
displayed. You can choose to filter on suspect in-links or suspect out-links, to all 
modules or to modules that are currently open.
To filter on suspect links, click Analysis > Suspect Links > Filter, then the 
type of links that you want to filter on. You can choose from: 

• In-links (open modules only)

• In-links (all modules) 

• Out-links (open modules only) 

• Out-links (all modules)

If you select one of the open modules only options, ensure that the target 
modules you want the suspect link filter to apply to are open.

Note  This filter cannot be saved in a view.

Displaying suspect link indicators

You can insert a column to display link indicators, which flag objects that have 
suspect links.
A link arrow with a question mark is displayed beside objects with suspect links. 
This  indicates an incoming suspect link and this  indicates an outgoing 
suspect link. The link indicators column does not indicate the number of suspect 
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links that an object has. To see more detailed information on suspect links see 
“Displaying all suspect link information,” on page 280.

To insert a column to display link indicators:
1. Click Analysis > Suspect Links > Display Indicators, then the type of 

links you want to flag. You can choose from: 

• In-links (open modules only)
• In-links (all modules) 
• Out-links (open modules only) 
• Out-links (all modules)

Note  If you select one of the open modules only options, 
ensure that the target modules you want to see suspect 
link indicators for are open.

Displaying the last change
You can insert a column that displays a summary of the last change that made a 
link suspect, for each object with in-links or out-links, to open modules or to all 
modules.
The following information is displayed in the column:

• The absolute path to the module containing the source or target of the 
suspect link
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• The object ID of the object that is linked to

• The date and time that the object was last modified

• If suspicion has never been cleared, that is stated

To insert a column displaying the last change that made the link suspect:
1. Click Analysis > Suspect Links > Display last change, then the type of 

links for which you want to see suspect link information. You can choose 
from:

• In-links (open modules only)
• In-links (all modules)
• Out-links (open modules only)
• Out-links (all modules)

Note  If you select one of the open modules only options, 
ensure that the target modules you want to see suspect 
link information for are open.

Displaying all suspect link information

You can insert a column that displays all the suspect link information for each 
object with in-links or out-links, to open modules or to all modules.
The following information is displayed in the column:



Using Telelogic DOORS           281

Showing suspect links

• The absolute path to the module containing the source or target of the 
suspect link

• The Object ID of the source or target object

• The number of changes that have been made to the object since suspicion 
was last cleared

• The name of the attribute that has been modified, and the time that the 
modification was made

There can be multiple suspect link entries for one object, as the following 
example shows:

If the source or target module has been baselined since the last time suspect links 
were cleared, there may have been changes to the source or target object that 
make the link suspect, but that cannot be displayed. This is because suspect link 
information is based on the object history of the source or target object. If the 
module has been baselined, the history is cleared from the current module 
version and stored in the baseline.
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In this instance DOORS states that the source or target module has been 
baselined, and that the baseline may contain details of changes that make the link 
suspect.

To insert a column that will display all the suspect link information:
1. Click Analysis > Suspect Links > Display all changes, then the type of 

links for which you want to see suspect link information. You can choose 
from: 

• In-links (open modules only)
• In-links (all modules) 
• Out-links (open modules only) 
• Out-links (all modules)

Note  If you select one of the open modules only options, 
ensure that the target modules you want to see suspect 
link information for are open.

Clearing suspect links
There are two ways to clear suspect links: Clear and Clear All.
• Use Clear to clear individual suspect in-links or out-links from a single 

object in a module
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• Use Clear All to clear all suspect in-links or all suspect out-links or both 
from a module

Caution  We recommend that you save all open modules before 
clearing suspect links.

When you clear suspect links, it is the suspicion on the link that is cleared. This 
means that if there have been changes to both the source and target objects of a 
link, and you clear the suspect link at the source object, the suspicion is also 
cleared at the target.

Access rights required for clearing suspect links

If you want to clear suspect links, you must have the following access rights:

• The first time a suspect link is cleared, you must have Create access to the 
link module. This is because attributes are created in the link module to store 
suspect link information.

• Anyone who subsequently clears suspect links that go through that link 
module must have Modify access to the link module. 

• You must have Modify access to both the source and target modules of the 
suspect link.

Using the Clear function

1. Click Analysis > Suspect Links > Clear in the module window.

The Clear Suspect Links dialog box for the current object is displayed.

Important: DOORS opens all modules in the database that contain objects 
that are linked to the current object. These modules will be opened without 
being displayed. If you do not have read access to either the module 
containing the linked object or the linked object itself, then DOORS will not 
calculate suspect links.

The information is displayed over two tabs: one for incoming links and one 
for outgoing links.

The information displayed includes the following: 

• The absolute path of the module containing the linked object
• The source or target object’s identifier
• The date and time of the last modification to the source or target object

2. Click Next or Previous to display the suspect links of the next or previous 
object in the current view.
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3. To see more information about a suspect link, select it and click Details.

The first change that caused the link to become suspect is displayed. Use the 
Next and Previous buttons to look through the changes that have been 
made to the linked object since suspicion was last cleared.

Select View change as redlining to see the changes that have caused the 
link to be flagged as suspect with redline markup.

If the source or target module has been baselined since the last time suspect 
links were cleared, there may have been changes to the source or target 
object that make the link suspect, but that cannot be displayed. This is 
because suspect link information is based on the object history of the source 
or target object. If the module has been baselined, the history is cleared from 
the current module version and stored in the baseline. 

In this instance, DOORS states that the source or target module has been 
baselined, and that the baseline may contain details of changes that make the 
link suspect.

4. Click OK to return to the Suspect Links dialog box for the current object.

5. Selecting a single entry or multiple entries activates the Clear option.

6. Click Clear to clear the suspect links.

DOORS performs an access control check to ensure that you have the 
necessary access to all formal and link modules required for update. 

If you do not have the necessary access, an error message is displayed, or the 
Clear button is unavailable. For more information see “Access rights 
required for clearing suspect links,” on page 283.

7. Click Close. 

When you click Close, modules open for edit, which were opened for edit 
previously, are left unsaved. 

An information message is displayed.

8. You must save any open modules.
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Using the clear all function

The Clear All suspect links option lets you clear all suspect incoming links, all 
suspect outgoing links, or both. If you have the module open in shareable edit 
mode, you can only clear suspect links in locked sections. 
To clear all suspect links:
1. In the module window, click Analysis > Suspect Links > Clear All.

The Clear All Suspect Links dialog box is displayed.

2. Select Clear Suspect In-links, Clear Suspect Out-links, or both.

3. Click OK.

All suspect links will be cleared.

An information message is displayed.

4. You must save any open modules.

Checking data against history
DOORS contains a utility to detect and fix any discrepancies between the 
current data in a module and the history of the module. The following 
discrepancies can be detected and fixed:

• Objects that have been deleted or undeleted in history, and aren’t deleted or 
undeleted in the current data.

• Objects that have been purged in history, and still present in the current 
data.

• Links that have been created or deleted in history, and aren’t present or are 
still present in the current data.

• Attribute values where there is a difference between the current data and 
history, including text values, string values, enumerated values, integer values, 
real values, dates, or usernames. Also included are differences in default 
values, inherited values and module attribute values.
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Changes to attributes and objects that weren’t included in history recording 
cannot be detected by the utility.
Objects that were included in history recording and are not in the current data 
are reported in the log but cannot be recovered.
The utility produces a report of any discrepancies, and allows you to update a 
module with the differences.
There are a number of discrepancies that the utility cannot detect:

• If OLE data wasn’t included in history when the history record was saved, 
OLE data won’t be included in the updated attribute value.

• If the change recorded in the history record is simply adding an OLE object 
and no text to a text attribute that was previously, and is currently, empty, the 
discrepancy won't be detected.

If the value recorded in history isn’t now a valid value for the attribute, then the 
tool will report this in the log, but it won’t update the attribute value. This can 
happen as a result of changes in the attribute definition or type definition that 
have been made since the history item was recorded (for example, changing the 
values of an enumerated type).
To check data against history:
1. Log on to DOORS as the Administrator user.

2. Open the module you want to check for discrepancies in exclusive edit 
mode.

3. Click Tools > Check data against history.

4. Accept the default location of the report file, or browse to a new location.

5. Select either Append output to existing contents or Discard existing file 
contents.
This determines whether a new report file is created, or an existing report 
file is added to.

6. Select or clear the following check boxes:

• Check history in all baselines (this check box is only available if there 
are any baselines for the module)

• Check attribute values in deleted objects 
• Update data to match latest history values

Select this check box if you want to recover the lost data. Note that even 
if you select this check box changes aren’t made permanent until you 
save the module.
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18 Using baselines
This chapter contains the following topics:

• Understanding baselines

• Viewing a baseline

• Baselining groups of modules

• Creating a baseline

• Copying a baseline

• Comparing baselines

• Deleting a baseline

Understanding baselines
A baseline is a read-only version of a module. It captures a moment in time and 
preserves it until you delete the module.
When you create a baseline of a module, you create a copy of the module, which 
no-one can edit.
The baseline includes the history of the module:

• Information about all the attribute definitions and types that have been 
created, deleted or edited since the module’s most recent baseline.

• Information about all the objects that have been created, deleted or edited 
since the module’s most recent baseline.

• Information about every module session (every time the module has been 
opened) since it was first created.

You can look at baselines (see “Viewing a baseline,” on page 288).
You can also create a new module by copying a baseline. The new module 
contains all the same data as the baseline, but doesn’t have any of the history 
information. For more information, see “Copying a baseline,” on page 289.

Using baselines to improve performance

DOORS stores the history information for each module in a separate file in the 
database. The history files can get very big, because they can contain a lot of 
information about the changes made to the modules.
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When you edit a module, DOORS opens its history file. The bigger the history 
file, the longer it takes to open it.
To improve performance, regularly create baselines of your modules. Creating a 
baseline creates a new file that contains the baseline, together with all the history 
information, and erases the contents of the module’s history file. You can still 
access the history information; it’s just stored in a different file which is not 
opened when you edit the module.
See “Comparing baselines,” on page 291 for information on comparing 
baselines.

Viewing a baseline
To view a baseline:
1. In the module window, click File > Baseline > View.

2. Select the baseline you want to view, then click Open.

If the baseline is part of a baseline set, the baseline set to which it belongs is 
displayed in the Baseline Set box. To see more information about the 
baseline set, click View.

If the baseline has been deleted, the Open and Signatures buttons are 
unavailable. The username of the user who deleted the baseline, and the date 
the baseline was deleted are displayed alongside the baseline.

Baselining groups of modules
If you have several modules that you want to baseline at the same time you can 
create a list of those modules, called a baseline set definition. Baseline set 
definitions are stored with either project or folder properties. When you want to 
baseline the modules, you access the baseline set definition from the project or 
folder properties dialog, create a baseline set, then baseline the modules to that 
set.
Managing the baselining of large numbers of modules in this way has several 
advantages:

• Having all of the modules listed together in the same place means that you 
never forget about one of the modules in the group when it is time to 
baseline them.

• DOORS checks for locks on the modules before starting to baseline them. 
You do not get half way through baselining a group of modules to find that 
another user has locked one of them.
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• The baselines can be labelled so that it is clear that they are part of the same 
group.

• Links between modules that are baselined as part of the same baseline set are 
handled more efficiently by DOORS. This improved link handling means 
that traceability is maintained between baselines in the same way as it is 
between current module versions. 

For more information on how your project can benefit from this improved link 
handling, see Managing incremental development using Intelligent Traceability in 
the online help and in Managing Telelogic DOORS on the Telelogic Lifecycle 
Solutions DVD.

Creating a baseline
To create a baseline, you must have modify access to the module. You can only 
create a baseline of a formal module.
To create a baseline:
1. Make sure you are in exclusive edit mode.

The edit mode is shown on the status bar at the bottom of the module 
window. To change your edit mode, click Edit > Edit Mode > Exclusive 
Edit.

2. Click File > Baseline > New.

3. Check that None is selected in the Baseline Set list.
4. Use the Version radio buttons to select the version number of the new 

baseline.

5. If you want the new baseline to have a suffix as well as a version number, 
type it in the Suffix box.

6. If you want to enter additional information about the baseline, type it in the 
Description box.

7. Click OK.

The module is automatically closed and then opened again.

Copying a baseline
When you copy a baseline, you create a new module. You can either:

• Copy all the information in the baseline. 



Using baselines

290    Using Telelogic DOORS

The new module contains exactly the same data as the baseline, except that it 
has no history information and no links.

• Copy only the objects that have headings. 

This lets you create a new module that has the same structure as the original 
module. The baseline is used as a template for the new module.

The new module is created in the same folder or project as the original module. 
You must have create access to this folder or project.
To copy a baseline:
1. In the module window, click File > Baseline > Copy.

2. Select the baseline you want to copy.

Note  You cannot copy baselines that have been deleted.

3. In the Copy to new formal module box, type the name you want to give 
the new module.

The name is case-sensitive. For example, the names Mymodule and 
MyMODULE are different.

The name must be unique within the parent project or folder. All the 
projects, folders and modules in the parent must have different names.

The name can contain the following characters:

• Alphanumeric characters (letters of the alphabet and numbers)
• Space characters
• Periods (.)
• Underscores (_)
• Hyphens (-)

4. If you want to enter additional information about the new module, type it in 
the Description box.

5. By default, the new module’s object identifiers start at 1 and have no prefix. 
If you want to override the default, use the Start at and Prefix boxes.

6. Use the Include radio buttons to specify what you want to copy:

• Click All information to copy everything.
• Click Headings only to copy only objects that have headings and only 

the Object Heading text for those object. 

7. Click OK.
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The new module is created. It inherits its access rights from its parent folder or 
project.

Comparing baselines
DOORS records changes to data and stores complete baselines without using 
third-party tools. DOORS offers an additional feature: baseline compare. This 
provides a list of the differences in the main column between any two baselines 
of the same module, recording:

• Any objects that have been modified in the main column

• Any objects that have been added or deleted in the main column

To compare baselines:
1. Open the module whose baselines you want to compare.

Make sure filtering is turned off. If the module is filtered, and some objects 
are hidden, the results of the baseline comparison can be affected.

2. In the module window, click File > Baseline > Compare.

The Baseline Compare window is displayed:

3. Select the baselines for comparison. The screenshot above shows that 
baseline 2.2 is being compared with current.
Note  DOORS treats the version in the left pane as the older of 

the two that are being compared. so when you perform a 
baseline compare, make sure you select the older baseline 
in the left pane. If you select a more recent version in the 
left pane, DOORS will report additions to the module as 
deletions and vice versa. For example, if you baseline a 
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module, then add some text to an object, then do a 
baseline compare, selecting the current version in the left 
pane, DOORS reports the text you added as being 
deleted. This is because the version selected in the left 
pane (as far as DOORS is concerned, the earlier 
version), contains text that does not exist in the version 
selected in the right pane. DOORS therefore reports this 
text as being deleted.

4. Select the Show Baselines option if you want the baseline you selected to 
be opened. A filter is applied to both versions of the module so that only 
objects that have changed since the last baseline are displayed. 

5. Click Compare.

DOORS tells you to how many differences there are between the baselines.

6. Click OK.

The Baseline Comparison Results dialog box is displayed with the Plain 
View tab selected.

Select the Redlining View tab if you want to see the changes as redlined text. 
Deletions are shown as red text with strikethrough, and insertions as blue text 
with underline.
If you selected the Show Baseline option in Step 3, the baseline is opened and 
objects that have changed are displayed.

Deleting a baseline
If a baseline is no longer needed it can be deleted. You must be a Database 
Manager or Custom user with Manage database powers to delete a baseline, and 
baseline deletion must be enabled for the database. The database default is to not 
allow baseline deletion. If you want baseline deletion to be enabled, contact your 
DOORS administrator.

Note  When a module is baselined all the history information 
stored in the module since the last baseline is transferred to 
the baseline. If you delete a baseline you are deleting the 
module history for that period. As a baseline deletion is not 
reversible you may want to archive the module before 
deleting the baseline so that it can be restored should you 
need to access that history information.

To delete a baseline:
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1. Click File > Baseline > Delete.

2. Select the baseline you want to delete.

If the baseline is part of a baseline set, the name of the baseline set is to 
which it belongs is displayed in the Baseline Set box. To see more 
information about the baseline set, click View.

3. Click Delete.

4. Click Confirm to delete the baseline.

The baseline remains in the baseline list and your username and the date of 
the deletion are displayed in the Deleted By and Deleted On columns.

Note  If the baseline is part of a baseline set that is currently open, 
you can’t delete it. 
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19 Using Electronic Signatures
This chapter contains the following topics:

• Viewing signatures

• Signing a baseline

• Including signature information in printouts

Viewing signatures
To view signatures that have been made against a baseline:
1. Click File > Baseline > View.

The View Baseline dialog box is displayed.

2. Select the baseline whose signatures you want to view and click Signatures.

The Baseline Signatures dialog box is displayed. 

Signatures that have been made against the baseline are displayed in the upper 
pane of the dialog box. The following information is displayed in the columns in 
the upper pane:

Column name Description 

Signatory The DOORS Username of the user who signed the baseline.

Date/Time The date and time that the baseline was signed. Signatures are 
displayed in full chronological order.
For more information, see the section on understanding how 
dates and times are recorded in Managing Telelogic DOORS, 
which is part of the DOORS documentation set.

Label If DOORS was configured to use Signature Labels when the 
user signed the baseline, the label the signatory selected is 
displayed here. If signature labels were not being used when 
the user signed the baseline, this is blank.

Full Name If the DOORS user has a Full Name, it is displayed here.
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To see more information about a signature, select it. The following information 
is displayed on the tabs in the lower pane of the dialog:

Signing a baseline
To sign a baseline:
1. In the baselined module click File > Baseline > View.

The View Baselines dialog box is displayed.

2. Select the baseline you want to sign and click Signatures.

Any signatures that have been made against the baseline are displayed in the 
upper section of the Baseline Signature dialog box in chronological order. 
For details of the information that is recorded when you sign a baseline, see 
“Viewing signatures,” on page 295.

3. Click Sign
The Add Signature dialog box is displayed.

Note  The Sign button is only activated once a baseline has 
been configured for sign off. If the Sign button is still 
unavailable after the baseline has been configured for 
sign off, it is because you have insufficient access rights, 
or the module has not been set up to use electronic 
signatures. In both of these instances contact the module 
owner.

Tab name Description

Comments If the user added any comments when signing the baseline, 
they are displayed here.

Details Database settings often change during the life-cycle of a 
module, so the Details tab displays information about the 
database at the time the signature was made.

• If the database was configured to use passwords, 
“Signatory was required to re-authenticate” is displayed. If 
passwords were not in use “Signatory was not required to 
re-authenticate” is displayed.

• Any restrictions on access are recorded.

• The signature labels that were available to the user when 
signing the baseline are listed.
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4. Select a Signature Label from the drop-down list and add any comments to 
the Comments field. For example, you may want to state a reservation 
about a certain part of the module. Remember that once you add the 
signature you are unable to edit any part of it.

If the module owner has chosen not to use signature labels, the Signature 
Labels field is unavailable. You will still be able to add comments to make 
the meaning of your signature clear.

A Full Name may have been assigned when the Database Manager created 
your user account. If so, your Full Name is displayed, and is included with 
your electronic signature. 

5. Click OK.

The Reconfirm User Details dialog box opens.

6. Type your DOORS Username and Password (if required) and click OK.

The dialog is dismissed and your signature is added to the list of signatures in 
the Baseline Signatures dialog box.

Including signature information in printouts
To include signature information in a print out:
1. In the formal module, click File > Page Setup.

The Page Setup dialog is displayed.

2. Click the Layout tab and select the Include Signature Information check 
box.
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A page displaying the signature information is included after the title page 
when the module is printed.
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20 Printing reports
This chapter contains the following topics:

• Using print preview

• Printing

• Applying saved page setups

• Creating page setups

• Creating a report

• Printing and Managing reports

Using print preview
Use print preview to see what you’re about to print, before you actually print it. 
If you like what is displayed, you can print directly from the Print Preview 
window.
To use print preview:
1. Open the module and set up the view you want to print.

The main column is always printed, even if it is not displayed in the view. If 
the main column is not displayed in the view, no table of contents is created 
or printed.

2. Click File > Print Preview.

3. In the Printer box, select the printer you want to use.

4. Use the Preview range radio buttons to select the pages you want to 
preview:

• Click Selected objects to preview the objects that are currently selected 
in the module. If an object in a table is selected, the whole table is 
previewed.

• Click All if you want to preview all the data in the current view.
• Click Current if you want to preview the page that contains the current 

object. 

If your current page setup includes a title and/or contents page, the title 
and/or contents pages are included with the current page.

• Click Range if you want to preview a range of pages, and then type the 
start and end page numbers in the from and to boxes. 
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If your current page setup includes a title and/or contents page, the title 
and/or contents pages are included with the page range you select here.

5. Click Preview.

The Print preview window is displayed.

It shows what the selected pages would look like if you printed them. It 
assumes that you’ll use your current page setup.

You can scroll through the printed pages using PAGE UP, PAGE DOWN, 
and the ARROW keys.

If your current view is too wide to fit on the printed page:

• The data for each object spans two or more printed pages.
• The page number of each printed page has a letter of the alphabet added 

to the end of it. For example, if page five spans three pages, they are 
numbered 5A, 5B, and 5C.

6. After the Starting printed page number, “of n” is displayed, where n is the 
total number of module pages you selected in Step 4. A module page means 
what you would get on a single printed page if the printed page was infinitely 
wide.

7. To zoom in or out, use the Scale drop-down list. This only affects what is 
displayed in the Print Preview window. It doesn’t affect the printed pages.

8. To display each module page on a separate row, select the Use vertical page 
breaks check box.

This makes each new module page start on a new row in the Print Preview 
window. Page 1A is displayed above page 2A, and so on. You can see at a 
glance how many printed pages you’ll get for each module page.

9. To print the pages, click Print.
The standard Print window is displayed, allowing you to specify which 
printer you want to use, what pages you want to print, and so on. Use the 
Print window’s context sensitive help for more information.

Printing
To print a module:
• In the module window, click File > Print.

A standard Print window is displayed that lets you specify which printer you 
want to use, what pages you want to print, and so on.
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Note  You can also print from the Print Preview window and 
the Report Manager (see “Using print preview,” on 
page 299, and “Printing and Managing reports,” on page 
308).

Applying saved page setups
You can control the appearance of modules when they are printed by using page 
setups. DOORS provides one predefined page setup, the Standard layout, 
which is used by default when you print a module. If you or any other user has 
created and saved a page setup, it is available to all DOORS users from the Page 
setup dialog in any formal module.
To apply a saved page setup to your module:
1. In the module window, click File > Page Setup.

A list of page setups is displayed in the left pane of the Page setup dialog 
box.

2. Select the page setup you want to use.

You can view the settings associated with that setup by looking at the tabs 
on the right of the dialog box. If you want to print the module using these 
settings, click OK.

If none of the available page setups is suitable, you can base a new page 
setup on an existing one. Select the page setup that is most like the one you 
want to create, and edit it. For information on how to create a new page 
setup see “Creating page setups,” on page 301

Creating page setups
To create or edit a page setup:
1. In a module window, click File > Page Setup.

2. On the left, a list is displayed of all the saved page setups for the database, 
and on the right, a series of tabs that can be used to define the layout of the 
module when it is printed. To see the settings associated with a saved page 
setup, select it in the left pane, and use the tabs to view the settings.

Note  If you have not edited the settings on the page setup 
dialog, the module is printed using the Standard layout, 
which is provided with DOORS. If no one has created 
and saved a page setup, the only setup listed in the left 
pane is Standard layout.
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3. Select the page setup that is most like the one you want to create. You can 
change it to suit your needs.

4. Use the Format tab to specify whether you want to print the module in 
Table format or Book format. The options that are available on this tab 
depends on which format you select.

Format 
selected

Appearance when printed Options available for this 
format

Table Includes all the columns that 
are displayed in the current 
view, and looks the same as 
the module does on screen.
The main column is always 
printed, even if it is not 
displayed in the view.

Cells
You can select whether the 
table cells have borders, 
shading or are not marked.
Column titles
You can select whether 
column titles display on every 
page or only on the first page.

Book Each object’s Object 
Heading and/or Object 
Text is printed on a new line, 
followed by the attribute 
values held in any other 
displayed columns. For each 
displayed column, the column 
title is printed along with the 
value for that object.

You can choose whether to 
include or omit attributes with 
null values from your print 
out. If you include attributes 
with null values, each object 
that is printed will have a list 
of the displayed columns 
under it, even if the object has 
no values in any of those 
columns. If you omit 
attributes with null values, 
only columns that contain an 
attribute value for the object 
will be printed. 
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5. Use the Layout tab to specify the layout you want.

Select this check 
box

To

Include title page Print a title (front) page. By default, the following 
information is printed on the title page:

• The path to the module from the parent project

• The module name

• The module version

• The name of the user who prints it

• The date the module is printed

Include filter 
criteria on title page

Include on the title page details of the filter criteria that 
are applied to the module. If the module is not filtered 
then No filter applied is printed on the title page.

Include sort criteria 
on title page.

Include on the title page details of the sort criteria that are 
applied to the module. If the module is not sorted, then 
No sort applied is printed on the title page.

Include signature 
information

Insert after the title page a page containing all the 
signature information for the module. This check box 
only applies if the module is configured to use electronic 
signatures on baselines.

Include contents up 
to level

Include a contents page when the module is printed. The 
heading levels that are displayed in the contents page are 
defined using the drop-down list to the right of the box. 
For example, select 2 to print level 1 and 2 headings in the 
contents page.
If the main column is not displayed in the view that you 
are printing, no table of contents is created or printed.

Insert page breaks 
up to level

Insert page breaks when the module is printed. Use the 
dropdown list to define what heading level will trigger a 
page break. For example, select 2 to start a new page for 
every level 1 heading and every level 2 heading.

Show change bars Print change bars.
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6. Use the Paper Size tab to define the paper size and page orientation. The 
dimensions are measured in either inches or millimeters, depending on your 
current user options settings. To change the settings, click Tools > Options 
in the DOORS Explorer, then edit the Settings tab.

7. Use the Margins tab to define the page margins. The values are measured in 
either inches or millimeters, depending on your current user options settings. 
To change the settings, in the DOORS Explorer, click Tools > Options, 
then edit the Settings tab.

8. Use the Headers tab to define headers for the title page, the contents pages, 
and the body pages. The body pages are the pages that contain the module 
content.

Field Description

Paper size Select the paper size you want to use.
If you select Custom, type the page width and height in the 
Width and Height boxes.

Width The width of the printed page. This field is greyed unless the 
paper size is Custom. 

Height The height of the printed page. This field is greyed unless the 
paper size is Custom.

Portrait Select if you want the page orientation to be portrait.

Landscape Select if you want the page orientation to be landscape.

Field Description

Top Enter the distance you want between the top of the page and 
the top of the first line on the page.

Bottom Enter the distance you want between the bottom of the page 
and the bottom of the last line on the page.

Left Enter the distance you want between the left edge of the page 
and the left margin.

Right Enter the distance you want between the right edge of the 
page and the right margin.
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You can either type the text that you want to be displayed in page headers 
directly into the appropriate box (Left, Middle or Right), or use rich text 
codes. Rich text codes automatically generate their associated value at print 
time. For example, use &N to include the page number:

You can combine text and codes. Enter Page &N of &C to print Page 1 of 
15, for example.

You can apply rich text formatting to header text. Select the text or rich text 
codes, then right-click and select the rich text format you want to apply.

9. Use the Footers tab to define footers for the title page, the contents pages, 
and the body pages. The body pages are the pages that contain the module 
content.

You can either type the text that you want to be displayed in page footers 
directly into the appropriate box (Left, Middle or Right), or use rich text 

Code Generates

&N Page number. Title pages aren’t numbered. Contents pages use 
roman numerals.

&C Total number of pages (for body pages only).

&M Module name.

&P Project name.

&I Database name.

&L Module location from the parent project.

&V Module version. 
If it is a baseline, then Baseline is printed along with the 
version number. If it is the current version, then Version is 
printed along with the version number.

&U Session username.

&D Session date.

&T Time of printing.

&A DOORS product name.

&B DOORS product version.
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codes. Rich text codes automatically generate their associated value at print 
time. For example, use &N to include the page number:

You can combine text and codes. Enter Page &N of &C to print Page 1 of 
1, for example.

Rich text formatting can be applied to footer text. Select the text or rich text 
codes, then right-click and select the rich text format you want to apply.

10. If you want to use this page setup again, or if you want to make it available to 
other users, you can save it. 

To save your page setup:

a. Click the Save as button on the left side of the dialog box.

b. Give your new page setup a name.

c. Click OK.

Code Generates

&N Page number. Title pages aren’t numbered. Contents pages use 
roman numerals.

&C Total number of pages (for body pages only).

&M Module name.

&P Project name.

&I Database name.

&L Module location from the parent project.

&V Module version. 
If it is a baseline, then Baseline is printed along with the 
version number. If it is the current version, then Version is 
printed along with the version number.

&U Session username.

&D Session date.

&T Print time.

&A DOORS product name.

&B DOORS product version.



Using Telelogic DOORS           307

Creating a report

The page setup is saved, and can be used by you or any other DOORS user 
on any module in the database.

11. If you do not want to save the page setup, click OK. Your settings are 
applied to the module, and persist in the current DOORS session. They are 
not available to other modules, and are lost if you select a previously saved 
page setup.

Creating a report
Reports are useful if you regularly print a module using the same view and page 
setup. When you create a report what you are actually doing is associating a 
selected view and page setup with the module for printing purposes. You can 
then print the module at any time from the DOORS Explorer using these 
settings, without having to navigate to and open the module.
You use a wizard to create the report. You can select the view and page setup, 
give the report a name, and save it.
To create a report:
1. Open the module you want to create the report for.

2. Click Tools > Wizards > Report.
The wizard Welcome screen is displayed.

3. Click Next.
4. Select the view you want to show in the report, then click Next.
5. Select the page setup you want to use in the report, then click Next.
6. In the Name box, type the name you want to give the report. This name is 

only used by the Report Manager to identify the report. It isn’t shown in the 
report itself.

The report name mustn’t exceed 80 characters.

7. If you want to enter additional information about the report, type it in the 
Description box. Again, this description is only used by the Report 
Manager. It isn’t shown in the report itself.

8. Click Next.
9. Click Finish to save the report details.

10. Click OK.

Note  To print the report, follow the instructions in “Printing and 
Managing reports,” on page 308.
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Printing and Managing reports
Once you have saved a report, it is accessed using the DOORS Explorer, not the 
module. A report is not a copy of a module at a particular point in time which 
can be printed later. It is an association between a module, a page setup and a 
view. When you print or view a report the module is opened read only, with the 
view that you selected when creating the report displayed, and the page setup 
you selected applied.
To print, view or delete a report:
1. In the DOORS Explorer, select the project that contains the module whose 

report you want to print, view or delete.

2. Click Tools > Manage Reports. 
A list of all the modules that have reports associated with them is displayed. 
Indented below each module is a list of its reports.

3. Select the report, then either:

• Click Print to print it. This opens the module and loads the view 
associated with the report, then displays the standard Print window. Use 
the Print window to specify which printer you want to use, what pages 
you want to print, and so on.

• Click View to open the module and load the view associated with it.
• Click Delete to delete the report. 

4. When you are finished, click Close.
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21 Importing
This chapter contains the following topics:

• Importing from Microsoft Word

• Editing imported Word style information

• Importing plain text files

• Importing RTF files

• Importing spreadsheet files

• Importing FrameMaker files

Importing from Microsoft Word
This topic describes how to import data from Microsoft Word into a module’s 
main column. You import headings and text into the module’s Object Heading 
and Object Text attributes.
You import documents from Microsoft Word into DOORS by exporting them 
from Microsoft Word. 
You must open the target folder or project in the DOORS Explorer before 
Word can export data to it. You must also specify the module you want to import 
to, as described in the following sections. If the module does not exist, it is 
created during import. If the module exists, you are asked if you want to append 
the imported data to the module. If you do not want to append data, the import 
stops.

• Paragraphs in the Word document that have Outline levels 1 to 9 are 
imported as heading objects. 

• You can choose to ignore section numbers in the Word headings. 

• Auto-numbered section numbers are always ignored.

• Paragraphs formatted as Body text in Microsoft Word are stored in the 
Object Text attribute of objects. These are created one level below the 
appropriate heading object.

• OLE objects are imported and stored as OLE objects. 

• Tables are imported as DOORS tables. 

• Bulleted lists are imported as DOORS bulleted lists

• Indented paragraphs in Word have identical indenting applied in DOORS
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• All other styles are imported as object text.

• Unicode and other international data is included in the import.

• If you import a document containing hidden text to DOORS, then export 
the module back to Word, the hidden text will be displayed in the resulting 
Word document.

• You cannot import a document that contains objects created using 
Microsoft Equation 3.0.

You can capture the style formatting of paragraphs in your Word document for 
use in a later export to a new Word document.

To import a document from Word into DOORS:
1. In the left pane of the DOORS Explorer, click the project or folder that you 

want to import the document into.

You must have create access to this folder or project.

2. Start Word and open the document you want to send to DOORS.

3. Click the Export to DOORS button  on the Word toolbar, or click 
Tools > Export to DOORS.

Note  If you are running DOORS through Citrix, Word must 
also be running through Citrix or the import will not 
work.

4. In the Module Name box, enter the name of the module you want to 
export to.
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5. In the Module Description box, enter additional information about the 
module.

6. Optionally, in the Module Prefix box, enter the object identifier prefix.

7. In the Absolute Numbers Start At box, enter the object identifier starting 
number.

8. If you want to ignore section numbers in Word headings, select the Remove 
header numbers check box.

The auto-numbering produced by DOORS may be different from the 
auto-numbering in the original document. If you have references to any of 
them, you should store the original numbers.

9. If you want to capture Word paragraph styles, select the Capture 
Paragraph Styles check box.

10. Click Export.
The module is created and opened, and the document is imported to it. 
The Progress panel on the Export to DOORS dialog gives information on the 
export progress.

Editing imported Word style information
If you capture paragraph style information when you import data from 
Microsoft Word, the style information is stored in the Paragraph Style attribute. 
The Paragraph Style attribute contains one or more <attribute: style> pairs. 
Each <attribute:style> pair defines the style that is applied to an attribute’s 
value when you export the data back to Word.
You can change the style information if, for example, you want to export the 
module to a Word file that uses a template with special styles.
You can edit the Paragraph Style attribute value in-place, but it is more efficient 
to use the Edit Paragraph Style Attribute tool. 
The Paragraph Style attribute can store as many <attribute: style> pairs as 
you want.
The value of the Paragraph Style attribute is object specific, but it can contain 
style information for more than one attribute. This means that you could, for 
example, specify one style for the Object Heading attribute, and a different 
style for the Object Text attribute. If you then exported the object, Word would 
apply different styles to the data in each attribute.
The tool can manipulate the styles either for the current object or for every 
object in the current view.
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Two settings have special significance:

• The Attributes setting

• The Properties setting

The Attributes setting lets you specify a default style which applies to every 
attribute which is not listed in the Paragraph Style attribute.
The Properties setting lets you specify styles for data in your view which are not 
attribute values, such as layout DXL and object identifiers.
You use the Attributes setting and the Properties setting in the same way as any 
other attributes. They have <attribute:style> pairs like any other values in the 
Paragraph Style attribute.
To run the Edit Paragraph Style Attribute tool:
1. Open the module whose Paragraph Style attribute you want to edit.

2. Click Tools > Support Tools > Edit Paragraph Style Attribute.

3. In the Attribute box, select the attribute that you want to specify a style for.

4. In the Paragraph style box, type the name of the Word style that you want 
to use for the selected attribute.

Note  To delete the paragraph style information for the 
selected attribute, clear (delete all the text in) the 
Paragraph Style box. 

5. If you want to change the Paragraph Style attribute of the current object 
only, click Apply to Current.
If you want to change the Paragraph Style attribute of all objects in the 
current view, click Apply to All.

6. Click Close.

Importing plain text files
The import plain text tool reads a text file and populates the current module 
with objects created from its contents.
The imported file is placed after the current object.
The structure of the object hierarchy and the values of the object attributes are 
determined by the structure and content of the file.
You can use the importer to populate an empty module, or to extend a populated 
module.
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Basic import options

The text file is analyzed to identify paragraphs and headings. 
A paragraph consists of:

• A blank line

• Text

• A blank line

A heading consists of:

• A blank line 

• A line of text that begins with a heading number 

A heading is a numbered paragraph.
Heading numbers consist of any combination of digits and periods that start and 
end with a digit.
When the importer finds a heading, it creates a heading object at the level in the 
object hierarchy that corresponds to the heading number.
When the importer finds a non-heading paragraph, it stores the contents in a 
child of the previous heading object.
When the importer finds an enumerated list item, it creates a child object of the 
previous heading object.
You can tell the importer to create individual objects for each sentence in a 
paragraph or in a heading, or to import the entire text file into a single object.

Controlling text decomposition

The text decomposition level determines how objects are created during 
importing.
There are four levels of text decomposition:

• None
No decomposition occurs.

One object is created after the current object, and the entire file is stored in 
the Object Text attribute.

Advanced functions cannot be used.

• Paragraph
An object is created for each heading.

An object is created for each paragraph.
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• Sentence
An object is created for each sentence in a heading.

An object is created for each sentence in a paragraph.

• Sentence with keywords
The discovery of a sentence containing a keyword triggers the creation of a 
new object for the next sentence. The sentence containing the keyword is 
stored in the Object Text attribute. 

All succeeding sentences are appended to the object text, until another 
sentence is found containing a keyword, which triggers the creation of the 
next object.

Note  The sentence that contains the keyword becomes the last 
sentence in the object. A new object is created for the 
sentence that immediately follows the keyword sentence.

Attribute value assignment

The Object Heading attribute is assigned the value of the string that:

• Starts with the first non-white-space character that follows a heading 
number.

• Ends with the last non-white-space character that precedes the first 
occurrence of a delimiter. A delimiter can be any of the following:

• period space [. ] 
• semicolon space [; ]
• colon space [: ] 
• space hyphen space [- ]
• carriage return

If a break is detected in the heading number sequence, heading objects are 
created to represent the missing headings in the sequence. You can specify the 
Object Heading that is assigned to the inserted heading objects.
By default, when the importer finds a heading paragraph, the object text is 
assigned the value of the string that:

• Starts with the text following the heading end delimiter.

• Ends with last non-white-space character that precedes a blank line.

You can override this default behavior by using advanced options. 
When the importer finds a text paragraph, the Object Text attribute is assigned 
the value of the paragraph text.
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The Object Short Text attribute of heading objects, is assigned the value of the 
Object Heading attribute (excluding the heading delimiter and security 
classification).

Advanced importing options

The advanced importing options let you: 

• Control how list items are imported.

• Capture embedded data from the file.

• Control how carriage returns and chapter numbers are handled.

• Select the encoding you want to use to interpret the file.

Controlling list import
You can control importing of enumerated lists and document lists.
An enumerated list item is a line of text that starts with one of the following:

• <optional white space> list_id. <mandatory white space>

• <optional white space> list_id) <mandatory white space>

• <optional white space> (list_id) <mandatory white space>

where list_id is one of:

• Character in the range a - z

• Character in the range A - Z

• One or more arabic digits

• One or more roman digits

A document list item is a line of text that contains a user-specified delimiter. 
Document list items do not need to be preceded by a blank line. 
There are two options for handling enumerated lists:

• Extract enumerated list items
One object is created for each list item. The object hierarchy reflects the 
structure of the list. 

The Object Short Text is assigned the value of the first non-white-space 
character and succeeding characters of the list item, up to the first period 
followed by a space [. ]. It is truncated to 80 characters.

• Extract document list items using delimiter
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If a document list item is found, an object is created as a child of the 
previous heading object. The Object Heading attribute is assigned the 
value of the text that precedes the delimiter. 

The Object Text attribute is assigned the value of the text that follows the 
delimiter.

Capturing embedded data
You can capture additional data embedded in the text file during the import.
The data you want to capture is stored in attributes you specify before importing 
begins.
There are three options for capturing embedded data:

• Heading number
The number of the paragraph (in the text file) that generated an object is 
captured. You can specify the attribute in which the heading number is 
stored. This creates traceability from each object to its origins in the input 
document. The heading number is the paragraph number of the preceding 
heading followed by appropriate section numbering.

• Security classification
Characters in parentheses ( ) preceded by white space and following a 
heading number are security classifications.

You can specify an attribute in which the security classification is stored.

Plain text paragraphs are assigned the same classification as the heading that 
precedes them. Headings without explicit security classifications are assigned 
a default classification (which you can specify).

• Reference
Text in square brackets [ ] is treated as reference information, (for example, 
requirement identifiers). You can specify an attribute in which reference 
information is stored. Multiple references for the same object are stored as a 
comma-separated list.

Controlling line breaks and chapter numbering

Two options control how carriage returns and chapter numbers are handled:

• Preserve carriage returns in paragraph text
Turning this option on lets you preserve carriage returns if the file only has 
carriage returns between paragraphs. 
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Turning this option off lets you auto-wrap the object text, if the text file has 
carriage returns at the end of each line. 

• Preserve chapter numbers using default heading
If there are breaks in the sequence of level 1 headings in the text file, you can 
automatically insert missing level 1 objects by turning this option on. You 
can specify a default value for the Object Heading attributes of the 
inserted level 1 objects.

This feature supports MIL-STD numbering for appendices (for example, 
10.0, 20.0, 30.0).

Importing plain text

The import plain text tool is configurable, and you can save your configuration 
settings in a file for future use. This means you need only define the settings once 
for each file you want to import.
To import a plain text file:
1. Open the module that you want to import the text into.

2. Select the object immediately before the required location for the imported 
text.

3. Click File > Import > Plain Text.
4. Type the name of the file you want to import including the path, or use 

Browse to locate it.

5. Click Import.
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This dialog box anticipates the name of a settings file you might want to load 
or save settings to. Change this if necessary.

6. Select the text decomposition level from the Decomposition level 
drop-down list.

The following table describes each level.

If you choose Sentence w/keyword(s), the Keywords list becomes 
available. Select one or more keywords from the list that you want to trigger 
object creation.

If you choose Sentence or Sentence w/keyword(s), the Abbreviations 
list becomes available. Select one or more abbreviations that you want 
recognized as valid. This avoids incorrect interpretation of abbreviations as 
sentence endings.

7. Click Advanced if you want to use the advanced options. For more 
information, see “Using the import plain text advanced options,” on page 
318.

8. Click Import.
The file is imported after the current object.

Using the import plain text advanced options
The advanced options let you control text decomposition, data capture, list 
importing, line break handling, chapter number handling and text encoding.

Level Description

None The text is imported as laid out in the file, but there is only 
one object.

Paragraph The text is imported with one object for each block of text up 
to an empty line.

Sentence The text is imported with one object for the text up to and 
including each period. A numbered list with a period following 
the number has a separate object for each number.

Sentence w/ 
keyword(s)

The same as Paragraph unless any selected keywords appear. 
Where a keyword appears, the sentence containing the 
keyword becomes the last sentence in the object. A new object 
is created for the next sentence.
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To use the advanced options:
1. Click Advanced on the Configure Import dialog box.

2. Select the Heading Number, Security Classification or Reference check 
boxes if you want to capture data of those types.

The appropriate in attribute and with default boxes are activated.

3. Type the names of the attributes in which the captured data should be 
stored, in each of the active in attribute boxes.

4. Type default values for each of the attributes in the with default boxes.

5. If you want to preserve carriage returns, select the Preserve carriage 
returns in paragraph text check box. 

6. If you want to preserve the chapter number sequence, select the Preserve 
chapter numbers using default heading check box and enter a default 
heading.

7. If you want to create objects for each enumerated list item, select the 
Extract enumerated list items check box.

8. If you want to create objects for document list items, select the Extract 
document list items using delimiter check box and enter the list item 
delimiter. For example, if the list items start with three hyphens in the text 
file, enter three hyphens in the Delimiter field.

Note  The delimiter should be a string that does not occur in 
normal text. If the delimiter is found in normal text, the 
import creates an object for the text following it. For 
example, if the list items start with a single hyphen, any 
text following a hyphen is treated as a list element in the 
import.

9. If you want to limit the heading length, select Maximum heading length 
and enter a maximum length.

10. If the text decomposition level is Sentence or Sentence w/keyword(s), 
add or remove keywords and abbreviations appropriately. For more 
information, see “Adding and removing keywords or abbreviations,” on page 
320.

11. Select the encoding that you want to use to interpret the file. The Encoding 
list contains a list of the code pages that are available on your machine. Select 
the encoding that was used when the plain text file was created. You can 
check if you have selected the correct encoding by looking at the output in 
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the preview pane. If the encoding is not correct, the preview pane may 
display symbols instead of text.

12. Click OK.

Adding and removing keywords or abbreviations
You can only add or remove keywords if the text decomposition level is set to 
Sentence w/keyword(s).
To add a keyword or abbreviation:
1. Type the keyword or abbreviation in the appropriate field of the Advanced 

Options window.

2. Click Add to the right of the entry.

The keyword or abbreviation is listed in the appropriate field in the Configure 
Import window.
To remove a keyword or abbreviation:
1. In the Configure Import window, select the keywords and abbreviations 

you want to remove.

2. Click Advanced.

3. Click the appropriate Remove button.

Importing RTF files
The Import RTF tool reads an RTF (Rich Text Format) file and populates the 
current module with objects created from its contents. Unicode and other 
international data is included in the import.
The imported objects are placed after the current object.
Before you can import an RTF file, you need to map the styles used in the RTF 
file to appropriate DOORS features. The tool attempts to map the RTF heading 
styles to DOORS features for you.
You can save a style mapping for future use.
If the tool finds any text before the first heading in the RTF file, the first object 
created has an Object Heading of Front Matter, and the text is stored in the 
Object Text attribute of the child of the heading object.
If the tool finds a picture embedded in a paragraph, it creates three objects. The 
first stores the text that precedes the picture; the second stores the picture; the 
third stores the text that follows the picture. The system attribute PictureNum, 
held in the object, stores a number that uniquely identifies the picture.
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RTF tables are imported as DOORS tables. Pictures contained in table cells are 
not imported.
Importing a document in RTF format may use more resources than importing 
the same document as a Microsoft Word document.
When you import an RTF document, a number of module attributes are created. 
These are used if the module is exported back to RTF, so that the resulting file 
has the same properties as the original.
To import an RTF file:
1. Open the module that is to contain the imported file.

2. Select the object immediately before the required location for the imported 
file.

3. Click File > Import > RTF.

4. Type the name of the RTF file you want to import including the path, or 
click Browse to locate it.

5. Click Import.

You use the Map RTF Styles dialog box to tell DOORS how to handle 
each RTF style in the file. The importer maps the heading styles that it can, 
and maps all other styles to object text.
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6. Click one or more RTF styles that you want to map to a specific DOORS 
feature.

Double-clicking a selected style deselects all other selected styles, and selects 
the style you clicked.

7. Click the DOORS feature you want to map the styles to.

The mappings are defined.

8. Repeat Step 4 and Step 5 until all the styles are correctly mapped.

9. If you want to save the style mapping, enter the name of a settings file in the 
Settings file box, or use Browse to locate it, and click Save.

10. Select the styles that are in the document to be imported.

This is necessary for DOORS to treat the headings correctly. If you do not 
select the styles in the document, the first heading is made a Heading Level 1 
during the import, regardless of its actual level.

11. Click Import.
The file is imported after the current object.
A progress bar shows how much has been done.

Importing spreadsheet files
The import spreadsheet tool imports comma separated value (CSV) and tab 
separated value (TSV) files that have been created with packages such as 
Microsoft Excel or Microsoft Access.
In CSV and TSV files, the rows and columns of the spreadsheet (or database 
table) are stored as lines of text.
Normally, each line represents a spreadsheet or database row, and contains data 
from each spreadsheet or database column. Each data item in a line is separated 
by a comma, or a tab, depending on the type of the file. However, if the file 
contains new line characters as part of the data, the strings that contain the new 
line characters are enclosed in quotes.
The import spreadsheet tool creates one object for each line in the file, and 
derives object attribute values from the TSV or the CSV data.
You can assign attribute values in two ways:

• Using an attribute list

If you use an attribute list, you create a list of existing attributes that 
correspond with the columns in the file you want to import. The attribute 



Using Telelogic DOORS           323

Importing spreadsheet files

types must be appropriate for the data in each column, or importing fails. 
Where the importer encounters empty fields, it assigns default values.

• Using column labels

If you use column labels, the contents of the fields in the first line (the 
column labels) determine which attribute is used for each column.

Note  The importer expects a label for the first column. If the 
spreadsheet does not have a label for the first column, you 
should add one; otherwise, the allocation of attributes does 
not work correctly. 

If the attributes do not exist, the tool creates them. The attribute types are 
normally derived from the type of data found in the columns, but you can 
choose the type you want from a list of defined types.
If a spreadsheet has been imported, and you subsequently change it, you can 
update the imported data by re-importing the file using the Update existing 
objects option. This option also creates new objects if any have been added to 
the spreadsheet.
If you decide to modify a subset of your data after you have imported it, you 
should filter the data you want to change, export the filtered data using the 
export spreadsheet tool, modify the exported data and then re-import it with the 
same filter applied. By using the Update Display set only option you guarantee 
that the correct objects are updated.
Data items in a CSV or TSV file can have integer, real, date, or string values. 
Strings are typically contained within double quotes, and can contain commas, 
tabs, and line breaks. Double quotes can be imported if they are duplicated. For 
example, looking at the CSV file with a text editor, the following string:
"This string has a comma, which is not imported and a double quote "" 
too"
is imported as:
This string has a comma which is not imported and a double quote " too

Importing a spreadsheet or database file
To import a spreadsheet or database file:
1. Open the module that you want to import the spreadsheet into.

2. Select the object immediately before the required location for the imported 
text.

The imported file is placed after the current object.
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3. Click File > Import > Spreadsheet.
4. If you are importing a CSV file, select the Comma radio button. If you are 

importing a TSV file, select the Tab radio button.

5. In the Input file box, type the name of the file you want to import or click 
Browse to locate it.

6. The following table describes the other options on the Import Spreadsheet 
dialog box.

If you want to: Then

Import the file using an attribute list Select From list.
The Attributes to import and 
Existing attributes sections become 
available. Define or load an attribute 
list. For more information, see 
“Defining attribute lists for import,” 
on page 325 or “Loading saved 
attribute lists for import,” on page 326.

Import the file using column labels  Select By column labels. 

Import the file to an empty module or 
to append objects to a populated 
module

Select Create new objects.

Update the attribute values of objects 
already in the module, and add objects 
that have been added to the CSV file

Select Update existing objects. 

Update every object in the module Select the All objects radio button. 
This option is only available if Update 
existing objects is selected.

Update objects in the current filter Select the Display set only radio 
button. This option is only available if 
Update existing objects is selected.
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7. Click Import.
If you are importing by column labels, and one or more attributes need to be 
created, you must confirm the creation of each attribute.

• If you want to change the type of an attribute before the attribute is 
created, click Choose different type. For more information, see 
“Choosing attribute types,” on page 327. 

• If you want to create an attribute without changing its type, click 
Confirm.

8. If you selected to create new objects, the file is imported. If you selected to 
update existing objects, the Select Key dialog box is displayed.

You use this dialog box to specify which column contains data that can 
uniquely identify every object that is created (or updated).

9. Select the column that uniquely identifies the objects, and click Select.
Importing runs to completion. When it is complete, a message box tells you 
how many objects were created or updated.

10. If you imported by column labels, and created new attributes, you must 
create new columns in the module to display those attributes. After creating 
the columns, save a new view.

Defining attribute lists for import
To define an attribute list:
1. On the Import Spreadsheet dialog box, select the From list radio button.

Specify the encoding that you want to 
use to interpret the file.

Click the Advanced button. The 
dialog box expands to display an 
encoding list, which contains a list of 
the code pages that are available on 
your machine, and a preview pane. 
Select the encoding that was used 
when the CSV file was created. You 
can check if this is the correct 
encoding by looking at the output in 
the preview pane. If the encoding is 
not correct, the preview pane may 
display symbols instead of text.

If you want to: Then
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The Attributes to import and Existing attributes boxes become available.

2. From the Existing attributes list, select an attribute.

3. Click Add.

The selected attribute is listed in the Attributes to import list.
4. Add, insert or delete attributes from the list until the attribute list matches 

the order of the columns in the file you want to import. If there are columns 
in the file that you do not want to import to DOORS, add ignore to the 
attribute list for that column. For example if you have three columns in a 
spreadsheet, and you only want to import information from column one and 
column three you would add attribute 1, ignore and attribute 2 For more 
information, see “Using attribute list elements for import,” on page 326.

5. Click Save.

6. Type the name and path of a file to store the attribute list, or click Browse to 
locate it.

7. Click Save.

The attribute list is saved. It can be loaded and used later. For more information, 
see “Loading saved attribute lists for import,” on page 326.

Using attribute list elements for import

To insert an attribute into an attribute list:
1. In the Import Spreadsheet dialog box, select the attribute you want to add 

to the list from the Existing attributes list.

2. From the Attributes to import list, select the attribute before which you 
want to insert the new attribute.

3. Click Insert.
To delete an attribute from an attribute list:
1. From the Attributes to import list, select the attribute you want to delete.

2. Click Delete.

Loading saved attribute lists for import

To load an attribute list:
1. In the Import Spreadsheet dialog box, click Load.

2. Type the name of the attribute list file you want to load including the path, or 
use Browse to locate it.
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3. Click Load.

The attribute list is loaded, and the window is updated.

Choosing attribute types
When you import a spreadsheet by column labels, attributes are created in which 
the spreadsheet data is stored. The attribute types are derived from the types of 
data found in each column. 
You are asked to confirm the type or choose a different one.
To choose a different attribute type:
1. Click Choose different type.

2. Select a new type for the attribute from the Attribute types available box.

3. Click OK.

Importing FrameMaker files
The import FrameMaker tool reads a Maker Interchange Format (MIF) file and 
populates the beginning of the current module with objects created from its 
contents. Before you can import a FrameMaker file, you have to map the styles 
used in the MIF file to suitable DOORS features. You define the mapping as 
part of the import process. You can save the style mapping for future use.

• The FrameMaker importer only reads text from Text Flow A. Any text not 
in Text Flow A is not imported.

• Any text formatted in a style mapped to the DOORS feature Ignore, is not 
imported.

• Text not mapped to any DOORS feature is imported as object text.

• Pictures are not imported. References to pictures are stored in the 
FramePicture attribute.

• International data is imported using encoding that is supported by the MIF 
format.

Using the Import FrameMaker tool advanced options you can:

• Remove the auto-numbering from auto-numbered headings, to avoid 
confusion with DOORS heading numbers.

If you decide not to remove auto-numbering, the numbers are enclosed in 
square brackets ( [ ] ).
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• Create the Autonum attribute, which is assigned the value of auto-numbers, 
a bullet or a dash wherever auto-numbers, bulleted list items or dashed list 
items are found.

• Save MIF style definitions from the file in a module attribute.

• Select the encoding to be used to interpret the file in DOORS.

Saving style definitions makes your modules bigger, but if you subsequently 
export data that you have imported, the style definitions are also exported. That 
means you don’t have to import the exported MIF file using a template for the 
styles to take effect.

Importing a MIF file

To import a MIF file:
1. Click File > Import > FrameMaker.
2. Type the name of the file you want to import including the path, or use 

Browse to locate it.

3. Click Import.

4. Click one or more FrameMaker styles that you want to map to a specific 
DOORS feature.

Double-clicking a selected style deselects all other selected styles and selects 
the style you clicked.
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5. Click the DOORS feature you want to map the styles to.

The mappings are defined.

6. Repeat Step 4 and Step 5 until all the styles are mapped.

7. If you want to save the style mapping, enter the name of a settings file in the 
Settings file box and click Save.

8. If you want to use advanced options, click Advanced. For more 
information, see “Using the import MIF advanced options,” on page 329.

9. Click Import.
The file is imported. A progress bar shows how much has been done.

Note  A DOORS module that has been exported to a MIF file 
cannot be imported back to DOORS until it has been loaded 
and saved in an application such as FrameMaker that can 
read MIF files.

Using the import MIF advanced options

To use the Import FrameMaker advanced options:
1. In the Map FrameMaker 5 styles dialog box, click Advanced.

2. If you want to store auto-numbering and list element identification in the 
Autonum attribute, select the Create Autonum attribute to store 
autonumbers and list item identifiers check box.

The auto-numbering produced by DOORS may be different from the 
auto-numbering in the original document. If you have references to any of 
them, you should store the original numbers.

3. If you want to remove auto-numbering from imported headings, select the 
Remove autonumbers from headings check box.

If you want heading numbers in square brackets ( [ ] ), clear the check box.

The auto-numbering produced by DOORS may be different from the 
auto-numbering in the original document. If you have references to any of 
them, you should not remove them.

4. If you want to save the style definitions in your module, select the Keep 
style definitions in module attribute check box.

5. Click OK.
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22 Exporting
This chapter contains the following topics:

• Exporting to Microsoft Word

• Exporting to Microsoft Excel

• Exporting to Microsoft Outlook

• Exporting to Microsoft PowerPoint

• Exporting to HTML

• Exporting to plain text

• Exporting to RTF

• Exporting to spreadsheet

• Exporting to FrameMaker

Exporting to Microsoft Word
This topic describes how to export your current view to Microsoft Word. 

• If your module contains Unicode or international data, this is included in the 
export and is encoded in rich text format.

• If your module contains hidden text that was previously imported from 
Word, the hidden text is displayed in the Word document when the module 
is exported.

To export to Microsoft Word:
1. In the module window, click File > Save.

This saves the module. It makes sure that the data you export includes any 
changes you made recently.

Note  When you export modules to Microsoft Word, DOORS 
uses the Windows clipboard. Make sure there is nothing 
on the clipboard that you do not want to lose before you 
export.

2. Click the Export to Word button , or click File > Export > Microsoft 
Office > Word.

Note  If you are running DOORS through Citrix, Word must 
also be running through Citrix or the export will not 
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work. 
 
This option is not available if you do not have Word 
installed on your machine.

3. Use the General tab to specify what data you want to export.

General tab Description

Layout Select either:

• Book to use the book layout, which lists the data on 
separate lines. All the columns in the current view are 
exported.

• Table to use the table layout, which lays the data out as 
a table, just like in DOORS. All the columns in the 
current view are exported.

Include DOORS 
Heading Numbers

By default, the DOORS heading numbers are exported 
with the Object Heading text.
Clear this check box if you don’t want to export DOORS 
heading numbers.

Issue a warning 
when an 
unregistered OLE 
object is exported 
as a picture

Clear this check box if you do not want to be warned that 
the module you are exporting contains unregistered OLE 
objects. Unregistered OLE objects are exported as 
pictures and cannot be activated in Word.

Include empty 
attributes

Select this check box if you want to export attributes that 
do not contain any value to Word. By default DOORS 
does not export empty attributes to Word.
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4. Optionally, use the Advanced tab to specify advanced options.

Advanced tab Description

Use Paragraph 
Style attribute

If you previously imported the data from Word, select this 
check box if you want to use the Word paragraph style 
information that was captured during the import.
This information is stored in the module’s Paragraph Style 
attribute.
The styles named in the Paragraph Style attribute are used 
to format the exported document.

Allow style 
mapping

Select this check box if you want to manually map 
DOORS heading and text levels to the Word paragraph 
styles in the exported document.
For example, you can say that you want level 1 headings in 
DOORS to use the Heading 2 Word style.

Ignore DOORS 
table borders, put 
all borders on all 
cells

By default, the exported Word document uses the same 
table border settings as the DOORS module.
Select this check box if you want to ignore the table 
border settings in the DOORS module, and put borders 
around all the table cells in the Word document.

Ignore DOORS 
column widths in 
table layout export, 
AutoFormat 
instead

By default, in Table layout the widths of the columns in 
the exported Word document match the widths in the 
DOORS module.
Select this check box if you want to ignore the column 
width settings in the DOORS module, and let Word chose 
the column widths.

Use normal 
template

By default, the normal.dot Word template is attached to 
the exported document.
If you want to use another template, clear this check box, 
then type the name of the template file in the Template 
name box, or use Browse to locate the file.

Use horizontal line 
separators in book 
layout exports

When using book format, this will insert line separators 
between objects in the Word document.
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5. Click Export.
6. If you selected the Allow style mapping check box on the Advanced tab, 

the Export to Word Style Mapping screen is displayed.

The list on the left shows what mappings you’ll get. For example, by default, 
level 1 headings in DOORS are mapped to the Heading 1 style in Word, 
and DOORS bullets are mapped to standard Word bullets.

7. When you have finished defining the mapping styles, click Close.

Exporting to Microsoft Excel
You can export your current view to Microsoft Excel. 

Save Word 
document after 
every

The export of large modules to Word occasionally fails 
with the Word error: "the formatting in this document is 
too complex. Please full save the document now". If you 
get this error, select this check box, and specify the 
intervals at which you want to save the Word document in 
the objects box. 
When you export the module, after the first group of 
objects has been exported you are prompted for a name 
and location to which you want to save the document. 
Subsequent saves during the export automatically update 
that document.

To Do this

Change a style 
mapping

Select the appropriate item on the left.
Then in the list on the right, select the Word style you 
want to use.

Save the style 
mapping 
information

In the Settings file box, type the name of the file that you 
want to save the information in, or click Browse to locate 
it, then click Save.

Load style mapping 
information from a 
file

In the Settings file box, type the name of the file that 
contains the style mapping information, or click Browse 
to locate it, then click Load.

Advanced tab Description
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• Columns other than the main column are always exported.

• You can control whether you export the main column too, and if so, which 
of its attributes you export.

• The maximum number of columns you can export to Microsoft Excel is 32.

Note  When you export to Microsoft Excel, rich text formatting 
and special characters are not preserved. If you want to 
preserve rich text formatting, export to a Microsoft Word 
table, then copy and paste the Word table into Excel.

To export to Excel:
1. In the module window, click File > Save.

This saves the module. It makes sure that the data you export includes any 
changes you made recently.

2. Click File > Export > Microsoft Office > Excel.
Note  If you are running DOORS through Citrix, Excel must 

also be running through Citrix or the export will not 
work.

3. Use the Main column drop-down list to specify whether you want to 
export the main column:

• Select Ignore if you don’t want to export the main column.
• Select Object Heading to export the Object Heading attribute in the 

main column.
• Select Object Short Text to export the Object Short Text attribute in 

the main column.
• Select Object Text to export the Object Text attribute in the main 

column.
• Select Object Heading and Text to export both the Object Heading 

and Object Text attributes in the main column.

4. Select the Include column titles check box if you want to export column 
titles.

5. Click Export.
The data is exported to Excel. Excel opens and displays the exported data.
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Exporting to Microsoft Outlook
You can export a DOORS object to Microsoft Outlook, as either a mail message 
or a note:

• The mail message has the Object Heading as its subject, and the Object 
Text as its contents

• The note contains the Object Heading and Object Text
To export the current object to Microsoft Outlook:
1. Click File > Export > Microsoft Office > Outlook.

Note  If you are running DOORS through Citrix, Outlook 
must also be running through Citrix or the export will 
not work.

2. Use the Send object to drop-down list to specify how you want to export 
the object:

• Select Mail to export it as a mail message
• Select Note to export it as a note

3. Click OK.

The object is displayed in a mail message window, or as a new note in the 
Outlook Notes folder. You have to open the Outlook Notes folder to see the 
new note.

Exporting to Microsoft PowerPoint
You can export the Object Heading attribute, and optionally also the Object 
Text attribute, to a Microsoft PowerPoint presentation.
You can export all the objects in the current view or just the current object.
To export to PowerPoint:
1. In the module window, click File > Save.

This saves the module. It makes sure that the data you export includes any 
changes you made recently.

2. If you only want to export one object, make the object you want to export 
the current object.

3. Click File > Export > Microsoft Office > PowerPoint.
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Note  If you are running DOORS through Citrix, PowerPoint 
must also be running through Citrix or the export will 
not work.

4. Use the Export drop-down list to specify what you want to export:

• Select Display set to export all the objects in the current view
• Select Current object to export only the current object

5. Use the Objects to level drop-down list to select the lowest level of object 
that you want to export.

Note  Tables are not exported as one object. Each cell is 
exported as a single object at level 5. If you select a level 
less than 5, no tables are exported.

6. Select the Include title check box if you want to include a title slide at the 
start of the PowerPoint presentation.

7. Select the Ignore Object Text check box if you want to exclude the Object 
Text attribute from the PowerPoint presentation, and export only the 
Object Heading attribute.

8. Click Export.
The exported data is displayed as a PowerPoint presentation, which you can edit 
and save. You may have to resize any exported pictures and OLE objects.

Exporting to HTML
You can export either:

• The current module

• The current module and all the modules that have links to or from it

The exported HTML includes any pictures in the modules, and pictorial 
representations of any OLE objects in the modules. 
If your document contains Unicode or international data, this is included in the 
export.

Note  Because of a know issue with Firefox you cannot export the 
symbol font to HTML if you are using Firefox. For 
information on a workaround, see the Mozilla web site.

To export to HTML:
1. In the module window, click File > Save.
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This saves the module. It makes sure that the data you export includes any 
changes you made recently.

2. Click File > Export > HTML.

3. Use the Layout drop-down list to specify which layout you want:

• Select Book to use the book layout, which lists the attributes for each 
object on separate lines.

• Select Table to use the table layout, which lays the data out as a table, 
just like in DOORS.

4. Use the Export drop-down list to specify what you want to export:

• Select Current to export the current module only
• Select All linked to export the current module and all the modules that 

have links to or from it

5. Select the Links check box if you want to export link information.

Links between objects are represented by hyperlinks. The text of the 
hyperlink tells you the direction of the link, and includes the Object 
Heading, Object Short Text, or Object Text of the object at the other 
end of the link.

6. Select the Icons check box if you want to use these icons to identify the type 
of each hyperlink in the exported HTML files:

 A hyperlink to an object in the same module.

A hyperlink to an object in a different formal module.

 A hyperlink to an object in a descriptive module.

 A hyperlink to a website.

 An external out-link

 An external in-link

7. Select the Change meter check box to include change meters in the 
exported HTML files.

Change meters indicate the age of the module, the age of the object and the 
number of changes made to the object. 

• The blue rectangle represents the age of the module.
• The red rectangle represents the age of the object and when it was last 

modified relative to the age of the module. In the example, the object 
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was created halfway through the life of the module, and was last 
modified today. So, if the module was created four days ago, the object 
was created two days ago.

• The gray box displays the number of times the object has been 
modified.

8. Select the Empty Attributes check box to include attributes with no value 
in the exported HTML files.

9. Type the name of the file you want to export the data to, or use Browse to 
locate it.

10. If the view you are exporting to HTML has auto-indentation switched on, 
the Preserve auto-indentation check box is displayed and is selected by 
default. Clear this option if you don’t want the generated HTML to be 
indented.

11. Click Export.

Exporting to plain text
You can export your current view to a plain text (ASCII) file.
To export to a plain text file:
1. In the module window, click File > Save.

This saves the module. It makes sure that the data you export includes any 
changes you made recently.

2. Click File > Export > Plain Text.
3. Use the General tab to specify the name of the file you want to export to, 

and the data you want to export to it.

General tab Description

File name Type the name of the file you want to export to, or use 
Browse to locate it.

Layout Select either:

• Book to use the book layout, which lists the attributes 
for each object vertically, on separate lines.

• Table to use the table layout, which lays the data out as 
a table, just like in DOORS.
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4. Optionally, use the Advanced tab to specify advanced options.

5. Click Export.

Exporting to RTF
You can export your current view to an RTF (Rich Text Format) file. Exports to 
RTF includes:

Include DOORS 
Heading Numbers

By default, the DOORS heading numbers are exported 
with the Object Heading text.
Clear this check box if you don’t want to export DOORS 
heading numbers.

Include empty 
attributes

Clear this check box if you do not want to export empty 
attributes to the plain text file.

Advanced tab Description

Add line breaks In Book layout, by default each attribute is on a single line.
Select this check box if you want to add line breaks. Use 
the Line width box to specify how long you want the 
lines to be.

Tab separated 
columns

In Book layout, by default space characters are used to 
separate the columns.
Select this check box if you want to use the tab character 
instead.

Line width Use this box to specify the maximum line length, in 
characters.

Encoding Select the encoding you want the exported file to use. This 
defaults to Latin1, or the code page you selected last time 
you exported a file to plain text.
If you select a unicode code page, a Byte Order Marker 
(BOM) is inserted at the start of the file. This means that 
if you open the exported file in a different program, it 
should be able to interpret the file.

General tab Description
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• OLE objects, but not pictures

• Unicode and other international data. This is encoded in rich text format.

To export to an RTF file:
1. In the module window, click File > Save.

This saves the module. It makes sure that the data you export includes any 
changes you made recently.

2. Click File > Export > Rich Text Format.
3. Use the General tab to specify the name of the file you want to export to, 

and the data you want to export to it.

General tab Description

File name Enter the name of the file you want to export to, or use 
Browse to locate it.

Layout Select either:

• Book to use the book layout, which lists the attributes 
for each object vertically, on separate lines. Only the 
Object Heading and Object Text attributes are 
exported.

• Table to use the table layout, which lays the data out as 
a table, just like in DOORS. All the columns in the 
current view are exported.

Include DOORS 
Heading Numbers

By default, the DOORS heading numbers are exported 
with the Object Heading text.
Clear this check box if you don’t want to export DOORS 
heading numbers.

Issue a warning 
when an 
unregistered OLE 
object is exported 
as a picture

Clear this check box if you do not want to be warned that 
the module you are exporting contains unregistered OLE 
objects. Unregistered OLE objects are exported as 
pictures and cannot be activated in the RTF document.
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4. Optionally, use the Advanced tab to specify advanced options.

5. Click Export.

Exporting to spreadsheet
You can export your current view, or selected attributes, to a CSV (comma 
separated value) or a TSV (tab separated value) file. The exported file can be 
imported by packages such as Microsoft Excel or Microsoft Access.
In CSV and TSV files, the rows and columns of the spreadsheet (or database 
table) are stored as lines of text. 
The export spreadsheet tool creates one line in the file for each object being 
exported.
Normally, each line represents one spreadsheet or database row. Each data item 
in a line is separated by a comma, or a tab, depending on the type of the file. 
However, if the data being exported contains new lines, the strings that contain 
the new line characters are enclosed in quotes.
You can create a list of attributes to export or you can export the columns in the 
current view.
You can include the names of the attributes in the file or, if you export the 
display set, you can include the column titles.

Note  When you export to a spreadsheet, rich text formatting and 
special characters are not preserved. If you want to preserve 
rich text formatting, export to a Microsoft Word table, then 
copy and paste the Word table into the spreadsheet.

Advanced tab Description

Break before Use these radio buttons to specify where you want page 
breaks in the RTF file.
For example, if you select 2, page breaks are inserted 
before every level 1 and level 2 object.

Column titles If you’re using Table layout, use these radio buttons to 
specify which pages you want column titles on.

Include borders If you’re using Table layout, select this check box to add 
borders around the exported data, so that it looks like 
your module in DOORS.
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Exporting to spreadsheet

To export to a CSV or TSV file:
1. In the module window, click File > Save.

This saves the module. It makes sure that the data you export includes any 
changes you made recently.

2. Click File > Export > Spreadsheet.
3. If you want to export all the columns in your current view, go to Step 8.

4. If you want to specify which attributes are exported, click the Attributes 
from list radio button.

5. Select the attributes you want to export:

• Select an attribute in the Existing attributes box
• Click either Add or Insert to add the attribute to the Attributes to 

export box:
• Use Add to add it before the selected entry in the Attributes to 

export box.
• Use Insert to add it after.

6. Click Delete to delete an attribute from the Attributes to export box.

Click Save to save the list of attributes to a file. Click Load to load a list of 
previously saved attributes from a file.

7. When the attribute list matches the order of the columns you want to 
export, go to Step 8.

8. Use the Include radio buttons to specify what objects you want to export:

• Click All objects to export all the objects in the module
• Click Display set only to export only the objects in the current view

9. If you want to include the column titles in the first line of the exported file, 
select the Include attribute names/column titles in first row check box. 

10. Use the Data separator radio buttons to specify what type of file you want 
to export to:

• Click Comma for a CSV file
• Click Tab for a TSV file

11. Type the name of the file you want to export to, or use Browse to locate it.

12. If you want to specify an encoding for the exported file, click Advanced.

An Encoding list box containing a list of the code pages that are available 
on your computer is displayed. Select the encoding you want to use.
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Note  Microsoft Excel 2000 does not support UTF-8 CSV files. 
If you are going to view the CSV file using Excel 2000, 
you need to export it with UTF-16 encoding.

13. Click Export.

Exporting to FrameMaker
You can export your current view to a Maker Interchange Format (MIF) file. 
International data that uses encoding supported by the MIF format is included in 
the export.
To export to a MIF file:
1. In the module window, click File > Save.

This saves the module. It makes sure that the data you export includes any 
changes you made recently.

2. Click File > Export > FrameMaker.
3. Use the General tab to specify the name of the file you want to export to, 

and the data you want to export to it.

General tab Description

File name Type the name of the file you want to export to, or use 
Browse to locate it.

Layout Select either:

• Book to use the book layout, which lists the attributes 
for each object vertically, on separate lines. Only the 
Object Heading and Object Text attributes are 
exported.

• Table to use the table layout, which lays the data out as 
a table, just like in DOORS. All the columns in the 
current view are exported.

Include DOORS 
Heading Numbers

By default, the DOORS heading numbers are exported 
with the Object Heading text.
Clear this check box if you don’t want to export DOORS 
heading numbers.



Using Telelogic DOORS           345

Exporting to FrameMaker

4. Optionally, use the Advanced tab to specify advanced options.

5. Click Export.
DOORS creates a partial MIF file. To convert it to a standard MIF file, open it in 
FrameMaker and then save it. Note that you can’t import it into DOORS until 
you have converted it to a standard MIF file.

Issue a warning 
when an 
unregistered OLE 
object is exported 
as a picture

Clear this check box if you do not want to be warned that 
the module you are exporting contains unregistered OLE 
objects. Unregistered OLE objects are exported as 
pictures and cannot be activated in the FrameMaker 
document.

Advanced tab Description

Page breaks at level Use these radio buttons to specify where page breaks are 
inserted in the MIF file.
For example, if you select 2, page breaks are inserted 
before every level 1 and level 2 object.

Page orientation If you’re exporting using Book layout, use these radio 
buttons to select either portrait or landscape page 
orientation.

Use data saved 
from MIF import

If you’re exporting using Book layout, select this check 
box if you’re exporting data that was originally imported 
from a MIF file, and you want to re-use the formatting 
information that was extracted during the import.
Note You need to import the resulting MIF file into 

FrameMaker, using a template that defines the 
relevant styles.

General tab Description
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23 Using the Change Proposal System
This chapter contains the following topics:

• Understanding the Change Proposal System

• Understanding Change Proposals and Suggestions

• Understanding Change Proposal Roles

• Understanding CP partner modules

• Understanding duplicate sets

• Understanding groups

• Creating groups

• Editing groups

• Submitting a change proposal

• Submitting a suggestion

• Understanding the review process

• Showing and reviewing individual change proposals

• Showing and reviewing groups

• Showing and reviewing suggestions

• Showing information about change proposals

• Managing duplicate sets

• Checking the approved changes

• Applying the approved changes

For information on how to set up and manage the Change Proposal System, see 
the DOORS online help or Managing Telelogic DOORS on the Telelogic 
Lifecycle Solutions DVD.

Understanding the Change Proposal System
Managing changes to requirements is a major challenge for any organization. As 
your projects proceed, it is inevitable that you will need to make changes to 
requirements. Any changes, however, are bound to affect other requirements; a 
single change to one requirement can cause a cascade of potential changes to 
requirements throughout your system. With the Change Proposal System (CPS), 
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DOORS offers you functionality to manage changes to the requirements in your 
system. 
CPS allows you to:

• Propose a change to a requirement

You can submit a proposed change, which can be either a Change Proposal 
or a Suggestion.

• Combine change proposals that affect the same requirement

• Group together related change proposals that affect different requirements 

• Review change proposals

You can put together a review team to review and determine the impact of 
the proposed change throughout the whole system.

• Agree on and implement the agreed changes

Using CPS allows you to make sure that proposed changes are not lost or 
overlooked, and gives you a mechanism to make sure you understand the effect a 
change to one requirement will have to other requirements throughout the 
system.

Understanding Change Proposals and Suggestions
You can submit a proposed change, which can be either a Change Proposal or 
a Suggestion.

Proposal Description

Change 
proposal (CP)

This is a detailed proposal about a particular object, or several 
objects in a module. If the CP is against several objects, it is called 
a multiple change proposal.
An example of a CP might be the proposal that the value of the 
Estimated Duration attribute for a particular object should be 
changed from 20 days to 30 days.

Suggestion This is a high-level proposal about a project.
For example, the suggestion that the project should have a test 
plan.
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Understanding Change Proposal Roles

Understanding Change Proposal Roles
Managers set up the CPS, configuring the functionality to fit in with your own 
change management process, and assigning different roles to users. The roles are:

For more information on setting up the CPS, see the DOORS online help or 
Managing Telelogic DOORS on the Telelogic Lifecycle Solutions DVD.

Understanding CP partner modules
Each project that is configured for review has a Change Proposal System 
folder. This folder contains various modules used by the Change Proposal 
System, including:

• A Suggestions module, which contains all the suggestions submitted 
against the project.

• Proposals modules, which contain change proposals.

• If any groups have been created, a Groups module, which contains 
information about the groups in the CP system.

Note  Never edit any of the modules in the Change Proposal 
System folder directly. Always use the procedures described 
in this chapter and in Managing Telelogic DOORS to 
manipulate the modules in this folder.

CP role Description

CP Manager The CP Managers control what data is configured for review, and 
who can review it. They control which users have which CP roles.

Standard These are the ordinary users taking part in the review.
They can submit proposals, and they can see the proposals 
submitted by themselves and by other users. 

CP Reviewer The CP Reviewers are the members of the CP review team 
(sometimes called the Change Control Board, or CCB).
They look at each proposal and decide on the appropriate course 
of action. They decide whether to accept, reject, or defer the 
proposal. 
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For information on how to set up and manage the Change Proposal System, see 
the DOORS online help or Managing Telelogic DOORS on the Telelogic 
Lifecycle Solutions DVD.
Each module configured for review has its own Proposals module, which 
contains all the change proposals submitted against that module. We call it the 
CP partner module. It has a name that begins with Proposals, followed by a 
number. For example, Proposals 35.
The Suggestions and Proposals modules have one section for each user taking 
part in the review. The Object Heading of each section is the unique identifier 
for the user.

Note  If you have DOORSnet, some of the sections may be divided 
into subsections based on e-mail address.

Understanding duplicate sets
Quite often two or more people make similar change proposals. When this 
happens, the CP Review team can place the change proposals in a duplicate set. 
A duplicate set consists of one primary change proposal, and any number of 
duplicates. 
In a duplicate set, only the primary change proposal is reviewed and applied. The 
duplicate change proposals are superseded by the primary change proposal, so 
the proposal you choose to be the primary CP in the set must contain the most 
complete information.
For example, if there are two similar CPs, but one has been raised against a single 
object, and the other is a multiple CP, you should probably make the multiple CP 
the primary CP. If you make the multiple CP a duplicate in the set, only the 
object that is referenced by the primary CP is reviewed and applied.
The duplicate CPs are made read only when they are added to the duplicate set, 
and their status does not change throughout the review process. You can remove 
a duplicate CP from a set at any time. The CP becomes editable, and has the 
status that it had when it was added to the duplicate set.
The status of the set and any comments the review team want to make on it are 
recorded with the primary CP.

Understanding groups
As requirements in DOORS are often related to other requirements in the same 
or different modules, you can create groups of related change proposals. For 
example, if you raise a change proposal against a user requirement, this may 



Using Telelogic DOORS           351

Understanding groups

necessitate changes against related system requirements and test requirements. 
Putting all these change proposals into the same group means that they can be 
reviewed and applied together, or not applied at all.
Groups can contain change proposals from different modules that are 
configured as part of different CP systems. You can only add CPs to groups that 
exist in folders that are direct ancestors of the CP system in the DOORS 
database hierarchy. If you want a group to hold CPs from a number of different 
CP systems and modules, you should create it a the top of the hierarchy of 
folders and projects. This means that it can be navigated to from all of its 
descendents.
A multiple change proposal can be included in a group.
Only the primary change proposal in a duplicate set can be included in a group. 
Duplicates in a duplicate set cannot be included.
There are two types of groups, as described in the following table. 

The user who creates the group is the group owner. Only the group owner can 
change the group type and status.

Group type Description

Master All the change proposals in the group inherit their status from the 
group. 
You should include change proposals in a master group if you 
want to prevent the review team from approving some of the 
change proposals but not others. For example, you may be 
proposing changes to several different requirements, but the 
changes are only valid if they are all considered together. 

Slave Change proposals that are members of a slave group can be 
reviewed independently of the group. The group inherits its status 
from the change proposal that is furthest behind in the review 
process. For example, a slave group that contains change proposals 
with the statuses New, Approved, On Hold and In Review will 
have a status of On Hold.
You should include change proposals in a slave group if you would 
like them to be considered together, but they don’t rely on each 
other for their validity.
Note that the slave group status changes from New as soon as any 
of the change proposals it contains move into the review cycle.
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Creating groups
1. In the DOORS Explorer, select a project or folder that is part of a 

configured change proposal system. This is the folder in which the group 
will be created and saved. 

See “Understanding groups,” on page 350 for information about where in 
the hierarchy you should create groups.

2. Click Tools > Change Proposal System > Manage Groups.
3. Use the Search up and Search down buttons to navigate the hierarchy. You 

can only move between the database root and the folder from which you 
started the Manage Groups tool.

4. Click New.

5. Type a name for the group in the Name box, and select a Type for the 
group. You can change the group type at any time.

6. Click OK.

The group is created and displayed in the list in the Manage Groups dialog 
box. 

Master groups are displayed with the Master icon , and slave groups 
with the Slave icon .
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Editing groups

Editing groups
1. In the DOORS Explorer, select the project or folder that contains the group 

you want to edit.

2. Click Tools > Change Proposal System > Manage Groups.

3. Select the group you want to edit from the list and click Edit.
You can change the group’s Name and Type, and if the group is of type 
Master, the Status.

Submitting a change proposal
For information on change proposals, see “Understanding the Change Proposal 
System,” on page 347.
To submit a change proposal:
1. In the module window, select the object you want to submit the proposal 

against.

If your proposal is to insert a new object, you can select either:

• An object at the same level as the proposed new object.
• An object one level below the proposed new object.

2. Click Tools > Change Proposal System > Submit Proposal, or select the 
object you want to submit the change proposal against and right-click 
Submit Change Proposal.
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The change proposal form is displayed.

The following table describes the options on the form:

Option Description

Applies to ‘n’ object(s) The object IDs of the objects against which the 
proposal is being made.
Note ‘n’ is the number of objects in the list.

Select objects Click this button to add or remove objects from the 
list. If the change proposal is against more than one 
object in the module, it is called a Multiple CP.

Show CPs If there is only one object in the list, and it already has 
change proposals against it, this button is available. 
Click to see the change proposals.
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Submitting a change proposal

Add to group/Remove 
from group

If this change proposal is related to other change 
proposals in this or other modules, you can group 
them together. This means that the CP Review board 
can consider all of the change proposals together and 
decide whether or not to apply them. For more 
information on groups, see “Understanding groups,” 
on page 350.
If you have submitted a CP in the current session and 
added it to a group, the next CP you submit is added 
to the same group by default. In this case the button 
is named Remove from group.

Attributes available A list of the attributes that have been included in the 
change proposal system configuration, and to which 
you have a minimum of read access.
When you submit a change proposal, you can 
propose changes to more than one attribute. Select 
each attribute against which you want to raise a 
change proposal and fill in the changes you propose. 
An icon is displayed next to the attributes that you 
have proposed changes for.
If you have selected more than one object, remember 
that the changes you propose against different 
attributes will be applied to all the objects that you 
selected.

Reason for change The reason why you’re proposing the change.
Try to give as much information as possible to help 
the CP Review team understand your proposal 
properly and increase the chances of it being 
accepted.

Current The current value of the selected attribute. If you 
have selected more than one object for the change 
proposal, the value of the first object in the Applies 
to ‘n’ objects list is displayed.

Proposed The proposed new value for the attribute. 

Option Description



Using the Change Proposal System

356    Using Telelogic DOORS

Enforce this attribute 
value

If the validity of your change proposal relies upon one 
or more of the object’s attribute values not changing, 
you can enforce those attribute values as part of your 
change proposal. This means that if the attribute 
value has changed between you submitting the change 
proposal and the review board applying it, the value 
that the attribute had when you submitted the change 
proposal is applied.
The value you enforce is the existing attribute value, 
so when you select this option the Proposed text box 
becomes unavailable.
Changes to the attribute value are also flagged to the 
CP Review team when they review the change 
proposal, and again when the change proposal is 
applied. Similarly if there are any other change 
proposals against that attribute, the review board will 
be notified of their existence.

Change type You can select one of four possible change types: 

• Modify this object to change the selected 
attribute value for the selected object or objects.

• Delete this object to delete the selected object or 
objects.

• Add new object to add a new object at the same 
level as the current object. This option is not 
available if you have selected more than one object 
for the change proposal.

• Add new object (below) to add a new object one 
level below the current object. This option is not 
available if you have selected more than one object 
for the change proposal

Priority Select the priority of your proposed change.
Be realistic and don’t exaggerate the importance of 
your proposal. The CP Review team will probably 
downgrade the priority if you exaggerate.

Option Description
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Submitting a change proposal

3. If you want to submit the proposal against more than one object, click 
Select Objects.

4. You can add objects to the change proposal in three ways. In the formal 
module window:

• Select the object that you want to add. In the Select objects dialog box, 
click Current Object, and click Add.

• Select the group of objects you want to add. In the Select objects 
dialog box, click Selected objects, and click Add. A confirmation 
dialog is displayed showing the number of objects that will be added. 
Click Confirm.

• Create a filter to display the objects that you want to add. In the Select 
object dialog box, click Objects in current view, and click Add. If 
more than one object is displayed by the filter, a confirmation dialog is 
displayed showing the number of objects that will be added. Click 
Confirm.

The selected object or objects are added to the list. Select an object from the 
list and click Show to display the object in the module window.

5. When you have added all the objects against which you want to make the 
change proposal, click OK.
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The Object Identifier of each object that is included in the change proposal 
is listed in the Applies to ‘n’ objects box.

6. If you want the change proposal to be part of a group, click Add to group.

The Select group dialog box is displayed.

Select the group you want the change proposal to be part of and click 
Select. If you want to add the change proposal to a group in a different 
folder, click Search up or Search down to locate the group. For more 
information about groups in the change proposal system, see 
“Understanding groups,” on page 350 and “Creating groups,” on page 352.

7. In the Change type box, select the type of your proposed change.

8. Fill in the form:

a. Select the attribute against which you want to propose a change.

b. If you’re proposing a new value for an attribute, type the new value in 
the Proposed box on the right of the screen.

If you’re proposing a change to an OLE object, double-click the object 
to activate it then make changes as required.

c. If the validity of changes you are proposing to other attributes relies on 
the selected attribute not changing, click Enforce this attribute value.

d. In the Reason for change box, type in the reason why you’re proposing 
the change. If you have clicked Enforce this attribute value, explain 
the effect that changes to the attribute will have on your change 
proposal.

Try to give as much information as possible to help the CP Review team 
understand your proposal properly and increase the chances of it being 
accepted.

e. In the Priority box, select the priority of your proposed change.

Be realistic and don’t exaggerate the importance of your proposal. The 
CP Review team will probably downgrade the priority if you exaggerate.

9. Repeat Step 8 for each attribute you want to propose changes for.

10. Click Submit.
A message stating that your change proposal has been submitted is 
displayed.

11. Click OK to acknowledge the message.
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Submitting a suggestion

DOORS can automatically e-mail you if the status of one of your proposals 
changes, for example, if one of your proposals is accepted.
To request e-mails, in the DOORS Explorer click Tools > Options, and then 
select the E-mail updates to change proposals box on the General tab. If this 
box is not available, your Database Manager has configured your database so that 
DOORS cannot send e-mails.

Submitting a suggestion
For information on suggestions, see “Understanding the Change Proposal 
System,” on page 347.
When you submit a suggestion for a project, your suggestion is added to the 
Suggestions module in the project’s Change Proposal System folder.
To submit a suggestion:
1. In the DOORS Explorer, select the project you want to submit a suggestion 

for, or any folder or module in the project.

If you’re working with projects that have sub-projects, and you select a 
folder or module, your suggestion is submitted to the Suggestions module 
associated with the nearest ancestor project. The title bar on the suggestions 
form tells you which project this is.

2. Click Tools > Change Proposal System > Submit Suggestion.

A suggestion form is displayed.

3. Fill in the form:

a. Type your suggestion in the Suggestion box.

b. In the Reason for change box, type in the reason why you’re proposing 
the change.

Try and give as much information as possible to help the CP Review 
team understand your suggestion properly and increase the chances of it 
being accepted.

c. In the Suggestion type box, select the type of your suggestion.

d. In the Priority box, select the priority of your suggestion. 

Be realistic and don’t exaggerate the importance of your suggestion. The 
CP Review team will probably downgrade the priority if you exaggerate.

4. Click Submit.
A message saying that your suggestion has been submitted is displayed.
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5. Click OK to acknowledge the message.

DOORS can automatically e-mail you if the status of one of your proposals 
changes, for example, if one of your proposals is accepted.
To request e-mails, in the DOORS Explorer click Tools > Options, and then 
select the E-mail updates to change proposals check box on the General tab. 
If this check box is not available, your Database Manager has configured your 
database so that DOORS cannot send e-mails.

Understanding the review process
When a change proposal is created, it can be created as an individual change 
proposal, or as part of a group. The way in which you review the change 
proposal depends on whether it was created as part of a group, and if so what 
type of group it is a member of.
If the change proposal is part of a master group, it must be reviewed alongside 
the other change proposals in the group. Once you have considered all of the 
change proposals in the group, you set the status of the group accordingly. All of 
the change proposals in the group inherit their status from the group.
If the change proposal is part of a slave group, you can review it alongside the 
other change proposals in the group, but you have to set the status of each 
change proposal individually.
If the change proposal is not part of a group, it is reviewed independently.
If a user wanted to raise the same change proposal against a number of objects in 
a module, all of the objects to which the change proposal applies can be included 
in one change proposal, called a multiple change proposal. The objects to which 
the change proposal applies are listed in the review dialog box. If you approve a 
multiple change proposal, the change is applied to all of the objects that were 
included in the change proposal.
When you review change proposals, you may or may not be able to edit the 
change proposal. This depends on how the change proposal system has been set 
up. If you want to be able to edit change proposals during the review process, 
contact the CP Manager.

Showing and reviewing individual change proposals
This topic describes how to:

• Look at change proposals that have been submitted by yourself or others.

• Update the status of a change proposal, if you’re a CP Reviewer or CP 
Manager, to reflect the outcome of the review.
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Showing and reviewing individual change proposals

This topic applies to change proposals that are not part of a group.
To show or review change proposals:
1. In the DOORS Explorer, open the module whose change proposals you 

want to review.

2. Click Tools > Change Proposal System > Open CP Partner.
This opens the CP partner module. If your CP role is Standard, the module 
is opened read only.

3. In the CP partner module, click Tools > Change Proposal System > 
Review.

A Review Proposals window is displayed. 

4. Click Next or Previous to display the next or previous proposal.
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By default, you can see all proposals. Use the Show proposals drop-down 
list to change the default. You can select:

• Submitted by anyone
• Submitted by this user (this shows all the proposals submitted by the 

user who submitted the proposal that you’re currently looking at)
• For this object
• In this duplicate set
• In this group

5. If the proposal is against an OLE object, double-click the object to activate 
it. The OLE object can be opened read only in the Current pane of the 
Review form for comparison.

6. You can view the suggested changes as redlining by selecting the View 
changes as redlining check box. Deletions are shown as red text with 
strikethrough, and insertions as blue text with underlining.

7. If you are a member of the CP Review Team and you want to add the CP to 
a group:

a. Click Add to Group.

b. Navigate to the group to which you want to add the change proposal by 
clicking Search up or Search down. 

c. Select the group you want and click Select.
Note  If you add the CP to a master group, the CP becomes a 

slave of that group, and its status is changed to the status 
of the master. The Status list is no longer available 
because slave CPs inherit their status from the master 
group. You can remove the CP from the group by 
clicking Remove.

8. If you are a member of the CP Review team and you want to change the 
status of a proposal to reflect the outcome of the review:

a. In the Status box, select the status agreed by the CP Review team.

b. Optionally, in the Reviewers' comments box, type any comments the 
team wants to make about its decision.

c. Click Save.

9. When you have finished, click Close.
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Showing and reviewing groups

Showing and reviewing groups
1. In the DOORS Explorer, select the project or folder that contains the group 

you want to review.

2. Click Tools > Change Proposal System > Manage Groups.

3. Select the group you want to review from the list and click Review. 

The Review Group dialog box is displayed. It contains a list of the modules 
that contain change proposals that are part of the group. You review the 
change proposals module by module.

4. Select the module you want to review and click Review.

Note  The Review button is not available if the group has been 
applied.

The Review Grouped CPs in module dialog box is displayed.

5. You can add CPs that have been raised against the current module, and are 
not members of any groups:
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a. Click Raise CP Module.

The CP Partner module is displayed.

b. Select the CP or CPs you want to add to the group.

c. In the Review Grouped CPs in module dialog box, select Current 
CP, Selected CP or CPs in current view, as appropriate and click Add.

d. The CP or CPs are added to the group. If a CP you have selected to add 
is already a member of a group, a message stating No CPs to process is 
displayed.

6. Select the CP that you want to review and click Review.

The Review Change Proposals dialog box is displayed.

7. Click Next or Previous to display the next or previous proposal in the 
group.

8. If the proposal is against an OLE object, double-click the object to activate 
it. The OLE object can be opened read only in the Current pane of the 
Review form for comparison.

9. You can view the suggested changes as redlining by selecting the View 
changes as redlining check box. Deletions are shown as red text with 
strikethrough, and insertions as blue text with underlining.

10. If you are a member of the CP Review Team and you want to remove a CP 
from the group click Remove. The CP is no longer associated with the 
group. If it was a slave CP, the Status list becomes available.

11. If you are a member of the CP Review team and you want to change the 
status of a proposal that is a member of a slave group to reflect the outcome 
of the review:

a. In the Status box, select the status agreed by the CP Review team.

b. Optionally, in the Reviewers’ comments box, type any comments the 
team wants to make about its decision.

c. Click Save.

d. When you have finished, click Close.

12. If you are the creator of a master group and you want to change the status of 
a master group to reflect the outcome of the review:

a. Click Close in the Review Change Proposal dialog box.

b. Click Close in the Review Grouped CPs in module dialog box.
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c. In the Review Group dialog box, select a new Group status from the 
list.

If you are reviewing proposals that are part of a master group, you must change 
the status of the group in the Review Group dialog box. The status that you set 
there is inherited by all of the change proposals that are member of the group.

Showing and reviewing suggestions
This topic describes how to:

• Look at suggestions that have been submitted by yourself or others.

• Update the status of suggestions, if you’re a CP Reviewer or CP Manager, to 
reflect the outcome of the review. 

To show or review proposals:
1. In the DOORS Explorer, open the Suggestions module in the project’s 

Change Proposal System folder.

2. Click Tools > Change Proposal System > Review.

The Review Change Suggestions dialog box displayed.

3. Click Next or Previous to display the next or previous suggestion:

By default, you can see all suggestions. Use the Show suggestions 
drop-down list to change the default. You can select:

• Submitted by anyone
• Submitted by this user (this shows all the suggestions submitted by the 

user who submitted the suggestion that you’re currently looking at)
• In this duplicate set

4. If a suggestion is a duplicate, click To Primary Suggestion to display the 
primary change proposal for the duplicate set. 

The Review window closes, and the Proposals module that contains the 
primary change proposal is opened, with the primary proposal as the current 
object.

5. If you are a member of the CP Review team and you want to change the 
status of a suggestion to reflect the outcome of the review:

a. In the Status box, select the status agreed by the CP Review team.

b. Optionally, in the Reviewers' comments box, type any comments the 
team wants to make about its decision.

c. Click Save.
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6. When you have finished, click Close.

Showing information about change proposals
This topic describes how to:

• Add a column to your current view that shows the number of change 
proposals submitted against each object in the module.

• Filter your current view to only show objects that have change proposals 
submitted against them.

You can do both at the same time.
To show information about change proposals:
1. In the module window, click Tools > Change Proposal System > Show 

Information.

2. Select the Show number of proposals per object check box to add a 
column to your current view that shows the number of change proposals 
submitted against each object. 

Clear this check box to remove this column from your current view.

3. Select the Filter to show objects with proposals check box to apply a filter 
to your current view, so that only objects that have change proposals are 
displayed. 

Clear this check box to turn off this filter.

4. Click Close.

Managing duplicate sets
For information on duplicate sets, see “Understanding duplicate sets,” on page 
350.
Members of the CP Review team can:

• Create a duplicate set.

• Add a proposal to a duplicate set.

• Remove a proposal from a duplicate set.

Note  A suggestion can only be added to a duplicate set as a 
duplicate. A suggestion cannot be the primary CP in a 
duplicate set.

To manage duplicate sets:
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1. In the DOORS Explorer, open the module whose change proposals you 
want to manage.

2. Click Tools > Change Proposal System > Open CP Partner.
This opens the CP partner module.

3. In the CP partner module, click Tools > Change Proposal System > 
Manage duplicate sets.

On the left, the Duplicate proposals box lists all the proposals in either the 
current module or the Suggestions module, depending on which Source of 
CPs button you select.

On the right, the Primary proposals box lists all the proposals in the 
current module.

If a proposal you select in either of these boxes is already a duplicate in a set, 
the details box displays information about the primary CP as well as the 
selected proposal.

4. To create a duplicate set:

a. In the Duplicate proposals box, select the proposals that you want to 
be duplicates.
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b. In the Primary proposals box, select the proposal that you want to be 
the primary CP.

c. Click Assign.

Primary CPs have the Primary icon , and duplicate CPs have the 
Duplicate icon .

5. To add a CP to a duplicate set and make it the new Primary CP:

a. In the Duplicate proposals box on the left, select the CP that is 
currently the primary CP in the duplicate set.

b. In the Primary proposals box, select the CP that is to be the new 
primary CP.

c. Click Assign
The CP you selected from the Primary proposals list becomes the new 
primary CP in the duplicate set. The old primary CP and all of its 
duplicates are reassigned as duplicates of the new primary CP.

6. To add another duplicate CP to a set:

a. In the Duplicate proposals box on the left, select the CP that you want 
to add to the duplicate set.

b. In the Primary proposals box, select the CP that is the primary CP in 
the set.

c. Click Assign
If you assign a primary CP to any other primary CP, it becomes a duplicate of the 
new primary CP, and its former duplicates become duplicates of the new primary 
CP.
If you assign a duplicate proposal in set A to a duplicate proposal in set B, the 
duplicate in set A is detached from its primary CP and becomes a duplicate of 
the primary CP in set B.
If you assign a primary CP to a proposal that is not part of a duplicate set, it and 
all of its duplicates, become duplicates of the new primary CP. 

7. To remove a proposal from a duplicate set:

a. In the Duplicate proposals box on the left, select the proposals you 
want to remove from their current duplicate sets.

b. Click Detach.

8. When you have finished, click Close.



Using Telelogic DOORS           369

Checking the approved changes

Checking the approved changes
Before you apply the changes that have been approved, you should check that 
there are no conflicts between the approved change proposals. You can check 
for conflicts by clicking Tools > Change Proposal System > Check from the 
CP Partner module, or by clicking the Check button on the Manage Groups 
dialog box.

Note  You can check groups that aren’t in the approved state. 
DOORS searches for conflicts as though the change 
proposals were approved.

An error or warning message similar to the example below may be displayed, 
depending on what conflicts are found.

To see which change proposals are generating conflict errors and warnings:

1. Click View Report.
A conflict error is reported if two or more of the change proposals in the 
approved set would apply changes to the same attribute of the same object.

A conflict warning is reported if:

• Two or more of the change proposals in the approved set would apply 
changes to different attributes of the same object.

• A change proposal in the approved set and one or more change 
proposals outside the approved set would apply changes to the same 
object.

• A change proposal in the approved set has been set to Enforce this 
attribute value, and the attribute value has changed since the change 
proposal was submitted.

2. Select a line in the report, and click Show.

The module containing the change proposal is displayed, with the object 
selected.

3. You can save a copy of the report to your local machine.
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a. Type a filename and path, or click Browse to select a location where the 
file can be saved

b. Click Save.

The report is created and saved in the location specified.

Applying the approved changes
When the CP Review team has accepted and approved a change proposal or a 
group of change proposals, a member of the team applies the change or the 
group. The affected modules are updated to reflect the changes.
You can only apply change proposals. You can’t apply suggestions because they 
don’t relate to any objects in the database.

Note  If an attribute that has been configured for review is either 
renamed, deleted, or changed from being an object attribute 
to a module-only attribute, it is not possible to apply the 
proposal. If you try to apply an approved change proposal 
that has been made against such an attribute, an error 
message is displayed stating that the attribute cannot be 
found. In this instance, the affected change proposal should 
be rejected.

To apply approved change proposals:
1. In the DOORS Explorer, open the module that you want to apply the 

changes to.

2. Click Tools > Change Proposal System > Open CP Partner.
This opens the CP partner module.

3. In the CP partner module, click Tools > Change Proposal System > 
Apply.

The Apply Change Proposals window is displayed.

4. In the Log file box, type the name of the log file that you want to record the 
applied changes in including the path, or click Browse to locate it.

Note  You can use this log file for audit purposes.

5. If you want to apply all the approved proposals to the module, click Apply 
All.
If you want to apply the current proposal:

a. Click Apply Current.
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b. Use the Next and Previous buttons to change the current proposal. 

c. When you have finished, click Close.

A message confirming that the changes have been made is displayed.

The original module is updated to reflect the proposed changes. In the Proposals 
module, the status of the applied proposals is changed from Approved to 
Applied.
To apply approved groups:
1. In the DOORS Explorer, click Tool > Change Proposal System > 

Manage Groups.

2. Navigate to and select the group you want to apply.

3. Click Apply.

DOORS checks the proposals in the groups for conflicts.

• If there are no conflicts, the change proposals in the group are applied.
• If there are conflict warnings but no conflict errors, a warning message 

is displayed. If you want to apply the change proposals, click Proceed 
with apply. 

• If there are conflict errors, you can’t apply the group until the errors are 
resolved.

For more information about conflicts and the conflict report, see “Checking the 
approved changes,” on page 369.
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24 Using DOORS to manage your testing
• Introducing Test Tracking

• Creating a test definition

• Updating test definitions

• Creating a form for recording test results

• Preparing the module for a test run

• Running tests

• Comparing test runs

Introducing Test Tracking
If your project has testing requirements that are not particularly complex, you 
can manage testing in a DOORS module. To do this you configure the module 
for test tracking. 
In a test tracking module, you can set up each object as a Test Case. Test case 
objects can be organized under headings and sub-headings in the usual way. Each 
test case object should contain enough information in its attributes to allow a 
test technician to understand the requirements for the test, run the test against 
the product, and enter the results of the test into the object. The object can be 
linked to other objects in the database, such as the requirements being tested.
The object attributes that are used by the test technician can be split into two 
distinct groups: 

• Attributes that define the test case

These attributes are called Test Case Attributes. Test Case Attributes store 
background information for test technicians. For example, you may want to 
specify prerequisites for the test and provide details of the expected 
outcome.

• Attributes that store test results

These attributes are called Test Run Attributes. Test Run Attributes are 
used to hold specific information about the results of each test run. For 
example, you may want information such as the test technician’s name, the 
date the test was run, whether the test passed and so on to be recorded each 
time the test is run.
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Test cases may need to be run several times during the development lifecycle. As 
a result of this requirement, you will need several copies of the Test Run 
Attributes so that a new set of test results can be recorded in the module for each 
test run. This can be done automatically in a test tracking module by creating a 
Test Run. The Test Run Attributes are duplicated and suffixed with a number, 
so you can easily identify the test run to which the results apply. The following 
table shows how you can build up test run attributes to keep track of test results 
from each test run. The original test run attributes are never used directly.

You can also create a form to display the test case attributes and test run 
attributes of each test case. This means that when a test run is ready, the test 
technician can select the first test case in the module, open the form and see 
immediately the background of the test case and the results that need to be 
recorded. The form has Next and Previous buttons so the tests can be stepped 
through one by one.
You can add a layout DXL column to any modules that are linked to the test 
module to display the status of tests linked to objects in the module as a tick or 
cross.
By using the test tracking tool you can build up a test history for your project, 
which is held together in one module. 
If you are managing more complex projects, consider using formal test 
management tools, such as those provided by our partners.

Creating a test definition
If you already have a DOORS module that you use for test tracking, you can 
configure it to use the test tracking tool, or you can create a new module for test 
tracking. If you use an existing module, none of the data in the module is lost.

Test Run 
Attribute name

Test Run 1 Test Run 2 Test Run 3

Test Date Test Date 1 Test Date 2 Test Date 3

Test Technician Test Technician 1 Test Technician 2 Test Technician 3

Test Status Test Status 1 Test Status 2 Test Status 3

Actual Test Result Actual Test Result 1 Actual Test Result 2 Actual Test Result 3

Additional 
Comments

Additional 
Comments 1

Additional 
Comments 2

Additional 
Comments 3
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1. Select the module you want to set up for test tracking in the contents pane of 
the DOORS database explorer.

2. Click Tools > Test Tracking > Create Test Definition.

The Create/Update Test Definitions dialog box is displayed.

The dialog is split into three sections:

• Candidate Attributes

All object attributes that exist in the module and are suitable for use as 
test case or test run attributes are listed in this pane. 

Note  Attributes that end with a space followed by a 
number cannot be used by the test tracking tool as 
this is the numbering format that is used to identify 
test run attributes.

• Test Case Attributes (common to all test runs)

Select the attributes in the Candidate Attributes list that you want to 
use as Test Case Attributes and click Add to move them into this list. 
These attributes provide the test technician with background 
information about the test. 

If a candidate attribute that you assign as a test case attribute inherits its 
access rights from its parent, the access to the attribute’s value for the 
group Everyone else is changed to RMCD. This is the access right that is 
required by the average user to a test case attribute’s value.

If you have assigned specific access rights to users, or changed the 
inherited access rights for group Everyone else, those access rights are 
maintained.

• Test Run Attributes (duplicated for each test run)

Select the attributes in the Candidate Attributes list that you want to 
use as Test Run Attributes and click Add to move them into this list. 
These attributes are duplicated each time you create a test run, and 
suffixed with a number to identify the test run with which they are 
associated. 

If a candidate attribute that you assign as a test run attribute inherits its 
access rights from its parent, the access to the attribute’s value for group 
Everyone else is changed to R. This is the access right that is required by 
the average user to a test run master attribute’s value. 
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If you have assigned specific access rights to users, or changed the 
inherited access rights for group Everyone else, those access rights are 
maintained.

3. To populate the module with attributes for use with the test tracking tool 
you can either:

• Automatically create a set of default attributes

Click Create Default Attributes. This creates a set of Test Case 
Attributes and Test Run Master Attributes that would typically be useful 
in test tracking.

• Manually create new attributes 

In the test tracking module, click Edit > Attributes, create attributes in 
the usual way, then click Refresh on the Create/Update Test 
Definitions dialog box. They are displayed in the Candidate 
Attributes list. You can then use the arrows to move them to the other 
lists and assign them for use in test tracking. For information on creating 
new attributes, see “Creating an attribute definition,” on page 116.

4. If you want to create a view to display the attributes you have assigned as 
Test Case Attributes, select Create test definition view named and either 
type a name, or leave the default. To create a view to display the attributes 
you have assigned as Test Run Attributes, select Create test run view 
named and either type a name for the view or leave the default.

5. Click OK.

6. Click to save when prompted.

Module attributes, which store information about the test tracking setup are 
created. These attributes are T3 Edit Form Attributes, T3 Edit Form 
Dimensions, T3 Test Case Attributes, T3 Test Run Attributes and T3 
Test Run Count.
Object attributes that are assigned as Test Run Attributes are set to read only. 
They are never used directly, but are copied for every test run that you 
create. 

Data in existing attributes, which you have now assigned to test runs is not 
lost. Any existing attributes that you assign to Test Run are copied. The 
original attributes remain unaltered. If you no longer need the original 
attributes, they can be deleted by clicking Edit > Attributes in the test 
tracking module, and deleting them in the usual way.

Note  Only the attribute definition is copied. The attribute 
value of an existing attribute that you assign for use as a 
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test run attribute is kept in the original attribute, but is 
not copied to the test run attribute.

Updating test definitions
You can update test definitions at any time by changing the attributes that are 
assigned to Test Case definitions and Test Run definitions.

1. Click Tools > Test Tracking > Create/ Update Test Definitions in the 
module you want to update.

2. Make the changes you require. If you have assigned or removed attributes 
from the Test Case or Test Run definitions and you want to update the view 
to reflect these changes, select the appropriate Create View check box and 
enter the original view name. Your old view is updated.

3. Click OK and save your changes when prompted.

Creating a form for recording test results
You can create a form, called the Test Run Results form, to display the test case 
attributes and test run attributes of each test case. This means that when you are 
ready to run a test set, the test technician can select the first test case in the 
module, open the form and see immediately the background of the test case and 
the results that need to be recorded. The form has Next and Previous buttons 
so the tests cases can be stepped through one by one.
To create the Test Run Results form:
1. Click Tools > Test Tracking > Define Test Run Results Form.

2. Any of the attributes that are displayed in the lists on the left hand side of 
the dialog box can be displayed on the edit form. Select the attributes you 
want to appear on the form and move them into the list on the right side of 
the dialog using the Add buttons. To remove an attribute from the form, 
select it in the list on the right, and click Remove.

3. The attributes appear on the form in the order in which they are displayed in 
the list. You can reorder them by selecting them and moving them using the 
Move Up and Move Down buttons.

4. Preview the form by clicking the Preview button.

5. Click OK to save the form. The list of attributes you have chosen to include 
on the form is saved in the module attribute called T3 Edit Form 
Attributes.
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Preparing the module for a test run
Before a test technician can run any of the tests in the module you must create a 
test run. This creates a duplicate set of test run attributes into which the test 
technician can enter results for each object (test case) in the module.
For example, if you created a test run attribute Test Technician, when you 
create a test run the attribute is duplicated and suffixed with a number. Each time 
you create a new test run another copy of the original attribute is made and the 
number is incremented. This makes it easy to see which test run the results are 
associated with.
To create a new test run:
1. Click Tools >Test Tracking > Create Test Run.

• A number is displayed in the First Test Run Number box. You can 
change this number, or leave the default. If you leave the default, the 
number will automatically increment for each new test run.

• If you want to create a view to display the results of the test run, select 
Create test run view and enter a name for the view.

• If you want the view to be derived from an existing view, select based 
on view, and select the view from the list. If no views are defined in the 
module, the based on view check box is unavailable.

2. Click OK.

An information window is displayed. This tells you the test run number and 
the number of attributes that have been created.

3. Click OK. 

If you selected to create a view for the test run, an information window is 
displayed telling you that the view has been created.

4. Click OK.

Note  When you create subsequent test runs, the test run number 
of the previous test run is displayed on the Create Test Run 
dialog box.

Running tests
Once a new test run has been created you can open the Test Case Edit Form, 
which displays the fields you need to complete for each test and background 
information about the test. You can then step through the test cases, and enter 
the required information.
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You can have the module open in either exclusive edit mode or shareable edit 
mode to enter test run results. If you have the module open in shareable edit 
mode, you can only edit the objects that you have locked.

1. Select the test case you want to run and click Tools > Test Tracking > 
Enter Test Run Results. The Test Run Results form is displayed.

2. Complete the fields as required, then click Apply. 

The results are saved in the attributes that have been created for this test run.

3. To run another test click Next or Previous.

Note  If Refresh editor on current selection is selected, and you 
click on an object in the module, the form is updated to 
display the details for that test case.

Comparing test runs
You can select an enumerated attribute and compare two test runs based on that 
attribute. For example, you may want to compare the results held in the Test 
Status enumerated attribute to see changes in the pass rate for the tests.
To compare test runs:
1. Click Tools > Test Tracking > Compare Test Runs. The Compare Test 

Runs dialog box is displayed.

2. Select the enumerated attribute whose results you want to compare from the 
Enumerated attribute to compare drop-down list.

3. By default, the last two test runs are compared. If you want to compare 
different test runs, type the numbers in the Test runs to compare boxes.

4. Click Collect Data.

The Old Value and New Value columns display all of the changes to the 
attribute value you selected to compare, and the Number of test cases 
column displays the number of test cases that have changed in that way. In 
the following example, one test case has gone from Exempt to Pass, three 
have gone from Fail to Pass, two have passed both runs, and 21 have 
remained Undetermined.
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You can sort the results in the List view by clicking the column title.

To see a graphic view of the results click the Graphic View tab.

5. If you want to filter the module based on any of these transitions, select the 
appropriate box or boxes next to the transition you want to filter on and 
click Filter Tests. For example, if you wanted to filter the module to only 
show tests that have changed from Exempt to Pass, select the first box in 
the example and click Filter Tests.
You can also filter the module from the Graphic View tab by selecting the 
circle that represents the transition on which you want to filter.

6. You can create a comparison view, which shows the differences between the 
two test runs in all of the attribute columns that are displayed.

To create the comparison view, select Convert View to show comparison 
and select the view you want to convert from the list. Click Filter Tests.
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The view you selected is displayed in the module and two sets of values (the 
results of each test run) are shown in each of the columns in the view. If you 
have also selected to filter the module on certain transitions, only the objects 
that match the filter are displayed.
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25 Using descriptive modules
This chapter contains the following topics:

• Understanding descriptive modules

• Controlling access to a descriptive module

• Marking up a descriptive module

• Extracting marked up objects

• Showing descriptive module properties

• Displaying marked up objects only

Understanding descriptive modules
In early versions of DOORS, if you wanted to import data into DOORS you had 
to use descriptive modules. Nowadays, DOORS provides a large range of 
importers to let you import data from many different types of file, including text 
files (see “Importing,” on page 309).
You can use descriptive modules if you want to:

• Import data from a text file into a DOORS formal module. You can 
manually identify which bits of the text are requirements.

• Ensure that the original data can’t be edited.

Note  You can only create a descriptive module using DXL or by 
importing data. When you create a descriptive module by 
importing data, DOORS imports the file using the current 
active code page, for example Latin-1, unless it finds a 
Unicode Byte Order Marker (BOM) at the start of the file. If 
the file contains a BOM, the encoding is inferred from the 
marker.

You can’t edit the contents of a descriptive module but you can extract (copy) 
sections of its text to formal modules. The extraction process automatically 
creates links between the original text in the descriptive module and the copy in 
the formal module.
For example, you have a mail message that contains some requirements that you 
want to import into DOORS. So you import the mail message into a descriptive 
module.
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Then you mark up the text in the descriptive module that you want to extract. 
Each marked up requirement becomes an object in the descriptive module.
Finally, you extract the marked up objects. DOORS automatically creates a link 
between each marked up object in the descriptive module and the copy of it in 
the formal module.
You can’t edit the text in the descriptive module, but you can edit the copy of the 
text in the formal module. You still have your descriptive module, with the 
original text, and links between the two modules.

Controlling access to a descriptive module
To change the access rights for a descriptive module, you must have admin 
access to the module.
To change the access rights for a descriptive module:
1. You can change the access rights for a module from either the DOORS 

Explorer or the module window:

• In the DOORS Explorer, select the module then right-click Properties
• In the module window, click File > Module Properties

2. Click the Access tab.

The current access rights for the module are displayed.

You need this 
access right

To

Read (R) See the module. If you don’t have read access, the module 
is not displayed in your DOORS Explorer.
Set your own default view for the module (see “Setting 
default views,” on page 82).

Create (C) Markup the module.
Create attribute types and attribute definitions for the 
module.

Modify (M) Change the module’s name, description, attribute values, 
or default view.
Create baselines of the module.

Delete (D) Delete, undelete and purge the module.
Cut the module to the DOORS Explorer clipboard.
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3. Make the changes you want.

Admin (A) Change the access rights for the module.

Access tab Description

Inherit from parent Select this check box if you want the module to inherit its 
access rights from the project or folder that it’s in.
When this check box is selected, the list of access rights is 
unavailable, and shows what access rights the module is 
inheriting.

Add To add a new entry to the list of access rights:
a. Click Add.

The Add Access dialog box is displayed.
b. In the Name box, select the name of the user or 

group that you want to add an entry for.

c. Select the access rights you want to give them, then 
click OK.

Remove To remove an entry from the list of access rights, select 
the entry, and then click Remove.

Edit To edit an entry in the list of access rights:
a. Select the entry then click Edit.

The Edit Access dialog box is displayed.
b. Select the access rights you want to give them, then 

click OK.

Additional access Select the additional access rights that you want to 
propagate with create access.
The additional rights are propagated to the objects in the 
module that inherit their access rights from the module.
For more information, see the section topic on 
propagating extra access rights in Getting started with 
Telelogic DOORS, which is available on the Telelogic 
Lifecycle Solutions DVD.

You need this 
access right

To
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4. Click OK.

Marking up a descriptive module
To mark up a descriptive module:
1. Open the descriptive module that you want to mark up:

a. In the DOORS Explorer, make sure that descriptive modules are being 
displayed.

If necessary, click View > Show Descriptive Modules.
b. Double-click the descriptive module in the DOORS Explorer.

2. Click Edit > Object Properties.
3. If you have not marked up the module before, the entire contents of the 

module is displayed in the Editing Descriptive Text pane. Text in this pane 
can be selected, but cannot be edited.

Select the text you want to mark up, then click Markup.

4. The text you selected is displayed in the Editing Object Text box. It is now 
an object in the descriptive module. Notice that:

• The attributes box is no longer empty. It now shows the attributes of the 
object. The Object Text attribute contains the text you selected.

• There is now an Absolute number box at the top right of the window, 
which shows the absolute number of the object.

Note  Text that has not been marked up doesn’t have an 
absolute number or any attributes because it isn’t an 
object in the module. It’s just unmarked up text.

5. Use the Next and Previous buttons to move through the module. 

When you find another piece of text that you want to mark up, select the 
text, then click Markup.

If you change your mind and decide that you don’t want the mark up that is 
currently being displayed, click Undo Markup.

Note  The Undo and Redo options on the Edit menu in the 
descriptive module window are not enabled, so you have 
to use the Edit Descriptive Object dialog box to undo 
markup.

6. When you’ve finished marking up the descriptive module, click Close.
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7. Save the descriptive module (click File > Save).

Extracting marked up objects
When you’ve marked up your descriptive module, you can extract the marked up 
objects to a formal module. Extracting an object makes a copy of the object in 
the formal module and creates a link between the original object in the 
descriptive module and the copy of it in the formal module.
Extracting copies the object text only. If you’ve created other attributes in the 
descriptive module, they are not copied to the formal module.

Note  You can extract marked up objects from one descriptive 
module to two or more formal modules. You can also 
populate a formal module with objects extracted from two or 
more descriptive modules.

To extract marked up objects:
1. Open the descriptive module that you want to extract the data from.

a. In the DOORS Explorer, make sure descriptive modules are being 
displayed.

If necessary, click View > Show Descriptive Modules.
b. Double-click the descriptive module in the DOORS Explorer.

2. In the descriptive module window, click Extract > Setup Extraction.

3. In the Target module box, type the name and path to the formal module 
that you want to extract the data to, or use Browse to locate it.

4. In the Link module box, type the name and path to the link module you 
want to use for the links between the descriptive and formal modules, or use 
Browse to locate it.

5. Click OK.

DOORS opens the formal module and the link module you selected in Step 
3 and Step 4. The descriptive module is now set up for you to extract data.

6. In the formal module window, select the object that you want to copy the 
marked up object to. You can copy to the same level as this object, or to one 
level below it.

7. In the descriptive module window, select the marked up object that you want 
to copy.
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8. In the descriptive module window, click Extract, then either Extract to 
Current Level or Extract to One Level Below.

An Edit Link Object dialog box is displayed. If you want, edit the attributes 
of the link that is created between the two objects, then click OK.

9. Repeat Step 6 to Step 8 to extract other marked up objects.

10. When you have finished, save the descriptive module, the target formal 
module and the link module (in each module window, click File > Save).

The marked up objects are copied from the descriptive module to the formal 
module. A link is created between each object in the descriptive module and the 
copy of it in the formal module.

Showing descriptive module properties
To show the properties of a descriptive module:
1. In the DOORS Explorer, make sure that descriptive modules are being 

displayed.

If necessary, click View > Show Descriptive Modules.
2. Select the descriptive module whose properties you want to show, then 

right-click Properties.

The properties sheet for the module is displayed.

General tab Description

Name The name of the module.

Description Additional information about the module.

Type The type of item whose properties are being displayed. 
This is Descriptive Module, and can’t be edited.

List of attributes This is a list of all the module’s attributes. For each 
attribute, it shows the name of the attribute and its value.

Edit To change the value of an attribute:
a. Select the attribute in the list of attributes, and then 

click Edit. 
b. Enter the new attribute value.

c. Click OK.
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Displaying marked up objects only
By default, when you open a descriptive module, the entire module is displayed.
If you only want to see the marked up objects in the module, click View > Show 
> Marked Up Objects Only.

For information 
on this tab

See

Access Either:

• The help for the Access tab (click the Access tab, then 
click Help).

• “Controlling access to a descriptive module,” on page 
384.

History Either:

• The help for the History tab (click the History tab, 
then click Help).

• “Tracking changes and traceability,” on page 257.
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26 Configuring DOORS
This chapter contains the following topics:

• Showing your user options

• Changing your display scheme

• Display scheme items

• Configuring the spelling checker

• Managing the dictionary

• Using the command line

• Summary of command line switches

• Using shortcuts

• Settings in the registry

• Running DOORS in batch mode

• Configuring the Welcome Screen

Showing your user options
To show your user options:
1. In the DOORS Explorer, click Tools > Options.

The General tab shows the following information:

General tab Description

Username Your DOORS username.
See your Database Manager if you want to change your 
username.

Full Name Your full name. This can be blank.
If you sign a baseline, your Full Name is displayed as part 
of your electronic signature.
See your Database Manager if you want to change your 
full name.

Email Your e-mail address.
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The Display tab shows information about your display schemes. For more 
information, see “Changing your display scheme,” on page 398.

System username The username you log on to your computer with. For 
example, your Windows 2003 username. 
If your system username is wrong or has changed, please 
let your Database Manager know, so they can update your 
user information.

Telephone Your telephone number.
If you submit proposals using either DOORSnet or a CP 
system, this is displayed with your proposals. Leave this 
box blank if you don’t want other people to see your 
telephone number.

Address Your postal address.
If you submit proposals using either DOORSnet or a CP 
system, this is displayed with your proposals. Leave this 
box blank if you don’t want other people to see your 
postal address.

User type Your user type. 
See your Database Manager if you want to change your 
user type.

User powers Your user powers.
See your Database Manager if you want to change your 
user powers.

Additional 
information

Additional information about yourself.
If you submit proposals using either DOORSnet or a CP 
system, this is displayed with your proposals.

E-mail updates to 
change proposals

If you are using a DOORS database server and you use a 
CP system to submit proposals, select this check box if 
you want to be notified by e-mail when the status of your 
proposals changes, for example when one of your 
proposals is accepted or rejected.

General tab Description
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The Password tab shows the following information about your password 
and lets you change it.

The Groups tab shows which groups you are in. See your Database 
Manager if you want to change your groups.

Password tab Description

Change Password To change your password:
a. Click Change Password.

b. Type your current password in the Old password 
box.

c. Type your new password in the New password 
box, then type it again in the Confirm new 
password box. 

d. Click OK.

Minimum password 
length

This is the minimum number of characters you must type 
when you change your password.
If it’s 0, when you change your password, you can leave 
the new password boxes empty; in this case, you don’t 
have to type in a password on the DOORS login screen. 

Expires after This tells you when your password expires. It’s measured 
in days, starting from when you last changed your 
password (see the Last changed box).
If your password has expired, the next time you log on, 
you’ll be asked to change your password.
If the value is 0, you are never asked to change your 
password.

Last changed When your password was last changed.
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The Settings tab shows the following information:

Settings tab Description

Show advanced 
system attributes

By default, screens that list system attributes don’t include 
ones that are for DOORS internal use only, such as 
OLEIconic and TableLeftBorder.
Select this check box if you always want to see all 
advanced system attributes.

Show network 
server monitor

Select this check box if you’re using a DOORS database 
server, and you want to monitor network traffic between 
your computer and the server.
When this check box is selected, an LED is added to the 
system tray on your Windows start bar. The LED flashes 
when data is being transferred to or from the DOORS 
database server.
Clear this check box to remove the LED from your 
system tray.

Show symbols in 
change bars

Select this check box if you want to display symbols in 
change bars.
Change bars allow you to track the changes to objects. 
The status of an object can be communicated by:

• The color of the change bar

• A symbol

• A tool-tip

This check box allows you to control whether a symbol is 
displayed.
Note The New Object symbol is always displayed in the 

change bar, even if this check box is cleared.
For information on change bars, see “Understanding 
change bars,” on page 258.
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Warn when view 
changes are to be 
lost

If you make changes to the module display, for example 
define and apply a filter or add a column, and don’t save 
these changes as a view the changes are lost if you select a 
different view or close the module.
When this check box is selected, a message is displayed 
warning that the changes you have made to the display 
will be lost unless you save the view.

Warn when 
restoring a change 
other than the most 
recent from history

If you restore a change from history, it is possible that the 
change may not have been the most recent. 
When this check box is selected, a warning message is 
displayed letting you know that the change is not the most 
recent.
When this check box is cleared, no warning message is 
displayed and the change is restored.
You can also control whether the warning is displayed by 
selecting or clearing the Do not show me this warning 
again check box on the warning itself.

Open last displayed 
folder or project on 
startup

Select this check box if you want the folder or project that 
was displayed when you closed your previous DOORS 
session to be displayed the next time you log on.

Measurement units This controls whether DOORS uses inches or millimeters 
on Page Setup screens.

Settings tab Description
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The Spelling tab shows information about the configuration of your spell 
checker. For more information on how to configure your spell checker, see 
“Configuring the spelling checker,” on page 403.

Default link 
module

This is the default link module that is used when you 
create links from one module to another and there isn’t a 
default linkset pairing for those two modules.
By default, it’s DOORS Links.
If you specify just the name of the module, without a 
path, DOORS assumes the link module is in the same 
folder or project as the link’s source module. 
If you specify a full path, starting with a slash character 
(/), DOORS uses the specified link module, regardless of 
which folder or project the link’s source module is in.

Web browser This is the browser that DOORS uses:

• If you click a URL in any module

• If you click the DOORS on the Web help topics

This value is stored in the BrowserName parameter in 
the registry. 

Recent module list 
size

Modules that have been opened recently are listed in the 
File menu. By default, the four most recently viewed 
modules are displayed. The path to the module from the 
nearest parent project is displayed in the module status 
bar when you hover the cursor over the module name.
You can display up to nine recently opened modules in the 
file menu. Select the number you want to display from the 
list. 

Switch view when 
navigating URL to 
an open module

View information is included with module, baseline and 
object URLs when the view displayed when the URL is 
copied is not the Standard view. 
You can select to never switch view, always switch view or 
be asked whether you want to switch view or not when 
you follow a URL that will result in the view in a module 
that is currently open being changed.

Settings tab Description
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Understanding display schemes

2. Click OK.

Understanding display schemes
Your display scheme controls the colors and fonts that are displayed in module 
windows. There are a number of standard display schemes:

• Modern

• Classic

• International Modern

• International Classic

• High Contrast #1

• High Contrast #2

• High Contrast Black

• High Contrast White

The Database Manager controls the default display scheme for your database.
You can change your display scheme to select a different standard scheme, or 
you can define your own scheme.

Understanding the High Contrast display schemes

There are four standard High Contrast display schemes:

• High Contrast #1

• High Contrast #2

• High Contrast Black

• High Contrast White

These display schemes follow the pre-defined Windows schemes and work along 
with the Accessibility Options on the Control Panel. 
For example, if you want to use the High Contrast Black display scheme in 
DOORS, follow these steps:

1. Open Accessibility Options in the Control Panel, then select the Display 
tab and select Settings.

The Settings for High Contrast dialog box is displayed.

2. Select one of the High Contrast Black options from the High Contrast 
Appearance Scheme drop-down list, and click OK.
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3. Select the Use High Contrast check box, and click OK.

4. Go to DOORS Explorer and click Tools > Options.

5. Click the Display tab.

6. Select High Contrast Black in the Schemes panel.

7. Click Apply.

Changing your display scheme
The Database Manager controls the default display scheme for your database.
You can change your display scheme to select a different standard scheme, or 
you can define your own scheme.
To change your display scheme:
1. In the DOORS Explorer, click Tools > Options.
2. Click the Display tab.

The Schemes panel contains a list of the display schemes you can use.

Below the Schemes panel, you can set the Line Spacing you want to use to 
display textual attribute values. By default, the line spacing is single for all 
locales except Korean, Simplified Chinese and Traditional Chinese.

On the right, the Colors and Fonts tabs show the colors and fonts for the 
selected display scheme.

On the Colors tab, the colors of the various items are displayed. To change 
the color of an item, double-click it then select the new color.

For information on the items, see “Display scheme items,” on page 400.

On the Fonts tab, use the Fonts used in box to select one of the following 
options:

A list of the current settings for each object level is displayed.

Option Description

Headings The font used in document mode to display headings.

Body text The font used in document mode to display the object 
text in the main column.

Graphics The font used in graphics mode.
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To change the settings for an entry in the list, double-click the entry and 
specify the new settings. In the Preview box, the current settings are 
displayed on the top line, and the proposed new settings on the line below.

3. To edit an existing display scheme:

a. Select the scheme, then edit the settings on the Colors and Fonts tabs.

b. Click OK.

The new colors and fonts are used the next time your screen is refreshed. To 
refresh your screen, click View > Refresh.

Note  You can’t edit the standard display schemes, but you can 
create new schemes based on them and save them with a 
different name (see the next step).

4. To create a new display scheme:

a. Select the existing scheme that is closest to how you want the new 
scheme to look.

b. Use the Colors and Fonts tabs to specify the colors and fonts you 
want.

c. Click Save As.

d. Type the name of your new scheme in the Save as box, then click OK.

e. Click OK.

The new colors and fonts are used the next time your screen is refreshed. To 
refresh your screen, click View > Refresh.

5. To delete a display scheme:

a. Select the scheme, then click Delete.

b. Click OK.

Note  If you select a font that is not available on the current 
desktop, a warning is displayed and the default font for the 
desktop is used in the current session. If the font you 
selected is available in subsequent sessions, it is used, if not 
the warning is displayed and the default font for the desktop 
is used.
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Display scheme items

Items that affect 
Document mode

Description

Page background Window background color for formal and descriptive modules when 
filtering and sorting are off.

Background—filtering Window background color for formal and descriptive modules when 
filtering is on, but sorting is off.

Background—sorting Window background color for formal and descriptive modules when 
sorting is on, but filtering is off.

Background—filtering 
& sorting

Window background color for formal and descriptive modules when 
both filtering and sorting are on.

Text background Background color for normal objects in formal and descriptive 
modules.

Current background Background color for current object in formal and descriptive 
modules.

Title background Column title’s background color in formal and descriptive modules.

Read-only text 
background

Background color for read-only text.

Lockable object 
background

Background color in shareable edit mode for objects that are in 
sections (objects that can be locked).
In the Modern display scheme, this color is used only for sections you 
haven’t locked. In the Classic display scheme, it’s used for sections you 
have locked as well as for sections you haven’t locked.

Data text Normal object’s text color in formal and descriptive modules.

Title text Column title’s text color in formal and descriptive modules.

Selected text Text color for selected objects in formal and descriptive modules.

Read-only text Color for data that you only have read access to. You can’t edit this 
data.

Deleted text Text color for deleted objects.



Using Telelogic DOORS           401

Display scheme items

Current outline Color of lines above and below the current object in formal modules.

Grid Lines Color of gridlines between objects in formal modules.

Current table cell 
background

Background color of current table cell in formal modules.

Link module page 
background

Window background color for link modules.

Link module text 
background

Background color for normal objects in link modules.

Link module current 
background

Background color for current source and target objects in link 
modules.

Link module title 
background

Background color for title in link modules, for all objects except the 
currently selected ones.

Link module data text Text color in link modules.

In-place text Text color when you edit in-place.

In-place background Background color when you edit in-place.

Partitioned-out text Color of partitioned-out text.

Partitioned-in (R) text Color of partitioned-in (R) text.

Partitioned-in (RW) text Color of partitioned-in (RW) text.

High indicator Color of change bars for unsaved changes.

Medium indicator Color of change bars for saved, but not baselined, changes.

Low indicator Color of change bars for objects that have not been changed since the 
last baseline.

Links out indicator Color of out-link arrows.

Links in indicator Color of in-link arrows.

Links start indicator Color of the object where a link start has been set.

Items that affect 
Document mode

Description
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User 1 
User 2 
User 3 
User 4 
User 5 
0% Indicator 
11% Indicator 
22% Indicator 
33% Indicator 
44% Indicator 
55% Indicator 
66% Indicator 
77% Indicator 
88% Indicator 
100% Indicator

User 3 is used as the color of the use in graphical view column 
indicator.
User 4 is used as the color of the use as datatip column indicator. 
The rest of these items are not used by DOORS.

Title background 
(selected)

Background color of column heading when selected.

Items that affect 
Graphics mode

Description

Graphics background Main window background color.

Graphics shade Color used to join levels of the hierarchy.

Graphics elide box Color of the small squares and triangles that indicate that objects are 
being hidden because there isn’t space to display them on the screen.

Graphics text Object text color.

Graphics box 
background

Object background color.

Graphics interface Color used to indicate the presence of hidden objects.

Graphics current Color used to indicate the current object.

Graphics select Color used to indicate selected objects.

Items that affect 
Document mode

Description
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Items that affect Print Preview
• Print Preview Background

• Print Preview Page

• Print Preview Text

• Print Preview Shade

Configuring the spelling checker
Click Tools > Options in the DOORS Explorer, then the Spelling tab to view 
the current settings for the spelling checker.

Graphics box edge Not used by DOORS.

Items that affect 
Graphics mode

Description
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Your user settings were inherited from the database when your user account was 
created. You can alter these settings to suit your spell checking requirements.

The options are divided into three sections, which are explained in detail below.

Available languages

All of the language dictionaries that are supplied with DOORS are listed in the 
Selected Languages list box. DOORS can check spelling and grammar for 
some languages, and spelling only for others. If you select a language that 
DOORS cannot check grammar for, the Grammar level list is unavailable.
The languages that are supplied with DOORS are listed in the following table:

Full spelling and grammar checking Spelling checking only

English (US) Afrikaans
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You can set the spelling checker rules that you want to apply for each language, 
by selecting a language from the list, and setting the options you require.
The panels immediately below the Selected Language list change depending 
on what language you select. For example, if you select English (US) you can 
include Legal and Business, Financial, Insurance lexicon supplements.
Click Use Locale Language to display your current locale language in the 
Selected Language list.

Grammar

DOORS checks the grammar and spelling in your DOORS modules according 
to predefined rules. The rules that are applied by the spelling checker depend on 
the combination of Proofing mode and Grammar level that you select.
If you have selected a language that is only supported for spelling checking, the 
Proofing Mode panel is unavailable, and the Active rules list displays the rules 
for the Spelling only check.

English (UK) Catalan

Dutch Czech

French Danish

German (pre- and post-spelling reform) Finnish

Italian Greek

Portuguese (European) Hungarian

Portuguese (Brazilian) Norwegian (Bokmal)

Spanish Norwegian (Nynorsk)

Swedish Polish

Russian

Full spelling and grammar checking Spelling checking only
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DOORS has three proofing modes, and three grammar levels:

The Active rules list displays the rules that are turned on for the proofing mode 
and grammar level that you have selected. Select a rule in the list to display a 
detailed description of it in the Rule description box.

Checking options

Use these boxes to customize the spelling checker further:

Proofing mode Description

Spelling only Applies a limited set of rules that identify spelling mistakes 
and simple grammatical errors, such as capitalization and 
hyphenation errors. The grammar level does not affect this 
proofing mode.

Quick proof Applies a wider range of rules that identify spelling mistakes 
and a limited range of grammatical errors, for example double 
negatives and errors in punctuation. The grammar level you 
select affects the rules that are applied when this proofing 
mode is selected.

Full proof Applies the complete set of rules to check for all possible 
errors. The grammar level you select affects the rules that are 
applied when this proofing mode is selected.

Option Description

Show spelling 
errors first

Select this option to highlight spelling errors before 
grammatical problems.

Ignore read-only 
attributes

Select this option to only check attributes to which you have 
modify access. You cannot correct errors in text unless you 
have modify access to the attribute.

Use default 
language if attribute 
language not 
suitable

For information on how this setting affects the way in which 
DOORS selects a language for checking, see the section 
Understanding default language selection in DOORS, which 
follows this table.
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Understanding default language selection in DOORS

When you run the spelling checker, and select the attributes you want to check, 
DOORS automatically checks in the locale language of the attribute. However, if 
the attribute’s locale language is not defined by the attribute or not supported by 
the spelling checker, DOORS defaults to a different language. The language that 
DOORS defaults to depends on whether you have selected the option Use 
default language if attribute language not suitable.

• If you select this option, and the attribute language is not suitable, DOORS 
defaults to checking in the language that you have selected in the Selected 
language list. Make sure that when you close the Options dialog box, the 
language you want to use as the default is displayed in the Selected 
language list.

• If you do not select this option, and the attribute language is not suitable, 
DOORS selects a language as described below:

• The language defined by the system locale
• If the system locale isn’t suitable, then the first available language in the 

list is used. This is usually English (US)
In either case, you can select a different language for the spelling check in the 
Check Spelling dialog box. For information on how to use the spelling checker, 
see “Checking spelling,” on page 62.
For more information about locales, see “Understanding locales and unicode 
options,” on page 17.

International Proofreader ™ English (US and UK) text proofing system © 2003 by Vantage Technology 
Holdings, Inc. All rights reserved. Reproduction or disassembly of embodied algorithms or database prohibited.  
For full copyright information, see “Text proofing system copyrights,” on page 443.

Managing the dictionary
DOORS provides two dictionaries that can be customized:

• Client dictionary

The client dictionary is stored on the machine on which the DOORS client 
is installed. This is not a personal dictionary. It can be accessed by any user 
of that client, including Citrix clients that access the client remotely, and 
remote access clients. Access controls cannot be set on the client dictionary. 
However, you cannot add words to the client dictionary if you do not have 
write access to the directory in which the client dictionary is stored.

• Database dictionary
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This dictionary is available to all DOORS users. You need modify access to 
the database dictionary to be able to customize it. You can set access rights 
to control who can add and remove words, and who can change user’s access 
rights.

To add new words to a dictionary:
1. Click Tools > Manage Dictionaries in the DOORS Explorer.

You can add words to the client dictionary or the database dictionary.

2. Select Client or Database from the Dictionary list.

3. Type the word you want to add to the selected dictionary in the New Word 
box.

4. Click Add new word. 

The word is added to the selected dictionary.

To add alternative words to the dictionary:
1. Click Tools > Manage Dictionaries in the DOORS Explorer.

2. Select Client or Database from the Dictionary list.

3. Type the word for which you want to provide an alternative in the As 
alternative to box.

4. Type the suggested alternative in the Suggest Word box.

5. Click Add alternative word.

The word and its suggested alternative are added to the list on the left of the 
box.

To remove a word or an alternative word from a dictionary:
1. Click Tools > Manage Dictionaries in the DOORS Explorer.

2. Select the dictionary from which you want to remove the word from the 
Dictionary list.

3. Select the Words tab to remove a word from the dictionary, or the 
Alternative words tab to remove an alternative word from the dictionary.

4. Select the word you want to delete, and click Remove selected word.

The word is removed from the selected dictionary.

Using the command line
By default, when you start DOORS, it looks at the settings in the registry to find 
out what configuration settings to use.
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Summary of command line switches

When you start DOORS using the command line, you can use switches to 
override the default settings in the registry. You can also use the switches to add 
functionality to DOORS. For example, you can use the -cli switch to execute 
your own DXL program before DOORS starts up.
The command looks like this:

doors [switches]

For example, the following command starts DOORS and opens the Car project 
in the DOORS Explorer:

C:\> cd "c:\program files\telelogic\doors 9.1\bin" 
C:\> doors -project Car

Notice that there’s a space between the switch (-project) and the parameter 
(Car). 
If the parameter contains a space, enclose it in double quotes, like this:

C:\> cd "c:\program files\telelogic\doors 9.1\bin" 
C:\> doors -project "My project"

If the parameter is a path that contains any spaces, enclose the full path in 
quotes, like this:

C:\> cd "c:\program files\telelogic\doors 9.1\bin"

Summary of command line switches
The following table lists all the switches that you can use on the DOORS 
command line:

Switch (abbreviation) Parameter Description

-addins

(-a)

addins_folders A list of one or more paths to the 
folders that contain your DXL 
addins files.
Use semicolons (;) to separate the 
entries in the list. Don’t include 
spaces after the semicolons. Paths 
can be local paths, conventional 
drive mappings, or UNC (Universal 
Naming Convention) paths.
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-attributeaddins

(-A)

dxl_attributes_ 
folders

A list of one or more paths to the 
folders that contain the programs 
that you can use for DXL attributes.
Use semicolons (;) to separate the 
entries in the list. Don’t include 
spaces after the semicolons. Paths 
can be local paths, conventional 
drive mappings, or UNC (Universal 
Naming Convention) paths.

-batch

(-b)

dxl_program Runs DOORS in batch mode, 
without the GUI. For more 
information, see “Running DOORS 
in batch mode,” on page 416. 

-caching

(-k)

Enables streaming for transfer of 
data between the database server 
and the client. This option may 
improve data transfer performance 
over a WAN.
However, using this option offers a 
potential security risk. Data is cached 
to the localdata area of the client 
machine whilst loading, although it is 
cleared on load completion.

-cli

(-C)

dxl_string

or
"#include 

<dxl_program>"

DXL that is executed at DOORS 
startup, before the DOORS splash 
screen is displayed. The parameter is 
either:

• A DXL code fragment

• A hash include statement that 
specifies the path to a DXL 
program

Switch (abbreviation) Parameter Description
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Summary of command line switches

-data

(-d)

port@server Specifies which DOORS database to 
use.
The parameter specifies the port that 
the server is using and the name of 
the server computer (for example, 
36677@myserver).
A DOORS 9.1 client can’t use a 
pre-9.0 database server.

-defopenmode

(-o)

One of the following:
READ_ONLY

READ_WRITE

READ_WRITE_SHARED

The default edit mode that formal 
modules are opened in when you 
double-click them in the DOORS 
Explorer.
The parameter is READ_WRITE for 
exclusive edit mode and 
READ_WRITE_SHARED for shareable 
edit mode. 
Note that this parameter must be 
upper case, unless you use the single 
letter abbreviations (r, w and s).

-defopenlinkmode

(-O)

One of the following:
READ_ONLY

READ_WRITE

READ_WRITE_SHARED

The default edit mode that formal 
modules are opened in when you 
open them by clicking a link arrow in 
another module.
The parameter is READ_WRITE for 
exclusive edit mode and 
READ_WRITE_SHARED for shareable 
edit mode. 
Note that this parameter must be 
upper case, unless you use the single 
letter abbreviations (r, w and s).

Switch (abbreviation) Parameter Description
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-dxl

(-D)

dxl_string

or
"#include 
<dxl_program>"

DXL that is executed immediately 
after DOORS starts up. The 
parameter is either:

• A DXL code fragment.

• A hash include statement that 
specifies the path to a DXL 
program.

-home

(-H)

doors_home The DOORS home folder. This is 
the path to the folder that DOORS 
was installed into (the folder that has 
a bin folder which contains the 
doors.exe file).

-layoutaddins
(-L)

layout_dxl_ 
folders

A list of one or more paths for 
layout DXL folders.
Use semicolons (;) to separate 
entries in the list. Don’t include 
spaces after the semicolons. Paths 
can be local paths, conventional 
drive mappings, or UNC (Universal 
Naming Convention) paths.

-localdata

(-f)

local_folder A folder on the local computer used 
as temporary storage for data copied 
from the DOORS database server.

Switch (abbreviation) Parameter Description
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Summary of command line switches

-logfile

(-l)

logfile A file in which DOORS logs 
information. This is the full path, 
including the name of the log file.
If you use this switch on the 
command line, it logs DXL errors in 
the file. Any reported DXL errors 
are logged in the file instead of being 
displayed on the screen.
If you use this switch in the registry, 
it logs the information that is 
recorded in the Windows event log. 
The information is logged in the file 
as well as in the application log, 
where the records have 
DOORS_DB_SERVER in the Source 
field. 

-notriggers

(-T)
Turn off triggers. You must be either 
a Database Manager or a Custom 
user who has the power to manage 
the database.

-password

(-P)

password The password for the session.

-project
(-p)

project_name The name of the project that you 
want to open at the start of the 
session. The contents of the project 
are displayed in the right pane of the 
DOORS Explorer. 
If you use the -batch switch, the 
parameter specifies the current 
project.

Switch (abbreviation) Parameter Description
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Using shortcuts
On Windows computers you can use a shortcut to run DOORS. For 
information on creating shortcuts, see your Windows online help.
You can use command line switches to override the default settings stored in the 
registry.
If you use command line switches to log on to DOORS, the Message of the Day 
will not be displayed.
To use a command line switch:
1. Select the shortcut icon on your desktop, then right-click Properties.

2. Click the Shortcut tab.

3. The Target box contains the command that is used to start DOORS when 
you double-click the shortcut icon.

-projectaddins

(-J)

project_addins_ 
folders

A list of one or more paths for 
project DXL addins directories. 
Use semicolons (;) to separate 
entries in the list. Don’t include 
spaces after the semicolons. Paths 
can be local paths, conventional 
drive mappings, or UNC (Universal 
Naming Convention) paths.

-user

(-u)

username The username of the user for the 
session.

-W When you are running a batch 
process, and there are any errors or 
printed output, they are sent to a 
command window. DOORS will 
continue to run until the command 
window is closed.
Using -W as part of the command 
line when running a batch process 
closes any command windows 
automatically and allows DOORS to 
stop running.

Switch (abbreviation) Parameter Description
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Settings in the registry

Edit the command to add whatever switches you want to use (for more 
information, see “Summary of command line switches,” on page 409).

Note  Don’t use the -password switch. It makes your 
password visible to other users, which could 
compromise security. 

4. Click OK.

Settings in the registry
When you start DOORS on a Windows computer, it uses the default 
configuration information in the registry, unless you use command line switches 
to override the defaults.
The registry has a directory containing the DOORS 9.1 client configuration 
details, and a directory for the DOORS 9.1 Server configuration, if the server is 
installed.
The default path to the DOORS 9.1 registry entry is: 
HKEY_LOCAL_MACHINE\SOFTWARE\ Telelogic\DOORS.

Caution  We strongly recommend that you do not directly edit the 
registry as this may corrupt your DOORS installation. See 
your system administrator or your DOORS administrator 
before making any changes.

The keywords are the same as the command line switches (see “Summary of 
command line switches,” on page 409).
You don’t need to use quotes when the parameter includes spaces.
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You cannot point your ServerData registry key to a mapped network drive. If 
you want to point to a mapped network drive for the server data, you can run 
doorsd in a console window.

The EXPORTDIRECTORY keyword

The EXPORTDIRECTORY keyword has no command line equivalent.
It specifies the default path used by the DOORS exporters in the File > Export 
submenu.
When you use an exporter, the value of EXPORTDIRECTORY is automatically 
updated to match the path you exported the data to.

The EXPORTDIRECTORY environment variable
The EXPORTDIRECTORY environment variable has no command line equivalent.
It specifies the default path used by the DOORS exporters in the File > Export 
submenu.
When you use an exporter, the value of EXPORTDIRECTORY is automatically 
updated to match the path you exported the data to.

Running DOORS in batch mode
You can use the -batch command line switch to run DOORS in batch mode. 
DOORS starts up without the GUI (it suppresses the login screen and the 
DOORS Explorer), runs the specified DXL program, and then stops.
When you use the -batch switch you normally need other switches like -user, 
-password and -project in order to log on and specify the current project.
The parameter of the -batch switch specifies the file that contains the DXL 
program that you want to run in batch mode. For example:

C:\> doors -b dxl_programs\batch_analysis.dxl -p Car -u "Jill"

Configuring the Welcome Screen
You can set up DOORS to display the Welcome Screen whenever users log on to 
DOORS. You can control:

• The link, company name and graphic that is displayed as Home. For 
information, see “Configuring Home,” on page 417.

• The links on the Documentation Welcome Screen and the Support Welcome 
Screen. For information, see “Configuring the links on the Welcome 
Screens,” on page 417.
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Configuring the Welcome Screen

Configuring Home

To configure Home:
1. Log on to DOORS as a Database Manager or a Custom user who has the 

power to manage the database.

2. In the DOORS Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , then right-click Properties.
4. Click the Welcome Screen tab.

5. Select Edit Link.

The Welcome Screen Link Configuration screen is displayed.

6. In the Image box, type the name of the image file you want to display or use 
Browse to locate it.

7. Enter a name for the link in Label.
8. Enter the URL you want to link to.

9. Click OK.

Configuring the links on the Welcome Screens
To configure the links on the Welcome Screens:
1. Log on to DOORS as a Database Manager or a Custom user who has the 

power to manage the database.

2. In the DOORS Explorer, make sure the Database view is selected.

If necessary, click View > Database View.

3. In the left pane, click Database , then right-click Properties.
4. Click the Welcome Screen tab.

5. Select the Welcome Screen you want to edit, and select Edit Section.
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The Welcome Screen Link Configuration screen is displayed.

6. Display or hide the section by selecting or clearing Section is visible.

7. In the Section image box, type the name of the image file you want to 
display or use Browse to locate it.

8. Enter a name in Section title.

9. Enter the text you want to display in the section.

10. Enter a name for the link in Label label.
11. Enter the URL you want to link to.

12. Click OK.
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27 Using DXL
This chapter contains the following topics:

• Understanding DXL

• Developing DXL programs

• Browsing the DXL library

• Converting layout DXL to attribute DXL

Understanding DXL
The DOORS eXtension Language (DXL) is an easy-to-learn scripting language 
that you can use to control and extend DOORS functionality.
DXL is syntactically similar to C and C++.
You can use DXL to:

• Automate routine or complex tasks, such as calculating attribute values.

• Respond to events by triggering custom programs.

• Add your own options to DOORS menus.

For a full description of DXL, see the DXL Reference Manual, which is on the 
Telelogic Lifecycle Solutions DVD, and available from the Help menu.

Developing DXL programs
You can use the DXL Interaction window to develop small DXL programs.
For large-scale program development, you should use a third-party editing tool 
when coding, and then load your code into the DXL Interaction window to 
execute and debug it.

Note  You can set up a menu option in DOORS to run your third 
party editing tool.

To use the DXL Interaction window:
1. In either the DOORS Explorer or a module window, click Tools > Edit 

DXL.

Note  If the Run and Save as buttons are not available, the 
database may be set up to stop users from editing and 
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running DXL. In this instance, contact the database 
manager.

2. Either type or load your program into the DXL input pane.

Click Load to load the contents of a file. Click Browse to load a program 
from the DXL library.

3. Click Run to run the program in the DXL input pane.

Any error messages that are generated are displayed in the DXL output 
pane. 

4. Click Next error to see the next error message. The contents of the DXL 
input pane are scrolled to the line of source code that caused the error 
displayed in the DXL output pane. 

5. Click Print to print the contents of the DXL input pane with line numbers.

6. Click Save as to save the contents of the DXL input pane to a file.

Right-click anywhere in the DXL input pane to display a pop-up menu.

Menu option Submenu 
option

Description

File Load Loads the contents of a text file into the 
DXL input pane. You can also use 
drag-and-drop to load a file directly from 
Windows Explorer.

Save Saves the changes you made to the text in the 
DXL input pane.

Save as Saves the contents of the DXL input pane to 
another file.

New Clears the DXL input pane. If you have made 
changes to the text that have not yet been 
saved, you are asked if you want to save 
them.

Edit Select all Selects all the text in the DXL input pane.

Deselect all Deselects the selected text.

Copy Copies the selected text to the clipboard.
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Browsing the DXL library

Browsing the DXL library
The DXL library is in the DOORS home directory’s /lib/dxl folder.
You can browse the DXL library by clicking the Browse button when you are:

• Using the DXL Interaction window to find a DXL program to run

• Creating a DXL attribute to find a DXL program to use for the attribute

• Creating a layout DXL column to find a DXL program to use for the layout 
DXL column

The DXL Browse Tools window is displayed. The DXL programs and the 
buttons displayed depend on where you were when you clicked the Browse 
button.
The results of running a DXL program can depend on whether you select the 
Edit DXL menu option on a module or on the database. For example, some 
DXL programs need to be run from within a module, and will fail if you run 
them from the database.

Cut Moves the selected text to the clipboard.

Paste Copies the text on the clipboard to the DXL 
input pane.

Undo Undoes the last edit action.

Search Search Finds a string of text in the DXL input pane. 
The search is case-sensitive.

Again Repeats the search.

Replace Replaces one string of text with another. You 
can replace text strings one at a time or all at 
once.

Goto line Moves the cursor to the start of a specified 
line number.

Menu option Submenu 
option

Description
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Note  If the Run or Edit buttons are not available, the database 
may be set up to stop users from editing and running DXL. 
In this instance, contact the database manager.

Converting layout DXL to attribute DXL
Values that are stored in layout DXL columns are recalculated every time 
DOORS refreshes the display. The constant recalculation of the values is 
memory intensive and can lead to poor performance. If you do not need your 
DXL program to update dynamically, you can convert the contents of your 
layout DXL column to attribute DXL. 
To convert a layout DXL column:
1. Open the module that contains the layout DXL you want to convert in 

exclusive edit mode. You must have create access to the module.

2. Select the view that includes the layout DXL column you want to convert.

3. Click Tools > Support Tools > Convert Layout DXL to Attribute DXL.

The Convert Layout DXL dialog box is displayed. It contains a list of the 
Layout DXL columns in the current view.

4. Select the column that you want to convert and click Convert.
A message is displayed stating that the DXL has been successfully converted, 
and the new Attribute DXL column is added to the view. 

Button Description

Apply Assigns the selected program to your DXL attribute or layout 
DXL column.

Current Edits the program currently assigned to your DXL attribute or 
layout DXL column.

Describe Shows the description of the selected program.

Edit Edits the selected program.

New Lets you define a new program for your DXL attribute or layout 
DXL column.

Run Runs the selected program in your DXL Interaction window.
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28 DOORS buttons
• Module buttons

• Database buttons

This chapter lists the buttons used in DOORS.

Module buttons

Button Function and any (keyboard shortcut) Toolbar

Compare baselines Baseline

Copy baseline Baseline

Create new baseline Baseline

View baselines Baseline

Copy (CTRL+C) Clipboard

Cut (CTRL+X) Clipboard

Paste (CTRL+V) Clipboard

Edit selected column properties Column

Insert new column Column

Remove selected column Column

Auto indent main column Column Alignment

Center column Column Alignment

Justify column Column Alignment

Left align column Column Alignment

Right align column Column Alignment

Accept changes (CTRL+M) Commit
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Discard changes (ESC) Commit

Create new discussion for module Discussion

Create new discussion for object Discussion

View discussions for module Discussion

View discussions for object Discussion

Apply Filtering to Explorer Display

Filter on/off Display

Filter properties Display

Graphics mode on/off Display

Module explorer on/off Display

Outlining mode on/off Display

Reapply filter Display

Sorting on/off Display

Edit mode exclusive edit Edit Mode

Edit mode read only Edit Mode

Edit mode shareable edit Edit Mode

Export to Word Export

Bold (CTRL+B) Formatting

Bullets Formatting

Decrease indent Formatting

Increase indent Formatting

Italics (CTRL+I) Formatting

Strikethrough (CTRL+SHIFT+S) Formatting

Button Function and any (keyboard shortcut) Toolbar
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Module buttons

Underline (CTRL+U) Formatting

Clear link start Link

Make link from start (SHIFT+CTRL+F) Link

Make link to start (SHIFT+CTRL+M) Link

Make new external link Link

Start link (CTRL+I) Link

Edit module properties Module

Print (CTRL+P) Module

Save (CTRL+S) Module

Find (CTRL+F) Navigation

Find next (F3) Navigation

Find previous (SHIFT+F3) Navigation

Go to (CTRL+G) Navigation

Delete object (DELETE) Object

Demote object (CTRL+ALT+RIGHT) Object

Edit object properties (CTRL+E) Object

New object at this level (CTRL+N) Object

New object below (CTRL+L) Object

Promote object (CTRL+ALT+LEFT) Object

Edit object heading (CTRL+H) Object Edit

Edit object text (CTRL+T) Object Edit

Swap heading and text Object Edit

Check spelling (CTRL+K) Spelling

Button Function and any (keyboard shortcut) Toolbar
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Database buttons

Edit table properties Table

Insert table Table

Insert table column Table

Insert table row Table

Button Function and any (keyboard shortcut)

Create new folder

Create new project

Navigate up one level

Add to favorites

Manage users and groups

Create new formal module (CTRL+M)

Create new link module (CTRL+L)

Open module read only (CTRL+R)

Open module shareable edit (CTRL+S)

Open module exclusive edit (CTRL+E)

Delete (DELETE)

Button Function and any (keyboard shortcut) Toolbar
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29 Keyboard shortcuts
This chapter describes the keyboard shortcuts you can use instead of clicking 
menu options with your mouse:

• CTRL keys

• Rich text

• Function keys

• Keypad keys

• Navigation Keys

CTRL keys
The following table lists the control key shortcuts:

Keys Context Description

CTRL+A Formal module Edits the attribute in the next 
column.

CTRL+C DOORS Explorer Copies the currently selected items 
to the DOORS Explorer clipboard.

Formal module Copies the currently selected 
objects to the module’s object 
clipboard.
If you’re editing an object, it copies 
the currently selected text to the 
system clipboard.

CTRL+D DOORS Explorer Creates a new descriptive module.

Formal module Discards a data change during an 
edit (deletes the edits you made to 
the current object).

Link module Deletes a link.

CTRL+E DOORS Explorer Opens the selected module in 
Exclusive edit mode
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Formal module Displays the object properties sheet, 
so you can edit objects.

Link module Displays the Edit Link Object sheet 
if a link is selected.

CTRL+F DOORS Explorer Creates a new formal module.

Formal module Finds text in the module.

CTRL+G Formal module Goes to a particular object in the 
module.

CTRL+H Formal module Edits the Object Heading 
attribute for the current object.

CTRL+I DOORS Explorer Moves focus between the toolbar, 
favorites, location, DOORS 
Explorer pane and Contents pane.

Formal module Starts a link. 

CTRL+K Formal module Runs the spelling checker.

CTRL+L DOORS Explorer Creates a new link module.

Formal module Creates a new object one level 
below the current object.

Link module Creates a new linkset.

CTRL+M Formal module Makes a data change (accepts the 
edits you made to the current 
object; they are stored in memory).

CTRL+N Formal module Creates a new object at the same 
level as the current object.

Link module Creates a new link.

CTRL+O DOORS Explorer Opens the Customize Toolbars 
dialog box.

Any module Opens the Customize Toolbars 
dialog box.

Keys Context Description



Using Telelogic DOORS           429

CTRL keys

CTRL+P Formal module Prints the module.

CTRL+R DOORS Explorer Opens the selected module Read 
only.

Formal Module Removes the contents of an 
attribute when it is open for 
in-place edit.

CTRL+S DOORS Explorer Opens the selected module in 
Shareable edit mode

Any module Saves the module.

CTRL+T Formal module Edits the Object Text attribute of 
the current object.

CTRL+V DOORS Explorer Pastes the contents of the DOORS 
Explorer clipboard to the DOORS 
Explorer.

Formal module If you’re editing an object, it pastes 
the contents of the system 
clipboard.
Otherwise it pastes the contents of 
the module’s object clipboard. New 
objects are created at the same level 
as the current object.

CTRL+X DOORS Explorer Cuts the currently selected items, 
and places them on the DOORS 
Explorer clipboard.

Formal module Cuts the currently selected objects 
to the module’s object clipboard. 
If you’re editing an object, it copies 
the currently selected text to the 
system clipboard.

CTRL+Z Any module Undoes your last edit.

Keys Context Description
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CTRL+RETURN DOORS Explorer Opens selected module in default 
edit mode.

Formal module Creates an object at the same level 
as the current object, when you’re 
editing in-place.

CTRL+LEFT ARROW Formal module Goes to the current object’s parent.
If you’re editing text, moves the 
insertion point one word to the left

CTRL+RIGHT ARROW Formal module Goes to the current object’s first 
child.
If you’re editing text, moves the 
insertion point one word to the 
right

CTRL+HOME Formal Module When editing text, moves the 
insertion point to the start of the 
attribute

CTRL+END Formal Module When editing text, moves the 
insertion point to the end of the 
attribute.

CTRL+ Double-click on 
attribute

Formal Module Goes to Edit Value editor of that 
attribute

RETURN Formal Module When editing attributes goes to 
same attribute for the next object 
(for enumerated lists only)

CTRL+Right SHIFT Formal Module When in-place editing, right aligns 
the attribute value for right-to-left 
reading order. 

CTRL+Left SHIFT Formal Module When in-place editing, left aligns 
the attribute value for left-to-right 
reading order.

CTRL+SHIFT+F Formal Module When a link start is defined, creates 
a link from the start object

Keys Context Description
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Rich text

Rich text
The functions in the following table are only available when you are editing 
attributes of type Text or String in a formal module:

Function keys
The functions in the following table are available in formal modules and the 
DOORS Explorer:

CTRL+SHIFT+M Formal Module When a link start is defined, creates 
a link to the start object.

Keys Description 

CTRL+B Makes the currently selected text bold.

CTRL+I Makes the currently selected text italic.

CTRL+U Makes the currently selected text underlined.

CTRL+SHIFT+S Makes the currently selected text strikethrough.

Key Description With CTRL

F1 Displays help in the DOORS Explorer 
and in module windows, but not in 
dialog boxes.

F2 DOORS Explorer - Displays the 
properties sheet of the item selected in 
the right pane.

Keys Context Description
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F2 In Module - Add the current object to a 
selection. For example, you can use F2 
to select object 1 then use F2 to select 
object 5, and all the objects in between 
will be selected. You can then use F2 to 
select object 9 and all the objects 
between object 5 and object 9 will be 
added to the selection.

Clears the current 
selection.

SHIFT+F2 Clears the current selection.

F3 In Module - Select In Module - Deselect

F3 Finds the next object in the module 
when using the Find function.

SHIFT+F3 Finds the previous object in the module 
when using the Find function.

F4 Deletes the current object.

F5 Refreshes the screen.

SHIFT+F5 Refreshes the module

F6 Compresses the current object if 
outlining is turned on.

Uncompresses the current 
object if outlining is turned 
on.

SHIFT+F10 In the DOORS Explorer and in module 
windows, displays the context menu 
(equivalent to right-clicking).

Key Description With CTRL
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Keypad keys

Keypad keys
The functions in the following table only work if you turn the NUM LOCK off 
by pressing NUM LOCK.

Keypad 
key

Description With CTRL

HOME
7

Moves to the first object in a formal 
module.

When editing text, moves 
the insertion point to the 
start of the attribute

END
1

Moves to the last object in a formal 
module.

When editing text, moves 
the insertion point to the 
end of the attribute

PAGE UP
9

Moves up a screen, unless in a formal 
module in Graphics mode, where the 
whole tree is rotated.

In a formal module in 
Graphics mode, redraws the 
whole tree with the parent 
aligned in a more compact 
form.

PAGE 
DOWN 3

Moves down a screen in a formal or 
descriptive module.

LEFT 
ARROW
4

In link modules, moves to the previous 
target object.

In formal modules, moves 
to the parent of the current 
object.

RIGHT 
ARROW 6

In link modules, moves to the next target 
object.

In formal modules, moves 
to the first child of the 
current object.

UP 
ARROW
8

In formal modules, moves to the 
previous object. In link modules, moves 
to the next source object.

In formal modules, moves 
to the previous object at the 
same level, skipping child 
objects.

DOWN 
ARROW 2

In formal modules, moves to the next 
object. In link modules, moves to the 
previous source object.

In formal modules, moves 
to the next object at the 
same level, skipping child 
objects.
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Navigation Keys
The following table lists the navigation key shortcuts:

INSERT
0

Creates an object one level below the 
current object.

Creates an object at the 
same level as the current 
object.

DELETE
.

Deletes an object or link.

 + Decompresses the current object if 
outlining is turned on.
In the Database or Module Explorer, 
expands the current item to display the 
items at the next level.

- Compresses the current object if 
outlining is turned on.
Collapses the entire directory of the 
Database or Module explorer, if you have 
the root node selected.

* Expands the entire directory of the 
Database or Module explorer, if you have 
the root node selected.

Press To

INSERT Create an object one level below the current object.

CTRL+INSERT Create an object at the same level as the current object.

HOME Go to the first object in the module.

END Go to the last object in the module.

CTRL+HOME If you are editing text, moves the insertion point to the 
start of the attribute.

Keypad 
key

Description With CTRL
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Navigation Keys

CTRL+END If you are editing text, moves the insertion point to the 
end of the attribute.

PAGE UP If you’re in Document mode, scroll up one screen.
If you’re in Graphics mode, rotate the tree clockwise 
through 90 degrees.

PAGE DOWN If you’re in Document mode, scroll down one screen.
If you’re in Graphics mode, rotates the objects 
clockwise.

UP ARROW If you’re in Document mode, go to the next or previous 
object.

DOWN ARROW If you’re in Graphics mode, move up or down the tree 
hierarchy.

CTRL+UP ARROW, 
CTRL+DOWN 
ARROW

Move from the current object to the sibling above or 
below it.
If the focus is on the left pane of the Module Explorer, 
they scroll.
If you are editing text, moves the insertion point to the 
start or end of the attribute.

CTRL+SHIFT+UP 
ARROW, 
CTRL+SHIFT+DOWN 
ARROW

Scrolls smoothly through the module contents.

CTRL+LEFT ARROW, 
CTRL+RIGHT 
ARROW

Go to the current objects parent (left arrow) or first 
child (right arrow).
If the focus is on the left pane of the Module Explorer, 
they scroll.
If you are editing text, moves the insertion point to the 
start or end of the previous or next word.

Press To
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SHIFT+RETURN If you’re in document mode, edit the current object 
in-place. If you’re already editing the current object, goes 
to the next object.
It does nothing if you are in Graphics mode, or if the 
focus is on the left pane of the Module Explorer.

MENU In the DOORS Explorer and in module windows, 
displays the context menu (equivalent to right-clicking or 
SHIFT+F10).

Press To
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30 Contacting support
This chapter contains the following topics:

• Contacting IBM Rational Software Support

• What to do before you contact Support

• Sending an automated problem report form

• Other information

Contacting IBM Rational Software Support
Support and information for Telelogic products is currently being transitioned 
from the Telelogic Support site to the IBM Rational Software Support site. 
During this transition phase, your product support location depends on your 
customer history.

Product support
• If you are a heritage customer, meaning you were a Telelogic customer prior 

to November 1, 2008, please visit the DOORS Support Web site.

Telelogic customers will be redirected automatically to the IBM Rational 
Software Support site after the product information has been migrated.

• If you are a new Rational customer, meaning you did not have 
Telelogic-licensed products prior to November 1, 2008, please visit the IBM 
Rational Software Support site.

What to do before you contact Support
If your site has a designated on-site support person, please contact that person 
before you contact our Support team.
To help our Support team solve your problem, please have the following 
information available:

• Your name, title, company name, e-mail address, fax number and telephone 
number.

• Your support ID and support password.

• The version and build number of DOORS that you’re running.

To get this information, run DOORS, and click Help > About DOORS.

https://support.telelogic.com/doors
http://www.ibm.com/software/rational/support/
http://www.ibm.com/software/rational/support/
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• The operating system you’re running DOORS on, for example Windows 
XP.

• What operating system your DOORS database is running on, if different.

• If you are reporting a new problem, please have a clear statement of the 
problem, including the exact text of any error messages produced by 
DOORS, your operating system, or any other tools that were running when 
the problem occurred.

• If you are calling about a problem you reported earlier, you need the original 
tracking number the Support team assigned to your problem.

• If you want, you can use the automated problem report form. For 
information, see “Sending an automated problem report form,” on page 
438.

The support center on our web site is at https://support.telelogic.com.

Sending an automated problem report form
To send an automated problem report to Support:
1. Select Help > Generate Support Request.

The Telelogic Support Information dialog box is displayed with some of 
your product information automatically included.

Review the information to make sure it’s accurate.

2. From the Impact drop down list box, select the severity of the problem.

3. In the Summary box, summarize the problem.

4. In the Problem box, type a detailed description of the problem.

5. If available, attach a snapshot.

Click either DOORS Window Snapshot or Screen Snapshot, whichever is 
applicable, and select the snapshot from your machine.

6. If possible, use the buttons in the Attachment Information area to add 
video capture, system details and files.

Note  The Add Product Files button is unavailable in 
DOORS. Product information is collected and added 
automatically.

Add any relevant information to help Support resolve the problem.

7. You can either:
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Sending an automated problem report form

• Display the information you’ve entered in a new window so that you can 
copy it. For example, you may want to add this information to someone 
else’s information. 

Click Just Text (No Email).
• Open the email to edit it before sending it to Support. 

Click Preview and Send to submit the report.

Guidelines for writing a problem report

• Be as specific as possible when you summarize the problem in the 
Summary box and when you explain the situation and provide details in the 
Problem box. For example, “The system crashed when I tried to add an 
attribute” is more helpful than “It crashed.”

• Indicate if there were any system changes, such as customizations or 
upgrades, before the problem occurred.

• If the problem is reproducible, list the specific steps to be followed in order 
to demonstrate the problem and also indicate the model you are using to 
perform the steps.

• In the problem description, include anything different or unusual that you 
observed before the problem happened.

• Make screen captures of anything that you feel will help and attach them to 
the problem report.

• Include any error messages and code samples you have related to the 
problem.

• If you have multiple unrelated questions or issues, please submit them 
separately. 

Automatic responses and recording defects

When you send the online form to Support, the customer service system 
immediately searches the Knowledge Base based on the Summary and 
Problem descriptions you entered. If there is an exact match of your problem in 
the knowledge base, the system automatically sends an email to you with a 
pointer to the most likely solution.
The problem is also automatically recorded in the defect tracking system as 
assigned to a support representative. This representative works with you to be 
certain that your problem is solved. The defect tracking system also records new 
problems with their solutions in the Knowledge Base to provide rapid assistance 
for other customers.
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Automatically generated problem reports

If your DOORS system crashes, it displays a message asking if you want to send 
a problem report about the crash to DOORS Support.
If you decide to send this generated report, the system displays the same online 
form that is available from Help > Generate Support Request. In this case, 
the form contains information about the crash condition, in addition to the 
information that is usually filled in describing your system. 
Add any more information that you can to help the Support staff identify the 
problem before you click the Preview and Send button.

Changing the email address of the problem report
If you want to send the problem to someone other than DOORS Support, for 
example to your internal support, you can change the default email address of 
the problem report.
To change the email address of the problem report:
1. Open System in the Control Panel.
2. On the Advanced tab, click Environment Variables, then click New under 

variables.

The New User Variable window is displayed

3. In Variable Name enter ILX_RECIP, the variable that controls the 
address used by the problem report.

4. In Variable Value enter the email address you want to use.

5. Click OK to add the value.
6. Click OK to save the value in the environment variables.
7. Click OK to save the value in the system properties.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software Web site.

http://www.ibm.com/software/rational/
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31 Notices
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user’s responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan  
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
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This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
1 Rogers Street 
Cambridge, Massachusetts 02142 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
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Trademarks

performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks

IBM, the IBM logo, ibm.com, Telelogic, and Telelogic DOORS are trademarks 
or registered trademarks of International Business Machines Corporation in the 
United States, other countries, or both. These and other IBM trademarked terms 
are marked on their first occurrence in this information with the appropriate 
symbol (® or ™), indicating US registered or common law trademarks owned by 
IBM at the time this information was published. Such trademarks may also be 
registered or common law trademarks in other countries. A current list of IBM 
trademarks is available on the Web at www.ibm.com/legal/copytrade.html.
Microsoft, Windows, and the Windows logo are trademarks of Microsoft 
Corporation in the United States, other countries, or both.
UNIX is a registered trademark of The Open Group in the United States and 
other countries.

Text proofing system copyrights

International Proofreader ™ English (US and UK) text proofing system © 2003 
by Vantage Technology Holdings, Inc. All rights reserved. Reproduction or 
disassembly of embodied algorithms or database prohibited. 
International Proofreader ™ French text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ German text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
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International Proofreader ™ Afrikaans text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Catalan text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Czech text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Danish text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Dutch text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Finnish text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Greek text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Italian text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited. 
International Proofreader ™ Norwegian, text proofing system © 2003 by 
Vantage Technology Holdings, Inc. All rights reserved. Reproduction or 
disassembly of embodied algorithms or database prohibited.
International Proofreader ™ Portuguese, text proofing system © 2003 by 
Vantage Technology Holdings, Inc. All rights reserved. Reproduction or 
disassembly of embodied algorithms or database prohibited.
International Proofreader ™ Russian, text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited.
International Proofreader ™ Spanish, text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited.
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Trademarks

International Proofreader ™ Swedish, text proofing system © 2003 by Vantage 
Technology Holdings, Inc. All rights reserved. Reproduction or disassembly of 
embodied algorithms or database prohibited.
Other company, product or service names may be trademarks or service marks 
of others.
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Index

A
Access rights

inheritance,   202, 204
propagating,   205
understanding,   197

Activating OLE objects,   177
Adding

columns,   145
graph columns,   149
icon columns,   153

Advanced filters
understanding,   94
using,   97

Applying approved change proposals,   370
Applying approved group change 

proposals,   371
ASCII,   339
Attribute definitions

changing access rights,   119
creating,   116
deleting,   129
editing,   123
importing,   128
showing,   115

Attribute types
changing access rights,   112
creating,   111
deleting,   115
editing,   114
importing,   128
showing,   110
understanding,   108

Attribute values
changing access rights,   122
copying,   130
measuring frequency,   131

Attributes
copying between modules,   68
creating link attributes,   229
linking by attribute,   237
T3,   376
Test Case attributes,   373
Test Run attributes,   373

Automated problem report form,   438

B
Baselines

comparing,   291
copying,   289
creating,   289
deleting,   292
opening,   288
signing,   296
understanding,   257, 287
viewing electronic signatures,   295

Buttons
changing on DOORS Explorer,   7
changing on module toolbars,   8
database,   426
module,   423

C
Change bars,   258
Change proposal roles,   349
Change Proposal System

check,   369
groups,   350

master,   351
slave,   351

understanding,   347
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Change proposals
applying approved,   370
applying approved group,   371
description,   348
multiple,   348
reviewing,   361, 365
reviewing groups,   363
showing,   361
showing groups,   363
showing information about,   366
submitting,   353
suggestions,   348

Changing
column information,   147
display levels,   140
DOORS Explorer display,   5

Checking data against history,   285
Checking your spelling,   62
Closing

modules,   21
Color-coding data,   148
Columns

adding,   145
editing column information,   147
inserting in tables,   168
showing column information,   145
working with,   143

Command line
switches,   409
using,   408

Comparing modules, see Module 
Comparison Wizard

Compressing parts of the hierarchy,   143
Converting layout DXL to attribute 

DXL,   422
CP partner modules,   349
Create links tool,   235

Creating
baselines,   289
CP groups,   352
folders,   207
formal modules,   23
link modules,   242
links,   216
linkset definitions,   240
linksets,   245
objects,   55
reports,   307
tables,   166

Customize toolbars
DOORS Explorer,   7
module,   8

Cutting, copying and pasting
in DOORS Explorer,   19
in module window,   20

D
Database buttons,   426
Deactivating OLE objects,   177
Default link modules,   238
Default linkset pairings

creating,   239
Default view

default views,   82
setting,   82

Deleting
baselines,   292
folders,   210
links,   233
linksets,   246
modules,   33
objects,   60
OLE objects,   184
tables,   172
views,   88

Demote object,   58
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Index

Descriptive modules
changing access rights,   384
marking up,   386
showing marked up objects,   389
showing properties,   388
understanding,   383

Dictionaries,   404, 407
Discussions

for modules
about,   247
adding comments,   250
closing,   250
creating,   248
deleting,   251
reopening,   252
viewing,   249

for objects
about,   247
adding comments,   254
closing,   254
creating,   252
deleting,   255
reopening,   256
viewing,   253

Display levels,   140
Display Link Indicators column,   278
Display modes

changing between,   139
document mode,   137
graphics mode,   137

Display schemes
about,   397
changing,   398
High Contrast,   397
items,   400

Document mode
turning on and off,   139
understanding,   137

DOORS
configuring,   391
running in batch mode,   416
starting,   3
stopping,   22

DOORS Explorer
changing the display,   5
cutting, copying and pasting,   19
Favorites field,   10
Location field,   9
making selections,   6
searching with,   89
selecting multiple items,   7
using drag-and-drop,   16

DOORS Explorer buttons,   7
DOORS Explorer toolbars,   7
DOORS Links,   221
Drag-and-drop

in a module window,   16
in DOORS Explorer,   16

Duplicate sets
managing,   366
understanding,   350

DXL
attributes,   129
developing programs,   419
editing a DXL attribute definition,   

126
library,   421
understanding,   419
using,   419

DXL Attribute Wizard,   119

E
Edit modes

changing,   38
understanding,   38

Editable sections,   39
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Editing
column information,   147
CP groups,   353
extended undo,   53
folder properties,   210
imported Word style information,   

311
links,   226
marked up objects,   387
objects,   48
undo,   53
views,   83

Electronic signatures
printing,   297
signing,   296
viewing,   295

Environment variables
EXPORTDIRECTORY,   416

EXPORTDIRECTORY,   416
Exporting

FrameMaker,   344
HTML,   337
Microsoft Excel,   334
Microsoft Outlook,   336
Microsoft PowerPoint,   336
Microsoft Word,   331
plain text,   339
RTF,   340
spreadsheets,   342

Extended undo facility,   53

F
Favorites

organizing items,   11
understanding,   10

Filtering data,   95, 97

Filters
advanced,   94
filtering the Module Explorer,   99
reapplying,   99, 100
simple,   94
turning on and off,   99

Finding
and replacing text in modules,   92
objects,   97
text in modules,   90

Folders
changing access rights,   208
creating,   207
deleting,   210
editing properties,   210
purging,   210
undeleting,   210
unlocking,   212

Formal modules
changing access rights,   24
creating,   23
finding and replacing text,   92
searching for objects that contain 

text,   90
showing properties,   29

Forms
creating,   73
deleting,   76
editing,   75
running,   75

FrameMaker
exporting,   344
importing,   327

G
Going directly to an object,   93
Grammar-checker,   405
Graph columns,   149
Graph Wizard,   149
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Index

Graphics mode
turning on and off,   139
understanding,   137

Groups
understanding,   199

Groups modules,   349

H
History,   285

I
IBM Customer Support,   437
Icon columns,   153
Iconizer Wizard,   154
ILX_RECIP,   440
Importing

database files,   322
FrameMaker,   327
Microsoft Word,   309
plain text,   312
RTF,   320
spreadsheets,   322

Inheritance
access rights,   202
example,   204

In-links,   215
In-place editing,   44
Inserting

OLE objects,   179
pictures,   176
symbols,   65
templates,   67
URLs,   66

J
Jumping directly to an object,   93

K
Keyboard shortcuts

CTRL keys,   427
functions,   431
keypad keys,   433
navigating,   133
navigation,   434
rich text,   431

L
Layout DXL columns

about,   129
converting to attribute DXL,   422

Link analysis
running,   268
understanding,   268

Link arrows,   215
Link modules

changing access rights,   222
creating,   242
defaults,   238
showing properties,   241
understanding,   220
working with,   243

Linking by attribute,   237
Links

clearing the start,   220
creating,   216
deleting,   233
editing,   226
link arrows,   215
understanding,   213

Linkset Control,   240
Linkset definitions,   240
Linkset pairings,   238
Linksets

creating,   245
deleting,   246
understanding,   220

Location field,   9
Locks,   211
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M
Making selections

in a module window,   15
in DOORS Explorer,   6

Marking up descriptive modules,   386
Merging object text,   70
Module buttons

about,   423
changing,   8

Module Comparison Wizard
introduction,   155
running,   156
using,   155

Module default view,   82
Module Explorer

filtering,   99
using,   136

Module toolbars,   8
Module window

cutting, copying and pasting,   20
making selections,   15
using drag-and-drop,   16

Modules
about discussions,   247
adding comments,   250
closing,   21, 34
closing discussions,   250
creating,   23
creating discussions,   248
creating objects,   55
deleting,   33
deleting discussions,   251
deleting links,   233
dividing up into editable sections,   42
finding and replacing text,   92
inserting as a table,   167
navigating using the keyboard,   133
opening,   13
paste special,   27
printing,   300
purging,   33
reopening discussions,   252
saving your changes,   55
searching for objects that contain 

text,   90
selecting everything,   16
selecting multiple objects,   15
setting up for sharing,   41
showing history,   263
showing link module properties,   241
showing properties,   29
showing statistics,   32
undeleting,   33
understanding,   383
unlocking,   212
viewing discussions,   249

Moving directly to an object,   93

O
Object

demote,   58
promote,   58

Object copier,   68
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Object properties sheet,   48
Object splitter,   67
Object text,   70
Objects

about discussions,   247
adding comments,   254
changing access rights,   56
closing discussions,   254
copying between modules,   68
creating discussions,   252
deleting,   60
deleting discussions,   255
editing marked up objects,   387
jumping to objects,   93
purging,   60
reopening discussions,   256
undeleting,   60
viewing discussions,   253

OLE objects
activating and deactivating,   177
copy and pasting,   180
cutting, copying and pasting,   182
deleting,   184
editing properties,   182
history,   185
inserting,   179
resizing,   181
setting OLE open limit,   185
understanding,   176
understanding registered and 

unregistered,   185
OLE open limit,   185
Opening

baselines,   288
modules,   13

Outlining,   142
Out-links,   215

P
Page setups

applying,   301
creating,   301

Pictures
inserting,   176
working with pictures,   175

Plain text
exporting,   339
importing,   312

Print preview,   299
Printing

electronic signatures,   297
modules,   300
reports,   308

Promote object,   58
Propagating access rights,   205
Proposals modules,   349

R
Redline markup column,   162
Redlining,   267
Registry settings,   415
Regular expressions,   102
Replacing text in modules,   92
Reports

creating,   307
printing, viewing or deleting,   308

Request lock
module,   14
section,   44

RTF
exporting,   340
importing,   320

S
Searching

for objects that contain text,   90
with DOORS Explorer,   89
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Sections
locking,   43
unlocking,   43

Selecting
everything in a module,   16
items in DOORS Explorer,   6
multiple items in DOORS Explorer,   

7
multiple objects in a module,   15

Setting the default view,   82
Setting up modules for sharing,   41
Shareable edit mode,   42
Shortcuts,   414
Showing and hiding parts of the 

hierarchy,   143
Showing column information,   145
Simple filters

understanding,   94
using,   95

Sorting
objects,   100
turning on and off,   101
understanding,   100

Spell-checker
configuring,   403
using,   62

Split Object Heading from Object Text,   
60

Starting DOORS,   3
Stopping DOORS,   22
Suggestions

reviewing,   365
submitting,   359

Suggestions modules,   349
Support,   438

Suspect links
clearing,   282
display all changes,   280
display all information,   280
display last change,   279
Display Link Indicators column,   278
filtering,   278
understanding,   276

Swap object heading and text attributes,   
59

Symbols,   65
System attributes,   105

T
T3 attributes,   376
Tables

changing properties,   169
creating,   166
deleting,   172
inserting a module as a table,   167
inserting columns,   168
inserting rows,   168
purging,   172
undeleting,   172
understanding,   165

Templates,   67
Test Case attributes,   373
Test definitions

creating,   374
updating,   377

Test Run attributes,   373
Test Run Results form,   377
Test Tracking

comparing tests,   379
introduction,   373
preparing the module,   378
running tests,   378

Text
finding and replacing in modules,   92
finding in modules,   90
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Traceability columns
adding,   271
understanding,   269

Traceability Explorer,   275

U
Understanding

CP groups,   350
Undoing an edit,   53
Unlocking

folders,   212
modules,   212
projects,   212

URLs,   66
User default view,   82

User options,   391

V
Views

changing access rights,   86
deleting,   88
editing,   83
saving current module view,   79
understanding,   78

W
Welcome Screen

configuring home,   417
configuring links,   417
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