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1 About this manual
Welcome to the Telelogic® DOORS® (DOORS) product family, a powerful set 
of tools that help you capture, track and manage your user requirements.
This document contains information on installing and setting up your DOORS 
products.

You’ll find PDF versions of these manuals on the support website at https://
support.telelogic.com.

For information on See

What’s new in DOORS The Telelogic DOORS readme file

How to set up licenses to use DOORS Telelogic Lifecycle Solutions Licensing Guide

How to use DOORS Getting Started with Telelogic DOORS
Using Telelogic DOORS

How to use the DOORS integrations Using Telelogic DOORS for ClearCase 
Interface
Using Telelogic DOORS for ClearQuest 
Interface
Using Telelogic DOORS for Rose Interface
Using Telelogic DOORS for Serena Version 
Manager Interface

How to set up and manage DOORS Managing Telelogic DOORS

How to write requirements Get It Right the First Time

The DXL programming language DXL Reference Manual

How to integrate DOORS with other 
applications

Telelogic DOORS API Manual
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2 Introduction
• What is DOORS?

• What types of DOORS installation can I have?

• What are the licensing options?

• What next?

What is DOORS?
The DOORS product family is a package of requirements management tools 
designed to help enterprises take control of and effectively manage projects from 
the concepts phase right through to completion.
The products in the DOORS family allow everyone in your organization to 
participate in and contribute to the requirements management process.

Product name Description

Telelogic® DOORS® At the heart of the family is DOORS, an application that 
runs on Windows® and UNIX® systems. With its own 
built-in database, DOORS provides a rich set of features 
to help you capture and manage requirements.

Telelogic® DOORS 

Analyst™
Telelogic DOORS Analyst is a modeling environment 
available inside DOORS. Telelogic DOORS Analyst 
enables users to augment and visualize requirements using 
diagrams, symbols and pictures based on the standardized, 
visual modeling language UML 2.0, which are embedded 
directly within your DOORS modules.
Telelogic DOORS Analyst is a natural extension to the 
rich capabilities already available in DOORS. With its 
powerful, yet easy-to-learn visual modeling features, 
Telelogic DOORS Analyst provides complete freedom of 
expression when defining requirements. With Telelogic 
DOORS Analyst you can easily augment your 
requirements descriptions with pictures, diagrams and 
models, to give extra life to and simplify understanding of 
requirements.
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What types of DOORS installation can I have?
There are three types of DOORS installations:

Telelogic® DOORS for 
ClearCase Interface™

Telelogic DOORS for ClearCase Interface is one of the 
DOORS integration products. It lets you transfer data 
between DOORS and ClearCase®, so you can 
synchronize configuration management regimes and 
establish traceability between information managed in 
DOORS and versions managed by ClearCase.

Telelogic® DOORS for 
ClearQuest Interface™

Telelogic DOORS for ClearQuest Interface is one of the 
DOORS integration products. It lets you transfer data 
between DOORS and ClearQuest®. The integration 
tracks a CR through its entire life-cycle providing status 
information on DOORS artefacts impacted by their 
implementation such as requirements and tests

Telelogic® DOORS for 
Rose Interface™

Telelogic DOORS for Rose Interface is one of the 
DOORS integration products. It lets you transfer data 
between DOORS and Rational Rose®, so you can add 
traceability to your software design process.

Telelogic® DOORS for 
Serena Version 
Manager Interface™

Telelogic DOORS for Serena Version Manager Interface 
is one of the DOORS integration products. It lets you 
transfer data between DOORS and Version Manager™. It 
allows complete life cycle traceability from requirements 
through to configuration management.

Setup type Description

DOORS Client Installs DOORS client application files on a local 
machine. The client can either access a database on the 
local machine, or on a networked machine.
Licensing may be set up for local or remote access.

DOORS Server Installs the DOORS database server on a local machine.
Licensing may be set up for local or network access.

Product name Description
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What are the licensing options?

What are the licensing options?
You must have either a software or hardware license to run any of the DOORS 
products.
Unless you are running DOORS 8.2 or DOORS 8.3, and have a valid 
maintenance agreement, you must request a new software license for DOORS 
9.1. Software licenses for all versions of DOORS 8.1 and earlier are not 
compatible with DOORS 9.1.
Rainbow dongles are no longer supported by DOORS. Customers who have 
previously used Rainbow dongles to run DOORS must contact their local 
Support department. Other existing hardware licenses do not need to be 
replaced.
For more information on licensing, see the Telelogic Lifecycle Solutions Licensing 
Guide, which is available from the Telelogic Lifecycle Solutions DVD, and 
from our web site at https://support.telelogic.com.

What next?
The following table describes the different DOORS installation options that are 
covered in this manual.

DOORS Example Data Installs the DOORS example database on a local machine.
Users can familiarize themselves with DOORS without 
accessing production data or installing a local DOORS 
database server.

If you are installing DOORS 9.1 on Go to

A Windows machine that does not have 
a previous version of DOORS installed

“New installation of DOORS on 
Windows,” on page 7

A Windows machine that is currently 
running a previous version of DOORS

“Upgrading to DOORS 9.1 from 
DOORS 5.x, 6.x, 7.x or 8.x,” on page 23

A UNIX machine “Installing the DOORS server on 
UNIX,” on page 33

A Citrix machine “Installing and using DOORS on Citrix,” 
on page 31

Setup type Description
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3 New installation of DOORS on Windows
This chapter describes how to install and set up DOORS 9.1 on a machine that 
does not have previous versions of DOORS installed. If you want to install 
DOORS and use data from previous versions of DOORS you should follow the 
instructions in “Upgrading to DOORS 9.1 from DOORS 5.x, 6.x, 7.x or 8.x,” on 
page 23. 
This chapter contains the following:

• Installing the DOORS database server

• Installing the DOORS client

• Installing the Telelogic License Server

• Silent installation

• Starting DOORS

• TDS, the DOORS database and UUIDs

• Installing the DOORS Example Data

• Uninstalling DOORS

Installing the DOORS database server
If you are installing both the DOORS client and the DOORS database server on 
the same machine, we advise you to install the DOORS client first. The DOORS 
database server and the DOORS client share components, and if you install the 
server before the client, you may need to restart your machine during the client 
installation. For information on the client installation, see, “Installing the 
DOORS client,” on page 9. When you have installed the DOORS client, follow 
the steps below to install the DOORS database server.

1. Check that you meet the system requirements for installing and running the 
DOORS database server. Details of system requirements can be found in 
the readme file, and on the website at https://support.telelogic.com.

2. Make sure you’re logged onto your computer as the local Administrator, and 
not a user with Administrator privileges.

3. Shut down all other applications. In particular, shut down Microsoft Office 
applications, including the Microsoft Office toolbar.

4. You can either install from the Telelogic Solutions DVD or from DOORS 
software downloaded from the Telelogic website.
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If you’re installing from DVD, put the Telelogic Lifecycle Solutions DVD 
into your DVD-ROM drive, browse to the DOORS server software and 
click to install. The DOORS database server installer runs, and the 
Welcome screen is displayed.

If you downloaded the DOORS database server software from the website, 
navigate to the file you downloaded, and double-click it. The DOORS 
database server installer runs, and the Welcome screen is displayed.

5. Click Next.
The License Agreement screen is displayed.

6. If you accept the terms of the license agreement, select the I accept... 
option and click Next.
If you do not have a DOORS client installed on your machine, the 
Destination Folder screen is displayed. If you have a DOORS client 
installed the DOORS Database Server Settings screen is displayed. Go to 
Step 8.

7. Enter the path to the folder you want to use for your DOORS installation, 
or leave the default. DOORS is installed to a new folder named 
DOORS 9.1, which is created in this location.

For example, the default installation folder is C:\Program 
Files\Telelogic\. If you install to this location, a folder called 
DOORS 9.1 is created in the Telelogic folder, and all the files your computer 
needs to run the DOORS database server are installed in the DOORS 9.1 
folder.

If you want to change the directory:

a. Click the Change button.

b. Browse to the directory you want to install to.

c. Click OK.

The DOORS Database Server Settings screen is displayed.

8. Enter the Port Number and the Data Directory.

a. In Port Number, type the port number to be used by your DOORS 
database server. We recommend you do not use a number lower than 
1000. The default port used by DOORS is 36677.

b. In Data Directory, type the path to the directory you want to use for 
your DOORS database. This directory must be on the local machine 
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Installing the DOORS client

and is where your data and user information will be stored. DOORS 
does not support mapped drives for data.

c. Click Next.
Note  If the port you specified is already being used by another 

application, a message is displayed. Click OK, type a 
different port number and click Next.

The Ready to Install the Program screen is displayed.

The settings you defined in the previous steps are displayed. Use the Back 
button if you want to change any of your settings.

9. Click Install.
10. When all the files are installed, the Finish screen is displayed. Click Finish 

to complete the installation.

Installing the DOORS client
If you are installing both the DOORS client and the DOORS database server on 
the same machine, we advise you to install the DOORS client first.

1. Ensure you have a DOORS 9.1 license. For more information on licensing, 
see the Telelogic Lifecycle Solutions Licensing Guide, which is available from the 
Telelogic Lifecycle Solutions DVD, and from our web site at https://
support.telelogic.com.

2. Check that you meet the system requirements for installing and running the 
DOORS client. Details of system requirements can be found in the readme 
file, and on the website at https://support.telelogic.com.

3. Make sure you’re logged onto your computer as the local Administrator, and 
not a user with Administrator privileges.

If you can’t log onto your computer as the local Administrator, see 
“Installing DOORS as a non-admin user,” on page 45.

4. Shut down all other applications. In particular, shut down Microsoft Office 
applications, including the Microsoft Office toolbar.

5. You can either install from the Telelogic Solutions DVD or from DOORS 
software downloaded from the Telelogic website.

If you’re installing from DVD:

a. Put the Telelogic Lifecycle Solutions DVD into your DVD-ROM 
drive, browse to Telelogic Lifecycle Solutions Clients, and click to 
install.
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The Telelogic Lifecycle Solutions Setup runs, and the Welcome 
screen is displayed. 

b. Click Next.
The License Agreement screen is displayed.

c. If you accept the terms of the license agreement, select the I accept... 
option and click Next.
The Select Products screen is displayed.

d. If you only want to install DOORS, clear all the other options and click 
Next. Go to step 8.

For information on installing products other than DOORS, see the 
appropriate installation manual, which is available from the Telelogic 
Lifecycle Solutions DVD.

If you downloaded the DOORS client software from the website, navigate 
to the file you downloaded, and double-click it.

The Welcome screen is displayed.

6. Click Next.
The License Agreement screen is displayed.

7. If you accept the terms of the license agreement, select the I accept... 
option and click Next.

8. The Destination Folder screen is displayed. 

Enter the path to the folder you want to use for your DOORS installation, 
or leave the default. DOORS is installed to a new folder named 
DOORS 9.1, which is created in this location.

For example, the default installation folder is C:\Program 
Files\Telelogic\. If you install to this location, a folder called 
DOORS 9.1 is created in the Telelogic folder, and all the files your computer 
needs to run the DOORS client are installed in the DOORS 9.1 folder.

If you want to change the directory:

a. Click the Change button.

b. Browse to the directory you want to install to.

c. Click OK.

9. Click Next.
The DOORS database settings screen is displayed.
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Installing the Telelogic License Server

10. Type the port number the DOORS database server is using in the Database 
Port field, and the name of the DOORS database server machine in the 
Database Host field.

11. Click Next.
The License Information screen is displayed.

12. If you do not have details of your license, select Supply license 
information later.
If you know the location of your DOORS license, type the information in 
the appropriate field.

• Telelogic® License Server™

If you are using a floating license, enter the location of the license server 
in the form port@host, for example 19353@licenseserver.

• Local License File

If you have a node-locked license, copy it to a folder on your machine 
and type the path to the file.

Note  If you are installing as a non-admin user you must supply 
license information on this screen.

13. Click Next.
The Ready to Install the Program screen is displayed. 

The settings you defined in the previous steps are displayed. Use the Back 
button if you want to change any of your settings.

14. Click Install.
15. When all the files are copied, the Finish screen is displayed. 

If you want to create a shortcut to DOORS on the desktop, select the check 
box, then click Finish to complete the installation.

Installing the Telelogic License Server
For information on installing the Telelogic License Server, see the Telelogic 
Lifecycle Solutions Licensing Guide, which is available from the Telelogic Lifecycle 
Solutions DVD, and from our website at https://support.telelogic.com.
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Silent installation
Installshield silent installation is supported with DOORS 9.1. This means that 
rather than having to install DOORS from scratch, choosing the same options 
time and time again, you can create an installer that will record your preferred 
settings once and then allow you to install in a more cost efficient and timely 
manner.
To do this, run each product installer from the command line. For the DOORS 
database server, enter a command in the following format:

C:\doors_server\setup.exe /s /v"/l*v 
\"C:\doors_server\install.log\" /qn 
PORTNUMBER=\"36677\" 
DATABASEDIR=\"C:\Program Files\Telelogic\DOORS 9.1\data\" 
INSTALLDIR=\"C:\Program Files\Telelogic\DOORS 9.1\""

For the DOORS client, enter a command in the following format:
msiexec.exe /l*v  
"C:\doors_client\install.log" /qn /i  
"C:\doors_client\Telelogic DOORS 9.1.msi" 
INSTALLDIR="C:\Program Files\Telelogic\" 
CLIENTDATA="36677@server_machine" 
TLLICENSESERVER="19353@license_server"

Note  If you are running silent installation on Windows Vista, you 
need to make sure that User Account Control is switched off.

When you script Telelogic product installations, you must do so in the following 
order:
First, any of Telelogic DOORS, Telelogic® Synergy™, Telelogic® Change™, and 
Telelogic® Tau®. Next, Telelogic DOORS Analyst and Telelogic® 
DocExpress®. Finally, all other products and integrations.
In the event of an error, a silent installation program does not display any dialog 
boxes. Instead, status information for the silent installation is recorded in a log 
file called install.log created in the command lines. You can specify any name 
and location you want.

Starting DOORS

For installations that point to an empty data folder

1. Click Start > All Programs > Telelogic > Telelogic DOORS 9.1.
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Starting DOORS

The following dialog box is displayed:

2. Click OK.

The Change Password dialog box is displayed.

3. Type the password you want to use for the Administrator user into the New 
password and Confirm new password fields. The password must be at 
least six characters long.

4. Click OK.

Note  Make a note of this password. If you forget it, you will 
have to contact Support.

5. The DOORS Explorer, and the Welcome Screen are displayed.
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6. Click Close to dismiss the Welcome Screen.

7. You should only use the Administrator account in emergencies, so create a 
new user account, which you can use next time you log on to DOORS:

a. Click Tools > Manage Users.

b. On the Users tab, click New.

c. Type a username in the Username box.

d. Click the Database Manager user type.

e. Click OK.

f. Click OK.

8. Exit DOORS (click File > Exit).
Don’t remain logged on as the Administrator user.

For installations that point to existing DOORS data

1. Click Start > All Programs >Telelogic > Telelogic DOORS 9.1.

DOORS is loaded and the DOORS login screen is displayed.

2. Type your DOORS username and password and click OK. If you do not 
have a DOORS username, contact your DOORS administrator.
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TDS, the DOORS database and UUIDs

3. The DOORS explorer is displayed.

TDS, the DOORS database and UUIDs
When you use the Telelogic® Directory Server™ (TDS), two files are created in 
the data subfolder (for example, c:\program files\telelogic\doors 
9.1\data\):

• tds_valid_id.txt

• tds_registered.txt

These files are used to associate the database with a Universally Unique Identifier 
(UUID).

tds_valid_id.txt

This file indicates that the repository identifier stored in the database is a valid 
UUID obtained from TDS. As long as this file is present, the database cannot be 
registered with a different UUID. 
If you want to deploy a copy of a database as a new database with a different 
UUID, you need to delete this file. If you want to retain the current UUID, you 
mustn't delete this file.

tds_registered.txt
This file indicates that the repository identifier stored in the database is a valid 
UUID that is recognized by the currently configured TDS. As long as this file is 
present, the database server will not run unless the UUID is found in the TDS 
registry. 
If you want to redeploy a database with its existing UUID on a new TDS server, 
you need to delete this file. You must also make sure that the tds_valid_id.txt file 
is not deleted.

Installing the DOORS Example Data
Telelogic supplies an example database that is already populated with data.
The example database is used to give new DOORS users the opportunity to 
familiarize themselves with DOORS without having to access any of your 
company’s production data or the need to install a local DOORS database server.
To install the Example Data:
1. Ensure you have the DOORS client already installed on your machine.
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2. If you have the training database for a previous version of DOORS installed 
on your machine, remove it.

3. The DOORS Example Data uses port 29998. If you have a DOORS 
database server already using this port on your machine, the Example Data 
will not install correctly.

4. Shut down all other applications. In particular, shut down Microsoft Office 
applications, including the Microsoft Office toolbar.

5. Download the DOORS Example Data software from the website, navigate 
to the file you downloaded, and double-click it.

The Welcome screen is displayed.

6. Click Next.
The License Agreement screen is displayed.

7. If you accept the terms of the license agreement, select the I accept... 
option and click Next.
The Ready to Install the Program screen is displayed. 

8. Click Install.
When all the files are copied, the Finish screen is displayed.

9. Click Finish.

10. Run the example database to make sure it has installed correctly.

Click Start > All Programs > Telelogic > Telelogic DOORS 9.1 
Example Data.

Uninstalling DOORS
Use Add/Remove Programs in the Windows Control Panel to remove version 
9.1 of the DOORS database server, the DOORS client, or the DOORS Example 
Data.

Note  If you uninstall the DOORS Example Data on Windows 
Vista, a warning dialog will be displayed. Click 
Automatically close application. The software will 
uninstall as normal.
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4 Upgrading to DOORS 9.1 from DOORS 9.0
This chapter describes how to upgrade to DOORS 9.1 from 9.0.

• Information for users upgrading to DOORS 9.1 from 9.0

• What happens to my integrations?

• Migrating data to DOORS 9.1

• Installing DOORS

• Checking your installation

Information for users upgrading to DOORS 9.1 from 9.0
In all cases DOORS 9.1 is installed into a new directory named DOORS_9.1 by 
default, and after successful installation DOORS 9.0 is removed.
You cannot install DOORS 9.1 into the same directory as your current 9.0 
installation. If you try to do this the installation will fail.

Data migration

Either:

• Install DOORS 9.1, then copy your 9.0 data to the 9.1 data folder

• Enter the path to your DOORS 9.0 data folder in the Database Settings 
screen when you install the DOORS 9.1 database server.

Licensing

You do not need a new software license for DOORS 9.1 if you are already 
running DOORS 9.0, and have a valid maintenance agreement.

Directory names and menu options

DOORS 9.1 is installed by default to a new directory named DOORS 9.1. You 
cannot install DOORS 9.1 to the same directory as your DOORS 9.0 
installation.
The Start > All Program > Telelogic menu displays Telelogic DOORS 9.1 
after the successful installation of DOORS 9.1.



Upgrading to DOORS 9.1 from DOORS 9.0

18    Telelogic DOORS Installation Guide

Default directories when upgrading to DOORS 9.1

DOORS 9.1 is installed to C:\Program Files\Telelogic\DOORS 9.1 by 
default. You can choose to install into this directory or modify this path to install 
into a new directory. However, you cannot install into the directory in which 9.0 
is currently installed.

Compatibility between DOORS 9.0 and DOORS 9.1
• DOORS 9.0 clients can connect to a DOORS 9.1 database server.

• DOORS 9.1 clients can connect to a DOORS 9.0.

• DOORS 9.1 can read DOORS 9.0.

• DOORS 9.0 clients can read DOORS 9.1 project or module archives and 
partitions.

What happens to my integrations?
When you upgrade from 9.0 to 9.1, your integrations will still run with your 
previous version of DOORS. If you want to run your integrations with DOORS 
9.1, you need to re-install them.

Migrating data to DOORS 9.1
For safety, it is critical that you make a backup of your DOORS data before 
attempting to migrate. The recommended steps for migrating your data are given 
below.

1. Stop the DOORS database server and copy the DOORS data directory to 
the directory that your DOORS 9.1 database server is using.

2. Start the DOORS 9.1 database server.

To initiate the migration, the DOORS Administrator must log on from a 
DOORS 9.1 client and confirm that the data is to be migrated. No-one can 
use DOORS until migration is completed. The DOORS client can be on the 
DOORS database server machine, or on a different machine.

If the Administrator does not successfully log on, or does not confirm that 
migration is required, then no migration will be performed.

3. Select Start > Program Files > Telelogic > Telelogic DOORS 9.1.
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Migrating data to DOORS 9.1

The DOORS login screen is displayed.

Note  If the DOORS login screen is not displayed, you have 
not copied your existing DOORS data to the correct 
directory. If you chose to migrate your data using archive 
and restore, the dialog above is not displayed. 

4. Type the Administrator password. No other DOORS user can log onto the 
unmigrated database.

If you don’t know your Administrator password, contact your local Support 
department

After successful login, the following dialog is displayed: 

5. Click Confirm to begin the migration.

Note  This may only take a few seconds to complete, 
depending on the size of your data.

When the migration is complete, the DOORS database explorer is displayed.

If you have a dbadmin password, you need to perform these additional 
steps:

a. Log off and stop the DOORS database server.

b. Reset the dbadmin password:

Open a DOS command prompt, navigate to the bin directory and enter 
a command in the following format:
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doorsd -R <newpassword> -s <datadirectory>

c. Restart the DOORS database server.

You can now access the data and other DOORS users can log onto DOORS 
9.1.

Installing DOORS
For information on installing DOORS, see the appropriate chapter.

• “New installation of DOORS on Windows,” on page 7

• “Installing the DOORS server on UNIX,” on page 33

Checking your installation

For installations that point to an empty data folder

1. Click Start > Programs > Telelogic > Telelogic DOORS 9.1
The following dialog box is displayed:

2. Click OK.

The Change Password dialog box is displayed.

3. Type the password you want to use for the Administrator user into the New 
password and Confirm new password fields. The password must be at 
least six characters long.

4. Click OK.

Note  Make a note of this password. If you forget it, you will 
have to contact Support.
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Checking your installation

5. The DOORS Explorer, and the Tip of the Day are displayed.

6. Click OK to dismiss the Tip of the Day screen.

7. You should only use the Administrator account in emergencies, so create a 
new user account, which you can use next time you log in to DOORS:

a. Click Tools > Manage Users
b. On the Users tab, click New
c. Type a username in the Username box

d. Click the Database Manager user type

e. Click OK
8. Exit DOORS (click File > Exit).

Don’t remain logged in as an Administrator user

For installations that point to existing DOORS 9 data

1. Click Start > Programs > Telelogic > Telelogic DOORS 9.1
DOORS is loaded and the DOORS login screen is displayed.
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2. Type your DOORS username and password and click OK. If you do not 
have a DOORS username, contact your DOORS administrator.

3. The DOORS explorer is displayed.
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5 Upgrading to DOORS 9.1 from DOORS 5.x, 
6.x, 7.x or 8.x

This chapter discusses what you need to take into consideration when you are 
upgrading to DOORS 9.1 from version 5.x, 6.x, 7.x or 8.x.
It contains information on update paths, licensing and migrating your data.
The installation procedure is the same whether you are upgrading to DOORS 
9.1 or installing it from scratch. For information on the installation procedure, 
follow the appropriate links in the text.

• Migration paths

• Does DOORS 9.1 overwrite DOORS 8.x or 7.x?

• What do I do with my existing DOORS data?

• How does licensing change?

• What happens to my integrations?

• Can I install and set up DOORS 9.1 in phases?

• What do the new installation options mean?

• Upgrading and migrating data to DOORS 9.1

• Installing DOORS

Migration paths
This section answers the following questions:

• Can I migrate directly to DOORS 9.1 from DOORS 5.x?

• Can I migrate directly to DOORS 9.1 from DOORS 6.x?

• Can I migrate directly to DOORS 9.1 from DOORS 7.x?

• Can I migrate directly to DOORS 9.1 from DOORS 8.x?

Can I migrate directly to DOORS 9.1 from DOORS 5.x?

You cannot migrate data directly to DOORS 9.1 from DOORS 5.x. Data must 
first be migrated to DOORS 6.0 SR1 format. It can then be migrated to 
DOORS 9.1. You do not have to upgrade all of your DOORS 5.x clients to 
DOORS 6.0 SR1. Only the DOORS 5.x database needs to be migrated.
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Telelogic recommends you migrate your data in the following way:

1. Install a DOORS 6.0 SR1 Complete Server Installation, accepting the 
default data directory.

2. Copy your DOORS 5.x database to this default directory.

3. Run DOORS 6.0 SR1.

4. Log on as Administrator.

5. Click Confirm to migrate your data.

Caution  You must complete the data migration from DOORS 5.x 
to DOORS 6.0 SR1 by running the Module Migrator 
DXL. This DXL can be obtained by contacting Support. 
If you do not run this DXL before you migrate the data 
to DOORS 9.1, your data migration will not be complete 
and some data may not display correctly. 
If you are migrating a very large database, you can run the 
module migrator DXL on more than one DOORS client, 
as long as each client is running on a different machine. 
This allows you to migrate different sections of the data 
at the same time. Do not run more than on DOORS 
client on any one machine at the same time when running 
the Module Migrator DXL.

For more information refer to the DOORS 6.0 SR1 Installing and Setting Up 
Guide, which is available from the DOORS/ERS 6.0 SR1 documentation CD 
and from the website at https://support.telelogic.com.
When you have completed the data migration from DOORS 5.x to DOORS 6.0 
SR1, you can migrate the data from DOORS 6.0 SR1 to DOORS 9.1. For 
information on how to do this, see “Upgrading and migrating data to DOORS 
9.1,” on page 28.

Can I migrate directly to DOORS 9.1 from DOORS 6.x?

You can migrate data directly to DOORS 9.1 from DOORS 6.x.

Can I migrate directly to DOORS 9.1 from DOORS 7.x?
You can migrate data directly to DOORS 9.1 from DOORS 7.x.

Can I migrate directly to DOORS 9.1 from DOORS 8.x?

You can migrate data directly to DOORS 9.1 from DOORS 8.x.



Telelogic DOORS Installation Guide           25

Does DOORS 9.1 overwrite DOORS 8.x or 7.x?

Does DOORS 9.1 overwrite DOORS 8.x or 7.x?
DOORS 9.1 does not overwrite DOORS 8.x or 7.x. The following defaults apply 
when you install DOORS 9.1 on Windows:

• DOORS 9.1 is installed to a new directory named DOORS 9.1.

• A new label, Telelogic DOORS 9.1, is added to the Start > All Programs 
> Telelogic menu.

• The DOORS database server service is called DOORS DB Server 9.1.

Note  You can install multiple database server services on your 
PC with DOORS 9.1. For more information see the 
Managing DOORS manual, which is available from the 
Telelogic Lifecycle Solutions DVD and from the 
website at https://support.telelogic.com.

• The DOORS database server port number defaults to 36677. This was also 
the default for previous versions of DOORS. If you want to be able to run 
your existing DOORS database server and a DOORS 9.1 database server 
from your machine, you should ensure that the 9.1 database server runs on a 
different port.

• By default, the DOORS 9.1 database server points to an empty data 
directory in the DOORS 9.1 directory. Telelogic recommends that you do 
not change this default path. This gives you more control over how and 
when you migrate your existing DOORS data. For information on the 
options available see “What do I do with my existing DOORS data?,” on 
page 25.

• The DOORS 9.1 client installs to a new directory. By default, this is 
C:\Program Files\Telelogic\DOORS 9.1. This means that your 
previous DOORS is not overwritten, and you can run DOORS 7.x or 8.x 
and DOORS 9.1 in parallel on the same machine.

These defaults do not apply to UNIX. For information on upgrading to 
DOORS 9.1 on UNIX, see “Installing the DOORS database server,” on page 
33.

What do I do with my existing DOORS data?
Caution  We strongly recommend that you make a copy of your 

data directory before installing DOORS 9.1, or migrating 
any data to DOORS 9.1. Once you have migrated your 
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data to DOORS 9.1 format, you cannot reverse the 
migration.

You have four options for migrating existing DOORS data to DOORS 9.1:

• Stop the DOORS database server, copy the DOORS data directory to the 
directory that your DOORS 9.1 database server is using, then restart the 
DOORS database server. Run a DOORS 9.1 client and log on as the 
Administrator user.

This gives you the maximum amount of control over when you migrate your 
data. You can install your DOORS database server, and all the DOORS 
clients, pointing them all to the empty data directory. This means that none 
of your DOORS 9.1 clients can access your DOORS data and migrate it 
until you are ready to do so. When you are ready to migrate your data, you 
can copy it to the empty directory and run a DOORS client against it. When 
you log on as the Administrator user, your data is migrated to DOORS 9.1.

• Point the DOORS 9.1 database server at the DOORS data directory when 
you install DOORS 9.1, then run a DOORS client and log on as 
Administrator.

We do not recommend you do this unless you have:

a. Made a copy of the DOORS data directory.

b. Ensured that the data is ready to migrate.

You should bear in mind that any DOORS client using the DOORS 9.1 
database server who has access to the Administrator password could migrate 
the data.

• Archive the projects you want to migrate, then restore them to DOORS 9.1.

Telelogic recommends that you only use this option for initial testing of 
DOORS 9.1. Using archive and restore as a means of migrating data is time 
consuming. It also results in the loss of access controls and cross-project 
links.

• Make a copy of your current DOORS data directory. Access the copied data 
directory from a DOORS 7.x or 8.x client, and delete the projects and 
folders that you do not want to migrate to DOORS 9.1.

This allows you to implement a phased migration of your DOORS data. 
However, after the initial data migration the remaining DOORS data must 
be migrated to DOORS 9.1 using archive restore. Using this method to 
migrate data is time consuming. If you archive and restore data from the 
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How does licensing change?

same master database that was migrated, then access controls and cross-
project links are preserved.

How does licensing change?
The action you need to take depends on the version of DOORS you are running, 
and whether you have a valid maintenance agreement:

• If you are running DOORS 8.2 or 8.3, and you have a valid maintenance 
agreement, you do not need a new license to install and run DOORS 9.1.

• If you are running DOORS 8.2 or 8.3, and do not have a valid maintenance 
agreement, a message is displayed:
The FEATURE name DOORS with version 2008.1101 cannot be found. 
License server does not support this version of the feature

If this message is displayed, you need to obtain a new license.

• If you are running a version of DOORS earlier than 8.2, you need a new 
license to run DOORS, and you also need to install either version 1.3, 1.4 or 
1.5 of the Telelogic License Server.

When Telelogic released DOORS 8.2, we upgraded the version of FLEXnet® to 
v11.5, and we changed all DOORS licenses to use the Telelogic vendor daemon 
instead of the DOORS daemon. This allowed you to merge all of your Telelogic 
licenses into one license key. The default port number used for licensing was 
changed to 19353; the previous port used for licensing was 7192.
Rainbow dongles are no longer supported with DOORS. Customers who have 
previously used Rainbow dongles to run DOORS must contact their local 
Support department. Other existing hardware licenses do not need to be 
replaced.
For more information about licensing, see the Telelogic Lifecycle Solutions Licensing 
Guide, which is available from the Telelogic Lifecycle Solutions DVD and 
from our website at https://support.telelogic.com.

What happens to my integrations?
When you upgrade to 9.1, you will need to upgrade your integrations too. New 
versions of all the integrations are being released, and will be available from the 
Telelogic Lifecycle Solutions DVD and from our website at https://
support.telelogic.com.
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Can I install and set up DOORS 9.1 in phases?
As DOORS 9.1 does not overwrite previous DOORS installations, you can 
install your DOORS database server and all your DOORS clients alongside the 
versions you are currently using. You can choose when to migrate your data. If 
you want some users to start using the new DOORS version while others 
continue using the old one, they can do so as long as you have made sure that the 
DOORS 9.1 database server is using a different port than your existing DOORS 
database server.

What do the new installation options mean?
The installation options changed after DOORS 8.0. This is in line with other 
Telelogic products.

Upgrading and migrating data to DOORS 9.1
• DOORS 7.x and 8.x clients cannot connect to a DOORS 9.1 database 

server.

• DOORS 9.1 clients cannot connect to a DOORS 7.x database server.

• DOORS 9.1 can read DOORS 5.x, DOORS 6.0 SR1, DOORS 7.x or 
DOORS 8.x project and module archives.

• DOORS 7.x and DOORS 8.x clients cannot read DOORS 9.1 project or 
module archives, or partitions.

• DOORS 9.1 clients cannot read DOORS 7.x and DOORS 8.x partitions. 
Partitions must be rejoined or recovered before you migrate data to DOORS 
9.1.

9.x/8.x 7.1 6.0 SR1

DOORS Client Installation DOORS Standard End User DOORS Client 
Installation

DOORS Database Server 
Installation

DOORS/ERS Complete 
Server Installation

DOORS Complete 
Server Installation

DOORS Laptop/Non-
networked PC

DOORS Complete 
Server Installation

Workstation Client DOORS Remote 
Access Client
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Upgrading and migrating data to DOORS 9.1

• CPS review cycles do not have to be completed before you migrate your data 
to DOORS 9.1.

If a DOORS 7.x or DOORS 8.x client tries to connect to the 9.1 server, it will 
not be allowed to connect and will receive a message that states Cannot connect 
to server. The network is busy. 

Migrating data to DOORS 9.1
For safety, it is critical that you make a backup of your DOORS data before 
attempting to migrate. The recommended steps for migrating your data are given 
below.

1. Stop the DOORS database server and copy the DOORS data directory to 
the directory that your DOORS 9.1 database server is using.

2. Start the DOORS 9.1 database server.

To initiate the migration, the DOORS Administrator must log on from a 
DOORS 9.1 client and confirm that the data is to be migrated. No-one can 
use DOORS until migration is completed. The DOORS client can be on the 
DOORS database server machine, or on a different machine.

If the Administrator does not successfully log on, or does not confirm that 
migration is required, then no migration will be performed.

3. Select Start > Program Files > Telelogic > Telelogic DOORS 9.1.

The DOORS login screen is displayed.

Note  If the DOORS login screen is not displayed, you have 
not copied your existing DOORS data to the correct 
directory. If you chose to migrate your data using archive 
and restore, the dialog above is not displayed. 

4. Type the Administrator password. No other DOORS user can log onto the 
unmigrated database.
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If you don’t know your Administrator password, contact your local Support 
department

After successful login, the following dialog is displayed: 

5. Click Confirm to begin the migration.

Note  This may only take a few seconds to complete, 
depending on the size of your data.

When the migration is complete, the DOORS database explorer is displayed.

If you have a dbadmin password, you need to perform these additional 
steps:

a. Log off and stop the DOORS database server.

b. Reset the dbadmin password:

Open a DOS command prompt, navigate to the bin directory and enter 
a command in the following format:
doorsd -R <newpassword> -s <datadirectory>

c. Restart the DOORS database server.

You can now access the data and other DOORS users can log onto DOORS 
9.1.

Installing DOORS
For information on installing DOORS, see the appropriate chapter.

• “New installation of DOORS on Windows,” on page 7

• “Installing the DOORS server on UNIX,” on page 33
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6 Installing and using DOORS on Citrix
This chapter discusses describes how to install DOORS on Citrix. It contains the 
following:

• Supported platforms

• Installation guidelines

• Environment specifications

• Configuring external links

Supported platforms
DOORS 9.1 is supported on:

• Citrix Presentation Server v4.5 on Windows 2003 Server Standard and 
Enterprise Edition (32 bit and 64 bit), using the Citrix ICA client v 
10.00.52110 on Windows XP.

Although it may be possible for DOORS 9.1 to work with other versions of 
Citrix on other supported DOORS platforms, they have not been tested and are 
not supported.

Installation guidelines
Terminal services must be activated on the host machine, then Citrix can be 
installed. These steps must take place before any applications are installed. At 
installation of Citrix, it is useful to rename the drives from A: C: D: etc., to M: N: 
& O:, for example. Doing this allows the Citrix clients to map their local drives 
(through redirection) to the drive letters of A: C: and D:. The swap file should 
also be increased, for example, to 2.5 times the amount of memory available. The 
registry file size should also be increased appropriately to accommodate the 
multiple current_user_keys required.
To install DOORS 9.1 on Citrix you must be in “install mode”.
Telelogic recommends that you configure DOORS 9.1 to display in “Seamless 
mode”. You may experience problems if you display in “Desktop mode”.
As a result of product performance enhancements, the DOORS 9.1 client will 
only display colors correctly for text highlighting when using the 16 bit color 
depth resolution in the Citrix ICA client.
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Environment specifications
For the best performance, install the DOORS database server on a different 
machine to the Citrix server. To optimize performance, place both machines as 
geographically close to one another as possible. The DOORS licence server can 
be located on either machine, or a separate machine.
No DOORS Integrations have been tested in a Citrix environment.

Configuring external links
You need to configure DOORS to allow external links to access locations in 
DOORS via Citrix.
To configure external links:

1. On the Citrix server, publish protocolhandler.exe to accept parameters:
C:\Program Files\Telelogic\DOORS 9.1\bin\protocolhandler.exe %*

2. On the desktop where the Citrix DOORS client is accessed, copy the 
following to a .reg file and run it to add it to the registry: 
  Windows Registry Editor Version 5.00
  [HKEY_CLASSES_ROOT\doors]
  @="URL:DOORS protocol"
  "URL Protocol"=""
   
  [HKEY_CLASSES_ROOT\doors\Default Icon]
  @=""
   
  [HKEY_CLASSES_ROOT\doors\shell]
  [HKEY_CLASSES_ROOT\doors\shell\open]
  [HKEY_CLASSES_ROOT\doors\shell\open\command]
  @="\"C:\\Program Files\\Citrix\\ICA Client\\pn.exe\" /
pn:DOORS_CITRIX /app:protocolhandler /param:\"-r 120 -url %1\""

• DOORS_CITRIX is the application set name containing the 
protocolhandler and the DOORS applications.

• protocolhandler is the application name as published in the Citrix server.

• -r 120 -url %1 are the parameters that are passed to the protocolhander 
application in the Citrix server. When you click on a URL, %1 is replaced by 
the URL string.

When you click on an external link, it will open.
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7 Installing the DOORS server on UNIX
This chapter describes how to install and set up version 9.1 of DOORS on 
UNIX computers. It contains the following:

• Understanding UNIX installations

• Installing the DOORS database server

Understanding UNIX installations
The Telelogic Lifecycle Solutions DVD contains the files for installing 
DOORS servers on UNIX. These files can also be downloaded from our 
website at https://support.telelogic.com.
The following files are available. 

• solaris_server.zip
• hpux_server.zip
• linux_server.zip

Installing the DOORS database server
To use the UNIX versions of the DOORS server in a traditional client-server 
configuration, install the DOORS database server first on the server machine 
and then install DOORS on Windows client machines but ensure that they are 
connecting to the database server on the port serving the DOORS data.
If you are upgrading from a previous version of DOORS, read the chapter 
entitled “Upgrading to DOORS 9.1 from DOORS 5.x, 6.x, 7.x or 8.x,” on page 
23.
To install the DOORS database server:
1. Check that you meet the system requirements for installing and running the 

DOORS database server. Details of system requirements can be found in 
the readme file, and on the website at https://support.telelogic.com.

2. If you’re installing DOORS for the first time, go to Step 4.

3. If you’re reinstalling, stop the DOORS database server.

a. Change your working directory to $DOORSHOME/bin.

b. Enter the following command:
dbadmin -data port@computer -killserver [-password password]
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See the following table for what each parameter means.

4. Log on as root. The installation must be performed using the root account.

5. If you’re installing DOORS for the first time, create a non-privileged user 
account to own the DOORS data and application files.

Telelogic recommends that you create an account called doors. We call this 
user the DOORS owner.

6. Set up the directory you want to install DOORS in (the DOORS home 
directory):

a. Create the DOORS home directory.

b. Use the chown command to set the owner of the new directory to the 
DOORS owner.

c. Set the $DOORSHOME environment variable to point to the new directory.

7. You can either install from the Telelogic Solutions DVD or from DOORS 
software downloaded from the Telelogic website.

If you downloaded the software from the web, uncompress the archive to a 
temporary location on your computer, and go to Step 8.

If you are installing DOORS from DVD:

a. Put the Telelogic Lifecycle Solutions DVD into your DVD-ROM 
drive.

b. Mount it.

The following table describes how to mount your DVD-ROM drive:

Where Is

port The port the server is using (by default, 36677).

computer The name of the computer the server is running on.

password The server’s password (omit the -password switch if the 
password is currently blank).

Platform Example command

Solaris mount -r -F hsfs /dev/sr0 /cdrom

HP-UX mount -r -F cdfs /dev/dsk/c0t2d0 /cdrom
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Installing the DOORS database server

Note  On Sun Solaris and Linux, if the volume manager is 
configured, it automatically mounts the DVD-ROM.

c. Navigate to the DOORS UNIX server directory on the DVD, and 
uncompress the server zip you need to a temporary location on your 
computer.

8. Run the installation script, giving the full path including the disk device. For 
example, if you unzipped the archive to /mydisk/temp, enter:
/mydisk/temp/doors_9/unix/bin/instdoor.sh

9. Follow the instructions on your screen to install DOORS.

10. Answer the prompts on the screen:

a. Enter path to DVD-ROM device or DOORS distribution:
[/cdrom]

b. Enter y at the second prompt, to install the DOORS database server:
Install package DOORS_SERVER [ y ]: y

c. Enter the path to the DOORS home directory you created in Step 6

d. Enter the name of the DOORS owner (by default, doors).

e. Confirm that you want to install the server.

f. The installation script then confirms all the installation options and 
installs the files. Press ENTER when the installation finishes.

11. Edit the startup file of the DOORS owner.

The following table shows the lines you must add or edit:

Linux® mount /dev/cdrom

Startup file Code

Bourne or K shell 
.profile 

DOORSHOME=doors-home-path

SERVERDATA=datapath

PATH=$DOORSHOME/bin:$PATH

PORTNUMBER=database-server-port-number

export DOORSHOME SERVERDATA PATH PORTNUMBER 
DOORSDATA

Platform Example command
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12. Start the DOORS database server:

a. Log on as the DOORS owner user.

b. Change your working directory to $DOORSHOME/bin.

c. Enter the following command:
./doorsd &

Note  If you use the Korn shell and do not use “doorsd 
&” in a system startup script then you should execute 
the following command instead:

“nohup doorsd &”

C shell .login setenv DOORSHOME doors-home-path

setenv SERVERDATA datapath

set path=($DOORSHOME/bin $path)

setenv PORTNUMBER database-server-port-number

Startup file Code
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8 Installing Telelogic DOORS for ClearCase 
Interface on Windows

This chapter describes how to install and set up version 2.1 of Telelogic DOORS 
for ClearCase Interface to integrate with DOORS 9.1. It contains the following:

• Check that you meet the system requirements

• Installing Telelogic DOORS for ClearCase Interface

• Uninstalling Telelogic DOORS for ClearCase Interface

Check that you meet the system requirements
The system requirements for running version 2.1 of Telelogic DOORS for 
ClearCase Interface on Windows are:

• Your computer must be running Windows XP

For information on minimum and recommended system requirements 
(RAM, processor power and so on), visit the support center on our web site 
at https://support.telelogic.com.

• DOORS 9.1

Note  Do not choose Remote Client Installation when you 
install DOORS.

• ClearCase 2003.06.xx (International English edition) or IBM Rational 
ClearCase 7.0.0.0

Installing Telelogic DOORS for ClearCase Interface
Follow these steps to install Telelogic DOORS for ClearCase Interface:
1. Download the Telelogic DOORS for ClearCase Interface software from the 

Telelogic web site.

2. Make sure you’re logged onto your computer as the local Administrator, and 
not a user with Administrator privileges.

3. Shut down all other applications. In particular, shut down DOORS and 
ClearCase.

4. Using Windows Explorer, double-click the file you downloaded.
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5. You see the Telelogic DOORS for ClearCase Interface welcome screen.

6. Run the installation, following the instructions on screen.

7. When the installation is complete, the setup complete screen is displayed.

8. Click Finish to complete setup.

For information on how the integration works see the Using Telelogic DOORS 
for ClearCase Interface manual. This is available from our website at https://
support.telelogic.com.

Uninstalling Telelogic DOORS for ClearCase Interface
Use Add/Remove Programs in the Windows Control Panel to remove version 
2.1 of Telelogic DOORS for ClearCase Interface.
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9 Installing Telelogic DOORS for ClearQuest 
Interface on Windows

This chapter describes how to install and set up version 2.2 of Telelogic DOORS 
for ClearQuest Interface to integrate with DOORS 9.1. It contains the following:

• Check that you meet the system requirements

• Installing Telelogic DOORS for ClearQuest Interface

• Uninstalling Telelogic DOORS for ClearQuest Interface

Check that you meet the system requirements
The system requirements for running version 2.2 of Telelogic DOORS for 
ClearQuest Interface on Windows are:

• Your computer must be running Windows XP

For information on minimum and recommended system requirements 
(RAM, processor power, and so on), visit the support center on our website 
at http://www.support.telelogic.com.

• DOORS 9.1

• ClearQuest 2003.06.xx (International English edition) or IBM Rational 
ClearQuest 7.0.0.0

Installing Telelogic DOORS for ClearQuest Interface
Follow these steps to install Telelogic DOORS for ClearQuest Interface:

1. Download the Telelogic DOORS for ClearQuest Interface software from 
the Telelogic web site.

2. Make sure you are logged onto your computer as the local Administrator, 
and not a user with Administrator privileges.

3. Shut down all other applications. In particular, shut down DOORS and 
ClearQuest.

4. Using Windows Explorer, double-click the file you downloaded.

5. You see the Telelogic DOORS for ClearQuest Interface welcome screen.

Run the installation, following the instructions on screen.
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6. When the installation is complete, the setup complete screen is displayed.

7. Click Finish to complete setup.

For information on how the integration works see the Using Telelogic DOORS 
for ClearQuest Interface manual. This is available from our website at https://
support.telelogic.com.

Uninstalling Telelogic DOORS for ClearQuest Interface
Use Add/Remove Programs in the Windows Control Panel to uninstall 
version 2.2 of Telelogic DOORS for ClearQuest Interface.
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10 Installing Telelogic DOORS for Rose 
Interface on Windows

This chapter describes how to install and set up version 2.10 of Telelogic 
DOORS for Rose Interface to integrate with DOORS 9.1. It contains the 
following:

• Check that you meet the system requirements

• Installing Telelogic DOORS for Rose Interface

• Uninstalling Telelogic DOORS for Rose Interface

Check that you meet the system requirements
The system requirements for running version 2.10 of Telelogic DOORS for 
Rose Interface are:

• Your computer must be running Windows XP

For information on minimum and recommended system requirements 
(RAM, processor power, and so on), visit the support center on our web site 
at https://support.telelogic.com.

• DOORS 9.1

• Rational Rose 2003.06.xx or 7.0.0.0

Installing Telelogic DOORS for Rose Interface
Follow these steps to install Telelogic DOORS for Rose Interface:
1. Download the Telelogic DOORS for Rose Interface software from the 

Telelogic web site.

2. Make sure you are logged onto your computer as the local Administrator, 
and not a user with Administrator privileges.

3. Shut down all other applications. In particular, shut down DOORS and 
Rational Rose.

4. Using Windows Explorer, double-click the file you downloaded.

5. You see the Telelogic DOORS for Rose Interface welcome screen.

Run the installation, following the instructions on screen.
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6. When the installation is complete, the setup complete screen is displayed.

7. Click Finish to complete setup.

For information on how the integration works see the Using Telelogic DOORS 
for Rose Interface manual. This is available from our website at https://
support.telelogic.com.

Uninstalling Telelogic DOORS for Rose Interface
Use Add/Remove Programs in the Windows Control Panel to remove version 
2.10 of Telelogic DOORS for Rose Interface.
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11 Installing Telelogic DOORS for Serena 
Version Manager Interface on Windows

This chapter describes how to install and set up version 1.4 of Telelogic DOORS 
for Serena Version Manager Interface to integrate with DOORS 9.1. It contains 
the following topics:

• Check that you meet the system requirements

• Installing Telelogic DOORS for Serena Version Manager Interface

• Setting up licences

• Uninstalling Telelogic DOORS for Serena Version Manager Interface

Check that you meet the system requirements
The system requirements for running version 1.4 of Telelogic DOORS for 
Serena Version Manager Interface are:

• Your computer must be running Windows XP

For information on minimum and recommended system requirements 
(RAM, processor power, and so on), visit the support center on our web site 
at https://support.telelogic.com.

• DOORS 9.1

• Version Manager 8.0.0.3 or 8.1.3

Note  As a new feature, PVCS Version Manager 8.0 provides 
support for a file server system, in the form of a port@host 
setting. Telelogic DOORS for Serena Version Manager 
Interface 1.4 does not support the file server system. You can 
only use Telelogic DOORS for Serena Version Manager 
Interface 1.4 on mapped data.

Installing Telelogic DOORS for Serena Version Manager Interface
Follow these steps to install Telelogic DOORS for Serena Version 
Manager Interface:
1. Download the Telelogic DOORS for Serena Version Manager Interface 

software from the Telelogic web site.
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2. Make sure you are logged onto your computer as the local Administrator, 
and not a user with Administrator privileges.

3. Shut down all other applications. In particular, shut down DOORS and 
PVCS Version Manager.

4. Using Windows Explorer, double-click the file you downloaded.

5. You see the Telelogic DOORS for Serena Version Manager Interface 
welcome screen.

Run the installation, following the instructions on screen.

6. When the installation is complete, the setup complete screen is displayed.

7. Click Finish to complete setup.

For information on how the integration works see the Using Telelogic DOORS 
for Serena Version Manager Interface manual. This is available from our website 
at https://support.telelogic.com.

Setting up licences
If you are installing Telelogic DOORS for Serena Version Manager Interface for 
the first time or reinstalling or upgrading from an earlier version of the 
integration, you have to request and setup a new license before you can use it. 
For information about licensing, see the Telelogic Lifecycle Solutions Licensing Guide, 
which is available from the Telelogic Lifecycle Solutions DVD.

Uninstalling Telelogic DOORS for Serena Version Manager Interface
Use Add/Remove Programs in the Windows Control Panel to remove version 
1.4 of PVCS Version Manager.
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12 Troubleshooting
This chapter contains the following:

• Installing DOORS as a non-admin user

• Problems installing the software

• If you have no Export to DOORS button in Word

• Using the DOORS API

• Colors

• DISPLAY variables on Solaris

• DISPLAY variables—all UNIX installations

• Dual Boot Machines

Note  Go to the support center on our website at http://
www.support.telelogic.com for the latest information on 
problems you may encounter when you install and set up 
DOORS, and how to work around the problems.

Installing DOORS as a non-admin user
When you install the DOORS database server, you must be logged onto the 
machine as a user with administrator privileges. However, you can install the 
DOORS client as a non-admin user providing the system administrator has set 
the non-admin user up with the following options.

• On Windows 2003 systems the user that launches the installation must have 
been granted the impersonate privilege. To do this:

a. Click Start > All Programs > Administrative Tools > Local Security 
Policy.

b. Expand Local Policies, and then click User Rights Assignment.
c. In the right pane, double-click Impersonate a client after 

authentication.

d. In the Local Security Policy Setting dialog box, click Add.

e. In the Select Users or Group dialog box, click the user account that 
you want to add, click Add, and then click OK.

f. Click OK.
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• The Always install with elevated privileges policy must be enabled in the 
group policy for non-admin users who need to install the DOORS client.

Caution  When the DOORS client is installed by a non-admin user, the 
Client License Setup Utility is not installed. This is because 
a user must have administrator privileges to run it. You must 
set up your license when prompted during the installation.

• If you are upgrading from a previous version of DOORS, you must remove 
it using Add/Remove Programs in the Windows Control Panel before you 
install DOORS 9.1.

Problems installing the software
If you have problems installing any of the products in the DOORS product 
family, try the following before you contact our Support team for help:

• Stop all applications before you install the software.

Shut down all the applications running on your computer.

• Turn off virus protection software.

When virus protection software is running in the background, it can 
interfere with the installation of any software product because of the way 
installers decompress files when they install them on your computer.

• Make sure you meet the system requirements for the product you’re trying to 
install.

For each product, the chapter in this book that describes how to install the 
product starts by listing the system requirements for the product. Make sure 
you meet the system requirements before you try to install the product.

• Restart your computer, and then try installing the DOORS product again.

If you have no Export to DOORS button in Word
If you have no Export to DOORS button, it may be because you’ve modified 
the location of your Word startup folder.
To change or check this folder:
1. In Word, click Tools > Options. 

2. Select the File Locations tab.

The Startup entry shows the location of your Word startup folder.
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Using the DOORS API

3. If there is no copy of the DOORS template file, copy doors.dot from the 
\lib\word folder in the DOORS home folder (for example, c:\program 
files\telelogic\doors 9.1\lib\word) to your Word startup folder.

4. Staying in Word, click Tools > Templates and Add ins, and make sure 
doors.dot is selected in the list of items that are currently loaded.

5. Right-click the Word toolbar and select DOORS.

The Export to DOORS button is displayed on the Word toolbar.

Using the DOORS API
The DOORS API will only work with TCP/IP communication. Socket-based 
communication in UNIX is not supported.

Colors
If your display card supports only 256 colors, you may experience unusual color 
effects. This will not affect underlying data, but Telelogic recommends you use a 
display that supports more than 256 colors.

DISPLAY variables on Solaris
A Solaris DOORS client can now run in batch mode without a DISPLAY 
environment variable being set.
If the batch-mode DXL attempts to use the GUI and DISPLAY has not been 
defined, DOORS will exit.
If DISPLAY has been defined, DOORS will attempt to connect to the specified X 
display, even if the batch-mode DXL doesn’t use a GUI. As a result, DISPLAY 
must refer to a valid X display that you are authorized to connect to.

DISPLAY variables—all UNIX installations
The X display must be specified with the DISPLAY environment variable; using 
the standard -display or -d options does not work.

Dual Boot Machines
If you have a dual boot machine and DOORS 9.1 is installed on one of the 
operating systems you cannot install it on the other operating system as well.
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13 Contacting support
This chapter contains the following topics:

• Contacting IBM Rational Software Support

• What to do before you contact Support

• Sending an automated problem report form

• Other information

Contacting IBM Rational Software Support
Support and information for Telelogic products is currently being transitioned 
from the Telelogic Support site to the IBM Rational Software Support site. 
During this transition phase, your product support location depends on your 
customer history.

Product support
• If you are a heritage customer, meaning you were a Telelogic customer prior 

to November 1, 2008, please visit the DOORS Support Web site.

Telelogic customers will be redirected automatically to the IBM Rational 
Software Support site after the product information has been migrated.

• If you are a new Rational customer, meaning you did not have 
Telelogic-licensed products prior to November 1, 2008, please visit the IBM 
Rational Software Support site.

What to do before you contact Support
If your site has a designated on-site support person, please contact that person 
before you contact our Support team.
To help our Support team solve your problem, please have the following 
information available:

• Your name, title, company name, e-mail address, fax number and telephone 
number.

• Your support ID and support password.

• The version and build number of DOORS that you’re running.

To get this information, run DOORS, and click Help > About DOORS.

https://support.telelogic.com/doors
http://www.ibm.com/software/rational/support/
http://www.ibm.com/software/rational/support/
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• The operating system you’re running DOORS on, for example Windows 
XP.

• What operating system your DOORS database is running on, if different.

• If you are reporting a new problem, please have a clear statement of the 
problem, including the exact text of any error messages produced by 
DOORS, your operating system, or any other tools that were running when 
the problem occurred.

• If you are calling about a problem you reported earlier, you need the original 
tracking number the Support team assigned to your problem.

• If you want, you can use the automated problem report form. For 
information, see “Sending an automated problem report form,” on page 50.

The support center on our web site is at https://support.telelogic.com.

Sending an automated problem report form
To send an automated problem report to Support:
1. Select Help > Generate Support Request.

The Telelogic Support Information dialog box is displayed with some of 
your product information automatically included.

Review the information to make sure it’s accurate.

2. From the Impact drop down list box, select the severity of the problem.

3. In the Summary box, summarize the problem.

4. In the Problem box, type a detailed description of the problem.

5. If available, attach a snapshot.

Click either DOORS Window Snapshot or Screen Snapshot, whichever is 
applicable, and select the snapshot from your machine.

6. If possible, use the buttons in the Attachment Information area to add 
video capture, system details and files.

Note  The Add Product Files button is unavailable in 
DOORS. Product information is collected and added 
automatically.

Add any relevant information to help Support resolve the problem.

7. You can either:
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Sending an automated problem report form

• Display the information you’ve entered in a new window so that you can 
copy it. For example, you may want to add this information to someone 
else’s information. 

Click Just Text (No Email).
• Open the email to edit it before sending it to Support. 

Click Preview and Send to submit the report.

Guidelines for writing a problem report

• Be as specific as possible when you summarize the problem in the 
Summary box and when you explain the situation and provide details in the 
Problem box. For example, “The system crashed when I tried to add an 
attribute” is more helpful than “It crashed.”

• Indicate if there were any system changes, such as customizations or 
upgrades, before the problem occurred.

• If the problem is reproducible, list the specific steps to be followed in order 
to demonstrate the problem and also indicate the model you are using to 
perform the steps.

• In the problem description, include anything different or unusual that you 
observed before the problem happened.

• Make screen captures of anything that you feel will help and attach them to 
the problem report.

• Include any error messages and code samples you have related to the 
problem.

• If you have multiple unrelated questions or issues, please submit them 
separately. 

Automatic responses and recording defects

When you send the online form to Support, the customer service system 
immediately searches the Knowledge Base based on the Summary and 
Problem descriptions you entered. If there is an exact match of your problem in 
the knowledge base, the system automatically sends an email to you with a 
pointer to the most likely solution.
The problem is also automatically recorded in the defect tracking system as 
assigned to a support representative. This representative works with you to be 
certain that your problem is solved. The defect tracking system also records new 
problems with their solutions in the Knowledge Base to provide rapid assistance 
for other customers.
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Automatically generated problem reports

If your DOORS system crashes, it displays a message asking if you want to send 
a problem report about the crash to DOORS Support.
If you decide to send this generated report, the system displays the same online 
form that is available from Help > Generate Support Request. In this case, 
the form contains information about the crash condition, in addition to the 
information that is usually filled in describing your system. 
Add any more information that you can to help the Support staff identify the 
problem before you click the Preview and Send button.

Changing the email address of the problem report
If you want to send the problem to someone other than DOORS Support, for 
example to your internal support, you can change the default email address of 
the problem report.
To change the email address of the problem report:
1. Open System in the Control Panel.
2. On the Advanced tab, click Environment Variables, then click New under 

variables.

The New User Variable window is displayed

3. In Variable Name enter ILX_RECIP, the variable that controls the 
address used by the problem report.

4. In Variable Value enter the email address you want to use.

5. Click OK to add the value.

6. Click OK to save the value in the environment variables.

7. Click OK to save the value in the system properties.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software Web site.

http://www.ibm.com/software/rational/
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14 Notices
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user's responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan  
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
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This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
1 Rogers Street 
Cambridge, Massachusetts 02142 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
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Trademarks

performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks

IBM, the IBM logo, ibm.com, Telelogic, Telelogic DOORS, Telelogic Synergy, 
Telelogic Change, Telelogic Tau, Telelogic DocExpress, Telelogic License Server, 
Telelogic DOORS for ClearCase Interface, Telelogic DOORS for ClearQuest 
Interface, Telelogic DOORS for Rose Interface, Telelogic DOORS for Serena 
Version Manager Interface are trademarks or registered trademarks of 
International Business Machines Corporation in the United States, other 
countries, or both. These and other IBM trademarked terms are marked on their 
first occurrence in this information with the appropriate symbol (® or ™), 
indicating US registered or common law trademarks owned by IBM at the time 
this information was published. Such trademarks may also be registered or 
common law trademarks in other countries. A current list of IBM trademarks is 
available on the Web at www.ibm.com/legal/copytrade.html.
Linux is a registered trademark of Linus Torvalds in the United States, other 
countries, or both.
FLEXnet is a registered trademark or trademark of Macrovision Corporation.
Microsoft and Windows are trademarks of Microsoft Corporation in the United 
States, other countries, or both.
UNIX is a registered trademark of The Open Group in the United States and 
other countries.
Other company, product or service names may be trademarks or service marks 
of others.
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