
Telelogic DOORS 
Using Telelogic DOORS for ClearQuest 
Interface





Telelogic DOORS for ClearQuest Interface

Using Telelogic DOORS for ClearQuest 
Interface

Release 2.2



Before using this information, be sure to read the general information under the 
"Notices" chapter on page 27.

This edition applies to VERSION 2.2, Telelogic DOORS for ClearQuest 
Interface and to all subsequent releases and modifications until otherwise 
indicated in new editions.
© Copyright IBM Corporation 1993, 2008 
US Government Users Restricted Rights—Use, duplication or disclosure 
restricted by GSA ADP Schedule Contract with IBM Corp.



Using Telelogic DOORS for ClearQuest Interface     iii

Table of contents

Chapter 1: About this manual                                                                         1
Typographical conventions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1
Related documentation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  1

Chapter 2: Concepts                                                                                           3
About Telelogic DOORS for ClearQuest Interface. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3
About Telelogic DOORS for ClearQuest Interface functions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3
Configuring Telelogic DOORS for ClearQuest Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  3

Chapter 3: Configuring Telelogic DOORS for ClearQuest Interface   5
Configuring projects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5
Configuring forms . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9

Chapter 4: Using Telelogic DOORS for ClearQuest Interface             15
Querying the ClearQuest database  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  15
Viewing query results . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17
Editing a ClearQuest record  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17
Linking a ClearQuest record to a DOORS object . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  18
Displaying link information in a DOORS module. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  18
Finding DOORS objects linked to a ClearQuest record . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  19
Finding ClearQuest records linked to a DOORS object . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  20
Deleting links . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  21

Chapter 5: Contacting support                                                                     23
Contacting IBM Rational Software Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  23

Product support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  23
What to do before you contact Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  23
Sending an automated problem report form  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  24

Guidelines for writing a problem report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  25
Automatic responses and recording defects  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  25



Table of contents

iv    Using Telelogic DOORS for ClearQuest Interface

Automatically generated problem reports. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  26
Changing the email address of the problem report  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  26

Other information. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  26

Chapter 6: Notices                                                                                            27
Trademarks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  29



Using Telelogic DOORS for ClearQuest Interface    1

1 About this manual
Welcome to Telelogic® DOORS for ClearQuest Interface™.
This manual describes how to use version 2.2 of Telelogic DOORS for 
ClearQuest Interface. It assumes that you know how to use both Telelogic® 
DOORS® and ClearQuest®.

Typographical conventions
The following typographical conventions are used in this manual:

Related documentation
The following table describes where to find information in the documentation 
set:

You’ll also find PDF versions of the DOORS manuals on:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus. For example: Click Yes to continue.

Italics Book titles

Courier Commands, files, and directories; computer output. For 
example: Edit your .properties file.

> A menu choice. For example: Select File > Open. This means 
select the File menu, then select the Open command from it.

For information on See

How to use DOORS The Telelogic DOORS documentation 
set

How to use ClearQuest The ClearQuest documentation set

How to install Telelogic DOORS for 
ClearQuest Interface

Telelogic DOORS Installation Guide
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• The Telelogic Lifecycle Solutions DVD

• The support website at https://www.support.telelogic.com
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2 Concepts
This chapter introduces Telelogic DOORS for ClearQuest Interface and explains 
the concepts you need to understand before you use it:

• About Telelogic DOORS for ClearQuest Interface

• About Telelogic DOORS for ClearQuest Interface functions

• Configuring Telelogic DOORS for ClearQuest Interface

About Telelogic DOORS for ClearQuest Interface
DOORS is the world’s leading tool for creating, structuring, and managing 
complex sets of requirements, such as those for a typical software development 
project. ClearQuest is a defect and change tracking tool.
Telelogic DOORS for ClearQuest Interface is a bridge between these two 
products, enabling users to co-ordinate defect tracking and requirements 
management. This integration is not supported on a ClearQuest MultiSite 
configuration.

About Telelogic DOORS for ClearQuest Interface functions
Telelogic DOORS for ClearQuest Interface allows you to:

• Query a ClearQuest database from a DOORS project

• Edit ClearQuest records

• Link ClearQuest records to DOORS objects, and track these links

• Attach files to a ClearQuest record using Telelogic DOORS for ClearQuest 
Interface

Configuring Telelogic DOORS for ClearQuest Interface
You can configure Telelogic DOORS for ClearQuest Interface so that a different 
ClearQuest database is used for each DOORS project. This means that different 
ClearQuest databases and different form settings can be used on different 
DOORS projects. 
You can configure:

• Database
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ClearQuest supports multiple databases. A ClearQuest database must be 
associated with each DOORS Project that uses Telelogic DOORS for 
ClearQuest Interface.

• Type Selection
ClearQuest supports many different types and schemas. You can select the 
ClearQuest types that you want to make available to Telelogic DOORS for 
ClearQuest Interface for each DOORS project. You make a ClearQuest type 
available by associating it with a Telelogic DOORS for ClearQuest Interface 
type. There are two Telelogic DOORS for ClearQuest Interface types: 
Enhancement Request (ER) and Defect, which can be associated with 
any available ClearQuest types.

• Query
You can configure Telelogic DOORS for ClearQuest Interface to display 
selected ClearQuest fields on the Query tab of the integration form. You can 
query the ClearQuest database on a single ClearQuest field, or on multiple 
ClearQuest fields. Telelogic DOORS for ClearQuest Interface supports the 
use of And or Or logic when querying on multiple fields.

• Report Details
The results of a query are displayed on the Reports/Details tab of the 
integration form. You can configure Telelogic DOORS for ClearQuest 
Interface to display selected ClearQuest fields on the Report/Details tab of 
the integration form. ClearQuest records are displayed in a list in the top 
section of the tab. When a record is selected in the list, the details of that 
record are displayed in the lower section of the tab. You can control which 
of the fields in the bottom section of the tab you want users to be able to 
edit. ClearQuest system fields, for example id or Submitter cannot be 
edited.

• Edit Records
You can configure Telelogic DOORS for ClearQuest Interface to display 
selected ClearQuest fields on the Edit Record tab of the integration form. 
You can control which of these fields you want users to be able to edit. 
ClearQuest system fields, for example id or Submitter cannot be edited.
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3 Configuring Telelogic DOORS for 
ClearQuest Interface

This chapter describes: 

• Configuring projects

• Configuring forms

Configuring projects
When you configure a DOORS project to use Telelogic DOORS for ClearQuest 
Interface, you select the ClearQuest database you want to associate with the 
DOORS project. You can then select the ClearQuest types that you want to 
make available to Telelogic DOORS for ClearQuest Interface for that project.
You make a ClearQuest type available by associating it with a Telelogic DOORS 
for ClearQuest Interface type. There are two Telelogic DOORS for ClearQuest 
Interface types: Enhancement Request (ER) and Defect, which can be 
associated with any available ClearQuest types. The ClearQuest types will be 
referred to in Telelogic DOORS for ClearQuest Interface by their Telelogic 
DOORS for ClearQuest Interface labels, i.e. Enhancement Request and Defect.
To configure a project you must be one of the following DOORS users:

• Administrator user

• Database Manager
• Project Manager
Once you have configured Telelogic DOORS for ClearQuest Interface, any 
DOORS users with access to the associated ClearQuest database will be able to 
use Telelogic DOORS for ClearQuest Interface.

1. Select the correct DOORS Project in the left pane of the DOORS Explorer. 

2. Select ClearQuest > Configure Project.
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The ClearQuest Database Configuration dialog box opens, displaying the 
names of the available ClearQuest schema repositories in the top pane.

3. In the top pane of the dialog box, select the ClearQuest schema repository 
that contains the database you want to use.

A list of the databases that are available for that schema repository is 
displayed in the Database Name pane.

4. Select the ClearQuest database that is to be associated with the DOORS 
project selected in the DOORS explorer.
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Configuring projects

The ClearQuest login dialog box is displayed.

5. Enter your ClearQuest username and password and click Login.

You can configure the ClearQuest login to save your ClearQuest username 
and/or password by selecting the appropriate checkboxes:

• If you save your username, you will be prompted for your password 
each time Telelogic DOORS for ClearQuest Interface accesses the 
ClearQuest database. 

• If you save your username and password, you will not be prompted to 
login again, unless the login fails.

• You can login again during a session, or change your login options by 
selecting ClearQuest > Login from the DOORS explorer, or from the 
right click menu in a DOORS module.

Telelogic DOORS for ClearQuest Interface retrieves the available 
ClearQuest database types for the current database and displays them in the 
lower panes of the dialog box. You use the Enhancement Request Type 
Name pane to associate a ClearQuest type with the Telelogic DOORS for 
ClearQuest Interface type ER, and the Defect Type Name pane to 
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associate a ClearQuest type with the Telelogic DOORS for ClearQuest 
Interface type Defect.

6. Associate a ClearQuest Database type with the Telelogic DOORS for 
ClearQuest Interface type ER by selecting the ClearQuest database type 
from the list in the Enhancement Request Type Name pane. Associate a 
ClearQuest database type with the Telelogic DOORS for ClearQuest 
Interface type Defect by selecting the ClearQuest database type from the list 
in the Defect Type Name pane. You can create associations for either or 
both of the Telelogic DOORS for ClearQuest Interface types.
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Configuring forms

7. Click Apply to save the configuration information.

Configuring forms
You can configure a form for each ClearQuest type that is associated with a 
Telelogic DOORS for ClearQuest Interface type. When the form is configured it 
provides the interface between the DOORS project and the associated 
ClearQuest database. For information on associating a ClearQuest type with a 
Telelogic DOORS for ClearQuest Interface type, see “Configuring projects,” on 
page 5.
To configure a form you must be one of the following DOORS users:

• Administrator user 

• Database Manager
• Project Manager
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Once you have configured Telelogic DOORS for ClearQuest Interface, any 
DOORS users with access to the associated ClearQuest database will be able to 
use Telelogic DOORS for ClearQuest Interface.

1. Select ClearQuest > Configure Forms in the DOORS Explorer.

The ClearQuest Forms Configuration dialog box is displayed. There are 
five tabs in the dialog box: 

• Query Configuration
• Report Configuration
• Detail Configuration
• Data Entry Configuration
• View Fields

2. Click to display the drop down Form list at the top of the ClearQuest Form 
Configuration dialog box. The ClearQuest types that were associated with 
Telelogic DOORS for ClearQuest Interface types during the Project 
Configuration are displayed. In this example they are EnhancementRequest 
and Defect.

3. Select the ClearQuest type you want to configure.

Telelogic DOORS for ClearQuest Interface retrieves the field list for the 
selected ClearQuest type from the ClearQuest database. The field list is 
displayed in the Available Field list on each of the tabs in the ClearQuest 
Form Configuration dialog box. You can select which of these fields you 
want to be displayed on the Telelogic DOORS for ClearQuest Interface 
form.

4. Select the Query Configuration tab.
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Configuring forms

You use the Query Configuration tab to define what ClearQuest fields are 
available to users when they use Telelogic DOORS for ClearQuest Interface 
to query the ClearQuest database. These fields are displayed on the Query 
tab of the Telelogic DOORS for ClearQuest Interface form.

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Telelogic DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form in the same order that they are displayed in the Selected 
Item Order list. To reorder the list, select a field and move it using the 
up and down arrows.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

• Select the Report Configuration tab.

You can define what ClearQuest fields will be available in Telelogic DOORS 
for ClearQuest Interface as a result of a query. These are displayed as 
column headers in the upper pane of the Report/Details tab of the 
Telelogic DOORS for ClearQuest Interface form
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• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Telelogic DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form in the same order as they are displayed in the Selected 
Item Order list. To reorder the list, select a field and move it using the 
up and down arrows.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

5. Select the Detail Configuration tab.

You can define what additional ClearQuest fields are available in Telelogic 
DOORS for ClearQuest Interface as a result of a query. These fields are 
displayed in the lower pane of the Reports/Details tab of the Integration 
form, and show the values of the record that is selected in the upper pane.

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Telelogic DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form in the same order as they appear in the Selected Item 
Order list. To reorder the list, select a field and move it using the up and 
down arrows.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

• By default, the ClearQuest fields in the Details section of the Telelogic 
DOORS for ClearQuest Interface form are editable. To disallow edits to 
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Configuring forms

a ClearQuest field select it in the Selected Item Order list and clear the 
Editable checkbox.

Note  ClearQuest system generated fields, for example id or 
Submitter are not editable. The Editable checkbox is 
cleared and dimmed when fields of this type are selected.

6. Select the Data Entry Configuration tab.

You can define what ClearQuest fields are available for editing in Telelogic 
DOORS for ClearQuest Interface as a result of a query. These are displayed 
on the Edit Record tab of the Telelogic DOORS for ClearQuest Interface 
form

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to make available in Telelogic DOORS for ClearQuest Interface. They 
are displayed in the Selected Item Order list.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form in the same order as they appear in the Selected Item 
Order list. To reorder the list, select a field and move it using the up and 
down arrows.

• The fields are displayed on the Telelogic DOORS for ClearQuest 
Interface form with their ClearQuest labels. To give a ClearQuest field a 
different label, select it in the Selected Item Order list and enter a new 
name in the Displayed Name field.

• By default, the ClearQuest fields in the Details section of the Telelogic 
DOORS for ClearQuest Interface form are editable. To disallow edits to 
a ClearQuest field select it in the Selected Item Order list and clear the 
Editable checkbox.

Note  ClearQuest system generated fields, for example id or 
Submitter are not editable. The editable checkbox is 
cleared and dimmed when fields of this type are selected.
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7. Select the View Fields tab.

Users can create links between ClearQuest records and DOORS objects 
using Telelogic DOORS for ClearQuest Interface. The link information is 
stored in the DOORS module in an attribute called CQ Links. This 
attribute is created automatically the first time a user creates a link. You can 
define what ClearQuest fields you want to be stored in the CQ Links 
attribute for each link that is created. The default is the ClearQuest record’s 
id if no fields are identified

• In the left pane, select the checkboxes of the ClearQuest fields you want 
to be stored in the CQ Links attribute for each link that is created.

• The fields are listed in the CQ Links attribute in the same order as they 
appear in the Selected Item Order list. To reorder the list, select a field 
and move it using the up and down arrows.

8. You can preview the form by clicking the Preview Form button.

The Telelogic DOORS for ClearQuest Interface form is generated, and the 
fields you specified during the configuration are displayed.

9. Click Close to close the Preview form.

Note  You can query the ClearQuest database using the 
Preview form, and records matching the query will 
display. However, you cannot edit any fields when in 
Preview mode.

10. Click Save, then Close in the ClearQuest Form Configuration dialog box.
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4 Using Telelogic DOORS for ClearQuest 
Interface

This chapter describes:

• Querying the ClearQuest database

• Viewing query results

• Editing a ClearQuest record

• Linking a ClearQuest record to a DOORS object

• Displaying link information in a DOORS module

• Finding DOORS objects linked to a ClearQuest record

• Finding ClearQuest records linked to a DOORS object

• Deleting links

Querying the ClearQuest database 
To use Telelogic DOORS for ClearQuest Interface you must have access to:

• The configured DOORS project

• The ClearQuest database that has been associated with that project

To query the ClearQuest database:
1. In a formal module, right click and select ClearQuest > Reports > Show 

Defect Query Form or ClearQuest > Reports > Show Enhancement 
Request Query Form. 
The ClearQuest Login screen is displayed.

Note  If the current DOORS project has not been configured 
for Telelogic DOORS for ClearQuest Interface, an error 
message is displayed. The DOORS Administrator user, a 
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DOORS Database Manager or DOORS Project 
Manager must run the Configure Project and 
Configure Forms options from the DOORS Explorer 
before Telelogic DOORS for ClearQuest Interface can 
be used.

2. Enter your ClearQuest username and password.

You will be prompted to log into the ClearQuest database each time 
Telelogic DOORS for ClearQuest Interface accesses the ClearQuest 
database. You can choose to save your ClearQuest username and/or 
password when you log in by ticking the appropriate checkbox on the login 
dialog box.

• If you save your username you will be prompted for your password each 
time Telelogic DOORS for ClearQuest Interface accesses the 
ClearQuest database.

• If you save your username and password you will not be prompted to 
login unless the login fails.

• You can login again during a session, or change your login options by 
selecting ClearQuest > Login from the DOORS explorer, or from the 
right click menu in a DOORS module.

The Telelogic DOORS for ClearQuest Interface form opens, displaying the 
ClearQuest fields you can use to query the ClearQuest database. The 
ClearQuest fields that are displayed on the Telelogic DOORS for 
ClearQuest Interface form are those that were specified when Telelogic 
DOORS for ClearQuest Interface was configured
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Viewing query results

3. Select the Query tab.

Specify the criteria for your query. Telelogic DOORS for ClearQuest 
Interface only supports And or Or logic when you enter a value in more 
than one field.

4. Click Perform Query.

Telelogic DOORS for ClearQuest Interface queries the ClearQuest 
database. When the information has been retrieved from the ClearQuest 
database, the Report/Details tab of the integration form is activated and the 
results of the query are displayed.

Viewing query results
The results of the query are listed in the upper section of the Reports/Details 
tab. When a record is selected in the list, the details of that record are displayed in 
the lower section of the tab.
Depending on how the Report/Details tab has been configured, you may be able 
to edit the fields in the lower section of the form. If a field in this section is read 
only, it is dimmed.

Editing a ClearQuest record
You can edit a ClearQuest record using the Edit Record tab on the integration 
form.
To edit a ClearQuest record:



Using Telelogic DOORS for ClearQuest Interface

18    Using Telelogic DOORS for ClearQuest Interface

1. Select the record you want to edit in the list on the Report/Details tab.

2. Select the Edit Record tab or click the Edit button.

The fields on the Edit Record tab are populated with values from the 
ClearQuest record you selected in the previous step. If a field on the Edit 
Record tab is read only, it is dimmed.

3. Make the required changes and click Apply to save them to the ClearQuest 
database.

Linking a ClearQuest record to a DOORS object
To link a ClearQuest record to a DOORS object:
1. Select the ClearQuest record on the Report/Details tab of the integration 

form dialog box.

2. In the formal module, select the DOORS object to which you want to link 
the record.

3. Right click in the DOORS formal module and select ClearQuest > 
Linking > Create Link.

The link is created.

Displaying link information in a DOORS module
ClearQuest link information is stored in the DOORS module in an attribute 
called CQ Links. This attribute is created automatically the first time a link is 
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Finding DOORS objects linked to a ClearQuest record

created between a ClearQuest record and a DOORS object. The CQ Links 
attribute holds information about the ClearQuest record that is linked to the 
DOORS object. The information held in the attribute depends on the 
ClearQuest fields selected when Telelogic DOORS for ClearQuest Interface is 
configured.
You can use Telelogic DOORS for ClearQuest Interface to create a view called 
ClearQuest Status View. The CQ Links attribute is displayed in a column in 
the ClearQuest Status View. To create this view select ClearQuest > Status 
View > Create Status View from the right click menu within the module.
You can refresh the view to show new link information by selecting ClearQuest 
> Status View > Update Status View from the right click menu. The latest link 
information for the current DOORS project is retrieved from ClearQuest, and 
an information dialog is displayed stating that the CQ Status Files have been 
updated successfully.

Note  Telelogic DOORS for ClearQuest Interface has to access the 
ClearQuest database to retrieve this information. You may be 
prompted to log into the ClearQuest database.

Finding DOORS objects linked to a ClearQuest record
You can trace links from a ClearQuest record to a DOORS object using 
Telelogic DOORS for ClearQuest Interface.
To trace linked DOORS objects:
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1. On the Report/Details tab of the integration form, select the ClearQuest 
record you want to check for links.

2. Click the Requirements button.

Any DOORS modules that contain objects that are linked to the selected 
record are opened in read-only mode and filtered to display only the linked 
objects.

Finding ClearQuest records linked to a DOORS object
You can trace links from a DOORS object to a ClearQuest record using 
Telelogic DOORS for ClearQuest Interface.
To trace linked ClearQuest records:
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Deleting links

1. In the DOORS formal module, select the ClearQuest Status View from 
the Views drop down list.

ClearQuest link information is displayed in the CQ Links attribute column 
in this view.

2. Right click on an object that has a link to a ClearQuest record and select 
ClearQuest > Reports > Show Enhancement Requests or ClearQuest 
> Reports > Show Defects.

The Telelogic DOORS for ClearQuest Interface form is opened. The 
Report/Details tab is displayed and ClearQuest records that are linked to 
the selected DOORS object are listed.

Deleting links
To delete links between DOORS objects and ClearQuest records:
1. Select the ClearQuest Status View from the drop down views list in the 

DOORS formal module

2. Select the DOORS object containing the link that you want to delete.

3. Right click and select ClearQuest > Reports > Show Defects or 
ClearQuest > Reports > Show Enhancement Requests.

The Telelogic DOORS for ClearQuest Interface form is opened. The 
Report/Details tab is displayed and ClearQuest records that are linked to 
the selected DOORS object are listed.

4. Select the ClearQuest record that is the target of the link you want to delete.

5. In the formal module right click on the DOORS object that was selected in 
Step 2 and select ClearQuest > Linking > Delete Link.

The link is deleted and the following dialog is displayed:

Note  The deleted link is displayed in the ClearQuest Status 
View until you update the view. To update the status 
view select ClearQuest > Status View > Update 
Status View from the right click menu in the formal 
module.



Using Telelogic DOORS for ClearQuest Interface

22    Using Telelogic DOORS for ClearQuest Interface



Using Telelogic DOORS for ClearQuest Interface    23

5 Contacting support
This chapter contains the following topics:

• Contacting IBM Rational Software Support

• What to do before you contact Support

• Sending an automated problem report form

• Other information

Contacting IBM Rational Software Support
Support and information for Telelogic products is currently being transitioned 
from the Telelogic Support site to the IBM Rational Software Support site. 
During this transition phase, your product support location depends on your 
customer history.

Product support
• If you are a heritage customer, meaning you were a Telelogic customer prior 

to November 1, 2008, please visit the DOORS Support Web site on 
https://support.telelogic.com/doors.

Telelogic customers will be redirected automatically to the IBM Rational 
Software Support site after the product information has been migrated.

• If you are a new Rational customer, meaning you did not have 
Telelogic-licensed products prior to November 1, 2008, please visit the IBM 
Rational Software Support site on 
http://www.ibm.com/software/rational/support/.

What to do before you contact Support
If your site has a designated on-site support person, please contact that person 
before you contact our Support team.
To help our Support team solve your problem, please have the following 
information available:

• Your name, title, company name, e-mail address, fax number and telephone 
number.

• Your support ID and support password.

• The version and build number of DOORS that you’re running.
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To get this information, run DOORS, and click Help > About DOORS.

• The operating system you’re running DOORS on.

• What operating system your DOORS database is running on, if different.

• If you are reporting a new problem, please have a clear statement of the 
problem, including the exact text of any error messages produced by 
DOORS, your operating system, or any other tools that were running when 
the problem occurred.

• If you are calling about a problem you reported earlier, you need the original 
tracking number the Support team assigned to your problem.

• If you want, you can use the automated problem report form. For 
information, see “Sending an automated problem report form,” on page 24.

The support center on our web site is at https://support.telelogic.com.

Sending an automated problem report form
To send an automated problem report to Support:
1. Select Help > Generate Support Request.

The Telelogic Support Information dialog box is displayed with some of 
your product information automatically included.

Review the information to make sure it’s accurate.

2. From the Impact drop down list box, select the severity of the problem.

3. In the Summary box, summarize the problem.

4. In the Problem box, type a detailed description of the problem.

5. If available, attach a snapshot.

Click either DOORS Window Snapshot or Screen Snapshot, whichever is 
applicable, and select the snapshot from your machine.

6. If possible, use the buttons in the Attachment Information area to add 
video capture, system details and files.

Note  The Add Product Files button is unavailable in 
DOORS. Product information is collected and added 
automatically.

Add any relevant information to help Support resolve the problem.

7. You can either:
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Sending an automated problem report form

• Display the information you’ve entered in a new window so that you can 
copy it. For example, you may want to add this information to someone 
else’s information. 

Click Just Text (No Email).
• Open the email to edit it before sending it to Support. 

Click Preview and Send to submit the report.

Guidelines for writing a problem report

• Be as specific as possible when you summarize the problem in the 
Summary box and when you explain the situation and provide details in the 
Problem box. For example, “The system crashed when I tried to add an 
attribute” is more helpful than “It crashed.”

• Indicate if there were any system changes, such as customizations or 
upgrades, before the problem occurred.

• If the problem is reproducible, list the specific steps to be followed in order 
to demonstrate the problem and also indicate the model you are using to 
perform the steps.

• In the problem description, include anything different or unusual that you 
observed before the problem happened.

• Make screen captures of anything that you feel will help and attach them to 
the problem report.

• Include any error messages and code samples you have related to the 
problem.

• If you have multiple unrelated questions or issues, please submit them 
separately. 

Automatic responses and recording defects

When you send the online form to Support, the customer service system 
immediately searches the Knowledge Base based on the Summary and 
Problem descriptions you entered. If there is an exact match of your problem in 
the knowledge base, the system automatically sends an email to you with a 
pointer to the most likely solution.
The problem is also automatically recorded in the defect tracking system as 
assigned to a support representative. This representative works with you to be 
certain that your problem is solved. The defect tracking system also records new 
problems with their solutions in the Knowledge Base to provide rapid assistance 
for other customers.
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Automatically generated problem reports

If your DOORS system crashes, it displays a message asking if you want to send 
a problem report about the crash to DOORS Support.
If you decide to send this generated report, the system displays the same online 
form that is available from Help > Generate Support Request. In this case, 
the form contains information about the crash condition, in addition to the 
information that is usually filled in describing your system. 
Add any more information that you can to help the Support staff identify the 
problem before you click the Preview and Send button.

Changing the email address of the problem report
If you want to send the problem to someone other than DOORS Support, for 
example to your internal support, you can change the default email address of 
the problem report.
To change the email address of the problem report:
1. Open System in the Control Panel.
2. On the Advanced tab, click Environment Variables, then click New under 

variables.

The New User Variable window is displayed

3. In Variable Name enter ILX_RECIP, the variable that controls the 
address used by the problem report.

4. In Variable Value enter the email address you want to use.

5. Click OK to add the value.
6. Click OK to save the value in the environment variables.
7. Click OK to save the value in the system properties.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software Web site on http://www.ibm.com/software/rational/.
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6 Notices
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user's responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan  
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
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This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
1 Rogers Street 
Cambridge, Massachusetts 02142 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
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Trademarks

performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks

IBM, the IBM logo, ibm.com, Telelogic, Telelogic DOORS, and Telelogic 
DOORS for ClearQuest Interface are trademarks or registered trademarks of 
International Business Machines Corporation in the United States, other 
countries, or both. These and other IBM trademarked terms are marked on their 
first occurrence in this information with the appropriate symbol (® or ™), 
indicating US registered or common law trademarks owned by IBM at the time 
this information was published. Such trademarks may also be registered or 
common law trademarks in other countries. A current list of IBM trademarks is 
available on the Web at www.ibm.com/legal/copytrade.html.
FLEXnet is a registered trademark or trademark of Macrovision Corporation.
Microsoft, Windows, Windows 2003, Windows XP, Windows Vista and/or other 
Microsoft products referenced herein are either trademarks or registered 
trademarks of Microsoft Corporation.
Other company, product or service names may be trademarks or service marks 
of others.
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