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About this manual 
Welcome to Telelogic® DOORS for HP Quality Center Interface™.
Telelogic DOORS for HP Quality Center Interface allows you to synchronize 
data between Telelogic® DOORS® (DOORS), the world’s leading requirements 
management solution, and HP Quality Center®, an integrated enterprise 
application for organizing and managing the entire testing process. You can 
transfer requirements in DOORS to a Quality Center project and transfer tests 
and defects between Quality Center and DOORS. You can access DOORS 
requirements information using your Quality Center interface, and access 
Quality Center test and defect information using your DOORS interface.
This document describes how to use version 3.3 of Telelogic DOORS for HP 
Quality Center Interface. It assumes that you know how to use both DOORS 
and Quality Center.

Typographical conventions
The following typographical conventions are used in this manual:

Typeface or 
Symbol

Meaning

Bold Important items, and items that you can select, including 
buttons and menus. For example: Click Yes to continue.

Italics Book titles

Courier Commands, files, and directories; computer output. For 
example: Edit your .properties file.

> A menu choice. For example: Select File > Open. This means 
select the File menu, then select the Open command from it.
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Related documentation
The following table describes where to find information in the documentation 
set:

You’ll find PDF versions of the DOORS manuals on:

• The Telelogic Lifecycle Solutions DVD

• The Support website at https://www.support.telelogic.com

For information on See

How to use DOORS The Telelogic DOORS documentation 
set

How to use Quality Center The Quality Center documentation set 

How to use the Administration Console The Administration Console Online 
Help

What’s new in Telelogic DOORS for HP 
Quality Center Interface 3.3

The Telelogic DOORS for HP Quality 
Center Interface readme file

How to set up licenses to use Telelogic 
DOORS for HP Quality Center Interface

Telelogic Lifecycle Solutions Licensing Guide
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2 Installing Telelogic DOORS for HP Quality 
Center Interface

This chapter contains information on how to install and configure Telelogic 
DOORS for HP Quality Center Interface.

• Understanding the installation options

• System requirements

• Upgrading from previous versions of the integration

• Installing the Integration Server

• Installing an Integration Client

• Installing the Administration Console

• Upgrading version 3.1 data

• Uninstalling the Integration

Understanding the installation options
The Integration installer has two installation options. These are:

• Integration Client

You install an integration client on each DOORS client that needs to use the 
integration. This allows the DOORS user to access the integration options 
available in the DOORS client.

• Integration Server

This option installs both the Integration Server and the Integration Client.

System requirements
The following sections describe the system requirements for each component of 
the integration:

• System requirements for the Integration Server

• System Requirements for the Integration Client

• System Requirements for the Administration Console
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System requirements for the Integration Server

Before you install the integration server you must have:

• A DOORS version 9.1 or later database server installed and configured on 
any machine on the network, including both Windows® and UNIX® 
machines. Make sure the DOORS database is not set up to use system 
usernames. Telelogic DOORS for HP Quality Center Interface cannot 
communicate with DOORS if system usernames are being used.

• A Quality Center server version 9.2. The server can be on any machine on 
the network; it does not need to be on the machine you are installing the 
Integration Server on.

The machine on which you install the Integration Server must have:

• Windows 2003 Server SP2 (Enterprise and Standard).

• A DOORS 9.1 or later client.

• You must have used a Microsoft Internet Explorer browser to connect to 
the Quality Center server you intend to use for the integration.

• IIS 6.0 running with ASP.NET v2.0 enabled.

Note  You can use the Manage your Server wizard to install and 
configure IIS and ASP.NET.

• Minimum 512 MB RAM.

Caution  The DOORS client that is installed on the Integration 
Server machine must not be used for the day to day 
administration of the integration, or for any other 
DOORS tasks. You should only run the DOORS client 
on the Integration Server machine if instructed to do so 
by the DOORS support team.

System Requirements for the Integration Client

Install and configure the Integration Server before you install any integration 
clients.
Each machine on which you install the Integration Client must have either:

• Windows 2003 Server SP2 (Enterprise and Standard)

• Windows XP Professional SP2 or SP3

A DOORS 9.1 or later client must also be installed.
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Upgrading from previous versions of the integration

System Requirements for the Administration Console

Each machine on which you install the Administration Console must have either:

• Windows 2003 Server SP2 (Enterprise and Standard)

• Windows XP Professional SP2 or SP3

Both .NET Framework v2.0 and v3.0 must also be installed.

Upgrading from previous versions of the integration
The following sections describe what you must do to upgrade to version 3.3 
from a previous version.

• Upgrade from version 1.8

• Upgrade from version 3.0

• Upgrade from version 3.1

• Upgrade from version 3.2

Upgrade from version 1.8
1. Migrate your data.

You must synchronize your data before you uninstall version 1.8.

2. Uninstall version 1.8 using Add/Remove Programs from the Windows 
Control Panel.

3. Install version 3.1.

You do not have to configure or run version 3.1 after you install it, but you 
must install it before you install version 3.3.

4. Install version 3.3 and migrate 3.1 data to 3.3.

For information on migrating data from version 3.1 to 3.3, see “Upgrading 
version 3.1 data,” on page 14.

Upgrade from version 3.0

On machines with version 3.0 of TestDirector Integration installed, install 
version 3.1, then install version 3.3 and migrate 3.1 data to 3.3.
For information on migrating data from version 3.1 to 3.3, see “Upgrading 
version 3.1 data,” on page 14.
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Upgrade from version 3.1

You can upgrade direct to version 3.3 form version 3.1.
On machines with version 3.1 of TestDirector Integration installed, install 
version 3.3, then migrate 3.1 data to 3.3.
For information on migrating data from version 3.1 to 3.3, see “Upgrading 
version 3.1 data,” on page 14.

Upgrade from version 3.2
Telelogic DOORS for HP Quality Center Interface includes a migration tool that 
allows you to upgrade and migrate from version 3.2.

Installing the Integration Server
If you are upgrading the Integration Server, see “Upgrading from previous 
versions of the integration,” on page 5 for information on how to upgrade to 3.3.

Run the installer
To install the Integration Server:
1. Make sure you meet the system requirements for installing and running the 

Integration server. For information on system requirements, see “System 
requirements,” on page 3. 

2. If you’re running version 3.2, uninstall it.

3. Make sure you’re logged into your computer as a user with Administrator 
privileges.

4. Shut down all other applications. In particular, shut down Microsoft Office 
applications, including the Microsoft Office toolbar.

5. Check that the Default Web Site in the Internet Services Manager is started. 
If it isn’t, right-click and select Start.

6. Using Windows Explorer, double-click setup.exe.

The Welcome screen is displayed.

If the Modify/Repair/Remove dialog box is displayed, exit the installer 
and modify the installation using Add/Remove Programs in the Windows 
Control Panel.

Note  If the .NET Framework v2.0 is not detected by the 
installer, a browser window is opened at Microsoft’s 
.NET Framework download page. You must install the 



Installing and Using Telelogic DOORS for HP Quality Center Interface           7

Installing the Integration Server

.NET Framework before you continue. You may be 
required to reboot your machine.

7. Click Next.
The License Agreement screen is displayed.

8. Select the I accept option and click Next.
The Choose Destination Location screen is displayed.

9. Enter the path to the folder you want to install to, or leave the default.

10. Click Next.
The Setup Type screen is displayed.

11. Select Server and click Next.
Note  This option installs both the Integration Client and the 

Integration Server.

The Integration Server TCP Port screen is displayed.

12. Enter the TCP port on which the Internet Information Service is serving 
the Default Web Site.

To find out the port number:

a. On the desktop, right-click on My Computer and select Manage.

The Computer Management window is displayed.

b. Navigate Services and Applications > Internet Information Service 
(IIS) Manager > Web Sites.

c. Right-click Default Web Site and select Properties.

The TCP Port is displayed in the Web Site Identification panel.

13. Click Next.
The Enter Domain\Groupname screen is displayed.

14. Enter the fully qualified group name that will be authorized to access the 
Administration Console. Domain is the name of the machine you are 
installing the Integration Server on and Groupname is the name of a group 
with the necessary privileges (for example, 
QCI_Server\QCI_Admin_Console_Users).

If you need to create the group, use the Computer Management window.

15. Click Next.
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The Ready to Install the Program screen is displayed.

16. Click Install.
The necessary files are installed on the machine.

Note  If you do not have IIS installed, an error is displayed. 
You must click Abort, install IIS, then reinstall the 
Integration Server.

17. Click Finish.

The install wizard closes.

Run the configuration tool

Before you proceed, you need to configure the Integration Server.
To configure the Integration Server:
1. If it’s still open, shut down the Computer Manager.

2. From the Start menu select Telelogic > Telelogic Lifecycle Solution 
Tools > Telelogic DOORS Quality Center Integration 3.3 Tools > Set 
Access Permissions.

The Telelogic DOORS for HP Quality Center Interface Configuration 
Tool dialog box is displayed.

3. In Username enter a user.



Installing and Using Telelogic DOORS for HP Quality Center Interface           9

Installing the Integration Server

By default, a local machine user called IWSUSER is used in this tool. 
However, you can specify a domain user instead. The tool cannot create a 
domain user, but if one already exists it can be used.

• If you want to specify or create IWSUSER, enter 
<machinename>\IWSUSER.
• If a user named IWSUSER already exists, leave the check box clear.
• If a user named IWSUSER does not exist, select the check box.

• If you want to specify a domain user, enter 
<domainname>\<username>, and leave the check box clear.

4. Enter a password in the Password and Confirm Password boxes.

• If IWSUSER already exists, enter the user’s existing password.
• If IWSUSER does not exist, enter a new password.

This password uses the Windows 2003 password rules that are in force 
on your system.

5. Click Next.
The Gathering the virtual folder structure dialog box is displayed.

6. Enter the name of the web site that is hosting the services, or leave the 
default.

7. Enter the path to the location of the virtual folder for TDI Services and the 
SOQ Services, or leave the defaults.

8. Click Next.
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The Applying configuration dialog box is displayed.

A warning dialog box is also displayed.

9. Click Yes. When all the categories have been successfully configured, click 
Next. 
A summary screen is displayed.

You can use the Copy button to copy the summary text.

10. Click Next.
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Installing an Integration Client

The Testing Services dialog box is displayed.

You can use the Copy button to copy the results text.

11. Select Run Tests to test the availability of the services.

12. If necessary, add the IWSUSER to the group you created in step 14 of “Run 
the installer,” on page 6.

13. Navigate to Quality Center and log on. This downloads ActiveX 
components.

14. Click Finish.

Installing an Integration Client
Once the Integration Server has been installed, you can install the Integration 
Client on the DOORS and Quality Center client machines that you want to 
access the integration.
To install the Integration Client:
1. Make sure you meet the system requirements for installing and running the 

Integration Client. For information on system requirements, see “System 
requirements,” on page 3. 

2. Make sure you’re logged into your computer as a user with Administrator 
privileges.

3. Shut down all other applications. In particular, shut down Microsoft Office 
applications.
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4. Using Windows Explorer, double-click setup.exe.

The Welcome screen is displayed.

If the Modify/Repair/Remove dialog box is displayed, exit the installer 
and modify the installation using Add/Remove Programs in the Windows 
Control Panel.

5. Click Next.
The License Agreement screen is displayed.

6. Select the I accept option and click Next.
The Choose Destination Location screen is displayed.

7. Enter the path to the folder you want to install to, or leave the default and 
click Next.
The Setup Type screen is displayed.

8. Select Client and click Next.
The Specify the Location of Integration Server screen is displayed.

9. In IP Address, enter the fully qualified domain name or IP address of the 
machine on which the Integration Server is installed.

10. In TCP Port, enter the TCP Port on which the Integration Administration 
Service is serving the Default Web Site on the Integration Server machine. 
This is the TCP Port that was entered in Step 12 of Installing the Integration 
Server.

11. Click Next.
The Ready to Install the Program screen is displayed.

12. Click Install.
A progress bar is displayed as the files are installed.

13. Click Finish.

Installing the Administration Console
To install the Administration Console:
1. Make sure you have both the .NET Framework v2.0 and v3.0 installed.

2. Open your Internet browser and type http://<integrationserver>/
AdminToolInstall.
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Installing the Administration Console

The Administration Console installation welcome page is displayed.

3. If you need to install the .NET Framework, do so now.

Note  The .NET Framework is installed in the background. 
Make sure it is installed before you proceed. The .NET 
icon will be displayed in the notification area on the 
taskbar.

4. Run the Administration Console installer.

Click setup.

5. If you want to install the Administration Console from the local machine, 
select Save, then double-click the setup.exe file. If you want to install the 
Administration Console from the network, select Run.

The Welcome screen is displayed.

6. Click Next.
The License Agreement screen is displayed.

7. Accept the terms of the agreement and click Yes.

The Choose Destination Location screen is displayed.

8. Enter the path to the folder you want to install to, or leave the default and 
click Next.
The Ready to Install the Program screen is displayed.
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9. Click Install.
A progress bar is displayed as the files are installed.

10. Click Finish.

11. Start the Administration Console.

From the Start menu select Telelogic > Telelogic Lifecycle Solution 
Tools > Telelogic DOORS Quality Center Integration 3.3 Tools > 
Administration Tool.

Upgrading version 3.1 data
To upgrade version 3.1 data to version 3.3:
1. Shut down Web Services.

2. Run the Migration tool.

From the Start menu select Telelogic > Telelogic Lifecycle Solution 
Tools > Telelogic DOORS Quality Center Integration 3.3 Tools > 
Migrate 3.1 Data to 3.3.

3. Select the 3.1 folder

Enter the location of the 3.1 data. By default this is in 
c:\inetpub\wwwroot\doorstdintegrationwebservices.

4. Select the 3.3 folder.

Enter the location of the 3.3 data. By default this is in 
c:\inetpub\wwwroot\DOORSTDIServices\.

5. Click Perform Migration.

The migration is performed.

6. Restart Web Services to pick up the migrated data.

Uninstalling the Integration
Use Add/Remove Programs in the Windows Control Panel to remove version 
3.3 of Telelogic DOORS for HP Quality Center Interface and the 
Administration Console.
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3 Analyzing your data
• User roles

• Data architecture

• Working with synchronization tasks

• SoQ attributes

User roles
Telelogic DOORS for HP Quality Center Interface provides a unique, role-based 
approach to systems integration. The roles addressed include the Analyst, the 
QA/Tester, and the Analyst Manager.

Analysts
Analysts, working inside of DOORS, are interested in developing requirements 
that can be satisfied by both development and test. If requirements need to be 
verified through testing, the Analyst creates Qualification Criteria, which detail 
the testing that is required. By using the integration, the Analyst can monitor that 
test planning covers all of the original requirements and can interrogate the test 
plan to check that it meets the qualification criteria. Once testing begins, the 
Analyst can monitor the requirements for associated defects that have been 
raised against tests that have failed. The analyst can identify full business impact 
for defect resolution against the original customer demand.

QA/Testers
QA/Testers, working inside of Quality Center, are interested in test development 
and test execution. QA/Testers take the Qualification Criteria as their 
requirements and develop tests to meet them. Tests are associated back to the 
requirements so that a review can take place in order to make sure that all 
defined objectives have been met.

Analyst Managers
Analyst Managers, working inside of DOORS, are interested in finding if tests 
have been successfully developed and then executed against the original 
requirements. Initially managers are only interested in a true or false answer to 
distinguish if a requirement can be considered qualified. As a manager needs to 
perform analysis on why a requirements has not been successfully tested, more 
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detail is needed. This detail is provided by the Statement of Quality reports that 
can be generated using Telelogic DOORS for HP Quality Center Interface.

Overall benefits
The Analyst Manager understands the full business impact of releasing a system.
The Analyst can focus on providing testable requirements, and can be involved 
in prioritization of defects dependent on business impact.
The QA/Tester can test against a defined set of requirements instead of testing 
what is built.

Data architecture
Traditional integrations between two products often make the assumption that a 
subset of information can be synchronized and replicated into two different 
databases. While this integration is intended to be used on enterprise scale data, 
it cannot do this by simply scaling the amount of information that is replicated; 
there is no magic solution on how to duplicate gigabytes of information. Rather 
than take this normal approach of data duplication, the integration requires the 
organization to perform some analysis on their data architectures in order to 
identify one or more subsets of information that need to be available in both 
DOORS and Quality Center.
Data analysis starts with two questions:

1. Which information within DOORS makes up the Qualification Criteria that 
should be seen in the requirements pane within Quality Center. How does 
the tester know what to test and when to consider that a test should pass.

2. How much information from within Quality Center should be seen in 
modules within DOORS.  Each different type of information seen within 
Quality Center will be transferred into one or more DOORS modules.

The answers to these questions are not as obvious as it would appear. The fact 
that the integration can synchronize a certain type of information does not mean 
that it should. Consideration of the other aspects of the integration should be 
taken into account before data analysis can be considered as complete. For 
instance, SoQ attributes are designed to reduce the amount of information that 
needs to be explicitly synchronized.

Working with synchronization tasks
Before you start to use Telelogic DOORS for HP Quality Center Interface, you 
must spend some time analyzing what information needs to be visible in both 



Installing and Using Telelogic DOORS for HP Quality Center Interface           17

SoQ attributes

DOORS and Quality Center. Once you have done this, care is needed to break 
this information down and develop a synchronization strategy.
To do this effectively, you need to understand the scope of information. Scope 
can be understood to be the combination of three elements:

• Information category

You may want to integrate requirements, tests or defects.

• Volume of information

How much of the information in a category needs to be seen in both 
DOORS and Quality Center.

• Attribute ownership and mapping

Which tool can modify data and how this information is seen by the 
secondary tool.

You need to understand the scope of information before you define it with one 
or more synchronization tasks. Synchronization task definitions establish rules 
by which the integration will function. It is not necessarily the case that only one 
synchronization task should be used to describe the complete scope of 
information.
Performance of the integration is governed by the overall size of a 
synchronization task and the amount of data that has been modified since the 
last synchronization. Where possible, task definition should restrict the overall 
volume of data by constraining both the filter used and the number of attributes 
considered. A second strategy for task definition is to consider the amount of 
data that’s being modified. If it is known that an area of information is 
infrequently subject to change and a different area of data is far more volatile, 
split the task definition into two, with one task being synchronized less 
frequently than the other.
For more information about tasks, see “Understanding synchronization tasks,” 
on page 19.

SoQ attributes
Task synchronization is not the only way to retrieve Quality Center information 
into DOORS and display it alongside the requirements. Statement of Quality 
(SoQ) attributes have been defined to provide three levels of reporting against 
the original Qualification Criteria. SoQ attributes are produced as a report with 
the assumption that this reporting is only done at milestones in a project and not 
more frequently. If a report needs updating, it must be recreated.
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The three levels of report include:

• SoQ Value

A single statement against each requirement describing if the requirement 
and its children can be considered as qualified or not. As the report is 
produced a defined test set within Quality Center is used to interrogate the 
state of testing at a particular time.

• SoQ Defect

A slightly more verbose version of SoQ Value. Where a non-qualified 
requirement has associated defects within Quality Center, information about 
the defect is reported alongside the requirement itself. The Analyst can now 
determine if the priority of the defect has been set to indicate the business 
impact on the defect if it is not resolved at time of release.

• SoQ Report

An extension to SoQ Defect providing a mini-report on TestRuns run 
against each requirement in the module. This report provides a summary of 
testing and the level of defects that have been raised against a requirement.

For more information about SoQ attributes, see “Creating SoQ Attributes,” on 
page 33.
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4 Understanding synchronization tasks
• Overview

• What information can be transferred?

• Understanding synchronization task components

• REQUIREMENTS entities and synchronization tasks

• TEST entities and synchronization tasks

• DEFECT entities and synchronization tasks

• Naming synchronization tasks

• Mapping attributes and fields

Overview
Before you start creating synchronization tasks it is important that you analyze 
the data that needs to be available in both DOORS and Quality Center. You 
should be aware that the amount of information that is transferred by a 
synchronization task and the frequency with which that data is modified will 
impact on the speed at which the data can be synchronized. For more 
information about what you should consider before creating your 
synchronization tasks, see “Analyzing your data,” on page 15.
Each subset of data that you want to transfer should be defined by either a 
module filter that is saved as part of a view, or as a Quality Center favorite. These 
views and favorites can be selected when you create the synchronization tasks 
and this is how you define the data that is to be transferred. The DOORS view 
must also have any attributes that you want to be available to the integration 
displayed in columns.
For each view or favorite that you have created, you must create a 
synchronization task. A synchronization task comprises mappings between the 
attributes in a DOORS module and fields in a Quality Center entity. The 
synchronization task binds a DOORS module to a Quality Center entity and 
defines the rules that will govern the transfer of the data between the databases.

What information can be transferred?
The Integration can move data between the REQUIREMENTS, TESTS and 
DEFECTS entities in Quality Center and any number of DOORS modules.
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For each entity, one or other application must be the controlling application. The 
controlling application is the application that controls the creation and deletion 
of objects. So, if you have five synchronization tasks that define information that 
is to be transferred between the TESTS entity and DOORS, all five must specify 
the same application as the controlling application.
DOORS must be the controlling application for the REQUIREMENTS entity 
and typically Quality Center will be the controlling application for the TEST and 
DEFECTS entities. Using DOORS and Quality Center in this way enables the 
Analyst to use SoQ attributes to interrogate the Quality Center database from 
DOORS and retrieve varying levels of information about the state of testing for 
the project.
For DOORS to be able to retrieve this information, you must create 
synchronization tasks for both the REQUIREMENTS entity and the TEST 
entity. The synchronization tasks for the REQUIREMENTS entity should 
define the qualification criteria for the project. Once the qualification criteria 
have been transferred to Quality Center as requirements, the QA/Tester can 
begin creating tests and associating the tests with the requirements that they 
verify.
Quality Center provides a function by which tests can be created automatically 
from requirements. This has two main advantages for the integration:

• If you have created the qualification criteria in DOORS in a hierarchical 
structure, that structure is copied when the tests are created. Non-leaf 
objects are created as folders in the TEST entity and leaf objects are created 
as tests. When the analyst in DOORS creates SoQ attributes to determine 
the status of the project, the values for the leaf objects are propagated up 
through the hierarchy, so the analyst can get a high level statement of quality 
for the project as a whole. More detailed information can be viewed by 
navigating down through the hierarchy in DOORS.

• Associations are created automatically from the tests to the requirements 
when the tests are created. The integration relies upon the creation of 
associations to retrieve and present testing information to the Analyst using 
the SoQ attributes.

If you want Analysts to see data from the DEFECTS entity in DOORS, you can 
create synchronization tasks to transfer this information. Again care should be 
taken when analyzing what information needs to be transferred so that you can 
maximize the performance of the integration. Remember that the analyst can 
retrieve information about the defects that impact the project using SoQ 
attributes, so it may not be necessary to create synchronization tasks for the 
DEFECTS entity. 
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Understanding synchronization task components

Understanding synchronization task components
For each subset of information you want to transfer between DOORS and 
Quality Center you must create a synchronization task comprising mappings 
between the attributes in a DOORS module and fields in a Quality Center entity. 
You map attributes in DOORS to fields in Quality Center. Data is transferred 
between the mapped attributes when the synchronization task is run. 

DOORS

To set up a DOORS module for synchronization, create the DOORS view. The 
view should contain columns for each of the attributes you want to make 
available for mapping. If DOORS is to be the controlling application for the 
entity, i.e. if you want to copy data from the selected DOORS module to Quality 
Center, a filter that displays the objects you want to copy should be saved with 
the view.

Quality Center

To set up a Quality Center entity for synchronization, select the Quality Center 
Domain, Project and Entity along with Attributes you want to make available for 
mapping. If Quality Center is to be the controlling application for the entity, i.e. if 
you want to copy data from the entity to DOORS, you also select the favorite 
that displays the elements you want to copy to DOORS. 

Synchronization task

The synchronization task defines the rules by which data is transferred between 
the databases. The synchronization task defines the controlling application, 
attribute mappings and a synchronization schedule.

Controlling application

The controlling application is the application that controls the creation and 
deletion of objects. DOORS must be the controlling application for the 
REQUIREMENTS entity, and typically Quality Center is the controlling 
application for the TEST and DEFECT entities. 
For example, if DOORS is the controlling application for an entity and a 
DOORS user deletes an object that has been synchronized with Quality Center, 
the corresponding object is deleted in Quality Center the next time the 
synchronization task is run. If a Quality Center user deletes elements that have 
been created as the result of a synchronization and the corresponding objects 
still exist in DOORS, those elements are recreated when the synchronization 
task is run.
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Note  Only elements and objects that have been created by a 
synchronize are deleted if they are removed from the 
controlling database.

Attribute mappings

Each DOORS attribute that is included in a synchronization task must be 
mapped to a compatible field in Quality Center. Data in attributes that are not 
mapped, or that are mapped to incompatible fields, cannot be transferred when 
the synchronization task is run. For information about the attribute and field 
types that are compatible, see “Mapping attributes and fields,” on page 24.
When you map attributes, you also define which application is the owner of the 
attribute. The attribute owner is the application that controls the content of the 
individual fields or attributes, and can be either DOORS or Quality Center. So, 
although one application controls the creation and deletion of objects, you can 
specify which application can edit the attributes that are mapped.

Synchronization

You set a synchronization schedule for each synchronization task. The frequency 
with which a synchronization task should be run will depend on the information 
it contains and how often that information is modified.
The synchronization task is run automatically according to the schedule that is 
set. However, synchronization tasks can also be run manually from DOORS, and 
the Administration Console.

REQUIREMENTS entities and synchronization tasks
Once you have identified the requirements and attributes that make up the 
qualification criteria for the project, you need to create synchronization tasks to 
copy that information to the REQUIREMENTS entity in Quality Center. You 
set up a DOORS module for each subset of data you want to copy to Quality 
Center. You must also create one or more Quality Center entities.
The attributes you included in each DOORS module must be mapped to 
compatible Quality Center fields so that the data can be synchronized 
successfully.
The Quality Center entities define the Domain, Project, Entity and Attributes for 
the qualification criteria to be copied to. As all of the qualification criteria will be 
copied to the REQUIREMENTS entity, the number of Quality Center entities 
you have to create depends on whether all the DOORS modules include the 
same attributes, or different attributes. If they all include the same attributes, you 
can create one Quality Center REQUIREMENTS entity and map all of the 
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TEST entities and synchronization tasks

DOORS attributes to it. If the DOORS modules contain different attributes, 
you will have to create a Quality Center mapping for each DOORS module that 
contains a different set of attributes.
You can create the Quality Center fields for mapping manually, or you can let the 
integration do this for you. This function is available when you create the 
synchronization task. Instead of creating and selecting the Quality Center fields 
to which you want to map the DOORS attributes, you can create it from the 
DOORS attributes. This will create compatible fields in the REQUIREMENTS 
entity for all the attributes that are included in the DOORS module you select, 
and will include those fields in the Quality Center mapping that it creates. 
Once the Quality Center entity has been created, you can select it when you 
create subsequent synchronization tasks, or you can use the function again to 
create new Quality Center mappings to other DOORS modules.

TEST entities and synchronization tasks
When tests have been created to verify the qualification criteria in the 
REQUIREMENTS entity and the tests have been associated with the 
requirements they verify, you create synchronization tasks to copy the test data to 
DOORS. You create a Quality Center entity for each subset of information you 
want to copy to DOORS. You can copy all of the test information to a single 
DOORS module through one or more synchronization tasks, or you can copy 
subsets of information to different modules. 
You must also create one or more DOORS modules to which the Quality Center 
entities can be mapped.
As with the mappings for the REQUIREMENTS entity, the number of DOORS 
modules you require for mapping is determined by the attributes that are 
included in each Quality Center mapping, and whether you want to copy the data 
to one or more DOORS modules. You must create a DOORS mapping for each 
DOORS module you want to copy data to. If you want to map more than one 
Quality Center entity to a single DOORS module, and the entities contain 
different attributes for mapping, you will have to create views in the DOORS 
module that displays compatible attributes for the fields in each Quality Center 
entity. You must then create a DOORS module for each view.
You can create the DOORS modules for mapping manually, or you can let the 
integration do this for you. This function is available when you create the 
synchronization task. Instead of creating and selecting the DOORS module to 
which you want to map the Quality Center entity, you can create it from the 
Quality Center entity. You select the Quality Center entity to create the DOORS 
module from, and the module you want to copy the Quality Center data to. The 
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integration then creates compatible attributes in the module for all the fields that 
are included in the selected Quality Center entity, and includes those attributes in 
the DOORS module it creates.
Once the DOORS module has been created, you can select it when you create 
subsequent synchronization tasks, or you can use the function again to create 
different DOORS modules for mapping to other Quality Center entities.

DEFECT entities and synchronization tasks
You create mappings for the DEFECTS entity in the same way as for the TEST 
entity.
Remember that analysts can retrieve information about defects that impact the 
project by creating SoQ attributes in the requirements modules, so it may not be 
necessary to create synchronization tasks for the DEFECTS entity.

Naming synchronization tasks
It is worthwhile spending some time before you start using the integration 
setting up naming conventions for synchronization tasks. This means that it will 
be easier to identify the synchronization tasks and the information that is being 
transferred by them.
You may also want to consider creating a file containing the names and 
descriptions of synchronization tasks, which can be stored in a central location 
and accessed by users of the integration.

Mapping attributes and fields
When you create a synchronization task, you have to map attributes in DOORS 
to fields in Quality Center. Data is transferred between the attributes and fields 
that are mapped, so when you map attributes, you must make sure that the 
attribute type in DOORS is compatible with the field type in Quality Center. The 
following table shows the types that are compatible in DOORS and Quality 
Center.

DOORS attribute type Quality Center field type

Date Date
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Mapping attributes and fields

String
If DOORS is the owner, rich text 
markup and OLE objects are not copied 
to Quality Center. The attribute may be 
truncated in Quality Center.

String
If Quality Center is the owner, the 
attribute value is displayed in DOORS in 
plain text.

Text
If DOORS is the owner, rich text 
markup and OLE objects are not copied 
to Quality Center. The attribute may be 
truncated in Quality Center.
The DOORS Object Text attribute 
cannot be mapped to the Quality Center 
String attribute. Object Text can only be 
mapped to the Quality Center Memo 
attribute type.

String
If Quality Center is the owner, the 
attribute value is displayed in DOORS in 
plain text.
Note: You may have to increase the 
default size of string fields in Quality 
Center from 40 to 255 characters.

Text
If DOORS is the owner, OLE objects 
are not copied to Quality Center.

Memo
If Quality Center is the owner, text color 
is not copied to DOORS. Memo 
attribute values are stored and displayed 
as HTML.
Note Quality Center only allows three 

memo fields in each project. If you 
want to map more than three text 
attributes, map to string field 
types.

Integer Number

Real String

Single-value Enumeration
The name of the lookup list to which you 
are mapping the enumeration must be 
added to the enumeration as a value.

Lookup List
The Verify value checkbox must be 
selected.

DOORS attribute type Quality Center field type
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The Test name field in the TEST entity in Quality Center cannot be empty and 
cannot contain any of the following characters:

• Quotation marks (“ ”)

• Angle brackets (< >)

• Colons (:)

• Commas (,)

• Forward slash (/)

• Back slash (\)

• Question mark (?)

• Bar (|)

• Asterisk (*)

• Percent sign (%)

If you map a DOORS attribute to the Test name field and DOORS is the 
owner of the attribute and the controlling application, you must ensure that the 
DOORS attribute does not contain any of those characters.
If DOORS is the controlling application for the TEST entity, tests are not 
synchronized to a folder, and are only visible in grid view.

Multi-valued Attributes
DOORS must be the owner.

String
Multi-valued attributes are represented in 
Quality Center as a comma separated list.

DXL Attribute
DOORS must be the owner.

String

DOORS attribute type Quality Center field type
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5 Synchronizing data
• Understanding object synchronization

• Understanding link synchronization

• Synchronizing data from the Administration Console

• Synchronizing data from DOORS

• Creating traceability columns

Understanding object synchronization
When you run a synchronization task, information is updated according to the 
rules defined in the task. So objects or elements are created and deleted to match 
the controlling application, and attribute values are updated to match the value 
for the owner of each attribute. Information in DOORS tables is not included in 
a synchronization.

Note  Read-only objects in DOORS cannot be updated by a 
synchronization.

For example, if you have a synchronization task where DOORS is the controlling 
application, and the owner of attributes A, B and C and Quality Center is the 
owner of attribute D, when you synchronize the task:

• Elements are created in Quality Center to match objects that have been 
created in DOORS

• Elements are deleted from Quality Center if they were originally created in 
DOORS and the corresponding object in DOORS no longer exists

• The values stored in attributes A, B and C are copied from DOORS to 
Quality Center

• The values stored in attribute D are copied from Quality Center to DOORS

Note  If a parent object in the controlling application is deleted and 
the corresponding object in the receiving application has a 
child that is not part of the task you are synchronizing, the 
parent object is not deleted in the receiving application.

If a synchronization task contains a DOORS column displaying a DXL attribute, 
the data for the attribute will be synchronized to Quality Center the first time the 
synchronization task is run. Subsequent synchronizations will not update the 



Synchronizing data

28    Installing and Using Telelogic DOORS for HP Quality Center Interface

attribute in Quality Center unless the objects have been modified in DOORS 
since the last synchronization. This is because refreshing DXL attributes does 
not change the modified date of an object.
A synchronization schedule is defined for each synchronization task when it is 
created, and the synchronization task is automatically run according to that 
schedule. Tasks can also be synchronized manually from DOORS or the 
Administration Console.
It is important that an appropriate synchronization schedule is defined, so that 
Analysts and QA/Testers can be confident that they are working with accurate 
and up-to-date information.

Note  If you are going to synchronize large tasks, the Quality 
Center client timeout setting should be set to either a high 
value or -1 value. If a small value is used, the Quality Center 
client being used for the synchronization could timeout 
before it’s finished.

Understanding link synchronization
When you run a TEST synchronization task, links from tests to requirements 
that are included in the synchronization task are also synchronized. This means 
that links between objects in DOORS are replicated between the corresponding 
elements in Quality Center when a synchronization task that includes the source 
objects is run. Similarly, associations between elements in Quality Center are 
replicated between the corresponding objects in DOORS when a 
synchronization task that includes the source elements is run. 
Links are not copied during a synchronization if they:

• Go in the opposite direction than specified above, for example links from 
requirements to tests

• Are between objects or elements in the same task, for example links between 
requirements in a task

• Are between objects or elements other than those specified above, for 
example links between tests and test sets

Which application controls the creation and deletion of links?
There is no controlling application for the creation and deletion of links. As long 
as a link conforms to the rules for link synchronization it will be synchronized 
when the synchronization task is run:
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Synchronizing data from the Administration Console

• If a link or association is created in one database and the corresponding 
objects exist in the other database, the link will be created when the 
synchronization task is run

• If a link or association that has been created as a result of a previous 
synchronization is deleted in either database, the corresponding link will be 
deleted when the synchronization task is run

• If a synchronized link is independently deleted in both databases, and a new 
link is created in one database, that link will be deleted by a synchronization.

What happens when a linked object is deleted? 

If an object that has a synchronized link is deleted from the database of the 
controlling application for the entity, running the synchronization task has the 
following effect:

• The corresponding object in the other database is deleted.

• The previously synchronized link is deleted.

If an object that has a synchronized link is deleted from the database that is not 
the controlling application for the entity, the link is also deleted. However, 
because a synchronization recreates the object, this indirect link deletion is 
invalid, so the corresponding link in the controlling application is not deleted. 
When the synchronization task is run, the object that was deleted is recreated 
along with the link.

Synchronizing data from the Administration Console
The Administration Console is the recommended application to use when you 
want to synchronize data. Only use DOORS to synchronize when you do not 
have access to the Administration Console.
For information on how to synchronize data using the Administration Console 
see the console’s Online Help.

Synchronizing data from DOORS
In a DOORS module, you can run a single synchronization task, or all of the 
synchronization tasks that are associated with the module.

Note  Once the synchronization has been started, it cannot be 
cancelled. Clicking the Cancel button at any stage does not 
stop the synchronization.
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To run a single synchronization task:
1. In the DOORS module window, select DOORSConnect > Quality 

Center > Synchronize > Synchronize Task.

A dialog box containing a list of all the synchronization tasks associated with 
the current module is displayed.

2. Select the synchronization task you want to run and click Sync.

A Link Synchronization dialog box is displayed. 

3. Click Objects and Links or Objects only.

A message stating that the module’s edit mode is being changed to read only 
is displayed.

4. Click OK.

Objects and optionally links in DOORS and Quality Center are 
synchronized according to the synchronization task mapping information.

When the synchronization is complete, a report is generated. This contains 
details of:

• Objects and elements that have been created
• Objects and elements that have been deleted
• Objects and elements that have been modified
• Links that have been created
• Links that have been deleted
• Any errors or warnings that were generated

5. Change back to exclusive edit mode to see any updates that have been made 
by the synchronization.

To run all synchronization tasks:
1. In the DOORS module window, select DOORSConnect > Quality 

Center > Synchronize > Synchronize All Tasks.
A confirmation dialog box is displayed.

2. Click Confirm to run all the synchronization tasks associated with the 
module.

A Link Synchronization dialog box is displayed. 

3. Click Objects and Links or Objects only.

A message stating that the module’s edit mode is being changed to read only 
is displayed.
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Creating traceability columns

4. Click OK.

Objects and optionally links in DOORS and Quality Center are 
synchronized according to the synchronization task mapping information.

When the synchronization is complete, a report is generated. This contains 
details of:

• Objects and elements that have been created
• Objects and elements that have been deleted
• Objects and elements that have been modified
• Links that have been created
• Links that have been deleted
• Any errors or warnings that were generated

5. Change back to exclusive edit mode to see any updates that have been made 
by the synchronization.

Creating traceability columns
You can create traceability columns that display information about links that 
have been synchronized as part of a synchronization task. Only links that satisfy 
the criteria for link synchronization can be analyzed in a traceability column. For 
more information see “Understanding link synchronization,” on page 28.
To create traceability columns:

1. In the DOORS Formal Module window, select DOORSConnect > 
Quality Center > Create Traceability Column.

This runs the Task Traceability Analysis wizard.
2. Click Next on the Welcome screen.

3. Select the tasks and the direction of the links you want to analyze.

4. Click Next.
5. Select the attributes you want to display in the traceability column for each 

selected task.

Click Next and repeat this step for each task selected in the previous step.

6. On the Recursion Depth screen, type the number of traceability columns 
you want to display. 

7. Click Next.
8. Click Finish.

The traceability columns are added to your view.
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6 Creating SoQ Attributes
• Understanding SoQ Attributes

• Creating the SoQ Value Attribute

• Creating the SoQ Defect Attribute

• Creating the SoQ Report Attribute

Understanding SoQ Attributes
SoQ attributes provide three levels of reporting against qualification criteria that 
have been integrated with Quality Center through requirement and test tasks: 

• SoQ Value

• SoQ Defect

• SoQ Report

They enable the analyst to see varying degrees of detail about the test status of 
the project at milestones in the project.
SoQ value attributes cannot be calculated unless the requirements and tests that 
verify them have been included in synchronization tasks, and those 
synchronization tasks have been run at least once. SoQ attributes will only 
display results for the tests that are associated with the requirements in the 
synchronization task.
You create the SoQ Value attribute in the DOORS Requirements module.

Note  The Qualification Attribute menu options are only displayed 
in modules that are mapped to the REQUIREMENTS entity 
in Quality Center through a synchronization task.

Understanding the SoQ Value attribute
The SoQ Value attribute provides information about the status of the tests in 
Quality Center that are associated with requirements, and that are included in 
synchronization tasks that have been run by the integration. Each DOORS 
requirement is checked for associated TESTS in Quality Center, and where 
associated tests are found, it displays results from the latest run of the test set 
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you select. For each requirement one of the following values will be displayed in 
the SoQ Value attribute:

SoQ values are propagated up through the requirements hierarchy. So if a 
DOORS object has children, the SoQ value of the child object is considered 
when the SoQ value of the parent is calculated. For example, if the SoQ value of 
a child object is Not-completed, the SoQ value that is reported to the analyst 
for the parent object is Not-completed. The analyst can navigate through the 
hierarchy to see which child object has the value Not-completed, and can 
determine the business impact of that result.
If any descendant of an object has an SoQ value of No coverage, the parent 
object will also have an SoQ value of No Coverage. If that object also has a 
descendant with an SoQ value of Failed, the SoQ value of the parent will be 
Failed, not No Coverage.

Understanding the SoQ Defect attribute

The SoQ Defects attribute displays the same information as the SoQ Value 
attribute for all attribute values except Failed. Where an SoQ Value is Failed, 
the integration will retrieve and display defects that have been raised against, or 

SoQ Value of... Means...

No coverage There are no TEST elements associated with the DOORS 
requirements.

Failed There is at least one TEST element associated with the 
DOORS requirement that has been run and has a verdict of 
Failed.

Not-run Each TEST element associated with the DOORS requirement 
has a verdict of either Not-run, Passed or N/A.

Not-completed At least one TEST element associated with the DOORS 
requirement has a verdict of Not-completed.

N/A All TEST elements associated with the DOORS requirement 
have a verdict of N/A.

Qualified All of the TEST elements associated with the DOORS 
requirement have been run and have a verdict of Passed or 
N/A.
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associated with, tests that are associated with the DOORS requirement and that 
have failed in the latest run of the test set you selected. 
There are several ways to create associations between defects and runs in Quality 
Center. Defects that are associated in the ways described below are displayed 
when the SOQ Defect attribute is calculated.
Using Quality Center functionality, you can create an association between a 
defect and a run in one of two ways:

• When you run a test, and it fails, you raise a defect. Quality Center records 
the RUN in the DEFECT. As the defect is associated with a particular run, it 
cannot be associated with any other test. So, if a single defect is the reason 
why two different tests have failed, you have to raise two identical defects, 
one for each failed run. When you calculate the SoQ defect attribute, all of 
the defects that are associated with failed runs are displayed.

• Alternatively, some Quality Center users work around this limitation by 
customizing Quality Center. They create an attribute in the RUN entity, and 
use this customization to record the defect ID of the defect that has caused 
the test to fail. This means that one defect can be associated with numerous 
runs. If this is the way that you associate defects with runs in Quality Center, 
you must provide the name of the attribute that you use to record the defect 
ID when you create the SoQ Defect attribute, or those defects will not be 
displayed when the SoQ Defect attribute is calculated. You do this by 
selecting the attribute name from the Attribute as Defect ID list on the 
SoQ Defect dialog box.

Understanding the SoQ Report
The SoQ Report displays the same information as the SoQ Defects attribute, 
along with a summary of how elements of type TEST are associated with the 
DOORS requirement, and gives the verdicts from the SoQ Value that have 
resulted in the value that is reported.

Creating the SoQ Value Attribute
1. In the requirements module, select DOORSConnect > Quality Center> 

Qualification Attribute > SoQ Value.

Note  You need Modify access to the module.

2. Type a name in Attribute Name.

The prefix SoQValue_ is automatically added to the name. For example, if 
you enter Attribute, the attribute will be named SoQValue_Attribute. 
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3. Select the synchronization task that defines the requirements for which you 
want to calculate SoQ attributes from the Task drop-down list.

4. Select a Test Set from the Test set drop-down list.

5. Click Calculate. 

If the module is open in either read-only or shareable edit mode, it will be 
changed to exclusive edit mode before starting the calculation. 

Creating the SoQ Defect Attribute
1. In the DOORS Formal Module window, select DOORSConnect > 

Quality Center > Qualification Attribute > SoQ Defects.
Note  You need Modify access to the module.

2. Enter a name in Attribute Name.

The prefix SoQDefect_ is automatically added to the name. For example, if 
you enter Attribute, the attribute will be named SoQDefect_Attribute.

3. Select the synchronization task that defines the requirements for which you 
want to calculate SoQ attributes from the Task drop-down list.

4. Select a Test Set from the Test set drop-down list.

5. The Attribute as Defect Id list is populated with attributes from the RUN 
entity in Quality Center. If you have created an attribute in the RUN entity 
where you can enter the Defect ID of any associated defect manually, select 
that attribute from the list. Those defects will also be included in the SoQ 
Defect attribute. For more information about this option, see 
“Understanding the SoQ Defect attribute,” on page 34.

6. Select attributes to display in the SoQ Defect attribute from the Defect 
Attributes list.

• If you want to save the attribute configuration for use later, click Save. 
Browse to the folder where you want to save the configuration, and click 
Save. 

• If you want to load a configuration that you have saved previously, click 
Load. Browse to the folder that contains the configuration file you want 
to load, and click Load.

7. Click Calculate. 

The SoQ defect value for each object in the task is calculated.



Installing and Using Telelogic DOORS for HP Quality Center Interface           37

Creating the SoQ Report Attribute

Creating the SoQ Report Attribute
1. In the requirements module, select DOORSConnect > Quality Center > 

Qualification Attribute > SoQ Report.
Note  You need Modify access to the module.

2. Follow the instructions in “Creating the SoQ Defect Attribute,” on page 36, 
Step 2 to Step 6.

3. Click Calculate. 

The SoQ report value for each object in the task is calculated and displayed in 
table format. The table summarizes how elements of type TEST are associated 
with the DOORS object.
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7 Turning logging on and off
Note  This section is for reference, and steps should only be 

performed when requested by DOORS support.

Telelogic DOORS for HP Quality Center Interface is installed with logging 
turned off by default. If you want to turn logging on, you need to open the 
registry for editing and then edit the following values in the registry:
• LogLevel

This value determines what actions are recorded in the log file.
• LogPath

This value determines the location of the log file.

Turning on logging
To turn on logging:
1. Open the Registry Editor.

Click Start > Run and type regedit. Click OK.

Note  You must be logged on as an administrator or a member 
of the Administrators group in order to perform this 
procedure.

2. Navigate to the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\TDIntegration\WebService\

3. Select the string value LogLevel.

If the string value doesn’t already exist, right-click New > String Value and 
enter LogLevel.

4. Either:

• Right-click Modify.
• Double-click.

The Edit String window is opened.

5. Enter the value provided by support in the Data field and click OK.

6. Select the string value LogPath.
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If the string value doesn’t already exist, right-click New > String Value and 
enter LogPath.

7. Either:

• Right-click Modify.
• Double-click.

The Edit String window is opened.

8. Enter a location in the Value data field and click OK.

The default location for LogPath is IWS Logs in the home directory of the 
web service. The log file is named IWS-<timestamp>.log, where 
<timestamp> is a UTC milliseconds timestamp.

9. Select Registry > Exit to close the registry.

Logging is switched on, and the location of the log file is set.

Clearing old log files
If you switch on logging, each time the aspnet_wp.exe process restarts, a new 
log file is created. Clear out old log files regularly, otherwise the performance of 
your system may be adversely affected.
Navigate to the folder containing the log files, and delete any obsolete log files.

Turning off logging
To turn off logging:
1. Open the Registry Editor.

Click Start > Run and type regedit. Click OK.

Note  You must be logged on as an administrator or a member 
of the Administrators group in order to perform this 
procedure.

2. Navigate to the following registry subkey:
HKEY_LOCAL_MACHINE\SOFTWARE\Telelogic\TDIntegration\WebService\

3. Select the string value LogLevel.

4. Either:

• Right-click Modify.
• Double-click.
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The Edit String window is opened.

5. Enter 0 in the Value data field and click OK.

Logging is switched off.
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8 Contacting support
This chapter contains the following topics:

• Contacting IBM Rational Software Support

• What to do before you contact Support

• Sending an automated problem report form

• Other information

Contacting IBM Rational Software Support
Support and information for Telelogic products is currently being transitioned 
from the Telelogic Support site to the IBM Rational Software Support site. 
During this transition phase, your product support location depends on your 
customer history.

Product support
• If you are a heritage customer, meaning you were a Telelogic customer prior 

to November 1, 2008, please visit the DOORS Support Web site on 
https://support.telelogic.com/doors.

Telelogic customers will be redirected automatically to the IBM Rational 
Software Support site after the product information has been migrated.

• If you are a new Rational customer, meaning you did not have 
Telelogic-licensed products prior to November 1, 2008, please visit the IBM 
Rational Software Support site on 
http://www.ibm.com/software/rational/support/.

What to do before you contact Support
If your site has a designated on-site support person, please contact that person 
before you contact our Support team.
To help our Support team solve your problem, please have the following 
information available:

• Your name, title, company name, e-mail address, fax number and telephone 
number.

• Your support ID and support password.

• The version and build number of DOORS that you’re running.
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To get this information, run DOORS, and click Help > About DOORS.

• The operating system you’re running DOORS on, for example Windows 
XP.

• What operating system your DOORS database is running on, if different.

• If you are reporting a new problem, please have a clear statement of the 
problem, including the exact text of any error messages produced by 
DOORS, your operating system, or any other tools that were running when 
the problem occurred.

• If you are calling about a problem you reported earlier, you need the original 
tracking number the Support team assigned to your problem.

• If you want, you can use the automated problem report form. For 
information, see “Sending an automated problem report form,” on page 44.

The support center on our web site is at https://support.telelogic.com.

Sending an automated problem report form
To send an automated problem report to Support:
1. Select Help > Generate Support Request.

The Telelogic Support Information dialog box is displayed with some of 
your product information automatically included.

Review the information to make sure it’s accurate.

2. From the Impact drop down list box, select the severity of the problem.

3. In the Summary box, summarize the problem.

4. In the Problem box, type a detailed description of the problem.

5. If available, attach a snapshot.

Click either DOORS Window Snapshot or Screen Snapshot, whichever is 
applicable, and select the snapshot from your machine.

6. If possible, use the buttons in the Attachment Information area to add 
video capture, system details and files.

Note  The Add Product Files button is unavailable in 
DOORS. Product information is collected and added 
automatically.

Add any relevant information to help Support resolve the problem.

7. You can either:
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• Display the information you’ve entered in a new window so that you can 
copy it. For example, you may want to add this information to someone 
else’s information. 

Click Just Text (No Email).
• Open the email to edit it before sending it to Support. 

Click Preview and Send to submit the report.

Guidelines for writing a problem report

• Be as specific as possible when you summarize the problem in the 
Summary box and when you explain the situation and provide details in the 
Problem box. For example, “The system crashed when I tried to add an 
attribute” is more helpful than “It crashed.”

• Indicate if there were any system changes, such as customizations or 
upgrades, before the problem occurred.

• If the problem is reproducible, list the specific steps to be followed in order 
to demonstrate the problem and also indicate the model you are using to 
perform the steps.

• In the problem description, include anything different or unusual that you 
observed before the problem happened.

• Make screen captures of anything that you feel will help and attach them to 
the problem report.

• Include any error messages and code samples you have related to the 
problem.

• If you have multiple unrelated questions or issues, please submit them 
separately. 

Automatic responses and recording defects

When you send the online form to Support, the customer service system 
immediately searches the Knowledge Base based on the Summary and 
Problem descriptions you entered. If there is an exact match of your problem in 
the knowledge base, the system automatically sends an email to you with a 
pointer to the most likely solution.
The problem is also automatically recorded in the defect tracking system as 
assigned to a support representative. This representative works with you to be 
certain that your problem is solved. The defect tracking system also records new 
problems with their solutions in the Knowledge Base to provide rapid assistance 
for other customers.
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Automatically generated problem reports

If your DOORS system crashes, it displays a message asking if you want to send 
a problem report about the crash to DOORS Support.
If you decide to send this generated report, the system displays the same online 
form that is available from Help > Generate Support Request. In this case, 
the form contains information about the crash condition, in addition to the 
information that is usually filled in describing your system. 
Add any more information that you can to help the Support staff identify the 
problem before you click the Preview and Send button.

Changing the email address of the problem report
If you want to send the problem to someone other than DOORS Support, for 
example to your internal support, you can change the default email address of 
the problem report.
To change the email address of the problem report:
1. Open System in the Control Panel.
2. On the Advanced tab, click Environment Variables, then click New under 

variables.

The New User Variable window is displayed

3. In Variable Name enter ILX_RECIP, the variable that controls the 
address used by the problem report.

4. In Variable Value enter the email address you want to use.

5. Click OK to add the value.
6. Click OK to save the value in the environment variables.
7. Click OK to save the value in the system properties.

Other information
For Rational software product news, events, and other information, visit the 
IBM Rational Software Web site on http://www.ibm.com/software/rational/.
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9 Notices
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right 
may be used instead. However, it is the user's responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to:  
 
IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY 10504-1785 
U.S.A.  
 
For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to:  
 
IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan  
 
The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
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This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the 
purpose of enabling: (i) the exchange of information between independently 
created programs and other programs (including this one) and (ii) the mutual use 
of the information which has been exchanged, should contact:  
 
Intellectual Property Dept. for Rational Software 
IBM Corporation 
1 Rogers Street 
Cambridge, Massachusetts 02142 
U.S.A. 
 
Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
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Trademarks

performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 
Additional legal notices are described in the legal_information.html file that is 
included in your software installation.

Trademarks
IBM, the IBM logo, ibm.com, Telelogic, Telelogic DOORS, for HP Quality 
Center Interface are trademarks or registered trademarks of International 
Business Machines Corporation in the United States, other countries, or both. 
These and other IBM trademarked terms are marked on their first occurrence in 
this information with the appropriate symbol (® or ™), indicating US registered 
or common law trademarks owned by IBM at the time this information was 
published. Such trademarks may also be registered or common law trademarks in 
other countries. A current list of IBM trademarks is available on the Web at 
www.ibm.com/legal/copytrade.html.
Microsoft, Windows and/or other Microsoft products referenced herein are 
either trademarks or registered trademarks of Microsoft Corporation.
UNIX is a registered trademark of The Open Group in the United States and 
other countries.
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