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1 Introduction
The IBM® Rational® Change for DOORS® Interface brings together IBM® 
Rational® DOORS®, the world's leading requirements management tool, and 
IBM® Rational® Change, the best-of-breed software change management 
solution.
The Rational Change for DOORS Interface offers capabilities that can be 
grouped into three categories:

• Requirements change management

• Requirements implementation

• Requirements gathering

The requirements change management features of the Rational Change for 
DOORS Interface allow users to do the following:

• Propose a change to a system at a high level.

• Categorize a change into one or more requirements change requests (RCRs).

• Propose, review, and apply changes to requirements in association with the 
requests.

With requirements implementation, users can:

• Trace requirements through to implementation.

• Obtain immediate visibility when requirements are implemented.

• Determine the project status based on how many requirements are fulfilled.

• Assess the impact of requirements changes on the project.

Requirements gathering allows users to import enhancement requests from 
Rational Change into Rational DOORS to use as the basis for a new Rational 
DOORS document.
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Features
The following are the Rational Change for DOORS Interface features:

• Create one or more implementation requests for a requirement.

• Associate one or more existing implementation requests with one or more 
requirements.

• Directly access implementation request information in Rational DOORS 
requirement objects.

• Run activity reports for requirements modules, showing each requirement's 
associated change requests (CRs), tasks, and files that implement the 
requirement.

• Start Rational Change from Rational DOORS to create, view, or modify CRs.

• Import data from Rational Change into Rational DOORS.

• Propose changes to requirements and associate the proposed changes to 
CRs.

• Review CRs and the associated proposed requirement changes.

• Apply proposed requirement changes to Rational DOORS.

Benefits
The Rational Change for DOORS Interface allows an organization to implement 
a requirements-driven development process with the following benefits:

• Clearly defined and communicated requirements, which improves the focus 
of the development team, thereby reducing rework and improving 
productivity.

• Automatic establishment of the relationships between requirements and 
related development activities, which improves process control and 
productivity.

• Real-time visibility of the relationships between requirements and 
development activities, which helps reduce feature creep and streamlines 
development.

• Ability to import enhancement requests and defects submitted by users to be 
used as a basis for new requirements, thereby allowing traceability and re-use 
of customer-reported issues.
2 IBM® Rational® Change for DOORS® Interface User’s Guide



Interface menus
Interface menus
Administrative and module-specific Rational Change operations are available on 
the Change Management menu on the Formal module main menu, as shown 
in the following figure.

Requirement-specific Rational Change operations are available on each 
requirement pop-up menu, as shown in the following figure.

See the IBM Rational Change for DOORS Interface Administration Guide (located at 
http://publib.boulder.ibm.com/infocenter/rsdp/v1r0m0/index.jsp) for step-
by-step instructions for the following:

• Product Requirements

• Installing the Interface

• Managing Packages
IBM® Rational® Change for DOORS® Interface User’s Guide  3
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• Interface Configuration

Assumptions
Before using this document, you should have a basic understanding of how to 
use Rational DOORS and Rational Change. If you are unfamiliar with these 
products, you will find documentation on the Rational Software Information 
Center. 

Conventions
The following describes the conventions used in this document.

Typefaces and symbols

This document also uses the following conventions:

Note  A note contains important information that should not be 
overlooked.

Caution  A caution indicates potential danger to the database, the 
database server, or some other integral piece of the 
Rational Change for DOORS Interface software or your 
system.

Typeface Description

Italic Used for book titles and terminology. Also designates 
names of roles (developer), states (working), groups 
(ccm_root), and users (sue).

Bold Used for items that you can select, such as buttons, 
icons, and so forth, and menu paths. Also used for the 
names of dialog boxes, dialog box options, toolbars, 
folders, baselines, databases, releases, properties, and 
types. Also used for emphasis.

Courier Used for commands, filenames, and directory paths. 
Represents command syntax to be entered verbatim. 
Signifies computer output that displays on-screen.

Courier Italic Represents values in a command string that you supply. 
For example, (drive:\username\commands).
4 IBM® Rational® Change for DOORS® Interface User’s Guide
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Contacting IBM Rational Software Support
If the self-help resources have not provided a resolution to your problem, you 
can contact IBM® Rational® Software Support for assistance in resolving 
product issues.

Note  If you are a heritage Telelogic customer, a single reference 
site for all support resources is located at http://
www.ibm.com/software/rational/support/telelogic/

Prerequisites
To submit your problem to IBM Rational Software Support, you must have an 
active Passport Advantage® software maintenance agreement. Passport 
Advantage is the IBM comprehensive software licensing and software 
maintenance (product upgrades and technical support) offering. You can enroll 
online in Passport Advantage from http://www.ibm.com/software/lotus/
passportadvantage/howtoenroll.html

• To learn more about Passport Advantage, visit the Passport Advantage 
FAQs at http://www.ibm.com/software/lotus/passportadvantage/
brochures_faqs_quickguides.html.

• For further assistance, contact your IBM representative.

To submit your problem online (from the IBM Web site) to IBM Rational 
Software Support, you must additionally:

• Be a registered user on the IBM Rational Software Support Web site. For 
details about registering, go to http://www.ibm.com/software/support/.

• Be listed as an authorized caller in the service request tool.

Submitting problems
To submit your problem to IBM Rational Software Support:

1. Determine the business impact of your problem. When you report a 
problem to IBM, you are asked to supply a severity level. Therefore, you 
need to understand and assess the business impact of the problem that you 
are reporting.
IBM® Rational® Change for DOORS® Interface User’s Guide  5
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Chapter 1: Introduction
Use the following table to determine the severity level.

2. Describe your problem and gather background information, When 
describing a problem to IBM, be as specific as possible. Include all relevant 
background information so that IBM Rational Software Support specialists 
can help you solve the problem efficiently. To save time, know the answers to 
these questions:

• What software versions were you running when the problem occurred?

To determine the exact product name and version, use the option 
applicable to you: 

- Start the IBM Installation Manager and select File > View Installed 
Packages. Expand a package group and select a package to see the 
package name and version number. 

- Start your product, and click Help > About to see the offering name 
and version number. 

• What is your operating system and version number (including any 
service packs or patches)? 

• Do you have logs, traces, and messages that are related to the problem 
symptoms? 

• Can you recreate the problem? If so, what steps do you perform to 
recreate the problem? 

Severity Description

1
The problem has a critical business impact: You are unable to 
use the program, resulting in a critical impact on operations. 
This condition requires an immediate solution.

2 This problem has a significant business impact: The program 
is usable, but it is severely limited.

3
The problem has some business impact: The program is 
usable, but less significant features (not critical to 
operations) are unavailable.

 4
The problem has minimal business impact: The problem 
causes little impact on operations or a reasonable 
circumvention to the problem was implemented.
6 IBM® Rational® Change for DOORS® Interface User’s Guide
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• Did you make any changes to the system? For example, did you make 
changes to the hardware, operating system, networking software, or 
other system components? 

• Are you currently using a workaround for the problem? If so, be 
prepared to describe the workaround when you report the problem.

3. Submit your problem to IBM Rational Software Support. You can submit 
your problem to IBM Rational Software Support in the following ways:

• Online: Go to the IBM Rational Software Support Web site at https://
www.ibm.com/software/rational/support/ and in the Rational support 
task navigator, click Open Service Request. Select the electronic 
problem reporting tool, and open a Problem Management Record 
(PMR), describing the problem accurately in your own words.

For more information about opening a service request, go to http://
www.ibm.com/software/support/help.html

You can also open an online service request using the IBM Support 
Assistant. For more information, go to http://www.ibm.com/software/
support/isa/faq.html.

• By phone: For the phone number to call in your country or region, go 
to the IBM directory of worldwide contacts at http://www.ibm.com/
planetwide/ and click the name of your country or geographic region. 

• Through your IBM Representative: If you cannot access IBM 
Rational Software Support online or by phone, contact your IBM 
Representative. If necessary, your IBM Representative can open a 
service request for you. You can find complete contact information for 
each country at http://www.ibm.com/planetwide/.
IBM® Rational® Change for DOORS® Interface User’s Guide  7
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2 Managing Interface Packages
This section contains information about installing and removing Rational Change 
for DOORS Interface packages.

• Installing packages (page 9)

• Removing packages (page 10)

A package is a bundle of several files that are necessary for updating or adding 
upgraded features to the interface. Your administrator deploys these packages to 
the server.

When a Rational DOORS session is started, the Rational Change for DOORS 
Interface automatically checks the server to determine whether new packages are 
available for installation. If a package is available for installation, the Package 
Available dialog box opens.

For more detailed information about packages, see “Managing Packages” in the 
IBM Rational Change for DOORS Interface Administration Guide.

Installing packages
To install packages:

1. On the Package Available dialog box, select Install update now, and then 
click OK.

If you are not ready to install the package, select Remind me again, and then 
select in 1 day, in 7 days, or never.

2. If you are instructed to restart Rational DOORS, close the program and 
restart your session.
IBM® Rational® Change for DOORS® Interface User’s Guide 9
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Removing packages
If for some reason an unneeded package was installed, the system allows you to 
remove the package. Packages must be removed in the inverse order in which 
they were installed.
To remove a package:

1. On the main menu, select Rational Change Interface > Remove 
Packages from Client.
The Remove Packages from Client - DOORS dialog box opens, showing 
a list of installed packages.

2. Click to select the package that you want to remove.

You many only remove the most recently installed package. The Remove 
button becomes active when the most recently installed package is selected.

3. Click Remove to remove the package.

4. Click OK to close the dialog box.

If you are instructed to restart Rational DOORS, close the program and 
restart your session.
10 IBM® Rational® Change for DOORS® Interface User’s Guide



3 Requirements Gathering
This chapter describes how to retrieve CR data from Rational Change for use in 
Rational DOORS. To import requirements from Rational Change, the following 
steps must be performed:

• Defining attribute mapping (page 11)

• Obtaining Rational Change data (page 12)

Defining attribute mapping
The first step in retrieving requirements from Rational Change is to define which 
Rational Change attributes you want to retrieve and to define the corresponding 
Rational DOORS attributes where the values are to be transferred.
To define attribute mappings:

1. In Rational DOORS, open the module for which you want to define 
attributes.

2. On the main menu, select Change Management > Retrieve 
Requirements from Rational Change > Define Attribute Mapping.

3. Under DOORS Attribute, select one of the Rational DOORS attributes 
listed.

4. Click Edit.
5. In CR Attributes, click to select the Rational Change CR attribute you want 

mapped to the Rational DOORS attribute you selected.

6. Click Close.

If you do not select a Rational Change CR attribute before clicking Close, no 
mapping is created. This method can also be used to remove existing 
mappings.

7. Repeat the above steps for each Rational DOORS attribute you want to map.

8. When you have finished mapping attributes, click OK to save the changes and 
to close the dialog box.
IBM® Rational® Change for DOORS® Interface User’s Guide 11
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Obtaining Rational Change data
The second step in importing requirements from Rational Change into Rational 
DOORS is to obtain the data from Rational Change. Complete the following 
steps to obtain Rational Change data:

• Obtain requirements from Rational Change. See Obtaining requirements 
(page 12).

• Save the selected option (optional). See Saving selected options (page 14).

• Load the previously saved options (optional). See Loading saved options 
(page 14).

Obtaining requirements
To obtain requirements from Rational Change:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Retrieve 
Requirements from Rational Change > Get Requirements.

3. To the right of Query String, click Select.
4. In either the Shared Queries or Saved Queries section, click a query to 

select it.
12 IBM® Rational® Change for DOORS® Interface User’s Guide



Obtaining Rational Change data
5. In the Insertion Point section, select one of the following options to tell the 
system where to insert the Rational DOORS objects that are created by the 
get requirements operation:

• Top of module—places all new objects at the top of the current 
module.

• After current object—places all new requirements after the current 
object at the same level of the hierarchy.

• Below current object—places all new requirements below the current 
object in the hierarchy.

6. In the Processed CR Action section, select one of the following options:

• Ignore Processed (or Existing) CRs—any CR that has already been 
imported into the current module is ignored. Change requests that have 
not yet been imported are retrieved.

• Update Processed (or Existing) CRs—the Rational DOORS object 
representing any CR that has already been processed is updated from 
Rational Change with the current values of the CR attributes. Change 
requests that have not yet been imported are retrieved.

7. In the Sort Order section, select a sort order (optional).

Choosing a sort order creates a hierarchy of objects in Rational DOORS, 
with each possible value of the CR attribute being represented by a Rational 
DOORS object, and with each CR that contains that value falling beneath it. 
You can select up to four sort attributes. Each attribute selected adds 
another level to the hierarchy.
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8. Click Import to begin the import process.

The following figure shows the results of an import with severity and 
request_type selected as sorting attributes.

Saving selected options
To save all of the options you selected on the Get Requirements from Rational 
Change - DOORS dialog box:

1. Click Save Options.

2. Click Browse to choose a path and filename.

3. Click Save.

Loading saved options
Performing the following step allows you to load the options you saved in the 
previous set of steps.
To load previously saved options for the Get Requirements from Rational 
Change - DOORS dialog box:

1. Click Load Options.

2. Type the file name, or browse to the file containing your saved options.

3. Click Load.
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4 Requirements Change Management
This chapter describes how to use the Rational Change for DOORS Interface to 
manage requirement changes. Using the interface allows you to do the following:

• Submit RCRs.

• Select a default RCR on which to work.

• Propose changes to requirements.

• Have the requirements automatically associated with the default RCR.

• Review RCRs.

• Apply RCRs.

Requirements change management using the Rational Change for DOORS 
Interface is centered around an RCR. This request contains a description of the 
change and other associated information such as priority, product name, reviewer 
comments, and the user name of the person assigned to make the requirement 
changes. This CR is assigned to a single requirement engineer, who then uses 
Rational DOORS to propose changes to one or more requirements. 

Proposed changes are automatically associated with the RCR that the engineer is 
currently working on. After the requirement engineer completes the CR, it is 
reviewed by one or more people. If the CR is approved, the proposed changes can 
be applied to the Rational DOORS document.

You can also choose to use the system CR lifecycle that is included with the 
Rational Change for DOORS Interface to manage your requirements changes. 
The system CR lifecycle is designed for end users to submit requests for changes 
they want made to a system. The system CR is then broken down into one or 
more RCRs, and potentially into one or more implementation requests.

The Rational Change for DOORS Interface can track the following types of 
changes to your Rational DOORS document:

• Adding one or more objects in any structure.

• Modifying objects.

• Adding or removing outgoing links to an object.

• Deleting objects or object hierarchies.

• Relocating objects within a module.
IBM® Rational® Change for DOORS® Interface User’s Guide 15



Chapter 4: Requirements Change Management
To enforce that all changes made to a module are associated with an RCR, the 
Rational Change for DOORS Interface requires that the user select a default 
RCR whenever a module is opened for editing.

The following sections contain information about using the Rational Change for 
DOORS Interface change management operations:

• Submitting requirements change requests (page 17)

• Opening modules (page 18)

• Selecting default requirements change requests (page 19)

• Proposing changes to Rational DOORS documents (page 20)

• Entering change comments (page 21)

• Undoing changes (page 21)

• Sending requirements change requests to review (page 22)

• Reviewing requirements change requests (page 23)

• Reviewing several requirements change requests simultaneously (page 25)

• Requirements Change Request report (page 27)

• Showing requirements change requests (page 28)

• Applying requirements change requests (page 28)

• Conflict detection and resolution feature (page 30)

• Viewing requirements change request information in Rational DOORS 
(page 35)

• Managing changes to Rational DOORS Analyst Add On modules (page 36)
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Submitting requirements change requests
The starting point for requirements change management is to submit an RCR. 
There are two ways to submit an RCR:

• With system change request lifecycle (page 17)

• Without system change request lifecycle (page 17)

With system change request lifecycle
If you are using the system CR lifecycle, follow these steps to submit an RCR:

1. Log on to Rational Change, and then display the system CR on which you 
want to work.

2. Click Submit Requirements CR, and then type the required information.

In the standard lifecycle, the Submit Requirements CR link is available 
only when the system CR is in the Requirements Change state.

3. Click Submit Requirements CR.

Without system change request lifecycle
If you are not using the system CR lifecycle, you can submit an RCR through the 
standard Rational Change submit mechanism, or you can use the following steps 
to submit the RCR from Rational DOORS:

1. In the Rational DOORS module view, on the main menu, select Change 
Management > Requirements Change Request > Submit.

2. Complete all applicable fields on the submit form, and then click Submit 
RCR.
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Opening modules
If you have already selected a default RCR in another module, that selection is 
used and you will not be prompted to select a new one. However, if you have not 
selected a default RCR, when you open a module that has been configured to use 
requirements change management, you are prompted to select a default RCR.
When prompted to select a default RCR when opening a module, you have three 
options:

1. Select an RCR from the list, and then click OK to propose changes to the 
module.

2. Do one of the following:

• Click Open for Unmanaged Changes, and then edit the attributes that 
are not controlled by requirements change management. Also, the 
system displays a list of the modifiable attributes. 

Caution Any changes you make to attributes that are not on this list are 
discarded when you open the module in this way.

• Click Open in Read-Only mode, and then open the module for 
reading without selecting a default RCR.
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Selecting default requirements change requests
All changes made to a document, with the exception of unmanaged attributes, go 
through a formal review and approval process. When using requirements change 
management, all changes to requirements must be associated with an RCR. This 
allows you to track a set of changes made throughout this process.
When you select a default RCR, you are choosing to automatically associate any 
proposed changes to objects in the current Rational DOORS module with that 
CR.
To select a default RCR:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > Select Default.
The Select Default RCR - DOORS dialog box opens, and the default RCR 
that is already selected is highlighted.

3. In CR Number & Synopsis, click to select the RCR you want to work on.

In the default lifecycle, only RCRs that are assigned to you are included in 
the list. If there are no RCRs listed, then, in Rational Change, assign one to 
yourself.
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4. Click OK.
The default requirements Rational Change request is displayed in the lower 
right corner of the Rational DOORS module window.

Proposing changes to Rational DOORS documents
This section describes how to propose changes to a Rational DOORS document 
using the Rational Change for DOORS Interface. This process is also referred to 
as “recording changes.”
To propose changes to a Rational DOORS document:

1. Make the changes in Rational DOORS as you normally would. 

The modifications can include modifying objects, adding new objects, 
deleting objects, moving objects, adding links, and deleting links.

2. When you have finished your modifications, in Rational DOORS, click Save.
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Entering change comments
This section describes how to enter a comment for changes you have made to a 
Rational DOORS object. This operation can only be done after you have saved 
your changes.
To enter a change comment:

1. In Rational DOORS, open the applicable module.

2. Right click the Rational DOORS object you modified, and then select 
Requirements Change Request > Enter Change Comment.

3. Type a comment, and then click OK.

Undoing changes
Sometimes you will need to undo a change. For example, you changed the wrong 
item, and you need to resolve a conflict with another proposed change. Or you 
changed your mind about how something was written, and you want to start 
again from the original document.
This section describes how to undo a change you have made.

Unsaved changes

If you have not yet entered a comment and have not clicked OK or you have not 
saved the Rational DOORS module, close the module.
All changes that you made in that session are undone.

Saved changes

If you have already saved your changes:

1. Right click the object that contains the changes you want to undo, and then 
select Requirements Change Request > Undo Change.

2. Click Confirm to undo your change.

Note  This operation is not supported for IBM® Rational® 
DOORS® Analyst Add On modules.

Rational DOORS Analyst Add On modules

If you are using Rational DOORS Analyst Add On modules, reject the RCR.
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Sending requirements change requests to review
Once you have finished proposing changes to fulfill an RCR, that CR should be 
sent to review so a decision can be made as to whether the changes should be 
applied to the document.
To send an RCR to review:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > Send RCR to Review.

3. Click Confirm to send the RCR to review.

All open modules that are in the edit and shared edit modes are closed. Click 
Yes to reopen them.
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Reviewing requirements change requests
Once an RCR has been sent to review, it can be reviewed to determine whether 
the changes are acceptable and to identify the impact of making those changes.
The RCR review feature now displays added objects as they will be displayed 
when the RCR is applied. As a consequence of this change, reviewing an RCR 
now requires the user to open the module in the exclusive edit mode.
To review an RCR:

1. In Rational DOORS, open the applicable module.

2. Select Change Management > Requirements Change Request > 
Review.

The Select a RCR to Review - DOORS dialog box opens and shows a list 
of all modules affected by each RCR is located in the second column.

3. Decide the types of RCRs you want to include when searching for conflicts.

4. Select the RCR you want to review.

In the default lifecycle, the list contains only those RCRs in the review state 
that have your user name in one of the reviewer fields.
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5. Click OK.

6. Click Close.

A new view is created in Rational DOORS as shown in the following figure. 
This view shows the proposed changes associated with the selected RCR and 
is filtered to include only those objects that are affected by the RCR. The 
view also contains a details column that shows any conflicts that might be 
present within the RCR. For more information on conflicts, see Conflict 
detection and resolution feature (page 30).
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Reviewing several requirements change requests simultaneously
Simultaneously reviewing several RCRs allows you to determine how a group of 
changes will look together. It also allows you to identify conflicts or 
inconsistencies.
To simultaneously review several RCRs:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > Display multiple RCRs.

3. To select RCRs that are still being worked on, select Also show assigned 
RCRs, and then click Refresh CR List.

4. Select the RCRs you want to review.
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5. Click OK.
A new view is created that shows the changes that will be made by the RCRs. 
Also included are details about the RCRs, such as who made the changes, 
when they were made, and any comments.
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Requirements Change Request report
The RCR report contains the following information from the Rational Change 
and Rational DOOS systems:
Rational Change
• All attribute values selected in the Select Rational Change RCR 

Attributes - DOORS dialog box, which you select when you generate the 
report.

• Attached file names, sizes, and dates.

Rational DOORS
• Changes for any modified attributes that are under Rational Change control 

in all the impacted DOORS modules associated with the RCR.

• The Object Heading and Object Text attribute values of Objects that were 
affected by the RCR. The redline differences are also shown.

• All modified, added, deleted, or moved Object IDs and their associated 
DOORS module name.

• All changes made to the DOORS links, including new and deleted links and 
identifiable before and after link information.

• The before and after values of object linking and embedded (OLE) objects.

Generating the Requirements Change Request report
To generate the RCR report:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > Create RCR Report.
The RCRs for This Module - DOORS dialog box opens and displays all 
RCRs associated with the DOORS module from which the report was 
generated.

3. In the RCRs for This Module - DOORS dialog box, select the RCR from 
which you want to generate the report.

The Select Rational Change RCR Attributes - DOORS dialog box opens 
and displays all reportable Rational Change attributes.

4. Select all attributes that you want to include in the report, and then click 
Apply to generate the report.
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Showing requirements change requests
There are several ways to locate RCRs, including querying from Rational Change, 
following a link from a related system CR, or from within Rational DOORS. This 
section describes how to identify RCRs that are associated with proposed 
changes to the current module.
To show RCRs with proposed changes to the current module:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > Show for this Module.

3. In CR Number & Synopsis, click to select the RCR you want to see.

4. Click Show, and then review the RCR.

5. Repeat the above steps to show other RCRs.

6. Click OK or Close to close the dialog box.

Applying requirements change requests
When proposals have been approved, the Rational Change for DOORS Interface 
allows you to apply the proposed changes to the Rational DOORS module.
To apply the approved changes:

1. In Rational DOORS, open the applicable module in read-only mode.

2. On the main menu, select Change Management > Requirements 
Change Request > Apply.

The Apply Requirements Change Requests - DOORS dialog box opens 
and displays every approved RCR for the current module.

3. Select individual RCRs to view or apply.

To create a baseline of your Rational DOORS document after the apply has 
finished, select Also create baseline after apply.
28 IBM® Rational® Change for DOORS® Interface User’s Guide



Applying requirements change requests
Apply button option
When you click Apply, the module is reopened in edit mode without requiring 
that you select a default RCR. Then, the Rational Change for DOORS Interface 
automatically checks all approved RCRs for conflicts.

• If conflicts are found, the apply process is cancelled and the approved 
changes are not applied. The reason is written to a status log.

• If no conflicts are found, the apply process is completed. Then, the interface 
checks all non-approved RCRs associated with the modules that were affected 
by the applied RCR. If there are any conflicts, the interface marks all non-
approved RCRs with conflicts as obsolete.

For example, applied RCR 1 is checked against three non-approved RCRs—RCR 2, 
RCR 3, and RCR 4. The system identifies a conflict with RCR 3, and RCR 3 is 
marked obsolete.

When you open a module associated with RCR 3 and RCR 3 is the default RCR, 
the Conflict Resolution for RCR - DOORS dialog box opens. Then, you 
resolve the conflict. See Resolving conflicts (page 32).
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Conflict detection and resolution feature
The Rational Change for DOORS Interface automatically detects most conflicts 
during the review and apply states. During review, conflicts are detected only within 
a single RCR. During apply, conflicts are detected on all approved RCRs.
When the Rational Change for DOORS Interface checks for conflicts, one of the 
following can happen, depending on how the template was configures. See 
“Interface Configuration: Defining configuration templates” in the IBM Rational 
Change for DOORS Interface Administration Guide.

• Warns you when you are modifying attributes that already have outstanding 
proposed changes.

• Prevents approval of RCRs that conflict with already approved RCRs.

• Helps you identify and resolve conflicts when working on an RCR that is 
marked obsolete. See Resolving conflicts (page 32).

Conflict examples
The following are some examples of conflicts:

• Two or more proposals were made against the same object or module. These 
proposals might clash with each other or be order dependent.

• Multiple RCRs were approved against the same object and the change type is 
Delete on any of the RCRs.

• The Rational DOORS attributes were changed by the RCR overlap.

• Two RCRs were approved to change the object text of a requirement. If both 
were applied without revision, the second one applied would overwrite the 
first. Similarly, one CR might request a child object to be added to 
requirement X while another requests that requirement X should be deleted. 
If the latter is applied, the former should not be applied.

• Not all changes were made using the Rational Change for DOORS Interface. 
The interface cannot detect manual changes. For example, an RCR might 
have been submitted against a requirement. Before the CR was applied, 
someone manually modified the requirement without using the interface. In 
this case, when the CR is applied, it could overwrite the other change because 
the two are unrelated.

The system, however, cannot detect all conflicts, so they need to be inspected 
manually to evaluate the semantics of the change. See Resolving conflicts (page 
32). Use the RCR Conflicts Report to identify the conflicts the system cannot 
detect. See Running the RCR Conflicts Report (page 31).
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Running the RCR Conflicts Report
The Rational Change for DOORS Interface allows you to run a report, at any 
time, to detect conflicts for a single RCR, or for an entire module.
To run the RCR Conflicts Report:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > RCR Conflicts Report.

3. Choose whether you want to see conflicts for all RCRs that affect the 
module, or only for a specific RCR.

4. Choose the types of RCRs you want to include when detecting conflicts. For 
example, select All approved RCRs.
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5. Choose a report format.

• Grouping by object—to show conflicts for the same Rational DOORS 
objects together.

• Grouping by RCR—to show conflicts for the same RCR together.
• Grouping by conflict—to show conflicts of the same type together.

6. Click Generate Conflicts Report.
The Conflicts Report - DOORS dialog box opens and displays the report 
results.

Resolving conflicts
When conflicts are found, they must be resolved manually, which is done by 
either rejecting one of the RCRs, or by rejecting one of the proposed changes 
from the conflicting RCR. Usually the person who proposed the changes or the 
person who is responsible for the entire document resolves the conflicts.

Caution  Be careful when rejecting individual proposed changes 
from an RCR. If there are interdependencies between 
proposals and only some of the proposals are rejected, an 
RCR might be rendered invalid. For example, if the RCR 
proposes to create a hierarchy of new Rational DOORS 
objects and the proposal to create the topmost object is 
rejected, the other objects no longer have a parent object, 
and the RCR is invalid.

When a module is opened in exclusive or sharable edit mode and the default 
RCR is marked obsolete, the Rational Change for DOORS Interface displays the 
Conflict Resolution for RCR - DOORS dialog box.
For more detailed information about how RCRs are marked obsolete, see Apply 
button option (page 29).
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The interface offers several options to resolve RCR conflicts.
At anytime, click Navigate to Selected Object to view the exact object within 
the module.
To resolve an RCR conflict:

1. In Objects with Conflict, review the objects that have conflicts.

2. In Object Attributes with Conflicts, individually select each attribute to 
view the details.

When you click an item in this section, the conflict results display in the 
Original Value, Current Value, and Proposed Value fields. You will 
resolve these one at a time.

3. Review the following sections:

• Original Value—displays, prior to any changes, the attribute value.
• Current Value—displays the current attribute value that is in the 

Rational DOORS database.
• Proposed Value—displays your proposed values for that attribute.
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4. In Format, in the Proposed Value section, select from the following 
options:

• Proposed Value—displays the proposed value as it is displayed in 
Rational DOORS.

• Difference with Original—displays the proposed value with redline 
differences against the original value.

• Difference with Current—displays the proposed value with redline 
differences against the current value.

5. If you need to edit the information in Proposed Value:
a. Click Edit to activate the Update and Cancel options so that you can 

make your edits.

b. Click Update to update the object with the conflict.

To undo the edits, click Cancel.
6. Determine how to resolve the conflict, and then do one of the following:

• To keep the proposed edits and allow your changes to overwrite the 
values in the database, click Keep Proposed.

The attribute value stays as is, with your changes.

• To discard your changes and keep the database values, click Discard 
Proposed.

The proposed values are replaced with the attribute current values.

• To override the conflict and make the RCR active, in Objects with 
Conflicts, select all objects, and then click Finish Conflict Resolution 
to clear the obsolete flag.

The Finish Conflict Resolution option becomes active after the 
resolved box is checked for each object. It also becomes active when all 
objects with conflicts have been resolved.

7. Click Close.

8. In Rational DOORS, save the module.

If you have discarded any proposed changes, the Rational DOORS module 
closes.
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Viewing requirements change request information in Rational 
DOORS

The Rational Change for DOORS Interface can create and maintain a view in 
Rational DOORS that shows information about the RCR associated with each 
object in a Rational DOORS module.
This view is described in the following sections:

• Customizing requirements change request attributes (page 35)

• Syncing the requirements change request Attrs View (page 36)

Customizing requirements change request attributes
When you customize the RCR attributes, you can select the RCR attributes you 
want to view in Rational DOORS.
To customize RCR attributes:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > Customize RCR Attributes.

The Custom Rational Change RCR Attributes - DOORS dialog box 
opens and displays a list of all the attributes defined in your Rational Change 
process and the name of the Rational DOORS attribute that will be created 
if you choose to display that attribute.

3. In RCR Attribute, click to select the attributes you want to be visible inside 
Rational DOORS.

4. If applicable, click Edit DOORS Attribute Name to modify the name of 
the Rational DOORS attribute.

5. To view information about previously applied RCRs, select Include 
Applied Requirements Change Requests.

By default, information about previously applied RCRs is not displayed. 

6. Click Apply.

The attributes you selected are created in your Rational DOORS module.

7. Use the Rational DOORS Insert > Column menu to add the wanted 
attributes to your view.

The interface creates a view for you named RCR Attrs View. This view 
contains a default set of attributes. 
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Syncing the requirements change request Attrs View
The RCR Attrs View option retrieves the current information from the Rational 
Change database and refreshes the Rational Change attributes you are viewing.
To sync the requirements CR Attrs View:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Requirements 
Change Request > Sync Requirements Change Requests.

Managing changes to Rational DOORS Analyst Add On modules
The requirements change management features of the Rational Change for 
DOORS Interface can be used to manage changes to the Rational DOORS 
Analyst Add On modules. To use the interface in this way, you should be aware of 
some special considerations and differences in behavior. Also see Synchronizing 
all modules (page 50).

• The module must be initialized for the Rational DOORS Analyst Add On 
before requirements change management is enabled.

• You might be required to merge your UML Model in the Rational DOORS 
Analyst Add On. This can happen in the following situations:

• An RCR is applied to a module that has other RCRs actively being 
worked on.

• You are applying multiple RCRs that might be conflicting in a single 
module.
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5 Implementing Requirements
Sometimes you need to trace the current status of requirements during product 
development. Using the Rational Change for DOORS Interface, you can create 
new CRs or associate existing CRs with requirements. Then, you can trace the 
module requirements through the implementation process.
You can also view the status of a requirement associated CRs and run an activity 
report to view the requirements and CRs for a module.
This chapter contains information about the Rational Change for DOORS 
Interface traceability operations:

• Tracing the implementation of requirements (page 37)

• Using administrative operations (page 39)

• Using the requirements implementation operations (page 42)

For details about using Rational Change, see the Rational Change Help.

Tracing the implementation of requirements
After a CR is submitted against a requirement, Rational Change can track the 
details of the changes made to the requirement, such as who submitted the CR 
and why.
You can also use Rational Change to notify users when the status of the CR is 
modified, such as when the request is assigned, resolved, or deferred. See the 
Rational Change Help for more information.
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When you run the Rational Change for DOORS Interface, the interface shows 
the CR number and the CR status for each requirement. This information is 
shown on a Rational DOORS view, named IR Attrs View, which is created by 
the interface. By default, these attributes are labeled csint_ir_crstatus, 
csint_ir_problem_number and csint_ir_problem_synopsis, as shown in the 
following figure.

For information about adding and removing attributes or changing their labels, 
see Customizing IR attributes (page 39).
You can submit a new CR for a requirement, or you can associate one or more 
existing CRs with a requirement. Also, at any time, you can synchronize one or 
more requirements with one or more CRs to update the Rational DOORS view 
with the latest Rational Change information.
The sync operation updates Rational DOORS with Rational Change 
information. Therefore, if you enter a CR ID directly into the Implementation 
Request column, it is no longer listed after you run a sync operation.
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Using administrative operations
This section discusses the operations available for administering the 
requirements implementation portion of the Rational Change for DOORS 
Interface. All users can perform these operations.

• Customizing IR attributes (page 39)

• Adding or removing attributes, or changing labels (page 40)

Customizing IR attributes
From the Rational DOORS Formal module, you can choose the CR attributes 
that are included in the IR Attrs View. You can also change the labels used for 
these attributes.
For example, the crstatus, problem_number and the problem_synopsis 
attributes are included by default in the IR Attrs View and are labeled 
csint_ir_status, csint_problem_number, and csint_problem_synopsis 
respectively. See the figure below for an example.
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If you were to add the release attribute to the Rational Change for DOORS 
Interface view and label the value Implementation Request Release, the 
following view opens.

Adding or removing attributes, or changing labels
To add or remove an attribute, or to change its label:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Customize IR 
Attributes.
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3. In IR Attribute, do one of the following:

• To add an attribute, select the attribute check box.
• To remove an attribute, clear the attribute check box.
• To change the name of the Rational DOORS attribute that is included in 

the Rational Change data:
a. Click the attribute row to highlight it.

b. Click Edit DOORS Attribute Name.

c. In DOORS Attribute Name, type the new attribute name, in 
the format shown in the figure below, and then click Apply.

4. In the Custom Change IR Attributes - DOORS dialog box, click Apply.

5. If you have added attributes, use Insert > Column to insert them into your 
view.

6. On the main menu, select Change Management > Sync Implementation 
Requests.

The new attributes columns are updated with the Rational Change values.
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Using the requirements implementation operations
This section shows the operations available for tracing the status of requirements. 

Note  Before performing any operations, you must enable the 
Requirements Implementation option from within the 
configuration dialog box.

The following sections explain how to use the requirement-specific traceability 
operations:

• Submitting change requests to fulfill requirements (page 43)

• Submitting change requests when requirements change management is 
enabled (page 44)

• Showing change requests (page 45)

• Generating activity reports (page 47)

• Adding one or more existing change requests (page 48)

• Removing one or more change requests (page 48)

• Synchronizing one requirement (page 49)

• Synchronizing all requirements (page 49)
42 IBM® Rational® Change for DOORS® Interface User’s Guide



Using the requirements implementation operations
Submitting change requests to fulfill requirements
You can submit a CR that will be used to fulfill a requirement.
To submit a CR to fulfill a requirement:

1. In Rational DOORS, open the applicable module.

2. Right-click the requirement.

If you need to select more than one requirement, use shift+left-click to 
select multiple items. Only a single CR is submitted.

Note  When using this feature, be aware that all child 
requirements of the selected requirements are included 
in the CR, even if your view does not show them.

3. On the pop-up menu, select Implementation Request > Submit.
If you have requirements change management enabled, and there has been at 
least one RCR applied to the selected requirement, see Submitting change 
requests when requirements change management is enabled (page 44).

4. If prompted, select a submit form, and then click Load.

5. In the Change Request Submission page, type or select information for 
the CR, and then click Submit IR.

In the Rational DOORS Formal module window, the Implementation 
Request Status column shows that the requirement status is submitting.

For descriptions of the fields, click the More Info link on the Rational 
Change submit form.

6. Right-click the requirement, and then select Implementation Request > 
Sync. 

The Rational Change for DOORS Interface updates the Rational Change 
CR attribute columns for the selected requirement. Also, you can submit or 
add multiple CRs to a requirement.

For more information, see Synchronizing one requirement (page 49).
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Submitting change requests when requirements change management is enabled
This section describes the extra steps required to submit a CR when 
requirements change management is enabled. These steps are only applicable 
when at least one RCR has been applied to the selected requirement.
Performing these extra steps:

• Ensures that the implementation request addresses all of the appropriate 
changes made by a given RCR.

• Allows the interface to automatically associate your newly created 
implementation request with both the selected RCR and its parent system 
CR, if one exists.

1. Follow steps 1 and 2 in Submitting change requests to fulfill requirements 
(page 43).

A dialog box listing all of the RCRs that have been applied to the selected 
requirement opens.

2. Select the RCR you are implementing, and then click OK.

3. Select one or more requirements from the list, shown in the following figure, 
and then click OK.
The Rational Change submit form opens and displays those requirements 
that were modified by the RCR selected in step 1 of this procedure.

4. Continue with step 3 in Submitting change requests to fulfill requirements 
(page 43).
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Showing change requests
In Rational Change, you can show the CRs that are related to a requirement. This 
allows you to use the Rational Change show form to view all information 
contained in the CR.
To show a CR:

1. In Rational DOORS, open the applicable module, and then right-click the 
requirement.

2. On the pop-up menu, select Implementation Request > Show.

If only one CR is associated with the requirement, the Change Request 
Information - DOORS dialog box opens.
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If multiple CRs are associated with the requirement, an interim dialog box 
displays all of the CRs for the requirement. Click a listed CR ID to view the 
CR in the Change Request Information - DOORS dialog box.
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Generating activity reports
You can generate an activity report that shows all the of the module 
requirements and their associated implementation requests.
To generate an activity report:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Show Activity Report.
The Rational Change for DOORS Interface generates the report in the 
background, and the report opens when it is completed. The following is a 
sample default report.
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Adding one or more existing change requests
You can add one or more existing CRs to one or more Rational DOORS 
requirements by specifying their CR IDs.
If you do not know the CR IDs, you can query the Rational Change database for 
them. For more information, see the Rational Change Help.
To add one or more CRs to one or more Rational DOORS requirements:

1. In Rational DOORS, open the applicable module.

2. Right-click the requirement, or shift-click multiple, contiguous requirement 
objects.

3. On the pop-up menu, select Implementation Request > Add.

4. In Add Implementation Request ID, type one or more CR IDs. Separate 
multiple entries with commas.

5. Click OK.

The Rational Change for DOORS Interface adds the CR IDs to the 
requirements and updates all Rational Change CR attribute columns.

Removing one or more change requests
You can remove one or more CRs from one or more Rational DOORS 
requirements by specifying their CR IDs.
If you do not know the CR IDs, you can query the Rational Change database for 
them. For more information, see the Rational Change Help.
To remove one or more CRs from one or more Rational DOORS requirements:

1. In Rational DOORS, open the applicable module.

2. Right-click the requirement, or shift-click multiple, contiguous requirement 
objects.

3. On the pop-up menu, select Implementation Request > Remove.

4. In Remove Implementation Request, type one or more CR IDs. Separate 
multiple entries with commas.

5. Click OK.

The Rational Change for DOORS Interface removes the CRs from the 
requirements and updates all Rational Change CR attribute columns.
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Synchronizing one requirement
You can synchronize all CRs in the Rational Change database associated with a 
Rational DOORS requirement in a module. This operation queries the Rational 
Change database to find all CRs associated with the requirement and updates all 
the requirement Rational Change CR attribute columns. The operation also 
updates the Rational DOORS requirement data stored in Rational Change for 
the selected requirement.
To synchronize the CRs for a single requirement:

1. In Rational DOORS, open the applicable module, and then right-click the 
requirement.

2. On the pop-up menu, select Implementation Request > Sync.

The Rational Change for DOORS Interface updates the values in all 
Rational Change CR attribute columns for the selected requirement. Also, 
this operation synchronizes all objects that are currently selected in Rational 
DOORS.

Synchronizing all requirements
You can synchronize all CRs in the Rational Change database with all Rational 
DOORS requirements in a module. This operation queries the Rational Change 
database to find all CRs associated with all the module requirements, and then 
updates all Rational Change CR attribute columns for all requirements in the 
module. The operation also updates Rational DOORS object data stored in 
Rational Change.
To synchronize all requirements in a module:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Change Management > Sync Implementation 
Requests.

The Rational Change for DOORS Interface updates the values in all 
Rational Change CR attribute columns for all requirements in the module.
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Synchronizing all modules
You can synchronize all modules in the Rational Change database with all 
Rational DOORS requirements in a module. This operation syncs all 
implementation requests (IRs) and RCRs for all modules in the Rational DOORS 
database that are configured to use the Rational Change for DOORS Interface. 
The operation also updates Rational DOORS object data stored in Rational 
Change.
To synchronize all modules:

1. In Rational DOORS, open the applicable module.

2. On the main menu, select Rational Change Interface > Sync All 
Modules.

The Rational Change for DOORS Interface updates the values in all Rational 
Change IR and RCRs attribute columns for all requirements in all modules.
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Appendix: Notices
This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right may 
be used instead. However, it is the user's responsibility to evaluate and verify the 
operation of any non-IBM product, program, or service. 
IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to: 

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A. 

For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send 
written inquiries to: 

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom or any 
other country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. 
Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 
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This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 
IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you. 
Licensees of this program who wish to have information about it for the purpose 
of enabling: (i) the exchange of information between independently created 
programs and other programs (including this one) and (ii) the mutual use of the 
information which has been exchanged, should contact: 

Intellectual Property Dept. for Rational Software
IBM Corporation
1 Rogers Street
Cambridge, Massachusetts 02142
U.S.A.

Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee. 
The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 
Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments 
may vary significantly. Some measurements may have been made on 
development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some 
measurements may have been estimated through extrapolation. Actual results 
may vary. Users of this document should verify the applicable data for their 
specific environment. 
Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
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Trademarks
performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products.
This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
fictitious and any similarity to the names and addresses used by an actual 
business enterprise is entirely coincidental. 
If you are viewing this information in softcopy format, the photographs and 
color illustrations may not be included. 

Trademarks

IBM, the IBM logo, ibm.com, Rational, Rational Change, Rational DOORS, and 
Rational DOORS Analyst Add On are trademarks or registered trademarks of 
International Business Machines Corporation in the United States, other 
countries, or both. These and other IBM trademarked terms are marked on their 
first occurrence in this information with the appropriate symbol (® or ™), 
indicating US registered or common law trademarks owned by IBM at the time 
this information was published. Such trademarks may also be registered or 
common law trademarks in other countries. A current list of IBM trademarks is 
available on the Web at www.ibm.com/legal/copytrade.html.
Other company, product or service names may be trademarks or service marks 
of others.
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installing, 9
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mapping attributes, 11
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R
Rational Change

obtaining data, 12
obtaining requirements, 12

Rational DOORS
mapping attributes with CS, 11
proposing changes, 20

Rational DOORS Analyst Add On
managing changes, 36
undoing changes, 21

RCR Conflicts Report, 31
RCR see Requirements Change Requests
recording changes, 20
relabeling attributes, 40
removing attributes, 40
reports

activity, 47
RCR Conflicts, 31
Requirements Change Request, 27

requirements
adding change requests, 48
change in status, 37
obtaining, 12
removing change requests, 48
showing change requests, 45
submitting change requests, 43
synchronizing all, 49
synchronizing one, 49
tracing, 37

Requirements Change Request
apply button, 29
applying, 28
customizing attributes, 35
locating, 28
report, 27
reviewing, 23
selecting defaults, 19
sending to review, 22
showing, 28
simultaneously reviewing, 25
Status View, updating, 36
submitting, 17
viewing information about in Rational 

DOORS, 35
requirement-specific traceability 

operations, 42

S
synchronizing

all modules, 50
all requirements, 49
one requirement, 49

T
tracing implementation of requirements, 

37

U
undoing changes

Rational DOORS Analyst Add On, 
modules, 21

recorded, 21
unrecorded, 21
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