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Introduction 
About the integration 
The IBM Rational Change for Eclipse Interface  gives you the ability to work with change requests from IBM 
Rational Change using the Mylyn within Eclipse. 

Assumptions 
Before using this document, you should have a basic understanding of how to use Mylyn and IBM Rational 
Change. If you are unfamiliar with Mylyn, IBM recommends that you to read the Mylyn documentation 
located on http://eclipse.org/mylyn/start/ 

For more information about Eclipse, go to:  http://www.eclipse.org/ 

You should also have a conceptual and practical understanding of IBM Rational Change.  

If you need more information about IBM Rational Change, refer to the following documentation, which is 
available on the IBM support Web site at http://www.ibm.com/software/support/ 

IBM recommends that you read this entire document before using the integration. Knowing all of the features 
before you integrate your data helps ensure a seamless, efficient integration. 

Features 
The integration allows you to query for and IBM Rational Change CRs as Mylyn tasks. The integration also 
includes full support for attaching files and the Mylyn task context to the CR. 

Audience 
The IBM Rational Change for Eclipse and Subversion Interface is for developers using Eclipse with Mylyn as 
their development environment and Subversion as their configuration management tool 

 

Notices 
© Copyright IBM Corporation 2007, 2009 

U.S. Government Users Restricted Rights – Use, duplication, or disclosure restricted by GSA ASP Schedule 
Contract with IBM Corp. 

This information was developed for products and services offered in the U.S.A. IBM may not offer the 
products, services, or features discussed in this document in other countries. Consult your local IBM 
representative for information on the products and services currently available in your area. Any reference to 
an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or 
service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM 
intellectual property right may be used instead. However, it is the user's responsibility to evaluate and verify 
the operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter described in this document. 
The furnishing of this document does not grant you any license to these patents. You can send written 
license inquiries to: 

IBM Director of Licensing  
IBM Corporation  
North Castle Drive  
Armonk, NY 10504-1785 
U.S.A. 

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual 
Property Department in your country or send written inquiries to: 

IBM World Trade Asia Corporation  



Licensing  
2-31 Roppongi 3-chome, Minato-ku  
Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom or any other country where such 
provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION “AS IS” 
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED 
TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes are periodically made 
to the information herein; these changes will be incorporated in new editions of the publication. IBM may 
make improvements and/or changes in the product(s) and/or the program(s) described in this publication at 
any time without notice. 

Any references in this information to non-IBM Web sites are provided for convenience only and do not in any 
manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of the 
materials for this IBM product and use of those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes appropriate without 
incurring any obligation to you.  

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the 
exchange of information between independently created programs and other programs (including this one) 
and (ii) the mutual use of the information which has been exchanged, should contact: 

Intellectual Property Dept. for Rational Software  
IBM Corporation  
1 Rogers Street Cambridge,  
Massachusetts 02142 
U.S.A. 

Such information may be available, subject to appropriate terms and conditions, including in some cases, 
payment of a fee.  

The licensed program described in this document and all licensed material available for it are provided by 
IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any 
equivalent agreement between us. 

Any performance data contained herein was determined in a controlled environment. Therefore, the results 
obtained in other operating environments may vary significantly. Some measurements may have been made 
on development-level systems and there is no guarantee that these measurements will be the same on 
generally available systems. Furthermore, some measurements may have been estimated through 
extrapolation. Actual results may vary. Users of this document should verify the applicable data for their 
specific environment. 

Information concerning non-IBM products was obtained from the suppliers of those products, their published 
announcements or other publicly available sources. IBM has not tested those products and cannot confirm 
the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on 
the capabilities of non-IBM products should be addressed to the suppliers of those products. 

This information contains examples of data and reports used in daily business operations. To illustrate them 
as completely as possible, the examples include the names of individuals, companies, brands, and products. 
All of these names are fictitious and any similarity to the names and addresses used by an actual business 
enterprise is entirely coincidental. 

If you are viewing this information softcopy, the photographs and color illustrations may not appear. 

Trademarks 
IBM, the IBM logo, ibm.com, Rational, Synergy, and Change are trademarks or registered trademarks of 
International Business Machines Corporation in the United States, other countries, or both. These and other 
IBM trademarked terms are marked on their first occurrence in this information with the appropriate symbol 
(® or ™), indicating US registered or common law trademarks owned by IBM at the time this information 



was published. Such trademarks may also be registered or common law trademarks in other countries. A 
current list of IBM trademarks is available on the Web at www.ibm.com/legal/copytrade.html. 

Eclipse is a trademark of the Eclipse Foundation, Inc., in the United States, other countries, or both. 

JDK, Java, JavaScript, Solaris, Sun, Sun Microsystems, OpenWindows, and all Java-based trademarks and 
logos are trademarks or registered trademarks of Sun Microsystems, Inc., in the United States, other 
countries, or both. 

Other company, product or service names mentioned may be trademarks or service marks of others. 

 



Product requirements 
The following products are required to run the IBM Rational Change for Eclipse Interface: 

• IBM Rational Change 5.1 or 5.2 

• Eclipse 3.4, Eclipse 3.5, or Rational Application Developer 7.5 

• Mylyn 3.1.1 or higher



Installation instructions 

Installing the integration 
Follow the steps below to install the integration: 

IBM Rational Update Site 
1. Start Eclipse 
2. Select Help -> Software Updates -> Find and Install… 
3. Choose Search for new features to install and click Next. 
4. Click New Remote Site and then type IBM Rational for the name and 

http://download.boulder.ibm.com/ibmdl/export/pub/software/rational/telelogic/eclipse for the 
URL. 

5. Click OK and then click Finish. 
6. Find IBM Rational Change for Eclipse Interface 1.1 in the list of available features, and then 

click the checkbox next to it. 
7. Click Next. 
8. Accept the license agreement, and then click Next. 
9. Click Finish. 
10. Click Install All. 
11. When prompted to restart Eclipse, click Yes. 

Local Installation 
1. Download the IBM Rational Change for Eclipse Interface 1.1 from the  IBM  Rational support 

website. 
2. Unzip the zip file to a temporary directory.  
3. Start Eclipse. 
4. Select Help -> Software Updates -> Find and Install… 
5. Choose Search for new features to install and then click Next. 
6. Click New Local Site and then browse to the temporary directory where you unzipped the files. 
7. Click OK and then click Finish. 
8. Find IBM Rational Change for Eclipse Interface 1.1 in the list of available features, and then 

click the checkbox next to it. 
9. Click Next. 
10. Accept the license agreement and then click Next. 
11. Click Finish. 
12. Click Install All. 
13. When prompted to restart Eclipse, click Yes. 



Getting started 

Setting up the Task Repository 
The first step to working with Mylyn is creating a task repository.  This repository represents a 
single IBM Rational Change database. 
To setup a task repository, follow these steps: 
 

1. In Eclipse, to open the Mylyn Task Repositories select Window -> Show View -> 
Other… and then choose the Mylyn Task Repositories View. 

2. In the Task Repositories view, click the Add Task Repository Menu . 
3. Select Change and click Next>. 
4. In Server, type the URL to your IBM Rational Change server. 
5. In Label, type a label for this Change database. 

This label will be displayed whenever you are looking at query results in the Mylyn 
interface, so you should choose a label that will make it clear which IBM Rational Change 
server and database you are accessing. 

6. Type your User ID and Password. 
7. Click the arrow next to Additional Settings. 
8. Click Get Parameters. 
9. Choose the correct Database and Role. 

You should select the database and role you normally use when you login to IBM 
Rational Change using your web browser. 

10. If you use a Proxy server when connecting to IBM Rational Change, enter the proxy 
server information. 

11. Click Finish. 
 

Configuring IBM Rational Change Queries 

Creating a new query 
After you have setup a IBM Rational Change task repository, the next step in the Mylyn setup 
process is setting up a query to find CRs you want to work with. 
To setup a query, follow these steps: 

• In Eclipse, select Window->Show View->Other… to open the Mylyn Task Repositories 
view, and then right click on the Change repository. 

• In the Task Repositories List view, right-click Change, and then choose New -> 
Query… 

• IBM Rational Query Wizard page is displayed. 
• If you want to manually write a IBM Rational Change query string, select Create query 

using free text field, and then click Next. 
a. Give your query a title, type the IBM Rational Change query string, and then click 

Finish. 
 

Stored Queries: 
 1. Select the IBM Rational Change repository you setup earlier, and then click Next 
 2. Select predefined query option, and select the query from the list box and click Finish. 
  



After you have created a query, CRs matching that query are automatically pulled into the Mylyn 
Task List view.  Working with Mylyn tasks is the same across all repository types.  For more 
information on how to work with Mylyn tasks, see the Mylyn documentation located on 
http://eclipse.org/mylyn/start/ 



Integrating with Subversion 
 
The IBM Rational Change for Eclipse Interface can be used together with the Subclipse or 
Subversive plugins for Eclipse to associate Subversion change-sets with CRs from IBM Rational 
Change.  When the IBM Rational Change for Eclipse Interface is installed and a CR is selected 
as the active task in Mylyn, the connector automatically adds a special comment anytime you 
commit changes through Subclipse or Subversive.  For example,  

ASSIGNED – task N#1: Submit and Assign a CR to demo  
http://localhost:8600/servlet/PTweb?ACTION_FLAG=frameset_form&TEM
PLATE_FLAG=ProblemReportView&database=\\qc9\ccmdb\base65&role=Use
r&problem_number=N#1 
 

The comment includes the Change Request number and a link to view the CR in IBM Rational 
Change.  This comment can also be used by vcindexer to display information about the change 
set in IBM Rational Change.  For more information on vcindexer and how to display Subversion 
change set information in IBM Rational Change, see the vcindexer documentation on the IBM 
support Web site. 
 

Contacting IBM Rational Software Support 
 
If the self-help resources have not provided a resolution to your problem, you can contact IBM® Rational® 
Software Support for assistance in resolving product issues. 
 

Note: If you are a heritage Telelogic customer, a single reference site for all support resources is 
located at http://www.ibm.com/software/rational/support/telelogic/ 

 

Prerequisites 
 
To submit your problem to IBM Rational Software Support, you must have an active Passport Advantage® 
software maintenance agreement. Passport Advantage is the IBM comprehensive software licensing and 
software maintenance (product upgrades and technical support) offering. You can enroll online in Passport 
Advantage from http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html 
 

• To learn more about Passport Advantage, visit the Passport Advantage FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.html. 

• For further assistance, contact your IBM representative. 
 
To submit your problem online (from the IBM Web site) to IBM Rational Software Support, you must 
additionally: 

• Be a registered user on the IBM Rational Software Support Web site. For details about registering, 
go to http://www.ibm.com/software/support/. 

• Be listed as an authorized caller in the service request tool. 
 

Submitting problems 
 
To submit your problem to IBM Rational Software Support: 
 



1. Determine the business impact of your problem. When you report a problem to IBM, you are asked to 
supply a severity level. Therefore, you need to understand and assess the business impact of the 
problem that you are reporting. 
 
Use the following table to determine the severity level. 

 
Severity Description 

1 
The problem has a critical business impact: You are unable to use 
the program, resulting in a critical impact on operations. This 
condition requires an immediate solution. 

2 This problem has a significant business impact: The program is 
usable, but it is severely limited. 

3 
The problem has some business impact: The program is usable, 
but less significant features (not critical to operations) are 
unavailable. 

4 
The problem has minimal business impact: The problem causes 
little impact on operations or a reasonable circumvention to the 
problem was implemented. 

 
 
2. Describe your problem and gather background information. When describing a problem to IBM, be as 

specific as possible. Include all relevant background information so that IBM Rational Software Support 
specialists can help you solve the problem efficiently. To save time, know the answers to these 
questions: 
• What software versions were you running when the problem occurred? 

To determine the exact product name and version, use the option applicable to you:  
o Start the IBM Installation Manager and select File > View Installed Packages. Expand a 

package group and select a package to see the package name and version number.  
o Start your product, and click Help > About to see the offering name and version number.  

• What is your operating system and version number (including any service packs or patches)?  
• Do you have logs, traces, and messages that are related to the problem symptoms?  
• Can you recreate the problem? If so, what steps do you perform to recreate the problem?  
• Did you make any changes to the system? For example, did you make changes to the hardware, 

operating system, networking software, or other system components?  
• Are you currently using a workaround for the problem? If so, be prepared to describe the 

workaround when you report the problem. 
3. Submit your problem to IBM Rational Software Support. You can submit your problem to IBM Rational 

Software Support in the following ways: 
• Online: Go to the IBM Rational Software Support Web site at 

https://www.ibm.com/software/rational/support/ and in the Rational support task navigator, click 
Open Service Request. Select the electronic problem reporting tool, and open a Problem 
Management Record (PMR), describing the problem accurately in your own words. 
 
For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html 
 
You can also open an online service request using the IBM Support Assistant. For more 
information, go to http://www.ibm.com/software/support/isa/faq.html. 

 
• By phone: For the phone number to call in your country or region, go to the IBM directory of 

worldwide contacts at http://www.ibm.com/planetwide/ and click the name of your country or 
geographic region.  

 
• Through your IBM Representative: If you cannot access IBM Rational Software Support online or 

by phone, contact your IBM Representative. If necessary, your IBM Representative can open a 
service request for you. You can find complete contact information for each country at 
http://www.ibm.com/planetwide/. 



 


