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Introduction 
 

Welcome to the IBM Rational® Change for HP Quality Center Interface™ 3.7. 

The IBM Rational Change for HP Quality Center Interface organizes the transfer of 
defect data between HP Quality Center and IBM Rational® Change™, enabling you 
to manage project defects using the most suitable tool for your needs.  

For example, if the development team uses IBM Rational Change and the quality 
assurance team uses HP Quality Center, the IBM Rational Change for HP Quality 
Center Interface enables the teams to integrate their projects so that they are both 
working with the same data. This means that the quality assurance team can use one 
tool to handle the testing process, while the development team can use its preferred 
change management tool. 

The IBM Rational Change for HP Quality Center Interface employs multiple transfer 
options to satisfy varying user needs. This enables users to create defects that do not 
yet exist in the receiving tool, or update existing defects. 

You begin working with the IBM Rational Change for HP Quality Center Interface 
by creating a synchronization link in IBM Rational Change for HP Quality Center 
Interface. When you create a synchronization link, you define and configure the data 
to be transferred between a change request entity in a IBM Rational Change database 
and a defect entity in a HP Quality Center project. 

After you create a synchronization link, you can work with your defects in HP 
Quality Center or in IBM Rational Change, as required. You can also run the 
synchronization as a service. The service synchronizes your links automatically, 
according to predetermined time intervals. 
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Using this guide 
 

This guide contains the following chapters: 
Chapter 1      What’s New in IBM Rational Change for HP Quality Center Interface 

This chapter describes the new features available in this version of   
integration. 
 

Chapter 2       Installing the IBM Rational Change for HP Quality Center Interface  
This chapter describes how to install the IBM Rational Change for HP 
Quality Center Interface 3.7. 
 

Chapter 3       Integration strategies  
This chapter describes the IBM Rational Change for HP Quality Center 
Interface 3.7 concepts and data mapping between HP Quality Center and 
IBM Rational Change. 
 

Chapter 4       HP Quality Center project & IBM Rational Change process setup 
This chapter describes how to prepare your HP Quality Center projects 
and process to use this integration. 
 

Chapter 5       Creating links between HP Quality Center and IBM Rational Change 
This chapter describes how to create a new link between a HP Quality 
Center project and a IBM Rational Change database. This chapter also 
describes how to delete an existing link and how to update an existing 
link. 
 

Chapter 6       Working with the IBM Rational Change for HP Quality Center 
Interface 

This chapter describes how to run the Synchronization task, either 
manually or as a service. It also explains how to migrate defects from IBM 
Rational Change. 
 
 

Documentation Updates for HP Quality Center 
 

HP is continuously updating its product documentation with new information. 
You can download the latest version of HP Quality Center documentation from 
the HP Customer Support Web site at http://support.openview.hp.com. 
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Assumptions about your background 
 

This document assumes that you have a basic understanding of how to use HP 
Quality Center and IBM Rational Change. 
 

Typographical conventions 
 
 This document uses the following typographical conventions: 
  
Typefaces and symbols 
 

Typeface Description 
Italic Used for book titles and terminology. Also 

designates names of roles (developer), states 
(working), groups (ccm_root), and users (laura). 

Bold Used for items that you can select, such as 
buttons, icons, etc., and menu paths. Also used 
for the names of dialog boxes, dialog box 
options, toolbars, folders, baselines, databases, 
releases, properties, and types. Also used for 
emphasis. 
 

Courier Used for commands, filenames, and directory 
paths. Represents command syntax to be entered 
verbatim. Signifies computer output that displays 
on-screen. 

Courier Italic Represents values in a command string that you 
supply. For example, 
(drive:\username\commands). 
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Contacting IBM Rational Software Support 
 

If the self-help resources have not provided a resolution to your problem, you can contact 
IBM® Rational® Software Support for assistance in resolving product issues. 
 

Note: If you are a heritage Telelogic customer, a single reference site for all 
support resources is located at 
http://www.ibm.com/software/rational/support/telelogic/ 

 

Prerequisites 
 
To submit your problem to IBM Rational Software Support, you must have an active 
Passport Advantage® software maintenance agreement. Passport Advantage is the IBM 
comprehensive software licensing and software maintenance (product upgrades and 
technical support) offering. You can enroll online in Passport Advantage from 
http://www.ibm.com/software/lotus/passportadvantage/howtoenroll.html 
 

• To learn more about Passport Advantage, visit the Passport Advantage FAQs at 
http://www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguid
es.html. 

• For further assistance, contact your IBM representative. 
 
To submit your problem online (from the IBM Web site) to IBM Rational Software 
Support, you must additionally: 

• Be a registered user on the IBM Rational Software Support Web site. For details 
about registering, go to http://www.ibm.com/software/support/. 

• Be listed as an authorized caller in the service request tool. 
 

Submitting problems 
 
To submit your problem to IBM Rational Software Support: 
 
1. Determine the business impact of your problem. When you report a problem to IBM, 

you are asked to supply a severity level. Therefore, you need to understand and assess 
the business impact of the problem that you are reporting. 
 
Use the following table to determine the severity level. 

 
Severity Description 

1 
The problem has a critical business impact: You are 
unable to use the program, resulting in a critical impact 
on operations. This condition requires an immediate 



 8

solution. 

2 This problem has a significant business impact: The 
program is usable, but it is severely limited. 

3 
The problem has some business impact: The program is 
usable, but less significant features (not critical to 
operations) are unavailable. 

4 

The problem has minimal business impact: The 
problem causes little impact on operations or a 
reasonable circumvention to the problem was 
implemented. 

 
 
2. Describe your problem and gather background information. When describing a 

problem to IBM, be as specific as possible. Include all relevant background 
information so that IBM Rational Software Support specialists can help you solve the 
problem efficiently. To save time, know the answers to these questions: 
• What software versions were you running when the problem occurred? 

To determine the exact product name and version, use the option applicable to 
you:  

o Start the IBM Installation Manager and select File > View Installed 
Packages. Expand a package group and select a package to see the 
package name and version number.  

o Start your product, and click Help > About to see the offering name and 
version number.  

• What is your operating system and version number (including any service packs 
or patches)?  

• Do you have logs, traces, and messages that are related to the problem symptoms?  
• Can you recreate the problem? If so, what steps do you perform to recreate the 

problem?  
• Did you make any changes to the system? For example, did you make changes to 

the hardware, operating system, networking software, or other system 
components?  

• Are you currently using a workaround for the problem? If so, be prepared to 
describe the workaround when you report the problem. 

3. Submit your problem to IBM Rational Software Support. You can submit your 
problem to IBM Rational Software Support in the following ways: 
• Online: Go to the IBM Rational Software Support Web site at 

https://www.ibm.com/software/rational/support/ and in the Rational support task 
navigator, click Open Service Request. Select the electronic problem reporting 
tool, and open a Problem Management Record (PMR), describing the problem 
accurately in your own words. 
 
For more information about opening a service request, go to 
http://www.ibm.com/software/support/help.html 
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You can also open an online service request using the IBM Support Assistant. For 
more information, go to http://www.ibm.com/software/support/isa/faq.html. 

 
• By phone: For the phone number to call in your country or region, go to the IBM 

directory of worldwide contacts at http://www.ibm.com/planetwide/ and click the 
name of your country or geographic region.  

 
• Through your IBM Representative: If you cannot access IBM Rational 

Software Support online or by phone, contact your IBM Representative. If 
necessary, your IBM Representative can open a service request for you. You can 
find complete contact information for each country at 
http://www.ibm.com/planetwide/. 
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Installing the IBM Rational Change for HP Quality Center 
Interface 3.7 
 

This chapter describes how the IBM Rational Change for HP Quality Center 
Interface 3.7 works, how to install the integration, and how to setup the systems 
for smooth running of the integration. 

 

This chapter includes 
 

Before you begin 
Installing IBM Rational Change for HP Quality Center Interface 3.7 
After the installation 

Before you begin 
 

1. Install HP Quality Center 9.0 or 9.2. For detailed instructions, refer to 
the HP Quality Center documentation.  

 
2. Install IBM Rational Synergy 7.1 and IBM Rational Change 5.2.  For 

detailed instructions refer to the documentations of these products and 
the read me files in each of their patches. 

 

Installing IBM Rational Change for HP Quality Center Interface 3.7 
 

Installation instructions 
 

1. Install the IBM Rational Change for HP Quality Center Interface 3.7 
on a separate, dedicated standard desktop machine that is not being 
used as a HP Quality Center or IBM Rational Change server. 

 
1. To successfully work with the IBM Rational Change for HP Quality 

Center Interface 3.6, the machine must meet the minimum 
requirements and recommendations of Microsoft® .NET Framework 
2.0 Desktop System requirement. For more information, refer to the 
Microsoft .NET product requirement guide. 

 
2. HP Quality Center is a Web-based product. Therefore, you do not need 

to install HP Quality Center on the client machine where you are about 
to install IBM Rational Change for HP Quality Center 3.6 Interface. 
However, you must connect to the HP Quality Center server at least 
once from this machine prior to installing the integration. This will 
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enable the HP Quality Center to download the client components that 
are required to run this integration. The URL to connect to HP Quality 
Center server is in the following format.  
http://ServerMachineName:portNo/virtualdir 
example:http://qcserv:8080/qcbin 

 
3. If the HP Quality Center and IBM Rational Change servers are located 

on different machines, the clock on these machines should be set to 
same time. This action is important for the integration to work 
correctly during the synchronization process. 

 
4. If it is not already installed, install Microsoft .NET Framework 2.0 

before installing IBM Rational Change for HP Quality Center 3.7 
Interface.  For more information see: 
http://msdn.microsoft.com/netframework/technologyinfo/howtoget/def
ault.aspx 

 
5. Obtain the interface zip file (See Contacting IBM Rational Software 

Support) 
 

6. Use a zip program to extract the contents of the zip file to a local 
directory. Example C:\TEMP. 

 
7. Double Click the TlogicChangeQualityCenterInt.msi file 

to install the integration. 
 

8. Follow the Installation wizard instructions to complete the installation. 
 
 

IBM Rational Change for HP Quality Center Interface 3.7 installer installs the 
following programs on your machine: 
  

IBM Rational Change for HP Quality Center Interface 
 

IBM Rational Change for HP Quality Center Interface Service 
 
The IBM Rational Change for HP Quality Center Interface Service is 
shown below in the Services window. 
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After the installation 

Configure IBM Rational Change 
 

If you would like to use the default IBM Rational Change lifecycle process provided 
by this interface, follow these steps to create and install the IBM Rational Change 
package. The default lifecycle comes with all the required attributes to run this 
interface. 

1. Copy the td_process.xml file, which is in the interface zip file, to the IBM 
Rational Change Process installation directory. For example, this directory might 
be as follows: 

C:\Program Files\IBM Rational\Change 
5.2\cs_app\webapps\synergy\WEB- INF\cr_process 
 

2. Unzip the td_template.zip file, which is in the interface zip file, to the IBM 
Rational  Change package_templates directory. For example, this directory 
might be as follows: 

C:\Program Files\IBM Rational\Change 
5.2\cs_app\webapps\synergy\WEB- INF\ 
package_templates 
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3. Log on to IBM Rational Change as Admin, and create a new package using the 
td_process.xml process file and the td_template package template.  To 
learn how to create and install a new package, refer to the IBM Rational Change 
documentation. 

 

Configuring IBM Rational Change users roles 
 

The user of IBM Rational Change must have pt_admin role privileges. This role is 
required by the integration to modify change requests.  

 

Creating attributes for IBM Rational Change custom lifecycle 
 

If you would like to use your own existing custom lifecycles in IBM Rational 
Change, you must add the following. 

1. Add the td_problem attribute to your custom lifecycle. This attribute will save the 
HP Quality Center Defect ID value. This is a required attribute for the correct 
operation of this integration. 

Name: td_problem 
Label: TD BUG ID  
Web type: CCM_STRING 
Database type: string 
 

2. The R&D Comments field in HP Quality Center must be mapped to a IBM 
Rational Change attribute defined as having the CCM_TEXT web type. 

Example: 
Name: r_d_comments 
Label: R and D Comments 
Web type: CCM_TEXT 
Database type: string 

 

3. You must add the following lines to your package template CFG file: 
[CCM_ATTRIBUTE][NAME]db_id[/NAME][ALIAS]DCMDBID[/
ALIAS][TYPE]CCM_STRING[/TYPE][/CCM_ATTRIBUTE] 

[CCM_ATTRIBUTE][NAME]delimiter[/NAME][ALIAS]DCM 
Delimiter[/ALIAS][TYPE]CCM_STRING[/TYPE][/CCM_ATT
RIBUTE] 

4. Login to IBM Rational Change as Admin, and create a new package using your 
custom template. 

 

5. Install the package you just created. 
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Integration strategies  
 

To successfully use this integration, you must be able to transfer data between HP 
Quality Center and IBM Rational Change. After you understand the concepts 
described in this section, you are ready to setup your HP Quality Center project to use 
IBM Rational Change data, and vice versa. 

 At your site, you most likely have one of the following scenarios: 

You are just starting out and setting up new projects in HP Quality Center. 
You already have data in HP Quality Center and IBM Rational Change 
that needs to be integrated. 
You have data in either HP Quality Center or IBM Rational Change, but 
not in both. 

 
In addition, you may have customized the default HP Quality Center defect lifecycle, 
the default IBM Rational Change lifecycle, or both.  

Regardless of which scenario applies to you, you must consider some basic strategies 
that make the integration work. Moreover, you must understand these strategies 
before you use this integration. 

Learning how the defect synchronization works 
 

When you perform a synchronization operation, HP Quality Center defects are 
synchronized with the specific IBM Rational Change change requests that they have 
been mapped to. 

Understanding data mapping 
 

HP Quality Center uses the concept of defects and IBM Rational Change uses the 
concept change requests (CR). However, the information contained in a specific 
defect field and a corresponding CR attribute is not the same for both applications. 
Thus, data mapping is used to define how specific fields that are used in a HP Quality 
Center defect and a corresponding IBM Rational Change Request relate to each other. 

Special default mappings 
 

IBM Rational Change for HP Quality Center Interface comes with the following 
default mapping for the lifecycle package provided with this integration. The default 
mapping is shown in the following table. 

If you already have a custom lifecycle at your site, you could customize your 
mapping as explained in the Creating attributes for IBM Rational Change custom 
Lifecycle on page . 
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HP Quality Center Defect 
System Field 

 
 
IBM Rational 
Change CR 
attribute 

 
 
Comments 

BG_CLOSING_DATE conclusion_date Part of default lifecycle 
BG_CLOSING_VERSION release Part of default lifecycle 
BG_DESCRIPTION problem_description Part of default lifecycle 
BG_DETECTED_BY submitter Part of default lifecycle 
BG_DETECTION_VERSION  product_version Part of default lifecycle 
BG_DEV_COMMENTS r_d_comments Can be mapped to any IBM 

Rational Change CR attribute 
of type CCM_TEXT. The 
default lifecycle that 
comes with this integration 
has an attribute  
r_d_comments. 
The BG_DEV_COMMENTS 
can be mapped to this attribute 
or you can choose to create a 
new attribute 

BG_PLANNED_CLOSING_VER None Can be mapped to any IBM 
Rational Change CR attribute 
of type CCM_STRING. 

BG_PRIORITY  priority Part of default lifecycle 
BG_PROJECT  product_name Part of default lifecycle 
BG_REQUEST_ID None No attribute in IBM Rational 

Change 
BG_RESPONSIBLE  resolver Part of default lifecycle 
BG_SEVERITY severity Part of default lifecycle 
BG_STATUS crstatus Part of default lifecycle 
BG_SUMMARY problem_synopsis Part of default lifecycle 
BG_REPRODUCIBLE None  No attribute in  IBM Rational 

Change 
BG_SUBJECT None No attribute in  IBM Rational 

Change 
BG_ACTUAL_FIX_TIME None Not mapped. 
BG_ESTIMATED_FIX_TIME None Not mapped. 
BG_DETECTION_DATE None  Can be mapped to 

creation_date attribute in IBM 
Rational Change. 

BG_BUG_ID None Not mapped 
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Mapping HP Quality Center defect status to IBM Rational Change lifecycle states 
 

This integration supports the dissimilar lifecycles used by developers and testers and 
also supports lifecycle hiding. Lifecycle hiding means hiding some workflow states 
used by one team from the other. 
 
See Chapter 5: “Creating links between HP Quality Center and IBM Rational 
Change”, which explains how to map lifecycles between HP Quality Center and IBM 
Rational Change. This integration comes with default status mapping (see Lifecycle 
Configuration mapping dialog). 

 

How data is synchronized between HP Quality Center and IBM Rational Change 
 

When you first synchronize a HP Quality Center Project with a IBM Rational Change 
database, for each defect in the HP Quality Center project, a corresponding CR is 
created in the IBM Rational Change database. At that time, the HP Quality Center 
defect is mapped to this IBM Rational Change change request number in the current 
IBM Rational Change database. This CR number is saved in the next available 
BG_USER field, in the HP Quality Center defect.  This CR number is used as 
reference for all the feature synchronization purpose. The BG_USER field created by 
the synchronization process is labeled as problem_number. This user field should 
not be deleted or modified manually outside of the synchronization process to ensure 
the proper running of this integration. 

Synchronization also considers new CRs in IBM Rational Change that match the user 
defined custom query. These CRs are migrated to HP Quality Center as defects. 
While migrating the change request, a new defect is created in HP Quality Center and 
that defect’s BG_BUG_ID is saved in the td_problem attribute of the CR. The 
td_problem attribute uniquely identifies the HP Quality Center defect with HP 
Quality Center domain name, server name, project name, and defect ID. The 
following figure shows the TD BUG ID and R & D Comments attributes that are used 
in synchronization process.     

The process is similar to migrating a IBM Rational Change CR to the HP Quality 
Center project database.  
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HP Quality Center project & IBM Rational Change process 
setup  
 

Customize a project 
 

Whether you created a new project or are using one that was already created, you 
must customize it as described in this section. This will ensure that this 
integration tool works properly. 

 
 Note: You must have administrator rights to customize the project. 

 

Customize system fields 
  

To customize the system fields: 
 

1. Connect to the HP Quality Center server machine, for example 
http://Server_name:portno/QCBIN 
 

2. Login to the desired domain and project. 
 

3. Click Tools -> Customize 
 

The Project Customization screen is displayed. 
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4. Click Customize Project Entities.  

The Customize Project Entities dialog box is appars 
 

5. In Project Entities, select the DEFECT entity and Click on System 
Fields. 
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6. See the Special Default Mappings shown in Chapter 3. Each HP 
Quality Center Defect Field in table1 has a corresponding field in the 
System Fields folder. 

 
7. Select the History check box for all system fields that are mapped to 

IBM Rational Change attributes. 
 

When the History check box is selected for a specific system field, HP 
Quality Center keeps a log of any changes that are made to that field. 
In addition, during the synchronization operation, the HP Quality 
Center database is queried to find all defect fields that have been 
modified since the last synchronization. 

 

Customize project lists 
 

HP Quality Center projects contain lists (such as projects, priority, and severity) that 
contain defect field values. Similarly, IBM Rational Change list boxes contain values 
for CR attributes (such as product, priority, and severity). The contents of these lists 
can be customized. 
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If a defect field has a list box and if that field is mapped to a IBM Rational Change 
attribute, the items in the list must match the attribute range values in IBM Rational 
Change. To help you learn how to do this, the following example is provided. 
 

Note: If you have many lists that change frequently, consider using the IBM 
Rational Change external listbox feature.  This feature can be configured so that 
IBM Rational Change retrieves attribute range values directly from the HP 
Quality Center database.  Using this feature allows you to maintain lists using HP 
Quality Center without the need to make corresponding changes in IBM Rational 
Change. 

 
Map project name list items: 
 

To map the Project name list items in HP Quality Center to the product_name list 
box values in IBM Rational Change, do the following: 

 

1.   Go to the Project Customization page. 
 
2. Click the Customize Projects Lists link to display the Customize Project 

Lists dialog box. 
 

 
 

   
 
3. In Lists, select All Projects. 
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All project list items are shown in the List Items area. 
When a new defect is created in the HP Quality Center project, the 
value for the BG_PROJECT field is selected from this list. 
 

4. Make a note of the projects shown in the List Items area in the 
Customize Project Lists dialog box. 

 
The BG_PROJECT field is mapped to IBM Rational Change 
attribute product_name. Enter these values in the IBM Rational 
Change product_name list box. 
 
To enter the Project names in IBM Rational Change, do the following: 

 
5. Log on to IBM Rational Change as Admin, and click Administration.  

The Administration page appears. 
 

6. Click Listbox Manager. 
 
 

 
 
 

7. In Select Listbox, click product_name. 
 



 23

8. Add the project names, that you noted earlier, to the Define the 
Listbox Values list. 

 
9. If there are any additional IBM Rational Change products names that 

were not present in the HP Quality Center Project List Items, add 
them to the HP Quality Center Project List Items. 

 

Mapping priority list items 
 

To map the priority list items in HP Quality Center to the priority list box values in 
IBM Rational Change, do the following: 

 
1. Display the Customize Project Lists dialog box. 
 
2. In Lists, select Priority. 

 
All priority list items are shown in the List Items area. The priority 
field value for a defect is assigned from List Items. 

 

 
 
 

3. Make a note of the priorities shown in List Items. 
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The priority field is mapped to IBM Rational Change attribute priority. 
Enter these values in IBM Rational Change priority list box. To enter 
the priority values in IBM Rational Change, do the following: 

 
4. Log on to IBM Rational Change as Admin, and click Administration.  

The Administration page appears. 
 
5. Click Listbox Manager. 

 
6. In Select Listbox, select priority. 

 
7. Add the priority values that you noted earlier, to Define the Listbox 

Values. 
 

 
8. If there are any additional IBM Rational Change priority values that 

were not there in the HP Quality Center Priority List Items, add them 
to the HP Quality Center Priority List Items. 

 

Map severity list items 
 

To map the severity list items in HP Quality Center to the severity list box values in 
IBM Rational Change, follow the steps shown in Map Priority List Items section. 
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Creating links between HP Quality Center and IBM Rational 
Change 
 

Creating links 
 

Use the IBM Rational Change Link Wizard to create a link in the the IBM Rational 
Change for HP Quality Center Interface. The the IBM Rational Change Link Wizard 
enables you to define and configure the data to be transferred between a the IBM 
Rational Change database and a HP Quality Center project. 

       
     To create new links: 
 

From your desktop, start the IBM Rational Change for HP Quality 
Center Interface by double-clicking .  
 
Your first task is to create links between the IBM Rational Change 
database and the HP Quality Center project using IBM Rational Change 
Link Wizard. If no links are configured during startup, the IBM Rational 
Change for HP Quality Center Interface automatically launches the IBM 
Rational Change Link wizard. You could also start Link Wizard by 
selecting Links > Create menu from IBM Rational Change for HP 
Quality Center Interface. 
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Click Next to begin creating a link using the wizard. 
 

The HP Quality Center Configuration dialog box appears. In Server 
URL, type the HP Quality Center server and the virtual directory name. 

 
   Note: Type a real host name, not localhost.  

 
 

 
Type the username and password for the user you will use to synchronize 
data with HP Quality Center.  This user must be an administrator for the 
HP Quality Center project you will synchronize with. 
 
Click Next.  

 
The Quality Center Project Configuration dialog box opens. 
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4. In Domain, select a HP Quality Center Domain. 
5. In Project, select a project and click Next. 

     
     The IBM Rational Change Configuration Page dialog box appears. 
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6. Type the IBM Rational Change server name, port, userid, password and 
database path used by IBM Rational Change and then click Next. 

 
Note: You must have pt_admin role in IBM Rational Change to use this 
integration. 

 
The Defect Attribute Mapping dialog box appears. 

 

 
 

 
A default mapping of HP Quality Center Defect field with IBM Rational 
Change CR attribute is displayed in this dialog. You can use this default 
setting or customize it for your needs. 

 
The HP Quality Center Defect Field column displays the current defect 
fields in the HP Quality Center project that was selected in the previous 
wizard dialog. 

 
The IBM Rational Change CR Attribute column shows all available 
IBM Rational Change CR attributes in the Change database. 

 
A default sync method is also set for each field. You can use this default 
setting or modify the settings to your needs. 
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The Sync method column has the following options. 

 
SYNC_OFF:  Synchronization process ignores any changes made to the 
field in HP Quality Center and corresponding attribute in  IBM Rational 
Change. 
 
SYNC_TD2CCM: Changes made to the field in HP Quality Center 
override the changes made to the corresponding attribute in IBM Rational 
Change. 
 
SYNC_CCM2TD:  Changes made to a attribute in IBM Rational Change 
override the change made to the corresponding field in HP Quality Center 
 
SYNC_ON:  Synchronization process determines which tool has the most 
recent update for any given attribute and updates the out-of-date tool with 
latest changes. 
 
Refresh: Updates the HP Quality Center Defect fields and the IBM 
Rational Change CR attribute list with the latest values from the HP 
Quality Center and the IBM Rational Change servers. 

 
Note: 

  
It is very important that the user checks and adjusts the time on HP 
Quality Center and IBM Rational Change Server machines during 
the setup process. The Synchronization process uses system time 
as a reference to determine the latest changes.  

 
Link Wizard restricts the user from configuring a single CR 
attribute to multiple HP Quality Center defect fields to avoid any 
data loss during the synchronization process. 

 
 

7. Click Next. 
 

The Lifecycle Configuration Mapping dialog box appears. 
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8. Make the following selections in the Lifecycle Configuration Mapping dialog 
box  

From Select IBM Rational Change submit form select a submit form for 
your custom lifecycle. 
 

9. From Map CR Status to Quality Center Defect Status, map your states 
 

The CR Status to Quality Center Defect Status mapping is used for updating 
defect status brought in from IBM Rational Change. All available CR status are 
listed in the IBM Rational Change CR Status column. The CR status names are 
not modifiable. The Quality Center Defect Status list box contains all available 
HP Quality Center status. You could choose an empty value in this column. If the 
value is empty it means that HP Quality Center Defect lifecycle does not have a 
corresponding state. Unmapped states are not synchronized. 

 
10. From Map Quality Center Defect Status to CR status, map your states 

 
The Quality Center Defect Status to CR status mapping is used for updating 
the CR status brought in from HP Quality Center projects. All available HP 
Quality Center Defect status are listed in the Quality Center Defect Status 
column. The defect status names are not modifiable. The IBM Rational Change 
CR Status list box has all available IBM Rational Change lifecycle status. You 
could choose an empty value in this column. If the value is empty, it means that 
IBM Rational Change lifecycle does not have a corresponding state and IBM 
Rational Change for HP Quality Center Interface will not update the CR status. 
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Note: It is not mandatory to map all HP Quality Center defect states to 
IBM Rational Change CR states or vice versa. The unmapped states are 
hidden and are not synchronized. This level of flexible customization 
allows a team to hide the lifecycle that is internal to a team and 
synchronize only those states that are meaningful for the other team. 

 

11. Click Next.  The IBM Rational Change and Quality Center Custom Query 
Page dialog box appears. 

 

 

 

This dialog box provides the option to add a SQL statement that will be added to 
the query used to find defects in HP Quality Center to sync.  This optional field 
can be used to be selective about which HP Quality Center defects are 
synchronized with IBM Rational Change.  For example, you could synchronize 
only defects with Urgent Priority, or only defects submitted against a specific 
area of the product being tested.  The text you enter must be valid SQL.  You 
should perform at least one manual sync operation to verify that your custom 
query is working as expected.   

Also, you can migrate newly created CRs to HP Quality Center during 
synchronization. Specify a valid IBM Rational Change query, and then check the 
box Automatically migrate new IBM Rational Change CRs to Quality Center 
during sync. 
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12. Click Next. The IBM Rational Change and Quality Center Link Setup Page 
appears. 

 

 
 

13. In Link Name, type the name of your link. This name is displayed in IBM 
Rational Change for HP Quality Center Interface. 

 
In Sync Time, Type a time interval to synchronize the updated defect 
records.  
 

Note: Minimum allowed time interval is one minute. IBM Rational Change for 
HP Quality Center Interface updates the data between HP Quality Center and 
IBM Rational Change database based on the time interval provided in this dialog. 
The interval between synchronizations is between the end of one synchronization 
operation and the beginning of the next. 

 

14. Click Next. 
The completion dialog box appears. 
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Updating links 
 

Each synchronization link that is created using IBM Rational Change Link 
Wizard can be edited with in the IBM Rational Change for HP Quality Center 
Interface. You should not manually edit link configuration XML files due to the 
likelihood of introducing an error. Always use the following procedure to update 
the link configuration. 

      To edit HP Quality Center Server Settings, do the following: 

 
1. In the IBM Rational Change for HP Quality Center Interface left pane, select a 

link. 
 
2. Click Quality Center tab. 

 

 
 
3. Update the HP Quality Center server information 
4. Click Save, then click OK. 
 

 
Before saving the configuration, IBM Rational Change for HP Quality Center 
Interface will try to validate your updates. If validation fails, you have the choice 
to save or discard the invalid configuration. 
 

 
 
To edit the IBM Rational Change Server settings: 
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1. From the left pane of the IBM Rational Change for HP Quality Center 

Interface, select the link whose properties you want to edit. 
 
2. Click the IBM Rational Change tab. 

 
3. Update the IBM Rational Change information. 

 
4. Click Save. 

 
 

 
To edit attribute mapping, do the following: 
 
1. From the left pane of the IBM Rational Change for HP Quality Center 

Interface, select the link whose properties you want to edit. 
 
2. Click the Attribute tab. 

 
 The attribute-mapping dialog box is displayed. The mapping information 
displayed in this dialog is from the link configuration XML file for the 
selected link. The configuration file may not contain recent updates to the 
IBM Rational Change process, and HP Quality Center defect fields. To get the 
CR attributes in IBM Rational Change or the defect field in HP Quality Center 
server dynamically, click Refresh. 

 

3. Click Save. 



 36

 

 
 
 

To edit the lifecycle mapping: 
 

1. From the left pane of the IBM Rational Change for HP Quality Center 
Interface, select the link whose properties you want to edit. 

 
2. Click the Lifecycle tab. 

 
The status-mapping dialog box appears. The mapping information displayed 
in this dialog is from the link configuration XML file for the selected link. 
The configuration file may not contain recent updates to IBM Rational 
Change process and the HP Quality Center defect status. To get the CR states 
from IBM Rational Change or the defect states from HP Quality Center server 
dynamically, click Refresh. 

3. Click Save. 
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Note: The IBM Rational Change states that are not mapped to HP Quality Center 
defect status or vice versa are hidden states and are not synchronized. 

 

Deleting links: 
 

To manually delete a link from the IBM Rational Change for HP Quality Center 
Interface:  

 
1. From the left pane of the IBM Rational Change for HP Quality Center Interface, 

select the link you want to delete. 
 
2. Select Links > Delete. 
3.  
4. Click Yes. 
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Working with the IBM Rational Change for HP Quality Center 
Interface 

 Manual synchronization operation 
 

To manually synchronize a link from the IBM Rational Change for HP Quality 
Center Interface: 

 
1. In the IBM Rational Change for HP Quality Center Interface, select a link. 
 
2. Choose Tools > Synchronize > link 

 
The Manual Sync Dialog box appears. 
 

3. Select a logging level if you need more information during synchronization 
process. The available logging levels are Brief, Verbose and Debug. 

 
4. Click start button to start the synchronization operation. 

 
5. Click Cancel button to stop the manual synchronization operation.  

. 
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Note: The detailed messages and status are logged to <your install 
directory>\logs\MainApplog.txt file 

 

 Synchronization service 
. 

To run the synchronization operations as a Service from the IBM Rational Change for 
HP Quality Center Interface: 

 
1. In IBM Rational Change for HP Quality Center Interface, select Tools > Start 

Service. 
 

A message appears indicating the status of service during startup. The 
synchronization process starts for all the configured links in parallel.  Multiple 
IBM Rational Change databases can be synchronized with multiple HP Quality 
Center servers and projects simultaneously.  The update frequency for each link is 
configured by the user in the Link Wizard while creating a new link and is 
modifiable from Options tab in IBM Rational Change for HP Quality Center 
Interface. The synchronization service reads the link configuration file to update 
itself of any changes users might have made to the link before starting the 
synchronization cycle for a link. 

 
Note: There is no visual indication of status during automatic synchronization, 
however detailed log files for each link are available in <your install 
directory>\logs\ 

 
2. In IBM Rational Change Lifecycle Manager, select Tools > Stop Service. 
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Migrate a change request from IBM Rational Change to HP Quality Center Project 
 
To migrate a change request from the IBM Rational Change database to a HP Quality 
Center project: 

1. Select a link in the IBM Rational Change for HP Quality Center Interface, and 
then select Tools > Migrate. 

 
2. The Migrate Defects Dialog dialog box appears. 
 

 
 
3. In IBM Rational Change Query, provide an IBM Rational Change query. 
 
4. Click Query. 

 
The list of change requests from query result is displayed in the Migrate Defects 
Dialog  dialog box. 
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5. Check all the CRs you want to migrate. 
 

6. Select a logging level if you need more information during migration process. The 
available logging levels are Brief, Verbose and Debug.  

 
7. Click Migrate. 

 
Warning: Clicking Query without providing a query string in the IBM Rational 
Change Query edit box causes IBM Rational Change for HP Quality Center 
Interface to select the CRs from the entire IBM Rational Change database that are 
not migrated or not synchronized with a HP Quality Center project. If your 
database is large this operation may take a while. For optimum performance, 
always provide a IBM Rational Change query. 

Note: It is not necessary to provide a separate migration command to migrate the 
newly created defects in HP Quality Center project. Newly submitted defects in 
HP Quality Center are picked up dynamically during the Synchronization process. 

Detailed messages and status is logged to <your install 
directory>\logs\MainApplog.txt file. 
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Managing the sync service with the system tray 
When you launch the IBM Rational Change for HP Quality Center Interface, an 
icon is placed in system tray. If you try to exit the IBM Rational Change for HP 
Quality Center Interface by clicking on System ‘Close’ menu or the ‘X’ icon at 
top right corner of the title bar, the IBM Rational Change for HP Quality Center 
Interface minimizes itself to system tray as an icon. 

 
 
 

Double-clicking this icon activates the IBM Rational Change for HP Quality Center 
Interface. To start or stop the Sync service from the context menu, right-click this icon, 
and then select Start Service or Stop Service. 

 
 
Whenever the Sync service changes its state, Service Status Update appears, notifying 
the user of the status. 
 

 
Click Status to browse directly to the Status page in IBM Rational Change for HP 
Quality Center Interface. Use Exit to close the IBM Rational Change for HP Quality 
Center Interface.  
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The Status page displays when the synchronization was last performed for a link and 
when the next sync is scheduled. 

 

Logging during Synchronization:  
 

Your <installation directory> contains tdcsConfig.xml. The 
content of this file are shown below.  

logLevel options:  Brief=0, Verbose=1, Debug =2 

logfileSizeCap option: default =5. (5 MegaByte ).  

keepOldLogFile option: default = 1. (To keep the history of log files), 0 for no 
log history. 
TimePatterns: The default date/time format used for SYNERGY query and HP 
Quality Centery query. You could set the time pattern to your locale. 
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tdcsConfig.xml 

The contents of tdcsConfig.xml is shown below: 

<?xml version="1.0" encoding="utf-8"?> 

<TDCSConfig version="tdcs3.2"> 

  <section name="Log Settings"> 

    <entry name="logLevel">0</entry> 

    <entry name="logFileSizeCap">5</entry> 

    <entry name="keepOldLogFile">1</entry> 

  </section> 

  <section name="TimePatterns"> 

 <entry name="CMQuery">MM/dd/yyyy HH:mm:ss</entry> 

 <entry name="TDQuery">yyyy-MM-dd HH:mm:ss</entry> 

  </section> 

</TDCSConfig> 
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Appendix A: Notices 

This information was developed for products and services offered in the U.S.A. 
IBM may not offer the products, services, or features discussed in this document 
in other countries. Consult your local IBM representative for information on the 
products and services currently available in your area. Any reference to an IBM 
product, program, or service is not intended to state or imply that only that IBM 
product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right may 
be used instead. However, it is the user's responsibility to evaluate and verify the 
operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not grant you 
any license to these patents. You can send written license inquiries to: 

IBM Director of Licensing  
IBM Corporation  
North Castle Drive  
Armonk, NY 10504-1785 
U.S.A. 

For license inquiries regarding double-byte character set (DBCS) information, 
contact the IBM Intellectual Property Department in your country or send written 
inquiries to: 

IBM World Trade Asia Corporation  
Licensing  
2-31 Roppongi 3-chome, Minato-ku  
Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom or any other 
country where such provisions are inconsistent with local law: 
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES 
THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some 
states do not allow disclaimer of express or implied warranties in certain 
transactions. Therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements 
and/or changes in the product(s) and/or the program(s) described in this 
publication at any time without notice. 
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Any references in this information to non-IBM Web sites are provided for 
convenience only and do not in any manner serve as an endorsement of those 
Web sites. The materials at those Web sites are not part of the materials for this 
IBM product and use of those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it 
believes appropriate without incurring any obligation to you.  

Licensees of this program who wish to have information about it for the purpose 
of enabling: (i) the exchange of information between independently created 
programs and other programs (including this one) and (ii) the mutual use of the 
information which has been exchanged, should contact: 

Intellectual Property Dept. for Rational Software  
IBM Corporation  
1 Rogers Street Cambridge,  
Massachusetts 02142 
U.S.A. 

Such information may be available, subject to appropriate terms and conditions, 
including in some cases, payment of a fee.  

The licensed program described in this document and all licensed material 
available for it are provided by IBM under terms of the IBM Customer 
Agreement, IBM International Program License Agreement or any equivalent 
agreement between us. 

Any performance data contained herein was determined in a controlled 
environment. Therefore, the results obtained in other operating environments may 
vary significantly. Some measurements may have been made on development-
level systems and there is no guarantee that these measurements will be the same 
on generally available systems. Furthermore, some measurements may have been 
estimated through extrapolation. Actual results may vary. Users of this document 
should verify the applicable data for their specific environment. 

Information concerning non-IBM products was obtained from the suppliers of 
those products, their published announcements or other publicly available 
sources. IBM has not tested those products and cannot confirm the accuracy of 
performance, compatibility or any other claims related to non-IBM products. 
Questions on the capabilities of non-IBM products should be addressed to the 
suppliers of those products. 

This information contains examples of data and reports used in daily business 
operations. To illustrate them as completely as possible, the examples include the 
names of individuals, companies, brands, and products. All of these names are 
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fictitious and any similarity to the names and addresses used by an actual business 
enterprise is entirely coincidental. 

If you are viewing this information softcopy, the photographs and color 
illustrations may not appear. 

Trademarks 

IBM, the IBM logo, ibm.com, IBM Rational Synergy, and IBM Rational Change 
are trademarks or registered trademarks of International Business Machines 
Corporation in the United States, other countries, or both. These and other IBM 
trademarked terms are marked on their first occurrence in this information with 
the appropriate symbol (® or ™), indicating US registered or common law 
trademarks owned by IBM at the time this information was published. Such 
trademarks may also be registered or common law trademarks in other countries. 
A current list of IBM trademarks is available on the Web at 
www.ibm.com/legal/copytrade.html. 

HP Quality Center is a registered trademark of Hewlett-Packard Corporation. 

 Microsoft .NET Framework is a trademark of Microsoft Corporation. 

Other company, product or service names mentioned may be trademarks or 
service marks of others. 


