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Overview
Getting Started

Overview
This tutorial teaches you the basics of working with the Rational Tau product in a C# coding 
environment, and introduces the concepts of requirements analysis and project implementation. In 
the tutorial, you model a simple application that calculates the population growth projections of 
senior citizens residing in a city. The growth projections will help the city’s planner determine the 
appropriate size of a new senior center. The calculation example used in this tutorial is based on 
Fibonacci numbers. For more information on Fibonacci numbers, see http://en.wikipedia.org/
wiki/Fibonacci_number.

Tutorial Objectives
When you have completed this tutorial, you will have had experience with:

� Using the Rational Tau interface
� Creating a C# project
� Creating a use case diagram
� Creating an activity diagram
� Creating a class diagram
� Generating and editing C# code
� Integrating Rational Tau with Visual Studio 2008
� Running and compiling a C# application

Before You Begin
To complete the lessons in this tutorial, you must have Microsoft Visual Studio 2008 environment 
configured. This is because Rational Tau integrates with the IDE for building, running and 
debugging C# applications. The integration must also be installed from Program Files > IBM 
Rational > IBM /Rational Tools> IBM Rational Tau 4.3 > Install Microsoft Visual Studio 
2008 integration.
Tau 1
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Getting Started
Documentation Conventions
This document uses the following conventions:

� Boldface for names of GUI objects and controls, including selection choices; and 
emphasis. Examples:
–  From the Default model view drop-down list box, select Standard View.

–  Click the Activity flow final symbol  on the Drawing toolbar.
–  If the Rational Tau browser does not display, select View > Browser.
–  A project file, called <project_name>.ttp.

� Courier font in 10 point for pathnames, system messages, and items that you 
have to type. Examples:
–  The Output window displays the message Animation session terminated.
–  In the Project name box, replace the default project name with <project name>.
–  Type show for the function name, and press Enter.

� Italics for the first mention of a concept with an explanation.

About the Rational Tau Product

IBM® Rational® Tau® provides standards-based Model Driven Development™ (MDD™) of 
complex systems and robust software for enterprise IT applications, including those utilizing 
Service Oriented Architectures. Rational Tau’s iterative requirements-based approach, 
comprehensive error-checking, and automated simulation increase developer productivity from 
initial requirements through final documentation and deployment.

Rational Tau offers a large feature set for developers to employ key enabling technologies in a 
natural, easy-to-use tool environment. Rational Tau makes a seamless and efficient environment 
for systems, software, and testability. It enables you to perform these tasks:

� Analyze, during which you can define, analyze, and validate the system requirements.
� Design, during which you can specify and design the architecture.
� Implement, during which you can automatically generate code, then build and run 

within the Rational Tau product.
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About the Rational Tau Product
Tool Tips
This section describes time saving features in Rational Tau that enable you to work more 
efficiently on a project. Wherever possible, the task-oriented procedures in this tutorial 
demonstrate the use of these features. 

Using Shortcuts

Keyboard shortcuts (CTRL + Arrow Key, for example) allow you to quickly navigate through the 
Rational Tau interface. For a complete list of available shortcuts, see the Help topic “Editor 
Shortcuts.”

Using the Auto Placement Feature

You can use Rational Tau’s auto placement feature to quickly add a series of elements in the 
drawing area (CTRL + Space Bar). This feature is especially useful when drawing activity and 
state machine diagrams. For more information on this feature, see the Help topic “Add Symbols.”

Starting Rational Tau 

Windows

To start the Rational Tau product in Windows, for a typical installation by selecting Start > 
Programs > IBM Rational > IBM Rational Tau version number.

Linux and Solaris

To start the Rational Tau product on Linux and Solaris, type the following command:

<installation path>/bin/tau

Saving a Project in Rational Tau
To save a project in Rational Tau, on the main menu bar, select File > Save All. To configure 
Rational Tau to automatically save changes to your project, follow these steps.

1.    On the main menu bar, select Tools > Options.

2.    On the Save tab, in the Auto-backup panel, select the Activate checkbox and specify an 
interval (every 5 minutes, for example.) 

3.    Click OK. 
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Getting Started
Closing Rational Tau
To exit the Rational Tau product, follow these steps.

1.    Save your work. Do one of the following: 

� Press CTRL+S.

� Click the Save button  to save your work.
� File > Save All especially if many files were edited.

2.    Choose File > Exit or click the Close button 

Note
A red bar on the lefthand side of any file in your workspace indicates that you need to save 
your work before you exit Rational Tau. 

Project Files and Directories
The Rational Tau product creates the following files and subdirectories in the project directory:

� A project file, called <project_name>.ttp contains references to all files, model files 
(*.u2) and addins used in the project.

� A workspace, called <project_name>.ttw in which enables users to reference many 
projects. 

� Model files, called <file_name.u2> that contain the unit files for the project, including 
UML diagrams, packages, use cases, code generation configurations and other 
granularity of UML elements.

Model Element Names
It is recommened that the names of model elements should follow some conventions, such as 
these:

� Class names begin with an upper case letter, such as “System.”
� Operations and methods begin with lower case letters, such as “restartSystem.”
� Upper case letters to separate concatenated words, such as “checkStatus.”
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About the Rational Tau Product
Model Views
Rational Tau enables you to construct a model in several views, each representing different 
abstract characteristics of your model. For detailed information on model views, see the Help topic 
“Views.”
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Getting Started
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Goals for this Lesson
Lesson 1: Starting Your Project
When you create a C# project in Rational Tau, it contains UML diagrams as well as libraries, and 
add-ins. Rational Tau creates a directory containing the project files in a specified location. The 
name you choose for your new project is used to name project files and directories, and it appears 
at the top level of the project hierarchy in the Rational Tau browser.

Goals for this Lesson
In this lesson, you create a new C# project in Rational Tau, configure a project workspace, and add 
the necessary packages for the exercises in this tutorial. You will learn about the following 
concepts:

� Project configuration settings
� Project workspaces
� Project directories

Exercise 1: Using the Rational Tau Developer 
Wizard

In this exercise, you create a new C# project and workspace in Rational Tau. You also create a 
package structure that you reference in completing the exercises in this tutorial.

Task 1a: Creating a New Project and Workspace
To create a C# project, follow these steps:

1.    Click Start > Programs > IBM Rational > IBM Rational Tau version number.

2.    Do one of the following:

� Press CTRL+N, or
� On the main toolbar, select File > New, or
� On the IBM Rational Tau Welcome page, in the New Project panel, click Proceed.

3.    In the New dialog box, in the Project tab, choose UML for C# Code Generation.

4.    In the Project name box, type FibonacciNumber.
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Lesson 1: Starting Your Project
5.    In the Location box, enter a new directory name or browse to an existing directory.

6.    Accept the default option Create new workspace.

7.    Click OK.

8.    In the Developer Wizard, select Enable MS Visual Studio Integration. 

9.    Accept the remaining Developer Wizard defaults and click Next, then click Finish. 
Rational Tau creates a new project and workspace. In the Output window Messages tab, 
the following message displays:

Add-in module CSharpApplication activated.

Add-in module MSVS8Integration activated.

Exercise 2: Working with Packages
In this exercise, you create two C# packages in your workspace. The first package is for analysis 
and requirements diagrams that provide a high level overview of your application. The second 
package is for a class diagram. In subsequent lessons, you create a use case diagram and an activity 
diagram in the analysis package, and a class diagram in the class package. 
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Summary
By default, when you create your project, Rational Tau adds a single package in the project 
directory. The package has the same name as the project. In the first task of this lesson, you rename 
the package included with the project. In the second task, you create a second C# package for your 
class diagram. 

Task 2a: Renaming the Default Package
To rename the C# package, follow these steps.

1.    In the Model view, select the FibonacciNumber package.

2.    Press F2.

3.    Type Analysis.

Task 2b: Creating a New Package
To create a new C# package, follow these steps:

1.    In the Model view, right-click Model, then Select New Model Element > Package.

2.    In the Create Model Root Element dialog box, in the Element Name field, type 
Implementation.

3.    On the main menu bar, select File > Save All. Notice all the red change bars disappear.

Summary
In this lesson, you created a project that will serve as the basis and structure for storing the models 
in the rest of the tutorial. You are ready to proceed to the next lesson, in which you begin your 
project by creating a use case diagram.
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Lesson 1: Starting Your Project
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Goals for this Lesson
Lesson 2: Creating a Use Case 
Diagram

Use case diagrams show the behavior and capabilities of a system as it interacts with an external 
user or actor. A use case diagram also shows what a system will do and who will use it. 

Goals for this Lesson
In this lesson, you create a simple use case diagram for the application you are modeling. As you 
work through this lesson, you will learn about the following elements in use case diagrams, and 
how to draw them: 

� Actors
� Use Cases
� Associations

Exercise 1: Creating a Use Case Diagram
The following figure shows the use case diagram that you create in this exercise.

Use Case Diagram
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Lesson 2: Creating a Use Case Diagram
Task 1a: Adding a New Use Case Diagram
To create a use case diagram, follow these steps. 

1.    Right-click Analysis. 

2.    Select New Diagram > Use Case diagram. Rational Tau creates the use case diagram in 
your workspace and opens it in the drawing area.

Task 1b: Renaming a Use Case Diagram
In this task, you use the properties editor to rename the use case diagram. Follow these steps.

1.    Right-click Use case diagram1 and select Properties.

2.    In the Edit Properties dialog box, in the Name field, replace the default name 
with Senior Citizen Population.

3.    Click the Close button  to exit the Properties dialog box. Optionally you can leave this 
open and it will update to reflect the properties of the selected element .

Task 1c: Adding an Actor and a Use Case
In this task, you add an actor and a use case to the diagram. An actor is an external element outside 
of the system that interacts with the system. A use case illustrates the capabilities of a system and 
shows why a user interacts with the system. 

The actor in your diagram is a city planner who is using a system to gather data on the expected 
population growth of senior citizens in the city. The use case shows the system using a Fibonacci 
algorithm to compute the growth projections the planner needs to help determine the appropriate 
size of the new senior center. 

To add an actor and a use case to your diagram, follow these steps. 

1.    Click the actor symbol  on the Drawing toolbar, then click in the drawing area. 
Rational Tau adds an actor element in the drawing area. 

2.    Replace the default name with CityPlanner.

3.    Click the use case symbol  on the Drawing toolbar, then click in the drawing area. 
Rational Tau adds a use case element in the drawing area. 

4.    Replace the default name with CalculatePopulationGrowth.
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Exercise 1: Creating a Use Case Diagram
Task 1d: Adding an Association
An association line shows a relationship between two elements in a use case diagram. In this task, 
you draw an association line that shows the interacting relationship between the city planner and 
the application use case. You can add an association line using the association symbol on the 
Drawing Tool menu, or by selecting the association “handle” on the CityPlanner element. 

To draw an association line using the handle:

1.    In the drawing area, select CityPlanner. 

2.    Click on the Association “handle” at the bottom of the CityPlanner element as shown in 
the following figure. 

3.    Click anywhere inside of the CalculatePopulationGrowth use case element. Rational 
Tau adds an association line that connects the two elements.

To draw an association line using the symbol:

1.    Click the Association symbol  on the Drawing Toolbar.

2.    Click the right edge of CityPlanner and the left edge of ComputePopulationGrowth. 
Rational Tau adds an association line that connects the two elements. 

3.    On the main menu bar, select File > Save All.

Your drawing should resemble the Use Case Diagram figure. 
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Lesson 2: Creating a Use Case Diagram
Summary
In this lesson, you created a use case diagram. You became familiar with the following elements of 
use case diagrams:

� Actors
� Use cases
� Associations

You are now ready to proceed to the next lesson, in which you create an activity diagram. 
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Goals for this Lesson
Lesson 3: Creating an Activity 
Diagram

An activity diagram shows behavior based on sequences of activities. The activity diagram 
consists of various activities, data, and messages connected to each other using arrows. The arrows 
are used to show the direction of activity flow in the diagram.

Goals for this Lesson
In this lesson, you create an activity diagram. Your activity diagram will show the sequence of 
activities that occur when the city planner uses the application to estimate the future population 
growth of senior citizens. The city planner starts the application, then enters a value that the 
application uses to calculate the population growth. In your activity diagram, the value supplied by 
the planner represents a number of years in the future. The response from the application is a 
population growth projection based on the number of years.

When you create this activity diagram using Rational Tau, you will learn how to draw

� An initial node
� An action node 
� An activity line
� A final node
Tau 15



Lesson 3: Creating an Activity Diagram
Exercise 1: Creating an Activity Diagram
The following figure shows the Activity Diagram that you create in this exercise.

Activity Diagram

Task 1a: Configuring UML Settings
In this task, you configure UML editing settings so you can draw the elements of your activity 
diagram as shown in the Activity Diagram figure. By default, Rational Tau is configured to draw 
the elements of an activity diagram horizontally. Follow these steps to change the setting to 
vertical so you can draw the elements as shown above.

1.    On the menu bar, select Tools > Options, then click the UML Advanced Editing tab.

2.    On the UML Advanced Editing tab, in the Activity diagrams panel, select Vertical from 
the Autocreate orientation drop down list box.

3.    Click OK.

Task 1b: Adding a New Activity Diagram
To create an Activity diagram, follow these steps.

1.    In the Rational Tau browser, expand Model, then right on the Analysis package. 

2.    Select New Diagram > Activity Diagram. Rational Tau creates the activity diagram in 
your workspace and opens it in the drawing area.
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Exercise 1: Creating an Activity Diagram
3.    In the Edit Properties dialog box, in the Name field, replace the default name with 
Senior Citizen Population.

4.    Click outside of the Name field to commit your name change.

Task 1c: Drawing Activity Nodes
Nodes show a specific unit of behavior within an activity flow. In this task, you draw an initial 
node, three action nodes and a final activity node in your diagram. The nodes show the units of 
behavior that occur when the user starts the application and enters a value that the application uses 
to produce a population projection figure.

To draw activity nodes, follow these steps:

1.    Click the initial node  symbol on the Drawing toolbar, then click in the drawing area. 
Rational Tau adds an initial node element in the drawing area.

2.    In the drawing area, select the initial node. 

3.    Press Shift-Spacebar and on the pop-up menu, click the Activity/action  symbol. 
repeat twice to result in three action nodes. Notice that each time you add an action node, 
Rational Tau automatically includes an activity flow arrow between each node. The 
arrows show the direction of flow in the diagram. 

4.    Continue to press Shift-Spacebar and click the Activity final  symbol on the Drawing 
toolbar. 

5.    Click each activity node and type the names as shown in the Activity Diagram figure. 

6.    On the main menu bar, select File > Save All.

You have finished drawing the activity diagram. Your diagram should resemble the Activity 
Diagram figure. 
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Lesson 3: Creating an Activity Diagram
Summary
In this lesson, you created an activity diagram. You learned about the following elements in an 
activity diagram:

� Initial Nodes
� Action Nodes
� Final Nodes
� Associations

You are now ready to proceed to the next lesson, in which you create a class diagram.
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Exercise 1: Creating a Class Diagram
Lesson 4: Creating a Class Diagram
A class diagram shows the types of elements in a system and how they interact and relate to each 
other. Class relationships are typically shown with dependency, generalization and association 
lines.

Exercise 1: Creating a Class Diagram
In this exercise, you create a class diagram and draw a class in the diagram. The class contains an 
operation and an attribute for the application you are modeling.

Task 1a: Adding a New Class Diagram
The following figure shows the Class Diagram that you create in this exercise.

To create a class diagram, follow these steps: 

1.    In the browser, expand Model. 

2.    Right-click the Implementation package and select New Diagram > Class Diagram. 
Tau creates the class diagram in the scope of the Implementation package.

3.    Change the name of the Class Diagram 1 by using the Edit Properties dialog box, or by 
selecting the diagram in the model view and pressing F2. The new name should be 
Calculate.
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Lesson 4: Creating a Class Diagram
Task 1b: Drawing a Class
To draw a class, follow these steps:

1.    Click the Class button  on the Drawing toolbar, then click anywhere in the drawing 
area to add the class to the diagram.

2.    Name the class Fib by selecting in the class on the diagram and typing the text.

Task 1c: Adding Attributes and Operations
In this task, you add an attribute and an operation to the class you created in the previous task. The 
attribute you add will be the resulting number that is generated when the application performs a 
computation. The operation is the act of computing the number. 

To add attributes to the Fib class, follow these steps: 

1.    Select the Fib class. 

2.    Place the cursor in the middle compartment of the class box and type result:int in the 
attribute text box. 

3.    Place the cursor in the bottom compartment of the class box and type compute( 
n:int):int in the operation text box. You can try using name completion here by using 
CTRL + Space bar after you started typing int to see a list of possible candidates.

4.    If your types have a red underline perform a Check All

5.    On the main menu bar, select File > Save All. 

Summary
In this lesson, you created a class diagram. You learned about the following elements in a class 
diagram:

� Attributes
� Operations

You are now ready to proceed to the next lesson, in which you will generate code from the Fib 
class.
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Goals for this Lesson
Lesson 5: Generating C# Code and 
More

Goals for this Lesson
In this lesson, you

� Generate source code from your model.
� Add external code, and view updates to your model.
� Build and run your application. 

Exercise 1: Generating and Editing C# Code
In this exercise, you generate C# code from the Fib element you created in the previous lesson. 
After you generate the code, you use Microsoft Visual Studio to add external code to the compute 
operation contained in that element. 

Task 1a: Generating and Viewing C# Code
To generate the C# code from your source files, perform the following steps.

1.    Right-click on Implementation package and select Update C# source code. Rational Tau 
generates C# source code files for the classes and interfaces contained in your. 

Note:  Default file mapping is used to generate the source code, more on configuring 
this can be found in the online help.

2.    To examine the generated code, right-click the Fib class and select Goto source. 

3.    In the Visual Studio Selection dialog box, select New Instance of Visual Studio, then 
click OK.

Microsoft Visual Studio displays the source code in a file named Implementation.Fib.cs. 

4.    Close Microsoft Visual Studio. 
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Lesson 5: Generating C# Code and More
Task 1b: Creating a Project in Microsoft Visual Studio
In this task, you create a project in Microsoft Visual Studio. For the remainder of this tutorial, you 
work with your model in both Visual Studio and in Rational Tau. The Visual Studio project you 
create in this task allows you to edit the source code that you generated in Task 1a: Generating 
and Viewing C# Code. 

Before you create the project, verify that the MSVS8 add-in is enabled in Rational Tau. To do this, 
perform the following steps:

1.    From the main menu, select Tools > Customize.

2.    Click the Add-ins tab.

3.    In the list of Customization modules, verify that MSVS8Integration is checked.

4.    Click Close.

Rational Tau is also dependendent on Visual Studio saving the projects when they are created. If 
your generated files not not show up in your project this may be due to your Visual Studio settings. 
To correct this set the following option:

1.    From the main menu, select Tools > Options.

2.    In Project Solutions there is an option Save new projects when created. Make sure the 
check box is selected.

3.    Close Visual Studio and repeat the following steps.

To create a Visual Studio project, follow these steps:

1.    In the Model view select the Implementation package.

2.    From the Visual Studio .NET menu, select Create/Update Visual Studio .NET C# 
Project.

3.    Select New instance of Visual Studio.

4.    Click OK.

5.    In the New Project dialog box, select the Console Application template and give your 
project a name.

6.    Click OK. 

The Console Application main menu is displayed. The Solutions Explorer panel contains several 
files used by MSVS. In the next task, you edit the Implementation.Fib.cs and Program.cs source 
files. Implementation.Fib.cs contains the code created from your UML model in Rational Tau. 
Program.cs is a file generated by Visual Studio containing a class program that serves as the main 
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Exercise 1: Generating and Editing C# Code
function in your application. This class has automatically been added to your model view in 
Rational Tau. 

Task 1c: Adding Code for the Compute Operation
In this task you add code that is the body of the compute operation that you created in Lesson 4: 
Creating a Class Diagram. To add code manually for the compute operation, follow these steps: 

1.    In the Model browser, open the Calculate diagram. 

2.    In the drawing area, right-click the Fib class and select Goto source. Select the submenu 
choice corresponding to the generated class.

3.    Delete the default entry class Fib and replace it with the following text:

class Fib
{
        int result;
        public int compute(int n)
        {
            if (n == 0)
                result = 1;
            else if (n == 1)
                result = 2;
            else
                result = n + compute(n - 1);
            return result;
        }

}

4.    Open the Program.cs file and change the Program class to

class Program

{

        static Implementation.Fib myFib;

        static void Main(string[] args)

        {

            myFib = new Implementation.Fib();

            int res = myFib.compute(Convert.ToInt32(args[0]));

            Console.WriteLine("The result was " + 
res.ToString());

        }

}
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Lesson 5: Generating C# Code and More
5.    Select File > Save All.

Task 1d: Viewing Model Updates
In this task, you view the updates that were made to the model when you added the code in the 
previous task. To view the updates in Rational Tau that you made in the previous task, follow these 
steps. 

1.    On the Rational Tau main menu, select C# > Update Model. Optionally you can perform 
this from Visual Studio using Tau > Create/Update Project.

2.    In the Rational Tau Model view, expand the Implementation package, then expand the 
Fib class. 

Notice that Rational Tau has added the operationBody element to the com-
pute(int):int operation, as shown in the following figure. This is a container in the 
model that stores the code implementing the behavior of compute.

Task 1e: Compiling C# Code
In this task, you compile the source code in Visual Studio. To compile your code, follow these 
steps. 
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Optional
1.    On the Console Application main menu, select Build > Build Console Application1. 

2.    Verify that a “Build suceeded” message is in the status bar in Visual Studio. 

Task 1f: Running your Application
The application you have modeled in this tutorial runs an algorithm that computes Fibonacci 
numbers. To run the application, follow these steps. 

1.    In a command window, navigate to your Visual Studio solutions directory. 

2.    In the Release directory, enter the following command: 

ConsoleApplication1 “n”

Where ConsoleApplication1 is the name of the executable and “n” is an integer rep-
resenting a number of years in the future. 

3.    Press Enter. The result is total number of seniors expected to be residing in the city in the 
number of years you specify. For example, if you entered 22, the total number of senior 
expected to be residing in the city in 22 years would be approximately 256. 

Optional
Depending on whether you prefer to work primarily in the model or the code Rational Tau has 
some options to help automate the updated. Rational Tau enables you automatically update your 
model, or your code based on settings specified after applying the TTDCSharp::CSharpSettings 
stereotype. This stereotype enables the following functionality: 

� Automatic model Update - This will update the model whenever the source code is 
saved.

� Automatic source generation - Whenever something is changed in the model the code 
will be updated.

� Support for roundtripping - Enables one to add new code and keep the model current.
To apply the C# stereotype, follow these steps.

1.    In the Model view, right-click Model, then select Properties. 

2.    Click Stereotypes.

In the Stereotypes dialog box, select the TTDCSharp::CSharpSettings checkbox. 
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Lesson 5: Generating C# Code and More
Summary
In this lesson, you generated C# code, manually added code, and ran your application. You learned 
how to 

� Export a C# package
� Edit source code
� Run your generated application
26 C# Tutorial



Conclusion
This tutorial has introduced you to UML modeling with IBM Rational Tau in a C# environment. 
By completing the exercises in this tutorial, you have become familiar with the Rational Tau 
product. You have learned how to:

� Create a project
� Use drawing tools and shortcut keys
� Draw diagrams
� Compile code
� Add external code to a model

Your knowledge of how to perform these tasks gives you a basic understanding of IBM Rational 
Tau. You will enhance your skills and product knowledge as you continue to work on UML 
modeling projects using this product. 
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Contacting IBM Rational Software Support
Technical Support and 
Documentation

Contacting IBM Rational Software Support
If the self-help resources have not provided a resolution to your problem, you can contact IBM® 
Rational® Software Support for assistance in resolving product issues.

Prerequisites
To submit your problem to IBM Rational Software Support, you must have an active Passport 
Advantage® software maintenance agreement. Passport Advantage is the IBM comprehensive 
software licensing and software maintenance (product upgrades and technical support) offering. 
You can enroll online in Passport Advantage from http://www.ibm.com/software/lotus/
passportadvantage/howtoenroll.html

� To learn more about Passport Advantage, visit the Passport Advantage FAQs at http://
www.ibm.com/software/lotus/passportadvantage/brochures_faqs_quickguides.html.

� For further assistance, contact your IBM representative.
To submit your problem online (from the IBM Web site) to IBM Rational Software Support, you 
must additionally:

� Be a registered user on the IBM Rational Software Support Web site. For details about 
registering, go to http://www.ibm.com/software/support/.

� Be listed as an authorized caller in the service request tool.
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Technical Support and Documentation
Submitting problems
To submit your problem to IBM Rational Software Support:

1.    Determine the business impact of your problem. When you report a problem to IBM, you 
are asked to supply a severity level. Therefore, you need to understand and assess the 
business impact of the problem that you are reporting.

Use the following table to determine the severity level.

2.    Describe your problem and gather background information, When describing a problem to 
IBM, be as specific as possible. Include all relevant background information so that IBM 
Rational Software Support specialists can help you solve the problem efficiently. To save 
time, know the answers to these questions:

� What software versions were you running when the problem occurred?
To determine the exact product name and version, use the option applicable to you: 

� Start the IBM Installation Manager and select File > View Installed Packages. 
Expand a package group and select a package to see the package name and version 
number. 

� Start your product, and click Help > About to see the offering name and version 
number. 

� What is your operating system and version number (including any service packs or 
patches)? 

� Do you have logs, traces, and messages that are related to the problem symptoms? 
� Can you recreate the problem? If so, what steps do you perform to recreate the 

problem? 

Severity Description

1 The problem has a critical business impact: You are unable to 
use the program, resulting in a critical impact on operations. 
This condition requires an immediate solution.

2 This problem has a significant business impact: The program is 
usable, but it is severely limited.

3 The problem has some business impact: The program is usable, 
but less significant features (not critical to operations) are 
unavailable.

 4 The problem has minimal business impact: The problem causes 
little impact on operations or a reasonable circumvention to the 
problem was implemented.
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� Did you make any changes to the system? For example, did you make changes to 
the hardware, operating system, networking software, or other system 
components? 

� Are you currently using a workaround for the problem? If so, be prepared to 
describe the workaround when you report the problem.

3.    Submit your problem to IBM Rational Software Support. You can submit your problem to 
IBM Rational Software Support in the following ways:

� Online: Go to the IBM Rational Software Support Web site at https://
www.ibm.com/software/rational/support/ and in the Rational support task 
navigator, click Open Service Request. Select the electronic problem reporting 
tool, and open a Problem Management Record (PMR), describing the problem 
accurately in your own words.

� For more information about opening a service request, go to http://www.ibm.com/
software/support/help.html

� You can also open an online service request using the IBM Support Assistant. For 
more information, go to http://www.ibm.com/software/support/isa/faq.html.

� By phone: For the phone number to call in your country or region, go to the IBM 
directory of worldwide contacts at http://www.ibm.com/planetwide/ and click the 
name of your country or geographic region. 

� Through your IBM Representative: If you cannot access IBM Rational Software 
Support online or by phone, contact your IBM Representative. If necessary, your 
IBM Representative can open a service request for you. You can find complete 
contact information for each country at http://www.ibm.com/planetwide/.

If the problem you submit is for a software defect or for missing or inaccurate documentation, 
IBM Rational Software Support creates an Authorized Program Analysis Report (APAR). The 
APAR describes the problem in detail. Whenever possible, IBM Rational Software Support 
provides a workaround that you can implement until the APAR is resolved and a fix is delivered. 
IBM publishes resolved APARs on the IBM Rational Software Support Web site daily, so that 
other users who experience the same problem can benefit from the same resolution.

Rational Tau Documentation
The IBM Rational Tau documentation provides information on most of the topics covered in this 
tutorial. Online help is available from the following locations: 

� From the Start menu, click Programs > IBM Rational  > IBM Rational 
Documentation > IBM Rational Tau version number.

� From the Help menu in the Rational Tau interface. 
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Technical Support and Documentation
The following table lists the Help topics that provide additional information on key concepts 
covered in this tutorial. 

Help Topic Reference Information
“UML and C#” General information on UML modeling using 

Rational Tau in a C# environment. 
“Working with Diagrams” Provides information on creating, saving, and 

printing diagrams, as well as other common 
diagram operations.

“UML Language Guide” Provides a complete list of UML language 
constructs and model elements
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