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Using the SLOC Agent with Rational ProjectConsole

1. Introduction

The SLOC Agent executable is designed to run standalone as well as with Rational ProjectConsole.  It parses files in a specified directory and creates a comma-separated-value (CSV) file containing the number of source-lines-of-code (SLOC) and the number of comments for each file within the directory.   If you wish to use the SLOC Agent standalone, please refer to the SLOC Agent Reference Manual.

The SLOC Agent supports Java™, C++, and C source files.  These files are identified by their file extensions, therefore, only files with extensions .java, .cpp, .c, and .h are recognized and processed.

This document will describe how to use the SLOCAgent with ProjectConsole.  It will describe how to configure the SLOC Agent to be used with ProjectConsole and then describe how to collect the SLOC metrics into ProjectConsole’s metric warehouse.

1.1 Pre-requisites

This document assumes that you have experience in setting up ProjectConsole collections, particularly in setting up text source collections.  If you do not, we recommend that you first go through the Rational ProjectConsole Tutorial sections that cover text source collections, especially Section 8.  Section 8 most resembles the steps involved in setting up this SLOC collection.

These instructions also assume that you are adding the SLOC collection to the existing Sample Metric Warehouse that is included and installed with the product.  The instructions will take advantage of the ProjectConsole feature which allows you to use existing dimension tables to store dimension attributes – in this case, attributes of SLOC measures.

Lastly, these instructions assume that you are using ClearCase and there assume that you wish to identify a VOB name as one of the attributes of the SLOC metrics.   NOTE: It is not a requirement that you use this ProjectConsole SLOC collection with ClearCase.  The SLOC collection will work with any source directory structure.

1.2 Setup/Configuration

The following directory reference is used throughout this document.  Substitute the value with your installed value:

InstallDir
e.g.:  C:\Program Files\Rational\ProjectConsole

The SLOCAgent package is delivered in a WinZip file, SLOCAgent.zip.   Contents are:

1. README.txt

2. SLOCAgent.exe

3. slocsample.txt

4. SLOCAgent_Reference_Manual.doc

5. Using_SLOCAgent_With_ProjectConsole.doc

Unzip the contents of the zip file into a temporary directory.  Perform the following actions:

1. Copy the SLOCAgent.exe to InstallDir\bin

2. Copy the slocsample.txt file to InstallDir\templates\designer

3. Copy the two documents to InstallDir\doc

2. Define a SLOC Collection

The steps involved in defining a ProjectConsole collection are as follows:

1. Define a text source template

2. Define the target tables

3. Define the mapping

4. Define the scheduled task

5. Run the task

These steps will be expanded in further details in the following sections.

2.1 Define the SLOC Text Source Template

The ProjectConsole text source template is used to parse the sample CSV text output file and identify the columns or fields that are in the CSV file.  Tagging them with a source field name will then identify these fields.

Perform the following steps:

1. Launch the Dashboard Designer

2. Create a Text Source Template (File>New>Text Source Template or press the [image: image1.jpg]


icon button).  Enter a name (e.g., “SLOC Template”).

[image: image2.jpg][_[CIx]

|| Source Template20157525
ot P | s

Narne :JELOG Termpite

Description





3. Click on the Source Fields Tab.  Select your host name and then Select slocsample.txt  as the Template File.

4. Hit the Add button.
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5. Rename the record to SLOC line.

6. Double-click the second row in the Lines box – the first line starting with SOURCE_FILE.  The SOURCE_FILE is a keyword that identifies rows that contain valid data.  (Notice that the first line does not have a SOURCE_FILE keyword.  This is because this line is a header line and does not contain data.  The header line is for information only.)
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7. Change the Delimiter to the comma character.  The token list will then automatically be expanded to show the tokens we are interested in because they are separated by a comma..
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8. SOURCE_FILE is a keyword, so check the Keyword column.

9. All other tokens are source fields.  For each field, specify the field name as shown in the dialog snapshot below:

[image: image6.jpg]2 Add Record
Record name [5LOC fine I Global

Lines:

, DirectoryPath, FileName, FullNarme, nSLOC, nbComment, Langt.4]
SURCE_FILE, csourcelepp, CommandLinePar urceicpp)
SOURCE_FILE, csourcelcpp, SLOCAgentjava, cisourcelcppiSLOCAge!

SOURCE_FILE, csourcelepp, CQCom.cpp, cisourceleppiCacom.cop, Ty,

Delimiter
Tokens

Tokenname | Keyword | Source field | Field name | _Position
SOURCE_FILE ¥ [m] o
cisourcelepp [u] 2 directoryPath |2
CommandLineP. [m] 2 fileName |3
clsourcelcppiCo. [m] 2 fullName |4
81 [m] 2 sLoC 5
75 =] ¥ comments 6

7]
Cancel Help

[Tava ApptWindom




10. Now click on the OK button.

11. Save this newly created text source template.

You have finished creating a text source template for the sample SLOC CSV file.  

The next step is to create the target tables.

2.2 Create the SLOC Target Tables

The target measure and dimension tables are used to store the values collected.  For this SLOC collection, you will need to create the following additional dimension target tables:

· DirectoryPath_Dim – Stores the extracted source field, directoryPath
· Language_Dim – Stores the extracted source field, language
· FileName_Dim – Stores the extracted source field, fileName
The following dimension tables will be reused.  If you are not starting with the Sample Metric Warehouse, then you must create these tables:

· Artifact_Dim – Stores the extracted source field, fullName
· Project_Dim – Not extracted from the CSV file, but can be set on the collection task

· Vob_Dim – Not extracted from the CSV file, but can be set on the collection task

The next set of instructions is for creating dimension tables.  Instructions are provided for creating the DirectoryPath_Dim table.  Use the instructions to similarly create the Language_Dim and FileName_Dim tables.

1. First, check out the schema from the ProjectConsole menu list “Schema>Check Out” or by pressing the [image: image7.jpg]


 icon button.

2. Create a dimension table (Select File>New>Dimension Table or press the [image: image8.jpg]


 icon button).  Rename table to DirectoryPath_Dim
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3. Click on the Target Fields tab

4. Select the row and press the Edit button.  Then change the field name to “Directory Path” and press OK.
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5. Save the dimension table.

Now repeat the instruction and create dimension tables for Language_Dim and FileName_Dim.

The next step is to create the measure target table.  For this example, we will name it, SLOC_Measure.

1. Create a measure table (Select File>New>Measure Table or press the [image: image11.jpg]


 icon button).  Rename the table to SLOC_Measure.
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2. Press the Target Fields tab.  Create the following fields:

Reference Fields:

· artifact_fk – a reference to the artifact_dim table.

· directoryPath_fk – a reference to the DirectoryPath_Dim table.

· fileName_fk – a reference to the FileName_Dim table.

· language_fk – a reference to the Language_Dim table.

· project_fk – a reference to the project_dim table.

· vob_fk – a reference to the vob_dim table.

Measure Fields:

· SLOC – an integer measure field.  Stores number of SLOC.

· Comments – an integer measure field.  Stores number of comments.

· In addition, rename the measure display name to Source Items.  This existence measure can be used to count the number of rows collected from the source CSV file.

Here is a screenshot example.  Your SLOC_Measure table should look like:
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3. Now save the measure table by pressing the icon button.

4. Check in the schema by pressing the [image: image14.jpg]


 icon button.   Be sure to upgrade the warehouse when prompted.

You are finished creating the SLOC target tables.

The next step is to create the mapping.  

2.3 Create the SLOC Mapping

The mapping maps target fields with extracted source fields.

Perform the following steps:

1. Create a new mapping (File>New>Mapping or press the [image: image15.jpg]


 icon button).  Name it “SLOC Mapping”.
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2. Press the Mappings tab.  Select SLOC_Measure for the target table and SLOC Template for the source template.

Map the source fields identified in the SLOC Template to the target fields in SLOC_Measure as defined in the following dialog screenshot:  
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3. Note that the vob and project fields are not mapped since these values are not defined in the source template because they are not in the CSV file.  At this point, you can define default values in the mapping or you can specify the values in the scheduled tasks.  We will specify the values in the scheduled tasks.

4. Now save the mapping.

You have created the mapping for the SLOC collection.

The next step is to create scheduled tasks.

2.4 Create the SLOC Scheduled Tasks

Scheduled tasks are used to perform the actual collections.  In the task, you define which mapping you wish to execute.  In addition, you can supply values for any target fields which are not extracted or collected from the source, such as the vob and project fields in our SLOC example.  You will also specify in the task to also execute the SLOCAgent as part of the scheduled task’s startup commands.

Again this example assumes that you are interested in collecting from ClearCase VOBs.  So, for this example, we will use the following mounted VOB paths.

Z:\dash.analyzer

Z:\id.portal

You can substitute these VOB names with your own VOB names.  Or you can substitute a directory name containing any source directory structure.

These two ClearCase VOBs have a mixture of Java and C++ code.  

Perform the following steps to create a collection for the dash.analyzer VOB:

1. Create a Scheduled Task (File>New>Scheduled Task or press the [image: image18.jpg]


 icon button).  Name it SLOC dash.analyzer Collection.  Select the Host Name.  Select the SLOC Mapping.
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2. Press the Parameters tab.  In the Startup Commands text box, type in the specified command as shown in the following screenshot.  Refer the SLOC Agent Reference Manual for details on the parameters provided.  In addition, click on the SourceInstance value parameter cell and change the name from slocsample.txt to dashanalyzer.txt.  NOTE: This name must match the name supplied in the outputFile parameter.
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3. At this point, you can add the field values for vob and project by pressing the Add button.  For vob, set the value to dash.analyzer because that is the actual name of the VOB.  For project, set the value to Dashboard (our SLOC example project name).
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4. Press the Schedule tab and define a schedule.

5. Save the scheduled task.

Now perform the following steps to create a collection for the id.portal VOB:

6. Create a Scheduled Task (File>New>Scheduled Task or press the [image: image22.jpg]


 icon button).  Name it SLOC id.portal Collection.  Select the Host Name.  Select the SLOC Mapping.

7. Press the Parameters tab.  In the Startup Commands text box, type in the specified command as shown in the following screenshot.  Then click on the SourceInstance value parameter cell and change the name from slocsample.txt to idportal.txt.  NOTE: This name must match the name supplied in the outputFile parameter.

8. Add the field values for vob and project by pressing the Add button.  For vob, set the value to id.portal because that is the actual name of the VOB.  For project, set the value to Portal (our project name for the second VOB).
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9. Set the schedule.

10. Save the task.

You have completed creating the tasks for the SLOC collections.

At this point, you are ready to run the collections.  Go to the next section.

3. Run the SLOC Collections

If you defined a schedule for each task, then the collections will automatically run.   If you wish to manually run the tasks, you will use the ProjectConsole Administrator.  For this example, we will run the tasks manually.  

Perform the following steps:

1. Terminate the Designer tool if you have not done so already.

2. Start the ProjectConsole Adminstrator from the ProjectConsole Web site.

3. Expand the Scheduled Tasks branch in the Administrator’s navigation tree.

4. Scroll down and click on SLOC dash.analyzer Collection.  The details dialog should pop up on the right pane.  Select Task>Run.
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5. A dialog will pop up saying the task is running. Press OK.

6. Search for and open the task log under the Scheduled Task Logs branch or in the Scheduled Task Log Summary dialog.
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7. Repeat the steps and run the SLOC id.portal Collection.

You are finished running the SLOC collection.

The next step is to view the results using the ProjectConsole Dashboard.  

4. View Results Using Dashboard

Perform the following steps:

1. Terminate the Administrator if you have not done so already.

2. Run the Dashboard from the ProjectConsole Web site.

3. Create a Private Metrics Panel (select File>New>Private Metrics Panel or press the [image: image26.jpg]


 icon button).

4. Create a chart (select Chart>Insert or press the [image: image27.jpg]


 icon button).

5. In the chart properties, change the chart type to Distribution.  For the Y-Axis, scroll down and select SLOC and Comments.  For the X-Axis, select project.
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.

6. Press OK.  A line chart appears.  Resize the chart.  Distribution charts are best viewed using a bar chart, so move the cursor over the chart and right-mouse-click select Display Type>Bar Chart.  You have created a simple distribution chart showing SLOC and Comment counts by project.
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7. Now try drilling-down on the Portal bars and view the breakdown by Language.  Now you see a chart showing the number of SLOCs and Comments by language for the Portal project.
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8. Now on your own, create other SLOC charts and indicators.

You have successfully viewed the results of the SLOC collections!

5. Conclusion

You have now successfully executed the entire thread for using the  with Rational ProjectConsole! 

Let’s review the steps involved for the SLOC collection:

1. From the Designer tool, create a Text Source Template defining the contents of the SLOCAgent tool CSV output file.

2. Create the target tables to store the data

3. Create the mapping of source fields to target fields

4. Create a scheduled task for the mapping.  Be sure to execute the SLOCAgent tool on the Startup Commands.   Also define a schedule for the task if you wish to automate the collection.

5. Optionally, manually run the task using the Administrator tool.

6. View the results of the collection using the Dashboard tool.

By following these instructions, we have shown you how you can easily integrate the SLOCAgent code counting with Rational ProjectConsole and add source-lines-of-code metrics to your ProjectConsole metrics warehouse.
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