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About this book

This installation guide provides instructions for installing and uninstalling IBM®
Rational® Developer for System z® 8.0.1.

This document contains information on the following tasks:

* Preparing for installation

¢ Installing IBM Rational Developer for System z

* Installing required and optional workstation software

¢ Installing System z components

¢ Installing RSE Server for Multiplatform

* Recognizing known problems and limitations with installation

The following names are used in this manual:
* IBM Rational Developer for System z is called Developer for System z

* IBM Rational Developer for System z Common Access Repository Manager is called
Common Access Repository Manager, abbreviated to CARMA

Note: The configuration information found in this document is for IBM Rational
Developer for System z Version 8.0.1.

The information in this document applies to all Rational Developer for System z
v8.0.1 packages including IBM Rational Developer for zEnterprise.

Who should read this book

This book is intended for programmers installing and configuring Developer for
System z 8.0.1 client on their workstation. To use this book, you need to be familiar
with the Microsoft Windows operating system, the Red Hat Linux operating
system, or the SUSE Linux operating system.

Where to find more information about Developer for System z

This document does not contain information about using Developer for System z.
Refer to the online help for that information.

For information about product problems and limitations, refer to the
rdz80_releasenotes.html file located in the Documents\n1\en\readme directory of
the IBM Rational Developer for System z Installation disk or IBM Rational Developer for
zEnterprise Installation disk.

See the Library page of the Developer for System z Web site: http://www.ibm.com/

software/rational/products/developer/systemz/1ibrary/index.html for updated
documentation and troubleshooting information.

© Copyright IBM Corp. 2000, 2010 ix
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Chapter 1. Introduction to Developer for System z

Developer for System z has a host component and a workstation client component.
The host component is typically installed by a site's system programmer and is
transparent to the application programmers. For the remainder of this guide,
unless the host component is specifically called out, the term Developer for System
z will refer to the workstation component of the tool - the graphical user interface
powered by the Eclipse platform.

Developer for System z is a set of development tools built on the Eclipse platform
(www.eclipse.org). Think of the Eclipse platform as the framework and Developer
for System z and other bundled offerings as the tool contributors.

Preinstallation tasks

About this task

Before you install the product, complete the steps listed below:

1. Confirm that your system meets the requirements described in the section
[Chapter 2, “Client installation requirements,” on page 3]

2. Confirm that your user ID meets the required access privileges for installing the
product. See [“User privileges requirements” on page 9.

3. Read the section [Chapter 3, “Planning to install,” on page 11

© Copyright IBM Corp. 2000, 2010 1



2 IBM Rational Developer for System z 8.0.1: Installation Guide



About this task

Chapter 2. Client installation requirements

To prepare for installation, you need to confirm the following:

* Media requirements
¢ Hardware and software requirements

Media requirements

You can match references to physical disks with references to electronic image

directories as shown in the following table:

Table 1. Disk name and electronic image references

Disk Name

Electronic Image Directory Name

IBM Rational Developer for System z with EGL
Installation disk or IBM Rational Developer for
System z with Java Installation disk

* RDz801Edition_Setup

* RDz801Edition\diskl

* RDz801 UMLProfiles\diskl
* RDz801_RTCz\diskl

¢ RTC30\diskl

Note: The value for £dition depends on
the edition of Developer for System z.

IBM Rational Developer for zEnterprise
Installation disk

* RDz801Ent_Setup

* RDz801Ent\diskl

* RDz801 UMLProfiles\diskl
* RDz801 RTCz\diskl

* RTC30\diskl

IBM Rational Developer for System z z/OS® and
Multiplatforms Server Installation disk

* RDz801_z0S_SMPE
* RDz801 RSE

IBM Rational Developer for zEnterprise zOS and
Multiplatforms Server Installation disk

* RDz801_z0S_SMPE
* RDz801Ent RSE

IBM Rational Developer for System z Quick Start
and Documentation disk

* RDz801 QuickStart
* RDz801 Documentation

IBM Rational Developer for zEnterprise Quick
Start and Documentation disk

* RDz801Ent_Documentation
* RDz801Ent_QuickStart

You must have access to either of the following media to install Developer for

System z on the workstation:

* Developer for System z installation disk:

— IBM Rational Developer for System z Installation disk or IBM Rational Developer

for zEnterprise Installation disk

* Developer for System z electronic image

© Copyright IBM Corp. 2000, 2010
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Once you have downloaded the Developer for System z images from Passport
Advantage® and expanded them, the following directories apply to installing
Developer for System z on the workstation:

— RDz801Edition Setup
— RDz801Edition\diskl
Or:

— RDz801Ent_Setup

— RDz801Ent\diskl

Media for additional offerings

In addition to the Developer for System z media, you will have additional
installation media for other offerings that are bundled with Developer for System
z. This may include IBM Rational Business Developer or IBM Rational Application
Developer. The bundled software you have will depend on which edition of
Developer for System z you purchased. For the remainder of this document, these
offerings that are bundled with Developer for System z will be referred to as the
bundled offerings.

In order to install required System z components on the System z host, you must
have access to either of the following media:
* IBM Rational Developer for System z:

— IBM Rational Developer for System z Server for zOS and Multiplatforms Server
Installation disk or IBM Rational Developer for zEnterprise Server for zOS and
Multiplatforms Server Installation disk

* IBM Rational Developer for System z electronic image:
Once you have downloaded the Developer for System z images from Passport

Advantage and expanded them, the following directory applies to installing
required software on the System z host:

— RDz801_z0S_SMPE
See the Program Directory for IBM Rational Developer for System z (GI11-8298) and the

IBM Rational Developer for System z Host Configuration Quick Start Guide (GI11-9201)
for details on installing required System z server tools.

In order to install the UML Profiles for COBOL Development Extension, you must
have access to either of the following media
 IBM Rational Developer for System z

— IBM Rational Developer for System z with EGL Installation disk, or IBM Rational
Developer for System z with Java Installation disk, or IBM Rational Developer for
zEnterprise Installation disk

 IBM Rational Developer for System z electronic image

Once you have downloaded the Developer for System z images from Passport
Advantage and expanded them, the following directory applies to installing the
UML Profiles for COBOL Development extension:

— RDz801 UMLProfiles\diskl

See [“Installing the UML Profiles for COBOL Development extension” on page 67]
for details on installing this software.

In order to install the Rational Team Concert” Integration extension, you must
have access to either of the following media:

 IBM Rational Developer for System z installation disks
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— Rational Developer for System z with EGL Installation disk, or Rational Developer
for System z with Java Installation disk, or Rational Developer for zEnterprise
Installation disk

* IBM Rational Developer for System z electronic images

Once you have downloaded the Developer for System z electronic images, the

following directory applies to installing the extension:

— RDz801_RTCz\disk1l

See [‘Installing the Rational Team Concert Integration extension” on page 68 for
details on installing this software.

Hardware and software requirements

The following information on hardware and software requirements for Developer
for System z, is also available in Prerequisites for IBM Rational Developer for System z.
The Prerequisites document contains the most current information about hardware
and software requirements. A link to the Prerequisites document can be found on
the library page of the Developer for System z Web site:

http://www.ibm.com/software/rational/products/developer/systemz/1ibrary/
index.html.

Client prerequisites for Developer for System z

Developer for System z is a licensed program to support users who want to write
large-scale business applications.

There are prerequisites and corequisites for using this software.
Hardware requirements
Verify that you meet the minimum hard disk space requirements to install the

product. The following table provides an account of space requirements according
to each aspect of the installation process:

Hardware Requirements

Processor 1 GHz or faster 32-bit (x86) or 64-bit (x64) processor

A dual or quad core is recommended.

Memory 2 GB RAM minimum

Recommended: 3GB RAM or more

Chapter 2. Client installation requirements 5



Hardware

Requirements

Disk space

1.1 GB of disk space is required to install the IBM Rational Developer
for System z minimum set of features.

1.8 GB of disk space, plus 210 MB of temporary space, is required for a
full installation of IBM Rational Developer for System z. This includes
Installation Manager and IBM Rational Developer for System z.

5 GB of disk space is recommended when installing other bundled
software.

* Disk space requirements can be reduced depending on the features
that you install.

* Additional disk space is required for the resources that you develop.

* Additional disk space is required if you download the electronic
image to install the product.

» Additional disk space is required if you use FAT32 instead of NTFS.

Display

1024 x 768 resolution using 256 colors

A higher resolution and color palette is recommended.

Other hardware

Microsoft mouse or compatible pointing device

Workstation prerequisites

Before you can install the product, verify that your system meets the software

requirements.

Operating systems:

The following operating systems are supported for this product:

Product Name PTFs or Service Levels Required
Microsoft Windows XP Professional Service Pack 3 or later
Microsoft Windows Server 2003 Enterprise Service Pack 1 or later
Edition

Microsoft Windows Server 2003 Standard Service Pack 1 or later
Edition

Microsoft Windows Server 2008 Enterprise No Service Level Required
Edition

Microsoft Windows Server 2008 Standard No Service Level Required
Edition

Microsoft Windows Vista Business Service Pack 1

Microsoft Windows Vista Enterprise Service Pack 1

Microsoft Windows Vista Ultimate Service Pack 1

Microsoft Windows 7 Professional Edition No service level required
Microsoft Windows 7 Enterprise Edition No service level required
Microsoft Windows 7 Ultimate Edition No service level required
Red Hat Linux Desktop v 5.0 32 bit No service level required
Red Hat Linux Desktop v 6.0 32 bit No service level required
Red Hat Linux Enterprise Server v 5.0 32 bit | No service level required
Red Hat Linux Enterprise Server v 6.0 32 bit | No service level required
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Product Name

SUSE Linux Enterprise Server v 10.0 32 bit
SUSE Linux Enterprise Server v 11.0 32 bit
SUSE Linux Enterprise Desktop v 10.0 32 bit
SUSE Linux Enterprise Desktop v 11.0 32 bit

PTFs or Service Levels Required

No service level required

No service level required

No service level required

No service level required

Microsoft Windows 2008 Enterprise Server R2 | No service level required

Microsoft Windows 2008 Standard Edition R2 | No service level required

Note:

1. Creating Windows COBOL or PL/I binaries using Developer for System z
compilers is not supported in Windows 7, Windows Server 2008 R2, or Linux.
Please use another supported operating system in order to take advantage of
this functionality.

2. Developer for System z supports the 32 bit edition of all the Windows
Operating Systems listed. In addition, Developer for System z supports 32 bit
compatability mode of the Windows 7 64 bit editions and Windows 2008 R2 64
bit editions.

3. Developer for System z language support is dependent on the above listed
operating systems having the base language support.

4. Developer for System z was developed for use with Eclipse IDE version 3.6.1
that uses at least version 1.6 of the IBM Java Development Kit (JDK). You can
only extend an existing Eclipse IDE that meets these requirements.

Hosted Development Environments/Virtualization Support:

PTFs or Service Levels
required

Product Name Version

Windows Terminal Services Windows 2008 and later all available maintenance

Citrix® (32 bit and 64 bit)

Presentation Server 4.X

all available maintenance

VMware®

Server version 2.0,
Workstation

all available maintenance

VMware®

vSphere 4.0 ESXi

all available maintenance

Note: Developer for System z supports running under the Citrix virtual
environment using 64 bit Windows in 32 bit mode compatibility.

For additional information about Software support services for IBM SWG products
in a virtualization environment, see [Software support for IBM SWG products in 4|
VMware environment| and [Support Policy for Citrix Metaframe and Rational Team|
Unifying Platform version 7.0|

Workstation corequisites
Developer for System z requires the software listed in this section to be installed as
a prerequisite to installation depending on the Developer for System z functions

you select to install.

Note: For information about supported database servers, Web application servers,
and other software products, see the online help.
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TXSeries for Multiplatforms:
Note: There is no TXSeries support on the Developer for System z Linux client.

One of the following levels must be installed to support applications with
embedded CICS® statements:

Program | Product Name PTFs or Service Levels Required
Number

5724-B44 | TXSeries for Multiplatforms v 7.1 all available maintenance

5655-M15 | TXSeries for Multiplatforms v 6.2 all available maintenance

5655-M15 | TXSeries for Multiplatforms v 6.1 1700893

The related product Web site is as follows:

http:/ /www.ibm.com /software /htp / cics/ txseries /|

DB2 for Windows:

To support applications with embedded SQL statements, one of the following
levels must be installed:

Program | Product Name PTFs or Service Levels Required
Number

5765-F35 | DB2® Workgroup Server Edition v 9.7

5724-B55 DB2 Connect Personal Edition v 9.7

5765-F41 | DB2 Enterprise Server Edition v 9.7 for
Windows

The related product Web site is:

lhttp:/ /www.ibm.com /software/data/db2/9 /|

Note: DB2 Workgroup Server Edition v9.7 is required for precompilation and DB2
Connect " Personal Edition v9.7 is required for access to host databases.

Rational Software Architect:

To use the COBOL Generation from UML feature, the following application must
be installed:

Program | Product Name PTFs or Service Levels Required
Number

5724-V88 | Rational Software Architect v 8.0.1

The related product Web site is:

lhttp:/ /www-01.ibm.com /software /awdtools /swarchitect/standard /|

Web Browser:
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To view the readme files and the installation guide, one of the following Web

browsers must be installed:

Product Name

PTFs or Service Levels Required

Microsoft Internet Explorer 7.0 or later

all available maintenance

Firefox 1.5.x or later

all available maintenance

Adobe Acrobat Reader:

The following software must be installed to properly view product documentation

PDFs:

Product Name

PTFs or Service Levels Required

Adobe Acrobat Reader Version 7.0 or later

all available maintenance

User privileges requirements

You must have a user ID that meets the following requirements before you install

IBM Rational Developer for System z.

* Your user ID must not contain double-byte characters.

* To install for all users of the system, you must have an ID that belongs to the
Administrators group. If you do not have Administrator privileges, you can only

install for the current user.

Chapter 2. Client installation requirements 9
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Chapter 3. Planning to install

Read all topics in this section before attempting to install any of the product
features. Many problems may be avoided by proper planning and understanding
the key aspects of the installation process before actually beginning installation.

Installation methods

There are a number of methods that you might use when installing Developer for
System z.

Some factors that might determine the installation method you use are the
following:

¢ The format and method by which you access your installation files (for example,
from installation disks or files downloaded from IBM Passport Advantage)

* If you are installing onto your own workstation, or if you are making the
installation files available to your enterprise.

* If you install using the Installation Manager GUI, or if you install silently.

The typical installation methods you might use are the following;:

* Installing from the installation disks

¢ Installing from a downloaded electronic image on your workstation
* Installing from an electronic image on a shared drive

¢ Installing from a repository on an HTTP server

Note: With the latter three methods you could choose to run the Installation
Manager program in silent mode to install Developer for System z. For details on
running Installation Manager in silent mode, see [“Silent installation” on page 31/

Installing from installation disks

With this method, you have the installation disks containing the installation files,
and typically you are installing Developer for System z on your own workstation.
Refer to[‘Overview: Installing Developer for System z from the installation disks’]

fon page 23|for an overview of the steps.

Using electronic images

Extracting electronic images

If you download the installation files from IBM Passport Advantage, you must
extract the electronic images from the compressed files for Developer for System z
and any bundled offerings you wish to install before you can begin the installation.
Developer for System z electronic images are packaged as zip files.

Installing from a downloaded electronic image on a workstation
With this method, you have downloaded the installation files from IBM Passport
Advantage and you will install Developer for System z on your own workstation.
Refer to|“Overview: Installing Developer for System z from an electronic image on|
[your workstation” on page 24| for an overview of the steps.

© Copyright IBM Corp. 2000, 2010 11



Installing from an electronic image on a shared drive

With this method, you will place the electronic image on a shared drive so that
users in your enterprise can access the installation files for Developer for System z
from a single location. Refer to [“Overview: Installing Developer for System z from|
lan electronic image on a shared drive” on page 25[for an overview of the steps.

Installing from a repository on an HTTP server

This method provides an alternative way to install across a network. This differs
from the previous method because, in order to place installation files for Developer
for System z on an HTTP Web server, you must use a utility application - IBM
Packaging Utility - which is provided with the Developer for System z installation
media. IBM Packaging Utility is used to copy the installation files in a package
format that can be used for installing Developer for System z directly from an
HTTP Web server. The directory on the HTTP Web server that contains the
package is called a repository. The same repository can also be used for other
offerings, as well as future service updates. Refer to|“Overview: Installing|
Developer for System z from a repository on a HTTP Web server” on page 25 and
“Overview: Placing Developer for System z on an HTTP Web server” on page 26|
for an overview of the steps.

Feature installation

12

You can customize your Developer for System z installation by selecting which
features and bundled offerings you want to install. The Developer for System z
launchpad provides you with the option of a guided installation or an expert
installation.

For more information about the Developer for System z launchpad program, refer
to [“Using the launchpad program” on page 26

Installation Manager automatically enforces any dependencies between features
and prevents you from deselecting any features that are required.

Note: Once you finish installing the package, you can still add or remove features
from your installation by running the Modify Packages wizard in Installation
Manager. See [Chapter 8, “Modifying installed packages,” on page 59 for more
information.

Features for Developer for System z

The following table shows the features of Developer for System z that you can
choose to install. For information about the available features of other offerings
that are bundled with Developer for System z, see the documentation for those
offerings.

Table 2. Developer for System z features

Feature Description
System z Integrated Development Provides an interactive, workstation-based
Environment (required) environment where you can connect to a

mainframe and develop mainframe-based
applications in COBOL, PL/I, Assembler, C/C++,
and Java, as well as workstation-based
applications in COBOL, PL/1, and Java. This
feature also includes connectivity to other
environments, such as AIX® and Linux for System
Z.
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Table 2. Developer for System z features (continued)

Feature

Description

COBOL and PL/I for Windows**

** See explanatory note after this table.

Enables creation of Windows binaries for COBOL
and PL/I programs for use in unit testing
applications locally with Windows shell scripts or
in the CICS TX Series runtime. This feature is not
required for local syntax check; the local syntax
check capability is enabled by selection of the
System z Integrated Development Environment
feature.

System z Code Generators

Provides design tools and wizards which allow
you to rapidly create System z application code
skeleton and logic from UML models or
user-provided input.

SCLM Developer Toolkit

Provides tools to access and work with Software
Configuration and Library Manager (SCLM)
managed source code.

Rational ClearCase® SCM Adapter

Provides the IBM Rational ClearCase SCM and
ClearCase MVFS plug-ins, which enable
versioning of software artifacts in ClearCase
versioned object bases (VOBs) using snapshot
views and dynamic views when ClearCase VOB
and view servers are also installed.

CA Endevor Software Change
Manager

Provides tools to access and work with CA
Endevor Software Change Manager managed
source code.

Enterprise Service Tools for CICS
(including Service Component
Architecture)

Enterprise Service Tools for CICS provide an
integrated set of tools that support modern
application architectures and the transformation
and reuse of existing CICS application processes.
The tools support generation of Web service
descriptions and service flow processing artifacts
directly to a z/OS system, including CICS TS and
the CICS Service Flow Runtime. Enterprise Service
Tools quickly enable the move towards
service-oriented architecture (SOA).

BMS Screen Designer

Enables you to visually create and modify Basic
Mapping Support (BMS) map sets. It is designed
for CICS developers who are familiar with
terminal-based tools (for example, SDF II) or
GUI-based tools, such as the BMS editor included
with VA COBOL.

CICS Code Generators

Provides design tools and wizards which allow
you to rapidly create CICS Transaction Server
application code skeleton and logic from UML
models or user-provided input, for example, using
UML models or database schema definitions to
generate CICS transactions which provide Create,
Read, Update, and Delete interfaces to DB2 tables.
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Table 2. Developer for System z features (continued)

Feature

Description

™

Enterprise Service Tools for IMS

Enterprise Service Tools for IMS provide an
integrated set of tools that support modern
application architectures and the transformation
and reuse of existing IMS application processes.
The tools support generation of Web service
descriptions and processing artifacts directly to a
z/0S system, including the IMS SOAP Gateway
and IMS info 2.0 applications. Enterprise Service
Tools quickly enable the move towards
service-oriented architecture (SOA).

MES Screen Designer

Enables you to create and modify Message Format
Service (MFS) message and format files. Many
Information Management System (IMS) programs
are based on MFS, which is an IMS Transaction
Manager environment facility that formats
messages to and from terminal devices.

IMS Code Generators

Provides code snippets which allow you to rapidly
add common programming objects to IMS
application code.

Data Tools

Provides relational database tools to work with
tables, table views, and filters. With these tools,
you can create physical database models by means
of reverse engineering database tables or using
DDL scripts. You can also use the tools to create
SQL statements, DB2 routines (such as stored
procedures and user-defined functions), and
several types of files, including SQLJ, SQL DDL,
and XML files.

System z Stored Procedures

Enables you to create, test, and deploy DB2 stored
procedures written in COBOL, PL/I, Java, or SQL
directly to a z/OS system.

File Manager (available only on
Windows)

Provides IBM File Manager for z/OS capabilities,
including a formatted edit session with multiple
views of the data of many dataset types, to
Rational Developer for System z.

Note: This feature requires that you have a license
for IBM File Manager for z/OS.

Fault Analyzer (available only on
Windows)

Enables you to work with fault entries created by
IBM Fault Analyzer for z/OS during real-time
analysis of abending programs.

Note: This feature requires that you have a license
for IBM Fault Analyzer for z/OS

Common Access Repository Manager
(CARMA)

Provides a unified interface and set of services for
accessing System z-based source control
management tools. CARMA also provides a
generic graphical user interface (GUI) client that
can be used as a framework for accessing and
interfacing with custom source control
management systems.

Plug-in Development Environment
(PDE)

Provides tools for creating, developing, testing,
debugging, and deploying Eclipse plug-ins, which
can be used to extend the Rational Developer for
System z Eclipse environment.
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Note: ** COBOL and PL/I for Windows is not available on Windows 7, Windows
2008 R2, or Linux platforms.
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Chapter 4. IBM Installation Manager

The IBM Installation Manager is a program that installs Developer for System z
and other packages on your workstation. It also updates, modifies, and uninstalls
these and other packages that you install. A package can be a product, a group of
components, or a single component that is designed to be installed with the
Installation Manager.

For the most current information on the IBM Installation Manager, see the
Installation Infocenter at:

http:/ /publib.boulder.ibm.com/infocenter/install /v1r4/index.jsp

Installation Manager is an installation management tool that offers a number of
time-saving features. It helps you install, update, modify, and uninstall product
packages on your computer. It keeps track of what you are about to install, as well
as what you have already installed and what is available for you to install. It
searches for updates so you know that you are installing the latest version of a
package. It also provides tools for managing licenses for the packages it installs,
and for updating and modifying packages.

For the most current information on how to deploy Developer for System z to
many users, see the information available in the Installation Manager Infocenter
and on the Rational Installation Wiki at:

https:/ /www.ibm.com/developerworks/wikis/display/rationalinstall/Home

There are six wizards in Installation Manager that make it easy to maintain your
package through its lifecycle, as follows:

* The Install Packages wizard walks you through the installation process. You can
install a package by simply accepting the defaults, or you can modify the default
settings to create a custom installation. Before you install, you are provided with
a complete summary of your selections throughout the wizard. Using the wizard
you can install one or more packages at one time.

¢ The Update Packages wizard searches for available updates to packages you
have installed. An update might be a fix that was released, a new feature, or a
new version of the product. Details of the contents of the update are provided in
the wizard. You can choose whether to apply an update.

¢ The Modify Packages wizard modifies certain elements of a package you have
already installed. During your first installation of the package, you select the
features you want to install. If you find later that you require other features, you
can use the Modify Packages wizard to add them to your package. You can also
remove features, and add or remove languages.

* The Roll Back Packages wizard allows you to uninstall updates you have
installed for a product and revert to a previous version of that product.

* The Manage Licenses wizard helps set up the licenses for your packages. Use
this wizard to change your trial license to a full license, to set up your servers
for floating licenses and to select which type of license to use for each package.

* The Uninstall Packages wizard removes a package from your computer. You can
uninstall more than one package at a time.
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Installing Installation Manager
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About this task

IBM Installation Manager is typically installed automatically as part of the
Developer for System z installation process.

If you need to install IBM Installation Manager by itself, without installing
Developer for System z, the IBM Installation Manager installer is provided as a zip
file called im.installer.win32.zip in the IMInstaller_Win directory (for Windows
installations) and im.installer.linux.zip in the IMInstaller_Linux directory (for
Linux installations) on the IBM Rational Developer for System z Installation Setup
disk if you are using physical installation disks, or in the RDz801£dition_Setup
directory if you downloaded an electronic image. To install IBM Installation
Manager take the following steps:

1.
| Windows |

Unzip the im.installer.win32.zip file to a temporary directory on your
system to extract the installation files.

Unzip the im.installer.linux.zip file to a temporary directory on your
system to extract the installation files.

If you wish to share the IBM Installation Manager installation image with other
users in your enterprise, you can also extract the files to a location on a shared
drive where other users can access the image.

| Windows |

If you are installing as an Administrator for all users on the system, run the
install.exe program, located at the root of the directory in which you
extracted the IBM Installation Manager installation image. If you are installing
as a non-administrator for the current user only, run the userinst.exe program.

If you are installing as an Administrator for all users on the system, run the
install program, located at the root of the directory in which you extracted the
IBM Installation Manager installation image. If you are installing as a
non-administrator for the current user only, run the userinst program.

3. Follow the prompts on the screen to install IBM Installation Manager.

You can also perform a silent installation of the Installation Manager using the
following steps:

1.
| Viindows |

Unzip the im.installer.win32.zip file to a temporary directory on your
system to extract the installation files.

Unzip the im.installer.linux.zip file to a temporary directory on your
system to extract the installation files.
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If you wish to share the IBM Installation Manager installation image with other
users in your enterprise, you can also extract the files to a location on a shared
drive where other users can access the image.

2. Run the following command from the root of the directory where you extracted
the installation image to silently install IBM Installation Manager:

| Viindows |

Administrator installation:

installc.exe --launcher.ini silent-install.ini

Administrator installation:
install --launcher.ini silent-install.ini

| Windows |

Non-administrator installation:
userinstc.exe --launcher.ini user-silent-install.ini

Non-administrator installation:
userinst --launcher.ini user-silent-install.ini

For more information about installing IBM Installation Manager, refer to the IBM
Installation Manager documentation.

Starting Installation Manager
About this task

IBM Installation Manager is installed and started automatically when you perform
the Developer for System z installation.

| Vindows |

If you need to start Installation Manager manually to update, modity, roll back, or
uninstall packages following the installation, do the following:

1. Open the Start menu from the Taskbar.

2.
* For an administrator installation, select All Programs -> IBM Installation
Manager -> IBM Installation Manager.
* For a non-administrator installation, select All Programs -> My IBM
Installation Manager -> IBM Installation Manager
| Linux |

If need to start Installation Manager manually to update, modify, roll back, or
uninstall packages following the installation, do the following:

1. Open a terminal window.

2. Change to <Installation Manager install directory>/eclipse
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3. Run ./IBMIM

Uninstalling Installation Manager

About this task

|_Vindows |

The IBM Installation Manager must be uninstalled using the Add or Remove
Programs panel.

1. Open the Start menu from the Taskbar.

2. Select Control Panel -> Add or Remove Programs -> IBM Installation
Manager.

3. Click the Remove button and follow the instructions provided by the operating
system.

Note: You cannot uninstall IBM Installation Manager until all packages have been
uninstalled.

Perform the following steps to uninstall Installation Manager:
1. Open a terminal window.

2. Run /var/ibm/InstallationManager/uninstall/uninstall.

Using Installation Manager

20

Installation repositories

Installable offerings, or packages, are stored in locations called repositories, which
can be on an HTTP Web server, shared network drive, physical disks, or your local
machine. Installation Manager retrieves packages from these repositories to install
them on your system.

When you launch the installation of Developer for System z from the launchpad
program, the necessary repository information is passed to Installation Manager
automatically. Anytime you start Installation Manager manually from the Windows
Start menu, you must specify the repositories that contain the packages you want
to install in the Installation Manager repository preferences so that Installation
Manager knows where to look for them. See [“Setting repository preferences in|
[[nstallation Manager” on page 21|for more details.

Some organizations may bundle and host their own product packages within their
intranet. For this type of business case scenario, see [“Installing from a repository|
fon an HTTP server” on page 12 Your system administrators will need to provide
you with the correct URL.

By default, IBM Installation Manager uses an embedded URL in each package you
install to connect to a repository server through the Internet and search for
installable packages, such as service updates and new features.
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Setting repository preferences in Installation Manager

About this task

When you start the installation of Developer for System z from the launchpad
program, the necessary repository information is automatically passed to
Installation Manager when it starts. However, if you start Installation Manager
manually from the Windows Start menu, for example to install packages from a
repository located on a Web server, then you must add the repository location in
the Installation Manager preferences before you can install the package. This is
done on the Repositories panel of the Preferences window in Installation Manager.
By default, Installation Manager uses an embedded URL in each Rational software
development product to connect to a repository server through the Internet and
search for installable packages, updates, and new features. Your organization may
require you to redirect the repository to use intranet sites.

Note: Before starting the installation process, be sure to obtain the installation
package repository URL from your administrator.

To add, edit, or remove a repository location in Installation Manager, take the
following steps:

1. Start Installation Manager.

2. On the Start page of Installation Manager, click File -> Preferences, and then
click Repositories. The Repositories page opens, showing any available
repositories, their locations, and whether or not they are accessible.

3. On the Repositories page, click Add Repository.

4. On the Add repository window, enter the URL of the repository location or
browse to it and enter a file path, and then click OK. The new or changed
repository location is listed. If the repository is not accessible, a red x is
displayed in the Accessible column.

5. Click OK to exit.

Package groups and the shared resource directory

When you install Developer for System z with IBM Installation Manager, you must
choose a package group and a shared resource directory.

Package groups

During the installation process, you must specify a package group for Developer
for System z and any other bundled offerings you are installing. A package group
represents a directory in which packages share resources with other packages in
the same group. This is known as shell sharing. When you install Developer for
System z and any bundled offerings with Installation Manager, you can choose to
create a new package group or install the packages into an existing package group.
(Some packages might not be able to share a package group, in which case the
option to use an existing package group will be disabled.)

Note: When you install multiple packages at the same time, all the packages are
installed into the same package group.

A package group is assigned a name automatically; however, you choose the
installation directory for the package group.

Once you create the package group by successfully installing a package, you
cannot change the installation directory for the package group. The installation
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directory contains files and resources specific to the packages installed into that
package group. Other resources in the packages that can potentially be shared by
other package groups are placed in the shared resources directory.

Shared resources directory

The shared resources directory is the directory where resources that can be shared
by different packages, potentially in different package groups, are stored. Using a
common location for these resources allows Installation Manager to install only one
copy of each of these resources to conserve disk space, rather than installing
separate copies of the same resources when they are used by multiple packages.

Important: You can specify the shared resources directory only once: the first time
that you install a package. For best results, use your largest drive for this. You
cannot change the directory location later unless you uninstall all packages.

Extending an existing Eclipse IDE

The Developer for System z package includes a version of the Eclipse integrated
development environment (IDE), or workbench, which is installed when you install
Developer for System z. However, if you have an existing Eclipse integrated IDE
that is already installed on your workstation, you have the option to extend that
IDE by adding the Developer for System z functionality to the existing
environment.

During the Developer for System z installation, select the Extend an existing
Eclipse IDE option on the Location page of the Install Packages wizard to extend
an existing Eclipse IDE. You will be asked for the location of your existing Eclipse
IDE as well as the Java Virtual Machine (JVM) that you want to use.

You might extend your existing Eclipse IDE, for example, because you want to
gain the functionality provided in the Developer for System z package, but you
also want to have the preferences and settings in your current IDE when you work
with the functionality from Developer for System z. You also might want to work
with plug-ins you have already installed to extend the Eclipse IDE.

Your existing Eclipse IDE must be version 3.6.1 and must use at least version 1.6 of
the IBM Java Development Kit (JDK) to be extended. Installation Manager checks
that the Eclipse environment you specify meets the requirements for the
installation package. If the requirements are not met, you will not be able to extend
that Eclipse IDE.
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Chapter 5. Installing Developer for System z

Installation tasks summary

The following sections provide an overview of the various installation methods
you might use when installing Developer for System z.

Overview: Installing Developer for System z from the
installation disks

About this task
In this installation scenario, you have the physical disks containing the installation
files, and typically you are installing Developer for System z on your own

workstation.

The general steps for installing from the installation disks are the following;:

1. Complete the pre-installation steps listed in [‘Preinstallation tasks” on page 1)

2. Insert the IBM Rational Developer for System z Installation disk into your DVD
drive.

3. If autorun is enabled on your system, the Developer for System z launchpad
program automatically opens.

| Windows |

If autorun is not enabled, start the launchpad program by running
Taunchpad.exe from the root of the disk.

If autorun is not enabled, start the launchpad program by running
Taunchpad.sh from the root of the disk.

Refer to|Chapter 5, “Installing Developer for System z”|for details.

4. Choose Install Rational Developer for System z.

5. Decide whether you want to do an expert installation or a guided installation
of Developer for System z. A guided installation uses an installation wizard to
help you decide which features to install. An expert installation starts with the
most common features selected and lets you decide on your own which
features you want to install. For details, see [“Using the launchpad program” on|

6. Follow the on-screen instructions in the IBM Installation Manager Install
Packages wizard to install Developer for System z and any bundled offerings.
Refer to[“Working with Installation Manager” on page 28| for details.

7. Configure your licenses for Developer for System z and any bundled offerings
you installed as needed. If you have a trial license and need to configure a term
or permanent license, do so now. For example, you may want to configure
floating license support. Refer to ['Managing licenses” on page 50| for details.

8. Install additional software included with Developer for System z. For more
information, see [Appendix A, “Installing additional software,” on page 67
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Overview: Installing Developer for System z from an electronic
image on your workstation

About this task

The general steps for installing from an electronic installation image are the
following:

1. Ensure that your workstation has sufficient space to store both the files you
must download from IBM Passport Advantage and the extracted installation
image. Refer to|“Hardware requirements” on page 5.|

2. Download all required parts for Developer for System z and any bundled
offerings you wish to install from IBM Passport Advantage to a temporary
directory.

3. Extract the installation image from the compressed files you downloaded and

verify the installation image is complete. See [“Extracting electronic images” on|
for details.

4. Continue with the steps i“Installing from an electronic image,”| below.

Installing from an electronic image

About this task

Take the following steps:

1. Complete the pre-installation steps listed in [“Preinstallation tasks” on page 1)
2.

| _Windows _|

Start the launchpad program by running Taunchpad.exe from the root of the
RDz801Edition_Setup directory.

Start the launchpad program by running Taunchpad.sh from the root of the
RDz801Edition_Setup directory.

Refer to|Chapter 5, “Installing Developer for System z,” on page 23| for details.

3. Choose Install Rational Developer for System z.

4. Decide whether you want to do an expert installation or a guided installation
of Developer for System z . A guided installation uses an installation wizard to
help you decide which features to install. An expert installation starts with the
most common features selected and lets you decide on your own which
features you want to install. For details, see [Chapter 5, “Installing Developer for]
[System z,” on page 23]

5. Follow the on-screen instructions in the IBM Installation Manager Install
Packages wizard to install Developer for System z and any bundled offerings.
Refer to|“Working with Installation Manager” on page 28| for details.

6. Configure your licenses for Developer for System z and any bundled offerings
you installed as needed. If you have a trial license and need to configure a term
or permanent license, do so now. For example, you may want to configure
floating license support. Refer to [‘Managing licenses” on page 5(| for details.

7. Install additional software included with Developer for System z. For more
information, see [Appendix A, “Installing additional software,” on page 67)
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Overview: Installing Developer for System z from an electronic
image on a shared drive

About this task

In this scenario, you will place the electronic image on a shared drive so that users
in your enterprise can access the installation files for Developer for System z and
any bundled offerings from a single location. This is also useful when you need to
perform silent installations on a number of user systems. The following steps are
performed by the person placing the installation image on a shared drive:

1. Ensure that your shared drive has sufficient disk space to store both the files
you must download from IBM Passport Advantage and the extracted
installation image. Refer to ["Hardware requirements” on page 5| for details.

2. Download all required parts for Developer for System z and any bundled
offerings from IBM Passport Advantage to a temporary directory on the shared
drive.

Note: You can instead download the parts to your workstation and copy only
the extracted installation image to the shared drive.

3. Extract the installation image from the downloaded files into an accessible
directory on the shared drive and verify the installation image is complete. See
[“Extracting electronic images” on page 11| for details.

To install Developer for System z interactively from the installation files on the
shared drive, take the following steps:

1. Change to the RDz801£dition_Setup directory on the shared drive containing
the installation image.

2. Follow the steps in [“Installing from an electronic image” on page 24 to install
Developer for System z and any bundled offerings.

For information about performing silent installations using your shared electronic
image, refer to[“Silent installation” on page 31

Overview: Installing Developer for System z from a repository
on a HTTP Web server

About this task

In this scenario, the product packages are retrieved by the IBM Installation
Manager from an HTTP Web server.

These steps assume the repository containing the packages for Developer for
System z and any bundled offerings has been created on the HTTP Web server.
Refer to[|“Overview: Placing Developer for System z on an HTTP Web server” on|
|Eage 2§| for details on copying the installation packages to an HTTP Web server.

To install the Developer for System z package from a repository on an HTTP
server, take the following steps:

1. Complete the pre-installation steps listed in [“Preinstallation tasks” on page 1}

2. Install IBM Installation Manager. Refer to [“Installing Installation Manager” on|
3. Start Installation Manager. Refer to [“Starting Installation Manager” on page 19
for details.
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4. Add the URL of the repository containing the Developer for System z package
to the repository preference in Installation Manager. See [*Setting repository]
[preferences in Installation Manager” on page 21.

5. Click Install to start the Install Packages wizard in Installation Manager, and
follow the on-screen instructions to complete the installation.

6. Configure your licenses for Developer for System z and any bundled offerings
you installed as needed. If you have a trial license and need to configure a term
or permanent license, do so now. For example, you may want to configure
floating license support. Refer to ["Managing licenses” on page 5(| for details.

7. Install additional software included with IBM Rational Developer for System z.
For more information, see |[Appendix A, “Installing additional software,” on|

Overview: Placing Developer for System z on an HTTP Web

You can place the Developer for System z install package, as well other offering
packages, on an HTTP Web server by using the IBM Packaging Utility to create an
installation repository. You may want to do this if you have a number of different
offerings or service updates you want to place in a single repository in addition to
the Developer for System z 8.0.1 offering and its bundled offerings. You can use
this repository to perform interactive or silent installations.

Note: While you can perform silent installations from a repository on an HTTP
web server, this step is not required to perform silent installations.

To place packages on an HTTP Web server you will use the IBM Packaging Utility
to create a new installation repository or copy to an existing repository. Refer to
[“Copying packages to an HTTP server using the Packaging Utility” on page 71| for
details on using the Packaging Utility to create an installation repository. Once you
have created your repository, you can do the following:

1. Provide users in your enterprise with the URL of the installation repository.
Users can point to the repository and perform installations without having the
installation media on their systems.

2. Use the repository to perform silent installations. Refer to[“Silent installation”|
‘

n page 31|for details on running silent installations.

Using the launchpad program

26

The Developer for System z launchpad program provides you with a single
location to view release information and begin the installation process.

Use the launchpad program to start the installation of Developer for System z in
the following cases:

* You are installing from the product installation disks.
* You are installing from an electronic image on your workstation.

* You are installing from an electronic image on a shared drive.

When you start the installation from the launchpad program, IBM Installation
Manager will be launched with the necessary repository location information

automatically configured. This prevents you from having to set the repository
location manually in the Installation Manager preferences.
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On the Install Rational Developer for System z panel of the launchpad, you can
decide to install for all users (which requires you to have administrator access), or
you can just install for the current user. Then you click on one of the provided
links to start either a guided installation or an expert installation.

You can select to perform an expert installation rather than selecting a guided
installation. Selecting an expert installation will launch the Developer for System z
installation with the most common features and bundled offerings selected by
default.

Note: No matter which installation option you select from the launchpad program,
you can always customize the set of features to be installed by selecting and
deselecting additional features.

To start the Developer for System z installation from the launchpad program as an
administrator, take the following steps:

1. Complete the preinstallation tasks described in [Preinstallation tasks” on pagel
if you have not done so already.

2. If you are installing from the installation disks, insert the installation disk into
your DVD drive. If you are installing from an electronic image, open the
RDz801Edition_Setup directory.

3. If auto-run is enabled on your system, the launchpad program will start
automatically. If auto-run is not enabled on your system or you are installing
from an electronic image:

|_Viindows |

Run Taunchpad.exe, located at the root of the disk or the
RDz801Edition_Setup directory.

Run Taunchpad.sh , located at the root of the disk or the
RDz801Edition_Setup directory.

4. Read the Welcome information on the Welcome panel and select the Product
documentation selection on the left to see the available documentation. Click
the links on the panel to view the product documentation.

5. To install IBM Rational Developer for System z, click the Install IBM Rational
Developer for System z selection on the left. Click the Install for all users
radio button if you are installing for all users. Click the Install for the current
user radio button if you are installing only for the current user. Decide if you
want to start a guided installation or an expert installation and click the
corresponding link.

a. If you want start a guided installation of IBM Rational Developer for
System z, click the Start guided installation link. This launches the
Developer for System z installation wizard. On the installation wizard, you
can select the features you want to install by checking the boxes that
correspond to those features. Then click on the link at the bottom of the
panel to continue the guided (or custom) installation.

b. If you want start an expert installation of IBM Rational Developer for
System z, click the Start expert installation link.
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7. IBM Installation Manager will be launched to perform the installation of
Developer for System z and any bundled offerings you choose to install. Follow
the prompts in the Install Packages wizard to complete the installation. For
more details, refer to|“Working with Installation Manager.”|

Note: There is also an Install optional software selection on the left of the
launchpad panel. Click on that selection if you want to install optional software
such as:

* TXSeries for Multiplatforms v7.1

e UML Profiles for COBOL Development v8.0.1 (RSA)

Working with Installation Manager

28

About this task

When you launch the Developer for System z installation from the launchpad
program (see [“Using the launchpad program” on page 26), IBM Installation
Manager will start and you will be presented with the Install Packages wizard. The
following steps will guide you through using the Install Package wizard of
Installation Manager to install Developer for System z:

Procedure

1. The first panel of the wizard displays a list of the packages that are available
for installation. The available packages will include Developer for System z
and any bundled offerings that are recommended based on your selections
from the launchpad. Refer to|“Using the launchpad program” on page 26| for
more details about the launchpad program. The available bundled offerings
will vary depending on the edition of Developer for System z you purchased.

2. You might be prompted to update IBM Installation Manager to a newer
version if one is available. If prompted, click Yes to install the update, or click
No if you want to install the newer version later. If you click Yes, Installation
Manager updates itself and informs you that it must restart to complete the
update.

Click OK to restart Installation Manager

3. On the Licenses panel, read the license agreement for the selected packages.
There is a license agreement for each package you select to install. On the left
side of the Licenses panel, click each package name to display the
corresponding license agreement.

a. If you agree to the terms of all of the license agreements, click I accept the
terms of the license agreements.

b. Click Next to continue.

4. On the Location panel, Installation Manager will give you the option of either
creating a new package group to contain the Developer for System z package,
or using an existing package group on your system. When you install
packages into the same package group they share a common workbench, and
the functionality from the different packages is combined in that workbench.
This is known as shell sharing. Packages that are installed into different
package groups do not share a workbench and are kept separate from each
other.

To create a new package group for Developer for System z:
a. Select the radio button labeled Create a new package group.

b. Enter the installation directory you want to use for the new package
group. This directory is where resources will be stored which are specific
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to the packages installed in the package group. Each package group you
create on your system has a separate installation directory. This directory is
different from the shared resources directory, where resources are installed
that can be shared by packages in different package groups.

c. If you do not have any other packages installed on your system, you will
also be asked to choose the location to use for the shared resources
directory. It is recommended that you select a location on your largest
drive for the shared resources directory, as it will be used by every
package you install using Installation Manager and it cannot be changed
after the first package is installed. If you already have one or more
packages installed on your system, Installation Manager will display the
location of the shared resources directory but you will not be given the
option to select or change it.

Note: To change the location of the shared resources directory at a later
time you must uninstall all packages and then re-install them, specifying a
new shared resources directory.

To install Developer for System z into an existing package group:
a. Select the radio button labeled Use an existing package group.

b. Installation Manager will display a list of the available package groups on
your system. Select the package group into which you want to install
Developer for System z. Installation Manager will verify that the package
group you selected is compatible with Developer for System z. If it is not,
Installation Manager will display an error message informing you of the
problem and you will not be able to continue with the installation until
you select a compatible package group or select to create a new package
group.

When you have finished making your selections, click Next to continue.

. On the next Location panel, you can choose to extend an existing Eclipse IDE

already installed on your system, adding the functionality in the packages that

you are installing. You must have Eclipse Version 3.6.1 using IBM Java

Development Kit (JDK) version 1.6 or higher to select this option. It is

recommended that you use the Eclipse IDE and JDK that are packaged with

Developer for System z instead of extending an existing one.

* If you do not want to extend an existing Eclipse IDE, click Next to continue.
¢ To extend an existing Eclipse IDE:
a. Select Extend an existing Eclipse.

b. In the Eclipse IDE field, type or navigate to the location of the folder
containing the eclipse executable file (eclipse.exe for Windows, eclipse
for Linux). Installation Manager checks if the Eclipse IDE version is
valid for the package that you are installing. The Eclipse IDE JVM field
displays the Java Virtual Machine (JVM) for the IDE that you specified.

c. Click Next to continue.

. On the next Location page, under Languages, select the languages you want
to install for this package group. The corresponding national language
translations for the user interface and documentation for Developer for
System z will be installed.

Note: Your choices apply to all packages installed in this package group.
Note: In this release of Developer for System z, selecting any of the available
languages will result in the national language translations for all languages

being installed.
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7.

10.

11.

12.

On the Features panel, select the features that you want to install for
Developer for System z and any bundled offerings you are installing. If you
selected to do a guided installation from the launchpad at the start of the
installation process, a set of features will be selected by default based on the
responses you gave to the questions in the installation wizard. You can click
on the name of any feature to view a description of that feature. The feature
description is displayed in the Details section at the bottom of the panel. For
more information about the available features of Developer for System z, refer
to [“Feature installation” on page 12| For information about the available
features of the offerings that are bundled with Developer for System z, refer to
the documentation for those offerings.

When you have finished selecting the features you want to install, click Next.

On the help system configuration page, select one of the following options
and then click Next:

* Access help from the Web
* Download help and access content locally
* Access help from a server on your intranet

On the z/OS connection panel, you can optionally configure a remote z/OS
connection that will be created the first time you launch the Developer for
System z workbench using a new workspace. Developer for System z will
connect to the server to automatically retrieve workbench configuration
settings. This can help you roll out common configuration settings to multiple
users without having to configure each client separately.

By default, the z/OS connection configuration is disabled. If you do not want
to configure a z/OS connection, leave the Configure my z/OS connection
now checkbox unchecked and click Next to continue with the installation. If
you want to enable this feature and enter your z/OS connection settings,
perform the following steps:

a. Select the Configure my z/OS connection now checkbox.

b. Enter the host name of the Developer for System z server in the Host
name field.

c. In the Connection name field, enter a name to be used for this connection
in the Developer for System z Remote Systems view.

d. Select either userid/password or certificate for the server authentication
method.

e. Enter the daemon port of the Developer for System z server in the
Daemon port field.

f. Click Next to continue with the installation. Your z/OS connection will be
configured the first time you launch the Developer for System z workbench
using a new workspace.

On the Summary panel, review your choices before you begin the installation.
If you want to change the choices you made on previous panels, click Back
and make your changes. When you are satisfied with your installation choices,
click Install to install the packages. The installation begins and a progress
indicator shows you the percentage of the installation complete.

When the installation process is complete, a message confirms the success of
the installation.

To view the installation log file for the current session, click View log file to
open the installation log in a new window.

If necessary, configure your licensing for Developer for System z and other
bundled offerings you installed through the Manage License panel in
Installation Manager. This may include configuring floating license support or
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installing product activation kits to install permanent or term license keys.
Refer to [‘Managing licenses” on page 50| for more details.

Silent installation
About this task

You can install Developer for System z in silent mode. When you run Installation
Manager in silent mode, its user interface is not available; you use a response file
instead to input the commands required to install the package.

Running Installation Manager in silent mode is helpful because it allows you to
use a batch process to install, update, modify, and uninstall packages through
scripts.

There are the following three main tasks for silent installation:

1. If you are planning to perform silent installations on multiple systems, copy the
installation image to a location on a shared drive or server.

2. Create the response file.
3. Run Installation Manager in silent install mode.

Copying the installation image to a shared drive or server
About this task

If you are planning to perform silent installations on multiple systems, you should
copy the installation image to a location on a shared drive where other systems in
your intranet can access it.

To copy the installation image from physical installation disks to a shared location,
take the following steps:

1. Insert the IBM Rational Developer for System z Installation disk into your DVD
drive.

2. Copy the contents of the IBM Rational Developer for System z Installation disk into
the shared location where you want to store the installation image.

3. If you want to make other offerings that are bundled with Developer for
System z available for silent installation, for example IBM Rational Business
Developer or IBM Rational Application Developer, you will need to follow the
previously mentioned process for these offerings.

a. If the bundled offering installation is contained on a single installation disk,
copy the contents of that installation disk to the directory you created in
Step 1. If the bundled offering includes multiple installation disks, perform
the following steps.

1) Create a new directory in your shared location to contain the product
installation files for the bundled offering. This directory can have any
name you choose.

2) For each installation disk, create a diskN directory for each installation
disk inside the directory you created to contain the product installation
files, where N corresponds to the number of the installation disk. Copy
the contents of each installation disk into the corresponding diskN
directory you created for that disk.

4. Once you have finished copying the contents of your installation disks to your
shared location, you are ready to create a response file and perform silent
installations.
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To copy the installation image from an electronic image to a shared location, take
the following steps:

1. Extract each of the compressed files you downloaded for Developer for System
z and any bundled offerings you want to make available for silent installations
to the shared location where you want to store the image. Alternatively, you
could extract the compressed files on your local machine and then copy the
uncompressed files and directories to the shared location.

2. In the shared location, verify that you now have the following;:

a. In the root of the shared directory, you should have the following
directories:

* RDz801Edition_Setup, where £dition will vary depending on the edition
of Developer for System z you downloaded.

e RDz8O1EGL, or RDz801Java, or RDz801Ent

* One directory for each bundled offering you are making available for
silent installations, for example IBM Rational Business Developer or IBM
Rational Application Developer. The available bundled offerings will vary
depending on the edition of Developer for System z you purchased.

b. In the RDz801EGL, RDz801Java, or RDz801Ent directories, and in the
directory for each bundled offering you copied to your shared location, you
should have one or more diskN directories, one for each installation disk for
the product.

3. Once you have verified the directory structure of your shared installation
image you are ready to create a response file and perform silent installations.

Alternatively, you can copy your installation image to a repository on an HTTP
Web server and perform silent installations using the repository. To create a
repository you will need to use the IBM Packaging Utility. Refer to |“Overview:|
[Placing Developer for System z on an HTTP Web server” on page 26 for more
details.

Creating a response file
About this task

You can create a response file by recording your actions as you install Developer
for System z packages using Installation Manager. When you record a response
file, all of the selections that you make in the Installation Manager GUI are stored
in an XML file. You can then use the same response file to perform silent
installations on other systems. When you run Installation Manager in silent mode,
Installation Manager uses the XML response file to locate the repository containing
the package, select the features to install, and so on.

To record a response file for installation (or uninstallation), take the following
steps:

1. On a command line, change to the eclipse subdirectory in the directory where
you installed Installation Manager.

| Vindows |

cd C:\Program Files\IBM\Installation Manager\eclipse

| Linux |
cd /opt/IBM/InstallationManager/eclipse
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2. On a command line, type the following command to start installation manager,
substituting your own name and location for the response file and (optionally)
the log file.

|_Viindows |

IBMIM.exe -record <response file path and name>.xml -log
<log file path and name>.xml

For example,

IBMIM.exe -record C:\my_response_file.xml -log
C:\install_Tog.xmI

IBMIM -record <response file path and name>.xml -log
<log file path and name>.xml

For example,

IBMIM -record /root/mylog/my_response _file.xml -log
/root/mylog/install_Tog.xml

Note: Ensure the directories in which you want the response file and log file to
be stored exist. Installation Manager will not create directories for the response
file and the log file.

3. Install Developer for System z and any other bundled offerings you want to
install using the Installation Manager GUI Refer to [“Working with Installation|
[Manager” on page 2§ for more details.

You can record a response file without installing or uninstalling a product by
adding the optional -skipInstall <agentDatalocation> parameter. Note that
<agentDatalocation> must be a writable directory. The argument causes
Installation Manager to save the installation data without installing the product.
You can use the same <agentDatalocation> in the next recording session to
record updates or modifications to the product, or to record license
management. Note that the products installed or the preferences, including
repository settings, that you may have set on install when not using the
-skipInstall argument are not stored. Using -skipInstall will make installation
faster because the Installation Manager is not installing the product, it is just
recording the installation data.

The syntax for using the skipInstall argument is:

IBMIM -record <response file and path name>
-skipInstall <a writable directory for agent data location>

For example (on the Windows platform):
IBMIM -record c:\mylog\responsefile.xml -skipInstall c:\temp\recordData

Note: Ensure the file paths you enter exist. Installation Manager will not create
directories for the response file and the log file.

4. If necessary, configure your licensing for Developer for System z and other
bundled offerings you installed. This may include configuring floating license
support or installing product activation kits to install permanent license keys.
Refer to[“Managing licenses” on page 50| for more details.

5. Exit Installation Manager.

After you exit Installation Manager, an XML response file is created and resides in
the location specified in the command you use to launch Installation Manager.
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A sample response file which can be used to install Developer for System z is
provided on the IBM Rational Developer for System z Installation disk in the
SilentInstall directory. The sample response file can also be found in the
RDz801Edition_Setup directory if you are installing from an electronic image. You
can use this file as-is to perform silent installations of Developer for System z, or
modify to your own specifications. Refer to [‘Silent installation commands” on]
for information on customizing your response file.

Running Installation Manager in silent installation mode

You can run Installation Manager in silent installation mode from a command line.

Refer to the Installation Manager online help for additional documentation on how
to run it in silent mode.

You can run Installation Manager in silent mode by running the following
command from the directory in which Installation Manager is installed.

_Windows |

IBMIMc.exe —Tauncher.ini silent-install.ini [arguments]

IBMIM --Tauncher.ini silent-install.ini [arguments]

The following table describes the arguments used with the silent installation
command:

Table 3. Arguments used with the silent installation command

Argument |Description

-input This argument specifies an XML response file as the input to Installation
Manager. A response file contains commands that Installation Manager runs.

-log (Optional) This argument specifies a log file that records the result of the
silent installation. The log file is an XML file.

To run Installation Manager in silent installation mode, do the following:

1. On a command line, change to the eclipse subdirectory in the directory where
you installed Installation Manager.

| Vindows |

Example: c¢d "C:\Program Files\IBM\Installation Manager\eclipse"

[ Linux |
Example: cd /opt/IBM/InstallationManager/eclipse

2. Enter and run the following command, substituting your own locations for the
response file and, optionally, the log file.

| Windows |

Example: IBMIMc.exe -—Tauncher.ini silent-install.ini -input
c:\mylog\responsefile.xml -Tog c:\mylog\silent install log.xm]
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Example: IBMIM --launcher.ini silent-install.ini -input
/root/mylog/responsefile.xml -log /root/mylog/silent _install Tog.xml

Installation Manager runs in silent installation mode. It reads the response file and
writes a log file to the directory you specified. You must have a response file when
running in silent installation mode, however, log files are optional. A successful
install ends in a return code of 0. If the install ends with a non-zero number, the
install failed. If you receive a non-zero return code, check the response file and log
file for possible causes of the failure. See [“Silent install log files” on page 40| for
more information about log files. If you specified a log file when you entered the
silent installation command, any errors will be logged in the log file you specified.
A successful installation results in a log file that contains simply the following:
<result></result>.

Response file commands

If you want to use the silent installation capabilities of Installation Manager, you
need to create a response file that contains all of the commands that Installation
Manager must run. The recommended way to do this is to create a response file by
recording your actions as you install Developer for System z. However, you can
also create or edit a response file manually.

There are the following two categories of commands for the response file:

* Preference commands are used to set preferences that are found in Installation
Manager under File -> Preferences..., such as repository location information.

¢ Silent installation commands are used to emulate the Install Packages wizard in
Installation Manager.

Silent install preference commands

While you typically specify preferences using the Preferences window, you can also
specify preferences (identified as keys) in a response file for use during a silent
installation.

Note: You can specify more than one preference in a response file.

When you define preferences in a response file, your XML code will look similar to
the following example:
<preference>

name = "the key of the preference"

value = "the value of the preference to be set"
</preference>

Use the following table to identify keys and their associated values for silent
installation preferences:
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Table 4. Keys for silent installation preferences

Key Value Notes®
com.ibm.cic.common.core.preferences.logLocation Specifies the location |Important:This key is
of Installation optional and is
Manager log file. designed for testing
and debugging. If you
do not specify a
location for the log
file, both silent
installation and the Ul
version of Installation
Manager will use the
same location.
com.ibm.cic.license.policy.location Specifies a URL that
defines where the
remote license policy
file resides.
com.ibm.cic.common.core.preferences. http.proxyEnabled True or False False is the default

value.

com.ibm.cic.common.core.preferences.

http.proxyHost Host name or

Host name or IP

¢:\IBM\ common

/opt/1BM/common
Note: The paths
above are default
values for this
preference; typically,
install packages
provide their own
values for this
preference.

IP address address
com.ibm.cic.common.core.preferences. http.proxyPort Port number
com.ibm.cic.common.core.preferences. http.proxyUseSocks True or False False is the default
value.
com.ibm.cic.common.core.preferences. SOCKS.proxyHost Host name or IP
address
com.ibm.cic.common.core.preferences. SOCKS.proxyPort Port number
com.ibm.cic.common.core.preferences. ftp.proxyEnabled True or False False is the default
value.
com.ibm.cic.common.core.preferences. ftp.proxyHost Host name or IP
address
com.ibm.cic.common.core.preferences. ftp.proxyPort Port number
com.ibm.cic.common.core.preferences.eclipseCache | Windows | You cannot change this

location if you have
already installed a
package.

com.ibm.cic.agent.core.pref.offering.service.repositories.areUsed

True or False

Change this preference
to 'False' to disable it.
When 'True’, all linked
repositories are
searched when
products are installed
or updated.
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Table 4. Keys for silent installation preferences (continued)

Key

Value Notes®

com.ibm.cic.common.core.preferences.preserveDownloaded Artifacts

Change this preference
to 'False' to disable it.
When 'True’, the files
required to roll the
package back to a
previous version are
stored on your system.
When 'False', these
files are not stored. If
you do not store these
files, you must connect
to your original
repository or media to
roll back.

True or False

Silent installation commands

You can use this reference table to learn more about response file commands for

use during a silent installation.

Table 5. File commands for use during silent installation

Response file commands

Description

Set profile
<profile id="the profile (package group) id"

installlLocation="the install location of the profile">

<data key="keyl" value="valuel"/>
<data key="key2" value="value2"/>
</profile>

Use this command to create a package group (or
installation location). If the specified package group
already exists, the command has no effect. Currently,
when creating the profile, the silent installation will
also create two installation contexts; one for Eclipse
and one for native. A profile is an installation location.

You can use the <data> element for setting profile
properties.

The following list contains the currently supported
keys and related values:

* The eclipselocation key specifies an existing
Eclipse location value, such as c:\myeclipse\
eclipse.

* The cic.selector.nl key specifies the Natural
Language (NL) locale selections, such as zh, ja, and
en.

Note: Separate multiple NL values with commas.

The following list contains the currently supported
language codes:

* English (en)

* French (fr)

 Simplified Chinese (zh)

e Traditional Chinese (Taiwan) (zh_TW)
* German (de)

* Japanese (ja)

* Spanish (es)

e Korean (ko)

* Portuguese (pt_BR)
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Table 5. File commands for use during silent installation (continued)

Response file commands

Description

Set profile (continued)
<profile id="the profile (package group) id"
<data key="keyl" value="valuel"/>

<data key="key2" value="value2"/>
</profile>

installlLocation="the install Tocation of the profile">

The following properties are used to configure a z/OS
connection that will be used to automatically retrieve
workbench configuration settings. The connection will
be created the first time the workbench is launched
using a new workspace.

The

user.remoteConfig.hostname,
com.ibm.rational.developer.systemz.v80

property specifies the Developer for System z
server host name.

The

user.remoteConfig.connectionName,
com.ibm.rational.developer.systemz.v80

property specifies a name to be used for the z/OS
connection in the Developer for System z Remote
Systems view.

The

user.remoteConfig.connectionDescription,
com.ibm.rational.developer.systemz.v80

property specifies a description of the z/OS
connection.

The

user.remoteConfig.authenticationMethod,
com.ibm.rational.developer.systemz.v80

property specifies the authentication method used
to connect to the Developer for System z server.
Possible values are USERID and CERTIFICATE.

The

user.remoteConfig.daemonPort,
com.ibm.rational.developer.systemz.v80

property specifies the daemon port used by the
Developer for System z server. The default port is
4035.

Set repositories

<server>

<repository location="http:/xxx/repository/">
<repository location="file:/C:/repository/">
<!--add more repositories below>

<..>

</server>

Use this command to specify the repositories used
during a silent installation. Each repository location
can be a URL or a file path.
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Table 5. File commands for use during silent installation (continued)

Response file commands

Description

Install

<install>

<offering profile= "profile id"
features= "feature ids"

id= "offering id"

version= "offering version">
</offering>

<!--add more offerings below>
<...>

</install>

Use this command to specify the installation packages
that will be installed.

The profile ID must match an existing profile or a
profile created by the set profile command.

Feature IDs can be optionally specified by a
comma-delimited list, such as "featurel, feature2", and
so on. If no feature IDs are specified, all the default
features in the specified offering will be installed.

Note: Required features will be included for
installation, even if they are not explicitly specified in
the comma-delimited list.

<install modify="true"> or <uninstall
modify="true">(optional attribute)

<uninstall modify="true">
<offering
profile="profileID"id="1Id"
version="Version"
features="-"/>
</uninstall>

Use the <install modify="true"> attribute on install
and uninstall commands to indicate that you want to
modify an existing install. If the attribute is not set to
true, the value defaults to false. If the intent of the
modify operation is only to install additional language
packs, then a hyphen “-* should be used in the
offering feature id list to indicate no new features are
being added.

Important: You must specify "modify=true" and a
hyphen "-" feature list as specified in the example;
otherwise, the install command will install the
offering's default features and the uninstall command
will remove all the features.

Uninstall

<uninstall>

<offering profile= "profile id"
features= "feature ids"

id= "offering id"

version= "offering version">
</offering>

<!--add more offerings below>
<...>

</uninstall>

Use this command to specify the installation packages
that will be uninstalled.

The profile ID must match an existing profile or a
profile specified in a profile command. Further, if
there are no feature IDs specified, all the features in
the specified offering will be uninstalled; if there are
no offering IDs specified, all the installed offering in
the specified profile will be uninstalled.

Rollback

<rollback>

<offering profile= "profile id"
id= "offering id"

version= "offering version">
</offering>

<!--add more offerings below>
<...>

</rollback>

Use this command to roll back to the specified
offerings from the version currently installed on the
specified profile. You cannot specify features in a roll
back command.

InstallAll
<installALL/>

Note: This command is equivalent to using
-silent -installAll

Use this command to silently search for and install all
available installable packages.
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Table 5. File commands for use during silent installation (continued)

Response file commands Description

UpdateAll
<updateALL/>

Note: This command is equivalent to using

-silent -updateAll

Use this command to silently search for and update
all available installable packages.

40

Reference: Sample response file

You can use an XML-based response file to specify predefined information, such as
silent installation preferences, repository locations, package groups, and so on.
Response files are beneficial for teams and companies that want to install
installation packages silently and to standardize the locations and preferences for
installation packages.

Sample response file

<agent-input >
<!-- add preferences -->
<preference name="com.ibm.cic.common.core.preferences.http.proxykEnabled"
value="c:/temp"/>
<l-- create the profile if it doesn't exist yet -->
<profile id="my_profile" installlLocation="c:/temp/my_profile"></profile>
<server>
<repository
location=
"http://a.site.com/Tocal/products/sample/20060615_ 1542/repository/">
</repository>/server>

<install>

<offering profile= "my profile" features= "core" id= "ies"
version= "3.2.0.20060615"> </offering>

</install>

</agent-input>

Silent install log files

You can use silent install log files to examine the results of a silent installation
session.

The silent installation functionality creates an XML-based log file that records the
result of the silent install execution (as long as a log file path is specified using -log
<your log file path>.xml). If your silent installation session is successful, the log
file will contain just the root element of <result> </result>. However, if there
errors occur during the installation, the silent install log file will contain error
elements with messages, such as the following:
<result>

<error> Cannot find profile: profile id</error>

<error> some other errors</error>
</result>

For detail analysis, you can look at the logs generated in the Installation Manager
data area. By using a preference command, you can optionally set the data area to
your preferred location, as shown in the response file topic.
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Running Installation Manager in wizard mode
About this task

Wizard mode starts Installation Manager in either the install wizard or the
uninstall wizard with your preferences and install or uninstall choices already set
based on the specified response file. The response file can only contain preference
commands and install or uninstall commands. You cannot mix install and uninstall
commands in the same response file when you run Installation Manager in wizard
mode.

| Windows |

Enter the following command on the command line to start Installation Manager in
wizard mode:

IBMIM.exe -mode wizard -input <response file>

Enter the following command on the command line to start Installation Manager in
wizard mode:

./IBMIM -mode wizard -input <response file>
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Chapter 6. Post-installation tasks

Remote or Web-based helps

With some products, you can access, download, and update help content from the
Web. Access to Web-based help content provides you with the latest content that is
available for your product.

If your product offers help content on the Web, only a limited number of help
topics are installed with the product. By default, your product connects to the Web
and accesses help content directly from an information center. If you need to access
the help when you are not connected to the Internet, you can download the help
and access it locally, or you can connect to an information center on an intranet
server if your system administrator has made one available to you.

See the installation guide to find out if your product supports Web-based help
content.

The following three options are available during the installation process, but can be
changed at any time:

* You can access help content from the Web. This method provides the smallest
installation footprint and ensures that you have access to the most current
information. This is the default selection.

If you select this option, then you will be linked to your product information
center through an ibm.com® Web site. You can access the Web-based help for
the product only when you are connected to the Internet. When you are
disconnected, you will have access to a limited number of help topics that are
installed with the product.

* You can download help contents to your computer so that you can work while
disconnected from the Internet. Important: If you select this method, you must
connect to an update site where you can choose the help content and features to
download. The help is not automatically downloaded when you install the
product.

After you download the information center content that you need, it will be
available when you work while disconnected. You can update the content when
changes are available.

* If your company supports it, you can access help content from your corporate
intranet servers. This method assumes that your intranet administrator has set
up a link to a server behind your firewall where product help content is
installed. By selecting this option, you must enter the link to your intranet
server. Administrators must make scheduled updates to the help content.

If you are an administrator and you want users to access help content from an

intranet server, see the installation information for guidance on setting up the
intranet server and downloading the help content from the update site.

Whether you access Web-based help content, download and use help content
locally, or connect to your intranet to get help, click Help > Help content to open

help topics and find solutions.

To change the way that your products access help content, see the installation
topics for your product for detailed instructions.
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Web-based help content

The Developer for System z help system is configured to use remote help so that
you can pull in content from the Web dynamically. With remote help, you always
have the latest content available from within Developer for System z. Some help
systems are not configured to access help content on the Web; in such cases, help
content is included with the installation.

You can obtain help three ways. One of these options is best for you, depending on
your needs and situation:

* The help content can be accessed on the Web so that you can have the smallest
installation footprint and the most up-to-date information.

* The help content can be downloaded and accessed on your computer so that
you can work disconnected from the Internet with periodic updates.

¢ The help content can be deployed on an intranet server so that you can work
behind a firewall with administrative updates.

You can change your access decision at any time. If you install multiple products
together, you can use different locations for the help for each product, depending
on installation footprint, frequency of use, and internet policies. If internet speed is
an issue, a longer one-time download and local access might be preferable. Later
help updates include only differences.

If you are an administrator and you want users to access help content from an
intranet server, see the [Installation Manager information centet for instructions on
how to install the help WAR file on a server. In the Installation Manager
information center, select Enterprise installation articles -> Delivering help
content from an intranet server.

Accessing Web-based help

Help for Developer for System z is available on a product information center on
the Internet. You can view this help from within Developer for System z.

Before you begin

During installation, the option to access help from a remote information center was
selected. This option is the default selection.

About this task

The Developer for System z help system can retrieve content installed with the
product, as well as content from a remote server running an information center.
The information center for Developer for System z has the most current help
content and when Developer for System z is configured to retrieve content from a
remote information center, the contents of the information center can be accessed
by selecting Help » Help Contents to open your help system.

During installation, Developer for System z was configured to access the help from
the product information center.

The information center for Developer for System z is available from the following
Web address:

http:/ /publib.boulder.ibm.com/infocenter/ratdevz/v8r0/index.jsp.
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Follow these steps to check your connection to the information center:

Procedure

1. Open the Preferences dialog

2. Select Help » Content

3. Ensure that Include remote help and give it priority is selected.
4

. Ensure that the URL for the Developer for System z information center is in the
list of available information centers. If the Developer for System z information
center is not listed, complete the following steps:

Click Add
In the Name field, enter a name for the connection.
In the Host field, enter publib.boulder.ibm.com
In the Path field, enter /infocenter/ratdevz/v8r0
Select Use default port
f. Click OK
5. Select the entry for the Developer for System z information center.
6. Click Test Connection.

®© o0 T o

Downloading help content with the Local Help System
Updater site

This topic explains how to download help content from the Local Help System
Updater site.

Before you begin

To access all help content locally, you need to download it from the IBM Local
Help System Updater Web site or from the RDz8.0_updateSite.zip file found in
the install_localhelp directory of the Quick Start Disk.

About this task

Before using the locally installed help for the product, you have to download the
help to your local system.

To install the help content from the RDz8.0_updateSite.zip file found in the
install localhelp directory of the Quick Start Disk, see |“Installing help content]
locally using the Local Help Updater and the RDz8.0 updateSite.zip file” on page|
47

To download the help content from the Local Help System Updater site, complete
the following steps:

Procedure

1. With Developer for System z open, click Help » Local Help Updater. The
Updater site opens.

2. In the Available Content pane, select the help you want to download. For the
IBM Rational Developer for System z, select Developer for System z.

a. On the Sites pull down, select All Sites.
b. Select Developer for System z.

C. Select the version of the help you want to install. The Developer for System
z documentation features that are available for download appear.
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d. Select the check box next to the help you want to download.

3. If Developer for System z is not in the list, you need to add the location.
a. On the Sites pull down, select Internal Sites.

Select the + icon to add a location.

Select Remote.

Type a name for the site.

Type http:/ /publib.boulder.ibm.com/infocenter/ratdevz/v8r0/site/site.xml
for the URL.

f. Select the location you just created. The Developer for System z
documentation features that are available for download appear.

® oo o

g. Select the check box next to the help you want to download.

4. Click Install. The help content is downloaded and installed. A progress bar
opens and tracks the status of the download.

Note: Depending on your network connection speed, this operation might take
a few minutes.

5. When the download is completed, open the help in the product by selecting
Help » Help Contents.

Results

The help that you selected is installed on your system. The files are updated
automatically when an Internet connection is available.

Updating help content

Use the Local Help System updater to ensure that you have the latest help content.
Before you begin

You have installed help features from the Local Help System Updater Web site.
About this task

Updates are automatically installed each time you start the product, if you have an
Internet connection.

To update the help without restarting the product, complete the following steps:

Procedure
1. Close the product help system window.

2. Open the Local Help System Updater by selecting Help » Local Help Updater.
The Updater site opens.

3. Click the Installed Features tab.
4. Click Search for Updates. If updates to the content you have installed are

available, they are installed to your system. A progress bar indicates the status
of the request.

5. When the update is completed, open the help in the product by selecting Help
> Help Contents.
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Installing help content locally using the Local Help Updater
and the RDz8.0_updateSite.zip file

If you are not going to use remote help to access the help content from the Web
and you do not have internet access, you must install the help content locally. This
topic explains how to install the help content using the Local Help System Updater
and the RDz8.0_updateSite.zip file provided in the install image. The
RDz8.0_updateSite.zip file is located on the IBM Rational Developer for System z
Quick Start Disk.

Before you begin

During installation, the help access option, Download help and access the content
locally, was selected.

About this task

Before using the help for the product, you have to install the help to your local
system.

To install the help content on the workstation using the Local Help System
Updater and the RDz8.0_updateSite.zip file, complete the following steps:

Procedure

1. Extract the contents of the file RDz8.0_updateSite.zip to a temporary location
on your system. Remember this location.

2. Using Windows Internet Explorer as your default browser, open IBM Rational
Developer for System z, click Help » Local Help Updater. The Local Help
Updater opens.

3. Specify the location of the extracted RDz8.0_updateSite.zip file.
a. Select Internal Sites from the Sites pull down.

Select the + icon to add a location.

Select Local.

Type a name for the site.

®ao00

Click Browse and browse to the location where you extracted the contents
of RDz8.0_updateSite.zip.

f. Double click on the site.xml file, and then Click OK. A progress bar opens
and tracks the status as the Local Help Updater searches for the available
features included in the RDz8.0_updateSite.zip file. The internal site you
specified is created and appears in the Site List in the Available Content
pane.

g. Select the internal site you created. The Developer for System z
documentation features that are available for download appear.

4. Select the IBM Rational Developer for System z documentation you want to
install. The Install button is now active (no longer grayed).

5. Click Install. A progress bar opens and tracks the status of the install.
6. When the installation is complete, Close and restart Developer for System z.

7. Select Window > Preferences and then Help>Content.. Verify that the Local
infocenter is enabled. Close the Preferences window.

8. Select Help > Help Contents to open the product help.
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Results

The help that you selected to install locally is installed and available on your
system.

Removing help content

You can use the Local Help System Updater to remove installed help content.
Before you begin

You have downloaded help features using the Local Help System Updater.
About this task

To remove installed help content, complete the following steps:

Procedure
1. Close the product help system window.

2. Open the Local Help System Updater by clicking Help » Local Help Updater.
The Updater site opens.

3. In the Installed Features pane, select the features that you want to remove,
then click Remove. The help features you selected are removed from your
system. A progress bar indicates the status of the request.

4. When the removal is completed, open the help in the product by selecting Help
> Help Contents.

Setting up an intranet server for help content

You can set up an intranet server behind a firewall to provide help content to
users. With this method, users do not have to download and save help content to
their computers.

Before you begin

You have a server available that can be accessed by users behind a firewall.

About this task

See the [[nstallation Manager information center|for the instructions for setting up
an intranet server for help content. In the Installation Manager information center,
select Enterprise installation articles -> Delivering help content from an intranet
server.

Changing the way that you access help content

You can change the way that you access help content. You can choose from the
following methods: access help from the Web; download help and access content
locally; or access help from a server on your intranet.

Close the help browser before you change the way that you access help content.

During the installation process, you selected one of the following methods for
accessing help content:

* Access help from the Web.

* Download help and access content locally.

IBM Rational Developer for System z 8.0.1: Installation Guide


http://publib.boulder.ibm.com/infocenter/install/v1r2/index.jsp

* Access help from a server on your intranet.

To change the way that you access help content, complete the following steps:
1. Click Windows » Preferences. The Preferences window opens.

2. Expand the Help entry, and then click Content. A list displaying the currently
configured information center or centers opens. Depending on the access
method that was chosen, complete one of the following procedures.

* To change from accessing help content from an information center on an IBM
Web site to accessing help content on an intranet server, follow these steps:

a. Disable the link to the internet site by selecting the Web address in the
Contents list, and then clicking Disable.

b. Click Add; then name the intranet connection, specify the intranet Web
address for the server that contains the help content, and then click OK.

c. Click OK to close Preferences.
d. Click Help » Help Contents, to open your help.

¢ To change from accessing help content from an information center on an IBM
Web site to downloading and accessing help content locally, follow these
steps:
a. Ensure that Include help content from a remote information center is
selected.

b. Disable the link to the product Information Center by selecting that
connection in the Contents list, and then clicking Disable.

c. Click Add; then enter a name for the local help connection. Specify the
localhost Host IP address 127.0.0.1 and path /help. Select any unused
port number, and then click OK.

d. Save any work and close and restart the product.

e. Follow the instructions in ['Downloading help content with the Local|
[Help System Updater site” on page 45 to download help content.

* To change from accessing help content locally to accessing help content from
an IBM Web site, follow these steps:

a. Ensure that Include help content from a remote information center is
selected.

b. Disable the link to localhost by selecting that connection in the Contents
list, and then clicking Disable.

c. Click Add; then name the connection, specify the Web address for the
IBM Web site that contains the help content, and then click OK. This Web
address might already be available in the list of connections. If it is listed,
select the connection and click Enable.

d. Click OK to close Preferences.
e. Click Help » Help Contents, to open your help.

* To change from accessing help content locally to accessing help content from
an intranet server, follow these steps:

a. Ensure that Include help content from a remote information center is
selected.

b. Disable the link to localhost by selecting that connection in the Contents
list, and then clicking Disable.

c. Click Add; then name the connection, specify the intranet Web address
for the server that contains the help content, and then click OK.

d. Click OK to close Preferences.
e. Click Help » Help Contents, to open your help.
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* To change from accessing help content from an intranet server to

downloading and accessing help content locally, follow these steps:

a. Ensure that Include help content from a remote information center is
selected.

b. Disable the link to the intranet server by selecting that connection in the
Contents list, and then clicking Disable.

c. Click Add; then enter a name for the local help connection. Specify the
localhost Host address 127.0.0.1 and path /help. Enter any unused port
number, and then click OK.

d. Save any work and close and restart the product.

e. Follow the instructions in [‘Downloading help content with the Local]
[Help System Updater site” on page 45 to download help content.

* To change from accessing help content from an intranet server to accessing
help from an IBM Web site, follow these steps:

a. Disable the link to your intranet site by selecting the intranet Web
address in the Contents list, and then clicking Disable.

b. Click Add; then name the connection, specify the Web address for the
IBM Web site that contains the help content, and then click OK.

c. Click OK to close Preferences.
d. Click Help » Help Contents, to open your help.

Managing licenses

50

Licensing for your installed IBM software and customized packages is
administered using the Manage Licenses wizard in IBM Installation Manager. The
Manage Licenses wizard displays license information and allows you to perform
license configuration tasks for each of your installed packages.

Trial licenses that come with some Rational products expire 30 or 60 days after
installation. You need to activate your product in order to use it after the
expiration date. Using the Manage Licenses wizard, you can upgrade trial versions
of an offering to a licensed version by importing a product activation kit. You can
also enable Floating license enforcement for offerings with trial or permanent
licenses to use floating license keys from a license server.
* For more information on managing licenses for your Rational product, see the
Rational licensing support page at http://www-306.1ibm.com/software/rational/
support/Ticensing/.

Authorized User License

An IBM Rational Authorized User license permits a single, specific individual to
use a Rational software product. Purchasers must obtain an Authorized User
license for each individual user who accesses the product in any manner. An
Authorized User license cannot be reassigned unless the purchaser replaces the
original assignee on a long-term or permanent basis.

For example, if you purchase one Authorized User license, you can assign that
license to one specific individual, who can then use the Rational software product.
The Authorized User license does not entitle a second person to use that product
at any time, even if the licensed individual is not actively using it.
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Floating license

Token

An IBM Rational Floating license is a license for a single software product that can
be shared among multiple team members; however, the total number of concurrent
users cannot exceed the number of floating licenses you purchase. For example, if
you purchase one floating license for a Rational software product, then any user in
your organization may use the product at any given time. Another person who
wants to access the product must wait until the current user logs off.

To use floating licenses, you must obtain floating license keys and install them on a
Rational License Server. The server responds to end-user requests for access to the
license keys; it will grant access to the number of concurrent users that matches
the number of licenses the organization purchased.

license

The token-based license model means that you can buy a certain number of token
licenses. If you use a Rational tool that checks out a FEATURE that is token-based,
the FEATURE line in the license file specifies the number of tokens that are
checked out.

Token-based licenses can only be used with floating licenses. They cannot be used
for authorized user license.

For more details about token licensing, contact your local IBM marketing
representative.

License enablement

If you are installing a Rational software product for the first time or want to
extend a license to continue using the product, you have options on how to enable
licensing for your product.

Licenses for Rational Software Development Platform offerings are enabled in the
following two ways:
* Importing a product activation kit

* Enabling Rational Common Licensing to obtain access to floating license keys

Note: Trial licenses that come with some Rational products expire 30 or 60 days
after installation. You need to activate your product in order to use it after the
expiration date.

Activation kits

Product activation kits contain permanent or term license keys for your trial
Rational product. You purchase the activation kit, download the activation kit .zip
file to your local machine, and then import the activation kit . jar file to enable the
license for your product. Use IBM Installation Manager to import the activation kit
to your product.

Floating license enforcement

Optionally, you can obtain floating license keys, install IBM Rational License
Server, and enable Floating license enforcement for your product. Floating license
enforcement provides the following benefits:

* License compliance enforcement across the organization
* Fewer license purchases
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* Serve license keys for IBM Rational Team Unifying and Software Development
Platform desktop products from the same license server

For more information on obtaining activation kits and Floating licenses, see
[‘Purchasing licenses” on page 54.

Viewing license information for installed packages
About this task

You can review license information for your installed packages, including license
types and expiration dates, from IBM Installation Manager.

To view license information, take the following steps:
1. Start IBM Installation Manager.
2. On the main page, click Manage Licenses.

The package vendor, current license types, and expiration dates are displayed for
each installed package.

Importing a product activation kit
About this task

To install your permanent or term license key, you must import the activation kit
from the download location or the product media by using IBM Installation
Manager.

If you have not purchased an activation kit, you must do this first. If you have
purchased a product or a product activation kit, insert the appropriate disk or
download the activation kit from IBM Passport Advantage to an accessible
workstation. The activation kit is packaged as a Java archive (.jar) file. The .jar
file contains the permanent license key and must be imported to activate your
product.

To import the activation kit .jar and enable the new license key, take the following
steps:

1. Start IBM Installation Manager.

2. On the main page, click Manage Licenses.

3. Select a package and click the Import Activation Kit button.
4

. Click Next. Details for the selected package are shown, including the current
license kind and the version range of the license.

5. Browse to the path on the media disk or download location for the activation
kit; then select the appropriate Java archive (.jar) file and click Open.

6. Click Next. The Summary page displays the target install directory for the
activation kit, the product the new license applies to, and version information.

7. Click Finish.

The product activation kit with its permanent license key is imported to the
product. The Manage Licenses wizard indicates whether or not the import was
successful.
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Enabling floating licenses
About this task

If your team environment supports Floating license enforcement, you can enable
Floating licenses for your product and configure a connection to obtain access to
floating license keys.

Before enabling Floating license enforcement, you must obtain the license server
connection information from your administrator. For details on license server,
license key, and Rational Common Licensing administration, see the IBM Rational
License Management Guide.

To enable floating licenses as the license type for specified packages and configure
license server connections:

1. In the IBM Installation Manager for the Rational Software Development
Platform, click File -> Open -> Manage Licenses.

2. Select a version of a package and then select the Configure Floating license
support button.

3. Click Next.
4. Click the Enable Floating license enforcement button.
5. Configure one or more license server connections, as follows:
a. Click an empty field in the Servers table or click the Add button.

b. If your administrator provided you with information for a redundant server
environment, click the Redundant Server button. Fields for the primary,
secondary, and tertiary server names and ports appear.

c. Enter the host name of the license server in the Name field.

d. (Optional) Enter a value in the Port field for environments where a firewall
is used. Do not assign a value to this port unless your administrator
instructs you to do so.

e. For redundant server environments, enter the names and ports (if required)
for the secondary and tertiary servers.

f. (Optional) You can click the Test Connection button to confirm that the
connection information is correct and that the server is available.

g. Click OK.
6. Click Next.

7. (Optional) Configure the license usage order for your shell shared or custom
packages. The order of licenses in the list determines the order in which your
package attempts to obtain access to license keys for a given licensed package.

8. Click Finish.

The Manage Licenses wizard indicates whether the floating licenses configuration
is successful.

Now, when you next open the enabled product, a connection is created to the

license server to obtain a license key from the pool of available floating license
keys.
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Purchasing licenses

About this task

You can purchase new licenses if your current product license is about to expire or
if you want to acquire additional product licenses for team members.

To purchase licenses and enable your product, complete the following steps:
1. Determine the type of license you want to purchase.

2. Go to ibm.com or contact your IBM sales representative to purchase the
product license. For details, visit the IBM Web page on How to buy software.

3. Depending on the type of license you purchase, use the Proof of Entitlement
you receive and do one of the following to enable your product:

* If you purchase Authorized User licenses for your product, go to Passport
Advantage and follow the instructions there for downloading your product
activation kit file. Once you have downloaded the activation kit, you must
import the product activation .jar file using Installation Manager.

* If you purchase Floating licenses for your product, click the link to the IBM
Rational Licensing and Download site, login (IBM registration is required), and
then select the link to connect to the IBM Rational License Key Center. There
you can use your Proof of Entitlement to obtain floating license keys for your
license server.

Optionally, you can also go to Passport Advantage to download the
activation kit for your product. After importing the activation kit, you have
the option of switching from a floating to a permanent license type if you
use your PC offline for long periods.

When you want to import the activation kit or enable floating license support for
your product, use the Manage Licenses wizard in IBM Installation Manager.

Silently installing and configuring licenses

You can import product licenses and configure floating license support silently, just
like you can install packages silently. You will need to generate a response file to
be used by IBM Installation Manager to perform your license configuration tasks.
Refer to|“Silent installation” on page 31|for details on recording a response file and
running silent installations. When recording your response file, use the Manage
Licenses panel to import an activation kit or configure floating license support
before you exit Installation Manager. The necessary information for performing
these tasks silently will be written in the response file.

Increasing the number of file handles on Linux computers

54

For best product performance, increase the number of file handles above the
default of 1024 handles.

Before you begin
Important: Before you work with your Rational product, increase the number of

file handles. Most Rational products use more than the default limit of 1024 file
handles per process. A system administrator might need to make this change.

About this task

Ensure that you complete the following steps correctly. If this procedure is not
completed correctly, your computer will not start.
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To increase the number of file handles on a Linux computer, complete the
following steps:

Procedure

1.

Log in as root. If you do not have root access, you will need to obtain it before
continuing.

Change to the etc directory.

Attention: If you decide to increase the number of file handles in the next
step, do not leave an empty initscript file on your computer. If you do so,
your computer will not start the next time that you restart it.

Use the vi editor to edit the initscript file in the etc directory. If this file does
not exist, type vi initscript to create it.

On the first line, type ulimit -n 4096. The point is that 4096 is significantly
larger than 1024, the default on most Linux computers.

Important: Do not set the number of handles too high, because doing so can
negatively impact system-wide performance.

On the second line, type eval exec "$4".
Save and close the file after making sure you have completed steps 4 and 5.

Optional: Restrict the number of handles available to users or groups by
modifying the Timits.conf file in the etc/security directory. If you do not
have this file, consider using a smaller number in step 4 in the previous
procedure (for example, 2048). Do this so that most users have a reasonably
low limit on the number of open files that are allowed per process. If you use a
relatively low number in step 4, it is less important to do this. However, if you
set a high number in step 4 earlier and you do not establish limits in the
Timits.conf file, computer performance can be significantly reduced.

The following sample Timits.conf file restricts all users, and then sets different
limits for others afterwards. This sample assumes that you set handles to 8192

in step 4.

* soft nofile 1024
* hard nofile 2048
root soft nofile 4096

root hard nofile 8192

userl  soft nofile 2048

userl hard nofile 2048

Note that the "*" in the preceding example sets the limits for all users first.
These limits are lower than the limits that follow. The root user has a higher
number of allowable handles open, while the number available to userl is
between the two. Make sure that you read and understand the documentation
contained in the Timits.conf file before making changes.

Additional configuration requirements for Linux operating systems

If you use a Linux operating system, then you must check that your computer
meets the requirements listed in this topic.

Environment variable might need setting for Firefox or Mozilla
browsers

You might need to set the environment variable MOZILLA_FIVE_HOME to the folder
containing you Firefox or Mozilla installation. For example, setenv
MOZILLA_FIVE_HOME /usr/1ib/firefox-1.5.
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If you do not set this environment variable, then when you run the product you
might see the following error message:

org.eclipse.swt.SWTError: No more handles
[Unknown Mozilla path (MOZILLA_FIVE_HOME not set)]

Firefox browsers must be dynamically linked

To support the SWT browser widget, your Firefox browser must be dynamically
linked, which means it was not downloaded from mozilla.org, but was compiled
from source. This is typically the case when Firefox comes as part of the
distribution (that is, it is in a place such as /usr/1ib/firefox).

One way to ensure that this is true is to see if it is the browser that is pointed at
by /etc/gre.conf. The purpose of this gre.conf file is to point at an embeddable
browser.

If your browser is not dynamically linked, then you might see the following error
message whey you run the product:
org.eclipse.swt.SWTError: No more handles
(java.lang.UnsatisfiedLinkError:
/home/n0002466/ .eclipse/ibm.software.development.platform_7.0.0
/configuration/org.eclipse.osgi/bundles/267/1/.cp/1ibswt-mozilla-gtk-3236.s0
(Tibxpcom.so: cannot open shared object file: No such file or directory))
SUSE Linux might require a fix for invisible text problem.))

SUSE Linux might require a fix for invisible text problem

If your operating system is SUSE Linux Enterprise Desktop 10 SP1 or SUSE Linux
Enterprise Server 10 SP1, then you might need the following operating system
update to resolve a problem with text not being displayed in some editors:

http://support.novell.com/techcenter/psdb/44ab155e3202595389¢c101e6cf7e20f2.html
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Chapter 7. Starting Developer for System z

About this task

You can start Developer for System z from the Windows desktop environment or
the command-line interface, as follows:

* To start IBM Rational Developer for System z from the Windows Start menu,
click Start -> All Programs -> [package group name] -> IBM Rational
Developer for System z -> IBM Rational Developer for System z.

* To start IBM Rational Developer for System z on a Linux system, click the IBM
Rational Developer for System z shortcut from the application shortcut menu in
your desktop environment.

| Windows |

To start Developer for System z from a command line, type <product install
directory>\eclipse.exe .

To start Developer for System z from a command line, type <product install
directory>/eclipse.
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Chapter 8. Modifying installed packages

About this task

The IBM Installation Manager Modify Packages allows you to change the content
of the installed packages by adding or removing features. This functionality is
available only on packages that have been installed using the IBM Installation
Manager.

Note: You may need access to the original installation media and update media to
modify your installation. See the Installation Manager help for more information.

Note: Close all programs that were installed using Installation Manager before
modifying.

Note: You cannot modify the Eclipse location or JVM.

To modify an installed package, take the following steps:
1. From the main panel of Installation Manager, click the Modify Packages icon.

2. On the Modify Packages panel, select the package group that contains the
packages you want to modify. If you need help determining what packages are
installed, click Cancel, then click File -> View Installed Packages. The page
that is displayed shows you the package groups and packages that are installed
on your system. When you are ready, click Modify Packages again, select the
package group, and click Next to continue.

3. On the Languages panel, select or deselect any languages you want to add or
remove and click Next.

4. On the Features panel, the currently installed features are preselected. Select
any additional features you wish to install, or deselect any of the installed
features to remove them. When you have finished making your selections, click
Next to continue.

5. On the Summary panel, review your choices before you begin modifying your
installation. If you want to change the choices you made on previous panels,
click Back and make your changes. When you are satisfied with your choices,
Click Modify to make the changes you specified. The modification process
begins and a progress indicator shows you the percentage of the process
completed.

6. The Complete page is displayed with results.
7. Click View Log File to see the complete installation log.

© Copyright IBM Corp. 2000, 2010 59



60 IBM Rational Developer for System z 8.0.1: Installation Guide



Chapter 9. Updating installed packages

About this task

You can use IBM Installation Manager to install product updates and new features
for any packages that were installed by Installation Manager.

By default, Internet access is required to install updates unless your repository
preferences point to a local or network update repository to which your system has
access. See the Installation Manager help for more information.

Note: Close all programs that were installed using Installation Manager before
updating.

To find and install package updates, take the following steps:

1.

If you want to install updates from a specific repository, for example a
repository stored on an HTTP Web server in your intranet, you need to
specify the repository location in the Installation Manager preferences before
proceeding. If you want to simply let Installation Manager search the internet
for updates for you, you do not need to perform this step.

Note: When you specify repositories in the Installation Manager preferences,
Installation Manager will still search the internet for updates in addition to
searching the repositories you specify. If you do not want Installation Manager
to search for updates, go to File -> Preferences and deselect the Search
service repositories during installation and updates checkbox at the bottom
of the Repositories panel. This tells Installation Manager to search only the
repositories specified in the preferences and not to search the internet.

From the main panel of the Installation Manager, click Update.

On the Update Packages panel, select the package group that contains the
packages you want to modify. If you need help determining what packages
are installed, click Cancel, then click File -> View Installed Packages. The
page that is displayed shows you the package groups and packages that are
installed on your system. If you want to check for updates for all of your
installed packages, select the Update All check box. Click Next to continue.

Installation Manager searches for any available updates to the installed
packages. The next panel displays a list of available updates that were found.

By default, only the recommended updates are displayed. If you want to see
all the updates for the package, click Show All. The updates are displayed
with the required dependencies preselected.

Select the updates that you want to install and click Next.

On the Licenses panel, read the license agreements for the selected updates.
There will be a license agreement for each update you selected to install. On
the left side of the License panel, click each package name to display its
license agreement.

a. If you agree to the terms of all of the license agreements, click I accept the
terms of the license agreements.

b. Click Next to continue.

On the Summary panel, review your choices before you begin installing the
updates. If you want to change the choices you made on previous panels,
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click Back and make your changes. When you are satisfied with your
installation choices, click Update to install the update. The update installation
begins and a progress indicator shows you the percentage of the installation
completed.

9. The Complete page is displayed with results.
10. Click View Log File link to see the complete installation log.
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Chapter 10. Uninstalling Developer for System z

About this task

The Uninstall option in the Installation Manager allows you to uninstall packages
that were previously installed using Installation Manager.

To uninstall the packages, you must log in to the system using the same user
account that you used to install the packages.

| Windows |

Do one of the following to begin the uninstall process:

¢ From the Windows Add or Remove Programs screen, select IBM Rational
Developer for System z (package group name) and click Remove. This launches
IBM Installation Manager.

* From the Windows Start menu, click Start -> All Programs -> IBM Installation
Manager -> IBM Installation Manager.

Note: If you did a non-administrator installation, you would click Start -> All
Programs -> My IBM Installation Manager -> My IBM Installation Manager

Perform the following steps to begin the uninstall process:
1. Open a terminal window.

2. Change to the <Installation Manager install directory>/eclipse directory.
(Example: /opt/IBM/InstallationManager/eclipse)

3. Run /IBMIM.

Procedure
1. Close all programs that you installed using Installation Manager.
2. From the main panel of Installation Manager, click Uninstall.

3. On the Uninstall Packages panel, select the packages you want to uninstall.
Click Next.

4. In the Packages page, select the packages you want to uninstall and click Next.

5. On the Summary panel, review the packages you selected to uninstall. Click
Back if you want to make any changes. Click Uninstall to begin the uninstall
process.

6. The Complete panel is displayed after the uninstallation finishes and shows the
results.

7. Click Done.
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Chapter 11. Migration

Migrating WebSphere Developer for zSeries or WebSphere Developer
for System z workspaces

About this task

If you have a workspace you used in WebSphere® Developer for zSeries® 6.0.1 or
WebSphere Developer for System z 7.0, and you want to migrate the workspace for
use with IBM Rational Developer for System z Version 8.0.1, you must follow these
steps:

1. Install IBM Rational Developer for System z Version 8.0.1.

2. Start Rational Developer for System z, specifying the name of the workspace
you are migrating. The old workspace is migrated automatically so that all the
old artifacts are present and appear in the new workspace.

3. Rational Developer for System z Version 7.x workspaces will be migrated to
Version 8.0.1.

Note: Developer for System z cannot be upgraded from version 7.x to version 8.0.1.
Version 8.0.1 can coexist with all previous versions of Developer for System z in a

different installation location.

Note: Developer for System z does not support migrating a Windows-based
workspace into a Linux-based Developer for System z 8.0.1 workspace.
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Appendix A. Installing additional software

Installing required System z components

See the Developer for System z Host Planning Guide for details on installing required
System z components.

Installing IBM TxSeries for Multiplatforms
About this task

CICS TxSeries for Multiplatforms provides a local CICS development platform so
you can develop CICS programs.

CICS TxSeries has its own set of installation documentation, which is available on
the disk with the product.

To install IBM TxSeries for Multiplatforms:

1.

Insert the IBM Rational Developer for System z Installation disk, or open the
RDz801Edition_Setup directory of your electronic image.

Run Taunchpad.exe to start the launchpad program.

Click the Install optional software tab on the left side of the launchpad
window.

Click Launch IBM TxSeries for Multiplatforms v7.1 installation to launch the
installation.

When prompted, insert the IBM TxSeries for Multiplatforms v7.1 installation
CD, or specify the location that contains the electronic installation image.

After the installation starts, follow the prompts on the screen to perform the
installation.

Installing the UML Profiles for COBOL Development extension
About this task

Note: This extension requires that you have IBM Rational Software Architect
Version 8.0.1 installed prior to the installation, or that you install it at the same
time as the extension. The extension can be installed with or without Developer for
System z installed.

To install the UML Profiles for COBOL Development extension:

1.

Insert the IBM Rational Developer for System z Installation disk, or open the
RDz801Edition_Setup directory of your electronic image.

| Viindows |

Run Taunchpad.exe to start the launchpad program.
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Run Taunchpad.sh to start the launchpad program.

3. Click the Install optional software tab on the left side of the launchpad
window.

4. Click Launch UML Profiles for COBOL Development installation to launch
the installation.

5. If you are prompted, insert the IBM Rational Developer for System z Installation
disk, or specify the location that contains the electronic installation image.

6. After IBM Installation Manager starts, follow the prompts on the screen to
perform the installation.

If you already have IBM Rational Software Architect installed, choose the
package group in which you install it when you are prompted to select the
existing package group for installation.

If you are installing Rational Software Architect at the same time as UML
Profiles for COBOL Development, you can either create a new package group
or install into an existing one.

Installing RSE Server for Multiplatform

See the Developer for System z RSE Server Installation and Configquration Guide on the
IBM Rational Developer for System z RSE Server for AIX, Linux, and Linux on System z
Installation disk for details on installing the optional RSE Server.

See the IBM Rational Developer for Power Systems Software V8.0 Installation Guide, file
AIXp_LinuxpServerInstall.html on the IBM Rational Developer for zEnterprise Server
Installation Disk, for details in installing the optional RSE Server on Power/AIX and
Power/Linux on IBM Rational Developer for zEnterprise.

Installing the Rational Team Concert Integration extension

68

The Rational Team Concert Integration extension can be installed at the same time
you install Developer for System z by doing the following:

1. Start the installation by choosing either a guided or expert installation from the
launchpad, as described in [“Using the launchpad program” on page 26/

2. When Installation Manager is launched to begin the installation, "Rational Team
Concert - Client for Eclipse IDE" and the "Rational Team Concert Integration
extension" will be listed on the Available Packages panel.

3. Select the Rational Team Concert Integration extension if it is not already
selected.

4. If either Rational Developer for System z or Rational Team Concert - Client
for Eclipse IDE is not selected, and you do not already have the one that is not
selected installed, select that one.

5. Click Next and follow the panels in the Install Packages wizard to install the
extension.
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Appendix B. Known problems and limitations

This section covers known problems and limitations with installation and
uninstallation.

For information about product problems and limitations, refer to the
rdz80_releasenotes.html file located in the Documents\n1\en\readme directory of

the IBM Rational Developer for System z Installation disk or IBM Rational Developer for
zEnterprise Installation disk.
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Appendix C. IBM Packaging Utility

You can use the IBM Packaging Utility software to copy packages to a repository
that can be placed on a Web server available over HTTP or HTTPS.

The Packaging Utility software is included on the IBM Rational Enterprise
Deployment disk. If you want to place a repository containing Developer for
System z and other packages on a Web server available over HTTP, then you must
use the Packaging Utility to copy the packages into the repository.

You can use this utility to perform the following tasks:
* Generate a new repository for packages.

* Copy packages to a new repository. You can copy multiple packages into a
single repository, thereby creating a common location in your enterprise from
which products can be installed using IBM Installation Manager.

* Delete packages from a repository.

Refer to the online help for the Packaging Utility for full instructions on using the
tool.

Installing the Packaging Utility
About this task

The IBM Packaging Utility must be extracted from a compressed file before it can
be used to copy the Developer for System z package.

Use the following steps to extract the IBM Packaging Utility software:

1. Locate the Packaging Utility compressed file on the IBM Rational Enterprise
Deployment disk for your platform. The compressed file containing the
Packaging Utility for Windows is located on the disk at PackagingUtility\
pu.disk_win32.zip. The compressed file containing the Packaging Utility for
Linux is located on the disk at PackagingUtility/pu.disk_Tlinux.zip.

2. Extract the files from the compressed file containing the utility into a temporary
directory. Be sure to preserve the directory of the compressed files. These are
the installation files you will use to install the Packaging Utility.

3. Change to the directory where you extracted the Packaging Utility installation
files and start the installation program.

4. On Windows, run InstallerImage win32\install.exe. On Linux, run
InstallerImage_linux/install.

5. Installation Manager will start up with the Install Packages wizard configured
to install Packaging Ultility.

6. Follow the on-screen instructions in the Install Packages wizard to complete the
installation.

Copying packages to an HTTP server using the Packaging Utility
About this task

If you want to create a repository on an HTTP server, then you must use the
Packaging Utility to copy packages to the repository. The Packaging Utility can be
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used to combine multiple product packages, as well as service updates, into a
single repository location. Refer to the Packaging Utility online help for more
information.

To copy packages with the packaging utility, take the following steps:

1.

10.
11.

Start Packaging Utility from the Windows Start menu through Start -> All
Programs -> IBM Packaging Utility -> IBM Packaging Utility.

On the main page of the utility, click Copy Packages.

Read the information provided and click Next.

On the Source panel, click Open repository... and enter the location of the
package you want to copy. For Developer for System z and its bundled
offerings, you would point to the repository.config file located either on the
IBM Rational Developer for System z Installation disk or in the
RDz801Edition_Setup directory of an electronic image.

Alternatively, you can select Passport Advantage... to enter your Passport
Advantage ID and password and copy packages from the Passport
Advantage.

Select the packages you want to install from the list of packages that are
available in the repository you selected. Click Next.

Read the terms of the license agreements for the selected packages. If you
agree to the terms, select I agree with the terms of the license agreements
and click Next.

On the Destination panel, select an existing repository or click Browse and
select the location where you would like to store your repository. Click OK
once you have selected your destination directory.

Click Next to advance to the Summary page. The Summary page displays the
selected packages that will be copied into the destination repository. This page
also lists the amount of storage space that the copy requires, as well as the
amount of available space on the drive.

If you would like to make changes, click Back to return to previous panels
and make changes. When you are satisfied with your selections, click Copy to
copy the selected packages to the destination repository. A status bar appears
at the bottom of the wizard indicating how much time is remaining in the
copy process. Once the copy process is finished, a Complete page opens and
displays all of the packages that were copied successfully.

Click Done to return to the Packaging Utility main page.

If you would like to copy additional offerings to your repository, repeat steps
2-10, specifying the additional packages you want to copy.

Now that you have used the Packaging Utility to copy the Developer for System z
installation files into a repository, you can place the repository on a Web server or
other shared driver and make it available over HTTP or HTTPS. (The repository
can also be placed on a UNC drive.)
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Notices

© Copyright IBM Corporation 2000, 2010.

U.S. Government Users Restricted Rights - Use, duplication or disclosure restricted
by GSA ADP Schedule Contract with IBM Corp.

Programming interfaces: Intended programming interfaces allow the customer to
write programs to obtain the services of Rational Developer for System z.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.

1623-14, Shimotsuruma, Yamato-shi
Kanagawa 242-8502 Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.
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Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

Intellectual Property Dept. for Rational Software
IBM Corporation

3039 Cornwallis Road, PO Box 12195

Research Triangle Park, NC 27709

USA.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.
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Copyright license

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Trademarks and service marks

See www.ibm.com /legal / copytrade.shtml}

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corp., registered in many jurisdictions worldwide.
Other product and service names might be trademarks of IBM or other companies.
A current list of IBM trademarks is available on the Web at www.ibm.com/legal/
copytrade.shtml.

Rational are trademarks of International Business Machines Corporation and
Rational Software Corporation, in the United States, other countries, or both.

Intel and Pentium are trademarks of Intel Corporation in the United States, or
other countries, or both.

Microsoft, Windows, and the Windows logo are trademarks or registered
trademarks of Microsoft Corporation in the United States, or other countries, or
both.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States and other countries.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Copyright license

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided "AS IS", without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.
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countries.
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