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Preface
This manual provides detailed instructions about how to upgrade to the current 
version of Rational Suite when an earlier version is already installed on your 
computer or your network. (For information about installing Rational Suite for the 
first time, see the Installation Guides for Rational Desktop Products and Rational 
Server Products.) 

Rational Suite delivers a comprehensive set of integrated tools that embody software 
engineering best practices and span the entire software development life cycle. 
Rational Suite's unparalleled level of integration improves communication both 
within teams and across team boundaries, reducing development time and improving 
software quality. 

Audience

 This manual is intended for administrators who install and configure Rational Suite. 

Other Resources

■ All manuals are available online, either in HTML or PDF format. The online 
manuals are on the Rational Solutions for Windows Online Documentation CD. 

■ To send feedback about documentation for Rational products, please send e-mail 
to techpubs@rational.com.

■ For more information about Rational Software technical publications, see: 
http://www.rational.com/documentation. 

■ For more information on training opportunities, see the Rational University Web 
site: http://www.rational.com/university.

■ For articles, discussion forums, and Web-based training courses on developing 
software with Rational Suite products, join the Rational Developer Network by 
selecting Start > Programs > Rational Software > Logon to the Rational Developer 
Network.
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Contacting Rational Customer Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Customer Support as follows:

Note:  When you contact Rational Customer Support, please be prepared to supply the 
following information:

■ Your name, company name, telephone number, and e-mail address

■ Your operating system, version number, and any service packs or patches you 
have applied

■ Product name and release number

■ Your service request number (if you are following up on a previously reported 
problem)

Your Location Telephone Facsimile E-mail

North America (800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com 

Europe, Middle 
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4546-201
Netherlands

support@europe.rational.com 

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com 
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1Planning an Upgrade
If you upgrade to Rational Suite 2003 from an earlier version, you need to upgrade 
your software and datastores in a specific order to continue using your team’s data. 
When you upgrade, you need to upgrade all computers in your environment so that 
datastores and software are all running the same version of Rational software. Read 
this manual to understand how to upgrade successfully. 

This manual collects information available for individual products. Any changes 
made after this book went to press are recorded in the Rational Suite Release Notes. The 
Release Notes are in the top-level directory of the Rational Solutions for Windows 
installation CD-ROMs, in the readme.htm file.

This chapter describes how to plan for a successful upgrade. It concludes with a 
checklist to help you determine whether you are ready to upgrade.

Overview: Flow of Events

This manual describes the steps to upgrade Rational Suite. At a high level, these steps 
are as follows:

■ Create an upgrade plan, including schedule, people to involve, milestones, and 
special notes for your installation. 

■ Ensure that users are not connected to Rational products or their datastores – 
either instruct them to disconnect or, from each server, disconnect all users. 

■ Remove existing Rational software from your computer.

■ Install the current version of Rational Suite on servers and administrator systems.

■ Upgrade datastores for installed products and perform configuration tasks.

■ Optionally configure web servers.

■ Test the upgrade to make sure everything is working correctly.

■ Install new software on desktops and perform minor tasks.

■ Alert users that they can resume using the tools.
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Creating an Upgrade Plan

In a large organization, coordinating and implementing an upgrade can be a complex 
task. We recommend that you create an upgrade plan so that all affected people 
understand their responsibilities in the process. We suggest that you include at least 
the following topics in your plan:

■ Why are you upgrading? Include an overview of new features or a pointer to the 
new features in the Rational Suite Release Notes.

■ Who is participating in the upgrade? Include each person’s name, contact 
information, role, and responsibility.

■ When is the upgrade taking place? Include a schedule with milestones and specific 
dates.

■ What are you upgrading? Include a list of Rational point products that you use in 
your environment and special considerations for each product.

■ What else do you need? Include special information about your environment that 
is relevant to the upgrade.

■ How will you verify success? What are your acceptance criteria for a successful 
upgrade?

■ Do you have contingency plans for administrators performing the upgrade and for 
users who may have problems after the upgrade? Will knowledgeable people be 
available to help during the upgrade?

Who Should Participate

Before you upgrade, identify the members of your upgrade team. The following list 
describes the types of people to involve. 

■ Network or System administrators – install Rational tools, may decide to set up a 
silent install

■ Database administrators (DBAs) – upgrade enterprise databases

■ Configuration managers – administer ClearCase

■ Project leaders – use the Rational Administrator to maintain Rational projects; 
represent needs of the users

■ The Change (or Configuration) Control Board – members of the team who govern 
a project’s software development environment
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In a smaller group, one person may perform more than one of these roles (for 
example, the DBA might be the same person as the network administrator). In a larger 
group, several people may perform just one role; in that case, identify one main 
contact in each role.

Which Products Are You Upgrading

Use the following worksheet to note which products are part of your environment 
and how they are configured. Remember that editions of Rational Suite include 
different combinations of these products. Your configuration should help you 
determine which roles to involve in the upgrade.

Notes:

■ NA means not applicable.
■ In the Upgrade? column, indicate whether the product is in your environment.
■ In the Database column, write the type of database you use with the product.
■ In the Web column, indicate whether you use the Web interface for the product.
■ In the VOB Server column, write the name of the VOB Server.
■ In the File Server column, indicate where you store this product’s artifacts.

Understanding the Rules of Upgrading

Before you upgrade your Rational software, you need to understand the rules that 
apply, as described in this section.

Table 1 Worksheet: Which Products Will You Upgrade?

Product Upgrade? Database Web VOB Server File Server

ClearQuest NA

Rational Unified 
Process

NA NA

ProjectConsole NA

RequisitePro NA

ClearCase NA

Test Products NA

Rose NA NA NA
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Can You Upgrade Directly?

In most cases, you can upgrade directly from your starting version, but in a few cases, 
you need to upgrade to an intermediate version before you can upgrade to the current 
version. The general rules are as follows; more detailed information is in Table 2:

■ For servers, if you are starting from one or two versions back (version 2001A or 
2002), you can upgrade directly to the current version, 2003. 

■ For desktops, after you upgrade the servers, if you are starting at version 2000 or 
later, you can upgrade directly to the current version, 2003.

Table 2 Paths to Upgrading Rational Suite

If you are starting from this version Then upgrade as follows

Servers running Rational Suite 2002 or 
2001A 

Follow the procedures in this manual.

Servers running Rational Suite 2001 or 
2000

1 Upgrade to version 2001A, as described in 
“Upgrading from Earlier Versions of Rational 
Suite” in the 2001A version of Installing Rational 
Suite (see www.rational.com/documentation).

2 Upgrade from version 2001A to the current version 
by following the procedures in this chapter.

Desktops running Rational Suite 2000 
or later

1 Before you start, ensure that servers are upgraded. 

2 Upgrade desktops directly to the current version.

Rational Suite 1.5, 1.1, or 1.0 1 Upgrade servers and desktops to version 2000; 
contact Rational Customer Support for more 
information.

2 Upgrade servers from version 2000 to version 
2001A, as described in “Upgrading from Earlier 
Versions of Rational Suite” in the 2001A version of 
Installing Rational Suite (see 
www.rational.com/documentation).

3 Upgrade servers from version 2001A to the current 
version by following the procedures in this manual.

4 Upgrade desktops from version 2000 to the current 
version by following the procedures in this manual.

A Rational point product, any version Contact Customer Support for more information.
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Upgrade, Then Make Major Changes

If you plan to make major changes to your environment, perform them after 
determining that the upgrade is successful. Do not attempt to make major changes to 
your Rational Suite environment in the middle of the upgrade. An example of a major 
change is switching a vendor database, enabling a project for use with Unified 
Change Management, or adding new point products to your environment. If you are 
adding a new product, read about prerequisites and postrequisites in the Installation 
Guides for Rational Server Products and Rational Desktop Products. 

Exception: Version 2003 no longer supports the Microsoft Windows 9x operating 
systems (Windows 95, Windows 98, Windows Me). Update these older operating 
systems before starting the Rational Suite upgrade. (You can use Rational Robot to 
record and run test scripts on Windows 98 and Windows Me, and Rational 
TestManager to run scripts on those platforms. For more information, read about 
platform support in the Rational Testing Products Release Notes.) 

Back Up Databases and Datastores 

We strongly recommend that you back up your databases and datastores on a regular 
basis. Before upgrading, make sure that you have backups of all your data, and back 
up different datastores at the same point in the project (this is sometimes called a 
“simultaneous” backup). Doing so will ensure project consistency should you need to 
restore your data.

For more information about creating backups, contact Rational Customer Support.

Plan to Verify Upgrade Success

Because upgrading software changes both the software and your environment, it is 
important to verify that the upgrade is successful. Here are some suggestions: 

■ Many organizations benefit from performing a test upgrade in a non-production 
area of their network. Some organizations copy all data stores to a lab environment 
and test there first before starting a production upgrade. By using this technique, 
you can understand the special considerations that apply to your environment 
before you upgrade your production data.

■ To ensure that the software is running normally, run a series of tests after the 
upgrade but before desktop users resume use of the software. We recommend that 
you determine your group’s acceptance criteria before the upgrade and that you 
document those criteria in your upgrade plan.
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Special Rules for Upgrading ClearCase and ClearQuest

This section describes special considerations for upgrading ClearCase and 
ClearQuest, including how to prepare for the upgrade, and working with the 
products in a standalone environment. 

Preparing to Upgrade ClearCase 

If you use Rational ClearCase or Rational ClearCase LT to store Rational data, make 
these preparations:

■ If you use ClearCase or ClearCase LT to store assets from Rational RequisitePro or 
Rational Test, make sure that those assets are available through a ClearCase view 
so that you can upgrade the data stores.

■ If you established the integration between Rational Suite and ClearCase by using 
the Rational Administrator to create a UCM-enabled project, your RequisitePro 
and Rational Test assets are already checked out and you don’t need to take further 
steps. We recommend, however, that you perform the following steps so that you 
can revert to the current version should the need arise:

❑ Use the Rational Administrator to perform a Check in All operation for the 
RequisitePro project and the Test datastore. (In the Administrator, on the 
Configure dialog box for your project, click Check in All for both datastores. 
ClearCase checks in all project-related assets, then checks them out again.)

❑ Create a baseline (In the ClearCase Project Explorer, select the project, then click 
Tools > Make Baseline).

■ If you used another method to integrate Rational Suite and ClearCase, then:

❑ We recommend that you create a label to mark the latest versions of your 
datastores. This will allow you to revert to the current version should the need 
arise.

❑ Check out RequisitePro and Rational Test assets that you store in ClearCase. If 
you do not, the upgrade will fail.

Working with Full ClearCase, ClearQuest, and MultiSite

The Rational Shipping Server is required by both Rational ClearCase Multisite and 
Rational ClearQuest MultiSite. It should be installed only on those hosts that are 
responsible for replicating data to other sites. 

We recommend that you avoid configuring any one host to run the Shipping Server 
for both products, because de-installing either product from such a host will remove 
the Shipping Server that is used by both products and render the remaining product 
inoperable. 
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If you must install both ClearCase MultiSite and ClearQuest with the Shipping Server 
on the same host, ensure you do the following:

■ Install ClearCase first.

■ Uninstall both products if you ever uninstall either product.

Warning:  Administrators should ensure that site configuration files for typical host 
systems do not specify installation of the ClearQuest Shipping Server. Any 
attempt to install ClearCase on a host where ClearQuest and the Shipping 
Server is already installed will fail. 

You Cannot Run with Mixed Versions of Software

All Rational tools and all servers and desktops must run the same version of Rational 
software. With just a few exceptions, you cannot mix versions. 

Exceptions

The exceptions are as follows:

■ You can install a v2003 product on a computer that already has full ClearCase v4.2 
or later.

Note:  If you plan to work with an older version of full ClearCase and a newer 
version of other Rational products, do not remove full ClearCase from your 
computer when you remove other Rational products from your computer.

■ If you are working with ClearQuest or ClearCase standalone, there may be 
situations where you can operate in a mixed-version environment. For more 
information, see Upgrading ClearCase or ClearQuest Standalone on page 23.

■ For information about mixing ClearQuest versions in an environment that has 
UNIX clients, see the ClearQuest Installation Guide for UNIX. 

Upgrading ClearCase or ClearQuest Standalone 

Your network environment can contain mixed versions of ClearCase and ClearQuest 
clients (where some clients are at v2003 and some clients are at earlier versions) if 
these products are in a standalone environment, that is: 

■ You’ve installed ClearCase only, ClearQuest only, or both.
■ You have not installed Rational Suite.
■ You have not installed other individual Rational point products.

In addition, for ClearQuest, the following items must be true.

■ You are not using ClearQuest MultiSite.
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■ As long as your network environment contains ClearQuest clients at v2001 or 
earlier, you plan to keep your database at its current feature level.

■ If your vendor database is SQL Anywhere, you do not plan to upgrade to SQL 
Anywhere 8.0 until all ClearQuest clients and databases have been upgraded to 
version 2003.

Upgrade Order

If you plan to use mixed versions of ClearCase or ClearQuest clients, the upgrade 
tasks remain the same as described in this manual, but the order in which you 
perform these tasks changes as follows:

1 Upgrade all ClearCase servers but do not change the ClearCase VOB feature level. 
VOBs and views are inaccessible during the upgrade process, but checked-out files 
and directories may remain checked out during the upgrade.

Rule: Newer ClearCase servers can communicate with newer or older clients.

2 To run ClearQuest in a mixed-version environment, apply a special package that 
prevents data corruption. 

3 Upgrade ClearCase and ClearQuest clients when it’s convenient to do so. You can 
operate in this mixed-version mode indefinitely.

Rule: Older ClearQuest databases can communicate with newer or older clients.

4 When all clients are upgraded, upgrade ClearQuest databases. If you are using an 
SQL Anywhere database, switch to SQL Anywhere 8.0.

5 Optional: when all clients are upgraded, increment the ClearCase VOB feature 
level.

Applying the Special ClearQuest Package

ClearQuest now has a feature, the data code page, which restricts ClearQuest 
databases to accept data in one character set only. To operate in a network 
environment with versions of ClearQuest earlier than v2003:

■ Work on an administrator host that has been upgraded to at least ClearQuest 
Version 2002.05.01 Patch 2. 

■ Apply the CharacterSetValidation package (using a script) to all ClearQuest 
schemas.

■ Set the ClearQuest data code page value for all associated user databases. 

■ If any clients are using a version earlier than 2002.05.01, Patch 2, then set the 
ClearQuest data code page to ASCII.
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For more information about working with ClearQuest data code pages, read about 
ClearQuest and Code Pages in the Rational ClearQuest Administrator’s Guide. For more 
information about performing these specific steps, read the section about 
Interoperation with Previous Versions of ClearQuest in the same guide.

Have You Met the Prerequisites?

Table 3 lists the prerequisites for installing Rational Suite products on servers.

Table 3 Server Requirements and Recommendations

Item Requirements and Recommendations

Operating Systems ■ Microsoft Windows XP Professional, Service Pack 1
■ Microsoft Windows 2000 Server, Service Pack 2, 3
■ Microsoft Windows 2000 Advanced Server, Service Pack 2, 3
■ Microsoft Windows 2000 Professional, Service Pack 2, 3
■ Microsoft Windows NT 4.0 Server, Service Pack 6a + SRP 

(Security Rollup Package, Q299444)
■ Microsoft Windows NT Workstation, Service Pack 6a + SRP 

(Security Rollup Package, Q299444)

Notes: 
■ The production release of Windows 2003 Server was not 

available for final testing for most products at the time this 
document was finalized. Please visit our web site 
www.ibm.com/software/rational/ to obtain the latest information 
on Windows 2003 Server support.

■ ClearCase LT server supports Windows 2003 Server.
■ See the Database section of this table for supported UNIX 

platforms that Windows clients can access.

Hardware ■ 500-600 MHz or higher
■ 256-512+ MB RAM ; 

More memory generally improves performance; required 
memory depends on the number of concurrent users, amount 
of data being requested, and the size of the database

■ 2 x physical memory is the recommended swap space
■ 250 MB or higher disk space for a Rational point product
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 ClearCase LT Server 
File Storage Space 
Requirements

■ Rational ClearCase LT needs enough disk space on the server to 
contain the files and databases under source control. The 
amount of space required depends on the characteristics and 
use of the VOBs and views.

■ In addition to the free disk space required to load the Rational 
ClearCase LT server, the server needs 0.5 to 1.0 MB for each 
user who will access the ClearCase Web interface through the 
ClearCase LT server.

Rational Suite
Disk Space

■ Rational Suite Enterprise – 1.6 GB (full), 1.2 GB (typical), 
1.9 GB (Enterprise Deployment)

■ Rational AnalystStudio – 1.2 GB (full), 851 MB (typical)
■ Rational DevelopmentStudio – 1.4 GB (full), 1.1 GB (typical)
■ Rational DevelopmentStudio for UNIX (Windows components 

only) – 515 MB (full), 445 MB (typical)
■ Rational DevelopmentStudio – RealTime Edition – 1.4 GB (full), 

1.1 GB (typical)
■ Rational DevelopmentStudio – RealTime Edition for UNIX 

(Windows components only) – 515 MB (full), 445 MB (typical)
■ Rational TestStudio – 1.4 GB (full), 1.1 GB (typical)
■ Rational TeamTest – 645 MB (full), 583 MB (typical)
■ Rational Team Unifying Platform – 1.1 GB (full), 825 MB 

(typical)

Note: If Rational ProjectConsole is include in your Rational Suite, 
it requires 1+ GB for its repository.

Table 3 Server Requirements and Recommendations (continued)
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Point Product
Disk Space

■ ClearCase LT Server: 264 MB (full)
■ ClearQuest Multisite Administrator: 250 MB
■ ClearQuest Web Server: 250 MB
■ Rational Shipping Server: 250 MB
■ Terminal Server (ClearQuest): 250 MB
■ PurifyPlus for Windows: 70 MB (full), 68 MB (typical)
■ QualityArchitect: 250 MB
■ Rational Unified Process: 195 MB (full/typical)
■ RUP Modeler: 50 MB
■ RUP Organizer: 2-4 GB
■ RequisitePro: 192 MB (full), 176 MB (typical)
■ Robot: 282 MB (full/typical)
■ Rose Enterprise Edition: 456 MB (full/typical)
■ SoDA: 150 MB (Microsoft Word), 100 MB (FrameMaker)
■ TestManager: 379 MB (full/typical)

Table 3 Server Requirements and Recommendations (continued)
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Databases ClearQuest Databases
■ IBM DB2 Universal Database 7.2 with Fix Pack 8, 8.1
■ Microsoft SQL Server 7.0, Service Pack 4; SQL Server 2000, 

Service Pack 2, 3
■ Oracle server + Client 8.1.6, 8.1.7
■ Sybase SQL Anywhere 8.0.1 is available on the Rational 

Solutions for Windows installation disc. It is configured to work 
only with Rational products. Select SQL Anywhere from the 
Product Selection list in the Rational Setup Wizard. 

■ Microsoft Access 2000, 2002 Service Pack 1, 2 (You cannot use 
Access from the ClearQuest Web client.)

Note: ClearQuest also supports Oracle on Solaris 2.6, 7-9 and 
HP-UX 11.0 QPK1100, 11.11 GoldQPK11i and Bundle11i.

RequisitePro Enterprise Database
■ Microsoft SQL Server 7.0, Service Pack 4; SQL Server 2000, 

Service Pack 2, 3
■ Oracle server + client 8.1.7, 9, Service Pack R2

Note: RequisitePro also supports Oracle on Solaris 2.6, 7-9 and 
HP-UX 11.0 QPK1100, 11.11 GoldQPK11i and Bundle11i.

Rational TestManager Database
■ Microsoft Access 2000, 2002 Service Pack 1, 2
■ Sybase SQL Anywhere 8.0.1 is available on the Rational 

Solutions for Windows installation discs. It is configured to work 
only with Rational products. Select SQL Anywhere from the 
Product Selection list in the Rational Setup Wizard. 

Table 3 Server Requirements and Recommendations (continued)
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ProjectConsole Collection Agent 

If you install the agent software on additional computers, agents 
require the same version of ProjectConsole software as the server.

Additional Collection Support:
■ Microsoft Project 2000 Professional
■ Microsoft Project 2002 (.mpp only)
■ Rational XDE v. 2003

Web Server
■ Microsoft Word 2000 Service Pack 1
■ Microsoft Word 2002

Template Builder

Microsoft Word 2000 Service Pack 1; Word 2002
(required to create ProjectConsole Template Builder templates)

Repository (supports the same vendor databases as ClearQuest)
■ IBM DB2 Universal Database 7.1, 7.2 (Fix Pack 8), 8.1
■ Microsoft SQL Server 7.0, Service Pack 4; SQL Server 2000, 

Service Pack 2, 3
■ Oracle server + Client 8.0.5, 8.1.6, 8.1.7
■ Sybase SQL Anywhere 8.0.1 is available on the Rational 

Solutions for Windows installation disc. It is configured to work 
only with Rational products. Select SQL Anywhere from the 
Product Selection list in the Rational Setup Wizard. It is not 
installed by default with the product.

■ Microsoft Access 2000, 2002 Service Pack 1, 2.

Note: ProjectConsole also supports Oracle on Solaris 2.6, 7-9 and 
HP-UX 11.0 QPK1100, 11.11 GoldQPK11i and Bundle11i.

Table 3 Server Requirements and Recommendations (continued)
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Hosted Development 
Systems (remote 
sessions)

Rational ClearCase, Rational ClearCase LT, Rational ClearQuest, 
Rational RequisitePro, Rational Robot, Rational Rose, and 
Rational SoDA support hosted development on these platforms:
■ Citrix MetaFrame 1.8, Service Pack 2
■ Citrix MetaFrame XP Application Server
■ Microsoft Windows 2000 Advanced Terminal Server, Service 

Pack 2, 3

Notes: 
■ Rational ClearQuest supports Citrix MetaFrame and Citrix XP 

on all supported Windows server operating systems.
■ Rational ClearCase and ClearCase LT do not support remote 

sessions on Citrix XP and MetaFrame.

You must use floating licenses for these products. Node-locked 
licenses are not supported.

Web Servers ClearCase Web, ProjectConsole Server, RequisiteWeb use the 
Rational Web Platform. The Rational Web Platform runs on the 
server operating systems listed at the beginning of this table.

For ClearQuest Web:
■ IIS 5.0 on Windows 2000 Server Service Pack 2, 3
■ IIS 4.0 on Windows NT Server Service Pack 6a + SRP (Security 

Rollup Package, Q299444)

For Rational ManualTest Web Execution: 
■ Microsoft Internet Explorer 5.0 or later on the Web server
■ Microsoft Internet Information Services 5.0 (IIS 5.0) on 

Windows XP and Windows 2000
■ Microsoft Personal Web Server (PWS) from the Windows NT 

4.0 Option Pack (available from Microsoft, 
www.microsoft.com) on Windows NT 4.0 Workstation

■ Microsoft Internet Information Server (IIS) from the Windows 
NT 4.0 Option Pack (available from Microsoft, 
www.microsoft.com) on Windows NT 4.0 Server

We recommend that you use Windows 2000 Server, Windows 2000 
Advanced Server, or Windows NT 4.0 Server as the Web server 
platform. You cannot use a shared or networked project on 
Windows XP Professional, Windows 2000 Professional, or 
Windows NT 4.0 Workstation.

Table 3 Server Requirements and Recommendations (continued)
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Automated License 
Key Requests

Internet connection to request and receive license key files. For 
more information, see the Rational Software License Management 
Guide.

Dual Boot Systems Rational Suite does not support dual boot systems where both 
operating systems are on the same partition.

Rational 
Documentation

Adobe Acrobat Reader 4.x or higher to read online PDF files. 
Download the free Adobe Acrobat Reader from Adobe.com.

Language Support You can install Rational Suite on these international operating 
systems: 
■ Simplified or Traditional Chinese
■ Dutch
■ French
■ German
■ Hebrew
■ Italian
■ Japanese
■ Korean
■ Swedish

All displays, menus, controls, wizards, reports, and user 
documentation are in U.S. English. 
■ If you have a Traditional Chinese, Dutch, Hebrew, or Korean 

operating system, enter data (such as path names) in U.S. 
English or the ASCII character set.

■ If you have a Simplified Chinese, French, German, Italian, 
Japanese, or Swedish operating system, enter data in U.S. 
English or the native language character set. Regional date, 
time, currency, and numbering conventions are also supported 
for both input and output. 

Table 3 Server Requirements and Recommendations (continued)
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Table 4 lists the prerequisites for installing Rational products on desktops.

Table 4 Desktop Requirements and Recommendations

Item Requirements and Recommendations

Operating 
Systems

■ Microsoft Windows XP Professional, Service Pack 1
■ Microsoft Windows 2000 Professional, Service Pack 2, 3
■ Microsoft Windows NT 4.0 Workstation, Service Pack 6a + SRP 

(Security Rollup Package, Q299444)

Notes:

PurifyPlus supports additional operating systems. See the PurifyPlus 
Family Release Notes in the Rational Solutions for Windows Online 
Documentation CD for more information.

Robot and TestManager also support:

Windows 98, 98SE, and ME. However, the TestManager installation does 
not include the Rational Administrator if TestManager is installed on 
Windows 98, 98SE, or ME.

XDE:
■ For the latest information about XDE operating system support, see 

the Release Notes for Rational XDE.

The production release of Windows 2003 Server was not available for 
final testing at the time this document was finalized. Please visit our web 
site www.ibm.com/software/rational/ to obtain the latest information on 
Windows 2003 support.

Hardware ■ 500-600 MHz or higher
■ 256-512+ MB RAM;

more memory generally improves performance
■ Swap space: 2 x physical memory
■ 800 X 600 X 256-color video resolution, or higher; high color or true 

color recommended
■ Microsoft mouse or compatible pointing device

Notes:

XDE:
■ 512 MB RAM; 1 GB recommended for Developer versions.

Remote Access 
Support

See the Server Requirements and Recommendations table in the 
Installation Guide for Rational Server Products or the Rational Suite 
Release Notes.
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Rational Suite
Disk Space

■ Rational Suite Enterprise – 1.6 GB (full), 1.2 GB (typical)
■ Rational AnalystStudio – 1.2 GB (full), 851 MB (typical)
■ Rational DevelopmentStudio – 1.4 GB (full), 1.1 GB (typical)
■ Rational DevelopmentStudio for UNIX (Windows components only) – 

515 MB (full), 445 MB (typical)
■ Rational DevelopmentStudio – RealTime Edition – 1.4 GB (full), 

1.1 GB (typical)
■ Rational DevelopmentStudio – RealTime Edition for UNIX (Windows 

components only) – 515 MB (full), 445 MB (typical)
■ Rational TestStudio – 1.4 GB (full), 1.1 GB (typical)
■ Rational TeamTest – 645 MB (full), 583 MB (typical)
■ Rational Team Unifying Platform – 1.1 GB (full), 825 MB (typical)

Point Product
Disk Space

ClearCase LT client file storage space:

Rational ClearCase LT needs enough disk space on the desktop to 
contain all files loaded into snapshot views and all view-private files 
added to the views. The amount of space required depends on the 
number and sizes of the files in the views.

■ ClearQuest native client: 371 MB (full), 321 MB (typical)
■ ClearQuest Web client: 50 MB (browser + JRE)
■ PurifyPlus for Windows: 70 MB (full), 68 MB (typical)
■ QualityArchitect: 250 MB
■ Rational Test Agent: 425 MB (We recommend more disk space for 

large virtual tester runs.)
■ Rational Unified Process: 195 MB (full/typical)
■ Rational Unified Process Modeler: 50 MB
■ Rational Unified Process Organizer: 2-4 GB
■ RequisitePro: 192 MB (full), 176 MB (typical)
■ Robot: 282 MB (full/typical)
■ Rose Enterprise Edition: 456 MB (full/typical)
■ SoDA: 150 MB (Microsoft Word), 100 MB (FrameMaker)
■ TestManager: 379 MB (full/typical)
■ XDE: 500 MB (minimum) for installation drive, 100 MB for workspace, 

2-5 GB recommended for workspace

Integrations with 3rd Party Applications

Table 4 Desktop Requirements and Recommendations (continued)
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ClearCase LT ■ Microsoft Office 2000 Service Pack 1, 2; 2002 without a Service Pack or 
Service Pack 1

■ Microsoft Word 2000 Service Pack 1, 2; 2002 without a Service Pack or 
Service Pack 1

ClearQuest ■ Crystal Reports 8.0, 8.5 (recommended for customizing standard 
reports)

■ Microsoft Project 98, 2000, 2002
■ Visual Source Safe 6.0, Service Pack 3 .NET

ProjectConsole 
Template Builder

■ Microsoft Word 2000 Service Pack 1; Word 2002
(required to create ProjectConsole Template Builder templates)

Integrations with 3rd Party Applications

(Purify 
PurifyPlus 
PureCoverage 
Quantify

For the latest support information, see the PurifyPlus Family Release 
Notes in the Rational Solutions for Windows Online Documentation 
CD.

RequisitePro ■ Microsoft Word 2000 Service Pack 1, 2; Word 2002 , Service Pack 1, 2
■ Microsoft Excel 2000, Service Pack 1, 2; Excel 2002, Service Pack 1, 2

Rose Microsoft JVM Build 3809

Robot and 
TestManager

■ If you are developing or running test scripts written in the Visual 
Basic language, Visual Basic 6 is required.

■ If you are developing or running Java test scripts, a JDK (Java 
Development Kit) is required.

SoDA ■ Microsoft Word 2000 Service Pack 1, 2; Word 2002 , Service Pack 1 

Table 4 Desktop Requirements and Recommendations (continued)
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IDEs, Integrations with 3rd Party Development Applications, Add-Ins, and 
Hosted Development Systems

ClearCase LT ■ Forte for C++ 6.x, Update 1
■ Forte for Java 2.0, 3.0
■ IBM VisualAge for Java 3.5.3, 4.0
■ IBM WebSphere Application Developer 5.0
■ IBM WebSphere Application Developer Integration Edition 5.0
■ IBM WebSphere Studio Enterprise Developer 5.0
■ IBM WebSphere Studio Site Developer 5.0
■ JBuilder 4.x – 8.x
■ Microsoft PowerBuilder 6.x – 9.x 
■ Microsoft Visual Basic 6.0, Service Pack 4, 5
■ Microsoft Visual C++ 5.0, 6.0, Service Pack 4, 5
■ Microsoft Visual InterDev 6.0
■ Microsoft Visual J++ 6.0, Service Pack 4, 5
■ Microsoft Visual Studio .NET 7.0, Service Pack 1 (with .NET 

Framework Service Pack 2); Studio .NET 7.1
■ Oracle JDeveloper 9.0
■ SunOne for Java 4.0
■ WebGain Studio 4.5.2
■ WebGain Visual Cafe 4.1 Expert Edition, 4.5.2 or higher Expert and 

Enterprise Editions

ClearQuest ■ Microsoft Visual Studio.NET, Service Pack 1 (with .NET Framework 
Service Pack 2)

■ IBM WebSphere Application Developer 5.0
■ IBM WebSphere Application Developer Integration Edition 5.0
■ IBM WebSphere Studio Enterprise Developer 5.0
■ IBM WebSphere Studio Site Developer Advanced 5.0 

Table 4 Desktop Requirements and Recommendations (continued)
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IDEs, Integrations with 3rd Party Development Applications, Add-Ins, and 
Hosted Development Systems

Rose ■ Rose Visual Basic: Microsoft Visual Basic 6.0 (Visual Studio 6.0)
■ Rose Visual C++: Microsoft Visual C++ 6.0 (Visual Studio 6.0 )
■ Rose J: JDK 1.1.6 

Rose Add-Ins that use a Web browser (for example, Web Publisher) 
support most common browsers.

Rose J supports the following Java IDEs. Use the JDK appropriate to your 
IDE.
■ VisualCafe in Studio 4.0, 4.1 Standard, Professional, Enterprise, and 

Expert Editions 
■ IBM VisualAge for Java 3.5, 3.5.3, 4.0 Professional and Enterprise 

Editions 
■ Forte for Java Community Edition 3.0 and 4.0
■ Forte for Java Enterprise Edition 3.0  and 4.0
■ Sun One Studio 3 and 4 Community and Enterprise Edition
■ JBuilder 4.0, 5.0, 6.0, 7.0, 8.0 Enterprise, Professional and Foundation 

Editions

Table 4 Desktop Requirements and Recommendations (continued)
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Rose Data 
Modeler

Rose Data Modeler can produce data models for the following databases:
■ IBM DB2 Universal Database + Client 5.x, 6.x, and 7.x
■ IBM DB2 OS390 + Client 5.x, 6.x
■ Microsoft SQL Server 6.x, 7.x
■ Oracle server + Client 7.x, 8.x, and 9.x
■ Sybase SQL Anywhere 8.0.1 is available on the Rational Solutions for 

Windows installation disc. It is configured to work only with Rational 
products. Select SQL Anywhere from the Product Selection list in the 
Rational Setup Wizard. 

■ Sybase System 12
■ SQL Server 2000

To reverse engineer Oracle and DB2 databases using Rose Data Modeler, 
an RDMS client must be installed.

Note: Rose Data Modeler also supports Oracle on Solaris 2.6, 7-9 and 
HP-UX 11.0 QPK1100, 11.11 GoldQPK11i and Bundle11i.

Make sure that the database server meets these minimum requirements:
■ Operating system: Windows NT 4.0 Server or Workstation 4.0 
■ Processor: Pentium 
■ Memory: 64 MB 
■ Disk space: 1.3 GB (minimum) 

Rose RealTime For the latest support information, see the Release Notes for Rose 
RealTime in the Rational Solutions for Windows Online Documentation 
CD.

XDE For the latest support information, see the printed Release Notes for XDE 
Developer and XDE Modeler in your XDE media kit.

XDE Tester For the latest support information, see the printed Release Notes for XDE 
Tester in you XDE Tester media kit.
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Rational Test 
Agent Software

In addition to the three listed as supported by all desktop products, you 
can install Test Agents on the following operating systems:

Windows
■ Microsoft Windows 2000 Server, Service Pack 2, 3
■ Microsoft Windows 2000 Advanced Server, Service Pack 2, 3
■ Microsoft Windows NT 4.0 Server, Service Pack 6a + SRP (Security 

Rollup Package, Q299444)
■ Microsoft Windows Millennium Edition
■ Windows 98 2nd edition

Note: If you use Windows XP Professional, ensure that Service Pack 1 is 
installed. 

UNIX
■ AIX 4.3
■ HP-UX 11
■ Solaris 2.6, 7- 9
■ Red Hat 7.1, 7.2, and 7.3 and 8.0 Personal Linux
■ Red Hat 7.1, 7.2, and 7.3 and 8.0 Professional Linux

■ If you are running test scripts written in the Visual Basic language,
VB 6 is required.

■ If you are running Java test scripts, a JDK is required.
■ Install TCP/IP on all Test Agents.

Table 4 Desktop Requirements and Recommendations (continued)
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Web Browsers on 
Windows

■ Microsoft Internet Explorer 5.5, Service Pack 1, 2; 6.0 without a Service 
Pack or Service Pack 1

■ Netscape Navigator 4.72 – 4.78, 7.0

Notes:
■ ClearCase Web and ClearQuest Web support Internet Explorer and 

Netscape Navigator 7.0 on Windows 98 2nd Edition, Windows ME, 
and Windows XP Home. 

■ ClearCase Web and ManualTest Web do not support Netscape 
Navigator 4.7x.

■ ProjectConsole does not support Netscape Navigator 4.72 – 4.78
■ RequsiteWeb also supports Netscape Navigator 4.70, 4.71
■ RUP Modeler and RUP Organizer support Netscape Navigator 

versions 6.2.1 and 6.2.3.
■ Some Rational products (including some Rose Add-In's) may require 

certain Microsoft Internet Explorer components. Rose is tested with 
one of the recommended versions of Internet Explorer. Attempting to 
install and run Rose without Internet Explorer installed may cause 
unpredictable results. However, you are not required to use Internet 
Explorer as your browser.
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Web Clients on 
Non-Windows 
Platforms

ClearCase Web
■ Netscape Navigator 7.0 on SuSE Linux 8.0, AIX 4.3.3, 5.1, 5.2, HP-UX 

11.x, Solaris 2.6, 7– 9 

ClearQuest Web
■ Netscape Navigator 7.0 on Red Hat Linux 7.1 - 7.3, SuSE Linux 8.0, 

AIX 4.3.3, 5.1, 5.2, HP-UX 11.x, Solaris 2.6, 7– 9 
■ Netscape Navigator 4.72 – 4.78 on Red Hat Linux 7.1 - 7.3, AIX 4.3.3, 

5.1, 5.2, HP-UX 11.x, Solaris 2.6, 7– 9

ManualTest Web
■ Netscape Navigator 4.78 on Solaris 2.9 (You can see the manual test 

scripts, but you cannot run and save the results to the project.
■ Netscape Navigator 4.78 on Red Hat Linux 7.3
■ Netscape Navigator 7.0 on Solaris 2.9

ProjectConsole
■ Netscape Navigator 7.0 on Red Hat Linux 7.1 - 7.3, SuSE Linux 8.0, 

AIX 4.3.3, 5.1, 5.2, HP-UX 11.x, Solaris 2.6, 7– 9 

RequisiteWeb and Rational Unified Process
■ Netscape Navigator 4.72-4.78
■ Netscape Navigator 7.0 on SuSE Linux 8.0

Rose Web Publisher
■ Netscape Navigator 4.7x on Solaris 2.6, 7– 9, and HP-UX 11.x
■ Netscape Navigator 4.74 on Red Hat Linux 7.1 - 7.3

XDE Web Publisher
■ Netscape Navigator 7.0 on Red Hat Linux 7.1 - 7.3, SuSE Linux 8.0
■ Netscape Navigator 4.72 – 4.78 on AIX 4.3.3, 5.1, 5.2, HP-UX 11.x, 

Solaris 2.6, 7– 9

Automated 
License Key 
Requests

Internet Connection to request and receive license key files. For more 
information, see the Rational Software License Management Guide.

Dual Boot 
Systems

Rational Suite and Rational Rose do not support dual boot systems 
where both operating systems are on the same partition.

Rational 
Documentation

Adobe Acrobat Reader 4.x or higher to read online PDF files. Download 
a free version of Adobe Acrobat Reader from http://www.adobe.com.

Table 4 Desktop Requirements and Recommendations (continued)
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Frequently Asked Questions

What is new in this version of the software? 

The major new features are described in the Rational Suite Release Notes.

Do I need to remove or uninstall software before upgrading?

Yes, you need to manually remove software before upgrading to a new version. 
Perform the steps in Removing Rational Products on page 137. Then, in the Control 
Panel, use the Add or Remove Programs tool to remove all Rational software from 
your system before starting the upgrade. If you do not remove software, the upgrade 
cannot proceed.

Make sure that you do not remove data storage (for example, VOBs, views, databases, 
or datastores) when you remove products. In particular, make sure that you do not 
locate data storage in subdirectories of directories installed by Rational.

Language 
Support

You can install Rational products on these international operating 
systems: 
■ Simplified or Traditional Chinese
■ Dutch
■ French
■ German
■ Hebrew
■ Italian
■ Japanese
■ Korean
■ Swedish

All displays, menus, controls, wizards, reports, and user documentation 
are in U.S. English. 
■ If you have a Traditional Chinese, Dutch, Hebrew, or Korean 

operating system, enter data (such as path names) in U.S. English or 
the ASCII character set.

■ If you have a Simplified Chinese, French, German, Italian, Japanese, 
or Swedish operating system, enter data in U.S. English or the native 
language character set. Regional date, time, currency, and numbering 
conventions are also supported for both input and output. 

Table 4 Desktop Requirements and Recommendations (continued)
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What happens to my existing repositories and data during an uninstall?

When the Rational installer removes an earlier version of a product, it does not 
remove the following files or software:

■ Rational license files
■ Data created by the user
■ System files that have been installed or updated by Rational
■ Components that another product may be using

Do I have to upgrade all of the systems and products my company uses at 
once?

Yes. Rational products share many components, so to operate correctly, all Rational 
products in a Suite environment must be at the same version number. There are a few 
exceptions to this general rule; for more information, see You Cannot Run with Mixed 
Versions of Software on page 23 and Upgrading ClearCase or ClearQuest Standalone on 
page 23. 

Can I still use my old license keys or do I need new ones?

The license keys you currently have installed will continue to work with the current 
version of Rational Suite.

If I install the software on drive D why does the product also need disk space on 
drive C?

Even if you have specified an alternate drive for installation, the setup program needs 
room on the same drive as the operating system (usually the C:\ drive) for the 
following reasons:

■ To install and modify various system .dll files

■ To install a small amount of information in the C:\flexlm directory if you have the 
Rational License Server installed

■ To install a sample project in C:\Classics when you install ProjectConsole

Do I have to reboot the machine during installation?

In many cases, a reboot is required during the installation of the new software. The 
setup program instructs you to reboot your machine if it is necessary to do so. After 
the reboot, you must log in using the same user id that you used to perform the 
installation. The installation continues. When it successfully completes, you can use 
the Rational software or log out and log in as another user.
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After I upgrade the software, how do I upgrade the data associated with the 
software? 

See Upgrading Servers and Administrator Systems on page 45 for more information 
about upgrading data used by your Rational tools.

What if I encounter problems during the upgrade? 

Contact Rational Customer Service as described on page xv.

Checklist: Are You Ready to Upgrade?

Use this checklist to determine whether you are ready to upgrade. When you can 
answer yes to all the questions in the checklist, then you are ready to upgrade.

Ready? Task

Have you read this manual to understand the upgrade process?

Have you read the Rational Suite Release Notes to determine whether there are 
updates to the upgrade process?

Have you created an upgrade plan?

Are the people on the upgrade team available when you need them?

Have you met the upgrade prerequisites, including those for operating systems and 
disk space?

Are you at the appropriate starting version (two versions back for servers, four 
versions back for desktops) or do you have a plan to get to an appropriate starting 
version?

Have you made backups of your data?

Can users disconnect from Rational tools when you plan to do the upgrade? 
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2Upgrading Servers and 
Administrator Systems 
We assume that you have already completed the tasks necessary to plan the upgrade, 
as described in Planning an Upgrade on page 17, and that all computers in your 
network meet the prerequisites.

This chapter describes how to upgrade servers in your Rational Suite environment by 
following these steps: 

■ Install new version of Rational Suite on servers
■ Upgrade SQL Anywhere software
■ Upgrade Rational ClearCase 
■ Upgrade Rational ClearQuest 
■ Upgrade a Rational Project (which upgrades RequisitePro and Rational Test)
■ Upgrade from Rational RobotJ to Rational XDE Tester
■ Upgrade Rational ProjectConsole
■ Migrate from Rational Rose to Rational XDE [optional]
■ Upgrade Rational Unified Process 

Installing New Software

In this section, you use the Rational Software Setup program to install the new version 
of Rational Suite. 

Before You Install

Before you install Rational software on a computer, perform these tasks, which are 
described in the remainder of this section:

■ Determine the type of installation to perform.
■ Save license server name, if you use a floating license.
■ Save ClearQuest information.
■ Save Rational project locations.
■ Perform tasks for ProjectConsole.
■ Perform tasks for ClearCase, if you use XDE.
■ Remove all existing Rational software from your computer.
■ Optional: Install Rational Download Manager.
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Determining the Type of Installation to Perform

Decide what type or types of installation to perform. Some of your options are to do 
the following:

■ Perform a regular installation from a CD, and have your users perform 
installations from a CD.

■ Create a release area and site defaults file so that desktop users can install more 
consistently with each other.

■ Create a silent installation so that users can install without having to interact with 
the installation program. 

For an overview of these and other options, see Deploying Rational Products on 
page 114.

Saving License Server Name

If you use a floating license scheme, record the name of your license server so that you 
can re-enter it after installation:

1 Start the License Key Administrator: click Start > Programs > Rational Software > 
Rational License Key Administrator.

2 If the License Key Administrator Wizard appears, click Cancel to dismiss it.

3 Click Settings > Client/Server Configuration.

4 Read the name of your License Server from the Single Server field or the Primary 
Server field. Record it here for future reference:

______________________

Saving ClearQuest Information

Saving the ClearQuest Connection

In ClearQuest, a connection refers to the set formed by one schema repository and all 
its associated user databases. When users log on to ClearQuest, they are asked to 
select the connection containing the database they want to use, then to select the 
database itself.

Connection names are machine-independent; you can rename a connection without 
changing its content on your machine. For more information about working with 
connections, see the Rational ClearQuest Administrator’s Guide.
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Creating a Connection Profile

Before you upgrade, create a connection profile for each connection in your network 
environment, as follows:

1 Start the ClearQuest Maintenance tool: click Start > Programs > Rational Software > 
Rational ClearQuest > Rational ClearQuest Maintenance Tool.

2 Click File > Export Profile.

3 Select the connection and provide a file name. Choose a directory that is not on the 
default Rational installation path.

4 Record the connection profile path here for future reference:

_________________________________________________

Later, you and other users can import the connection profile instead of manually 
typing information related to the connection.

Saving information about UCM

If you use the UCM integration between ClearCase and ClearQuest, then save the 
following information:

■ In ClearQuest, look at the UCM activities and write the name of the default user 
here:

_________________________________________________

■ Write the name of the user database you use with the integration:

_________________________________________________

Remembering Location of Rational Projects

Note the location of each Rational project now. After the upgrade, you need to browse 
to each project to re-register it:

1 Start the Rational Administrator: click Start > Programs > Rational Software > 
Rational Administrator.

2 In turn, select each project in the left pane. In the right pane, read the path and 
record it somewhere where you can retrieve it.

3 Record the locations of your Rational projects here for future reference:

_________________________________________________

_________________________________________________
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Performing ProjectConsole Tasks

Take the appropriate step, depending on whether you are installing ProjectConsole 
for the first time, or you are upgrading ProjectConsole.

Preparing to Install ProjectConsole for the First Time

Rational ProjectConsole was introduced in Version 2002, so it is possible that it is not 
yet installed on your network. If it is not installed, follow the instructions in the 
section, “Preparing to Install ProjectConsole,” in the Installation Guide for Rational 
Server Products.

Preparing to Upgrade ProjectConsole

If ProjectConsole is already installed on your network, perform the following steps:

1 Determine whether your schema is checked out; if so, check it in:

a Log onto ProjectConsole and start the ProjectConsole Designer Tool.

b Click the Schema menu and determine whether the Checkout option is enabled 
or disabled. If this option is enabled, then the schema repository is already 
checked in. If the option is disabled, then the option is checked out and you 
need to check it in. 

You cannot upgrade the ProjectConsole warehouse if the schema is checked 
out.

For more information, refer to Help for ProjectConsole.

2 Stop the following services:

❑ The default Web server under Internet Information Server (use the Computer 
Management utility)

❑ The World Wide Web (WWW) Publishing service 

❑ ProjectConsole servers and xmlagents.exe 

3 Change the Startup Type for the WWW service to Disabled or Manual. 

4 Back up the templates and other files you have added or modified in the following 
directories and their sub-directories: 
c:\program files\rational\jakarta-tomcat\webapps\ProjectConsole 
c:\program files\rational\ProjectConsole 

Note:  When you remove Rational Suite, the files that you have changed or added 
in ProjectConsole are removed from your system. Back them up to a safe place (a 
directory that is not used by Rational products) for later retrieval. For future 
reference, record the location of your backup on the following line:

_______________________________________________________
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5 In Version 2003, start pages are displayed, but root pages are not. If your current 
installation includes both types of pages, consider combining them into one page, 
start.htm.

6 Use database vendor tools to back up the schema repository and warehouse. 
Alternatively, you can use the ProjectConsole Maintenance Tool to copy the 
original databases to another set of databases.

Note:  ProjectConsole data migration occurs in place, replacing the earlier version 
of your data. If you do not back up the schema repository and warehouse, you 
have no recourse in the case that you need the earlier version of the data.

Performing Tasks for ClearCase for Use With XDE

In this version, ClearCase introduces Feature Level 4, which includes a new element 
type, xde, for use with XDE artifacts. If you used XDE with ClearCase 2002, you may 
have created an xde element type in your VOBs.

XDE 2002.05.20 Service Release 1 and XDE v2003 check ClearCase 2002 installations 
for proper configuration and create an xde element type if it is not already present. As 
part of changing to Feature Level 4, existing xde element types are renamed to 
xde_v5.0.

Understanding When to Run XDE Type Manager Installer

If you use XDE with ClearCase v2002 then ensure that you have defined an xde 
element type in your VOBs and that XDE files are associated with that type. To define 
the xde element type: run the XDE Type Manager Installer just before upgrading to 
ClearCase v2003 to ensure that existing VOBs are properly configured. The XDE Type 
Manager ships with XDE 2002.05.01 Service Release 1 and XDE 2003. See the XDE 
Compare/Merge Help for information about the XDE Type Manager Installer.

If you create a new VOB with ClearCase 2002 after running the XDE Type Manager 
Installer and before upgrading to ClearCase 2003, then re-run the XDE Type Manager 
Installer. After you install ClearCase v2003, when you create new VOBs, you do not 
need to perform additional steps; ClearCase v2003 automatically creates VOBs at 
Feature Level 4, and therefore those VOBs include the xde element type. 

Checking VOB Configuration

To check whether a VOB has been properly configured, run the following command 
from a command tool where the current directory is in the VOB you are checking:

cleartool lstype –kind eltype 
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If the output includes the element type xde, then the VOB has been configured to use 
XDE as the Type Manager for XDE model files. For example, in the output, you 
should see a line similar to the following:

06-Mar.11:25   vob_admin   element type "xde" 

Preparing to Upgrade SQL Anywhere

If SQL Anywhere is installed on your computer, then follow these steps now:

1 Stop the SQL Anywhere 5.0 service. From Sybase Central, open the Services folder. 
In the right pane, right click the service and from the shortcut menu, select stop. 

2 Back up all of your SQL Anywhere 5.0 databases. From Sybase Central, under 
Sybase SQL Anywhere, open the Utilities folder. Double-click Backup Database. 
Follow the wizard to back up your databases. When you are prompted for the 
connection parameters, enter dba for the database user ID and sql for the 
password. 

For more information, see the SQL Anywhere Help. From Sybase Central, click 
Help > SQL Anywhere Help. Click Using the SQL Anywhere Utilities > Backing up a 
database.

3 ProjectConsole only: Back up the SQL Anywhere 5.0 server software: copy the files 
in c:\program files\rational\SQLAny50\win32 to another folder. Record the name of the 
folder here:

______________________________________________________

4 Uninstall Sybase SQL Anywhere Database Server 5.0 on the database server host. If 
there is any other Rational software from an earlier version on the database server 
host, remove that also. 

Removing Rational Products From Your Computer

Before you upgrade to a new version of Rational software, remove all existing 
Rational software from your computer. Perform the tasks in Removing Rational 
Products on page 137. Then, from the Control Panel, run the Add or Remove Programs 
tool. Remove all installed Rational products. 

Optional: Installing Rational Download Manager

Rational Download Manager allows you to obtain this version of Rational products 
and service releases over the Web. Consider installing it now; alternatively, you can 
wait to install it until you want to install a service release for this version. For more 
information, see Applying Service Releases on page 135.
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Installing the Latest Version of Rational Suite

Use the Rational Software Setup program to install Rational Suite on all servers. This 
version includes a new setup program; we recommend that you familiarize yourself 
with the program before running it. For more information, see Installing Rational 
Products on page 113.

Perform the installations in the following order:

1 If you are working with ClearCase LT or ClearCase:

❑ For ClearCase LT, install software on the ClearCase LT server. When the 
installation finishes, the ClearCase LT Getting Started Wizard appears and 
displays a message saying that you have already run this wizard successfully. It 
is safe to quit the wizard.

❑ For ClearCase, upgrade on these systems in this order:

➑ License servers

➑ Registry servers

➑ VOB servers

➑ View servers

2 Upgrade software on all other servers, including Web servers. In this manual, you 
perform this step as part of Upgrading Web Servers on page 87.

3 Upgrade software on all desktop computers. In this manual, you perform this step 
as part of Upgrading Desktop Systems on page 145.

After the Installation: Reconfiguring Licenses

After you have installed a Rational product, if your computer does not have licensing 
configured, the License Key Administrator wizard appears. If you use a floating 
license, click Point to a Rational License server to get my licenses, and follow the 
instructions. Use the license server that you recorded in Saving License Server Name on 
page 46.
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Upgrading SQL Anywhere Server

This release of Rational products supports a new version of SQL Anywhere, version 
8.0. You need to upgrade SQL Anywhere if you use it as your database for Rational 
Test tools, ClearQuest, or ProjectConsole. 

To upgrade to the new version of SQL Anywhere:

1 Prepare to upgrade (ClearQuest only).

2 Upgrade the SQL Anywhere software on the database server host.

3 For some products, perform additional steps.

4 When clients upgrade, instruct them to connect to the new database.

ClearQuest Only: Before You Upgrade SQL Anywhere

If your site is running mixed versions of ClearQuest, (that is, some clients use v2003 
and some clients use earlier versions) and you use a SQL Anywhere database, 
continue to use SQL Anywhere 5.0 until your entire site has upgraded to ClearQuest 
v2003. At that point, upgrade your SQL Anywhere databases to version 8.0.

After you install the latest release of ClearQuest, you can still use existing databases 
created with SQL Anywhere 5.0. However, you cannot create new schema repositories 
or user databases using that version. Instead, use SQL Anywhere 8.0 to create new 
databases.

Upgrading the Database Server Host

In this section, you install the new software on the same database server host you 
have been using, and then update and move existing schema repositories and user 
databases to use version 8.0. 

Overview of Upgrade Steps

At a high level, you upgrade the SQL Anywhere database server host as follows:

1 ClearQuest only: upgrade one ClearQuest administrator host to ClearQuest v2003. 

2 ClearQuest only: prepare all databases for upgrade.

3 On the SQL Anywhere server, install SQL Anywhere 8 and configure the service.

4 ClearQuest only: from the administrator host, update the original databases to 
indicate the new server information.

5 ClearQuest only: From the administrator host, reformat the databases to SQL 
Anywhere 8.

6 Upgrade remaining clients, and reconnect to the new databases.
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ClearQuest Only

Perform this set of steps for ClearQuest only:

1 Upgrade one ClearQuest administrator host to ClearQuest v2003, making sure 
that you install ClearQuest Administration Tools. Select a ClearQuest 
administrator host that is different from the SQL Anywhere database server.

2 Create a profile to save your connection: in the ClearQuest Maintenance tool, click 
File > Export Profile and specify a file name.

3 From the administrator host, remove any installed Rational products that are from 
an earlier version. 

4 Install the latest release of ClearQuest on the ClearQuest administrator host. 

5 On the ClearQuest administrator host, start the ClearQuest Maintenance Tool. 
Connect to your current schema repositories and the user databases that were 
created with SQL Anywhere 5.0: click File > Import Profile and specify the file name 
you created in Step 2.

6 For each schema repository and user database you are upgrading, run the 
installutil utility with option preparedbforupgrade. On the ClearQuest 
administrator host, open a DOS command line window. Enter the following 
command:

installutil preparedbforupgrade SQL_ANYWHERE server database admin admin 
“SERVER_VER=5.0” 

where:

Warning:  If you do not run this command before stopping the SQL Anywhere 5.0 
service on the database server, you are prevented from successfully 
reconnecting to the schema repository and user databases later in this 
procedure.

server Database service name

database Full path to the schema repository or user database

admin Standard user name and password for SQL Anywhere database owners
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All Products: ClearQuest, Test, ProjectConsole

Perform this set of steps for all products that use SQL Anywhere:

1 On the database server host, ensure that you have performed the steps in Preparing 
to Upgrade SQL Anywhere on page 50.

2 On the same database server host, install the SQL Anywhere 8.0 server 
component. Start the Rational Setup Wizard. At the prompt to select a product, 

❑ If you plan to use ProjectConsole, then install any Suite edition; the SQL 
Anywhere 8 server is installed automatically. 

❑ For ClearQuest or Test, click Sybase SQL Anywhere Database Server 8.

3 ProjectConsole only: 

a Restore SQL Anywhere 5.0 server software: copy the files you backed up in 
Preparing to Upgrade SQL Anywhere on page 50 to 
c:\program files\rational\SQLAny50\win32. If you are prompted to overwrite 
existing files, click Yes.

b Start the SQL Anywhere 5.0 service: from the right pane of the services panel, 
right-click the service named SQL Anywhere – server_name, and click start, 
where server_name is the name of the server you used.

c For both the schema repository and the data warehouse, update the SQL 
Anywhere 5.0 databases so the SQL Anywhere 8 server can access them:

installutil preparedbforupgrade SQL_ANYWHERE server database 
admin admin “SERVER_VER=5.0” 

where:
server is the database service name
database is the full path to the schema repository or data warehouse
admin is the standard user name and password for SQL Anywhere database 
owners.

d Stop and disable the SQL Anywhere 5.0 service: from the right pane of the 
services panel, right-click the service named SQL Anywhere – server_name, and 
click Properties. On the Properties dialog box, change the Startup Type to 
Disabled and click stop to stop the service. 

4 Create and start the new SQL Anywhere 8.0 service. From Sybase Central, under 
Adaptive Server Anywhere 8, click Services. In the right pane, double-click Add 
Service to start the Create New Service wizard. Follow the wizard to create and 
start the new SQL Anywhere 8.0 service. On the Parameters page, enter the 
following operands:

–n servername 
–gd all 
–x protocol 
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where
protocol is one protocol or a comma-separated list of protocols. 

Possible values are: ALL, NamedPipes (or NP), NONE, SPX, TCPIP (or TCP) 
for example, –x tcpip 

For Test datastores, we recommend that you use the same servername that you 
used for the Version 5.0 database. Note here whether you used the same name or a 
different name: _______________________

For more detailed instructions about setting up SQL Anywhere for ClearQuest, see 
the Installation Guide for Rational Server Products.

To complete the process, you need to perform additional steps related to each product 
for which you use SQL Anywhere. See later sections of this chapter which discuss 
upgrading ClearQuest, Test tools, and ProjectConsole. 

After You Upgrade SQL Anywhere

ClearQuest Only: Migrating the Data

Perform these steps for ClearQuest only. To migrate the data, start on the ClearQuest 
administrator host that you have already upgraded to ClearQuest Version 2003. 

1 Update your schema repository:

a Update the schema repository properties. Start the ClearQuest Maintenance 
Tool. In the Existing Connections area, select the connection to SQL Anywhere 
5.0, then click Schema Repository > Update > Selected Connection. Enter the 
required properties, including the new 8.0 server name and SERVER_VER=8.0. 
Complete the other wizard steps.

b Move your schema repository. In the ClearQuest Maintenance Tool, in the 
Existing Connections area, select the connection to your existing SQL 
Anywhere 5.0 databases, then click Schema Repository > Move. Enter database 
information for a new database under your SQL Anywhere 8.0 server. For 
example, enter a different filename in the same directory as the existing 
database. Click Finish. 

c Create a new connection profile by exporting information containing the 
updated schema repository properties. Click File > Export Profile. In the Export 
Connection area, select the connection to SQL Anywhere 8.0. In the File Name 
box, enter the pathname and file name for the profile. Connection profiles must 
be saved with a .ini extension.

Write the path to the profile here for future reference:

______________________________________________
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2 Update your user databases:

a Update the user database properties. Start the ClearQuest Designer. Log in, and 
if you need to choose a connection, select the one you worked with in Step 1. If 
the Open Schema dialog box appears, click Cancel. Select Database > Update 
User Database Properties. In the Update User Database Properties dialog box, 
select the SQL Anywhere 5.0 user database, and click Properties. In the 
Database Properties dialog box, enter the new 8.0 database information, 
including the new SQL Anywhere 8.0 server name, and, in the Connect Options 
field, SERVER_VER=8.0. Click Update.

b Move your user database. In the ClearQuest Designer, select Database > Move 
User Database. In the Move User Database dialog box, select the database you 
just updated, then click Properties. In the Database Properties dialog box, enter 
database information for a new database under your SQL Anywhere 8.0 server. 
For example, enter a different filename in the same directory as the existing 
database. Click Move.

3 Repeat Step 1 and Step 2 for any other schema repositories and user databases you 
need to upgrade.

Upgrading ClearCase

This section describes how to upgrade ClearCase by performing the following tasks:

■ Raising the feature level of your VOBs
■ Reformatting some ClearCase views

Incrementing VOB Feature Level

With nearly every new release, ClearCase increments an internal feature level number. 
Each new feature level indicates support for a set of features introduced in the release. 
To take advantage of the new features, you need to change the feature level in each 
ClearCase VOB. 

Raising the feature level allows a VOB created in an earlier release to use features 
introduced in a later release. In a MultiSite environment, raising a feature level also 
advertises to the MultiSite family the functions that a VOB can perform. 

In Version 2003, the new feature level introduces support for new element types 
which facilitate working with Rational XDE. It also solves some line-length problems 
for certain element types.
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The following table describes the effect of raising or not raising the feature level:

Changing the Feature Level

To change the feature level, in a command window, use the cleartool chflevel 
command as follows:

cleartool chflevel –force –auto

Changing the Feature Level in a MultiSite Environment

In a MultiSite environment, change the feature level as follows:

1 Install the ClearCase release on all VOB replica hosts.

2 Raise the feature level of each replica.

3 Raise the feature level of the VOB family.

For more information about chflevel, see the ClearCase LT Reference or the ClearCase 
Reference. 

Reformatting ClearCase Views

If you are upgrading from the version before Version 5.0, read this section. 

If you are upgrading from Version 5.0, you have already performed the steps in this 
function and you can safely skip to the next section. 

ClearCase view data is stored in a view database. The previous release of ClearCase, 
Version 5.0, introduced a new view database format, requiring each view to be 
reformatted. You can choose to reformat in one of the following ways:

■ Automatically. ClearCase automatically reformats a view the first time it is used 
with the current release. 

■ Manually. You may choose to reformat some views manually using the cleartool 
reformatview command. We recommend that you manually reformat a view if it 
has a large database. By reformatting manually, you minimize the chance that 
clients will experience view access timeouts during automatic view reformats. 

Note:  After a view has been reformatted to the ClearCase 5.0 format, it cannot revert 
to the earlier format.

If you Then

Raise the feature level of all your VOBs to 4 You can take advantage of the new features.

Do not raise the feature level of any VOBs You cannot take advantage of the new features.
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Upgrading ClearQuest

This section describes how to upgrade ClearQuest schemas and databases created 
with an earlier version of ClearQuest. 

This section is written for ClearQuest administrators or people who are comfortable 
with administrative concepts related to ClearQuest. Before you start, we recommend 
that you have the Rational ClearQuest Administrator’s Guide available for reference.

Understanding the Upgrade Process for ClearQuest

To upgrade ClearQuest, you perform these general tasks:

1 Connect to ClearQuest, as described on page 60. 

2 Start the ClearQuest Designer and log on using Super User or Designer privileges. 

3 Perform tasks related to the databases you use to store ClearQuest data. 

4 Upgrade ClearQuest packages, test your databases, and check in the changes to 
the schema repository. See Upgrading ClearQuest Packages on page 60.

5 Apply schema changes to your user databases. See Applying Schema Changes to 
User Databases on page 61. 

Note:  We recommend you perform Step 4 and Step 5 during the same logon 
session.

6 Optionally, upgrade the ClearQuest feature level if you want to enable the latest 
set of ClearQuest features. See Upgrading the ClearQuest Feature Level on page 62.

Connecting to ClearQuest 

To re-establish a ClearQuest connection after an upgrade:

1 Start the ClearQuest Maintenance tool: click Start > Programs > Rational Software > 
Rational ClearQuest > Rational ClearQuest Maintenance Tool.

2 Perform one of the following steps:

❑ Click File > Import Profile and navigate to the profile you saved earlier.

❑ If you neglected to save a profile, click Connection > New and fill in the fields to 
re-establish a connection. For more information, refer to the ClearQuest 
Administrator’s Guide.
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Performing Database Tasks

Upgrading Database Versions or Changing Database Vendors

If you upgrade your database to a new version or you change to a different database 
vendor, you need to move your existing schema repositories and user databases to 
use the new database. This includes upgrading the version of SQL Anywhere. For 
each schema repository and user database:

1 Use the ClearQuest installutil utility with options convertschemarepo and 
convertuserdb. For more information, read about “Command Line Utilities” in the 
Rational ClearQuest Administrator’s Guide.

2 Create a new connection profile (.ini file): from the Maintenance Tool, click File > 
Export Profile and follow the prompts.

Using Oracle Databases

Upgrading Oracle

If you are running Oracle server 8.0.5, upgrade to Oracle 8.1.6 or 8.1.7. On a Windows 
host, upgrade the Oracle client software to 8.1.6 or 8.1.7. 

To use interMediaText support for multiline searches, set up the corresponding 
version of interMediaText (8.1.6 or 8.1.7) during the Oracle server installation:

1 Move the existing schema repositories and user databases to use the new Oracle 
version. Use the ClearQuest installutil utility with options convertschemarepo and 
convertuserdb. For more information, read about “Command Line Utilities” in the 
Rational ClearQuest Administrator’s Guide. 

2 To enable multiline search on the new Oracle databases, follow the instructions in 
“After Install: Configuring Databases and Administrative Tasks for ClearQuest” in 
the Installation Guide for Rational Products. 

Setting the Data Type

For Oracle databases, set the type of data you will be using. The valid data types are 
either LONG or CLOB. If your existing databases default to LONG, do not change 
them to CLOB. Databases already implemented with the LONG LOB_TYPE property 
are incompatible with CLOB. Note that there are limitations on using the CLOB data 
type. For more information on restrictions and guidelines, consult the Release Notes for 
Rational ClearQuest.
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Upgrading ClearQuest Packages

Each ClearQuest package implements a ClearQuest integration (for example, with 
Rational RequisitePro) or a feature (for example, e-mail rules). If you use ClearQuest 
in a Rational Suite environment, you probably use at least one of these packages. 
Carefully follow the instructions in this section to upgrade ClearQuest packages. 

To upgrade ClearQuest packages, perform these high-level steps, as detailed in the 
remainder of this section:

1 For each schema, apply package upgrades.

2 Test your changes, then check in the changes to the schema repository.

3 Apply schema changes to your user databases. See Applying Schema Changes to 
User Databases on page 61.

Note:  This chapter provides procedures for upgrading packages, but it does not 
provide information about the features that each package implements or about the 
dependencies among packages. For more detailed information about ClearQuest 
packages, see the Rational ClearQuest Administrator’s Guide.

Applying Package Upgrades

To upgrade ClearQuest packages:

1 Start the ClearQuest Designer if it is not already open: 

a Click Start > Programs > Rational Software > Rational ClearQuest > Rational 
ClearQuest Designer.

b Log on with Super User or Designer privileges.

A message may appear saying that the ClearQuest data code page value for the 
repository is not set.

c If the ClearQuest data code page message appears, place a checkmark next to 
this step to remind yourself later to take action. Click OK.

d If the Open Schema Wizard appears, click Cancel to dismiss it. (You can control 
whether the wizard appears by clearing or setting the Show this wizard at 
startup option.) 

2 From the Designer menu, click Package > Upgrade Installed Packages to display the 
Upgrade Installed Packages wizard.

3 On the Select a schema to upgrade page, the wizard lists the available schemas. Select 
the schema you want to upgrade.

The Upgrade Installed Packages wizard checks out the schema, analyzes which 
packages need upgrading, and determines whether those packages have any 
prerequisite packages.
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4 On the Status page, note the list of packages that need upgrading. Do the 
following:

❑ Select and copy this list into a text file. Write the name of the file here for later 
reference:
___________________________________________________

❑ If you are applying the Email package, place a checkmark next to this step to 
remember that you applied the package. When owners of desktop systems 
upgrade, they need to enable e-mail notification. We remind users to perform 
this task at the appropriate time.

The wizard applies packages to the schema in the correct order. 

5 When the wizard finishes, read the status message to verify that the package 
upgrade was successful. In the open schema, inspect the changes. Complete the 
work for this schema before upgrading other schemas.

6 Validate the changes you’ve made: from the Designer menu, click File > Validate. 

[Optional] Test the changes on a test database: click File > Test Work.

7 Check in the schema: from the Designer menu, click File > Check In. 

8 Repeat this procedure from Step 3 for additional schemas that need upgrading.

Applying Schema Changes to User Databases

This section describes how to apply schema changes to your user databases. Perform 
these steps now. In general, you should always perform the steps in this section after 
making changes in the ClearQuest Designer, such as applying packages. The effect of 
performing these steps is to push changes in your schema to the user databases.

Applying schema changes takes just a few minutes for each user database. To apply 
schema changes:

1 Start the ClearQuest Designer: click Start > Programs > Rational Software > Rational 
ClearQuest > Rational ClearQuest Designer. Log on with Super User or Designer 
privileges.

2 If the Open Schema Wizard appears, click Cancel. 

3 From the Designer menu, select Database > Upgrade Database.
A message warns you that this action cannot be reversed, recommends that you 
back up your databases before proceeding, and asks you if you want to continue. If 
you have backed up your databases, click Yes.

4 Select the user database from the list in the Upgrade Database Wizard. Click Next.
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5 On the next page, from the list, select the version of the schema (typically the 
latest) to which you wish to upgrade the user database.

If your most recent version does not appear in this list, it probably is not checked 
in. In that case, click Cancel to quit this wizard. On the Designer menu, click File > 
Open Schema, then check in the schema. You can now restart this process.

6 Click Finish. When the upgrade completes, a message appears saying that the 
database has been upgraded successfully.

7 Update your maintenance plans to include new user databases and schema 
repositories, and to omit the old ones.

You have now applied schema changes to your ClearQuest user database.

Changing the ClearQuest Data Code Page 

When you applied package upgrades, you may have seen a warning about the 
ClearQuest data code page (see Step c on page 60). The ClearQuest data code page 
refers to the legal character set that you can use to enter data into a ClearQuest 
database. By default, when no value is set, you are restricted to using ASCII characters 
only. 

To allow users to enter non-ASCII data into ClearQuest databases, read about 
ClearQuest data code pages in the ClearQuest Administrator’s Guide. 

Upgrading the ClearQuest Feature Level

This section describes how to upgrade the ClearQuest feature level. These steps are 
optional, as follows: 

■ Perform these steps if you want to enable the latest features in ClearQuest. In Version 
2003, these new features are Rational ClearQuest MultiSite (introduced in 
2001A.04.20) and an improved security model (introduced in Version 2001A).

■ Do not perform these steps if you do not want to enable these new features. Also, if 
you have already upgraded to the ClearQuest feature level introduced in Version 
2001A, do not perform the steps again.

Upgrading the ClearQuest feature level can take several hours. The upgrade changes 
the schema repository and all its associated user databases. Typically, new tables are 
added to all databases, and new columns may be added to existing tables.

If ClearQuest is installed in an environment with other Rational software, you must 
upgrade the feature level for all databases at the same time; you cannot upgrade them 
incrementally.
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Scheduling the Feature Level Upgrade

You can perform a feature level upgrade at any time, not just while you’re upgrading 
a version of Rational Suite. You may want to perform the work now. Alternately, you 
may want to finish the other tasks in the Suite upgrade now and allow users to 
resume their work, then upgrade the ClearQuest feature level later. While both 
options are possible, this chapter assumes you are upgrading the feature level now. 

Determining the Current Feature Level

To determine the current feature level of your databases, check the value for the 
feature level in the following tables:

■ For a schema repository, open the master_global table and refer to the feature level 
field.

■ For a user database, open the db_global table and refer to the feature level field.

For a description of the supported feature levels in this release, type the following at a 
command prompt: 

C:\Program Files\Rational\ClearQuest> packageutil showfeaturelevels 

Working With ClearQuest MultiSite

For information about upgrading the ClearQuest feature level in a ClearQuest 
MultiSite environment, see the Rational ClearQuest MultiSite Administrator’s Guide.

Overview of Upgrading the ClearQuest Feature Level

As part of upgrading the ClearQuest feature level, we strongly recommend that you 
perform the upgrade first on a test system, and then perform it again on production 
databases. At a high level, the process is as follows:

1 Verify your environment.

2 Create a test bed based on production databases.

3 Upgrade the test bed and validate that the upgrade was successful.

4 Create new databases for the production system.

5 Upgrade the production databases and validate that the upgrade was successful.
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Verifying Your Environment

Before you start the upgrade, be aware that the upgrade can fail under certain 
conditions. Table 5 describes these conditions and how to resolve them. 

Creating a Test Bed

A test bed is a safe, non-production area where you can test your changes. We 
recommend that you perform the upgrade on the test bed first before you upgrade 
your production databases. The following steps describe how to create a test bed 
based on your production databases:

1 Make sure you have a backup copy of your ClearQuest schema repository and 
user databases, as described in Back Up Databases and Datastores on page 21. 

Upgrading the ClearQuest feature level changes the underlying structure of your 
data and schemas. We strongly recommend you create a backup, if you haven’t 
done so already, so you can revert to it if necessary. 

2 Create new, empty vendor databases for each schema repository and user 
database, as described in “Configuring Vendor Databases” in the Installation Guide 
for Rational Server Products. Create the new databases in a new test directory or 
on a test server. In this section, we refer to these new databases as the test bed. 

Do not perform this step if you are using Microsoft Access or SQL Anywhere.

Note:  Create empty databases only. Do not use the vendor database tools to move 
or copy the data. ClearQuest updates the data structure and moves it into the new 
databases as part of the upgrade process.

Table 5 Troubleshooting: Upgrading the ClearQuest Feature Level

Condition Solution

You currently have a ClearQuest schema 
checked out.

Check in your ClearQuest schema.

Your ClearQuest database is locked. Unlock your database. For more information, 
read about the installutil unlockschemarepo 
and installutil unlockuserdb commands in 
the Rational ClearQuest Administrator’s Guide.

You have customized your schema to include 
Record Types or fields that have a ratl_  prefix. 

Contact Rational Customer Support. They 
will explain how to correct this condition.
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3 Shut down your web server, stop any scheduled ClearQuest MultiSite 
synchronization jobs, and ensure that all users have disconnected from ClearQuest 
by using one of these techniques:

❑ Some high-end databases give the administrator a tool for logging users off 
from the database. Check your vendor database to see if it has such a tool.

❑ Check the Task Manager Process List of each client and server computer. If one 
of these processes is running, use the Task Manager to end the process: 

clearquest.exe, cqdesign.exe, or any cqintsvr*.exe process

4 Copy your existing production schema repository and user databases to the test 
bed databases. Use the ClearQuest installutil utility with the options, 
convertschemarepo and convertuserdb. For more information, read about 
“Command Line Utilities” in the Rational ClearQuest Administrator’s Guide.

Using the convert options with installutil causes ClearQuest to lock the original 
production databases. If you need to unlock them, read about the installutil 
unlockschemarepo and installutil unlockuserdb commands in the Rational ClearQuest 
Administrator’s Guide.

5 For each database in the test bed, create another new empty vendor database. 
These will be the databases that you upgrade to. In this section, we refer to these 
new databases as the test upgrade set. 

Upgrading the Test Bed 

In this section, you upgrade the test bed and verify that the upgrade was successful. 
Upgrade the test bed as follows:

1 Start the ClearQuest Maintenance Tool: click Start > Programs > Rational Software > 
Rational ClearQuest > Rational ClearQuest Maintenance Tool. 

2 From the Existing Connections list, select the connection to the schema repository 
that you want to upgrade. 

3 From the ClearQuest Maintenance Tool menu, select Schema Repository > Upgrade 
> Selected Connection.

4 At the prompt to upgrade user databases, click Yes to continue.

5 Log in with Super User privileges.

6 Enter the properties of the schema repository to upgrade to (the empty database 
you created in the test upgrade set), then click Next.
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7 Enter the properties for the first user database you are upgrading to (the empty 
databases you created in the test upgrade set). Click Next. Repeat until you have 
associated all the user databases. Click Finish.

ClearQuest upgrades your schema repository and user databases, and notifies you 
when the process is complete. It records all actions in a text file in the \Temp 
directory.

8 Verify that the upgrade process completed successfully:

a When the upgrade process completes, carefully read the status message to 
ensure that the process completed successfully (scroll until you reach the end of 
the message). Click Done. 

b Test the application. Enter a few test records of each record type and move 
them though the entire state model to be sure the upgrade is working correctly.

Creating Production Databases

After you verify that the test upgrade is successful, proceed to upgrade your 
production databases. The steps for upgrading production databases are nearly 
identical to those for upgrading the test databases.

The following steps describe how to upgrade production databases:

1 Create empty vendor databases for each schema repository and user database, as 
described in “Configuring Vendor Databases” in the Rational ClearQuest 
Administrator’s Guide. Create the new databases on the production server. In this 
section, we refer to these new databases as the production upgrade set. 

Do not perform this step if you are using Microsoft Access or SQL Anywhere.

Note:  Create empty databases only. Do not use your vendor database tools to 
move or copy the data. ClearQuest updates the data structure and moves it into 
the new databases as part of the upgrade process.

2 Notify users to log off from ClearQuest, if any are logged in, shut down your web 
server, and stop any ClearQuest MultiSite synchronization jobs. 

Upgrading the Production Databases

In this section, you upgrade from your original production databases to the 
production upgrade set. The process is similar to the process for upgrading the test 
bed: 

1 Start the ClearQuest Maintenance Tool: click Start > Programs > Rational Software > 
Rational ClearQuest > Rational ClearQuest Maintenance Tool. 

2 From the Existing Connections list, select the connection to the schema repository 
that you want to upgrade. 
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3 From the ClearQuest Maintenance Tool menu, select Schema Repository > Upgrade 
> Selected Connection.

4 At the prompt to upgrade user databases, click Yes to continue.

5 Log in with Super User privileges.

6 Enter the properties of the schema repository to upgrade to (the empty database 
you created in the production upgrade set), then click Next.

7 Enter the properties for the first user database you are upgrading to (the empty 
databases you created in the production upgrade set). Click Next. Repeat until you 
have associated all the user databases. Click Finish.

ClearQuest upgrades your schema repository and user databases, and notifies you 
when the process is complete. It records all actions in a text file in the \Temp 
directory.

8 Verify that the upgrade process completed successfully:

a When the upgrade process completes, carefully read the status message to 
ensure that the process completed successfully (scroll until you reach the end of 
the message). Click Done. 

b Test the application. Enter a few test records of each record type and move 
them though the entire state model to be sure the upgrade is working correctly.

9 After verifying that the upgrade completed successfully:

a To prevent users from accidentally using the original production databases, 
either keep them locked or remove them. 

b Optionally, discard the test bed and test upgrade set.

Upgrading a Rational Project

This section describes how to upgrade datastores in a Rational project. It describes the 
actions to take if:

■ You need to update Rational Test or Rational RequisitePro datastores so you can 
use them with the new version of Rational Suite. Datastores created with an earlier 
version of Rational software are not compatible with the current version, 2003. 
Therefore, before you can use these datastores, you need to convert them as 
described in this section.

■ You want to verify that ClearQuest packages are correctly configured for a 
Rational project.
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Upgrading the RequisitePro Database and Rational Test Datastores

Use the Rational Administrator to upgrade both RequisitePro databases and Rational 
Test datastores as follows:

1 Start the Rational Administrator: click Start > Programs > Rational Software > 
Rational Administrator.

2 Re-register the Rational project: click File > Register Project and browse to the 
project’s location. You saved this location before you installed new software; see 
Remembering Location of Rational Projects on page 47.

3 Reconnect to the project: click File > Connect and browse to the project.

4 If you use SQL Anywhere as your test datastore, perform these steps if you used a 
different server name when you upgraded (see Step 4 on page 54):

Do not perform the steps if you used the same server name.

a Right-click the Rational Test Datastore and select Properties.

b Click Advanced Database Setup.

c Enter the name of the SQL Anywhere 8 database server and the Host Name. 
Click OK. 

d Quit the Properties dialog box.

5 From the Administrator menu, select File > Upgrade Project Assets.

The Administrator displays a list of registered projects.

6 Select a project to upgrade and click OK. 

You may see a warning that says that you need to establish a ClearQuest 
connection. You have already performed this step in Connecting to ClearQuest on 
page 58.

The upgrade process starts. It first upgrades the RequisitePro database, if one is 
associated with the Rational project, then it upgrades the Rational Test datastore, if 
one is associated with the Rational project. If your Rational project is connected to a 
ClearQuest database, you may be prompted to log in. If so, log in using Super User 
privileges.
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Upgrading the RequisitePro Database

The Rational Administrator displays the RequisitePro Database Upgrade wizard.

Note:  If your RequisitePro project is not part of a Rational Administrator project, you 
can start the RequisitePro Database Upgrade wizard by using a newer RequisitePro 
client to open a RequisitePro project that was created with an older version.

While you work with the wizard, keep these points in mind:

■ The Database Upgrade wizard guides RequisitePro project administrators through 
the process of upgrading existing database structure and project data to the 
current RequisitePro release. 

■ If security is enabled for the project, enter your Rational RequisitePro User ID and 
Password at the prompt. If there are multiple projects in an enterprise database, 
type the User ID and Password used to create the enterprise database.

■ After you upgrade the project database, users cannot open the associated projects 
until they upgrade to the current version of RequisitePro.

■ If the project you are upgrading contains cross-project traceability links, you must 
upgrade the external projects as well. If the external projects have security enabled, 
you are prompted to log on to those projects while the Database Upgrade Wizard 
is running. You can always check for references to external projects in any 
RequisitePro project by clicking Project > External Projects.

■ If an error occurs during the upgrade, the wizard displays an explanation of the 
problem. Problems commonly occur when the wizard cannot get exclusive access 
to the project or when the wizard cannot connect to external projects. After 
addressing a problem, rerun the wizard to complete the upgrade. 

After the Upgrade: Understanding RequisitePro Packages

Starting in RequisitePro version 2002, requirement artifacts are organized in packages. 
Packages are containers, similar to file folders, in which you can group artifacts or 
elements of different types. Packages in RequisitePro can contain documents, 
requirements, views, and other packages, according to your organizational needs.

Earlier versions of RequisitePro do not use packages. When you upgrade a project 
created in an earlier version, the upgrade process automatically organizes your 
requirements artifacts into packages. RequisitePro uses the following default scheme 
to organize packages: 
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■ Requirements Document. A package is created for each requirements document, 
including all requirements that are located within that document.

■ Requirement Type. A package is created for each requirement type, including 
requirements of that type not located in documents. 

A Requirement Type package is not created when there are no requirements 
associated with the given type, or if all requirements of that type are already 
located in Requirements Document packages.

■ View Type. A package is created for each view type: Attribute Matrix, Traceability 
Matrix, Traceability Tree. Each view package contains all views of that type in the 
project.

Later you can create your own packages, and reorganize your requirement artifacts 
accordingly. 

Upgrading the Rational Test Datastore

During the upgrade, the Rational Administrator displays a progress indicator. When 
it has finished, you can optionally click the View Log button to display a log of the 
upgrade. 

Note that after you perform this conversion, you cannot revert to an earlier version of 
the test datastore, nor can you use the upgraded test datastore with earlier versions of 
Rational Test tools.

Running Datastore Doctor

Run Datastore Doctor: click Tools > Rational Test > Rational Datastore Doctor and 
follow the prompts. The Datastore Doctor:

■ Verifies the consistency of a datastore and records and reports any inconsistencies. 

■ Attempts to repair inconsistencies in the datastore and the cache database 
contained within the datastore. 

Converting from Microsoft Access to a Sybase SQL Anywhere Database

Before Version 2002, Microsoft Access was the default database engine for test 
datastores. Starting with Version 2002, we strongly recommend that you convert to 
using Sybase SQL Anywhere if two or more users plan to use the test datastore 
simultaneously.

A special, Rational version of Microsoft Access is automatically installed when you 
install Rational software. The Sybase SQL Anywhere database server ships with 
Rational software but is not installed automatically.
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For more information, refer to the Installation Guide for Rational Server Products to 
read about:

■ Installing and configuring a SQL Anywhere database server.
■ Creating a SQL Anywhere test datastore.
■ Converting a test datastore from Microsoft Access to SQL Anywhere.

After Upgrading a Rational Project

Perform these steps after upgrading the Rational project:

If You Use Rational ClearCase or Rational ClearCase LT

If you use Rational ClearCase or Rational ClearCase LT to store Rational data:

■ If you’re using a snapshot view, update the view now.

■ If your team works with a UCM-enabled project:

a Use the Rational Administrator to perform a Check in All operation for the 
RequisitePro project and the Test datastore. (In the Administrator, on the 
Configure dialog box for your project, click Check in All for both datastores. 
ClearCase checks in all project-related assets, then checks them out again.) 
Until you perform this step, you will be unable to open the RequisitePro 
project.

b Create a baseline for your project (in the ClearCase Project Explorer, select the 
project, then click Tools > Make Baseline).

■ If your team uses another method to integrate Rational Suite and ClearCase:

a Use ClearCase to check in the project’s assets.

b Use ClearCase to create a label on the checked-in versions. Name the label so 
you will remember that these versions represent the upgrade.

Verifying ClearQuest Packages for a Rational Project

If you are working with a Rational project, you can verify that the ClearQuest 
packages for your Rational project are correctly configured and upgraded:

1 In the left pane of the Rational Administrator, select a project, right-click it, and 
select Connect.

2 Select the same project, right-click it, and select Configure to display the Configure 
Project dialog box.

3 Click Close to initiate the program that checks your project.

If the correct packages are applied, you do not see a message. However, if there are 
packages to apply or upgrade, a message appears directing you to this chapter. 
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Rebuilding the UCM Integration When You Use ClearQuest

If you use UCM with ClearQuest, the system rebuilds the integration the first time 
you use ClearCase and prompts you to login to ClearQuest. Refer to Saving 
information about UCM on page 47 to retrieve the information you’ll need. 

Log in with the user name of the person who originally set up the integration between 
ClearCase and ClearQuest. On the ClearQuest tab, select the database you have been 
using in the integration.

Upgrading from RobotJ to XDE Tester

In Version 2002, Rational introduced Rational RobotJ, which shipped as part of these 
products: Rational Suite Enterprise, Rational Suite TestStudio, and Rational TeamTest. 
In Version 2003, XDE Tester replaces RobotJ. XDE Tester is a standalone product; XDE 
Tester is not included as part of any other product. 

Read this section if you installed RobotJ as part of a version 2002 installation and you 
now want to work with XDE Tester Version 2003. Do not use this section to learn 
about installing XDE Tester for the first time; instead, refer to the Installation Guide for 
Rational XDE Tester.

Enabling Integrations

XDE Tester allows you to continue to use the original integrations with Rational 
TestManager, when you have both XDE Tester and TestManager installed. If you 
install Enterprise Studio, TestStudio, or TeamTest version 2003, TestManager will be 
installed for you and you can use the integrated features of XDE Tester and 
TestManager. 

To use the Rational Test Agents, perform a separate install. You must install the 2003 
version of TestManager, XDE Tester, and the Test Agents (if you use them) for the 
products to operate together.

Converting a Rational Test Datastore

In an earlier version, you might have created a Rational RobotJ datastore and 
associated it with a Rational Test datastore. If so, you have already performed the 
work to convert the RobotJ datastore so that it is compatible with XDE Tester. This 
work was performed as part of Upgrading a Rational Project on page 67. 
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Reusing RobotJ Assets

The test assets that you created with RobotJ also work with XDE Tester. These test 
assets are: RobotJ datastores, scripts, object maps, and verification points. From XDE 
Tester, you can connect to RobotJ datastores.

Re-enabling Java Environments and Web Browsers

If you used RobotJ and are now using XDE Tester, you must re-enable Java 
environments and Web browsers in XDE Tester because of upgrades in the enabling 
process.

Re-enabling Java Environments

To re-enable Java environments:

1 Disable any currently enabled environments: 

a In XDE Tester, click Configure > Enable Environments for Testing. 

b On the Enable Environments dialog box (the enabler), click the Java 
Environments tab.

c Click Select All to select all current Java environments.

d Click Disable to disable all current Java environments.

2 Click Search. On the Search for Java Environments dialog box, select one of the 
following search mechanisms, and then click Search:

❑ Use Quick Search on Windows systems only to search the registry for the Java 
environments. Quick Search is quicker than searching your hard drive(s).

❑ Use Search All Drives to scan your hard drives or partitions to locate all the Java 
environments on your system.

❑ Use Search In to browse to a specific drive or root directory to search.

A list of all JREs appears in the Java Environments list. Decide which 
environments to enable. 

3 Select the environment or environments you want to enable for Java testing, and 
then click Enable.

The enabled environments are indicated in parentheses after each JRE name in the 
list.

If a JRE is not enabled, the Record Monitor is blank when you try to record against 
a Java application. For this reason, we recommend that you leave the Record 
Monitor visible while you record. If you notice this symptom, run the enabler.
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4 To change the default JRE, select a JRE and click Set as Default.

The first time XDE Tester runs, it automatically enables the JVM of your browser's 
Java plug-in so that HTML recording works properly. If you install a different JVM, 
rerun the enabler.

Re-enabling Web Browsers

To re-enable Web browsers, follow a process similar to the one for re-enabling Java 
environments:

1 Disable any currently enabled browsers: 

a In XDE Tester, click Configure > Enable Environments for Testing. 

b On the Enable Environments dialog box (the enabler), click the Web Browsers 
tab.

c Click Select All to select all current browsers.

d Click Disable to disable all current browsers.

2 Click Search. On the Search for Web Browsers dialog box, select one of the 
following search mechanisms, and then click Search:

❑ Use Search All Drives to scan your hard drives or partitions to locate all the 
browsers on your system.

❑ Use Search In to browse to a specific drive or root directory to search.

A list of all browsers appears in the Web Browsers list. Decide which browsers to 
enable. 

3 If you don’t see a specific browser in the Web Browsers list, click Add to display the 
Add Browser dialog box. Locate the browser, select it, and click Add. The browser 
appears on the Web Browsers list in the enabler.

4 Select the browser or browsers you want to enable for HTML testing, and then 
click Enable.

The enabled browsers are indicated in parentheses after each browser name in the 
list.

If a browser is not enabled, the Record Monitor is blank when you try to record 
against an HTML application. For this reason, we recommend that you leave the 
Record Monitor visible while you record. If you notice this symptom, run the 
enabler.

5 To change the default browser, select a browser and click Set as Default.

The first time XDE Tester runs, it automatically enables the JVM of your browser's 
Java plug-in so that HTML recording works properly. If you install a different JVM, 
rerun the enabler.
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Integrations with XDE Tester

When you associate an XDE Tester datastore with a Rational project, you can use 
TestManager to run your XDE Tester scripts and to coordinate testing activities from a 
single computer running Windows. This is called the Local computer. To run XDE 
Tester scripts remotely on other computers, install Test Agent software (delivered on a 
separate CD-ROM), enable environments, and configure applications on the remote 
system, called an Agent computer. 

Upgrading ProjectConsole

ProjectConsole was introduced in Version 2002. If you are upgrading from that 
version, follow the instructions in this section. If you need to install ProjectConsole for 
the first time, follow the instructions in the Installation Guide for Rational Server 
Products.

Upgrading ProjectConsole Server Software

To migrate data for use with ProjectConsole 2003, perform the following high-level 
tasks:

1 Install ProjectConsole, including all its components, and the ProjectConsole Web 
server component as part of a Rational Suite installation. During this installation, 
SQL Anywhere 8.0, the report server, and collection agents are installed 
automatically. 

For more information, see the Installation Guide for Rational Server Products. 

2 Restore from backup the files you saved before the upgrade.

3 Migrate data from an existing data warehouse that you created with Version 2002.

4 Check for, and fix, any errors that occur during the data migration.

5 Perform final steps.

The remainder of this section describes restoring saved files from backup, configuring 
the ProjectConsole servers, and migrating existing data. 
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Restoring Saved Files from Backup

In Performing ProjectConsole Tasks on page 48, you saved ProjectConsole files that you 
had added or changed. Restore these files as follows:

■ Restore the files you backed up from this directory to the same directory:
c:\program files\rational\jakarta-tomcat\webapps\projectconsole 

■ Restore all templates to c:\program files\rational\ProjectConsole\templates

■ If you backed up transformation scripts, configuration files (.ini) or batch files, 
restore them to c:\program files\rational\bin.

Migrating Project Data from an Earlier Version of Rational 
ProjectConsole

If you plan to use data collected in an earlier version of Rational ProjectConsole with 
the current version of ProjectConsole, you must first use the ProjectConsole 
Maintenance Tool to migrate the existing data.

Some terms used to describe data storage in ProjectConsole have changed since the 
previous release. These changes are listed in the following table.

Old term New term Usage

server software Web server 
components

The Web server components installed on the 
ProjectConsole server machine.

agent software report server and 
collection agents

The agent software installed on the 
ProjectConsole server machine and any separate 
agent machines.

metrics warehouse none The data warehouse in which ProjectConsole 
stored the artifacts and data collected from 
various Rational point products and third-party 
tools. A metrics warehouse consisted of the 
schema repository (master) database and the 
warehouse database. 

warehouse database data warehouse The database in which ProjectConsole stores 
data collected from software development tools 
as well as view descriptions. The data 
warehouse is managed using the ProjectConsole 
Maintenance Tool.
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To migrate data used in an earlier version of ProjectConsole:

1 Click Start > Programs > Rational Software > Rational ProjectConsole > Rational 
ProjectConsole Maintenance Tool.

2 On the first page of the Maintenance Tool, click Migrate data from a previous 
version of ProjectConsole, and then click Next.

3 On the next page, in the Database type list, select the database vendor for the 
schema repository and warehouse databases that contain the data you want to 
migrate. The fields change depending on the database type you choose.

4 Specify the following required database information, based on the database type 
you chose:

For MS_ACCESS databases:

a In the Schema repository box, enter the directory of the existing schema 
repository database.

b In the Data warehouse box, enter the directory of the existing warehouse 
database.

security database An SQL Anywhere 8.0 database that contains 
information about the ProjectConsole 
navigation tree structure and authentication 
information for all users and groups. A security 
database is associated with a data warehouse 
and a schema repository. Together, these 
databases comprise a ProjectConsole repository.

ProjectConsole 
repository

The combined data warehouse/schema 
repository/security database group used to 
store collected data, navigation tree structure 
information, and user (and group) 
authentication information in ProjectConsole.

Old term New term Usage
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For DB2 databases:

a In the Schema repository box, type the database alias of the existing DB2 
schema repository.

b In the Data warehouse box, type the database alias of the existing DB2 
warehouse.

c In the Username box, type the username required to log in to your DB2 
databases.

d In the Password box, type the password required to log in to your DB2 
databases.

For ORACLE databases:

a In the Schema repository area:

➑ In the Name box, type the SQLNet alias to connect to your Oracle server.

➑ In the Username box, type the username required to log in to your Oracle 
schema repository.

➑ In the Password box, type the password required to log in to your Oracle 
schema repository.

b In the Data warehouse area:

➑ In the Name box, type the SQLNet alias to connect to your Oracle server.

➑ In the Username box, type the username required to log in to your Oracle 
warehouse.

➑ In the Password box, type the password required to log in to your Oracle 
warehouse.

c In the Connect options box, type the Oracle versions installed on the database 
server and on the client machine using the following format:

CLIENT_VER=8.X;SERVER_VER=8.X

For example:

CLIENT_VER=8.1;SERVER_VER=8.1

If the database server is a machine other than the ProjectConsole server, then 
the ProjectConsole server is the client.

Note:  ProjectConsole supports Oracle versions 8.0 and 8.1.
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For SQL_ANYWHERE databases:

a Ensure that you have performed the pre-requisite tasks of upgrading SQL 
Anywhere 5.0 databases to SQL Anywhere 8.0 (described in Upgrading SQL 
Anywhere Server on page 52).

b In the Schema repository box, enter the path of the existing SQL Anywhere 5.0 
schema repository database.

c In the Data warehouse box, enter the path of the existing SQL Anywhere 5.0 
warehouse database.

d In the Database server box, type the name of the SQL Anywhere 8.0 database 
server.

e Next to Protocol(s), select the check boxes for the protocols used to 
communicate with the SQL Anywhere server.

f In the Hostname(s) (n1, n2,…) box, type the host name or names of the database 
server or servers.

g In the Connect options box, specify the version of SQL Anywhere installed on 
your database server machine using the following format:

SERVER_VER=8.0

For SQL_SERVER databases:

a In the Schema repository box, type the name of the SQL Server schema 
repository database.

b In the Data warehouse box, type the name of the SQL Server warehouse 
database.

c In the Database server box, type the name of the server machine that hosts your 
SQL Server databases.

d In the Username box, type the username required to log in to the SQL Server 
schema repository.

e In the Password box, type the password required to log in to the SQL Server 
schema repository. 

5 After you specify all of the required information for the database type, click Next.

6 On the next page, perform the following steps:

a In the New repository name box, type a name for the new ProjectConsole 
repository for your migrated data.

b In the Old install location box, if the installation path for the previously installed 
version of Rational ProjectConsole was different than the default path, then 
enter the correct path.
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c In the New install location box, if the installation path for the currently installed 
version of Rational ProjectConsole is different than the default path, then enter 
the correct path.

d Click Finish.

After Migrating Data

Checking for Errors

After the migration completes, read the migration log to make sure there are no errors 
or exceptions. The log is displayed on the status page of the Maintenance Tool. It is 
also saved, by default, in: 

C:\Program Files\Rational\ProjectConsole\bin\PjsSetup.log 

If you notice an error or exception, address the problem before proceeding.

Changing the Rational Services Logon Information

You need to change the Rational Services Logon information if your site will use UNC 
paths for access to tree node properties, source templates, or tasks on remote 
machines. By default, the services run as the Local System user. Configure them to run 
as a domain user with access to the appropriate remote machine. To perform the 
configuration: start on the Services panel. 

If you are either collecting metric data, or generating artifact reports from Rose 
models, configure the Rational ProjectConsole Collection Server and Rational 
ProjectConsole Report server services as follows:

■ Log on using the Local System account.

■ Select the interact with desktop checkbox.

■ We recommend using a remote agent machine for all Rose data collections and 
artifact report generation.

For each of the following services, you may need to change the logon information.

■ Rational ProjectConsole Collection Server

Follow this step if you plan to perform metric data collections that access data 
repositories (Rose, Test Manager, MS Project, text, and so on) that are stored on a 
remote machine and the collection agent accesses those repositories using a 
mapped network drive or a UNC path name. 

❑ Configure this service to log on using a named account that has access to the 
remote resources.
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■ Rational ProjectConsole Dashboard Server

Follow this step if you use either Microsoft Access or SQL Anywhere for your data 
warehouse, and the databases (.mdb or .db files) are accessed using a mapped 
network drive or a UNC path name.

❑ Configure this service to log on using a named account that has access to the 
remote resources.

■ Rational ProjectConsole Report Server

Follow this step if you plan to configure report nodes in the ProjectConsole tree 
that access data repositories (Rose, Test Manager, MS Project, text, and so on) that 
are stored on a remote machine, and the report server accesses those repositories 
using a mapped network drive or a UNC path name.

❑ Configure this service to log on using a named account that has access to the 
remote resources.

■ Rational Web Platform, servlet engine

Follow this step if you plan to configure report nodes in the ProjectConsole tree 
that use the File System template to display a list of files that are stored on a 
remote machine, and the report nodes are accessed using a mapped network drive 
or a UNC path name.

❑ Configure this service to log on using a named account that has access to the 
remote resources.

Re-Connect to the Database

If you run collections from ClearQuest databases, re-establish the connection to these 
databases by performing one of the following tasks:

■ If you have saved ClearQuest connection information to a profile, in the 
ClearQuest Maintenance Tool, click File > Import Profile and enter the name of the 
profile.

■ If you do not have a profile, run the ClearQuest Maintenance Tool and select 
Connection > New. Provide the connection information. 

ProjectConsole Automatically Sets the Data Code Page

If you are a ClearQuest user, you may be aware of the ClearQuest data code page 
topic in that product. ProjectConsole also uses data code pages. ProjectConsole, 
however, automatically sets the data code page for the schema repository and data 
warehouse when you create or migrate a schema repository or data warehouse. 
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Performing Final Steps 

Perform the following tasks:

1 Check all the tree nodes on the main page and fix any that are broken.

❑ In v2002, if the icon for a tree node did not exist, ProjectConsole displayed a 
default icon. In v2003, ProjectConsole displays a red X. If you notice a red X, 
edit the tree node and use the New Icon Browse dialog box to select a new icon. 

❑ If you configured any tree nodes to display URLs that referenced virtual IIS 
directories, these URLs may be invalid unless you have configured RWP and 
IIS to work together. See Allowing IIS and RWP to Co-Exist on a Single Server on 
page 100 for more information. 

❑ If you configured any tree nodes to display html pages you created and stored 
in v2002 Jakarta-tomcat\webapps\projectconsole, you may need to manually copy 
these html pages to common\rwp\webapps\projectconsole. 

❑ If you used relative references to the html files in your tree nodes (that is, the 
URL contained only the name of the html file), copy the html file to 
common\rwp\webapps\projectconsole\pjc.

❑ The start.htm file and any associated image files are now located in 
rational\ProjectConsole\DataRepository\your-data-repository. If this page did not 
migrate during the upgrade, copy the page and the associated image files from 
jakarta-tomcat\webapps\projectconsole to the new data repository folder. Then use 
the ProjectConsole Maintenance Tool to re-connect to your repository.

❑ If any tree nodes under ProjectConsole Help or ProjectConsole Resources are 
no longer applicable, delete them.

2 If you use any templates that use an absolute path value to reference the 
jakarta-tomcat\webapps directory (using the FileSystem domain), then modify these 
paths to reference the location under the \common\rwp\webapps directory.

3 Modify any templates that use the FileSystem domain OPEN command to 
reference .gif files. ProjectConsole no longer supports .gif files inserted with the file 
system adapter; convert them to .png or .jpg format and modify the OPEN 
command to refer to the new file format.
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4 Update username and password fields for RequisitePro, ClearQuest, and Test 
Manager tree nodes. 

❑ In v2002, ProjectConsole prompted users to log in when an artifact report 
required authentication, and the logged in user was not a valid user in the 
specified product. 

In v2003, users are no longer prompted. If login information is specified in the 
configuration for a tree node, then the artifact report is generated using the 
specified username and password. If login information is not specified for a 
tree node, then the artifact report is generated using the username and 
password of user who is currently logged in.

❑ Only nodes that specify login information are included in scheduled, offline 
updates of the generated reports in the Web site. This includes report nodes for 
products that do not require a login. 

5 Check all the published views. The ProjectConsole Version 2003 has new sample 
published views. 

To remove the sample views, delete the files in
c:\program files\rational\common\rwp\webapps\projectconsole\PublishedViews\ 
Dashboard\ClassicsCD.com Projects.

6 If the original warehouse did not include a user with username admin, then the 
ProjectConsole Version 2003 adds this user. The username is admin and the 
password is changeit. You cannot delete, rename, or suspend this user, but you can 
change its password. We recommend that you do change the password for security 
reasons.

7 When you or a user starts the ProjectConsole Dashboard or Designer Java applets, 
a Security Warning appears asking if you want to trust the signed applet. Click 
Grant Always or Yes to continue, depending on which Java plug-in version is 
installed on your computer. 

We recommend that you notify users that they will also have to respond to the 
question about trusting the signed applet.

8 If you have upgraded from SQL Anywhere 5.0: Optionally, use the ProjectConsole 
Maintenance tool to copy the schema repository and data warehouse from the 
migrated SQL Anywhere 5.0 databases to the SQL Anywhere 8 databases. Taking 
this step improves performance. See the Maintenance Tool Help for assistance with 
this step.
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Upgrading ProjectConsole Agent Software

This section describes how to upgrade the ProjectConsole services running on a 
remote server. If you did not install ProjectConsole collection agents or report servers 
on a remote server, you may skip this section. 

We assume that you have already performed these steps:

■ Installed the ProjectConsole Web server components (see Upgrading Web Servers on 
page 87).

■ Restarted the ProjectConsole Web server machine, which automatically starts 
ProjectConsole servers. 

■ Upgraded the ProjectConsole server software on the Web server machine.

■ Installed the ProjectConsole report server and collection agents on a remote server.

To configure the ProjectConsole services:

1 Start the ProjectConsole Maintenance Tool: click Start > Rational Software > 
Rational ProjectConsole > Rational ProjectConsole Maintenance Tool.

2 On the first page of the Maintenance Tool, click Configure the ProjectConsole 
services, and then click Next.

3 Enter the Web server name.

There are advanced options on this page. In most cases, you can accept the default 
value for each option. The Maintenance Tool Help describes each option in detail.

4 Click Finish.

5 Verify that the message Operation Complete displays.

You do not need to restart the ProjectConsole collection agents or report server. These 
items automatically notice the new Web server name and connect to the 
ProjectConsole servers running on the Web server.

Migrating from Rose to XDE [optional]

XDE is not part of Rational Suite. It is a companion product and some Suite products 
integrate with XDE. For information about migrating to Rational XDE, see 
“Upgrading and Migrating to Rational XDE” in the Rational XDE Help.

When a Rose Model Is Part of a Rational Administrator Project

If you migrate a Rose model to XDE and the Rose model is in a Rational project, the 
Rational Administrator continues to maintain a pointer to the obsolete Rose project, 
and does not create a new pointer to the XDE project. Also, the Rose project and XDE 
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project are independent and do not synchronize automatically. After the conversion 
from Rose to XDE, you cannot migrate new work from the Rose model to the XDE 
model.

Therefore, remember to perform all your work in the new XDE model, not in the Rose 
model. 

Upgrading Rational Unified Process

To upgrade the Rational Unified Process, perform these tasks:

■ If you used an earlier version of RUP and did not customize it, then you do not 
need to do anything to upgrade RUP. However, you may optionally wish to 
evaluate RUP Builder to determine whether your organization can benefit from 
creating and publishing a customized configuration.

■ If you used an earlier version of RUP Builder to publish a RUP configuration for a 
project, use RUP Builder Version 2003 to select the process components and 
plug-ins you need. Then create appropriate process views and publish a new RUP 
web site.

■ If you edited an earlier version of the published RUP website to point to additional 
content, take one of the following steps:

❑ Use RUP Builder to add those links to process views.

❑ Use the RUP Organizer component of the Rational Process Workbench to 
package the content in a Thin Plug-in. Then include it in a configuration.

■ If you used Rational Process Workbench to create a process plug-in, download and 
install the new Rational Process Workbench, and migrate your plug-in based on 
content in the process-engineering version of RUP.

Running RUP Builder

To use RUP content that you have customized, run RUP Builder. Describe your 
process, select process components and plug-ins, edit the process views, and publish a 
new RUP web-site. See the RUP Builder Help and RUP Builder tool mentors for more 
information.

Adding Links to Process Views

If you created additional RUP content such as a project or organizational web site, use 
RUP Builder to create a process configuration and organize the content using the 
process views, adding the links that you need. See the RUP Builder Help for more 
information.
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Upgrading Rational Process Workbench

If you used Rational Process Workbench in an earlier version of RUP, read this section. 
In this release, RPW has been split into these components: 

■ RUP Modeler is an add-in to Rational XDE Modeler. Process Engineers use RUP 
Modeler to create process models for RUP plug-ins.

■ RUP Organizer helps you add content to RUP plug-ins, and to create Thin Plug-ins 
that do not require modeling.

If you used RPW in earlier releases, migrate your plug-ins to these new tools. For 
more information, read about migrating your plug-ins in the Rational Process 
Workbench Upgrade Guide. This guide is in the process-engineering version of RUP 
within the RPW package.

Packaging Content in a Thin Plug-in

To allow multiple teams access to organizational standards or guidelines in their 
customized version of RUP: 

1 From the Rational Developers Network, download and install Rational Process 
Workbench (RPW).

2 Use the RUP Organizer component of RPW to package the content into a Thin 
Plug-in.

3 Provide the plug-in to project managers for use in their RUP configurations.

For more information, see the process-engineering version of RUP within the RPW 
package, RUP Organizer Help, and RUP Organizer tool mentors.

Upgrading Extended Help 

If you customized Extended Help topics, upgrade as follows: 

1 Use the RUP Organizer component of the Rational Process Workbench, available 
from the RUP Plug-in Exchange on the Rational Developer network 
(www.rational.net\rupexchange). Create a thin plug-in containing those Extended 
Help topics you have added to Extended Help.

2 Use RUP Builder to add the Thin Plug-in to your RUP Configuration.

3 Use RUP Builder to publish the RUP Configuration.

4 Instruct your users to navigate to the published configuration.

5 The first time users invoke Extended Help, RUP displays all RUP configurations 
they have navigated to. Users need to select a configuration, usually the 
configuration of the project they are working on.
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3Upgrading Web Servers
This chapter describes how to upgrade Web servers. As of this release, most Rational 
Web servers run on the Rational Web Platform, which needs minimal manual 
configuration. 

If you are using Web services for the following tools, then you are using the Rational 
Web Platform (RWP), and you should be familiar with the material in this chapter:

■ RequisitePro
■ ProjectConsole
■ ClearCase

ClearQuest Web and ManualTest Web do not use the Rational Web Platform. If you 
use these Web services, there are no upgrade tasks.

The remainder of this chapter describes how to perform the following tasks:

■ Install the Rational Web Platform.
■ Configure RequisiteWeb (one-time activity to set up new RWP service).
■ Configure ClearCase Web (one-time activity to set up new RWP service).
■ Allow IIS and RWP to co-exist on a single server.
■ Configure RWP if you need to change the original configuration.

Installing a Web Service that Uses the Rational Web Platform

Before You Install

Before you install a Web service that uses the Rational Web Platform:

1 Stop the following services:

❑ The default Web server under Internet Information Server (use the Computer 
Management utility)

❑ The World Wide Web (WWW) Publishing service 

❑ ProjectConsole servers and xmlagents.exe 

2 Change the Startup Type for the WWW service to Disabled or Manual. 

3 Remove all Rational products on the computer that are at an earlier version than 
the current version. 
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Performing the Installation

Use the Rational setup program to install a Web service, such as RequisiteWeb, that 
uses the Rational Web Platform. The installation program configures the Rational Web 
Platform. 

In most cases, the Rational Web Platform is immediately available for use at this point. 
In some cases, you may need to make minor configuration changes before users can 
work with the Web tools. See Configuring the Rational Web Platform on page 100 for 
more information.

Upgrading Desktop Systems on page 145 describes how to redirect a desktop browser to 
start using the new Web servers. 

Configuring RequisiteWeb

To operate RequisiteWeb, see the following sections:

■ Configuring the RequisiteWeb server on the Rational Web Platform (RWP)

■ Testing RequisiteWeb

■ Managing RequisitePro Projects for RequisiteWeb

For more information about the Rational Web Platform, see Configuring the Rational 
Web Platform on page 100.

For the most current information on RequisiteWeb, including installation, 
configuration, and known issues, refer to the Installing and Configuring Rational 
RequisiteWeb document that is on the Rational Solutions for Windows CD at:
\Doc\RequisiteWebInstall.html
It is also located, by default, in your RequisiteWeb installation at: 
C:\Program Files\Rational\Doc\RequisiteWebInstall.html

The Installing and Configuring Rational RequisiteWeb document is also available from 
the online Release Notes in RequisitePro.

Prerequisites

The following instructions assume you have:

■ Configured the RequisitePro project database.

■ Installed and configured the Oracle client software on the RequisiteWeb server if 
you have chosen the Oracle database to store your RequisitePro projects. 

■ Installed the RequisiteWeb components. If you have not installed these 
components, see Installing Rational Products on page 113.
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■ To access RequisiteWeb from clients, users should install one of the supported Web 
browsers listed in the Installation Guide for Rational Desktop Products on their 
desktops. No additional client installation is required.

■ For proper RequisiteWeb operation, client users should set their browsers to allow 
cookies.

Configuring the RequisiteWeb Server 

This section describes how to configure the RequisiteWeb components on your 
Rational Web Server and describes how to perform the following tasks: 

■ Create the ReqWebUser
■ Add the ReqWebUser to the Local Administrator group.
■ Grant ReqWebUser access to network projects.
■ Assign DCOM permissions to the Local Administrators group.
■ Edit the RequisiteWeb configuration file (optional)
■ Enable the Secure Socket Layer (SSL).

Creating the ReqWebUser

RequisiteWeb requires that you create a RequisiteWeb user. The RequisiteWeb user 
can be given any name. For the purposes of this guide, the user will be called 
ReqWebUser. This user will be granted the necessary permissions for RequisiteWeb to 
operate properly. If all RequisitePro projects that will be accessible via ReqWeb will be 
located on drives local to the RequisiteWeb server, create ReqWebUser as a local user 
on the RequisiteWeb server. Otherwise (if any of the projects assessable via ReqWeb 
are located on network file shares within your domain), create ReqWebUser as a 
domain user on your primary domain controller server. 

Note:  If you create the ReqWebUser user on the Windows domain server, be sure to 
log in to your Windows domain server as an administrator.

Table 6 on page 90 describes how to create the ReqWeb user.
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Adding the ReqWebUser to the Local Administrator Group

Table 7 shows how to add the ReqWebUser to the local administrator group.

Note:  Be sure to log in to your RequisiteWeb server as an administrator for the 
following procedure.

Table 6 Creating the RequisiteWeb User

Step NT 4.0 Windows 2000 Server/.NET RC2

1 On the domain server, click Start > 
Programs > Administrative Tools 
(Common) > User Manager for 
Domains.

On the domain server, click Start > 
Programs > Administrative Tools > 
Computer Management.

2 Click User > New User. Expand Domain Users and Groups. 
Right-click Users; select New User.

3 In the Username field, type 
ReqWebUser 
and type a password of your choice.

In the Username field, type ReqWebUser 
and type a password of your choice. 

4 Clear the check box User must change 
password at next login, and select the 
check box Password never expires. 
Click Add; click Close.

Clear the check box User must change 
password at next login, and select the 
check box Password never expires. Click 
Create; click Close.

5 Close the User Manager application. Close the Computer Management 
application.

Table 7 Adding the ReqWebUser to the Local Administrator Group

Step NT 4.0 Windows 2000 Server/.NET RC2

1 On the Windows server, click Start > 
Programs > Administrative Tools 
(Common) > User Manager for 
Domains.

On the Windows server, click Start > 
Programs > Administrative Tools > 
Computer Management.

2 Click User > Select Domain, select your 
domain server, and type your machine 
name. Click OK.

Expand Local Users and Groups. Select 
Groups. Right-click Administrators and 
select Add to Group. In the Administrators 
Properties dialog box, click Add.

3 Under the Groups column, double-click 
Administrators.

The Select Users or Groups dialog box 
appears. At the Look in field, select the 
domain where you created the ReqWebUser.
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Assigning DCOM Permissions to the Local Administrators Group

RequisiteWeb uses DCOM to launch Microsoft Word. To achieve this, the 
ReqWebUser should be a member of the Administrators group on the RequisiteWeb 
server.

Note:  If you have not already installed Microsoft Word on your RequisiteWeb 
server, you must do so now.

To Assign Access Permissions to the Local Administrators Group:

1 On the Start menu, click Run, and type dcomcnfg

Note:  At this point you may see the DCOM Configuration Warning dialog box. Close 
the warning and proceed to the next step.

2 Select the Default Security tab. Under Default Access Permissions, click the Edit 
Default button. 

3 In the Registry Value Permissions dialog box, click Add.

4 At the Add Users and Groups dialog box, select your local machine from the List 
Names From drop-down list box.

5 Select the Administrators group in the Names list and click Add.

6 At the Type of Access field, select Allow Access. Click OK twice to return to the 
Distributed COM Configuration Properties dialog box.

To Assign Launch Permissions to the Local Administrators Group:

1 Select the Default Security tab. Under Default Launch Permissions, click the Edit 
Default button. 

2 In the Registry Value Permissions dialog box, click Add.

4 In the Local Group Properties dialog 
box, click Add. Select your Domain 
Server in the List Names From list. 
Select ReqWebUser in the Names list 
and click Add. Click OK.

Select the ReqWebUser and click Add. 

5 Click OK in the Local Group Properties 
dialog box to close it.

Click OK to close the Select Users or 
Groups dialog box. Click OK to finish.

6 Close the User Manager application. Close the Computer Management 
application.

Table 7 Adding the ReqWebUser to the Local Administrator Group 

Step NT 4.0 Windows 2000 Server/.NET RC2
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3 At the Add Users and Groups dialog box, select your local machine from the List 
Names From drop-down list box.

4 Select the Administrators group in the Names list and click Add.

5 At the Type of Access field, select Allow Launch. Click OK twice to return to the 
Distributed COM Configuration Properties dialog box.

6 Close DCOM and restart your system.

RequisiteWeb and IIS

RequisiteWeb uses Rational Web Platform (RWP) as its Web service. Because RWP and 
IIS can conflict with one another you must choose one of the following options to run 
RequisiteWeb on a server with IIS running: 

■ Disable IIS

■ Change and redirect the default RWP HTTP port

Disable IIS
If you choose to disable IIS, any programs using IIS will no longer work. Table 8 
shows how to disable IIS.

Table 8 Disable IIS

Step Windows NT 4.0 Windows 2000 Server/.NET RC2

1 Go to Start > Settings > Control Panel 
> Services. 

Go to Start > Settings > Control 
Panel > Administrative Tools > 
Services. 

2 Locate and select the World Wide Web 
Publishing service.

Locate the World Wide Web 
Publishing service and double-click 
the icon to display the Properties 
dialog box.

3 In the Services window, click the Stop 
button and change the Startup type to 
Disabled.

On the General tab under Server 
status, click the Stop button and 
change the Startup type to Disabled. 
Click OK and close the Services 
window.

4 Click Close to finish. Click OK to close the dialog box. Close 
the Internet Services Manager.
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Change and redirect the default RWP HTTP port
This option will allow the coexistence of RequisiteWeb and IIS. To change and redirect 
the default RWP HTTP port:

1 Change the default RWP HTTP port (80) in your rwp.conf file. Follow the 
instructions in To Change the Default RWP HTTP Port on page 214.

2 Create a virtual directory for RequisiteWeb on your RequisiteWeb server:

a Launch the Internet Services Manager by doing one of the following: 

➑ In Windows NT 4.0, click Start > Programs > Windows NT 4.0 Option Pack > 
Microsoft Internet Information Server > Internet Service Manager. 

➑ In Windows 2000 Server, click Start > Programs > Administrative 
Tools/Internet Services Manager.

b Right-click the Default Web Site and select New Virtual Directory. 

c In the Virtual Directory Creation Wizard, click Next and type an Alias: ReqWeb.

d Click Next and browse to and select 
C:\Program Files\Rational\common\RWP\webapps2\ReqWeb 
and click Next.

e Click Next and Finish to complete the wizard.

3 In the properties of your newly created Virtual Directory, select A redirection to a 
URL and redirect to: http://<server name>:<new port>/reqweb.

4 Close the Internet Services Manager and restart the Rational Web Platform. Follow 
the instructions To Stop and Restart RWP on page 218.

Editing the RequisiteWeb Configuration File (optional)

Edit the RequisiteWeb configuration file to:

■ Customize your document location

■ Customize web access to document locations

■ Relocate your catalog.txt

■ Enable SSL

To use customized RequisiteWeb settings, in a text editor, open 
C:\Program Files\Rational\common\rwp\webapps2\ReqWeb\WEB-INF\ 

classes\config.txt

This procedure assumes that you have installed the RequisiteWeb application on your 
C:\ drive. Substitute the appropriate drive, if necessary, when performing this step. 
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Considerations:

■ We recommend that you back up your config.txt file before making changes. 

■ Rational Web Platform must be restarted for configuration changes to take effect; 
see To Stop and Restart RWP on page 38.

■ We do not recommend changing any config.txt settings not listed in this table 
without guidance from RequisiteWeb technical support. 

Setting Description Default

RPXDocPath The path to the directory where RequisiteWeb 
temporarily stores Word documents (aka the “GenDoc” 
directory). From the GenDoc directory, client web 
browsers download documents (Word format) or read 
them for display (HTML format). For example:

RPXDocPath=C:\Program 
Files\Rational\common\rwp\webapps2\ReqWeb
\GenDoc

Note:  If you change the RPXDocPath directory, 
you must make a corresponding change to the 
RPXHTTP variable below. The converse also 
applies.

<blank>

RPXHTTP The URL that client web browsers use to access the 
RPXDocPath directory. If you enter a relative URL, it will 
be relative to “http://<servername>/ReqWeb”. For 
example:

RPXHTTP=GenDoc/

-or-

RPXHTTP=http://<anotherserver>/GenDoc/

Note:  This setting is case-sensitive. 

GenDoc/

RPXCatalog The path to the project catalog file that is used to locate 
RequisitePro projects. For example:

RPXCatalog=C:\Program 
Files\Rational\RequisitePro\ReqWeb\Projec
ts\catalog.txt 

<blank>

SSL Set SSL to true if SSL is enabled. This setting affects 
whether hyperlinks in HTML-format documents use 
HTTP or HTTPS. For example:

SSL=true 

false
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Enabling SSL (Secure Socket Layer) 

RequisiteWeb supports SSL, an encryption system that ensures the confidentiality of 
data exchanged between RequisiteWeb and a client web browser. To use SSL with 
RequisiteWeb:

1 Stop the Rational Web Platform, see To Stop and Restart RWP on page 38. 

2 Set SSL to true in the RequisiteWeb configuration file (see above table).

3 Remove all files and directories in the GenDoc directory. By default, this is 
C:\Program Files\Rational\common\rwp\webapps2\ReqWeb\GenDoc 

4 Follow the instructions for configuring the Rational Web Platform to enable SSL in 
Configuring RWP To Use Secure Sockets on page 41.

Granting ReqWebUser Access to Network Projects

Reboot Required

At this point you must restart your system. After rebooting, log in as the same user to 
complete the installation procedure.

Table 9 Granting ReqWebUser Access to Network Projects

Step Windows NT 4.0 Windows 2000 Server/.NET RC2

1 Go to Start > Settings > Control 
Panel > Services.

Go to Start > Settings > Control Panel > 
Administrative Tools > Services.

2 Locate and double-click the Rational 
Web Platform, ReqWeb servlet 
engine service to display the Service 
dialog box.

Locate the Rational Web Platform, 
ReqWeb servlet engine service and 
double-click the icon to display the 
Properties dialog box.

3 In the Service window under Log On 
As, click This Account and enter the 
ReqWebUser and password that you 
created. Click OK to close the Service 
window.

Select the Log On tab and click This 
account. Enter the ReqWebUser and 
password that you created and click Apply. 
Click OK and close the Rational Web 
Platform window.

4 Stop and start the Rational Web 
Platform, ReqWeb servlet engine 
service and start the Rational Web 
Platform, HTTP server service to 
finish.

Start or restart the Rational Web Platform, 
ReqWeb servlet engine service to finish.
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Testing RequisiteWeb

To test a RequisitePro project in RequisiteWeb:

1 Open a web browser.

2 Set the URL address to http://<server name>/reqweb on your RequisiteWeb server 
and press enter.

3 Select a RequisitePro project that contains documents from the Project list. If your 
project does not appear on the list, refer to the procedure Managing RequisitePro 
Projects for RequisiteWeb on page 96.

4 Type your RequisitePro User name and Password and click Log in.

5 Select a document in the Explorer and open it. If the document opens correctly, the 
test has succeeded; RequisiteWeb has been properly installed.   

Note:  If the Microsoft Word installer appears, you must allow it to complete.

Stopping and Starting RequisiteWeb

The Rational Web Platform (RWP) should start automatically, but if you need to stop 
and restart RWP, see To Stop and Restart RWP on page 38.

Managing RequisitePro Projects for RequisiteWeb

Although RequisiteWeb provides features for accessing and editing requirements and 
documents in projects, you must use the full RequisitePro PC client application to 
create projects and documents. RequisitePro offers project templates and other 
management tools for creating and modifying project structure and security. For more 
information, refer to the Rational RequisitePro User's Guide or the RequisitePro online 
help.

Using the RequisiteWeb Project Catalog 

RequisiteWeb uses a catalog text file to provide access to RequisitePro projects. By 
default, the file contains entries for the RequisitePro Learning Project and another 
sample project. The projects that are listed in your catalog file appear in the Projects 
drop-down list box on the RequisiteWeb logon page.

To add your own projects to the catalog, you must type the full path for the project 
file, which has a .rqs extension. For instructions on modifying the catalog, see Editing 
the RequisitePro Projects Catalog.
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Editing the RequisitePro Projects Catalog 

To edit the catalog, perform the following procedure on the RequisiteWeb server:

1 Navigate to the directory: 
C:\Program Files\Rational\RequisitePro\ReqWeb\Projects

Note:  If your projects are installed in a directory other than C:\ you must edit the 
catalog.txt file to reflect the correct installation directory.

2 Using a text editor, open the catalog.txt file. 

3 Create an entry on each line with the full path to the RequisitePro project file. Copy 
the format of the default project entries. 

Note:  Use a full path for local projects on the RequisiteWeb server. To access 
projects on another server, you must specify a Universal Naming Convention 
(UNC) path to the shared folder containing the RequisitePro .rqs file. For example, 
\\server_name\full_path\my_project.rqs.

4 Save and close the catalog.txt file.

Note:  To view updates to the catalog.txt file, you must log off RequisiteWeb and then 
select a project at the RequisiteWeb project “log in” page.

Database Projects

RequisiteWeb can open SQL Server- and Oracle-based projects that are not physically 
located on the RequisiteWeb server; however, the ReqWebUser domain user must 
have Change or Modify permission for the directory containing the RequisitePro 
(.rqs) project file on the remote project server.

Note:  In order to execute the provided SQL Server database scripts you must be 
logged in as 'sa' or as a user with “System Administrator” and “Security 
Administrator” privileges.

Configuring ClearCase Web

For many sites, the ClearCase Web interface requires no special configuration; any 
host on which RWP is installed can support this interface at the URL

http://hostname[:port]/ccweb 

where hostname is the name of the RWP host and port is an optional port number if 
RWP has been configured to use a port other than 80 for HTTP (see To Change the 
Default RWP HTTP Port on page 34).

Note:  When RWP runs on a Windows computer, ClearCase Web interface users must 
be given permission to Log On Locally to the RWP server. Windows does not grant this 
permission by default.
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The remainder of this section explains how you can edit the ClearCase Web interface 
configuration file

ccase-home-dir/config/ccweb/ccweb.conf 

if you need to modify the default configuration of the ClearCase Web interface.

Note:  Do not confuse this file with the ClearCase Web interface support file for RWP. 
This support file is installed as C:\Program Files\Rational\common\rwp\ccweb.conf. It 
should not be modified.

Specifying the ClearCase Primary Group

At sites where ClearCase users on Windows set the CLEARCASE_PRIMARY_GROUP 
environment variable (read about Setting the ClearCase Primary Group in the ClearCase 
Administrator’s Guide), you must also specify that primary group for ClearCase Web 
interface users by modifying this line in the ccweb.conf file:

–primary_group group-name 

where group-name is the name of a domain group that will be used as the 
CLEARCASE_PRIMARY_GROUP for all users who access the ClearCase Web interface 
on this host.

Note:  When users from multiple domains access the ClearCase Web interface, you 
must enable domain (described in Using Proxy Groups and Domain Mapping in 
Windows NT Domains in the ClearCase Administrator’s Guide) on the RWP host and 
specify an appropriate value for –primary_group in ccweb.conf. 

Web View Storage

The ClearCase Web interface normally creates Web view directories on the RWP 
server host. These directories are used for temporary storage of files that are checked 
out or ready to be created as elements. Therefore, they must be on a disk volume that 
has enough space for the number of Web views to be supported. We suggest 
allocating 0.5 MB to 1 MB of disk space for each Web view.

On Windows, these directories are normally created under 
C:\Program Files\Rational\ClearCase\var\ccweb 

If the default Web view storage directory is not appropriate, you can select a different 
area by modifying ccweb.conf. Add the line

–view_storage pathname 
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where pathname is the directory in which you want the Web view directories to be 
created. This directory must be local to the RWP host.

Note:  Although the ClearCase Web interface may create a separate directory for Web 
view storage, it continues to store executable and administrative files in 
ccase-home-dir/ccweb. 

Limiting Upload Size

To better manage Web view storage or reduce the possibility of denial-of-service 
attacks, you may want to limit the size of files that can be uploaded to the RWP server. 
To do so, modify the following line in the ccweb.conf file:

–upload_limit size 

where size is the approximate desired size limit in bytes. An attempt to upload a file 
that is too large results in an error message in the Client Upload output window.

Specifying a Session Timeout

You can configure the session timeout interval, which controls how long a user login 
remains valid. The default value is 14400 seconds (four hours). You can change this 
default by modifying the line

–session_timeout seconds 

in ccweb.conf, where seconds is an integer number of seconds between 600 (10 minutes) 
and 2147483647 (about 68 years). Values less than 600 are interpreted as 600.

Specifying a Directory for Temporary Storage

You can designate a directory where the ClearCase Web interface stores temporary 
files by adding a line of the form

–tmpdir directory-name 

to ccweb.conf, where directory-name is a directory on the RWP host in which the 
ClearCase Web interface has permission to create and delete files. If this line is not 
present in ccweb.conf, the ClearCase Web interface uses the value of the TMP or TEMP 
environment variables, if they exist.

Permission to Download Applets on Windows

Internet Explorer typically requires a user to have local administrator privileges to 
download applets, including those used by the ClearCase Web interface. After these 
applets have been downloaded (the first time the Web interface is used), they do not 
have to be downloaded again unless a ClearCase patch or new ClearCase release 
changes them. 
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Allowing IIS and RWP to Co-Exist on a Single Server

In some cases, you may want the Rational Web Platform to co-exist on the same 
computer with an IIS application. To enable this co-existence:

1 Follow the instructions in Configuring the Rational Web Platform on page 100 to 
configure the Rational Web Platform to listen on port 81. At this point, you can use 
hostname:81 to get access to a Rational Web application, for example, 
http://hostname:81/projectconsole.

2 Restart the RWP service.

3 Start IIS. 

4 For each Rational Web application, create an IIS virtual directory pointing to a 
redirection directory. For example, name the directory projectconsole.

5 Edit the properties of each redirection directory:

❑ Configure it as “A redirection to a URL”

❑ For the URL, enter the path that you set up in Step 1, for example, 
http://hostname:81/projectconsole.

You can now get direct access to a Rational Web application without using the port 
number, for example, by typing: http://hostname/projectconsole.

Configuring the Rational Web Platform

The Rational Web Platform (RWP) provides server side support for Web interfaces to 
the Rational products, Rational ClearCase, Rational ProjectConsole, and Rational 
RequisiteWeb. RWP is installed with a default configuration, which is suitable for 
most sites. Some sites may need to modify the RWP configuration after installation to 
accommodate various host- or site-specific requirements. For example:

■ To make RWP use a different HTTP port number
■ To change RWP logging defaults
■ To configure access to RWP from another Web server acting as a proxy
■ To configure RWP to use secure sockets

This section explains how to edit the RWP configuration files to make some of the 
more common changes in the default configuration. 
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The Rational Web Platform includes a Web server based on the Apache HTTP Server 
version 2.x and a servlet engine based on the Tomcat servlet container version 4.x. 
Additional information about the Apache HTTP Server is available at www.apache.org. 
Additional information about the Tomcat servlet container is available at 
jakarta.apache.org.

On Windows, RWP creates a second instance of the servlet engine for use if needed.

Note:  The Rational Web Platform supports only the Web interfaces to Rational 
products. Using it to serve other Web applications or content is not supported.

RWP Installation Directory

RWP is normally installed in the following directory:

■ On Windows, C:\Program Files\Rational\common\rwp 

The default RWP installation directory can be changed at installation time by 
supplying a different path when prompted by the install program.

RWP Configuration Files

RWP configuration is specified in several files. The following files are normally 
installed in the conf subdirectory of the RWP installation directory:

■ rwp.conf specifies configuration parameters for the RWP server.

■ ssl.conf specifies configuration parameters for secure sockets if they are used by the 
RWP server.

■ server.xml specifies configuration parameters for the RWP servlet engine.

■ On Windows, server2.xml specifies configuration parameters for the RWP ReqWeb 
servlet engine.

■ workers.properties specifies configuration parameters for the connections between 
RWP and RWP servlet engine(s).

On Windows, the following files are normally installed in the bin subdirectory of the 
RWP installation directory:

■ jk_service.properties controls how the RWP servlet engine runs as a Windows 
service.

■ jk_service2.properties controls how the RWP ReqWeb servlet engine runs as a 
Windows service.
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You can edit these files with any text editor. They include explanations of all 
configuration parameters. This section describes a few of the parameters that you may 
need to change.

Note:  After changing any configuration parameter in any of these files, you must stop 
and restart RWP before the change takes effect. See To Stop and Restart RWP on 
page 106.

Configuration File Reference Versions

The RWP installation directory includes reference versions of all configuration files.

❑ rwp.in.conf 

❑ server.in.xml 

❑ server2.in.xml 

The install program uses these reference versions to determine whether configuration 
files have been customized. Do not make any changes to them.

To Change the Default RWP HTTP Port 

The port on which RWP listens for HTTP requests is defined by the Listen parameter 
in rwp.conf. For example,

Listen 80

tells RWP to listen on port 80 (the default for HTTP). You may change this to specify 
any available port number. For example:

Listen 8000

tells RWP to listen on port 8000.

Note:  If you change the RWP HTTP port number to anything other than 80, all URLs 
that reference RWP must include the port number. For example:

http://RWP_host.domain:8000/ccweb

To Change the Default RWP Servlet Engine Ports 

The ports on which the RWP servlet engine communicates with RWP are defined in 
the server.xml and server2.xml files as well as the workers.properties file. Table 10 lists 
default port numbers, port uses, and the files in which the port numbers are defined.

Table 10 Default RWP Servlet Engine Ports

Port Number Description Location

8009 (8010 on 
HP-UX)

Used for communication between RWP 
and the RWP servlet engine

server.xml, workers.properties 
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If any of these ports is used by another application on the RWP host, we recommend 
that you reconfigure that application to use different ports. If you cannot, you must 
change the ports RWP uses.

The following example, from server.xml, defines port 8009 as the port used for internal 
communication between RWP and the RWP servlet engine:

<Connector className="org.apache.ajp.tomcat4.Ajp13Connector"
port="8009" minProcessors="5" maxProcessors="75"
acceptCount="10" debug="0"/>

To change either port, change the value of the port attribute of the appropriate 
Connector element. For example, the port=”8088” attribute in the line 

<Connector className="org.apache.ajp.tomcat4.Ajp13Connector"
port="8088" minProcessors="5" maxProcessors="75"
acceptCount="10" debug="0"/>

causes internal communication between RWP and the servlet engine to use port 8088.

Note:  If you change the port attribute of the Ajp13Connector element in server.xml, you 
must also change the port in this line of the workers.properties file:

worker.ajp13.port=8009

If you change the port attribute of the Ajp13Connector element in server2.xml, you must 
also change the port in the worker.ajp13_2.port line of workers.properties. These files 
exist only on Windows hosts where RWP supports a second instance of the RWP 
servlet engine.

To Configure RWP Logging

A number of configuration parameters related to access, error, and event logging in 
rwp.conf are grouped under the heading Logging-related directives. You may want to 
change any of the following:

■ ErrorLog specifies the name of the file where errors are logged. For example,

ErrorLog logs/error.log

8010 Used for communication between RWP 
and the RWP ReqWeb servlet engine 
(Windows only)

server2.xml, workers.properties 

8005 (8006 on 
HP-UX)

RWP servlet engine shutdown port server.xml 

Table 10 Default RWP Servlet Engine Ports

Port Number Description Location
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specifies that errors will be logged in the file logs/error.log under the RWP 
installation directory.

Note:  Any RWP log file may be piped to the rotatelogs command, as described in 
Log Rotation and Log Cleanup on page 105.

■ LogLevel specifies the type and severity of errors to be logged. For example,

LogLevel warn

specifies that errors up to and including warnings will be logged. Table 11 lists the 
various log levels in order of decreasing severity. Specifying any of these values for 
LogLevel logs events of that severity and all lower severities.

■ LogFormat specifies the format in which events are logged. You can choose one of 
the predefined formats (for example, common), or you can define your own format. 
For more information about format tokens and the rules for constructing log file 
strings, see the documentation for mod_log_config at www.apache.org.

■ CustomLog specifies the name of the file in which RWP access requests are logged. 
For example,

CustomLog logs/access.log common

specifies that access requests will be logged in the file logs/access.log under the 
RWP installation directory in the common log file format.

Table 11 RWP Log Levels

LogLevel Messages logged

emerg Emergency messages about events that may render the server inoperable 
(Highest severity)

alert Conditions that should be corrected immediately

crit Critical conditions such as hardware or system errors

error All other errors

warn Warning messages

notice Conditions that may require special handling

info Informational messages (lowest severity)

debug Debugging RWP 
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Log Rotation and Log Cleanup

On RWP hosts where ClearCase is installed, the scheduled Weekly Log Scrubbing job 
removes all RWP log files that are more than 30 days old. You can modify this job as 
described in the ClearCase Administrator’s Guide to change the frequency with which 
the job runs, the age of the log files it removes, or any other aspect of its operation.

Note:  If you change any of the default RWP log locations on a host where ClearCase is 
installed, you must also modify the cleanuplogs script so that it looks for these logs in 
their new location.

On RWP hosts that do not have ClearCase installed, you must periodically run the 
following program to remove old log files:

■ the perl script cleanuplogs.pl, located in the RWP bin directory.

Use a scheduled-execution program supplied by the operating system (at on 
Windows) to run these scripts, or run them manually.

To Change the User Account Used by RWP

On installation, RWP is configured to run with the identity of a built-in user account. 
You can change this account if necessary by using one of the procedures described in 
this section.

To Change the RWP User Account on Windows

On Windows computers, RWP is started at boot time by the Windows Service Control 
Manager and runs with the identity of the built-in LocalSystem account 
(NT AUTHORITY\SYSTEM).

To change the identity under which RWP runs on Windows:

1 Run the Services application (in Control Panel > Services or Control Panel > 
Administrative Tools > Services). RWP includes the following services:

❑ Rational Web Platform, HTTP Server

❑ Rational Web Platform, servlet engine

❑ Rational Web Platform, ReqWeb servlet engine

Caution: The HTTP Server and servlet engine must run as LocalSystem on a 
Windows RWP host that is supporting the ClearCase Web interface. If these 
services run as any other user, the ClearCase Web interface will fail. The ReqWeb 
servlet engine can run as another account if necessary.

2 Edit each service’s Log On properties to specify either a local or domain account.

3 Run rwp_restart to stop and restart RWP (see To Stop and Restart RWP on page 106).
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To Stop and Restart RWP

RWP is normally started at boot time. If you need to stop or restart RWP (for example, 
to force it to re-read a changed configuration file), use one of the following 
commands, which are normally installed in the RWP bin directory:

■ rwp_startup starts RWP if it is not already running.

■ rwp_shutdown stops RWP and any associated servlet engine processes.

■ rwp_restart runs the rwp_shutdown and rwp_startup commands, in that order, to 
restart RWP.

Note:  Commands that stop and start ClearCase do not affect RWP.

To Configure Access to RWP from Another Web Server

Some sites may need to access RWP by proxy or redirection from another Web server. 
In this configuration, the other Web server redirects specific URLs to an RWP process 
running on the same server but using a different port, or running on a separate server. 
Two common use cases require this type of configuration.

■ RWP and another Web server must run on the same host. We recommend that 
you install RWP on a host that does not have to run any other Web servers. If this is 
impossible, we recommend that you configure the other Web server to use ports 
that are not being used by RWP. If you cannot do this, you must configure RWP to 
use ports not used by the other Web server (see To Change the Default RWP HTTP 
Port on page 102) and optionally configure the other Web server to redirect URLs 
for Rational Web clients to RWP.

■ RWP must run behind a firewall. To restrict access to RWP, a Web server running 
on the public side of a firewall can be configured to pass specific URLs to an RWP 
instance running on the other side of the firewall.

Follow the instructions in this section to enable a proxied or redirected configuration 
that provides access to RWP from either of the following Web servers:

■ Apache HTTP Server

■ Microsoft Internet Information Server (IIS)

Note:  Instructions for configuring proxied or redirected access to a Rational Web 
application are specific to the application and the Web server acting as the proxy. Only 
the Web servers and Rational Software products that are specifically cited in this 
section can be supported in a proxied or redirected configuration.
106 Rational Suite Upgrade Guide 



Configuring mod_proxy Support for Apache

To configure an instance of Apache HTTP Server to support proxy access to RWP, you 
must configure the Apache HTTP Server with proxy support supplied by the Apache 
mod_proxy module. Detailed information about how to do this is available at 
www.apache.org. The following is a summary of the steps you will probably need to 
take:

1 Configure the Apache HTTP Server to load the mod_proxy module and the other 
modules on which it depends. This typically requires you to uncomment various 
LoadModule directives related to mod_proxy support in the Apache httpd.conf file. 
For example

LoadModule proxy_module modules/mod_proxy.so
LoadModule proxy_connect_module modules/mod_proxy_connect.so
LoadModule proxy_http_module modules/mod_proxy_http.so 

You also need to uncomment the ProxyRequests On directive in the <IfModule 
mod_Proxy.c> block in httpd.conf:

<IfModule mod_Proxy.c>
ProxyRequests On
</IfModule>

2 Add the appropriate ProxyPass and ProxyPassReverse directives within the 
<IfModule mod_proxy.c> block in httpd.conf. ProxyPass and ProxyPassReverse 
directives are application specific:

For the ClearCase Web interface, add these ProxyPass and ProxyPassReverse 
directives: 

ProxyPass /ccweb http://hostname[:port]/ccweb
ProxyPassReverse /ccweb http://hostname[:port]/ccweb
ProxyPass /Java_Plugins http://hostname[:port]/Java_Plugins
ProxyPassReverse /Java_Plugins http://hostname[:port]/Java_Plugins

Where hostname is the name of the RWP server host and port is an optional port 
number, which you must specify if you have changed the default port on which 
RWP listens for HTTP requests (see To Change the Default RWP HTTP Port on 
page 102). For example, the following directives would configure the proxy server 
to support access by the ClearCase Web interface to an RWP process listening on 
port 81 of a host named RWP_host. 

ProxyPass /ccweb http://RWP_host:81/ccweb
ProxyPassReverse /ccweb http://RWP_host:81/ccweb
ProxyPass /Java_Plugins http://RWP_host:81/Java_Plugins
ProxyPassReverse /Java_Plugins http://RWP_host:81/Java_Plugins

Note:  The URLs specified in this example must be written in the httpd.conf file 
exactly as specified here, with the exception of the host name and optional port 
number.
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Configuring URL Redirection for Internet Information Server

If RWP must co-exist on a server with an instance of Microsoft Internet Information 
Server (IIS) that listens for HTTP requests on port 80, you must reconfigure RWP to 
listen for HTTP requests on a different port (see To Change the Default RWP HTTP Port 
on page 102) and then do one of the following:

■ Include a port specifier (for example http://hostname:81/ccweb/) in the URLs used by 
Rational Web interfaces served by this instance of RWP.

■ Use the IIS redirection facility to force Rational Web interface URLs directed to 
port 80 (and received by IIS) to be redirected to RWP.

To configure IIS to use redirection:

1 Run the IIS configuration utility (Internet Services Manager). 

2 Create a new virtual directory in the IIS Default Web Site folder:

❑ For the Virtual Directory Alias, pick a name that reflects the name of the Web 
client that will use the virtual folder (for example, ccweb).

❑ For the Web Site Content Directory, you must specify a physical directory on the 
Web server host. Although this directory must exist on the host, it will not be 
used to hold any Web site content after you configure redirection in Step 4. We 
recommend that you create a new directory for this purpose and apply 
protections to it that reduce the chances of its being accidentally deleted.

Note:  If you create this directory as a subdirectory of the RWP installation 
directory, it will be deleted if RWP is reinstalled on the host.

❑ For Access Permissions, specify Read and Run scripts.

3 Right-click the virtual directory you created in Step 2 and open its Properties 
dialog box. 

4 In the When connecting to this resource, the content should come from section of 
the Virtual Directory tab, select A redirection to a URL. 

5 In the Redirect to: box, type the URL used by the Rational Web interface that you 
are redirecting to RWP. For example, to redirect the ClearCase Web interface 
(ccweb) to use an instance of RWP listening on port 81, type

http://hostname:81/ccweb/ 

where hostname is the name of the host running RWP and IIS.

6 In the The client will be sent to section, select The exact URL entered above.

7 Verify that browsing to the URL http://hostname/ccweb redirects you to the 
ClearCase Web interface at the URL specified in Step 5. 
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Configuring RWP To Use Secure Sockets

To provide secure communications between Rational Web clients and RWP, you can 
configure RWP to support the Secure Sockets Layer (SSL) protocol. To do this, you 
need to take the following steps:

1 Edit the RWP configuration files to enable SSL support.

2 Modify client URLs as needed to specify the HTTPS protocol.

3 Stop and restart RWP.

Procedures for configuring RWP to support SSL are the same as those for configuring 
any Apache HTTPD that uses the mod_ssl module. These procedures are fully 
documented at the mod_ssl.org Web site; a summary of the configuration steps is 
presented here.

The first step in using SSL is to obtain a certificate from a certification authority (CA). 
RWP includes the openssl program (installed in the RWP bin directory), which you can 
use to generate a self-signed certificate for testing purposes and also obtain a 
certificate and key from a CA. For more information on openssl, see the openssl.org 
Web site.

You can run openssl in the RWP bin directory to generate a self-signed certificate and a 
matching private key and then install them in the locations specified in Step 2 and 
Step 3 of the following procedure.

■ On Windows, use this openssl command line:

OpenSSL> req –new –x509 –nodes –keyout ../conf/server.key –out ../conf/server.crt 

Note:  If you do not have the right to create files in the specified –out directory, this 
command will fail.

To configure RWP to accept SSL connections:

1 Configure RWP to include the ssl.conf configuration file. Uncomment this directive 
in rwp.conf:

Include conf/ssl.conf

Note:  The ssl.conf file includes a Listen directive that specifies the port on which 
RWP will listen for HTTPS requests. The default is port 443. You can change this in 
the same way that you change the default HTTP port. If you want RWP to listen 
only for HTTPS requests, comment out the Listen directive in the rwp.conf file.

2 Install the certificate. The default location of the certificate file is specified in this 
directive in the ssl.conf file:

SSLCertificateFile rwp-root-dir/conf/server.crt

where rwp-root-dir represents the directory in which RWP is installed on the host. If 
you install the certificate file in a different location, make sure that this line in 
ssl.conf references that location.
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3 Install the key. The default location of the key file is specified in this directive in the 
ssl.conf file: 

SSLCertificateKeyFile rwp-root-dir/conf/server.key

If you install the key file in a different location, verify that this directive references 
that location.

4 Stop and restart RWP.

Note:  To configure a Web application to use SSL, specify the https protocol in the 
application URL. For example:

https://RWP_host.domain/ccweb

Configuring Secure Access to RWP

There are a number of ways to configure RWP to use SSL to provide secure 
communications with Rational Web clients such as ccweb. Figure 1 shows a typical 
configuration that allows ccweb clients on the public Internet to access RWP through a 
firewall. Communications between client Web browsers and the RWP host supporting 
ccweb use the HTTPS protocol and are secured by SSL. Communications between 
RWP and the ClearCase servers on the corporate intranet use ordinary ClearCase 
remote procedure calls (RPCs) and are not secure. ClearCase RPCs cannot 
communicate through a firewall, so you cannot place a firewall between RWP and the 
ClearCase servers used by ccweb.

In a configuration like that shown in Figure 1, the ccweb URL would be: 

https://hostname/ccweb 

where hostname is the name of the RWP server host. HTTPS communications between 
the ClearCase Web client and RWP would use port 443, the default for HTTPS.
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Figure 1 Secure Communications Between ccweb and RWP

Other Modifications to RWP

We do not recommend that you modify any RWP configuration files other than those 
described in this section. Some of the configuration options cannot be changed 
without adversely affecting the operation of RWP. Any configuration change not 
recommended in this section should be carefully evaluated before introducing them 
into a production environment.
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4Installing Rational 
Products
Use the Rational installation program for initial and upgrade installations of Rational 
products. This chapter describes the Rational Setup Wizard and how the Wizard can 
help you deploy Rational products directly from the Rational Solutions for Windows 
CD-ROM, from a release area on a network, and in silent installation mode. 

Note:  See the Installation Guide for Rational Desktop Products for more information 
about installing and configuring desktop or client software.

Removing Previous Releases of Rational Products

Before installing Rational products from version 2003.06.00, remove previous versions 
of Rational products, including the Rational license server. The only exception is 
Rational ClearCase. You can install 2003.06.00 products with older versions of 
ClearCase. 

For the removal procedure, see the Removing Rational Products chapter in this guide. 

Note:  If you are using floating licenses, record the license server name(s) before you 
remove Rational products from your computer. After you install new Rational 
products on your computer, reset the hostnames in the Rational License Key 
Administrator. For more information, see the Removing Rational Products chapter in 
this guide.
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Deploying Rational Products

Use Table 12 to help you find the correct procedures for the deployment method that 
you have selected for your users. If the references are numbered, read the sections in 
the order specified. 

Table 12 Deployment Methods

Method See

Install directly from the Rational Solutions 
for Windows CD-ROM. 

1 Using the Rational Setup Wizard on page 115.

2 Using the Custom Setup Page on page 116.

3 Specifying the Rational License Server on 
page 119.

4 Installing Rational Products from the CD on 
page 119.

5 Post-Installation Tasks on page 131.

Create a release area and site defaults file 
using the Rational Setup Wizard.

1 Using the Rational Setup Wizard on page 115.

2 Specifying the Rational License Server on 
page 119.

3 Using the Setup Wizard to Create a Release Area 
and Site Defaults File on page 122.

Create multiple site defaults files for a 
release area.

1 Create a release area using the Rational Setup 
Wizard.

2 Running the Site Preparation Wizard to Create 
Multiple Sitedef Files on page 125.

Install from a release area on a network 
(using the standard configuration).

1 Installing Rational Products from a Release Area 
on page 125.

2 Post-Installation Tasks on page 131.

Install from a release area on a network 
(customizing the client configuration for 
your desktop).

1 Installing Rational Products from a Release Area 
on page 125.

2 Using the Custom Setup Page on page 116.

3 Post-Installation Tasks on page 131.

Cancel a product installation. ■ Canceling a Product Installation on page 132, or, 
■ Canceling a Silent Installation on page 131.

Reinstall the product (modify or repair). Reinstalling a Product (Modify or Repair) on 
page 133.
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Using the Rational Setup Wizard

The Rational Setup Wizard installs Rational Software products. Your Rational product 
shipment includes three Rational Solutions for Windows CD-ROMs: 

■ Disc 1-2 provide the Rational products to install. 

■ Disc 3 provides Rational product documentation.

■ Installation blocks and warnings are listed in Rational Setup Wizard Warnings or 
Blocks on page 134.

Rational_Install Log

The Setup Wizard does not display an error summary. The log of installation activities 
called Rational_install.log records all installation activities. You and a Customer Support 
representative can use the log to trace any installation errors.

By default, the install log file is in the TEMP directory. The location of the directory 
depends on the TEMP environment variable set on the computer. To find the location, 
open a command Window and type echo %TEMP% at the DOS prompt. 

This folder and file may be hidden. To display them in Windows Explorer, set Show 
Hidden Files and Folders.

Before You Start the Rational Setup Wizard

The following general requirements are necessary to run the Rational Setup Wizard 
on the system.

Set up a silent installation in a release area. Setting Up Silent Installations of Rational Products 
on page 129.

Perform a silent installation. 1 Performing a Silent Installation on page 130.

2 Post-Installation Tasks on page 131.

Remove a product. ■ Removing Rational Products on page 137, or, 
■ Using the Command Line to Remove a Product on 

page 131.

Use command line syntax. Command Line Syntax on page 133.

Apply a service release. Applying Service Releases on page 135.

Table 12 Deployment Methods (continued)

Method See
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■ Stop all applications, including SQL Anywhere services, before you begin the 
installation.

■ Make sure you have administrator privileges before installing Rational products. 

To use the Rational Setup Wizard on a Windows operating system, you must have 
Windows administrator privileges on the local computer. Log in as one of the 
following users:

❑ Local administrator

❑ Member of the local administrator’s group

❑ Domain administrator who is a member of the local administrator’s group

■ Turn off all virus protection software. These programs often run in the background 
and interfere with the install application’s performance because the virus 
protection checks each file that is installed.

■ Make certain that the system meets the minimum requirements and the correct 
operating system.

■ The Rational Setup Wizard uses C:\Program Files\Rational as the default installation 
path.

■ The Rational Setup Wizard installs Microsoft Core Components and some 
additional files on the same drive as the operating system (often the C:\ drive), 
even if you have specified an alternate drive for installation. These files can require 
5-15 MB of temporary disk space on your hard drive.

■ The Rational Setup Wizard requires that you install all Rational products in the 
same directory. If you already have Rational products installed on the computer, 
the Setup Wizard installs additional Rational products in the same directory. 

■ Make sure that you have a current backup of your registry and system directories. 

■ Turn off any user interface managers or environments that run on Microsoft 
Windows.

Using the Custom Setup Page

Use Table 13 to help you install the correct server features for your Rational product 
when you install the product from the CD-ROM image or when you customize your 
own configuration as you install from a release area. 
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The Custom Setup page lists the features for the product to be installed. The feature 
list in a Rational Suite edition includes Rational point products. The Custom Setup 
page appears in Step 9 of the procedure in Installing Rational Products from the CD on 
page 119.

Note:  For disk space requirements, see Have You Met the Prerequisites? on page 25. Do 
not use the number displayed in Custom Setup or the Space button on that page.

Table 13 Server Custom Setup in Rational Setup Wizard

To Install
Choose 
Product Custom Options Notes

Rational Suite 
Edition

Rational Suite The products included in the 
Suite edition will be selected. 
For example, under 
ClearQuest, you will see the 
ClearQuest Administration 
Tools, Web server, etc.

■ Does not install the ClearCase 
LT Server. 

■ Under each product in the 
Rational Suite, you will see 
features displayed as they are 
displayed in the rest of the 
Custom Options column.

ClearCase LT 
server

ClearCase LT ■ Rational ClearCase 
Microsoft Visual 
Studio.NET

■ Web server 

■ Install from CD-ROM: Select 
the server and client software 
option for the ClearCase LT 
server in the Client/Server 
page.

■ Create Release Area: Select 
Siteprep ClearCase Server in 
the Client/Server page.

ClearQuest 
Administration 
Tools

ClearQuest Administration Tools

ClearQuest 
MultiSite 
Administration 
Tools

ClearQuest MultiSite Administration 
Tools
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ClearQuest 
database

SQL Anywhere 
8.0.1

See Notes. ■ Do not select Rational 
ClearQuest in the Setup 
Wizard’s Product Selection 
page. Install SQL Anywhere as 
a separate product.

■ To install other vendor database 
software, read the vendor 
documentation. 

■ No ClearQuest features are 
required when you install the 
vendor database.

ClearQuest 
MultiSite

Rational 
Shipping 
Server

See Notes.

ClearQuest Web 
server used with 
IIS

ClearQuest ClearQuest Web

ManualTest Web 
Execution

■ Any Rational 
Suite

■ Robot
■ TeamTest
■ TestManager

Web Server Components > 
Rational ManualTest Web 
Execution

You do not have to install any 
other Rational testing product on 
the server. You can clear all the 
other features.

ProjectConsole 
software

Any Rational 
Suite

■ ProjectConsole > Web 
Server Components 
(includes Report Server 
and Data Collection Agent 
software)

■ ProjectConsole > Report 
Server and Data Collection 
Agent (Select this option if 
you want to configure 
additional Agents)

■ ProjectConsole > Template 
Builder

ProjectConsole is included in all 
Rational Suite editions. 

Table 13 Server Custom Setup in Rational Setup Wizard (continued)

To Install
Choose 
Product Custom Options Notes
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Specifying the Rational License Server

You can provide a Rational license server name in the Rational Setup Wizard if you 
are using floating licenses. You may provide the license server name if you plan to 
have users install from a release area or run a silent installation from the release area. 
If your product requires a license key and you do not provide the server name, users 
will see the Rational License Key Administrator (LKAD) launch at the end of the 
installation.

Installing Rational Products from the CD

This section describes a typical installation of a Rational product from the Rational 
Solutions for Windows CD. The Rational Setup Wizard Program guides you through the 
software installation. .

1 Log in as a user with Administrator rights on the local machine.

2 Insert the Rational Solutions for Windows Disc 1 into the computer’s CD-ROM drive. 

The Rational Setup Wizard starts automatically.

If autorun is disabled on your computer, click Start > Run and enter 
cd_drive: \Setup.exe where drive is the letter of the CD-ROM drive.

3 The Welcome page to the Rational Setup Wizard appears. Click Next to launch the 
installation, and to advance through the following screens.

4 The Product Selection page lists all products available for installation. Select the 
product you want to install.

5 Select the Desktop Installation from CD Image option in the Deployment Method 
page.

RequisitePro 
Database

RequisitePro ■ Database Setup
■ Sample Projects

If you are installing RequisitePro 
on a client, you do not need to 
install the Database Setup.

RequisiteWeb RequisitePro Web Server Components > 
Rational RequisiteWeb

Do not install RequisiteWeb on a 
computer that has JIntegra already 
installed.

Table 13 Server Custom Setup in Rational Setup Wizard (continued)

To Install
Choose 
Product Custom Options Notes
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6 If you are installing ClearCase LT, you will see the Client/Server page. The client 
software on the clients will not work until you have installed and configured the 
server (and client software).

❑ If you are installing and configuring the server software, select Install the server 
and client software. 

❑ If you are installing client software, select Install the client software only.

7 Choose to accept or not to accept the Rational Software license agreement in the 
License Agreement page. 

❑ If you accept the license agreement, the installation Wizard continues. 

❑ If you do not accept the license agreement, exit the Setup Wizard by clicking 
Cancel and then Finish. For information about changes to the computer, see 
Canceling a Product Installation on page 132.

8 On the Destination Folder page, specify the directory where you want to install the 
Rational product. If you want to modify the location, click Change.

Note:  The installation Wizard requires that all Rational products be installed in the 
same directory.

9 The Custom Setup page provides product feature options for the software 
installation. You can either accept the default typical features on the page or you 
can customize the installation. Refer to the table in Using the Custom Setup Page on 
page 116 for the product features that you want to install.

If you want to clear features or select new features, click Help.

Note:  For disk space requirements, see Have You Met the Prerequisites? on page 25. 
Do not use the number displayed in Custom Setup or the Space button on that 
page.

10 Depending on the product that you have selected, you will see one or more custom 
configuration pages in the wizard. Use the Help to provide instructions in this 
section of the configuration wizard.

❑ Enter the required information in each page of the wizard. (All required 
information displays in the left panel of the wizard with a red dot.) 

❑ To navigate through the pages, you can either click Next to see them 
sequentially or click on the page title in the left pane to access the page directly 
and nonsequentially.

When you complete the last page, click Done.

11 Click Install on the Ready to Install the Program page to begin the installation.
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12 A Restart Windows page appears if the Rational Setup Wizard needs to restart your 
computer. If files required for the installation are in use during the Rational Setup 
program and if the program needs to install shared components on your computer, 
the Setup Wizard may need to restart your computer. 

Select Restart or Don’t Restart. If you select Don’t Restart, the Wizard reminds you 
that the installation cannot complete until Windows restarts.

After Windows restarts, the second part of the installation process starts 
automatically after you log on. 

13 When the Setup Complete page appears, we recommend that you review the 
current information related to new features and known issues in the readme file. In 
addition, you can view the Rational Developer Network Web pages. Click Finish to 
complete the installation.

Creating a Release Area and Site Defaults File

A release area contains site defaults files and all the files that will be used in 
subsequent installations. For example, part of setting up a release area is to specify 
information, such as client software and license servers. This information is stored in a 
site defaults file and used when a Rational product, such as ClearCase LT or 
ClearQuest, is installed on clients.

There are two methods for creating site defaults files. Both methods create an on-disk 
image of product files in a shareable directory on the network. The first method 
creates a release area (Enterprise Deployment). The second method (Site Preparation 
Wizard) does not create a release area. You can also use these methods to install the 
product on your computer after creating a site defaults file.

■ Run the Rational Setup Wizard on the Rational Solutions for Windows CD-ROM. See 
Using the Setup Wizard to Create a Release Area and Site Defaults File on page 122 for 
more information.

■ Run the Site Preparation Wizard multiple times to create multiple site defaults 
files. See Running the Site Preparation Wizard to Create Multiple Sitedef Files on 
page 125 for more information.

Note:  Do not use the Enterprise Deployment option in the Rational Setup Wizard or 
the Site Preparation Wizard on Windows 9x computers. You cannot create a site 
defaults file or release area on Windows 9x systems.
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Using the Setup Wizard to Create a Release Area and Site Defaults File

This section explains how you can use the Rational Setup Wizard to create a release 
area and populate it with site defaults files. You can create a meaningful name for 
each site defaults file, such as CQdevelopers.dat. By default, the file is named sitedefs.dat 
if you do not specify a name for it. Do not name a file with an additional suffix, such 
as sitedefs.developers.dat. 

You can use this release area to install Rational servers. Client users can use this 
release area to install Rational products on their desktops. 

1 Make the release area directory shareable. Even if the drive containing that 
directory is already shareable, making the directory itself shareable makes it easier 
to find the product release area.

a In Windows Explorer, right-click the network release area to display the 
directory shortcut menu.

b Click Sharing. The Properties page appears.

c On the Sharing tab, click SHARE this folder and supply a meaningful share 
name, such as ClearQuest 6.0 Release Area.

Note:  The Setup Wizard creates a shortcut to the site defaults file only if the release 
area is created under a network share. The shortcut appears in the release area, for 
example, as sitedefs or CQdevelopers without the suffix .dat.

2 Log in as a user with Administrator rights on the local computer. 

3 Insert the Rational Solutions for Windows Disc 1 into the computer’s CD-ROM drive. 

The Rational Setup Wizard starts automatically.

If autorun is disabled on your computer, click Start > Run and enter 
cd_drive: \Setup.exe where drive is the letter of the CD-ROM drive.

The Rational Setup Wizard Program guides you through the software installation. 
Click Next to open the page.

4 The Product Selection page lists all products available for installation. Select the 
product that you want to create a release area for. Click Next.

5 Select the Enterprise Deployment option in the Deployment Method page. Click Next.

6 Depending on the product you have selected, you will see one or more custom 
configuration pages in the wizard. Use the Help to provide instructions in this 
section of the wizard.

Enter the required information in each page of the wizard. (All required 
information displays in the left panel of the wizard with a red dot.) 
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To navigate through the pages, you can either click Next to see them sequentially 
or click on the page title in the left pane to access the page directly and 
nonsequentially.

7 In the Completion pages, you are required to fill in the Description page and the 
Create a Release Area page. The Launch Installation is optional.

a In the Description page, enter a description for users. When you are done, click 
Next.

b In the Create a Release Area page, enter the release area location and filename 
for the site defaults file (*.dat) that will be created. 

Note:  Do not use multi-byte characters.

❑ If you want to install software on your computer based on the site defaults that 
you just entered, click Next to go to the Launch Installation page. Select Launch 
installation using these settings. You will save the site defaults information to a 
file and then proceed with the installation on your computer. Click Done and 
then Next.

Skip to Installing the Product on Your Computer on page 123 for the rest of the 
instructions. 

❑ If you only want to create a release area, click Done and then Next to create the 
site defaults file.

8 When the Setup Complete page appears, we recommend that you review the 
current information related to new features and known issues in the readme file. In 
addition, you can view the Rational Developer Network Web pages. Click Finish to 
complete the installation of the release area.

For more information about how to install products from this release area, see 
Installing Rational Products from a Release Area on page 125.

Installing the Product on Your Computer

When you create a release area, you have the option to install the product on your 
desktop. 

1 In the Launch Installation page, select Launch installation using these settings and 
then click Done and then Next. 

2 When the Rational Setup Wizard Completed page appears, click Finish to complete 
the installation of the release area.

3 When the installation begins, click Next. Choose to accept or not to accept the 
Rational Software license agreement in the License Agreement page. 

❑ If you accept the license agreement, the Setup Wizard continues. 
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❑ If you do not accept the license agreement, exit the Setup Wizard by clicking 
Cancel and then Finish. For information about changes to the computer, see 
Canceling a Product Installation on page 132.

4 Specify the Destination folder, and then click Next, or change the destination by 
clicking Change.

5 In the Site Default Configuration page, you will see the Release Area Description 
that you entered previously. Decide whether you want the site defaults that you 
set installed on your computer. Either click Use the standard configuration (These 
are site defaults that you set.) or I will create my own custom client configuration. 

❑ If you select I will create my own custom client configuration: 

➑ The Custom Setup page displays product features to select. For more 
information, see Using the Custom Setup Page on page 116.

Note:  For disk space requirements, see Have You Met the Prerequisites? on 
page 25. Do not use the number displayed in Custom Setup or the Space button 
on that page.

➑ When you click Next, you may change any of the existing site default values. 
(Any changes to the site default values apply only to this single installation.) 
After modifying the values, click Done and then click Install to begin the 
installation.

❑ If you select Use the standard configuration, then the features for the existing 
site default values will be used for the installation. Click Next and then click 
Install to begin the installation. 

6 A Restart Windows page appears if the Rational Setup Wizard needs to restart your 
computer. If files required for the installation are in use during the Rational Setup 
program and if the program needs to install shared components on your computer, 
the Setup Wizard may need to restart your computer. 

Select Restart or Don’t Restart. If you select Don’t Restart, the Wizard reminds you 
that the installation cannot complete until Windows restarts.

After Windows restarts, the second part of the installation process starts 
automatically after you log on. 

7 When the Setup Complete page appears, we recommend that you review the 
current information related to new features and known issues in the readme file. In 
addition, you can view the Rational Developer Network Web pages. Click Finish to 
complete the installation.
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Running the Site Preparation Wizard to Create Multiple Sitedef Files

In some cases, your site may require multiple site defaults files. For example, if two 
groups, say a database administrator’s group and a client user group, both use 
ClearQuest but need to work with different default settings (such as ClearQuest 
features), then you can create one site defaults file for each group.

To create multiple site defaults for a release area:

1 Create the initial release area by following the instructions in Using the Setup 
Wizard to Create a Release Area and Site Defaults File on page 122. Set up this area 
with the site-specific parameters relevant to the first group of users.

2 Select the site defaults file created in Step 1 (sitedefs.dat, for instance) as a starting 
point by clicking File > Open or typing the command siteprep.exe <sitedefs.dat>. The 
Rational Site Preparation Wizard displays the values set in sitedefs.dat. Keep the 
values that apply to both groups and change the ones according to the needs of the 
second group. 

Note:  If you double-click on siteprep.exe in the release area or use the command 
siteprep.exe without the site defaults filename, the Site Preparation Wizard 
launches without displaying the values set in the existing site defaults file.

3 Click File > Save as to save a new site defaults file. You are prompted to enter a file 
name and folder for the new site defaults file:

❑ If you started the site preparation on the command line and specified a 
file-name argument for the site defaults file, for example, sitedefs.dat, the Folder 
and File name boxes display this information. You could save the modified site 
defaults files with a new file name, for example sitedefs_cqclient.dat.

❑ If no file name was previously specified, the File name box is blank. Type a file 
name that does not currently exist in the release area. 

Note: If you enter the name of an existing site defaults file, a warning message 
appears. You can overwrite the existing file or specify a different file name to 
create a new site defaults file.

According to your needs, you may create additional site defaults files in this way.

Installing Rational Products from a Release Area

When users install Rational products from a release area designated by you, in most 
cases, they accept the defaults as presented on the installation screens. Users who do 
not want to accept the defaults should speak to you before they make changes.

Installing from a release area includes the following steps:
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1 Create one or more site defaults files in a release area using the Rational Setup 
Wizard or the Site Preparation Wizard. Give users the path to the site defaults file 
or have them click the shortcut to the site defaults file created by the Rational 
Setup Wizard. For instructions, see Using the Setup Wizard to Create a Release Area 
and Site Defaults File on page 122.

2 Users can then access the release area from the command line or click the shortcut. 
The command line or shortcut will launch the Setup Wizard on their desktops. The 
Setup Wizard will use the settings in the site defaults file to install the product.

3 To install products from a release area, users can use the standard configuration set 
by you or they can customize the standard client configuration for their desktops. 
For more information, see the following procedures.

Note:  If users type only siteprep.exe in the command window or click siteprep.exe, the 
Setup Wizard uses the settings in sitedefs.dat (the default site defaults file name). If 
there are other site defaults files, such as developers_cq.dat, that you would like them 
to use, tell them to specify developers_cq.dat or click the specific shortcut, developers_cq 
or developers_cq.link

If users click siteprep.exe (without specifying a site defaults file name) and there is no 
site defaults file called sitedefs.dat in the release area, the Site Preparation Wizard 
launches to create a new site defaults file.

Using a Standard Configuration

Before following these instructions, read the overview information in the previous 
paragraphs. You or your administrator must create a release area and a site defaults 
file before you can install a product from the release area. 

To install a default configuration from the release area:

1 Log on as a user with local administrator privileges.

2 To install a Rational product using the settings in a specific site defaults file, either 
specify the name of the site defaults file on the command line or click the 
associated site defaults shortcut in the release area. For example, to install 
ClearQuest using the settings in sitedefs_cqclient.dat, map a network drive from 
your computer to the shared release area. Then, 

❑ In the DOS Windows, use the cd command to navigate to the root directory of 
the release area. Then enter, for example, setup.exe sitedefs_cqclient.dat, or

❑ In Windows Explorer, expand the mapped drive and launch the shortcut, for 
example, sitedefs_cqclient.link or sitedefs_cqclient.

3 The Rational Setup Wizard guides you through the software installation. 
In each page, click Next to open the next page. Click Help for more information.
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❑ The License Agreement page displays the Rational Software license agreement. 
If you accept the license agreement and click Next, the installation continues. 

❑ If you do not accept it, the installation does not let you proceed further. Click 
Cancel and exit from the installation. You will not see any visible changes to the 
system. The program returns your system to the state it was in before you 
launched the Rational Setup Wizard.

Note:  If you do not have the correct version of Windows Installer software on 
your computer, the Rational Setup Wizard will install it for you. Canceling the 
installation does not remove the updated version of Windows Installer. In some 
cases, you may have to restart the computer. 

4 The Destination Folder page displays the default destination folder for the 
installation. Click Change to select a different destination folder for the installation. 
Click Next.

5 Click Use the standard configuration on the Site Default Configuration page. The 
default features for the product and the existing site default values will be used for 
the client installation. Click Next.

6 Click Install to begin the installation on your client desktop.

7 A Restart Windows page appears if the Rational Setup Wizard needs to restart your 
computer. If files required for the installation are in use during the Setup Wizard, 
and if the Wizard needs to install shared components on your computer, the Setup 
Wizard may need to restart your computer. 

Select Restart or Don’t Restart. If you select Don’t Restart, the Wizard reminds you 
that the installation cannot complete until Windows restarts.

After Windows restarts, the second part of the installation process starts 
automatically after you log on. 

8 When the Setup Complete page appears, we recommend that you review the 
current information related to new features and known issues in the readme file. In 
addition, you can view the Rational Developer Network Web pages. Click Finish to 
complete the installation.

Customizing Your Own Configuration

Before following these instructions, read the overview of installing a product from a 
release area in this section. You or your administrator must create a release area and a 
site defaults file before you can install a product from the release area. 

To customize a configuration for a specific computer:
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1 Log on as a user with local administrator privileges.

2 To install a Rational product using the settings in a specific site defaults file, either 
specify the name of the site defaults file on the command line or click the 
associated site defaults shortcut in the release area. For example, to install 
ClearQuest using the settings in sitedefs_cqclient.dat, map a network drive from 
your computer to the shared release area. Then, 

❑ In the DOS Window, use the cd command to navigate to the root directory of 
the release area. Then enter, for example, setup.exe sitedefs_cqclient.dat, or

❑ In Windows Explorer, expand the mapped drive and launch the shortcut, for 
example, sitedefs_cqclient.link or sitedefs_cqclient.

3 The Rational Setup Wizard runs and guides you through the software installation. 
In each page, click Next to open the next page. Click Help for more information.

4 The License Agreement page displays the Rational Software license agreement. 

❑ If you accept the license agreement and click Next, the installation continues. 

❑ If you do not accept it, the installation does not let you proceed further. Click 
Cancel and exit from the installation. You will not see any visible changes to the 
system. The program returns your system to the state it was in before you 
launched the Rational Setup Wizard.

Note:  If you do not have the correct version of Windows Installer software on 
your computer, the Rational Setup Wizard will install it for you. Canceling the 
installation does not remove the updated version of Windows Installer. In some 
cases, you may have to restart the computer. 

5 The Destination Folder page displays the default destination folder for the 
installation. If you want to select a different destination folder for the installation, 
click Change. 

6 Click I will create my own custom client configuration on the Site Default 
Configuration page.

❑ The Custom Setup page displays product features to select. For more 
information about features for your product, see Using the Custom Setup Page 
section in this chapter. 

Note:  For disk space requirements, see the System and Software Requirements 
table in the Before You Install chapter of this guide. Do not use the number 
displayed in Custom Setup or the Space button on that page.

❑ When you click Next, you may change any of the existing site default values. 
(Any changes to the site default values apply only to this single installation.) 
After modifying the values, click Done.

7 Click Install to begin the installation on your client desktop.
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8 A Restart Windows page appears if the Rational Setup Wizard needs to restart your 
computer. If files required for the installation are in use during the Setup Wizard 
and if the Wizard needs to install shared components on your computer, the Setup 
Wizard may need to restart your computer. 

Select Restart or Don’t Restart. If you select Don’t Restart, the Wizard reminds you 
that the installation cannot complete until Windows restarts.

After Windows restarts, the second part of the installation process starts 
automatically after you log on. 

9 When the Setup Complete page appears, we recommend that you review the 
current information related to new features and known issues in the readme file. In 
addition, you can view the Rational Developer Network Web pages. Click Finish to 
complete the installation.

Setting Up Silent Installations of Rational Products

Silent install is a method of installing Rational products on client computers without 
intervention from users. It greatly reduces the work of an administrator during a 
deployment. It also ensures that the correct software configuration is installed on each 
server and desktop.

This section describes how to set up and perform a silent installation. The basic steps, 
explained below, are:

1 Create a site defaults file and a release area on the network. Creating a release area 
is optional.

a Use the Enterprise Deployment option in the Rational Setup Wizard to create a 
site defaults file and a release area to deploy the product to your users. See 
Creating a Release Area and Site Defaults File on page 121 for the procedure.

Or use the Site Preparation Wizard by double-clicking siteprep.exe in the 
CD-ROM image (or run siteprep.exe on the command line) to create a site 
defaults file without the release area.

b You can customize site defaults files for different sets of users. For more 
information, see Running the Site Preparation Wizard to Create Multiple Sitedef 
Files on page 125.

2 Use the setup.exe /g command to start the Rational Setup Wizard and test the site 
defaults file. You should not see any installation screens displayed on your 
computer during the installation. (See Performing a Silent Installation on page 130 
for the full command.)
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The file directs the Rational Setup Wizard to install program files in a specific 
directory on your computer. If a restart is required, your computer restarts 
automatically. After the restart, you must log on manually. The installer then 
re-launches automatically and finishes. When the installation finishes, you do not 
see an installation complete screen. 

If you did not specify the license server in the site defaults file, you or your users 
may have to manually configure licensing after the Setup Wizard finishes.

3 Give users the following information so they can perform silent installations on 
their computers.

❑ Path to the site defaults file and the setup.exe executable in the release area or 
the shortcut to the site defaults file. (The shortcut will not have a .dat suffix.)

❑ Silent installation commands.

❑ Installation directory (where the Rational Setup Wizard will install the files on 
your desktop).

❑ License key information, if necessary.

❑ Ensure that users remove all Rational products from their desktops. Users who 
install silently do not see the message to remove previous versions of Rational 
products. The installation does not proceed until all products are removed. The 
message is saved in the user's installation log file. If the installation fails, direct 
users to the log file. For more information about this file, see Rational_Install Log 
on page 115.

Note:  For information about setup.exe command line parameters, see Command Line 
Syntax on page 133 or type setup / ?.

Performing a Silent Installation

After you have created the site defaults file, test it with the following commands:

<local drive>:\setup.exe /g <C:\sitedefs.dat>

Where <local drive>:\ is a mapped drive or path to setup.exe. There is a space 
between setup.exe and command /g and a space between /g and the path to the 
sitedefs.dat file which is C:\:sitedefs.dat.

Note:  You must specify the absolute pathnames to both setup.exe and <sitedefs.dat> 
when you perform a silent installation, unless you have mapped the files to a disk 
drive on your computer.

By default, the installation log file (rational_install.log) is created in your computer 
TEMP directory. To find the Temp directory, open a command prompt and type echo 
%TEMP%. The location of the directory depends on the system environment variable 
set on the computer. 
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Canceling a Silent Installation

There is no command to cancel a silent installation.

Using the Command Line to Remove a Product

To remove a Rational product in the current releases (2003.06.00), use the following 
commands. These commands will not remove earlier versions of Rational products.

<local drive>:\msiexec.exe /X <path to product>.msi /qn

Where <local drive>:\ is a mapped drive or path to msiexec.exe. The variable <path to 
product>.msi, such as ClearQuest.msi, is the path to the MSI file in your 
network-wide release area used by ClearQuest, for example, during installation. In 
the release area, that MSI file exists in the Setup directory. The command /x 
indicates an uninstall operation and /qn indicates no user interfaces are displayed 
during the uninstall operation.

Note:  You must specify the absolute pathnames to both msiexec.exe and <path to 
product>.msi when you perform a silent uninstall, unless you have mapped the files 
to a disk drive on your computer.

For more information about the msiexec.exe command, and associated command line 
options, see the Microsoft Windows Installer Platform Software Developer’s Kit 
documentation at http://www.microsoft.com/windows/reskits/webresources/default.asp.

Post-Installation Tasks

The following sections apply to all deployment types.

Licensing

If you do not see the License Key Administrator (LKAD) launch at the end of the 
installation, your product is either licensed or does not require a license. Skip to 
Canceling a Product Installation on page 132. 

You or your users may see the License Key Administrator (LKAD) launch at the end 
of a product installation for the following reasons:

Table 14 LKAD Launch

Deployment Type Reason

Desktop installation from CD 
image

■ You did not provide a Rational license server name in the 
Rational Setup Wizard, or

■ The product requires a node-locked license key.
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If you see the LKAD, you or your users must perform the following tasks to license 
the product.

Canceling a Product Installation

If you click Cancel any time during the installation procedure or before the 
installation completes, you will not see any visible changes to the system. The 
program returns your system to the state it was in before you launched the Rational 
Setup Wizard.

Note:  If you do not have the correct version of Windows Installer software on your 
computer, the Rational Setup Wizard will install it for you. Canceling the installation 
does not remove the updated version of Windows Installer. In some cases, you may 
have to restart the computer. 

Install from a Release Area 
(Enterprise Deployment)

■ You did not provide a Rational license server name when 
you created the site defaults file, or

■ The product requires a node-locked license key.

Silent Installation ■ You did not provide a Rational license server name when 
you created the site defaults file, or

■ The product requires a node-locked license key.

Table 15 LKAD Tasks

To Configure Task See

Floating License Key Enter the name of the 
Rational license server 
in the LKAD.

■ Rational Software License Management 
Guide, or

■ LKAD Help

Node-Locked License 
Key

Import the 
node-locked license 
key in the LKAD.

■ Rational Software License Management 
Guide, or

■ LKAD Help

Table 14 LKAD Launch (continued)

Deployment Type Reason
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Reinstalling a Product (Modify or Repair)

If you have sucessfully completed a previous installation of a Rational product in 
version 2003.06.00, you can modify or repair the installation by using Add or Remove 
Programs.

To remove the Rational product, see the chapter Removing Rational Products.

1 Log in as a user with Administrator rights on the local computer on which you 
want to install the product.

2 Click Start > Settings > Control Panel > Add or Remove Programs.

3 Highlight the Rational product and click Change.

❑ Modify the Existing Installation – Choosing this option enables you to change 
which products and product features are installed. The Setup Wizard provides 
the Custom Setup page for you to clear or select features. For example, you 
included the ClearQuest Multisite Administration Tools in your ClearQuest client 
installation. To reinstall the ClearQuest client, clear this product feature in the 
Custom Setup page and reinstall the ClearQuest client.

Click Modify and then click Next to select or clear features in the Custom Setup 
page. Click Next and then click Install to begin the installation.

❑ Repair the Existing Installation – Choosing this option enables you to repair a 
damaged registry or replace files that you may have inadvertently deleted. This 
option does not repair incomplete or unsuccessful installations.

To begin the repair, click Repair and then click Next and then click Install. At the 
end of the operation, the status of the repair is displayed.

Command Line Syntax

This section provides the syntax for setup.exe.

Table 16 Command Line Syntax

Setup.exe Command Parameter Description

setup Executes the Rational Setup Wizard

<local drive> Specifies path to setup.exe.

/g Executes the silent install session.

<path to sitedefs.dat> Specifies the path to the site defaults file.

msiexec.exe /x Executes the silent uninstall session.
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For example, to create a site defaults file, enter on the command line:

<local drive>:\setup <path to sitedefs.dat

Rational Setup Wizard Warnings or Blocks

If you encounter blocks or warnings during the installation procedure, consult the 
following table if you do not remember the entire message.

/qn Indicates no user interfaces are displayed during the 
operation.

<path to product>.msi Specifies path to product’s MSI file. The MSI file is 
used by ClearQuest, for example, during 
installation. The MSI file exists in the Setup 
directory in the release area.

/l Specifies the name and location of the install log file. 
By default, the log of installation activities called 
Rational_install.log is in the TEMP directory.

Table 16 Command Line Syntax (continued)

Setup.exe Command Parameter Description

Table 17 Warnings and Blocks

Warning/Block Solution

You are attempting to install on an 
unsupported operating system. 

We recommend that you install on a supported 
operating system. Your Rational product's 
Release Notes for a complete list of supported 
operating systems and service packs.

You are attempting to install on a system with 
an unsupported browser. 

See your Rational product's Release Notes for a 
complete list of supported browsers before 
using Rational Unified Process, ProjectConsole, 
Rose, Web Publisher, and XDE Web Publisher.

You are attempting to install on a system that 
has an version of Office that is not compatible 
with SiteCheck.

See your Rational product's Release Notes for a 
complete list of supported versions.

You are attempting to install on an 
unsupported version of WebSphere Studio.

It is recommended that you utilize a supported 
version. Please refer to the Release Notes for 
the complete list of supported operating 
systems.
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Applying Service Releases

Here are the basic steps for obtaining a Rational service release:

1 Install the Rational Download Manager client software on your computer. 

There are two sources from which you can download the Rational Download 
Manager installer.

❑ From the Rational Solutions for Windows Disc 2. Locate the Rational Download 
Manager setup.exe and Readme.html in the Rational Extras folder. The 
Readme.html contains the installation procedure.

❑ From the Rational Download Center at 
www.rational.com/support/downloadcenter/about_dlm.jsp. You must either login or 
register as a member before you can download the software.

You can either save the file to a local drive on your computer or install Rational 
Download Manager directly from the Rational Download Center by clicking Open 
in the File Download dialog box.

2 Use your browser to go to: www.rational.com/docs/v2003/readme_v2003.html for 
service release documentation. The documentation provides service release 
features, restrictions, and instructions.

3 Use the Rational Download Manager to download the service release mechanism 
from this web site.

4 Install the Rational service release.

MDAC and ODBC If the correct MDAC and ODBC drivers are not 
installed on your computer, the Setup Wizard 
installs version 2.7 of the Microsoft Data Access 
Components (MDAC) and Open Database 
Connectivity (ODBC) drivers. For more 
information, read Microsoft Knowledge Base 
Article 216149.

Table 17 Warnings and Blocks (continued)

Warning/Block Solution
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5Removing Rational 
Products
This chapter describes how to remove Rational products from your servers. For 
information about removing desktop or client products, see the Installation Guide for 
Rational Desktop Products.

Before You Remove Rational Software

This section provides general requirements for removing Rational server products. It 
also describes which components the Rational Setup Wizard does or does not remove 
from the computer.

■ If you plan to move the application to another system, first return the license key 
file to your Rational Software account. To return a node-locked or floating license 
key, use Rational AccountLink (www.rational.com/accountlink), the online license 
management tool. For more information about moving licenses or returning 
licenses, see the Rational Software License Management Guide.

■ Removing a Rational product does not delete the license key file, project databases, 
and other files that you created while using the product. If you plan to install an 
upgrade of the Rational product to a different drive or use a new installation path, 
back up these files and manually remove them. If you do not remove them, the 
Rational Setup Wizard may find these files and install the application in the old 
location instead of the new location.

■ Before removing the Rational products (including the Rational license server) from 
clients, record the specified license serve hostname(s) in the Rational License Key 
Administrator (LKAD). 

a Launch the LKAD from Start > Programs > Rational Software > Rational License 
Key Administrator. 

b Find the hostname(s) in Settings > Client/Server Configuration. 

c After you install the new Rational products, reset the license server name in the 
(LKAD). The LKAD Wizard should launch after the installation. If the Wizard 
does not launch, use Start > Programs > Rational Software > Rational License Key 
Administrator.
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■ Removing ClearCase LT does not remove ClearCase LT data from the computer. If 
you reinstall ClearCase LT on the same computer, you must install ClearCase LT to 
the same directory to see the old data.

■ To remove Rational Software products from a Windows NT, 2000, or XP computer, 
you must have Windows administrator privileges on the local system.

■ Make sure that no one is using the application or any associated files. You cannot 
remove files that are in use.

Before You Remove ClearCase Data from the ClearCase LT Server

You should never remove ClearCase data from a computer unless that data was used 
for purposes of evaluation only and you have no intention of saving it or using it in a 
production capacity.

To completely remove ClearCase data from the ClearCase LT server, take the 
following steps before you remove ClearCase LT:

1 Use the ClearCase Administration Console or the cleartool lsvob command to 
locate all VOBs on the ClearCase LT server. Then use the ClearCase 
Administration Console or the cleartool rmvob command to remove the VOBs.

2 Use the ClearCase Administration Console or the cleartool lsview command to 
locate all views. Then use the ClearCase Administration Console or the cleartool 
rmview command to remove the views.

3 Use the ClearCase Administration Console or the cleartool lsstgloc command to 
locate all server storage locations on the ClearCase LT server. Then use the 
ClearCase Administration Console or the cleartool rmstgloc command to remove 
the storage locations.

4 To remove registry values, use regedit to remove these lines:

HKLM\Software\Atria\ClearCase\CurrentVersion\ServerSetupComplete

HKLM\Software\Atria\ClearCase\CurrentVersion\CredmapAllowedDomainList

5 Delete the ClearCase/var directory from the installation directory.

Before You Remove Rational RequisiteWeb

RequisiteWeb installs a new project catalog containing paths to new sample projects. 
Be sure to make a copy of your existing catalog.txt file before removing RequisiteWeb. 
If you are upgrading from an earlier release of RequisiteWeb, the catalog.txt file 
should be located in the following default directory: C:\Program 
Files\Rational\RequisitePro\ReqWeb\Projects
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Add your previous catalog.txt entries to the new catalog file that is installed with the 
new version of RequisiteWeb in the default directory: 
C:\Program Files\Rational\RequisitePro\ReqWeb\Projects

Note:  Your existing webapps2 directory will be deleted when you remove 
RequisiteWeb. To preserve your configuration files or any other files in your 
webapps2 directory, you must relocate those files before removing RequisiteWeb.

For more information, see Managing RequisitePro Projects for RequisiteWeb on page 197.

Removing Rational Software

Use the Windows Add or Remove Programs control panel to select and remove the 
Rational product. Click Start > Settings > Control Panel > Add or Remove Programs. 
Highlight the product and click Remove.

To remove data and additional software for RequisiteWeb, see 

■ Removing RequisiteWeb 2003.06.00 on page 139.

■ Removing RequisiteWeb 2002.05.X on page 139.

■ Removing RequisiteWeb 2001A on page 142.

Removing RequisiteWeb 2003.06.00

1 Use the Add/Remove Programs function in the Windows Control Panel to select 
and remove RequisiteWeb.

2 Using dcomcnfg, remove the Local Administrators Group from "Default launch 
permissions" and "Default access permissions".

3 If ReqWebUser is no longer in use, remove this user.

4 RequisitePro project data, backup files, and log files may still exist on the server. 
The log files will be located at C:\Program Files\Rational\common\rwp\logs\.

Removing RequisiteWeb 2002.05.X

To remove RequisiteWeb from a Windows NT or Windows 2000 server, you must 
have Windows administrator privileges on that computer. Use the following 
instructions to:

■ Delete the ReqWeb and Jakarta virtual directories

■ Remove the Jakarta ISAPI Filter

■ Restart the IIS Admin Service
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■ Remove the RequisiteWeb program files

Note:  To remove RequisiteWeb 2001A, see Removing RequisiteWeb 2001A on page 142.

Deleting the ReqWeb and Jakarta Virtual Directories

1 Launch the Internet Services Manager by doing one of the following:

❑ Click Start > Run, and type inetmgr. Click OK.

❑ In Windows NT 4.0, click Start > Programs > Windows NT 4.0 Option Pack > 
Microsoft Internet Information Server > Internet Service Manager.

❑ In Windows 2000 Server, click Start > Programs > Administrative Tools/Internet 
Services Manager.

2 Select the Default Web Site and click the Stop button on the toolbar.

3 Right-click the ReqWeb virtual directory and select Delete.

4 Right-click the Jakarta virtual directory and select Delete. Leave the Internet 
Services Manager open.

Removing the Jakarta ISAPI Filter

1 Right-click the Default Web Site and select Properties. The Default Web Site 
Properties dialog box appears. Click the ISAPI Filters tab and select the jakarta filter.

2 Click Remove and then click OK to close the dialog box.
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Restarting the IIS Admin Service

Perform the tasks in the following table. Refer to the column that corresponds to your 
operating system.

Removing the RequisiteWeb Program

After using Add/Remove Programs in the Windows Control Panel to remove 
RequisitePro and the uninstall process is complete (including restarting the server), 
check to see if the C:\Program Files\Rational\RequisitePro\ReqWeb directory is still present 
on the server. If so, delete the ReqWeb directory and its subdirectories. You must also 
perform the following steps to edit your System Variables: 

1 On the start menu, click Settings > Control Panel. In the Control Panel, double-click 
the System icon. The System Properties dialog box appears.

2 Do one of the following:

❑ In Windows 2000, at the Advanced tab, click Environment Variables.

❑ In Windows NT, click the Environment tab.

Locate the PATH system variable and remove the following from your PATH 
directory:

C:\Program Files\Rational\common\java\jre\bin

Step Windows NT 4.0 Windows 2000

1 Close the Internet Service Manager. In the Internet Services Manager, 
right-click the server name.

2 At the Start/Run command line, type 
cmd. 

Select Restart IIS.

3 In the MS-DOS window, type the 
following:
net stop w3svc 
net start w3svc 

At the Stop/Start/Reboot dialog box, 
select Restart Internet Services on 
<server name>.

4 Type exit to close the MS-DOS window. Click OK to close the dialog box.

Close the Internet Services Manager.
Removing Rational Products 141



Removing RequisiteWeb 2001A

To remove RequisiteWeb from a Windows NT or Windows 2000 server, you must 
have Windows administrator privileges on that machine. Use the following 
instructions to:

■ Stop and remove the RqTomcat Service

■ Remove the ReqWeb and Jakarta virtual directories

■ Remove RequisiteWeb 2001A

■ Remove the Tomcat_Home and Java_Home system variables

Stop and Remove the RqTomcat Service

After you stop the RqTomcat service you must perform the following steps to remove 
the service from your system:

1 Open an MS-DOS shell and navigate to the following directory: 

C:\ProgramFiles\Rational\jakarta-tomcat\bin

2 Type the following at the MS-DOS prompt:

jk_nt_service -R RqTomcat

3 Close the MS-DOS shell

Step Windows NT 4.0 Windows 2000

1 Go to Start > Settings > Control Panel > 
Services.

Go to Start > Settings > Control Panel > 
Administrative Tools > Services.

2 Locate and select the RqTomcat service. Locate the RqTomcat service and 
double-click the icon to display the 
Properties dialog box.

3 In the Services window, click the Stop 
button.

On the General tab under Service status, 
click the Stop button. Click OK and close 
the Services window.

4 Click Close to finish. Click OK to close the dialog box.

Close the Internet Services Manager.
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Remove the ReqWeb and Jakarta Virtual Directories

1 Launch the Internet Services Manager by doing one of the following:

❑ In Windows NT 4.0, click Start > Programs > Windows NT 4.0 Option Pack > 
Microsoft Internet Information Server > Internet Service Manager.

❑ In Windows 2000 Server, click Start > Programs > Administrative Tools > Internet 
Services Manager.

2 Under the Default Web Site, locate the ReqWeb and Jakarta virtual directories. 
Right-click each of the directories and select delete.

3 Right-click the Default Web Site and select Properties.

4 At the ISAPI Filters tab, locate the jakarta filter. Right-click the jakarta filter and 
select delete. 

5 Click OK and close the Internet Services Manager.

Remove RequisiteWeb 2001A

After using Add/Remove Programs in the Windows Control Panel to remove 
RequisitePro and the uninstall process is complete (including restart the server), check 
to see if the following directories are still present on the server:

C:\Program Files\Rational\RequisitePro

C:\Program Files\Rational\jakarta-tomcat

If so, delete both directories and their subdirectories.

Remove the Tomcat_Home and Java_Home System Variables

1 On the start menu, click Settings > Control Panel. In the Control Panel, 
double-click the System icon. The System Properties dialog box appears.

2 Do one of the following:

❑ In Windows 2000, at the Advanced tab, click Environment Variables.

❑ In Windows NT, click the Environment tab.

3 Locate the TOMCAT_HOME and JAVA_HOME system variables and delete them 
from your system.

Note:  Restore back up projects and your catalog.txt file to their original locations.
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6Upgrading Desktop 
Systems
This chapter describes how to upgrade a desktop system.

Before the Upgrade

Before you upgrade, perform the following tasks:

1 Get the go-ahead from your administrator or project leader.

In your network installation of Rational products, most of the work of upgrading 
to a new version occurs on servers and administrative systems. Therefore, before 
you upgrade to a new version, make sure that your administrator has performed 
all prerequisite tasks. 

2 Gather the following information from your administrator or project leader:

Type of installation to perform:

______________________________________________________________

Location of installation and other installation details:

______________________________________________________________

If you use floating licenses, the location of your license server:

______________________________________________________________

If you use ClearQuest, the location of the ClearQuest profile:

______________________________________________________________

If your team works with a Rational project, the location of your project or projects:

______________________________________________________________

Locations of new Web servers for RequisiteWeb, ProjectConsole, or ClearCase 
Web:

______________________________________________________________

3 Uninstall any Rational products from an earlier version.

In the Control Panel, use the Add or Remove Programs tool to remove all earlier 
Rational software on your system. If more than one Rational product is installed 
on your computer, run this tool again until all older products are removed.
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Upgrading to the New Version

Using the information you have gathered, install the new version of Rational products 
on your desktop. 

After the Upgrade

After the installation completes, perform these steps, referring to the information you 
gathered in the first part of this chapter:

1 If you use floating licenses and your computer does not have licensing configured, 
the License Key Administrator wizard appears. If you use a floating license, click 
Point to a Rational License server to get my licenses, and follow the instructions.

2 If you use ClearQuest, reconnect to the ClearQuest databases: 

a Start the ClearQuest Maintenance tool: click Start > Programs > Rational 
Software > Rational ClearQuest > Rational ClearQuest Maintenance Tool.

b Click File > Import Profile and provide the name of the ClearQuest profile. 

3 If you work with Rational projects:

a Start the Rational Administrator: click Start > Programs > Rational Software > 
Rational Administrator.

b For each Rational project you work with, click File > Register Project, and 
supply the path to the project.

4 Redirect your Web browser to new Web servers for RequisiteWeb, ProjectConsole, 
and ClearCase Web. 

5 Wait for your administrator to notify you that the upgrade is complete.

You are now ready to use Version 2003 of Rational products. 
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