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Preface
This manual provides an overview of the typical tasks that an administrator needs to 
perform to set up and maintain a Rational Suite environment. This manual describes 
some topics in more detail and provides pointers to other resources.

Audience

This guide is intended for Rational Suite administrators.

Other Resources

■ All manuals are available online, either in HTML or PDF format. The online 
manuals are on the Rational Solutions for Windows Online Documentation CD. 

■ To send feedback about documentation for Rational products, please send e-mail 
to techpubs@rational.com.

■ For more information about Rational Software technical publications, see: 
http://www.rational.com/documentation. 

■ For more information on training opportunities, see the Rational University Web 
site: http://www.rational.com/university.

■ For articles, discussion forums, and Web-based training courses on developing 
software with Rational Suite products, join the Rational Developer Network by 
selecting Start > Programs > Rational Suite > Logon to the Rational Developer 
Network.
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Contacting Rational Customer Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Customer Support as follows:

Note:  When you contact Rational Customer Support, please be prepared to supply the 
following information:

■ Your name, company name, telephone number, and e-mail address

■ Your operating system, version number, and any service packs or patches you 
have applied

■ Product name and release number

■ Your Service Request (SR) number (if you are following up on a previously 
reported problem)

Your Location Telephone Facsimile E-mail

North America (800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com 

Europe, Middle 
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4546-201
Netherlands

support@europe.rational.com 

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com 
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1Setting Up a Rational 
Suite Environment
This chapter describes tasks to perform to set up a Rational Suite environment when 
you are installing Rational Suite for the first time on your network.

These tasks include the following:

■ Plan network resources.
■ Configure licenses.
■ Install Rational Suite software on servers.
■ Configure servers and files.
■ Configure integrations.
■ Install Rational Suite software on clients.

For information about upgrading Rational Suite, see the Rational Suite Upgrade Guide.

Plan Network Resources

During planning, you work in these areas, as described in this section:

■ Planning for UCM (Unified Change Management).
■ Designating servers.
■ Developing a database plan.
■ Configuring databases.
■ Configuring security.

Planning for UCM

Unified Change Management is the Rational Software process of managing change in 
software development from requirements to release. Configuring a network to work 
with UCM requires special considerations. If you plan to use UCM to store Rational 
assets, see Using Unified Change Management with Rational Suite.
13



Designating Servers

Before you install Rational Suite, you need to determine which computers you will 
use as servers. Servers need to be highly available, and may need extra memory and 
disk space. Table 1 describes types of servers you may want to include in your 
environment. Note that you may be able to combine several servers on one computer.

Developing a Database Plan

For each Suite product you are using, you need to decide which database 
management system to use with Rational Suite.  Table 2 summarizes choices based on 
the size of the user group planned for each product. 

Table 1 Servers Used with Rational Suite

Type of Server Description

License server If you use floating licenses, you need to set up a server to administer 
the licenses. For more information, see the Rational Suite License 
Management Guide.

Web server Some Rational tools include a Web component. You can set up a Web 
server for these tools:
■ ClearCase LT. 
■ ClearQuest. 
■ RequisitePro. 
■ ProjectConsole.

For more information, see the Rational Software Server Products 
Installation Guide.

Database server If you are using commercial databases with Rational Suite products, 
we recommend that you install those databases on dedicated servers. 
See Developing a Database Plan on page 14.

ClearCase LT server ClearCase LT is a client/server product. To use a ClearCase LT client, 
a ClearCase LT server must be installed in the same network domain 
as the clients. A client can work with exactly one server. For 
guidelines about selecting a ClearCase LT server system, see the 
Rational Software Server Products Installation Guide.

ClearQuest 
administrator’s system

To use ClearQuest, you need to designate one computer as the 
administrator’s system. See the Rational Software Server Products 
Installation Guide.
14 Rational Suite Administrator’s Guide



The number of concurrent users is determined by the total number of current users 
accessing the database or schema.

Database performance depends on factors such as: number of users, network 
response time, number of records in the database, and database tuning. Refer to 
product documentation for more details about each choice.

When you use Oracle or SQL Server to store RequisitePro projects, you may include 
multiple projects within one Oracle schema or SQL Server database.

Microsoft Access Runtime is automatically installed when you install at least one 
Rational Suite product on your computer. (The Access development environment is 
not installed.) Also, Sybase SQL Anywhere is available on the product CD, but it is 
configured to work only with Rational products. SQL Anywhere is not installed 
automatically and must be installed separately from Rational Suite.

The Rational Software Server Products Installation Guide, included with your Rational 
Suite media kit, provides an overview of the installation, configuration, and 
administration of different database management systems, particularly for use with 
ClearQuest.

Table 2 Commercial Database Choices

Rational 
ClearQuest

Rational 
RequisitePro

Rational Test ProjectConsole

Microsoft 
Access

Fewer than 5 
concurrent 
users

5 or fewer 
concurrent users 
per RequisitePro 
project

No more than 
one concurrent 
user

Fewer than 5 
concurrent 
users

Sybase SQL 
Anywhere 
Server

5 to 20 
concurrent 
users

N/A One or more 
concurrent 
users

5 to 20 
concurrent 
users

Microsoft SQL 
Server

More than 20 
concurrent 
users

6 or more 
concurrent users 
per database

N/A More than 20 
concurrent 
users

Oracle
More than 20 
concurrent 
users

6 or more 
concurrent users 
per schema

N/A More than 20 
concurrent 
users

IBM DB2
More than 20 
concurrent 
users

N/A N/A More than 20 
concurrent 
users
Chapter 1 - Setting Up a Rational Suite Environment 15



Configuring Databases

For Rational products that work with commercial databases, install and configure 
those databases before installing Rational products. 

Configuring Security

You set security for some Rational Suite products by using the Rational Administrator 
to set up authorization for users and groups. You set security parameters through 
individual point products for other products. 

Table 3 provides an overview of how to set up security in each Rational tool.

Configuring Licenses

Rational Suite uses Rational Common Licensing Services. Before installing Rational 
software, decide what types of licenses you want to use and, if necessary, configure 
licenses for the software you will install. For more information about licensing, see 
Rational Suite License Management Guide, included with your Rational Suite media kit.

Installing Rational Suite Software on Servers

Use the Rational Software Setup program to install Rational Suite on your network 
servers. The Rational Software Setup program allows you to install Rational Suite and 
other Rational Software products.

You can use the Setup program to perform a standard install or a silent install.

Table 3 Summary: Setting Up Security for Rational Tools

Tool Comments

Rational ClearQuest The ClearQuest administrator uses the ClearQuest Designer to set up 
user and group access to the ClearQuest database. See Rational 
ClearQuest Administrator’s Guide.

Rational 
RequisitePro

The RequisitePro administrator sets up RequisitePro users and groups 
by setting project security for the RequisitePro database. See Rational 
RequisitePro User’s Guide.

Rational Rose Rational Rose does not support user lists. To set security for Rose, 
secure the directory containing the Rose models.

Rational Test Use the Rational Administrator to add users and groups to the test 
datastore. See Managing Test Users and Groups on page 45.

Rational Project Supply an optional password to secure the Rational project. See 
Creating the Rational Project on page 28.
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For assistance while using the program, see the Rational Windows Setup Help.

Installing Rational ClearCase LT 

To use ClearCase LT, you must:

■ Install ClearCase LT server on the computer before installing Rational Suite.

■ Install ClearCase LT server before you install ClearCase LT clients. This enables 
you to specify the server name during client install, rather than having to 
configure a pointer to the server at a later time.

Configuring Servers and Files

After you install Rational software, perform other tasks to configure the servers, 
including Web servers, and files that you will use with Rational tools. Table 1 on 
page 14 lists the types of servers that you may need to configure. The Rational Software 
Server Products Installation Guide provides an overview of procedures to follow after 
you install Rational software. 

Configuring Integrations

Configure integrations that you plan to use, as described in Table 4.

Table 4 Rational Suite Integrations

Integration Comments

Rational project A Rational project associates datastores from Rational products, 
enabling integrations across Rational Suite. For an overview, see 
Creating the Rational Project on page 27.

UCM UCM is a process related to configuration management. Tool 
support for UCM is included in Rational ClearCase and Rational 
ClearQuest. See Using Unified Change Management with Rational Suite.

UCM and ClearQuest To learn about requirements for adding ClearQuest to a 
UCM-enabled project, see the “Enabling ClearQuest for UCM” 
chapter in Rational ClearQuest Administrator’s Guide. 

RequisitePro and 
ClearQuest

This integration allows you to link defect and enhancement requests 
to requirements, allowing you to trace back to a report’s origin. See 
Configuring the Integration for ClearQuest and RequisitePro on page 51.

Integrations with 
ClearQuest

To learn about configuring integrations that work with ClearQuest, 
see the “ClearQuest Schemas and Packages” chapter in Rational 
ClearQuest Administrator’s Guide.
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Installing Rational Suite Software on Client Computers

After you set up the server environment for Rational Suite, you can install Rational 
software on client computers. The Rational Software Server Products Installation Guide 
contains more information, including information about prerequisites, how to install 
on a client computer, and activities to perform after you install.

Extended Help Extended Help, available from all Rational Suite tools, allows you to 
view relevant topics in the Rational Unified Process, depending on 
the context from which you start. You can also customize Extended 
Help to include information relevant to your team. See your 
application’s online Help.

Integrations with 
RequisitePro

To learn about configuring integrations that work with RequisitePro, 
see the “Integrating with Other Products” chapter in Rational 
RequisitePro User’s Guide.

Table 4 Rational Suite Integrations (continued)

Integration Comments
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2Understanding a Rational 
Project
This chapter provides information about Rational projects so you can work with them 
more effectively. This chapter helps you understand:

■ The structure of a Rational project 

■ Unified Change Management (UCM) in the context of a Rational project

■ The Rational Suite artifacts that can be associated with a project, and the artifacts’ 
relationship to the Rational project

What Is a Rational Project?

A Rational project is a logical collection of databases and datastores that associates the 
data you use when working with Rational Suite. This collection of data resides in a 
Rational project (.rsp) file, with a name of your choice (for example, project.rsp). A 
Rational project consists of the following artifacts:

■ Zero or one RequisitePro project
■ Zero or one Rational Test datastore 
■ Zero or one ClearQuest database
■ Unlimited Rose model files

About the Rational Administrator

You use the Rational Administrator to manage your Rational Suite environment. The 
Rational Administrator is a tool for managing associations (or pointers) between 
Rational artifacts such as test datastores, Requisite Pro projects, and Rose models.

You can use the Rational Administrator to:

■ Create and manage a Rational project, which is a subset of associations between 
Rational Suite artifacts. 

■ Create and maintain users and groups.

■ Upgrade project assets in Requisite Pro databases and test datastores.

■ Enable a Rational project for use with Unified Change Management (UCM).
19



Why Work with Rational Projects?

Creating a Rational project allows you to take advantage of many of the integrations 
among Rational Suite tools. For example: 

■ From the Test Log window of the Rational Test Manager, you can generate a defect 
in ClearQuest.

■ You can associate RequisitePro requirements with Rational test datastores.

■ You can associate Rose data models with RequisitePro requirements through all 
iterations of the model design.

■ By associating a ClearQuest and RequisitePro database, you can tie defects to the 
requirements from which they originate.

What Is UCM?

Unified Change Management (UCM) is the Rational Software process of managing 
change in software system development from requirements to release. UCM spans the 
development lifecycle, defining how to manage change to requirements, design 
models, documentation, components, test cases, and source code.

UCM is unique because it links activities used to plan and track project progress with 
the artifacts that are undergoing change. An activity might arise from an issue raised 
in a meeting, a defect entered into a defect database, or a request for enhancement 
sent in by a customer. 

Many development teams use UCM to manage change to source code. You can also 
use UCM to manage change to these elements of a Rational project: RequisitePro 
projects, Rational test datastores, and Rose model files.

You use the Rational Administrator to enable UCM to work with a Rational project; 
for complete information on using UCM with Rational Suite, see Using Unified Change 
Management with Rational Suite.

Understanding Rational Projects and Related Artifacts

This section describes each type of artifact you can associate with a Rational project 
and its relationship to the Rational project.

RequisitePro Projects

Using a Rational RequisitePro project, you can organize, prioritize, track, and control 
changing requirements. You can manage all of your software development project’s 
requirements — user requirements, software specifications, and use cases — using the 
RequisitePro database as a central repository. 
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You itemize requirements within requirements documents, and then manage them 
using an integrated database. Each RequisitePro project consists of requirements 
documents and a dynamically-linked RequisitePro database. Your teams can 
collaborate, communicate, and provide updates on the same project. A RequisitePro 
project document can store text, graphics, or other objects (such as OLE objects) that 
identify project needs and are meaningful to users.

There can be several RequisitePro projects within one RequisitePro database, each one 
associated with a separate Rational project. 

There can be only one Rational project associated with each RequisitePro project. If a 
RequisitePro project is associated with a Rational project, and you associate the same 
RequisitePro project with another Rational project, the association with the first 
Rational project will be removed.

Figure 1 shows the relationship of RequisitePro Projects to Rational Projects. 

Figure 1 The Relationship of RequisitePro Projects to Rational Projects

Read about setting up RequisitePro in the Rational Software Server Products Installation 
Guide. Read about using RequisitePro in Rational RequisitePro User’s Guide. 

Test Datastores

A Rational test datastore is a collection of related test assets including test scripts, 
suites, datapools, logs, reports, test plans, and build information. 

RequisitePro
Database

RequisitePro RequisitePro

RequisitePro

Project Project

Project

Rational Rational Rational

Project Project Project
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Team members often want to test and report on the work involved in a project 
through the same shared resources, for example, the same test datastore or the same 
ClearQuest defect database. There can be only one test datastore for each Rational 
Project.

Each test artifact in a test datastore can be associated with at most one RequisitePro 
project. However, a test datastore can contain artifacts that point to different 
RequisitePro projects. So, for example, you can associate requirements from many 
RequisitePro projects with test cases in the same test datastore.

Figure 2 shows the relationship between a test datastore and a Rational project. 

Figure 2 Relationship Between a Test Datastore and a Rational Project

See Rational TestManager User’s Guide for more information.

ClearQuest Databases

Rational ClearQuest is a change request management tool that helps you track and 
manage all change activities (such as defects and enhancement requests) associated 
with a Rational project. When used with other tools in the Rational Suite, ClearQuest 
can play an important role in supporting change and defect management in an 
iterative software development environment.

A Rational ClearQuest database consists of a schema repository and a user database:

■ The ClearQuest schema repository stores all schemas and all system data 
associated with existing schemas. The schema repository does not store any user 
data. 

Test
Artifact

Test
Artifact

RequisitePro RequisiteProRational
Project Project Project

Test Datastore
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■ A ClearQuest user database contains all user data and a copy of the schema 
associated with the database. User data in a ClearQuest database includes 
change-request records (such as defects), as well as reports, records or tables, and 
all data entered by users. 

One ClearQuest database can be used by multiple Rational projects.

Figure 3 shows the relationship between a ClearQuest database and a Rational 
project.

Figure 3 Relationship Between a ClearQuest Database and a Rational Project

For a detailed overview of ClearQuest, see Rational ClearQuest Introduction.

Rose Model Files

Rational Rose enables visual modeling of architectures, components, and data using 
the Unified Modeling Language (UML). From a Rose model, you can automatically 
implement the framework of your code in a number of popular languages. Rose also 
helps you maintain consistency between a software model and its implementation in 
code. A Rational project can be associated with an unlimited number of Rose models.

Figure 4 shows the relationship between Rose models and a Rational project.
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RequisitePro RequisiteProRational
Project Project Project
Chapter 2 - Understanding a Rational Project 23



Figure 4 Relationship Between Rose Models and a Rational Project

Relating Rational Artifacts to a Rational Project

Figure 5 shows the possible relationships between a Rational project and associated 
artifacts. Multiple instances of the Rational project indicate that more than one project 
can be associated with the attached artifact.
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Figure 5 Relationship Between Rational Artifacts and a Rational Project
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3Creating and Configuring 
a Rational Project
This chapter shows you how to create and configure a Rational project.

Creating the Rational Project

To create a Rational project, perform the following steps as described in the remainder 
of this section:

1 Decide where to locate the project.

2 Create a shared directory in which you will store the project.

3 Create the project.

A later section describes how to configure a project.

Deciding Where to Locate the Project 

Determine where the project will reside, following these guidelines:

■ The Rational project contains pointers to the Rational Suite tools’ databases. 
Therefore, these databases can reside anywhere on your network system.

■ Before proceeding, create the top-level directory of the project. Make sure the 
directory is empty and make it a shared directory. Read about Creating a Shared 
Directory on page 27. If you do not share the directory, the project will not be 
available to members of your team.

■ If you are using UCM, there may be special considerations for locating the 
Rational project. See Using Unified Change Management with Rational Suite.

■ Rational project pathnames should be as brief as possible, and no longer than 256 
characters. Use of longer pathnames increases the possibility of datastore errors 
within Rational Test Manager.

Creating a Shared Directory

Before you create the Rational project, create a share name pointing to the directory 
that will contain the project’s files:
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1 Create a directory on the computer where you will create the Rational project. 
Choose an area that is not under version control. In other words, the area should 
not be part of a VOB. 

2 Create a share name pointing to the directory you created in Step 1:

a In Windows Explorer, navigate to the directory and select the directory name.

b Click File > Sharing.

3 On the directory’s Properties page, on the Sharing tab:

a Select Shared As.

b In the Share Name field, enter a meaningful name describing the directory, for 
example, rational-project.

c Click OK.

Sharing the directory enables users and other programs to access the Rational project 
over the network by using UNC pathnames. For more information on how and when 
to use UNC pathnames, see the Windows online Help.

Creating the Rational Project

To create a Rational project, perform the following steps:

1 Start the Rational Administrator: click Start > Programs > Rational Suite > Rational 
Administrator. 

2 Start the New Project Wizard by clicking File > New Project on the Administrator 
menu. 

3 On the wizard’s first page:

a Supply a name for your project, for example, revenue. The dialog box prevents 
you from typing illegal characters.

b In the Project Location field, specify a UNC pathname to the root of the project, 
referring to the share name you created (for example, 
\\computer-name\rational-project\revenue). Make sure that you specify a path that 
is at least in a subdirectory of the share; in this example, rational-project is the 
share, so you need to specify a directory at least one level lower. 

c Clear the check box Use ClearCase and Unified Change Management to baseline 
project assets because you aren’t working with a UCM-enabled project. To 
learn about this topic, see Using Unified Change Management with Rational Suite.

4 If you do create a password for the Rational project, supply the password on the 
Security page. If you do not create a password, then leave the fields blank on this 
page.
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5 On the Summary page, select Configure Project Now. The Configure Project dialog 
box appears.

Configuring the Rational Project

To configure a Rational project, you associate the project with the following artifacts:

■ Zero or one RequisitePro project
■ Zero or one test datastore 
■ Zero or one ClearQuest database
■ Unlimited Rose model files

If the Configure Project dialog box is not visible, display it as follows:

1 In the Rational Administrator, select the project you want to configure and click 
File > Connect. Supply a password if one is required. 

2 Select the project to configure and click File > Configure Project. The Configure 
Project dialog box appears as shown in Figure 6.

Figure 6 The Configure Project dialog box

Working with ClearQuest MultiSite

You can use ClearQuest MultiSite to share access to a ClearQuest database among 
multiple sites by creating replicas of the database.

Requirements

Models Area

Change Requests 
Area

Test Assets Area

Assets Area
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If you have a replicated ClearQuest database, you can configure Rational projects only 
if your current replica masters the RA_Project record.

Associating Requirements

A RequisitePro project organizes and helps you manage a related set of requirements. 
Each RequisitePro project includes a requirements database, documents, discussions, 
histories, and other management-related and administrative items.

You can create a new RequisitePro database or associate an existing database.

Creating a New RequisitePro Project

To create a new RequisitePro project:

1 On the Configure Project dialog box, click Create in the Requirements Assets area. 
RequisitePro displays the Create Rational RequisitePro Project dialog box.

2 Select a Project Template, for example, Use-Case Template, then click Create. 

3 On the Project Properties dialog box:

a In the Name field, specify a name for the RequisitePro project.

b In the Directory field, use a UNC pathname to specify the location where you’d 
like the requirements to reside. For example, you might specify: 
\\computerA\project-directory\requirements.

c In the Database field, specify the type of database you plan to use with your 
RequisitePro project. You configured this database in Configuring Databases on 
page 16. 

d Optionally, provide a comment describing the RequisitePro project.

e Click OK. RequisitePro creates the project.

Associating an Existing RequisitePro Project with the Rational 
Project

To associate an existing RequisitePro project with your project, perform these steps:

1 On the Configure Project dialog box, click Select in the Requirements Assets area. 
The Select RequisitePro Project File dialog box appears.

2 Navigate to the RequisitePro project file you want to associate with the Rational 
project.

Working With RequisitePro and XDE

You can use the integration between RequisitePro and XDE to create links between 
RequisitePro projects and XDE models. 
30 Rational Suite Administrator’s Guide



To take advantage of the integration, use XDE to convert the RequisitePro project into 
XDE format. The Rational Administrator continues to display the older version of the 
RequisitePro project, as it was just before the conversion. The Rational Administrator 
does not display the converted version of the RequisitePro project.

Warning:  After conversion, the old RequisitePro project is obsolete and should not be 
used. After you convert your RequisitePro project to XDE, use XDE to 
manage the project.

For more information on this topic, see the migration information in the XDE online 
Help as well as compatibility information in the XDE Release Notes.

Associating a Test Datastore

A Rational test datastore is a collection of related test assets, including test scripts, 
suites, datapools, logs, reports, test plans, and build information. 

You can create a new test datastore or associate an existing test datastore.

Creating a New Test Datastore

To create a new test datastore:

1 On the Configure Project dialog box, click Create in the Test Assets area. The 
Create Test Datastore wizard starts. 

2 On the first page of the wizard, select the vendor database you want to work with. 
Click Next.

3 Complete the second page of the wizard with the UNC pathname of the test 
datastore you want to create (for example, \\computerA\project-directory\tests) and 
other information specific to the vendor database you chose in Step 2. Click Next.

4 On the third page of the wizard, select initialization options as appropriate and 
click Next. 

5 The Summary page is displayed, indicating the wizard has completed. Click 
Finish.

Your test datastore has been successfully created.

Associating an Existing Test Datastore with the Project

To associate an existing test datastore with your project:
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1 On the Configure Project dialog box, click Select in the Test Assets area. The Select 
Test Datastore dialog box appears.

2 Navigate to the test datastore you wish to associate with the Rational project, or 
enter the UNC pathname where the test datastore resides.

Note:  We recommend that you run the Datastore Doctor on the datastore prior to 
associating it with a project. See the online Help for more information on the 
Datastore Doctor.

Associating a ClearQuest Database

Rational ClearQuest is a change request management tool that helps you track and 
manage all the change activities (such as defects and enhancement requests) 
associated with a Rational project.

Note:  Before beginning this procedure, ensure you have the 2003.06.00 database 
connection name defined to ClearQuest. To verify this, start the ClearQuest 
Maintenance Tool and ensure that the 2003.06.00 connection name appears in the left 
pane of the tool. Unless otherwise specified, this is the default connection name you 
want to work with.

Perform the following steps to associate an existing ClearQuest user database with the 
Rational project:

1 Follow the steps in Configuring the Rational Project on page 29 to display and work 
with the Configure Project dialog box.

2 In the Configure Project dialog box, click Select in the Change Requests area. 

3 In the Select Connection Name dialog box (Figure 7), select the database connection 
associated with the ClearQuest database you want to work with. Click OK.

Figure 7 The Select Connection Name dialog box
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4 In the Select ClearQuest Database dialog box (Figure 8), select the database you 
want to associate with the Rational project by clicking the appropriate Database 
Name. Click OK.

Figure 8 The Select ClearQuest Database dialog box

Your ClearQuest database is now associated with your Rational project, with your 
desired connection.

Associating Rose Models

Rational Rose enables visual modeling of architectures, components, and data, 
automating the process of maintaining consistency between a software model and its 
implementation. Before you associate Rose models with the project, read Establishing a 
Virtual Path Map in Rose on page 33.

Establishing a Virtual Path Map in Rose

Rose maintains internal absolute pathnames to models and parts of models. This 
means that to share a Rose model with another developer, you need to use exactly the 
same paths, including drive letters, to get access to the same Rose model. To work 
around this restriction, set up a virtual path map as follows:

1 Start Rose: click Start, then click Programs > Rational Suite > Rational Rose.

2 Open the Rose model you will be working with.

3 From the Rose menu, choose File > Edit Path Map to display the Virtual Path Map 
dialog box.

4 On the Virtual Path Map dialog box:

a In the Symbol field, type CURDIR.

b In the Actual Path field, type &.

c Click Add.

The following line appears in the Virtual Symbol to Actual Path Mapping list:
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$CURDIR =&

d Click Close.

5 Quit Rose.

6 Start Rose again, open the Rose model, and quit Rose. 

For more information about virtual path maps, view the Rose help for the Virtual Path 
Map dialog box.

Associating Rose Files with the Rational Project

To associate an existing Rose model with the Rational project:

1 On the Configure Project dialog box, click Add in the Models area. The Add Rose 
Model dialog box appears.

2 Navigate to the Rose model you will be working with.

Migrating from Rational Rose to XDE

Using Rational XDE, you can migrate your Rose model (.mdl file) to a XDE model 
(.mdx file). However, keep in mind that the Rational Administrator offers no support 
for XDE models. 

After migration from Rose to XDE, the Rational Administrator will continue to 
display the Rose model (.mdl) in the state in which it was migrated to XDE. The newly 
migrated XDE model (.mdx) is not displayed through the Rational Administrator.

Warning:  While it is possible to modify the Rose model (.mdl file) after migration to 
XDE, we strongly discourage you from doing so, as there is no 
synchronization between the .mdl and .mdx models. After you migrate your 
Rose model to XDE, use XDE to manage the model as well as other XDE 
integrations.
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4Working with a Rational 
Project
This chapter describes additional administrative tasks you can perform while 
working with a Rational project.

Connecting to a Rational Project

You must connect to a Rational project before you can configure it, delete it, or 
manage Rational Test users and groups. After you connect to a Rational project, you 
can view the properties of the associated datastores, projects, and databases.

To connect to a Rational project:

1 From the Rational Administrator menu, click File > Connect.

2 A list of all Rational projects that are not already connected appear in the Connect 
dialog box. Select the project you want to connect to and click OK. 

3 If necessary, enter the Rational project’s password and click OK.

Registering a Rational Project

If you plan to administer a Rational project on a computer other than the one on 
which it was created, register it. You register the Rational project on the same 
computer you used to create and configure the project.

1 From the Rational Administrator menu, click File > Register Project.

2 In the Select Rational Project dialog box, navigate to the Rational project and click 
Open.

After a project is registered, the project name appears in the project hierarchy in the 
Rational Administrator’s left pane.

Unregistering a Rational Project

After you no longer need to work with a Rational project, remove the project name 
and details from the Rational Administrator by unregistering the project. 
Unregistering a Rational project does not delete it. After you unregister a project, you 
can register it again and resume using it.
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1 From the Rational Administrator menu, click File > Unregister Project.

2 Select the project to unregister and click OK. 

Working with the Properties of a Rational Project

You can display properties of a Rational project or edit the project password by 
performing the following steps:

1 Connect to the Rational project. See Connecting to a Rational Project on page 35.

2 Click Edit > Properties.

The General tab allows you to view, but not edit, the Rational project name and 
location.

The Security tab allows you to modify the Rational project’s password.

3 View or modify properties and click OK.

4 To view your changes, click View > Refresh, or disconnect and reconnect to the 
project.

Disconnecting from a Rational Project

After you finish working with a Rational project, you can disconnect from it. 
Disconnecting from the project, and then reconnecting to the project, allows you to 
view changes you may have made to project properties.

1 From the Rational Administrator menu, click File > Disconnect.

2 A list of Rational projects that are registered and connected appear in the 
Disconnect dialog box. Select the Rational project from which to disconnect and 
click OK.

Relocating a Rational Project

Rational projects contain associations to other artifacts, such as RequisitePro projects 
and Rose Models. Therefore, it is critical that the location of the project remain the 
same. Sometimes, however, you may find it necessary to relocate a Rational project. 

Some possible reasons for relocating your project are:

■ You are retiring a server that contains the Rational project (.rsp) file.

■ You are moving the project from a server that may have data integrity problems.
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■ You are consolidating your installation’s architectural configuration.

Note:  You cannot relocate a UCM-enabled Rational project with this procedure.

Preparing to Relocate a Rational Project

Before you start to relocate your Rational project, follow these steps:

1 Select the ultimate destination for your Rational project. Ensure the destination 
computer you select will be stable and accessible to all who use the Rational 
project. 

2 Create a shared directory on the computer (see Creating a Shared Directory on 
page 27). Your Rational project will eventually reside in this directory.

Record the name of the directory you create in the following space for later 
reference: _________________

3 Create a new directory with a unique name, in the shared directory you created in 
Step 2. The name should be different from your existing Rational project. Your new 
Rational project will have this same name.

Record the name of the directory you create in the following space for later 
reference: _________________

4 Find the location of your existing Rational project (.rsp) file. It is most likely in a 
shared directory you have created in the following directory structure: 

\\computer-name\shared-directory-name\Rational-project-name\project.rsp

where:

❑ computer-name is the name of the computer where your Rational project is 
currently located

❑ shared-directory-name is the name of the shared directory where your Rational 
project is currently located

❑ Rational-project-name is the name of the directory where your Rational project is 
currently located. The Administrator names this directory after your Rational 
project name.

❑ project.rsp is the name of your Rational project.

Record the location of your existing Rational project for later reference: 
________________________________________________________________

5 Using Windows, copy the Rational-project-name directory (not just the Rational 
project file) to a removable storage location (floppy disk, CD, and so on) for 
backup and recovery purposes. 

Note:  It is important to note where you store this directory. You will need it later in 
this procedure.
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6 To relocate your Rational project, you must relocate each associated artifact. You 
can determine which artifacts are associated with your Rational project from the 
Details Pane (right pane) of the Administrator.

Overview of Relocating a Rational Project

To relocate your Rational project, perform the following steps:

1 Relocate the RequisitePro project.

2 Delete the old Rational project.

3 Create the new Rational project.

4 Associate the relocated RequisitePro project with the new Rational project.

5 Associate Test artifacts with the new Rational project.

6 If needed, relocate your ClearQuest database.

7 Associate your ClearQuest Database with the new Rational project.

8 Associate Rose models with the new Rational project.

Relocating the RequisitePro Project

If a RequisitePro project is associated with your Rational project, follow these steps to 
relocate it. Otherwise, skip to Deleting the Old Rational Project on page 39.

1 Locate your RequisitePro project (.rqs) file. It is most likely in a shared directory 
you have created (see Creating a Shared Directory on page 27) in the following 
directory structure:

\\computer-name\shared-directory-name\Rational-project-name\RequisitePro-project-na
me\RequisitePro-project.rqs

where:

❑ computer-name is the name of the computer where your Rational project is 
currently located.

❑ shared-directory-name is the name of the shared directory where your Rational 
project is currently located.

❑ Rational-project-name is the name of the directory where your Rational project is 
currently located. The Administrator names this directory after your Rational 
project name.

❑ RequisitePro-project-name is the name of the directory where your RequisitePro 
project is currently located. You named the project when you created it with the 
RequisitePro Create Project Wizard (launched from the Administrator).

❑ RequisitePro-project.rqs is the name of your RequisitePro project.
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In addition, your destination directory must retain the same directory structure.

2 Relocate your RequisitePro project with the appropriate procedure in Table 5. 

The procedure you select depends on the vendor database you use with 
RequisitePro. Make sure your database administrator and RequisitePro 
administrator are aware of your intentions to move the RequisitePro project.

Deleting the Old Rational Project

Ensure you have backed up the Rational project directory and followed the steps in 
Preparing to Relocate a Rational Project on page 37 before proceeding to delete the 
project from its current location. 

To delete the project:

1 From the Rational Administrator, select the project you want to delete in the 
project (left) pane.

2 From the menu, click File > Delete Project.

3 To delete the project, click OK.

Creating the New Rational Project

After you delete the original Rational project, create another one with a unique name. 
Follow these steps to create and configure a new project.

Table 5 Relocating a RequisitePro project based on vendor database

Vendor database used 
with RequisitePro

Procedure to move your RequisitePro project

Microsoft Access Copy the RequisitePro-project-name directory containing your 
RequisitePro project to the final destination you selected in Preparing 
to Relocate a Rational Project on page 37. 

Ensure you copy the entire RequisitePro-project-name directory and 
not just the RequisitePro project file within the directory.

Microsoft SQL Server There are different procedures to follow depending on whether you 
relocate the RequisitePro project to the same computer, or to another 
computer. Contact Rational Customer Support for the latest 
procedures for moving a RequisitePro project in a Microsoft SQL 
Server environment.

Oracle Contact Rational Customer Support for the latest procedures for 
moving a RequisitePro project in an Oracle environment.
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1 From the Rational Administrator, click File > New Project. The New Project - 
General dialog box appears.

2 In the Project Name field, enter the unique directory name that you entered in 
Step 3 of the section Preparing to Relocate a Rational Project on page 37.

In the Project Location field, enter the UNC pathname of the destination directory 
you created in Preparing to Relocate a Rational Project on page 37 (for example, 
\\computer-name\shared-directory-name\unique-directory-name). Click Next.

3 Optionally, enter a password for the project. Click Next.

4 Review the summary on the New Project - Summary screen. If the summary is 
correct, select the Configure Project Now check box and click Finish. If not, click 
Cancel and recreate the project.

Associating the RequisitePro Project With the New Rational Project

Follow these steps to associate the RequisitePro project that you moved in Relocating 
the RequisitePro Project on page 38 with the new Rational project.

1 In the left pane of the Rational Administrator, select the Rational project you 
created in Creating the New Rational Project on page 39.

2 Click File > Configure Project.

3 In the Configure Project dialog box, in the Requirements Assets area, click Select.

4 In the Select RequisitePro Project File dialog box, navigate to the RequisitePro 
project that you moved in Relocating the RequisitePro Project on page 38, select it, 
and click Open.

5 The Associate Rational RequisitePro Project dialog box in Figure 9 is displayed. 
Click Yes to associate the RequisitePro project with the new Rational project.
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Figure 9 The Associate Rational RequisitePro Project dialog box

6 In the Associate Rational RequisitePro Project dialog box, click Close to complete 
the association. 

The RequisitePro project is now associated with the Rational project.

Associating Test Artifacts With the New Rational Project

To associate Test artifacts with the Rational project you created in Creating the New 
Rational Project on page 39, you must:

■ Create Test assets from an existing test datastore, and associate them to the new 
Rational project.

■ Associate existing users and groups to the new Rational project.

Creating Test Assets For the New Rational Project

Follow these steps to create a new test datastore from an existing test datastore, and 
associate it with the new Rational project.

1 In the left pane of the Rational Administrator, select the Rational project you 
created in Creating the New Rational Project on page 39.

2 Click File > Configure Project.

3 In the Configure Project dialog box, in the Test Assets area, click Create.

4 On the first page of the wizard, select the vendor database you want to work with. 
Click Next.
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5 Complete the second page of the wizard with the UNC pathname of the test 
datastore you want to create (for example, \\computerA\project-directory\tests) and 
other information specific to the vendor database you chose in Step 4. Click Next.

6 On the third page of the wizard, select the Initialize Assets from the following Test 
Datastore check box. Navigate to the directory in which you copied your old 
Rational project for backup purposes (see Step 5 in Preparing to Relocate a Rational 
Project on page 37). Locate and select your old test datastore.

7 Next, on the same wizard page, select the Initialize Users and Groups from the 
Rational Project check box. Navigate to the directory in which you copied your old 
Rational project for backup purposes (see Step 5 in Preparing to Relocate a Rational 
Project on page 37). Locate and select your old Rational project.

8 Click Next to display the Summary page.

9 Click Finish to complete the wizard.

Your new test datastore has been successfully created using your old test datastore, 
and is now associated with your new Rational project. In addition, the users and 
groups you created with your old Rational project are now associated with your new 
Rational project.

Relocating Your ClearQuest Database

You are not required to relocate your ClearQuest database when you change the 
location of a Rational project, except in the following cases:

■ Your Rational project and all associated artifacts reside on a single local computer.

■ Your ClearQuest database resides on a server that you will no longer use.

If you need to move your ClearQuest database, use the ClearQuest Designer. For 
information on moving the database, see the Rational ClearQuest Administrator’s Guide.

Associating the ClearQuest Database With the New Rational Project

Follow these steps to associate the ClearQuest database that you use with your old 
Rational project to the new Rational project you just created.

1 In the left pane of the Rational Administrator, select the new Rational project you 
created in Creating the New Rational Project on page 39.

2 Click File > Configure Project.

3 In the Configure Project dialog box, in the Change Requests area, click Select.

4 In the Select Connection Name dialog box, select your database connection.

5 In the Select ClearQuest Database Name dialog box, select the name of the 
ClearQuest database you used with your old Rational project.
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6 Click OK. 

Your ClearQuest database is now associated with your new Rational project.

Associating Rose Models With the New Rational Project

Follow these steps to associate the Rose models you used with your old Rational 
project to the new Rational project you just created.

1 In the left pane of the Rational Administrator, select the new Rational project you 
created in Creating the New Rational Project on page 39.

2 Click File > Configure Project.

3 In the Configure Project dialog box, in the Models area, click Add.

4 In the Add Rose Model dialog box, navigate to the location of the models 
associated with your old Rational project. Select the models you wish to associate 
with your new Rational project.

5 Click Open. 

Your Rose models are now associated with your new Rational project.

Deleting a Rational Project

There may be times when you wish to delete a Rational project. As artifacts that are 
associated with the Rational project become obsolete or change location, it may be 
easier to delete the project and create a new one.

Note:  Do not use Windows Explorer or any other program to delete a Rational project. 
Always use the Rational Administrator.

Before you delete a Rational project:

■ Consider carefully the effects of deleting the project. Are there any integrations 
between Rational Suite artifacts that need to be preserved? Do you have a recovery 
plan in place, if needed?

■ Communicate your intention to delete the project with all members of your team, 
especially those responsible for maintaining other Rational products.

■ Make a backup copy of the Rational project.

When you delete a Rational project:

■ The project is unregistered.

■ The associations among the various projects, datastores, and databases are 
removed, but the artifacts themselves are not removed.

■ The project is permanently deleted.
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To permanently delete a Rational project, follow these steps:

1 From the Rational Administrator, select the project you want to delete in the 
project (left) pane.

2 From the menu, click File > Delete Project.

3 To delete the project, click OK.

Working with ClearQuest MultiSite

You can use ClearQuest MultiSite to share access to a ClearQuest database among 
multiple sites by creating replicas of the database.

If you have a replicated ClearQuest database, you can configure Rational projects only 
if your current replica masters the RA_Project record.

Working with SQL Anywhere

From the Rational Administrator, you may access Sybase Central and ISQL, Sybase 
tools that enable you to work with a SQL Anywhere database.

Sybase Central 

Use the Sybase Central tool to perform Sybase SQL Anywhere functions, such as 
creating, backing up, and compressing a SQL Anywhere database.

To use the Sybase Central tool, click Tools > Sybase Central.

ISQL

Use the ISQL tool to generate interactive SQL queries on an SQL Anywhere database.

To use the ISQL tool, click Tools > ISQL.

For more information about using Sybase Central or ISQL, see the Sybase Central 
database management tool Help.
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5Managing Test Users and 
Groups
This chapter provides information about Rational Test users and groups. This chapter 
helps you:

■ Understand the structure of Rational Test users and groups

■ Administer Rational Test users, groups, and assets

Understanding Rational Test Users and Groups

This section describes Test users and groups. This information is a prerequisite for 
administering Test users, groups, and associated assets.

Test Users

Test users are typically the QA managers, developers, and test engineers who use 
Rational Test components to create, edit, run, monitor, analyze, and manage test 
scripts.

For each test user, you can specify:

■ User ID
■ Password
■ First name
■ Last name
■ Company
■ Title
■ Department
■ Phone number
■ E-mail address

You can set the Rational test datastore privileges for a test user to create, modify and 
delete:

■ Test planning assets
■ Test implementation assets
■ Test execution assets
■ Test results analysis assets
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Test Groups

You set privileges for groups of users (called test groups), then assign privileges to each 
user by adding the user to a test group. When you add a test user to a test group, the 
test user acquires the privileges of that test group. A test user can be a member of one 
or more test groups. 

You can define any test group as a default group, and you can also create multiple 
default groups. Every test user that you create acquires the privileges of the default 
groups.

When you create a Rational project using the Rational Administrator, a Test Users 
folder and a Test Groups folder is created by default. This folder appears in the left 
pane of the Rational Administrator window, under the Rational test datastore object.

Admin Test User

When you create the Rational test datastore, the Admin Test User is also created. The 
Admin Test User is located within the Test Users folder. The Admin Test User is not a 
member of any specific test group and takes on all available privileges.

The Admin Test User can:

■ Create, modify, and delete test assets, reports, builds and logs.

■ Customize test assets and builds.

Admin Test Security

There is no default password for the Admin Test User. You can log in as an Admin 
Test User without using a password. This lets you log into any Rational Test 
component after you first install the software.

When you connect to a project for the first time, you should define a password for the 
Admin Test User to prevent unauthorized access. The Admin Test User always has 
full test user access privileges and cannot be deleted from a project.

Administering Test Users and Groups

Use the following procedures to administer and maintain users and groups for the 
Rational test datastores you have defined.

Adding a Test Group or Test User

You must have Admin Test User privileges to add a Test group or Test user. To add a 
test group or test user to a Rational test datastore:
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1 Use the Rational Administrator to connect to the project. From the Rational 
Administrator menu, click File > Connect. Select the project name and click OK. 

2 To add a Test group:

a Click Insert > Test Group. 

b A dialog box displays a list of all connected projects. Select the project to add a 
test group to, and click OK.

The Insert Test Group dialog box opens.

c Type a name and description for the group.

d Optionally, click Set as default group to set a test group as a default group for all 
test users you will add to the project. 

e Set the privileges for the Test group by selecting or clearing the appropriate 
check boxes. 

➑ Write Privileges – Select the appropriate check boxes to give privileges to a 
group to create, modify, or delete Test planning assets, Test implementation 
assets, Test execution assets, and Test results analysis assets. 

➑ Administration Privileges – Select the appropriate check boxes to give 
privileges to a Test group to customize Test assets. Test assets include scripts 
and suites.

See Table 6 for examples of types of Test assets.

f Click OK.

3 To add a Test user:

a Click Insert > Test User. 

b A dialog box displays a list of all connected projects. Select the project to add a 
Test user to, and click OK.

The Insert Test User dialog box opens.

Table 6 Examples of Test Assets

Test Asset Types Examples

Test planning assets Test plans and iterations of plans

Test implementation assets Tools used in the implementation of test plans

Test execution assets Suites, computers, and computer lists

Test results analysis assets Build results, test log folders, and test logs
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c On the General tab, type the user’s information.

d On the Groups tab, add to or remove users from the available groups.

e Click OK.

Modifying a Test Group or Test User

You must have Admin Test User privileges to modify a test group. To modify existing 
test group information:

1 From the Rational Administrator menu, connect to the project. Click File > 
Connect. Select the project name and click OK. 

2 If Test Groups or Test Users are not listed in the left pane of the main window, 
double-click the Rational test datastore object.

3 If the test group or user that you want to modify is not listed, double-click Test 
Groups or Test Users, respectively, to display all groups or users.

4 Select the test group or test user to modify.

5 Click Edit > Properties.

6 Change the test group or test user information on the appropriate tabs. 

7 Click OK.

Deleting a Test Group or Test User

When you delete a test group, you delete the group privileges for any test users in the 
deleted group. Deleting a Test group does not delete Test users. 

To delete a test group or test user from a Rational test datastore:

1 Use the Rational Administrator to connect to the project. From the Rational 
Administrator menu, connect to the project. Click File > Connect. Select the project 
name and click OK. 

2 If Test Groups or Test Users are not listed in the left pane of the main window, 
double-click the Rational test datastore object.

3 If the test group or test user that you want to delete is not listed, double-click Test 
Groups or Test Users to display all groups or users respectively.

4 Select the test group or test user to delete, then click Edit > Delete. 

The Rational Administrator prompts you to confirm the deletion. 

5 Click Yes.
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Changing a Password for a Test User

Follow these steps to change a password for a test user:

1 In the left pane of the Rational Administrator main window, double-click Rational 
Test Datastore.

2 Double-click Test Users to display all test users.

3 Select the user name of the password that you want to change.

4 Click Edit > Properties.

5 On the General tab of the Properties box, select the original password in the 
Password box, then type a new password.

Passwords are alphanumeric strings (ASCII characters only) of up to 20 characters 
and are case-sensitive. Non-ASCII characters, such as accented letters, are not 
supported in the password field.

6 Click OK.
Chapter 5 - Managing Test Users and Groups 49



50 Rational Suite Administrator’s Guide



6Configuring the 
Integration for ClearQuest 
and RequisitePro
This chapter shows how to configure the integration of Rational ClearQuest and 
Rational RequisitePro. This integration allows you to associate ClearQuest records 
with RequisitePro requirements.

To learn about using the integration between RequisitePro and ClearQuest, refer to 
Getting Started: Rational Suite AnalystStudio provided on your documentation CD.

How to Use this Chapter

If you are Then

Setting up a Rational Administrator Project 
before configuring the integration.

Follow the instructions in Configuring the 
Rational Administrator Project on page 53.

Testing your ClearQuest schema and 
RequisitePro project for the availability of 
typical and custom setup types.

Follow the instructions in the section Testing 
Your ClearQuest Schema and RequisitePro Project 
on page 53.

Setting up a new integration using typical 
record and requirement types (recommended 
for inexperienced users.)

Follow the instructions in the section Setting 
Up a Typical Integration on page 54.

Setting up a new integration using custom 
record and requirement types (recommended 
for experienced users).

Follow the instructions in the section Setting 
Up a Custom Integration on page 55.

Using a ClearQuest database with hidden 
records.

See Maintaining Record Visibility on page 58.

Working in a ClearQuest MultiSite 
environment.

See Using the Integration with ClearQuest 
MultiSite on page 58.

Reconfiguring or repairing existing 
integration associations.

Ensure that you have upgraded all Rational 
products, databases, schemas, and projects 
according to the instructions in this document, 
then follow the instructions in the section 
Repairing and Reconfiguring the Integration on 
page 59.
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Overview of the Configuration Process

To configure the integration, perform the following steps:

1 Plan the configuration; decide if you want to use the Typical or Custom setup type.

2 Configure a Rational project to associate your ClearQuest database and your 
RequisitePro Project.

3 Use the RequisitePro-ClearQuest Integration Wizard to test your project.

4 If necessary, configure your ClearQuest schema and RequisitePro project to resolve 
any problems found during the test.

5 Use the RequisitePro-ClearQuest Integration Wizard to set up the integration.

Overview of the RequisitePro-ClearQuest Integration Wizard

The RequisitePro-ClearQuest Integration Wizard provides an easy way to set up new 
integrations and reconfigure or repair existing integrations. The wizard also tests and 
verifies databases, projects, and associations to help you troubleshoot problems with 
new and existing integrations. 

The wizard replaces the ASCQISetup.bat and ASCQISetup.exe files used to configure 
the integration in earlier versions of Rational Software. If you have an existing 
integration, you can continue to use ASCQISetup.bat and ASCQISetup.exe to modify the 
integration, or you can use the wizard to make changes. 

Planning: Deciding to Use Typical or Custom Setup Type

Before you configure your integration, you must decide if you want to customize the 
integration or use the typical settings in the ClearQuest schema and RequisitePro 
project templates provided by Rational Software.

Typical Setup Type

In a typical integration, the Defect record type and the EnhancementRequest record type 
in ClearQuest are associated with the FEAT requirement type in RequisitePro. The 
FEAT requirement type has two attributes, Defect and EnhancementRequest. Choose the 
typical setup type if you are an inexperienced user or if you do not need to use any 
custom record or requirement types in the integration.
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Custom Setup Type

A custom integration can associate any record type(s) with any requirement type(s). 
Choose the custom setup type if you are an experienced user and you need to use 
special record and requirement types in the integration.

Configuring the Rational Administrator Project

To enable the integration, you must create a Rational Administrator project which 
associates a ClearQuest database and a RequisitePro project. If your ClearQuest 
database and RequisitePro project are not associated with a Rational project, use the 
Rational Administrator to create a project. When configuring the Rational project, 
select the ClearQuest database and the RequisitePro project that you want to use for 
the integration. For more information, see Creating and Configuring a Rational Project on 
page 27 or see Rational Administrator Help.

If you receive an error message when you try to configure a Rational Administrator 
project, see Repairing Rational Administrator Project Problems on page 59.

Testing Your ClearQuest Schema and RequisitePro Project

You can test your ClearQuest schema and RequisitePro project using the 
RequisitePro-ClearQuest Integration Wizard. The wizard checks for the presence of 
the record types, requirement types, and attributes necessary to the custom and 
typical setup types. 

1 Start Rational Administrator.

2 Right-click on the Rational Project containing your ClearQuest database and 
RequisitePro project and select RequisitePro-ClearQuest Integration. 

3 On the Choose Setup Type page, review the available setup types. If the setup type 
you want to use is available, you can continue with the wizard.

4 If one or both setup types are unavailable, the wizard produces a configuration 
report explaining which requirement types, record types, or attributes are missing 
or mis-configured. You can view and save this report by selecting Integration 
Status.

Configure your ClearQuest database and/or RequisitePro project according to the 
configuration report, depending on the kind of integration setup type you want. If 
you want a typical setup type, make sure your project conforms to the settings 
described in Setting Up a Typical Integration on page 54. If you want a custom setup 
type, make sure your project conforms to the settings described in Setting Up a Custom 
Integration on page 55.
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Setting Up a Typical Integration

To set up a typical integration, you must create a ClearQuest database and a 
RequisitePro project, and associate them to each other in a Rational Administrator 
project. If you have not yet created your ClearQuest database or your RequisitePro 
project, read this section for information on which schemas and templates to use.

If you have already created your ClearQuest database and RequisitePro project, you 
can quickly test whether the typical setup type is available by using the wizard. The 
wizard checks the database and project for the availability of typical record and 
requirement types. 

Configuring the ClearQuest Schema

To configure your ClearQuest schema for a typical integration, create your database 
using one of the following packaged schemas provided with ClearQuest:

■ Rational Suite AnalystStudio schema
■ Rational Suite DevelopmentStudio schema
■ Rational Suite Enterprise schema
■ Rational Suite TestStudio schema

Or use a custom schema containing the following:

❑ A Defect record type with a Submit form and a Record form.

❑ An EnhancementRequest record type with a Submit form and a Record form.

Each record type must have the following actions of the appropriate type:

If you have created your ClearQuest database using a custom schema or the Blank 
schema, your ClearQuest database may lack the record types, actions, and states 
necessary for the typical setup type. 

For more information on how to create record types, actions, and states in ClearQuest, 
refer to ClearQuest Designer Help.

Action Type

Submit State transition

Open State transition

Close State transition

Modify Modify
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Configuring the RequisitePro project

To configure your RequisitePro project for a typical integration, create your project 
from one of the following project templates provided with RequisitePro:

■ Composite Template

■ Traditional Template

■ Use-Case Template

Or use a project containing a requirement type with prefix FEAT and two attributes of 
the ClearQuest Integration type: Defect and EnhancementRequest.

If you created your RequisitePro project using a custom template or the Blank 
template, your project may lack the appropriate requirement type and attributes 
necessary for the typical setup type.

For more information on how to create requirement and attribute types, refer to 
Working with Requirement Types in RequisitePro Help. 

Setting up the Configuration

After your ClearQuest database and RequisitePro project are associated with a single 
Rational Administrator project, use the RequisitePro-ClearQuest Integration Wizard 
to set up your associations.

1 Start Rational Administrator.

2 Right-click on the Rational Project containing your ClearQuest database and 
RequisitePro project and select RequisitePro-ClearQuest Integration. 

3 On the Choose Setup Type page, select Typical setup type.

If Typical is unavailable, you must add the typical record and requirement types 
detailed below to your database and project before you can set up a typical 
integration.

Setting Up a Custom Integration

To set up a custom integration, you must create a ClearQuest database and a 
RequisitePro project, and associate them to each other in a Rational Administrator 
project. If you have not yet created your ClearQuest database or your RequisitePro 
project, read this section for information on which schemas and templates to use.
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If you have already created your ClearQuest database and RequisitePro project, you 
can quickly test whether the custom setup type is available by using the wizard. The 
wizard checks the database and project for the availability of typical record and 
requirement types. For more information, see Testing Your ClearQuest Schema and 
RequisitePro Project on page 29.

Setting Up the ClearQuest Schema

Your schema must have the most recent version of the RequisitePro and Repository 
packages applied to the schema. If you have not applied these packages, Rational 
Administrator prevents you from associating the ClearQuest project to a RequisitePro 
project.

Your schema must have at least one record type, and it must have a Back Reference 
field on the Requirements_List (or a custom list) field for each record type you want 
to associate to a requirement type.

To add a Back Reference field to your schema, perform the following steps:

1 In the ClearQuest Designer, click File > Open Schema. The Open Schema dialog 
box appears.

2 Select the option Checkout a schema to edit.

3 Select your schema from the list and click Next. Click Finish.

4 In the schema browser, open the Record Types folder.

5 In a record type you selected when you applied the RequisitePro package, 
double-click Fields. The list of fields appears.

6 Right-click the Requirements_List field name and select Field Properties. The 
Properties dialog box appears. 

7 At the Back Reference field, type the name of the appropriate record type, such as 
EnhancementRequests_List. For some schemas, this field may already contain a 
value. In some cases this field may be read-only. If so, no action is required.

8 Close the Properties dialog box.

9 Repeat steps 5–8 for each of the record types you selected when you applied the 
RequisitePro package.

10 Click File > Check In. ClearQuest validates the schema and displays a Check In 
dialog box.

11 Type a comment describing the schema changes and click OK.
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To apply the changes you have made to your packages to the ClearQuest user 
database:

1 Back up your database.

2 From the ClearQuest Designer menu, select Database > Upgrade Database and click 
Yes to continue. 

3 In the Upgrade Database window, select the database instance that is included in 
your Rational project. Click Next.

4 Select the latest version of the schema (the schema with the highest version 
number). Click Finish.

5 Click OK and close the ClearQuest Designer.

Your ClearQuest database is now upgraded to use the current integration between 
RequisitePro and ClearQuest.

For more information on how to create record types, actions, and states in ClearQuest, 
refer to ClearQuest Designer Help.

Setting up the RequisitePro Project

The RequisitePro project must have at least one requirement type with at least one 
attribute of the ClearQuest integration type.

For more information on how to create requirement and attribute types, refer to 
Working with Requirement Types in RequisitePro Help. 

Setting up the Configuration

After your ClearQuest database and RequisitePro project are associated with a single 
Rational project, use the RequisitePro-ClearQuest Integration Wizard to set up your 
associations.

1 Start Rational Administrator.

2 Right-click on the Rational Project containing your ClearQuest database and 
RequisitePro project and select RequisitePro-ClearQuest Integration. 

3 On the Choose Setup Type page, select Custom setup type.

If Custom is unavailable, you cannot set up any integration between the 
ClearQuest database and RequisitePro project. You must add the record types, 
requirement types, and attributes to your database and project before you can set 
up a the integration. Choose Integration Status for information on which record 
types, requirement types, or attributes are missing.

4 On the Configure Associations page, select requirement types, record types, and 
attributes for your integration.
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5 The remaining steps of the wizard prompt you to review and confirm your 
decisions before committing them. To make changes to your integration later, 
follow the steps in Reconfiguring an Existing Integration on page 61.

Maintaining Record Visibility

The ClearQuest record visibility feature allows you to limit access to certain 
ClearQuest records. This limited access applies to selected ClearQuest user groups, 
and is based on criteria defined by an administrator. The criteria specify that records 
are visible for a user group depending on the value of a specific ClearQuest reference 
field. To use the integration between RequisitePro and ClearQuest, RequisitePro users 
must have record visibility throughout the life of all integrated records.

We recommend that you define record visibility for user groups based on the value of 
the RAProject field, which is required for integration with RequisitePro. If you use 
this criterion, you preserve the integration between RequisitePro and ClearQuest, 
because you cannot change the value of the RAProject field without first removing all 
associations to RequisitePro requirements. In addition, this criterion ensures that all 
RequisitePro project users have visibility for the same ClearQuest records.

Using the Integration with ClearQuest MultiSite

When you use the integration between RequisitePro and ClearQuest within a 
ClearQuest MultiSite environment, you must set up the integration individually at 
each different site. You can enable the integration with the originating ClearQuest 
schema repository and user database, or with a local replica. To integrate with any 
ClearQuest database, that database must have mastership of the RAProject record and 
of the ClearQuest records you want to associate. 

To save time, we recommend that you create a query that filters records in your 
ClearQuest database by mastership. Use it to screen records before associating them 
with requirements in the Associate [ClearQuest Record Type] dialog box. To create this 
query, click Build Query in the dialog box. For more information, see the dialog box 
Help.
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To set up the integration with ClearQuest MultiSite, perform the following steps:

1 Create and configure a separate local RequisitePro project at each site.

2 Create and configure a separate Rational Administrator Project at each site which 
associates the ClearQuest MultiSite database with the local RequisitePro project. 

Note:  You can associate each ClearQuest record with only one requirement at a 
time, even if the ClearQuest database containing that record is associated with 
multiple RequisitePro projects.

When you are configuring the integration in a MultiSite Environment, you may need 
to use the ClearQuest Maintenance Tool to specify which schema repository you are 
using. Always use a connection to the appropriate schema repository that matches the 
default local registry key, 2003.06.00. 

Note:  For more information, see the Rational ClearQuest MultiSite Administrator’s Guide 
on the Rational Solutions for Windows Products Online Documentation CD.

Repairing and Reconfiguring the Integration

This section describes how to troubleshoot new and existing integrations. Consult the 
table below for information on how to use this section:

Repairing Rational Administrator Project Problems

If you receive an error message from Rational Administrator related to missing 
packages, your ClearQuest schema is missing the Repository or RequisitePro package. 
You must apply and upgrade the packages before you can associate your ClearQuest 
database to a RequisitePro project using Rational Administrator.

If you are Then

Receiving an error message when you try to 
associate a ClearQuest database to a 
RequisitePro project in Rational 
Administrator.

 Follow the procedures described in 
Repairing Rational Administrator Project 
Problems on page 59.

Repairing an integration that has broken 
record-requirement associations caused by 
changes to record types, requirement types, or 
attributes used by the integration.

Follow the instructions in the section Repairing 
Invalid Associations on page 60.

Changing an existing, functional integration. Follow the instructions in the section 
Reconfiguring an Existing Integration on 
page 61.
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Applying the Repository and RequisitePro Packages

To apply the Repository and RequisitePro packages: 

1 From the ClearQuest Designer menu, click Package > Package Wizard. The Package 
Wizard window appears.

2 In the Select a Package list, select the latest version of the Repository package. 
Click OK.

3 In the Package Wizard, click Next. Select your schema. Click Next again.

4 Select all record types that you will use in the integration. 

Note:  If a previous version of the Repository package has been applied, some 
record types in your schema may not appear because they have already been 
selected. We recommend that you select at least Defect and EnhancementRequest, 
if they are present.

5 Click Finish.

6 Repeat steps 1–6 for the RequisitePro package.

7 From the ClearQuest menu, select File > Checkin to check in the schema. Click OK 
after verifying your choice. Click OK again in the ClearQuest Checkin Confirmation 
dialog box.

Repairing Invalid Associations

After an integration is successfully set up, changes you make to requirement types, 
record types, and attributes can cause some or all of the associations that enable the 
integration to become invalid. You can repair these associations by restoring your 
requirement types, record types, or attributes to their original state, or by using the 
wizard to repair the associations.

To repair invalid associations using the wizard, take the following steps:

1 Start Rational Administrator.

2 Right-click the Rational Project containing your existing integration and select 
RequisitePro-ClearQuest Integration.

3 On the Choose Setup Type page, select Specify the requirement and record types 
used by the integration or repair or reconfigure my current integration.

4 On the Configure Associations page, add, delete, or modify associations marked 
Invalid in the associations pane.

5 Review and confirm your changes.
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Reconfiguring an Existing Integration

To reconfigure an existing integration, use the RequisitePro-ClearQuest Integration 
Wizard.

Reconfiguring Existing Associations with Custom Associations

To reconfigure existing associations with custom associations, take the following 
steps:

1 Start Rational Administrator.

2 Right-click the Rational Project containing your existing integration and select 
RequisitePro-ClearQuest Integration.

3 On the Choose Setup Type page, select Specify the requirement and record types 
used by the integration or repair or reconfigure my current integration.

4 On the Configure Associations page, add, delete, or modify associations in the 
associations pane.

5 Review and confirm your changes.

Overwriting Existing Associations with Typical Associations

To reconfigure an existing integration with typical integration settings, your 
ClearQuest database and RequisitePro project must contain all the typical record 
types, requirement types, and attributes described in Typical Setup Type on page 52. 
The wizard will test for these conditions before allowing you to overwrite the existing 
integration. 

To overwrite the existing integration with typical integration settings:

1 Start Rational Administrator.

2 Right-click the Rational Project containing your existing integration and select 
RequisitePro-ClearQuest Integration.

3 When prompted, select Overwrite existing integration associations with Typical 
setup associations.

Review and confirm your changes.
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7Troubleshooting
This chapter provides information on preliminary troubleshooting and pointers to 
additional troubleshooting information available throughout the Rational 
documentation set.

Troubleshooting Guide

Table 7 lists common symptoms and possible problems and solutions. If you are 
unsure of how to resolve a problem, call Rational Customer Support before 
proceeding. See Before Calling Technical Support on page 65 for more information.

Troubleshooting Integrations with Rational ClearQuest

Many Rational tools have integrations with Rational ClearQuest.

Table 7 Troubleshooting Guide

Symptom
Possible 
Problem Possible Solution

You receive the "Unable to 
access ClearQuest 
database" message when 
configuring a Rational 
project that includes a 
ClearQuest database.

The license 
server is 
unavailable or 
you have an 
invalid license.

Check your licensing status. Ensure you have 
a valid license.

During testing, your 
datastore sometimes does 
not properly connect, the 
reported test data is 
inconsistent, or some test 
data is lost. 

Your test 
datastore may be 
corrupted.

Run the Datastore Doctor on the test datastore 
to verify its structure and correct any 
inconsistencies. For more information on the 
Datastore Doctor, see the online Help.
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To enable the integration, you either use a specialized ClearQuest schema, or apply a 
ClearQuest package to your existing schema. In some cases, you then perform 
additional tasks.

Troubleshooting Missing Packages Errors

If you are missing required integration packages, associating a ClearQuest database 
with Rational projects containing Test and RequisitePro artifacts results in the 
following error message:

“The schema you have selected needs to be modified to support integrations. One or 
more ClearQuest packages need to be applied to your schema before you can 
configure or use this Rational project.”

Using the ClearQuest Designer, apply the appropriate ClearQuest packages listed in 
Table 8. 

Your user database can now be associated with your Rational project.

For more information about applying packages and enabling integrations with 
ClearQuest, see the Rational ClearQuest Administrator’s Guide.

Note:  When you customize a ClearQuest package or schema, you can sometimes 
unintentionally disable either the integration you are trying to achieve or the 
integrations between other Rational products. Customize packages or schemas only 
as directed by Rational Technical and Field Engineers. If you have questions, contact 
Technical Support before proceeding.

Table 8 Packages Needed for ClearQuest User Database Integrations

If your Rational project
To associate the Rational project with a ClearQuest 
user database, you must apply

Contains Test artifacts TeamTest and Repository packages.

Contains RequisitePro 
artifacts

RequisitePro and Repository packages.

Is UCM-enabled UnifiedChangeManagement, UCMPolicyScripts, and 
AMStateTypes packages.
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Data Code Pages: Character Set Compatibility with ClearQuest 

You may see an error message about data code pages if your Rational project is 
integrated with ClearQuest. The error message appears when you enter data into a 
tool and the characters you use are incompatible.with the set of characters that a 
ClearQuest database accepts. 

For example, say that you are working in a RequisitePro project that is integrated with 
a ClearQuest database, and the ClearQuest database accepts characters in English 
only.  If you use English to enter RequisitePro data, the error message does not appear. 
However, the error message does appear if you use another character set, such as 
Japanese or Chinese. 

If you see this error message, consult with your ClearQuest administrator or systems 
administrator to resolve the character set incompatibility. 

Before Calling Technical Support

Before calling Rational Customer Support, be prepared to provide the information 
listed in Contacting Rational Customer Support on page xi. In addition, you may be 
asked to provide the following information:

■ Information on upgrades you have installed

■ Database products you have installed and release levels of the products

■ Your license information

❑ What is your license key?

❑ Is the license active?

■ Information on debugging tools you have used (for example, CQ Trace)

■ Information about project artifacts (Rational projects, test datastores, ClearQuest 
databases, Rose Models, RequisitePro projects, and so forth)

❑ In which product and product release were the artifacts created?

❑ Do the artifacts reside on a local computer or on the network?

❑ If the artifacts reside on a network, are the computers resident in the same 
domain, or in different subnet groups?

❑ Were the artifacts backed up prior to being upgraded?

❑ What upgrade procedures were followed? In which documentation?

■ A copy of the Rational project (.rsp file)
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Use the Search or Find functionality of your Windows system find the file, or ask 
your Technical Support representative to help you.

■ If the problem involves ClearQuest, a copy of the Tracking CQ.dat file

Use the Search or Find functionality of your Windows system find the file, or ask 
your Technical Support representative to help you.

For More Troubleshooting Information

Table 9 provides information on troubleshooting other Rational products.

Table 9 Rational Troubleshooting Information

Topic Source of Troubleshooting Information

Rational Suite licenses “Troubleshooting Licenses” chapter of Rational Suite License 
Management Guide 

Rational Suite installations “Troubleshooting” chapter of Rational Software Server Products 
Installation Guide 

ClearCase LT Administration “Troubleshooting” chapter of Rational ClearCase 
Administrator’s Guide

RequisitePro use “Troubleshooting” chapter of Rational RequisitePro User’s 
Guide
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