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Preface
Rational ClearQuest Project Tracker allows you to exchange information between the 
Microsoft Project 2000 project management application and Rational’s ClearQuest 
change management system. It helps you create a comprehensive closed loop project 
tracking system that takes full advantage of the project management features of 
Microsoft Project 2000 and the change management capabilities of Rational 
ClearQuest.

With Project Tracker, the project manager has easy access to information in ClearQuest 
about work being performed by individual contributors. The project manager can feed 
this information into Microsoft Project 2000 and accurately update the project plan 
with the most up-to-date information available.

With Project Tracker, information from new and updated project plans can be 
transferred to ClearQuest and made available to individual contributors and team 
managers. The contributors can adjust their priorities and schedules based on the most 
up-to-date project plan dates.

Creating this closed loop project tracking system ensures that individual contributors 
are focused on the plan and that the project manager gets accurate information on the 
progress being made. As a result, Project Tracker saves time, reduces wasted efforts, 
and helps bring projects in on schedule. 

This guide also provides information on how to use Microsoft Project project plans 
based on the Rational Unified Process (RUP). If you have the Rational Unified Process 
available on your system, you can access the RUP project plans from Rational Unified 
Process > Templates > Microsoft Project. These plans reinforce the best practices 
methodology developed by Rational Software.
ix



About This Manual

This document is intended for project managers and staff of organizations that are 
using Rational ClearQuest for change request management, and that are using or 
planning to use Microsoft Project 2000 for project management. 

For systems administrators, Appendix A, Setting Up and Configuring Project Tracker 
explains how to set up and configure Project Tracker. The system requirements for 
using Project Tracker are also included in this appendix. 

Appendix B, Using RUP Project Plans describes how to access and apply the optional 
RUP project plans to Project Tracker.
x Using Project Tracker



ClearQuest Documentation Roadmap

More Information
Online documentation

Help files

Administration

Project 
Management

Orientation

Database
Design

Installation Guide (Rational Desktop Products)

Installation Guide (Rational Server Products)

Installation Guide (UNIX)

Administrator's Guide (Rational ClearQuest)

Administrator's Guide (Rational ClearQuest MultiSite)

Upgrade Guide (Rational Suite)

Using Project Tracker
(Windows platforms;

see online
documentation)

Introduction

Release Notes
(See online documentation)

Designer tutorials
(See online documentation)

Administrator's Guide
(Rational ClearQuest)

API Reference
(See online 

documentation)
Preface xi



ClearQuest Integrations with Other Rational Products

Typographical Conventions

This manual uses the following typographical conventions:

■ ccase-home-dir represents the directory into which the ClearCase Product Family 
has been installed. By default, this directory is /opt/rational/clearcase on UNIX and 
C:\Program Files\Rational\ClearCase on Windows. 

■ cquest-home-dir represents the directory into which Rational ClearQuest has been 
installed. By default, this directory is /opt/rational/clearquest on UNIX and 
C:\Program Files\Rational\ClearQuest on Windows. 

Integration Description Where it is documented

ClearQuest-
Base ClearCase

Associates change requests 
with versions of ClearCase 
elements.

ClearCase: Developing Software 
ClearCase: Managing Software 
Projects

ClearQuest: Administrator’s Guide

ClearQuest-PurifyPlus Allows developers to invoke 
ClearQuest from PurifyPlus.

PurifyPlus Help
ClearQuest: Administrator’s Guide

ClearQuest- 
RequisitePro

Allows developers to invoke 
ClearQuest from RequisitePro 
and to associate requirements 
with ClearQuest change 
requests.

Rational Suite: Administrator’s Guide

ClearQuest: Administrator’s Guide

ClearQuest-SoDA Collects information from 
ClearQuest and presents it in 
various report formats.

Using Rational SoDA for Word 
Using Rational SoDA for Frame 
SoDA Help

ClearQuest-
Test Manager

Allows developers to invoke 
ClearQuest from TestManager.

Using Rational TestManager 
ClearQuest: Administrator’s Guide

ClearQuest-Robot Allows developers to invoke 
ClearQuest from Robot.

Rational Robot User’s Guide
Rational Robot Help

ClearQuest-UCM Links UCM activities to 
ClearQuest records.

ClearCase: Developing Software 
ClearCase: Managing Software 
Projects

ClearQuest: Administrator’s Guide
xii Using Project Tracker



■ Bold is used for names the user can enter; for example, command names and 
branch names.

■ A sans-serif font is used for file names, directory names, and file extensions.

■ A sans-serif bold font is used for GUI elements; for example, menu names and 
names of check boxes.

■ Italic is used for variables, document titles, glossary terms, and emphasis. 

■ A monospaced font is used for examples. Where user input needs to be 
distinguished from program output, bold is used for user input.

■ Nonprinting characters appear as follows: <EOF>, <NL>. 

■ Key names and key combinations are capitalized and appear as follows: SHIFT, 
CTRL+G.

■ [ ] Brackets enclose optional items in format and syntax descriptions.

■ { } Braces enclose a list from which you must choose an item in format and syntax 
descriptions.

■ | A vertical bar separates items in a list of choices.

■ ... In a syntax description, an ellipsis indicates you can repeat the preceding item 
or line one or more times. Otherwise, it can indicate omitted information.

Note: In certain contexts, you can use “...” within a pathname as a wildcard, similar 
to “*” or “?”. For more information, see the wildcards_ccase reference page.

■ If a command or option name has a short form, a “medial dot” ( ⋅ ) character 
indicates the shortest legal abbreviation. For example:

lsc⋅heckout 

Online Documentation 

Rational ClearQuest includes online documentation, as follows:

Help System: Use the Help menu, the Help button, or the F1 key.

Reference Pages: On Windows, to display a reference page for Rational ClearQuest 
MultiSite, at the command prompt type multiutil man command-name.

API Reference: Click Start > Programs > Rational Software > Rational ClearQuest > 
Rational ClearQuest API Reference.

Tutorial: Click Start > Programs > Rational Software > Rational ClearQuest > ClearQuest 
Designer Tutorial.
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PDF Manuals: Navigate to:

■ On UNIX, cquest-home-dir/doc/books 

■ On Windows, cquest-home-dir\doc\books 

Customer Support

If you have any problems with the software or documentation, please contact Rational 
Customer Support by telephone, fax, or electronic mail as described below. For 
information regarding support hours, languages spoken, or other support information, 
click the Support link on the Rational Web site at www.rational.com.

Your 
location

Telephone Facsimile Electronic mail

North 
America

800-433-5444
toll free or 
408-863-4000
Cupertino, CA

408-863-4194
Cupertino, CA
781-676-2460
Lexington, MA

support@rational.com 

Europe, 
Middle 
East, and 
Africa

+31-(0)20-4546-200
Netherlands

+31-(0)20-4546-201 
Netherlands

support@europe.rational.com 

Asia Pacific 61-2-9419-0111
Australia

61-2-9419-0123
Australia

support@apac.rational.com 
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1Overview of Project 
Tracker
This chapter provides an overview of Rational ClearQuest Project Tracker. It outlines 
the benefits of using Project Tracker, describes the capabilities of the product, and 
provides two scenarios showing how the software might be used to exchange 
information between a project manager and the individual contributors and team 
managers working on a project.

What Is Rational ClearQuest Project Tracker?

Rational ClearQuest Project Tracker is a Microsoft Project 2000 add-in, a software 
module that can be used to add additional Rational ClearQuest functionality to 
Microsoft Project 2000.

With Project Tracker, you can export tasks from a Microsoft Project 2000 project plan to 
automatically create new database records in Rational ClearQuest. The tasks are 
automatically linked with these new database records. You can then synchronize the 
corresponding tasks and records later in the project, so that changes made in one 
system can be automatically reflected in the other. 

You can also import records from Rational ClearQuest to create new project plan tasks 
in Microsoft Project 2000. These records and tasks are also linked so that you can 
continue to synchronize them periodically. In this way, progress reported in Rational 
ClearQuest can be transferred automatically to Microsoft Project 2000, so that a project 
manager can always update the project plan with the most accurate and up-to-date 
information.

Creating a Closed Loop Project Tracking System

By using Project Tracker, you can take full advantage of both project management and 
change management systems to create a closed loop project tracking system. 

A project manager can use a project management tool, Microsoft Project 2000, to create 
a high-level project plan. The plan specifies the major tasks that make up a project. It 
also identifies dependencies between the tasks, planned start and completion dates for 
the tasks, and other planning data. The project manager can update the plan as tasks 
are completed, resources are added or lost, or other factors change. 
1



A change management system, such as Rational ClearQuest, lets both managers and 
individual contributors enter new change requests for a project, including requested 
enhancements, defects, and documentation. They can also modify and close existing 
change requests, share information with each other, and create queries and reports to 
track individual change requests and the overall progress of the project.

However, using a project management tool and a change request system together can 
be extremely difficult. Under typical conditions, an immense amount of manual effort 
is required to keep corresponding tasks and records synchronized and up-to-date.

For example, if a project manager wants to update a project plan during the course of 
the project, the manager has to identify all of the new and modified change requests 
entered in the change management system by many different contributors. 

To keep a project plan updated, information must be obtained from many contributors. 
Project Tracker makes it easy to keep corresponding tasks and records synchronized. 

After the project manager collects all of this information, the manager must manually 
re-enter the data as new or modified tasks in the project management tool. Not only is 
this process time-consuming and error-prone, but the information is likely to be 
outdated before it can all be captured and entered. 

With Project Tracker, you will be able to automate most of the integration of 
information between Microsoft Project 2000 and the ClearQuest change management 
system. This saves the project manager time and makes sure that everyone on the team 
can work from accurate, up-to-date information and plans. 

The result is a closed loop project tracking system, where actual results and other input 
from individual contributors and managers working on the project can be fed into the 
project plan, while changes in the project plan are sent back to the individual 
contributors.
2 Using Project Tracker



Capabilities of Project Tracker 

Project Tracker provides a number of capabilities that automate the integration of a 
project plan created in Microsoft Project 2000 with a project database created in 
Rational ClearQuest. 

Linking a Project Plan with a Database

When you first set up a Microsoft Project 2000 project plan to work with Project Tracker, 
you create an association between that project plan and a corresponding ClearQuest 
database. This may be an existing database related to the same project as the project 
plan, or a new database just created for the project. The link ensures that future 
imports, exports, updates, and synchronizations are always performed against the 
same database. More information on linking is provided in Chapter 2, Linking a Project 
Plan with a ClearQuest Database.

Importing ClearQuest Records to Create New Microsoft Project Tasks

In Microsoft Project 2000, tasks are the building blocks of a project plan. Similarly, each 
record in the Rational ClearQuest database represents an activity that is a necessary 
part of a project. When Microsoft Project 2000 and Rational ClearQuest are both used 
to plan and track activities for the same project, in most cases each project plan task will 
correspond with a single record in the Rational ClearQuest database. 

With Project Tracker, you can create new tasks in a project plan from records in a 
ClearQuest database using the Import New Records from ClearQuest function. Fields 
in the newly created task are initialized from the ClearQuest record. The record and the 
task are automatically linked, so that future changes to one are reflected in the other 
when the project plan and the ClearQuest database are synchronized. More 
information on importing is provided in Chapter 3, Importing Records from ClearQuest.

Exporting Microsoft Project Tasks to Create ClearQuest Records

With Project Tracker, you can also take tasks in the project plan and use these to create 
new records in a ClearQuest database using the Export New Tasks to ClearQuest 
function. Fields in the newly created ClearQuest record are initialized from the project 
plan task. The task and the record are automatically linked, so that future changes to 
one will be reflected in the other when the project plan and the ClearQuest database 
are synchronized.
Chapter 1 - Overview of Project Tracker 3



The Import function creates new project plan tasks from records in ClearQuest. The 
Export function creates new records in ClearQuest from tasks in the project plan.

Note, however, that Project Tracker only creates new records in the ClearQuest 
database for nonsummary tasks in the project plan. Summary tasks, which represent 
an overall description of a collection of specific work steps, do not typically have a 
corresponding record in the ClearQuest database. Similarly, Project Tracker does not 
create database records for milestones, which indicate the completion of a project 
phase but do not represent a task in themselves. 

More information on exporting is provided in Chapter 4, Exporting Tasks from Microsoft 
Project 2000.

Updating and Synchronizing a Project Plan with a ClearQuest Database

Over the course of a project, changes may be made in project plan by the project 
manager, and in the Rational ClearQuest database by team managers and contributors. 
Project Tracker provides update and synchronize capabilities, so that changes to 
ClearQuest database records are reflected in the linked project tasks, and changes to 
project tasks are reflected in the linked ClearQuest database records.

The Update function updates project plan tasks from ClearQuest. The Synchronize 
function performs a bidirectional transfer of information between linked records and 
tasks. 

With Project Tracker, you can update the project plan by copying information from 
records in the ClearQuest database to linked tasks in the project plan. This keeps the 
project plan up-to-date by transferring information that was entered into ClearQuest 
by the individual contributors and managers working on the project.

Note that the Import function described earlier uses new ClearQuest records to create 
new Microsoft Project tasks, while in contrast the Update function works with existing 
records and tasks that were already linked.

You can also synchronize the project plan and the database. This involves a two-way 
flow of information (compared to the one-way transfer used in the update process). 

First, information is copied from records in the ClearQuest database to linked tasks in 
the project plan. Second, information is copied from tasks in the project plan to linked 
records in the ClearQuest database. 

At the end of this process, the project plan and the ClearQuest database are 
synchronized, with the same information included in every pair of linked tasks and 
4 Using Project Tracker



records. Not only does the project manager have the most up-to-date information from 
the individual contributors, but the contributors have the most up-to-date data from 
the latest project plan.

Note that the Export function described earlier uses new Microsoft Project tasks to 
create new ClearQuest records, while in contrast the Synchronize function works with 
existing tasks and records that were already linked.

During the Synchronize process, potential disagreements or conflicts are resolved 
through a set of rules. For example, planned start and planned completion dates are 
resolved in favor of the entries in the Microsoft Project task. This is because planned 
dates are typically driven by the project manager who creates the project plan. 

On the other hand, actual start and actual completion dates are resolved in favor of the 
entries in the ClearQuest record, because accurate, actual dates are entered into the 
ClearQuest database by the individual contributors who perform the work.

Also, a log file is available to help you track updated information and if necessary, 
reverse changes.

The update and synchronization processes are described in more depth in Chapter 5, 
Updating and Synchronizing.

Using the RUP Project Plans 

The Rational Unified Process (RUP) provides a best practices methodology for 
software development projects. RUP makes available a set of Microsoft Project plans 
that organize tasks according to the best practices methodology. 

You can use these plans as the starting point to create and customize project plans that 
reinforce RUP. When the project plans are complete, you can use Project Tracker to 
create records in a ClearQuest database that correspond to the tasks in the project plan.

If the Rational Unified Process is available on your system, you can access the RUP 
project plans by clicking Rational Unified Process > Templates > Microsoft Project. The 
RUP project plans are described in more depth in Appendix B, Using RUP Project Plans.
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Scenario 1: Starting with a New Project Plan 

One scenario for using Project Tracker is at the beginning of a new project. The project 
manager creates a new project plan in Microsoft Project, then uses that plan to create a 
new ClearQuest database. Ongoing changes to the database are then transferred to the 
project plan, and changes to the project plan are transferred to the database. 

All of the Project Tracker functions described in this scenario are available in Microsoft 
Project 2000 under the Tools > ClearQuest menu.

In Step 1 if this scenario, as shown in following diagram, the project manager creates a 
detailed project plan describing the tasks planned for the project.

In Step 2, the ClearQuest Administrator creates a new ClearQuest database, and then 
the project manager or the ClearQuest Administrator uses functionality available 
under the Tools > ClearQuest menu in Microsoft Project to link this database with the 
new project plan.
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In Step 3, the project manager uses the Export New Tasks to ClearQuest function to 
create database records from the project plan tasks. This also creates a link between 
each project tasks and each database record. 

In Step 4, team managers and individual contributors modify records in the 
ClearQuest database to record progress on actual work, and add new records so they 
can track previously unplanned work.

In Step 5, the project manager uses the Import New Records from ClearQuest function 
to automatically create new tasks from ClearQuest records that were added to the 
database. 

In Step 6, the project manager uses the Update Plan from ClearQuest function to 
update existing project plan tasks based on changed records in the ClearQuest 
database. 

In Step 7, the project manager adds new tasks and modifies existing tasks in the project 
plan.

In Step 8, the project manager uses the Export New Tasks to ClearQuest to 
automatically create new ClearQuest records from new tasks that have been added to 
the project plan

In Step 9, the project manager uses the Synchronize Plan with ClearQuest function to 
automatically update existing ClearQuest database records based on changed tasks in 
the project plan.

All of the Project Tracker functions described in this scenario are available in Microsoft 
Project 2000 under the Tools > ClearQuest menu.

Scenario 2: Integrating a Project Plan with an Existing 
ClearQuest Database

Another typical scenario for using Project Tracker is when a project plan and a Rational 
ClearQuest database have previously been created independently for the same project, 
and the project tasks and ClearQuest database records need to be linked.

The project manager imports ClearQuest database records to create new project plan 
tasks, then exports Microsoft Project project plan tasks to create new database records. 
Ongoing changes to the database are then transferred to the project plan, and changes 
to the project plan are transferred to the database. All of the Rational ClearQuest 
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Project Tracker functions described in this scenario are available in Microsoft Project 
2000 under the Tools > ClearQuest menu.

In Step 1, the project manager (or ClearQuest administrator) links the project plan with 
the existing ClearQuest database using the Link to ClearQuest Database function. 

This particular function is generally a one-time procedure and is only applied when a 
new project plan is created. After a project plan is linked to a ClearQuest database, the 
association remains permanent unless problems occur with the ClearQuest database. 
Make sure to contact the ClearQuest administrator if there are difficulties with the 
ClearQuest database.

In Step 2, the project manager uses the Import New Records from ClearQuest function 
to create new tasks in the project plan from existing ClearQuest database records.

In Step 3, the project manager uses the Export New Tasks to ClearQuest function to 
create new ClearQuest database records from existing project plan tasks. At this point, 
all of the tasks in the project plan (excluding summary tasks and milestones) are linked 
with corresponding records in the ClearQuest database.

In Step 4, team managers and individual contributors modify records in the 
ClearQuest database to record progress on actual work, and add new records so they 
can track previously unplanned work.

In Step 5, the project manager uses the Import New Records from ClearQuest function 
to automatically create new tasks from ClearQuest records that were added to the 
database. 

In Step 6, the project manager uses the Update Plan from ClearQuest function to 
update existing project plan tasks based on changed records in the ClearQuest 
database. 

In Step 7, the project manager adds new tasks and modifies existing tasks in the project 
plan.

In Step 8, the project manager uses the Export New Tasks to ClearQuest to 
automatically create new ClearQuest records from new tasks that have been added to 
the project plan

In Step 9, the project manager uses the Synchronize Plan with ClearQuest function to 
automatically update existing ClearQuest database records based on changed tasks in 
the project plan.

As in Scenario 1, Steps 4 through 9 can be repeated iteratively over the life of the 
project.
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How Team Members Create Records in a ClearQuest 
Database

To understand how information is exchanged between Microsoft Project 2000 and 
Rational ClearQuest, it is helpful to know how individual contributors and managers 
create records in a ClearQuest database. If you are already familiar with ClearQuest, 
you should proceed to Chapter 2, Linking a Project Plan with a ClearQuest Database.

Team members create records by entering data in forms generated by ClearQuest. The 
records are stored in the ClearQuest database. The forms are made up of tabs and fields 
that vary according to the type of activity being tracked. 

The Main and Schedule tabs that follow are examples of the two ClearQuest forms 
used for submitting information to Project Tracker. 
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Note that these forms can be customized for your environment by your ClearQuest 
administrator. As a result, the forms for your organization’s ClearQuest system may 
differ from these examples, with possibly, different fields and different names on the 
fields or the tabs.

The Main tab includes the Headline, Description, and Owner fields. The Schedule tab is 
divided in two sections and includes fields for planned and actual dates.

The Planned section in the Schedule tab includes mostly read-only fields that store 
scheduling data provided from the project plan. The Actual section contains data that 
is provided and updated by the team member using ClearQuest. 

When the project manager imports records from ClearQuest to create new tasks, 
information entered in the records’ Main tab and in the Actual section of the Schedule 
tab is copied over into the project plan. 

When the project manager exports tasks to create new records in ClearQuest, 
information is copied into the records’ Main tab and into the Planning section of the 
Schedule tab. The import and export processes are described in Chapter 3, Importing 
Records from ClearQuest and Chapter 4, Exporting Tasks from Microsoft Project 2000. 

ClearQuest also assigns a unique identification (ID) number for every record. When a 
record in ClearQuest or a task in Microsoft Project 2000 are created using Project 
Tracker, a unique ID is assigned. This ID is used to link the ClearQuest record with its 
associated project plan task, so that information continues to be exchanged between 
them when the project manager uses the update or synchronize processes described in 
Chapter 5, Updating and Synchronizing.
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2Linking a Project Plan 
with a ClearQuest 
Database
This chapter describes how to link a Microsoft Project plan with a Rational ClearQuest 
database so that you can exchange information between them.

You only go through this process the first time you want to exchange information 
between a project plan and a ClearQuest database. After the link is established, 
Rational ClearQuest Project Tracker exchanges information between the linked project 
plan and the linked ClearQuest database.

Also, you can only link a project plan to one ClearQuest database. After a link is made 
it cannot be removed.

Note that before you can use Project Tracker, a number of installation steps must be 
performed by the ClearQuest administrator. These steps are described in Appendix A, 
Setting Up and Configuring Project Tracker.

You may want the ClearQuest administrator to work with you the first time you go 
through this process, so that you both can make sure that the prerequisites have been 
met and that everything is working properly.

Selecting the ClearQuest Database

The first step in linking a Microsoft Project 2000 project plan with a ClearQuest 
database is to open your project plan and select the correct database.

To select a ClearQuest database:

1 Open the Microsoft Project project plan.

2 Click Tools > ClearQuest > Link to ClearQuest Database. The ClearQuest Login 
window appears.

3 Log on to the appropriate ClearQuest database by providing your user name, 
password, and the ClearQuest database name and click OK. This establishes which 
ClearQuest database is associated with the project plan.
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Choosing Fields to Store ClearQuest Data

After you select the ClearQuest database, the Assign Custom Fields window 
automatically appears. This window lets you establish which fields in Microsoft 
Project 2000 are used to store ClearQuest related data. 

Microsoft Project 2000 ships with several extra fields predefined precisely to let users 
and tool vendors enhance the functionality of the application. These fields are labeled 
Text1, Text2, and so on. You must select three of these fields to be used by Project 
Tracker. You should pick three that are not already being used for your project by some 
other integration with Microsoft Project.

In the Assigns Custom Fields window, choose the project plan fields to store 
ClearQuest related data by clicking the three unused fields and then clicking OK. 
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Configure Your View in Microsoft Project 2000 to Display 
ClearQuest Related Data 

After selecting the Microsoft Project fields used to store ClearQuest related data, you 
are prompted to add columns to your Microsoft Project 2000 view. This is a standard 
Microsoft Project operation, described in the Help for Microsoft Project 2000.

To add columns to your Microsoft Project 2000 view:

1 Select a column that is already in the view. 

The new columns are added in front of this selected column. We recommend 
selecting the third column, so that new fields appear immediately after the Task 
Name column.

2 Click Insert > Insert Column or right-click the column heading and select Insert 
Column from the shortcut menu. 

The Column Definition window appears, prompting you to select a field for the 
new column.

3 Specify the Field name, CQ Record, and click OK.

A new column appears in the project plan with the title, CQ Record.

4 Repeat these steps to add a column for the CQ Type field. The project plan displays 
the CQ Record and CQ Type columns.
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Note: You can easily remove (hide) a column in much the same way – see the Microsoft 
Project 2000 Help for more instructions.

Updating the ClearQuest Record Types

Before you are ready to start exchanging data between ClearQuest and Microsoft 
Project 2000, you need to establish which ClearQuest record types will be available.

Click Tools > ClearQuest > Updating the ClearQuest Record Types List and click OK. 

This function finds which record types are enabled for use with Project Tracker (by 
virtue of having the appropriate ClearQuest packages applied to the record types).

This function populates a list of values available for the CQ Type field in Microsoft 
Project 2000 and ensures that the values are accurate. The value of this field controls, 
which kind of ClearQuest record should be created, for the given Microsoft Project 
2000 task.
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3Importing Records 
from ClearQuest
This chapter tells you how to import records from a Rational ClearQuest database to 
create new tasks in a project plan.

The chapter describes the following:

■ How to perform the basic steps for importing ClearQuest records into the project 
plan. 

■ How to create and use queries that select exactly which ClearQuest database 
records you want to import. 

■ How to save and review log files created during the import process.

Chapter 4, Exporting Tasks from Microsoft Project 2000 describes the inverse process of 
exporting tasks from a project plan to create new records in a ClearQuest database.

As noted in Chapter 1, Overview of Project Tracker, the Import function uses new 
ClearQuest records to create new Microsoft Project tasks, while in contrast the Update 
function works with existing records and tasks that were already linked. The Update 
function is described in Chapter 5, Updating and Synchronizing.

Accessing Rational ClearQuest Project Tracker
from Microsoft Project 2000

After Rational ClearQuest Project Tracker is installed and you open Microsoft Project 
2000, you can access the main functions by clicking Tools > ClearQuest. The main 
functions are:

■ Update Plan From ClearQuest

■ Synchronize Plan With ClearQuest

■ Export New Tasks To ClearQuest

■ Import New Records From ClearQuest

■ Link To ClearQuest Database

■ Update ClearQuest Record Types List
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Importing Records from a ClearQuest Database 

With the import process, you can create a new project plan quickly by building on the 
detailed information available in a ClearQuest database, or you can automatically add 
new tasks to an existing project plan.

To create new project plan tasks from ClearQuest records:

1 Launch Microsoft Project 2000 and open the project plan.

2 Click Tools > ClearQuest > Import New Records from ClearQuest. 

The Select Records to Import window appears. This window lets you select an 
existing query against the ClearQuest database or create a new query (see Creating 
and Using Queries for Imports on page 21). When you run a query, Project Tracker 
displays the query results from the ClearQuest database.

Note: If the Rational ClearQuest Login window appears instead, associate the 
project plan with the ClearQuest database. These steps are described in Chapter 2, 
Linking a Project Plan with a ClearQuest Database.

3 After you locate or create the desired query, click Run to execute the query against 
the ClearQuest database. The results of your query then appear.

4 If you want to review a particular record before importing it into your project, 
Project Tracker lets you access the actual record forms stored in the ClearQuest 
database. Double-click on the record in the Select Records to Import window. 
Close the record’s window to continue importing. 

5 Select the records you want to import and click OK.

Click New Query to
access the Query Wizard
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Note: Make sure to highlight the records you want to import, Project Tracker 
imports only the selected ClearQuest records.

The Import New ClearQuest Records To MS Project Plan Tasks window then 
appears. It lets you start the import process.

6 Click Start. 

The Import New ClearQuest Records To MS Project Plan Tasks window lists the 
tasks being created as the records are being copied over from the ClearQuest 
database. The Progress window lists the ID and name of each record being 
imported. 

7 Click Close when you are finished importing and want to return to your project 
plan.

Matching Resources with ClearQuest Users

During the Import process, Project Tracker checks each ClearQuest record to see that 
the entry in the Owner field (sometimes called the ClearQuest user field) matches one 
of the Resource names already in use in the project plan. If it encounters an Owner 
name in a ClearQuest record that is not in use in the project plan, it interrupts the 
import process and displays the Select Resource Matching CQ User window. 
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If you see a Resource name that is equivalent to the Owner field in the linked 
ClearQuest record, select that name from the list and click Change Resource Name. For 
example, if the ClearQuest user is lead, and you know that QE Manager is the equivalent 
name in the project plan, select QE Manager and click the Change Resource Name.

When you change the Resource Name, Project Tracker replaces the entry that was in 
the Owner field of the ClearQuest database record, into the Resource name field of the 
project plan task. It does not use the Resource name you selected in the Select Resource 
matching CQ user window. 

In the preceding example, Project Tracker puts lead in the Resource name field, even 
though you selected QE Manager before clicking Change Resource Name. 

It may seem counter-intuitive that the project plan’s Resource name is changed, but 
this happens for the following reasons: 

■ At the end of the process, the Owner field in the database record and the Resource 
name field in the project plan task must have the same entry.

■ The Import process can not change the value in the ClearQuest database.

In this situation, Project Tracker also changes the Resource name in the list of valid 
Resource names (in this example from QE Lead to admin). You can see this by clicking 
Tools > Resources > Assign Resources. 

This change is made to make sure that the same Resource name (admin) is used 
consistently for future tasks and records in both the project plan and the ClearQuest 
database. 
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If you do not see a matching resource name, you can select Create Resource. Project 
Tracker fills in the Resource name field in the project plan task with the entry that is in 
the Owner field of the ClearQuest Record. It also adds the new entry to the list of 
Resource names used in the project plan. Again, you also can see this list by clicking 
Tools > Resources > Assign Resources. 

If you click Create All Resources, then Project Tracker automatically fills in the 
Resource name field in the project plan task with the entry that is in the Owner field 
for all of the ClearQuest database records that are being imported. 

Project Tracker does not display the Select Resource matching CQ user window again 
during that import process. Before clicking the Create All Resources, make sure that 
you do not want to use the Change Resource Name function for any other record that 
you want to import.

Saving and Viewing the Log File

As Project Tracker imports the ClearQuest records, it creates a progress log listing each 
record and the value of each field that is transferred.

You can save the log as a Rich Text Format (.rtf) file and review it to make sure that all 
of the information that was imported is appropriate and in the correct format for your 
project plan. You can open the saved file using any type of text editor or word 
processor.

It is also a good idea to keep all log files in their own folder in case questions arise about 
tasks created by the import process.

To save and read the progress log file, click Save Log in the Import New ClearQuest 
Records To MS Project Plan Tasks window and specify the filename and directory path 
for the log file. 
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Viewing New Tasks in the Microsoft Project Plan

As Project Tracker imports the records selected by the query into the project plan, it 
creates new project tasks. Information from the following ClearQuest fields is copied 
to create a corresponding project plan task:

■ Task Name/Headline

■ Assigned Resource

■ Actual Work

■ Planned Work

■ Remaining Work

■ Actual Start Date

■ Actual Finish Date

When Project Tracker finishes converting the ClearQuest records, the newly created 
tasks appear at the end of the project plan.You can reposition the new tasks anywhere 
in the project plan, as long as they remain nonsummary tasks.

The new tasks include a CQ Type value. This value describes the type of record that 
was imported as defined in ClearQuest, for example Defect or Enhancement. 

The project plan is now updated to reflect the new tasks imported from the ClearQuest 
database.
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Creating and Using Queries for Imports

A query is a request to retrieve database records that meet specified criteria, for 
example all records of a certain type, or all records where the value in a field equals or 
exceeds a specified value, or all records created after a certain time.

Project Tracker lets you:

■ Run a query that you created in the past

■ Run a public query created by someone else

■ Modify and run an existing query, either one you created or a public query

■ Create and run a new query using the ClearQuest Query Wizard

The queries used by Project Tracker are exactly the same as normal ClearQuest queries, 
and in fact may be queries created earlier using ClearQuest. If you are not familiar with 
the process of creating and using database queries, you should review the Introduction 
for Rational ClearQuest. For more information on running a query, see the Help in 
Rational ClearQuest.

To open a ClearQuest query window, click Tools > ClearQuest > Import New Records 
from ClearQuest. 

The Workspace section at the top of the window lets you select personal queries that 
you created previously or existing public queries that were created by the system 
administrator or someone else and were made available to you and others using the 
system.
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You can select an existing personal or private query and then click Run to execute the 
query. If you want to see the criteria used to create the query before you run it, click 
Edit. When you create or select the query, click Run to execute. As noted earlier, Project 
Tracker displays the records retrieved from the ClearQuest database by your query. 

Saving a Master Copy of the Project Plan

It is strongly recommended that you keep a secure master copy of the last official 
version of the Microsoft Project project plan and always use this master copy for 
importing, exporting and for other Project Tracker functions.

In some situations, you may want to distribute several copies of the project plan, 
perhaps to multiple project managers. However, you can not safely export records 
from each of these copies to the ClearQuest database, because changes in one copy of 
the project plan may conflict with changes in another version. The lead project 
manager must take the responsibility of integrating changes from all sources into the 
master copy of the project plan and using this master copy to export to the ClearQuest 
database. 

The same logic applies to the other functions of Project Tracker. Keep a secure master 
copy of the project plan, integrate all changes into this copy, and make sure that all 
importing, exporting, updating and synchronizing are carried out between this version 
of the project plan and the ClearQuest database.
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4Exporting Tasks from 
Microsoft Project 2000
This chapter describes how to export tasks from a project plan to create new records in 
a Rational ClearQuest database.

The chapter also describes how to save and review log files created during the export 
process. It concludes with notes about how certain fields in your project plan and 
ClearQuest database are affected by the export process.

As noted in the first chapter, the Export function uses new Microsoft Project tasks to 
create new ClearQuest records, while in contrast the Synchronize function works with 
existing tasks and records that were already linked. The Synchronize function is 
described in Chapter 5, Updating and Synchronizing.

CQ Record Types and Required Fields

Before describing the Export process, it is useful to understand CQ Record Types and 
the concept of required fields for ClearQuest records.

When you export project plan tasks to create new ClearQuest database records, you 
must select a CQ Record Type for each new record.

Depending on the record type selected, you may also need to enter values in additional 
required fields for that record type. For example, if you are exporting a task and you 
select Enhancement Request as the CQ Record Type, you need to enter a customer 
name and a customer priority for that record. In order to enter the information, you use 
a series of ClearQuest forms, known as submit forms.

Individual contributors and team managers working with ClearQuest use the CQ 
record type and required fields to find and analyze records in the database. For 
example, a manager might want to create a report of all of the recent enhancement 
requests, and sort the requests by priority. This is only possible if, during the Export 
process, you identified tasks that represent enhancement request as 
EnhancementRequest record types and make an entry (High, Medium, or Low) in the 
Customer Priority field.
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Exporting Tasks from a Project Plan to Create ClearQuest 
Records

Tasks from a project plan can be exported from Microsoft Project 2000 to create new 
records in the Rational ClearQuest database. This lets you:

■ Add new records to a ClearQuest database based on information in a project plan.

■ Keep the ClearQuest database continuously updated based on new tasks added to 
the project plan during the life of the project.

To export the project plan tasks:

1 Launch Microsoft Project 2000 and open the project plan.

2 In the CQ Type field for a particular task, select a valid record type from the list. 
Repeat this for each task you want to export.

3 Select the tasks that you want to export to the ClearQuest database.

Make sure to select the tasks you want to export. Rational ClearQuest Project 
Tracker only exports the selected tasks.

4 Click Tools > ClearQuest > Export New Tasks To ClearQuest. 

The Export New Project Plan Tasks to ClearQuest window appears.
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5 Click Start. 

6 If there are required fields for any of the record types that you are exporting, 
Project Tracker displays a message asking if you want to add data to the new 
record being created. 

If you click No, the task will not be exported to the ClearQuest database (although 
it will remain in the project plan).

If you click Yes, Project Tracker displays the forms used in ClearQuest to submit 
and modify data for that record type.

7 On the ClearQuest forms, tabs that include a required field are marked by a red 
square. The names of the required fields are highlighted in red. 

Click on each of the tabs with a red square, then make an entry in each required 
field. You can also enter information in the other fields on these forms if you know 
the correct information. 
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8 After you complete the required fields for all of the tasks being exported, Project 
Tracker begins the export process and displays the name of each task being 
exported in the Progress window.

9 Click OK to save the changes to the ClearQuest database and to your project plan.

Required fields always
appear in red

Click on tabs marked
with red squares to
enter information
in required fields

Req
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10 Check the Show all logged information box at any time during the export process if 
you want to display full details about a task and its values.

You can check or clear the Show all logged information box at any time before or 
during the export process. When it is checked, the Progress window displays 
information on each field in each task being exported, including the value of the 
field. When the box is cleared, the Export New Microsoft Project Plan Tasks To 
ClearQuest window displays only the name of the task being copied to the 
ClearQuest database.

After the export process is complete, Project Tracker displays a message advising 
you to save the changes to the project plan. Clicking OK makes the changes 
permanent in the ClearQuest database. Clicking Cancel prevents the new records 
from being saved in the ClearQuest database.

11 During the Export process, Project Tracker checks each project plan task to see that 
the entry in the Resource name field matches one of the Owner field entries 
already in use in the ClearQuest database (the Owner field is also sometimes 
called the ClearQuest user field). 

If it encounters a Resource name in a project plan task that is not in use in the 
ClearQuest database, Project Tracker interrupts the export process and displays 
the Select Matching ClearQuest User window. 

If you see an Owner name that is equivalent to the Resource field in the linked 
project plan task, select that name from the list and click OK. 
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For example, if the project plan Resource name is user, and you know that Associate 
is the equivalent Owner name in the ClearQuest database, select user and click OK.

Note that when you click OK, Project Tracker takes the entry that was in the Owner 
field of the ClearQuest database record and replaces it into the Resource name 
field of the project plan task. 

In the preceding example, this means it places user in the Resource name field of 
the project plan task you were exporting. This is to make sure that at the end of the 
process the Owner field in the database record and the Resource name field in the 
project plan task have the same entry. Project Tracker also changes the Resource 
name in the list of valid Resource names to make sure that the same Resource 
name (user) is used consistently for future tasks and records in both the project 
plan and the ClearQuest database. 

If you do not see a matching User name, click Cancel. This cancels the exporting of 
that project plan task. Contact your ClearQuest Administrator to create the correct 
User name in the ClearQuest database.

12 When you return to the Exporting New Microsoft Project Plan Tasks window, click 
Save Log, to save the information in a Rich Text Format (.rtf) file (see Saving and 
Viewing the Log File on page 19).

13 Click Close when exporting is complete and you want to return to your project 
plan. 

The task you exported displays a unique CQ Record ID.

Saving a Master Copy of the Project Plan

It is strongly recommended that you keep a secure master copy of the last official 
version of the Microsoft Project project plan and always use this master copy for 
importing, exporting, and other Project Tracker functions.

In some situations, you may want to distribute several copies of the project plan, 
perhaps to multiple project managers, however, you can not safely export records from 
each of these copies to the ClearQuest database, because changes in one copy of the 
project plan may conflict with changes in another version. The lead project manager 
must take the responsibility of integrating changes from all sources into the master 
copy of the project plan and using this master copy to export to the ClearQuest 
database. 
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The same logic applies to the other functions of Project Tracker. Keep a secure master 
copy of the project plan, integrate all changes into this copy, and make sure that all 
importing, exporting, updating, and synchronizing are carried out between this 
version of the project plan and the ClearQuest database.

Viewing New Records in the ClearQuest Database

Project Tracker creates a new ClearQuest record for each task and transfers the 
following fields from the Microsoft Project 2000 task to the record:

■ Task Name
■ Planned Start Date
■ Planned Finish Date
■ Planned Work
■ Actual Work
■ Remaining Work
■ Actual Start Date
■ Actual Finish Date
■ Assigned Resource

When Project Tracker finishes exporting the project plan tasks, the newly created 
records are listed in the ClearQuest database.

The planned start and end dates from the project plan task appear on the Schedule tab 
of the ClearQuest form for this record. These fields cannot be modified by the team 
member using ClearQuest, because these dates are the responsibility of the project 
manager who creates the project plan, not the team member using ClearQuest.

Additional Information About Exporting

Assigning Resources

Microsoft Project 2000 allows several resources to be assigned to a task, while Rational 
ClearQuest allows only one resource to be assigned. If more than one resource is listed 
in the project plan task, Project Tracker carries over only the first one.
Chapter 4 - Exporting Tasks from Microsoft Project 2000 31



Summary Tasks and Milestones and Are Not Exported

As described in Chapter 1, Overview of Project Tracker, Project Tracker does not export 
Microsoft Project 2000 summary tasks or milestones. A summary task is a collection of 
detail tasks that is used to summarize a phase of a project, but does not involve work 
independent of the detail tasks that it summarizes. A milestone is point that marks a 
significant event or deadline, but it has neither work nor duration associated with it. 
Therefore, Project Tracker creates ClearQuest database records for detail tasks, but not 
for summary tasks or milestones.

Changing Field Values by Owners

After a task is exported to ClearQuest, some, but not all, of the fields in the resulting 
record can be modified by the owner of the record. 

The owner is the team member responsible for performing the task. The fields available 
for changing are those where the team member is likely to have correct information, 
such as the actual start date and the remaining work. The fields not available for 
changing are those where the project manager is most likely to have correct 
information, such as the planned start and end date.

Entering Required Fields When the Task Has No Entry

When the field in a task is blank and that field corresponds to a required field in the 
ClearQuest database record, Project Tracker prompts you for an entry. When you make 
an entry, that value is included in the database record, but the field in the project plan 
task is still blank. If this situation occurs, you may want to run the Update or the 
Synchronize function to assure that the task and the record have the same value (the 
Update and Synchronize functions are described in Chapter 5, Updating and 
Synchronizing).

For example, if the Owner field is blank in the project plan task, during the Export 
process you may be prompted to enter a name for this field, because Owner is a 
required field in the ClearQuest database record. Your entry is included in the new 
database record created by the Export process, but the field in the project plan task 
remains blank. If you want the project plan task to include the same information as the 
database record, you need to run the Update or Synchronize function.
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5Updating and 
Synchronizing 
This chapter outlines the basic steps for updating project plan tasks from Rational 
ClearQuest database records, and how to save and view the log files. It describes the 
basic steps for a bidirectional synchronizing of the project plan and the ClearQuest 
database. 

The chapter also describes the rules that are used to resolve conflicts that occur during 
updates and synchronization, when the same information is changed independently in 
the two systems.

Note that the Update and Synchronize functions do not automatically handle deleted 
tasks or records. The issues concerning deletions are described in Chapter 6, Additional 
Administrative Procedures.

Synchronizing Compared with Updating

Synchronizing the project plan with the ClearQuest database is very similar to 
updating the project plan. The main difference is that the Update Plan From 
ClearQuest function is a one-way transfer of information, with updates flowing only 
from the ClearQuest database to the project plan. 

The synchronize process is a two-way transfer of information, with updates flowing 
first from the ClearQuest database to the project plan, and then from the project plan 
back to the ClearQuest database. In the end, the linked records and tasks share the 
same information.
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Updating Linked Project Plan Tasks with ClearQuest 
Records

During the life of a project, team members change information in ClearQuest database 
records. 

For example, a team member may specify new dates in the actual start and end date 
fields provided in the Schedule form of the ClearQuest record. 

If the ClearQuest records are already linked to specific tasks in the project plan, then 
the Update Plan from ClearQuest function lets you automatically update the linked 
tasks with the changed information in the ClearQuest records.

The task fields that will be updated from the ClearQuest record are:

■ Task Name/Headline
■ Assigned Resource
■ Actual Work
■ Planned Work
■ Remaining Work
■ Actual Start Date
■ Actual Finish Date

To update the project plan tasks from ClearQuest records:

1 Launch Microsoft Project 2000 and open the project plan.

2 Click Tools > ClearQuest > Update Plan from ClearQuest. Project Tracker displays 
the window used for updating. 
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3 Check the Show all logged information check box if you want to display details 
about the update any time before or during the update process. 

When this box is checked, the Progress window displays information on each 
value being updated with new information. When the box is not checked, the 
Progress window displays only the name of the task being updated.

4 Click Start.

5 During the Update process, Project Tracker checks each ClearQuest record to see 
that the entry in the Owner field (sometimes called the ClearQuest user field) 
matches one of the Resource names already in use in the project plan. If it 
encounters an Owner name in a ClearQuest record that is not in use in the project 
plan, it interrupts the update process and displays the Select Resource matching 
CQ user window. 

If you see a Resource name that is equivalent to the Owner field in the linked 
ClearQuest record, select that name from the list and click Change Resource Name. 

If you do not see a matching resource name, click Create Resource, and Project 
Tracker fills in the Resource name field in the project plan task with the entry that 
is in the Owner field of the ClearQuest Record. 

If you click Create All Resources, then Project Tracker automatically fills in the 
Resource name field with the entry that is in the Owner field, for all of the other 
ClearQuest database records that are being used in the update process. For a more 
detailed description of these options, see the Matching Resources with ClearQuest 
Users section in Chapter 3, Importing Records from ClearQuest.
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6 Click Save Log to store the log as a Rich Text Format (.rtf) file after the update 
process is completed, if you wish to have a copy of all the transactions. 

You can open the saved .rtf file using any text editor or word processor. (For more 
information, see Saving and Viewing the Log File on page 19.)

7 Click Close when you finish updating and want to return to the project plan.

Synchronizing the Project Plan with the Database

During the life of a project, you may be updating the project plan to respond to changes 
in requirements, priorities, and resources. The Synchronize Plan with Rational 
ClearQuest function lets you convey this changed planning information to members 
through Project Tracker.

For example, if revising the project plan changes the Planned Start Date and Planned 
End Date for some tasks, the synchronize process copies those changes to the 
appropriate records in the ClearQuest database. When team members next run a To Do 
List query against the ClearQuest database, they see a list of tasks that are scheduled 
for the future, and the records for those tasks include the updated planning dates.

Project Tracker first pulls information from linked ClearQuest database records in 
order to update the following values in the project plan tasks:

■ Task Name/Headline
■ Assigned Resource
■ Actual Work
■ Planned Work
■ Remaining Work
■ Actual Start Date
■ Actual Finish Date

Project Tracker then takes information from the following values in the project plan 
task and uses them to update the linked ClearQuest database records:

■ Task Name/Headline
■ Assigned Resource
■ Planned Start Date
■ Planned Finish Date
■ Planned Work
■ Remaining Work
■ Planned Duration
■ Remaining Duration
■ Actual Work
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■ Actual Start Date
■ Actual Finish Date

Making Changes to Both ClearQuest and Project Plan

The Synchronize Plan with Rational ClearQuest function must be used with caution, 
because it makes changes to both the ClearQuest database and the project plan. After 
the changes are saved to the ClearQuest database, you need the help of the ClearQuest 
administrator to make any corrections.

Synchronizing Linked Tasks and Records

To synchronize the Rational ClearQuest database and the project plan:

1 Launch Microsoft Project 2000 and open the project plan.

2 Click Tools > ClearQuest > Synchronize Plan With ClearQuest.

Project Tracker displays the Synchronize Microsoft Project Plan Tasks And 
ClearQuest Records window.

3 Check the Show all logged information check box if you want to display details 
about the changed values. Again, you can check or uncheck the Show all logged 
information check box at any time before or during the Synchronize process.

4 Click Start. 

As each task is synchronized, you see the log transactions that are created. 
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Matching Resources with CQ Users

During the Synchronize process, Project Tracker twice compares entries in the Owner 
field of ClearQuest database records with the corresponding entries in the Resource 
name field of the linked Microsoft Project project plan tasks to make sure they are the 
same. 

This happens first when the Synchronize process pulls modified database records to 
update project plan tasks, and again then the process pulls modified project tasks to 
update database records.

In the first part of the Synchronize process, Project Tracker checks each ClearQuest 
record to see that the entry in the Owner field (sometimes called the ClearQuest user 
field) matches one of the Resource names already in use in the project plan. If it 
encounters an Owner name in a ClearQuest record that is not in use in the project plan, 
it interrupts the synchronize process and displays the Select Resource matching CQ 
user window. 

If you see a Resource name that is equivalent to the Owner field in the linked 
ClearQuest record, select that name from the list and click Change Resource Name. 

If you do not see a matching resource name, you can click Create Resource, and Project 
Tracker fills in the Resource name field in the project plan task with the entry that is in 
the Owner field of the ClearQuest Record. 

If you click Create All Resources, then Project Tracker automatically fills in the 
Resource name field in the project plan task with the entry that is in the Owner field 
for all of the other ClearQuest database records that are being used in the synchronize 
process. For a more detailed description of these options, see Matching Resources with 
ClearQuest Users on page 17.

During the second part of the Synchronize process, Project Tracker checks each project 
plan task to see that the entry in the Resource name field matches one of the Owner 
field entries, already in use in the ClearQuest database. If it encounters a Resource 
name in a project plan task that is not in use in the ClearQuest database, it interrupts 
the Synchronize process and displays the Select Matching ClearQuest User window. 
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If you see an Owner name that is equivalent to the Resource field in the linked project 
plan task, select that name from the list and click OK. 

Note that when you click OK, Project Tracker takes the entry that was in the Owner 
field of the ClearQuest database record and places that entry back into the Resource 
name field of the project plan task. This is to make sure, that at the end of the process, 
the Owner in the database and the Resource name in the project plan task have the 
same entry. Project Tracker also changes the Resource name in the list of valid Resource 
names to make sure that the same Resource name is used consistently for future tasks 
and records in both the project plan and the ClearQuest database. 

If you do not see a matching User name, click Cancel. This cancels the synchronizing 
of that project plan task. You should contact your ClearQuest Administrator to create 
the correct User name in the ClearQuest database.

Saving and Viewing the Log File

After the synchronize process is complete, Project Tracker advises you to save changes 
to the project plan. Because the changes to the ClearQuest database are already 
committed, you should save the changes to the project plan. This ensures that 
information shared between the ClearQuest database and the project plan remains 
consistent. 

1 Click OK to save the project plan. The Planning Wizard window appears.

2 In the Planning Wizard window, check whether you want to save the project plan 
with or without a baseline and click Save. The Synchronize Microsoft Project Plan 
Tasks With ClearQuest Records window returns. 
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3 Click Save Log if you want to save the log as a Rich Text Format (.rtf) file. You can 
open the saved file using any type of text editor or word processor. 

4 Click Close when you are finished synchronizing and want to return to the project 
plan.

Rules for Resolving Conflicting Information

Sometimes conflicting information is encountered when updating or synchronizing 
the project plan with the ClearQuest database. This occurs when the same information 
is changed independently in the two systems. For example, the project manager might 
change the start date for a task in Microsoft Project 2000, while an individual 
contributor responsible for that task might enter a different date in the ClearQuest 
database. 

To address this problem, Project Tracker applies a set of synchronization rules designed 
to determine the winner based on the who is most likely to have the best information 
or make the best decision. 

In the preceding example, the same information was changed independently in 
Microsoft Project 2000 and in ClearQuest. Because the individual contributor assigned 
to the task is in the best position to know the actual start date, the rule in Rational 
ClearQuest Project Tracker is that the contributor's decision wins for this field. 

In applying this rule, the Update Plan From ClearQuest function and the Synchronize 
Plan with ClearQuest function copy the Actual Start Date from the ClearQuest 
database into the corresponding project plan field. 

There are also rules, of course, where the decision of the project manager wins. For 
example, because the project manager is responsible for planning, the Planned Start 
Date always comes from the entry in the Microsoft Project task.

The synchronization rules followed by Project Tracker are shown in the following 
table. This table indicates which fields can be updated in Microsoft Project 2000 and in 
ClearQuest, and which entry is the winner if there is a conflict.
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The Description field is not changed in the project plan or the ClearQuest database.

Overriding the Synchronization Rules

In some cases, you may want to override the synchronization rules applied by Project 
Tracker. To do this, you may need to view the log of the tasks that have been updated 
or synchronized (see Saving and Viewing the Log File on page 19), then manually update 
the affected tasks and records using Microsoft Project 2000 and ClearQuest.

Field name
Can be updated in 
Microsoft Project

Can be updated in 
ClearQuest

Winner if 
conflict

Task Name/Headline Yes Yes ClearQuest

Planned Start Date Yes No -

Planned Finish Date Yes No -

Planned Work Yes Yes ClearQuest

Remaining Work Yes Yes ClearQuest

Planned Duration Yes No -

Remaining Duration Yes No -

Actual Work Yes Yes ClearQuest

Actual Start Date Yes Yes ClearQuest

Actual Finish Date Yes Yes ClearQuest
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6Additional 
Administrative 
Procedures
This chapter describes administrative procedures you may need to keep data correctly 
synchronized between the project plan and the Rational ClearQuest database, along 
with additional information that you can use for troubleshooting.

Using Functions Together to Ensure Updated Information

Updating and Synchronizing Apply Only to Linked Tasks and Records

The Update and Synchronize functions work only with tasks that are already linked to 
records during an import or export process. New tasks and new database records (that 
is, tasks that do not yet have a linked record, and records that do not yet have a linked 
task) are ignored by these functions. 

To make sure that a project plan and a ClearQuest database are fully updated, you may 
need to use more than one function at a time.

Import and Update to Update a Project Plan

If individual contributors added new records to the ClearQuest database, you want 
them to be transferred to the project plan as new tasks, however, any records that were 
added since the last use of the Import function are ignored by the Update and 
Synchronize functions, because they are not yet linked to project plan tasks.

Therefore, to make sure that both new and modified records in the ClearQuest 
database are reflected in the project plan, you may need to first use the Import function 
to transfer the new records, and then use the Update function to capture changed 
information from existing records. 

Export and Synchronize to Update a ClearQuest Database

If the project manager added new tasks to the Microsoft Project 2000 project plan, you 
want these tasks to be transferred to the ClearQuest database as new records, however, 
any tasks that were added since the last use of the Export function are ignored by the 
Synchronize function, because they are not yet linked to a database record.
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Therefore, to make sure that both new and modified tasks are reflected in the 
ClearQuest database, you may need to use the Export function to transfer the new 
tasks, then use the Synchronize function to capture changed information from existing 
tasks.

Updating the ClearQuest Record Types List

When records are being imported into Microsoft Project, Project Tracker checks to 
make sure that, in the new tasks being created, only valid ClearQuest record types are 
inserted in the CQ Type field.

However, during the life of a project the ClearQuest systems administrator may add 
new record types to the ClearQuest database and may remove obsolete ones. If this 
happens, you need to run the Updating the ClearQuest Record Types List function. 

When you run this function, Project Tracker updates the ClearQuest Records Type List 
for that project plan to include new entries on the list of valid record types. 

Alternatively, you can convert the record type for a new task to one of the types already 
on the list, however, you must do one or the other or you are not allowed to import the 
record.

To run the Updating the ClearQuest Record Types List, click Tools > ClearQuest >  
Update ClearQuest Record Types List.

Deleting Tasks and Records

Deleting a Task from the Project Plan

Great care is required when a task is deleted from the project plan. In some cases you 
may want to delete the ClearQuest record that corresponds to the deleted task. In other 
circumstances it may be preferable to leave the record in place. Perhaps some work was 
done on this item even though it is no longer needed in the project plan, or perhaps the 
work is being transferred to another project.

When you delete a task from the project plan, Project Tracker does not delete the 
corresponding ClearQuest record. You can leave the ClearQuest record in the database, 
or you can remove it manually in ClearQuest. Whatever choice you make, you must be 
very careful to track all of the tasks deleted from the project plan and take the correct 
action in each case.

The log created by the Update and Synchronize functions includes a message that 
indicates when a linked task can not be found for a ClearQuest database record. 
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Consult the log to find these messages and make sure that the appropriate result was 
achieved. 

Deleting a Record from the ClearQuest Database

Great care also is required when a record is deleted from the ClearQuest database. In 
some cases you may want to delete the project plan task that corresponds to the deleted 
record. In other circumstances it may be preferable to leave the task in place.

When you delete a record from the ClearQuest database, Project Tracker does not 
delete the corresponding project plan task. You can leave the task in the project plan, 
or you can remove it manually in Microsoft Project 2000. Whatever choice you make, 
you must be very careful to track all of the records deleted from the ClearQuest 
database and take the correct action in each case.

The log created by the Update and Synchronize functions includes a message that 
indicates when a linked ClearQuest database record can not be found for a task. 
Consult the log to find these messages and make sure that the appropriate result was 
achieved. 

Additional Considerations

Changing Required Fields in ClearQuest

If the ClearQuest administrator changes the ClearQuest database schema to add new 
required fields or make existing fields required, he or she must work closely with the 
project manager to make sure that every task in the Microsoft Project project plan has 
an entry in this field.

If one of the tasks in the Microsoft Project project plan does not have an entry in the 
newly created required field, then that task can not be exported or synchronized. 
Project Tracker displays an error message and fails to export or synchronize that task.

Avoiding Nested Project Plans

After a project plan is linked to a ClearQuest database, it is not possible to nest other 
project plans in the linked plan. If you do so, running the Synchronize function causes 
run-time errors and unpredictable behavior.

Instead of nesting a project in the linked project, you need to enter the new tasks into 
your linked project.
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Task Name May Be Truncated When Transferred to the ClearQuest 
Headline Field

The ClearQuest Headline field can contain up to 125 characters. Therefore, if you 
export a project plan task with a Task Name exceeding 125 characters, only the first 125 
are transferred to the Headline field of the ClearQuest record (in other words, the field 
is truncated at 125 characters). You can see when this occurs in the progress log, which 
displays a statement. 

Note that if you use the Export function and later the Synchronize function, you may 
end up with the 125 character truncated version back in the project plan Task Name 
field. This is because the Export function only transfers the first 125 characters to the 
Headline field in the ClearQuest record. Then, during the Synchronize process, the 125 
character version is copied back to the project plan Task Name field, overwriting the 
longer version. 

Removing an Owner from the ClearQuest Database

The ClearQuest administrator is able to remove names from the list of active Rational 
ClearQuest users (which consists of those user names that are valid entries in the 
Owner field of the ClearQuest database).

However, when a name is removed from the list of active ClearQuest users, it is not 
removed from the list of ClearQuest users recognized by Project Tracker during the 
Import, Export, Update and Synchronize processes. 

This fact can have an impact when Project Tracker, during one of these processes, finds 
a Resource name in the project plan that does not match a recognized ClearQuest 
owner name. Rational ClearQuest Project Tracker then displays a list of recognized 
ClearQuest users. 

You can select a name from the list so that the Resource name in the project plan record 
matches a recognized ClearQuest user, however, in this case the list displayed includes 
the name of the ClearQuest user who was earlier removed from the list of active users. 
Selecting this would cause the name of someone no longer working on the project to 
be stored in the Resource name field of the project plan task.

It is therefore important that the ClearQuest administrator notify every project 
manager when a ClearQuest user is removed from the active users list. That way, the 
project manager knows not to select that user’s name during an Import, Export, 
Update, or Synchronize process.
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Deleting the Actual End Date from a ClearQuest Record

A Rational ClearQuest user may modify the Actual End Date field in a ClearQuest 
database record to make it blank, however, when you then run the Update or 
Synchronize process, that blank is not copied into the Actual Finish Date field in the 
linked record in the project plan. Instead, whatever date was in the Actual Finish Date 
field remains there.

This happens because Microsoft Project does not allow Project Tracker to copy a blank 
onto an Actual Finish Date field that already has a value.

To know if there is a blank in the Actual End Date field, you or the ClearQuest 
administrator can run a query of the ClearQuest records.
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ASetting Up and 
Configuring Project 
Tracker
This chapter describes how to set up Rational ClearQuest Project Tracker in order to 
exchange information between Microsoft Project 2000 and ClearQuest.

Prerequisites

The prerequisites for setting up Project Tracker are:

■ ClearQuest has been installed and is in use
■ Microsoft Project 2000 has been installed and is in use by the project manager

In essence, these prerequisites mean that your project team has already learned how to 
effectively use both ClearQuest and Microsoft Project 2000, and that both applications 
are deployed on the current project. This means that there are already ClearQuest 
records for the project and that there is a project plan in Microsoft Project with work 
tasks.

To set up and configure Project Tracker you need to:

1 Update the ClearQuest database schema for your project — to store the new 
information that will be exchanged with Microsoft Project 2000.

2 Run Regsvr32 CQMSPInt.dll if Microsoft Project 2000 is not installed on your 
system.

In addition, the following steps need to be taken either by you or by the project 
manager responsible for each project plan. These steps are described in Chapter 2, 
Linking a Project Plan with a ClearQuest Database. You may want to work with the project 
manager or managers to make sure these steps are carried out correctly:

1 Configure each Microsoft Project 2000 project plan with information about 
ClearQuest by providing the following information:

❑ Which ClearQuest database to exchange data with.
❑ Which Microsoft Project fields to use to store ClearQuest related data
❑ Which ClearQuest record types will be available.

2 Configure the view inside Microsoft Project 2000 to display ClearQuest related 
data.
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When you finish these steps, you can do the initial import of ClearQuest records into 
Microsoft Project 2000 and the initial export of Microsoft Project 2000 tasks to 
ClearQuest.

The following sections describe these steps in more detail.

Platform Dependencies

Project Tracker is implemented as an add-in to Microsoft Project 2000 that 
communicates with ClearQuest using COM. This means that the platforms supported 
by Project Tracker are defined by Microsoft Project 2000. In other words, this means 
that Project Tracker does not depend on the way ClearQuest was deployed. 

The ClearQuest server can be deployed on an NT machine or a UNIX machine using 
any of the supported ClearQuest databases. All that is required is that the client 
machine have the Windows ClearQuest client and Microsoft Project 2000 installed.

Update the ClearQuest Database Schema for Your Project

Project Tracker requires two ClearQuest packages to be applied to the ClearQuest 
database schema that is used for your project’s ClearQuest database. These ClearQuest 
packages must be installed in the following order:

1 AMBaseActivity

2 AMWorkActivitySchedule

What Are ClearQuest Packages? 

ClearQuest packages contain definitions of new database fields and related 
information that, when applied to the definition of a ClearQuest record type, add the 
new fields to that record type. The ClearQuest packages needed by Project Tracker 
define fields such as Planned Start Date and Actual Work.

For more information on ClearQuest packages, refer to Administrator’s Guide for 
Rational ClearQuest and to the Help for Rational ClearQuest Designer.

Note: You must apply both the AMBaseActivity and AMWorkActivitySchedule 
packages to each ClearQuest record type that you want to use to exchange information 
with Microsoft Project 2000. 
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To apply these packages, use the ClearQuest Package Wizard feature in the ClearQuest 
Designer application. For more information on the ClearQuest Package Wizard, refer 
to Administrator’s Guide for Rational ClearQuest and to the Help for the Rational 
ClearQuest Designer. 

Run Regsvr32 CQMSPInt.dll

If Microsoft Project 2000 is already installed on your system, then during installation, 
ClearQuest will automatically register the CQMSPInt.dll. This .DLL file is available in 
your system when you install ClearQuest.

However, if Microsoft Project is not installed, you will need to follow these steps to 
register CQMSPInt.dll and finalize the installation of Project Tracker.

To register the file:

1 Click Start > Run.

2 In the Run window, enter Regsvr32 CQMSPInt.dll and click OK.

Package Description
Record Types 
added/modified

Fields

AMBaseActivity Provides additional 
support for Rational 
ClearQuest Project 
Tracker.

Adds the Main tab to 
the enabled record 
type.

Fields added to enabled 
record type:
■ Headline
■ Owner
■ Description

AMWork
ActivitySchedule

Provides scheduling 
attributes needed to 
integrate Rational 
ClearQuest and 
Microsoft Project 2000 
using Rational 
ClearQuest Project 
Tracker.
With the 
AMWorkActivitySche
dule record type 
family, you can query 
records being created 
and updated with 
Rational ClearQuest 
Project Tracker.

Defines and adds the 
AMSchedule record 
type family to the 
enabled schema. 
Record types being 
enabled with this 
package are added to 
this record type family.
Adds the Schedule tab 
to the enabled record 
type.

Fields added to enabled 
AM Schedule record type:
■ am_planned_start_date
■ am_planned_end_date
■ am_planned_work
■ am_planned_rem_work
■ am_planned_duration
■ am_planned_rem_

duration
■ am_actual_start_date
■ am_actual_end_date
■ am_actual_work
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BUsing RUP Project 
Plans
The Rational Unified Process (RUP) provides a set of Microsoft Project plans that 
organizes tasks according to the best practices methodology supported by RUP. 

If RUP is available on your system, you can access the project plans from Rational 
Unified Process > Templates > Microsoft Project.

Two levels of plans are provided for each iteration in each phase, a summary template 
at the workflow detail level, and a more detailed template at the activity level.

You can use the RUP project plans as a starting point, then adjust and add detail to 
reach a complete project plan with the specific tasks that can be converted to Rational 
ClearQuest database records and assigned to individual contributors. For example, 
you should replace generic resource names with specific resource names, adjust start 
and finish dates, add detailed work-level tasks and remove tasks that do not apply.
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