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Preface
This manual provides a complete description of the features and options available in 
Rational RequisitePro, a requirements management tool that integrates a powerful 
multi-user requirements database utility with the familiar environment of Microsoft 
Word for Windows. The program allows you to work simultaneously with a 
requirements database and requirements documents. 

Audience

Rational RequisitePro User’s Guide is designed to meet the diverse needs and 
responsibility levels of various types of users. Users may perform different roles that 
vary depending on the RequisitePro project they access. The roles listed below 
describe typical user functions; however, they may not correspond directly to 
RequisitePro security groups. RequisitePro administrators can create any number of 
security groups with specific permissions for creating, updating, and deleting 
projects, documents, and requirements.

Requirements viewers read documents, query the requirements database, and 
participate in discussion groups. These are common activities for all RequisitePro 
users.

Requirements contributors perform the common activities of requirements 
viewers; however, they have additional permissions to modify requirements 
attribute values. 

Requirements authors use standardized templates to write or revise requirements 
documents and add, delete, or revise requirements in the project database. The 
templates are created by the project administrators.

Project administrators create and manage all elements of a project (including 
security, document types, and requirement types) and set up cross-project 
traceability.

Rational RequisitePro User’s Guide is organized to introduce activities that are common 
to all users who view and query requirements. It then moves to the skills needed for 
creating and managing requirements, and it addresses the advanced skills required 
for managing projects.
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The following table indicates which chapters are most relevant for various types of 
RequisitePro users:

All readers should refer to Appendix A, Keyboard Shortcuts and Mouse Actions; 
Appendix B, Customizing RequisitePro; and the Glossary, which defines technical terms 
used in RequisitePro.

Other Resources

■ Help. You can view Help within RequisitePro whenever you need assistance. To 
display the Help Contents, click Help > Contents and Index, or press the F1 key. You 
can also click the Help button in any dialog box.

■ Let’s Go RequisitePro. This help interface provides access to beneficial information 
about setting up RequisitePro projects and the requirements management process. 
Let’s Go RequisitePro guides new users through the various “getting started” 
information available in RequisitePro, including Help and the two tutorials, 
Rational RequisitePro Tutorial and Quick Tour. For advanced users, it provides a 
single source for accessing pertinent, in-depth documentation, including the 
Rational Unified Process and Web resources.

Let’s Go RequisitePro automatically appears when you start RequisitePro, but you 
can disable it by clearing the check box on the Options dialog box (click Tools > 
Options) or on the initial Let’s Go RequisitePro splash screen. You can launch Let’s 
Go RequisitePro at any time from the Help menu by clicking Help > Let’s Go 
RequisitePro.

Recommended Chapters
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17

Requirements
Viewers

Requirements 
Contributors

Requirements
Authors

Project
Administrators

Type of 
User
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■ Getting Started Tours. You can access two Help tours from either Let’s Go 
RequisitePro or the Getting Started book in the help Contents tab: Requirements 
Management Tour, an overview for using RequisitePro as part of a requirements 
management process; and Project Administration Tips, a guide for RequisitePro 
project administrators, who will be setting up and managing projects.

■ The RequisitePro tutorials. RequisitePro includes two self-paced tutorials to get 
you started with the program: Rational RequisitePro Tutorial and Quick Tour. Both 
can be opened from either the Let’s Go RequisitePro help screen (available from 
Help > Let’s Go RequisitePro) or the Windows Start menu (click the RequisitePro 
program group). 

■ Rational Documentation Web site. You can order documentation for Rational 
products from www.rational.com/documentation. 

■ White papers and technical notes. Rational offers complementary white papers 
on current trends in requirements management and a list of recommended reading 
materials for some perspectives on how you can achieve your development goals 
using requirements management principles. For free copies of these materials, visit 
http://www.rational.com/products/reqpro/whitepapers.jsp. Technical notes are available at 
http://solutions.rational.com/solutions.

■ Rational Developer Network. The Rational Developer Network provides the 
guidance you need to implement and deepen your knowledge on Rational tools 
and best practices. It includes immediate access to white papers, artifacts, codes, 
discussions, training, documentation, and self-paced Web-based training. It also 
includes a RequisitePro Knowledge Center and RequisitePro Getting Started 
Guides. For more information, see http://www.Rational.net. 

From RequisitePro, you can open the Rational Developer Network by clicking Help 
> Rational on the Web > Rational Developer Network. Rational Developer Network is 
also available from Let’s Go RequisitePro.

■ Rational Training Services. Rational University offers requirements management 
classes and tool training for RequisitePro users. It also provides Single Learning 
Modules, which are one-hour introductions to Rational products. For information 
about training opportunities, see the Rational University Web site at 
http://www.rational.com/university.

Reference

Information about requirements management is provided in Dean Leffingwell and 
Don Widrig, Managing Software Requirements: A Unified Approach (Addison Wesley, 
2000).
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RequisitePro Integrations With Other Rational Products

Integration Description Where it is Documented

RequisitePro-

ClearQuest

You can track and manage change 
requests and associate 
requirements with enhancement or 
defect records.

RequisitePro Help

Getting Started: Rational Suite AnalystStudio

RequisitePro-

ClearCase 

You can archive RequisitePro 
projects in ClearCase.

Rational RequisitePro User’s Guide

RequisitePro Help

RequisitePro-

Unified Change 

Management

RequisitePro administrators can 
create baselines of RequisitePro 
projects in UCM and create  
RequisitePro projects from  
baselines.

Rational RequisitePro User’s Guide

RequisitePro Help

Using UCM with Rational Suite

Getting Started: Rational Suite AnalystStudio

RequisitePro-

Rose

You can associate RequisitePro 
requirements and documents with 
Rose use cases and models.

Integrated Use Case Management Help (available from 
Rose or RequisitePro Help)

Getting Started: Rational Suite AnalystStudio

RequisitePro-

Rational XDE

You can associate XDE model 
elements with RequisitePro 
requirements and documents. 

RequisitePro-XDE Integration Help (available from 
RequisitePro Help and XDE Help)

RequisitePro-

TestManager

You can reference RequisitePro 
requirements from TestManager to 
ensure traceability between 
requirements and test assets.

Rational TestManager User’s Guide

Rational TestManager Help

Rational Suite Administrators Guide

RequisitePro Help

RequisitePro-

SoDA

You can create reports that extract 
information from a RequisitePro 
project.

SoDA Help

RequisitePro Help

RequisitePro-

ProjectConsole

You can create reports that extract 
information from a RequisitePro 
project.

Getting Started: Rational ProjectConsole

RequisitePro-

Rational 
Administrator

RequisitePro project administrators 
use Rational Administrator to 
create UCM-enabled Rational 
projects that allow team members 
to create baselines of RequisitePro 
projects and to enable the 
RequisitePro-ClearQuest 
integration.

RequisitePro Help 

Rational TestManager User’s Guide

RequisitePro-

Rational
Unified Process 
(RUP) 

You can launch Extended Help 
from the RequisitePro Help menu. 
Extended Help displays RUP tool 
mentors for RequisitePro.

RequisitePro Help
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Contacting Rational Customer Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Customer Support.

Please help our Customer Support staff deliver quality customer service by providing 
complete information. The techsupport.html file, which is located in the RequisitePro 
installation directory and is also available by clicking Help > Contacting Technical 
Support, contains a Customer Information Form. You can use this form to document 
problems, questions, or suggestions and to detail your company and system 
information. You can copy the form into your e-mail message.

Attach your error.log file (located in the RequisitePro installation directory in the bin 
folder) if you are getting an error message. Add any files, screen captures, and other 
information you feel are relevant.

Contacting Rational Technical Publications

To send feedback about documentation for Rational products, send e-mail to our 
technical publications department at techpubs@rational.com. 

For technical problems and questions, contact Customer Support.

Location Contact Information Notes

U.S. and Canada 800-433-5444 (toll free)
408-863-4000 (Cupertino, CA)
781-676-2460 (facsimile)
support@rational.com

When sending e-mail:
■ Specify the product name 

and release number in the 
subject line. 

■ For existing issues, include 
your case ID in the subject 
line

Europe, Middle East, Africa +31 (0) 20-4546-200
+31 (0) 20-4546-201 (facsimile)
support@europe. rational.com

Asia Pacific +61-2-9419-0111
+61-2-9419-0123 (facsimile)
support@apac.rational.com

World Wide Web http://www.rational.com Click the Customer Support 
link.
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1Introducing 
Requirements 
Management
This chapter is adapted from Rational’s white paper Applying Requirements 
Management with Use Cases. The full version of this document is available from the 
Rational Developer Network (http://www.Rational.net).

Applying Requirements Management with Use Cases

If you are new to or somewhat familiar with requirements management and are 
interested in improving your requirements management process, you can use the 
framework presented in this chapter to develop your own approach.

Software and System Development in the Age of Process

For most software and system development teams, the 1990s have been 
process-intensive when compared to the more freewheeling days of the past. 
Standards for measuring and certifying effective software development process have 
been introduced and popularized. Many books and articles on software development 
process and related material on business process modeling and re-engineering have 
been published. Increasing numbers of software tools have helped define and apply 
effective software development process. The global economy’s dependence on 
software accelerated in the past decade, enabling development processes and 
improving system quality.

So how do we explain the high incidence of the software project failure today? Why 
are many, if not most, software projects still plagued by delays, budget overruns, and 
quality problems? How can we improve the quality of the systems we build as our 
businesses, national economies, and daily activities become increasingly dependent 
on them? 

The answers, as always, lie in the people, tools, and processes applied to our 
profession. Requirements management is often proposed as a solution to the ongoing 
problems of software development, yet relatively little attention has been focused on 
improving the practice of this discipline. 

This chapter presents the elements of an effective requirements management process 
and highlights some of the obstacles to its successful implementation.
1



Requirements management applies equally to software-only projects and to projects 
in which software is only a part of the end result or is not included at all. For 
convenience, the term system is used here to mean any or all of these things. However, 
it is the abstract nature of software development, alone or in combination with 
hardware, that complicates requirements management and is therefore the primary 
focus of this chapter.

What Is a Requirement? 

The first step toward understanding requirements management is to agree on a 
common vocabulary. Rational defines a requirement as “a condition or capability to 
which the system [being built] must conform.” The Institute of Electronics and 
Electrical Engineers (IEEE) uses a similar definition.

Well-known requirements engineering authors Merlin Dorfman 
and Richard H. Thayer offer a compatible and more refined 
definition that is specific—but not necessarily limited—to 
software:

“A software requirement can be defined as: 

❑ A software capability needed by the user to solve a 
problem or achieve an objective.

❑ A software capability that must be met or possessed by a system or system 
component to satisfy a contract, specification, standard, or other formally 
imposed documentation.”1

Why Manage Requirements? 

Simply put, system development teams that manage requirements do so because they 
want their projects to succeed. Meeting their project’s requirements defines success. 
Failing to manage requirements decreases the probability of meeting these objectives.

Recent evidence is supportive:

■ The Standish Group’s CHAOS Reports from 1994, 1997, and 2000 established that 
the most significant contributors to project failure relate to requirements.2

■ In December 1997, Computer Industry Daily reported on a Sequent Computer 
Systems, Inc., study of 500 IT managers in the U.S. and U.K. that found 76 percent 
of the respondents had experienced complete project failure during their careers. 
The most frequently named cause of project failure was “changing user 
requirements.”3

A requirement is a
condition or
capability to which
the system must
conform.
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Avoiding failure should be sufficient motivation to manage requirements. Increasing 
the probability of a successful project and other benefits of managing requirements 
may be equally motivational. The Standish Group’s CHAOS report further 
established that managing requirements well was the factor most related to successful 
projects.

What Is Requirements Management?

Because requirements are things to which the system being built must conform, and 
conformance to some set of requirements defines the success or failure of projects, it 
makes sense to find out what the requirements are, write them down, organize them, 
and track them in the event they change.

Stated another way, requirements management is: 

■ a systematic approach to eliciting, organizing, and documenting the requirements 
of the system, and

■ a process that establishes and maintains agreement between the customer and the 
project team on the changing requirements of the system.

This definition is similar to Dorfman and Thayer’s and the IEEE’s definition of 
software requirements engineering. Requirements engineering includes elicitation, 
analysis, specification, verification, and management of the software requirements, 
with software requirements management being the planning and controlling of all these 
related activities.4 All of these activities are incorporated in the definition of 
requirements management presented here and taught by Rational Software. The 
difference lies mainly in the choice of the word management rather than engineering. 
Management is a more appropriate description of all the activities involved, and it 
accurately emphasizes the importance of tracking changes to maintain agreements 
between stakeholders and the project team.
Applying Requirements Management with Use Cases 3



The Problems of Requirements Management

So what might be difficult about a process intended to ensure that a system conforms 
to the expectations set for it? When put into practice on real projects, difficulties come 
to light.

Figure 1 displays the 
results of a 1996 survey of 
developers, managers, and 
quality assurance 
personnel. It shows the 
percentage of respondents 
who experienced the most 
frequently mentioned 
requirements-related 
problems. 

A more comprehensive list 
of problems includes the 
following:

■ Requirements are not 
always obvious and 
have many sources.

■ Requirements are not always easy to express clearly in words.

■ Many different types of requirements at different levels of detail must be managed.

■ The number of requirements can become unmanageable if not controlled.

■ Requirements are related to one another and to other deliverables of the process in 
a variety of ways.

■ Requirements have unique properties or property values; they are neither equally 
important nor equally easy to meet.

■ Many interested and responsible parties are involved in a project, which means 
that requirements must be managed by cross-functional groups of people.

■ Requirements change.

■ Requirements can be time-sensitive.

When these problems are combined with inadequate requirements management and 
process skills and the lack of easy-to-use tools, many teams despair of ever managing 
requirements well. Rational Software has developed the expertise to instruct teams in 
requirements management skills and process, and Rational RequisitePro is an 
accessible tool for automating effective requirements management.

Figure 1. Common Requirements Management Problems 

#1 Can’t track changes 71%

#2 Difficult to write

#3 Feature creep 67%

#4 Not well organized 54%

70%
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Requirements Management Skills 

To resolve the problems mentioned above, Rational encourages the development of 
key skills. These skills are presented below in what appears to be sequential order, but 
in an effective requirements management process they are applied continuously in 
varied order. Here they are presented in the sequence one would likely apply to the 
first iteration of a new project.

Analyze the Problem

Problem analysis is conducted to 
understand business problems, 
target initial stakeholder needs, 
and propose high-level solutions. 
These acts of reasoning and 
analysis find “the problem behind 
the problem.”

During problem analysis, 
agreement is gained on a statement 
of the real problems and the 
stakeholders are identified. Initial 
solution boundaries and 
constraints are defined from both 
technical and business 
perspectives. If appropriate, the 
business case for the project 
analyzes return on investment that 
is expected from the system.

Understand Stakeholder Needs

Requirements have many sources. They may come from anyone with an interest in 
the outcome of the project. Customers, partners, end users, and domain experts are 
some sources of requirements; so too are management, project team members, 
business policies, and regulatory agencies.

It is important to know how to determine who the sources should be, how to get 
access to those sources, and how to elicit information from them. The individuals who 
serve as primary sources for this information are referred to as “stakeholders” in the 
project.

If you are developing an information system to be used internally within your 
company, you may include people with end-user experience and business domain 
expertise in your development team. Very often you will start the discussions at a 

Figure 2. Steps in Problem Analysis
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business-model level rather than at a system level. If you are developing a product to 
be sold to a marketplace, you may make extensive use of your marketing people to 
better understand the needs of customers in that market. 

Requirements may be elicited through activities such as interviewing, brainstorming, 
conceptual prototyping, using questionnaires, and performing competitive analysis. 
The result of requirements elicitation is a list of requests or needs that are described 
textually and graphically and that have been given priority relative to one another.

Define the System 

To define the system means to translate and organize the understanding of 
stakeholder needs into a meaningful description of the system to be built. Early in 
system definition, decisions are made on what constitutes a requirement, 
documentation format, language formality, degree of requirements, request priority 
and estimated effort, technical and management risks, and scope. Part of this activity 
may include early prototypes and design models directly related to the most 
important stakeholder requests.

We use the word description rather than document to avoid the perceived limitation 
inherent in the common use of the latter. A description may be a written document, 
electronic file, picture, or any other representation meant to communicate system 
requirements.

The outcome of system definition is a description of the system that is both natural 
language and graphical (see Figure 3). Some suggested formats for the description are 
provided in later sections.

Figure 3. System Definition in Natural and Formal Language

Principle 55
W RITE N ATURAL LAN GUAG E BEFORE A M ORE FORM AL M ODEL
If you write the form al m odel first, the tendency will be to write natural language that
describes the m odel instead of the solution system .

TO MAKE A LONG DISTANCE CALL, THE USER SHOULD LIFT THE P HONE.  THE SYSTEM S HALL
RESPOND W ITH A DIAL TONE. THE USER SHOULD DIAL A “9”.  THE SYSTEM SHALL RE SPOND
W ITH A DISTINCTIVE DIAL TONE…

THE SYS TEM CONSISTS OF FOU R STATES: IDLE, D IAL TONE, D ISTINCTIVE D IAL TONE, AND
CONNECTED.  TO GET FROM THE IDLE S TATE TO THE DIAL TON E STATE, LIFT THE PH ONE.
TO GET FROM THE DIAL TONE STATE TO THE  DISTINCTIV E DIAL TON E STATE, DIAL A “9.”

Note that in the latter exam ple, the text does not help the reader at all.

- Alan M . Davis, 201 Principles of Software Developm ent, 1995
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Manage the Scope of the Project

The scope of a project is defined by the set of requirements allocated to it. Managing 
project scope to fit the available resources (time, people, and money) is key to 
managing successful projects. Managing scope is a continuous activity that requires 
iterative or incremental development, which breaks project scope into smaller, more 
manageable pieces.

Using requirement attributes, such as priority, effort, and risk, as the basis for 
negotiating the inclusion of a requirement is a particularly useful technique for 
managing scope. Focusing on the attributes rather than the requirements themselves 
helps desensitize negotiations that are otherwise contentious.

It is also helpful for team leaders to be trained in negotiation skills and for the project 
to have a champion in the organization, as well as on the customer side. 
Product/project champions should have the organizational power to refuse scope 
changes beyond the available resources or to expand resources to accommodate 
additional scope.

Refine the System Definition 

With an agreed-upon high-level system definition and a fairly well understood initial 
scope, it is both possible and economical to invest resources in more refined system 
definitions. Refining the system definition includes two key considerations: 
developing more detailed descriptions of the high-level system definition and 
verifying that the system will comply with stakeholder needs and behave as 
described.

The descriptions are often the critical reference materials for project teams. 
Descriptions are best done with the audience in mind. A common mistake is to 
represent what is complex to build with a complex definition, particularly when the 
audience may be unable or unwilling to invest the critical thinking necessary to gain 
agreement. This leads to difficulties in explaining the purpose of the system to people 
both inside and outside the project team. Instead, you may discover the need to 
produce different kinds of descriptions for different audiences. This chapter includes 
suggested formats for detailed natural language, formal text, and graphical 
descriptions. After the description format is established, refinement continues 
throughout the project lifecycle.

Manage Changing Requirements

No matter how carefully you define your requirements, they will change. In fact, 
some requirement change is desirable; it means that your team is engaging your 
stakeholders. Accommodating changing requirements is a measure of your team’s 
stakeholder sensitivity and operational flexibility, team attributes that contribute to 
successful projects. Change is not the enemy—unmanaged change is.
Applying Requirements Management with Use Cases 7



A changed requirement means that more or less time has to be spent on implementing 
a particular feature, and a change to one requirement may affect other requirements. 
Managing requirement change includes activities such as establishing a baseline, 
keeping track of the history of each requirement, determining which dependencies 
are important to trace, establishing traceable relationships between related items, and 
maintaining version control.

As Figure 4 illustrates, it is also important to establish a change control or approval 
process, requiring all proposed changes to be reviewed by designated team members. 
Sometimes this single channel of change control is called a Change Control Board 
(CCB).

Important Requirements Concepts

To apply requirements management skills to a project, everyone working on a project 
should understand certain requirements management concepts, including the 
following:

Requirement Types. A requirement type is simply a class of requirements. The larger 
and more intricate the system, the more types of requirements appear. By identifying 
types of requirements, teams can organize large numbers of requirements into 
meaningful and more manageable groups. Establishing different types of 
requirements in a project helps team members classify requests for changes and 
communicate more clearly.

Figure 4. The Key to Managing Change: All Requests Go Through a Single Channel
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Usually, one type of requirement can be broken down, or decomposed, into other 
types. Business rules and vision statements can be types of high-level requirements 
from which teams derive user needs, features, and product requirement types. Use 
cases and other forms of modeling drive design requirements that can be decomposed 
to software requirements and represented in analysis and design models. Test 
requirements are derived from the software requirements and decompose to specific 
test procedures. When there are hundreds, thousands, or even tens of thousands of 
instances of requirements in a given project, classifying requirements into types 
makes the project more manageable.

Cross-Functional Teams. Unlike other processes, such as testing or application 
modeling, which can be managed within a single business group, requirements 
management should involve everyone who can contribute their expertise to the 
development process. It should include people who represent the customer and the 
business expectations. Development managers, product administrators, analysts, 
systems engineers, and even customers should participate. Requirements teams 
should also include those who create the system solution— engineers, architects, 
designers, programmers, quality assurance personnel, technical writers, and other 
technical contributors (see Figure 5).

Often, the responsibility for authoring and maintaining a requirement type can be 
allocated by functional area, further contributing to better large project management. 
The cross-functional nature of requirements management is one of the more 
challenging aspects of the discipline.

Traceability. As implied in the description of requirement types, no single expression 
of a requirement stands alone. Stakeholder requests are related to the product features 
proposed to meet them. Product features are related to individual requirements that 
specify the features in terms of functional and nonfunctional behavior. Test cases are 
related to the requirements they verify and validate (see Figure 6). Requirements may 
be dependent on other requirements or mutually exclusive. 

QA & Test

Dev. Mgrs & 
Proj. Mgrs

Corp
Mgmt.

RequirementsAnalysts Tech writers
& docs

Developers
& Designers QA & Test

Dev. Mgrs & 
Proj. Mgrs

Figure 5. Team Members Involved in Requirements Management
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In order for teams to determine the impact of changes and feel confident that the 
system conforms to expectations, these traceability relationships must be understood, 
documented, and maintained. Traceability is one of the most difficult concepts to 
implement in requirements management, but it is essential to accommodating change. 
Establishing clear requirement types and incorporating cross-functional participation 
can make traceability easier to implement and maintain. For more information on 
different strategies for requirements traceability, see the white paper, Traceability 
Strategies for Managing Requirements with Use Cases.5

Requirements Traceability
Establish Traceability Paths

1. Trace top level
requirements into detailed
requirements

2. Trace requirements into
design

3. Trace requirements into
test procedures

4. Trace requirements into
user documentation plan

   Design   

Software Design
Descriptions

Object Models

Test Suites

   Test   

2 3

 Req A 

1

Product 
Requirements

(Features)

Detailed 
Requirements
(Use Cases)

     Req B      

Documentation
Plan

User Docs

4

Figure 6. Establish Traceability Paths Between Requirements
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Multidimensional Attributes. 
Each type of requirement has 
attributes, and each individual 
requirement has different attribute 
values. For example, requirements 
may be assigned priorities, 
identified by source and rationale, 
delegated to specific sub-teams 
within a functional area, given a 
degree-of-difficulty designation, or 
associated with a particular 
iteration of the system. To illustrate, 
Figure 7 displays attributes for a 
Feature Requirement Type from an 
example project in RequisitePro. As 
implied by the title of the screen, the requirement type and attributes for each type are 
defined for the entire project, ensuring usage consistency across the team.

In Figure 8, feature 
requirements are displayed 
for a specific project in 
RequisitePro. Note that 
even without displaying 
the entire text for each 
requirement, we can learn 
a great deal about each 
requirement from its 
attribute values. In this 
case, its priority and 
difficulty (which may be assigned by different team members) will help the team 
begin to scope the project to available resources and time, taking into account both 
stakeholder priorities and a very rough estimate of effort reflected in the difficulty 
attribute value. In more detailed types of requirements, the priority and effort 
attributes may have more specific values (for example, estimated time, lines of code) 
with which to further refine scope. This multidimensional aspect of a requirement, 
compounded by different types of requirements—each with its own attributes—is 
essential to organizing large numbers of requirements and to managing the overall 
scope of the project.

Change History. Both individual requirements and collections of requirements have 
histories that become meaningful over time. Change is inevitable and desirable to 
keep pace with a changing environment and evolving technology. Recording the 
versions of project requirements enables team leaders to capture the reasons for 
changing the project, such as a new system release. Understanding that a collection of 
requirements may be associated with a particular version of software allows you to 

Figure 7. Attributes for the Feature Requirement Type

Figure 8. Attribute Matrix for Feature Requirements
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manage change incrementally, reducing risk and improving the probability of 
meeting milestones. As individual requirements evolve, it is important to understand 
their history: what changed, why, when, and even by whose authorization.

Putting Requirements Management to Work

Requirements management uses the key skills and concepts presented above to 
identify and resolve the problems successfully. 

To build a system that truly meets customers’ needs, the project team must first define 
the problem to be solved by the system. Next, the team must identify stakeholders 
from whom business and user needs are elicited, described, and prioritized. From this 
set of high-level expectations or needs, a set of product or system features should be 
agreed upon (see Figure 9). 

Figure 9. Overview of Requirements Management

Detailed software requirements should be written in such a form as can be 
understood by both the customers and the development team. We have found that 
using the language of the customer to describe these software requirements is most 
effective in gaining the customer’s understanding and agreement. These detailed 
software requirements are then used as input for the system design specifications as 
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well as for test plans and procedures needed for implementation and validation. 
Software requirements should also drive the initial user documentation planning and 
design.

Effective requirements management 
includes the following project team 
activities: 

1 Agree on a common vocabulary 
for the project.

2 Develop a vision of the system that 
describes the problem to be solved 
by the system, as well as its 
primary features.

3 Elicit stakeholders’ needs in at 
least five important areas: 
functionality, usability, reliability, 
performance, and supportability.

4 Determine what requirement types 
to use.

5 Select attributes and values for 
each requirement type.

6 Choose the formats in which requirements are described.

7 Identify team members who will author, contribute to, or simply view one or more 
types of requirements.

8 Decide what traceability is needed.

9 Establish a procedure to propose, review, and resolve changes to requirements.

10 Develop a mechanism to track requirement history.

11 Create progress and status reports for team members and management.

These essential requirements management activities are independent of industry, 
development methodology, or requirements tools. They are also flexible, enabling 
effective requirements management in the most rigorous and the most rapid 
application development environments.

Sources

1 M. Dorfman and R. Thayer, Software Engineering (Los Alamitos, CA: IEEE 
Computer Society Press, 1997), p. 79.

2 CHAOS, The Standish Group International, Inc. (Dennis, MA, 1994, 1997, 2000).

A Few Words about Documents
The decision to describe requirements in

 
documents deserves some thought. On the
one hand, writing is a widely accepted form
of communication and, for most people, a 
natural thing to do. On the other hand, the
goal of the project is to produce a system,
not documents. Common sense and
experience teach that the decision is not
whether but how to document requirements.
Document templates provide a consistent
format for requirements management.
Rational RequisitePro offers these templates
and the additional feature of linking
requirements within a document to a database
containing all project requirements. This
unique feature allows requirements to be
documented naturally, making them more
accessible and manageable in a database.
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2Introducing Rational 
RequisitePro
This chapter covers key Rational RequisitePro concepts. A complete glossary can be 
found at the end of this book.

Why Use RequisitePro?

Studies have shown that managing requirements is the most significant factor in 
delivering projects on time, on budget, and on target. RequisitePro helps projects 
succeed by giving teams the ability to manage all project requirements 
comprehensively and facilitating team collaboration and communication.

Moving beyond conventional requirements management, RequisitePro combines 
both document-centric and database-centric approaches. By deeply integrating 
Microsoft Word with a multi-user database, RequisitePro lets you organize, prioritize, 
trace relationships, and easily track changes to your requirements. The program’s 
unique architecture and dynamic links make it possible for you to move easily 
between the requirements in the database and their presentation in Word documents. 

Team Collaboration and User Satisfaction 

Requirements drive the entire project. RequisitePro’s integration with other 
industry-leading tools optimizes the flow of requirements data throughout the 
project, promoting consistency and ensuring that what is designed, tested, 
documented, and delivered meets the users’ needs. RequisitePro’s deep integration 
with other lifecycle tools promotes artifact reusability and eases the sharing of 
information, further enhancing team collaboration. 

A product development team typically includes a large number of individuals with 
diverse roles, such as business analysts, project leaders, product marketing managers, 
development managers, QA managers, developers, and testers. When each person on 
your team has access to critical requirements information and is able to manage those 
requirements, team efficiency and effectiveness are promoted and project risk is 
reduced. 
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Flexibility Through the Web Component

In addition to the Windows client version of RequisitePro, RequisiteWeb offers a 
Web-based client for RequisitePro. RequisiteWeb allows users to access RequisitePro 
requirements information across an intranet. By using browsers—Netscape Navigator 
or Microsoft Internet Explorer—RequisiteWeb provides a thin client solution to access 
project documents and data. No Rational application-specific files need to be installed 
on the user’s machine. 

Using RequisiteWeb, you can modify the name, text, and attributes of requirements 
directly in the database and from within documents, and you can create, delete, and 
query requirements and assign new parents to them. All changes are automatically 
tracked, just as they are in RequisitePro. Requirement authoring through the Web 
allows better support of distributed teams and multiple-platform environments.

RequisiteWeb supports the following features:

■ Viewing documents

■ Modifying requirements (in documents or database)

■ Creating requirements in the database

■ Creating and modifying Attribute Matrix views

■ Creating and modifying Traceability Tree views (traced into or traced out of)

■ Setting your own user password

■ Viewing, modifying, and creating hierarchical relationships

■ Creating traceability links within and across projects

■ Filtering and sorting requirements

■ Creating and replying to discussions

Change Management 

Change occurs in practically every development project, but it does not have to 
consume project resources or throw the project off course. With RequisitePro, you can 
manage inevitable change to ensure that your entire team is current as requirements 
evolve. Robust traceability features in RequisitePro enable you to establish and 
maintain dependencies between different requirements. As change occurs, these 
traceability relationships are flagged as suspect, so you can understand how change 
affects the entire project. For each requirement a change history is maintained, 
capturing the who, what, when, and why of the change.
16 Chapter 2 - Introducing Rational RequisitePro



Comprehensive Process Support 

Whether your team follows a rigorous requirements management process, such as 
IEEE, SEI CMM, or Unified Modeling Language-driven use-case approaches, or is just 
beginning to define a formal process, RequisitePro can help you meet your objectives 
of delivering precise, quality software. RequisitePro provides industry standard 
project templates and attributes, and it can also import existing documents and be 
customized to support existing projects.

A Quick Tour of Key Concepts in RequisitePro

This section provides an overview of RequisitePro concepts and defines some terms 
that will help you get started.

Requirements

RequisitePro organizes requirements and provides traceability and change 
management throughout the project lifecycle. A requirement describes a condition or 
capability that a system must provide. Requirements contain a name and text, and 
they can be qualified with attributes to provide specific details. Requirements may be 
created in a document or in a view. All requirements information is stored in the 
database.

More information on requirements is provided in the chapter Working with 
Requirements on page 107.

Requirement Type

A requirement type is an outline for your requirements. Requirement types are used 
to classify similar requirements so they can be efficiently managed. When you define 
a requirement type, you define a common set of attributes, display style, and tag 
numbering. 

You can create requirement types that are appropriate for your project. (For more 
information, see Creating and Modifying Requirement Types on page 226.)

Requirement Attributes

In RequisitePro, requirements are classified by their type and their attributes. An 
attribute provides information to manage a requirement. Attributes can provide 
crucial information to help a team plan, communicate, and monitor project activities 
from the analysis and design phases through the release phase. 
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Attribute information may include the following:

■ The relative benefit of the requirement

■ The cost of implementing the requirement

■ The priority of the requirement

■ The difficulty or risk associated with the requirement

■ The relationship of the requirement to another requirement

RequisitePro provides several default requirement attributes, such as Priority (high, 
medium, low), Status (proposed, approved, incorporated, validated), Cost, and 
Difficulty. These attributes are suggestions. You can create and control attributes 
according to your needs. Whichever attributes you use, RequisitePro lets you easily 
customize your project documents and databases to define, articulate, and manage 
the processes of your organization.

You can use attributes to determine which requirements to implement in the next 
release. For example, you may decide that in the first release, you will implement only 
those requirements evaluated as high risk, with high difficulty. If you have assigned 
risk and difficulty attribute values to each requirement, you can then easily query all 
requirements of high risk and high difficulty.

(For more information, see Creating and Modifying Requirement Attributes on page 229.)

Project

A RequisitePro project includes a requirements database and its related documents. A 
project is usually created by a project administrator, who determines the project 
structure and sets up security permissions for the project’s users.

Although all project users are encouraged to view and query requirements and to 
participate in discussions, only a limited group of users create and manage 
requirements within a project.

(For more information about projects, see the following chapters: Creating Projects on 
page 171; Working with Project Security on page 181; Managing Projects on page 193; and 
Working with Project Information on page 217.) 

Project Database

The project database is the requirements database managed by RequisitePro. When 
you use RequisitePro, you can use one of three physical databases to store 
requirements: Microsoft Access, Oracle, or Microsoft SQL Server. Each RequisitePro 
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project has its own database, where all the requirements for a project are stored. (With 
the exception of Microsoft Access, all of these databases may contain more than one 
project.)

In the project database, requirements can be added, modified, or deleted. When 
requirements are changed in a document, the changes are updated in the database.

Often a project includes a variety of requirements documents, such as a product 
requirements document, a system requirements document, software and hardware 
specifications, user requirements, quality assurance procedures, and test plans. 
Information from all project documents is stored in the project database. The database 
centralizes information, so that members of the project team can update requirements, 
manage priorities and test plans, and report the project’s progress in one shared 
repository.

Project Version Control

RequisitePro’s version control lets you trace change by archiving projects. You can 
manage multiple versions of your projects, retrieving, modifying, and returning 
revisions to the archive in an organized and consistent manner. From RequisitePro, 
you can use RequisitePro’s Archive command or Rational ClearCase.

If your team is using Unified Change Management (UCM), RequisitePro project 
administrators can create baselines of RequisitePro projects by performing tasks in 
Rational Administrator and ClearCase, implementing the UCM model. If you have a 
RequisitePro project that is baselined, you can use that baseline to create new projects 
in RequisitePro. For example, you may want to base the next release of a project on a 
stable configuration of the previous release. 

(For more information, see Archiving Projects on page 200 and Creating a Project 
Baseline with Unified Change Management on page 208.)

Project List

A RequisitePro project list is a personal library of accessible RequisitePro projects. 
Each user’s list is unique. For example, a project administrator who monitors the 
progress of all the projects scheduled for completion this quarter could have an 
extensive list of projects, whereas some users might have just one project in their lists 
at a time.

Project administrators store new projects in their file systems—typically in the 
RequisitePro Project directory. In the Open Project and Documents dialog box, you 
can add or delete projects from your project list as you need them. (For more 
information, see Adding a RequisitePro Project to Your Project List on page 30.)
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Explorer

The Explorer is RequisitePro’s primary navigation window. In this window, project 
artifacts (documents, requirements, views, and packages) are displayed hierarchically 
in a tree browser. Project information is organized in packages, which are units of 
related artifacts. The project’s root package is displayed as the project node, and the 
contents of each root package are displayed beneath it. Packages can be customized; 
you can create them as needed, rename and rearrange them, and delete them when 
you no longer need them. When you select an artifact, a description of it appears in 
the window below the Explorer. 

You can use the Explorer to view your project structure and artifacts and to work with 
project information. For example, you can double-click or right-click a view or a 
document to open it; you can select requirements and edit them; and you can drag 
and drop artifacts between packages. The Explorer reflects saved changes made to an 
open document, view, or requirement. 
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Views 

RequisitePro views are windows to the database. Views present information about a 
project, a document, or requirements graphically in a table (matrix) or in an outline 
tree. Requirements, their attributes, and their relationships to each other are displayed 
and managed in views. RequisitePro includes query functions for filtering and sorting 
the requirements and their attributes in views. (See Working in Views on page 37.) 

Three kinds of views can be created:

■ The Attribute Matrix displays all requirements of a specified type. The 
requirements are listed in the rows, and their attributes appear in the columns.
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■ The Traceability Matrix displays the relationships (traceability) between two 
types of requirements.

■ The Traceability Tree displays the chain of traceability to or from requirements of a 
specified type.

.

Three views of the same requirements. Top to bottom: Attribute Matrix, Traceability Matrix, 
Traceability Tree. 

Documents

When you create a document in RequisitePro, you are working in RequisitePro Word. 
The document looks like a Word document, but a few changes have been introduced 
that allow RequisitePro to exercise security controls over the document. For example, 
the File menu Save as and Exit commands are disabled in the RequisitePro Word 
window in order to prevent conflicts in handling RequisitePro documents. (To close 
the Word document, click Window > Close Word.) The Templates and Add-in command 
on the Tools menus is unavailable so as to prevent deletion of the RequisitePro 
template, which is required for proper functioning of RequisitePro. 
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A requirements document is a specification that captures requirements, describes the 
objectives and goals of the project, and communicates product development efforts. 
Each requirements document belongs to a particular document type, explained below.

RequisitePro manages requirements directly in the project documents. When you 
build a requirements document, RequisitePro dynamically links it to a database, 
which allows rapid updating of information between documents and views. When 
you save revisions, they are available to team members and others involved with the 
project.

With RequisitePro’s version tracking, you can easily review the change history for a 
requirement, a document, or the whole project.

Not all documents are requirements documents. Documents do not have to contain 
requirements to be included in a project. Any Word document, no matter where it 
resides in the file system, can be associated with a project and is available in the 
document list when a project is opened. (For more information, see the chapter 
Working with Documents on page 85.)

Document Type

A document type identifies the type of document, such as a use-case or a software 
requirements specification, and helps ensure consistency across documents of the 
same type. A document type is an outline that is applied to documents. The outline 
can include the default font for the document, the available heading and paragraph 
styles, and the default type of requirements for the document, or it can encompass 
both formatting conventions and an outline that helps you organize your 
requirements information. (For more information, see Creating and Modifying 
Document Types on page 221.)

All documents of the same document type share the same file extension (for example, 
.prd). You determine document types when you create or modify your project. Then, 
when you create a document, you can associate it with a document type already 
defined in your project. The new document inherits the style and functional attributes 
associated with the document type, making it consistent with other documents of the 
same type.

RequisitePro provides standard document outlines that can be used “as is” or 
customized according to your specifications. After you have defined the appearance 
of the document and the information to include, you can use the document as a 
standard for your organization.
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There are several benefits to using standards: 

■ The outline can be used as an example of the type of information to include and 
can serve as a comprehensive “to do” list so no information is overlooked.

■ Expectations and procedures are clearly presented so new authors and team 
members spend less time learning to build the necessary requirements documents.

■ Authors familiar with the outline can create new documents quickly. 

■ Readers familiar with the outline can quickly locate and review information.

Hierarchical Relationships

Hierarchical requirement relationships are one-to-one or one-to-many, parent-child 
relationships between requirements of the same type. Use hierarchical relationships to 
subdivide a general requirement into more explicit requirements. 

Example: 

Parent requirement:
The system shall display customer information.

Child requirements provided for detail:
Name
Address
Date of Birth

When working with hierarchical relationships, keep the following in mind:

■ Each child requirement can only have one parent, but a requirement can be both a 
parent and a child.

■ The parent and child requirements must be located in the same place. If a parent 
requirement appears in a document, the child requirement should also appear in 
that document. (Note that all requirements are stored in the database.) 

■ You can create hierarchical relationships in a document or in a view by using the 
Hierarchy tab in the Requirement Properties dialog box. (You can also use 
Requirement menu commands to create hierarchical relationships in a view.)

■ When you delete a parent, you can choose to delete its children or assign them to 
another parent.

■ You cannot create a traceability relationship between a parent and its own child.
24 Chapter 2 - Introducing Rational RequisitePro



■ Hierarchical relationships are a type of change-managed relationship in 
RequisitePro. If a requirement is changed, the relationships with its children 
become suspect. You can view and manage suspect relationships using one of two 
views: a Traceability Matrix or a Traceability Tree.

(For more information, see Working with Hierarchy on page 135.)

Traceability Relationships

Traceability links requirements to related requirements of same or different types. 
RequisitePro’s traceability feature makes it easy to track changes to a requirement 
throughout the development cycle. Without traceability, each change would require a 
review of your documents to determine which, if any, elements need updating.

When working with traceability relationships, keep the following in mind:

■ You can create a traceability relationship between requirements of the same or 
different types.

■ You can create traceability relationships between requirements that exist in the 
same document, in different documents, or in the project database.

■ You can create, view, and manipulate traceability relationships in a document or in 
a view.

■ Traceability relationships are a type of change-managed relationship in 
RequisitePro. If either end-point of the connection is changed, the relationship 
becomes suspect. If you modify the text or selected attributes of a requirement that 
is traced to or traced from another requirement, RequisitePro marks the relationship 
between the two requirements “suspect.”

■ Traceability relationships cannot have circular references. For instance, a 
traceability relationship cannot exist between a requirement and itself, nor can a 
relationship indirectly lead back to a previously traced from node. RequisitePro 
runs a check for circular references each time you establish a traceability 
relationship. 

Note:  You cannot create a traceability relationship between a parent and its own child, 
but you can create a traceability relationship between a parent requirement and a 
different parent requirement’s child.

(For more information, see the chapter Working with Traceability on page 145.)
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Traced to/Traced from Relationships

The trace to/trace from state represents a bidirectional dependency relationship 
between two requirements. The trace to/trace from state is displayed in a Traceability 
Matrix or Traceability Tree when you create a relationship between two requirements. 

For example, you might create a feature requirement (Requirement A) that calls for a 
new command to be added to a particular menu in your application. In addition, in 
another requirements document, you might create a use-case requirement 
(Requirement B) associated with that menu item. You would thus create a traceability 
relationship in which the use-case requirement (B) is traced from the feature 
requirement (A).

There can be only one traceability relationship between any two requirements. The 
difference between a trace to and a trace from relationship is perspective. In the 
example above, both of the following statements are true:

■ A is traced to B

■ B is traced from A

Direct and Indirect Traceability Relationships

Traceability relationships may be either direct or indirect.

In a direct traceability relationship, a requirement is physically traced to or from 
another requirement. For example, if Requirement A is traced to Requirement B, and 
Requirement B is traced to Requirement C, then the relationships between 
Requirements A and B and between Requirements B and C are direct relationships. 
The relationship between Requirements A and C is indirect. Indirect relationships are 
maintained by RequisitePro; you cannot modify them directly. 

Direct and indirect traceability relationships are depicted with arrows in traceability 
views. Direct relationships are presented as solid arrows, and indirect relationships 
are dotted and lighter in color. 

Suspect Relationships

A hierarchical relationship or a traceability relationship between requirements 
becomes suspect if RequisitePro detects that a requirement has been modified. If a 
requirement is modified, all its immediate children and all direct relationships traced 
to and from it are suspect. 

When you make a change to a requirement, the suspect state is displayed in a 
Traceability Matrix or a Traceability Tree. Changes include modifications to the 
requirement name, requirement text, requirement type, or attributes.
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For more information about parent-child relationships or traceability relationships 
that are marked suspect, see the sections Suspect Relationships on page 143 and Suspect 
Relationships on page 151.
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3Getting Around in 
Rational RequisitePro
This chapter explains the basics of opening Rational RequisitePro and accessing 
RequisitePro projects.

Starting RequisitePro

You can start RequisitePro in one of two ways:

■ On the Start menu, click Programs. Click the installed Rational Windows Suite 
and/or RequisitePro version, and then click RequisitePro.

■ In Windows Explorer, double-click any file name with the .rqs extension.

Working in RequisitePro 

When you start RequisitePro, the Open Project dialog box opens, which lets you select 
a project to work with or to create a new project. Click the tab labeled Existing to select 
a project from your project list, or click the New tab to create a project.
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RequisitePro includes the Explorer window (a tree browser) and a description 
window. The Explorer is RequisitePro’s primary navigation window. It lists the 
requirements artifacts—requirements, views, documents, and other packages— of 
the open project, organized in packages. When you select an artifact, a description of 
it appears in the window below the Explorer. Views appear to the right of the 
Explorer. RequisitePro documents are presented separately in Microsoft Word. 

The toolbar and menus in RequisitePro contain RequisitePro commands and provide 
access to project information, requirements information, and views. When you 
position your cursor over a toolbar button, a ToolTip appears, describing the button’s 
function.

Working with Projects and Project Packages

When you start RequisitePro, the Open Project dialog box opens, which lets you select 
a project to work with or to create a new project. The Existing tab lists all the 
RequisitePro projects that are accessible to you. You can add or remove projects from 
your list as you need them. 

In the Open Project dialog box, projects are listed according to recent use; the projects 
you have opened most recently appear at the top of the list. When you select a project 
and click OK, it appears in the Explorer, following the RequisitePro icon. The plus sign 
that precedes the name of the project indicates that it contains artifacts; click the plus 
sign to expand the list and see the hidden objects. 

Within each project, requirements artifacts are organized in packages. A package is a 
container that can contain requirements documents, requirements, views, and other 
packages. You can place related artifacts in a single package, and this organization 
makes it easier for you to view them and to manipulate the data. You can configure 
your packages as necessary to facilitate your work. An artifact cannot appear in more 
than one package, but you can move it from one package to another. You can create a 
package within another package. All project packages are shared by all project users.

Within a package, artifacts are listed in the following order: documents (alphabetically 
by name), views (by type and then alphabetically within the type), and requirements 
(by type and then by tag). 

Adding a RequisitePro Project to Your Project List

Before you can access a RequisitePro project, you must add it to your project list. 
Projects you create are automatically added to your project list.
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1 Click File > Open Project. The Open Project dialog box opens.

2 Click Add. The Add Project dialog box opens. 

3 Select the project file you want to add to the list. (Project files have an .rqs 
extension.)

4 Click Open. RequisitePro adds the project to your project list, and it appears with 
the projects listed on the Existing tab. You can now open the project and use its 
requirements and documents. 

Tip: Click the Properties button to view or change the database properties of the 
selected project. 

5 Click OK to save the changes.

Note: To add a project stored on a floppy disk, move or copy the project to a local drive 
or network drive (using Windows Explorer), and then add it to your project list.

Removing a Project from the Project List

You can remove a RequisitePro project from your project list without deleting the files 
from your system. 

To remove a project from the project list:

1 Click File > Open Project.
The Open Project dialog box opens.

2 Select the project you want to remove, and click Remove. RequisitePro removes the 
project.

3 Click OK to save the changes.

Note:  You can retrieve a project you removed by clicking the Add button. (See the 
preceding section.)
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Opening a Project and Project Documents 

When you open a RequisitePro project, the project appears in the Explorer. Project 
artifacts may be hidden from view until you click the plus sign. The artifacts are 
arranged in packages, as described in Working with Projects and Project Packages on 
page 30. To open an artifact, you select it in the Explorer; then, either double-click it or 
right-click and click Open.

Projects that were created in RequisitePro version 4.0 or later must be updated. When 
you try to open a project that must be updated, the Database Upgrade Wizard 
appears. The wizard guides project administrators through the process of upgrading 
existing database structure and project data to the current RequisitePro release. For 
information about the upgrading of projects that are not organized in packages, see 
Upgrading RequisitePro Projects to the Latest Version on page 179. 

If a project is in a version of RequisitePro earlier than 4.0, you must first upgrade the 
project to version 4.0 before using the Database Upgrade Wizard. Contact Customer 
Support for information. 

Note:  Do not open a project for which a baseline is being created in Unified Change 
Management or one that is being added to ClearCase.

To open a project:

1 Click File > Open Project (or click the Project button).

The Open Project dialog box opens.
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2 Select the project you want to open, and select one of the Open Project Options 
check boxes. If you want to be the only user who has change permissions for the 
project, select the Exclusive check box. To open the project and its documents in 
read-only mode, select the Read Only check box. Click OK. 

Depending on the security setting for the project, one of two dialog boxes opens:

❑ If security is set on the project, see Accessing a Secure Project on page 34.

❑ If no security is set on the project, but your user name has not been identified in 
the project, the Project Logon dialog box opens.

3 Do one of the following:

❑ Accept the displayed name. 

❑ Select a user name from the list.

❑ Type a new user name that will be added to the project.

4 Click OK. The project appears in the Explorer. If the project is already open by 
another user who has exclusive rights, you are given read-only access. 

You can open one or more requirements documents in an open RequisitePro project in 
one of the following ways:

❑ Double-click one or more documents in the Explorer.

❑ Click Window > Show Word. In Word, click RequisitePro > Document > Open. The 
Open Document dialog box opens. Select one or more documents and click OK.

Note:  Do not press the ESC key while the document is opening. If you want to 
view the document but not make modifications to it, you can select it in the 
Explorer, right-click, and click Open Read Only. 

Closing a Project and Documents

The Close command closes a project and its documents and any open views.

1 Click File > Close Project.

If you made no changes, the Project Close dialog box opens and prompts you to 
close the project and its documents or keep it open. Click Yes to close the project 
and its documents.
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If you modified but did not save a document, the Document Changed dialog box 
opens.

2 Do one of the following:

❑ To save the changes to the document, click Yes. If you made changes to a 
requirement’s text, the Change Description dialog box opens and asks you to 
enter the reason for the changes before saving.

❑ To close the project without saving the document changes, click No. 

❑ To cancel the close project procedure, click Cancel.

❑ To review document changes, click Review Changes. If you made changes to a 
requirement’s text, the Change Description dialog box opens and asks you to 
enter the reason for the changes.

The Document Changes dialog box opens, listing each modification to the 
document.

3 Do one of the following:

❑ To save the changes to the document, click Yes. 

❑ To close the project without saving the document changes, click No. 

❑ To cancel the close project procedure, click Cancel.

Accessing a Secure Project

Project administrators can enable security for a project, requiring users to log on and 
provide a password. The project administrator sets up security and assigns a user 
name and password to each member of the team.
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Logging on to RequisitePro

To log on and to access a secured RequisitePro project: 

1 Click File > Open Project. The Open Project dialog box opens.

2 Select a project in the list to open and click OK. If RequisitePro detects that security 
is enabled, the Project Logon dialog box opens. 

3 Type your name in the Username box. Usernames cannot exceed 20 characters, and 
they are not case sensitive.

4 Type your password. Your password is set up by a project administrator. 
Passwords are case sensitive; for example, Mycomputer, MYCOMPUTER, and 
mycomputer are separate passwords. 

5 Click OK. You are now ready to use the project. 

Modifying Your Password, User Name, or E-mail Address

When you are in a project, you can modify your password, user name, or e-mail 
address. If you are a RequisitePro administrator or a member of a group with project 
security permissions, you also have the ability to change the password, user name, or 
e-mail address for other users. See Editing User Information on page 185.

A valid e-mail address is necessary for receiving RequisitePro discussion messages 
via e-mail. For more information, see Configuring E-mail for Discussions on page 65.

1 Open a project and log on. 

2 Click File > Project Administration > Security.
The Project Security dialog box opens.

3 Select the Enable security for this project check box. Select a user group and a user 
name, and click the Edit button.
Working in RequisitePro 35



The Edit User dialog box opens.

To change your password:

1 Type your password in the Old Password text box that appears in the dialog box. 
(This step applies only to users who do not have project security permissions.)

2 Type your new password in the New Password text box. Passwords are case 
sensitive and are limited to 14 alphanumeric characters.

3 Confirm the new password by typing it again in the Verify box. 

4 Click OK. Your new password is in place and ready for use.

To change your user name (for users with project security permissions):

1 Select your current name in the Username field.

2 Type a new user name. User names are limited to 20 alphanumeric characters and 
are not case sensitive.

3 Click OK. Your new name is in place and ready for use.

To change your e-mail address:

1 Select your current e-mail address in the E-mail Address box.

2 Type a new e-mail address.

3 Click OK. Your e-mail address is in place and ready for use.

Closing RequisitePro

Close the project and project documents (see Closing a Project and Documents on 
page 33). Then click File > Exit.
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4Working in Views
Rational RequisitePro views use tables or outline trees to display requirements and 
their attributes or the traceability relationships between different requirement types. 
RequisitePro includes powerful query functions for filtering and sorting the 
requirements and their attributes in views.

A view is an environment for analyzing and printing requirements. You can have 
multiple views open at one time, and you can scroll to view all requirements and 
attributes in the table or tree. The number of requirements in the current view appears 
in the lower right corner of the views window.

You can create three kinds of views:

■ The Attribute Matrix view displays all requirements and their attributes within a 
specified type.

■ The Traceability Matrix view displays the relationships between requirements of 
two types.

■ The Traceability Tree view displays the chain of traceability through the project 
requirements. A Traceability Tree can be set up in one of two directions: traced out 
of requirements of a specified type or traced into requirements of a specified type.

You can do the following in a view:

■ Create and modify the requirement name, requirement text, requirement 
attributes, and traceability relationships

■ Sort and filter view information

■ Save a view’s query and display setup

■ Save view information to other formats

■ Print views
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Accessing Functions and Navigating in Views

All views commands are located in the toolbar. To navigate in a view quickly, use the 
arrow keys, the PAGE UP or PAGE DOWN keys, and the HOME and END keys. Use the 
right button on the mouse as a shortcut to commands that are specific to requirements 
and attributes. Move the mouse over the requirements and attribute labels and click 
the right button to access these shortcut menus. For more information, see Mouse 
Actions and Shortcuts in Views on page 266.

When you select a requirement in a matrix or a tree, the full name and text of the 
selected requirement are displayed in the text pane at the bottom of the view. (You can 
resize the text pane by positioning the mouse on the upper border and dragging 
upward.) When you select a requirement in the Explorer, the requirement name 
appears in the description window below the Explorer pane. 

Viewing Current Data

While a view is open, other users may add, delete, or modify requirements that are 
displayed in your view. These changes are not automatically reflected in your open 
view or in the Explorer.

To update the data displayed in the view and in the Explorer for requirements that 
were modified by other users, click in the view or in the Explorer and then click View 
> Refresh (or the Refresh the view button). The Refresh command updates the 
displayed content. 

Traceability in a View

The Traceability Matrix and Traceability Tree views display traceability relationships, 
and the Traced-to or Traced-from attributes appear in the Attribute Matrix. A 
traceability relationship is displayed as suspect when you make a change to a 
requirement. For more information about traceability relationships between 
requirements, see the chapter Working with Traceability on page 145. 

■ Arrows are used to indicate direct traceability relationships in the Traceability 
Matrix and Traceability Tree views. If the arrow points from A to B, then the 
following two statements are true: A is traced to B and B is traced from A.

■ In the Traceability Tree and Traceability Matrix views, suspect traceability 
relationships are marked as lines through the arrows. In an Attribute Matrix, 
suspect relationships are denoted by an (s) after the requirement tag in the 
Traced-to or Traced-from column.
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■ A requirements relationship is indirect if the relationship is derived by traversing 
the requirements relationships. An arrow outlined by a dotted line, lighter in color 
than a direct relationship arrow, indicates an indirect traceability relationship in 
the Traceability Tree and the Traceability Matrix.

Hierarchy in a View

All views display hierarchical relationships, and you can use the Traceability Matrix 
and Traceability Tree to display hierarchical relationships that are marked suspect. 
For more information about hierarchical relationships between requirements, see the 
chapter Working with Hierarchy on page 135. 

■ You can create hierarchical relationships in a view by using Requirement menu 
commands or editing the requirement properties in the Hierarchy tab of the 
Requirement Properties dialog box.

■ When you modify a parent requirement, RequisitePro marks the relationships 
between the parent and all its immediate children as suspect.

■ When you modify a child requirement, the relationship with its parent is not 
marked as suspect.

■ When a child requirement is assigned to a new parent, all hierarchical 
relationships between the new parent and its immediate children are 
automatically marked as suspect. The relationships between the children and their 
children are not marked as suspect.

■ In the Traceability Tree, you can manually mark a hierarchical relationship as 
suspect or clear a suspect relationship.

You can set the level of child requirements to display in a view or in the Explorer. 

1 Click View > Displayed Levels. The Displayed Levels dialog box opens.

2 Set the number of levels to display in the rows. If you select 1, only root artifacts 
are displayed; if you select 2, one level below the root artifacts is displayed; and if 
you select all, all levels are displayed. For a Traceability Matrix, set the number of 
the levels to display in columns.

3 Click View > Properties > Save as Default to save these levels as the defaults for a 
view. This command saves the currently selected pane size, window size, 
displayed levels, and all view properties as default settings.
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The Attribute Matrix

The Attribute Matrix is a spreadsheet-like display that lists requirements of a specific 
requirement type and their attributes. Requirements are arranged in rows, listed by 
tag number and followed by requirement name (or requirement text, if the 
requirement has not been assigned a name). Attributes are arranged in columns. The 
Attribute Matrix displays all requirements, and you can create requirements in the 
database from this view. 

Requirements

In an Attribute Matrix, a requirement is displayed in a single row, showing the 
requirement tag followed by the requirement name (or requirement text if the 
requirement has not been assigned a name). When requirement text exceeds the 
width of the row, the last character is followed by an ellipsis (...), signifying the 
presence of additional text. An arrow marker at the beginning of a row indicates a 
selected row.

An * and <Click here to create a requirement> marks the beginning of the empty row at 
the bottom of the matrix, where you can insert a new requirement. A pencil icon at the 
beginning of a row indicates that the requirement information you are entering has 
not yet been saved. 

Attribute
Label

Attribute
Value

Requirement
Tag and

Text
Pane

Name or 
Text
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To change the number of lines of requirement name and/or requirement text 
displayed, click View > Row/Column Sizing, and then select a different value for the 
row or column size.

Attributes

Attribute labels are listed at the top of each column. Corresponding attribute values 
are listed beneath the attribute labels. Query information is displayed here as well. 

Click View > Displayed Attributes to select the attributes you want to display in the 
view. The Attribute Matrix displays all internal and external traceability relationships 
in the Traced-to and Traced-from columns; suspect traceability relationships are 
denoted with an (s) in the relevant column. You can change the size of the attribute 
columns.

Text Pane

The text pane, located at the bottom of the Attribute Matrix, displays a requirement's 
tag, name, and text, and it reads “Multiple requirements selected” if you have selected 
more than one requirement. This field is read-only. Graphics and OLE objects 
included in requirement text are displayed as small rectangular symbols. For 
Word-linked files included in the requirement text, the path and time stamp of the 
linked file are presented. The default size of the text pane is two lines, but you can 
drag the border to increase the size.

The Traceability Matrix

The Traceability Matrix displays and manipulates the relationships between two 
requirement types. The requirements can be of the same type or of different types, and 
they include all internally and externally mapped requirements. Use this view to 
create, modify, and delete traceability relationships and to view indirect relationships. 
The Traceability Matrix also shows traceability relationships that are marked as 
suspect. If you display a Traceability Matrix of requirements of the same type, it 
shows hierarchical relationships that are marked as suspect.

In this view, a requirement is traced to or traced from another requirement. For 
example, Requirement B is traced from Requirement A if it was directly or indirectly 
derived from Requirement A. If Requirement A is the basis of several other 
requirements, Requirement A is traced to these requirements.

An arrow pointing from one requirement to another indicates that a direct traceability 
relationship exists between the requirements. A dotted line arrow indicates an 
indirect relationship.
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Rows and columns can be resized. The intersection of a row and column is called a 
cell.

To change the number of lines of requirement name and/or requirement text 
displayed, click View > Row/Column Sizing and then select a different value for the row 
or column size.

Note:  If the requirement has a name assigned, that name appears in the first line of 
each row or column. Increase the row or column size to view both the name and text.

Cells
■ If the cell is blank, no relationship exists.

■ If an arrow points upward to a column requirement, the row 
requirement is traced to the column requirement.

■ If an arrow points down toward a row requirement, the row 
requirement is traced from the column requirement.

■ If a dotted line arrow is displayed, an indirect relationship exists.

■ If an arrow with a red diagonal line through it is displayed, the 
traceability relationship is suspect.

■ If a triangle with a red diagonal line through it is displayed, the 
hierarchical relationship is suspect.

Text Panes

The Traceability Matrix displays two text panes at the bottom of the window. These 
panes let you review the requirements in each area, so you can easily create, modify, 
and delete traceability relationships. The default size of each pane is set to one line 
and can be resized. The top text pane displays the name (or text) of the currently 
selected row requirement, and the bottom pane displays the name (or text) of the 
currently selected column requirement. These fields are read-only. If the selected 
requirement has been assigned a name, that name appears in the text pane. 
Otherwise, the requirement text appears in the text pane. When more than one row or 
column is selected, the corresponding text pane displays the message “Multiple 

Traced to arrow

Traced from arrow

Indirect relationship

Suspect relationship

Suspect relationship
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requirements selected.” Graphics and OLE objects included in requirement text 
appear as small rectangular symbols. For Word-linked files included in requirement 
text, the path and time stamp of the linked file are presented. 
.

The Traceability Tree

The Traceability Tree provides a graphical view of relationships to or from (internal 
and external) requirements of one specific requirement type, including direct, 
indirect, and suspect traceability relationships. Although direct and suspect 
relationships are modified in this view, RequisitePro permits read-only access to 
indirect relationships.

In addition, the Traceability Tree displays hierarchical relationships and shows 
parent-child relationships that have been marked as suspect.

Selected Row

Rows Cell

Requirement
Selected Column
Requirement

Columns
The Traceability Tree 43



The tag, name, and attributes of the selected requirement are displayed in the 
attribute pane.

When creating a Traceability Tree, you can choose one that displays all requirements 
traced to the requirements on which the tree is based or one that shows all 
requirements traced from the requirements on which the tree is based. 

Tree Pane

Traceability relationships for root-level requirements are indented and preceded by 
an arrow. Child requirements are indented below their parents and preceded by a 
triangle. The text pane below the tree provides the name and text of the selected 
requirement in the tree; the pane on the right side of the view displays requirement 
attributes of the highlighted requirement.

Note:  To resize the tree pane, click the border between the tree and attribute panes. 
Press the left button on the mouse and drag it left or right to the size you want. This 
does not affect the length of the lines set in the Row/Column Sizing dialog box. 

Attribute Pane

Text Pane

Tree Pane

Root-Level
Requirement

Branch-Level
Requirement
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If the arrow leading from a root requirement points toward a branch 
requirement, the branch requirement is traced from the root requirement. (This 

appears only in a Traced out of Traceability Tree.)

If the arrow leading from a branch requirement points toward a root 
requirement, the branch requirement is traced to the root requirement. (This 

appears only in a Traced into Traceability Tree.)

If an arrow with a red diagonal line is displayed, the traceability relationship is 
suspect. 

If a triangle with a red diagonal line is displayed, the hierarchical relationship is 
suspect.

Attribute Pane

The attribute pane, located on the right side of the Traceability Tree, displays the tag, 
name, and attributes associated with the currently selected requirement. To display 
the attributes of a particular requirement, click the requirement in the tree pane. This 
is a read-only text box and cannot be edited.

If you have more than one requirement selected, the pane displays the attributes for 
the first requirement selected.

Text Pane

The text pane, located in the lower section of the Traceability Tree, displays a 
requirement's name and text. This field is read-only. To display the full name and text 
of a particular requirement, click the requirement in the tree pane. To adjust the 
height of the pane, click its upper border and drag the pane to the size you want.

The text pane is blank when a requirement is not selected. When more than one 
requirement is selected, the text pane displays the message “Multiple requirements 
selected.” Graphics and OLE objects included in requirement text appear as small 
rectangular symbols. For Word-linked files included in requirement text, the path and 
time stamp of the linked file are presented. 

Working with Views

This section presents the fundamentals of working in a view:

■ Creating a view

■ Expanding and collapsing a view
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■ Saving a view

■ Opening and closing a view

■ Renaming a view

■ Printing a view

■ Deleting a view

Creating a View

1 Select the package in which you want the new view to appear and click File > New 
> View. The View Properties dialog box opens. 

2 Do the following:

❑ In the Name box, type the name under which you want the view to be listed in 
the Explorer. Filling in the Description box is optional. 

Note:  The Package box contains the name of the package you selected in Step 1. 
Click the Browse button if you want to change that selection.

❑ Select the view and requirement types. Note that user-defined requirement 
types are also displayed. The Traceability Matrix displays two requirement 
types (one type for the row and another for the column), the Attribute Matrix 
displays a single requirement type, and the Traceability Tree displays a single 
requirement type at the root level. Only requirements associated with the 
selected requirement types appear in the view. 
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❑ Select the Private check box if you want to be the only user who can open the 
view.

Note:  The Author, Date, and Time boxes are read-only and cannot be modified. 

3 Click OK. The view opens and appears in the Explorer in the package you selected 
in Step 1, listed alphabetically by name.

4 Click File > Save View to save the view in the project database.

Expanding and Collapsing a View

You can expand and collapse hierarchical relationships in all views and in the 
Explorer and traceability relationships in the Traceability Tree. An expanded view 
shows the root requirement and all its sublevel requirements. Collapse the view to 
show only the root-level requirements.

The Expand All command expands all relationships in a view. When you select this 
command in a Traceability Tree, a requirement that has a traceability relationship 
with a root requirement appears as a branch of the root requirement. This command 
also expands all parent requirements, displaying all children, in all views.

The Collapse All command collapses all relationships in a view. When you select this 
command in a Traceability Tree, a requirement that has a traceability relationship 
with a root requirement is no longer displayed. This command also collapses all 
parent requirements, hiding all children, in all views.

You can expand the parent requirement by clicking the plus sign next to the parent 
requirement, selecting the parent and clicking SHIFT +, or selecting the parent and 
clicking View > Expand. You can collapse the parent requirement by clicking the 
minus sign next to the parent requirement, selecting the parent and clicking the minus 
(-) key, or selecting the parent and clicking View > Collapse. Use the Expand All 
command to expand all hierarchical or trace tree relationships in the view; use the 
Collapse All command to collapse all hierarchical or trace tree relationships in the 
view.

Saving a View

When you save a view, the layout of the view and the query criteria are also saved. 
The data within the view is not saved as part of the view; it is part of the database. 
Thus, when you open a saved view, the display shows the current information in a 
saved view format.

Note:  The saved view is not a snapshot of requirement information for a particular 
date. To save the results of a query, you must print the view. For more information on 
queries, see the chapter Querying and Searching on page 55.
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If you want to save a view and you have more than one view open, make sure that the 
view you want to save is active. To make an open view active, click the title bar. 

To save a view:

1 Open the view that you want to save.

2 Click File > Save View (or the Save the current view button). 

RequisitePro organizes views by view type in the Explorer. The view you saved 
appears in the package for that view type, listed alphabetically by title. 

Opening and Closing a View

When you open a saved view, RequisitePro displays the view according to the 
specified layout and re-applies the query criteria to the current project database. The 
display therefore shows the current information in a saved view format. To open a 
view, select the view in the Explorer and double-click it. 

To close a view, click the X in the upper right corner of the screen (the one below the 
top-level X in the title bar).

Renaming a View

Renaming can be used to change the name of an open view window. You might want 
to give a view a longer, descriptive name before you print it, so that the new name 
appears on the printed page. You can still retain the original name in the file system. 
Renaming a view does not save the renamed view to the database until the view is 
saved again.

1 In the Explorer, select the view you want to rename and click File > Properties, or 
open a view and click View > Save View As. 

The View Properties dialog box opens.

2 Type a new name for the view in the Name box and click OK.

3 Click File > Save View to save the renamed view to the database.

Note:  The view is alphabetized in the Explorer by the new name after you click 
View > Refresh.

Printing a View

You can print any active view, and you can choose to print the entire matrix or 
selected items.
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To print an open view:

1 If you want to print only a selected requirement or relationship, click the 
requirements or relationships in the matrix. (Use a multiple select action to select 
multiple requirements or relationships.)

2 Click File > Print. The Print dialog box opens.

3 If you are printing selected requirements or relationships, click Selection.

4 Make any other necessary changes to the Print dialog box, and then click OK.

Note:  Use the Print button on the toolbar to print directly to the default printer. The 
entire view is printed using the default printer selections.
You can also export a view to a comma-separated value (CSV) file and use another 
application, such as Excel, to open the file and arrange the data for printing. For more 
information, see Exporting a View as a CSV File on page 167.

You can specify the header and footer information to be printed with the view. In an 
open view, click File > Page Setup. In the Page Setup dialog box, select the information 
you want to appear, and then click Print.

Deleting a View

A personal view can be deleted only by the person who created it. A projectwide view 
can be deleted by the person who created it or by a member of the Administrators 
Group.

1 In the Explorer, select the view you want to delete.

2 Click Edit > Delete. 

Customizing Views

You can customize the look and content of every view you create. You can: 

■ Adjust the size of rows and columns. 

■ Filter and sort data according to query criteria, so that only requirements that 
match the query criteria are displayed.

■ Select specific view properties to display, such as buttons, requirement name and 
text, lines, images, root images, and trace to and trace from buttons.

■ Save a defined view for future use. Saving a view saves its query criteria and 
layout, but not the requirement data. 
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Adjusting Row Height

Adjusting row height affects all rows in the view.

1 Click View > Row/Column Sizing.
The Row/Column Sizing dialog box opens.

:

2 Type the number of lines to display for each requirement. The maximum number 
of lines depends on a monitor’s display resolution. 

3 Click OK. The view is modified according to your specifications.

You can also use a shortcut to adjust rows. Click and hold the mouse on any border in 
the requirement area, and then drag the row up or down to the size you want. If the 
row height is already set at one line, RequisitePro will not let you drag the row up to 
less than one line. The Traceability Tree does not have a shortcut. 

Adjusting Column Width

1 Click View > Row/Column Sizing.
The Row/Column Sizing dialog box opens, as shown above.

2 Type the number of pixels (in the Attribute Matrix) or lines (in the Traceability 
Matrix) to display for each requirement or attribute. Parameters for column widths 
in different views follow.

❑ Attribute Matrix: To set a different width for each column, drag the column to 
the width you want. To set an equal width for all columns, use the 
Row/Column Sizing dialog box. The maximum screen height is based on your 
screen’s resolution.

❑ Traceability Matrix: RequisitePro determines the maximum width on the basis of 
screen resolution.
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❑ Traceability Tree: The column width is represented by the amount of indentation 
or each branch. RequisitePro dynamically changes the maximum number of 
pixels allowed in these columns according to the width of the requirement pane 
and the size of the view. Any change to the column width affects all of the 
columns in this view.

3 Click OK to commit these changes. 

You can also use a shortcut to adjust rows. Click and hold the mouse on any border in 
the attribute label area or the requirement area (the gray area at the top of each 
column) in an Attribute or Traceability Matrix. Drag the width left or right to the size 
you want. The Traceability Tree does not have a shortcut.

Resizing and Arranging Views

Use the menu commands or the buttons on the toolbar to define the size and arrange 
the order of a view.

Creating Cascaded Views

In a cascaded views arrangement, each view is displayed to the right and slightly 
below the preceding view. If many views are open, RequisitePro may overlap the first 
cascade of views with a second cascade until all open views are arranged. 

Click Window > Cascade. RequisitePro cascades the views.
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Creating Tiled Views

A tiled view arranges open views next to each other without overlap. To tile the 
views, click Window > Tile. 

Arranging Icons

Icons for all minimized views can be arranged from left to right, beginning at the 
bottom left corner of the view. To arrange the minimized views, click Window > 
Arrange Icons. 

Displaying View Properties

Use the Properties command to display properties associated with an active view. 
Each view displays distinct properties. These properties affect how the view appears 
and not the information contained therein.

Click View > Properties. Eight menu commands are listed; however, some are not 
available, depending on the type of view that is active. (For example, the option Show 
Trace to is not available when an Attribute Matrix is active.) If they are checked off on 
the menu, they appear in the active view.

■ Save as Default saves the current view settings as the default settings for a new 
view.

■ Reset Default resets the view properties to the saved default settings.
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■ Show Name displays the requirement name. You can define the number of lines 
displayed by clicking View > Row/Column Sizing.

■ Show Text displays the requirement text. You can define the number of lines 
displayed by clicking View > Row/Column Sizing.

■ Show Trace To or Show Trace From displays arrows in the direction of either trace to 
or trace from relationships, depending on your selection. (These options are not 
available when an Attribute Matrix is active.)

■ Show Indirect displays both direct and indirect traceability relationships. (This 
option is only available when a Traceability Matrix is active.)

■ Show Expand Indicators displays a + in the cell if the child requirements of a 
collapsed requirement contains traceability relationships. (This option is only 
available when a Traceability Matrix is active.)

Saving View Properties as Default

The Save As Default command saves a view layout and any properties displayed as 
the default when opening views of that type. This command is available for all view 
types. To save a view and its displayed properties as the default for views of that type, 
click View > Properties > Save As Default. RequisitePro saves the view, layout, and 
properties for views of that type.

Note:  Use the Reset Default command to reset any view properties that have been 
changed back to the saved default settings.
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5Querying and Searching
Creating and Using Queried Views

After you have created a view, you can save it as is, or you can refine the view by 
querying (filtering and sorting) its information in a variety of ways.

You can filter requirements in views by limiting the values of one or more attributes or 
by limiting traceability. You can query requirements displayed in rows in an Attribute 
Matrix or Traceability Matrix, columns in a Traceability Matrix, or root requirements 
in a Traceability Tree.

Querying Overview

Filtering restricts the information being displayed, and sorting determines the order 
in which the information is displayed. For example, in an Attribute Matrix, you may 
want to order requirements information from highest to lowest priority (sort criteria) 
and view only those requirements assigned to you (filter criteria).

You can filter and sort requirements by applying query criteria to the attributes. These 
criteria limit the values of the attributes and the traceability relationships. You can 
create an attribute-by-attribute query, so that you can see the results of each query 
criterion, or you can create a query that filters and sorts several attributes at the same 
time. When you save a view, you save the query criteria.

You can temporarily sort requirements by attribute value in an Attribute Matrix by 
right-clicking the attribute label and clicking Sort Ascending or Sort Descending on 
the shortcut menu. When you save the view, this sorting is not saved. 

The default sort order in a view is ascending by requirement tag. When you create a 
query that includes multiple query criteria, you can sort the criteria to determine the 
order in which the requirements are displayed in a view. You can also modify the sort 
order after you have created a query. For example, you might sort requirements by 
priority; within priority, you might sort by date and by location. The requirements are 
listed by date and in the order in which they appear in the document.

Queries on requirements in a particular package return requirements that match the 
query in that package. The query results do not include requirements that are stored 
in nested packages within the package you selected.
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You cannot query for hierarchical requirement relationships that are suspect. Parent 
requirements are automatically grouped with child requirements in unsorted and 
unfiltered views. 

Rational RequisitePro does not automatically update queries. You can update the 
requirements information in a query by clicking View > Refresh. You can update 
changes to the view itself (including changes to the queries that other users have 
saved) by selecting the view in the Explorer and clicking Refresh on the shortcut 
menu. Refreshing displayed content is particularly important when other users are 
working in the same database.

When you query requirements across cross-project traceability relationships, note that 
queries related to user and document information include data from the open project 
only. Data from external projects is included in queries on system attributes such as 
requirement text, revision number, and revision date, but not on user or document 
information. You must open the external project to query on those criteria.

When you query requirements across projects that use enterprise databases, note that 
cross-project traceability queries that use the trace to or trace from attributes are 
supported only between projects of the same database type. To query between SQL 
Server projects, the projects must reside in the same schema. For Oracle projects, you 
can create a link to a remote database that allows such queries. See the section 
“Creating a Database Link to the Remote Database” in Configuring an Oracle Database 
(OracleSetup.html).

Working with Queries

You can use a query to extract data from the database and present it for use in any of 
the three views. You can save, open, edit, print, and export queried views. 

Queried views range from simple to complex. When you query most attributes in a 
view, choose one requirement type at a time. If you base a query on the Trace to or 
Trace from attributes, you have the ability to select more than one requirement type 
for targets.

You can control the query. To ensure that information in a queried view is current, 
especially if other users are working in the database being queried, refresh the 
database with new data (click View > Refresh), and then reapply the query criteria.

■ By default, the Attribute Matrix view displays all attributes for any requirement 
type and all requirements of that type. You can display only the most necessary 
attributes when querying this view.

■ The Traceability Matrix view displays two requirement types and the 
interrelationships between them.
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■ The Traceability Tree view displays all requirements of one type (root) and all 
requirements related to/from them.

Note:  When an Attribute Matrix view or a Traceability Matrix view is queried, a filter 
or a sort is applied to the row or column requirements in the view. When a 
Traceability Tree view is queried, the filter and sort criteria are applied to the root 
requirements in the view.

Creating and Modifying Queries

You can filter requirements in views by limiting the values of one or more attributes or 
by limiting traceability. You can query row, column, root requirements, and external 
requirement types.

1 Select a view in the Explorer and click File > Properties. The View Properties dialog 
box opens. 

2 Click the Query button.

The Query [Row/Column/Root] Requirements dialog box opens. If you have not 
yet added any query criteria, the Select Attribute dialog box opens.

3 Select the attribute value that you want to use to query, and click OK.

Only one requirement type is available in the Select Attribute dialog box, unless 
you are querying with trace to or trace from attributes and have returned to this 
dialog box to modify the query.

The Query Requirements dialog box opens. The dialog box displayed depends on 
whether the attribute is a list-type or an entry-type attribute.

4 For list-type attributes, select one or more attribute values by which you want to 
filter an attribute; the logical operator OR is assumed for list-type attributes. For 
entry-type attributes, select an operator (that is, includes, equal to) and specify the 
value.

Tip: When querying on a date, enter the date in the same format as specified for 
your computer under Regional Settings in your Microsoft Windows Control Panel.
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5 Select a sort order (None, Ascending, or Descending). If you are querying on the 
Location attribute, you can select the Sort by document position check box to sort 
the requirements in the view in the same order as in the document that contains 
them.

6 Type When Traced criteria, if applicable. The When Traced option is available only 
when trace to or trace from attributes are queried. For hierarchical requirements, 
traceability queries automatically include the parent if the child participates in a 
traceability relationship. You cannot query for suspect hierarchical relationships, 
and you cannot create a traceability query between two external requirements.

7 Click OK. The Query [Row/Column/Root] Requirements dialog box opens again.

8 To add other query criteria, click Add and repeat Steps 3 through 7.

(The logical operator and is assumed between multiple attributes.)

9 Select the Retain Hierarchical Display check box to include the parents of filtered 
child requirements in the view, even if the parent requirements do not match the 
filter criteria you specified in the query.

(For more information about parent-child requirements, see Working with Hierarchy 
on page 135.)

10 Click OK. 

Creating and Modifying Sort Order for Queries

The default sort order in a view is ascending by requirement tag. When you create a 
query that includes multiple query criteria, you can sort the criteria to determine the 
order in which the requirements are sorted when you query the active view. You can 
also modify the sort order after you have created a query.

1 Open an Attribute Matrix, Traceability Matrix, or Traceability Tree.

2 Click View > Query [Row/Column/Root] Requirements. (The command displayed in 
the View menu depends on the view type you selected in Step 1.)

The Query [Row/Column/Root] Requirements dialog box opens.

3 To move criteria higher in the list, select the criteria and click Move Up. The criteria 
at the top of the list are applied first. To move criteria lower in the list, select the 
criteria and click Move Down. The criteria at the bottom of the list are applied last.

4 Click OK.

In an Attribute Matrix, you can temporarily sort requirements by attribute value. 
Right-click the attribute label and click Sort Ascending or Sort Descending on the 
shortcut menu. When you save a view, this sorting is not saved.
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Deleting Queries

You can delete a query for a view. Deleting a query does not delete any requirements 
from your database; it simply removes the ability to filter and sort a view based on the 
query criteria.

1 Open a view and click View > Query Row Requirements/Query Column 
Requirements/Query Root Requirements.
The Query Row/Column/Root Requirements dialog box opens (depending on 
your displayed view).

2 In the Query Criteria list, select the query criteria you want to delete.

Note:  The order of this list determines the order in which RequisitePro filters and 
sorts the criteria. Deleting a query from the list may affect the results of subsequent 
queries.

3 Click Remove.

Searching for Requirements Artifacts in a Project

RequisitePro provides two methods for finding requirements: 

■ The Go To command launches a global search of the database, quickly finds a 
requirement, and displays it in its location (document or view). 

■ The Find command launches a search for a requirement in the active view or 
document.

Navigating to a Requirement Using the Go To Command

You can use the Go To command to find a requirement location in a project. Using that 
command in an open document lets you jump quickly to a requirement in the 
document.

Navigating to a Requirement from a View

1 Select a requirement in a view or in the Explorer.

2 Click Requirement > Go To.

If the requirement is located in a document, the document containing the requirement 
opens, with the requirement selected. If the requirement is located in a view, the 
Requirement Properties dialog box opens, showing the name, text, attribute values, 
relationships, and discussions for the selected requirement.
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Navigating to a Requirement from a Document

1 In an open document, click RequisitePro > Requirement > Go To.

The Go To Requirement dialog box opens.

2 Select the requirement type from the Requirements of Type list. If you do not know 
the requirement type, select All Requirement Types. 

3 Select the location of the requirement from the Located in list. Choose All locations, 
Database only, or a specific document from the list.

Note:  Click the Find button to open the Find dialog box, which you can use to 
locate a specific tag number, requirement name, or text.

4 Select the requirement and click OK. RequisitePro performs one of the following 
operations: 

❑ If the requirement is in a document that is not open, RequisitePro opens the 
document and selects the requirement.

❑ If the requirement is in an open document, the document appears in the active 
window with the requirement selected.

❑ If the requirement is not located in a document, the Requirement Properties 
dialog box opens, and you can examine or modify the requirement name, text, 
attribute values, or traceability relationships.

Using the Find Command to Search a Project

The Find dialog box helps you find an artifact based on requirement name, text, or 
tag. The dialog box opens when you click Find in one of the following locations:
■ Edit > Find

■ RequisitePro > Requirement > Find
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■ Find button

■ Go To Requirement dialog box

■ Parent Requirement Browser dialog box

■ Select Requirements dialog box

The procedure for using the Find dialog box is the same no matter how you open it.

1 In the Text search box, type the text to use to search for the requirement name, text, 
or tag.

2 Select the Match case check box if you want to search only for requirements with 
an exact capitalization match.
For example, if you select this check box and enter the text menu, RequisitePro 
finds requirements containing menu but not requirements containing Menu.

3 Select the Use * as wildcard check box to search for requirements using the 
wildcard character * (asterisk) to match one or more characters in the search text.
For example, if you select this check box and enter the text *document*, 
RequisitePro finds requirements containing document, documents, documented, 
undocumented, and so on.

4 Select the Find whole words only check box if you want to search only for a whole 
word typed in the search text.
For example, if you select this check box and enter the text menu, RequisitePro 
finds requirements containing menu, but not requirements containing menus.
This check box is not available if more than one word is entered in the text search.

5 Do one of the following:

❑ Click Up to search from the cursor backward through the document.

❑ Click Down to search from the cursor forward through the document.

6 Click Find Next to search for the next requirement satisfying the search criteria.

Note:  In a view, all children of a parent requirement are searched, regardless of 
whether the children are currently displayed in the view. If RequisitePro finds a 
child requirement that matches the search criteria but is collapsed, the view is 
expanded so that the requirement is displayed.

■ If the requirement is found, RequisitePro highlights the requirement and displays 
it in context. 
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■ If the search is performed in a view and all requirements in the view are not 
expanded, RequisitePro expands the requirements in the view to display the 
results of the search.

■ If the requirement is not found, RequisitePro returns to the requirement from 
which the search began.

Reviewing a Project with Cross-Project Traceability

When you open a project, RequisitePro may connect to an external project and display 
requirements from both projects. In this case, the projects have been connected to one 
another, and cross-project traceability relationships may exist. You can review the 
requirements in both projects and their change-managed relationships in a view. 

Cross-project traceability creates traceability relationships between requirements that 
reside in different projects. This feature establishes connectivity among projects that 
were divided into subprojects or projects that relate to each other or share a set of 
requirements, thereby making it easy for team members to reuse common 
requirements across projects. (For more information about cross-project traceability, 
see Setting Up and Modifying Cross-Project Traceability on page 234 and the Help topic 
“Tip 3: Deciding how to organize RequisitePro projects.”)

Results of Cross-Project Traceability

When cross-project traceability relationships are established, the following can occur:

■ External requirement types can be queried for display in views. 

■ If a requirement that is traced to requirements in other projects is deleted, 
RequisitePro updates the other projects to reflect the change. If the traceability 
relationship in the external project cannot be deleted, the relationship is updated 
when connectivity is established between the projects.

■ If a requirement modification causes the relationship to become suspect, and the 
requirement is traced to or traced from requirements in other projects, RequisitePro 
updates the projects to reflect the suspect link. If the traceability relationship in the 
external project cannot be modified, the relationship is updated when connectivity 
is established between the projects.

■ If a link between an internal and external requirement is marked as suspect, 
cleared as suspect, or created or removed by the user, RequisitePro updates both 
the internal and external projects to reflect the change.

■ RequisitePro checks for circularity when external relationships are created. The 
circular check references internal requirements and first-level external 
requirements.
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Displaying External Requirements

Requirements in the current project are distinguished from requirements in external 
projects by the project prefix. External requirements appear as follows:

■ The Traceability tab in the Requirement Properties dialog box displays only the 
relationships that are related to the current project. The General tab displays 
external requirement information as read-only.

■ The Find dialog box displays a list of requirement types for the current project and 
each externally mapped project. 

■ The View Properties dialog box displays requirement types from the current 
project and any external projects. If the Attribute Matrix view is selected, only the 
internal requirement types are available for selection. A full Attribute Matrix view 
of external requirements is not provided because of performance considerations.

■ The Attribute Matrix displays all internal and external traceability relationships in 
the Trace-to and Trace-from columns.

■ The Traceability Matrix displays all internally and externally mapped 
requirements of a single requirement type in the rows and columns. 

■ The Traceability Tree displays all internal and external requirements traced to or 
traced from a requirement. The first cross-project traceability level is displayed. So, 
if an internal requirement is traced to an external requirement, the external 
requirement is displayed in the tree. Other requirements to which the external 
requirement traces do not appear.

Displaying Requirement Relationships in Exported Views 

Requirements in exported views with cross-project traceability appear as follows:

■ An exported CSV file indicates that a traced to/from requirement exists as 
displayed in the view.

■ An exported Microsoft Word file indicates a traced to/from requirement exists as 
displayed in the view. 

For more information on exported views, see Exporting Requirements on page 167.

RequisitePro Extensibility Interface

For advanced querying capabilities, the RequisitePro Extensibility Interface provides 
a fully documented COM-based API, giving customers and third-party solution 
providers direct access to the requirement data.
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The Extensibility Interface includes complete documentation for the RequisitePro 
Query Engine and the associated query language syntax. The Query Engine provides 
a programmatic interface and uses objects to retrieve RequisitePro project data for 
requirements and discussions. You can optimize queries to load only necessary 
information, enhancing the performance of your application.

You can open the documentation for the RequisitePro Extensibility Interface by 
clicking Help > Extensibility Interface Reference.

Requirement Metrics

Requirement Metrics provides RequisitePro project administrators and product 
analysts with the capability of reporting statistics on requirement names, text, 
attributes, relationships, and revisions. These report results are displayed in Microsoft 
Excel and can be manipulated using Excel’s charting capabilities.

You begin by creating one or more filters. A filter creates criteria for retrieving 
requirement information. For example, you would use an Attribute Count Filter to 
determine how many requirements in the project have a priority with the value 
“High.” You then combine one or more filters to produce a query. A query combines 
the criteria from multiple filters to analyze requirements. The filters that compose a 
query are joined with the AND statement. Finally, you combine one or more queries 
to produce a report.

Two types of reports are available in Requirement Metrics:

■ A static report, which uses static filters and shows results about the project at the 
present time. 

■ A trend analysis report, which uses time-sensitive filters that analyze changes in 
requirement text, attributes, traceability, and hierarchical relationships. Trend 
analysis reports require that you specify an increment for displaying revisions.

The Requirement Metrics main window is the primary user interface for the 
application. This window allows you to select a requirement type for your report, 
choose filters and filter criteria, build queries, and add them to your report. As you 
add filters to your queries, you limit the requirements in your report to those 
requirements that match your filter criteria.

To access Requirement Metrics, click Tools > Metrics or the Metrics button on the 
toolbar. For more information, see Using Requirement Metrics on page 194.
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6Working with Discussions
Discussions let you address comments, issues, and questions to a group of 
participants that you define. Discussions can be associated with one or more specific 
requirements, or they can refer to the project in general. A discussion item is either the 
initial discussion topic or a response. A participant can respond to either the initial 
discussion text or to another response.

Understanding Discussions

Viewing Discussions

All users of a Rational RequisitePro project can read discussion items, whether or not 
they are discussion participants. Participants in discussion groups can create and 
reply to discussions. Those who have an e-mail address specified in their user 
information can receive discussion items by e-mail. 

When a user opens a project that has unread discussions or responses associated with 
it, the discussions icon on the toolbar appears highlighted, and the ToolTip on the 
Show all discussion button informs the user. In views, an icon is placed next to 
requirements that are associated with discussions.

Responding to Discussions

When a user responds to the discussion, the response is added to the project in 
RequisitePro. In addition, the response is sent to all participants who have an e-mail 
address specified in their user information.

If you are the discussion author or a project administrator, you can restrict the 
discussion to participants. In this case, all project users can still read discussion items, 
but only participants can respond to the discussion.

Configuring E-mail for Discussions

RequisitePro offers the capability of communicating with a group of discussion 
participants regarding comments, issues, and questions related to one or more 
requirements or to the project in general. When e-mail is enabled, this feature 
65



automatically generates an e-mail copy of any discussion item you enter (a new 
discussion or a reply) and sends it to all discussion participants with valid e-mail 
addresses. Otherwise, users are notified through RequisitePro only.

Discussion e-mail is enabled and configured in several ways:

■ Type an e-mail address in the Project Security dialog box (click File > Project 
Administration > Security). This entry supplies the user information for each user in 
RequisitePro. 

■ Configure a notification e-mail service (click Tools > E-mail Setup).

■ Configure participation and notification mail for all users with e-mail addresses 
using the Rational E-mail Reader application.

Entering E-mail Addresses in Project Security

All RequisitePro users can add or edit their own e-mail addresses within 
RequisitePro; however, only project administrators (who have administrator 
permissions) can add or edit other users’ information. 

For information about entering your own e-mail address in Project Security, see the 
procedure Modifying Your Password, User Name, or E-mail Address on page 35. 
Administrators can use the same procedure for entering or modifying all users’ e-mail 
addresses.

Configuring Notification E-mail for Discussions

Use the E-mail Setup command to configure notification e-mail to other discussion 
participants in RequisitePro. When you initiate or reply to a discussion item from 
within the Discussions dialog box, RequisitePro automatically sends copies of the 
discussion items to the project database and to all participants with valid e-mail 
addresses in their RequisitePro user information. 

Note:  This configuration option is not required if your system administrator has 
configured participation and notification e-mail using the Rational E-mail Reader. The 
Rational E-mail Reader application allows discussion participants to reply to the 
discussion items both through their e-mail and from within RequisitePro. 

To configure your notification e-mail:

1 Click Tools > E-mail Setup.
The E-mail Configuration dialog box opens.

2 Select the Enable e-mail notification check box to automatically generate 
notification e-mail (messages from you to other discussion group participants) 
when you create or reply to a discussion item in RequisitePro. Clear the check box 
to disable notification e-mail messages. 
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3 Select the E-mail protocol option that is used on your network (either SMTP/POP3 
or MAPI). 

❑ For SMTP/POP3, type your SMTP server name, your e-mail address (for 
example, “yourname@yourcompany.com”), and your name as it should appear 
in discussion group notices.

❑ For MAPI, select your MAPI Profile. 

4 Click OK.

Configuring E-mail Using the Rational E-mail Reader

The Rational E-mail Reader offers full e-mail integration with RequisitePro by 
associating an e-mail handler with each RequisitePro project. The Rational E-mail 
Reader application allows discussion participants to reply to the discussion items 
through their e-mail or from within RequisitePro. Initial discussion items and replies 
are automatically stored in the RequisitePro database and sent to discussion 
participants by e-mail. 

Discussion participants must have an e-mail address specified in their RequisitePro 
user information in order to receive discussion-related e-mail.

To configure e-mail using the Rational E-mail Reader, see Configuring E-mail for 
Discussions in Rational Desktop Products Installation Guide. This configuration is 
typically performed by a system administrator. Note that this configuration is 
required for enabling e-mail for use with RequisiteWeb.

Be sure to use the SMTP mail protocol when configuring the Rational E-mail Reader 
with RequisitePro. MAPI is not supported.

Creating Discussions

You can create a discussion at any time.

1 Do one of the following:

❑ Click Tools > Discussions (or the Show all discussions button).

❑ In the Explorer or in a view, select one or more requirements and click 
Requirement > Discussion.

❑ Select a requirement in a document and click RequisitePro > Requirement > 
Discussions.
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The Discussions dialog box opens. 

2 Click Create. The Discussion Properties dialog box opens.

3 Click the General tab, and type a subject (required) and text. The subject should be 
brief, but it should also be descriptive enough to inform other users of the 
discussion’s contents. The text you type in the Text box becomes the first item in 
the discussion. Open the discussion by raising an issue, making a comment, or 
asking a question.
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4 Click the Participants tab. Add users and groups. (See Creating and Modifying 
Discussion Participants Information on page 78.)

5 Click the Requirements tab and add requirements. (See Creating and Modifying a 
Discussion's Requirement Information on page 80.)

Note:  If you have filtered or displayed only discussions associated with specific 
requirements, those requirements are automatically listed on the Requirements tab. 
(See Displaying, Filtering, and Sorting Discussions on page 74.)

6 Click OK to close the Select Requirements dialog box, and click OK to close the 
Discussion Properties dialog box.

7 Click Close to close the Discussions dialog box.
If e-mail is configured for discussions, the discussion is opened and the message is 
sent to all participants who have an e-mail address specified in their user 
information. An icon on the toolbar also notifies users that there is a new 
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discussion associated with that project and its requirements. The highlighted icon 
appears for all users who open the project (whether or not they are participants of 
the discussion). 

As with e-mail, discussion messages cannot be modified after they have been sent. 
This restriction prevents conflicts when the original text is included in a discussion 
reply. If you want to add an explanation regarding your initial message, you can do so 
by creating a reply to the discussion.

If you try to create a discussion when you have a requirement with a pending tag 
number selected in an open document, a message appears, informing you that you 
cannot associate discussions with pending requirements. Save the requirements 
document and try again.

Viewing and Modifying Discussion Properties

To view discussion properties:

1 Click Tools > Discussion (or the Show all discussions button).
The Discussions dialog box opens.

2 Select a discussion and click the Properties button.

Note:  Only the originator of the discussion and an administrator can modify a 
discussion’s properties.

Each of the tabs in the Discussion Properties dialog box lets you perform different 
tasks:

■ Use the General tab to view the discussion subject and text or to type a subject and 
text when you are creating a new discussion.

■ Use the Attributes tab to view the discussion’s author, the date and time the 
discussion was created, and the discussion’s current priority and status. Only the 
priority and status can be modified.

■ Use the Participants tab to view or modify listings of the discussion’s participants, 
divided by users and groups, and to restrict the discussion to participants or make 
it available to others. 

■ Use the Requirements tab to determine which requirements are associated with a 
discussion. Note that a discussion does not need to address any requirements 
specifically. However, if a specific requirement is addressed, it should be 
associated using this tab.
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Notifying Participants about a New Discussion

When you create a new discussion, all the discussion’s participants are automatically 
notified about the discussion, provided that you did the following in the Discussion 
Properties dialog box:

■ You typed a subject and topic text in the General tab.

■ You specified participants in the Participants tab.

In a new discussion, the discussion author is automatically included as a participant.

After you have completed these two tasks and clicked OK in the dialog box, 
RequisitePro adds the discussion to the project and sends an e-mail message to each 
participant for whom an e-mail address has been specified in the participant’s user 
information. The message contains the subject and text you entered at the General tab.

Participants can also read the discussion and its responses in RequisitePro. When a 
user opens a project, RequisitePro displays a highlighted discussions button on the 
toolbar, and the Tooltip on the button indicates that new discussions or responses are 
associated with that project or its requirements.

Reading Discussions

The Discussions dialog box helps you keep track of which discussion items you have 
read and which you have not. Unread discussion items are shown as bold text. Items 
you have read are shown as regular text.

1 Click Tools > Discussions (or the Show all discussions button).

The Discussions dialog box opens.

2 In the discussions list, click a discussion.

An expand indicator is displayed to the left of discussions with responses. 

3 Click an item to read it. The item’s text is displayed in the lower portion of the 
dialog box.

After approximately 5 seconds, RequisitePro changes the item from bold to normal 
text, indicating that it has been read. If you select another item before 
approximately 5 seconds elapse, RequisitePro leaves the previously selected item 
bold, indicating that it is still unread.

4 Click Close to close the Discussions dialog box.

Note:  To manually mark an item as read or unread, right-click the item and click 
Mark Read or Mark Unread on the shortcut menu.
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Responding to Discussions

You can respond to a discussion either in RequisitePro or in your e-mail application. 

If you are not a discussion participant, you can respond to the discussion only if the 
Restrict To Participants check box is cleared in the Discussion Properties dialog box at 
the Participants tab. Only the discussion author and members of the Administrators 
group can modify this option.

Responding to Discussions in RequisitePro

To respond to a discussion in RequisitePro using the Discussions dialog box:

1 Click Tools > Discussions (or the Show all discussions button).

The Discussions dialog box opens.

2 In the discussions list, click a discussion or response to a discussion.
The discussion text appears in the lower portion of the Discussions dialog box.

3 Click Reply. 
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The Discussion Response dialog box opens.

The default subject is “RE: [previous discussion item's subject].” You can change 
the subject.

4 Type your response. 

The text automatically wraps at the end of each line you type. You can use CTRL-C 
to copy selected text from another application or document and CTRL-V to paste it 
into the response text box. Text formatting, such as bold and underline, is not 
available in the Discussion Response dialog box. You cannot attach files to the 
response.

5 Click OK. The Discussions dialog box opens again. RequisitePro updates the 
associated project and discussion and then sends your response to all participants 
who have an e-mail address specified in their user information.

Responding to Discussions Using E-mail

You can respond to a discussion using your e-mail application. Depending on 
whether your system administrator has enabled participation e-mail using the 
Rational E-mail Reader, one of two conditions apply:

■ If participation e-mail is enabled, your reply is delivered to all discussion 
participants and stored in the RequisitePro database. It is then accessible from 
within RequisitePro. 

■ If participation e-mail is not configured, your reply is delivered to the recipients 
you select, but it is not stored in the RequisitePro database.

To respond to a discussion using your e-mail application:

1 In your e-mail application, open the message containing the discussion item to 
which you wish to reply.

2 Select the reply option.
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3 Use the default recipient provided.

Note:  If participation e-mail is enabled, messages arrive from an e-mail handler 
that is specific to a RequisitePro project. In this case, reply to the sender directly. If 
participation e-mail is disabled, you can reply to all recipients; however, your 
message is not stored in the RequisitePro discussion. You can add recipients in 
either case.

4 Use the default subject provided. Do not modify the subject.

5 Type your response. Do not type below the line “Text below this line is not 
included in the discussion response,” and do not delete this line or anything below 
it.

RequisitePro uses this line to indicate which text is your response and which text is 
already included in the discussion. If you delete the line, your reply includes both 
your new text and any text that was below the deleted line.

Attachments are not supported in discussions, and they are not added to the 
discussion in the RequisitePro database.

6 Send the e-mail message. The message is sent to RequisitePro, which updates the 
associated project and discussion and then sends your response to all participants 
who have e-mail.

Discussion replies cannot be modified after they have been sent. This prevents 
conflicts when the reply text is included in another reply. To add an explanation 
regarding your message, you can create another reply.

Displaying, Filtering, and Sorting Discussions

Displaying Discussions Associated with a Single Requirement

You can open the Discussions dialog box to display only the discussions associated 
with a specific requirement, or you can open the Discussions dialog box to display all 
open discussions.

To display only discussions associated with a requirement:

1 Select a requirement in the Explorer, a view, or a document.

2 Open the Discussions dialog box. In the Explorer or an open view, do one of the 
following:

❑ Click Requirement > Discussions.

❑ Click Tools > Discussion.

❑ Click the Discussions icon to the right of the requirement.
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In an open document, click RequisitePro > Requirement > Discussions.

The Discussions dialog box opens, showing only those discussions associated with 
the specified requirement.

To display all discussions, do the following: 

❑ Click Filter, clear the Requirement check box, and then click OK.

❑ Close the dialog box, and click Tools > Discussions.

Filtering Discussions

You can specify which discussions you wish to view in the Discussions dialog box, 
based on text, requirement, users, priority, and status.

To filter discussions, do the following:

1 Click Tools > Discussions (or the Show all discussions button).

The Discussions dialog box opens, showing all open discussions.

2 Click Filter. The Discussion Filter dialog box opens.
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3 To display discussions containing specific text in their subjects, select the Subject 
Text check box, and then type the text.

Use % in the text if you want RequisitePro to find discussions using the wildcard 
character % to match one or more characters in the search text. For example, if this 
check box is selected and you type the text %document%, RequisitePro finds 
discussions containing document, documents, documented, undocumented, and so on.

4 To display discussions with which one or more requirements are associated, select 
the Requirement check box, and then type the requirements by which you wish to 
filter (separated by commas) in the text box. For example, enter PR1, SR22, or 
TST114 to include all discussions with which the requirements PR1, SR22, or 
TST114 are associated.

You can also click the adjacent ... button to open the Select Requirements dialog 
box and select requirements by name.

5 To display discussions for which a particular user is a participant, select the 
Participant check box, and then select the user name in the list.

You can select the name of a user who is a member of a group. RequisitePro finds 
discussions for which that group’s members are participants, including the 
selected user.

6 To display discussions with a specific priority, select the Priority check box, and 
then select High, Medium, or Low in the list. 

7 To display open or closed discussions, select the Status check box, and then select 
Open or Closed in the list.

8 To display read or unread discussions, select the Read Status check box, and then 
select Read or Unread in the list. 

9 Filter by more than one option by repeating any of Steps 3–7 above, and then click 
OK.

The Discussions dialog box opens again, showing only the discussions that match 
the filters set above. The filter settings are displayed next to the Filter button in the 
dialog box.

Note:  Press the F5 special function key to refresh the discussions list. This includes 
updates to the priority and status of discussions that you have made and other 
changes from members of your team who are using RequisitePro and RequisiteWeb. 
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Sorting Discussions

In the Discussions dialog box, you can change the sort order in which discussions 
appear.

1 Click Tools > Discussions (or the Show all discussions button).
The Discussions dialog box opens.

2 In the discussions list, click the column heading by which you want to sort the 
discussions.

For example, to sort discussions alphabetically by subject, click the Subject column 
heading.

3 To reverse the sort order, click the column heading again.

Printing Discussions

You can print discussion items. The printout shows the discussion item’s subject, text, 
author, and creation date and time. The printout also shows information about the 
associated discussion, including the discussion’s priority, status, requirements, and 
participants.

1 Click Tools > Discussions (or the Show all discussions button).
The Discussions dialog box opens.

2 In the discussions list, click one or more discussion items. (Use a multiple select 
action to select more than one item.)

3 Click the Print button. 

4 From the Windows Print dialog box, select the options you want and print.

Modifying Discussions

Viewing and Modifying Discussion Attributes

The Attributes tab in the Discussion Properties dialog box shows the discussion’s 
author, the date and time the discussion was created, and its current priority and 
status. These properties can be modified only by the discussion author and project 
administrators.
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To modify discussion attributes:

1 Click Tools > Discussions (or the Show all discussions button).
The Discussions dialog box opens.

2 Select a discussion, and then click Properties. 
You can also click Create to create a new discussion.

3 Click the Attributes tab.

4 Select a Priority from the list.

Note:  You can change a discussion’s priority only if the discussion is open.

5 If you are modifying a discussion, change the Status to Open or Closed. (You 
cannot change the status of a new discussion.)

After modifying the priority or status, the discussion still appears in the 
Discussion list, even if it does not match the filter criteria of the display. To refresh 
the Discussions list after you or others on your team have changed the priority or 
status, press the F5 special function key. 

Creating and Modifying Discussion Participants Information

The Discussion Properties dialog box, Participants tab lets you determine which users 
and groups are included in the discussion and whether the discussion is restricted to 
participants. 

Any user can view the Participants tab, but only the discussion author and project 
administrators can modify its options, with the following two exceptions:

■ You can add yourself to the Users list if the Restrict To Participants check box is 
cleared. 

■ You can always remove yourself from the Users list. 

If you are a member of a group that participates in the discussion, you cannot remove 
yourself from discussion participation. A RequisitePro administrator must remove 
you from the group.

The options in this dialog box can be modified only if the discussion is open.

To modify participants information:

1 Click Tools > Discussions (or the Show all Discussions button).
The Discussions dialog box opens.
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2 In the discussions list, click an open discussion and click Properties, or click Create 
to create a new discussion. The Discussion Properties dialog box opens.

3 Click the Participants tab.

4 To add a user, click Add below the Users list. The Project Users dialog box opens.

5 Select a user from the list, and then click OK. (Use a multiple select action to select 
more than one user.) For a new discussion, the discussion author is automatically 
included as a participant.

6 To add a group, click Add below the Groups list. The Project Groups dialog box 
opens.
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7 Select a group from the list, and then click OK. (Use a multiple select action to 
select more than one group.) If a user is a member of a group and you add the 
group to the Groups list, you do not need to add the name of the individual user to 
the Users list.

8 To remove users, click the user names in the Users list, and then click Remove 
below the Users list. To remove groups, click the group names in the Groups list, 
and then click Remove below the list.

9 To restrict the discussion to participants only, select the Restrict To Participants 
check box. Only participants can respond to the discussion, although all users can 
read it in RequisitePro.

10 Click OK to close the dialog box.

Creating and Modifying a Discussion's Requirement Information

You can use the Discussion Properties dialog box, Requirements tab to associate 
specific requirements with a discussion. Note that a discussion does not need to 
address any requirement specifically. However, if you want to address a specific 
requirement, you should use this tab to associated it with the discussion.

Any user can view the Requirements tab, but only the discussion author and members 
of the Administrators group can modify its options. The options in this dialog box can 
be modified only if the discussion is open.

To modify a discussion’s requirement information:

1 Click Tools > Discussions (or the Show all discussions button).
The Discussions dialog box opens.

2 In the discussions list, select an open discussion and click Properties, or click 
Create to create a new discussion. The Discussion Properties dialog box opens.

3 Click the Requirements tab.

4 To associate a requirement with the selected discussion, click Add. 
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The Select Requirements dialog box opens.

5 Select a requirement type from the Requirements of type list, select a location from 
the Located in list, and select a requirement from the list. (Use a multiple select 
action to select multiple requirements.) To locate a specific requirement, click Find. 
You can use the Find dialog box to locate a specific tag number and requirement 
name and text.

Note:  Requirements with pending tag numbers do not appear in this list because 
pending requirements cannot be associated with discussions. 

6 When you have finished selecting requirements, click OK. 
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The Discussion Properties dialog box reopens with the specified requirement 
shown in the Associated Requirements list. 

Note:  You can remove a requirement by selecting it in the Associated 
Requirements list, and then clicking Remove.

7 To display a requirement’s properties, click Properties. 

The Requirement Properties dialog box opens, showing the selected requirement's 
properties. 

8 Click OK to close each dialog box.

Creating and Modifying a Requirement’s Discussion Information

You can view and create discussions from within the Requirement Properties dialog 
box at the Discussions tab.

1 Do one of the following to open the dialog box:

❑ In an open document, select the requirement and click RequisitePro > 
Requirement > Properties.

❑ Select the requirement in the Explorer or a view and click Requirement > 
Properties.

2 Click the Discussions tab. A list of all discussions associated with the requirement 
is displayed.

3 To create a new discussion associated with this requirement, click Create.

4 To read a discussion item, select the discussion, and then click View.

5 To view the properties for a selected discussion, select the discussion and click 
Properties.
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If the requirement has not been saved in the database, the Create, View, and 
Properties buttons are not available. To create a new discussion associated with the 
requirement, read a discussion item, or view the properties for a selected 
discussion, save the document containing the requirement, and then open the 
dialog box again.

Closing and Deleting Discussions

If you are the discussion author or a RequisitePro administrator, you can close a 
discussion that is no longer needed. Closed discussions are filtered out of the 
Discussions dialog box by default. A discussion must be closed before you can delete 
it. (However, you may find it helpful to retain closed discussions for the record they 
provide.) 

1 Click Tools > Discussions (or click the Show all Discussions button).
The Discussions dialog box opens.

2 In the discussions list, click the open discussion.

3 Click Properties. The Discussion Properties dialog box opens.

4 On the Attributes tab, select Closed from the Status list.

5 Click OK. The Discussions dialog box opens again, and the discussion you closed 
has an X next to the author column. 

Discussion authors and project administrators can delete closed discussions. 

1 Click Tools > Discussions (or click the Show all discussions button).
The Discussions dialog box opens.

2 In the discussions list, click a closed discussion. (Closed discussions have an X next 
to the From column.) Then click Delete. 

3 At the prompt asking you to confirm the deletion, click Yes.
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7Working with Documents
A Rational RequisitePro requirements document is a Microsoft Word file created in 
RequisitePro and integrated with the project database. Requirements created outside 
of a project document can be imported or copied into the document. 

When you create a new project document, RequisitePro associates the document with 
the project that is open. This association is used to update the database and 
synchronize the revision numbering of the project and document. The document’s 
name, location, document type, and revision information are stored in the project 
database. Also stored in the project database are the document requirements, their 
attribute values, and their traceability relationships. 

Creating a RequisitePro Document

To create a document in a RequisitePro project:

1 Open the project with which you want to associate the new document, and in the 
Explorer select the package in which you want to store the new document.

2 Do one of the following: 

❑ Click File > New > Document. 

❑ In Word, click RequisitePro > Document > New.
The Document Properties dialog box opens.
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3 In the General tab, type the name of the document in the Name box (64 characters 
maximum) and a brief description (up to 255 characters) of the document’s 
purpose or contents in the Description box. 

The Package box displays where the document resides (the package name you 
selected in Step 1). Click the adjacent Browse button to open the Package Browser 
dialog box and select a different package in which to place the document. 

4 In the Filename box, type, modify, or view the name of the document. The file 
name defaults to the name you typed in the Name box. The file name is limited to 
eight characters unless long file names are supported by your operating system; if 
they are, you can use up to 64 characters. (See the topic “RequisitePro file names” 
in Help.) Do not give it an extension; RequisitePro assigns an extension according 
to the document type you selected.

5 Click the Show Tags check box to display requirement tags in the new document. 
Clear this box to hide the tag text. 
Selecting this check box sets options in Microsoft Word to ensure that the 
requirement tags are visible both on your display and in the printed document. 
The check box Hidden Text is selected by default in both the View tab and the Print 
tab in the Microsoft Word Options dialog box (click Tools > Options).

6 Type a location for the file in the Directory box, or click Browse to select a directory.

By default, RequisitePro places a document in the project directory, but documents 
can be saved anywhere on your system. You can type the name of a directory in 
this text box. If you are working in a networked environment with shared drives, 
type a Universal Naming Convention name for identifying a shared directory on a 
server, such as “\\Servername\Sharename.” This happens by default if you type 
a location with a drive letter.

7 Select a document type to assign to the new document. If an outline is associated 
with the document type, RequisitePro uses the outline to format the new 
document. After the document has been saved, you cannot change its document 
type.

8 Click OK. The new document is open and ready to be edited.

Note:  The document must be saved for the requirements to be committed to the 
database.
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Saving a RequisitePro Document

When you save a document, RequisitePro saves to the project database all document 
modifications, such as the document's name, revision number, label, and change 
description. RequisitePro automatically creates backup files for each document file in 
the document directory and updates them when you save the document. In addition, 
RequisitePro commits all new and modified requirements in the document to the 
database, and it deletes from the database all requirements that you deleted from the 
document. Requirements with pending tag numbers are assigned requirement tags. 

You save the active requirements document by clicking RequisitePro > Document > 
Save. If you use Microsoft Word’s File > Save command, the document is saved, but 
the document and requirements information are not updated in the RequisitePro 
database.

By default, a document is stored in the project directory. However, you can choose to 
store a document in any location.

To save a requirements document in a RequisitePro project:

1 Click either the Save the current document button or RequisitePro > Document > 
Save. 

If you modified a requirement in the document, the Change Description dialog 
box opens and prompts you to type a reason for the change.

2 Type an explanation of the modifications in the Change Description box.

3 If the change description applies to all requirements that were changed in the 
document, select the Apply to all... check box. 

Note:  If the document contains requirements that include Microsoft Word-linked files, 
you may receive a message stating that the location of linked files cannot be resolved. 
Your machine may be disconnected from the network, your machine may not have 
the specified drive mapped, the removable drive may be empty, or you may not have 
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permissions to read the specified drive. You can still save the changes you made to the 
requirements or to the document, but the links to the external documents are not 
updated. Click OK.

4 Click OK to save the document and its requirements. (Click Cancel to end the entire 
process.)

If you want to save a document without the standard bookmarks and style 
RequisitePro adds to requirements, you may turn off the options. To save a document 
without bookmarks, use the Microsoft Word Options command from the Tools menu; 
on the View tab, clear the Bookmarks check box. If you want to save a document 
without requirement tags, click Tools > Options; on the Print tab, clear the Hidden Text 
check box. If you have exclusive access to the project and you want to save a 
document without the colored text, you can edit the requirement style in the 
RequisitePro Project Properties dialog box.

Opening a Document After a Project Is Open

You can open a document in one of the following ways: 

■ Double-click the document in the Explorer; the document appears in Microsoft 
Word. 

■ In Microsoft Word, click RequisitePro > Document > Open. 

The Open Document dialog box opens.

The Open Document dialog box displays the documents that are associated with 
the open project. This list includes all documents you have either created in the 
project or imported into the project, regardless of whether the documents contain 
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requirements. You can view a list of all the documents, or you can select a type of 
document to display. The documents of the selected type appear in the list below 
the Documents of Type list.

❑ Select one or more documents to open and click OK. 
The document opens in the Microsoft Word window. Do not press the ESC key 
while the document is opening.

Note:  For more information on options for controlling access by other users when 
the project and documents are open, see Setting Security on page 182. If you want 
to view the document but not make any modifications, select the document in the 
Explorer, right-click, and select Open Read Only.

Closing and Saving a RequisitePro Document

To close a project document:

❑ Click RequisitePro > Document > Close.
If modifications were made to the document that were not saved, the 
Document Changed dialog box opens.

5 Do one of the following:

❑ To accept the modifications and save the document, click Yes. 

❑ To abandon the modifications and leave the document as is, click No. 

❑ To return to the document without closing, click Cancel.

❑ To review changes to the document, click the Review Changes button. The 
Document Changes dialog box lists changes, as described below.

Note:  If you changed one or more requirements in the document, the Change 
Description dialog box opens (whether you selected Yes or Review Changes above). 
You have the option to record reasons for changing each requirement.
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Reviewing Changes Before Closing a Document

When closing a document that has been modified, the Document Changed dialog box 
presents you the option of reviewing the changes.

To review modifications to a document:

1 Follow Steps 1 and 2 in the preceding procedure and click the Review Changes 
button. If you have changed one or more requirements in the document, the 
Change Description dialog box opens. You have the option to record reasons for 
changing each requirement. 

The Document Changes dialog box lists all modifications to the document. 

2 Click OK to save the changes once you have reviewed them.

Deleting Documents From a Project

Use the Remove command to remove requirements formatting in the document and 
remove the requirements and the document itself from the project database. To use 
this command, you must have exclusive access to the project. 

This command does not delete the document or any text that you highlighted as 
requirements. RequisitePro saves the document as a Microsoft Word document in the 
project directory.

To add the document back to a project, import it into an open requirements document 
and re-create the requirements.

1 Select the document in the Explorer and click Edit > Delete.

A dialog box opens, asking you to confirm the deletion.

Note:  Before you delete a document, be aware that some of the requirements in the 
document may have been assigned to other packages. If you delete the document, 
all those requirements are deleted. We recommend that you create an Attribute 
Matrix view for the requirement type of the requirements in that document. Check 
the Location attribute to determine the document where those requirements are 
located and check the Package attribute to determine whether they are associated 
with other packages.

2 Click Yes.

RequisitePro makes the following changes:

❑ The requirements formatting is removed from the document 

❑ The requirements are removed from the project database. 
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❑ All text remains in the document.

❑ The document is closed in RequisitePro.

❑ You can open the document in Microsoft Word, or open it in RequisitePro as a 
Word document, but you can no longer open it in RequisitePro as a 
requirements document. 

Changing the Location of a RequisitePro Document

New documents are stored in the project directory by default. Documents can be 
created in or moved to any directory on the file system. All documents associated 
with the project are included in your project list regardless of where they are stored.

To change the location of a project document:

1 Do one of the following:

❑ In the Explorer, select the document and click File > Properties.

❑ In the open document, click RequisitePro > Document > Properties.

The Document Properties dialog box opens. On the General tab, the document file 
name and location appear in the Directory box.

2 Click Browse to change the location of the file. The Browse for Folder dialog box 
opens.
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3 Select a new location for the document. Click a folder to open it.

4 Click OK to close each dialog box.

Modifying Document Information

To modify information in an open document:

1 Open the Document Properties dialog box in one of the following ways:

❑ In the Explorer, select the document and click File > Properties.

❑ In Microsoft Word, click RequisitePro > Document > Properties.

2 Modify the document’s information:

❑ On the General tab, you can change the name of the document, its description, 
and the directory in which it is stored. You cannot change its logical name or its 
document type, but you can create a new document and move the text and 
requirements from the existing document to the new one using the Microsoft 
Word cut and paste command. The Package box displays the package where 
the document resides. You can browse to open the Package Browser dialog box 
and select a different package.

❑ On the Revision tab, you have the option of typing a label to associate with the 
revision number (up to 20 characters) and a change description (up to 2,048 
characters). These options are available only if the document is new (and you 
have added information on the General tab) or if you have made changes to the 
document that have not been saved. You can click the History button to display 
a description of the history of document changes. 

3 Click OK to close the Document Properties dialog box. 

4 Click RequisitePro > Document > Save to save your changes to the document. 

Moving Text and Requirements to a New Document

If a requirements document becomes corrupted, you can use the Microsoft Word cut 
and paste commands to move all the contents of the document (including its 
requirements) to another document. This is also helpful when you want to move the 
contents of an entire document to a new document with a new file name.

Note:  To move individual requirements from one document to another, use the cut 
and paste commands on the RequisitePro Requirements menu rather than the 
Microsoft Word Edit menu.
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To move all text and requirements:

1 Open an existing RequisitePro document.

2 Create a new document by doing one of the following:

❑ Click File > New > Document.

❑ In Word, click RequisitePro > Document > New.

3 Type a name and file name for the new document, select a document type, and 
then click OK.

4 In Word, do the following: 

❑ Click Window and click the existing file name.

❑ Click Edit > Select All.

❑ Click Edit > Cut.

❑ Click the Window menu, and then click the file name of the new document.

❑ Click Edit > Paste.

5 Click RequisitePro > Document > Save.

A dialog box opens and asks you how to handle each requirement that you have 
pasted into the new document.

6 Accept the default option “Change the location of this requirement” and click OK.

Protecting Documents

When you protect a document for revisions, you can electronically distribute the 
document or make it available in a shared directory for reviewers to suggest changes. 
You can then merge the revisions in one document.

Use the commands on the Microsoft Word Tools menu to track changes and protect 
RequisitePro documents. To protect documents, use RequisitePro’s offline authoring 
feature to edit a document in Word outside of RequisitePro. To make a copy of a 
requirements document, use the Save As command (click RequisitePro > Document > 
Save As). See the section that follows and Working with Documents Offline on page 100.
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Working with Microsoft Word

Saving a RequisitePro Document as a Word Document

RequisitePro includes an option to save a project document as a Microsoft Word 
document that is independent of the project. This lets you attach the document to 
e-mail or share the document with someone outside of your work group. 

When you choose this option, RequisitePro makes a copy of the active requirements 
document and saves it as a Word file. The resulting Word document retains the look 
and feel of the original requirements document and even includes bookmarks and 
tags used by RequisitePro to identify requirements.

To save a project document as a Word document:

1 Open the RequisitePro document.

2 Click RequisitePro > Document > Save As.

The Document Save As dialog box opens.

3 Specify a destination for the new copy of the document. 

4 Accept the default name in the File name box, or type a file name. Do not change 
the .doc extension.

5 Click Save. RequisitePro closes the original RequisitePro document and opens the 
new .doc file in Word.

Note:  Microsoft Word turns off the bookmarks and hidden text features by default, so 
you do not see the requirement tags or bookmarks around requirements when a 
document is viewed outside RequisitePro. Before editing the requirement text in a 
Word document outside of RequisitePro, we recommend marking Bookmarks and 
Hidden text options for display. In Microsoft Word, click Tools > Options and click the 
View tab.

Managing Microsoft Word Documents

While working in RequisitePro, you can create, open, modify, save, and close Word 
documents that are independent from RequisitePro. Use the standard File menu 
commands to manage these Word documents. (The Save As and Exit commands are 
unavailable in order to prevent conflicts in handling RequisitePro documents.)

RequisitePro documents are associated with projects, they are managed with the 
commands available when you click RequisitePro > Document, and they are saved in 
RequisitePro format by default.
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Closing Microsoft Word

To close Word without closing RequisitePro, click the Window menu on the toolbar 
and select Close Word.

Tips for Using Word in RequisitePro

Do Not Use

Do not use the Microsoft Word File > Versions feature. The Word logic of identifying a 
base version with subsequent revisions conflicts with RequisitePro’s document 
revision history features. Version changes in Word can conflict with the RequisitePro 
requirements database. In addition, multiple versions greatly increase your document 
file size.

Do not use the Cut command in Microsoft Word to cut requirement text. When you 
use the Word Cut command, you may delete the requirement from the project. In 
addition, if you cut a requirement from a document using the Cut command in Word, 
you cannot paste it into the project database. 

Do not use the fast saves option in Word. Clear the Allow fast saves check box in 
Microsoft Word’s Options dialog box.

Do not use Microsoft Word hidden text in requirement text, which appears in a 
document in bookmarks. Hidden text is not saved in the RequisitePro database.

Do not use the Tools > Merge Documents command on RequisitePro documents.

Do not create requirements from text that contains the Wingdings font or other special 
characters at the beginning of the text string.

Use with Caution

You can use Word’s automatic paragraph numbering (click Format > Bullets and 
Numbering) within requirement text in a requirements document, but be aware that 
this feature can produce inconvenient and unexpected results. Automatic numbering 
changes caused by the addition or deletion of paragraphs require you to confirm 
changes to all subsequent numbered requirements in the document. This also adds a 
revision history entry for each requirement, resulting in a cluttered revision history 
list. Changes in autonumbering can also affect the requirement tag numbering.

If you are using Word 2000 and choose to clear the Trust all installed add-ins and 
templates check box on the Security dialog box (click Tools > Macro > Security), you 
must click Enable at the Microsoft Word message box each time you open a document 
in RequisitePro.
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Incorrect use of the Word's Track Changes feature can cause performance problems 
and database corruption. Bookmarks may truncate requirement text; requirement tags 
may not appear as hidden text; and requirement numbering may be altered. These 
changes may be copied into the database, resulting in loss of data or a manual repair 
of all requirements. When you use this feature, be sure to follow the instructions 
outlined in the section Using Word’s Track Changes Feature on page 98. 

Improving Word Performance

The following tips can improved Microsoft Word’s performance with RequisitePro 
documents:

■ Create small RequisitePro documents. Large documents can take significant time 
to open, close, and manipulate; documents less than 5 MB or about 50 pages are 
optimal. (Documents that have graphics or other resource-intensive objects should 
be shorter than 50 pages.)

■ View documents in Normal mode. Documents in Page Layout mode are 
constantly being repaginated.

■ Open documents selectively. Having many Word documents open at once 
decreases performance.

■ Store each document on a server that is local to the document’s primary author. 
When working in a RequisitePro project across multiple sites, authors can improve 
Word performance when opening, saving, and closing RequisitePro documents by 
storing the documents on a server that is local to the primary author. 

Working with Word Styles

If you press ENTER after a marked requirement in a document, the requirement style 
(such as double underline) and color are carried to the next line. Press CTRL and the 
SPACEBAR before typing, and the Word style is reset to Normal.

Formatting a Document Using Word

If you want to change the presentation style of one or more aspects of the document 
you are working on but not change other documents of the same type, you can use the 
formatting commands in Word. RequisitePro uses formatting features in Word to 
highlight your requirements within a document. If you apply different formatting to a 
requirement, either by directly formatting the requirement or by changing the 
template style on which it is based, your requirement text may be modified or entirely 
lost. You can correct this problem by using the Refresh Requirements command.
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Using Word Master Documents

Using master documents in Microsoft Word can be very helpful for viewing and 
printing a collection of smaller subdocuments as one document. All subdocuments 
within the master document can be printed with consistent page numbering. Master 
documents are a feature of Microsoft Word. You should not attempt to create, import, 
or manage master documents from within RequisitePro.

Consider the following guidelines when using master documents:

■ Archive the project before creating subdocuments. (For information on archiving 
projects, see Archiving Projects on page 200.)

■ The master document should not be a RequisitePro document; the subdocuments 
can be RequisitePro documents. This prevents redundant requirements and 
broken traceability links.

■ Do not edit requirement text in the subdocuments outside of RequisitePro.

■ Do not edit the subdocuments in RequisitePro while viewing the master document 
in Microsoft Word. 

To prepare RequisitePro documents to be used as subdocuments, save them in Word 
format:

1 Select the project in the Explorer and click File > Properties. 

2 On the Documents tab of the Project Properties dialog box, clear the check box Save 
documents in RequisitePro format.

Note:  This removes all project security from these requirements documents and 
they can be modified outside RequisitePro, so clear this check box only when you 
are preparing subdocuments for viewing or printing from a Microsoft Word 
master document.

3 Open and save the documents in the project that you want to use as 
subdocuments. 

Important: After viewing and printing the master document in Microsoft Word, open 
the Project Properties dialog box again and select the check box Save documents in 
RequisitePro format. Open the subdocuments and save them. This reestablishes 
project security for those documents.

For more information on using master and subdocuments, see the Microsoft Word 
documentation.
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Using Word Options for “Hidden” Requirements

You can set options in the Options dialog box (in Microsoft Word, click Tools > 
Options) to affect how requirements are displayed in RequisitePro documents:

■ If you clear the Bookmarks check box, you do not see the bookmarks around the 
requirement in RequisitePro documents.

■ The requirement tag in a RequisitePro document is hidden text in Microsoft Word. 
If you clear the Hidden text check box, you do not see the tag in the text of the 
requirement in the RequisitePro document. 

Note:  When you edit a RequisitePro document offline or a RequisitePro document 
saved as a Microsoft Word document, Microsoft Word turns off the bookmarks and 
hidden text features by default. Before you edit the requirement text in an offline 
document, we recommend that you select the Bookmarks and Hidden text options for 
display. In Microsoft Word, click Tools > Options and click the View tab. 

For information about setting color and style for requirements, see Creating and 
Modifying Requirement Types on page 226.

Using Word’s Track Changes Feature

You can use the Track Changes feature in Word to edit requirement text. To avoid 
tracking changes without knowing it, make sure to select both the Highlight changes 
on screen and Track changes while editing options in the Word Highlight Changes 
dialog box (Tools > Track Changes > Highlight Changes). 

To review edited requirements in a view, click View > Properties. Be sure that the Show 
Name option is selected and that the Show Text option is not. When you select these 
options, the view you open displays requirements by name only; the requirement text 
is not displayed. This is useful when you use the Track Changes feature, because 
unlike Word documents, views do not distinguish between text that has been added 
and text that has been marked for deletion. This can make the requirement text 
confusing to read in a view.

Be aware that use of the Track Changes feature with RequisitePro documents can 
cause performance problems and Word errors (such as requirement text errors and 
database corruption). We strongly recommend that it be used only as follows:

■ Use Track Changes only when you are confident that your document is near 
completion. This is important because use of the Track Changes feature to edit a 
Word document increases the size of the document, which affects Word 
performance. Take the document offline for review purposes, use the Track 
Changes feature, incorporate edits into the offline document, and then bring it 
back online.
98 Chapter 7 - Working with Documents



■ Do not select the Hidden option for Deleted text in the Track Changes dialog box.

■ Do not use the Tools > Merge Documents option with RequisitePro documents.

Editing a Requirements Document Outside of RequisitePro

To edit a document in Word outside of RequisitePro and merge it back in later, use 
RequisitePro’s offline authoring feature rather than the Save As command.

Creating a Word Document from a RequisitePro Requirements 
Document

Click RequisitePro > Document > Save As to save a copy of your requirements 
document with a .doc file extension. The resulting Word document does not appear in 
the project documents list.

Managing External Word Documents

To manage a Microsoft Word document that is not part of a RequisitePro project, use 
the File menu commands in Microsoft Word. These commands do not create, open, or 
save RequisitePro document or requirement information in the database, nor do they 
convert nonrequirement documents to requirements documents. However, you can 
cut or copy portions of a Word document and paste them into a requirements 
document.

Displaying the RequisitePro Toolbar in Word

When you open a RequisitePro document, Word includes a RequisitePro toolbar. It 
can be floating or docked to the Word window. If the toolbar is hidden, you can 
display it by doing the following in Microsoft Word: Click Tools > Customize, and in 
the Customize dialog box, Toolbars tab, select Rational RequisitePro and click Close.

Unavailable Word Commands

The File > Save As and File > Exit commands are unavailable in order to prevent 
conflicts in handling RequisitePro documents. On the RequisitePro toolbar, click 
Window > Close Word to close the Word document.

The Templates and Add-Ins command (click Tools > Templates and Add-Ins) is 
unavailable to prevent deletion of the RequisitePro template, which is required for 
proper functioning of RequisitePro.
Working with Microsoft Word 99



Working with Documents Offline 

Offline authoring allows requirements authors and project administrators to use a 
document outside of RequisitePro (that is, offline).

When you take a document offline, RequisitePro creates a copy of the document in the 
directory you specify. The original is still stored in RequisitePro, but it is changed to a 
read-only document. Other users can view the document in RequisitePro, but they 
cannot edit it until you bring it back online.

When you take a document offline, RequisitePro includes Microsoft Word macros in 
the document. These macros allow you to add and delete requirements in the offline 
document.

Note:  In Word 2000, you may need to adjust your macro security levels to use the New 
and Delete menu commands (on the Requirement menu) in offline authoring. Word 
2000 defaults to the highest level for macro security. This setting prevents the 
availability of the RequisitePro offline authoring macros. Reset the macro security in 
Word 2000 to medium on the Security dialog box, which is available by clicking Tools 
> Macro > Security.

Do not rename documents while they are offline. The original file name is necessary 
for recognizing the offline document within RequisitePro. When you bring the 
document back online, RequisitePro replaces the read-only document with the 
modified document. Alternatively, you can elect to cancel the offline process. When 
you do so, RequisitePro restores the original document, removing its read-only state, 
so all requirements authors and members of the Administrators group can again 
modify it within RequisitePro.

Taking Documents Offline

Before taking a document offline, make sure all changes made to requirement text 
outside the document (such as in the Attribute Matrix or in RequisiteWeb) have been 
saved in the document.

1 To take a document offline, do one of the following:

❑ In Word, click RequisitePro > Document > Offline Documents.

❑ Click Tools > Offline Documents. 
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The Offline Documents dialog box opens.

2 Select a document type from the Display Types list.

3 Click the document you want to take offline. (Use a multiple select action to select 
more than one document.)

4 Click Take Offline. 

The Take Offline Information dialog box opens.

5 In the Reason text box, type a reason for taking the document offline.

6 Click OK. 
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Determining Whether a Document Is Offline

To check whether a document is offline:

1 Do one of the following:

❑ Click Tools > Offline Documents.

❑ In an open document, click RequisitePro > Document > Offline Documents.

The Offline Documents dialog box opens.

2 If the document you want is listed in the Offline documents list, select it and click 
Offline Info.

The Offline Information dialog box opens, displaying the document name, the 
user who took the document offline, the offline date and time, location, and reason 
for taking the document offline.

Modifying Offline Documents

You can modify an offline document in the same manner as you would any other 
Microsoft Word document. All Word features and options are available when you edit 
a RequisitePro offline document. In addition, you can add and delete RequisitePro 
requirements in an offline document.

When you open the offline document in Word, make sure that you enable the Word 
macros. These macros allow you to add and delete requirements in the offline 
document. 
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You can modify requirement text in an offline document. When you bring the 
document back online and open it in RequisitePro, you are prompted to provide a 
reason for the changes you made to the requirement text.

Microsoft Word turns off the bookmarks and hidden text features by default. Before 
you edit the requirement text in an offline document, we recommend that you mark 
the hidden text and bookmarks for display. Click Tools > Options in Microsoft Word to 
open the Options dialog box, and select the Hidden text and Bookmarks check boxes 
on the View tab. 

Do not rename documents while they are offline. RequisitePro requires the original 
file name in order to recognize offline documents.

Creating Requirements in Offline Documents

Mark text in an offline document as a requirement in the same way you would if the 
document were online. 

1 Select the information to define the requirement.

2 Click RequisitePro > Requirement > New. 

The RequisitePro macro stylizes the requirement text with a double underline and 
notifies you that a requirement was created. When you bring the document back 
online, RequisitePro gives the requirement a number and default attributes. You 
can then modify the requirement in the Requirement Properties dialog box.

Deleting Requirements in Offline Documents

You can delete a requirement in an offline document in the same way you would if the 
document were online. When you use the Delete-Unmark command, RequisitePro 
retains the requirement text in the document, but the text is no longer recognized as a 
requirement. RequisitePro removes the requirement color and style settings and 
replaces them with the document default style. In an offline document, you can delete 
only one requirement at a time.

The use of the Delete-Unmark command in an offline document depends on a 
Microsoft Word macro. For more information on enabling the offline macros, see 
Help.

To delete-unmark a requirement in an offline document:

1 In the offline document, click anywhere in a requirement.

2 Click RequisitePro > Requirement > Delete-Unmark.
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To undo a delete operation, click Edit > Undo. Click Undo until the requirement is 
completely restored.

When you bring the document back online, RequisitePro notifies you that the 
requirement has been deleted and asks whether you want to update the online 
document with the changes. If you decline, RequisitePro does not bring the document 
back online.

Bringing Offline Documents Back Online

If you are the offline author or an administrator, you can bring an offline document 
back online.

1 Do one of the following:

❑ Click Tools > Offline Documents.

❑ In an open document, click RequisitePro > Document > Offline Documents.

The Offline Documents dialog box opens.

2 In the Offline documents list, select the document you want to bring back online. 
(Use a multiple select action to select more than one document.)

3 Click Bring Online.

The Bring Online Information dialog box opens.

4 In the Description of Changes box, type a description of the changes made to the 
currently selected document while it was offline. If you are bringing multiple 
documents back online and the changes apply to all subsequent documents, select 
the Apply to All check box. If you do not select that check box, the Bring Online 
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Information dialog box opens for each subsequent document you bring online in 
this session, and you must enter changes for each document individually. You can 
select Apply to All for any document you bring online in the session to apply the 
changes to all subsequent documents.
For example, if you are bringing back online four documents named Doc1, Doc2, 
Doc3, and Doc4, and you do not select Apply to All while entering information for 
Doc1, but you do select Apply to All while entering information for Doc2, the Bring 
Online Information dialog box does not open for Doc3 or Doc4.

5 Click OK. 

A Microsoft Word warning message states that the document you are bringing 
online contains macros. Click the Enable Macros button.

If you have deleted requirements in an offline document, RequisitePro notifies you 
how many requirements you have deleted, and it asks whether you want to 
update the online document with the changes.

6 Click Yes to update the document, or click No to decline the update. 
If you do not update the document, RequisitePro does not bring the document 
back online.

Bringing Documents Online Without Saving Changes

If you are the offline author or a member of the Administrators group, you can bring a 
document back online without saving any changes you made while it was offline.

1 Do one of the following:

❑ Click Tools > Offline Documents.

❑ In an open document, click RequisitePro > Document > Offline Documents.

The Offline Documents dialog box opens.

2 In the Offline documents list, select the document you want to bring back online 
without saving offline changes. (Use a multiple select action to select more than 
one document.)

3 Click Cancel Offline. A message appears, asking you to confirm the deletion of the 
offline changes. (If you are bringing multiple documents back online, this message 
appears only once for all documents.)

4 Select the Remove the offline document from the file system check box to delete the 
offline documents from the directory in which they were stored. 

5 Click Yes. The online version of the documents is restored.
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Reading Offline Documents

You can read a document that another user has taken offline. RequisitePro displays 
the document in read-only mode, in the state it was in before the other user took it 
offline.

If you are the offline author or a member of the Administrators group and you open 
the document in RequisitePro, you can choose to bring it back online or open it in the 
state it was in before it was taken offline.

1 Click RequisitePro > Document > Open.

2 The Open Document dialog box opens, listing all project documents and 
identifying documents that have been taken offline.

3 Select the offline document you want to open, and click OK. The Offline Document 
Open dialog box opens, identifying the user who took the document offline.

4 Do one of the following:

❑ If you are the offline author or a project administrator, click Bring Online to 
bring the document back online, or click Open Read Only to open it in the state 
it was in before you took it offline. You cannot access the Bring Online button if 
you are not the offline author or an administrator.

❑ If another user took the document offline, click Open Read Only to open the 
document for editing.
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8Working with 
Requirements
A requirement describes a condition or capability that a system must provide; it is 
either derived directly from user needs or is stated in a contract, standard, 
specification, or other formally imposed document. Examples of requirements include 
inputs to the system, outputs from the system, and functions and attributes of the 
system and the system environment.

Requirements may be described in terms of the “FURPS” model, which categorizes 
the major types of requirements as follows:

■ Functional requirements: feature sets, capabilities, and security.

■ Usability requirements: human factors, aesthetics, consistency in the user interface, 
online and context-sensitive help, wizards and agents, user documentation, and 
training materials.

■ Reliability requirements: frequency and severity of failure, recoverability, 
predictability, accuracy, mean time between failure.

■ Performance requirements: conditions imposed on functional requirements.

■ Supportability requirements: testability, extensibility, adaptability, maintainability, 
compatibility, configurability, serviceability, installability, and localizability.

In Rational RequisitePro, requirements contain a name and text, and they can be 
qualified with attributes. Attributes describe a requirement in terms of user-defined 
characteristics or properties, such as cost, priority, and status. 

You can create requirements in a view or in a requirements document. All 
requirements created in RequisitePro are stored in the project database. After a 
requirement is created, you can do the following:

■ Move or copy the requirement to a document or a view

■ Qualify the requirement by assigning attributes

■ Trace the requirement to and from other requirements

You can use hierarchical relationships to subdivide a general requirement into more 
explicit requirements. Child requirements provide additional detail about their parent 
requirement. 

A requirement’s name, text, attributes, and relationships can be modified in a view or 
a document. You can read the information in context and add information that 
supports and justifies the requirements.
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Using the in-view editing feature, you can edit and create requirements directly 
within an Attribute Matrix view. Click a selected requirement in the view to start 
editing the requirement name, text, or attributes. (You can also create requirements 
directly in the view without opening a dialog box.) You can create requirements in 
Traceability Tree and Traceability Matrix views using the Requirement Properties 
dialog box.

When you create a requirement in a document, RequisitePro places hidden text at the 
beginning of the description to hold the requirement’s tag. This hidden text is 
underlined with a dotted line. If information is typed in this tag area, it is formatted as 
hidden text and is visible only when Microsoft Word’s Hidden Effects feature is 
turned on (Format > Font > Hidden Effects). To reformat the text to normal, use Word’s 
Font feature (available through the Format menu). The text of the requirement should 
be in normal text only. Requirement text can be articulated as text, graphic elements, 
OLE objects, or Word-linked files. 

Extended editing of documents (available from the Project Properties dialog box, 
Documents tab) lets you change requirement text outside a document: from a view, 
from RequisiteWeb, from the RequisitePro Extensibility Interface, or from integrated 
tools. You can update requirement text without opening the document. This allows 
multiple people to simultaneously edit requirements within a single document. All 
changes are tracked in the database. 

The Embedded Elements Detection Wizard searches all requirement text located in 
project documents for nontextual elements, such as graphics, numbered lists, 
formatting, Microsoft Word-linked files, or OLE files, to prevent the loss of these 
nontextual elements if you select extended editing. These nontext elements cannot be 
edited outside the document, even if extended editing is available. With this option 
selected, RequisitePro prevents you from overwriting the requirement text and 
embedded nontextual elements in the document with text from the database. 

The wizard is required for searching requirements created with RequisitePro version 
4.5 or earlier. In later versions, requirements are automatically checked for embedded 
objects. Additional information about this wizard is available from Help.

Creating Requirements

All requirements that are created in RequisitePro are stored in the project’s database. 
After a requirement has been created, it can be modified, moved, and copied within 
the project and traced to and from other requirements in the same project or across 
projects. 
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When a requirement is created, RequisitePro stores the following information in the 
database:

■ The requirement name. A user-defined title for a requirement; it must not exceed 128 
characters. Like tag and text attributes, the name can be used to reference 
requirements. The name is displayed by default in all RequisitePro views. All 
requirements must have either a name or text (or both), but requirements located 
in documents must have text. A name is not required to be unique, and you can 
change it at any time if you created the requirement or belong to a group that has 
update permissions. 

■ The requirement text. Requirement text is the full textual content of a requirement; it 
must not exceed 16,000 characters. If the requirement is located in a document, the 
requirement text may include embedded and linked objects, such as graphics, 
tables, and Microsoft Word files. 

■ Attribute values. 

Creating a Requirement in the Explorer

1 Select the package in which you want the requirement to be located and click File > 
New > Requirement. 

The Requirement Properties dialog box opens.

2 In the General tab, make a selection from the Type list, and type a name and some 
text. 

3 Click OK.

RequisitePro creates the new requirement in the selected package and assigns the 
next available tag to the requirement. The Location attribute for the requirement is 
listed as Database, because it was created in the Explorer.

Creating a Requirement in a Document

When you create a requirement in a document, RequisitePro performs the following 
operations:

■ The selected requirement text information is bracketed with bookmarks.

■ The following information is associated with the new requirement:

❑ Requirement tag identifier. A requirement tag consists of a prefix and a number.

❑ Color and style format. If the requirement type has color and style, the new 
requirement is formatted with these settings.

❑ Requirement attributes. The new requirement is associated with the attributes 
established for the requirement type. Attributes can be viewed in the 
Requirement Properties dialog box.
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■ For hierarchical relationships, the requirement is assigned a parent based on the 
parent you select in the Requirement Properties dialog box, Hierarchy tab. (For 
more information about parent-child relationships, see Working with Hierarchy on 
page 135.) 

Note:  The requirement and its attribute values are not saved to the project database 
until you save the document.

In addition to text, a requirement can include the following elements: 

■ OLE objects (both embedded and linked)

■ Fields (for example, author, title, subject) 

■ Pictures (both inline and floating) 

■ Tables 

■ Annotations (comments, footnotes, bookmarks, hyperlinks) 

■ Subdocuments 

■ Lists containing more than a single item (including bulleted and numbered 
headings or other styles, both sequential and outline) 

Note that if you include these elements in a requirement, you cannot edit the 
requirement text outside the document (even when the extended editing feature is 
selected).

If you plan to edit the requirement text outside a document and the requirement was 
created in RequisitePro version 4.5 or earlier, you can run the Embedded Elements 
Detection Wizard to search all requirement text located in project documents for 
nontextual elements, such as graphics, numbered lists, formatting, or OLE files. 
(Document requirements created in RequisitePro versions after 4.5 are automatically 
checked for embedded elements; you do not need to run the wizard to check them.) 
This search helps prevent you from losing these nontextual elements if you select 
extended editing. With this option selected, RequisitePro prevents you from 
overwriting the requirement text and embedded nontextual elements in the document 
with text from the database.

The number of requirements in your project documents determines how long this 
search takes. After the initial search, RequisitePro displays a list of affected 
documents. If there are any errors encountered during the search, you can rerun the 
wizard later, and RequisitePro searches only those documents that have not been 
successfully processed.

Note:  Before you start the wizard, review the document paths in the Document 
Properties dialog box to make sure all the paths are accessible.
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Creating a Requirement 

1 In the document, select the information (text, graphics, OLE objects) that you want 
to become part of the requirement. (If you do not select text, you are prompted to 
enter text for the requirement.)

Note:  If you include pictures or objects in requirement text, make sure to use the In 
line with text option on the Layout tab of the dialog box that opens when you click 
Format > Picture/Object. (For information about including Word-linked files in 
requirement text, see Inserting Microsoft Word-linked Files in Requirements on page 
114.) If you plan to use the requirements document in conjunction with Microsoft 
Project, limit the text description of the requirement to 255 characters; this will 
accommodate the length limitation of a task description in Microsoft Project.

2 Click RequisitePro > Requirement > New or the Create Requirement button.

The Requirement Properties dialog box opens.

3 Click the General tab. 

❑ In the Type box, select a requirement type with which to associate the 
requirement. 

❑ In the Name box, type the requirement name (up to 128 characters). You are not 
required to assign a name to a requirement if you have data in the Text box, but 
you cannot leave both the Name and the Text boxes blank. The Text box contains 
text, graphics, and objects that are included as part of the requirement; they are 
displayed in this box. The text of the requirement must not exceed 16,000 
characters.

❑ Click the Browse button next to the Package box if you want to select a different 
package in which to place the new requirement. 

4 Click OK.
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5 To save your changes, click RequisitePro > Document > Save.
RequisitePro saves the document, updates the database, and assigns a requirement 
number to the requirement (in place of the Pending tag). The Location attribute for 
the requirement is listed as the name of the document.

Note:  If you press ENTER after a marked requirement, the requirement style (such as 
double underline) and color are carried to the next line. Press CTRL and the SPACEBAR 
before typing, and the Word style is reset to Normal.

Creating Multiple Requirements from a Range of Text

Click RequisitePro > Requirement > New Wizard to create multiple requirements from a 
range of selected text in a document. When you select this command, the New 
Requirements Wizard opens. You specify the keywords to use for the requirements 
and indicate whether the requirements are in sentences or a paragraph.

RequisitePro uses three methods to distinguish individual requirements in the 
selected range of text:

■ Key words. RequisitePro searches for a specific word, such as shall (the default) or 
any word you specify in each sentence or paragraph (according to the options you 
select). 

■ Text delimiters. RequisitePro searches for text contained within specific text 
delimiters, such as < >, { }, [ ], BEGINREQ ENDREQ. You can designate text to become 
a requirement by surrounding the text with any delimiters you choose. We 
recommend you use a different character on each end of the text, such as open and 
close brackets [ ]. 

■ Word style. RequisitePro searches the text for specified style settings, such as 
“Heading 1” or “Body text” or highlighted text. The styles in your current 
document outline are loaded into the Styles box.

To create requirements from a range of text:

1 In the document, select the text you want to identify as requirements. 

2 Click RequisitePro > Requirement > New Wizard.
The New Requirements Wizard opens.

3 Select a requirement type to apply to the requirements. 

4 Click Set Defaults to open the Set Requirement Defaults dialog box, where you can 
enter default attributes, hierarchy, traceability, and a change description for the 
requirements you create. Then click OK.
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5 In the New Requirements Wizard, select one of the following options to indicate a 
method of distinguishing each requirement in the range of text:

❑ Keywords. Type keywords in the Keywords box; click Add to add the keywords 
to the requirements criteria field. Select either the Match case check box to make 
the keyword match the case of the typed text or the Use * as wildcard check box 
if you want to use a wildcard character in the Keyword box.
(If you want to create requirements from the selected text for each sentence or 
for each paragraph without parsing based on a keyword, type only an * and 
select the Use * as wildcard check box.) To create one requirement per sentence, 
click Sentence; to create one requirement per paragraph, click Paragraph.

❑ Text delimiters. Type a beginning and end delimiter in the indicated field and 
click Add.

❑ Word styles. Select a style from the styles list and click Add.

You can use more than one criteria to differentiate the individual requirements. 
Add keywords, text delimiters, and Word styles to the search list by clicking each 
button in turn. Note that with each selection, the dialog box changes to include 
specific options for that selection.

6 When you have finished adding requirements criteria, click Create.

RequisitePro checks the selected text for the criteria you chose and reports any text 
that matches your criteria in the Requirement Found dialog box: 

❑ Click Yes to accept the proposed requirement.

❑ Click No to reject the proposed requirement.

❑ Click Yes to All to accept all proposed requirements.

7 When all proposed requirements have been created, click Close in the New 
Requirements Wizard.

Note:  The new requirements are not committed to the database until the document 
is saved.

Creating Requirements From Tables

To create a requirement from the text within a single cell in a Word table:

1 Select the text.

2 Click RequisitePro > Requirement > New.

3 Type the requirement information in the Requirement Properties dialog box, and 
click OK.
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To create a requirement that includes text in multiple cells in the table, you must 
convert the table to text in Word, create the requirement, and then convert the text 
(including the requirement) back to a table.

To create multiple requirements from text in multiple cells, convert the table to text, 
use the New Requirements Wizard to create multiple requirements, and convert the 
text back to a table.

1 In the document, select the text to modify.

2 In Word, click Table > Convert > Table to Text.

3 Click RequisitePro > Requirement > New Wizard. 

4 Create the requirements from the selected range of text.

5 Select the newly created requirements.

6 In Word, click Table > Convert > Text To Table.

Inserting Microsoft Word-linked Files in Requirements

You can include Microsoft Word-linked files as part of requirement text. If you change 
the linked file, any traceability or hierarchical relationships with the requirement are 
marked as suspect.

You can link to Microsoft PowerPoint files, Word documents, Excel spreadsheets, 
bitmap files, and other types of files. Do not link to RequisitePro documents. You can 
include other OLE objects in requirement text, but changes to the files do not mark 
traceability or hierarchical relationships as suspect. You must edit requirement text 
from the document if the text contains linked files, OLE objects, or embedded objects. 
For further information, see “In-view editing and extended editing” in Help.

You can use Microsoft Word’s Insert commands to link files to RequisitePro 
requirement text; you can also use Word’s Paste Special and Field commands 
(available through the Edit and Insert menus respectively). If you click Insert > Field, 
the following types of Microsoft Word Links and References are supported:

■ Link

■ IncludeText

■ IncludePicture

Select the Links and References category in the Field dialog box and select the Field 
names. For more information about using the above Word commands, see Microsoft 
Word Help.
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To insert a Microsoft Word-linked file in requirement text:

1 Open a RequisitePro document and click where you want to insert the file. This 
can be in the text of an existing requirement or anywhere in the document where 
you plan to add a new requirement.

2 On the Microsoft Word menu, click one of the following:
❑ Insert > File

❑ Insert > Picture > From File

❑ Insert > Object

3 In the dialog box that opens, browse to the file you want to insert and do one of the 
following:

❑ To insert a file, select the file you want to insert and click Link > Insert as Link. 

❑ To insert a picture, select the picture you want to insert and click Insert > Link to 
File.

❑ To insert an object, select the Create from File tab in the Object dialog box, and 
type the name of the file. (You can also click the Browse button, navigate to the 
file you want to insert, and select it.) Click Insert. In the Object dialog box, select 
the Link to file check box and click OK.

Note:  Do not insert other RequisitePro documents.

4 If you are creating a requirement, do the following:

❑ Select the text that you want to include as requirement text for the new 
requirement. Include the linked file in that selection.

❑ Click RequisitePro > Requirement > New. The Requirements Properties dialog 
box opens.

❑ In the Name box, provide a name for the requirement. Notice that the Text box 
includes the path of the inserted object. Click OK.

5 Click RequisitePro > Document > Save to save the Word-linked file as part of the 
requirement text.

In a view, the Requirements Properties dialog box, and any integration dialog boxes, 
the requirement text includes the path of the linked file and the date and time the file 
was last modified:

<rp.link file:=”path” ts:=”dd-MM-yyyy hh:mm:ss SGMT”/>

Note:  If you do not see the linked file in the requirement text, click F9 to refresh Word. 
If the linked file path still does not appear in the requirement text, you have inserted 
an object instead of a linked file.
Creating Requirements 115



Inserting Microsoft Equations in Requirements

If you want to use RequisitePro’s suspect links feature with Microsoft equations, you 
must insert the equation in a Word document and then insert that document in 
requirement text. If you insert the equation as an object rather than as a Word-linked 
file, changes to the equation do not trigger suspect links.

To insert a Microsoft equation into a RequisitePro requirement:

1 Create a Microsoft Word document containing the equation. You may want to 
create one document per equation if you want to detect changes to each equation 
individually.

2 Insert the Word document that contains the equation in RequisitePro requirement 
text by doing the following:

❑ Open the RequisitePro document.

❑ Click Insert > File.

❑ In the dialog box that opens, browse to the Word document that contains the 
equation.

❑ Select the document and click Insert > Insert as Link. 

3 Create a requirement containing the Word-linked file by doing the following:

❑ Select the linked file. You can also select any text that you want to include as 
requirement text for the new requirement. 

❑ Click RequisitePro > Requirement > New. The Requirements Properties dialog 
box opens.

❑ In the Name box, provide a name for the requirement. Notice that the Text box 
includes the path of the inserted object. Click OK.

4 Click RequisitePro > Document > Save to save the Word-linked file as part of the 
requirement text.

Displaying Linked Files Outside the Document

In a view, the Requirements Properties dialog box, and any integrations dialog boxes, 
the requirement text includes the path of the linked file and the date and time the file 
was last modified:

<rp.link file:="path" ts:="dd-MM-yyyy hh:mm:ss GMT"/>

We recommend using Universal Naming Convention path names if you are sharing 
documents with other RequisitePro users.
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Traceability

When you establish a traceability relationship or hierarchical relationship between 
requirements that include linked files, RequisitePro alerts you to changes to the linked 
source files. You can edit the linked file outside of RequisitePro at any time. 
RequisitePro checks for changes to the linked file when the RequisitePro document is 
saved, and the relationships are marked as suspect only after the document is saved. 
A relationship is marked as suspect if the link references a directory or a file that does 
not exist, but a relationship is not marked suspect if the directory cannot be located.

Troubleshooting While Creating Requirements in Documents

If you experience problems while creating requirements in a project document, check 
for the following conditions to identify and solve the problem:

■ Verify that the selected text does not contain hidden text at the beginning or the end of the 
selection. Because RequisitePro uses hidden text to delineate requirements, it 
prevents the creation of a requirement with hidden text at its beginning or end.

■ Verify that the selected text is not inside or overlapping another requirement. 
Requirements cannot be nested or overlap one another.

Creating a Requirement in a View

You can create requirements in any view. In a Traceability Matrix or a Traceability 
Tree, you can enter data in the Requirement Properties dialog box. In an Attribute 
Matrix, you can insert a new requirement directly into the matrix and set requirement 
name, text, and attributes before saving it.

When you create a requirement in the database, RequisitePro performs the following 
operations:

■ The following information is associated with the new requirement:

❑ Requirement tag identifier. A requirement tag is composed of a prefix and a 
number.

❑ Requirement name. 

❑ Requirement text. 

❑ Requirement attributes. The new requirement is associated with the attributes 
established for the requirement type.

■ Click Requirement > New in a view to create a requirement at the root level (that is, 
one that has no parent). To create child or sibling requirements, see Creating Child 
Requirements in a View on page 135 and Creating Peer Requirements on page 137.
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Creating a Requirement in a Traceability Tree or Traceability Matrix

You create requirements in a Traceability Tree or Traceability Matrix by clicking 
Requirement > New and typing data in the Requirement Properties dialog box.

1 Open a Traceability Tree or a Traceability Matrix based on the requirement type for 
the requirement you want to create.

2 Do one of the following: 

❑ Click Requirement > New. 

❑ Click a requirement in a view, right-click, and select New from the shortcut 
menu.

❑ Select a requirement in the Explorer and click Requirement > New.

The Requirement Properties dialog box opens. 

RequisitePro populates the Type, Package, and Location boxes.

❑ The new requirement inherits the requirement type displayed in the view. 
Select another requirement type from the Type list to change the requirement’s 
type.

❑ The Location box indicates the requirement is located in the database only and 
not in a document. 

3 Type the new requirement name and text and click OK.

RequisitePro creates a requirement tag based on the requirement type’s prefix. A 
sequential number is assigned to the requirement based on the numbering scheme 
assigned to that requirement type. In a Traceability Matrix, the new requirement is 
the last row entry before the default entry; in a Traceability View, the new 
requirement is listed at the bottom of the tree. 
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Creating Requirements in an Attribute Matrix

You can create a requirement in the database by directly inserting the requirement 
into an Attribute Matrix.

1 Open an Attribute Matrix of the requirement type that you want to use for the 
requirement you are creating.

2 Do one of the following to create a requirement in the matrix:

❑ Select the last row (marked <click here to create a requirement>) and 
double-click or press the SPACEBAR.

❑ Click Requirement > New.

❑ Press the INSERT key.

The Name and Text lists appear.

Note:  If you want to use the Requirement > New and INSERT key options to create 
requirements directly in the matrix in the Text box, go to Tools > Options (on the 
toolbar) and make sure that the In-view requirements creation (without dialog box) 
check box is selected. Otherwise, the Requirement Properties dialog box opens. 
(See the preceding section.)

3 Type a requirement name and press the TAB key to go to the box below to enter 
text describing the requirement.

Note:  If you are planning to use this project in conjunction with Microsoft Project, 
limit the text description of the requirement to 255 characters; this will 
accommodate the length limitation of a task description in Microsoft Project. 

4 Do one of the following to save the information:

❑ Press the TAB key.

❑ Click in another cell.

❑ Press the ENTER key. 

Note:  Check settings in the Options dialog box. The ENTER key inserts new line 
check box must be cleared if you want to use the ENTER key to save requirement 
information in the Attribute Matrix.)

RequisitePro creates a new empty row (marked with an * and <click here to create 
a requirement>) below the row you are editing and moves the cursor over to the 
first attribute cell for the new requirement you are inserting. A pencil icon appears 
at the beginning of the row, indicating that the requirement is in edit mode and 
that changes are not yet saved.

5 Select or type an attribute, and press the TAB key to go to other attribute columns 
to make any changes from the default attribute values.
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6 Use the TAB key to go to the next row, or click outside the row, when you are 
finished setting information about the new requirement.
RequisitePro creates a new requirement and assigns the next available tag to the 
requirement. The Location attribute for the requirement is listed as Database 
because the requirement was created in a view.

Revising Requirement Text and Properties

Use the Requirement Properties dialog box to view or modify requirement 
information, including attribute values, traceability relationships, hierarchical 
relationships, discussions, and change descriptions. In an Attribute Matrix, you can 
change the name, text, and attributes directly in the view. (For more information, see 
the chapters Working with Discussions on page 65, Working with Hierarchy on page 135, 
and Working with Traceability on page 145.)

Opening the Requirement Properties Dialog Box

Do one of the following to open the Requirement Properties dialog box:

■ Select a requirement in the Explorer and either right-click and select Properties or 
click File > Properties.

■ Select a requirement in a view and either right-click and select Properties or click 
Requirement > Properties.

■ Select a requirement in an open document and either right-click and select 
Requirement Properties or click RequisitePro > Requirement > Properties. 

■ Select a requirement in a document or in a view and click the Display properties 
button. 
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Accessing Revision Information

Use the Revision tab in the Requirement Properties dialog box to record and monitor 
revision information about the requirement. 

■ RequisitePro automatically generates an internal revision number for the 
requirement in the Revision box whenever a requirement is modified and saved. 
This box is read-only. Changes to name, text, and attributes cause the revision 
number to change. If you make the change in a RequisitePro view, RequisitePro 
increments the revision number for the individual requirement each time you 
make a change. If you make the change in a document, RequisitePro increments 
the revision number for the requirement each time you save the document.

■ Click the Label box to associate a logical name with a revision number. The Label 
box is available only if the requirement is new or if you change an attribute value. 
It is also available when you change the text at the General tab or when you change 
the hierarchy on the Hierarchy tab of the dialog box. This step is optional. Any 
specific revision can be named in this text box, using any combination of up to 20 
alpha-numeric characters, such as Beta Release. The label is added to the 
requirement’s change history. When it has been applied, it cannot be changed or 
removed.

■ Use the Change Description box to record changes made to a requirement. This text 
box can contain up to 2,048 characters. (This step is optional.) 

■ The Date, Time, and Author boxes are populated by RequisitePro and cannot be 
modified. The Package box is also populated by default, but you can browse to 
select another package in which you want the requirement to appear.

■ Click the History button to display the requirement’s change history.

■ Any modifications made to requirements are pending until the document is saved. 
When a requirement is committed to the database, its status changes from Proposed 
changes... to Last Saved. 
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Recording Requirement Changes in Documents

When you modify a requirement’s text in a document, you can describe the reason for 
the change. Make sure the cursor is still in the requirement and then do the following:

1 Click RequisitePro > Requirement > Annotate Change. 

The Change Description dialog box opens.

2 Type the reason for the changes.

3 Click OK. 

RequisitePro commits the description to the database when you save the 
document.

If you attempt to close a document that contains requirement changes without 
annotating the changes, RequisitePro displays the Change Description dialog box, 
scrolls to the requirement, and prompts you to record a reason for the change. 

Modifying Attribute Values

Attributes and their corresponding list of default values are defined by the 
requirement type of the requirement. Use the Attributes tab in the Requirement 
Properties dialog box to assign values to the attributes for a requirement. 

To assign values to requirement attributes:

1 Open the Requirement Properties dialog box by following one of the options on 
page 120.

2 Click the Attributes tab. 
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The attributes for the requirement are displayed.

3 Type attribute values: 

❑ For list-type attributes, select a value in the list.

❑ For entry-type attributes, enter a value in the text box.

Note:  To move between fields, use the scroll bar or the TAB key.

4 Click OK.

You can use shortcuts for changing the attribute values, requirement name, or 
requirement text in an Attribute Matrix.

To modify attribute values from an Attribute Matrix:

1 In an Attribute Matrix, do one of the following:

❑ Double-click an attribute value or requirement text.

Note: Make sure the Double-click to go to source check box in the Options dialog 
box is cleared if you want this option for editing directly in the Attribute Matrix. If 
the check box is selected, double-clicking opens the Requirement Properties dialog 
box or a document (if the requirement resides in a document).

❑ Click the requirement name, text, or attribute, and then press the SPACEBAR.

2 For list-type attributes, select a value in the list. For multiple value list-type 
attributes, select one or more values in the list.
For entry-type attributes and requirement name and text, type data in the text box. 

In order to modify the requirement text located in documents, you must select the 
Enable Extended Editing of documents check box in the Documents tab of the 
Project Properties dialog box.

3 Press the TAB key to move to other rows that can be edited.

4 To accept the changes, click outside the row or press ENTER.
(To cancel the editing process without saving changes, press ESC.)
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You can also use a multiple select action in an Attribute Matrix to select more than one 
attribute value, and then right-click and select Set Value from the shortcut menu. The 
Set Value dialog box opens, allowing you to select a value to use for all selected 
requirements.

Using the Requirement Name Conversion Wizard

If you have been using a user-defined attribute to serve as a name or label for 
requirements in your project (before RequisitePro version 2001.03.00), you may want 
to add the data to the requirement name. The Requirement Name Conversion Wizard 
takes you through the process of copying this data.

Note:  If the project is secure, you can perform this conversion only if you are a 
member of the administrators group.

The requirement name is limited to 128 characters. If the attribute values you copy to 
the requirement name are longer than 128 characters, they will be truncated.

To start the wizard:

Open the Requirement Name Conversion Wizard in Windows Explorer. The 
executable, rqreqnameconvwiz.exe, is located in the Rational\RequisitePro\bin\ directory.

Associating Requirements with New Types

When you change a requirement’s type, several things can happen:

■ Attribute values associated with the requirement are changed to the default 
attribute values of the new requirement type. 

■ If the requirement is a parent, the requirement type is also changed for all of its 
child requirements.

■ If the requirement is a child, the requirement is moved to the root for the new 
requirement type, and the requirement no longer has a parent.

For more information about parent and child requirements, see the chapter Working 
with Hierarchy on page 135.

Associating a Requirement with a New Requirement Type

1 Open the Requirement Properties dialog box by following one of the options in 
Opening the Requirement Properties Dialog Box on page 120.

2 Click the General tab.

3 Select a new requirement type from the Type list.
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The Change Requirement Type dialog box opens, explaining the change process.

4 Click Yes. The requirement type is changed in the Requirement Properties dialog 
box.

5 Click OK to save the changes.

Associating Multiple Requirements with a New Type

When you change the requirement type, several things happen:

■ Attribute values associated with the requirements are changed to the default 
attribute values of the new requirement type.

■ If the requirements are parents, the requirement type is also changed for all of their 
child requirements.

■ If the requirements are children, they are moved to the root for the new 
requirement type, and the requirements no longer have a parent.

Note:  Resetting attribute values is a separate procedure; you do it after you change 
the requirement type and save the document.

1 Open an Attribute Matrix and use a multiple select action to select multiple 
requirements.
For requirements in documents, the documents must be open in RequisitePro 
before you begin the following procedure.

2 Click Requirement > Change Type.
A dialog box opens, explaining the change process.

3 Click Yes. The Change Requirement Type dialog box opens.

4 In the New Requirement Type list, select a new requirement type.

5 Click OK.

The requirements and their children are removed from the Attribute Matrix. When 
you display a matrix of the new requirement type, the requirements and their children 
are added at the end of the matrix by default. 

For requirements in documents, you must save the open document to commit 
requirements to the database.
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Relocating Requirements

You can move or copy requirements within the same requirements document, 
between documents, and between a document and the database. Requirements are 
moved by using RequisitePro’s Cut, Copy, and Paste commands. 

Cutting, copying, and pasting a requirement include its name, text, attributes, and 
traceability relationships. 

Requirements that are cut using RequisitePro’s Cut command are placed in a buffer 
available only to RequisitePro. If a requirement is in the buffer and another 
requirement is cut or copied, the original requirement is deleted from the database. 
The buffer used in RequisitePro is not the Windows Clipboard. Any information 
currently on the Windows Clipboard is preserved when you cut a requirement in a 
RequisitePro database.

If security is enabled in the project, you must have Delete permissions for a 
requirement type in order to cut requirements of that type.

Caution: Do not use the Microsoft Word Cut, Copy, and Paste commands to move 
requirements. When you use the Word Cut command, it is possible the requirement 
could be deleted from the project. In addition, if you cut a requirement from a 
document using the Cut command in Word, you cannot paste the requirement into the 
project database.

Note:  The RequisitePro Cut and Paste commands move the original requirements. 
The Copy and Paste commands create new requirements. If pasted in a document, 
new pending requirements are inserted. If pasted in a database, new requirements are 
created in the database.

Cutting or Copying from a Document 

To cut or copy a requirement from a document:

1 Click in the requirement text. 

2 Click RequisitePro > Requirement > Cut (or Copy). 

RequisitePro cuts or copies the requirement (and its child requirements) from the 
requirements document.

You can move or copy the requirement to a new position in the current document or 
to another requirements document.
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To paste the requirement in a document:

1 Open or click the destination document and place your cursor in the location 
where you want to paste the requirement.

2 Click RequisitePro > Requirement > Paste.
RequisitePro inserts the requirement (and its child requirements) in the specified 
location.

You may want to remove a requirement from a document and locate it only in the 
database. You can paste a requirement into an Attribute Matrix view if it is based on 
the same requirement type as the cut requirement. A requirement cannot be pasted 
into a Traceability Matrix or a Traceability Tree view. 

If you paste a requirement containing an OLE object from a document into the project 
database, you can no longer access the linked file. 

To paste a cut requirement into the database:

1 Open or create an Attribute Matrix view based on the same requirement type as 
the cut requirement.

2 Click Edit > Paste. 
RequisitePro pastes the requirements into the database.

Note:  If an OLE object is part of the requirement you are pasting into the database, 
the object is lost. RequisitePro treats the loss of the object as a change to the 
requirement and marks all traceability relationships involving that requirement as 
suspect. Click Traceability > Clear Suspect to reset these relationships. 

Cutting or Copying in a View

To move a requirement in the database to a document, you can cut it from an 
Attribute Matrix and paste it into a requirements document.

■ Click Edit > Cut to move a requirement, with all of its relationships, into a 
document.

■ Click RequisitePro > Requirement > Copy to make a copy of a database requirement 
and paste it into a document. This option creates a new requirement when you 
save the requirements document. Copying a requirement duplicates its text and its 
attributes, but not its traceability relationships. For hierarchical requirements, 
RequisitePro copies the requirement as a peer requirement at the same level in the 
parent/child hierarchy. (For more information, see the chapter Working with 
Hierarchy on page 135.)
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To cut or copy a requirement from the database:

1 Open an Attribute Matrix containing the requirement.

2 Select the requirement’s name/text cell in the first column of the matrix.
(Use a multiple select action to select multiple requirements.)

3 Click Edit > Cut or Edit > Copy. 

To paste the requirement into a requirements document or into another Attribute 
Matrix of the same requirement type in the same RequisitePro project:

1 Open the requirements document or Attribute Matrix and click the location to 
paste the requirement.

2 Do one of the following: 

❑ To paste the requirement in a document, click RequisitePro > Requirement > 
Paste. 

❑ To paste the requirement in a view, click Edit > Paste.

RequisitePro inserts the requirement (and its child requirements) in the specified 
location in the document; in a view, the requirement is placed at the end of the 
matrix. Note that a copied requirement is identified with the text “Copy of ... .”
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Rules for Relocating Requirements

Consider the following rules when moving requirements using the RequisitePro Cut, 
Copy, and Paste commands:

1 If you cut a requirement from a document and do not paste it into the database, it is removed 
from both the document and the database when you save the document.

2 For parent-child requirement hierarchies: When pasting from a document to the same 
document, you can cut and paste only a root requirement or a leaf (the lowest-level child 
requirement). When pasting from a document to a different document, you can move a root 
requirement and all its children. For more information about parent-child requirements, see 
the chapter Working with Hierarchy on page 135. 

3 For parent-child requirement hierarchies: Only a root requirement can be moved from the 
database to a document. For more information about parent-child requirements, see the 
chapter Working with Hierarchy on page 135.

■ Do not use Microsoft Word’s Cut/Paste commands. We recommend that you do not use 
Word’s Cut command to cut requirement text for two reasons. The risk of not 
capturing the entire requirement (including its bookmarks and tag) and 
accidentally deleting the requirement from the project database is greater in Word. 
In addition, a requirement cannot be moved from a document into the project 
database with Word’s Cut command.

■ Be careful when you use the buffer with the RequisitePro Cut command. Requirements 
you cut using RequisitePro’s Cut command go into a proprietary cut buffer. You 
should paste a requirement to its new location before cutting or copying another 
requirement. If requirements are in the buffer and you cut or copy another 

Requirement 
Location

Function
Requirement Destination

Paste to Database Paste to Document

Document Cut Removes the 
requirement from the 
document but saves it in 
the database.1

Relocates the 
requirement in the 
document.2

Copy Creates a new 
requirement in the 
database.

Creates a new 
requirement in the 
document.

Database Cut Not Applicable Relocates the 
requirement in the 
document.3

Copy Creates a new 
requirement in the 
database.

Creates a new 
requirement in the 
document.3
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requirement, the first requirements are placed back in their original location in the 
database. If you want to cut or copy multiple requirements, you can do so in the 
Attribute Matrix only.

Note:  The buffer used in RequisitePro is not the Windows Clipboard. Any 
information on the Windows Clipboard is preserved when you cut or copy a 
requirement in RequisitePro.

Refreshing Requirement Color and Style in a Document

A specific color and style distinguishes requirements that belong to a specific 
requirement type. For example, you might mark all requirements that belong to the 
requirement type feature with a dark green requirement color and a double underline 
style. This helps you easily recognize all feature requirements regardless of their 
location. Refreshing the color and styles of requirements is useful for restoring 
requirements to their proper state when their color and style have been inadvertently 
overwritten.

To refresh requirement color and style in a requirements document:

1 Select the requirements to refresh. 

2 Click RequisitePro > Document > Refresh Requirements.

RequisitePro checks the color and style settings of the requirements in the 
document and, if necessary, resets them to the proper settings for the requirement 
type. 

Note:  To remove color and styling and convert the requirement back to plain text, see 
Unmarking and Removing Requirements in a Document on page 133.

Rebuilding Requirement Tags in a Document

When a requirement is created in a document, the requirement information is 
bracketed by bookmarks and assigned a requirement tag. Select the Show Tags check 
box in the Document Properties dialog box to ensure that the requirement tags are 
visible both on your display and in the printed document.

Tags can be accidentally corrupted or deleted while editing a requirements document. 
Use the Rebuild Tags command to rebuild a requirement tag that is partially or 
completely deleted or corrupted. RequisitePro rebuilds the affected tags, then 
provides a list of rebuilt requirement tags. 

The Rebuild Tags command does not restore deleted or corrupted requirement 
information such as text, graphics, or OLE objects. You cannot rebuild tags if a 
document is open in read-only mode, and you must have Update permissions to use 
this command.
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To rebuild requirement tags in a document:

1 Highlight the requirement tags to rebuild. 

2 Click RequisitePro > Document > Rebuild Tags.

RequisitePro rebuilds all the requirement tags in the document and displays a list 
of them.

Refreshing Requirement Text

RequisitePro updates its display at different times, depending on what you (or other 
RequisitePro users) modify and where you make changes.

If you modify requirement text in a document, RequisitePro updates the requirement 
when you save the document. If you open a document and have write or read-only 
permission, the document is displayed in Microsoft Word in its last-saved state.

Views display the current state of the database. New requirements or modified 
requirements that have not been saved are not reflected in the view. You can refresh 
requirements in a view at any time by using the Refresh command on the View menu. 
RequisitePro updates all requirement information in the database.

Renumbering Requirements

Use the Renumber Requirements command to renumber all requirements of a 
specified type in a project. This feature is useful to eliminate the “holes” in a 
numbering scheme that result when you delete or move requirements. You can 
renumber one or several requirement types in one operation. Requirements are 
renumbered in the database and in requirements documents. You can select which 
requirement type you want to renumber and the order in which you want the 
documents processed. (Requirements in documents are renumbered in the order in 
which they appear in the document.)

If security has been set for the project, you must have project structure permission to 
renumber requirements. The project must be open in exclusive mode to use this 
command. To renumber requirements in a document, you must open all documents 
that contain requirements of the specified type.

To renumber all requirements in a project:

1 Click File > Project Administration > Renumber Requirements. 

If the documents have not been saved, a message informs you that all documents 
will be saved before the requirements are renumbered. Click Yes to proceed.
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The Renumber Requirements dialog box opens.

2 In the Requirement Type list, select the requirement type that you want to 
renumber. 

3 Select the Renumber Requirements of this type check box. 

Note:  To renumber requirements of more than one requirement type, repeat Steps 
2 and 3.

4 In the Initial Requirement Number box, enter the initial requirement number that 
you want to set. The default number is 1.

5 To change the order of renumbering for database requirements and documents, 
select Database or a document name. Click the Move Up and Move Down buttons to 
put the database and documents in the order in which you want them to be 
processed. The requirements in the first item listed (the database or a document) 
are renumbered first, followed sequentially by the requirements in the second 
item, and so on. 

Note:  A document appears in the Order of Processing list only if it contains 
requirements of the selected type. 

6 Click OK.

Deleting Requirements

In general, we recommend that you not delete any requirements after you archive a 
project, because deleting a requirement deletes the complete information related to 
that requirement, including its history.
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RequisitePro does provide a Delete Requirement function that should only be used 
prior to archiving a project, when you are getting familiar with the tool. To delete a 
requirement after the project is archived, you can use a requirement attribute (for 
example, Deactivated, Retired, or Inactive) to indicate that a requirement is no longer 
valid.

When you delete a requirement that is linked to requirements that reside in other 
projects, the other projects are updated to remove the relationships to and from the 
deleted requirement.

Note:  Deleting a requirement causes its history and traceability relationships to be 
permanently removed from the project database.

Unmarking and Removing Requirements in a Document

You have the option of leaving the text in a document when you delete a requirement. 
Use the Delete-Unmark command to remove the requirement styling from text without 
deleting the text itself. The requirement text, graphics, or OLE objects remain in the 
document, but they are no longer recognized as requirements. The color and style 
settings of the requirement are removed and replaced with the document default 
style. 

The Delete-Remove command deletes the requirement text from the requirements 
document and removes it from the database. 

To unmark or remove a requirement in a document:

1 In the requirements document, click in the requirement text or highlight a range of 
text that includes multiple requirements.

2 Do one of the following:

❑ Click RequisitePro > Requirement > Delete-Unmark to retain the text without 
identifying it as a requirement.

❑ Click RequisitePro > Requirement > Delete-Remove to remove the requirement 
text from the document and the requirement information from the database. 

A message appears, asking you to confirm the deletion.

3 Click Yes. The RequisitePro formatting is removed and the requirement text is 
converted to the default text style.

Note:  If you select a parent requirement and click RequisitePro > Requirement > 
Delete-Unmark or RequisitePro > Requirement > Delete-Remove, the Delete 
Requirement dialog box opens, asking what you want to do with the remaining 
child requirements. If you click Cancel, then it cancels the entire Delete process.

You can undo an unmark operation before you save the document; in Word, click 
Edit > Undo repeatedly until the styling, bookmarks, and tags reappear.
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4 Click RequisitePro > Document > Save. 

The requirement is removed from the database.

Deleting Requirements from the Database

In an open view, you can delete a requirement from the database, provided that the 
requirement is not located in a document. (Check the Location attribute in an 
Attribute Matrix; requirements have a location listed as “Database” or the file name of 
the requirements document.)

When you delete a requirement that is linked to requirements that reside in other 
projects, the other projects are updated to remove the relationships with the deleted 
requirement. Unlike cut requirements, which are placed in a buffer for pasting within 
RequisitePro, deleted requirements are completely removed from the database, 
together with their history and traceability relationships.

1 Open the Attribute Matrix containing the requirement.

2 Select the requirement in the matrix. (Use a multiple select action to select more 
than one requirement.)

3 Click Edit > Delete. A message asks you to confirm the deletion.

4 Click Yes. The requirement is deleted.
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9Working with Hierarchy
Hierarchical requirement relationships are parent-child relationships that reflect 
direct dependencies between requirements of the same type. In addition, these 
associations provide powerful tools for change management. With hierarchical 
requirements, you can support a requirement with a number of sub-requirements by 
establishing a parent requirement and creating child requirements of that parent. 

Like traceability relationships (see the chapter Working with Traceability on page 145), 
hierarchical relationships are a type of change-managed relationship in Rational 
RequisitePro. If a requirement’s name, text, requirement type, or attribute is changed, 
the relationships with its children become suspect. You can view and manage suspect 
relationships using a Traceability Matrix or a Traceability Tree view. 

Creating Child Requirements

A child requirement is any requirement that has a parent. Each child requirement can 
have only one parent, but a requirement can be both a parent and a child. 

Hierarchical relationships are created in a requirements document or in a view. If the 
parent requirement resides in a document, the child requirement must reside in the 
same document. The parent requirement and all of its children must be of the same 
requirement type.

These relationships are created in one of the following ways: you can use the Hierarchy 
tab in the Requirement Properties dialog box; you can create them directly in a 
requirements document by clicking RequisitePro > Requirement > New; or you can 
click Requirement > New to insert them in an Attribute Matrix.

Hierarchical requirements use an outline numbering style, with a period denoting 
each child level. For example, if the requirement tag is PRD108, then its immediate 
children are numbered PRD108.1 and PRD108.2. Their immediate children are 
numbered PRD108.1.1 and PRD108.2.1.

Creating Child Requirements in a View

To create a child requirement in a view, make sure the currently selected requirement 
(which will become the child's parent) is not located in a document.
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1 Open the view containing the requirement that you have chosen to be a parent.

2 Click the requirement. (You can create one child requirement at a time.)

3 Click File > New > Child Requirement.

❑ In an Attribute Matrix, a new row appears directly following the last 
requirement with the selected parent, and the Name/Text Edit box opens, 
allowing you to add information. For more information, see Creating 
Requirements in an Attribute Matrix on page 119.

❑ In a Traceability Matrix and a Traceability Tree, the Requirement Properties 
dialog box opens. Click the General, Revisions, Attributes, Traceability, and 
Discussion tabs to define the child requirement, and type the appropriate 
information.

Note that in the Hierarchy tab, the parent requirement is predefined as the 
requirement you selected in Step 2. (If you want to, you can change the parent.)

4 Press the TAB key to go to the next row, click outside the row in an Attribute 
Matrix, or click OK in the Requirement Properties dialog box.

RequisitePro creates the child requirement in the database and generates a 
requirement tag for the child requirement based on the parent requirement’s 
number.

After creating child requirements, review saved views to make sure both child and 
parent requirements are displayed. You can modify the query on a saved view and 
select the Retain Hierarchical Display check box to include hierarchical 
requirements in the view. Then save the view again to keep those changes. (See 
Creating and Modifying Queries on page 57.)

Creating Child Requirements in the Explorer

1 Select the requirement you want to be the parent and click Requirement > New > 
Requirement. 

The Requirement Properties dialog box opens.

2 Click the tabs and type information to define the requirement.

3 Click OK. RequisitePro creates a new child requirement, indented below the 
selected parent requirement in the Explorer.

Creating Child Requirements in a Document

You can create child requirements in a requirements document by assigning a parent. 
The assignment is committed to the database when the document is saved.
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1 In a requirements document, highlight the requirement that you intend to be a 
child requirement. 

2 Click RequisitePro > Requirement > Properties or the Requirement properties 
button. 

The Requirement Properties dialog box opens.

3 Click the General tab and type the appropriate information to define the 
requirement.

4 Click the Hierarchy tab.

5 Select a parent from the Parent list. Note that the default is the last parent selected 
in the document. If the parent is not selected in the list, select <choose parent...> 
and select from the list that appears in the Parent Requirement Browser dialog box. 

6 Click OK to close each dialog box. 

7 Click RequisitePro > Document > Save to save the new parent-child relationship in 
the database.

RequisitePro generates a requirement tag for the child requirement based on the 
parent requirement’s number.

After creating child requirements, review saved views to make sure both child and 
parent requirements are displayed. You can modify the query on a saved view and 
select the Retain Hierarchical Display check box to include hierarchical requirements in 
the view. Then save the view again to keep those changes. (See Creating and Modifying 
Queries on page 57.)

Creating Peer Requirements

Requirements have a peer relationship when they are at the same level in the 
requirement hierarchy. For example, two requirements are peer requirements when 
they are children of the same parent. All requirements at the root level are peer 
requirements of one another.

When a requirement is created in a document, it is automatically placed at the same 
level as the requirement above it. See Creating a Requirement in a Document on 
page 109. 

Creating Sibling Requirements in a View

When you create a requirement in a view, it is automatically created at the root level. 
See Creating a Requirement in a View on page 117. To create a peer requirement of a 
requirement that has a parent, use the Create Sibling command.
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To create a sibling requirement:

1 Open the view containing the requirement you have chosen for a sibling.

2 Select the requirement.

3 Click File > New > Requirement.

Note:  You cannot create a sibling in a view if the parent of the siblings resides in a 
document.

❑ In an Attribute Matrix, a new row appears directly following the last 
requirement with the same parent, and the Name/Text Edit box opens, allowing 
you to add information. For more information, see Creating Requirements in an 
Attribute Matrix on page 119.

❑ In a Traceability Matrix and a Traceability Tree, the Requirement Properties 
dialog box opens. Click the General, Revision, Attributes, Traceability, and 
Discussions tabs to define the child requirement, and type the appropriate 
information.

Note that in the Hierarchy tab, the parent requirement is predefined as the parent of 
the requirement you selected in Step 2. (If you want to, you can change the parent.)

4 Tab to the next row or click outside the row in an Attribute Matrix, or click OK in 
the Requirement Properties dialog box.

RequisitePro creates the sibling requirement in the database and generates a 
requirement tag for the new requirement based on the parent requirement’s 
number.

Note:  After creating sibling requirements, review saved views to make sure both child 
and parent requirements are displayed. You can modify the query on a saved view 
and select the Retain Hierarchical Display check box to include hierarchical 
requirements in the view. Then save the view again to keep those changes. (See 
Creating and Modifying Queries on page 57.)

Changing Parent Requirements

You can assign a hierarchical requirement with a new parent of the same requirement 
type. When you do, the entire sub-tree of children is also moved to the new parent. 
The requirements are renumbered as though they were created for the new parent.
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When children are assigned to a different parent, all hierarchical relationships 
between the new parent and its immediate children are marked as suspect. However, 
the relationships between the children and their children are not marked as suspect. 
(See also Suspect Relationships on page 151.)

Note:  After creating new child requirements, review saved views to make sure both 
child and parent requirements are displayed. You can modify the query on a saved 
view and select the Retain Hierarchical Display check box to include hierarchical 
requirements in the view. Then save the view again to keep those changes. (See 
Creating and Modifying Queries on page 57.)

Assigning Parent Requirements in the Requirement Properties Dialog 
Box

1 Open the Requirement Properties dialog box in one of the following ways:

❑ Select the requirement in the Explorer or in a view and click Requirement > 
Properties.

❑ In the document, click anywhere in the requirement text. Then click 
RequisitePro > Requirement > Properties. 

2 Click the Hierarchy tab.

3 Select a new parent from the Parent list. If the parent is not displayed in the list, 
select <choose parent...>. 
Changing Parent Requirements 139



The Parent Requirement Browser dialog box opens. 

4 Select a parent requirement from the list. To locate a specific requirement, click the 
Find button. 

5 After selecting the parent requirement, click OK.

6 In the Requirement Properties dialog box, click OK.

The requirement becomes a child requirement of the parent you selected. New 
requirement tags are generated for the child requirement and its sub-tree of 
children, based on the parent requirement’s number. 

Note:  For requirements in documents, you must save the open document to 
commit requirements to the database. After creating new child requirements, 
review saved views to make sure both child and parent requirements are 
displayed. You can modify the query on a saved view and select the Retain 
Hierarchical Display check box to include hierarchical requirements in the view. 
Then save the view again to keep those changes.

Assigning Parent Requirements in a View

In a view or in the Explorer, you can associate more than one hierarchical requirement 
with a new parent of the same requirement type. All selected requirements are 
assigned to the same new parent. When you assign a new parent to a requirement, the 
entire sub-tree of children is also moved to the new parent. The requirements are 
renumbered as if they were newly created for the new parent.
140 Chapter 9 - Working with Hierarchy



When requirements are assigned to a new parent, all hierarchical relationships 
between the new parent and its immediate children are marked as suspect. The 
relationships between the children and their children are not marked as suspect.

Note:  If any of the requirements you want to change are in documents, the document 
must be open (and you must have the ability to edit it) before you begin the following 
procedure.

To assign a new parent to more than one requirement:

1 Select a requirement in the Explorer or in a view. (Use a multiple select action to 
select more than one requirement.)

2 Click Requirement > Change Parent.

The Select New Parent dialog box opens.

3 In the New Parent list, select a new parent. If the parent is not displayed in the list, 
select <choose parent...>. 

The Parent Requirement Browser dialog box opens. 

4 Select a parent requirement from the list. To locate a specific requirement, click the 
Find button. 

5 After selecting the parent requirement, click OK.

6 In the Select New Parent dialog box, click OK.
The requirements become child requirements of the parent you chose. A new 
requirement tag is generated for the child requirements and their sub-trees of 
children, based on the new parent requirement’s number. 

Note:  For requirements in documents, you must save the open document to 
commit requirements to the database. After creating new child requirements, 
review saved changes to make sure both child and parent requirements are 
displayed. You can modify the query on a saved view and select the Retain 
Hierarchical Display check box to include hierarchical requirements in the view. 
Then save the view again to keep those changes.
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Changing Multiple Child Requirements to Root Requirements

To change multiple selected child requirements to root requirements in an Attribute 
Matrix:

1 Open the Attribute Matrix, and then select the child requirements. (If the 
requirements appear in a document, the document must be open.)

2 Click Requirement > Change Parent.

The Select New Parent dialog box opens.

3 In the New Parent list, select <none>.

4 Click OK.

The requirements now appear as root requirements of the same requirement type. 
The children are renumbered to the next available numbers for the requirement 
type.

Deleting Hierarchical Requirements

In general, we recommend that you not delete any requirements after you have 
archived a project, because deleting a requirement deletes all the information related 
to that requirement, including its history. (See Deleting Requirements on page 132.) 
After the project is archived, use a requirement attribute (such as Deactivated, Retired, 
or Inactive) to indicate that a requirement is no longer valid, rather than deleting it.

To delete requirements that are located in documents, go to the document. To delete 
requirements that are located only in the database, go to an Attribute Matrix. 

When you delete a requirement that is traced to or traced from requirements that 
reside in other projects, the other projects are updated to remove the relationships 
with the deleted requirement.

Unlike cut requirements, which are placed in a buffer for pasting within RequisitePro, 
deleted requirements (together with their history and traceability relationships) are 
completely removed from the database.

To delete a hierarchical requirement:

1 Do one of the following:

❑ Open the Attribute Matrix and click the requirement to delete. (Use a multiple 
select action to select multiple requirements.) Click Edit > Delete.

❑ Open the document, select the requirement to delete, and click RequisitePro > 
Requirement > Delete-Unmark. 

A dialog box opens, asking you to confirm the deletion.
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2 Click Yes to delete the requirement.

If the requirement has children, the Delete Requirement dialog box opens.

Note:  If you are deleting multiple requirements in the Attribute Matrix, the Delete 
Requirement dialog box opens for each parent requirement.

3 Do one of the following:

❑ Select the Delete all child requirements recursively check box to delete the 
requirement and all its children. This option removes all traceability and 
hierarchical relationships.

❑ Select the Assign all child requirements to a new parent check box to delete the 
requirement and save its children. This option reassigns all children to a new 
parent you select from a list of requirements. When the children are reassigned, 
all hierarchical relationships between the new parent and its immediate 
children are marked suspect.

4 Click OK. 

If you are working in a view, the requirement is deleted immediately when you click 
the Delete button. If you are working in a requirements document, save the document 
to commit the deletion to the database.

If you have deleted requirements from a document but have not saved the document, 
you can undo the delete operation. In Word, click Edit > Undo until the requirements 
are completely restored. 

Suspect Relationships

A relationship between requirements becomes questionable or suspect if RequisitePro 
detects a requirement’s name, text, requirement type, or attributes have been 
modified. In a view, you can manually mark a hierarchical relationship suspect or 
clear a suspect relationship.

■ When you modify a parent requirement, RequisitePro marks as suspect the 
relationship between the parent and all its immediate children. 
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■ When you modify a child requirement, RequisitePro does not mark as suspect the 
relationship between the child and its parent, although the child’s relationship 
with other requirements is marked as suspect.

■ When children are reassigned to another parent, all hierarchical relationships 
between the new parent and its immediate children are automatically marked as 
suspect. The relationships between the children and their children are not marked 
as suspect.

Displaying Suspect Hierarchical Relationships

You can display suspect hierarchical relationships using the Traceability Matrix and 
the Traceability Tree views. In a view, the suspect relationship is identified by a red 
diagonal line through the requirement icon. 

The Auto Suspect command monitors a requirement’s change history and displays a 
suspect signal when requirements are changed. Click Tools > Auto Suspect to enable 
or disable automatic checking for changes that affect the traceability or hierarchical 
relationships between requirements in the project.

When Auto Suspect is disabled, RequisitePro does not monitor changes in 
requirements, and it does not mark relationships as suspect. There are times when this 
mode is appropriate (for example, when you are revising spelling mistakes in your 
documents and do not want those revisions to cause your relationships to become 
suspect).

When Auto Suspect is enabled, RequisitePro constantly monitors requirements for 
changes that may affect traceability or hierarchical relationships. If there is a change in 
a requirement, the state of the requirement’s relationships is automatically changed to 
suspect. If you have cross-project traceability active, requirements in external projects 
are also monitored.

Auto Suspect is available by default. If you cancel Auto Suspect, it is automatically 
made available the next time you open the project. You can also make it available by 
clicking Tools > Auto Suspect and selecting Enable Auto Suspect.

Clearing Suspect Relationships

You can reset a parent-child relationship that has been marked suspect by manually 
clearing it in the Traceability Matrix or Traceability Tree.

In a Traceability Matrix, select one or more intersection points in the matrix where a 
traceability link has been created. Then either click Traceability > Clear Suspect, or 
click Edit > Set Value, and select Clear Suspect from the list.

In the Traceability Tree, select one or more requirements to modify. Then click 
Traceability > Clear Suspect.
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10Working with Traceability
In Rational RequisitePro, traceability is a dependency relationship between two 
requirements. Traceability is a methodical approach to managing change by linking 
requirements that are related to each other.

Like hierarchical relationships (see the chapter Working with Hierarchy on page 135), 
traceability relationships are change-managed relationships in RequisitePro. If either 
end-point of the connection is changed, the relationship becomes suspect.

RequisitePro makes it easy to track changes to a requirement throughout the 
development cycle, so it is not necessary to review all your documents individually to 
determine which elements need updating. You can view and manage suspect 
relationships using a Traceability Matrix or a Traceability Tree view. 

This chapter addresses traceability between requirements in the same project. For 
information about cross-project traceability, see Setting Up and Modifying Cross-Project 
Traceability on page 234.

Creating Traceability in a Document

Use the Requirement Properties dialog box (RequisitePro > Requirement > Properties) 
to trace a requirement to or from other requirements in a document. A common 
traceability relationship is one in which one requirement is derived from another.

Creating a Traceability Relationship in a Requirements Document

To create a traceability relationship in a requirements document:

1 Place the cursor in the requirement.

2 Click RequisitePro > Requirement > Properties. 

The Requirement Properties dialog box opens.

3 Click the Traceability tab.

The From box lists requirements from which the selected requirement is traced. 
The To box lists requirements to which the selected requirement is traced. An (s) 
after the requirement tag represents a suspect relationship. (You can double-click a 
requirement to view a read-only version of its dialog box.) 

4 Click the Add button adjacent to the To or From box.
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The Trace To Requirement or the Trace From Requirement dialog box opens.

5 Select a requirement to trace to or trace from in the box and click OK. RequisitePro 
adds this requirement to the To or From box on the Traceability tab.

Creating Traceability Using the Requirement Menu

To create traceability using the RequisitePro > Requirement menu:

1 In a requirements document, place the cursor in the text of the requirement.

2 Click RequisitePro > Requirement > Trace To or RequisitePro > Requirement > Trace 
From. 
The Trace To Requirement(s) dialog box or the Trace From Requirement(s) dialog 
box opens.

3 From the Requirements of type box, select the requirement type with which the 
requirement is associated.

Note:  Click the Find button to open the Find dialog box, which you can use to 
locate a specific tag number and/or requirement name and text.

4 Select the location (document or database) of the requirement from the Located in 
list. If you do not know the location, set the box to All locations.

5 Select a requirement to trace to or trace from in the box and click OK. RequisitePro 
creates a traceability relationship between the two requirements.
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Creating and Deleting Traceability in Views

You can create and delete traceability relationships in an Attribute Matrix, a 
Traceability Matrix, and a Traceability Tree. (For more information about navigating 
in a view, see Working with Views on page 45.)

Creating and Deleting Traceability Relationships in an Attribute Matrix

To create a traceability relationship:

1 Open an Attribute Matrix and select a requirement. Then click Requirement > 
Properties.

The Requirement Properties dialog box opens.

2 Click the Traceability tab.

3 Click the Add button adjacent to the To or From box. 

The Trace To Requirement(s) or the Trace From Requirement(s) dialog box opens.

4 From the Requirements of type list, select the requirement type with which the 
requirement is associated.

Note:  Click the Find button to open the Find dialog box, which you can use to 
locate a specific tag number or requirement name and text.

5 Select the location (document or database) of the requirement from the Located in 
list. If you do not know the location, select All locations.

6 Select a requirement to trace to or trace from in the list and click OK. RequisitePro 
adds this requirement to the To or From box on the Traceability tab.

7 Click OK. 
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To delete a traceability relationship:

1 Select the requirement and click Requirement > Properties.

2 Click the Traceability tab.

3 In the To or From list, select the requirement for the traceability relationship you 
want to remove.

4 Click the Remove button.

A message appears, asking you to confirm the deletion.

5 Click Yes, and then click OK.

Creating and Deleting Traceability in a Traceability Matrix

To create a traceability relationship:

1 Open a Traceability Matrix and select the cell that intersects the two requirements 
for which you want to create a traceability relationship. (Use a multiple select 
action to select more than one cell, a row, or a column.)

2 Establish traceability in one of the following ways:

❑ Click Traceability > Trace To or Traceability > Trace From.

❑ Click Edit > Set Value, select a Traceability Function, and click OK.

❑ Right-click the intersection cell and select Trace To or Trace From.

An arrow appears in the cell, signifying the relationship.

To delete the traceability relationship:

1 Select the arrow you want to remove in a Traceability Matrix cell. (Use a multiple 
select action to select multiple cells.)

2 Do one of the following:

❑ Click Traceability > Delete Trace.

❑ Right-click and select Delete Trace.

❑ Click Edit > Set Value, select Delete Trace from the Traceability Function list, and 
click OK.

❑ Press the DELETE key on the keyboard. 

A dialog box opens asking you to confirm the deletion.

3 Click Yes.

Trace To

Trace
From
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Creating and Deleting Traceability Relationships in the Traceability Tree

Two methods may be used to create traceability relationships in the Traceability Tree:

■ Drag and drop

■ Traceability commands

Drag and Drop

1 Open a Traceability Tree and select the requirements (displayed by their tags) to or 
from which you want to create a traceability relationship. (Use a multiple select 
action to select more than one requirement.)

2 Hold down the right mouse button, dragging up or down the Traceability Tree 
until the cursor is on the requirement with which you want to create a traceability 
relationship to or from the selected requirements, and then release the mouse 
button. A shortcut menu appears.

3 Do one of the following:

❑ Click Move Here to delete the traceability relationship between the selected 
requirements and the requirements to or from which they were traced and to 
create a traceability relationship between the selected requirements and the 
requirement the cursor was on when you released the mouse button.

❑ Click Copy Here to maintain the traceability relationship between the selected 
requirements and the requirements to or from which they were traced and to 
create an additional traceability relationship between the selected requirements 
and the requirement the cursor was on when you released the mouse button.

❑ Click Cancel to cancel the operation.

Tip: To copy or move a traceability relationship, you can also press the CTRL key 
(to copy) or the ALT key (to move) and hold down the left mouse button, dragging 
up or down the Traceability Tree until the cursor is on the desired requirement, 
and then releasing the mouse button. Note that if you use this method to copy a 
traceability relationship, you are not given the option to cancel before the copy 
occurs. You are given the option to cancel when you use this method to move a 
traceability relationship.

Traceability Commands

1 Select the requirements (displayed by their tags) to or from which you want to 
create a traceability relationship. (Use a multiple select action to select more than 
one requirement.)

2 Do one of the following:

❑ Click Traceability > Trace To or Traceability > Trace From.
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❑ Right-click and click Trace To or Trace From from the shortcut menu.
(In a Traceability Tree, the command available depends on the tree type, that is, 
whether the tree is traced into or traced out of a specific requirement type.) 
The Trace To Requirements or Trace From Requirements dialog box opens.

3 Select the requirements in the list. (Use a multiple select action to select more than 
one requirement.)

4 Click OK.

Deleting Traceability in a Traceability Tree

1 Select the requirement tag for the traceability relationship you want to remove. 
(Use a multiple select action to select multiple tags.)

2 Do one of the following:

❑ Click Traceability > Delete Trace.

❑ Right-click and click Delete Trace from the shortcut menu.

A message opens, asking you to confirm the deletion.

3 Click Yes.

The relationship is removed from the tree.

Troubleshooting Failed Multiple Select Actions

When you select more than one relationship or requirement in a view and then 
perform an operation on the multiple selection (such as creating traceability or 
deleting), the operation may fail for one or more requirements or relationships. 

For example, the operation may fail if you do not have rights to perform the operation 
on the requirements or relationships, or if some of the requirements are located in 
documents and the operation is permitted only for requirements in the database.

RequisitePro notifies you of such failures, providing an exception log (separate from 
the error log file) that shows the requirements or relationships for which the operation 
failed, and the reason for the failure.

1 In a view, perform the desired operation on a selected group of requirements or 
relationships.

❑ If the operation is successful, the modifications are shown in the view, and no 
dialog box opens.

❑ If the operation fails for one or more requirements or relationships, or if you 
stop the operation before it is completed by pressing the ESC key, the Exception 
Report dialog box opens, providing the number of requirements or 
relationships for which the operation failed.
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2 Click Details to learn more about the failed operation. The dialog box is expanded, 
showing the reason for the failure.

3 To copy the text in the text box, select the text and press CTRL-C. You can then 
paste the text into a text document.

4 Click Close.

Suspect Relationships

A relationship between requirements becomes questionable or suspect if RequisitePro 
detects that a requirement’s name, text, requirement type, or attribute has been 
modified. All direct relationships to and from it are suspect. 

You can define attributes that, when modified, cause traceability relationships to 
become suspect. You also can manually mark requirement relationships as suspect in 
a view.

Displaying Suspect Traceability Relationships

The suspect state is reflected in the Requirement Properties dialog box as well as in 
views. In the Traceability Tree and Traceability Matrix views, suspect traceability 
relationships are marked as lines through the arrows. In an Attribute Matrix, an (s) 
appears after the requirement tag in the Traced-to or Traced-from column.

On the Traceability tab of the Requirement Properties dialog box, an (s) displayed after 
the requirement tag in the To and From boxes represents a suspect relationship. In a 
view, the suspect relationship is identified by a red diagonal line through the 
traceability arrow. 

The Auto Suspect command monitors a requirement’s change history and displays a 
suspect signal when requirements are changed. Click Tools > Auto Suspect to enable 
or disable automatic checking for changes that affect the traceability or hierarchical 
relationships between requirements in the project.

If Auto Suspect is disabled, RequisitePro does not monitor changes in requirements 
and does not mark relationships as suspect. There are times when this mode is 
appropriate; for example, when you are correcting spelling mistakes in your 
documents, you do not want those corrections to cause your relationships to become 
suspect. 

With Auto Suspect enabled, RequisitePro constantly monitors requirements for 
changes that may affect traceability or hierarchical relationships. If there is a change in 
a requirement, the state of the requirement’s relationships is automatically changed to 
suspect. If you have cross-project traceability active, requirements in external projects 
are also monitored.
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Auto Suspect is enabled by default. If you disable Auto Suspect, you can later activate 
it by clicking Tools > Auto Suspect. It is automatically enabled the next time the project 
is opened. 

Manually Marking and Clearing Suspect Traceability Relationships

You can manually mark a requirement relationship as suspect and clear the suspect 
state. When you clear the suspect state, the relationship is reset to its previous state, 
traced to or traced from. Suspect relationships are set and cleared in a Traceability 
Matrix or Traceability Tree.

To mark or clear one or more suspect relationships:

1 In a Traceability Matrix, select one or more intersection points where a traceability 
link has been created; in a Traceability Tree, select one or more requirements to 
modify. 

2 Do one of the following:

❑ Click Traceability > Mark Suspect or Traceability > Clear Suspect.

❑ Right-click any of the selected cells and click Mark Suspect or Clear Suspect.

❑ Click Edit > Set Value and click Mark Suspect or Clear Suspect. (This command 
is not available in a Traceability Tree.)
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11Importing Requirements 
and Documents
Use the Import Wizard to import requirements from a Microsoft Word document or a 
comma-separated value (CSV) file into a Rational RequisitePro project. 

The import process is recommended for:

■ Importing nonproject documents into the active project.

■ Importing new requirements into an existing project.

■ Updating existing requirement attributes with new information.

The Import Wizard can import requirements and attributes into your project from 
several sources: 

■ Requirement documents created in other RequisitePro projects.

■ Microsoft Word documents created outside of RequisitePro.

■ Any database that supports export of data in CSV format, such as Microsoft SQL 
Server, Oracle, Microsoft Excel, or Microsoft Access.

Preparing to Import

Project Setup

You import an external document or a CSV file into a RequisitePro project and place it 
in the package of your choice. If the project administrator has not already set up a 
project, you should create one before you proceed with the import. (See the chapter 
Creating Projects on page 171.) The project must include at least one requirement type 
and one document type.

Import Logs

RequisitePro creates a log file each time you import a file. The log file is a written 
record of the import process. The log file records these operations: requirement types 
matching, conflict resolutions, attribute mappings, the success or failure of search 
criteria, canceled operations, value errors, and the success or failure of the import. The 
log file is saved in the directory where the project is stored, and it is named 
import#.log, where # is a number representing sequential order of creation. If a log file 
is deleted, the next one created receives the old number to fill in the gap.
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About RequisitePro Format

To import RequisitePro documents from one project to another, you must first save 
the documents in Microsoft Word format. The resulting Word document retains the 
appearance of the original requirements document, including the bookmarks and tags 
that are used in RequisitePro.

When the Save documents in RequisitePro Format check box on the Documents tab of 
the Project Properties dialog box is selected, all documents within the project are 
saved in RequisitePro format. 

Documents saved in RequisitePro format cannot be modified and saved in Word 
outside of RequisitePro. This allows RequisitePro projects to be secure. 

When this option is cleared, documents are saved in Word format. Documents that are 
saved in Word format can be modified in Word outside of RequisitePro and are not 
secure. 

To ensure that the documents are once again brought under RequisitePro control after 
they are imported into a new project, select the Save documents in RequisitePro 
Format check box on the Project Properties dialog box for that project. If security is not 
an issue for a particular project, you can clear the check box.

Converting All the Documents in a Project to Word

If you want to import all the documents from one project into another, they can all be 
converted to Microsoft Word format at once.

To convert all documents to Word at once:

1 Open the project.

2 In the Explorer, select the project and click File > Properties. The Project Properties 
dialog box opens.
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3 On the Documents tab, clear the Save documents in RequisitePro Format check box.

4 Click OK. When the project is closed, all documents are converted to Word format 
but remain in the RequisitePro system. The documents retain their RequisitePro 
extensions.

The newly formatted documents are ready to import into another project. Follow the 
instructions in Importing from Word on page 156.

Converting an Individual Document to Word

To convert a single RequisitePro document to Word format:

1 Open the document you want to convert. 

The Open Project dialog box opens.

2 Click RequisitePro > Document > Save As. The Document Save As dialog box 
opens; it displays the file name with its extension changed to .doc.

3 Click Save. The document is converted from RequisitePro format to Word format.

The file management system automatically saves the new Word document (*.doc) 
into the same folder as the project.

The new Word document is ready to import into another project. Follow the 
instructions in the section Importing from Word on page 156.
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Saving or Removing Bookmarks

Bookmarks in a RequisitePro document are requirement indicators. They appear as 
heavy square brackets, to distinguish them from the square bracket character 
normally found in Microsoft Word. When you create a requirement in a RequisitePro 
document, RequisitePro automatically inserts bookmarks that surround and specify 
the text of the requirement.

When a document is imported, the Import Wizard finds strings of text in the 
document (that is, the wizard parses the document) and imports them into the project 
as requirements. In the import process, you define the criteria that the wizard uses to 
parse the text. The criteria can be keywords, text delimiters, or Word styles.

If RequisitePro detects bookmarks in the document being imported, the Remove 
Bookmarks information box appears. (This information box appears after you have 
responded to the Document Properties dialog box at the beginning of a Word import.)

■ Click Yes to remove bookmarks and include all the document’s text in the parsing 
process.

■ Click No to leave the bookmarks in place. RequisitePro recognizes any bookmarks 
that were previously created in a RequisitePro document and brings that text into 
the new document as new requirements. The bookmarked text is ignored in the 
parsing process.

Importing from Word

Use the Import Wizard to import requirements from a Microsoft Word document into 
a RequisitePro document or to import a Microsoft Word document in its entirety into 
a RequisitePro project.

The document you are importing must be in Word format. If your document was 
created in an application other than Word, refer to the Microsoft Word documentation 
to save the file in Word format.

Turn off Word’s spelling, grammar, and background repagination options (in the 
Options dialog box) before you import a Word document.

Note:  If you are importing a Word document that uses a template other than Word’s 
normal.dot template or an existing RequisitePro outline, you should set up that 
template as a RequisitePro outline before you import the document. RequisitePro 
overwrites any unrecognized formatting with the normal.dot formatting. If you have 
customized the formatting within the Word document, you should save the document 
as a Word template and copy it to the RequisitePro outlines directory. Then create 
document types based on that outline in the project into which you plan to import the 
document. The Word styles are then maintained in the RequisitePro document. See 
Creating Your Own Outlines on page 224 and the Microsoft Word documentation for 
help in creating Word templates.
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Importing Word Documents and Requirements

To use the Import Wizard to import Word documents:

1 Open the project into which you will be importing the Word document.

2 Select the project in the Explorer and click File > Import. The Import Wizard opens, 
and the Select a Source screen opens.

3 Select the Microsoft Word Document option.

4 Type the path and name of the Word document you want to import, or click 
Browse to select a file.
The Browse command opens the Open dialog box. Navigate to the document and 
click Open. (If the document is not found in the list, try changing the file type to All 
files.) The Open dialog box closes and the selected document is loaded into the 
Import Wizard.

5 Click Next to continue. The Select Import Content screen opens. 

6 Designate the import content by selecting the appropriate option (Requirements 
and document, Requirements only, or Document only).

Depending on your choice, you will take one of three paths. The following table 
demonstrates the trade-offs between the different import options. 

Importing Both Requirements and the Document

If you select the Requirements and Document option on the Select Import Content 
screen, the Import Wizard imports the entire document and the requirements created 
by parsing the text. The Word document is imported into a new RequisitePro 
requirements document, and requirements are automatically generated in the new 
document. The Requirements and document option works well if your document 
already contains a well-defined requirement structure. The Import Wizard parses the 
document for requirements on the basis of key words, text delimiters, or Word styles.

Requirements 
and Document

Requirements only Document only

Requirement definition Automatic Automatic Manual

Requirement 
destination

New document Database or
New document or
Existing document

New document
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1 Select the Requirements and Document option on the Select Import Content screen 
and click Next.

The Document Properties dialog box opens.

2 Complete the following information:

❑ Type the document name (any length up to 64 characters).

❑ Accept the default package assignment, or click Browse to select the package in 
which the imported material will be placed.

❑ Type the filename. (RequisitePro assigns an extension according to the 
Document Type selected.)

❑ Select the Show Tags check box if you want to display requirement tags in your 
document.

❑ Select a document type from the list.

❑ Click the Revision tab to enter a change description or create a user-defined 
label (optional). Revision number, date, time, and author are generated by the 
system and cannot be edited here.

3 Click OK to continue.

If the document type you selected contains formatting, you have the option of 
retaining the formatting of the imported document or overwriting it with the 
format of the document type outline that you selected. 

The Requirements to Import screen opens.

4 Select a type for the new requirements in the Requirement Type list.
The wizard provides a default requirement type by matching it to the document 
type you selected earlier. 
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Occasionally, you may want to include requirements of multiple types in a single 
document. For example, any sentence containing the word shall could become a 
product requirement, and any sentence containing the word will could become a 
software requirement. As you create search criteria in the step below, you can use 
the Requirement Type list to select which requirement types you want to apply.

5 Click the Set Defaults button to open the Set Requirement Defaults dialog box, 
where you can enter default attributes, hierarchy, and traceability and type a 
change description for the requirements you import.

6 Mark one of three methods for differentiating or parsing the Word document. The 
Import Wizard finds strings of text in the Word document and imports them into 
the project as requirements.

❑ Keywords. Import Wizard searches the Word document for a specific word, such 
as shall (the default). Type keywords in the Keywords box and click Add to add 
the keywords to the requirements criteria field. Select the Match case check box 
to make the keyword match the case of the text you enter in the Keyword box, or 
select the Use * as wildcard check box if you want to use the * as a wildcard 
character in the Keyword box. Enter the word and click Add.

If you want to create requirements from the selected text for each sentence or 
for each paragraph without parsing based on a keyword, type only an * and 
select the Use * as wildcard check box.

❑ Text delimiters. The Import Wizard searches the Word document for text 
contained within specific text delimiters, such as < >, { }, [ ]. When you have 
entered both the starting and ending delimiters, click Add.

❑ Word styles. The Import Wizard searches the Word document for specified style 
settings, such as “Heading 1” or “Body text” or highlighted text. Select the 
appropriate styles and click Add. 

You do not need to limit the search to one criteria only. You can add keywords, 
text delimiters, and Word styles to the search list by marking each button in 
turn. Use Remove to delete a criteria from the search list.

7 Click Next to continue.
RequisitePro parses the document using the differentiation methods you selected. 
When a requirement is located, the Requirement found dialog box opens.

8 Indicate whether the text found is a valid requirement: Click Yes or No for each. 
Choose Yes to all to automatically accept all requirements found in the document.
Each requirement is added to the Requirements to import box on the Import 
Wizard screen. Each new requirement begins with a pending tag, followed by the 
initial text of the requirement.

When you are satisfied with your selection, click Next to continue.
The Import Wizard displays the final Status screen.
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9 Click Commit to accept the import, or click Cancel to cancel the import in its 
entirety.

Importing Requirements Only

Select Requirements only at the Select Import Content screen if you want to extract 
requirements from a document without importing the rest of the text. If your 
document already contains a well-defined requirement structure such as keywords, 
styles, or delimiters, this option automatically creates your requirements during the 
import process. The Import Wizard parses the document for requirements on the basis 
of key words, text delimiters, or Word styles. It creates requirements from the text it 
finds and leaves the rest of the document behind. This option gives you flexibility in 
the location of the new requirements. You can create requirements in the current 
project (directly in the database), in an existing RequisitePro document, or in a new 
document. 

1 Select the Requirements only option on the Select Import Content screen and click 
Next. The Select a Destination screen appears.

2 Choose one of the following destinations for the imported requirements:

❑ Select Current project database to import the requirements into the database of 
the open project.

❑ Select New RequisitePro document to import the requirements into a new 
document you define. (The Document Properties dialog box opens and 
prompts you for information about the new document before proceeding to the 
next step.)

❑ Select Existing RequisitePro document to choose from a list of existing project 
documents. (If the document you choose is not already open, RequisitePro 
opens it for you.)

3 Click Next to continue. The Requirements to Import screen opens. 

4 Follow Steps 4-9 in the section Importing Both Requirements and the Document on 
page 157.

At Step 7, when the Requirements to import dialog box opens, you have the 
following options:

❑ If you want to read the full text of the requirement, click the View button.

❑ To remove a requirement from the list, select it and click the Remove button. (It 
is saved in an Add requirements box.) Click Add to view the box.
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Importing the Document Only

The Import Wizard imports the entire document into a new RequisitePro document 
without parsing the text. Choose Document only if your requirement structure is not 
defined or if you want to manually create the requirements after importing. No 
requirements are created during the import process. This option gives you the most 
flexibility in creating requirements in documents.

1 Select the Document only option on the Select Import Content screen and click 
Next. The Document Properties dialog box opens. 

2 Type information about the new document. (See Step 2 in the section Importing 
Both Requirements and the Document on page 157.) 

If the document type you selected contains formatting, you have the option of 
retaining the formatting of the imported document or overwriting it with the 
format of the document type outline that you selected. Click Yes to import the 
document text and formatting; click No to import the document text and to apply 
the formatting of the document type you selected.

The Import Wizard displays the final Status screen. 

3 Click Commit to accept the import, or click Cancel to cancel the import in its 
entirety.

Note:  If you are importing a RequisitePro document from one project to another, this 
process includes an extra dialog box. (See Saving or Removing Bookmarks on page 156.)

Importing a CSV File

A CSV file is a data file consisting of fields and records, stored as text, in which the 
fields are separated from each other by commas. If the data in a field contains a 
comma, the field is further surrounded with quotation marks. Using a comma- 
delimited file format allows data to be shared between database systems that use 
different formats.

RequisitePro can import requirements and attributes into your project from any 
database that supports export of data in CSV format, such as SQL Server, Oracle, 
Excel, or Access.

The CSV import process is recommended for:

■ Importing requirements from a non-RequisitePro database into the active project.

■ Updating existing requirement attributes with new information.
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Requirement Numbers

When a new requirement is added to the database, it is assigned a new root 
requirement number. If a requirement has a tag or a number in the external CSV file, 
that number is not preserved. RequisitePro recognizes a hierarchical numbering 
scheme and imports lower-level requirements as children of a higher level 
requirement.

Requirements in a CSV file are renumbered when they are imported into the project 
database.

Preparing a CSV File for the Import Wizard

The CSV file and RequisitePro must be configured properly in order for you to import 
all information:

■ The CSV file must contain a header in RequisitePro format. RequisitePro uses the 
following header format: 
<Tag>, “Requirement text”, “Name”, <Attribute 1>,<Attribute 2>, <Attribute 3>...
The requirement type specified in the <Tag> field determines the default 
requirement type that are assigned during the import process. You can change this 
requirement type assignment in the Import Wizard.

■ All attributes that are included in the CSV file must exist in the corresponding 
RequisitePro requirement type in the current project. If the attributes do not match, 
the default values for the requirement type are inserted during the import process. 
(See Creating and Modifying Requirement Attributes on page 229.)

■ RequisitePro recognizes only the first 32 characters of attribute names, so limit the 
length of attribute names in the CSV file in order to avoid data loss.
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■ All list-type attribute values in the CSV file must exactly match the predefined 
list-type attribute values in the RequisitePro requirement type definition. Edit the 
attribute values in the CSV file or modify the list-type values in your RequisitePro 
project. (See Working with Requirement Attributes and Attribute Values on page 228.)

Note:  Multiple-value list attributes appear in a CSV file in quotes, separated by 
commas (for example, “Chris, Sarah, John”).

■ If the CSV file contains null values (blank spaces) for any list-type requirement 
attributes, those attributes are assigned the default value as defined in the Project 
Properties dialog box. (You open the dialog box by selecting the project in the 
Explorer and clicking File > Properties). To retain a null value, remove the default 
setting in RequisitePro before importing the CSV file. You can reassign the default 
value after the import process is complete. (See Working with Requirement Attributes 
and Attribute Values on page 228.)

■ All requirements in the CSV file are converted to the requirement type specified in 
the import process (in the header <Tag> field, by default). If the CSV file contains 
requirements with different requirement type tags, such as “PR1” and “SR2”, those 
requirements are renumbered with the assigned requirement tag, and some 
hierarchical relationships may be lost.

Defining a Header for a CSV File

When you import a CSV file from another RequisitePro project or a non-RequisitePro 
application, the first row of the CSV file must be a header row with a column heading 
for each column of data. RequisitePro uses the header to match column headings in 
the import document with attributes in the project.

RequisitePro uses the following header format:
<Tag>, “Requirement text”, “Name”, <Attribute 1>,<Attribute 2>, <Attribute 3>...

1 To begin creating a header, type a tag that describes a requirement type, such as 
PR, SR, TST, or any other tag you created in your project, followed by a comma. 
The word tag can be added in the header, but it is not required. For example, SR 
and SR tag are both acceptable.

❑ The tag field in the header is used to set the default Requirement Type used in 
the import. If the tag field does not match any requirement type in the project, 
the Match Requirement Type screen appears, prompting you to choose one 
manually.

❑ The first column in the CSV file must be the tag column. The tag column cannot 
contain any empty cells. If a cell is empty, type in any character to fill it.

❑ If the tag column in the CSV file contains numbers, the numbers are not 
preserved. Imported requirements are added to the project’s requirements list 
and renumbered accordingly. Hierarchical relationships are retained.
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2 Add the literal string Requirement text as the second field of the header, followed 
by a comma. The second column in the CSV file must be the text of the 
requirements.

3 For the remaining fields in the header, type a heading for each column in the CSV 
file, separated by commas. For requirement name, type in Name, followed by a 
comma. The column headings in the header can be anything you like, but you can 
save time by using names (that is, labels) of attributes as they appear in your 
project.

❑ RequisitePro looks at the header in the CSV file and tries to match the 
column heading to an attribute in the project. During the import process you 
are asked to review the attribute matching and make corrections.

❑ The columns under the attribute headings must contain attribute values.

Note:  As an alternate to typing the CSV header, you can copy a header from another 
CSV file. Exporting an existing RequisitePro file to a CSV file creates a tag in the 
correct format. Open an Attribute Matrix of the requirement type you plan to import 
and click File > Export > Export to CSV. Then copy the header from the newly exported 
file and paste it into the file you plan to import. (For more information, see Exporting a 
View as a CSV File on page 167.)

Using the Import Wizard to Import a CSV File

1 Open a project. 

2 Select the project in the Explorer and click File > Import.
The Import Wizard opens, and the Select a Source screen appears.

3 Complete the following information:

❑ Click the CSV button to import requirements from a CSV text file. 

❑ Type the name of the CSV file to import, or click Browse to select a file from the 
list. (The Browse command opens the Open dialog box. Navigate to the 
document and click Open. The Open dialog box closes and the selected 
document is loaded into the Import Wizard.)

4 Click Next to continue. The Match Requirement Types screen appears.

5 The Import Wizard, by default, selects the RequisitePro requirement type that 
matches the requirement types in the CSV file that you are importing. You can 
override the default selection. 

6 Click Next to continue. The Match Attributes screen appears.

7 Click Match Manually to check that RequisitePro mapped the attributes 
correctly. The Match Attributes dialog box opens.
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8 Complete the following information:

❑ If you want to change the mapping, click and hold the mouse while dragging a 
new line from an imported attribute to an existing attribute. You can draw a 
line between any two attributes; they do not have to be on the same horizontal 
line.

❑ If RequisitePro cannot make a match, the imported attribute is listed but has no 
line connecting it to an existing RequisitePro attribute. You can make the match 
manually if you recognize an attribute with the same meaning. Requisite Pro 
ignores any attributes left unconnected. Only matched attributes are imported.

Note:  The following types of attribute matching import blank values (that is, 
you will lose data): a real number entry-type attribute imported into an integer 
entry-type attribute; any entry-type attribute imported into a date, time, real, 
integer, or URL link, if it does not match the format for that attribute; a single 
value list-type attribute imported into a multiple value list-type attribute; and a 
multiple value list-type attribute imported into a single value list-type 
attribute.

❑ To remove a match, select the pair and click Unmatch.

When you are satisfied with the attribute matching, click OK to return to the 
wizard.

9 Click Next to continue. The Select A Resolution dialog box opens.

When attribute values in the imported requirements conflict with the values in 
existing requirements, RequisitePro can resolve the conflict in one of two ways:

❑ By adding the imported requirements as new requirements in your document 
or database
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❑ By overwriting your existing attribute values with those in the imported CSV 
file.

Depending on your choice, you take one of the two paths described in the sections 
that follow. 

Defining New RequisitePro Requirements

The wizard imports the text of the requirements as written in the CSV file. You can 
accept or delete the requirements before importing.

1 In the Select A Resolution dialog box, select Define new RequisitePro requirements 
and click Next. The Requirements to Import screen opens.

2 Review requirements in the list and revise the list as needed:

❑ Click View to read the full text of the requirement. The Edit Imported 
Requirements dialog box opens. Select a requirement from the list. The full text 
of the requirement is displayed in the text pane at the bottom of the dialog box. 
To make changes to any of the list-type attribute values, double-click the cell 
and select a new value from the list box. To make changes to entry-type 
attribute values, select the value and type the new value. Click Accept for 
Import.

❑ Click Remove to remove a selected requirement. (A requirement that was 
removed is not entirely deleted. It is moved into the Add requirements dialog 
box.)

❑ Click Add to review a list of requirements you have removed. If you would like 
to add a requirement back into the list, select it and click OK.

3 Click Next to continue.The Select A Destination screen opens.

4 Choose a destination for the new imported requirements:

❑ Select Current project database to bring the requirements into the database of 
the open project.

❑ Select New RequisitePro document to create a new document (based on the 
document type of your choosing) and bring the requirements into the new 
document. The Document Properties dialog box opens and prompts you to 
record the document name, file name, and document type.

❑ Select Existing RequisitePro document to choose from a list of existing project 
documents. If the file you choose is not open, RequisitePro opens it for you.

5 Click Next to continue. The final Status screen appears.

6 Click Commit to accept the import, or click Cancel to cancel the import in its 
entirety.
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Updating Attributes of Existing Requirements

The new imported requirement attributes overwrite the requirement attributes in the 
open project. The text of the imported requirements is not imported. You can accept or 
delete the requirements before importing them.

1 In the Select A Resolution dialog box, select Update attributes of existing 
requirements and click Next.
The Requirements to Import screen opens. The list box shows tag numbers, 
followed by the comment: [text will not be imported].

2 Review requirements in the list and revise the list as needed:

❑ Click the View button to access the Edit Imported Requirements dialog box. 

❑ Click the Remove button to remove requirements from the list and store them in 
the Add requirements dialog box.

3 Click Next. The Import Wizard displays the final Status screen.

4 Click Commit to accept the import, or click Cancel to cancel the import in its 
entirety.

Exporting Requirements

Requirements are exported from RequisitePro in views.

■ Attribute Matrixes and Traceability Trees can be exported as CSV files or as 
Microsoft Word documents.

■ Traceability Matrixes can be exported as CSV files only.

Setting view properties for requirement text and name affects what is exported. If the 
requirement text and name are not displayed in the view, they are not exported. If you 
have queried the view, only the filtered requirements are exported.

Exporting a View as a CSV File

As described in Importing a CSV File on page 161, a CSV file is a data file consisting of 
fields and records, stored as text, in which the fields are separated from each other by 
commas. If the data in a field contains a comma, the field is further surrounded with 
quotation marks.

Depending on the view (which is exported as an ASCII file), each requirement is 
exported with the requirement tag, followed by the requirement text, requirement 
name, and requirement attributes.

■ From an Attribute Matrix, the tag, name, text, and attributes displayed are 
exported.
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■ From a Traceability Matrix, the tag, name, text, and traceability relationships are 
exported.

■ From a Traceability Tree, the tag, name, and text are exported. Each indented 
(traced) requirement includes commas representing each level in the hierarchy. 
Only the expanded levels in a view are exported.

Setting view properties for requirement text and name affects what is exported. If the 
requirement text and name are not displayed in the view, they are not exported. If you 
have queried the view, only the filtered requirements are exported.

Hierarchical requirements are exported with their full hierarchical tag number. This 
number is used to denote the hierarchical relationships and is used on subsequent 
imports to reconstruct the hierarchy.

To export a view as a CSV file:

1 Open the view you want to export.

2 Click File > Export > Export to CSV. 

3 Type a file name for the exported view (use the .csv extension), and click Save.

The file is exported. You can open the CSV file in:

❑ RequisitePro

❑ Word outside of RequisitePro

❑ Excel

❑ Any other utility that reads this type of file

Exporting a View as a Word Document

To export a view as a Word document:

1 Open an Attribute Matrix or a Traceability Tree that you want to export.

2 Click File > Export > Export to Word.
The Export to Word dialog box opens. 

3 Complete the following information:

❑ Choose a location to save the exported file in the Save in list.

❑ Type a name for the exported file in the File name box.

Do not modify the .doc file selection in the Save as type box.

4 Click Save.

RequisitePro exports the view as a Word document (*.doc), opens Word, and 
displays the exported view as a Word document table.
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RequisitePro exports Attribute Matrixes to Word in table format. The Word table looks 
like an Attribute Matrix, but it shows all of the cells. (In an Attribute Matrix, the cells 
may be truncated, depending on the column size you specify.) 

When a Traceability Tree is exported to a Word document, the view shown in Word 
displays requirements in an outline format. The root requirements are formatted with 
Tree Level 1, the first level branch requirements with Tree Level 2, and so on. 
RequisitePro exports the requirement prefix, followed by the full requirement text, for 
each requirement. The formatting style is based on a template created especially for 
this export (treexprt.dot), which is stored in the bin directory. You can modify this 
template and its styles to suit your needs. If you modify the template, all documents 
using the treexprt.dot template are also modified. See the Microsoft Word 
documentation for more information about modifying templates.
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12Creating Projects
A Rational RequisitePro project provides the framework within which project artifacts 
are organized and managed. Each project includes the following: a database, 
documents, packages, document types, requirements, requirement types, attributes, 
attribute values, discussions, traceability relationships, saved personal and 
projectwide views, revision histories, and security information. Each project resides in 
a separate directory. This storage method simplifies the process of organizing, 
archiving, and managing project files. The project-based system is designed to 
minimize confusion and help you focus on one set of requirements.

Only one project can be open at a time. Numerous requirements documents can 
belong to a project; different users can edit different documents simultaneously. 

Documents are stored separately from the project database, usually in a project 
directory. If you are storing documents in another location, use Universal Naming 
Convention paths whenever possible. 

RequisitePro project administrators create and manage all elements of projects. This 
chapter provides instructions for performing the following tasks:

■ Creating a RequisitePro project.

■ Creating a project template.

■ Creating a RequisitePro project from a baseline.

■ Converting earlier versions of RequisitePro projects to the latest release.

Creating a RequisitePro Project

When you create a project in RequisitePro, you have the choice of basing the project 
on a blank template, on one of three templates included with RequisitePro, or on a 
template created from an existing project. When you create a project based on a 
template, the document and requirement types, attributes, security information, 
package structure, and data of the selected template are copied to the new project. If 
you are using a project template you created with the Include project data option 
selected, the template also copies the following project data from the existing project: 
packages, requirements, documents, views, and history. 
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If you have a baseline of a RequisitePro project, you can use that baseline to create 
new projects in RequisitePro. For example, you may want to base the next release of a 
project on a stable configuration of the previous release. To create a RequisitePro 
project from a baseline, RequisitePro project administrators perform tasks in Rational 
Administrator and Rational ClearCase, implementing the Unified Change 
Management model. Note that the project created from a baseline does not maintain 
any cross-project traceability links from the original baselined project. (See Creating a 
RequisitePro Project from a Baseline on page 178 and Using Rational Unified Change 
Management to Create a Project Baseline on page 244.)

Reviewing RequisitePro Project Template Options

Three project templates are shipped with RequisitePro; they are described in the 
sections that follow. They contain packages, document types, requirement types, and 
requirement attributes, and they provide project structure that you can use to get 
started. After you create a RequisitePro project based on one of these three templates, 
you can set your own security and add your own data to the new project. More 
information about each of these templates is available from Help.

■ Use-Case Template. The Use-Case Template is ideal for implementing the Rational 
Unified Process. This template is designed for RequisitePro projects that use the 
RequisitePro integration with Rational Rose use cases and ClearQuest 
enhancement requests. Use cases are particularly applicable to object-oriented 
software design using the Unified Modeling Language and for applications that 
are user-intensive. 

■ Traditional Template. The Traditional Template is best suited for projects that use 
declarative requirements specifications. This template includes a traditional 
Software Requirements Specification outline rather than use cases.

■ Composite Template. The Composite Template allows you to combine the best 
qualities of both use-case modeling and traditional requirements specification 
techniques. This template provides an outline for a modern software requirements 
specification package applying both traditional document-based techniques and 
use-case modeling. 

These templates provide packages, queries, and documents in accordance with the 
principles of the Rational Unified Process. The templates contain a Glossary 
document and a Requirements Management Plan document, which provide base 
content common to most requirements management needs, including descriptions of 
project artifacts, common terms, and roles. After you create a project based on one of 
these template, you can modify and customize the structure as the project evolves.
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Determining a Database Type

Before creating a RequisitePro project, you decide which database to use to store the 
requirements information. The currently supported databases are Microsoft Access 
and the enterprise databases Oracle and Microsoft SQL Server. Refer to the release 
notes for specific database versions.

Use the following criteria when deciding which back-end database to use with 
RequisitePro: 

■ Use a Microsoft Access database with small work groups (five or fewer concurrent 
users). Use an enterprise database if you anticipate having more than five 
logged-on users at one time. Tests have shown that the performance of Microsoft 
Access decreases after the sixth concurrent user. (These numbers may vary with 
network bandwidth.) 

■ Use an enterprise database if your team is distributed or connected through a wide 
area network (WAN). Enterprise databases provide socket-level access to remote 
network locations, which tend to perform better. 

■ Use an enterprise database if you are managing large numbers of requirements 
(tens of thousands).

RequisitePro creates Access databases using the Access Jet Engine, so you do not need 
to purchase Microsoft Access. 

If you plan to use enterprise databases, RequisitePro provides scripts as a starting 
point for database administrators to create the RequisitePro schemas in a SQL Server 
or an Oracle server. These scripts can be modified. 

If you plan to use Oracle, each client machine requires Oracle client software. For 
more information, see Rational Desktop Products Installation Guide.

Using the Data Transport Wizard, project administrators can move project data 
between Access, Oracle, or SQL Server databases. Data can also be moved between 
two Oracle databases or two SQL Server databases. However, the wizard cannot 
move data between two Access databases.

For more information about configuring SQL Server or Oracle, see Rational Desktop 
Products Installation Guide.

You can access the following instructions from the RequisitePro help directory (<install 
drive>\Program Files\Rational\RequisitePro\help):

■ Configuring an Oracle database (oraclesetup.html)

■ Configuring a SQL Server database (sqlsetup.html)

For RequisitePro projects that use enterprise databases, the project administrator has 
the option to store either one or many RequisitePro projects in the same instance or 
database/schema. Consider the following tips when deciding on the distribution of 
RequisitePro projects across enterprise databases:
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■ Avoid sharing an instance with applications other than RequisitePro. RequisitePro 
projects can potentially share an instance with other applications at your site. The 
primary advantage of sharing the same instance between applications is that it 
reduces the amount of database administration required. However, because 
RequisitePro data must be synchronized with the RequisitePro documents, it is not 
recommended to share the instance with other applications. If it is necessary to 
share an instance, the only way that you can back up your RequisitePro data is 
through logical backups. You cannot perform image (physical) backups in a shared 
instance because whenever the data for one application must be recovered, the 
data for all applications is also recovered. This could create a situation where data 
from an application independent of RequisitePro must be restored, forcing you to 
restore out-of-date RequisitePro data as well.

■ Place all RequisitePro projects in one database/schema. Putting all the 
RequisitePro projects in one database/schema is the most effective way to store 
your projects. Because all the projects are stored together, all projects are backed up 
together. However, if a project must be restored, all projects stored in that 
database/schema must be restored together. A restore operation overwrites all 
work done since the backup was created.

Placing each project in its own individual database/schema maximizes flexibility, 
but it also creates more work for the database administrator. Projects that 
participate in cross-project traceability must be in sync with each other, and 
cross-project traceability links may be lost if you restore one project but not the 
other or if you restore the projects from backups created at different points in time.

Naming Projects

RequisitePro uses two different names to identify projects:

■ Project name. A descriptive name of no more than 64 characters.

■ Project file name. The DOS file name, followed by the .rqs extension. This is the 
name you see if you view your project directory in Windows Explorer or File 
Manager.

When you create a project, RequisitePro automatically determines whether your 
operating system supports long file names. If it does, all file names, including project, 
documents, archives, and directories, use long names.

If you save projects and archives with long file names, you cannot read these names if 
you copy them to a network or drive that does not support long file names and does 
not offer a conversion method.
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Creating a Project

1 Open the Create Project dialog box by doing one of the following:

❑ From RequisitePro, click File > New > Project.

❑ From Rational Administrator, in the Configure Project dialog box, click Create 
in the Requirement Asset area.

2 Select one of the following project templates: 

❑ Select the Blank template, and set each project parameter.

❑ Select one of the default templates provided with RequisitePro.

❑ Select a template you created from an existing project, using the Project 
Template Wizard.

Note:  Templates displayed here are located in the <install drive>\Program 
Files\Rational\ RequisitePro\Templates directory or in the secondary location specified 
in the Options dialog box. When you select a template, a description appears in the 
text box at the bottom of the dialog box. Select the Details check box to toggle the 
display of the template description box. 

If you want to use templates created in an earlier version of RequisitePro, you 
must accept the option to upgrade them. Each upgraded template overwrites the 
old template in your selected templates directory, and a copy of the old template is 
added to the /Copy of Project Templates from v.2001/subdirectory.

3 Click OK. The Rational RequisitePro Project Properties dialog box opens.
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4 Type general information about the new project..

❑ Type a project name (up to 64 characters). 

❑ Type the path for the project directory, or click Browse and select the directory. 
After the project is created, you cannot change this field.

❑ Select a database in which to store the project. You can create projects in 
Microsoft Access, SQL Server, or Oracle. If you select a database other than 
Microsoft Access, click Properties to configure the database. (For more 
information about selecting a database type, see Determining a Database Type on 
page 173.)

❑ Type a description of the project. (This step is optional.) You can modify the 
description after the project is created.

5 Click OK. 

6 Click Yes to create the project directory, and then click Close when the directory 
has been successfully created.

Note:  For more information on configuring an enterprise database, see Rational 
Desktop Products Installation Guide. 

You can access instructions from the RequisitePro help directory (<install 
drive>\Program Files\Rational\RequisitePro\help):

❑ Configuring an Oracle database (oraclesetup.html)

❑ Configuring a SQL Server database (sqlsetup.html)
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What Happens When You Create a Project

When you create a new project, RequisitePro performs the following operations:

■ It creates six project files:

❑ projectname.rqs. A project information text file.

❑ projectname.mdb. The project database (in Microsoft Access). This file is not 
used for enterprise databases.

❑ projectname.ldb. Locks the Microsoft Access database file while you have the 
project open to prevent concurrent project use by multiple users. This file is not 
used for enterprise databases.

❑ structure.xml. Project structure, including requirement types, attributes, and 
document types.

❑ security.xml. Project security definitions, including group names, descriptions, 
and their access rights.

❑ permissions.xml. Project security permissions for individual users, including 
document and requirement access by type.

■ The project appears in the Explorer and is added to your project list. It includes 
several default packages; this project structure is provided by RequisitePro to help 
get you started. 

■ The requirement types and document types you created in the project become 
available for your use.

Creating a Project Template

You can create a template based on an existing RequisitePro project. When you do, the 
new template copies the existing project’s structure and security, including document 
types, requirement types, attributes, and user and group permissions. You also have 
the option to include project data (packages, requirements, documents, views, and 
history). An icon for the new template appears in the Create Project dialog box, and 
you can select it when creating new projects. Note that after you create a project 
template, it cannot be modified.

1 Open the Create Project dialog box by doing one of the following:

❑ From RequisitePro, click File > Project > New.

❑ From Rational Administrator, in the Configure Project dialog box, click the 
Create button in the Requirement Asset area.

2 Double-click the Make New Template icon. 
The Project Template Wizard opens. 
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3 At the Enter Template Information screen, type the following information:

❑ Template Name: Type in a name for the new template.

❑ Template Location: Choose a location for the new template. By default, 
templates are created in the Program Files\Rational\RequisitePro\Templates 
directory. You can set a second location for additional project templates, such as 
those shared on a network or used by a particular project. Click Tools > Options 
to open the Options dialog box and type the full path and subdirectory name 
under Directories in the Project Templates box.

❑ RequisitePro Project: Choose a RequisitePro project on which to base the 
template structure. Click the browse button to navigate to the project.

❑ Include Project Data: Select this check box if you want the template to include 
data from the selected project in addition to the project structure. Note that if 
the project has security enabled, you must log on to the project. If security is 
enabled, only users with project structure permissions can create a template 
that includes project data.

❑ Documentation File (optional): You can select an existing .rtf file that contains 
details about the template. Text from the file specified here appears in the 
Details text box on the Create Project dialog box when the template is selected. 
Click the browse button to navigate to the file.

❑ Icon File: Select an icon for the template that will appear in the Create Project 
dialog box. (You can modify this icon at any time by replacing the .ico file in the 
template’s folder. Be sure to rename the new icon file with the exact name used 
by the original file.)

4 Click Next to continue.

5 Check the information at the Confirm screen and click Finish to create the 
template. The new template appears in the Create Project dialog box.

Creating a RequisitePro Project from a Baseline

If you have a baseline of a RequisitePro project, you can use that baseline to create 
new projects in RequisitePro. For example, you may want to base the next release of a 
project on a stable configuration of the previous release. For more information, see 
Creating a Project Baseline with Unified Change Management on page 208 and Using 
Rational Unified Change Management to Create a Project Baseline on page 244.
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RequisitePro project administrators perform the following tasks in Rational 
Administrator and Rational ClearCase, implementing the Unified Change 
Management (UCM) model.

Note:  A RequisitePro project created from a baseline does not maintain the 
cross-project traceability links, discussions information, and associations with 
Rational ClearQuest and Rational Rose from the original baselined project.

A UCM project and a Rational Administrator project must be created before a 
RequisitePro project can be created from a baseline. (Refer to ClearCase and Rational 
Administrator Help for more information.) 

1 Create a UCM project.

2 Add a UCM component to the project that already contains a versioned 
RequisitePro project at a recommended baseline.

3 Set the recommended baseline for the new UCM project. (By default the baseline 
selected above will be selected.)

4 Create an integration view for the new UCM project.

To create a Rational Administrator project: 

1 Click Tools > Rational Administrator to open Rational Administrator.

2 Click File > New Project. The Rational Administrator New Project Wizard opens.

3 Type requested information in the wizard, select UCM enabled, and select 
Requirement Assets to be versioned.
When you complete the wizard, the Configure Project dialog box opens.

4 Click the Select button to choose Requirement Assets.

5 Browse to the UCM view and select the .rqs file for the baselined RequisitePro 
project.

6 Click OK in the Configure Project dialog box.
The new RequisitePro project contains the data and structure from the selected 
baselined project.

The new project has the same name as the baselined project. You can change the 
name in the Rational RequisitePro Project Properties dialog box. You also have the 
option to remove the old baselined project from the RequisitePro list of projects in 
the Open Project dialog box. 

Upgrading RequisitePro Projects to the Latest Version

If you try to open a project that was created in RequisitePro version 4.0 or later, it must 
be updated to the current version. The Database Upgrade Wizard allows RequisitePro 
project administrators to upgrade an existing database structure and project data 
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structure to the current RequisitePro release. (If the project was created in a version of 
RequisitePro earlier than 4.0, you must first upgrade the project to RequisitePro 4.0 
before using the Database Upgrade Wizard. Contact Customer Support for 
information.)

Caution: If the RequisitePro project is associated with a Rational repository (rather 
than the more current structure of a Rational project, which can be created in Version 
2001.03.00 or later), upgrading the project may cause irreparable harm to the Rational 
repository that you use with other Rational products. To protect your Rational 
repository, first upgrade your software and datastores to Version 2001A, and then 
upgrade the software and datastores to the current version. For more information, see 
Rational Suite Upgrade Guide (available on the Rational Solutions for Windows Online 
Documentation CD).

In the current version of RequisitePro, project data is organized into packages. When 
you upgrade older projects (which did not include packages) to the current release, 
RequisitePro organizes the requirement artifacts as follows:

■ It creates a package for each requirements document; the package includes all 
requirements that are located in that document.

■ It creates a package for each requirement type; the package includes all 
requirements of that type that are not located in documents. If a requirement type 
does not include any requirements or includes only requirements that are located 
in documents, RequisitePro does not create a package for that requirement type. 

■ It creates an Attribute Matrix package, a Traceability Matrix package, and a 
Traceability Tree package. Each view package contains all views of that type in the 
project. 

When you upgrade older projects to the current version of RequisitePro, tables and 
properties of the database are modified, so you cannot revert to the state before the 
upgrade. We recommend that you back up the database before you start the upgrade. 

If the project you are upgrading contains cross-project traceability links, you must 
upgrade the external projects as well. After you have completed the upgrade, you 
may move project artifacts into packages other than the default ones created by 
RequisitePro. For more information about moving artifacts in packages, see Working 
with Packages on page 218.

The upgrade process upgrades all RequisitePro projects in an enterprise database. 
Make sure all RequisitePro users have closed all projects in the database before 
continuing with the upgrade. If the database includes projects that are UCM-enabled 
and others that are not, RequisitePro flags the UCM projects, which forces you to 
perform a Check-in-all procedure prior to opening them. After you have completed 
this procedure, RequisitePro removes the flag, and you can open the project.

Follow the instructions at each screen in the Database Upgrade Wizard, and click the 
Help button to access Help for the upgrade process.
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13Working with Project 
Security
Because Rational RequisitePro allows multiple users to access the same project 
documents and database simultaneously, project security is crucial. Security prevents 
system use, potential harm, or data loss from unauthorized user access to a project, 
document, or requirement. By default, security is disabled; this allows unlimited user 
access to the project.

We recommend that you enable security for all RequisitePro projects. Doing so 
ensures that all changes to the project are associated with the proper username of the 
individual who made the change, thereby ensuring that you have a complete audit 
trail for all changes. 

Project security is crucial for projects with multiple users. In RequisitePro, users are 
given specific permissions that determine the amount or kind of access they have to 
projects. When security is enabled, users belong to groups. RequisitePro 
administrators assign group-specific permissions. 

Any RequisitePro user can create a new project. When you create a new project, you 
are considered the project administrator and are automatically placed in the 
Administrators group. After you create the project, you (and other project 
administrators) can define other users and groups. 

If security has not been enabled for the project, any user can open the RequisitePro 
project. When you open an unsecured project for the first time, RequisitePro allows 
you to log on with your Windows logon name, as a user name of your choice, or as the 
user name specified in the Options dialog box (click Tools > Options) Default Project 
Logon box. The user name is added to the Administrators group list for the project.

If security has been enabled, the Project Logon dialog box opens each time you or 
another user opens the project. The project administrator who set security can assign 
passwords for other users. When security is enabled, this condition applies to the 
project regardless of how you open it (for example, from RequisitePro, from 
RequisiteWeb, from programmatic access using the RequisitePro Extensibility 
Interface, or from another Rational tool). 
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Setting Security

To enable or disable security for a project:

1 Click File > Project Administration > Security.

The Project Security dialog box opens.
.

2 Select the Enable security for this project check box to set security; clear the box if 
you want to disable security.

3 Select groups and users by following the steps in the next section.

4 Click OK.

Creating and Modifying Groups and Users

RequisitePro provides three default security groups: Deleted Users, Administrators, and 
Users. Remember that all security permissions are assigned at the group level only 
and that a user can be in only one group. 

■ Deleted Users. This group contains users who have been deleted from other groups, 
have no permissions, and cannot log on to RequisitePro. This group is maintained 
by RequisitePro for project history.

■ Administrators. Members of this group have full permissions to work in a project. 
They can change a project structure, create and modify data, and set and maintain 
security permissions. You can add and remove users from this group, but you 
cannot modify Administrators group permissions.

■ Users. By default, members of this group have full permissions to create and 
modify all documents, requirements, attributes, and traceability. You can modify 
Users group permissions to limit the type of permissions granted for each 
document type and requirement type.

You can add and delete groups, add users to groups, move a user to a different group, 
and edit a user’s information, such as user name, password, and e-mail address.
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Creating a New Security Group

To create a new security group:

1 Click File > Project Administration > Security.
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 Click Add below the Groups box.
The Group Permissions dialog box opens.

3 In the Name box, type a name for the group.

4 Set the group permissions and click OK. (For more information on setting and 
editing group permissions, see Assigning Permissions to a Security Group on 
page 186.)

5 Click OK to save and close the Project Security dialog box.

Deleting a Security Group

You can delete a group if you are a RequisitePro administrator or a member of a group 
with project security permissions and if all users have been removed from the group.

1 Click File > Project Administration > Security.

The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)
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2 In the Groups box, select the group to delete.

3 Click Delete. RequisitePro prompts you to confirm the deletion.

4 Click Yes. 

5 Click OK in the Project Security dialog box.

Adding a User to a Security Group

To add a user to a group:

1 Click File > Project Administration > Security.
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 In the Users of Group list, select the group to add the user to, and click Add next to 
the Users of Group list. The Add User dialog box opens.

3 In the Username box, type the user’s name. It should not exceed 20 alphanumeric 
characters, and it is not case sensitive. 

4 In the New Password box, type the user’s password.

Note:  This box and the Verify box below are encrypted, displaying a symbol for 
each of the 14 maximum possible characters. Passwords are case-sensitive; for 
example, Mycomputer, MYCOMPUTER, and mycomputer are treated as different 
passwords.

5 In the Verify box, type the password again.

6 In the E-Mail Address box, type the user’s e-mail address. This e-mail address is 
necessary for participating in RequisitePro discussions via e-mail. (For more 
information, see Responding to Discussions on page 65.)

7 Click OK. RequisitePro adds the new user to the group.

8 Click OK to save and close the Project Security dialog box.
184 Chapter 13 - Working with Project Security



Editing User Information

To edit user information:

1 Click File > Project Administration > Security. 
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 In the Groups list, select the security group to which the user belongs.

3 In the Users of Group list, select the user name.

4 Click Edit next to the Users of Group list.
The Edit User dialog box opens.

5 Edit the user name, password, or e-mail address.

6 Click OK.

7 Click OK to save and close the Project Security dialog box.

Deleting a User from a Security Group

When you delete a user from a security group, RequisitePro moves the user to the 
<Deleted Users> group. All records associated with the user are maintained. If you 
reinstate a user with the same name as a deleted user, RequisitePro prompts you to 
confirm whether it is the same person before reinstating the user.

To delete a user:

1 Click File > Project Administration > Security.
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 In the Groups list, select the group containing the user.

3 Select the user in the Users of Group list.

4 Click Delete adjacent to the Users of Groups list. A dialog box opens, prompting 
you to confirm deletion of the user. 

5 Click Yes to move the user from the current group to the <Deleted Users> group.

6 Click OK to save your changes and close the Project Security dialog box.
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Moving a User to Another Security Group 

To move a user to another security group:

1 Click File > Project Administration > Security.
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 In the Groups list, select the group containing the user.

3 Select the user in the Users of Group list.

4 Click Move. The Move User dialog box opens.

5 Select the group to move the user to.

6 Click OK.

7 Click OK to save your changes and close the Project Security dialog box.

Assigning Permissions to a Security Group

Each security group has its own set of permissions, and all members of the group 
share the same permissions. The following list shows all possible permissions that can 
be assigned to a group:

■ Project permissions: access the project, manage project structure, manage project 
security

■ Document type permissions: read, update, create, delete documents

■ Requirement type permissions: read, update, create, delete requirements

■ Attribute permissions: read, update attributes

■ Attribute value permissions: read, update attribute values

■ Traceability permissions: set and clear suspect relationships, create and delete 
traceability relationships
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Members of the Administrators group and groups with project security permissions 
can create group accounts; assign permissions to the groups; and add, move, edit, and 
delete users in groups.

To assign permissions:

1 Click File > Project Administration > Security.
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 In the Groups list, select the group. 

3 Click Edit below the Groups list.
The Group Permissions dialog box opens.

The Administrators group has full permissions. You cannot edit this group’s 
permissions, but you can add and remove users from the Administrators group.

4 To assign project structure modification permissions to the group, select the Can 
manage project structure check box. Groups with these permissions have complete 
access to all tabs and information in the Project Properties dialog box for this 
project. To remove a group’s permissions, clear the check box.

5 To assign project security permissions to the group, select the Can manage project 
security check box. Groups with these permissions can change group and user 
permissions for this project. To remove a group’s permissions, clear the check box.

6 Assign document, requirement, traceability, attribute, and attribute value 
permissions, as described in the following sections.

7 Click OK.

Assigning Document Type Permissions

To assign document type permissions to a group:

1 Click File > Project Administration > Security.
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 In the Groups list, select the group.

3 Click Edit below the Groups list. The Group Permissions dialog box opens.

4 In the Document Types list, select the document type for which you want to assign 
permissions. 
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5 Click Edit Permissions below the Document Types list.
The Document Type Permissions dialog box opens.

 

6 Assign document permissions by selecting the corresponding check box. Groups 
can have read, update, create, and delete permissions. To remove a permission 
assigned to a group, clear the check box that corresponds to the permission. If you 
do not want the group to have any permissions for this document type, clear all 
selections. 

❑ Read permissions: Members of the group can view documents of this type. If 
Read is the only permission selected, members of the group cannot modify 
documents of this type. 

❑ Update permissions: Members of the group can modify documents of this type. 
If Update is selected, Read is also automatically selected.

❑ Create permissions: Members of the group can create documents of this type. If 
Create is selected, Read and Update are also automatically selected.

❑ Delete permissions: Members of the group can delete documents of this type. If 
Delete is selected, Read, Update, and Create are also automatically selected.

7 Click OK to save the modifications and to close each dialog box.

Assigning Requirement Type and Traceability Permissions

To assign requirement type and traceability permissions to a group:

1 Click File > Project Administration > Security.
The Project Security dialog box opens. (Make sure the Enable security for this 
project check box is selected.)

2 In the Groups list, select the group.

3 Click Edit below the Groups list. The Group Permissions dialog box opens.

4 In the Requirement Types list, click the requirement type for which you want to 
assign permissions and click Edit Permissions. 
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The Requirement Type Permissions dialog box opens.

5 Assign requirement type permissions by selecting the corresponding check box. 
Groups can have read, update, create, and delete permissions for a requirement 
type. To remove one of the other permissions assigned to a group, clear the check 
box that corresponds to the permission.

❑ Read permissions: Members of the group can view all requirements of this 
type. If Read is the only permission selected, members of the group cannot 
modify requirements of this type. This permission is selected by default, and 
the box cannot be cleared. 

❑ Update permissions: Members of the group can modify all requirements of this 
type but not create or delete them.

❑ Create permissions: Members of the group can create requirements of this type. 
If Create is selected, Update is also automatically selected.

❑ Delete permissions: Members of the group can delete requirements of this type. 
If Delete is selected, Update and Create are also automatically selected.

6 To add permissions for traceability relationships to and from requirements of the 
selected type, select check boxes for the following:

❑ Read permissions: Members of the group can view all traceability relationships 
between requirements of this type. This permission is selected by default, and 
the box cannot be cleared. 

❑ Mark Suspect permissions: Members of the group can set suspect traceability 
relationships to and from requirements of this type. If Clear Suspect is selected, 
Mark Suspect is automatically marked.
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❑ Clear Suspect permissions: Members of the group can clear suspect traceability 
relationships to and from requirements of this type.

❑ Create permissions: Members of the group can create traceability relationships 
to and from requirements of this type. If Delete is selected, Create permissions is 
automatically selected.

❑ Delete permissions: Members of the group can delete traceability relationships 
to and from requirements of this type.

7 To assign attribute permissions to the security group, select a requirement attribute 
and click Edit Permissions. For more information about attribute permissions, see 
the following section.

8 Click OK in each dialog box to save the modifications.

Assigning Attribute Permissions

To assign permissions for a requirement name, requirement text, or requirement 
attributes:

1 Select the requirement type, as described in the previous section. 

2 In the Requirement Type Permissions dialog box, select the attribute, name, or text 
for which you want to set permissions.

3 Click Edit Permissions. 

The Attribute Permissions dialog box opens. 

❑ For list-type attributes, the dialog box pictured below opens.
s.

The Read permission check box is automatically selected and cannot be cleared. To 
allow users to modify attributes of the selected type, select the Update check box 
and refer to the section that follows for more information on assigning permissions 
to modify specific attribute values.
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❑ For entry-type attributes, name, or text, the following dialog box opens:
 

The Read permission check box is automatically selected and cannot be cleared.

4 Select the Update check box to give members of the group permissions to modify 
the attributes. Clear the box to allow default Read permissions only.

5 Click OK.

6 Click OK in the Requirement Type Permissions and Group Permissions dialog 
boxes.

Assigning Permissions for Attribute Values

For list-type attributes, you can assign permissions for specific attribute values:

1 Select an attribute, as described in Steps 1-3 in Assigning Attribute Permissions on 
page 190.

2 Select the Update check box in the Attribute Permissions dialog box for a list-type 
attribute. 

The attribute values in the list box and the Edit Permissions button are enabled.

3 Select and attribute value in the list and click Edit Permissions. 

The Attribute Value Permissions dialog box opens.
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4 Select the Update check box to give members of the group permissions to modify 
the attribute value. (The Read permission check box is automatically selected and 
cannot be cleared.)

5 Click OK.

6 Repeat Steps 3 and 4 to set or remove group permissions for other attribute values.

7 Click OK in the Attribute Permissions, Requirement Type Permissions, and Group 
Permissions dialog boxes.
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14Managing Projects
This chapter provides instructions for the following tasks for managing Rational 
RequisitePro projects:

■ Renumbering requirements

■ Printing project summaries and reports

■ Using Requirement Metrics

■ Archiving projects

■ Reading and recording a project’s revision information

■ Creating a project baseline with Unified Change Management

■ Removing documents and requirements from a project database

■ Moving projects

■ Copying projects

■ Moving a project between databases

The final section presents a list of file types used in RequisitePro.

Renumbering Requirements

If the project is open in exclusive mode, you can renumber all requirements of one or 
more specified types in the requirements document and database. This feature is 
useful to eliminate the “holes” in a numbering scheme that result when you delete or 
move requirements.

For more information, see Rebuilding Requirement Tags in a Document on page 130.

Printing Project Summaries and Reports

Printing a Project Summary in RequisitePro

1 Click File > Project Administration > Print Summary. 

A standard Windows Print dialog box opens.

2 Select the options you want and print.
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Using Rational SoDA with RequisitePro

RequisitePro is integrated with SoDA, Rational’s software documentation automation 
tool.

Using SoDA and RequisitePro, you can:

■ Modify and generate SoDA reports and documents from an open RequisitePro 
project. 

■ Create a report that consolidates RequisitePro requirements information and Rose 
modeling information. 

■ Create a use-case report that includes all use case requirements and Rose use-case 
diagrams.

Before you begin the following procedure, make sure that the current version of SoDA 
for Word is installed and that a RequisitePro project is open.

1 Click Tools > Generate SoDA Report. The SoDA dialog box opens, showing a list of 
templates that can be used with RequisitePro.

2 Select a template from the list and click OK. SoDA for Word opens. The SoDA menu 
is active and the selected template is open.

3 Use the template to create a SoDA report from the open RequisitePro project. 

Refer to SoDA Help for more information about generating SoDA reports.

Note:  Do not begin generating a second SoDA report while the progress indicator 
is active.

Using Requirement Metrics

Requirement Metrics provides project administrators and analysts with the capability 
of reporting statistics concerning a RequisitePro project’s attributes, relationships, 
requirements, and revisions. These statistics are displayed in Microsoft Excel.

You can use Requirement Metrics to retrieve information that is vital for evaluating 
the following:

■ the progress of a project;

■ priorities, workloads, and deadlines;

■ the addition of new requirements;

■ changing or unstable requirements; and

■ approved and incorporated features.
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You begin by creating one or more filters. A filter creates criteria for retrieving 
requirement information. For example, you would use an Attribute Count Filter to 
determine how many requirements in the project have a priority with the value 
“High.” You then combine one or more filters to produce a query. A query combines 
the criteria from multiple filters to analyze requirements. The filters that compose a 
query are joined with the AND statement. You then combine one or more queries to 
produce a report. 

Two types of reports are available in Requirement Metrics:

■ A static report, which uses static filters and shows results about the project at the 
present time. 

■ A trend analysis report, which uses time-sensitive filters that analyze changes in 
requirement text, attributes, traceability, and hierarchical relationships. Trend analysis 
reports require that you specify an increment for displaying revisions.

Your report can address the following questions by using the corresponding sample 
queries:

Question Query

How many requirements were created since 
the last release?

■ Requirements Creation filter
■ Options/Time Period > 10/15/99

How many High Priority requirements do I 
have?

■ Attribute Value filter
■ Priority = High

How many requirements went from Low 
Priority to High Priority in the last month?

■ Attribute Value Change filter
■ Priority Before = Low
■ Priority After = High
■ Options/Time Period/Last Month

How many requirements contain text that 
has changed more than three times since the 
last iteration?

■ Requirement Text Change filter
■ Number of changes > 3
■ Options/Time Period > 10/15/99

What is the level of detail associated with my 
requirements?

■ Children filter: > 0 children

How stable is the organization of my 
requirements?

■ Parent Change filter
■ Before = Select All
■ After = Select All

Are my associations with other requirements 
stable?

■ Traceability Change filter: Select All
■ Relationship = Trace To and From
■ Action = Added or Removed
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The Requirement Metrics main window is the primary user interface for the 
application. This window lets you select a requirement type for your report, choose 
filters and filter criteria, and build queries and add them to your report. As you add 
filters to your queries, you limit the requirements in your report to those requirements 
that match your filter criteria.

Start Requirement Metrics by clicking Tools > Metrics or the Metrics button. For more 
information, see the help included with Requirement Metrics.

If your project needs for metrics go beyond the feature offered by RequisitePro, 
consider using Rational ProjectConsole, which provides software metrics across the 
lifecycle and lets you report on requirements as well as other project lifecycle artifacts.

Main Window Query Pane

The Query pane in the Requirement Metrics main window provides features for 
selecting multiple filters in order to build a single query. The query concatenates the 
filters when it is added to the Report pane at the bottom half of the main window.

The Query pane contains the following fields and controls:

Choose a Requirement View: Presents names of predefined views within angle 
brackets for selection. (Users may also select a saved view from the RequisitePro 
project.)

Note:  Saved views for external projects are not supported in the list of saved views.

Types: Indicates each filter type included in your query. All queries include the Base 
filter, which returns all requirements of the selected requirement type. 

Criteria: Displays the criteria you have selected for each filter in the query.

Add Filter: Presents the Add Filter dialog box, which allows you select another filter to 
add to the query.

Delete Filter: Removes the selected filter from the query.

Add to Report: Combines all the filters you've selected into a single query and adds it 
to the Report's query list.

Main Window Report Pane

The Report pane in the Requirement Metrics main window provides features for 
managing the queries that you have added to your report.

The Report pane contains the following fields and controls:

Names: Displays the label for each query in the report. To change the label text, click 
the query once, click once more, and then type a label.

Criteria: Summarizes the filter criteria contained in each filter.
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Move Up: Moves the selected query up in the list of queries. The order of the queries in 
the Report pane determines the order in which they appear in the report.

Move Down: Moves the selected query down in the list of queries.

Delete Query: Removes the selected query from the report.

Create: Runs the report with the displayed query criteria.

Creating a Filter and Query

1 Select a view from the Choose a Requirement View list. This can be a view that you 
have previously created, or it can be a predefined view that includes all the 
requirements of a requirement type. The view defines the requirement type that the 
filter uses.

2 Click the Add Filter button. The Add Filter dialog box opens, and a list of possible 
filters is displayed. 

3 Select a filter and click OK. 

Tip: You can also select a filter by double-clicking it.

An appropriate dialog box for the filter opens. 

4 Make all your selections and click OK to add the filter to the filter list. 

5 Add more filters to the list until your query is complete.

Adding a Query to a Report

When you add the query to the report, Requirement Metrics builds all filters in the 
filter list into a single query and adds that query to the report's list of queries. Filters 
are joined in the query with the “AND” logical operator.

1 Click the Add to Report button. The query is added to the report's list of queries 
with a default label. 

2 To change this label, select the query in the list, then single-click the query again. 
The cursor changes into edit mode over the label. 

3 Type your new label and press ENTER to save the changes.

4 To rearrange the order of the queries in the query list, select a query and click Move 
Up or Move Down. The order to the queries determines the order in which they appear 
in the report.

5 Click the menu command Options > Output Requirements Detail to display the 
requirement tags, text, and attribute values (when applicable) in the report.

A separate worksheet is created in Microsoft Excel for each query in the report.
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Setting the Time Controls

When you add any time-sensitive filters to the report, the Options > Time Period 
command is made available. You can use this feature to filter for a relative time 
period, such as “last week,” or you can select a specific beginning and/or ending date 
for the report.

In addition, if the report consists of only time-sensitive queries, you can show 
revisions in intervals of days, weeks, months, quarters, or years. This option lets you 
create a Trend Analysis report.

To set the time controls:

1 Click the Time Controls button. The Report Time Period dialog box opens.

2 Do one of the following:

❑ Click Relative Time Period and select a relative time period from the list.

❑ Click Specific Time Period, and select an operator (such as “>”) and a date from 
the lists. When you select the “Between” operator, you must select a beginning 
and ending date.

3 For reports with only time-sensitive filters, select the Trend Intervals check box and 
then select an interval from the list. 

Note:  If you select “Any Time” as your relative time period, the check box is not 
enabled because there is no end date associated with this selection. 

4 Select the Show Cumulative Counts check box to show the cumulative number of 
requirements for each time interval.

Running the Report

After you have added queries to the report, you are ready to run it.

Do one of the following:

■ Click the Create button.

■ Click File > Create Report.

The program opens Microsoft Excel and presents the requested statistics in a new 
workbook. The results are also presented in a default graph. To reformat the graph, 
use Microsoft Excel’s Graph Wizard. 

Saving the Report

After you have added queries to your report, you can save it for repeated use. You can 
open and edit saved reports in Requirement Metrics or run them from the Windows 
command line.
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1 To save the current report, click File > Save Report As. 

The Save As dialog box opens.

2 Browse to a directory and type a file name for the report. Click Save.

Requirement Metrics saves the report, including all queries and settings, to a *.rqm 
file.

Opening and Editing a Saved Report

1 To open a saved report, click File > Open Report.

The Open dialog box opens.

2 Browse to a directory, select a saved report (with a .rqm extension), and click Open.

Note:  When you edit saved reports and change any of the requirement types or 
attributes, the saved report may become obsolete. An error message is displayed if 
you try to run an obsolete report. 

Running from the Command Line

You can run Requirement Metrics from the command line outside of RequisitePro. 
Click the Start button on the taskbar and choose the Run command.

The command line syntax is: 

rqmetricsgui.exe ReportFile [user:=Username] [pass:=Password] [save:=Filename]

If any element of an argument contains any spaces, then you must enclose the entire 
argument in double quotes.

Include the full path of the rqmetricsgui.exe. Typically this is C:\Program 
Files\Rational\RequisitePro\bin\rqmetricsgui.exe.

The ReportFile argument should include the path and file name of the .rqm file you 
want to run. 

The argument user:=Username is required for all projects that have project security 
set. If this project has security established, you must use a valid user name for the 
project. If this is not a secured project, you must first successfully log into the project. 
(This adds your user name to the project.) You can then use the same user name to run 
Requirement Metrics from the command line. (Your current user name is specified in 
the RequisitePro Options dialog box.)

The optional argument pass:=Password specifies the password needed for the user 
name. If either of these arguments is incorrect, you cannot access the project or run the 
report you requested.
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The optional argument save:=Filename specifies a name for an output file in Excel 
format. This is useful for uninterrupted batch processing. 

Note:  If an Excel file with the file name already exists, Requirement Metrics 
overwrites the file.

Archiving Projects

In RequisitePro, archiving is the process of duplicating the database, documents, and 
all related files in a project for the purpose of restoring at a later time. You can archive 
projects by using one of the following commands: 

■ The RequisitePro Archive command.

■ The Rational ClearCase archive command.

Note:  As an alternative to using these archiving procedures, you can create a baseline 
if you are implementing the UCM model with ClearCase. See Creating a Project 
Baseline with Unified Change Management on page 208.

Neither archive method automatically creates a copy of your database if you are using 
an enterprise database. Creating a baseline creates a copy for these databases. For 
more information, see Archiving Projects that Use an Enterprise Database on page 204 
and Creating a Project Baseline with Unified Change Management on page 208.

You can use a variety of configuration management tools, such as PVCS Version 
Manager or Microsoft Visual SourceSafe, to archive your RequisitePro projects. If your 
project uses a Microsoft Access database, first use the RequisitePro Archive command 
to create archive files; then use your configuration management tool to archive these 
files. Be sure to include all project documents in your archive.

Projects that participate in cross-project traceability should be archived or backed up 
at the same point in time to maintain consistent traceability links between them. To 
maintain cross-project traceability, open the archived project or projects, disconnect 
the external project or projects, and for each external project, browse to the location of 
the recent archive. This preserves the cross-project traceability that existed at the time 
the projects were archived.

Archiving Projects with the Archive Command

You can use the Archive command in RequisitePro to make a copy of your entire 
RequisitePro project in a separate directory.

Note:  Projects that participate in cross-project traceability should be archived or 
backed up at the same point in time to maintain consistent traceability links between 
them. 
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1 Click File > Project Administration > Archive > RequisitePro Archive. 

The Archive Project dialog box opens.

2 Select the directory where you want to store the backup copy. Click Browse to open 
the Browse for Folder dialog box. Navigate to a directory, select a folder, and click OK.
(To add a new subdirectory to an existing directory path, click at the end of the 
Directory field and type a forward slash (/) and a new subdirectory name.)

3 (Optional) Type a new revision number for the project in the Revision # box. The 
number must be greater than or equal to the current revision number (in the form 
xxxx.yyyy). This number appears in the Revision tab of the Project Properties dialog 
box.

4 To apply the revision number to the requirement documents, select the Propagate 
to all documents (offline documents excluded) check box.

Note:  If security is enabled, you must have project structure permission to 
propagate the revision number. You must also have the project open exclusively.

5 If you want to assign a version number for this archived project, type a name for 
the archived version in the Version Label box and a description for it in the Change 
Description box. This label appears in the Revision tab of the Project Properties dialog 
box. A label can be used to easily identify this particular version of the project at a 
later time. 

The RequisitePro Archive command performs the following:

■ It creates a directory (beginning with “bak”) to hold the archive files. 

■ It copies the RequisitePro project files (.rqs and .rql) to the directory.

■ It copies all project documents to the directory.

■ It updates the version of the original project (if you have security permissions to 
modify the project structure).
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For Microsoft Access-based projects, the RequisitePro Archive command also performs 
the following:

■ It copies the project database file (.mdb) to the directory.

■ It updates the .mdb file in the archive directory with the location of the project 
documents in the archive.

For enterprise database projects, the .mdb file is not copied or updated. A solution 
provided in RequisitePro would remove configuration flexibility. Therefore, the 
database administrator must create a file containing a logical export of the database. 
This file must be placed in the archive directory created by RequisitePro. See “Tips for 
archiving and backing up enterprise databases” in Help.

Note:  To retrieve a project archived with the Archive command, add the archived 
project to your project list (click File > Open Project, and in the dialog box, click the 
Add button) and then open the project in RequisitePro.

Archiving Projects with Rational ClearCase

Before you archive your RequisitePro projects in ClearCase, you must have a 
ClearCase view and VOB. Projects that participate in cross-project traceability should 
be archived or backed up at the same point in time to maintain consistent traceability 
links between them. For more information, see Archiving Projects on page 200.

When you archive projects that use an Access database, ClearCase includes all project 
files, documents, and database content in the archive. When you archive projects that 
use an enterprise database, ClearCase includes only project files and requirements 
documents in the archive. You must use your database utilities to archive the 
enterprise database.

To set the default ClearCase view in RequisitePro:

1 Click Tools > Options.

2 In the Options dialog box, type the target VOB location (drive, viewname, 
vobname, directory) in the ClearCase View box. This step defines the view to which 
the RequisitePro database and documents are copied during the archive functions.

3 Click OK.

To archive your RequisitePro project using ClearCase:

1 Click File > Project Administration > Archive > Rational ClearCase. 

The Archive with ClearCase dialog box opens.

2 Select the directory (ClearCase view) where you want the backup copy stored. 
Click Browse to open the Browse for Folder dialog box. Navigate to a directory, 
select a folder, and click OK. 
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3 (Optional) Type a new revision number for the project in the Revision # box. This 
number appears in the Revision tab of the Project Properties dialog box. Note that 
this is not the same as a revision number in ClearCase.

4 To apply the revision number to the requirement documents, select the Propagate 
to all documents (offline documents excluded) check box.

Note:  If security is enabled, you must have project structure permission to 
propagate the revision number. You must also have the project open exclusively.

5 If you want to assign a version number for this archived project, enter a name for 
the archived version in the Version Label box and a description for it in the Change 
Description box. This label appears in the Revision tab of the Project Properties 
dialog box. A label can be used to easily identify this particular version of the 
project at a later time from within RequisitePro. Note that this is not the same as a 
label in ClearCase.

The Rational ClearCase command (click File > Project Administration > Archive) 
performs the following:

■ It retrieves the path of the view that was stored at the time of the last archive. If not 
present, RequisitePro looks for the default view path specified in the Options dialog 
box. (Click Tools > Options.) If this is the first time the project is archived, RequisitePro 
creates the archive directory in your view and makes it a ClearCase element. It 
remains checked out so the appropriate files can be copied.

■ It copies the RequisitePro project files (.rqs and .rql) to the directory.

■ It copies all project documents to the directory.

■ It updates the RequisitePro Revision # of the original project (if you have security 
permissions to modify the project structure).

■ It checks in all files and the directory.

For Microsoft Access-based projects, the Rational ClearCase Archive command 
(invoked when you click Archive > Rational ClearCase) also performs the following:

■ It copies the project database file (.mdb) to the directory 

■ It updates the .mdb file in the archive directory with the location of the project 
documents in the ClearCase view.

For enterprise database projects, the .mdb file is not copied or updated. A solution 
provided in RequisitePro would remove configuration flexibility. Therefore, the 
database administrator must create a file containing a logical export of the database. 
This file should be placed in the archive directory created by RequisitePro and then 
checked into ClearCase. 
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Archiving Projects that Use an Enterprise Database

RequisitePro supports the use of the enterprise databases Oracle and SQL Server for 
RequisitePro projects. Several considerations should be kept in mind when you 
archive a RequisitePro project that uses one of these databases. 

The following information guides RequisitePro project administrators, database 
administrators (DBAs), and system administrators in archiving or backing up 
RequisitePro projects that use enterprise databases so that no data is lost and archives 
of your projects can be created quickly and dependably.

As an alternative to archiving, you can create a baseline if you are implementing the 
UCM model with ClearCase. Creating a baseline simplifies the archiving process for 
projects that use enterprise databases. See Creating a Project Baseline with Unified 
Change Management on page 208.

You can archive your project in one of two ways in RequisitePro: through the 
RequisitePro Archive command or through ClearCase. 

Using the RequisitePro Archive command results in the following:

■ It creates a directory (beginning with “bak”) to hold the archive files. 

■ It copies the RequisitePro project files (.rqs and .rql) to the directory.

■ It copies all project documents to the directory.

The database administrator must create a file containing a logical export of the 
database. This file should be placed in the archive directory created by RequisitePro.

Using the ClearCase archive feature results in the following:

■ It reverts to the last archive location.

■ It copies the RequisitePro project files (.rqs and .rql) to the directory.

■ It copies all project documents to the directory.

The database administrator must create a file containing a logical export of the 
database. This file should be placed in the archive directory created by RequisitePro 
and then checked into ClearCase.

Note:  Before it becomes necessary to restore a RequisitePro project, it is a good idea to 
verify the success of the archive. It would be unfortunate to realize that the restoration 
process is not working correctly when you must restore project data. To what extent 
you restore an archive depends on your circumstances.

Logical Backups

A logical backup (import/export) of a database exports the database objects 
independent of the physical location of those objects. In other words, a logical backup 
exports the data stored in a table regardless of the location of the table (such as 
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tablespace or datafile). The Oracle Export Utility can create a file that contains all the 
objects in a particular schema. The file can then be imported to the same schema to 
recover from a failure or to a different instance or schema for archiving purposes.

Similarly, SQL Server can export all the database objects to another SQL Server. Unlike 
the Oracle Export Utility, the SQL Server Import/Export Utility cannot export all the 
database objects to a file. However, all the objects residing in a SQL Server database 
can be stored in a backup file giving a similar result to the Oracle Export Utility. To 
create a backup file in this manner, use the Enterprise Manager for SQL Server and 
select the database that contains RequisitePro data in the left pane and select the 
Backup database option in the right pane. On the SQL Server Backup dialog box, 
make sure to select “Database - Complete” for this type of backup. The resulting 
Backup file will contain all of the objects stored in the RequisitePro database.

The advantages of logical backups include the following:

■ Making a logical backup is highly recommended before you upgrade to a new 
version of Oracle, SQL Server, or RequisitePro. A logical backup provides the latest 
data in the event of a failure. Oracle may require a logical backup if the newer 
database format is not compatible with the older database format. For SQL Server, we 
recommend creating a physical backup (Database - Complete) through the SQL 
Server Enterprise Manager.

■ In Oracle, logical backups can be used to detect block corruptions. If a corrupt 
block is detected during an export, the export will fail. The corrupt blocks must be 
repaired before a successful export can be obtained.

■ Logical backups can be used to provide a test or development copy of your 
RequisitePro projects. The test or development copy can be used to test a new release 
of RequisitePro or to train new users.

■ In Oracle, logical backups can be used to in conjunction with COALESCE to 
defragment extents.

■ Logical backups can be used to significantly alter your database structure such as 
moving the RequisitePro Oracle schema from one Oracle tablespace to another or 
using a different Oracle schema name. It can also be used to move RequisitePro data 
to a different database in SQL Server.

■ Logical backups are very useful when changing database servers.

The biggest disadvantage of logical backups is the amount of time they take to 
perform. For large RequisitePro schemas or databases, it may take several hours to 
complete a logical backup. For high-availability databases that are used around the 
clock in different parts of the world, the time it takes to perform a logical backup can 
have a serious implication on the database usability. For Oracle, consider using a 
combination of incremental, cumulative, and complete logical backups to provide 
flexibility to your users. SQL Server users might not be as affected by a logical backup 
as Oracle users are.
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Sessions should be restricted during a logical backup. The following sequence of 
commands will allow you to put your database in restricted mode during a logical 
backup. For Oracle, the following example demonstrates how to put the database in 
restricted mode during an export.

SVRMGR> shutdown immediate

SVRMGR> startup restrict open

exp userid=reqpro/reqpro...

SVRMGR> alter system disable restricted session;

SQL Server databases can be put in single user mode by right-clicking the database 
and selecting Properties. When the RequisitePro Database Properties dialog box 
opens, select Single user under Access on the Options tab.

Image Backups

Image backups (physical backups) are an alternative to logical backups for backing up 
a RequisitePro databases. Unlike logical backups, image backups make physical 
copies of the database files. Image backups are by nature more tightly coupled to the 
database and its current operating state. For example, Oracle keeps track of the 
current log sequence file number that is being used, and a backup must contain all the 
redo log files necessary to build the database back to the correct log sequence file 
number. Image backups should not be used if the RequisitePro projects share an 
instance with data from any other application.

Offline image backup (or cold backup) refers to making physical copies of the 
database files while the database is shut down. Offline image backups can be used 
with RequisitePro data provided that a backup of the RequisitePro project files and 
documents is created whenever an offline image backup is created.

Online image backup (or hot backup) refers to making a copy of the database files 
(offline image backup) and then making copies of the redo logs for Oracle or the 
transaction logs for SQL Server. For Oracle, the database must be running in 
ARCHIVELOG mode to create online image backups. For SQL Server, an 
administrative task should be established to backup the transaction log for the SQL 
Server database that contains RequisitePro data. Verify that no one is using 
RequisitePro while you are performing an online image backup to ensure that the 
data stored in the database matches the project documents.
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Restoring Projects from an Archive

To restore a RequisitePro project from an archive, follow these steps:

1 Create a directory to hold the project you are restoring.

2 Do one of the following:

❑ If the RequisitePro Archive command was used, copy all the files from the 
archive directory to the new directory.

❑ If the ClearCase Archive command was used to archive the project, copy all the 
files from the ClearCase view into the new directory. 

3 If the project uses a Microsoft Access database, you can start using the project from 
this new location. If the project uses an enterprise database, you must do the 
following:

❑ Restore the file containing the logical backup through the appropriate import 
utility (for example, SQL Server Enterprise Manager). 

❑ Depending on how you are restoring the project, you may need to create 
database objects such as a database, tablespaces, a user, or a role.

❑ If you are using Oracle, make sure the alias points to the correct database.

❑ Modifications to the project files (.rqs and .rql) may be required as a result of 
changes in server name, database name, and user name. These changes can be 
performed by clicking File > Open Project, adding the project, and with the 
project selected, clicking the Properties button.

❑ When you open the project, you must update references to documents that 
were not located in the original project directory (before the project was 
archived) to reflect the new location. You can update the references by opening 
the document in RequisitePro; when the Locate document dialog box opens, 
use the Browse button to open the document in the new directory.

Note:  Changes made to an archived project cannot be merged into any other project.

Viewing and Entering Revision Information About the Project

Use the Revision tab in the Project Properties dialog box to view information about the 
most recent revision of the project. You have the option of typing information about 
the most recent revision, and you can access the project’s revision history.

Open the Project Properties dialog box by selecting the project in the Explorer and 
clicking File > Properties. Click the Revision tab.
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■ The Revision box contains the revision number. This read-only text box cannot be 
edited unless the project is archived using RequisitePro’s Archive command (or 
checked into ClearCase). You can only override the revision number when the project 
is archived. The new revision number that you use must be greater than the existing 
number and must be expressed in an N.m format (for example, 2.5).

■ The Label box contains a descriptive name for the revision (up to 20 characters). 
This field is optional, and it is available only if changes have been made to project 
properties.

■ The Date, Time, and Author boxes are read-only; they display the date and time the 
project was modified and the name of the user who made the last change.

■ The Change Description box displays changes made to the project. You can type 
information into the field if changes have been made to project properties in other 
tabs of the dialog box. Otherwise, the field is read-only.

■ The History button opens a dialog box that displays the change history of the 
project.

Creating a Project Baseline with Unified Change Management

If your RequisitePro project is using the Unified Change Management (UCM) model, 
you can create baselines of the project. RequisitePro project administrators can create 
baselines of RequisitePro projects by performing tasks in ClearCase and Rational 
Administrator, implementing the UCM model. For more information about UCM, see 
Using Rational Unified Change Management to Create a Project Baseline on page 244.

For information about archiving projects that do not use the UCM model, see 
Archiving Projects with Rational ClearCase on page 202.

When you create a project from a baseline, the newly created project does not 
maintain the cross-project traceability links, discussions information, and associations 
with Rational ClearQuest, Rational Rose, and Rational XDE from the original 
baselined project. See Creating a RequisitePro Project from a Baseline on page 178.

You can create a baseline of a RequisitePro project when the following conditions are 
met:

■ The RequisitePro project must be associated with a UCM-enabled Rational project 
in Rational Administrator.

■ The RequisitePro project must be versioned.

■ All users must have closed the Requisite Pro project.
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To check in the RequisitePro project:

1 Click Tools > Rational Administrator to open Rational Administrator.

2 Select the Rational Administrator project, right-click, and click Configure. 

3 In the Configure Project dialog box, in the Requirements Assets area, click the 
Check In All button.

4 Confirm your selection at the messages that follow, and type an activity to describe 
the baseline in the Check in all dialog box.

5 After the check in operation is completed, close the Configure Project dialog box.

The time required for checking in a project is proportional to the number of 
requirement types, documents, and saved views in the project.

To create the baseline:

1 Open the Rational ClearCase Project Explorer. (From Rational Administrator, you 
can click Tools > Rational ClearCase Project Explorer.)

2 Right-click the integration stream for the associated UCM project and click Make 
Baseline.

3 Type or edit the Baseline Title, select a View Context, and click OK.

Note:  You can ignore the message that the integration view contains elements that 
are currently checked out. It is not necessary to check in all files if you are creating 
a baseline of a RequisitePro project. 

Removing Documents and Requirements from a Project 
Database

When a document and its requirements are removed from the project database, the 
requirement formatting and the requirements are deleted (although the text remains), 
and the document can only be referenced outside RequisitePro as a Word document. 
To remove documents and requirements from the database, you must have exclusive 
access to the project. (For more information about the exclusive option, see Working 
with Projects and Project Packages on page 30.)

Before you delete a document, be aware that some of the requirements in the 
document may have been assigned to other packages. If you delete the document, all 
those requirements are deleted. We suggest that you create an Attribute Matrix view 
for the requirement type of the requirements in that document. Check the Location 
attribute to determine the document in which those requirements are located, and 
check the Package attribute to determine whether they are associated with other 
packages.
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To remove documents and requirements:

1 Select the document in the Explorer and click Edit > Delete. 

A confirmation dialog box opens.

2 Click Yes. RequisitePro removes the requirements formatting from the document 
and removes the requirements from the project database. All text remains in the 
document, and you can open the document in RequisitePro as a Microsoft Word 
document (but not as a requirements document) or in Word outside of 
RequisitePro. 

Moving Projects

Do not attempt to copy or move a RequisitePro project by copying the project 
directory from one location to another. Internal unique identifiers may cause conflicts 
if the project uses cross-project traceability.

To move project files to a new location:

1 Remove the project from your list of projects. Click File > Open Project, select the 
project name in the Select a Project box, and click Remove.

2 Copy the project files (.rqs, .rql) to your new location using Windows Explorer. If 
the project was created in Microsoft Access, copy the Access database file (.mdb) to 
your new location. 

3 Add the project in its new location to the list of projects. Click File > Open Project, 
and in the Open Project dialog box, click Add at the Select a Project box.

4 Rename the original project directory and all directories that contain project 
documents (so that you have a backup in case anything goes wrong). You can delete 
this directory when you are comfortable that the move was successful. If you want to 
save a copy of the original directory, see the next section for instructions. 
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5 Open your project in RequisitePro. The first time you open a project document that 
is not stored in the project directory, you are prompted to locate the document. Select 
it from the new location.

Note:  If you have a document that is not stored in the project directory and you try to 
open it, you may be prompted to find it and to select it from the new location. If you 
are using the project with integrations, you must reconfigure those integrations after 
you move the project. For more information, see Rational Suite Administrator’s Guide.

If you are moving the project data to a new database, use the Data Transport Wizard. 
If you want to move an entire SQL Server of Oracle database (including all 
RequisitePro projects in the database) to another server, use the native tools provided 
with the database system. Consult your database administrator.

Copying Projects

You can copy the structure or data (or both) of a RequisitePro project, but do not 
attempt to copy the project directory from one location to another. Internal unique 
identifiers may cause conflicts if the project uses cross-project traceability. If you are 
using an enterprise database for your RequisitePro project, copying the project 
directory does not copy the project database. Both copies of the project continue to 
point to the same database instance, and conflicts between document and 
requirement updates will result.

You can copy the structure and data of a RequisitePro project in one of the following 
ways:

■ If you are using an Access database for your RequisitePro project, you can move a 
project to another location and keep a backup copy. (See the previous section.) 

■ For any project, you can create a template based on the project and create a project 
based on that template. By default, document types, requirement types, attributes, 
user and group permissions, and views are copied to the template and to the new 
project. You can also include project data. (See Creating a RequisitePro Project on 
page 171.)

■ If you are implementing the UCM model with ClearCase, you can create a project 
from a baseline. All the data from the baseline project is copied to the new project. (See 
Creating a RequisitePro Project from a Baseline on page 178.) 

You can also split a project and keep some requirements in one project and others in a 
new project. Before you begin, we strongly recommend that you archive your original 
project. Keep in mind that you cannot merge the two copies of the project back 
together into one project.
Copying Projects 211



1 Click File > Project Administration > Archive to make a physical copy (B) of your 
RequisitePro project (A).

2 Open your copy (B) in RequisitePro and change the project name under the 
General tab of the Project Properties dialog box.

3 Delete requirements in each project until you have one copy of each requirement in 
each project. (For more information, see Deleting Requirements on page 132.)

Moving a Project Between Databases

The Data Transport Wizard can move RequisitePro projects between Microsoft 
Access, Oracle, and SQL Server. It can also move a SQL Server or Oracle project to 
another database of the same type, but it cannot move data between two Access 
databases. The wizard moves one project at a time, and it does not move projects that 
are connected by cross-project traceability.

The Data Transport Wizard requires that the following conditions be met prior to 
performing the database type conversion. The wizard displays messages to alert you 
if any conditions are not met.

■ The project must be saved in the current version of RequisitePro. 

■ You must have administrator permissions for the project.

■ You must have log on and write permissions for the target database.

■ Your database administrator must supply you with the user name and password, a 
server name, and a schema name in order to access an enterprise database.

Note:  Make sure all RequisitePro users have closed the project before you continue. It 
is strongly recommended that you archive or back up both the source and the 
destination database and related documents before continuing with the move. For 
more information on configuring an enterprise database, see Rational Desktop Products 
Installation Guide.

You can access the following documents in your RequisitePro Help directory (<install 
drive>\Program Files\Rational\RequisitePro\help):

■ Configuring an Oracle database (oraclesetup.html)

■ Configuring a SQL Server database (sqlsetup.html)
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Starting the Data Transport Wizard

It is strongly recommended that you archive or back up both the source and the 
destination database and related documents before continuing with the database type 
conversion. (See Archiving Projects on page 200.)

Note:  Prior to running the wizard, you must open RequisitePro once. Then make sure 
to close any open RequisitePro project before starting the wizard.

Open the Data Transport Wizard in Windows Explorer. The executable, 
rqdatatransportwiz.exe, is located in the Rational\RequisitePro\bin\directory.

The Data Transport Wizard introduction screen opens. Each screen of the wizard 
includes a Help button. To view step-by-step instructions about using the screen, click 
the Help button in that screen.

Moving Project Data to an Oracle Database

To move a RequisitePro project to an Oracle database, follow the step below. If you 
want to move the entire database (including all RequisitePro projects in the database) 
to another server, use the native tools provided with Oracle. Consult your database 
administrator.

We recommend that you archive your project before you move it to another database. 
Click File > Project Administration > Archive > RequisitePro Archive. The destination 
database must contain a RequisitePro schema. See “Configuring an Oracle database” 
in Help.

1 Open the Data Transport Wizard in Windows Explorer (see the preceding section).

2 Click Next at the first Data Transport Wizard screen, and then click Browse to select 
the project you want to convert.

3 At the project/database screen, click Choose to open the Database Properties 
dialog box. Select Oracle as the type and click the Configuration button. The Microsoft 
ODBC for Oracle Setup dialog box opens. Do not modify the default entries in the 
Data Source Name and Description boxes. 

4 In the User Name box, type the user name you use to log on to the Oracle database. 
This should be supplied to you by your Oracle database administrator.

5 In the Server box, type the alias you created when configuring your machine (for 
example, OracleDB).

6 Click OK to return to the Data Transport Wizard project/database screen.

7 Click the Account Info button to enter database account information and follow the 
remaining screens. For Schema, type the name of the database schema that has been 
established by your database administrator for storing projects. (All projects can use 
the same database schema.) Then view the Conversion Report, and exit the wizard.
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Moving Project Data to a SQL Server Database

If you want to move data from a RequisitePro project to a SQL Server database, follow 
the steps below. If you want to move the entire database (including all RequisitePro 
projects in the database) to another server, use the native tools provided with SQL 
Server. Consult your database administrator.

Note: We recommend that you archive your project before you move it to another 
database. Click File > Project Administration > Archive > RequisitePro Archive. The 
destination database must contain a RequisitePro schema. Install the SQL Server 
Setup under the Custom/Full installation process. Then refer to the topic 
“Configuring a SQL Server database” in Help.

1 Open the Data Transport Wizard in Windows Explorer. The executable, 
rqdatatransportwiz.exe, is located in the Rational\RequisitePro\bin\ directory. 

2 Click Next at the first Data Transport Wizard screen, and then click Browse to select 
the project you want to convert.

3 At the project/database screen, click Choose to open the Database Properties 
dialog box. Select SQL Server as the type and click the Configuration button. 

4 In the Create a New Data Source to SQL Server dialog box, do not modify the 
Name or Description boxes. In the Server box, type the name of the SQL Server, 
supplied by your database administrator. Click Next.

5 On the next screen, select the option With SQL Server authentication using a login ID 
and password entered by the user. (RequisitePro does not support Windows NT 
authentication.) Be sure the check box Connect to SQL Server to obtain default settings 
for the additional configuration options is selected. Type a login ID and password 
supplied by your database administrator, such as ReqPro and reqpro. Click Next.

6 Select the check box Change the default database to and select a database name 
supplied by your database administrator, such as “RequisitePro.” Click Next.

7 Click Next to accept the default language, character, and regional settings. The use 
of log files, shown on the screen that follows, is optional. Do not select the check box 
Change the language of SQL Server system messages to . . . The selection of this check 
box prevents users from opening the project after its initial creation. Click Finish.

8 In the ODBC Microsoft SQL Server Setup dialog box, click the Test Data Source 
button. Click OK in the SQL Server ODBC Data Source Test dialog box. Then click OK 
to return to the Data Transport Wizard project/database screen.

9 Click Account Info to enter database account information, and follow the 
remaining screens. For Schema, type the user name of the owner of the database 
tables. Then view the Conversion Report, and exit the wizard.
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RequisitePro File Types

RequisitePro uses the following file extensions: 

File 
extension

Definition

.rqs A RequisitePro project information file.

.mdb A RequisitePro project database (using Microsoft Access). This file is not 
used for enterprise databases

.rql A RequisitePro project file that specifies the ODBC and database account 
information.

.xml RequisitePro project files that contain structure, security, and permission 
information.

.doc A Microsoft Word document file.

.bak A backup document file.

.dot A Microsoft Word template.

.def An outline’s definition file.

.txt

.mnu

Plain text menu files used to add commands to the toolbar.

.hlp A Windows application help file.
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15Working with Project 
Information
Project administrators can modify information about a Rational RequisitePro project, 
including:

■ General project information

■ Packages

■ General document information

■ Document types

■ Requirement types

■ Requirement attributes

■ Attribute values

■ Cross-project traceability

You can also view the database and generate reports.

Working with General Project Information

You can create and modify a RequisitePro project’s general information through the 
General tab in the Project Properties dialog box. 

1 In the Explorer, select the project and click File > Properties.

The Project Properties dialog box opens.

2 Click the General tab.

3 In the Name box, type or modify the project name (up to 64 characters). 

If you change the name of a project, rename the .rqs and .rql files (and .mdb files 
for Microsoft Access projects) and the folder that the project is stored in to reflect 
the new name of the project. You must then add the newly named project on the 
Open Project dialog box for all client machines that access the project.

4 In the Prefix box, type or modify the project prefix. This identifier is used to 
identify requirements and requirement types in this project when it is referenced 
as an external project for cross-project traceability. 
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The prefix can be up to 8 characters, it is stored in uppercase letters, and it can be 
changed at any time.

5 In the Directory box, specify a path for RequisitePro to store the project. For new 
projects, type the project directory, or click Browse. After the project is created, you 
cannot change this box.

You can later relocate the project by moving the project directory to another 
location in the file system. To access the project in its new location, users must add 
it to their project lists.

6 The Database box displays the type of database selected for the project. You have 
the option to create projects in Microsoft Access, SQL Server, or Oracle. To modify 
the database type, you must run the Data Transport Wizard. You can click 
Properties to open the Database Properties dialog box, where you can view and 
modify information about the database.

7 In the Description box, type a description (or modify the existing description) of 
the project’s purpose and content. (This step is optional.)

8 Click OK.

Working with Packages

Project information is organized in folders within packages, which are units of related 
artifacts. The project’s root package is displayed as the project node, and the contents 
of each root package are displayed beneath it. By organizing your requirements 
information in packages, your team members can quickly find the information they 
need. You can create, rename, move, and delete packages as needed. Use packages to 
organize your project artifacts in a way that meets the needs of your team members 
and is compatible with team processes. For example, you can group documents, 
requirements, and views in packages by feature, component, or team. You can move 
artifacts between packages by dragging and dropping them or changing the Package 
setting in the artifact’s Properties dialog box.

Consider using a consistent package structure across all your team's projects by 
creating a project template from an existing RequisitePro project.

Packages do not have security permissions, but the elements within them (for 
example, requirements, documents, and views) do. 

Packages may be nested, which means that a package can contain other packages. 
Queries on requirements in a particular package return requirements that match the 
query in that package; the query results do not include requirements that are stored in 
nested packages within the package you selected.
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To create a package:

1 In the Explorer, select the project name or an existing package, and click File > New 
> Package.

The Packages Properties dialog box opens.

2 In the Name box, type the name under which the package will be listed in the 
Explorer. The name cannot include commas, colors, nonprintable characters, or 
carriage returns, and it must be unique relative to other packages at its location.

3 In the Description box, type a brief description of the package.

4 Click OK.

The new package appears in the Explorer, nested within the project or package you 
selected in Step 1.

To rename a package:

1 In the Explorer, select the package you want to rename and click File > Properties.

The Package Properties dialog box opens.

2 In the Name box, edit the package name. The name cannot be the same as the name 
of another package at the current location.

3 Click OK.

The renamed package is displayed in the Explorer, alphabetized by the new name.

You can move artifacts (requirements, views, documents, and other packages) 
between packages in one of two ways:

■ You can drag and drop the artifact from one package to another in the Explorer. 
(Make sure that the package name is unique among the other packages where it is 
located.)

■ You can select the artifact in the Explorer, click File > Properties, and modify the 
package assignment in the Properties dialog box.

To delete a package, you must first make sure that it is empty. (An empty package 
does not have indented artifacts listed below the package name.)

1 In the Explorer, expand the view of the package so that all the artifacts it contains 
are listed.

2 Move or delete all the artifacts in the package.

You can drag the artifacts to other packages, or you can delete the artifacts by 
selecting an item in the package and clicking Edit > Delete. This removes the 
artifact from the project permanently.
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3 Select the package and click Edit > Delete.

RequisitePro deletes the package from the Explorer and from the project database.

Working with Document Information

You can modify general document and document type information through the 
Project Properties dialog box.

Viewing and Modifying Document Information

1 Select the project in the Explorer and click File > Properties.

The Project Properties dialog box opens.

2 Click the Documents tab.

3 Do the following:

❑ Select or clear the Save documents in RequisitePro Format check box. If this 
check box is selected, documents are secure; that means they cannot be opened 
in Word outside of RequisitePro. If this check box is cleared, documents are not 
secure; they are saved in Word format and can be opened in Word outside of 
RequisitePro.

❑ Select or clear the Enable Extended Editing of documents check box. If this check 
box is selected, the requirement text can be modified and saved in a view in 
RequisiteWeb or in a Rational Rose use case (Integrated Use Case 
Management); the check box must be selected in order for you to modify 
requirement text located in documents. 

4 Click OK.

Working with Document Types

You can create document types and modify existing document types. If you no longer 
need a document type, you can delete it.

A document type is a template that is applied to your RequisitePro documents. It 
serves as an outline for each RequisitePro document you create of that type. The 
document type defines the document’s file extension, such as .prd; all documents of 
the same document type share the same file extension. The document type identifies a 
default requirement type; each new requirement you create in the document will be 
based on the default requirement type unless you indicate otherwise. The document 
type also identifies an outline (or template) for the document, which controls its page 
layout, heading and paragraph styles, and a default font.
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When you create or modify your project, you determine the document types to use in 
the project. When you create a project based on a template, default document types 
are included, but you can add or modify the document types at any time. Each 
document in your project must be associated with a document type. More than one 
document can be associated with the same document type.

When you create a document, you associate it with a document type that you have 
already defined in your project. The new document inherits the style and functional 
attributes associated with the document type. This makes all documents of the same 
type consistent.

To help you define a common format for your document types, you can choose 
outlines included with RequisitePro to associate with new or existing document 
types.

Creating and Modifying Document Types

1 In the Explorer, select the project and click File > Properties. 

The Project Properties dialog box opens. 

2 Click the Document Types tab.
.

3 Do one of the following:

❑ To add a new document type, click Add.

❑ To modify an existing document type, select the requirement type in the list, 
and then click Edit. 
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The Document Type dialog box opens.
.

4 In the Name box, type or modify a unique name for the document type (up to 64 
characters).

5 (Optional) In the Description box, type or modify a description.

6 In the File Extension box, type or modify a file extension. Type a three-character 
text string, or, if your operating system supports long file names, a longer 
extension. (File extensions can contain a maximum of 20 characters in 
RequisitePro.) The file extension is applied to all documents associated with the 
document type.

7 Select a requirement type in the Default Requirement Type list. 

8 Select an outline from the list. If you use the default selection None, documents are 
associated with the normal.dot Microsoft Word template. See Using RequisitePro 
Document Outlines on page 223 for more information on available outlines.

Note:  If you select a new outline, the new outline applies to new documents only. 
Existing documents are not affected by the change. 

9 Click OK. The new or modified document type appears in the list box.

10 Click OK in the Project Properties dialog box.

Note:  You can edit the .dot files associated with your document types to include 
your company name and other information specific to your organization. You can 
enter this information in the Microsoft Word File > Properties dialog box. Then in 
the document itself, right-click the Company-Name box, and click Update Field. 
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Deleting Document Types

If no documents of a particular document type exist in a project, you can delete the 
document type from the list. If security is enabled, you must have project structure 
permission to delete a document type.

1 In the Explorer, select the project and click File > Properties. 

The Project Properties dialog box opens.

2 Click the Document Types tab. 

3 In the Document Type list, select the document type you want to delete.

4 Click Delete.

5 Click OK.

Using RequisitePro Document Outlines

Outlines are document templates that are useful for maintaining consistency across 
RequisitePro documents of the same type. Outlines can help you quickly create 
user-needs documents, specifications, and test plans. 

Every new document in RequisitePro includes default formatting information. New 
documents are based on document types, which include a default file extension, a 
default requirement type, and an associated outline. You can assign outlines to a 
document type in the Project Properties dialog box (Document Types tab).

RequisitePro includes the following outlines that can be used when creating 
document types in your project:

■ Software Requirements Outline

■ Modern Software Requirements Specification

■ Functional Test Case Specification

RequisitePro includes the following Rational Unified Process (RUP) outlines for 
requirements management:

■ RUP Requirements Management Plan

■ RUP Glossary

■ RUP Vision Document

■ RUP Stakeholder Requests

■ RUP Use Case Specification

■ RUP Use Case Software Requirements Specification

■ RUP Test Plan
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RequisitePro includes these additional outlines for business modeling:

■ RUP Business Glossary

■ RUP Business Rules

■ RUP Business Vision Document

■ RUP Business Use Case Specification

■ RUP Business Use Case Realization Specification

■ RUP Supplementary Business Specification

The project templates provided with RequisitePro include specific document outlines 
that you can use. See Reviewing RequisitePro Project Template Options on page 172.

Note:  If you have installed Rational TestManager, we recommend that you develop all 
test artifacts in that tool. Test-related outlines are included with RequisitePro for users 
who do not have TestManager. 

You can edit the .dot files associated with your document types to include your 
company name and other information specific to your organization. You can type the 
company name or other information in the Microsoft Word File > Properties dialog 
box. In the document, right-click the Company-Name box and click Update Field.

Creating Your Own Outlines

You can create your own outlines to use for RequisitePro documents.

1 Start Microsoft Word outside of RequisitePro.

2 Create a new Word template. (See the Word documentation for more information 
about creating templates.)

3 Copy the new template to the <install drive>\Program 
Files\Rational\RequisitePro\outlines directory. 

Note:  Microsoft Word templates that apply to RequisitePro documents are 
automatically stored as document outlines in the RequisitePro outlines 
subdirectory. You can set a second location for additional outlines, such as those 
shared on a network or used by a particular project. Click Tools > Options to open 
the Options dialog box and type the full path and subdirectory name under 
Directories in the Document Outlines text box. RequisitePro accesses your local 
outlines directory first, so to avoid confusion, you can do one of the following: 
move all your document outlines to the shared location, or make sure that the local 
outlines directory contains outlines with different file names than the ones stored 
on the shared location.

4 In a text editor, create a new text file containing the following three lines of 
information, separated by carriage returns (<CR>):
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❑ The outline name, up to 64 characters
This logical name must be unique in the outlines directory.

❑ A description of the outline, up to 256 characters

❑ The Word template’s file name (with the .dot extension)

For example:

Acme Enterprises Standard Software Requirement Specifications<CR>
Standard outline used for Software Requirements Specifications at 
Acme Enterprises<CR>
acme_srs.dot

5 In the outlines directory, save the text file, using the same file name as the template 
and the extension .def (for example, acme_srs.def).

To enable your team to create consistent documents, you can save the outline in a 
shared directory. All users can set a second location for additional outlines in the 
Options dialog box. Click Tools > Options to open the Options dialog box and type 
the full path and subdirectory name in the Document Outlines box.

Note:  You can edit the .dot files associated with your document types to include 
your company name and other information specific to your organization. You can 
enter the text in the Microsoft Work File > Properties dialog box. In the document 
itself, right-click the Company-Name box and click Update Field.

6 To assign the new outline to a document type, see Creating and Modifying Document 
Types on page 221.

Working with Requirement Types

You can create requirement types and modify existing requirement types. If you no 
longer need a requirement type, you can delete it.

A requirement type defines descriptive and operational information associated with a 
requirement. A requirement type serves as a template for all requirements of the same 
type and is useful for ensuring consistency and classifying or grouping similar 
requirements in a project. Requirement types can specify the initial numbering of the 
requirements; required terms, such as must or shall; a standard prefix, such as PR; and 
color and text formatting. Each requirement type has a unique set of user-defined 
attributes.

If you are using a project template as a starting point, several requirement types are 
available for your use. You can add or remove a requirement type to fit your process; 
select the project in the Explorer and then click File > Properties and the Requirement 
Types tab. You can also modify a requirement type after it has been created. To do so, 
you must open the project in exclusive mode, and if security is enabled, you must 
have project structure permission to change the tag prefix, color, or style.
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Creating and Modifying Requirement Types

1 In the Explorer, select the project and click File > Properties.
The Project Properties dialog box opens.

2 Click the Requirement Types tab.
.

3 Do one of the following:

❑ To add a new requirement type, click Add.

❑ To modify an existing requirement type, select the requirement type in the list, 
and then click Edit.

The Requirement Type dialog box opens.

4 Complete the boxes in the dialog box as follows:

❑ In the Name box, type or edit a name for the requirement type (up to 64 
characters).
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❑ In the Description box, type or edit a description (up to 255 characters). 

❑ To enable external traceability between requirements of this type in this project 
and other projects, select the Allow External Traceability check box.

❑ To specify the starting number for the first requirement of the defined type, 
click the Initial Requirement # box and type a positive integer to start this 
sequence. RequisitePro automatically numbers requirements when they are 
created. 

The default value for this text box is 1. The initial number sequence can be 
modified any time before the first requirement of this type is created. After the 
first requirement of this type has been saved, you must use the Renumber 
Requirements dialog box to change the sequence. 

❑ In the Requirement Must Contain box, type a single word or phrase that must be 
included in every requirement of this type that is created. This box is optional 
and is not case-sensitive.

Note:  Exclusive access to a project is necessary to modify the values in the 
following three steps for an existing requirement type. These options can be 
modified at any time.

❑ In the Requirement Tag Prefix box, type or edit a tag prefix for a requirement 
type. Examples of tag prefixes are SR and PR. 

❑ Select a Requirement Color and a Requirement Style to be used for requirements 
of this type in documents. The default color is blue, and the default style is 
Double Underline. 

5 Click OK in each dialog box.

Deleting Requirement Types

You can delete a requirement type if there are no requirements of the type in the 
project and if document types do not reference it as a default requirement type. You 
must have the project open in exclusive mode, and if security is enabled, you must 
have project structure permission to delete a requirement type.

1 In the Explorer, select the project and click File > Properties. The Project Properties 
dialog box opens.

2 Click the Requirement Types tab.

3 Select the requirement type you want to delete.

4 Click Delete.

5 Click OK.
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Working with Requirement Attributes and Attribute Values

Use the Attributes tab in the Project Properties dialog box to add an attribute. You can 
also use this tab to modify an existing attribute.

The following table shows suggested attributes that can be helpful for defining your 
requirements in RequisitePro. These attributes are suggestions, not rules. You can use 
these suggested attributes, which are provided with RequisitePro, or you can define 
and use any attributes that are appropriate for your project and business.

The list of requirement attributes above provides examples. Other common attributes 
include Difficulty, Stability, Risk, Security, Safety, Release Implemented, and Functional 
Area. RequisitePro also maintains system attributes for all requirements, including 
date, version, and relationship to other requirements. 

You can create and control attributes according to your needs. Regardless of the 
attributes you use, RequisitePro offers the flexibility to easily customize your project 
documents and databases to define, articulate, and manage the processes and culture 
of your organization.

Attribute Use to identify requirements by

Priority Importance to the project. Helps team members prioritize 
their efforts and use their time more effectively.

Status Progress
■ If a requirement’s status is Proposed, the requirement is 

currently being discussed by the project team. 
■ If a requirement’s status is Approved, the requirement 

has been discussed and agreed upon.
■ If a requirement’s status is Incorporated, the 

requirement has been added to the appropriate 
specification.

Authors Individual or team that created or changed the 
requirement’s text or attributes.

Responsible Party Individual or team responsible for ensuring the 
requirement is satisfied.

Rationale Text of or reference to an explanation. For example, the 
reference might be to a page and line number of a product 
requirement specification, or to a minute marker on a 
video tape of an important customer interview.

Cost Cost to implement the requirement. The attribute value 
for this attribute can be logical (high, medium, low) or 
numerical.
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You cannot delete requirement attributes if requirements of the requirement type 
already exist or if the requirement type is the default of a document type. 

Creating and Modifying Requirement Attributes

Use the Attributes tab in the Project Properties dialog box to add an attribute or 
modify an existing one. 

1 In the Explorer, select the project and click File > Properties. 
The Project Properties dialog box opens.

2 Click the Attributes tab.

3 Select a requirement type.

The attributes for the selected type are displayed in the same order as in the 
Requirement Properties dialog box, Attributes tab. (You can reorder the attributes 
list by selecting an attribute and then clicking Move Up or Move Down.)

4 Do one of the following:

❑ To add an attribute, click Add. The Add Attribute dialog box opens. 

❑ To edit an attribute, click Edit. The Edit Attribute dialog box opens.
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5 In the Type list, select a type. The following data types are supported:

The dialog box changes, depending on the type you select. If you select List (Single 
Value) or List (Multiple Value), the dialog box contains a List Values box. If you select 
one of the other types, the dialog box contains a Default Value box.

Data Type Allows Example

List (Single 
Value)

A set of values from which a single 
value can be selected. Each List 
value can be up to 32 characters in 
length.

High, Medium, or Low

List (Multiple 
Value)

A set of values from which more 
than one value can be selected. 
Each List value can be up to 32 
characters in length. 

Sue, Bob, and John

Text A text string up to 255 characters. John Smith

Integer Whole numbers. 5, 1500

Real Real numbers. 1.345, 6.7

Date A date in the format defined by the 
user’s Windows setting. 

mm/dd/yy

Time A time in the format defined by a 
user’s Windows setting. 

10:00 AM

URL Link A site on the Internet or on an 
intranet.

www.yoursite.com. (If 
you are using 
RequisiteWeb, include 
http://at the beginning 
of the link.)
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6 In the Label box, type a name for the attribute.

7 If the data type is a list-type, type the values in the List Values box. 

(Optional) If the data type is an entry-type, type a default value. If a new 
requirement is created and a value is not specified for the attribute, RequisitePro 
uses the default value.

8 To hide attributes of the selected requirement type from all RequisitePro users in 
views and in the Requirement Properties dialog box, select the Hidden from display 
check box.

9 To ensure traceability relationships are marked as Suspect when attributes are 
changed, select the Change affects suspect check box. When this check box is 
selected, RequisitePro monitors all requirements (based on this requirement type) 
and ensures that the status of all relationships labeled Traced to and Traced from for 
this requirement is changed to Traced-Suspect if the attribute value is changed.

10 Click OK to close each dialog box.

Deleting Requirement Attributes

You can delete a requirement attribute if you open the project in exclusive mode. If 
security is enabled for the project, you must have project security structure 
permission to delete an attribute.

1 Select the project in the Explorer and click File > Properties.

The Project Properties dialog box opens.

2 Click the Attributes tab.

3 In the Requirement Type list, select the requirement type for the attribute you want 
to delete.
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4 In the Labels for Attributes list, select the attribute.

5 Click Delete.

If the attribute is assigned to any requirements in the project, a message appears, 
asking you to confirm the deletion.

6 Click Yes.

7 Click OK in the Project Properties dialog box.

RequisitePro removes the attribute from the Attributes tab, removes all 
requirement references to the attribute, and removes all security referencing the 
attribute. If the attribute is a list-type, RequisitePro removes all list values and all 
security referencing the list values.

Modifying Attribute Values

You can add, delete, and edit the values assigned to a particular list-type attribute. 

1 In the Explorer, select the project and click File > Properties. 

The Project Properties dialog box opens.

2 Click the Attributes tab.

3 In the Requirement Type list, select the requirement type; in the Labels for Attributes 
list, select a single or multiple-value list-type attribute; and in the Values per 
Attribute list, select the value that you want to edit.

4 Click Edit. The Attribute Value dialog box opens.

5 In the Value text box, modify the value.

6 To use the value as the default value, select the Use as default check box.

7 Click OK. The changes to the attribute values appear in the Attributes tab of the 
Project Properties dialog box.

8 Click OK to close the Project Properties dialog box.
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Deleting Attribute Values

If an attribute value is not necessary to your project, you can delete it. To do so, you 
must have selected the Exclusive check box when you selected the project in the Open 
Project dialog box.

1 Select the project in the Explorer, and click File > Properties. 

The Project Properties dialog box opens.

2 Click the Attributes tab.

3 In the Requirement Type list, select the requirement type.

4 In the Labels for Attributes list, select the single value or multiple value list 
attribute.

5 In the Values per Attribute list, select the value that you want to delete.

6 Click Delete. 

If the value is not assigned to any requirements in the project, the value is deleted.

If the value is assigned to any requirements in the project, the Remove Value 
dialog box opens.

❑ Select a replacement value in the list, or select <no entry> if you want to assign 
no value to the requirement.

❑ Click OK. The value is removed from the Values per Attribute list.

Note:  When you delete a list value, any requirement that has that list value 
assigned to it is affected. If you select a replacement value, affected 
requirements are assigned the replacement value. If you do not select a 
replacement value, the value is simply deleted from the affected requirement. If 
you delete a value from a multiple value list and you do not select a 
replacement value, any other values previously assigned to requirements 
remain unchanged, and only the deleted value is deleted from affected 
requirements.

7 Click OK. 
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8 If the deleted value was the default, and you want to make one of the other values 
the default, click the value in the Values per Attribute list, and then click Default. To 
remove the designation of a value as the default, click the value in the Values per 
Attribute list, and then click No default. Repeat this step for any other value that 
you do not want as the default. 

9 Click OK.

Setting Up and Modifying Cross-Project Traceability

Cross-project traceability allows you to establish direct traceability relationships 
between requirements in different RequisitePro projects. This RequisitePro feature 
eliminates duplication by allowing teams to reuse requirements that are common 
across projects. Often a set of requirements is common to multiple projects. These 
requirements can be created in their own RequisitePro projects and traced to 
system-specific requirements located in their respective RequisitePro projects.

Projects must be created prior to setting up cross-project traceability. You can 
configure projects to connect automatically to external projects when a project with 
externally traced requirements is opened. You can also connect external projects 
manually. Note, however, that you cannot query across projects.

After you connect an external project, all externally traced requirement types are 
available for traceability relationships. External requirement types are displayed in 
the RequisitePro dialog boxes used to create traceability relationships. External 
requirements are identified with a project prefix set in the General tab of the Project 
Properties dialog box for the external project.

For information about maintaining cross-project traceability in archived projects, see 
Archiving Projects on page 200.

Marking Requirement Types for Cross-Project Traceability

To allow cross-project traceability for requirements in a project, you must do the 
following:

❑ Assign a project prefix so you can distinguish between requirements in 
different projects.

❑ Manually mark requirement types in the project as externally available. Only 
requirements of these types will be available for cross-project traceability.

Note:  To mark requirements for external traceability, you must have project structure 
permission.
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1 Open the project that you want to be the external project.

2 Select the project in the Explorer and click File > Properties. The Project Properties 
dialog box opens.

3 On the General tab, type a prefix in the Prefix text box (up to 8 characters). The 
prefix is stored in uppercase letters. You can change it at any time.

4 Click the Requirement Types tab, and select a requirement type that you want to 
mark for external traceability.

5 Click Edit.

The Requirement Type dialog box opens.

6 Select the Allow External Traceability check box, and click OK. RequisitePro marks 
the requirement type for cross-project traceability.

7 Repeat Steps 4 through 6 for any other requirement types that you want to be 
available for external relationships.

8 Click OK to close the Project Properties dialog box.

Connecting Projects

Connecting a project activates the relationship between the current project and the 
external project. When an external project is disconnected, you temporarily remove 
the connection to the open project.

You can establish traceability between requirements that reside in different projects. 
After the requirement types in the external project have been marked for external 
traceability, connect the external project to the currently open project. 
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To view external projects, click File > Project Administration > External Projects.
The External Projects dialog box opens.
.

It displays the following:

❑ Prefix—an identifier used for requirements in cross-project traceability. In an 
external project, the project prefix appears before the requirement tag, 
separated from the tag by a decimal. For example, if a requirement’s tag is 
PR234 and the project’s prefix is GLOBAL, then the external requirement is 
displayed as GLOBAL.PR234. The prefix can be up to 8 characters and must be 
uppercase letters. You assign the prefix in the General tab of the Project 
Properties dialog box.

❑ Name—the name of the external project.

❑ Status—indicates whether the external project is currently connected or 
disconnected to the open project.

❑ Location—indicates the location of the selected external project. 

To add a project as an external project:

1 In the External Projects dialog box, click Add. The Add External Project dialog box 
opens.

2 Locate the project and click Open.

3 To specify whether the external project should be automatically connected when 
the current project is open, select the Connect to the external project at project open 
check box.

Note:  In this case, when you open the project, one of several conditions apply:

❑ If neither project is secure, you are not required to log on to the project.

❑ If the project is secured and your user name and password are different than 
those used to log on to the secured project, the Project Logon dialog box opens. 
Log on to the project as you normally would. (If your user name and password 
are the same in both projects, you are not required to log on multiple times.)
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❑ If the project is not secured and the external project is secured, the Project 
Logon dialog box opens. Log on to the project as you normally would. 

4 To connect other external projects, repeat the above steps. (To remove a project 
from the External Projects dialog box, select the project and click the Remove 
button.)

5 Select the project from the External Project References list, and click Browse to 
relocate the project. Locate the project and click Connect. 

The Browse button is active only when an external project has been moved and 
disconnected.

Disconnecting Projects

You can disconnect external projects when they are not needed or are unavailable. For 
example, you may want to disconnect projects when you are working in a distributed 
mode and the database is unavailable, you are not working on traceability issues, or 
you want to relocate the external project. 

Disconnecting an external project increases system performance. A project must be 
disconnected before you can relocate it.

1 Click File > Project Administration > External Projects.
The External Projects dialog box opens. 

2 Select the project and click Disconnect. This temporarily disconnects the project. 

To reconnect the project, select the project and click Connect. (The Disconnect button 
automatically changes to a Connect button when you select a disconnected project, 
and the Connect button automatically changes to a Disconnect button when you select 
a connected project.)

Results of Disconnecting an External Project

Disconnecting an external project has the following implications:

■ Requirements in the disconnected project are displayed in the Traceability Matrix 
and Attribute Matrix with a label marking them as unavailable external 
requirements. The requirement is denoted as follows: ProjectPrefix<EXTERNAL 
KEY>ID number NOT AVAILABLE. (The ID number is for internal RequisitePro 
reference; it does not reflect the tag number.)

■ You cannot create or modify traceability relationships with requirements in the 
disconnected project.

■ You can delete traceability relationships with requirements in the disconnected 
project.
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■ If you delete a requirement or its traceability state changes to Suspect, external 
requirements relationships are updated with the new state. 

■ Any changes to requirements in the external project are updated when the project 
is opened. 

Moving External Projects

To relocate an external project, you must first disconnect it.

1 Click File > Project Administration > External Projects.
The External Projects dialog box opens.

2 Select the project, and then click Disconnect.

3 In File Manager or Windows Explorer, copy the project files (.rqs, .rql, .mdb) to the 
new location. For more information, see Moving Projects on page 210.

4 In the External Projects dialog box, in the External Project References listing, select 
the project.

5 Click Browse.

6 Select the project and click Open.

Viewing the Database with Microsoft Access

Because the current version of RequisitePro uses the Access 2000 database format to 
store project information, you must use Access 2000 or 2002 to view the database. If 
you are using a database created in a version of RequisitePro earlier than 2000.02.10, 
refer to the Note below.

1 Open Microsoft Access (version 2000 or 2002).

A dialog box opens, displaying options for accessing the database.

2 Click Open existing database.

3 Click OK.

4 Locate the project database and click OK. The database has an .mdb extension. 

The database opens for reading. The tables that comprise your project data are 
displayed. 

5 To print the database schema, click Tools > Analyze > Documentor. 

The Documentor opens. The Print Table Definition dialog box opens.

6 Select the Options check box.

7 Clear the Permission By User and Group check box.
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8 Select Table and click OK.

9 To print the report, click Access Print.

You can now generate reports. The database is still open for reading, so you cannot 
make changes to the structure or to the information. You cannot change RequisitePro 
tables or data, but you can create your own tables, queries, and reports in Access.

Note:  If you have a database that was created in a version of RequisitePro earlier than 
2000.02.10, the project database is in Microsoft Access 97 format. Rational has 
provided a utility to convert Microsoft Access-based RequisitePro projects from 
Access 97 format to Access 2000 format. The utility "RqAcc2KConv.exe" can be 
invoked by either dragging and dropping the RequisitePro project file (.rqs) onto the 
executable, or running the utility from the command line and specifying the entire 
path to the RequisitePro project file (.rqs) file. As part of the conversion process, the 
utility creates a backup copy of your database with the .tac extension instead of the 
.mdb extension. The backup copy can be removed when you are satisfied that the 
conversion was successful. The utility also repairs and compacts the database.
Viewing the Database with Microsoft Access 239



240 Chapter 15 - Working with Project Information



16Integrating with Other 
Products
You can use Rational RequisitePro with several tools:

■ Rational XDE

■ Rational ClearQuest

■ Rational ClearCase

■ Rational Unified Change Management 

■ Rational Rose 

■ Rational SoDA

■ Rational TestManager

■ Rational Unified Process

■ Microsoft Project

In addition, RequisitePro is included in all Rational Suite products as part of the 
Rational Team Unifying Platform, which also includes ClearQuest, TestManager, 
Rational ClearCase LT, SoDA, and the Rational Unified Process. 

Using Rational XDE with RequisitePro

The RequisitePro-XDE integration lets you combine the use-case modeling and 
application design capabilities of XDE with requirements management capabilities in 
RequisitePro. 

You can define your use cases by integrating Unified Modeling Language diagrams in 
XDE and Microsoft Word documents in RequisitePro. You can assign attributes and 
traceability to your use cases in order to manage your use cases in the context of the 
requirements. In addition, you can trace your requirements in RequisitePro to your 
design in XDE in order to better understand the impact that requirement change will 
have on your design.

The use-case modeling capabilities of this integration are similar to those of Integrated 
Use Case Management, which integrates RequisitePro and Rational Rose. You can 
migrate use-case associations in a Rose model when you upgrade the model to an 
XDE model. 
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For information about configuring and performing tasks in RequisitePro and XDE, 
see the RequisitePro-XDE Integration Help.

Using Rational ClearQuest with RequisitePro

If you have ClearQuest or any Rational Suite product installed on your PC, you can 
launch ClearQuest directly from the RequisitePro Tools menu (click Tools > Rational 
ClearQuest).

ClearQuest is a defect and change tracking system designed for the dynamic and 
evolving nature of software development. ClearQuest offers a flexible approach to 
track and manage all the change activities that are associated with an organization. 
With it, team members can customize and define queries, fields, activities, and states 
specific to their environment. This expanded level of customization makes the process 
of managing change easy for a team to implement, deploy, and maintain. 

If you have ClearQuest installed, you can open it from RequisitePro (Tools > Rational 
ClearQuest). If you have a Rational Suite product or are working with a Rational 
Administrator project, you can collect enhancement requests and defects in 
ClearQuest and associate them with new or existing requirements in RequisitePro. 
From RequisitePro, you can use custom requirement attributes to associate a 
requirement with one or many ClearQuest records. 

Note:  When you associate RequisitePro requirements with ClearQuest records in a 
ClearQuest MultiSite environment, the local ClearQuest database replica may have 
mastership of some ClearQuest records. You cannot associate these records with your 
RequisitePro project until you return mastership to the original database. 

Configuring the Integration

The RequisitePro-ClearQuest Integration Wizard provides an easy way to set up new 
integrations and reconfigure or repair existing integrations. The wizard also tests and 
verifies databases, projects, and associations to help you troubleshoot problems with 
new and existing integrations. 

The wizard replaces the ASCQISetup.bat and ASCQISetup.exe files used to configure 
the integration in earlier versions of Rational Software. If you have an existing 
integration, you can continue to use ASCQISetup.bat and ASCQISetup.exe to modify 
the integration, or you can use the wizard to make changes.

For more information on configuring the integration, see the book Rational Suite 
Administrator’s Guide, which is available on the Rational Solutions for Windows 
Online Documentation CD (included with RequisitePro and all Rational Suite 
products). If you have Rational Suite AnalystStudio installed, see Getting Started: 
Rational Suite AnalystStudio. More information on this integration is available from the 
white paper Using Rational ClearQuest and RequisitePro for Analysts.
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Associating a Requirement with a ClearQuest Record

To associate a requirement with a ClearQuest record using the Requirement 
Properties dialog box:

1 Do one of the following to open the Requirement Properties dialog box:

❑ Select the requirement in an open document, and click RequisitePro > 
Requirement > Properties.

❑ Select the requirement in the Explorer or in a view, and click Requirement > 
Properties.

2 Click the Attributes tab.

3 Scroll to the bottom of the Attributes list to the EnhancementRequest or Defect 
attribute to view the ClearQuest records associated with this requirement, and 
then do one of the following:

❑ Type the ClearQuest record number. 

❑ Click the adjacent browse button to select a record. In the Associate 
Enhancement Requests or the Associate Defects dialog box, select a 
requirement from the Records list and click the Associate button.

❑ Click the adjacent browse button and create a new record in ClearQuest to 
associate with the requirement. 

4 Click OK in the Attributes tab of the Requirement Properties dialog box.

To associate a requirement with a ClearQuest record using an Attribute Matrix:

1 Open an Attribute Matrix view of feature requirements.

2 In the EnhancementRequest or Defect column for a requirement, do one of the 
following:

❑ Type the ClearQuest record number.

❑ Click the adjacent browse button to select an enhancement request. In the 
Associate Enhancement Requests or Associate Defects dialog box, select a 
requirement from the Records list and click the Associate button.

❑ Click the adjacent browse button and create a new record in ClearQuest to 
associate with the requirement. (The button appears when you double-click the 
cell.)

3 To save the associated value in the Attribute Matrix, click outside the cell.
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Using Rational ClearCase with RequisitePro

You can use ClearCase with RequisitePro in several ways.

If your project uses the Unified Change Management (UCM) model, you can create 
baselines of the project. RequisitePro project administrators can implement the UCM 
model in ClearCase and Rational Administrator by creating baselines of RequisitePro 
projects.

If your RequisitePro project does not use the UCM model, you can archive it using the 
ClearCase archive command from within RequisitePro.

Using Rational Unified Change Management to Create a Project Baseline 

UCM is Rational's out-of-the-box usage model for managing change in software 
system development, from requirements to release. UCM is a unified approach to 
configuration management and change request management, automated in ClearCase 
and ClearQuest. ClearCase can be set up to implement the UCM model for basic 
activity-based configuration management or in conjunction with ClearQuest to 
provide full change-request management. 

To implement the model for baselining a RequisitePro project, the project must be 
associated with a UCM-enabled Rational project in the Rational Administrator. For 
more information, see Creating a Project Baseline with Unified Change Management on 
page 208.

If you have created a baseline for a RequisitePro project, you can use that baseline to 
create new projects in RequisitePro. For example, you may want to base the next 
release of a project on a stable configuration of the previous release. For more 
information, see Creating a RequisitePro Project from a Baseline on page 178.

Using ClearCase to Archive Projects

In RequisitePro, archiving is the process of duplicating the database, documents, and 
all related files in a project so that they can be restored at a later time. You can archive 
a RequisitePro project in ClearCase using the Project > Archive > Rational ClearCase 
command. For more information, see Archiving Projects with Rational ClearCase on 
page 202.

Using Rational Rose with RequisitePro

Rose offers powerful tools for object-oriented analysis, modeling, design, and 
construction. As the world’s leading visual modeling tool, Rose lets system analysts 
start modeling requirements with use cases and actors and enables developers to 
define and communicate a software architecture. 
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You can open Rose directly from RequisitePro by clicking Tools > Rational Rose, and 
you can associate Rose use cases with RequisitePro requirements and documents 
using Integrated Use Case Management.

For additional information on Integrated Use Case Management, see the white paper 
Use Case Management with Rose and RequisitePro or the manual Getting Started: Rational 
Suite AnalystStudio. 

Using Integrated Use Case Management

Rational’s integrated management of use cases between Rose and RequisitePro allows 
you to start or work in either environment, according to your process.

Integrated Use Case Management allows you to manage use cases using attributes 
(such as Priority, Risk, Status, and Iteration) by associating Rose use cases with 
RequisitePro documents and requirements. You can easily navigate from Rose 
use-case models to RequisitePro use-case documents and requirements and vice 
versa.

Use-case management in RequisitePro adds depth and relational information to your 
Rose use cases. The following features are supported:

■ textual definitions of use cases in a Microsoft Word documents 

■ detailed descriptions of flows of events, special requirements, preconditions, and 
postconditions

■ hierarchical (parent/child) relationships between use-case names and actions 
within the use-case flow of events

■ traceability to and from other use cases and associated design features. 

We recommend that you develop your use cases in Rose and then detail and manage 
them in RequisitePro using Integrated Use Case Management. This approach 
accomplishes associations between Rose and RequisitePro with several easy menu 
selections.

To associate a Rose model or package with a RequisitePro project, open the model or 
package in Rose and click Tools > Rational RequisitePro. For more information on 
Integrated Use Case Management, see the Integrated Use Case Management Help, 
available from Rose or RequisitePro.

To associate a RequisitePro document with a Rose use case, open the document and 
click RequisitePro > Document > Associate to Rose Use Case. 

To associate a RequisitePro requirement with a Rose use case, do one of the following:

■ Select the requirement in a view or in the Explorer, and then click Requirement > 
Associate to Rose Use Case.
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■ Select the requirement in a Word document, and click RequisitePro > Requirement 
> Associate to Rose Use Case. 

Viewing a Rose Use Case Associated with a Document or Requirement

If you have Rose installed on your system (as part of AnalystStudio or a stand-alone 
application), you can work with the Integrated Use Case Management feature that 
links RequisitePro documents and requirements with Rose use cases. You can use the 
Open Rose Use Case command to navigate from a RequisitePro document or 
requirement to its associated Rose use case. (For more information, see the Integrated 
Use Case help, available through the Help button in the dialog boxes.)

Note: The Rose commands appear on the Document and Requirement menus only if 
Rose is installed on your system.

To go to a use case associated with a document:

1 Open a document that is associated with a use case.

2 Click RequisitePro > Document > Open Rose Use Case.

To go to a use case associated with a requirement:

1 Do one of the following:

■ In a view, select a requirement that is associated with a use case.

■ In a document, click the cursor inside a requirement that is associated with a use 
case.

2 Click Requirement > Open Rose Use Case.

Note: You must save your Rose model before you can navigate from a RequisitePro 
document or requirement to the associated Rose use case using the Open Rose Use 
Case command.

Associating Documents and Requirements with XDE Elements

If you have Rose installed on your system (as part of AnalystStudio or as a 
stand-alone application), you can use the Integrated Use Case Management feature to 
associate a RequisitePro document or requirement with a use case in Rose. You can 
use the Associate to Rose Use Case command to directly associate a document or 
requirement with a Rose use case. (For more information, see the Integrated Use Case 
Management Help, available through the Help button in the dialog boxes.)

Note: This command appears only if Rose is installed on your system. 

To associate a document with a Rose use case:

1 Open a document.

2 Click RequisitePro > Document > Associate to XDE Element.
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To associate a requirement with a Rose use case, do one of the following:

■ Select a requirement in a view or in the Explorer, and then click Requirement > 
Associate to XDE Element.

■ Place your cursor within a requirement in a document, and click RequisitePro > 
Requirement > Associate to XDE Element.

Note:  If you want to move a requirement into another document and it is associated 
with a Rose use case, you must first remove the association. Then associate the 
requirement to the appropriate use case after you have saved it in the other document.

For more information about associating a document or requirement with a Rose use 
case, see the Integrated Use Case Management Help, which is available through the 
Help button in the dialog boxes.

Using Rational SoDA with RequisitePro

RequisitePro is a supported domain for SoDA. This allows you to create reports that 
extract information from various data sources, including a RequisitePro database. 

Using SoDA and RequisitePro, you can:

■ Use SoDA to modify and generate SoDA reports and documents from an open 
RequisitePro project. 

■ Use SoDA and RequisitePro to create a report that consolidates RequisitePro 
requirements information and Rose modeling information. 

■ Create a use-case report that includes all use-case requirements and Rose use-case 
diagrams.

For more information, see Printing Project Summaries and Reports on page 193.

Using Rational TestManager with RequisitePro

If you have TestManager installed, you can launch the TestManager component 
directly from the RequisitePro Tools menu (click Tools > Rational TestManager).

RequisitePro requirements can be referenced from TestManager to ensure complete 
test coverage for all requirements. TestManager is part of Rational TeamTest and all 
Rational Suite products. TestManager is the one place to manage all testing 
activities—planning, design, development, execution, and analysis. TestManager ties 
testing and the rest of the development effort, combining your testing assets and tools 
to provide a single point from which to understand the exact state of your project. If a 
requirement changes, TestManager marks the association use case as suspect. Using 
TestManager, you can create reports that show all suspect test cases and test input 
development coverage reports that show the percentage of requirements that have 
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implemented test cases. If you have installed TestManager, we recommend that you 
use it to develop all test artifacts. For additional information, see Rational TestManager 
User’s Guide and TestManager Help.

Using the Rational Unified Process with RequisitePro

The Rational Unified Process (RUP) is an online knowledge base of proven 
software-development principles. As a software engineering process, the RUP 
provides a disciplined approach to assigning tasks and responsibilities within a 
development organization. Its goal is to ensure the production of high-quality 
software that meets the needs of its end users, within a predictable schedule and 
budget. The RUP captures many of the best practices in modern software 
development in a form that can be tailored to a wide range of projects and 
organizations. Many activities in the RUP are supported by software-engineering 
tools. Tool Mentors describe how Rational Software tools can be used to support 
particular steps and activities. Click Help > Extended Help to access the Tool Mentors 
and other information databases.

The Use-Case template provides a basic project structure that is compliant with the 
RUP. The project template provides requirement types, suggested attributes, default 
attribute values, and related document types. For more information on using the 
Use-Case template, see Reviewing RequisitePro Project Template Options on page 172.

Using Microsoft Project with RequisitePro

The Microsoft Project Integration Wizard manages traceability from requirements in 
RequisitePro projects to tasks in Microsoft Project schedules. You can use the wizard 
to do the following:

■ Create tasks from requirements and establish traceability relationships from those 
requirements to the tasks.

■ Add or remove traceability from requirements to existing tasks.

After you have established traceability you can:

■ Refresh requirement information within RequisitePro that links to the traced tasks 
in Microsoft Project. 

■ Review suspect traceability relationships between requirements and tasks in a 
RequisitePro Traceability Tree or Traceability Matrix.

■ Analyze the impact on the requirements, the tasks, the project, and the schedule as 
changes occur.
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Tips for Using Microsoft Project with RequisitePro

Follow these guidelines when using the Microsoft Project integration:

■ Create an associated task for any requirement that you want to track in Microsoft 
Project. For example, you would generate a task for any feature requirement for 
which you must produce a document and submit that document for review and 
approval by a specified date. 

■ If you follow the Rational Unified Process, you should probably include a use case 
as the main item that should appear in your schedule. It may also make sense to 
trace each alternative flow and each individual step in a use case. Supplementary 
requirements are also candidates for the schedule, but the process associated with 
a supplementary requirement is highly dependent on the nature of the 
requirement; for example, performance constraints have one set of tasks, and 
usability constraints have a different set of tasks. 

■ Whatever requirements are handed off to the development team should appear in 
the schedule. 

■ Map the requirements that have activities associated with them. For example, if 
you have a parent requirement and all the children are approved for a release, you 
might want to generate a task linked to the parent. If only one of the children is 
approved, link only the child. If the children are sufficiently weighty, then you 
may want to bring over the parent and children as a task hierarchy. 

■ If you have a requirement attribute to designate a product release number, you 
might want a schedule just for requirements assigned to the same release number. 

■ If you have an “assigned-to” requirement attribute, you might want to generate a 
schedule for everything assigned to each developer.

MSPT Requirement Types

Requirements and tasks are linked using a special requirement type, the MSPT 
requirement type. This requirement type is a place holder in a RequisitePro project 
that represents a task in a Microsoft Project schedule. The MSPT requirements are 
linked to tasks in a schedule. The MSPT requirement type contains, as requirement 
attributes, the Microsoft Project file name and a unique ID of the task it represents.

The MSPT requirement type also includes default attributes that are based on task 
fields in Microsoft Project. These default attributes are Cost, Duration, Finish, 
Milestone, Priority, Resource Names, and Start.

You can also map Microsoft Project fields to RequisitePro attributes for the MSPT 
requirement type in the .rqs file of your RequisitePro project. For more information 
about the MSPT requirement type, see Working with the MSPT Requirement Type on 
page 255.
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Requirements

Software Requirements

To use the MS Project Integration Wizard, you must have Microsoft Project 2000 or 
Microsoft Project 2002 installed on your system. If neither is installed, the Start 
Microsoft Project and Integration Wizard commands are disabled on your RequisitePro 
Tools menu.

Security Requirements

To initially integrate a RequisitePro project with Microsoft Project using the wizard, 
you must have RequisitePro administrator permissions.

To use the Microsoft Project Integration Wizard in subsequent sessions:

■ You must have create and delete permissions for the MSPT requirement type. 

■ You must have attribute update permissions for all attributes associated with the 
MSPT requirement type.

Note:  You cannot integrate an individual Microsoft Project schedule with more than 
one RequisitePro project. You can integrate multiple Microsoft Project schedules with 
various requirement types within one RequisitePro project.

Starting the Wizard and Adding the MSPT Requirement Type

You can start the Microsoft Project Integration Wizard from within RequisitePro or 
run it as an independent application. These instructions explain how to start the 
wizard from within RequisitePro. 

Note:  Make sure that you have closed any open dialog boxes in Microsoft Project 
before you use the Microsoft Project Integration Wizard.

To start the Microsoft Project Integration Wizard:

1 Click Tools > Microsoft Project > Integration Wizard. The introduction page opens.

2 Click Next. The Select Project Files page opens.

3 Select a project. The list displays all projects in your RequisitePro project list.

4 Do one of the following:

❑ Enter the name and path of an existing Microsoft Project schedule.

❑ Click Browse to locate, select, and open an existing schedule in Microsoft 
Project.
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❑ Click New to create a new schedule. The Project Info dialog box opens. When 
you are finished creating the new schedule, click OK in the Project Info dialog 
box. A dialog box opens, prompting you to save the new project. After saving 
the schedule, the wizard minimizes Microsoft Project, returns to this page, and 
adds the new schedule name to the Microsoft Project Schedule text box.

5 Click Next. If the project you selected has security enabled, the Logon dialog box 
appears. Log on as you would to a secured RequisitePro project.

The wizard checks the project, searches for the MSPT requirement type, and adds 
it if it is missing. The MSPT Info page is displayed. Click Next.

The wizard opens the project and schedule and displays the Select An Action page.

Creating Tasks from Requirements

The following instructions assume that the wizard is started and that the Select An 
Action page is displayed. Use this feature to select requirements in RequisitePro in 
order to create new tasks in Microsoft Project that are linked to the RequisitePro 
requirements.

Note:  The first time the Select An Action page opens after you select a new schedule, 
only the first option is available. After tasks have been created, the other options 
become available.

1 Select the option Select requirements to create tasks, or add and remove traceability 
to existing tasks.

2 Click Next.

3 In the Requirement Type list, select a requirement type.

4 Click one of the following:

❑ All requirements of selected type. 

❑ Requirements of this attribute value. 

➑ In the Attribute list, select the attribute.

➑ In the Value box, select a value and an operator.

❑ To search for requirements containing specific phrases (for example, the word 
shall) in requirement name or text, enter the string in the Requirement Text 
Search box. You can use partial strings, but wildcard searches are not 
supported.

5 Click Next. The page displays the Task Traceability Tree for the requirements that 
you filtered in the previous page.

6 Select one or more requirements and select Create Tasks. 
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7 Click Next. At the next page, click Finish.

Note:  Each time you make a change to a schedule, a dialog box opens, prompting 
you to save with or without a baseline. We recommend that you save with a 
baseline for each change. See the Microsoft Project help for more information 
about baselines.

8 Click Exit to close the wizard, or click Another Action to return to the Select an 
Action page where you can create more tasks, add or remove traceability, and 
refresh requirement information from Microsoft Project.

Adding or Removing Traceability

The following instructions assume that the wizard is started, the Select An Action 
page opens, and you have created tasks in Microsoft Project that are linked to 
requirements in RequisitePro.

You can modify traceability in the Microsoft Project Integration Wizard by doing one 
of the following:

■ Select a RequisitePro requirement and link it to a Microsoft Project task.

■ Select a Microsoft Project task and link it to a RequisitePro requirement.

Both option are covered in the two procedures below.

Selecting Requirements to Modify Traceability

At the Select An Action page:

1 Select the option Select requirements to create tasks, or add and remove traceability 
to existing tasks.

2 Click Next. 

3 In the Requirement Type list, select a requirement type.

4 Click one of the following:

❑ All requirements of selected type. 

❑ Requirements of this attribute value.

➑ In the Attribute list, select the attribute.

➑ In the Value box, select a value and an operator.

❑ To search for requirements containing specific phrases (for example, the word 
shall) in the requirement name or text, enter the string in the Requirement Text 
Search box. You can use partial strings, but wildcard searches are not 
supported.

5 Click Next.
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The page displays the task traceability tree for the requirements that you filtered in 
the previous page.

To remove traceability between the selected task and requirement:

1 Select one or more tasks, click Remove traceability, and click Finish. The traceability 
between the selected tasks and requirement is removed. Note that the tasks remain 
in the Microsoft Project schedule.

2 Click Exit to close the wizard, or click Another Action to return to the Select An 
Action page where you can create more tasks, add or remove traceability, and 
refresh requirement information from Microsoft Project.

To add traceability between the selected requirements and a task:

1 Select a requirement and click Add Traceability. Traceability is created for one 
requirement at a time. 

2 Click Next to advance to the next page and select a task.

3 Do one of the following:

❑ If you are satisfied with the current task selection, click Finish.

❑ To change the selection, click MS Project to display the schedule and select one 
or more tasks. Return to the Integration Wizard and click Refresh Task List to 
refresh the task display. Then click Finish.

4 Click Exit to close the wizard, or click Another Action to return to the Select An 
Action page where you can create more tasks, add or remove traceability, and 
refresh requirement information from Microsoft Project.

Selecting Tasks to Modify Traceability

At the Select An Action page:

1 Select the option Select tasks to add or remove traceability and click Next.

The Select Tasks page appears.

2 Do one of the following:

❑ If you are satisfied with the current task selection, click Next.

❑ To modify the selection, click Microsoft Project to display the schedule and 
select one or more tasks. Return to the Integration Wizard and click the Refresh 
Task List to refresh the task display. Then click Next.

This page displays the Task Traceability Tree for the tasks you selected in the 
previous page and the requirements from which the tasks are traced.
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3 Do one of the following:

❑ To display the task in the Microsoft Project schedule, select a task and click Go 
to Task. In the schedule, you can view the task or make modifications. When 
you are finished, return to the Integration Wizard. 

❑ Select a requirement and the Remove traceability option. Then click Finish. The 
traceability between the selected task and the requirement is removed.

❑ Select a task and the Add Traceability option. Then click Next. The Select a 
Requirement Type page appears. 

4 In the Requirement Type list, select a requirement type.

5 Click one of the following:

❑ All requirements of selected type. 

❑ Requirements of this attribute value. 

➑ In the Attribute list, select the attribute.

➑ In the Value box, select a value and an operator.

❑ To search for requirements containing specific phrases (for example, the word 
shall) in the requirement name or text, type the string in the Requirement Text 
Search box. You can use partial strings but not wildcard searches.

6 Click Next. The requirements that you filtered in the previous pages are displayed.

7 Select a requirement. To display the requirements without tasks, select the Show 
only requirements with no tasks check box.

8 Click Finish.

Refreshing MSPT Requirement Information from Tasks

The following instructions assume that the Select An Action page in the Microsoft 
Project Integration Wizard is open and that you have created tasks in Microsoft 
Project that are linked to MSPT requirements that represent the tasks in RequisitePro. 
Traceability should be established between your product requirements and the MSPT 
requirements.

When the values in the Microsoft Project task fields are changed, you must use the 
refresh feature in the Microsoft Project Integration Wizard to update the 
corresponding attribute values in the MSPT requirements. The resulting changes to 
the MSPT attribute values cause the traceability relationships between your product 
requirements and the MSPT requirements to be marked as suspect. This suspect 
condition alerts you of changes in the Microsoft Project schedule.
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You can then view the suspect relationships in a Traceability Matrix that includes your 
product requirements and the MSPT requirements, or you can review the changes to 
the MSPT attribute values using an Attribute Matrix of the MSPT requirement type.

To refresh the MSPT requirements from the Microsoft Project tasks:

1 At the Select An Action page, select the option Refresh MSPT information from MS 
Project tasks and click Next.

The Update page displays the list of changes to occur when you update 
RequisitePro from the Microsoft Project tasks.

2 To proceed with the integration, click Finish.

Working with the MSPT Requirement Type

Viewing the MSPT Requirement Type

You can view the MSPT requirement type in a view in RequisitePro.

1 Click File > New > View.

2 Select one of the following views:

❑ Select an Attribute Matrix and the MSPT requirement type to review the 
changes to the MSPT attribute values.

❑ Select a Traceability Matrix. Select the requirement types for your product 
requirements (in the row requirements) and the MSPT requirements (in the 
column requirements). The traceability is displayed between the requirement 
types.

❑ Select a Traceability Tree. Select the product requirement type and expand the 
display to view the traceability relationships to the MSPT requirements.

3 Click OK.

Mapping Fields to Attributes for the MSPT Requirement Type

Unlike other requirement types, you cannot add a new attribute to the MSPT 
requirement type using the Attributes tab on the Project Properties dialog box. You 
can, however, create attributes for the MSPT requirement type in the .rqs file for the 
RequisitePro project in which you are working. For example, if the name of the project 
you are working on is “blueproject,” then you use the blueproject.rqs file to create 
new attributes for the MSPT requirement type.

If security is enabled for the project, you must have project structure permission to 
map a field to an attribute for an MSPT requirement type.
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To map fields to attributes:

1 In a text editor, open the .rqs file for the project with which you are working.

2 Refer to the next section to locate the task field that you want to map to an attribute 
for the MSPT requirement type.

3 In the [MSProjectMappings] section of the .rqs file, enter the following:

field ID=attribute name

where field ID is the field ID listed in the next section, and attribute name is the 
label you want to give the attribute in RequisitePro.

4 Save the .rqs file.

The Microsoft Project Integration Wizard creates an attribute for the MSPT 
requirement type based on the information entered.

Microsoft Project Field IDs

Use the following Microsoft Project field IDs to map attributes for the MSPT 
requirement type in RequisitePro to corresponding constants in Microsoft Project. 
Add your entries to the [MSProjectMappings] section in <project name>.rqs file using 
a text editor. 

Use the format “field ID=attribute name,” where field ID is the numeric constant 
listed below and the attribute name is the label you want to give the attribute in 
RequisitePro. Field IDs shown in bold are already provided as default attributes for 
the MSPT requirement type.

Actual Cost = 28 Actual Duration = 28 Actual Finish = 42

Actual Start = 41 Actual Work = 2 Baseline Cost = 6

Baseline Duration = 27 Baseline Finish = 44 Baseline Start = 43

Baseline Work = 1 BCWP = 11 BCWS = 12

Confirmed = 110 Constraint Date = 18 Constraint Type = 17

Contact = 112 Cost = 5 Cost1 = 106

Cost2 = 107 Cost3 = 108 Cost Variance = 9

Created = 93 Critical = 19 CV = 83

Delay = 20 Duration = 29 Duration1 = 103

Duration2 = 104 Duration3 = 105 Duration Variance = 30
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Early Finish = 38 Early Start = 37 Finish = 36

Finish1 = 53 Finish2 = 56 Finish3 = 59

Finish4 = 62 Finish5 = 65 Finish Variance = 46

Fixed Cost = 8 Fixed (Duration) = 34 Flag1 = 72

Flag10 = 81 Flag2 = 73 Flag3 = 74

Flag4 = 75 Flag5=76 Flag6 = 77

Flag7 = 78 Flag8 = 79 Flag9 = 80

Free Slack = 21 Hide Bar = 109 ID = 23

Late Finish = 40 Late Start = 39 Linked Fields = 98

Marked = 71 Milestone = 24 Name = 14

Notes = 15 Number1 = 87 Number2 = 88

Number3 = 89 Number4 = 90 Number5 = 91

Objects = 97 Outline Level = 85 Outline Number = 102

% Complete = 32% Work Complete = 33 Predecessors = 47

Priority = 25 Project = 84 Remaining Cost = 10

Remaining Duration = 31 Remaining Work = 4 Resource Group = 113

Resource Initials = 50 Resource Names = 49 Resume = 99

Resume No Earlier Than = 101 Rollup = 82 Sheet Notes = 94

Start = 35 Start1 = 52 Start2 = 55

Start3  = 58 Start4 = 61 Start5 = 64

Start Variance = 45 Stop = 100 Subproject File = 26

Successors = 48 Summary = 92 SV = 13

Text1 = 51 Text10 = 70 Text2 = 54

Text3 = 57 Text4 = 60 Text5 = 63

Text6 = 66 Text7 = 67 Text8 = 68
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Deleting Attributes for MSPT Requirement Types

If security is enabled for the project, you must have project structure permission to 
remove the MSPT requirement type if you want to delete an attribute for the 
requirement type.

To delete attributes:

1 Open the RequisitePro project file (projectname.rqs) with a text editor.

2 In the project file, under the heading [MSProjectMappings], locate the requirement 
attribute that you want to delete. Attributes are listed with the Microsoft Project 
field ID, followed by an equal sign (=), and the attribute name; for example, 
5=Cost.

3 Delete the entire line that contains the attribute. Save and close the project file.

4 Click File > Open Project.

5 Select the project, select the Exclusive check box, and click OK. Log on to the 
project, if necessary.

6 Click Tools > Microsoft Project > Integration Wizard.

7 Click Next. Be sure that the current RequisitePro project and related Microsoft 
Project are selected. Click Next.

8 Select the option Refresh MSPT information from MS Project tasks. Click Next. 

9 After the processing is complete, click Finish. Click Exit and Yes at the confirmation 
prompt.

Text9 = 69 Total Slack = 22 Unique ID = 86

Unique ID Predecessors = 95 Unique ID Successors = 96 Update Needed = 111

WBS = 16 Work = 0 Work Variance = 3
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17Troubleshooting
The sections in this chapter describe some of the problems that may arise when you 
use Rational RequisitePro and how you can resolve them. Technical support is 
available for all Rational products, including RequisitePro. To get assistance with 
problems that are not covered in this chapter, go to http://solutions.rational.com/solutions/. 
Select RequisitePro from the list box; below the box, type the keywords to be used in 
the search. A list of technical notes that contain the keywords is presented; click the 
topic that describes the problem you are experiencing. 

Creating Requirements

A requirements document is a Microsoft Word file created in Rational RequisitePro 
and integrated with the project database. Requirements cannot be created in a normal 
Word document. 

If you experience problems when creating requirements in a document, check for the 
following:

■ Overlapping requirements. Make sure that the highlighted selection is not inside 
of or overlapping another requirement. Requirements cannot be nested or overlap 
one another. 

■ Bookmarks and hidden text. RequisitePro uses Word bookmarks and hidden text 
to designate requirements. If your document contains bookmarks or hidden text 
(either in other requirements or in nonrequirement text in the document), make 
sure the highlighted selection is not inside of or overlapping a Word bookmark or 
hidden text.

■ Document saved status. You cannot establish traceability for a new requirement or 
in a newly created document until you save the document. If a requirement is not 
displayed in the Traced From Requirement(s) dialog box or Traced To 
Requirement(s) dialog box, try saving the document.

■ Track changes. Be sure that Word’s Track Changes functionality is not turned on 
when creating or modifying requirements. 

■ File versioning. Be sure that Word’s file versioning capability is not turned on.

(See Tips for Using Word in RequisitePro on page 95.)
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Database Corruption

On very rare occasions, a RequisitePro project that uses the Microsoft Access database 
may become corrupted. When this occurs, RequisitePro displays an error message.  It 
is a good practice to periodically repair or compact your Access database even if you 
are not experiencing problems.

Note:  To repair corrupted projects that use an enterprise database, see your database 
administrator.

To repair and compact a corrupted Microsoft Access project database, make sure that 
all users close the project, and then do the following:

1 Open the Database Properties dialog box by doing one of the following:

❑ Click File > Open Project. In the Open Projects dialog box, select the corrupted 
project and click Properties.

❑ In the Explorer, select the project and click File > Properties. On the General tab 
of the Project Properties dialog box, click Properties.

2 Click the Configure button. 

The ODBC Microsoft Access Setup dialog box opens.

3 To repair a corrupted database, do the following:

❑ Click the Repair button. 

The Repair Database dialog box opens. The selected database appears in the 
Database Name box. 

❑ Click OK.

4 To compact the database, do the following:

❑ Click Compact on the ODBC Microsoft Access Setup dialog box. 

The Database to Compact From dialog box opens. The selected database 
appears in the Database Name box. 

❑ Click OK.

5 In the Database to Compact Into dialog box, select one of the Format options based 
on the version of Access the RequisitePro project uses, not the version of 
RequisitePro. Select Version 4.x if you are using Access 2000; select Version 3.x if 
you are using Access 97. 

Note:  If the version selected does not match the database, you receive an ODBC 
error. If you have Access 97 on your system, the Version 4.x option does not appear. 
If the database you are compacting is in the Access 2000 format, you must perform 
the compact procedure on a system with Access 2000 installed.
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6 Click OK.

7 Click Yes to confirm that you want to replace your database with a compacted 
version.

Document Not Found Messages

If the Document Not Found dialog box opens when you try to open a document, the 
document may have been deleted in Windows Explorer, moved, or renamed. You can 
respond to the error message in one of the following ways:

■ You can browse the file system to associate the document with a new location.

■ You can delete all requirements associated with the document from the project.

■ You can click Cancel to keep the requirements associated with the document, and 
then try to restore the file and reopen the document.

Files Are Too Big for Microsoft Word

When you open a large document in Microsoft Word, an error message may appear, 
stating that the file is too large to open. 
We recommend that you use small Word documents for the following reasons:

■ Word allows only one user at a time to modify a document.

Note:  The extended editing feature allows concurrent users to modify 
requirements located in documents without having to open the document.

■ Small documents are more likely to be reviewed thoroughly because multiple 
reviewers can work on small sections of text concurrently.

■ Small documents enable better system performance.

■ Word may have problems processing large documents.
For help working with large documents, see Rational Technical Note #2383 (available 
at www.Rational.com); Tips for Using Word in RequisitePro on page 95; and the 
Microsoft Word documentation. 

Failed Multiple Select Actions

When you select more than one relationship or requirement in a view and then 
perform an operation on the multiple selection (such as creating traceability or 
deleting), the operation may fail for one or more requirements or relationships. 
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For example, the operation may fail if you do not have rights to perform the operation 
on the requirements or relationships, or if some of the requirements are in documents 
and the operation is not permitted for requirements in documents.

RequisitePro notifies you of such failures by providing an exception log that shows 
the requirements or relationships for which the operation failed and the reason for the 
failure.

1 In a view, perform the desired operation on a selected group of requirements or 
relationships.

❑ If the operation is successful, the modifications are shown in the view, and no 
dialog box appears.

❑ If the operation fails for one or more requirements or relationships, or if you 
stop the operation before it is completed, the Exception Report dialog box 
opens, providing the number of requirements or relationships for which the 
operation failed.

2 Click Details to learn more about the failed operation.

The dialog box is expanded, showing the reason for the failure.

3 To copy the text in the text box, select the text and press CTRL-C. You can then 
paste the text into a text document.

4 Click Close.

General Protection Faults in Page View Mode

Viewing documents in Page View mode in Microsoft Word can trigger General 
Protection Faults (GPFs), caused by high memory requirements. A GPF is an error 
condition that occurs when an application attempts to access memory outside of its 
authorized memory space or an invalid instruction is issued. To avoid GPFs while 
viewing documents, switch to Word’s Normal view. When you have had a GPF, you 
may continue to have problems caused by memory corruption. Restart the machine 
and try again.

Recovering an AutoRecover Document

If your computer system fails, you can retrieve a Rational RequisitePro document 
saved with the Microsoft Word Autosave feature. You must have previously selected 
the AutoRecover feature in Word.

1 In Word, click File > Open.

The Open Word Document dialog box opens.
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2 Locate the directory and the document, and click Open.

The document is displayed. Word prompts you to save the document.

3 In Word, click File > Save.

A message appears, asking whether you want to replace the existing document.

4 Click Yes.

The document is saved in the condition it was in at the time of the last automatic 
save.

5 Click File > Close.

6 Open the document in RequisitePro by clicking RequisitePro > Document > Open.

7 Click RequisitePro > Document > Save.

RequisitePro Menu Appears Incorrectly

If you encounter General Protection Faults in a document, the RequisitePro menu may 
appear in applications other than Microsoft Word, such as Microsoft Outlook or other 
e-mail applications. In addition, you may see duplicate occurrences of the 
RequisitePro menu in the Word document.

To remove the erroneous menu, delete the normal.dot and email.dot templates from 
your Microsoft Office directories. Before doing so, verify that you do not have any 
customizations in normal.dot or email.dot. If you do, you will have to recreate those 
customizations after the files are generated again. Typically, the .dot files are located 
in the following directories:
■ Program Files\Microsoft Office\Office

■ Program Files\Microsoft Office\Templates

These files will be generated again automatically by your Microsoft Office applica-
tions.

Invalid Date/Time Errors

If you receive invalid date/time errors, change the Windows Regional Settings on 
your machine to one of the default settings.

To find the default settings in the Regional Settings Properties dialog box, switch to a 
different locale on the Regional Settings tab and then switch back. The default settings 
appear on the Time and Date tabs.
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SQL Server Syntax Error

If you have an existing RequisitePro database in Microsoft SQL Server and your SQL 
Server has been upgraded to 7.0 from a previous version, then the system administra-
tor must run the following stored procedure in SQL Server to set the database compat-
ibility level to SQL Server 7.0: 
sp_dbcmptlevel<database name>, 70

For example:
sp_dbcmptlevel RequisitePro, 70

If the system administrator does not run this procedure, SQL Server Syntax Errors 
may appear in RequisitePro.

Word Automation Server Error Message

When you try to open a Rational RequisitePro document, the following error message 
may appear: "The Word Automation server could not be started." The distributed 
version of the Component Object Model (COM) must be changed on your system to 
allow RequisitePro to open Microsoft Word.

Do the following to configure the distributed COM entry for Word on your system:

1 On the Start menu, click Run.

2 Type dcomcnfg and click OK.

3 In the Distributed COM Configuration Properties dialog box, click the Applications 
tab and select Microsoft Word Document.

4 Click the Properties button. The Microsoft Word Document Properties dialog box 
opens. 

5 On the Security tab, do the following:

❑ Select Use custom access permissions and click Edit. 

❑ Add the Interactive User from the local machine and click OK. You return to the 
Microsoft Word Document Properties dialog box.

❑ Select Use custom launch permissions and click Edit. Add the Interactive User 
from the local machine and click OK. 

6 On the Identity tab, select The interactive User. 

7 Click OK twice to exit the distributed COM configuration. 

8 Reboot the PC before opening RequisitePro again.
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AKeyboard Shortcuts and 
Mouse Actions
Dialog Box Shortcuts

You can use keyboard combinations to move to tabs, fields, and buttons in a 
RequisitePro dialog box. To use a dialog box shortcut, press the ALT key while 
simultaneously pressing the underlined letter in a dialog box tab, field, or button. For 
example, in the Project Properties, Document Properties, or Requirement Properties 
dialog box, press ALT-G to open the General tab.

Menu Shortcuts

You can use combinations of keyboard shortcuts to open menus. To use a menu 
shortcut, press the ALT key while simultaneously pressing the underlined letter in the 
menu. For example, to open the Requirement menu, press ALT-R. When a menu is 
displayed, you can select a command by pressing the underlined letter in the 
command.

Selecting Multiple Items in RequisitePro

You can use mouse actions and combinations of keyboard and mouse actions to select 
more than one item in various RequisitePro lists.

The following are referred to as multiple select actions in RequisitePro 
documentation:

❑ SHIFT-click: To click the mouse button while holding down the SHIFT key.

❑ CTRL-click: To click the mouse button while holding down the CTRL key.

❑ Drag: To hold down the right mouse button while moving the mouse and then 
releasing the button.

You can use the actions in the following ways:

❑ To select adjacent items, use SHIFT-click or drag.

❑ To select nonadjacent items, use CTRL-click.
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The anchor is the first item you click when using multiple select actions to select a 
range of items. In RequisitePro, the term “anchor” is generally used to mean the first 
cell you click in a view. You use the anchor to select a range of cells. For example, if 
you click the cell in row 1, column 1 of a Traceability Matrix, that cell becomes the 
anchor. If you then SHIFT-click the cell in row 10, column 3 of the matrix, all of the cells 
in rows 1 through 10, columns 1 through 3, are selected. To reset the anchor, click 
anywhere outside the range. The cell you click is the new anchor. You can also use an 
anchor to select a range of items in documents and in certain dialog boxes that 
support multiple select actions.

Mouse Actions and Shortcuts in Views 

You can use keyboard shortcuts and mouse actions to quickly move around and select 
information in views. The keyboard shortcuts and mouse actions differ in each view. 

The following tables provide specific shortcuts for selecting items in an Attribute 
Matrix, a Traceability Matrix, or a Traceability Tree.

Attribute Matrix Mouse Actions and Keyboard Shortcuts

Mouse Actions

If you want to Do this

Select the requirement in the row in 
which you click. 

(This action also clears all selected items 
and sets the selected row as the anchor. 
Clicking in a cell also changes the 
selected column to the column in which 
you clicked.)

Click row label

OR

Click cell

Select the requirements between the 
anchor row and the row in which you 
SHIFT-click.

(This action clears any rows that are not 
in the range.)

SHIFT-click row label

OR

SHIFT-click cell in selected column

Set the selected row as the anchor, while 
keeping previously selected items 
selected.

OR

Clear a previously selected row while 
keeping others selected.

CTRL-click row label
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Keyboard Shortcuts

Switch the column selection to the 
column in which you click.

(Clicking in a cell also selects the row in 
which you clicked.)

Click column label

OR

CTRL-click column label

OR

CTRL-click in cell

If you want to Do this

Move to the right one column. RIGHT ARROW

Move to the right one column when in 
edit mode

OR

Switch between the Explorer and the 
open view.

TAB

Move to the left one column. LEFT ARROW

Switch between open views. CTRL-TAB

Move down one row.

(This action clears all selected items and 
sets the selected row as the anchor.) 

ENTER

OR

DOWN ARROW

Commit the new or modified 
requirement to the database when in 
edit mode.

ENTER

OR

TAB (when cursor is in last column of a 
requirement’s row)

Move up one row.

(This action clears all selected items and 
sets the selected row as the anchor.) 

SHIFT-ENTER

OR

UP ARROW

Activate the currently selected cell for 
editing.

(This action is only available when a 
single cell is selected.)

SPACEBAR

If you want to Do this
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Cancel the edit mode in the currently 
selected cell.

(This action is only available when a 
single cell is selected.)

ESC

Move to the top of the view and select 
the first row.

(This action sets the first row as the 
anchor and clears all other selected 
items.) 

HOME

Move to the top of the view and select 
all items between the anchor row and 
the first row of the view.

(This action clears all other selected 
items.)

SHIFT-HOME

Move to the top of the view, without 
changing the selection or the anchor.

CTRL-HOME

Move to the bottom of the view and 
select the last row.

(This action sets the last row as the 
anchor and clears all other selected 
items.) 

END

Move to the bottom of the view and 
select all items between the anchor row 
and the last row of the view.

(This action clears all other selected 
items.)

SHIFT-END

Move to the bottom of the view, without 
changing the selection or the anchor. 

CTRL-END

Move up one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or it selects the first row if the 
view is positioned on the top page. The 
newly selected row is the new anchor.)

PAGE UP

If you want to Do this
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Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was 
when its page was displayed, or it 
selects all rows from top to anchor if the 
view is positioned at the top of the 
page.)

SHIFT-PAGE UP

Move up one page in the view, without 
changing the selection or the anchor.

CTRL-PAGE UP

Move the view one page left. 

(This action selects the column that is in 
the same horizontal position as the 
previously selected column was when 
its page was displayed, or it selects the 
first column if the view is positioned on 
the far left page.)

ALT-PAGE UP

Move down one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or it selects the last row if the 
view is positioned on the bottom page. 
The newly selected row is the new 
anchor.)

PAGE DOWN

Move down one page in the view, 
without changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was 
when its page was displayed, or it 
selects all rows from the bottom to the 
anchor if the view is positioned at the 
bottom of the page.)

SHIFT-PAGE DOWN

Move down one page in the view, 
without changing the selection or the 
anchor. 

CTRL-PAGE DOWN

If you want to Do this
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Traceability Matrix Mouse Actions and Keyboard Shortcuts

Mouse Actions

Move the view one page right. 

(This action selects the column that is in 
the same horizontal position as the 
previously selected column was when 
its page was displayed, or it selects the 
last column if the view is positioned on 
the far right page.)

ALT-PAGE DOWN

Expand the selected row requirement to 
show its children in the view. 

SHIFT-PLUS SIGN

Collapse the selected row requirement 
to hide its children in the view. 

MINUS SIGN

Select every row in the view. CTRL-A

If you want to Do this

If you want to Do this

Select a cell.

(This action clears all other selected 
cells.) 

Click cell

Select all cells in the rectangle formed by 
the anchor cell and the clicked cell.

SHIFT-click cell

Set the cell as the anchor while keeping 
previously selected cells selected.

OR

Clear a previously selected cell while 
keeping others selected.

CTRL-click cell

OR

CTRL-click row label

OR

CTRL-click column label

Select the row and the cell(s) at the 
intersection of the selected row and the 
currently selected column(s). 

(This action clears all other selected cells 
and rows and sets the selected cell and 
row as anchors.)

Click row label
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Keyboard Shortcuts

Select the cells in all rows between the 
clicked row and the anchor row, in all 
selected columns.

(This action clears any rows and 
columns that are not in the range.)

SHIFT-click row label

Select the column and the cell(s) at the 
intersection of the selected column and 
the currently selected row(s). 

(This action also clears all other selected 
cells and columns and sets the selected 
cell and column as anchors.)

Click column label

Select the cells in all columns between 
the clicked column and the anchor 
column, in all selected rows.

(This action includes all selected rows.)

SHIFT-click column label

If you want to Do this

Move to the right one column. RIGHT ARROW 

Move to the left one column. LEFT ARROW

Move down one row. ENTER

OR

DOWN ARROW

Move up one row. SHIFT-ENTER

OR

UP ARROW

Display a shortcut menu for the 
currently selected cells.

SPACEBAR

Switch between the Explorer and the 
open view. 

TAB

Switch between open views. CTRL-TAB

Close the shortcut menu for the 
currently selected cells.

ESC

If you want to Do this
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Move to the top of the view and select 
all cells in the selected columns in the 
top row. 

(This action clears all other selected 
rows and sets the top row as the anchor.)

HOME

Move to the top of the view, without 
changing the anchor.

(This action selects all cells in selected 
columns between the top row and the 
anchor row.)

SHIFT-HOME

Move to the top of the view, without 
changing the selection or the anchor.

CTRL-HOME

Move to the bottom of the view in the 
selected column and select the cell in 
that column in the last row.

 (This action clears all other selected 
rows and sets the last row as the 
anchor.)

END

Move to the bottom of the view, without 
changing the anchor.

(This action selects all cells in selected 
columns between the bottom row to the 
anchor row.)

SHIFT-END

Move to the bottom of the view, without 
changing the selection or the anchor.

CTRL-END

Move up one page in the view, while 
changing the anchor.

(This action selects the selected columns 
and the row that is in the same vertical 
position as the previously selected row, 
or it selects the top row if the view is 
already on the top page. The newly 
selected row is the new anchor.)

PAGE UP

Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was 
when its page was displayed.)

SHIFT-PAGE UP

If you want to Do this
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Move up one page in the view, without 
changing the selection or the anchor.

CTRL-PAGE UP

Move the view one page left, while 
changing the anchor.

(This action selects the selected rows 
and the column that is in the same 
horizontal position as the previously 
selected column was when its page was 
displayed, or it selects the first column if 
the view is positioned on the far left 
page.)

ALT-PAGE UP

Move the view one page left, without 
changing the anchor.

(This action selects the cells in selected 
rows and the columns between the 
anchor column and the column that is in 
the same horizontal position as the 
anchor column was when its page was 
displayed, or selects the first column if 
the view is already on the far left page.)

ALT-SHIFT-PAGE UP

Moves left one page in the view, without 
changing the selection or the anchor.

ALT-CTRL-PAGE UP

Move the view down one page, while 
changing the anchor.

(This action selects the selected columns 
and the row that is in the same vertical 
position as the previously selected row 
was when its page was displayed, or it 
selects the last row if the view is already 
on the bottom page. The newly selected 
row is the new anchor.)

PAGE DOWN

Move down one page, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was 
when its page was displayed.)

SHIFT-PAGE DOWN

Move down one page in the view, 
without changing the selection or the 
anchor.

CTRL-PAGE DOWN

If you want to Do this
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Traceability Tree Mouse Actions and Keyboard Shortcuts

Mouse Actions

Move the view one page right, while 
changing the anchor.

(This action selects the selected rows 
and the column that is in the same 
horizontal position as the previously 
selected column was when its page was 
displayed, or it selects the last column if 
the view is already on the far right 
page.)

ALT-PAGE DOWN

Move the view one page right without 
changing the anchor.

(This action selects the selected rows 
and the columns between the anchor 
column and the column that is in the 
same horizontal position as the anchor 
was when its page was displayed, or it 
selects the last column if the view is 
already on the far right page.)

ALT-SHIFT-PAGE DOWN

Move right one page in the view, 
without changing the selection or the 
anchor.

ALT-CTRL-PAGE DOWN

Expand the selected row requirement to 
show its relationships. Preserve the 
previous row selection. 

SHIFT-PLUS SIGN

Collapse the selected requirement to 
hide its relationships. 

MINUS SIGN 

Select every cell in the view. CTRL-A

If you want to Do this

If you want to Do this

Select the clicked item.

(This action clears all selects items and 
sets the selected row as the anchor.)

Click row
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Keyboard Shortcuts

Select the items between the anchor row 
and the row in which you click. 

(This action clears any rows that are not 
in the range.)

SHIFT-click row

Set the selected row as the anchor, while 
keeping previously highlighted text 
selected.

OR

Clear a previously selected row while 
keeping others selected.

CTRL-click row

Copy a selected row's requirement to a 
new position. (The requirement cannot 
be a root requirement.)

CTRL-click row, then drag

Move a selected row's requirement. (The 
requirement cannot be a root 
requirement.)

ALT-click row, then drag

If you want to Do this

Move down one row DOWN ARROW

Move up one row UP ARROW

Display a shortcut menu for the 
currently selected requirements.

SPACEBAR

Switch between the Explorer and the 
open view.

TAB

Switch between open views. CTRL-TAB

Close the shortcut menu for the 
currently selected requirements.

ESC

Move to the top of the view and select 
the first row. 

(This action sets the first row as the 
anchor and clears all other selected 
items.)

HOME

If you want to Do this
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Move to the top of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the first row of the 
view.)

SHIFT-HOME

Move to the top of the view, without 
changing the selection or the anchor.

CTRL-HOME

Move to the bottom of the view and 
select the last row. 

(This action sets the last row as the 
anchor and clears all other selected 
items.)

END

Move to the bottom of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the last row of the 
view.)

SHIFT-END

Move to the bottom of the view, without 
changing the selection or the anchor.

CTRL-END

Move up one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or it selects the top row if the 
view is positioned on the top page. The 
newly selected row is the new anchor.)

PAGE UP

Move down one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously 
selected row was when its page was 
displayed, or it selects the last row if the 
view is positioned on the bottom page. 
The newly selected row is the new 
anchor.)

PAGE DOWN

If you want to Do this
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Move up one page in the view, without 
changing the anchor.

(This action moves up one page from 
the anchor.)

SHIFT-PAGE UP

Move down one page in the view, 
without changing the anchor.

(This action moves down one page from 
the anchor.)

SHIFT-PAGE DOWN

Move up one page in the view. CTRL-PAGE UP

Move down one page in the view. CTRL-PAGE DOWN

Expand the item to show its 
relationships.

SHIFT- PLUS SIGN

Collapse the item to hide its 
relationships. 

MINUS SIGN 

Highlight every item in the view. CTRL-A

If you want to Do this
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BCustomizing 
RequisitePro
Configuring RequisitePro

You can click Tools > Options to configure the appearance and behavior of Rational 
RequisitePro.

1 Click Tools > Options.
The Options dialog box opens.

2 Type or select the following options as needed:

General

❑ Show Buttons: Select this check box to display the toolbar buttons.

❑ Show Status: Select this check box to display the status line on the toolbar. This 
displays project and document status as you work in RequisitePro.

❑ Show ToolTips: Select this check box to display button function definitions 
when you hold the pointer over a toolbar button.

❑ Let's Go RequisitePro at startup: Select this check box to display the Let's Go 
RequisitePro splash screen each time you start RequisitePro.

Views

❑ Prompt for save: Select this check box if you want RequisitePro to prompt you 
to save changes to display options and view properties when you close an 
unsaved view. Changes to requirements and other data within the view are not 
affected. 

❑ Double-click to go to source: Select this check box if you want the option to 
double-click requirement in a view to access its source. For requirements 
located in documents, the document opens. For other requirements, the 
Requirement Properties dialog box opens. If this check box is cleared, 
double-clicking expands and collapses the requirement hierarchy.

❑ ENTER key inserts new line (multi-line only): Select this check box if you want to 
use the ENTER key to create a new line in an Attribute Matrix.
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❑ In-view requirements creation (without dialog box): Select this check box if you 
want to create requirements directly in the Attribute Matrix by clicking 
Requirement > New or the INSERT key. If this check box is cleared, the 
Requirement Properties dialog box opens when you click Requirement > New or 
the INSERT key.

❑ Font: This field lists the font displayed in views.

❑ Change: Click this button to change the font.

Traceability

❑ Warn on remove: Select this check box if you want RequisitePro to display a 
warning message when you remove requirement traceability.

❑ Changes logged in history: Select this check box to display changes to 
requirement traceability on the revision history list in the Requirement 
Properties dialog box.

Default Project Logon

❑ Username: This box contains (by default) the name of the user who last logged 
on successfully. This entry is used as the default name at your next attempt to 
log on to a RequisitePro project. Type another user name if necessary. 

Microsoft Word

❑ Version: Select your preferred version of Microsoft Word when you have more 
than one version installed. The option <Use Default> uses the current version of 
the application, which is recorded in the Windows registry.

Directories

❑ Document Outlines: This field defines a secondary location for accessing 
document type outlines. If RequisitePro is installed locally on your PC, the 
default path is <install drive>\Program Files\Rational\RequisitePro\outlines. Use this 
option to define an alternate location for outlines (for example, a directory on a 
server for shared outlines). Note that the document outlines directory and the 
secondary document outlines directory are stored for your own machine 
configuration, not for the RequisitePro project.

❑ ClearCase View: This field defines the directory for ClearCase archiving in 
RequisitePro. This must be a ClearCase view that is available to all users of the 
RequisitePro project.

❑ Working Path: This field displays the working directory for all your 
RequisitePro projects. Write permissions must be available for this directory in 
order for RequisitePro to create new projects and write temporary files.
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❑ Project Templates: This field defines a secondary location for storing project 
templates. If RequisitePro is installed locally on your PC, the default path is 
<install drive>\Program Files\Rational\RequisitePro\templates. Use this option to 
define an alternate location for project templates (for example, a directory on a 
server for shared templates). 

Rational XDE

❑ Start Preference: If you are using the Rational RequisitePro-XDE Integration 
and you have more than one edition of XDE on your system, you can designate 
one edition to open automatically from RequisitePro when no other edition of 
XDE is already open.

3 Click OK.

Customizing Toolbar Menus

The Add-ins command (on the Tools menu) allows you to add your own customized 
menu options to menus in RequisitePro. These menu options can be used to start 
external applications, such as e-mail or the Windows Notepad, directly from 
RequisitePro. In addition, you can configure an option to open an individual file with 
the application of your choice. You can add commands to any of the following 
RequisitePro menus: File, Edit, View, Requirement, Traceability, Tools, and Help.

You can add either a projectwide menu item for use by all members of the project 
team or a menu item that appears only when RequisitePro is open on your PC. The 
Add-ins command prompts you to specify an external menu file that defines your 
customized menu options.

1 Click Tools > Add-ins.
The Add-ins dialog box opens.

2 Click the Add button to add a customized menu option. 

3 In the Add-in dialog box, type a name for the menu option. This name identifies 
the menu file on your add-ins list.

4 Click the Browse button. The Select a RequisitePro Menu File dialog box opens.

5 Select a file type to display: All Files, Menu Files, or Text Files.

6 Navigate to a menu file and click Open.

7 Leave the Active check box selected, and select either Local to apply the menu 
items to your menus only or Project to apply the menu items to the menus of all 
users who open the project.

8 Click OK in each dialog box.

The options defined in the menu file are added to the specified menu.
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Creating a Menu File

Using any text editor, you can create a file to add menu options to menus in 
RequisitePro. The entries appear on the RequisitePro menu in the order in which you 
specify them. You can add commands to any of the following RequisitePro menus: 
File, Edit, View, Requirement, Traceability, Tools, and Help.

As you add menu entries, you specify:

■ Keywords that determine items on the menu (a submenu, a menu option, a 
separator)

■ Menu actions that execute an application or open a specific external file, such as a 
Readme file.

Pay close attention to the syntax rules that apply to your entries to the menu file. For 
example, the syntax of the menu specifications includes opening and closing braces 
{...}.

Note:  Rational Rose users may be familiar with creating menu specification files for 
extending the Rose Tools menu. RequisitePro menu files use the same syntax with a 
subset of the Rose functions.
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Menu File Template
Create your menu file in a text editor, based on the following template. Save your file 
with a .TXT extension or a .MNU extension to help locate the file easily in your file 
structure.

Menu <RequisitePro menu name>

{

Separator

Option <menu item>

{

Exec <command line>

Status <status text>

}

Menu <submenu name>

{

Option <menu item>

{

Exec <command line>

Status <status text>

}

Option <menu item>

{

Exec <command line>

Status <status text>

}

}

}
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Key Words
Use the following table to define the key words to copy into the menu file:

Menu names, submenu names, option names, and statuses require double quotes if 
they include more than one word. You can include more than one menu command in 
a file, and separators can be in menus or submenus. You can create a maximum of five 
levels of submenus (indented one below another). Add an ampersand (&) directly 
before a character in the menu name to create an underlined letter signifying an access 
key in the menu option.

Keywords and Variables Definitions and Valid Entries

Menu Keyword to specify the menu or submenu to 
which you want to add the menu items

Separator Keyword to place a separator in the menu

Option Keyword to specify the name of the item as it 
will appear on the menu

Exec Keyword to identify the command line to be 
run when the menu item is chosen

Status Keyword to identify the text for the status line

<RequisitePro menu name> File, Edit, View, Requirement, Traceability, 
Tools, Window, or Help

<menu item> User-defined text for an item on the menu or 
submenu

<submenu name> User-defined text identifying the name of the 
submenu

<command line> User-defined text identifying the commands to 
execute when the menu item is chosen

<status line> User-defined text identifying the text for the 
status line
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Sample Menu File
The following example shows a simple menu definition file. After you create a menu 
file, reference it using the Add-ins command. This feature allows you to add 
customized menu commands to the RequisitePro menus.

The following menu file instructs RequisitePro to add the command Open Windows 
Notepad to the Edit menu. 

Menu Edit

{

Separator

Option “Open Windows &Notepad . . .”

{

Exec notepad.exe

Status “Open the Windows Notepad”

}

}
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Glossary
The terms that follow are used throughout Rational RequisitePro User’s Guide. Most are specific to 
RequisitePro.

Special Symbols
.bak file.  A backup of a document file. A new .bak file is created in the same directory each time a 
document is saved and contains a version of the document before it was saved. You can delete .bak files 
at any time; they are created whenever the original documents are saved. 

.def file. A file, located in the RequisitePro outlines directory, that specifies information about a 
particular document outline used by RequisitePro. This type of file has the following format: 
outline_logical_name is the name of the outline (up to 64 bytes); outline_description is a description of 
the outline (up to 256 bytes); and outline_filename.dot is the name of the corresponding Microsoft Word 
template file. See document outline.

.doc file. A DOS file name extension for Microsoft Word documents. 

.dot file (Word template). A DOS file name extension for Microsoft Word template files. A Word 
template determines the basic structure for a document, including fonts, menus, special formatting, and 
styles. A Word template is associated with a document template, which can be used to create Word 
documents in RequisitePro. Document outline information is stored in .def files. You can edit the .dot 
files associated with your document types to include your company name and other information specific 
to your organization. You can enter the company name and other information in the Microsoft Word 
Properties dialog box (click File > Properties). Then in the document itself, right-click the 
Company-Name field, and select Update Field (Word template).

.rqs file. A text file, created and updated automatically by RequisitePro, that stores project-specific 
information. Every RequisitePro project has an .rqs file, which resides in the project directory. Do not 
modify any section of this file, except the [MSProjectMappings] section, as described in RequisitePro 
Help.

.~sr file. A text file created for each user who accesses a project. When a user opens a project, a file is 
written to the project directory with a unique system-generated file name and an extension of *.~sr. This 
file simply records the user ID, the type of access the user has to the project, and a session ID. The 
exclusive lock file name will always be exclusive.~sr. All other file names will begin with a prefix that 
indicates the type of project access reflected by the user in the project: RO indicates “read only” access, 
and RW indicates “read/write” access.

A
active document. The document that has processing focus. You can have more than one document open 
at a time; however, only one of the documents is active.
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active view. The view that has processing focus. You can have more than one view open at a time; 
however, only one of the views is active. See also view.

activity. A unit of work an individual, or a set of individuals working together as a team, may be asked 
to perform.

actor. Someone or something outside the system that interacts with the system.

Add-ins command.  A command on the Tools menu that allows you to add your own customized 
commands to any RequisitePro menu. These menu commands can be used to start external applications, 
such as e-mail or the Windows Notepad, directly from RequisitePro. In addition, you can configure a 
command to open an individual file with the application of your choice.

administrators group.  A group of users with full permissions to work in a project. These users can 
change a project’s structure, create and modify data, modify and delete projectwide views, and set and 
maintain security permissions. Users can be added and removed from the group, but the group cannot 
be deleted. Administrator group permissions cannot be modified.

analyst.  See system analyst.

anchor. The first item you click when using multiple select actions to select a range of items. In 
RequisitePro, the term anchor is generally used to mean the first cell you click in a view. You use the 
anchor to select a range of cells. For example, if you click the cell in row 1, column 1 of a Traceability 
Matrix, that cell becomes the anchor. If you then Shift-click the cell in row 10, column 3 of the matrix, all 
of the cells in rows 1 through 10 and columns 1 through 3 are selected. To reset the anchor, click 
anywhere outside the range. The cell you click is the new anchor. You can also use an anchor to select a 
range of items in documents and in certain dialog boxes that support multiple select actions. See multiple 
select actions.

archiving. The process of duplicating the database, documents, and all related files in a project for the 
purpose of restoring them at a later time.

attribute.  Descriptive information that provides important details about a requirement or discussion. 
See also requirement attribute.

attribute label.  The name of the requirement attribute, such as risk, priority, or author. Also referred to 
as requirement attribute label.

Attribute Matrix.  A spreadsheet-like table view that displays requirements in rows and the attributes 
that describe them in columns. You can add or change values in the attribute fields. Also referred to as 
requirement Attribute Matrix.

attribute type.  A set of descriptive and operational information associated with a requirement attribute 
when the attribute is created. Attribute values can be list-type or entry-type. For list-type attributes, you 
select a textual attribute value from a list box. For entry-type attributes, you type in a value, such as a 
number, text string, date, or time. Also referred to as requirement attribute type.

attribute value.  Information assigned to a requirement attribute. Attribute values can be text or 
numbers. For example, the attribute priority can be assigned the values Low, Medium, and High. Also 
referred to as requirement attribute value.

author. The user responsible for creating or modifying a document or requirement.

author (version information). The user responsible for the changes associated with a given revision. 
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B
baseline.  A reviewed and approved release of artifacts that constitutes an agreed basis for further 
evolution or development and that can be changed only through a formal procedure, such as change 
management and configuration control. See also Unified Change Management.

bookmark.  A marker inserted at a specific point in a document to which the user may return for later 
reference. In Microsoft Word, a bookmark is a location or selection of text named for reference purposes. 
Bookmarks are implemented in RequisitePro documents to designate requirement text. Bookmarks are 
designated by square brackets, as in the following: [example].

C
change description (version information). Textual information that specifies the justification or 
reasoning behind the changes associated with a given revision of a project, document, or requirement. 
See also version information.

change-managed relationship.  A connection between two requirements that implies dependency or 
another type of relationship. RequisitePro tracks two types of change-managed relationships: hierarchical 
relationships and traceability relationships. Changes to either of the requirements can cause a “suspect” 
condition in the relationship. See also suspect relationship state.

child requirement.  A requirement that participates in a hierarchical relationship with a parent 
requirement. A child can have only one parent requirement. See also parent requirement, hierarchical 
requirement.

circular traceability relationship.  A relationship between a requirement and itself, or an indirect 
relationship that leads back to a previously traced-from node. Traceability relationships cannot have 
circular references. RequisitePro checks for circular references each time you establish a traceability 
relationship. RequisitePro also checks for circularity when you create an external relationship. The 
circular check references only internal requirements and first-level external requirements.

ClearCase.  See Rational ClearCase.

ClearQuest.  See Rational ClearQuest.

collapse indicator. See expand/collapse indicator.

cross-project traceability. A RequisitePro feature that allows you to establish traceability relationships 
between requirements that reside in different projects. See also external traceability.

CSV file. A comma-separated value text file, commonly used to exchange files between database 
systems that use different formats. Sometimes called comma-delimited files, CSV files can be imported into 
RequisitePro.

D
deleted users group. A security group of users who have been removed from other groups, have no 
permissions, and cannot log on to RequisitePro. This group is maintained by the project administrator 
for project history.

dialog box. An interactive window displayed on the screen that solicits a response from the user.
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dialog box shortcut. See keyboard shortcuts.

directory. A catalog for file names and other directories. A directory is an organization of files (or 
folders) grouped for the user’s convenience. The topmost directory is called the root directory. The 
directories within a directory are called subdirectories. 

discussions. A RequisitePro feature that lets you address comments, issues, and questions to a group of 
discussion participants. Discussions can be associated with one or more specific requirements or refer to 
the project in general.

discussion item. A discussion item is either the initial discussion topic or a response. A response can be 
either to the initial discussion text or to another response.

document. Any Microsoft Word document. It may be part of the RequisitePro project or outside the 
project, and it may or may not contain requirements. See also requirements document.

document outline. A reference document or template used to create new documents in RequisitePro. An 
outline can include formats, page layout information, fonts, and Word styles. It is useful for maintaining 
consistency across documents of the same type. Document outline information is stored in a .def file. It 
includes the full name of the template, a description of the outline, and the associated Word template's 
DOS filename (.dot). See also document type. 

document properties. Specific items of information about a document. Documents have attributes 
associated with them such as author, date and time of last revision, and file name.

document type. Defines descriptive and operational information associated with a requirements 
document. The document type serves as a template for each requirements document you create of that 
type. The document type defines the document’s file extension, such as .prd; all documents of the same 
document type share the same file extension. The document type identifies a default requirement type; 
each new requirement you create in the document is based on the default requirement type unless you 
indicate otherwise. The document type also identifies a document template, which controls the 
document page layout, default text, paragraph styles, and other structure.

document version. A revision of a document, identified in the document properties revision history. A 
new version is created when a document is changed and saved. See revision.

E
enhancement request. A type of stakeholder request that specifies a new feature or functionality of the 
system. Certain Rational RequisitePro requirement types have attributes that associate the requirement 
with specific records in Rational ClearQuest. By default, if you are using a project based on the Use-Case 
Project template, the feature (FEAT) requirement type includes EnhancementRequest and Defect 
attributes that can associate the feature requirement with enhancement request and defect records in 
ClearQuest.

enterprise database. A database that is designed to support a large, networked organization. An 
enterprise database offers scalability, security, and administrative features for large, complex projects. 
RequisitePro supports the use of the enterprise databases Oracle and SQL Server. 

entry-type attributes. Entry-type attributes are numeric, text, time, or date values that are typed in by 
project users. An entry-type attribute can be configured with a default value, which users can accept or 
replace as they create or modify requirements. For example, if you want to set a default cost of $20, 
format the entry-type attribute “Cost” to accept integer values and have a default value of 20. You define 
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attributes in the Attributes tab of the Project Properties dialog box. Requirement attributes can be entry 
type or list type. If you have configured an integration with Rational ClearQuest, you have two 
additional default requirement types, EnhancementRequest and Defect. See also attribute type, attribute 
value. Compare list-type attributes.

exclusive access. A condition by which access to a RequisitePro project and its documents is available 
only to the user who opens the project. Exclusive access is required to change a variety of project 
characteristics. You set access when you open a project. You can open a project and its documents in 
exclusive mode only if the project and documents are not already open by another user.

expand/collapse indicator. A small box displayed next to a requirement in a view, indicating that the 
requirement has one or more child requirements, or next to a discussion item in the Discussions dialog 
box, indicating that the discussion item has responses. The box contains a + or a -, indicating whether or 
not the requirement or discussion is displayed in an expanded or collapsed state. An item that can be 
expanded (that is, preceded by a +) contains hidden subitems that can be displayed. An item that can be 
collapsed (that is, preceded by a -) does not have hidden subitems.

Explorer. RequisitePro’s primary navigation window. In this window, project artifacts (documents, 
requirements, and views) are displayed in packages in a tree browser. 

export. To move information from one system or program to another. You can export requirements from 
a RequisitePro view to Microsoft Word documents and to CSV files.

extension. See file name extension.

external project. A project containing requirements used to establish traceability relationships with 
requirements in a currently open project. See cross-project traceability.

external requirement. A requirement residing in an external project. You can create traceability 
relationships between requirements in different projects.

external traceability. Traceability relationships between requirements in two RequisitePro projects. See 
also traceability.

F
file name extension. A DOS file name extension (for example, .prd). File name extensions are used in 
RequisitePro to indicate document type and can contain a maximum of 20 characters.

filtering. A process by which you can change the amount of information displayed in a view. You specify 
certain criteria on which to filter information. You can filter requirements by specifying certain distinct 
criteria for any or all of their attributes. For example, instead of displaying all requirements, you might 
apply a filter to display only requirements having a high priority. See also sorting and query.

H
hidden text. A Microsoft Word feature used to hide text within a document. Hidden text is delineated 
with a dotted underline. A requirement within a Word document begins with a requirement tag 
formatted in hidden text style. You can hide the tags for improved readability. Click Tools > Options, 
and then click the View tab. Clear the Hidden text check box and click OK.
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hierarchical requirement. A requirement that is included within an ordered relationship with other 
requirements of the same type. Use hierarchical relationships to subdivide a general requirement into 
more explicit requirements. Child requirements provide additional detail for their parent requirement. 
For example: 
Parent requirement: The system shall display customer information.
Child requirements provided for detail: Name, Address, Date of Birth.
Each child requirement can have only one parent, but a requirement can be both a parent and a child. If a 
parent requirement is changed, the relationships with its children become suspect.

I
import. To bring information from one system or program into another. In RequisitePro, you can import 
documents and requirements from Microsoft Word and CSV files.

Integrated Use Case Management. An integration between Rational RequisitePro and Rational Rose 
that allows you to associate use cases in Rose with RequisitePro documents and requirements. You can 
easily navigate between Rose use-case models and RequisitePro use-case documents and requirements. 

internationalization. The process of developing a program core whose feature and code designs do not 
make assumptions on the basis of a single language or locale and whose source code base simplifies the 
creation of different language editions of a program.

K
keyboard shortcuts. A dialog box shortcut is a keyboard combination you can use to move to tabs, fields, 
and buttons in a RequisitePro dialog box. To use a dialog box shortcut, press the Alt key while 
simultaneously pressing the underlined letter in a dialog tab, field, or button. For example, in the Project 
Properties, Document Properties, or Requirement Properties dialog boxes, press Alt-G to open the 
General tab.
A menu shortcut is a keyboard combination you can use to open a menu. To use a menu shortcut, press 
the Alt key while simultaneously pressing the underlined letter in the menu. For example, to open the 
Requirement menu, press Alt-R. When a menu is displayed, you can select a command by pressing the 
key for the underlined letter in the command.

keyword. Words that are used to help specify and define requirements. Many organizations use words 
such as shall, must, or will in their requirements, making it easier to separate a requirement from 
surrounding text in the document. Keywords are a part of the definition of a requirement type. You enter 
keywords in the Requirement Must Contain box in the Requirement Type dialog box. 

L
label (version information). A string (no more than 20 characters long) that contains user-defined 
revision information. You can use a revision label for noting requirement, document, or project/archive 
version information.

licensed user. A RequisitePro user. Each user who is associated with a license of RequisitePro is a 
licensed RequisitePro user. Also referred to as user.
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list-type attributes. Requirement attributes are either list-type or entry-type. List-type attributes are sets 
of descriptive values (for example, Status, which may contain the list values Proposed, Approved, In 
progress, and Complete). You can assign single values or multiple values for list-type attributes. You 
define attribute values in the Attributes tab in the Project Properties dialog box. See also attribute type, 
attribute value. Compare entry-type attributes.

M
matrix. An arrangement of rows and columns used for organizing related items in a view. See Attribute 
Matrix, Traceability Matrix.

menu file. A text file with specific syntax that is used to add menu commands to any RequisitePro 
menu. Menu files typically have an MNU or TXT file extension. Menu files are referenced using the 
Add-ins command on the Tools menu. The commands appear on the RequisitePro menus in the order in 
which they are specified in the menu file.

menu shortcuts. See keyboard shortcuts.

Metrics. See Requirement Metrics.

multiple select actions. Mouse actions and combination keyboard/mouse actions that you use to select 
multiple items in RequisitePro. Use Ctrl-Click to select multiple items that are not adjacent to each other. 
Hold down the Ctrl key and click the mouse. (You can also use Ctrl-click to clear a selected item.) Use 
Shift-click to select a range of items. Hold down the Shift key and click the mouse. Use Drag to select a 
range of items. With one item selected, drag the mouse. Release the mouse when the range is selected.

multiple value list. An attribute type that supports one-to-many associations. You can use a multiple 
value list when you want to assign a requirement more than one value for a specific attribute.
For example, you might create an attribute type called Owner, with multiple values Bob, John, and Sue, 
representing different users working on the same project. For this attribute, you might then assign only 
the values Bob and Sue to a particular requirement, indicating that Bob and Sue are responsible for this 
particular requirement, but John is not.

N
name. See requirement name.

O
offline author. A user who takes a RequisitePro document offline.

offline authoring. A RequisitePro feature that lets users read and modify a document in Microsoft Word 
outside of RequisitePro (i.e., offline). When you take a document offline, RequisitePro creates a copy of 
the document in the directory you specify. The original is still stored in RequisitePro, but it is changed to 
a read-only document. Other users can view the document in RequisitePro, but they cannot edit it until 
you bring it back online.

OLE. Object linking and embedding. You can create an OLE object in one application (original 
application) and insert it into files in other (source) applications. If you modify the OLE object in its 
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original application, the changes are automatically reflected in any files containing the OLE object in a 
source application. You can use OLE objects in RequisitePro requirements documents.

outline. See document outline. 

P

package. A container, represented in the Explorer as a folder, that can contain requirements, documents, 
views, and other packages. You can place related artifacts in a single package for organizing your project. 
All project packages are shared by all project users.

parent requirement. A requirement that participates in a hierarchical relationship with one or more 
child requirements. A parent can reside at the root level, or it can be nested in the hierarchy with a parent 
of its own. In either case, parents reside above their children in the hierarchy. See also child requirement, 
hierarchical requirement.

parse. To break information into component parts so that a program can act upon it. The Import Wizard 
parses text to separate requirements in a document.

peer requirement. A requirement that is at the same hierarchical level as another requirement. Two 
requirements are peer requirements when they are children of the same parent. All requirements at the 
root level are peer requirements of one another. See also parent requirement, child requirement, hierarchical 
requirement.

pending requirement. A newly created requirement in a document or a view that has not yet been saved 
in the database.

pending tag number. A tag number for a newly created requirement in a RequisitePro document. The 
requirement maintains the pending tag number until the document is saved. See also requirement tag.

permissions. The RequisitePro privileges granted to a group of RequisitePro users. RequisitePro 
administrators or members of a group with project security permissions can assign permissions to 
groups. Also referred to as privileges or rights. See also security.

project. A RequisitePro project. A project includes a database, documents, document types, 
requirements and their attributes, requirement types, requirement traceability, discussions, and user and 
group security. Within RequisitePro, you create a project first. You then create requirement documents 
and requirements in each document.

project database. The requirements database managed by RequisitePro. The project database stores all 
requirements in the project, including those created in requirement documents. Changes you make to 
requirements in the documents are reflected in the project database. You can create requirements directly 
in the project database rather than in a requirement document using an Attribute Matrix view. These 
requirements can be modified or deleted in a view. Microsoft Access, Oracle, and Microsoft SQL Server 
databases can be used with RequisitePro projects. See also project database.

project directory. A directory that contains information for a single RequisitePro project. You define the 
project directory when you create a new project. (By default, RequisitePro creates a directory name that 
matches what is typed in the Name box in the RequisitePro Project Properties dialog box.) For projects 
that use the Microsoft Access database, the database is stored in the project directory. The project 
directory does not store the database for projects that use an enterprise database (i.e., Oracle and SQL 
Server databases). Requirements documents for the project may be stored in another directory. The 
project directory path can contain up to 256 characters. See also project directory.
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project prefix. An identifier used for requirements in cross-project traceability. In an external project, the 
prefix is displayed before the tag requirement, separated from the tag by a period. For example, if a 
requirement’s tag is PR234 and the project’s prefix is GLOBAL, then the external requirement is 
displayed as GLOBAL.PR234. The prefix can be up to 8 characters and must be uppercase letters. You 
can change the prefix at any time in the Project Properties dialog box, General tab.

project summary report. A report that displays the project’s entire structure in report form. The 
requirement types (and their attributes, including multiple value lists), document types, and document 
details are included in the printout.

project template. A RequisitePro template that contains project structure including document types, 
requirement types, requirement attributes, packages, users, groups, and security.

Q
query. A method for filtering and sorting requirements in views by limiting the values of one or more 
attributes or by limiting traceability, and specifying the order in which the filtered requirements are 
displayed. For example, you might create a query to display only requirements having a high or medium 
priority. Within that filter, you might sort requirements first by priority, and then by cost.

R

Rational Administrator. A Rational tool that enables integrations between Rational products. Use 
Rational Administrator to configure Rational projects, which store software testing and development 
information.

Rational ClearCase. Rational's configuration management tool, which can be used to store copies of 
RequisitePro projects. If you are implementing a Unified Change Management model, you can use 
ClearCase to create baselines of RequisitePro projects.

Rational ClearQuest. Rational’s defect and change tracking system. ClearQuest offers a flexible 
approach to track and manage all the change activities that are associated with an organization, such as 
defects and enhancement requests. 

Rational Rose. Rational’s visual modeling tool for designing and visualizing object-oriented and 
component-based applications. RequisitePro is integrated with Rose through Integrated Use Case 
Management.

Rational TestManager. A Rational tool designed to help software development and testing professionals 
track software testing information through all phases of the software development, test, and revision 
cycles. RequisitePro requirements can be referenced from TestManager to ensure complete test coverage 
for all requirements. If a requirement changes, TestManager marks the associated test cases and test 
input as suspect. Using TestManager, you can create reports that show all suspect test cases and test 
input development coverage reports that show the percentage of requirements that have implemented 
test cases. If you have installed TestManager, we recommend that you develop all test artifacts in that 
tool. 

Rational Unified Process (RUP). Rational’s online knowledge base of proven software-development 
principles. The RUP captures many of the best practices in modern software development in a form that 
can be tailored to a wide range of projects and organizations. The RUP includes Tool Mentors, which 
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provide descriptions on how Rational Software tools can be used to support particular steps and 
activities.

Rational XDE. Rational XDE Professional, an eXtended Development Environment that has been 
designed for developers and is fully integrated into the IBM WebSphere Workbench, IBM WebSphere 
Studio Application Developer, and Microsoft Visual Studio .NET. Its capabilities include pattern engine 
support, Unified Modeling Language (UML) visualization and documentation support, code templates, 
and automatic or on-demand synchronization of code and models. XDE Professional includes Rational 
XDE Modeler, which allows users to communicate designs and patterns in UML. Using XDE Modeler, 
team members can create semantically rich models for architecture, business needs, design, reusable 
assets, and management-level communication, which can then be used to generate working code. 
Developers can round-trip engineer changes, and architects can see whether architectural changes are 
required. Rational RequisitePro is integrated with XDE through Integrated Use Case Management.

read-only access. An option by which a RequisitePro project or document is restricted to viewing.

renumbering. The process of assigning new numbers to requirements. The renumber feature is useful 
for eliminating “holes” in a numbering scheme, which can result when you delete requirements. To 
renumber requirements, you must open the project in exclusive mode. In addition, if security is enabled, 
you must have project structure permission to renumber requirements. To renumber requirements in 
documents, all documents that contain requirements of that type must be open.

requirement. Describes a condition or capability that a system must provide; it is either derived directly 
from user needs, or stated in a contract, standard, specification, or other formally imposed document.

requirement attribute. A descriptive field of information associated with a requirement. RequisitePro 
requirement attributes are either system attributes (defined by RequisitePro) or user-defined (defined by 
the project owner). See attribute.

requirement attribute label. The name of the requirement attribute, such as risk, priority, or author. See 
attribute label. 

requirement Attribute Matrix. See Attribute Matrix.

requirement attribute type. See attribute type.

requirement attribute value. See attribute value.

requirement location. The location where a requirement was created or the location to which it was last 
moved. The location can be either a specific requirements document or the project database.

Requirement Metrics. A Rational RequisitePro feature for compiling statistics on requirement name, 
text, attributes, relationships, and revisions. These report results are displayed in Microsoft Excel and can 
be manipulated using Excel’s charting capabilities. Two types of reports are available: static reports 
(which show results about the project at the present time) and trend analysis reports (which use 
time-sensitive filters that analyze changes in requirement text, attributes, traceability, and hierarchical 
relationships).

requirement name. A user-defined title for a requirement. Like tag and text attributes, the name can be 
used to reference requirements. The name is displayed by default in all Rational RequisitePro views. All 
requirements must have either a name, text, or both, but requirements located in documents must have 
text. A name does not need to be unique and can be changed at any time if you created the requirement 
or belong to a group that has update permissions. 

requirement tag. The unique identifier of each requirement in a project. A requirement tag is composed 
of a tag prefix and a unique numerical value, such as “PR100.1.2.” The tag prefix is always the 
296 Glossary 



requirement type, as defined in the Project Properties dialog box. The numerical value is generated by 
RequisitePro. The tag prefix can contain a maximum of 20 characters. Each requirement type in your 
project has a different tag prefix (for example, FEAT, SR, UCS) that you determine when you create a new 
project or add a new requirement type. When you add a requirement to a requirements document or 
database, RequisitePro assigns the requirement the appropriate tag prefix, dependent on its requirement 
type, and an incremental numerical value. See also pending tag number.

requirement text. The full textual content of a requirement. In a document, it may include embedded 
and linked objects, such as graphics, tables, and Microsoft Word files.

requirement type. A set of descriptive and operational information associated with a requirement when 
the requirement is created. A requirement type serves as an outline for all requirements of the same type 
and is useful for classifying and grouping similar requirements in a project. Each requirement type has 
its own set of user-defined attributes. See also requirement attribute.

requirement version. A requirement attribute that shows the version of the requirement. As a 
requirement evolves, it is helpful to identify the version numbers (and history) of requirements changes.

requirements document. A document created in Microsoft Word or RequisitePro that captures 
requirements and is used to communicate product development efforts. Each requirements document 
addresses a particular requirement type, such as product features, use cases, and supplementary 
specifications. A RequisitePro requirements document differs from a Word document in that you can 
access requirement attributes and other information directly from within the requirements document. 
Also referred to as document or RequisitePro document.

requirements management. A systematic approach to eliciting, organizing, documenting, and 
managing the changing requirements of a software application.

requirements text. The full textutal content of a requirement. In a document, it may include embedded 
and linked objects, such as graphics, tables, and Microsoft Word files.

RequisitePro document. A Microsoft Word document that is part of a RequisitePro project. Most Word 
functionality is available within RequisitePro documents.

RequisiteWeb. Rational’s Web interface that allows clients to access RequisitePro requirements 
information across an intranet. By using browsers -- Netscape Navigator or Microsoft Internet Explorer -- 
RequisiteWeb provides a thin client solution to access project documents and data. No Requisite 
application-specific files need to be installed on individual machines.

revision. A distinct version of a project, document, or requirement. A revision is identified by a unique 
internal revision number, generated by RequisitePro.

revision number. The number identifying a revision. Revision numbers are automatically incremented 
each time you or another user changes and saves a project, document, or requirement. Revision numbers 
take the form M.n, where M is generally 1 and n is a 4-digit number that is incremented each time 
changes are saved.

root requirement. A requirement at the uppermost level of the requirements hierarchy. A root 
requirement does not have a parent requirement. See also parent requirement, child requirement, hierarchical 
requirement.

Rose. See Rational Rose.

RUP. See Rational Unified Process.
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S
security. Prevention of system use, potential harm, or data loss by unauthorized individuals. In 
RequisitePro, users are given specific permissions that determine the level of access they have to projects. 
If you are a RequisitePro administrator or a member of a group with project security permissions, you 
can assign permissions. See also permissions.

Select. See multiple select actions.

SHIFT-click. See multiple select actions.

SoDA. Rational’s Software Documentation Automation tool.

sorting. The process of establishing a specific order for the information in a RequisitePro view. You can 
sort requirements using one or many requirement attributes. For example, you might sort requirements 
first by priority (high, medium, or low). Then, within priority, you might sort again by unique ID 
number. See also filtering, query.

suspect relationship state. A state applied to a traceability or hierarchical relationship when a change 
occurs to one or both of the requirements in the relationship. A suspect relationship state indicates that, 
because of the modification to one or both requirements, the relationship may require modification as 
well. When suspect relationships are displayed in an Attribute Matrix, an (s) appears after the 
requirement tag in the Traced-to or Traced-from column. See also change-managed relationship, Traceability 
Matrix.

system analyst. An individual who leads and coordinates requirements elicitation and use-case 
modeling by outlining the system’s functionality and delimiting the system.

T

tag. See requirement tag.

tag prefix. The prefix for a requirement type. A tag is a unique identifier assigned to each requirement 
you create. The tag prefix can be up to 20 characters long, and it is defined as a part of the requirement 
type.

template. See .dot file (Word template) or project template.

TestManager. See Rational TestManager.

text. See requirement text.

trace to/trace from relationship. A relationship between two requirements that implies the source, 
derivation, or dependencies between the requirements. The trace to/trace from state appears in a 
Traceability Matrix or Traceability Tree when you create a relationship between two requirements.
For example, you might create a feature requirement (Requirement A) that calls for a new command to 
be added to a particular menu in your application. Creating this requirement might cause you to create a 
software requirement (Requirement B) associated with that menu item. You would thus create a 
traceability relationship in which the software requirement (B) is traced from the feature requirement 
(A). There can be only one traceability relationship between any two requirements. The difference 
between calling it a “trace to” or “trace from” relationship is one of perspective. For the example above, 
both of the following statements are true: A is traced to B, and B is traced from A. In RequisitePro, the 
terms trace to/trace from relationship and traceability relationship are used interchangeably.
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traceability. A relationship between two requirements that implies the source, derivation, or 
dependencies between the requirements using the “trace to” and “trace from” features.

Traceability Matrix. A view that illustrates the relationships between requirements of the same or 
different types. You use this matrix to create, modify, and delete traceability relationships and view 
indirect relationships and traceability relationships with a suspect state. You can also use the Traceability 
Matrix to filter and sort the row requirements and column requirements separately. See also view. 

traceability relationship. See trace to/trace from relationship.

Traceability Tree. A view that displays all internal and external requirements traced to or from a 
requirement (depending on the direction of the tree). The Traceability Tree displays only the first level 
cross-project traceability. For example, if an internal requirement is traced to an external requirement, the 
external requirement is displayed in the Traceability Tree, but other requirements that the external 
requirement is traced to are not displayed in the tree. Also referred to as a tree view. See also view. 

tree view. See Traceability Tree.

type. See requirement type.

U

Unified Change Management (UCM). Rational's out-of-the-box usage model for managing change in 
software system development, from requirements to release. UCM is a unified approach to configuration 
management and change request management, automated in Rational ClearCase and Rational 
ClearQuest. ClearCase can be set up to implement the UCM model for basic activity-based configuration 
management or in conjunction with ClearQuest to provide full change-request management. To 
implement the UCM model when creating a baseline of a Rational RequisitePro project, the project must 
be associated with a UCM-enabled Rational project in the Rational Administrator.

Universal Naming Convention (UNC). The system of naming files among computers on a network so 
that a file on a given computer will have the same path when accessed from any of the other computers 
on the network. For example, if the directory c:\path1\path2\...pathn on computer servern is shared 
under the name pathdirs, a user on another computer would open \\servern\pathdirs\filename.ext to 
access the file c:\path1\path2\...pathn\filename.ext on servern. Also called Uniform Naming Convention. 

use case. A sequence of actions that a system performs, yielding an observable result of value (a work 
output) to a particular actor (someone or something outside the system that interacts with the system).

user information. A RequisitePro user’s user name, password, and e-mail address. If you are a member 
of a group with project security permissions, you can edit another user’s information. In addition, a user 
can edit his or her own user information.

users group. A security group that can, by default, read documents and requirements, create views, and 
participate in discussions. Administrators can modify Users group permissions.

V
version information. Unique, identifying information associated with a project, document, or 
requirement each time it is modified. The internally generated revision number, combined with 
information about the author, date, time, and reason for modification, constitute version information. See 
also revision.
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view. A window that displays requirements, the attributes assigned to requirements, and the 
relationships between requirements. A view displays information in spreadsheet-like tables or in outline 
trees. In RequisitePro, the terms view and view window are used interchangeably. See also Attribute Matrix, 
Traceability Matrix, Traceability Tree.

W

wildcard character. A keyboard character that can be used to represent one or many characters. 
Typically the asterisk (*) represents one or more characters, and the underscore (_) represents a single 
character. For example, the file specification *.* (pronounced “star-dot-star”) uses the asterisk wildcard to 
mean “any combination of file name and extension.” When filtering the subject of discussions, the 
percent symbol (%) is the wildcard character used to represent one or more characters.

Word document. A document created in Microsoft Word or RequisitePro that is saved in Word format. 
See also RequisitePro document.

Word Template. See .dot file.
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Index
A
Add Attribute 217
adding

discussions 67
document types 220
projects to the project list 30
requirement attributes 228
requirement types 225
users to a security group 184

adjusting
column width in views 50
row height in views 50

administrators group 182
alphabetizing discussions 77
annotating change 122
answering discussions 72
application programming interface 63
Archive command 200
archived projects, retrieving 202
archiving

Oracle projects 204
projects 200, 202
restoring projects 207
SQL Server projects 204
using Rational ClearCase 202, 204, 244
using RequisitePro Archive command 204

arranging
icons 52
views 51

assigning
attribute permissions 190
attribute value permissions 191
document type permissions 187
group permissions 186
new parents to a single requirement 139
new parents to multiple requirements 140
requirement type permissions 188

associating requirements with new types 124
Attribute Matrix 40, 56

attribute labels 41
definition 21, 37
denotation of suspect traceability 38, 41
exporting as a CSV file 167

graphics and OLE objects 41
keyboard shortcuts 267
mouse actions 266
querying in 56
requirements 40
shortcuts 266
text panes 41
Word-linked files 41

attribute pane 45
attribute values

assigning permissions 191
deleting 233
modifying 122, 232
sorting by 55

attributes, see requirement attributes
Auto Suspect

and cross-project traceability 151
and hierarchical relationships 144
and Spelling Checker 144, 151

B
backing up projects

Oracle 204
SQL Server 204

backups
advantages of logical 205
creating using the Archive command 200
disadvantages of logical 205
image 206
logical 204
offline image 206
online image 206
storing 200

baseline
creating a RequisitePro project from 19

baselines
creating a RequisitePro project from 178
RequisitePro projects 208
with Unified Change Management 200

bookmarks 156
removing 156
saving 156
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building queries 57

C
canceling security 182
cascade view 51
causes of project failure 1
cells 42
change affects suspect (option) 231
change history 11, 23
change management 16
change-managed relationships 24, 25
changing, see modifying
checking

whether a document is offline 102
child requirements 135

changing to root requirements 142
ClearCase

archiving projects using 202
integrations with RequisitePro 244

clearing
suspect relationships 144
suspect traceability 152

ClearQuest
associating a requirement 243
using with RequisitePro 242

closing
discussions 83
documents 89
nonproject documents 95
RequisitePro 36

collapse all 47
collapsing 47
column width in views 50
COM Server 63
comma separated value (CSV) file, see also CSV 

files 49
Composite Template 172
configuring

edition of Rational XDE to open with Requi-
sitePro 279

e-mail 66
RequisitePro 279

connecting projects for cross-project traceability 
235

converting earlier versions of projects 179
copying

projects 211

requirements 126
corrupted document, fixing 92
Create RequisitePro Project dialog box 171
creating

backups using the Archive command 200
cascade view 51
child requirements in the Explorer 136
discussions 67
discussions within the Requirement Proper-

ties dialog box 82
document types 220
documents 85, 221
menu files 282
MS Project tasks from requirements 251
multiple requirements in a document 112
outlines 224
outlines in secondary directory 224
packages 218
peer requirements

in a view 137
projects 171

with project wizard 177, 207
queries 57
reports 198
requirement attributes 228
requirement information in a discussion 80
requirement types 225
requirements 111

in an Attribute Matrix 119
in a document 109
in the Explorer 109
from a table 113
in a Traceability Matrix 118
in a Traceability Tree 118
in a view 117
including nontextual elements 111
in offline documents 103
troubleshooting 259

RequisitePro projects 171, 175
RequisitePro projects from a baseline 178
security groups 183
tile view 52
traceability

in an Attribute Matrix 147
in a Traceability Tree 149
in a Traceability Matrix 148
in requirements document 145
in views 147
in Word documents 145
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traceability between requirements 146
views 45, 46

cross-functional teams 9
cross-project traceability 234

across database types 56
across enterprise databases 174
and Auto Suspect 151
connecting projects 235
disconnecting projects 237
displaying 63
displaying in exported views 63
marking requirement types 234
overview 234
querying requirements 56
results 62
reviewing project 62
views 63

CSV files
copying header 164
defining header 163
definition 161
exporting views as 167
importing 153, 161, 164
requirements in exported files 63

customizing
menus 281
RequisitePro 279
views 49

cutting requirements 126

D
Data Transport Wizard 212, 213
data types for requirement attributes 230
database 18

Microsoft Access 18, 173
moving 212
Oracle 173, 212
searching 59
selecting 173
SQL Server 173, 212
troubleshooting 260
viewing with Microsoft Access 238

database conversion. See moving 214
database corruption 260
default view properties 53
deleted users group 182
deleting, see also removing

attributes for MSPT requirement types 258
document types 223
hierarchical requirements 142
projects from the project list 31
queries 59
requirements 132
security groups 183
users from a security group 185
views 49

dialog box shortcuts 265
disabling security 182
disconnecting projects from external traceability 

237
discussion groups 65
discussion items 65
discussions 65– 83

attributes 77
closing 83
configuring e-mail for 65
creating 67
creating requirement information for 80
displaying 74
displaying for a single requirement 74
filtering 75
icon 65, 71
locating 74
modifying 77
modifying requirement information in 80
notifying participants about 71
ordering 77
participants 65
participants information 78
printing 77
properties 70
reading 71
responding to 65, 72

in RequisitePro 72
using e-mail 73

setting up projects for 65
sorting 77
unread 65
viewing 65, 71, 75, 77

Discussions icon 65, 71
displaying

RequisitePro toolbar in Word 99
displaying, see also viewing

cross-project traceability 63
discussions 74
suspect traceability 151
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view properties 52
document not found message 261
document outline 280
document types

adding 220
adding to your project 221
creating 220
definition 220
deleting 223
permissions 187
removing 223
using to create a document 221

documentation for Rational products xvii
documents 85–??, 85– 106

changing information 220
changing location 91, 95
closing 89
closing Microsoft Word 95
closing nonproject documents 95
creating 85
definition 22
determining whether offline 102
importing from Microsoft Word 157
importing to another project 154
locking 93
Microsoft Word 93, 94
modifying information 92, 220
offline 100, 102
opening 31, 32, 35, 88
outlines 23, 224
protecting 93
recovering an AutoRecover document 262
refreshing requirement color and style 130
reviewing changes 90
saving 87, 89
saving in Microsoft Word 154
searching 60
storage 171
taking offline 100
tracking changes 98
unlocking 93
viewing information 220

.dot files 222
drag and drop to create traceability relationships 

149

E
editing

document information 220
.dot files 222
outlines 222

e-mail
changing 36
configuring for discussions 65
configuring notification 66
modifying 36
notifying participants about discussions 71
Rational E-mail Reader 67
receiving notification of discussions 35
responding to discussions using 73
typing addresses in project security 66

Embedded Elements Detection Wizard 108, 110
enabling security 182
ending discussions 83
enterprise databases 18, 173, 180, 211
enterprise databases. See also SQL Server, Oracle

distributing projects across types 173
equations

inserting in requirement text 116
Excel 153

importing CSV files 161
exclusive access 33
expand all 47
expanding 47
Explorer 20, 30

creating child requirements 136
creating requirements 109
refresh 38

exporting 167
cross-project traceability 63
CSV files 167
requirements as Word document 168

extended editing 108, 123
external projects

disconnecting 237
relocating 238

F
failed multiple select actions 150, 261
file types 215
filter

creating 197
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requirements 55
filtering

discussions 75
hierarchical relationships 56

filtering and sorting 55
see also querying, queries

Find command 59, 60
finding

discussions in projects 74
FURPS model 107

G
General Protection Faults 262
Getting Started tours xvii
Go To command 59

H
hierarchical relationships 24, 39, 135

creating child requirements 135
in documents 136
in the Explorer 136
in a view 135

creating peer requirements 137
deleting 142
exporting 168
filtering 56
parent requirements 138
sorting 56

hierarchy 37–??, 135– 144

I
icons, arranging 52
image backups 206
import logs 153
Import Wizard 156

using to export requirements 167
exporting as a Word document 168
exporting CSV files 167

using to import CSV files 164
using to import Word files 156

importing
attribute matching 165
converting documents to Word 154

converting individual documents to Word 
155

creating a log file 153
CSV files 161, 164

copying CSV file header 164
define new requirements option 166
defining CSV file header 163
preparing files 162
requirement numbers 162
update attributes of existing requirements 

option 167
from Access 153
from Excel 153
from Oracle 153
from SQL Server 153
from Word 156
import logs 153
Microsoft Word documents and require-

ments 156
document only option 161
requirements and document option 157
requirements only import option 160

prerequisites 153
project setup 153
recommended use 153
requirements and document 157
requirements from a Word document to a 

RequisitePro document 156
RequisitePro documents 154
saving and removing bookmarks 156
Word document to a RequisitePro project 156
Word documents

requirements and document import 
option 157

inserting Microsoft Word-linked files in require-
ments 114

Integrated Use Case Management 245
integrations xix

with Rational ClearQuest 242
with Rational XDE 241
with Microsoft Project 248
with Rational ClearCase 202, 244
with Rational Robot 247
with Rational Rose 244
with Rational SoDA 194, 242, 247
with Rational TestManager 247
with Unified Change Management 244

invalid date/time errors 263
in-view editing 108, 119
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K
key words 112
keyboard shortcuts 265

L
Let’s Go RequisitePro xvi
linked files, inserting in requirements 114
locating, see also finding
locking project documents 93
log file 153
logging into RequisitePro 35
logical backups 204, 205

M
macros, making available when taking docu-

ments offline 102
managing

change 16
changing requirements 7
external Word documents 99
Microsoft Word documents 94
projects 193
requirements xvii, 1, 3, 12, 15

master documents 97
menu file, sample 285
menu shortcuts 265
menus

creating menu files 282
customizing 281

metrics 64, 194
information types 194
running from the command line 199

Microsoft Access 18, 153, 173
importing CSV files 161

Microsoft equations
inserting in requirement text 116

Microsoft Project 248
Microsoft Word

bookmarks 103
closing 95
converting all documents when importing 

154
converting individual documents when 

importing 155

creating a Word document from a Requi-
sitePro requirements document 99

editing a requirements document outside of 
RequisitePro 99

enabling macros 105
exporting a view 168
hidden text 103, 108
improving Word performance 96
managing external Word documents 99
master documents 97
requirements in exported files 63
tips for using in RequisitePro 95, 126, 129
troubleshooting 261
unavailable Word commands 99
using the track changes feature 98
using to modify offline documents 102
using Word options for "hidden" require-

ments 98
working with documents 93
working with Word styles 96

Microsoft Word-linked files 108
inserting in a requirement 114
saving requirements documents 87
traceability 117

modifying
attribute values 122
child requirements 142
discussion attributes 77
discussion participants 78
discussion properties 70
discussions within the Requirement Proper-

ties dialog box 82
document information 92
e-mail 36
location of documents 91
offline documents 102
parent requirements 138
passwords 35
project information 217
requirement information in a discussion 80
requirements 122
user name 35

mouse actions 265
moving

documents 91
external projects 238
packages 219
project data to a SQL Server database 214
project data to an Oracle database 213
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projects 210
requirements 126, 129
requirements to a new document 92
text to a new document 92
users to another security group 186

MSPT 249
deleting attributes 258

N
naming projects 174
navigating

in a document 59
in an Attribute Matrix 266, 267
in a Traceability Matrix 270, 271
in a Traceability Tree 274
in a view 59
in an Attribute Matrix 266
to a requirement 59
in views 38

O
offline authoring 100

bringing documents back online 104, 105
creating requirements in offline documents 

103
deleting requirements in offline documents 

103
determining whether a document is offline 

102
making available Word macros when using 

102
modifying offline documents 102
obtaining information about offline docu-

ments 102
overview 100
reading offline documents 106
renaming 100
saving offline changes 104
taking documents offline 100
and unsaved changes 105
Word master documents 97

offline documents
and revision numbers 203

offline image backup 206
OLE objects 41, 43, 45, 108, 133

online Help xvi
online image backup 206
Open Project dialog box 29
opening

documents 31, 32, 35, 88
projects 31, 32, 35

exclusive access 33
read-only mode 33

views 48
Oracle 18, 153, 173, 212

archiving projects 204
configuring 173
and cross-project traceability 56
importing CSV files 161
moving projects 212
and multiple projects 18
tips when using 173

Oracle database, converting to 213
ordering discussions 77
outlines 222, 224, 280

assigning to document types 223
creating 224
creating secondary location 224
editing 222
types included with RequisitePro 223
using RequisitePro 223

P
packages 20, 218

arrangement of artifacts 30
creating 218
deleting 219
moving 219
organizing 218
project structure 30, 218
querying 218
querying requirements 55
renaming 219
security 218

parent, changing 138
parent-child relationships 24, 39

see also hierarchical relationships 24
parsing, definition 159
participants

notifying about discussions 71
responding to discussions 72

passwords
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changing 35
editing 185
limitations 184
modifying 35
new 184

peer requirements 137
Performance Studio 247
permissions

attribute permissions 190
attribute values 191
document type 187
establishing for a project 181
group 186
groups and users 182
requirement text 190
requirement type 188

printing
discussions 77
project summaries 193
reports 193
views 48

problem analysis 5
project

database 18
failure 1
modifying 154
security 154

project access 33
Project Administration Tips xvii
project administrators xv, xvi
project information, modifying 217
project list 19

adding projects 30
removing projects 31

project management 193
project scope management 7
project security

adding users to a group 184
administrators group 182
assigning permissions 186
creating groups 183
deleted users group 182
deleting groups 183
deleting users from a group 185
editing passwords 185
editing user name 185
groups and users 182
moving users 186
permissions 186

typing e-mail addresses 66
users group 182

project summaries, printing 193
project template 172, 281

creating 177
project version control 19
project wizard 177, 207
projects 18

adding 30
archiving 200, 202
components 171
connecting for cross-project traceability 235
converting earlier versions 179
copying 211
creating 171, 175

with project wizard 177, 207
creating a baseline 208
creating from a baseline 178
cross-project traceability 62
definition 18
disconnecting from external traceability 237
discussion 65
file types 215
groups and users 182
list 19
locating discussions in 74
managing 193
modifying information 217
moving 210
naming 174
opening 31, 32, 35
overview 171
printing summaries 193
relocating 238
removing from the project list 31
renaming 210, 217
revision information 207
security 181
storing backup copies 200
structure through templates 172
upgrading 179

properties for views 52
protecting documents for revisions 93

Q
queried views 55
queries 41
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adding to report 197
building 57
creating 57, 197
creating and modifying sort order 58
deleting 59
on requirements in packages 55
saved in views 47
sort by attribute value 55
sort by document position 58
traced to/traced from 56
updating 56

query, definition 55
querying 55– 64

advanced 63
criteria 55
and cross-project traceability relationships 56
display in an Attribute Matrix 56
display in a Traceability Matrix 57
display in a Traceability Tree 57
multiple requirement types 56
on location attribute 58
on packages 218
trace from criteria 56
trace to criteria 56
traced to/traced from 56

Quick Tour xvii

R
Rational Administrator 242, 244

creating a baseline 208
creating a RequisitePro project from a baseline 

179
Rational Administrator New Project Wizard 179
Rational ClearCase 202, 244
Rational ClearQuest 242

associating a requirement 243
Rational Developer Network xvii
Rational E-mail Reader 67
Rational product documentation xvii
Rational RequisitePro Tutorial xvii
Rational Robot 247
Rational Rose integrations 244
Rational SoDA 194, 242, 247
Rational Suite 241
Rational Suite Performance Studio 247
Rational Suite TestStudio 247
Rational Team Unifying Platform 241

Rational TeamTest 247
Rational technical support xx
Rational Unified Change Management 244
Rational Unified Process 248
Rational University xvii
Rational XDE

using 241
reading

discussions 71
offline documents 106

read-only documents 106
rebuilding damaged tags 130
recommended reading xvi, 13
recovering an AutoRecover document 262
references 13
refining the system definition 7
refresh

Explorer 38
queries 56
requirements 131
views 38

Refresh command 56
relationship

suspect 39, 41, 43
traced to/traced from 26

deleting, see also removing
requirements

in offline documents 103
removing, see also deleting 31

attribute values 233
bookmarks 156
document types 223
documents 209
queries 59
requirement types 227
requirements 209

renaming projects 210, 217
renumbering requirements 131, 193
replying to discussions 72
reports

opening and editing 199
printing 193
running 198
saving 198

requirement attributes 17
adding 228
and scope management 7
creating 228
data types 230
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deleting for MSPT types 258
modifying values 122
multidimensional 11
permissions 190
removing values 233
viewing in an Attribute Matrix 41

Requirement commands to create traceability 
relationships 149

requirement management
scope 7

Requirement Metrics 64, 194
creating filter 197
Query pane 196
Report pane 196
running from the command line 199
static report 64
trend analysis 64
types of reports 195

requirement name 109
Requirement Name Conversion Wizard 124
requirement tags

rebuilding 130
viewing in an Attribute Matrix 40

requirement types 8, 17
adding 225
changing 124
creating 225
definition 17, 225
marking for cross-project traceability 234
MSPT 249
new 124
overview 1
permissions 188
removing 227

requirements 17, 107– 134
assigning new parents 138, 139

in a view 140
in the Explorer 140
to multiple requirements 140

associating with ClearQuest records 242
associating with new types 124

multiple requirements 125
attribute values 109
can’t create 117
categories 107
change history 11
changing child to root 142
changing parents 138
color, refreshing 132

copying 126
copying from view 127
creating 111

child requirements 135
from a table 113
in an Attribute Matrix 119
in a document 109
in a Traceability Matrix 118
in a Traceability Tree 118
in a view 117
in the Explorer 109
including nontextual elements 111
multiple 112
in offline documents 103
peer requirements 137
troubleshooting 259
with Microsoft Word-linked files 114

creating from Traceability Tree and Traceabil-
ity Matrix views 108

creating peers in a view 137
cutting 126
cutting from view 127
definition 2, 17, 107
deleting 132
deleting in offline documents 103
description 109
discussion information 82
document types 19
e-mail discussions 66
exporting 167, 168
extended editing 110
filter 55
filtering and sorting 55
Find command 60
finding 59
hidden text 108
hierarchical relationships 135
importing 157
inserting equations in Word-linked files 116
key words 112
locating discussions associated with 74
managing changing 7
modifying information 122
moving 126, 129
moving to a new document 92
name length 109
naming 109
navigating to 59
numbering when imported 162
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numbers 162
parent-child relationships 135
querying 55
rebuilding tags 130
recording changes 122
refreshing 131
refreshing color and style 132
refreshing color and style in a document 130
renumbering 131, 193
restrictions on editing 110
revising properties 120
revising text 120
revision information 121
searching for 59
sort by document position 58
sorting 56
style, refreshing 132
suspect 143
suspect relationships 151
tag 108
text delimiters 112
text length 109
traceability relationships 145– 152
tracking changes in Word documents 98
troubleshooting 117
types 107
unmarking in a document 133
Word style 112

requirements and document import option 157
requirements authors xv, xvi
requirements contributors xv, xvi
requirements documents, see documents
requirements management 1, 12, 15

activities that promote success 13
and changing requirements 7
definition 3
fundamentals 1– 13
Managing Software Requirements book xvii
and problem analysis 5
problems of 4
and project scope 7
reference xvii
refining system definition 7
skills 5– 8
and stakeholder needs 5
system definition 6
and use cases 1

Requirements Management Tour xvii
Requirements menu 146

Requirements Metrics
creating queries 197

requirements only import option 160
requirements viewers xv, xvi
RequisitePro xvii

and change management 16
closing 36
improving Word performance 96
incorrect appearance of menu 263
and Microsoft Word 94
process support 17
and team collaboration 15

RequisitePro Extensibility Interface 63, 108
RequisitePro integrations xix
RequisitePro toolbar

displaying in Word 99
RequisiteWeb 16, 108
resizing

tree pane 44
views 51

responding to discussions 65, 72
using e-mail 73
using RequisitePro 72

restoring projects from an archive 207
retrieving archived projects 202
reviewing changes in a document 90
revising requirement properties 120
revision information 121, 203, 207
revisions, protect for 93
Robot 247
roles of users and security groups xv
Rose integrations 244
Rose use case

associated with a document or requirement 
246

associating documents with 246
row height in views 50

S
saving

bookmarks 156
documents 87, 89
documents in Microsoft Word 154
documents without the bookmarks 88
queries in views 47
requirements document as Word file 94
view properties 53
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views 47
searching

active view 60
for artifacts 59
database 59
documents 60
Find command 60
Go To command 59
for project artifacts 59
views 60

security 181
consequences of disabling 181
disabling 182
enabling 182
groups and users 182

security groups xv
adding users 184
creating 183
deleting 183
deleting users 185
moving users 186

selecting
database type 173
items in an Attribute Matrix 266
items in a Traceability Matrix 270
items in a Traceability Tree 274

selecting multiple items 265
shortcuts 265

dialog box 265
in an Attribute Matrix 266
in a Traceability Matrix 270
in a Traceability Tree 274
menu 265
in views 38

SoDA 194, 242, 247
sort by document position 58
sorting

default order 55
definition 55
discussions 77
hierarchical relationships 56
requirements 56

sorting and filtering 55
see also querying, queries

Spelling Checker
without Auto Suspect 151

SQL Server 18, 153, 173, 212
archiving projects 204
configuring 173

converting 214
and cross-project traceability 56
importing CSV files 161
moving project data 214
moving projects 212
and multiple projects 18
tips when using 173
troubleshooting syntax errors 264

stakeholder needs 5
starting RequisitePro 29
Suite products 241
suspect relationships 26, 42, 45, 143, 151

change affects suspect option 231
clearing 144, 152
definition 135, 145
denotation in Attribute Matrix 38, 41
displaying 151
traceability changes 25

system definition 6

T
tags, rebuilding 130
TeamTest 247
technical support xx
template

Composite Template 172
creating a project template 177
default packages 177
project 172, 281
project structure 172
Traditional Template 172
Use Case Template 172

templates
benefits of using 24
project 24

terminating discussions 83
terms 287
test artifacts 224
TestStudio 247
text delimiters 112
text pane 45
tile view 52
time controls, setting 198
toolbar, displaying 99
traceability 9, 25, 38, 145– 152

changes to linked files 117
clearing suspect relationships 152
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creating
in an Attribute Matrix 147
in a Traceability Matrix 148
in a Traceability Tree 149
in a view 147
in requirements document 145
using requirements menu 146
in Word documents 145

cross-project 234
direct and indirect 26
direction of 45
in MS Project 252
and Microsoft equations 116
overview 85, 145
suspect relationships 25, 151

Traceability Matrix 22, 41, 56
cells 42
definition 22, 37
direct and indirect relationships in 41
exporting as a CSV file 167, 168
graphics and OLE objects 43
keyboard shortcuts 271
mouse actions 270
navigating in 270
querying in 56
suspect relationships 41
text panes 42
tracing to/tracing from relationships 41

traceability relationships
using drag and drop to create 149
using Requirement commands to create 149

Traceability Tree 22, 43, 57
attribute pane 45
definition 22, 37
exporting as a CSV file 167, 168
graphics and OLE objects 45
mouse actions 274
querying in 57
text pane 45

traced from 26, 38, 41
traced to 26, 38, 41
track changes 93, 98
Traditional Template 172
training xvii
tree pane 44
troubleshooting

creating requirements 259
database corruption 260
document not found message 261

failed multiple select actions 150, 261
General Protection Faults in Page View mode 

262
invalid date/time errors 263
Microsoft Word files are too big 261
recovering an AutoRecover document 262
RequisitePro menu appears incorrectly 263
SQL Server syntax errors 264
when creating requirements 117
Word automation server error message 264

tutorials xvii

U
Unified Change Management 19, 178, 208, 244

baseline projects 200
Universal Naming Convention 86
Universal Naming Convention paths 171
unlocking project documents 93
unmarking requirements 133
upgrading a RequisitePro project 179
Use Case Management, Integrated 245
Use Case Template 172
use cases and requirements management 1
user name

changing 35
editing 185
modifying 35
restrictions 184

user roles xv
users group 182
using Word options for "hidden" requirements 

98
using Word’s track changes feature 98

V
values, attribute

deleting 233
modifying 232

view properties
displaying 52
saving as default 53

Viewing 38
viewing

database with Microsoft Access 238
viewing, see also displaying
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discussion attributes 77
discussion participants 78
discussion properties 70
discussions 65, 71, 75, 77
offline documents 106

views 37– 53
adjusting column width 50
adjusting row height 50
arranging 51
arranging icons 52
cascade 51
collapse all 47
copying requirements in 127
creating 45, 46
creating peer requirements 137
cross-project traceability 63
customizing 49
cutting requirements in 127
deleting 49
displaying properties 52
expand all 47
exported 63
exporting as Word document 168
exporting to a CSV file 49
navigating 38, 59
navigating in 38
opening 48
printing 48
properties command 52
refresh 38
resizing 51
saving 47
saving queries in 47
searching 60
tile 52

viewing hierarchy in 39

W
Web 16
white papers and technical notes xvii
Windows NT 214
wizards

Data Transport Wizard 212, 213
Database Upgrade Wizard 179
Embedded Elements Detection Wizard 108, 

110
Import Wizard 153
Rational Administrator New Project Wizard 

179
Requirement Name Conversion Wizard 124

Word automation server error 264
Word format 154
Word style 112
Word, see Microsoft Word
Word-linked files

displaying outside the document 116
equations 116
presentation in Attribute Matrix 41
presentation in Traceability Matrix 43
presentation in Traceability Tree 45

working in RequisitePro 29

X
XDE

using with RequisitePro 241
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