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Preface
About This Manual

This manual provides a basic description of Rational ClearQuest. It also provides an
overview of how to deploy ClearQuest in an organization, from planning and setting
up a defect and change tracking process, through working on and managing defects.
For instructions on how to install ClearQuest on Windows, see the Installation Guide for
Rational Server Products and the Installation Guide for Rational Desktop Products. For
instructions on how to install ClearQuest on UNIX, see the Installation Guide for
Rational ClearQuest.

Where appropriate, this manual refers you to specific locations in the ClearQuest
documentation for detailed information about individual procedures and concepts.

User Roles and the ClearQuest Documentation Set

The documentation for ClearQuest consists of printed and online task-oriented
information that supports ClearQuest administrators, schema designers, and client
users. The information in this manual applies to these roles as follows:

Role Typical tasks Chapters to read

Administrator Plans the change management
process for an organization, creates
and customizes ClearQuest
schemas, maintains databases, and
troubleshoots the change
management system.

Chapter 1, Overview of
ClearQuest and ClearQuest
MultiSite

Chapter 2, Planning a Change
Management Process

Chapter 3, Administering and
Customizing ClearQuest

Chapter 4, Using ClearQuest
xiii



The Clear Quest Documentation Roadmap in the next section shows how the
ClearQuest documentation set is organized to support these roles.

Designer Designs and customizes schemas to
fit the organization’s change
management process.

Chapter 1, Overview of
ClearQuest and ClearQuest
MultiSite

Chapter 2, Planning a Change
Management Process

Chapter 3, Administering and
Customizing ClearQuest

Chapter 4, Using ClearQuest

Project Manager Assigns change requests to
members of the project team.
Creates queries, charts, and reports
to track progress.

Chapter 1, Overview of
ClearQuest and ClearQuest
MultiSite

Chapter 4, Using ClearQuest

User Creates, updates, transitions, and
reports on change request records
in a ClearQuest client interface.

Chapter 1, Overview of
ClearQuest and ClearQuest
MultiSite

Chapter 4, Using ClearQuest

Role Typical tasks Chapters to read
xiv Introduction to Rational ClearQuest



ClearQuest Documentation Roadmap

More Information
Online documentation

Help files

Administration

Project 
Management

Orientation

Database
Design

Installation Guide (Rational Desktop Products)

Installation Guide (Rational Server Products)

Installation Guide (UNIX)

Administrator's Guide (Rational ClearQuest)

Administrator's Guide (Rational ClearQuest MultiSite)

Upgrade Guide (Rational Suite)

Using Project Tracker
(Windows platforms;

see online
documentation)

Introduction

Release Notes
(See online documentation)

Designer tutorials
(See online documentation)

Administrator's Guide
(Rational ClearQuest)

API Reference
(See online 

documentation)
Preface xv



ClearQuest Integrations with Other Rational Products

Online Documentation

Rational ClearQuest includes online documentation, as follows:

Help System: Use the Help menu, the Help button, or the F1 key.

Reference Pages: On Windows, to display a reference page for Rational ClearQuest
MultiSite, at the command prompt type multiutil man command-name.

API Reference: Click Start > Programs > Rational Software > Rational ClearQuest >
Rational ClearQuest API Reference.

Integration Description Where it is documented

ClearQuest-
Base ClearCase

Associates change requests
with versions of ClearCase
elements.

ClearCase: Developing Software

ClearCase: Managing Software
Projects

ClearQuest: Administrator’s Guide

ClearQuest-PurifyPlus Allows developers to invoke
ClearQuest from PurifyPlus.

PurifyPlus Help
ClearQuest: Administrator’s Guide

ClearQuest-
RequisitePro

Allows developers to invoke
ClearQuest from RequisitePro
and to associate requirements
with ClearQuest change
requests.

Rational Suite: Administrator’s Guide

ClearQuest: Administrator’s Guide

ClearQuest-SoDA Collects information from
ClearQuest and presents it in
various report formats.

Using Rational SoDA for Word

Using Rational SoDA for Frame

SoDA Help

ClearQuest-
Test Manager

Allows developers to invoke
ClearQuest from TestManager.

Using Rational TestManager

ClearQuest: Administrator’s Guide

ClearQuest-Robot Allows developers to invoke
ClearQuest from Robot.

Rational Robot User’s Guide
Rational Robot Help

ClearQuest-UCM Links UCM activities to
ClearQuest records.

ClearCase: Developing Software

ClearCase: Managing Software
Projects

ClearQuest: Administrator’s Guide
xvi Introduction to Rational ClearQuest



Tutorial: Click Start > Programs > Rational Software > Rational ClearQuest >
ClearQuest Designer Tutorial.

PDF Manuals: Navigate to:

■ On UNIX, cquest-home-dir/doc/books

■ On Windows, cquest-home-dir\doc\books

Customer Support

If you have any problems with the software or documentation, please contact Rational
Customer Support by telephone, fax, or electronic mail as described below. For
information regarding support hours, languages spoken, or other support
information, click the Support link on the Rational Web site at www.rational.com.

Your
location

Telephone Facsimile Electronic mail

North
America

800-433-5444
toll free or
408-863-4000
Cupertino, CA

408-863-4194
Cupertino, CA
781-676-2460
Lexington, MA

support@rational.com

Europe,
Middle
East, and
Africa

+31-(0)20-4546-200
Netherlands

+31-(0)20-4546-201
Netherlands

support@europe.rational.com

Asia Pacific 61-2-9419-0111
Australia

61-2-9419-0123
Australia

support@apac.rational.com
Preface xvii
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1Overview of
ClearQuest and
ClearQuest MultiSite
Rational ClearQuest is a customizable defect and change tracking system designed for
the dynamic environment of software development. With ClearQuest, you can manage
every type of change activity associated with software development, including
enhancements, defects, and documentation modifications.

ClearQuest shortens development cycles by unifying your entire team in the process
of managing software change requests:

■ Development engineers can identify and prioritize action items that pertain to
their section of code.

■ Technical writers can locate development change requests that require
enhancements to the documentation, as well as change requests pertaining to the
documentation itself.

■ Test engineers can record the defects they find and track the status and resolution
of change requests to verify software quality.

■ Project leaders and managers can get information at a glance to help them allocate
development resources, streamline work flow, and accurately determine release
dates.

■ Administrators can customize ClearQuest to fit an organization’s process and
workflow by integrating it with existing tools.

Rational ClearQuest

ClearQuest consists of several components that work together in a client-server
environment. ClearQuest users access your databases by using Windows or UNIX
desktop clients, or by using a Web browser to access Web clients hosted on servers
running the Microsoft Internet Information Server (IIS). Your ClearQuest databases
can be hosted on either Windows or UNIX servers, but the ClearQuest Administration
Tools can only be run on Windows. For more information about the client and server
components of ClearQuest, see Table 1.
1



Table 1 ClearQuest Components

Component Used by Tasks
For more
information

Client user interfaces

ClearQuest Windows
client

Everyone Submit, modify, and
track change requests,
and analyze project
progress by creating
and updating queries,
charts, and reports.

See Using the
ClearQuest Windows
Client on page 23, or
see the ClearQuest
Help.

ClearQuest UNIX
client

Everyone Submit, modify, and
track change requests,
and analyze project
progress by creating
and updating queries,
charts, and reports.

See Using the
ClearQuest UNIX
Client on page 24, or
see the ClearQuest
Help.

ClearQuest Web client Everyone Access ClearQuest
across multiple
platforms by using
Netscape Navigator,
Internet Explorer, or
Mozilla to submit,
modify, and track
change requests, and
support project
analysis by creating
and updating queries
and reports.

See Using the
ClearQuest Web Client
on page 25, or see the
ClearQuest Help.

Administrative tools

ClearQuest Designer ClearQuest
administrator and
schema designer

Customize
ClearQuest, manage
ClearQuest schemas
and databases, and
administer users and
user groups.

See Designing and
Customizing Schemas
on page 15, or see the
information about
customizing a schema
in the Administrator’s
Guide for Rational
ClearQuest.
2 Introduction to Rational ClearQuest



ClearQuest
Maintenance Tool

Everyone Set up and connect to
the schema repository
during installation
and when you
upgrade to a new
ClearQuest version.

See Designing and
Customizing Schemas
on page 15, or see the
information about
working with
ClearQuest schemas
in the Administrator’s
Guide for Rational
ClearQuest.

Rational E-Mail
Reader

ClearQuest
administrator

Enable ClearQuest
users to submit and
modify records by
e-mail.

See Administering
ClearQuest E-Mail on
page 20, or see the
information about
administering
ClearQuest e-mail in
the Administrator’s
Guide for Rational
ClearQuest.

ClearQuest User
Administration Tool

ClearQuest
administrator

Create users and user
groups, set user IDs
and passwords,
assign users to user
groups, import and
export users and user
groups between
schemas, subscribe
users and user groups
to databases, and
search for users.

See the information
about administering
users in the
Administrator’s Guide
for Rational
ClearQuest.

ClearQuest Import
Tool

ClearQuest
administrator

Import data,
including records,
history, and
attachments from
other change request
systems and between
ClearQuestdatabases.

See Exporting and
Importing ClearQuest
Data on page 20, or
see the information
about importing data
in the Administrator’s
Guide for Rational
ClearQuest.

Table 1 ClearQuest Components (Continued)

Component Used by Tasks
For more
information
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Ready-to-Use Defect Tracking System

ClearQuest includes predefined schemas that provide ready-to-use defect and change
tracking processes and integrations with various Rational Software products. You can
use ClearQuest schemas as is or customize them to fit your organization’s workflow.
For a list of ClearQuest predefined schemas, see Selecting a ClearQuest Schema on
page 16.

Support for Your Development Environment

ClearQuest provides the following support for your software development
environment:

■ Lets you consistently manage a defect tracking process within a specific
development project or throughout the entire company.

■ Integrates with Rational ClearCase and Microsoft Visual SourceSafe so you can
associate change requests directly with changes in your evolving software.

■ Integrates with Rational TeamTest, VisualTest, Purify, PureCoverage, and
Quantify, letting you submit change requests to ClearQuest directly from these
testing tools.

■ Supports an integration with Microsoft VisualStudio 6 and VS.Net.

■ Supports an integration with Seagate’s Crystal Reports 8.5 Professional Edition so
you can create custom reports from ClearQuest data.

ClearQuest Export
Tool

ClearQuest
administrator

Export ClearQuest
data from one
ClearQuest user
database to another
user database.

See Exporting and
Importing ClearQuest
Data on page 20, or
see the information
about exporting data
in the Administrator’s
Guide for Rational
ClearQuest.

On Windows,
ClearQuest MultiSite
Administration Tools
On UNIX, multiutil

ClearQuest MultiSite
Administrator

Create and manage
replicas of schema
repositories and user
databases.

See the Administrator’s
Guide for Rational
ClearQuest MultiSite.

Table 1 ClearQuest Components (Continued)

Component Used by Tasks
For more
information
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■ Lets you integrate with other standard Windows tools, such as Microsoft Excel,
Word, and Project, through an advanced COM interface.

■ Provides access to Rational Unified Process through the ClearQuest Help > Rational
Extended Help menu.

■ Supports Sybase SQL Anywhere (included with ClearQuest), Microsoft Access,
Microsoft SQL Server, Oracle relational databases, and IBM DB2.

■ Supports Microsoft IIS Web server.

ClearQuest MultiSite

Rational ClearQuest MultiSite adds a powerful capability to Rational ClearQuest. With
MultiSite, developers at different locations can use the same defect-tracking database
set (a schema repository and its associated user databases). Each site has its own replica
set (copy of the database set). At any time, changes made in one replica can be sent in
update packets to other replicas. The update process can be automated or can be
started manually with a command.

An organization can use MultiSite to distribute independent, but related, development
efforts across multiple cities, nations, or continents. For example, a company in the
United States has development and testing sites in India, Argentina, Japan, and
Australia. Because it is not practical for all engineers to access the defect-tracking
databases in the United States, the company uses MultiSite to distribute the
development.

MultiSite can also be used at a single geographical location to let independent groups
work with the same development data or to be a backup mechanism. For example, a
company that wants extra reliability for backups can create local replicas for a
defect-tracking database set. For more information about ClearQuest MultiSite, see the
Administrator’s Guide for Rational ClearQuest MultiSite.

Defining ClearQuest Schemas, Schema Repositories,
Databases, and Connections

When you use ClearQuest, you work with a variety of objects, including ClearQuest
databases, schemas, schema repositories, database sets, and connections. The
following sections define these components and explain how they work together as
part of a change management system.
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Schemas

A ClearQuest schema is a complete description of the process model for one type of
change request. This includes a description of the states and actions of the model, the
structure of the data that can be stored about the individual change request, hook code
or scripts that can be used to implement business rules, and the forms and reports used
to view and input information about the change request.

The schema is a pattern or blueprint for ClearQuest user databases. When you create a
database to hold user data, the database follows the blueprint defined in a schema.
However, a schema is not a database itself: it does not hold any user data about change
requests, and it does not change when users add or modify data in the user databases.

Schema Repositories

ClearQuest stores schemas in a special type of database called a schema repository,
which is also sometimes referred to as a master repository or a master database.

A schema repository can store multiple schemas, for example, one schema for defect
change requests and another schema for feature enhancement change requests. In
Figure 1, the schema repository stores both Schema A and Schema B.

The schema repository can also include multiple versions of the same schema. A new
version is created each time changes are made to a schema, for example, by changing
an action or adding a new report. In Figure 1, the schema repository stores three
versions of Schema A and two versions of Schema B.
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Figure 1 Schema Repositories and Schemas

Databases

A database in ClearQuest is a collection of user data for one process model.

You associate each database with a specific version of a specific schema. For example,
in Figure 1 each user database uses a version of a schema stored in the schema
repository. The schema defines the way the data is stored and changed in that database
(that is, the database is an instance of a version of a schema). Users change data in the
databases when they add or modify information about change requests, but these
changes have no effect on the schema.

Databases contain a record for each change request.  As the change request moves
through its lifecycle, the data stored in this record changes accordingly.

You can create and associate multiple databases with a single schema. For example, if
you have three projects that use the same process model for correcting defects, you
could create one database for each project and associate all three with the same schema.
In Figure 1 two user databases use Version 3 of Schema A.

User Database
Schema

Repository

Schema A

Version 1
Version 2
Version 3

Schema B

Version 1
Version 2
Chapter 1 - Overview of ClearQuest and ClearQuest MultiSite 7



Connections

One schema repository and all of its associated user databases is called a connection or
a database set (see Figure 1). Typically all of the schemas and databases for one project
will be included in one connection. However, one connection can support multiple
projects, or one project can have multiple connections.

For a complete description about how to work with schemas and databases, see the
Administrator’s Guide for Rational ClearQuest.
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2Planning a Change
Management Process
This chapter provides a brief explanation of a change management system as well as
an overview of the steps an administrator should follow when planning a change
management process. For more information, see the Administrator’s Guide for Rational
ClearQuest.

After you outline your change management process, you can customize one of the
predefined Rational ClearQuest schemas, or create a new schema to best implement
your process. For more information, see Chapter 3, Administering and Customizing
ClearQuest.

Understanding Change Management Systems

When you use a change management system in your organization, you can implement
and manage consistent change management process models.

For each change request type, you can do the following:

■ Define a process model with states, actions, and rules.
■ Program customized rules that control when and how actions can be performed.
■ Create forms that let participants in the system access change requests,

communicate with each other, and perform appropriate actions.
■ Build reports and queries that give managers visibility into the status of individual

change requests, classes of change requests, and all of the change requests
associated with a project.

A change management system ensures that individual change requests go through a
change request lifecycle according to the correct policies and procedures of the
organization, while simplifying the work of the development team.

A change management system also provides management tools to assign work and
manage workloads, track the progress of projects, improve teamwork, and
continuously improve processes and products.
9



Identifying Scope

The first step in planning your change management process is to determine the scope
of the process to ensure that its execution will be complete, concise, and effective. You
may decide to apply the process to a single project team, one department, or multiple
departments, but the process should include all of the groups directly affected by
change requests.

Constructing a Change Management Process Model

A change management process model (also called a state transition model) is a
systematic representation of the possible steps in one change request lifecycle.  This
model defines the lifecycle in terms of the states that the change request passes through,
the actions that are taken to move between the states, and the rules that define when and
how the actions can be taken.

The state of a change request is its current status. Typical states include submitted,
assigned, opened, postponed, duplicated, resolved, and closed.

An action is an activity that moves a change request from one state to another (a state
transition). Typical actions include assign, reject, open, postpone, duplicate, validate,
resolve, and close.

Rules define when and how an action can be taken. For example, the ability to use a
Validate action to move a change request from a Resolved state to a Closed state might
be restricted to quality assurance engineers.

A process model can be illustrated in a diagram, as shown in Figure 2. In this diagram
states are shown as ovals and actions are represented by arrows.
10 Introduction to Rational ClearQuest



Figure 2 Change Management Process Model

Identifying Key Roles

The change management process that you construct affects many groups and
individuals in your organization. You must identify these key roles in your process and
get their approval before implementing the change management system. The key roles
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Resolved

Closed
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Unduplicate

Duplicate
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in every change management process differ, but Table 2 lists roles that are common in
many organizations.

Designing a Workflow Diagram

After you define the key roles in your change management system, you need to create
a workflow diagram to indicate how each of the roles will interact with the change
request throughout its lifecycle. A workflow diagram is a visual representation of the
relationships between the roles, tasks, and artifacts in your change management
system.

Table 3 shows a text-based example of a change request’s lifecycle in a product
development organization. Creating a similar table may help you to design your
workflow diagram.

Table 2 Common Key Roles

Role Change management responsibility

Customer Uses the product or service your organization
provides. Typically, customers are the source of
most change requests. The success of the product or
service depends on how these requests are
managed.

Change Control Board (CCB) Reviews the incoming change requests and
determines how each individual request will be
handled.

Manager Requires information to help assign and schedule
work related to the change request.

Solution Provider (Developer) Receives the change requests from the CCB.
Develops the proper solution to resolve the change
request.

Tester Evaluates the resolution of a change request. It is the
tester’s responsibility to ensure that the resolution
implemented by the developer provides a
satisfactory answer to a change request.

Technical Writer/Training
Course Developer

Requires information about documentation
impacted by the change request resolution.
12 Introduction to Rational ClearQuest



Of course, the lifecycle of a change request can be more complicated than the one
shown in Table 3. Based on the key roles you defined for your system, there may be
more (or fewer) parties involved, and the change request might be rejected, revised,
reassigned, postponed, duplicated, and otherwise modified or rerouted.

Deploying and Enforcing the Change Management
Process

In order to deploy and maintain your change management process successfully, you
must make sure to enforce all of the rules and policies defined by your change
management process model.

To minimize interference with change management operations, you should refrain
from frequently revising the system. When it is necessary to revise the existing change
management process, you should:

■ Develop a project plan to document the details of changes.

■ Get sign-offs from all affected teams.

■ Test the system thoroughly before it goes live.

Table 3 Change Request Lifecycle

Team Member Role in the change request lifecycle

User Submit a change request

Change Control Manager Review and accept the change request

Project Manager Assign and schedule work

Engineer Perform the work to resolve the change
request

Tester Verify the solution in a test build

Systems Integrator Verify the changes in a release build
Chapter 2 - Planning a Change Management Process 13
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3Administering and
Customizing
ClearQuest
This chapter is for Rational ClearQuest administrators and schema designers, or
anyone who is responsible for performing ClearQuest administrative or customization
tasks. It provides brief descriptions of the tools you use to perform administrative or
customization tasks on Windows, including:

■ Designing and customizing a ClearQuest schema.

■ Working with schema repositories.

■ Exporting ClearQuest data.

■ Importing ClearQuest data.

■ Sending e-mail notifications.

This chapter also includes sections that describe the UNIX and Web methods of
administering ClearQuest.

Before you read this chapter, you should be familiar with the concepts of schemas,
schema repositories, databases, and connections described in Defining ClearQuest
Schemas, Schema Repositories, Databases, and Connections on page 5.

For complete information about administering and customizing ClearQuest, including
a description of how to get your ClearQuest users up and running, see the
Administrator’s Guide for Rational ClearQuest. To take the ClearQuest tutorial, click
Start > Programs > Rational Software > Rational ClearQuest > ClearQuest Designer
Tutorial.

Designing and Customizing Schemas

The ClearQuest Designer is a client/server tool included with ClearQuest that you can
use to perform many administrative and customization tasks. As a ClearQuest
administrator or schema designer, you can use the ClearQuest Designer to browse,
design, and modify a schema in a schema repository. Creation and modification of a
schema may include:

■ Defining the layout of data.

■ Building a process model for each change request type.
15



■ Adding programming for the process models.

■ Creating forms, charts, and reports.

You can also use the ClearQuest Designer to:

■ Create a test database to examine the modified schema before checking it in.

■ Create a new user database.

■ Upgrade a user database with the latest version of a schema.

■ Create and modify user accounts and permissions with the ClearQuest User
Administration Tool.

Other members of the development team typically do not have permission to work
with schemas. However, you can assign them permissions to make specific changes
such as modifying queries and reports.

Note: You can also access the ClearQuest User Administration Tool from the Windows
Start menu by clicking Start > Programs > Rational Software > Rational ClearQuest >
ClearQuest User Administration.

Starting the ClearQuest Designer

To start the ClearQuest Designer:

1 Click Start > Programs > Rational Software > Rational ClearQuest > Rational
ClearQuest Designer.

ClearQuest provides a default user name, admin, that you can use to get started.
Do not type a password. The admin user account is set up with the access
privileges you need to perform all ClearQuest administrator functions. To change
the admin account, click Tools > User Administration, select the admin user, and
click Edit.

For more information about user-access privileges, see the information about
administering users in the Administrator’s Guide for Rational ClearQuest.

2 In the Open Schema dialog, check out a schema if you are planning to modify it
and click Finish; otherwise click Cancel to continue.

Selecting a ClearQuest Schema

Table 4 lists the predefined schemas that are included with Rational ClearQuest.
ClearQuest schemas consist of various packages that provide specific functionality.
You can add individual packages to an existing ClearQuest schema or to your own
customized schema. For complete descriptions of ClearQuest schemas and packages,
see the Administrator’s Guide for Rational ClearQuest.
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Customizing a Schema

When you use ClearQuest, the process of working with a record, along with the
appearance of the record form and fields, is defined by the ClearQuest schema. As a
ClearQuest administrator or designer, you can create a ClearQuest schema that best
implements the change management process planned for your organization. For more
information, see Chapter 2, Planning a Change Management Process.

You can use one of the schemas provided with ClearQuest as is, customize an existing
schema, or create a new schema from scratch. Whichever option you choose, you use
the ClearQuest Designer to perform the following schema modification tasks:

■ Adding states to your change request lifecycle.

Table 4 Predefined Schemas

Schema Description

AnalystStudio Compatible with Rational Suite Analyst Studio.
Contains customization for use with Rational
RequisitePro.

Blank Contains only system fields. Use this schema to
create a schema from scratch.

Common Contains metadata that is common to all
ClearQuest schemas.

DefectTracking Contains the fields necessary to start using
ClearQuest to track defects in a software
development environment.

DevelopmentStudio Compatible with Rational Suite
DevelopmentStudio. Contains fields and rules that
work with Rational Purify, Quantify, and
PureCoverage.

Enterprise For use with Rational Suite EnterpriseStudio.
Contains fields and hooks that work with all
Rational products.

TestStudio Compatible with Rational Suite TestStudio.
Contains fields and rules that work with Rational
TeamTest, RequisitePro, Purify, Quantify, and
PureCoverage.

UnifiedChangeManagement Supports the UCM process by providing
integration with Rational ClearCase.
Chapter 3 - Administering and Customizing ClearQuest 17



■ Adding actions to transition between states.

■ Adding fields to your record forms.

■ Defining the behavior of fields (for example, read-only, mandatory, or optional
fields).

■ Creating Visual Basic or Perl field hooks or action hooks to help enforce the rules
of your change management system. For more information, see the API Reference
for Rational ClearQuest.

Checking Out a Schema

To customize a schema, you must first check it out of the schema repository. If you did
not check out the schema when you opened the ClearQuest Designer, click File > Open
Schema. For complete instructions on working with schemas, including setting up a
test database to test your schema customizations, see the Administrator’s Guide for
Rational ClearQuest.

Checking In a Schema

At any time while working on a schema, you can click File > Test Work to test your work
in progress. This upgrades the test database with your latest changes, providing a
quick way to test your changes in the ClearQuest client without affecting your
production user database.

When you are satisfied that your schema changes work correctly, click File > Check in
to check the schema into the schema repository. After the schema is checked in, you can
use it to upgrade your user database. Click Database > Upgrade Database. ClearQuest
prompts you to back up the schema repository and the database before upgrading.

For more information about working with ClearQuest schemas, see the Administrator’s
Guide for Rational ClearQuest.

The ClearQuest Designer Help contains detailed information about modifying your
schemas.

Working with Schema Repositories

After you create or customize a schema repository, you can use the ClearQuest
Maintenance Tool to perform the following tasks:

■ Create and manage schema repositories and connections.

■ Create sample databases.
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■ Move a schema repository.

■ Upgrade schema repositories and user databases to a new version of ClearQuest.

Creating and Connecting to a Schema Repository

You use the ClearQuest Maintenance Tool to create a new schema repository and set
up a connection to it and its associated user databases. Note that you must first create
the vendor databases to use for your schema repository and user databases.

You can also use the Maintenance Tool to change the connection information for an
existing schema repository after it is moved or modified.

For more information about creating and connecting to schema repositories, click Help
in the ClearQuest Maintenance Tool or see the Administrator’s Guide for Rational
ClearQuest.

Connection Profiles

As a ClearQuest administrator, you can save database connection settings for later use
by exporting a connection profile. When you modify schema connection information,
or create a new schema, users can import the connection profile rather than entering or
modifying the connection information. Both ClearQuest administrators and
ClearQuest client users can import and export connection profiles for later use.

For more information about connection profiles, click Help in the ClearQuest
Maintenance Tool.

Moving a Schema Repository

You can use the ClearQuest Maintenance Tool to move your schema repository to a
new location, or modify it to use a different vendor database. If you use your vendor
database tools to move a schema repository, the connection you have set up to the
schema repository will be lost. In this case you will need to edit the connection
information for the schema repository.

For more information about moving a schema repository and editing connection
information, see the ClearQuest Maintenance Tool Help or see the Administrator’s
Guide for Rational ClearQuest.

Upgrading to a New Version of ClearQuest

When you install a new version of ClearQuest, you can upgrade all user databases and
schema repositories (whether or not you are connected to them) to use this new
version.
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For more information about upgrading schema repositories and user databases to a
new version of ClearQuest, see the Upgrade Guide for Rational Suite (Windows) or the
Installation Guide for Rational ClearQuest (UNIX).

For more information about working with schema repositories, see the ClearQuest
Maintenance Tool Help.

Exporting and Importing ClearQuest Data

The ClearQuest Export Tool and the ClearQuest Import Tool are utilities that you and
ClearQuest users can use to export and import data to and from ClearQuest databases
and external files.

To open the ClearQuest Export Tool, click Start > Programs > Rational Software >
Rational ClearQuest > ClearQuest Export Tool.

To open the ClearQuest Import Tool, click Start > Programs > Rational Software >
Rational ClearQuest > ClearQuest Import Tool.

For more information about exporting and importing ClearQuest data, see the
ClearQuest Export Tool and ClearQuest Import Tool Help, or the Administrator’s Guide
for Rational ClearQuest.

Administering ClearQuest E-Mail

Rational ClearQuest supports several e-mail capabilities including:

■ Automatic e-mail notification: Send e-mail notification to users or user groups
when specific events occur, such as being assigned a change request.

■ Submitting and modifying defects by e-mail: Users can submit and modify
records by e-mail without using the ClearQuest clients.

■ Round-trip e-mail: Combine e-mail notification with e-mail submission to update
records. For example, when a user receives an e-mail notification that a record has
been submitted, that user can respond with an e-mail message that appends notes
to the record in the database.

■ E-mail notification action hook: Use an action notification hook to have
ClearQuest send an e-mail message when a user completes a specific action.

ClearQuest includes a Rational E-Mail Reader service, e-mail rules, and e-mail options
that you and your users must configure in order to take advantage of these features.
For more information about setting up the ClearQuest e-mail capabilities, and using
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the Rational E-Mail Reader service, see the Administrator’s Guide for Rational
ClearQuest.

Administering ClearQuest on the Web

You can configure ClearQuest on a Web server to let users with an Internet browser
perform many of the same functions available through the ClearQuest Windows and
UNIX clients.  ClearQuest Web supports Active Server Pages (ASP), and must be
hosted on a Web server running the Microsoft Internet Information Server (IIS).

For more information about the ClearQuest Web client, see the Administrator’s Guide for
Rational ClearQuest, or the ClearQuest Web client Help.

Administering ClearQuest on UNIX

You have the option of letting users work with a UNIX installation of ClearQuest.
There are several things to keep in mind when planning a UNIX installation, including:

■ The ClearQuest Installation for UNIX does not include the ClearQuest Designer,
ClearQuest Maintenance Tool, ClearQuest Import Tool, or ClearQuest Export Tool.

■ A ClearQuest Windows installation with ClearQuest Designer and the ClearQuest
Maintenance Tool is required to configure, customize, and administer schemas and
databases within the UNIX environment.

■ A ClearQuest Windows installation with the ClearQuest Import Tool and
ClearQuest Export Tool is needed to import and export data from external files.

For more information about running ClearQuest on UNIX, see the Administrator’s
Guide for Rational ClearQuest.
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4Using ClearQuest
This chapter contains information for all Rational ClearQuest users, including
administrators and schema designers. It introduces the basic concepts of using the
ClearQuest Windows, UNIX, and Web clients, including information about how to:

■ Submit change requests

■ Work with change requests

■ Track change requests

■ Gather project metrics

If you are reading this chapter as a ClearQuest administrator, look for Administrator Tip
next to suggestions for customizing ClearQuest to fit your organization’s workflow.

For more information about planning a change management process, see Chapter 2,
Planning a Change Management Process. For more information about administrative
tasks, see Chapter 3, Administering and Customizing ClearQuest.

Note: The examples in this chapter use the DefectTracking schema and SAMPL
database that are included with ClearQuest. This represents only one model for using
ClearQuest. For information about additional schemas, see Selecting a ClearQuest
Schema on page 16.

Using the ClearQuest Windows Client

Rational ClearQuest provides a Windows client that you use to access a user database
and work with change requests:

To start using the ClearQuest Windows client:

1 Click Start > Programs > Rational Software > Rational ClearQuest.

2 Log on to the ClearQuest Windows client. You can use the ClearQuest predefined
user name, admin, to get started. Do not type a password.

3 Select a database from the Database list. Select the SAMPL database to experiment
with a working user database that already contains change request records.
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Note: If the Database list is empty, contact your ClearQuest administrator, or see
the following Administrator Tip.

For more information about the ClearQuest Windows client, see the ClearQuest Help.

Administrator Tip: During installation, you create and configure user databases for
your site; their names appear in the Database list when users log in. For more
information about creating and configuring user databases, see the Installation Guide
for Rational Server Products (Windows) or the Installation Guide for Rational
ClearQuest (UNIX).

After installation, you use ClearQuest Designer to set up user login accounts and to
define user access privileges. For more information about setting up user login
accounts, see the information about administering users in the Administrator’s Guide for
Rational ClearQuest.

Using the ClearQuest UNIX Client

Rational ClearQuest provides a UNIX client that you can use to perform most
ClearQuest operations from a UNIX machine.

To start using the ClearQuest UNIX client:

1 At a command prompt, set the ClearQuest home environment variable
($CQ_HOME):

cquest-home-dir/cq_setup.sch

2 To start the UNIX client, type clearquest.

3 In the Schema Repository dialog box, select a schema and click OK.

4 Log on to the ClearQuest UNIX client. You can use the ClearQuest predefined user
name, admin, to get started. Do not type a password.

5 Select a database from the Database list.

Note: If the Database list is empty, contact your ClearQuest administrator, or see
the following Administrator Tip.

Select the SAMPL database to experiment with a working user database that
already contains many change request records.

For more information about the ClearQuest UNIX client, see the ClearQuest Help.

Administrator Tip: During installation, you create and configure user databases for
your site; their names appear in the Database list when users log in. For more
information about creating and configuring user databases, see the Installation Guide
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for Rational Server Products (Windows) or the Installation Guide for Rational
ClearQuest (UNIX).

Several administrator tools, including the ClearQuest Designer and the ClearQuest
Maintenance Tool, are not available with a UNIX installation of ClearQuest. For more
information about the differences between Windows and UNIX installations of
ClearQuest, see the Administrator’s Guide for Rational ClearQuest.

Using the ClearQuest Web Client

Rational ClearQuest includes a Web-based client interface. You can use the ClearQuest
Web client with a Web browser to:

■ Submit change request records.

■ View and modify change request records.

■ Run predefined queries.

■ Create and run new queries.

■ Create and run new reports.

■ View predefined charts and reports.

To start using the ClearQuest Web client:

1 Navigate to the ClearQuest Web URL provided by your ClearQuest administrator.

2 Log on to the ClearQuest Web client. You can use the ClearQuest predefined user
name, admin, to get started. Do not type a password.

3 If you are set up to access multiple schema repositories, select a schema repository
from the Schema Repository list.

4 Select a database from the Database list, or type a database name in the text field.

For more information about the ClearQuest Web client, see the ClearQuest Help.

Administrator Tip: As a ClearQuest administrator, you set up and customize the
ClearQuest Web client, control user access, and customize ClearQuest Web hooks. For
more information about these tasks, see the Administrator’s Guide for Rational
ClearQuest.
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ClearQuest Client Interfaces

The three ClearQuest client interfaces consist of a Workspace, a Query Builder, and a
Record form. In the ClearQuest Windows and UNIX clients, all three components are
available on the screen at the same time. In the Web client, the Workspace is always
visible and the Query Builder and Record form are displayed based on the user’s
selections. See Figure 3 for an example of the ClearQuest Windows and UNIX client
interface and its components.

Figure 3 ClearQuest Client Interface

Workspace

The Workspace, located in the leftmost pane of all three ClearQuest client interfaces,
lists the queries, charts, and reports that are available.

The Public Queries folder in the Workspace contains the queries, charts, and reports
that are installed with ClearQuest, as well as any that your ClearQuest administrator
creates. In the Windows and UNIX clients, you can drag any query, chart, or report to
your Personal Queries folder and modify it to suit your needs.
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Query Builder

The Query Builder, located in the top right pane of the ClearQuest Windows and UNIX
client interfaces, displays the results of a query. In the ClearQuest Web interface, the
Query Builder is located in the right half of the window when the client is started. Click
a record to display its data in the Record form. In the UNIX or Windows clients, you
can use the Query editor tab to change the query filter requirements and the Display
editor tab to change the columns displayed in the query result set. To modify a query
in the Web client, click Operations.

Record Form

The Record form, located below the Query Builder in the Windows and UNIX clients,
displays all of the data for a specified record. In the Web client, the Record form is
located in the right pane of the window when a record is selected from the Query
Builder.

For more information, see the ClearQuest Help.

Working with Change Request Records in the Windows
and UNIX Clients

You work with a change request record by submitting it and then moving it through
predefined stages, or states. In each state, you can perform actions such as modifying
the record or moving it to another state. After submitting a change request, click the
Actions button on the Record Form to list the actions that you can perform on the
record while it is in the current state.

The following sections describe a typical workflow for a change request record with
the Windows or UNIX client. For information about working with change requests
with the ClearQuest Web client, see the ClearQuest Help.

Submitting a Change Request

You begin using ClearQuest by submitting a change request. This creates a record in
the user database that everyone on the team can track as your software development
and testing evolves.

To submit a change request, click Actions > New and select a record type. The types of
records available depend on the schema that you are using.
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Submit Defect Form

The defect record type is a type of change request used in many ClearQuest
implementations. To submit a defect and open the Submit Defect form, click the New
Defect button on the toolbar, or click Actions > New and select the defect record type.

You use the tabs on the Submit Defect form to describe the change request in detail.
Some tabs contain fields that are mandatory. For example, the Headline field requires a
short sentence describing the problem, and you must select a value for the Severity
field. Tabs with mandatory fields are marked with a red square and the mandatory
fields themselves are labeled in red.

You can save frequently used field values as defaults so you do not have to re-enter
them each time you submit a change request. Fill in the fields you want to save and
click Values > Save as Default. When you create a new defect you can click Values >
Load Default to populate the Submit Defect form with the default values. See Figure 4
for an example of the Submit Defect record form.

Figure 4 Submit Defect Form

Note: You can submit a change request directly to ClearQuest from Rational TeamTest,
Purify, PureCoverage, Quantify, and Visual Test. You can also use ClearQuest Web and
ClearQuest UNIX to submit and modify change requests or submit change requests by
e-mail.

Administrator Tip: As a ClearQuest administrator, you can create additional record
types. For example, you might want separate record types for hardware defects,
software defects, and enhancement requests. You can also customize record forms by
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adding tabs and fields and defining their behavior. For more information about
working with forms, see the Administrator’s Guide for Rational ClearQuest, or see the
ClearQuest Help.

Assigning a Change Request

After you submit a change request, you can use the Assign action to assign it to an
engineer who will do the work. The Assign action is a state transition that moves a
defect record from the Submitted state to the Assigned state. The State field on the
Record Form tells you what state a record is in.

To assign the record:

1 Click Actions > Assign.

2 Fill in all of the information on the record tab and click Apply.

Administrator Tip: The exact process of working with records, including the states the
record can be in and the actions available in each state, depends on the ClearQuest
schema you are using and any customizations you have made to it. For more
information about planning the states in your change management process, see
Chapter 2, Planning a Change Management Process. For more information about
customizing your schema, see Customizing a Schema on page 17, or see the
Administrator’s Guide for Rational ClearQuest.

Modifying a Change Request

Not all actions change the state of a change request. You can click Actions > Modify to
change some information on a change request without changing its state.

Opening and Resolving a Change Request

If you are the engineer assigned to the change request, you begin work by clicking
Actions > Open. This changes the record’s state to Opened; now the rest of the team can
see that you are working on the problem.

When you finish your work, click Actions > Resolve to change the record’s state to
Resolved.

Administrator Tip: As a ClearQuest administrator, you can restrict ClearQuest actions
to specific user groups. For example, you might allow everyone on the team to resolve
a change request, but restrict the Verify action to members of the Quality Assurance
group. For more information about using security in Rational ClearQuest, see the
Administrator’s Guide for Rational ClearQuest.
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Tracking Change Request Records in the Windows and
UNIX Clients

In ClearQuest, you run a query to find specific defect or change request records in the
database. ClearQuest queries make it easy for everyone on your team to track change
request records as they move through your process. The following sections describe
how to track change request records with the Windows or UNIX client. For information
about tracking change request records with the ClearQuest Web client, see the Help.

Public and Private Queries

There are two main query folders in the Workspace: Personal Queries and Public
Queries. When you use an out-of-the-box schema, the ClearQuest Public Queries folder
includes ready-to-use queries that help you locate records by project or component, by
assigned engineer, by level of severity, and so on. Any queries, charts, or reports that
you create are always stored in the Personal Queries folder. Unless your administrator
has given you Public Folder Administrator privileges, you are only allowed to save
queries to the Personal Queries folder. You can modify a query in the Public Queries
folder, but it is stored in the Personal Queries folder when you save it.

Running a Query From the Workspace

You run a ClearQuest query from the Workspace by double-clicking the query name.

For example, when you discover a defect in your software, you can run a query to see
if the defect has already been submitted. Double-click Public Queries > All Defects in
the Workspace to display all the records in the database. Or, double-click Public
Queries > Keyword search to locate records containing a specific word in the Headline
or Description field.

The Query Builder displays the records that fit the query criteria. If the query results
are not displayed, click the Result set tab, located under the Query Builder. Click the
Query editor and Display editor tabs to modify the selection criteria and the display of
your query.

During a session of submitting new defects, you can click Query > Recently Submitted
to see a list of the defects you have submitted since you logged on.

For more information about running queries, see the ClearQuest Help.
30 Introduction to Rational ClearQuest



Creating a Custom Query

You create custom queries in ClearQuest to search for records based on criteria that you
provide. You decide which fields you want your query to display, as well as the fields
and corresponding values to use as query filters.

Fore more information about creating queries, see the ClearQuest Help.

Using the Query Wizard on the Windows Client

The Query Wizard walks you through the steps of creating a custom query. To verify
that the Wizard is turned on, click Query and look for a check mark next to the Use
Query Wizard option. If no check mark is visible, click Query > Use Query Wizard to
activate the wizard.

Click Query > New Query to start the Query Wizard. Follow the instructions on the
Query Wizard to:

■ Build a new query or modify an existing one.

■ Choose a record type to query.

■ Select display fields for the query.

■ Select fields for query filters and define filter values.

After you finish with the Query Wizard, query results are displayed in the Results set
tab of the Query Builder. To save the new query to the Personal Queries folder, click
File > Save As or click the Save Query button in the toolbar.

For help using the Query Wizard, click Help on the Query Wizard dialog.

You can also choose to create a query without using the Query Wizard. For more
information, see the ClearQuest Help.

Administrator Tip: As a ClearQuest administrator, you can save queries to the Public
Queries folder and can assign this privilege to other users. For more information about
administering users, see the Administrator’s Guide for Rational ClearQuest.

Modifying Queries

To modify a query, double-click the query in the Workspace and then use the Query
editor and Display editor tabs to make your changes.

To change the filtering criteria for a query, use the Query editor tab. For example, you
may want to modify a query to filter on the Closed Date field instead of the Submit Date
field. To set up how the query results are displayed in the Query Builder, use the
Display editor tab. You can select the fields you want displayed for each record as well
as the sort criteria for the records.
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To save the new query to the Personal Queries folder, click File > Save As or click the
Save Query button in the toolbar.

Gathering Project Metrics

ClearQuest provides predefined charts and reports that you can run to view the status
of your project at a glance. The options for creating and viewing charts and reports
vary depending on the client you are using. For information about the charting and
reporting capability of a particular client, see Table 5.

Using ClearQuest Charts

ClearQuest charts are graphic representations of record data. The out-of-the box
ClearQuest schema repositories include many predefined chart types, including aging,
distribution, and trend. Distribution charts show the current status of data; trend and
aging charts show historical information.

For example, you can see how the workload is distributed among the engineers on
your team by running a distribution chart that displays the defects assigned to each
engineer. Or, you can see the defect records graphed by state and severity. For an
example of a ClearQuest distribution chart, see Figure 5.

For more detailed information about working with ClearQuest charts, see the
ClearQuest Help.

Table 5 Charting and Reporting Capability of ClearQuest Clients

Client Charts Reports

Windows View and Create View and Create

UNIX N/A Create (Textual Reports)

Web View View and Create
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Figure 5 ClearQuest Distribution Chart

Creating ClearQuest Charts

To create a new ClearQuest chart, click Query > New Chart.

Use the Chart Wizard to:

■ Specify chart type.

■ Select the chart style.

■ Select fields.

■ Define labels.

■ Select display type.

For more information, click Help in the Chart Wizard.

Saving ClearQuest Charts

After you create or modify a ClearQuest chart, you can save it to the Personal Queries
folder in the Workspace. To save a chart, click File > Save or File > Save As.

Running ClearQuest Charts

To view an existing ClearQuest chart, double-click the chart in the Workspace.
Depending on the type of chart you select, you may need to specify parameters that
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further define the query associated with the chart. In this case, specify the parameters
and click Run Query.

Modifying ClearQuest Charts

You can modify the contents of an active chart in one of the following ways:

■ Click Edit > Properties to define how the data is displayed.

■ Use the Query editor tab to filter the records included in the chart.

To modify and save a chart, it must be located in the Personal Queries folder. Drag and
drop public charts from the Public Queries folder to the Personal Queries folder to
modify and save it.

Using ClearQuest Report Formats and Reports

You can use ClearQuest report formats and reports to format the display of ClearQuest
data returned by a query. You first create a report format that specifies the layout of
your report, including the fields that are displayed. You then create the actual report,
which links a report format to a query.

ClearQuest out-of-the-box schemas come with predefined report formats and reports
that you can view by clicking Report Formats or Reports in the Public Queries folder of
the Workspace.

For more detailed information about working with ClearQuest reports and report
formats, see the ClearQuest Help.

Creating Report Formats

To create a ClearQuest report, you must first create a ClearQuest report format to
define the layout of your report. In order to create report formats, you must purchase
and install Crystal Reports Professional Edition 8.5.

If your administrator has already created report formats in the Public Queries folder,
you can use them to create new reports. See Figure 6 for an example of a report based
on the Defect Summary report format.
34 Introduction to Rational ClearQuest



Figure 6 ClearQuest Defect Summary Report

Creating Reports in ClearQuest Windows and ClearQuest Web

After you or your administrator create a report format with Crystal Reports, you can
generate a ClearQuest report by applying the report format to an existing query or a
set of query results. For detailed instructions, see the ClearQuest Help.

If you or your administrator are unable to create report formats, and you do not want
to use the out-of-the-box formats, you can generate reports by using the ClearQuest
integration with Rational SoDA. For more information about the Rational SoDA report
generation tool and about setting up a report template, see the Rational SoDA Help.
For detailed instructions on creating a SoDA report, see the ClearQuest Help.

Creating Textual Reports in ClearQuest UNIX

Although you cannot create and view graphical reports in ClearQuest UNIX, you can
create textual reports by selecting and arranging information in a query result set. Like
a graphical report, you can print or export a textual report. However, you are unable
to save a textual report, and you must recreate it each time you use ClearQuest.

For detailed instructions on how to create a textual report in ClearQuest UNIX, see the
ClearQuest Help.
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Saving ClearQuest Reports

After you create or modify a ClearQuest report on ClearQuest Windows, you can save
it to the Personal Queries folder in the Workspace. To save a report, click File > Save or
File > Save As.

ClearQuest Web automatically saves your report after you create it, or when you
modify it.

Running ClearQuest Reports

To view an existing ClearQuest report, double-click the chart in the Workspace.
Depending on the type of chart you select, you may need to specify parameters that
further define the query associated with the chart. In this case, specify the parameters
and then click Run Query.

Modifying Reports and Report Formats in ClearQuest Windows

If you are using the ClearQuest Windows client, you can change the following
properties of ClearQuest reports and report formats at any time:

■ Report or report format name.

■ Report layout.

■ Data displayed in report.

Modifying the properties of reports and report formats is not supported in ClearQuest
UNIX and ClearQuest Web.

Exporting ClearQuest Charts and Reports

Using ClearQuest, you can save and export ClearQuest charts and reports to files
outside of the ClearQuest database.

In the ClearQuest Windows and ClearQuest Web clients, you can save and export
charts as graphic files. You can then e-mail the graphics to remote users or import them
into other files.

If you want to share a report or report format with someone at a remote location, or
modify a ClearQuest report so that it can be viewed with a different application, you
can export your report or report format from the ClearQuest Windows client.
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Printing ClearQuest Data

You can use the ClearQuest client to print query results, individual change request
records, charts, and reports.

For more information about printing options, see the ClearQuest client Help.

Receiving Automatic E-Mail Notification

Your ClearQuest administrator can configure ClearQuest to send e-mail messages to
various team members when a change request is submitted or changed. To take
advantage of automatic e-mail notification, all ClearQuest users must set up their
e-mail options. To view and modify the e-mail options for your ClearQuest account,
click View > E-mail Options.

Administrator Tip: The ClearQuest Email_rule record type makes it easy to define the
rules for sending automatic e-mail notification to ClearQuest users. The Email_rule
record type is part of the E-mail package included in every ClearQuest out-of-the-box
schema. You can also use the Rational E-Mail Reader to configure your e-mail settings
so that ClearQuest users can submit and modify records by e-mail.

For more information, see the ClearQuest Designer Help, or see the Administrator’s
Guide for Rational ClearQuest.
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