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Preface
This manual tells you how to install Rational testing products, including the steps you 
need to take both before and after installation. With Rational testing products, you can 
plan, develop, and execute both functional and performance tests for your Windows 
Millennium, Windows NT 4.0, Windows XP, Windows 2000, and Windows 98 
applications, as well as manage all testing activities — planning, design, 
development, execution, and analysis — using Rational TestManager.

Audience

This guide is intended for Rational software users who are installing Rational testing 
products, such as system administrators, application developers, quality assurance 
managers, and quality assurance testers.

Other Resources

■ Rational testing products contain complete online Help. From the main toolbar, 
you can choose an option from the Help menu. 

■ All manuals for this product are available online in PDF format. These manuals are 
on the Rational Solutions for Windows Online Documentation CD.

■ For information about training opportunities, see the Rational University 
Web site: http://www.rational.com/university.

Contacting Rational Technical Publications

To send feedback about documentation for Rational products, please send e-mail to 
our technical publications department at techpubs@rational.com.
vii



Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Technical Support as follows:

Note:  When you contact Rational Technical Support, please be prepared to supply the 
following information:

■ Your name, telephone number, and company name

■ Your computer ’s make and model

■ Your operating system and version number

■ Product release number and serial number

■ Your case ID number (if you are following up on a previously reported problem)

Your Location Telephone Facsimile E-mail

North America (800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com 

Europe, Middle 
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4545-201
Netherlands

support@europe.rational.com 

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com 
viii Preface



1Before You Begin
This chapter tells you what you need to know before installing Rational testing 
products and is organized as follows:

■ About Rational TestManager on page 1

■ About Rational Robot on page 1

■ About Rational TeamTest on page 2

■ About Rational Test Datastores  on page 2

■ About Rational ClearQuest Databases on page 3

■ About Licensing on page 4

■ Hardware and Software Requirements on page 4

■ Before You Install Rational Testing Products on page 7

■ Installing Client Software for Performance Testing on page 7

About Rational TestManager

Use Rational TestManager to manage all testing activities: planning, design, 
development, execution, and analysis. TestManager ties testing to the rest of the 
development effort, joining your testing assets and tools to provide a single point 
from which to understand the exact state of your project. 

Note:  If you plan to do performance testing, you need to install the Rational Test 
Agents. See Installing Rational Test Agents on page 26.

About Rational Robot

When you install Rational Robot, you install all of the following components: 

■ Rational TestManager, which is described in the previous section.

■ Rational Robot – Use to develop and execute functional and performance tests for 
your Windows applications. For information, see the Rational Robot User’s Guide.
1



■ Rational Administrator – Use to manage a Rational project. For information, see 
the Rational Suite Administrator’s Guide.

■ Rational SiteCheck – Use to manage Internet and intranet Web sites. For 
information, see the Rational SiteCheck Help.

■ Comparators – Includes the Object Properties, Text, Grid, and Image Comparators. 
Use to view and analyze the results of test script playback. For information, see the 
Rational TestManager User’s Guide and the Comparators Help.

About Rational TeamTest

When you install Rational TeamTest, you can install some or all of the components 
available on your installation CDs. The following list describes Rational TeamTest:

■ Rational TestManager and Rational Robot, described previously.

■ Rational ClearQuest – Use to track defects of your testing project. Robot installs 
ClearQuest, which includes specially designed defect forms.

About Rational Test Datastores

A Rational test datastore stores functional and performance testing assets and artifacts 
such as suites, test plans, test cases, reports, test logs, and scripts, as well as 
information about users, groups, and computers. When you create a new test 
datastore from the Administrator, you have the option of using two types of database 
engines:  Microsoft Access or Sybase SQL Anywhere.

Microsoft Access - Microsoft Access is the default database engine for a test datastore.  
It is installed automatically when you install your Rational software.  We recommend 
using Microsoft Access when no or very limited concurrent access to the test datastore 
is necessary.  Microsoft Access is relatively low maintenance, but is better suited to 
single-user access.

Sybase SQL Anywhere - We recommend using this type of database engine when 
two or more concurrent users are going to be accessing a test datastore 
simultaneously.  Data access for a SQL Anywhere database server is faster than for a 
comparably sized Microsoft Access database.  However, a SQL Anywhere database 
does require more maintenance than a Microsoft Access database. The Sybase SQL 
Anywhere database server comes with your Rational software but does not install 
automatically.  For information about setting up SQL Anywhere, please see Setting Up 
SQL Anywhere on page 30.
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About Rational ClearQuest Databases

Before you create or attach a ClearQuest database to a project using the Administrator, 
you must:

■ Configure ClearQuest by creating a new schema project or by connecting to an 
existing schema project. A ClearQuest schema project stores all schemas and all 
data associated with existing schemas in a special project. The schema project does 
not store any user data. For more information about configuring a schema project, 
see the Rational Suite Installation Guide.

■ Decide what type of ClearQuest user database to use. A ClearQuest user database 
contains all user data and a copy of the schema associated with the database. User 
data in a ClearQuest database includes change-request records such as defects, as 
well as reports, records, tables, and all other data entered by users.

The following table summarizes which type of database software to use for a 
ClearQuest database:

Table 1 Determining a Database Type for ClearQuest

If You Have Then 

Seven or fewer concurrent users 
who will not access the database 
over a wide-area network

Use a Microsoft Access database. This is the default 
database and installs automatically when you install 
Rational software.

Note:  Rational ClearQuest Web does not support Microsoft 
Access databases.

This database is virtually maintenance free; for example, 
you can back it up by simply backing up the Rational 
project directory. However, with more than seven 
concurrent users, database access is relatively slow.

Eight or more concurrent users 
who will access the database 
over a wide-area network

Use the Sybase SQL Anywhere Database Server software 
that comes on Disc 2 of the Rational Solutions for Windows 
CDs.

We recommend using a Window NT Server for your 
database server because a Windows NT Workstation allows 
only ten network connections.

Eight or more concurrent users 
and you want to use Microsoft 
SQL Server for your database

Use Microsoft SQLServer to create an empty database 
foundation to use with ClearQuest.

For information about using Microsoft SQL Server for 
ClearQuest, see the Rational ClearQuest Installation Guide, 
available on the Rational Solutions for Windows Online 
Documentation CD.
About Rational ClearQuest Databases 3



About Licensing

If you want to play back more than one virtual tester, you need to purchase the 
appropriate licenses and install a license server. See Rational Software License 
Administrator’s Guide for the software licensing description, procedures, and licensing 
administration information. The online Help for Rational License Key Administrator 
contains detailed information about common user licensing activities.

Hardware and Software Requirements

Make sure that your computer conforms to the following minimum requirements for 
each product or component you plan to install.

Table 2 Hardware and Software Requirements

Eight or more concurrent users 
and you want to use Oracle 
software

Use Oracle to create an empty database foundation to use 
with ClearQuest.

For information about using Oracle for ClearQuest, see the 
Rational ClearQuest Installation Guide, available on the 
Rational Solutions for Windows Online Documentation CD.

If You Have Then 

Rational Component Minimum Requirements

Rational TeamTest Pentium class or equivalent, 200 MHz minimum
(Pentium II 300 MHz or better recommended)

CD ROM

800 MB free disk space (minimum installation)

128 MB RAM is the recommended minimum; more memory 
generally improves responsiveness.

Video Resolution 1024x768

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows XP, Windows 2000, or Windows 98 2nd 
edition
4 Chapter 1 - Before You Begin



Rational Robot Pentium class or equivalent, 200 MHz minimum
(Pentium II 300 MHz or better recommended)

CD ROM

800 MB free disk space (minimum installation)

128 MB RAM is the recommended minimum; more memory 
generally improves responsiveness.

Video Resolution 1024x768

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows XP, Windows 2000, and Windows 98 
2nd edition

If you are developing or running test scripts written in the 
Visual Basic language, VB 6 on Windows 2000 or Windows NT 
is required.

If you are developing or running Java test scripts, the JDK 
(IBM version 1.1.7B or Sun Microsystems versions 1.2.2 or 
1.3.0) is required.

If you are developing BEA WebLogic EJB scripts, you must 
have BEA WebLogic Server 6.0 installed on the same machine. 
For running, you need WebLogic 6.0 client software installed.

Rational TestManager Pentium class or equivalent, 200 MHz minimum
(Pentium II 300 MHz or better recommended)

CD ROM

800 MB free disk space (minimum installation)

128 MB RAM is the recommended minimum; more memory 
generally improves responsiveness.

1-3 MB RAM per virtual tester

1-3 MB disk space per virtual tester

Video Resolution 1024x768

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows XP, Windows 2000, and Windows 98 
2nd edition

If you are running test scripts written in the Visual Basic 
language, VB 6 on Windows 2000 or Windows NT is required.

If you are running Java test scripts, the JDK (IBM version 1.1.7B 
or Sun Microsystems versions 1.2.2 or 1.3.0) is required.

If you are running BEA WebLogic EJB scripts, you need BEA 
WebLogic Server 6.0 client software installed.

Rational Component Minimum Requirements
Hardware and Software Requirements 5



Rational Test Agent software 
– Windows Systems

Pentium class or equivalent 
(500 MHz or better recommended).

128 MB memory.

425 MB free disk space for installation. We recommend more 
disk space for large virtual tester runs.

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows XP, Windows 2000, or Windows 98 2nd 
edition.

If you are running VU test scripts, Microsoft Windows NT 4.0 
(Service Pack 5 or 6a) or Windows 2000 is required.

If you are running test scripts written in the Visual Basic 
language, VB 6 Service Pack 3 and Windows 2000, or VB 6 
Service Pack 3 and Windows NT is required.

If you are running Java test scripts, the JDK (IBM version 1.1.7B 
or Sun Microsystems versions 1.2.2 or 1.3.0) is required.

TCP/IP

Rational Test Agent software 
– UNIX Systems

32 MB memory, plus .5–2 MB per virtual tester (some 
workloads may require more memory).

150 MB free disk space for installation. We recommend more 
disk space for large virtual tester runs.

One of the following operating systems:
AIX 4.3

HP-UX 11

DYNIX/ptx

Solaris 2.5, 2.6, 2.7, or 2.8

Red Hat 6 and 7 release of Linux

If you are running Java test scripts, the JDK (IBM version 1.1.7B 
or Sun Microsystems versions 1.2.2 or 1.3.0) is required.

If you are running BEA WebLogic EJB scripts, you need BEA 
WebLogic Server 6.0 client software installed.

Rational ClearQuest Web ClearQuest Web is included with Rational TeamTest. 

Microsoft Internet Information Server (IIS) with Active Server 
Pages. 

Crystal Reports 8.0 
Professional Edition

80 MB free disk space (minimum installation)

Rational Component Minimum Requirements
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Before You Install Rational Testing Products

Before you install Rational testing products, you must do the following:

■ If you are running a previous version of Rational Suite PerformanceStudio or 
Rational LoadTest be sure to uninstall these products first.

Previous versions of Rational LoadTest and Rational Suite PerformanceStudio do 
not work with testing products from this release. You must uninstall them first.

■ If SQA Suite 6.x is installed on your computer, you do not have to uninstall it. The 
current version of Rational testing products and SQA Suite 6.x. can coexist because 
they are installed in different directories.

■ Decide which type of database you need for your ClearQuest database. For more 
information, see About Rational ClearQuest Databases on page 3.

■ Make sure that all computers have TCP/IP installed. Install any updates to your 
network software that you have not installed.

■ Verify that the computers are communicating with each other. (If you have any 
problems, see your network administrator.)

For Rational performance testing products:

■ Determine the role each computer will play in testing—whether it will be a Local 
or an Agent computer. For information, see Installing Rational Test Agents on 
page 26.

■ Install the appropriate client software. For information, see Installing Client 
Software for Performance Testing on page 7.

■ Determine the kind of network you will be using, either Ethernet or Token Ring. 
You need to know this when you install the Rational Test network driver. For 
information, see Installing and Removing the Network Driver on page 21.

Installing Client Software for Performance Testing

To play back a test script that tests Oracle, Sybase, or SQL Server databases on a Local 
or Agent computer, you must install the appropriate database client software.

Oracle Client Software

To play back a test script that tests an Oracle database on a Local or Agent computer, 
you must install Oracle client software. 
Before You Install Rational Testing Products 7



Sybase Client Software

To generate test scripts that test a Sybase database, you must install the Sybase 11.1 
NT client software on the Local computer, that is, the Windows 2000 Server or the 
Windows NT 4 Server.

To play back test scripts that test a Sybase database, you must install the appropriate 
software on each Agent computer: 

■ For UNIX Agents, install Sybase 11.1 UNIX client software

■ For NT Agents, install Sybase 11.1 NT client software

SQL Server Client Software

To generate test scripts that test a SQL Server database, you must install the SQL 
Server 6.5 or newer NT client software on the Local computer. 

Note:  Datastores created on the client can be stored on separate Servers that have 
Windows NT 4 or Windows 2000 operating systems with SQL software.

To play back SQL Server test scripts on an Agent, you must install the appropriate 
software on each Agent computer as follows: 

■ For UNIX Agents, install Sybase 11.1 UNIX client software (limited compatibility)

■ For NT Agents, install SQL Server 6.5 or newer NT client software

TUXEDO Protocol Software

To generate test scripts using the TUXEDO protocol, you must install the TUXEDO 6 
client software on the Local computer before you install any Rational testing 
products. 

SAP Protocol Software

To generate test scripts using the SAP protocol, you must install the SAP Frontend 
software, typically referred to as SAPGUI, on the Local computer.

DCOM/COM+ Protocol Software

Before you play back test scripts that use the DCOM/COM+ protocol on an Agent 
computer, ensure that the client application recorded on the Local computer also runs 
on the Agent. This ensures that the necessary COM objects are present and properly 
registered on the Agent.
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WebLogic/EJB Protocol Software

To generate test scripts that test a WebLogic/EJB server, you must install WebLogic on 
the appropriate Local computer.

To play back test scripts that test a WebLogic/EJB server, you must install WebLogic 
on the appropriate Local or Agent computer.
Installing Client Software for Performance Testing 9
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2Installing Rational Testing 
Products
This chapter explains how to install the Rational testing products Rational TeamTest, 
Robot, and TestManager. It includes the following topics:

■ Installation Types on page 11

■ Installing Rational Robot, Team Test, and TestManager on page 12

■ Setting Up Silent Installations on page 15

■ Removing Your Software  on page 15

■ Troubleshooting Your Installation on page 15

Note:  Please see the Rational Suite Installation Guide for directions on how to install 
TestStudio.

Installation Types

The Rational Software Setup program provides you with several installation types, 
letting you install the configuration most appropriate for your system. The following 
table describes the installation types:

Table 3 Installation Types

Type Description

Typical Installs the most commonly used features for a product. 

Use this option for standard installations.

Custom Allows you to add or remove products or product features. 
Defaults to all features in a typical installation.

Use this option to install Web Server Components on a Web 
Server (ClearQuestWeb and TestManager/Web).

Compact Installs a subset of the standard configuration. May omit 
optional files, including online documentation or online 
Help. Use this option on systems with limited disk space.
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Installing Rational Robot, Team Test, and TestManager

This section describes how to install Rational Robot, Rational TeamTest, and 
TestManager. 

1 Log on using an account with Administrator privileges.

2 Insert the Rational Solutions for Windows Disc 1 CD into your CD drive. The 
installation starts automatically.

If the installation does not start automatically, do the following:

a Click Start > Run.

b Type drive:\SETUP.EXE

where drive is the CD-ROM drive.

c Click OK.

3 At the Rational Software Setup screen, click Next.

4 At the Choose Product screen, select one of the following from the list of available 
products:

❑ Rational Robot

❑ Rational TeamTest 

❑ Rational TestManager

Note:  To install a Rational Test Agent, see Installing Rational Test Agents on page 26.

A green check mark next to a Rational product indicates you have a license key 
configured for that product. If you do not see a green check mark next to the 
product you want to install, you may want to install license keys before you install 
the product.

To configure a license key, click the Configure Licenses button to launch the 
Rational License Key Administrator (LKAD) and the License Key Administrator 
Wizard. 

If you do not install the license keys before you install the product, the LKAD 
appears at the end of the installation.

Network Installs the files needed to run the program from a CD or 
network location. Use this option to run the program from a 
centrally managed location.

Type Description
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For more information about software licenses, click Help or see the Rational 
Software License Administrator’s Guide. 

5 Click Next.

If you did not install the license keys before you installed the product, the Setup 
program displays a message. Select OK to install without licensing configured. 
Select Cancel to go back and configure licensing.

6 Read the terms of the license agreement, select Yes, I accept the agreement, and 
click Next. 

If you do not accept the agreement, the Setup program ends.

7 Select the setup configuration you prefer and click Next.

❑ Typical – Installs the most commonly used features for this product. 

❑ Custom – Lets you specify which products or features to install.

❑ Compact – Installs the smallest subset of features needed to run this product.

❑ Network – Configures your machine to run the product from a network drive.

If the Upgrade Compatibility screen appears, you have additional, older Rational 
products installed on your system. Because Rational tools share files and 
components, this installation can cause the older Rational products to stop 
working. You will see no visual clue that the older products may be compromised.

8 For each additional, older product listed, we recommend that you either:

❑ Upgrade it – Complete this installation, and restart the Setup wizard to upgrade 
the listed products. Upgrading each product updates all necessary files, 
registry entries, startup menu items, and shared components. See the 
product-specific upgrade section in Before You Begin on page 1 for requirements.

❑ Remove it – Complete this installation, and then see Removing Your Software on 
page 15 for the removal procedure.

9 If the Update Shared Components screen appears, do one of the following: 

❑ Click Next to install the shared components listed. Setup installs the U.S. 
English versions of the files. It does not overwrite newer versions of the files. 

❑ Click Replace files with newer versions in English to replace your version of the 
shared components with the U.S. English version. (This option is available only 
if you installed earlier versions of the shared files in a non-U.S. English 
language.) 
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❑ Click Cancel to exit Setup and install the shared files yourself. 

Note:  A shared component is software provided by a company other than Rational 
Software Corporation. It is potentially available to other applications on your 
system. In general, we recommend that you let the Rational setup procedure install 
shared components for you.

10 At the Rational Confirmation screen, view the selections that you have made and, 
if they are correct, click Next.

When Setup prompts you to insert Disk-02 in the CD-ROM drive, insert the disk 
and click OK.

When Setup prompts you to insert Disk-01 in the CD-ROM drive, insert the disk 
and click OK.

The Error Summary dialog box displays errors from the first part of the software 
installation. If the installation is successful, this dialog box does not appear.

11 Click Finish when done. 

12 You must shut down and restart your computer to finish the installation. Log on 
again using the same user account and Administrator privileges that you used to 
start the installation. This allows the setup program to complete. 

If you need to install a software license, the online Help for Rational License Key 
Administrator contains detailed information about common user licensing activities. 
Refer to Rational Software License Administrator’s Guide for the software licensing 
description, procedures, and licensing administration information. 

When to Install Shared Files Yourself

You may want to install shared files yourself under the following circumstances:

■ You are using a U.S. English system, but installing new files may invalidate your 
current environment. In this case, you need to determine how to correct your 
environment so you can run existing tools and the Rational products that you 
want to install.

■ Your site may mandate that you obtain shared files directly from the
source — for example, from Microsoft — rather than using files supplied by a third 
party. Alternatively, your site may prohibit end users from installing shared 
components.

■ You may want to install equivalent files that are localized to your language. 
Rational Software supplies only U.S. English versions of shared files. 

■ There may be a later version of the files available. Rational products should work 
with the supplied version of shared files or any later versions.
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Setting Up Silent Installations

A silent installation lets you perform an installation of a Rational Software product, 
using the same parameters, repeatedly on a number of systems. Silent installations 

save system administrators time and also control which products the users can use. 

Refer to Rational Suite Installation Guide for more information.

Removing Your Software

To remove Rational software products, make sure that no one is using the Rational 
software on your system. You cannot remove files that are in use. To remove Rational 
software from a Windows NT system, you must have Windows NT administrator 
privileges on the local machine. The Rational Software Setup program does not 
remove directories that contain files that you have created using Rational software 
products.

To remove Rational software from your computer:

1 Click Start > Settings > Control Panel.

2 Click Add/Remove Programs.

3 Select the Rational product that you want to remove and click Add/Remove.

Troubleshooting Your Installation

If you encounter any problems running the Rational Setup wizard, try the following 
suggestions before you call Rational Technical Support for help:

■ Stop all applications before you begin the installation.

■ Turn off all virus protection software. These programs often run in the background 
and interfere with the installation and file decompression process.

■ Turn off any user interface managers or desktop environments that run on 
Microsoft Windows.

■ Change to a standard VGA video driver while Rational Setup is running, or 
disable video features such as virtual screens or screen switching.

■ Change to a standard mouse driver, or disable special mouse features that perform 
tasks such as leaving pointer trails or changing pointer sizes.
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3Upgrading from Previous 
Releases
This chapter is organized as follows:

■ General Information About Upgrading on page 17

■ Upgrading from Recent Rational Test Releases on page 18

■ Upgrading from Older Rational Test Releases on page 20

General Information About Upgrading

We recommend that you upgrade data from a previous version of Rational testing 
products to the current version after you finish working on a project. 

Be sure to back up your data before you upgrade.

If you have integrations with products such as ClearQuest, RequisitePro, etc., use 
ClearQuest Designer to upgrade these first. Once you have upgraded the packages, 
upgrade the test datastores as described on page 19.
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Upgrading from Recent Rational Test Releases

Use the following procedure if you are upgrading to 2002.05 from Rational Test 
Releases 2001A.04 or 2001.03. If you are upgrading from Release 2000.02.10 or earlier, 
refer to Upgrading from Older Rational Test Releases  on page 20:

1 Install Rational Test 2002.05. For details, see Installing Rational Robot, Team Test, and 
TestManager on page 12.

2 Upgrade your TestStudio.

❑ Start the ClearQuest Designer:

Click Start > Programs > Rational Suite TestStudio > Rational ClearQuest 
RationalClearQuest Designer.

❑ If the Open Schema Wizard appears, click Cancel.

❑ From the Designer menu, click Package > Upgrade Installed Packages to display 
the Upgrade Installed Packages wizard.

❑ On the Select a schema to upgrade page, the wizard lists the available schema 
repositories. Select the schema you want to upgrade.

The Upgrade Installed Packages wizard checks out the schema, analyzes which 
packages need upgrading, and determines whether any prerequisites to those 
packages are required.

❑ On the Status page, note the list of packages that need upgrading and click 
Upgrade.

❑ After the package upgrades successfully, click Exit to close the Wizard.

3 Apply schema changes to the ClearQuest database:

❑ Start the ClearQuest Designer if it is not already open:

Click Start, > Programs > Rational Suite TestStudio > Rational ClearQuest > 
Rational ClearQuest Designer.

❑ If the Open Schema Wizard appears, click Cancel.

❑ From the Designer menu, select Database > Upgrade Database.

A message warns you that this action cannot be reversed, recommends that you 
back up your databases before proceeding, and asks you if you want to 
continue. If you have backed up your databases, click Yes.

❑ Select the user database from the list in the Upgrade Database Wizard. Click 
Next.
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❑ On the next page, select the schema master database version from the list. If 
your most recent version does not appear in this list, it probably is not checked 
in. In that case, click Cancel to quit this wizard. On the Designer menu, click 
File > Open Schema, and check in the schema. You can now restart this process

❑ Click Finish.

When the upgrade completes, a message appears saying that the database has 
been upgraded successfully.

If you created datastores in previous Rational Test releases, refer to the next 
section, Upgrading Test Datastores, to make them compatible with Release 
2002.05.

For detailed procedures about upgrading ClearQuest packages and the database, see 
the section on “Updating ClearQuest” in the Rational Suite Installation Guide. This 
manual is available on the Rational Solutions for Windows Documentation CD and is also 
available for Web download at www.rational.com. 

Note:  You must follow all of the instructions in the “Updating ClearQuest” section of 
the Rational Suite Installation Guide to successfully perform the upgrade. The Rational 
Suite Installation Guide is available on the Online Documentation CD.

Upgrading Test Datastores

Datastores created in Rational Test Releases 2001A.04 or 2001.03 are not compatible 
with the latest version, 2002.05. Before TestManager or Robot Versions 2002.05 can 
connect to and operate against the test assets contained in the datastores, you must 
first use Administrator to upgrade them as follows:

1 Start the Administrator: click Start > Programs > Rational Suite > Rational 
Administrator.

2 In the left pane of the Administrator, select a project, right-click it, and select 
Connect.

3 In the Administrator, select File > Upgrade Project Assets.

The Administrator displays a dialog box listing all registered assets.

4 Select the .RSP file to upgrade the datastores associated with the project and click 
OK.

The program displays a progress dialog. When the process is complete, you can view 
the log generated during the upgrade.

Once upgraded, the datastore cannot be used with earlier versions of TestManager or 
Robot.
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Refer to Rational Suite Administrator’s Guide for more information on creating and 
upgrading datastores.

Refer to Rational TestManager User’s Guide for more information on new features 
associated with the upgrade.

Upgrading from Older Rational Test Releases

If you are upgrading to 2002.05 from Rational Test Releases 2000.02.10 and earlier, 
refer to Chapter 6, “Upgrading from Earlier Versions of Rational Suite” in the Rational 
Suite Installation Guide. This manual is available on the Rational Solutions for 
Windows Documentation CD and is also available for Web download at 
www.rational.com. 
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4Installing Additional 
Software
This chapter is organized as follows:

■ Installing and Removing the Network Driver on page 21

■ Supported Playback Environments on Agent Computers on page 24

■ Installing Rational Test Agents on page 26

■ Installing Rational Robot for Distributed Testing on page 30

■ Setting Up SQL Anywhere on page 30

■ Installing the Rational Test Enablers on page 37

■ Installing the Sample Applets on page 39

■ Installing Crystal Reports on page 39

■ Installing Rational ManualTest Web Execution on page 40

Installing and Removing the Network Driver

To record sessions over a network for performance testing, you must install the 
Rational Test network driver. If you have a network driver from a previous release, 
you must remove it and install the current network driver. The following sections 
explain how to do this on Windows NT and Windows XP, and Windows 2000.

Installing the Network Driver on Windows NT

To install the Rational Test network driver on Windows NT:

1 Install your Rational testing software.

2 Click Start > Settings > Control Panel.

3 Double-click the Network icon.

4 Click the Protocols tab.

5 Click Add.
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6 Click Have Disk. The required files were copied to the Rational directory during 
Rational Test installation.

7 Specify one of the following file paths to install the driver.

❑ For Windows NT Ethernet networks, type:

C:\Program Files\Rational\Rational Test\driver

or installpath\Rational\Rational Test\driver

where installpath is the drive and path is where you installed the Rational 
testing software.

❑ For Windows NT Token Ring networks, type:

C:\Program Files\Rational\Rational Test\drivertk

or installpath\Rational\Rational Test\drivertk

where installpath is the drive and path is where you installed the Rational 
testing software.

Note:  You can install only one type of driver on your computer at a time, either 
Ethernet or Token Ring. You must remove one type of driver before installing a 
new type of driver. 

8 Click OK.

9 In the Select OEM Option dialog box, click OK again to verify the driver.

10 Click Close.

11 Click Yes to shut down Windows and restart your computer after you install the 
network driver.

Removing the Network Driver from Windows NT

If you need to switch from an Ethernet network to a Token Ring network, or the 
reverse, you must remove the driver for the unwanted network type before you install 
the driver for the new network type.

To remove a network driver from Windows NT:

1 Click Start > Settings > Control Panel and double-click the Network icon.

2 Click the Services tab.

3 Select the Rational network driver from the Network Services list.

❑ If your current driver is from Rational Suite PerformanceStudio 1.0 or earlier, 
select PerformanceStudio Network Driver.
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❑ If your current driver is from Rational Suite PerformanceStudio 1.5 or 2000, 
select RSPS Network Driver.

4 Click Remove.

5 Click Yes to confirm that you want to remove the driver.

6 When the removal is complete, click Close.

7 Click Yes to reboot the computer.

When the computer restarts, you can install the new network driver. 

Installing the Network Driver on Windows XP or Windows 2000 

To install the Rational Test network driver on Windows XP or Windows 2000:

1 Click Start > Settings > Network and Dialup Connections.

2 Right-click Local Area Connection, and then select Properties from the context 
menu.

3 Click Install.

4 Click Protocol, and then click Add.

5 Click Have Disk.

6 Enter the path where the driver is located, or browse for the driver. For example, 
type:

C:\Program Files\Rational\Rational Test\driverw2k

or installpath\Rational\Rational Test\driverw2k

where installpath is the drive and path where you installed the Rational testing 
software.

7 Select either Ethernet or Token Ring network, and then click OK.

8 Click Yes to shut down Windows and restart your computer after you install the 
network driver.

Removing the Network Driver from Windows XP or Windows 2000

To remove the network driver from a Windows 2000 or a Windows XP computer:

1 Click Start > Settings > Network and Dialup Connections.

2 Right-click Local Area Connection, and select Properties from the shortcut menu.

3 Select Rational Test Network Driver 2000 from the Network Services list.

4 Click Uninstall.
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5 Click Yes to confirm that you want to remove the driver.

6 When the removal is complete, click Close.

7 Click Yes to reboot the computer.

Supported Playback Environments on Agent Computers

The following table lists the protocols that are supported when you play back a 
performance testing script on an Agent computer. For example, if your Agent 
computer runs Solaris, you cannot play back a test script that accesses ODBC. All 
playback platforms support sockets.

Note:  SQL Server 7.x playback is available on ODBC platforms only.

Also note that use of Agent software on AIX 4.3 requires AIX patch “part number 
ix89833” from IBM. Contact IBM to order the patch.

 

Table 4 Agent Platforms for Performance Testing 

Win NT
Win XP

Win 2000

Win ME
Win 98, 
2nd ed.

Sun OS 2.6
Solaris 7
Solaris 8

HP-UX 11
AIX 4.3 DYNIX/ptx 

Red Hat 
Linux 6 & 7

HTTP & 
HTTP/
SSL

Yes No Yes Yes No Yes

Oracle Yes No Yes Yes Yes Yes

Sybase Yes No Yes Yes No No

Tuxedo & 
Jolt Yes No Yes Yes Yes Yes

SQL 
Server Yes No

Yes, except 
extended stored 

procedures

Yes, except 
extended stored 

procedures No No

ODBC*
Yes No No No No No

SAP
VU Yes No No No No No
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* Including ODBC for SQL Server 7 and 2000.

The following table shows the operating systems that are supported when you play 
back a GUI test script on an Agent computer.

 

DCOM/
COM+

Yes No No No No No

CORBA 
(Visibroker 

3.x only)

Yes No Yes No No No

WebLogic
/EJB

Yes Yes No No No Yes

JAVA Yes Yes Yes No No Yes

Table 4 Agent Platforms for Performance Testing (continued) 

Win NT
Win XP

Win 2000

Win ME
Win 98, 
2nd ed.

Sun OS 2.6
Solaris 7
Solaris 8

HP-UX 11
AIX 4.3 DYNIX/ptx 

Red Hat 
Linux 6 & 7

Table 5 Playback Environments for GUI Testing 

Win NT
Win XP

Win 2000
Win 98, 
2nd ed. Solaris

HP-UX
AIX DYNIX/ptx Linux 

SQA Basic Yes Yes No No No No
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Installing Rational Test Agents

After you install and license your Rational testing software on a Local computer, you 
have the option of installing Rational Test Agents on other computers. You use an 
Agent computer to:

■ Add workload to the server, if you are running a performance test.

■ Run test scripts on more than one computer. If you are running a functional test, 
you can save time by running the test scripts on the next available Agent computer 
instead of running them all on the local computer. Of course, your test scripts must 
be modular.

■ Test configurations. If you are testing various hardware and software 
configurations, you can run test scripts on specific Agent computers that are set up 
with these configurations.

Note:  The same version of Rational testing software must be installed on the Local 
and Agent computers; otherwise, they donot work together.

Note:  When projects containing GUI or Manual scripts are to be shared, create the 
project in a shared directory using the Uniform Naming Convention (UNC).  UNC 
paths are required for GUI test scripts and Manual test scripts that are run on Agent 
computers. For more information about creating a shared directory, see the Rational 
Suite Administrator’s Guide or the Rational Administrator Help.

Installing a Windows Agent

To install Agent software on a Windows computer:

1 Log on using an account with Administrator privileges.

2 Insert the Rational testing software CD into your CD drive. The installation starts 
automatically.

If the installation does not start automatically, do the following:

a Click Start > Run.

b Type drive:\SETUP.EXE and click OK, where drive is the CD drive you are 
using.

3 In the Rational Software Setup screen, click Next.

4 Select Rational Test Agent from the list of available products and click Next.
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5 Read the terms of the license agreement, select one of the following, and then click 
Next.

❑ Yes, I accept the agreement. If you accept the agreement, the Setup program 
continues.

❑ No, I don’t accept the agreement. If you do not accept the agreement, the Setup 
program ends.

6 Select the setup configuration you prefer, and then click Next.

Note:  You cannot select the Network configuration for Rational testing products.

❑ Typical – Installs the most commonly used features for this product. 

❑ Custom – Lets you specify which products or features to install.

❑ Compact – Installs the minimal software needed to run this product.

7 Follow the on-screen instructions to complete the installation.

The Rational Setup Wizard displays a series of dialog boxes that guide you 
through the installation process and prompt you for information.

8 In the last dialog box, click Finish.

You must restart your computer to finish the installation.

9 Log on again using the same user account and Administrator privileges that you 
used to start the installation. This allows the setup program to complete.

Starting a Windows Agent

A Windows Agent runs as an application. To start the Agent, click the executable or 
put it in a start group. 

On Windows NT, you can run the Agent as an NT service if the Agent will be used 
only for virtual testers. 

To run an Agent as an NT service:

1 Right-click the Start menu. Click Open All Users.

2 Double-click Programs.

3 Double-click Startup.

4 If the Agent is running, you must exit it. 
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5 Right-click the Rational Test Agent icon and select Delete.

6 If you are running the Local computer as an Agent:

a Click Start > Run.

b Type rtpsvc -install, and then click OK.

7 Start the Agent as an NT service:

a Click Start > Settings > Control Panel.

b Double-click Services.

c Select Rational Test Agent Service from the list of services, and then click Start.

8 To start the Agent automatically when you restart your computer:

a Click Startup.

b Click Automatic in the Startup Type box, and then click OK.

Installing a UNIX Agent

To install Agent software on a UNIX computer:

1 Log on as root.

2 Create the installation directory:

# mkdir -p /usr/rational/test

3 Insert the Rational Test Agent Disc 1 CD into your CD drive.

4 If the CD does not automount, issue the appropriate UNIX mount command. 
Change your directory to the CD directory. The mount and the change directory 
commands for each Agent are as follows:

For an Agent on a Solaris operating system:

# mount /dev/dsk/c0t6d0s0 /cdrom

# cd /cdrom/cdrom01/solaris_agent

For an Agent on an HP-UX operating system:

# pfs_mount /dev/rdsk/c0t2d0 -t rrip /cdrom

# cd /cdrom/hp11_agent

For an Agent on an AIX operating system:

# mount -v cdrfs -r /dev/cd0 /cdrom

# cd /cdrom/aix4.3_agent
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For an Agent on a Red Hat release of Linux:

# mount /dev/cdrom /mnt/cdrom

# cd /mnt/cdrom/linux_agent

For an Agent on a DYNIX/ptx operating system:

# mount -r -f cdfs /dev/dsk/cd1 /cdrom

# cd /cdrom/dynix_agent

5 Copy the installation files to your hard drive. 

# find . -print|cpio -pdvm /usr/rational/test

6 Set the RATL_RTHOME and PATH environment variables:

# RATL_RTHOME=/usr/rational/test

# export RATL_RTHOME

# PATH=$PATH:/usr/rational/test

# export PATH

7 Change your directory to the directory that contains the installation script.

# cd /usr/rational/test/bin

8 Run the installation script.

# sh agent_install

9 Start the UNIX Agent.

# sh RTsagt

To restart the UNIX Agent manually:

1 Start the Bourne shell, if you are not running it already.

# sh

2 Change your directory to the installation directory.

# cd /usr/rational/test/bin

3 Set the RATL_RTHOME and PATH environment variables:

# RATL_RTHOME=/usr/rational/test

# export RATL_RTHOME

# PATH=$PATH:/usr/rational/test

# export PATH
Installing Rational Test Agents 29



4 Start the Agent daemon.

# ./RTsagt

Removing a UNIX Agent

To remove the UNIX Agent:

1 Find the rtprvd process and kill it using ps -ef|grep rtprvd.

2 Kill the process:

kill pid

3 rm -rf /usr/rational/test

Installing Rational Robot for Distributed Testing

To record GUI test scripts on multiple computers, you must install Robot on each 
computer. A separate node-locked license is required for Robot-only installations. For 
information about installing node-locked licenses, see the Rational Software License 
Administrator’s Guide or the Rational License Key Administrator Help.

To install Robot, follow the Rational Setup. For information, see Installing Rational 
Robot, Team Test, and TestManager on page 12.

Setting Up SQL Anywhere

To create a SQL Anywhere database server, the following tasks need to be completed:

■ Install the Sybase SQL Anywhere Server software. 

Note:  SQL Anywhere is available on the Rational Solutions CD and can be 
installed using the Rational Software Setup wizard.

Note:  We recommend using a dedicated machine for optimal performance. All 
clients should have network access to this computer.

■ Choose or create a user account to run the SQL Anywhere database server and set 
user privileges for that account. See Defining User Privileges on Windows NT on 
page 32 or Defining User Privileges on Windows 2000 on page 33.

■ Create a SQL Anywhere database server. (See procedure on page 33.)

Note:  We recommend that you run the SQL Anywhere Server process on the same 
file server the datastore resides on.
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Installing the SQL Anywhere Database Server Software

When you install the SQL Anywhere database server software, the Rational 
Administrator and other Rational components that you need to manage Rational 
projects and test datastores in a networked, client/server environment are also 
installed.  However, we strongly suggest that you install the server software along 
with a full install of the Rational product that you purchased. The SQL Anywhere 
database server software provides tools, samples, and related library files for your 
SQL Anywhere database server.

Installing the SQL Anywhere database server software does not require a separate 
license.

Note:  You must install the SQL Anywhere database server software on a network 
server running Microsoft Windows NT or Microsoft Windows 2000 Server or 
Workstation. No additional licenses are required.

To begin the installation:

1 Turn on the computer to start Windows.

2 Log on using an account with Administrator privileges.

3 Quit any applications before installing the software.

4 Insert the Rational Solutions CD into your CD drive. The installation program 
should start automatically. If the installation program does not start automatically:

a Click Start > Run.

b Type drive:\SETUP.EXE and click OK.

5 At the Rational Software Setup screen, click Next.

6 At the Choose Software screen, select Sybase SQL Anywhere Database Server 5.5.05 
and click Next.

7 At the License Agreement screen, read the terms of the license agreement carefully, 
click Yes, I accept the agreement, and click Next.  

If you do not accept the agreement, the Setup program ends.

8 To complete the install, accept the defaults on the next several screens by clicking 
Next.
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Defining User Privileges on Windows NT

To define privileges for a user account running a SQL Anywhere database server:

1 Make sure you have installed the Sybase SQL Anywhere Server software.

2 Do one of the following:

a If your Windows NT computer is running Windows NT Workstation software, 
click 
Start > Programs > Administrative Tools (Common) > User Manager. 

b If your Windows NT computer is running Windows NT Server software:

i Click Start > Programs > Administrative Tools (Common) > User Manager for 
Domains.

ii Click User > Select Domain and type the local machine name in the Domain 
box, and then click OK.   

Note:  If the user does not already exist, create the user (User > New User).

3 Click Policies > User Rights to open the User Rights Policy dialog box.

4 Select Show Advanced User Rights.

5 In the Right list box of the User Rights Policy dialog box, select Access this computer 
from network.

6 Click Add.

7 In List Names From, select the domain of the account running the SQL Anywhere 
database server.

8 Click Show Users.

9 In the Names list, select the account running the SQL Anywhere database server.

10 Click Add, and click OK.

11 In the Right list box of the User Rights Policy dialog box, select Log on as a service.

12 Repeat Steps 7 through 10.

13 In the Right list box of the User Rights Policy dialog box, select Log on locally.

14 Repeat Steps 7 through 10.

15 Click OK.

16 Click User > Exit.
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Defining User Privileges on Windows 2000

To define privileges for a user account running a SQL Anywhere database server:

1 Make sure you have installed the Sybase SQL Anywhere Server software.

2 Do one of the following:

a If you are running on a Windows 2000 Server, click 
Start > Programs > Administrative Tools > Local Security Policy. 

b If you are running Windows 2000 Professional:

i Click Start > Settings > Control Panel.

ii Select Administrative Tools.

iii Select Local Security Policy.

3 Select Local Policies>User Rights Assignments.

4 In the right pane of the Local Security Settings dialog box, double-click Log on as a 
service and click Add.

5 In the Look In field of the Select Users or Groups dialog box, select the domain of 
the account running the SQL Anywhere domain server.

6 In the Name list, select the account running the SQL Anywhere database server and 
click Add.

7 Click OK twice to return to the Local Security Settings dialog box.

8 Close the Local Security Settings dialog box.

Creating a SQL Anywhere Database Server

A SQL Anywhere database server is a process that runs on the database server 
machine. Its function is to coordinate all activity against your SQL Anywhere 
databases. You can create one SQL Anywhere server to provide access to all of your 
database files, including all of the ones in your test datastore(s).

To create a SQL Anywhere database server: 

1 From the Start menu, click Rational Administrator.

2 Click Tools > Sybase Central.

3 In the left pane, click Services under Sybase SQL Anywhere.

4 In the right pane, double-click Add Service to launch the Create New Service 
wizard.

5 Click Next.
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6 In the Choose Service Type dialog box, select Network Server and click Next.

7 In the Choose Name and Startup dialog, enter the name of the service, select the 
manner in which the service will be started (we recommend Automatic), and click 
Next.

Note:  Do not use spaces or nonalphanumeric characters in the server name. 
(Underscores are acceptable.)

The Choose Path Name dialog displays the default path for the executable file for 
the new service. This is the path to the SQL Anywhere database server executable 
(DBSRV50.EXE) that exists in the SQLANY50\WIN32 subdirectory within the 
Rational install directory. This should be set by default.

Note:  A Windows 2000 defect causes the path to display incorrectly on the Choose 
Path Name dialog. In that case, click Browse to locate the DBSRV50.EXE.

8 Click Next.

9 In the Specify Parameters dialog use the -n flag and enter the database server 
name; for example:

-n MyDBServer

The database server name is the only required parameter for Rational tools. The 
name you enter here is required when creating a ClearQuest database or Rational 
Test datastore.

10 Click Next.

11 In the Choose Account dialog, click Other, select Administrator, enter a password, 
enter the same password again to confirm, and click Next.

Note:  The account you specify must have Log on as a Service privilege. If the 
account does not have this privilege, Sybase displays a message to that affect. Click 
Yes to grant the privilege when the service is installed.

12 In the Choose Options dialog, we recommend that you select Start service when 
created and click Next.

13 The Ready to Create New Service dialog displays the settings you have selected. 
Confirm that the settings are correct and click Finish.
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Creating a SQL Anywhere Test Datastore 
Note:  You must install the Sybase SQL Anywhere software and create a SQL 
Anywhere database server before you create a SQL Anywhere test datastore.

To create a SQL Anywhere test datastore: 

1 Click Start > Programs > Rational Product > Rational Administrator.

2 In the left pane, right-click a project to configure and select Configure Project.

3 Under Test Assets, click Create.

4 Type the path of the new test datastore or click Browse to select a path. If you are 
going to use SQL Anywhere as the database engine, specify a path to a directory 
on the computer that is running the SQL Anywhere database server. 

5 Optionally, choose the initialization options you want:

❑ To initialize the test assets from an existing test datastore, select Initialize Assets 
from the following Test Datastore. Type the path of the existing test datastore, or 
click Browse to select a path.

Note:  It does not matter what database type the source datastore uses.

❑ To initialize the test users and groups in the new test datastore from an existing 
Rational project, select Initialize Test Users and Groups from the Rational Project. 
Enter or browse to the path of the existing Rational project.

6 Click Advanced Database Setup in the Create Test Datastore dialog.

7 In the Advanced Database Setup dialog:

a Click the Use Sybase SQL Anywhere for database engine button.

b Specify the name of the SQL Anywhere database server. This should be the 
same name you specified when creating the SQL Anywhere database server in 
Step 7 in Creating a SQL Anywhere Database Server on page 34.

c Select the protocols that the client computers running Rational Test will use to 
communicate with the SQL Anywhere database server.  You may need to 
confer with your IT department or appropriate network specialist.

d Optionally, specify a comma-separated list of computer names or computer IP 
Addresses — running SQL Anywhere database servers — that can be quickly 
searched. This is particularly important when the computer(s) running the SQL 
Anywhere servers is not in the immediate network segment (or subnetwork).

8 Click OK to return to the Create Test Datastore dialog.

9 Click OK to finish creating the test datastore.
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Converting a Test Datastore from Microsoft Access to SQL Anywhere

You use the Test Datastore Properties dialog to convert an existing Microsoft Access 
test datastore to SQL Anywhere test datastore.

Important: You cannot change a SQL Anywhere test datastore to a Microsoft Access 
test datastore.

Note:  You must install the Sybase SQL Anywhere software and create a SQL 
Anywhere database server before you change an existing Microsoft Access test 
datastore to a SQL Anywhere test datastore.

Note:  We recommend backing up your test datastore before starting the conversion.

Note:  All test datastore users must log off of a Rational project before you change the 
database engine of a Rational Test datastore.

Note:  When you change from a Microsoft Access test datastore to a SQL Anywhere 
test datastore, the Crystal Reports dictionaries are replaced. All modifications out of 
the box to the Crystal Reports dictionaries are lost.

To convert an existing Microsoft Access test datastore to a SQL Anywhere test 
datastore:

1 Select the project to which you want to connect. Click File > Connect. 

2 Select a Test datastore in the project hierarchy of the left (project) pane.

3 Click Edit > Properties.

4 Click Advanced Database Setup.

5 In the Advanced Database Setup dialog:

a Click Use Sybase SQL Anywhere for database engine.

b Specify the name of the SQL Anywhere database server. This should be the 
same name you specified when creating the SQL Anywhere database server in 
Step 7 in Creating a SQL Anywhere Database Server on page 34.  

c Select the protocols that the client computers running Rational Test will use to 
communicate with the SQL Anywhere database server.  You may need to 
confer with your IT department or appropriate network specialist.   

d Optionally, specify a comma-separated list of computer names or computer IP 
Addresses — running SQL Anywhere database servers — that can be quickly 
searched. This is especially important when the computer(s) running the SQL 
Anywhere servers is not in the immediate network segment (or subnetwork).
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6 Click OK to convert the test datastore to SQL Anywhere.  If the operation fails to 
complete successfully, the original configuration is reset, leaving Microsoft Access 
as the database engine in use.

7 Click OK to close the Test Datastore Properties dialog. 

Managing a SQL Anywhere Database Server

See the Sybase online Help for more information about managing a SQL Anywhere 
Database Server.

Installing the Rational Test Enablers

The Rational Test Enablers consist of the following:

■ Rational ActiveX Test Control – Install to test the properties of the ActiveX 
controls in your application-under-test using Robot. 

Note:  If you are using a development environment other than PowerBuilder, 
Oracle Forms, Visual Basic, Delphi, Java, or HTML, and you want to test the 
properties of your ActiveX controls, you must manually add the Rational ActiveX 
Test Control to each OLE container in your application. For instructions, see the 
documentation that comes with your development environment.

The ActiveX Test Control provides communication between any OLE container 
and Robot. It is a nonintrusive control and has no impact on the behavior or 
performance of your application. At runtime, the Rational ActiveX Test Control is 
not visible. 

■ Rational Test Java Enabler – Required to test Java applets running in a browser, or 
to test stand-alone Java applications. This Enabler scans your hard drive for Web 
browsers and Sun JDK installations that Robot supports and enables only those 
environments currently installed on your system. Run the enabler each time you 
install a new Java environment (such as a new release of a browser or JDK).

Note:  The Rational Test Enabler for Java is intended to work from a Custom or 
Typical installation only.  The Rational Test Enabler for Java does not work if you 
do a network install of Rational Suite. Installation of the Java Enabler customizes 
your computer and updates files that were installed on your computer. When you 
do a minimal/network install, the files that need to be updated are on your CD as 
read-only files and cannot be updated. 
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■ Rational Test Oracle Forms Enabler – Install to test Oracle Forms 6.0, 5.0, and 4.5 
applications. Installs both the Rational Test Oracle Forms Enabler and the 
Rational Test Object Testing Library for Oracle Forms. 

Note:  Be sure to install Oracle Forms 6.0, 5.0, or 4.5 and the Oracle Open Client 
Adapter for ODBC before you install the Rational Test Oracle Forms Enabler.

■ Rational Test Delphi Enabler – Install to test your Delphi applications. Before you 
can test your Delphi applications, you must install the Rational Object Testing 
Library for Delphi and the Rational Test Delphi Enabler.

■ Rational Test Visual Basic Enabler – Install to test Visual Basic 4.0 applications. 
Ensures that all forms in your project, including MDI forms, contain the Rational 
ActiveX Test Control. This Enabler is an add-in (extension) to Visual Basic 4.0. For 
more information about Visual Basic add-ins, see your Visual Basic 
documentation. 

Note:  You do not need the Visual Basic Enabler to test Visual Basic 5.0 and later 
applications.

For more information about the Rational Test Enablers, see the Rational Robot User’s 
Guide.

To install the Rational Test Enablers: 

1 Turn on the computer to start Windows.

2 Insert the Rational Solutions for Windows Disc 1 CD into your CD drive. The 
installation starts automatically.

If the installation does not start automatically, do the following:

a Click Start > Run.

b Type drive:\SETUP.EXE, and then click OK.

3 At the Rational Software Setup screen, click Next.

4 Select Rational Test Enablers and click Finish.

The Rational Test Enablers installation starts.

5 Select one or more of the following, and then click Next.

❑ Rational ActiveX Test Control

❑ Rational Test Oracle Forms Enabler

❑ Rational Test Java Enabler 
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❑ Rational Test Visual Basic Enabler

❑ Rational Test Delphi Enabler

6 Follow the on-screen instructions to complete the installation.

Installing the Sample Applets

The Rational sample applets are included:

■ Small sample applets – You can install sample applets for Java, HTML, Oracle 
Forms, PowerBuilder, and Visual basic development environments.

To install the sample applets:

1 Install Robot, Rational TeamTest, TestStudio, or EnterpriseStudio. For information 
about installing Robot and Rational TeamTest, see Installing Rational Robot, Team 
Test, and TestManager on page 12.

Note:  You cannot install the Rational sample applets if your only installed Rational 
testing product is TestManager.

2 Click Start > Programs > Rational product name > Rational Test > Set Up Rational Test 
Samples.

3 Select the sample applets that you want to install:

❑ HTML Sample

❑ Java Sample

❑ Visual Basic Sample

❑ PowerBuilder Sample

❑ Oracle Sample

4 Click Next.

5 Click Finish to complete the installation.

Installing Crystal Reports

Crystal Reports lets you customize defect reports that come with Rational TeamTest. 
Crystal Reports also lets you create new report formats. This software comes on a 
separate CD in your Rational testing software kit.

To install Crystal Reports 8.0 Professional Edition use the Crystal Reports installation 
directions that come with the CD.
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Installing Rational ManualTest Web Execution

A manual test script is a set of testing instructions that are run by a human tester. A 
manual test script can consist of steps and verification points that you type into a 
manual test script using Rational ManualTest. After you create a manual test script 
and associate it with a test case, creating a test case implementation, you can run the 
test case from a Web browser. For information about creating a manual test script and 
about test case implementations, see the Rational TestManager User’s Guide.

With the ManualTest Web Execution component of Rational TestManager, you can:

■ Run a test case with a manual test script implementation from a Web browser. The 
advantage to using the ManualTest Execution feature of TestManager is that you 
need only Web browser software to run a test case with a manual test script 
implementation. 

■ Indicate results and add comments as you perform each task in a manual test 
script. These results appear in a test log.

■ Include your test case results in a TestManager report.

When you run a test case, you view and record the results of performing the manual 
steps and verification points in the manual test script. 

Note:  You can only run a test case from a Web browser if it has a manual test script 
implementation; you cannot run a test case with an automated test script 
implementation from a Web browser. If a test case has both a manual test script and an 
automated test script implementation, only the manual test script runs from a Web 
browser.

To run a test case associated with a manual test script, you or an administrator must 
install and configure a Web server with ManualTest Web Execution software and 
configure a Web browser on each client to access a Rational project. Use a Web 
browser to run a test case with a manual test script implementation, and type the 
computername, the network name of the Web server, and the alias – the name of 
an alias for the directory where you or your administrator installed the ManualTest 
Web Execution software on the Web server. 

For example:
http://Webserver1/ManTestdir

For information about setting up a Web browser and installing a Web server, see 
Installing a Web Server on page 42 and Setting Up a Web Browser (Optional) on page 49.
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Software Requirements

Make sure that your server conforms to the following minimum requirements for a 
Web server:

For the Web server:

■ Windows XP Professional, Windows 2000 Professional, Windows 2000 Server, 
Windows 2000 Advanced Server, Windows 98, Windows NT 4.0 Workstation, or 
Windows NT 4.0 Server.

■ Microsoft Internet Explorer 5.0 or later on the Web server.
 

Note:  We recommend that you use Windows 2000 Server, Windows 2000 Advanced 
Server, or Windows NT 4.0 Server as the Web server platform. You cannot use a 
shared or networked project with the Windows XP Professional, Windows 2000 
Professional, or Windows NT 4.0 Workstation.

To access the Web server as a client, use one of the following Web browsers:

■ Netscape Navigator 4.0 or later

■ Microsoft Internet Explorer 4.0 or later

About Shared Projects

We recommend that when you create a project, you make it a shared project so others 
can access your manual test scripts from a Web browser. To share a project, create the 
project in a shared directory and use the Uniform Naming Convention (UNC) for the 
directory name. 

Note:  UNC paths are required for GUI test scripts that are run on Agent computers.

(For more information about creating a shared directory, see the Rational Suite 
Administrator’s Guide or the Rational Administrator Help.)

For Install

All versions of Windows XP 
and Windows 2000

Microsoft Internet Information Services 5.0 (IIS 5.0) 
from the Windows CD

Windows 98 or the Windows 
NT 4.0 Workstation

Microsoft Personal Web Server (PWS) from the 
Windows NT 4.0 Option Pack (available from 

Microsoft, www.microsoft.com)

Windows NT 4.0 Server Microsoft Internet Information Server (IIS) from the 
Windows NT 4.0 Option Pack (available from 

Microsoft, www.microsoft.com)
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Installing a Web Server

To install a Web server to run a test case with a manual test script implementation 
from a Web browser:

1 Install the ManualTest Web Execution component. 

a Turn on the computer to start Windows.

b Log on using an account with Administrator privileges.

c Quit all applications before installing any Rational products.

d Insert the Rational Solutions CD 1 into your CD drive.

The installation starts automatically.

If the CD does not start automatically, click Start > Run. Type drive:\SETUP.EXE, 
and then click OK.

e On the Rational Software Setup page, click Next.

f At the Choose Product screen, select one of the following Rational testing 
products from the list of available products:

➑ Rational Robot

➑ Any Rational Suite product

➑ Rational TeamTest

➑ Rational TestManager

A green check mark next to a Rational product indicates you have a license key 
configured for that product. If you do not see a green check mark next to the 
product you want to install, you may want to install license keys before you 
install the product.

To configure a license key, click the Configure Licenses button to launch the 
Rational License Key Administrator (LKAD) and the License Key 
Administrator Wizard. 

If you do not install the license keys before you install the product, the LKAD 
appears at the end of the installation.

For more information about software licenses, click Help or see the Rational 
Software License Administrator’s Guide. 
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g Click Next.

If you did not install the license keys before you installed the product, the Setup 
program displays a message. Select OK to install without licensing configured. 
Select Cancel to go back and configure licensing.

h Read the terms of the license agreement carefully, select Yes, I accept the 
agreement, and click Next.

If you do not accept the agreement, the Setup program ends. 

i Do one of the following on the Select Configuration page:

➑ If you want to create manual test scripts on the Web server, click Custom to 
install a Rational testing product.

Click Custom, and then click Next.

Expand Web Server Components. 

Select the Rational ManualTest Web Execution check box.

Note:  You do not need to install a Rational testing product on the Web 
server unless you want to create manual test scripts on the Web server. 

➑ If you do not want to create manual test scripts on the Web server machine 
using the manual test client and only want to set up a Web server to run 
scripts:

Click Custom, and then click Next.

Clear all check boxes on the Choose Features page.

Expand Web Server Components. 

Select the Rational ManualTest Web Execution check box.

j Follow the on-screen instructions to complete the installation. 

The Rational Setup wizard displays a series of dialog boxes that guide you 
through the installation process and prompt you for information.

k Click Finish when done.

Your system restarts. 

2 Install Microsoft Windows NT 4.0 Option Pack or Microsoft Internet Information 
Services 5.0 on the Web server by doing one of the following:

❑ For a Web server running Windows XP or Windows 2000, install the Microsoft 
Internet Information Services 5.0 from the Windows CD. 
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❑ For a Web server running Windows NT 4.0 Server, install the Microsoft Internet 
Information Server (IIS) from the Windows NT 4.0 Option Pack.

❑ For a Web server running Windows 98 or Windows NT 4.0 Workstation, install 
the Microsoft Personal Web Server (PWS) from the Windows NT 4.0 Option 
Pack. 

3 Install Microsoft Internet Explorer 5.0 or later on the Web server. 

Note:  Although a client can use Microsoft Internet Explorer 4.0, you must install 
Microsoft Internet Explorer 5.0 or later on the Web server.

4 Configure the Microsoft Access Driver by doing the following:

a Click Start > Settings > Control Panel.

b Do one of the following:

For Windows 2000, double-click Administrative Tools, and then double-click 
Data Sources (ODBC).

For Windows 98 and NT 4.0 Workstation and Server, double-click ODBC Data 
Sources.

c Click the Connection Pooling tab.

d Under ODBC Drivers, double-click Microsoft Access Driver (*.mdb).

e Select Don't pool connections to this driver, and then click OK.

f Click OK.

g Restart the system.

5 Configure the Web server to run a test case from a Web browser by doing one of 
the following: 

❑ For a Web server running Windows 2000 Professional, Windows 98, or a 
Windows NT 4.0 Workstation, see Configuring a Microsoft Personal Web Server on 
page 47.

❑ For a Web server running Windows NT 4.0 Server, Windows XP Professional, 
Windows 2000 Server, or Windows 2000 Advanced Server, see the next section, 
Configuring a Microsoft Internet Information Server. 
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Configuring a Microsoft Internet Information Server

To configure the Microsoft Internet Information Server (IIS) on all versions of 
Windows XP, Windows 2000, or a Windows NT 4.0 Server:

1 Do one of the following:

❑ For all Windows XP systems, click Start > Control Panel 
Double-click Administrative Tools. Double-click Internet Services Manager.

❑ For all Windows 2000 systems, click Start > Settings > Control Panel. 
Double-click Administrative Tools. Double-click Internet Services Manager.

❑ For Windows NT 4.0, click Start > Programs > Windows NT 4.0 Option Pack > 
Microsoft Internet Information Server > Internet Service Manager.

2 Optionally, double-click Internet Information Server to display all machines.

3 Do one of the following:

❑ For all Windows XP systems, double-click computername 

where computername is the network name of the Web server and double-click 
Web Sites.

❑ For all Windows 2000 and Windows NT 4.0 systems, double-click 
computername 

where computername is the network name of the Web server.

4 Click Default Web Site.

5 Right-click, and then click New > Virtual Directory.

6 Do one of the following:

❑ For Windows XP and Windows 2000, click Next, and then go to the next step.

❑ For Windows NT 4.0, go to the next step.

7 Type an alias for the directory where you installed your Rational software on the 
Web server.

For example: TM

Note:  Write down this alias. You must use this alias to run a test case from a Web 
browser.

8 Click Next.
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9 Type the drive and path of the location where you installed your Rational 
software, or click Browse to select the drive and path.

For example, the default location is:

c:\Program Files\Rational\Rational Test\www\manual script

10 Click Next.

11 Do one of the following:

For Windows XP and Windows2000, select the following options to allow 
privileges to the Rational project:
❑ Read
❑ Run scripts (such as ASP)

For Windows NT 4.0 Server, select the following options to allow privileges to the 
Rational project:
❑ Allow Read Access
❑ Allow Script Access
❑ Allow Execute Access

12 Do one of the following:

❑ For Windows XP and Windows 2000, click Next, and then click Finish.

❑ For Windows NT, click Finish.

13 Right-click the new alias, and then click Properties.

14 Click the Documents tab.

Ensure that the following files appear under the Enable Default Document box:
❑ Default.asp

❑ Default.htm

If these file do not appear, do the following:

a Click Add.

b Type Default.asp, and then click OK.

15 Click the Directory Security tab.

16 Under Anonymous and Authentication Control, click Edit.

17 Make sure that you select the Allow Anonymous Access check box, and then click 
Edit. 
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18 Do one of the following:

❑ For Windows XP and Windows 2000, clear the Allow IIS to control password 
check box, and then go to the next step.

❑ For Windows NT 4.0, clear the Enable Automatic Password Synchronization 
check box, and then go to the next step.

19 Type the Username and Password for the user account either on this Web server (if 
the project is on the Web server), or on the domain (to access shared projects on 
other systems in the domain). 

Note:  Windows XP does not support the assignment of the Administrator user as 
the access user of a web client.

All Web clients use this user account to access a Rational project either on a Web 
server or on the domain (to access shared projects on other systems in the domain). 
This user account must have privileges to read and write into a Rational project. If 
you want Web clients to have access to a Rational project, you must log onto this 
account when you create a new Rational project or register an existing Rational 
project using the Administrator.

Note:  By configuring the privileges to this account, you can restrict access to 
certain shared projects. For more information about setting privileges, see your 
Microsoft Windows 2000 or Windows NT 4.0 documentation.

20 Click OK to close all windows.

Configuring a Microsoft Personal Web Server
Note:  If you use Windows NT 4.0 Workstation or Windows 2000 Professional with the 
Personal Web Server, you can access only local projects. To access shared projects with 
Windows 2000 Professional or Windows 98, you must run PWS under a domain user 
account.

To configure the Microsoft Personal Web Server (PWS) on a Windows 98 or Windows 
NT 4.0 Workstation server:

1 For Windows 98 or Windows NT 4.0 Workstation, be sure to install the Microsoft 
Personal Web Server (PWS) from the Windows NT 4.0 Option Pack (available from 
Microsoft, www.microsoft.com).

2 Do one of the following:

❑ For Windows 98, click Start > Programs > Microsoft Personal Web Server > 
Personal Web Manager.
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❑ For Windows NT 4.0 Workstation, click Start > Programs > Windows NT 4.0 
Option Pack > Microsoft Personal Web Server > Personal Web Manager.

3 Click Advanced.

4 Select <Home>.

5 Click Add.

6 Under Directory, type the drive and path of the location where you installed your 
Rational software, or click Browse to select the drive and path.

For example, the default location is:

c:\Program Files\Rational\Rational Test\www\manual script

7 Under Alias, type the alias for the directory where you installed your Rational 
software on the Web server.

For example: TM

Note:  Write down this alias. You must use this alias to run manual test scripts on this 
Web server through a Web browser.

8 For Windows 98 or Windows NT 4.0 Workstation, under Access, click all of the 
following: Read, Execute, and Scripts.

9 Click OK.

10 Click Properties > Exit.

11 Complete the steps for either Windows 98 or Windows NT 4.0 Workstation.

If you have Windows 98 you are finished with the configuration. If you have a 
Windows NT 4.0 Workstation, 

a Click Start > Programs > Administrative Tools (Common) > 
User Manager.

b Under the User Name column, select:

IUSR__computername

where computername is the name of the Web server.

c Click User > Properties. 

d Click Groups.

e Under Not members of, select Administrators, and then click Add. 

f Click OK. Click OK again.

g Click User > Exit.
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Setting Up a Web Browser (Optional)

You can use Netscape Navigator 4.0 (or later) or Microsoft Internet Explorer 4.0 (or 
later) as your Web browser to run a test case. You can use your Web browser on a 
system running any operating system software.

Netscape Navigator

To set up a Netscape Navigator browser to run a test case:

1 Start Netscape Navigator.

2 Click Edit > Preferences. Under Category, click Advanced.

3 Double-click Advanced, and then click Cache to display the Cache panel.

4 In the Cache panel, click Every time.

5 Click OK.

Microsoft Internet Explorer 

To set up a Microsoft Internet Explorer browser to run a test case:

1 Start Internet Explorer.

2 Do one of the following:

❑ For Internet Explorer 5.0 or later, click Tools > Internet Options. 

❑ For Internet Explorer 4.0, click View > Internet Options.

3 Click the General tab.

4 Under Temporary Internet files, click Settings.

5 Under Check for newer versions of stored pages, click Every visit 
to the page.

6 Click OK. Click OK again.

Troubleshooting 

This section lists some problems you may experience when running a test case from a 
Web browser, a description of each problem, and how to correct each problem.

Note:  The error messages in this troubleshooting section are ManualTest Web 
Execution error messages, not Web browser error messages.

Problem – Your Rational projects do not appear when you log onto a Rational project. 
(You type http://computername/alias and log onto a Rational project.)
Error message – None.
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Solution – All Web clients use the same user account to access a Rational project either 
on a Web server (if the project is on the Web server), or on the domain (to access 
shared projects on other systems in the domain). 

There are two things to check:

■ Check to make sure that this user account has privileges to read and write into a 
Rational project. (Ask your administrator to check the privileges of the user 
account that they set up on the Web server.)

■ To allow Web clients access, you must also log onto this account when you create a 
new Rational project or register an existing Rational project using the 
Administrator.

Problem – You cannot connect from a Web browser to a Web server running the 
Microsoft Personal Web Server (PWS). 
Error message – None.
Solution – If you restart a Web server running PWS, PWS may not start automatically 
when the server restarts. This is an intermittent problem. To fix the problem, restart 
PWS.

To restart PWS:

1 Click Start > Programs > Windows NT 4.0 Option Pack > Microsoft Personal Web 
Server > Personal Web Manager.

2 Under Publishing, click Start.

3 Click Properties > Exit.

Problem – When you log onto a project from a Web browser, you receive an error 
message.
Error message – Unable to connect to project.
Solution – Make sure the Web server privileges are set correctly. For information about 
setting privileges, see Configuring a Microsoft Internet Information Server on page 45 or 
Configuring a Microsoft Personal Web Server on page 47.

Problem – You get an error message when you select a manual test script.
Error message – Error message that includes Server.ObjectCreate in the 
message.
Solution – Make sure that you or the Web server administrator installs Microsoft 
Internet Explorer 5.0 or later on the Web server.
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Problem – When you type text in a dialog box and submit it, you observe erratic 
behavior. Alternatively, when you open a manual test script, results and comments 
are already filled in from the last session. 
Error message – None.
Solution – Disable caching on your Web browser. For information about disabling 
caching, see Setting Up a Web Browser (Optional) on page 49.

Problem – After you connect to the Web server, a Login dialog box appears. In the 
Login dialog box, the project select list is empty.
Error message – None.
Solution – Create a project and create manual test scripts, or register an existing project 
that contains manual test scripts. 

To create a project or register an existing project:

1 Do one of the following:

❑ For IIS, log onto the user account of the virtual directory that you configured to 
run a test case. For information, see Configuring a Microsoft Internet Information 
Server on page 45.

❑ For PWS, log onto the user account that the Web server runs under. For 
information, see Configuring a Microsoft Personal Web Server on page 47.

2 Start the Administrator and create a new project, or register an existing project. For 
information about creating or registering a project, see the Rational Suite 
Administrator’s Guide or the Rational Administrator online Help.

3 If you create or register a shared project, make sure that the privileges for the 
project directory are set for the virtual directory user account for IIS, or for the user 
account that the Web server runs under for PWS.

4 Restart the Web server.

Troubleshooting Your Web Server

If you have problems with your Web server, ensure that your Web server meets the 
software requirements. For information, see Software Requirements on page 41. 
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