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Welcome to the Rational RequisitePro User’s Guide. This guide provides a 
complete reference for the features and options available in Rational 
RequisitePro (hereafter referred to as RequisitePro).

RequisitePro requirements management software from Rational Software
Corporation integrates a powerful multi-user requirements database tool 
Microsoft Word for Windows, enabling you to build a requirements databa
and requirements documents simultaneously.

About this Manual

Reading to Meet Your Needs
The RequisitePro User’s Guide is designed to meet the diverse needs and 
responsibility levels of various types of users. Users may perform differen
roles that vary depending on the RequisitePro project they access. The r
listed below describe typical user functions; however, they may not corresp
directly to RequisitePro security groups. RequisitePro administrators can
create any number of security groups with specific permissions for creatin
updating, and deleting projects, documents, and requirements.

Requirements viewers read documents, query the requirements databa
and participate in discussion groups. These are common activities for
RequisitePro users.

Requirements contributors perform the common activities of 
requirements viewers; however, they have additional permissions to 
modify requirements attribute values. 

Requirements authors use standardized templates to write or revise 
requirements documents and add, delete, or revise requirements in th
project database. The templates are created by the project managers

Project managers create and manage all elements of a project – includ
security, document types and requirement types – and set up cross-pr
traceability.
xv



Preface

oves 

el of 
The RequisitePro User’s Guide is organized to initially introduce activities 
that are common to all users who view and query requirements. It then m
to the skills needed for creating and managing requirements. Finally it 
addresses the advanced skills required for managing projects.

Refer to the following table which recommends reading based on your lev
use in RequisitePro:

All readers should refer to Appendix A: Keyboard Shortcuts and Mouse 
Actions, Appendix B: Customizing RequisitePro, and the Glossary, which 
defines technical terms used in RequisitePro.

Recommended Chapters

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

Requirements
Viewers

Requirements 
Contributors

Requirements
Authors

Project
Managers

Type of 
User
xvi
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RequisitePro Conventions

Typographical Conventions Used Throughout this Manual:

File Extensions Used in RequisitePro:  

See also Appendix A: Keyboard Shortcuts and Mouse Actions

Convention Usage

Capitalization Signifies an item on a menu.
For example, Open represents the Open 
command on the Project menu.

Carrot symbol
>

Used to show the path of selecting menu 
commands in RequisitePro
For example, click Project > Open means click 
the Project menu and choose the Open 
command.

Italics Used to emphasize a word, term, or file name 
(ex., tlearn.rqs).

Boldface Signifies menu options and buttons in 
RequisitePro windows or dialog boxes.

File Extension Definition

.def An outline’s definition file.

.doc A Word document.

.dot A Word template.

.hlp A Windows application help file.

.txt

.mnu

Plain text menu files used to add 
commands to Tool Palette menus.

.rqs A text file for project information.
xvii
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Using Online Help

You can view online help within RequisitePro whenever you need assista
To display the Help Contents:

• Click the Help button on the Tool Palette. 

• Or, on the Tool Palette, click Help > Contents and Index.

• Or, press the F1 key.

• Or, click the Help button in any dialog box.

Let’s Go RequisitePro
Let’s Go RequisitePro, a new help interface that automatically appears w
you start the application, provides prominent access to beneficial informa
about setting up RequisitePro projects and the Requirements Manageme
process. Let’s Go RequisitePro guides new users through the various “ge
started” information available in RequisitePro, including online help and t
Learning Project. For advanced users, it provides a single source for acce
pertinent, in-depth documentation, including whitepapers, the Rational 
Unified Process, and Web resources.

Let's Go RequisitePro automatically appears when you start RequisitePro
you can disable it by clearing the check box on the Tools > Options dialog box 
or on the initial Let's Go RequisitePro splash screen.

You can launch Let's Go RequisitePro at any time from the Help menu. C
Help > Let's Go RequisitePro.

Getting Started Tours
You can access three online help tours from either Let’s Go RequisitePro or 
the Getting Started book in the help Contents tab:

• Quick Start, a basic tour through RequisitePro’s project, document an
requirements structure;

• Requirements Management Tour, an overview for using RequisitePro 
as part of a requirements management process; and

• Project Administration Tips , a guide for RequisitePro project 
administrators, who will be setting up and managing projects.
xviii
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 Word 
Also available from the Getting Started book on the Contents tab are topic
the Learning Project tutorial (see below) and basic topics on using 
RequisitePro.

The Learning Project Tutorial

The Learning Project is an online tutorial designed to help you quickly lea
how to use specific RequisitePro features. If you are a new user, the bes
to take a quick tour of RequisitePro is by working through the Learning 
Project.

Note: In the Learning Project 4.5, we have documented requirements u
a use-case design process. For an example of a RequisitePro pro
that does not include use cases, refer to the sample project, 
QuarterByte Savings Bank Example Project, which is included by 
default in your RequisitePro project list.

The Learning Project 4.5 automatically appears in the project list in the Ope
Project and Documents dialog box, where you can open the project and i
documents. The documents contain an easy-to-use tutorial with exercise
guide you through RequisitePro’s main features. You can explore the key
features of RequisitePro using documents and requirement examples fou
the use case-driven approach to capturing requirements popularized by t
Unified Modeling Language (UML), Rational Rose, and the Rational Unifi
Process. The Learning Project 4.5 presents RequisitePro concepts in a u
case-driven example, although these concepts are equally applicable in a
other approaches to requirement management.

To begin exploring the Learning Project, do the following:

1. On the RequisitePro Tool Palette, click Project > Open.
The Open Project and Documents dialog box appears.

2. In the Select a Project list, select Learning Project 4.5.

3. In the Select Document(s) list, select the following document:
Welcome to the Learning Project

4. Click OK .
If your user name has not been added to the project, the Project Logo
dialog appears. Type your user name or select one from the list and c
OK .

The project and documents are opened. The documents appear in the
Workplace.
xix
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5. Read the Welcome Document.

6. To continue the Learning Project tutorial, follow the instructions at the e
of the document. As you review the document, read and follow the 
instructions as you encounter them.

Rational Training Services

Rational offers requirements management classes and tool training for 
RequisitePro 4.5 users. Rational University provides a professional educa
curriculum that includes the following requirements management classes

Requirements Management

This class provides training in eliciting and managing the changing 
requirements of a project. Topics include: problem analysis, product featu
definition and requirements specification, definition of requirement attribut
and maintenance of traceability for use in scope management, change 
management, and impact analysis.

Requirements Management with Use Cases

This extended alternative to the Requirements Management class includ
the concepts introduced in that class. In addition, it provides an in-depth 
at use-case development that presents the concepts and techniques nec
to effectively capture system requirements using use cases.

Introduction to Rational RequisitePro

This class demonstrates implementation and usage of RequisitePro, inclu
terminology, configuration, and set up of the repository. Students gain ha
on training in designing projects, documents, populating projects with exte
data, and creating requirements for sharing data with project managemen
team members. Learn how to determine priorities, produce reports suitabl
management reviews, implement traceability, and manage requirements.

Advanced Rational RequisitePro

This class provides a two-day workshop in exploring and using the advan
features of RequisitePro. Skills learned can be applied to current Requisit
projects. Hands-on exercises and activities enhance understanding of 
RequisitePro in a distributed and integrated work environment.
xx
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Professional Education for Software Development Teams

In addition to requirements management, Rational University offers a var
of courses for the following disciplines:

• Analysis & Design and Visual Modeling

• Automating Software Test

• Rational Unified Process

• Configuration and Change Management

• Change Request Management

To register for Rational University courses, call 1-888-RATL-444 (728-544
or call your local Rational Solutions Provider. To register online, visit 
www.rational.com.

Contacting RequisitePro Technical Support

At Rational Software Corporation, we are committed to helping you meet y
requirements management goals. We welcome your comments on our pro
and services. If you have product suggestions or recommendations, plea
contact our Technical Support staff or your Rational account manager.

Rational Software Corporation offers telephone and e-mail support to 
customers with an active maintenance contract. If your maintenance con
has expired, please contact your Rational account manager. 

Potential customers using evaluation copies of RequisitePro should conta
their Rational account manager instead of Technical Support for assistan

Answers to most questions can be found in online help or in this manual.
RequisitePro Release Notes (readme.html) contain late-breaking updates. 
Consult these resources for answers to questions before contacting Ratio
Technical Support.
xxi
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If you cannot find the information you need, contact Rational Customer 
Support.

To find the version number and other information about your RequisitePr
product, on the RequisitePro Tool Palette, click Help > About RequisitePro.

E-mail
Please help our Technical Support staff deliver quality customer service b
providing complete information. The techsupport.html file, which is located in 
the RequisitePro installation directory and is also available by clicking Help > 
Contacting Technical Support, contains a Customer Information Form. Yo
can use this form to document problems, questions, or suggestions and to
your company and system information. The form can be copied into your
mail message.

Attach your error.log file (located in the ReqPro installation directory in the
bin folder) if you are getting an error message. Add any files, screen capt
and other information you feel are relevant.

Telephone
When contacting Rational for support, please be near the computer with 
Rational product installed, and be ready to provide the following informat

• Your Rational license number

• The RequisitePro version number

• The operating system and version number (for example, Windows NT
SP3)

• The version number of any other product that relates to the problem: 
Microsoft Word, MS Project, Visual SourceSafe, PVCS, ClearCase, e

Region Telephone Fax E-mail

North America 800-433-5444 303-544-7333 support@rational.com

Europe +31-(0)20-4546-200 +31-(0)20-4546-201 support@europe.rational.co

Asia Pacific +61-2-9419-0111 +61-2-9419-0123 support@apac.rational.com
xxii
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• A description of the problem, the steps that led to the problem, and a
error messages displayed

The Technical Support staff might also ask for information about your syst
such as: 

• The directory location of your RequisitePro executable file (ReqPro.exe) 
and the location of any other product that relates to the problem 
(filename.exe) (For example, C:\Program Files\Rational\RequisitePro 4

• System information: The CPU speed, the amount of RAM installed, 
the amount of free space available on your hard drive

• The network protocol vendor and version number

Visit Our Web Site

For more information about Rational Software Corporation, its products, 
services, and current new releases, visit our Web site at 
http://www.rational.com.

You can also select the following Web pages directly from the Help menu
pointing to the Rational on the Web menu option):

• Rational Home Page

• RequisitePro Home Page

• Technical Support

RequisitePro Users Mailing List 

Join our user group! Rational has implemented an open e-mail list 
“req_forum@rational.com” for customers to exchange ideas on using 
RequisitePro. This list is monitored to ensure product questions and prob
are being answered. 

To subscribe to the mailing list, go to the following Web site: 
http://www.rational.com/products/reqpro/usergroups 
xxiii
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If you have comments or suggestions about the RequisitePro documenta
please submit your feedback using the online comment form at 
http://www.rational.com/cgi-bin/www/techpub.cgi 
or e-mail us at techpubs@rational.com.

For technical problems and questions, please contact Technical Support.
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C  H  A  P  T  E  R   1 

Fundamentals of Requirements 
Management

This chapter is an excerpt from Rational’s white paper Applying Requirements 
Management with Use Cases. To review the full version of this or many othe
Rational white papers, please visit our Web site at http://www.rational.com
support.

Applying Requirements Management with Use Cases

If you are new to or somewhat familiar with requirements management and
interested in requirements process improvement, this paper offers a frame
with which to develop your own approach.

Software and System Development in the Age of Process
For most software and system development teams, the 1990s have been
process-intensive when compared to the more freewheeling days of the p
Standards for measuring and certifying effective software development 
process have been introduced and popularized. Many books and articles
software development process and related material on business process
modeling and re-engineering have been published. Increasing numbers o
software tools have helped define and apply effective software developm
process. The global economy's dependence on software accelerated in th
decade, enabling development processes and improving system quality.

So how do we explain the high incidence of the software project failure tod
Why are many, if not most, software projects still plagued by delays, budg
overruns, and quality problems? How can we improve the quality of the 
systems we build as our businesses, national economies, and daily activi
become increasingly dependent on them? 
1-1
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The answers, as always, lie in the people, tools, and processes applied t
profession. Requirements management is often proposed as a solution to
ongoing problems of software development, yet relatively little attention h
been focused on improving the practice of this discipline. 

This paper presents the elements of an effective requirements managem
process and highlights some of the obstacles to its successful implement

Why Manage Requirements? 
Simply put, system development teams who manage 
requirements do so because they want their projects to 
succeed. Meeting their project’s requirements defines 
success. Failing to manage requirements decreases the 
probability of meeting these objectives.

Recent evidence is supportive:

• The Standish Group’s CHAOS Reports from 1994 and 1997 establish
that the most significant contributors to project failure relate to 

requirements.1 

• In December 1997, Computer Industry Daily reported on a Sequent 
Computer Systems, Inc. study of 500 IT managers in the U.S. and U.K.
found 76 percent of the respondents had experienced complete proje
failure during their careers. The most frequently named cause of proj

failure was “changing user requirements.”2 

Avoiding failure should be sufficient motivation to manage requirements. 
Increasing the probability of a successful project and other benefits of 
managing requirements may be equally motivational. The Standish Grou
CHAOS report further established that managing requirements well was 
factor most related to successful projects.

What is a Requirement? 
The first step towards understanding requirements management is to agr
a common vocabulary. Rational defines a requirement as “a condition or 
capability to which the system [being built] must conform.” The Institute o
Electronics and Electrical Engineers uses a similar definition.

Meeting your
project’s
requirements defines
success.
1-2
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Well-known requirements engineering authors Merlin 
Dorfman and Richard H. Thayer offer a compatible and 
more refined definition that is specific - but not 
necessarily limited - to software:

“A software requirement can be defined as: 

• A software capability needed by the user to solve 
a problem or achieve an objective.

• A software capability that must be met or possessed by a system
system component to satisfy a contract, specification, standard, o

other formally imposed documentation.”3

What is Requirements Management?
Since requirements are things to which the system being built must confo
and conformance to some set of requirements defines the success or fail
projects, it makes sense to find out what the requirements are, write them
down, organize them, and track them in the event they change.

Stated another way, Requirements Management is: 

• a systematic approach to eliciting, organizing, and documenting the 
requirements of the system, and

• a process that establishes and maintains agreement between the 
customer and the project team on the changing requirements of the 
system.

This definition is similar to Dorfman and Thayer’s and the IEEE’s “Softwa
Requirements Engineering.” Requirements Engineering includes elicitatio

analysis, specification, verification, and management4. All of these activities 
are incorporated in the definition of requirements management presented
and taught by Rational Software. The difference lies mainly in the choice
the word “management” rather than “engineering.” Management is a mor
appropriate description of all the activities involved, and it accurately 
emphasizes the importance of tracking changes to maintain agreements 
between stakeholders and the project team.

A requirement is a
condition or
capability to which
the system must
conform.
1-3
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The Problems of Requirements Management
So what might be 
difficult about a 
process intended to 
ensure that a system 
conforms to the 
expectations set for it? 
When put into practice 
on real projects, 
difficulties come to 
light. Figure 1 displays 
the results of a 1996 
survey of developers, 
managers, and quality 
assurance personnel. It 
shows the percentage 
of respondents who 
experienced the most frequently mentioned requirements-related problem

A more comprehensive list of problems includes:

• Requirements are not always obvious and have many sources.

• Requirements are not always easy to express clearly in words.

• There are many different types of requirements at different levels of de

• The number of requirements can become unmanageable if not contro

• Requirements are related to one another and to other deliverables of
process in a variety of ways.

• Requirements have unique properties or property values. For exampl
they are neither equally important nor equally easy to meet.

• There are many interested and responsible parties, which means 
requirements need to be managed by cross-functional groups of peop

• Requirements change.

• Requirements can be time-sensitive.

When these problems are combined with inadequate requirements 
management and process skills, and the lack of easy-to-use tools, many 
despair of ever managing requirements well. Rational Software has devel

Figure 1

Common Requirements Problems

#1 Can’t track changes 71%

#2 Difficult to write

#3 Feature creep 67%

#4 Not well organized 54%

70%
1-4
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the expertise to instruct teams in requirements management skills and pro
In addition, Rational’s RequisitePro is an accessible tool for automating 
effective requirements management.

Requirements Management Skills 
To resolve the problems mentioned above, Rational encourages the 
development of key skills. These skills are presented below in what appea
be sequential order, but in an effective requirements management proces
are applied continuously in varied order. Here they are presented in the 
sequence one would likely apply to the first iteration of a new project.

Key Skill 1: Analyzing the Problem

Problem analysis is 
conducted to understand 
business problems, target 
initial stakeholder needs, and 
propose high-level solutions. 
These acts of reasoning and 
analysis find “the problem 
behind the problem.”

During problem analysis, 
agreement is gained on a 
statement of the real 
problems and the 
stakeholders are identified. 
Initial solution boundaries and constraints are defined from both technical
business perspectives. If appropriate, the business case for the project an
return on investment that is expected from the system.

Key Skill 2: Understanding Stakeholder Needs

Requirements have many sources. They may come from anyone with an
interest in the outcome of the project. Customers, partners, end users, an
domain experts are some sources of requirements. Management, project
members, business policies, and regulatory agencies can be others.

It is important to know how to determine who the sources should be, how
get access to those sources, and how to elicit information from them. The
individuals who serve as primary sources for this information are referred t
“stakeholders” in the project.

Figure 2

Steps in Problem Analysis
1-5
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If you are developing an information system to be used internally within y
company, you may include people with end-user experience and busines
domain expertise in your development team. Very often you will start the 
discussions at a business-model level rather than at a system level. If yo
developing a product to be sold to a marketplace, you may make extensiv
of your marketing people to better understand the needs of customers in 
market. 

Techniques for eliciting requirements include interviews, brainstorming, 
conceptual prototyping, questionnaires, and competitive analysis. The res
requirements elicitation is a list of requests or needs that are described tex
and graphically, and that have been given priority relative to one another

Key Skill 3: Defining the System 

To define the system means to translate and organize the understanding
stakeholder needs into a meaningful description of the system to be built. E
in system definition, decisions are made on what constitutes a requireme
documentation format, language formality, degree of requirements, reque
priority and estimated effort, technical and management risks, and scope
of this activity may include early prototypes and design models directly rela
to the most important stakeholder requests.

The outcome of system definition is a description of the system that is bo
natural language and graphical. Some suggested formats for the descriptio
provided in later sections. 

Principle 55
WRITE NATURAL LANGUAGE BEFORE A MORE FORMAL MODEL
If you write the formal model first, the tendency will be to write natural language that
describes the model instead of the solution system.

TO MAKE A LONG DISTANCE CALL, THE USER SHOULD LIFT THE PHONE.  THE SYSTEM SHALL
RESPOND WITH A DIAL TONE. THE USER SHOULD DIAL A “9”.  THE SYSTEM SHALL RESPOND
WITH A DISTINCTIVE DIAL TONE…

THE SYSTEM CONSISTS OF FOUR STATES: IDLE, DIAL TONE, DISTINCTIVE DIAL TONE, AND
CONNECTED.  TO GET FROM THE IDLE STATE TO THE DIAL TONE STATE, LIFT THE PHONE.
TO GET FROM THE DIAL TONE STATE TO THE DISTINCTIVE DIAL TONE STATE, DIAL A “9.”

Note that in the latter example, the text does not help the reader at all.

- Alan M. Davis, 201 Principles of Software Development, 1995
1-6
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Key Skill 4: Managing the Scope of the Project

The scope of a project is defined by its requirements. Managing project s
to fit the available resources (time, people, and money) is key to managin
successful projects. Managing scope is a continuous activity that requires
iterative or incremental development, which breaks project scope into sm
more manageable pieces.

Using requirement attributes, such as priority, effort, and risk, as the basi
negotiating the inclusion of a requirement is a particular useful technique
managing scope. Focusing on the attributes rather than the requirements
themselves helps desensitize negotiations that are otherwise contentious

It is also helpful for team leaders to be trained in negotiation skills and for
project to have a champion in the organization, as well as on the customer
Product/project champions, whether on the project team or not, should hav
organizational power to refuse scope changes beyond the available reso
or to expand resources to accommodate additional scope.

Key Skill 5: Refining the System Definition 

With an agreed-upon high-level system definition and a fairly well understo
initial scope, it is both possible and economical to invest resources in mo
refined system definitions. Refining the system definition includes two ke
considerations: developing more detailed descriptions of the high-level sys
definition, and verifying that the system will comply with stakeholder need
and behave as described.

The descriptions are often the critical reference materials for project team
Descriptions are best done with the audience in mind. A common mistake
represent what is complex to build with a complex definition, particularly 
when the audience may be unable or unwilling to invest the critical thinkin
necessary to gain agreement. This leads to difficulties in explaining the 
purpose of the system to people both inside and outside the project team
Instead, you may discover the need to produce different kinds of descript
for different audiences. This paper includes suggested formats for detaile
natural language, formal text, and graphical descriptions. Once the descri
format is established, refinement continues throughout the project lifecyc
1-7
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Key Skill 6: Managing Changing Requirements

No matter how carefully you define your requirements, they will change. I
fact, some requirement change is desirable! It means that your team is 
engaging your stakeholders. Accommodating changing requirements is a
measure of your team’s stakeholder sensitivity and operational flexibility 
team attributes that contribute to successful projects. Change is not the en
unmanaged change is. 

A changed requirement means that more or less time has to be spent on
implementing a particular feature, and a change to one requirement may 
an impact on other requirements. Managing requirement change include
activities such as establishing a baseline, keeping track of the history of e
requirement, determining which dependencies are important to trace, 
establishing traceable relationships between related items, and maintaini
version control. As Figure 3 illustrates, it is also important to establish a cha
control or approval process, requiring all proposed changes to be reviewe
designated team members.

Figure 3

The Key to Managing Change
All Requests Go Through a Single Channel
1-8
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Important Requirements Concepts
To apply requirements management skills to a project, certain requireme
management concepts are useful for everyone on the project to understa
They include:

Requirement Type. The larger and more intricate the system, the more typ
of requirements appear. A requirement type is simply a class of requirem
By identifying types of requirements, teams can organize large numbers 
requirements into meaningful and more manageable groups. Establishing
different types of requirements in a project helps team members classify 
requests for changes and communicate more clearly.

Usually, one type of requirement can be broken down, or decomposed, in
other types. Business rules and vision statements can be types of high-le
requirements from which teams derive user needs, features, and product
requirement types. Use cases and other forms of modeling drive design 
requirements that can be decomposed to software requirements and 
represented in analysis and design models. Test requirements are derived
the software requirements and decompose to specific test procedures. W
there are hundreds, thousands, or even tens of thousands of instances o
requirements in a given project, classifying requirements into types make
project more manageable.

Cross-Functional Teams. Unlike other processes, such as testing or 
application modeling, which can be managed within a single business gro
requirements management should involve everyone who can contribute t
expertise to the development process. It should include people who repre
the customer and the business expectations. Development managers, pr
managers, analysts, systems engineers, and even customers should parti
Requirements teams should also include those who create the system so
– engineers, architects, designers, programmers, QA personnel, technica
writers, and other technical contributors.
1-9
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Often, the responsibility for authoring and maintaining a requirement type 
be allocated by functional area, further contributing to better large project
management. The cross-functional nature of requirements management i
of the more challenging aspects of the discipline.

Traceability.  As implied in the description of requirement types, no single
expression of a requirement stands alone. Stakeholder requests are rela
the product features proposed to meet them. Product features are related
individual requirements that specify the features in terms of functional an
non-functional behavior. Test cases are related to the requirements they v
and validate. Requirements may be dependent on other requirements or 
mutually exclusive. 

In order for teams to determine the impact of changes and feel confident 
the system conforms to expectations, these traceability relationships mus
understood, documented, and maintained. While traceability is one of the 
difficult concepts to implement in requirements management, it is essenti
accommodating change. Establishing clear requirement types and 
incorporating cross-functional participation can make traceability easier to
implement and maintain.

QA & Test

Dev. Mgrs & 
Proj. Mgrs

Corp
Mgmt.

RequirementsAnalysts
Tech writers
& docs

Developers
& Designers QA & Test

Dev. Mgrs & 
Proj. Mgrs

Figure 4
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Multi-Dimensional 
Attributes:  Each type of 
requirement has attributes, 
and each individual 
requirement has different 
attribute values. For 
example, requirements may 
be assigned priorities, 
identified by source and 
rationale, delegated to 
specific sub-teams within a 
functional area, given a 
degree-of-difficulty 
designation, or associated 
with a particular iteration of the system. To illustrate, Figure 6 displays 
attributes for a Feature Requirement Type from a Learning Project in 

Figure 5

Requirements Traceability
Establish Traceability Paths

1. Trace top level
requirements into detailed
requirements

2. Trace requirements into
design

3. Trace requirements into
test procedures

4. Trace requirements into
user documentation plan

   Design   

Software Design
Descriptions

Object Models

Test Suites

   Test   

2 3

 Req A 

1

Product 
Requirements

(Features)

Detailed 
Requirements
(Use Cases)

     Req B      

Documentation
Plan

User Docs

4

Figure 6
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Rational’s RequisitePro requirements management tool. As implied by the
of the screen, the requirement type and attributes for each type are define
the entire project, ensuring usage consistency across the team.

In Figure 7, feature 
requirements are 
displayed for a 
specific project in 
RequisitePro. Note 
that even without 
displaying the 
entire text for each 
requirement, we 
can learn a great 
deal about each requirement from its attribute values. In this case, its prio
and difficulty – which may be assigned by different team members – will h
the team begin to scope the project to available resources and time, takin
account both stakeholder priorities and a very rough estimate of effort refle
in the difficulty attribute value. In more detailed types of requirements, the
priority and effort attributes may have more specific values (e.g., estimate
time, lines of code, etc.) with which to further refine scope. This multi-
dimensional aspect of a requirement, compounded by different types of 
requirements - each with its own attributes - is essential to organizing larg
numbers of requirements and to managing the overall scope of the projec

Change History: Requirements, considered individually or in groups, have
histories that become meaningful over time. Change is inevitable and desi
to keep pace with a changing environment and evolving technology. Recor
the versions of project requirements enables team leaders to capture the
reasons for changing the project, such as a new system release. Understa
that a collection of requirements may be associated with a particular versio
software allows you to manage change incrementally, reducing risk and 
improving the probability of meeting milestones. As individual requiremen
evolve, it is important to understand their history: what changed, why, wh
and even by whose authorization.

Putting Requirements Management to Work
Requirements management employs the key skills and concepts present
above to identify and resolve the problems successfully. 

Figure 7
1-12
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To build a system that truly meets customers’ needs, the project team mus
define the problem to be solved by the system. Next, the team must iden
stakeholders from whom business and user needs are elicited, described
prioritized. From this set of high-level expectations or needs, a set of prod
or system features should be agreed upon.

Detailed software requirements should be written in such a form as can b
understood by both the customers and the development team. We have 
that using the language of the customer to describe these software require
is most effective in gaining the understanding and agreement. These det
software requirements are then used as input for the system design 
specifications as well as for test plans and procedures needed for 
implementation and validation. Software requirements should also drive t
initial user documentation planning and design.

Figure 8

Introduction to Requirements Management
Overview
1-13
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To facilitate this, the project 
team should: 

1. Agree on a common 
vocabulary for the project.

2. Develop a vision of the 
system that describes the 
problem to be solved by 
the system, as well as its 
primary features.

3. Elicit stakeholders needs 
in at least five important 
areas: functionality, 
usability, reliability, 
performance, and 
supportability.

4. Determine what 
requirement types to use.

5. Select attributes and 
values for each requirement type.

6. Choose the formats in which requirements are described.

7. Identify team members who will author, contribute to, or simply view o
or more types of requirements.

8. Decide what traceability is needed.

9. Establish a procedure to propose, review, and resolve changes to 
requirements.

10. Develop a mechanism to track requirement history.

11. Create progress and status reports for team members and managem

These essential requirements management activities are independent of 
industry, development methodology, or requirements tools. They are also
flexible, enabling effective requirements management in the most rigorous
the most rapid application development environments.

A Few Words about Documents
The decision to describe requirements in
documents deserves some thought.  On the
one hand, writing is a widely accepted form
of communication and, for most people, a
natural thing to do. On the other hand, the
goal of the project is to produce a system,
not documents. Common sense and
experience teach that the decision is not
whether but how to document requirements.
With effective requirements management
process that establishes what to document,
document templates that show how to write
them, and document-and-database-centric
tools such as Rational’s RequisitePro to
facilitate the management of requirements
contained within, documents are invaluable
vehicles for requirements capture and
communication.
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Overview: RequisitePro Concepts

This chapter covers key RequisitePro concepts. A complete glossary, 
RequisitePro terms, can be found in Appendix A.

Why Use RequisitePro?

Studies have shown that managing requirements is the most significant fa
in delivering projects on time, on budget, and on target. RequisitePro help
projects succeed by giving teams the ability to manage all project requirem
comprehensively, while facilitating team collaboration and communication

Moving beyond conventional requirements management, RequisitePro 
combines both document-centric and database-centric approaches. By d
integrating Microsoft Word with a multi-user database, RequisitePro organ
all your project requirements, providing traceability and change managem
throughout the project life cycle. 

Team Collaboration, User Satisfaction 
Requirements drive the entire project. RequisitePro’s integration with oth
industry-leading tools optimizes the flow of requirements data throughout
project, promoting reuse and consistency, and ensuring that what is desig
tested, documented, and delivered meets the users’ needs.

A product development team typically includes a large number of individu
with diverse roles, such as business analysts, project leaders, product 
marketing managers, development managers, QA managers, developers
testers and more. Giving each person on your team access to critical 
requirements information, and the ability to manage to those requirement
promotes team efficiency and effectiveness.
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Change Happens – Manage it 
Change occurs in practically every development project, but it doesn’t hav
consume project resources or throw the project off course. With Requisite
you can manage inevitable change to ensure your entire team is current 
requirements evolve. Traceability features in RequisitePro let you establi
and maintain dependencies between different requirements. As change o
these traceability relationships are flagged as suspect, so you can unders
how change impacts the entire project. For each requirement a change h
is maintained, capturing the who, what, when, and why of the change.

Comprehensive Process Support 
Whether your team follows a rigorous requirements management process,
as IEEE, SEI CMM or UML-driven use-case approaches, or is just beginn
to define a formal process, RequisitePro can help you meet your objective
delivering precise, quality software. RequisitePro provides industry stand
project templates and attributes, and it can also import existing documents
be customized to support existing projects.

A Quick Tour of Key Concepts in RequisitePro

This section provides an overview of RequisitePro concepts and defines s
terms that will help you get started.

Requirement
RequistePro is a requirements repository that organizes requirements and 
provides traceability and change management throughout the project lifec
To talk about RequisitePro, we first have to decide what a requirement is

Rational defines a requirement as “a condition or capability to which the 
system must conform.” 

Later in this chapter we will discuss requirement types and attributes. 
(For more information on requirements, refer to Chapter 8: Requirements.)

Project
A RequisitePro project includes a requirements database and its related 
documents. A project is usually created by a project manager, who determ
the project structure and sets up security permissions for the project’s us
2-2
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While all project users are encouraged to view and query requirements a
participate in discussions, a limited group of users create and manage 
requirements within a project.

(For more information on projects, refer to the following chapters: Project 
Creation, Project Security, Project Management, and Project Information.)

Project Database
Each RequisitePro project has its own database, where all the requiremen
a project are stored (with the exception of projects that use an Oracle or 
Server database).

In the project database, requirements can be added, modified, or deleted. 
requirements are changed in a document, the changes are updated in th
database.

Often a project includes a variety of requirements documents, such as a pr
requirements document, a system requirements document, software and
hardware specifications, user requirements, quality assurance procedure
test plans. Information from all project documents is stored in the project 
database. The database centralizes information, so that members of the p
team can update requirements, manage priorities and test plans, and rep
project’s progress in one shared repository.

Project Version Control
RequisitePro’s version control lets you trace change by archiving projects
Version control helps you keep a record of changes to project files during
development cycle. You can manage multiple versions of your projects, 
retrieving, modifying, and returning revisions to the archive in an organize
and consistent manner. This is accomplished in RequisitePro with 
RequisitePro’s Archive command, Rational ClearCase, Visual SourceSaf
PVCS Version Manager. (For more information, refer to Archiving Projects on 
page 14-7.)

Project List
A RequisitePro project list is a personal library of accessible RequisitePro
projects. Each user’s list is unique. For example, a program manager 
monitoring the progress of all the projects scheduled for completion this 
quarter could have an extensive list of projects, while some users might h
just one project in their lists at a time.
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Project managers store new projects in their file systems – typically in the
RequisitePro Projects directory. In the Open Projects and Documents dia
box, you can add or delete projects from your project list as you need the

(For more information, refer to Adding a RequisitePro Project to Your Projec
List on page 3-3.)

The Tool Palette, Word Workplace, and Views Workplace
RequisitePro is composed of workplaces where distinct but interrelated w
is done. The workplaces are launched from the Tool Palette as shown in 
figure on the following page. All requirements information is stored in the
database whether it is displayed in the Views Workplace and/or the Word
Workplace.

Tool Palette

When RequisitePro is started, the Tool Palette is displayed. Menus on the
Palette contain RequisitePro commands, and provide access to project 
information, document information, requirements information, discussions
and views.

 The icon buttons below the menu bar are shortcuts to frequently used m
commands. When you position your mouse over a button, a ToolTip appe
describing the button’s function. Use the first button on the Tool Palette to
open RequisitePro projects and documents.

Word Workplace

The Word Workplace is the place within RequisitePro where requirements
created and modified in a document. The Word Workplace contains 
requirement specifications in the form of RequisitePro documents and W
documents.

The Word Workplace looks like a Word document, but the menu bar has b
modified to include a RequisitePro menu that allows you to manage 
requirements and documents. With a few exceptions, RequisitePro uses 
same commands in the Word Workplace that are available in Microsoft W
The File > Save As, File > Exit, Tools > Protect Document, and Tools > 
Templates and Addins commands are disabled in the Word Workplace in o
to prevent conflicts in handling RequisitePro documents.

Use the Window > Close Word command on the Tool Palette to close the 
Word Workplace.
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Views Workplace

The Views Workplace is a window to the database. Requirements, their 
attributes, and their relationships to each other are displayed and manag
views.

All Views Workplace commands are located in the menu bar at the top of
Views Workplace. As in the Tool Palette, icon buttons are available to ac
one command at a time.

Views
In RequisitePro, a view is accessed in the Views Workplace. Views prese
information about a project, a document, or requirements graphically in a t
(matrix) or in an outline tree. Views display the attributes assigned to 
requirements, such as Status and Priority, or the relationships between 
different types of requirements. (For more information, refer to Chapter 4
Views.) 

Three kinds of views can be created in the Views Workplace:

• The Attribute Matrix View  displays all requirements of a specified type
The requirements are listed in the rows, and their attributes appear in
columns.

• The Traceability Matrix View  displays the relationships (traceability) 
between two types of requirements.

• The Traceability Tree displays the chain of traceability to or from 
requirements of a specified type.
2-6
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Top to bottom: Attribute Matrix, Traceability Matrix, Traceability Tree. Three views of the sa
requirements.

Documents
 A requirements document is a specification that captures requirements, 
describes the objectives and goals of the project, and communicates pro
development efforts. Each requirements document belongs to a particula
document type, explained below.

RequisitePro manages requirements directly in the project documents. W
you build a requirements document, RequisitePro dynamically links it to a
database, enabling you to manage requirements by updating and saving
documents. When saved, revisions are available to team members and o
involved with the project.

With RequisitePro’s version tracking, you can easily review the change his
for a requirement, a document, or the whole project.

Documents are created in either Word or RequisitePro format. RequisiteP
format makes proprietary modifications to the standard Word application 
allows RequisitePro to exercise security controls over the document. As s
certain Word features are disabled, and that functionality is available inst
2-7
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through commands on the RequisitePro menu in the Word Workplace an
RequisitePro Tool Palette. For example, Word’s File > Open command is 
executed in RequisitePro as Document > Open on the Tool Palette or 
RequisitePro > Document > Open in the Word Workplace.

Not all documents are requirements documents. Documents do not have
contain requirements to be included in a project. Any Word document, no
matter where it resides in the file system, can be associated with a projec
will be available in the document list when a project is opened. (For more
information, refer to Chapter 7: Documents.)

Document Types and Requirement Types
Document types and requirement types are two similar requirements 
management concepts and tools. Both serve as templates and define the
appearance of two essential requirements management components, a 
document and a requirement. But where they differ is in their application.

Document Type

A document type identifies the type of document, such as a use-case or a
software requirements specification, and helps ensure consistency acros
documents of the same type. A document type is a template that is applie
your documents. The template can include the default font for your docum
the available heading and paragraph styles, and the default type of 
requirements for the document. Or it could encompass both formatting 
conventions and an outline that helps you organize your requirements 
information. (For more information, refer to Creating and Modifying 
Document Types on page 15-2.)

All documents of the same document type share the same file extension 
example, .prd). You determine document types when you create or modif
your project. Then, when you create a document, you can associate it wi
document type already defined in your project. The new document inherits
style and functional attributes associated with the document type, making
consistent with other documents of the same type.

RequisitePro provides standard document templates that can be used “as
customized according to your specifications. Once you have defined the 
appearance of the document and the information to include, you can use
document as a standard for your organization.
2-8



A Quick Tour of Key Concepts in RequisitePro

 
n is 

nd 

. 

s are 
hen 

play 

tes. 
nt. 
te, 

h the 

ority 
), 
 

There are several benefits to using standards: 

• The template can be used as an example of the type of information to
include and can serve as a comprehensive “to do” list so no informatio
overlooked.

• Expectations and procedures are clearly presented so new authors a
team members spend less time learning to build the necessary 
requirements documents.

• Authors familiar with the template can create new documents quickly

• Readers familiar with the template can quickly locate and review 
information.

Requirement Type

A requirement type is a template for your requirements. Requirement type
used to classify similar requirements so they can be efficiently managed. W
you define a requirement type, you define a common set of attributes, dis
style, and tag numbering. 

You can create your own requirement types appropriate for your project.
(For more information, refer to Creating and Modifying Requirement Types on 
page 15-4.)

Requirement Attributes
Requirements in RequisitePro are classified by their type and their attribu
In RequisitePro, an attribute provides information to manage a requireme
Attributes can provide crucial information to help a team plan, communica
and monitor project activities from the analysis and design phases throug
test and release phases. 

Attribute information may include:

• The relative benefit of the requirement

• The cost of implementing the requirement

• The priority of the requirement

• The difficulty or risk associated with the requirement

• The relationship of the requirement to another requirement

RequisitePro provides several default requirement attributes, such as Pri
(high, medium, low), Status (proposed, approved, incorporated, validated
Cost and Difficulty. These attributes are suggestions. You can create and
2-9
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control attributes according to your needs. Whichever attributes you use,
RequisitePro offers the flexibility to easily customize your project docume
and databases to define, articulate, and manage the processes and cultu
your organization.

You can use attributes to determine which requirements to implement in 
next release. For example, you may decide that in the first release, you w
only implement requirements evaluated as high risk, with high difficulty. I
you have assigned risk and difficulty attribute values to each requirement,
can then easily query all requirements of high risk and high difficulty.

(For more information, refer to Creating and Modifying Requirement 
Attributes on page 15-7.)

Hierarchical Relationships
Hierarchical requirement relationships are one-to-one or one-to-many, pa
child relationships between requirements of the same type. Use hierarch
relationships to subdivide a general requirement into more explicit 
requirements. 

Example: 

Parent requirement:
The system shall display customer information.

Child requirements provided for detail:
Name
Address
Date of Birth

When working with hierarchical relationships, keep the following in mind:

• Each child requirement can only have one parent, but a requirement ca
both a parent and a child.

• The parent and child requirements must be located in the same place, 
in the same document or in the database only.

• You create hierarchical relationships in the Word Workplace or the Vie
Workplace, using the Hierarchy tab in the Requirement dialog box. (In
Views Workplace, you can also use Requirement menu commands to
create hierarchical relationships.)

• When you delete a parent, you can choose to delete its children or as
them to another parent.
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• You cannot create a traceability relationship between a parent and its
child.

• Hierarchical relationships are a type of change-managed relationship
RequisitePro. If a requirement is changed, the relationships with its 
children become suspect. You can view and manage suspect relationshi
using a Traceability Matrix or a Traceability Tree in the Views Workpla

(For more information, refer to Chapter 9: Hierarchical Relationships.)

Traceability Relationships
Traceability links requirements to related requirements of same or differe
types. RequisitePro’s Traceability feature makes it easy to track changes
requirement throughout the development cycle. Without traceability, each
change would require a review of your documents to determine which, if a
elements need updating.

When working with traceability relationships, keep the following in mind:

• You can create a traceability relationship between requirements of th
same or different types.

• You can create traceability relationships between requirements that e
in the same document, in different documents, or in the project datab

• You can create, view, and manipulate traceability relationships in the
Word Workplace or in the Views Workplace.

• Traceability relationships are a type of change-managed relationship 
RequisitePro. If either end-point of the connection is changed, the 
relationship becomes suspect. If you modify the text or selected attributes
of a requirement that is traced to or traced from another requirement, 
RequisitePro marks the relationship between the two requirements 
“suspect.”

• Traceability relationships cannot have circular references. For instanc
traceability relationship cannot exist between a requirement and itself,
can a relationship indirectly lead back to a previously traced from node. 
RequisitePro runs a check for circular references each time you estab
traceability relationship. 

Note: You cannot create a traceability relationship between a parent an
own child, but you can create a traceability relationship between a
parent requirement and a different parent requirement’s child.

(For more information, refer to Chapter 10: Traceability Relationships.)
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Traced to/Traced from Overview

There can be only one traceability relationship between any two requirem
The difference between calling the relationship trace to and calling it trace 
from is perspective.

For example, you might create a software requirement (Requirement A) t
calls for a new command to be added to a particular menu in your applica
In addition, in another requirements document, you might create a test 
requirement (Requirement B) associated with that menu item. You would 
create a traceability relationship in which the test requirement (B) is trace
from the software requirement (A)

In this example, both of these statements are true:

• A is traced to B

• B is traced from A

Direct and Indirect Traceability Relationships

There are two types of traceability relationships: direct and indirect.

In a direct traceability relationship, a requirement is physically traced to o
from another requirement. For example, if Requirement A is traced to 
Requirement B, and Requirement B is traced to Requirement C, then the
relationships between A and B and between B and C are direct relationsh
The relationship between A and C is indirect (inferred). Indirect relationsh
are maintained by RequisitePro; you cannot modify them directly.

Suspect Relationships
A hierarchical relationship or a traceability relationship between requireme
becomes suspect if RequisitePro detects that a requirement has been mo
If a requirement’s text is modified, all its immediate children and all direct 
relationships traced to and from it are suspect. 

When you make a change to a requirement, the suspect state is displaye
Traceability Matrix or a Traceability Tree. Changes include modifications 
the requirement text, requirement type, or attributes.

For more information about parent-child relationships or traceability 
relationships that are marked suspect, refer to Suspect Relationships on page 
9-9 and Suspect Relationships on page 10-9.
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Getting Started

This chapter explains the basics of opening the RequisitePro application 
accessing RequisitePro projects.

Launching RequisitePro

You can start RequisitePro in one of two ways:

• On the Start menu, click Programs. Click the installed Rational Windows
Suite and/or RequisitePro version, and then click RequisitePro.

• In Windows Explorer, double-click any file name with the .rqs extension.

Using the RequisitePro Tool Palette

The Tool Palette is the central interface for accessing and working with 
RequisitePro projects. When RequisitePro is launched, the Tool Palette 
appears: 

• Menus on the Tool Palette contain RequisitePro commands and pro
access to project information, requirements information, and views.

•  The icon buttons below the menu bar are shortcuts to frequently us
menu commands. When you position your mouse over a button, a 
ToolTip appears, describing the button’s function.
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Exiting RequisitePro

When you exit RequisitePro, the application closes the current project, 
prompting you first to save any changes you made to the project’s 
requirements documents.

1. On the Tool Palette, click Project > Exit .

If you did not modify any requirements document, a dialog box appea
asking you to confirm that you want to exit. Click Yes. 

If you modified one or more requirements documents, and have not y
saved those changes, the Document Changed dialog box appears.

2. Do one of the following:

• To save the changes you made without reviewing the changes, clickYes.
If you made changes to a requirement’s text, the Change Description 
dialog box appears and asks you to enter the reason for the change
before saving.

• To close the document and exit RequisitePro without saving the 
changes, click No.

• To cancel the exit process, click Cancel.

• To review changes to the document, click Review Changes.
If you made changes to a requirement’s text, the Change Description 
dialog box appears and asks you to enter the reason for the change

The Document Changes dialog box appears, listing each modification
to the document.
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3. Do one of the following:

• To save the changes you made, click Yes. RequisitePro saves the 
changes in the document and in the database.

• To close the document and exit RequisitePro without saving the 
changes, click No.

• To cancel the exit process, click Cancel.

Working with Projects

Adding a RequisitePro Project to Your Project List
A RequisitePro project list is a library of accessible RequisitePro projects
Each user’s project list is unique. All projects are stored in the file system
Using the Open Project and Documents dialog box, you select projects fr
the file system for your own project list. You can add or remove projects fr
your list as you need them. 

Before you can access a project, you must add it to the project list on your
machine:

1. On the Tool Palette, click Project > Open.
The Open Projects and Documents dialog box appears. 

Note the list of projects in the Select a Project field.
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2. Click Add. The Add Project dialog box appears:

3. Find the project to add to the list (it has a .rqs extension). 

4. Highlight the project and click Open. 

5. Click OK . RequisitePro adds the project to the Select a Project field. Y
can now open the project and use its associated requirements and 
documents.

Removing a Project from the Project List
Removing a project from the project list does not delete the project files, 
removes the project from the listing. It remains in the file system and can
added to your project list again.

To remove a project from the project list:

1. On the Tool Palette, click Project > Open.
The Open Project and Documents dialog box appears.

2. Highlight the project name in the Select a Project list and click Remove. 
RequisitePro removes the project.

Note: You can retrieve a project you removed by clicking the Add 
button. (Refer to Adding a RequisitePro Project to Your Project 
List on the previous page.)

3. Click OK .

Opening a Project and Documents
When you open a project, you can open a document at the same time. O
can choose to open just the project without selecting a document. Requisi
displays all documents associated with the project, regardless of where the
stored on the file system.
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To open a project and a document:

1. On the Tool Palette, click Project > Open (or click the Project button). 
The Open Project and Documents dialog box appears:

2. Highlight the project to open in the Select a Project list box.

3. When documents are created, they are assigned a document type. 
The Select Documents list displays documents by type. To see a diffe
selection of documents, choose another document type from the Display 
Types drop-down menu.

4. Highlight the document to open in the Select Documents list box.
This list includes all documents you have either created in the project
imported into the project, regardless of whether the documents conta
requirements. You can use a multiple select action (Ctrl-click, Shift-cli
or drag) to open more than one document.

5. Select the user access options. If you want to be the only user who h
access to the project and documents, mark the Exclusive check box. To 
open all selected documents in read-only mode, mark the Read Only 
check box.

6. Click OK .

Depending on the security set on the project, one of two dialog boxes app

• If security is set on the project, refer to Accessing a Secure Project on page 
3-7.
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• If no security is set on the project, but your user name has not been 
identified in the project, the Project Logon dialog box appears.

1. Do one of the following:

• Accept the displayed name; or

• Click the down arrow and select a user name from the list; or

• Type a new user name that will be added to the project.

2. Click OK .

The project opens, and the new name is added to the project.

Closing a Project and Documents
The Close command closes a project and its documents and any open vie

1. On the Tool Palette, click Project > Close.

If you made no changes, the Project Close dialog box appears and 
prompts you to close the project and its documents or keep it open. C
Yes to close the project and its documents.

If you modified but did not save a document, the Document Changed 
dialog box appears.

2. Do one of the following:

• To save the changes to the document, click Yes. If you made changes to
a requirement’s text, the Change Description dialog box appears and 
asks you to enter the reason for the changes before saving.

• To close the project without saving the document changes, click No. 

• To cancel the close project procedure, click Cancel.

• To review document changes, click Review Changes. If you made 
changes to a requirement’s text, the Change Description dialog box 
appears and asks you to enter the reason for the changes.
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The Document Changes dialog box appears, listing each modification
to the document.

3. Do one of the following:

• To save the changes to the document, click Yes. 

• To close the project without saving the document changes, click No. 

• To cancel the close project procedure, click Cancel.

Accessing a Secure Project
Project managers can enable security for a project, requiring users to log o
provide a password. The project manager sets up security and assigns a
name and password to each member of the team.

Logging on to RequisitePro

To log on and to access a secured RequisitePro project: 

1. On the Tool Palette, click Project > Open (or click the Project button). 
The Open Project and Documents dialog box appears.

2. Highlight a project in the list to open and click OK . If RequisitePro detects 
that security is enabled, the Project Logon dialog box appears:

3. Type your name in the Username text box and your password in the 
Password text box. Click OK . You are now ready to use the project. 
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Modifying Your Password, User Name, or E-mail Address

Once you are in a project you can modify your password, user name, or e
address. If you are a RequisitePro administrator or a member of a group 
project security permissions, you also have the ability to change the passw
user name or e-mail address for other users. See Editing User Information on 
page 13-5.

A valid e-mail address is necessary for receiving RequisitePro discussion
messages via e-mail. For more information, see Configuring E-mail for 
Discussions on page 6-2.

1. Open a project and log on. The RequisitePro Tool Palette appears.

2. Click Project > Security.
The Edit User dialog box appears.

3. If you are a RequisitePro administrator or a member of a group with pro
security, the Project Security dialog box appears instead. Click the 
“Enable security for this project” check box. Select a user group and a 
name, and click the Edit  button. 
Then the Edit User dialog box appears:

To change your password:

1. Type your password in the Old Password text box that appears in the 
dialog box (This step applies only to users who don’t have project secu
permissions).

2. Type your new password in the New Password text box.
Passwords are case sensitive and limited to 14 alphanumeric charac

3. Confirm the new password by typing it again in the Verify  text box. 

4. Click OK . Your new password is in place and ready for use.
3-8
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To change your user name (for users with project security permissions):

1. Highlight your current name in the Username field.

2. Type a new user name. User names are limited to 20 alphanumeric 
characters and are not case sensitive.

3. Click OK . Your new name is in place and ready for use.

To change your e-mail address:

1. Highlight your current e-mail address in the E-mail field.

2. Type a new e-mail address.

3. Click OK . Your e-mail address is in place and ready for use.
3-9
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Views

RequisitePro views use tables and outline trees to display requirements a
their attributes or the traceability relationships between different requirem
types. RequisitePro includes powerful query functions for filtering and sort
the requirements and their attributes in views.

The Views Workplace is an environment for analyzing and printing 
requirements, whether they are document-based or database-only 
requirements. You can have multiple views open at one time. The Views 
Workplace provides scroll bars to view all requirements and attributes in 
table or tree. The number of requirements in the current view appears in 
lower right corner of the views window.

You can create three kinds of views in the Views Workplace:

• The Attribute Matrix view displays all requirements and their attribut
within a specified type.

• The Traceability Matrix view displays the relationships between 
requirements of two types.

• The Traceability Tree view displays the chain of traceability through 
project requirements.
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Accessing Functions and Navigating in Views

• All Views Workplace commands are located in the menu bar at the to
the Views Workplace. Unless stated otherwise, this manual refers to 
commands in the Views Workplace when working with views.

• To navigate in a view quickly, use the ARROW keys, the PAGE UP or PAGE 
DOWN keys, and the HOME and END keys. For more information, refer to 
Mouse Actions and Shortcuts in the Views Workplace in Appendix A.

• Use the right button on the mouse as a shortcut to commands that ar
specific to requirements and attributes. Move the mouse over the 
requirements and attribute labels and click the right button to access t
shortcut menus. For more information, refer to Mouse Actions and 
Shortcuts in the Views Workplace in Appendix A.

• The full text of the selected requirement is displayed in the text pane a
bottom of the view. To resize a text pane, position the mouse on the u
border and drag upward.

Viewing Current Data

While a view is open, other users may add, delete, or modify requirements
are displayed in your view. These changes are not automatically reflected
your open view.

To update the data displayed in the view for requirements that were mod
by other users, click View > Refresh All (or the Refresh button) in the Views 
Workplace. The Refresh All command affects all open views and 
automatically updates the data in each view.

The View > Query Now command in the Views Workplace reruns a view’s
query criteria against the database and updates your requirement set. (Fo
information on queries, refer to Query and Search on page 5-1.) Requirements
that have been deleted or no longer match the query are removed from th
view. New requirements that match the query are added to the view. Query 
Now does not refresh the data for requirements that are already in your v

Note: If there are many requirements in the database, Refresh All can take 
some time to complete. If you just need to see a fresh requiremen
without updating the text and attributes for each requirement, use
Query Now.
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Traceability in the Views Workplace

The Traceability Matrix and Traceability Tree views display traceability 
relationships. Traceability relationships are displayed as suspect when yo
make a change to a requirement. For more information about traceability
relationships between requirements, refer to Traceability Relationships on 
page 10-1. 

• Arrows are used to indicate direct traceability relationships in the 
Traceability Matrix and Traceability Tree views. If the arrow points fro
A to B, then the following two statements are true: A is traced to B and B 
is traced from A.

• A requirements relationship is indirect if the relationship is derived by
traversing the requirements relationships. An arrow outlined by a dott
line, lighter in color than a direct relationship arrow, indicates an indir
traceability relationship in the Traceability Tree and the Traceability 
Matrix.

Hierarchy in the Views Workplace

All views display hierarchical relationships, and you can use the Traceab
Matrix and Traceability Tree to display hierarchical relationships that are 
marked suspect. For more information about hierarchical relationships 
between requirements, refer to Hierarchical Relationships on page 9-1.

• You can create hierarchical relationships in the Views Workplace by us
Requirement menu commands or editing the requirement properties in
Hierarchy tab of the Requirement dialog box.

• When you modify a parent requirement, RequisitePro marks the 
relationships between the parent and all its immediate children as sus

• When you modify a child requirement, the relationship with its parent 
not marked as suspect.

• When a child requirement is assigned to a new parent, all hierarchica
relationships between the new parent and its immediate children are 
automatically marked suspect. The relationships between the children
their children are not marked as suspect.

• In the Traceability Tree, you can manually mark a hierarchical relations
as suspect or clear a suspect relationship.
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The Attribute Matrix

This view displays requirements and their attributes for a specific requirem
type. Requirements are arranged in rows and listed by tag number. Attrib
are arranged in columns. The Attribute Matrix displays both document-based
and database-based requirements, but only database requirements can b
created in this view.

Requirements
In this view, requirement tags and text are displayed on rows in the matri
When requirement text exceeds the capacity of the row, RequisitePro ma
the last word with ellipses (...), which indicate there is more text that is no
displayed. The row height and width can be changed.

Attributes
Attribute labels are listed at the top of each column. Corresponding attrib
values are listed beneath the attribute labels. Query information is display
here as well. Columns can be resized.

Text Pane
The text pane displays the description of a requirement in its entirety. This 
is located at the bottom of the matrix and is blank when a requirement is 
selected. “Multiple requirements selected” appears in the text pane if you h

attribute
labels

attribute
values

requirement
tag 

text
pane

and text
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selected more than one requirement. Graphics or OLE objects in requirem
are displayed as small rectangular symbols. The default size of the text pa
two lines, but its height can be increased to as many lines as you need.

The Traceability Matrix

This view displays and manipulates the relationships between two requirem
types. The requirements can be of the same type or different types. Use 
view to create, modify, and delete traceability relationships and to view 
indirect relationships. The Traceability Matrix also shows traceability 
relationships that are marked suspect. If you display a Traceability Matrix
requirements of the same type, it shows hierarchical relationships that ar
marked as suspect.

In this view, a requirement is traced to or traced from another requirement. For
example, requirement B is traced from requirement A if it was directly or 
indirectly derived from requirement A. If requirement A is the basis of seve
other requirements, Requirement A is traced to these requirements.

An arrow pointing from one requirement to another indicates that a direct
traceability relationship exists between the requirements. A dotted line ar
indicates an indirect relationship.

Rows and columns can be resized. The intersection between a row and co
is called a cell.

Cells
•  If the intersection is blank, no relationship exists.

•  If an arrow points upward to a column requirement, the 
requirement is traced to that requirement

•  If an arrow points down toward a row requirement, the 
requirement is traced from that requirement

•  If a dotted line arrow is displayed, an indirect 
relationship exists.

•  If an arrow with a red diagonal line through it is 
displayed, the traceability relationship is suspect.

•  If a triangle with a red diagonal line through it is 
displayed, the hierarchical relationship is suspect.

Traced to arrow

Traced from arrow

Indirect relationship

Suspect relationship

Suspect relationship
4-5



Views

ew 
te 

and 
tly 

ently 
 the 
Text Panes
The Traceability Matrix displays two text panes. These panes let you revi
the requirements in each area, so you can easily create, modify, and dele
traceability relationships. The default size of each pane is set to one line 
can be resized. The top text pane displays the complete text of the curren
selected row requirement and the bottom pane displays the text of the curr
selected column requirement. “Multiple requirements selected” appears in
text pane if you have selected more than one requirement.

selected

rows

cell

row
requirement

selected
column
requirement

columns
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The Traceability Tree

The Traceability Tree provides a graphical view of relationships to or from
requirements of one specific requirement type, including direct, indirect a
suspect traceability relationships. Although direct and suspect relationship
modified in this view, RequisitePro permits read-only access to indirect 
relationships.

In addition, the Traceability Tree displays hierarchical relationships and sh
parent-child relationships that have been marked as suspect.

Requirement text appears at the bottom of the view and associated attribu
the right of the view of the currently selected requirement. 

When creating a Traceability Tree, you can choose one that displays all 
requirements traced to the requirements the tree is based on, or one that sh
all requirements traced from the requirements the tree is based on. 

Tree Pane
Select a specific requirement type on which to base the view. Traceability
relationships for root-level requirements are indented and preceded by an
arrow. Child requirements are indented below their parents and preceded
triangle. The pane on the right side of the view displays requirement attrib

attribute
pane

text
pane

tree
pane

branch-level
requirement
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Note: To resize the tree pane, click the border between the tree and attr
panes. Press the left button on the mouse and drag it left or right to
desired size. This does not affect the length of the lines set in the
Row/Column Sizing dialog box.

If the arrow points toward a branch-level requirement, the root is traced 
to this requirement.

If the arrow points away from the branch-level requirement, the 
requirements on the branches are traced from the requirement. 

If an arrow with a red diagonal line is displayed, the traceability 
relationship is suspect. 

If a triangle with a red diagonal line is displayed, the hierarchical 
relationship is suspect.

Attribute Pane
This pane displays the attributes associated with the currently selected 
requirement. To display the attributes of a particular requirement, click th
requirement in the tree pane. This is a read-only text box and cannot be e

If you have more than one requirement selected, the pane displays the 
attributes for the first requirement selected.

Text Pane
The text pane is located in the lower section of the Traceability Tree. To 
display the full text of a particular requirement, click the requirement in the 
pane. To adjust the height of the pane, click its upper border and drag the
to the desired size.

“Multiple requirements selected” appears in the text pane if you have sele
more than one requirement.
4-8
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Working with Views

This section presents the fundamentals of working in the Views Workplac
including the following:

• Creating a view

• Expanding and collapsing in the Views Workplace

• Saving a view

• Opening a saved view

• Closing a view

• Renaming a view

• Duplicating a view

• Printing a view

• Deleting a view

Creating a View
1. On the Tool Palette, click Window >Show Views (or the Show the views 

workplace button). The Views Workplace opens.

2. In the Views Workplace, click File > New View (or the New View button). 
The New View dialog box appears:

3. Select a view type to display.

4. Select a requirement type to display in the view. The Traceability Mat
requires both row and column requirement types.
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5. Click OK . The view is displayed.

Note: The Traceability Matrix displays more than one requirement type.
The Attribute Matrix displays a single requirement type, and the 
Traceability Tree displays a single requirement type at the root lev
Only requirements associated with the selected requirement type
appear in the view.

Expanding and Collapsing in the Views Workplace
The Expand All and Collapse All commands on the View menu are used to 
expand and collapse hierarchical relationships in all views and traceabilit
relationships in the Traceability Tree. An expanded view shows the root 
requirement and all its sub-level requirements. Collapse the view to show
the root level requirements.

The Expand All command expands all relationships in a view. When you 
select this command in a Traceability Tree, a requirement that has a tracea
relationship with a root requirement appears as a branch of the root 
requirement. This command also expands all parent requirements, displa
all children, in all views.

The Collapse All command collapses all relationships in a view. When you
select this command in a Traceability Tree, a requirement that has a tracea
relationship with a root requirement is no longer displayed. This command 
collapses all parent requirements, hiding all children, in all views.

To expand the Traceability Tree or hierarchical relationships:

• Click the View menu and choose Expand All . 

To collapse the Traceability Tree or hierarchical relationships:

• Click the View menu and choose Collapse All.

Saving a View
When you save a view, the layout of the view and the query criteria are a
saved. The data within the view is not saved as part of the view, but is pa
the database instead. Thus, when you open a saved view, current inform
is displayed in a saved view format.

Note: The saved view is not a snapshot of requirement information for a 
particular date. The way to save the results of a query is to print th
view. For more information on queries, refer to Query and Search on 
page 5-1.
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A view must be active in the Views Workplace to be saved. To make an o
view active and display the view in the active color, click the title bar of th
view or select it from the Windows menu.

To save a view:

1. In the Views Workplace, click File > Save View As. (or the Save button). 
The Save View As dialog box appears:

2. Click the Name text box and type a name of up to 64 characters.

3. Make the view available to all users (Project-wide availability) or for your 
own use (Personal) by marking the corresponding button.

Note: Only the author or a member of the Administrators group can
modify project-wide views.

4. RequisitePro populates the following fields, which cannot be edited:

• The Author  text box displays the name of the RequisitePro user wh
saved the view.

• The Date text box displays the date the view was saved.

• The Time text box displays the time the view was saved.

5. Click OK  to save the view.

RequisitePro organizes views by view type in the Previously Saved Views list 
box in the Open View dialog box. When a view is saved, it is added to this l
4-11
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Opening a Saved View
To display a saved project-wide or personal view:

1. In the Views Workplace, click File > Open View (or the Open a 
previously saved view button).
The Open View dialog box appears:

2. Choose a project-wide or personal view by marking the correspondin
button. A list of saved views appears.

3. Highlight the desired view from the list. The author, date of creation, a
time of creation appears below the list. 

Note: You can select more than one view to open by using Ctrl-click
Shift-click.

4. Click OK . RequisitePro displays the selected view(s).

Closing a View
1. In the Views Workplace, click File > Close View. 

Note: If the Prompt for save option is activated (the check box is marked
in the Tools > Options dialog box), and you have changed any of 
view’s properties, a dialog box appears asking if you want to save
view. Click Yes or No.

2. RequisitePro closes the view.
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Renaming a View
Renaming can be used to change the name of an open view window. You m
want to give a view a longer, descriptive name before you print the view, 
that the new name appears on the printed page. You can still retain the or
name in the file system. Renaming a view does not save the renamed vie
the database until the view is saved again.

1. In the Views Workplace, click View > Rename.
The Rename View dialog box appears.

2. Type a new name for the view in the Name text box and click OK .

Note: Use the Save option on the File menu to save the renamed view.

Duplicating a View
Duplicating a view opens another window with the same view properties as
active window. This is especially useful for creating copies of the view wi
different sorting and filter options.

To duplicate a view:

• Click View > Duplicate. 

• RequisitePro renames the view with the suffix 2; for example, “Product 
Requirement Description View2.”
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Printing a View
In the Views Workplace, you can print any active view. When you print a vie
you can choose to print the entire matrix or selected items.

To print an open view:

1. If you want to print only a selected requirement or relationship, click t
requirement(s) or relationship(s) in the matrix. (Use a multiple select 
action to select multiple requirements or relationships.)

2. Click File > Print .
The Print  dialog box appears.

3. If you are printing selected requirements or relationships, click Selection.

4. Make any other necessary changes to the Print dialog box, and then 
OK .

Note: Use the Print  button on the Views Workplace toolbar to print directl
to the default printer. In this case, the entire view is printed using 
default printer selections.

Tip: You can also export a view to a CSV and use another application, s
as Excel, to open the data and arrange it for printing. See Exporting a 
View as a CSV File on page 11-23 for more information.
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Deleting a View
A personal view can only be deleted by the person who created it. A proj
wide view can be deleted by the person who created it or by a member o
Administrators Group.

To delete a view:

1. Click File > Delete View.
The Delete View dialog box appears. 

2. Choose a project-wide or personal view to delete by clicking the 
corresponding button. A list of saved views appears.

3. Highlight the desired view from the list. The author, date of creation, a
time of creation appear below the list.

Note: You can select more than one view to delete by using Ctrl-click or
Shift-click.

4. Click OK . RequisitePro deletes the selected view(s).
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Customizing Views

Customizing a view defines its look and content. You can: 

• adjust the size of rows and columns; 

• filter and sort data according to query criteria;

• select specific view properties to display. 

Once a view is defined, it can be saved for future use. Saving a view save
view properties that were customized. When a saved view is opened, it 
displays in the state in which it was saved. 

Adjusting Row Height
Adjusting row height affects all rows in the view.

1. Click View > Row/Column Sizing.
The Row/Column Sizing dialog box appears.:

2. Type the number of lines to display for each requirement. The maxim
number of lines depends on a monitor’s display resolution. 

3. Click OK . The view is modified according to your specifications.

Shortcut: Click and hold the mouse on any border in the requirement a
then drag the row up or down according to the desired height. If the r
height is already set at one line, RequisitePro will not let you drag the 
up to less than one line. The Traceability Tree does not have a shortc
4-16
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Adjusting Column Width
1. Click View > Row/Column Sizing.

The Row/Column Sizing dialog box appears, as shown above.

2. Type the number of pixels (in the Attribute Matrix) or lines (in the 
Traceability Matrix) to display for each requirement or attribute. 
Parameters for column widths in different views follow.

• Attribute Matrix: To set a different width for each column, drag the 
column to the desired width. To set an equal width for all columns, 
the View menu, Row/Column Sizing dialog. The maximum screen 
height varies based on your screen’s resolution.

• Traceability Matrix: RequisitePro determines the maximum width bas
on your screen’s resolution.

• Traceability Tree: The column width is represented by the amount of
indentation or each branch. RequisitePro dynamically changes the 
maximum number of pixels allowed in these columns according to t
width of the requirement pane and the size of the view. Any change
the column width affects all of the columns in this view.

3. Click OK to commit these changes. 

Shortcut: Click and hold the mouse on any border in the attribute labe
area or the requirement area (the gray area at the top of each column)
Attribute or Traceability Matrix. Drag the width left or right to the desire
size. The Traceability Tree does not have a shortcut.
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Resizing and Arranging Views

Use the menu commands or the buttons on the toolbar in the Views Workp
to define the size and arrange the order of a view.

Creating Cascaded Views
This feature overlaps views. Each view is displayed to the right and sligh
below the preceding view. If many views are open, RequisitePro may ove
the first cascade of views with a second cascade until all open views are 
arranged. 

Click Window > Cascade. RequisitePro cascades the views.
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Creating Tiled Views
This view arranges open views next to each other without overlap. 

Click Window > Tile. RequisitePro tiles the views.

Arranging Icons
This feature arranges the icons for all minimized views from left to right, 
beginning at the bottom left corner of the Views Workplace. 

Click Window > Arrange Icons. RequisitePro arranges the minimized view
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Displaying View Properties

Use the Properties command to display properties associated with an activ
view. Each view displays distinct properties. These properties affect how
view appears and not the information contained therein.

1. Click View > Properties. Click the following properties to display them
in the view. If they are marked on the menu with a check mark, they ap
in the active view.

• Attribute Matrix:

1. Show Buttons displays a button to the left of requirements and any
hierarchical relationships. The button is used to expand or collapse
requirement.

2. Show Discussions displays a red triangle to the right of the 
requirement text, indicating there are one or more discussions 
associated with a requirement.

3. Show Text displays the first line of the requirement text.

• Traceability Tree:

1. Show Buttons displays a button to the left of requirements and any
traceability and hierarchical relationships. The button is used to 
expand or collapse the requirement.

2. Show Discussions displays an icon indicating there are one or mor
discussions associated with a requirement.

3. Show Lines displays lines in the Traceability Tree that connect 
relationships.

4. Show Images displays traceability relationships with arrows.

5. Show Root Images displays an arrow at the root of hierarchical 
requirements.

6. Show Text displays the first line of the requirement text.

7. Show Trace To and Trace From display arrows in the direction of 
either trace to or trace from relationships, depending on your 
selection.
4-20
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• Traceability Matrix:

1. Show Buttons displays a small box or button to the left of 
requirements with children.

2. Show Discussions displays an icon indicating there are one or mor
discussions associated with a requirement.

3. Show Text displays the first line of the requirement text.

4. Show Trace To and Trace From display arrows in the direction of 
either trace to or trace from relationships, depending on your 
selection.

Saving View Properties as Default
The Save As Default command saves a view layout and any properties 
displayed as the default when opening views of that type. This command
available for all view types. To save a view and its displayed properties as
default for views of that type:

• Click View > Properties > Save As Default.

• RequisitePro saves the view, layout, and properties for views of tha
type.

Note: Use the Reset Default command to reset any view properties tha
have been changed back to the saved default settings.
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Query and Search

Creating and Using Queried Views

Once you have created a view, you can save it as is, or you can refine the
by querying (filtering and sorting) its information in a variety of ways.

You can filter requirements in views by limiting the values of one or more
attributes or by limiting traceability. You can query requirements displayed
rows in an Attribute Matrix or Traceability Matrix, columns in a Traceabilit
Matrix, or root requirements in a Traceability Tree.

Querying (Filtering and Sorting) Overview
Filtering restricts the information being displayed. Sorting determines the
order in which information is displayed. For example, in an Attribute Matr
you may want to view only those requirements assigned to you (filter crite
and order requirements information from highest to lowest priority (sort 
criteria).

You filter and sort requirements by applying query criteria to the attributes
These criteria limit the values of the attributes and/or limit the traceability 
relationships. You can create a singular attribute query, so that you can se
results of each query criteria. Or you can create a multiple attribute query
filters and sorts all at once.

Note: RequisitePro does not automatically update views after you have
queried. If other users have been changing data while a view is op
you can use Query Now or Refresh All to reflect those changes in 
your open view. Refer to Viewing Current Data on page 4-2 for more 
information.
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Filtering

Filtering data is a process by which you can limit the amount of informatio
displayed in a view in the Views Workplace. You specify the criteria for 
filtering the information. You can filter requirements by specifying distinct
criteria for any or all of their attributes. For example, instead of displaying
requirements, you might apply a filter such that only requirements having
high priority are displayed.

Sorting

By default, the sort order in a view is ascending by requirement tag. When
create a query that includes multiple query criteria, you can sort the criter
determine the order in which the requirements are displayed in a view. You
also modify the sort order after you have created a query. For example, y
might sort requirements by priority, high to low. Then, within priority, you 
might sort by date.

Working with Queries

Use the Query command to extract data from the database and present it 
use in any of the three views. You can save, open, edit, print, and export
queried views. 

Queried views range from simple to complex. When querying most attribu
in a view, you choose one requirement type at a time. If you base a query
the Trace to or Trace from attributes, you have the ability to select more tha
one requirement type for targets.

You control the query. To ensure the information in a queried view is curr
especially if other users are working in the database being queried, refres
database with new data (click View > Refresh the Refresh button), then 
reapply the query criteria.

• By default, the Attribute Matrix view displays all attributes for any 
requirement type and all requirements of that type. You can display o
the most necessary attributes when querying this view.

• The Traceability Matrix view displays two requirement types and the 
interrelationships between them.

Note: When an Attribute Matrix view or a Traceability Matrix view is 
queried, a filter and/or a sort is applied to the row and/or column 
requirements in the view.
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• The Traceability Tree view displays all requirements of one type (root) 
all requirements related to/from them.

When a Traceability Tree view is queried, the filter and/or sort criteria 
applied to the root requirements in the view.

Creating Queries
1. In the Views Workplace, open an Attribute Matrix, Traceability Matrix, 

Traceability Tree view (For more information on views, refer to Chapt
4: Views.)

2. Click the View menu in the Views Workplace.

The command displayed in the View menu depends on the active vie

• To query row requirements in an Attribute or Traceability Matrix,
select Query Row Requirements.

• To query column requirements in a Traceability Matrix,
select Query Column Requirements.

• To query the root requirements in a Traceability Tree view,
select Query Root Requirements.

The Select Attribute dialog box appears.

Note: Both requirement attributes you have created and system attribut
created by default in RequisitePro are included in the list.

3. Select the attribute that you want to use to query, and click OK .

The Query Requirements dialog box appears. Depending on the type 
attribute you selected (list-type or entry-type), the box contains a spec
set of criteria for you to define.

4. For list-type attributes, select one or more values.
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For entry-type attributes, mark an option (i.e. includes, equal to) and type 
in the value.

5. Enter a Sort Order: None, Ascending, or Descending.

Note: To temporarily sort attribute values in ascending or descending o
in an Attribute Matrix, you can right-click on the attribute label and
select Sort Ascending or Sort Descending on the shortcut menu. 
This sorting does not change an existing filter, and the sort order 
be reset if you create or modify a query.

6. Enter When Traced criteria, if applicable. The When Traced option is o
available when trace to or trace from attributes are queried. For 
hierarchical requirements, traceability queries automatically include th
parent if the child participates in a traceability relationship (You canno
query for suspect hierarchical relationships).

Note: You cannot create a traceability query between two external 
requirements.

7. Click OK . The Query [Row/Column/Root] Requirements dialog box 
reappears.

8. To add other query criteria, click Add and repeat steps 3 through 7.

Note: The logical operator and is assumed between multiple attributes

9. Click the Retain Hierarchical Display check box to include the parents
of child requirements that match the filter criteria, even though the pare
do not match.

Note: The query engine ignores hierarchical relationships, unless you m
the Retain hierarchical display check box. (For more information 
on parent-child requirements, refer to Hierarchical Relationships on 
page 9-1.)

10. When the query is built, click OK  in the dialog box. RequisitePro update
the view with the query results.

Note: To run the query again, click the View menu and click Query 
Now. (For more information on Query Now, refer to Viewing 
Current Data on page 4-2.)
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Modifying Queries

After you have created a query, you can make changes to the query crite
With the view open, do the following:

1. To open the Query [Row/Column/Root] Requirements dialog box 
(depending on your displayed view), click the View menu and choose 
Query Row Requirements, Query Column Requirements, or Query 
Root Requirements.

2. Select the query criteria you want to modify and click Modify .

3. The Query Requirements dialog box appears. (The dialog box that 
appears depends on whether the attribute is a list-type or entry-type.)
Follow steps 4-10 above in Creating Queries.

Deleting Queries

1. In the Views Workplace, click the View menu and choose Query Row 
Requirements, Query Column Requirements, or Query Root 
Requirements.
The Query [Row/Column/Root] Requirements dialog box appears 
(depending on your displayed view.

2. In the Query Criteria  list, select the query criteria you want to delete.

Note: The order of this list determines the order in which RequisiteP
filters and sorts the criteria. Be aware that deleting a query fro
the list may affect the results of subsequent queries.

3. Click Remove. Click OK  to close the dialog box.

Searching for Requirements in the Database, 
Documents, and Views

RequisitePro provides two methods for finding requirements: 

• The Go To command launches a global search of the database, quick
finds a requirement, and displays it in its location (document or view).

• The Find Requirement command launches a search for a requirement
the active view or document.
5-5



Query and Search

 

 the 

ears 

es, 
Using Go To to Search the Database for a Requirement
1. Do one of the following:

• On the Tool Palette, click Requirement > Go To.

• In the Word Workplace, click RequisitePro > Requirement > Go To.

The Go To Requirement dialog box appears: 

2. Select the requirement type from the Requirements of Type list box. If 
you do not know the requirement type, select All Requirement Types. 

3. Select the location of the requirement from the drop-down list in the 
Located in edit box. Choose All locations, Database only, or a specific 
document from the list.

Note: Click the Find button to open the Find Requirement dialog box, 
which you can use to locate a specific tag number and/or 
requirement text.

4. Highlight the requirement and click OK . RequisitePro performs one of the
following operations: 

• If the requirement is in an unopened document, RequisitePro opens
document and highlights the requirement.

• If the requirement is in an open document, the Word Workplace app
with the document active and the requirement highlighted.

• If the requirement is in the database only, the Requirement dialog box 
appears so you can examine or modify its description, attribute valu
or traceability relationships.
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Using Find Requirement to Search an Active Document or View
1. Do one of the following:

• To search in a document, click Requirement > Find on the Tool Palette, 
or click RequisitePro > Requirement > Find in the Word Workplace.

• To search in a view, click Requirement > Find (or the Find 
requirement button) in the Views Workplace.

The Find Requirement dialog box appears: 

2. Type the text of the requirement in the Text Search field.

3. The next step is to establish a search parameter. The dialog box offers
different ways to search for text:

• Mark the Match case check box for a case-sensitive search.

• Mark the Use * as wildcard check box for a wildcard search. The 
asterisk matches 0 or more characters.

• Mark the Find whole words only check box for an exact word match.

4. Mark the Up or Down button to specify a direction to search the view o
document.

5. Click Find Next to launch the search. RequisitePro searches the curre
view or document for the requirement that satisfies the parameters 
established in the dialog box.

• If the requirement is found, RequisitePro highlights the requirement 
displays it in context. 

• If the search is performed in a view and all requirements in the view
not expanded, RequisitePro expands the requirements in the view t
display the results of the search.

• If the requirement is not found, RequisitePro returns to the requirem
from which the search began.
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Shortcuts to a Document-Based Requirement from a View
When you are working in the Views Workplace, you can switch to the Wo
Workplace to read the document-based requirement in context or to mod

In the Views Workplace, highlight the requirement to display and do the 
following:

• Press the right button on the mouse and choose Go To from the shortcut 
menu that appears, or

• Double-click the requirement.

Note: This shortcut works only if the default Double-click to go to 
document option is marked in the Tools > Options dialog box.

RequisitePro opens the Word Workplace and highlights the requireme
the document.

Reviewing a Project with Cross-Project Traceability
Sometimes, when you open a project, RequisitePro connects to an exter
project and displays both projects. In this case, the projects have been 
connected to one another, and cross-project traceability relationships ma
exist. You can review the requirements in both projects and their change
managed relationships in the Views Workplace.

Cross-project traceability creates traceability relationships between 
requirements that reside in different projects. This feature establishes 
connectivity among projects that were divided into subprojects or projects
relate to each other or share a set of requirements. (For more information
cross-project traceability, see Setting Up and Modifying Cross-Project 
Traceability on page 15-11.)

Results of Cross-Project Traceability

Once cross-project traceability relationships are established, the following
occur:

• External requirement types can be queried for display in views. 

• If a requirement that is traced to requirements in other projects is dele
RequisitePro updates the other projects to reflect the change. If the 
traceability relationship in the external project cannot be deleted, the 
relationship is updated when connectivity is established between the 
projects.
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• If a requirement modification causes the relationship to become susp
and the requirement is traced to or traced from requirements in other 
projects, RequisitePro updates the projects to reflect the suspect link. I
traceability relationship in the external project cannot be modified, the
relationship is updated when connectivity is established between the 
projects.

• If a link between an internal and external requirement is marked as sus
cleared as suspect, or created or removed by the user, RequisitePro up
both the internal and external projects to reflect the change.

• RequisitePro checks for circularity when external relationships are 
created. The circular check references internal requirements and first-
external requirements.

Displaying External Requirements

Requirements in the current project are distinguished from requirements 
external projects by the project prefix. External requirements appear as 
follows:

• The Traceability  tab in the Requirement dialog box displays only the 
relationships that are related to the current project. The General tab 
displays external requirement information as read-only.

• The Find Requirement dialog box displays a list of requirement types fo
the current project and each externally mapped project. 

• The New View dialog box displays requirement types from the current
project and any external projects. If the Attribute Matrix view is selecte
only the internal requirement types are available for selection. A full 
Attribute Matrix view of external requirements is not provided because
performance considerations.

• The Attribute Matrix displays all internal and external traceability 
relationships in the Trace-to-from columns.

• The Traceability Matrix  displays all internally and externally mapped 
requirements of a single requirement type in the rows and columns. 

• The Traceability Tree displays all internal and external requirements 
traced to or traced from a requirement. The first level cross-project 
traceability level displays. So, if an internal requirement is traced to an 
external requirement, the external requirement is displayed in the tree
Other requirements the external requirement traces to do not appear.
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Displaying Requirement Relationships in Exported Views 

Requirements in exported views with cross-project traceability appear as
follows:

• An exported CSV file indicates that a traced to/from requirement exists as
displayed in the view.

• An exported Word file indicates a traced to/from requirement exists as 
displayed in the view. 

For more information on exported views, refer to Exporting Requirements on 
page 11-23.

RequisitePro Extensibility Interface

For advanced querying capabilities, the RequisitePro Extensibility Interfa
provides a fully documented COM-based API, giving customers and third
party solution providers direct access to the requirement data.

The Extensibility Interface includes complete documentation for the 
RequisitePro Query Engine and the associated query language syntax. T
Query Engine provides a programmatic interface and utilizes objects to 
retrieve RequisitePro project data for requirements and discussions. You
optimize queries to load only necessary information, enhancing the 
performance of your application.

Launch the documentation for the RequisitePro Extensibility Interface by
clicking Help > Extensibility Interface Reference.
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Discussions

Discussions let you address comments, issues, and questions to a group
participants that you define. Discussions can be associated with one or m
specific requirements, or refer to the project in general. A discussion item
either the initial discussion topic or a response. A participant can respond
either the initial discussion text or to another response.

Understanding Discussions

Viewing Discussions
All project users can read discussion items in RequisitePro, whether they
discussion participants or not. Any participants who have an e-mail addre
specified in their user information can read discussion items via e-mail. S
Configuring E-mail for Discussions on page 6-2 for more information.

When a user opens a project, RequisitePro displays an icon on the Tool P
status bar to indicate that there are new discussions or responses associ
with that project or its requirements.

Responding to Discussions
When a user responds to the discussion, the response is added to the pro
RequisitePro. In addition, the response is sent to all participants who hav
e-mail address specified in their user information.

If you are the discussion author or a project manager, you can restrict the
discussion to participants. In this case, all project users can still read discu
items, but only participants can respond to the discussion.
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Configuring E-mail for Discussions
RequisitePro offers the capability of communicating with a group of 
discussion participants regarding comments, issues, and questions relate
one or more requirements, or related to the project in general. When ena
for e-mail, this feature will automatically generate an e-mail copy of any 
discussion item you enter (a new discussion or a reply) and send it to all 
discussion participants with valid e-mail addresses.

Discussion e-mail is enabled and configured in several ways:

• Enter an e-mail address in Project Security on the Project menu.

• Configure an outbound e-mail service on the Tools menu.

• Configure inbound and outbound mail for all users with e-mail addres
using the Rational E-mail Reader application.

Entering E-mail Addresses in Project Security

All RequisitePro users can add or edit their own e-mail addresses within 
RequisitePro; however, only project managers with administrator permiss
can add or edit other users’ information. 

See the procedure Modifying Your Password, User Name, or E-mail Addres
on page 3-8 for information on entering your own e-mail address in Proje
Security. Administrators can use the same procedure for entering or modif
all users’ e-mail addresses.

Configuring Outbound E-mail for Discussions

Use the E-mail Setup option to configure an e-mail service for your outbo
e-mail to other discussion participants. When you initiate or reply to a 
discussion item from within the RequisitePro Discussions dialog box, this 
feature automatically sends copies of the discussion items to the Requisit
database and to all participants with a valid e-mail address in their 
RequisitePro user information. 

Note: The E-mail Setup option is not required if your system administra
has configured inbound and outbound e-mail using the Rational E
mail Reader. See Configuring E-mail Using the Rational E-mail 
Reader on the following page.
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To configure your outbound e-mail:

1. On the Tool Palette, click Tools > E-mail Setup.
The E-mail Setup dialog box appears.

2. Click the Enable E-mail Notification check box to automatically generate
outbound e-mail (messages from you to other discussion group 
participants) when you create or reply to a discussion item in Requisite
Clear the check box to disable outbound e-mail messages.

3. Click the down-arrow at the E-mail Provider  field and select the e-mail 
protocol that is used on your LAN:

• SMTP/POP3

• MAPI

4. For SMTP/POP3, type the following:

• your SMTP server name

• your e-mail address, such as “yourname@yourcompany.com”

• your name as it should appear in discussion group notices

5. For MAPI , type your MAPI profile. 

6. Click OK .

Configuring E-mail Using the Rational E-mail Reader

The Rational E-mail Reader offers full e-mail integration with RequisitePro
associating an e-mail handler with each RequisitePro project. The Ration
mail Reader application allows discussion participants to reply to the 
discussion items using their e-mail, as well as from within RequisitePro. In
discussion items and replies are automatically stored in the RequisitePro
database and sent to discussion participants via e-mail. Participants can 
to the discussion items using their e-mail, as well as from within Requisite

Discussion participants must have an e-mail address specified in their 
RequisitePro user information in order to receive discussion-related e-ma

To configure e-mail using the Rational E-mail Reader, refer to Configuring E-
mail for Discussions in the “Rational RequisitePro Installation” chapter of th
Rational RequisitePro Installation Guide. This configuration is typically 
performed by a system administrator.
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Creating Discussions

You can create a new discussion at any time.

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears:

2. Click Create. The Discussion Properties dialog box appears:

3. Click the General tab.

4. Enter a subject (required). The subject should be brief, but descriptive
enough to inform other users of the discussion’s contents.
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5. Enter text. The text you enter will become the first item in the discussi
Open the discussion by raising an issue, making a comment, or askin
question.

6. Click the Participants tab. Add users and groups. (See Creating and 
Modifying Discussion Participants Information on page 6-15.)

7. Click the Requirements tab and add requirements. (See Creating and 
Modifying a Discussion's Requirement Information on page 6-17.)

Note: If you have filtered or displayed only discussions associated w
specific requirements, those requirements are automatically lis
on the Requirements tab. (See Displaying, Filtering, and Sorting 
Discussions on page 6-11.)
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8. Click OK .
The discussion is opened and the message is sent to all participants 
have an e-mail address specified in their user information. An icon on
Tool Palette also notifies users that there is a new discussion associa
with that project.

Viewing and Modifying Discussion Properties
To view discussion properties:

1.On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears

2.Select a discussion and click the Properties button.

Note: Only the originator of the discussion and an administrator can
modify a discussion’s properties.

The Discussion Properties dialog box lets you do the following:

• Use the General tab to view the discussion subject and text, or enter
subject and text when you are creating a new discussion.

• Use the Attributes  tab to view the discussion’s author, the date and tim
the discussion was created, and the discussion’s current priority an
status. Only the priority and status can be modified.

• Use the Participants tab to view or modify listings of the discussion’s
participants, divided by users and groups, and whether or not the 
discussion is restricted to participants. 

• Use the Requirements tab to determine which requirements are 
associated with a discussion. Note that a discussion does not need
address any requirements specifically. However, if a specific 
requirement is addressed, it should be associated using this tab.

Notifying Participants about a New Discussion
When you create a new discussion, you do not have to do anything to no
participants about the discussion, provided that you have:

• entered a subject and topic text in the Discussion Properties dialog box 
at the General tab, and

• specified participants in the Discussion Properties dialog box at the 
Participants tab.
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Note: In a new discussion, the discussion author is automatically includ
as a participant.

After you have completed these two tasks and clicked OK  in the Discussion 
Properties dialog box, RequisitePro adds the discussion to the project an
sends an e-mail message to each participant for whom an e-mail address
been specified in the participant’s user information. The message contain
subject and text you entered at the General tab.

Participants can also read the discussion and its responses in RequisiteP
When a user opens a project, RequisitePro displays an icon on the Tool P
to indicate that there are new discussions or responses associated with t
project and/or its requirements.

Reading Discussions

The Discussions dialog box helps you keep track of which discussion item
you have read and which you have not.

1. On the Tool Palette, click Project > View Discussions.
(or the Show Discussions button).

The Discussions dialog box appears.

2. In the discussions list, click a discussion.

An expand/collapse indicator is displayed to the left of discussions wi
responses. Unread discussion items are shown as bold text. Items you
read are shown as normal text.

3. Click an item to read it. The item’s text displays in the lower portion of t
dialog box.

After approximately 5 seconds, RequisitePro changes the item from b
to normal text, indicating that it has been read. If you select another it
before approximately 5 seconds elapse, RequisitePro leaves the previ
selected item bold, indicating that it is still unread.

4. To manually mark an item as read or unread, right-click the item and se
Mark Read or Mark Unread  on the shortcut menu that appears.
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Responding to Discussions

You can respond to a discussion either in RequisitePro or in your e-mail 
application. 

Note: If you are not a discussion participant, you can respond to the 
discussion only if the Restrict To Participants check box is cleared 
in the Discussion Properties dialog box at the Participants tab. Only
the discussion author and members of the Administrators group c
modify this option.

Responding to Discussions in RequisitePro
To respond to a discussion using the Discussions dialog box in RequisitePro:

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).

The Discussions dialog box appears:

2. In the discussions list, click a discussion or response to a discussion.
The discussion text appears in the lower portion of the Discussions dialog 
box.

3. Click Reply. 
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The Discussion Response dialog box appears:

The default subject is “RE: [previous discussion item's subject].” You c
change the subject.

4. Enter the text of your response. 

The text automatically wraps at the end of each line you type. You can
Ctrl-C to copy selected text from another application or document, an
Ctrl-V to paste it into the response text box. Text formatting, such as b
and underline, is not available in the Discussion Response dialog box. 
You cannot attach files to the response.

5. Click OK . The Discussions dialog box is displayed again. RequisitePro
updates the associated project and discussion, and then sends your 
response to all participants who have an e-mail address specified in t
user information.

Responding to Discussions Using E-mail
You can respond to a discussion using your e-mail application. Dependin
whether your system administrator has enabled inbound e-mail using the
Rational E-mail Reader, one of two conditions apply:

• If inbound e-mail is enabled, your reply is delivered to all discussion 
participants and stored in the RequisitePro database. It is then acces
from within RequisitePro. 

• If inbound e-mail is not configured, your reply is delivered to the recipie
you select, but it is not stored in the RequisitePro database.
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To respond to a discussion using your e-mail application:

1. In your e-mail application, open the message containing the discussio
item to which you wish to reply.

2. Select the reply option.

3. Use the default recipient provided.

Note: If inbound e-mail is enabled, messages will arrive from an e-m
handler that is specific to a RequisitePro project. In this case, 
simply reply to the sender. If inbound e-mail is not enabled, yo
can reply to all recipients; however, in this case, your messag
will not be stored in the RequisitePro discussion. You can add
recipients in either case.

4. Use the default subject provided. Do not modify the subject.

5. Enter the text of your response. Do not type below the line: “Text belo
this line is not included in the discussion response.” In addition, do no
delete this line or anything below it.

RequisitePro uses this line to indicate which text is your response an
which text is already included in the discussion. If you delete the line, y
reply includes both your new text and any text that was below the dele
line.

Note: Attachments are not supported in discussions. Any attachmen
you include will not be added to the discussion in the 
RequisitePro database.

6. Send the e-mail message. The message is sent to RequisitePro, whic
updates the associated project and discussion, and then sends your 
response to all participants who have e-mail.

Note: Discussion replies cannot be modified after they have been s
This prevents conflicts when the reply text is included in anoth
reply. If you want to add an explanation regarding your messa
you can do so by creating another reply.
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Displaying, Filtering, and Sorting Discussions

Displaying Discussions Associated with a Single Requirement
You can open the Discussions dialog box to display only the discussions 
associated with a specific requirement. Or, you can open the Discussions 
dialog box to display all open discussions.

To display only discussions associated with a requirement:

1. Select a requirement.

2. Open a discussion.

• In the Views Workplace, select a requirement and then do one of th
following:

• Click Requirement > Discussions.

• Click the Discussions icon to the right of the requirement.

• Right-click the requirement, and then click Discussions in the 
shortcut menu that appears.

• In the Word Workplace, select a requirement and then do one of th
following:

• Click RequisitePro > Requirement > Discussions.

• Click Requirement > Discussions on the Tool Palette.

3. The Discussions dialog box appears, showing only those discussions 
associated with the specified requirement.

Note: To display all discussions, do one of the following:

• click Filter , clear the Requirement check box, and then click OK, or

• close the dialog box, and click Project > View Discussions on the Tool 
Palette.
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Filtering Discussions
You can specify which discussions you wish to view in the Discussions dialog 
box, based on text, requirement, users, priority, and status.

To filter discussions, do the following:

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).

The Discussions dialog box appears, showing all open discussions:

2. Click Filter . The Discussion Filter dialog box appears:

3. To display discussions containing specific text in their subjects, select
Subject Text check box, and then enter the text in the text box.
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Use * (asterisk) in the text if you want RequisitePro to find discussion
using the wildcard character * to match one or more characters in the
search text. For example, if this check box is selected and you enter the
*document*, RequisitePro finds discussions containing document, 
documents, documented, undocumented, etc.

4. To display discussions with which one or more requirements are 
associated, mark the Requirement check box, and then enter the 
requirements by which you wish to filter (separated by commas) in the 
box. For example, enter PR1, SR22, TST114 to include all discussions 
with which the requirements PR1, SR22, or TST114 are associated.

Note: Alternatively, click the adjacent ... button to open the Select 
Requirements dialog box, which you can use to select 
requirements by name.

5. To display discussions for which a particular user is a participant, sele
the Participant  check box, and then select the desired user name in the

Note: You can select the name of a user who is a member of a grou
RequisitePro will find discussions for which that group’s 
members are participants, including the selected user.

6. To display discussions with a specific priority, select the Priority  check 
box, and then select High, Medium, or Low in the list. 

7. To display open or closed discussions, select the Status check box, and 
then select Open or Closed in the list.

8. Filter by more than one option by repeating any of steps 3 - 7 above.

9. Click OK .

The Discussions dialog box is displayed again, showing only the 
discussions that match the filters set above. The filter settings are displ
next to the Filter  button in the dialog box.
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Sorting Discussions
In the Discussions dialog box, you can change the sort order in which 
discussions appear.

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click the column heading by which you want to s
the discussions.

For example, to sort discussions alphabetically by subject, click the 
Subject column heading.

3. To reverse the sort order, click the column heading again.

Printing Discussions

You can print discussion items. The printout shows the discussion item’s
subject, text, author, and creation date and time. The printout also shows
information about the associated discussion, including the discussion’s 
priority, status, requirements, and participants.

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click one or more discussion items. (Use a mult
select action to select more than one item.)

3. Click the Print  button. A Print  dialog box appears.

4. Click OK .

Modifying Discussions

Viewing and Modifying Discussion Attributes
The Attributes tab in the Discussion Properties dialog box shows the 
discussion’s author, the date and time the discussion was created, and it
current priority and status. These properties can be modified by the discus
author and project administrators only.
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To modify discussion attributes:

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears.

2. Select a discussion, and then click Properties.
Alternatively, click Create to create a new discussion.

3. Click the Attributes  tab.

4. Click the down arrow at the Priority  field and select a priority from the 
drop-down list.

Note: You can only change a discussion’s priority if the discussion is
open.

5. If you are modifying a discussion, change Status to Open or Closed. (You 
cannot change the status of a new discussion.)

Creating and Modifying Discussion Participants Information
The Discussion Properties dialog box, Participants tab lets you determine 
which users and groups are included in the discussion, and whether or no
discussion is restricted to participants. 

Any user can view the Participants tab, but only the discussion author and 
project administrators can modify its options, with the following two 
exceptions:

• If the Restrict To Participants check box is cleared, you can add 
yourself to the Users list.

• Regardless of whether or not the Restrict To Participants check box is 
selected, you can remove yourself from the Users list. 

Note: However, if you are a member of a group that participates in t
discussion, you cannot remove yourself from the group. A 
RequisitePro administrator must remove you from the group.

The options in this dialog box can be modified only if the discussion is op
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To modify participants information:

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click an open discussion and click Properties; or 
click Create to create a new discussion. The Discussion Properties dialog 
box appears:

3. Click the Participants tab.

4. To add a user, click Add below the Users list. The Project Users dialog 
box appears:

5. Select a user from the list, then click OK . (Use a multiple select action to
select more than one user.)

Note: For a new discussion, the discussion author is automatically 
included as a participant.
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6. To add a group, click Add below the Groups list. The Project Groups 
dialog box appears:

7. Select a group from the list, then click OK . (Use a multiple select action to
select more than one group.)

Note: If a user is a member of a group and you add the group to the
Groups list, you do not need to add the user individually to the
Users list.

8. To remove users, click the user names in the Users list, then click Remove 
below the Users list.

9. To remove groups, click the group names in the Groups list, then click
Remove below the Groups list.

10. To restrict the discussion to participants only, select the Restrict To 
Participants check box. Only participants will be able to respond to th
discussion, although all users can read it in RequisitePro.

11. Click OK  to close the dialog box.

Creating and Modifying a Discussion's Requirement 
Information

The Discussion Properties dialog box, Requirements tab lets you determine 
which requirements are associated with a discussion. Note that a discuss
does not need to address any requirement specifically. However, if a spe
requirement is addressed, it should be associated using this tab.

Any user can view the Requirements tab, but only the discussion author an
members of the Administrators group can modify its options. The options
this dialog box can be modified only if the discussion is open.
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To modify a discussion’s requirement information:

1. On the Tool Palette, click Project > View Discussions
(or the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, select an open discussion and click Properties, or 
click Create to create a new discussion. The Discussion Properties dialog 
box appears.

3. Click the Requirements tab.

4. To add a requirement, click Add. 

The Select Requirements dialog box appears:

5. Select a requirement type from the Requirements of type list.

Note: Requirements with pending tag numbers do not appear in this

6. Select a location from the “Located in” list.

7. Select a requirement from the list. (Use a multiple select action to sel
multiple requirements.) 

8. To locate a specific requirement, click Find.

9. When you have finished selecting requirements, click OK . 
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The Discussion Properties dialog box reappears with the specified 
requirement shown in the Associated Requirements list:

10. To remove a requirement, click the requirement in the Associated 
Requirements list, then click Remove.

11. To display a requirement’s properties, click Properties. The 
Requirement dialog box appears, showing the selected requirement's
properties. 

12. Click OK . To close the Discussion Properties dialog box, click OK .

Creating and Modifying a Requirement’s Discussion 
Information

You can view and create discussions from within the Requirement dialog box 
at the Discussions tab.

1. Do one of the following to open the Requirement dialog box:

• In the Word Workplace, select the requirement in an opened docum
and click RequisitePro > Requirement > Properties.

• In the Word Workplace, select the requirement in an opened docum
On the Tool Palette, click Requirement > Properties.

• In the Views Workplace, select the requirement in a view. Click 
Requirement > Properties.

2. Click the Discussions tab. A list of all discussions associated with the 
requirement is displayed.

3. To create a new discussion associated with this requirement, click Create.

4. To read a discussion item, select the discussion, and then click View.
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5. To view the properties for a selected discussion, select the discussion
click Properties.

Note: If the requirement is not saved in the database yet, the Create, View, 
and Properties buttons are disabled, regardless of how you access
the Requirement dialog box. Save the document containing the 
requirement, then open the dialog box again.

Closing Discussions

If you are the discussion author or a project administrator, you can close 
discussion if it is no longer needed. Closed discussions are filtered out of
Discussions dialog box by default. A discussion must be closed before you 
delete it.

1. On the Tool Palette, click Project > View Discussions
(or click the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click the open discussion.

3. Click Properties. The Discussion Properties dialog box appears.

4. Click the Attributes  tab.

5. Click the down arrow at the Status field and select Closed from the
drop-down list.

6. Click OK . The Discussions dialog box reappears. When the discussion
selected, the Delete button is enabled, indicating that the discussion is 
closed and can be deleted.

Deleting Closed Discussions
If you are the discussion author or a project administrator, you can delete
closed discussion. A discussion must be closed before you can delete it.

1. On the Tool Palette, click Project > View Discussions
(or click the Show Discussions button).
The Discussions dialog box appears.

2. In the discussions list, click a closed discussion.

3. Click Delete. A message appears, asking you to confirm the deletion.

4. Click Yes.
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Documents

A RequisitePro requirements document is a Word file created in RequisitePro 
and integrated with the project database. Requirements created outside o
project document can be imported or copied into a project document. 

When you create a new project document, RequisitePro associates the 
document with the project that is open. This association is used to update
database and synchronize the revision numbering of the project and docum
The document’s name, location, document type, and revision information
stored in the project database. 

Creating a Project Document

To create a document in a project:

1. On the Tool Palette, click Document > New; or 
in the Word Workplace, click RequisitePro > Document > New.
The Document dialog box appears:
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2. Type the name of the document in the Name field (64 characters 
maximum).

3. Type a a brief description of the document’s purpose or contents in th
Description field. 

4. Type a file name in the Filename field. You do not need to give it an 
extension; RequisitePro assigns an extension according to the Docum
Type selected.

5. Click the Show Tags check box to display requirement tags in the new
document. Clear this box to hide the tag text. 
Selecting this check box sets options in Microsoft Word to ensure that
requirement tags are visible both on your display and in the printed 
document. The check box “Hidden Text” is marked in both the View ta
and the Print tab in the Microsoft Word Tools > Options dialog box.

6. Type a location for the file in the Directory  field, or click Browse to select 
a directory.

7. Click the down arrow at the Document Type list and select a document 
type to assign to the new document.

8. Click OK . The new document is open and ready to be edited.

Note: The document must be saved for the requirements to be 
committed to the database.

Saving a Project Document

When a document is saved in RequisitePro, all modifications to the docum
properties, such as its logical name, revision number, label and change 
description, are saved to the project database. New requirements and ch
made to existing requirements are committed to the database and are re
in the document. Requirements that were deleted from the document are
deleted from the database.

To save a project document:

1. Do one of the following:

• click the Save the current document button on the Tool Palette; or

• click Document > Save on the Tool Palette; or 

• in the Word Workplace, click RequisitePro > Document > Save.
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If a requirement in the document was modified, the Change Description 
dialog box appears and prompts you to type a reason for the change:

2. Type an explanation of the modifications in the Change Description field.

3. Click the Apply to all... check box, if the change description applies to a
requirements that were changed in the document. 

4. Click OK .

Opening a Document After a Project is Open

To open a project document:

1. Do one of the following:

• on the Tool Palette, click the Open a project and documents button, or

• click Document > Open, or

• in the Word Workplace, click RequisitePro > Document > Open.

The Open Project and Documents dialog box appears.
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The Open Project and Documents dialog box displays a list of projects
available in your project list. Beneath the Projects list box, a second l
box displays the documents that are associated with project you sele

2. Select a project from the project list. A list of the project’s documents 
appears in the document list. This list includes all documents you hav
either created in the project or imported into the project, regardless o
whether the documents contain requirements.

Only one project can be open at a time. If you try to open another pro
and its documents while working in a project, RequisitePro prompts yo
save any modifications, closes the current project and its associated 
documents before opening the new project and documents.

Note: For more information on options for controlling access by other us
when the project and documents are open, refer to Controlling User 
Access to a Document on page 14-1.

3. Select one or more documents to open and click OK . 
RequisitePro launches Word and opens the documents.
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Closing and Saving a Project Document

To close a project document:

1. On the Tool Palette, click Document > Close, or
in the Word Workplace, click RequisitePro > Document > Close.
If modifications were made to the document that were not saved, the 
Document Changed dialog box appears:

2. Do one of the following:

• To accept the modifications and save the document, click Yes. 

• To abandon the modifications and leave the document as is, click No. 

• To return to the document without closing, click Cancel.

• To review changes to the document, click the Review Changes button. 
The Document Changes dialog box lists changes, as described below

Note: If you changed one or more requirements in the document, the 
Change Description dialog box appears (whether you selected Yes 
or Review Changes above). You have the option to record reasons
for changing each requirement.

Reviewing and Changes Before Closing a Document
When closing a document that has been modified, the Document Changed 
dialog box presents you the option of reviewing the changes.

To review modifications to a document:

1. Follow steps 1 and 2 above and click the Review Changes button. 

If you have changed one or more requirements in the document, the 
Change Description dialog box appears. You have the option to record
reasons for changing each requirement. 

Then the Document Changes dialog box lists all modifications to the 
document. 

2. Click OK to save the changes once you have reviewed them.
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Changing the Location of a Project Document

New documents are stored in the project directory by default. Documents
be created in or moved to any directory on the file system. All documents
associated with the project are included in your project list regardless of w
they are stored.

To change the location of a project document:

1. On the Tool Palette, click Document > Properties, or
in the Word Workplace, click RequisitePro > Document > Properties.

The Document dialog box appears. On the General tab, the document file 
name and location appear in the Directory edit box.

2. Click Browse to change the location of the file. The Browse for Folder 
dialog box appears:

3. Select a new location for the document. Click a folder to open it.

4. Click OK to accept the location and close the Browse for Folder dialog 
box. 

5. Click OK  to close the Document dialog box.
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Modifying Document Information

To modify information in an open project document:

1. Open the Document dialog box, in one of the following ways:

• In the Word Workplace, click RequisitePro > Document > Properties.

• On the Tool Palette, click Document > Properties.

2. Modify the document’s information:

• On the General tab, you can change the name of the document, its 
description, and the directory in which it is stored. You cannot chan
its logical name or its document type.

• On the Revision tab, you can enter a Change description. All other fiel
are populated by RequisitePro.

3. Click OK  to close the Document dialog box. 

4. To save your changes to the document, do one of the following:

• In the Word Workplace, click RequisitePro > Document >Save.

• On the Tool Palette, click Document >Save. 

Working With Microsoft Word

Saving a RequisitePro Document as a Word Document
RequisitePro includes an option to save a project document as a Microso
Word document that is independent of the project. This allows you to atta
the document to e-mail or share the document with someone outside of y
work group. 

When you choose this option, RequisitePro makes a copy of the active 
requirements document and saves it as a Word file. The resulting Word 
document retains the look and feel of the original requirements document
even includes bookmarks and tags used by RequisitePro to identify 
requirements.

To save a project document as a Word document:

1. On the Tool Palette, click Document > Save As, or
in the Word Workplace, click RequisitePro > Document > Save As.
The Save As dialog box appears.

2. Specify a destination for the new copy of the document. 
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3. Accept the default name in the File name field, or type a file name and .doc
extension for the document.

4. Click Save.

Managing Microsoft Word Documents
While working in RequisitePro, you can create, open, modify, save, and c
Word documents that are independent from RequisitePro. Use the stand
File menu commands to manage these Word documents (The Save As an
commands are disabled in the Word Workplace in order to prevent conflic
handling RequisitePro documents).

Note: RequisitePro documents are associated with projects, managed f
the Document menu on the Tool Palette or the RequisitePro menu in 
the Word Workplace, and saved in RequisitePro format by default

Closing Microsoft Word
To close Word without closing RequisitePro, click the Window menu on the 
Tool Palette and choose Close Word.

Tips for Using Word in RequisitePro

Do not use

Do not use the Microsoft Word File > Versions feature. The Word logic of 
identifying a base version with subsequent revisions conflicts with 
RequisitePro’s document revision history features. Version changes in W
can conflict with the RequisitePro requirements database. In addition, mul
versions greatly increase your document file size.

Do not use the Track changes while editing, Protect Document, or 
Revisions options on the Word Tools menu for requirements documents. 
Requirements may become corrupt if you use this feature instead of the 
RequisitePro Protect for Revisions command.

Use with caution

While you can use Word’s automatic paragraph numbering (the Format > 
Bullets and Numbering command) within requirement text in a requireme
document, this feature can produce inconvenient and unexpected results
Automatic numbering changes caused by the addition or deletion of 
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paragraphs require you to confirm changes to all subsequent numbered 
requirements in the document. This also adds a revision history entry for 
requirement, resulting in cluttered revision history list. Changes in 
autonumbering can also impact the requirement tag numbering.

Improving Word performance

The following tips can improved Microsoft Word's performance with 
RequisitePro documents:

• Create small RequisitePro documents. Since large documents can take
significant time to open, close and manipulate, documents less than 5
or about 50 pages are optimal. 

• View documents in Normal mode. Documents in Page Layout mode ar
constantly being repaginated.

• Open documents selectively. Many Word documents open at once 
decreases performance.

Working with Word styles

If you press Enter after a marked requirement in a document, the require
style (such as double underline) and color are carried to the next line. Pre
Ctrl  and the Spacebar before typing, and the Word style is reset to Norma

Using Word Options for “hidden” requirements

You can set options in the Microsoft Word Tools > Options dialog box to 
affect how requirements are displayed in RequisitePro documents:

• If you clear the Bookmarks check box, you will not see the bookmark
around the requirement in RequisitePro documents.

• The requirement tag in a RequisitePro document is hidden text in 
Microsoft Word. If you clear the Hidden text check box, you will not se
the tag in the text of the requirement in the RequisitePro document. 

For information about setting color and style for requirements, refer to the
Creating and Modifying Requirement Types on page 15-4.

Editing a requirements document outside of RequisitePro

To edit a document in Word outside of RequisitePro and merge it back in l
use RequisitePro’s offline authoring feature rather than the Save As comm
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Creating a Word document from a RequisitePro 
requirements document

Use the Document > Save As command to save a copy of your requiremen
document with a .doc file extension. The resulting Word document will no
appear in the project documents list.

Managing external Word documents

To manage a Microsoft Word document that is not part of a RequisitePro
project, use the File menu commands in the Word Workplace.

Disabled Word commands

The File > Save As and File > Exit commands are disabled in the Word 
Workplace in order to prevent conflicts in handling RequisitePro docume
On the RequisitePro Tool Palette, use the Window > Close Word command 
to close the Word Workplace.

The Tools > Protect Document command is disabled and replaced with th
RequisitePro Document > Protect for Revisions command.

The Tools > Templates and Addins is disabled to prevent deletion of the 
RequisitePro template, which is required for proper functioning of 
RequisitePro.

Working With Documents Offline 

Offline authoring lets requirements authors and project managers use a pr
document outside of RequisitePro (i.e., offline).

When you take a document offline, RequisitePro creates a copy of the 
document in the directory you specify. The original is still stored in 
RequisitePro, but it is changed to a read-only document. Other users can
the document in RequisitePro, but they cannot edit it until you bring it bac
online.

When you take a document offline, RequisitePro includes Microsoft Word
macros in the document. These macros allow you to add and delete 
requirements in the offline document.

Note: You must have Microsoft Word 97 or Word 2000 to include the 
Requisite Pro macros in the offline document. You can edit the 
document offline using an older version of Word, but you will not 
have macros for creating and deleting requirements unless you u
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Word 97 or Word 2000.
In Word 2000, you may need to adjust your macro security levels 
use the Requirement > Create and Delete menu commands in off
authoring. Word 2000 defaults to the highest level for macro secur
This setting prevents the enabling of the RequisitePro offline 
authoring macros. Reset the macro security in Word 2000 to med
on the Security dialog box, which is available by clicking Tools > 
Macro > Security.

Note: Do not rename documents while they are offline. The original file 
name is necessary for recognizing the offline document within 
RequisitePro.

When you bring the document back online, RequisitePro replaces the rea
only document with the modified document. Alternatively, you can elect t
cancel the offline process. In this case, RequisitePro restores the origina
document, removing its read-only state, so all requirements authors and 
members of the Administrators group can again modify it within RequisiteP

Taking Documents Offline
1. To take a document offline, do one of the following:

• In the Word Workplace, click RequisitePro > Document > Offline 
Documents.

• Or, on the Tool Palette, click Document > Offline Documents.

2.  In the Display Types list, select a document type.

3. Click the document you want to take offline. (Use a multiple select act
to select more than one document.)

4. Click Take Offline. The Take Offline Information  dialog box appears:
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5. In the Reason text box, type a reason for taking the document offline.

6. In the Location field, enter the directory path where you want to store t
document. Or, click Browse to locate the directory.

7. Click OK . 

Determining Whether a Document is Offline
To check whether a document is offline:

• Open the Open Project and Documents dialog box:

• On Tool Palette, click Document > Open; or

• In the Word Workplace, click RequisitePro > Document > Open.

• In the Select Documents list, offline documents are followed by the w
“(offline).”

To learn more about an offline document:

• Click the document in the Select Documents list, and then click Offline  
Info .

• The Offline Information  dialog box appears, showing the document 
name, the user who took the document offline, offline date and time, 
location, and reason the document was taken offline.

Modifying Offline Documents
You modify an offline document in the same manner as you would any ot
Microsoft Word document. All Word features and options are available fo
your use when editing a RequisitePro offline document. In addition, you c
add and delete RequisitePro requirements in an offline document.

In order to enable the Word macros that create a RequisitePro menu in th
offline document:

• Check the Tool/Option dialog box and clear the “Save as RTF” check 

• Be sure to save all requirements documents in Word 97 or Word 2000
format.

Note: You must have Microsoft Word 97 or Word 2000 to include the 
RequisitePro macros in the offline document. You can edit the 
document offline using Word 95 or later, but you will not have 
macros for creating and deleting requirements unless you use Wo
97 or Word 2000.
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When you open the offline document in Word, make sure that you enable
Word macros. These macros allows you to add and delete requirements 
offline document.

You can modify requirement text in an offline document. When you bring 
document back online and open it in RequisitePro, RequisitePro prompts
to enter a reason for the changes to the requirement text.

Note: Do not rename documents while they are offline. The original file 
name is necessary for recognizing the offline document within 
RequisitePro.

Creating Requirements in Offline Documents
Mark requirement text in an offline document in the same way you would
the document were online. The RequisitePro macro stylizes the requirem
text with a double underline and notifies you that a requirement was crea
When you bring the document back online, RequisitePro gives the requirem
a number and default attributes. You can then modify the requirement in 
Requirement dialog box.

To mark text as a requirement in an offline document:

(You must have saved the document in Microsoft Word 97 or Word 2000
use this macro.)

1. Highlight the information to define the requirement.

2. Click RequisitePro > Requirement > Create. 

Deleting Requirements in Offline Documents
Delete a requirement in an offline document in the same way you would if
document were online. When you delete a requirement, RequisitePro doe
remove the requirement text from the document, but it is no longer recogn
as a requirement. RequisitePro removes the requirement color and style 
settings and replaces them with the document default style.

When you bring the document back online, RequisitePro notifies you 
regarding the requirements you have deleted, and asks you if you want to
update the online document with the changes. If you decline, RequisitePr
does not bring the document back online.

To delete a requirement in an offline document:

(You must have saved the document in Microsoft Word 97 or Word 2000
use this macro.)
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1. In the offline document, click anywhere in a requirement.

2. Click RequisitePro > Requirement > Delete (Unmark).

3. To undo a delete operation, click Edit > Undo. Click Undo until the 
requirement is completely restored.

In an offline document, you can delete only one requirement at a time

Bringing Offline Documents Back Online
If you are the offline author or an administrator, you can bring an offline 
document back online.

1. Do one of the following:

• In the Word Workplace, click RequisitePro > Document > Offline 
Documents, or

• On the Tool Palette, click Document > Offline Documents.

The Offline Documents dialog box appears:

2. In the Offline documents list, select the document you want to bring b
online. (Use a multiple select action to select more than one documen
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3. Click Bring Online . The Bring Online Information  dialog box appears:

4. In the Description of Changes box, enter a description of the changes m
to the currently selected document while it was offline (if any).

5. If you are bringing multiple documents back online and the changes a
to all subsequent documents, select the Apply to All  check box.
If you do not select the Apply to All check box, the Bring Online 
Information dialog box appears for each subsequent document you b
online in this session, and you must enter changes for each documen
individually. You can select Apply to All for any document you bring 
online in the session to apply the changes to all subsequent documen
For example, if you are bringing back online four documents named Do
Doc2, Doc3, and Doc4, and you do not select Apply to All while enteri
information for Doc1, but you do select Apply to All while entering 
information for Doc2, the Bring Online Information dialog box does no
appear for Doc3 or Doc4.

6. Click OK . 

Note: A Microsoft Word warning message states that the document you
bringing online contains macros. Click the Enable Macros button.

If you have deleted requirements in an offline document, RequisitePr
notifies you how many requirements you have deleted, and asks if yo
want to update the online document with the changes.

7. Click Yes to accept updating the document, or click No to decline updating 
the document.
If you decline updating the document, RequisitePro does not bring th
document back online.
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Bringing Documents Online Without Saving Changes
If you are the offline author or a member of the Administrators group, you 
bring a document back online without saving any changes you made whi
was offline.

1. To open the Offline Documents dialog box, do one of the following:

• In the Word Workplace, click RequisitePro > Document > Offline 
Documents.

• On the Tool Palette, click Document > Offline Documents.

2. In the Offline documents list, select the document you want to bring b
online without saving offline changes to them. (Use a multiple select 
action to select more than one document.)

3. Click Cancel Offline. A message appears, asking you to confirm the 
deletion of the offline changes.

If you are bringing multiple documents back online, this message app
only once for all documents.

4. Select the Remove offline document files check box to delete the offline
documents from the directory in which they were stored. 

5. Click Yes. The online version of the documents are restored.
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Reading Offline Documents
You can read a document that another user has taken offline. RequisiteP
displays the document in read-only mode in the state it was in before the o
user took it offline.

If you are the offline author or a member of the Administrators group, whe
you open the document in RequisitePro, you can choose to bring it back o
or open it in the state it was in before it was taken offline.

1. To open the Open Project and Documents dialog box, do one of the 
following:

• On Tool Palette, click Document > Open; or

• In the Word Workplace, click RequisitePro > Document > Open.

2. Click the offline document in the Select Document(s) list that you wan
open.

3. Click OK . The Offline Document Open dialog box appears, identifying 
the user who took the document offline:

4. Do one of the following:

• If you are the offline author or an administrator, click Bring Online  to 
bring the document back online, or Open Read Only to open it in the 
state is was in before you took it offline.

Note: You cannot access the Bring Online button if you are not the 
offline author or an administrator.

• If another user took the document offline, click Open Read Only to 
open the document for reading.
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Using Word Master Documents
Using master documents in Microsoft Word can be very helpful for viewin
and printing a collection of smaller subdocuments as one document. All 
subdocuments within the master document can be printed with consistent
numbering. Master documents are a feature of Microsoft Word. You shou
not attempt to create, import, or manage master documents from within 
RequisitePro.

Consider the following guidelines when using master documents:

• Archive the project before creating subdocuments. (For information
archiving projects, refer to Archiving Projects on page 14-7.)

• The master document should not be a RequisitePro document; the 
subdocuments can be RequisitePro documents. This prevents redu
requirements and broken traceability links.

• Do not edit requirement text in the subdocuments outside of 
RequisitePro.

• Do not edit the subdocuments in RequisitePro while viewing the ma
document in Microsoft Word. 

To prepare RequisitePro documents to be used as subdocuments, save t
Word format:

1. On the Tool Palette, click Project > Properties. 

2. On the General tab of the Project dialog box, clear the check box Save 
documents in Requisite format.

Note: This removes all project security from these requirements docume
and they can be modified outside RequisitePro, so only clear this 
check box when you are preparing subdocuments for viewing or 
printing from a Microsoft Word master document. 

3. Open and save the documents in the project that you want to use as 
subdocuments. 

Important:  After viewing and printing the master document in Microsoft 
Word, open the Project dialog box again and select the check box Save 
documents in Requisite format. Open the subdocuments and save them. T
reestablishes project security for those documents.

For more information on using master and subdocuments, refer to the 
Microsoft Word documentation. 
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Requirements

A requirement is a condition or capability to which your project must confor
Requirements are written to be meaningful to the user of the system. Eac
requirement includes visible behavior and benefit. In RequisitePro, 
requirements are located in a requirements document or directly in the 
database. The Word Workplace is used to define requirements and the V
Workplace is used to analyze them.

If a requirement is located in a document, the requirement text can be modified 
in the document only. The requirement’s attributes and relationships can be
modified in both the Views and Word Workplaces. Reviewers can read th
information in context and add information that supports and justifies the 
requirements.

When a requirement is created in a document, RequisitePro places hidde
at the beginning of the description to hold the requirement’s tag. This hidden 
text is underlined with a dotted line. If information is typed in this tag area
is formatted as hidden text and is visible only when Word’s Hidden Text 
feature is turned on. To reformat the text to normal, use Word’s Format > Font 
feature. The text of the requirement should be in normal text only.

Creating Requirements

All requirements that are created in RequisitePro are stored in the projec
database. Once created, a requirement can be modified, moved and cop
within the project and traced to and from other requirements in the same pr
or across projects. 
8-1



Requirements

tion 

, the 

e 

 

e 

ased 
(For 

ct 

n the 

e 
d 
When a requirement is created, RequisitePro stores the following informa
in the database.

• The requirement’s description. In a document, this may include any 
combination of text, graphics, or OLE objects. In the project database
requirement description is limited to text. 

• Attribute values. 

Creating a Requirement in a Document
When you create a requirement in a document, RequisitePro performs th
following operations:

• The selected information is bracketed with bookmarks.

• The following information is associated with the new requirement:

• Requirement tag identifier. A requirement tag is comprised of a prefix
and a number

• Color and style format. If the requirement type has color and style, th
new requirement is formatted with these settings.

• Requirement attributes. The new requirement is associated with the 
attributes established for the requirement type.

• For hierarchical relationships, the requirement is assigned a parent b
on the parent you select in the Requirement dialog box, Hierarchy tab. 
more information on parent-child relationships, refer to Hierarchical 
Relationships on page 9-1.)

Note: The requirement and its attribute values are not saved to the proje
database until you save the document.

To create a requirement in a document:

1. Open a requirements document and type the text of the requirement i
document. 

2. Highlight the information (text, graphics, OLE objects) that will becom
part of the requirement. (If you don’t highlight text, you will be prompte
to enter text for the requirement.)

3. Do one of the following:

• Click RequisitePro > Requirement > Create in the Word Workplace.

• Click Requirement > Create on the Tool Palette.

• Right-click and select Create Requirement from the shortcut menu.
8-2



Creating Requirements

 

s a 

yle 
ress 
 

• Or, click the Create requirement button on the Tool Palette.

The Requirement dialog box appears:

4. Click the down arrow in the Type field and select a requirement type with
which to associate the requirement. The Tag text at the beginning of the 
requirement text automatically includes the Pending tag. 

5. Click OK .

6. To save your changes, click RequisitePro > Document > Save in the 
Word Workplace or Document > Save on the Tool Palette.
RequisitePro saves the document, updates the database, and assign
requirement number to the requirement (in place of the Pending tag).

Note: If you press Enter after a marked requirement, the requirement st
(such as double underline) and color are carried to the next line. P
Ctrl and the Spacebar before typing, and the Word style is reset to
Normal.

Using Fast Create

Use RequisitePro’s Fast Create feature to create a requirement without 
opening the Requirement dialog box. 

1. Highlight the text in the document that will become the requirement.
(If you don’t highlight text, the Requirement dialog box opens. Refer to 
To create a requirement in a document: on page 8-2.)

2. Press the Shift key and click the Create a requirement button on the Tool 
Palette. 
RequisitePro bypasses the Requirement dialog box and creates the 
requirement based on the default requirement type chosen for the 
requirements document.
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Creating Multiple Requirements 

Use the Block Create command to simultaneously create multiple 
requirements in a document. This feature allows you to select a block of 
that contains many requirements and automatically generate RequisitePr
requirements from that text. The Block Create command creates root 
requirements only.

RequisitePro uses three methods to distinguish individual requirements in
highlighted block of text:

• Key words – RequisitePro searches for a specific word, such as “shall” (
default), or any word you specify. 

• Text delimiters – RequisitePro searches for text contained within speci
text delimiters, such as < >, { }, [ ], BEGINREQ ENDREQ. You can designate 
text to become a requirement by surrounding the text with any delimit
you choose. We recommend you use a different character on each e
the text, such as open and close brackets [ ]. 

• Word style – RequisitePro searches the text for specified style settings
such as “Heading 1” or “Body text” or highlighted text. The styles in yo
current document template are loaded into the Styles box.

To create multiple requirements from a block of text:

1. Create or open a requirements document and type the text of the 
requirements. 

2. Highlight the information (text, graphics, OLE objects) that will becom
requirements. 

3. On the Tool Palette, click Requirement > Block Create.
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The Requirement Block Create dialog box appears:

4. Click the down arrow at the Requirement Type field and select a 
requirement type with which to associate the block of requirements. 

5. Click the Set Defaults button to open the Set Requirement Defaults dial
box, where you can enter default attributes, hierarchy, traceability and
change description for the requirements you create.

6. Click on one of the following options to indicate a method of 
distinguishing each requirement in the block of text:

• Keywords – Type keywords in the Keywords field and click Add to add 
the keywords to the requirements criteria field. To make the keywor
case sensitive, click the Case sensitive check box. 

• Text delimiters – Type a beginning and end delimiter in the indicate
field and click Add.

• Word styles – Select a style from the styles list and click Add.

Note: The dialog box changes to include specific options for each of 
above choices.
You can use more than one criteria to differentiate the individu
requirements. Add keywords, text delimiters, and Word styles 
the search list by clicking each button in turn. Keep in mind th
RequisitePro searches the document in the order listed above
keywords first, text delimiters second and word styles last.

7. Select a source, sentence or paragraph, from which RequisitePro will 
search for keywords to differentiate the requirements.
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8. When you have finished adding requirements criteria, click Create.

RequisitePro checks the highlighted text for the selected criteria and 
reports any text that matches your criteria in the Requirement Found 
dialog box: 

• Click Yes to accept the proposed requirement.

• Click No to reject the proposed requirement.

• Click Yes to All to accept all proposed requirements.

9. When all proposed requirements have been reviewed, the Status dialog 
box appears.

10. Click Close.
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Troubleshooting While Creating Requirements

If you experience problems while creating requirements in a project docum
check for the following conditions to identify and solve the problem:

• Verify the document is not locked.
In the Word Workplace, click RequisitePro > Document > Lock.
Or, on the Tool Palette, click Document > Lock. If a check mark appears
to the left of the Lock menu item, select Lock to remove the mark.

• Verify the highlighted selection does not contain hidden text at the 
beginning or the end of the selection. Because RequisitePro uses hidden
text to delineate requirements, it prevents the creation of a requireme
with hidden text at its beginning or end.

• Verify the highlighted selection is not inside or overlapping another 
requirement. Requirements cannot be nested or overlap one another.

Creating a Requirement in the Database
Requirements located in the database can be created, viewed, and modif
the Views Workplace. These requirements can only be created in an Attri
Matrix and Traceability Tree and cannot include graphical images and OL
objects.

When you create a requirement in the database, RequisitePro performs t
following operations:

• The following information is associated with the new requirement:

• Requirement tag identifier. A requirement tag is composed of a prefix
and a number.

• Requirement attributes. The new requirement is associated with the 
attributes established for the requirement type.

• Using the Requirement > Create command in a view creates a 
requirement at the root level (it has no parent). To create child or sibl
requirements, refer to Creating Child Requirements in the Database on 
page 9-2 and Creating Peer Requirements on page 9-3.
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To create a requirement in a database:

1. On the Tool Palette, click Window > Show Views
(or the Go to views workplace button).

2. In the Views workplace, click File > New View. 

3. Select the Attribute Matrix or Traceability Tree view type and a 
requirement type. 

4. Click OK . The view appears.

5. In the Views workplace, click Requirement > Create.

The Requirement dialog box appears: 

RequisitePro populates the Type and Location fields:

• The new requirement inherits the requirement type displayed in the
view. Select another requirement type from the Type list to change the 
requirement’s type.

• The Location text box indicates the requirement is located in the 
database only and not a document. 

6. Type the new requirement in the Text box.

RequisitePro creates a requirement tag based on the requirement typ
prefix. A sequential number is assigned to the requirement based on 
numbering scheme assigned to that requirement type.
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Revising Requirements

Use the Requirement dialog box to view or modify requirement information
including attribute values, traceability relationships, hierarchical relationsh
discussions, and change descriptions. (For more information, refer to Cha
6: Discussions, Chapter 9: Hierarchical Relationships, and Chapter 10: 
Traceability Relationships.)

To modify the description of a requirement located in a document, the 
operation must be performed in the document. Requirement attribute valu
and traceability relationships can be modified in the Views Workplace. Ev
if a requirement resides in a requirements document, its attributes and 
traceability relationships can be modified in the Word Workplace as well.

Opening the Requirement Dialog Box
From a requirements document:

1. Place the cursor inside the text of the requirement.

2. Do one of the following to open the Requirement dialog box:

• In the Word Workplace, click RequisitePro > Requirement > 
Properties. 

• Right-click and select Requirement Properties from the shortcut menu.

• On the Tool Palette, click Requirement > Properties. 

• Or, click the Display properties button on the Tool Palette. 

From an Attribute Matrix:

1. Click the requirement to highlight it.

2. Do one of the following to open the Requirement dialog box:

• In the Views Workplace, click Requirement > Properties. 

• Or, click the Display properties button on the Views Workplace 
toolbar.
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Accessing Revision Information
Use the Revision tab in the Requirement dialog box to record and monitor 
revision information about the requirement. 

• RequisitePro automatically generates an internal revision number fo
requirement in the Revision text box whenever a requirement is 
modified and saved. This text box is read-only.

• If a change has been made, click the Label text box to associate a logica
name with a revision number. This step is optional. Any specific revis
can be named in this text box, using any combination of 20 alpha-
numeric characters, such as Beta Release. The label is added to the 
requirement’s change history. Once applied, it cannot be changed o
removed.

• Use the Change Description text box to record changes made to a 
requirement. This text box can contain up to 2,048 characters. 
This step is optional. 

• The Date, Time, and Author text boxes are populated by RequisitePr
and cannot be modified.

• Click the History  button to display the requirement’s change history.

• Any modifications made to requirements are pending until the docum
is saved. When a requirement is committed to the database, its sta 
changes from Proposed changes... to Last Saved. 
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Recording Changes to Document-Based Requirements
When you modify a requirement’s text, you must describe the reason for 
change. 

After you have modified the requirement’s text, make sure the cursor is st
the requirement and then do the following:

1. To open the Change Description dialog box, do one of the following:

• In the Word Workplace, click RequisitePro > Requirement > 
Annotate Change.

• On the Tool Palette, click Requirement > Annotate Change.

2. Type the reason for changes.

3. Click OK . 

If you attempt to close a document that contains requirement changes wit
annotating the changes, RequisitePro displays the Change Description dialog 
box, scrolls to the requirement, and prompts you to record a rationale for
change. 
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Modifying Attribute Values

Attributes and their corresponding list of default values are defined by the
requirement type of the requirement. Use the Attributes  tab in the 
Requirement dialog box to assign values to the attributes for a requireme

1. Open the Requirement dialog box by following one of the options on pag
8-9.

2. Click the Attributes  tab. The attributes for the requirement are display

3. Enter attribute values: 

• For list-type attributes, select a value in the list.

• For entry-type attributes, enter a value in the text box.

Note: To move between fields, use the scroll bar or the Tab key.

4. Click OK .

Modifying Attribute Values from the Attribute Matrix
You can use shortcuts for changing attribute values in the Views Workpla

1. In an Attribute Matrix , do one of the following:

• double-click an attribute value; or

• click the attribute value, and then press the space bar.

2. Enter attribute values: 

• For list-type attributes, select a value in the list.

• For entry-type attributes, enter a value in the text box.
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Note: Press Esc to deselect the attribute value cell and cancel the 
modification process.

3. To accept the new value, click outside the cell or press Enter.

Note: You can also use a multiple select action in an Attribute Matrix to 
select more than one attribute value. Click Requirement > Set 
Attribute Value,  or right-click, and choose Set Attribute Value 
from the shortcut menu. The Set Attribute Value dialog box appears, 
allowing you to enter a value for all selected requirements.
If you want to change the attribute values in an entire column, righ
click the attribute label and select Set Attribute Value from the 
shortcut menu.

Associating Requirements with New Types

When you change a requirement’s type, several things can happen:

• Any attribute values associated with the requirement will be changed to
default attribute values of the new requirement type. 

• If the requirement is a parent, the requirement type is also changed fo
of its child requirements.

• If the requirement is a child, the requirement is moved to the root for 
new requirement type, and the requirement no longer has a parent.

For more information on parent and child requirements, see Chapter 9, 
Hierarchical Relationships.

Note: If you are changing requirement type in the Views Workplace, and
any of the requirements you want to change are document-based
document must be opened in RequisitePro before you begin eithe
the following two procedures.

Associating a Single Requirement with a New Type
1. Open the Requirement dialog box by following one of the options on pag

8-9.

2. Click the General tab.

3. Click the down arrow in the Types field and select a new requirement typ
8-13
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A dialog box appears, explaining the change process.

4. Click Yes. The requirement type is changed in the Requirement dialog
box.

5. Click OK .

Associating Multiple Requirements with a New Type
When you change the requirement type, several things can happen:

• Any attribute values associated with the requirements will be changed
the default attribute values of the new requirement type.

• If the requirements are parents, the requirement type is also changed f
of their child requirements.

• If the requirement are children, they are moved to the root for the new
requirement type, and the requirements no longer have a parent.

Note: Resetting attribute values is a separate procedure after you chang
requirement type and save the document.

1. In the Views Workplace, open an Attribute Matrix and use a multiple 
select action to select multiple requirements.
If any of the requirements you want to change are document-based, t
document must be opened in RequisitePro before you begin the follow
procedure.

2. Click Requirement > Change Type.
A dialog box appears, explaining the change process.
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3. Click Yes. The Change Requirement Type dialog box appears.

4. In the New Requirement Type list, click the down arrow and select a new
requirement type.

5. Click OK .

The requirements and their children are removed from the Attribute Matri
When you display a matrix of the new requirement type, the requirements
their children are added at the end of the matrix by default. 
For document-based requirements, you must save the open document to
commit requirements to the database.

Relocating Requirements

You can move or copy requirements within the same requirements docum
between documents, and between a document and the database. Require
are moved by using RequisitePro’s Cut, Copy, and Paste commands. Do not 
use the Microsoft Word Cut, Copy, and Paste commands to move 
requirements.

Note: The Cut/Paste commands move the original requirements. The 
Copy/Paste commands create new requirements. If pasted in a 
document, new pending requirements are inserted. If pasted in a 
database, new requirements are created in the database.

Cutting or Copying from a Document 
To cut or copy from a requirements document:

1. Place the cursor in a requirement. 

2. Click Requirement on the Tool Palette, or on the RequisitePro menu in 
the Word Workplace, and click Cut or Copy.
RequisitePro cuts or copies the requirement (and its child requiremen
from the requirements document.

Pasting the requirement in a document:

You can move or copy the requirement to a new position in the current 
document or to another requirements document.
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1. Open or click the destination document and place your cursor in the 
location where you want to paste the requirement.

2. On the Tool Palette, click Requirement > Paste.
RequisitePro inserts the requirement (and its child requirements) in th
specified location.

Pasting a cut requirement into the database:

You may want to remove a requirement from a document and locate it on
the database. You can paste a requirement into an Attribute Matrix view if
based on the same requirement type as the cut requirement. A requirem
cannot be pasted into a Traceability Matrix or a Traceability Tree view. 

1. Open or create an Attribute Matrix view based on the same requirem
type as the cut requirement.

2. In the Views Workplace, click Requirement > Paste. 
RequisitePro pastes the requirements into the database.

Cutting or Copying in a View
In order to move a database-only requirement to a document, you can cu
from an Attribute Matrix and paste it into a requirements document.

• Use the RequisitePro Cut command to convert a database-only 
requirement into a document-based requirement.

• Use the RequisitePro Copy command to make a copy of a database 
requirement and paste it into a document. This option creates a new 
requirement when you save the requirements document. Copying a 
requirement duplicates its text and its attributes, but not its traceabilit
relationships. 

Note: For hierarchical requirements, RequisitePro copies the 
requirement as a peer requirement at the same level in the pa
child hierarchy. (For more information, see Hierarchical 
Relationships on page 9-1).

To cut or copy a requirement from the database:

1. In the Views Workplace, open an Attribute Matrix containing the 
requirement.

2. Select a requirement (must be a database-based requirement).
(Use a multiple select action to select multiple requirements.)

3. Click Requirement > Cut or Requirement > Copy.
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To paste the requirement into a requirements document:

1. Open the requirements document and click the location to paste the 
requirement.

2. In the Word Workplace, click RequisitePro > Requirement > Paste. Or, 
on the Tool Palette, click Requirement > Paste.
RequisitePro inserts the requirement (and its child requirements) in th
specified location.

Rules for Relocating Requirements
Consider the following rules when moving requirements using the 
RequisitePro Cut, Copy, and Paste commands:

1 If you cut a requirement from a document and do not paste it into the database
removed from both the document and the database when you save the docume
2 For parent-child requirement hierarchies: When pasting from a document to th
same document, you can only cut and paste a root requirement or a leaf (the low
level child requirement). When pasting from a document to a different document,
can move a root requirement and all its children. For more information about par

Requirement 
Location

Function
Requirement Destination

Paste to Database Paste to Document

Document Cut Relocates the 
requirement to be a 
database-only 
requirement.1

Relocates the 
requirement in the 
document.2

Copy Creates a new 
database-only 
requirement.

Creates a new 
document-based 
requirement.

Database Cut Not Applicable Relocates the 
requirement to be 
document-based.3

Copy Creates a new 
database-only 
requirement.

Creates a new 
document-based 
requirement.3
8-17
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child requirements, refer to Hierarchical Relationships on page 9-1.
3 For parent-child requirement hierarchies: When pasting from the database to a
document, you can only move a root requirement. For more information about pa
child requirements, refer to Hierarchical Relationships on page 9-1.

• Do not use Word’s Cut/Paste commands. We recommend you do not use
Word’s Cut command to cut requirement text for two reasons. The risk
not capturing the entire requirement (including its bookmarks and tag) 
accidentally deleting the requirement from the project database is gre
in Word. In addition, a document-based requirement cannot be moved
the project database with Word’s Cut command.

• Using the buffer with the RequisitePro Cut command. Requirements you 
cut using RequisitePro’s Cut command go into a proprietary cut buffer. 
You should paste a requirement to its new location before cutting or 
copying another requirement. If requirements are in the buffer and you
or copy another requirement, the first requirements are placed back in 
original location in the database. If you want to cut or copy multiple 
requirements, you can do so in the Attribute Matrix only.

Note: The buffer used in RequisitePro is not the Windows Clipboard
Any information currently on the Windows Clipboard is 
preserved when you cut or copy a requirement in RequisitePr

• Avoid losing OLE objects. If you move a requirement that includes an OL
object from a requirements document into the project database, the O
object is lost. RequisitePro does not currently support OLE objects in
database. Because the loss of the object is considered a change to th
requirement description, the requirement’s direct traceability relationsh
become suspect.

Refreshing Requirement Color and Style in a 
Document

A specific color and style distinguishes requirements that belong to a spe
requirement type. For example, you might mark all requirements that belo
to the requirement type feature with a dark green requirement color and a 
double underline style. This helps you easily recognize all feature 
requirements regardless of their location. Refreshing the color and styles
requirements is useful for restoring requirements to their proper state wh
their color and style have been overwritten.
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To refresh requirement color and style in a requirements document:

1. Highlight the requirements to refresh. 

2. Do one of the following:

• In the Word Workplace, click RequisitePro > Document > Refresh 
Requirements.

• On the Tool Palette, click Document > Refresh Requirements.

RequisitePro checks the color and style settings of the requirements i
document and, if necessary, resets them to the proper settings for the
requirement type. 

Note: To remove color and styling and convert the requirement back to 
plain text, see Unmarking Requirements in a Document on page 8-21.

Rebuilding Requirement Tags in a Document

When a requirement is created in a document, the requirement informatio
bracketed by bookmarks and assigned a requirement tag. Mark the Show Tags 
check box in the Document dialog box to ensure that the requirement tags a
visible both on your display and in the printed document.

Tags can be accidentally corrupted or deleted while editing a requiremen
document. Use the Rebuild Tags command to rebuild a requirement tag tha
is partially or completely deleted or corrupted. RequisitePro rebuilds the 
affected tags, then provides a list of rebuilt requirement tags.

To rebuild requirement tags in a document:

1. Highlight the requirement tags to rebuild. 

2. Do one of the following

• In the Word Workplace, click RequisitePro > Document > Rebuild 
Tags.

• On the Tool Palette, click Document > Rebuild Tags.

RequisitePro rebuilds the requirement’s tags.

Renumbering Requirements

Use the Renumber Requirements command to renumber all requirements o
a specified type in a project. This feature is useful to eliminate the “holes” 
numbering scheme that result when you delete or move requirements. Yo
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renumber one or several requirement types in one operation. Requiremen
renumbered in the database and in requirements documents. You can se
which requirement type you want to renumber and the order in which you w
the documents processed (Document-based requirements are renumber
the order in which they appear in the document).

The project must be opened in exclusive mode to use this command. If sec
is enabled, you must have project structure permission to renumber 
requirements.

Caution: Using the Track changes while editing command directly from 
Microsoft Word, and then renumbering requirements, will damage your 
document beyond repair. If you use RequisitePro's Document > Protect for 
Revisions command, RequisitePro will turn off the Track changes while 
editing option before renumbering and turn it back on once the renumber
operation is complete. RequisitePro's Protect for Revisions command will
damage your document. For more information, refer to Protecting Documents 
for Revisions on page 14-2.

To renumber all requirements in a project:

1. On the Tool Palette, click Project > Renumber Requirements.

The Renumber Requirements dialog box appears:

2. In the Requirement Type list, select the requirement type that you wan
to renumber. 
8-20



Deleting Requirements

,

t 

n 
em 

chive 
lated 

ly be 
ol. 
ment 
 

in 
 to/

e.
3. Click the Renumber Requirements of this type check box to mark the 
type. 

Note: To renumber requirements of more than one requirement type
repeat steps 2 and 3.

4. In the Initial Requirement Number text box, enter the initial requiremen
number that you want to set. The default number is 1.

5. To change the order of renumbering for database requirements and 
documents, select Database or a document name. Click the Move Up and 
Move Down buttons to put the database and documents in the order i
which you want them to be processed. The requirements in the first it
listed (the database or a document) are renumbered first, followed 
sequentially by the requirements in the second item, and so on. 

Note: A document appears in the Order of Processing list only if it 
contains requirements of the selected type. 

6. Click OK .

Deleting Requirements

In general, we recommend against deleting any requirements after you ar
a project, since deleting a requirement deletes the complete information re
to that requirement including its history.

RequisitePro does provide a Delete Requirement function that should on
used prior to archiving a project, when you are getting familiar with the to
Once the project is archived, if a requirement is to be deleted, use a require
attribute (for instance: Deactivated, Retired, or Inactive) to indicate that a
requirement is no longer valid.

When you delete a requirement that is linked to requirements that reside 
other projects, the other projects are updated to remove the relationships
from the deleted requirement.

Note: Deleting a requirement causes its history and traceability 
relationships to be permanently removed from the project databas

Unmarking Requirements in a Document
You have the option of leaving the text in a document when you delete a 
document-based requirement:
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• Use the Delete (Unmark) or Block Delete (Unmark) command to dele
document-based requirements from the document where they reside
from the project database without disrupting the text of the document. 
requirement text, graphics, or OLE objects are not removed from the 
document, but they are no longer recognized as a requirement. The c
and style settings of the requirement are removed and replaced with 
document default style. 

• The Delete (Remove) command deletes the requirement text from the
requirements document, as well as removing it from the database. 

To unmark a document-based requirement:

1. In the requirements document, click in the requirement text or highligh
contiguous block of requirements.

2. Do one of the following:

• In the Word Workplace, click RequisitePro > Requirement > Delete 
(Unmark) .

• On the Tool Palette, click Requirement > Delete (Unmark).

Note: To delete multiple requirements, use the Block Delete (Unmark) 
command.

A message appears, asking you to confirm the deletion.

3. Click Yes. The RequisitePro formatting is removed and the requireme
text is converted to the default text style.

Note: If you do a Block Delete of a parent requirement with child 
requirements, the Delete Requirement dialog box appears, as
what you want to do with the remaining child requirements. If 
you click Cancel, then it cancels the entire Block Delete proce

4. To save your changes, do one of the following:

• In the Word Workplace, click RequisitePro > Document > Save. 

• On the Tool Palette, click Document > Save. 

The requirement is removed from the database.

Note: To undo an unmark operation, use the Edit/Undo option in Word 
repeatedly until the styling, bookmarks and tags reappear.
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Deleting Requirements from the Database
You can delete a requirement from the database in the Views Workplace
provided the requirement is a database-only requirement. (Check the Loc
attribute in an Attribute Matrix; database-only requirements have a locatio
“Database”; document-based requirements display the file name of the 
requirements document.)

When you delete a requirement that is linked to requirements that reside 
other projects, the other projects are updated to remove the relationships
from the deleted requirement.

Unlike cut requirements, which are placed into a buffer for pasting within 
RequisitePro, a deleted requirement is completely removed from the data

Note: Deleting a requirement causes its history and traceability 
relationships to be permanently removed from the project databas

1. In the Views Workplace, open the Attribute Matrix containing the 
requirement.

2. Select the requirement in the matrix. (Use a multiple select action to se
more than one requirement.)

3. Click Requirement > Delete.
A message appears, asking you to confirm the deletion.

4. Click Yes.
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Hierarchical Relationships

Hierarchical requirement relationships are parent-child relationships that 
reflect direct dependencies between requirements. In addition, these 
associations provide powerful tools for change management. With hierarch
requirements, you can support a requirement with a number of sub-
requirements by establishing a parent requirement and creating child 
requirements of that parent. 

Like traceability relationships (see Traceability Relationships on page 10-1), 
hierarchical relationships are a type of change-managed relationship in 
RequisitePro. If a requirement is changed, the relationships with its childr
become suspect. You can view and manage suspect relationships using a 
Traceability Matrix or a Traceability Tree in the Views Workplace.

Creating Child Requirements

A child requirement is any requirement that has a parent. Hierarchical 
relationships are created in a requirements document or in the database. P
and children must reside in the same location, either as database-only 
requirements or in the same document. The parent requirement and all o
children must be of the same requirement type.

These relationships are created using the Hierarchy  tab in the Requirement 
dialog box or directly in a requirements document using the RequisitePro > 
Requirement menu commands in the Word Workplace.
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Creating Child Requirements in the Database
1. In the Views Workplace, open the Attribute Matrix or Traceability Tree

containing the requirement that you intend to be a parent.

2. Click the requirement. (You can only create a child for one requiremen
a time.)

3. Click Requirement > Create Child.

Note: You can create a child in the database only if the currently 
selected requirement (which will become the child's parent) is
database-only requirement.

The Requirement dialog box appears.

4. Click the following tabs to define the child requirement, and enter the
appropriate information:

• General

• Revision

• Attributes

• Traceability

• Hierarchy

• Discussions

5. Click the Hierarchy  tab. The parent requirement is pre-defined as the 
requirement you selected in step 2. (If you want to, you can change th
parent.)

6. Click OK.

RequisitePro creates the child requirement in the database. RequisitePro
generates a requirement tag for the child requirement based on the paren
requirement’s number.

Note: After creating child requirements, review saved views to make su
both child and parent requirements are displayed. You can modify
query on a saved view and mark the Retain Hierarchical Display 
check box to include hierarchical requirements in the view. Then s
the view again to keep those changes. Refer to Modifying Queries on 
page 5-5.
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Creating Child Requirements in a Document
You can create child requirements in a requirements document by assign
parent. The assignment is committed to the database when the documen
saved.

1. In a requirements document, highlight the requirement that you inten
be a child requirement. 

2. To open the Requirement dialog box, do one of the following:

• In the Word Workplace, click RequisitePro > Requirement > 
Properties.

• On the Tool Palette, click Requirement > Properties.

• On the Tool Palette, click the Display the properties... button.

3. Click the Hierarchy  tab.

4. Select a parent from the Parent list box.

Note: The default is the last parent selected in the document.

5. Click OK . 

The requirement changes to a pending child requirement of the paren
selected. 

Note: To save the new parent-child relationship in the database, click 
Document > Save on the Tool Palette or on the RequisitePro menu
the Word Workplace. RequisitePro generates a requirement tag fo
the child requirement based on the parent requirement’s number.

Note: After creating child requirements, review saved views to make su
both child and parent requirements are displayed. You can modify
query on a saved view and mark the Retain Hierarchical Display 
check box to include hierarchical requirements in the view. Then s
the view again to keep those changes. Refer to Modifying Queries on 
page 5-5.

Creating Peer Requirements

Requirements have a peer relationship when they are at the same level i
requirement hierarchy. For example, two requirements are peer requirem
when they are children of the same parent. All requirements at the root le
are peer requirements of one another.
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When a requirement is created in a document, it is automatically placed a
same level as the requirement above it. Refer to Creating a Requirement in a 
Document on page 8-2. To create peer requirements in a view, refer to the
following section.

Creating Sibling Requirements in the Views Workplace
In the Views Workplace (an Attribute Matrix or a Traceability Tree), the 
automatic creation of a requirement is at the root level. Refer to Creating a 
Requirement in the Database on page 8-7. To create a peer requirement of 
requirement that has a parent, use the Create Sibling command.

To create a sibling requirement:

1. In the Views Workplace, open the Attribute Matrix or Traceability Tree
containing the requirement that you intend to be a sibling.

2. Click the requirement. (You can only create a sibling for one requirem
at a time.)

3. Click Requirement > Create Sibling.

Note: You can create a sibling in the view only if the parent of the 
siblings is a database-only requirement.

The Requirement dialog box appears.

4. Click the following tabs to define the child requirement, and enter the
appropriate information:

• General

• Revision

• Attributes

• Traceability

• Hierarchy

• Discussions

5. Click the Hierarchy  tab. The parent requirement is pre-defined as the 
parent of the sibling requirement you selected in step 2. (If you want t
you can change the parent.)

6. Click OK.

RequisitePro creates the sibling requirement in the database. RequisiteP
generates a requirement tag for the new requirement based on the paren
requirement’s number.
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Changing Parent Requirements

In a requirements document or an Attribute Matrix or Traceability Tree, yo
can assign single or multiple hierarchical requirements to a different pare
When you assign a requirement to a new parent, its entire sub-tree of chi
is also moved to that parent.

When children are assigned to a different parent, all hierarchical relations
between the new parent and its immediate children are marked suspect. 
relationships between the children and their children are not marked as sus
(See also Suspect Relationships on page 10-9.)

Note: After creating new child requirements, review saved views to mak
sure both child and parent requirements are displayed. You can 
modify the query on a saved view and mark the Retain Hierarchical 
Display check box to include hierarchical requirements in the view
Then save the view again to keep those changes. Refer to Modifying 
Queries on page 5-5.

Assigning a New Parent to a Single Requirement
You can reassociate a hierarchical requirement with a new parent of the 
requirement type using the Hierarchy  tab in the Requirement dialog box.

Note: To change parents of document-based requirements in the Views
Workplace, the document must be opened (and you must have th
ability to edit it) before you begin the following procedure.

To assign a new parent:

1. Do one of the following:

• In the Word Workplace, click anywhere in the requirement text. Clic
RequisitePro > Requirement > Properties. 

• In the Word Workplace, click anywhere in the requirement text. On 
Tool Palette, click Requirement > Properties. 

• In the Views Workplace, open a view and select the requirement. F
the Views Workplace toolbar, click Requirement > Properties.

The Requirement dialog box appears.
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2. Click the Hierarchy  tab.

3. Select a parent from the Parent list.

4. If the parent is not displayed in the list, select <choose parent...>. 

The Parent Requirement Browser dialog box appears: 

5. Select a parent requirement from the list. To locate a specific requirem
click the Find button. 

6. After selecting the parent requirement, click OK .

7. In the Requirement dialog box, click OK .

The requirement changes to a child requirement of the parent you sele
New requirement tags are generated for the child requirement and its
tree of children, based on the new parent requirement’s number. 
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Note: For document-based requirements, you must save the open docu
to commit requirements to the database.

Assigning a New Parent to Multiple Requirements
In an Attribute Matrix, you can reassociate more than one hierarchical 
requirement with a new parent of the same requirement type. All selected
requirements are assigned to the same new parent.

Note: If any of the requirements you want to change are document-based
document must be opened (and you must have the ability to edit it) before
begin the following procedure.

To assign a new parent to more than one requirement:

1. In the Views Workplace, open an Attribute Matrix and then select the 
requirements.

2. Click Requirement > Change Parent.
The Select New Parent dialog box appears:

3. In the New Parent list, select a parent.

4. If the parent is not displayed in the list, select <choose parent...>. The 
Parent Requirement Browser dialog box appears, as shown on the 
previous page. 

5. Select a parent requirement from the list. To locate a specific requirem
click the Find button. 

6. After selecting the parent requirement, click OK .

7. In the Select New Parent dialog box, click OK .

The requirements become child requirements of the parent you chose
new requirement tag is generated for the child requirements and their
trees of children, based on the new parent requirement’s number. 

Note: For document-based requirements, you must save the open 
document to commit requirements to the database.
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Deleting Hierarchical Requirements

In general, we recommend against deleting any requirements after you ar
a project, since deleting a requirement deletes the complete information re
to that requirement including its history (Refer to Deleting Requirements on 
page 8-21).

To delete document-based requirements, go to the Word Workplace. To d
requirements that are located only in the database, go to an Attribute Matr
the Views Workplace.

When you delete a requirement that is traced to/from requirements that reside
in other projects, the other projects are updated to remove the relationsh

Unlike cut requirements, which are placed into a buffer for pasting within 
RequisitePro, a deleted requirement is completely removed from the data

To delete a hierarchical requirement:

1. Do one of the following:

• In the View Workplace, open the Attribute Matrix and click the 
requirement to delete. (Use a multiple select action to select multipl
requirements.) Click Requirement > Delete.

• In the Word Workplace, open the document and highlight the 
requirement to delete.
Click RequisitePro > Requirement > Delete (Remove), or 
On the Tool Palette, click Requirement > Delete (Remove).

A dialog box appears, asking you to confirm the deletion.

2. Click Yes to delete the requirement.

If the requirement has children, the Delete Requirement dialog box 
appears:
9-8



Suspect Relationships

, 

lity 

all 
 
d its 

 

tion 

lear 

t. 

e 
ild’s 

the 
ect. 
ked 
Note: If you are deleting multiple requirements in the Attribute Matrix
the Delete Requirement dialog appears for each parent 
requirement.

3. Do one of the following:

• Select the Delete all child requirements recursively option to delete 
the requirement and all its children. This option removes all traceabi
and hierarchical relationships.

• Or, select the Assign all child requirements to a new parent option to 
delete the requirement and save its children. This option reassigns 
children to a new parent you select in the list. When the children are
reassigned, all hierarchical relationships between the new parent an
immediate children are marked suspect.

4. When you have made your selection, click OK . 

If you are working in the Views Workplace, the requirement is deleted
immediately when you click the Delete button. If you are working in the 
Word Workplace, save the requirements document to commit the dele
to the database.

Suspect Relationships

A relationship between requirements becomes questionable or suspect if 
RequisitePro detects a requirement has been modified. In the Views 
Workplace, you can manually mark a hierarchical relationship suspect or c
a suspect relationship.

• When you modify a parent requirement, RequisitePro marks the 
relationship between the parent and all its immediate children suspec

• When you modify a child requirement, RequisitePro does not mark th
relationship between the child and its parent suspect, although the ch
relationship with other requirements is marked suspect.

• When children are reparented, all hierarchical relationships between 
new parent and its immediate children are automatically marked susp
The relationships between the children and their children are not mar
as suspect.
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Displaying Suspect Hierarchical Relationships
You can display suspect hierarchical relationships using the Traceability 
Matrix and the Traceability Tree views. In the Views Workplace, the susp
relationship is identified by a red diagonal line through the requirement ic

Auto Suspect

The Auto Suspect command monitors a requirement’s change history an
displays a suspect signal when requirements are changed. Use the Project > 
Auto Suspect command to enable or disable automatic checking for chan
that affect the traceability or hierarchical relationships between requireme
in the project.

If Auto Suspect is disabled, RequisitePro does not monitor changes in 
requirements, and does not mark relationships as suspect. There are tim
when this mode is desirable. For example, when you are revising spelling
mistakes in your documents and do not want those revisions to cause yo
relationships to become suspect, you can disable Auto Suspect.

With Auto Suspect enabled, RequisitePro constantly monitors requireme
for changes that may affect traceability or hierarchical relationships. If ther
a change in a requirement, the state of the requirement’s relationships is
automatically changed to suspect. If you have cross-project traceability ac
requirements in external projects are also monitored.

Auto Suspect is enabled by default. If you disable Auto Suspect, it is 
automatically re-enabled the next time the project is opened. Or, enable it
the Project > Auto Suspect command.

Clearing Suspect Relationships
You can reset a parent-child relationship that has been marked suspect b
manually clearing it in the Traceability Matrix or Traceability Tree:

1. Do one of the following: 

• In a Traceability Matrix, select one or more intersection points in the
matrix where a traceability link has been created. 

• In the Traceability Tree, select one or more requirements to modify

2. In the Views Workplace, click Requirement > Clear Suspect.
9-10
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Traceability Relationships

In RequisitePro, traceability is a dependency relationship between two 
requirements. Traceability is a methodical approach to managing change
linking requirements that are related to each other.

Like hierarchical relationships (see Hierarchical Relationships on page 9-1), 
traceability relationships are change-managed relationships in RequisiteP
either end-point of the connection is changed, the relationship becomes 
suspect.

RequisitePro makes it easy to track changes to a requirement throughou
development cycle, so you don’t need to review all your documents 
individually to determine which elements need updating. You can view an
manage suspect relationships using a Traceability Matrix or a Traceability T
in the Views Workplace.

This chapter addresses traceability between requirements in the same pr
For information about cross-project traceability, see Setting Up and Modifying 
Cross-Project Traceability on page 15-11.
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Creating Traceability in the Word Workplace

Use the Requirement dialog box or the RequisitePro > Requirement menu 
command in the Word Workplace to trace a requirement to or from other 
requirements in a document. A common traceability relationship is one in
which one requirement is derived from another.

Creating a Traceability Relationship in a Requirements 
Document

To create a traceability relationship in a requirements document:

1. Place the cursor in the text of the requirement.

2. Open the Requirement dialog box by doing one of the following:

• Click RequisitePro > Requirement > Properties in the Word 
Workplace.

• Click Requirement > Properties on the Tool Palette.

• Click the Display properties button on the Tool Palette.

3. Click the Traceabilty tab on the dialog box. 

The From field lists requirements from which the selected requiremen
traced. The To field list requirements to which the selected requirement
traced. An “(s)” after the requirement tag represents a suspect relation

Note: Double-click a requirement to view a read-only version of its dialo
box.

4. Click the Add button adjacent to the To or From field.
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The Trace To Requirement or the Trace From Requirement dialog box 
appears.

5. From the Requirements of type list box, select the requirement type with
which the requirement is associated.

6. If you know the location of the requirement (document or database), se
it from the Located in list box. If not, select All locations.

7. Highlight a requirement to trace to or trace from in the list box and click 
OK . RequisitePro adds this requirement to the To or From field on the 
Traceability  tab.

8. Click OK . 

Creating Traceability Using the Requirements Menu
To create traceability using the Requirements menu:

1. In a requirements document, place the cursor in the text of the requirem

2. In the Word Workplace, click RequisitePro > Requirement, or on the 
Tool Palette, click Requirement. Then click either the Trace To or the 
Trace From command.
The Trace To Requirement(s) dialog box or the Trace From 
Requirement(s) dialog box appears.
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3. From the Requirements of type list box, select the requirement type with
which the requirement is associated.

4. Select the location (document or database) of the requirement from th
Located in list box if you know it, otherwise set the list box to All 
locations.

5. Highlight a requirement to trace to or trace from in the list box and click 
OK . RequisitePro creates a traceability relationship between the two 
requirements.

Creating Traceability in the Views Workplace

You can create traceability relationships in the Attribute Matrix, the 
Traceability Matrix, and the Traceability Tree. (For more information on 
navigating in the Views Workplace, refer back to Views on page 4-1)

Creating Traceability Relationships in an Attribute Matrix
1. Create an Attribute Matrix, or open an existing one and select a 

requirement.

2. Click Requirement > Properties.
The Requirement dialog box appears.

3. Click the Traceability  tab.
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4. Click the Add button adjacent to the To or From field. The Trace To 
Requirement(s) or the Trace From Requirement(s) dialog box appears.

5. From the Requirements of type list box, select the requirement type with
which the requirement is associated.

6. Select the location (document or database) of the requirement from th
Located in list box if you know it, otherwise select All locations.

7. Highlight a requirement to trace to or trace from in the list box and click 
OK . RequisitePro adds this requirement to the To or From field on the 
Traceability  tab.

8. Click OK on the Requirement dialog box. 

Creating and Deleting Traceability in a Traceability Matrix

To create a traceability relationship:

1. Open a Traceability Matrix and select the cell that intersects the two 
requirements for which you want to create a traceability relationship. (U
a multiple select action to select more than one cell.)

2. In the Views Workplace, click Requirement > Trace To or 
Requirement > Trace From.
An arrow displays in the cell, signifying the relationship.

Trace To

Trace From
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To delete the traceability relationship:

1. Highlight the arrow in a Traceability Matrix cell. (Use a multiple select 
tion to select multiple cells.)

2. Click Requirement > Remove Trace, or press the Delete key on the 
keyboard. A dialog box appears asking you to confirm the deletion.

3. Click Yes.

To apply traceability to a row or column:

1. Select the rows or columns to fill in a Traceability Matrix. 

2. Click the View menu in the Views Workplace, and then click:

• Select All Rows in Selected Columns, or 

• Select All Columns in Selected Rows.

For example, if you selected a column in step 1, click Select All Rows in 
Selected Columns. All of the rows are selected. The intersection cells 
the selected column and all of the rows are also selected. 

3. Optionally, use a multiple select action to clear the requirements you 
not want to assign to the traceability state.

4. Click Requirement > Set Traceability.
The Set Traceability dialog box appears.

5. Select a Traceability Function  from the list.

6. Click OK . For lengthy operations, the status bar shows the progress o
operation.

Creating Traceability Relationships in the Traceability Tree
There are two methods for creating traceability relationships in the 
Traceability Tree:

• Using drag and drop

• Using Requirement commands
10-6
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Drag and Drop

1. Open a Traceability Tree and select the requirements (displayed by t
tags) to or from which you want to create a traceability relationship. (U
a multiple select action to select more than one requirement.)

2. Press the Ctrl key and hold down the right mouse button, dragging up
down the Traceability Tree until the cursor is on the requirement with 
which you want to create a traceability relationship to or from the selec
requirements, and then release the mouse button. A shortcut menu ap

3. Do one of the following:

• To delete the traceability relationship between the selected requirem
and the requirements to or from which they were traced, and create
traceability relationship between the selected requirements and the
requirement the cursor was on when you released the mouse butto
click Move Here.

• To maintain the traceability relationship between the selected 
requirements and the requirements to or from which they were trac
and create an additional traceability relationship between the select
requirements and the requirement the cursor was on when you rele
the mouse button, click Copy Here.

• To cancel the operation, without moving, deleting, or creating any 
traceability relationships, click Cancel.

Tip:  To copy or move a traceability relationship, you can also press th
Ctrl key (to copy) or the Alt key (to move) and hold down the left mou
button, dragging up or down the Traceability Tree until the cursor is on
desired requirement, and then releasing the mouse button. Note that i
use this method to copy a traceability relationship, you are not given 
option to cancel before the copy occurs. You are given the option to ca
when you use this method to move a traceability relationship.
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Requirements Commands

1. Select the requirements (displayed by their tags) to or from which you
want to create a traceability relationship. (Use a multiple select action
select more than one requirement.)

2. Click Requirement > Trace To or Requirement > Trace From.
(The command available depends on the type of Traceability Tree in 
active window.) 
The Trace To Requirements or Trace From Requirements dialog box 
appears.

3. Select the requirements in the list. (Use a multiple select action to sel
more than one requirement.)

4. Click OK .

Troubleshooting Failed Multiple Select Actions
In the Views Workplace, when you select more than one relationship or 
requirement in a view, and then perform an operation on the multiple selec
(such as creating traceability or deleting), the operation may fail for one o
more requirements or relationships. 

For example, the operation may fail if you do not have rights to perform th
operation on the requirements or relationships, or if some of the requirem
are document-based and the operation is permitted only on database-ba
requirements.

RequisitePro notifies you of such failures, providing an exception log (sepa
from the error log file) that shows the requirements or relationships for wh
the operation failed, and the reason for the failure.

1. In a view, perform the desired operation on a selected group of 
requirements or relationships.

• If the operation is successful, the modifications are shown in the vie
and no dialog box appears.

• If the operation fails for one or more requirements or relationships, o
you stop the operation before it is completed by pressing the Esc key, the 
Exception Report dialog box appears, providing the number of 
requirements or relationships for which the operation failed.

2. Click Details to learn more about the failed operation. The dialog box 
expanded, showing the reason for the failure.
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3. To copy the text in the text box, select the text and press Ctrl-C . You can 
then paste the text into a text document.

4. Click Close.

Suspect Relationships

A relationship between requirements becomes questionable or suspect if 
RequisitePro detects a requirement has been modified. If a requirement’s
is modified, all direct relationships to and from it are suspect. 

You can define attributes that, when modified, cause traceability relations
to become suspect. You also can manually mark requirement relationship
suspect in the Views Workplace.

Displaying Suspect Traceability Relationships
The suspect state is reflected in the Requirement dialog box as well as in t
Traceability Matrix and the Traceability Tree views.

On the Traceability  tab of the Requirement dialog box, an “(s)” displayed 
after the requirement tag in the To and From fields represents a suspect 
relationship. In the Views Workplace, the suspect relationship is identified
a red diagonal line through the traceability arrow. 

Auto Suspect

The Auto Suspect command monitors a requirement’s change history an
displays a suspect signal when requirements are changed. Use the Project > 
Auto Suspect command to enable or disable automatic checking for chan
that affect the traceability or hierarchical relationships between requireme
in the project.

If Auto Suspect is disabled, RequisitePro does not monitor changes in 
requirements, and does not mark relationships as suspect. There are tim
when this mode is desirable. For example, when you are revising spelling
mistakes in your documents and do not want those revisions to cause yo
relationships to become suspect, you can disable Auto Suspect.

With Auto Suspect enabled, RequisitePro constantly monitors requireme
for changes that may affect traceability or hierarchical relationships. If ther
a change in a requirement, the state of the requirement’s relationships is
automatically changed to suspect. If you have cross-project traceability ac
requirements in external projects are also monitored.
10-9
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Auto Suspect is enabled by default. If you disable Auto Suspect, it is 
automatically re-enabled the next time the project is opened. Or, enable it
the Project > Auto Suspect command.

Clearing Suspect Traceability Relationships
You can reset a requirement relationship that has been changed to a sus
state by manually clearing it. The relationship is reset to its previous state
traced to or traced from. Suspect relationships are cleared in the Traceabil
Matrix view or Traceability Tree in the Views workplace.

To clear one or more suspect relationships:

1. Do one of the following: 

• In a Traceability Matrix, select one or more intersection points in the
matrix where a traceability link has been created. 

• In the Traceability Tree, select one or more requirements to modify

2. In the Views Workplace, click Requirement > Clear Suspect.
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Import Wizard

Use the Import Wizard to import requirements from a Word document or 
comma-separated value (CSV) file into a project. 

The import process is recommended for:

• Importing non-project documents into the active project.

• Importing new requirements into an existing project.

• Updating existing requirement attributes with new information.

The Import Wizard can import requirements and attributes into your proje
from several sources: 

• Requirement documents created in other RequisitePro projects.

• Word documents created outside of RequisitePro.

• Any database that supports export of data in CSV format, such as SQ
Server, Oracle, Excel, or Access.

Before You Begin

Project Setup
You will be importing an external document or CSV file into a RequisitePr
project. If the project manager or RequisitePro Administrator has not alre
set up a project, you will need to create one now (refer to Project Creation on 
page 12-1). Minimally, the project must have at least one requirement type
one document type defined.
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Import Logs
RequisitePro creates a log file each time you import a file. The log file is a
written record of the import process. The log file records these operations
matching of requirement types, how conflicts were resolved, attribute 
mappings, the success or failure of search criteria, canceled operations, 
errors, and whether or not the import was successful. The log file is save
the directory where the project is stored, and is named import#.log, where
a number representing sequential order of creation. If a log file is deleted
next one created will receive the old number to fill in the gap.

Importing Documents from Another RequisitePro 
Project

To successfully import RequisitePro documents from one project to anoth
you must first save the documents in Word format. The resulting Word 
document retains the appearance of the original requirements document,
including the bookmarks and tags that are used in RequisitePro.

About RequisitePro format
When the Save documents in RequisitePro format check box on the Project 
dialog box is marked, all documents within the project will be saved in 
RequisitePro format. 

Documents saved in RequisitePro format cannot be modified and saved 
Word outside of RequisitePro. This allows RequisitePro projects to be sec
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When this option is cleared, documents will be saved in Word format. 
Documents that are saved in Word format can be modified in Word outsid
RequisitePro, and are not secure. 

To ensure that the documents are once again brought under RequisitePr
control after they are imported into a new project, mark the Save documents 
in RequisitePro format check box on the Project dialog box for that project. 
If security is not an issue for a particular project, you can clear the check 

Converting All the Documents in a Project to Word
If you want to import all the documents from one project into another, they 
all be converted to Word format at once.

To convert all documents to Word at once:

1. Open the project.

2. On the Tool Palette, click Project > Properties.

The Project dialog box appears:

3. On the General tab, clear the Save documents in RequisitePro format 
check box.

4. Click OK . When the project is closed, all documents will be converted
Word format, but will remain in the RequisitePro system. The docume
will retain their RequisitePro extensions.

The newly formatted documents are ready to import into another project.
Follow the instructions in Importing from Word on page 11-5.
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Converting an Individual Document to Word
To import a single document from an existing project:

1. Open the project:

• On the Tool Palette, click Project > Open.

• Or, click the Open project button.

The Open Project and Documents dialog box appears:

2. Select a document and click OK . RequisitePro opens the document.

3. On the Document menu, click Save As. The Document Save As dialog 
box displays the file name with its extension changed to “.doc”:

4. Click Save. The document is converted from RequisitePro format to Wo
format.

The file management system automatically saves the new Word docum
(*.doc) into the same folder as the project.

The new Word document is ready to import into another project. Follow th
instructions in the Importing from Word section, beginning on page 11-5.
11-4



Importing from Word

 
acket 

at 

e 
e 
t the 
s, or 

in 

any 
 and 
Saving or Removing Bookmarks
Bookmarks in a RequisitePro document are requirement indicators. They
appear as heavy square brackets, to distinguish them from the square br
character normally found in Word. When you create a requirement in a 
RequisitePro document, RequisitePro automatically inserts bookmarks th
surround and specify the text of the requirement.

When a document is imported, the Import Wizard finds strings of text in th
document (that is, the Wizard parses the document) and imports them into th
project as requirements. In the import process, you define the criteria tha
Wizard uses to parse the text. The criteria can be keywords, text delimiter
Word styles.

If RequisitePro detects bookmarks in the document being imported, the 
Remove Bookmarks dialog box appears: 

This dialog box appears after you have responded to the Document dialog 
box at the beginning of a Word import.

• Click Yes to remove bookmarks and include all the document’s text 
the parsing process.

• Click No to leave the bookmarks in place. RequisitePro recognizes 
bookmarks that were previously created in a RequisitePro document
brings that text into the new document as new requirements. The 
bookmarked text is ignored in the parsing process.

Importing from Word

Use the Import Wizard to import requirements from a Microsoft Word 
document into a RequisitePro document, or to import a Microsoft Word 
document in its entirety into a RequisitePro project.
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The document you are importing must be in Word format. If your docume
was created in an application other than Word, refer to the Microsoft Wor
documentation to save the file in Word format.

Turn off Word’s spelling, grammar and background repagination options 
the Options dialog box) before importing a Word document.

Note: If you are importing a Word document that uses a template other t
Word’s normal.dot template or an existing RequisitePro outline, yo
should set up that template as a RequisitePro outline prior to 
importing the document. RequisitePro will overwrite any 
unrecognized formatting with the normal.dot formatting.
If you have customized the formatting within the Word document, 
you should save the document as a Word template and copy it to 
RequisitePro outlines directory. Refer to the Microsoft Word 
documentation for help in creating Word templates. Refer to the 
RequisitePro online help topic “Creating outlines” for help in 
managing RequisitePro outlines.

Importing Word Documents and Requirements
To use the Import Wizard to import Word documents:

1. On the Tool Palette, click Project > Open.
The Open Project and Documents dialog box appears.

2. Select the project into which you will be importing the Word documen

3. Click the Project menu and choose Import . The Import Wizard opens, 
and the Select a Source screen appears:

4. Click Microsoft Word  Document to mark the option.
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5. Type the path and name of the Word document you want to import, or c
Browse to select a file.
The Browse command displays the Open dialog box. Navigate to the 
desired document and click Open. (If the desired document is not found in
the list, try changing the file type to All files.) The Open dialog box closes 
and the selected document is loaded into the Import Wizard.

6. Click Next to continue. The Select Import Content screen appears:

7. Designate the import content by clicking the appropriate option. Selec
Requirements and document, Requirements only, or Document only.

Depending on your choice, you will take one of three paths. The follow
table demonstrates the trade-offs between the different import option

Requirements 
and Document

Requirements 
only Document only

Requirement 
definition

Automatic Automatic Manual

Requirement 
destination

New document

Database or
New document or
Existing 
document

New document
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The Requirements and Document Import Option

If you select the Requirements and Document option on the Select Impor
Content screen, the Import Wizard imports the entire document and the 
requirements created by parsing the text. The Word document is imported
a new RequisitePro requirements document, and requirements are 
automatically generated in the new document. The Requirements and 
document option works well if your document already contains a well-defin
requirement structure. The Import Wizard parses the document for 
requirements based on key words, text delimiters, or Word styles.

1. Select the Requirements and Document option on the Select Import 
Content screen and click Next. The Document dialog box appears:

2. Complete the following information:

• Type the document Name (any length up to 64 characters).

• Type the Filename (RequisitePro will assign an extension according 
the Document Type selected).

• Mark the Show Tags check box if you want to display requirement tag
in your document.

• Select a Document Type from the list.

• Click the Revision tab to enter a change description or create a user
defined label (optional). Revision number, date, time, and author ar
generated by the system and cannot be edited here.

3. Click OK  to continue.
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Note: If the document type you selected is associated with an outl
(or template) that contains special formatting and text, the 
Outline has text dialog box appears. You must indicate if you
want to preserve the text and formatting from the outline for
this document type. Click Yes to retain the style settings and 
text from the document outline. Click No to import the basic 
Word document only.

The Requirement screen appears:

4. Select a type for the new requirements in the Requirement Type list.
The Wizard provides a default requirement type by matching it to the 
document type you selected earlier. 

Note: Occasionally, you may want to include requirements of multip
types in a single document. For example, any sentence contai
the word “shall” could become a product requirement, and any
sentence containing the word “will” could become a software 
requirement. As you create search criteria in the step below, y
can use the Requirement Type list to select which requirement 
types you want to apply.

5. Click the Set Defaults button to open the Set Requirement Defaults dial
box, where you can enter default attributes, hierarchy, traceability and
change description for the requirements you create.

6. Mark one of three methods for differentiating or parsing the Word 
document. The Import Wizard finds strings of text in the Word docume
and imports them into the project as requirements.

Key word - Import Wizard searches the Word document for a specif
word, such as “shall” (the default). Enter the key word and click Add.
11-9



Import Wizard

t 
u 

d 
. 

n 
ist 

you 
Text delimiters - Import Wizard searches the Word document for tex
contained within specific text delimiters, such as < >, { }, [ ]. When yo
have entered both the starting and ending delimeters, click Add.

Word style - Import Wizard searches the Word document for specifie
style settings, such as “Heading 1” or “Body text” or highlighted text
Select the appropriate styles and click Add. 

Note: You do not need to limit the search to one criteria only. You ca
add keywords, text delimiters, and Word styles to the search l
by marking each button in turn. Use Remove to delete a criteria 
from the search list.

7. Click Next to continue.
RequisitePro parses the document using the differentiation methods 
selected. When a requirement is located, the Requirement found dialog 
box appears: 
11-10
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8. Indicate whether the text found is a valid requirement: Click Yes or No for 
each. Choose Yes to all to automatically accept all requirements found i
the document. Each requirement is added to the Requirements to import 
dialog box:

Each new requirement begins with a pending tag, followed by the init
text of the requirement.

9. When you are satisfied with your selection, click Next to continue.
The Import Wizard displays the final Status screen:

10. Click Commit to accept the import or click Cancel to cancel the import in 
its entirety.

The Requirements only  Import Option

Select Requirements only at the Select Import Content screen if you want 
extract requirements from a document without importing the rest of the tex
your document already contains a well-defined requirement structure suc
11-11
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keywords, styles, or delimiters, this option automatically creates your 
requirements during the import process. The Import Wizard parses the 
document for requirements, based on key words, text delimiters, or Word
styles. It creates requirements from the text it finds and leaves the rest of
document behind. You have flexibility in the location of the new requiremen
You can create requirements in the current project (directly in the databas
an existing RequisitePro document, or in a new document. 

1. Select the Requirements only option on the Select Import Content scree
and click Next. The Select a Destination screen appears: 

2. Choose one of the following destinations for the imported requiremen

• Select Current project database to import the requirements into the 
database of the open project.

• Select New RequisitePro document to import the requirements into a 
new document you define. (The Document dialog appears and prompts
you for information about the new document before proceeding to t
next step.)

• Select Existing RequisitePro document to choose from a list of existing
project documents. (If the document you choose is not already ope
RequisitePro opens it for you.)

3. Click Next to continue. The Requirement screen appears. 

4. Follows step 4-9 above in The Requirements and Document Import 
Option.

Note: At step 7, when the “Requirements to import” dialog box appears,
you have the following options:
11-12
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• If you want to read the full text of the requirement, click the View 
button.

• To remove a requirement from the list, select it and click the 
Remove button. (It is saved in an Add requirements box.) Click 
Add to view the box.

The Document only  Import Option

The Import Wizard imports the entire document into a new RequisitePro 
document without parsing the text. Choose Document only if your 
requirement structure is not defined or you want to manually create the 
requirements after importing. No requirements are created during the imp
process. It gives you the most flexibility in creating document-based 
requirements.

1. Select the Document only option on the Select Import Content screen an
click Next. The Document dialog box appears. 

2. Complete information about the new document. (See step 2 above inThe 
Requirements and Document Import Option on page 11-8.) 

Note: If the document type you selected is associated with an outl
(or template) that contains special formatting and text, the 
Outline has text dialog box appears. You must indicate if you
want to preserve the text and formatting from the outline for
this document type. Click Yes to retain the style settings and 
text from the document outline. Click No to import the basic 
Word document only.

The Import Wizard displays the final Status screen. 

3. Click Commit to accept the import, or click Cancel to cancel the import 
in its entirety.

Note: If you are importing a RequisitePro document from one project to 
another, this process includes an extra dialog box (Refer to Saving or 
Removing Bookmarks on page 11-5).

Importing a CSV File

RequisitePro can import requirements and attributes into your project from
database that supports export of data in CSV format, such as SQL Serve
Oracle, Excel, or Access.
11-13



Import Wizard

tive 

 
 by 
ded 

 be 

oot 
al 

as 

base.

lly 

Pro 
The CSV import process is recommended for:

• Importing requirements from a non-RequisitePro database into the ac
project.

• Updating existing requirement attributes with new information.

A CSV (comma-separated value) file is a data file consisting of fields and
records, stored as text, in which the fields are separated from each other
commas. If the data in a field contains a comma, the field is further surroun
with quotation marks. Using a comma-delimited file format allows data to
shared between database systems that use different formats.

Requirement Numbers
When a new requirement is added to the database, it is assigned a new r
requirement number. If a requirement has a tag or a number in the extern
CSV file, that number is not preserved. RequisitePro will recognize a 
hierarchical numbering scheme and will import lower-level requirements 
children of a higher-level requirement.

Requirements in a CSV file are renumbered when they are imported into the project data

Preparing a CSV File for the Import Wizard
The CSV file and RequisitePro must be configured properly to successfu
import all information:

• The CSV file must contain a header in RequisitePro format. Requisite
uses the following header format: 
<Tag>, “Requirement text”, <Attribute 1>,<Attribute 2>, <Attribute 3>.
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The requirement type specified in the <Tag> field, determines the def
requirement type that will be assigned during the import process. You
change this requirement type assignment in the Import wizard.

• All attributes that are included in the CSV file must exist in the 
corresponding RequisitePro requirement type in the current project. If
attributes don’t match, the default values for the requirement type are
inserted during the import process. See Creating and Modifying 
Requirement Attributes on page 15-7.

• All list-type attribute values in the CSV file must exactly match the 
predefined list-type attribute values in the RequisitePro requirement t
definition. Edit the attribute values in the CSV file or modify the list-typ
values in your RequisitePro project. See Working with Requirement 
Attribute Values on page 15-10.

Note: Multiple-value list attributes appear in a CSV file in quotes, 
separated by commas (e.g. “Chris, Sarah, John”).

• If the CSV file contains null values (blank spaces) for any list-type 
requirement attributes, those attributes will be assigned the default va
as defined in the RequisitePro project properties. To retain a null valu
remove the default setting in RequisitePro before importing the CSV f
You can reassign the default value after the import process is complete
Working with Requirement Attribute Values on page 15-10.

• All requirements in the CSV file will be converted to the requirement ty
specified in the import process (in the header <Tag> field, by default)
the CSV file contains requirements with different requirement type tag
such as “PR1” and “SR2”, those requirements will be renumbered with
assigned requirement tag, and some hierarchical relationships may be

Defining a Header for a CSV File

RequisitePro uses the following header format:
<Tag>, Requirement text, <Attribute 1>,<Attribute 2>, <Attribute 3>...

A sample CSV file with a correctly formatted header row.
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1. To begin creating a header, type a tag that describes a requirement t
such as PR, SR, TST, or any other tag you created in your project, follo
by a comma. The word tag can be added in the header, but is not require
For example, SR and SR tag are both acceptable.

• The tag field in the header is used to set the default Requirement T
used in the import. If the tag field does not match any requirement t
in the project, the Match Requirement Type screen appears, prompting
you to choose one manually.

• The first column in the CSV file must be the tag column. The tag colu
cannot contain any empty cells. If a cell is empty, type in any chara
to fill it.

• If the tag column in the CSV file contains numbers, the numbers will 
be preserved. Imported requirements will be added to the project’s 
requirements list and renumbered accordingly. Hierarchical 
relationships will be retained.

2. The literal string Requirement text must be the second field of the heade
followed by a comma.

• The second column in the CSV file must be the text of the requireme

3. For the remaining fields in the header, type a heading for each colum
the CSV file, separated by commas. The column headings in the hea
can be anything you like, but if you use names (i.e. labels) of attribute
they appear in your project you will save yourself some time later.

• RequisitePro will look at the header in the CSV file and try to match 
column heading to an attribute in the project. During the import proc
you will be asked to review the attribute matching and make correcti

• The columns under the attribute headings must contain attribute va

Note: As an alternate to typing the CSV header, you can copy a header 
another CSV file. Exporting an existing RequisitePro file to a CSV
file will create a tag in the correct format. Open an Attribute Matrix 
the requirement type you plan to import and use the File > Export  > 
Export to CSV command. Then copy the header from the newly 
exported file and paste it into the file you plan to import. (For more
information, refer to Exporting a View as a CSV File on page 23.)
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Using the Import Wizard to Import a CSV File
Open a project, then do the following:

1. On the Tool Palette, click Project > Import, or
from the Views Workplace, click File > Import .
The Import Wizard opens, and Select a Source screen appears:

2. Complete the following information:

• Click the CSV button to import requirements from a comma-separat
value text file. 

• Type the name of the CSV file to import, or click Browse to select a file 
from the list. (The Browse command displays the Open dialog box. 
Navigate to the desired document and click Open. The Open dialog box 
closes and the selected document is loaded into the Import Wizard.

3. Click Next to continue. The Match Requirement Types screen appears:
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The Import Wizard, by default, selects the RequisitePro requirement t
that matches the requirement types in the CSV file that you are import
You can override the default selection. 

4. Click Next to continue. 

The Match Attributes  screen appears:

5. Click Match Manually  to check that RequisitePro mapped the attribut
correctly. 

The Match Attributes  dialog box appears:
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6. Complete the following information:

• If you want to change the mapping, click and hold the mouse while 
dragging a new line from an imported attribute to an existing attribu

• If RequisitePro could not make a match, the imported attribute will b
listed but will have no line connecting it to an existing RequisitePro 
attribute. You can make the match manually if you recognize an attrib
with the same meaning. Requisite Pro will ignore any attributes left 
unconnected. Only matched attributes are imported.

• When you are satisfied with the attribute matching, click OK  to return 
to the Wizard.

7. Click Next to continue.

The Select A Resolution dialog box appears:

When attribute values in the imported requirements conflict with the 
values in existing requirements, RequisitePro can resolve the conflict
one of two ways:

• add the imported requirements as new requirements in your docume
database

• overwrite your existing attribute values with those in the imported CS
file.

Depending on your choice, you will take one of two paths: The Define new 
RequisitePro requirements Import Option on page 11-20 or The Update 
attributes of existing requirements Import Option on page 11-22.
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The Define new RequisitePro requirements Import Option

The Wizard imports the text of the requirements as written in the CSV file. Y
can accept or delete the requirements before importing.

1. Select Define new RequisitePro requirements and click Next.

The Requirements to Import screen appears:

2. Review requirements in the list and revise the list as needed:

• Click View to read the full text of the requirement. The Edit Imported 
Requirements dialog box appears. Select a requirement from the lis
The full text of the requirement displays in the text pane at the bottom
the dialog. To make changes to any of the list-type attribute values,
double-click on the cell and select a new value from the drop-down 
To make changes to entry-type attribute values, select the value and
the new value. Click Accept for Import .

• Click Remove to remove a selected requirement. (A requirement tha
was removed is not entirely deleted. It is moved into the Add 
requirements dialog box.)

• Click Add to review a list of requirements you have removed. If you
would like to add a requirement back into the list, select it and click OK .

3. Click Next to continue.
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The Select A Destination screen appears:

4. Choose a destination for the new imported requirements:

• Select Current project database to bring the requirements into the 
database of the open project.

• Select New RequisitePro document to create a new document (based
on the document type of your choosing) and bring the requirements 
the new document. The Document dialog box appears and prompts yo
to record the document name, filename, and document type.

• Select Existing RequisitePro document to choose from a list of 
existing project documents. If the file you choose is not open, 
RequisitePro opens it for you.

5. Click Next to continue. The final Status screen appears:

6. Click Commit to accept the import or click Cancel to cancel the import in 
its entirety.
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The Update attributes of existing requirements Import 
Option

The new imported requirement attributes overwrite the requirement attrib
in the open project. The text of the imported requirements will not be impor
You can accept or delete the requirements before importing.

1. Select Update attributes of existing requirements and click Next.
The Requirements to Import screen appears:

The list box shows tag numbers, followed by the comment:
[text will not be imported].

2. Review requirements in the list and revise the list as needed:

• Click the View button to access the Edit Imported Requirements 
dialog box. Only tag numbers are displayed, as the text will not be 
imported. (To view the text of the requirements associated with the 
numbers, refer back to the Attribute Matrix in the Views Workplace.

• Click the Remove button to remove requirements from the list and sto
them in an Add requirements dialog box.

3. Click Next.
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The Import Wizard displays the final Status screen.

4. Click Commit to accept the import, or click Cancel to cancel the import 
in its entirety.

Exporting Requirements

Requirements are exported from RequisitePro in the Views Workplace.

• An Attribute Matrix can be exported as a CSV file or as a Word docum

• A Traceability Matrix can be exported as a CSV file only.

• A Traceability Tree can be exported as a CSV file or as a Word docum

Exporting a View as a CSV File
As described above in Importing a CSV File on page 13, a CSV file is a data
file consisting of fields and records, stored as text, in which the fields are
separated from each other by commas. If the data in a field contains a com
the field is further surrounded with quotation marks.

To export a view as a CSV file:

1. Open the Attribute Matrix, the Traceability Matrix, or the Traceability 
Tree that you want to export.

2. In the Views Workplace, click File > Export > Export to CSV.
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The Export to CSV dialog box appears: 

3. Complete the following information:

• Choose a location to save the exported file in the Save in drop-down list.

• Type a name for the exported file in the File name text box.

• Do not modify the .csv file selection in the Save as type text box.

4. Click Save. 

RequisitePro exports the View as a comma separated value file (*.cs
which is readable by such applications as SQL Server, Oracle, Excel,
Access.

Exporting a View as a Word Document
To export a view as a Word document:

1. Open an Attribute Matrix or a Traceability Tree that you want to expo

2. In the Views Workplace, click File > Export > Export to Word .
The Export  to Word  dialog box appears. 
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3. Complete the following information:

• Choose a location to save the exported file in the Save in drop-down list.

• Type a name for the exported file in the File name text box.

• Do not modify the .doc file selection in the Save as type text box.

4. Click Save.

RequisitePro exports the View as a Word document (*.doc), then ope
Word and displays the exported View as a Word document table.

Note: When a Traceability Tree is exported to a Word document, 
RequisitePro creates a new document based on a template cr
especially for this export (treexprt.dot). You can modify this 
template and its styles to suit your needs. Heading styles 1-9 
be modified, but they must be retained.
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Project Creation

Project managers create and manage all elements of projects.
This chapter provides instructions for performing the following tasks:

• Creating a project using a blank project database

• Creating a project using the Project Wizard

• Creating a project using an existing project as a template

• Converting earlier versions of RequisitePro projects to the 4.5 format

Creating a Project Using a Blank Project Database

This feature is intended for use by knowledgeable users who want the mo
flexibility when creating a new project. To use this feature effectively, it is
important that you know how to work with each of the tabs in the Project 
dialog box.

1. On the Tool Palette, click Project > New.
The New Project dialog box appears. 
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2. Select Blank Project database and click OK . 

The Project dialog box appears, with the General tab in front. 

3. Click the Name text box and type a unique name of up to 64 characters
accept the default name provided by RequisitePro. The first eight 
characters of the project prefix are used to identify the project if the pro
is used for cross-project traceability. RequisitePro automatically popul
the Creator text box with your RequisitePro user’s name. This text box
read-only and cannot be edited.

4. In the Directory  text box, specify a path for RequisitePro to store the 
project. Accept the default or click Browse and select a path in the Browse 
for Folder dialog box. The path should include the drive, the project 
directory, and the new project folder. The path cannot exceed 256 
characters. Once the project is created, you cannot change this field.

Note: You can later relocate a project by moving the project directory
another location in the file system. To access the project in its
new location, users must add it to their project lists.

5. In the Database field, click the down arrow to select a database for stori
the project. You have the option to create projects in Microsoft Acces
Microsoft SQL Server, or Oracle.

6. If you select the Microsoft SQL Server or Oracle database, click 
Properties to configure your access to that database.

Note: For more information on configuring SQL Server or Oracle, see th
Rational RequisitePro Installation Guide.
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7. If desired, clear the Save documents in RequisitePro Format check box. 
RequisitePro marks this check box by default. If this check box is mark
documents are secure; that is, they cannot be opened in Word outsid
RequisitePro. If this check box is cleared, documents are not secure;
is, they are saved in Word format, and can be opened in Word outside
RequisitePro. 

If the directory specified does not exist, the Project message box appears
prompting you to create the directory. Click Yes to create the directory. 

8. Use the other tabs in the Project dialog box to create settings and record
more information about the project. See Chapter 15, Project Information, 
for further instructions about using the tabs in the Project dialog box.

9. Click OK  in the Project dialog box to create the project.

Recording Revision Information About the Project
Use the Revision tab in the Project dialog box to view information about t
most recent revision of the project. Enter optional information about the m
recent revision, and access the project’s revision history.

In the Project dialog box, click the Revision tab. 

• The Revision text box contains the revision number. This read-only tex
box cannot be edited unless the project is checked into ClearCase, V
SourceSafe, or PVCS Version Manager, or it is archived using 
RequisitePro’s Archive command. You can only override the revision 
number when the project is archived. The new revision number that y
use must be greater than the existing number and must be expressed
N.m format, for example, 2.5.

• The Label text box contains a descriptive name for the revision. This fie
is optional and only available if changes have been made to project 
properties.

• The Date text box is read-only and displays the date the project was 
modified.

• The Time text box is read-only and displays the time the project was 
modified.

• The Change Description text box displays changes made to the projec
This field is optional and only available if changes have been made to
project properties.
12-3



Project Creation

 of 

you 
• The History  button opens a dialog box that displays the change history
the project.

Creating a Project Using the Project Wizard

The Project Wizard simplifies the process of creating a project by guiding 
through the procedure step-by-step. 

1. On the Tool Palette, click Project > New. 
The New Project dialog box appears. 

2. Select Use the project wizard and click OK .

RequisitePro starts the Project Wizard and the Welcome screen appears. 

3. Click Next. 
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The Project screen appears.

4. Complete the information:

• In the Name text box, type a name for the project, or accept the defa
name provided by RequisitePro. 

• In the Description text box, type a description of the project (this step
optional).

• In the Directory  text box, specify a location for storing the project. B
default, RequisitePro creates a directory name that matches the nam
typed in the Name text box above. Accept the default or click Browse 
and select a path from the Browse for Folder dialog box.

• In the Database field, click the down arrow to select a database for 
storing the project.You have the option to create projects in microso
Access, Microsoft SQL Server, or Oracle.
If you select the Microsoft SQL Server or Oracle database, click 
Properties to configure your access to that database.

5. Click Next to continue.

The Document Type information screen appears.

Note: If the directory specified does not exist, the Project message box 
appears, prompting you to create the directory. Click Yes to 
create the directory. Click No to close the message box without 
creating the directory.

6. Read the information on the screen, and click Next to continue.
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The Create the First Document Type screen appears.

7. Complete the information:

• In the Name text box, type a name for the document type, or accept 
default provided by RequisitePro.

• In the Tag text box, specify a tag to label requirements created in th
document type, or accept the default provided by RequisitePro.

• In the Description text box, type a description of the document type.

• To indicate that any requirements created in the document must con
the work “shall,” mark the Requirements must contain the word shall 
check box.

Note: This step is optional. You can change “shall” to a different wo
once you have created the project and opened the document.

• Select an outline to be used with the document type. If you choose 
default selection, None, RequisitePro uses the normal.dot Word 
template.

8. Click Next to continue. 
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The Defined Document Types screen appears.

9. Do one of the following if needed:

• To add more document types, click Add, and repeat steps 5 and 6 abov

• To edit a document type, click Edit . Complete the information in the 
Edit a document type screen and click Next.

• To remove a document type, click Remove. 

10. Click Next to continue. 

The Document description screen appears. 

11. Read the information in the pane and click Next to continue. 

The Create the First Document screen appears. 

12. Complete the information:

• In the Description text box, type a description of the document. 
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• In the Document Type list, select a document type. 

• To create a RequisitePro document from an existing Word docume
type the document name in the Document to import text box, or click 
Browse to find the document. 

13. Click Next to continue.

The Documents Defined screen appears. 

14. Do one of the following:

• To add more documents, click Add and repeat step 9.

• To edit a document, click Edit . 

• To remove a document from the list, click Remove. 

15. Click Next to continue.

The Congratulations screen appears. 

16. Click Exit  to complete the process.

Creating a Project Using an Existing Project as a 
Template

When you use an existing project as a template, RequisitePro creates the
project using the same structure as the existing project. Document types,
requirement types, view definitions, attributes, user and group permission
all copied. Documents, requirements, history information, and traceability
relationships are not copied.
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1. On the Tool Palette, click Project > New.
The New Project dialog box appears. 

2. Click Use an existing project as a template.

3. In the projects list, select the name of the project to use as a template

Note: You can use the RequisitePro Project Template 4.5, which provides 
standard document types and requirement types for your new pro
This project template is located in your project list (and at the 
following location: <install drive>/Program Files/Rational/common
OutOfTheBox/requirements/rstemplate.rqs).

4. Click OK .

RequisitePro opens the project, duplicates the project structure and o
the Project dialog box with the General tab displayed in front.

5. In the Name text box, type a name for the project, or accept the defau
name provided by RequisitePro. 

6. In the Description text box, type a description of the project (this step 
optional).

7. In the Directory  text box, specify a location for storing the project. Acce
the default or click Browse and select a path from the Browse for Folder 
dialog box.

8. In the Database field, click the down arrow to select a database for stori
the project. You have the option to create projects in Microsoft Acces
Microsoft SQL Server, or Oracle.

9. Click OK . The project is added to your project list and ready for use.
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Converting RequisitePro Projects to the 4.5 Format

If you try to open a project created in RequisitePro 2.0, 2.1, 2.5, 3.0, 3.1, or
the Project Conversion Wizard automatically displays and guides you thro
the project conversion. 

Note: In RequisitePro 4.5, you cannot open projects that were created i
versions of RequisitePro earlier than 2.0, including Requisite 
Baseline.

Prior to conversion, the project is archived in its original form in a backup
subdirectory in the project directory. You can use this archive to open the
project in the earlier version of RequisitePro. You cannot open 4.5 version
projects in earlier versions of RequisitePro.

Conversion includes the following:

• Conversion to 32-bit format (versions 2.0 and 2.1).

• Conversion to allow for the new features in RequisitePro 4.5:

• Integrated Use Case Management

• Access to the RequisitePro Extensibility Interface

• Requirement Metrics

• Let's Go RequisitePro help assistant

To convert to RequisitePro 4.5:

1. On the Tool Palette, click Project > Open. 
The Open Project and Documents screen appears.

2. Select the project to open and click OK .
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If the project was created in an earlier version of RequisitePro, the Project 
Conversion Wizard Introduction  screen appears.

3. Click Next. 

The Project Archive screen appears.

4. In the Archive Location text box, specify the location for the archived 
project.

RequisitePro makes a copy of the project and its documents and stor
in the archive directory before converting the project to a RequisitePro
project. 

5. If you started the conversion process from the command line, the Project 
Selection screen appears, prompting you for the location of the projec
convert. In the Selected Project text box, specify a location for the projec

6. Click Archive to continue.

RequisitePro archives the project. 

The Project Conversion screen appears. 

7. Click Convert to convert the project. 

The Congratulations screen appears.

8. Click Exit to complete the process.

When you run the Project Conversion Wizard from within RequisitePro, th
converted project opens when you click Exit.

Note: If the converted project is connected to an external project that is
previous project format, the converted project opens; however, th
connection to the external project is disabled. Open the external 
project and convert it to the current format in order to re-establish
connection for cross-project traceability.
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Project Security

Because RequisitePro allows multiple users to access the same project 
documents and database simultaneously, project security is crucial. It ass
that all changes to requirements and documents are tracked properly.

You can enable or disable security in a project, depending on the needs o
group. With security enabled, users belong to groups. Project managers a
group-specific permissions. The permissions determine the amount or kin
access users have to projects. Security permissions are assigned at the g
level, not the user level, and a user can be in only one group.

Any RequisitePro user can create a new project. When you create a new
project, you are considered the project administrator and are automatical
placed in the Administrators group. After you create the project, you (and o
Administrators) can define other users and groups. 

When you first create a project, security is not enabled. If you want to use
project security, you must specify it in the Project Security dialog box.

If security is enabled, the Project Logon dialog box appears each time you o
another user opens the project. The project manager who enabled securi
assign passwords for other users.
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Setting Security

To enable or disable security for a project:

1. On the Tool Palette, click Project > Security.

The Project Security dialog box appears.

2. Click the Enable security for this project check box. Mark the check box
to enable security; clear the box to disable security.

3. Select groups and users by following the steps in the next section.

4. Click OK .

Creating and Modifying Groups and Users

RequisitePro provides three default security groups: Deleted Users, 
Administrators, and Users. Remember that all security permissions are 
assigned at the group level only, and a user can be in only one group. 

• Deleted Users. This group contains users who have been deleted from
other groups, have no permissions, and cannot log on to RequisitePro.
group is maintained by RequisitePro for project history.

• Administrators. Members of this group have full permissions to work in
project. They can change a project structure, create and modify data,
set and maintain security permissions. You can add and remove users
this group, but you cannot modify Administrators group permissions.

• Users. By default, members of the Users group can read documents a
requirements, create views, and participate in discussions. You can mo
Users group permissions.
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You can add and delete groups, add users to groups, move a user to a dif
group, and edit a user’s information, such as user name, password, and e
address.

Creating a New Security Group
To create a new security group:

1. On the Tool Palette, click Project > Security.
The Project Security dialog box appears.

2. Click Add below the Groups list box.
The Group Permissions dialog box appears.

3. In the Name text box, type a name for the group.

4. Set the group permissions and click OK . 

For more information on setting and editing group permissions, see 
Assigning Permissions to a Security Group on page 13-6.

5. Click OK to save and close the Project Security dialog box.
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Deleting a Security Group
If all users have been removed from a group, you can remove the group.

To delete a group:

1. On the Tool Palette, click Project > Security. The Project Security 
dialog box appears.

2. In the Groups list box, select the group to delete.

3. Click Delete. RequisitePro prompts you to confirm the deletion.

4. Click OK . 

5. Click OK in the Project Security to save and close.

Adding a User to a Security Group
To add a user to a group:

1. On the Tool Palette, click Project > Security. The Project Security 
dialog box appears.

2. In the Users of Group list, select the group to add the user to, and click
Add next to the Users of Group list. The Add User dialog box appears.

3. In the Username text box, type the user’s name (up to 20 alphanumeri
characters, not case sensitive). 

4. In the New Password text box, type the user’s password

Note: This field and the Verify field below are encrypted, displaying 
symbol for each of the 14 maximum possible characters.

Remember: Passwords are case-sensitive (for example, Mycomputer
MYCOMPUTER, and mycomputer are treated as different passwords
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5. In the Verify  text box, type the password again.

6. In the E-Mail Address text box, type the user’s e-mail address.

This e-mail address is necessary for participating in RequisitePro 
discussions via e-mail. For more information, see Configuring E-mail for 
Discussions on page 6-2.

7. Click OK . RequisitePro adds the new user to the group.

8. Click OK to save and close the Project Security dialog box.

Editing User Information
To edit user information:

1. On the Tool Palette, click Project > Security. 
The Project Security dialog box appears.

2. In the Groups list, select the security group to which the user belongs.

3. In the Users of Group list, select the user name.

4. Click Edit  next to the Users of Group list.
The Edit User dialog box appears.

5. Edit the user name, password, or e-mail address.

6. Click OK .

7. Click OK to save and close the Project Security dialog box.

Deleting a User from a Security Group
When you delete a user from a security group, RequisitePro moves the us
the <Deleted Users> group. All records associated with the user are 
maintained. If you reinstate a user with the same name as a deleted user
RequisitePro prompts you to confirm whether it is the same person befor
RequisitePro reinstates the user.

To delete a user:

1. On the Tool Palette, click Project > Security.
The Project Security dialog box appears.

2. In the Groups list, select the group containing the user.

3. Select the user in the Users of Group list.

4. Click Delete below the Groups list. A dialog box appears, prompting you
to confirm deletion of the user. 
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5. Click Yes to move the user from the current group to the <Deleted Users> 
group.

6. Click OK  to save your changes and close the Project Security dialog box.

Moving a User to Another Security Group 
To move a user to another security group:

1. On the Tool Palette, click Project > Security.
The Project Security dialog box appears.

2. In the Groups list, select the group containing the user.

3. Select the user in the Users of Group list.

4. Click Move. The Move User dialog box appears. 

5. Select the group to move the user to.

6. Click OK .

7. Click OK  to save your changes and close the Project Security dialog box.

Assigning Permissions to a Security Group

Each security group has its own set of unique permissions. All members o
group share the same permissions. The following list shows all possible 
permissions that can be assigned to a group:

• Project permissions: access the project, manage project structure, man
project security.

• Document type permissions: read, update, create, delete documents.

• Requirement type permissions: read, update, create, delete requirement

• Attribute permissions: read, update attributes.

• Attribute value permissions: read, update attribute values.
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Members of the Administrators group and groups with project security 
permissions can create group accounts, assign permissions to the group
add, move, edit, and delete users in groups.

To assign permissions:

1. On the Tool Palette, click Project > Security. The Project Security 
dialog box appears.

2. In the Groups list, select the group.

3. Click Edit below the Groups list.
The Group Permissions dialog box appears.

Note: The Administrators group has full permissions. You cannot edit th
group’s permissions, although you can add and remove users from
Administrator’s group.

4. To assign project structure modification permissions to the group, ma
the Can manage project structure check box. Groups with these 
permissions have complete access to all tabs and information in the 
Project dialog box for this project. To remove a group’s permissions, cl
the check box.

Note: The Can access project check box is automatically checked and
cannot be changed. 
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5. To assign project security permissions to the group, mark the Can manage 
project security check box. Groups with these permissions can chang
group and user permissions for this project. To remove a group’s 
permissions, clear the check box.

6. Assign document, requirement, attribute and attribute value permissio
as described in the following sections.

7. Click OK .

Assigning Document Type Permissions to a Security Group
To assign document-type permissions:

1. On the Tool Palette, click Project > Security.
The Project Security dialog box appears.

2. In the Groups list, select the group.

3. Click Edit below the Groups list. The Group Permissions dialog box 
appears.

4. In the Document Types list, select the document type for which you wan
to assign permissions. 

5. Click Edit Permissions below the Document Types list.
The Document Type Permissions dialog box appears. 

6. Assign document permissions by marking the corresponding check b
Groups can have read, update, create, and delete permissions. To re
a permission assigned to a group, clear the check box that correspon
the permission. If you do not want the group to have any permissions
this document type, clear all selections. 

• Read permissions: Members of the group can view documents of th
type. If Read is the only permission selected, members of the group
cannot modify documents of this type. 
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• Update permissions: Members of the group can modify documents 
this type. If Update is selected, Read is also automatically selected.

• Create permissions: Members of the group can create documents of
type. If Create is selected, Read and Update are also automatically 
selected.

• Delete permissions: Members of the group can delete documents of
type. If Delete is selected, Read, Update, and Create are also 
automatically selected.

7. Click OK  to save the modifications.

Assigning Requirement Type Permissions to a Security Group
To assign requirement-type permissions:

1. On the Tool Palette, click Project > Security.
The Project Security dialog box appears.

2. In the Groups list, select the group.

3. Click Edit below the Groups list. The Group Permissions dialog box 
appears.

4. In the Requirement Types list, click the requirement type for which you
want to assign permissions. 

5. Click Edit Permissions below the Requirement Types list.
The Requirement Type Permissions dialog box appears. 
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6. Assign requirement permissions by marking the corresponding check 
Groups can have read, update, create, and delete permissions. To re
one of the other permissions assigned to a group, clear the check box
corresponds to the permission.

• Read permissions: Members of the group can view requirements of 
type. If Read is the only permission selected, members of the group
cannot modify requirements of this type. This requirement-type 
permission is automatically selected, and the box cannot be cleared

• Update permissions: Members of the group can modify requirements
this type.

• Create permissions: Members of the group can create requirements
this type. If Create is selected, Update is also automatically selected.

• Delete permissions: Members of the group can delete requirements
this type. If Delete is selected, Update and Create are also automatically 
selected.

7. If desired, select a requirement attribute and click Edit Permissions to 
assign attribute permissions to the security group. For more informati
see the following section.

8. Click OK  to save the modifications.

Assigning Attribute Permissions to a Security Group
To assign attribute permissions:

1. Select the requirement type, as described in steps 1 through 5 in Assigning 
Requirement Type Permissions to a Security Group on page 13-9.

2. In the Requirement Type Permissions dialog box, select the attribute.

3. Click Edit Permissions. 

The Attribute Permissions dialog box appears. 
13-10



Assigning Permissions to a Security Group

 be 
rk 

e 

 to 
• For list-type attributes, the dialog box pictured below appears.

The Read permission check box is automatically marked and cannot
cleared. To allow users to modify attributes of the selected type, ma
the Update check box and refer to the section on page 12 for more 
information on assigning permissions to modify specific attribute 
values.

• For entry-type attributes, the dialog box pictured below appears. 

The Read permission check box is automatically marked and cannot b
cleared.

4. Mark the Update check box to give members of the group permissions
modify the attributes. Clear the box to allow default Read permissions 
only.

5. Click OK .

6. Click OK  in the Requirement Type Permissions and Group 
Permissions dialog boxes.
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Assigning Permissions to Attribute Values for a
Security Group

To assign permissions to attribute values:

1. Select an attribute, as described in steps 1 through 3 in Assigning Attribute 
Permissions to a Security Group on page 10.

2. Mark the Update check box in the Attribute Permissions dialog box for 
the list-type attribute. 

The attribute values in the list box and the Edit Permissions button are 
enabled.

3. Select and attribute value in the list and click Edit Permissions. 

The Attribute Value Permissions dialog box appears. 

The Read permission check box is automatically marked and cannot b
cleared.

4. Mark the Update check box to give members of the group permissions
modify the attribute value. Clear the box to allow default Read 
permissions only for the attribute value.

5. Click OK .

6. Repeat steps 3 and 4 to set or remove group permissions for other attr
values.

7. Click OK  in the Attribute Permissions, Requirement Type 
Permissions, and Group Permissions dialog boxes.
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Project Management

This chapter provides instructions for the following tasks for managing 
projects:

• Controlling user access to a project and its documents

• Creating outlines

• Renumbering requirements

• Printing project summaries and reports

• Archiving projects

• Removing a project’s revision information

• Removing documents and requirements from a database

• Moving projects

• Copying projects

• Converting a database

Controlling User Access to a Document

When opening projects and documents, you have several options for 
controlling access by other users when the project and documents are op

• Exclusive access limits access to the project and documents to the 
who opens the project. Exclusive access is needed to renumber 
requirements, change tag prefixes, change requirement color and s
remove an attribute, remove revision information and propagate a 
revision number. 

• Read-only access lets a user open a project for viewing only.

• Document read-only access lets a user open a document for viewin
only.
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For information on setting up read-only, create, and delete permissions fo
projects and requirements documents, refer to chapter 13, Project Security on 
page 13-1.

Locking and Unlocking Project Documents
When you lock a document, users cannot modify its text, graphics, or OL
objects. Locking a document does not prevent users with appropriate 
permissions from modifying the document properties, such as logical nam
description, or requirement properties, such as attribute values and 
traceability relationships. When you lock a document, it remains locked u
you or another user with update permissions unlocks it.

To lock a document, do one of the following:

• In the Word Workplace, click RequisitePro > Document > Lock.

• On the Tool Palette, click Document > Lock.

A check mark appears next to Lock.

To unlock a document, do one of the following:

• In the Word Workplace, click RequisitePro > Document > Lock.

• On the Tool Palette, click Document > Lock.

The check mark next to Lock is cleared. Read- and write-access is allowed
the document.

Protecting Documents for Revisions
When you protect a document for revisions, you can electronically distrib
the document or make it available in a shared directory for reviewers to 
suggest changes. You can then merge the revisions in one document.

RequisitePro's Protect for Revisions command turns on Microsoft Word's 
Tools > Track Changes > Highlight Changes > Track changes while editi
option and makes that Word menu command unavailable. To protect you
documents, RequisitePro turns off the option for several operations: 
renumbering requirements, cutting and pasting requirements, creating or
deleting requirements, and importing a document.

Caution: Do not use the Track changes while editing or Revisions options 
on the Word Tools menu for requirements documents. Requirements ma
become corrupt if you use this feature instead of the RequisitePro Protect for 
Revisions command.
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To use RequisitePro’s Protect for Revisions command:

1. Do one of following:

• On the Tool Palette, click Document > Protect for Revisions; or 

• In the Word Workplace, click RequisitePro > Document > Protect for 
Revisions.

2. The Requirement dialog box appears.
A check mark appears next to the Protect for Revisions command. You
now distribute the document to reviewers or place copies of it in a sha
directory.

Note: Use RequisitePro's offline authoring feature to edit a document in
Word outside of RequisitePro. Or, to make a copy of a requiremen
document, use the Document > Save As command. 
(Refer to Working With Documents Offline on page 7-10 and Saving a 
RequisitePro Document as a Word Document on page 7-7.)

Using Outlines

Outlines are templates that are useful for maintaining consistency across
documents of the same type, such as software requirements specification
Outlines can help you quickly create user-needs documents, specification
and test plans.

Assign outlines to a document type in the Document Type tab in the Project 
dialog box. See Working with Document Types on page 15-1 for more 
information about document types.

Using RequisitePro Outlines
RequisitePro includes the following outlines that can be used when creat
document types in your project: 

• Product Requirements Document

• Software Requirements Specification

• Test Design Specification

• Test Case Scenario
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RequisitePro also includes these Rational Unified Process templates for 
requirements management: 

• Requirements Management Plan

• Stakeholder Requests Document

• Glossary

• Vision Requirements Outline

• Use Case Specification

• (Use Case) Software Requirements Specification

• (Non-Use Case) Software Requirements Specification

• Supplementary Requirements Specification

• Test Plan Document

• Test Case Scenario

Creating Your Own Outlines
1. Start Microsoft Word outside of RequisitePro.

2. Create a new template. (See the Word documentation for more informa
about creating templates.)

3. Move the new template and help file to the RequisitePro Outlines 
directory.

Note: Templates are automatically stored in the RequisitePro Outlines 
subdirectory. You can set a second location for additional templat
such as those shared on a network or used by a particular project
Use the Tools > Options command on the Tool Palette to specify a 
secondary location for the outlines. Type the full path and 
subdirectory name in the Outline Path field, and click OK .

4. In a text editor, create a new text file containing the following three lin
of information, separated by carriage returns (<CR>):

• The outline's full name, up to 64 characters
Important: Be sure that this logical name is unique in the Outlines 
directory.

• A description of the outline, up to 256 characters

• The Word template's DOS filename
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For example:
Acme Enterprises Standard Software Requirement Specifications<CR>

Standard outline used for Software Requirements Specifications at 

Acme Enterprises<CR>

acme_srs.dot

5. In the Outlines directory, save the text file, using the same file name as 
template and the extension .def (for example, acme_srs.def).

Renumbering Requirements

If the project is opened in exclusive mode, you can renumber all requirem
of one or more specified types in the requirements document and databa
This feature is useful to eliminate the “holes” in a numbering scheme that re
when you delete or move requirements.

Caution: Using the Track changes while editing command directly from 
Microsoft Word, and then renumbering requirements, will damage your 
document beyond repair. If you use RequisitePro's Document > Protect for 
Revisions command, RequisitePro will turn off the Track changes while 
editing option before renumbering and turn it back on once the renumber
operation is complete. RequisitePro's Protect for Revisions command will
damage your document.

For more information, refer to Renumbering Requirements on page 8-19 and 
Protecting Documents for Revisions on page 14-2.

Printing Project Summaries and Reports

Printing a Project Summary in RequisitePro
1. On the Tool Palette, click Project > Print  Summary.

2. Verify that the correct printer is selected.

3. Click OK .

Requirement Metrics
Requirement Metrics provides project managers and product analysts wit
capability of reporting statistics on RequisitePro requirements text, attribu
relationships, and revisions. These report results are displayed in Micros
Excel and can be manipulated using Excel’s charting capabilities.
14-5



Project Management

ing 

ith 
. A 
he 

ou 

 the 

 in 
. 

ying 

e 
 
r 
ur 

 

tion 

 Rose 

of 
You begin by creating one or more filters. A filter creates criteria for retriev
requirement information. For example, you would use an Attribute Count 
Filter to determine how many requirements in the project have a priority w
the value “High”. You then combine one or more filters to produce a query
query combines the criteria from multiple filters to analyze requirements. T
filters that compose a query are joined with the AND statement. Finally, y
combine one or more queries to produce a report.

There are two types of reports that are available in Requirement Metrics:

• A static report uses static filters and shows results about the project at
present time.

• A trend analysis report uses time-sensitive filters that analyze changes
requirement text, attributes, traceability, and hierarchical relationships
Trend analysis reports require that you specify an increment for displa
revisions.

The Requirement Metrics main window is the primary user interface for th
application. This window allows you to select a requirement type for your
report, choose filters and filter criteria, build queries and add them to you
report. As you add filters to your queries, you limit the requirements in yo
report to only those requirements that match your filter criteria.

Access Requirement Metrics with the Tools > Metrics command on the Tool 
Palette. For more information, refer to the online help included with 
Requirement Metrics.

Using Rational SoDA with RequisitePro
RequisitePro is integrated with SoDA, Rational’s software documentation
automation tool.

Using SoDA and RequisitePro, you can:

• Modify and generate SoDA reports and documents from an open 
RequisitePro project. 

• Create a report that consolidates RequisitePro requirements informa
and Rose modeling information. 

• Create a use case report that includes all use case requirements and
use case diagrams.

Before you begin the following procedure, make sure the current version 
SoDA for Word is installed and a RequisitePro project is open.
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1. On the Tool Palette, click Project > Generate SoDA Report. The SoDA 
dialog box appears, showing a list of templates for use with Requisite

2. Select a template from the list and click OK . SoDA for Word appears. The
SoDA menu is active and the selected template is open.

3. Use the template to create a SoDA report from the open RequisitePro
project. Refer to the SoDA documentation for more information about
generating SoDA reports.

Refer to SoDA documentation for more information about generating SoD
reports.

Note: Do not begin generating a second SoDA report while the progres
indicator is active.

Archiving Projects

RequisitePro provides four methods for archiving projects: 

• The Archive command in RequisitePro

• Rational ClearCase

• Microsoft Visual SourceSafe

• Intersolv PVCS Version Manager

RequisitePro integrates with Visual SourceSafe PVCS Version Manager 
providing an interface directly into your archives. For projects archived w
ClearCase, you must use the ClearCase interface to access non-tip revis

You must have ClearCase, SourceSafe or PVCS Version Manager installe
your system to use these archiving options with RequisitePro. If you do n
have one of these applications, you can use the Archive command in 
RequisitePro.

Since RequisitePro is a multi-user tool itself, it uses the above application
differently than version control tools are traditionally used. All users check 
the projects into a shared location. Users only check in the projects to pro
an archiving history, or snapshot view, to review over time.

Note: The archive features are not available for projects that use an Or
or SQL Server database. Use your database administration tools 
back up projects and documents in those databases.
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Archiving Projects with the Archive Command
Using the Archive command in RequisitePro, you can store a project and m
a backup copy of a project.

To archive projects with RequisitePro’s Archive command:

1. On the Tool Palette, click Project > Archive > RequisitePro Archive. 
The Archive Project dialog box appears:

2. Select the directory where you want the backup copy stored. Click Browse 
to open the Browse for Folder dialog box, where you can specify an 
existing directory. 
Once you have selected a directory, click OK to close the dialog box.

Note: To create a new subdirectory, click at the end of the directory 
field and add a backward slash (\) followed by a new subdirect
name.

3. Enter a new revision number for the project. It must be greater than o
equal to the current revision number (in the form xxxx.yyyy).

4. To apply the revision number to the requirement documents, mark the
Propagate to all documents check box.

Note: If security is enabled, you must have project structure permiss
to propagate the revision number. You must also have the pro
opened exclusively.

5. Enter the a name for the archived version in the Version Label text box 
and a description for it in the Change Description text box.
14-8



Archiving Projects

g 

ase 
it 
oject 
e 

L 
up 

you 
es 

ase 
ents 

sers 

ing. 
 

ic 

 

Archiving Projects with ClearCase
Rational ClearCase is a version manager that uses a snapshot view of 
RequisitePro project and its documents. ClearCase does not track ongoin
document-level revisions.

Integration with ClearCase works at the project level by copying a 
RequisitePro Access database and associated documents to an existing 
Versioned Object Base (VOB) in ClearCase.

Unlike the other version managers you can use with RequisitePro, ClearC
does not remove the project from your RequisitePro project list. Instead, 
serves as an interface to manage project check in and check out. Your pr
list is updated to point to the archived copy of the database rather than th
original.

Note: This feature is not available for projects that use an Oracle or SQ
Server database. Use your database administration tools to back 
projects and documents in those databases.

Setting Configurations to Use ClearCase

Before archiving RequisitePro projects using integration with ClearCase, 
must configure ClearCase and RequisitePro to work together. This includ
creating a VOB in ClearCase and setting a destination directory for 
RequisitePro project archives. The destination directory must be a ClearC
shared view for all users of the project. The database and all project docum
will be checked out to this shared view, and will then be accessible to all u
of the project. 

Do the following to set up RequisitePro integration with ClearCase:

Create a target VOB and a snapshot view in ClearCase, or check with your 
ClearCase administrator to learn which VOB and view your team will be us
We recommend you create a separate VOB to archive your RequisitePro
artifacts.

Note: If you intend to update the RequisitePro database from within a 
ClearCase view, you must use a snapshot view. ClearCase dynam
views do not support concurrent updates to the Access database.

Set the destination directory in RequisitePro:

Note: Before setting a destination directory, check with your ClearCase
administrator, if you have one. Setting this directory will affect 
anyone using project archives.
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1. On the Tool Palette, click Tools > Options. The Options dialog box 
appears.

2. Type a target VOB location (drive, viewname, vobname, directory) in 
ClearCase View field.

Use UNC naming conventions for a shared drive. This step defines the vie
which the RequisitePro database and documents will be copied during th
archive functions.

3. Click OK .

Now you are ready to add RequisitePro projects to ClearCase.

Adding Projects to ClearCase

When you add a project to ClearCase, the project is not removed from yo
RequisitePro project list, but the project files are copied from their curren
location to the specified directory, where they are managed by ClearCase
must have exclusive access to a project to add it to the ClearCase archiv

1. On the Tool Palette, click Project > Archive > Rational ClearCase.
The ClearCase dialog box appears.

2. Click Add Project. The Add Project to ClearCase dialog box appears.

3. In the listing of projects in your project list, select the project, and then
click OK .
The Check into ClearCase dialog box appears.

4. Accept the Revision number (which defaults to the latest version of the
project), or enter a new revision number for the project.

Note: If you enter your own revision number, you must use X.Y form
and enter a number higher than the current project revision 
number.

5. To apply the revision number to the requirement documents as well as
project, select the Propagate to all documents check box.

Note: If security is enabled, you must have project structure permiss
to propagate the revision number.

6. In the Version Label and Change Description text boxes, enter the 
appropriate information. The version label you choose here appears i
ClearCase and can be viewed in a Version Tree.

Note: The only information stored by ClearCase is the change 
description; the rest of the information is used by RequisitePro
14-10
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Note: You can check a project back in without retaining the 
modifications you have made by clicking Unlock Project in the 
ClearCase dialog box.

7. Click OK .

RequisitePro copies the associated database and Word files and checks
into the identified ClearCase VOB. It also updates your project list to poin
the archived copy of the database rather than the original.

Checking Projects into ClearCase

When you are finished working on a project, you can check it back into th
ClearCase manager. For security purposes, only the user who checked t
project out can check the project back in. When a project is checked in, t
project’s revision number is incremented.

1. On the Tool Palette, click Project > Archive > Rational ClearCase.
The ClearCase dialog box appears.

2. In the RequisitePro Projects in ClearCase listing, select the project.

3. Click Check In. The Check into ClearCase dialog box appears.

4. Accept the Revision number (which defaults to the latest version of the
project), or enter a new revision number for the project.

Note: If you enter your own revision number, you must use X.Y form
and enter a number higher than the current project revision 
number.

5. To apply the revision number to the requirement documents as well as
project, select the Propagate to all documents check box.

Note: If security is enabled, you must have project structure permiss
to propagate the revision number.

6. In the Version Label and Change Description text boxes, enter the 
appropriate information. The version label you choose here appears i
ClearCase and can be viewed in a Version Tree.

Note: The only information stored by ClearCase is the change 
description; the rest of the information is used by RequisitePro

Note: You can check a project back in without retaining the 
modifications you have made by clicking Unlock Project in the 
ClearCase dialog box.

7. Click OK .
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Checking Projects out of ClearCase

You check a project out of ClearCase to make revisions to it. 

1. On the Tool Palette, click Project > Archive > Rational ClearCase.
The ClearCase dialog box appears.

2. In the RequisitePro Projects in ClearCase listing, select the project.

3. Click Check Out. The project is checked out for write-access. The sta
in the ClearCase dialog box changes from Checked in to Checked Out.

Note: You can check a project back in without retaining the modification
you have made by clicking Unlock Project in the ClearCase dialog 
box.

Undoing (Unlocking) Checked-out Projects in ClearCase

The undo feature (also called the unlock feature) is useful when you do n
want to retain the modifications made to a project when you or another u
checked it out, or if a project was inadvertently checked out. This feature
checks the project in exactly as it was checked out. The revision number i
increased, and any modifications that were made to the project when it w
checked out are not saved.

1. On the Tool Palette, click Project > Archive > Rational ClearCase.
The ClearCase dialog box appears.

2. In the RequisitePro Projects in ClearCase listing, select the project.

3. Click Unlock Project. A dialog box appears, asking you to confirm the
procedure.

4. Click Yes. The project is checked in without retaining any changes ma
when it was checked out.

Viewing Non-tip Revisions in ClearCase

Integrated with RequisitePro, ClearCase only displays the snapshot view, 
revision of a project. You cannot view previous versions of a project (non
revisions) in the RequisitePro/ClearCase interface. Instead, you must ope
version manager through the ClearCase software itself.

Refer to ClearCase online help for more information about working with 
ClearCase.
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Archiving Projects with Visual SourceSafe
Visual SourceSafe manages project versions. You can use Visual Source
to:

• Store a backup copy of your project

• Check a project in and out

• Gain read-only access to earlier versions of the project

Logging on to Visual SourceSafe

Before you can use Visual SourceSafe to archive RequisitePro projects, 
must log on through RequisitePro. You must log on even if you already h
Visual SourceSafe open on your system.

To log on:

1. On the Tool Palette, click Project > Archive > Visual SourceSafe. The 
Visual SourceSafe Login dialog box appears.

2. Enter your user name and password.

Note: Enter your Visual SourceSafe user name, not your RequisiteP
user name. Note that they may be the same.

3. Specify the path for the srcsafe.ini file. Click Browse to specify a different 
location for the srcsafe.ini file. 

Note: This file is the .ini  file in the root directory of your Visual 
SourceSafe database.

4. Click OK .

Adding Projects to Visual SourceSafe

When you add a project to Visual SourceSafe, RequisitePro removes the
project from your project list. To access the project, you must check the pro
out of Visual SourceSafe. When you check the project out, RequisitePro 
increments its revision number.

1. Log on to Visual Source Safe as described above. The Visual Source Safe 
dialog box appears.

2. Click Add Project. The Add Project dialog box appears.

3. Select the project, and then click OK . If security is enabled, the 
RequisitePro Login dialog box appears.
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4. Enter your RequisitePro user name and password, and click OK . The 
Check In dialog box appears.

5. In the RequisitePro Version text box, enter a new revision number for th
project (equal to or greater than the value displayed). Use the integer
four-decimal format (for example, 12.1234). This step is optional.

The default number is 1 plus the current revision number. If the revisi
number reaches x.9999, the first number (x) increments by 1, and the
number is reset to 0000.

Note: If security is enabled, you must have project structure permiss
to propagate a revision number.

Note: The VSS Version number appears in the VSS Version text bo
and cannot be changed.

6. Select Propagate to all documents if you want to apply the new revision
number, version label, and change description to all documents. If you
not select this check box, RequisitePro applies the new number to the
project, but not to its associated documents.

7. In the Version Label text box, enter a label that briefly describes the 
revision, up to 20 characters. This step is optional.

8. In the Change Description text box, enter a description of changes for th
revision. This text is placed in the Comments of each item you check into
Visual SourceSafe. This step is optional.

9. Mark the Keep checked out check box if you want the project to remain
in the RequisitePro project list and the files to remain on the file syste
when you check the project into Visual SourceSafe. If you clear this ch
box, the project files are removed from the file system and the 
RequisitePro project list until you check them out of Visual SourceSaf

10. Click OK .

Checking Projects into Visual SourceSafe

If a project has been previously checked out of Visual SourceSafe for wri
access, you can check in the project. To perform this procedure, your use
name must match the name of the user currently logged on to RequisiteP

1. Log on to Visual Source Safe as described in Logging on to Visual Sourc-
eSafe on page 13. The Visual Source Safe dialog box appears.

2. In the Project Revisions list, select the revision you want to check in.
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3. Click Check In. If security is enabled, the RequisitePro Login dialog box 
appears.

4. Perform the login instructions outlined in the previous procedure, Adding 
Projects to Visual SourceSafe on page 13. Begin at step 4.

Checking Projects Out of Visual SourceSafe

You can only check out the most recent version (tip revision) of a project 
write or read-access. The project revision status changes from checked in to 
checked out, and the project is added to your RequisitePro project list. On
one user can check out a project at a time.

1. Log on to Visual Source Safe as described in Logging on to Visual Sourc-
eSafe on page 13. The Visual Source Safe dialog box appears.

2. In the Project Revisions box, select the tip revision of the project. If the
project is not currently checked out, VSS displays revisions for the pro
and enables the Check Out button.

3. Click Check Out. The Check Out dialog box appears.

4. Specify the directory to which you want the project checked out.

5. To specify read-only privileges for tip revisions, select the Read only 
check box. 

This option is enforced for non-tip revisions, which can only be check 
read-only. For tip revisions, checking out a project read-only retrieves
tip revision of the project, but does not check out the project in your na

6. If you want to store all documents in the project directory, mark the Check 
out remote documents to project directory check box.

This option is only applicable when documents reside in directories th
are different than the project directory. This checkbox is selected by 
default for read-only tip revisions.

7. Click OK .

Viewing Non-tip Revisions in Visual SourceSafe

You can view previous versions of a project (non-tip revisions) stored in 
Visual SourceSafe. You view such projects in read-only mode. Requisite
copies and stores the project in the directory you select.
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1. Log on to Visual Source Safe as described in Logging on to Visual Sourc-
eSafe on page 13. The Visual Source Safe dialog box appears.

2. In the RequisitePro Projects in VSS box, select the project.

3. In the Project Revisions dialog box, select the revision of the project.

4. Click Get. The Get dialog box appears.

5. Specify the directory to which you want the project checked out.

Note: The Read only check box and the Check out remote documents 
to project directory check box are marked by default for non-tip
revisions.

6. Click OK .

Viewing Project Components in Visual SourceSafe

The components of a project consist of the versions of the project file, the
files, and the documents that belong to the selected revision. The file nam
version number, status, date checked in or out, and user are listed for eac
in the project.

1. Log on to Visual Source Safe as described on Logging on to Visual Sourc-
eSafe on page 13. The Visual Source Safe dialog box appears.

2. In the RequisitePro Projects in VSS box, select the project.

3. In the Project Revisions dialog box, select the revision of the project.

4. Click Components. The Project Components dialog box appears, where
you can view the components of the project.

5. When you are finished viewing project components, click Close.

Deleting Projects from Visual SourceSafe

You can delete the archived files from Visual SourceSafe. This does not d
the project, but simply removes it from Visual SourceSafe.

1. Log on to Visual Source Safe as described on Logging on to Visual Sourc-
eSafe on page 13. The Visual Source Safe dialog box appears.

2. In the RequisitePro Projects in VSS box, select the project to remove.

3. Click Remove Project. A message appears, asking you to confirm the 
deletion.

4. Click OK .
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Archiving Projects with the PVCS Version Manager
PVCS Version Manager manages project versions. You can use PVCS Ve
Manager to check a project in and out, and to gain read-only access to e
versions of the project. In addition, PVCS Version Manager stores a back
copy of your project.

Adding Projects to the PVCS Version Manager

When you add a project to the PVCS Version Manager, the project is remo
from your RequisitePro project list. You must then check the project out fr
the PVCS Version Manager to access it in RequisitePro.

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Click Add.

3. Select the project from your list of RequisitePro projects, and then clic
OK .

4. In the Check into PVCS Version Manager dialog box, enter the 
appropriate information for the project, and then click OK .
PVCS removes the project from your RequisitePro project list and sto
it in the PVCS Version Manager archive. To use the project again, yo
must check it out of PVCS Version Manager.

Note: If security is enabled, you must have project structure permission
propagate a revision number. 

Checking Projects Out of the PVCS Version Manager

You can only check out the most recent version of a project (tip revision) st
in the PVCS Version Manager for write-access. The project revision Statu
changes from In to Out, and the project is added to your RequisitePro proje
list. 

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Select the project in the Projects in PVCS listing.

3. Select the project revision in the Projects Revision listing.

4. Click Check Out (write) or Check Out (read).

You can only edit the most recent version (write-access).

5. Accept the default location or specify a directory location where you w
the project stored.
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Checking Projects into the PVCS Version Manager 

For security purposes, only the user who checked the project out can chec
project back in. You cannot check a project in that has not been modified
When you check a RequisitePro project into PVCS Version Manager, it is
removed from your RequisitePro project list. 

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Select the project from the RequisitePro Projects in PVCS listing.

3. Select the current revision in the Project Revisions listing.

4. Click Check In.

5. Accept or enter a new Revision number for the project.

6. Select the Propagate to all documents check box to apply the revision 
number to the requirement documents.

Note: To propagate the revision number, you must have project structur
permission if security is enabled.

7. Type the appropriate information in the Version label and Revision 
Change description text boxes.

Viewing Non-tip Revisions in PVCS

You can view previous versions of a project (non-tip revisions) stored in t
PVCS Version Manager in read-only mode. The project is copied and store
the directory you select.

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Select the project in the Projects in PVCS listing.

3. Select the project revision in the Projects Revision listing.

4. Click Check Out (read).

5. Enter a directory location to store the project.
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Updating Projects in the PVCS Manager

You can rapidly check a project in and out again and thus increment the 
revision number. The project revision status changes from “In” to “Out” an
the project is added to your RequisitePro project list. Use this option if yo
want the archived version of the project to be current, but still want the pro
checked-out for editing.

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Select the project in the RequisitePro Projects in PVCS listing.

3. Select the tip (most recent) revision in the Projects Revision listing.

4. Click Update.

5. Type the relevant information in the dialog box.

Unlocking Checked-out Projects in PVCS Version Manager

The unlock feature is useful when you do not want to retain the modificati
made to a project when it was checked out or when a project was inadvert
checked out. This feature checks the project in exactly as it was checked
The revision number is not increased, and any modifications that were ma
a project when it was checked out are not saved.

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Select the project in the Projects in PVCS listing.

3. Select the checked out revision of the project in the Project Revisions list.

4. Click Unlock.

Removing Projects from the PVCS Version Manager

You can delete the archived files and delete the subdirectory where the 
archived files were located. This does not delete the project, but removes
from PVCS Version Manager.

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Select the project in the Projects in PVCS listing.

3. Click Remove from PVCS.

Note: This command deletes the archived files from the directory and 
deletes the subdirectory where the archived files were located. 
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Viewing Project Components in the PVCS Version Manager

The components of a project consist of the project database and any docu
that are associated with it. The file name, revision number, status, date che
in or out, and user are listed for each file in the project.

1. On the Tool Palette, click Project > Archive > PVCS Version Manager.

2. Select the project in the Projects in PVCS listing.

3. Select the project revision in the Projects Revision listing.

4. Click Components.

Removing a Project’s Revision Information

You can delete the change histories of the project, their revision numbers
associated requirements documents, and all requirements created in the
project. This helps keep the project database size smaller.

To remove revision information, you must have the project opened 
exclusively (for more information, refer to Opening a Project and Documents
on page 3-4). Revision information stored in archived projects is not dele

To remove revision information:

1. On the Tool Palette, click Project > Remove Revisions.
The Remove Revisions dialog box appears. 

The Before Date text box in the Remove Revisions dialog box 
automatically populates with the current date.

2. To change the date, click the Before Date text box and modify the date as
needed. 

3. Click OK . RequisitePro displays a dialog box describing the deletions

4. If you want to remove the revision information, click Yes. If you do not 
want to remove the revision information, click No.
14-20
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Removing Documents and Requirements from a 
Project Database

When a document and its requirements are removed from the project 
database, the requirement formatting and the requirements are deleted 
(although the text remains) and the document can only be referenced ou
RequisitePro as a Word document. The project must be opened exclusive
perform this operation (for more information about the exclusive option, re
to Opening a Project and Documents on page 3-4).

To remove documents and requirements:

1. Open the document in RequisitePro. 

2. Do one of the following:

• In the Word Workplace, click RequisitePro > Document > Remove.

• On the Tool Palette, click Document > Remove. 

A confirmation dialog box appears.

3. To remove the document, click Yes. To cancel the operation, click No.

Moving Projects

If you are using an Access database for your RequisitePro project, you c
move the project to a new location, such as a different server.

To move the project:

1. Remove the project from your list of projects. Click Project > Open, se-
lect the project name in the Select a Project field and click Remove.

2. Copy the project files to your new location using Windows Explorer.

3. Add the project in its new location to the list of projects. Click Project > 
Open, and click Add at the Select a Project field.
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4. Rename the original project directory and all directories that contain 
project documents. This way you have a backup in case anything goe
wrong. You can delete this directory once you are comfortable that th
move was successful.

Note: If you want to save a copy, of the original directory, don’t delete it
See Copying Projects below.

5. Open your project in RequisitePro. The first time you open a project 
document that is not stored in the project directory, you will be promp
to locate the document. Select it from the new location.

Note: If you have documents that are not stored in the project directory,
when you open a document, you may be prompted to find it, and 
select it from the new location.

Copying Projects

Access Database Projects
Do not attempt to copy a RequisitePro project that uses a Microsoft Acce
database by copying the project directory from one location to another. In
case, internal unique identifiers may cause conflicts if the project uses cr
project traceability.

There are two types of copying functions you can perform:

• You can move a project to another location and keep a backup copy. R
to Moving Projects on page 14-21.

• You can create a new project that uses an existing project as a templ
Document types, requirement types, attributes, user and group 
permissions, and views are all copied to the new project. Refer to Creating 
a Project Using an Existing Project as a Template on page 12-8. 

You can also split a project. Before you begin, we strongly recommend y
archive your original project.

1. Use the Project > Archive command to make a physical copy (B) of y
RequisitePro project (A).

2. Open your copy (B) in RequisitePro and change the project name unde
General tab of the Project > Properties dialog box.
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3. You can then delete requirements in each project to be left with one c
of each requirement in each project. See deleting requirements for m
information.

Note: When performing any of the above procedures, note that you can
merge the two copies of projects back together into one project.

Enterprise Database Projects
Do not attempt to create a copy of a project that uses an Oracle or Micro
SQL Server database. In this case, copying the project directory does not
the project database. Both copies of the project will continue to point to th
same enterprise database instance. Conflicts between document and 
requirement updates will result.

Converting a Database

The Database Type Conversion Wizard is included with RequisitePro. It 
enables you to convert a RequisitePro project from one database type to
another.

In most cases, the wizard is used to convert a project that uses a Microso
Access database to an enterprise database (Oracle or Microsoft SQL Se
however, the wizard also supports the conversion of a project from an 
enterprise database to Access.

The Database Type Conversion Wizard requires that the following conditi
be met prior to performing the database type conversion. The wizard disp
messages to alert you if any conditions are not met.

• The project must be saved in the current version of RequisitePro. 

• You must have administrator permissions for the project.

• You must have log on and write permissions for the target database.

• Your database administrator must supply you with the user name and
password, a server name, and a schema name in order to access the
enterprise database.

Caution: It is strongly recommended that you archive or backup both the 
source and the destination database and related documents before conti
with the database type conversion.
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To start the Database Type Conversion Wizard:

Note: Make sure to close any open RequisitePro project before starting
wizard.

• Open the Database Type Conversion Wizard in Windows Explorer. T
executable, rqdbtypewiz.exe, is located in the Rational\RequisitePro 
4\bin\ directory.

• The Database Type Conversion Wizard introduction screen appears. 
screen of the wizard includes a Help button. To view step-by-step 
instructions about using the screen, click the Help button in that scree
14-24
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Project Information

Project managers can modify information about a project, including:

• Document types

• Requirement types

• Requirement attributes

• Attribute values

• Cross-project traceability

Working with Document Types

You can create document types and modify existing document types. If yo
longer need a document type, you can remove it.

A document type defines descriptive and operational information associa
with a requirements document. The document type serves as a template 
each requirements document you create of that type.

The document type defines the document’s file extension, such as .prd; a
documents of the same document type share the same file extension. Th
document type identifies a default requirement type; each new requiremen
create in the document will be based on the default requirement type unles
indicate otherwise. The document type also identities an outline (or temp
for the document, which controls its page layout, default text, paragraph st
etc.
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Creating and Modifying Document Types
1. On the Tool Palette, click Project > Properties. The Project dialog box 

appears. 

2. Click the Document Types tab.

3. Do one of the following:

• To add a new document type, click Add.

• To modify an existing document type, select the requirement type in
list, and then click Edit .

The Document Type dialog box appears.

4. In the Name text box, type a unique name for the document type.
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Working with Requirement Types

ith 

at is 

e 

 new 

.

e.

. If 

ated 

 
es 
h as 
ing. 
5. In the Description text box, type a description. 

6. In the File Extension text box, type a file extension. Enter a three-
character text string, or, if long file names are supported, a longer 
extension. The file extension is applied to all documents associated w
the document type.

7. Select a requirement type in the Default Requirement Type list. The 
default requirement type is used to specify the type of requirement th
created when Fast Create is used. 

8. In the Name text box below Outline, select an outline to associate with th
document type. If you use the default selection, None, Word’s normal.dot 
template is used. If you select a new outline, the new outline applies to
documents only. Existing documents are not affected by the change. 

9. Click OK . The new or modified document type appears in the list box

10. Click OK  in the Project dialog box.

Removing Document Types
If no documents of a particular document type exist in a project, you can 
remove the document type.

1. On the Tool Palette, click Project > Properties. The Project dialog box 
appears.

2. Click the Document Types tab. 

3. In the Document Type list, select the document type you want to remov

4. Click Remove.

Working with Requirement Types

You can create requirement types and modify existing requirement types
you no longer need a requirement type, you can remove it.

A requirement type defines descriptive and operational information associ
with a requirement. A requirement type serves as a template for all 
requirements of the same type and is useful for ensuring consistency and
classifying or grouping similar requirements in a project. Requirement typ
can specify: the initial numbering of the requirements; required terms, suc
“must” or “shall”; a standard prefix, such as PR; and color and text formatt
Each requirement type has a unique set of user-defined attributes. 
15-3
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Creating and Modifying Requirement Types
1. On the Tool Palette, click Project > Properties.

The Project dialog box appears.

2. Click the Requirement Types tab.

3. Do one of the following:

• To add a new requirement type, click Add.

• To modify an existing requirement type, select the requirement type
the list, and then click Edit .

4. The Requirement Type dialog box appears.

5. In the Name text box, type or edit a name for the document type.
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6. In the Description text box, type or edit a description. 

7. To enable external traceability between requirements of this type in th
project and other projects, select the Allow External Traceability  check 
box.

8. To specify the starting number for the first requirement of the defined ty
click the Initial Requirement Number  text box and type a positive 
integer to start this sequence. RequisitePro automatically numbers 
requirements when they are created. 

The default value for this text box is 1. The initial number sequence ca
modified any time before the first requirement of this type is created. Onc
the first requirement of this type has been saved, you must use the 
Renumber Requirements dialog box to change the sequence. 

9. In the Requirement Must Contain text box, type a single word or phrase
that must be included in every requirement of this type that is created. 
field is optional and is not case-sensitive.

Note: Exclusive access to a project is necessary to modify the value
the following three steps for an existing requirement type. The
options can be modified at any time.

10. In the Requirement Tag Prefix text box, type or edit a tag prefix. 
Examples of tag prefixes are SR, PR and TST. 

11. In the Requirement Color list, click the down arrow and select a color. 
The color is assigned to a requirement of this type when it is displaye
a document. The default color is blue.

12. In the Requirement Style list, click the down arrow and select a style. Th
style is assigned to a requirement of this type when it is displayed in a
document. The default style for this text box is Double Underline. You 
can also select Normal (no styling) or Small Capitals. 

13. Click OK . In the Project dialog box, Requirement Types tab, 
RequisitePro displays the new or edited requirement type with its tag
prefix and logical name. For example, TEST: Test Plan.

14. Click OK  to close the Project dialog box.
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Removing Requirement Types
You can remove a requirement type if there are no requirements of this typ
the project and if document types do not reference it as a default. You mu
have the project opened in exclusive mode to remove requirement types.

1. On the Tool Palette, click Project > Properties. The Project dialog box 
appears.

2. Click the Requirement Types tab.

3. Select the requirement type you want to remove.

4. Click Remove.

5. Click OK .

Working with Requirement Attributes

Use the Attributes  tab in the Project dialog box to add an attribute. You can
also use this tab to modify an existing attribute.

The following table shows suggested attributes that can be helpful for defi
your requirements in RequisitePro. These attributes are suggestions, not 
You can use these suggested attributes, which are provided with Requisit
or you can define and use any attributes that are appropriate for your pro
and business.

Attribute Use to identify requirements by

Priority Importance to the project. Helps team members prioritize their
efforts and use their time more effectively.

Status Progress.

• If a requirement’s status is Proposed, the requirement 
is currently being discussed by the project team. 

• If a requirement’s status is Approved, the requirement 
has been discussed and agreed upon.

• If a requirement’s status is Incorporated, the 
requirement has been added to the appropriate 
specification.

Authors Individual or team that created or changed the requirement’s 
text or attributes.
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Note: The list of requirement attributes above provides examples. Othe
common attributes include Difficulty, Stability, Risk, Security, Safety, 
Release Implemented and Functional Area.
In addition to the attributes mentioned above, RequisitePro mainta
system attributes for all requirement, including date, version and 
relationship to other requirements.

You can create and control attributes according to your needs. Regardles
the attributes you use, RequisitePro offers the flexibility to easily customi
your project documents and databases to define, articulate and manage 
processes and culture of your organization.

You cannot remove requirement attributes if requirements of the requirem
type already exist, or if the requirement type is the default of a document t

Creating and Modifying Requirement Attributes
Use the Attributes  tab in the Project dialog box to describe the 
characteristics or properties of a requirement type. 

1. On the Tool Palette, click Project > Properties. 
The Project dialog box appears.

2. Click the Attributes  tab.

Responsible Party Individual or team responsible for ensuring the requirement 
satisfied.

Rationale Text of or reference to an explanation. For example, the 
reference might be to a page and line number of a product 
requirement specification, or to a minute marker on a video 
tape of an important customer interview.

Cost Cost to implement the requirement. The attribute value for this
attribute can be logical (high, medium, low) or numerical.

Attribute Use to identify requirements by
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The attributes for the selected type are displayed in the same sort order a
the Requirements dialog box.

3. To reorder attributes, select the attribute in the Labels list and then click 
the Move Up or Move Down button. 

4. For list-type attributes, to designate a value as the default value, selec
attribute in the Label box. In the Values per Attribute box, select the 
value and click Default.

5. To add an attribute, click Add.
The Add Attribute  dialog box appears. 

6. In the Type list, select a type. The following data types are supported:

Data Type Allows Example

List (Single 
Value)

A set of values from which a single 
value can be selected. Each List value 
can be up to 20 characters in length.

High, Medium or Low

List (Multiple 
Value)

A set of values from which more than 
one value can be selected. Each List 
value can be up to 20 characters in 
length. 

Sue, Bob, John

Text A text string. John Smith

Integer Whole numbers in the field. 5 or 1500

Real Real numbers in the field. 1.345 or 6.7
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The dialog box changes, depending on the type you select. If you sel
List (Single Value) or List (Multiple Value) , the dialog box contains a 
List Values text box. If you select one of the other types, the dialog bo
contains a Default Value text box.

7. In the Label text box, type a name.

8. If the data type is a list-type, in the List Values text box, type the values. 

9. If the data type is an entry-type, enter a default value (optional). If a n
requirement is created and a value is not specified for the attribute, 
RequisitePro uses the default value.

10. To ensure traceability relationships are marked as Suspect when attributes 
are changed, mark the Change Affects Suspect check box. When this 
check box is selected, RequisitePro monitors all requirements (based
this requirement type) and ensures that the status of all relationships 
labeled Traced to and Traced from for this requirement is changed to 
Traced-Suspect if the attribute value is changed.

11. Click OK . The new or edited attribute appears in the Attributes  tab of the 
Project dialog box.

12. Click OK  to close the Project dialog box.

Date A date in the format defined by the 
user’s Windows setting. 

mm/dd/yy

Time A time in the format defined by a 
user’s Windows setting. 

10:00 AM

Data Type Allows Example
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Working with Requirement Attribute Values

You can add and edit the values assigned to a particular list-type attribute
you can remove an attribute value.

Modifying Attribute Values
1. On the Tool Palette, click Project > Properties. The Project dialog box 

appears.

2. Click the Attributes  tab.

3. In the Requirement Type list, select the requirement type.

4. In the Labels for Attributes  list, select a single or multiple-value list-type
attribute.

5. In the Values per Attribute list, select the value that you want to edit.

6. Click Edit . The Attribute Value  dialog box appears. 

7. In the Value text box, modify the value.

8. To use the value as the default value, mark the Use as default check box.

9. Click OK . The changes to the attribute values appear in the Attributes  tab 
of the Project dialog box.

10. Click OK  to close the Project dialog box.

Removing Attribute Values
To remove attribute values, you must have the project opened exclusivel

1. On the Tool Palette, click Project > Properties. The Project dialog box 
appears.

2. Click the Attributes  tab.

3. In the Requirement Type list, select the requirement type.

4. In the Labels for Attributes  list, select the list-type attribute.
15-10
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5. In the Values per Attribute list, select the value that you want to remov

6. Click Remove. 

If the value is not assigned to any requirements in the project, the valu
removed.

If the value is assigned to any requirements in the project, the Remove 
Value dialog box appears:

• In the list, select a value to use as a replacement for the removed v

• Click OK . The value is removed from the Values per Attribute list.

7. Click OK  to close the Project dialog box.

Setting Up and Modifying Cross-Project Traceability

Cross-project traceability enables direct traceability relationships between
requirements in different RequisitePro projects. This RequisitePro feature
eliminates duplication by allowing reuse of requirements among various 
teams working on related projects. Often a set of requirements is commo
multiple projects. These requirements can be created in their own 
RequisitePro projects and traced to system-specific requirements located
their respective RequisitePro projects.

Projects must be created prior to setting up cross-project traceability. You
configure projects to automatically connect to external projects when a 
project with externally traced requirements is opened. You can also conn
external projects manually.

After you connect an external project, all externally traced requirement ty
are available for traceability relationships. External requirement types are
displayed in the RequisitePro dialog boxes used to create traceability 
relationships. External requirements are identified with a project prefix se
the General tab of the Project dialog box for the external project.
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Marking Requirement Types for Cross-Project Traceability
To allow cross-project traceability for requirements in a project, you must
the following:

• Assign a project prefix.

• Manually mark requirement types in the project as externally availab
Only requirements of these types will be available for cross-project 
traceability.

1. On the Tool Palette, click Project > Properties. The Project dialog box 
appears.

2. If it is not already displayed, click the General tab.

3. If the project does not have a prefix, enter a prefix for the project, up t
characters. The prefix is stored in uppercase letters. You can change
any time.

4. Click the Requirement Types tab.

5. In the Requirement Type list box, select the requirement type to mark fo
external traceability.

6. Click Edit .

The Requirement Type dialog box appears.

7. Mark the Allow External Traceability  check box.

8. Click OK . 

RequisitePro marks the requirement type for cross-project traceability
15-12
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9. Repeat steps 5 through 8 for any other requirement types.

10. Click OK  to close the Project dialog box.

Connecting Projects
Once the requirement types in the external projects have been marked fo
external traceability, connect the external projects to the currently open 
project. 

To view external projects, click Project > External Projects.
The External Projects dialog box appears.

It displays the following:

• Prefix - an identifier for the project. In an external project, the projec
prefix appears before the requirement tag, separated from the tag b
decimal. For example, if a requirement’s tag is PR234 and the proje
prefix is GLOBAL, then the external requirement is displayed as 
GLOBAL.PR234. The prefix can be up to 8 characters, and must be
uppercase letters. You can change the prefix at any time in the General 
tab of the Project dialog box.

• Name - the name of the external project.

• Status - indicates whether the project is currently connected or 
disconnected.

• Location - indicates the location of the project.
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To add a project as an external project:

1. In the External Projects dialog box, click Add. The Add external project 
dialog box appears.

2. Locate the project and click Open.

3. To automatically open the external project when the current project is
opened, click the Connect to the external projects at project open check 
box.

Note: In this case, when you open the project, one of several condit
apply:

• If neither project is secured, you are not required to log on to 
project.

• If the project is secured and your user name and password 
different than those used to log on to the secured project, the 
Project Logon dialog box appears. Log on to the project as yo
normally would. (If your user name and password are the sam
both projects, you will not be required to log on multiple times

• If the project is not secured and the external project is secur
the Project Logon dialog box appears. Log on to the project as
you normally would. 

4. To connect other external projects, repeat the above steps.

5. To remove a project from the External Projects dialog box, select the 
project and click the Remove button.

Note: If you remove a project with requirements that participate in 
external traceability, RequisitePro warns you about deleting th
references. 

If the external project is not accessible, RequisitePro warns yo
the current project will be updated and the external project wil
contain invalid references until it is opened and synchronized.

If an external project is moved, an error message appears, 
indicating that the project cannot be found. 

6. Select the project from the External Project References list, and click 
Browse to relocate the project. Locate the project and click Open. 

Note: The Browse button is only active when a project has been mov
or cannot be located.
15-14



Setting Up and Modifying Cross-Project Traceability

 are 

g 
 you 

 

h a 

 

e 
Disconnecting Projects
You can disconnect external projects when they are not needed or are 
unavailable. For example, you may want to disconnect projects when you
working in a distributed mode and the database is unavailable. 

If you are not currently working on traceability relationships, disconnectin
will increase system performance. A project must be disconnected before
can relocate it.

1. On the Tool Palette, click Project > External Projects.
The External Projects dialog box appears. 

2. Select the project and click Disconnect. This temporarily disconnects the
project. 

3. To reconnect the project, select the project and click Connect (the 
Disconnect button automatically changes to a Connect button when you 
select a disconnected project, and the Connect button automatically 
changes to a Disconnect button when you select a connected project).

Results of Disconnecting an External Project

When you disconnect an external project:

• Requirements display in the traceability matrix and attribute matrix wit
label marking them as disconnected external requirements.

• You cannot create traceability relationships with requirements in the 
disconnected project.

• You cannot change traceability relationships with requirements in the
disconnected project.

• If you delete a requirement or its traceability state changes to Suspect, 
external requirements relationships are updated with the new state. 

• Any changes to requirements in the external project are updated in th
disconnected project when the project is opened. You can see these 
changes, but you cannot update them.
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Relocating an External Project

To relocate an external project, you must first disconnect it.

1. On the Tool Palette, click Project > External Projects.
The External Projects dialog box appears.

2. Select the project, and then click Disconnect.

3. In File Manager or Windows Explorer, move the project’s .rqs file to the 
new location.

4. In the External Projects dialog box, in the External Project References 
listing, select the project.

5. Click Browse.

6. Click Open.
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Integration with Other Products

Integration with Microsoft Project

The MS Project Integration Wizard manages traceability from requirement
RequisitePro projects to tasks in Microsoft Project schedules. You can us
wizard to:

• Create tasks from requirements and establish traceability relationship
from those requirements to the tasks.

• Add or remove traceability from requirements to existing tasks.

After you have established traceability you can:

• Refresh MSPT requirement information within RequisitePro that links
the traced tasks in Microsoft Project. 

• Review suspect traceability relationships between requirements and t
in a RequisitePro Traceability Tree or Traceability Matrix.

• Analyze the impact on the requirements, the tasks, the project, and th
schedule as changes occur.

Tips for using MS Project with RequisitePro
Follow these guidelines when using the MS Project integration:

• Create a task from any requirement that generates tasks you wish to 
in MS Project. For example, if a Feature requirement needs to have a
document, go through a review, for approval, you might want to gene
a task for this requirement. 

• If you follow the Rational Unified Process, a use case is probably the m
item that should appear in your schedule. It may also make sense to 
each alternative flow, and/or each individual step in a use case. 
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Supplementary requirements are also candidates for the schedule, bu
process associated with a supplementary requirement is highly depen
on the nature of the requirement - e.g. performance constraints have 
set of tasks, usability constraints have a different set of tasks. 

• Whatever level of requirements are handed off to the development tea
the level that should appear in the schedule. 

• Map the requirements that have activities associated with them. For 
example, if you have a parent requirement and all the children are 
approved for a release, you might want to generate a task linked to th
parent. If only one of the children is approved, just link the child. If the
children are sufficiently weighty, then you may want to bring over the 
parent and children as a task hierarchy. 

• If you have a requirement attribute to designate a product release num
you might want a schedule just for requirements assigned to the sam
release number. 

• If you have an “assigned-to” requirement attribute, you might want to 
generate a schedule for everything assigned to each developer.

Requirements

Software Requirements

Microsoft Project 95 (version 4.1) or 98 must be installed on your system
order to use the MS Project Integration Wizard. If not, the Start Microsoft
Project and Integration Wizard options are disabled on your RequisitePro
Tools menu.

Setting the Correct Version of MS Project

If you have both MS Project 98 and MS Project 95 installed on your compu
use the Tools > Options command on the Tool Palette to specify the Microsoft 
Project Version you want to use with RequisitePro. 

Security Requirements

In order to initially integrate a RequisitePro project with Microsoft Project 
using the wizard, you must have RequisitePro administrator permissions.

In order to use the MS Project Integration Wizard in subsequent sessions

• You must have create and delete permissions for the MSPT requirem
type. 
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• You must have attribute update permissions for all attributes associat
with the MSPT requirement type.

MSPT Requirement Types
Requirements and tasks are linked using a special requirement type, the M
requirement type. This requirement type is a place holder in a RequisiteP
project that represents a task in a schedule. The MSPT requirement type
linked to a task in a schedule. It contains, as requirement attributes, the 
Microsoft Project file name and a unique ID of the task it represents.

The MSPT requirement type also includes default attributes that are base
task fields in Microsoft Project. These default attributes are Cost, Duratio
Finish, Milestone, Priority, Resource Names, and Start.

You can also map Microsoft Project fields to RequisitePro attributes for th
MSPT requirement type in the .rqs file of your RequisitePro project. For more
information about the MSPT requirement type, see Working with the MSPT 
Requirement Type on page 16-14.

Starting the Wizard and Adding the MSPT Requirement Type
You can start the MS Project Integration Wizard from within RequisitePro
run it as an independent application. These instructions explain how to sta
wizard from within RequisitePro. 

Note: Make sure that you have closed any open dialog boxes in Micros
Project before you use the MS Project Integration Wizard.

To start the MS Project Integration Wizard:

1. On the Tool Palette, click Tools > Microsoft Project Integration
Wizard . The introduction screen appears.
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2. Click Next. The Select Project Files screen appears. 

3. Select a project. The list displays all projects in your RequisitePro pro
list.

4. Do one of the following:

• Enter the name and path of an existing Microsoft Project schedule.

• Click Browse to locate, select, and open an existing schedule in 
Microsoft Project.

• Click New to create a new schedule. The Project Info  dialog box 
appears. When you are finished creating the new schedule, click OK  in 
the Project Info  dialog box. A dialog box appears, prompting you to 
save the new project. After saving the schedule, the wizard minimiz
Microsoft Project, returns to this screen, and adds the new schedul
name to the Microsoft Project Schedule text box.

5. Click Next. If the project you selected has security enabled, the Logon 
dialog box appears. Log on as you would to a secured RequisitePro pr

The wizard checks the project and searches for the MSPT requireme
type. If the wizard does not find the MSPT requirement type, the wiza
adds it and displays the MSPT Info  screen. Click Next.
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The wizard opens the project and schedule and displays the Select an 
Action screen.

Creating Tasks from Requirements
The following instructions assume the wizard is started and the Select An 
Action screen is displayed. Use this feature to select requirements in 
RequisitePro in order to create new tasks in Microsoft Project that are lin
to the RequisitePro requirements.

Note: The first time the “Select An Action” screen appears after you sele
new schedule, only the first option is available. After tasks have b
created, the other options become available.

1. Select the option “Select requirements to create tasks, or add and 
remove traceability to existing tasks.”

2. Click Next.
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The wizard displays the “Select a Requirement Type” screen.

3. In the Requirement Type list, select a requirement type.

4. Click one of the following:

• All requirements of selected type. 

• Requirements of this attribute value. 
- In the Attribute  list, select the attribute.
- In the Value box, select a value and an operator.

• To search for requirements containing specific phrases (for example
word “shall”), enter the string in the Requirement Text Search box. 
You can use partial strings, but wildcard searches are not supporte
16-6
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5. Click Next. The screen displays the Task Traceability Tree for the 
requirements that you filtered in the previous screen.

6. Select one or more requirements and select Create Tasks. 

7. Click Next. At the next screen, click Finish.

Note: Each time you make a change to a schedule, a dialog box appea
prompting you to save with or without a baseline. We recommend
saving with a baseline for each change. See the Microsoft Project
documentation for more information about baselines.

8. Click Exit to close the wizard, or click Another Action  to return to the 
“Select an Action” screen where you can create more tasks, add or rem
traceability, and refresh requirement information from Microsoft Proje

Adding or Removing Traceability
The following instructions assume the wizard is started and the Select An 
Action screen is displayed and that you have created tasks in Microsoft Pr
that are linked to requirements in RequisitePro.

You have two options for modifying traceability in the MS Project Integrati
Wizard. You can:

• select a RequisitePro requirement and link it to a Microsoft Project tas

• select a Microsoft Project task and link it to a RequisitePro requireme

Both option are covered in the two procedures below.
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Selecting Requirements to Modify Traceability

At the Select An Action screen:

1. Select the option “Select requirements to create tasks, or add and re-
move traceability to existing tasks.” 

2. Click Next. 

The wizard displays the “Select a Requirement Type” screen.

3. In the Requirement Type list, select a requirement type.

4. Click one of the following:

• All requirements of selected type. 

• Requirements of this attribute value. 
- In the Attribute  list, select the attribute.
- In the Value box, select a value and an operator.

• To search for requirements containing specific phrases (for example
word “shall”), enter the string in the Requirement Text Search box. 
You can use partial strings, but wildcard searches are not supporte

5. Click Next.
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The screen displays the task traceability tree for the requirements that yo
filtered in the previous screen.

To remove traceability between the selected task and requirement:

1. Select one or more tasks and then click Remove traceability, and click 
Finish. The traceability between the selected tasks and requirement i
moved. Note that the tasks remain in the Microsoft Project schedule.

2. Click Exit to close the wizard, or click Another Action  to return to the 
“Select an Action” screen where you can create more tasks, add or rem
traceability, and refresh requirement information from Microsoft Proje

To add traceability between the selected requirements and a task:

1. Select a requirement and click Add Traceability. Traceability is created 
for one requirement at a time. 

2. Click Next to advance to the next screen and select a task.
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3. Do one of the following:

• If you are satisfied with the current task selection, click Finish.

• To change the selection, click MS Project to display the schedule and 
select one or more tasks. Return to the Integration Wizard and click
Refresh Task List to refresh the task display. Then click Finish.

Selecting Tasks to Modify Traceability

At the Select An Action screen:

1. Select the option “Select tasks to add or remove traceability” and click 
Next.

The Select Tasks screen appears.
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2. Do one of the following:

• If you are satisfied with the current task selection, click Next.

• To modify the selection, click MS Project to display the schedule and 
select one or more tasks. Return to the Integration Wizard and click 
Refresh Task List to refresh the task display. Then click Next.

This screen displays the Task Traceability Tree for the tasks you sele
in the previous screen and the requirements from which the tasks are
traced.
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3. Do one of the following:

• To display the task in the Microsoft Project schedule, select a task a
click Go to Task. In the schedule, you can view the task or make 
modifications. When you are finished, return to the Integration Wiza

• Select a requirement and the Remove traceability option. Then click 
Finish. The traceability between the selected task and requirement 
removed.

• Select a task and the Add Traceability  option. Then click Next. The 
Select a Requirement Type screen appears. Continue to the step 4

4. In the Requirement Type list, select a requirement type.

5. Click one of the following:

• All requirements of selected type. 

• Requirements of this attribute value. 
- In the Attribute  list, select the attribute.
- In the Value box, select a value and an operator.

• To search for requirements containing specific phrases (for example
word “shall”), enter the string in the Requirement Text Search box. 
You can use partial strings, but wildcard searches are not supporte
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6. To go to the next screen of the wizard, click Next. The screen displays the
requirements that you filtered in the previous screen.

7. Select a requirement. To display the requirements without tasks, selec
Show only requirements with no tasks check box.

8. Click Finish.

Refreshing MSPT Requirement Information from Tasks
The following instructions assume the Select An Action screen in the MS 
Project Integration Wizard is displayed and that you have created tasks in
Microsoft Project that are linked to MSPT requirements, which represent 
tasks in RequisitePro. Traceability should be established between your pro
requirements and the MSPT requirements.

When the values in the Microsoft Project task fields are changed, you nee
use the refresh feature in the MS Project Integration Wizard to update the
corresponding attribute values in the MSPT requirements. The resulting 
changes to the MSPT attribute values cause the traceability relationships
between your product requirements and the MSPT requirements to be ma
as suspect. This suspect condition alerts you of changes in the Microsoft
Project schedule.

You can then view the suspect relationships in a Traceability Matrix that 
includes your product requirements and the MSPT requirements; or you 
review the changes to the MSPT attribute values using an Attribute Matri
the MSPT requirement type.
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To refresh the MSPT requirements from the Microsoft Project tasks:

1. At the Select an Action screen, select the option “Refresh MSPT 
information from MS Project tasks” and click Next.

The Update screen displays the list of changes to occur when Requisite
is updated with a Microsoft Project tasks.

2. To proceed with the integration, click Finish.

Working with the MSPT Requirement Type

Viewing the MSPT Requirement Type

You can view the MSPT requirement type in a view in RequisitePro.

1. In the Views Workplace, click File > New View, or click the New View 
icon.

2. Select one of the following views:

• Select an Attribute Matrix  and the MSPT requirement type to review
the changes to the MSPT attribute values.

• Select a Traceability Matrix . Select the requirement types for your 
product requirements (in the row requirements) and the MSPT 
requirements (in the column requirements). The traceability is displa
between the requirement types.

• Select a Traceability Tree. Select the product requirement type and 
expand the display to view the traceability relationships to the MSP
requirements.

3. Click OK .

Mapping Fields to Attributes for the MSPT Requirement Type

Unlike other requirement types, you cannot add a new attribute to the MS
requirement type using the Attributes tab on the Project dialog box. You c
however, create attributes for the MSPT requirement type in the .rqs file for 
the RequisitePro project in which you are working. For example, if the na
of the project you are working on is “blueproject,” then you use the 
blueproject.rqs file to create new attributes for the MSPT requirement typ

If security is enabled, you must have project structure permission to map a
to an attribute for an MSPT requirement type.
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To map fields to attributes:

1. Refer to Microsoft Project Field IDs on page 16-15 to locate the task field
which you want to map to an attribute for the MSPT requirement type

2. In a text editor, open the .rqs file for the project with which you are 
working. 

3. In the [MSProjectMappings] section of the .rqs file, enter the following:

field ID=attribute name

where field ID is the field ID listed in Microsoft Project Field IDs on page 
16-15 and attribute name is the label you want to give the attribute in
RequisitePro.

4. Save the .rqs file.

The MS Project Integration Wizard will create an attribute for the MSPT 
requirement type based on the information entered.

Microsoft Project Field IDs

Use the following Microsoft Project field IDs to map attributes for the MSP
requirement type in RequisitePro to corresponding constants in Microsoft
Project. Add your entries to the [MSProjectMappings] section in <project 
name>.rqs file using a text editor. 

Use the following format:

field ID=attribute name 

where field ID is the numeric constant listed below and the attribute name
the label you want to give the attribute in RequisitePro. Field IDs shown i
bold are already provided as default attributes for the MSPT requirement 

Actual Cost = 7 Actual Duration = 28 Actual Finish = 42

Actual Start = 41 Actual Work = 2 Baseline Cost = 6

Baseline Duration = 27 Baseline Finish = 44 Baseline Start = 43

Baseline Work = 1 BCWP = 11 BCWS = 12

Confirmed = 110 Constraint Date = 18 Constraint Type = 17

Contact = 112 Cost = 5 Cost1 = 106

Cost2 = 107 Cost3 = 108 Cost Variance = 9

Created = 93 Critical = 19 CV = 83

Delay = 20 Duration = 29 Duration1 = 103

Duration2 = 104 Duration3 = 105 Duration Variance = 30
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Early Finish = 38 Early Start = 37 Finish = 36

Finish1 = 53 Finish2 = 56 Finish3 = 59

Finish4 = 62 Finish5 = 65 Finish Variance = 46

Fixed Cost = 8 Fixed (Duration) = 34 Flag1 = 72

Flag10 = 81 Flag2 = 73 Flag3 = 74

Flag4 = 75 Flag5=76 Flag6 = 77

Flag7 = 78 Flag8 = 79 Flag9 = 80

Free Slack = 21 Hide Bar = 109 ID = 23

Late Finish = 40 Late Start = 39 Linked Fields = 98

Marked = 71 Milestone = 24 Name = 14

Notes = 15 Number1 = 87 Number2 = 88

Number3 = 89 Number4 = 90 Number5 = 91

Objects = 97 Outline Level = 85 Outline Number = 102

% Complete = 32 % Work Complete = 33 Predecessors = 47

Priority = 25 Project = 84 Remaining Cost = 10

Remaining Duration = 31 Remaining Work = 4 Resource Group = 11

Resource Initials = 50 Resource Names = 49 Resume = 99

Resume No Earlier Than = 101Rollup = 82 Sheet Notes = 94

Start = 35 Start1 = 52 Start2 = 55

Start3  = 58 Start4 = 61 Start5 = 64

Start Variance = 45 Stop = 100 Subproject File = 26

Successors = 48 Summary = 92 SV = 13

Text1 = 51 Text10 = 70 Text2 = 54

Text3 = 57 Text4 = 60 Text5 = 63

Text6 = 66 Text7 = 67 Text8 = 68

Text9 = 69 Total Slack = 22 Unique ID = 86

Unique ID Predecessors = 95 Unique ID Successors = 96 Update Needed = 1

WBS = 16 Work = 0 Work Variance = 3
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Deleting Attributes for MSPT Requirement Types

To delete an attribute for an MSPT requirement type, you must have proj
structure permission to remove a requirement type (if security is enabled

To delete attributes:

1. Open the RequisitePro project file (projectname.rqs) with a text edito

2. In the project file, under the heading [MSProjectMappings], locate the
requirement attribute that you want to delete. Attributes are listed with
Microsoft Project field ID, followed by an equal sign (=), and the attribu
name; for example, 5=Cost.

3. Delete the entire line that contains the attribute. Save and close the pr
file.

4. In the RequisitePro Tool Palette, click Project > Open.

5. Select the project, check the Exclusive check box, and click OK . Log on 
to the project, if necessary.

6. On the Tool Palette, click the Tools > Microsoft Project  > Integration 
Wizard .

7. Click Next. Be sure that the current RequisitePro project and related 
Microsoft Project are selected. Click Next.

8. Select the option “Refresh MSPT information from MS Project tasks.”
Click Next. 

9. After the processing is complete, click Finish. Click Exit  and Yes at the 
confirmation prompt.

Integration with Rational Rose

Rational Rose offers powerful tools for object-oriented analysis, modeling
design, and construction. As the world’s leading visual modeling tool, Ratio
Rose enables system analysts to start modeling requirements with use c
and actors and enables developers to define and communicate a softwar
architecture. 

You can open Rose directly from RequisitePro by clicking Tools > Rational 
Rose, and you can associate Rose use cases with RequisitePro requirem
and documents using Integrated Use Case Management.
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Integrated Use Case Management
Rational’s Integrated Use Case Management allows you to manage use 
in Rational Rose using attributes, such as Priority, Risk, Status, and Itera
by associating use cases in Rose with RequisitePro documents and 
requirements. You can easily navigate from Rose use-case models to 
RequisitePro use-case documents and requirements.

Use-case management in RequisitePro adds depth and relational informa
to your Rose use cases with support for:

• textual definitions of use cases in a Microsoft Word documents; 

• detailed descriptions of flows of events, special requirements, 
preconditions and postconditions; 

• hierarchical (parent/child) relationships between use-case names and
actions within the use-case flow of events; 

• traceability to and from other use cases, associated design features, an
plans. 

We recommend that you initially develop your use cases in Rose and the
detail and manage them in RequisitePro using Integrated Use Case 
Management. This approach accomplishes associations between Rose a
RequisitePro with several easy menu selections.

Note: If you have developed your use cases in RequisitePro and want to
Rose use case diagrams with associated attributes, you can trans
your RequisitePro use cases to Rose, using the Rational 
Synchronizer. You can then associate those use cases to Requisi
requirements and documents using Integrated Use Case Manage

To associate a Rose model or package with a RequisitePro project, open
model or package in Rose and use the commands on the Tools > RequisitePro 
menu. Refer to online help in Rose for more information on Integrated Us
Case Management.

What is the Rational Synchronizer?

The Rational Synchronizer automates the creation and updating of items
your project. The Synchronizer works with items in RequisitePro (such as
requirements), items in Rose (such as, use cases and actors), and items in 
TestStudio (such as, scripts). The Synchronizer uses either predefined or 
defined rules to determine which items to create or update. 
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For example, your project may contain a rule that says “For every use-ca
requirement in RequisitePro, create a corresponding use case in Rose, if
does not already exist.” When requirements change, this rule communica
changes accurately and promptly to the team that is working on design a
analysis in Rose. 

With Rose, the Rational Synchronizer allows you to automatically create R
items (use cases, actors, classes, packages) from existing requirements,
maintain the Rose items and their matching RequisitePro requirements in 

Note: The RequisitePro requirements must be database-only requireme
in order to synchronize them with Rose.

With TestStudio, the Rational Synchronizer allows you to automatically cre
test requirements from any requirement, and attach a test script to that cr
test requirement. Additionally, test requirements created in TestStudio ar
directly stored into a RequisitePro projects, avoiding duplication of data.

To start the Rational Synchronizer, do the following:

Click Tools > Rational Synchronizer.

Rational Suite TestStudio

If you have the Rational TestManager component of Rational Suite 
TestStudio installed on your PC, you can launch it directly from the 
RequisitePro Tools menu (click Tools > Rational TestManager).

TestManager is an information management tool for software developme
and testing professionals, designed to help track software testing informa
through all phases of the software development, test, and revision cycles.
can use TestManager to plan testing strategies, and to track information re
to test execution. TestManager has features that can be used by all memb
the software development and testing team and lets you manage the soft
quality assurance process from the beginning of product development all
way through product delivery.

RequisitePro also is integrated with Rational Suite TestStudio through the
Rational Synchronizer.
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Integration with Rational ClearQuest

If you have ClearQuest or any Rational Suites product installed on your P
you can launch ClearQuest directly from the RequisitePro Tools menu (c
Tools > Rational ClearQuest).

ClearQuest is a Windows change request management product designed
the dynamic and evolving nature of software development. ClearQuest o
a flexible approach to track and manage all the change activities that are
associated with an organization. With it, team members can customize a
define queries, fields, activities, and states specific to their environment. T
expanded level of customization makes the process of managing change
for a team to implement, deploy, and maintain. If you have a Rational Su
product installed, you can use ClearQuest and RequisitePro together. Th
system analyst can collect enhancement requests in ClearQuest and the
associate those enhancement requests with new or existing requirement
RequisitePro.
16-20
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Keyboard Shortcuts and Mouse Actions

Dialog Box Shortcuts

You can use keyboard combinations to move to tabs, fields, and buttons 
RequisitePro dialog box. To use a dialog box shortcut, press the Alt key w
simultaneously pressing the underlined letter in a dialog tab, field, or butt
For example, in the Project, Document, or Requirement dialog box, press Alt-
G to open the General tab.

Menu Shortcuts

You can use combinations of keyboard shortcuts to open a menu in the T
Palette or Views Workplace. To use a menu shortcut, press the Alt key w
simultaneously pressing the underlined letter in the menu. For example, t
open the Requirement menu, press Alt-R.  Once a menu is displayed, you can
select a command by pressing the underlined letter in the command.

Selecting Multiple Items in RequisitePro

You can use mouse actions and combinations of keyboard and mouse ac
to select more than one item in various RequisitePro lists.

The following are referred to as multiple select actions in RequisitePro 
documentation:

• Shift-click : To click the mouse button while holding down the Shift ke

• Ctrl-click :  To click the mouse button while holding down the Contro
key.

• Drag: To hold down the right mouse button while moving the mouse a
then releasing the button.
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You can use the actions in the following ways:

• To select adjacent items, use Shift-click  or drag.

• To select nonadjacent items, use Ctrl-click .

The anchor is the first item you click when using multiple select actions to
select a range of items. In RequisitePro, the term “anchor” is generally use
mean the first cell you click in a view in the Views Workplace. You use th
anchor to select a range of cells. For example, if you click the cell in row 
column 1 of a traceability matrix, that cell becomes the anchor. If you the
Shift-click the cell in row 10, column 3 of the matrix, all of the cells in rows
through 10, columns 1 through 3, are selected. To reset the anchor, click
anywhere outside the range. The cell you click is the new anchor. You can
use an anchor to select a range of items in documents and in certain dial
boxes that support multiple select actions.
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Mouse Actions and Shortcuts in the Views Workplace

You can use keyboard shortcuts and mouse actions to quickly move arou
and select information in the Views Workplace. The keyboard shortcuts a
mouse actions differ in each matrix. 

The following tables provide specific shortcuts for selecting items in an 
attribute matrix, a traceability matrix, or a traceability tree.

Attribute Matrix Mouse Actions and Keyboard Shortcuts

Mouse Actions

If you want to Do this

Select the requirement in the row in which 
you click. 

(This action clears all selected items and 
sets the selected row as the anchor. 
Clicking in cell also changes the selected 
column to the column in which you 
clicked.)

Click row label

OR

Click cell

Select the requirements between the anchor 
row and the row in which you Shift-click.

(This action clears any rows that are not in 
the range.)

Shift-click row label

OR

Shift-click cell in selected column

Set the selected row as the anchor, while 
keeping previously selected items selected.

OR

Clear a previously selected row while 
keeping others selected.

Ctrl-click row label

Switch the column selection to the column 
in which you click.

(Clicking in cell also selects the row in 
which you clicked.)

Click column label

OR

Ctrl-click column label

OR

Ctrl-click in cell

Select a range of requirements

(This action clears any rows that are not in 
the range.)

drag
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Keyboard Shortcuts

If you want to Do this

Move to the right one column. Tab

OR

Right arrow

Move to the left one column. Shift-Tab

OR

Left arrow

Move down one row.

(This action clears all selected items and 
sets the selected row as the anchor.) 

Enter

OR

Down arrow

Move up one row.

(This action clears all selected items and 
sets the selected row as the anchor.) 

Shift-Enter

OR

Up arrow

Activate the field for data entry, in the 
currently selected cell.

Space bar

Deactivate the field for data entry, in the 
currently selected cell.

Esc

Move to the top of the view and select the 
first row.

(This action sets the first row as the anchor 
and clears all other selected items.) 

Home

Move to the top of the view and select all 
items between the anchor row and the first 
row of the view.

(This action clears all other selected items.)

Shift-Home

Move to the top of the view, without 
clearing selected items.

Ctrl-Home

Move to the bottom of the view and select 
the last row.

(This action sets the last row as the anchor 
and clears all other selected items.) 

End
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Move to the bottom of the view and select 
all items between the anchor row and the 
last row of the view.

(This action clears all other selected items.)

Shift-End

Move to the bottom of the view, without 
clearing selected actions. 

Ctrl-End

Move up one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously-
selected row was when its page was 
displayed, or selects the first row if the 
view is positioned on the top page. The 
newly-selected row is the new anchor.)

Page Up

Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from top to anchor if the view is positioned 
at the top of the page.)

Shift-Page Up

Move up one page in the view, without 
changing the selection or the anchor.

Ctrl-Page Up

Move the view one page left. 

(This action selects the column that is in the 
same horizontal position as the previously-
selected column was when its page was 
displayed, or selects the first column if the 
view is positioned on the far left page.)

Alt-Page Up

Move down one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously-
selected row was when its page was 
displayed, or selects the last row if the view 
is positioned on the bottom page. The 
newly-selected row is the new anchor.)

Page Down

If you want to Do this
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Move down one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from the bottom to the anchor if the view is 
positioned at the bottom of the page.)

Shift-Page Down

Move down one page in the view, without 
changing the selection or the anchor. 

Ctrl-Page Down

Move the view one page right. 

(This action selects the column that is in the 
same horizontal position as the previously-
selected column was when its page was 
displayed, or selects the last column if the 
view is positioned on the far right page.)

Alt-Page Down

Expand the selected row requirement to 
show its children in the view. 

+

Collapse the selected row requirement to 
hide its children in the view. 

-

Select every row in the view. Ctrl-A

Cut text of any non-list attribute. Shift-Delete

Copy text of any non-list attribute. Ctrl-Insert

Paste text of any non-list attribute. Shift-Insert

If you want to Do this
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Traceability Matrix Mouse Actions and Keyboard Shortcuts

Mouse Actions

If you want to Do this

Select a cell.

(This action clears all other selected cells.) 

Click cell

Select all cells in the rectangle formed by 
the anchor cell and the clicked cell.

Shift-click cell

Set the cell as the anchor, while keeping 
previously selected cells selected.

OR

Clear a previously selected cell while 
keeping others selected.

Ctrl-click cell

Select the cell in the clicked row and the 
anchor column.

(This action clears all other selected cells 
and sets the selected cell as the anchor.)

Click row label

Select the cells in all rows between the 
clicked row and the anchor row, in all 
selected columns.

(This action clears any rows and columns 
that are not in the range.)

Shift-click row label

Select all cells that intersect with selected 
columns, without clearing previously 
selected cells.

Ctrl-click row label

Select the cell in the clicked column and all 
selected rows.

Click column label

Select the cells in all columns between the 
clicked column and the anchor column, in 
all selected rows.

Shift-click column label

Select all cells that intersect with selected 
rows, without clearing previously selected 
cells.

Ctrl-click column label
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Keyboard Shortcuts

If you want to Do this

Move to the right one column. Tab

OR

Right arrow

Move to the left one column. Shift-Tab

OR

Left arrow

Move down one row. Enter

OR

Down arrow

Move up one row. Shift-Enter

OR

Up arrow

Display a shortcut menu for the currently 
selected cells.

Space bar

Close the shortcut menu for the currently 
selected cells.

Esc

Move to the top of the view and select all 
cells in the selected columns in the top row.

(This action clears all other selected rows 
and sets the top row as the anchor.)

Home

Move to the top of the view, without 
changing the anchor.

(This action selects all cells in selected 
columns between the top row to the anchor 
row.)

Shift-Home

Move to the top of the view, without 
changing the selection or the anchor.

Ctrl-Home

Move to the bottom of the view and select 
all cells in the selected columns in the last 
row.

 (This action clears all other selected rows 
and sets the last row as the anchor.)

End
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Move to the bottom of the view, without 
changing the anchor.

(This action selects all cells in selected 
columns between the bottom row to the 
anchor row.)

Shift-End

Move to the bottom of the view, without 
changing the selection or the anchor.

Ctrl-End

Move up one page in the view, while 
changing the anchor.

(This action selects the selected columns 
and the row that is in the same vertical 
position as the previously-selected row, or 
selects the top row if the view is already on 
the top page. The newly-selected row is the 
new anchor.)

Page Up

Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed.)

Shift-Page Up

Moves up one page in the view, without 
changing the selection or the anchor.

Ctrl-Page Up

Move the view one page left, while 
changing the anchor.

(This action selects the selected rows and 
the column that is in the same horizontal 
position as the previously-selected column 
was when its page was displayed, or selects 
the first column if the view is positioned on 
the far left page.)

Alt-Page Up

If you want to Do this
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Move the view one page left, without 
changing the anchor.

(This action selects the cells in selected 
rows and the columns between the anchor 
column and the column that is in the same 
horizontal position as the anchor column 
was when its page was displayed, or selects 
the first column if the view is already on the 
far left page.)

Alt-Shift-Page Up

Moves left one page in the view, without 
changing the selection or the anchor.

Alt-Ctrl-Page Up

Move the view down one page, while 
changing the anchor.

(This action selects the selected columns 
and the row that is in the same vertical 
position as the previously-selected row was 
when its page was displayed, or selects the 
last row if the view is already on the bottom 
page. The newly-selected row is the new 
anchor.)

Page Down

Move down one page, without changing 
the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed.)

Shift-Page Down

Move down one page in the view, without 
changing the selection or the anchor.

Ctrl-Page Down

Move the view one page right, while 
changing the anchor.

(This action selects the selected rows and 
the column that is in the same horizontal 
position as the previously-selected column 
was when its page was displayed, or selects 
the last column if the view is already on the 
far right page.)

Alt-Page Down

If you want to Do this
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Move the view one page right without 
changing the anchor.

(This action selects the selected rows and 
the columns between the anchor column 
and the column that is in the same 
horizontal position as the anchor was when 
its page was displayed, or selects the last 
column if the view is already on the far 
right page.)

Alt-Shift-Page Down

Moves right one page in the view, without 
changing the selection or the anchor.

Alt-Ctrl-Page Down

Expand the selected requirement to show 
its relationships. Preserve the previous row 
selection. 

+

Collapse the selected requirement to hide 
its relationships. 

- 

Select every cell in the view. Ctrl-A

If you want to Do this
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Traceability Tree Mouse Actions and Keyboard Shortcuts

Mouse Actions

Keyboard Shortcuts

If you want to Do this

Select the clicked item.

(This action clears all selects items and sets 
the selected row as the anchor.)

Click row

Select the items between the anchor row 
and the row in which you click. 

(This action clears any rows that are not in 
the range.)

Shift-click row

Set the selected row as the anchor, while 
keeping previously highlighted text 
selected.

OR

Clear a previously selected row while 
keeping others selected.

Ctrl-click row

Copy a selected row's requirement to a new 
position

Ctrl-click row, then drag

OR

Right-click, then drag, and select Copy here 
from context menu

Move a selected row's requirement Alt-click row, then drag

OR

Right-click, then drag, and select Move here 
from context menu

If you want to Do this

Move down one row Down arrow

Move up one row Up arrow

Display a shortcut menu for the currently 
selected requirements.

Space bar

Close the shortcut menu for the currently 
selected requirements.

Esc
A-12



Mouse Actions and Shortcuts in the Views Workplace
Move to the top of the view and select the 
first row. 

(This action sets the first row as the anchor 
and clears all other selected items.)

Home

Move to the top of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the first row of the view.)

Shift-Home

Move up one page in the view, without 
changing the selection or the anchor.

Ctrl-Home

Move to the bottom of the view and select 
the last row. 

(This action sets the last row as the anchor 
and clears all other selected items.)

End

Move to the bottom of the view, without 
changing the anchor.

(This action selects all items between the 
anchor row and the last row of the view.)

Shift-End

Move down one page in the view, without 
changing the selection or the anchor.

Ctrl-End

Move up one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously-
selected row was when its page was 
displayed, or selects the top row if the view 
is positioned on the top page. The newly-
selected row is the new anchor.)

Page Up

Move down one page in the view, while 
changing the anchor.

(This action selects the row that is in the 
same vertical position as the previously-
selected row was when its page was 
displayed, or selects the last row if the view 
is positioned on the bottom page. The 
newly-selected row is the new anchor.)

Page Down

If you want to Do this
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Keyboard Shortcuts and Mouse Actions
Move up one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from the top to the anchor if the view is 
positioned at the top of the page.)

Shift-Page Up

Move down one page in the view, without 
changing the anchor.

(This action selects all rows between the 
anchor and the row that is in the same 
vertical position as the anchor was when its 
page was displayed, or selects all rows 
from the bottom to the anchor if the view is 
positioned at the bottom of the page.)

Shift-Page Down

Move up one page in the view, without 
changing the selection or the anchor.

Ctrl-Page Up

Move down one page in the view, without 
changing the selection or the anchor.

Ctrl-Page Down

Expand the item to show its relationships. +

Collapse the item to hide its relationships. - 

Highlight every item in the view. Ctrl-A

If you want to Do this
A-14



 

s.

ol 

ow 

ro.

hen 
ta 
A P  P  E  N  D  I  X      B

Customizing RequisitePro

Configuring RequisitePro

You can use the Tools > Options command on the Tool Palette to configure
the appearance and behavior of RequisitePro.

1. On the Tool Palette, click the Tools > Options.
The Options dialog box appears.

2. Type or mark the following options as needed:

Tool Palette

• Show Buttons: Mark this check box to display the Tool Palette button

• Show Status: Mark this check box to display the status line on the To
Palette. This displays project and document status as you work in 
RequisitePro.

• Show Tool Tips: Mark this check box to display a button definition 
when you hold the pointer over a button on a RequisitePro toolbar.

• Always on Top: Mark this check box to display the Tool Palette and 
open dialog boxes in the foreground of your screen, regardless of h
many applications you have open.

• Let's Go RequisitePro at startup: Mark this check box to display the 
Let's Go RequisitePro splash screen each time you start RequisiteP

Views

• Prompt for save: Mark this check box if you want RequisitePro to 
prompt you to save changes to display options and view properties w
you close an unsaved view. Changes to requirements and other da
within the view are not affected. 
B-1
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• Double-click to go to document: Mark this check box for the ability to 
double-click on a requirement in a view to access it in a requiremen
document. If this check box is cleared, double-clicking expands and
collapses the requirement hierarchy.

• Font: Lists the font displayed in the Views Workplace.

• Change: Click this button to change the font.

Traceability

• Warn on remove: Mark this check box if you want Requisite Pro to 
warn you when you remove requirement traceability.

• Changes logged in history: Mark this check box to display changes t
requirement traceability on the revision history list in the requiremen
properties dialog box.

Default Project Logon

• Username: Type your RequisitePro user name. This is used as your
default logon name for all RequisitePro projects.

Microsoft Word

• Version: Click the down arrow to select your preferred version of 
Microsoft Word when you have more than one version installed. Th
option “<Use Default>” uses the current version of the application, 
which is recorded in the Windows registry.

• Save as RTF: Mark this check box to saves all RequisitePro docume
as RTF files. 

Microsoft Project

• Version: Click the down arrow to select your preferred version of 
Microsoft Project when you have more than one version installed. T
option “<Use Default>” uses the current version of the application, 
which is recorded in the Windows registry.

Directories

• Outline Path: Defines a secondary location for accessing document
type outlines. If RequisitePro is installed locally on your PC, the defa
path is ...RequisitePro\outlines. Use this option to define an alterna
location for outlines, for example, a directory on the server for share
outlines.
B-2
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• PVCS Archive: Defines the main directory for PVCS archiving in 
RequisitePro. A subdirectory is created within this directory for each
project you archive.

• PVCS DLL : Defines the full path for the location of the PVCS dynam
link library. This is helpful when PVCS is installed in a non-default 
location.

• ClearCase View: Defines the directory for ClearCase archiving in 
RequisitePro. This needs to be a shared view for all RequisitePro u

• Working Path : Displays the working directory for RequisitePro. Writ
permission must be enabled for this directory in order for RequisiteP
to create new projects and write temporary files.

3. Click OK .

Customizing Tool Palette Menus

The Add-in  option on the Tool Palette Tools menu allows you to add your own
customized menu items to any menu on the RequisitePro Tool Palette. T
menu options can be used to start external applications, such as e-mail o
Windows Notepad, directly from RequisitePro. In addition, you can config
an option to open an individual file with the application of your choice.

You can add either a project-wide menu item for use by all members of th
project team or a menu item that appears only when you open RequisiteP
your PC. The Add-in option prompts you to specify an external menu file t
defines your customized menu options.

To add custom menu items:

1. On the Tool Palette, click Tools > Add-ins.
The Add-ins dialog box appears.

2. Click the Add button to add a customized menu option. The Add-in  dialog 
box appears.

3. Type a name for the menu option. This name identifies the menu file 
your add-ins list.

4. Click the Browse button. The Select a RequisitePro Menu File dialog 
box appears.

5. Select a file type to display: All Files, Menu Files, or Text Files.

6. Navigate to a menu file and click Open.

7. Leave the Active check box as marked.
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8. Mark one of the following:

• Local to apply the menu items to your Tool Palette only.

• Project to apply the menu items to the Tool Palette of all users who
access the project.

9. Click OK  to close the Add-in dialog box.

10. Click OK  to close the Add-ins dialog box.

The options defined in the menu file are added to the specified Tool Pale
menu.

Creating A Menu File

Using any text editor, you can create a file to add menu options to any 
RequisitePro Tool Palette menu. The entries will appear on the Requisite
menu in the order in which you specify them. 

As you add menu entries, you will specify:

• Keywords that determine items on the menu (a submenu, a menu opti
separator)

• Menu actions that execute an application or open a specific external 
such as a readme file.

Pay close attention to the syntax rules that apply to your entries to the me
file. For example, the syntax of the menu specifications includes opening
closing braces {...}.

Note: Rational Rose users may be familiar with creating menu specifica
files for extending the Rose Tools menu. RequisitePro menu files 
the same syntax with a subset of the Rose functions.
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Menu File Template
Create your menu file in a text editor, based on the following template. Sa
your file with a .TXT extension or a .MNU extension to help locate the file
easily in your file structure.

Menu <RequisitePro menu name>
{

Separator
Option <menu item>
{

Exec <command line>
Status <status text>

}
Menu <submenu name>
{

Option <menu item>{
Exec <command line>
Status <status text>

}
Option <menu item>
{

Exec <command line>
Status <status text>

}
}

}
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Key Words
Use the following table to define the key words to copy into the menu file

Notes
1. Menu names, submenu names, option names, and statuses need do

quotes if they include more than one word.

2. Separators can be in menus or submenus.

3. Can include more than one menu item in a file.

4. Add an ampersand (&) directly before a character in the menu name 
create a underlined letter signifying an access key in the menu option

5. You can create a maximum of five levels of submenus (indented one be
another).

Keywords and Variables Definitions and Valid Entries

Menu keyword to specify the Tool Palette menu or 
submenu to which you want add the menu 
items

Separator keyword to place a separator in the menu

Option keyword to specify the name of the item as it 
will appear on the menu

Exec keyword to identify the command line to be run 
when the menu item is chosen

Status keyword to identify the text for the status line 
of the Tool Palette

<RequisitePro menu name> Project, Document, Requirement, Tools, 
Window, or Help

<menu item> user-defined text for an item on the menu or 
submenu

<submenu name> user-defined text identifying the name of the 
submenu

<command line> user-defined text identifying the commands to 
execute when the menu item is chosen

<status line> user-defined text identifying the text for the 
status line of the Tool Palette
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Sample Menu File
The following example shows a simple menu definition file. After you crea
a menu file, reference using the Add-ins option on the Tool Palette Tools
menu. This feature allows you to add customized menu options to the 
RequisitePro menus.

The following menu file instructs RequisitePro to add the options “Open 
readme file” and “Open Windows Notepad” to the Tool Palette Window me
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G L O S S A R Y

Rational RequisitePro Terms

The terms that follow are used throughout the RequisitePro User’s Guide
Most are specific to RequisitePro. 

Active document: The current document in the Word Workplace, which ha
processing focus. The Word Workplace is the Microsoft Word implementa
within RequisitePro where you view, create, and modify project documen
You can have many documents open at one time; however, only one of t
documents is active.

Active view: The current view in the Views Workplace, which has process
focus. You can have many views open at one time; however, only one of t
views is active. See also Views Workplace.

Actor:  Someone or something outside the system that interacts with the 
system.

Add-in command: An option on the Tool Palette Tools menu that allows yo
to add your own customized menu options to any Tool Palette menu. The
menu options can be used to start external applications, such as e-mail o
Windows Notepad, directly from RequisitePro. In addition, you can config
an option to open an individual file with the application of your choice.

Administrators group : A group of users with full permissions to work in a 
project. They can change a project structure, create and modify data, mo
and delete project-wide views, and set and maintain security permissions
Users can be added and removed from this group, but this group cannot 
deleted. Administrator group permissions cannot be modified.

Anchor: The first item you click when using multiple select actions to selec
range of items. In RequisitePro, the term “anchor” is generally used to me
the first cell you click in a view in the Views Workplace. You use the anch
to select a range of cells. For example, if you click the cell in row 1, colum
of a Traceability Matrix, that cell becomes the anchor. If you then Shift-cli
the cell in row 10, column 3 of the matrix, all of the cells in rows 1 through 
columns 1 through 3, are selected. To reset the anchor, click anywhere ou
the range. The cell you click is the new anchor. You can also use an anch
select a range of items in documents and in certain dialog boxes that sup
multiple select actions. See Multiple select actions.
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Attribute : Descriptive information that provides important details about a 
requirement or discussion. See also Requirement attribute.

Attribute label : The name of the requirement attribute, such as risk, prior
or author. Also referred to as requirement attribute label.

Attribute Matrix : A spreadsheet-like table View that displays requirements
rows and the attributes that describe the requirements in columns. You ca
or change values in the attribute fields. Also referred to as Requirement 
attribute matrix.

Attribute type : A set of descriptive and operational information associate
with a requirement attribute when the attribute is created. Attribute values
be list-type or entry-type. For list-type attributes, you select a textual attrib
value from a drop-down list. For entry-type attributes, you type in a value, s
as a number, text string, date, or time. Also referred to as requirement attribute 
type.

Attribute value : Information assigned to a requirement attribute. Attribute
values can be text or numbers. For example, the attribute priority can be 
assigned the values Low, Medium and High. Also referred to as requirement 
attribute value.

Author : The user responsible for creating or modifying a document or 
requirement.

Author (version information) : User responsible for the changes associate
with a given revision.

Bookmark: A marker inserted at a specific point in a document to which t
user may return for later reference. In Microsoft Word, a bookmark is a 
location or selection of text named for reference purposes. Bookmarks ar
implemented in RequisitePro documents to designate requirement text. 
Bookmarks are designated by square brackets, as in the following: [exam

Change description (version information): Textual information that 
specifies the justification or reasoning behind the changes associated wit
given revision of a project, document, or requirement. See also Version 
information.

Change-managed relationship: A connection between two requirements tha
implies dependency or a logical relationship. RequisitePro tracks two type
change-managed relationships: hierarchical relationships and traceability 
relationships. Changes to either of the requirements can cause a “suspec
condition in the relationship. See also Suspect relationship.
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Child requirement : A requirement that participates in a hierarchical 
relationship with a parent requirement. A child can have only one parent 
requirement. See also Parent requirement, Hierarchical requirement.

Circular traceability relationship : A relationship between a requirement an
itself, or an indirect relationship that leads back to a previously traced-fro
node. Traceability relationships cannot have circular references. Requisit
checks for circular references each time you establish a traceability 
relationship. RequisitePro also checks for circularity when you create an 
external relationship. The circular check only references internal requirem
and first-level external requirements.

ClearCase: See Rational ClearCase. 

CMM : The Software Engineering Institute’s Capability Maturity Model, a 
framework for effective software process developed at Carnegie-Mellon. 
CMM for Software describes increasing levels of process maturity, from an
hoc, immature process to a mature, disciplined one.

Collapse indicator: See Expand/collapse indicator.

Concurrency: A condition in which two or more users can access the sam
project at the same time. See also Exclusive access.

Cross-project traceability: A RequisitePro feature that allows you to 
establish traceability relationships between requirements that reside in 
different projects. See also External traceability.

CSV file: A comma-separated value text file, commonly used to exchange 
between database systems that use different formats. Sometimes called 
comma-delimited files, CSV files can be imported into RequisitePro.

Ctrl-click : See Multiple select actions.

Current project : The project that is open, or active. A user can have only o
RequisitePro project open at a time. Also referred to as the active project or the 
open project.

Database: A collection of data stored in a repository. By using specific 
commands, you can search and sort a database for the retrieval of speci
information. RequisitePro stores your projects in a database. Use the view
queries in the RequisitePro Views Workplace to search the project datab
See also Project database.

Database-based requirement: A requirement that currently resides only in 
the database. The requirement may have been created in the database, o
recently moved to the database from a document.
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.def file: A file, located in the RequisitePro outlines directory, that specifie
information about a particular outline used by RequisitePro. 

Deleted Users group: A security group of users who have been deleted fro
other groups, have no permissions, and cannot log on to RequisitePro. T
group is maintained by the project manager for project history.

Dialog box: An interactive window displayed on the screen that solicits a 
response from the user.

Dialog box shortcut: See Keyboard shortcuts.

Directory : A catalog for file names and other directories. A directory is an
organization of files (or folders) grouped for the user’s convenience. The 
topmost directory is called the root directory. The directories within a direct
are called subdirectories.

Discussion: A RequisitePro feature that lets you address comments, issue
and questions to a group of discussion participants. Discussions can be 
associated with one or more specific requirements, or refer to the project
general.

Discussion item: A discussion item is either the initial discussion topic or a
response. A response can be either to the initial discussion text or to ano
response.

.doc file: A DOS file name extension for Word documents. Do not use the .
file name extension as a file name extension for document types.

Document: Any Word document, whether it is part of the RequisitePro proje
or outside the project, whether it contains requirements or not. See also 
Requirements document.

Document-based requirement: A requirement that currently resides in a 
RequisitePro document. The requirement could have been created in the
document, or most recently moved to the document from the database or
another document.

Document properties: Specific items of information about a RequisitePro 
document. Documents have attributes associated with them such as auth
date and time of last revision and file name.

Document type: Defines descriptive and operational information associate
with a requirements document. The document type serves as a template
each requirements document you create of that type.
The document type defines the document’s file extension, such as .prd; a
documents of the same document type share the same file extension. Th
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document type identifies a default requirement type; each new requireme
you create in the document will be based on the default requirement type u
you indicate otherwise. The document type also identifies an outline (or 
template) for the document which controls its page layout, default text, 
paragraph styles, etc.

Document version: A revision of a RequisitePro document, identified in th
document properties revision history. A new version is created when a 
document is changed and saved. See Revision.

.dot file: A DOS file name extension for Word template files. Do not use t

.dot file name extension as a file name extension for RequisitePro docum
types.

Drag: See Multiple select actions.

Drop-down menu: A list that appears below a menu bar or field when the u
clicks the down arrow. The menu remains open without further action until
user closes it or chooses a menu item.

Entry-type attributes : Entry-type attributes are numeric, text, time, or date
values that are entered by project users. An entry-type attribute can be 
configured with a default value which users can accept or replace as they c
or modify requirements. For example, you could format the entry-type 
attribute “Cost” to accept integer values and have a default value of 20. Y
define attributes in the Attributes tab of the Project dialog box. Requireme
attributes can be of entry or list-type. See also Attribute types, Attribute values. 
Compare List-type attributes.

Exclusive access: A condition by which access to a RequisitePro project a
its documents is only available to the user who opens the project. Exclus
access is required to change a variety of project characteristics. You set a
when you open a project. See also Concurrency.

Expand/collapse indicator: A small box displayed in one of the following 
locations: next to a requirement in a view, indicating that the requirement
one or more child requirements; or next to a discussion item in the Discuss
dialog box, indicating that the discussion item has responses. The box con
a + or a -, indicating whether or not the requirement or discussion is displa
in an expanded or collapsed state.

Extension: See File name extension.

External project: A project containing requirements used to establish 
traceability relationships with requirements in a currently open project.
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External requirement: A requirement residing in an external project. You ca
create traceability relationships between requirements in different project

External traceability : Traceability relationships between requirements in tw
different projects. See also Traceability.

File name extension: A DOS file name extension (for example, .prd). File 
name extensions are used in RequisitePro to indicate document type and
contain a maximum of 20 characters.

Filtering : A process by which you can change the amount of information 
displayed in a view in the Views Workplace. You specify certain criteria o
which to filter information. You can filter requirements by specifying certa
distinct criteria for any or all of their attributes. For example, instead of 
displaying all requirements, you might apply a filter such that only 
requirements having a high priority are displayed. See also Sorting, Queried 
view.

Graphic: Electronic line art or bitmapped artwork. You can use graphic 
formats such as Enhanced Metafile (.emf), Joint Photographic Experts G
(.jpg), Portable Network Graphics (.png), Windows Bitmap (.bmp, .rle, .di
and Windows Metafile (.wmf) in your RequisitePro documents. 

Group: A list of users, defined in project security and organized by the 
operations they have privileges to perform. For example, members of the
Administrators group can create group accounts and add users to groups

Hidden text: A Word feature used to hide text within a document. Hidden te
is delineated with a dotted underline. In RequisitePro, a requirement with
document begins with a requirement tag formatted in hidden text style.You
hide the tags for improved readability. On the Word menu bar, click Tools
then Options, and then click the View tab. Clear the Hidden text check box
click OK.

Hierarchical requirement : A requirement that is included within an ordere
relationship with other requirements of the same type. Use hierarchical 
relationships to subdivide a general requirement into more explicit 
requirements. Child requirements provide additional detail for their paren
requirement. For example: 
Parent requirement: The system shall display customer information.
Child requirements provided for detail: Name, Address, Date of Birth.
Each child requirement can only have one parent, but a requirement can
both a parent and a child. If a parent requirement is changed, the relation
with its children become suspect.
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Icon: A graphical representation of a RequisitePro command or process. W
used in RequisitePro on toolbars in the Tool Palette and Views Workplac
icons are typically referred to as buttons.

IEEE : (“I triple E”) Institute of Electronics and Electrical Engineers, the 
hardware and software standards body, sets standards for such measura
items as acceptability criteria, performance benchmarks, and configuratio
management. 

ISO 9000: (“eye-so”) International Organization for Standardization’s set o
industry specific standards. The ISO works to establish global standards 
communications and information exchange. The ISO 9000 standards are
of documents that can be used for quality assurance purposes. 

Keyboard shortcuts: A dialog box shortcut is a keyboard combination you 
can use to move to tabs, fields, and buttons in a RequisitePro dialog box
use a dialog box shortcut, press the Alt key while simultaneously pressing
underlined letter in a dialog tab, field, or button. For example, in the Proje
Document, or Requirement dialog box, press Alt-G to open the General t
A menu shortcut is a keyboard combination you can use to open a menu in
Tool Palette or Views Workplace. To use a menu shortcut, press the Alt k
while simultaneously pressing the underlined letter in the menu. For exam
to open the Requirement menu, press Alt-R. Once a menu is displayed, yo
select a command by pressing the key for the underlined letter in the comm

Keyword: Words that are used to help specify and define requirements. M
organizations use words such as “shall,” “must,” or “will” in their 
requirements, making it easier to separate a requirement from surrounding
in the document. Keywords are a part of the definition of a requirement ty
You enter keywords in the Requirement Must Contain field in the Requirem
Type dialog box. See also Requirement type.

Label (version information): A string that contains user-defined revision 
information, up to 20 characters. You can use a revision label for noting 
requirement, document, or project/archive version information.

Leaf tag: The last (rightmost) number in a requirement’s tag number. For
example, the leaf tag number for Requirement PRD201.7.9 is 9. See alsoRoot 
tag.

Licensed user: A RequisitePro user. Each user that is associated with a lice
of RequisitePro is a licensed RequisitePro user. See also User.
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List-type attributes : Requirement attributes are either list-type or entry-typ
List-type attributes are sets of descriptive values (for example, Status, wh
may contain the list values Proposed, Approved, In progress, and Compl
You can assign single values or multiple values for list-type attributes. Yo
define attribute values in the Attributes tab in the Project dialog box. See 
Attribute types, Attribute values. Compare Entry-type attributes.

Matrix : An arrangement of rows and columns used for organizing related
items in the Views Workplace. See Attribute Matrix, Traceability Matrix.

Menu: A list of options from which a user can make a selection in order to
perform a desired action. In RequisitePro, menus are available from the m
bar found above the buttons on the Tool Palette and in a View window. T
Word Workplace includes a RequisitePro menu with access to document
requirement, and window commands.

Menu file: A text file with specific syntax that is used to add menu comman
to any RequisitePro Tool Palette menu. Menu files typically have an MNU
TXT file extension. Menu files are referenced using the Add-ins command
the Tools menu. The commands appear on the RequisitePro menus in the
in which they are specified in the menu file.

Menu shortcuts: See Keyboard shortcuts.

Multiple select actions: Mouse actions and combination keyboard/mouse 
actions that you use to select multiple items in RequisitePro. Use Ctrl-Click to 
select multiple items that are not adjacent to each other. Hold down the Ctr
and click the mouse.(You can also use Ctrl-click to clear a selected item.)
Shift-click to select a range of items. Hold down the Shift key and click the
mouse. Use Drag to select a range of items. With one item selected, drag t
mouse. Release the mouse when the range is selected.

Multiple value list : An attribute type that supports one-to-many associatio
You can use a multiple value list when you want to assign a requirement m
than one value for a specific attribute.
For example, you might create an attribute type called Owner, with multip
values Bob, John, and Sue, representing different users working on the s
project. For this attribute, you might then assign only the values Bob and
to a particular requirement, indicating that Bob and Sue are responsible fo
particular requirement, but John is not.

Offline author:  A user who takes a RequisitePro document offline.
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Offline authoring:  A RequisitePro feature that lets users read and modify
document in Microsoft Word outside of RequisitePro (i.e., offline). When y
take a document offline, RequisitePro creates a copy of the document in 
directory you specify. The original is still stored in RequisitePro, but it is 
changed to a read-only document. Other users can view the document in
RequisitePro, but they cannot edit it until you bring it back online.

OLE : Object linking and embedding. You can create an OLE object in on
application (original application) and insert it into files in other, source 
applications. If you modify the OLE object in its original application, the 
changes are automatically reflected in any files containing the OLE object
source application. You can only modify an OLE object in its original 
application. You can use OLE objects in RequisitePro requirements 
documents.

Open project: See Current project.

Outline: A reference document or template used to create documents in 
RequisitePro. An outline can include formats, page layout information, 
attributes, attribute definitions and system defaults. An outline is useful fo
maintaining consistency across documents of the same type. An outline i
stored in a .def file. It includes the outline’s full name, a description of the
outline, and the associated Word template’s DOS filename. See also Template, 
Document type.

Parent requirement: A requirement that participates in a hierarchical 
relationship with one or more child requirements. A parent can reside at t
root level, or it can be nested in the hierarchy with a parent of its own. In ei
case, parents reside above their children in the hierarchy. See also Child 
requirement, Hierarchical requirement.

Parse: To break information into component parts so that a program can 
upon it. Used by the Import Wizard to separate requirements in a docume

Peer requirement: A requirement that is at the same hierarchical level as 
another requirement. For example, two requirements are peer requireme
when they are children of the same parent. In addition, all requirements a
root level are peer requirements of one another. See also Parent requirement, 
Child requirement, Hierarchical requirement.

Pending tag number: A tag number for a newly created requirement in a 
RequisitePro document. The requirement maintains the pending tag num
until the document is saved. See also Requirement tag.
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Permissions: The RequisitePro privileges granted to a group of RequisiteP
users. RequisitePro administrators or members of a group with project sec
permissions can assign permissions to groups. Also referred to as privileges or 
rights. See also Security.

Project: A RequisitePro project. A project includes a database, document
document types, requirements and their attributes, requirement types, 
requirement traceability, discussions, and user and group security. Within
RequisitePro, you create a project first. You then create requirement 
documents and requirements in each document.

Project database: The requirements database managed by RequisitePro.
requirements in the project are stored in the project database, including t
created in requirement documents. Changes you make to requirements i
documents are reflected in the project database. Microsoft Access, Oracle
Microsoft SQL Server databases are available to user for RequisitePro 
projects. See also Database.

Project directory: A directory that contains information for a single 
RequisitePro project. You define the project directory when you create a 
project (By default, RequisitePro creates a directory name that matches w
is typed in the Name text box in the Project Wizard). For projects that use
Microsoft Access database, the database is stored in the project directory
project directory does not store the database for projects that use an Ora
SQL Server database. Requirements documents for the project may be s
in another directory. The project directory path can contain up to 256 
characters. See also Directory.

Project prefix : An identifier used for requirements in cross-project 
traceability. In an external project, the prefix is displayed before the tag 
requirement, separated from the tag by a period. For example, if a 
requirement’s tag is PR234 and the project’s prefix is GLOBAL, then the 
external requirement is displayed as GLOBAL.PR234. The prefix can be u
8 characters, and must be uppercase letters. You can change the prefix a
time in the Project dialog box, General tab.

Project properties: The characteristics that make up a project, such as 
document types, requirement types, requirement attributes, the date a pr
was created, the user who created it, and the file location where the proje
stored.

Project summary report: A report that displays the project’s entire structur
in report form. The requirement types (and their attributes, including multi
value lists), document types, and document details are included in the prin
Glossary-10
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PVCS Version Manager: A version control product by Intersolv, which can
be used to store backup copies of RequisitePro projects. Alternately, pro
can be archived using Microsoft Visual SourceSafe, Rational ClearCase, o
RequisitePro Archive command.

Query: A method for filtering and sorting requirements in views by limiting
the values of one or more attributes or by limiting traceability, and specify
the order in which the filtered requirements display.
For example, you might create a query such that only requirements havin
high or medium priority are displayed. Within that filter, you might sort 
requirements first by priority, and then by cost.

Rational ClearCase: A version control product by Rational, which can be 
used to store backup copies of RequisitePro projects. Alternately, projects
be archived using Microsoft Visual Source Safe, Intersolv PVCS Version 
Manager, or the RequisitePro Archive command.

Rational Rose: Rational’s visual modeling tool for designing and visualizin
object-oriented and component-based applications. RequisitePro is integ
with Rose through Integrated Use Case Management.

Read-only access: An option by which a RequisitePro project or document
restricted to viewing only.

Renumbering: The process of assigning new numbers to requirements. T
renumber feature is useful for eliminating “holes” in a numbering scheme,
result when you delete requirements. To renumber requirements, you mu
open the project in exclusive mode. In addition, if security is enabled, you m
have project structure permission to renumber requirements. To renumbe
document-based requirements, all documents that contain requirements o
type must be open.

Reparenting: The process of reassociating a hierarchical requirement wit
new parent of the same requirement type. When you reparent a requirem
the entire sub-tree of children is also moved to the new parent. The repare
requirements are renumbered as if they were newly created for the new pa
See also Child requirement, Parent requirement, Hierarchy.

Repository: A collection of data; a database.

Requirement: A condition or capability to which the system being built mu
conform. 
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Requirement attribute: A descriptive field of information associated with a
requirement. RequisitePro requirement attributes are either system attrib
(defined by RequisitePro) or user-defined (defined by the project owner). 
Attribute.

Requirement attribute label: The name of the requirement attribute, such 
risk, priority, or author. See Attribute label. 

Requirement Attribute Matrix : See Attribute Matrix.

Requirement attribute type: See Attribute type.

Requirement attribute value: See Attribute value.

Requirement location: The location where a requirement was created or t
location to which it was last moved. The location can be either a specific 
RequisitePro document or the project database. A requirement’s location
important because you can only edit the requirement’s description in the 
requirement location. You edit the description for a document-based 
requirement in the document. You edit the description for a database-onl
requirement in the Requirement dialog box.

Requirement tag: The unique identifier of each requirement in a project. A
requirement tag is composed of a tag prefix and a unique numerical value,
as “PR100.1.2.” The tag prefix is always the requirement type, as defined
Project Properties. The numerical value is generated by RequisitePro. Th
prefix can contain a maximum of 20 characters. Each requirement type in 
project has a different tag prefix (for example, FEA, SR, TST) that you 
determine when you create a new project or add a new requirement type. W
you add a requirement to a requirements document or database, Requisi
assigns the requirement the appropriate tag prefix, dependent on its 
requirement type, and an incremental numerical value. See also Leaf tag, Root 
tag, Pending tag number.

Requirement type: A set of descriptive and operational information 
associated with a requirement when the requirement is created. A require
type serves as a template for all requirements of the same type and is use
classifying and grouping similar requirements in a project. Each requirem
type can its own set of user-defined attributes. See also Requirement attribute.

Requirement version: A requirement attribute that shows the version of th
requirement. As a requirement evolves, it is helpful to identify the version
numbers (and history) of requirements changes.
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Requirements document: A document created in Word or RequisitePro th
captures requirements and is used to communicate product developmen
efforts. Each requirements document addresses a particular requirement
A RequisitePro requirements document differs from a Word document in 
you can access requirement attributes and other information directly from
within the requirements document. Also referred to as a document or a 
RequisitePro document.

Requirements management: A systematic approach to eliciting, organizing
documenting, and managing the changing requirements of a software 
application.

RequisitePro document: A Word document that is part of a RequisitePro 
project. Most Word functionality is available within RequisitePro documen

Response: An answer to a discussion item. You can respond to the initial 
discussion topic or to other, previous responses. In RequisitePro, the term
“response” and “discussion response” are used interchangeably.

Revision: A distinct version of a project, document, or requirement. A revisi
is identified by a unique internal revision number, generated by Requisite

Revision number: The number identifying a revision. Revision numbers a
automatically incremented each time you or another user changes and sa
project, document, or requirement.

Root requirement: A requirement at the uppermost level of the requiremen
hierarchy. A root requirement does not have a parent requirement. See a
Parent requirement, Child requirement, Hierarchical requirement.

.rqs file: A text file, created and updated automatically by RequisitePro, th
stores project-specific information. Every RequisitePro project has an .rqs
which resides in the project directory. Do not modify any section of this fi
except the [MSProjectMappings] section, as described in RequisitePro On
Help.

Security: Prevention of system use, potential harm, or data loss by 
unauthorized individuals. In RequisitePro, users are given specific permiss
that determine the amount or kind of access they have to projects. If you 
RequisitePro administrator or a member of a group with project security 
permissions, you can assign permissions. See also Permissions.

Shift-click : See Multiple select actions.

SoDA: Rational’s Software Documentation Automation tool.
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Sorting: The process of establishing a specific order for the information in
RequisitePro View. You can sort requirements using one or many requirem
attributes. For example, you might sort requirements first by priority (high
medium, or low). Then, within priority, you might sub-sort by unique ID 
number. See also Filtering, Query.

Suspect relationship state: A state applied to a traceability or hierarchical 
relationship when a change occurs to one or both of the requirements in 
relationship. A suspect relationship state indicates that, because of the 
modification to the requirement(s), the relationship may need modification
well. See also Change-managed relationship, Traceability Matrix.

System analyst: An individual who leads and coordinates requirements 
elicitation and use-case modeling by outlining the system’s functionality a
delimiting the system.

Tag: See Requirement tag.

Tag prefix: The prefix for a requirement type. The prefix can be up to 20 
characters. A tag is a unique identifier assigned to each requirement you c
The tag prefix is defined as a part of the requirement type.

Template: A reference file used to create new Word documents. A templa
can include formats, page layout information, attributes, and attribute 
definitions. Templates are used in RequisitePro for requirements specifica
standards. In both Word and RequisitePro, templates use the file extensi
.dot. A Word template is part of a RequisitePro outline, which also includes
outline's full name and a description of the outline. Outlines are stored in 
files. In RequisitePro, the terms template and Word template are used 
interchangeably. See also Word template, Outline.

Tip revision: The current version of a project. If a project is not open, a tip
revision is the most recent version of the project.

Tool Palette: The main interface for accessing and working with RequisiteP
projects. Tool Palette buttons provide quick access to project information
requirements information, and views. You also use the Tool Palette menu
commands to perform requirements management operations in a Requisi
project.

Trace to/trace from relationship: A relationship between two requirements
that implies the source, derivation, or dependencies between the requirem
The trace to/trace from state appears in a traceability matrix or traceability
when you create a relationship between two requirements.
For example, you might create a software requirement (Requirement A) t
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Creating this requirement might cause you to create a test requirement 
(Requirement B) associated with that menu item. You would thus create 
traceability relationship in which the test requirement (B) is traced from th
software requirement (A). There can only be one traceability relationship 
between any two requirements.

Traceability : A relationship between two requirements that implies the 
source, derivation, or dependencies between the requirements using the 
to” and “trace from” features.

Traceability Matrix : A view that illustrates the relationships between 
requirements of the same or different types. You use this matrix to create
modify, and delete traceability relationships and view indirect relationship
and traceability relationships with a suspect state. You can also use the 
Traceability Matrix to filter and sort the row requirements and column 
requirements separately. See also View. 

Traceability relationship: See Trace to/trace from relationship.

Traceability Tree: A view that displays all internal and external requiremen
traced to or from a requirement (depending on the direction of the tree). T
traceability tree only displays the first level cross-project traceability. For 
example, if an internal requirement is traced to an external requirement, t
external requirement displays in the traceability tree, but other requireme
that the external requirement is traced do not displayed in the tree. Also 
referred to as a Tree view. See also View. 

Tree view: See Traceability Tree.

Type: See Requirement type.

Use case: A sequence of actions that a system performs, yielding an observ
result of value (a work output) to a particular actor (someone or somethin
outside the system that interacts with the system).

User: See Licensed user.

User information: A RequisitePro user’s user name, password, and e-ma
address. If you are a member of a group with project security permissions
can edit another user’s information. In addition, a user can edit his or her 
user information.

Users group: A security group that can, by default, read documents and 
requirements, create views, and participate in discussions. Administrators
modify Users group permissions.
Glossary-15



Rational RequisitePro Terms

 
ate, 
 

 

es of 

 can 
, or 

one 

risk 

d 
he 
ord 

at 

 
ality 
ts. 
sert 
ro 
in 
Version information : Unique, identifying information associated with a 
project, document, or requirement each time it is modified. The internally
generated revision number, combined with information about the author, d
time, and reason for modification, constitute version information. See also
Revision.

View: A window in the Views Workplace that displays requirements, the 
attributes assigned to requirements, and the relationships between 
requirements. A view displays information in spreadsheet-like tables or in
outline trees. In RequisitePro, the terms view and view window are used 
interchangeably. See also Attribute Matrix, Traceability Matrix, Traceability 
Tree.

Views Workplace: An area in RequisitePro where you analyze and print 
requirements information. The workplace displays and manages three typ
views: Attribute Matrix, Traceability Matrix, and Traceability Tree.

Visual SourceSafe: A version control product by Microsoft, which can be 
used to store backup copies of RequisitePro projects. Alternately, projects
be archived using Intersolv PVCS Version Manager, Rational ClearCase
the RequisitePro Archive command.

Wildcard character: A keyboard character that can be used to represent 
or many characters. Typically the asterisk (*) represents one or more 
characters and the question mark (?) represents a single character. For 
example, the file specification *.* (pronounced star-dot-star) uses the aste
wildcard to mean “any combination of file name and extension.”

Word application : Microsoft Word, the word processor used to specify an
manage requirements and requirements specifications in RequisitePro. T
integrated implementation of Word in RequisitePro is referred to as the W
Workplace.

Word document: A document created in Microsoft Word or RequisitePro th
is saved in Word format. See also RequisitePro document.

Word Template: See Template.

Word Workplace : A Microsoft Word window within RequisitePro where you
view, create, and modify documents. RequisitePro uses the Word function
to provide powerful features for viewing, editing, and formatting documen
You can open several documents at a time, apply character styles, and in
objects into your documents. The Word Workplace includes a RequisiteP
menu for managing RequisitePro requirements and documents from with
Word. Also referred to as Word window.
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multi-dimensional attributes 1-11

N
navigating

in the attribute matrix A-4
in the traceability matrix A-8
in the traceability tree A-12

non-tip revisions
in ClearCase 14-12
in PVCS Version Manager 14-18
in Visual SourceSafe 14-15

O
offline authoring 7-10

bringing documents back online 7-14
without saving offline changes 7-16

creating requirements in offline documents 
7-13

deleting requirements in offline documents 
7-13

determining whether a document is offline 7-
12

enabling Word macros when using 7-12
modifying offline documents 7-12
obtaining information about offline 

documents 7-12
overview 7-10
reading offline documents 7-17
saving offline changes 7-14
taking documents offline 7-11
Word master documents 7-18

OLE objects 8-18, 8-22
opening

documents 3-4, 7-3
projects 3-4

exclusive access 3-5, 14-1
views 4-12

options command 14-4
Oracle 11-1, 11-13, 11-24, 12-2, 14-23
ordering
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Index
discussions 6-14
outlines 14-4

assigning to document types 14-3
creating 14-4
creating secondary location 14-4
using RequisitePro templates 14-3

P
parent, changing 9-5
parent-child relationships 2-10, 4-3

see also hierarchical relationships 2-10
parsing, definition 11-9
participants

notifying about discussions 6-6
responding to discussions 6-8

passwords
changing 3-8
editing 13-5
limitations 13-4
modifying 3-8
new 13-4

peer requirements 9-3
permissions

attribute permissions 13-10
attribute values 13-12
document type 13-8
group 13-6
requirement type 13-9

printing
discussions 6-14
project summaries 14-5
reports 14-5
views 4-14

Project Administration Tips xviii
project components

viewing in PVCS Version Manager 14-20
viewing in Visual SourceSafe 14-16

project conversion wizard 12-10
project database 2-3
project dialog box 11-2

attributes tab 15-6
document types tab 15-1, 15-2

documents tab 15-1
general tab 15-11
requirement types tab 15-3, 15-4
revision tab 12-3

project list 2-3
adding projects 3-3
removing projects 3-4

project management 14-1
project managers xvi
project security

adding users to a group 13-4
administrators group 13-2
assigning permissions 13-6
creating groups 13-3
deleted users group 13-2
deleting groups 13-4
deleting users from a group 13-5
editing passwords 13-5
editing user name 13-5
enabling 14-1
entering e-mail addresses 6-2
groups and users 13-2
moving users 13-6
permissions 13-6
users group 13-2

project summaries, printing 14-5
project version control 2-3
project wizard 12-4
projects 2-2

adding
to ClearCase 14-10
to PVCS Version Manager 14-17
to the project list 3-3
to Visual SourceSafe 14-13

archiving 14-7
checking into

ClearCase 14-11
PVCS Version Manager 14-18
Visual SourceSafe 14-14

checking out of
ClearCase 14-12
PVCS Version Manager 14-17
Visual SourceSafe 14-15
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cloning 12-8
closing 3-7
components 14-16, 14-20
connecting for cross-project traceability 15-

13
converting earlier versions 12-10
copying 14-22
creating 12-1

with a blank database 12-1
with a template 12-8
with project wizard 12-4

cross-project traceability 5-8
definition 2-2
deleting from Visual SourceSafe 14-16
disconnecting from external traceability 15-

15
discussions 6-1
groups and users 13-2
integrating 16-1
list 2-3
locating discussions in 6-11
managing 14-1
modifying information 15-1
moving 14-21
opening 3-4
removing

from PVCS Version Manager 14-19
from the project list 3-4
from Visual SourceSafe 14-16

removing revision information 14-20
revision information 12-3
security 13-1
setting up user access 14-1
storing backup copies 14-7

properties for views 4-20
protecting documents for revisions 14-2
PVCS Version Manager

adding projects to 14-17
checking projects into 14-18
checking projects out of 14-17
removing projects 14-19
unlocking checked-out projects 14-19
updating projects 14-19

using to archive projects 14-17
viewing non-tip revisions in 14-18
viewing project components 14-20

Q
queried views 5-1
queries 4-4

building 5-3
creating 5-3
deleting 5-5
modifying 5-5
query now 4-2, 5-1
refresh all 4-2, 5-1
saved in views 4-10
traced to/traced from 5-2

query command 5-2
query now 4-2, 5-1
query, definition 5-1
querying 5-1

traced to/traced from 5-2
Quick Start xviii

R
Rational ClearCase 14-9
Rational ClearQuest 16-20
Rational Rose 16-17, 16-18
Rational SoDA 14-6
Rational Suites TestStudio 16-19
Rational Synchronizer 16-18
reading

discussions 6-7
offline documents 7-17

read-only access 14-1
read-only documents 7-17
rebuilding damaged tags 8-19
recommended reading 1-15
references 1-15
refresh all 4-2, 5-1
refresh command 5-2
removing, see also deleting

attribute values 15-10
bookmarks 11-5
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document types 15-3
documents 14-21
projects

from PVCS Version Manager 14-19
from the project list 3-4
from Visual SourceSafe 14-16

queries 5-5
requirement types 15-6
requirements 14-21
revision information for a project 14-20

renaming views 4-13
renumbering requirements 8-19, 14-5
reparenting 9-5
replying

to discussions 6-8
requirement attributes 2-9

adding 15-6
creating 15-6
data types 15-8
deleting for MSPT types 16-17
editing values 15-10
modifying values 8-12
permissions 13-10
removing values 15-10
viewing in an attribute matrix 4-4

requirement dialog box
attributes tab 8-12
discussions tab 6-19
general tab 8-2
hierarchy tab 4-3
revision tab 8-10
traceability tab 10-2

Requirement Metrics 14-5
requirement numbers 11-14
requirement tags

rebuilding 8-19
viewing in an attribute matrix 4-4

requirement types 1-9, 2-9
adding 15-3
compared to document types 2-8
copying from another project 12-8
creating 15-3
definition 2-9, 15-3

marking for cross-project traceability 15-12
MSPT 16-3
new 8-13
overview 1-1
permissions 13-9
removing 15-6

requirement types tab 15-3, 15-4
requirements 2-2, 8-1

assigning new parents 9-5
to a single requirement 9-5
to multiple requirements 9-7

associating with new types 8-13
multiple requirements 8-14
single requirements 8-13

attribute values 8-2
can’t create 8-7
changing parents 9-5
color, refreshing 8-21
copying 8-15

from view 8-16
creating

child requirements 9-1
in a database 8-7
in a document 8-2
in offline documents 7-13
multiple 8-4
peer requirements 9-3
sibling requirements 9-4
using fast create 8-3

cutting 8-15
from view 8-16

definition 1-2, 2-2, 8-1
deleting 8-21

in offline documents 7-13
description 8-2
discussion information 6-19
exporting 11-23, 11-24
fast create 8-3
filtering and sorting 5-1
find requirement command 5-7
go to 5-8
hidden text 8-1
hierarchical relationships 9-1
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importing 11-6
key words 8-4
locating discussions associated with 6-11
modifying information 8-11
moving 8-15, 8-17
numbering when imported 11-14
parent-child relationships 9-1
querying 5-1
rebuilding tags 8-19
recording changes 8-11
refreshing color and style 8-21
renumbering 8-19, 14-5
revising 8-9
revision information 8-10
searching for 5-5
sibling requirements 9-4
sorting 5-2
style, refreshing 8-21
suspect relationships 9-9, 10-9
text delimiters 8-4
traceability relationships 10-1
troubleshooting 8-7
unmarking 8-21
Word style 8-4

requirements authors xvi
requirements contributors xvi
requirements documents, see documents
requirements management 1-2, 1-3, 1-12

fundamentals 1-1
problems 1-4
skills 1-5–1-8
tour xviii

Requirements Management Tour xviii
requirements menu 10-3
requirements only import option 11-11
requirements viewers xvi
RequisitePro Extensibility Interface 5-10
RequisitePro format 11-2
resizing

tree pane 4-8
views 4-18

responding to discussions 6-8
using e-mail 6-9

using RequisitePro 6-8
reviewing

changes in a document 7-5
revising requirements 8-9
revision information 12-3

removing 14-20
revision tab

document dialog box 7-7
project dialog box 12-3
requirement dialog box 8-10

revisions
in ClearCase 14-11
in PVCS Version Manager 14-17
in Visual SourceSafe 14-13
protect for revisions 14-2

Rose 16-17
row height in views 4-16

S
saving

bookmarks 11-5
documents 7-2, 7-5
requirements document as Word file 7-7
view properties 4-21
views 4-10

searching
active view 5-7
database 5-6
documents 5-7
find requirement command 5-7
for requirements 5-5
go to command 5-6
views 5-7

security 13-1
disabling 13-2
enabling 13-2
groups and users 13-2

security groups
adding users 13-4
creating 13-3
deleting 13-4
deleting users 13-5
Index-10
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moving users 13-6
selecting

items in a traceability matrix A-7
items in a traceability tree A-12
items in an attribute matrix A-3

selecting multiple items A-1
setting up project security 14-1
shortcuts A-1

dialog box A-1
menu A-1

sibling requirements 9-4
SoDA 14-6
sort ascending 5-4
sort descending 5-4
sorting

discussions 6-14
requirements 5-2
sort order 5-4

sorting and filtering 5-1
see also querying, queries

SQL Server 11-1, 11-13, 11-24, 12-2, 14-23
starting

RequisitePro 3-1
suspect relationships 2-12, 4-5, 4-8, 9-9, 10-9

change affects suspect option 15-9
clearing 9-10, 10-10
displaying 9-10, 10-9

T
tags, rebuilding 8-19
terminating

discussions 6-20
terms Glossary-1
TestStudio 16-19
text delimiters 8-4
text pane 4-8
tile view 4-19
tip revisions

using with ClearCase 14-9
viewing non-tip revisions

in ClearCase 14-12
in PVCS Version Manager 14-18

in Visual SourceSafe 14-15
viewing project components

Visual SourceSafe 14-16
tool palette 2-4, 3-1

customizing menus B-3
discussions icon 6-1, 6-6
menus B-3

traceability 1-10, 2-11, 4-3, 10-1
clearing suspect relationships 10-10
creating

in attribute matrix 10-4
in requirements document 10-2
in traceability matrix 10-5
in traceability tree 10-6
in views workplace 10-4
in Word workplace 10-2
using requirements menu 10-3

cross-project 15-11
direct and indirect 2-12
in MS Project 16-7
overview 10-1
suspect relationships 10-9

traceability matrix 2-6, 4-5, 5-2
cells 4-5
definition 2-6, 4-1
displaying properties 4-21
keyboard shortcuts A-8
mouse actions A-7
querying in the 5-2
text panes 4-6

traceability tab 10-2
traceability tree 2-6, 4-7, 5-3

attribute pane 4-8
definition 2-6, 4-1
displaying properties 4-20
keyboard shortcuts A-12
mouse actions A-12
querying in the 5-3
text pane 4-8

traced from 4-5
traced to 4-5
traced to/traced from 2-12
tree pane 4-7
Index-11
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troubleshooting
failed multiple select actions 10-8
when creating requirements 8-7

U
undoing checked-out projects

ClearCase 14-12
unlocking

checked-out projects using PVCS Version 
Manager 14-19

project documents 14-2
unmarking

requirements 8-21
updating projects

using PVCS Version Manager 14-19
Use Case Management, Integrated 16-18
user access to projects and documents 14-1
user name

changing 3-8
editing 13-5
modifying 3-8
restrictions 13-4

users group 13-2

V
view

copying requirements in 8-16
cutting requirements in 8-16

view properties
displaying 4-20
saving as default 4-21

viewing, see also displaying
discussion attributes 6-14
discussion participants 6-15
discussion properties 6-6
discussions 6-1, 6-7, 6-12, 6-14
non-tip revisions

in ClearCase 14-12
in PVCS Version Manager 14-18
in Visual SourceSafe 14-15

offline documents 7-17
project components

PVCS Version Manager 14-20
Visual SourceSafe 14-16

views 2-6, 4-1
arranging 4-18
arranging icons 4-19
attribute matrix 2-6
cascade 4-18
closing 4-12
collapse all 4-10
column width 4-17
creating 4-9
cross-project traceability 5-9
customizing 4-16
definitions 4-1
deleting 4-15
displaying properties 4-20
duplicating 4-13
expand all 4-10
exported 5-10
exporting as Word document 11-24
navigating 4-2
opening 4-12
printing 4-14
properties command 4-20
query now 4-2
refresh all 4-2
renaming 4-13
resizing 4-18
row height 4-16
saving 4-10
searching 5-7
tile 4-19
traceability matrix 2-6
traceability tree 2-6

views workplace 2-6
Visual SourceSafe

adding projects to 14-13
archiving projects using 14-13
checking projects into 14-14
checking projects out of 14-15
deleting projects in 14-16
logging into 14-13
viewing non-tip revisions in 14-15
Index-12
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viewing project components in 14-16

W
wizards

Database Type Conversion Wizard 14-23
Import Wizard 11-1
MS Project Integration Wizard 16-1
Project Conversion Wizard 12-10
Project Wizard 12-4

Word format 11-3
Word style 8-4
Word workplace 2-4
Word, see Microsoft Word
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