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Preface
This manual tells you how to install Rational testing products, including the steps you 
need to take both before and after installation. With Rational testing products, you can 
plan, develop, and execute both functional and performance tests for your Windows 
Millennium, Windows NT 4.0, Windows 2000, Windows 98, and Windows 95 
applications, as well as manage all testing activities — planning, design, 
development, execution, and analysis — using Rational TestManager.

Audience

This guide is intended for Rational software users who are installing Rational testing 
products, such as system administrators, application developers, quality assurance 
managers, and quality assurance testers.

Other Resources

■ Rational testing products contain complete online Help. From the main toolbar, 
you can choose an option from the Help menu. 

■ All manuals for this product are available online in PDF format. These manuals are 
on the Rational Solutions for Windows Online Documentation CD.

■ For information about training opportunities, see the Rational University 
Web site: http://www.rational.com/university.

Contacting Rational Technical Publications

To send feedback about documentation for Rational products, please send e-mail to 
our technical publications department at techpubs@rational.com.
v



Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product, contact 
Rational Technical Support as follows:

Note:  When you contact Rational Technical Support, please be prepared to supply the 
following information:

■ Your name, telephone number, and company name

■ Your computer’s make and model

■ Your operating system and version number

■ Product release number and serial number

■ Your case ID number (if you are following up on a previously-reported problem)

Your Location Telephone Facsimile E-mail

North America (800) 433-5444
(toll free)

(408) 863-4000
Cupertino, CA

(781) 676-2460
Lexington, MA

support@rational.com 

Europe, Middle 
East, Africa

+31 (0) 20-4546-200
Netherlands

+31 (0) 20-4545-201
Netherlands

support@europe.rational.com 

Asia Pacific +61-2-9419-0111
Australia

+61-2-9419-0123
Australia

support@apac.rational.com 
vi Preface



1Before You Begin
This chapter tells you what you need to know before installing Rational testing 
products and is organized as follows:

■ About Rational TestManager on page 1

■ About Rational Robot on page 1

■ About Rational TeamTest on page 2

■ About Rational ClearQuest Databases on page 2

■ About Licensing on page 3

■ Hardware and Software Requirements on page 4

■ Before You Install Rational Testing Products on page 6

■ Installing Client Software for Performance Testing on page 7

About Rational TestManager

Use Rational TestManager to manage all testing activities: planning, design, 
development, execution, and analysis. TestManager ties testing to the rest of the 
development effort, joining your testing assets and tools to provide a single point 
from which to understand the exact state of your project. 

Note:  If you plan to do performance testing, you need to install the Rational Test 
Agents. See Installing Rational Test Agents on page 35.

About Rational Robot

When you install Rational Robot, you install all of the following components: 

■ Rational TestManager, which is described in the previous section.

■ Rational Robot – Use to develop and execute functional tests for your Windows 
applications. For information, see the Using Rational Robot manual.
1



■ Rational Administrator – Use to manage a Rational project. For information, see 
the Using the Rational Administrator manual.

■ Rational SiteCheck – Use to manage Internet and intranet Web sites. For 
information, see the Rational SiteCheck Help.

■ Comparators – Includes the Object Properties, Text, Grid, and Image Comparators. 
Use to view and analyze the results of test script playback. For information, see the 
Using Rational TestManager manual and the Comparators Help.

About Rational TeamTest

When you install Rational TeamTest, you can install some or all of the components 
available on your installation CDs. The following list describes Rational TeamTest:

■ Rational TestManager and Rational Robot, described previously.

■ Rational ClearQuest– Use to track defects of your testing project. Rational Robot 
installs this version of Rational ClearQuest, which includes specially designed 
defect forms.

About Rational ClearQuest Databases

Before you create or attach a ClearQuest database to a project using the Rational 
Administrator, you need to:

■ Configure ClearQuest by creating a new schema project or by connecting to an 
existing schema project. A ClearQuest schema project stores all schemas and all 
data associated with existing schemas in a special project. The schema project does 
not store any user data. For more information about configuring a schema project, 
see the Installing Rational Suite manual.

■ Decide what type of ClearQuest user database to use. A ClearQuest user database 
contains all user data and a copy of the schema associated with the database. User 
data in a ClearQuest database includes change-request records such as defects, as 
well as reports, records, tables, and all other data entered by users.
2 Chapter 1 - Before You Begin



The following table summarizes which type of database software to use for a 
ClearQuest database:

Table 1 Determining a Database Type for ClearQuest

About Licensing

If you want to play back more than one virtual tester, you need to purchase the 
appropriate licenses and install a license server. See Administering Licenses for Rational 
Software for the software licensing description, procedures, and licensing 
administration information. The online Help for Rational License Key Administrator 
contains detailed information about common user licensing activities.

If you have Then 

Seven or fewer concurrent users 
who will not access the database 
over a wide-area network

Use a Microsoft Access database. This is the default 
database and installs automatically when you install 
Rational software.

Note:  Rational ClearQuest Web does not support Microsoft 
Access databases.

This database is virtually maintenance-free; for example, 
you can back it up by simply backing up the Rational 
project directory. However, with more than seven 
concurrent users, database access is relatively slow.

Eight or more concurrent users 
who will access the database 
over a wide-area network

Use the Sybase SQL Anywhere Database Server software 
that comes on Disc 2 of the Rational Solutions for Windows 
CDs.

We recommend using a Window NT Server for your 
database server because a Windows NT Workstation allows 
only ten network connections.

Eight or more concurrent users 
and you want to use Microsoft 
SQL Server for your database

Use Microsoft SQLServer to create an empty database 
foundation to use with ClearQuest.

For information about using Microsoft SQL Server for 
ClearQuest, see the Installing Rational ClearQuest manual, 
available on the Rational Solutions for Windows Online 
Documentation CD.

Eight or more concurrent users 
and you want to use Oracle 
software

Use Oracle to create an empty database foundation to use 
with ClearQuest.

For information about using Oracle for ClearQuest, see the 
Installing Rational ClearQuest manual, available on the 
Rational Solutions for Windows Online Documentation CD.
About Licensing 3



Hardware and Software Requirements

Make sure that your computer conforms to the following minimum requirements for 
each product or component you plan to install.

Table 2 Hardware and Software Requirements

Rational component Minimum requirements

Rational TeamTest PC-compatible computer with a Pentium microprocessor
(133 MHz or better recommended)

300 MB free disk space (minimum installation)

64 MB RAM is the recommended minimum; more memory 
generally improves responsiveness.

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows 2000, Windows 98 2nd edition, or 
Windows 95 SR2

Rational Robot PC-compatible computer with a Pentium microprocessor 
(133 MHz or better recommended)

200 MB free disk space (minimum installation)

64 MB RAM is the recommended minimum; more memory 
generally improves responsiveness.

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows 2000, Windows 98 2nd edition, or 
Windows 95 SR2

Rational TestManager PC-compatible computer with a Pentium microprocessor 
(133 MHz or better recommended)

200 MB free disk space (minimum installation)

64 MB RAM is the recommended minimum; more memory 
generally improves responsiveness.

1-3 MB RAM per virtual tester

1-3 MB disk space per virtual tester

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows 2000, Windows 98 2nd edition, or 
Windows 95 SR2

If you are running Visual Basic language test scripts, VB 6 on 
Windows 2000 or Windows NT is required.

If you are running Java test scripts, the JDK (IBM version 1.1.7B 
or Sun Microsystems versions 1.2.2 or 1.3.0) is required.
4 Chapter 1 - Before You Begin



Rational Test Agent software 
– Windows Systems

PC-compatible computer with a Pentium microprocessor 
(133 MHz or better recommended).

64 MB memory.

150 MB free disk space for installation. We recommend more 
disk space for large virtual tester runs.

Microsoft Windows Millennium, Windows NT 4.0 (Service 
Pack 5 or 6a), Windows 2000, Windows 98 2nd edition, or 
Windows 95 SR2.

If you are running VU test scripts, Microsoft Windows NT 4.0 
(Service Pack 5 or 6a) or Windows 2000 is required.

If you are running Visual Basic language test scripts, VB 6 
Service Pack 3 and Windows 2000, or VB 6 Service Pack 3 and 
Windows NT.

If you are running Java test scripts, the JDK (IBM version 1.1.7B 
or Sun Microsystems versions 1.2.2 or 1.3.0).

TCP/IP

Rational Test Agent software 
– UNIX Systems

32 MB memory, plus .5–2 MB per virtual tester (some 
workloads may require more memory).

150 MB free disk space for installation. We recommend more 
disk space for large virtual tester runs.

One of the following operating systems:
AIX 4.3

HP-UX 11

DYNIX/ptx

Solaris 2.5, 2.6, or 2.7

Red Hat 6.x release of Linux

If you are running Java test scripts, the JDK (IBM version 1.1.7B 
or Sun Microsystems versions 1.2.2 or 1.3.0).

Rational ClearQuest Web ClearQuest Web is included with Rational TeamTest. 

Microsoft Internet Information Server (IIS) with Active Server 
Pages. 

Crystal Reports 8.0 
Professional Edition

80 MB free disk space (minimum installation)

Rational component Minimum requirements
Hardware and Software Requirements 5



Before You Install Rational Testing Products

This section contains information about tasks to do before you install Rational testing 
products. Before you install Rational testing products, be sure to do the following:

■ If you are running a previous version of Rational Suite PerformanceStudio or 
Rational LoadTest be sure to uninstall these products first.

Previous versions of Rational LoadTest and Rational Suite PerformanceStudio will 
not work with testing products from this release. You must uninstall them first.

■ If SQA Suite 6.x is installed on your computer, you do not have to uninstall it. The 
current version of Rational testing products and SQA Suite 6.x. can coexist because 
they are installed in different directories.

■ Decide which type of database you need for your ClearQuest database. For more 
information, see About Rational ClearQuest Databases on page 2.

■ Make sure that all computers have TCP/IP installed. Install any updates to your 
network software that you have not installed.

■ Verify that the computers are communicating with each other. (If you have any 
problems, see your network administrator.)

SQL Anywhere Server Your network server must be an Intel-based PC.

Windows 2000, Windows NT 4.0 Server, Windows NT 4.0 
Workstation

Pentium processor

64 MB memory

100 MB disk space

TCP/IP

Note:  Novell NetWare software is no longer supported for 
network servers.

Rational component Minimum requirements
6 Chapter 1 - Before You Begin



For Rational performance testing products:

■ Determine the role each computer will play in testing—whether it will be a Local 
or an Agent computer. For information, see Installing Rational Test Agents on 
page 35.

■ Install the appropriate client software. For information, see Installing Client 
Software for Performance Testing on page 7.

■ Determine the kind of network you will be using, either Ethernet or Token Ring. 
You will need to know this when you install the Rational Test network driver. For 
information, see Installing and Removing the Network Driver on page 31.

Installing Client Software for Performance Testing

To play back a test script that tests Oracle, Sybase, or SQL Server databases on a Local 
or Agent computer, you must install the appropriate database client software before 
you install any Rational testing products.

Oracle Client Software

To play back a test script that tests an Oracle database on a Local or Agent computer, 
you must install Oracle client software. 

Sybase Client Software

To generate test scripts that test a Sybase database, you must install the Sybase 11.1 
NT client software on the Local computer. 

To play back test scripts that test a Sybase database, you must install the appropriate 
software on each Agent computer: 

■ For UNIX Agents, install Sybase 11.1 UNIX client software

■ For NT Agents, install Sybase 11.1 NT client software

SQL Server Client Software

To generate test scripts that test a SQL Server database, you must install the SQL 
Server 6.5 or newer NT client software on the Local computer. 

To play back SQL Server test scripts on an Agent, you must install the appropriate 
software on each Agent computer as follows: 

■ For UNIX Agents, install Sybase 11.1 UNIX client software (limited compatibility)

■ For NT Agents, install SQL Server 6.5 or newer NT client software
Installing Client Software for Performance Testing 7



TUXEDO Protocol Software

To generate test scripts using the TUXEDO protocol, you must install the TUXEDO 6 
client software on the Local computer. 

SAP Protocol Software

To generate test scripts using the SAP protocol, you must install the SAP Frontend 
software, typically referred to as SAPGUI, on the Local computer.

DCOM Protocol Software

Before you play back test scripts that use the DCOM protocol on an Agent computer, 
ensure that the client application recorded on the Local computer also runs on the 
Agent. This ensures that the necessary COM objects are present and properly 
registered on the Agent.
8 Chapter 1 - Before You Begin



2Installing Rational Testing 
Products
This chapter explains how to install the Rational testing products TeamTest, Robot, 
and TestManager. It includes the following topics:

■ Installation Types on page 9

■ Installing Rational Robot, Team Test, and TestManager on page 10

■ Removing Your Software on page 12

■ Troubleshooting Your Installation on page 12

Note:  Please see the Installing Rational Suite manual for directions on how to install 
TestStudio.

Installation Types

The Rational Software Setup program provides you with several installation types, 
letting you install the configuration most appropriate for your system. The following 
table describes the installation types:

Table 3 Installation Types

Type Description

Typical Installs the most commonly used features for a product. 

Use this option for standard installations.

Custom/Full Allows you to add or remove products or product features. 
Defaults to all features in a typical installation.

Use this option to install Web Server Components on a Web 
Server (ClearQuestWeb and TestManager/Web).

Compact/Laptop Installs a subset of the standard configuration. May omit 
optional files, including online documentation or online 
Help. Use this option on systems with limited disk space.

Minimal Installs the files needed to run the program from a CD or 
network location. Use this option to run the program from a 
centrally managed location.
9



Installing Rational Robot, Team Test, and TestManager

This section describes how to install Rational Robot, TeamTest, and TestManager. 

1 Log in using an account with Administrator privileges.

2 Insert the Rational Solutions for Windows Disc 1 CD into your CD drive. The 
installation starts automatically.

If the installation does not start automatically, do the following:

a Click Start > Run.

b Type drive:\SETUP.EXE, and then click OK.

3 At the Rational Software Setup screen, click Next.

4 At the Choose Product to Install screen, select one of the following from the list of 
available products, and then click Next:

❑ Rational Robot

❑ Rational TeamTest 

❑ Rational TestManager

Note:  To install a Rational Test Agent, see Installing Rational Test Agents on page 35.

For information about software licenses, click Help or see the Administering Licenses 
for Rational Software manual. 

5 Read the terms of the license agreement, select Yes, I accept the agreement, and 
then click Next. 

If you do not accept the agreement, the Setup program ends.

6 Select the setup configuration you prefer, and then click Next.

❑ Typical – Installs the most commonly used features for this product. 

❑ Custom/Full – Lets you specify which products or features to install.

❑ Compact/Laptop – Installs the smallest subset of features needed to run this 
product.

❑ Minimal – Configures your machine to run the product from a network drive.

If the Upgrade Compatibility screen appears, you have additional, older Rational 
products installed on your system. Because Rational tools share files and 
components, this installation can cause the older Rational products to stop 
working. You will see no visual clue that the older products may be compromised.
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7 For each additional, older product listed, we recommend that you either:

❑ Upgrade it – Complete this installation, and then restart the Setup wizard to 
upgrade the listed products. Upgrading each product updates all necessary 
files, registry entries, startup menu items, and shared components. See the 
product-specific upgrade section in Before You Begin on page 1 for requirements.

❑ Remove it – Complete this installation, and then see Removing Your Software on 
page 12 for the removal procedure.

8 If the Update Shared Components screen appears, do one of the following: 

❑ Click Next to install the shared components listed. Setup installs the U.S. 
English versions of the files. It does not overwrite newer versions of the files. 

❑ Click Replace files with newer versions in English to replace your version of the 
shared components with the U.S. English version. (This option is available only 
if you installed earlier versions of the shared files in a non-U.S. English 
language.) 

❑ Click Cancel to exit Setup and install the shared files yourself. 

Note:  A shared component is software provided by a company other than Rational 
Software Corporation. It is potentially available to other applications on your 
system. In general, we recommend that you let the Rational setup procedure install 
shared components for you.

9 At the Rational Confirmation screen, view the selections that you have made and, 
if they are correct, click Next.

10 Click Finish when done. 

11 You must shut down and restart your computer to finish the installation. Log in 
again using the same user account and Administrator privileges that you used to 
start the installation. This allows the setup program to complete. 

If you need to install a software license, the online Help for Rational License Key 
Administrator contains detailed information about common user licensing activities. 
Refer to Administering Licenses for Rational Software for the software licensing 
description, procedures, and licensing administration information. 

When to Install Shared Files Yourself

You may want to install shared files yourself under the following circumstances:

■ You are using a U.S. English system, but installing new files may invalidate your 
current environment. In this case, you need to determine how to correct your 
environment so you can run existing tools and the Rational products that you 
want to install.
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■ Your site may mandate that you obtain shared files directly from the
source — for example, from Microsoft — rather than using files supplied by a third 
party. Or, your site may prohibit end-users from installing shared components.

■ You may want to install equivalent files that are localized to your language. 
Rational Software supplies only U.S. English versions of shared files. 

■ There may be a later version of the files available. Rational products should work 
with the supplied version of shared files or any later versions.

Removing Your Software

To remove Rational software products, make sure that no one is using the Rational 
software on your system. You cannot remove files that are in use. To remove Rational 
software from a Windows NT system, you must have Windows NT administrator 
privileges on the local machine. The Rational Software Setup program does not 
remove directories that contain files that you have created using Rational software 
products.

To remove Rational software from your computer:

1 Click Start > Settings > Control Panel.

2 Click Add/Remove Programs.

3 Select the Rational product that you want to remove, and then click Add/Remove.

Troubleshooting Your Installation

If you encounter any problems running the Rational Setup wizard, try the following 
suggestions before you call Rational Technical Support for help:

■ Stop all applications before you begin the installation.

■ Turn off all virus protection software. These programs often run in the background 
and interfere with the installation and file decompression process.

■ Turn off any user interface managers or desktop environments that run on 
Microsoft Windows.

■ Change to a standard VGA video driver while Rational Setup is running, or 
disable video features such as virtual screens or screen switching.

■ Change to a standard mouse driver, or disable special mouse features that perform 
tasks such as leaving pointer trails or changing pointer sizes.
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3Upgrading from Previous 
Releases
This chapter is organized as follows:

■ General Information on Upgrading on page 13

■ Upgrading from Rational Test 2001.03 to 2001A.04 on page 13

■ Upgrading from Rational Test 7.x to 2001A.04 on page 14

■ Upgrading a Rational 7.x Repository to a Project on page 15

■ Upgrading from Rational Test 6.x to 7.x on page 18

■ Installing the Rational Test 6.x to 7.x Repository Upgrade Kit on page 18

General Information on Upgrading

We recommend that you upgrade data from a previous version of Rational testing 
products to the current version after you finish working on a project. 

Be sure to back up your data before you upgrade.

Upgrading from Rational Test 2001.03 to 2001A.04

If you are upgrading from Rational Test 2001.03 to 2001A.04, you must do the 
following tasks in order:

1 Install Rational Test 2001A.04. For details, see Installing Rational Robot, Team Test, 
and TestManager on page 10.

2 Upgrade your TeamTest/TestStudio-based schema to the latest package versions. 
The latest packages include:

❑ Repository 2.0

❑ TeamTest 3.0

❑ RequisitePro 1.5

❑ Email 5.0

❑ PQC 2.0
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For detailed procedures about upgrading ClearQuest packages and the database, see 
the section on “Updating ClearQuest” in the Installing Rational Suite manual. This 
manual is available on the Rational Solutions for Windows Documentation CD and is 
also available for Web download at www.rational.com. 

Note:  You must follow all of the instructions in the “Updating ClearQuest” section of 
the Installing Rational Suite manual to successfully perform the upgrade.

Upgrading from Rational Test 7.x to 2001A.04

If you are upgrading from Rational Test 7.x (or Rational Suite 1.x), you must do the 
following tasks in order:

1 Install Rational Test 2001A.04. For details, see Installing Rational Robot, Team Test, 
and TestManager on page 10.

2 Upgrade your TeamTest/TestStudio-based schema from the version available in 
ClearQuest 7.x.

For detailed procedures about upgrading ClearQuest packages and the database, 
see the section on “Updating ClearQuest” in the Installing Rational Suite manual. 
You must follow all of the instructions in “Updating ClearQuest” to successfully 
perform the upgrade.

Note:  If you are upgrading from Rational Test 7.0, you must first apply the 
following two packages and upgrade your database before applying any other 
required packages:

❑ Repository Upgrade 0.2 

❑ TeamTest Upgrade 0.1

For a list of the other required packages, see Upgrading from Rational Test 2001.03 to 
2001A.04 on page 13.

3 Convert your Rational 7.x repository to a project.

See Upgrading a Rational 7.x Repository to a Project on page 15 for directions. 

Note:  If you are upgrading from SQA Suite 6.x, you must first convert to a 
Rational 7.x repository. See Creating a 7.x Repository Using Data from a 6.x Repository 
on page 19 for details.
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Before starting these procedures:

❑ Back up your current repository in case the conversion is unsuccessful. You will 
still be able to use your existing repository to access test assets. However, 
integrations with RequisitePro and ClearQuest will no longer be valid.

❑ Be aware that you must have administrator permission to convert the 
repository. 

Upgrading a Rational 7.x Repository to a Project

After you have upgraded your ClearQuest schema and database, you need to convert 
your repositories to Rational projects. Rational Administrator provides a wizard that 
creates one new Rational project in the directory you specify for each 7.x project in the 
source repository.

All repository global assets, such as users, groups, and computers, get copied into 
each new Rational project. In addition, the repository conversion process upgrades 
your RequisitePro projects.

Use the following procedure to upgrade test repositories from Rational Suite 1.0, 1.5, 
or 2000, or from any test products marked as 7.x, such as Rational Robot 7.0, 7.1, or 
7.5.

1 In the Administrator, select File > Convert Rational Repository into Rational 
Projects.

2 In the Repository Conversion - Login screen, enter the path of the repository you 
want to convert, as well as the user ID and the password. Click Next.

3 In the Destination screen, enter the path where the new Rational project will 
reside. Click Next. 

This directory becomes the root for all new projects. One new Rational project is 
created under this directory for each 7.x project in the source repository. All 
repository global assets, such as users, groups, and computers, get copied into 
each new Rational project.

4 In the Options screen, select one of the following options and click Next:

❑ Create a test case for each RequisitePro requirement that defines test criteria 
and is associated with a test script. 

❑ Create a test case for each test script associated with a test requirement that 
describes a feature of the application-under-test. This option is recommended if 
multiple test scripts are associated with the same requirement.
Upgrading a Rational 7.x Repository to a Project 15



For more information about test cases, see the Using Rational TestManager manual or 
the Rational TestManager Help. 

5 In the Summary screen, review your settings and click Finish.

6 Optionally, review the RepositoryConvert.txt log file that is written to your temp 
directory.

Rational Test Asset Conversion Information

All test assets that were stored in a 7.x repository project are now stored in a Test 
Datastore. Each Test Datastore is associated with a Rational project. Any 7.x test assets 
that were global to the repository are copied into each Test Datastore created for a 7.x 
repository project. Thus, test assets within a Test Datastore are not shared with any 
other Test Datastore.

Within a Test Datastore, the test assets are persisted as a collection of files. The 
properties and relationships of each test asset are stored within an XML file. These 
files are organized via the Test Datastore directory structure. Each Test Datastore also 
uses an MS Access database for caching some of the information in the XML files for 
use by reports and queries.

Note:  Users and Groups are stored in a separate datastore called a 
UserGroupTestDatastore. This datastore is created in a sub-directory of the Rational 
Administrator project.

Test cases are a new asset type. Test cases define the individual tests that are executed 
in order to validate test inputs such as RequisitePro requirements. In a 7.x repository 
project, scripts served this purpose as well as being the actual implementation of the 
test. In the new Rational Test, scripts are only used as implementations and do not 
play any role in test coverage. In order to facilitate this new model, the conversion 
program creates test cases based on the script/requirement relationships that exist in 
the 7.x repository project. 

The following table lists the data that is converted from a v. 7.x repository to a v. 
2001A.04 project:

Types of 7.x Rational Test Assets Converted?

Scripts Yes (including VPs and Low-Level Scripts

Schedules Yes (now called Suites)

Sessions Yes

Users Yes
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The following table lists the new test asset types:

Groups Yes

Computers Yes

Datapools Yes

Data Types Yes

Performance Reports Yes

Listing Reports No

Logs No

Builds Yes

Test Documents No

Coverage Reports No

Queries No

Log Filters No

New Test Asset Types Description

Computer List A collection of Computer assets that can be referenced 
as the execution target for Suites, Test Cases and 
Scripts.

Test Plan A collection of Test Cases which define “what” needs to 
be tested for a particular feature or set of features.

Test Case A specific “test” that needs to be planned, designed, 
and executed in order to validate some aspect of the 
System Under Test (SUT).

Configured Test Case A specific “test” that needs to be run under a specific 
configuration (i.e. Operating System, etc.).

Listing Report (based on Crystal 
Reports)

A type of report that displays information about the test 
assets that are stored in the Test Datastore.

Test Case Analysis Report A type of report that displays information about Test 
Cases and Test Case Results store in the Test Datastore.

Iteration A specific period of time during a project, which is 
typically associated with some exit criteria and 
milestones.
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Upgrading from Rational Test 6.x to 7.x

If you are using Rational Test 6.x (version 6.x of SQA Suite) and want to upgrade to 
the current version of the Rational testing products, you will need to perform an 
interim upgrade to version 7.x first, and then upgrade from 7.x to 2001.

You must do the following tasks in order:

1 Install the Rational Test 6.x to 7.x Repository Upgrade Kit.

2 Create a 7.x repository using the 6.x repository as the source of data. For 
information, see Creating a 7.x Repository Using Data from a 6.x Repository on 
page 19.

3 Upgrade your Rational Test 7.x repository to a Rational project. For information, 
see Upgrading a Rational 7.x Repository to a Project on page 15.

Installing the Rational Test 6.x to 7.x Repository Upgrade Kit

Installing the upgrade utility on the Rational Test 6.x to 7.x Repository Upgrade Kit 
CD provides the needed programs to upgrade your repositories. 

To install the upgrade kit:

1 Log in using an account with Administrator privileges.

2 Insert the Rational Test 6.x to 2001 Repository Upgrade Kit CD into your CD drive. 
The installation starts automatically.

Test Input Identifies some aspect of the SUT that needs to be 
verified by a Test Case. Types of Test Inputs include 
Requisite Pro requirements and Rose Model elements 
as well as others that are configured as part of the 
TestManager extensible Test Input mechanism.

Test Input Type Types of test inputs, such as RequisitePro requirements 
and Rose elements.

Test Script Type Types of scripts, such as GUI, VU, Java, and VB.

Configuration Attribute A specific aspect of a configuration such as OS, OS 
Version, memory, etc.

Configuration A collection of Configuration Attributes which together 
describe some environment under which some set of 
Test Cases need to execute and pass.
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If the installation does not start automatically, do the following:

a Click Start > Run.

b Type drive:\SETUP.EXE, and then click OK.

3 At the Rational Software Setup screen, click Next.

4 At the Select Installation Option screen, click Install Unlicensed Tools, and then 
click Next.

5 Read the terms of the license agreement, select Yes, I accept the agreement, and 
then click Next. If you do not accept the agreement, the Setup program ends.

6 At the Setup Configuration screen, select Typical, and then click Next.

7 At the Software Use screen, select Administrator, and then click Next.

8 At the Rational Confirmation screen, view the selections that you have made and, 
if they are correct, click Next.

9 Click Finish when done. 

Creating a 7.x Repository Using Data from a 6.x Repository

This section discusses how to create a 7.x repository and populate it with data from a 
6.x repository. Because the 7.x repository that you create is only temporary and needs 
to be converted to version 2001, it is recommended that you create MS Access 
databases. MS Access databases are the easiest to create.

To create a 7.x repository using data from a 6.x repository:

1 Create a shared directory in which to store the ClearQuest schema repository and 
the defect database.

2 Start the Rational Administrator.

3 Click File > Create Repository.
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4 Enter the UNC path for the new Rational repository, using the shared directory 
that you created in Step 1, and click Next.

Note:  If you plan to perform the 7.x to 2001A upgrade on a different computer, you 
must use UNC paths (\\server-name\directory-path).

5 Accept Microsoft Access as the default database type and click Next.

Select Access even if your ultimate goal is to use a different database type. For 
now, you are only creating a temporary database that will ultimately be converted 
to v. 2001, and for this purpose, MS Access is the easiest database to create. 
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6 In the Rational Test Database Initialization screen:

a Click Initialize the new repository with data from an existing SQA 6.x repository.

b Browse to or type the path to the 6.x repository and click Next.

7 In the ClearQuest Schema Repository Login screen:

a Make sure that Create or Attach ClearQuest Database is checked.

b Accept the default user ID and password and click Next.

❑ Default administrator account – The user ID is admin, with no password.

❑ Default user account – The user ID is user, with the password password.
Installing the Rational Test 6.x to 7.x Repository Upgrade Kit 21



8 In the No ClearQuest Schema or Repository screen, click Create or attach a 
ClearQuest Schema Repository and click OK.

If this dialog does not appear, click Start > Programs > Rational Administrator > 
Rational ClearQuest Maintenance Tool.

9 In the ClearQuest Maintenance Tool, click Create a New schema repository and 
click Next.

10 In the Connect to Existing Schema Repository screen:

a Select MS_Access as the Vendor.

b Browse to the shared folder that you created in Step 1 and type a name for the 
schema repository’s database file, for example schema.mdb. 

c Click Open.

d Click Next.
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11 In the Create Sample Database screen, clear the Create sample database checkbox 
and click Next.

12 Clear the Save Current Setting as Default checkbox and click Finish.

13 Click Done when the message Done creating repository is displayed.

14 In the Create Repository Wizard screen, click Next.
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15 In the New or Existing ClearQuest Database screen, enter a database name and 
description and click Next, for example:

Database name: upgd

Description: Converted 6x data

16 In the ClearQuest Database Information screen, you create the user (defect) 
database. Accept the defaults and click Next.
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17 In the ClearQuest Database timeout screen, accept the defaults and click Next.

18 Click Finish to create the ClearQuest database and convert the 6.x data.

19 Click OK.

See Upgrading a Rational 7.x Repository to a Project on page 15 for information on 
converting your new repository to v. 2001A. After you complete the 7.x to 2001A 
conversion, see the topic, Moving or converting user databases, in the Rational 
ClearQuest Designer Help, for instructions about changing the database type from 
MS Access to the database type used at your site.
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Conversion Details

When you create a Rational repository with SQA Suite 6.x data, the converter does the 
following:

■ Adds the prefix _RENAMED_ to a script name or verification point ID that has a 
period (.) in the name.

■ Converts the period (.) in a script name or verification point ID to an underscore 
(_).

For example, a script named wn95.tst converts to _RENAMED_wn95_tst. A 
verification point ID named alpha.b2 converts to _RENAMED_alpha_b2.

The following table lists the data that is converted from a SQA Suite 6.x repository to a 
Rational repository.

Table 4 Data Converted from a SQA 6.x Repository

Type of SQA Suite 6.x data Converted?

Custom reports and graphs No

Defects Yes 

E-mail rules No

Filters for defects or test procedures No

Groups
(Privileges are not converted.)

Yes

List reports No

LoadTest schedules (called suites in a Rational project) No

Projects Yes

Requirements Yes

Test cases (called verification points in a Rational project) Yes

Test logs No

Test plans Yes

Test procedures (called test scripts in Rational project) Yes

Users (Privileges are not converted.) Yes

Virtual user test procedures (called test scripts in a Rational project) No
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Fields in SQA 6.x and TestStudio Defect Forms

Rational ClearQuest 2.0 includes a specially designed defect form, the TestStudio 
defect form, similar to the SQA 6.x Manager defect form. The following table lists each 
field in an SQA 6.x defect form and the comparable field in the TestStudio defect 
form.

Note:  The word List in the Description column indicates that if you customize a list in 
SQA 6.x, it converts to a list in the TestStudio defect form.

Table 5 Comparison of Defect Fields

SQA 6.x defect 
field

TestStudio 
defect field Description

ID New ID 
generated

The SQA 6.x ID does not appear on the defect form, but 
you can use the query feature of ClearQuest to find it. 

Description Headline/
Description

Converts the first 125 characters or up to the first 
carriage return and places this text in the Headline field. 
The entire SQA 6.x Description field also appears in the 
Description field of the TestStudio defect form.

Priority Priority List

Severity Severity List

Occurrences (Not converted)

Keywords Keywords List

Symptoms Symptoms List

Build Found Notes In SQA 6.x, a Build Found field is a text field. 
In Rational Suite, Builds are objects that contain log 
folders and logs. The text data from the Build Found 
field is stored in Notes. A Build object is not created for 
each SQA 6.x Build Found field. 

Build Fixed Notes In SQA 6.x, a Build Fixed field is a text field. 
In Rational Suite, Builds are objects that contain log 
folders and logs. The text data in the Build Fixed field is 
stored in Notes. A Build object is not created for each 
SQA 6.x Build Fixed field. 

Proc Script

Case Verification 
Point

Cycle (Not converted)
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Reported By Reported By 
Contact

Reported By 
Company

Reported By 
Company

Hardware Hardware List

Operating 
System

Operating 
System

List

Other Other 
Environment

Test Station (Not converted) In SQA 6.x, a Test Station field is a text field. 
In Rational Suite, the Computers field replaces the Test 
Station field and is an object. A Computer object is not 
created for each SQA 6.x Test Station field. 

Log (Not converted)

Custom 1 Custom 1 List

If you customized the label for this field in SQA 6.x, the 
label is not converted. Use the ClearQuest Designer to 
customize this label.

Custom 2 Custom 2 List

If you customized the label for this field in SQA 6.x, the 
label is not converted. Use the ClearQuest Designer to 
customize this label.

Custom 3 Custom 3 If you customized the label for this field in SQA 6.x, the 
label is not converted. Use the ClearQuest Designer to 
customize this label.

Attachment Attachments You can attach more than one file after you convert to a 
Rational Suite repository.

Requirement Requirement

Status History History

Resolution Resolution List

Resolution 
Description

Resolution Note

Table 5 Comparison of Defect Fields

SQA 6.x defect 
field

TestStudio 
defect field Description
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Troubleshooting

The convert.txt file in the converted project directory contains the conversion 
status of each verification point and script. Use this file as a diagnostic tool if you have 
any problems with your data after conversion. 

Modified 
Software

(Not converted)

Table 5 Comparison of Defect Fields

SQA 6.x defect 
field

TestStudio 
defect field Description
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4Installing Additional 
Software
This chapter is organized as follows:

■ Installing and Removing the Network Driver on page 31

■ Supported Playback Environments on Agent Computers on page 34

■ Installing Rational Test Agents on page 35

■ Installing Rational Robot for Distributed Testing on page 40

■ Installing the Rational Test Enablers on page 40

■ Installing the Sample Applets on page 42

■ Installing Crystal Reports on page 42

■ Installing Rational ManualTest Web Execution on page 43

Installing and Removing the Network Driver

To record sessions over a network for performance testing, you must install the 
Rational Test network driver. If you have a network driver from a previous release, 
you must remove it and install the current network driver. The following sections 
explain how to do this on Windows NT and Windows 2000.

Installing the Network Driver on Windows NT

To install the Rational Test network driver on Windows NT:

1 Install your Rational testing software.

2 Click Start > Settings > Control Panel.

3 Double-click the Network icon.

4 Click the Protocols tab.

5 Click Add.

6 Click Have Disk. The required files were copied to the Rational directory during 
Rational Test installation.
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7 Specify one of the following file paths to install the driver.

❑ For Windows NT Ethernet networks, type:

C:\Program Files\Rational\Rational Test\driver

or installpath\Rational\Rational Test\driver

where installpath is the drive and path is where you installed the Rational 
testing software.

❑ For Windows NT Token Ring networks, type:

C:\Program Files\Rational\Rational Test\drivertk

or installpath\Rational\Rational Test\drivertk

where installpath is the drive and path is where you installed the Rational 
testing software.

Note:  You can install only one type of driver on your computer at a time, either 
Ethernet or Token Ring. You must remove one type of driver before installing a 
new type of driver. 

8 Click OK.

9 In the Select OEM Option dialog box, click OK again to verify the driver.

10 Click Close.

11 Click Yes to shut down Windows and restart your computer after you install the 
network driver.

Removing the Network Driver from Windows NT

If you need to switch from an Ethernet network to a Token Ring network, or the 
reverse, you must remove the driver for the unwanted network type before you install 
the driver for the new network type.

To remove a network driver from Windows NT:

1 Click Start > Settings > Control Panel, then double-click the Network icon.

2 Click the Services tab.

3 Select the Rational network driver from the Network Services list.

❑ If your current driver is from Rational Suite PerformanceStudio 1.0 or earlier, 
select PerformanceStudio Network Driver.

❑ If your current driver is from Rational Suite PerformanceStudio 1.5 or 2000, 
select RSPS Network Driver.

4 Click Remove.
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5 Click Yes to confirm that you want to remove the driver.

6 When the removal is complete, click Close.

7 Click Yes to reboot the computer.

When the computer restarts, you can install the new network driver. 

Installing the Network Driver on Windows 2000

To install the Rational Test network driver on Windows 2000:

1 Click Start > Settings > Network and Dialup Connections.

2 Right-click Local Area Connection, and then select Properties from the context 
menu.

3 Click Install.

4 Click Protocol, and then click Add.

5 Click Have Disk.

6 Enter the path where the driver is located, or browse for the driver. For example, 
type:

C:\Program Files\Rational\Rational Test\driverw2k

or installpath\Rational\Rational Test\driverw2k

where installpath is the drive and path where you installed the Rational testing 
software.

7 Select either Ethernet or Token Ring network, and then click OK.

8 Click Yes to shut down Windows and restart your computer after you install the 
network driver.

Removing the Network Driver from Windows 2000

To remove the network driver from a Windows 2000 computer:

1 Click Start > Settings > Network and Dialup Connections.

2 Right-click Local Area Connection, and select Properties from the shortcut menu.

3 Select PerformanceStudio Network Driver 2000 from the Network Services list.

4 Click Uninstall.
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5 Click Yes to confirm that you want to remove the driver.

6 When the removal is complete, click Close.

7 Click Yes to reboot the computer.

Supported Playback Environments on Agent Computers

The following table lists the protocols that are supported when you play back a 
performance test script on an Agent computer. For example, if your Agent computer 
runs Solaris, you cannot play back a test script that accesses ODBC. All playback 
platforms support sockets.

Note:  SQL Server 7.x playback is available on ODBC platforms only.

Also note that use of Agent software on AIX 4.3 requires AIX patch “part number 
ix89833” from IBM. Contact IBM to order the patch.

 

Table 6 Playback Environments for Performance Testing 

HTTP & 
HTTP/
SSL

Oracle Sybase
Tuxedo 
& Jolt

SQL 
Server

ODBC
SAP
VU

DCOM 
CORBA 
(Visibroker 
3.x only)

Win NT Yes Yes Yes Yes Yes Yes Yes Yes Yes

Win ME No No No No No No No No No

Win 2000 Yes Yes Yes Yes Yes Yes Yes Yes Yes

Win 98, 
2nd ed.

No No No No No No No No No

Win 95, 
SR2

No No No No No No No No No

Solaris 2.5, 
2.6, 2.7

Yes Yes Yes Yes Yes, 
except 
extended 
stored 
procedur
es

No No No Yes

HP-UX 11 Yes Yes Yes Yes Yes, 
except 
extended 
stored 
procedur
es

No No No No
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The following list shows the operating systems that are supported when you play 
back a GUI test script on an Agent computer.

■ Windows NT

■ Windows ME

■ Windows 2000

■ Windows 98, 2nd ed.

■ Windows 95, SR2

Installing Rational Test Agents

After you install and license your Rational testing software on a Local computer, you 
have the option of installing Rational Test Agents on other computers. You use an 
Agent computer to:

■ Play back tests using multiple virtual testers. This allows you to add workload to a 
server.

■ Play back functional tests. You can distribute your functional tests among different 
computers to save time. 

■ Monitor and report on resources used during performance tests.

Note:  The same version of Rational testing software must be installed on the Local 
and Agent computers; otherwise, they will not work together.

AIX 4.3 Yes Yes Yes Yes Yes, 
except 
extended 
stored 
procedur
es

No No No No

DYNIX/ptx No Yes No Yes No No No No No

Red Hat 
Linux

Limited Yes No Yes No No No No No

Table 6 Playback Environments for Performance Testing (continued) 

HTTP & 
HTTP/
SSL

Oracle Sybase
Tuxedo 
& Jolt

SQL 
Server

ODBC
SAP
VU

DCOM 
CORBA 
(Visibroker 
3.x only)
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Installing a Windows Agent

To install Agent software on a Windows computer:

1 Log in using an account with Administrator privileges.

2 Insert the Rational testing software CD into your CD drive. The installation starts 
automatically.

If the installation does not start automatically, do the following:

a Click Start > Run.

b Type drive:\SETUP.EXE,\SETUP.EXE and click OK, where drive is the CD 
drive you are using.

3 In the Rational Software Setup screen, click Next.

4 Click Install Unlicensed Tools, and then click Next.

5 Select Rational Test Agent from the list of available products, and then click Next.

6 Read the terms of the license agreement, select one of the following, and then click 
Next.

❑ Yes, I accept the agreement. If you accept the agreement, the Setup program 
continues.

❑ No, I don’t accept the agreement. If you do not accept the agreement, the Setup 
program ends.

7 Select the setup configuration you prefer, and then click Next.

Note:  You cannot select the Minimal configuration for Rational testing products.

❑ Typical – Installs the most commonly used features for this product. 

❑ Custom/Full – Lets you specify which products or features to install.

❑ Compact/Laptop – Installs the minimal software needed to run this product.

8 Follow the on-screen instructions to complete the installation.

The Rational Setup Wizard displays a series of dialog boxes that guide you 
through the installation process and prompt you for information.

9 In the last dialog box, click Finish.

You must restart your computer to finish the installation.

10 Log in again using the same user account and Administrator privileges that you 
used to start the installation. This allows the setup program to complete.
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Starting a Windows Agent

A Windows Agent runs as an application. To start the Agent, click the executable or 
put it in a start group. 

On Windows NT, you can run the Agent as an NT service if the Agent will be used 
only for virtual testers. 

To run an Agent as an NT service:

1 Right-click the Start menu. Click Open All Users.

2 Double-click Programs.

3 Double-click Startup.

4 If the Agent is running, you must exit it. 

5 Right-click the Rational Test Agent icon and select Delete.

6 If you are running the Local computer as an Agent:

a Click Start > Run.

b Type rtpsvc -install, and then click OK.

7 Start the Agent as an NT service:

a Click Start > Settings > Control Panel.

b Double-click Services.

c Select Rational Test Agent Service from the list of services, and then click Start.

8 To start the Agent automatically when you restart your computer:

a Click Startup.

b Click Automatic in the Startup Type box, and then click OK.

Installing a UNIX Agent

To install Agent software on a UNIX computer:

1 Log in as root.

2 Create the installation directory:

# mkdir -p /usr/rational/test

3 Insert the Rational Solutions for Windows Disc 1 CD into your CD drive.
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4 If the CD does not automount, then issue the appropriate UNIX mount command. 
Change your directory to the CD directory. The mount and the change directory 
commands for each Agent are as follows:

For an Agent on a Solaris operating system:

# mount /dev/dsk/c0t6d0s0 /cdrom

# cd /cdrom/solaris_agent

For an Agent on an HP-UX 11.x operating system:

# pfs_mount /dev/rdsk/c0t2d0 -t rrip /cdrom

# cd /cdrom/hp11_agent

For an Agent on an AIX 4.3 operating system:

# mount -v cdrfs -r /dev/cd0 /cdrom

# cd /cdrom/aix4.3_agent

For an Agent on a Red Hat 6.x release of Linux:

# mount /dev/cdrom /mnt/cdrom

# cd /mnt/cdrom/linux_agent

For an Agent on a DYNIX/ptx operating system:

# mount -r -f cdfs /dev/dsk/cd1 /cdrom

# cd /cdrom/dynix_agent

5 Copy the installation files to your hard drive. 

# find . -print|cpio -pdvm /usr/rational/test

6 Change your directory to the directory that contains the installation script.

# cd /usr/rational/test/bin

7 Run the installation script.

# sh agent_install

8 Start the UNIX Agent.

a Start the Bourne shell, if you are not running it already.

# sh

b Change your directory to the installation directory.

# cd /usr/rational/test/bin
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c Set the RATL_RTHOME and PATH environment variables:

# RATL_RTHOME=/usr/rational/test

# export RATL_RTHOME

# PATH=$PATH:/usr/rational/test

# export PATH

d Start the Agent daemon.

# ./RTsagt

Restarting a UNIX Agent

To restart the UNIX Agent manually:

1 Start the Bourne shell, if you are not running it already.

# sh

2 Change your directory to the installation directory.

# cd /usr/rational/test/bin

3 Set the RATL_RTHOME and PATH environment variables:

# RATL_RTHOME=/usr/rational/test

# export RATL_RTHOME

# PATH=$PATH:/usr/rational/test

# export PATH

4 Start the Agent daemon.

# ./RTsagt

Removing a UNIX Agent

To remove the UNIX Agent:

1 Find the rtprvd process and kill it using ps -ef|grep rtprvd.

2 kill -9 pid

3 rm -rf /usr/rational/test
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Installing Rational Robot for Distributed Testing

To record GUI test scripts on multiple computers, you need to install Robot on each 
computer. A separate node-locked license is required for Robot-only installations. For 
information about installing node-locked licenses, see the Administering Rational 
Software Licenses manual or the Rational License Key Administrator Help.

To install Rational Robot, follow the Rational Setup. For information, see Installing 
Rational Robot, Team Test, and TestManager on page 10.

Installing the Rational Test Enablers

The Rational Test Enablers consist of the following:

■ Rational ActiveX Test Control – Install to test the properties of the ActiveX 
controls in your application-under-test using Rational Robot. 

Note:  If you are using a development environment other than PowerBuilder, 
Oracle Forms, Visual Basic, Delphi, Java, or HTML, and you want to test the 
properties of your ActiveX controls, you must manually add the Rational ActiveX 
Test Control to each OLE container in your application. For instructions, see the 
documentation that comes with your development environment.

The ActiveX Test Control provides communication between any OLE container 
and Robot. It is a non-intrusive control and has no impact on the behavior or 
performance of your application. At runtime, the Rational ActiveX Test Control is 
not visible. 

■ Rational Test Java Enabler – Required to test Java applets running in a browser, or 
to test stand-alone Java applications. This Enabler scans your hard drive for Web 
browsers and Sun JDK installations that Robot supports, and enables only those 
environments currently installed on your system. Run the enabler each time you 
install a new Java environment (such as a new release of a browser or JDK).

■ Rational Test Oracle Forms Enabler – Install to test Oracle Forms 6.0, 5.0, and 4.5 
applications. Installs both the Rational Test Oracle Forms Enabler and the 
Rational Test Object Testing Library for Oracle Forms. 

Note:  Be sure to install Oracle Forms 6.0, 5.0, or 4.5 and the Oracle Open Client 
Adapter for ODBC before you install the Rational Test Oracle Forms Enabler.

■ Rational Test Delphi Enabler – Install to test your Delphi applications. Before you 
can test your Delphi applications, you must install the Rational Object Testing 
Library for Delphi and the Rational Test Delphi Enabler.
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■ Rational Test Visual Basic Enabler – Install to test Visual Basic 4.0 applications. 
Ensures that all forms in your project, including MDI forms, contain the Rational 
ActiveX Test Control. This Enabler is an add-in (extension) to Visual Basic 4.0. For 
more information about Visual Basic add-ins, see your Visual Basic 
documentation. 

Note:  You do not need the Visual Basic Enabler to test Visual Basic 5.0 and later 
applications.

For more information about the Rational Test Enablers, see the Using Rational Robot 
manual.

To install the Rational Test Enablers: 

1 Turn on the computer to start Windows.

2 Insert the Rational Solutions for Windows Disc 1 CD into your CD drive. The 
installation starts automatically.

If the installation does not start automatically, do the following:

a Click Start > Run.

b Type drive:\SETUP.EXE, and then click OK.

3 At the Rational Software Setup screen, click Next.

4 Click Install Unlicensed Tools, and then click Next.

5 Select Rational Test Enablers, then click Finish.

The Rational Test Enablers installation starts.

6 Select one or more of the following, and then click Next.

❑ Rational ActiveX Test Control

❑ Rational Test Oracle Forms Enabler

❑ Rational Test Java Enabler 

❑ Rational Test Visual Basic Enabler

❑ Rational Test Delphi Enabler

7 Follow the on-screen instructions to complete the installation.
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Installing the Sample Applets

The Rational sample applets are included:

■ Small Sample applets – Use with the Try it! cards for quick and easy instructions 
about recording tests on controls created in specific development environments. 
You can install sample applets for Java, HTML, Oracle Forms, PowerBuilder, and 
Visual basic development environments.

To install the sample applets:

1 Install Rational Robot, TeamTest, TestStudio, or EnterpriseStudio. For information 
about installing Robot and TeamTest, see Installing Rational Robot, Team Test, and 
TestManager on page 10.

Note:  You cannot install the Rational sample applets if your only installed Rational 
testing product is Rational TestManager.

2 Click Start > Programs > Rational product name > Rational Test > Set Up Rational Test 
Samples.

3 Select the sample applets that you want to install:

❑ HTML Sample

❑ Java Sample

❑ Visual Basic Sample

❑ PowerBuilder Sample

❑ Oracle Sample

4 Click Next.

5 Click Finish to complete the installation.

Installing Crystal Reports

Crystal Reports lets you customize defect reports that come with Rational TeamTest. 
Crystal Reports also lets you create new report formats. This software comes on a 
separate CD in your Rational testing software kit.

To install Crystal Reports 8.0 Professional Edition use the Crystal Reports installation 
directions that come with the CD.
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Installing Rational ManualTest Web Execution

A manual test script is a set of testing instructions that are run by a human tester. A 
manual test script can consist of steps and verification points that you type into a 
manual test script using Rational ManualTest. After you create a manual test script 
and associate it with a test case, creating a test case implementation, you can run the 
test case from a Web browser. For information about creating a manual test script and 
about test case implementations, see the Using Rational TestManager manual.

With the ManualTest Web Execution component of Rational TestManager, you can:

■ Run a test case with a manual test script implementation from a Web browser. The 
advantage to using the ManualTest Execution feature of TestManager is that you 
only need Web browser software to run a test case with a manual test script 
implementation. 

■ Indicate results and add comments as you perform each task in a manual test 
script. These results appear in a test log.

■ Include your test case results in a TestManager report.

When you run a test case, you view and record the results of performing the manual 
steps and verification points in the manual test script. 

Note:  You can only run a test case from a Web browser if it has a manual test script 
implementation; you can not run a test case with an automated test script 
implementation from a Web browser. If a test case has both a manual test script and an 
automated test script implementation, only the manual test script runs from a Web 
browser.

To run a test case associated with a manual test script, you or an administrator install 
and configure a Web server with ManualTest Web Execution software and configure a 
Web browser on each client to access a Rational project. To run a test case with a 
manual test script implementation, using a Web browser, you type the machinename, 
the network name of the Web server, and the alias, the name of an alias for the 
directory where you or your administrator installed the ManualTest Web Execution 
software on the Web server. 

For example:
http://Webserver1/ManTestdir

For information about setting up a Web browser and installing a Web server, see 
Installing a Web Server on page 45 and Setting Up a Web Browser on page 51.
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Software Requirements

Make sure that your server conforms to the following minimum requirements for a 
Web server:

For the Web server:

■ Windows ME, Windows 2000 Professional, Windows 2000 Server, Windows 2000 
Advanced Server, Windows 98, Windows 95, Windows NT 4.0 Workstation, or 
Windows NT 4.0 Server.

■ Microsoft Internet Explorer 5.0 or later on the Web server.
 

Note:  We recommend that you use Windows 2000 Server, Windows 2000 Advanced 
Server, or Windows NT 4.0 Server, as the Web server platform. You can not use a 
shared or networked project with the Windows 2000 Professional or Windows NT 4.0 
Workstation.

To access the Web server as a client, use one of the following Web browsers:

■ Netscape Navigator 4.0 or later

■ Microsoft Internet Explorer 4.0 or later

About Shared Projects

We recommend that when you create a project, you make it a shared project so others 
can access your manual test scripts from a Web browser. To share a project, create the 
project in a shared directory and use the Uniform Naming Convention (UNC) for the 
directory name. (For more information about creating a shared directory, see the Using 
the Rational Administrator manual or the Rational Administrator Help.) 

For Install

All versions of Windows 2000 
and Windows ME

Microsoft Internet Information Services 5.0 (IIS 5.0) 
from the Windows 2000 CD

Windows 98, Windows 95, or 
the Windows NT 4.0 
Workstation

Microsoft Personal Web Server (PWS) from the 
Windows NT 4.0 Option Pack (available from 
Microsoft, www.microsoft.com)

Windows NT 4.0 Server Microsoft Internet Information Server (IIS) from the 
Windows NT 4.0 Option Pack (available from 
Microsoft, www.microsoft.com)
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Installing a Web Server

To install a Web server to run a test case with a manual test script implementation 
from a Web browser:

1 Install the ManualTest Web Execution component. 

a Turn on the computer to start Windows.

b Log in using an account with Administrator privileges.

c Quit all applications before installing any Rational products.

d Insert the Rational Solutions CD 1 into your CD drive.

The installation starts automatically.

If the CD does not start automatically, click Start > Run. Type drive:\SETUP.EXE, 
and then click OK.

e On the Rational Software Setup page, click Next.

f Click one of the following Rational testing products from the list of available 
products, and then click Next:

➑ Rational Robot

➑ Any Rational Suite product

➑ Rational TeamTest

➑ Rational TestManager

g Read the terms of the license agreement carefully, select one of the following, 
and then click Next.

➑ Yes, I accept the agreement. If you accept the agreement, the Setup program 
continues.

➑ No, I don’t accept the agreement. If you do not accept the agreement, the 
Setup program ends. 

h Do one of the following on the Select Configuration page:

i If you do not want to create manual test scripts on the Web server and only 
want to set up a Web server:

Click Custom, and then click Next.

Clear all check boxes on the Choose Features page.

Click the -- on the Web Server Components check box. 

Select the Rational ManualTest Web Execution check box.
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ii If you want to create manual test scripts on the Web server, click Typical to 
install a Rational testing product.

Note:  You do not need to install a Rational testing product on the Web 
server unless you want to create manual test scripts on the Web server. The 
Manual Test Web Execution component installs by default when you install 
any of the Rational testing products.

i Follow the on-screen instructions to complete the installation. 

The Rational Setup wizard displays a series of dialog boxes that guide you 
through the installation process and prompt you for information.

j Click Finish when done.

Your system restarts. 

2 Install Microsoft Windows NT 4.0 Option Pack or Microsoft Internet Information 
Services 5.0 on the Web server by doing one of the following:

❑ For a Web server running Windows 2000, install the Microsoft Internet 
Information Services 5.0 from the Windows 2000 CD. 

❑ For a Web server running Windows NT 4.0 Server, install the Microsoft Internet 
Information Server (IIS) from the Windows NT 4.0 Option Pack.

❑ For a Web server running Windows 98, Windows 95, or Windows NT 4.0 
Workstation, install the Microsoft Personal Web Server (PWS) from the 
Windows NT 4.0 Option Pack. 

3 Install Microsoft Internet Explorer 5.0 or later on the Web server. 

Note:  Although a client can use Microsoft Internet Explorer 4.0, you must install 
Microsoft Internet Explorer 5.0 or later on the Web server.

4 Configure the Microsoft Access Driver to run a test case from a Web browser by 
doing the following:

a Click Start > Settings > Control Panel.

b Do one of the following:

For Windows 2000, double-click Administrative Tools, and then double-click 
Data Sources (ODBC).

For Windows 98, 95, NT 4.0 Workstation and Server, double-click ODBC Data 
Sources.

c Click the Connection Pooling tab.

d Under ODBC Drivers, double-click Microsoft Access Driver (*.mdb).
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e Select Don't pool connections to this driver, and then click OK.

f Click OK.

g Restart the system.

5 Configure the Web server to run a test case from a Web browser by doing one of 
the following: 

❑ For a Web server running Windows 2000 Professional, Windows 98, Windows 
95, or a Windows NT 4.0 Workstation, see Configuring a Microsoft Personal Web 
Server on page 49.

❑ For a Web server running Windows NT 4.0 Server, Windows 2000 Server, or 
Windows 2000 Advanced Server, see the next section, Configuring a Microsoft 
Internet Information Server. 

Configuring a Microsoft Internet Information Server

To configure the Microsoft Internet Information Server (IIS) on all versions of 
Windows 2000, Windows ME, or a Windows NT 4.0 Server:

1 Do one of the following:

❑ For all Windows 2000 and Windows ME systems, click Start > Settings > Control 
Panel. 
Double-click Administrative Tools. Double-click Internet Services Manager.

❑ For Windows NT 4.0, click Start > Programs > Windows NT 4.0 Option Pack > 
Microsoft Internet Information Server > Internet Service Manager.

2 Optionally, double-click Internet Information Server to display all machines.

3 Double-click machinename

where machinename is the network name of the Web server.

4 Click Default Web Site.

5 Right-click, and then click New > Virtual Directory.

6 Do one of the following:

❑ For Windows 2000 and Windows ME, click Next, and then go to the next step.

❑ For Windows NT 4.0, go to the next step.
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7 Type an alias for the directory where you installed your Rational software on the 
Web server.

For example: TM

Note:  Write down this alias. You must use this alias to run a test case from a Web 
browser.

8 Click Next.

9 Type the drive and path of the location where you installed your Rational 
software, or click Browse to select the drive and path.

For example, the default location is:

c:\Program Files\Rational\Rational Test\www\manual script

10 Click Next.

11 Do one of the following:

For Windows 2000 and Windows ME, select the following options to allow 
privileges to the Rational project:
❑ Read
❑ Run scripts (such as ASP)

For Windows NT 4.0 Server, select the following options to allow privileges to the 
Rational project:
❑ Allow Read Access
❑ Allow Script Access
❑ Allow Execute Access

12 Do one of the following:

❑ For Windows 2000 and Windows ME, click Next, and then click Finish.

❑ For Windows NT, click Finish.

13 Right-click the new alias, and then click Properties.

14 Click the Documents tab.

Make sure that the following files appear under the Enable Default Document box:
❑ Default.asp

If these file do not appear, do the following:

a Click Add.

b Type Default.asp, and then click OK.
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15 Click the Directory Security tab.

16 Under Anonymous and Authentication Control, click Edit.

17 Make sure that you select the Allow Anonymous Access check box, and then click 
Edit. 

18 Do one of the following:

❑ For Windows 2000 and Windows ME, clear the Allow IIS to control password 
check box, and then go to the next step.

❑ For Windows NT 4.0, Clear the Enable Automatic Password Synchronization 
check box, and then go to the next step.

19 Type the Username and Password for the user account either on this Web server (if 
the project is on the Web server), or on the domain (to access shared projects on 
other systems in the domain). 

All web clients use this user account to access a Rational project either on a Web 
server or on the domain (to access shared projects on other systems in the domain). 
This user account must have privileges to read and write into a Rational project. If 
you want Web clients to have access to a Rational project, you must log into this 
account when you create a new Rational project or register an existing Rational 
project using the Rational Administrator.

Note:  By configuring the privileges to this account, you can restrict access to 
certain shared projects. For more information about setting privileges, see your 
Microsoft Windows 2000 or Windows NT 4.0 documentation.

20 Click OK to close all windows.

Configuring a Microsoft Personal Web Server
Note:  If you use Windows NT 4.0 Workstation or Windows 2000 Professional with the 
Personal Web Server, you can access only local projects. To access shared projects with 
Windows 2000 Professional, Windows 98, or Windows 95, you must run PWS under a 
domain user account.

To configure the Microsoft Personal Web Server (PWS) on a Windows 2000 
Professional, Windows 98, Windows 95, or Windows NT 4.0 Workstation server:

1 Do one of the following:

❑ For Windows 2000 Professional, be sure to install the Internet Information 
Services 5.0 (IIS 5.0) from the Windows 2000 Professional CD.
Installing Rational ManualTest Web Execution 49



❑ For Windows 98, Windows 95, or Windows NT 4.0 Workstation, be sure to 
install the Microsoft Personal Web Server (PWS) from the Windows NT 4.0 
Option Pack (available from Microsoft, www.microsoft.com).

2 Do one of the following:

❑ For Windows 2000 Professional, click Start > Settings > Control Panel. 
Double-click Administrative Tools. Double-click Personal Web Manager.

❑ For Windows 98, Windows 95, or Windows NT 4.0 Workstation, click Start > 
Programs > Windows NT 4.0 Option Pack > Microsoft Personal Web Server > 
Personal Web Manager.

3 Click Advanced.

4 Select <Home>.

5 Click Add.

6 Under Directory, type the drive and path of the location where you installed your 
Rational software, or click Browse to select the drive and path.

For example, the default location is:

c:\Program Files\Rational\Rational Test\www\manual script

7 Under Alias, type the alias for the directory where you installed your Rational 
software on the Web server

For example: TM

Note:  Write down this alias. You must use this alias to run manual test scripts on this 
Web server through a Web browser.

8 Do one of the following:

❑ For Windows 2000 Professional – Under Access permissions, select
Read and Script Source Access. Under Application permissions, select Execute 
(including scripts).

❑ For Windows 98, Windows 95, or Windows NT 4.0 Workstation – 
Under Access, click all of the following: Read, Execute, and Scripts.

9 Click OK.

10 Do one of the following:

❑ For Windows 98, Windows 95, or Windows NT 4.0 Workstation, 
click Properties > Exit.

❑ For Windows 2000 Professional, click File > Close.
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11 Complete the steps for either Windows 2000 Professional or for Windows 98, 
Windows 95, or Windows NT 4.0 Workstation

For Windows 2000 Professional:

a Click Start > Settings> Control Panel.

b Double-click Users and Passwords.

c Under the User Name column, select:

IUSR__machinename

where machinename is the name of the Web server.

d Click Properties.

e Click the Group Membership tab.

f Under Other, select Administrators.

g Click OK. Click OK again.

h Restart the system.

If you have Windows 98, or Windows 95 you are finished with the configuration. If 
you have a Windows NT 4.0 Workstation, do the following:

a Click Start > Programs > Administrative Tools (Common) > 
User Manager.

b Under the User Name column, select:

IUSR__machinename

where machinename is the name of the Web server.

c Click User > Properties. 

d Click Groups.

e Under Not members of, select Administrators, and then click Add. 

f Click OK. Click OK again.

g Click User > Exit.

Setting Up a Web Browser

You can use Netscape Navigator 4.0 (or later) or Microsoft Internet Explorer 4.0 (or 
later) as your Web browser to run a test case. You can use your Web browser on a 
system running any operating system software.
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Netscape Navigator

To set up a Netscape Navigator browser to run a test case:

1 Start Netscape Navigator.

2 Click Edit > Preferences. Under Category, click Advanced.

3 Double-click Advanced, and then click Cache to display the Cache panel.

4 In the Cache panel, click Every time.

5 Click OK.

Microsoft Internet Explorer 

To set up a Microsoft Internet Explorer browser to run a test case:

1 Start Internet Explorer.

2 Do one of the following:

❑ For Internet Explorer 5.0 or later, click Tools > Internet Options. 

❑ For Internet Explorer 4.0, click View > Internet Options.

3 Click the General tab.

4 Under Temporary Internet files, click Settings.

5 Under Check for newer versions of stored pages, click Every visit 
to the page.

6 Click OK. Click OK again.

Troubleshooting 

This section lists some problems you may experience when running a test case from a 
Web browser, a description of each problem, and how to correct each problem.

Note:  The error message in this troubleshooting section are ManualTest Web 
Execution error messages, not Web browser error messages.

Problem – Your Rational projects do not appear when you log into a Rational project. 
(You type http://machinename/alias and log into a Rational project.)
Error message – None.
Solution – All web clients use the same user account to access a Rational project either 
on a Web server (if the project is on the Web server), or on the domain (to access 
shared projects on other systems in the domain). 
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There are two things to check:

■ Check to make sure that this user account has privileges to read and write into a 
Rational project. (Ask your administrator to check the privileges of the user 
account that they set up on the Web server.)

■ To allow Web clients access, you must also log into this account when you create a 
new Rational project or register an existing Rational project using the Rational 
Administrator.

Problem – You cannot connect from a Web browser to a Web server running the 
Microsoft Personal Web Server (PWS). 
Error message – None.
Solution – If you restart a Web server running PWS, PWS may not start automatically 
when the server restarts. This is an intermittent problem. To fix the problem, restart 
PWS.

To restart PWS:

1 Click Start > Programs > Windows NT 4.0 Option Pack > Microsoft Personal Web 
Server > Personal Web Manager.

2 Under Publishing, click Start.

3 Click Properties > Exit.

Problem – When you log into a project from a Web browser, you get this error 
message.
Error message – Unable to connect to project.
Solution – Make sure the Web server privileges are set correctly. For information about 
setting privileges, see Configuring a Microsoft Internet Information Server on page 47 or 
Configuring a Microsoft Personal Web Server on page 49.

Problem – You get an error message when you select a manual test script.
Error message – Error message that includes Server.ObjectCreate in the 
message.
Solution – Make sure that you or the Web server administrator installs Microsoft 
Internet Explorer 5.0 or later on the Web server.

Problem – When you type text in a dialog box and submit it, you get erratic behavior. 
Alternatively, when you open a manual test script, results and comments are already 
filled in from the last session. 
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Error message – None.
Solution – Disable caching on your Web browser. For information about disabling 
caching, see Setting Up a Web Browser on page 51.

Problem – After you connect to the Web server, a Login dialog box appears. In the 
Login dialog box, the project select list is empty.
Error message – None.
Solution – Create a project and create manual test scripts, or register an existing project 
that contains manual test scripts. 

To create a project or register an existing project:

1 Do one of the following:

❑ For IIS, log into the user account of the virtual directory that you configured to 
run a test case. For information, see Configuring a Microsoft Internet Information 
Server on page 47.

❑ For PWS, log into the user account that the Web server runs under. For 
information, see Configuring a Microsoft Personal Web Server on page 49.

2 Start the Rational Administrator and create a new project, or register an existing 
project. For information about creating or registering a project, see the Using the 
Rational Administrator manual or the Rational Administrator online Help.

3 If you create or register a shared project, make sure that the privileges for the 
project directory are set for the virtual directory user account for IIS, or for the user 
account that the Web server runs under for PWS.

4 Restart the Web server.

Troubleshooting Your Web Server

If you have problems with your Web server, check to make sure that your Web server 
meets the software requirements. For information, see Software Requirements on page 
44. 
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