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Preface

This manual provides a complete description of the features and options available in
Rational RequisitePro, a requirements management tool that integrates a powerful
multi-user requirements database utility with the familiar environment of Microsoft
Word for Windows. The program allows you to work simultaneously with a
requirements database and requirements documents.

Audience

Using Rational RequisitePro is designed to meet the diverse needs and responsibility
levels of various types of users. Users may perform different roles that vary
depending on the RequisitePro project they access. The roles listed below describe
typical user functions; however, they may not correspond directly to RequisitePro
security groups. RequisitePro administrators can create any number of security
groups with specific permissions for creating, updating, and deleting projects,
documents, and requirements.

Requirements viewers read documents, query the requirements database, and
participate in discussion groups. These are common activities for all RequisitePro
users.

Requirements contributors perform the common activities of requirements
viewers; however, they have additional permissions to modify requirements
attribute values.

Requirements authors use standardized templates to write or revise requirements
documents and add, delete, or revise requirements in the project database. The
templates are created by the project administrators.

Project administrators create and manage all elements of a project (including
security, document types, and requirement types) and set up cross-project
traceability.

Using Rational RequisitePro is organized to initially introduce activities that are
common to all users who view and query requirements. It then moves to the skills
needed for creating and managing requirements, and it addresses the advanced skills
required for managing projects.

XV



The following table indicates which chapters will be most relevant for various types
of RequisitePro users:

Recommended Chapters

Type of

User 1/2 |3 4|5 6 |7 8|9 |[10|11 12|13 |14 |15 | 16
Requirements N IV IV Ve BV Ve e
Viewers
Requirements N IV BV Ve BV Ve g e
Contributors
Requirements | | | v | | ¥ || (||| €| e
Authors
Project (AN A A A AN
Administrators

All readers should refer to Appendix A, Keyboard Shortcuts and Mouse Actions;
Appendix B, Customizing RequisitePro; and the Glossary, which defines technical
terms used in RequisitePro.

Other Resources

@I = Online Help. You can view online help within RequisitePro whenever you need

XVi

assistance. To display the Help Contents, click the Help button on the Tool Palette,
click Help > Contents and Index, or press the F1 key. You can also click the Help
Help | button in any dialog box.

Let’s Go RequisitePro. This help interface automatically appears when you start the
application and provides prominent access to beneficial information about setting up
RequisitePro projects and the requirements management process. Let’s Go
RequisitePro guides new users through the various “getting started” information
available in RequisitePro, including online help and the Rational RequisitePro
Tutorial. For advanced users, it provides a single source for accessing pertinent,
in-depth documentation, including white papers, the Rational Unified Process, and
Web resources.

= Let’s Go RequisitePro automatically appears when you start RequisitePro, but you
can disable it by clearing the check box on the Tools > Options dialog box or on the
initial Let’s Go RequisitePro splash screen. You can launch Let’s Go RequisitePro
at any time from the Help menu by clicking Help > Let’s Go RequisitePro.

Preface



» Getting Started Tours. You can access two online help tours from either Let’s Go
RequisitePro or the Getting Started book in the help Contents tab: Requirements
Management Tour, an overview for using RequisitePro as part of a requirements
management process; and Project Administration Tips, a guide for RequisitePro
project administrators, who will be setting up and managing projects.

» The Rational RequisitePro Tutorial. The online tutorial is designed to help you
quickly learn how to use specific RequisitePro features. The tutorial consists of 7
modules; after you have installed RequisitePro, you can access the tutorial by
clicking the Start button and then clicking Program Files > RequisitePro.

» Rational Training Services. For more information on training opportunities, see
the Rational University Web site: http://www.rational.com/university.

Reference

Information about requirements management is provided in the following book:

* Dean Leffingwell and Don Widrig, Managing Software Requirements: A Unified
Approach (Addison Wesley, 2000).
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Contacting Rational Technical Support

If you have questions about installing, using, or maintaining this product, contact

Rational Technical Support:

Location

Contact Information

Notes

U.S. and Canada

800-433-5444
781-676-2450
support@rational.com

Europe

+31 (0) 20 4546 200
support@rational.europe.com

Asia Pacific

+61-2-9419-0111
support@apac.rational.com

When sending e-mail:

= Specify the product name
in the subject line, for
example, “Rational Suite”.

= For existing issues, include
your case ID in the subject
line

World Wide Web

http:/ /www.rational.com

Click the Technical Support
link.

Please help our Technical Support staff deliver quality customer service by providing
complete information. The techsupport.html file, which is located in the RequisitePro
installation directory and is also available by clicking Help > Contacting Technical
Support, contains a Customer Information Form. You can use this form to document
problems, questions, or suggestions and to detail your company and system
information. You can copy the form into your e-mail message.

Attach your error.log file (located in the RequisitePro installation directory in the bin
folder) if you are getting an error message. Add any files, screen captures, and other
information you feel are relevant.

Other Contacts

Joining the RequisitePro Users Mailing List

Rational has created an open e-mail list “req_forum@rational.com” for customers to
exchange ideas on using RequisitePro. This list is monitored to ensure product
questions and problems are being answered. To subscribe to the mailing list, go to the
following Web site: http://www.rational.com/support/usergroups.

Contacting Rational Technical Support  xix


http://www.rational.com/

Contacting Rational Technical Publications

To send feedback about documentation for Rational products, please send e-mail to
our technical publications department at techpubs@rational.com.

For technical problems and questions, please contact Technical Support.
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Introducing
Requirements
Management

This chapter is adapted from Rational’s white paper Applying Requirements
Management with Use Cases. The full version of this document is available from Let’s
Go RequisitePro. In RequisitePro, select Let’s Go RequisitePro from the Help menu, and
then click the link to the white paper.

Applying Requirements Management with Use Cases

If you are new to or somewhat familiar with requirements management and are
interested in improving your requirements management process, you can use the
framework presented in this chapter to develop your own approach.

Software and System Development in the Age of Process

For most software and system development teams, the 1990s have been
process-intensive when compared to the more freewheeling days of the past.
Standards for measuring and certifying effective software development process have
been introduced and popularized. Many books and articles on software development
process and related material on business process modeling and re-engineering have
been published. Increasing numbers of software tools have helped define and apply
effective software development process. The global economy’s dependence on
software accelerated in the past decade, enabling development processes and
improving system quality.

So how do we explain the high incidence of the software project failure today? Why
are many, if not most, software projects still plagued by delays, budget overruns, and
quality problems? How can we improve the quality of the systems we build as our
businesses, national economies, and daily activities become increasingly dependent
on them?

The answers, as always, lie in the people, tools, and processes applied to our
profession. Requirements management is often proposed as a solution to the ongoing
problems of software development, yet relatively little attention has been focused on
improving the practice of this discipline.



This chapter presents the elements of an effective requirements management process
and highlights some of the obstacles to its successful implementation.

Requirements management applies equally to software-only projects and to projects
in which software is only a part of the end result or is not included at all. For
convenience, the term “system” is used here to mean any or all of these things.
However, it is the abstract nature of software development, alone or in combination
with hardware, that complicates requirements management and is therefore the
primary focus of this chapter.

What Is a Requirement?

The first step toward understanding requirements management is to agree on a
common vocabulary. Rational defines a requirement as “a condition or capability to
which the system [being built] must conform.” The Institute of Electronics and
Electrical Engineers (IEEE) uses a similar definition.

Well-known requirements engineering authors Merlin Dorfman

and Richard H. Thayer offer a compatible and more refined A requirement s a

condition or

definition that is specific—but not necessarily limited—to capability to which
. the system must
software:
conform.

“A software requirement can be defined as:

s A software capability needed by the user to solve a problem or achieve an
objective.

2 A software capability that must be met or possessed by a system or system
component to satisfy a contract, specification, standard, or other formally
imposed documentation.”?

Why Manage Requirements?

Simply put, system development teams that manage requirements do so because they
want their projects to succeed. Meeting their project’s requirements defines success.
Failing to manage requirements decreases the probability of meeting these objectives.

Recent evidence is supportive:

» The Standish Group’s CHAQOS Reports from 1994 and 1997 established that the
most significant contributors to project failure relate to requirements.?
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» In December 1997, Computer Industry Daily reported on a Sequent Computer
Systems, Inc., study of 500 IT managers in the U.S. and U.K. that found 76 percent
of the respondents had experienced complete project failure during their careers.
The most frequently named cause of project failure was “changing user
requirements.”>

Avoiding failure should be sufficient motivation to manage requirements. Increasing
the probability of a successful project and other benefits of managing requirements
may be equally motivational. The Standish Group’s CHAOS report further
established that managing requirements well was the factor most related to successful
projects.

What Is Requirements Management?

Because requirements are things to which the system being built must conform, and
conformance to some set of requirements defines the success or failure of projects, it
makes sense to find out what the requirements are, write them down, organize them,
and track them in the event they change.

Stated another way, requirements management is:

» asystematic approach to eliciting, organizing, and documenting the requirements
of the system, and

» aprocess that establishes and maintains agreement between the customer and the
project team on the changing requirements of the system.

This definition is similar to Dorfman and Thayer’s and the IEEE’s definition of
“software requirements engineering.” Requirements engineering includes elicitation,
analysis, specification, verification, and management of the software requirements,
with “software requirements management” being the planning and controlling of all
these related activities.* All of these activities are incorporated in the definition of
requirements management presented here and taught by Rational Software. The
difference lies mainly in the choice of the word “management” rather than
“engineering.” Management is a more appropriate description of all the activities
involved, and it accurately emphasizes the importance of tracking changes to
maintain agreements between stakeholders and the project team.

The Problems of Requirements Management

So what might be difficult about a process intended to ensure that a system conforms
to the expectations set for it? When put into practice on real projects, difficulties come
to light.
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Figure 1 displays the results of
a 1996 survey of developers, Common Requirements Problems
managers, and quality

assurance personnel. It shows

the percentage of respondents #1 Can’t track changes 71%
who experienced the most
frequently mentioned #2 Difficult to write 70%
requirements-related
problems.
o #3 Feature creep 67%
A more comprehensive list of
problems includes the
following: #4 Not well organized 54%
= Requirements are not
always obvious and have _
Figure 1

many sources.
* Requirements are not always easy to express clearly in words.

* Many different types of requirements at different levels of detail must be
managed.

= The number of requirements can become unmanageable if not controlled.

* Requirements are related to one another and to other deliverables of the process in
a variety of ways.

» Requirements have unique properties or property values; they are neither equally
important nor equally easy to meet.

* Many interested and responsible parties are involved in a project, which means
that requirements must be managed by cross-functional groups of people.

* Requirements change.
» Requirements can be time-sensitive.

When these problems are combined with inadequate requirements management and
process skills and the lack of easy-to-use tools, many teams despair of ever managing
requirements well. Rational Software has developed the expertise to instruct teams in
requirements management skills and process, and Rational RequisitePro is an
accessible tool for automating effective requirements management.
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Requirements Management Skills

To resolve the problems mentioned above, Rational encourages the development of
key skills. These skills are presented below in what appears to be sequential order, but
in an effective requirements management process they are applied continuously in
varied order. Here they are presented in the sequence one would likely apply to the
first iteration of a new project.

Analyze the Problem

Problem analysis is conducted to

understand business problems, Steps in Proplem Analysis

target initial stakeholder needs, and Step 1 - Gain agreement on / )
propose high-level solutions. These the problem being
acts of reasoning and analysis find Step 2 - Identify the Y y
“the problem behind the problem.” stakeholders

P P Step 3 - Define the system / ) /
During problem analysis, agreement boundaries
. . Step 4 - Identify constraints b /
is gained on a statement of the real to be imposed on / )
problems and the stakeholders are the system
identified. Initial solution boundaries Y

and constraints are defined from
both technical and business
perspectives. If appropriate, the
business case for the project analyzes return on investment that is expected from the
system.

Figure 2

Understand Stakeholder Needs

Requirements have many sources. They may come from anyone with an interest in
the outcome of the project. Customers, partners, end users, and domain experts are
some sources of requirements; so too are management, project team members,
business policies, and regulatory agencies.

It is important to know how to determine who the sources should be, how to get
access to those sources, and how to elicit information from them. The individuals who
serve as primary sources for this information are referred to as “stakeholders” in the
project.

If you are developing an information system to be used internally within your
company, you may include people with end-user experience and business domain
expertise in your development team. Very often you will start the discussions at a
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business-model level rather than at a system level. If you are developing a product to
be sold to a marketplace, you may make extensive use of your marketing people to
better understand the needs of customers in that market.

Requirements may be elicited through activities such as interviewing, brainstorming,
conceptual prototyping, using questionnaires, and performing competitive analysis.
The result of requirements elicitation is a list of requests or needs that are described
textually and graphically and that have been given priority relative to one another.

Define the System

To define the system means to translate and organize the understanding of
stakeholder needs into a meaningful description of the system to be built. Early in
system definition, decisions are made on what constitutes a requirement,
documentation format, language formality, degree of requirements, request priority
and estimated effort, technical and management risks, and scope. Part of this activity
may include early prototypes and design models directly related to the most
important stakeholder requests.

We use the word “description” rather than “document” to avoid the perceived
limitation inherent in the common use of the latter. A description may be a written
document, electronic file, picture, or any other representation meant to communicate
system requirements.

The outcome of system definition is a description of the system that is both natural
language and graphical. Some suggested formats for the description are provided in
later sections.

Principle 55

WRITE NATURAL LANGUAGE BEFORE A MORE FORMAL MODEL
If you write the formal model first, the tendency will be to write natural language that
describes the model instead of the solution system.

TO MAKE A LONG DISTANCE CALL, THE USER SHOULD LIFT THE PHONE. THE SYSTEM SHALL
RESPOND WITH A DIAL TONE. THE USER SHOULD DIAL A “9”. THE SYSTEM SHALL RESPOND
WITH A DISTINCTIVE DIAL TONE...

THE SYSTEM CONSISTS OF FOUR STATES: IDLE, DIAL TONE, DISTINCTIVE DIAL TONE, AND
CONNECTED. TO GET FROM THE IDLE STATE TO THE DIAL TONE STATE, LIFT THE PHONE.
TO GET FROM THE DIAL TONE STATE TO THE DISTINCTIVE DIAL TONE STATE, DIAL A “9.”

Note that in the latter example, the text does not help the reader at all.

- Alan M. Davis, 201 Principles of Software Development, 1995
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Manage the Scope of the Project

The scope of a project is defined by the set of requirements allocated to it. Managing
project scope to fit the available resources (time, people, and money) is key to
managing successful projects. Managing scope is a continuous activity that requires
iterative or incremental development, which breaks project scope into smaller, more
manageable pieces.

Using requirement attributes, such as priority, effort, and risk, as the basis for
negotiating the inclusion of a requirement is a particularly useful technique for
managing scope. Focusing on the attributes rather than the requirements themselves
helps desensitize negotiations that are otherwise contentious.

It is also helpful for team leaders to be trained in negotiation skills and for the project
to have a champion in the organization, as well as on the customer side.
Product/project champions should have the organizational power to refuse scope
changes beyond the available resources or to expand resources to accommodate
additional scope.

Refine the System Definition

With an agreed-upon high-level system definition and a fairly well understood initial
scope, it is both possible and economical to invest resources in more refined system
definitions. Refining the system definition includes two key considerations:
developing more detailed descriptions of the high-level system definition and
verifying that the system will comply with stakeholder needs and behave as
described.

The descriptions are often the critical reference materials for project teams.
Descriptions are best done with the audience in mind. A common mistake is to
represent what is complex to build with a complex definition, particularly when the
audience may be unable or unwilling to invest the critical thinking necessary to gain
agreement. This leads to difficulties in explaining the purpose of the system to people
both inside and outside the project team. Instead, you may discover the need to
produce different kinds of descriptions for different audiences. This chapter includes
suggested formats for detailed natural language, formal text, and graphical
descriptions. After the description format is established, refinement continues
throughout the project lifecycle.
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Manage Changing Requirements

No matter how carefully you define your requirements, they will change. In fact,
some requirement change is desirable; it means that your team is engaging your
stakeholders. Accommodating changing requirements is a measure of your team’s
stakeholder sensitivity and operational flexibility, team attributes that contribute to
successful projects. Change is not the enemy—unmanaged change is.

A changed requirement means that more or less time has to be spent on implementing
a particular feature, and a change to one requirement may affect other requirements.
Managing requirement change includes activities such as establishing a baseline,
keeping track of the history of each requirement, determining which dependencies are
important to trace, establishing traceable relationships between related items, and
maintaining version control.

As Figure 3 illustrates, it is also important to establish a change control or approval
process, requiring all proposed changes to be reviewed by designated team members.
Sometimes this single channel of change control is called a Change Control Board

(CCB).
The Key to Managing Change
All Requests Go Through a Single Channel
Change requests come from many sources
throughout the product lifecycle
Customer and
End-User Inputs
e —
- New .
Single Channel Marketin
for Approval Feature - -(—g
New
Approved . ‘SRS
Decision Rem ‘ Coders inputs
Process Code Testers inputs
(ccB) | |—
Change -
Request (CR‘ ‘ Help Desk
End-User Inputs
h 4 Y«
Figure 3
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Important Requirements Concepts

To apply requirements management skills to a project, everyone working on a project
should understand certain requirements management concepts, including the
following:

Requirement Types. A requirement type is simply a class of requirements. The larger
and more intricate the system, the more types of requirements appear. By identifying
types of requirements, teams can organize large numbers of requirements into
meaningful and more manageable groups. Establishing different types of
requirements in a project helps team members classify requests for changes and
communicate more clearly.

Usually, one type of requirement can be broken down, or decomposed, into other
types. Business rules and vision statements can be types of high-level requirements
from which teams derive user needs, features, and product requirement types. Use
cases and other forms of modeling drive design requirements that can be decomposed
to software requirements and represented in analysis and design models. Test
requirements are derived from the software requirements and decompose to specific
test procedures. When there are hundreds, thousands, or even tens of thousands of
instances of requirements in a given project, classifying requirements into types
makes the project more manageable.

Cross-Functional Teams. Unlike other processes, such as testing or application
modeling, which can be managed within a single business group, requirements
management should involve everyone who can contribute their expertise to the
development process. It should include people who represent the customer and the
business expectations. Development managers, product administrators, analysts,
systems engineers, and even customers should participate. Requirements teams
should also include those who create the system solution—engineers, architects,
designers, programmers, quality assurance personnel, technical writers, and other
technical contributors.
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Analysts Requirements

Figure 4

Often, the responsibility for authoring and maintaining a requirement type can be
allocated by functional area, further contributing to better large project management.
The cross-functional nature of requirements management is one of the more
challenging aspects of the discipline.

Traceability. As implied in the description of requirement types, no single expression
of a requirement stands alone. Stakeholder requests are related to the product features
proposed to meet them. Product features are related to individual requirements that
specify the features in terms of functional and nonfunctional behavior. Test cases are
related to the requirements they verify and validate. Requirements may be dependent
on other requirements or mutually exclusive.

In order for teams to determine the impact of changes and feel confident that the
system conforms to expectations, these traceability relationships must be understood,
documented, and maintained. Traceability is one of the most difficult concepts to
implement in requirements management, but it is essential to accommodating
change. Establishing clear requirement types and incorporating cross-functional
participation can make traceability easier to implement and maintain. For more
information on different strategies for requirements traceability, see the white paper,
Traceability Strategies for Managing Requirements with Use Cases.”
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Requirements Traceability
Establish Traceability Paths
Product 1. Trace top level
Requirements Req A requirements into detailed
(Features) .
requirements
1 2. Trace requirements into
design
Detailed . .
Requirements Req B 3. Trace requirements into
(Use Cases) test procedures
2 3 4 4. Trace requirements into
user documentation plan
Design Test User Docs
Software Design Test Suites Documentation
Descriptions Plan
Object Models
Figure 5
Multidimensional Attributes. ,

Each type of requirement has
attributes, and each individual
requirement has different attribute
values. For example, requirements
may be assigned priorities,
identified by source and rationale,
delegated to specific sub-teams
within a functional area, given a
degree-of-difficulty designation, or
associated with a particular
iteration of the system. To illustrate,
Figure 6 displays attributes for a
Feature Requirement Type from an

General I Revision |

Reguirement Types
Attributes

Documents: I Document Types

Fequirement Type:

FEAT: Feature

Fequirement Type

Fequirement Attribute:
Label:

Pricrity ﬂ
Statug

Cost

Difficulty =l

Add... | Edit... | Eemoye | Movegpl Movegownl

QK I Cancel | Help |

Figure 6

example project in RequisitePro. As implied by the title of the screen, the requirement
type and attributes for each type are defined for the entire project, ensuring usage

consistency across the team.
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In Figure 7, feature

requirements are displayed W =]

for a specific project in Redurements. -
FEAT!: The 0 5 | vedium [T

FEATZ: The GBS system shall provide a loan office Lot Medium

RequisitePro. Note that
even without dlsplaylng FEAT3: The GBS System shall calculate the blue... Medium Medium
. FEAT4: The GBS system shall allow only.. High Medium
the entire text for each FEATS: The GBS system shall allaw only... High Medium | |
requirement, we can learn < | |
FEAT1: The QBS system shall, upon user request, display detailed customer ;I

a great deal about each
requirement from its
attribute values. In this
case, its priority and difficulty (which may be assigned by different team members)
will help the team begin to scope the project to available resources and time, taking
into account both stakeholder priorities and a very rough estimate of effort reflected
in the difficulty attribute value. In more detailed types of requirements, the priority
and effort attributes may have more specific values (for example, estimated time, lines
of code) with which to further refine scope. This multi-dimensional aspect of a
requirement, compounded by different types of requirements—each with its own
attributes—is essential to organizing large numbers of requirements and to managing
the overall scope of the project.

infarmation including: OMame, 0Address, OPhone MumberDAccount MumbersOL LI

Figure 7

Change History. Both individual requirements and collections of requirements have
histories that become meaningful over time. Change is inevitable and desirable to
keep pace with a changing environment and evolving technology. Recording the
versions of project requirements enables team leaders to capture the reasons for
changing the project, such as a new system release. Understanding that a collection of
requirements may be associated with a particular version of software allows you to
manage change incrementally, reducing risk and improving the probability of
meeting milestones. As individual requirements evolve, it is important to understand
their history: what changed, why, when, and even by whose authorization.
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Putting Requirements Management to Work

Requirements management employs the key skills and concepts presented above to
identify and resolve the problems successfully.

To build a system that truly meets customers’ needs, the project team must first define
the problem to be solved by the system. Next, the team must identify stakeholders
from whom business and user needs are elicited, described, and prioritized. From this
set of high-level expectations or needs, a set of product or system features should be
agreed upon.

Introduction to Requirements Management
Overview

»

o )
Problem Problem
Space
. ./ ~—
A Solution
Features ) Space
Q i ./i
% ~a|  The
. Product
Software Z i/' To Be
Requirements o Built \‘i
Test '
Procedures x

Figure 8

Detailed software requirements should be written in such a form as can be
understood by both the customers and the development team. We have found that
using the language of the customer to describe these software requirements is most
effective in gaining the customer’s understanding and agreement. These detailed
software requirements are then used as input for the system design specifications as
well as for test plans and procedures needed for implementation and validation.
Software requirements should also drive the initial user documentation planning and
design.
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Effective requirements management

includes the following project team A Few Words about Documents

activities: The decision to describe requirements in
documents deserves some thought. On the

1 Agree on a common vocabulary one hand, writing is a widely accepted form

of communication and, for most people, a
natural thing to do. On the other hand, the

2 Develop a vision of the system that | £0al of the project is to produce a system,

. not documents. Common sense and
describes the problem to be solved experience teach that the decision is not

for the project.

by the system, as well as its whether but how to document requirements.
primary features. Document templates provide a consistent
o ) format for requirements management.
3 Elicit stakeholders’ needs in at Rational RequisitePro offers these templates
least five important areas: and the additional feature of linking

requirements within a document to a database

functionality, usability, reliability, containing all project requirements. This

performance, and supportability. unique feature allows requirements to be
) . documented naturally, making them more
4 Determine what requirement types accessible and manageable in a database.
to use.

5 Select attributes and values for each requirement type.
6 Choose the formats in which requirements are described.

7 Identify team members who will author, contribute to, or simply view one or more
types of requirements.

8 Decide what traceability is needed.

9 Establish a procedure to propose, review, and resolve changes to requirements.
10 Develop a mechanism to track requirement history.

11 Create progress and status reports for team members and management.

These essential requirements management activities are independent of industry,
development methodology, or requirements tools. They are also flexible, enabling
effective requirements management in the most rigorous and the most rapid
application development environments.

Sources

1 M. Dorfman and R. Thayer, Software Engineering (Los Alamitos, CA: IEEE
Computer Society Press, 1997), p. 79.

2 CHAOS, The Standish Group International, Inc. (Dennis, MA, 1994, 1997).

3 Computer Industry Daily, December 12, 1997.
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4 M. Dorfman and R. Thayer, Software Engineering (Los Alamitos, CA: IEEE
Computer Society Press, 1997), p. 80.
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with Use Cases, White Paper (Rational Software Corporation, 1998).
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Introducing Rational
RequisitePro

This chapter covers key Rational RequisitePro concepts. A complete glossary can be
found at the end of this book.

Why Use RequisitePro?

Studies have shown that managing requirements is the most significant factor in
delivering projects on time, on budget, and on target. RequisitePro helps projects
succeed by giving teams the ability to manage all project requirements
comprehensively, while facilitating team collaboration and communication.

Moving beyond conventional requirements management, RequisitePro combines
both document-centric and database-centric approaches. By deeply integrating
Microsoft Word with a multi-user database, RequisitePro enables you to organize,
prioritize, trace relationships, and easily track changes to your requirements. The
program’s unique architecture and dynamic links make it possible for you to move
easily between the requirements in the database and their presentation in Word
documents.

Team Collaboration and User Satisfaction

Requirements drive the entire project. RequisitePro’s integration with other
industry-leading tools optimizes the flow of requirements data throughout the
project, promoting consistency and ensuring that what is designed, tested,
documented, and delivered meets the users’ needs. RequisitePro’s deep integration
with other lifecycle tools promotes artifact reusability and eases the sharing of
information, further enhancing team collaboration.

A product development team typically includes a large number of individuals with
diverse roles, such as business analysts, project leaders, product marketing managers,
development managers, QA managers, developers, and testers. Giving each person
on your team access to critical requirements information, and the ability to manage
those requirements, promotes team efficiency and effectiveness and reduces project
risk.
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Flexibility Through the Web Component

In addition to the Windows client version of RequisitePro, RequisiteWeb offers a
Web-based client for RequisitePro. RequisiteWeb allows users to access RequisitePro
requirements information across the Internet or an intranet. By using browsers—
Netscape Navigator or Microsoft Internet Explorer—RequisiteWeb provides a thin
client solution to access project documents and data. No Rational application-specific
files need to be installed on the user’s machine.

Using RequisiteWeb, you can modify the name, text, and attributes of requirements
directly in the database and from within documents, and you can create, delete,
query, and reparent requirements in the database. All changes are automatically
tracked, just as they are in RequisitePro. Requirement authoring through the Web
allows better support of distributed teams and multiple-platform environments.

RequisiteWeb supports the following features:

* Viewing documents

* Modifying requirements (in documents or database)

» Creating requirements in the database

» Creating and modifying Attribute Matrix views

= Creating and modifying Traceability Tree views (traced into or traced out of)
= Setting your own user password

* Viewing, modifying, and creating hierarchical relationships

» Creating traceability links within and across projects

» Filtering and sorting requirements

» Creating and replying to discussions

Change Management

Change occurs in practically every development project, but it does not have to
consume project resources or throw the project off course. With RequisitePro, you can
manage inevitable change to ensure that your entire team is current as requirements
evolve. Robust traceability features in RequisitePro enable you to establish and
maintain dependencies between different requirements. As change occurs, these
traceability relationships are flagged as suspect, so you can understand how change
affects the entire project. For each requirement a change history is maintained,
capturing the who, what, when, and why of the change.
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Comprehensive Process Support

Whether your team follows a rigorous requirements management process, such as
IEEE, SEI CMM, or Unified Modeling Language-driven use-case approaches, or is just
beginning to define a formal process, RequisitePro can help you meet your objectives
of delivering precise, quality software. RequisitePro provides industry standard
project templates and attributes, and it can also import existing documents and be
customized to support existing projects.

A Quick Tour of Key Concepts in RequisitePro

This section provides an overview of RequisitePro concepts and defines some terms
that will help you get started.

Requirement

RequisitePro is a requirements repository, which organizes requirements and
provides traceability and change management throughout the project lifecycle. A
requirement describes a condition or capability to which a system must conform.
Requirements contain a name and text, and they can be qualified with attributes to
provide specific details.

Requirement types and attributes are discussed later in this chapter. (For more
information on requirements, refer to the chapter Working with Requirements on page
115.)

Project

A RequisitePro project includes a requirements database and its related documents. A
project is usually created by a project administrator, who determines the project
structure and sets up security permissions for the project’s users.

Although all project users are encouraged to view and query requirements and to
participate in discussions, only a limited group of users create and manage
requirements within a project.

(For more information on projects, refer to the following chapters: Creating Projects on
page 181; Working with Project Security on page 191, Managing Projects on page 205;
and Working with Project Information on page 229.)
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Project Database

The project database is the requirements database managed by RequisitePro. When
you use RequisitePro, you can use one of four physical databases to store
requirements: Microsoft Access, Oracle, or Microsoft SQL Server. Each RequisitePro
project has its own database, where all the requirements for a project are stored. (With
the exception of Microsoft Access, all of these databases may contain more than one
project.)

In the project database, requirements can be added, modified, or deleted. When
requirements are changed in a document, the changes are updated in the database.

Often a project includes a variety of requirements documents, such as a product
requirements document, a system requirements document, software and hardware
specifications, user requirements, quality assurance procedures, and test plans.
Information from all project documents is stored in the project database. The database
centralizes information, so that members of the project team can update requirements,
manage priorities and test plans, and report the project’s progress in one shared
repository.

Project Version Control

RequisitePro’s version control lets you trace change by archiving projects. You can
manage multiple versions of your projects, retrieving, modifying, and returning
revisions to the archive in an organized and consistent manner. From RequisitePro,
you can use RequisitePro’s Archive command or Rational ClearCase.

If your team is using Unified Change Management (UCM), RequisitePro project
administrators can create baselines of RequisitePro projects by performing tasks in
Rational Administrator and ClearCase, implementing the UCM model. If you have a
RequisitePro project that is baselined, you can use that baseline to create new projects
in RequisitePro. For example, you may want to base the next release of a project on a
stable configuration of the previous release.

(For more information, refer to Archiving Projects on page 212 and Creating a Project
Baseline with Unified Change Management on page 221.)

Project List

A RequisitePro project list is a personal library of accessible RequisitePro projects.
Each user’s list is unique. For example, a project administrator who monitors the
progress of all the projects scheduled for completion this quarter could have an
extensive list of projects, whereas some users might have just one project in their lists
at a time.

20 Chapter 2 - Introducing Rational RequisitePro



Project administrators store new projects in their file systems—typically in the
RequisitePro Project directory. In the Open Project and Documents dialog box, you
can add or delete projects from your project list as you need them. (For more
information, refer to Adding a RequisitePro Project to Your Project List on page 33.)

The Tool Palette, Word Workplace, and Views Workplace

RequisitePro is composed of workplaces where distinct but interrelated work is done.
The workplaces are launched from the Tool Palette as shown in the figure on the
following page. All requirements information, whether it is displayed in the Views
Workplace or the Word Workplace, is stored in the database.

Tool Palette

When RequisitePro is started, the Tool Palette is displayed. Menus on the Tool Palette
contain RequisitePro commands and provide access to project information, document
information, requirements information, discussions, and views.

The icon buttons below the menu bar are shortcuts to frequently used menu
commands. When you position your mouse over a button, a ToolTip appears,
describing the button’s function. Use the first button on the Tool Palette to open
RequisitePro projects and documents.

Word Workplace

The Word Workplace is the place within RequisitePro where requirements are created
and modified in a document. The Word Workplace contains requirement
specifications in the form of RequisitePro documents and Word documents.

The Word Workplace looks like a Word document, but the menu bar has been
modified to include a RequisitePro menu that allows you to manage requirements
and documents. With a few exceptions, RequisitePro uses the same commands in the
Word Workplace that are available in Microsoft Word. The File > Exit and Tools >
Templates and Add-in commands are unavailable in the Word Workplace in order to
prevent conflicts in handling RequisitePro documents.

Views Workplace

The Views Workplace is a window to the database. Requirements, their attributes,
and their relationships to each other are displayed and managed in views.
RequisitePro includes powerful query functions for filtering and sorting the
requirements and their attributes in views. All Views Workplace commands are
located in the menu bar at the top of the Views Workplace. As in the Tool Palette, icon
buttons are available to access one command at a time.
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Views

In RequisitePro, a view is accessed in the Views Workplace. Views present
information about a project, a document, or requirements graphically in a table
(matrix) or in an outline tree. Views display the attributes assigned to requirements,
such as Status and Priority, or the relationships between different types of
requirements, such as parent-child requirements. (For more information, refer to the
chapter Working in Views on page 41.)

Three kinds of views can be created in the Views Workplace:

» The Attribute Matrix displays all requirements of a specified type. The
requirements are listed in the rows, and their attributes appear in the columns.

» The Traceability Matrix displays the relationships (traceability) between two
types of requirements.

= The Traceability Tree displays the chain of traceability to or from requirements of
a specified type.

1 RequisitePro Views =l B

Fie View Reguiement Window Help

DlelE| =] mi=l%| = nlal 6l 65l

B SR: Attribute Matrix [_[Ofx~
C|Difficulty [ Stability Unigu 2
Reguirements: =
=) SR1: The system shall display a Gustomer. [medium _ [uedium  [starr [20
SR1.1:Name [vedium — [edium  [starr [21
SR1.2: Address [Medium — [medium —|starr |22
BRI B 5 SR-PR: Traceability Matria M= B
SR1.4: Account NUmbers e — = = —
SR1.5: Loan Numbers aldlald <M < g O =
SR1.5. Balance Informationfor; | RoiTements =HEEEE E 1= =)<
SRZ: The systern shall save all up e el el 2 sty (E) [P
ate o oo o o oo oo
Gl oo oo o e oo |o
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I e | SR Pivoe... | B = = SR1: The system display a Customer ﬂ Requirement PRE
Requitement G4, 2 modiied | BR14Account. | | | &4 PR1: The GBS systern shall, upon, Priority Mediurm
_— SR1.5: Loan. | [ | & [EE Status Proposed
SR1.5: Balance.. Cost
4 g 2;1 12 :;dme Difficulty Lowy
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SR1: The syster shall display ¢ Stahility Medium
— = ER1.2:Phane Number Assigned To
JPREThe BES Systemshalal | - 5= 5R1 4 Account Numbers Unique 1D 8
3 % PR11: Each user shall have a Laocation QBS Product Reguirerr
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Three views of the same requirements. Top to bottom: Attribute Matrix, Traceability Matrix,
Traceability Tree.
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Documents

A requirements document is a specification that captures requirements, describes the
objectives and goals of the project, and communicates product development efforts.
Each requirements document belongs to a particular document type, explained
below.

RequisitePro manages requirements directly in the project documents. When you
build a requirements document, RequisitePro dynamically links it to a database,
which allows you to manage requirements by updating and saving the documents.
When you save revisions, they are available to team members and others involved
with the project.

With RequisitePro’s version tracking, you can easily review the change history for a
requirement, a document, or the whole project.

Documents are created in either Word or RequisitePro format. RequisitePro format
makes proprietary modifications to the standard Word application that allows
RequisitePro to exercise security controls over the document. As such, certain Word
features are unavailable, and that functionality is available instead through
commands on the RequisitePro menu in the Word Workplace and the Tool Palette.
For example, Word'’s File > Open command is executed in RequisitePro as Document >
Open on the Tool Palette and RequisitePro > Document > Open in the Word
Workplace.

Not all documents are requirements documents. Documents do not have to contain
requirements to be included in a project. Any Word document, no matter where it
resides in the file system, can be associated with a project and is available in the
document list when a project is opened. (For more information, refer to the chapter
Working with Documents on page 93.)

Document Types and Requirement Types

Document types and requirement types are two similar requirements management
concepts and tools. Both serve as outlines and define the appearance of two essential
requirements management components, a document and a requirement. However,
they differ in their application.

Document Type

A document type identifies the type of document, such as a use-case or a software
requirements specification, and helps ensure consistency across documents of the
same type. A document type is an outline that is applied to documents. The outline
can include the default font for the document, the available heading and paragraph
styles, and the default type of requirements for the document, or it can encompass
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both formatting conventions and an outline that helps you organize your
requirements information. (For more information, refer to Creating and Modifying
Document Types on page 231.)

All documents of the same document type share the same file extension (for example,
.prd). You determine document types when you create or modify your project. Then,
when you create a document, you can associate it with a document type already
defined in your project. The new document inherits the style and functional attributes
associated with the document type, making it consistent with other documents of the
same type.

RequisitePro provides standard document outlines that can be used “as is” or
customized according to your specifications. After you have defined the appearance
of the document and the information to include, you can use the document as a
standard for your organization.

There are several benefits to using standards:

* The outline can be used as an example of the type of information to include and
can serve as a comprehensive “to do” list so no information is overlooked.

» Expectations and procedures are clearly presented so new authors and team
members spend less time learning to build the necessary requirements documents.

= Authors familiar with the outline can create new documents quickly.

= Readers familiar with the outline can quickly locate and review information.

Requirement Type

A requirement type is an outline for your requirements. Requirement types are used
to classify similar requirements so they can be efficiently managed. When you define
a requirement type, you define a common set of attributes, display style, and tag
numbering.

You can create your own requirement types appropriate for your project. (For more
information, refer to Creating and Modifying Requirement Types on page 236.)

Requirement Attributes

In RequisitePro, requirements are classified by their type and their attributes. An
attribute provides information to manage a requirement. Attributes can provide
crucial information to help a team plan, communicate, and monitor project activities
from the analysis and design phases through the release phase.
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Attribute information may include:

» The relative benefit of the requirement

= The cost of implementing the requirement

= The priority of the requirement

» The difficulty or risk associated with the requirement

» The relationship of the requirement to another requirement

RequisitePro provides several default requirement attributes, such as Priority (high,
medium, low), Status (proposed, approved, incorporated, validated), Cost, and
Difficulty. These attributes are suggestions. You can create and control attributes
according to your needs. Whichever attributes you use, RequisitePro allows you to
easily customize your project documents and databases to define, articulate, and
manage the processes of your organization.

You can use attributes to determine which requirements to implement in the next
release. For example, you may decide that in the first release, you will implement only
those requirements evaluated as high risk, with high difficulty. If you have assigned
risk and difficulty attribute values to each requirement, you can then easily query all
requirements of high risk and high difficulty.

(For more information, refer to Creating and Modifying Requirement Attributes on
page 240.)

Hierarchical Relationships

Hierarchical requirement relationships are one-to-one or one-to-many, parent-child
relationships between requirements of the same type. Use hierarchical relationships
to subdivide a general requirement into more explicit requirements.

Example:

Parent requirement:
The system shall display customer information.

Child requirements provided for detail:
Name

Address

Date of Birth

When working with hierarchical relationships, keep the following in mind:

= Each child requirement can only have one parent, but a requirement can be both a
parent and a child.
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The parent and child requirements must be located in the same place. If a parent
requirement appears in a document, the child requirement should also appear in
that document. (Note that all requirements are stored in the database.)

You can create hierarchical relationships in the Word Workplace or the Views
Workplace, using the Hierarchy tab in the Requirement Properties dialog box. (In
the Views Workplace, you can also use Requirement menu commands to create
hierarchical relationships.)

When you delete a parent, you can choose to delete its children or assign them to
another parent.

You cannot create a traceability relationship between a parent and its own child.

Hierarchical relationships are a type of change-managed relationship in
RequisitePro. If a requirement is changed, the relationships with its children
become suspect. You can view and manage suspect relationships using a
Traceability Matrix or a Traceability Tree in the Views Workplace.

(For more information, refer to Working with Hierarchy on page 143.)

Traceability Relationships

Traceability links requirements to related requirements of same or different types.
RequisitePro’s traceability feature makes it easy to track changes to a requirement
throughout the development cycle. Without traceability, each change would require a
review of your documents to determine which, if any, elements need updating.

When working with traceability relationships, keep the following in mind:

You can create a traceability relationship between requirements of the same or
different types.

You can create traceability relationships between requirements that exist in the
same document, in different documents, or in the project database.

You can create, view, and manipulate traceability relationships in the Word
Workplace or in the Views Workplace.

Traceability relationships are a type of change-managed relationship in
RequisitePro. If either end-point of the connection is changed, the relationship
becomes suspect. If you modify the text or selected attributes of a requirement that
is traced to or traced from another requirement, RequisitePro marks the relationship
between the two requirements “suspect.”
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» Traceability relationships cannot have circular references. For instance, a
traceability relationship cannot exist between a requirement and itself, nor can a
relationship indirectly lead back to a previously traced from node. RequisitePro
runs a check for circular references each time you establish a traceability
relationship.

Note: You cannot create a traceability relationship between a parent and its own
child, but you can create a traceability relationship between a parent requirement and
a different parent requirement’s child.

(For more information, refer to the chapter Working with Traceability on page 153.)

Traced to/Traced from Relationships

The trace to/trace from state represents a bidirectional dependency relationship
between two requirements. The trace to/trace from state is displayed in a Traceability
Matrix or Traceability Tree when you create a relationship between two requirements.

For example, you might create a feature requirement (Requirement A) that calls for a
new command to be added to a particular menu in your application. In addition, in
another requirements document, you might create a use-case requirement
(Requirement B) associated with that menu item. You would thus create a traceability
relationship in which the use-case requirement (B) is traced from the feature
requirement (A).

There can be only one traceability relationship between any two requirements. The
difference between a trace to and a trace from relationship is perspective. In the
example above, both of the following statements are true:

» Ais traced to B
» Bis traced from A

Direct and Indirect Traceability Relationships
Traceability relationships may be either direct or indirect.

In a direct traceability relationship, a requirement is physically traced to or from
another requirement. For example, if Requirement A is traced to Requirement B, and
Requirement B is traced to Requirement C, then the relationships between A and B
and between B and C are direct relationships. The relationship between A and C is
indirect. Indirect relationships are maintained by RequisitePro; you cannot modify
them directly.
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Suspect Relationships

A hierarchical relationship or a traceability relationship between requirements
becomes suspect if RequisitePro detects that a requirement has been modified. If a
requirement is modified, all its immediate children and all direct relationships traced
to and from it are suspect.

When you make a change to a requirement, the suspect state is displayed in a
Traceability Matrix or a Traceability Tree. Changes include modifications to the
requirement name, requirement text, requirement type, or attributes.

For more information about parent-child relationships or traceability relationships
that are marked suspect, refer to the sections Suspect Relationships on page 151 and
Suspect Relationships on page 160.
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Getting Around in
Rational RequisitePro

This chapter explains the basics of opening Rational RequisitePro and accessing
RequisitePro projects.

Starting RequisitePro

You can start RequisitePro in one of two ways:

=  On the Start menu, click Programs. Click the installed Rational Windows Suite
and/or RequisitePro version, and then click RequisitePro.

= In Windows Explorer, double-click any file name with the .rqs extension.

Using the RequisitePro Tool Palette

The Tool Palette is the central interface for accessing and working with RequisitePro
projects. When RequisitePro is started, the Tool Palette appears.

& Rational RequisitePro _ [} |

Project Document  Bequirement Tool:  Window  Help

=@ lue olemE = o

Feady |

* Menus on the Tool Palette contain RequisitePro commands and provide access to
project information, requirements information, and views.

= The icon buttons below the menu bar are shortcuts to frequently used menu
commands. When you position your mouse over a button, a ToolTip appears,
describing the button’s function.

By default, RequisitePro displays the Tool Palette on top of other applications on your
desktop. If you have changed the desktop to display other applications on top, you
can view the RequisitePro Tool Palette by doing one of the following;:

= In the Views Workplace, click Window > Show Tool Palette.
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In the Word Workplace, click RequisitePro > Window > Show Tool Palette.

To display the Tool Palette when it is behind other applications, press ALT-TAB to
display opened applications, and then select the RequisitePro icon.

To always keep the Tool Palette on top of all applications, change options in the
Options dialog box. On the Tool Palette, click Tools > Options. Select Always On
Top in the Tool Palette pane, so that a check mark appears in the check box.

Exiting RequisitePro

When you exit RequisitePro, the application closes the current project, prompting you
first to save any changes you made to the project’s requirements documents.

1

On the Tool Palette, click Project > Exit.

If you did not modify any requirements document, a dialog box appears, asking
you to confirm that you want to exit. Click Yes.

If you modified one or more requirements documents and have not yet saved
those changes, the Document Changed dialog box appears.

Document Changed E

The document 'OBS Product Requirements Document’ has
been modified. Do you want to save the document before
closing?

Mo Cancel Beview Changes...

2 Do one of the following:

s To save the changes you made without reviewing the changes, click Yes.
If you made changes to a requirement’s text, the Change Description dialog box
appears and asks you to enter the reason for the changes before saving.

2 To close the document and exit RequisitePro without saving the changes, click
No.

2 To cancel the exit process, click Cancel.

s To review changes to the document, click Review Changes.
If you made changes to a requirement’s text, the Change Description dialog box
appears and asks you to enter the reason for the changes.

32 Chapter 3 - Getting Around in Rational RequisitePro



The Document Changes dialog box appears, listing each modification to the
document.

Document Changes E
The following changes were detected in the document:
- Document contents modified.

- Deleted requirements: PRZ.

Do you want to zave these changes in the databaze?

Mo Cancel

3 Do one of the following:

s To save the changes you made, click Yes. RequisitePro saves the changes in the
document and in the database.

a To close the document and exit RequisitePro without saving the changes, click
No.

s To cancel the exit process, click Cancel.

Working with Projects

When you click Project > Open and the Open Project and Documents dialog box
appears, you will notice there are names of projects listed in the Select a Project field.

A RequisitePro project list is a library of accessible RequisitePro projects. Each user’s
project list is unique. All projects are stored in the file system. Using the Open Project
and Documents dialog box, you can select projects from the file system for your own
project list. You can add or remove projects from your list as you need them.

Adding a RequisitePro Project to Your Project List

Before you can access a RequisitePro project, you must add it to your project list.
When you create a project, it is automatically added to your list of projects.
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To add a project to your project list:

1 On the Tool Palette, click Project > Open.
The Open Projects and Documents dialog box appears.

Open Project and Do X

Select a Project:

Add...

Praject 10 J Remaove |

Froject 15 P i |

Froject 16 LI EeTEs

Location: |C:\PHDGF|AM FILESARATIOMALA\REQUISITEPROYSAMPLE S \LEARMIMG

Open project options: " Read Only ™ Exclusive

Select Document(s): Dizplay Type(s) |4l Types ™

Arrange Shipment ucs

Check Order Status ucs

CheckOut ucs

ClazsicsCh Supplementary Specification Sup

ClassicsCD Vision Docurment WS

Glozzany GLS

Shop far CO ucs

Open document(s] option: I Read Only Froperties... |
oK | Cancel | Help |

Note the list of projects in the Select a Project field.
2 Click Add. The Add Project dialog box appears:

Add Project [2]=]
Lockin | '3 RemuisiePro 20 =] ﬁfl
“iProject].1gs
Flename:  [s ﬂl
Fils of e |Frojects [ RIS) | Carcel

3 Locate the project file you want to add to the list. (Project files have an .rqs
extension.)

4 Select the file and click Open.

5 Click OK. RequisitePro adds the project to your project list, and it appears in the
Select a Project field. You can now open the project and use its associated
requirements and documents.

Tip: Click the Properties button next to the Select a Project field to change the database
properties of the selected project.
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Note: To add a project stored on a floppy disk, move or copy the project to a local
drive or network drive (using Windows Explorer), and then add it to your project list.

Removing a Project from the Project List

Removing a project from the project list does not delete the project files; it simply
removes the project from the listing. It remains in the file system and can be added to
your project list again.

To remove a project from the project list:

1 On the Tool Palette, click Project > Open.
The Open Project and Documents dialog box appears.

2 Select the project name in the Select a Project list and click Remove. RequisitePro
removes the project.

Note: You can retrieve a project you removed by clicking the Add button. (Refer to
the preceding section.)

3 Click OK.

Opening a Project and Documents

When you open a RequisitePro project, you can open one or more of its associated
documents at the same time, or you can open just the project without selecting a
document. RequisitePro displays all documents associated with the project,
regardless of where they are stored on the file system.

If you try to open a project that was created in RequisitePro version 4.0 or later and
requires updating to the current version, the Database Upgrade Wizard appears. The
wizard guides project administrators through the process of upgrading existing
database structure and project data to the current RequisitePro release. If a project is
in a version of RequisitePro earlier than 4.0, you must first upgrade the project to
version 4.0 before using the Database Upgrade Wizard. Contact Technical Support for
information.

Note: Do not open a project that is in the process of being baselined in Unified
Change Management or added to ClearCase.
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To open a project and a document:

ﬁ, 1 On the Tool Palette, click Project > Open (or click the Project button).

The Open Project and Documents dialog box appears.

Open Project and O x|

Select a Project:

Add...

Praject 10 J Remove |

Project 14

Project 15 = i

Project 16 LI Toperties... |

Location: |E:\PF|DGF|AM FILES\RATIONALNREGQUISITEPROMVS AMPLESALEARMNING

Open project options: [ Read Only ™ Exclusive

Select Document(s]: Display Type(s)|&ll Types ™

Armange Shipment ucs

Check Order Status ucs

CheckOut ucs

ClazzicsCD Supplementary S pecification SUP

ClaszicsCD Vision Document WIS

Glozzary GLS

Shop for CD ucs

Open document(s] option: [ Read Only Froperties. . |
()8 | Cancel | Help |

2 Select the project to open in the Select a Project list box.
3 Select the document or documents you want to open.

When documents are created, they are assigned a document type. The Select
Documents list displays documents by type. (To see a different selection of
documents, choose another document type from the Display Types drop-down menu.)
This list includes all documents you have either created in the project or imported into
the project, regardless of whether the documents contain requirements. You can use a
multiple select action (CTRL-click, SHIFT-click, or drag) to open more than one
document.

4 Select the user access options. If you want to be the only user who has access to the
project and documents, select the Exclusive check box. To open all selected
documents in read-only mode, select the Read Only check box.

5 Click OK.
Depending on the security set on the project, one of two dialog boxes appears:
» If security is set on the project, refer to Accessing a Secure Project on page 38.

» If no security is set on the project, but your user name has not been identified in
the project, the Project Logon dialog box appears.
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Do one of the following:

2 Accept the displayed name.

2 Click the down arrow and select a user name from the list.
s Type a new user name that will be added to the project.
Click OK.

The project opens, and the new name is added to the project.

Note: Do not press the ESC key while the document is opening.

Closing a Project and Documents

The Close command closes a project and its documents and any open views.

1

On the Tool Palette, click Project > Close.

If you made no changes, the Project Close dialog box appears and prompts you to
close the project and its documents or keep it open. Click Yes to close the project
and its documents.

If you modified but did not save a document, the Document Changed dialog box
appears.

Document Changed E

The document 'OBS Product Requirements Document’ has
been modified. Do you want to save the document before
closing?

Mo Cancel Beview Changes...

2 Do one of the following:

s To save the changes to the document, click Yes. If you made changes to a
requirement’s text, the Change Description dialog box appears and asks you to
enter the reason for the changes before saving.

s To close the project without saving the document changes, click No.
2 To cancel the close project procedure, click Cancel.

2 To review document changes, click Review Changes. If you made changes to a
requirement’s text, the Change Description dialog box appears and asks you to
enter the reason for the changes.
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The Document Changes dialog box appears, listing each modification to the
document.

Document Changes E
The following changes were detected in the document:
- Document contents modified.

- Deleted requirements: PRZ.

Do you want to zave these changes in the databaze?

Mo Cancel

3 Do one of the following:
s To save the changes to the document, click Yes.
s To close the project without saving the document changes, click No.

2 To cancel the close project procedure, click Cancel.

Accessing a Secure Project

Project administrators can enable security for a project, requiring users to log on and
provide a password. The project administrator sets up security and assigns a user
name and password to each member of the team.

Logging on to RequisitePro
To log on and to access a secured RequisitePro project:

~a| 1 On the Tool Palette, click Project > Open (or click the Project button). The Open
== Project and Documents dialog box appears.

2 Highlight a project in the list to open and click OK. If RequisitePro detects that
security is enabled, the Project Logon dialog box appears.

Project Logon [x]
Usermame: I.t’-‘-.dmin
Password: I xxxxxxxxxxxxxx

QK I Cancell Help |

3 Type your name in the Username text box and your password in the Password
text box. Click OK. You are now ready to use the project.
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Modifying Your Password, User Name, or E-mail Address

When you are in a project, you can modify your password, user name, or e-mail
address. If you are a RequisitePro administrator or a member of a group with project
security permissions, you also have the ability to change the password, user name, or
e-mail address for other users. See Editing User Information on page 195.

A valid e-mail address is necessary for receiving RequisitePro discussion messages
via e-mail. For more information, see Configuring E-mail for Discussions on page 73.

1 Open a project and log on. The RequisitePro Tool Palette appears.

2 C(lick Project > Security.
The Project Security dialog box appears.

3 Click the Enable security for this project check box. Select a user group and a user
name, and click the Edit button.

The Edit User dialog box appears.

Edit Uzer

Usemame:

New Pazsvord: |

Werify: |

E-Mail dddress: |

QK I Cancel | Help

To change your password:

1 Type your password in the Old Password text box that appears in the dialog box.
(This step applies only to users who do not have project security permissions.)

2 Type your new password in the New Password text box. Passwords are case
sensitive and limited to 14 alphanumeric characters.

3 Confirm the new password by typing it again in the Verify text box.

4 Click OK. Your new password is in place and ready for use.
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To change your user name (for users with project security permissions):
1 Select your current name in the Username field.

2 Type a new user name. User names are limited to 20 alphanumeric characters and
are not case sensitive.

3 Click OK. Your new name is in place and ready for use.
To change your e-mail address:

1 Select your current e-mail address in the E-mail field.

2 Type a new e-mail address.

3 Click OK. Your e-mail address is in place and ready for use.
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Working in Views

Rational RequisitePro views use tables or outline trees to display requirements and
their attributes or the traceability relationships between different requirement types.
RequisitePro includes powerful query functions for filtering and sorting the
requirements and their attributes in views.

The Views Workplace is an environment for analyzing and printing requirements,
whether or not they reside in documents. You can have multiple views open at one
time. The Views Workplace provides scroll bars to view all requirements and
attributes in the table or tree. The number of requirements in the current view appears
in the lower right corner of the views window.

You can create three kinds of views in the Views Workplace:

= The Attribute Matrix view displays all requirements and their attributes within a
specified type.

» The Traceability Matrix view displays the relationships between requirements of
two types.

= The Traceability Tree view displays the chain of traceability through the project
requirements. A Traceability Tree can be set up in one of two directions: traced out
of requirements of a specified type or traced into requirements of a specified type.

In the Views Workplace, you can do the following:

* Create and modify the requirement name, requirement text, requirement
attributes, and traceability relationships

= Sort and filter view information
= Save a view’s query and display setup
= Save view information to other formats

=  Print views
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Accessing Functions and Navigating in Views

All Views Workplace commands are located in the menu bar at the top of the Views
Workplace. Unless stated otherwise, this manual refers to the commands in the Views
Workplace when working with views.

To navigate in a view quickly, use the arrow keys, the PAGE UP or PAGE DOWN keys,
and the HOME and END keys. Use the right button on the mouse as a shortcut to
commands that are specific to requirements and attributes. Move the mouse over the
requirements and attribute labels and click the right button to access these shortcut
menus. For more information, refer to Mouse Actions and Shortcuts in the Views
Workplace on page 276.

The full name and text of the selected requirement are displayed in the text pane at
the bottom of the view. To resize a text pane, position the mouse on the upper border
and drag upward.

Viewing Current Data

While a view is open, other users may add, delete, or modify requirements that are
displayed in your view. These changes are not automatically reflected in your open
view.

To update the data displayed in the view for requirements that were modified by
EI; other users, click View > Refresh All (or the Refresh button) in the Views Workplace.
E| The Refresh All command affects all open views and automatically updates the data in
each view.

The View > Query Now command in the Views Workplace reruns a view’s query
criteria against the database and updates your requirement set. (For more information
on queries, refer to the chapter Querying and Searching on page 61.) Requirements that
have been deleted or no longer match the query are removed from the view. New
requirements that match the query are added to the view. Query Now does not refresh
the text and attributes for requirements that are already in your view.

If there are many requirements in the database, the Refresh All command may take
time to complete. If you simply want to see a fresh requirement set and do not want to
update the text and attributes for each requirement, use Query Now.
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Traceability in the Views Workplace

The Traceability Matrix and Traceability Tree views display traceability relationships,
and the Traced-to or Traced-from attributes appear in the Attribute Matrix. A
traceability relationship is displayed as suspect when you make a change to a
requirement. For more information about traceability relationships between
requirements, refer to the chapter Working with Traceability on page 153.

Arrows are used to indicate direct traceability relationships in the Traceability
Matrix and Traceability Tree views. If the arrow points from A to B, then the
following two statements are true: A is traced to B and B is traced from A.

In the Traceability Tree and Traceability Matrix views, suspect traceability E!
relationships are marked as lines through the arrows. In an Attribute Matrix,
suspect relationships are denoted by an (s) after the requirement tag in the
Traced-to or Traced-from column.

A requirements relationship is indirect if the relationship is derived by traversing
the requirements relationships. An arrow outlined by a dotted line, lighter in color
than a direct relationship arrow, indicates an indirect traceability relationship in
the Traceability Tree and the Traceability Matrix.

Hierarchy in the Views Workplace

All views display hierarchical relationships, and you can use the Traceability Matrix
and Traceability Tree to display hierarchical relationships that are marked suspect.
For more information about hierarchical relationships between requirements, refer to
the chapter Working with Hierarchy on page 143.

You can create hierarchical relationships in the Views Workplace by using
Requirement menu commands or editing the requirement properties in the
Hierarchy tab of the Requirement Properties dialog box.

When you modify a parent requirement, RequisitePro marks the relationships
between the parent and all its immediate children as suspect.

When you modify a child requirement, the relationship with its parent is not
marked as suspect.

When a child requirement is assigned to a new parent, all hierarchical
relationships between the new parent and its immediate children are
automatically marked as suspect. The relationships between the children and their
children are not marked as suspect.
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» In the Traceability Tree, you can manually mark a hierarchical relationship as
suspect or clear a suspect relationship.

The Attribute Matrix

The Attribute Matrix displays requirements and their attributes for a specific
requirement type. Requirements are arranged in rows and listed by tag number.
Attributes are arranged in columns. The Attribute Matrix displays all requirements,
but only database requirements can be created in this view.
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In an Attribute Matrix, a requirement is displayed in a single row, showing the
requirement tag followed by the requirement name (or requirement text if the
requirement has not been assigned a name). When requirement text exceeds the
width of the row, the last character is followed by an ellipsis (...), signifying the
presence of additional text. An arrow marker at the beginning of a row indicates a
selected row.

An * and <Click here to create a requirement> marks the beginning of the empty row at
the bottom of the matrix, where you can insert a new requirement. A pencil icon at the
beginning of a row indicates that the requirement information you are entering has
not yet been saved.

To change the number of lines of requirement name and/or requirement text
displayed, click View > Row/Column Sizing, and then select a different value for the
row or column size.
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Attributes

Attribute labels are listed at the top of each column. Corresponding attribute values
are listed beneath the attribute labels. Query information is displayed here as well.

If there are suspect traceability relationships, an (s) appears after the requirement tag
in the Traced-to or Traced-from column. You can change the size of the attribute
columns.

Text Pane

The text pane, located at the bottom of the Attribute Matrix, displays a requirement's
tag, name, and text. This field is read-only. The text pane is blank when a requirement
is not selected, and it reads “Multiple requirements selected” if you have selected
more than one requirement. Graphics and OLE objects included in requirement text
are displayed as small rectangular symbols. For Word-linked files included in the
requirement text, the path and time stamp of the linked file are presented. The default
size of the text pane is two lines, but you can drag the border to increase the size.

The Traceability Matrix

The Traceability Matrix displays and manipulates the relationships between two
requirement types. The requirements can be of the same type or of different types.
Use this view to create, modify, and delete traceability relationships and to view
indirect relationships. The Traceability Matrix also shows traceability relationships
that are marked as suspect. If you display a Traceability Matrix of requirements of the
same type, it shows hierarchical relationships that are marked as suspect.

In this view, a requirement is traced to or traced from another requirement. For
example, requirement B is traced from requirement A if it was directly or indirectly
derived from requirement A. If requirement A is the basis of several other
requirements, requirement A is traced to these requirements.

An arrow pointing from one requirement to another indicates that a direct traceability
relationship exists between the requirements. A dotted line arrow indicates an
indirect relationship.

Rows and columns can be resized. The intersection of a row and column is called a
cell.
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To change the number of lines of requirement name and/or requirement text
displayed, click View > Row/Column Sizing and then select a different value for the row
or column size.

Note: If the requirement has a name assigned, that name appears in the first line of
each row or column. Increase the row or column size to view both the name and text.

Cells
» If the cell is blank, no relationship exists.
» Ifan arrow points upward to a column requirement, the row é}
requirement is traced to the column requirement. Traced to arrow
= If an arrow points down toward a row requirement, the column
requirement is traced from the row requirement. Traced from arrow
» Ifadotted line arrow is displayed, an indirect relationship exists. Ei;{é.irect relationship
» Ifan arrow with a red diagonal line through it is displayed, the m
traceability relationship is suspect. Suspect relationship
= If a triangle with a red diagonal line through it is displayed, the
hierarchical relationship is suspect. Suspect relationship
Text Panes

The Traceability Matrix displays two text panes at the bottom of the window. These
panes let you review the requirements in each area, so you can easily create, modify,
and delete traceability relationships. The default size of each pane is set to one line
and can be resized. The top text pane displays the name (or text) of the currently
selected row requirement, and the bottom pane displays the name (or text) of the
currently selected column requirement. These fields are read-only. If the selected
requirement has been assigned a name, that name appears in the text pane.
Otherwise, the requirement text appears in the text pane. When more than one row or
column is selected, the corresponding text pane displays the message “Multiple
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requirements selected.” Graphics and OLE objects included in requirement text
appear as small rectangular symbols. For Word-linked files included in requirement
text, the path and time stamp of the linked file are presented.
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The Traceability Tree

The Traceability Tree provides a graphical view of relationships to or from
requirements of one specific requirement type, including direct, indirect, and suspect
traceability relationships. Although direct and suspect relationships are modified in
this view, RequisitePro permits read-only access to indirect relationships.

In addition, the Traceability Tree displays hierarchical relationships and shows
parent-child relationships that have been marked as suspect.
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The tag, name, and attributes of the selected requirement are displayed in the
attribute pane.
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When creating a Traceability Tree, you can choose one that displays all requirements
traced to the requirements on which the tree is based or one that shows all
requirements traced from the requirements on which the tree is based.

Tree Pane
Select a specific requirement type on which to base the view. Traceability
(N 2 sp ! . .
relationships for root-level requirements are indented and preceded by an arrow.
B Child requirements are indented below their parents and preceded by a triangle. The
pane on the right side of the view displays requirement attributes.

Note: To resize the tree pane, click the border between the tree and attribute panes.
Press the left button on the mouse and drag it left or right to the size you want. This
does not affect the length of the lines set in the Row/Column Sizing dialog box.

If the arrow leading from a root requirement points toward a branch
requirement, the branch requirement is traced from the root requirement. (This
appears only in a Traced out of Traceability Tree.)

If the arrow leading from a branch requirement points toward a root
requirement, the branch requirement is traced to the root requirement. (This
appears only in a Traced into Traceability Tree.)

If an arrow with a red diagonal line is displayed, the traceability relationship is
suspect.
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If a triangle with a red diagonal line is displayed, the hierarchical relationship is
suspect.

Attribute Pane

The attribute pane, located on the right side of the Traceability Tree, displays the tag,
name, and attributes associated with the currently selected requirement. To display
the attributes of a particular requirement, click the requirement in the tree pane. This
is a read-only text box and cannot be edited.

If you have more than one requirement selected, the pane displays the attributes for
the first requirement selected.

Text Pane

The text pane, located in the lower section of the Traceability Tree, displays a
requirement's name and text. This field is read-only. To display the full name and text
of a particular requirement, click the requirement in the tree pane. To adjust the
height of the pane, click its upper border and drag the pane to the size you want.

The text pane is blank when a requirement is not selected. When more than one
requirement is selected, the text pane displays the message “Multiple requirements
selected.” Graphics and OLE objects included in requirement text appear as small
rectangular symbols. For Word-linked files included in requirement text, the path and
time stamp of the linked file are presented.

Working with Views

This section presents the fundamentals of working in the Views Workplace:
* Creating a view

» Expanding and collapsing in the Views Workplace

= Saving a view

* Opening a saved view

» Closing a view

* Renaming a view

* Duplicating a view

* Printing a view

= Deleting a view
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Creating a View

E 1 On the Tool Palette, click Window > Show Views (or the Show the Views Workplace
button). The Views Workplace opens.

D 2 In the Views Workplace, click File > New View (or the Create a new view button).
= The New View dialog box appears.

Newview x|

—iew Type:
% Attribute Matriz " Traceahility Tree [Traced out of...]
" Traceability Matrix " Traceability Tree [Traced inta...]
Fow Requirement Tupe: Eolumm Beguirement Type;:
FEAT: Feature Requirement Type FEAT: Feature Requirement Type
SUPP: Supplementary Requirement Type SUPP: Supplementary Requirement Tupe

Requirement Type TERM: Glozzary Requirement Type
Reguirement Tupe IJC: Use Casze Requirement Type

(| I K | »

(1[4 | Cancel | Help

3 Select a view type to display.

4 Select a requirement type to display in the view. Note that the Traceability Matrix
displays two requirement types (one type for the row and another for the column),
the Attribute Matrix displays a single requirement type, and the Traceability Tree
displays a single requirement type at the root level. Only requirements associated
with the selected requirement types appear in the view.

5 Click OK. The view is displayed.

Expanding and Collapsing in the Views Workplace

The Expand All and Collapse All commands on the View menu are used to expand
and collapse hierarchical relationships in all views and traceability relationships in
the Traceability Tree. An expanded view shows the root requirement and all its
sub-level requirements. Collapse the view to show just the root level requirements.
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The Expand All command expands all relationships in a view. When you select this
command in a Traceability Tree, a requirement that has a traceability relationship
with a root requirement appears as a branch of the root requirement. This command
also expands all parent requirements, displaying all children, in all views.

The Collapse All command collapses all relationships in a view. When you select this
command in a Traceability Tree, a requirement that has a traceability relationship
with a root requirement is no longer displayed. This command also collapses all
parent requirements, hiding all children, in all views.

To expand the Traceability Tree or hierarchical relationships:
» (Click the View menu and select Expand All.
To collapse the Traceability Tree or hierarchical relationships:

» (lick the View menu and select Collapse All.

Saving a View

When you save a view, the layout of the view and the query criteria are also saved.
The data within the view is not saved as part of the view; it is part of the database.
Thus, when you open a saved view, current information is displayed in a saved view
format.

Note: The saved view is not a snapshot of requirement information for a particular
date. To save the results of a query, you must print the view. For more information on
queries, refer to the chapter Querying and Searching on page 61.

To save a view, make sure it is active in the Views Workplace. To make an open view
active and display the view in the active color, click the title bar of the view or select it
from the Windows menu.
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To save a view:

E I 1 In the Views Workplace, click File > Save View As (or the Save the current view
button). The Save View As dialog box appears.

Save Yiew As

Mame: |Use Cazez Sorted by Stability

— Previously S aved Yiews:
" Project-wide
Attribute M atrix Views:

Traceability b atriz Wiews:
Traceability Tree Views:

Authar: |

|
pee || tme |
Ok I Eancell Help |

2 Click the Name text box and type a name of up to 64 characters.

3 Make the view available to all users (Project-wide availability) or for your own
use (Personal) by selecting the corresponding button.

Note: Only the author or a member of the Administrators group can modify
project-wide views.

RequisitePro populates the following fields, and they cannot be edited:

2 The Author text box, which displays the name of the RequisitePro user who
saved the view.

2 The Date text box, which displays the date the view was saved.
2 The Time text box, which displays the time the view was saved.
4 Click OK to save the view.

RequisitePro organizes views by view type in the Previously Saved Views list box in
the Open View dialog box. When a view is saved, it is added to this list.
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Opening a Saved View
To display a saved project-wide or personal view:
1 In the Views Workplace, click File > Open View (or the Open a previously saved
- I view button).
= The Open View dialog box appears.

Open Yiew x|

— Previouzly 5 aved Wiews:
s Project-wide = Personal

Abtribute M atniz Wiews:
FEAT: all Features
SUPF: All Supplemental Requirements
UC: All Use Cazes
Traceability b atriz Wisws:
UC-FEAT: Uze Cazes Traced to Features
Traceability Tree Yiews:
FEAT: Requirements Traced to Features

Author: | |

pas || omme [ ]
[k I Cancel I Help I

2 Choose a project-wide or personal view by marking the corresponding button. A
list of saved views appears.

3 Select the desired view from the list. The author, date of creation, and time of
creation appear below the list.

Note: You can select more than one view to open by using CTRL-click or
SHIFT-click.

4 Click OK. RequisitePro displays the selected view(s).

Closing a View
1 Inthe Views Workplace, click File > Close View.

Note: If the Prompt for save option is activated (in other words, the check box is
selected in the Tools > Options dialog box) and you have changed any of the view’s
properties, a dialog box appears asking if you want to save the view. Click Yes or
No.

2 RequisitePro closes the view.
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Renaming a View

Renaming can be used to change the name of an open view window. You might want
to give a view a longer, descriptive name before you print it, so that the new name
appears on the printed page. You can still retain the original name in the file system.
Renaming a view does not save the renamed view to the database until the view is
saved again.

1 In the Views Workplace, click View > Rename.
The Rename View dialog box appears.

Rename Yiew

LEENT=A T raceability Tresl

QK I Cancel |

2 Type a new name for the view in the Name text box and click OK.

Note: Use the Save option on the File menu to save the renamed view.

Duplicating a View

Duplicating a view opens another window with the same view properties as the
active window. This is especially useful for creating copies of the view with different
sorting and filter options.

To duplicate a view:
» (lick View > Duplicate.

RequisitePro renames the view with the suffix 2 (for example, “Product Requirement
Description View2”).

Printing a View

In the Views Workplace, you can print any active view. When you print a view, you
can choose to print the entire matrix or selected items.

To print an open view:

1 If you want to print only a selected requirement or relationship, click the
requirement(s) or relationship(s) in the matrix. (Use a multiple select action to
select multiple requirements or relationships.)

2 Click File > Print. The Print dialog box appears.
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3 If you are printing selected requirements or relationships, click Selection.
4 Make any other necessary changes to the Print dialog box, and then click OK.

% Note: Use the Print button on the Views Workplace toolbar to print directly to the
default printer. The entire view is printed using the default printer selections.
You can also export a view to a comma separated value (CSV) file and use another
application, such as Excel, to open the file and arrange the data for printing. See
Exporting a View as a CSV File on page 179 for more information.

Deleting a View

A personal view can be deleted only by the person who created it. A project-wide
view can be deleted by the person who created it or by a member of the
Administrators Group.

To delete a view:

1 Click File > Delete View. The Delete View dialog box appears.

Delete View x|

— Prexviouzlp Saved Yiews:
1+ Project-wide " Perzonal

Attribute b atriv Wiews:
FEAT: All Features
SUPP: all Supplemental Requirements
UC: Al Uge Cazses
Traceability b atris Wiewes:
UC-FEAT: Use Cazes Traced to Features
Traceability Tree Wiews:
FEAT: Requirements Traced ta Features

Athor: | |

e B e B

] | Cancel | Help |

2 Choose a project-wide or personal view to delete by clicking the corresponding
button. A list of saved views appears.

3 Select the view you want to delete from the list. The author, date of creation, and
time of creation appear below the list.

Note: You can select more than one view to delete by using CTRL-click or
SHIFT-click.

4 Click OK. RequisitePro deletes the selected view(s).
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Customizing Views

Customizing a view defines its look and content. You can:
» Adjust the size of rows and columns
» Filter and sort data according to query criteria

» Select specific view properties to display, such as buttons, requirement name and
text, lines, images, root images, and trace to and trace from buttons

After a view has been defined, it can be saved for future use. Saving a view saves the
view properties that were customized. When a saved view is opened, it appears in the
state in which it was saved.

Adjusting Row Height
Adjusting row height affects all rows in the view.

1 Click View > Row/Column Sizing.
The Row/Column Sizing dialog box appears.

Row/Column 5izing E3 |
MNew Height: [1-41 lines] I

Mew Wwidth: [15-512 pixels] ISEI?

ak I Cancel |

2 Type the number of lines to display for each requirement. The maximum number
of lines depends on a monitor’s display resolution.

3 Click OK. The view is modified according to your specifications.

Shortcut: Click and hold the mouse on any border in the requirement area, and
then drag the row up or down to the size you want. If the row height is already set
at one line, RequisitePro will not let you drag the row up to less than one line. The
Traceability Tree does not have a shortcut.

56 Chapter 4 - Working in Views



Adjusting Column Width

1

Click View > Row/Column Sizing.
The Row /Column Sizing dialog box appears, as shown above.

Type the number of pixels (in the Attribute Matrix) or lines (in the Traceability
Matrix) to display for each requirement or attribute. Parameters for column widths
in different views follow.

Q

Attribute Matrix: To set a different width for each column, drag the column to
the desired width. To set an equal width for all columns, use the View menu,
Row /Column Sizing dialog. The maximum screen height is based on your
screen’s resolution.

Traceability Matrix: RequisitePro determines the maximum width on the basis
of screen resolution.

Traceability Tree: The column width is represented by the amount of indentation
or each branch. RequisitePro dynamically changes the maximum number of
pixels allowed in these columns according to the width of the requirement
pane and the size of the view. Any change to the column width affects all of the
columns in this view.

Click OK to commit these changes.

Shortcut: Click and hold the mouse on any border in the attribute label area or the
requirement area (the gray area at the top of each column) in an Attribute or
Traceability Matrix. Drag the width left or right to the size you want. The
Traceability Tree does not have a shortcut.

Resizing and Arranging Views

Use the menu commands or the buttons on the toolbar in the Views Workplace to
define the size and arrange the order of a view.

Creating Cascaded Views

The cascaded views feature overlaps views. Each view is displayed to the right and
slightly below the preceding view. If many views are open, RequisitePro may overlap
the first cascade of views with a second cascade until all open views are arranged.
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Click Window > Cascade. RequisitePro cascades the views.
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Creating Tiled Views

A tiled view arranges open views next to each other without overlap. To tile the
views, click Window > Tile. RequisitePro presents a tiled view, as shown in the

following screen shot.
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Arranging Icons

Icons for all minimized views can be arranged from left to right, beginning at the
bottom left corner of the Views Workplace. To arrange the minimized views, click
Window > Arrange Icons.

Displaying View Properties

Use the Properties command to display properties associated with an active view.
Each view displays distinct properties. These properties affect how the view appears
and not the information contained therein.

Click View > Properties. Click the following properties to display them in the view. If
they are checked off on the menu, they appear in the active view.

Attribute Matrix:

Q

Show Buttons displays a button to the left of requirements and any hierarchical
relationships. The button is used to expand or collapse the requirement.

Show Discussions displays a red triangle to the right of the requirement text,
indicating there are one or more discussions associated with a requirement.

Show Name displays the requirement name. You can define the number of lines
displayed using the View > Row/Column Sizing command.

Show Text displays the requirement text. You can define the number of lines
displayed using the View > Row/Column Sizing command.

Traceability Tree:

Q

Show Buttons displays a button to the left of requirements and any traceability
and hierarchical relationships. The button is used to expand or collapse the
requirement.

Show Discussions displays an icon indicating that one or more discussions are
associated with a requirement.

Show Lines displays lines in the Traceability Tree that connect relationships.
Show Images displays traceability relationships with arrows.

Show Root Images displays an arrow at the root of hierarchical requirements.
Show Name displays the requirement name.

Show Text displays the first line of the requirement text.
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s Show Trace To or Show Trace From displays arrows in the direction of either
trace to or trace from relationships, depending on your selection.

Traceability Matrix:

2 Show Buttons displays a small box or button to the left of requirements with
children.

2 Show Discussions displays an icon indicating that one or more discussions are
associated with a requirement.

2 Show Expand Indicators displays a + in the cell if the child requirements of a
collapsed requirement contains traceability relationships.

2 Show Name displays the requirement name. You can define the number of lines
displayed using the View > Row/Column Sizing command.

s Show Text displays the first line of the requirement text. You can define the
number of lines displayed using the View > Row/Column Sizing command.

2 Show Trace To or Show Trace From displays arrows in the direction of either
trace to or trace from relationships, depending on your selection.

2 Show Indirect displays both direct and indirect traceability relationships.

Saving View Properties as Default

The Save As Default command saves a view layout and any properties displayed as
the default when opening views of that type. This command is available for all view
types. To save a view and its displayed properties as the default for views of that type,
click View > Properties > Save As Default. RequisitePro saves the view, layout, and
properties for views of that type.

Note: Use the Reset Default command to reset any view properties that have been
changed back to the saved default settings.
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Querying and Searching

Creating and Using Queried Views

After you have created a view, you can save it as is, or you can refine the view by
querying (filtering and sorting) its information in a variety of ways.

You can filter requirements in views by limiting the values of one or more attributes
or by limiting traceability. You can query requirements displayed in rows in an
Attribute Matrix or Traceability Matrix, columns in a Traceability Matrix, or root
requirements in a Traceability Tree.

Querying Overview

Filtering restricts the information being displayed, and sorting determines the order

in which the information is displayed. For example, in an Attribute Matrix, you may
want to order requirements information from highest to lowest priority (sort criteria)
and view only those requirements assigned to you (filter criteria).

You can filter and sort requirements by applying query criteria to the attributes. This
criteria limits the values of the attributes and the traceability relationships. You can
create an attribute-by-attribute query, so that you can see the results of each query
criteria, or you can create a query that filters and sorts all at once for several attributes.

You cannot query hierarchical requirement relationships that are suspect. Parent
requirements are automatically grouped with child requirements in unsorted and
unfiltered views.

Rational RequisitePro does not automatically update queries. You can update a query
by clicking either View > Refresh All or View > Query Now.

Note: When you query requirements across cross-project traceability relationships,
note that queries related to user and document information include data from the
current project only. Data from external projects is included in queries on system
attributes such as requirement text, revision number, and revision date, but not on
user or document information. You must open the external project to query on those
criteria.
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In an Attribute Matrix, cross-project traceability queries are only supported between
projects of the same enterprise database type. To query between SQL Server projects,
the projects must reside in the same schema.

Filtering

Filtering data is a process by which you can limit the amount of information
displayed in a view in the Views Workplace. You can specify the criteria for filtering
the information. You can filter requirements by specifying distinct criteria for any or
all of their attributes. For example, instead of displaying all requirements, you might
apply a filter so that only requirements having a high priority are displayed.

Sorting

By default, the sort order in a view is ascending by requirement tag. When you create
a query that includes multiple query criteria, you can sort the criteria to determine the
order in which the requirements are displayed in a view. You can also modify the sort
order after you have created a query. For example, you might sort requirements by
priority (high to low). Then, within priority, you might sort by date.

Working with Queries
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Use the Query command to extract data from the database and present it for use in
any of the three views. You can save, open, edit, print, and export queried views.

Queried views range from simple to complex. When you query most attributes in a
view, choose one requirement type at a time. If you base a query on the Trace to or
Trace from attributes, you have the ability to select more than one requirement type
for targets.

You can control the query. To ensure that information in a queried view is current,
especially if other users are working in the database being queried, refresh the
database with new data (click View > Refresh All), and then reapply the query criteria.

= By default, the Attribute Matrix view displays all attributes for any requirement
type and all requirements of that type. You can display only the most necessary
attributes when querying this view.

» The Traceability Matrix view displays two requirement types and the
interrelationships between them.

Note: When an Attribute Matrix view or a Traceability Matrix view is queried, a filter
or a sort is applied to the row or column requirements in the view.
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» The Traceability Tree view displays all requirements of one type (root) and all
requirements related to/from them.

Note: When a Traceability Tree view is queried, the filter and sort criteria are applied
to the root requirements in the view.

Creating Queries

1 In the Views Workplace, open an Attribute Matrix, Traceability Matrix, or
Traceability Tree view. (For more information on views, refer to the chapter
Working in Views on page -41.)

2 Click the View menu in the Views Workplace.
The command displayed in the View menu depends on the active view:

s To query row requirements in an Attribute or Traceability Matrix, select Query
Row Requirements.

s To query column requirements in a Traceability Matrix, select Query Column
Requirements.

» To query the root requirements in a Traceability Tree view, select Query Root
Requirements.

The Select Attribute dialog box appears.

Select Attribute E

Bequirement Types:
I FR:Product Requirement Type j

to Filker/S ort Requirements:

Location LI

QK I Eancell Help |

Note: The list includes the requirement attributes you have created and the system
attributes created by default in RequisitePro.

3 Select the attribute that you want to use to query, and click OK.

The Query Requirements dialog box appears. Depending on the type of attribute
you selected (list-type or entry-type), the box contains a specific set of criteria for
you to define.
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4 For list-type attributes, select one or more values; for entry-type attributes, mark
an option (that is, includes, equal to) and type in the value.

Tip: When querying on a date, enter the date in the same format as specified for
your computer under Regional Settings in your Microsoft Windows Control Panel.

5 Enter a Sort Order: None, Ascending, or Descending.

Note: To temporarily sort attribute values in ascending or descending order in an
Attribute Matrix, you can right-click on the attribute label and select Sort Ascending
or Sort Descending on the shortcut menu. This sorting does not change an existing
filter, and the sort order will be reset if you create or modify a query.

6 Enter When Traced criteria, if applicable. The When Traced option is only available
when trace to or trace from attributes are queried. For hierarchical requirements,
traceability queries automatically include the parent if the child participates in a
traceability relationship. (You cannot query for suspect hierarchical relationships.)

Note: You cannot create a traceability query between two external requirements.

7 Click OK. The Query [Row/Column/Root] Requirements dialog box reappears.
8 To add other query criteria, click Add and repeat Steps 3 through 7.

Note: The logical operator and is assumed between multiple attributes.

9 Select the Retain Hierarchical Display check box to include the parents of child
requirements that match the filter criteria, even though the parents do not match.

Note: The query engine ignores hierarchical relationships, unless you select the Retain
hierarchical display check box. (For more information on parent-child requirements,
refer to Working with Hierarchy on page -143.)

10 When the query is built, click OK in the dialog box. RequisitePro updates the view
with the query results.

Note: To run the query again, click the View menu and click Query Now. (For more
information on Query Now, refer to Viewing Current Data on page 42.)

Modifying Queries

After you have created a query, you can make changes to the query criteria. With the
view open, do the following;:

1 To open the Query [Row/Column/Root] Requirements dialog box (depending on
your displayed view), click the View menu and choose Query Row Requirements,
Query Column Requirements, or Query Root Requirements.

2 Select the query criteria you want to modify and click Modify.
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3 The Query Requirements dialog box appears. (The dialog box that appears
depends on whether the attribute is a list-type or entry-type.) Follow Steps 4-10 in
the preceding section.

Deleting Queries

1 In the Views Workplace, click the View menu and choose Query Row Requirements,
Query Column Requirements, or Query Root Requirements.
The Query [Row /Column/Root] Requirements dialog box appears (depending on
your displayed view).

2 In the Query Criteria list, select the query criteria you want to delete.

Note: The order of this list determines the order in which RequisitePro filters and
sorts the criteria. Be aware that deleting a query from the list may affect the results
of subsequent queries.

3 Click Remove. Click OK to close the dialog box.

Searching for Requirements in Documents and Views

RequisitePro provides two methods for finding requirements:

* The Go To command launches a global search of the database, quickly finds a
requirement, and displays it in its location (document or view).

* The Find Requirement command launches a search for a requirement in the active
view or document.

Navigating to a Requirement Using the Go To Command

You can use the Go To command in the Views Workplace to find a requirement
location in a project. Using that command in an open document enables you to jump
quickly to a requirement in the document.

Navigating to a Requirement from the Views Workplace
1 In a matrix in the Views Workplace, select a requirement.
2 C(Click Requirement > Go To.

If the requirement is located in a document, the document containing the requirement
opens, with the requirement selected. Otherwise, the Requirement Properties dialog
box appears, showing the name, text, attribute values, relationships, and discussions
for the selected requirement.
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Navigating to a Requirement from the Word Workplace
1 Do one of the following:
2 On the Tool Palette, click Requirement > Go To.
s In the Word Workplace, click RequisitePro > Requirement > Go To.
The Go To Requirement dialog box appears.

~ Display:

Fequirements [rypmpe———"
of type: el

Located it [Database only |

PR32: This is a new requirement for the database. =

|
O | cencel | Eed. | | Hep |

2 Select the requirement type from the Requirements of Type list box. If you do not
know the requirement type, select All Requirement Types.

3 Select the location of the requirement from the drop-down list in the Located in list
box. Choose All locations, Database only, or a specific document from the list.

Note: Click the Find button to open the Find Requirement dialog box, which you can
use to locate a specific tag number, requirement name, or text.

4 Select the requirement and click OK. RequisitePro performs one of the following
operations:

2 If the requirement is in an unopened document, RequisitePro opens the
document and highlights the requirement.

s If the requirement is in an open document, the Word Workplace appears with
the document active and the requirement highlighted.

2 If the requirement is not located in a document, the Requirement Properties
dialog box appears so you can examine or modify the requirement name, text,
attribute values, or traceability relationships.
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Using the Find Requirement Command to Search a Document or View

The Find Requirement dialog box helps you find a requirement based on requirement
name, text, or tag. The dialog box appears when you click Find in one of the following
locations:

Tool Palette Requirement menu

Word Workplace RequisitePro > Requirement menu
Views Workplace Requirement menu

Views Workplace Find button

Go To Requirement dialog box

Parent Requirement Browser dialog box

Select Requirements dialog box

The procedure for using the Find Requirement dialog box is the same, irrespective of
how you access the dialog box.

1

Find Requirement
Text search: -
|requirement ™ Match case Direction

I Use ® az wildcard CUp
EndNes] _Cose | Heb | oifiaupaiswardsaniy © Down

In the Text search text box, enter the text to use to search for the requirement name,
text, or tag.

Select the Match case check box if you want to search only for requirements with
an exact capitalization match.

For example, if you select this check box and enter the text menu, RequisitePro will
find requirements containing “menu” but not requirements containing “Menu.”

Select the Use * as wildcard check box to search for requirements using the
wildcard character * (asterisk) to match one or more characters in the search text.
For example, if you select this check box and enter the text *document*,
RequisitePro finds requirements containing “document,” “documents,”
“documented,” “undocumented,” and so on.
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4 Select the Find whole words only check box if you want to search only for a whole
word entered in the search text.
For example, if you select this check box and enter the text menu, RequisitePro
finds requirements containing “menu,” but not requirements containing “menus.”
This check box is disabled if more than one word is entered in the text search.

5 Do one of the following:
s Click Up to search from the cursor backward through the document.
2 Click Down to search from the cursor forward through the document.
6 Click Find Next to search for the next requirement satisfying the search criteria.

Note: In a view in the Views Workplace, all children of a parent requirement are
searched, regardless of whether or not the children are currently displayed in the
view. If RequisitePro finds a child requirement that matches the search criteria but is
collapsed, the view is expanded so that the requirement is displayed.

= If the requirement is found, RequisitePro highlights the requirement and displays
it in context.

= If the search is performed in a view and all requirements in the view are not
expanded, RequisitePro expands the requirements in the view to display the
results of the search.

» If the requirement is not found, RequisitePro returns to the requirement from
which the search began.

Shortcuts from a View to a Requirement in a Document

When you are working in the Views Workplace, you can switch to the Word
Workplace to view a requirement within a document.

In the Views Workplace, highlight the requirement to display and do one of the
following:

» Press the right button on the mouse and choose Go To from the shortcut menu that
appears.

= Double-click the requirement.

Note: This shortcut works only if the default Double-click to go to document option is
marked in the Tools > Options dialog box.

RequisitePro opens the Word Workplace and highlights the requirement in the
document.
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Reviewing a Project with Cross-Project Traceability

Sometimes, when you open a project, RequisitePro connects to an external project and
displays both projects. In this case, the projects have been connected to one another,
and cross-project traceability relationships may exist. You can review the
requirements in both projects and their change-managed relationships in the Views
Workplace.

Cross-project traceability creates traceability relationships between requirements that
reside in different projects. This feature establishes connectivity among projects that
were divided into subprojects or projects that relate to each other or share a set of
requirements. (For more information on cross-project traceability, see Setting Up and
Modifying Cross-Project Traceability on page 244.)

Results of Cross-Project Traceability
When cross-project traceability relationships are established, the following can occur:
» External requirement types can be queried for display in views.

» If a requirement that is traced to requirements in other projects is deleted,
RequisitePro updates the other projects to reflect the change. If the traceability
relationship in the external project cannot be deleted, the relationship is updated
when connectivity is established between the projects.

» If a requirement modification causes the relationship to become suspect, and the
requirement is traced to or traced from requirements in other projects, RequisitePro
updates the projects to reflect the suspect link. If the traceability relationship in the
external project cannot be modified, the relationship is updated when connectivity
is established between the projects.

» Ifalink between an internal and external requirement is marked as suspect,
cleared as suspect, or created or removed by the user, RequisitePro updates both
the internal and external projects to reflect the change.

* RequisitePro checks for circularity when external relationships are created. The
circular check references internal requirements and first-level external
requirements.

Displaying External Requirements

Requirements in the current project are distinguished from requirements in external
projects by the project prefix. External requirements appear as follows:
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» The Traceability tab in the Requirement Properties dialog box displays only the
relationships that are related to the current project. The General tab displays
external requirement information as read-only.

* The Find Requirement dialog box displays a list of requirement types for the
current project and each externally mapped project.

» The New View dialog box displays requirement types from the current project and
any external projects. If the Attribute Matrix view is selected, only the internal
requirement types are available for selection. A full Attribute Matrix view of
external requirements is not provided because of performance considerations.

» The Attribute Matrix displays all internal and external traceability relationships in
the Trace-to and Trace-from columns.

» The Traceability Matrix displays all internally and externally mapped
requirements of a single requirement type in the rows and columns.

= The Traceability Tree displays all internal and external requirements traced to or
traced from a requirement. The first cross-project traceability level is displayed. So,
if an internal requirement is traced to an external requirement, the external
requirement is displayed in the tree. Other requirements to which the external
requirement traces do not appear.

Displaying Requirement Relationships in Exported Views
Requirements in exported views with cross-project traceability appear as follows:

» Anexported CSV file indicates that a traced to/from requirement exists as
displayed in the view.

* An exported Microsoft Word file indicates a traced to/from requirement exists as
displayed in the view.

For more information on exported views, refer to Exporting Requirements on page 178.

RequisitePro Extensibility Interface

For advanced querying capabilities, the RequisitePro Extensibility Interface provides
a fully documented COM-based application programming interface, giving
customers and third-party solution providers direct access to the requirement data.
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The Extensibility Interface includes complete documentation for the RequisitePro
Query Engine and the associated query language syntax. The Query Engine provides
a programmatic interface and uses objects to retrieve RequisitePro project data for
requirements and discussions. You can optimize queries to load only necessary
information, enhancing the performance of your application.

Launch the documentation for the RequisitePro Extensibility Interface by clicking
Help > Extensibility Interface Reference.

Requirement Metrics

Requirement Metrics provides RequisitePro project administrators and product
analysts with the capability of reporting statistics on requirement names, text,
attributes, relationships, and revisions. These report results are displayed in Microsoft
Excel and can be manipulated using Excel’s charting capabilities.

You begin by creating one or more filters. A filter creates criteria for retrieving
requirement information. For example, you would use an Attribute Count Filter to
determine how many requirements in the project have a priority with the value
“High.” You then combine one or more filters to produce a query. A query combines
the criteria from multiple filters to analyze requirements. The filters that compose a
query are joined with the AND statement. Finally, you combine one or more queries
to produce a report.

There are two types of reports that are available in Requirement Metrics:

» A static report uses static filters and shows results about the project at the present
time.

= A trend analysis report uses time-sensitive filters that analyze changes in
requirement text, attributes, traceability, and hierarchical relationships. Trend
analysis reports require that you specify an increment for displaying revisions.

Access Requirement Metrics with the Tools > Metrics command on the Tool Palette.

For more information, refer to Using Requirement Metrics on page 206.
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Working with
Discussions

Discussions let you address comments, issues, and questions to a group of
participants that you define. Discussions can be associated with one or more specific
requirements, or they may refer to the project in general. A discussion item is either
the initial discussion topic or a response. A participant can respond to either the initial
discussion text or to another response.

Understanding Discussions

Viewing Discussions

All users of a Rational RequisitePro project can read discussion items, whether or not
they are discussion participants. Participants in discussion groups can create and
reply to discussions. Those who have an e-mail address specified in their user
information can receive discussion items by e-mail.

When a user opens a project, RequisitePro displays an icon on the Tool Palette status
bar to indicate that there are new discussions or responses associated with that project
or its requirements.

Responding to Discussions

When a user responds to the discussion, the response is added to the project in
RequisitePro. In addition, the response is sent to all participants who have an e-mail
address specified in their user information.

If you are the discussion author or a project administrator, you can restrict the
discussion to participants. In this case, all project users can still read discussion items,
but only participants can respond to the discussion.

Configuring E-mail for Discussions

RequisitePro offers the capability of communicating with a group of discussion
participants regarding comments, issues, and questions related to one or more
requirements or to the project in general. When e-mail is enabled, this feature will
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automatically generate an e-mail copy of any discussion item you enter (a new
discussion or a reply) and send it to all discussion participants with valid e-mail
addresses.

Discussion e-mail is enabled and configured in several ways:
» Enter an e-mail address in Project Security (click Project > Security).
* Configure a notification e-mail service (click Tools > E-mail Setup).

» Configure participation and notification mail for all users with e-mail addresses
using the Rational E-mail Reader application.

Entering E-mail Addresses in Project Security

All RequisitePro users can add or edit their own e-mail addresses within
RequisitePro; however, only project administrators (who have administrator
permissions) can add or edit other users” information.

See the procedure Modifying Your Password, User Name, or E-mail Address on page 39
for information on entering your own e-mail address in Project Security.
Administrators can use the same procedure for entering or modifying all users’ e-mail
addresses.

Configuring Notification E-mail for Discussions

Use the E-mail Setup command to configure notification e-mail to other discussion
participants in RequisitePro. When you initiate or reply to a discussion item from
within the Discussions dialog box, this feature automatically sends copies of the
discussion items to the RequisitePro database and to all participants with valid e-mail
addresses in their RequisitePro user information.

Note: This configuration option is not required if your system administrator has
configured participation and notification e-mail using the Rational E-mail Reader.
The Rational E-mail Reader application allows discussion participants to reply to the
discussion items both through their e-mail and from within RequisitePro.

To configure your notification e-mail:

1 On the Tool Palette, click Tools > E-mail Setup.
The E-mail Configuration dialog box appears.

2 Select the Enable e-mail Notification check box to automatically generate
notification e-mail (messages from you to other discussion group participants)
when you create or reply to a discussion item in RequisitePro. Clear the check box
to disable notification e-mail messages.
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3 Click the down-arrow at the E-mail Provider field and select the e-mail protocol
that is used on your network (either SMTP /POP3 or MAPI).

4 For SMTP/POP3, type the following:

s your SMTP server name

s your e-mail address, such as “yourname@yourcompany.com”

s your name as it should appear in discussion group notices
5 For MAPI, click the down-arrow at the Profile field and select your MAPI profile.
6 Click OK.

Configuring E-mail Using the Rational E-mail Reader

The Rational E-mail Reader offers full e-mail integration with RequisitePro by
associating an e-mail handler with each RequisitePro project. The Rational E-mail
Reader application allows discussion participants to reply to the discussion items
through their e-mail or from within RequisitePro. Initial discussion items and replies
are automatically stored in the RequisitePro database and sent to discussion
participants by e-mail.

Discussion participants must have an e-mail address specified in their RequisitePro
user information in order to receive discussion-related e-mail.

The Rational E-mail Reader can run only on NT clients or NT servers. To configure
e-mail using the Rational E-mail Reader, refer to Configuring E-mail for Discussions in
the “Rational RequisitePro Installation” chapter of the Rational RequisitePro Installation
Guide. This configuration is typically performed by a system administrator. Note that
this configuration is required for enabling e-mail for use with RequisiteWeb.

Be sure to use the SMTP mail protocol when configuring the Rational E-mail Reader
with RequisitePro. MAPI is not supported.
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Creating Discussions

You can create a discussion at any time.

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions
button). The Discussions dialog box appears.

& | @

Eilter.. Open

Subject Create..
wiiting Product R equirement per Jmer request A7 dq
Mew Discussions Feature ? Fred 12/2/98 11:14:41 AM Reply...
= Reconsider Low Resouces Sandy 1242798 10:34:32 AM
E RE: Reconsider Low Resources Sandy 12/2/98 10:36:39 AM Fropetties.
m RE: Reconsider Low Resouices Adam 12/2/98 11:24:50 A
elete
FErirt.
Associated Requirements:  PRE = Close
Participants: Fred, Charles, Cathy, Sandy
Meszage text: Help
Pleaze examine this requirement and give re your feedback.
=

2 Click Create. The Discussion Properties dialog box appears.

General I Adtributes I Participants I Bequirements
Subject:  [New Discussions Feature =l
Text: How will the user know when a new discussion is opened? ;I

| |
oK | Cancel | Help |

3 Click the General tab, and type a subject (required) and text. The subject should be
brief, but descriptive enough to inform other users of the discussion’s contents.
The text you type will become the first item in the discussion. Open the discussion
by raising an issue, making a comment, or asking a question.
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4 Click the Participants tab. Add users and groups. (See Creating and Modifying
Discussion Participants Information on page 87.)

Discussion Properties E

General I Attributes I Participants I Bequirements
— Participants:
Uszers: Groups:
Sandy
Adam
Cath .
Ehafl'rles Project Groups E
Adminiztrators

Add... | Femoye | Erel

I Restict To Participants

QK | Cancel | Help

Cancel | Help |

5 Click the Requirements tab and add requirements. (See Creating and Modifying a
Discussion’s Requirement Information on page 89.)

Gererdl | Atibutes | Patiiparts | Beauitements

~Assaciated Rrequirements: |

Select Requirements [x]

- Display;

PR1E: All other screens shall he

Bequirements
of ype:

Locatedin:  [alocations =l

[ equirement ypes =1

Add

~ [FRT: The UES system shall, upon user request, display d -
PR2: The GBS system shall povide  loan officer with t
PF3: The DB System shal calculate the blus book value
PRd: The OBS system shal allow only maintenance of cur
oK. FRE: The OBS system shal allow only maintenance of cur
-/ | PRG: The BBS system shall allow updales to custamer inf
PR7: The DBS spstem shall provide the folowing reparts

ity s us
PATT: The QBS shalloffer 2 camprehensive online Help
PF12: Upon user request. the DBS spstem shall displap 3
PF13: The OBS system shall automalically switch to ithe
FH14: The QBS system shall 1espond to inquiiss vithin
FR15. The QBS system shall use no more than 1 megabyte o
PRTE: All other screens shall have customer infomation

P17, All balance ifomation shal be updated systemati

5F1: The system shall display  Customer Information 5o Hl
2511 M

oK | Concel Find Hep |

Note: If you have filtered or displayed only discussions associated with specific
requirements, those requirements are automatically listed on the Requirements tab.
(See Displaying, Filtering, and Sorting Discussions on page 82.)

6 Click OK.
If e-mail is configured for discussions, the discussion is opened and the message is
sent to all participants who have an e-mail address specified in their user
information. An icon on the Tool Palette also notifies users that a new discussion is
associated with that project.
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As with e-mail, discussion messages cannot be modified after they have been sent.
This prevents conflicts when the original text is included in a discussion reply. If you
want to add an explanation regarding your initial message, you can do so by creating
a reply to the discussion.

If you click the discussion icon on the Tool Palette when you have a requirement with
a pending tag number selected in an opened document, a message appears, informing
you that you cannot associate discussions with pending requirements. Save the
requirements document and try again.

Viewing and Modifying Discussion Properties

To view discussion properties:

1

2

On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).
The Discussions dialog box appears

Select a discussion and click the Properties button.

Note: Only the originator of the discussion and an administrator can modify a
discussion’s properties.

The Discussion Properties dialog box lets you do the following:

Use the General tab to view the discussion subject and text, or enter subject and
text when you are creating a new discussion.

Use the Attributes tab to view the discussion’s author, the date and time the
discussion was created, and the discussion’s current priority and status. Only the
priority and status can be modified.

Use the Participants tab to view or modify listings of the discussion’s participants,
divided by users and groups, and whether or not the discussion is restricted to
participants.

Use the Requirements tab to determine which requirements are associated with a
discussion. Note that a discussion does not need to address any requirements
specifically. However, if a specific requirement is addressed, it should be
associated using this tab.

Notifying Participants about a New Discussion

When you create a new discussion, you do not have to do anything to notify
participants about the discussion, provided that you did the following:
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* You typed a subject and topic text in the Discussion Properties dialog box at the
General tab.

* You specified participants in the Discussion Properties dialog box at the
Participants tab.

Note: In a new discussion, the discussion author is automatically included as a
participant.

After you have completed these two tasks and clicked OK in the Discussion Properties
dialog box, RequisitePro adds the discussion to the project and sends an e-mail
message to each participant for whom an e-mail address has been specified in the
participant’s user information. The message contains the subject and text you entered
at the General tab.

Participants can also read the discussion and its responses in RequisitePro. When a
user opens a project, RequisitePro displays an icon on the Tool Palette to indicate that
there are new discussions or responses associated with that project or its
requirements.

Reading Discussions

& |

The Discussions dialog box helps you keep track of which discussion items you have
read and which you have not.

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).

The Discussions dialog box appears.
2 In the discussions list, click a discussion.

An expand/collapse indicator is displayed to the left of discussions with
responses. Unread discussion items are shown as bold text. Items you have read
are shown as normal text.

3 Click an item to read it. The item’s text displays in the lower portion of the dialog
box.

After approximately 5 seconds, RequisitePro changes the item from bold to normal
text, indicating that it has been read. If you select another item before
approximately 5 seconds elapse, RequisitePro leaves the previously selected item
bold, indicating that it is still unread.

4 To manually mark an item as read or unread, right-click the item and select Mark
Read or Mark Unread on the shortcut menu that appears.
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Responding to Discussions

You can respond to a discussion either in RequisitePro or in your e-mail application.

Note: If you are not a discussion participant, you can respond to the discussion only if
the Restrict To Participants check box is cleared in the Discussion Properties dialog
box at the Participants tab. Only the discussion author and members of the
Administrators group can modify this option.

Responding to Discussions in RequisitePro
To respond to a discussion using the Discussions dialog box in RequisitePro:

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions

=i button).

Q The Discussions dialog box appears.

B Discussions

Filter.... | Open

Subject

ing Product Reguirsment per customer request
Mew Discussions Feature
=] Reconsider Low Resources Sandy
E] RE: Reconsider Low Resources Sandy
! RE: Reconsider Low Resources Adam

Associated Fequirements: PRE ;I
Farticipants: Fred, Charles, Cathy, Sandy
fessage text:
Flease examine this requirement and give me your feedback.
[

LCreate...
Beply...
Propeties...
[efete

Brint

ele ELIED

2 In the discussions list, click a discussion or response to a discussion.

The discussion text appears in the lower portion of the Discussions dialog box.

3 Click Reply.
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The Discussion Response dialog box appears.

Discussion Responze E
Author: Date & Time: | 12/2/38 11:37 AM
Subject: |F|E: R ewriting Product Requirement per customer request
Text: Let's zet up a meeting tomarmow at noon so we can discuss it ;I
together]
=
QK | Cancel | Help |

The default subject is “RE: [previous discussion item's subject].” You can change
the subject.

Type your response.

The text automatically wraps at the end of each line you type. You can use CTRL-C
to copy selected text from another application or document, and CTRL-V to paste it
into the response text box. Text formatting, such as bold and underline, is not
available in the Discussion Response dialog box. You cannot attach files to the
response.

Click OK. The Discussions dialog box is displayed again. RequisitePro updates the
associated project and discussion and then sends your response to all participants
who have an e-mail address specified in their user information.

Responding to Discussions Using E-mail

You can respond to a discussion using your e-mail application. Depending on
whether your system administrator has enabled participation e-mail using the
Rational E-mail Reader, one of two conditions apply:

If participation e-mail is enabled, your reply is delivered to all discussion
participants and stored in the RequisitePro database. It is then accessible from
within RequisitePro.

If participation e-mail is not configured, your reply is delivered to the recipients
you select, but it is not stored in the RequisitePro database.
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To respond to a discussion using your e-mail application:

1 In your e-mail application, open the message containing the discussion item to
which you wish to reply.

2 Select the reply option.
3 Use the default recipient provided.

Note: If participation e-mail is enabled, messages will arrive from an e-mail handler
that is specific to a RequisitePro project. In this case, simply reply to the sender. If
participation e-mail is disabled, you can reply to all recipients; however, your
message will not be stored in the RequisitePro discussion. You can add recipients in
either case.

4 Use the default subject provided. Do not modify the subject.

5 Type your response. Do not type below the line: “Text below this line is not
included in the discussion response.” In addition, do not delete this line or
anything below it.

RequisitePro uses this line to indicate which text is your response and which text is
already included in the discussion. If you delete the line, your reply includes both
your new text and any text that was below the deleted line.

Note: Attachments are not supported in discussions. Any attachments you include
will not be added to the discussion in the RequisitePro database.

6 Send the e-mail message. The message is sent to RequisitePro, which updates the
associated project and discussion and then sends your response to all participants
who have e-mail.

Note: Discussion replies cannot be modified after they have been sent. This
prevents conflicts when the reply text is included in another reply. To add an
explanation regarding your message, you can create another reply.

Displaying, Filtering, and Sorting Discussions

Displaying Discussions Associated with a Single Requirement

You can open the Discussions dialog box to display only the discussions associated
with a specific requirement, or you can open the Discussions dialog box to display all
open discussions.
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To display only discussions associated with a requirement:

1 Select a requirement.

2 Open a discussion.

3 From the Views Workplace, select a requirement and then do one of the following:
2 (Click Requirement > Discussions.
2 Click the Discussions icon 1 to the right of the requirement.

2 Right-click the requirement, and then click Discussions in the shortcut menu
that appears.

From the Word Workplace, select a requirement and then do one of the following:
2 (Click RequisitePro > Requirement > Discussions.
2 Click Requirement > Discussions on the Tool Palette.

4 The Discussions dialog box appears, showing only those discussions associated
with the specified requirement.

Note: To display all discussions, do one of the following:
2 Click Filter, clear the Requirement check box, and then click OK.

2 Close the dialog box, and click Project > View Discussions on the Tool Palette.
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Filtering Discussions

You can specify which discussions you wish to view in the Discussions dialog box,
based on text, requirement, users, priority, and status.

To filter discussions, do the following:

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).
Q The Discussions dialog box appears, showing all open discussions.
Bl Discussions M=
Filter... | Open
Subject ¥ |From Create...
Fiewriting Product Requirement per customer request Cathy 2 11:17.57 &AM —I
Mew Discussions Feature ¥ Fred 12/2/98 111441 AM Eeply... |
= Reconsider Low Resources Sandy 12/2/98 10:34:32 AM
) RE: Reconsider Low Resources Sandy 1242498 10:36:39 AM Properties... |
B RE: Reconsider Low Resources Adarn 12/2/98 11:24.50 AM
Delete |
Pint... |
Aezociated Requirements: FRE ;I Cloze |
Participants: Fred, Charles, Cathy, Sandy
tMessage test: Help |
Please examine this requirement and give me your feedback.
=

2 Click Filter. The Discussion Filter dialog box appears.

Discussion Filter E
I~ Subject Tent! |

[ Bequirement: I

[ Participant: I

™ Pricrity: I

1 S0 T

[v Status: IDpen

]9 I Cancell Help |

3 To display discussions containing specific text in their subjects, select the Subject
Text check box, and then type the text in the text box.
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Use % in the text if you want RequisitePro to find discussions using the wildcard
character % to match one or more characters in the search text. For example, if this
check box is selected and you type the text $document %, RequisitePro finds
discussions containing “document,” “documents,” “documented,”
“undocumented,” and so on.

To display discussions with which one or more requirements are associated, select
the Requirement check box, and then type the requirements by which you wish to
filter (separated by commas) in the text box. For example, enter PR1, SR22,
TST114 to include all discussions with which the requirements PR1, SR22, or
TST114 are associated.

Note: You can also click the adjacent ... button to open the Select Requirements dialog
box and select requirements by name.

5

8
9

To display discussions for which a particular user is a participant, select the
Participant check box, and then select the desired user name in the list.

Note: You can select the name of a user who is a member of a group. RequisitePro
will find discussions for which that group’s members are participants, including
the selected user.

To display discussions with a specific priority, select the Priority check box, and
then select High, Medium, or Low in the list.

To display open or closed discussions, select the Status check box, and then select
Open or Closed in the list.

Filter by more than one option by repeating any of Steps 3-7 above.
Click OK.

The Discussions dialog box is displayed again, showing only the discussions that
match the filters set above. The filter settings are displayed next to the Filter button in
the dialog box.

Sorting Discussions

In the Discussions dialog box, you can change the sort order in which discussions
appear.

1

&3 |

2

On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).
The Discussions dialog box appears.

In the discussions list, click the column heading by which you want to sort the
discussions.
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For example, to sort discussions alphabetically by subject, click the Subject
column heading.

3 To reverse the sort order, click the column heading again.

Printing Discussions

You can print discussion items. The printout shows the discussion item’s subject, text,
author, and creation date and time. The printout also shows information about the
associated discussion, including the discussion’s priority, status, requirements, and
participants.

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).
The Discussions dialog box appears.

& |

2 In the discussions list, click one or more discussion items. (Use a multiple select
action to select more than one item.)

3 Click the Print button. A Print dialog box appears.
4 Click OK.

Modifying Discussions

Viewing and Modifying Discussion Attributes

The Attributes tab in the Discussion Properties dialog box shows the discussion’s
author, the date and time the discussion was created, and its current priority and
status. These properties can be modified by the discussion author and project
administrators only.

To modify discussion attributes:

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).
The Discussions dialog box appears.

& |

2 Select a discussion, and then click Properties.
You can also click Create to create a new discussion.

3 Click the Attributes tab.
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4 Click the down arrow at the Priority field and select a priority from the drop-down
list.

Note: You can only change a discussion’s priority if the discussion is open.

5 If you are modifying a discussion, change Status to Open or Closed. (You cannot
change the status of a new discussion.)

Creating and Modifying Discussion Participants Information

The Discussion Properties dialog box, Participants tab lets you determine which users
and groups are included in the discussion and whether the discussion is restricted to
participants.

Any user can view the Participants tab, but only the discussion author and project
administrators can modify its options, with the following two exceptions:

*  You can add yourself to the Users list if the Restrict To Participants check box is
cleared.

* You can remove yourself from the Users list whether or not the Restrict To
Participants check box is selected.

Note: If you are a member of a group that participates in the discussion, you cannot
remove yourself from the group. A RequisitePro administrator must remove you
from the group.

The options in this dialog box can be modified only if the discussion is open.
To modify participants information:

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).
Q The Discussions dialog box appears.
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2 In the discussions list, click an open discussion and click Properties, or click Create
to create a new discussion. The Discussion Properties dialog box appears.

Discussion Properties [ X]
General I Attibutes ] Participants I Requirements
Subject I‘
Teut: d
oK I Cancel Help |

3 Click the Participants tab.

4 To add a user, click Add below the Users list. The Project Users dialog box appears.

Project Users E

Adam
Cathy
Charlez
:Fred
Sandy
Scott

Ok, I Cancell Help I

5 Select a user from the list, and then click OK. (Use a multiple select action to select
more than one user.)

Note: For a new discussion, the discussion author is automatically included as a
participant.
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6 To add a group, click Add below the Groups list. The Project Groups dialog box
appears.

Project Groups

Administrators

Cancel I Help I

7 Select a group from the list, then click OK. (Use a multiple select action to select
more than one group.)

Note: If a user is a member of a group and you add the group to the Groups list, you
do not need to add the user individually to the Users list.

8 To remove users, click the user names in the Users list, then click Remove below
the Users list. To remove groups, click the group names in the Groups list, then
click Remove below the Groups list.

9 To restrict the discussion to participants only, select the Restrict To Participants
check box. Only participants will be able to respond to the discussion, although all
users can read it in RequisitePro.

10 Click OK to close the dialog box.

Creating and Modifying a Discussion's Requirement Information

The Discussion Properties dialog box, Requirements tab lets you determine which
requirements are associated with a discussion. Note that a discussion does not need to
address any requirement specifically. However, if a specific requirement is addressed,
it should be associated using this tab.

Any user can view the Requirements tab, but only the discussion author and
members of the Administrators group can modify its options. The options in this
dialog box can be modified only if the discussion is open.
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To modify a discussion’s requirement information:

1 On the Tool Palette, click Project > View Discussions (or the Show Discussions
button).
The Discussions dialog box appears.

& |

2 In the discussions list, select an open discussion and click Properties, or click
Create to create a new discussion. The Discussion Properties dialog box appears.

3 Click the Requirements tab.
4 To add a requirement, click Add.

The Select Requirements dialog box appears.

Select Requirements
= DiSD:ay
Bequirements -
e IAII requirement types j
Located in: |AII location: j

: T hall p
PR3 The QBS System shall caloulate the blue book value
PR4: The QBS system shall allow only maintenance of cur
PRE: The QBS system zhall allow only maintenance of cur
PRE: The OBS system shall allow updates to custamer inf
PR7: &l other screens shal have custamer information
PRE: All balance information shall be updated systemati
PR3 The QBS system shall provide the following reports
PR10: The OBS system shall ack the last date a report
PR11: Each user shal have a unique login and associated

PR12: The security shall be implemented such that the us

PR13: The OBS shall offer a comprehensive onine Help 3

PR14: Upon user request, the LBS system shall digplay a

PR15: The GBS system shall automatically switch to eithe

PR1E: The LBS spstem shall respond ta inguinies within b

PR17: The GBS system shall use no more than 1 megabyte o

SR1: The system shall display a Customer Infarmation So d

[ = B P Y RV

o | Cameel | fd | Hep |

5 Select a requirement type from the Requirements of type list, select a location
from the Located in list, and select a requirement from the list. (Use a multiple
select action to select multiple requirements.) To locate a specific requirement,
click Find. You can use the Find Requirement dialog box to locate a specific tag
number and requirement name and text.

Note: Requirements with pending tag numbers do not appear in this list.

6 When you have finished selecting requirements, click OK.
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The Discussion Properties dialog box reappears with the specified requirement
shown in the Associated Requirements list.

Digcuszsion Properties E
General I Attributes I Participants I Requirements

—Azzociated Reguirements

FPR1: The OBS systern shall. upon user request, display detailed customer
PR11: Each uzer zhall have a unigue login and asszociated password,

Eemove | F'lgperties...l

Ok | Cancell Help |

7 To remove a requirement, click the requirement in the Associated Requirements
list, and then click Remove.

8 To display a requirement’s properties, click Properties. The Requirement
Properties dialog box appears, showing the selected requirement's properties.

9 Click OK. To close the Discussion Properties dialog box, click OK.

Creating and Modifying a Requirement’s Discussion Information

You can view and create discussions from within the Requirement Properties dialog
box at the Discussions tab.

1 Do one of the following to open the Requirement Properties dialog box:

s In the Word Workplace, select the requirement in an opened document and
click RequisitePro > Requirement > Properties.

2 In the Word Workplace, select the requirement in an opened document. On the
Tool Palette, click Requirement > Properties.

2 In the Views Workplace, select the requirement in a view. Click Requirement >
Properties.

2 Click the Discussions tab. A list of all discussions associated with the requirement
is displayed.

3 To create a new discussion associated with this requirement, click Create.

4 To read a discussion item, select the discussion, and then click View.

Modifying Discussions 91



5 To view the properties for a selected discussion, select the discussion and click
Properties.

Note: If the requirement has not been saved in the database, the Create, View, and
Properties buttons are not available, regardless of how you gained access to the
Requirement Properties dialog box. Save the document containing the
requirement, and then open the dialog box again.

Closing Discussions

If you are the discussion author or a project administrator, you can close a discussion
that is no longer needed. Closed discussions are filtered out of the Discussions dialog
box by default. A discussion must be closed before you can delete it.

1 On the Tool Palette, click Project > View Discussions (or click the Show
Discussions button).
The Discussions dialog box appears.

& |

a H WO N

In the discussions list, click the open discussion.
Click Properties. The Discussion Properties dialog box appears.
Click the Attributes tab.

Click the down arrow at the Status field and select Closed from the
drop-down list.

6 Click OK. The Discussions dialog box reappears. When the discussion is selected,
the Delete button is enabled, indicating that the discussion is closed and can be
deleted.

Deleting Closed Discussions

If you are the discussion author or a project administrator, you can delete a closed
discussion. A discussion must be closed before you can delete it.

1 On the Tool Palette, click Project > View Discussions (or click the Show
Discussions button).
The Discussions dialog box appears.

& |

2 In the discussions list, click a closed discussion.
3 Click Delete. A message appears, asking you to confirm the deletion.

4 C(Click Yes.
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Working with Documents

A Rational RequisitePro requirements document is a Microsoft Word file created in
RequisitePro and integrated with the project database. Requirements created outside
of a project document can be imported or copied into a project document.

When you create a new project document, RequisitePro associates the document with
the project that is open. This association is used to update the database and
synchronize the revision numbering of the project and document. The document’s
name, location, document type, and revision information are stored in the project
database.

Creating a RequisitePro Document

To create a document in a RequisitePro project:
1 Do one of the following:
2 On the Tool Palette, click Document > New.

2 In the Word Workplace, click RequisitePro > Document > New.
The Document Properties dialog box appears.

Document Properties m
General | Reyision
Mame: IPrDcess Sale Use Case Specification
Description

A document specifying the following use case: A sales clark | &
will process a sale for & customer allowing the customer to
purchase an iterm.

¥

Filename: |ProcessfSaIe ucs ¥ Show Tags
Diractong: |C YProgram FilesRational\RequisiteFro 4.5% Browse...
Docurnent

Toas: IUSE! Case Specification Document Type LI

Ok I Cancel | Help |

2 In the General tab, type the name of the document in the Name field (64 characters
maximum).
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3 Type a brief description (up to 255 characters) of the document’s purpose or
contents in the Description field.

4 In the Filename field, type, modify, or view the name of the document. The file
name defaults to the same name you typed in the Name field. The file name is
limited to eight characters; if long file names are supported, you can use up to 64
characters. Do not give it an extension; RequisitePro assigns an extension
according to the Document Type selected.

5 Click the Show Tags check box to display requirement tags in the new document.
Clear this box to hide the tag text.
Selecting this check box sets options in Microsoft Word to ensure that the
requirement tags are visible both on your display and in the printed document.
The check box Hidden Text is selected in both the View tab and the Print tab in the
Microsoft Word Tools > Options dialog box.

6 Type alocation for the file in the Directory field, or click Browse to select a
directory.

By default, RequisitePro places a document in the project directory, but documents
can be saved anywhere on your system. You can type the name of a directory in
this text box. If you are working in a networked environment with shared drives,
type a Universal Naming Convention name for identifying a shared directory on a
server, such as “\\Servername\Sharename.” This happens by default if you type
a location with a drive letter.

7 Click the down arrow at the Document Type list and select a document type to
assign to the new document. Note that after the document is created, you cannot
change the document type associated with it.

8 Click OK. The new document is open and ready to be edited.

Note: The document must be saved for the requirements to be committed to the
database.

Saving a RequisitePro Document

When you save a document, RequisitePro saves to the project database all document
modifications, such as the document's name, revision number, label, and change
description. RequisitePro automatically creates backup files for each document file in
the document directory and updates them when you save the document. In addition,
RequisitePro commits all new and modified requirements in the document to the
database, and it deletes from the database all requirements that you deleted from the
document. Requirements with pending tag numbers are assigned requirement tags.
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The Save command on the Document menu on the RequisitePro Tool Palette saves the
active requirements document. This command is also available on the RequisitePro >
Document menu in the Word Workplace. If you save the document using the Save
command on the File menu in the Word Workplace, the document will be saved, but
the document and requirements information will not be updated in the RequisitePro
database.

To save a requirements document in a RequisitePro project:
1 Do one of the following:

2 On the Tool Palette, click either the Save the current document button or
Document > Save.

2 In the Word Workplace, click RequisitePro > Document > Save.

If you modified a requirement in the document, the Change Description dialog
box appears and prompts you to type a reason for the change.

Change Description E

Requirement SUPL3 haz changed. Please enter a
reazon for thiz change.

Lhange Description:

Changes per customer request, ;I
-]
ptégpply to all modified requirements in the document
Corcs |

2 Type an explanation of the modifications in the Change Description field.

3 If the change description applies to all requirements that were changed in the
document, select the Apply to all... check box.

Note: If the document contains requirements that include Microsoft Word-linked
files, you may receive a message stating that the location of linked files cannot be
resolved. Your machine may be disconnected from the network, your machine may
not have the specified drive mapped, the removable drive may be empty, or you may
not have permissions to read the specified drive. You can still save the changes you
made to the requirements or to the document, but the links to the external documents
are not updated. Click OK.

4 Click OK to save the document and its requirements. (Click Cancel to end the
entire process.)
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If you want to save a document without the standard bookmarks and style
RequisitePro adds to requirements, you may turn off the options. To save a document
without bookmarks, use the Microsoft Word Tools > Options command, and on the
View tab, clear the Bookmarks check box. If you want to save a document without
requirement tags, use the Microsoft Tools > Options command, and clear the Hidden
Text check box on the Print tab. If you have exclusive access to the project and you
want to save a document without the colored text, you can edit the requirement style
in the RequisitePro Project Properties dialog box.

Opening a Document After a Project Is Open

=]

If you try to open a project that was created in RequisitePro version 4.0 or later and
requires updating to the current version, the Database Upgrade Wizard appears. The
wizard guides project administrators through the process of upgrading existing
database structure and project data to the current RequisitePro release. If a project is
in a version of RequisitePro earlier than 4.0, you must first upgrade the project to
version 4.0 before using the Database Upgrade Wizard. Contact Technical Support for
information.

Do not open a project for which you are creating a baseline in Unified Change
Management or that you are adding to ClearCase.

To open a document:

1 Do one of the following:
2 On the Tool Palette, click the Open a project and documents button.
2 On the Tool Palette, click Document > Open.

2 In the Word Workplace, click RequisitePro > Document > Open.
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The Open Project and Documents dialog box appears.

Open Project and Do |

Select a Project:

Add...
My exercise project
Project 10 Femove
Project 14 _I
Project 15 = ti I
Project 16 LI roperties. ..
Locatiorn: IE:'\F'FEDGFL-'-\M FILESSRATIOMALMREQUISITEPROMSAMPLES\LEARMIMG
Open project options: [ Read Only [ Exclusive
Select Document(s]: Dizplay Typels):| Al Types hd
Arrange Shiprment ucs
Check Order Status Ucs
CheckOut Ucs
ClaszicsCD Supplementary Specification SUpP
ClazzicsCD Yizsion Document WIS
Glozzary GLS
Shop for CD Ucs
Open docurment[z] option: [~ Read Only Froperties... I

Ok I Cancel | Help |

The Open Project and Documents dialog box displays a list of projects available in
your project list. Beneath the list of projects, a second list box displays the
documents that are associated with the project you select. You can click the
Properties button to view a read-only version of the Document Properties dialog
box for the selected document in the list.

Select a project from the project list. A list of the project’s documents appears in the
document list. This list includes all documents you have either created in the
project or imported into the project, regardless of whether the documents contain
requirements.

Only one project can be open at a time. If you try to open another project and its
documents while working in a project, RequisitePro prompts you to save any
modifications; it then closes the current project and its associated documents
before opening the new project and documents.

Note: For more information on options for controlling access by other users when
the project and documents are open, refer to Setting Security on page 192.

Select one or more documents to open and click OK.
RequisitePro launches the Word Workplace and opens the documents. Do not
press the ESC key while the document is opening.
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Closing and Saving a RequisitePro Document

To close a project document:
1 Do one of the following:
2 On the Tool Palette, click Document > Close.

s In the Word Workplace, click RequisitePro > Document > Close.
If modifications were made to the document that were not saved, the
Document Changed dialog box appears.

Document Changed E

The document 'OBS Product Requirements Document’ has
been modified. Do you want to save the document before
closing?

Mo Cancel Beview Changes...

2 Do one of the following:
2 To accept the modifications and save the document, click Yes.
2 To abandon the modifications and leave the document as is, click No.
s To return to the document without closing, click Cancel.

s To review changes to the document, click the Review Changes button. The
Document Changes dialog box lists changes, as described below.

Note: If you changed one or more requirements in the document, the Change
Description dialog box appears (whether you selected Yes or Review Changes above).
You have the option to record reasons for changing each requirement.

Reviewing Changes Before Closing a Document

When closing a document that has been modified, the Document Changed dialog box
presents you the option of reviewing the changes.

To review modifications to a document:

1 Follow Steps 1 and 2 in the preceding procedure and click the Review Changes
button. If you have changed one or more requirements in the document, the
Change Description dialog box appears. You have the option to record reasons for
changing each requirement.

The Document Changes dialog box lists all modifications to the document.

2 Click OK to save the changes once you have reviewed them.
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Changing the Location of a RequisitePro Document

New documents are stored in the project directory by default. Documents can be
created in or moved to any directory on the file system. All documents associated
with the project are included in your project list regardless of where they are stored.

To change the location of a project document:
1 Do one of the following:
2 On the Tool Palette, click Document > Properties.
2 In the Word Workplace, click RequisitePro > Document > Properties.

The Document Properties dialog box appears. On the General tab, the document
file name and location appear in the Directory edit box.

2 Click Browse to change the location of the file. The Browse for Folder dialog box

appears.
Document Properties m

General | Reyision
Name: IPrDcess Sale Use Case Specification Browse for Folder =]
Description:  [4 4ocument specifying the following use case: & sal )

will process a sale for a customer allowing the custol Select the directory to re-locate your document

purchase an iterm. to...
D Metwork Aszociates ;I
Filename: IProcessfSaIe ucs v s D Dutiook Express
Dirgctary: IC \Frogram Files|Rational|ReguisiteFra 4.5 | D Paint Shop Pro 5
— D Plus!

.Dr;;:_mem IUSE! Case Specification Document Type E‘D Rational

- common

oK I Cancel Help

&} eaim)
: {3 ucleam
AT rutines LI

()8 I Cancel |

3 Select a new location for the document. Click a folder to open it.
4 Click OK to accept the location and close the Browse for Folder dialog box.

5 Click OK to close the Document Properties dialog box.
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Modifying Document Information

To modify information in an open document:

1 Open the Document Properties dialog box in one of the following ways:
2 In the Word Workplace, click RequisitePro > Document > Properties.
2 On the Tool Palette, click Document > Properties.

2 Modify the document’s information:

2 On the General tab, you can change the name of the document, its description,
and the directory in which it is stored. You cannot change its logical name or its
document type.

2 On the Revision tab, you can enter a Change description. All other fields are
populated by RequisitePro.

3 Click OK to close the Document Properties dialog box.
4 To save your changes to the document, do one of the following:
2 In the Word Workplace, click RequisitePro > Document > Save.

2 On the Tool Palette, click Document > Save.

Moving Text and Requirements to a New Document

If a requirements document becomes corrupted, you can use the Microsoft Word cut
and paste commands to move all contents of the document (including all its
requirements) to another document. This is also helpful when you want to move the
contents of an entire document to a new document with a new file name.

Note: To move individual requirements from one document to another, use the cut
and paste commands on the RequisitePro Requirements menu rather than the
Microsoft Word Edit menu.

To move all text and requirements:
1 Open an existing RequisitePro document.
2 Create a new document by doing one of the following:
2 On the Tool Palette, click Document > New.
2 In the Word Workplace, click RequisitePro > Document > New.

3 Type aname and file name for the new document, select a document type, and
then click OK.
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4 In Microsoft Word, do the following:
a  Click Window and click the existing file name.
2 Click Edit > Select All.
s Click Edit > Cut.
5 Click the Window menu and then click the file name of the new document.
s Click Edit > Paste.
5 On the Tool Palette, click Document > Save.

A dialog box appears and asks you how to handle each requirement that you have
pasted into the new document.

6 Accept the default option “Change the location of this requirement” and click OK.

Protecting Documents

When you protect a document for revisions, you can electronically distribute the
document or make it available in a shared directory for reviewers to suggest changes.
You can then merge the revisions in one document.

Use the commands on the Microsoft Word Tools menu in the Word Workplace to
track changes and protect RequisitePro documents. To protect documents, use
RequisitePro’s offline authoring feature to edit a document in Word outside of
RequisitePro. To make a copy of a requirements document, use the Document > Save
As command. (Refer to the section that follows and to Working with Documents Offline
on page 105.)

Working with Microsoft Word

Saving a RequisitePro Document as a Word Document

RequisitePro includes an option to save a project document as a Microsoft Word
document that is independent of the project. This allows you to attach the document
to e-mail or share the document with someone outside of your work group.

When you choose this option, RequisitePro makes a copy of the active requirements
document and saves it as a Word file. The resulting Word document retains the look
and feel of the original requirements document and even includes bookmarks and
tags used by RequisitePro to identify requirements.
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To save a project document as a Word document:

1 Open the RequisitePro document in the Word Workplace.

2 Do one of the following:
2 On the Tool Palette, click Document > Save As.
2 In the Word Workplace, click RequisitePro > Document > Save As.
The Document Save As dialog box appears.

3 Specify a destination for the new copy of the document.

4 Accept the default name in the File name field, or type a file name. Do not change
the .doc extension.

5 Click Save. RequisitePro closes the original RequisitePro document and opens the
new .doc file in Word.

Note: Microsoft Word turns off the bookmarks and hidden text features by default, so
you will not see the requirement tags or bookmarks around requirements when a
document is viewed outside RequisitePro. Before editing the requirement text in a
Word document outside of RequisitePro, we recommend marking Bookmarks and
Hidden text options for display. In Microsoft Word, click Tools > Options and click the
View tab.

Managing Microsoft Word Documents

While working in RequisitePro, you can create, open, modify, save, and close Word
documents that are independent from RequisitePro. Use the standard File menu
commands to manage these Word documents. (The Save As and Exit commands are
unavailable in the Word Workplace in order to prevent conflicts in handling
RequisitePro documents.)

Note: RequisitePro documents are associated with projects, managed from the
Document menu on the Tool Palette or the RequisitePro menu in the Word
Workplace, and saved in RequisitePro format by default.

Closing Microsoft Word

To close Word without closing RequisitePro, click the Window menu on the Tool
Palette and select Close Word.
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Tips for Using Word in RequisitePro

Do Not Use

Do not use the Microsoft Word File > Versions feature. The Word logic of identifying a
base version with subsequent revisions conflicts with RequisitePro’s document
revision history features. Version changes in Word can conflict with the RequisitePro
requirements database. In addition, multiple versions greatly increase your document
file size.

Do not use the Cut command in Microsoft Word to cut requirement text. When you
use the Word Cut command, you may delete the requirement from the project. In
addition, if you cut a requirement from a document using the Cut command in Word,
you cannot paste the requirement into the project database.

Do not use the fast saves option in Word. Remove the check mark in the Allow fast
saves check box in Microsoft Word’s Options dialog box.

Use with Caution

Although you can use Word’s automatic paragraph numbering (the Format > Bullets
and Numbering command) within requirement text in a requirements document, this
feature can produce inconvenient and unexpected results. Automatic numbering
changes caused by the addition or deletion of paragraphs require you to confirm
changes to all subsequent numbered requirements in the document. This also adds a
revision history entry for each requirement, resulting in a cluttered revision history
list. Changes in autonumbering can also affect the requirement tag numbering.

If you are using Word 2000 and choose to clear the Trust all installed add-ins and
templates check box on the Tools > Macro > Security dialog box, you must click Enable
at the Microsoft Word message box each time you open the RequisitePro Word
Workplace.

Improving Word Performance

The following tips can improved Microsoft Word’s performance with RequisitePro
documents:

» Create small RequisitePro documents. Large documents can take significant time
to open, close, and manipulate; documents less than 5 MB or about 50 pages are
optimal.

* View documents in Normal mode. Documents in Page Layout mode are
constantly being repaginated.
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* Open documents selectively. Having many Word documents open at once
decreases performance.

Working with Word Styles

If you press ENTER after a marked requirement in a document, the requirement style
(such as double underline) and color are carried to the next line. Press CTRL and the
spacebar before typing, and the Word style is reset to Normal.

Using Word Options for “Hidden” Requirements

You can set options in the Microsoft Word Tools > Options dialog box to affect how
requirements are displayed in RequisitePro documents:

» If you clear the Bookmarks check box, you will not see the bookmarks around the
requirement in RequisitePro documents.

» The requirement tag in a RequisitePro document is hidden text in Microsoft Word.
If you clear the Hidden text check box, you will not see the tag in the text of the
requirement in the RequisitePro document.

Note: When editing a RequisitePro document offline, note that Microsoft Word turns
off the bookmarks and hidden text features by default. Before you edit the
requirement text in an offline document, we recommend that you mark the hidden
text and bookmarks for display.

For information about setting color and style for requirements, refer to Creating and
Modifying Requirement Types on page 236.

Editing a Requirements Document Outside of RequisitePro

To edit a document in Word outside of RequisitePro and merge it back in later, use
RequisitePro’s offline authoring feature rather than the Save As command.

Creating a Word Document from a RequisitePro Requirements
Document

Use the Document > Save As command to save a copy of your requirements document
with a .doc file extension. The resulting Word document will not appear in the project
documents list.

Managing External Word Documents

To manage a Microsoft Word document that is not part of a RequisitePro project, use
the File menu commands in the Word Workplace.
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Unavailable Word Commands

The File > Save As and File > Exit commands are unavailable in the Word Workplace
in order to prevent conflicts in handling RequisitePro documents. On the
RequisitePro Tool Palette, use the Window > Close Word command to close the Word
Workplace.

The Tools > Templates and Add-Ins command is unavailable to prevent deletion of the
RequisitePro template, which is required for proper functioning of RequisitePro.

Working with Documents Offline

Offline authoring allows requirements authors and project administrators to use a
document outside of RequisitePro (that is, offline).

When you take a document offline, RequisitePro creates a copy of the document in the
directory you specify. The original is still stored in RequisitePro, but it is changed to a
read-only document. Other users can view the document in RequisitePro, but they
cannot edit it until you bring it back online.

When you take a document offline, RequisitePro includes Microsoft Word macros in
the document. These macros allow you to add and delete requirements in the offline
document.

Note: In Word 2000, you may need to adjust your macro security levels to use the
Requirement > Create and Delete menu commands in offline authoring. Word 2000
defaults to the highest level for macro security. This setting prevents the availability
of the RequisitePro offline authoring macros. Reset the macro security in Word 2000
to medium on the Security dialog box, which is available by clicking Tools > Macro >
Security.

Do not rename documents while they are offline. The original file name is necessary
for recognizing the offline document within RequisitePro. When you bring the
document back online, RequisitePro replaces the read-only document with the
modified document. Alternatively, you can elect to cancel the offline process. When
you do so, RequisitePro restores the original document, removing its read-only state,
so all requirements authors and members of the Administrators group can again
modify it within RequisitePro.

Taking Documents Offline

Before taking a document offline, make sure all changes made to requirement text
outside the document (such as in the Attribute Matrix or in RequisiteWeb) have been
saved in the document.
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1 To take a document offline, do one of the following;:
2 In the Word Workplace, click RequisitePro > Document > Offline Documents.
2 On the Tool Palette, click Document > Offline Documents.

2 In the Display Types list, select a document type.

3 Click the document you want to take offline. (Use a multiple select action to select
more than one document.)

4 C(Click Take Offline.

The Take Offline Information dialog box appears.

Take OFffline Information E

Document: |E!BS Product Requirements Document

Beaszon:

Location: I Erowse...l
Ok I Cancel | Help |

5 In the Reason text box, type a reason for taking the document offline.

6 In the Location field, enter the directory path where you want to store the
document, or click Browse to locate the directory.

7 Click OK.

Determining Whether a Document Is Offline
To check whether a document is offline:
» Open the Open Project and Documents dialog box in one of the following ways:
2 On the Tool Palette, click Document > Open.
2 In the Word Workplace, click RequisitePro > Document > Open.
» In the Select Documents list, offline documents are followed by the word (offline).
To learn more about an offline document:

» (lick the document in the Select Documents list, and then click the Offline Info
button.
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» The Offline Information dialog box appears, showing the document name, the
user who took the document offline, offline date and time, location, and reason the
document was taken offline.

Open Project and Documents ﬂ
Selecta Project

Add...

Learning Project- Common

Project1 Bemowe
QuanerByte Savings Bank Example Project

RequisitePro Project Template Propetties...
Location: C\PROGRAM FILESYRATIONALYREQUISITEPROSAMPLES LEARNING_FR
Open project options: ™ Read Only ™ Exclusive

Select Document(s): Display Type(s):| Al Types hd

Classics DPFS Glossay
[

Offline Information ﬂ

Document |l:|aasms OFFS Wision Documant on

Author: IDevun ctian

Dat/Time:  [3/15/00 1031 AM R ey TS
Location [C:tMy Documents! Classics_Visionvis J Gtz (el

Besson: Dacumenttakan affling fy Devon on 3/ 15,00 10:31 A =l

Fieason: customer to examine before meeting 3/14

E
Close I Help

Modifying Offline Documents

You can modify an offline document in the same manner as you would any other
Microsoft Word document. All Word features and options are available for your use
when editing a RequisitePro offline document. In addition, you can add and delete
RequisitePro requirements in an offline document.

When you open the offline document in Word, make sure that you make the Word
macros available. These macros allow you to add and delete requirements in the
offline document.

You can modify requirement text in an offline document. When you bring the
document back online and open it in RequisitePro, RequisitePro prompts you to enter
a reason for the changes to the requirement text.

Microsoft Word turns off the bookmarks and hidden text features by default. Before
you edit the requirement text in an offline document, we recommend that you mark
the hidden text and bookmarks for display. Click Tools > Options in Microsoft Word
to open the Options dialog box, and select the hidden text and bookmarks check
boxes on the Views tab.
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Do not rename documents while they are offline. RequisitePro requires the original
file name in order to recognize offline documents.

Creating Requirements in Offline Documents

Mark requirement text in an offline document in the same way you would if the
document were online. The RequisitePro macro stylizes the requirement text with a
double underline and notifies you that a requirement was created. When you bring
the document back online, RequisitePro gives the requirement a number and default
attributes. You can then modify the requirement in the Requirement Properties dialog
box.

To mark text as a requirement in an offline document:
1 Select the information to define the requirement.

2 C(Click RequisitePro > Requirement > Create.

Deleting Requirements in Offline Documents

Delete a requirement in an offline document in the same way you would if the
document were online. When you delete a requirement, the requirement text remains
in the document, but it is no longer recognized as a requirement. RequisitePro
removes the requirement color and style settings and replaces them with the
document default style.

When you bring the document back online, RequisitePro notifies you regarding the
requirements you have deleted and asks whether you want to update the online
document with the changes. If you decline, RequisitePro does not bring the document
back online.

To delete a requirement in an offline document:
1 In the offline document, click anywhere in a requirement.
2 C(lick RequisitePro > Requirement > Delete (Unmark).

To undo a delete operation, click Edit > Undo. Click Undo until the requirement is
completely restored.

Note: In an offline document, you can delete only one requirement at a time.

Bringing Offline Documents Back Online

If you are the offline author or an administrator, you can bring an offline document
back online.
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1 Do one of the following:
2 In the Word Workplace, click RequisitePro > Document > Offline Documents.
2 On the Tool Palette, click Document > Offline Documents.

The Offline Documents dialog box appears.

Offline Documents x|

— Orline document

Name Dizplay Type(s): IAII Types vl

Arange Shipment ucs -
Check Order Status ucs =
CheckOut ucs

ClazsicsCD Supplementany 5 pecification SUP Take Dffline... |
WIS

ClassicsCD Wision Document
Glozzam GLS
Shop for CD 0cs =

— Offline docurment

LICS Lnknown Ering Orline. . |
Cancel Offline... |
Qffling Infa... |

Close | Help |

2 In the Offline documents list, select the document you want to bring back online.
(Use a multiple select action to select more than one document.)

3 Click Bring Online.

The Bring Online Information dialog box appears.

Bring Online Information x|

Docurnert: IBmwse Catalog

Reason: [Document taken offline by Unknown on 34152007 1:41 PM.
FReason: to work on it at home.

Drezcription -
af Changes: _I

™ Remove the offine document from the file spstenn

Ok Cancel Help
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4 In the Description of Changes box, enter a description of the changes made to the
currently selected document while it was offline (if any).

5 If you are bringing multiple documents back online and the changes apply to all
subsequent documents, select the Apply to All check box.
If you do not select that check box, the Bring Online Information dialog box
appears for each subsequent document you bring online in this session, and you
must enter changes for each document individually. You can select Apply to All for
any document you bring online in the session to apply the changes to all
subsequent documents.
For example, if you are bringing back online four documents named Doc1, Doc2,
Doc3, and Doc4, and you do not select Apply to All while entering information for
Docl, but you do select Apply to All while entering information for Doc2, the Bring
Online Information dialog box does not appear for Doc3 or Doc4.

6 Click OK.

Note: A Microsoft Word warning message states that the document you are
bringing online contains macros. Click the Enable Macros button.

If you have deleted requirements in an offline document, RequisitePro notifies you
how many requirements you have deleted, and it asks if you want to update the
online document with the changes.

7 Click Yes to accept updating the document, or click No to decline updating the
document.
If you do not update the document, RequisitePro does not bring the document
back online.

Bringing Documents Online Without Saving Changes

If you are the offline author or a member of the Administrators group, you can bring a
document back online without saving any changes you made while it was offline.

1 To open the Offline Documents dialog box, do one of the following:
2 In the Word Workplace, click RequisitePro > Document > Offline Documents.

2 On the Tool Palette, click Document > Offline Documents.

110 Chapter 7 - Working with Documents



The Offline Documents dialog box appears.
x

— Online documnent

Mame Display Types): |A|| Types vl

Anange Shipment UCs -

Check Order Status ucs

CheckOut Ucs

ClassicsCD Supplementary S pecification SUP Take Offline... |
ClagsicsCD Vision Documnent WIS

Glogzary GLS

Shap for CD s =

Offline document:

Mame Type Authar

UCS  Unknown B Oiflie.. |
Cancel Offine.. |
Oftline Info... |

Cloge | Help |

2 In the Offline documents list, select the document you want to bring back online
without saving offline changes. (Use a multiple select action to select more than
one document.)

3 Click Cancel Offline. A message appears, asking you to confirm the deletion of the
offline changes. (If you are bringing multiple documents back online, this message
appears only once for all documents.)

4 Select the Remove offline document files check box to delete the offline documents
from the directory in which they were stored.

5 Click Yes. The online version of the documents is restored.

Reading Offline Documents

You can read a document that another user has taken offline. RequisitePro displays
the document in read-only mode in the state it was in before the other user took it
offline.

If you are the offline author or a member of the Administrators group and you open
the document in RequisitePro, you can choose to bring it back online or open it in the
state it was in before it was taken offline.

1 To open the Open Project and Documents dialog box, do one of the following:
2 On Tool Palette, click Document > Open.
s In the Word Workplace, click RequisitePro > Document > Open.

2 Click the offline document in the Select Document(s) list that you want to open.
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3 Click OK. The Offline Document Open dialog box appears, identifying the user
who took the document offline.

Offline Document Open E

Document ‘GBS Product Requirements Document' was taken offline by
uzer "Sandy’

{Bring driine]  Open Fiead Orly LCancel Help

4 Do one of the following:

2 If you are the offline author or an administrator, click Bring Online to bring the
document back online.

2 Click Open Read Only to open it in the state it was in before you took it offline.

Note: You cannot access the Bring Online button if you are not the offline
author or an administrator.

s If another user took the document offline, click Open Read Only to open the
document for reading.

Using Word Master Documents

Using master documents in Microsoft Word can be very helpful for viewing and
printing a collection of smaller subdocuments as one document. All subdocuments
within the master document can be printed with consistent page numbering. Master
documents are a feature of Microsoft Word. You should not attempt to create, import,
or manage master documents from within RequisitePro.

Consider the following guidelines when using master documents:

» Archive the project before creating subdocuments. (For information on archiving
projects, refer to Archiving Projects on page 212.)

* The master document should not be a RequisitePro document; the subdocuments
can be RequisitePro documents. This prevents redundant requirements and
broken traceability links.

* Do not edit requirement text in the subdocuments outside of RequisitePro.

* Do not edit the subdocuments in RequisitePro while viewing the master document
in Microsoft Word.

To prepare RequisitePro documents to be used as subdocuments, save them in Word
format:
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1 On the Tool Palette, click Project > Properties.

2 On the General tab of the Project Properties dialog box, clear the check box Save
documents in Requisite format.

Note: This removes all project security from these requirements documents and
they can be modified outside RequisitePro, so clear this check box only when you
are preparing subdocuments for viewing or printing from a Microsoft Word
master document.

3 Open and save the documents in the project that you want to use as
subdocuments.

Important: After viewing and printing the master document in Microsoft Word, open
the Project Properties dialog box again and select the check box Save documents in
Requisite format. Open the subdocuments and save them. This reestablishes project
security for those documents.

For more information on using master and subdocuments, refer to the Microsoft
Word documentation.
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Working with
Requirements

A requirement describes a condition or capability to which a system must conform; it
is either derived directly from user needs or is stated in a contract, standard,
specification, or other formally imposed document. Examples of requirements
include inputs to the system, outputs from the system, functions of the system, and
attributes of the system and the system environment.

Requirements may be described in terms of the “FURPS” model, which categorizes
the major types of requirements as follows:

* Functional requirements: feature sets, capabilities, and security

» Usability requirements: human factors, aesthetics, consistency in the user
interface, online and context-sensitive help, wizards and agents, user
documentation, and training materials

» Reliability requirements: frequency and severity of failure, recoverability,
predictability, accuracy, mean time between failure

» Performance requirements: conditions imposed on functional requirements

* Supportability requirements: testability, extensibility, adaptability,
maintainability, compatibility, configurability, serviceability, installability, and
localizability

In Rational RequisitePro, requirements contain a name and text that can be qualified
with attributes. Attributes provide specific details about a requirement, such as cost,
priority, and status.

You can create requirements in a view or in a requirements document. All
requirements created in RequisitePro are stored in the project database. After a
requirement is created, you can do the following:

*  Move or copy the requirement to a document or a view
* Qualify the requirement by assigning attributes
= Trace the requirement to and from other requirements

You can use hierarchical relationships to subdivide a general requirement into more
explicit requirements. Child requirements provide additional detail about their parent
requirement.

115



A requirement’s name, text, attributes, and relationships can be modified in both the
Views and Word Workplaces. You can read the information in context and add
information that supports and justifies the requirements.

Using the in-view editing feature, you can edit and create requirements directly
within an Attribute Matrix view. Simply click on a selected requirement in the view to
start editing the requirement name, text, or attributes. (You can also create
requirements directly in the view without opening a dialog box.) You can create
requirements in Traceability Tree and Traceability Matrix views using the
Requirement Properties dialog box.

When you create a requirement in a document, RequisitePro places hidden text at the
beginning of the description to hold the requirement’s tag. This hidden text is
underlined with a dotted line. If information is typed in this tag area, it is formatted as
hidden text and is visible only when Microsoft Word’s Hidden Effects feature is
turned on (Format > Font > Hidden Effects). To reformat the text to normal, use Word'’s
Format > Font feature. The text of the requirement should be in normal text only.
Requirement text can be articulated as text, graphic elements, OLE objects, or
Word-linked files.

Extended editing of documents (available from the Project Properties dialog box,
Documents tab) allows you to change requirement text outside a document: from a
view, from RequisiteWeb, from the RequisitePro Extensibility Interface, or from
integrated tools. You can update requirement text without opening the document.
This allows multiple people to simultaneously edit requirements within a single
document. All changes are tracked in the database.

The Embedded Elements Detection Wizard searches all requirement text located in
project documents for nontextual elements, such as graphics, numbered lists,
formatting, Microsoft Word-linked files, or OLE files, to help you from losing these
nontextual elements if you enable extended editing. These nontextual elements
cannot be edited outside the document, even if extended editing is enabled.
Additional information about this wizard is available from online Help.

Creating Requirements

All requirements that are created in RequisitePro are stored in the project’s database.
Once created, a requirement can be modified, moved, and copied within the project
and traced to and from other requirements in the same project or across projects.

When a requirement is created, RequisitePro stores the following information in the
database:
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»  The requirement name. A user-defined title for a requirement; it must not exceed 128
characters. Like tag and text attributes, the name can be used to reference
requirements. The name is displayed by default in all RequisitePro views. All
requirements must have either a name or text (or both), but requirements located
in documents must have text. A name is not required to be unique, and you can
change it at any time if you created the requirement or belong to a group that has
update permissions.

= The requirement text. Requirement text is the full textual content of a requirement. If
the requirement is located in a document, the requirement text may include
embedded and linked objects, such as graphics, tables, and Microsoft Word files.

v Attribute values.

Creating a Requirement in a Document

When you create a requirement in a document, RequisitePro performs the following
operations:

» The selected requirement text information is bracketed with bookmarks.
» The following information is associated with the new requirement:
s Requirement tag identifier. A requirement tag consists of a prefix and a number.

s Color and style format. If the requirement type has color and style, the new
requirement is formatted with these settings.

2 Requirement attributes. The new requirement is associated with the attributes
established for the requirement type. Attributes can be viewed in the
Requirement Properties dialog box.

» For hierarchical relationships, the requirement is assigned a parent based on the
parent you select in the Requirement Properties dialog box, Hierarchy tab. (For
more information on parent-child relationships, refer to Working with Hierarchy on
page 143.)

Note: The requirement and its attribute values are not saved to the project database
until you save the document.

If you plan to edit the requirement text outside a document, note that the Embedded
Elements Detection Wizard searches all requirement text located in project documents
for nontextual elements, such as graphics, numbered lists, formatting, or OLE files.
This search helps prevent you from losing these nontextual elements if you select
extended editing. With this option selected, RequisitePro prevents you from
overwriting the requirement text and embedded nontextual elements in the
document with text from the database.
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If you include the following in the text of a requirement, you will not be able to edit
the requirement text outside the document (even when the extended editing feature is
selected):

»  OLE objects (both embedded and linked)

» Fields (for example, author, title, subject)

» Pictures (both inline and floating)

» Tables

* Annotations (comments, footnotes, bookmarks, hyperlinks)
»  Subdocuments

» Lists containing more than a single item (including bulleted and numbered
headings or other styles, both sequential and outline)

When you click Next, RequisitePro begins a search for these elements. The number of
requirements in your project documents determine how long this search takes. After
the initial search, RequisitePro displays a list of affected documents. If there are any
errors encountered during the search, you can rerun the wizard later, and
RequisitePro will search only those documents that have not been successfully
processed.

The Embedded Elements Detection Wizard is only required for searching
requirements created with previous versions of RequisitePro (4.5 or earlier). Any new
document requirements are automatically checked for embedded elements. You do
not need to run the wizard for new requirements.

Note: Before you start the wizard, review the document paths in the Document
Properties dialog box to make sure all the paths are accessible.

Creating a Requirement

1 Inthe document, select the information (text, graphics, OLE objects) that will
become part of the requirement. (If you do not highlight text, you will be
prompted to enter text for the requirement.)

Note: If you include pictures or objects in requirement text, make sure to clear the
Float over text check box in the Word 97 Insert Picture or Object dialog box that is
used to position the item. In Word 2000, use the In line with text option on the
Format > Picture/Object > Layout dialog box tab. (For information about including
Word-linked files in requirement text, see Inserting Microsoft Word-linked Files in
Requirements on page 122.) If you plan to use the requirements document in
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conjunction with Microsoft Project, limit the text description of the requirement to
255 characters; this will accommodate the length limitation of a task description in
Microsoft Project.

2 Do one of the following:

2 In the Word Workplace, either click RequisitePro > Requirement > Create, or
right-click and select Create Requirement from the shortcut menu.

2 On the Tool Palette, either click Requirement > Create, or click the Create
requirement button.

The Requirement Properties dialog box appears.

Requirement Properties: FEATpendingl
General | Rewizion | Attributes | Traceability | Hierarchy I Discuzzions
Type: IFE.&T: Feature Requirement Type j
Hame: |E-mail notification
Teut E-mail notification for customers when new titles are added that d

may be of interest to them

[]

Location: | ClassicsCD Yision Documet |

Ok I Cancel | Help |

3 Click the General tab. Type the requirement name in the Name field, and click the
down arrow in the Type field and select a requirement type with which to
associate the requirement. The Tag text at the beginning of the requirement text
automatically includes the Pending tag. You can click on the other tabs and type
the appropriate information to define the requirement.

4 Click OK.

5 To save your changes, click RequisitePro > Document > Save in the Word
Workplace or Document > Save on the Tool Palette.
RequisitePro saves the document, updates the database, and assigns a requirement
number to the requirement (in place of the Pending tag).

Note: If you press ENTER after a marked requirement, the requirement style (such as
double underline) and color are carried to the next line. Press CTRL and the spacebar
before typing, and the Word style is reset to Normal.

Using Fast Create

Use RequisitePro’s Fast Create feature to create a requirement without opening the

Requirement Properties dialog box.
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1 Select the text in the document that will become the requirement.
(If you do not highlight text, the Requirement Properties dialog box opens. Refer
to the preceding section.)

2 Press the SHIFT key and click the Create a requirement button on the Tool Palette.
t ] RequisitePro bypasses the Requirement Properties dialog box and creates the
requirement based on the default requirement type chosen for the requirements
document.

Creating Multiple Requirements

Use the Requirement > Block Create command to create multiple requirements from a
block of selected text in a document. When you select this command, the Requirement
Block Create dialog box opens. You specify the keywords to use for the requirements
and indicate whether the requirements are in sentences or a paragraph.

RequisitePro uses three methods to distinguish individual requirements in the
selected block of text:

» Key words. RequisitePro searches for a specific word, such as “shall” (the default)
or any word you specify in each sentence or paragraph (according to the options
you select).

»  Text delimiters. RequisitePro searches for text contained within specific text
delimiters, such as <>, { }, [ ], BEGINREQ ENDREQ. You can designate text to become
a requirement by surrounding the text with any delimiters you choose. We
recommend you use a different character on each end of the text, such as open and
close brackets [ ].

= Word style. RequisitePro searches the text for specified style settings, such as
“Heading 1” or “Body text” or highlighted text. The styles in your current
document outline are loaded into the Styles box.

To create multiple requirements from a block of text:
1 Create or open a requirements document and type the text of the requirements.

2 Highlight the information (text, graphics, OLE objects) that will become
requirements.

3 On the Tool Palette, click Requirement > Block Create.
The Requirement Block Create dialog box appears.

4 Click the down arrow at the Requirement Type field and select a requirement type
with which to associate the block of requirements.
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5 Click Set Defaults to open the Set Requirement Defaults dialog box, where you can
enter default attributes, hierarchy, traceability, and a change description for the
requirements you create. Then click OK.

6 In the Requirement Block Create dialog box, click on one of the following options
to indicate a method of distinguishing each requirement in the block of text:

s Keywords. Type keywords in the Keywords field; click Add to add the
keywords to the requirements criteria field. Select either the Match case check
box to make the keyword match the case of the typed text or the Use * as
wildcard check box if you want to use a wildcard character in the Keyword field.
(If you want to create requirements from the selected text for each sentence or
for each paragraph without parsing based on a keyword, type only an * and
select the Use * as wildcard check box.)

a  Text delimiters. Type a beginning and end delimiter in the indicated field and
click Add.

2 Word styles. Select a style from the styles list and click Add.

Note: The dialog box changes to include specific options for each of the above
choices.

You can use more than one criteria to differentiate the individual requirements.
Add keywords, text delimiters, and Word styles to the search list by clicking each
button in turn. Keep in mind that RequisitePro searches the document in the order
listed above: keywords first, text delimiters second, and word styles last.

7 Select a source (either sentence or paragraph) from which RequisitePro will search
for keywords to differentiate the requirements.

8 When you have finished adding requirements criteria, click Create.

RequisitePro checks the highlighted text for the selected criteria and reports any
text that matches your criteria in the Requirement Found dialog box:

2 Click Yes to accept the proposed requirement.
2 Click No to reject the proposed requirement.
s Click Yes to All to accept all proposed requirements.

9 When all proposed requirements have been reviewed, the Status dialog box
appears. Click Close.
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Inserting Microsoft Word-linked Files in Requirements

You can include Microsoft Word-linked files as part of requirement text. If you
change the linked file, any traceability or hierarchical relationships with the
requirement are marked as suspect.

You can link to Microsoft PowerPoint files, Word documents, Excel spreadsheets,
bitmap files, and other types of files. Do not link to RequisitePro documents. You can
include other OLE objects in requirement text, but changes to the files will not mark
traceability or hierarchical relationships as suspect. You must edit requirement text
from the document if the text contains linked files, OLE objects, or embedded objects.
For further information, see “In-view editing and extended editing” in online Help.

You can use the following Microsoft Word commands to create linked files that can be
included in RequisitePro requirement text:

= Insert > File
= |Insert > Picture > From File
= Insert > Object

There are additional ways to insert linked files in Microsoft Word (for example, Edit >
Paste Special and Insert > Field). If you are using the Insert > Field command, the
following types of Microsoft Word Links and References are supported:

= Link
= IncludeText
* IncludePicture

Select the Links and References category in the Field dialog box and select the Field
names. For more information about using the above Word commands, refer to
Microsoft Word online help.

To insert a Microsoft Word-linked file in requirement text:

1 Open a RequisitePro document and click where you want to insert the file. This
can be in the text of an existing requirement or anywhere in the document where
you plan to add a new requirement.

2  On the Microsoft Word menu, click one of the following:
= Insert > File
2 Insert > Picture > From File

2 Insert > Object
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3 In the dialog box that appears, browse to the file you want to insert and do one of
the following:

2 To insert a file, select the file you want to insert and click Link > Insert as Link.
(Word 97 users must select the Link to File check box.)

= Toinsert a picture, select the picture you want to insert and click Insert > Link to
File. (Word 97 users must select the Link to File check box.)

s To insert an object, select the Create from File tab in the Object dialog box, and
type the name of the file. (You can also click the Browse button, navigate to the
file you want to insert, and select it.) Click Insert. In the Object dialog box, select
the Link to file check box and click OK.

Note: Do not insert other RequisitePro documents.
4 If you are creating a requirement, do the following;:

s Select the text that you want to include as requirement text for the new
requirement. Include the linked file in that selection.

2 On the Tool Palette, click Requirement > Create. The Requirements Properties
dialog box appears.

2 In the Name field, provide a name for the requirement. Notice that the Text field
includes the path of the inserted object. Click OK.

5 For either a new or modified requirement text, click RequisitePro > Document >
Save to save the Word-linked file as part of the requirement text.

In the Views Workplace, the Requirements Properties dialog box, and any integration
dialog boxes, the requirement text includes the path of the linked file and the date and
time the file was last modified:

<rp.link file:="path” ts:=”"dd-MM-yyyy hh:mm:ss SGMT” />

Note: If you do not see the linked file in the requirement text, click F9 to refresh Word.
If the linked file path still does not appear in the requirement text, you have inserted
an object instead of a linked file.

Inserting Microsoft Equations in Requirements

If you want to use RequisitePro’s suspect links feature with Microsoft equations, you
must insert the equation in a Word document and then insert that document in
requirement text. If you insert the equation as an object rather than as a Word-linked
file, changes to the equation do not trigger suspect links.
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To insert a Microsoft equation into a RequisitePro requirement:

1 Create a Microsoft Word document containing the equation. You may want to
create one document per equation if you want to detect changes to each equation
individually.

2 Insert the Word document that contains the equation in RequisitePro requirement
text by doing the following:

s Open the RequisitePro document.
2 On the Microsoft Word menu, click Insert > File.

2 In the dialog box that appears, browse to the Word document that contains the
equation.

2 Select the document and click Insert > Insert as Link. (Word 97 users must select
the Link to File check box.)

3 Create a requirement containing the Word-linked file by doing the following:

2 Select the text that you want to include as requirement text for the new
requirement. Include the linked file in that selection.

2 On the Tool Palette, click Requirement > Create. The Requirements Properties
dialog box appears.

s In the Name field, provide a name for the requirement. Notice that the Text field
includes the path of the inserted object. Click OK.

4 Click RequisitePro > Document > Save to save the Word-linked file as part of the
requirement text.
Displaying Linked Files Outside the Document

In the Views Workplace, the Requirements Properties dialog box, and any
integrations dialog boxes, the requirement text includes the path of the linked file and
the date and time the file was last modified:

<rp.link file:="path" ts:="dd-MM-yyyy hh:mm:ss GMT"/>

We recommend using Universal Naming Convention path names if you are sharing
documents with other RequisitePro users.

Traceability

When you establish a traceability relationship or hierarchical relationship between
requirements that include linked files, RequisitePro alerts you to changes to the linked
source files. You can edit the linked file outside of RequisitePro at any time.
RequisitePro checks for changes to the linked file when the RequisitePro document is
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saved, and the relationships are marked as suspect only after the document is saved.
A relationship is marked as suspect if the link references a directory or a file that does
not exist, but a relationship is not marked suspect if the directory cannot be located.

Troubleshooting While Creating Requirements

If you experience problems while creating requirements in a project document, check
for the following conditions to identify and solve the problem:

»  Verify that the highlighted selection does not contain hidden text at the beginning or the
end of the selection. Because RequisitePro uses hidden text to delineate
requirements, it prevents the creation of a requirement with hidden text at its
beginning or end.

v Verify that the highlighted selection is not inside or overlapping another requirement.
Requirements cannot be nested or overlap one another.

Creating a Requirement in a View

You can create requirements in any view. In a Traceability Matrix or a Traceability
Tree, you can enter data in the Requirement Properties dialog box. In an Attribute
Matrix, you can insert a new requirement directly into the matrix and set requirement
name, text, and attributes before saving it.

When you create a requirement in the database, RequisitePro performs the following
operations:

» The following information is associated with the new requirement:

s Requirement tag identifier. A requirement tag is composed of a prefix and a
number.

2 Requirement name.
2 Requirement text.

2 Requirement attributes. The new requirement is associated with the attributes
established for the requirement type.

» Using the Requirement > Create command in a view creates a requirement at the
root level (that is, it has no parent). To create child or sibling requirements, refer to
Creating Child Requirements in a View on page 143 and Creating Peer Requirements on
page 145.
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Creating Requirements in a Traceability Tree or Traceability Matrix

You create requirements in a Traceability Tree or Traceability Matrix by using the
Requirement > Create menu command and entering data in the Requirement
Properties dialog box.

1 In the Views Workplace, open a Traceability Tree or a Traceability Matrix based on
the requirement type for the requirement you want to create.

2 Do one of the following:
2 Click Requirement > Create.
s Right-click and select Create from the shortcut menu.

The Requirement Properties dialog box appears.

Requirement Properties: FEAT pending [ %]
General | Fiexizion I Attributes I Traceability I Hierarchy I Dizcuszions
Tupe: IFEAT: Feature Requirement Type j
Mame: IBrowsel
Text Easy Browsing for available titles ;I
Location: | Database |
QK | Cancel | Help |

RequisitePro populates the Type and Location fields:

2 The new requirement inherits the requirement type displayed in the view.
Select another requirement type from the Type list to change the requirement’s

type.

2 The Location text box indicates the requirement is located in the database only
and not in a document.

3 Type the new requirement name and text and click OK.

RequisitePro creates a requirement tag based on the requirement type’s prefix. A
sequential number is assigned to the requirement based on the numbering scheme
assigned to that requirement type.

Creating Requirements in an Attribute Matrix

In an Attribute Matrix, you can create a requirement in the database by directly
inserting the requirement into the matrix.
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Open an Attribute Matrix based on the requirement type for the requirement you
want to create.

Do one of the following to create a requirement in the matrix:

2 Select the last row (marked <click here to create a requirement>) and
double-click or press the spacebar.

2 Click Requirement > Create.
s Press the INSERT key.
The Text Edit drop-down box appears.

Note: If you want to use the Requirement > Create and INSERT key options to
create requirements directly in the matrix in the Text box, go to Tools > Options (on
the Tool Palette) and make sure that the In-view requirements creation (without
dialog box) check box is selected. Otherwise, the Requirement Properties dialog
box appears. (See the preceding section.)

Type a requirement name and tab to the field below to enter text describing the
requirement.

Note: If you are planning to use this project in conjunction with Microsoft Project,
limit the text description of the requirement to 255 characters; this will
accommodate the length limitation of a task description in Microsoft Project.

Do one of the following to save the information:
s Press the TAB key.

2 Click in another cell.

2 Press the ENTER key.

Note: Check settings in the Options dialog box. The ENTER key inserts new line
check box must be cleared if you want to use the ENTER key to save
requirement information in the Attribute Matrix.)

RequisitePro creates a new empty row (marked with an * and <click here to create
a requirement>) below the row you are editing and moves the cursor over to the
first attribute cell for the new requirement you are inserting. A pencil icon appears
at the beginning of the row, indicating that the requirement is in edit mode and
that changes are not yet saved.

Select or type an attribute, and tab to other attribute columns to make any changes
from the default attribute values.
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6 Tab to the next row, or click outside the row, when you are finished setting
information about the new requirement.
RequisitePro creates a new requirement and assigns the next available tag to the
requirement.

7 Enter data for a new requirement or press ESC to cancel the edit mode in the
Attribute Matrix.

Revising Requirement Properties

Use the Requirement Properties dialog box to view or modify requirement
information, including attribute values, traceability relationships, hierarchical
relationships, discussions, and change descriptions. (For more information, refer to
the chapters Working with Discussions on page 73, Working with Hierarchy on page 143,
and Working with Traceability on page 153.)

Opening the Requirement Properties Dialog Box
From a requirements document:
1 Place the cursor inside the text of the requirement.
2 Open the Requirement Properties dialog box in one of the following ways:

2 In the Word Workplace, either click RequisitePro > Requirement > Properties, or
right-click and select Requirement Properties from the shortcut menu.

[ﬂ] 5 On the Tool Palette, either click Requirement > Properties, or click the Display
properties button.

From a view:

1 Click the requirement to highlight it.

2 Open the Requirement Properties dialog box in one of the following ways:
s In the Views Workplace, click Requirement > Properties.
»  Right-click and select Properties from the shortcut menu.

s Click the Display properties button on the Views Workplace toolbar.
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Accessing Revision Information

Use the Revision tab in the Requirement Properties dialog box to record and monitor
revision information about the requirement.

General Revision | Attributes |Iraceab|l|ty| Hierarchy |D15CUSS|UHS
— Last saved

Rewvision: 1.0003 Lakel: I

Authar: |DE\/|:||'] |
Change STABILTY: Medium - High 2]
Description

Histary... | ﬂ

Cancel | Help |

* RequisitePro automatically generates an internal revision number for the
requirement in the Revision text box whenever a requirement is modified and
saved. This text box is read-only. Changes to name, text, and attributes cause the
revision number to be implemented. If you make the change in a RequisitePro
view, RequisitePro increments the revision number for the individual requirement
each time you make a change. If you make the change in a document, RequisitePro
increments the revision number for the requirement each time you save the
document.

» Ifachange has been made, click the Label text box to associate a logical name with
a revision number. This step is optional. Any specific revision can be named in this
text box, using any combination of 20 alpha-numeric characters, such as Beta
Release. The label is added to the requirement’s change history. Once applied, it
cannot be changed or removed.

» Use the Change Description text box to record changes made to a requirement.
This text box can contain up to 2,048 characters. (This step is optional.)

» The Date, Time, and Author text boxes are populated by RequisitePro and cannot
be modified.

= Click the History button to display the requirement’s change history.

* Any modifications made to requirements are pending until the document is saved.
When a requirement is committed to the database, its status changes from Proposed
changes... to Last Saved.
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Recording Requirement Changes in Documents

When you modify a requirement’s text in a document, you must describe the reason
for the change.

After you have modified the requirement’s text, make sure the cursor is still in the
requirement and then do the following:

1 To open the Change Description dialog box, do one of the following;:
2 In the Word Workplace, click RequisitePro > Requirement > Annotate Change.
2 On the Tool Palette, click Requirement > Annotate Change.

2 Type the reason for changes.

3 Click OK.

If you attempt to close a document that contains requirement changes without
annotating the changes, RequisitePro displays the Change Description dialog box,
scrolls to the requirement, and prompts you to record a rationale for the change.

Change Description E

Fequirement SUFPL3 haz changed. Please enter a
reazon for this change.

LChange Description:

Changes per customer request, d

|

WD\?DDI}I ta all moditied requirsments in the document

Cancel |

Modifying Attribute Values

Attributes and their corresponding list of default values are defined by the
requirement type of the requirement. Use the Attributes tab in the Requirement
Properties dialog box to assign values to the attributes for a requirement.

To assign values to requirement attributes

1 Open the Requirement Properties dialog box by following one of the options on
page 128.

2 C(Click the Attributes tab.
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The attributes for the requirement are displayed.

Requirement Properties: UC1.2 m
General | Revision Attributes | Traceability | Hierarchy |D15CUSS|UHS
—Adtributes

Friarity: |Med|um LI ;I

Status: |Proposed =l

Cast: [100

Difiiculty: [Medium =1

Stahility [High =l Zi
QK | Cancel Help |

3 Enter attribute values:

2 For list-type attributes, select a value in the list.

»  For entry-type attributes, enter a value in the text box.

Note: To move between fields, use the scroll bar or the TAB key.
4 Click OK.
To modify attribute values from an Attribute Matrix:

You can use shortcuts for changing the attribute values, requirement name, or
requirement text in an Attribute Matrix.

1 Inan Attribute Matrix, do one of the following:
2 Double-click an attribute value or requirement text.

Note: Make sure the Double-click to go to source check box in the Options dialog
box is cleared if you want this option for editing directly in the Attribute Matrix. If
the check box is selected, double-clicking will open the Requirement Properties
dialog box or a document (if the requirement resides in a document).

2 Click the requirement name, text, or attribute, and then press the spacebar.

2 For list-type attributes, select a value in the list. For multiple value list-type
attributes, select one or more values in the list.
For entry-type attributes and requirement name and text, type data in the text box.

Note: In order to modify the requirement text, you must open the project
exclusively and close any open documents that may contain the requirements you
are editing. The Enable Extended Editing of documents check box must be
selected in the Documents tab of the Project Properties dialog box.

3 Press the TAB key to move to other rows that can be edited.
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4 To accept the changes, click outside the row or press ENTER.
(To cancel the editing process without saving changes, press ESC.)

Note: You can also use a multiple select action in an Attribute Matrix to select
more than one attribute value, and then right-click and select Set Value from the
shortcut menu. The Set Value dialog box appears, allowing you to select a value to
use for all selected requirements.

Using the Requirement Name Conversion Wizard

If you have been using a user-defined attribute to serve as a name or label for
requirements in your project, you may want to add the data to the requirement name.
RequisitePro project administrators can populate the requirement name with data
from a user-defined attribute for requirements in a project. The Requirement Name
Conversion Wizard takes you through the process of copying this data.

Note: If the project is secure, you must be a member of the administrators group to
perform this conversion.

The requirement name is limited to 128 characters. If the attribute values you copy to
the requirement name are longer, they will be truncated.

To start the wizard:

Open the Requirement Name Conversion Wizard in Windows Explorer. The
executable, rqregnameconvwiz.exe, is located in the Rational\RequisitePro\bin\ directory.

Associating Requirements with New Types

When you change a requirement’s type, several things can happen:

= Any attribute values associated with the requirement will be changed to the
default attribute values of the new requirement type.

» If the requirement is a parent, the requirement type is also changed for all of its
child requirements.

= If the requirement is a child, the requirement is moved to the root for the new
requirement type, and the requirement no longer has a parent.

For more information on parent and child requirements, see the chapter Working with
Hierarchy on page 143.
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Associating a Single Requirement with a New Type

1 Open the Requirement Properties dialog box by following one of the options in
Opening the Requirement Properties Dialog Box on page 128.

2 Click the General tab.
3 Click the down arrow in the Types field and select a new requirement type.

A dialog box appears, explaining the change process.

Change Requirement Type B
‘wihen changing the type of a requirement, the curment selections for the
uzer-defined attributes for the requirement and all of its descendents will be

replaced by the default selections for the new requirement type.

Continue with changing the type of this requirement?

4 Click Yes. The requirement type is changed in the Requirement Properties dialog
box.

5 Click OK.

Associating Multiple Requirements with a New Type
When you change the requirement type, several things happen:

= Any attribute values associated with the requirements are changed to the default
attribute values of the new requirement type.

» If the requirements are parents, the requirement type is also changed for all of
their child requirements.

= If the requirements are children, they are moved to the root for the new
requirement type, and the requirements no longer have a parent.

Note: Resetting attribute values is a separate procedure after you change the
requirement type and save the document.
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1 In the Views Workplace, open an Attribute Matrix and use a multiple select action
to select multiple requirements.
For requirements in documents, the documents must be opened in RequisitePro
before you begin the following procedure.

2 Click Requirement > Change Type.
A dialog box appears, explaining the change process.

Change Requirement Type B
‘wihen changing the type of a requirement, the curment selections for the
uzer-defined attributes for the requirement and all of its descendents will be

replaced by the default selections for the new requirement type.

Continue with changing the type of this requirement?

3 Click Yes. The Change Requirement Type dialog box appears.

4 In the New Requirement Type list, click the down arrow and select a new
requirement type.

5 Click OK.

The requirements and their children are removed from the Attribute Matrix. When
you display a matrix of the new requirement type, the requirements and their
children are added at the end of the matrix by default.

For requirements in documents, you must save the open document to commit
requirements to the database.

Relocating Requirements

You can move or copy requirements within the same requirements document,
between documents, and between a document and the database. Requirements are
moved by using RequisitePro’s Cut, Copy, and Paste commands.

Cutting, copying, and pasting a requirement include its name, text, attributes, and
traceability relationships.
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Caution: Do not use the Microsoft Word Cut, Copy, and Paste commands to move
requirements. When you use the Word Cut command, it is possible the requirement
could be deleted from the project. In addition, if you cut a requirement from a
document using the Cut command in Word, you cannot paste the requirement into
the project database.

Note: The RequisitePro Cut/Paste commands move the original requirements. The
Copy/Paste commands create new requirements. If pasted in a document, new
pending requirements are inserted. If pasted in a database, new requirements are
created in the database.

Cutting or Copying from a Document
To cut or copy a requirement from a document:
1 Click in the requirement text.
2 Do one of the following:
2 On the Tool Palette, click Requirement > Cut (or Copy).

2 In the Word Workplace, click Requirement > RequisitePro > Cut (or Copy).
RequisitePro cuts or copies the requirement (and its child requirements) from
the requirements document.

To paste the requirement in a document:

You can move or copy the requirement to a new position in the current document or
to another requirements document.

1 Open or click the destination document and place your cursor in the location
where you want to paste the requirement.

2 On the Tool Palette, click Requirement > Paste.
RequisitePro inserts the requirement (and its child requirements) in the specified
location.

To paste a cut requirement into the database:

You may want to remove a requirement from a document and locate it only in the
database. You can paste a requirement into an Attribute Matrix view if it is based on
the same requirement type as the cut requirement. A requirement cannot be pasted
into a Traceability Matrix or a Traceability Tree view.

1 Open or create an Attribute Matrix view based on the same requirement type as
the cut requirement.

2 In the Views Workplace, click Requirement > Paste.
RequisitePro pastes the requirements into the database.
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Cutting or Copying in a View

In order to move a requirement in the database to a document, you can cut it from an
Attribute Matrix and paste it into a requirements document.

»  Use the RequisitePro Cut command to move a requirement, with all of its
relationships, into a document.

» Use the RequisitePro Copy command to make a copy of a database requirement
and paste it into a document. This option creates a new requirement when you
save the requirements document. Copying a requirement duplicates its text and its
attributes, but not its traceability relationships.

Note: For hierarchical requirements, RequisitePro copies the requirement as a peer
requirement at the same level in the parent/child hierarchy. (For more information,
see the chapter Working with Hierarchy on page 143.)

To cut or copy a requirement from the database:
1 In the Views Workplace, open an Attribute Matrix containing the requirement.

2 Select a requirement that is not already located in a document.
(Use a multiple select action to select multiple requirements.)

3 Click Requirement > Cut or Requirement > Copy.
To paste the requirement into a requirements document:
1 Open the requirements document and click the location to paste the requirement.
2 Do one of the following:
2 In the Word Workplace, click RequisitePro > Requirement > Paste.

2 On the Tool Palette, click Requirement > Paste.
RequisitePro inserts the requirement (and its child requirements) in the
specified location.
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Rules for Relocating Requirements

Consider the following rules when moving requirements using the RequisitePro Cut,

Copy, and Paste commands:

Requirement ) Requirement Destination
Locati Function
ocation Paste to Database Paste to Document
Document Cut Removes the Relocates the
requirement from the requirement in the
document but saves it in | document.?
the database.!

Copy Creates a new Creates a new
requirement in the requirement in the
database. document.

Database Cut Not Applicable Relocates the
requirement in the
document.

Copy Creates a new Creates a new
requirement in the requirement in the
database. document.’

1 If you cut a requirement from a document and do not paste it into the database, it is removed
from both the document and the database when you save the document.

For parent-child requirement hierarchies: When pasting from a document to the same
document, you can cut and paste only a root requirement or a leaf (the lowest-level child
requirement). When pasting from a document to a different document, you can move a root
requirement and all its children. For more information about parent-child requirements,
refer to the chapter Working with Hierarchy on page 143.

3 For parent-child requirement hierarchies: Only a root requirement can be moved from the
database to a document. For more information about parent-child requirements, refer to the
chapter Working with Hierarchy on page 143.

» Do not use Microsoft Word’s Cut/Paste commands. We recommend that you do not
use Word’s Cut command to cut requirement text for two reasons. The risk of not
capturing the entire requirement (including its bookmarks and tag) and
accidentally deleting the requirement from the project database is greater in Word.
In addition, a requirement cannot be moved from a document into the project
database with Word’s Cut command.

»  Be careful when you use the buffer with the RequisitePro Cut command. Requirements
you cut using RequisitePro’s Cut command go into a proprietary cut buffer. You
should paste a requirement to its new location before cutting or copying another
requirement. If requirements are in the buffer and you cut or copy another
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requirement, the first requirements are placed back in their original location in the
database. If you want to cut or copy multiple requirements, you can do so in the
Attribute Matrix only.

Note: The buffer used in RequisitePro is not the Windows Clipboard. Any
information on the Windows Clipboard is preserved when you cut or copy a
requirement in RequisitePro.

»  Awoid losing OLE objects. If you move a requirement that includes an OLE object
from a requirements document into the project database, the OLE object is lost.
RequisitePro does not currently support OLE objects in its database. Because the
loss of the object is considered a change to the requirement description, the
requirement’s direct traceability relationships become suspect.

Refreshing Requirement Color and Style in a Document

A specific color and style distinguishes requirements that belong to a specific
requirement type. For example, you might mark all requirements that belong to the
requirement type feature with a dark green requirement color and a double underline
style. This helps you easily recognize all feature requirements regardless of their
location. Refreshing the color and styles of requirements is useful for restoring
requirements to their proper state when their color and style have been overwritten.

To refresh requirement color and style in a requirements document:

1 Highlight the requirements to refresh.

2 Do one of the following:
s In the Word Workplace, click RequisitePro > Document > Refresh Requirements.
2 On the Tool Palette, click Document > Refresh Requirements.

RequisitePro checks the color and style settings of the requirements in the
document and, if necessary, resets them to the proper settings for the requirement
type.

Note: To remove color and styling and convert the requirement back to plain text, see
Unmarking Requirements in a Document on page 141.
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Rebuilding Requirement Tags in a Document

When a requirement is created in a document, the requirement information is
bracketed by bookmarks and assigned a requirement tag. Select the Show Tags check
box in the Document Properties dialog box to ensure that the requirement tags are
visible both on your display and in the printed document.

Tags can be accidentally corrupted or deleted while editing a requirements document.
Use the Rebuild Tags command to rebuild a requirement tag that is partially or
completely deleted or corrupted. RequisitePro rebuilds the affected tags, then
provides a list of rebuilt requirement tags.

To rebuild requirement tags in a document:

1 Highlight the requirement tags to rebuild.

2 Do one of the following:
2 In the Word Workplace, click RequisitePro > Document > Rebuild Tags.
2 On the Tool Palette, click Document > Rebuild Tags.

RequisitePro rebuilds all the requirement tags in the document.

Renumbering Requirements

Use the Renumber Requirements command to renumber all requirements of a
specified type in a project. This feature is useful to eliminate the “holes” in a
numbering scheme that result when you delete or move requirements. You can
renumber one or several requirement types in one operation. Requirements are
renumbered in the database and in requirements documents. You can select which
requirement type you want to renumber and the order in which you want the
documents processed. (Requirements in documents are renumbered in the order in
which they appear in the document.)

The project must be opened in exclusive mode to use this command. If project security
has been set, you must have project structure permission to renumber requirements.
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To renumber all requirements in a project:
1 On the Tool Palette, click Project > Renumber Requirements.

The Renumber Requirements dialog box appears.

Renumber Requirements E

— Requirement Type

ISH Software Requirement Type j

[+ Eenumber Requirements of this type

Initial Requirement Humber: |1

r— Order of Processing:

Document: BBS Software Requirements Document

ove llp | [ove Qownl

MWOTE: ‘Protect for Revizsions' will be tumed off for al
documents involved in the operation.

QK I Cancel | Help |

2 In the Requirement Type list, select the requirement type that you want to
renumber.

3 Select the Renumber Requirements of this type check box.

Note: To renumber requirements of more than one requirement type, repeat Steps
2 and 3.

4 In the Initial Requirement Number text box, enter the initial requirement number
that you want to set. The default number is 1.

5 To change the order of renumbering for database requirements and documents,
select Database or a document name. Click the Move Up and Move Down buttons
to put the database and documents in the order in which you want them to be
processed. The requirements in the first item listed (the database or a document)
are renumbered first, followed sequentially by the requirements in the second
item, and so on.

Note: A document appears in the Order of Processing list only if it contains
requirements of the selected type.

6 Click OK.
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Deleting Requirements

In general, we recommend that you not delete any requirements after you archive a
project, because deleting a requirement deletes the complete information related to
that requirement, including its history.

RequisitePro does provide a Delete Requirement function that should only be used
prior to archiving a project, when you are getting familiar with the tool. To delete a
requirement after the project is archived, you can use a requirement attribute (for
example, Deactivated, Retired, or Inactive) to indicate that a requirement is no longer
valid.

When you delete a requirement that is linked to requirements that reside in other
projects, the other projects are updated to remove the relationships to/from the
deleted requirement.

Note: Deleting a requirement causes its history and traceability relationships to be
permanently removed from the project database.

Unmarking Requirements in a Document
You have the option of leaving the text in a document when you delete a requirement:

»  Use the Delete (Unmark) or Block Delete (Unmark) command to delete requirements
from the document where they reside and from the project database without
disrupting the text of the document. The requirement text, graphics, or OLE
objects are not removed from the document, but they are no longer recognized as a
requirement. The color and style settings of the requirement are removed and
replaced with the document default style.

» The Delete (Remove) command deletes the requirement text from the requirements
document and removes it from the database.

To unmark a requirement in a document:

1 In the requirements document, click in the requirement text or highlight a
contiguous block of requirements.

2 Do one of the following:
2 In the Word Workplace, click RequisitePro > Requirement > Delete (Unmark).
2 On the Tool Palette, click Requirement > Delete (Unmark).
Note: To delete multiple requirements, use the Block Delete (Unmark) command.

A message appears, asking you to confirm the deletion.
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3 Click Yes. The RequisitePro formatting is removed and the requirement text is
converted to the default text style.

Note: If you do a Block Delete of a parent requirement with child requirements,
the Delete Requirement dialog box appears, asking what you want to do with the
remaining child requirements. If you click Cancel, then it cancels the entire Block
Delete process.

4 Save your changes by doing one of the following;:
2 In the Word Workplace, click RequisitePro > Document > Save.
2 On the Tool Palette, click Document > Save.
The requirement is removed from the database.

Note: To undo an unmark operation, use the Edit/Undo option in Word
repeatedly until the styling, bookmarks, and tags reappear.

Deleting Requirements from the Database

You can delete a requirement from the database in the Views Workplace, provided
that the requirement is not located in a document. (Check the Location attribute in an
Attribute Matrix; requirements have a location listed as “Database” or the file name of
the requirements document.)

When you delete a requirement that is linked to requirements that reside in other
projects, the other projects are updated to remove the relationships to and from the
deleted requirement. Unlike cut requirements, which are placed into a buffer for
pasting within RequisitePro, a deleted requirement is completely removed from the
database.

Note: Deleting a requirement causes its history and traceability relationships to be
permanently removed from the project database.

1 In the Views Workplace, open the Attribute Matrix containing the requirement.

2 Select the requirement in the matrix. (Use a multiple select action to select more
than one requirement.)

3 Click Requirement > Delete. A message asks you to confirm the deletion.

4 C(lick Yes. The requirement is deleted.
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Working with Hierarchy

Hierarchical requirement relationships are parent-child relationships that reflect
direct dependencies between requirements. In addition, these associations provide
powerful tools for change management. With hierarchical requirements, you can
support a requirement with a number of sub-requirements by establishing a parent
requirement and creating child requirements of that parent.

Like traceability relationships (see the chapter Working with Traceability on page 153),
hierarchical relationships are a type of change-managed relationship in Rational
RequisitePro. If a requirement’s name, text, requirement type, or attribute is changed,
the relationships with its children become suspect. You can view and manage suspect
relationships using a Traceability Matrix or a Traceability Tree in the Views
Workplace.

Creating Child Requirements

A child requirement is any requirement that has a parent. Hierarchical relationships
are created in a requirements document or in a view. The parent and child
requirements must both reside in the same document or in no documents. The parent
requirement and all of its children must be of the same requirement type.

These relationships are created in the following ways: you can use the Hierarchy tab in
the Requirement Properties dialog box; you can create them directly in a requirements
document using the RequisitePro > Requirement menu commands in the Word
Workplace; or you can insert them in an Attribute Matrix.

Creating Child Requirements in a View

1 In the Views Workplace, open the view containing the requirement that you
intend to be a parent.

2 Click the requirement. (You can only create a child for one requirement at a time.)
3 Click Requirement > Create Child.

Note: You cannot create a child in a view if the currently selected requirement
(which will become the child's parent) is located in a document.
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s Inan Attribute Matrix, a new row appears directly following the last
requirement with the selected parent, and the Name/Text Edit box appears,
allowing you to add information. See Creating Requirements in an Attribute
Matrix on page 126 for more information.

2 In a Traceability Matrix and a Traceability Tree, the Requirement Properties
dialog box appears. Click the General, Revisions, Attributes, Traceability, and
Discussion tabs to define the child requirement, and type the appropriate
information.

Note that in the Hierarchy tab, the parent requirement is predefined as the
requirement you selected in Step 2. (If you want to, you can change the parent.)

Tab to the next row or click outside the row in an Attribute Matrix, or click OK in
the Requirement Properties dialog box.

RequisitePro creates the child requirement in the database and generates a
requirement tag for the child requirement based on the parent requirement’s
number.

Note: After creating child requirements, review saved views to make sure both
child and parent requirements are displayed. You can modify the query on a saved
view and select the Retain Hierarchical Display check box to include hierarchical
requirements in the view. Then save the view again to keep those changes. (Refer
to Modifying Queries on page 64.)

Creating Child Requirements in a Document

You can create child requirements in a requirements document by assigning a parent.
The assignment is committed to the database when the document is saved.

1

In a requirements document, highlight the requirement that you intend to be a
child requirement.

To open the Requirement Properties dialog box, do one of the following:
2 In the Word Workplace, click RequisitePro > Requirement > Properties.
2 On the Tool Palette, click Requirement > Properties.

2 On the Tool Palette, click the Display the properties... button.

Click the Hierarchy tab.

Select a parent from the Parent list box.

Note: The default is the last parent selected in the document.

Click OK.
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The requirement changes to a pending child requirement of the parent you
selected.

Note: To save the new parent-child relationship in the database, click Document >
Save on the Tool Palette or on the RequisitePro menu in the Word Workplace.
RequisitePro generates a requirement tag for the child requirement based on the
parent requirement’s number.

After creating child requirements, review saved views to make sure both child and
parent requirements are displayed. You can modify the query on a saved view and
select the Retain Hierarchical Display check box to include hierarchical requirements in
the view. Then save the view again to keep those changes. (Refer to Modifying Queries
on page 64.)

Creating Peer Requirements

Requirements have a peer relationship when they are at the same level in the
requirement hierarchy. For example, two requirements are peer requirements when
they are children of the same parent. All requirements at the root level are peer
requirements of one another.

When a requirement is created in a document, it is automatically placed at the same
level as the requirement above it. Refer to Creating a Requirement in a Document on
page 117.

Creating Sibling Requirements in a View

In the Views Workplace (an Attribute Matrix, a Traceability Tree, or a Traceability
Matrix), the automatic creation of a requirement is at the root level. Refer to Creating a
Requirement in a View on page 125. To create a peer requirement of a requirement that
has a parent, use the Create Sibling command.

To create a sibling requirement:

1 In the Views Workplace, open the view containing the requirement you have
chosen for a sibling.

2 Select the requirement.
3 Click Requirement > Create Sibling.

Note: You cannot create a sibling in a view if the parent of the siblings resides in a
document.
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s Inan Attribute Matrix, a new row appears directly following the last
requirement with the same parent, and the Name/Text Edit box appears,
allowing you to add information. See Creating Requirements in an Attribute
Matrix on page 126 for more information.

2 In a Traceability Matrix and a Traceability Tree, the Requirement Properties
dialog box appears. Click the General, Revision, Attributes, Traceability, and
Discussions tabs to define the child requirement, and type the appropriate
information.

Note that in the Hierarchy tab, the parent requirement is pre-defined as the parent
of the requirement you selected in Step 2. (If you want to, you can change the
parent.)

4 Tab to the next row or click outside the row in an Attribute Matrix, or click OK in
the Requirement Properties dialog box.

RequisitePro creates the sibling requirement in the database and generates a
requirement tag for the new requirement based on the parent requirement’s
number.

Note: After creating sibling requirements, review saved views to make sure both
child and parent requirements are displayed. You can modify the query on a saved
view and select the Retain Hierarchical Display check box to include hierarchical
requirements in the view. Then save the view again to keep those changes. (Refer to
Modifying Queries on page 64.)

Changing Parent Requirements

In a requirements document or an Attribute Matrix or Traceability Tree, you can
assign single or multiple hierarchical requirements to a different parent. When you
assign a requirement to a new parent, its entire sub-tree of children is also moved to
that parent.

When children are assigned to a different parent, all hierarchical relationships
between the new parent and its immediate children are marked as suspect. The
relationships between the children and their children are not marked as suspect. (See
also Suspect Relationships on page 160.)

Note: After creating new child requirements, review saved views to make sure both
child and parent requirements are displayed. You can modify the query on a saved
view and select the Retain Hierarchical Display check box to include hierarchical
requirements in the view. Then save the view again to keep those changes. (Refer to
Modifying Queries on page 64.)
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Assigning a New Parent to a Single Requirement

You can reassociate a hierarchical requirement with a new parent of the same
requirement type using the Hierarchy tab in the Requirement Properties dialog box.

Note: To change parents of requirements located in documents from the Views
Workplace, the document must be opened (and you must have the ability to edit it)
before you begin the following procedure.

To assign a new parent:
1 Do one of the following:

2 In the Word Workplace, click anywhere in the requirement text. Then click
RequisitePro > Requirement > Properties.

2 In the Word Workplace, click anywhere in the requirement text. On the Tool
Palette, click Requirement > Properties.

2 In the Views Workplace, open a view and select the requirement. From the
Views Workplace toolbar, click Requirement > Properties.

The Requirement Properties dialog box appears.

2 C(lick the Hierarchy tab.

SR1.7 E
General I Revision I Attributes IIrac:eabiI'rty Hierarchy |Di_sc:ussions
— Barent

SR1: The sps izplay & Customer Information Screen upon
— Children
SR1.7.1: Mame

SR1.7.2: Address

SR1.7.3: Phane number

5R1.7.4: Checking Account Mumbers
5R1.7.5: Checking Account Balances
5R1.7.6: Checking Account Activity Histories.

QK | Cancel Help

3 Select a parent from the Parent list.

4 If the parent is not displayed in the list, select <choose parent...>.
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The Parent Requirement Browser dialog box appears.

Parent Requirement Browser E
— Display
Bequirements N -
o ISH. Software Requirement Type j
Located in: IDoc: QES Software Requirements Document j

SR1.1: Mame

SR1.2: Address

SR1.3: Phone Mumber

SR1.4: Account Mumbers

SR1.5: Loan Mumbers

5R1.6: Balance information for all Accounts/Loans

SR2: The spstem shall save all updated data to the Cust
SR3: The spstem shall generate an error meszage stating
SR4: The spstem shall dizplay the SAVINGS ACCOUNT scree
SR4.1: Name

SR4.2: Address

5R4.3: Phone number

SR4.4: Savings Account Mumbers

SR4.5: Savings Account Balances

SR4.E: Savings Account Activity Histories

SRE: The spstem shall inhibit editing of Customer Infor

SRE: The spstem shall allow editing in all 5avings Acco d
CO7. Tl snmbmres aleall sciim all s dmbmres sbimas imman e

0k | Cancel | Eind. | Hep |

5 Select a parent requirement from the list. To locate a specific requirement, click the
Find button.

6 After selecting the parent requirement, click OK.
7 In the Requirement Properties dialog box, click OK.

8 The requirement changes to a child requirement of the parent you selected. New
requirement tags are generated for the child requirement and its sub-tree of
children, based on the new parent requirement’s number.

Note: For requirements in documents, you must save the open document to
commit requirements to the database.

Assigning a New Parent to Multiple Requirements

In an Attribute Matrix, you can reassociate more than one hierarchical requirement
with a new parent of the same requirement type. All selected requirements are
assigned to the same new parent.

Note: If any of the requirements you want to change are in documents, the document
must be opened (and you must have the ability to edit it) before you begin the
following procedure.
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To assign a new parent to more than one requirement:

1 In the Views Workplace, open an Attribute Matrix and then select the
requirements.

2 C(Click Requirement > Change Parent.

The Select New Parent dialog box appears.

Select Hew Parent E

Mew Parent:

dizp

QK I Cancel | Help

3 In the New Parent list, select a parent.

4 If the parent is not displayed in the list, select <choose parent...>. The Parent
Requirement Browser dialog box appears, as shown in the previous procedure.

5 Select a parent requirement from the list. To locate a specific requirement, click the
Find button.

6 After selecting the parent requirement, click OK.

7 In the Select New Parent dialog box, click OK.
The requirements become child requirements of the parent you chose. A new
requirement tag is generated for the child requirements and their sub-trees of
children, based on the new parent requirement’s number.

Note: For requirements in documents, you must save the open document to
commit requirements to the database.

Deleting Hierarchical Requirements

In general, we recommend that you not delete any requirements after you have
archived a project, because deleting a requirement deletes all the information related
to that requirement, including its history. (Refer to Deleting Requirements on page 141.)

To delete requirements that are located in documents, go to the Word Workplace. To
delete requirements that are located only in the database, go to an Attribute Matrix in
the Views Workplace.

When you delete a requirement that is traced to or traced from requirements that
reside in other projects, the other projects are updated to remove the relationships.
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Unlike cut requirements, which are placed into a buffer for pasting within
RequisitePro, a deleted requirement is completely removed from the database.

To delete a hierarchical requirement:
1 Do one of the following:

2 In the View Workplace, open the Attribute Matrix and click the requirement to
delete. (Use a multiple select action to select multiple requirements.) Click
Requirement > Delete.

2 In the Word Workplace, open the document, highlight the requirement to
delete, and do one of the following:

e Click RequisitePro > Requirement > Delete (Remove).
e On the Tool Palette, click Requirement > Delete (Remove).
A dialog box appears, asking you to confirm the deletion.
2 Click Yes to delete the requirement.

If the requirement has children, the Delete Requirement dialog box appears.

Delete Requirement E

“f'ou are about to delete requirement SR13 which containg
child requirements.

‘what do you wizh to do with the child requirements?

& Delete all child requirements recursivel

" Aszign all child requirements to a new parent

Mew Parent: |<n0ne> 'l
QK I Cancel | Help |

Note: If you are deleting multiple requirements in the Attribute Matrix, the Delete
Requirement dialog appears for each parent requirement.

3 Do one of the following:

2 Select the Delete all child requirements recursively option to delete the
requirement and all its children. This option removes all traceability and
hierarchical relationships.

2 Select the Assign all child requirements to a new parent option to delete the
requirement and save its children. This option reassigns all children to a new
parent you select in the list. When the children are reassigned, all hierarchical
relationships between the new parent and its immediate children are marked
suspect.

4 When you have made your selection, click OK.
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If you are working in the Views Workplace, the requirement is deleted immediately
when you click the Delete button. If you are working in the Word Workplace, save the
requirements document to commit the deletion to the database.

Suspect Relationships

A relationship between requirements becomes questionable or suspect if RequisitePro
detects a requirement’s name, text, requirement type, or attributes have been
modified. In the Views Workplace, you can manually mark a hierarchical relationship
suspect or clear a suspect relationship.

*  When you modify a parent requirement, RequisitePro marks as suspect the
relationship between the parent and all its immediate children.

= When you modify a child requirement, RequisitePro does not mark as suspect the
relationship between the child and its parent, although the child’s relationship
with other requirements is marked as suspect.

*  When children are reparented, all hierarchical relationships between the new
parent and its immediate children are automatically marked as suspect. The
relationships between the children and their children are not marked as suspect.

Displaying Suspect Hierarchical Relationships

4

You can display suspect hierarchical relationships using the Traceability Matrix and
the Traceability Tree views. In the Views Workplace, the suspect relationship is
identified by a red diagonal line through the requirement icon.

The Auto Suspect command monitors a requirement’s change history and displays a
suspect signal when requirements are changed. Use the Project > Auto Suspect
command to enable or disable automatic checking for changes that affect the
traceability or hierarchical relationships between requirements in the project.

If Auto Suspect is disabled, RequisitePro does not monitor changes in requirements
and does not mark relationships as suspect. There are times when this mode is
desirable (for example, when you are revising spelling mistakes in your documents
and do not want those revisions to cause your relationships to become suspect).

With Auto Suspect enabled, RequisitePro constantly monitors requirements for
changes that may affect traceability or hierarchical relationships. If there is a change in
a requirement, the state of the requirement’s relationships is automatically changed to
suspect. If you have cross-project traceability active, requirements in external projects
are also monitored.
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Auto Suspect is available by default. If you cancel Auto Suspect, it is automatically

made available the next time the project is opened. You can also make it available
with the Project > Auto Suspect command.

Clearing Suspect Relationships

You can reset a parent-child relationship that has been marked suspect by manually
clearing it in the Traceability Matrix or Traceability Tree:

1 Do one of the following:
a  In a Traceability Matrix, select one or more intersection points in the matrix
where a traceability link has been created.

=)

In the Traceability Tree, select one or more requirements to modify.

2 In the Views Workplace, click Requirement > Clear Suspect.
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Working with Traceability

In Rational RequisitePro, traceability is a dependency relationship between two
requirements. Traceability is a methodical approach to managing change by linking
requirements that are related to each other.

Like hierarchical relationships (see the chapter Working with Hierarchy on page 143),
traceability relationships are change-managed relationships in RequisitePro. If either
end-point of the connection is changed, the relationship becomes suspect.

RequisitePro makes it easy to track changes to a requirement throughout the
development cycle, so you do not need to review all your documents individually to
determine which elements need updating. You can view and manage suspect
relationships using a Traceability Matrix or a Traceability Tree in the Views
Workplace.

This chapter addresses traceability between requirements in the same project. For
information about cross-project traceability, see Setting Up and Modifying Cross-Project
Traceability on page 244.

Creating Traceability in the Word Workplace

Use the Requirement Properties dialog box or the RequisitePro > Requirement menu
command in the Word Workplace to trace a requirement to or from other
requirements in a document. A common traceability relationship is one in which one
requirement is derived from another.

Creating a Traceability Relationship in a Requirements Document
To create a traceability relationship in a requirements document:
1 Place the cursor in the text of the requirement.
2 Open the Requirement Properties dialog box by doing one of the following:
s Click RequisitePro > Requirement > Properties in the Word Workplace.
2 Click Requirement > Properties on the Tool Palette.

[ﬂ] 1 Click the Display properties button on the Tool Palette.
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3 Click the Traceability tab on the dialog box.

Requirement Pro ﬂ

General | Revizion | Altributes Traceability Higrarchy | Dizcussions

Add... |
Remave |

~—From

~To

Add... |
Hemaoyve |

0K | Cancel | Help |

The From field lists requirements from which the selected requirement is traced.
The To field lists requirements to which the selected requirement is traced. An (s)
after the requirement tag represents a suspect relationship.

Note: Double-click a requirement to view a read-only version of its dialog box.
4 Click the Add button adjacent to the To or From field.

The Trace To Requirement or the Trace From Requirement dialog box appears.

Trace From Requirement(s] E
— Display
Bequirements "
o IAII requirement types j
Located in: IAII locations j

S system shall provide a loan T with ©
PR3: The GBS System shall calculate the blue book value
PR4: The GBS system shall allow only maintenance of cur
PRE: The GBS system shall allow only maintenance of cur
PRE: The GBS system shall allow updates to customer inf
PR7: &ll other screens shall have customer information
FRE: All balance information shall be updated systemati
PRS: The GBS system shall provide the following reports
PR10: The OBS system shall rack the last date a report
FR11: Each uzer shall have a unigue login and associated
FR12: The security shall be implemented such that the us
PR13: The OBS shall offer a comprehensive on-ine Help =
FR14: Upon uger request, the OBS spstem shall dizsplay a
PR15: The OBS system shall automatically switch to eithe
PR1E: The OBS system shall respond to inguiries within t
PR17: The OBS system shall use no more than 1 megabyte o

SR1: The spstem display a Customer Information Screen u d
CO1 1kl

0k | Cancel | Eind. | Hep |

5 From the Requirements of type list box, select the requirement type with which the
requirement is associated.
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If you know the location of the requirement (document or database), select it from
the Located in list box. If not, select All locations.

Select a requirement to trace to or trace from in the list box and click OK.
RequisitePro adds this requirement to the To or From field on the Traceability tab.

Click OK.

Creating Traceability Using the Requirements Menu

To create traceability using the Requirements menu:

1
2

In a requirements document, place the cursor in the text of the requirement.

In the Word Workplace, click RequisitePro > Requirement, or on the Tool Palette,
click Requirement. Then click either the Trace To or the Trace From command.
The Trace To Requirement(s) dialog box or the Trace From Requirement(s) dialog
box appears.

From the Requirements of type list box, select the requirement type with which the
requirement is associated.

Note: Click the Find button to open the Find Requirement dialog box, which you
can use to locate a specific tag number and/or requirement name and text.

Select the location (document or database) of the requirement from the Located in
list box. If you do not know the location, set the list box to All locations.

Select a requirement to trace to or trace from in the list box and click OK.
RequisitePro creates a traceability relationship between the two requirements.

Creating Traceability in the Views Workplace

You can create traceability relationships in the Attribute Matrix, the Traceability
Matrix, and the Traceability Tree. (For more information on navigating in the Views
Workplace, refer to Working with Views on page 49.)

Creating Traceability Relationships in an Attribute Matrix

1
2

Create an Attribute Matrix, or open an existing one and select a requirement.

Click Requirement > Properties.
The Requirement Properties dialog box appears.
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3 Click the Traceability tab.

Requirement Pro)

General | Revizion

x|

Altributes Traceability Higrarchy | Dizcussions

~—From

Add... |
Remave |

~To

Add... |
Hemaoyve |

ok

| Cancel | Help |

4 Click the Add button adjacent to the To or From field.

The Trace To Requirement(s) or the Trace From Requirement(s) dialog box

appears.
Trace From Requirement(s] E
— Display
Bequirements " -
o IAII requirement types J
Located in: IAII locations j

SO 1 hlenn

0k | Cancel | Eind. | Hep |

PR2: The GBS system shall provide a loan officer with
PR3: The GBS System shall calculate the blue book value
FR4: The QBS system shall allow only maintenance of cur |
PRE: The GBS system shall allow only maintenance of cur

PRE: The GBS system shall allow updates to customer inf

PR7: &ll other screens shall have customer information

FRE: All balance information shall be updated systemati

PRS: The GBS system shall provide the following reports

PR10: The OBS system shall rack the last date a report

FR11: Each uzer shall have a unigue login and associated

FR12: The security shall be implemented such that the us

PR13: The OBS shall offer a comprehensive on-ine Help =

FR14: Upon uger request, the OBS spstem shall dizsplay a

PR15: The OBS system shall automatically switch to eithe

PR1E: The OBS system shall respond to inguiries within t

PR17: The OBS system shall use no more than 1 megabyte o

SR1: The spstem display a Customer Information Screen u d

5 From the Requirements of type list box, select the requirement type with which the

requirement is associated.

Note: Click the Find button to open the Find Requirement dialog box, which you
can use to locate a specific tag number or requirement name and text.

6 Select the location (document or database) of the requirement from the Located in
list box. If you do not know the location, select All locations.
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7

8

Select a requirement to trace to or trace from in the list box and click OK.
RequisitePro adds this requirement to the To or From field on the Traceability tab.

Click OK on the Requirement Properties dialog box.

Creating and Deleting Traceability in a Traceability Matrix

=)

Trace To

g

Trace
From

To create a traceability relationship:

1

2

Open a Traceability Matrix and select the cell that intersects the two requirements
for which you want to create a traceability relationship. (Use a multiple select
action to select more than one cell.)

In the Views Workplace, click Requirement > Trace To or Requirement > Trace
From.
An arrow appears in the cell, signifying the relationship.

To delete the traceability relationship:

1

Highlight the arrow in a Traceability Matrix cell. (Use a multiple select action to
select multiple cells.)

Click Requirement > Delete Trace, or press the DELETE key on the keyboard. A
dialog box appears asking you to confirm the deletion.

Click Yes.

To apply traceability to a row or column:

1

2

Select the rows or columns to fill in a Traceability Matrix.

Click the View menu in the Views Workplace, and then do one of the following:
2 Click Select All Rows in Selected Columns.

2 Click Select All Columns in Selected Rows.

For example, if you selected a column in Step 1, click Select All Rows in Selected
Columns. All of the rows are selected. The intersection cells of the selected column
and all of the rows are also selected. To clear the requirements you do not want to
assign to the traceability state, use a multiple select action.

Click Requirement > Set Traceability.
The Set Traceability dialog box appears.

Select a Traceability Function from the list.

Click OK. For lengthy operations, the status bar shows the progress of the
operation.
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Creating Traceability Relationships in the Traceability Tree

Two methods may be used to create traceability relationships in the Traceability Tree:

Drag and drop

Requirement commands

Drag and Drop

1

Open a Traceability Tree and select the requirements (displayed by their tags) to or
from which you want to create a traceability relationship. (Use a multiple select
action to select more than one requirement.)

Press the CTRL key and hold down the right mouse button, dragging up or down
the Traceability Tree until the cursor is on the requirement with which you want to
create a traceability relationship to or from the selected requirements, and then
release the mouse button. A shortcut menu appears.

Do one of the following:

Q

To delete the traceability relationship between the selected requirements and
the requirements to or from which they were traced, and to create a traceability
relationship between the selected requirements and the requirement the cursor
was on when you released the mouse button, click Move Here.

To maintain the traceability relationship between the selected requirements
and the requirements to or from which they were traced, and to create an
additional traceability relationship between the selected requirements and the
requirement the cursor was on when you released the mouse button, click Copy
Here.

To cancel the operation without moving, deleting, or creating any traceability
relationships, click Cancel.

Tip: To copy or move a traceability relationship, you can also press the CTRL key
(to copy) or the ALT key (to move) and hold down the left mouse button, dragging
up or down the Traceability Tree until the cursor is on the desired requirement,
and then releasing the mouse button. Note that if you use this method to copy a
traceability relationship, you are not given the option to cancel before the copy
occurs. You are given the option to cancel when you use this method to move a
traceability relationship.
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Requirements Commands

1

Select the requirements (displayed by their tags) to or from which you want to
create a traceability relationship. (Use a multiple select action to select more than
one requirement.)

Click Requirement > Trace To or Requirement > Trace From.

(The command available depends on the type of Traceability Tree in the active
window.)

The Trace To Requirements or Trace From Requirements dialog box appears.

Select the requirements in the list. (Use a multiple select action to select more than
one requirement.)

4 C(Click OK.

Troubleshooting Failed Multiple Select Actions

In the Views Workplace, when you select more than one relationship or requirement
in a view and then perform an operation on the multiple selection (such as creating
traceability or deleting), the operation may fail for one or more requirements or
relationships.

For example, the operation may fail if you do not have rights to perform the operation
on the requirements or relationships, or if some of the requirements are located in
documents and the operation is permitted only for requirements in the database.

RequisitePro notifies you of such failures, providing an exception log (separate from
the error log file) that shows the requirements or relationships for which the operation
failed, and the reason for the failure.

1

In a view, perform the desired operation on a selected group of requirements or
relationships.

2 If the operation is successful, the modifications are shown in the view, and no
dialog box appears.

2 If the operation fails for one or more requirements or relationships, or if you
stop the operation before it is completed by pressing the ESC key, the Exception
Report dialog box appears, providing the number of requirements or
relationships for which the operation failed.

Click Details to learn more about the failed operation. The dialog box is expanded,
showing the reason for the failure.
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3 To copy the text in the text box, select the text and press CTRL-C. You can then
paste the text into a text document.

4 C(Click Close.

Suspect Relationships

A relationship between requirements becomes questionable or suspect if RequisitePro
detects that a requirement’s name, text, requirement type, or attribute has been
modified. All direct relationships to and from it are suspect.

You can define attributes that, when modified, cause traceability relationships to
become suspect. You also can manually mark requirement relationships as suspect in
the Views Workplace.

Displaying Suspect Traceability Relationships

The suspect state is reflected in the Requirement Properties dialog box as well as in
views. In the Traceability Tree and Traceability Matrix views, suspect traceability
relationships are marked as lines through the arrows.m In an Attribute Matrix, an
(s) appears after the requirement tag in the Traced-to or Traced-from column.

On the Traceability tab of the Requirement Properties dialog box, an (s) displayed
after the requirement tag in the To and From fields represents a suspect relationship.
In the Views Workplace, the suspect relationship is identified by a red diagonal line
through the traceability arrow.

The Auto Suspect command monitors a requirement’s change history and displays a
suspect signal when requirements are changed. Use the Project > Auto Suspect
command to enable or disable automatic checking for changes that affect the
traceability or hierarchical relationships between requirements in the project.

If Auto Suspect is disabled, RequisitePro does not monitor changes in requirements
and does not mark relationships as suspect. There are times when this mode is
required; for example, when you are correcting spelling mistakes in your documents,
you do not want those corrections to cause your relationships to become suspect.

With Auto Suspect enabled, RequisitePro constantly monitors requirements for
changes that may affect traceability or hierarchical relationships. If there is a change in
a requirement, the state of the requirement’s relationships is automatically changed to
suspect. If you have cross-project traceability active, requirements in external projects
are also monitored.
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Auto Suspect is enabled by default. If you disable Auto Suspect, you can later activate
it with the Project > Auto Suspect command. It is automatically enabled the next time
the project is opened.

Clearing Suspect Traceability Relationships

You can reset a requirement relationship that has been changed to a suspect state by
manually clearing it. The relationship is reset to its previous state, traced to or traced
from. Suspect relationships are cleared in the Traceability Matrix view or Traceability
Tree in the Views workplace.

To clear one or more suspect relationships:
1 Do one of the following:

2 In a Traceability Matrix, select one or more intersection points in the matrix
where a traceability link has been created.

s In the Traceability Tree, select one or more requirements to modify.

2 In the Views Workplace, click Requirement > Clear Suspect.
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Importing Requirements
and Documents

Use the Import Wizard to import requirements from a Microsoft Word document or a
comma-separated value (CSV) file into a Rational RequisitePro project.

The import process is recommended for:

= Importing nonproject documents into the active project

= Importing new requirements into an existing project

» Updating existing requirement attributes with new information

The Import Wizard can import requirements and attributes into your project from
several sources:

» Requirement documents created in other RequisitePro projects
* Microsoft Word documents created outside of RequisitePro

* Any database that supports export of data in CSV format, such as SQL Server,
Oracle, Excel, or Access

Preparing to Import

Project Setup

You will be importing an external document or CSV file into a RequisitePro project. If
the project administrator has not already set up a project, you should create one now.
(Refer to the chapter Creating Projects on page 181.) The project must have at least one
requirement type and one document type defined.

Import Logs

RequisitePro creates a log file each time you import a file. The log file is a written
record of the import process. The log file records these operations: requirement types
matching, conflict resolutions, attribute mappings, the success or failure of search
criteria, canceled operations, value errors, and the success or failure of the import. The
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log file is saved in the directory where the project is stored, and it is named
import#.log, where # is a number representing sequential order of creation. If a log file
is deleted, the next one created will receive the old number to fill in the gap.

Importing RequisitePro Documents

To successfully import RequisitePro documents from one project to another, you must
first save the documents in Microsoft Word format. The resulting Word document
retains the appearance of the original requirements document, including the
bookmarks and tags that are used in RequisitePro.

About RequisitePro Format

When the Save documents in RequisitePro format check box on the Documents tab of
the Project Properties dialog box is selected, all documents within the project will be
saved in RequisitePro format.

Documents saved in RequisitePro format cannot be modified and saved in Word
outside of RequisitePro. This allows RequisitePro projects to be secure.

When this option is cleared, documents will be saved in Word format. Documents
that are saved in Word format can be modified in Word outside of RequisitePro and
are not secure.

To ensure that the documents are once again brought under RequisitePro control after
they are imported into a new project, select the Save documents in RequisitePro format
check box on the Project Properties dialog box for that project. If security is not an
issue for a particular project, you can clear the check box.

Converting All the Documents in a Project to Word

If you want to import all the documents from one project into another, they can all be
converted to Microsoft Word format at once.

To convert all documents to Word at once:
1 Open the project.

2 On the Tool Palette, click Project > Properties. The Project Properties dialog box
appears.
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3 On the Documents tab, clear the Save documents in RequisitePro Format check box.

Project Properties m

General | Fevision | Feguirement Types
Documents | Document Types | Attributes

[ Save documents in RequisitePro Format

Selectthis check box to secure documents so that they cannot be opened
successfully in Microsoft Word outside of RequisitePra.

¥ Enable Extended Editing of documents

Selectthis check box to allow changes in requirement text from outside a
document (from views, RequisiteWeb, the RequisitePro Extensibility Interface, or
integrated tools).

4 Click OK. When the project is closed, all documents will be converted to Word
format but will remain in the RequisitePro system. The documents will retain their
RequisitePro extensions.

The newly formatted documents are ready to import into another project. Follow the
instructions in Importing from Word on page 167.

Converting an Individual Document to Word
To import a single document from an existing project:
1 Using the Tool Palette, open the project in one of the following ways:

2 Click Project > Open.
Ij: I 2 Click the Open project button.
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The Open Project and Documents dialog box appears.

i

Select a Project:

Add.. I
Py exercize project
Project 10 Remove I
Project 14 _I
Froject 15 = ties... I
Project 16 ;I S
Location: |C:\F'FEGGF|.6«M FILESRATIOMNALVREQUISITEPROMSAMPLESALEARMING
Open project options I Bead Only I Exclusive
Select Document(s): Display Typels):| &l Types -
Arrange Shipment cs
Check Order Status UCs
CheckOut ucs
ClassicsCD Supplementany Specification SUP
ClagsicsCD Vision Docurnent WIS
Glozsamy GELS
Shop for CO cs
Open document(s] option: I~ Read Oy Properties... I

Ok | Cancel I Help I

2 Select a project and document and click OK. RequisitePro opens the document.

3 On the Document menu, click Save As. The Document Save As dialog box displays
the file name with its extension changed to .doc.

4 Click Save. The document is converted from RequisitePro format to Word format.

The file management system automatically saves the new Word document (*.doc)
into the same folder as the project.

The new Word document is ready to import into another project. Follow the
instructions in the Importing from Word section.

Saving or Removing Bookmarks

Bookmarks in a RequisitePro document are requirement indicators. They appear as
heavy square brackets, to distinguish them from the square bracket character
normally found in Microsoft Word. When you create a requirement in a RequisitePro
document, RequisitePro automatically inserts bookmarks that surround and specify
the text of the requirement.

When a document is imported, the Import Wizard finds strings of text in the
document (that is, the wizard parses the document) and imports them into the project
as requirements. In the import process, you define the criteria that the wizard uses to
parse the text. The criteria can be keywords, text delimiters, or Word styles.

If RequisitePro detects bookmarks in the document being imported, the Remove
Bookmarks information box appears. (This information box appears after you have
responded to the Document Properties dialog box at the beginning of a Word import.)
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» Click Yes to remove bookmarks and include all the document’s text in the parsing
process.

= Click No to leave the bookmarks in place. RequisitePro recognizes any bookmarks
that were previously created in a RequisitePro document and brings that text into
the new document as new requirements. The bookmarked text is ignored in the
parsing process.

Importing from Word

Use the Import Wizard to import requirements from a Microsoft Word document into
a RequisitePro document or to import a Microsoft Word document in its entirety into
a RequisitePro project.

The document you are importing must be in Word format. If your document was
created in an application other than Word, refer to the Microsoft Word
documentation to save the file in Word format.

Turn off Word’s spelling, grammar, and background repagination options (in the
Options dialog box) before importing a Word document.

Note: If you are importing a Word document that uses a template other than Word'’s
normal.dot template or an existing RequisitePro outline, you should set up that
template as a RequisitePro outline prior to importing the document. RequisitePro will
overwrite any unrecognized formatting with the normal.dot formatting. If you have
customized the formatting within the Word document, you should save the
document as a Word template and copy it to the RequisitePro outlines directory. Then
create document types based on that outline in the project into which you plan to
import the document. Refer to the Microsoft Word documentation for help in creating
Word templates and to the RequisitePro online help topic “Creating outlines” for help
in managing RequisitePro outlines.

Importing Word Documents and Requirements
To use the Import Wizard to import Word documents:

1 On the Tool Palette, click Project > Open.
The Open Project and Documents dialog box appears.

2 Select the project into which you will be importing the Word document, and click
OK.

3 On the Tool Palette, click Project > Import. The Import Wizard opens, and the
Select a Source screen appears.
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4 Select the Microsoft Word Document option.

5 Type the path and name of the Word document you want to import, or click
Browse to select a file.
The Browse command displays the Open dialog box. Navigate to the desired
document and click Open. (If the desired document is not found in the list, try
changing the file type to All files.) The Open dialog box closes and the selected
document is loaded into the Import Wizard.

6 Click Next to continue. The Select Import Content screen appears.

7 Designate the import content by selecting the appropriate option (Requirements
and document, Requirements only, or Document only).

Depending on your choice, you will take one of three paths. The following table
demonstrates the trade-offs between the different import options.

Requirements

and Document Requirements only | Document only

Requirement definition | Automatic Automatic Manual
Requirement New document Database or New document
destination New document or

Existing document

Importing Both Requirements and the Document

If you select the Requirements and Document option on the Select Import Content
screen, the Import Wizard imports the entire document and the requirements created
by parsing the text. The Word document is imported into a new RequisitePro
requirements document, and requirements are automatically generated in the new
document. The Requirements and document option works well if your document
already contains a well-defined requirement structure. The Import Wizard parses the
document for requirements on the basis of key words, text delimiters, or Word styles.
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1 Select the Requirements and Document option on the Select Import Content screen
and click Next.

The Document Properties dialog box appears.

Document Properties m
General | Revision

Marne: IPrucess Sale Use Case Specification
Descriptian: [ document specifying the following use case: A sales clerk ;I

will process & sale for a customer allowing the customer to

purchase an item. LI
Filenarne: IProcess_SaIe ucs ¥ Show Tags
Directory: |C YPrograrm Files\Rational\ReguisitePro 4.54 Browse...
eI IUse Casze Specification Document Type LI

Type:

oK I Cancel | Help |

2 Complete the following information:

=)

Select a Document Type from the list.

3 Click OK to continue.

Type the document Name (any length up to 64 characters).

Type the Filename. (RequisitePro will assign an extension according to the
Document Type selected.)

Click the Revision tab to enter a change description or create a user-defined
label (optional). Revision number, date, time, and author are generated by the
system and cannot be edited here.

Select the Show Tags check box if you want to display requirement tags in your
document.

Note: If the document type you selected is associated with an outline (or template)
that contains special formatting and text, the Outline has text dialog box appears.
You must indicate whether you want to preserve the text and formatting from the
outline for this document type. Click Yes to retain the style settings and text from
the document outline. Click No to import the basic Word document only.

The Requirement screen appears.
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4 Select a type for the new requirements in the Requirement Type list.
The wizard provides a default requirement type by matching it to the document
type you selected earlier.

Note: Occasionally, you may want to include requirements of multiple types in a
single document. For example, any sentence containing the word “shall” could
become a product requirement, and any sentence containing the word “will”
could become a software requirement. As you create search criteria in the step
below, you can use the Requirement Type list to select which requirement types
you want to apply.

5 Click the Set Defaults button to open the Set Requirement Defaults dialog box,
where you can enter default attributes, hierarchy, traceability, and a change
description for the requirements you create.

6 Mark one of three methods for differentiating or parsing the Word document. The
Import Wizard finds strings of text in the Word document and imports them into
the project as requirements.

s Keywords. Import Wizard searches the Word document for a specific word, such
as “shall” (the default). Type keywords in the Keywords field and click Add to
add the keywords to the requirements criteria field. Select the Match case check
box to make the keyword match the case of the text you enter in the Keyword
box, or select the Use * as wildcard check box if you want to use the * as a
wildcard character in the Keyword field. Enter the word and click Add.

Note: If you want to create requirements from the selected text for each
sentence or for each paragraph without parsing based on a keyword, enter
only an * and select the Use * as wildcard check box.

2 Text delimiters. The Import Wizard searches the Word document for text
contained within specific text delimiters, such as < >, { }, [ ]. When you have
entered both the starting and ending delimeters, click Add.

2 Word style. The Import Wizard searches the Word document for specified style
settings, such as “Heading 1” or “Body text” or highlighted text. Select the
appropriate styles and click Add.

Note: You do not need to limit the search to one criteria only. You can add
keywords, text delimiters, and Word styles to the search list by marking each
button in turn. Use Remove to delete a criteria from the search list.

7 Click Next to continue.
RequisitePro parses the document using the differentiation methods you selected.
When a requirement is located, the Requirement found dialog box appears.
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8 Indicate whether the text found is a valid requirement: Click Yes or No for each.
Choose Yes to all to automatically accept all requirements found in the document.
Each requirement is added to the Requirements to import box on the Import
Wizard screen. Each new requirement begins with a pending tag, followed by the
initial text of the requirement.

When you are satisfied with your selection, click Next to continue.
The Import Wizard displays the final Status screen.

9 Click Commit to accept the import or click Cancel to cancel the import in its
entirety.

Importing Requirements Only

Select Requirements only at the Select Import Content screen if you want to extract
requirements from a document without importing the rest of the text. If your
document already contains a well-defined requirement structure such as keywords,
styles, or delimiters, this option automatically creates your requirements during the
import process. The Import Wizard parses the document for requirements on the basis
of key words, text delimiters, or Word styles. It creates requirements from the text it
finds and leaves the rest of the document behind. You have flexibility in the location
of the new requirements. You can create requirements in the current project (directly
in the database), in an existing RequisitePro document, or in a new document.

1 Select the Requirements only option on the Select Import Content screen and click
Next. The Select a Destination screen appears.

2 Choose one of the following destinations for the imported requirements:

2 Select Current project database to import the requirements into the database of
the open project.

2 Select New RequisitePro document to import the requirements into a new
document you define. (The Document Properties dialog box appears and
prompts you for information about the new document before proceeding to the
next step.)

2 Select Existing RequisitePro document to choose from a list of existing project
documents. (If the document you choose is not already open, RequisitePro
opents it for you.)

3 Click Next to continue. The Requirement screen appears.
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4 Follow Steps 4-9 in the section Importing Both Requirements and the Document on
page 168.

Note: At Step 7, when the Requirements to import dialog box appears, you have
the following options:

2 If you want to read the full text of the requirement, click the View button.

s To remove a requirement from the list, select it and click the Remove button. (It
is saved in an Add requirements box.) Click Add to view the box.

Importing the Document Only

The Import Wizard imports the entire document into a new RequisitePro document
without parsing the text. Choose Document only if your requirement structure is not
defined or if you want to manually create the requirements after importing. No
requirements are created during the import process. This option gives you the most
flexibility in creating requirements in documents.

1 Select the Document only option on the Select Import Content screen and click
Next. The Document Properties dialog box appears.

2 Complete information about the new document. (See Step 2 in the section
Importing Both Requirements and the Document on page 168.)

Note: If the document type you selected is associated with an outline (or template)
that contains special formatting and text, the Outline has text dialog box appears. You
must indicate if you want to preserve the text and formatting from the outline for this
document type. Click Yes to retain the style settings and text from the document
outline. Click No to import the basic Word document only.

The Import Wizard displays the final Status screen.

3 Click Commit to accept the import, or click Cancel to cancel the import in its
entirety.

Note: If you are importing a RequisitePro document from one project to another, this
process includes an extra dialog box. (Refer to Saving or Removing Bookmarks on
page 166.)

Importing a CSV File

RequisitePro can import requirements and attributes into your project from any
database that supports export of data in CSV format, such as SQL Server, Oracle,
Excel, or Access.
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The CSV import process is recommended for:
* Importing requirements from a non-RequisitePro database into the active project
» Updating existing requirement attributes with new information

A CSV file is a data file consisting of fields and records, stored as text, in which the
fields are separated from each other by commas. If the data in a field contains a
comma, the field is further surrounded with quotation marks. Using a
comma-delimited file format allows data to be shared between database systems that
use different formats.

Requirement Numbers

When a new requirement is added to the database, it is assigned a new root
requirement number. If a requirement has a tag or a number in the external CSV file,
that number is not preserved. RequisitePro will recognize a hierarchical numbering
scheme and will import lower-level requirements as children of a higher-level

requirement.

105.0.0 | The systera shall ..
108,10 The stbsystera B Yl e e
T0% 1.1 | The subsystem .. ;

0000 [ The ATNhall . PR30 The wer shanld ...
100 1 0| The ETMtken __ PRAD Thesysterashal
109 2.0 The wer pressses .. pR4:1 The su}:sygtem__“
10930 | The & T displays. .. PEA.1.1 The subsystern ...
PRS0 The AThI shall. ..
— - PE3.1 The ATH then ...
PR32 The wser pressses ..
PR5.3 The 5TM displays. ..

Requirements in a CSV file are renumbered when they are imported into the project
database.

Preparing a CSV File for the Import Wizard

The CSV file and RequisitePro must be configured properly to successfully import all
information:

» The CSV file must contain a header in RequisitePro format. RequisitePro uses the
following header format:
<Tag>, “Requirement text”, “Name”, <Attribute 1>,<Attribute 2>, <Attribute 3>...
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The requirement type specified in the <Tag> field determines the default
requirement type that will be assigned during the import process. You can change
this requirement type assignment in the Import wizard.

= All attributes that are included in the CSV file must exist in the corresponding
RequisitePro requirement type in the current project. If the attributes do not
match, the default values for the requirement type are inserted during the import
process. (See Creating and Modifying Requirement Attributes on page 240.)

= Alllist-type attribute values in the CSV file must exactly match the predefined
list-type attribute values in the RequisitePro requirement type definition. Edit the
attribute values in the CSV file or modify the list-type values in your RequisitePro
project. (See Working with Requirement Attributes and Attribute Values on page 239.)

Note: Multiple-value list attributes appear in a CSV file in quotes, separated by
commas (for example, “Chris, Sarah, John”).

= If the CSV file contains null values (blank spaces) for any list-type requirement
attributes, those attributes will be assigned the default value as defined in the
Project Properties dialog box (Project > Properties). To retain a null value, remove
the default setting in RequisitePro before importing the CSV file. You can reassign
the default value after the import process is complete. (See Working with
Requirement Attributes and Attribute Values on page 239.)

* All requirements in the CSV file will be converted to the requirement type
specified in the import process (in the header <Tag> field, by default). If the CSV
file contains requirements with different requirement type tags, such as “PR1” and
“SR2”, those requirements will be renumbered with the assigned requirement tag,
and some hierarchical relationships may be lost.

Defining a Header for a CSV File

RequisitePro uses the following header format:
<Tag>, “Requirement text”, “Name”, <Attribute 1>,<Attribute 2>, <Attribute 3>...

1 To begin creating a header, type a tag that describes a requirement type, such as
PR, SR, TST, or any other tag you created in your project, followed by a comma.
The word tag can be added in the header, but it is not required. For example, SR
and SR tag are both acceptable.

2 The tag field in the header is used to set the default Requirement Type used in
the import. If the tag field does not match any requirement type in the project,
the Match Requirement Type screen appears, prompting you to choose one
manually.
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s The first column in the CSV file must be the tag column. The tag column cannot
contain any empty cells. If a cell is empty, type in any character to fill it.

2 If the tag column in the CSV file contains numbers, the numbers will not be
preserved. Imported requirements will be added to the project’s requirements
list and renumbered accordingly. Hierarchical relationships will be retained.

2 The literal string Requirement text must be the second field of the header, followed
by a comma. The second column in the CSV file must be the text of the
requirements.

3 For the remaining fields in the header, type a heading for each column in the CSV
file, separated by commas. For requirement name, type in Narme, followed by a
comma. The column headings in the header can be anything you like, but if you
use names (that is, labels) of attributes as they appear in your project you will save
yourself some time later.

2 RequisitePro will look at the header in the CSV file and try to match the
column heading to an attribute in the project. During the import process you
will be asked to review the attribute matching and make corrections.

2 The columns under the attribute headings must contain attribute values.

Note: As an alternate to typing the CSV header, you can copy a header from another
CSYV file. Exporting an existing RequisitePro file to a CSV file will create a tag in the
correct format. Open an Attribute Matrix of the requirement type you plan to import
and use the File > Export > Export to CSV command. Then copy the header from the
newly exported file and paste it into the file you plan to import. (For more
information, refer to Exporting a View as a CSV File on page 179.)

Using the Import Wizard to Import a CSV File
1 Open a project.
2 Do one of the following:
2 On the Tool Palette, click Project > Import.

2 PFrom the Views Workplace, click File > Import.
The Import Wizard opens, and the Select a Source screen appears.

3 Complete the following information:

2 Click the CSV button to import requirements from a CSV text file.
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s Type the name of the CSV file to import, or click Browse to select a file from the
list. (The Browse command displays the Open dialog box. Navigate to the
desired document and click Open. The Open dialog box closes and the selected
document is loaded into the Import Wizard.)

4 Click Next to continue. The Match Requirement Types screen appears.

5 The Import Wizard, by default, selects the RequisitePro requirement type that
matches the requirement types in the CSV file that you are importing. You can
override the default selection.

6 Click Next to continue. The Match Attributes screen appears.

7 Click Match Manually to check that RequisitePro mapped the attributes
correctly. The Match Attributes dialog box appears.

8 Complete the following information:

a  If you want to change the mapping, click and hold the mouse while dragging a
new line from an imported attribute to an existing attribute.

2 If RequisitePro cannot make a match, the imported attribute will be listed but
will have no line connecting it to an existing RequisitePro attribute. You can
make the match manually if you recognize an attribute with the same meaning.
Requisite Pro will ignore any attributes left unconnected. Only matched
attributes are imported.

Match Attributes E

Drraw lines between columns with the mouse to match imported
altributes to existing attributes. Highlight an attribute and click
‘Unmatch' to remove a match.

Imported attributes: Existing attributes:  Type:
Priority ——————————FPricrity lizt =
Statug——————Status lizt
Cogt————ost real

Stability ——————Stability list

Degree of Difficu. - Drifficulty list
@———__Assigned To text

=

Cancel | Help | Qnmatchl

When you are satisfied with the attribute matching, click OK to return to the
Wizard.

9 Click Next to continue. The Select A Resolution dialog box appears.
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When attribute values in the imported requirements conflict with the values in
existing requirements, RequisitePro can resolve the conflict in one of two ways:

Q

By adding the imported requirements as new requirements in your document
or database

By overwriting your existing attribute values with those in the imported CSV
file.

Depending on your choice, you will take one of the two paths described in the
sections that follow.

Defining New RequisitePro Requirements

The Wizard imports the text of the requirements as written in the CSV file. You can
accept or delete the requirements before importing.

1

In the Select A Resolution dialog box, select Define new RequisitePro requirements
and click Next. The Requirements to Import screen appears.

Review requirements in the list and revise the list as needed:

a

Click View to read the full text of the requirement. The Edit Imported
Requirements dialog box appears. Select a requirement from the list. The full
text of the requirement displays in the text pane at the bottom of the dialog box.
To make changes to any of the list-type attribute values, double-click on the cell
and select a new value from the drop-down list. To make changes to entry-type
attribute values, select the value and type the new value. Click Accept for
Import.

Click Remove to remove a selected requirement. (A requirement that was
removed is not entirely deleted. It is moved into the Add requirements dialog
box.)

Click Add to review a list of requirements you have removed. If you would like
to add a requirement back into the list, select it and click OK.

Click Next to continue.The Select A Destination screen appears.

Choose a destination for the new imported requirements:

a

Select Current project database to bring the requirements into the database of
the open project.

Select New RequisitePro document to create a new document (based on the
document type of your choosing) and bring the requirements into the new
document. The Document Properties dialog box appears and prompts you to
record the document name, file name, and document type.
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s Select Existing RequisitePro document to choose from a list of existing project
documents. If the file you choose is not open, RequisitePro opens it for you.

5 Click Next to continue. The final Status screen appears.

6 Click Commit to accept the import, or click Cancel to cancel the import in its
entirety.

Updating Attributes of Existing Requirements

The new imported requirement attributes overwrite the requirement attributes in the
open project. The text of the imported requirements will not be imported. You can
accept or delete the requirements before importing.

1 In the Select A Resolution dialog box, select Update attributes of existing
requirements and click Next.
The Requirements to Import screen appears. The list box shows tag numbers,
followed by the comment: [text will not be imported].

2 Review requirements in the list and revise the list as needed:

s Click the View button to access the Edit Imported Requirements dialog box.
Only tag numbers are displayed, because the text will not be imported. (To
view the text of the requirements associated with the tag numbers, refer back to
the Attribute Matrix in the Views Workplace.)

s Click the Remove button to remove requirements from the list and store them
in an Add requirements dialog box.

3 Click Next. The Import Wizard displays the final Status screen.

4 Click Commit to accept the import, or click Cancel to cancel the import in its
entirety.

Exporting Requirements

Requirements are exported from RequisitePro in the Views Workplace.

= An Attribute Matrix can be exported as a CSV file or as a Microsoft Word
document.

» A Traceability Matrix can be exported as a CSV file only.

» A Traceability Tree can be exported as a CSV file or as a Microsoft Word
document.
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Setting view properties for requirement text and name affects what will be exported.
If the requirement text and name are not displayed in the view, they will not be
exported. If you have queried the view, only the filtered requirements are exported.

Exporting a View as a CSV File

As described in Importing a CSV File on page 172, a CSV file is a data file consisting of
fields and records, stored as text, in which the fields are separated from each other by
commas. If the data in a field contains a comma, the field is further surrounded with
quotation marks.

Depending on the view (which is exported as an ASCII file), each requirement exports
with the requirement tag, followed by the requirement text, requirement name, and
requirement attributes.

*  From an Attribute Matrix, the tag, name, text, and attributes displayed are
exported.

* From a Traceability Matrix, the tag, name, text, and traceability relationships are
exported.

* From a Traceability Tree, the tag, name, and text are exported. Each indented
(traced) requirement includes commas representing each level in the hierarchy.
Only the expanded levels in a view are exported.

Setting view properties for requirement text and name affects what will be exported.
If the requirement text and name are not displayed in the view, they will not be
exported. If you have queried the view, only the filtered requirements are exported.

Hierarchical requirements are exported with their full hierarchical tag number. This
number is used to denote the hierarchical relationships and is used on subsequent
imports to reconstruct the hierarchy.

To export a view as a CSV file:
1 Inthe Views Workplace, display the view you want to export.
2 In the Views Workplace, click File > Export > Export to CSV.
3 Type a file name for the exported view (use the .csv extension), and click Save.
The file is exported. You can open the CSV file in:
2 RequisitePro
+ Word outside of RequisitePro
2 Excel

2 Any other utility that reads this type of file
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Exporting a View as a Word Document

To export a view as a Word document:

1
2

Open an Attribute Matrix or a Traceability Tree that you want to export.

In the Views Workplace, click File > Export > Export to Word.
The Export to Word dialog box appears.

Complete the following information:

2 Choose a location to save the exported file in the Save in drop-down list.
s Type a name for the exported file in the File name text box.

Do not modify the .doc file selection in the Save as type text box.

Click Save.

RequisitePro exports the View as a Word document (*.doc), then opens Word and
displays the exported View as a Word document table.

Note: When a Traceability Tree is exported to a Word document, RequisitePro creates
anew document based on a template created especially for this export (treexprt.dot).
You can modify this template and its styles to suit your needs. Heading styles 1-9 can
be modified, but they must be retained.
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Creating Projects

In RequisitePro, the concept of a project is used to provide the groundwork for
organizing and effectively managing requirements. Each project includes the
following: a database, documents, document types, requirements, requirement types,
attributes, attribute values, discussions, traceability relationships, saved personal and
project-wide views, revision histories, and security information. Each project resides
in a separate directory. This storage method simplifies the process of organizing,
archiving, and managing project files. The project-based system is designed to
minimize confusion and help you focus on one set of requirements.

Only one project can be open at a time. Numerous requirements documents can
belong to a project; different users can edit different documents simultaneously.

Documents are stored separately from the project database, usually in a project
directory. Avoid storing documents on your license server if you use RequisiteWeb. If
you are storing documents in another location, use Universal Naming Convention
paths whenever possible.

RequisitePro project administrators create and manage all elements of projects. This
chapter provides instructions for performing the following tasks:

» Creating a RequisitePro project
» Creating a project template
» Creating a RequisitePro project from a baseline

» Converting earlier versions of RequisitePro projects to the latest release

Creating a RequisitePro Project

When you create a project in Rational RequisitePro, you have the choice of basing the
project on a blank template, on one of three templates included with RequisitePro, or
on a template created from an existing project. When you create a project based on a
template, the document and requirement types, attributes, security information, and
data of the selected template are copied to the new project.
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If you have a RequisitePro project that is baselined, you can use that baseline to create
new projects in RequisitePro. For example, you may want to base the next release of a
project on a stable configuration of the previous release. To create a RequisitePro
project from a baseline, RequisitePro project administrators perform tasks in Rational
Administrator and Rational ClearCase, implementing the Unified Change
Management model. Note that the project created from a baseline does not maintain
any cross-project traceability links from the original baselined project. (See Creating a
RequisitePro Project from a Baseline on page 188 and Using Rational Unified Change
Management to Create a Project Baseline on page 251.)

Reviewing RequisitePro Project Template Options

Three project templates are shipped with RequisitePro; they are described in the
sections that follow. They contain document types, requirement types, and
requirement attributes. After you create a RequisitePro project based on one of these
three templates, you can set your own security and add your own data to the new
project. More information about each of these templates is available from online Help.

Use-Case Template

The Use-Case Template is ideal for implementing the Rational Unified Process. This
template is designed for RequisitePro projects that utilize the RequisitePro integration
with Rational Rose use cases and ClearQuest enhancement requests. Use cases are
particularly applicable to object-oriented software design using the Unified Modeling
Language and for applications that are user-intensive.

Traditional Template

The Traditional Template is best suited for projects that use declarative requirements
specifications for systems that are highly computational, embedded, and algorithmic,
such as weather prediction applications or other scientific systems. This template
includes a traditional Software Requirements Specification outline rather than use
cases.

Composite Template

The Composite Template allows you to combine the best qualities of both use-case
modeling and traditional requirements specification techniques. This template
provides an outline for a modern software requirements specification package
applying both traditional document-based techniques and use-case modeling.
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Determining a Database Type

Before creating a RequisitePro project, you will decide which database to use to store
the requirements information. RequisitePro provides the capability to use Microsoft
Access and the enterprise databases Oracle and Microsoft SQL Server. Refer to the
release notes for specific database versions.

Use the following criteria when deciding which back-end database to use with
RequisitePro:

» Use Microsoft Access with small work groups (no more than 5 concurrent users).

» If your team is distributed across states or countries, use an enterprise database
(SQL Server or Oracle); these enterprise-level databases provide socket-level
access to remote network locations, which tend to perform better.

= Use an enterprise database if you anticipate having more than ten logged-on users
at one time. Tests have shown that the performance of Microsoft Access decreases
after the sixth simultaneous logged-on user. (These numbers may vary with
network bandwidth.)

» Use an enterprise database if you will be managing large numbers of requirements
(tens of thousands).

If you plan to use an enterprise database, RequisitePro provides scripts as a starting
point for database administrators to create the RequisitePro schemas in the
appropriate server. These scripts can be modified.

If you plan to use Oracle, you must install the appropriate client software on each
client machine. See the manual Installing Rational RequisitePro for details.

Using the Data Transport Wizard, project administrators can move project data
between Access, Oracle, or SQL Server databases. Data can also be moved between
two Oracle databases or two SQL Server databases. However, the wizard cannot
move data between two Access databases.

For more information on configuring SQL Server or Oracle, see the guide Installing
Rational RequisitePro.

If you have installed the enterprise database setup under the Custom/Full installation
process, you can access the following instructions from the RequisitePro help
directory (<install drive>\Program Files\Rational\RequisitePro\help):

» Configuring an Oracle database (oraclesetup.html)

» Configuring a SQL Server database (sqlsetup.html)
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For RequisitePro projects that use enterprise databases, the project administrator has
the option to store either one or many RequisitePro projects in the same instance or
database/schema. Refer to the following tips when deciding on the distribution of
RequisitePro projects across enterprise databases:

» Avoid sharing an instance with applications other than RequisitePro. RequisitePro
projects can potentially share an instance with other applications at your site. The
primary advantage of sharing the same instance between applications is that it
reduces the amount of database administration required. However, because
RequisitePro data must be synchronized with the RequisitePro documents, it is not
recommended to share the instance with other applications. If it is necessary to
share an instance, the only way that you can back up your RequisitePro data is
through logical backups. Image (physical) backups will not work in a shared
instance because anytime the data for one application needs to be recovered, the
data for all applications will also be recovered. This could create a situation where
data from an application independent of RequisitePro must be restored, forcing
you to restore out-of-date RequisitePro data as well.

» Place all RequisitePro Projects in one database/schema. Putting all the
RequisitePro projects in one database/schema is the most effective way to store
your projects. Because all the projects are stored together, all projects are backed
up together. However, if a project must be restored, all projects stored in that
database/schema must be restored together. A restore operation will overwrite all
work done since the backup was created.

* Avoid one RequisitePro project per database/schema. Each project can be stored
in its own individual database/schema. This maximizes flexibility, but it also
creates more work for the database administrator. Projects stored in their own
database/schema can be backed up and restored without affecting other projects.
However, projects that participate in cross-project traceability must be in sync
with each other. Cross-project traceability links may be lost if you restore one
project but not the other, or if you restore the projects from backups created at
different points in time.
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Creating a Project
1 Open the Create RequisitePro Project dialog box by doing one of the following:
s From RequisitePro, click Project > New on the Tool Palette.

s From Rational Administrator, in the Configure Project dialog box, click the
Create button at the Requirement Asset field.

Create Rational RequizitePro Project E

Chooze a Project Template:

@ Q\:“ 5 Create I
EME Composite  MakeMew  Tradiional
Template Template Template Cancel |

5

Uze-Case

Template Mo Details<< |

Use thiz template to create a blank project.

Help |

2 Select one of the following Project Templates:
2 Select the Blank template, and set each project parameter.
2 Select one of the default templates provided with RequisitePro.

2 Select a template you created from an existing project, using the Project
Template Wizard.

Note: A description of each template appears in the text box at the bottom of the
dialog box. Click the Details/No Details button to toggle the display of the template
description box.
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3 Type information about the new project in the RequisitePro Project Properties

dialog box that appears.

— Project Propertie:

Mame:
Directary:
Databaze:

Description:

|E:\Program Filez'FR ational'AequisiteProPr Browse... |

I M5 Access

ok |

Cancel |

=l | Eopeties |
-
|
Help |

2 Type a project Name (up to 64 characters).

s Type the path for the project Directory, or click Browse and select the directory.
After the project is created, you cannot change this field.

s Click the down arrow to select a Database for storing the project. You can create
projects in Microsoft Access, SQL Server, or Oracle. If you select a database
other than Microsoft Access, click Properties to configure the database.

2 Type a Description of the project. (This step is optional.) You can modify the
description after the project is created.

4 Click OK. The new project appears in the RequisitePro Open Project and

Documents dialog box.

Note: For more information on configuring an enterprise database, see the guide

Installing Rational RequisitePro.

If you have installed the enterprise database setup under the Custom/Full installation
process, you can access instructions from the RequisitePro help directory (<install
drive>\Program Files\Rational\RequisitePro\help):

s Configuring an Oracle database (oraclesetup.html)

s Configuring a SQL Server database (sqlsetup.html)

What Happens When You Create a Project

When you create a new project, RequisitePro performs the following operations:

» It creates six project files:

s projectname.rgs. A project information text file.
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s projectname.mdb. The project database (in Microsoft Access). This file is not
used for enterprise databases.

2 projectname.ldb. Locks the Microsoft Access database file while you have the
project open to prevent concurrent project use by multiple users. This file is not
used for enterprise databases.

s structure.xml. Project structure, including requirement types, attributes, and
document types.

2 security.xml. Project security definitions, including group names, descriptions,
and their access rights.

s permissions.xml. Project security permissions for individual users, including
document and requirement access by type.

The project is added to your project list.

The requirement types and document types you created in the project become
available for your use.

Creating a Project Template

EN

Make Mew
Template

You can create a template based on an existing project's structure, including
document types, requirement types, attributes, and user and group permissions. You
also have the option to include project data. The new template appears in the Create
RequisitePro Project dialog box, and you can select it when creating new projects.

1

Open the Create RequisitePro Project dialog box by doing one of the following:
s From RequisitePro, click Project > New on the Tool Palette.

2 From Rational Administrator, in the Configure Project dialog box, click the
Create button at the Requirement Asset field.

Double-click the Make New Template icon.
The Project Template Wizard opens.

At the Enter Template Information screen, enter the following information:
s Template Name: Type in a name for the new template.

2 Template Location: Choose a location for the new template. By default,
templates are created in the Program Files\Rational\RequisitePro\Templates
directory. You can set a second location for additional project templates, such
as those shared on a network or used by a particular project. If you want to set
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a secondary location to store templates, use the Tool Palette Tools > Options
command to open the Options dialog box and type the full path and
subdirectory name in the Project Template Path field.

2 RequisitePro Project: Choose a RequisitePro project on which to base the
template structure; you can also include project data. Click the ... button to
browse to the project.

s Include Project Data: Select this check box if you want the template to include
data from the selected project in addition to the project structure. Note that if
the security has been set for the project, you must log on to the project. If
security is set, only users with project structure permissions can create a
template that includes project data.

= Documentation File (optional): You can select an existing .rtf file that contains
details about the template. Text from the file specified here appears in the
Details text box on the Create RequisitePro Project dialog box when the
template is selected. Click the ... button to browse to the file.

2 lcon File: Select an icon for the template that will appear in the Create
RequisitePro Project dialog box.

4 Click Next to continue.

5 Check the information at the Confirm screen and click Finish to create the
template. The new template appears in the Create RequisitePro Project dialog box.

Tip: If you have created a template from a secure project, you may want to use
Windows file system security to protect the template files. By default, templates are
created in the Program Files\Rational\RequisitePro\Templates directory, and all template
files are located in a subdirectory with the same name as the template. (If you want to
set a secondary location to store templates, use the Options dialog box.)

Creating a RequisitePro Project from a Baseline

If you have a RequisitePro project that has been baselined, you can use that baseline to
create new projects in RequisitePro. For example, you may want to base the next
release of a project on a stable configuration of the previous release. See Creating a
Project Baseline with Unified Change Management on page 221 and Using Rational Unified
Change Management to Create a Project Baseline on page 251 for more information.
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RequisitePro project administrators perform the following tasks in Rational
Administrator and Rational ClearCase, implementing the Unified Change
Management (UCM) model.

Note: A RequisitePro project created from a baseline does not maintain the
cross-project traceability links, discussions information, and associations with
Rational ClearQuest and Rational Rose from the original baselined project.

To create a RequisitePro project from a baseline, the administrator must first create a
UCM project and a Rational Administrator project. (Refer to ClearCase and Rational
Administrator online help for more information.)

1 Create a UCM project.

2 Add a UCM component to the project that already contains a versioned
RequisitePro project at a recommended baseline.

3 Set the recommended baseline for the new UCM project. (By default the baseline
selected above will be selected.)

4 Create an integration view for the new UCM project.
To create a Rational Administrator project:

1 Click Tools > Rational Administrator to open Rational Administrator.

N

Click File > New Project. The Rational Administrator New Project Wizard appears.

(2]

Type requested information in the wizard, select UCM enabled, and select
Requirement Assets to be versioned.
When you complete the wizard, the Configure Project dialog box appears.

=Y

Click the Select button to choose Requirement Assets.

5 Browse to the UCM view and select the .rgs file for the baselined RequisitePro
project.

6 Click OKin the Configure Project dialog box.
The new RequisitePro project contains the data and structure from the selected
baselined project.

Note: The new project has the same name as the baselined project. You can change the
name in the Project Properties dialog box. You also have the option to remove the old
baselined project from the RequisitePro list of projects in the Open Project and
Documents dialog box.
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Upgrading RequisitePro Projects to the Latest Version

If you try to open a project that was created in RequisitePro version 4.0 or later and
must be updated to the current version, a wizard appears. The Database Upgrade
Wizard guides RequisitePro project administrators through the process of upgrading
existing database structure and project data to the current RequisitePro release. If the
project was created in a version of RequisitePro earlier than 4.0, you must first
upgrade the project to RequisitePro 4.0 before using the Database Upgrade Wizard.
Contact Technical Support for information.

This upgrade modifies tables and properties of the database. For these reasons, you
cannot revert to the state before the upgrade. We recommend that you back up the
database before you start the upgrade. If the project you are upgrading contains
cross-project traceability links, you must upgrade the external projects as well.

Caution: The upgrade process upgrades all RequisitePro projects in an enterprise
database. Make sure all RequisitePro users have closed all projects in the database
before continuing with the upgrade.

Follow the instructions at each screen in the Database Upgrade Wizard, and click the
Help button to access online Help for the upgrade process.
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Working with Project
Security

Because Rational RequisitePro allows multiple users to access the same project
documents and database simultaneously, project security is crucial. You can enable or
disable security in a project, depending on the needs of the group. When security is
enabled, users belong to groups. RequisitePro administrators assign group-specific
permissions. The permissions determine the amount or kind of access users have to
projects.

Any RequisitePro user can create a new project. When you create a new project, you
are considered the project administrator and are automatically placed in the
Administrators group. After you create the project, you (and other project
administrators) can define other users and groups.

If security has not been enabled for the project, any user can open the RequisitePro
project. When you open an unsecured project for the first time, RequisitePro allows
you to log on with your Windows logon name, as a user name of your choice, or as the
user name specified in the Options dialog box (click Tools > Options) Default Project
Logon field. The user name is added to the Administrators group list for the project.

If security is enabled, the Project Logon dialog box appears each time you or another
user opens the project. The project administrator who set security can assign
passwords for other users.
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Setting Security

To enable or disable security for a project:
1 On the Tool Palette, click Project > Security.

The Project Security dialog box appears.

¥ Enable security for this project

Groups:

Deted Users of Group: Administrators

<[eleted Users>
Add

Users —I
Delete I
Mave.. I

Add. Edt | [P0z

oK | Cancel | Help |

2 Select the Enable security for this project check box to set security; clear the box if
you want to disable security.

3 Select groups and users by following the steps in the next section.

4 Click OK.

Creating and Modifying Groups and Users

RequisitePro provides three default security groups: Deleted Users, Administrators, and
Users. Remember that all security permissions are assigned at the group level only
and that a user can be in only one group.

= Deleted Users. This group contains users who have been deleted from other groups,
have no permissions, and cannot log on to RequisitePro. This group is maintained
by RequisitePro for project history.

»  Administrators. Members of this group have full permissions to work in a project.
They can change a project structure, create and modify data, and set and maintain
security permissions. You can add and remove users from this group, but you
cannot modify Administrators group permissions.

= Users. By default, members of the Users group have full permissions to create and
modify all documents, requirements, attributes, and traceability. You can modify
Users group permissions to limit the type of permissions granted for each
document type and requirement type.
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You can add and delete groups, add users to groups, move a user to a different group,
and edit a user’s information, such as user name, password, and e-mail address.

Creating a New Security Group
To create a new security group:

1 On the Tool Palette, click Project > Security.
The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

2 C(Click Add below the Groups list box.
The Group Permissions dialog box appears.

X
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Feature Requirement Type rAudc/d
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lze Case Requirement Type rfudedd
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3 In the Name text box, type a name for the group.

4 Set the group permissions and click OK. (For more information on setting and
editing group permissions, see Assigning Permissions to a Security Group on
page 197.)

5 Click OK to save and close the Project Security dialog box.
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Deleting a Security Group
If all users have been removed from a group, you can remove the group.
To delete a group:
1 On the Tool Palette, click Project > Security.

The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

In the Groups list box, select the group to delete.
Click Delete. RequisitePro prompts you to confirm the deletion.

Click OK.

a A W DN

Click OK in the Project Security dialog box to save and close.

Adding a User to a Security Group
To add a user to a group:

1 On the Tool Palette, click Project > Security.
The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

2 In the Users of Group list, select the group to add the user to, and click Add next to
the Users of Group list. The Add User dialog box appears.

Add User [ x|

Uzemarne: |

Mew Passward: |

Werify: I

E-Mail Address: |

(1] 4 I Cancel | Help |

3 In the Username text box, type the user’s name. It should not exceed 20
alphanumeric characters, and it is not case sensitive.
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In the New Password text box, type the user’s password.

Note: This field and the Verify field below are encrypted, displaying a symbol for
each of the 14 maximum possible characters. Passwords are case-sensitive; for
example, Mycomputer, MYCOMPUTER, and mycomputer are treated as different
passwords.

In the Verify text box, type the password again.

In the E-Mail Address text box, type the user’s e-mail address. This e-mail address
is necessary for participating in RequisitePro discussions via e-mail. (For more
information, see Responding to Discussions on page 73.)

Click OK. RequisitePro adds the new user to the group.

Click OK to save and close the Project Security dialog box.

Editing User Information

To edit user information:

1

On the Tool Palette, click Project > Security.
The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

In the Groups list, select the security group to which the user belongs.
In the Users of Group list, select the user name.

Click Edit next to the Users of Group list.
The Edit User dialog box appears.

Edit the user name, password, or e-mail address.
Click OK.

Click OK to save and close the Project Security dialog box.

Deleting a User from a Security Group

When you delete a user from a security group, RequisitePro moves the user to the
<Deleted Users> group. All records associated with the user are maintained. If you
reinstate a user with the same name as a deleted user, RequisitePro prompts you to
confirm whether it is the same person before reinstating the user.
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To delete a user:

1 On the Tool Palette, click Project > Security.
The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

2 In the Groups list, select the group containing the user.
3 Select the user in the Users of Group list.

4 Click Delete below the Groups list. A dialog box appears, prompting you to
confirm deletion of the user.

5 Click Yes to move the user from the current group to the <Deleted Users> group.

6 Click OK to save your changes and close the Project Security dialog box.

Moving a User to Another Security Group
To move a user to another security group:

1 On the Tool Palette, click Project > Security.
The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

2 In the Groups list, select the group containing the user.
3 Select the user in the Users of Group list.

4 Click Move. The Move User dialog box appears.

Select the new group for the user ‘4 Project banager':

<Deleted Users:
Administrators

QK I Cancel Help

5 Select the group to move the user to.
6 Click OK.

7 Click OK to save your changes and close the Project Security dialog box.
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Assigning Permissions to a Security Group

Each security group has its own set of permissions, and all members of the group
share the same permissions. The following list shows all possible permissions that can
be assigned to a group:

»  Project permissions: access the project, manage project structure, manage project
security

»  Document type permissions: read, update, create, delete documents

= Requirement type permissions: read, update, create, delete requirements
= Attribute permissions: read, update attributes

»  Attribute value permissions: read, update attribute values

»  Traceability permissions: set and clear suspect relationships, create and delete
traceability relationships

Members of the Administrators group and groups with project security permissions
can create group accounts; assign permissions to the groups; and add, move, edit, and
delete users in groups.

To assign permissions:

1 On the Tool Palette, click Project > Security.
The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

2 In the Groups list, select the group.
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3 Click Edit below the Groups list.
The Group Permissions dialog box appears.

Projeck Security

X

~ Group

Mame: Iuse[gl

Diocument Types

ary Document Type
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Requirement Types

[" Canmanage project structure
[" Can manage project sacuriby

Permizgions:

rfufed

r;’u;’cd

Supplementary Requirement Type
Glozzam Requirement Type rfudcdd
Use Case Requirement Type rdudcid
Edit Pemizsions |
1] 4 I Cancel | Help |

X
| Enable security for thiz project
~ Jzers of Group: Administrators

Add...
Chris
Databaze Corversion Edit .
Devon —I
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e J Delete
KHebmer x s |

[elete |
| Cancel | Help |

Note: The Administrators group has full permissions. You cannot edit this group’s
permissions, but you can add and remove users from the Administrators group.

4 To assign project structure modification permissions to the group, select the Can
manage project structure check box. Groups with these permissions have complete
access to all tabs and information in the Project Properties dialog box for this
project. To remove a group’s permissions, clear the check box.

5 To assign project security permissions to the group, select the Can manage project
security check box. Groups with these permissions can change group and user
permissions for this project. To remove a group’s permissions, clear the check box.

6 Assign document, requirement, traceability, attribute, and attribute value
permissions, as described in the following sections.

7 Click OK.
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Assigning Document Type Permissions

To assign document-type permissions to a group:

1

On the Tool Palette, click Project > Security.
The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

In the Groups list, select the group.
Click Edit below the Groups list. The Group Permissions dialog box appears.

In the Document Types list, select the document type for which you want to assign
permissions.

Click Edit Permissions below the Document Types list.
The Document Type Permissions dialog box appears.

Document Type Permissions

Document Type:

| Interview |

Permizssions
IV Bead i a
V¥ Update [ Delete
ak I Cancel | Help |

Assign document permissions by selecting the corresponding check box. Groups
can have read, update, create, and delete permissions. To remove a permission
assigned to a group, clear the check box that corresponds to the permission. If you
do not want the group to have any permissions for this document type, clear all
selections.

2 Read permissions: Members of the group can view documents of this type. If
Read is the only permission selected, members of the group cannot modify
documents of this type.

s Update permissions: Members of the group can modify documents of this type.
If Update is selected, Read is also automatically selected.

s Create permissions: Members of the group can create documents of this type. If
Create is selected, Read and Update are also automatically selected.

2 Delete permissions: Members of the group can delete documents of this type. If
Delete is selected, Read, Update, and Create are also automatically selected.

Click OK to save the modifications.
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Assigning Requirement Type and Traceability Permissions

To assign requirement-type and traceability permissions to a group:

1

5

On the Tool Palette, click Project > Security.

The Project Security dialog box appears. (Make sure the Enable security for this
project check box is selected.)

In the Groups list, select the group.
Click Edit below the Groups list. The Group Permissions dialog box appears.

In the Requirement Types list, click the requirement type for which you want to
assign permissions and click Edit Permissions.

The Requirement Type Permissions dialog box appears.

Regquirement Type Permissions E

Fequirement Type:

| Feature Requirement Type |

— Permission
¥ Eead v Create
I i v Delete
Altributes: Permissions:
Teut 1u -
Friority i
Statug 1u
Cost 1u
Drifficulty i
Stability i
Aszsigned To i LI

Edit Permissions... |

— Traceability Permizzion:

¥ | Fead
V' Mark Suspect v Create
¥ Clear Suspect v Delete

QK I Cancel | Help |

Assign requirement type permissions by selecting the corresponding check box.
Groups can have read, update, create, and delete permissions for a requirement
type. To remove one of the other permissions assigned to a group, clear the check
box that corresponds to the permission.

= Read permissions: Members of the group can view all requirements of this
type. If Read is the only permission selected, members of the group cannot
modify requirements of this type. This permission is automatically selected,
and the box cannot be cleared.

s Update permissions: Members of the group can modify all requirements of this
type.
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s Create permissions: Members of the group can create requirements of this type.
If Create is selected, Update is also automatically selected.

2 Delete permissions: Members of the group can delete requirements of this
type. If Delete is selected, Update and Create are also automatically selected.

To add permissions for traceability relationships to and from requirements of the
selected type, select check boxes for the following:

s Read permissions: Members of the group can view all traceability relationships
between requirements of this type. This permission is automatically selected
and the box cannot be cleared.

s Mark Suspect permissions: Members of the group can set suspect traceability
relationships to and from requirements of this type. If the Clear Suspect check
box is selected, this check box is automatically marked.

2 Clear Suspect permissions: Members of the group can clear suspect traceability
relationships to and from requirements of this type.

2 Create permissions: Members of the group can create traceability relationships
to and from requirements of this type. If the Delete check box is selected, this
check box is automatically selected.

s Delete permissions: Members of the group can delete traceability relationships
to and from requirements of this type.

To assign attribute permissions to the security group, select a requirement
attribute and click Edit Permissions. For more information about attribute
permissions, see the following section.

Click OK in each dialog box to save the modifications.

Assigning Attribute Permissions

To assign permissions for a requirement name, requirement text, or requirement
attributes:

1
2

Select the requirement type, as described in the previous section.

In the Requirement Type Permissions dialog box, select the attribute, Name, or
Text for which you want to set permissions.

Click Edit Permissions.

The Attribute Permissions dialog box appears.
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s For list-type attributes, the dialog box pictured below appears.

Attribute Permissions

Attribute:
| Status |

o
Permission:
¥ |Fead

¥ Update

Adtribute Values: Permissions:

Propozed rfu
Approved T

Walidated T

Edit Permizsions. |
ok I Eancell Help I

The Read permission check box is automatically selected and cannot be cleared. To
allow users to modify attributes of the selected type, select the Update check box
and refer to the section that follows for more information on assigning permissions
to modify specific attribute values.

s For entry-type attributes, Name, or Text, the dialog box pictured below
appears.

Attribute Permissions

Attribute:

| Roseltem Type |

Pernizzions

¥ Fiead
v Update

Cancel | Help |

The Read permission check box is automatically selected and cannot be cleared.

4 Select the Update check box to give members of the group permissions to modify
the attributes. Clear the box to allow default Read permissions only.

5 Click OK.

6 Click OKin the Requirement Type Permissions and Group Permissions dialog
boxes.

202 Chapter 13 - Working with Project Security



Assigning Permissions for Attribute Values

For list-type attributes, you can assign permissions for specific attribute values:

1

Select an attribute, as described in Steps 1-3 in Assigning Attribute Permissions on
page 201.

Select the Update check box in the Attribute Permissions dialog box for a list-type
attribute.

The attribute values in the list box and the Edit Permissions button are enabled.
Select and attribute value in the list and click Edit Permissions.
The Attribute Value Permissions dialog box appears.

Attnbute Value Permissions E

Attribute Walue:

| Fropogzed |

Permizsion

¥ Fiead
Mu pdate

Cancel | Help |

The Read permission check box is automatically selected and cannot be cleared.

Select the Update check box to give members of the group permissions to modify
the attribute value. Clear the box to allow default Read permissions only for the
attribute value.

Click OK.
Repeat Steps 3 and 4 to set or remove group permissions for other attribute values.

Click OK in the Attribute Permissions, Requirement Type Permissions, and Group
Permissions dialog boxes.
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Managing Projects

This chapter provides instructions for the following tasks for managing Rational
RequisitePro projects:

Renumbering requirements

Printing project summaries and reports

Using Requirement Metrics

Archiving projects

Reading and recording a project’s revision information

Creating a project baseline with Unified Change Management
Removing documents and requirements from a project database
Moving projects

Copying projects

Moving a project between databases

The final section presents a list of file types used in RequisitePro.

Renumbering Requirements

If the project is opened in exclusive mode, you can renumber all requirements of one
or more specified types in the requirements document and database. This feature is
useful to eliminate the “holes” in a numbering scheme that result when you delete or
move requirements.

For more information, refer to Rebuilding Requirement Tags in a Document on page 139.

205



Printing Project Summaries and Reports

Printing a Project Summary in RequisitePro
1  On the Tool Palette, click Project > Print Summary.
2 Verify that the correct printer is selected.
3 Click OK.

Using Rational SoDA with RequisitePro

RequisitePro is integrated with SoDA, Rational’s software documentation automation
tool.

Using SoDA and RequisitePro, you can:

* Modify and generate SODA reports and documents from an open RequisitePro
project.

» Create a report that consolidates RequisitePro requirements information and Rose
modeling information.

= Create a use case report that includes all use case requirements and Rose use case
diagrams.

Before you begin the following procedure, make sure that the current version of SoDA
for Word is installed and that a RequisitePro project is open.

1 On the Tool Palette, click Project > Generate SoDA Report. The SoDA dialog box
appears, showing a list of templates for use with RequisitePro.

2 Select a template from the list and click OK. SoDA for Word appears. The SoDA
menu is active and the selected template is open.

3 Use the template to create a SODA report from the open RequisitePro project.
Refer to SODA documentation for more information about generating SODA reports.

Note: Do not begin generating a second SoDA report while the progress indicator is
active.

Using Requirement Metrics

Requirement Metrics provides project administrators and analysts with statistics
concerning a RequisitePro project’s attributes, relationships, requirements, and
revisions. These statistics are displayed in Microsoft Excel.
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You can use Requirement Metrics to retrieve information that is vital for evaluating:
» the progress of a project

» priorities, workloads, and deadlines

= the addition of new requirements

» changing or unstable requirements

» approved and incorporated features

You begin by creating one or more filters. A filter creates criteria for retrieving
requirement information. For example, you would use an Attribute Count Filter to
determine how many requirements in the project have a priority with the value
“High.” You then combine one or more filters to produce a query. A query combines
the criteria from multiple filters to analyze requirements. The filters that compose a
query are joined with the AND statement. You then combine one or more queries to
produce a report.

Two types of reports are available in Requirement Metrics:

= A static report uses static filters and shows results about the project at the present
time.

» A trend analysis report uses time-sensitive filters that analyze changes in
requirement text, attributes, traceability, and hierarchical relationships. Trend analysis
reports require that you specify an increment for displaying revisions.

Your report can address the following questions by using the corresponding sample
queries:

Question Query

How many requirements were created |* Requirements Creation filter
since the last release? = Options/Time Period > 10/15/99
How many High Priority requirements |= Attribute Value filter

do I have? = Priority = High

How many requirements went from = Attribute Value Change filter
Low Priority to High Priority in the last |, Priority Before = Low

month?

= Priority After = High
= Options/Time Period/Last Month
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How many requirements contain text |* Requirement Text Change filter
that has changed more than three times |,

Number of changes > 3
since the last iteration? &

= Options/Time Period > 10/15/99

What is the level of detail associated Children filter: > 0 children

with my requirements?

How stable is the organization of my = Parent Change filter
requirements? = Before = Select All

= After = Select All

Are my associations with other = Traceability Change filter: Select All

i ? . .
requirements stable? = Relationship = Trace To and From

= Action = Added or Removed

The Requirement Metrics main window is the primary user interface for the
application. This window allows you to select a requirement type for your report,
choose filters and filter criteria, and build queries and add them to your report. As
you add filters to your queries, you limit the requirements in your report to only those
requirements that match your filter criteria.

Access Requirement Metrics with the Tools > Metrics command or the Metrics button
on the Tool Palette. For more information, refer to the online help included with
Requirement Metrics.

Main Window Query Pane

The Query pane in the Requirement Metrics main window provides features for
selecting multiple filters in order to build a single query. The query concatenates the
filters when it is added to the Report pane at the bottom half of the main window.

The Query pane contains the following fields and controls:

Choose a Requirement View: Presents names of predefined views within angle
brackets for selection. (Users may also select a saved view from the RequisitePro
project.)

Note: Saved views for external projects are not supported in the list of saved views.

Types: Indicates each filter type included in your query. All queries include the Base
filter, which returns all requirements of the selected requirement type.

Criteria: Displays the criteria you have selected for each filter in the query.

Add Filter: Presents the Add Filter dialog box, which allows you select another filter to
add to the query.
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Delete Filter: Removes the selected filter from the query.

Add to Report: Combines all the filters you've selected into a single query and adds it
to the Report's query list.

Main Window Report Pane

The Report pane in the Requirement Metrics main window provides features for
managing the queries that you have added to your report.

The Reports pane contains the following fields and controls:

Names: Displays the label for each query in the report. To change the label text, click
the query once, click once more, and then type a label.

Criteria: Summarizes the filter criteria contained in each filter.

Move Up: Moves the selected query up in the list of queries. The order of the queries in
the Report pane determines the order in which they appear in the report.

Move Down: Moves the selected query down in the list of queries.
Delete Query: Removes the selected query from the report.

Create: Runs the report with the displayed query criteria.

Creating a Filter and Query

1 Select a view from the Choose a Requirement View drop-down list. This can be a
view that you have previously created in the Views Workplace, or it can be a
predefined view that includes all the requirements of a requirement type. The view
defines the requirement type that the filter uses.

2 Click the Add Filter button. The Add Filter dialog box appears, and a list of possible
filters is displayed.

3 Select a filter and click OK.

Tip: You can also select a filter by double-clicking on it.

An appropriate dialog box for the filter appears.

4 Make all your selections and click OK to add the filter to the filter list.

5 Add more filters to the list until your query is complete.
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Adding a Query to a Report

When you add the query to the report, Requirement Metrics builds all filters in the
filter list into a single query and adds that query to the report's list of queries. Filters
are joined in the query with the “AND” logical operator.

1 Click the Add to Report button. The query is added to the report’s list of queries
with a default label.

2 To change this label, select the query in the list, then single-click the query again.
The cursor changes into edit mode over the label.

3 Type your new label and press ENTER to save the changes.

4 To rearrange the order of the queries in the query list, select a query and click Move
Up or Move Down. The order to the queries determines the order in which they appear
in the report.

5 Click the menu command Options > Output Requirements Detail to display the
requirement tags, text, and attribute values (when applicable) in the report.

A separate worksheet is created in Microsoft Excel for each query in the report.

Setting the Time Controls

When you add any time-sensitive filters to the report, the Options > Time Period
command is made available. You can use this feature to filter for a relative time
period, such as “last week,” or you can select a specific beginning and /or ending date
for the report.

In addition, if the report consists of only time-sensitive queries, you can show
revisions in intervals of days, weeks, months, quarters, or years. This option enables
you to create a Trend Analysis report.

To set the time controls:

1 Click the Time Controls button on the toolbar. The Report Time Period dialog box
appears.

2 Do one of the following:

» (Click Relative Time Period and select a relative time period from the drop-down
list.

» Click Specific Time Period, and select an operator (such as “>") and a date from the
drop-down lists. When you select the “Between” operator, you must select a
beginning and ending date.
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3 For reports with only time-sensitive filters, select the Trend Intervals check box and
then select an interval from the drop-down list.

Note: If you select “Any Time” as your relative time period, the check box is not
enabled because there is no end date associated with this selection.

4 Select the Show Cumulative Counts check box to show the cumulative number of
requirements for each time interval.

Running the Report
After you have added queries to the report, you are ready to run it.
Do one of the following:
» Click the Create button.
» (lick the File > Create Report menu command.

The program opens Microsoft Excel and presents the requested statistics in a new
workbook. The results are also presented in a default graph. To reformat the graph,
use Microsoft Excel’s Graph Wizard.

Saving the Report

After you have added queries to your report, you can save it for repeated use. You can
open and edit saved reports in Requirement Metrics or run them from the Windows
command line.

1 To save the current report, click the File > Save Report As menu command.
The Save As dialog box appears.
2 Browse to a directory and type a file name for the report. Click Save.

Requirement Metrics saves the report, including all queries and settings, to a *.rqm file.

Opening and Editing a Saved Report
1 To open a saved report, click the File > Open Report menu command.
The Open dialog box appears.
2 Browse to a directory, select a saved report (with a .rqm extension), and click Open.

Note: When you edit saved reports and change any of the requirement types or
attributes, the saved report may become obsolete. An error message appears if you try
to run an obsolete report.
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Running from the Command Line

You can run Requirement Metrics from the command line outside of RequisitePro.
Click the Start button on the taskbar and choose the Run command.

The command line syntax is:
rqmetricsgui.exe ReportFile [user:=Username] [pass:=Password] [save:=Filename]

If any element of an argument contains any spaces, then you must enclose the entire
argument in double quotes.

Include the full path of the rqmetricsgui.exe. Typically this is C:\Program
Files\Rational\RequisitePro\bin\rgmetricsgui.exe.

The ReportFile argument should include the path and file name of the .rqm file you
want to run.

The argument user:=Username is required for all projects that have project security
set. If this project has security established, you must use a valid user name for the
project. If this is not a secured project, you must first successfully log into the project.
(This adds your user name to the project.) You can then use the same user name to run
Requirement Metrics from the command line. (Your current user name is specified in
your Tools > Options dialog box in RequisitePro.)

The optional argument pass:=Password specifies the password needed for the user
name. If either of these arguments is incorrect, you cannot access the project or run the
report you requested.

The optional argument save:=Filename specifies a name for an output file in Excel
format. This is useful for uninterrupted batch processing.

Note: If an Excel file with the file name already exists, Requirement Metrics
overwrites the file.

Archiving Projects

In RequisitePro, archiving is the process of duplicating the database, documents, and
all related files in a project for the purpose of restoring at a later time. There are two
methods for archiving projects from within RequisitePro:

* You can use the RequisitePro Archive command.
*  You can use the Rational ClearCase archive feature.

Note: .As an alternative to using these archiving procedures, you can create a baseline
if you are implementing the UCM model with ClearCase. See Creating a Project
Baseline with Unified Change Management on page 221.
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Neither archive method will automatically create a copy of your database if you are
using an enterprise database. Creating a baseline will create a copy for these
databases. Refer to Archiving Projects that Use an Enterprise Database on page 216 and
Creating a Project Baseline with Unified Change Management on page 221.

You can use a variety of configuration management tools, such as PVCS Version
Manager or Microsoft Visual SourceSafe, to archive your RequisitePro projects. If your
project uses a Microsoft Access database, first use the RequisitePro Archive command
to create archive files; then use your configuration management tool to archive these
files. Be sure to include all project documents in your archive.

Projects that participate in cross-project traceability should be archived or backed up
at the same point in time to maintain consistent traceability links between them.

Archiving Projects with the Archive Command

Using the Archive command in RequisitePro, you can make a copy of your entire
RequisitePro project in a separate directory.

Note: Projects that participate in cross-project traceability should be archived or
backed up at the same point in time to maintain consistent traceability links between
them.

1 On the Tool Palette, click Project > Archive > RequisitePro Archive. The Archive
Project dialog box appears.

Archive Project E
Project: | The Learning Praject - Traditional |

Diirectory: IE:\Program Filez\Rational\Fequiz = Browse... |
Bevizion #: |1_DD23 ™ Propagate to all documents

Wergion Label: I

Ehang_e . Modified requirement type ‘PR ;I
Description: - Deleted attribute 'Risk'.

E
oK I Cancel | Help |

2 Select the directory where you want the backup copy stored. Click Browse to open
the Browse for Folder dialog box. Navigate to a directory, select a folder, and click OK.
You return to the Archive Project dialog box.

Note: To add a new subdirectory to an existing directory path, click at the end of the
Directory field and type a forward slash (/) and a new subdirectory name.
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3 If you want to enter a new revision number for the project, type it in the Revision #
text box. The number must be greater than or equal to the current revision number (in
the form xxxx.yyyy). This number appears in the Revision tab of the Project Properties
dialog box.

4 To apply the revision number to the requirement documents, select the Propagate
to all documents check box.

Note: If security has been established, you must have project structure permission to
propagate the revision number. You must also have the project opened exclusively.

5 If you want to assign a version number for this archived project, type a name for
the archived version in the Version Label text box and a description for it in the
Change Description text box. This label appears in the Revision tab of the Project
Properties dialog box. A label can be used to easily identify this particular version of
the project at a later time.

Using the RequisitePro Archive command results in the following:

» Creates a directory to hold the archive files. Choose a directory name like
“BAKnnn” where nnn represents the version number of the project. (For example, if
the version number of the project is 1.0037, the directory could be called BAK137.)

» Copies the RequisitePro project files (.rgs and .rql) to the directory.
= Copies all project documents to the directory.

= Updates the version of the original project (if you have security permissions to
modify the project structure).

For Microsoft Access-based projects this command also performs the following:
» Copies the project database file (.mdb) to the directory.

» Updates the .mdb file in the archive directory with the location of the project
documents in the archive.

For enterprise database projects, the above two steps are not performed. These steps
are highly dependent on your configuration, and a solution provided in RequisitePro
would remove configuration flexibility. Therefore, the database administrator must
create a file containing a logical export of the database. This file must be placed in the
archive directory created by RequisitePro. See Tips for archiving and backing up
enterprise databases in online Help.

Note: To retrieve a project archived with the Archive command, add the archived
project to your project list (click Project > Open and then click the Add button) and
then open the project in RequisitePro.
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Archiving Projects with Rational ClearCase

To archive your RequisitePro projects in ClearCase, open the RequisitePro Options
dialog box (click Tools > Options) and specify the path of the default ClearCase view
for any new project being archived. Projects that participate in cross-project
traceability should be archived at the same point in time to maintain consistent
traceability links between them.

When you archive projects that use an Access database, ClearCase includes all project
files, documents, and database content in the archive. When you archive projects that
use an enterprise database, ClearCase includes only project files and requirements
documents in the archive. You must use your database utilities to archive the
enterprise database.

1 On the Tool Palette, click Project > Archive > Rational ClearCase. The Archive with
ClearCase dialog box appears.

2 Select the directory (ClearCase view) where you want the backup copy stored.
Click Browse to open the Browse for Folder dialog box. Navigate to a directory, select
a folder, and click OK.

You return to the Archive Project dialog box.

3 If you want to enter a new revision number for the project, type it in the Revision #
text box. This number appears in the Revision tab of the Project Properties dialog box.
Note that this is not the same as a revision number in ClearCase.

4 To apply the revision number to the requirement documents, select the Propagate
to all documents check box.

Note: If security is has been established, you must have project structure permission
to propagate the revision number. You must also have the project opened exclusively.

5 If you want to assign a version number for this archived project, enter a name for
the archived version in the Version Label text box and a description for it in the
Change Description text box. This label appears in the Revision tab of the Project
Properties dialog box. A label can be used to easily identify this particular version of
the project at a later time from within RequisitePro. Note that this is not the same as a
label in ClearCase.

This command performs the following:

» Retrieves the path of the view that was stored at the time of the last archive. If not
present, RequisitePro looks for the default view path specified in the Tools > Options
dialog box. If this is the first time the project is archived, RequisitePro creates the
archive directory in your view and makes it a ClearCase element. It remains
checked-out so the appropriate files can be copied.
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» Copies the RequisitePro project files (.rqs and .rql) to the directory.
» Copies all project documents to the directory.

= Updates the RequisitePro Revision # of the original project (if you have security
permissions to modify the project structure).

»  Checks in all files and the directory.
For Microsoft Access-based projects this command also performs the following:
= Copies the project database file (.mdb) to the directory

= Updates the .mdb file in the archive directory with the location of the project
documents in the ClearCase view.

For enterprise database projects, the above two steps are not performed. These steps
are highly dependent on your configuration, and a solution provided in RequisitePro
would remove configuration flexibility. Therefore, the database administrator must
create a file containing a logical export of the database. This file should be placed in
the archive directory created by RequisitePro and then checked into ClearCase.

Archiving Projects that Use an Enterprise Database

RequisitePro supports the use of the enterprise databases Oracle and SQL Server for
RequisitePro projects. Several considerations should be kept in mind when you
archive a RequisitePro project that uses one of these databases.

The following information guides RequisitePro project administrators, database
administrators (DBAs), and system administrators in archiving or backing up
RequisitePro projects that use enterprise databases so that no data is lost and archives
of your projects can be created quickly and dependably.

As an alternative to archiving, you can create a baseline if you are implementing the
UCM model with ClearCase. Creating a baseline simplifies the archiving process for
projects that enterprise databases. See Creating a Project Baseline with Unified Change
Management on page 221.

You can archive your project in one of two ways in RequisitePro: through the
RequisitePro Archive command or through ClearCase.

Using the RequisitePro Archive command results in the following:

* Creates a directory to hold the archive files. Choose a directory name like
“BAKnnn” where nnn represents the version number of the project. (For example, if
the version number of the project is 1.0037, the directory could be called BAK137.)

= Copies the RequisitePro project files (.rqs and .rql) to the directory
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» Copies all project documents to the directory

The database administrator must create a file containing a logical export of the
database. This file should be placed in the archive directory created by RequisitePro.

Using the ClearCase archive feature results in the following:

» Reverts to the last location where you archived

» Copies the RequisitePro project files (.rgs and .rql) to the directory
= Copies all project documents to the directory

The database administrator must create a file containing a logical export of the
database. This file should be placed in the archive directory created by RequisitePro
and then checked into ClearCase.

Logical Backups

A logical backup (import/export) of a database exports the database objects
independent of the physical location of those objects. In other words, a logical backup
exports the data stored in a table regardless of the location of the table (such as
tablespace or datafile). The Oracle Export Utility can create a file that contains all the
objects in a particular schema. The file can then be imported to the same schema to
recover from a failure or to a different instance or schema for archiving purposes.

Similarly, SQL Server can export all the database objects to another SQL Server. Unlike
the Oracle Export Utility, the SQL Server Import/Export Utility cannot export all the
database objects to a file. However, all the objects residing in a SQL Server database
can be stored in a backup file giving a similar result to the Oracle Export Utility. To
create a backup file in this manner, use the Enterprise Manager for SQL Server and
select the database that contains RequisitePro data in the left pane and select the
Backup database option in the right pane. On the SQL Server Backup dialog box,
make sure to select “Database - Complete” for this type of backup. The resulting
Backup file will contain all of the objects stored in the RequisitePro database.

The advantages of logical backups include the following:

= Logical backups are highly recommended before any upgrade to a new version of
Oracle, SQL Server, or RequisitePro. Prior to an upgrade, a logical backup will
provide the latest data in the event of a failure. Oracle may require a logical backup if
the newer database format is not compatible with the older database format. For SQL
Server, we recommend creating a physical backup (Database - Complete) through the
SQL Server Enterprise Manager.
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» In Oracle, logical backups can be used to detect block corruptions. If a corrupt
block is detected during an export, the export will fail. The corrupt blocks must be
repaired before a successful export can be obtained.

» Logical backups can be used to provide a test or development copy of your
RequisitePro projects. The test or development copy can be used to test a new release
of RequisitePro or to train new users.

» In Oracle, logical backups can be used to in conjunction with COALESCE to
defragment extents.

» Logical backups can be used to significantly alter your database structure such as
moving the RequisitePro Oracle schema from one Oracle tablespace to another or
using a different Oracle schema name. It can also be used to move RequisitePro data
to a different database in SQL Server.

= Logical backups are very useful when changing database servers.

The biggest disadvantage of logical backups is the amount of time they take to
perform. For large RequisitePro schemas or databases, it may take several hours to
complete a logical backup. For high-availability databases that are used around the
clock in different parts of the world, the time it takes to perform a logical backup can
have a serious implication on the database usability. For Oracle, consider using a
combination of incremental, cumulative, and complete logical backups to provide
flexibility to your users. SQL Server users might not be as affected by a logical backup
as Oracle users are.

Sessions should be restricted during a logical backup. The following sequence of
commands will allow you to put your database in restricted mode during a logical
backup. For Oracle, the following example demonstrates how to put the database in
restricted mode during an export.

SVRMGR> shutdown immediate

SVRMGR> startup restrict open

exp userid=reqpro/reqpro...

SVRMGR> alter system disable restricted session;

SQL Server databases can be put in single user mode by right clicking on the database
and selecting Properties. When the RequisitePro Database Properties dialog box
appears, select “Single user” under “Access” on the Options tab.

218 Chapter 14 - Managing Projects



Image Backups

Image backups (physical backups) are an alternative to logical backups for backing up
a RequisitePro databases. Unlike logical backups, image backups make physical
copies of the database files. Image backups are by nature more tightly coupled to the
database and its current operating state. For example, Oracle keeps track of the
current log sequence file number that is being used, and a backup must contain all the
redo log files necessary to build the database back to the correct log sequence file
number. Image backups should not be used if the RequisitePro projects share an
instance with data from any other application.

Offline image backup (or cold backup) refers to making physical copies of the
database files while the database is shut down. Offline image backups can be used
with RequisitePro data provided that whenever an offline image backup is created, a
backup of the RequisitePro project file(s) and documents is also created.

Online image backup (or hot backup) refers to making a copy of the database files
(offline image backup) and then making copies of the redo logs for Oracle or the
transaction logs for SQL Server. For Oracle, the database will need to be running in
ARCHIVELOG mode to create online image backups. For SQL Server, an
administrative task should be established to backup the transaction log for the SQL
Server database that contains RequisitePro data. Verify that no one is using
RequisitePro while you are performing an online image backup to ensure that the
data stored in the database matches the project documents.

Restoring Projects from an Archive
To restore a RequisitePro project from an archive, follow these steps:
1 Create a directory to hold the project you are restoring.
2 Do one of the following:

= If the RequisitePro Archive command was used, copy all the files from the archive
directory to the new directory.

» If the ClearCase Archive command was used to archive the project, copy all the
files from the ClearCase view into the new directory.

3 If the project uses a Microsoft Access database, you can start using the project from
this new location. If the project uses an enterprise database, you must do the
following:

» Restore the file containing the logical backup through the appropriate import
utility (for example, SQL Server Enterprise Manager).
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» Depending on how you are restoring the project, you may need to create database
objects such as a database, tablespaces, a user, or a role.

= If you are using Oracle, make sure the alias points to the correct database.

* Modifications to the project files (.rqs and .rql) may be required as a result of
changes in server name, database name, and user name. These changes can be
performed by using the Project > Open command, then adding the project, and with
the project selected, clicking the Properties button.

=  When the project is opened, references to documents that were not located in the
original project directory (before the project was archived) must be updated to reflect
the new location. The references can be updated by opening the document in
RequisitePro; when the Locate document dialog box appears, use the Browse button
to open the document in the new directory.

Note: Changes that you make to an archived project cannot be merged into any other
project.

Viewing and Entering Revision Information About the Project

Use the Revision tab in the Project Properties dialog box to view information about the
most recent revision of the project. Enter optional information about the most recent
revision, and access the project’s revision history.

Open the Project Properties dialog box by clicking Project > Properties, and click the
Revision tab.

» The Revision text box contains the revision number. This read-only text box cannot
be edited unless the project is archived using RequisitePro’s Archive command (or
checked into ClearCase). You can only override the revision number when the project
is archived. The new revision number that you use must be greater than the existing
number and must be expressed in an N.m format (for example, 2.5).

» The Label text box contains a descriptive name for the revision. This field is
optional, and it is available only if changes have been made to project properties.

= The Date text box is read-only and displays the date the project was modified.
= The Time text box is read-only and displays the time the project was modified.

= The Change Description text box displays changes made to the project. You can
type information into the field if changes have been made to project properties in
other tabs of the dialog box. Otherwise, the field is read-only.
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» The History button opens a dialog box that displays the change history of the
project.

Creating a Project Baseline with Unified Change Management

If your RequisitePro project is using the Unified Change Management (UCM) model,
you can create baselines of the project. RequisitePro project administrators can create
baselines of RequisitePro projects by performing tasks in ClearCase and Rational
Administrator, implementing the UCM model. For more information about UCM, see
Using Rational Unified Change Management to Create a Project Baseline on page 251.

Note that the time required for checking in a project is proportional to the number of
requirement types, documents, and saved views in the project.

For archiving projects that do not use the UCM model, refer to Archiving Projects with
Rational ClearCase on page 215.

Note: When creating a project from a baseline, the newly created project does not
maintain the cross-project traceability links, discussions information, and associations
with Rational ClearQuest and Rational Rose from the original baselined project. Refer
to Creating a RequisitePro Project from a Baseline on page 188.

You can baseline a RequisitePro project when the following conditions are met:

» The RequisitePro project must be associated with a UCM-enabled Rational project
in Rational Administrator.

» The RequisitePro project must be versioned.

» All users must have closed the Requisite Pro project.

To check in the RequisitePro project:

1 Click Tools > Rational Administrator to open Rational Administrator.

2 Select the Rational Administrator project, right-click, and select Configure on the
shortcut menu.

3 In the Configure Project dialog box, in the Requirements Assets area, click the
Check In All button.

4 Confirm your selection at the messages that follow, and type an activity to describe
the baseline in the Check in all dialog box.

5 After the check in operation is completed, close the Configure Project dialog box.
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To create the baseline:

1 Open the Rational ClearCase Project Explorer.
Tip: From Rational Administrator, you can click Tools > Rational ClearCase Project
Explorer.

2 Right-click on the integration stream for the associated UCM project and click
Make Baseline from the shortcut menu.

3 Type or edit the Baseline Title, select a View Context, and click OK.

Note: You can ignore the message that the integration view contains elements that are
currently checked out. All files do not need to be checked in if you are creating a
baseline of a RequisitePro project.

Removing Documents and Requirements from a Project
Database

When a document and its requirements are removed from the project database, the
requirement formatting and the requirements are deleted (although the text remains),
and the document can only be referenced outside RequisitePro as a Word document.
The project must be opened exclusively to perform this operation. (For more
information about the exclusive option, refer to Opening a Project and Documents on
page 35.)

To remove documents and requirements:

-

Open the document in RequisitePro.

2 Do one of the following:

[

In the Word Workplace, click RequisitePro > Document > Remove.
a On the Tool Palette, click Document > Remove.

A confirmation dialog box appears.

RequisitePro
@ This removes the current document and all agsociated requirements from a project.
- 'ou will not be able to reference this document in RequizitePro again as a project document.
- &l ket will remnain, and pou can reference the document az a Word document.

- fou may re-introduce this document into FequisitePro later, but all requirermnents and attribute selections will be lost.

Proceed with removing the document named "Saftware Bequirements Document’ [LEARMSRS SRS]?

3 To remove the document, click Yes. To cancel the operation, click No.
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Moving Projects

If you are using an Access database for your RequisitePro project, you can move the
project to a new location, such as a different server. Do not attempt to copy or move a
RequisitePro project by copying the project directory from one location to another.
Internal unique identifiers may cause conflicts if the project uses cross-project
traceability.

To move an Access-based project:

1 Remove the project from your list of projects. Click Project > Open, select the
project name in the Select a Project field, and click Remove.

2 Copy the project files to your new location using Windows Explorer.

3 Add the project in its new location to the list of projects. Click Project > Open, and
click Add at the Select a Project field.

4 Rename the original project directory and all directories that contain project
documents (so that you have a backup in case anything goes wrong). You can delete
this directory when you are comfortable that the move was successful.

Note: If you want to save a copy of the original directory, see the next section for
instructions.

5 Open your project in RequisitePro. The first time you open a project document that
is not stored in the project directory, you will be prompted to locate the document.
Select it from the new location.

Note: If you have a document that is not stored in the project directory and you try to
open it, you may be prompted to find it and to select it from the new location.

If you are using an enterprise database for your RequisitePro project, consider
whether you need to move an individual project or the entire database.

2 If you need to move the database, you should consult your database
administrator.
a If you need to move an individual RequisitePro project to another database, use

the Data Transport Wizard.

Copying Projects

Do not attempt to copy or move a RequisitePro project by copying the project
directory from one location to another. Internal unique identifiers may cause conflicts
if the project uses cross-project traceability. If you are using an enterprise database for
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your RequisitePro project, copying the project directory does not copy the project
database. Both copies of the project will continue to point to the same database
instance, and conflicts between document and requirement updates will result.

You can copy the structure and data of a RequisitePro project in one of the following
ways:

» If you are using an Access database for your RequisitePro project, you can move a
project to another location and keep a backup copy. (Refer to the previous section.)

» For any project, you can create a template based on the project and create a project
based on that template. Document types, requirement types, attributes, user and
group permissions, views. and data can be copied to the template and to the new
project. (Refer to Creating a RequisitePro Project on page 181.)

» If you are implementing the UCM model with ClearCase, you can create a project
from a baseline. All the data from the baselined project is copied to the new project.
(Refer to Creating a RequisitePro Project from a Baseline on page 188.)

You can also split a project and keep some requirements in one project and others in a
new project. Before you begin, we strongly recommend that you archive your original
project. Keep in mind that you cannot merge the two copies of the project back
together into one project.

1 Use the Project > Archive command to make a physical copy (B) of your
RequisitePro project (A).

2 Open your copy (B) in RequisitePro and change the project name under the
General tab of the Project Properties dialog box.

3 Delete requirements in each project to be left with one copy of each requirement in
each project. (See Deleting Requirements on page 141 for more information.)

Moving a Project Between Databases

RequisitePro uses open database connectivity (ODBC) technology to access the
databases. It ships with ODBC version 3.5 and the following components: Access Jet
Engine 4.0 for use with Microsoft Access; ODBC driver 2.5 for use with Oracle; and
ODBC driver 3.7 for use with SQL Server. All files needed for ODBC and Access are
shipped and installed with RequisitePro. (For information about establishing an
ODBC data source, see online Help.)

Read-only access to RequisitePro projects that use the Microsoft Access database is
available with Access or any third-party tool using ODBC. This can be helpful for
retrieving data and creating reports.

224 Chapter 14 - Managing Projects



The use of client/server databases offers significantly increased scalability and power
to your organization’s implementation of RequisitePro. With RequisitePro, you can
use Oracle, SQL Server, and Microsoft Access databases. These databases (with the
exception of Access) are designed for scalable, enterprise-wide use.

The Data Transport Wizard, included with RequisitePro, enables you to move a
RequisitePro project from one database to another. The wizard can move data
between any combination of the following supported database types: Microsoft
Access, Oracle, and SQL Server. (It cannot move data between two Access databases.)
However, it does not move projects that are connected by cross-project traceability.

The Data Transport Wizard requires that the following conditions be met prior to
performing the database type conversion. The wizard displays messages to alert you
if any conditions are not met.

* The project must be saved in the current version of RequisitePro.
* You must have administrator permissions for the project.
* You must have log on and write permissions for the target database.

* Your database administrator must supply you with the user name and password,
a server name, and a schema name in order to access an enterprise database.

Note: Make sure all RequisitePro users have closed the project before you continue. It
is strongly recommended that you archive or backup both the source and the
destination database and related documents before continuing with the move. For
more information on configuring an enterprise database, see the guide Installing
Rational RequisitePro.

If you have installed the Oracle Setup and SQL Server Setup under the Custom/Full
installation process, you can access the following documents in your RequisitePro
Help directory (<install drive>\Program Files\Rational\RequisitePro\help):

* Configuring an Oracle database (oraclesetup.html)

» Configuring a SQL Server database (sqlsetup.html)

Starting the Data Transport Wizard

It is strongly recommended that you archive or backup both the source and the
destination database and related documents before continuing with the database type
conversion. (Refer to Archiving Projects on page 212.)

Note: Prior to running the wizard, you must open RequisitePro once. Then make sure
to close any open RequisitePro project before starting the wizard.
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Open the Data Transport Wizard in Windows Explorer. The executable,
rqdatatransportwiz.exe, is located in the Rational\RequisitePro\bin\directory.

The Data Transport Wizard introduction screen appears. Each screen of the wizard
includes a Help button. To view step-by-step instructions about using the screen, click
the Help button in that screen.

Moving a Project to an Oracle Database

If you have installed the Oracle Setup under the Custom /Full installation process,
you can access detailed information on configuring an Oracle database (located in the
directory <install drive>\Program Files\Rational\RequisitePro\help). To move a RequisitePro
project to an Oracle database, follow the steps below.

We recommend that you archive your project before you change databases. Click
Project > Archive > RequisitePro Archive.

1 Open the Data Transport Wizard in Windows Explorer. The executable,
rqdatatransportwiz.exe, is located in the Rational\RequisitePro\bin\ directory.

2 Click Next at the first Data Transport Wizard screen, and then browse to select the
project you want to convert.

3 At the project/database screen, click Choose to open the Database Properties
dialog box. Select Oracle at the Database field and click the Configuration button. The
Microsoft ODBC for Oracle Setup dialog box appears.

Note: Do not modify the default entries in the Data Source Name and Description
fields.

4 Type your User Name for logging on to the Oracle database. This should be
supplied to you by your Oracle database administrator.

5 For the Server field, type the alias you created when configuring your machine (for
example, OracleDB).

6 Click OK to return to the Data Transport Wizard project/database screen.

7 Click the Account Info button to enter database account information and follow the
remaining screens. For Schema, type the name of the database schema that has been
established by your database administrator for storing projects. (All projects can use
the same database schema.) Then view the Conversion Report, and exit the wizard.
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Moving a Project to a SQL Server Database

If you have installed the SQL Server Setup under the Custom/Full installation
process, you can access detailed information on configuring a SQL Server database; it
is located in the directory <install drive>\Program Files\Rational\RequisitePro\help. If you
want to convert a RequisitePro project to use a SQL Server database, follow the steps
below.

Note: We recommend that you archive your project before you change databases.
Click Project > Archive > RequisitePro Archive.

1 Open the Data Transport Wizard in Windows Explorer. The executable,
rqdatatransportwiz.exe, is located in the Rational\RequisitePro\bin\ directory.

2 Click Next at the first Data Transport Wizard screen, and then click Browse to
select the project you want to convert.

3 At the project/database screen, click Choose to open the Database Properties
dialog box. Select SQL Server at the Database field and click the Configuration button.

4 In the Create a New Data Source to SQL Server dialog box, do not modify the
Name or Description. In the Server field, type the name of the SQL Server, supplied
by your database administrator. Click Next.

5 On the next screen, select the option With SQL Server authentication using a login ID
and password entered by the user. (Note: RequisitePro does not support Windows NT
authentication.) Be sure the check box Connect to SQL Server to obtain default settings
for the additional configuration options is selected. Type a login ID and password

supplied by your database administrator, such as “ReqPro” and “reqpro.” Click Next.

6 Select the check box Change the default database to and select a database name
supplied by your database administrator, such as “RequisistePro.” Click Next.

7 Click Next to accept the default language, character, and regional settings. The use
of log files, shown on the screen that follows, is optional.

Note: Do not select the check box Change the language of SQL Server system
messages to . . . The use of this check box prevents users from opening the project
after its initial creation. Click Finish.

8 In the ODBC Microsoft SQL Server Setup dialog box, click the Test Data Source
button. Click OK in the SQL Server ODBC Data Source Test dialog box. Then click OK
to return to the Data Transport Wizard project/database screen.

9 Click Account Info to enter database account information and follow the remaining
screens. For Schema, type the user name of the owner of the database tables. Then
view the Conversion Report, and exit the wizard.
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RequisitePro File Types

The following file types are used for project files and other RequisitePro information

files:
Fi
ile . Definition

Extension

Iqgs A RequisitePro project information file.

.mdb A RequisitePro project database (using Microsoft Access). This file is not
used for enterprise databases

xql A RequisitePro project file that specifies the ODBC and database account
information.

xml RequisitePro project files that contain structure, security, and permission
information.

.doc A Microsoft Word document file.

bak A backup document file.

.dot A Microsoft Word template.

.def An outline’s definition file.

Axt Plain text menu files used to add commands to Tool Palette menus.

.mnu

hlp A Windows application help file.
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Working with Project
Information

Project administrators can modify information about a Rational RequisitePro project,
including:

General project information
Document types
Requirement types
Requirement attributes
Attribute values

Cross-project traceability

Working with General Project Information

You can create and modify a RequisitePro project’s general information through the
General tab in the Project Properties dialog box.

1

On the Tool Palette, click Project > Properties.

The Project Properties dialog box appears.

2 C(lick the General tab.

3 In the Name text box, type or modify the project name, up to 64 characters.

Note: Note: You can change the name at any time. Be sure to use a unique project
name for each project; this is important when configuring e-mail using the
Rational E-mail Reader.

In the Prefix text box, type or modify the project prefix. This identifier is used to
identify requirements and requirement types in this project when it is referenced
as an external project for cross-project traceability.

Note: The prefix can be up to 8 characters, it is stored in uppercase letters, and it
can be changed at any time.
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5 The Directory text box specifies a path for RequisitePro to store the project. For new
projects, type the project directory, or click Browse. After the project is created,
you cannot change this field.

Note: You can later relocate the project by moving the project directory to another
location in the system. To access the project in its new location, users must add it to
their project lists.

6 The Database field displays the type of database selected for the project. You have
the option to create projects in Microsoft Access, SQL Server, or Oracle. To modify
the database type, you must run the Data Transport Wizard. You can click
Properties to open the Database Properties dialog box, where you can view and
modify information about the database.

7 In the Description text box, type or modify optional information describing the
purpose and content of the project.

8 C(lick OK.

Working with Document Types

You can create document types and modify existing document types. If you no longer
need a document type, you can delete it.

A document type defines descriptive and operational information associated with a
requirements document. The document type serves as an outline for each document
you create of that type.

The document type defines the document’s file extension, such as .prd; all documents
of the same document type share the same file extension. The document type
identifies a default requirement type; each new requirement you create in the
document will be based on the default requirement type unless you indicate
otherwise. The document type also identifies an outline (or template) for the
document, which controls its page layout, heading and paragraph styles, and a
default font.

When you create or modify your project, you determine the document types to use in
the project. Each document in your project must be associated with a document type.
More than one document can be associated with the same document type.

When you create a document, you associate it with a document type that you have
already defined in your project. The document type defines the characteristics of the
documents associated with the document type. This makes all documents of the same
type consistent.
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To help you define a common format for your document types, you can choose
outlines included with RequisitePro to associate with new or existing document

types.

Creating and Modifying Document Types
1 On the Tool Palette, click Project > Properties. The Project Properties dialog box
appears.

2 Click the Document Types tab.

Project Properties ﬂ

Gerneral | R ewizion I Reguirement Tppes
D ocuments Document Types | Attributes
Document Type: E stengion:
Glossary Document Type GLS Add...
Supplementary Requirement S pecification 0... SUP
Uze Caze Specification Document Type cs Melete
Wigioh Document Type WIS

Edit...

Description

Bl

-

ak. I Cancel Help

3 Do one of the following:
s To add a new document type, click Add.

s To modify an existing document type, select the requirement type in the list,
and then click Edit.
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The Document Type dialog box appears.

Document Type
Marne: IUse Caze Document Type
Description: RequisitePro provided |ze Case :I
[
File

Extenzion:  |LUSE

— Default Regquirement Type:
IUse Case Lean Requirement Type j Mew ...
= Outling
Mame: IUse Case Specification j
Desaription:  [Eohion) supplied use case document -
zpecification. -

Ok, I Cancell Help |

4 In the Name text box, type a unique name for the document type.
5 In the Description text box, type a description.

6 In the File Extension text box, type a file extension. Type a three-character text
string, or, if long file names are supported, a longer extension. The file extension is
applied to all documents associated with the document type.

7 Select a requirement type in the Default Requirement Type list. The default
requirement type is used to specify the type of requirement that is created when
Fast Create is used.

8 Select an Outline from the list. If you use the default selection None, documents are
associated with the normal.dot Microsoft Word template. See Using RequisitePro
Document Outlines on page 233 for more information on available outlines.

Note: If you select a new outline, the new outline applies to new documents only.
Existing documents are not affected by the change.

9 Click OK. The new or modified document type appears in the list box.
10 Click OK in the Project Properties dialog box.

Note: You can edit the .dot files associated with your document types to include
your company name and other information specific to your organization. You can
enter this information in the Microsoft Word File > Properties dialog box. Then in
the document itself, right-click on the Company-Name field, and select Update
Field.
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Deleting Document Types

If no documents of a particular document type exist in a project, you can delete the
document type.

1 On the Tool Palette, click Project > Properties. The Project Properties dialog box
appears.

2 C(Click the Document Types tab.
3 In the Document Type list, select the document type you want to delete.

4 C(Click Delete.

Using RequisitePro Document Outlines

Outlines are document templates that are useful for maintaining consistency across
RequisitePro documents of the same type. Outlines can help you quickly create
user-needs documents, specifications, and test plans.

Note: If you have installed Rational TestManager, we recommend that you develop
all test artifacts in that tool. Test-related outlines are included with RequisitePro for
users who do not have TestManager.

Every new document in RequisitePro includes default formatting information. New
documents are based on document types, which include a default file extension, a
default requirement type, and an associated outline. You can assign outlines to a
document type in the Project Properties dialog box (Document Types tab).

RequisitePro includes the following outlines that can be used when creating
document types in your project:

» Software Requirements Outline
* Modern Software Requirements Specification
» Functional Test Case Specification

RequisitePro includes the following Rational Unified Process (RUP) outlines for
requirements management:

= RUP Requirements Management Plan
» RUP Glossary

= RUP Vision Document

» RUP Stakeholder Requests

» RUP Use Case Specification

Working with Document Types 233



RUP Use Case Software Requirements Specification

RUP Test Plan

RequisitePro includes these additional outlines for business modeling:

RUP Business Glossary

RUP Business Rules

RUP Business Vision Document

RUP Business Use Case Specification

RUP Business Use Case Realization Specification

RUP Supplementary Business Specification

Document outlines are included by default when you use a RequisitePro project
template. See Reviewing RequisitePro Project Template Options on page 182.

Note: You can edit the .dot files associated with your document types to include your
company name and other information specific to your organization. You can type the
company name or other information in the Microsoft Word File > Properties dialog
box. In the document, right-click on the Company-Name field and select Update Field.

Creating Your Own Outlines

1

Start Microsoft Word outside of RequisitePro.

2 Create a new template. (See the Word documentation for more information about

creating templates.)
Move the new template and help file to the RequisitePro Outlines directory.

Note: Templates are automatically stored in the RequisitePro Outlines
subdirectory. You can set a second location for additional templates, such as those
shared on a network or used by a particular project.

Use the Tools > Options command on the Tool Palette to specify a secondary
location for the outlines. Type the full path and subdirectory name in the Outline
Path field, and click OK.

In a text editor, create a new text file containing the following three lines of
information, separated by carriage returns (<CR>):

s The outline’s full name, up to 64 characters
Important: Be sure that this logical name is unique in the Outlines directory.

2 A description of the outline, up to 256 characters

s The Word template’s DOS filename
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For example:

Acme Enterprises Standard Software Requirement Specifications<CR>
Standard outline used for Software Requirements Specifications at
Acme Enterprises<CR>

acme srs.dot

In the Outlines directory, save the text file, using the same file name as the template
and the extension .def (for example, acme_srs.def).

To enable your team to create consistent documents, you can save the outline in a
shared directory. All users can set a second location for additional outlines in the
Options dialog box. Use the Tool Palette Tools > Options command to open the
Options dialog box and type the full path and subdirectory name in the Outline Path
field.

Note: You can edit the .dot files associated with your document types to include your
company name and other information specific to your organization. You can enter the
text in the Microsoft Work File > Properties dialog box. In the document itself,
right-click on the Company-Name field and select “Update Field.”

Working with Requirement Types

You can create requirement types and modify existing requirement types. If you no
longer need a requirement type, you can delete it.

A requirement type defines descriptive and operational information associated with a
requirement. A requirement type serves as a template for all requirements of the same
type and is useful for ensuring consistency and classifying or grouping similar
requirements in a project. Requirement types can specify the initial numbering of the
requirements; required terms, such as “must” or “shall”; a standard prefix, such as
PR; and color and text formatting. Each requirement type has a unique set of
user-defined attributes.

If you are using a project template as a starting point, several requirement types will
already be created. You can add or remove a requirement type to fit your process
(Project > Properties, Requirement Types tab). You can also modify a requirement
type after it has been created. To do so, you must open the project in exclusive mode,
and if security is enabled, you must have project structure permission to change the
tag prefix, color, or style.
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Creating and Modifying Requirement Types

1 On the Tool Palette, click Project > Properties.
The Project Properties dialog box appears.

2 C(Click the Requirement Types tab.

Project Properties |

Documents I Daocument Types | Attributes
General I Revizion Requirernent Types

Requirement Tupe:
FEAT: Feature Requirement Type Add.
SUPP: Supplementary Feguirement Type
TEEM: Gl T
UC: Uze Caze Requirement Type

Delete

=
Edit... |

Dezcription
Thiz requiremnent type identifiez all glozzam items within the Claszsics, Inc. ;I

project.
I

(] I Cancel | Help

3 Do one of the following:
2 To add a new requirement type, click Add.

»  To modify an existing requirement type, select the requirement type in the list,
and then click Edit.

The Requirement Type dialog box appears.

Requirement Type
M ame: ISoflware Fequirement Type
Description: The Saftware Requirement Type is for all |« |
software requirerments
[ -]
Initial Requirement #: |1 " Gliow External Traceabili

Reguirement Must Contain: |

Reguirement T ag Prefix: ISH
Reguirement Color: IDark Red j

Riequirement Style: |DoubleUnderine =l

Ok I Cancel | Help |
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4 Complete the fields in the dialog box as follows:

Q

In the Name text box, type or edit a name for the requirement type (up to 64
characters).

In the Description text box, type or edit a description (up to 255 characters).

To enable external traceability between requirements of this type in this project
and other projects, select the Allow External Traceability check box.

To specify the starting number for the first requirement of the defined type,
click the Initial Requirement Number text box and type a positive integer to start
this sequence. RequisitePro automatically numbers requirements when they
are created.

The default value for this text box is 1. The initial number sequence can be
modified any time before the first requirement of this type is created. After the first
requirement of this type has been saved, you must use the Renumber
Requirements dialog box to change the sequence.

=)

In the Requirement Must Contain text box, type a single word or phrase that
must be included in every requirement of this type that is created. This field is
optional and is not case-sensitive.

Note: Exclusive access to a project is necessary to modify the values in the
following three steps for an existing requirement type. These options can be
modified at any time.

In the Requirement Tag Prefix text box, type or edit a tag prefix for a requirement
type. Examples of tag prefixes are SR and PR.

In the Requirement Color list, click the down arrow and select a color. The color
is assigned to a requirement of this type when it is displayed in a document.
The default color is blue.

In the Requirement Style list, click the down arrow and select a style. The style
is assigned to a requirement of this type when it is displayed in a document.
The default style for this text box is Double Underline. You can also select
Normal (no styling) or Small Capitals.

5 Click OK. In the Project Properties dialog box, Requirement Types tab, RequisitePro
displays the new or edited requirement type with its tag prefix and logical name.

6 Click OK to close the Project Properties dialog box.
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Deleting Requirement Types

You can delete a requirement type if there are no requirements of this type in the
project and if document types do not reference it as a default. You must have the
project opened in exclusive mode to delete requirement types.

1 On the Tool Palette, click Project > Properties. The Project Properties dialog box
appears.

Click the Requirement Types tab.
Select the requirement type you want to delete.

Click Delete.

a A WO DN

Click OK.
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Working with Requirement Attributes and Attribute Values

Use the Attributes tab in the Project Properties dialog box to add an attribute. You can
also use this tab to modify an existing attribute.

The following table shows suggested attributes that can be helpful for defining your
requirements in RequisitePro. These attributes are suggestions, not rules. You can use
these suggested attributes, which are provided with RequisitePro, or you can define
and use any attributes that are appropriate for your project and business.

Attribute Use to identify requirements by

Priority Importance to the project. Helps team members prioritize
their efforts and use their time more effectively.

Status Progress

= If a requirement’s status is Proposed, the requirement is
currently being discussed by the project team.

= If a requirement’s status is Approved, the requirement
has been discussed and agreed upon.

= If a requirement’s status is Incorporated, the
requirement has been added to the appropriate
specification.

Authors Individual or team that created or changed the
requirement’s text or attributes.

Responsible Party Individual or team responsible for ensuring the
requirement is satisfied.

Rationale Text of or reference to an explanation. For example, the
reference might be to a page and line number of a product
requirement specification, or to a minute marker on a
video tape of an important customer interview.

Cost Cost to implement the requirement. The attribute value
for this attribute can be logical (high, medium, low) or
numerical.

Note: The list of requirement attributes above provides examples. Other common
attributes include Difficulty, Stability, Risk, Security, Safety, Release Implemented, and
Functional Area. RequisitePro also maintains system attributes for all requirements,
including date, version, and relationship to other requirements.
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You can create and control attributes according to your needs. Regardless of the
attributes you use, RequisitePro offers the flexibility to easily customize your project
documents and databases to define, articulate, and manage the processes and culture
of your organization.

You cannot delete requirement attributes if requirements of the requirement type
already exist or if the requirement type is the default of a document type.

Creating and Modifying Requirement Attributes
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Use the Attributes tab in the Project Properties dialog box to add an attribute or
modify an existing one.

1 On the Tool Palette, click Project > Properties.
The Project Properties dialog box appears.

2 Click the Attributes tab.

The attributes for the selected type are displayed in the same order as in the
Requirement Properties dialog box.

Project Properties m
General | Revision | Reguirement Types
Documents | Document Types Aftributes

Fequirement Type: Regquirement Type

Regquirement Attributes
Labels for Attributes

Brief Description -
Property
Affects Architecture

Planned lteration
Actual teration

Asgsigned To LI
Add.. Edit... | Helete | fidl e (e | Il e g |
(0] 4 | Cancel | Help |

3 To reorder attributes, select the attribute in the Labels list and then click the Move
Up or Move Down button.

4 For list-type attributes, to designate a value as the default value, select the attribute
in the Label box. In the Values per Attribute box, select the value and click Default.

5 To add an attribute, click Add.
The Add Attribute dialog box appears.
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6 In the Type list, select a type. The following data types are supported:

Data Type Allows Example
List (Single A set of values from which a single | High, Medium, or Low
Value) value can be selected. Each List

value can be up to 32 characters in

length.

List (Multiple A set of values from which more |Sue, Bob, and John
Value) than one value can be selected.
Each List value can be up to 32
characters in length.

Text A text string up to 255 characters. | John Smith
Integer Whole numbers. 5, 1500
Real Real numbers. 1.345, 6.7
Date A date in the format defined by the | mm/dd/yy

user’s Windows setting.

Time A time in the format defined by a |10:00 AM
user’s Windows setting.

The dialog box changes, depending on the type you select. If you select List (Single
Value) or List (Multiple Value), the dialog box contains a List Values text box. If you
select one of the other types, the dialog box contains a Default Value text box.

Add Attribute [ x| Add Attribute [ ]

Lahbel I Labhel: I
Type: IL\st (Single value) ﬂ Type IDate j
ListWalues: N Default
_I YWalue I
a
™ Hidden from display ™ Hidden from display
[T Change affects suspect [~ Change affects suspect
Enter each list value followed by <Erters. Order Enter an optional default value for this attilbute.

the values on the list as you want them to sor.

oK I Cancel | Help | Ok I Cancel Help

7 In the Label text box, type a name for the attribute.

8 If the data type is a list-type, type the values in the List Values text box.
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If the data type is an entry-type, type a default value (optional). If a new
requirement is created and a value is not specified for the attribute, RequisitePro
uses the default value.

9 To hide attributes of the selected requirement type from all RequisitePro users in
the Views Workplace and in the Requirement Properties dialog box, select the
Hidden from display check box.

10 To ensure traceability relationships are marked as Suspect when attributes are
changed, select the Change affects suspect check box. When this check box is
selected, RequisitePro monitors all requirements (based on this requirement type)
and ensures that the status of all relationships labeled Traced to and Traced from for
this requirement is changed to Traced-Suspect if the attribute value is changed.

11 Click OK. The new or edited attribute appears in the Attributes tab of the Project
Properties dialog box.

12 Click OK to close the Project Properties dialog box and save the changes.

Modifying Attribute Values
You can add, delete, and edit the values assigned to a particular list-type attribute.

1 On the Tool Palette, click Project > Properties. The Project Properties dialog box
appears.

2 Click the Attributes tab.

3 In the Requirement Type list, select the requirement type; in the Labels for
Attributes list, select a single or multiple-value list-type attribute; and in the Values
per Attribute list, select the value that you want to edit.

4 Click Edit. The Attribute Value dialog box appears.

Attribute Yalue E

Walle: |High

0k | concel | Hel

5 In the Value text box, modify the value.

6 To use the value as the default value, select the Use as default check box.
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7 Click OK. The changes to the attribute values appear in the Attributes tab of the
Project Properties dialog box.

8 Click OK to close the Project Properties dialog box.

Deleting Attribute Values
To delete attribute values, you must have the project opened exclusively.

1 On the Tool Palette, click Project > Properties. The Project Properties dialog box
appears.

Click the Attributes tab.
In the Requirement Type list, select the requirement type.
In the Labels for Attributes list, select the list-type attribute.

In the Values per Attribute list, select the value that you want to delete.

» 0 A W DN

Click Delete.
If the value is not assigned to any requirements in the project, the value is deleted.

If the value is assigned to any requirements in the project, the Remove Value
dialog box appears.

Aemove Yalue E

Ore or mare requirements in the project
contain this value for the attibute
‘Status’

Far theze requirements, replace the
walue 'Started' with the value:

QK I Cancell Help |

2 In the list, select a value to use as a replacement for the removed value.
o (Click OK. The value is removed from the Values per Attribute list.

7 Click OK to close the Project Properties dialog box.
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Setting Up and Modifying Cross-Project Traceability

Cross-project traceability enables direct traceability relationships between
requirements in different RequisitePro projects. This RequisitePro feature eliminates
duplication by allowing reuse of requirements among various teams working on
related projects. Often a set of requirements is common to multiple projects. These
requirements can be created in their own RequisitePro projects and traced to
system-specific requirements located in their respective RequisitePro projects.

Projects must be created prior to setting up cross-project traceability. You can
configure projects to connect automatically to external projects when a project with
externally traced requirements is opened. You can also connect external projects
manually.

After you connect an external project, all externally traced requirement types are
available for traceability relationships. External requirement types are displayed in
the RequisitePro dialog boxes used to create traceability relationships. External
requirements are identified with a project prefix set in the General tab of the Project
Properties dialog box for the external project.

Marking Requirement Types for Cross-Project Traceability

To allow cross-project traceability for requirements in a project, you must do the
following:

2 Assign a project prefix so you can distinguish between requirements in
different projects.

s Manually mark requirement types in the project as externally available. Only
requirements of these types will be available for cross-project traceability.

1 On the Tool Palette, click Project > Properties. The Project Properties dialog box
appears.

2 C(Click the General tab.

3 If the project does not have a prefix, enter a prefix for the project (up to 8
characters). The prefix is stored in uppercase letters. You can change it at any time.

4 Click the Requirement Types tab.

5 In the Requirement Type list box, select the requirement type to mark for external
traceability.

6 Click Edit.
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The Requirement Type dialog box appears.

Requirement Type
Mame: ISDFtware Requirement Type
Description: The Software Requirement Tppe iz for all A

software requirements

Initial Fequirement #: |1

Requirement kust Contair: I

Requirement Tag Prefis: ISH

Requirement Color: I Dark Red ﬂ

Requitement Style: [DoubleUnderiine 4|

QK I Cancel | Help |

7 Select the Allow External Traceability check box, and click OK. RequisitePro marks
the requirement type for cross-project traceability.

8 Repeat Steps 5 through 8 for any other requirement types.
9 Click OK to close the Project Properties dialog box.

Connecting Projects

Once the requirement types in the external projects have been marked for external
traceability, connect the external projects to the currently open project.

To view external projects, click Project > External Projects.
The External Projects dialog box appears.

External Projects x|
— External Project References:
Prefie:  Mame: Status:

[Eonnest |
Bemave |

Location: I Brawee)., |

™ Connect to the external project at project open

] Cancel Help |
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It displays the following:

» Prefix—an identifier for the project. In an external project, the project prefix
appears before the requirement tag, separated from the tag by a decimal. For
example, if a requirement’s tag is PR234 and the project’s prefix is GLOBAL,
then the external requirement is displayed as GLOBAL.PR234. The prefix can
be up to 8 characters and must be uppercase letters. You can change the prefix
at any time in the General tab of the Project Properties dialog box.

2 Name—the name of the external project.
2 Status—indicates whether the project is currently connected or disconnected.
s Location—indicates the location of the project.

To add a project as an external project:

1 In the External Projects dialog box, click Add. The Add External Project dialog box
appears.

2 Locate the project and click Open.

3 To automatically open the external project when the current project is opened,
click the Connect to the external projects at project open check box.

Note: In this case, when you open the project, one of several conditions apply:
s If neither project is secured, you are not required to log on to the project.

s If the project is secured and your user name and password are different than
those used to log on to the secured project, the Project Logon dialog box
appears. Log on to the project as you normally would. (If your user name and
password are the same in both projects, you will not be required to log on
multiple times.)

2 If the project is not secured and the external project is secured, the Project
Logon dialog box appears. Log on to the project as you normally would.

4 To connect other external projects, repeat the above steps.

5 To remove a project from the External Projects dialog box, select the project and
click the Remove button.

Note: If you remove a project with requirements that participate in external
traceability, RequisitePro warns you about deleting the references.

If the external project is not accessible, RequisitePro warns you that the current
project will be updated and the external project will contain invalid references
until it is opened and synchronized.

246 Chapter 15 - Working with Project Information



If an external project is moved, an error message appears, indicating that the
project cannot be found.

Select the project from the External Project References list, and click Browse to
relocate the project. Locate the project and click Open.

Note: The Browse button is only active when a project has been moved or cannot
be located.

Disconnecting Projects

You can disconnect external projects when they are not needed or are unavailable. For
example, you may want to disconnect projects when you are working in a distributed
mode and the database is unavailable.

If you are not currently working on traceability relationships, disconnecting will
increase system performance. A project must be disconnected before you can relocate

it.

1

On the Tool Palette, click Project > External Projects.
The External Projects dialog box appears.

Select the project and click Disconnect. This temporarily disconnects the project.

To reconnect the project, select the project and click Connect. (The Disconnect
button automatically changes to a Connect button when you select a disconnected
project, and the Connect button automatically changes to a Disconnect button
when you select a connected project.)

Results of Disconnecting an External Project

When you disconnect an external project:

Requirements are displayed in the traceability matrix and attribute matrix with a
label marking them as disconnected external requirements.

You cannot create traceability relationships with requirements in the disconnected
project.

You cannot change traceability relationships with requirements in the
disconnected project.

If you delete a requirement or its traceability state changes to Suspect, external
requirements relationships are updated with the new state.

Any changes to requirements in the external project are updated in the
disconnected project when the project is opened. You can see these changes, but
you cannot update them.
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Relocating an External Project
To relocate an external project, you must first disconnect it.

1 On the Tool Palette, click Project > External Projects.
The External Projects dialog box appears.

2 Select the project, and then click Disconnect.

3 In File Manager or Windows Explorer, move the project files (.rgs, .rgl, and .xml)
to the new location.

4 In the External Projects dialog box, in the External Project References listing, select
the project.

5 Click Browse.
6 Click Open.
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Integrating with Other
Products

You can use Rational RequisitePro with several tools:
» Rational ClearQuest

» Rational ClearCase

= Rational Unified Change Management

= Rational Rose

» Rational SoDA

» Rational Synchronizer

» Rational TestManager

* Rational Unified Process

* Microsoft Project

In addition, RequisitePro is included in all Rational Suite products as part of the
Rational Team Unifying Platform, which also includes: Rational ClearQuest, Rational
TestManager, Rational ClearCase LT, Rational SoDA, and the Rational Unified
Process.

Using Rational ClearQuest with RequisitePro

If you have ClearQuest or any Rational Suite product installed on your PC, you can
launch ClearQuest directly from the RequisitePro Tools menu (click Tools > Rational
ClearQuest).

Rational ClearQuest is a Windows change request management product designed for
the dynamic and evolving nature of software development. ClearQuest offers a
flexible approach to track and manage all the change activities that are associated
with an organization. With it, team members can customize and define queries, fields,
activities, and states specific to their environment. This expanded level of
customization makes the process of managing change easy for a team to implement,
deploy, and maintain.
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If you have a Rational Suite product or are working with a Rational Administrator
project, you can collect enhancement requests and defects in ClearQuest and associate
them with new or existing requirements in RequisitePro. From RequisitePro, you can
use custom requirement attributes to associate a requirement with one or many
ClearQuest records.

You can use the EnhancementRequest and Defect custom requirement attributes to
associate a requirement with one or many ClearQuest enhancement requests. If you
are using a project that is based on the Use-Case project template, these attributes are
available for all requirements of the feature (FEAT) requirement type. You can either
type the ClearQuest record number or click the adjacent browse button to select a
record. Other associations can be created using the ClearQuest/RequisitePro
Integration Setup.

Note: When you associate RequisitePro requirements with ClearQuest records in a
ClearQuest MultiSite environment, the local ClearQuest database replica may not
have mastership of some ClearQuest records. You cannot integrate these records with
your RequisitePro project.

If you have Rational Suite AnalystStudio installed, refer to Getting Started with Rational
Suite AnalystStudio. More information on this integration is available from the white
paper Using Rational ClearQuest and RequisitePro for Analysts. For information on
configuring this integration, refer to the book Configuring Rational Suite on the
Rational Solutions for Windows Online Documentation CD, which is included with
RequisitePro and all Rational Suite products.

Associating a Requirement with a ClearQuest Record

To associate a requirement with a ClearQuest record using the Requirement
Properties dialog box:

1 Do one of the following to open the Requirement Properties dialog box:

2 In the Word Workplace, select the requirement in an opened document. Then
either click RequisitePro > Requirement > Properties, or on the Tool Palette, click
Requirement > Properties.

2 In the Views Workplace, select the requirement in a view. Click Requirement >
Properties.

2 C(Click the Attributes tab.

3 Scroll to the bottom of the Attributes list to the EnhancementRequest or Defect
attribute to view the Rational ClearQuest records associated with this requirement.
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Do one of the following:
2 Type the ClearQuest record number.

2 Click the adjacent browse button to select a record. In the Associate
Enhancement Requests or the Associate Defects dialog box, select a
requirement from the Records list and click the Associate button.

s Click the adjacent browse button and create a new record in ClearQuest to
associate with the requirement.

4 Click OKin the Attributes tab of the Requirement Properties dialog box.
To associate a requirement with a ClearQuest record using an Attribute Matrix:
1 Open an Attribute Matrix view of feature requirements.

2 In the EnhancementRequest or Defect column for a requirement, do one of the
following:

2 Type the ClearQuest record number.

2 Click the adjacent browse button to select an enhancement request. In the
Associate Enhancement Requests or Associate Defects dialog box, select a
requirement from the Records list and click the Associate button.

3 To save the associated value in the Attribute Matrix, click outside the cell.

Using Rational ClearCase with RequisitePro

You can use Rational ClearCase with RequisitePro in several ways.

If your project uses the Unified Change Management (UCM) model, you can create
baselines of the project. RequisitePro project administrators can implement the UCM
model in ClearCase and Rational Administrator by creating baselines of RequisitePro
projects.

If your RequisitePro project does not use the UCM model, you can archive it using the
Rational ClearCase archive command from within RequisitePro.

Using Rational Unified Change Management to Create a Project Baseline

UCM is Rational's out-of-the-box usage model for managing change in software
system development, from requirements to release. UCM is a unified approach to
configuration management and change request management, automated in Rational
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ClearCase and Rational ClearQuest. ClearCase can be set up to implement the UCM
model for basic activity-based configuration management or in conjunction with
ClearQuest to provide full change-request management.

To implement the model for baselining a Rational RequisitePro project, the project
must be associated with a UCM-enabled Rational project in the Rational
Administrator. For more information, see Creating a Project Baseline with Unified
Change Management on page 221.

If you have a RequisitePro project that is baselined, you can use that baseline to create
new projects in RequisitePro. For example, you may want to base the next release of a
project on a stable configuration of the previous release. For more information, see
Creating a RequisitePro Project from a Baseline on page 188.

Using ClearCase to Archive Projects

In RequisitePro, archiving is the process of duplicating the database, documents, and
all related files in a project so that they can be restored at a later time. You can archive
a RequisitePro project in ClearCase using the Project > Archive > Rational ClearCase
command on the Tool Palette. For more information, refer to Archiving Projects with
Rational ClearCase on page 215.

Using Rational Rose with RequisitePro

Rational Rose offers powerful tools for object-oriented analysis, modeling, design,
and construction. As the world’s leading visual modeling tool, Rational Rose enables
system analysts to start modeling requirements with use cases and actors and enables
developers to define and communicate a software architecture.

You can open Rose directly from RequisitePro by clicking Tools > Rational Rose, and
you can associate Rose use cases with RequisitePro requirements and documents
using Integrated Use Case Management.

Using Integrated Use Case Management

Rational’s integrated management of use cases between Rational Rose and
RequisitePro allows you to start or work in either environment, according to your
process.
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Integrated Use Case Management allows you to manage use cases using attributes
(such as Priority, Risk, Status, and Iteration) by associating Rose use cases with
RequisitePro documents and requirements. You can easily navigate from Rose
use-case models to RequisitePro use-case documents and requirements and vice
versa.

Use-case management in RequisitePro adds depth and relational information to your
Rose use cases. The following features are supported:

= textual definitions of use cases in a Microsoft Word documents

» detailed descriptions of flows of events, special requirements, preconditions, and
postconditions

» hierarchical (parent/child) relationships between use-case names and actions
within the use-case flow of events

= traceability to and from other use cases and associated design features.

We recommend that you develop your use cases in Rose and then detail and manage
them in RequisitePro using Integrated Use Case Management. This approach
accomplishes associations between Rose and RequisitePro with several easy menu
selections.

To associate a Rose model or package with a RequisitePro project, open the model or
package in Rose and use the commands on the Tools > RequisitePro menu. Refer to
online help in Rose for more information on Integrated Use Case Management.

To associate a RequisitePro document or requirement with a Rose use case, open the
document or select the requirement in RequisitePro and use the Rational Rose >
Associate to Use Case commands on the Tool Palette Document or Requirement menu.

Refer to the white paper Use Case Management with Rose and RequisitePro or the manual
Getting Started with Rational Suite AnalystStudio for more information on Integrated
Use Case Management.

Viewing a Rose Use Case Associated with a Document or Requirement

If you have Rational Rose installed on your system (as part of AnalystStudio or a
stand-alone application), you can work with the Integrated Use Case Management
feature that links RequisitePro documents and requirements with Rose use cases. You
can use the Rational Rose > Go to Rational Rose command to navigate from a
RequisitePro document or requirement to its associated Rose use case. (For more
information, refer to the Integrated Use Case help, available through the Help button
in the dialog boxes.)
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Note: The Rational Rose commands appear on the Document and Requirement menus
on the RequisitePro Tool Palette only if Rose is installed on your system.

To go to a use case associated with a document:

1 In the Word Workplace, open a document that is associated with a use case.
2 On the Tool Palette, click Document > Rational Rose > Go to Rational Rose.
To go to a use case associated with a requirement:

1 Do one of the following:

* Ina view, select a requirement that is associated with a use case.

* Inadocument, click the cursor inside a requirement that is associated with a use
case.

2 On the Tool Palette, click Requirement > Rational Rose > Go to Rational Rose.

Note: You must save your Rose model before you can navigate from a RequisitePro
document or requirement to the associated Rose use case using the Rational Rose > Go
to Rational Rose command.

Associating Documents and Requirements with Rose Use Cases

If you have Rational Rose installed on your system (as part of AnalystStudio or as a
stand-alone application), you can use the Integrated Use Case Management feature to
associate a RequisitePro document or requirement with a use case in Rose. You can
use the Rational Rose > Associate to Use Case command to directly associate a
document or requirement with a Rose use case. (For more information, refer to the
Integrated Use Case Help, available through the Help button in the dialog boxes.)

Note: This command appears only if Rose is installed on your system.

To associate a document with a Rose use case:

1 In the Word Workplace, open a document.

2 On the Tool Palette, click Document > Rational Rose > Associate to Use Case.
To associate a requirement with a Rose use case:

1 Do one of the following:

» Select a requirement in the Views Workplace.

» Place your cursor within a requirement in a document.
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2 On the Tool Palette, click Requirement > Rational Rose > Associate to Use Case.

Note: If you want to move a requirement into another document and it is associated
with a Rose use case, you must first remove the association. Then associate the
requirement to the appropriate use case after you have saved it in the other
document.

For more information about associating a document or requirement with a Rose use
case, refer to the Integrated Use Case help, which is available through the Help button
in the dialog boxes.

Using Rational SoDA with RequisitePro

RequisitePro is a supported domain for Rational SoDA. This allows you to create
reports that extract information from various data sources, including a RequisitePro
database.

Using SoDA and RequisitePro, you can:

»  Use SoDA to modify and generate SoDA reports and documents from an open
RequisitePro project.

» Use SoDA and RequisitePro to create a report that consolidates RequisitePro
requirements information and Rose modeling information.

For more information, refer to Printing Project Summaries and Reports on page 206.

Using the Rational Synchronizer with RequisitePro

The Rational Synchronizer automates the creation and updating of items in your
project. The Synchronizer uses either predefined or user-defined rules to determine
which items to create or update. You can use the Synchronizer to update items in
Rational products that are not linked by other integrations. For example, you may use
the Synchronizer to create items like Rose actors, which are not currently part of the
Rose-RequisitePro Integrated Use Case Management.

The Synchronizer is shipped with RequisitePro, but the option to install it is not
checked by default when you are installing RequisitePro. You must select the Custom
/ Full option and then select the Rational Synchronizer check box. Once it is installed,
you can launch the Synchronizer from RequisitePro by clicking Tools > Rational
Synchronizer.
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Using Rational TestManager with RequisitePro

If you have Rational Robot installed, you can launch the TestManager component
directly from the RequisitePro Tools menu (click Tools > Rational TestManager).

RequisitePro requirements can be referenced from TestManager to ensure complete
test coverage for all requirements. TestManager is part of Rational TeamTest and all
Rational Suite products. Rational TestManager is the one place to manage all testing
activities—planning, design, development, execution, and analysis. TestManager ties
testing and the rest of the development effort, combining your testing assets and tools
to provide a single point from which to understand the exact state of your project. If
you have installed TestManager, we recommend that you develop all test artifacts in
that tool.

Using the Rational Unified Process with RequisitePro

The Rational Unified Process is an online knowledge base of proven
software-development principles. As a software engineering process, the Rational
Unified Process provides a disciplined approach to assigning tasks and
responsibilities within a development organization. Its goal is to ensure the
production of high-quality software that meets the needs of its end users, within a
predictable schedule and budget. The Rational Unified Process captures many of the
best practices in modern software development in a form that can be tailored to a
wide range of projects and organizations. Many activities in the Rational Unified
Process are supported by software-engineering tools. Tool Mentors provide
descriptions on how Rational Software tools can be used to support particular steps
and activities.

The Use-Case template provides a basic project structure that is compliant with the
Rational Unified Process. The project template provides requirement types, suggested
attributes, default attribute values, and related document types. For more information
on using the Use-Case template, see Reviewing RequisitePro Project Template Options on
page 182.

Using Microsoft Project with RequisitePro

The Microsoft Project Integration Wizard manages traceability from requirements in
RequisitePro projects to tasks in Microsoft Project schedules. You can use the wizard
to do the following:
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Create tasks from requirements and establish traceability relationships from those
requirements to the tasks.

Add or remove traceability from requirements to existing tasks.

After you have established traceability you can:

Refresh requirement information within RequisitePro that links to the traced tasks
in Microsoft Project.

Review suspect traceability relationships between requirements and tasks in a
RequisitePro Traceability Tree or Traceability Matrix.

Analyze the impact on the requirements, the tasks, the project, and the schedule as
changes occur.

Tips for Using Microsoft Project with RequisitePro

Follow these guidelines when using the Microsoft Project integration:

Create an associated task for any requirement that you want to track in Microsoft
Project. For example, you would generate a task for any feature requirement for
which you must produce a document and submit that document for review and
approval by a specified date.

If you follow the Rational Unified Process, a use case is probably the main item
that should appear in your schedule. It may also make sense to trace each
alternative flow and each individual step in a use case. Supplementary
requirements are also candidates for the schedule, but the process associated with
a supplementary requirement is highly dependent on the nature of the
requirement; for example, performance constraints have one set of tasks, and
usability constraints have a different set of tasks.

Whatever requirements are handed off to the development team should appear in
the schedule.

Map the requirements that have activities associated with them. For example, if
you have a parent requirement and all the children are approved for a release, you
might want to generate a task linked to the parent. If only one of the children is
approved, link only the child. If the children are sufficiently weighty, then you
may want to bring over the parent and children as a task hierarchy.

If you have a requirement attribute to designate a product release number, you
might want a schedule just for requirements assigned to the same release number.

If you have an “assigned-to” requirement attribute, you might want to generate a
schedule for everything assigned to each developer.
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MSPT Requirement Types

Requirements and tasks are linked using a special requirement type, the MSPT
requirement type. This requirement type is a place holder in a RequisitePro project
that represents a task in a schedule. The MSPT requirement type is linked to a task in
a schedule. It contains, as requirement attributes, the Microsoft Project file name and a
unique ID of the task it represents.

The MSPT requirement type also includes default attributes that are based on task
fields in Microsoft Project. These default attributes are Cost, Duration, Finish,
Milestone, Priority, Resource Names, and Start.

You can also map Microsoft Project fields to RequisitePro attributes for the MSPT
requirement type in the .rqs file of your RequisitePro project. For more information
about the MSPT requirement type, see Working with the MSPT Requirement Type on
page 263.

Requirements

Software Requirements

Microsoft Project 98 must be installed on your system in order to use the Microsoft
Project Integration Wizard. If not, the Start Microsoft Project and Integration Wizard
options are disabled on your RequisitePro Tools menu.

Security Requirements

In order to initially integrate a RequisitePro project with Microsoft Project using the
wizard, you must have RequisitePro administrator permissions.

In order to use the Microsoft Project Integration Wizard in subsequent sessions:
*  You must have create and delete permissions for the MSPT requirement type.

* You must have attribute update permissions for all attributes associated with the
MSPT requirement type.

Starting the Wizard and Adding the MSPT Requirement Type

You can start the Microsoft Project Integration Wizard from within RequisitePro or
run it as an independent application. These instructions explain how to start the
wizard from within RequisitePro.

Note: Make sure that you have closed any open dialog boxes in Microsoft Project
before you use the Microsoft Project Integration Wizard.
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To start the Microsoft Project Integration Wizard:

1  On the Tool Palette, click Tools > Microsoft Project Integration Wizard. The
introduction screen appears.

2 Click Next. The Select Project Files screen appears.
3 Select a project. The list displays all projects in your RequisitePro project list.
4 Do one of the following:

2 Enter the name and path of an existing Microsoft Project schedule.

2 Click Browse to locate, select, and open an existing schedule in Microsoft
Project.

2 Click New to create a new schedule. The Project Info dialog box appears. When
you are finished creating the new schedule, click OK in the Project Info dialog
box. A dialog box appears, prompting you to save the new project. After saving
the schedule, the wizard minimizes Microsoft Project, returns to this screen,
and adds the new schedule name to the Microsoft Project Schedule text box.

5 Click Next. If the project you selected has security enabled, the Logon dialog box
appears. Log on as you would to a secured RequisitePro project.

The wizard checks the project, searches for the MSPT requirement type, and adds
it if it is missing. The MSPT Info screen is displayed. Click Next.

The wizard opens the project and schedule and displays the Select an Action
screen.

Creating Tasks from Requirements

The following instructions assume the wizard is started and the Select An Action
screen is displayed. Use this feature to select requirements in RequisitePro in order to
create new tasks in Microsoft Project that are linked to the RequisitePro requirements.

Note: The first time the “Select An Action” screen appears after you select a new
schedule, only the first option is available. After tasks have been created, the other
options become available.

1 Select the option “Select requirements to create tasks, or add and remove
traceability to existing tasks.”

2 C(Click Next.
3 In the Requirement Type list, select a requirement type.

4 Click one of the following;:
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2 All requirements of selected type
2 Requirements of this attribute value
o In the Attribute list, select the attribute.
o In the Value box, select a value and an operator.

s To search for requirements containing specific phrases (for example, the word
“shall”) in requirement name or text, enter the string in the Requirement Text
Search box. You can use partial strings, but wildcard searches are not
supported.

5 Click Next. The screen displays the Task Traceability Tree for the requirements that
you filtered in the previous screen.

6 Select one or more requirements and select Create Tasks.
7 Click Next. At the next screen, click Finish.

Note: Each time you make a change to a schedule, a dialog box appears,
prompting you to save with or without a baseline. We recommend that you save
with a baseline for each change. See the Microsoft Project online help for more
information about baselines.

8 Click Exit to close the wizard, or click Another Action to return to the “Select an
Action” screen where you can create more tasks, add or remove traceability, and
refresh requirement information from Microsoft Project.

Adding or Removing Traceability

The following instructions assume the wizard is started and the Select An Action
screen is displayed and that you have created tasks in Microsoft Project that are
linked to requirements in RequisitePro.

You can modify traceability in the Microsoft Project Integration Wizard by doing one
of the following:

» Select a RequisitePro requirement and link it to a Microsoft Project task.
= Select a Microsoft Project task and link it to a RequisitePro requirement.

Both option are covered in the two procedures below.
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Selecting Requirements to Modify Traceability
At the Select An Action screen:

1 Select the option “Select requirements to create tasks, or add and remove
traceability to existing tasks.”

2 Click Next.
3 In the Requirement Type list, select a requirement type.
4 Click one of the following:
s All requirements of selected type.
2 Requirements of this attribute value.
o In the Attribute list, select the attribute.
o In the Value box, select a value and an operator.

a To search for requirements containing specific phrases (for example, the word
“shall”) in the requirement name or text, enter the string in the Requirement
Text Search box. You can use partial strings, but wildcard searches are not
supported.

5 Click Next.

The screen displays the task traceability tree for the requirements that you filtered in
the previous screen.

To remove traceability between the selected task and requirement:

1 Select one or more tasks and then click Remove traceability, and click Finish. The
traceability between the selected tasks and requirement is removed. Note that the
tasks remain in the Microsoft Project schedule.

2 Click Exit to close the wizard, or click Another Action to return to the “Select an
Action” screen where you can create more tasks, add or remove traceability, and
refresh requirement information from Microsoft Project.

To add traceability between the selected requirements and a task:

1 Select a requirement and click Add Traceability. Traceability is created for one
requirement at a time.

2 Click Next to advance to the next screen and select a task.
3 Do one of the following:

2 If you are satisfied with the current task selection, click Finish.
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s To change the selection, click MS Project to display the schedule and select one
or more tasks. Return to the Integration Wizard and click Refresh Task List to
refresh the task display. Then click Finish.

Selecting Tasks to Modify Traceability

At the Select An Action screen:

1 Select the option “Select tasks to add or remove traceability” and click Next.
The Select Tasks screen appears.

2 Do one of the following:
s If you are satisfied with the current task selection, click Next.

2 To modify the selection, click Microsoft Project to display the schedule and
select one or more tasks. Return to the Integration Wizard and click the Refresh
Task List to refresh the task display. Then click Next.

This screen displays the Task Traceability Tree for the tasks you selected in the
previous screen and the requirements from which the tasks are traced.

3 Do one of the following:

2 To display the task in the Microsoft Project schedule, select a task and click Go
to Task. In the schedule, you can view the task or make modifications. When
you are finished, return to the Integration Wizard.

2 Select a requirement and the Remove traceability option. Then click Finish.
The traceability between the selected task and requirement is removed.

2 Select a task and the Add Traceability option. Then click Next. The Select a
Requirement Type screen appears.

4 In the Requirement Type list, select a requirement type.
5 Click one of the following:
s All requirements of selected type.
2 Requirements of this attribute value.
o In the Attribute list, select the attribute.
o In the Value box, select a value and an operator.

s To search for requirements containing specific phrases (for example, the word
“shall”) in the requirement name or text, enter the string in the Requirement
Text Search box. You can use partial strings, but wildcard searches are not
supported.
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6 To go to the next screen of the wizard, click Next. The screen displays the
requirements that you filtered in the previous screen.

7 Select a requirement. To display the requirements without tasks, select the Show
only requirements with no tasks check box.

8 Click Finish.

Refreshing MSPT Requirement Information from Tasks

The following instructions assume the Select An Action screen in the Microsoft
Project Integration Wizard is displayed and that you have created tasks in Microsoft
Project that are linked to MSPT requirements, which represent the tasks in
RequisitePro. Traceability should be established between your product requirements
and the MSPT requirements.

When the values in the Microsoft Project task fields are changed, you must use the
refresh feature in the Microsoft Project Integration Wizard to update the
corresponding attribute values in the MSPT requirements. The resulting changes to
the MSPT attribute values cause the traceability relationships between your product
requirements and the MSPT requirements to be marked as suspect. This suspect
condition alerts you of changes in the Microsoft Project schedule.

You can then view the suspect relationships in a Traceability Matrix that includes
your product requirements and the MSPT requirements; or you can review the
changes to the MSPT attribute values using an Attribute Matrix of the MSPT
requirement type.

To refresh the MSPT requirements from the Microsoft Project tasks:

1 At the Select an Action screen, select the option “Refresh MSPT information from
MS Project tasks” and click Next.

The Update screen displays the list of changes to occur when RequisitePro is
updated with a Microsoft Project tasks.

2 To proceed with the integration, click Finish.

Working with the MSPT Requirement Type

Viewing the MSPT Requirement Type
You can view the MSPT requirement type in a view in RequisitePro.
1 In the Views Workplace, click File > New View, or click the New View icon.

2 Select one of the following views:
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s Select an Attribute Matrix and the MSPT requirement type to review the
changes to the MSPT attribute values.

2 Select a Traceability Matrix. Select the requirement types for your product
requirements (in the row requirements) and the MSPT requirements (in the
column requirements). The traceability is displayed between the requirement

types.

s Select a Traceability Tree. Select the product requirement type and expand the
display to view the traceability relationships to the MSPT requirements.

3 C(lick OK.

Mapping Fields to Attributes for the MSPT Requirement Type

Unlike other requirement types, you cannot add a new attribute to the MSPT
requirement type using the Attributes tab on the Project Properties dialog box. You
can, however, create attributes for the MSPT requirement type in the .rqs file for the
RequisitePro project in which you are working. For example, if the name of the project
you are working on is “blueproject,” then you use the blueproject.rgs file to create
new attributes for the MSPT requirement type.

If security has been set for the project, you must have project structure permission to
map a field to an attribute for an MSPT requirement type.

To map fields to attributes:

1 Refer to the next section to locate the task field that you want to map to an attribute
for the MSPT requirement type.

2 In a text editor, open the .rgs file for the project with which you are working.
3 In the [MSProjectMappings] section of the .rqgs file, enter the following:
field ID=attribute name

where field ID is the field ID listed in the next section and attribute name is the
label you want to give the attribute in RequisitePro.

4 Save the .rqgs file.

The Microsoft Project Integration Wizard will create an attribute for the MSPT
requirement type based on the information entered.
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Microsoft Project Field IDs

Use the following Microsoft Project field IDs to map attributes for the MSPT
requirement type in RequisitePro to corresponding constants in Microsoft Project.
Add your entries to the [MSProjectMappings] section in <project name>.rgs file using
a text editor.

Use the following format:
field ID=attribute name

where field ID is the numeric constant listed below and the attribute name is the label
you want to give the attribute in RequisitePro. Field IDs shown in bold are already
provided as default attributes for the MSPT requirement type.

Actual Cost = 7Actual Duration = 28Actual Finish = 42
Actual Start = 41 Actual Work = 2Baseline Cost = 6
Baseline Duration = 27Baseline Finish = 44Baseline Start = 43
Baseline Work = 1IBCWP = 11BCWS = 12

Confirmed = 110Constraint Date = 18Constraint Type = 17
Contact = 112Cost = 5Cost1 = 106

Cost2 = 107Cost3 = 108Cost Variance =9

Created = 93Critical = 19CV = 83

Delay = 20Duration = 29Durationl = 103

Duration2 = 104Duration3 = 105Duration Variance = 30
Early Finish = 38Early Start = 37Finish = 36

Finish1 = 53Finish2 = 56Finish3 = 59

Finish4 = 62Finish5 = 65Finish Variance = 46

Fixed Cost = 8Fixed (Duration) = 34Flagl = 72

Flagl0 = 81Flag2 = 73Flag3 = 74

Flag4 = 75Flag5=76Flag6 = 77

Flag7 = 78Flag8 = 79Flag9 = 80

Free Slack = 21Hide Bar = 109ID = 23

Late Finish = 40Late Start = 39Linked Fields = 98

Marked = 71Milestone = 24Name = 14
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Notes = 15Numberl = 87Number2 = 88

Number3 = 89Number4 = 90Number5 = 91

Objects = 970utline Level = 850utline Number = 102

% Complete = 32% Work Complete = 33Predecessors = 47

Priority = 25Project = 84Remaining Cost = 10

Remaining Duration = 31Remaining Work = 4Resource Group = 113
Resource Initials = 50Resource Names = 49Resume = 99

Resume No Earlier Than = 101Rollup = 82Sheet Notes = 94

Start = 35Startl = 52Start2 = 55

Start3 = 58Start4 = 61Start5 = 64

Start Variance = 45Stop = 100Subproject File = 26

Successors = 48Summary = 925V = 13

Textl = 51Text10 = 70Text2 = 54

Text3 = 57Text4 = 60Text5 = 63

Text6 = 66Text7 = 67Text8 = 68

Text9 = 69Total Slack = 22Unique ID = 86

Unique ID Predecessors = 95Unique ID Successors = 96Update Needed = 111
WBS = 16Work = 0Work Variance = 3

Deleting Attributes for MSPT Requirement Types

To delete an attribute for an MSPT requirement type, you must have project structure
permission to remove a requirement type (if security is enabled).

To delete attributes:
1 Open the RequisitePro project file (projectname.rgs) with a text editor.

2 In the project file, under the heading [MSProjectMappings], locate the requirement
attribute that you want to delete. Attributes are listed with the Microsoft Project
field ID, followed by an equal sign (=), and the attribute name; for example,
5=Cost.

3 Delete the entire line that contains the attribute. Save and close the project file.

4 In the RequisitePro Tool Palette, click Project > Open.
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Select the project, check the Exclusive check box, and click OK. Log on to the
project, if necessary.

On the Tool Palette, click the Tools > Microsoft Project > Integration Wizard.

Click Next. Be sure that the current RequisitePro project and related Microsoft
Project are selected. Click Next.

Select the option “Refresh MSPT information from MS Project tasks.” Click Next.

After the processing is complete, click Finish. Click Exit and Yes at the
confirmation prompt.
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Troubleshooting

The following sections describe some of the problems that may arise when you use
RequisitePro and how you can resolve them.

Creating Requirements

A requirements document is a Microsoft Word file created in Rational RequisitePro
and integrated with the project database. Requirements cannot be created in a normal
Word document.

If you experience problems when creating requirements in a document, check for the
following:

Overlapping requirements. Make sure that the highlighted selection is not inside
of or overlapping another requirement. Requirements cannot be nested or overlap
one another.

Bookmarks and hidden text. RequisitePro uses Word bookmarks and hidden text
to designate requirements. If your document contains bookmarks or hidden text
(either in other requirements or in nonrequirement text in the document), make
sure the highlighted selection is not inside of or overlapping a Word bookmark or
hidden text.

Document saved status. You cannot establish traceability for a new requirement or
in a newly created document until you save the document. If a requirement does
not display in the Traced From Requirement(s) dialog box or Traced To
Requirement(s) dialog box, try saving the document.

Track changes. Be sure that Word’s Track Changes functionality is not turned on
when creating or modifying requirements.

File versioning. Be sure that Word’s file versioning capability is not turned on.
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Database Corruption

On very rare occasions, a RequisitePro project that uses the Microsoft Access database
may become corrupted. When this occurs, RequisitePro displays an error message. In
addition, it is a good practice to periodically repair/compact your Access database
even if you are not experiencing problems.

Note: To repair corrupted projects that use an enterprise database, see your database
administrator.

To repair and compact a corrupted Microsoft Access project database, make sure that
all users close the project, and then do the following:

1 Open the Database Properties dialog box by doing one of the following:

s Click Project > Open. In the Open Project and Documents dialog box, select the
corrupted project and click Properties.

s In an open RequisitePro project, click Project > Properties. On the General tab of
the Project Properties dialog box, click Properties.

2 C(Click the Configure button.
The ODBC Microsoft Access Setup dialog box appears.
3 Click the Repair button.

The Repair Database dialog box appears. The selected database appears in the
Database Name field. Click OK.

4 Click Compact on the ODBC Microsoft Access Setup dialog box.

The Database to Compact From dialog box appears. The selected database appears
in the Database Name field. Click OK.

5 In the Database to Compact Into dialog box, select one of the Format options based
on the version of Access the RequisitePro project uses, not the version of
RequisitePro. Select Version 4.x if you are using Access 2000; select Version 3.x if
you are using Access 97.

Note: If the version selected does not match the database, you will receive an
ODBC error. If you have Access 97 on your system, the Version 4.x option does not
appear. If the database you are compacting is in the Access 2000 format, you must
perform the compact procedure on a system with Access 2000 installed.

6 Click OK.

7 Click Yes to confirm that you want to replace your database with a compacted
version.
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Document Not Found Messages

If the Document Not Found dialog box appears when you try to open a document, the
document may have been deleted in Windows Explorer, moved, or renamed. You can
respond to the error message in one of the following ways:

* You can browse the file system to associate the document with a new location.
* You can delete all requirements associated with the document from the project.

* You can click Cancel to keep the requirements associated with the document, and
then try to restore the file and reopen the document.

Files Are Too Big for Microsoft Word

When you open a large document in Microsoft Word, an error message may appear,
stating that the file is too large to be opened.
We recommend that you use small Word documents for the following reasons:

= Word allows only one user at a time to modify a document.

Note: The extended editing feature allows users to concurrent modify
requirements located in documents without having to open the document.

* Small documents are more likely to be reviewed thoroughly because multiple
reviewers can work on small sections of text concurrently.

» Small documents enable better system performance.

= Word may have problems processing large documents.

For help working with large documents, see information about master documents in
the Microsoft Word documentation.

Failed Multiple Select Actions

When you select more than one relationship or requirement in a view and then
perform an operation on the multiple selection (such as creating traceability or
deleting), the operation may fail for one or more requirements or relationships.

For example, the operation may fail if you do not have rights to perform the operation
on the requirements or relationships, or if some of the requirements are in documents
and the operation is not permitted for requirements in documents.
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RequisitePro notifies you of such failures by providing an exception log that shows
the requirements or relationships for which the operation failed and the reason for the
failure.

1 In a view, perform the desired operation on a selected group of requirements or
relationships.

s If the operation is successful, the modifications are shown in the view, and no
dialog box appears.

2 If the operation fails for one or more requirements or relationships, or if you
stop the operation before it is completed, the Exception Report dialog box
appears, providing the number of requirements or relationships for which the
operation failed.

2 Click Details to learn more about the failed operation.
The dialog box is expanded, showing the reason for the failure.

3 To copy the text in the text box, select the text and press CTRL-C. You can then
paste the text into a text document.

4 C(lick Close.

General Protection Faults in Page View Mode

Viewing documents in Page View mode in Word can trigger General Protection
Faults (GPFs), caused by high memory requirements. A GPF is an error condition that
occurs when an application attempts to access memory outside of its authorized
memory space or an invalid instruction is issued. To avoid GPFs while viewing
documents, switch to Normal view. When you have had a GPE, you may continue to
have problems caused by memory corruption. If this occurs reboot the machine and
try again.

Recovering an AutoRecover Document

If your computer system fails, you can retrieve a Rational RequisitePro document
saved with the Microsoft Word Autosave feature. You must have previously selected
the AutoRecover feature in Word.

1 In Word, click File > Open.
The Open Word Document dialog box appears.

2 Locate the directory and the document, and click Open.
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The document is displayed. Word prompts you to save the document.
3 In Word, click File > Save.
A message appears, asking whether you want to replace the existing document.
4 Click Yes.
Only changes made after the last automatic save are lost.
5 Click File > Close.
6 Do one of the following to open the document in RequisitePro:
2 On the Tool Palette, click Document > Open.
2 In the Word Workplace, click RequisitePro > Document > Open.
The Open Project and Documents dialog box appears.

7 Select the document and click OK. The document is displayed in the Word
Workplace.

8 Do one of the following:
2 On the Tool Palette, click Document > Save.

2 In the Word Workplace, click RequisitePro > Document > Save.

RequisitePro Menu Appears Incorrectly

If you encounter General Protection Faults in the Word Workplace, the RequisitePro
menu may appear in other applications besides Microsoft Word. These may include
Microsoft Outlook or other e-mail applications. In addition, you may see duplicate
occurrences of the RequisitePro menu in the Word Workplace.

To remove the erroneous menu, delete the normal.dot and email.dot templates from
your Microsoft Office directories. Before doing so, verify that you do not have any
customizations in normal.dot or email.dot. If you do you will have to recreate those
customizations after the file is recreated. Typically, the .dot files are located in the
following directories:

= Program Files\Microsoft Office\Office

= Program Files\Microsoft Office\Templates
These files will be generated again automatically by your Microsoft Office applica-
tions.
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Invalid Date/Time Errors

If you receive invalid date/time errors, change the Windows Regional Settings on
your machine to one of the default settings.

To find the default settings in the Regional Settings Properties dialog box, switch to a
different locale on the Regional Settings tab and then switch back. The default settings
appear on the Time and Date tabs.

SQL Server Syntax Error

If you have an existing RequisitePro database in Microsoft SQL Server and your SQL
Server has been upgraded to 7.0 from a previous version, then the system administra-
tor must run the following stored procedure in SQL Server to set the database com-
patibility level to SQL Server 7.0:

sp_dbcmptlevel<database name>, 70

For example:

sp_dbcmptlevel RequisitePro, 70

If the system administrator does not run this procedure, SQL Server Syntax Errors
may appear in RequisitePro.
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Keyboard Shortcuts and
Mouse Actions

Dialog Box Shortcuts

You can use keyboard combinations to move to tabs, fields, and buttons in a
RequisitePro dialog box. To use a dialog box shortcut, press the ALT key while
simultaneously pressing the underlined letter in a dialog box tab, field, or button. For
example, in the Project Properties, Document Properties, or Requirement Properties
dialog box, press ALT-G to open the General tab.

Menu Shortcuts

You can use combinations of keyboard shortcuts to open a menu in the Tool Palette or
Views Workplace. To use a menu shortcut, press the ALT key while simultaneously
pressing the underlined letter in the menu. For example, to open the Requirement
menu, press ALT-R. When a menu is displayed, you can select a command by pressing
the underlined letter in the command.

Selecting Multiple Items in RequisitePro

You can use mouse actions and combinations of keyboard and mouse actions to select
more than one item in various RequisitePro lists.

The following are referred to as multiple select actions in RequisitePro
documentation:

2 SHIFT-click: To click the mouse button while holding down the SHIFT key.
s CTRL-click: To click the mouse button while holding down the Control key.

s Drag: To hold down the right mouse button while moving the mouse and then
releasing the button.

You can use the actions in the following ways:
s To select adjacent items, use SHIFT-click or drag.

s To select nonadjacent items, use CTRL-click.
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The anchor is the first item you click when using multiple select actions to select a
range of items. In RequisitePro, the term “anchor” is generally used to mean the first
cell you click in a view in the Views Workplace. You use the anchor to select a range of
cells. For example, if you click the cell in row 1, column 1 of a Traceability Matrix, that
cell becomes the anchor. If you then SHIFT-click the cell in row 10, column 3 of the
matrix, all of the cells in rows 1 through 10, columns 1 through 3, are selected. To reset
the anchor, click anywhere outside the range. The cell you click is the new anchor. You
can also use an anchor to select a range of items in documents and in certain dialog
boxes that support multiple select actions.

Mouse Actions and Shortcuts in the Views Workplace

You can use keyboard shortcuts and mouse actions to quickly move around and select
information in the Views Workplace. The keyboard shortcuts and mouse actions differ
in each view.

The following tables provide specific shortcuts for selecting items in an Attribute
Matrix, a Traceability Matrix, or a Traceability Tree.

Attribute Matrix Mouse Actions and Keyboard Shortcuts

Mouse Actions

If you want to Do this
Select the requirement in the row in Click row label
which you click. OR

(This action also clears all selected items Click cell
and sets the selected row as the anchor.
Clicking in a cell also changes the
selected column to the column in which

you clicked.)

Select the requirements between the SHIFT-click row label
anchor row and the row in whichyou | 5p

SHIFT-click.

. . SHIFT-click cell in selected column
(This action clears any rows that are not

in the range.)

276 Appendix A - Keyboard Shortcuts and Mouse Actions



If you want to

Do this

Set the selected row as the anchor, while
keeping previously selected items
selected.

OR

Clear a previously selected row while
keeping others selected.

CTRL-click row label

Switch the column selection to the
column in which you click.

Click column label

OR
(Clicking in a cell also selects the row in CTRIL-click column label
which you clicked.)

OR

CTRL-click in cell
Select a range of requirements drag
(This action clears any rows that are not
in the range.)
Keyboard Shortcuts
If you want to Do this
Move to the right one column. TAB

OR

RIGHT ARROW
Move to the right one column when TAB
viewing requirement data.
Move to the left one column. SHIFT-TAB

OR

LEFT ARROW
Move down one row. ENTER

(This action clears all selected items and
sets the selected row as the anchor.)

OR

DOWN ARROW
Commit the new or modified ENTER
requirement to the database when in OR

edit mode.

TAB (when cursor is in last column of a
requirement’s row)
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If you want to Do this

Move up one row. SHIFT-ENTER

(This action clears all selected items and | OR
sets the selected row as the anchor.) UP ARROW

Activate the field for data entry, in the |SPACEBAR
currently selected cell.

(This action is only available when a
single cell is selected.)

Cancel the edit mode in the currently ESC
selected cell.

(This action is only available when a
single cell is selected.)

Move to the top of the view and select | HOME
the first row.

(This action sets the first row as the
anchor and clears all other selected
items.)

Move to the top of the view and select |SHIFT-HOME
all items between the anchor row and
the first row of the view.

(This action clears all other selected
items.)

Move to the top of the view, without CTRL-HOME
changing the selection or the anchor.

Move to the bottom of the view and END
select the last row.

(This action sets the last row as the
anchor and clears all other selected
items.)

Move to the bottom of the view and SHIFT-END
select all items between the anchor row
and the last row of the view.

(This action clears all other selected
items.)

Move to the bottom of the view, without | CTRL-END
changing the selection or the anchor.
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If you want to

Do this

Move up one page in the view, while
changing the anchor.

(This action selects the row that is in the
same vertical position as the previously
selected row was when its page was
displayed, or it selects the first row if the
view is positioned on the top page. The
newly selected row is the new anchor.)

PAGE UP

Move up one page in the view, without
changing the anchor.

(This action selects all rows between the
anchor and the row that is in the same
vertical position as the anchor was
when its page was displayed, or it
selects all rows from top to anchor if the
view is positioned at the top of the

page.)

SHIFT-PAGE UP

Move up one page in the view, without
changing the selection or the anchor.

CTRL-PAGE UP

Move the view one page left.

(This action selects the column that is in
the same horizontal position as the
previously selected column was when
its page was displayed, or it selects the
first column if the view is positioned on
the far left page.)

ALT-PAGE UP

Move down one page in the view, while
changing the anchor.

(This action selects the row that is in the
same vertical position as the previously
selected row was when its page was
displayed, or it selects the last row if the
view is positioned on the bottom page.
The newly selected row is the new
anchor.)

PAGE DOWN

Move down one page in the view,
without changing the anchor.

(This action selects all rows between the
anchor and the row that is in the same
vertical position as the anchor was
when its page was displayed, or it
selects all rows from the bottom to the
anchor if the view is positioned at the
bottom of the page.)

SHIFT-PAGE DOWN
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If you want to

Do this

Move down one page in the view,
without changing the selection or the
anchor.

CTRL-PAGE DOWN

Move the view one page right.

(This action selects the column that is in
the same horizontal position as the
previously selected column was when
its page was displayed, or it selects the
last column if the view is positioned on
the far right page.)

ALT-PAGE DOWN

Expand the selected row requirement to
show its children in the view.

SHIFT-PLUS SIGN

Collapse the selected row requirement
to hide its children in the view.

MINUS SIGN

Select every row in the view.

CTRL-A

Cut text of any nonlist attribute.

SHIFT-DELETE

Copy text of any nonlist attribute.

CTRL-INSERT

Paste text of any nonlist attribute.

SHIFT-INSERT

Mouse Actions

Traceability Matrix Mouse Actions and Keyboard Shortcuts

If you want to Do this

Select a cell. Click cell

(This action clears all other selected

cells.)

Select all cells in the rectangle formed by | SHIFT-click cell

the anchor cell and the clicked cell.

Set the cell as the anchor while keeping
previously selected cells selected.

OR

Clear a previously selected cell while
keeping others selected.

CTRL-click cell

OR

CTRL-click row label
OR

CTRL-click column label
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If you want to Do this

Select the row and the cell(s) at the Click row label
intersection of the selected row and the
currently selected column(s).

(This action clears all other selected cells
and rows and sets the selected cell and
row as anchors.)

Select the cells in all rows between the | SHIFT-click row label
clicked row and the anchor row, in all
selected columns.

(This action clears any rows and
columns that are not in the range.)

Select the column and the cell(s) at the |Click column label
intersection of the selected column and
the currently selected row(s).

(This action also clears all other selected
cells and columns and sets the selected
cell and column as anchors.)

Select the cells in all columns between | SHIFT-click column label
the clicked column and the anchor
column, in all selected rows.

(This action includes all selected rows.)

Keyboard Shortcuts

If you want to Do this

Move to the right one column. TAB
OR
RIGHT ARROW

Move to the left one column. SHIFT-TAB
OR
LEFT ARROW

Move down one row. ENTER
OR
DOWN ARROW

Move up one row. SHIFT-ENTER
OR
UP ARROW
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If you want to Do this

Display a shortcut menu for the SPACEBAR
currently selected cells.

Close the shortcut menu for the ESC
currently selected cells.

Move to the top of the view and select | HOME
all cells in the selected columns in the
top row.

(This action clears all other selected
rows and sets the top row as the anchor.)

Move to the top of the view, without SHIFT-HOME
changing the anchor.

(This action selects all cells in selected
columns between the top row and the
anchor row.)

Move to the top of the view, without CTRL-HOME
changing the selection or the anchor.

Move to the bottom of the view and END
select all cells in the selected columns in
the last row.

(This action clears all other selected
rows and sets the last row as the
anchor.)

Move to the bottom of the view, without | SHIFT-END
changing the anchor.

(This action selects all cells in selected
columns between the bottom row to the
anchor row.)

Move to the bottom of the view, without | CTRL-END
changing the selection or the anchor.

Move up one page in the view, while PAGE UP
changing the anchor.

(This action selects the selected columns
and the row that is in the same vertical
position as the previously selected row,
or it selects the top row if the view is
already on the top page. The newly
selected row is the new anchor.)
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If you want to

Do this

Move up one page in the view, without
changing the anchor.

(This action selects all rows between the
anchor and the row that is in the same
vertical position as the anchor was
when its page was displayed.)

SHIFT-PAGE UP

Moves up one page in the view, without
changing the selection or the anchor.

CTRL-PAGE UP

Move the view one page left, while
changing the anchor.

(This action selects the selected rows
and the column that is in the same
horizontal position as the previously
selected column was when its page was
displayed, or it selects the first column if
the view is positioned on the far left

page.)

ALT-PAGE UP

Move the view one page left, without
changing the anchor.

(This action selects the cells in selected
rows and the columns between the
anchor column and the column that is in
the same horizontal position as the
anchor column was when its page was
displayed, or selects the first column if
the view is already on the far left page.)

ALT-SHIFT-PAGE UP

Moves left one page in the view, without
changing the selection or the anchor.

ALT-CTRL-PAGE UP

Move the view down one page, while
changing the anchor.

(This action selects the selected columns
and the row that is in the same vertical
position as the previously selected row
was when its page was displayed, or it
selects the last row if the view is already
on the bottom page. The newly selected
row is the new anchor.)

PAGE DOWN

Move down one page, without
changing the anchor.

(This action selects all rows between the
anchor and the row that is in the same
vertical position as the anchor was
when its page was displayed.)

SHIFT-PAGE DOWN
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If you want to Do this

Move down one page in the view, CTRL-PAGE DOWN
without changing the selection or the
anchor.

Move the view one page right, while ALT-PAGE DOWN
changing the anchor.

(This action selects the selected rows
and the column that is in the same
horizontal position as the previously
selected column was when its page was
displayed, or it selects the last column if
the view is already on the far right

page.)

Move the view one page right without | ALT-SHIFT-PAGE DOWN
changing the anchor.

(This action selects the selected rows
and the columns between the anchor
column and the column that is in the
same horizontal position as the anchor
was when its page was displayed, or it
selects the last column if the view is
already on the far right page.)

Move right one page in the view, ALT-CTRL-PAGE DOWN
without changing the selection or the
anchor.

Expand the selected row requirement to | SHIFT-PLUS SIGN
show its relationships. Preserve the
previous row selection.

Collapse the selected requirement to MINUS SIGN
hide its relationships.

Select every cell in the view. CTRL-A

Traceability Tree Mouse Actions and Keyboard Shortcuts

Mouse Actions

If you want to Do this

Select the clicked item. Click row

(This action clears all selects items and
sets the selected row as the anchor.)
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If you want to

Do this

Select the items between the anchor row
and the row in which you click.

(This action clears any rows that are not
in the range.)

SHIFT-click row

Set the selected row as the anchor, while
keeping previously highlighted text
selected.

OR

Clear a previously selected row while
keeping others selected.

CTRL-click row

Copy a selected row's requirement to a
new position. (The requirement cannot
be a root requirement.)

CTRL-click row, then drag

Move a selected row's requirement. (The
requirement cannot be a root
requirement.)

ALT-click row, then drag

Keyboard Shortcuts

If you want to

Do this

Move down one row

DOWN ARROW

Move up one row

UP ARROW

Display a shortcut menu for the
currently selected requirements.

SPACEBAR

Close the shortcut menu for the
currently selected requirements.

ESC

Move to the top of the view and select
the first row.

(This action sets the first row as the
anchor and clears all other selected
items.)

HOME

Move to the top of the view, without
changing the anchor.

(This action selects all items between the
anchor row and the first row of the
view.)

SHIFT-HOME
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If you want to Do this

Move up one page in the view, without | CTRL-HOME
changing the selection or the anchor.

Move to the bottom of the view and END
select the last row.

(This action sets the last row as the
anchor and clears all other selected
items.)

Move to the bottom of the view, without | SHIFT-END
changing the anchor.

(This action selects all items between the
anchor row and the last row of the
view.)

Move down one page in the view, CTRL-END
without changing the selection or the
anchor.

Move up one page in the view, while PAGE UP
changing the anchor.

(This action selects the row that is in the
same vertical position as the previously
selected row was when its page was
displayed, or it selects the top row if the
view is positioned on the top page. The
newly selected row is the new anchor.)

Move down one page in the view, while [ PAGE DOWN
changing the anchor.

(This action selects the row that is in the
same vertical position as the previously
selected row was when its page was
displayed, or it selects the last row if the
view is positioned on the bottom page.
The newly selected row is the new
anchor.)

Move up one page in the view, without | SHIFT-PAGE UP
changing the anchor.

(This action selects all rows between the
anchor and the row that is in the same
vertical position as the anchor was
when its page was displayed, or it
selects all rows from the top to the
anchor if the view is positioned at the
top of the page.)
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If you want to

Do this

Move down one page in the view,
without changing the anchor.

(This action selects all rows between the
anchor and the row that is in the same
vertical position as the anchor was
when its page was displayed, or it
selects all rows from the bottom to the
anchor if the view is positioned at the
bottom of the page.)

SHIFT-PAGE DOWN

Move up one page in the view, without
changing the selection or the anchor.

CTRL-PAGE UP

Move down one page in the view,
without changing the selection or the
anchor.

CTRL-PAGE DOWN

Expand the item to show its PLUS SIGN
relationships.

Collapse the item to hide its MINUS SIGN
relationships.

Highlight every item in the view. CTRL-A
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Customizing
RequisitePro

Configuring RequisitePro

You can use the Tools > Options command on the Tool Palette to configure the
appearance and behavior of Rational RequisitePro.

1

On the Tool Palette, click the Tools > Options.
The Options dialog box appears.

Type or select the following options as needed:

Tool Palette

a

a

Show Buttons: Select this check box to display the Tool Palette buttons.

Show Status: Select this check box to display the status line on the Tool Palette.
This displays project and document status as you work in RequisitePro.

Show Tool Tips: Select this check box to display a button function definition
when you hold the pointer over a button on a RequisitePro toolbar.

Always on Top: Select this check box to display the Tool Palette and open dialog
boxes in the foreground of your screen, regardless of how many applications
you have open.

Let's Go RequisitePro at startup: Select this check box to display the Let's Go
RequisitePro splash screen each time you start RequisitePro.

Views

Q

Prompt for save: Select this check box if you want RequisitePro to prompt you
to save changes to display options and view properties when you close an
unsaved view. Changes to requirements and other data within the view are not
affected.

Double-click to go to source: Select this check box if you want the option to
double-click on a requirement in a view to access its source. For requirements
located in documents, the document opens. For other requirements, the
Requirement Properties dialog box opens. If this check box is cleared,
double-clicking expands and collapses the requirement hierarchy.
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s ENTER key inserts new line (multi-line only): Select this check box if you want to
use the ENTER key to create a new line in an Attribute Matrix.

2 In-view requirements creation (without dialog box): Select this check box if you
want to create requirements directly in the Attribute Matrix using the
Requirement > Create command or the INSERT key. If this check box is cleared,
the Requirement Properties dialog box appears when you click Requirement >
Create or the INSERT key.

2 Font: This field lists the font displayed in the Views Workplace.
s Change: Click this button to change the font.
Traceability

2 Warn on remove: Select this check box if you want RequisitePro to display a
warning message when you remove requirement traceability.

2 Changes logged in history: Select this check box to display changes to
requirement traceability on the revision history list in the Requirement
Properties dialog box.

Default Project Logon

s Username: This field contains (by default) the user name from the last
successful project logon. This entry will be used as the default name at the next
attempt to logon to a RequisitePro project. Type another user name if
necessary.

Microsoft Word

s Version: Click the down arrow to select your preferred version of Microsoft
Word when you have more than one version installed. The option <Use
Default> uses the current version of the application, which is recorded in the
Windows registry.

Microsoft Project

2 Version: Click the down arrow to select your preferred version of Microsoft
Project when you have more than one version installed. The option <Use
Default> uses the current version of the application, which is recorded in the
Windows registry.

Directories

2 Document Outlines: This field defines a secondary location for accessing
document type outlines. If RequisitePro is installed locally on your PC, the
default path is Program Files\Rational\RequisitePro\outlines. Use this option to
define an alternate location for outlines (for example, a directory on a server for
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shared outlines). Note that the document outlines directory and the secondary
document outlines directory are stored for your own machine configuration,
not for the RequisitePro project.

ClearCase View: This field defines the directory for ClearCase archiving in
RequisitePro. This must be a ClearCase view that is available to all users of the
RequisitePro project.

Working Path: This field displays the working directory for RequisitePro. Write
permission must be available for this directory in order for RequisitePro to
create new projects and write temporary files.

Project Template Path: This field defines a secondary location for storing project
templates. If RequisitePro is installed locally on your PC, the default path is
Program Files\Rational\RequisitePro\templates. Use this option to define an
alternate location for project templates (for example, a directory on a server for
shared templates).

3 C(lick OK.

Customizing Tool Palette Menus

The Add-in option on the Tool Palette Tools menu allows you to add your own
customized menu items to any menu on the Tool Palette. These menu options can be
used to start external applications, such as e-mail or the Windows Notepad, directly
from RequisitePro. In addition, you can configure an option to open an individual file
with the application of your choice.

You can add either a project-wide menu item for use by all members of the project
team or a menu item that appears only when you open RequisitePro on your PC. The
Add-in option prompts you to specify an external menu file that defines your
customized menu options.

To add custom menu items:

1

On the Tool Palette, click Tools > Add-ins.
The Add-ins dialog box appears.

Click the Add button to add a customized menu option. The Add-in dialog box
appears.

Type a name for the menu option. This name identifies the menu file on your
add-ins list.

Click the Browse button. The Select a RequisitePro Menu File dialog box appears.
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Select a file type to display: All Files, Menu Files, or Text Files.
Navigate to a menu file and click Open.

Leave the Active check box as marked.

©® N o o

Select one of the following:
s Local to apply the menu items to your Tool Palette only.

s Project to apply the menu items to the Tool Palette of all users who access the
project.

9 Click OK to close the Add-in dialog box.
10 Click OK to close the Add-ins dialog box.

The options defined in the menu file are added to the specified Tool Palette menu.

Creating a Menu File

Using any text editor, you can create a file to add menu options to any RequisitePro
Tool Palette menu. The entries will appear on the RequisitePro menu in the order in
which you specify them.

As you add menu entries, you will specify:

» Keywords that determine items on the menu (a submenu, a menu option, a
separator)

* Menu actions that execute an application or open a specific external file, such as a
readme file.

Pay close attention to the syntax rules that apply to your entries to the menu file. For
example, the syntax of the menu specifications includes opening and closing braces

{..}.

Note: Rational Rose users may be familiar with creating menu specification files for
extending the Rose Tools menu. RequisitePro menu files use the same syntax with a
subset of the Rose functions.
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Menu File Template

Create your menu file in a text editor, based on the following template. Save your file
with a .TXT extension or a .MNU extension to help locate the file easily in your file
structure.

Menu <RequisitePro menu name>
{

Separator

Option <menu item>

{

Exec <command line>
Status <status text>

}

Menu <submenu name>
{

Option <menu item>{
Exec <command line>
Status <status text>

}

Option <menu item>

{

Exec <command line>
Status <status text>

}

}
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Key Words

Use the following table to define the key words to copy into the menu file:

Keywords and Variables Definitions and Valid Entries

Menu Keyword to specify the Tool Palette menu or
submenu to which you want add the menu
items

Separator Keyword to place a separator in the menu

Option Keyword to specify the name of the item as it

will appear on the menu

Exec Keyword to identify the command line to be
run when the menu item is chosen

Status Keyword to identify the text for the status line
of the Tool Palette

<RequisitePro menu name> Project, Document, Requirement, Tools,
Window, or Help

<menu item> User-defined text for an item on the menu or
submenu

<submenu name> User-defined text identifying the name of the
submenu

<command line> User-defined text identifying the commands to

execute when the menu item is chosen

<status line> User-defined text identifying the text for the
status line of the Tool Palette

Notes

1 Menu names, submenu names, option names, and statuses need double quotes if
they include more than one word.

2 Separators can be in menus or submenus.
3 Can include more than one menu item in a file.

4 Add an ampersand (&) directly before a character in the menu name to create a
underlined letter signifying an access key in the menu option.

5 You can create a maximum of five levels of submenus (indented one below
another).
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Sample Menu File

The following example shows a simple menu definition file. After you create a menu
file, reference using the Add-ins option on the Tool Palette Tools menu. This feature
allows you to add customized menu options to the RequisitePro menus.

The following menu file instructs RequisitePro to add the options “Open readme file”
and “Open Windows Notepad” to the Tool Palette Window menu.

E sample_txt - Notepad M= 3

File Edit Search Help
Henu Window

{

-

Separator
Option "Open &readme file..."

Exec “"c:iyprogram files\rational\requisitepro 4.8\readme.doc"”
Status "This will open the RequisitePro readme file"

¥

Option "Open Windows &Motepad..."

{

Exec notepad.exe
Status "Open the Windows Hotepad”

¥

3
K| 2
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Glossary

The terms that follow are used throughout Using Rational RequisitePro. Most are specific to RequisitePro.

active document: The current document in the Word Workplace, which has processing focus. The Word
Workplace is the Microsoft Word implementation within RequisitePro where you view, create, and
modify project documents. You can have many documents open at one time; however, only one of these
documents is active.

active view: The current view in the Views Workplace, which has processing focus. You can have many
views open at one time; however, only one of these views is active. See also Views Workplace.

activity: A unit of work an individual, or a set of individuals working together as a team, may be asked
to perform.

actor: Someone or something outside the system that interacts with the system.

Add-in command: An option on the Tool Palette Tools menu that allows you to add your own
customized menu options to any Tool Palette menu. These menu options can be used to start external
applications, such as e-mail or the Windows Notepad, directly from RequisitePro. In addition, you can
configure an option to open an individual file with the application of your choice.

administrators group: A group of users with full permissions to work in a project. They can change a
project structure, create and modify data, modify and delete project-wide views, and set and maintain
security permissions. Users can be added and removed from this group, but this group cannot be
deleted. Administrator group permissions cannot be modified.

analyst: See System analyst.

anchor: The first item you click when using multiple select actions to select a range of items. In
RequisitePro, the term “anchor” is generally used to mean the first cell you click in a view in the Views
Workplace. You use the anchor to select a range of cells. For example, if you click the cell in row 1,
column 1 of a Traceability Matrix, that cell becomes the anchor. If you then Shift-click the cell in row 10,
column 3 of the matrix, all of the cells in rows 1 through 10, columns 1 through 3, are selected. To reset
the anchor, click anywhere outside the range. The cell you click is the new anchor. You can also use an
anchor to select a range of items in documents and in certain dialog boxes that support multiple select
actions. See Multiple select actions.

archiving: The process of duplicating the database, documents, and all related files in a project for the
purpose of restoring at a later time.

attribute: Descriptive information that provides important details about a requirement or discussion.
See also Requirement attribute.

attribute label: The name of the requirement attribute, such as risk, priority, or author. Also referred to
as requirement attribute label.

Attribute Matrix: A spreadsheet-like table View that displays requirements in rows and the attributes
that describe the requirements in columns. You can add or change values in the attribute fields. Also
referred to as Requirement Attribute Matrix.
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attribute type: A set of descriptive and operational information associated with a requirement attribute
when the attribute is created. Attribute values can be list-type or entry-type. For list-type attributes, you
select a textual attribute value from a drop-down list. For entry-type attributes, you type in a value, such
as a number, text string, date, or time. Also referred to as requirement attribute type.

attribute value: Information assigned to a requirement attribute. Attribute values can be text or
numbers. For example, the attribute priority can be assigned the values Low, Medium, and High. Also
referred to as requirement attribute value.

author: The user responsible for creating or modifying a document or requirement.
author (version information): The user responsible for the changes associated with a given revision.

.Jbak file: A backup of a document file. A new .bak file is created in the same directory each time a
document is saved and contains a version of the document before it was saved. You can delete .bak files
at any time; they will be created again the next time the original documents are saved.

baseline: A Rational ClearCase Unified Change Management object that typically represents a stable
configuration of one or more components. A baseline identifies activities and one version of every
element visible in one or more components. You can create a development stream or rebase an existing
development stream from a baseline. See also Unified Change Management.

bookmark: A marker inserted at a specific point in a document to which the user may return for later
reference. In Microsoft Word, a bookmark is a location or selection of text named for reference purposes.
Bookmarks are implemented in RequisitePro documents to designate requirement text. Bookmarks are
designated by square brackets, as in the following: [example].

change description (version information): Textual information that specifies the justification or
reasoning behind the changes associated with a given revision of a project, document, or requirement.
See also Version information.

change-managed relationship: A connection between two requirements that implies dependency or a
logical relationship. RequisitePro tracks two types of change-managed relationships: hierarchical
relationships and traceability relationships. Changes to either of the requirements can cause a “suspect”
condition in the relationship. See also Suspect relationship state.

child requirement: A requirement that participates in a hierarchical relationship with a parent
requirement. A child can have only one parent requirement. See also Parent requirement, Hierarchical
requirement.

circular traceability relationship: A relationship between a requirement and itself, or an indirect
relationship that leads back to a previously traced-from node. Traceability relationships cannot have
circular references. RequisitePro checks for circular references each time you establish a traceability
relationship. RequisitePro also checks for circularity when you create an external relationship. The
circular check only references internal requirements and first-level external requirements.

ClearCase: See Rational ClearCase.
ClearQuest: See Rational ClearQuest.

CMM: The Software Engineering Institute’s Capability Maturity Model, a framework for effective
software process developed at Carnegie-Mellon. CMM for Software describes increasing levels of
process maturity, from an ad-hoc, immature process to a mature, disciplined one.

collapse indicator: See Expand/collapse indicator.
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concurrency: A condition in which two or more users can access the same project at the same time. See
also Exclusive access.

cross-project traceability: A RequisitePro feature that allows you to establish traceability relationships
between requirements that reside in different projects. See also External traceability.

CSV file: A comma-separated value text file, commonly used to exchange files between database
systems that use different formats. Sometimes called comma-delimited files, CSV files can be imported
into RequisitePro.

Ctrl-click: See Multiple select actions.

current project: The project that is open, or active. A user can have only one RequisitePro project open at
a time. Also referred to as the active project or the open project.

database: A collection of data stored in a repository. By using specific commands, you can search and
sort a database for the retrieval of specific information. RequisitePro stores your projects in a database.
Use the views and queries in the RequisitePro Views Workplace to search the project database. See also
Project database.

.def file: A file, located in the RequisitePro outlines directory, that specifies information about a
particular document outline used by RequisitePro. See also Outline.

deleted Users group: A security group of users who have been deleted from other groups, have no
permissions, and cannot log on to RequisitePro. This group is maintained by the project administrator
for project history.

dialog box: An interactive window displayed on the screen that solicits a response from the user.
dialog box shortcut: See Keyboard shortcuts.

directory: A catalog for file names and other directories. A directory is an organization of files (or
folders) grouped for the user’s convenience. The topmost directory is called the root directory. The
directories within a directory are called subdirectories.

Discussion: A RequisitePro feature that lets you address comments, issues, and questions to a group of
discussion participants. Discussions can be associated with one or more specific requirements or refer to
the project in general.

discussion item: A discussion item is either the initial discussion topic or a response. A response can be
either to the initial discussion text or to another response.

.doc file: A DOS file name extension for Microsoft Word documents. Do not use the .doc file name
extension as a file name extension for document types.

document: Any Microsoft Word document. It may be part of the RequisitePro project or outside the
project, and it may or may not contain requirements. See also Requirements document.

document properties: Specific items of information about a RequisitePro document. Documents have
attributes associated with them such as author, date and time of last revision, and file name.

document type: Defines descriptive and operational information associated with a requirements
document. The document type serves as an outline for each requirements document you create of that
type. The document type defines the document’s file extension, such as .prd; all documents of the same
document type share the same file extension. The document type identifies a default requirement type;
each new requirement you create in the document will be based on the default requirement type unless
you indicate otherwise. The document type also identifies an outline (or template) for the document
which controls its page layout, default text, paragraph styles, and so on.

Glossary 299



document version: A revision of a RequisitePro document, identified in the document properties
revision history. A new version is created when a document is changed and saved. See Revision.

.dot file (Word template): A DOS file name extension for Microsoft Word template files. A Word
template determines the basic structure for a document, including fonts, menus, special formatting, and
styles. A Word template is associated with a RequisitePro document outline, which can be used to create
documents. Document outline information is stored in .def files. You can edit the .dot files associated
with your document types to include your company name and other information specific to your
organization. You can enter the company name and other information in the Microsoft Word File >
Properties dialog box. Then in the document itself, right-click on the Company-Name field, and select
Update Field (Word template).

drag: See Multiple select actions.

drop-down menu: A list that appears below a menu bar or field when the user clicks the down arrow.
The menu remains open without further action until the user closes it or chooses a menu item.

enhancement request: A type of stakeholder request that specifies a new feature or functionality of the
system. Certain Rational RequisitePro requirement types have attributes that associate the requirement
with specific records in Rational ClearQuest. By default, if you are using a project based on the Use Case
project template, the feature (FEAT) requirement type includes EnhancementRequest and Defect
attributes that can associate the feature requirement with enhancement request and defect records in
ClearQuest.

enterprise database: A database that is designed to support a large, networked organization. An
enterprise database offers scalability, security, and administrative features for large, complex projects.
RequisitePro supports the use of the enterprise databases Oracle and SQL Server for RequisitePro
projects.

entry-type attributes: Entry-type attributes are numeric, text, time, or date values that are typed in by
project users. An entry-type attribute can be configured with a default value, which users can accept or
replace as they create or modify requirements. For example, if you want to set a default cost of $20,
format the entry-type attribute “Cost” to accept integer values and have a default value of 20. You define
attributes in the Attributes tab of the Project Properties dialog box. Requirement attributes can be entry
type or list type. If you have configured an integration with Rational ClearQuest, you have two
additional default requirement types, EnhancementRequest and Defect. See also Attribute types, Attribute
values. Compare List-type attributes.

exclusive access: A condition by which access to a RequisitePro project and its documents is only
available to the user who opens the project. Exclusive access is required to change a variety of project
characteristics. You set access when you open a project. See also Concurrency.

expand/collapse indicator: A small box displayed in one of the following locations: next to a
requirement in a view, indicating that the requirement has one or more child requirements; or next to a
discussion item in the Discussions dialog box, indicating that the discussion item has responses. The box
contains a + or a -, indicating whether or not the requirement or discussion is displayed in an expanded
or collapsed state.

export: To move information from one system or program to another. You can export requirements from
a RequisitePro view to Microsoft Word documents and to CSV files.

extension: See File name extension.

external project: A project containing requirements used to establish traceability relationships with
requirements in a currently open project.
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external requirement: A requirement residing in an external project. You can create traceability
relationships between requirements in different projects.

external traceability: Traceability relationships between requirements in two different projects. See also
Traceability.

file name extension: A DOS file name extension (for example, .prd). File name extensions are used in
RequisitePro to indicate document type and can contain a maximum of 20 characters.

filtering: A process by which you can change the amount of information displayed in a view in the
Views Workplace. You specify certain criteria on which to filter information. You can filter requirements
by specifying certain distinct criteria for any or all of their attributes. For example, instead of displaying
all requirements, you might apply a filter such that only requirements having a high priority are
displayed. See also Sorting, Query.

graphic: Electronic line art or bitmapped artwork. You can use graphic formats such as Enhanced
Metafile (.emf), Joint Photographic Experts Group (.jpg), Portable Network Graphics (.png), Windows
Bitmap (.bmp, .rle, .dib), and Windows Metafile (.wmf) in your RequisitePro documents.

group: A list of users, defined in project security and organized by the operations they have privileges to
perform (for example, Administrators group members can create group accounts and add users to
groups).

hidden text: A Microsoft Word feature used to hide text within a document. Hidden text is delineated
with a dotted underline. In RequisitePro, a requirement within a document begins with a requirement
tag formatted in hidden text style.You can hide the tags for improved readability. On the Microsoft
Word menu bar, click Tools, then Options, and then click the View tab. Clear the Hidden text check box
and click OK.

hierarchical requirement: A requirement that is included within an ordered relationship with other
requirements of the same type. Use hierarchical relationships to subdivide a general requirement into
more explicit requirements. Child requirements provide additional detail for their parent requirement.
For example:

Parent requirement: The system shall display customer information.

Child requirements provided for detail: Name, Address, Date of Birth.

Each child requirement can only have one parent, but a requirement can be both a parent and a child. If a
parent requirement is changed, the relationships with its children become suspect.

icon: A graphical representation of a RequisitePro command or process. When used in RequisitePro on
toolbars in the Tool Palette and Views Workplace, icons are typically referred to as buttons.

IEEE: (“I triple E”) Institute of Electronics and Electrical Engineers, the hardware and software standards
body, sets standards for such measurable items as acceptability criteria, performance benchmarks, and
configuration management.

import: To bring information from one system or program into another. In RequisitePro, you can import
documents and requirements from Microsoft Word files and from CSV files.

Integrated Use Case Management: An integration between Rational RequisitePro and Rational Rose
that allows you to associate use cases in Rose with RequisitePro documents and requirements. You can
easily navigate from Rose use-case models to RequisitePro use-case documents and requirements and
vice versa.

internationalization: The process of developing a program core whose feature and code designs don't
make assumptions based on a single language or locale and whose source code base simplifies the
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creation of different language editions of a program.

keyboard shortcuts: A dialog box shortcut is a keyboard combination you can use to move to tabs, fields,
and buttons in a RequisitePro dialog box. To use a dialog box shortcut, press the Alt key while
simultaneously pressing the underlined letter in a dialog tab, field, or button. For example, in the Project
Properties, Document Properties, or Requirement Properties dialog boxes, press Alt-G to open the
General tab.

A menu shortcut is a keyboard combination you can use to open a menu in the Tool Palette or Views
Workplace. To use a menu shortcut, press the Alt key while simultaneously pressing the underlined
letter in the menu. For example, to open the Requirement menu, press Alt-R. Once a menu is displayed,
you can select a command by pressing the key for the underlined letter in the command.

keyword: Words that are used to help specify and define requirements. Many organizations use words
such as “shall,” “must,” or “will” in their requirements, making it easier to separate a requirement from
surrounding text in the document. Keywords are a part of the definition of a requirement type. You enter
keywords in the Requirement Must Contain field in the Requirement Type dialog box. See also
Requirement type.

label (version information): A string that contains user-defined revision information, up to 20
characters. You can use a revision label for noting requirement, document, or project/archive version
information.

leaf tag: The last (rightmost) number in a requirement’s tag number. For example, the leaf tag number
for Requirement PRD201.7.9 is 9.

licensed user: A RequisitePro user. Each user that is associated with a license of RequisitePro is a
licensed RequisitePro user. Also referred to as user.

list-type attributes: Requirement attributes are either list-type or entry-type. List-type attributes are sets
of descriptive values (for example, Status, which may contain the list values Proposed, Approved, In
progress, and Complete). You can assign single values or multiple values for list-type attributes. You
define attribute values in the Attributes tab in the Project Properties dialog box. See also Attribute types,
Attribute values. Compare Entry-type attributes.

matrix: An arrangement of rows and columns used for organizing related items in the Views Workplace.
See Attribute Matrix, Traceability Matrix.

menu: A list of options from which a user can make a selection in order to perform a desired action. In
RequisitePro, menus are available from the menu bar found above the buttons on the Tool Palette and in
a View window. The Word Workplace includes a RequisitePro menu with access to document,
requirement, and window commands.

menu file: A text file with specific syntax that is used to add menu commands to any RequisitePro Tool
Palette menu. Menu files typically have an MNU or TXT file extension. Menu files are referenced using
the Add-ins command on the Tools menu. The commands appear on the RequisitePro menus in the
order in which they are specified in the menu file.

menu shortcuts: See Keyboard shortcuts.
Metrics: See Requirement Metrics.

multiple select actions: Mouse actions and combination keyboard /mouse actions that you use to select
multiple items in RequisitePro. Use Ctrl-Click to select multiple items that are not adjacent to each other.
Hold down the Ctrl key and click the mouse. (You can also use Ctrl-click to clear a selected item.) Use
Shift-click to select a range of items. Hold down the Shift key and click the mouse. Use Drag to select a
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range of items. With one item selected, drag the mouse. Release the mouse when the range is selected.

multiple value list: An attribute type that supports one-to-many associations. You can use a multiple
value list when you want to assign a requirement more than one value for a specific attribute.

For example, you might create an attribute type called Owner, with multiple values Bob, John, and Sue,
representing different users working on the same project. For this attribute, you might then assign only
the values Bob and Sue to a particular requirement, indicating that Bob and Sue are responsible for this
particular requirement, but John is not.

name: See Requirement name.
offline author: A user who takes a RequisitePro document offline.

offline authoring: A RequisitePro feature that lets users read and modify a document in Microsoft Word
outside of RequisitePro (i.e., offline). When you take a document offline, RequisitePro creates a copy of
the document in the directory you specify. The original is still stored in RequisitePro, but it is changed to
a read-only document. Other users can view the document in RequisitePro, but they cannot edit it until
you bring it back online.

OLE: Object linking and embedding. You can create an OLE object in one application (original
application) and insert it into files in other (source) applications. If you modify the OLE object in its
original application, the changes are automatically reflected in any files containing the OLE object in a
source application. You can use OLE objects in RequisitePro requirements documents.

open project: See Current project.

outline: A reference document or template used to create new documents in RequisitePro. An outline
can include formats, page layout information, fonts, and Word styles. An outline is useful for
maintaining consistency across documents of the same type. Outline information is stored in a .def file. It
includes the outline's full name, a description of the outline, and the associated Word template's DOS
filename (.dot). See also Document type.

parent requirement: A requirement that participates in a hierarchical relationship with one or more
child requirements. A parent can reside at the root level, or it can be nested in the hierarchy with a parent
of its own. In either case, parents reside above their children in the hierarchy. See also Child requirement,
Hierarchical requirement.

parse: To break information into component parts so that a program can act upon it. Used by the Import
Wizard to separate requirements in a document.

peer requirement: A requirement that is at the same hierarchical level as another requirement. For
example, two requirements are peer requirements when they are children of the same parent. In
addition, all requirements at the root level are peer requirements of one another. See also Parent
requirement, Child requirement, Hierarchical requirement.

pending requirement: A newly created requirement in a document or a view that has not yet been saved
in the database.

pending tag number: A tag number for a newly created requirement in a RequisitePro document. The
requirement maintains the pending tag number until the document is saved. See also Requirement tag.

permissions: The RequisitePro privileges granted to a group of RequisitePro users. RequisitePro
administrators or members of a group with project security permissions can assign permissions to
groups. Also referred to as privileges or rights. See also Security.
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project: A RequisitePro project. A project includes a database, documents, document types,
requirements and their attributes, requirement types, requirement traceability, discussions, and user and
group security. Within RequisitePro, you create a project first. You then create requirement documents
and requirements in each document.

project database: The requirements database managed by RequisitePro. The project database stores all
requirements in the project, including those created in requirement documents. Changes you make to
requirements in the documents are reflected in the project database. You can create requirements
directly in the project database rather than in a requirement document using an Attribute Matrix view.
These requirements can be modified or deleted in the Views Workplace. Microsoft Access, Oracle, and
Microsoft SQL Server databases are available for use in RequisitePro projects. See also Database.

project directory: A directory that contains information for a single RequisitePro project. You define the
project directory when you create a new project. (By default, RequisitePro creates a directory name that
matches what is typed in the Name text box in the RequisitePro Project Properties dialog box.) For
projects that use the Microsoft Access database, the database is stored in the project directory. The
project directory does not store the database for projects that use an enterprise database (i.e., Oracle and
SQL Server databases). Requirements documents for the project may be stored in another directory. The
project directory path can contain up to 256 characters. See also Directory.

project prefix: An identifier used for requirements in cross-project traceability. In an external project, the
prefix is displayed before the tag requirement, separated from the tag by a period. For example, if a
requirement’s tag is PR234 and the project’s prefix is GLOBAL, then the external requirement is
displayed as GLOBAL.PR234. The prefix can be up to 8 characters and must be uppercase letters. You
can change the prefix at any time in the Project Properties dialog box, General tab.

project properties: The characteristics that make up a project, such as document types, requirement
types, requirement attributes, the date a project was created, the user who created it, and the file location
where the project is stored.

project summary report: A report that displays the project’s entire structure in report form. The
requirement types (and their attributes, including multiple value lists), document types, and document
details are included in the printout.

project template: A RequisitePro template that contains project structure including document types,
requirement types, requirement attributes, users, groups, and security.

query: A method for filtering and sorting requirements in views by limiting the values of one or more
attributes or by limiting traceability, and specifying the order in which the filtered requirements are
displayed. For example, you might create a query such that only requirements having a high or medium
priority are displayed. Within that filter, you might sort requirements first by priority, and then by cost.

Rational Administrator. A Rational tool that enables integrations between Rational products. Use
Rational Administrator to configure Rational projects, which store software testing and development
information.

Rational ClearCase: Rational's configuration management tool, which can be used to store copies of
RequisitePro projects. Implementing a Unified Change Management model, ClearCase can also be used
to create baselines of RequisitePro projects.

Rational ClearQuest: Rational’s change-request management software. ClearQuest offers a flexible
approach to track and manage all the change activities that are associated with an organization, such as
defects and enhancement requests. In RequisitePro, the terms ClearQuest and Rational ClearQuest are
used interchangeably.
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Rational Rose: Rational’s visual modeling tool for designing and visualizing object-oriented and
component-based applications. RequisitePro is integrated with Rose through Integrated Use Case
Management.

Rational TestManager: A Rational tool designed to help software development and testing
professionals track software testing information through all phases of the software development, test,
and revision cycles. If you have installed TestManager, we recommend that you develop all test artifacts
in that tool.

Rational Unified Process: Rational’s online knowledge base of proven software-development
principles. RUP captures many of the best practices in modern software development in a form that can
be tailored to a wide range of projects and organizations. RUP includes Tool Mentors, which provide
descriptions on how Rational Software tools can be used to support particular steps and activities.

read-only access: An option by which a RequisitePro project or document is restricted to viewing only.

renumbering: The process of assigning new numbers to requirements. The renumber feature is useful
for eliminating “holes” in a numbering scheme, which can result when you delete requirements. To
renumber requirements, you must open the project in exclusive mode. In addition, if security is has been
set, you must have project structure permission to renumber requirements. To renumber requirements
in documents, all documents that contain requirements of that type must be open.

reparenting: The process of reassociating a hierarchical requirement with a new parent of the same
requirement type. When you reparent a requirement, the entire sub-tree of children is also moved to the
new parent. The reparented requirements are renumbered as if they were newly created for the new
parent. See also Child requirement, Parent requirement, Hierarchical requirement.

report: A formatted and organized presentation of data. In RequisitePro, you can use Requirement
Metrics and the RequisitePro Extensibility Interface to create reports using data in the requirements
database.

repository: A collection of data; a database.

requirement: Describes a condition or capability to which a system must conform; either derived
directly from user needs, or stated in a contract, standard, specification, or other formally imposed
document.

requirement attribute: A descriptive field of information associated with a requirement. RequisitePro
requirement attributes are either system attributes (defined by RequisitePro) or user-defined (defined by
the project owner). See Attribute.

requirement attribute label: The name of the requirement attribute, such as risk, priority, or author. See
Attribute label.

requirement Attribute Matrix: See Attribute Matrix.
requirement attribute type: See Attribute type.
requirement attribute value: See Attribute value.

requirement location: The location where a requirement was created or the location to which it was last
moved. The location can be either a specific requirements document or the project database.

Requirement Metrics: A Rational RequisitePro feature for compiling statistics on requirement name,
text, attributes, relationships, and revisions. These report results are displayed in Microsoft Excel and
can be manipulated using Excel’s charting capabilities. Two types of reports are available: static reports
(which show results about the project at the present time) and trend analysis reports (which use
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time-sensitive filters that analyze changes in requirement text, attributes, traceability, and hierarchical
relationships).

requirement name: A user-defined title for a requirement. Like tag and text attributes, the name can be

used to reference requirements. The name is displayed by default in all Rational RequisitePro views. All
requirements must have either a name, text, or both, but requirements located in documents must have

text. A name does not need to be unique and can be changed at any time if you created the requirement
or belong to a group that has update permissions.

requirement tag: The unique identifier of each requirement in a project. A requirement tag is composed
of a tag prefix and a unique numerical value, such as “PR100.1.2.” The tag prefix is always the
requirement type, as defined in the Project Properties dialog box. The numerical value is generated by
RequisitePro. The tag prefix can contain a maximum of 20 characters. Each requirement type in your
project has a different tag prefix (for example, FEAT, SR, UCS) that you determine when you create a
new project or add a new requirement type. When you add a requirement to a requirements document
or database, RequisitePro assigns the requirement the appropriate tag prefix, dependent on its
requirement type, and an incremental numerical value. See also Leaf tag, Pending tag number.

requirement text: The full textual content of a requirement. In a document, it may include embedded
and linked objects, such as graphics, tables, and Microsoft Word files.

requirement type: A set of descriptive and operational information associated with a requirement when
the requirement is created. A requirement type serves as an outline for all requirements of the same type
and is useful for classifying and grouping similar requirements in a project. Each requirement type has
its own set of user-defined attributes. See also Requirement attribute.

requirement version: A requirement attribute that shows the version of the requirement. As a
requirement evolves, it is helpful to identify the version numbers (and history) of requirements changes.

requirements document: A document created in Microsoft Word or RequisitePro that captures
requirements and is used to communicate product development efforts. Each requirements document
addresses a particular requirement type, such as product features, use cases, and supplementary
specifications. A RequisitePro requirements document differs from a Word document in that you can
access requirement attributes and other information directly from within the requirements document.
Also referred to as document or RequisitePro document.

requirements management: A systematic approach to eliciting, organizing, documenting, and
managing the changing requirements of a software application.

requirements text: The full textutal content of a requirement. In a document, it may include embedded
and linked objects, such as graphics, tables, and Microsoft Word files.

RequisitePro document: A Microsoft Word document that is part of a RequisitePro project. Most Word
functionality is available within RequisitePro documents.

RequisiteWeb: Rational’s Web interface that allows clients to access RequisitePro requirements
information across the Internet or an intranet. By utilizing browsers -- Netscape Navigator or Microsoft
Internet Explorer -- RequisiteWeb provides a thin client solution to access project documents and data.
No Requisite application-specific files need to be installed on individual machines.

response: An answer to a discussion item. You can respond to the initial discussion topic or to other,
previous responses. In RequisitePro, the terms “response” and “discussion response” are used
interchangeably.
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revision: A distinct version of a project, document, or requirement. A revision is identified by a unique
internal revision number, generated by RequisitePro.

revision number: The number identifying a revision. Revision numbers are automatically incremented
each time you or another user changes and saves a project, document, or requirement.

root requirement: A requirement at the uppermost level of the requirements hierarchy. A root
requirement does not have a parent requirement. See also Parent requirement, Child requirement,
Hierarchical requirement.

Rose: See Rational Rose.

xgs file: A text file, created and updated automatically by RequisitePro, that stores project-specific
information. Every RequisitePro project has an .rgs file, which resides in the project directory. Do not
modify any section of this file, except the [MSProjectMappings] section, as described in RequisitePro
Online Help.

RUP: See Rational Unified Process.

security: Prevention of system use, potential harm, or data loss by unauthorized individuals. In
RequisitePro, users are given specific permissions that determine the amount or kind of access they have
to projects. If you are a RequisitePro administrator or a member of a group with project security
permissions, you can assign permissions. See also Permissions.

SHIFT-click: See Multiple select actions.
SoDA: Rational’s Software Documentation Automation tool.

sorting: The process of establishing a specific order for the information in a RequisitePro View. You can
sort requirements using one or many requirement attributes. For example, you might sort requirements
first by priority (high, medium, or low). Then, within priority, you might sub-sort by unique ID number.
See also Filtering, Query.

~sr file: A text file created for each user who accesses a project. When a project is opened, a file will be
written to the project directory with a unique system-generated file name and an extension of *.~sr. This
file simply records the user ID, the type of access the user has to the project, and a session ID. The
exclusive lock file name will always be exclusive.~sr. All other file names will begin with a prefix that
indicates the type of project access reflected by the user in the project: RO indicates “read only” access,
and RW indicates “read/write” access.

suspect relationship state: A state applied to a traceability or hierarchical relationship when a change
occurs to one or both of the requirements in the relationship. A suspect relationship state indicates that,
because of the modification to one or both requirements, the relationship may need modification as well.
When suspect relationships are displayed in an Attribute Matrix, an (s) appears after the requirement tag
in the Traced-to or Traced-from column. See also Change-managed relationship, Traceability Matrix.

system analyst: An individual who leads and coordinates requirements elicitation and use-case
modeling by outlining the system’s functionality and delimiting the system.

tag: See Requirement tag.

tag prefix: The prefix for a requirement type. The prefix can be up to 20 characters. A tag is a unique
identifier assigned to each requirement you create. The tag prefix is defined as a part of the requirement

type.
template: See .dot file (Word template) or Project template.
TestManager: See Rational TestManager.
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text: See Requirement text.

tip revision: The current version of a project. If a project is not open, a tip revision is the most recent
version of the project.

Tool Palette: The main interface for accessing and working with RequisitePro projects. Tool Palette
buttons provide quick access to project information, requirements information, and views. You also use
the Tool Palette menu commands to perform requirements management operations in a RequisitePro
project.

trace to/trace from relationship: A relationship between two requirements that implies the source,
derivation, or dependencies between the requirements. The trace to/trace from state appears in a
Traceability Matrix or Traceability Tree when you create a relationship between two requirements.

For example, you might create a feature requirement (Requirement A) that calls for a new command to
be added to a particular menu in your application. Creating this requirement might cause you to create a
use-case requirement (Requirement B) associated with that menu item. You would thus create a
traceability relationship in which the use-case requirement (B) is traced from the feature requirement
(A). There can only be one traceability relationship between any two requirements. In RequisitePro, the
terms trace to/trace from relationship and traceability relationship are used interchangeably.

traceability: A relationship between two requirements that implies the source, derivation, or
dependencies between the requirements using the “trace to” and “trace from” features.

Traceability Matrix: A view that illustrates the relationships between requirements of the same or
different types. You use this matrix to create, modify, and delete traceability relationships and view
indirect relationships and traceability relationships with a suspect state. You can also use the Traceability
Matrix to filter and sort the row requirements and column requirements separately. See also View.

traceability relationship: See Trace to/trace from relationship.

Traceability Tree: A view that displays all internal and external requirements traced to or from a
requirement (depending on the direction of the tree). The traceability tree only displays the first level
cross-project traceability. For example, if an internal requirement is traced to an external requirement,
the external requirement displays in the traceability tree, but other requirements that the external
requirement is traced to do not displayed in the tree. Also referred to as a Tree view. See also View.

tree view: See Traceability Tree.
type: See Requirement type.

Unified Change Management (UCM): Rational's out-of-the-box usage model for managing change in
software system development, from requirements to release. UCM is a unified approach to configuration
management and change request management, automated in Rational ClearCase and Rational
ClearQuest. ClearCase can be set up to implement the UCM model for basic activity-based configuration
management or in conjunction with ClearQuest to provide full change-request management. To
implement the UCM model when creating a baseline of a Rational RequisitePro project, the project must
be associated with a UCM-enabled Rational project in the Rational Administrator.

use case: A sequence of actions that a system performs, yielding an observable result of value (a work
output) to a particular actor (someone or something outside the system that interacts with the system).

user: See Licensed user.

user information: A RequisitePro user’s user name, password, and e-mail address. If you are a member
of a group with project security permissions, you can edit another user’s information. In addition, a user
can edit his or her own user information.
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users group: A security group that can, by default, read documents and requirements, create views, and
participate in discussions. Administrators can modify Users group permissions.

version information: Unique, identifying information associated with a project, document, or
requirement each time it is modified. The internally generated revision number, combined with
information about the author, date, time, and reason for modification, constitute version information.
See also Revision.

view: A window in the Views Workplace that displays requirements, the attributes assigned to
requirements, and the relationships between requirements. A view displays information in
spreadsheet-like tables or in outline trees. In RequisitePro, the terms view and view window are used
interchangeably. See also Attribute Matrix, Traceability Matrix, Traceability Tree.

Views Workplace: An area of Rational RequisitePro where you create, analyze, and print requirements
information. The workplace displays and manages three types of views: an Attribute Matrix, a
Traceability Matrix, and a Traceability Tree.

Web: See RequisiteWeb.

wildcard character: A keyboard character that can be used to represent one or many characters.
Typically the asterisk (*) represents one or more characters and the underscore (_) represents a single
character. For example, the file specification *.* (pronounced star-dot-star) uses the asterisk wildcard to
mean “any combination of file name and extension.” When filtering the subject of discussions, the
percent symbol (%) is the wildcard character used to represent one or more characters.

Word application: Microsoft Word. The word processor used to author requirement documents and edit
requirements in RequisitePro documents. The integrated implementation of Word in RequisitePro is
referred to as the Word Workplace.

Word document: A document created in Microsoft Word or RequisitePro that is saved in Word format.
See also RequisitePro document.

Word Template: See .dot file.

Word Workplace: A Microsoft Word window within RequisitePro where you view, create, and modify
documents. RequisitePro uses the Word functionality to provide powerful features for viewing, editing,
and formatting documents. You can open several documents at a time, apply character styles, and insert
objects into your documents. The Word Workplace includes a RequisitePro menu for managing
RequisitePro requirements and documents from within Word. Also referred to as Word window.
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A

Add Attribute 229
adding

discussions 76

document types 230

projects to the project list 33

requirement attributes 239

requirement types 235

users to a security group 194
adjusting

column width in views 57

row height in views 56
administrators group 192
alphabetizing discussions 85
annotating change 130
answering discussions 80
application programming interface 70
Archive command 213
archived projects, retrieving 214
archiving

Oracle projects 216

projects 212, 215, 252

using ClearCase 215, 252
using the Archive command 213

restoring projects 219

SQL Server projects 216

using ClearCase 252

using Rational ClearCase 217

using RequisitePro Archive command 216
arranging

icons 59

views 57
assigning

attribute permissions 201

attribute value permissions 203

document type permissions 199

group permissions 197

new parents to a single requirement 147

new parents to multiple requirements 148

new parents to requirements 146

requirement type permissions 200

associating requirements with new types 132
Attribute Matrix 23, 44, 62

attribute labels 45

definition 23, 41

denotation of suspect traceability 43, 45
displaying properties 59
exporting as a CSV file 178, 179
graphics and OLE objects 45
keyboard shortcuts 277

mouse actions 276

querying in 62

requirements 44

shortcuts 276

sort ascending and descending 64
text panes 45

Word-linked files 45

attribute pane 49
attribute values

deleting 243
modifying 130, 242

attributes, see requirement attributes
auto suspect

and hierarchical relationships 151
and spell check 151
and spelling checker 160

backing up projects

Oracle 216
SQL Server 216

backups

creating using the Archive command 213
storing 212

baseline

creating a RequisitePro project from 20, 188
RequisitePro projects 221
with Unified Change Management 212

bookmarks 166
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removing 166
saving 166
building queries 63

C

canceling security 192
cascade view 57
causes of project failure 1
cells 45, 46
change affects suspect (option) 242
change history 12, 24
change management 18
change-managed relationships 26, 27
changing, see modifying
checking
whether a document is offline 107
child requirements 143
ClearCase
archiving projects using 215, 252
integrations with RequisitePro 251
setting configurations for using 215
using to archive projects 252
clearing
suspect relationships 152
suspect traceability 161
ClearQuest
associating a requirement 250
using with RequisitePro 249
closing
discussions 92
documents 98
nonproject documents 102, 103
RequisitePro 32
views 53
collapse all 50
collapsing 50
column width in views 57
COM Server 70

comma separated value (CSV) file, see also CSV

files 55
Composite Template 182
configuring

ClearCase 215
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RequisitePro 289
connecting projects for cross-project
traceability 245
converting earlier versions of projects 190
copying
projects 223
requirements 135
corrupted document, fixing 100
Create RequisitePro Project dialog box 181
creating
backups using the Archive command 213
cascade view 57
discussions 76
discussions within the Requirement Proper-
ties dialog box 91
document types 230
documents 93
menu files 292
MS Project tasks from requirements 259
multiple requirements in a document 120
outlines 234
outlines in secondary directory 234
projects 181
Create RequsitePro dialog box 228
with project wizard 187, 220
queries 63
requirement attributes 239
requirement information in a discussion 89
requirement types 235
requirements
in an Attribute Matrix 126
in a document 117
in a Traceability Matrix 126
in a Traceability Tree 126
inaview 125
including nontextual elements 118
in offline documents 108
troubleshooting 269
using fast create 119
RequisitePro projects 181, 185
RequisitePro projects from a baseline 188
security groups 193
tile view 58
traceability
in Attribute Matrix 155
in requirements document 153



in Traceability Matrix 157
in Traceability Tree 158
in Views Workplace 155
in Word Workplace 153
views 49, 50
cross-functional teams 9
cross-project traceability 244
across database types 62
across enterprise databases 184
and auto suspect 160
connecting projects 245
disconnecting projects 247
displaying 69
displaying in exported views 70
marking requirement types 244
overview 244
querying requirements 61
results 69
reviewing project 69
views 69
CSV files
copying header 175
defining header 174
definition 173
exporting views as 179
importing 163, 172, 175
requirements in exported files 70
customizing
menus 291
RequisitePro 289
Tool Palette menus 291
views 56
cutting requirements 135

D

Data Transport Wizard 224, 225
data types for requirement attributes 241
database 20

Microsoft Access 20, 183

moving 224

Oracle 183, 224

searching 65

selecting 183

SQL Server 183, 224

troubleshooting 270
database conversion. See moving 227
database corruption 270
default view properties 60
deleted users group 192
deleting

projects from the project list 35
deleting, see also removing

attributes for MSPT requirement types 266

discussions 92

hierarchical requirements 149

queries 65

requirements 141

security groups 194

users from a security group 195

views 55
dialog box shortcuts 275
directories

outlines 234

setting for ClearCase 215
disabling security 192
disconnecting projects from external

traceability 247

discussion groups 73
discussion items 73
discussions 73— 92

attributes 86

closing 92

configuring e-mail for 73

creating 76

creating requirement information for 89

deleting 92
displaying 82
filtering 84
icon 73, 78
locating 82
modifying 86

modifying requirement information in 89

notifying participants about 78
ordering 85

participants 73

participants information 87
printing 86

properties 78

reading 79
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responding to 73, 80
in RequisitePro 80
using e-mail 81
setting up projects for 73
sorting 85
viewing 73, 79, 84, 85
displaying, see also viewing
cross-project traceability 69
discussions 82
suspect traceability 160
view properties 59
document not found message 271
document outline 290
document types 24
adding 230
compared to requirement types 24
creating 230
definition 24, 230
display 36
editing 233
permissions 199
removing 233
documents 93— 113
changing location 99, 102, 103
closing 98
closing Microsoft Word 102
closing nonproject documents 102, 103
creating 93
definition 24
determining whether offline 106
importing from Microsoft Word 167
locking 101
Microsoft Word 101, 102
modifying information 100
offline 105, 106
opening 35, 38, 96
outlines 25
protecting 101
recovering an AutoRecover document 272
refreshing requirement color and style 138
reviewing changes 98
saving 94, 98
searching 67
storage 181
taking offline 105
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unlocking 101
.dot files 232
drag and drop to create traceability
relationships 158
duplicating views 54

E

editing
document types 233
.dot files 232
outlines 232
e-mail
changing 40
configuring for discussions 73
entering addresses in project security 74
modifying 40
notifying participants about discussions 78
Rational E-mail Reader 75
receiving notification of discussions 39
responding to discussions using 81
Embedded Elements Detection Wizard 116, 117
enabling security 192
ending discussions 92
enterprise databases 20
enterprise databases. See also SQL Server, Oracle
distributing projects across types 184
equations
inserting in requirement text 123
Excel 163
importing CSV files 172
exclusive access 36
exiting, see closing 32
expand all 50
expanding 50
exporting 178
cross-project traceability 70
CSV files 179
requirements as Word document 180
extended editing 116, 131

F

failed multiple select actions 159, 271



file types 228 using to import CSV files 175

filter import wizard
creating 209 using to import Word files 167
requirements 61 importing

filtering converting documents to Word 164
discussions 84 converting individual documents to
requirements 62 Word 165

filtering and sorting 61 creating a log file 163
see also querying, queries CSV files 172, 175

Find Requirement command 65, 67 copying CSV file header 175

finding define new requirements option 177
discussions in projects 82 defining CSV file header 174

FURPS model 115 preparing files 173

requirement numbers 173
update attributes of existing requirements

G option 178
from Access 163

General Protection Faults 272 from Excel 163

Getting Started xvii from Oracle 163

Go To command 65, 68 from SQL Server 163

from Word 167
Microsoft Word documents and
H requirements 167
document only option 172

hierarchical relationships 26, 43, 143 requirements and document option 168

creating child requirements 143 requirements only import option 171
inaview 143 requirements and document 168
in documents 144 RequisitePro documents 164

creating peer requirements 145
deleting 149
exporting 179

saving and removing bookmarks 166
Word document to a RequisitePro

roject 167
parent requirements 146 P

hierarchy 143—152

Word documents
requirements and document import

option 168
inserting Microsoft Word-linked files in
I requirements 122
icons, arranging 59 .Integratfed Use Case Management 252
integrations

image backups 219
with Rational ClearQuest 249

with Microsoft Project 256

with Rational ClearCase 215, 251, 252
with Rational Robot 256

with Rational Rose 252

import logs 163
Import Wizard
importing
requirements from a Word document to a
RequisitePro document 167

using to export requirements 178 with Rational SoDA 206, 255
exporting as a Word document 180 with Rational Suite AnalystStudio 252
exporting CSV files 179 with Rational Synchronizer 255
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with Rational TestManager 256

with Unified Change Management 251
invalid date/time errors 274
in-view editing 116, 126

K

key words 120
keyboard shortcuts 275

L

Let’s Go RequisitePro xvi

linked files, inserting in requirements 122
locating, see also finding

locking project documents 101

log file 163

logging into RequisitePro 38

logical backups 217

macros, making available when taking docu-
ments offline 107
managing
change 18
changing requirements 8
external Word documents 104
Microsoft Word documents 102
projects 205
requirements xvii, 1, 3, 13, 17
master documents 112
menu shortcuts 275
menus
creating menu files 292
customizing 291
metrics 71, 206
information types 207
running from the command line 212
Microsoft Access 20, 163, 183
importing CSV files 172
Microsoft equations
inserting in requirement text 123
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Microsoft Project 256
Microsoft Word

bookmarks 107

closing 102

converting all documents when
importing 164

converting individual documents when
importing 165

creating a Word document from a Requi-
sitePro requirements document 104

editing a requirements document outside of
RequisitePro 104

enabling macros 110

exporting a view 180

hidden text 107, 116

improving Word performance 103

managing external Word documents 104

master documents 112

requirements in exported files 70

tips for using in RequisitePro 103, 135, 137

troubleshooting 271

unavailable Word commands 105

using to modify offline documents 107

using Word options for "hidden"
requirements 104

working with documents 101

working with Word styles 104

Microsoft Word-linked files 116

saving requirements documents 95
traceability 124

Microsoft Word-linked files, inserting in a

requirement 122

modifying

attribute values 130
discussion attributes 86
discussion participants 87
discussion properties 78
discussions within the Requirement Proper-
ties dialog box 91
document information 100
e-mail 40
location of documents 99
offline documents 107
parent requirements 146
passwords 39



project information 229 renaming 105

queries 64 saving offline changes 108
requirement information in a discussion 89 taking documents offline 105
requirements 130 and unsaved changes 110
user name 39 Word master documents 112

mouse actions 275 offline image backup 219

moving OLE objects 45, 47, 49, 116, 138, 141
documents 99 online image backup 219
projects 223 open database connectivity technology 224
projects to a SQL Server database 227 opening
projects to an Oracle database 226 documents 35, 38, 96
requirements 134, 137 projects 35, 38
requirements to a new document 100 in earlier versions of RequisitePro 96
text to a new document 100 exclusive access 36
users to another security group 196 read-only mode 36

MSPT 258 views 53
deleting attributes 266 Oracle 20, 163, 183, 225

archiving projects 216
configuring 183

N and cross-project traceability 62
importing CSV files 172
navigating moving projects 224
in a Traceability Matrix 280, 281 and multiple projects 20
in a Traceablity Tree 284 tips when using 184
in an Attribute Matrix 276, 277 Oracle database, converting to 226
to a requirement 65 ordering discussions 85
in views 42 outlines 232, 234, 290

assigning to document types 233
creating 234
o creating secondary location 234
editing 232

offline authoring 105
using RequisitePro 233

bringing documents back online 108, 110

creating requirements in offline
documents 108

deleting requirements in offline

P

documents 108 parent, changing 146
determining whether a document is parent-child relationships 26, 43
offline 107 see also hierarchical relationships 26
making available Word macros when parsing, definition 170
using 107 participants
modifying offline documents 107 notifying about discussions 78
obtaining information about offline responding to discussions 80
documents 107 passwords
overview 105 changing 39
reading offline documents 111 editing 195
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limitations 195
modifying 39
new 195
peer requirements 145
Performance Studio 256
permissions
attribute permissions 201
attribute values 203
document type 199
group 197
requirement text 201
requirement type 200
printing
discussions 86
project summaries 206
reports 206
views 54
problem analysis 5
project
database 20
failure 1
file types 228
modifying 164
security 164
project access 36
Project Administration Tips xvii
project administrators xvi
Project Conversion Wizard 190
project information, modifying 229
project list 20
adding projects 33
removing projects 35
project management 205
project scope management 7
project security
adding users to a group 194
administrators group 192
assigning permissions 197
creating groups 193
deleted users group 192
deleting groups 194
deleting users from a group 195
editing passwords 195
editing user name 195
entering e-mail addresses 74
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groups and users 192
moving users 196
permissions 197
users group 192
project summaries, printing 206
project template 182, 291
creating 187
using to create a project 228
project version control 20
project wizard 187, 220
projects 19
adding to the project list 33
archiving 212, 215, 252
connecting for cross-project traceability 245
converting earlier versions 190
copying 223
creating 181, 185, 228
with project wizard 187, 220
creating a baseline 221
creating from a baseline 188
cross-project traceability 69
definition 19
disconnecting from external traceability 247
discussion 73
groups and users 192
list 20
locating discussions in 82
managing 205
modifying information 229
moving 223
opening 35, 38
overview 181
relocating 248
removing from the project list 35
revision information 220
security 191
storing backup copies 212
upgrading 190
properties for views 59
protecting documents for revisions 101

Q

queried views 61



queries 45
building 63
creating 63, 209
deleting 65
modifying 64
query now 42
refresh all 42
saved in views 51
traced to/traced from 62
updating 61
query
adding to report 210
Query command 62
query now 42
query, definition 61
querying 61—71
advanced 70
criteria 61
and cross-project traceability
relationships 61
traced to/traced from 62

R

Rational xvii
Rational Administrator 250, 252
creating a baseline 221
creating a RequisitePro project from a
baseline 189
Rational Administrator New Project Wizard 189
Rational ClearCase 215, 251, 252
using to archive projects 252
Rational ClearQuest 249
associating a requirement 250
Rational RequisitePro Tutorial xvii
Rational Robot 256
Rational Rose 252
Rational Rose integrations 252
Rational SoDA 206, 255
Rational Suite 249
Rational Suite Performance Studio 256
Rational Suite TestStudio 256
Rational Synchronizer 255
Rational Team Unifying Platform 249

Rational TeamTest 256
Rational technical support xix
Rational Unified Change Management 251
Rational Unified Process 256
Rational University xvii
reading

discussions 79

offline documents 111
read-only documents 111
rebuilding damaged tags 139
recommended reading 14
recovering an AutoRecover document 272
references 14
refining the system definition 7
refresh all 42
Refresh command 62
relationship

suspect 43, 45, 47

traced to/traced from 28
deleting, see also removing

requirements

in offline documents 108

removing

bookmarks 166
removing, see also deleting 35

attribute values 243

bookmarks 166

document types 233

documents 222

queries 65

requirement types 238

requirements 222
renaming views 54
renumbering requirements 139, 205
reparenting 146
replying to discussions 80
report

opening and editing 211

printing 206

running 211

saving 211
requirement

categories 115
requirement attributes 25

adding 239
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creating 239
data types 241
deleting for MSPT types 266
modifying values 130
multidimensional 11
permissions 201
removing values 243
viewing in an Attribute Matrix 45
Requirement commands to create traceability
relationships 159
requirement atttributes
and scope management 7
Requirement Metrics 71, 206
creating filter 209
Query pane 208
Report pane 209
running from the command line 212
requirement name 117
Requirement Name Conversion Wizard 132
requirement tags
rebuilding 139
viewing in an Attribute Matrix 44
requirement types 9, 25
adding 235
compared to document types 24
creating 235
definition 25, 235
marking for cross-project traceability 244
MSPT 258
new 132
overview 1
permissions 200
removing 238
requirements 19, 115—142
assigning new parents 146
to a single requirement 147
to multiple requirements 148
associating with ClearQuest records 250
associating with new types 132
multiple requirements 133
single requirements 133
attribute values 117
can’t create 125
change history 12
changing 8
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changing parents 146
color, refreshing 141
copying 135
copying from view 136
creating
in an Attribute Matrix 126
child requirements 143
in a document 117
in a Traceability Matrix 126
in a Traceability Tree 126
inaview 125
including nontextual elements 118
multiple 120
in offline documents 108
peer requirements 145
troubleshooting 269
using fast create 119
with Microsoft Word-linked files 122
creating from Traceability Tree and Traceabil-
ity Matrix views 116
cutting 135
cutting from view 136
definition 2, 19, 115
deleting 141
deleting in offline documents 108
description 117
discussion information 91
document types 20
exporting 178, 180
extended editing 117
fast create 119
filter 61
filtering and sorting 61
Find Requirement command 67
finding 65
goto 68
hidden text 116
hierarchical relationships 143
importing 167
inserting equations in Word-linked files 123
key words 120
locating discussions associated with 82
modifying information 130
moving 134, 137
moving to a new document 100
navigating to 65



numbering when imported 173
numbers 173

parent-child relationships 143
querying 61

rebuilding tags 139

recording changes 130
refreshing color and style 141

refreshing color and style in a document 138

renumbering 139, 205
restrictions on editing 118
revising properties 128
revision information 129
searching for 65

sorting 62

style, refreshing 141

suspect relationships 160

tag 116

text delimiters 120
traceability relationships 153—?7
troubleshooting 125
unmarking in a document 141
Word style 120

requirements and document import option 168

requirements authors xvi
requirements contributors xvi
requirements documents, see documents
requirements management 1, 13, 17
activities that promote success 14
and changing requirements 8
definition 3
fundamentals 1—14

Managing Software Requirements book xvii

and problem analysis 5

problems of 3

and project scope 7

refining system definition 7

skills 5—8

and stakeholder needs 5

system definition 6

and use cases 1
Requirements Management Tour xvii
Requirements menu 155
Requirements Metrics

creating queries 209
requirements only import option 171

requirements viewers xvi
RequisitePro
and change management 18
improving Word performance 103
incorrect appearance of menu 273
and Microsoft Word 101
process support 19
and team collaboration 17
RequisitePro Extensibility Interface 70
RequisiteWeb 18, 116
resizing
tree pane 48
views 57
responding to discussions 80
using e-mail 81
using RequisitePro 80
restoring projects from an archive 219
retrieving archived projects 214
reviewing changes in a document 98
revising requirement properties 128
revision information 220
revisions, protect for 101
Robot 256
Rose integrations 252
Rose use case
associated with a document or
requirement 253
associating documents with 254
row height in views 56

S

saving
bookmarks 166
documents 94, 98
documents without the bookmarks 96
queries in views 51
requirements document as Word file 101
view properties 60
views 51
searching
active view 67
database 65
documents 67
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Find Requirement command 67
for requirements 65
Go To command 65
views 67
security 191
disabling 192
enabling 192
groups and users 192
security groups
adding users 194
creating 193
deleting 194
deleting users 195
moving users 196
selecting
items in a Traceability Matrix 280
items in a Traceability Tree 284
items in an Attribute Matrix 276
selecting multiple items 275
shortcuts 275
dialog box 275
in a Traceability Matrix 280
in a Traceability Tree 284
in an Attribute Matrix 276
menu 275
in views 42
SoDA 206, 255
sort ascending 64
sort descending 64
sorting
definition 61
discussions 85
requirements 62
sort order 64
sorting and filtering 61
see also querying, queries
spelling checker
without auto suspect 160
SQL Server 20, 163, 183, 225
archiving projects 216
configuring 183
and cross-project traceability 62
importing CSV files 172
moving projects 224, 227
and multiple projects 20
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tips when using 184
troubleshooting syntax errors 274
SQL Server database
converting to 227
stakeholder needs 5
starting RequisitePro 31
Suite products 249

suspect relationships 29, 46, 48, 49, 160

change affects suspect option 242
clearing 152, 161
definition 143, 153

denotation in Attribute Matrix 43, 45

displaying 154, 160
traceability changes 27
system definition 6

T

tags, rebuilding 139

TeamTest 256

technical support xix

template
creating a project template 187
using to create a project 228

templates
benefits of using 25
Composite Template 182
project 25, 182, 291
Traditional Template 182
Use Case Template 182

terminating discussions 92

terms 297

TestStudio 256

text delimiters 120

text pane 49

tile view 58

time controls, setting 210

Tool Palette 21, 31
customizing menus 291
Discussions icon 73, 78
menus 291

ToolTip 21, 31

traceability 10, 27, 43, 153—161
and Microsoft equations 123



changes to linked files 124
clearing suspect relationships 161
creating
in Attribute Matrix 155
in requirements document 153
in Traceability Matrix 157
in Traceability Tree 158
using requirements menu 155
in Views Workplace 155
in Word Workplace 153
cross-project 244
direct and indirect 28
direction of 48
in MS Project 260
overview 153
suspect relationships 27, 160
Traceability Matrix 23, 45, 62
cells 46
definition 23, 41
direct and indirect relationships in 45
displaying properties 60
exporting as a CSV file 178, 179
graphics and OLE objects 47
keyboard shortcuts 281
mouse actions 280
navigating in 280
querying in 62
suspect relationships 45
text panes 46
tracing to/tracing from relationships 45
traceability relationships
using drag and drop to create 158
using Requirement commands to create 159
Traceability Tree 23, 47, 63
attribute pane 49
definition 23, 41
displaying properties 59
exporting as a CSV file 178, 179
graphics and OLE objects 49
mouse actions 284
querying in 63
text pane 49
traced from 28, 43, 45, 62
traced to 28, 43, 45, 62
track changes 101

Traditional Template 182

training xvii

tree pane 48

troubleshooting
creating requirements 269
database corruption 270
document not found message 271
failed multiple select actions 159, 271
General Protection Faults in Page View

mode 272

invalid date/time errors 274
Microsoft Word files are too big 271
recovering an AutoRecover document 272
RequisitePro menu appears incorrectly 273
SQL Server syntax errors 274
when creating requirements 125

tutorial xvii

U

Unified Change Management 20, 188, 221, 251
baselining projects 212
Universal Naming Convention 94
Universal Naming Convention paths 181
unlocking project documents 101
unmarking
requirements in a document 141
unmarking requirements 141
upgrading a RequisitePro project 190
Use Case Management, Integrated 252
Use Case Template 182
use cases and requirements management 1
user name
changing 39
editing 195
modifying 39
restrictions 194
users group 192
using Word options for "hidden"
requirements 104

Vv

values, attribute
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deleting 243
modifying 242
view
copying requirements in 136
cutting requirements in 136
view properties
displaying 59
saving as default 60
viewing, see also displaying
discussion attributes 86
discussion participants 87
discussion properties 78
discussions 73, 79, 84, 85
offline documents 111
views 41-60
adjusting column width 57
adjusting row height 56
arranging 57
arranging icons 59
cascade 57
closing 53
collapse all 50
creating 49, 50
cross-project traceability 69
customizing 56
definitions 41
deleting 55
displaying properties 59
duplicating 54
expand all 50
exported 70
exporting as Word document 180
exporting to a CSV file 55
navigating 42
opening 53
printing 54
properties command 59
query now 42
refresh all 42
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renaming 54
resizing 57
saving 51
saving queries in 51
searching 67
tile 58

Views Workplace 21, 23, 41
Attribute Matrix 23
navigating in 42
Traceability Matrix 23
Traceability Tree 23
viewing hierarchy in 43

w

Web 18

wizards
Data Transport Wizard 224, 225
Database Upgrade Wizard 190

Embedded Elements Detection Wizard 116,

117
Import Wizard 163
Rational Administrator New Project
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