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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
1
 Installing ClearQuest
This chapter describes how to install ClearQuest. You, the ClearQuest 
administrator, set up the databases to use with ClearQuest, install 
ClearQuest, and provide the required setup information to each client user. 
You (or your client users) can then install ClearQuest on the client machines. 

It’s important that you review all the necessary steps before beginning.

This chapter covers the following topics:

■ “Before you begin” on page 8

■ “Understanding the install process” on page 9
7



Before you begin

Before you install ClearQuest, read the following:

■ Rational ClearQuest Release Notes: An HTML file that contains the most 
current system requirements information (including platform version 
support).

■ For Windows: <d>:\ClearQuest\readme.htm (where <d> is your CD-ROM 
drive

■ For Unix: <d>:/products/ClearQuestClient/readme.htm (where <d> is your 
CD-ROM drive

■ Introducing Rational ClearQuest: An overview of ClearQuest components 
and how to use them.

■ Administering Rational ClearQuest: A guide on how to customize 
ClearQuest to meet your needs.

Note: If you are using Rational ClearQuest/TeamTest Edition, see the 
Getting Started with Rational ClearQuest TeamTest Guide This guide is 
available as a Portable Document Format (PDF) file in the 
\\ClearQuest\books directory.
8  Installing Rational ClearQuest
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Understanding the install process

You, the ClearQuest administrator, install ClearQuest by performing the 
following steps:

1 Set up your database product. As the ClearQuest administrator, you are 
responsible for setting up the databases your users will use with ClearQuest. 
See “Configuring vendor databases” on page 11.

2 Install ClearQuest on the administrator’s workstation and create the 
ClearQuest databases. See “Installing ClearQuest for an administrator” 
page 37.

An administrative installation of ClearQuest involves the following steps

■ “Installing ClearQuest for an administrator” on page 38

■ “Creating ClearQuest databases” on page 39

■ “Setting up configuration management integrations” on page 44

■ “Setting up record submission via e-mail” on page 48

■ “Installing Crystal Reports” on page 49

3 Set up your license server. See “Licensing ClearQuest” on page 111.

4 Optionally, customize your installation. See the Administering Rational 
ClearQuest guide for details on customizing ClearQuest.

5 Install ClearQuest on the client machines and provide users with the 
information they need to connect to ClearQuest. See “Installing ClearQu
Windows for end-users” on page 51 and “Installing ClearQuest Unix for 
end-users” on page 55.

6 If you are installing ClearQuest Web, see “Setting Up ClearQuest Web” 
page 63.
Installing ClearQuest  9
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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
2
 Configuring vendor databases
Before you install Rational ClearQuest, you install and configure the vendor 
databases that you will use with ClearQuest. 

ClearQuest requires at least two databases:

■ A schema repository: This is the master database where ClearQuest stores 
schemas.

■ A user database: This is where data entered by ClearQuest client and web 
users is stored. You can have as many user databases as you need. 

This chapter covers the following topics:

■ “Choosing a database vendor” on page 12

■ “Setting up Microsoft Access” on page 13

■ “Setting up SQL Anywhere” on page 14

■ “Setting up Microsoft SQL Server Version 6.5” on page 19

■ “Setting up Microsoft SQL Server 7 and 2000” on page 24

■ “Setting up the Oracle Server” on page 28

■ “Setting up IBM DB2 6.1” on page 35
11



Choosing a database vendor

ClearQuest supports the following databases:

■ Entry-level database: Microsoft Access (supplied with ClearQuest)

■ Mid-level database: Sybase SQL Anywhere (supplied with ClearQuest)

■ High-end databases: Microsoft SQL Server and Oracle (NT and Unix)

For specific supported versions, see ClearQuest Release Notes:

■ For Windows: <d>:\ClearQuest\readme.htm (where <d> is your 
CD-ROM drive

■ For Unix: <d>:/products/ClearQuestClient/readme.htm 
(where <d> is your CD-ROM drive

Note: If your ClearQuest installation will include ClearQuest Unix clients, 
your vendor database must be Oracle and it must be installed on a Unix 
server.

To decide which database vendor is best for your needs, determine how 
many simultaneous users you expect to have. Use the following general 
guidelines:

■ For initial testing and evaluation or for small groups (fewer than five 
users), you can use the entry-level database. 

■ For small- to medium-size groups (five to twenty users), you can use the 
mid-level database.

■ For larger groups (over twenty users), large amounts of data, or to achieve 
better performance, use one of the high-end databases.

Note: You can use more than one database vendor for ClearQuest 
databases. For example, you might want to use high-end databases for your 
schema repository and user databases, then use an entry- or mid-level 
database for your test database.
12  Installing Rational ClearQuest



Setting up Microsoft Access

Note: ClearQuest Web does not support Microsoft Access databases.

If you are using ClearQuest with Microsoft Access, 

1 Create one shared directory on the machine for the directory that will contain 
your Microsoft Access databases. 

2 Make a note of the UNC path of the share directory. The path should be of 
the form: 

\\<machine_name>\<share_name>\<database_directory>\

For example: 

\\developmentserver\project34share\clearquestdbs\

The first time you run the ClearQuest, you are asked to create a schema 
repository. You will specify this pathname and provide a filename for the 
schema repository. ClearQuest then creates and initializes the appropriate 
Access databases in this directory.

Now that you have set up the Access databases, proceed to “Installing 
ClearQuest for an administrator” on page 37. 
Configuring vendor databases  13
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Setting up SQL Anywhere

To create an SQL Anywhere database server, complete the following tasks:

■ Install the Sybase SQL Anywhere Server software. (Note: SQL Anywhere 
is available on the ClearQuest CD and can be installed using the Rational 
Software Setup wizard).

■ Choose or create a user account to run the SQL Anywhere database server 
and set user privileges for that account. 
See Defining user privileges below.

■ Create an SQL Anywhere database server. See “Creating an SQL 
Anywhere database server” on page 16.

Defining user privileges

To define privileges for a user account running an SQL Anywhere datab
server: 

1 Make sure you have installed the Sybase SQL Anywhere Server softwa

2 Do one of the following:
■ If your Windows NT computer is running Windows NT Workstation 

software, click Start > Programs > Administrative Tools 
(Common) > User Manager.

■ If your Windows NT computer is running Windows NT Server software

■ Click Start > Programs > Administrative Tools (Common) > 
User Manager for Domains. 

■ Click User > Select Domain and type the local machine name in th
Domain box, and then click OK.

Note: If the user does not already exist, create the user (User > New 
User).

3 Click Policies > User Rights to open the User Rights Policy dialog box.

4 Select Show Advanced User Rights.

5 In the Right list box of the User Rights Policy dialog box, select Access 
this computer from network. 
14  Installing Rational ClearQuest



6 Click Add.

7 For List Names From, select the domain of the account running the SQL 
Anywhere database server.

8 Click Show Users. 

9 In the Names list, select the account running the SQL Anywhere database 
server.

10 Click Add, and then click OK.

11 In the Right list box of the User Rights Policy dialog box, select 
Log on as a service.

12 Repeat Steps 6 through 10.

13 In the Right list box of the User Rights Policy dialog box, select 
Log on locally

14 Repeat Steps 6 through 10.

15 Click OK. 

16 Click User > Exit. 
Configuring vendor databases  15



Creating an SQL Anywhere database server

An SQL Anywhere database server is a process that runs on the database 
server machine. Its function is to coordinate all activity against your SQL 
Anywhere databases. You create one SQL Anywhere server to provide 
access to all of your database files. 

Follow these steps to use the Rational Administrator to create a new server:

1 From the Start menu, click Sybase SQL Anywhere Database Server > 
Rational Administrator.

2 Click File > New SQL Anywhere Database Server.

3 Type a unique alphanumeric string of up to 30 characters that identifies this 
database server on the network, and then click Next. 

Important: Do not use spaces or special characters in the server name 
(underscores are acceptable).

4 Type the amount of space to use for caching data for the SQL Anywhere 
database server, and then click Next. Allow 2048 KB for each Rational 
repository on the server.

5 Select one or more protocols to communicate with the SQL Anywhere 
database server, and then click Next.

Note: To reduce connection time, select only those protocols that are 
actually used on your network.

6 Select the Startup options, as described in the following steps.

a Select one of the following Windows NT Service Startup options. These 
options start the SQL Anywhere database server when you power on your 
system: 

■ Click Automatic to automatically start the SQL Anywhere database 
server when you start your system.

■ Click Manual if you do not want the SQL Anywhere database server to 
automatically start when you start your system. If you select this option 
you will have to manually start the database server after each time you 
reboot the server machine.
16  Installing Rational ClearQuest
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b Select or clear Start service immediately. This option starts the SQL 
Anywhere database server immediately after you create it. If the box is 
cleared, you will need to start the server manually after creating it. 

7 In the Account section, do the following.

a Click Other Account to allow users to access a shared ClearQuest 
database or shared repository. This option gives users the most flexibility 
for accessing a database or repository.

Note: Do not use System Account (LocalSystem) to run the service 
under a local account. Doing so prevents you from remotely configuring a 
ClearQuest database using UNC.

b Type a domain and user account name for the Other Account. This is the 
account you created and configured under “Defining user privileges” o
page 14. The name is case-sensitive. 

Enter the user account information as follows:

■ If you created a local machine account in Step 2 on page 14, enter t
domain and account name as: 

.\userid
■ If you created a domain account, enter the domain and account nam

domain\userid

c Type the password for the Other Account. The password is case-sens

8 Click Next.

The Rational Administrator displays a summary of your choices.

9 Click Finish.

10 After installing the SQL Anywhere software, create one shared directory
the machine for the directory that contains your SQL Anywhere databas
(To increase performance, keep your databases on the same machine a
database server.) 

11 Make a note of the UNC path of the share directory. The path should be
the form: 

\\<machine_name>\<share_name>\<database_directory>
Configuring vendor databases  17



For example: 

\\developmentserver\project34share\clearquestdbs

Now that you have set up your SQL Anywhere databases, proceed to 
“Installing ClearQuest for an administrator” on page 37. 
18  Installing Rational ClearQuest



Setting up Microsoft SQL Server Version 6.5

Install SQL Server 6.5 with SQL Server Service Pack 5a, if you have not 
already installed it.

Note: When you install SQL Server, select one of the following sort-order 
options: 

■ Dictionary order, case-sensitive

■ Dictionary order, case-insensitive 

If you change sort orders after installing SQL Server, you must rebuild the 
SQL databases and reload the data. 

Note: This will affect case-sensitivity of ClearQuest queries. If you want 
ClearQuest queries to be case-insensitive, set the order here.

Registering your SQL Server machine for SQL Server 6.5

Start SQL Server Enterprise Manager. If the SQL Server machine is not 
already registered, register it now.

1 Click Server > Register Server. 

2 Type the server name. 

Note: Make a note of the server name because you will need it during the 
ClearQuest installation. 

3 Click Use Standard Security. 

4 For Login ID, type SA, which is the System Administrator.

5 For Password, type your SA password. 

6 Click Register. 

The server should now appear in the list of servers. 

7 Set up the SQL Server databases as described in the next section.
Configuring vendor databases  19
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Setting up SQL Server 6.5 databases

You must set up one empty SQL Server 6.5 database for the ClearQuest 
schema repository, and one empty SQL Server 6.5 database for each 
ClearQuest Client user database (such as the optional SAMPL database). For 
each SQL Server 6.5 database, complete the following tasks:

■ Create an empty database

■ Create login accounts for the database

■ Set up a backup procedure for the database

To add more databases to ClearQuest, repeat the preceding tasks for each 
new database. 

Note: These instructions assume that you have a simple SQL Server 
configuration. If you have large databases or many users, consider setting up 
separate log devices or spreading data across multiple devices. For details, 
see your SQL Server documentation. 

Creating empty databases

Use the SQL Server Enterprise Manager to create an empty SQL Server 6.5 
database for the ClearQuest schema repository and for each ClearQuest 
client user database (such as the SAMPL database). 

Note: Your SQL Server databases must be in the same network domain as 
your ClearQuest Web server and any ClearQuest clients or tools that need to 
connect to the database. If it is not in the same domain, you will get an error. 
See the ClearQuest release notes for more details.Consult the Microsoft 
KnowledgeBase Article Q152828, 
http://premium.microsoft.com/support/kb/articles/q152/8/28.asp. 

For each SQL Server 6.5 database, do the following.

1 Create the data device. 

a Select your SQL Server machine. If your machine does not appear in the 
list of servers, you need to register it. See “Registering your SQL Serv
machine for SQL Server 6.5” on page 19.

b Click Manage > Database Devices.
20  Installing Rational ClearQuest



c Click the New Device icon.

d Type a name for the device, select a location, and type a size.

For the schema repository, allocate at least 50 MB. The device must be 
large enough to hold all the schema versions. You can adjust this size later, 
if necessary.

For the user database, allocate at least 15 MB for every 1,000 records you 
expect to generate. The exact amount of space required depends on the 
complexity of your schema.

e Click Create Now.

The new device should now appear in the list of devices.

f Close the Manage Database Devices window. 

2 Create the database.

a Click Manage > Databases.

b Click the New Database icon.

c Type a name for the database.

d For Data Device, select the device you just created. 

e Leave Log Devices as none.

f Click Create Now.

The new database should now appear in the list of databases.

3 Configure the database: 

a In the Manage Database window, double-click the database you just 
created. The Edit Database dialog box appears. 

b Click the Options tab. 

c Click Select Into/Bulk Copy and Truncate Log on Checkpoint.

d Click OK.

e Close the Manage Databases window.
Configuring vendor databases  21



Creating login accounts for each database

Use the SQL Server 6.5 Enterprise Manager to create login accounts for 
ClearQuest. ClearQuest uses these accounts to log into the SQL Server 
database program on behalf of ClearQuest users. These login accounts are 
separate from ClearQuest user logins and are hidden after the installation.

Note: When you create the ClearQuest schema repository, the ClearQuest 
Maintenance tool prompts you for the three logins listed below. If you do not 
want to create three separate login accounts, you can use the DBO login ID 
for all three. 

Create the following login accounts for each database using SQL Server 
authentication:
■ A database owner (DBO) login account

■ A general purpose login account

■ Another general purpose login account to be used by the schema 
repository. This third account will be used as a read-only account by 
ClearQuest.

Note: You will need to set up SQL Server to operate in Mixed Mode 
(Windows NT Authentication and SQL Server Authentication). This 
property can be set via Enterprise Manager, right-click on the server and 
select Properties menu, Security tab.

Follow these steps to create the login accounts:

1 Click Manage > Logins. 

2 Type a unique login name and password.

Note: Remember the names and passwords of each login account; you will 
need them during the ClearQuest installation. 

3 In the Permit column, click the database for which you are creating the 
login. A check mark should appear in the Permit column. 

4 If you are creating the database owner login, click the Alias column and 
select DBO. 

5 Click Add and confirm the password.
22  Installing Rational ClearQuest
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6 Repeat steps 2 through 5 for the other accounts.

7 Close the Manage Logins window.

Setting up database backup procedures 

The backup procedure described here provides a daily backup for the 
ClearQuest databases by overwriting the backup device each day. It assumes 
that your site also periodically backs up the backup device to recoverable 
media. 

Use the SQL Server Enterprise Manager to set up backup schedules for the 
schema repository and for the databases.

1 Click Tools > Database Backup/Restore.

2 On the Database Backup/Restore dialog box, click the Backup tab. 

3 From the Database Backup list, select the database you want to back up. 

4 From the Backup Devices list, select New. 

5 Type a name and select a location. We recommend that you put the backup 
device on a different disk than the database devices, and that this daily 
backup be backed up to tape by your site’s normal backup procedures. 

6 Select Disk Backup Device. 

7 Select Create.

8 Click Schedule. 

9 In the Backup Volume Labels dialog box, leave Volume level blank. 

10 In the Schedule Backup dialog box, select Recurring.

11 Click Change. 

12 For Daily Frequency, select 12 a.m. or another time of your choice.

13 Click OK to close the open dialog boxes.

14 Click Close to close the Database Backup/Restore dialog box. 

Now that you have set up your SQL Server databases, proceed to “Insta
ClearQuest for an administrator” on page 37. 
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Setting up Microsoft SQL Server 7 and 2000

You need to set up one empty SQL Server database for the ClearQuest 
schema repository, and one empty SQL Server database for each ClearQuest 
Client user database (such as the optional SAMPL database). For each SQL 
Server database, complete the following tasks.

■ (Verify) server registration

■ Create an empty database

■ Set up a backup procedure for the database

■ Create a SQL Server login with the db_owner role to use for the 
ClearQuest database logins (the same login is used by ClearQuest for all 
connections). 

Note: Do not use the SA (system administrator) login. During an upgrade 
or move process, ClearQuest requires empty databases. However, if the SA 
login is used, ClearQuest is able to see the System Tables, assumes the 
database is not empty, and does not allow the upgrade/move process to 
continue.

For SQL Server 2000 users:When installing SQL Server 2000, it is 
important to select the default registration name for your database server.  
This will make the registration name the same as your server’s machine 
name.

If you want to add more user databases to ClearQuest, repeat the preceding 
tasks for each new database. 

Registering your SQL Server machine for SQL Server 

1 In the SQL Server Enterprise Manager, select your Windows NT server 
in the SQL Server Group. 

If your server is not shown, register it now by going to Step 2. If your server 
is already registered, go to “Creating a new SQL Server 7 database” on
page 25. 

2 Right-click on the SQL Server Group and select New SQL Server 
Registration. The Register SQL Server Wizard displays.

3 Select a server name, and click Next. 
24  Installing Rational ClearQuest



Note: Make a note of the server name because you will need it during the 
ClearQuest installation. 

4 For Authentication Mode, select SQL Server, then click Next. 

5 For Login ID, type SA, and for Password, type your SA password. Then 
click Next. (The SA user has the privilege to create logins and databases.)

6 Add this server to an existing group, or create a new group. Then click Next.

7 Click Finish. The server will appear in the list of servers. 

Creating a new SQL Server 7 database

1 From the Getting Started Taskpad, select Administer SQL Server > 
Create a database.

2 In the wizard, specify a file system location for the database and the log. You 
can accept the defaults for the growth rate of the database and the log.

If you want to give the databases larger initial values, allocate at least 50 
MB for the schema repository and at least 15 MB for every 1,000 records 
expected for your user databases.

3 After you create a database, you are prompted to create a Database 
Maintenance Plan. The Database Maintenance Plan Wizard allows you to set 
up a database backup routine. It is strongly recommended that you set up 
automated nightly backups for all your ClearQuest databases.

4 Set database properties for the new database:

a Select the new database from the server’s databases folder.

b Right-click on the database and select Properties.

c On the Options tab, select these Settings:

■ Select into / bulk copy
■ Truncate log on checkpoint

d Click OK.
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Creating SQL Server logins

Create a db_owner login for each ClearQuest database (schema repository 
and each user database) by selecting the db_owner role for each of the logins 
you create.

Note: Do not use the SA (system administrator) as the owner login of a 
ClearQuest database. During an upgrade or move process, ClearQuest 
requires empty databases. However, if the SA login is used, ClearQuest is 
able to see the System Tables, assumes the database is not empty, and does 
not allow the upgrade/move process to continue.

1 Expand the Security folder, then right-click Logins, and click New 
Login. The SQL Server Login Properties - New Login dialog box displays.

2 On the General tab, select SQL Server authentication mode because 
ClearQuest does not support Windows authentication.

Note: Because ClearQuest requires a SQL Server login for each database 
and does not support Windows NT Authentication, you will need to set up 
SQL Server to operate in Mixed Mode (Windows NT Authentication and 
SQL Server Authentication). This property can be set via Enterprise 
Manager, right-click on the server and select Properties menu, Security tab.

3 Enter a name and password.

4 In the Defaults area, select your database and leave the Language set to 
<default>.

5 On the Server Roles tab, do not grant any server roles. 

6 Click OK and verify your password.

7 Grant db_owner privileges to the login in the new database.

a On the Database Access tab, select from the Permit list the new 
database to grant the login permission.

b Under Permit in database role, check db_owner and public. Do not 
grant this user any other privileges.
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Migrating from SQL Server 6.5

Use the ClearQuest Maintenance Tool to migrate your schema repository to 
a SQL Server 7 database. Then use ClearQuest Designer to move previous 
SQL Server 6.5 user databases to SQL Server 7. You do this by using the 
Properties dialog box to change the properties of the user database.

Warning: When migrating from SQL Server 6.5 to SQL Server 7, do not 
use the SQL Server 7 Upgrade Wizard to upgrade your schema repository 
and user databases. You need to use the ClearQuest Maintenance Tool and 
ClearQuest Designer. 

Ensuring SQL Server 7 Client Connectivity

SQL Server 7 client machines require SQL Server ODBC driver number 
3.7x. To update the ODBC driver for a client machine:

1 Go to that machine, insert the SQL Server 7 CD-ROM, and run 

D:\x86\other\mdac_type.exe

where D: is the letter of your CD-ROM drive.

2 Choose the Custom install option when prompted.

3 Select ODBC Driver for Microsoft SQL Server (and unselect other 
options such as Microsoft JetEngine).

Now that you have set up your SQL Server databases, proceed to “Insta
ClearQuest for an administrator” on page 37. 
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Setting up the Oracle Server

If you are using ClearQuest with Oracle databases, install and create the 
databases according to Oracle’s documentation. Follow these guidelines
when you set up your Oracle databases:

■ Create a specific Oracle database instance, or identify an existing Ora
instance, to use for ClearQuest data.

■ Create two or more separate Oracle database users (each with its log

■ the ClearQuest schema repository user login

■ one user login for each ClearQuest user database

■ Grant each user login the Connect and Resource roles only.

■ We recommend that you associate each Oracle database user with a u
default tablespace that is separate from all other users.

Note: The Oracle database users can share the temporary tablespace(s), 
but the temporary tablespace(s) for these users must be separate from 
Oracle system tablespace. 

Note: If your ClearQuest installation will include ClearQuest Unix client
your vendor database must be Oracle and it must be installed on a Unix
server.
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Configuring an Oracle client installation for ClearQuest 
Windows

The ClearQuest administrator and all ClearQuest Windows end-users must 
install Oracle Client Software on their local machines before they can install 
and use ClearQuest. To install Oracle Client Software, follow the Oracle 
Networking Products documentation.

Before using ClearQuest Windows, all users must use the SQL*Net Easy 
Configuration or SQL8*Net Easy Configuration program to configure 
their computers to access Oracle databases. 

IMPORTANT:Even if you will only be using ClearQuest Unix clients , you 
need to use the SQL*Net Easy Configuration tool to configure the 
administrator’s NT workstation to access the Oracle database. ClearQu
Unix requires that the administrator machine be a Windows machine.

1 From the Start menu, click Oracle for Windows NT > SQL*Net Easy 
Configuration if using Oracle 7.x or click Oracle for Windows NT > 
SQL8*Net Easy Configuration if using Oracle 8.x and complete these 
steps: 

2 Select View Configuration Information to see if your Oracle database 
administrator configured a Database Alias for you. If not, go to the next s

3 Add a new database alias by selecting Add Database Alias. Click OK.

4 Type a SQL*Net Database Alias (database name your Oracle database
administrator set up previously). Make a note of the Database Alias bec
you will need it during the ClearQuest database setup. Click OK.

Note: All ClearQuest users must use the same Database Alias.

5 Select TCP/IP as the network protocol to use to communicate with the 
database. Click OK.

6 Type the Host Name (the name of database server machine) and the 
Database Instance (the system ID or SID). Get this information from you
Oracle database administrator.

Note: All ClearQuest users must use the same Database Alias, Databa
Instance (system ID or SID), TCP/IP protocol, and Host Name (Oracle 
server machine).
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7 When you click OK, the SQLNet Easy (or SQLNet8 Easy) Configuration 
program asks you to confirm your choices. Click Yes to confirm the current 
configuration information.

8 After configuring your database, the installer displays the initial opening 
screen so that you can configure additional aliases. 
To quit the program, click Cancel. 

Enhancing search capabilities 

With a standard Oracle installation, you cannot perform a string search on 
multi-line text fields. For example, in ClearQuest you cannot search for text 
in a multi-line Notes field.

Oracle does provide an option called the ConText Option (Oracle 7), 
ConText Cartridge (Oracle 8) or IntermediaText (Oracle 8.1.x) that enables 
string searches in multi-line text fields. When installed, multi-line text fields 
become available for queries in ClearQuest.

For Oracle 7.x and Oracle 8.0.x

To enable Oracle multi-line text search with ClearQuest, do the following.

1 Install the ConText Option/Context Cartridge according to the Oracle 
documentation.

2 Start at least two ConText servers. Be sure to use the QDM (Query, DDL, 
DML) personality options.

3 To set up the ClearQuest Oracle user to have the necessary privileges, run 
the following SQL script using Oracle’s SQLPlus utility as the Oracle system 
user.

The SQL script (setup_cq_ora_user.sql) can be found in the 
ClearQuest installation directory (\\Rational 
Software\ClearQuest\).

sqlplus ctxsys/<password>@<tnsname> 

@setup_cq_ora_user.sql <cquser> 
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where <cquser> is the name of the Oracle login used for creating the 
ClearQuest database.

For Oracle 8.1.x

1 Install InterMedia Text according to the Oracle documentation. Generally, 
this is installed by default when the Oracle server is installed.

2 Start at least two ConText servers.

3 To set up the ClearQuest Oracle user to have the necessary privileges, run 
the following SQL script using Oracle’s SQLPlus utility as the Oracle system 
user.

The SQL script (setup_cq_ora8i_ctx.sql) can be found in the 
ClearQuest installation directory (\\Rational 
Software\ClearQuest\).

sqlplus system/<password@tnsname> 

@setup_cq_ora8i_ctx.sql <cquser> 

where <cquser> is the name of the Oracle login used for creating the 
ClearQuest database.

For ClearQuest Unix clients

If your ClearQuest installation will include ClearQuest Unix clients, your 
vendor database must be Oracle and it must be installed on a Unix server.

In addition, after setting up your Oracle database server, you must also 
install OpenLink Request Broker to facilitate Oracle connections. See 
“Setting up the Oracle OpenLink Request Broker” on page 31.

Setting up the Oracle OpenLink Request Broker

If you will be supporting ClearQuest Unix clients, you need to install and
start the OpenLink Request Broker. 

1 Log into the Oracle server as the same user ID you will use when install
ClearQuest. 

2 Change to the openlink_server directory in the Rational root directory th
was created when you installed the ClearQuest components. 
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cd [Rational_dir]/ClearQuestOracleSupport/openlink_server/[arch]

3 Run install.sh and follow the prompts for the OpenLink Configuration 
utility, accepting defaults when available. 

4 In the second phase of the installation, select 1) Request Broker and 
enter the requested information. 

5 Next, select 9) for Oracle 7 or 10) for Oracle 8 and enter the path name 
of the Oracle home directory and the SID to be used. 

6 Next, select S) Startup Request Broker. 

7 Quit the OpenLink Configuration Utility. 

Installing the OpenLink ODBC catalog views for Oracle 7 or 
Oracle 8 

This task is done while connected to the internal database. Run the Oracle 
svrmgrl with the corresponding sql script, and use odbccat7.sql for Oracle 7 
or odbccat8.sql for Oracle 8. The script(s) are located in the newly created 
bin directory. 

1 Log in as the Oracle database administrator. 

2 Change to the directory containing the odbccat7.sql or odbccat8.sql script: 
cd [Rational_dir]/ClearQuestOracleSupport/openlink_server/[arch]/bin

3 Enter the following: 
$ svrmgr1 lmode=y
SVRMGR>CONNECT internal;
SVRMGR>@odbccat7.sql

--or--
SVRMGR>@odbccat8.sql
SVRMGR>EXIT;

For more information, see the comments in the odbccat*.sql file.
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Automatically restarting the OpenLink broker on reboot

The following instructions assume your Unix installation uses the typical 
directories for startup and shutdown scripts. 

To automatically restart the OpenLink Request Broker after rebooting the 
server: 

1 Log in as root (root privileges are typically required for this step). 

2 After installing the cd-image, there will be an rc.OpenLinkBroker file in: 

    [Rational_dir]/ClearQuestOracleSupport/openlink_server/[arch]

where [arch] is either hp10_pa or sun5.

For Solaris,

1 Copy the rc.OpenLinkBroker script to the /etc/init.d directory. 

    cp rc.OpenLinkBroker /etc/init.d/openlinkbroker

2 Edit the /etc/init.d/openlinkbroker script to change the value of BIN_DIR to 
be: 

[Rational_dir]/ClearQuestOracleSupport/openlink_server/sun_5/bin

3 Make the script executable: 

    chmod +x /etc/init.d/openlinkbroker

4 Make symbolic links for startup and shutdown as follows. Note that the 
example uses "98" for startup and "02" for shutdown. You may need to use 
different numbers so that the startup script is invoked after any Oracle and 
NFS start up scripts. 

ln -s /etc/init.d/openlinkbroker /etc/rc2.d/S98openlinkbroker
ln -s /etc/init.d/openlinkbroker /etc/rc2.d/K02openlinkbroker
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For HP-UX,

1 Copy the rc.OpenLinkBroker script to the /etc/init.d/ directory. 

    cp rc.OpenLinkBroker /sbin/init.d/openlinkbroker

2 Edit the /sbin/init.d/openlinkbroker script to change the value of BIN_DIR to 
be: 

[Rational_dir]/ClearQuestOracleSupport/openlink_server/hp10_pa/bin

3 Make the script executable: 

     chmod +x /sbin/init.d/openlinkbroker

4 Make symbolic links for startup and shutdown as follows. Note that the 
example uses "98" for startup and "02" for shutdown. You may need to use 
different numbers so that the startup script is invoked after any Oracle and 
NFS start up scripts.

ln -s /sbin/init.d/openlinkbroker /sbin/rc2.d/S98openlinkbroker
ln -s /sbin/init.d/openlinkbroker /sbin/rc2.d/K02openlinkbroker

Now that you have set up your Oracle databases, proceed to “Installing 
ClearQuest for an administrator” on page 37.
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Setting up IBM DB2 6.1

To use ClearQuest with IBM DB2 databases, you need to install IBM DB2 
6.1 on the machine which you will use as your database server.

IMPORTANT: Please see the ClearQuest release notes before proceeding 
for more information about using DB2 databases with ClearQuest 
(\\ClearQuest\books\clearquest_readme.htm.).

Creating a new DB2 database

You need to set up one empty DB2 database for the ClearQuest schema 
repository, and one empty DB2 database for each ClearQuest user database 
(such as the optional SAMPL database). For each DB2 database, complete the 
following tasks.

1 From the Start menu, click DB2 for Windows NT > Control Center.

2 Enter the login name and password for the DB2 administrator account and 
click OK.

1 From the DB2 Control Center, expand the machine name that corresponds to 
the database server on which you will create the database until you see the 
Databases folder.

2 Right-click the Databases folder and choose Create > Database using 
Smart Guide.

Note: Make sure all DB2 services are running, otherwise this utility will 
not work.

3 Enter a name of the database. Note the DB2 supports database names will 
eight characters or less.

4 Click Done.

Creating a DB2 alias on client machine

All ClearQuest Windows client users (including the ClearQuest 
administrator) must install DB2 client software on their local machines 
before they can install and use ClearQuest. To install DB2 client software, 
follow the IBM documentation.
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Note: If the client and server machines are the same, you can skip this step.

Before using ClearQuest Windows client, all users must use the Client 
Configuration Assistant to create a DB2 alias for each ClearQuest 
schema repository and user database they will use.

1 Install DB2 Client Software according to the IBM DB2 documentation.

2 From the Start menu, choose DB2 for Windows NT > Client 
Configuration Assistant. The Welcome dialog box appears.

3 Click Add database.

4 Click Search the network.

5 Click Next.

6 Expand the Known Systems folder, if you see the database server 
machine on which the ClearQuest database resides, expand it and select the 
database name for which you want to create an alias. 

Note: If you don’t see the machine you need, try expanding the Other 
Systems folder. If you don’t see the machine you need in the Other 
Systems folder, talk to your database administrator. There may be a net
problem.

7 Expand the database server machine folder you need and click the data
for which you need to create an alias.

8 Click Next.

9 Click Done.

Now that you have set up your DB2 databases, proceed to “Installing 
ClearQuest for an administrator” on page 37.
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Before installing ClearQuest on client machines you must install it on the 
administrator’s machine, set up licensing, and set up your schema repos
and user databases.

If you are using an Oracle or DB2 database, install the Oracle or DB2 cl
software before installing ClearQuest. See “Setting up the Oracle Server” 
page 28 or see “Setting up IBM DB2 6.1” on page 35 for more informatio

This chapter covers the following topics:

■ “Installing ClearQuest for an administrator” on page 38

■ “Creating ClearQuest databases” on page 39

■ “Setting up configuration management integrations” on page 44

■ “Setting up record submission via e-mail” on page 48

■ “Installing Crystal Reports” on page 49
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Installing ClearQuest for an administrator

To install ClearQuest for administrators: 

1 Load the ClearQuest CD-ROM. 

2 If the setup program does not run automatically, navigate to the top level 
directory of the CD-ROM and double-click setup.exe. 

The Rational Software Setup wizard prompts you through the ClearQuest 
installation.

3 If you are evaluating ClearQuest, choose the Evaluator installation. 
Otherwise, choose the Administrator installation.

4 Launch the License Administrator to enter your ClearQuest licenses. Follow 
the instructions on your License Certificate and in the online Help for the 
License Key Administrator.

Note: Rational ClearQuest uses a FlexLM license server. If you don’t 
already have a FlexLM license server installed, it is available on the Ratio
Solutions for Windows CD. For more information, see Administering 
Licenses for Rational Suite, available on the Rational Solutions for Window
Online Documentation CD.
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Creating ClearQuest databases

After you install ClearQuest and have created the necessary empty vendor 
databases (see “Configuring vendor databases” on page 11), you must c
the ClearQuest databases (schema repository and user databases). Init
you can create a sample user database to use while you familiarize you
with the product. You can create your production user databases later.

If you chose the Evaluator installation, Microsoft Access databases are 
created for you automatically. If you chose the Administrator installation,
follow these steps to create ClearQuest databases:

Creating a schema repository

1 Launch the ClearQuest Maintenance Tool (Start > Programs > Rational 
ClearQuest > ClearQuest Maintenance Tool). 

Note: The first time you launch ClearQuest, the Maintenance Tool runs
automatically.

2 Select Create a new schema repository and click Next.

3 Select the vendor database you plan to use, enter the properties approp
for that vendor, then click Next. Save this information for clients to use 
when they connect to the databases. The information to enter is as follo
■ MS_ACCESS

■ Enter a name for the schema repository. Enter the entire path to the
using a UNC style path. For example:

\\DevServer\ProjectShare\CQ_DBS\schema_repo.mdb

You can browse to the directory where you want to create the datab
Be sure to browse using the Network Neighborhood to preserve the
UNC style path name.
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■ SQL_ANYWHERE

■ Enter a name for the schema repository. Enter the entire path to the file 
using a UNC style path. For example:

\\DevServer\ProjectShare\CQ_DBS\schema_repo.db

You can browse to the directory where you want to create the database. 
Be sure to browse using the Network Neighborhood to preserve the 
UNC style path name.

■ Enter the name of the database server.

■ Enter the protocols used to communicate with the SQL Anywhere 
server.

■ Enter the database host name. The database host machine must be 
visible to the client machines via network share and via one or more of 
the communication protocols. For TCP/IP, this can also be the IP 
address.

■ SQL_SERVER

■ Enter an SQL Server database name for the database that will contain 
the schema repository. 

■ Enter the name of the database server.

■ Enter the database owner (DBO or Administrator) login.

■ Enter the password for the database owner (DBO or Administrator) 
login.

■ Enter the general purpose or read/write login.

■ Enter the password for the general purpose or read/write user login.

■ Enter the schema repository or read-only user login.

■ Enter the password for the schema repository or read-only login.
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■ ORACLE

■ Enter the TNS name (SQL*Net Alias pointing to the Oracle instance).

■ Enter the Oracle login you created for the schema respository.

■ Enter the password for the login.

■ The following options need to be entered in the Connect Options 
field, delimited by semi-colons. For example, 

Host=<name>;SID=<name>;Server_ver=8.0;Client_ver=7;Lob_type=LONG

Note: All ClearQuest users must use the same SQL*Net Alias (TNSname), 
Database Instance (system ID or SID), TCP/IP protocol, and Host Name 
(Oracle server machine).

4 We recommend that you create a sample database using one of the provided 
schemas. Select a schema, give the sample database a name, then click Next.

Option Definition

Host The name of the database server machine. If your 
ClearQuest deployment will include both Unix and 
Windows clients the Host name is mandatory.

SID The name of the Database Instance. If your 
ClearQuest deployment will include both Unix and 
Windows clients the SID name is mandatory.

Server_ver Provide the version of the Oracle server you are 
using. Possible values are 7, 8.0, and 8.1 (For 
Oracle 8i, use 8.1.)

Client_ver Provide the version of the Oracle client software you 
are using. Possible values are 7, 8.0, and 8.1 (For 
Oracle 8i, use 8.1.)

If ClearQuest client users want to use a different 
Oracle client version than what is entered here by 
the administrator, they’ll need to override the set 
options manually. The default setting is 7.
See Release Notes for details.

Lob_type Set the type of data you’ll be using. The valid data 
type is LONG. 
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5 If you created a sample database, you must select a vendor and enter the 
database properties. When you are finished, click Next.

6 You can save these settings as a default profile, or click Finish to complete 
the setup. The profile records the entries you made and saves them to a file 
(the default name is cqprofile.ini). Clients can connect to the database 
by using the profile file instead by typing the connection information.

Creating a user database

You create ClearQuest user databases with the ClearQuest Designer, after 
you have successfully created a schema repository.

Note: Unless you are using MS Access, you must have first created empty 
vendor databases before you can create ClearQuest databases.

1 From the Start menu, choose Programs > Rational ClearQuest > 
ClearQuest Designer.

2 Click Next when the Rational Schema Repository dialog box appears.

3 Click OK when the ClearQuest Designer Login dialog box appears.

Note: When you click OK, you will be logging in with the default 
ClearQuest administrator login name and password. The default user name is 
“admin” the password is null and should be left blank. You should chang
this password and create a new login as your earliest convenience. 

4 Click Cancel when the Open Schema dialog box appears.

5 Choose Database > New Database.

6 Enter a logical name for the database you want to create. This name mu
five characters or less.

7 Click Next.

8 Select the vendor database you plan to use, enter the properties approp
for that vendor, then click Next. For more information about the required 
parameters for vendor databases, see step 3 under “Creating a schema
repository”  on page 39.

9 Click Next.
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10 Click Next to accept the default polling parameters.

11 Choose a schema with which to associate your database. You must associate 
the database with a schema.

Warning: If you have Rational ClearQuest/TeamTest edition, you must 
select the TestStudio schema. The Rational ClearQuest/TeamTest edition 
license does not allow you to use other schemas. You will get a licensing 
error if you do not choose the TestStudio schema.

12 Click Finish.
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Setting up configuration management integrations

You can integrate ClearQuest with software configuration management tools 
to create a complete change management system. ClearQuest relates change 
requests directly to changes in your evolving code base, allowing you to 
answer such questions as: 

■ Which defects have been fixed in one release but not in another?

■ Which defects can be attributed to a specific release?

Integrating with Rational ClearCase

The integration of ClearQuest and ClearCase allows you to associate change 
requests with one or more ClearCase elements. To set up the integration:

1 Within ClearCase, use the ClearQuest Integration Configuration tool located 
on the ClearCase Administration menu. The online Help describes how to 
set up and use the integration.

2 Within ClearQuest, apply the ClearCase package to a schema to enable the 
integration. For more information on installing packages, see the 
Administering Rational ClearQuest guide.

Note: If you have a previous installation of ClearQuest that used the 
ClearCase add-in, select the Upgrade 1.0 version of the ClearCase 
package. If this is the first time you are installing the integration, use the 1.0 
version of the package.

Unified Change Management (UCM)

To use the ClearQuest/ClearCase UCM integration, consult the following 
documentation:

■ To set up the ClearCase part of the integration and to learn about the UCM 
process, see the Managing Software Projects with ClearCase guide 
provided with ClearCase.

■ To set up the ClearQuest part of the integration, see Appendix B, 
“Enabling ClearQuest for Unified Change Management,” in the 
Administering Rational ClearQuest guide.
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Integrating with Microsoft Visual SourceSafe

The ClearQuest/Visual SourceSafe integration adds Visual SourceSafe fields 
to a record type you choose, and the Visual SourceSafe tab to the record type 
form. 

To enable the integration:

1 Install ClearQuest and Visual Studio according to the normal procedure for 
each product.

2 Set up your ClearQuest schema repository and user databases.

3 Use the ClearQuest Designer to add the Visual SourceSafe integration 
package to your schema using the Package Wizard.

a Launch the ClearQuest Designer from the Start menu

b Check out the schema you want to use with the integration.

c Install the Visual SourceSafe package by choosing Package > Package 
Wizard. Click More Packages to locate the VisualSourceSafe package, 
then click OK.
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d Select the Visual SourceSafe package and click Next.

Note: If you have a previous installation of ClearQuest that used the Visual 
SourceSafe add-in, select the Upgrade 1.0 version of the package. If this is 
the first time you are installing the integration, use the 1.0 version.

e Select the record types to be enabled by the package, then click Finish.

For more information on packages, consult the Administering Rational 
ClearQuest guide or the Help for the ClearQuest Designer.

4 Check in the schema.

5 Upgrade your user database to the new version of the schema.

Important: We recommend that you first upgrade a test database and 
familiarize yourself with the integration features before upgrading your 
production database.

6 In ClearQuest, create a query that your end users can use to find the records 
you want to associate to projects in Visual SourceSafe.

7 On each client that wants to use the integration, launch the ClearQuest 
Visual Source Safe tool (cqvss.exe) located in the ClearQuest home 
directory. You can drag a copy of cqvss.exe to the desktop to create a 
shortcut to it.

8 Log in and select the Visual SourceSafe database you want to use.

9 From the ClearQuest tools for Visual SourceSafe screen, select Setup Tool.
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10 In the Visual SourceSafe Integration dialog, select the ClearQuest query you 
want to use and click OK.

The installation of the integration is complete. To begin using the 
integration, see the Help for the ClearQuest Visual SourceSafe tool.
Installing ClearQuest for an administrator  47



he 
 

ional 
ine 

 to 
s in 

der 
Setting up record submission via e-mail

To enable your users to submit and modify records via e-mail, you configure 
the Rational E-mail Reader. The E-mail Reader is an e-mail processing tool 
that parses submitter’s e-mail and commits new records or changes to t
database. The E-mail Reader requires a dedicated e-mail account to be
assigned for parsing records.

Use the Rational E-mail Reader to designate one machine to be the Rat
Mail Server. We recommend that the Rational Mail Server run on a mach
that is always available. 

The E-mail Reader (mailreader.exe) is automatically installed in the 

\Rational\common directory. You can drag a copy of the mailreader.exe
the desktop to create a shortcut to it. You can then follow the instruction
the online Help (located in \Rational\common\mailreader.hlp) on 
how to set up the E-mail Reader. For more information on the E-mail Rea
see “Administering ClearQuest E-mail” in the Administering Rational 
ClearQuest Guide.
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Installing Crystal Reports

If you want to customize the defect reports that ship with ClearQuest, you 
must install Crystal Reports Pro 6.0. This software comes on a separate CD 
in your Rational ClearQuest software kit.

To install Crystal Reports, use the Crystal Reports installation directions that 
come with the CD.

Note: Users who will not be editing existing or creating new report 
formats, do not need to install Crystal Reports.

You have completed Step 2 of the steps described in “Understanding th
install process” on page 9. Return to that page to determine the next ste
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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
4
 Installing ClearQuest Windows for 
end-users
n 

l 

st 
ClearQuest Windows must be installed on each end-user machine. When 
ClearQuest Windows is installed and connected to the database, users can 
enter and modify records.

Note: It is also possible to allow users to install the ClearQuest Windows 
client from a network location, for more information see “Silent Installatio
of Rational ClearQuest” on page 113.

To install ClearQuest Windows for end-users: 

1 Load the ClearQuest CD-ROM. 

2 If the setup program does not run automatically, navigate to the top leve
directory of the CD-ROM and double-click setup.exe. 

The Rational Software Setup wizard prompts you through the ClearQue
Windows installation.

3 Choose the Client installation. 

If you will be doing schema development, select the Administrator 
installation, which includes additional administrative tools.

4 Launch the License Administrator to enter your ClearQuest licenses.
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Connecting to ClearQuest databases

After installing ClearQuest Windows as a client user, the first time client 
users run ClearQuest Windows, client users need to connect to an existing 
schema repository. You, the ClearQuest administrator, must provide them 
database properties information needed. 

You can create a database profile for client users to use to connect to the 
schema repository, see step 6 of “Connecting to ClearQuest databases”
page 52.

Note: If you are using Oracle or DB2, your client users will need to inst
the respective client software before installing ClearQuest. For more 
information, see “Configuring an Oracle client installation for ClearQues
Windows”  on page 29 or see “Creating a DB2 alias on client machine”  
page 35.

The following instructions apply to client users who need to connect to a
schema repository:

1 Launch the ClearQuest Maintenance Tool (Start > Programs > Rational 
ClearQuest > ClearQuest Maintenance Tool). 

Note: The first time you launch ClearQuest Windows, the Maintenance
Tool runs automatically.

2 Select Connect to Existing schema repository and click Next.

3 Select the vendor database that you plan to use, enter the properties 
appropriate for that vendor, then click Next. 

Enter the information provided by your administrator, or, if your ClearQue
administrator created a user profile file (usually called cqprofile.ini) 
that includes the database information you need, click Load Profile to 
navigate to the profile file. 

If you did not create a profile for client users, they must enter the followi
information: 

■ MS_ACCESS

■ Enter the entire path to the schema repository using a UNC style pa
For example:
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\\DevServer\ProjectShare\CQ_DBS\schema_repo.mdb

You can browse to the directory containing the database. Be sure to 
browse using the Network Neighborhood to preserve the UNC style 
path name.

■ SQL_ANYWHERE

■ Enter the path to the schema repository using a UNC style path. For 
example:

\\DevServer\ProjectShare\CQ_DBS\schema_repo.mdb

You can browse to the directory containing the database by using 
Network Neighborhood, which preserves the UNC style path name.

■ Enter the name of the database server.

■ Enter the protocols used to communicate with the SQL Anywhere 
server.

■ Enter the database host name.

■ SQL_SERVER

■ Enter an SQL Server database name for the database containing the 
schema repository. 

■ Enter the name of the database server.

■ Enter the schema repository or read-only user login.

■ Enter the password for the schema repository or read-only login.

■ ORACLE

■ Enter the SQL*Net Alias (alias pointing to the Oracle instance).

■ Enter the Oracle login created for the schema respository.

■ Enter the password for the login.

■ DB2

■ Enter the Database Alias name (alias pointing to the DB2 database).

■ Enter the DB2 login created for the schema repository.

■ Enter the password for the login.

4 Click Finish to complete the connection.
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Enabling e-mail notification

After installing ClearQuest Windows, users must enable e-mail notification 
if they want to receive automatic e-mail messages from ClearQuest 
Windows. To do this:

1 Launch ClearQuest Windows (Start > Programs > Rational 
ClearQuest > Rational ClearQuest).

2 Choose View > E-mail Options. This opens the E-mail Setup dialog.

3 Select Enable E-mail Notification.

4 Select either SMTP or MAPI

5 If you entered SMTP:
■ Enter the SMTP host address of your mail server. 

■ Enter your e-mail address. 

■ Click Finish.

6 If you entered MAPI:
■ Choose a MAPI profile from the list.

■ Click Finish.
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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
5
 Installing ClearQuest Unix for end-users
This chapter describes how to install ClearQuest Unix. You, the ClearQuest 
administrator, set up the databases to use with ClearQuest, install 
ClearQuest, and provide the required setup information to each client user. 

This chapter covers the following topics:

■ “Understanding the install process” on page 56

■ “Installing ClearQuest Unix client and Oracle Support” on page 57

■ “Running ClearQuest Unix” on page 60

■ “Enabling e-mail notification” on page 61
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Understanding the install process

If you plan to use ClearQuest Unix clients with your ClearQuest installation, 
the installation must include the following:

■ Oracle databases (for schema repository and user databases)

■ OpenLink Request Broker (facilitates Oracle connections)

■ ClearQuest Designer on Windows (for schema development)

■ ClearQuest Unix client 

You, the ClearQuest administrator, install ClearQuest Unix by performing 
the following steps:

1 On Unix, set up your database product. As the ClearQuest administrator, you 
are responsible for setting up the databases your users will use with 
ClearQuest. See the appropriate section:
■ “Setting up the Oracle Server” on page 28. 

Note: If your ClearQuest installation will include ClearQuest Unix client
your vendor database must be Oracle and it must be installed on a Unix
server.

2 On Windows, install ClearQuest for Windows on the administrator’s 
workstation and create the ClearQuest databases. See “Installing ClearQ
for an administrator” on page 37. 

Note: The ClearQuest administrator version must be installed on a 
Windows machine. All ClearQuest customizations are done with the 
ClearQuest Designer, a Windows-only application.

3 Set up your license server. See “Licensing ClearQuest” on page 111.

4 On Windows, Optionally, customize your installation. See the Administering 
Rational ClearQuest guide for details on customizing ClearQuest.

5 On Unix, install the ClearQuest Unix client on the server machine from 
which users will run ClearQuest. See “Installing ClearQuest Unix client a
Oracle Support” on page 57. 

6 Install OpenLink Request Broker to facilitate Oracle connections. See 
“Setting up the Oracle OpenLink Request Broker” on page 31
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Installing ClearQuest Unix client and Oracle Support

For ClearQuest Unix, the system administrator needs to install the 
ClearQuest client software and let all client users know where to find the 
installation.

To install the ClearQuest client, do the following: 

1 Log in as the user who will own the ClearQuest installation. This user will 
perform administrative functions such as managing the database registry. 
Note: All other users only need read-only access to the installation 
directories. 

2 From the ClearQuest CD, run rs_install. 

3 Accept the license agreement. 

4 Select u)Use existing licensing. 

5 Select Configuration Selections. 

6 You can choose to install the ClearQuest Client and the OpenLink Request 
Broker (Oracle Support) all on the same machine as your Oracle installation, 
or you can install the ClearQuest client on a different machine. The 
OpenLink Request Broker must be on the same machine as the Oracle 
server. 

7 You must install at least the Oracle Support option now in order to complete 
the rest of the installation. Select either: 
■ s1) *ClearQuest Client and Oracle Support for Unix 
■ s2) *ClearQuest Client-Only for Unix
■ s3) *ClearQuest Oracle Support-Only for Unix

8 Enter the directory where Rational products are installed. A ClearQuest 
directory (referred to here as [CQ_Home]) will be created within the 
Rational products root directory (referred to here as [Rational_dir]). If the 
directory does not exist, the install can create it for you as long as you have 
write privileges to the parent directory. 

9 Select the licensing option that allows you to enter a port@host name. 

10 Enter the port@hostname name. For example, 

27000@server
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where "port" is 27000 and "host" is the name of the Windows license server. 

The "host" name needs to be a permanent name; if your network uses DHCP, 
you may need a variation or special form of the host name. Check with your 
network administrator. 

Note: On HP-UX, “@” may be set to kill the input line. If so, you can 
escape the “@” with a backslash or just enter the host name.

11 Optionally, you can choose to test the license server at this time. Select 
option 2) to test the license server. This step may install a small part of t
Unix license server software in order to perform the check. If the check fa
you may still proceed with the installation, but you will have to repeat the
licensing setup at a later time. 

12 Select f) forward to the next menu to continue.

13 Accept the default for the "Customize the install" prompt. 

14 Choose the skip option for the "Install mode" prompt. 

15 Select f)Forward to do the install. 

16 When the installation finishes, you're asked to enter the location of wher
store the registry information regarding the schema repository. 

Note: This directory must be readable by all machines and users that w
run ClearQuest. It must also be writable by the user who will be the 
ClearQuest administrator.
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17 When finished with the installation, add the ClearQuest home directory 

   [Rational_dir]/ClearQuestClient/bin

to your path or source cq_setup.csh to set the ClearQuest home environment 
variable ($CQ_HOME): 

   source [Rational_dir]/cq_setup.csh

18 Type Clearquest to run ClearQuest. 

19 The first time you run the ClearQuest/UNIX client, the Register Database 
dialog displays. Enter the information to connect to the schema repository as 
described below:
■ Enter ORACLE as the vendor.

■ Enter the Server name.

■ Enter the SID. Note that the SID is case-sensitive.

■ Enter the Oracle login and password you created for the schema 
repository.

■ Click Apply.

20 If you need to make changes to Connect Options, connect to the schema 
repository from the command line and enter:
% cqreg register -v[endor] <db_vendor> -s[erver] <db_server>
-d[database] <database_name> -u[ser] <user> -p[assword] <password>
[-co <connect_options>] <options>

Options include: [-help] [-effort_only] [-force] [-verbose] [-errors]
[-home <cq_home>] [-version <cq_version>] [-cq_databases <cq_databases>]

For <connect options> see the section “Creating ClearQuest databases”
on page 39.

For example:
% cqreg register -v oracle -s myserver -d TEST -u cqadmin \
  -p cqadmin -co "SERVER_VER=8.0"
Installing ClearQuest Unix for end-users  59



Running ClearQuest Unix

You should tell ClearQuest Unix client users where ClearQuest is installed. 
They can then run ClearQuest directly, or source a configuration file that will 
modify their path.

To run ClearQuest Unix, 

1 Add the ClearQuest home directory to their path:

   [Rational_dir]/ClearQuestClient/bin

or source cq_setup.csh to set the ClearQuest home environment variable 
($CQ_HOME): 

   source [Rational_dir]/cq_setup.csh

2 To run ClearQuest Unix, type clearquest.
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Enabling e-mail notification

After installing ClearQuest, users must enable e-mail notification if they 
want to send automatic e-mail messages from ClearQuest. To do this:

1 Launch ClearQuest. Type ClearQuest at a Unix shell prompt.

2 Within ClearQuest, choose View > E-mail Options. This opens the E-mail 
Setup dialog.

3 Select Enable E-mail Notification.

4 Enter your e-mail address.

5 Click OK.
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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
6
 Setting Up ClearQuest Web
This chapter describes how to set up the ClearQuest Web server for both 
Microsoft Internet Information Server version 4 (IIS 4) for Windows NT, 
and Windows 2000 Server, which includes Microsoft Internet Information 
Server version 5 (IIS 5).

This chapter covers the following topics:

■ “Understanding the installation process” on page 64

■ “Setting up ClearQuest Web for IIS 4” on page 65

■ “Setting Up ClearQuest Web for IIS 5” on page 77

■ “Enabling e-mail notification for web clients” on page 94

■ “Providing ClearQuest Web information to web clients” on page 98
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Understanding the installation process

The following are special considerations for using ClearQuest Web:

■ ClearQuest Web does not support Microsoft Access databases. 

■ Your browser must have cookies enabled when using ClearQuest Web.

■ Make sure your web server is set to display 256 colors. This is necessary 
for generating charts.

To install and configure ClearQuest Web on your Windows server, you must 
complete the following tasks:

Note: You must have first set up the vendor database that ClearQuest will 
use. See “Configuring vendor databases” on page 11.

1 If you are using Windows NT and want to use IIS 4.0, verify that Window
NT 4.0 Option Pack, which includes Microsoft Internet Information Serve
4.0 (IIS), is installed on your web server.

2 Install ClearQuest on the Web server. See, “Installing ClearQuest for an
administrator” on page 37.

Note: We recommend, for improved performance, security, and reliabili
that the Web server machine and the database server machine be two 
different machines, each with its software installed onto an NTFS partitio

3 Follow the instructions in this chapter to configure Microsoft Internet 
Information Server to serve the ClearQuest Web pages.

4 Configure the web server so that web clients can take advantage of 
ClearQuest’s e-mail notification feature.

5 Provide users with the path to ClearQuest Web.
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Setting up ClearQuest Web for IIS 4

This section is for users using Windows NT (Workstation or Server) with IIS 
4. If you are using Windows 2000 Server, which has IIS 5 as an embedded 
component, see “Setting Up ClearQuest Web for IIS 5” on page 77.

This section contains the following:

■ “Setting up an anonymous user account for IIS 4” on page 65

■ “Creating a cache directory for IIS 4” on page 68

■ “Configuring IIS 4.0 to serve ClearQuest Web pages” on page 69

Setting up an anonymous user account for IIS 4

Create an anonymous user account for IIS to use when it serves the 
ClearQuest pages. If you are using an SQL Server database, the anony
user account should be known in the domain that contains the ClearQue
database, and should have full access to that database.

Create the anonymous user account

Create the anonymous user account as follows:

1 Log on as a Windows NT administrator.

2 If the web server belongs to a Windows NT domain, ask your Windows N
system administrator to create a domain user and provide you with the u
name and password. (If not, go to Step 4.)

3 Run the User Manager (Start > Programs > Administrative Tools > 
User Manager), select Policies > User Rights, select the Show 
Advanced Rights checkbox, and give this user the following privileges o
the Web server:
■ Access this computer from network 

■ Log on locally 

■ Log on as a service

Also provide access to any other resources used by your hook scripts su
mail accounts or auxiliary databases. Skip to Step 6.
Setting Up ClearQuest Web  65



4 If the web server operates in stand-alone mode (does not belong to a 
Windows NT domain), use the default anonymous account created by the IIS 
installation (IUSR_<machine_name>) for Step 5. 

5 Run the User Manager (Start > Programs > Administrative Tools > 
User Manager), select Policies > User Rights, select the Show 
Advanced Rights checkbox, and give the IUSR_<machine_name> 
account the following privileges: 
■ Access this computer from network 

■ Log on locally 

■ Log on as a service

Also provide access to any other resources used by your hook scripts such as 
mail accounts or auxiliary databases.

6 Verify that the anonymous user account has a specific, known password (you 
will need it later). Make sure there are no password policies in effect such as 
“User must change password at next login,” because these prevent the 
anonymous user account from functioning properly.
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Set up the registry key access privileges

Give the anonymous user account full access privileges to the 
HKEY_LOCAL_MACHINE\Software\Rational Software\ClearQuest 
registry key as follows.

1 Select Run  from the Start menu and type REGEDT32 to run the REGEDT32 
program.

2 In the HKEY_LOCAL_MACHINE MDI window, select 
Software\Rational Software\ClearQuest.

3 On the Registry Editor menu bar, select Security > Permissions.

4 In the Registry Key Permissions dialog box, select the anonymous user. For 
the type of access, select Full Control. Select Replace Permission on 
Existing Subkeys so that the anonymous user can update the entire 
registry tree below ClearQuest.

5 Close the REGEDT32 program.

Set up read access permission

Give the anonymous user account read access permission to the directory 
tree containing the ClearQuest web files (this is the WWW directory in the 
ClearQuest installation area). 

Note: If you installed ClearQuest onto a FAT partition instead of an NTFS 
partition, you will not see a Security tab and can skip this section.

1 Use the Windows Explorer to locate the directory in which you installed 
ClearQuest. Right-click the www directory and select Properties from the 
shortcut menu. 

2 On the Properties dialog box, click the Security tab. Click Permissions 
and select Replace Permissions on Subdirectories. 

3 On the Directory Permissions dialog box, click Add.
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4 Select the anonymous user account.
■ If you chose the default local anonymous username in Step 2, set List 

Names From to the name of the local machine, click Show Users 
below the Names list, then select the IUSR_machinename account 
from the Names list.

■  If you are using a domain account, select that domain in the List 
Names From field, click Show Users, and select the domain 
account from the Names list. 

5 Click Add. 

6 Set Type of Access to Read. 

7 Click OK to close the Add Users and Groups dialog box.

8 Click OK to close the Directory Permissions dialog box.

9 Click OK to close the WWW Properties dialog box.

Creating a cache directory for IIS 4

Create a cache directory in the ClearQuest Web directory hierarchy:

1 At the top of the web directory tree, there should be a directory called 
cache. If a cache directory does not exist, create one under the ClearQuest 
WWW directory. For example:

c:\Program Files\Rational\ClearQuest\WWW\cache

2 Give the anonymous user full access to everything in this directory tree.
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Configuring IIS 4.0 to serve ClearQuest Web pages

This section describes how to configure the IIS 4.0 web server to serve 
ClearQuest Web pages.

■ “Create a virtual directory for IIS 4” on page 69

■ “Edit the properties of the virtual directory for IIS 4” on page 72

■ “Edit the properties of the cache directory for IIS 4” on page 75

■ “Edit the properties of the images directory for IIS 4” on page 76

■ “Restart the web server for IIS 4” on page 76

Note: If the Internet Service Manager is not available, you must install t
Windows NT 4.0 Option Pack. When installing the Option pack, be sure
explicitly select the Internet Service Manager.

Create a virtual directory for IIS 4

The first step in setting up IIS 4.0 is to create a virtual directory for the w
To create this directory, you use the Internet Service Manager program 
(Microsoft Management Console) that comes with IIS 4.0.

1 Start the Microsoft Management Console program (Internet Service 
Manager). 

Start > Programs > Windows NT 4.0 Option Pack > Microsoft 
Internet Information Server > Internet Service Manager
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2 In the Navigator window, right-click Default Web Site, then click New > 
Virtual Directory from the shortcut menu.

3 In the New Virtual Directory Wizard, type an alias name, such as CqWeb. 
Do not use a “/” character in the alias name.

 In the Navigator window,
right-click Default Web

Site.

Type an alias name

Click Next
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4 Type or browse to the name of the directory containing the ClearQuest Web 
files. These files are located in the WWW subdirectory of the ClearQuest 
installation directory. For example:

C:\Program Files\Rational\ClearQuest\WWW

5 Select the default permissions for the virtual directory:

Type the name of the
directory containing the

ClearQuest Web file

Click Next

Select 
Allow Execute Access 
(includes Script Access)

Click Finish
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Edit the properties of the virtual directory for IIS 4

Edit the properties of the virtual directory as follows: 

1 In the Microsoft Management Console left pane, navigate to the virtual 
directory you created earlier. 

2 Right-click on the virtual directory and select Properties from the shortcut 
menu. 

3 In the Properties dialog box, click the Virtual Directory tab. 

Note: You should not run ClearQuest Web in a separate memory space (as 
an isolated process). If you do so, e-mail rules will not work. If you need to 
run ClearQuest Web in a separate memory space, see the ClearQuest Release 
Notes (\\ClearQuest\readme.htm) for more information.

Clear all of these boxes

Select Execute
(including script)
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4 In the same Properties dialog box, click Configuration. In the Application 
Configuration dialog, click the App Mappings tab.

5 In the same Application Configuration dialog box, click the App Options 
tab.

Verify that Cache ISAPI
applications is selected.

Verify that .asa and .asp
are mapped to asp.dll

Select Enable session
state and set the timeout.

Select Enable parent
paths.
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6 Click OK to return to the Properties dialog box.

7 In the Properties dialog box, click the Documents tab.

8 In the same Properties dialog box, click the Directory Security tab. In the 
Anonymous Access and Authentication Control, click Edit to open the 
Authentication Methods dialog box.

If necessary, add the
Default.asp document to

the list of documents...

Click to add the 
Default.asp 
document to the 
list

then remove any other
documents and select

Default.asp as the
default

Select Allow
Anonymous Access

Important: Verify that
Windows NT

Challenge/Response
is NOT selected.

If the box has a check
mark, be sure to clear it.

Then click Edit 
to define the 
anonymous user 
account
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9 Define the anonymous user account: 

Note: ClearQuest Web does not work if Enable Automatic Password 
Synchronization is selected.

10 Click OK.

11 Type the password in the Confirm Password dialog box and click OK. 

12 Click OK again to close the Properties dialog.

Edit the properties of the cache directory for IIS 4

Edit the properties of the cache subdirectory as follows: 

1 In the Microsoft Management Console left pane, navigate to the cache 
directory under the virtual directory name. 

2 Right-click the cache directory.

3 Click Properties from the shortcut menu. 

4 In the Properties dialog box, click the Directory tab. 

5 For Access Permissions, select only Read. Verify that no other options are 
selected.

6 For Permissions, select None. 

7 Click OK. 

Clear Enable Automatic
Password

Synchronization
and type the password

Select the anonymous user
account created on page 65
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Edit the properties of the images directory for IIS 4

Edit the properties of the images subdirectory as follows:

1 In the Navigator window of the Microsoft Management Console, expand the 
directory tree of the Default Web Site until you locate the images directory 
under your alias name. 

2 Right-click the images directory. 

3 Click Properties from the shortcut menu. 

4 In the Properties dialog box, click the Directory tab.

5 For Access Permissions, select only Read. Verify that no other options are 
selected. 

6 For Permissions, select None. 

7 Click OK. 

Restart the web server for IIS 4

Close the Microsoft Management Console, saving your console settings, 
then restart the web server.

You have completed installing and configuring the ClearQuest web server 
for IIS 4.
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Setting Up ClearQuest Web for IIS 5

This section describes how to set up the ClearQuest Web server for Windows 
2000 Server, which includes Microsoft Internet Information Server version 5 
as an embedded component. If you are using Windows NT, see “Setting
ClearQuest Web for IIS 4” on page 65.

This section contains the following:

■ “Setting up an anonymous user account for IIS 5” on page 77

■ “Creating a cache directory for IIS 5” on page 81

■ “Configuring IIS 5 to serve ClearQuest Web pages” on page 83

Setting up an anonymous user account for IIS 5

Create an anonymous user account for IIS to use when it serves the 
ClearQuest pages. If you are using an SQL Server database, the anony
user account should be known in the domain that contains the ClearQue
database, and should have full access to that database.

Create the anonymous user account

Create the anonymous user account as follows:

1 Log on as a Windows 2000 administrator.

2 If the web server belongs to a Windows domain, ask your Windows syst
administrator to create a domain user and provide you with the user nam
and password. (If not, go to Step 4.)

3 For this domain user, click Start > Programs > Administrative Tools > 
Local Security Policy, select Local Policies > User Rights 
Assignment. For each of the following double-click to view the Local 
Security Setting dialog box then use the Add button to grant this user the
following privileges on the Web server: 
■ Access this computer from network
■ Log on as a service
■ Log on locally 

Also provide access to any other resources used by your hook scripts, s
as mail accounts. (Go to Step 6.)
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4 If the web server operates in stand-alone mode (does not belong to a 
Windows NT domain), use the default anonymous account created by the IIS 
installation (IUSR_<machine_name>). Click Start > Programs > 
Administrative Tools > Local Security Policy, select Local Policies 
> User Rights Assignment, and use the Add button to grant this user the 
following privileges on the Web server: 
■ Access this computer from network
■ Log on as a service
■ Log on locally 

Also provide access to any other resources used by your hook scripts, such 
as mail accounts. 

5 Verify that the anonymous user account has a specific, known password (you 
will need it later). Make sure there are no password policies in effect such as 
“User must change password at next login,” because these prevent the 
anonymous user account from functioning properly.
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Set up registry key access privileges

Give the anonymous user account full access privileges to the 
HKEY_LOCAL_MACHINE\Software\Rational Software\ClearQuest 
registry key as follows.

1 Select Run  from the Start menu and type REGEDT32 to run the REGEDT32 
program.

2 In the HKEY_LOCAL_MACHINE MDI window, select 
Software\Rational Software\ClearQuest.

3 On the Registry Editor menu bar, select Security > Permissions.

4 In the Registry Key Permissions dialog box, select the anonymous user. For 
the Permissions, select Full Control. 

5 Select Allow inheritable permissions.

6 Close the REGEDT32 program.

Select Allow
inheritable
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Set up read access permission

Give the anonymous user account read access permission to the directory 
tree containing the ClearQuest web files (this is the WWW directory in the 
ClearQuest installation area). 

Note: If you installed ClearQuest onto a FAT partition instead of an NTFS 
partition, you will not see a Security tab and can skip this section.

1 Use the Windows Explorer to locate the directory in which you installed 
ClearQuest. Right-click the www directory and select Properties from the 
shortcut menu. 

2 On the Properties dialog box, click the Security tab and select Allow 
inheritable permissions.

3 On the Security tab, click Add.

Select Allow
inheritable
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4 Select the anonymous user account.
■ If you chose the default local anonymous username in Step 2, set Look 

in to the name of the local machine, then select the IUSR_machinename 
account from the Name list.

■  If you are using a domain account, select that domain in the Look in 
field, and select the domain account from the Name list. 

5 Click Add, then click OK.

6 On the Security tab, in the Permissions section, select the checkbox to 
allow Read, then click OK.

Creating a cache directory for IIS 5

Create a cache directory in the ClearQuest Web directory hierarchy.

Note: If you installed ClearQuest onto a FAT partition instead of an NTFS 
partition, you will not see a Security tab and can skip this section.

1 At the top of the web directory tree, there should be a directory called 
cache. If a cache directory does not exist, create one your ClearQuest 
WWW directory. For example:

c:\Program Files\Rational\ClearQuest\WWW\cache

2 Right-click the cache directory to see its properties.

3 On the Properties dialog box, click the Security tab.
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4 Select the anonymous user account.
■ If you chose the default local anonymous username in Step 2, set Look 

in to the name of the local machine, then select the IUSR_machinename 
account from the Name list.

■  If you are using a domain account, select that domain in the Look in 
field, and select the domain account from the Name list. 

5 Click Add, then click OK.

6 In the Permissions section, select the checkbox to allow Full Control, then 
click OK.
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Configuring IIS 5 to serve ClearQuest Web pages

This section describes how to configure the IIS 5 web server to serve 
ClearQuest Web pages.

■ “Create a virtual directory for IIS 5” on page 83

■ “Edit the properties of the virtual directory for IIS 5” on page 87

■ “Editing the properties of the cache directory for IIS 5” on page 92

■ “Edit the properties of the images directory for IIS 5” on page 92

■ “Restart the web server for IIS 5” on page 93

Create a virtual directory for IIS 5

Create a virtual directory for the web as follows. 

1 Start the Internet Services Manager. 

Start > Programs > Administrative Tools > Internet Services 
Manager

2 In the Navigator window, right-click Default Web Site.
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3 On the shortcut menu, click New > Virtual Directory.

4 Click Next when the Virtual Directory Creation Wizard appears.

 In the Navigator
window, right-click
Default Web Site.
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5 Type an alias name, such as CqWeb. Do not use a “/” character in the a
name. Then click Next.

6 Type or browse to the name of the directory containing the ClearQuest W
files. These files are located in the WWW subdirectory of the ClearQues
installation directory. For example:

C:\Program Files\Rational\ClearQuest\WWW

Type (or browse to)
the directory

containing the
ClearQuest Web file

Then click Next
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7 Clear Read, clear Run scripts, and select Execute. Then click Next.

8 Click Finish to complete the Wizard.

Then click Next

Select Execute,
and verify that nothing

else is selected
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Edit the properties of the virtual directory for IIS 5

Edit the properties of the virtual directory as follows: 

1 In the Internet Information Services left pane, navigate to the virtual 
directory you created earlier. 

2 Right-click on the virtual directory and select Properties from the shortcut 
menu.

3 In the Properties dialog box, click the Virtual Directory tab. 

Verify that Scripts
and Executables

is selected
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4 In the same Virtual Directory tab, click Configuration. In the Application 
Configuration dialog, click the App Mappings tab.

Verify that Cache ISAPI
applications is selected.

Verify that .asa and .asp
are mapped to asp.dll
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5 In the same Application Configuration dialog box, click the App Options 
tab.

Select Enable session
state and set the

timeout interval

Select Enable parent

Click OK
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6 In the Properties dialog box, click the Documents tab.

If necessary, add the
Default.asp document to

the list of documents...

Click to add the 
Default.asp 
document to the 
list

then remove any other
documents and select

Default.asp as the
default
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7 In the same Properties dialog box, click the Directory Security tab. In the 
Anonymous Access and Authentication Control, click Edit to open the 
Authentication Methods dialog box.

8 Define the anonymous user account: 

9 Click OK.

10 Type the password in the Confirm Password dialog box, then click OK. 

11 Click OK, then click OK again to close the Properties dialog.

Select Allow
Anonymous Access

Then click Edit 
to define the 
anonymous user 
account

Clear Allow IIS to
control password,

and type the password

Select the anonymous user
account created on page 65
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Editing the properties of the cache directory for IIS 5

Edit the properties of the cache subdirectory as follows: 

1 In the Internet Information Services left pane, navigate to the cache directory 
under the virtual directory name. 

2 Right-click the cache directory.

3 Click Properties from the shortcut menu. 

4 In the Properties dialog box, click the Directory tab. 

5 Select the Read check box. Verify that no other options are selected.

6 For Execute Permissions, select None. 

7 Click OK. 

Edit the properties of the images directory for IIS 5

Edit the properties of the images subdirectory as follows:

1 In the Navigator window of Internet Information Services, expand the 
directory tree of the Default Web Site until you locate the images directory 
under your alias name. 

2 Right-click the images directory. 

3 Click Properties from the shortcut menu. 
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4 In the Properties dialog box, click the Directory tab.

5 Select the Read check box. Verify that no other options are selected.

6 For Execute Permissions, select None.

7 Click OK. 

Restart the web server for IIS 5

Close Internet Information Services, saving your console settings, then 
restart the web server.

You have completed installing and configuring the ClearQuest web server 
for IIS 5.

Select Read, and
verify that the others

are not selected

For Execute
Permissions,
select None
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Enabling e-mail notification for web clients

ClearQuest clients use e-mail notification according to the business rules of 
your schema. To extend e-mail notification support to users of the web 
client, perform the following steps. 

1 Copy the code below into a text editor.
■ For Windows NT,

REGEDIT4 

[HKEY_USERS\.DEFAULT\Software\Rational Software\ClearQue
st\<version>\SendMail]
"MailTransport"="Protocol"
"MAPIProfile"="MyMAPIProfile"
"SendActive"=dword:00000001
"SMTPHost"="MyMailHost"
"RealName"="Web Server On \\\\MyWebServerMachine"
"ReplyTo"="MyGenericReturnAddress@MyDomainName"

■ For Windows 2000,

Windows Registry Editor Version 5.00

[HKEY_USERS\.DEFAULT\Software\Rational Software\ClearQue
st\<version>\SendMail]
"MailTransport"="Protocol"
"MAPIProfile"="MyMAPIProfile"
"SendActive"=dword:00000001
"SMTPHost"="MyMailHost"
"RealName"="Web Server On \\\\MyWebServerMachine"
"ReplyTo"="MyGenericReturnAddress@MyDomainName"

The <version> number represents the current ClearQuest software product 
version. To get this, start the ClearQuest Windows client GUI, point to Help 
> About, and note the value in the "Version:" field. If you have a service 
pack release, enter just the first token ("1.1" in this example). 
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2 Edit the pertinent entries (MailTransport, MAPIProfile, SMTPHost, 
RealName, and ReplyTo) of the text in step 1 so that 
■ Protocol is either SMTP or MAPI

■ MyMAPIProfile is the name of your MAPI profile (this value is ignored 
if MailTransport is set to anything other than MAPI)

■ MyMailHost is the name of your mail host computer if you are using 
SMTP

■ MyWebServerMachine is the name of your web server

■ MyGenericReturnAddress@MyDomainName should be replaced by the 
return address to be used for notification mail messages sent by 
ClearQuest. This address should be a valid e-mail address on the mail 
server you are using.

3 Save the file using the following naming convention: <filename>.reg.

4 In Windows Explorer, navigate to the location where you saved the new file, 
then double-click it to import it to the registry.
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Set up registry key access privileges

Give the anonymous user account full access privileges to the 
HKEY_USERS\.Default\Software\Rational 

Software\ClearQuest\<version>\SendMail registry key as follows.

For Windows NT,

1 Select Run  from the Start menu and type REGEDT32 to run the REGEDT32 
program.

2 In the HKEY_USERS window, select .Default\Software\Rational 
Software\ClearQuest\<version>\SendMail.

3 On the Registry Editor menu bar, select Security > Permissions.

4 Click Add to add the anonymous user account.

5 In the Add Users and Groups dialog box,
■ If you chose the default local anonymous username, set List Names 

From to the name of the local machine and click Show users to view 
the list of domain accounts. Select the IUSR_machinename account 
from the Names list.

■  If you are using a domain account, select that domain in the Look in 
field and click Show users to view the list of domain accounts. Select 
the domain account from the Name list. 

6 Click Add.

7 For the type of access, select Full Control.

8 Click OK.

9 Select Replace Permission on Existing Subkeys so that the 
anonymous user can update the entire registry tree below ClearQuest.

10 Click OK.

11 Close the REGEDT32 program.
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For Windows 2000,

Give the anonymous user account full access privileges to the 
HKEY_USER\.DEFAULT\Software\Rational 

Software\<version>\ClearQuest\SendMail registry key as follows.

1 Select Run  from the Start menu and type REGEDT32 to run the REGEDT32 
program.

2 In the HKEY_USER window, select .DEFAULT\Software\Rational 
Software\ClearQuest\<version>\SendMail.

3 On the Registry Editor menu bar, select Security > Permissions.

4 Click Add.

5 Select the anonymous user account.
■ If you chose the default local anonymous username in Step 2, set Look 

in to the name of the local machine, then select the <user_account> 
account from the Name list.

■  If you are using a domain account, select that domain in the Look in 
field. Select the domain account from the Names list. 

6 Click Add. 

7 Click OK to close the dialog box.

8 In the Permissions area, allow Full Control and Read permissions.

9 Select Allow inheritable permissions from parent to propagate 
from this object. 

10 Click Advanced.

11 Select Reset permissions on all child objects...

12 Click OK.

13 Click Yes.

14 Click OK to close the Permissions for SendMail dialog box.

15 Close the REGEDT32 program.
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Providing ClearQuest Web information to web clients

To enable your users to access ClearQuest over the web, tell them to enter 
the URL:

http://<host>/<alias>

where <host> is the host name of the ClearQuest Web server machine, and 
<alias> is the directory containing the ClearQuest Web files.

Using the Advanced Query editor

ClearQuest Web’s advanced query editor requires Java Runtime (JRE) 
plug-in. For Windows platforms, this plug-in is provided by ClearQuest W
if it is not already installed on the client machine. For Unix platforms, us
are directed to the JavaSoft web site which may or may not have a down
for the desired platform.

Administrator note:The Java Runtime Environment is under active 
development by JavaSoft, and may not be available for all platforms. 
Consult the JavaSoft and Netscape web sites for details. On platforms w
the JRE is not available, clients will not be able to use the Advanced Qu
Editor function of ClearQuest Web.
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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
7
 Upgrading ClearQuest
 

This chapter describes how to upgrade your existing ClearQuest installation. 
Before you begin the upgrade, read the release notes 
(\\ClearQuest\readme.html) to become familiar with what has changed in 
this release.

Topics covered in this chapter include:

■ “Understanding the upgrade process” on page 100

■ “Preparing to upgrade” on page 101

■ “Performing a test upgrade” on page 102

■ “Performing the production upgrade” on page 107

■ “Upgrading clients” on page 108

■ “Upgrading ClearQuest Web” on page 109

Note: If you are using Rational ClearQuest/TeamTest Edition, see the 
Getting Started with Rational ClearQuest TeamTest Guide This guide is
available as a Portable Document Format (PDF) file in the 
\\ClearQuest\books directory.
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Understanding the upgrade process

The following steps summarize the upgrade procedure. The sections of this 
chapter describe the steps in detail.

1 Read the ClearQuest release notes (\\Program 
Files\Rational\ClearQuest\readme.htm) to learn what has changed 
in this release. 

2 Read this chapter and be sure you understand the upgrade procedure before 
you begin.

3 Warning: Back up your current schema repository and user databases.

4 Perform a test upgrade.
■ Create new, empty vendor databases for your schema repository and user 

databases.

■ Install the new version of ClearQuest.

■ Upgrade your schema with upgrade schema packages, if necessary.

■ Use the ClearQuest Maintenance Tool to upgrade your schema repository 
and user databases.

■ Unlock your old databases so users can continue to work with those 
databases during the testing period.

5 Perform the upgrade on your production databases.

6 Notify your users of the new database connection information.

Important: If you are using multiple products from the Rational Suite, all 
products must be from the same Suite version (installed from the same 
CD-ROM). If you want to upgrade a product from the Suite, uninstall all 
Rational Suite products and install the desired products from the newer Suite 
CD-ROM.
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Preparing to upgrade

The ClearQuest upgrade process upgrades the application and your 
databases. Because upgrading changes the underlying structure of your data 
and can change your schemas, we highly recommend the following:

■ Do complete backups of your databases.

Having a backup is the only way to be assured that you can recover your 
schemas and user data if something goes wrong during the upgrade 
process.

■ Do a test upgrade. 

By testing the upgrade, you can be sure that your data upgrades 
successfully and your customizations work with the new release. Testing 
also gives you the chance to try new functionality in the form of Packages 
(for more information on packages, see the release notes).

You should only upgrade your user databases when you completely 
understand the upgrade process and are sure the upgrade works with your 
customizations.

Note: Upgrading might fail if you have custom database tables that were 
not created by ClearQuest. For information about upgrading if you have 
custom database tables, read the release notes (\\Program 
Files\Rational\ClearQuest\readme.htm).
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Performing a test upgrade

We strongly recommend the following steps for performing a test upgrade. 
You should be sure the process works before upgrading your production 
databases.

Database locking

To upgrade, install the latest version of ClearQuest, then use the ClearQuest 
Maintenance Tool to upgrade your databases. After ClearQuest upgrades 
your data, it locks your original databases. When your original databases are 
locked, you have two options for how to proceed with the upgrade:

■ You can complete the entire upgrading testing with the original databases 
locked. 

This means that your users will not be able to use ClearQuest until the 
upgrade testing is completed. How long that takes depends on the size and 
complexity of your database and the amount of testing you do. If the 
upgrade is successful, upgrade your client installations, and notify users 
about how to connect to the upgraded databases.

■ You can unlock your original databases while you test the upgrade.

This means that your users can continue to use your current version of 
ClearQuest and continue to enter records while the upgrade testing is 
performed. The only down time for your users occurs while the actual 
database upgrade and unlock procedures are being performed. If the 
upgrade test is successful, you must discard the test databases and perform 
the process again to upgrade the most current data.

To unlock your original schema repository and user databases, see 
“Unlocking your original databases” on page 105.
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Upgrade steps 

The upgrade steps are the same whether you are performing a test upgrade or 
the final production upgrade. We highly recommend performing a test run. 
The following steps assume you are doing a test upgrade first.

To perform an upgrade:

1 Back up your data.

Use your vendor tools to back up your schema repository and user databases. 
Upgrading changes the underlying structure of your data and can change 
your schemas. We strongly recommend you have a backup to revert to it if 
necessary. Install the latest version of ClearQuest on your test machine using 
the Administrator installation.

2 Create new, empty vendor databases for your schema repository and user 
databases. You should create the new databases in a new test directory or on 
a test server. For information on creating vendor databases see:
■ “Setting up Microsoft Access” on page 13

■ “Setting up SQL Anywhere” on page 14

■ “Setting up Microsoft SQL Server Version 6.5” on page 19

■ “Setting up Microsoft SQL Server 7 and 2000” on page 24

■ “Setting up the Oracle Server” on page 28

Warning: Create empty databases only. Do not use your vendor datab
tools to move or copy the data. ClearQuest updates the data structure a
moves it into the new databases as part of the upgrade process.

3 Follow the installation steps in “Installing ClearQuest for an administrato
on page 37 to install the new version of ClearQuest.

4 Notify users to log off from ClearQuest, and shut down your web server.

Users should not access ClearQuest during the upgrade process.

Note: Some high-end databases give the administrator a tool for loggin
users off from the database. Check your vendor database to see if it has
a tool.

5 Upgrade your schema repository and user databases.
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a Run the ClearQuest Maintenance Tool from the Start menu.

b Select the Upgrade schema repository and/or user database(s) and 
click Next.

c Specify the schema repository to upgrade from (your existing production 
schema repository). Click Next.

d To upgrade databases associated with this schema repository, select the 
Upgrade user databases option.

e Enter the ClearQuest login name and password for a ClearQuest user 
account with Super User privileges, then click Next.

f Enter the schema repository to upgrade to (the new, empty database you 
created), then click Next.

g For each of your user databases, enter the user database to upgrade to (the 
new, empty databases you created), then click Finish.

ClearQuest upgrades your schema repository and notifies you when the 
process is complete.

6 Upgrade your schema by applying schema packages. 

ClearQuest uses schema packages to add functionality to your schema. 
When you upgrade to a new version of ClearQuest, there are often "upgrade 
packages" that you’ll need to apply to your schema before deploying 
ClearQuest. See the release notes for which upgrade packages may be
needed for your schema. For example, if you are upgrading from release
and had applied e-mail rule or integration add-ins, you must apply certai
upgrade packages to your schemas. 

To add packages,

a Start ClearQuest Designer.

b Choose View > Schema Summary to determine the packages that are
currently applied to the schema.

c Refer to release notes to see which schema packages need to be upg

d Choose Package > Package Wizard.
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e Use the Package Wizard to apply packages. For more information, see 
packages, installing into a schema in the ClearQuest Designer Help Index.

7 After upgrading your user databases to the new version of ClearQuest, you 
also need to upgrade them to use the latest version of the schema that 
incorporates the upgrade packages. For more information, see Working 
with Databases > Upgrading user databases in the ClearQuest 
Designer Help Contents tab.

8 Determine whether you want to unlock your original databases and allow 
users to continue working with ClearQuest during upgrade testing. If you 
choose to unlock the database, see “Unlocking your original databases” on 
page 105.

9 Test the application.

Enter a few test records and move them though your entire state model 
sure the upgrade is working correctly.

Unlocking your original databases 

If you choose to allow users to continue using your original databases w
you test the upgrade, you must unlock the database.

Note: After you perform the final upgrade, do not unlock your original 
databases. Keeping the original databases locked prevents your users f
accessing the wrong databases.

1 Start a command window ("DOS prompt"), and change to the new 
ClearQuest home directory. 
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2 To unlock the schema repository, type the command for your vendor 
database:

> installutil unlockschemarepo dbvendor server db 
dbologin dbopassword ""

where:

■ dbvendor (vendor database) is either: 

■ SQL_SERVER for SQL Server databases 

■ MS_ACCESS for Microsoft Access 

■ SQL_ANYWHERE for Sybase SQL Anywhere 

■ ORACLE for Oracle 

■ server is either:

■ the hostname of the SQL Server database server 

■ the SQL Anywhere database server name

■ the Oracle SQL*Net alias

■ an empty string (““) for Microsoft Access

■ db is the database name containing your original schema repository fo
Oracle and SQL Server, or the full path to the database for Microsoft 
Access and SQL Anywhere

■ dbologin is the userid that owns the database (use admin for Micros
Access or SQL Anywhere)

■ dbopassword is the password to that userid (use admin for Microsoft
Access or SQL Anywhere)

3 To unlock user databases, repeat the above steps with the following 
exceptions:
■ the installutil subcommand to use is unlockuserdb instead of 

unlockschemarepo

■ point to the server database containing the original user database, no
schema repository
106  Installing Rational ClearQuest



e 

heir 
Performing the production upgrade 

After you have performed a test upgrade and are comfortable with the 
process, you are ready to upgrade your production schema repository and 
user databases.

1 Determine if you need to perform the upgrade on your production database.

a If you chose to leave your production database locked during testing and 
the test upgrade was successful, you can put your upgraded databases into 
production. 

b If you choose to allow users to continue working with your production 
database during test, you need to repeat the upgrade process (see “Upgrade 
steps” on page 103), but this time you will not unlock your original 
databases.

Note: You will need to create new target databases before repeating th
upgrade steps for production databases.

2 Inform users of the new connection information to use when upgrading t
client installations of ClearQuest.
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Upgrading clients

Each client installation should be upgraded by uninstalling the current 
ClearQuest installation, installing the latest version of ClearQuest (see 
“Installing ClearQuest Windows for end-users” on page 51 and “Installin
ClearQuest Unix client and Oracle Support” on page 57), and connectin
the newly upgraded databases. 

Note: Uninstalling the current version does not delete your databases o
license information.

After upgrading, users who had enabled e-mail notification must reenabl
To do this:

1 Choose View > E-mail Options. This opens the E-mail Setup dialog.

2 Select Enable E-mail Notification.

3 Select either SMTP or MAPI

4 If you entered SMTP:
■ Enter the SMTP host address of your mail server. 

■ Enter your e-mail address. 

■ Click Finish.

5 If you entered MAPI:
■ Choose a MAPI profile from the list.

■ Click Finish.
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Upgrading ClearQuest Web

To upgrade ClearQuest Web:

1 If you have not done so already, shut down your web server.

2 Uninstall the current version and install the new version of ClearQuest on 
your Web server. See “Installing ClearQuest for an administrator” on 
page 37.

3 Repeat all the steps in Chapter 6, “Setting Up ClearQuest Web” on page

4 Restart your web server.
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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
8
 Licensing ClearQuest
This chapter gives an overview on how ClearQuest licenses work. The 
ClearQuest administrator sets up and maintains licenses using the Rational 
License Administrator.

For more information about licensing Rational Software products, see the 
book, “Administering Licenses for Rational Software”. 
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Working with Rational Software licensing

Rational Software product licensing provides two types of licenses: 

■ Node-locked license: enables a single user to install and use a Rational 
Software product on a specific system. 

■ Floating license: enables a specified number of users to install and use a 
Rational Software product on their systems. Floating licenses are shared 
among all users of the licensed software.

Note: If you purchase ClearQuest with a node-locked license, your 
ClearQuest Web functionality is limited to the ability to submit defects and 
to run one query (predefined by your ClearQuest administrator). To get full 
ClearQuest Web functionality, you need to purchase a floating license. 

The license key certificate included with your purchase of ClearQuest 
indicates the type of licenses you are working with and the license keys you 
need to install.

Rational Software makes it easy to install and maintain licenses by providing 
the Rational License Administrator. Rational Software also provides 
GLOBEtrotter Inc.’s FLEXlm License Manager for administering floating
licenses.

The Rational License Administrator is automatically installed when you 
install ClearQuest. To use the Rational License Administrator, select 
Rational ClearQuest > License Administrator from the Start menu. 
For information about installing your product licenses so you can get sta
using ClearQuest, see the Rational License Administrator online Help. 

To install the FLEXlm License Manager, select GLOBEtrotter FLEXlm 
License Server from the list of products displayed in the Rational 
Software Setup program. For additional information about FLEXlm 
licensing, see the Rational License Administrator online Help.
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I N S T A L L I N G  R A T I O N A L  C L E A R Q U E S T
9
 Silent Installation of Rational ClearQuest
 the 
Silent Installation of Rational ClearQuest

You can configure Rational Software Setup to perform silent installations of 
Windows versions of Rational software. Silent installations allow you to 
perform an installation of a Rational Software product, using the same 
parameters, repeatedly on a number of systems.

The following sections provide a brief summary of the silent installation 
features.

Note: We recommend you read Rational’s Silent Installation White Paper 
before you attempt a silent installation. The white paper is available from
Rational Web site at http://www.rational.com/. Select the following links in 
order: Technical Support, White papers, and Rational Suite.

Overview of Silent Installations of Rational ClearQuest

This section describes how to perform a silent install. The basic steps, 
explained below, are:

1 Record an installation session. 

2 Optionally, add a post-installation command to the recorded installation.

3 Execute the installation procedure.
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Recording a Software Installation of Rational ClearQuest

You can record a software installation session and then use the responses that 
you provide to replay the installation. At the end of the recorded installation 
procedure, you will be given the option to exit without installing the product. 

1 Insert the Rational ClearQuest software CD in a CD drive.

2 Open a command window on your system and run RSSetup with the 
-autocapture switch. For example: 

<Install Location>\setup\rssetup -autocapture

Where <Install Location> is the location of the Rational ClearQuest 
software CD. 

3 When the Rational Software Setup program starts, proceed with the 
installation procedure on “Understanding the install process” on page 9. 
Your responses will be recorded in the responses file which is named as
follows:

<Install Path>\RSSetup\response.ini

Note: The option to use a temporary license is not supported when usi
the -autocapture switch. The silent installation procedure will not suppo
the capture of license certificate information into the response.ini file.

4 After you have answered all of the questions related to the installation, y
will be prompted to continue with the installation of the product or to exit
from the setup program. Click OK to proceed with the installation or 
Cancel to exit. Even if you cancel at this point, your answers are still sav

Example

The following example shows how to record an installation of Rational 
ClearQuest. 
<Install Location>\setup\rssetup -autocapture /product 
ClearQuest-1.1
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Specifying a Post-Installation Command

You can specify a command that will be performed after the silent 
installation has completed.

After you have completed preparation for a silent installation, perform the 
following steps:

1 Edit the response file. Append a line similar to the following to the end of the 
file. The label [PostInstallCmd] is required.

[PostInstallCmd]
Command=post-installation-commands.bat

where, the post-installation-commands.bat is a batch file that 
contains the commands you want to execute. Such a file might contain the 
following commands:

licadmin -fserver.txt
net send administrator “Installation Complete”

In this example, the License Key Administrator, licadmin , starts and 
uses the information in server.txt to specify the name of the license 
server that the current system will use. The batch file then sends a message 
to the administrator, indicating that the installation procedure is complete.

2 Save the response file to a unique name (to ensure that is it not overwritten 
by subsequent autocaptures). For example, save the response file with a 
name such as c:\responses\ent-w-post.ini
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Performing a Silent Software Installation

After you have recorded your responses, use the response file to replay the 
installation. For example:

<Install Location>\setup\rssetup -silent 
-response:response-path

Where response-path is the path of the response file. The default path is 
as follows:

"c:\Program Files\Rational\RSSetup\response.ini"

Note: If a response file is in the default location, that response file will be 
used each time you run the installation procedure. Specifying a response file, 
using the -response:response-path parameter, will override the default 
response file.

If you specify -autocapture on the RSSetup command line, your 
installation will initially select the product name identified in the previous 
response.ini file, but will allow you to select a new product for 
installation. A new response.ini file will be saved at the end of the 
installation procedure.

Preparing Multiple Response Files

You can save multiple response files to support attended installation of 
different products.

1 Identify a directory where you will store your response files. The following 
examples use a directory named as follows: 

C:\responses

2 Record the response file for each product you want to install. 

3 Rename the response file with a unique file name. For example, save the 
ClearQuest 2.0 response file as 
C:\responses\ClearQuest2_0responses.ini.

4 Perform the installation and specify the path to the response file as a 
parameter to the -response switch. For example: 
<Install Location>\setup\rssetup -silent 

-response:c:\response\ClearQuest2_0response.ini
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Examples

See “Silent Installation of Rational ClearQuest” on page 113.

To record an installation of Rational ClearQuest version 2.0:

<Install Location>\setup\rssetup -autocapture /product ClearQuest-2.0

To remove Rational ClearQuest version 2.0:

<Install Location>\setup\rssetup /uninstall /product ClearQuest-2.0
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RSSetup Command Syntax

This section provides the syntax for RSSetup, and well as a table of RSSetup 
command parameters.

Syntax

RSSetup [-silent [-response:response-path]]| 
[-verbose [-response:response-path]] |
[-autocapture]
[/product <product>] [/install /uninstall /update]

RSSetup Command Parameter Description

-silent Performs a silent (unattended) 
installation. 

-verbose Replays a previously recorded 
installation, allowing you to override the 
recorded responses.
Note: if you override the responses, 
those changes are not written to the 
response file.

-response:response-path Specifies the path to the response file. 
response-path is the path for the 
response file. You must specify the 
response-path.
The default path is 
<Install Location>\Setup\ 
RSSetup\response.ini, where 
<Install Location> is the location of the 
installation files.

-autocapture Records your responses to a software 
installation, storing the responses in a file 
for later replay.

/product product-identifier Specifies the product you are installing. 
This parameter does not apply for silent 
installations. For a silent installation, you 
specify the product name in the response 
file. See page 119 for the list of identifier 
you can use with this switch.
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The table below lists the product identifiers you must use with the 
/product switch.

/install Installs the product you specified with the 
/product switch. 
This switch cannot be combined with 
/uninstall or /update.
This parameter does not apply for silent 
installations. For a silent installation, you 
specify the product name in the response 
file.

/uninstall Removes the product you specified with 
the /product switch. 
This switch cannot be combined with 
/install or /update.

/update Updates the product you specified with 
the /product switch. 
This switch cannot be combined with 
/install or /uninstall. 
This parameter does not apply for silent 
installations. 

Product Name Product Identifiers

Rational LoadTest atbuLoadTest

Rational Suite Performance Studio 
Agent

atbuPSAgent

Rational Suite Performance Studio atbuRSuitePerformanceStudio

Rational Test Enablers atbuSetupEnablers

Rational TeamTest atbuTeamTest

Rational TestAccelerator atbuTestAccelerator

Rational Robot atbuTSRobot

Rational ClearQuest ClearQuest-1.1

Rational ClearQuest TeamTest Edition ClearQuestTeamTestEdition-1.1

Rational PureCoverage coverageNT

RSSetup Command Parameter Description
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Rational Suite DevelopmentStudio for 
UNIX 

dsbuRSDSU

Rational Developer Kit dsbuDeveloperKit

Rational Purify purifyNT

Rational Quantify quantifyNT

Rational RequisitePro rmbuRequisitePro

Rational RequisiteWeb rmbuRequisiteWeb

Rational Rose Inline EJB Addin Inline

Rational Rose Enterprise Edition Rose98i

Rational Rose Professional C++ 
Edition 

Rose98iC++Professional

Rational Rose Professional J Edition Rose98iJavaProfessional

Rational Rose Modeler Edition Rose98iModeler

Rational Rose Professional Visual 
Basic Edition 

Rose98iVBProfessional

Rational Rose Professional Data 
Modeler Edition 

RoseDataModelerProfessional

Rational Unified Process ruObjectory51

Rational SoDA for Word SoDA

Rational Suite AnalystStudio wsbuAnalystEdition

Rational Suite DevelopmentStudio wsbuDevelopmentStudio

Rational Suite Development Studio - 
RealTime Edition

wsbuDevelopmentStudioRT

Rational Suite Enterprise wsbuEnterprise

Globetrotter FLEXlm License Server  wsbuFLEXlmServer

Sybase SQL Anywhere Database 
Server

wsbuSQLAnywhereServer

Rational Suite TestStudio wsbuTestStudio

Rational Suite Web Server 
Components

wsbuWebComponents

Product Name Product Identifiers
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License Key Administrator Command Line

You can run the Rational License Key Administrator from a command line 
or batch file to automate your license key installations and configuration.

Additional detailed information about the License Key Administrator 
command line options and usage is available on the Rational Suite web site: 
http://www.rational.com/products/rs/prodinfo/index.jtmpl.

License Key Administrator Syntax

licadmin -ffilename.ext

The status of the execution of this command is written to a file named 
filename.ext_STATUS, where filename.ext is the name of the license 
parameter file you used. The status file is created in the directory where you 
executed the licadmin command.

Example

1 Create a file that contains the following line:
Server:group-license-server

where group-license-server is the name of your FLEXlm License Server 
system.

2 Save the file as server-info.txt.

3 In a command window, run the following command:
licadmin -fserver-info.txt

Your system will be configured to use floating license keys from 
group-license-server.

Table 1: Licadmin Command Parameters

Parameter Description

-ffilename.ext Specifies the path to the license parameter file. 
The license parameter file specifies the name 
of the license key server that you will use. For 
example:
Server:group-license-server
The keyword Server is case-sensitive.
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