Rational Robot: Try it!

with Rational SiteCheck

WELCOME TO RATIONAL ROBOT

Use the sample SiteCheck Web site with this
Try it! to discover how easy it is to test the structural

. integrity of your intranet or World Wide Web site. In
S l te( he(:k minutes, you'll understand the power behind Rational
Robot’s testing capabilities as you record tests for:
» Internal and external links not found
. ) Links to incorrect pages

» Pages with broken links or pages that have moved

) Differences between the original and the latest
Web site

» Orphans, viruses, and assertions

) Slowly downloading pages

Rational SiteCheck is a powerful yet intuitive tool for testing the structural
integrity of your intranet or World Wide Web site. It's designed to help you
view, track, and maintain your rapidly changing site. Rational SiteCheck is
an integrated component of Rational Robot. SiteCheck provides numerous

features including:
» Support for Netscape Navigator®, Microsoft® Internet Explorer, or the browser
of your choice.

» Automatic tracking and updating of broken links, permanently moved or

orphan pages, and pages that are slow to download.

» Identification and verification of Web pages with active content including

ActiveX and Java.

» Support for Secure Sockets layer (SSL), proxy servers, multiple security

realms, and virus checking with McAfee VirusScan® 2.0 or later.

» A fully functional, color-coded HTML editor and source code browser.

» » » Find out how Rational puts quality to the test. » » »

Rational

the e-development company™



Test the sample Web site

These three Web pages display some of the aspects of the sample Web site you can test. The sample

Web site is the home page and site of a fictitious moving company Burlington Movers.

Test for large files or slowly

downloading pages.
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Open the sample site

SiteCheck comes with a sample Web site which you can use to learn about the product. During
installation, the sample site is installed on your hard disk and is ready for viewing and editing in
SiteCheck. SiteCheck can also open any Internet/intranet site when you provide its URL.

Home page for the
sample Web site

ABOUT | OFFICES | SERVICES | PARTNERS

» » pTry this to open the sample site:

Q From the Windows taskbar, click SiteCheck.
@ | the Welcome to Rational SiteCheck dialog box, click OK. The Open Site dialog box appears.

® (lick Local Site and then specify the path to the sample Web site:
C:\Program Files\Rational\Rational Test 7\Samples\Web\default.htm
You can also click Browse and look for this file.

@ Click oK to open the sample Web site.

© i, message asks if you'd like to switch to a view of external links, click No so you can follow the
examples in this Try it!.



View your Web site in SiteCheck

When you first open a site, SiteCheck shows File View in the left pane and Page View in the right pane.
These opening views present a clear picture of how your site is physically structured on the hard disk
(File View) and logically structured in terms of the HTML hyperlinks (Page View). Understanding the
structure of your site is particularly important if you have a number of authors providing new content,
or if you have inherited an existing site.

» » » Try this to view the structure of a site:

O Click a file in File View. Notice that the file becomes the central document, or reference document,
in Page View.

B Double-click a page in Page View to make it the reference document.

© Click a plus (+) sign to see all of the links on that page.
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@ Place and hold the pointer over any of the files in Page View to see more information about the
Web page itself. This information includes the title, the author, the location of the file, and whether
the page uses frames, Java, ActiveX, or forms.

© Click the filter buttons to hide or show different file types in Page View.
| = Duplicatesl [ Images= | a2 E:-clternals | (2 Unknowns

Filter buttons can reduce visual clutter.




List View

List View offers you control over the display of your site data — you can sort, filter, and print
information, and even export List View data. Using preset filters, you can view information such
as slowly downloading pages, or pages that contain broken links, images, or sound files. After you
have chosen a filter, you can manipulate this information to pinpoint specific pages or files quickly
or arrange the information that you need in a report.

» » » Try this to view slowly downloading pages:

O Click the List View button to view your site in List View.

Lizt
A (lick List View > Defects > Slowly Downloading Pages.
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The default threshold setting for Slowly Downloading Pages is 20 seconds, based on the file's
download speed over a 28.8 modem. The definition of a slowly downloading page varies from user
to user, so the setting for Slowly Downloading Pages is variable.

» » » Try this to modify your slow pages settings:

O Click Tools > Preferences, and then click the Defects tab.

a Type a new download speed in the Slow Page Threshold box (note that the value for file size also
changes), and then click OK. The list reloads with the new slow pages.

This feature applies even when you are accessing the site locally. All local files download quickly,
but SiteCheck tells you the equivalent access rates for users with remote access.



Browser View and Site Properties View

Like Page View, Browser View appears in the right pane of SiteCheck. Browser View offers you the
chance to see your site as visitors will see it.

» » » Try this to view your site in Browser View and Site Properties View:

Q Click the Browser button to view your site in Browser View.

Browzer

When you navigate a
site in Browser View,
the active file is
selected in File View.
However, navigation
outside your site
cannot be shown in
File View.
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Click any link to
browse to that
page. You can
also browse to
external links
within Browser
View.

Site Properties View appears in the right pane of SiteCheck. Site Properties View displays a summary of
your Web site’s statistics.

Q To view your site in Site Properties View, click the Site button.
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the Total Site Size
and Server Type.



Source View

Source View lets you view and edit HTML files. When you use Source View to edit your Web pages, your
changes are automatically updated when saved and are reflected in the other views.

» » » Try this to edit a file in Source View:

O Select a file in any view.

@ (lick the Source button.

Source

(3 Type any changes in Source View.

@ When your changes are complete,

click Save Sre.
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You can use Global Replace to edit text in Source View. Global Replace lets you search for and then
replace text or HTML codes across your entire Web site.

» » » Try this to find and replace text in Source View:

O Click Edit > Global Replace. The Replace dialog box appears.

A Enter the text you
want to find — e.g.,
Burlington, and the
replacement text —
e.g., Lexington.

Replace [X]
Eind: IEulImglUn ﬂ
Replace with ILemngtun :’ Cancel |

™ Mateh whale word only

™ Match case

il iSearch display text only 1
dlonoelcibcinecol Bl

[~ Search unknown file types

Help |

— Select Search display text only

to ignore HTML tags.

Click All Files to
replace text in all files.

® When your choices are complete, click Find Next. When the text is found, a list appears with the files
that contain the search text and the number of occurrences of the text in each of the files.

® Click the Edit File button to replace the text on a file-by-file basis. The file opens in Source View, with

the found text highlighted.

©® Click the Replace button. The text is replaced, and the next instance is highlighted.

® When there are no more instances in the selected file, you can choose to search the next file.



Using Rational Robot, you can record two types of Web site verification points:

> Web Site Scan — Use to automatically check the content of your Web site with every
revision and to ensure that changes have not resulted in defects. You can check for the
following:

— Internal and external links not found

— Pages with broken links or pages that have moved
— Orphans, viruses, and assertions

— ActiveScan entries

— Slowly downloading pages

> Web Site Compare — Use to record a baseline of a Web site and compare that baseline to
your Web site at another point in time.

Create a repository

Before you can record a Web site verification point, you must create a repository. The repository
contains all of the information about your testing project, including test plans, requirements, results,
graphs, and reports. For more information about Rational repositories, see Using the Rational
Administrator manual.

» » » Trythis to create a repository:

O \Make sure that no applications are open on the desktop.

@ From the Windows taskbar, click Administrator.

K
[ 11

© (lick the Create Repository button to create a new repository.
®

4] Type a repository path (in this case, C:\repo1), and then click Next.
© Click Microsoft Access, and then click Next. Continue through the wizard.

O View your settings, and then click Finish.

o Select repo1, and then click Connect. ==



Start recording with Robot

When you record, you use Robot to scan your Web site through SiteCheck. You launch the recording
from Robot. Robot can record both your actions as you navigate through the sample Web site and the
verification points that you insert to check on changes to your Web site.

» » » Try this to start recording:

©  Start Rational Robot. From the Windows taskbar, click Robot.

O  Type admin for the User ID. (No password is required.)

3] Click to start recording. Type a name, and then click OK.
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] | 3‘3“ ﬂ
(5]
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5 verification point.
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4 ait state

™ Apply wait state to verification point

et even: |2 seconds
Timeout after: |3U seconds

— Expected result
& Pazs
" Fail / Click OK.

0K I Cancel Help




Record a Web Site Scan verification point

The Web Site Scan verification point is recorded through a wizard interface. Enter your options for each
screen, and then click Next to proceed to the following screen. At any time, you can click Back to
return to an earlier screen and change your options.

» » » Try this to record a Web Site Scan verification point:

O Before recording a verification point, you must follow the steps outlined in Start recording with
Robot on the preceding page of this Try it!.

O Click Local Site.
The default site is
the sample site,
found at C/.../
Samples/Web/
default.htm.

Select Site

Please select the site you wank to test

Site Type |

€ Intemet Site:

|hnp v unitedmedia. com/comics? =l

& LacaiSitg

[ Fprogremm i bdelakhin =] | Browsa. |

" Previously Saved Site Map
|d #iepo/mandFroject/D efFroi/Seript/vp/oompare web Sie Comparsb x| | Browse,

<nck [ News | cancel Help

©  (Click Next to display the Advanced Options page.

@ Choose your site
options, including
Site Root and
Default Page
Name.

Advanced Options

Advanced Options | /

c:/pragram fles/new/ratianal/sitechk samples/webidetault him

Site Boat,

Intemet Site Roat |

W Read Ertire Site:

Stop AfterLevet [

Fipbinon | Evcude. | e | esims. |

Defeuit Page Name: [defaulthim
I= | File W Emes e Sase Sensr i) //

<Back | Mets | Cancel Help

If the site does not
appear, click Browse
to find it.

+—— You can choose to
read the entire site
or stop after a
number of levels.

| —— You can also set
other advanced
options.

©  Click Next to display the Scan Options page.
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Record a Web Site Scan verification point (cont'd)

® Choose your scan

options and the
type of browser

Sean Options |

that you want to i~ Idenily the types of delecls‘yuu would ke to find

I {ntemal Links ot Found 7| Drphans
emulate for the > EdondlLinks o Fad e
scan. I Pages with Broken Links ¥ Pages Slow To Download

¥ Pages That Have Permanently Moved Slow Page Threshold [seconds] |20

¥ Assertions

~Identify the Browser that you would like to be identified as duing a site scan
& Geneic (" Microsoft Intemet Explorer 3% € Miciosolt Intenet Explorer 4.1
 Netscape Navigator 3.1  Metscape Mavigator 4

Do pouwant to run Rational SiteCheck now to add ActiveScan entries or Assertions?
" ‘es (To enter or update ActiveScan enties of Assertions)
& No (If the ActiveScan entiies and Assertions for this site are up-to-date)
]
L Click No (to avoid adding

ActiveScan entries for
<Back [ Fnsh | Canedl | Hep | this exercise).

©  Click Finish to continue recording with Robot, or click Back to make changes.

®  Click Stop when you've finished recording.

The value of verification points becomes apparent when you play them back. During playback,
you can identify changes or unintentional errors in your Web site as it evolves. This lets you
correct errors before your site becomes public. When you play back a Web Site Scan verification
point, SiteCheck scans the site based on the options that you selected when you recorded the
verification point. If it finds any defects, the verification point fails. For more information about
playing back a verification point, see the Using Rational Robot manual.

» » » Try this to view Web Site Scan results:

O After you play back a verification point, the playback is listed in the Rational LogViewer. To examine
the results of your Web Site Scan, double-click the event in the LogViewer. SiteCheck starts and
displays the All Defects List View.

@  (lick each of the View buttons to see more details about the Web Site Scan. For more information
about these views, see the preceding pages of this Try it!.

® 4 e a

Fage List Source Site Browser  Active



Record a Web Site Compare verification point

Now that you've recorded a Web Site Scan verification point, you can use your knowledge to record a
Web Site Compare verification point. SiteCheck provides you with comparison tools that compare any
two sites.

» » » Try this to record a Web Site Compare verification point:

O Before recording a verification point, you must follow the steps outlined in Start recording with
Robot in this Try it!.

A  (lick the Baseline select Site________________________________________|

Site tab. Pleass select the site you want to test.
(3) Click the Baseline Site | Comparison Site — Click the site
. . © Intemet Site type and type
Comparison Site [ i the path
tab.  Local Site
Note: If you are [e#program h\es;‘newflalmnah‘sllecy_ eb/default.him = | e
USing a site ma P, & Freviousiy Saved Site Map
make sure that it'S Id/repufman/?m\eclfDEFF‘rmeant/vp/cnmpareWeb Site Compare.b =] || Browse
the Baseline Site.
Bk [Hewts | Cancel Help
@ Click Next to display the Advanced Options page.
-
© Choose your site Advanced fot
options, including E ]
Site Root and o dprogram Jes/web/default him | You can choose to
Default Page Site oo [T read the entire site

Name. Intemet Site Rt | or StOp aftera

Default Fage Mame: [defaul him number of fevels.
I File Names Are Qaseﬁe}wum/
¥ Read Ertire Site

Stop After Level |5—

ETE e | Exclude. | Aliases. | izl

cgack | Met> | Caneal Help

® Click Next to display the Scan Options page.
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Record a Web Site Compare verification point (cont'd)

@  Set scan options
for both Baseline
and Comparison
sites.

Bassline Gile Compaison Site |

~Idertity the types of defects you would ke to find
I | Irternel ks Hot Found 7| Grphins

I¥ External Links Not Fourd I | inises

1% | Estes /it Broken ks I | Faes Sl To Dored

I= | Pages Tt Hisve Bemanertl oved SlowiFage Tfrestold (seconds] j20

I= [ sseiiions:

~Identity the Brovwser that you would fike to be identified as duing a site scan
& Geneiic  © Microsoft Intemet Explorer 3% € Micrasoft Intemet Explorer 4.x

" Netscape Navigator 3.x " Netscape Navigator 4.5

Do you want to un SOA SiteCheck now to add entries o
" Yes [To enter of update ActiveScan entries or Assertions] |
 No_[If the ActiveSean entries and Assertions for this site are up to datef

Scan Options

/F— Choose the type of

- browser that you

want to emulate for
the scan.

Click No (to avoid adding

ActiveScan entries for this
exercise).

cBack | Fimsh | Coedl |

|

®  Click Finish to continue recording with Robot, or click Back to make changes.

©  Click Stop when you've finished recording.

Once the recording is complete, you can play back the verification point and load it through the
LogViewer to see your results. For more information, see the Using Rational Robot manual.

» » » Try this to view comparison results:

O \When the
verification point
is played back and
loaded through
the LogViewer,
SiteCheck opens.

Click View =2
Comparison View to
see comparison
results.

2 & ‘ & @ o -4 @ B o2 e a g ‘ *
Open Compsie Save  Pinl | Home Felsd iy | Fage Lsl  Souce Sle Biowser Acive | Comp | [

)

Click Print to print the

> Fonet T DT IEQ

General Information

Comparison Finished April 9, 1998 11:32 AM

Baseline Site: cujrational Tjsamples/oreb/def:
Scanned April 9, 1998 11:32 AM

Rational SiteCheck Site Comparison =

report.

Click the links to view either

Comparison Site: e iles rati
Scanned April 9, 1998 11:32 AM

dded Deleted Mo

HomlFles| | [ 21 [ 0

ImageFlles| 0 | 41 | 0

Orphan Files| 216 | 3L 9

Othes| 0 | 23 | 0

Bxtemal Links| 0 || 1 [

_,ﬂ ar [129 [ o
I I |

the Baseline or Comparison
site.

| —— Click each item to view a
detailed list of files and
attributes.

O  Click File > Export Comparison to save the reports in HTML format. Choose a dedicated directory
for the reports because the number of files may be large.



Test active content

SiteCheck lets you preview and test forms and other types of active content on your Web site. The first
time SiteCheck recognizes a page with a form (or any other active content), it asks whether you want to
switch to ActiveScan View. When you test active content in ActiveScan View, you see the results
immediately.

» » » Try this to test active content:

©  You can test active content as part of a Web Site Scan or Compare verification point. When
recording with Robot, follow the procedure Record a Web Site Scan verification point in this Try it!.

@ Do you want to run 504 SiteCheck now to add ActiveScan entries or Azsertions?
* ez [To enter or update ActiveScan entries or Assertions) ———————————— Click Yes to test active content.
" Mo [If the ActiveScan entries and Assertions for this site are up ta date]

©  Click Finish to continue recording with Robot, or click Back to make changes. Once you click Finish,
SiteCheck opens in ActiveScan View.

e ChOOSE an |..-- ..-._._-.-.|-|...| i) - Riadiansl Sielhe
option from the el Ace dmMDuea s w
list of locations, b tenan s il g
- cotushanal! fesmplende [ Aere can Ervme st i |
shown on the B0 e CR— ' '
right, and then e — e Ac“vefca” entries
. W12 e Pl e ke b are automatica
click Got " recorded here g
8 ool e b o0 b e onthe page e bt o e ey )
move will be completed on time. Call or vl any of cur 16 -
posilonal offices for all your moving nesds. We deliver 1o
over 1600 destinaiions worldwlde. And remember, st X
Buelingian, we care. L —— An Active page
is shown here.
Hothwatin J ActiveScan entries
Eoutheastam
are made by
=] performing actions
or submitting data
Call Burlington today into forms.
0 | =fal |.|ﬂ
e e e e e
Note the "a" icon, which shows that the

page has active content.
©  Once you have made your ActiveScan entries, click File & Exit to close SiteCheck.

® Click Stop when you've finished recording.
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Use Assertions for quality control

Assertions allow you to set conditions on one page or all pages for analysis. For instance, you can
ensure that each page has a link back to your home page, or that each page has a title, or that each
sub-page has the correct background. This lets you impose an increased level of quality control

on your site.

» » » Try this to use Assertions:

O  vou can create Assertions as part of a Web Site Scan or Web Site Compare verification point. When
recording with Robot, follow the procedure Record a Web Site Scan verification point or Record a
Web Site Compare verification point in this Try it!.

@ Do you want to un S04 SiteCheck now to add ActiveScan entries or Azsertions?
% ez [To enter or update ActiveScan entries or Assertions] ———————— Click Yes to create Assertions.
Mo (If the ActiveScan entries and Assertions for this site are up to date)

©  Click Finish to continue recording with Robot, or click Back to make changes. Once you click Finish,
SiteCheck opens in Page View.

@ Click Edit > Global Assertions. The Assertions dialog box appears.

© (lick Add to create a new Assertion. ® Choose Assertions options, and then click OK.
.
Assertions [<] -~ Select Typr CIICk
U & Presence0f € Abssnce OF Presence Of.
Esisting  Display Test © TagTet & Link —_—
Type [ Value | £ Frame £ Fom £ Active Contiol §\C/I'Ck Link.
< Presence 0 Link /detaulthtm © Javadglet € WBSoipt C JavaScrit
<3 &shsence Of Display Test [Case Sen. . Lesington
%4 Presence Of Display Text burington " Custom
<3 Presence Of Tag Text tite: Link.
default.htm .
To see if all
Edit.. Remaove pages /nc/ude a
~N— .
ok | Coesl | He | link to the home
I Case Gensiive page, specify
. . . Check whether an HTML pags has a link to anather [default.htm.
The Add Assertions dialog box lets you specify il or page
the type of content you want to test. The options
include Display Text, Tag Text, Links, Java Applets, [ ok | Coesl | mep |
and ActiveX controls.

9 Once you have created your Assertions, click OK to close the Assertions dialog box.

®  Click File > Exit to close SiteCheck.

©  Click Stop when you've finished recording.



What's next

You have just explored some of the testing possibilities of Rational SiteCheck. SiteCheck offers a variety
of refinements that allow greater precision in testing. To record more verification points, try some of the
following:

» Test access to sites through your corporate firewall. Select the Proxies button in the
advanced section of the Open dialog box to specify your firewall settings.

» Exclude portions of a site from a scan. When opening your site, click Exclude, and enter the
directories you do not want to scan.

» Create a "snapshot” of your site structure at a given point in time by saving a site map.
Click File > Save Site, enter a Site Map name, and choose a location for the saved file.
This operation does not save changes or updates to actual files, but stores an image of your
site’s structure.

» Use Rational SiteMonitor to automatically check for defects on your Web site. SiteMonitor
lets you run scans of any site, at any time. You can use it to scan your complete site for
defects, check your server, compare two Web sites for differences, or compare your site with
a site map to check for changes. To open SiteMonitor, click Tools = Rational SiteMonitor.

This Try it! has covered only the basics of using SiteCheck. If you need more information, see the
SiteCheck Help.

Icons

Some of the more common icons found in SiteCheck are shown here. For additional icons, see the
SiteCheck Help.
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External links

a Files not yet parsed ﬁ_@ Sound files Unknown file types E}o Broken external links
Q Moved, renamed, or | :[sz] | Mailto links Compressed files A Adobe Acrobat
deleted files Portable Document
Format
il | Active content, no = | Active content, with " | No ActiveScan ke | ActiveScan entries,
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