Rational LoadTest: Try it!

For Virtual User Testing of SAP Applications

WELCOME TO RATIONAL LOADTEST

Use this Try it! to discover how easy it is
to test the performance of your SAP R/3
applications. In minutes, you’ll understand
the power behind Rational LoadTest
(a component of Rational Suite
PerformanceStudio) as you build tests
that verify your system can handle:

. » Large numbers of users concurrently

executing transactions

» Contention among multiple clients
accessing critical data

» ‘Worst-case scenarios’ occurring at
busy times

If you’re using SAP R/3 applications, you need Rational LoadTest, a component
of Rational Suite™ PerformanceStudio™ Rational LoadTest is the leader in

automated performance testing of client/server, Web, and ERP applications.

Rational LoadTest lets you plan, develop, and execute performance tests
against your SAP R/3 application, regardless of your R/3 hardware platform

or database server type.

As you use the testing tips in this card on your SAP application, you’ll quickly

discover how easy it is to create performance tests using LoadTest.

To find out more about LoadTest and PerformanceStudio, be sure to take a look
at the Getting Started with Rational Suite PerformanceStudio manual as well as

the other PerformanceStudio documentation and online Help.

» » » Find out how Rational puts quality to the test. » » »

Rational

the e-development company™



Create a repository and log in

Before you can begin testing, you need to create a repository. A repository contains all of the
information about your testing project including test documents, requirements, scripts, logs, defects,
gueries, and reports.

> » p Trythis:

O Install Rational Robot according to the instructions in the Getting Started with Rational Robot manual.
Also, make sure to install the SAP protocol license.

@ Click Start > Programs > Rational Suite PerformanceStudio > Rational Administrator.

© Click File > Create Repository.

Create Repository - Path [ 7] =]
Enter the path for the new Fational repository.
Type C:\SAPRepo for the name of _— Browse..
the repository where you’ll store your
tests.
Create Repository - New or Existing ClearQuest Database [7]x]

Click Next until you come to the
Create Repository - New or R e S e R e
Existing ClearQuest Database

existing database.

& ficale anew Cieartjuest dalabass

page. Type VU for the Rational |

ClearQuest database name. If your — Descipior: |

application has defects, you’ll enter € Attsch an esising Cleaiues! databass

them in this database later on. T [ R |

SAMPL

Continue to click Next to accept
all of the defaults.

<Back | New> | Cancel Help

At the end, click Finish, and then

click OK.
9 Click File > Connect. Connect to Repository HE
Rational
|| Browse... |
Select C:\SAPRepo, and then — IC\S4PRepn
click OK.

Rational Repository Login

User [D:

Iadmin

Password

|
Click OK to log in as the admin. I
No password is needed. [ Ok Cancel




Determine the SAP host name and system number

Before you test your SAP application, you also need to determine the host name and system number.
You can either ask your system administrator or follow the steps on this page to make a copy of the

host name and system number.
> > » Trythis:

(1] Right click the SAPGUI icon for your application,
and then click Properties.

@® In the Properties dialog box, click the Shortcut tab.

(3] Copy the host name by highlighting it and pressing
CTRL+c. You'll need it for the next set of steps.

The host name is a series of one
or more computer names and/or
IP addresses delimited by slashes

Open
Scan for Minses
Quick Yiew
AddtaZip

Send To 3

Cut
LCopy

Create Shorteut
Delete
Rename

Properties

207.121.200.200 Properties EHE

General  Shortcut |

R/3
207.121.200.200
El-d

Target type: Application

Target location: SAPGLUI

and uppercase letters, often with
a trailing port number.

You need the host name in order
to connect to your application.
(See the next page.)

¥ | Rt Separate MemomiSpace

Start in: ID:\SAPgui.S‘I hTEMP

Shortcut Key: INune

Bun: I Mormal window j

Find Target... | Qhangelcon...l

ak. I Cancel | Lpply




Capture a virtual user script

When you use Rational LoadTest to test the performance of your application, you’ll record a script that
emulates an actual user working with the SAP application. The script, called a virtual user script,
captures the requests and responses that occur between the client application and the database server.
For more information about creating virtual user scripts, see the Using Rational LoadTest manual and
the online Help. For information about the VU scripting language, see the VU Language Reference
and the online Help.

> » p Trythis:

O click Start > Programs > Rational Suite PerformanceStudio > Rational ERP vu to display
two dialog boxes.

Save script file as: HE
. Save jn: {23 Script - % =
Before you record a script, you have to name - I d —I ﬁl !I
it to create a placeholder for it. You then save extemC S
it in the repository you are connected to. includs B SAPTest2 e

3
vp
win32

@ |n the File Name box, do not accept the default path. dev_””””-agi
Instead, make sure to type the following path: e
C:\SAPRepo\Project\Default\Script\ERPVU
where SAPRepo is the repository you created, and

File name: IE \SaPRepo\ProjectsDefaulthS cript ER YU Save I

. . =1 tope: -
ERPVU is the name for the script you'll record. el B A e |
© cClick Save.
O In the Host Name box, paste the Hostname: [7H/207.121.200.200/H/204.73.193. 244/H/204.73.199.37/5./3200 =
host name and system number you System Number: [ag
just copied. If necessary, delete the
program path, for example Connect | Cancel |

C:\SAPGUI31H\SAPGUI.EXE.

© cClick Connect.

[ElsaP R/3 =] B3|
User System Halp
v [ Ji&leE XAl Anan?
: Log off | New password B
Log in. ‘
Client 56 =
User [pational

Password ~ [wxwxx

Language [E

LM (000 [pali 01176 [OVR [S238M




Capture a virtual user script (continued)

(7] Navigate through the application. Rational ERP vu records whatever you do. (Note: To record VU scripts
other than SAP VU scripts, you would use Rational Robot.)

[E Display Deliv.Free of Charge 5455: Overview [_T00=]
ales document  Edit Goto  Extras  Environment  System  Help
/vu Jel¢eaX AHM BHOD ? —
Make menu selections. | Document flow | g Sold-to party | " Orders | 6 Sales summary | & Status overview | °f

Deliv.Free of C 5455 Net value 6.66 [DEH |

Sold-to party 99999 IDES Marketi il { Lind: Be 123 } D-20001 Hamburg
99999 IDES Marketing ilung / Lind, Be 123 } D-20001 Hamburg
6100000069 PO date 06/05/1998 C
Enter keystrokes and Sales | Item Overview| Ordering party | Procurement | Shipping | Reason for rejection|
transactions. Req.deliv.date IF 86/ 0571998 Deliver.plant
= Complete div. Total weight 3808 [iG
l_ Yolume 6.6008 l_
' Pricing date 06/ 0571998
[2BB1 14 Days 3%, 30/2%, 45 Incoterms [FH
Order reason 999  Marketing material f. Mailing
Sales area [Tooe / |1_n.l |ﬁ Germany Frankfurt, Final customer sales, Cross-division
1 \ Item | IMalErial | Order quantity |SU| s | D ipti |J;[
y
| Consider the subseguent documents LCH (850) [pall 01176 [OVR 1219 PM ;.

©® Be sure to turn Exception Handling on if an unexpected, unwanted window appears during recording.
You can turn it on in two ways:

=] E3

|

| & Stat - | B Either click this icon
SR s e to turn on Exception Handling...

[ 66 [nEn
RatlERP

An ermor of a warning condition waz detected. Do pou want to activate exception handling mode?

...or, click Yes if this message
appears.

© Be sure to click the icon to turn Exception Handling off after you dismiss the unexpected window.

% Default - Rational Robot - [ERPYU ] = |
[i File Edt Yiew Record Debug lnset Tools ‘window Hslp NEES

Turning on Exception Handling

22 BEG sRo e N s adhl
=

if(UUErpCompareEvent( " 8182", inserts an ‘if’ statement in
"SAPMULSA M. th ; t I : t t B d t
"Display Sales Order: Initial Screen”, € virtual user script to Indicate
"E: Document TYPD does not exist", the code for the unwanted
12) 1= 8) {
window. This allows successful
/* UBAK-UBELHN = "5455" x=f . !
set Think_avg = 17987; playback of the script if the

emulate [“ERPUUG12"] UuErpSetValue{1, datapool_wvalue{UuErp_DP, "UI3|1K7UI3ELIJ unwanted WindOW doesn’t
/# UBAK-UBELH =/

set Think avg = 8; appear during playback.
emulate [“ERPUUB13"] UuErpSetCurPosByIndex{1), VuErp_log_message;

4l | _'l;I

O After you finish recording the script, log off from Rational ERP vu.




Build a LoadTest schedule

A LoadTest schedule represents the user load that you want to apply to your application. A schedule
contains one or more user groups to emulate the types of people who use your application, as well as

the number of users in each group. The schedule also contains scripts that emulate the activities that the
users perform.

> >

» Try this:

O Click Start > Programs > Rational Suite PerformanceStudio > Rational LoadTest.

FRational Repository Login

User D
Iadmirl

Password /
|

HRepositary Path

Accept admin as the User ID
and do not enter a Password.

Select the repository you

Accept Default as the project.

|
IE:'\SAPFlepo 2] Browss | created — SAPRepo.
Project
IDefauIt ;!
Ok I Cancel |
Click OK to log in.
@ |5 e
D8 e HG se 05 065 K
On the LoadTest toolbar, click New Schedule.
©

Create a new schedule using
" Performance Testing Wizard
€ Functional Testing "izard
" Egisting session

" Esisting schedule

[~ Dot show in future

]

Cancel Help

Select Blank Schedule,
and then click OK to continue.



Build a LoadTest schedule (continued)

(4] Right-click User Groups, and then click Insert > User Group.

B Schedulel® B
A user group represents one e — —
type of person who will use BT - oo e
the application. 000 scenains

& Compufers

™ User Settings

© Accept User Groupl as the name

User Group [ 7] & Futine
and 1 as the number of users, and M
. - k. Temmination
then click OK. [[Tzer Grougt
~ User Count #a# Shated ariables
Make user count:
You’'ll start with one user to test & Eixed
the schedule and then add more Nurmber: 1 =

users to put load on the application.

" Scalable

Percentags; |0 %

— Camputer
[MaSTER =]
Multiple Computers
akK I Cancel I Help I
B Schedule1= [-[OIx]
. . Schedule Event Dependencies
(6 Right-click User Groupl:luser(s), ) 8% UserGoues B
and then click Insert > Script. L R E o
™ User Settings
Add Scripts [2]x] - .
untime
@ Make sure to type ERPVU for the seitrone [P0 S
script name, and click OK. o e I L9 Temf=t
X R [ “ Shared Variables
ERPVU was the script that you
saved and created a placeholder for
before you started to record.
® select VU, and then click OK. —
© Click File > Save As, accept the default Bz |
. Iterations: |1 3 Delay between terations: |0 * Seconds
schedule name, and then click OK. S Eh
[~ Scheduling
ot EEC—
Dependencies: | =l Wuticke Dependengies
[[3 Concel | Popies. | Hep |




Play back the script

Now it’s time to make sure that one virtual user works correctly by running the schedule you created.
As the schedule runs, LoadTest provides numerous views so you can watch the progress of the test.

> » p Trythis:

O From LoadTest, click Run > Schedule, accept Schedulel as the schedule name, and then click OK.

@ After the schedule starts to run, click Monitor > Script.

LoadTest displays the log and the individual script
commands as they execute.

i Script View: User_Group1[1] - Cerl.s

[Script30060 succceded

Log < i 1]: script = Cen26), source = Cert.s(205) >>>
Script30061 succeeded

<< emulate[Script30062]: script = Cerl[27). source = Cert.s[208) >>>

Script30062 succeeded

<< emulate[Script30063]: script = Cen{26), source = Cert.s210) >>>

Script30063 succeeded =
F >
Al

I 3 Py N

{* SCREEN = "2302", F‘HOGHAM "'SAPMFO5SA", TITLE “Enter Vendor pa m:nl Create Vendnl Hem" *}

te ['Seri SqaSa ip ip
Script iiVerify Evem[ 2302 SAPMFOSA" "Enter Vendor payment: Create Vendor liem’ .6, VerifySereeninfo,VerifyMessageLine L
p — user_exitf-1,"VerifyEvent [{"Script30067y"] failed");

I* BSEG-WRBTR = 401 *
cmulﬂl:['Sr:nplfl[l[lﬁﬂ']quSupSeWulu:[‘ld BSEG_WRBTRI), "Scri I, "Seri failed' _'L|
4l | >

| Sraesie| || Suspend | feone || Teminete | | Eeciin

© After the schedule finishes running, click File > Exit to close LoadTest.

What’s next

You have just recorded an SAP R/3 session and played it back with one virtual user. You can record
scripts with different types of users. And, you can increase the number of users for each user group
and build them into schedules to form a real-life performance test.

The value of schedules becomes even more apparent when you scale up the number of users in your
test — to hundreds or thousands of virtual users — simply by increasing the number of usersin a

schedule. This lets you identify system performance errors and bottlenecks before you deploy your
application.

For detailed playback instructions and more information about schedules, take a look at the Using
Rational LoadTest manual and the online Help.
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