
Getting Started
with Rational Suite
PerformanceStudio
Version 2000.02.10



ii

Getting Started with Rational Suite PerformanceStudio

Copyright  1999-2000 Rational Software Corporation. All rights reserved. The contents of this 
manual and the associated software are the property of Rational Software Corporation and are 
copyrighted. Any reproduction in whole or in part is strictly prohibited. For additional copies of this 
manual or software, please contact Rational Software Corporation.

Rational, the Rational logo, PerformanceStudio, SiteCheck, TestFactory, TestStudio, 
Object-Oriented Recording, and O bject Testing are trademarks or registered trademarks of Rational 
Software Corporation in the U nited States and in other countries.  Java and all Java-based marks are 
trademarks or registered trademarks of Sun Microsystems, Inc. in the U nited States and other 
countries. All other names are used for identification purposes only and are trademarks or registered 
trademarks of their respective companies.

U .S. GO VERMEN T RIGH TS. U se, duplication, or disclosure by the U .S. Government is subject to 
restrictions set forth in the applicable Rational License Agreement and in DFARS 227.7202-1(a) and 
227.7202-3(a) (1995), DFARS 252.227-7013(c)(1)(ii) (Oct 1988), FAR 12.212(a) 1995, FAR 
52.227-19, or FAR 52.227-14, as applicable.

Revised 04/2000

This manual prepared by:
Rational Software Corporation
20 Maguire Road
Lexington, MA  02421
U .S.A.

Phone:
800-433-5444
408-863-4000

E-mail: support@rational.com
Web: http://www.rational.com

P/N  800-023368-000



ã ã ã Contents

Preface
Resources. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . v

U sing H elp  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . v

Contacting Rational Technical Publications . . . . . . . . . . . . . . . . vi

Contacting Rational Technical Support  . . . . . . . . . . . . . . . . . . . vi

1 About Rational Suite PerformanceStudio
The Path to Successful Performance Testing. . . . . . . . . . . . . . . . . . 1-2

Setting U p Your PerformanceStudio Test Lab. . . . . . . . . . . . . . . . . 1-4

Types of Tests. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-5

Performance Tests. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-5

Recording Scripts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-7

Types of Scripts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-7

Methods of Recording  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-7

Creating Schedules. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-8

Running and Monitoring a Schedule . . . . . . . . . . . . . . . . . . . . . . . . 1-9

Analyzing Results . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-10

Where to Look N ext. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1-11

2 Before You Begin
Tutorial Requirements. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-1

Copying the Tutorial Files. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2

Locating Internet Explorer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2

Specifying Internet Explorer Settings . . . . . . . . . . . . . . . . . . . . . . . . 2-3

Setting U p a Repository for the Tutorial  . . . . . . . . . . . . . . . . . . . . . 2-3
ii i



Contents
3 Tutoria l
Is This Tutorial for You?. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-1

Step 1: Planning a Test  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-2

Identifying the H ardware and Software Required for Testing .3-2

Mapping Out Your Testing Plan . . . . . . . . . . . . . . . . . . . . . . . . .3-3

Where to Go for More Information  . . . . . . . . . . . . . . . . . . . . . .3-3

Step 2: Setting Recording O ptions . . . . . . . . . . . . . . . . . . . . . . . . . . .3-3

Starting Rational Robot  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-4

Setting Recording Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-4

Step 3: Recording Scripts  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-8

Where to Go For More Information . . . . . . . . . . . . . . . . . . . . .3-20

Step 4: Examining the Recorded Scripts  . . . . . . . . . . . . . . . . . . . . .3-21

Where to Go For More Information . . . . . . . . . . . . . . . . . . . . .3-24

Step 5: Generating Realistic Data to Send to the Server . . . . . . . . .3-24

Where to Go For More Information . . . . . . . . . . . . . . . . . . . . .3-27

Step 6: Designing a Schedule to Represent Your Workload . . . . . .3-28

Inserting U ser Groups into Your Schedule  . . . . . . . . . . . . . . .3-30

Inserting Scripts and Selectors into Your Schedule . . . . . . . . .3-32

Saving the Schedule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-38

Where to Go For More Information . . . . . . . . . . . . . . . . . . . . .3-39

Step 7: Running the Schedule. . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-39

Setting the Information You See During a Schedule Run . . . .3-39

Running a Schedule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-41

Monitoring the Schedule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-41

Where to Go For More Information . . . . . . . . . . . . . . . . . . . . .3-43

Step 8: Running Reports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-44

Where to Go For More Information . . . . . . . . . . . . . . . . . . . . .3-48

Wrapping U p . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-48

Glossary

Index
iv



ã  ã  ã Preface
Rational Suite PerformanceStudio is a sophisticated tool for automating 
performance and distributed functional tests on client/server systems.

This manual introduces Rational Suite PerformanceStudio and provides a tutorial 
for first-time users. The manual is intended to help application developers and 
testers use PerformanceStudio.

Other Resources
ã This product contains complete online H elp. From the main toolbar, 

choose an option from the H elp menu. 

For information about context-sensitive H elp, see the following section.

ã All manuals for this product are available online in PDF format. These manuals 
are on the Rational Solutions for Windows Online Documentation CD.

ã For information about training opportunities, see the Rational U niversity 
Web site: http://www.rational.com/university.

Using Help
This product contains context-sensitive H elp for dialog boxes, menus, and toolbars.

Dialog Box Help
Most dialog box H elp includes overviews and detailed item information. 

Click th is to  see an 
overview of the d ia log box.

Click th is and then click an  
item  to see in form ation 
abou t the item .
v



Preface
Menu Command Help
For menu command H elp, highlight the command and press F1, or click the H elp 
button on the toolbar and select the command. A brief description of the command 
also appears in the status bar. 

Toolbar Button Help
For toolbar button H elp, pause the pointer over the button. A yellow ToolTip 
appears below the button, and a brief description appears in the status bar. For more 
detailed information, click the H elp button on the toolbar, and then select the button 
for which you want more information. 

Contacting Rational Technical Publications
To send feedback about documentation for Rational products, please send e-mail 
to our technical publications department at techpubs@rational.com. 

Contacting Rational Technical Support
If you have questions about installing, using, or maintaining this product, 
contact Rational Technical Support as follows:

Rational Technical Support

Location Contact Information Notes

North America Telephone:
800-433-5444 
408-863-4000

E-mail:
support@rational.com

Please be prepared to supply 
the following information:

– Your name, telephone number, 
and company name

– Computer make and model

– Operating system and
version number

– Product release number 
and serial number

– Your Case ID number (if you 
are calling about a previously 
reported problem)

Europe Telephone:
+31 (0) 20 4546 200

E-mail:
support@europe.rational.com

Asia Pacific Telephone:
+61-2-9419-0111

E-mail:
support@apac.rational.com

World Wide Web http://www.rational.com Click the Technical Support link.
vi
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About Rational Suite PerformanceStudio
If you’ve installed Rational Suite PerformanceStudio, you’re on your way to 
ensuring that your business-critical client/server and Web applications perform
exactly as you want. With PerformanceStudio, you can test the capacity, 
performance, and stability of your systems under real-world, multi-user worklo

Here are just some of the things that PerformanceStudio lets you do: 

ã Model complex workloads without programming. 

ã Monitor and analyze the response times that users actually experience und
different workloads. 

ã Automatically maintain accurate user emulation during playback. 

ã Verify correct playback of changing Web page content. 

ã Automatically replace literal data in scripts with variables, and then associat
the variables with test data.
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About Rationa l Su ite Perform anceStudio
The Path to Successful Performance Testing

1 . Install Rational Suite 
PerformanceStudio. For information 
about installing PerformanceStudio, 
see Installing Rational Suite.

2 . Create a Rational repository in the 
Rational Administrator to store your 
test assets. For information about 
creating a Rational repository, see the 
Using the Rational Administrator manual.

3 . Record scripts in Rational Robot that 
emulate client/server conversations. 
For information about recording GU I 
scripts, see the Using Rational Robot 
manual. For information about 
recording virtual user scripts, see the 
Using Rational LoadTest manual.
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The Path  to Successfu l Perform ance Testing
4 . Create schedules in Rational 
LoadTest that emulate clients sending 
requests to a server. For information 
about creating schedules, see the 
Using Rational LoadTest manual.

5 . Run and monitor the schedules as they 
add load to your database and Web 
servers. For information about running 
and monitoring schedules, see the 
Using Rational LoadTest manual.

6 . Analyze the results of your tests. For 
information about analyzing results, 
see the Using Rational LoadTest 
manual.
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About Rationa l Su ite Perform anceStudio
Setting Up Your PerformanceStudio Test Lab

Before you deploy your business applications, you want to know if they perform as 
you expect them to. With Rational Suite PerformanceStudio, you need only a few 
computers to emulate the real-world environment of complex client/server 
interactions and extensive Web commerce. 

You can transform your test lab into an activity center that emulates hundreds or 
thousands of users sending and receiving information between your client 
applications and their database, application, or Web servers. 

In your PerformanceStudio test lab, the point of control is the computer where the 
PerformanceStudio software is installed. From this Master computer, you can 
schedule, coordinate, monitor, and analyze the playback of GU I users and virtual 
users. 

M aster com puter
WinN T4 .0  or Win 2000

WinN T4 .0 U N IX , 
WinN T4 .0 ,

Virtual users

W in 95 Win 98
Server

Agent com puters

GU I users

Win 2000

Win 2000
1 -4



Types o f Tests
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GU I users test the client application response time, stability, and functionality of live 
clients. Virtual users test application, database, or Web servers as well as the network 
between the virtual users and these servers. Virtual users add load by emulating 
hundreds or thousands of client application sessions, or users connected to a server, 
without requiring an actual computer for each user.

In your test lab, you can use the Master computer by itself to play back scripts,
or you can distribute scripts to various Agent computers that extend the computer 
resources of the Master. U sing the Master and its Agents to play back scripts 
creates large workloads that test server performance. Agents can play back numerous 
combinations of virtual user and GU I user scripts, providing you with the flexibility 
and scalability you need to meet your testing requirements. 

Types of Tests

PerformanceStudio lets you answer the following questions before you deploy 
your applications:

ã H ow will the system perform in a production environment?

ã H ow long does it take for the database transaction to complete? 

ã H ow quickly was the server able to respond under heavy workload conditions? 

ã What are the usage patterns that impact performance? 

ã Where do bottlenecks exist? 

ã Where is the application’s break point and how can it be avoided? 

To help you discover the answers to these questions, Rational Suite 
PerformanceStudio provides you with a variety of tests for use throughout the 
testing lifecycle.

Performance Tests
A perform ance test helps you determine whether a multi-client system is 
performing within user-defined standards under varying loads. Performance te
require the LoadTest software. Performance tests typically involve loading the se
with many virtual users. For example, you might have a timer in one virtual use
find out how much time a query takes when 1000 other virtual users are sendi
requests to the same server at the same time. The term “performance testing”
includes load, stress, contention, and configuration tests. These tests let you 
accelerate the performance test cycle and achieve meaningful, accurate results
1 -5
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Load Tests
Load testing lets you test client or server response times under heavy workloads. 
These tests help you compute the maximum number of transactions a server can 
handle over a given time period. Also, when a client/server system uses load 
balancing or a distributed architecture, load testing helps ensure that the load 
balancing or distribution methods work as designed.

Stress Tests
Stress testing runs your client application under extreme conditions to see whether 
it or the server “breaks.” You can perform a stress test by continuously running
client application for many hours, performing a large number of transactions, o
having hundreds of emulated users perform the same operation at virtually the 
moment. 

In addition, as you stress the server, you may discover insufficient memory, 
unavailable services or hardware, or diminished shared resources.

Stress testing helps you make sure that your server or client application can ha
production conditions.

Contention Tests
Contention testing involves running tests to simulate a live user environment—
for example, users accessing the same database record which can reveal probl
areas such as locking, deadlock conditions, and concurrency controls.

Contention testing is often difficult to perform because it requires precise 
coordination between users. With Rational Suite PerformanceStudio, you can 
synchronize user tasks. You can also conduct multi-user scenarios in which 
emulated users wait for conditions to be satisfied before they continue running
For instance, while one virtual user adds a record to a database, a second virtua
waits for the first user to finish its transaction before attempting to read the rec

Stress ContentionLoad Configuration

Perform ance Tests
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Record ing Scripts
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Configuration Tests
In today’s heterogeneous client/server environments, each user’s computer 
can have a different mix of hardware and software, creating a risk that the applic
will run on some machines and not on others. With configuration testing, you c
ensure that your product will continue to run on multiple platforms. You also 
determine the minimal and optimal configuration of hardware and software tha
you need. 

Recording Scripts

In Rational Suite PerformanceStudio’s point-and-click environment, you can rec
scripts that emulate the way users will actually use your system. 

Types of Scripts
PerformanceStudio provides two types of scripts—virtual user and GU I scripts

Virtual user scripts test the performance of your client applications as they inter
with your application, database, and Web servers. A virtual user script represen
requests to a server, such as SQL and HTTP, and checks the server response
those requests. 

GU I scripts test the response time and stability of live clients as well as testing t
properties of the client application. 

Methods of Recording
Rational Suite PerformanceStudio ensures that the scripts you record accurate
reflect the traffic between clients and servers, regardless of the transmission ra

PerformanceStudio lets you record user activity in three ways: 

ã API  – Records API calls between the client software and the client libraries 
communicate with the server. API recording is the recommended approach
all Windows-based clients. PerformanceStudio and the client application a
both installed on the client computer in API mode.

ã N etwork – Records TCP/IP traffic transmitted across the network. N etwor
recording is recommended when the client computer does not support AP
recording.

ã Proxy – Records the same kind of traffic as network recording, but the clien
routes the traffic through a proxy computer. Proxy recording, a specialized fo
of network recording, is used on high-speed or switched networks.
1 -7
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Generating Scripts
With PerformanceStudio, you can create scripts simply, without any coding. 
PerformanceStudio’s DataSmart™ recording lets you instantly generate test-re
scripts and test data. With this unique type of recording, PerformanceStudio 
automatically replaces literal data in a script with variables, and then associates
variables with data from your databases or from PerformanceStudio data-read
datapools. By using realistic data from datapools, PerformanceStudio ensures 
your virtual user scripts accurately emulate the activities of different users send
requests to a server.

With PerformanceStudio, you can create, extend, or change a script manually.
PerformanceStudio offers two scripting languages VU  (similar in syntax to C) and 
SQ ABasic (similar in syntax to Microsoft Basic). With PerformanceStudio, you c
also call external C libraries or programs.

As you record, PerformanceStudio lets you enhance your scripts. You can add timers 
to bracket a series of activities, comments to annotate your scripts, and blocks to 
identify transactions. PerformanceStudio’s TransactionSmart™ Analysis 
automatically gathers transaction times for these blocks as a whole and for eac
individual command that comprises these transactions. With this information, y
can immediately look inside a transaction to diagnose any problems with individ
server requests.

All of these features make your recorded scripts easy to record, read, and main

Creating Schedules

A Rational Suite PerformanceStudio schedule provides a controlled, flexible way to
create realistic user workloads that closely model actual user workloads.

With PerformanceStudio’s LoadSmart™ scheduling, you can model complex 
workloads without programming. For instance, you can model hundreds of us
applying stress to an application’s database servers or thousands of hits on a We

The building blocks of every PerformanceStudio schedule are emulated users
organized into user groups, such as Data Entry, Accounting, and Sales, and the u
activities they perform, encapsulated into scripts.
1 -8



Running  and M on itoring  a  Schedule
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In the schedule, you can specify a weight for each user group to create realistic usage 
models. For example, you can specify that 20 percent of the users belong to the 
Accounting group, 30 percent to the Data Entry group, and 50 percent to Sales. 
Then you can create scripts that represent the activities of these groups and add these 
scripts to a schedule to emulate realistic workloads.

Running and Monitoring a Schedule

When a schedule is running, you can monitor its progress. You don’t need to w
until the end of a schedule run to confirm that the schedule is progressing 
successfully or to discover that something went wrong. Instead, you can view 
information that is dynamically updated as each schedule executes. 

Monitoring a schedule as it plays back lets you view all aspects of that schedule
users, user groups, computers, and scripts. There are more than 15 different w
view and monitor a schedule. And, you can use filters to customize each view t
just the data you want.
1 -9
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If you discover potential problems, you can suspend, resume, or terminate the 
schedule run, and you can view information about any of your emulated users. 
In addition, you can step through every transaction and every response to find out 
whether the schedule is progressing successfully. 

Analyzing Results

A variety of PerformanceStudio reports deliver accurate metrics at the end of a 
schedule run, providing you with insight into your server’s performance and stab
under large user workloads. If a report does not meet your testing needs, you 
easily customize its content and appearance.

You can display a report as a graph — line, bar, pie, stack, or area. You can also
the data in the form of a histogram, scatter, or Gantt chart. You can modify the la
of the x and y axes, zoom in on a particular area, display information on specific d
points, and much more. You can also export a graph to a spreadsheet or third-
application for further analysis. 
1 -1 0



Where to Look N ext

ng. 
In addition to displaying reports graphically, you can also display them in grid 
format. This lets you see the statistics for the run represented by a particular graph.

Where to Look Next

You’ve just been introduced to some of the ways that Rational Suite 
PerformanceStudio predicts and measures client/server and Web system testi
But there’s still a lot more to discover. 
1 -1 1



About Rationa l Su ite Perform anceStudio
Here’s where you can find the information you need:

To find out Read this

H ow to create a Rational repository and set up 
user access rights.

Using the Rational Administrator

H ow to plan tests, record and play back GU I 
scripts, and analyze functional testing results. 

Using Rational Robot

H ow to create performance and distributed 
functional tests. Also, how to record virtual 
user scripts, how to schedule, run, and 
monitor tests, and then analyze the results.

Using Rational LoadTest

H ow to use the VU  scripting language to 
enhance your virtual user scripts.

VU Language Reference

H ow to use the SQ ABasic scripting language 
to enhance your GU I scripts.

SQABasic Language Reference

H ow to use all of the functionality in Rational 
Suite PerformanceStudio.

Online H elp

H ow to use Rational LoadTest to test the 
performance of your SAP applications.

Rational LoadTest: Try it! for Virtual User 
Testing of SAP Applications 

H ow to use Rational Robot to test the 
functionality of your SAP applications.

Rational Robot: Try it! for GUI Testing of 
SAP Applications

H ow to use Rational SiteCheck to test the 
structural integrity of your intranet or 
World Wide Web site.

Rational Robot: Try it! with Rational 
SiteCheck

H ow to use Rational Robot to test the 
functionality of your H TML pages.

Rational Robot: Try it! with HTML 

H ow to use Rational Robot to test the 
functionality of Java applets and applications.

Rational Robot: Try it! with Java 

H ow to use Rational Robot to test the 
functionality of objects in your Oracle 
applications. 

Rational Robot: Try it! with Oracle Forms 

H ow to use Rational Robot to test the 
controls in your PowerBuilder applications.

Rational Robot: Try it! with PowerBuilder 

H ow to use Rational Robot to test the 
controls in your Visual Basic applications.

Rational Robot: Try it! with Visual Basic 
1 -1 2
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Before You Begin
This chapter tells you what you have to do before you start the Rational Suite 
PerformanceStudio tutorial. It includes the following topics:

ã Tutorial requirements

ã Copying the tutorial files

ã Locating Internet Explorer

ã Specifying Internet Explorer settings

ã Finding out the name of the computer running the Web server

ã Setting up a repository for the tutorial 

Tutorial Requirements

This tutorial requires the following software:

ã Rational Suite PerformanceStudio installed on the Master computer.

For instructions, see Installing Rational Suite.

ã Windows N T 4.0 server.

ã Microsoft Internet Information Server.

IIS is installed from the Windows N T 4.0 Option Pack. 

ã Browser software installed on the Master computer.

Rational Suite PerformanceStudio requires Microsoft Internet Explorer 4.0 SP1 
or greater.

Before you begin working with the tutorial, you need to:

ã Find out the path of Internet Explorer. For information, see Locating Internet 
Explorer on page 2-2. 
2 -1



Before You Begin
ã Specify Internet Explorer settings. For information, see Specifying Internet 
Explorer Settings on page 2-3.

ã Set up a Rational repository for the tutorial. For information, see Setting Up a 
Repository for the Tutorial on page 2-3.

Copying the Tutorial Files

Before you run the tutorial, you need to copy the Rational Suite PerformanceStudio 
tutorial files. 

To copy the tutorial files:

1 . Choose the Web server that you will use to serve the sample application. To run 
the tutorial, you must be able to access the directory structure of this server.

2 . Identify the root directory of the Web server that you will be using. For 
Microsoft Internet Information Server, the default location of the Web server 
root directory is:

C:\InetPub\wwwroot

3 . Copy the entire Rational Test 7\ClassicsTutorial folder from your installation 
CD into the root directory of the Web server. With Microsoft IIS this creates:

C:\InetPub\wwwroot\ClassicsTutorial

Locating Internet Explorer

Before you begin the tutorial, you need to know the path of the application that you 
will be testing. In this case, the application is Microsoft Internet Explorer, and 
Classics Online is run within Internet Explorer. 

Microsoft Internet Explorer is typically installed in the directory C:\Program 
Files\Plus!\Microsoft Internet\ iexplore.exe. H owever, if Internet Explorer is 
installed in a different location, you can use the Windows Find function to 
locate the file.

To locate the Internet Explorer executable:

1 . Click Start → Find → Files or Folders.

2 . Type iexplore.exe in the N amed box.

3 . Choose Local H ard D rives from the Look in list.

N O TE: Make sure you know the network name of the Web server, because 
you will need this information for the tutorial.
2 -2



Specifying  In ternet Explorer Settings

l your 

ur 
ata 
ds on 
torial 
4 . Make sure that Include subfolders is selected.

5 . Click Find N ow.

Windows searches all hard drives and displays all matches in the Find dialog box. 

6 . Click the file you want. Then, right-click and choose Properties from the 
context menu. 

Write down the Location path of the file. You will need this path when you 
record a session.

Specifying Internet Explorer Settings

For the tutorial to run correctly, you need to set the Internet Explorer home page to 
blank and clear the Internet Explorer cache. To do this:

1 . Start Internet Explorer.

2 . If you are using Internet Explorer 5, select Tools → Internet O ptions. If you are 
using Internet Explorer 4, select View → Internet O ptions.

3 . Make sure that the General tab is selected.

4 . In the H ome Page section, click U se Blank.

5 . In the Temporary Internet Files section, click D elete Files.

This clears the cache, so that during the tutorial you will be recording the actual 
traffic between the client and the server, rather than reading a Web page stored 
in cache. This does not harm your bookmarks or other settings; it only clears 
temporary files so that the tutorial runs correctly.

6 . Click O K  to confirm that you want to clear the cache.

7 . Click O K  to close the dialog box. 

Setting Up a Repository for the Tutorial

Before you record a session, you must create a repository — a place to store al
test data. 

A Rational repository stores software testing and development information for yo
projects. All Rational test components on your computer update and retrieve d
from the same active repository. The type of data in a Rational repository depen
the Rational software that you have installed. The data you create during this tu
is stored in the repository you are about to create.
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Before You Begin
To create a Rational repository:

1 . Click Start → Program s → Rational Suite PerformanceStudio → Rational 
Adm inistrator.

2 . From the Rational Administrator, click File → Create Repository.

3 . Type the drive and pathname for the repository, C:\PSTutoria l, and click N ext.

4 . In the D atabase type list, select M icrosoft Access, and click N ext.
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5 . Click D o not initia lize the new repository using data  from an existing 
repository, and click N ext.

6 . Clear the Create or Attach ClearQ uest D atabase check box, and click N ext.
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7 . A summary page confirms the type and location of your new repository. Click 
Finish to create the new repository.

The Rational Administrator will spend a few moments creating the repository 
structure. 

8 . When the Administrator completes its tasks, click O K  in the confirmation dialog 
box. 

9 . Click File → Exit to exit from Rational Administrator.
2 -6



ã  ã  ã C  H   A   P  T  E  R   3

Tutorial
This chapter provides a step-by-step tutorial for using Rational Suite 
PerformanceStudio. The tutorial covers the basic tasks that you follow when using 
Rational Suite PerformanceStudio, from planning the initial test to analyzing test 
reports. The tasks that this tutorial covers are as follows:

ã Planning a test

ã Setting recording options

ã Recording scripts

ã Examining the recorded scripts

ã Generating realistic data to send to the server

ã Designing a schedule to represent your workload

ã Running the schedule

ã Running reports

After you install all the required software elements, you can complete the various 
steps of the tutorial at your own pace. At any time while working in the tutorial, 
you can refer to other Rational documentation for more information. 

Is This Tutorial for You?

Before you begin this tutorial, ask yourself the following:

ã Are you new to PerformanceStudio, or to testing? 

ã Do you want to know more about the specific advantages of 
using PerformanceStudio? 

ã Do you need a reminder about how some of the basic components 
of PerformanceStudio fit together? 

If you answered ‘yes’ to one or more questions, then this tutorial is for you.
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Purpose of the Tutorial
This tutorial shows you how to test the performance of a Web-based e-commerce 
application. You will use PerformanceStudio tools, and Classics Online — a 
demonstration application developed by Rational Software — to perform the b
tasks involved in testing an application. 

The tutorial enables you to adapt the testing process to your own needs. While
tutorial’s initial steps walk you through each action required for setting up and 
running a performance test, the final steps encourage you to think independen
and to apply what you have learned to your own testing environment.

Step 1: Planning a Test

The first step of the testing process is to clearly define what you want to test. 
In this section, you will:

ã Identify the hardware and software required for testing.

ã Map out your testing plan.

Identifying the Hardware and Software Required for Testing
When planning a performance test, you need to determine the hardware and 
software that your test requires. For example:

ã Server computers – database servers, Web servers, other servers

This tutorial requires Microsoft Internet Information Server as your Web 
server. This server is installed from the Windows N T 4.0 Option Pack. 

ã Client com puters – Windows N T, Windows 2000, Windows 98, or 
Windows 95 computers; network computers; or Macintosh or U N IX 
workstations

This tutorial assumes that the test is set up and run from a Windows N T 4
server. Windows N T service pack 4 or later must be installed with the 
operating system.

ã D atabases that will be accessed

This tutorial uses the default database that is set up when repositories 
are registered.

ã Applications that will be running

This tutorial assumes that the following applications are running: an Intern
browser (specifically, Internet Explorer) and Classics Online.
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Mapping Out Your Testing Plan
The Classics Online application simulates a music retailer selling classical CDs over 
the Web. In the tutorial, you use PerformanceStudio to test the performance of the 
Classics Online as customers search for and order CDs. 

When you plan your tests, you need to think about the criteria that determine 
whether performance is acceptable, the types of users that access the server, and the 
types of activities that the users perform. For example:

ã What are the pass and fail criteria for your tests? This tutorial assumes that 
when 10 users access your Web site, 90% of them must have a response time of 
2 seconds or less. In the busy season, when you expect 20 users at a time to access 
your Web site, 80% of the users must have a response time of 6 seconds or less. 
N o response time can exceed 8 seconds.

ã What kinds of users access the server? This tutorial assumes that three groups 
of users access your Web site: ‘window shoppers’, ‘regular buyers’, and ‘big 
spenders’.

ã What kinds of activities do your groups of users perform? This tutorial assu
that W indow shoppers browse through 15 Web pages and may order one C
Regular buyers browse through 3 Web pages, and then order one CD. 
Big spenders browse through 15 Web pages and order 10 CDs.

ã What are the proportions of your user groups? This tutorial assumes that 5
percent of your users are window shoppers, 40 percent are regular buyers
only 10 percent are big spenders.

Where to Go for More Information
To learn more about planning tests, see Chapter 2 in the following manuals: 
Using Rational Load Test and Using Rational Robot.

Step 2: Setting Recording Options

In this section, you will:

ã Start Rational Robot.

ã Set up recording options.
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Starting Rational Robot
Rational Robot is the tool you use to record a script. 

To start Rational Robot:

1 . From the Start menu, click Start → Program s → Rational Suite 
Perform anceStudio → Rational Robot.

2 . In the Rational Repository Login dialog box, type admin as your user ID. 
Make sure that the password is blank, that PSTutoria l is selected as the 
repository, and that the project D efault is selected. Then click O K .

Setting Recording Options
Before you begin recording, you’ll set up some specific recording options. 
These options include the recording method that you want to use and the bas
characteristics of the generated script.
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To set virtual user recording options:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab, and click API recording. 

API recording records application program interface calls between the specific 
client application — in this case, the browser — and the Web server.

3 . Click the Generator tab.

a. In the General section, select U se datapools.

A datapool lets a script send a different set of values to the server each 
the script is played back in a test run. The U se datapools option initializes 
your script for datapool access. Later (in Step 5: Generating Realistic Data to 
Send to the Server on page 3-24), you’ll modify the initialized datapool sectio
of the script, and then create a datapool.

N O TE: LoadTest may display a Virtual U ser Method N etwork U navailable
dialog box. This dialog box applies only to N etwork recording. You are usin
the API method to record, so click O K to dismiss the dialog box.
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b. In the Tim ing section, click the per comm and button for Playback Pacing, 
and then at CPU /user threshold (ms), enter 5 0 0 .

This option allows you to differentiate between delays in CPU  processing 
time and delays in user think time. Setting the CPU /U ser threshold to 500 
milliseconds (ms) means that LoadTest considers any delays over 500 
milliseconds as user think time rather than CPU  delays.

c. Also in the Timing section, select Think maximum (ms) and enter 3 0 0 0  in 
the box.

Although this option does not change the think times that you will see in 
the generated script, it affects how LoadTest plays back the script. Setting 
the think maximum to 3000 milliseconds means that the script pauses for a 
maximum of 3 seconds during playback. 

After you have finished setting options, the Generator tab should look like this:

4 . Click the Generator Filtering tab.

a. In the Filtering section, make sure that the Auto Filtering option is selected 
and the M anual Filtering option is cleared.
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b. In the Auto Filtering section, the only selected protocol should be H TTP. 
If necessary, hold down the CTRL key while selecting all the other protocols 
in the Selected protocols list, and click < .

Robot will automatically capture requests for the selected protocols; in this 
case, H TTP.

After you have finished setting options, the Generator Filtering tab should look 
like this:

5 . Click the Generator per Protocol tab. This tab lets you select options specific 
to the protocol you are recording. 

In the H TTP section, select Allow partia l responses, Allow cache responses, 
and Allow redirects.

These options let your script play back successfully if:

– The server responds with partial data during recording or playback.

– The response is cached during recording or playback.

– Your script is directed to another http server during playback.

Clear U se http keep-alives for connections in a  session with multiple scripts.
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After you have finished setting options, the Generator Per Protocol tab should 
look like this:

6 . Click O K . You have finished setting the recording options.

Where to Go for More Information
LoadTest provides many recording options. This tutorial discusses the more widely 
used options. For more information about recording options, see Chapter 3 of the 
Using Rational LoadTest manual.

Step 3: Recording Scripts

You are ready to record scripts. In this section, you will:

ã Start recording.

ã Split the recording session into four modular scripts:

– an Open script, which will contain the client/server traffic that occurs wh
you open the Classics Online home page.

– a Browse script, which will contain the client/server traffic that occurs wh
you search through Classics Online.
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– an Order script, which will contain the client/server traffic that occurs wh
you order a CD. 

– a Close script, which will contain the client/server traffic that occurs wh
you close the Classics Online application.

ã Add comments and other items to the scripts.

ã Stop recording.

Although you shouldn’t press the stop recording button until the tutorial instru
you to do so, you can take a break in the middle of your recording session, whil
recording is still running. For example, even if you leave your desk for an hour 
during recording, when you play back the script, it will pause for only 3 second
This is because you have set the Think Maximum to 3 seconds. 

Starting the Recording Session
To record a session of Classics Online:

1 . In Robot, click File → Record Virtual U ser.

2 . Type the session name, Classics O nline Test. 

You will specify script names within the session as you finish recording 
each script.
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3 . Click O K . 

– Robot is minimized (default behavior).

– The floating VU  Record toolbar appears (default behavior). You will us
this toolbar to stop recording, redisplay Robot, split a script, and insert 
features into a script.

– The Virtual U ser Recorder icon appears on the taskbar. The icon blink
Robot captures requests and responses.

– Since the client application is not running, the Virtual U ser Start 
Application dialog box appears.

4 . Specify the path of the executable file for the browser, as noted earlier in Locating 
Internet Explorer on page 2-2. 

The default location is: 
C:\Program Files\Plus!\Microsoft Internet\Iexplore.exe

5 . Click O K. Robot starts the browser.

6 . From the browser, open the Classics Online application.

The default U RL is:

http://servername/ClassicsTutorial/default.htm

where servername is the network name of the computer running the Web serv

N O TE: Be sure to type this U RL in the Address box of Internet Explorer.
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7 . The browser displays the Classics Online home page:

Splitting a Script
After the sample application Classics Online starts, you’ll ‘split the script’. Splitti
scripts makes your scripts more flexible. For example, instead of recording one 
session, you will split the session into four scripts: an Open script, a Browse sc
an Order script, and a Close script. Then, when you design your schedule, yo
rearrange these modular scripts to emulate the work that each user does. 

The first script that you’ll split is the Open script. To split the script:

1 . On the opening page of Classics Online, wait until the Virtual U ser Record
icon on the toolbar stops blinking. This indicates that Robot has stopped 
capturing requests and responses.

Then, click the Split Script button on the VU  Record toolbar.

2 . In the Split Script dialog box, type O pen. This is the name of the script that you
just recorded.
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3 . Click O K . The focus returns to Classics O nline.

Adding a Comment
Comments are helpful additions to scripts. This is because one user action — such 
as clicking a search button on a Web page — can translate into more than one
command in a script. Adding comments to a script during recording makes the s
easier to understand and makes the commands in the script easier to map to u
actions.

In this section, you’ll add a comment, and then you’ll browse through Classics 
Online. To add a comment:

1 . Click the D isplay VU  Insert Toolbar button on the VU  Record Toolbar.

2 . Click the Com m ent button.

3 . In the Comment dialog box, type Browsing All CD s, and then click O K.

N O TE: It is a good idea to place relevant comments throughout the script.
As you go through the rest of these steps for recording a session, feel free 
add comments where you feel they are appropriate.
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4 . From the Classics Online application, click Search CD s.

5 . Select All Composers from the Search Composers list, and then click Submit.

Splitting the Script
Once again, splitting the script differentiates this task from the remaining tasks you 
will record. This time, you’ll split the Browse script.

To split the script:

1 . Wait until the Virtual U ser Recorder icon on the toolbar stops blinking. Thi
indicates that Robot has stopped capturing requests and responses. 

Then, click the Split Script button in the VU  Record toolbar.

2 . In the Split Script dialog box, type Browse for the script that you just recorded
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3 . Click O K . The focus returns to the Classics Online application.

Adding a Block
In this section, you’ll order a CD. You’ll fill in a name and address, add a block, a
then fill in credit card information.

A block allows you to set off a certain amount of code from the rest of the scrip
block can be used to set off a transaction, but in this instance, you’ll use a bloc
determine how long it takes the server to return a Web page.

1 . From the Classics Online application, click the back arrow to return to the 
Search page.

2 . Click the Buy It button to order a CD.
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3 . Type a name, address, and phone number, but do not click Submit:

4 . From the VU  Insert Toolbar, click the Start Block button.

5 . In the Start Block dialog box, type return web page, and then click O K .

6 . Click Subm it.

7 . To stop the block, from the VU  Insert Toolbar, click the Stop Block button.
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The name of the block, return web page, is displayed in the Stop Block dialog 
box. Click O K.

8 . Fill in the credit card information and quantity, and then click Subm it . You have 
just ordered a CD from Classics O nline.
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9 . Classics Online displays the confirmation screen:

Splitting the Script
Once again, you’ll split the script. This time, you’ll split the Order script. 

To split the script:

1 . Wait until the Virtual U ser Recorder icon on the toolbar stops blinking. Thi
indicates that Robot has stopped capturing requests and responses. 

Then click the Split Script button in the VU  Record toolbar.

2 . In the Split Script dialog box, type O rder for the script that you just recorded. 
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3 . Click O K . The focus returns to the Classics Online.

Finishing the Session
1 . Exit Classics Online. From the Classics Online Web page, click File → Close.

2 . Robot displays a dialog box that asks if you want to stop recording.

Click Yes.

3 . In the Stop Recording dialog box, type Close for the name of the script that you 
just recorded. 
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4 . In the Stop Recording dialog box, click O K . Robot generates the scripts for the 
session. 

5 . When the script generation is complete, click O K .
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Robot displays the scripts that you recorded in the session — Open, Browse, 
Order, and Close.

6 . In the next section, you’ll examine these scripts more closely. But for now, c
File → Close to close each open script. 

Where to Go For More Information
For more information about setting recording options, see Chapter 3 of the Using 
Rational LoadTest manual.

For more information about recording a virtual user script in Rational Robot, se
Chapter 4 of the Using Rational LoadTest manual.

If you would like to take a break while performing the tutorial, now is a good tim
You can come back and finish the remainder of the tutorial later.
3 -2 0



Step 4 : Exam in ing the Recorded Scripts

s 
se 

 

 
 with 

 
ally 

ese 

er and 
 are 
Step 4: Examining the Recorded Scripts

N ow that you have finished recording the session, you can view the generated 
scripts. This section shows some of the important features that you’ll see in a 
VU  (Virtual U ser) script.

To examine a script:

1 . Click File → O pen → Script.

2 . From the Open Script dialog box, select O pen, and click O K.

At the top of the script, Robot has added some general comments, such a
when you created the session and the recording method that you set. The
comments — in fact, all comments — appear in green.

Scroll down through the script. The VU  language reserved words appear in
blue. 

3 . You’ll also see, grouped together near the beginning of the Open script, VU
environment variables. Robot set most of them by default, and they are set
the VU  push command. 

You’ll also see some environment variables that you set before you started
recording. When you selected a maximum think time of 3000 ms, you actu
set a VU  environment variable — Think_max — that shows up in your script. 
To find Think_max:

a. Click Edit → Find.

b. In the Find dialog box, type Think_max.

c. Click Find N ext.

Recall that you also selected HTTP options and a Think/CPU  threshold. Th
selections also set VU  environment variables — in this case, Http_control 
and Think_cpu_threshold. 

4 . When you opened the Classics Online page, you sent requests to the serv
received information back from the server. These requests and responses
captured in VU  emulation commands, specifically http_request and 
http_nrecv. 

To find http_request:

a. Click Edit → Find. 

b. In the Find dialog box, type http_request.

c. Click Find N ext.
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5 . N otice the bracketed string of text that immediately follows the 
http_request command. This bracketed text is called a com mand ID . 
These command IDs uniquely identify each VU  emulation command. Because 
each emulation command is uniquely identified, you can report on it and isolate 
the source of any performance problem. Command IDs are a central concept of 
performance testing.

Robot adds a command ID to each VU  emulation command in the script in the 
form of ["Openn.00n"]. 

– The first part of the command ID is the name of the script — in this ca
Open.

– The n is a number to further guarantee uniqueness.

– the 00n is incremented with each emulation command.

Thus, in the Open script, the first emulation command is identified by the 
command ID Open1.001, the second by command ID Open1.002, and so 
on.

To find the command IDs in the Open script:

a. Click Edit → Find. 

b. In the Find dialog box, type O pen.

c. Click Find N ext.

6 . During recording, you added a comment to the Browse script. To see this 
comment, open the Browse script, and search for Browsing All CDs.

a. Click File → O pen → Script.

b. From the Open Script dialog box, select Browse, and then click O K. 
The Browse script opens.

c. Click Edit → Find.

d. In the Find dialog box, type Browsing All CD s, and then click Find N ext.

Both the comments that you enter and the comments that Robot enters a
in green, and are set off from the rest of the script with a leading /* and a 
closing */.

N O TE: A command ID may not always follow this exact format. For 
example, if your script names are very long, the command ID shows an 
abbreviated script name and a tilde. The important concept to remember i
that the command ID always uniquely identifies an emulation command.
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7 . Recall that you added a block during the recording session. When you added the 
block, you actually changed the command IDs in the script. To see how they 
have changed, open the Order script and search for Start_Block.

The command IDs within the return web page block are named according 
to the block — return 001, return 002 — and so on, rather than the 
script. This enables you to report a transaction that you define instead of a
individual command ID.

In addition, Robot added a start_time command at the beginning off the 
block, and a stop_time command at the end of the block. Think of this time
as a stopwatch that you clicked on just before you left the first Web page, a
clicked off after the server returned the next Web page. Later on, you’ll be a
to report on this block.

8 . When you set recording options before you recorded the session, you click
U se datapools. During recording, Robot automatically generated a 
DATAPOOL_CONFIG section in the script. To see the DATAPOOL_CONFIG 
section of the Order script, scroll down to the end of the script. You see the
following lines:

DATAPOOL_CONFIG "Order"OVERRIDE DP_NOWRAP DP_SEQUENTIAL DP_SHARED
{
EXCLUDE, "cboCreditCard", "string", "Visa";
EXCLUDE, "cmdSubmit", "string", "Submit";
EXCLUDE, "txtAddress", "string", "123 Pleasant Street";
EXCLUDE, "txtCardNumber", "string", "1234567";
EXCLUDE, "txtCity", "string", "Any Town";
EXCLUDE, "txtExpireDate", "string", "1/11/00";
EXCLUDE, "txtName", "string", "John Smith";
EXCLUDE, "txtPhone", "string", "123-4567";
EXCLUDE, "txtQuantity", "string", "1";
EXCLUDE, "txtState", "string", "USA";
EXCLUDE, "txtZip", "string", "12345";

    }

The DATAPOOL_CONFIG section sets the framework of the datapool. 
It contains information such as:

– The names of script variables and the literal values that were supplied to
variables during recording. 

– Instructions on whether each variable should use data from the datapo
during script playback.

– Directives that describe how data should be retrieved from the datapo
during script playback.

The datapool is dormant until you set it up. The next section shows how to
up a datapool, so that when the script runs, it will send realistic data to the se
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Where to Go For More Information
For more information about script structure, emulation commands, and VU  
environment variables, see the VU Language Reference. For more information about 
blocks, see the Using Rational LoadTest manual.

Step 5: Generating Realistic Data to Send to the Server

The actual data that you send to the server has a great effect on performance.

In the real world, where users have different names, the server has to retrieve and 
store each different name in some back-end database. The database has to do a lot of 
work to retrieve and store each different name, which is why Web applications may 
start to get slow.

Recall that when you recorded the session, you filled in the name of one user who 
ordered a CD. If you run a performance test and every user has the same name, the 
backend database has to retrieve and store only one name. Because the database can 
put this single name in a very fast area of memory known as a cache, the reports you 
run will tell you that you have a very fast system. (This is known as a “false posit
test result, since the test is falsely telling you that the system is performing as qu
as expected.)

To fix the problem, LoadTest uses datapools. Datapools supply different names 
to the server, which give a realistic idea of an application’s performance under 
world conditions.

This section tells you how to use datapools to emulate many users with differe
names ordering CDs from Classics Online.

1 . If you have closed Rational Suite PerformanceStudio, do the following:

a. Click Start → Program s → Rational Suite Perform anceStudio → 
Rational Robot. 

b. Click File → O pen → Script, select the Order script from the Open Scrip
dialog box, and then click O K. 

2 . Click Edit → D atapool Information.

The Configure Datapool in Script dialog box appears. This dialog box lets y
modify the DATAPOOL_CONFIG section of the script.
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3 . Select the following options for Playback behavior:

– U nder Cursor, click Private. Each user will have its own cursor.

– U nder Access O rder, click Random . Each row of the data will be accesse
in any order, and a row can be accessed multiple times or not at all.

– U nder U se Script data , click O bey U sage. This option tells the script to 
obey the command in the U sage column in the grid below to determine
source of each variable’s data.

4 . You’ll notice that, by default, the U sage column lists EX CLU D E for each 
variable. This is because Robot has generated a datapool framework in you
script but hasn’t yet instructed LoadTest to supply the variables with data fro
datapool. This default setting lets you run the script before the datapool is r
for use. 

In this tutorial, you’ll supply script variables with the name and address data 
Classics Online displayed just after you clicked the Buy It button: the name, 
address, city, state, zip code, and phone number. You set this up in the scr
follows:

a. To supply the variable txtN ame with names from the datapool, right-click
on the word EX CLU D E in the txtN ame row, and then select IN CLU D E. 

b. Continue selecting IN CLU D E for the address, city, phone number, state
and zip code rows. The Configure Datapool in Script dialog box should
look like this: 
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5 . You are now ready to create the datapool. In the Datapool section, click Create. 
A dialog box appears with the message The script has been saved to reflect 
any changes you have m ade. Click O K .

6 . The following dialog box appears:

7 . In the first row of the grid (which defines the datapool column TxtAddress), 
select the contents of the Type cell, and then click the down arrow to see a list 
of available data types.

8 . Scroll through the list and select Address-Street .
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9 . Continue selecting data types for each datapool column name. When you have 
finished, the dialog box should look like this:

1 0 . At N o. of records to generate, type 1 00 , and then click Generate D ata .

1 1 . Click Yes to confirm that data generation is complete.

1 2 . Click Cancel in the Data Generator Results Detail dialog box.

1 3 . Click Close in the Datapool Specification dialog box.

1 4 . Click Close in the Configure Datapool in Script dialog box.

Where to Go For More Information
The previous section showed how to add a datapool so that LoadTest will provide 
realistic values to the server during script playback. Thus, if script playback emulates 
100 users accessing a database on the server, each user can send a different record to 
the server. Without a datapool, the same record (the values captured during 
recording) would be sent to the server 100 times.

N ote that the datapool that you just created used values that LoadTest automatically 
generated. You can also create a datapool with user-defined data. For example, if your 
application allowed you to order CDs from different composers, you could create a 
datapool and populate it with the names of different composers, so that your test 
could emulate users ordering different CDs. 
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See Chapter 5 of the Using Rational LoadTest manual for more information about:

ã Defining and populating datapools with user-defined data types

ã Creating and managing more complex datapools within virtual user scripts

Step 6: Designing a Schedule to Represent Your Workload

N ow that you have finished recording the session, you are ready put your scripts into 
a schedule in such a way that they emulate your user workload.

To create a schedule:

1 . Open Rational LoadTest.

a. If you have closed Rational Suite PerformanceStudio, click Start  → 
Programs → Rational Suite PerformanceStudio → Rational LoadTest. 

b. If you are still in Robot, click Tools → Rational Test → Rational 
LoadTest. 

2 . In LoadTest, click File → N ew → Schedule. The N ew Schedule dialog box 
appears.

3 . Click Existing Session, and then click O K .

In the N ew from Existing Session dialog box, LoadTest displays a list of sessions 
that you have recorded. 
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4 . Select Classics O nline Test, and click O K .

5 . LoadTest displays a schedule, which contains the scripts that you recorded in the 
session.

LoadTest automatically creates a schedule that is ready to run. This schedule has one 
user group associated with it, U ser Group1 , and one scenario. 

The scenario has the same name as the session, and it contains the scripts in the order 
that you recorded them. In general, a scenario lets you group scripts and other 
elements together so that they can be shared among user groups. If a schedule is 
complicated and uses many scripts, grouping the scripts under a scenario makes the 
schedule easier to read and maintain. 

Although you can run this schedule — and in a real test, it’s a good idea to do so t
confirm that your scripts play back correctly — in the interest of brevity, this tuto
will skip this step. 
3 -2 9



Tutoria l

ugh 

load.

 

But even though the schedule is ready to run, it does not reflect your environment. 
If you ran this schedule, one user group, U ser Group1 , would open Classics Online, 
browse through the composers, place one order, and close Classics O nline.

H owever, your environment contains three groups of users that access your Web 
site: ‘window shoppers,’ ‘regular buyers,’ and ‘big spenders.’

In addition, each user group behaves differently: 

ã Window Shoppers, which comprise 50 percent of your total users, browse 
through 15 Web pages and may or may not order any CDs.

ã Regular Buyers, which comprise 40 percent of your total users, browse thro
three Web pages, and then order a CD. 

ã Big Spenders, which comprise only 10 percent of your total users, browse 
through 15 Web pages and place 10 orders at random intervals.

The following section shows how to design a schedule that emulates this work

Inserting User Groups into Your Schedule
In this section, you will insert three user groups — Window Shoppers, Regular
Buyers, and Big Spenders — into the schedule.

To add these user groups:

1 . Click the U ser Groups icon in the schedule.

2 . Click Insert → U ser Group.

3 . In the U ser Group dialog box:

– Type W indow Shoppers, the name of the user group.

– Click Scalable, and enter the percentage of your customers that are 
window shoppers, 5 0 .
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4 . Click O K . The user group W indow Shoppers appears in the schedule.

5 . Continue adding the two remaining user groups. 

– Click the W indow Shoppers user group, and repeat steps 2–4 to create 
user group called Regular Buyers with a scalable percentage of 40%.

– Click the Regular Buyers user group, and repeat steps 2–4 to create a u
group called Big Spenders with a scalable percentage of 10%.

6 . Remove U ser Group1  by right-clicking on it, and then clicking D elete.

After you’ve added user groups, your schedule should look like this:

You are now ready to add scripts and selectors to the schedule.
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Inserting Scripts and Selectors into Your Schedule
N ow that you have inserted user groups into the schedule, you’ll add the scripts
each user group will run. You will insert the Open, Browse, Order, and Close sc
so that they emulate the behavior of each user group. You will also add some ran
selectors, which will select the scripts to run, because not all scripts will run 
sequentially.

In your environment:

ã All users begin by opening Classics Online and end by closing Classics On
Therefore, each user will run the Open script first, and will run the Close sc
last.

ã Window Shoppers browse through 15 Web pages and may or may not orde
CDs. Therefore, they will run the Browse script 15 times, and may or may 
run the Order script.

ã Regular Buyers browse through three Web pages, and then order a CD. 
Therefore, they will run the Browse script three times, and will then run th
Order script once.

ã Big Spenders browse through 15 Web pages and place 10 orders at rando
intervals. Therefore, they will randomly run the Browse script 15 times and
randomly run the Order script 10 times.

Copying the Open and Close Scripts into the User Groups
You’ll start by copying the Open and Close scripts into each user group. To co
these scripts: 

1 . Select both the Open and Close scripts by pressing the CTRL key and clicking 
the left mouse button.

2 . Right-click, and then click Copy.

3 . Right-click on the W indow Shoppers user group, and click Paste. The Open 
and Close scripts are inserted into the Window Shoppers user group. Expan
the tree so that you can see them in the schedule.

4 . Right-click on the Regular Buyers user group, and click Paste. The Open and 
Close scripts are inserted into the Regular Buyers user group.

5 . Right-click on the Big Spenders user group, and click Paste. The Open and 
Close scripts are inserted into the Regular Buyers user group.
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In the following sections, you’ll add the Browse and Order scripts. However, ea
user group runs these scripts differently. Therefore, you need to add a selecto
randomly choose which script to run, and to then weight each script to increas
decrease its chances of being chosen.

Emulating the Window Shoppers Workload
Recall that customers in the Window Shoppers user group browse through 15
pages and may or may not order any CDs. If they order a CD, they sometimes
continue browsing. 

To reflect this behavior, you insert a random with replacement selector into yo
schedule, and place the Browse and Order scripts under that selector. A random
replacement selector runs the items under it — in this case, the Browse and O
scripts — in random order. Each time an item is selected, the odds of it being sel
again remain the same.

To insert a selector:

1 . Click the O pen script in the Window Shoppers user group.

2 . Click Insert → Selector.

In the Selectors dialog box, click Random with replacement. 

In N um ber to select, enter 16. This means that the selector will select a scr
randomly 16 times during the schedule run.

3 . Click O K. LoadTest adds the selector under the Open script.
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N ext, you’ll add the Browse and Order scripts under the selector.

1 . Click the selector that you just added in the Window Shoppers user group

2 . Click Insert → Script, and select the Browse script.

3 . At W eight, enter 15 . This is because Window Shoppers browse through 15 W
pages. This increases the chance that this script will be chosen by the sele

4 . Click O K.

5 . Click the Browse script in the Window Shoppers user group.

6 . Click Insert → Script, and then select the O rder script.

7 . At W eight, enter 1 , and then click O K. Because the weight of this script is 1 (an
the weight of the 
3 -3 4
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The Window Shoppers user group should look like this:

Emulating the Regular Buyers Workload
Recall that customers in the Regular Buyers user group browse through three 
Web pages, and then place one order. 

To reflect this behavior, you’ll add the Browse and Order scripts under the Op
script:

1 . Click the O pen script in the Regular Buyers user group.

2 . Click Insert → Script, and select the Browse script.
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3 . At Iterations, enter 3 . This is because Regular Buyers will browse through three 
Web pages.

4 . Click O K .

5 . Click the Browse script in the Regular Buyers user group.

6 . Click Insert → Script , select the O rder script, and then click O K .

Emulating the Big Spenders Workload
Recall that customers in the Big Spenders user group browse through 15 Web pages 
and order 10 CDs — a ratio of 3 ‘browses’ to 2 ‘orders’. They browse and order th
CDs in any order.

To reflect this behavior, you insert a random without replacement selector into y
schedule, and place the Browse and Order scripts under that selector. A rando
without replacement selector runs the items under it — in this case, the Browse
Order scripts — in random order. However, each time an item is selected, the 
of it being selected again change.

To insert a selector:

1 . Click the O pen script in the Big Spenders user group.

2 . Click Insert → Selector.

In the Selectors dialog box, click Random  without replacem ent. 

In N um ber to select, enter 2 5 . This means that the selector will select a scrip
randomly 25 times during the schedule run.

3 . Click O K. LoadTest adds the selector under the Open script.

N ext, you’ll add the Browse and Order scripts under the selector.
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1 . Click the selector that you just added in the Big Spenders user group.

2 . Click Insert → Script , and select the Browse script.

3 . At Weight, enter 3 . This is because Big Spenders browse through 15 Web pages 
for every 10 orders, which is a ratio of 3:2.

4 . Click O K .

5 . Click the Browse script in the Big Spenders user group.

6 . Click Insert → Script , and then select the Order script.

7 . At Weight, enter 2 , and then click O K .
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After you have added scripts and selectors, your schedule should look like this:

Saving the Schedule
After you have finished setting up the schedule, save it.

To save a schedule

1 . Click File → Save.

2 . Enter a name for the schedule, Classics O nline Schedule, in the Save As 
dialog box.
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3 . Click O K .

Where to Go For More Information
For more information about designing schedules, see Chapter 7 of the Using Rational 
LoadTest manual. The chapter includes detailed information about user groups, 
selectors, and other elements that you can insert into a schedule.

Step 7: Running the Schedule

N ow that your schedule reflects the browsing and ordering patterns of Classics 
Online customers, it is time to actually run it.

In this section, you’ll do the following:

ã Set the information that LoadTest displays when the schedule runs.

ã Run the schedule with 10 users.

ã Briefly examine the default reports that LoadTest generates after a schedule

Setting the Information You See During a Schedule Run
Before you run the schedule, you’ll set up LoadTest so that it displays informat
specific to HTTP testing. To set the information that LoadTest displays:

1 . Click Tools → O ptions, and then click the M onitor tab.

2 . U nder U ser, select the Results box, and clear any other boxes that are selecte
This displays information geared to the success or failure of each emulatio
command.
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3 . U nder State H istogram , select the H TTP box, and clear any other boxes that 
are selected. This displays a bar chart oriented to scripts that access Web data.

4 . U nder M isc, clear any boxes that are checked.

When you are finished, the dialog box should look like this:

5 . Click O K  to save these settings.
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Running a Schedule
To run a schedule with 10 users:

1 . Click Run → Schedule.

In the Run Schedule dialog box, the schedule name is displayed in the 
N am e box.

2 . In the N um ber of U sers box, enter 1 0 . 

This will run the schedule with 10 virtual users and distribute them among the 
user groups in the percentages that were set when you created the user groups: 
5 Window Shoppers, 4 Regular Buyers, and 1 Big Spender.

3 . Click O K . If necessary, LoadTest compiles your scripts and then begins to run 
the ClassicsWeb schedule. 

Monitoring the Schedule
While the schedule is running, it automatically displays the two views that 
you set — the Results U ser view and the HTTP H istogram view.

To monitor the schedule:

ã Maximize the LoadTest window and click W indows → T ile horizonta l to make 
sure you’ll be able to see the information.
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ã The dark area at the top of the schedule is the Progress bar. This lets you quickly 
asses how successfully the schedule is running. In this figure, the circle shows 
that you are about two-thirds (66%) through with the schedule run.

ã The Results U ser view displays information about the state of each script that is 
running. The runtime scripts are also called virtual users. In this figure, you can 
see all 10 virtual users. Six are running the Browse script, and four have already 
exited.

When you run your schedule, you will notice that the Regular Buyers will 
probably be the first virtual users to exit. These virtual users perform the fewest 
iterations of the scripts. The Window Shopper will be the last virtual user to exit, 
because it performs the most iterations. 

ã The H TTP H istogram view is a bar chart that gives specific information about 
the state that each virtual user is in. 
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In the H TTP H istogram view, data is grouped appropriately for tests that access 
Web servers. The following table shows the information displayed in this view: 

Where to Go For More Information
You can select a number of views when you monitor a schedule. See Chapter 8 of 
the Using Rational LoadTest manual for more information about:

ã Viewing a schedule

ã Types of histograms and views

ã Zooming in on histograms for more detailed information

ã Pausing or aborting a schedule run

Bar Name Description

Init U sers that are initializing.

Connect U sers that are waiting to connect to the Web server.

Send U sers that are sending data to the Web server.

Recv U sers that are waiting for data from the Web server.

Linespeed U sers that are being artificially delayed to achieve a specific network 
linespeed.

Quiet U sers that are thinking, delaying, or suspended, or are waiting on a 
shared variable or synchronization point.

GU I U sers that are performing GU I-related operations.

Other All other states.

Exit U sers that have finished the schedule, with either normal or 
abnormal termination.
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Step 8: Running Reports

After a schedule run is complete, LoadTest displays the Status and the Performance 
report output.

The Status report output shows which command IDs passed and which failed. To 
examine the output more closely:

1 . Click the square in the upper-right corner of the Status report output to 
enlarge it. 

N O TE: The LogViewer may appear, which indicates that at least one virtual user 
terminated abnormally. In a real test, you would investigate this failure. For this 
tutorial, however, dismiss the LogViewer, and from the LoadTest window, click 
the Perf and Status buttons to run the Performance and Status reports.
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In the Status report output, you’ll see a bar chart and a table. The table list
command IDs in alphabetical order. 

Look at the Open command IDs, which came from the Open script. You w
see that each Open command ran 10 times, which is as expected, becaus
virtual users opened Classics Online.

Look at the Browse command IDs. Each Browse command ran 102 times. 
happened because of the way you designed the schedule and the number
users you ran. That is:

– Four Regular Buyers executed the Browse command three times 
(4 x 3 =  12).

– Five Window Shoppers ran a selector that executed the Browse comm
15 times (5 x 15 =  75).

– One Big Spender ran a selector that executed the Browse command 
15 times.

You’ll notice the Status report output doesn’t list any command IDs from th
Close script, even though you recorded a Close script. This is because in t
script, you closed the connection, no server traffic was generated, and there
there are no emulation commands to report on.

2 . Click File → Save As to save the Status report output.
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3 . In the Save As dialog box, save the Status report with the name Status--1 0  
users, and then click O K.

The Performance report output displays the response times that occurred during the 
schedule run, grouped by command ID. 

To examine the output more closely:

1 . Click the square in the upper-right corner of the Performance report output to 
enlarge it. 

2 . Recall that when you planned your test, you set the pass and fail criteria as 
follows: 

When 10 users access your Web site, 90% of them must have a response time of 
2 seconds or less. 

When 20 users access your Web site, 80% of them must have a response time of 
6 seconds or less. 

N o response time can exceed 8 seconds.

N O TE: Your Performance report output will not be the same as that shown 
in the tutorial. This is because the performance characteristics of your 
environment differs from those used in the tutorial. U se the Performance 
report information in this tutorial as a guideline only.
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N ow that you have run schedule with 10 users, you can check whether you have 
met some of your goals.

– Scroll down the 90% column, and check whether any response time is
greater than 2 seconds. If none is greater, Classics Online has met this

– Scroll down the MAX column to see whether any maximum response ti
exceeds 8 seconds. If none exceeds 8 seconds, Classics Online has m
goal for 10 users.

3 . Click File → Save As to save the Performance report output.

4 . In the Save As dialog box, save the output with the name Performance--1 0  
users, and then click O K.

Running and Monitoring a 20-User Schedule
N ow that you have examined these reports, you’ll run the schedule with 20 us
and compare the difference in your server’s response time.

Running a schedule with 20 users is almost identical to running one with 10 us
The only difference is that you’ll enter 2 0  instead of 10 in N umber of U sers. And, 
when you run the schedule, the run should take longer, because it contains m
users.

To run a schedule with 20 users:

1 . Click Run → Schedule.

2 . In the N um ber of U sers box, enter 2 0 , and then click O K. This runs the 
schedule with 20 virtual users —10 Window Shoppers, 8 Regular Buyers, a
Big Spenders.

3 . Monitor the schedule, as you did with 10 users.

4 . At the end of the schedule run, LoadTest again displays Status and Perform
report output.

5 . Optionally, examine the Status report output. 

6 . Examine the Performance report output.

– Scroll down the 90% column, and check whether any response time is
greater than 2 seconds. If none is greater, Classics Online has met this

– Scroll down the MAX column to see whether any maximum response ti
exceeds 8 seconds. If none exceeds 8 seconds, Classics Online has m
goal.

7 . Then click File → Save As to save the Status report output.
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8 . In the Save As dialog box, save the Status report output with the name 
Status--2 0  users, and then click O K .

9 . Click File → Save As to save the Performance report output.

1 0 . In the Save As dialog box, save the Performance report output with the name 
Perform ance--2 0  users, and then click O K .

Where to Go For More Information
The previous sections showed you how to run Performance reports to compare 
two schedule runs. These are not the only types of reports you can run, however. 
LoadTest provides additional reports that enable you to:

ã Run one report to compare the results of up to six schedule runs.

ã Filter command IDs — both before and after running a report.

ã Eliminate renegade response times — called outliers — from the report output.

ã Report on a few commands — or even on one command ID.

ã Report on a few user groups — or even on one user.

ã Customize reports and save your customizations.

For more information about LoadTest reports and analyzing results, see Chap
of the Using Rational LoadTest manual.

Wrapping Up

N ow that you’ve completed the performance testing tutorial, it’s time to think ab
what you’ve learned and how you can apply this knowledge to your testing 
environment.

ã In Step 1, you learned about planning performance tests. You considered 
tasks of the application in terms of transactions, the people who perform th
transactions, and the frequency and volume of those transactions. How do 
concepts apply to your server?

ã In Step 2, you learned about setting recording options, and saw the kinds o
options that you could set for the different recording methods. How will you
the recording options for your session?

ã In Step 3, you learned about recording a session. How will you apply this to y
application? What are the logical ways that you can break up the user’s task
modularize testing later? Will adding blocks help you test specific tasks?
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ã In Step 4, you learned about examining the script. What features will you add to 
your recorded scripts?

ã In Step 5, you learned about generating realistic data to send to the server. What 
other ways can you use datapools to further refine your testing?

ã In Step 6, you created a schedule in Rational LoadTest based on the session that 
you recorded. You learned about user groups, selectors, and scripts, and how to 
model user behavior by manipulating these items. H ow can you use user groups, 
selectors, and scripts to emulate user actions? Will your schedule be more 
complex and require additional items?

ã In Step 7, you ran the schedule that you created and saw how LoadTest plays 
back the user actions and allows you to monitor the test as is it happening. You 
also saw how the test itself uses system resources. H ow will this affect how you 
choose to run a test? Do your servers have enough resources to run large 
numbers of users in the test schedule that you designed? 

ã In Step 8, you looked at the default reports created by LoadTest to analyze 
application and system performance. What reports will be most useful in your 
test environment? What kind of information do you most need to report on?

To help you in your testing, Rational Software provides several ways to learn more 
about this product and performance testing. For example:

ã D ocumentation – Rational provides comprehensive documentation for all it
products. You can find this documentation on the Rational Solutions for Windows 
Online Documentation CD.

ã Training – Rational offers training for all of its products — including 
PerformanceStudio — through Rational U niversity. For more information,
see the Rational U niversity Web site: http://www.rational.com/university.

Rational can also provide custom on-site training tailored to your situation.
Contact your Rational account manager to request this type of training.

ã Support Services – Rational provides a full range of technical support services, 
from product maintenance to mentoring and consulting. For more information, 
see Rational’s Web site: www.rational.com/services. In addition, you can con
your account manager for more information.

Good luck!
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Glossary
action object – In TestFactory, an object in the application map that represents
action to which a control in the application responds. Typical actions are mous
left-click, mouse right-click, and mouse left-double-click; the corresponding act
objects in the application map are LeftClick, RightClick, and LeftDoubleClick.

ActiveX  control – A reusable software control that takes advantage of Object Link
and Embedding (OLE) and Component Object Modeling (COM) technologies
Developers can use ActiveX controls to add specialized functions to application
software development tools, and Web pages. Robot can test ActiveX controls in
applications.

actual results – In a functional test, the outcome of testing an object through a 
verification point in a GU I script. Actual results that vary from the recorded base
results are defects or intentional changes in the application. See also baseline results.

Adm inistrator – See Rational Administrator. 

Agent computer – In LoadTest, a computer that has the Rational Agent softwar
installed and that plays back a virtual user or GU I script. In a LoadTest schedu
you can identify the Agent computer on which to run a script. See also Rational Agent.

API recording – In Robot, a virtual user recording method that captures API cal
between a specific client application and a server. These calls are captured on 
client computer. 

application m ap – In TestFactory, a hierarchical list of controls and actions in th
application-under-test, as well as the states of the application-under-test and th
transitions between those states. An application map can include U I objects an
action objects, as well as TestFactory objects such as Pilots, Test Suites, and s

application-under-test – The software being tested. See also system-under-test.

Asset Browser – A window that displays testing resources such as builds, querie
scripts, schedules, reports, report output, and logs. The Asset Browser is availa
TestManager and LoadTest. 

AU T – See application-under-test.
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autom ated testing – A testing technique in which you use software tools to repla
repetitive and error-prone manual work. Automated testing saves time and ena
reliable, predictable, and accurate testing process.

AutoPilot – In TestFactory, a tool for running scripts, Test Suites, and Pilots. T
scripts and Test Suites can run on your local computer or on computers in the
Lab. The Pilots run on your local computer, and the scripts they generate can ru
your local computer or on computers in the Test Lab.

base state – In TestFactory, the known, stable state in which you expect the 
application-under-test to be at the start of each script segment. See also script segment.

baseline results – In a functional test, the outcome of testing an object through
verification point in a GU I script. The baseline results become the expected sta
the object during playback of the script. Actual test results that vary from the bas
results are defects or intentional changes in the application. See also actual results.

best script – In TestFactory, an optimized script generated by a Pilot. A best sc
contains the fewest number of script segments that provide the most coverage 
source code or user interface in the application-under-test. 

breakpoint – A feature of the Robot debugger. When you assign a breakpoint t
line of code, and then run the script in the debugger environment, the script s
executing at that line of code. Control returns to you, and the breakpoint line i
displayed. From here you can view variables, perform other debugging activities
continue executing the script. 

build – A version of the application-under-test. Typically, developers add new 
features or enhancements to each incremental build. As team members test a
they enter defects against those features that do not behave as expected. You 
TestManager to define and manage builds. 

built-in data  test – A data test that comes with Robot and is used with the Obje
Data verification point. A data test uses a specific property of the object, in 
conjunction with other parameters, to determine the data to capture. Although
built-in data tests cannot be edited, renamed, or deleted, they can be copied an
edited, and they can be viewed. See also custom data test.

ClearQ uest – See Rational ClearQuest. 

client/server – An architecture for cooperative processing in which the software
tasks are split between server tasks and client tasks. The client computer send
requests to the server, and the server responds.

code coverage – In TestFactory, the percentage of code that is tested by a scrip
This percentage is based on the portion of the code that a script touches, relat
all code in the application-under-test. A Pilot can use code coverage to determin
best script for a run. See also UI coverage.
Glossary-2



Glossary

 
refix 
s 

e you 
e 

. 
er, 
ns 

n 
e 
tive 

tion 

aw 
ager, 

ith 
ct, 

so 

r 
ks. 

rs 

s 
. 

ent 
g 

hich 
com m and ID  – In LoadTest’s VU  language, an identifier for a command. Robot
automatically assigns a unique command ID, composed of an alphanumeric p
and a three-digit number, to each emulation command. Because command ID
appear in both the virtual user script and the LoadTest report output, they enabl
to determine the relationship between an emulation command and its respons
times.

com m and ID  prefix – In LoadTest, a prefix for a unique emulation command ID
The prefix defaults to the script name (up to the first seven characters). Howev
you can define the prefix in the Generator tab of the Virtual U ser Record Optio
dialog box.

custom  data  test – A customer-defined data test used with the Object Data 
verification point. A data test uses a specific property of the object, in conjunctio
with other parameters, to determine the data to capture. Custom data tests ar
created within your organization and are stored in the repositories that were ac
when they were created. They can be edited, renamed, and deleted. See also built-in 
data test.

data  test – A test that captures the data of an object with the Object Data verifica
point. See also built-in data test and custom data test.

datapool – A source of test data that GU I scripts and virtual user scripts can dr
from during playback. You can automatically generate datapools using TestMan
or you can import datapool data from other sources such as your database. 

dependency – In LoadTest, a method of coordinating an object in a schedule w
an event. For example, if the script Query is dependent upon the script Conne
then Connect must finish executing before Query can begin executing. See al
event.

distributed architecture – Architecture in which computer systems work togethe
and communicate with each other across LAN , WAN , or other types of networ
A client/server system is an example of distributed architecture.

distributed functional test – In LoadTest, a test that uses multiple Agent compute
to execute multiple GU I scripts written in the SQABasic language. 

dynam ic load balancing selector – A type of selector in a LoadTest schedule. Item
in the selector, such as scripts, are executed according to a weight that you set

em ulation com m ands – VU  language statements or commands that emulate cli
activity, evaluate the server’s responses, and perform communication and timin
operations. LoadTest stores the results of emulation commands in a log file, w
you can view from the LogViewer. 
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em ulation functions – VU  language functions that emulate client activity and 
evaluate the server’s responses. U nlike emulation commands, emulation func
do not perform communication and timing operations, and they are not logged

environm ent control com m ands – VU  language commands that let you control 
virtual user’s environment by changing the VU  environment variables. For exam
you can set the level of detail that is logged or the number of times that virtual u
attempt to connect to a server.

event – An item in a LoadTest schedule upon which another item is dependen
For example, if the script Connect sets an event and the script Query depends o
event, Connect must finish executing before Query can begin executing. See a
dependency.

external script – A script that runs a program created with any tool. You plan an
run external scripts in TestManager.

fixed user group – In LoadTest, a group that contains a scalable number of use
When you create a fixed user group, you indicate the maximum number of user
you will run in the group. Typically, you use fixed user groups in functional test
which do not add a workload to the system.

flow control statem ents – In the VU  and SQABasic languages, statements that 
you add conditional execution structures and looping structures to a script. 

functional test – A test to determine whether a system functions as intended. 
Functional tests are performed on GU I objects and objects such as hidden 
DataWindows and Visual Basic hidden controls. 

Grid Com parator – The Robot component for reviewing, analyzing, and editing
data files for text and numeric verification points in grid formats. The Grid 
Comparator displays the differences between the recorded baseline data and t
actual data captured during playback.

GU I script – A type of script written in the SQABasic language. It contains GU I 
actions such as keystrokes and mouse clicks. Typically, a GU I script also conta
verification points for testing objects over successive builds of the application-un
test.

GU I user – The type of user that is emulated when a GU I script is executed. 
Only one GU I user at a time can run on a computer.

hidden object – An object that is not visible through the user interface. H idden 
objects include objects with a visible property of False and objects with no GU I
component.

ID E – Integrated Development Environment. This environment consists of a se
integrated tools that are used to develop a software application. Examples of ID
supported by Robot include Oracle Forms, PowerBuilder, Visual Basic, and Ja
Glossary-4
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Im age Com parator – The Robot component for reviewing and analyzing bitma
image files for Region Image and Window Image verification points. The Image
Comparator displays differences between the recorded baseline image and the
image captured during playback. The Image Comparator also displays unexpe
active windows that appear during playback.

instrum entation – In TestFactory, the process of inserting code coverage coun
into the application-under-test. These counters record how much code is exec
during a script run. See also object code instrumentation and source code instrumentation.

load – See workload.

load balancing – See workload balancing. 

LoadTest – See Rational LoadTest.

log – A repository object that contains the record of events that occur while pla
back a script or running a schedule. A log includes the results of all verification po
executed as well as performance data that can be used to analyze the system’s
performance.

LogViewer – See Rational LogViewer.

low-level recording – A recording mode that uses detailed mouse movements a
keyboard actions to track screen coordinates and exact timing. During playbac
actions occur in real time, exactly as recorded.

m anual script – A set of testing instructions to be run by a human tester. The 
script can consist of steps and verification points. You create manual scripts in 
TestManager.

M aster com puter – A computer that executes LoadTest. From this computer, y
create, run, and monitor schedules. When the run is finished, you use it to ana
test results.

m ix-ins – See Pilot mix-ins.

network recording – In Robot, a virtual user recording method that records pack
level traffic. This traffic is captured on the wire. 

next available selector – In LoadTest schedules, a selector that distributes each i
such as a script, delay, or other selector to an available computer or virtual user
type of selector is used in a GU I schedule. The next available selector parcels o
items sequentially, based on which computers or virtual users are available.
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object – An item on a screen, such as a window, dialog box, check box, label, o
command button. An object has information (properties) associated with it and
actions that can be performed on it. For example, information associated with 
window object includes its type and size, and actions include clicking and scroll
In some development environments, a term other than object is used. For example, 
the Java environment uses component, and the HTML environment uses element.

object code instrum entation – In TestFactory, the process of inserting code 
coverage counters into the executable file of the application-under-test. These
counters record how much of the program a script tests. See also instrumentation and 
source code instrumentation.

O bject-O riented Recording®  – A script recording mode that examines objects in
the application-under-test at the Windows layer. Robot uses internal object nam
identify objects, instead of using mouse movements or absolute screen coordi

O bject Properties Comparator – The Robot component that you use to review,
analyze, and edit the properties of objects captured by an Object Properties 
verification point. The Object Properties Comparator displays differences betw
recorded baseline data and the actual data captured during playback.

O bject Scripting com mands – A set of SQABasic commands for accessing an 
application’s objects and object properties. You add Object Scripting command
manually when editing a script.

O bject Testing®  – A technology used by Robot to test any object in the applicati
under-test, including the object’s properties and data. Object Testing lets you t
standard Windows objects and IDE-specific objects, whether they are visible in
interface or hidden.

O CI  – Object Code Insertion. The Rational technology used in TestFactory to 
instrument object code and measure how much of the application-under-test a 
tests. See also code coverage and object code instrumentation.

perform ance test – A test that determines whether a multi-client system perform
within user-defined standards under varying loads. Performance tests are alway
from a schedule in LoadTest.

Pilot – In TestFactory, a tool for generating scripts automatically. 

Pilot m ix-ins – In TestFactory, a list of Pilots that are executed on a random ba
during the run of a lead Pilot. Mix-ins are useful for randomly testing multiple ar
of the application-under-test. To make tests more realistic, you can combine mi
and scenarios. 

Pilot scenario – An ordered list of Pilots that are executed during the run of a Pi
A Pilot scenario is useful for testing U I objects that need to be exercised in a spe
order. To make tests more realistic, you can combine scenarios and mix-ins.
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project – A collection of data, including test assets, defects, requirements, and 
models, that can facilitate the development and testing of one or more softwar
components. 

proxy recording – In Robot, a virtual user recording method that captures the cli
server conversation on the network wire rather than on the client computer. P
recording allows Robot to capture network packets that are not visible to it dur
network recording — for example, if the client and server are in different netwo
segments.

query – A request for information stored in the repository. A query consists of a fi
and several visible attributes — the columns of data to display, the width of the
column, and the sort order.

random  selector – A type of selector in a LoadTest schedule. Items in the selec
such as scripts, are randomly executed. Random selectors can be with replace
where the odds are the same, or without replacement, where the odds change
each iteration. 

Rational Adm inistrator – The component for creating and maintaining repositori
projects, users, groups, computers, and SQL Anywhere servers.

Rational Agent – The LoadTest software that resides on a shared network drive
runs on each computer where testing occurs. The entries specified in a schedu
back on the Agent computer, which reports on their progress and status as the
See also Agent computer.

Rational ClearQ uest – The Rational product for tracking and managing defects a
change requests throughout the development process. With ClearQuest, you 
manage every type of change activity associated with software development, 
including enhancement requests, defect reports, and documentation modifica

Rational LoadTest – The Rational Test component for running performance, 
stress, scalability, multi-user, and distributed functional tests on multiple Agent
connected by a network. With LoadTest, you can initiate test runs and monitor 
from a master computer that manages the test process. LoadTest is available o
Rational Suite PerformanceStudio.

Rational LogViewer – The Robot component for displaying logs, which contain th
record of events that occur while playing back a script or running a schedule. A
the component from which you start the four Comparators.

Rational Perform anceArchitect – The Rational component that lets you test the
performance of COM/DCOM applications. With Rational PerformanceArchitec
you can create a Rose sequence or collaboration diagram, convert it to a virtua
script, and then use Rational Suite PerformanceStudio to edit the script and ru
performance tests.
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Rational repository – A database that stores application testing information, such
test requirements, scripts, and logs. All Rational Suite TestStudio and Rational S
PerformanceStudio products and components on your computer update and 
retrieve data from the same connected repository. A repository can contain eith
a Microsoft Access or a Sybase SQL Anywhere database.

Rational RequisitePro – The Rational product for organizing, managing, and 
tracking the changing requirements of your system.

Rational Robot – The Rational product for recording, playing back, debugging, a
editing scripts. 

Rational SiteCheck – The Robot component for managing your intranet or Wor
Wide Web site. You can use SiteCheck to visualize the structure of your Web s
and you can use it with Robot to automate Web site testing.

Rational Synchronizer – The Rational tool that ensures the consistency of data 
across several Rational products.

Rational TestAccelerator – An agent application that executes scripts. TestFacto
uses computers running TestAccelerator as remote machines on which to run
automated distributed tests.

Rational TestFactory – The Rational Test component for mapping an applicatio
under-test and generating scripts automatically. TestFactory is available in Rat
Suite TestStudio and Rational Suite PerformanceStudio.

Rational TestM anager – The Robot component for managing the overall testin
effort. You use it to define and store information about test documents, 
requirements, scripts, schedules, and sessions.

Report Layout Editor – The TestManager component for customizing the layout
reports.

repository – See Rational repository. 

RequisitePro – See Rational RequisitePro. 

Robot – See Rational Robot.

scalable user group – In LoadTest, a group that contains a varying number of use
When you create a scalable user group, you assign it a percentage of the total 
workload. Assume you have a scalable user group that is 50 percent of the work
If you run a test with 10 users, the group will contain 5 users. If you run a test w
100 users, the group will contain 50 users.

scenario – In LoadTest, a modular group of scripts and other items in a schedule
is used by more than one user group. A scenario can contain scripts, delays, a
synchronization points. 
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scenario – See Pilot scenario.

schedule – In LoadTest, structure that you create to specify how scripts should
played back. A schedule can contain GU I scripts and virtual user scripts, and c
indicate the number of times to repeat a script and the computer on which the s
will run. In performance testing, a schedule is used to create a workload. In 
distributed functional testing, a schedule is used to distribute scripts among va
computers.

script – A set of instructions used to navigate through and test an application. Y
can generate scripts in a variety of ways. You can use Robot to record scripts us
functional testing and performance testing. You can also use TestManager to c
and manage manual scripts, and to manage external scripts created with a third
testing tool. A script can have properties associated with it, such as the purpose 
script and requirements for the script. See also external script, GUI script, manual script, 
and virtual user script.

script outline – In TestFactory, the readable version of a script. A script outline 
contains a description of the actions that Robot performs while running the scr

script segment – In TestFactory, a section of a script that tests a particular 
element of product functionality. A Pilot generates a script segment by starting
application-under-test in a base state, navigating through the part of the produc
you are testing, and returning the application-under-test to the base state. See
base state.

seed – An initial number fed to a random number generator. U sing the same s
produces the same series of random numbers. In LoadTest, you use seeds to ge
think times.

selector – An item that you insert in a LoadTest schedule to indicate how often 
in what order to run scripts. 

sequentia l selector – In a LoadTest schedule, a type of selector that executes e
script, delay, or other item in the same order in which it appears in the schedu

session – In virtual user recording, one or more scripts that you record from the t
you begin recording until the time you stop recording. Typically, the scripts in a
session represent a logical flow of tasks for a particular user, with each script 
representing one task. For example, a session could be made up of three scrip
login, testing, and logout. In TestFactory, a session is the period of time that the 
TestFactory application or a window is open.

shared variable – An integer variable that multiple scripts and multiple virtual use
can read and write to. You can see the value of a shared variable while monitor
LoadTest schedule. For example, you can set a shared variable as a flag to end
playback session. Each script can check the flag to see if the session should end.
that flag is set, exit tasks can be performed.
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shell script – A script that calls or groups several other GU I scripts and plays th
back in sequence. Shell scripts provide the ability to create comprehensive test
then store the results in a single log.

SiteCheck – See Rational SiteCheck.

source code instrum entation – In TestFactory, the process of inserting code int
the source code of the application-under-test. This code measures how much 
source code a script tests. See also instrumentation and object code instrumentation.

SQ ABasic – The Robot scripting language for recording GU I actions 
and verifying GU I objects. SQABasic contains most of the syntax rules and cor
commands that are contained in the Microsoft Basic language. In addition, 
SQABasic has commands that are specifically designed for automated testing. 
See also VU .

stable load – In LoadTest, a condition that occurs when a specified number of 
virtual users have logged on to the system-under-test and are active. When the
load criterion is met, LoadTest begins measuring the load.

streak – When running a virtual user schedule in LoadTest, a series of success
failures for emulation commands. You can see a streak while monitoring a sche

structura l test – A test to determine whether the structure of a Web site is consis
and complete. A structural test ensures that an application’s interdependent ob
are properly linked together. You perform a structural test using SiteCheck.

synchronization point – In LoadTest, a place where emulated virtual users stop a
wait until all other synchronized users reach that point. When all users reach th
synchronization point, they are released and continue executing. 

Synchronizer – See Rational Synchronizer. 

system  tuning – In LoadTest, the process of optimizing a system’s performance
changing hardware resources and software configuration parameters while usi
constant workload.

system -under-test – The system being tested. This includes the computers and
software that can generate a load on the system, networks, user interfaces, CPU
memory. See also application-under-test.

test assets – The resources that facilitate the planning or development phases
the testing effort. Examples of test assets include scripts, schedules, sessions, 
documents, and test requirements.

test development – The process of developing tests to verify the operation of a 
software application. This includes creating scripts that verify that the applicatio
under-test functions properly. Test development lets you establish the baselin
expected behavior for the application-under-test.
Glossary-10
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test docum ents – Test plans, project schedules, resource requirements, and an
other documents that are important to your project. You develop your test 
documents using your own word processing or scheduling program; you then
reference the name and location of the document in TestManager. This lets 
members of the test and development team locate documents quickly.

Test Lab – A collection of computers on which TestAccelerator is running. In 
TestFactory, you can distribute the scripts associated with a Pilot, a Test Suite, o
AutoPilot to run on computers in the Test Lab. See also Rational TestAccelerator. 

Test Suite – In TestFactory, a tool for running a collection of scripts as a group.

TestAccelerator – See Rational TestAccelerator. 

TestFactory – See Rational TestFactory.

TestM anager – See Rational TestManager.

Text Com parator – The Robot component for reviewing, analyzing, and editing
data files for text and numeric verification points in any format except grids. Th
Text Comparator displays the differences between the recorded baseline resul
the actual results.

think tim e – In virtual user and GU I scripts, think times are delays that simulate
user’s pauses to type or think while using an application. With virtual user scrip
LoadTest calculates the think time at runtime, based on think time VU  environm
variables that are set in the script. You can set a maximum think time in Robot. W
GU I scripts, Robot uses the actual delays captured between keystrokes, menu
choices, and other actions.

transaction – In LoadTest, a logical unit of work performed against a server. Fo
example, submitting a search query or submitting a completed form to a Web s
are both transactions.

transaction rate – In LoadTest, the playback speed calculated as a function of 
number of transactions per unit of time. For example, if a script contains one 
transaction, and each script is started at half-second intervals, your transaction
would be 2 per second. 

transactor – In LoadTest, an item that you insert in a LoadTest schedule to indi
the number of user-defined transactions that a virtual user performs in a given
period.

U I coverage – In TestFactory, the percentage of objects in the application map 
are tested by a Pilot-generated script. This percentage is the proportion of U I ob
that the script touches, relative to all U I objects available to the Pilot. A Pilot can
U I coverage to determine the best script for a run. See also code coverage.
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U I object properties – Attributes of object classes and U I objects that TestFacto
uses to map applications and generate scripts.

unexpected active window – A window that appears during script playback that 
interrupts the script playback process and prevents the expected window from b
active. For example, an error message generated by the application-under-tes
unexpected active window. You can view unexpected active windows in the Im
Comparator.

user group – In LoadTest, a collection of users that execute similar tasks and 
generate the same basic workload. Accountants and data entry operators are ex
of user groups.

verification – The process of comparing the test results from the current build of
software to its baseline results. 

verification point – A point in an SQABasic script that confirms the state of one 
more objects. During recording, a verification point captures object information
from the application-under-test and stores it as the baseline. During playback,
verification point recaptures the object information and compares it to the base
In a manual script, a verification point is a question about the state of the applica
under-test.

virtua l user – In LoadTest, a type of user that is emulated when a virtual user sc
is executed. A computer can run multiple virtual users simultaneously.

virtual user script – A type of script written in the VU  language. Virtual user scrip
contain client/server requests and responses as well as user think times.

VU  – The Robot scripting language for recording a client’s requests to a server
VU  provides most of the syntax rules and core commands available in the C 
programming language. In addition, VU  has emulation commands and functio
that are specifically designed for automated performance testing. See also SQABasic.

wait state – A delay or timing condition that handles time-dependent activities.

workload – In LoadTest, the set of all activities that users perform in an actual 
production setting of the system-under-test. You can use LoadTest to emulate
workload.

workload balancing – In LoadTest, the act of distributing activities so no one syste
or device becomes a bottleneck.

workload m odel – In LoadTest, the workload model is represented as a schedu
You can play back this schedule and analyze the response times.
Glossary-12



ã ã ã Index
A
adding

blocks 3-14

comments 3-12

Agent computers 1-5

analyzing schedule results 1-3, 1-10, 3-44

API recording 1-7, 3-5

B
blocks

adding 3-14

in scripts 1-8

viewing in scripts 3-23

C
command IDs 3-22

in Status report 3-45

comments

adding 3-12

in scripts 1-8, 3-21

viewing in script 3-22

configuration tests 1-5

contention tests 1-5, 1-6

CPU  delays 3-6, 3-21

creating datapools 3-26

creating schedules 3-28

customer support vi

customizing reports 1-10, 3-48

D
database servers, testing 1-4

DATAPOO L_CON FIG section of script 3-23

datapools

creating 3-26

editing 3-24

including and excluding rows 3-25

selecting datapool option 3-5

viewing in scripts 3-23

DataSmart recording 1-8

delays, differentiating between CPU  and user 
3-6, 3-21

documentation, PerformanceStudio 1-11, 3-49

E
editing

datapools 3-24

scripts 3-21

emulation commands 3-21

environment variables 3-21

F
filtering scripts 3-6

G
GU I scripts 1-7

GU I users 1-5
Index-1



Index
H
help desk vi

histograms 3-39

H TTP 3-42

hotline support vi

http recording options 3-7, 3-21

http_nrecv commands 3-21

http_request commands 3-21

I
inserting

scripts 3-32

selectors 3-33

user groups 3-30

installing the tutorial 2-2

L
load tests 1-5, 1-6

M
Master computers 1-4

maximum think time 3-6, 3-21

monitoring schedules 1-3, 1-9, 3-39, 3-41

N
network recording 1-7

P
Performance report 3-46

performance testing path 1-2

planning tests 3-2, 3-3, 3-46

Progress bar 3-42

proxy recording 1-7

R
Rational Administrator 1-2, 2-3

Rational LoadTest 1-3, 1-5

Rational Robot

recording 3-8

recording scripts with 1-2

starting 3-4

Rational Suite PerformanceStudio

documentation 1-11, 3-49

Rational technical support vi

recording

scripts 3-8

sessions 3-8

starting 3-9

stopping 3-18

recording methods

API 1-7, 3-5

network 1-7

proxy 1-7

recording options, http 3-7

reports

customizing 1-10, 3-48

Performance 3-46

saving 3-47

saving output 3-45

Status 3-44

repositories 2-3

creating 2-4

storing test assets in 1-2

requirements, tutorial 2-1

running schedules 1-3, 1-9, 3-39
Index-2



Index
S
saving

Performance report 3-47

schedules 3-38

Status report 3-45

scenarios 3-29

schedules 1-8

analyzing 1-3

creating 1-8

designing 3-28

inserting scripts 3-32

monitoring 1-3, 1-9, 3-41

running 1-3, 1-9, 3-39

saving 3-38

scripts in 1-8

user groups in 1-8, 3-30

scripting languages 1-8

scripts

blocks in 1-8, 3-14

comments in 1-8, 3-12, 3-21

editing 3-21

filtering 3-6

grouping into scenarios 3-29

in schedules 1-8

inserting 3-32

languages for 1-8

recording 3-8

searching for emulation commands in 3-21

splitting 3-11, 3-13, 3-17

timers in 1-8

types of 1-7

viewing 3-21

selectors, inserting 3-33

servers, generating realistic data for 3-24

sessions, recording 3-8

setting monitor views 3-39

splitting scripts 3-11, 3-13, 3-17

SQABasic language 1-8

starting Rational Robot 3-4

Status report 3-44

stopping recording 3-18

stress tests 1-5, 1-6

support, technical vi

T
technical support vi

test requirements 3-2

test types

configuration 1-5

contention 1-5, 1-6

load 1-5, 1-6

stress 1-5, 1-6

tests, planning 3-2, 3-3, 3-46

think time 3-6, 3-21

timers in scripts 1-8

Transaction Smart analysis 1-8

tutorial

creating a repository for 2-4

determining application path 2-2

installing 2-2

requirements 2-1

U
user delays 3-6, 3-21

user groups

in schedules 1-8

inserting 3-30
Index-3



Index
V
viewing scripts 3-21

virtual user scripts 1-7

virtual users 1-5

VU  environment variables 3-21

VU  language 1-8

W
Web servers 1-4

testing 3-3

workloads 1-8

representing 3-28
Index-4


	Contents
	Preface
	Other Resources
	Using Help
	Dialog Box Help
	Menu Command Help
	Toolbar Button Help

	Contacting Rational Technical Publications
	Contacting Rational Technical Support

	About Rational Suite PerformanceStudio
	The Path to Successful Performance Testing
	Setting Up Your PerformanceStudio Test Lab
	Types of Tests
	Performance Tests
	Load Tests
	Stress Tests
	Contention Tests
	Configuration Tests


	Recording Scripts
	Types of Scripts
	Methods of Recording
	Generating Scripts


	Creating Schedules
	Running and Monitoring a Schedule
	Analyzing Results
	Where to Look Next

	Before You Begin
	Tutorial Requirements
	Copying the Tutorial Files
	Locating Internet Explorer
	Specifying Internet Explorer Settings
	Setting Up a Repository for the Tutorial

	Tutorial
	Is This Tutorial for You?
	Purpose of the Tutorial

	Step 1: Planning a Test
	Identifying the Hardware and Software Required for Testing
	Mapping Out Your Testing Plan
	Where to Go for More Information

	Step 2: Setting Recording Options
	Starting Rational Robot
	Setting Recording Options
	Where to Go for More Information


	Step 3: Recording Scripts
	Starting the Recording Session
	Splitting a Script
	Adding a Comment
	Splitting the Script
	Adding a Block
	Splitting the Script
	Finishing the Session
	Where to Go For More Information

	Step 4: Examining the Recorded Scripts
	Where to Go For More Information

	Step 5: Generating Realistic Data to Send to the Server
	Where to Go For More Information

	Step 6: Designing a Schedule to Represent Your Workload
	Inserting User Groups into Your Schedule
	Inserting Scripts and Selectors into Your Schedule
	Copying the Open and Close Scripts into the User Groups
	Emulating the Window Shoppers Workload
	Emulating the Regular Buyers Workload
	Emulating the Big Spenders Workload

	Saving the Schedule
	Where to Go For More Information

	Step 7: Running the Schedule
	Setting the Information You See During a Schedule Run
	Running a Schedule
	Monitoring the Schedule
	Where to Go For More Information

	Step 8: Running Reports
	Running and Monitoring a 20-User Schedule
	Where to Go For More Information

	Wrapping Up

	Glossary
	Index

