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ã  ã  ã Preface
Rational LoadTest is a sophisticated tool for automating performance and distributed 
functional tests on client/server systems. You can use LoadTest to test Web, database, 
or transaction servers connected to clients on the network. LoadTest lets you run 
tests that emulate hundreds, or even thousands, of users on just a few computers. 

This guide is intended to help application developers and system testers use 
LoadTest to create, edit, run, monitor, analyze, and manage automated tests that 
run across a network.

Other Resources
ã This product contains complete online H elp. From the main toolbar, 

choose an option from the H elp menu. 

For information about context-sensitive H elp, see the following section.

ã All manuals are available online in PDF format. These online manuals are on the 
Rational Solutions for Windows Online Documentation CD.

ã For information about training opportunities, see the Rational U niversity 
Web site: http://www.rational.com/university.
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Preface
Using Help
This product contains context-sensitive H elp for dialog boxes, menus, and toolbars.

Dialog Box Help
Most dialog box H elp includes overviews and detailed item information. 

Menu Command Help
For menu command H elp, highlight the command and press F1, or click the H elp 
button on the toolbar and select the command. A brief description of the command 
also appears in the status bar. 

Toolbar Button Help
For toolbar button H elp, pause the pointer over the button. A yellow ToolTip 
appears below the button, and a brief description appears in the status bar. For more 
detailed information, click the H elp button on the toolbar, and then select the button 
for which you want more information. 

Contacting Rational Technical Publications
To send feedback about documentation for Rational products, please send e-mail 
to our technical publications department at techpubs@rational.com. 

Click th is to  see an 
overview of the d ia log box.

Click th is and then click an  
item  to see in form ation 
abou t the item .
xiv



Contacting Rational Technical Support
If you have questions about installing, using, or maintaining this product, 
contact Rational Technical Support as follows:

Rational Technical Support

Location Contact Information Notes

North America Telephone:
800-433-5444 
408-863-4000

E-mail:
support@rational.com

Please be prepared to supply 
the following information:

– Your name, telephone number, 
and company name

– Computer make and model

– Operating system and
version number

– Product release number 
and serial number

– Your Case ID number (if you 
are calling about a previously 
reported problem)

Europe Telephone:
+31 (0) 20 4546 200

E-mail:
support@europe.rational.com

Asia Pacific Telephone:
+61-2-9419-0111

E-mail:
support@apac.rational.com

World Wide Web http://www.rational.com Click the Technical Support link.
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What Is LoadTest?
This chapter introduces Rational LoadTest. It includes the following topics:

ã About LoadTest

ã LoadTest basics

ã Testing response times

ã The LoadTest environment 

ã Logging into LoadTest

About LoadTest

Rational LoadTest is a sophisticated tool for automating performance tests and 
distributed functional tests on client/server systems. A client/server system includes 
client applications accessing a database or application server, client applications 
accessing the TU XEDO  TP monitor, or browsers accessing a Web server.

LoadTest is completely integrated with the other components of Rational 
PerformanceStudio, including:

ã Rational Robot for recording sessions, and for generating and editing scripts

ã Rational TestManager for managing test assets, such as sessions, scripts, 
schedules, and reports

ã Rational LogViewer for viewing the user log files and the user error files, which 
contain the emulation data and the errors that occurred while running a VU  
script

With its intuitive point-and-click graphical user interface, LoadTest lets you play 
back the scripts you developed with Robot according to a schedule that you create. 
You can monitor the schedule’s progress, and you can analyze the results to se
the client application and the server perform under varying workload and stres
conditions.
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LoadTest helps you discover and correct performance problems before you deploy 
your application in the real world. With LoadTest, you have all of the tools you need 
to identify, isolate, and analyze performance bottlenecks. 

As an automated load testing tool, LoadTest emulates one or many users performing 
various computing tasks. By replacing actual users with virtual users, LoadTest 
removes the need for actual users to manually add workload to the server.

Because LoadTest lets you play back the activities of multiple users on a single 
computer, you can run tests involving hundreds, or even thousands, of users on just 
a few computers—or on one computer. 

Why Use LoadTest?
While LoadTest has a range of uses, it excels in solving performance issues su
the following:

Problem LoadTest Solution

Does the server perform correctly 
under load?

Conduct stability and stress testing of the network and
servers under maximum workload conditions.

Does the system meet scalability 
requirements?

Determine the number of users a server can support 
before the system is released.

What level of performance will the 
clients achieve? Can the server deliver 
acceptable response times during 
simultaneous access by large numbers 
of users?

Measure the response times of server operations, as se
by the client under varying transaction rates and worklo
mixes. In addition, you can determine:

ã Application response time (average case, best case, 
worst case).

ã H ow response time varies under different compute
configurations.

ã A server’s response time when a given numbe
virtual users are running against it.

ã How rapidly a client’s response time falls as th
number of virtual users accessing the server in

ã The server’s hit rate when Web testing is being
conducted.

ã The error rate and error breakdown.
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LoadTest lets application developers, system testers, and system integrators test 
multi-user client/server systems. LoadTest can be used to add maximum workload 
conditions to the network and server in a client/server environment, or to distribute 
GU I functional tests over several computers, thereby reducing the total testing time. 
With LoadTest, you can coordinate multiple computers, as well as emulate multiple 
virtual users, from a single computer running Windows N T. 

Robot records user activities, and then automatically creates a script that represents 
the user’s interactions with the server, as well as all queries and responses. 

Before you begin planning and developing tests, you should be familiar with th
following LoadTest concepts:

ã Scripts

ã The scripting languages

ã Sessions

ã Master and Agent computers

ã Schedules

ã The types of “users” that you emulate by recording and playing back scripts

ã The types of tests that LoadTest helps you perform

H ow do the access patterns of database 
tables affect performance? When is 
table or row locking a problem?

Run contention tests that analyze throughput and 
capacity under varying transaction rates, workload mix
and server configurations.

What was the percentage of 
improvement for client response times 
after the last tunable parameter change?

Place reproducible workloads on the server to objectiv
measure tuning efforts.

Does the latest release of the database 
server produce the same output and 
error detection as the previous release?

Test functional regression of database operations.

Which queries cause performance 
problems?

Isolate queries that perform poorly.

 (Continued) 

Problem LoadTest Solution
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Scripts
Much of your testing effort involves planning and recording scripts. The purpose of 
planning and recording scripts is to later play them back in a test to emulate user 
activity.

A script has two basic features:

ã A file that can be executed by Robot or by a LoadTest schedule

You generate a script when you record your GU I activities or client/server 
requests with Robot. Robot translates your GU I activities or client/server 
requests into scripting language commands (SQABasic for GU I activities, VU  
for client/server requests), and writes them to the script.

ã A set of properties, such as the type and purpose of the script

Typically, you define the script’s properties when you plan the script with 
TestManager. You can also define script properties in Robot or LoadTest a
you record the script.

Two Perspectives on Scripts
When you plan tests in TestManager and when you record tests in Robot, you
probably think of scripts in the context of the script and its properties.

But when you play back a script in a LoadTest schedule, think of that runtime 
instance of the script as a “user”—an emulated user performing the tasks that 
recorded.

The Scripting Languages
The SQABasic and VU  scripting languages are used to represent GU I and virt
user emulations. Depending on the type of emulation that you specify, Robot 
automatically creates the script in one of these languages when you record a s

GU I scripts – Contain SQABasic code for playing back the GU I activities that yo
recorded. SQABasic is the language for writing GU I scripts. It uses most of the
syntax rules and core commands found in the Microsoft Basic language. If you
familiar with Microsoft Basic or Visual Basic, you are already familiar with much 
the SQABasic language. For more information, see the SQABasic Language Reference.

Virtual user scripts – Contain VU  code for playing back the client/server reques
you recorded.The VU  language is a C-like scripting language. It shares much o
syntax rules, operators, and library functions with the C language. If you are fam
with the C language, you are already familiar with much of the VU  language.
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A VU  script communicates to the LoadTest system what needs to be done to 
perform the desired virtual user emulation. For more information, see the 
VU Language Reference.

You cannot mix SQ ABasic code and VU  code in the same script.

Sessions
When you record virtual user scripts, you are actually recording a session. A session 
contains all of the client requests and server responses issued from the time you 
begin recording until the time you stop recording. During virtual user recording, 
you can direct Robot to split the session into more than one script. 

If you do not split the session into multiple scripts, the session will consist of a single 
script that you name at the end of recording. 

H owever, splitting a session into scripts is a convenient way to let you treat sections 
of the recording session differently in a LoadTest schedule. For example, suppose 
you log into a database server and perform three different transactions. If you split 
the session so that the login and each transaction is a separate script, you can then set 
up the schedule to perform many iterations of the transactions but perform the login 
script only once.

The names of sessions and scripts are independent, although if the session consists 
of only one script, you should generally give it the same name as the script so you 
know that the script and the session are associated with each other.

Master and Agent Computers
You coordinate the activities of all your scripts from a single N T computer where 
LoadTest is running, known as the M aster computer. From the Master computer, 
you create, run, and monitor schedules. 

During the execution of a test, you play back scripts on the Master computer, 
or on computers that you have designated as Agent com puters. You use an Agent 
computer for the following:

ã Adding workload to the server – If you are running a test with a large numbe
of users, you can use Agent computers to add load to the server.

ã Running schedules with m any GU I users – If you are running a schedule with
more than one GU I user, you need an Agent computer, because only one
user can run on each computer.
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ã Running scripts on m ore than one com puter – If you are running a functional 
test, you can save time by running the scripts on the next available Agent 
computer instead of having the Master computer run all the scripts. O f cou
the scripts must be modular and independent.

ã Testing hardware configurations – If you are testing different hardware 
configurations, you can run scripts on different Agent computers that are se
with these hardware configurations.

Schedules
Typically, multiple scripts and multiple computers are involved in a test. At runtim
script playback is coordinated by schedules that you design. These schedules add a
emulated workload to the server. You run these schedules from the Master 
computer.

Once you have used LoadTest to create schedules that describe a baseline of be
for the server, you can run these schedules repeatedly against successive build
your product, and you can analyze the results using LoadTest’s reporting tools

Types of Users
In LoadTest, there are two types of emulated users—GU I users and virtual us. 

GUI Users
A GU I user is a single instance of a GU I script running on a computer. Only on
GU I user at a time can run on a computer.

A GU I user emulates the activities that actual users perform as they interact with
application in their daily work. Such activities include keystrokes and mouse 
movements.

In general, you include GU I users in functional tests. With LoadTest, however, 
can also use GU I users in performance tests. For information about functiona
performance tests, see Types of Tests on page 1-7.

Virtual Users
A virtual user is a single instance of a virtual user script running on a computer
U nlike GU I users, many virtual users can run on a computer simultaneously.

A virtual user emulates client/server requests sent to a server. When you recor
virtual user script, Robot records a client’s requests—such as Oracle, Microsoft 
Server, and HTTP requests—to the server. Robot also records the server’s 
responses. This network traffic is the only activity that Robot records. Robot ign
GU I actions such as keystrokes and mouse clicks.
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You include virtual users in performance tests. For information about performance 
tests, see Performance Tests on page 1-7.

Because many virtual users can run on a computer simultaneously, virtual users let 
you add a workload to a client/server system. Virtual users also let you determine 
scalability and measure server response times. 

GUI Users vs. Virtual Users
The following table summarizes the differences between GU I users and virtual 
users:

Types of Tests
You can use LoadTest to perform the following types of tests: 

ã Performance tests

ã Distributed functional tests

Performance Tests
A perform ance test helps you determine whether a multi-client system is 
performing within user-defined standards under varying loads. Performance tests 
require the LoadTest software.

GUI User Virtual User

Only one GU I user can run on a computer at 
one time.

Many virtual users can run on a computer at 
the same time.

Plays back GU I actions such as keystrokes 
and mouse clicks against GU I objects. These 
actions are recorded and stored in GU I 
scripts, written in the SQ ABasic language.

Plays back the requests that a client sends to 
a server. These requests are recorded and 
stored in virtual user scripts, written in the 
VU  language.

Can be used in functional tests and 
performance tests.

U sed in performance tests to add user load 
to the system —for example, to measure 
server response times under varying 
workloads.

Runs either in Robot or in a LoadTest 
schedule.

Runs in a LoadTest schedule only.

N O TE: A third type of automated testing, structural testing of Web sites, is 
described in the Rational Robot: Try It! With Rational SiteCheck card.
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Performance tests involve loading the server with many virtual users. For example, 
you might have a timer in one virtual user to find out how much time a query takes 
when 1000 other virtual users are sending requests to the same server at the same 
time. 

Additionally, one or more GU I users can be included in the test to measure a variety 
of performance issues that occur when many virtual users are running against the 
same server. Because GU I users measure client response times, this end-to-end 
response time is more indicative of what a real user experiences when there is 
significant client processing or screen-painting time associated with the user activity 
than you are measuring. Also, a GU I user is a good cross-check for your virtual user 
responses.

The term “performance testing” includes the following types of tests:

ã Load tests

ã Stress tests

ã Contention tests

ã Configuration tests

Load Tests 

Load testing is designed to test client or server response times under varying lo
Load tests also are used to help testers compute the maximum number of 
transactions a server can handle over a given time period. In addition, when a c
server system uses workload balancing or a distributed architecture, load testin
help ensure that the load balancing or distribution methods work as designed.

Load tests can involve virtual users only (for measuring server response times)
virtual users and GU I users (for measuring client response times). 

Stress Tests 

Stress testing is the process of running your client application under extreme 
conditions to see if they or the server “break.” Examples of stress testing includ

ã Continuously running a client application for many hours.

ã Performing a large number of transactions.

ã Having hundreds of users perform the same operation or a specific combina
of operations at virtually the same moment. 

Other types of stress on the system include insufficient memory, unavailable ser
or hardware, or diminished shared resources on the server.
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Stress testing helps you ensure that your client application or the server is able to 
handle production conditions, where the ineffective management of computer 
resources can result in system crashes.

You can test he following types of stress conditions:

Contention Tests 

Contention testing involves executing a combination of GU I and virtual users on 
one or more computers to simulate an actual user environment. For example, you 
might have GU I users and multiple virtual users accessing the same database to 
reveal problems in areas such as locking, deadlock conditions, and concurrency 
controls.

Contention testing is often difficult to perform because it requires precise 
coordination between users. In LoadTest’s point-and-click environment, you c
conduct multi-computer tests in which GU I and virtual users wait for conditions
be satisfied on their own computers, or on other computers, before they contin
running. For example, you can have a GU I user on one computer add a recor
database, and have a GU I user on another computer pause before attempting 
the record until the first GU I user finishes its script.

If you want to run a contention test under heavy user conditions, virtual users 
add the load.

Type of stress condition Type of users needed

A heavy volume of users performing the 
same activity simultaneously

Virtual users

A few users continuously repeating the 
same action on the client application 
hundreds or thousands of times or over 
long periods of time

GU I users

A few users continuously repeating the 
same client requests to a server hundreds 
or thousands of times or over long periods 
of time

Virtual users

Combinations of the preceding three 
conditions

Virtual and GU I users
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Configuration Tests 

In today’s heterogeneous client/server environments, each user’s computer can
a different mix of hardware and software, creating a risk that the application softw
will run on some computers and not others. In configuration testing, you want
ensure that your product will continue to run on multiple platforms.

LoadTest lets you easily schedule the same tests to run on different Agent comp
which in turn lets you:

ã Test for compatibility issues.

ã Determine the minimum and optimum configuration of hardware and softw
for running the application.

ã Learn how each part of your application performs on each computer.

While you typically perform configuration testing with GU I users only, you can a
load your client/server system with virtual users to test the effects of adding mem
more processors, and so on.

Distributed Functional Tests
D istributed functional tests allow multiple GU I objects to be tested simultaneous
in a distributed, efficient QA lab environment.

Fully testing a Windows client/server application might require running hundred
GU I scripts. The testing process will take a long time if each GU I script must b
executed sequentially in Robot on a single computer. You can accelerate the pr
considerably by distributing the GU I scripts over multiple computers and runn
them with LoadTest.

Because LoadTest lets you execute a number of different scripts simultaneous
networked computers, and control the execution of those scripts from a single
computer, LoadTest is extremely useful for performing distributed functional 
testing.

Assigning scripts to multiple computers through the next available selector is 
particularly useful in distributed functional testing. With this feature, you can ass
scripts to the next available computer, creating a reliable and efficient QA lab 
operation. If a computer crashes or loses network connectivity during test execu
testing does not stop—LoadTest simply assigns scripts to one of the other ava
computers.

You perform distributed functional testing with GU I users only.
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Testing Response Times

LoadTest lets you measure various indicators of performance. Whereas distributed 
functional testing measures correctness in terms of straightforward “pass/fail” 
responses, performance testing measures time: How long did it take for the acti
complete? How quickly was the server able to respond under heavy load condit
You can measure the client response time or the server response time, or both

The following sections explain the difference between server and client respon
times.

Client Response Time
When you use timers in a GU I script, the client response times that you meas
include GU I activities and GU I overhead, such as the time it takes to display a s
records retrieved in a database query. 

Testing client response times under varying load conditions requires:

ã Multiple virtual users loading the system by sending requests to a server.

ã One or more GU I users acting as the client application. The GU I user run
against the same server as the virtual users that are loading the system. SQA
timers in the GU I script measure client response times for individual activi
(such as accessing a database or Web site) or a sequence of activities (suc
accessing a Web site and sending a query to the server).

SQABasic timers measure the duration of GU I activities in a script. For 
example, you may want to measure the time required to perform a databa
transaction on a remote server, or how long it takes the application to perfo
tasks on client computers with different hardware configurations. For more
information about timers, see the Using Rational Robot manual.

Server Response Time
Server testing generally focuses on finding where bottlenecks and overload can
problematic. You identify potential problem areas by testing server response tim
under varying user loads.

In a virtual user script, the server response times are automatically measured fo
emulation command, typically consisting of a single or a few server requests. A s
user transaction can consist of many emulation commands. To measure the ti
this entire block of commands, you can insert timers around the activity of inter
either during recording or by editing the script. 
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Testing Web Servers
To test Web server response times, you load the system with virtual users. You can 
measure the response time for a single server request, for a block of requests, or for 
multiple requests. 

You start a timer when a request is made, and then stop the timer after the ser
response. This measures how long the server takes to process the request and
information, without the additional time required for GU I overhead within the 
client application.

Testing Database Servers
You can use timers in GU I and virtual user scripts to measure client response t
in a client/server system under the load of other virtual users. 

LoadTest can be used to simulate large numbers of networked TU XEDO 
workstation client users, measuring the responsiveness of both TU XEDO syst
and application server processes. Because the LoadTest TU XEDO emulation 
commands are modeled after the industry-standard XATMI and TU XEDO AT
application programming interfaces, extremely accurate test cases can be produ
stress every aspect of a TU XEDO server's performance.

Since there is an emulation command for every load-generating TU XEDO 
primitive, it’s easy to measure individual response times for service calls, transac
commits, and rollbacks, as well as many other message broadcasting, queuing
event brokering operations. You can even measure initial client connection tim
aid in tuning workstation listener and workstation handler resources. All TU XED
client/server communication modes and standard typed buffer types are suppo

The LoadTest Environment

LoadTest enables you to run a schedule in a distributed environment consistin
single Master computer that runs under Windows N T (on which you coordinate t
execution and play back scripts), and zero or more Agent computers (on which
play back scripts). 
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The LoadTest Environm ent
An Agent computer can run on Windows 95 or 98, Windows N T, Windows 2000, 
or any of the supported U N IX Agent platforms. The following table shows the types 
of users you can run on the Agent platforms:

The following figure illustrates a typical LoadTest configuration:

The server can run under a variety of operating systems, and can be connected to the 
Master and Agent computers over a TCP/IP network.

Agent platform Type of user

Windows 2000

Windows N T 4.0

Windows 95 and 98

Solaris 2.x

AIX 4.x

H P/U X 10.x and 11.x

Sequent Dynix

GU I users and virtual users

GU I users and virtual users

GU I users

Virtual users 

Virtual users 

Virtual users 

Virtual users

M aster com puter
WinN T4 .0  or Win 2000

WinN T4 .0 U N IX , 
WinN T4 .0 ,

Virtual users

W in 95 Win 98
Server

Agent com puters

GU I users

Win 2000

Win 2000
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Logging into LoadTest

After you have planned your tests and recorded your scripts, you are ready to put 
them into a schedule. To do this, you must log into LoadTest. 

To log into LoadTest:

1 . Click Start → Program s → Rational Perform anceStudio 7 .1  → Rational 
LoadTest. The Rational Repository Login dialog box appears:

2 . Type your user ID and password. If you do not know these, see your 
administrator.

3 . Select a repository from the Repository Path box.

4 . Select a project from the Project box.

5 . Click O K  to log in.
1 -1 4



ã  ã  ã C  H   A   P  T  E  R   2

Before You Begin
This chapter provides guidelines for planning performance testing against a database 
server and for functional testing with GU I users. It includes the following topics:

ã About performance and functional tests

ã Planning performance tests

ã Planning functional tests

About Performance and Functional Tests

When you plan tests, you must first determine whether you are interested in 
performance testing, functional testing, or both types of testing. 

In performance testing, you can measure the following things:

ã The client response time. This is the time it takes for a GU I user to enter a 
request, the server to respond to the request, and the GU I user to see the results. 
If you are interested in the total end-to-end response time, as seen by the user, 
you run a performance test with GU I users.

ã The server response time. This is the time it takes for the server to process a 
request. If you are interested in the server response only, you run a performance 
test with virtual users. 

Functional testing involves GU I users. You are testing the accuracy of the application 
and how it behaves on different computers. You need only a few users to do this.

Functional testing tends to have well-defined objectives and outcomes. For example, 
if the application has a feature that saves a file to disk, it is relatively straightforward 
to test this feature. If a file gets saved correctly, it passes the test. If it does not get 
saved correctly, it fails the test.
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Performance testing can be more complex than functional testing because 
performance itself is subjective. What one user might perceive as too slow, another 
user might perceive as perfectly acceptable. Therefore, when planning performance 
tests, you need to put some thought into what constitutes acceptable performance.

Another complication of performance testing is that performance varies widely 
depending on workload conditions. Querying a database on a system that is primarily 
used for CPU -intensive activities yields a different response time than performing 
the same query on a system used primarily for generating I/O-intensive database 
reports.

The following table summarizes the main differences between performance and 
functional tests:

Planning Performance Tests

Testing the performance of a server typically involves loading the server with many 
virtual users. The objective is to find out how the server performs under the load.

Some of the performance questions you might want to answer are:

ã H ow many virtual users can the server support under normal conditions?

ã Are there any situations where server performance degrades suddenly under 
normal conditions?

Functional Tests Performance Tests

Answer the question: “Does the system do 
what it is designed to do?”

Answer the question: “How quickly does the 
system perform what it is designed to do?”

Focus on how the system behaves against 
the functional or the design specification. 
The system must work as specified.

Focus on how the system behaves when 
executing actual business operations. 

Do not use a workload model. Model an actual workload, which is an 
approximation of the real-world environment 
you are trying to emulate.

Might deliberately use incorrect data to 
test error recovery and error handling. For 
example, if a field accepts a number from 
1 to 100, the test might use the numbers 
100, 1, 0, 101, and -1.

U se data that mirrors the actual work done. 
For stress tests, the data might not mirror the 
actual work done but instead will stress the 
capacity of the system.
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ã H ow does the system perform when you exceed the normal conditions? In a 
worst-case scenario, does the system degrade gracefully or does it break down 
completely?

ã H ow does the system perform under varying hardware configurations?

The following sections discuss the key steps that are involved in planning a test.

Setting Pass and Fail Criteria for Performance Tests
Because performance can be subjective, it is essential that you not only identify the 
features to be tested but that you also determine the criteria that will determine 
whether performance passes or fails. The pass or fail criteria will often involve a 
range of acceptable response times. For example, you could define the following as 
an acceptable response time:

ã At 100 users, 90% of all transactions have an average response time of 5 seconds 
or less. N o response time can exceed 20 seconds.

ã At 500 users, 80% of all transactions have an average response time of 10 seconds 
or less. N o response time can exceed 45 seconds.

Identifying Performance Testing Requirements
When planning a performance test, you need to determine the hardware and 
software that your test requires. For example:

ã Server computers: database servers, Web servers, other server systems

ã Client computers: Windows N T, 95, or 3.1 computers; network computers; 
or Macintosh or U N IX workstations

ã Databases that will be accessed

ã Applications that will be running

In addition, you need to determine the following parameters for your tests:

ã H ow large should the test databases and other test files be in order to accurately 
represent the real workload?

ã H ow should the data be distributed across the server in order to prevent I/O  
bottlenecks?

ã If you are testing a database, how should the key database parameters be set?
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Designing a Realistic Workload
If you are testing performance, it is essential that your workload model mirror the 
workload at your site. Therefore, you must determine the types of transactions that 
occur at your site. For example, do your users generally query the database and 
update it occasionally, or do they update it frequently? If they update the database 
frequently, are the updates complex and lengthy, or are they short? 

H ere are some additional factors to consider when designing the workload:

ã The workload interval – The period of time the workload model is supposed 
represent. For example, the workload interval could be a peak hour, an ave
day, or an end-of-the-month billing cycle.

ã Test variables – The factors you will change during the performance test. F
example, you might vary the number of users to understand how response
degrades as the workload increases.

It is best to change only one variable at a time. If performance changes, you k
that the change was caused by that variable.

You set these test variables when you set up a schedule. For more informa
see Designing Schedules on page 7-1.

ã Functional user classifications – Categorize the users into groups based on t
types of activities they perform. For each user group, you need to identify t
number of users or the percentage of overall users. For example, you migh
group 20% of the users into Accounting, 30% of the users into Data Entry, 
50% of the users into Sales.

You set up user groups in a schedule. However, you should plan your scri
beforehand so that when you record them they reflect the actions of a use
group. For more information about setting up user groups, see Inserting User 
Groups into a Schedule on page 7-5.

ã U ser work profiles – The set of activities that the users perform and the 
frequency with which they perform them. The user actions should mirror a
closely as possible the mix of tasks that the users actually perform. For exam
if the Sales user group access the database 70% more than the other two g
be sure that the workload reflects this.

ã U ser characteristics – Determine how long a user pauses before executing
transaction, the typing rates, and the number of times a transaction is exec
consecutively. It is important to model the user characteristics accurately 
because the values directly affect the overall performance of the system. F
example, a user who thinks for 5 seconds and types 30 words per minute p
much smaller workload on the system than a user who thinks for 1 second
types 60 words per minute.
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You use delays and think times to model the user characteristics. For more 
information about delays, see Inserting a Delay on page 7-19. For more 
information about think times, see Think maximum (ms) on page 3-16.

When designing a workload, make sure to consider factors such as these to ensure an 
accurate test environment.

Designing Performance Tests
Once you have decided on the pass and fail criteria, hardware and software 
requirements, and workload model, you are ready to record the user actions and set 
up the tests. Some questions you might consider are:

ã The term ination conditions – If one user fails, should the test stop or should
keep running? Generally, if you are implementing a large number of virtual u
tests and a few virtual users fail, the test can remain running. However, if a
virtual user that performs a fundamental task (such as setting up the datab
fails, the test should stop.

You set termination conditions in the schedule. For more information abou
setting termination conditions, see Controlling How a Schedule Terminates on page 
7-64.

ã The stable workload – Should the test wait until all the users are connected,
should the test begin running immediately? Generally, if you are trying to 
measure the response time for users, you should wait until they are all run
before the actual testing begins.

You define a stable workload for reporting purposes in the Performance rep
For more information, see Reporting on a Stable Load on page 9-25.

ã The applications that you will test – It will not be cost-effective to test all of 
your applications. You do not want to spend your time and resources tryin
include an application that has little effect on overall performance—for 
example, you might not want to include an application that updates a databa
the end of the year. In general, you want to identify the 20% of the applicati
that generate 80% of the workload on your system. You also need to limit t
number of applications to reduce test complexity.

ã The level of information to be logged – Typically, you set the 
Record_level environment variable to ESSENTIAL so you can calculate 
response times.

Leave the Log_level environment variable at its default setting of ALL 
during the early stages of script creation and testing. This is useful in debug
scripts. When you are satisfied that your VU  scripts are performing as desir
set the log level to ERROR. 
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Set the log level to ERROR when doing medium to large multi-user runs. This 
saves disk space. Logging all commands instead of only those that fail can quickly 
consume hundreds of megabytes of disk space. It also consumes CPU  overhead, 
so it will reduce the number of users you can run on each computer. 

You set the level of information logged when you set up a schedule. For more 
information about setting these levels, see Editing the User Settings on page 7-38.

You also need to set up a test database, since you will probably not run your tests on 
the production database.

Examples of Performance Tests
The following sections outline the objectives and approaches for some typical 
performance tests. Each test objective is accompanied by a table that outlines the key 
elements you might include when defining the test. The tables are intended only as 
a guide. They do not attempt to define all the possible elements you can include in 
your performance tests. 

Number of Virtual Users Supported Under Normal Conditions
You want to determine the number of users that a server can support before you 
release the system. You want to be sure that the system can meet your scalability 
requirements. H ow many users can the system support before the response is 
unacceptable?

Assume that your database system is estimated to support approximately 500 users. 
Therefore, you initially plan to run your schedule with 300, 400, 500, 600, and 700 
users concurrently performing multiple tasks. The following table shows the key 
elements you might include when designing the test:
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Incrementally Increasing Virtual Users
A common requirement in performance testing is to model what happens across a 
span of time as different users perform their work. For example, you might want to 
test how your server performs early in the morning when people are arriving for 
work and starting their day. You might also want to know how the server handles an 
increasing workload during the day and particularly those times of peak load. 

With LoadTest, it is easy to model this type of workload by incrementally loading 
virtual users. To incrementally load virtual users, you first develop a model of the 
workload that you want to test. For example, you write down the frequency and 
volume of use of your applications. Then, when setting up your schedule, you do the 
following:

ã Define scheduling methods to start different virtual user groups at different 
times during the life of the schedule.

ã For each virtual user group, set the number of virtual users that will run the 
script and, optionally, an iteration count, that are appropriate for your test.

By layering the start time and iteration count of your virtual users, you can build up 
load incrementally, or you can add spikes of load at specific times in your schedule 
run.

Scripts Schedule Reports

A script to initialize the 
database.

A script to log users in. 

A script for each user task: 

ã adding records
ã deleting records
ã querying the database
ã running payroll 

reports 

A fixed user group with one 
user. This user logs in, 
initializes the database, and 
sets an event indicating that 
the database is initialized.

A scalable user group with 
many users. This group logs 
in and waits until the event is 
set. It then executes the 
scenario.

A scenario that contains:

ã a selector to randomly 
select a script

ã a script for each user task

LogViewer report to 
show whether all users in 
the schedule successfully 
ran to completion.

Status report to show 
whether the server 
completed its requests 
successfully.

Performance reports for 
each schedule run: 300, 
400, 500, 600, and 700 
users.

Compare report 
comparing the output of 
all five Performance 
reports.
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The following list describes a sample test that represents overlapping shifts:

ã Suppose you start a schedule with 100 virtual users. Because this group of virtual 
users represents the early shift of entry clerks repeating the same group of order 
entry transactions over and over, you set each virtual user to run many iterations 
of the transaction —enough iterations to keep this group of virtual users runni
the script until the schedule ends. You may have to experiment to determi
how many iterations are needed.

ã Then, through a schedule, you set a D elay. The D elay type might be from the 
start of the schedule, or it might begin at a certain time of day. When the d
is over, 200 new virtual users begin. This is the next shift of entry clerks, wh
overlaps the first shift. 

ã During the combined shift, which represents peak load, 300 virtual users wi
performing their transactions repeatedly.

The following table summarizes a sample test that represents overlapping shift

Scripts Schedule Reports

A script to initialize the 
database.

A script to log users in. 

A script for each user task: 

ã adding records
ã deleting records
ã querying the database
ã running payroll 

reports 

A fixed user group with one 
user. This user logs in, 
initializes the database, and 
sets an event indicating that 
the database is initialized.

A fixed user group with 100 
users. Each user logs in and 
waits until the event is set. 
Each user then executes 
many iterations of the 
scenario.

A fixed user group with 200 
users that delays for 2 hours. 
each user then logs in, 
checks that the event is set, 
and executes many iterations 
of the scenario.

O ne scenario that contains:

ã a selector to randomly 
select a script

ã a script for each user task

LogViewer report to 
show whether all users in 
the schedule successfully 
ran to completion.

Status report to show 
whether the server 
completed its requests 
successfully.

Two Performance 
reports: 

ã One report on the 
time period from the 
start of the run until 2 
hours have passed

ã One report on the 
time period from 2 
hours until the end of 
the run

Compare report 
comparing the output of 
both Performance 
reports.
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How a System Performs Under Stress Conditions
Stress testing can be referred to as a relentless attempt to cause a breakdown in the 
server. You might suspect that there are some weak areas of the server that may break 
down or diminish due to some operation being performed a very high number of 
times or over a long period of time.

Since stress tests perform multiple simultaneous operations (such as sending 
hundreds of queries to the server at the same moment), virtual users provide the 
most practical and effective means of performing this type of stress test. Running 
virtual user scripts continuously helps you understand the long-term effects of 
running the application under stressful conditions.

In a simple stress test, you might want to conduct a test where virtual users perform 
the same operation continuously and repeatedly for hours on end. Your test might 
involve:

ã Inserting thousands of records into a database

ã Sending thousands of query requests to a database

The following table summarizes a sample stress test:

Scripts Schedule Reports

A script to initialize the 
database.

A script to log users in. 

A script for each user task: 

ã adding records
ã deleting records
ã querying the database
ã running payroll 

reports 

A fixed user group with one 
user. This user logs in, 
initializes the database, and 
sets an event indicating that 
the database is initialized.

A scalable user group with 
1000 users. Each user logs in 
and waits at a sync point. 
When all the users are 
synchronized, each user 
executes many iterations of 
the scenario.

O ne scenario that contains:

ã a selector to randomly 
select a script

ã a script for each user task

LogViewer report to 
show whether all users in 
the schedule successfully 
ran to completion.

Status report to show if 
the server behaved 
correctly, even under 
stress.

Performance reports for 
each schedule run: 900, 
1000, and 1100 users. 
These Performance 
reports show when the 
system starts to degrade, 
and ensure that the 
degradation is graceful.

Compare report 
comparing the output of 
each Performance report.
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How Different System Configurations Affect Performance
LoadTest lends itself well to configuration testing because of the way a schedule is 
organized and run. You might conduct a configuration test for a variety of reasons
for example:

ã You want to test how your system performs with more (or less) memory. 

ã You want to test how your system performs with a different amount of disk
space. 

ã You might have several types of network cards that you want to experiment 
to see which provides the best performance.

Since you are testing the same scripts under different configurations, you would
a schedule, change the computer configuration, and run another schedule wit
same number of users on the same computer. If you physically change servers
must alter the “connect” line of the VU  script.

The following table summarizes a sample configuration test for 100 users:

Scripts Schedule Reports

A script to initialize the 
database.

A script to log users in. 

A script for each user task: 

ã adding records
ã deleting records
ã querying the database
ã running payroll 

reports 

A fixed user group with one 
user. This user logs in, 
initializes the database, and 
sets an event indicating that 
the database is initialized.

A fixed user group with 100 
users. Each user logs in and 
waits until the event is set. 
Each user then executes 
many iterations of the 
scenario.

O ne scenario that contains:

ã a selector to randomly 
select a script

ã a script for each user task

LogViewer report to 
show whether all users in 
the schedule successfully 
ran to completion.

Status report to show if 
the server returned 
expected responses, even 
under stress.

Performance reports for 
each schedule run on 
each configuration.

Compare report 
comparing the output of 
each Performance report.
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Planning Virtual User Scripts
During the test planning phase, you can use Rational TestManager to define script 
properties before you actually record the script in Robot. 

Script properties include:

ã The script name, description, owner, purpose, and test environment

ã Related assets such as test requirements

ã N otes and specification files

ã Custom keywords

To plan scripts and define properties in TestManager, click File → Plan Script . For 
more information about planning scripts through TestManager, see the Using 
Rational Robot manual.

As you plan what you want to record, keep in mind that when you play back the 
script it should emulate real users performing everyday tasks—for example:

ã Typically, a script contains a single transaction (such as adding a new orde
database) or multiple transactions that are executed in succession (such a
adding an order to a database and then generating an invoice based on the 

In LoadTest, you insert the script into a user group that is likely to execute
transactions in the script—for example, an Order Entry user group for 
transactions that add new orders to the database.

ã Typically, a virtual user script represents requests to a server by multiple clients. 
In other words, when you run the script on a single computer, hundreds o
virtual users might run the script. You specify the number of virtual users to 
the script when you design the schedule.

ã Often, a script represents a transaction that is repeated multiple times. For
example, a member of an Order Entry department would not enter a singl
order and then quit for the day. Consequently, you might want each virtual 
to run a script multiple times. You set these iterations when you design the
schedule.
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Setting Virtual User Recording Options
Before you record a virtual user script, make sure your virtual user recording options 
are set the way you want them for the recording session. For example, you use 
recording options to set the recording method to use.

You can review and set virtual user recording options in any of these ways:

ã Before you begin recording, click Tools  →  Virtual U ser Record O ptions.

ã When you initiate recording, click O ptions in the Record Virtual U ser dialog 
box.

ã When you end recording, click O ptions in the Stop Recording dialog box. At 
this time, you can only set options that affect script generation (in the tabs 
Generator, Generator Filtering, and Generator per Protocol).

For information about recording options, see Setting Recording Options on page 3-1.

Virtual User Recording Considerations
When you record a virtual user script that accesses a database, you often need to make 
sure that when you run the schedule, the underlying database is in the same state as 
it was when you originally recorded the scripts. There are several ways to accomplish 
this:

ã At the start of a schedule run, have one user in the run initialize (roll back) the 
database before the other users do active work. The examples in the previous 
section use this method.

ã Before each schedule run, you can manually roll back the database to the state it 
was at the beginning of the recording session. 

ã H ave the last script in a session perform the necessary operations to restore the 
database, such as removing inserted records or undoing updates.

As you record the script, it is a good idea to:

ã Split the recording session into multiple scripts. Typically, each script recorded 
during a session contains a logical set of actions performed by one user. For 
example, if you record a query transaction against a Web server and an order 
entry transaction against a database server, you would probably split the session 
into two different scripts—one for each transaction.
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Splitting a session into multiple scripts is also a convenient way to treat sections 
of the recording session differently when you add the session’s scripts to a
schedule. For example, suppose you log into a database server and perform
different transactions. If you split the session so that the login and each 
transaction is a separate script, you can set up the schedule to perform ma
iterations of the transactions but perform the login script just once.

For more information about sessions, including how to split a virtual user 
recording session into multiple scripts, see Splitting a Session into Multiple Scripts 
on page 4-15.

ã Add comments to the script. This is because one user action, such as clicki
a window to add a record to a database, can translate into more than one 
emulation command. Therefore, adding comments to your script while 
recording makes the script easier to understand and easier to map to the u
actions. For more information about adding comments, see Comments on page 
5-11.

ã Insert blocks into the script. Each virtual user script automatically measures
server response time between one emulation command and the next. How
you may want to measure larger units of work, such as an entire transaction
do so, add blocks during recording to bracket these units of interest. For m
information about adding blocks, see Blocks on page 5-4. 

After you record the script, play back the script in a schedule to make sure it ru
correctly. You will not receive any syntax errors because you have not yet mod
the script. However, you may receive playback errors if your client-side environm
is set up differently from the way it was set up during recording or if you did no
restore the database to its initial recording state.

Modifying Virtual User Scripts
Once you have recorded a series of virtual user scripts, you should modify the
they will run more than once. For example, if your recorded script deletes a re
with the key of John Doe, you cannot run that script multiple times. If you run 
script with a workload of 100 users, the first virtual user will succeed, but the nex
virtual users will get an error. 

To avoid this problem, you can use a datapool to supply the data values to your s
Typically, you use a datapool so each virtual user that runs the script can send u
data to the server. Also, a single virtual user that performs the same transaction
multiple times can send unique data to the server in each transaction. If you d
use a datapool, each virtual user sends the same values to the server (which a
values that are in the recorded script).
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In general, you create a datapool immediately after you record the server or user 
actions. You create a datapool with Robot or TestManager.

You may also want to make the following changes to a recorded script:

ã M odifying think tim e distribution – The default think time distribution is 
CONSTANT. If 1000 users run a script, they will delay the exact same think tim
with each command. By setting a think time distribution of NEGEXP, each user 
will select a think time at random from a negative exponential distribution. 
change the think time distribution, you must modify the value of Think_dist 
in each script.

ã Suppressing aberrant think tim es – You might have been interrupted by a ten
minute phone call during the recording process. When you play back the sc
it pauses for ten minutes. You can remove this think time by editing the sc
or by setting a maximum think time in Robot’s Virtual U ser Record Option
For example, if you set a maximum think time of one minute, when the scr
runs, it pauses for one minute, not ten.

ã M odifying start and stop tim es – You might want to modify the placement o
start_time and stop_time commands, if you inserted timers or blocks 
during recording.

ã Inserting synchronization points – Inserting a synchronization point enables
you to coordinate the activities of a number of virtual users by pausing and
resuming activities. A useful technique is to synchronize all users at the 
beginning of the schedule and to stagger release times so that users executi
same script do not all start the script at the same time.

You can insert a synchronization point into a schedule or into a script:

– Into a  schedule. The advantages of inserting a synchronization point in
a schedule are that the synchronization point is visible in the schedule
that the synchronization point is easy to change without editing the scr
For more information, see Inserting a Synchronization Point on page 7-25.

– Into a  script. You can insert a synchronization point into a script in eith
of these ways:

During recording. For more information, see Synchronization Points on page 
5-7.

During script editing, by manually typing the VU  sync_point statement 
into the script. For more information, see the VU Language Reference.
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Correcting Errors in Virtual User Scripts
When you run a schedule, you might encounter the following errors in a script:

ã Syntax errors. These will occur only if you have modified the script. LoadTest 
will not run a schedule unless it can compile all of the scripts successfully. 
Therefore, you must fix the syntax errors first. 

Some of the most common syntax errors involve:

– attempting to use a function without the proper number and type of 
arguments

– attempting to use default scope variables across scripts

ã Runtime errors. These errors might appear while you monitor a schedule,
are often related to the environment or state of the client or server software
example, you might need to fix:

– initialization problems

– abnormal user termination

– abnormal loss of connections

– access to variables no longer in context

– a variable that you are attempting to use but that has not been initialize

The LogViewer’s U ser Log and U ser Error files contain the information 
necessary to fix these runtime errors.

ã Connection failures and initialization timeouts.

Analyzing Performance Results
LoadTest generates a great deal of data about your tests, and at first, the sheer v
of data might be overwhelming. However, if you planned your tests carefully, y
should be reasonably certain what data is important to you.

It is a good idea to first check that your sample is statistically valid. To do this, ru
Performance report and a Response report on your data.

The Performance report includes two columns: Mean and Standard Deviation. I
mean is less than three times the standard deviation, your data might be too disp
to get meaningful results.
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The Response graph shows the response time versus the elapsed time of the run. The 
data should reach a steady-state behavior rather than getting progressively better or 
worse. If the response time trend gets progressively better, you might be including 
login time in your results rather than measuring the results when they have attained 
a stable load. Or the data accessed in your database may be smaller than realistic, 
resulting in all accesses being satisfied in cache.

After you are satisfied that your sample is valid, you can start analyzing the results of 
your tests. When you are analyzing results, it is a good idea to use a multilevel 
approach. For example, if you were driving from one city to another, you would use 
a map of the U nited States to plan an overall route, and a more detailed city map to 
get to your destination. Similarly, when you analyze your results, you should first 
start at a macro level and then move to levels of greater detail.

The following sections outline the different levels of detail that you can use to 
analyze the results of your tests.

Comparing Results of Multiple Runs
The first level of analysis involves evaluating the graphical summaries of results for 
individual schedule runs and then comparing the results across multiple runs. For 
example, you can examine the distribution of response times for individual users or 
transactions during a single schedule run. You can also compare the mean response 
times across multiple runs with different numbers of users. 

This first-level analysis lets you know whether your performance goals are generally 
met. It helps identify trends in the data, and can highlight where performance 
problems occur—for example, performance might degrade significantly at 250 
users.

For this type of analysis, you run the Performance and Compare reports.

Comparing Specific Requests and Responses
The second level of analysis involves examining summary statistical and actual
values for specific user requests and system responses. Summary statistics inc
standard deviations and percentile distributions for response times, which indi
how the system responses vary as seen by individual users. If you are testing a
database, you might want to trace specific SQL requests and corresponding 
responses to analyze what is happening and the potential causes of performan
degradation.
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For second-level analysis, you could do the following:

1 . Identify a stable measurement interval by running the Response report and 
obtaining two timestamps. The first timestamp occurs when the virtual users 
exit from the startup tasks. This is the timestamp of the last user who starts to 
do “real” work: adding records, deleting records, and so on. The second 
timestamp is the first user who logs off the system. You have now identified
“stable” measurement interval.

2 . Create a Performance report using only the interval specified by these two
timestamps.

3 . Graph the Performance report to verify that the distribution has flattened.

4 . Run the Performance, Compare, and U sage reports to examine the summ
statistics for this measurement interval.

Determining the Cause of Performance Problems
The third level of analysis helps you understand the causes and significance of
performance problems.

Analyzing Resu lts Statistically
This detailed analysis takes the low-level data and uses statistical testing to help
correct conclusions. Although this analysis provides objective and quantitative 
criteria, it is more time consuming than first- and second-level analysis and requ
a basic understanding of statistics.

When you analyze your data at this level, you use the concept of statistica l 
significance to help you understand whether differences in response time are re
are due to some random event associated with the test data collection. On a 
fundamental level, randomness is associated with any event. Statistical testing 
determines whether there is a systematic difference that cannot be explained b
random events. If the difference was not caused by random error, the differen
statistically significant.

To perform a third-level analysis, you run the Performance and Response rep
2 -1 7
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Some of the measurements you need to be concerned about when you do third-level 
analysis are:

ã M inim um  – The lowest response time.

ã M axim um  – The highest response time.

ã M ean – The average response time. This average is computed by adding a
the response time values together and then dividing that total by the numb
response time values.

ã M edian – The midpoint of the data. Half of the response time values are le
than this point and half of them are greater than this point.

ã Standard D eviation – How tightly the data is grouped around the mean.

ã Percentiles – The percentages of response times above or below a certain p
The 90th percentile is often measured.

ã O utlier – A value that is much higher or lower than the others in the data.

For example, suppose that System A and System B both have a mean respons
of 12 milliseconds. This does not mean that the system response is the same. S
A might have response times of 11, 12, 13, and 12. System B might have respo
times of 1, 20, 25, and 2. Although the mean time is the same, the minimum, 
maximum, and standard deviation are all quite different. 

To do an even deeper analysis, you can save the report output in .csv format, 
export it into a commercial statistics package.

M onitoring Com puter Resources and Tuning Your System
Performance problems can be caused by limited hardware resources on your s
rather than software design. For example, your disk job service times could be
unacceptably slow due to a concentration of disk transfers all being sent to a si
disk rather than being spread across several disk drives. This problem is typica
fixed by relocating some of the frequently accessed files (such as swap files or 
temporary files) to a disk with less activity.

Performance problems can also be caused by overloaded LAN  segments or ro
which result in substantial network congestion. Even the simplest round-trip d
from client to server and back can take several seconds to process. This proble
typically fixed by splitting an overloaded LAN  segment into two or three segme
with routers in between. Sometimes you may also add a second network card 
server systems so they can be directly accessible to two LAN  segments without g
through a router.

Either of these hardware limitations can result in slow response time measurem
that cannot be fixed by changing the software design.
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LoadTest lets you match CPU , memory, and disk utilization metrics with user 
response time data. You can monitor your computer resource usage during a 
schedule playback and then graph this usage data over the corresponding user 
response times to determine whether imbalance in the hardware resources is causing 
slow response times.

For this type of analysis, you would run the Response report, and right-click on the 
report output to overlay the computer resource metrics one at a time to see if any of 
them are responsible for slow response times. 

For more information about running the Response report, see Mapping Computer 
Resource Usage onto Response T ime on page 9-27.

Planning Functional Tests

In the simplest sense, a functional test determines whether the software functions as 
designed. Typically, the ramifications of what has changed can be classified in one of 
two ways:

ã An unplanned change – for example, a software defect.

ã A planned change – for example, a fix for a software defect or an enhanceme

In either case, if you want to continue with your functional testing, you must m
the newly accepted functionality the new baseline standard, and then compare
new standard against tests of subsequent builds of the application. 

Distributed Functional Testing 
Functional tests that use Robot alone are usually performed on a single compu
With LoadTest, however, you can perform functional tests in distributed mode
meaning that you can have many computers running concurrently. This enable
to: 

ã Expand your functional testing efforts to include additional computers that 
configured differently – for example different operating systems, screen 
resolutions, clock speeds, and so on. 

ã Speed up the process of stand-alone functional testing by distributing the sc
among different computers and playing them back in the same schedule.
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Setting Pass and Fail Criteria for Functional Tests
One of your primary tasks in planning a functional test is to identify the features to 
be tested and how you will determine whether the features pass or fail. If you are 
running a functional test, the pass or fail criteria will be in the form of functional 
defects. For example, you need to determine whether the latest release of the 
application produces:

ã The same output as the baseline

ã The same error detection as the baseline

ã The same error recovery as the baseline

Identifying Functional Testing Requirements
When planning a functional test, you need to determine the hardware and software 
that your test requires. For example:

ã Server computers – the server computers that will be accessed

ã Client computers – the characteristics, such as processor speed, memory, a
disk space, of the client computers, that run the application

ã Databases that will be accessed

ã Applications to be tested

Scheduling Functional Tests
If you are testing performance, you schedule your tests so that the workload m
mirrors the workload at your site. If you are testing functionality, however, you 
schedule your tests so they can run on different computers, or on a specific 
computer. The following sections show how you might do this.

Distributing Tests Among Different Computers
With functional testing, you might want to run your tests immediately on any 
computer that is available. In this case, do two things:

ã When you insert user groups into a schedule, click the Multiple Computer
button and add your computers to the computer list that appears. For mor
information about scheduling scripts to run on different computers, see Inserting 
User Groups into a Schedule on page 7-5.
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ã After you have inserted your user groups, insert a N ext Available selector. The 
scripts that you insert under the selector will be continuously sent out to the 
next available computer. Of course, the scripts must be designed so that they are 
self-contained and do not rely on one another. For more information about the 
N ext Available selector, see Inserting a Selector on page 7-18.

Running Tests on a Specific Computer
If, however, you are testing functionality on a group of computers that have different 
hardware or software, you need to schedule the user groups to run on a particular 
computer. For more information about scheduling scripts to run on a particular 
computer, see Inserting User Groups into a Schedule on page 7-5.

Designing Functional Tests
Once you have decided on the number of users and the mix of tasks, you are ready 
to record the user actions and set up the tests. Some questions you might consider 
are:

ã If one user fails, should the test stop or should it keep running? Generally, if you 
are testing functionality, the test should stop if a user fails.

ã Should the test wait until all the users are connected, or should the test begin 
running immediately? Generally, if you are testing several configurations of a 
system, and the same script is running independently on each configuration, the 
test can begin running immediately.

ã What type of data will be needed to test each function? Datapools are extremely 
useful here. They enable you to exhaust every combination and iteration of a 
field. You can populate a datapool with valid and invalid data. Although you will 
probably create the datapool later, you need to plan the type of data it will 
contain at the same time you plan the tests.

You also need to set up a test database, since you will most likely not want to run your 
tests on the production database. 

To enable a test to be reused, you must record modular scripts so that they can start 
and stop at common, convenient points for even processing. For example, a set of 
modular scripts for a banking application might include querying an account, 
updating one of the attributes of the account, and returning to the menu where this 
function was first invoked. Most functional tests are based on many modular 
recordings that are placed into script shells in Robot.

Overview of a Distributed Functional Test 
Assume that you want to test your Accounting software. You want to distribute your 
tests so that they can run as quickly as possible.
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The following table summarizes how you set up this test:

The previous table shows one way to perform a distributed functional test. There are 
many other ways to use LoadTest to build and run effective distributed functional 
tests. The most important thing to keep in mind is that all of the scripts should be 
modular in nature. 

GUI Recording Considerations
Before you record a GU I script that accesses a database, you often need to make sure 
that when you run the schedule, the underlying database is in the same state as it was 
when you originally recorded the scripts. There are several ways to accomplish this:

ã At the start of a schedule run, have one user in the run initialize (roll back) the 
database before the other users do active work. The examples in the previous 
section use this method.

ã Before each schedule run, you can manually roll back the database to the state it 
was at the beginning of the recording session. 

ã H ave the last script in a session perform the necessary operations to restore the 
database, such as removing inserted records or undoing updates.

Scripts Schedule Reports

A script to log users in. 

A modular script for each 
user task.

A script to perform any 
cleanup work and then 
shut down the 
application.

A fixed user group, with one 
user assigned to each 
computer in the test, that 
logs the users in.

A fixed user group, with one 
user assigned to each 
computer in the test, that 
contains a N ext Available 
selector and modular scripts 
that run on any computer.

A fixed user group, with one 
user assigned to each 
computer in the test, that 
shuts down the application.

LogViewer report to 
show whether all users in 
the schedule successfully 
ran to completion.
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As you record the user actions, it is a good idea to annotate the script. Annotating 
your script while recording makes the script easier to understand and to map to the 
user actions.

After you record the user actions or server traffic, play back the script in Robot. You 
want to make sure that it runs correctly before you modify it. You will not receive 
any syntax errors because you have not modified the script. 

Modifying GUI Scripts
Once you have recorded a series of scripts, you should modify them so that they will 
run more than once. For example, if your recorded script deletes a record with the 
key of John Doe, you cannot run that script multiple times. If you run the script with 
a workload of 100 users, the first GU I user will succeed, but the next 99 GU I users 
will get an error. 

To avoid this problem, you can use a datapool to supply the data values to your script. 
Typically, you use a datapool so that each GU I user that runs the script can send 
realistic data to the server. Also, a single GU I user that performs the same transaction 
multiple times can send realistic data to the server in each transaction. If you do not 
use a datapool, each GU I user sends the same values to the server (the values that are 
in the recorded script).

Another use of datapools is for testing the values of each field. So, for example, if you 
are testing a numeric field, you can populate your datapool with the minimum and 
maximum values accepted, one less than the minimum and one more than the 
maximum values, a null value, and so on.

In general, you create a datapool immediately after you record the server or user 
actions. You create a datapool with Robot or TestManager.

You will probably want to add a loop to your script to repeatedly test the values of a 
field.

Correcting Errors in GUI Scripts
When you run the schedule, you might encounter the following errors in a script:

ã Syntax errors. For example, you might need to fix errors like the following: 

– An object did not exist during recording, but it occurs in playback.

– An object’s coordinates have changed between the time you recorded i
the time you run the schedule. For example, the coordinates of a drop
down combo box may have moved out of range.

To fix these problems, comment out the incorrect portion of the script, re-
record that portion of the script, and insert the corrected code into the scri
2 -2 3
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ã Runtime errors. These errors might appear while you monitor a schedule, and 
are often related to your environment. For example, you might need to fix:

– Script command failures. 

– U nexpected active windows. For example, assume you recorded a scr
that creates a new file in N otebook, and then closes that file. When you 
back that recording, the file already exists. When the script tries to close
file, it gets a message asking if it wants to overwrite the previous file. Th
message is an unexpected active window, because it did not appear du
recording.

Analyzing Functional Results
The LogViewer shows whether an individual script passed or failed. By default,
LoadTest displays the LogViewer if a script fails during a schedule run. If anyth
in the script failed, the LogViewer displays the script name in red. You can click
the script name to examine the cause of the failure. Scripts that pass are green
scripts that you terminate are yellow.

For more information about the LogViewer, see the Using Rational Robot manual.
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Setting Recording Options
This chapter describes how to set recording options, manage proxies, and provide 
login information through the Authentication Datapool. It includes the following 
topics:

ã About virtual user recording 

ã Setting the recording method

ã Setting script generation options 

ã Setting general recording options

ã Defining a client or server computer

ã Removing a computer or port

ã Authenticating login

ã Managing proxies

About Virtual User Recording

The following steps outline the general process for recording a virtual user script:

1 . Set the virtual user recording options.

Recording options tell Robot how to record and generate scripts. You set 
recording options to specify:

– The type of virtual user recording you want to perform, such as API, 
network, or proxy. The recording method you choose determines som
the other recording options you need to set.
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– Script generation options, such as specifying whether you want the scri
include datapool commands or think time delays, and whether you wan
filter out protocols to control the size of the script.

– General recording options, such as the prefixes to assign to default scr
and session names.

2 . Start the recording session.

If you use the API recording method, you must start recording first, at whic
point Robot prompts you for the name of the client. With the other recordi
methods, network and proxy, you can start recording before or after you star
client.

3 . Start the client application.

4 . Record the transactions. While you are recording the transactions, you can
the session into multiple scripts, each representing a logical unit of work.

For information about splitting a session, see Splitting a Session into Multiple Scripts 
on page 4-15.

5 . Optionally, insert timers, blocks, comments, and other features into the sc
during recording. 

For information about inserting these features into virtual user scripts, see
Chapter 5, Adding Features to Virtual User Scripts.

6 . Close the client application.

7 . Stop recording

8 . Robot automatically generates scripts.

Setting the Recording Method

A recording m ethod is the type of virtual user recording that you want to perform
Your choices are:

ã API recording 

ã N etwork recording (the default)

ã Proxy recording 
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In general, we recommend that you select network recording. H owever, the 
following table lists certain situations in which a recording method is required 
or recommended:

Situation API Network Proxy

The client application accesses secure 
data from a Web server.

Required

The client application accesses an Oracle 
8 database.

Required

The client application accesses an Oracle 
7 database. (For network and proxy 
recording, you need to supply the name 
of the O racle database. For more 
information, see Providing the N ame of an 
Oracle Database on page 3-23.)

Recommended First alternate Second alternate

The client application is not installed on 
the Master.

Recommended Alternate

The client application is not running on 
Windows N T 4, SP 3 or 4.

Recommended Alternate

You want to record traffic from multiple 
client applications that reside on different 
computers.

Recommended Alternate

You want to record traffic between 
multiple, specific client and server 
computers.

Recommended

N either the client nor the server 
computer is on the same network 
segment as the Master.

Required

An Ethernet switch controls network 
traffic, and neither the client nor the 
server application are installed on the 
same computer as the Master.

Required

The client application accesses a 
TU XEDO server.

Alternate Recommended
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API Recording 
With API recording, Robot records API calls between the specific client application 
and the server. Recording occurs on the client rather than on the wire, as with 
network and proxy recording. Therefore, choose API recording if you are accessing 
secure data from a Web server, because API recording captures the information 
before it reaches the wire and is encrypted.

API recording is supported only on Windows N T clients. With API recording, you 
do not have to specify the network names or IP addresses of the client and server 
as you do with network and proxy recording.

How to Choose API Recording
To use the API recording method:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab, and click API recording.

Network Recording 
With network recording, Robot records packet-level traffic at the OSI network 
interface layer using the “promiscuous” mode of your network card. N etwork 
recording is media-independent, supporting standards such as Ethernet, Toke
Ring, and Fiber Distributed Data Interface (FDDI). 

N etwork recording occurs on the wire rather than on the client (as with API 
recording).

How to Choose Network Recording
To use the network recording method:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab, and click N etwork recording.

3 . Optionally, click the M ethod:N etwork tab, and select the client/server pair tha
you will record. The default is to record all of the network traffic to and from
your computer. (For information, see Selecting a Client/Server Pair below.)

4 . Optionally, click the Generator Filtering tab to specify the network protocols 
to include in the script that Robot generates. (For information, see Setting 
Filtering Options on page 3-16.)
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Selecting a Client/Server Pair
The M ethod:N etwork tab contains the following lists of computer addresses. Select 
one item in each list: 

Client – The client’s network name (or IP address) and, optionally, the port num

Server – The server’s network name (or IP address) and, optionally, the port 
number.

If a computer that you want to specify is not listed, define the computer as descr
in Defining a Client or Server Computer on page 3-27.

You can choose Any or Local m achine instead of a specific computer name:

ã If you select Any for either the client or the server, Robot records traffic for a
clients or all servers on the network.

ã If you select Local machine for the client (the default), Robot records traffic 
from the Master computer. Robot determines the computer’s network nam
automatically. You do not have to specify it. 

Local machine records traffic from all of the computer’s ports. To record traff
from a particular port, click Computer Admin to define the computer network
name and port number of interest.

Selecting a Network Card
If you are using network recording and the Master computer has more than on
network interface card installed, you must identify the card to use, as follows:

1 . Click Start → Settings → Control Panel.

2 . Double-click the N etwork icon.

3 . Click the Bindings tab.

4 . Select all services in the Show Bindings for box.

5 . In the list of services, expand the PerformanceStudio N etwork D river item by 
clicking the +  icon before it.

6 . Click the network interface card that you want to use.

7 . Click M ove U p until the selected card is at the top of the list.

8 . Click O K.

9 . Reboot the computer.

Alternatively, instead of moving the name of the interface card that you want to
to the top of the list, you can click D isable to disable all of the other interface card
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Proxy Recording 
With proxy recording, the client/server traffic is routed through a proxy computer.

Proxy recording occurs at the OSI application layer and involves receiving and 
sending socket transactions. With proxy recording, you can record conversations 
between multiple, specific clients and servers (that is, when the Any choice in the 
M ethod:N etwork tab for either clients or servers would be impractical). 

The following examples show when you might need multiple clients and servers:

ã You need multiple client computers if different user groups (such as order entry 
clerks and customer service representatives) will issue requests to the server in 
at the same time during a single recording session.

ã You need multiple servers if requests are being sent to different databases (such 
as an Inventory database and a H uman Resources database) located on different 
computers.

The proxy com puter intercepts requests from clients and relays them to the server. 
N one of the client computers issuing requests to the servers need to have the Robot 
software installed. Robot is required only on the proxy computer. 

N ote that this document uses the word “proxy” to refer to the computer that 
performs proxy recording. It does not refer to a Web proxy server.

The following figure illustrates a proxy recording setup with multiple client 
computers and one server. Each computer’s network name indicates its role in
client/server traffic. N etwork names are followed by the computer’s port numb

Client computers

Client2:3020

Client3:3030

Proxy:3040

Rational Robot

Proxy computer Server computer

Clients map 
to proxy

Proxy maps 
to server

Server1:3070

Client1:3010

Proxy:3050

Proxy:3060

Other mappings on proxy
(client/server pairs)

Client1:3010 ^ Server1:3070
Client2:3020 ^ Server1:3070
Client3:3030 ^ Server1:3070
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How to Choose Proxy Recording
To use the proxy recording method:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the M ethod tab, and click Proxy recording.

3 . Click the M ethod:Proxy tab to:

– Create a proxy computer.

– Identify client/server pairs that will communicate through the proxy. 

After you set up your system for proxy recording, you should record a trial scrip
make sure the proxy recording yields the results you expect.

Proxy Recording Overview
To set up and use proxy recording:

1 . Start Robot on the proxy computer.

2 . In the Virtual U ser Proxy Administration dialog box, match up the proxy 
computer and port with each server to be used in the test. 

For details, see Creating a Proxy Computer on page 3-8.

3 . In the M ethod:Proxy tab of the Virtual U ser Record Options dialog box, matc
up each client with the server it will send requests to. Be sure to specify th
actual server and not the proxy computer.

For details, see Identifying Client/Server Pairs on page 3-8.

4 . Configure each client to send requests to the proxy computer, not to the se
For example, if the client will be sending requests to an Oracle database, us
Oracle client configuration software to specify the proxy computer’s address
port number, not the server’s.

5 . On each client computer, a tester should start the client application and nav
to the point where recording will begin.

6 . On the proxy computer, enable recording (File → Record Virtual U ser). 

N O TE: The proxy can run on one of the client computers. To have one 
computer serve as both the proxy and a client, assign different port numbers to
the proxy and client.

N O TE: If you are proxy recording against an Oracle database, the server shou
not be set up to redirect. Consult your Oracle documentation for information.
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7 . With recording enabled, each tester at each client computer performs the 
transactions to record.

8 . When all transactions are complete, stop recording on the proxy computer.

Creating a Proxy Computer
You create a proxy computer by mapping the proxy computer’s address to the 
address of one or more servers.

Before you create a proxy computer, be sure that:

ã The server’s network name (or IP address) and port number are defined. If
are not defined, click Com puter Adm in to display the Virtual U ser Computer 
Administration dialog box. For information about how to define the server’s
network name and port number in this dialog box, see Defining a Client or Server 
Computer on page 3-27.

ã Proxy service is running. For more information, see Starting and Stopping Proxy 
Service on page 3-32.

To create a proxy computer:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab and make sure that Proxy recording is selected.

3 . Click the M ethod:Proxy tab.

4 . Click Proxy Admin.

5 . In Proxy:Port, specify the proxy computer’s port number. N ote that Robot h
already detected and specified the proxy computer’s name.

You can specify any available port number. Avoid the “well-known” ports (tho
below 1024). If you specify a port number that is unavailable, Robot promp
you for a new port number.

6 . In the Server:Port list, select a server involved in the test.

7 . Click Create Proxy.

The proxy computer is added to the Existing Proxies list.

Identifying Client/Server Pairs
Clients and servers communicate through the proxy. A client and server that 
communicates through a proxy is called a client/server pair.
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Before you identify a client/server pair, be sure that the network names or IP 
addresses of all the clients and servers in the test appear in the M ethod:Proxy tab. 
If any are not listed, click Computer Admin to define them. For information about 
how to define a client or server computer, see Defining a Client or Server Computer on 
page 3-27.

To associate each client in the test with the server it will communicate with:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab and make sure that Proxy recording is selected.

3 . Click the M ethod:Proxy tab.

4 . Select a client in the Client [:Port] list.

The client port is optional.

5 . Select the client’s server in the Server:Port list.

The server port is required.

6 . Click Add. 

The client/server pair that you have identified appears in the Client/Server pairs for 
recording list.

Setting Script Generation Options

Although you should set script generation options before you record a session
can also change these options after you record a session. After recording, you 
change a script generation option and regenerate the script with the new optio
without recording the session again. The script generation options enable you

ã Modify the contents of the script—for example, by specifying whether the 
script will include datapool commands or think time delays

ã Set filtering options to control the size of the script—for example, by select
certain protocols to be included, and excluding the other protocols.

ã Modify a script that contains Oracle or TU XEDO requests—for example, t
give emulation commands pertaining to TU XEDO a command ID prefix th
reflects the specific emulation command.

For information about regenerating scripts, see Regenerating the Scripts Recorded in a 
Session on page 4-17.
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Modifying the Contents of a Script
To modify the contents of a script:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the Generator tab.

This tab lets you specify whether the script will:

ã U se datapools.

ã Contain prefixes for command IDs.

ã Contain the data retrieved from the server (as comments).

ã Contain the number of rows or bytes affected by SQ L statements or Web 
requests.

ã Contain the return codes for SQL statements.

ã Bind output parameters to VU  variables

ã Include think time delays.

ã Include both think time and CPU  delays.

ã H ave a maximum think time delay.

The following sections describe these options.

Use Datapools
Select this check box if you want Robot to generate datapool commands in the script. 
Datapool commands allow the script to access data in a datapool.

A datapool allows each virtual user running a script to send realistic data to the 
server. If you do not use a datapool, each virtual user sends the same data to the server 
(the data that you sent to the server when you recorded the script).

For more information about datapools, see Chapter 6, Working with Datapools.

Command ID Prefix
This option specifies an optional prefix for VU  emulation command IDs. 

Emulation commands include commands for emulating database clients as well as 
commands for performing communication and timing functions. An emulation 
com m and ID  appears in brackets after the command name. It uniquely identifies the 
emulation command in LoadTest reports.
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Emulation command IDs consist of a prefix and a three-digit numeric suffix. 
For example, if you specify task as the command ID prefix, you might see the 
following emulation command name and ID:

sqlnrecv ["task001"] 1355;

Robot automatically increments the numeric suffix by a value of 1 with each 
emulation command.

The maximum length of the command ID prefix is seven characters. If you do not 
specify a prefix, Robot uses the script name as the prefix (up to seven characters).

You cannot use this option to define multiple command ID prefixes in a recording 
session. If you want your script to contain multiple command ID prefixes, use blocks 
to define these prefixes.

With TU XEDO commands, any prefix that you define in Com mand ID  prefix is 
ignored if you specify a predefined TU XEDO emulation command ID prefix. For 
more information, see Assigning a Prefix to TUXEDO Command IDs on page 3-23.

Truncating a Com m and ID  Prefix
Robot uses a tilde (~ ) to indicate that a command ID prefix that exceeds seven 
characters has been truncated. 

The command ID prefix format is slightly different for truncated prefixes that appear 
in single-script sessions and multi-script sessions. For example, if you define a 
command ID prefix of EmulCmdID, Robot truncates the prefix as follows:

ã Truncation format for single-script sessions:

sqlexec ["EmulCmd~024"] "select * from table";
sqlnrecv ["EmulCmd~025"] ALL-ROWS;

ã Truncation format for multi-script sessions:

sqlexec ["EmulCmd~3.024"] "select * from table";
sqlnrecv ["EmulCmd~3.025"] ALL-ROWS;

The 3 after the tilde shows that the command is in the third script in the session.

Display Recorded Rows
This option specifies whether you want some or all of the data retrieved from the 
server to be inserted into the script. 

The inserted data is for informational purposes only. Data is inserted in the form of 
comments and does not affect script playback. 
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Select one of the following values from the D isplay recorded rows list:

Verify playback row counts 
This option specifies whether the number of rows that were affected by an executed 
SQL statement, or the number of bytes that were affected by a request to a Web 
server, are inserted into the script.

This information helps you determine whether a SQL statement or Web request 
executed during script playback behaves as it did during recording. If the SQL 
statement or request returns a different number of rows or bytes during playback, 
LoadTest notes the discrepancy when you run an Analog report.

Value Meaning

All Insert all retrieved data into the script.

First Insert a specified number of bytes (HTTP and socket protocols) or 
rows (other protocols) from the beginning of the data retrieved from 
the server.

If you select First, enter the number of bytes or rows to retrieve in 
the box that appears to the right of the D isplay recorded rows list:

Last Insert a specified number of rows from the end of the set of records 
retrieved from the server.

You cannot use Last with HTTP or socket protocols.

If you select Last, enter the number of rows to retrieve in the box 
that appears to the right of the D isplay recorded rows list:

N one Do not insert any retrieved data into the script.

N O TE: D isplay recorded rows is supported only for Sybase, Microsoft SQL 
Server, H TTP, and socket protocols.
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Verify playback row counts has the following meanings:

For an example of the effect that this check box has on a generated script, see Example 
of the Verify Playback Check Boxes on page 3-13.

Verify Playback Return Codes 
This option specifies whether you want the return code for an executed SQL 
statement to be inserted into the script.

During playback, LoadTest checks whether the return code for a SQL statement 
executed during script playback matches the return code for the same statement 
executed during recording. If the SQL statement returns a different code during 
playback, LoadTest notes the discrepancy in the LoadTest playback report.

The Verify playback return codes check box has the following meanings:

A single SQL statement can return multiple error codes.

Exam ple of the Verify Playback Check Boxes
Suppose you want the script to execute the following SQL statement:

INSERT INTO mytable VALUES ("value1", "value2")

State of check box Meaning

The check box is selected. Insert into the script the number of rows or bytes 
affected by a SQ L statement or Web request.

The check box is cleared. Do not insert the number of affected rows or bytes into 
the script.

State of check box Meaning

The check box is selected. Report SQ L return codes for each SQL statement 
executed in the script.

The check box is cleared. Do not insert any SQL return codes into the script.
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Depending on your Verify playback row counts and Verify playback return codes 
selections, Robot generates the SQ L statement in one of the following ways:

Because one SQL statement can return multiple error messages (for example, as a 
result of stored procedure execution), EXPECT_ERROR is an array. During 
playback, if an error code is returned that is not one of the values specified in the 
array, LoadTest generates an error.

Check box selected VU command and meaning

N either sqlexec ["x001"] "INSERT INTO mytable VALUES (’value1’, 
’value2’)";

During recording, Robot does not report the data it collects from the 
execution of the SQ L statement. During playback, LoadTest assumes 
that any non-zero return code is an error. It pays no attention to the 
number of affected rows.

Verify playback 
return codes

sqlexec ["x001"] EXPECT_ERROR {-212}, "INSERT INTO 

mytable VALUES (’value1’, ’value2’)";

Robot records that the error code -212 was returned from the SQL 
statement. During playback, LoadTest expects the SQL statement to 
return the error code -212. When you run an Analog report on the log, 
the report output shows any variance in the error codes. 

Verify playback 
row counts

sqlexec ["x001"] EXPECT_ROWS 1, "INSERT INTO mytable 

VALUES (’value1’, ’value2’)";

Robot records that one row was affected by the SQL statement. During 
playback, LoadTest expects the SQL statement to affect one row. When 
you run an Analog report on the log, the report output shows any 
variance in the number of rows affected.

Both sqlexec ["x001"] EXPECT_ERROR{-212}, EXPECT_ROWS 0, 

"INSERT INTO mytable VALUES (’value1’, ’value2’);

Robot records that the SQL statement returned the error code -212, and 
that no rows were affected. During playback, LoadTest expects that the 
SQL statement will return error -212 and that no rows will be affected. 
When you run an Analog report on the log, the report output shows any 
variance in the error codes and the number of rows affected.
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Bind Output Parameters to VU Variables
Select this check box to automatically script the VU  expressions needed to contain 
the return values of output parameters. This applies only to emulation commands 
that support output parameter binding (currently the IIOP_invoke command). 
Clearing this box will shorten scripts, but you will have to manually script output 
parameter binding expressions and binding variable declarations for any output 
parameters of interest.

Playback Pacing
Controls the script’s playback speed by including or excluding think time delays
the script. A think time delay includes both the time required for the user to thin
about and key in a request and the time required for the client to receive a resp
to the request.

Choose one of the following Playback Pacing settings:

Pacing setting Meaning

per command Plays back the script at a rate based on the actual time required to 
record and process each VU  emulation command. For example, if 
the think time delay for a particular emulation command is 16,703 
ms during recording, Robot adds the following line before that 
emulation command:

push Think_avg 16703;

This setting provides a realistic rate of playback on a per-command 
basis, reproducing delays in the same script locations as they 
occurred during recording. H owever, this setting adds more 
commands to the script than the per script setting does.

per script Plays back the script at a rate based on the average time it took to 
record and process all emulation commands. All emulation 
commands use the same (average) think time delay.

This setting and the per command setting both run a script in 
roughly the same amount of time. While playback timing is not as 
accurate on a per-command basis with the per script setting, it 
requires fewer commands to be inserted into the script. As a result, 
you can modify the script’s average think time by editing one 
Think_avg environment variable.

none Plays back the script on a per script basis, using the most recently-set 
value for Think_avg (the value at the top of the Think_avg 
stack). If there is no value set, the default Think_avg value of 5000 
ms (5 seconds) is used.

N o think time commands are added to the script with this setting.
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Pacing settings of per com m and and per script  use a combination of think time and 
response time environment variables. For more information, see the VU Language 
Reference.

CPU/User Threshold (ms)
Specifies the dividing point, in milliseconds (ms), between CPU  processing delays 
and delays due to user think time. In LoadTest reports, delays that fall below the 
threshold you specify are considered CPU  processing delays.

For example, an actual user might pause to think before selecting a student name 
from a SQL database. This delay is recorded as user think time. O nce the user clicks 
on the student name, the time spent generating the SQL command and accessing the 
database is a CPU  delay. 

Typical thresholds range from 0 through 10,000 ms (10 seconds). Valid thresholds 
range from 0 through 2,000,000,000 ms (just over 23 days). 

If you clear the CPU /U ser Threshold (ms) check box, all delays are considered think 
time delays. 

Think maximum (ms)
Specifies the maximum think time delay to allow in a script. If you specify a 
maximum think time delay, no think time delay in the script will exceed it.

You can type a maximum think time or select one from the list. The valid range is 
0 through 2,000,000,000 ms (just over 23 days). 

If you clear the Think maximum (ms) check box, there is no limit to the length of a 
think time delay.

Setting Filtering Options
When your record a session, the session might include requests associated with a 
variety of protocols—for example, Oracle, Microsoft SQL Server, and HTTP. 
After recording, you can generate scripts that include requests for all of the reco
protocols or just some of them.

N O TE: If you set Playback Pacing to none, the CPU /U ser threshold (ms) and 
Think m axim um  (m s) options are disabled. 
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Typically, you filter protocols only with network and proxy recording, because you 
record all traffic to or from an IP address. API recording targets a client application 
on a specific computer, so you probably do not need to filter protocols if you are 
using this method. H owever, you can filter protocols with API recording if you 
notice that Robot is capturing raw socket information as well as other protocols (such 
as non-H TTP requests from a Web browser). 

To see a list of the protocols that Robot records, select the M anual Filtering check 
box, record a script, and then view the list in the Virtual U ser Manual Filtering dialog 
box at the end of the recording session. For more information, see Choosing the 
Protocols to Include in a Script on page 4-11.

How to Filter Protocols
To filter protocols from a recorded script:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the Generator Filtering tab.

Automatic and Manual Filtering
At script generation time, at the end of the recording session, Robot can 
automatically filter the protocols to generate (based on the protocols listed in the 
Selected protocols box in this tab), or you can specify the protocols that Robot 
should generate, depending on how you set the following check boxes: 

Check box Meaning

Auto Filtering If selected, Robot generates scripts containing requests for the 
protocols listed in Selected protocols.

If cleared, Robot generates scripts containing requests for all 
scriptable protocols it records.

M anual Filtering If selected, Robot displays a list of connections, each consisting of a 
client, a server, and the protocol used in the client/server traffic. 
This list appears immediately after recording, just before Robot 
generates the script. 

When the list appears, select one or more connections to include in 
the script.

If cleared, Robot does not display a list of connections.

N O TE: If you select M anual Filtering, Robot attempts to detect the computer 
name of each client and server it records before it generates the script. This can 
increase script generation time.
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If you select both Auto Filtering and M anual Filtering, the list of connections 
includes all captured protocols:

ã Protocols that you listed in the Selected protocols box are marked for inclusion 
in the script. 

ã Protocols that you listed in the Available protocols box are marked for 
exclusion from the script. 

You can change these inclusion/exclusion designations in the Virtual U ser Manual 
Filtering dialog box, so that requests for any captured protocol can be included in or 
excluded from the script. For information about using this dialog box, see Choosing 
the Protocols to Include in a Script on page 4-11.

Protocol Lists
When the Auto Filtering check box is selected, the following lists are enabled:

Available protocols – Protocols that are available for capture, but that you want
exclude from the script that Robot generates.

Selected protocols – Protocols to include in the script that Robot generates.

Jolt, Socket, and TUXEDO Protocols
If you click the Advanced button, the Virtual U ser Advanced Protocol Filtering 
dialog box appears. This dialog box lets you define more detailed information ab
the Jolt, socket, and TU XEDO protocols specified in the Selected protocols list:

ã Jolt protocol. By default, LoadTest plays back all Jolt sessions recorded, 
regardless of which Jolt servers on the network they may have connected to
limit playback to Jolt sessions connected to a specific Jolt server, specify va
for both of the following filters:

– JSL H ost – Filter out all sessions not connected to a Jolt Server Listene
this host address.

– JSL Port – Filter out all sessions not connected to a Jolt Server Listener
this TCP port number.

To play back specific Jolt sessions, specify values for either or both of the 
following filters:

– U serN am e – Filter out all sessions that do not have this value as the 
userN ame parameter of the client’s JoltSession object constructor 
invocation.

– U serRole – Filter out all sessions that do not have this value as the userR
parameter of the client’s JoltSession object constructor invocation.
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ã Socket protocols. All Robot recording captures socket protocols. Socket 
protocols are at a level below the other protocols that Robot captures. The 
following check boxes define the socket protocols you can include in a script:

– W ell-known protocols (FTP, Telnet, ...)  – Select this check box to include
common socket protocols in the generated scripts. These protocols typi
use port numbers 1 through 1,023 (for example, FTP uses port 21).

– U nrecognized protocols – Select this check box to include other socket
protocols in the generated scripts. For example, select this box to capt
requests from a Java applet that communicates with a server via socke

ã TU X ED O  protocol. LoadTest can play back the traffic from one TU XEDO 
connection at a time. If you record traffic from multiple TU XEDO 
connections, you can specify which conversation to generate in the followin
W orkStation Listener (WSL) boxes:

– W SL H ost – The name of the workstation listener host.

– W SL Port – The TCP/IP port number for the host.

If you provide workstation listener information, you must supply values for 
both boxes.

In addition, you can specify the conversation to generate by supplying value
the following user-defined fields of the TPIN IT request message. These fie
are set by the client in the TPIN IT typed buffer that is passed as an argume
the TU XEDO API function tpinit(). You can define either or both of the 
following fields. If you define both, the request message must contain both f
values (that is, a logical AN D operation):

– U srnam e – The client name.

– Cltname – The user name.

When specifying a TU XEDO connection, you can use either the WSL or 
TPIN IT method, or you can use both methods.

N O TE: The TPIN IT method is an advanced method for specifying a 
TU XEDO connection. Typically, it is used only if the WSL method does not
produce satisfactory results.
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Providing HTTP, Oracle, TUXEDO, and IIOP Information
If you are recording H TTP, O racle, TU XEDO , or IIOP requests, you need to 
supply Robot with certain information.

Controlling the Values Accepted When an HTTP Script Is 
Played Back
You can set recording options that control which status values are acceptable when a 
virtual user script that accesses a Web server is played back. If you do not set any 
recording options, the script plays back successfully only if the playback conditions 
exactly match the conditions during recording. H owever, you can set recording 
options so that a script plays back successfully even if:

ã The server responds with partial or full page data during record or playback.

ã The response was cached during record or playback.

ã The script was redirected to another http server during playback.

ã You are recording a number of HTTP scripts and plan to play them back in a 
different order.

To expand the conditions under which a script will play back successfully:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the Generator per protocol tab.

3 . At the H TTP section, select one or more of the following:

a. Allow partial responses

Select this option to enable a script to play back successfully if the H TTP 
server responds with partial data during playback. This generates a script 
that sets the VU  environment variable H ttp_control to 
HTTP_PARTIAL_OK. Leaving this box cleared enforces strict 
interpretation of recorded responses during playback.

b. Allow cache responses

Select this option to enable a script to play back successfully if a response is 
cached differently during playback. This generates a script that sets the VU  
environment variable H ttp_control to HTTP_CACHE_OK. Leaving this box 
cleared enforces strict interpretation of recorded cache responses during 
playback.
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c. Allow redirects

Select this option to enable a script to play back successfully the script was 
directed to another H TTP server during playback or recording. This 
generates a script that sets the VU  environment variable H ttp_control to 
HTTP_REDIRECT_OK. Leaving this box cleared enforces strict 
interpretation of recorded redirects during playback.

d. U se H TTP keep-a lives for connections in a  session with multiple 
scripts. You should generally leave this check box cleared. 

Selecting this option provides more accurate representation of keep-alive 
behavior, but at a cost—if you loop scripts or play them back in a differe
order, you will have to manually edit your scripts to achieve successful 
playback.

Therefore, you should select this option only if:

– You will not loop scripts or play them back in a different order (or, if you
do, you do not mind editing the scripts).

– You want to preserve the browser’s connection keep-alive behavior tha
in the recorded session. 

The default behavior for multiple script recordings is to not use keep-ali
so that you don’t have to be aware of persistent http connections that s
script boundaries when you loop or change script ordering. However, 
default behavior may result in increased HTTP server overhead due to
absence of keep-alives. 

Supplying Variable Data Values to an HTTP Script
Dynamic data correlation is a technique to supply variable data values to a scrip
when the transactions in a script depend on values supplied from the server.

When you record an http script, the Web server may send back a unique string
session ID, to your browser. The next time your browser makes a request, it m
send back the same session ID to authenticate itself with the server.

The session ID can be stored in three places:

ã In the Cookie field of the HTTP header.

ã In an arbitrarily named field of the HTTP header.

ã In an arbitrary hidden field in an actual HTML page.

LoadTest finds the session IDs (and other correlated variables) and, when you
the schedule, automatically generates the proper script commands to extract t
actual values.
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Before you record a script, you can tell LoadTest to correlate all possible values (the 
default), not to correlate any values, or to correlate only a specific list of variables that 
you provide.

To specify the level of data correlation:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the Generator per protocol tab.

3 . At Correlate variables in response, select one of the following:

a. All – All variables are correlated. You should generally select this option
Select another option only if you encounter problems when you play b
the script.

b. Specific – Only the variables that you select are correlated.

c. N one – N o variables are correlated.

If you have selected All or Specific, your generated VU  script will contain the 
function http_find_values. This function finds the value of items that the 
server returns and the user does not change. It then correlates these values and
them in a system-defined variable in the form SgenRes_00n.

Examine the script to determine whether the proper values are being correlate
you want fewer values to be correlated, change the Correlate variables in response 
option to Specific, and then use the Add and Remove buttons to select only the 
names that you want correlated.

For example, assume you enter data in a form during recording, and the form 
field that you cannot modify—for example, UNITED STATES. In the generated 
script, the http_response emulation command will show the form as follows:

"<form name = \…
…
"\t<input type=\"hidden\" name=\"Country\" value=\"UNITED STATES\">\r\n

LoadTest can determine that this is an item for correlation, and adds an 
http_find_values function to your script. This function puts the UNITED 
STATES value in a variable. Your script will also contain a line that looks like this

{
string SgenRes_002[];
SgenRes_002 = http_find_values("Country", HTTP_FORM_DATA, 1);
#if 0
<UNITED STATES>
#endif
}

If you do not want UNITED STATES to be correlated, choose Specific but do not 
select the Country name from the list. You do not have to re-record the script; you 
can simply regenerate it from the session.
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Providing the Name of an Oracle Database
If you are using the network or proxy methods to record Oracle requests, you must 
provide the name that the client application uses to connect to the Oracle database. 
This name is in Oracle’s tnsnames.ora file. You can later play back the script ag
another Oracle database by changing this name.

To provide this name:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the Generator per protocol tab.

3 . Enter the name that the client application uses in the D atabase nam e box.

Assigning a Prefix to TUXEDO Command IDs
If you are recording TU XEDO requests, you can have Robot automatically assig
identifying prefix to TU XEDO emulation command IDs. The prefix allows 
LoadTest reports to be filtered by emulation command type. The prefix that you
here overrides the Command ID  prefix in the  Generator tab. 

For example, if you select the U se com m and type to prefix emulation com m ands 
check box, the third tux_tpcall emulation command in the script has the 
following command ID:

tux_tpcall ["tcal003"]

Robot assigns the following command ID prefixes for particular TU XEDO 
commands:

Command Prefix Command Prefix

tux_bq tbq tux_tpinit tini

tux_tpabort tabo tux_tpnotify tnot

tux_tpacall* tacaR tux_tppost tpos

tux_tpbroadcast tbro tux_tprecv trec

tux_tpcall tcal tux_tpresume tres

tux_tpcommit tcom tux_tpsend tsen

tux_tpconnect tcon tux_tpsubscribe tsub

* tacaR applies when tux_tpacall involves a request only. When tux_tpacall involves 
both a request and the reply (request/reply turnaround), the prefix is tacaT. This is used for 
asynchronous request timing only and is never assigned to an emulation command.
3 -2 3



Setting  Record ing O ptions

IDs 

n. 
Supplying IIOP information
If you are recording IIOP requests, you can have Robot automatically assign an 
identifying prefix to IIOP emulation command IDs. You can also include the 
original IORs in iiop_bind commands.

To assign an identifying prefix or to include the original IORS in iiop_bind 
commands:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the Generator per protocol tab.

3 . At the IIO P section select one or more of the following:

– U se operation nam e to prefix em ulation com m and ID s

Select this check box to have Robot automatically prefix the command 
with the operation being invoked. This applies to the iiop_invoke 
command. The prefix allows LoadTest reports to be filtered by operatio
The prefix that you set here overrides the Com m and ID  prefix in 
theGenerator tab.

– Include original IO Rs in iiop_bind com m ands

Select this check box to make the ior argument of every scripted 
iiop_bind emulation command contain the stringified form of the IOR 
originally recorded for that object reference. The ior argument is required 
by the IO R bind modus. Clearing this box will shorten scripts, but you will 
have to manually enter the ior argument value when using the IO R bind 
modus.

tux_tpdequeue tdeq tux_tpsuspend tsus

tux_tpdisconnect tdis tux_tpterm tter

tux_tpenqueue tenq tux_tpunsubscribe tuns

tux_tpgetrply tget

Command Prefix Command Prefix

* tacaR applies when tux_tpacall involves a request only. When tux_tpacall involves 
both a request and the reply (request/reply turnaround), the prefix is tacaT. This is used for 
asynchronous request timing only and is never assigned to an emulation command.
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Setting General Recording Options

Robot lets you set general recording options, which apply to all virtual user recording 
methods. To set general recording options:

1 . Click Tools  →  Virtual U ser Record O ptions.

2 . Click the General tab.

This tab lets you set: 

ã Automatic prefixes for scripts and sessions

ã Whether Robot should prompt you to start an application after you start 
network or proxy recording

ã Various settings for the Virtual U ser Recorder window

The following sections describe these options.

Autonaming Prefixes
In the Autonam ing Prefixes group box, you can define prefixes for default script and 
session names. If you define a prefix, Robot appends a consecutive number to the 
prefix, and uses the unique prefix and number combination as the name it suggests 
each time it prompts you to define a script or session name during recording. 

For example, if your prefix for a script is Script, Script1 is the default script 
name for the first script you record, Script2 is the default script name for the 
second script you record, and so on.

During recording, when you are prompted to define a script or session name, you 
can accept the default name, modify it, or change it completely.

Optionally, you can leave either or both of these boxes blank, so that session and 
script names consist of the names that you define during recording.

Script and session names can have a maximum of 40 characters. Consequently, the 
maximum length of a prefix is 40 characters less the number of digits in the numeric 
suffix of the last script or session that you recorded.

Start Application
To have Robot prompt you to start the client after you begin recording, select 
Prompt for application name on start recording.

With API recording, you must start the client after you begin the recording process, 
when Robot prompts you to do so. As a result, the Prom pt for application nam e on 
start recording check box is disabled with API recording.
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With network or proxy recording, you can start the client before or after you begin 
recording. H owever, connection information is sometimes lost if you start the 
application before you begin recording. We recommend that you start the 
application after you begin recording.

If you start the client after you begin recording, you can have Robot prompt you to 
start the client, or you can start it without being prompted (for example, if the client 
is running on a different computer than Robot).

Setting the Recorder Window
The Virtual U ser Recorder window displays information about client requests and 
server responses as they occur during a recording session. This window appears 
automatically, in either a normal or minimized state, when you begin recording.

The following check boxes in the Recording W indow group box set a variety of 
options for the Virtual U ser Recorder window:

M inim ize on start recording – Select this check box to minimize the Virtual U se
Recorder window when you start recording. Clear this check box to display the
window in a normal state.

During recording, the Virtual U ser Recorder icon is displayed in the taskbar, to
left of the clock. The icon blinks when Robot is capturing a request or response.
icon serves as a visual cue that Robot is recording, even when the Virtual U ser
Recorder window is minimized.

Show Rates view – Select this check box to display the number of calls and byte
the current three-second interval.

Show Statistics view – Select this check box to display the total number of calls a
bytes in the recording session.

Show Annotations view – Select this check box to display the comments, start/s
blocks, timers, or synchronization points that you insert into the script during 
recording.
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For more information about the Virtual U ser Recorder window, including 
descriptions of the window’s views, see Getting Feedback During Recording on page 4-7.

Defining a Client or Server Computer

If you are using network or proxy recording, and the computer that you want to
is not listed in the Method N etwork and Method Proxy tabs, you can add it to t
list.

To add a client or server computer:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod:N etwork tab or M ethod:Proxy tab, depending on whether 
you are adding a computer for network or proxy recording.

3 . Click Com puter Admin.

4 . In the N am e box of the Com puters group, type a name to associate with the
network name of the computer that you are adding. You can assign any nam
to 40 characters. 

Rates view Sta tistics view

Annotat ions view
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5 . Type the computer’s network name. 

You can find the computer’s network name in the Identification tab of the 
Windows N T N etwork dialog box (Start → Settings → Control Panel → 
N etwork). In this tab, the network name is labeled Computer N ame.

Alternatively, you can type the computer’s IP address associated with the 
network name. However, because DHCP-provided IP addresses can chan
you should type a network name.

For information about finding a computer’s IP address, see the Getting Started 
with Rational PerformanceStudio manual.

6 . Optionally, click Ping to make sure that the network name you just typed is 
correct. If it is correct, “Successful Ping of network name” appears in the 
status bar.

7 . Select Client System  to list this computer as a client. Select Server System to 
list this computer as a server. You can select both choices.

8 . Click Add.

9 . Take the following steps to use a port number with the network name. A p
number is required for servers used in proxy recording:

a. In the Ports group, type a name to associate with the port number that y
are adding. You can assign any name up to 40 characters.

b. Type the port number to use with the computer’s network name.

c. Click Add.

1 0 . Click Close.

The computer is now added to the Rational repository and appears in the list o
computers.

N O TE: You can also define a computer with Rational Administrator. The 
Administrator lets you define additional information about the computer, such a
what type of operating system the computer runs on. 
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Removing a Computer or Port

To remove a client or server computer from the M ethod:N etwork tab:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod:N etwork tab.

3 . Click Com puter Admin.

4 . In the N am e box of the Com puters group, select the computer name to remove 
from the list.

5 . Click Remove.

6 . Click Close.

To remove a port name and number from a computer’s address:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod:N etwork tab.

3 . Click Com puter Admin.

4 . In the N am e box of the Com puters group, select the computer name associat
with the port that you are removing.

5 . U nder Ports, select the port name to remove.

6 . Click Remove.

7 . Click Close.

Authenticating Login

If you are running tests against a database that requires a user ID and passwor
must provide them when the script is recorded and when the script is played b

During recording, Robot attempts to detect the user ID, password, and other l
information. When successful, Robot stores this information in an Authenticati
Datapool. In addition, Robot adds the user ID, but not the password, to the sc

During playback, when a user ID and password are required for a database, R
finds the user ID in the script, and then attempts to find a password in the 
Authentication Datapool that is associated with the user ID. Robot uses the firs
active password that it finds for the user ID.
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When to Modify the Authentication Datapool
If Robot detects the user ID, password, and other login information provided during 
recording, it updates the Authentication Datapool automatically. If your login 
information does not subsequently change, you never need to modify the 
Authentication Datapool.

H owever, there are times when modifying the Authentication Datapool is necessary:

ã If Robot cannot detect the password during recording. For example, O racle 
passwords are almost always transmitted in encrypted form. As a result, you 
typically need to enter Oracle passwords into the Authentication Datapool.

ã If you change your password after the password is recorded and stored in the 
Authentication Datapool.

ã If the server does not allow a user to log into the database multiple times 
simultaneously. 

In other words, suppose Robot detects your user ID and password when you 
record a virtual user script. Robot writes the information to the Authentication 
Datapool. During playback, LoadTest retrieves your user ID and password from 
the Authentication Datapool and uses the information to log the virtual user into 
the database. 

Modifying the Authentication Datapool with TestManager
To modify the Authentication Datapool with TestManager:

1 . In TestManager, click Tools → M anage D atapools.

2 . Click Perform anceStudioAuthentication (the Authentication Datapool).

3 . Click Edit .

4 . Click Edit D atapool D ata  in the Datapool Properties dialog box.
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5 . Each row in the Edit Datapool dialog box contains the following information:

6 . Repeat the last step for each user ID and password that you need to enter.

7 . Click Save, and then click Close.

8 . Click O K to close the Datapool Properties dialog box, and then close the 
Manage Datapools dialog box.

Modifying the Authentication Datapool During Recording
If you need to insert many rows of login information into the Authentication 
Datapool, it is best to do so through TestManager.

But if you need to add just a few rows of login information, you should do so during 
recording, when Robot prompts you for this information.

For information about providing login information at the end of the recording 
process, see Providing a Missing Password on page 4-5.

Datapool column Meaning

State Whether the password in this row is ACTIVE or IN ACTIVE. 
Select one of these choices from the list box.

If a user provides a password for a particular service, and the 
Authentication Datapool already contains a password for that 
user and service, Robot automatically makes the currently 
provided password active and the earlier password inactive. 

If there is more than one active password, Robot uses the first 
active password that it finds in the Authentication Datapool.

Class The class is always SQ L in this release.

Subclass One of the following values:

ã O racle
ã Sybase
ã SQ L Server

Service The name of the database server as it is defined in the 
database environment. Do not use a computer name for the 
name of Service.

This is the same name that Robot inserts into the server 
argument of the sqlconnect command during recording.

Login The user ID.

Password The password for this user ID. 
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Unique Features of the Authentication Datapool 
The Authentication Datapool is similar to other datapools that you edit with 
TestManager. H owever, there are differences:

ã An empty Authentication Datapool is included with the Rational Test software.

ã The Authentication Datapool is used strictly for login information. You 
cannot assign any standard or user-defined data types to the columns in an 
Authentication Datapool.

ã Do not delete or rename the Authentication Datapool.

ã You should not add to or remove the columns in the Authentication Datapool.

ã The Authentication Datapool is not associated with the DATAPOOL_CONFIG 
statement or any datapool commands.

Managing Proxies

If you are using the proxy recording method, you need to create a proxy and identify 
client/server pairs that will communicate through the proxy.

After you have defined a proxy relationship, you can manage your proxies as follows:

ã Starting and stopping proxy service.

ã Monitoring proxy activity.

ã Deleting a client/server pair.

ã Deleting a proxy.

ã Reassociating a proxy with a client/server pair.

The following sections describe these functions.

Starting and Stopping Proxy Service
Proxy service is a system service that lets you use the proxy recording method. Proxy 
service starts automatically when you:

ã Install PerformanceStudio.

ã Start your system.

ã Open the Virtual U ser Record O ptions dialog box and click the M ethod:Proxy 
tab.

Proxy service stops automatically when you shut down Windows. 
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Explicitly Starting or Stopping Proxy Service
Typically, you will want to keep proxy service running, even when you shut down 
Robot. But if you need to explicitly stop proxy service, or start it up again after 
stopping it, follow these steps:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab and make sure that Proxy recording is selected.

3 . Click the M ethod:Proxy tab.

4 . Click Proxy Adm in. The Virtual U ser Proxy Administration dialog box appears.

The Status box shows whether proxy service is Running or Stopped:

– If proxy service is Stopped, click Start to run it.

– If proxy service is Running, click Stop to stop it.

Alternatively, you can start and stop proxy service as follows:

1 . Click Start → Settings → Control Panel.

2 . Double-click Services.

3 . Select ProxyServer Service.

4 . Click either Start or Stop.

Recreating Proxies After Proxy Service Is Stopped
The proxy computers are listed in the Existing Proxies grid of the Virtual U ser Proxy 
Administration dialog box.

When proxy service stops, either explicitly or during Windows shutdown, all pro
computers are deleted. Therefore, you must create new proxy computers befor
start proxy recording. For information about creating a proxy computer, see Creating 
a Proxy Computer on page 3-8.

Proxy service is not automatically shut down (and therefore, proxy computers are 
deleted) if you:

ã Exit Robot, but do not exit Windows.

ã Log off of your N T session, but do not exit Windows.
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Monitoring Proxy Activities
You can view information about existing proxies in the Existing Properties grid of 
the Virtual U ser Proxy Administration dialog box. The grid has the following 
columns:

Click Refresh to update the information in the grid.

Deleting Client/Server Pairs
You should remove client/server pairs that are listed in the M ethod:Proxy tab but are 
not involved in the session you that want to record. To do so:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab and make sure that Proxy recording is selected.

3 . Click the M ethod:Proxy tab.

4 . Select the client/server pair to delete from the Client/Server pairs for 
recording list.

5 . Click Remove.

6 . Click O K .

Column in grid Meaning

Proxy:Port The name and port number of the proxy computer.

Server:Port The name and port number of the server computer. Client requests to 
the server are routed through the proxy.

Connections The current number of connections to the server.

State The state of the proxy:

ACTIVE – The proxy is available for recording.

RECORD – The proxy is recording.

CLOSE_WAIT – A request has been issued to delete the proxy. Th
proxy is deleted as soon as it is no longer in use. If the proxy is in us
new connect requests are accepted.

CLOSE_WAIT_N OCON N  – A request has been issued to delete th
proxy. The proxy is deleted as soon as it is no longer in use. If the 
proxy is in use, new connect requests are not accepted.
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Deleting a Proxy
To delete the proxy relationship between a server and its proxy:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the M ethod tab and make sure that Proxy recording is selected.

3 . Click the M ethod:Proxy tab.

4 . Click Proxy Adm in. The Virtual U ser Proxy Administration dialog box appears.

5 . In the grid of existing proxies, select the proxy to delete.

6 . Click D elete Proxy.

7 . In the Virtual U ser Delete Proxy dialog box, click one of the following buttons:

– W ait for a ll connections to close, accept new connections

Delete the proxy as soon as it is no longer in use. If the proxy is currently in 
use, allow new connections. This selection is associated with the proxy state 
CLOSE_WAIT.

– W ait for a ll connections to close, do not accept new connections

Delete the proxy as soon as it is no longer in use. If the proxy is currently in 
use, do not allow new connections. This selection is associated with the 
proxy state CLOSE_WAIT_N OCON N .

– Im m ediately close a ll connections

Delete the proxy immediately. If the proxy is currently in use, close the 
connections.

8 . Click D elete.

In the Virtual U ser Proxy Administration dialog box, the proxy that you deleted has 
either been removed, or it is still present but has a modified state, depending on your 
choice in step 7.

Re-Creating Proxies that Have Been Removed
If a proxy is removed, any client/server pairs that communicated through that proxy 
can no longer do so. To use these client/server pairs in proxy recording again, you 
must first re-create the proxy. You re-create a proxy by reassociating it with the 
server.
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When you click the M ethod:Proxy tab of the Virtual U ser Record O ptions dialog 
box, any client/server pairs that are no longer associated with a proxy are displayed in 
the Virtual U ser Delete Pairs Without Proxies dialog box. You can either:

ã Click O K  to delete all of the client/server pairs.

ã Click Cancel to re-create one or more proxies. 

To re-create a proxy:

1 . Click Proxy Admin in the M ethod:Proxy tab.

2 . In Proxy:Port, specify the proxy computer’s port number. N ote that Robot h
already detected and specified the proxy computer’s name.

You can specify any available port number. Avoid the “well-known” port 
numbers (those below 1024). If you specify a port number that is unavailab
Robot prompts you for a new port number.

3 . In the Server:Port list, select the server to be reassociated with the proxy.

4 . Click Create Proxy.

The proxy that you just created appears in the Existing Proxies list.
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Recording Virtual User Scripts
This chapter describes how to record virtual user scripts. The chapter includes the 
following topics:

ã Recording a session

ã Recording a single script in a session

ã Getting feedback during recording

ã Canceling scripts during recording

ã Choosing the protocols to include in a script

ã Playing back a script quickly

ã Working with sessions

ã Coding a virtual user script manually

ã Defining script properties

ã Managing scripts and sessions

Recording a Session

You do not record virtual user scripts directly as you do GU I scripts. Instead, you 
record a session. After recording, Robot generates one or more scripts from the 
session.

A Robot recording session contains all of the client requests and server responses 
issued from the time you begin recording until the time you stop recording. Robot 
stores all of the requests and responses recorded during the session in a session file 
(.wch). The session file is sometimes called the watch file.
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What You Can Record in a Session
Robot gives you considerable recording flexibility. You can record:

ã Multiple transactions. For example, you can record a data entry transaction and 
a query transaction in the same recording session, one after the other.

ã Transactions against the same server or different servers. For example, you can 
record one transaction against one Web server, and then record another 
transaction against a different Web server.

ã Different types of requests in the same session. For example, you can record 
Oracle, Microsoft SQL Server, H TTP, and TU XEDO  requests in a session. 

Where Files Are Stored
Scripts (.s) are stored in the Script directory of your current project. For example, if 
the current repository is MyRepo and the current project is MyProject, here is what 
the directory hierarchy looks like:

c:\MyRepo\Project\MyProject\Script

Session files (.wch) are stored in the Session directory—for example:

c:\MyRepo\Project\MyProject\Session

Restoring Robot During Recording
When you begin recording, Robot becomes minimized by default, allowing you
unobstructed access to the client application.

At any time during recording, you can restore the Robot window without affect
the client/server traffic you are recording. For example, you might want to resto
the Robot window to: 

ã Reset recording options, such as the script generation options in the 
Generator tab.

ã Insert features such as timers, blocks, and synchronization points through
Robot Insert menu rather than through the floating toolbar.

When Robot is minimized during recording or is hidden behind other windows
during recording, you can bring it to the foreground in either of the following wa

ã Click the O pen Robot W indow button on the VU  Record floating toolbar.

ã Click the Robot icon on the Windows taskbar.

You can also use the standard Windows ALT+ TAB key combination.
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Recording a Single Script in a Session

U se the following procedure to record a single virtual user script in a session. For 
information about splitting a recording session into multiple scripts, see Splitting a 
Session into Multiple Scripts on page 4-15.

To record a virtual user script:

1 . In Robot, click the Record VU  Script button.

Alternatively, click File → Record Virtual U ser, or press CTRL+ SH IFT+ R.

2 . Type the session name (40 characters maximum), or accept the default name. You 
will specify the script name when you finish recording the script.

If you have not yet set your virtual user recording options, you can do so now by 
clicking O ptions. The next step assumes that your options are set.

3 . Click O K  in the Record Virtual U ser - Enter Session N ame dialog box. The 
following events occur:

– Robot is minimized (default behavior).

– The floating VU  Record toolbar appears (default behavior). You can us
this toolbar to stop recording, redisplay Robot, split a script, and insert 
features into a script. (See Using the Floating Toolbars on page 4-5.)

– The Virtual U ser Recorder icon appears on the taskbar. The icon blink
Robot captures requests and responses.

– If the client application is already running, the Virtual U ser Recorder 
window appears in a normal or minimized state. During recording, this
window displays statistics about the recorded client/server conversation
it occurs. (See Getting Feedback During Recording on page 4-7.)

– If the client application is not running, the Virtual U ser Start Application
dialog box appears before the Virtual U ser Recorder window appears.

4 . If the Virtual U ser Start Application dialog box is displayed, provide the 
following information, and then click O K:

– The path of the executable file for the browser or database application

– Optionally, the working directory for any components (such as DLLs) th
the client application needs at runtime.

– Optionally, any arguments that you want to pass to the client applicatio
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The Virtual U ser Start Application dialog box appears only if you are performing 
API recording, or if you are performing network or proxy recording and selected 
Prompt for application name on start recording in the General tab of the 
Virtual U ser Record O ptions dialog box.

5 . Perform the transactions that you want to record.

As the application sends requests to the server, notice the activity in the Virtual 
U ser Recorder window. Progress bars and request statistics appear in the top of 
the window.

If there is no activity in the Virtual U ser Recorder window (or if the Virtual U ser 
Recorder icon never blinks), there is a problem with the recording. Stop 
recording and try to find the cause of the problem.

6 . Optionally, insert features such as blocks and timers through the VU  Insert 
floating toolbar or through the Robot Insert  menu.

7 . Optionally, when you finish recording transactions, close the client application.

8 . Click the Stop Recording button on the VU  Record floating toolbar.

9 . In the N am e of the just-recorded script box, type or select a name for the script 
that you just finished recording, or accept the default name.

Alternatively, to cancel the requests you made since you began recording, click 
Ignore just-recorded information. For more information, see Cancelling Scripts 
During Recording on page 4-9.

1 0 . Click O K .

The Virtual U ser Script Generation Feedback dialog box appears. This dialog 
box reflects the progress of the automatic script generation. After a few seconds 
(or longer, depending on the length of the session), script generation ends, 
the message Completed successfully appears in the status bar, and the O K  button 
is enabled.

During script generation, you might see:

– The Virtual U ser Missing Password dialog box. For more information 
about this dialog box, see Providing a Missing Password on page 4-5.

– The Virtual U ser Manual Filtering dialog box. For information about th
dialog box, see Choosing the Protocols to Include in a Script on page 4-11.

1 1 . Click O K in the Virtual U ser Script Generation Feedback dialog box. The sc
that you recorded appears in the Robot window. 
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Using the Floating Toolbars
When you begin to record a script, Robot displays a floating toolbar by default. The 
VU  Record toolbar gives you access to activities you might want to perform while 
Robot is hidden from view during recording.

If you click the rightmost button on the VU  Record toolbar, you display the 
VU Insert toolbar. This toolbar lets you insert features into the script and start 
another application during recording.

The following figure shows the VU  Record toolbar and the VU  Insert toolbar:

If Script Generation Problems Occur
If problems occur during script generation, the following message appears in the 
status bar of the Virtual U ser Script Generation Feedback dialog box:

Completed with warnings and/or errors.

To see the list of errors, click D etails. If the text of an error is truncated, you can 
either:

ã Double-click the text to see the entire message.

ã Press CTRL+ C to copy the text to the Clipboard.

Providing a Missing Password
During recording, if you provide a user ID and password required to access the 
database, Robot attempts to detect this login information. If Robot can detect all of 
this information, it writes the information to the Authentication Datapool. (During 
script playback, LoadTest checks the Authentication Datapool whenever an 
emulated user needs to provide a valid user ID and password when accessing the 
database.)

Stop record ing

Split session  in to scrip ts

O pen Robot window

O pen  VU  Insert too lbar
Sta rt / stop
tim er

Start / stop
block

Synchron izat ion poin tCom m ent

Start 
applicat ion
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If Robot cannot detect a password that you provided during recording, and it cannot 
find a valid password for the associated user ID in the Authentication Datapool, 
Robot prompts you to provide the password just before generating the scripts you 
recorded.

Robot prompts you to provide each password that it could not detect, one by one, in 
the Virtual U ser Missing Password dialog box. In the title bar, Robot displays the 
total number of passwords that it needs to prompt you for, and the number of the 
password that you are currently providing. For example, if (1  of 3 ) appears in the 
title bar, Robot is currently prompting you for the first of three passwords.

For more information about the Authentication Datapool, see Authenticating Login on 
page 3-29.

To Provide a Password
To add a password for the user ID displayed in Login:

1 . Type the password in Password, and type it again in Verify Password. An 
asterisk ( * ) represents each character that you type.

Alternatively, if no password is needed for this user ID, select N o Password.

2 . Click Enter.

Robot automatically closes the dialog box when you finish providing passwords.

Type the password here, and then  
repeat the en try in  the box below.

If  you have m any passwords to  
enter, consider clicking Skip All, 
and then  running TestM anager to 
add the passwords d irect ly to  the 
Authen tication D atapool.

Specif ies the password you are 
cu rrently defin ing, and the tota l 
num ber of passwords to  define.
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To Skip One or More Passwords
If you do not know a password for a particular user ID, click Skip. You will need to 
provide the password later (for example, by editing the Authentication Datapool).

If you prefer to provide passwords for all the user IDs at a later time, click Skip All. 
You may prefer to do this if there are many passwords to provide. 

Getting Feedback During Recording

When you begin to record a virtual user script, the Virtual U ser Recorder appears, 
either in a normal or minimized state. You can use this window to monitor client 
activity during the recording session.

The Virtual U ser Recorder tracks a variety of statistics about the client/server 
conversation, such as the number of bytes the client sends or receives in a call.

To help you gauge the rate at which client/server activity occurs, the Virtual U ser 
Recorder displays its data at three-second intervals. Information in the Virtual U ser 
Recorder window is continuously updated as the client/server conversation 
progresses.

If you do not see any activity in this window as you record, Robot is not capturing 
client/server traffic. Stop recording and try to determine the cause of the problem.

You can set a variety of options about the appearance of the Virtual U ser Recorder 
window. For more information, see Setting the Recorder Window on page 3-26.

The Virtual User Recorder During Recording
The following figure shows the Virtual U ser Recorder window as it might appear 
during recording, and the type of information that it displays:
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The activity that the window displays varies, depending on your recording method. 

ã With API recording, the window displays the number of API calls and bytes sent 
from your computer.

ã With network recording, the window displays the number of IP packets and the 
bytes in these packets. H owever, the information may not be from your 
computer only. For example, if you are recording the activities of any client, in 
the Client list, the Virtual U ser Recorder window reports the activity of all 
clients on the network, not just the activity of your computer.

For information about the client/server traffic that you can record, see Selecting a 
Client/Server Pair on page 3-5.

ã With proxy recording, the window displays the number of IP packets and the 
bytes in these packets. 

Progress ba rs ind icat ing the 
num ber of ca lls and bytes in  
the current 3 -second in terval

The annotat ions (com m ents, start/stop b locks, t im ers, 
synchronizat ion  poin ts) you insert during record ing

Tota l num ber of ca lls and 
bytes in  the record ing session

M ost ca lls in  any 
3 -second in terval

M ost bytes in  any 
3 -second in terval

N um ber of ca lls and bytes in  
the curren t 3 -second  in terval
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The Virtual User Recorder Icon
During recording, the icon associated with the Virtual U ser Recorder window is 
displayed on the taskbar. The icon blinks whenever Robot is capturing a request or 
response. This icon serves as a visual cue that Robot is recording, even when the 
Virtual U ser Recorder window is minimized.

The Virtual User Recorder After Recording
The Virtual U ser Recorder captures “raw” client API calls or network IP packets
in other words, the calls or packets as they exist before Robot converts them in
VU commands.

When recording ends, Robot stores the calls or packets as follows:

ã Robot stores the calls or packets in a session file (.wch) in the same raw form
the packets have when captured.

ã Robot translates the calls or packets into VU  commands and stores them in
or more .s script files.

Cancelling Scripts During Recording

During virtual user recording, you can cancel scripts that you have recorded. T
scripts are deleted.

This feature is useful if you make errors while recording a script, or if you want
exclude non-essential or preliminary activity (such as logging in or navigating to
Web site that you want to test). For example, if you split a script at the point wh
you want to send a query, you can ignore the login and other preliminary requ
you needed to make to get to the query’s starting point.

Canceling the Script in a Single-Script Session
If you have not split the session into multiple scripts, you can cancel both the s
and the session and then stop recording as follows:

1 . During virtual user recording, click the Stop button on the VU  Record floating 
toolbar.

2 . In the Stop Recording dialog box, click Ignore just-recorded inform ation.

3 . Click O K in the Stop Recording dialog box.

N O TE: At any time, you can regenerate new script files from the stored .wch file
For more information, see Regenerating the Scripts Recorded in a Session on page 4-17.
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4 . Click O K  to acknowledge that the session is being deleted.

Canceling the Current Script in a Multi-Script Session
When you record a session, you click the Split Script button to create multiple 
scripts. 

To cancel the current script, keep the other scripts that you recorded in this session, 
and then continue recording: 

1 . During virtual user recording, click the Split Script button on the VU  Record 
floating toolbar.

2 . In the Split Script dialog box, click Ignore just-recorded information.

3 . Click O K .

You can now begin recording a new script. 

To cancel the current script, keep the scripts that you previously recorded in this 
session, and then stop recording:

1 . During virtual user recording, click the Stop button on the VU  Record floating 
toolbar.

2 . In the Stop Recording dialog box, click Ignore just-recorded inform ation.

3 . Click O K .

4 . Click O K  in the Virtual U ser Script Generation Feedback dialog box (after 
Robot finishes generating the script).

Canceling All Scripts in a Multi-Script Session
To cancel all of the scripts in a session and stop recording:

1 . During virtual user recording, click the Stop button on the VU  Record floating 
toolbar.

2 . Click O K  in the Stop Recording dialog box.

3 . Immediately click Cancel in the Virtual U ser Script Generation Feedback dialog 
box.

4 . Optionally, delete the session and empty scripts that Robot generated. 

You probably want to keep a script if you have planned a script in TestManager 
and defined properties for it. You can later record over the script and retain the 
properties that you have defined.

For information about deleting scripts and sessions, see Deleting Scripts and Sessions on 
page 4-25.
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Choosing the Protocols to Include in a Script

During network and proxy recording (and to a lesser extent, during API recording), 
Robot might capture requests for protocols that you do not want to include in a 
script. You can specify the protocols to include in either of the following ways:

ã Automatically, by selecting Auto Filtering in the Generator Filtering tab of the 
Virtual U ser Record O ptions dialog box.

ã Manually, by selecting M anual Filtering in the Generator Filtering tab. If you 
select this check box, Robot displays the Virtual U ser Manual Filtering dialog 
box during script generation, immediately after recording. The following 
section describes how to filter protocols manually.

For information about setting automatic or manual filtering, see Setting Filtering 
Options on page 3-16.

Manually Filtering Protocols
The Virtual U ser Manual Filtering dialog box lists in a hierarchical tree the 
connections that Robot detected during the recording session. In this dialog box, 
a connection has three parts:

ã The name or IP address of a client

ã The name or IP address of the server that communicated with the client during 
the connection

ã The protocol of the captured requests and responses issued during the 
connection

U se this dialog box to select the protocols to include in the script. You select the 
protocols to include by adding and removing the connections listed in the dialog box. 
Because you are selecting protocols within the context of a connection, you select 
protocols in one or more of these ways:

ã You can select the protocol used in all the connections to a particular server.

ã You can select the protocols used in all the connections from a particular client.

ã You can select a particular protocol name, regardless of the clients and servers 
that use it.
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Controls in the Virtual User Manual Filtering Dialog Box
The Virtual U ser Manual Filtering dialog box has the following controls:

Control name Purpose

Sort O rder Changes the hierarchical order in which protocol, client, and 
server names are listed in the tree.

Protocol Changes the type of requests that Robot generates for the 
currently selected connection in the tree. Robot converts the 
protocol in the current connection to the protocol type that you 
specify in Protocol.

Typically, you will not want to convert captured protocols.

Include, Exclude Includes or excludes selected items in the script that Robot is 
generating.

Tree Displays the protocol, client, and server names for conversations 
that Robot captured during recording. Also indicates whether 
items are marked for inclusion in or exclusion from the script.

Items are marked for inclusion or exclusion as follows:

ã Items that Robot will generate to the script are shaded red.

ã Items that Robot will exclude from the script are clear 
(white).

ã If an item is partially shaded red, some of the items below 
will be included, and some will be excluded.

When you click an item in the tree, you select that item and also 
any items below that item.

Click the +  icon to expand a branch, and click the - icon to close 
a branch.

To change the hierarchical order of the protocol, client, and 
server names, select a new order in Sort O rder.

Robot attempts to detect and display the names of the clients 
and servers involved in the conversations. If the names cannot 
be resolved, Robot displays IP addresses.

O K, Cancel Confirms or cancels any changes that you have made in this 
dialog box, and then closes the dialog box. When you close the 
dialog box, requests represented by shaded items are generated 
to the script.
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Example of Manually Filtering Protocols
The following figure shows the Virtual U ser Manual Filtering dialog box, with the 
components of the connection sorted by protocol, then server, then client:

In this example, Robot will generate H TTP requests for the following connections:

ã All connections to the server 204.071.200.243:80

ã The single connection to the server 204.071.200.074:80

N o requests will be generated for the following items:

ã All connections to the server 089.064.002.133:80

ã All socket protocols

Including or Excluding Connections
In the Virtual U ser Manual Filtering dialog box tree, each top-level item expands to 
display the components of one or more connections. Connection components can 
appear in the tree in any hierarchical order, depending on the Sort O rder setting.

Choose a new protocol 
to replace the selected 
protocol in  the tree.

Specify whether to  
include or exclude the 
selected item  in the 
generated scrip t.

Tree d isp laying 
the nam es of 
the recorded 
connections.

Specify the h iera rch ica l order of client, 
server, and protocol nam es in  the tree.

Shaded (red ) item s will be 
included in  the scrip t.

Clear (white) item s will be 
excluded  from  the scrip t.

Part ia lly shaded item s ind icate that 
som e connections will be included and 
som e excluded in  the generated scrip t.
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If a top-level item is marked for inclusion in the script that is being generated, all 
requests associated with that item (such as all H TTP connections) are included in 
the script. H owever, you can then selectively exclude one or more of the individual 
connections.

By selecting items to include and exclude, you can:

ã Include or exclude all requests associated with a protocol, or just some of those 
requests (by including or excluding client or server items below it).

ã Include or exclude all requests to a particular server, or just some of those 
requests (by including or excluding protocol or client items below it).

ã Include or exclude all requests from a particular client, or just some of those 
requests (by including or excluding protocol or server items below it).

To include or exclude the requests associated with an item in the tree:

1 . Click an item to include or exclude. Any items hierarchically below it are also 
selected.

2 . Click Include or Exclude.

3 . Repeat the above steps until all items to include in the script are shaded in red, 
and all items to exclude are clear (white).

4 . Click O K .

Converting from One Protocol Type to Another
You can also use the Virtual U ser Manual Filtering dialog box to convert the requests 
captured during a connection from one protocol type to another. 

To convert a protocol in the Virtual U ser Manual Filtering tree:

1 . Click the item of the tree representing the protocol to convert.

2 . In the Protocol box, select the new protocol.

3 . Click O K .

Some requests may be lost in a protocol conversion.

Typically, you will not want to convert protocol requests. But if you need to convert, 
you will most likely convert to or from socket requests.

Socket requests are low-level requests that are typically issued in addition to requests 
made with other, higher-level protocols (such Oracle or SQ L Server). As a result, 
you can specify that a captured protocol be converted to its associated socket 
requests, or that captured socket requests be converted to the associated requests in 
a higher-level protocol.
4 -1 4



Playing Back a  Scrip t Q u ickly

gical 
 the 

s and 
Playing Back a Script Quickly

After you record a script, you generally play it back from a schedule, as part of a user 
group. H owever, if you want to test a script that you have just recorded or edited, 
you can play it back quickly. 

To play back a script quickly:

1 . In Robot, click File → Playback.

2 . Click the name of the virtual user script to play back.

3 . Click O K .

LoadTest appears, ready to play back the script that you selected.

4 . In LoadTest, click Run → Schedule.

5 . Click O K  in the Run Schedule dialog box.

Working with Sessions

A virtual user recording session contains all of the client requests and server 
responses issued from the time you begin recording until the time you stop 
recording.

When you work with sessions, you can:

ã Split the session into multiple scripts.

ã Regenerate the scripts from the session.

ã View the session’s properties.

The following sections describe each of these activities.

Splitting a Session into Multiple Scripts
Splitting a session signifies that everything you have recorded represents one lo
unit of work, such as a login to a database. When you split a session, you name
completed script and start a new script. You can continue recording transaction
splitting the session into as many scripts as you want. 
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How to Split a Session into Multiple Scripts
To split a session into multiple scripts:

1 . During recording, at the point where you want to end one script and begin a new 
one, click the Split Script  button on the VU  Record floating toolbar.

2 . Enter a name for the script that you are ending, or accept the default name. 

You will specify a name for the script that you are about to begin when you finish 
recording client requests for it.

Alternatively, to cancel the requests you made since you began recording the 
current script, click Ignore just-recorded inform ation. This action affects only 
the current script, not any previous scripts you recorded in this session. For 
more information, see Cancelling Scripts During Recording on page 4-9.

3 . Click O K .

4 . Repeat the previous steps as many times as needed to end one script and begin 
another.

5 . After you click the Stop Recording button to end the recording session, type or 
select a name for the last script you recorded, or accept the default name.

Importing a Session
You can import a session from a different computer into your current repository. For 
example, assume someone at another site e-mails you a session file. You can import 
this session file, regenerate scripts, and create a schedule.

To import a session file and regenerate scripts:

1 . In Robot, click Tools  →  Im port Session. The Open dialog box appears.

2 . Click the session file, then click O pen. The session and its scripts are now in 
your repository. 

3 . To regenerate the scripts in the session you imported, click Tools  →  
Regenerate VU  Scripts from  Session, and select the session you imported.

4 . To regenerate the schedule, click Tools  →  Rational Test → LoadTest.

N O TE: If you split a session into multiple scripts, you should examine the 
resulting scripts to make sure that they begin and end at a known state. This is 
particularly important if you plan to use a split script as part of a loop or to run a 
series of scripts in a different order than you recorded them. Check the state of 
connections used in the script and any sqlprepare emulation commands or 
VU  commands that declare or manipulate cursors. 
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5 . Click File → N ew → Schedule. The N ew Schedule dialog box appears.

6 . Select Existing Session, and click O K .

7 . LoadTest displays a list of sessions that are in the repository. Click the name of 
the session that you imported, and click O K . 

LoadTest automatically creates a schedule that is ready to run.

Regenerating the Scripts Recorded in a Session
You might want to regenerate a session’s scripts for a variety of reasons—for 
example, to overwrite edits you made to the original scripts (restoring the scrip
the original recorded transactions), or to change the script generation options.

When you regenerate scripts from a session, the regenerated scripts inherit th
properties of the original scripts.

At any time, you can regenerate a session’s scripts from the session file. To do

1 . In Robot, click Tools → Regenerate VU  Scripts from  Session.

2 . Click the name of the session to use for script regeneration.

You can regenerate scripts that are contained within a session. You cannot
regenerate scripts that have been deleted from the session. To see the scr
a session, click the session name, click Properties, and then click Contained 
Scripts.

3 . Click O K. 

The Virtual U ser Script Generation Feedback dialog box appears. This dia
box shows how script regeneration is progressing. After a few seconds (or 
longer, depending on the length of the session), script regeneration ends, 
message Completed successfully appears, and the O K button is enabled.

4 . Click O K to acknowledge that the script regeneration operation is complete

N O TE: To import a session from one repository to another, click Tools  →  
RationalTest  →  TestM anager. Then click File  →  Import Test Assets.
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Changing Recording Options
When you regenerate a session’s scripts, you can change many of the recordin
options that were set when the script was recorded. You can change the optio
the following Virtual U ser Record Options tabs:

ã Generator

ã Generator Filtering

ã Generator per Protocol

For example, you can:

ã Select U se datapools to add datapool commands to the script, even if the 
original script had no datapool commands generated for it. (Conversely, cl
this check box to have no datapool commands included in the new script.)

ã Select a different D isplay returned data  value than the one used in the 
original script.

ã Set different playback expectations than those used in the original script

For information about recording options, see Setting Recording Options on page 3-1. 

When you regenerate scripts, you cannot add client/server requests to those th
originally recorded. However, you can remove some recorded requests throug
protocol filtering.

For example, to change options in the Generator tab:

1 . Click Tools → Virtual U ser Record O ptions.

2 . Click the Generator tab. 

3 . Specify the script options to include in the new script, and then click O K.

4 . Click Tools → Regenerate VU  Scripts from  Session to regenerate the script.

Viewing Session Properties
Session properties include the list of scripts in the session and a description of
the session. 

While viewing a session’s properties, the only session property that you can mo
is its description. O ther session properties are automatically defined when you c
the session.

N O TE: When you regenerate a session’s scripts, remember that you overwrite
of the scripts in the session.
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U nless you are regenerating a session’s scripts, you should view session proper
TestManager. (Click View → Asset Browser and open Session Q ueries.)

To view and optionally modify session properties while you are regenerating a 
session’s scripts in Robot:

1 . Click Tools → Regenerate VU  Scripts from  Session.

2 . Click the name of the session whose properties you want to view. 

3 . Click Properties.

4 . When finished, click O K to save any changes, or click Cancel.

5 . In the Regenerate VU  Scripts from Session dialog box, click O K to regenerate 
the session’s scripts, or click Cancel to close the dialog box without regeneratin
the session’s scripts.

Accessing Script Properties from Session Properties
While you are viewing a session’s properties, you can view and optionally modify
properties of any script generated from the session. 

U nless you are regenerating a session’s scripts, you should view session proper
TestManager. (Click View → Asset Browser and open Session Q ueries.)

To view script properties just before you regenerate a session’s scripts in Robo

1 . In Robot, click Tools → Regenerate VU  Scripts from  Session.

2 . Click the name of the session whose properties you want to view. Session n
are the same as session file names, but without the .wch extension.

3 . Click Properties.

4 . Click the Contained Scripts tab.

5 . Select the script whose properties you want to view or modify.

6 . Click Properties. The Script Properties dialog box appears.

For information about the properties that you can define, see the section a
customizing scripts and LoadTest schedules in the Using Rational Robot manual.

7 . When you have finished viewing and editing script properties, click O K to save 
any changes in the Script Properties dialog box, or click Cancel.

N O TE: Once you click O K in the Regenerate VU  Scripts from Session 
dialog box, the existing scripts in the session are destroyed. If you then clic
Cancel in the Virtual U ser Generation Feedback dialog box before the scrip
are regenerated, Robot will generate empty scripts.
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8 . Click Cancel to close the Session Properties dialog box.

9 . In the Regenerate VU  Scripts from Session dialog box, click O K  to regenerate 
the session’s scripts, or click Cancel to close the dialog box without regeneratin
the session’s scripts.

Coding a Virtual User Script Manually

The fastest and easiest way to generate a virtual user script is to record a sessio
Robot and generate the script automatically.

However, you can open an empty virtual user script and add code to it—for exam
if you are hand-coding the script, or if you are copying code from another scrip

To open an empty virtual user script and add code to it:

1 . In Robot, click File → N ew → Script.

2 . Type a script name and, optionally, a description of the script.

3 . Click Virtual U ser.

4 . Click O K. Robot creates an empty script with the following lines:

#include <VU.h>
{
}

5 . Add the code to the virtual user script.

For information about using the VU  scripting language, see the VU Language 
Reference.

Creating Library Files
VU  libraries are packaged in DLLs. You create dynamic link library (DLL) files usi
a development tool such as Microsoft Visual Studio. For information about mak
the DLLs that you create available to VU  scripts, see the VU Language Reference.

Defining Script Properties

A script can have properties associated with it in addition to the script name. 
Examples of script properties include a description of the script, the purpose o
script, and any test requirements associated with the script.

Defining script properties is an important part of the test planning process. For
reason, you typically define a script’s properties in TestManager before you rec
the script. But you can also define a script’s properties after you record the scrip
described in the following section.
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How to Define Script Properties in Robot
To define properties for a script that is open for editing in Robot, click 
File → Properties.

If the script exists but is not open:

1 . Click File → O pen → Script to open the Open Script dialog box.

2 . Click the script you are defining properties for.

3 . Click Properties.

4 . Define the script’s properties, and then click O K.

For information about the properties that you can define, see the section abou
customizing scripts and LoadTest schedules in the Using Rational Robot manual.

Managing Scripts and Sessions

This section describes the following script and session management activities:

ã Finding the scripts contained in a session

ã Finding the session name associated with a script

ã Removing a script from a session

ã Re-recording sessions

ã Re-recording scripts

ã Copying scripts

ã Deleting scripts and sessions

Finding the Scripts Contained in a Session
To see a list of all the scripts contained in a session:

1 . In TestManager, click View → Asset Browser.

2 . Double-click All under Session Q ueries.

3 . Double-click the name of the session whose script names you want to view

4 . Click Contained Scripts.

Optionally, you can open scripts or view script properties.
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Finding the Session Associated with a Script
A script can be associated with only one session. To see the name of this session:

1 . In Robot, click File → O pen → Script.

2 . Click the name of the script whose associated session you want to view.

3 . Click Properties.

4 . Click Related Assets.

5 . View the session name in Referenced Session.

A script might not be associated with a session. For example, a script might have been 
removed from its session, as described in the next section.

Removing a Script from a Session
If you remove a script from a session, you can no longer regenerate that script if you 
regenerate the session.

To remove a script from a session:

1 . In Robot, click File → O pen → Script.

2 . Click the name of the script to remove from its session.

3 . Click Properties.

4 . Click Related Assets.

5 . View the session name in Referenced Session.

6 . Click Clear.

Re-Recording Sessions
When you begin to record over an existing session that contains scripts, Robot 
prompts you for a confirmation. In the same dialog box, Robot also prompts you for 
a disposition of the scripts in the session, as follows:
4 -2 2



M anaging Scripts and Sessions

 

the 

.

, the 

e of 

ripts 

s and 

e of 
Whether you select or clear the check box depends on what you want to do:

ã Delete all of the session’s scripts and their associated properties, and begin
re-recording the session.

ã Keep the original scripts and their properties while creating new scripts for 
session.

ã Overwrite the original scripts, but assign their properties to the new scripts

The following sections describe each action. Regardless of which action you take
original session and its properties are overwritten.

Deleting the Original Scripts and Properties
To re-record a session and delete the original scripts and their properties:

1 . Click File → Record Virtual U ser.

2 . In the Record Virtual U ser - Enter Session N ame dialog box, select the nam
the session to re-record, and then click O K.

3 . In the VU  Recording dialog box, select D elete old session’s conta ined scripts, 
then click Yes.

The session’s contained scripts and their properties are deleted.

4 . Continue re-recording the session, assigning any names you like to the sc
that you are recording.

Keeping the Original Scripts
To re-record a session and create new scripts while keeping the original script
their properties intact:

1 . Click File → Record Virtual U ser.

2 . In the Record Virtual U ser - Enter Session N ame dialog box, select the nam
the session to re-record, and then click O K.

3 . In the VU  Recording dialog box, clear D elete old session’s conta ined scripts, 
and then click Yes.

4 . Continue re-recording the session, assigning any names you like to the scripts 
that you are recording other than the names of the original scripts.

The original scripts will no longer be associated with this or any other session. 
H owever, you can still add the original scripts to a schedule.
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Overwriting the Original Scripts but Keeping Their Properties
To re-record a session and overwrite the original scripts while assigning the 
properties of the original scripts to the new scripts:

1 . Click File → Record Virtual U ser.

2 . In the Record Virtual U ser - Enter Session N ame dialog box, select the name of 
the session to re-record, and then click O K .

3 . In the VU  Recording dialog box, clear D elete old session’s conta ined scripts, 
and then click Yes.

4 . Continue re-recording the session, assigning the name of one of the original scripts 
to each script that you record.

Re-Recording Scripts
Recording over a session affects all scripts in the session. To record over just one 
script, simply select that script’s name when Robot prompts you for a script nam
during recording (in the Split Script or Stop Recording dialog box).

Also, if you plan a script in TestManager, the name of the planned script appea
the list of existing scripts that you can choose from when you record a script. 

The following table summarizes the events that take place when you select the 
of a planned or existing script rather than type a new name for a script that you
just recorded:

Type of script Result of overwriting the script

Planned script The script’s properties are applied to the new script.

Robot does not prompt for a confirmation before recording the scrip
because the existing script is empty.

Existing script is 
part of a session

Robot prompts for a confirmation that you want to overwrite the 
script:

ã Click N o to select or type another script name.
ã Click Yes to overwrite the script. The properties of the original 

script are applied to the new script. Also, the script is removed from
the original session and added to the new session.

Existing script is 
not part of a session

Robot overwrites the original script without prompting you for a 
confirmation.

The properties of the original script are applied to the new script.
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Copying Scripts
To copy a script in Robot:

1 . Click File → O pen → Script.

2 . Click the name of the script to copy, and then click O K .

3 . Click File → Save As.

4 . Type a name for the new script, and then click O K .

The new script does not retain the properties of the original script. In addition, the 
new script is not associated with any session.

Deleting Scripts and Sessions
To delete a script and its properties:

1 . In Robot, click File → D elete.

2 . Click the name of the script to delete.

To delete multiple scripts, hold down the CTRL key and click each script to 
delete.

3 . Click O K .

4 . Click O K  when prompted to confirm the deletion.

5 . Click Cancel to close the Delete Script dialog box.

If you delete a script from a session, you can no longer regenerate that script if you 
regenerate the session that it was once associated with.

If you delete all scripts in a session, the session still remains.

To delete a session:

1 . In TestManager, click View → Asset Browser.

2 . Double-click All under Session Q ueries.

3 . Right-click the name of the session to delete, and then click D elete.

4 . Click Contained Scripts.
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5 . When prompted to confirm the deletion, select or clear the D elete scripts 
conta ined in the session? check box as follows:

– Select the check box to delete all of the session’s scripts and propertie
addition to deleting the session.

– Clear the check box to leave the session’s scripts and properties intact.
scripts will no longer be associated with this or any other session. Howe
you can still add the scripts to a schedule.

6 . Click Yes to confirm the deletion.
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Adding Features to Virtual User Scripts
This chapter describes the features that you can add to a virtual user script while 
recording the script with Robot. The chapter includes the following topics:

ã Timers

ã Blocks

ã Synchronization points

ã Comments

ã U sing the Insert menu

Timers

Individual emulation commands (such as sqlprepare and sqlexec) are timed 
automatically. By default, these times are included in LoadTest report output.

H owever, if you want to measures the time it takes a virtual user to perform an 
activity—for example, sending a query to the server and displaying the results—
insert a timer or a block in the script.

How Timers Work
Think of a timer as a stopwatch that you click on just before you begin to perfo
the timed activity, and that you click off when you complete the activity.

For example, suppose you want to time how long it takes to submit a query to 
database server and receive the results. During recording, you would:

1 . Start the timer (click Insert → Start T im er) just before you click the button to 
send the query. This action inserts the VU  emulation command start_time 
into the script.

2 . Stop the timer (click Insert → Stop T imer) as soon as the results appear. Thi
action inserts the VU  emulation command stop_time into the script.
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When you stop a timer, you can reuse that timer’s name in another timer. The
no practical limit to the number of timers that you can add to a script. 

You can nest timers within other timers (by starting and stopping the second ti
before stopping the first timer), and you can overlap timers (by stopping the sec
timer after stopping the first timer).

If you do not explicitly stop a timer, no response time is reported for that activit

You cannot extend a timer over multiple scripts.

The following illustration shows the start_time and stop_time emulation 
commands for a timer named query1:

Why Use Timers?
You need to use timers in the following cases:

ã You want to time an overlapping sequence of events. You can insert a 
start_time command followed by several stop_time commands. You 
cannot overlap blocks (although you can nest them).

ã You want to time a very specific portion of the script. You can insert the 
start_time and stop_time commands exactly where you want when yo
edit the script. You can insert a block, however, only during recording.

In other cases, however, you may want to use blocks rather than timers. Block
only add timers to a script, but they also add a prefix to each command ID in th
block. This prefix enables you to easily identify emulation commands associate
with a block both in the script and in the report output.

Adding a Timer During Recording
During recording, you can add a timer operation to a virtual user script as follo

1 . If the VU  Insert floating toolbar is not already displayed, click the D isplay VU  
Insert Toolbar button on the VU  Record floating toolbar.

2 . Click the Start T im er button.
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3 . In the Start Timer dialog box, type the timer’s name (40 characters maximu
and then click O K.

4 . Perform the timed activity.

5 . Immediately after receiving the results generated by the activity, click the Stop 
T im er button on the VU  Insert floating toolbar.

6 . In the Stop Timer dialog box, select the name of the timer you typed in ste
and then click O K.

When you start and stop a timer during recording, you can view these comman
the Virtual U ser Recorder Annotations window.

Adding a Timer During Editing
The VU  Insert toolbar (or the Robot Insert menu) adds timers during recordin
To add a timer during editing, type the timer commands into the script.

The following are the timer commands for virtual user scripts:

ã start_time – Starts timing the activity. Insert this command immediately
before the first emulation command for the activity that you are timing. The
start_time measurement includes the think time (if any) for the next 
emulation command in the script. 

To exclude the think time for an emulation command, insert start_time 
after the emulation command and use the _fs_ts read-only variable. For 
example:

http_request ["test1.001"] ...
start_time ["timerid"] _fs_ts;
stop_time ["timerid"];

ã stop_time – Stops timing the activity. Insert this command immediately aft
the last emulation command for the activity that you are timing.

For details about using these commands, see the VU Language Reference.

N O TE: Inserting timers into GU I scripts is similar to inserting timers into virtual
user scripts. However, GU I scripts use a different set of timer commands 
(StartTimer and StopTimer). 
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Blocks

A block is a set of contiguous lines of code that you want to make distinct from the 
rest of the script. Typically, you use a block to identify a transaction within a script.

A block has the following characteristics:

ã A block begins with the following comment:

/* Start_Block "BlockName" */

ã Robot automatically starts a timer at the start of the block:

start_time ["BlockName"] _fs_ts;

Typically, the start_time emulation command is inserted after the first 
action, but with an argument to use a read-only variable that refers to the start 
of the first action.

ã The ID of every emulation command in a block is constructed the same way— 
that is, by the block name followed by a unique, three-digit autonumber. 
For example:

http_header_recv ["BlockName002"]  200; 

When you end a block, command IDs are constructed as they were before
started the block. For example, if the last command ID before the block wa
Script025, the next command ID after the block will be Script026. (For 
more information about command IDs, see Command ID Prefix on page 3-10.)

ã A block ends with a stop_time command plus a comment:

stop_time ["BlockName"]; /* Stop_Block */

A script can have up to 50 blocks. 

When you end a block, Robot automatically ends the current block. In other wo
blocks can be nested, but they cannot be overlapped. For example:

You cannot extend a block over multiple scripts. If you attempt to split a script in
middle of a block, Robot ends the block when it ends the initial script.

Valid blocks Invalid blocks

Block1Start Block1Start

Block2Start Block2Start

Block2Stop Block1Stop

Block1Stop Block2Stop
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Why Use Blocks?
You might want to use blocks for the following reasons:

ã To associate the block and timer names with the emulation command that 
performs the transaction.

ã To include the block name in LoadTest reports, thus enabling you to filter the 
reports with the block name.

ã To make the script easier to read, and to provide an immediate context for a line 
within the block through command IDs.

Adding a Block
To insert a block into a script:

1 . If the VU  Insert floating toolbar is not already displayed, click the Insert  button 
on the VU  Record floating toolbar.

2 . Click the Start Block button at that point in the script where you want the block 
to begin —for example, just before you start to record a transaction.

3 . Type the block name. 

Robot uses this name as the prefix for all command IDs in the block. The 
maximum number of characters for a command ID prefix is seven.

4 . Click O K.

5 . Record all of the client requests in the block.

6 . Click the Stop Block button to end the current block, and then click O K.

7 . Continue recording the other sections of the script.

When you start and stop a block during recording, the commands are reported
annotations in the Virtual U ser Recorded Annotations window.

N O TE: When you end a block, you always end the current block. If you are
nesting blocks, you cannot specify which block you want to end—the Stop 
Block command always applies to the innermost block. For more 
information, see N esting Blocks on page 5-6.

N O TE: You can add a block only during recording, not during editing.
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Nesting Blocks
To nest blocks, click Start Block on the VU  Insert floating toolbar to start a new 
block without explicitly ending the current block.

When you nest blocks:

ã Robot inserts the start_time command at or near the beginning of the 
second block.

ã Timing continues on the first block (in other words, stop_time is not 
inserted for the first block).

ã The second block’s name replaces the first block’s name as the prefix for 
emulation commands.

If you have nested blocks and you click Stop Block:

ã Robot inserts the stop_time command to stop timing the current block.

ã The next block up in the hierarchy becomes the current block (that is, its n
is used as the prefix for emulation commands). Timing continues on this b
plus other blocks that may be above it in the nesting hierarchy.

Example of Nested Blocks
The following example contains three blocks—blockA, blockB, and blockC:

/* blockA begins with a Start Block command */
/* Start_Block "blockA" */
start_time ["blockA"];
... /* Perform transaction in blockA */
http_nrecv ["blockA022"]  100 %% ;      /* 411/8147 bytes */
http_disconnect(img4_yahoo_com_80_5);

/* blockB begins with a second Start Block command */
/* Start_Block "blockB" */
start_time ["blockB"];
... /* Perform transaction in blockB */
http_nrecv ["blockB012"]  100 %% ;      /* 5812 bytes */
http_disconnect(D141_217_90_3_80);

/* blockC begins with a third Start Block command */
/* Start_Block "blockC" */
start_time ["blockC"];
... /* Perform transaction in blockC */
http_nrecv ["blockC054"]  100 %% ;      /* 4577 bytes */
http_disconnect(D141_217_90_3_80_17);

/* A Stop Block command ends the current block (blockC) */
stop_time ["blockC"]; /* Stop_Block */
moe_si_umich_edu_80 = http_request ["blockB013"] ...;
... /* Resume blockB transaction */
http_nrecv ["blockB018"]  100 %% ;      /* 5076 bytes */
http_disconnect(moe_si_umich_edu_80);

/* A second Stop Block command ends the current block (blockB) */
stop_time ["blockB"]; /* Stop_Block */
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ntdwwaag_v1_compuserve_com_80_38 = http_request ["BlockA023"]...;
... /* Resume blockA transaction */
http_nrecv ["BlockA031"]  100 %% ;      /* 3791/3787 bytes */
http_disconnect(ntdwwaag_v1_compuserve_com_80_38);

/* A third Stop Block command ends the current block (blockA) */
stop_time ["blockA"]; /* Stop_Block */

Synchronization Points

A synchronization point lets you coordinate the activities of a number of users 
by pausing the execution of each user at a particular point—the synchronization 
point—until one of the following events occur:

ã All users associated with the synchronization point arrive at the synchroniza
point. 

ã A timeout period is reached before all users arrive at the synchronization 
point. You specify the timeout period in the LoadTest Synchronization Poin
dialog box.

ã You manually release the users while monitoring a schedule run in LoadTe

When one of the above events occurs, LoadTest releases the users, allowing th
continue performing the transaction.

Both virtual users and GU I users support synchronization points. 

How Synchronization Points Work
At the start of a test, all users begin executing their assigned scripts. They cont
to run until they reach the synchronization point. In a script, a synchronization p
is the command sync_point (virtual user scripts) or SQ ASyncPointW ait (GU I 
scripts). In a schedule, a synchronization point is a time specified in the schedu

The following figure illustrates a synchronization point in a virtual user script:

Virtual users running
simultaneously

Virtual users reach the
synchronization point

1 2

sync_point
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The users pause at the synchronization point until LoadTest releases them. 
Typically, LoadTest releases synchronized users when they all arrive at the 
synchronization point.

Why Use Synchronization Points?
By synchronizing users to perform the same activity at the same time, you can make 
that activity occur at some particular point of interest in your test—for example, 
when the application-under-test sends a query to the server. 

Typically, synchronization points that you insert into scripts are used in conjunc
with timers to determine the effect of varying user load on the timed activity. Fo
example, to the effect of user load on data retrieval, you could take the followin
general steps:

1 . While recording the virtual user script (named VU 1 in this example) that w
submit the query and display the result, perform the following actions:

a. Insert a synchronization point named TestQuery into the script.

b. Click the Start Block button (see page 5-5). 

The block times the transaction you are about to perform. The block a
associates the block and timer names with the name of the emulation 
command that performs the transaction.

c. Submit the query and wait for the results to be displayed.

d. Click the Stop Block button.

2 . While recording the virtual user that will provide the user load, insert 
anotherTestQuery synchronization point just before you begin to record 
the activity that provides the load—for example, just before you click the but
to submit an order form. N ame this script VU 2.

3 . Add VU 1 and VU 2 to a schedule. 

4 . Run the schedule a number of times, each time using a different number o
VU 2 users. However, you only need one VU 1 user in each test.

Theoretically, as the number of synchronized VU 2 users increases, the tim
reported by the VU 1 timer should also increase.

In this example, the TestQuery synchronization point ensures that:

ã All VU 2 virtual users submit their forms at the same time—thereby providi
maximum concurrent user load.

ã The VU 1 user submits its query at the same time that the VU 2 users are loa
the server—thereby providing maximum user load at a critical time.
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Inserting Synchronization Points
You can insert a synchronization point into a script (through Robot) or into a 
schedule (through LoadTest).

ã Into a  script – You can insert a synchronization point into a script in one of t
following ways:

– During recording, through the Sync Point toolbar button or through the 
Insert menu.

– During script editing, by manually typing the synchronization point 
command name into the script.

Insert a synchronization point into the script to control exactly where the sc
pauses execution. For example, you can insert a synchronization point 
command just before you send a request to a server.

You should also use this method if the synchronization point will depend up
some logic that you add to the script during editing.

ã Into a  schedule – You can insert a synchronization point into a schedule 
through the LoadTest Synchronization Point dialog box.

Insert a synchronization point into the schedule to pause execution before
between scripts rather than within a script. In addition, inserting a 
synchronization point into a schedule offers these advantages:

– You can easily move the location of the synchronization point without 
having to edit a script.

– The synchronization point is visible within the schedule rather than hidd
within a script.

A script can have multiple synchronization points, each with a unique name. T
same is true of a schedule. A given synchronization point name can be referenc
multiple scripts and/or schedules.

The following sections describe the various ways to insert synchronization poin

Inserting a Synchronization Point During Recording
To insert a synchronization point into a virtual user script during recording:

1 . If the VU  Insert floating toolbar is not already displayed, click the Insert button 
on the VU  Record floating toolbar.

2 . Click the Sync Point button immediately before you begin to record the activi
that you are synchronizing.
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For example, to synchronize multiple virtual users so that they all submit a 
query at the same time, first insert the synchronization point, and then perform 
the user action that sends the query to the server.

3 . Type the synchronization point name.

4 . Click O K .

When you insert a synchronization point during recording, the command is reported 
as an annotation in the Virtual U ser Recorded Annotations window.

Inserting a Synchronization Point During Editing
You can only use the VU  Insert toolbar (or the Robot Insert menu) to insert a 
synchronization point into a script during recording. To insert a synchronization 
point during editing, type the VU  command sync_point into the script.

For details about using this command, see the VU Language Reference.

Inserting a Synchronization Point During Scheduling
When you insert a synchronization point into a schedule, you can do more than 
simply assign a synchronization point name to a script. For example:

ã You can specify whether you want the users to be released at the same time or at 
different times.

If the users are to be released at different times (that is, in a staggered fashion), 
you can specify the minimum and maximum times within which all users must 
be released.

ã You can specify a timeout period. 

For more information about inserting a synchronization point in a schedule, see 
Inserting a Synchronization Point on page 7-25

Release Tim es and Tim eouts for Synchronization Poin ts in  Scripts
You cannot define minimum and maximum release times or timeout periods for 
synchronization points that you insert into scripts (as you can for synchronization 
points that you insert into schedules). By default:

ã Virtual users held at a script-based synchronization point are released 
simultaneously.

N O TE: To insert a synchronization point into a GU I script, enter the 
synchronization point command SQ ASyncPointW ait into the script. You 
cannot insert a synchronization point into a GU I script during recording.
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ã There is no time limit to how long virtual users can be held at the 
synchronization point.

H owever, if a synchronization point in a schedule has a release time range and 
timeout period defined for it, the release times and timeout period apply to all 
synchronization points of that same name—even if a synchronization point is 
in a script.

Scope of a Synchronization Point
The scope of a synchronization point includes all scripts that reference a partic
synchronization point name plus all user groups that reference that name.

For example, suppose you have the following user groups in a schedule:

ã A Data Entry user group of 75 virtual users. This user group runs a script 
containing the synchronization point Before Query. 

ã An Engineering user group of 10 virtual users. This user group runs a 
different script than the Data Entry groups runs. But this script also contain
a synchronization point named Before Query.

ã A Customer Service user group of 25 virtual users. This user group runs a s
that contains no synchronization points. However, the user group does ha
synchronization point defined for it. This synchronization point is also nam
Before Query.

At schedule runtime, LoadTest releases the users held at the Before 
Query synchronization point when all 110 users arrive at their respective 
synchronization points.

Comments

A com m ent is a line of text in a script that begins with the characters /* and ends 
with the characters */ —for example:

/* This is a comment. */

Comments are ignored at script compile time and during script playback.

U se comments to document the script and to help you find your way around t
script if you later need to edit it.
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Adding Comments During Recording
To insert a comment into a virtual user script during recording:

1 . If the VU  Insert floating toolbar is not already displayed, click the Insert  button 
on the VU  Record floating toolbar.

2 . Click the Com m ent button at that point in the script where you want to insert 
the comment.

3 . Type your comment in the Comment dialog box (60 characters maximum), and 
then click O K.

When you add a comment during recording, the comment is reported as an 
annotation in the Virtual U ser Recorded Annotations window.

Adding Comments During Editing
To add a comment during editing, type the comment directly into the script. 

Be sure to begin the comment with the /* characters, and end the comment with 
the */ characters.

Comments that you type in manually during editing are not limited to the 
60-character maximum that applies when you add comments during recording.

Using the Insert Menu

The preceding sections describe how to use the VU  Insert floating toolbar to add 
start timers and stop timers, synchronization points, start blocks and stop blocks, and 
comments to a script during recording.

During recording, you can also use the Robot Insert menu to add these features.

If Robot is minimized while you are recording (its default state), click the 
O pen Robot W indow button on the VU  Record floating toolbar. This button 
restores the Robot window, letting you access the Insert menu.
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Working with Datapools
This chapter describes how to create and manage datapools. It includes the 
following topics:

ã What is a datapool

ã Planning and creating a datapool

ã Data types

ã U sing datapools with virtual user scripts

ã U sing datapools with GU I scripts

ã Managing datapools with TestManager

ã Managing user-defined data types

ã Generating and retrieving unique datapool rows

ã Creating a datapool outside Rational Test

ã Creating a column of values outside Rational Test

You should familiarize yourself with the concepts and procedures in this chapter 
before you begin to work with datapools.

N O TE: This chapter describes datapool access from virtual user and GU I scripts 
played back in a LoadTest schedule. For information about datapool access from 
GU I scripts played back in Robot, see the datapools chapter in the Using Rational 
Robot manual.
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What Is a Datapool? 

A datapool is a test dataset. It supplies data values to the variables in a script during 
script playback.

Datapools let you automatically pump test data to virtual users and GU I users under 
high-volume conditions that potentially involve hundreds of users performing 
thousands of transactions.

Typically, you use a datapool so that:

ã Each user that runs the script can send realistic data (which can include unique 
data) to the server.

ã A single user that performs the same transaction multiple times can send realistic 
data to the server in each transaction.

If you do not use a datapool during script playback, each user sends the same literal 
values to the server (the values that were captured when you recorded the script).

For example, suppose you record a virtual user script that sends order number 53328 
to a database server. If 100 virtual users run this script, order number 53328 is sent 
to the server 100 times. If you use a datapool, each virtual user can send a different 
order number to the server.

Datapool Tools
You create and manage datapools with either Robot or TestManager, as follows:

Activity Robot TestManager

Automatically generate datapool 
commands in a virtual user script. •

Create a datapool and automatically 
generate datapool values. • •

Edit the DATAPO OL_CO N FIG 
section of a virtual user script. •

Edit datapool column definitions 
and datapool values. • •
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This chapter describes how to perform all of these activities.

Managing Datapool Files
A datapool consists of two files:

ã Datapool values are stored in a text file with a .csv extension. 

ã Datapool column names are stored in a specification(.spc) file. The Robot or 
TestManager software is always responsible for creating and maintaining this 
file. You should never edit this file directly.

.csv and .spc files are stored in the Datapool directory of your Robot project.

U nless you import a datapool, the Robot or TestManager software automatically 
creates and manages the .csv and .spc files based on instructions you provide through 
the user interface.

If you import a datapool, you are responsible for creating the .csv file and populating 
it with data. H owever, the Rational Test software is still responsible for creating and 
managing the .spc file for the imported datapool.

For information about importing datapools, see Importing a Datapool on page 6-35 and 
Creating a Datapool Outside Rational Test on page 6-44.

Create and edit datapool data types. •

Perform datapool management 
activities such as copying and 
renaming datapools.

•

Import and export datapools. •

Import data types. •

 (Continued) 

Activity Robot TestManager

N O TE: LoadTest automatically copies a .csv file to each Agent computer that uses 
it. If an Agent’s .csv file becomes out-of-date, LoadTest automatically updates it
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Datapool Cursor
The datapool cursor, or row-pointer, can be shared among all users that access the 
datapool, or it can be unique for each user. 

Sharing a datapool cursor among all users allows for a coordinated test. Because each 
row in the datapool is unique, each user can share the same cursor and still send 
unique records to the database.

Also, a shared cursor can be persistent across schedule runs. For example, suppose 
the last datapool row accessed in a schedule run is row 100:

ã If the cursor is persistent across schedule runs, datapool row access resumes with 
row 101 the first time the datapool is accessed in a new schedule run.

ã If the cursor is not persistent, datapool row access resumes with row 1 the first 
time the datapool is accessed in a new schedule run.

For information about defining the scope of a cursor, see the description of the 
Cursor argument on page 6-16.

Row Access Order
Row access order is the sequence in which datapool rows are accessed at test runtime.

With GU I scripts, you can control the row access order of the datapool cursor 
through the sequence argument of the SQ ABasic SQADatapoolOpen 
command. 

With virtual user scripts, you can control row access order through the Access O rder 
setting in the Robot Configure Datapool in Script dialog box. (See page 6-17.)

Datapool Limits
A datapool can have up to 150 columns if the Rational Test software automatically 
generates the data for the datapool, or 32,768 columns if you import the datapool 
from a database or other source. Also, a datapool can have up to 2,147,483,647 rows.

N O TE: GU I users can share a cursor when playback occurs in a LoadTest 
schedule, but not when playback occurs in Robot.
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What Kinds of Problems Does a Datapool Solve?
If you play back a script just once during a test run, that script probably does not need 
to access a datapool.

But often during a test run, and especially during performance testing, you need to 
run the same script multiple times — for example:

ã During performance testing, you will probably want to run multiple instanc
of a script, so that the script is executed many times simultaneously. 
(Remember, a virtual user is one runtime instance of a script.)

ã During functional and performance testing, you will often want to run multip
iterations of a script, so that the script is executed many times consecutive
(simulating a user performing the same task over and over). 

If the values used in each script instance and each script iteration are the same
values — the values you provided during recording — you might encounter 
problems at test runtime. 

Here are some examples of problems that datapools solve:

ã Problem: During recording, you create a personnel file for a new employee, us
the employee’s unique social security number. Each time the script is playe
back, there is an attempt to create the same personnel file and supply the 
social security number. The application rejects the duplicate requests.

Solution: U se a datapool to send different employee data, including unique so
security numbers, to the server each time the script is played back.

ã Problem: You delete a record during recording. During playback, each instan
and iteration of the script attempts to delete the same record, and “Record
Found” errors result.

Solution: U se a datapool to reference a different record in the deletion requ
each time the script is played back.

ã Problem: The client application reads a database record while you record a s
for a performance test. During playback, that same record is read hundred
times. Because the client application is well designed, it puts the record in c
memory, making its retrieval deceptively fast in subsequent fetches. The 
response times that the performance test yields will be inaccurate.

Solution: U se a datapool to request a different record each time the script is
played back.
6 -5



Working with  D atapools

n 
ript 
ese 
Planning and Creating a Datapool

H ere is a summary of the stages involved in preparing a datapool for use in testing. 
The order shown is the typical order for planning and creating a datapool for virtual 
user scripts:

1 . Plan the datapool.

Determine the datapool columns you need. In other words, what kinds of values 
(names, addresses, dates, and so on) do you want to retrieve from the datapool 
and send to the server?

Typically, you need a datapool column for each script variable that you plan to 
assign datapool values to during recording. 

For example, suppose your client application has a field called O rder N umber. 
During recording, you type in a value for that field. With virtual user scripts, the 
value is automatically assigned to a script variable. During playback, that variable 
can be assigned unique order numbers from a datapool column.

This stage requires some knowledge of the client application and the kinds of 
data that it processes. 

To help you determine the datapool columns you need, record a preliminary 
virtual user script. Rational Robot automatically captures all the values 
supplied to the client application during recording and lists them in the 
DATAPOOL_CONFIG section at the end of the script. For more information, see 
Finding Out What Data Types You N eed on page 6-10.

2 . Generate datapool code.

To access a datapool at runtime, a script must contain datapool commands, such 
as commands for opening the datapool and fetching a row of data. With virtual 
user scripts, a DATAPOOL_CONFIG section must also be present. This section 
contains a variety of information about how the datapool is created and accessed.

Datapool code is generated in either of these ways:

– With virtual user scripts, Robot generates datapool code automatically whe
you finish recording a script. Robot is aware of all the variables in the sc
that are assigned values during recording, and it matches up each of th
variables with a datapool column.

To have Robot generate datapool commands automatically during 
recording, make sure U se datapools is selected in the Generator tab of the 
Virtual U ser Record Options dialog box, and then record the script.
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– With GUI scripts, you manually insert the datapool commands and match
script variables with datapool columns. For information about coding 
datapool commands, see Using Datapools with GUI Scripts on page 6-24.

3 . Create and populate the datapool.

After the datapool commands are in the script, you can create and populat
datapool. 

To start creating and populating a datapool for a virtual user script you are 
editing in Robot, click Edit → D atapool Information. 

If you are creating a datapool for exclusive use by a GU I script, use TestMan
to create and populate the datapool. For more information, see Creating a 
Datapool with TestManager on page 6-25.

Creating and populating a datapool for a virtual user script involves these 
general steps:

– Editing the DATAPOOL_CONFIG section of the script. For example, you 
might want to change the default datapool access flags, or exclude a dat
column from being created for a particular script variable. Or, you can 
accept all the default settings that Robot specifies when it creates this se
in a virtual user script.

For information about editing the DATAPOOL_CONFIG section of a script, 
see Step 1. Editing Datapool Configuration on page 6-14.

– Defining the datapool columns that you determined you needed during
planning stage. For example, for an Order N umber column, you can spe
the maximum number of characters that an order number can have, a
whether the Order N umber column must contain unique values. 

For information about defining datapool columns, see Step 2. Defining 
Datapool Columns and Generating the Data on page 6-19.

You also assign a data type to each datapool column. Data types suppl
datapool column with its values. For information about data types, see Data 
Types on page 6-9.

– Generating the data. Once you configure the datapool and define its 
columns, you populate the datapool simply by clicking Generate D ata .

With Robot, you can create and populate a datapool immediately after recor
or at any other time, as long as the datapool commands are in the script.

N O TE: You can also create and populate a datapool file manually and impo
it into the repository. For more information, see Creating a Datapool Outside 
Rational Test on page 6-44.
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The following figure illustrates the three stages of datapool creation:

In Robot, click Edit
Modify DATAPOOL_CONFIG or accept the defaults.

Plan the Datapool
What datapool columns do you need?
What data type should you assign each column?
Do you need to create data types?

Generate the Code

Select the Use datapools recording option.
Record the transaction(s), and then stop recording. 
Robot automatically generates datapool commands.
Robot automatically matches up script variable 
names with datapool column names.

Virtual User Scripts

Manually add datapool commands to the script.
Match up script variable names with datapool 
columns.

GUI Scripts

Create and Populate the Datapool

Datapool Information.

In Robot or TestManager, define datapool columns (including 
assigning a data type to each datapool column).
Generate the data.

Virtual User Scripts

Virtual User and GUI Scripts
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Data Types

A datapool data  type is a source of data for one datapool column.

For example, the N ames - First data type (shipped with Rational Test as a standard 
data type) contains a list of persons’ first names. Suppose you assign this data t
the datapool column FN AME. When Robot automatically generates the datapo
populates the FN AME column with all of the values in the N ames - First data t

Here is the relationship between data types, datapool columns, and the values
assigned to script variables during playback:

Standard and User-Defined Data Types
There are two kinds of datapool data types, as follows: 

ã Standard data  types that are included with Rational Test. These data types
include commonly used, realistic sets of data in categories such as first and
names, company names, cities, and numbers. 

For a list of the standard data types, see Appendix C.

ã U ser-defined data  types that you create. You must create a data type if none
the standard data types contains the kind of values you want to supply to a s
variable.

First Name
Data Type

FNAME
Datapool Column

Virtual User 1 Virtual User 3Virtual User 2
FNAME="Frederick" FNAME="Mary" FNAME="Frank"

Charlotte

Frederick
Mary
Frank

Lauren
Eleanor

William
Victor ..., Frederick, ...

..., Mary, ...

..., Frank, ...

..., Lauren, ...

..., Eleanor, ...

..., Charlotte, ...

..., William, ...

..., Victor, ...

..., ..., ...

D uring datapool genera tion, 
the First N am e data type 
popu lates the FN AM E 
datapool co lum n with va lues

D uring p layback, the FN AM E 
colum n supplies a d if ferent 
va lue to the FN AM E variab le 
in  each instance of the scrip t
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U ser-defined data types are useful in situations such as:

– When a field accepts a limited number of valid values. For example, supp
a datapool column supplies data to a script variable named color. This 
variable provides the server with the color of a product being ordered. If
product only comes in the colors red, green, blue, yellow, and brown, th
are the only values that color can be assigned. N o standard data type 
contains these exact values.

To ensure that the variable is assigned a valid value from the datapool:

1 . Before you create the datapool, create a data type named Colors t
contains the five supported values (Red, Green, Blue, Yellow, 
Brown).

2 . When you create the datapool, assign the Colors data type to the 
datapool column COLOR. The COLOR column will supply values 
the script’s color variable.

– When you need to generate data that contains multi-byte characters, su
are used in some foreign-language character sets. For more information
the section Generating Multi-Byte Characters on page 6-13.

Before you create a datapool, find out which standard data types you can use a
sources of data and which user-defined data types you need to create. Althoug
possible to create a data type while you are creating the datapool itself, the proc
creating a datapool will be smoother if you create the user-defined data types f

Finding Out What Data Types You Need
To decide whether to assign a standard data type or a user-defined data type t
datapool column, you need to know the kinds of values that will be supplied to s
variables during playback — for example, will a variable contain names, dates, o
numbers, and so on.

Here are two ways you can find the kind of values that are supplied to a variab

ã With virtual user scripts, you can view the DATAPOOL_CONFIG section that 
Robot automatically adds to the end of the script. (Robot adds this informa
to a virtual user script when you select U se datapools in the Generator tab of 
the Virtual U ser Record Options dialog box.)

The DATAPOOL_CONFIG section contains a line for each value assigned to 
script variable during recording. In the following example, the value 329781 is 
assigned to the variable CUSTID:

INCLUDE, "CUSTID", "string", "329781"

For more information about the DATAPOOL_CONFIG section of a script, see 
Step 1. Editing Datapool Configuration on page 6-14.
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ã With GU I scripts, you need to search the script for each value that you provided 
to the application during recording. Later, you will replace these literal values with 
variables. During playback, the variables will be supplied values from the datapool.

Finding Values in GUI Scripts
H ere are two examples of literal values in GU I scripts. The values are in bold type:

’Credit Card Type
ComboBox Click, "ObjectIndex=1", "Coords=104,7"
ComboListBox Click, "ObjectIndex=1", "Text=Discover"

’Credit Card Expiration Date
EditBox Left_Drag, "ObjectIndex=4", "Coords=19,13,16,12"
InputKeys "12/31/99"

To make the task of searching for values easier, insert a descriptive comment into the 
script before providing a value to the client application during recording.

Creating User-Defined Data Types
If none of the standard data types can provide the correct kind of values to a script 
variable, create a user-defined data type. 

To create a user-defined data type in TestManager:

1 . Click Tools → M anage D ata  Types.

2 . Click N ew.

3 . Type a name for the data type (40 characters maximum) and optionally, 
a description (255 characters maximum).

4 . Click O K . 

5 . Click Yes when prompted to enter data values now.

The Edit Data Type dialog box appears. This dialog box supports Input Method 
Editor (IME) modes for typing multi-byte characters.

6 . Type in a data type value on the first blank line in the list. 

When you start typing the value, a pencil icon appears, indicating editing mode.

7 . To type a new value, place the insertion point on the blank line next to the 
asterisk icon, and then type the value. 

8 . Repeat steps 6 and 7 until you have added all the values.

9 . Click Save.

N O TE: The only values that Robot records are those that you specifically provide 
during recording. If you accept a default, Robot does not record that value.
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The following figure shows the data type Colors being populated with five values:

When you create a user-defined data type, it is listed in the Type column of the 
Datapool Specification dialog box (where you define datapool columns). Type also 
includes the names of all the standard data types. U ser-defined data types are flagged 
in this list with an asterisk (*).

Generating Unique Values from User-Defined Data Types
You may want a user-defined data type to supply unique values to a script variable 
during playback. To do so, the user-defined data type must contain unique values. 

In addition, when you are defining the datapool in the Datapool Specification dialog 
box, make the following settings for the datapool column associated with the user-
defined data type:

ã Set Sequence to Sequential.

ã Set Repeat to 1.

ã Make sure the N o. of records to generate value does not exceed the number 
of unique values in your user-defined data type.

For information about the values you set in the Datapool Specification dialog box, 
see Defining Datapool Columns on page 6-27.

Type new value hereType new value here.

Slide th is bar 
up or down to 
change row heigh t.

Line cu rrently being edited .

N O TE: You can assign data from a standard data type to a user-defined data type. 
For information, see Editing User-Defined Data Type Definitions on page 6-39.
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Generating Multi-Byte Characters
If you want to include multi-byte characters in your datapool (for example, to 
support Japanese and other languages that include multi-byte characters), you can 
do so in either of these ways:

ã Through a user-defined data type. For information, see the section Creating 
User-Defined Data Types on page 6-11. 

The editor provided for you to supply the user-defined data fully supports Input 
Method Editor (IME) operation. An IME lets you type multi-byte characters, 
such as Kanji and Katakana characters as well as multi-byte ASCII, from a 
standard keyboard. It is included in the Japanese version of Microsoft Windows.

ã Through the Read From File data type. For information, see the section Creating 
a Column of Values Outside Rational Test on page 6-48.

Using Datapools with Virtual User Scripts

Robot can insert datapool commands into a virtual user script automatically. If you 
want Robot to do so, take these steps before you begin to record a virtual user script:

1 . In Robot, click Tools → Virtual U ser Record O ptions.

2 . Click the Generator tab.

3 . Select U se datapools, and then click O K .

4 . Record your transaction(s), and then stop recording.

The datapool commands are included in the script that Robot generates during 
recording. N ext, you create the datapool itself, as described in the following section.

Creating a Datapool with Robot
In Robot, you create a datapool in two basic steps:

1 . Edit the DATAPOOL_CONFIG section of the virtual user script, or accept 
the defaults. (See the next section, Step 1. Editing Datapool Configuration.)

2 . Define datapool columns and generate the data. (See Step 2. Defining Datapool 
Columns and Generating the Data on page 6-19.)

You cannot automatically generate data for a datapool that has more than 
150 columns.

N O TE: DATAPOOL_CONFIG is included only in virtual user scripts. As a result, 
this section is not applicable for GU I scripts, or if you are creating a datapool for 
exclusive use by a GU I script. To create a datapool that is accessed only by GU I 
scripts, see Using Datapools with GUI Scripts on page 6-24.
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Step 1. Editing Datapool Configuration
You begin the process of creating a datapool by editing the DATAPOOL_CONFIG 
statement that Robot automatically generates in a script.

DATAPOOL_CONFIG has two basic purposes:

ã During datapool creation, it specifies the datapool columns for Robot to create, 
if any.

ã During test runtime, it provides information such as the access order of datapool 
rows, and whether script variables should be assigned values from the datapool 
or use the literal values provided during recording.

The best way to edit DATAPOOL_CONFIG is by editing the Robot Configure 
Datapool in Script dialog box rather than by editing the script directly.

To edit datapool configuration and to begin the process of defining and generating 
a datapool:

1 . If the script that will access the datapool is not open for editing, click File → 
O pen → Script to open it.

2 . Click Edit → D atapool Information to open the Configure Datapool in Script 
dialog box.

This dialog box lets you edit the DATAPOOL_CONFIG section of the script.

3 . Either accept the defaults in the Configure Datapool in Script dialog box, or 
make any appropriate changes.

U se the table on page 6-16 to help you modify the settings in this dialog box.

4 . When finished making any changes, click Save.

The DATAPOOL_CONFIG section of the script is updated according to the 
values set in the Configure Datapool in Script dialog box.

N O TE: By default, the U sage column (see page 6-18) contains the value 
EX CLU D E for each script variable listed in the grid. This means that Robot 
does not create a datapool column for these variables when it creates the 
datapool. To have Robot automatically create datapool columns when it 
creates the datapool, change the U sage values to IN CLU D E or O VERRID E.
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e.
5 . Take one of these actions:

– Click Create to define and populate the new datapool.

If the datapool you are trying to create already exists, the Create button does 
not appear in the dialog box. Instead, the Edit Specification button appears, 
allowing you to edit datapool column definitions, and the Edit Existing 
D ata  button appears, allowing you to edit datapool values.

– Click Close if you do not want to define and populate a datapool at this tim

6 . If you clicked Create in the previous step, continue by following the 
instructions in the section Step 2. Defining Datapool Columns and Generating the 
Data on page 6-19.

H ere is how the Configure Datapool in Script dialog box maps to the 
DATAPOOL_CONFIG section of a script:

For more information about the parts of the DATAPOOL_CONFIG section of a 
script, see the description of DATAPOOL_CONFIG in the VU Language Reference.

Because O bey U sage  is selected and the Persisten t  
check box is not checked, no other flag  is used. 

These tab les m atch  row for 
row and colum n for co lum n.

N O TE: Typically, a script has just one DATAPOOL_CONFIG section. If a script 
has multiple DATAPOOL_CONFIG sections (for example, to accommodate a 
script that accesses multiple databases and servers), the Configure Datapool in 
Script dialog box accesses the first one. To edit the others, you must edit the 
script directly.
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M odifying D ATAPO O L_CO N FIG
U se the following table to help you define the fields and columns in the Configure 
Datapool in Script dialog box (see step 3 in the previous instructions):

Field or column Description

D atapool name The name assigned to the datapool. The datapool name defaults to 
the script name. You cannot modify D atapool name.

Wrap at end of file? Sets the action to take after the last row in the access order is reached:

ã Yes – Resume at the beginning of the access order.
ã N o – End access to the datapool.

If you attempt to retrieve a datapool value after the end of the 
datapool is reached, a runtime error occurs.

To ensure that unique datapool rows are fetched, choose N o, and 
make sure the datapool has at least as many rows as the numbe
users (and user iterations) that will be requesting rows at runtim

With an access order of Random , this value is ignored.

Cursor Specifies whether the datapool cursor is shared by all users accessing 
the datapool (Shared) or is unique to each user (Private). Also 
specifies whether a shared cursor is persistent across schedule runs:

ã With a shared cursor, all users work from the same access ord
For example, if the access order for a Colors column is Red, 
Blue, and Green, the first user to request a value is assigned R
the second is assigned Blue, and the third is assigned Green.

ã If you check the Persistent box, the datapool cursor is persistent 
across schedule runs. For example, if you have a persistent 
cursor with Access O rder set to Sequentia l, and datapool row 
number 100 was the last row accessed in the last schedule ru
the first row accessed in the next schedule run is 101.
A persistent cursor resumes row access based on the last time 
cursor was accessed as a persistent cursor. For example, suppose a 
cursor is persistent, and the last row accessed for that cursor in
schedule run is 100. Then, the same schedule is run again, bu
the cursor is now private. Row access ends at 50. If the cursor
set back to persistent the next time the schedule is run, row 
access resumes with row 101, not 51.
With persistent cursors, you can use the Row box to set the row 
to be accessed first in the next test run.
Persistent cursors are only valid with shared cursors, and whe
Access O rder is set to either Sequential or Shuffle.

ã With a private cursor, each user starts at the top of its access 
order. With Random  or Shuffle access, the access order is 
unique for each user and operates independently of the other
With Sequential access, the access order is the same for each 
user (ranging from the first row stored in the file to the last), bu
it operates independently for each user.
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Access O rder Determines the sequence in which datapool rows are accessed:

ã Sequential – Rows are accessed in the order in which they are
physically stored in the datapool file, beginning with the first 
row in the file and ending with the last. 

ã Random  – Rows are accessed in any order, and any given row
can be accessed multiple times or not at all. 

ã Shuffle – Each time LoadTest rearranges, or “shuffles,” the 
access order of all datapool rows, a unique sequence results. Ea
row is referenced in a shuffled sequence only once.

Think of non-sequential access order (Shuffle and Random ) as 
being like a shuffled deck of cards. With Shuffle access order, each 
time you pick a card (access a row), you place the card at the botto
of the pack. With Random  access order, the selected card is 
returned anywhere in the pack — which means that one card mig
be selected multiple times before another is selected once.

Also, with Shuffle, after each card has been selected once, you 
either resume selecting from the top of the same access order 
(W rap at end of file? is Yes), or no more selections are made 
(W rap at end of file? is N o).

With Random , you never reach the end of the pack (there is no 
end-of-file condition, so W rap a t end of file? is ignored).

U se Script D ata Specifies the source of the values that script variables are assigne
during schedule runtime, as follows:

ã Always – Script variables are assigned the values provided durin
recording rather than values from the datapool. Recorded valu
are listed in the Script D ata  column. 
This option overrides the runtime meaning of the INCLUDE 
directive in the U sage column. It also adds the flag OVERRIDE 
to the DATAPOOL_CONFIG section of the script. 

This option provides a convenient way to run the script even i
the datapool file is missing or incomplete.

ã O bey U sage – Script variables associated with the INCLUDE 
directive in the U sage column are assigned datapool values. 
Script variables not associated with the INCLUDE directive are 
assigned values in the Script D ata  column.
N o flag is added to DATAPOOL_CONFIG with this option.

 (Continued) 

Field or column Description
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D atapool Exits this dialog box to let you further define the datapool, and shows 
the next row to be accessed in the row access order, as follows:

ã Create or Edit Specification – Lets you define datapool 
columns in a new or existing datapool, and lets you populate th
datapool with values.

ã Edit Existing D ata  – Lets you edit values in an existing datapool.
ã Row N umber – Shows the datapool row to be accessed first in th

next test run. This box applies only to persistent cursors (the 
Persistent box must be checked). The row number is modifiable
Valid row numbers are 1 through 2,147,483,647 (commas are 
not allowed). If you specify a number that is not in the datapool, 
an error occurs at test runtime.

After you specify a starting row number, click Set Cursor.

Any changes you make in the D atapool group box do not affect the 
DATAPOOL_CONFIG section of the script.

U sage Specifies one of the following directives to apply during database 
creation and during schedule runtime. To change an individual 
directive, right-click the directive name:

ã IN CLU D E
- During datapool creation, creates a column for the script 

variable in N ame. The column is assigned the same name.
- During schedule runtime, assigns a value to the script variable 

in N ame from the corresponding datapool column.
You can override the runtime meaning of all INCLUDE 
directives by selecting Always in the U se Script D ata group 
box. With Always selected, all script variables are assigned the 
associated values in the Script D ata  column.

ã EX CLU D E 
- During datapool creation, does not create a column for the 

script variable in N ame.
- During schedule runtime, assigns the value in Script D ata  to 

the script variable in N ame. Datapool values are not used.

ã O VERRID E 
- During datapool creation, creates a column for the script 

variable in N ame. The column is assigned the same name.
- During schedule runtime, assigns the value in Script D ata  to 

the script variable in N ame. Datapool values are not used.

You can select multiple U sage items using standard Windows 
selection methods (for example, holding down the CO N TRO L key 
while clicking each item to change). When all items are selected, 
right-click on one of them to change them all.

 (Continued) 

Field or column Description
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Step 2. Defining Datapool Columns and Generating the Data
To complete the creation of the datapool that you started in Step 1. Editing Datapool 
Configuration on page 6-14, you define the datapool’s columns and populate it w
data. You do so in the Datapool Specification dialog box.

The Datapool Specification dialog box contains the D atapool Fields grid. Each row 
in the grid represents a datapool field — that is, a column of data in the datapoo

When the dialog box opens, the grid lists a datapool column name and a defau
column definition for each script variable that is assigned the value INCLUDE or 
OVERRIDE in the Configure Datapool in Script dialog box. 

N ame The name of a script variable that is assigned a value during 
recording. If Robot creates a datapool column for this variable (if 
U sage is either INCLUDE or OVERRIDE), the datapool column is 
assigned the same name. 

This value can only be modified in the script.

Type The data type of the value in Script D ata . The data type is 
always string.

This value can only be modified in the script.

Script D ata A value that was provided during recording. The value was assigned 
to the script variable in N ame.

If there is no value in this column for a particular script variable, a 
length of 1 is assigned to the datapool column associated with the 
script variable.

This value can only be modified in the script.

 (Continued) 

Field or column Description

N O TE: If the Datapool Specification dialog box is not open, see Step 1. Editing 
Datapool Configuration on page 6-14 to learn how to open it.
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You define and populate the datapool as follows:

1 . To insert one or more new columns into the datapool file:

a. Click the row located either just before or just after the location where you 
want to insert the new datapool column. (N ote that the order in which 
datapool column names are listed in N ame determines the order in which 
values are stored in a datapool record.)

An arrow appears next to the name of the datapool row you clicked.

b. Click either Insert before or Insert a fter, depending on where you want to 
insert the datapool column.

c. Type a name for the new datapool column (40 characters maximum).

Make sure there is a script variable of the same name listed in the Configure 
Datapool in Script dialog box. The case of the names must match.

2 . For each datapool column in the grid, assign a data type to the column, and 
modify the default property values for the column as appropriate.

For information about the data types and other properties you can define for a 
datapool column, see Defining Datapool Columns on page 6-27.

To see an example of datapool columns defined in the Datapool Specification 
dialog box, see Example of Datapool Column Definition on page 6-30. 

3 . When finished defining datapool columns, type a number in the N o. of records 
to generate field.

If a different row has to be retrieved with each fetch, make sure the datapool has 
at least as many rows as the number of users (and user iterations) that will be 
requesting rows at runtime.

4 . Click Generate D ata .

You cannot generate data for a datapool that has more than 150 columns.

Alternatively, if you do not want to generate any data now, click Save to save 
your datapool column definitions, and then click Close.

5 . Optionally, click Yes to see a brief summary of the generated data.
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If There Are Errors
If the datapool values are not successfully generated, you are prompted to see an 
error report rather than a summary of the generated data. To correct the errors:

1 . Click Yes to see the error report.

2 . After viewing the cause of the errors, click Cancel.

3 . Correct the errors in the D atapool Fields grid.

Viewing Datapool Values
To see the generated values, close the Datapool Specification dialog box. In the 
Configure Datapool in Script dialog box, click Edit Existing D ata .

If a datapool includes complex values (for example, embedded strings, or field 
separator characters included in datapool values), you should view the datapool 
values to make sure the contents of the datapool are as you expect.

Editing Datapool Column Definitions with Robot
To edit datapool column definitions in Robot, you must begin in the Configure 
Datapool in Script dialog box.

This section provides the basic steps for editing datapool column definitions while 
in Robot. For information about the Configure Datapool in Script dialog box, see 
Step 1. Editing Datapool Configuration on page 6-14.

To edit a datapool’s column definitions while in Robot:

1 . If the script that will access the datapool is not open for editing, click File → 
O pen → Script to open it.

2 . Click Edit → D atapool Information to open the Configure Datapool in Scrip
dialog box.

3 . Either accept the defaults in the Configure Datapool in Script dialog box, o
make any appropriate changes. 

U se the table on page 6-16 to help you modify the settings in this dialog bo

4 . When finished making any changes, click Save.

5 . Click Edit Specification to open the Datapool Specification dialog box, wher
you update datapool column definitions.

For information about the data types and other properties you can define f
datapool column, see Defining Datapool Columns on page 6-27.

To see an example of datapool columns defined in the Datapool Specificat
dialog box, see Example of Datapool Column Definition on page 6-30. 
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6 . To insert one or more new columns into the datapool file:

a. Click the row located either just before or just after the location where you 
want to insert the new datapool column. (N ote that the order in which 
datapool column names are listed in N ame determines the order in which 
values are stored in a datapool record.)

An arrow appears next to the name of the datapool row you clicked.

b. Click either Insert before or Insert a fter, depending on where you want to 
insert the datapool column.

c. Type a name for the new datapool column (40 characters maximum).

Make sure there is a script variable of the same name listed in the Configure 
Datapool in Script dialog box. Case of the names must match.

7 . When finished modifying datapool columns, type a number in the N o. of 
records to generate field.

If a different row has to be retrieved with each fetch, make sure the datapool has 
at least as many rows as the number of users (and user iterations) that will be 
requesting rows at runtime.

8 . Click Generate D ata .

You cannot generate data for a datapool that has more than 150 columns.

Alternatively, if you do not want to generate any data now, click Save to save 
your datapool column definitions, and then click Close.

9 . Optionally, click Yes to see a brief summary of the generated data.

If There Are Errors
If the datapool values are not successfully generated, you are prompted to see an 
error report rather than a summary of the generated data. To correct the errors:

1 . Click Yes to see the error report.

2 . After viewing the cause of the errors, click Cancel.

3 . Correct the errors in the D atapool Fields grid.
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Editing Datapool Values with Robot
To edit datapool values in Robot, you must begin in the Configure Datapool in 
Script dialog box.

This section provides the basic steps for editing datapool values while in Robot. 
For information about the Configure Datapool in Script dialog box, see Step 1. 
Editing Datapool Configuration on page 6-14.

To view or edit a datapool’s values while in Robot:

1 . If the script that will access the datapool is not open for editing, click File → 
O pen → Script to open it.

2 . Click Edit → D atapool Information to open the Configure Datapool in Scrip
dialog box.

3 . Either accept the defaults in the Configure Datapool in Script dialog box, o
make any appropriate changes. 

U se the table on page 6-16 to help you modify the settings in this dialog bo

4 . When finished making any changes, click Save.

5 . Click Edit Existing D ata .

6 . In the Edit Datapool dialog box, edit datapool values as appropriate.

For information about editing datapool values, see Editing Datapool Values with 
TestManager on page 6-34.

7 . When finished editing datapool values, click Save, and then click Close.

For an example of the datapool values that TestManager generates, see Example of 
Datapool Value Generation on page 6-32.

Cancelling Your Edits
To abandon all the edits that you made in the Edit Datapool dialog box, clickCancel 
or the ESC key. With either action, all your edits are abandoned, and the Edit 
Datapool dialog box closes.
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Using Datapools with GUI Scripts

A GU I script can access a datapool when it is played back in Robot. Also, when a GU I 
script is played back in a LoadTest schedule, the GU I script can access the same 
datapool as other GU I scripts and/or virtual user scripts.

There are differences in the way GU I scripts and virtual user scripts are set up for 
datapool access:

ã You must add datapool commands to GU I scripts manually while editing the 
script in Robot. Robot adds datapool commands to virtual user scripts 
automatically.

ã There is no DATAPOOL_CONFIG statement in a GU I script. The command 
SQADatapoolOpen defines the access method to use for the datapool.

Although there are differences in setting up datapool access in GU I scripts and 
virtual user scripts, you define a datapool for either type of script using TestManager 
in exactly the same way.

H ere are the general tasks involved in providing access to a datapool from a GU I 
script. The steps are not in a fixed order — you can create the datapool at any 

ã Record the GU I script.

ã Add datapool commands to the script.

ã Create the datapool.

For information about recording a GU I script for datapool access and adding 
datapool commands to a GU I script, see the datapools chapter in the Using Rational 
Robot manual.

For information about creating a datapool with TestManager, see Creating a Datapool 
with TestManager on page 6-25.

Accessing a Datapool from GUI and Virtual User Scripts
If a GU I script and a virtual user script provide the same set of values to the cli
application during recording, the scripts can access the same datapool during 
playback in a LoadTest schedule.

Here is the suggested order of steps for creating a datapool and setting up acce
from GU I scripts and virtual user scripts:

1 . Record the virtual user procedure and create the datapool as described in Using 
Datapools with Virtual User Scripts on page 6-13.

2 . Record the GU I script.

3 . Edit the GU I script and add datapool commands to it. 
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For information about recording GU I scripts and adding datapool commands to 
GU I scripts, see the Using Rational Robot manual.

If you want to ensure that GU I users and virtual users each retrieve a unique row of 
data from the datapool, follow the guidelines listed in Generating and Retrieving Unique 
Datapool Rows on page 6-42.

Managing Datapools with TestManager

You manage datapools in the TestManager Manage Datapools dialog box:

The activities you perform in this dialog box affect datapools stored in the repository. 
For information about where datapools are stored, see Datapool Location on page 6-36.

Creating a Datapool with TestManager
To create and automatically populate a datapool with TestManager:

1 . Click Tools → M anage D atapools.

2 . Click N ew.

3 . Type a name for the datapool (40 characters maximum) and optionally, 
a description (255 characters maximum).

4 . Click O K .

5 . Click Yes to acknowledge that you want to define the datapool now. 

The Datapool Specification dialog box appears. This dialog box lets you define 
the columns in the datapool file. Datapool column definitions are listed as rows 
in this dialog box. Datapool columns are also called fields.

6 . Click Insert before or Insert after to add a datapool column to the datapool.
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7 . Type a name for the new datapool column (40 characters maximum).

With virtual user scripts, datapool column names must match the names of the 
script variables that they supply values to. N ames are case-sensitive.

8 . Assign a data type to the datapool column, and define any other properties as 
necessary.

For information about the properties you can define for a datapool column, see 
Defining Datapool Columns on page 6-27.

9 . Repeat steps 6 through 8 until you have defined all the columns in the datapool.

To see an example of datapool columns defined in the Datapool Specification 
dialog box, see Example of Datapool Column Definition on page 6-30. 

1 0 . Type a number in N o. of records to generate.

Alternatively, if you do not want to generate any data now, click Save to save 
your datapool column definitions, and then click Close.

1 1 . When finished defining datapool columns, click Generate D ata .

You cannot generate data for a datapool that has more than 150 columns.

1 2 . Optionally, click Yes to see a brief summary of the generated data.

If There Are Errors
If the datapool values are not successfully generated, you are prompted to see an 
error report rather than a summary of the generated data. To correct the errors:

1 . Click Yes to see the error report.

2 . After viewing the cause of the errors, click Cancel.

3 . Correct the errors in the D atapool Fields grid.

Viewing Datapool Values
To see the generated values, close the Datapool Specification dialog box. In the 
Manage Datapools dialog box, select the datapool you just created, click Edit, and 
then click Edit D atapool D ata .

If a datapool includes complex values (for example, embedded strings, or field 
separator characters included in datapool values), you should view the datapool 
values to make sure the contents of the datapool are as you expect.
6 -2 6



M anaging D atapools with  TestM anager
Making the Datapool Available to a Script
For a script to be able to access the datapool you create with TestManager, the script 
must contain datapool commands, such as commands for opening the datapool and 
fetching values. Virtual user scripts must also contain DATAPOOL_CONFIG.

You can add datapool commands and DATAPOOL_CONFIG to a script either before 
or after you create the datapool with TestManager:

ã For information about automatically adding datapool commands and 
DATAPOOL_CONFIG to a virtual user script during recording, see Using 
Datapools with Virtual User Scripts on page 6-13.

ã For information about adding datapool commands to a GU I script, see Using 
Datapools with GUI Scripts on page 6-24.

Defining Datapool Columns
U se the following table to help you define datapool columns in the Datapool 
Specification dialog box:

Grid column Description

N ame The name of a datapool column (and its corresponding script variable).

If you change the name of a datapool column, be sure the new name 
matches all instances of its corresponding script variable.

If you create a datapool outside of the Rational Test environment and 
then import it, TestManager automatically assigns default names to the 
datapool columns. U se N ame to match the imported datapool column 
names with their corresponding script variables. N ames are case-sensitive.

You can use an IME to type multi-byte characters in datapool field names. 

(With GU I scripts, you can associate datapool column names and script 
variables through column position rather than column name. For more 
information, see the description of the SQADatapoolValue command 
in the SQABasic Language Reference.)
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Type The standard or user-defined data type that supplies values to the datapool 
column in N ame. U ser-defined data types are marked with an asterisk 
(*).

Specify the data type to assign to the datapool column, as follows:

ã To select a standard data type or an existing user-defined data type, 
click the currently displayed data type name, and then select the new 
data type from the drop-down list:

See Appendix C for a description of the standard data types.
If you type rather than select the name of a user-defined data type, 
enter an asterisk before the user-defined data type name. For example, 
to specify the user-defined data type MyData, type:

*MyData

ã To create a new user-defined data type, enter the data type name 
(without the asterisk) in the field, and then press RETU RN . After you 
click Yes to confirm that you want to create a user-defined data type, 
the Data Type Properties - Edit dialog box appears.
For information about creating a data type, see Creating User-Defined 
Data Types on page 6-11.

Sequence The order in which the values in the data type specified in Type are 
written to the datapool column. Select one of these options from the 
drop-down list:

ã Random  – Writes numeric and alphanumeric values to the datapool
column in any order.

ã Sequentia l – Writes numeric values sequentially (for example, 0, 1, 
2...). With decimal numbers, the sequence is based on the lowest 
possible decimal increment (for example, with a D ecimals value of 2, 
the sequential values are 0.00, 0.01, 0.02, ...).
Sequentia l is only supported for numeric values (including date and
time values) and values generated from user-defined data types.
When you select Sequential with numeric data types, and you specif
M inimum  and M aximum  range, Interval must be greater than 0.

ã U nique – With data type Integers - Signed, ensures that numbers 
written to the datapool column are unique. Also, set Repeat to 1, 
and define a M inimum  and M aximum  range.

Do not confuse the Random  and Sequential settings in this grid with 
Random  and Sequential access order in the Configure Datapool in Script 
dialog box.The Random  and Sequential settings in this grid determine the 
order in which values are written to an individual datapool column at 
datapool creation time. Random  and Sequential access order determine 
the order in which users access datapool rows at schedule runtime.

 (Continued) 

Grid column Description
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Repeat The number of times a given value can appear in a datapool column. 
Repeat cannot be set to 0.

To make values unique with Integers - Signed data types and user-defined 
data types, set Repeat to 1. For unique Integers - Signed values, also set 
Sequence to either Sequential or U nique.

When defining unique values, make sure the number of rows you are 
generating is not higher than the range of possible unique values.

Length The maximum number of characters that a value in the datapool column 
can have. If the datapool column contains numeric values, Length 
specifies the maximum number of characters a number can have, including 
a decimal point and minus sign, if any. 

For example, for decimal numbers as high as 999.99, set Length to 6. 
For decimal numbers as low as -999.99, set Length to 7.

Length cannot be 0.

D ecimals Specifies the maximum number of decimal places that floating point 
values can have. Maximum setting is 6 decimal places.

Interval Writes a sequence of numeric values to the datapool column. The 
sequence increments by the Interval you set. For example, if Interval is 10, 
the datapool column contains 0, 10, 20, and so on. If Interval is 10 and 
Decimal is 2, the datapool column contains 0.00, 0.10, 0.20, and so on. 

Minimum interval is 1. Maximum interval is 999999.

With numeric data types (including dates and times), when Sequence is 
set to Sequential and you specify a M inimum  and M aximum  range, 
Interval must be greater than 0.

U se Interva l only with numeric values (including dates and times).

M inimum Specifies the lowest in a range of numeric values. For example, if the 
datapool column supplies order number values, and the lowest possible 
order number is 10000, set Type to Integer - Signed, M inimum  to 10000, 
and M aximum  to the highest possible order number.

U se M inimum  only with numeric values (including dates and times).

M aximum Specifies the highest in a range of numeric values. For example, if the 
datapool column supplies values to a variable named ounces, set Type to 
Integer - Signed, M inimum  to 0, and M aximum  to 16.

U se M aximum  only with numeric values (including dates and times).

 (Continued) 

Grid column Description
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Some items might not be modifiable, depending on the data type you select. For 
example, if you select the N ames - First data type, you cannot modify D ecimals, 
Interval, M inim um , or M aximum .

If you are generating unique values for an Integers - Signed data type, Length, 
M inim um , M axim um , and N o. of records to generate must be consistent. For 
example, if you want unique numbers from 0 through 999, errors may result if you 
set Length to 1, M aximum  to 5000, and/or N o. of records to generate to a number 
greater than 1000.

Example of Datapool Column Definition
Suppose you want to record a transaction in which a customer purchase is entered 
into a database. During recording, you supply the client application with the 
following information about the customer:

ã Customer name

ã Customer ID

ã Credit card number

ã Credit card type

ã Credit card expiration date

Seed The number that Rational Test uses to compute random values. 
The same seed number always results in the same random sequence. 
To change the random sequence, change the seed number.

When Type is String Constant, use Seed to provide the alphanumeric 
value of the constant. For example, if you want to insert the constant 
“Rational Software” into every row of a datapool column, set Type to 
String Constant and type Rational Software into Seed.

D ata File The path to the user-defined data type file. The path is automatically 
inserted for you. This field is not modifiable.

Data type files are stored in the Datatype directory of your project. You
never have to modify these files directly.

 (Continued) 

Grid column Description

N O T E: You can use an IME to type multi-byte characters into the N ame column 
only. The IME is automatically disabled when you are editing any other column. 
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After you record the script, you are ready to create the datapool. Following the 
instructions on page 6-25, you define the datapool’s columns in the Datapool 
Specification dialog box, as illustrated below:

N ote the following datapool column definition highlights:

ã fN am e column. The standard data type N ames - First supplies this datapo
column with masculine and feminine first names.

ã lN am e column. The standard data type N ames - Last supplies this datapo
column with surnames.

ã custID  column. The standard data type Integer - Signed supplies ID numbe
this datapool column. Because all customer IDs in this example consist of s
digits, the M inimum  and M aximum  range is set from 1000000 through 999999
Also, because all IDs must be unique, Sequence is set to U nique.

ã ccN um  column. The Integer - Signed data type generates numbers up to n
digits. Because credit card numbers contain more than nine digits, the stan
data type Float X.XXX is used to supply credit card numbers to this datapo
column. D ecimals is set to 0 so that only whole numbers are generated. 
Sequence is set to Random to generate random card numbers. To genera
unique numbers, Repeat is set to 1.

Generate 1 00 0  
datapool rows

The only user-defined  
data type needed

D ate range

Floa t data type with  0  
decim als is used for 
credit  card num bers 
requiring  1 6  d ig its

Custom er ID  is unique

D atapool 
co lum n 1

N O TE: Sequence can only be set to U nique for Integer - Signed data types
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ã ccType column. This is the only datapool column that needs to have values 
supplied from a user-defined data type. The user-defined data type Credit Card 
Type contains just four values — American Express, Discover, MasterCard
and Visa.

ã ccExpD ate column. The standard data type Date - MM/DD/YYYY supplies 
credit card expiration dates to this datapool column. The range of valid 
expiration dates is set from July 1, 1998 through December 31, 2002. Sequence 
is set to Random to generate random dates. 

Example of Datapool Value Generation
After you define datapool columns in the Datapool Specification dialog box, clic
Generate D ata  to generate the datapool values. To see the values you generat

1 . Click Close.

2 . Click Edit D atapool D ata .

This is what you see:

Editing Datapool Column Definitions with TestManager
To edit the definitions of the columns in an existing datapool with TestManage

1 . Click Tools → M anage D atapools.

2 . Select the datapool to edit, and then click Edit.

3 . Click D efine D atapool Fields. 

D rag th is vert ica l bar to  
change colum n wid th .
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The Datapool Specification dialog box appears. This dialog box lets you define 
the columns in the datapool file. Datapool column definitions are listed as rows 
in this dialog box. Datapool columns are also called fields.

4 . Edit one or more datapool column definitions, as described in the table in 
Defining Datapool Columns on page 6-27.

5 . When finished editing datapool column definitions, take either of these actions:

– To save the datapool column definitions but not generate any data, cli
Save, and then click Close.

– To save the datapool column definitions and generate data, type a num
in the N o. of records to generate field, and then click Generate D ata . 
Optionally, click Yes to see a brief summary of the generated data.

If There Are Errors
If the datapool values are not successfully generated, you are prompted to see
error report rather than a summary of the generated data. To correct the error

1 . Click Yes to see the error report.

2 . After viewing the cause of the errors, click Cancel.

3 . Correct the errors in the D atapool Fields grid.

Deleting a Datapool Column
Datapool column definitions are listed as rows in the Datapool Specification 
dialog box.

To delete a datapool column definition from the list:

1 . Click anywhere in the row to be deleted.

2 . Click the gray box to the left of the datapool column name. This action sele
the entire row.

3 . Press the DELETE key.

You are not prompted to confirm the deletion.

N O TE: To see the generated values, close the Datapool Specification dialog bo
In the Datapool Properties - Edit dialog box, click Edit D atapool D ata .
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Editing Datapool Values with TestManager
To view or edit the values in an existing datapool with the TestManager editor:

1 . Click Tools → M anage D atapools.

2 . Select the datapool to edit, and then click Edit.

3 . Click Edit D atapool D ata  in the Datapool Properties - Edit dialog box.

The Edit Datapool dialog box appears.

4 . Modify the datapool values as necessary. N ote that:

– When you click a value to edit it, an arrow icon appears to the left of the 
you are editing.

– When you begin to edit the value, a pencil icon appears to the left of the 
indicating editing mode.

– To undo the changes you just made to a value, press CTRL +  Z before you 
move the insertion point out of the field.

– To see the editing menu, select the text to edit, and then right-click th
mouse.

– To increase the width of a column, move the bar that separates colum
names. To increase the height of a row, move the bar that separates r

5 . To delete an entire datapool row:

a. Click the gray box to the left of the first value in the row you are deletin
This action selects the entire row.

b. Press the DELETE key.

6 . When finished modifying datapool values, click Save, and then click Close.

For an example of the datapool values that TestManager generates, see Example of 
Datapool Value Generation on page 6-32.

Cancelling Your Ed its
To abandon all the edits that you made in the Edit Datapool dialog box, clickCancel 
or the ESC key. With either action, all your edits are abandoned, and the Edit 
Datapool dialog box closes.

Slide up or down to 
change row heigh t.

Slide left or right to  
change colum n width .
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Renaming a Datapool
To rename a datapool:

1 . In TestManager, click Tools → M anage D atapools.

2 . Click the name of the datapool to rename.

3 . Click Rename.

4 . Type the datapool’s new name (40 characters maximum).

5 . Click O K, and then click Close.

Copying a Datapool
To copy a datapool:

1 . In TestManager, click Tools → M anage D atapools.

2 . Click the name of the datapool to copy.

3 . Click Copy.

4 . Type a name for the new datapool (40 characters maximum).

5 . Click O K, and then click Close.

Deleting a Datapool
To delete a datapool:

1 . In TestManager, click Tools → M anage D atapools.

2 . Click the name of the datapool to delete.

3 . Click D elete.

4 . Click Yes to confirm the deletion, and then click Close.

Deleting a datapool removes the datapool .csv and .spc files plus all references 
datapool from the repository.

Importing a Datapool
Robot automatically creates and populates datapools for you. However, it is 
possible for you to create and populate a datapool yourself, using a tool such a
Microsoft Excel. For example, you might want to export data from your database
a .csv file, and use that file as your datapool.

If you create a datapool yourself, you need to import it into the same repository
as the scripts that will access it. U se TestManager to import a datapool .csv file
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To import a datapool .csv file using TestManager:

1 . Click Tools → M anage D atapools.

2 . Click Import.

3 . In Look in, specify the directory where the datapool you created is located.

4 . In File nam e, specify the name of the datapool .csv file.

5 . Click O pen. The Datapool Properties - Import dialog box appears, containing 
the datapool name.

6 . Accept the default datapool name or type a new one (40 characters maximum).

7 . In Field Separator, make sure the character(s) displayed are the same as the field 
separator used in the .csv file you are importing as a datapool.

For information about field separators in datapools, see Datapool Structure on 
page 6-45.

8 . Optionally, type a description of the datapool (255 characters maximum).

9 . Click O K , and then click Close.

When you import a datapool, you often have to change the names of the datapool 
columns to match the names of the corresponding script variables. For more 
information, see Matching Datapool Columns with Script Variables on page 6-48.

Datapool Location
When you import a datapool, TestManager copies the datapool’s .csv file to the
Datapool directory associated with the current repository and project.

For example, if the current repository is MyRepo, and the current project direc
is MyProject, the datapool is stored in the following directory:

C:\MyRepo\Project\MyProject\Datapool

This directory also includes the datapool’s specification (.spc) file. When you cr
and then import a .csv file, TestManager automatically creates the .spc file for y
You should never edit the .spc file directly. 

N O TE: After you import a datapool, the original file you used to populate the 
datapool remains in the directory you specified when you saved it. The Ration
Test software has no further need for this file. 
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Importing a Datapool from Another Project
U se the TestManager Import feature to copy a datapool you created for one project 
into another. When you import a datapool into a new project, the source datapool is 
still available to the original project.

To import a datapool into a new project:

1 . Run TestManager. (By default, click Start → Program s → Rat iona l p roduct  
nam e → Rational Test 7  → TestM anager.)

2 . In the Rational Repository Login dialog box, select the repository and project 
that you are importing the datapool to.

3 . Click File → Import Test Assets. The Import Test Assets wizard appears.

4 . Select D atapool in the Asset Type list.

5 . Click the appropriate overwrite option. This option determines whether to 
overwrite an existing datapool with the same name as the one you are importing.

6 . Click N ext.

7 . In the Login dialog box, provide the path, project name, and your login 
information for the repository that contains the datapool you are importing.

If you are importing between projects in the same repository, you do not need 
to provide a user ID and password.

8 . Click N ext.

9 . Select one or more datapools to import. (To select multiple datapools, hold 
down the CTRL key while clicking each datapool to import.)

1 0 . Click N ext.

1 1 . Click Finish after reading the information summarizing the import operation.

Exporting a Datapool
U se the TestManager Export feature to copy a datapool to any directory on your 
computer’s directory structure. When you export a datapool, the original datap
remains in its repository and project.

Do not attempt to export a datapool to another Rational Test project. Instead, us
import feature to import the datapool into the new project. For more informatio
see Importing a Datapool on page 6-35.

N O TE: If the datapool you are importing includes user-defined data types, 
import the data types before you import the datapool. For information, see 
Importing a User-Defined Data Type on page 6-41.
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To export a datapool to a location on your computer’s directory structure:

1 . In TestManager, click Tools → M anage D atapools.

2 . Click the datapool to export.

3 . Click Export.

4 . In Save In, specify the directory where you want to copy the datapool.

5 . Click Save.

6 . Click O K to acknowledge that the datapool was exported to the correct loca

Managing User-Defined Data Types

U se TestManager to manage user-defined data types. You can edit data type 
values and data type definitions. You can also rename, copy, and delete data ty

For information about creating user-defined data types, see Data Types on page 6-9.

Editing User-Defined Data Type Values
If you want to add, remove or modify data type values, or if you just want to mod
the optional description, edit the data type.

You can only edit user-defined data types, not standard data types.

To edit a user-defined data type in TestManager:

1 . Click Tools → M anage D ata  Types.

2 . Select the data type to edit, and then click Edit.

3 . Optionally, modify the data type description.

4 . Click Edit D ata Type D ata . A dialog box appears with the name of the data ty
you are editing.

5 . The arrow icon points to the line that is currently available for editing. Edit th
line, or place the insertion point in another line.

You can use the keyboard’s up and down arrow keys to move the line poin

6 . To see the editing menu, select the text to edit, and then right-click the mo

7 . To delete a value, place the insertion point anywhere in the value, click the 
box to the left of the value, and then press the DELETE key.

8 . When finished making changes, click Save.

9 . Click O K in the Data Type Properties - Edit dialog box, and then close the 
Manage Data Types dialog box.
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Editing User-Defined Data Type Definitions
Like all data types, a user-defined data type is essentially a one-column datapool. The 
single column contains the values that you type into the user-defined data type.

You can edit the default definition of the data type column in the Datapool 
Specification dialog box, just as you edit the default definition of datapool columns. 

If you edit the definition of a user-defined data type, and then generate values for the 
data type, you overwrite any existing values for the data type.

How To Edit User-Defined Data Type Definitions
To edit the definition of a user-defined data type in TestManager:

1 . Click Tools → M anage D ata  Types.

2 . Select the data type to edit, and then click Edit.

3 . Click D efine D ata  Type Field.

The Datapool Specification dialog box appears. N ote that the Insert Before and 
Insert After buttons are not present. That is because a user-defined data type file 
can have only one column of values.

4 . Define the fields in the data type. U se the table in Defining Datapool Columns on 
page 6-27 to help you.

5 . When finished defining the data type, click Generate D ata .

Optionally, click Yes to see a brief summary of the generated data.

6 . Click Close in the Datapool Specification dialog box, and then click Edit D ata  
Type D ata .

7 . Make any necessary modifications to the generated values.

8 . When finished modifying values, click Save.

9 . Click O K  in the Data Type Properties - Edit dialog box, and then close the 
Manage Data Types dialog box.

Automatically Generating Values for a User-Defined Data Type
You can add values to a user-defined data type by supplying it with values from a 
standard data type. Doing so can reduce the typing that you need to perform when 
adding values to the user-defined data type.

For example, suppose you want to create a user-defined data type containing a list 
of valid product IDs. The valid ID numbers range from 1000001 through 1000100. 
H owever, there is a dash between the fourth and fifth digits (such as 1000-001). 
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Rather than type in all 100 numbers, with dashes, you can have TestManager 
generate the numbers and assign them to a user-defined data type. All you then have 
to do is edit the data type values and add the dash to each ID. The following steps 
guide you through the process:

1 . In TestManager, click Tools → M anage D ata  Types.

2 . Click N ew.

3 . Type a name for your user-defined data type (for example, Item ID).

4 . Click O K .

5 . Click N o when prompted to enter data type values now.

6 . Click the name of your new data type, and then click Edit .

7 . Click D efine D ata  Type Field.

8 . Set the following column values in the grid (or accept the defaults):

– Type =  Integers - Signed

– Sequence =  Sequential

– Repeat =  1

– Length =  7

– Interval =  1

– M inim um  =  1000001

– M axim um  =  1000100

9 . Type 100 in N o. of records to generate.

1 0 . Click Generate D ata .

1 1 . Click N o to decline to see data generation details, and then click Close.

1 2 . Click Edit D ata  Type D ata  in the Data Type Properties dialog box.

1 3 . Type a dash character between the fourth and fifth characters of each value.

N O TE: You can also assign the standard data type Read From File to a user-
defined data type. For information about using the Read From File data type, 
seeCreating a Column of Values Outside Rational Test on page 6-48.
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Importing a User-Defined Data Type
You can import a user-defined data type from one project into another. When you 
import a user-defined data type into a new project, the source data type is still 
available to the original project.

To import a user-defined data type into a new project:

1 . Run TestManager. (By default, click Start → Program s → Rat iona l p roduct  
nam e → Rational Test 7  → TestM anager.)

2 . In the Rational Repository Login dialog box, select the repository and project 
that you are importing the user-defined data type to.

3 . Click File → Import Test Assets. The Import Test Assets wizard appears.

4 . Select D ata type in the Asset Type list.

5 . Click the appropriate overwrite option. This option determines whether to 
overwrite an existing datapool with the same name as the one you are importing.

6 . Click N ext.

7 . In the Login dialog box, provide the path, project name, and your login 
information for the repository that contains the data type you are importing.

If you are importing between projects in the same repository, you do not need 
to provide a user ID and password.

8 . Click N ext.

9 . Select one or more data types to import. (To select multiple data types, hold 
down the CTRL key while clicking each data type to import.)

1 0 . Click N ext.

1 1 . Click Finish after reading the information summarizing the import operation.

Renaming a User-Defined Data Type
To rename a user-defined data type in TestManager:

1 . Click Tools → M anage D ata  Types.

2 . Click the name of the data type to rename.

3 . Click Rename.

4 . Type the data type’s new name (40 characters maximum).

5 . Click O K, and then click Close.
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Copying a User-Defined Data Type
To copy a user-defined data type in TestManager:

1 . Click Tools → M anage D ata  Types.

2 . Click the name of the data type to copy.

3 . Click Copy.

4 . Type the name of the new data type (40 characters maximum).

5 . Click O K , and then click Close.

Deleting a User-Defined Data Type
To delete a user-defined data type in TestManager:

1 . Click Tools → M anage D ata  Types.

2 . Click the name of the data type to delete.

3 . Click D elete.

4 . Click Yes to confirm the deletion, and then click Close.

Generating and Retrieving Unique Datapool Rows

Many database tests work best when each row of test data is unique. For example, 
if a test involves virtual users adding customer orders to a database, each new order 
has to be unique — in other words, at least one field in the new record has to 
“key” field containing unique data.

When you are defining datapool columns in the Datapool Specification dialog b
you specify whether a given datapool column should contain unique data. If yo
specify that one or more columns should contain unique data, the datapool tha
Rational Test software generates is guaranteed to contain unique rows.

However, even when a datapool contains all unique rows, it is possible for dupl
rows to be supplied to a script at test runtime. 

To generate and retrieve unique datapool rows, you need to perform a few sim
tasks when you define the datapool.

U se the following guidelines whether the datapool is being accessed by a single 
or by multiple scripts, including both virtual user and GU I scripts.
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What You Can Do to Guarantee Unique Row Retrieval
To ensure that a datapool supplies only unique rows to scripts at runtime, follow 
these guidelines:

What to do How to do it

Specify at least 
one column of 
unique data.

In the Datapool Specification dialog box, specify that at least one 
datapool column should contain unique data. U nique data can be 
supplied through the Integers - Signed data type, through the Read 
From File data type, and through user-defined data types.

With the Integers - Signed data type, take all of these actions:

ã Set Sequence to U nique or Sequential.
ã Set Repeat to 1.
ã If Sequence= U nique, set an appropriate range in M inimum  and 

M aximum . 
ã Make sure the values of Length and N o. of records to generate are 

appropriate for the set of numbers to generate.

With the Read From File data type, see Generating Unique Values on page 
6-50 for information.

With user-defined data types, see Generating Unique Values from User-
Defined Data Types on page 6-12 for information.

Generate enough 
datapool rows.

Generate at least as many unique datapool rows as the number of times 
the datapool will be accessed during a test. 

For example, if 50 users will access a datapool during a test, and each user 
is set for 3 iterations each, the datapool must contain at least 150 rows.

You specify the number of rows to generate in the N o. of records to 
generate field of the Datapool Specification dialog box.

Disable cursor 
wrapping.

If the datapool cursor wraps after the last row in the datapool has been 
accessed, previously fetched rows are fetched again.

Disable cursor wrapping in any of these ways:

ã When editing the DATAPOOL_CONFIG section of a virtual user 
script in the Configure Datapool in Script dialog box, set Wrap at 
end of file? to N o.

ã When editing a virtual user script in Robot, add DP_NOWRAP to the 
list of flags in the flags argument of the DATAPOOL_CONFIG 
statement or the datapool_open function.

ã When editing a GU I script in Robot, set the wrap argument of the 
SQADatapoolOpen command to False.
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Creating a Datapool Outside Rational Test

To create a datapool file and populate it with data, you can use any text editor, such 
as Windows N otepad, or any application, such as Microsoft Excel or Microsoft 
Access, that can save data in .csv format.

For example, you can create a datapool file and type in the data, row by row and value 
by value. O r, you can export data from your database into a .csv file that you create 
with a tool such as Excel.

After you create and populate a datapool, use TestManager to import the datapool 
into the repository. For information about importing a datapool, see Importing a 
Datapool on page 6-35.

U se sequential or 
shuffle access 
order. 

With sequential or shuffle access, each datapool row is referenced in the 
row access order just once. When the last row is retrieved, the datapool 
cursor either wraps or datapool access ends.

With random access, rows can be referenced in the access order multiple 
times. So, a given row can be retrieved multiple times.

Set row access order in any of these ways:

ã When editing the DATAPOOL_CONFIG section of a virtual user 
script in the Configure Datapool in Script dialog box, set Access 
O rder to Sequentia l or Shuffle.

ã When editing a virtual user script in Robot, add DP_SEQUENTIAL 
or DP_SHUFFLE to the list of flags in the flags argument of the 
DATAPOOL_CONFIG statement or the datapool_open function.

ã When editing a GU I script in Robot, set the sequence argument of 
the SQADatapoolOpen command to SQA_DP_SEQUENTIAL or 
SQA_DP_SHUFFLE.

Do not rewind 
the cursor during 
a test.

If you rewind the datapool cursor during a test (through the VU  
datapool_rewind function or the SQABasic SQADatapoolRewind 
command), previously accessed rows will be fetched again.

N O TE: Rational Test can only guarantee that a datapool contains unique rows 
when you generate datapool data through Robot or TestManager.

 (Continued) 
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Datapool Structure
A datapool is stored in a text file with a .csv extension. The file has these 
characteristics:

ã Each row contains one record.

ã Each record contains datapool field values delimited by a field separator. Any 
character can be used for the field separator. Some common field separators are:

– Comma ( , ). This is typically the default in the U S and the U K.

– Semi-colon ( ; ). This is typically the default in most other countries.

– Colon ( : ).

– Pipe ( |  ).

– Slash ( / ).

The field separator can consist of up to three single-byte ASCII characters or
multi-byte character.

ã Each column in a datapool file contains a list of datapool field values. 

ã Field values can contain spaces.

ã A single value can contain a separator character if the value is enclosed in do
quotes. For example, “Jones, Robert” is a single value in a record, not two.

The quotes are used only when the value is stored in the datapool file. Th
quotes are not part of the value that is supplied to your application.

ã A single value can contain embedded strings. For example, “Jones, Robert
“Bob”” is a single value in a record, not two.

ã Each record ends with a line feed. 

ã Datapool column names are stored in a .spc file. (Robot and TestManager
the .spc file. N ever edit the .spc file directly.)

ã The datapool name that is stored in the repository is the same as the root 
datapool file name (without the .csv extension). The maximum length of a 
datapool name is 40 characters.

N O TE: To view or change the field separator, click Start → Settings → 
Control Panel, double-click the Regional Settings icon, and then click the 
N um ber tab. List separator contains the separator character(s). 
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Example Datapool
This is an example of a datapool file with three rows of data. In this example, field 
values are separated by commas:

John,Sullivan,238 Tuckerman St,Andover,MA,01810
Peter,Hahn,512 Lewiston Rd,Malden,MA,02148
Sally,Sutherland,8 Upper Woodland Highway,Revere,MA,02151

Example Using Microsoft Excel
To create and populate a datapool using Microsoft Excel:

1 . Run Microsoft Excel.

2 . Click File → N ew to create a new Excel workbook.

3 . Click the W orkbook icon, and then click O K .

4 . Type a datapool record into row 1. To do so, type each value in the record into 
separate columns, beginning with column A.

When using Microsoft Excel to populate a datapool, do not separate values with 
the Windows separator character (see page 6-45). Excel automatically inserts the 
separator character when you save the datapool in .csv format.

5 . Continue populating the datapool by typing records into the subsequent rows.

H ere is an example of how a datapool might look as it is being populated with data 
in Microsoft Excel:

N ote that:

ã Each column represents a datapool field.

ã Each row is an individual datapool record containing datapool field values.
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Saving the Datapool in Excel
When you finish adding rows of values to the datapool, save the datapool to .csv 
format. To do so using Microsoft Excel:

1 . Click File → Save As.

2 . In the Save in field, specify the directory where you want to save the datapool.

Do not specify the Datapool directory in the repository. When you later 
import the datapool using the TestManager Import feature, TestManager 
automatically copies the datapool to the Datapool directory in the current 
repository and project.

3 . In the File name field, type the datapool name (maximum 40 characters). This 
is the name that the script and the repository use to identify the datapool.

4 . In the Save as type list, select the entry CSV (Comma delim ited) (* .csv).

5 . Click Save.

If you are prompted that the .csv file format does not support multiple 
workbook sheets, click O K  to save the datapool and abandon the other (empty) 
worksheets.

U pon closing Excel, if you are prompted to decide whether to save the .csv file 
in Microsoft Excel format, click N o.

If you use Windows N otepad to open the datapool file you just created and saved, 
this is how it looks:
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Matching Datapool Columns with Script Variables
When you create a .csv file and then import it as a datapool, TestManager 
automatically assigns column names (that is, datapool field names) to each 
datapool column. 

Datapool column names must match the names of the script variables that they 
supply with data (including a case match). But most likely, when you create and 
import a datapool, the column names that TestManager assigns will not match the 
names of the associated script variables. As a result, you need to edit the column 
names that TestManager automatically assigns during the import. You do so by 
modifying a column’s N ame value in the Datapool Specification dialog box.

For information about how to open the Datapool Specification dialog box durin
datapool editing, see Editing Datapool Column Definitions with TestManager on page 
6-32.

Maximum Number of Imported Columns
You can import a datapool that contains up to 32,768 columns. If you open an 
imported datapool in the Datapool Specification dialog box, you can view and ed
datapool column definitions up to that limit. 

A datapool is subject to a 150-column limit only if you generate data for the data
from the Datapool Specification dialog box. 

Creating a Column of Values Outside Rational Test

A datapool that you create with Rational Test can include a column of values 
supplied by an ASCII text file. You could use this feature, for example, if you wa
the datapool to include a column of values from a database.

Populating a datapool column with values from an external file requires two 
basic steps:

1 . Create the file containing the values.

2 . Assign the values in the file to a datapool column through the standard data
Read From File.

N O TE: With GU I scripts, you can associate datapool column names and scrip
variables through column position rather than column name. For more 
information, see the description of the SQADatapoolValue command in the 
SQABasic Language Reference.
6 -4 8



Creating  a  Co lum n o f Va lues O utside Rational Test

 of 

e, you 

mn 

in the 
Step 1. Create the File
To use a file as a source of values for a datapool column, the file must be a standard 
ASCII text file. The file must contain a single column of values, with each value 
terminated by a carriage return.

You can create this text file any way you like — for example, you can use either
these methods:

ã Type the list of values in Microsoft N otepad.

ã Export a column of values from a database to a text file.

Step 2. Assign the File’s Values to the Datapool Column
Once the file of values exists, you assign the values to a datapool column just as you 
assign any set of values to a datapool column — through a data type. In this cas
assign the values through the Read From File data type. To do so:

1 . Open the Datapool Specification dialog box:

– To open this dialog box during datapool creation, see Creating a Datapool 
with TestManager on page 6-25.

– To open this dialog box during datapool editing, see Editing Datapool Column 
Definitions with TestManager on page 6-32.

2 . In the Type column, select the data type Read From File for the datapool colu
being supplied the values from the external text file.

3 . Tab out of the column. The Open dialog box appears.

4 . In Look in, specify the directory where the text file you created is located.

5 . In File nam e, specify the name of the text file.

6 . Click O pen. 

You can use the Read From File data type to assign values to multiple columns 
same datapool.
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Generating Unique Values
You can use the Read From File data type to generate unique values to a datapool 
column you create outside Rational Test.

To generate unique values through the Read From File data type, the file that the 
data type accesses must contain unique values. 

In addition, when you are defining the datapool in the Datapool Specification dialog 
box, make the following settings for the datapool column associated with the Read 
From File data type:

ã Set Sequence to Sequential.

ã Set Repeat to 1.

ã Make sure the N o. of records to generate value does not exceed the number 
of unique values you are accessing through the Read From File data type.

For information about the values you set in the Datapool Specification dialog box, 
see Defining Datapool Columns on page 6-27.
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Designing Schedules
This chapter describes how to design schedules. It includes the following topics:

ã About schedules

ã Creating a schedule

ã Inserting user groups into a schedule

ã Inserting scripts into a schedule

ã Inserting other items into a schedule

ã Opening a schedule

ã Editing a script

ã Editing a schedule

ã U sing events and to coordinate execution

ã Setting shared variables 

ã Saving a schedule

ã Printing and exporting a schedule

ã Checking a schedule

ã Checking Agent computers

ã Controlling runtime information of a schedule

ã Controlling how a schedule terminates

ã Running a schedule
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About Schedules

A schedule shows a hierarchical representation of the workload that you want to run. 
It shows such items as the user groups, the number of users in each user group, 
which scripts the user groups run, and how many times each script runs. 

Through a schedule, you can:

ã Run virtual user scripts and GU I scripts.

ã Group scripts to emulate the actions of different types of users.

ã Set the order in which scripts run.

ã Synchronize users.

The following simple schedule shows three user groups: Accounting, Data Entry, 
and Sales.

In this schedule:

ã The Accounting user group runs two scripts: one calculates payroll hours and 
one calculates payroll taxes. 

ã The Data Entry user group runs five scripts: one logs in, one initializes database 
options, and three change database records. 

ã The Sales user group runs three scripts: one logs in, one initializes database 
options, and one reads database records.
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The examples in this chapter show virtual user scripts. A schedule, however, can 
contain GU I scripts, or a mixture of GU I and virtual user scripts. 

Creating a Schedule

A schedule enables you to not only run scripts, but, more importantly, to emulate 
the actions of users adding load on a system. A schedule can be as simple as one 
virtual user executing one script, or as complex as hundreds of virtual users in 
different groups, with each group executing different scripts at different times.

Creating a Schedule from a Blank Schedule
To create a schedule from a blank schedule:

1 . Click File → N ew → Schedule.

2 . Click Blank Schedule.

3 . Click O K . 
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A schedule appears, which contains a U ser Groups icon and a Scenarios icon.

The following sections explain how to insert user groups, scripts, and other items 
into a schedule so you can run it.

Creating a Schedule from a Session
If you have recorded a session in Robot, you can play back the scripts in the session 
through LoadTest.

When you add a session to a schedule and then run the schedule, you execute all of 
the client/server requests that you recorded during the session in the order in which 
you recorded them.

Adding a session to a schedule saves you from having to add individual scripts to the 
schedule. For example, suppose you record the scripts Connect, Query, and 
Disconnect in a recording session named DBQuery. To run the scripts in a 
schedule, you can either add each script to the schedule in the order in which you 
recorded them, or you can simply add the session DBQuery.

To create a schedule directly from a Robot session:

1 . Click File → N ew → Schedule. The N ew Schedule dialog box appears.

2 . Select Existing Session, and click O K .

3 . LoadTest displays a list of sessions that you have recorded. Click the name of a 
session, and click O K . 

LoadTest automatically creates a schedule that is ready to run.

N O TE: You can also create a schedule using a wizard. For more information, 
see Schedules, creating, in the LoadTest H elp index.
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Inserting User Groups into a Schedule

A user group is the basic building block for all schedules. A user group is a collection 
of users that perform the same activity. For example, the schedule on page 7-2 
contains three user groups: Accounting, Data Entry, and Sales.

To insert a user group into a schedule:

1 . Click Insert → U ser Group.

2 . Type the name of the user group in the N ame box. Although you can use the 
default name, it is better to use a name that describes the user group.

N O TE: The name of a user group cannot be identical to the name of a 
shared variable, a script, or the following reserved words: MASTER, ALL, 
ASSIGN, TO, THRU, END, UNION, DELAY, delay, shared, SHARED, SYC, 
DLB_FREQ, DLB_TIME, or PERMUTE.
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3 . Decide whether the group will contain a fixed or scalable number of users. 

– Fixed – Specifies a fixed number of users. Enter the maximum numbe
users you want to be able to run. For example, if you enter 5 0  users, you 
can run up to 50 users in the Sales group each time you run a schedu

Typically, you assign a fixed number of users to user groups that do not
a workload. For example, one user could run a warmup script to open a 
database for the users, and another user could run a shutdown script to 
restore and close the database. 

– Scalable – Specifies a scalable number of users. Type the percentage o
workload that the user group represents. For example, the Accounting
group might represent 20 percent of the users, the Data Entry group m
represent 30 percent of the users, and the Sales group might represen
percent of the users. Each time you run a schedule, you specify the to
number of users that will run. 

4 . Select the computer where the user group will run. The default computer is
LoadTest Master. To run a user group on an Agent computer, select its nam
the Computers box.

Typically, you run the user group on an Agent computer if:

– A functional test is designed for a particular computer. 

– A performance test requires specific client libraries, or a functional test
requires specific software. The user group must run on the computer 
has the libraries or software installed.

5 . To distribute the users in a user group among multiple computers, click th
M ultiple com puters button. 

N O TE: Copy any custom-created external C libraries necessary for the tes
to the Agent computer.
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Typically, you run a user group on multiple computers if you have:

– A functional test that must execute as quickly as possible. You can save 
by running your users simultaneously on different computers.

– A large number of virtual users, and the Master computer does not ha
enough CPU  or memory resources to support this workload. You can
conserve resources by running the users on different computers so th
fewer users run on each computer.

The top section of the Multiple Computers dialog box displays the comput
that are in the repository.

To run a user group on a computer that is not in the repository, simply typ
name or IP address in the N ame or IP Address box, and then click Add to List. 
LoadTest adds the computer to the list, but not to the repository.
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If you assign more than one computer to a user group, the users are distributed 
according to the W eight that you set for the computer. If one computer can 
handle more users, you should give it a higher weight than the other computers. 
For example, if AgentOne can handle twice as many users as the other 
computers, you may want to give it a weight of 2, and assign the others a weight 
of 1.

If you do not assign a weight, the users are distributed evenly in round-robin 
fashion. The first user runs on the first computer on the list, the second user 
runs on the second computer, and so on.

Click the M ove U p and M ove D own buttons to change the order in which the 
computers become available to run users. If you have many computers and 
many users, the order of the computers is unimportant. H owever, if you are 
running only a few users, you might want one user to start on a specific 
computer. For example, if your schedule contained only one user, the user 
would run on the top computer in the list.

Click the D elete button to remove a computer from the list. When you are 
satisfied with the order of the computers, click O K .

6 . In the U ser Group dialog box, click O K . The user group appears in the schedule.

Inserting Scripts into a Schedule

After you insert user groups into a schedule, you add the scripts that the user groups 
run. The schedule on page 7-2 shows the scripts that each user group runs. The 
Accounting group runs two scripts, the Data Entry group runs five scripts, and the 
Sales group runs three scripts.

N O TE: U ser groups can contain either virtual user or GU I scripts. You cannot 
mix two kinds of scripts within one user group.
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To insert a script into a schedule:

1 . Open the schedule, and select the user group that will run the script. For 
example, the Sales user group might run a script that reads a record.

2 . Click Insert → Script . The Script dialog box appears, which lists the scripts in 
the repository:

3 . Select the script from the Select section of the window, or type the name of the 
script in the Script name box.

N O TE: If you type the name of a script that is not in the repository, LoadTest 
adds the name to the repository. H owever, the script file itself is empty, and 
you must record it before you run the schedule.
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4 . To make the script set an event, type the name of the event in the Event  box. For 
information about events, see Using Events and Dependencies to Coordinate 
Execution on page 7-52.

5 . To run the script more than once, set the number of times you want to repeat it 
in the Iterations box.

6 . If you set multiple iterations of the script and you want to delay between each 
execution of the script, enter the delay time in the D elay between iterations 
box.

7 . Typically, a script runs immediately after the preceding item in the schedule 
completes. To customize when the script runs, select one of the following 
options from the Scheduling m ethod list: 

– After D elay of...

– After D ependencies...

– After Start of Schedule

8 . To create a dependency on another item in the schedule, type the name of the 
event in the D ependencies box. For information about dependencies, see Using 
Events and Dependencies to Coordinate Execution on page 7-52.

9 . Click O K .

Inserting Other Items into a Schedule

A schedule requires only user groups and scripts to run. H owever, a schedule that 
realistically models the work that actual users perform is likely to contain more than 
user groups and scripts. It might also contain scenarios, selectors, delays, and 
synchronization points. 

Inserting a Scenario
A scenario lets you group scripts together so they can be shared by more than one 
user group. If you have a complicated schedule that uses many scripts, grouping the 
scripts under a scenario has the added advantage of making your schedule easier to 
read and maintain. 

N O TE: Another way to set iterations and delays between iterations is to 
insert a sequential selector, a delay, and a script directly into a schedule. The 
advantage of this method is that the selector and the delay are visible in the 
schedule. The advantage of adding iterations and a delay between iterations 
when you insert a script is that less space is taken up in the schedule.
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You define a scenario in the Scenarios section of the schedule by inserting a scenario 
and then inserting items within it. To make a user group execute a scenario, you 
insert the scenario name in a user group. O therwise, the scenario is not executed. 

In the schedule on page 7-2, both the Data Entry and the Sales user groups run the 
scripts Login and Initialize Options. You can simplify this schedule by 
storing both scripts in a scenario. The following schedule shows the scripts Login 
and Initialize Options grouped under the Set U p Database Application 
scenario:

To insert a scenario into a schedule:

1 . Click the Scenarios section in the schedule.

2 . Click Insert → Scenario. 

3 . Type a name in the N ame box. You can use the default name, but it is better to 
supply a name that describes the scenario.
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4 . Click O K . The name of the scenario appears in the Scenarios section of the 
schedule.

5 . Click the user group that will run the scenario.

6 . Click Insert → Scenario. The Scenario dialog box appears:

7 . Type the name of the scenario in the N ame box.

8 . To run the scenario more than once, set the number of times you want to repeat 
it in the I terations box.

9 . To make the scenario set an event, type the name of the event in the Event box. 
For details about events, see Using Events and Dependencies to Coordinate Execution 
on page 7-52.

After you have created the scenario and the user group that runs the scenario, it is a 
good idea to populate the scenario. A scenario requires only scripts to run. However, 
like a user group, a realistic scenario may also contain selectors, delays, and 
synchronization points. A scenario can even contain other scenarios.

Inserting an Executable
An executable is a program, such as N otepad or Excel, that runs on Windows N T. 
You can insert an executable into a GU I user group only. When you run the 
schedule, the executable runs as well.

To insert an executable into a schedule:

1 . Click Insert → Executable. 
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2 . Type a name in the Executable nam e box. To see a list of executables, click the 
Browse button.

3 . To make the executable set an event, type the name of the event in the Event  box. 
For information about events, see Using Events and Dependencies to Coordinate 
Execution on page 7-52.

4 . Select the W ait for com pletion check box to if you want the executable to finish 
running before the next item in the schedule begins running. Clear this box if 
you want the schedule to run the next item before the executable finishes 
running.

5 . N ormally, an executable runs immediately after the preceding item in the 
schedule completes. To customize when the executable runs, select an option 
from the Scheduling m ethod list: 

– After D elay of...

– After D ependencies...

– After Start of Schedule

6 . To create a dependency on another item in the schedule, type the name of the 
dependency in the D ependencies box. For information about dependencies, see 
Using Events and Dependencies to Coordinate Execution on page 7-52.

7 . Click O K .

Setting Schedule Items to Run in Different Sequences
A selector provides more sophisticated control than running a simple sequence of 
consecutive items in a schedule. A selector tells LoadTest which items each user will 
execute, and in what sequence. For example, you might want to repeatedly select a 
script at random from a group of scripts.
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Consider the following schedule, which does not contain any selectors: 

When you run the schedule with 50 virtual users, LoadTest assigns 10 users to 
Accounting, 15 users to Data Entry, and 25 users to Sales. All 50 users start executing 
scripts at the same time. 

ã The 10 Accounting users run each script in the order in which the script appears 
in the schedule: first Calculate Hours and then Calculate Taxes. 

ã The 15 Data Entry users run the Set U p Database Application scenario and then 
run the Add New Record, Modify Record, and Delete Record 
scripts in the order in which the scripts appear in the schedule. 

ã The 25 Sales users run the Set U p Database Application scenario and then run 
the Read Record script.

H owever, suppose your Data Entry users actually add records, delete records, and 
modify records randomly. Furthermore, they do not perform these tasks with the 
same frequency. For every record they delete, they modify seven records and add 
two records. 

To make your user group reflect this behavior, insert a Random selector into the 
Data Entry user group. The following schedule shows the Data Entry user group, 
which selects scripts randomly without replacement.
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When you run the schedule with 50 virtual users, LoadTest assigns 10 users to 
Accounting, 15 users to Data Entry, and 25 users to Sales. Each Data Entry user: 

ã Runs the Set U p Database Application scenario. 

ã Picks one script per iteration: Add New Record, Modify Record, or 
Delete Record. Since there are 100 iterations, each Data Entry user adds a 
record 20 times, modifies a record 70 times, and deletes a record 10 times. The 
adding, modifying, and deleting are done in any order.

Types of Selectors
LoadTest provides the following types of selectors:

ã Sequentia l – Runs each script or scenario in the order in which it appears in
schedule. This is the default.

ã N ext available – Distributes its scripts or scenarios to an available user (one u
per computer). Typically, you use this selector in a GU I user group. The ite
are parceled out in order, based on which users are available to run anoth
script. Once an item runs, it does not run again. 

A next available selector distributes each script without regard to its iteratio
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In the following schedule, the Testing user group has two users (and therefore 
two computers) assigned to it. The schedule runs three GU I scripts under a next 
available selector. 

When you run this schedule:

– The excel script runs on the first computer for 100 iterations.

– The notepad script runs on the second computer for one iteration.

– The test dialog box script runs on the next available computer (mo
likely the second computer, because its script had only one iteration), a
runs for two iterations.

ã Random  with replacement – The selector runs the items under it in random
order, and each time an item is selected, the odds of it being selected agai
remain the same. Think, for example, of a bucket that contains 10 red balls
10 green balls. You have a 50% chance of picking a red ball and a 50% chan
picking a green ball. The first ball selected is red. The ball is then replaced in
bucket. Every time you pick a ball, you have a 50% chance of getting a red 

Since the ball is replaced after each selection, the bucket always contains 1
and 10 green balls. It is even possible (but unlikely) that you pick a red ball e
time—you never pick a green ball. Similarly, the Random  with replacem ent 
selector is not guaranteed to run every item in it, particularly if you have set 
script to run more frequently than another. In other words, if your bucket 
contains 19 red balls and one green ball, the green ball might not be select
all.

ã Random  without replacement – The selector runs the items under it in 
random order, but each time an item is selected, the odds change. For exa
think of the same bucket that contains 10 red balls and 10 green balls. Again
first ball selected is red. However, the ball is not replaced in the bucket. 
Therefore, the next time you have a slightly greater chance of picking a gre
ball. Each time you select a ball, your odds change.
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And, of course, if the first 10 balls selected are red, the odds of the next 10 balls 
being green are 100 percent. Similarly, the Random without replacement  
selector will run every item in it, as long as the number of iterations of the 
selector is greater than or equal to the number of items in the selector. 

ã D ynam ic load balancing – With dynamic load balancing, items are not selecte
randomly. Think again of the bucket that contains red and green balls, and
assume that you have assigned an equal “weight” to each ball. Therefore, i
first ball selected is red, the second ball selected is always green. This is be
with each ball, or script, selected, the system “dynamically balances” the 
workload to approach the 50-50 weight that you set. O f course, you can set o
weights that are not 50-50. The important fact to remember, however, is tha
next script to run is not selected randomly; it is selected to balance the work
according to the weight that you have set.

You can balance the workload either for time or for frequency. For example
assume you are dynamically balancing scripta and scriptb, and using 
equal weights. Scripta, however, takes twice as long to run as scriptb.

If you check D ynam ic load balancing for tim e, the load is balanced by the 
runtime of each script. Because scripta takes twice as long to run, it is actually
selected only half as often as scriptb.

If you check D ynam ic load balancing for frequency, both scripts will run an 
equal number of times. If scripta runs 500 times, scriptb also runs 500 
times. The fact that scripta takes longer to run is not factored into the 
balance.

Dynamic load balancing is done across all users in a user group. For exam
the following schedule shows the Data Entry user group, which contains 1
users. Three scripts, Add New Record, Modify Record, and Delete 
Record, are contained in a dynamic load balancing selector.
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When you run the schedule, the first Data Entry user selects the Modify 
Record script, because it has the largest weight. But because the workload is 
balanced across all Data Entry users, after the first user exits, LoadTest 
recalculates the weights to reflect the fact that the script with the largest weight, 
7, has already been selected. By the time later users are ready to select a script, 
the weights have changed so they have a greater chance of selecting the Add 
New Record script.

Inserting a Selector
To insert a selector into a schedule:

1 . Click the user group or a scenario that will contain the selector. For example, to 
add a selector to the scripts in a user group, click that user group.

2 . Click Insert → Selector.
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3 . Select the type of selector you want to add. 

4 . The Selector dialog box differs slightly, depending on the type of selector that 
you add and whether it is within another selector.

– For a sequential selector, enter the number of times you want the sele
to repeat in the N umber to repeat box. 

– For a random or dynamic selector, type the number of iterations in the
N um ber to Select box.

If you are inserting a selector within another random or dynamic load balancin
selector, enter the weight of the selector in the W eight box.

5 . To make the selector set an event, type the event in the Event box. For 
information about events, see Using Events and Dependencies to Coordinate 
Execution on page 7-52.

6 . Click O K. LoadTest displays the selector in your schedule.

Inserting a Delay
A delay tells LoadTest how long to pause before it runs the next item in the sche

In functional testing, you use delays to cause scripts to wait before executing. F
example, if one user updates a record, you can insert a delay to give the applic
under-test time to display the correct information. By providing a delay, you ca
ensure that the application-under-test has enough time to complete displaying
information, in case another user must work with the information displayed.

In performance testing, you use delays to model user behavior. For example, if
Accounting user group calculates the hours and taxes, and then pauses for tw
minutes, you would add a delay after the Calculate Taxes script, as shown in 
the following schedule.
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You can insert a delay into a schedule or a script.

ã Into a  schedule – The advantages of inserting a delay into a schedule are th
the delay is visible in the schedule and the delay is easy to change without ed
the script.

ã Into a  script – The method that you use to insert a delay into a script depe
on whether the script is a virtual user script or a GU I script. 

You insert a delay into a virtual user script by editing the script to include a 
delay() library routine or by modifying the think time VU  environment 
variables. U se this method to make the delay before script execution differ
each time. For more information about the delay() library routine and the 
think time environment variables, see the VU Language Reference.

You insert a delay into a GU I script when you record the script. For more 
information, see the Using Rational Robot manual.

To insert a delay into a schedule:

1 . Click the user group, scenario, or selector that you want to add a delay to.

2 . Click Insert → D elay. 

3 . Select a delay:

– Specified number of seconds – Begin counting the delay when the 
previous item finishes executing. Enter the number of seconds to dela
the D elay box. 

– From  start of schedule – Begin counting the delay from the time the 
schedule begins executing. Enter the number of seconds to delay in th
D elay box. 

– U ntil a  particular tim e of day – Delay until the time of day you specify. If
you select this, the D elay box changes to a time-of-day spin box. Set the
time of day in that box.
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4 . Enter how long to delay in the D elay box. 

5 . To make the delay set an event, type the event in the Event box. For information 
about events, see Using Events and Dependencies to Coordinate Execution on page 
7-52.

6 . Click O K .

Setting Schedule Items to Run at Certain Rates
A transactor tells LoadTest the number of user-defined tasks that each user will run 
in a given time period. For example, you might be testing an O rder Entry group that 
completes 10 forms per hour. Or you might be testing a Web server, and you want 
the server to be able to support 100 hits per minute. To model this time-based 
behavior, you use a transactor.

In the previous section, you added a delay to the Accounting user group. This delay 
made the virtual users pause for two minutes after they calculated the hours and 
taxes, as shown in the schedule on page 7-19.

H owever, suppose that the Accounting group instead calculates the hours and the 
taxes at a certain rate—say, 10 calculations per hour. To make your schedule r
this rate, you need to replace the selector and delay with a transactor. The follo
schedule shows the Accounting user group after you have added a transactor:

N O TE: The default delay is 5 seconds. To change this default, click Tools → 
O ptions, click the Create Schedule tab, and enter a delay in the D elay 
O ptions section.
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This schedule is identical to the one on page 7-19, except that it contains:

ã A transactor, which tells LoadTest the rate that you want to maintain, and how 
long you want to maintain this rate.

ã A scenario, which contains the items that the transactor will run.

The following section explains how to insert a transactor and set its options to reflect 
the rate that you want to maintain.

Inserting a Transactor
To insert a transactor into a schedule:

1 . Click the user group or selector that will contain the transactor.

2 . Click Insert → T ransactor.

N O TE: This example shows how to insert a transactor in a user group. 
H owever, you can also insert an independent transactor in a sequential or 
random selector, which will affect the number of times LoadTest runs the 
transactor. For information about selectors, see Types of Selectors on page 7-15.
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3 . Select the name of the transactor that you want to add. The default name is 
Transactorn , but it is a good idea to make the transactor name similar to the 
scenario that it will run. 

4 . U nder Type, select whether you want a coordinated or an independent 
transactor. 

– A Coordinated transactor, which has a built-in synchronization point, le
you specify the total rate that you want to achieve. The virtual users wo
together to generate the workload. For example, if you run a schedule 
10 users and then run the same schedule with 20 users, the total transa
rate will stay the same. 

U se a coordinated transactor when you are emulating the total transac
rate applied to a server, rather than the rate of specific times a user run
task. For example, to emulate the number of hits per minute that a We
server can handle, use a coordinated transactor.

– An Independent transactor lets each user operate independently. It doe
not coordinate the users under it with a built-in synchronization point. F
example, if you run a schedule with 10 users and then run the same 
schedule with 20 users, the total transaction rate will double—because
number of users have doubled. 

U se an independent transactor if different user groups will run the 
transaction at different times, or you are emulating user behavior rathe
than group behavior. For example, to emulate an Accounting user grou
that performs 10 calculations per hour but not all at the same time, use
independent transactor.

5 . U nder Rate, select the rate of the transactor.

– For a coordinated transactor, you generally select Tota l ra te. This is 
because whether 100 users or 50 users are participating, it has no effe
the rate that LoadTest submits transactions. 

Select U ser rate for a coordinated transactor, however, if you expect to 
change the rate frequently and want the convenience of not having to 
the schedule. For example, suppose you have inserted a coordinated 
transactor, and you want to compare a workload at 100 hits per minute,
hits per minute, and 300 hits per minute—increasing the workload with
each schedule run. If you select U ser rate, you do not have to change the
rate in the transactor’s properties. Instead, when you run the schedule
can run the schedule at 100 users, 200 users, and 300 users, and the ra
scale proportionally. 
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– For an independent transactor, you must select U ser rate. Because each 
transactor operates independently, U ser rate is meaningful only with this 
type of transactor.

6 . Enter the D istribution. Although each distribution will approach the rate you
have chosen (if you run the transactions over a long enough period of time)
negative exponential distribution most closely emulates typical user behavi

– A Constant distribution means that each transaction occurs exactly at t
rate you specify. For example, if your rate is four per minute, a transact
will start at 15 seconds, 30 seconds, 45 seconds, and 60 seconds—exa
four per minute, evenly spaced, with a 15-second interval. Although th
distribution is simple conceptually, it does not accurately emulate the 
randomness of user behavior. 

U se a Constant distribution to emulate an automated process. For exam
you might want to emulate an environment where users are uploading 
to a database every half hour. 

– A U niform  distribution means that over time, the transactions will avera
out to the rate you specify, although the time between each transaction
not be constant. The time between the start of each transaction will be
chosen randomly with a uniform distribution within the range that you 
select. Think of this range as a “window” through within the transaction c
run. 

For example, assume that your rate is 4 per minute (that is, 1 transactio
15-second interval). If you select a range of 20%, your transaction will h
a 3-second window on each side, because 20% of 15 seconds is 3 seco

Therefore, the first transaction will start at 12 -18 seconds (15 plus or mi
3). The second transaction will start 15 seconds plus or minus 3 secon
after the first transaction starts. So, for example, if the first transaction 
started at 12 seconds, the second transaction would start at 24 to 30 sec
However, if the first transaction started at 18 seconds, the second 
transaction would start at 30 to 36 seconds. 

Because each transaction starts randomly within the range that you specify, it
is normal for transactions to run at a rate that is faster or slower than the
that you selected for short periods of time. For example, if a transaction
started every 12 seconds for a minute (recall that the window is 12-18 
seconds), the rate for that interval would be 5 per minute—not the 4 p
minute that you selected. Over time, however, the transaction rate will
average out to 4 per minute.
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With a U niform distribution, a transaction has the same probability of 
running within the range that you specify. The transaction will start 
anywhere within this window. In our example, the probability of the first 
transaction starting at 12 seconds, 18 seconds—or anywhere in betwe
is equal.

– A N egative Exponentia l distribution, in contrast, changes the probability of 
when a transaction will start. This distribution most closely emulates th
“burstiness” of typical user behavior. U sing the same example of 4 
transactions per minute, the probability that a transaction will start 
immediately is high, but decreases over time, so that the desired averag
is maintained.

Imagine that you have called a meeting at two o’clock. Most people arriv
two, a few people arrive at five minutes past two, and fewer still at ten p
two. Perhaps the last straggler arrives at two-thirty. This arrival time 
approximates a negative exponential distribution. Most people arrive o
time, and then the arrival rate will decline. Mathematically speaking, th
interval is chosen randomly from a negative exponential distribution wi
the average interval =  1/rate.

7 . At I terations, enter the number of times that you want the transaction to ru
For example, you might want the transaction to run five times. 

8 . Enter the name of the Scenario that the transactor will run. It is a good idea t
make the scenario name similar to the name of the transactor.

9 . To make the transactor set an event, type the event in the Event box. For 
information about events, see Using Events and Dependencies to Coordinate 
Execution on page 7-52.

1 0 . If you are inserting an independent transactor within a random selector, enter the
weight of the selector in the W eight box.

1 1 . Click O K. LoadTest displays the transactor in your schedule.

Inserting a Synchronization Point
A synchronization point lets you coordinate the activities of a number of users b
pausing the execution of each user at a particular point (the synchronization p
until one of the following events occurs:

ã All users associated with the synchronization point arrive at the synchroniza
point.

ã A timeout period is reached before all users arrive at the synchronization p

ã You manually release the users while monitoring a schedule.
7 -2 5



D esigning  Schedu les

our 

o 
 time 
irtual 

n 

n all 
When one user encounters a synchronization point, the user stops and waits for 
other users to arrive. When the set number of users reach the synchronization point, 
LoadTest releases the users and allows them to continue executing. 

For example, assume that you are running a stress test, which is an attempt to run 
your applications under extreme conditions to see if they or the server “break.” Y
schedule might contain virtual users that perform the certain operations 
continuously and repeatedly for hours on end. To run a stress test, you need t
synchronize your virtual users so that they perform the operations at the same
to stress the system. You insert a synchronization point to synchronize these v
users.

The following schedule shows a stress test:

The users in the Accounting user group immediately wait at the synchronizatio
point. The users in the Data Entry and Sales user groups perform the Set U p 
Database Application scenario and then wait at the synchronization point. Whe
the users reach the synchronization point, they are released. 
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If you run the test with 10,000 virtual users, when all the users reach the stress test 
synchronization point, they are released:

ã Each of the 2000 users in the Accounting group calculates the hours and taxes, 
pauses for two minutes, and then calculates the hours and taxes again. Each user 
repeats this 100 times.

ã Each of the 3000 users in the Data Entry group adds, deletes, or modifies a 
record. Each user repeats this 100 times.

ã Each of the 5000 users in the Sales group reads a record. Each user repeats this 
200 times.

To insert a synchronization point into a schedule:

1 . Click Insert → Synchronization Point. 

2 . Type the name of the synchronization point in the N ame box.

3 . To release all users at once from a synchronization point, click Together. The 
default restart time is 0, which means that when the last user reaches the 
synchronization point, all users are released immediately. 

To delay the users, enter a number in the Restart time box. For example, if you 
set the Restart t im e to 4 seconds, after the users all reach the synchronization 
point (or the timeout occurs), they wait 4 seconds, and then they are all released.

4 . To release the users one by one from a synchronization point, click Staggered.
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The amount of time that each user waits to be released is chosen at random and 
is uniformly distributed within the range that you set in the M inimum time and 
M axim um  tim e boxes. For example, if the M inimum time is 1 second and the 
M axim um  tim e is 4 seconds, after the users reach the synchronization point (or 
the timeout occurs) each user waits between 1 and 4 seconds before being 
released. All users are distributed randomly between 1 and 4 seconds. 

5 . In the T im eout box, enter the timeout period for this synchronization point. If 
all the users associated with a synchronization point do not reach the 
synchronization point when the timeout period ends, LoadTest releases any 
users waiting there. The timeout period begins when the first user arrives at the 
synchronization point.

Although a user who reaches a synchronization point after a timeout is not held, 
the user is delayed at that synchronization point. So, for example, if the timeout 
period is reached, and the Restart time is 1 second and the M aximum time is 4 
seconds, a user is delayed between 1 and 4 seconds.

The default Tim eout  is 0, which means that there is no timeout. Setting a 
timeout is useful, because one virtual user might encounter a problem, and 
might never reach the synchronization point. You do not want to hold up other 
virtual users because of a problem with one user.

6 . Click O K .

Opening a Schedule

To work with an existing schedule, you must open it. You can open a schedule from 
a menu or from the Asset Browser.

To open a schedule from a menu:

1 . Click File → O pen → Schedule. The Open Schedule dialog box appears, 
which lists your schedules.
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2 . Select a schedule.

3 . Click O K .

To open a schedule using the Asset Browser:

1 . Click View → Asset Browser.

2 . U nder Schedules, double-click the schedule, or select O pen from its shortcut 
menu.

Editing a Script

While you are working with schedule, you may want to want to edit a script. 
Through LoadTest, you can:

ã Edit the properties of a script.

ã Edit the text of a script.
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Editing the Properties of a Script
A script can have properties associated with it in addition to the script name. 
Examples of script properties include a description of the script and the purpose of 
the script. 

Defining script properties is an important part of the test planning process. For that 
reason, you typically define a script’s properties in TestManager before you rec
the script. But you can edit the script’s properties after you record the script.

To edit the properties of a script:

1 . Click the script whose properties you want to edit.

2 . Click Edit → Script Properties.

3 . Click the tab that you want to edit.

4 . Edit the script’s properties, and then click O K.

For information about the properties you can define, see the section on custom
scripts and LoadTest schedules in the Using Rational Robot manual.

N O TE: The Related Assets tab pertains to GU I scripts, and the VU  
Com pilation tab pertains to VU  scripts.
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Editing the Text of a Script
To edit the text of a script:

1 . Click the script whose text you want to edit.

2 . Click Edit → O pen Script. Robot appears, ready to edit the script you have 
selected:

3 . To edit the script, use Robot’s Edit menu commands.

4 . When you have finished editing the script, click File → Close.

Editing a Schedule

While you are working with a schedule, you might want to want to rearrange cer
items. For example, you might move a script from one user group into another
group or gather a few scripts together into a scenario. You might also want to ch
the properties of an item. For example, you might change a user group from F
to Scalable, or change the number of users in a user group. The following sect
tell you how to do these tasks.
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Editing the Properties of a Schedule
A schedule can have properties associated with it. Examples of schedule properties 
include a description of the schedule and the owner of the schedule. 

Defining schedule properties is an important part of the test planning process. For 
that reason, you typically define a schedule’s properties in TestManager before
design the actual schedule. But you can also edit the schedule’s properties wit
LoadTest.

To edit the properties of a schedule:

1 . Click File → O pen → Schedule, and open the schedule whose properties yo
want to edit.

2 . Click File → Properties. 

3 . Click the tab that you want to edit. 

4 . Edit the schedule’s properties, and then click O K.

For information about the properties you can define, see the section on custom
scripts and LoadTest schedules in the Using Rational Robot manual.
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Cutting and Pasting Items
To cut and paste an item in a schedule:

1 . Click the item. To select more than one item, hold down the CTRL key while 
clicking.

2 . Click Edit → Cut.

3 . Click where you want to paste the item. You can paste the item in the same 
schedule or in another schedule.

4 . Click Edit → Paste.

LoadTest does not let you paste any item that would create an incorrect schedule. 
For example, if you copy the Accountants user group and then paste it into another 
portion of the schedule, LoadTest renames the pasted group Accountants1. This is 
because you cannot have two user groups with the same name in one schedule. 

Similarly, if you copy a GU I and virtual user script and then paste both scripts into 
a virtual user group, LoadTest pastes only the virtual user script. This is because a 
user group cannot mix GU I and virtual user scripts.

Deleting Items
To delete an item in a schedule:

1 . Click the item. To select more than one item, hold down the CTRL key while 
clicking.

2 . Click Edit → D elete.

All items, except for scripts and executables, are completely deleted. Scripts are 
deleted from the schedule but remain in the repository, so you can reuse them. 
Executables are deleted from the schedule but remain on your system.

For information about deleting scripts, see the Using Rational Robot manual.

Replacing Items
You can use in-line editing to replace any item in a schedule except delays and 
selectors. Replacing an item —especially an item high in the schedule structur
is often easier than deleting the item and adding another one. For example, yo
schedule may contain a complex structure of user groups, scripts, and scenari
Rather than having to delete an item and recreate the schedule structure under
you can replace the item.
7 -3 3



D esigning  Schedu les
To replace an item in a schedule:

1 . Click Tools → O ptions → Create Schedule, and clear the Show num eric 
va lues check box. You must turn this option off to replace an item.

2 . Open the schedule that contains the item you want to replace.

3 . Click the item, wait a few seconds, and click it again.

4 . Type the name of the new item. If the item is a script, it must already be in 
the repository.

Editing Items
To edit the properties of an individual item in a schedule, select that item and click 
Edit → Properties. LoadTest displays the same dialog box that appeared when you 
created the item. You can edit the values in each box.

For example, to edit the properties of a user group:

1 . Click the user group.

2 . Click Edit → Properties. 

3 . To change the name of the user group, type a new name in the N ame box.
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4 . To change whether the user count is fixed or scalable, click the appropriate 
choice under M ake user count .

5 . To change the maximum number of users emulated by the user group, or to 
change the percentage of the load the user group should emulate, select a 
different number in the N umber or Percentage box.

6 . To change which computer this user group is runs on, select a new computer 
from the Computers list.

7 . If you are running the schedule on multiple computers and want to change the 
order of computers, click the M ultiple computers button. The Multiple 
Computers dialog box appears.

Click the M ove U p and M ove D own buttons to change the order of the 
computers in the list. Click the D elete button to remove a computer from the 
list. When you are satisfied with the order of the computers, click O K.

8 . In the U ser Group dialog box, click O K . 

Editing Information for All User Groups
At times, you may want to edit information for more than one user group. For 
example, you might want to change the scaling proportion of the user groups. 
Although you can edit each user group individually, it is much easier to edit the 
information for all of the user groups at the same time.
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To edit information for all user groups:

1 . Click the U ser Groups button to the right of the schedule. 

The columns of the dialog box display the same information that you set when 
you created each user group.

2 . To change which computer the user group runs on, click the button in the 
Com puters column. The Multiple Computers dialog box appears, which lets 
you change the information.

3 . To change the number of users assigned to a fixed user group, type the number 
in the N um ber of U sers column.

4 . To change the percentage of users assigned to a scalable user group, type the 
number in the % column.

5 . Click O K .
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Editing the Settings of an Agent Computer
You may want to change the default settings associated with an Agent computer. To 
change the computer settings:

1 . Click the Com puters button to the right of the schedule. The Computer 
Settings dialog box appears, which lists the Agent computers in the schedule and 
the operating systems that these computers run on: 

If a computer has not been added to the repository, the O perating System  
column displays the message Not in the repository.

2 . The U pdate VU  Scripts column controls whether LoadTest copies compiled 
VU  scripts to the Agent computer. Select this check box for LoadTest to copy 
over compiled scripts if they are out of date. Clear the box only if you are sure 
the compiled scripts are up to date and you want to avoid the overhead of 
checking each script.

3 . Click the arrow next to the Return Files column, and check the types of files you 
want copied to the Master computer after the schedule runs. You can return 
Output, Result, Error, and Log files to the Master computer.

4 . Click the arrow next to the Remove Files column, and check the types of files 
you want removed from the Agent computer after the schedule runs. You can 
remove O utput, Result, Error, and Log files from the Agent computer.

N O TE: If you select both the Return Files and the Rem ove Files boxes for a 
file, the file is first copied to the Master computer, and then removed from 
the Agent computer.
7 -3 7



D esigning  Schedu les

s 
5 . In the Local D irectory box, type the name of the local working directory for the 
Agent computer to store compiled scripts and any datapool files. The Output, 
Result, Error, and Log files are also stored in a subdirectory under this directory. 
It is a good idea to supply a name to ensure that there is adequate space to store 
these files and to avoid conflicts with other users who running tests on that 
Agent.

If you do not supply a name, LoadTest uses the environment settings of the user 
who started the Agent computer to determine where to store scripts and files. 
LoadTest checks the following environment variables, and uses the value of the 
first one that is set:

a. TMPDIR

b. TMP

c. TEMP

d. (U N IX Agents only) /tmp

6 . Click O K .

Editing the User Settings
You may want to change the default settings associated with users. In particular, it is 
often useful to change what information is logged when you run a schedule. For 
example, if you are having problems running a schedule, you may want to set one 
virtual user’s log level to All and the other users’ log levels to Error so that you can 
investigate the problem more thoroughly.

To edit user settings:

1 . Click the U ser Settings button to the right of the schedule. 

N O TE: For GU I scripts, only Result and Error files have meaning, and thu
they are the only files returned to the Master computer, removed from an 
Agent computer, or stored in a local directory.
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In this dialog box, all of the user groups have inherited the same values, as you 
can see by the minus sign in each column.

To change the value of a user setting for all user groups, double-click a value in 
the first row. For example, to change the log level of all virtual user groups, 
double-click All in the Log Level column and change it to the value you want:
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To change the value of a user setting for one virtual user group, double-click the 
individual value that you want to change. For example, to change the log level of the 
Accounting user group to Error, double-click the minus sign in the Accounting row 
of the Log Level column, and then select Error:

If a virtual user group has a fixed number of users, you can change the value of a user 
setting for an individual user. To do so, double-click the plus sign in the first column 
of the user group that contains that user. For example, assume that the Accounting 
user group is fixed, with 20 users. To change the log level of the first user in the 
Accounting user group to All, double-click the minus sign in the first column of the 
Accounting row, and select All:
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Assigning Values to System Environment Variables
LoadTest passes the system environment variables set on an Agent computer to each 
user. If you are using virtual users to test a database server or application, you can 
override these system environment variables as follows:

If you are testing LoadTest passes these environment variables to the Agent

Oracle on a U N IX 
Agent

The directory that contains the client software to ORACLE_HOME.

Example: 

ORACLE_HOME = /ora/app/oracle/product/8.0.5

If /var/opt/oracle does not contain tnsnames.ora, assign the 
pathname of the file to the variable TNS_ADMIN.

Example: TNS_ADMIN = /home/uname/oracletest

Sybase on a U N IX 
Agent

ã The directory that contains the client software to SYBASE.
Example: SYBASE = /usr/local/sybasec

ã The directory that contains the Sybase client libraries to the path 
of one of the following system environment variables: 
PATH (Windows NT)

LD_LIBRARY_PATH (Solaris Agents)

SHLIB_PATH (H P-U X Agents)

LIBPATH (AIX Agents)
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Master or Agents 
running TU XEDO 
scripts 

ã The directory that contains the client software to TUXDIR. 
ã The NLSPATH environment variable to the path of the directory 

that contains the TUXEDO message file.
ã The value of $TUXDIR/lib to one of the following system 

environment variables: 
LD_LIBRARY_PATH (Solaris Agents)

SHLIB_PATH (H P-U X Agents)

LIBPATH (AIX Agents)

For Windows N T Masters, these need to be defined only for 
TU XEDO  client-only installations. The TU XEDO full run-time 
installation process sets them automatically. For more 
information, see the TU XEDO  installation instructions.

ã One of the following:
The Workstation Listener’s address to WSNADDR.

Example: 

WSNADDR=//sparky:36001
WSNADDR=00028CA1C0A8F0D6

The Workstation Listener’s host name and port to WSLHOST and 
WSLPORT. These variables override WSNADDR, if set.

Example: 

WSLHOST=sparky
WSLPORT=36001

 Master or Agents 
running TU XEDO 
scripts that use 
FML typed buffer 
field names

ã A list of FML field table file names to FIELDTBLS. This variable is 
used by Agents running scripts that contain FML typed buffer field 
name references. If not set, VU  functions that use FML typed buffer 
field names that are defined in files not in this list fail, causing 
dependent VU  commands to fail.
Example: FIELDTBLS=ct.fldtbl,inv.fldtbl

ã The absolute pathname of the directory containing the FML field 
table file to FLDTBLDIR. This variable is used by Agents running 
scripts that contain FML typed buffer field name references. If not 
set, VU functions that use FML typed buffer field names (for 
example, tux_setbuf_int()) fail, causing dependent VU  
commands to fail.
Example: FLDTBLDIR=/u1/tuxapp/dat

 (Continued) 

If you are testing LoadTest passes these environment variables to the Agent
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 Master or Agents 
running TU XEDO 
scripts that use 
FML32 typed 
buffer field names

ã A list of FML32 field table file names to FIELDTBLS32. This 
variable is used by Agents that run scripts that contain FML32 
typed buffer field name references. If not set, VU  functions that 
use FML32 typed buffer field names that are defined in files not in 
this list fail, causing dependent VU  commands to fail.
Example: FIELDTBLS32=ct32.fldtbl,inv32.fldtbl

ã The absolute pathname of the directory containing the FML32 
field table files to FLDTBLDIR32. This variable is used by Agents 
running scripts that contain FML32 typed buffer field name 
references. If not set, VU  functions that use FML32 typed buffer 
field names (such as tux_setbuf_int()) fail, causing 
dependent VU  commands to fail.
Example: FLDTBLDIR32=/u1/tuxapp/dat

 Master or Agents 
running TU XEDO 
scripts that use 
VIEW, 
X_COMMON, or 
X_C_TYPE typed 
buffers

ã A list of view description file names to VIEWFILES. This variable 
is used by used by Agents running scripts that use VIEW, 
X_COMMON or X_C_TYPE typed buffers. If not set, VU  functions 
that use these typed buffers that are defined in view description 
files not in this list fail, causing dependent VU  commands to fail.
Example: VIEWFILES=ct.V,inv.V

ã The absolute pathname of the directory containing the view 
description files to VIEWDIR. If not set, tux_tpalloc() or 
tux_alloc_buf() calls that try to allocate a buffer of type 
VIEW, X_COMMON, or X_C_TYPE fail, causing dependent VU  
commands or functions to fail.
Example: VIEWDIR=/u1/tuxapp/dat:/u1/tuxapp/dat2

 Master or Agents 
running TU XEDO 
scripts that use 
VIEW32 typed 
buffers

ã A list of view description file names to VIEWFILES32. This 
variable is used by Agents running scripts that use VIEW32 typed 
buffers. If not set, VU  functions that use VIEW32 typed buffers 
which are defined in view description files not in this list fail, 
causing dependent VU  commands to fail.
Example: VIEWFILES32=ct32.V,inv32.V

ã The absolute pathname of the directory containing the view 
description files to VIEWDIR32. This variable is used by Agents 
running scripts that use VIEW32 typed buffers. If not set, 
tux_tpalloc() or tux_alloc_buf() calls that try to 
allocate a buffer of type VIEW32 fail, causing dependent VU  
commands or functions to fail.
Example: VIEWDIR32=/u1/tuxapp/dat

Solaris Agents 
running TU XEDO 
scripts

ã The TLI network service provider pathname to WSDEVICE. This 
value is typically /dev/tcp. If not set, playback terminates with an 
error message.
Example: WSDEVICE=/dev/tcp

 (Continued) 

If you are testing LoadTest passes these environment variables to the Agent
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To override the value of a system environment variable:

1 . Click the U ser Settings button to the right of the schedule. The U ser Settings 
dialog box appears.

2 . Click the button in the Sys Environm ent Variables column. The Environment 
Variable Settings dialog box appears: 

3 . Type the name of the environment variable in the Variable nam e box.

4 . Type the value of the environment variable in the Variable va lue box.

5 . Click Add.

To change the value of a system environment variable that you have already set:

1 . Click the name that you want to change.

2 . Change the value in the Variable va lue box.

3 . Click U pdate.

Initializing VU Environment Variables
You can initialize the value of most VU  environment variable within LoadTest. To 
initialize the value of a VU  environment variable:

1 . Click the U ser Settings button to the right of the schedule. The U ser Settings 
dialog box appears.

2 . Click the button in the VU  Environment Variables column. The VU  
Environment variables dialog box appears.
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3 . Click the tab that corresponds to the type of environment variable you want to 
initialize, and enter the initial value for the variable.

Changing the Log Level Value
The Log level column in the U ser Settings dialog box affects virtual users only. It 
sets the level of information written to each U ser Log file. You can set the log level 
to the following values:

ã U nexpected – Log timeouts and unexpected responses from SQL emulatio
commands. For other emulation commands, U nexpected is equivalent to 
T im eout.

ã T im eout – Log emulation commands that time out. If no commands time o
while you are executing the schedule, no U ser Log file is created.

ã All – Perform complete logging. A log entry is made for every emulation 
command.

ã O ff – N othing is logged, and no U ser Log file is created.

ã Error – Log all SQL emulation commands that are in error as well as those 
time out. For other emulation commands, Error is equivalent to T im eout.

If you are running many virtual users, the recommended log level is Error. The 
default log level of All will work, but running the schedule requires more CPU , 
memory, and especially more disk resources. 

However, if you have problems with the schedule and are debugging it, it is 
sometimes useful for one member of each user group to have a log level of All. 

For more information about the log level, see the Log_level environment variable 
in the VU Language Reference.

To change the value of the log level:

1 . Click the U ser Settings button to the right of the schedule. The U ser Settin
dialog box appears.

2 . To change the log level for all users in a group, click the cell in the Log Level 
column for that group.

To change the log level for an individual user in a fixed user group, click the p
sign in the first column of the user group that contains that user. The list of u
expands to display individual users. Click the cell in the Log Level column for 
that user.

N O TE: For more information on VU  environment variables and their 
meanings, see the VU Language Reference.
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3 . Select a value for the log level.

4 . Click O K .

Changing the Record Level Value
The Record level column in the U ser Settings dialog box affects virtual users only. 
It sets the level of information written to the result file. You cannot read the result 
file directly; LoadTest uses it to generate reports. You can set the record level to the 
following values:

ã M IN IM AL – Record only items necessary for reports to run. However, the 
reports will contain no real data. U se this value when you do not want the u
activity included in the reports.

ã T IM ER –  M IN IM AL plus start_time and stop_time emulation 
commands. Your reports will not contain response times for each emulatio
command, and an emulation command failure will not show up as a a failure
addition, the result file for each virtual user will be small. A small result file 
means that disk consumption and CPU  overhead for each virtual user is le
results are retrieved quickly from Agent computers, and you can run repor
a relatively short time. U se this option if you are not concerned with the 
response times or pass/fail status of an individual emulation command.

ã FAILU RE – T IM ER plus emulation command failures and some environmen
variable changes. U se this option if you want the advantages of a small resu
but you also want to make sure that no emulation command failed. 

ã CO M M AN D –  FAILU RE plus emulation command successes and some 
environment variable changes (default).

ã ALL –  CO M M AN D  plus all environment variable changes. Complete recording 
is done. This option is essentially the same as CO M M AN D , except it produces 
more detailed data in Trace report output.

For more information about the VU  record level, see the Record_level 
environment variable in the VU Language Reference.

To change the record level:

1 . Click the U ser Settings button to the right of the schedule. The U ser Settin
dialog box appears.

2 . To change the record level for all users in a group, click the cell in the Record 
Level column for that group.
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To change the record level for an individual user in a fixed user group, click the 
plus sign in the first column of the user group that contains that user. The list of 
users expands to display individual users. Click the cell in the Record Level 
column for that user.

3 . Select a value for the record level.

4 . Click O K .

Changing the Number of Start Scripts
Set this option in the U ser Settings dialog box only if you have changed the runtime 
settings so that you are starting users in groups. You may need to do this to control 
the maximum number of users that log on to a database server at the same time. 

If you are starting users in groups, the Start Scripts column sets the number of 
scripts that the group of users must complete before the next group starts. 

For example, assume the Data Entry user group contains 100 virtual users. Each 
virtual user runs a Login script and then selects three scripts in a random order: 
Add New Record, Modify Record, and Delete Record. You have changed 
the runtime settings so that the 100 users are not starting all at once; instead, they are 
starting in groups of 25. 

If you enter a value of 1 in the Start Scripts column, the second group of 25 starts 
when each user in the first group of 25 completes the Login script. The third group 
of 25 starts when each user in the second group has completed the Login script, and 
so on.

To change the number of start scripts:

1 . Click the U ser Settings button to the right of the schedule. The U ser Settings 
dialog box appears.

2 . To change the number of scripts for all users in a group, click the cell in the Start 
Scripts column for that group.

To change the number of scripts for an individual user in a fixed user group, 
click the plus sign in the first column of the user group that contains that user. 
The list of users expands to display individual users. Click the cell in the Start 
Scripts column for that user.

To restore the number of scripts to the inherited value, double-click in the cell.

3 . Enter the number of scripts that the user must complete before the next group 
starts. Generally this is one script—a login script.

4 . Click O K.
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Limiting the Number of Scripts
The Script Lim its column in the U ser Settings dialog box lets you limit the number 
of scripts that GU I or virtual users can run without having to remove any scripts 
from the user group. 

For example, you can limit the number of scripts to:

ã Test if the user (or user group, or all users) can complete the initial logon/setup 
scripts. By limiting the number of scripts, you don’t have to delete the 
remainder of the scripts assigned to the user group and add them later, or c
a new schedule just to run a simple test.

ã Temporarily disable a user group without deleting it from the schedule. By
setting Script Lim its to 0 for the user group, you disable it. (You can also disab
a fixed user group by setting the number of users to 0.)

ã Vary the length of a schedule run. If your schedule contains nested scenar
with varying numbers of scripts, and random selection of those scenarios, it
be very complicated to use repetition counts to vary the length of the sche
run. A simpler way is to limit the number of scripts.

To limit the number of scripts:

1 . Click the U ser Settings button to the right of the schedule. The U ser Settin
dialog box appears.

2 . To limit the scripts for all users in a group, click the cell in the Script Lim its 
column for that group.

To limit the scripts for an individual user, click the plus sign in the first colum
of the user group that contains that user. The list of users expands to disp
individual users. Click the cell in the Script Lim its column for that user.

To restore the script limits to the inherited value, double-click in the cell.

3 . Enter the maximum number of scripts.

4 . Click O K.

Changing the Way Random Numbers Are Generated
Each user in a user group has a user seed, which generates random numbers in a
script. These random numbers affect:

ã A virtual user’s think time, random number VU  library routines, and random
access in datapools. 

ã A GU I user’s random access in datapools. 

You can set user seeds to be unique or to be the same.
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With a unique seed, each user who runs the same script will have a slightly different 
behavior. For example, if one virtual user thinks for 1.3 seconds before executing the 
first command, the second virtual user might think for 2.4 seconds. Although the 
individual think times will vary, they will have the same distribution around a mean 
value. The seeds also affect the VU  library routines that have to do with random 
numbers. For example, if the first user calls the VU  uniform routine twice and 
receives the numbers 5 and 3, other users in that group will probably receive 
different numbers, bounded only by the minimum and maximum values that are set 
in the script.

With the same seed, each virtual user who runs the same script will have exactly the 
same behavior. For example:

ã If the first user thinks for 1.3 seconds before executing the first command, the 
second user (and all subsequent users) will also think for 1.3 seconds before 
executing that command. 

ã If the first user calls the VU  uniform routine twice and receives the numbers 
5 and 3, all other users in that group will also receive 5 and 3.

You can also set whether or not the random number generator is reseeded at the 
beginning of each script. In general, it is more desirable not to reseed, because one 
long pseudorandom sequence is better than many short ones. 

To change the behavior of the default random number generator:

1 . Click the U ser Settings button to the right of the schedule. The U ser Settings 
dialog box appears.

2 . To change the seed flags for all users in a group, click the cell in the Seed Flags 
column for that group.

To change the seed flags for an individual user, click the plus sign in the first 
column of the user group that contains that user. 

You can select one of the following options:

– U nique and not reseeded – Generates a unique seed for each user and d
not reseed the random number generator at the beginning of each scr
Each user in a user group will behave slightly differently. This is the mo
commonly used option in performance testing.

– U nique and reseeded – Generates a unique seed for each user and rese
the random number generator at the beginning of each script. Each us
a user group will behave slightly differently, but the numbers are resee
at the beginning of each script. You might require this option if you are
doing government LTD (Live Test Demonstration) testing.
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– Sam e and not reseeded – Generates the same seed for each user and d
not reseed the random number generator at the beginning of each scr
This is generally not a desirable option to select when modeling a reali
workload, because each user who runs the same script will behave in 
same way. But this option may be useful for certain types of stress test

– Same and reseeded – Generates the same seed for each user and rese
the random number generator at the beginning of each script. This is 
generally not a desirable option to select when modeling a realistic 
workload, because each user who runs the same script will behave in 
same way, and short pseudorandom sequences are not desirable. How
this option may be useful for certain types of stress testing.

3 . To change the seed behavior for all users in a group, click the cell in the Seed 
column for that group.

To restore a seed to its inherited value, double-click in the cell.

To change the seed for an individual user, click the plus sign in the first colu
of the user group that contains that user. 

4 . Click O K.

Viewing Schedules with the Asset Browser
The Asset Browser is a Rational Test window that displays your testing resourc
When you are running LoadTest, the Asset Browser gives you quick access to a
schedules, reports, and results of schedule runs that are in your project.

To see the schedules in your project from the Asset Browser:

1 . Click View → Asset Browser.

2 . Double-click on the schedule that you want to view.

N O TE: The VU  library routines that generate random numbers are 
negexp, rand, and uniform. For more information about these routines, 
see the VU Language Reference.

N O TE: For more information about the Asset Browser and how to structur
queries, see the Using Rational Robot manual.
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Deleting a Schedule
You may occasionally want to delete a schedule. For example, if you plan to change 
a schedule extensively, it may be easier to delete it and start with a new one.

When you delete a schedule:

ã All of the relationships you have created in the schedule are deleted.

ã All items defined in the schedule, such as selectors, synchronization points, 
scenarios, and delays, are deleted.

ã Scripts are not deleted from the repository. You can reuse them in another 
schedule. For information about deleting a script from the repository, see the 
Using Rational Robot manual.

ã Executables remain on your system. You can reuse them in another schedule.

To delete a schedule:

1 . Click View → Asset Browser.

2 . Click the schedule that you want to delete.

3 . Click Edit → D elete.

Renaming a Schedule
To rename a schedule:

1 . Click View → Asset Browser.

2 . Click the schedule that you want to rename.

3 . Click Edit → Rename.
7 -5 1



D esigning  Schedu les

e 

n 

 the 

n 

 you 
 

y.
Using Events and Dependencies to Coordinate Execution

An event  is a mechanism that coordinates the way items are run in a schedule. For 
example, assume you are running a schedule that contains 100 virtual users that 
access a database. You want the first user to initialize the database, and the other 99 
users to wait until the initialization is complete. To do this, you set a dependency on 
an event, which blocks the 99 users until the event—the first user initializes th
database—occurs.

You can have multiple events in a schedule, but only one item in a schedule caset 
an event. However, many items can depend on the event.

The following schedule shows 99 users waiting until the first user initializes a 
database:

The second column in the schedule lists the events, and the third column lists
dependencies. In this schedule, as soon as the Initialize Database script 
completes, it sets the event Database Is Initialized. The Add New Record, 
Modify Record, and Delete Record scripts depend on this event and can ru
only after it is set.

N O TE: In the previous example, the Data Entry users run scripts randomly. 
Therefore, you must add a dependency to each script in the selector, because
do not know which script will run first. However, if the Data Entry users ran the
scripts sequentially, you would need to add a dependency to the first script onl
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Setting an Event
To add a script that sets an event: 

1 . Click Insert → Script . 

2 . In the Script name box, enter the name of the script that will set an event.

3 . In the Event  box, type the name of the event.

4 . In the I terations box, select the number of iterations. If you set multiple 
iterations, the script sets the event after the last iteration completes.

5 . Click O K . You have now made a script set an event.
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Setting a Dependency on an Event
To add a script that depends on an event:

1 . Click Insert → Script . 

2 . In the Script name box, enter the name of the script that will depend on an 
event.

3 . In the Scheduling method box, select After D ependencies.

4 . In the D ependencies box, select the name of the event. To make the script wait 
on more than one event, click M ultiple D ependencies.

5 . Click O K . You have now made a script depend on an event.

N O TE: The previous example shows how to add a script that sets an event 
and another script that depends upon an event. H owever, scenarios, 
executables, transactors, and delays can also set events, and executables can be 
dependent on an event.
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Setting Shared Variables

If you are running virtual users, you can initialize shared variables in a schedule. 
A shared variable maintains its value across all scripts in a schedule. Each virtual user 
can access and change the shared variable.

Shared variables are useful in the following situations:

ã For synchronizing users when you need more specific coordination than a 
synchronization point provides. For example, you may want to limit a 
transaction so that only five users perform it at once. In that case, you can use a 
shared variable with the VU  language wait library routine.

ã For blocking a user from executing until a global event occurs. It is generally 
easier to set an event and a dependency than to set a shared variable. H owever, 
if the event depends on some logic within a script, you must use a shared variable.

ã For counting loops within a VU  script. If you want to set a loop for an entire 
script, it is easier to set a selector or an iteration count within the schedule. 
H owever, if only a portion of the script loops, you can set a shared variable to 
control the number of iterations of that loop.

ã For monitoring specific transaction counts and conditions. You can view shared 
variables when you monitor a schedule, and they provide detailed information 
about the progress or state of a schedule run.

You declare a shared variable within a VU  script with the keyword shared. For more 
information about declaring shared variables, see the VU Language Reference.

You initialize a shared variable within a schedule. This is optional—the default va
is 0.

You manipulate the value of a shared variable through the logic in a VU  script or wh
you monitor the schedule.
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To initialize a shared variable:

1 . Click the Shared Variables button to the right of the schedule. 

2 . In the Variable nam e box, type the name of the shared variable.

3 . In the Integer va lue box, type the initial value for the shared variable. When you 
run the schedule, the shared variable is set to this value.

4 . Optionally, type an explanation of the shared variable In the Comment box.

5 . Click Add. The shared variable and its value appear in the bottom portion of the 
dialog box. If you add a comment, the comment appears as well.

To change a shared variable:

1 . Click the Shared Variables button to the right of the schedule. The Shared 
Variable Settings dialog box appears, with a list of the shared variables that you 
have set.

2 . Click the shared variable that you want to change. The variable name and value 
appear in the top portion of the dialog box.

– To modify the shared variable, change its name or value and click U pdate.

– To delete the value of a shared variable, click D elete.

3 . To reset all of the shared variable values to 0, which is the default initializat
click Rem ove All.

4 . Click O K.
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Printing and Exporting a Schedule

Designing a schedule can involve many iterations and changes. You may find it 
helpful to examine a printed view of a schedule. You can print a schedule or export 
it as a .txt file.

To print a schedule:

1 . Click File → O pen → Schedule, and open the schedule you want to print.

2 . Click File → Print .

3 . Adjust the printing settings, if necessary, and click O K .

To export a schedule as a .txt file:

1 . Click File → O pen → Schedule, and open the schedule you want to save.

2 . Click File → Export to File. 

3 . Select a folder. The default folder is your current directory. 

4 . Enter a file name for the exported data. The default file name is the name of the 
schedule.

5 . Click Save.
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Saving a Schedule

After you have finished modifying a schedule, you should save your modifications. 
A schedule that is not saved has an asterisk in the title bar. 

To save a schedule:

ã Click File → Save. 

To save more than one schedule:

ã Click File → Save All. 

To save a schedule under a different name:

1 . Click File → Save As.

2 . Type a new name in the N ame box. 

If the schedule with that name already exists, a warning dialog box asks whether 
you want to overwrite the existing schedule.

3 . Optionally, type a description. If you have many similar schedules, it is useful to 
add a description. This description appears when you click File → Properties. 

N O TE: If you click Tools → O ptions, click the Create Schedule tab, then 
select the Check schedule when saving box, one verification screen appears 
for each schedule being saved.
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4 . Optionally, type a note. If you have many similar schedules, it is useful to add a 
note. 

5 . Click O K .

Checking a Schedule

While you are working on a schedule, you might change it so that it will not run 
correctly. For example, you might insert a script into a schedule before it is recorded. 
Although LoadTest automatically checks a schedule before it runs, you can check a 
schedule at any time to correct problems without actually running it.

LoadTest checks a schedule for many kinds of errors, including the following:

ã The schedule contains a script that exists in the repository but is empty. To 
correct this problem, record or create the script with Robot.

ã The schedule does not contain any user groups. A schedule must have at least 
one user group to run.

ã The schedule contains an empty user group. Either delete the user group or add 
scripts and other items to it.

ã A user group contains an empty scenario. Either delete the scenario or add items 
to it.

ã The schedule contains a selector that is empty.

To check a schedule:

ã Click Run → Check Schedule.

LoadTest displays any problems with the schedule in a separate window. 

N O TE: D escription and N otes are both fields that you can display when 
you create a query. For information about creating queries, see the Using 
Rational Robot manual.

N O TE: You can set options so the schedule is checked automatically whenever 
you save it. To check the schedule automatically, click Tools → O ptions, click the 
Create Schedule tab, then select the Check schedule when saving check box. 
7 -5 9



D esigning  Schedu les

to 
lize 
Checking Agent Computers

If you are running users on Agent computers, it is a good idea to check the Agents 
before you run the schedule. This way, you can determine whether any problems 
exist before you run the schedule.

When you check Agent computers, LoadTest ensures that:

ã All of the Agent computers scheduled for the users actually exist. For example, 
if you incorrectly typed the name of an Agent computer, LoadTest notifies you.

ã The Agent computers are available and running.

ã The Agent software is running. The same release of PerformanceStudio 
software must be installed on both the Master and the Agent computers.

To check the Agent computers:

ã Click Run → Check Agents.

LoadTest displays any problems with the Agent computers in a separate window. 

Controlling Runtime Information of a Schedule

LoadTest lets you control the way a schedule runs. The following list describes the 
types of runtime settings that you can change:

ã How users are started—either all at once or in groups.

ã The criteria for whether a schedule passes or fails.

ã The order in which the user groups run.

ã Timing information such as how long the run should be, how long to take 
initialize the system, whether to suppress timing delays, and whether to initia
timestamps for each script.

ã The number to feed to the random number generator.
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To set the runtime settings for a schedule:

1 . Click the Runtim e button to the right of the schedule. 

2 . Set the Start group inform ation. This option specifies how many users to start 
at the same time. You can adjust this number to avoid overloading the server. 
The next group of users can start after the current group of users has finished 
initializing. You can select one of the following:

– Start a ll users at once – Select this to start all users at the same time.

– Start users in groups – Select this to set the number of users to start at
time in the N umber to start a t a  time box.

3 . Set the Schedule pass criteria . This option determines what the LogViewer 
lists as a “passing” schedule. If the schedule does not meet the criteria, the
LogViewer lists the Schedule Start and Schedule End events as “failed.” You
select one or more of the following:

– Schedule ran to completion – The schedule ran to completion without 
manual termination of the run.

– All users completed normally – All users in the schedule were able to 
complete all of their assigned schedule items.

– All GU I scripts returned success – All GU I scripts passed, which means
that no verification points failed and no user action commands timed o

N O TE: If you are starting users in groups, you should also set the number 
scripts that each user needs to run before the next group starts. To do this
click the U ser Settings button to the right of the schedule, and modify the 
Start Scripts box.
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4 . Set the Execution order. This option defines the order in which users are 
started, and therefore determines which user groups are executed if you run 
fewer users than the maximum number defined. You can select one of the 
following:

– Sequentia l – Runs each user as it is encountered in the schedule (from
top to the bottom). 

– Balanced – Balances the run among the user groups in proportion to t
schedule.

– Custom  – Lets you select specific user groups or users to run. This opti
which applies to fixed user groups only, can be useful for troubleshooti
For example, if a script does not work, and that script is used only by th
Accounting group, you can run that group only. Click the D efine button to 
run a particular user or user group, and then click Add to add that user or 
group to the execution list.

Run fixed users first – Runs the fixed user groups before the scalable user 
groups, regardless of the execution order. If your user groups are all fixed, 
option has no effect. 

Assume that you have defined four user groups with a total of 101 users, and
have the following schedule: 

N O TE: You can also temporarily disable a fixed user group by setting the 
number of users to 0. Right-click on the user group, click Properties, and set 
N um ber to 0. LoadTest ignores the user group when you run the schedule
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Although your schedule contains 101 users, you want to run it with only 10 
users. The following table lists how the execution order affects which users are 
run:

5 . Set the T ime information. This option specifies the maximum amount of time 
for the schedule to run, how long you want to allow for users to initialize, 
whether to include timing delays, and whether to keep the timestamps from 
script to script or to reset them for each script. You can select one or more of the 
following:

– D uration of run – Specify the maximum number of seconds for the 
schedule to run. If you select 0, no time limit is imposed on the schedu
run.

– Initia lization time – The maximum number of seconds for all users to 
confirm that they completed initializing. If you have changed the numb
of start scripts, make sure that you set this time high enough.

– Suppress tim ing delays – Runs a schedule very quickly because all timin
delays in virtual user scripts are suppressed. This choice is useful if you
testing a schedule to see whether it runs correctly and you are not intere
in the timing delays. N ote, however, that this creates a maximum workl
on the server, Master, and Agent computers. Do not suppress timing d
if you are running a large number of virtual users.

– Initia lize timestamps for each script – Indicates whether timestamps are
carried over from script to script or are reinitialized with each virtual us
script.

6 . In the Seed box, select a seed number. LoadTest uses this seed to generate
random numbers for selectors and shared access in datapools.

If you select You run these user groups

Sequentia l 1 End of Month Accounting
9 Accounting

Balanced 2 Accounting
3 Data Entry
5 Sales

Balanced and Run Fixed U sers First 1 End of Month Accounting
2 Accounting
3 Data Entry
4 Sales
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7 . In the Enable IP Aliasing box, click to use IP aliasing. This makes each virtual 
user have a different source IP address. This option has meaning only if you are 
running H TTP scripts, and your system administrator has set up your computer 
to use IP aliasing. For information on setting up IP Aliasing, see Appendix B, 
Configuring Master and Agent Computers.

8 . Click O K .

Controlling How a Schedule Terminates

LoadTest lets you set the conditions that force a schedule to terminate. For example, 
you may want to stop a schedule if you discover that a large number of users are 
completing abnormally, indicating that something is wrong with the run.

To control how a schedule terminates:

1 . Click the Termination button to the right of the schedule. 

2 . U nder Termination O ptions, select what happens if you manually stop the 
schedule when it is running. You can select the following options:

– Term inate after completion of next emulation command – Each user 
exits after the next emulation command finishes. This option usually st
a run quickly.

– Term inate after completion of the script – Each user exits after the 
current script finishes. If you select this option, enter a larger value for 
Clean-up tim e.
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– Clean-up time – Enter the number of seconds allowed from the time a 
termination is requested to the time LoadTest forces the termination o
user.

3 . Set the U ser termination counts. When you run a schedule, as the virtual use
log off, you may no longer be interested in measuring the workload. For 
example, if you run a schedule with 1000 users, after 700 users log off, you 
no longer be interested in measuring the system response and you may w
terminate the schedule to save time. This option lets you set the number of 
and the number of scripts that, when complete, trigger the termination of t
schedule.

– Tota l complete – Enter a number of users. When that number complet
the schedule terminates. If you select U se maximum users, the schedule 
terminates when all users finish.

– N orm al complete – Enter a number of users. When that number 
completes successfully, the schedule terminates. If you select U se 
m axim um users, the schedule terminates when all users finish.

– Abnorm al complete – Enter a number of users. When that number 
completes abnormally, the schedule terminates. If you select U se 
m axim um users, the schedule terminates when all users finish.

– Scripts complete – Enter a number of scripts. When that number of scrip
finish running, the schedule terminates. A value of 0 means that no lim
placed on the number of scripts, and the schedule terminates when it 
finished running all of the items in it.

4 . Click O K.

N O TE: The VU  library routines that generate random numbers are 
negexp, rand, and uniform. For more information about these routines, 
see the VU Language Reference.
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Running a Schedule

When you run a schedule, each user executes its assigned schedule items. The results 
of running the schedule are stored in logs. After you run the schedule, you can run 
reports to analyze the data stored in the logs and display run results in the form of 
graphs and charts.

To run a schedule:

1 . Click Run → Schedule.

2 . To change the schedule, click the Change button. The Open Schedule dialog 
box appears, from which you can select a different schedule to run.

3 . Enter the number of users that you want to run in the N um ber of users box. 
The dialog box displays the number of virtual and GU I users that your license 
permits.

If a schedule includes both fixed and scalable user groups, the fixed user groups 
are assigned first. So, for example, if your schedule includes one user group fixed 
at 10 users, and you run 100 users, 10 users are assigned to the fixed user group, 
and the remaining 90 users are distributed among the scalable user groups.
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4 . The name of the Log Folder is based on the schedule, and the Log N ame is 
based on the number of users and the number of times you have run the 
schedule. For example, if you run the sample schedule three times, with 10 
users, 15 users, and 20 users, all three logs will be in the sample schedule folder. 
The log names will be U sers 10 # 01, U sers 15 # 02, and U sers 20 # 03. 
Therefore, the log name U sers 20 # 03 indicates that this is the third time you 
have run the schedule, and the schedule is being run with 20 users. 

To change the log folder or log name, click the Change button. 

5 . If you plan to monitor resources, select the M onitor resources check box. This 
option lets you monitor your computer resource usage when you play back the 
schedule and then graph this usage data over the corresponding user response 
times when you analyze your results.

6 . To change the rate at which the views get updated, type a new update interval in 
the U pdate Rate box. The lower the interval, the faster the update.

7 . Click the O ptions button to change the options that appear when you monitor 
the schedule.

8 . Click O K . LoadTest displays a Preparing to Run window similar to the 
following:

LoadTest checks the schedule, and compiles any uncompiled or out-of-date scripts.

To cancel the schedule run while LoadTest is checking the schedule, click Cancel.

After LoadTest checks the schedule and compiles the necessary scripts, it minimizes 
the Preparing to Run window. At this point, you cannot cancel or dismiss this 
window. To stop the run, click Run → Stop Schedule.

For information about monitoring a schedule as it runs, see Chapter 8, Monitoring 
Schedules.
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Monitoring Schedules
This chapter discusses how to monitor a schedule. It includes the following topics:

ã About monitoring schedules

ã Displaying the schedule views

ã Displaying a histogram

ã Displaying the user views

ã Displaying the Shared Variables view

ã Displaying the Script view

ã Displaying the Sync Points view

ã Displaying the Computer view

ã Displaying the Transactor view

ã Displaying the Group views

ã Filtering and sorting views

ã Changing shared variable information manually

ã Debugging a script

ã Changing monitor defaults

ã Controlling the schedule during a run 
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About Monitoring Schedules

While a schedule is running, you may want to monitor its progress. Monitoring a 
schedule lets you not only confirm that a schedule is progressing successfully, but 
also lets you discover potential problems early in the run so you can intervene if 
necessary. You can suspend and restart virtual users, change the values of shared 
variables, and release users waiting on synchronization points.

LoadTest’s monitoring tools provide you with up-to-date information that is 
dynamically updated as the schedule runs. This information includes:

ã The number of commands that have executed successfully and the numb
commands that have failed.

ã The general state of the users: whether they are initializing, connecting to 
database, exiting the schedule, or performing other tasks.

ã Whether any users have terminated abnormally.

When you run a schedule, LoadTest displays the monitoring information in a 
Progress bar and in views. The Progress bar gives you a quick summary of the
of the run and cannot be changed. You can change the views, however, to pro
summary information or detailed information about each user. The following fig
shows the Progress bar and the default views:

O verall schedule 
view

Standard 
h istogram  view

Com pact user view

Progress bar; pu ll 
down to resize
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The Progress bar lets you quickly assess how successfully the schedule is running. 
The Progress bar provides the following information:

ã U sers – The total number of users in the run.

ã Active – The number of user that are neither suspended or terminated.

ã Suspended – The number of virtual users in a paused state.

ã Abn. Term  – The number of users that terminated without completing all o
their assigned tasks.

ã N ormal Term. – The number of users that completed their tasks successfu

ã T im e in Run – The time the schedule has been running, expressed in 
hours:minutes:seconds.

ã %D one – The approximate percentage of the schedule that has completed

LoadTest also displays three views of the running schedule:

ã The Overall Schedule view, which displays general information about the st
of users. For more information, see Displaying the Schedule Views on page 8-4.

ã The Standard H istogram view, which is a bar chart that provides a general
of what tasks the users are performing. For example, some users might be
initializing, some users might be executing VU  code, and some users migh
connecting to the database. This chart shows the number of users in each

LoadTest displays the Standard H istogram view by default. However, if you
users are running GU I scripts, or if you are testing SQL database or Web 
performance, you may want to display a bar chart specifically geared to tho
tests. For more information, see Displaying the Histogram Views on page 8-5. 

ã The Compact user view, which displays information about the current stat
the users. In this view, you can click on a particular user to display addition
information about that user or control its operation. For more information, 
Displaying the User Views on page 8-12.
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Displaying the Schedule Views

The schedule views are very similar to the actual schedule that you have designed. 
Columns show you which iteration is being executed and what percentage of the 
users in a group are currently in a script or a selector. 

To display a schedule view:

1 . Click M onitor → Schedule.

2 . Select one of the schedule views:

– O verall – U se this view to display general information about the status 
the schedule. LoadTest displays this view by default when you run a 
schedule. The following figure shows an Overall schedule view:

The Overall schedule view is similar to the actual schedule that you ha
designed. However, it contains two additional columns:

The I teration column shows how many iterations are in the schedule ite
and the iteration in progress, averaged over all users currently executing
schedule item. 

For example, 3/10 indicates that, for the users currently executing that
schedule item, on the average, the users are executing the 3rd of 10 to
iterations.
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The U sers Inside column shows the percentage of users that are currently 
executing each portion of the schedule. The percentage next to the user 
group shows the percentage of total users that have been assigned to the 
group and have not yet exited the schedule. The percentage next to the 
items within a user group, however, shows the percentage of users within 
that group that are executing that item. 

For example, if the Sales user group contains 50 percent of the total users, 
the U sers Inside column for that group is 50 percent. If all users in the Sales 
group are executing the Read Record script, the U sers Inside column for 
that script is 100 percent.

– U ser – U se this view to display the exact schedule progress of a particu
user. The following figure shows a U sers schedule view:

Displaying the Histogram Views

The histogram views group the users into various states, such as exiting and 
initializing. U se a histogram view to display a bar graph of how many users are
each state. 

To display a histogram view:

1 . Click M onitor → H istogram .

2 . Select one of the histogram views:

– Standard – Data is grouped in a general way. Select this histogram if yo
want a general overview of the user states.

– GU I – Data is grouped appropriately for tests that run GU I scripts.

– SQ L – Data is grouped appropriately for tests that access SQL databas

– H TTP – Data is grouped appropriately for tests that access Web server
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– I IO P – Data is grouped appropriately for tests that access IIOP servers

– Custom  – Data is grouped according to your needs. For information ab
customizing a histogram, see Configuring Custom Histograms on page 8-36.

The following figure shows a Standard histogram:

In this histogram, seven users are in the Quiet state and three users have exit

The following sections describe the different types of histograms that you can 
display.

Standard Histograms
In a Standard histogram, which is displayed by default, data is grouped in a gen
way. The following table describes the bars in a Standard histogram:

Bar Name Description

U nstarted The process associated with the user has not started. If you see this state 
for a while, you have probably started users and scripts in groups. U ntil 
a group completes initialization, subsequent groups are in this state.

Init U sers that are initializing.

Quiet U sers that are thinking, delaying, or suspended, or waiting on a shared 
variable or synchronization point.

Server States related to communicating with the server.
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GUI Histograms
A GU I histogram displays information pertinent to tests that run GU I scripts. The 
following table describes the bars in a GU I histogram:

Code U sers that are executing VU  or SQABasic code.

Overhead States related to run overhead. These states are GetTask (getting the 
next schedule task), InitScript (initializing a script), Match (pattern 
matching), and Read_Shv (reading a shared variable over the network).

GU I U sers performing GU I-related operations.

Exit U sers that have finished the schedule, with either normal or abnormal 
termination.

 (Continued) 

Bar Name Description

Bar Name Description

Init U sers that are initializing.

Input U sers that are typing input.

WaitApp U sers that are waiting on an application output.

Quiet U sers that are delayed.

Code U sers that are executing SQABasic code.

Overhead States related to run overhead. These states are GetTask (getting the 
next schedule task) and InitScript (initializing a script).

O ther All other states.

Exit U sers that have finished the schedule, with either normal or abnormal 
termination.
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SQL Histograms
A SQL histogram displays information pertinent to tests that access SQL databases. 
The following table describes the bars in a SQL histogram:

HTTP Histograms
An H TTP histogram displays information pertinent to tests that access Web servers. 
The following table describes the bars in an H TTP histogram:

Bar Name Description

Init U sers that are initializing.

Connect U sers that are waiting to connect to the database server.

Exec U sers that are executing VU  sqlprepare or sqlexec statements.

Query U sers that are waiting on the results of a query.

Quiet U sers that are thinking, delaying, or suspended, or waiting on a shared 
variable or synchronization point.

GU I U sers that are performing GU I-related operations.

Other All other states.

Exit U sers that have finished the schedule, with either normal or abnormal 
termination.

Bar Name Description

Init Virtual users that are initializing.

Connect Virtual users that are waiting to connect to the Web server.

Send Virtual users that are sending data to the Web server.

Recv Virtual users that are waiting for data from the Web server.

Linespeed Virtual users that are being artificially delayed to achieve a specific 
network linespeed.
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IIOP Histograms
An IIO P histogram displays information pertinent to tests that access IIO P protocol. 
The following table describes the bars in an IIOP histogram:

Zooming In on Histogram Bars
Each bar in a histogram shows a summary state that contains individual states. You 
can zoom in on a bar to see a breakdown of how many users are in each state.

To zoom in on a histogram bar:

ã Double-click on a bar that contains users. A window appears that displays the 
individual states.

Quiet Virtual users that are thinking, delaying, or suspended, or waiting on a 
shared variable or synchronization point.

GU I Virtual users that are performing GU I-related operations.

Other All other states.

Exit Virtual users that have finished the schedule, with either normal or 
abnormal termination.

Bar Name Description

Bar Name Description

Init Virtual users that are initializing.

Bind Virtual users that are obtaining an object reference.

Connect Virtual users that are waiting to connect to the server.

Invoke Virtual users that are invoking a remote operation.

Quiet Virtual users that are thinking, delaying, or suspended, or waiting on a 
shared variable or synchronization point.

GU I Virtual users that are performing GU I-related operations.

Other All other states.

Exit Virtual users that have finished the schedule, with either normal or 
abnormal termination.

N O TE: To restore the window to its original state, click View → Reset .
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The following figure shows an expanded histogram, after you have clicked on the 
Quiet bar:

Seven users are classified as Quiet. The expanded histogram shows that five users are 
in the Think state, and two are in the TransDelay state.

The individual states in the histogram bars are as follows:

This bar Indicates that

Bind Virtual users that are obtaining an object reference.

Cleanup A virtual user is cleaning up (process cleanup) before exiting.

CPU _Delay A virtual user is emulating a CPU  (client application) delay before 
submitting a command to the server.

Connect A virtual user is executing a connect emulation function.

Disconn A virtual user is executing a disconnect emulation function. However, 
the client has not yet disconnected.

Delay A virtual user is executing the VU  delay routine, or a GU I user is 
executing the SQABasic DelayFor() command.

Exit A virtual user has exited.

ExitSQ ABasic A GU I user has finished executing an SQABasic script.
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ExternC A virtual user is executing an external C routine called from within the 
script.

GetTask A virtual or GU I user is waiting to be assigned its next schedule task.

Keys A GU I user is keystroking.

Init A virtual or GU I user is being initialized (process initialization).

InitScript A virtual user is preparing to execute a script.

Invoke Virtual users that are invoking a remote operation.

Match A virtual user is executing tux_precv pattern-matching code while 
the user is waiting for completion of the server’s response.

Read_Shv A virtual user is running on an Agent computer and reading a shared 
variable from the Master computer.

RecvDelay A virtual user encountered a linespeed delay when receiving.

SchedDelay A virtual or GU I user is executing a delay that you set in the schedule.

SendDelay A virtual user encountered a linespeed delay when sending.

Sending A virtual user is sending data with an http_request or sock_send 
emulation command.

ShvBlock A virtual user is temporarily blocked while trying to obtain exclusive 
access to change the value of a shared variable.

SQABasic A GU I user is executing SQABasic code.

SQL_Exec A virtual user is executing or preparing a SQL command (sqlexec or 
sqlprepare) and waiting for the server to complete the operation.

StartApp A GU I user is starting an application within a GU I script.

Suspend A virtual user has been suspended.

TestCase A virtual user is executing a testcase or emulate command.

Think A virtual user or a GU I user is thinking before submitting a command 
to the server.

TransDelay A virtual user or a GU I user is delayed waiting for the next transaction.

Tuxedo A virtual user is executing a TU XEDO emulation command and 
waiting for the server to complete the operation.

 (Continued) 

This bar Indicates that
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Displaying the User Views

The user views display the status and details of GU I and virtual user operations. 
Display one of the user views to see the status of individual users.

To display a user view:

1 . Click M onitor → U ser.

2 . Select one of the user views:

– Full – Contains complete information about all users.

– Com pact – Contains summary information about all users. This is the m
efficient user view to use when you are running Agent computers.

– Results – Contains information about the success and failure rate of ea
VU  emulation command.

– Source – Displays the line number and the name of the source file bein
executed.

– M essage – Similar to the Compact user view, but also displays the first 
letters of text from the VU  display library routine. 

U nstarted The process associated with the user has not started. If you see this state 
for a while, you have probably started users and scripts in groups. U ntil 
a group completes initialization, subsequent groups are in this state.

VU _Code A virtual user is executing VU  code unrelated to user emulation 
commands. For example, the user may be accessing a datapool or 
performing logic that you added to the script.

WaitResp A virtual user is waiting for completion of the server’s response (a 
receive emulation command).

WaitShvSync A virtual user is waiting on an event in a schedule, waiting to be 
released from a synchronization point, or executing the wait routine, 
but the event has not yet occurred.

WaitObj A GU I user is waiting for a window or control to appear.

 (Continued) 

This bar Indicates that
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The following items apply to all user views:

ã To make tracking certain users easier, you can change which users are displayed. 
For more information, see Filtering and Sorting Views on page 8-27.

ã When you display a user view, you can also display the script that the user is 
currently running. Simply double-click on the number in the first column, next 
to the user. LoadTest displays the script. For more information, see Displaying 
the Script View on page 8-18.

ã When a user terminates abnormally, LoadTest writes a message stating the 
reason for termination to the running Schedule window. You can view this 
message from any user view. Right-click on the terminated user, and then select 
the View Termination M essage option. 

A user that terminates abnormally can be easily identified in the user views 
because its Exited state is displayed in red.

The rest of this section describes and gives examples of each user view.

Compact User View
The Compact user view contains summary information about all users. The 
following figure shows an example of a Compact user view:

The Compact user view displays the following information:

ã Groups – Contains information about the user group. The Schedule column 
displays the user group to which the user belongs, as well as a number 
identifying the individual user within the group. This identification remains 
constant throughout the run. The Com puter column displays the computer on
which the user is running.

ã Script – The script that each user is running. In this example, both Accoun
users are running the Calculate Hours script.
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ã State – The state that the user is in. In this example, two users are thinking
eight users have exited the run. If a user has terminated abnormally, Load
displays the word Exited in red.

ã T im e – The time each user has been in that state. In this example, the 
Accounting[2] user has been thinking for 1 second.

Results User View
The Results user view contains information about the success and failure rate o
VU  emulation command. The following figure shows an example of a Results u
view:

In addition to the information displayed in the Compact user view, the Results 
view contains the following information:

ã Com m and – The VU  emulation command that is executing. In this exampl
the two Accounting users are executing the VU  emulation command 
sqlnrecv.

ã Streak – Succession of successes or failures of VU  language emulation 
commands. For example, 4 successes indicates that 4 emulation command
row have been successfully executed.

ã Failure Rate – The number of failures in the last ten VU  emulation comman
the number of failures in the current script, and the number of failures ove
8 -1 4
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Source User View
The Source user view displays the line number and the name of the source file that 
is being executed. The following figure shows an example of a Source user view:

In addition to the information displayed in the Compact user view, the Source user 
view contains the following information:

ã Com m and – The VU  emulation command that is executing. In this exampl
the two Accounting users are executing the VU  emulation command 
sqlnrecv.

ã Source – Generally the same as the script. However, if a GU I script calls ano
script, or if a VU  script contains an include file, the called script or the inclu
file is displayed.

ã Cm d Count – The number of VU  emulation commands that have been 
executed in the current script. This number helps you distinguish between
executions of the same command on different loop iterations. In this exam
the first user is on line 37 and the command count is 4. If line 37 is part of a lo
the next time LoadTest executes that line, the line number is the same bu
command count increases.
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Message User View
The Message user view is similar to the Compact user view, but it also displays 
messages from the VU  display library routine. If you have added this routine to a 
VU  script, you may want to show this view.

The following figure shows an example of a Message user view:

In addition to the information displayed in the Compact user view, the Message user 
view contains the following information:

ã M essage – Text displayed from a running VU  script. If the user executes a 
VU  display library routine, the first 20 characters of its text appear here, a
remain until they are overwritten by the next display routine.

Full User View
The Full user view contains complete information about all users. The followin
figure shows an example of a Full user view:
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In addition to the information displayed in the Compact user view, the Full user 
view contains the following information:

ã Type – Whether the user is a virtual user or a GU I user.

ã Com m and – The VU  emulation command that is executing. In this example,
users are executing the VU  emulation command sqlexec.

ã Source – Generally the same as the script. However, if a GU I script calls ano
script, or if a VU  script contains an include file, the called script or the inclu
file is displayed.

ã Cm d Count – The number of VU  emulation commands that have been 
executed in the current script. If this script is part of a loop, the next time 
LoadTest executes that line, the line number stays the same but the comm
count increases. Thus, the command count helps you distinguish between
executions of the same command on different loop iterations.

ã Streak – Succession of successes (S) or failures (F) in the entire schedule 
For example, S21 means that 21 emulation commands in a row have been
successfully executed from the time the schedule began running.

ã Failure Rate – The number of failures in the last ten emulation commands
the number of failures in the current script, and the number of failures ove

Displaying the Shared Variables View

The Shared Variables view lets you inspect the values of any shared variables th
have set in your schedule or script.

To display the Shared Variables view:

ã Click M onitor → Shared Variable.

The following figure shows a Shared Variables view:

This view shows the name of each shared variable, the value of the variable, an
number of users waiting for the shared variable to reach a certain value. 
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You can change the value of a shared variable from this view. For information about 
changing the value, see Changing the Value of a Shared Variable on page 8-31.

Displaying the Script View

The Script view displays the line of code that a user is running. The Script view is 
useful if you want to watch the progress of a user through a script.

To display the Script view:

1 . Click M onitor → Script . LoadTest displays a list of users that are running 
scripts:

2 . Click the user whose progress you want to check. To select more than one user, 
hold down the CTRL key while clicking. The Script view appears:

The top half of the window shows two tabs: Errors and Log. These tabs display the 
last 100 lines of the U ser Log and U ser Error files. The top tab automatically toggles 
to the last message that was written.
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The bottom half of the window shows the script. The script displays, line by line, 
what the user is doing.

Displaying the Sync Points View

The Sync Points view displays information about the synchronization points that 
you have set in the schedule or that you have included in a script. This view also lets 
you manually release users that are waiting on a synchronization point. 

To display the Sync Points view:

ã Click M onitor → Sync Points. The Sync Points view appears:

The Sync Points view displays the following information:

ã N am e – The name of the synchronization point.

ã State – The state the synchronization point is in. The states can be: 

– Em pty – N o users have arrived at the synchronization point.

– W aiting – At least one user has arrived at the synchronization point, but
all of the users have arrived.

– Released – The users are released from the synchronization point. Th
column also indicates whether the users were released because they a
reached the synchronization point (N ormal), whether you have released 
the users manually (M onitor), or whether the synchronization points hav
timed out (T imeout).

N O TE: Even if you have set the log level to All, successful emulation commands 
are put into a buffer and are temporarily unavailable when you monitor a user 
the Script view. This is to increase LoadTest's efficiency. U nsuccessful 
commands are displayed immediately; however, your log and error files will 
contain the complete results. For efficiency reasons, only the last 100 lines of t
log and error files are displayed when monitoring the Script view.
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ã T im e – The time the synchronization point has been in the current state.

ã T im eout – The timeout period that you set in the schedule, or Infinite, if you 
did not set a timeout period.

ã U sers – The number of users that have reached the synchronization point

– Arrived – The number of users that have arrived at the synchronization
point before it was released.

– To sync – The number of users that must arrive to release the 
synchronization point.

– Late – The number of users that arrived at the synchronization point a
it was released.

ã D elay – If the release time is together, the release delay that you have set in
schedule. If the release type is staggered, the minimum and maximum rele
times.

Displaying the Users Waiting on a Synchronization Point
To display the users waiting on a synchronization point:

1 . Click M onitor → Sync Points. The Sync Points view appears.

2 . Right-click the name of the synchronization point, and then click See U sers.

Releasing a Synchronization Point
You might decide to release a synchronization point, even though the required
number of users has not yet been reached. Subsequent users that arrive at th
synchronization point are not held. However, if you have set a restart time and
maximum time in the schedule, the users will be delayed. So, for example, if yo
release a synchronization point but have set a restart time of 1 second and a 
maximum time of 4 seconds, each user who reaches that synchronization poin
delayed from 1 to 4 seconds.

To release a synchronization point:

1 . Click M onitor → Sync Points. The Sync Points view appears.

2 . Right-click the name of the synchronization point, and click Release.

3 . A confirmation message appears, asking you to confirm the release. Click Yes or 
N o.
8 -2 0



D isplaying the Com puter View

ster 

 

 run 
Displaying the Computer View

U se the Computer view to check the computer resources used during a schedule 
run, as well as the status of the Master and Agent computers at the beginning and end 
of a run. 

Viewing Resource Usage During a Run
To check computer resources used during a schedule run:

ã Click M onitor → Com puters. The Computer view appears.

LoadTest displays the computer resources used for each Master and Agent computer 
in the run. 

The Computer view displays the following information:

ã N am e – The name of the computer that you specified in the schedule. Ma
is the local computer.

ã Com puter Type – The type of computer: either Master, Agent, or Server.

ã State – The state the computer is in. When you display the Computer view
manually, it is generally in the run state.

ã T im e – The time the computer has been in the current state. The time is 
displayed in hours:minutes:seconds.

ã U sers – The total number of users assigned to run on the computer. 

ã CPU  System  – The percent of CPU  cycles servicing the operating system.

ã CPU  U ser – The percent of CPU  cycles servicing user processes.

ã CPU  Q ueue Length – The number of processes or threads that are ready to
but have to wait in a queue. 

This number should be 0 or very small unless the CPU  System  and CPU  U ser 
percentages are close to 100.
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ã M em ory Pages Input/Sec. – The number of pages per second that are read i
memory.

ã M em ory Pages O utput/Sec. – The number of pages per second that are 
swapped onto disk. This number should be considerably smaller than the 
memory pages that are input.

Together, these numbers can indicate memory bottlenecks.

ã M em ory % U sed – The percentage of memory used.

ã D isk T ransfers/Sec. – This shows the disk access speed (seek, rotation, and
transfer time) for up to four disks. If one disk is much slower than the other
might be fragmented. If the transfer rate peaks when the response time is d
this also could indicate a problem with your disk.

ã % D isk U sed – The percent of used disk space on the monitored disk.

ã D elay – This lets you gauge the general state of your network. At regular 
intervals, LoadTest sends a small ICMP packet to the remote computer an
times that request, in ms. This time does not include any service time used
user-level process on the remote computer. The time should stay relativel
consistent and quite small. A large number or a number that varies widely m
indicate network problems. 

ã Service T im e – This lets you gauge the general state of your network. At regu
intervals, LoadTest sends a small TCP packet to the specified computer an
times that request, in ms. This time includes the service time for a user-lev
process on the remote computer to reply to the packet. The time should s
relatively consistent and quite small. A large number or a number that varie
widely might indicate network problems.

N O TE: If you are monitoring resources for a computer that runs HP-U X o
AIX, the D isk T ransfers/Sec. column will always show n/a . This is because 
HP-U X and AIX are unable to supply LoadTest with disk transfer 
information. However, all other columns will be correct.

N O TE: In addition to monitoring your computer resources, you can report
on them. The Response report lets you compare your response time with
your computer resource usage.
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Graphing Resource Usage During a Run
You can graph the resources that your computer uses during a schedule run. To 
graph computer resources:

1 . Click M onitor → Com puters. The Computer view appears.

2 . Right-click a cell in the Resources U sed or N etwork columns, and click Add 
to Graph. 

The following figure shows M em ory Pages Input being added to the graph:

To change the color of an item that is in the graph:

ã Right-click on the corresponding cell and click Toggle Text Color or Change 
Text Color.

To remove an item that is in the graph:

ã Right-click on the corresponding cell and click Remove from Graph.

To remove all items that are in the graph:

ã Right-click on any cell in the graph and click Clear Graph.
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Viewing Computers at the Start or End of a Run
The Computer view appears automatically when Agent computers start up. When all 
Agents are up and running, the Computer view closes. When Agents begin shutting 
down, the Computer view reappears automatically so you can watch the cleanup 
activities such as transferring files to the Master computer. 

The Computer view includes Progress messages, which indicate when the 
computer is creating or initializing processes, transferring files, terminating users, 
and so on. 

The following figure shows a Computer view at the end of a run:

The Computer view displays the following information:

ã N am e – The name of the computer that you specified in the schedule. Ma
is the local computer.

ã State – The state the computer is in. It can be one of the following: 

– N ot Connected – The Master computer has not yet connected to the Ag
computer.

– Initia lizing – The computer is being initialized, or is transferring compile
scripts and datapools that are out of date.

– Run – The computer is running users.

– Term ination – The computer is in termination mode, waiting for users 
exit.

– Clean U p – The computer is cleaning up before exiting. This includes 
transfer and removal of the result files.

– Exit – The computer has exited.

ã T im e – The time the computer has been in the current state. The time is 
displayed in hours:minutes:seconds.

ã U sers – The total number of users assigned to run on the computer. 
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Displaying the Transactor View

The Transactor view shows the status of the transactors that you inserted into the 
schedule.

To display a Transactor view:

1 . Click M onitor → Transactors.

The Transactor view contains the following information:

ã N am e – The name that you gave the transactor when you inserted it in the
schedule.

ã Type – Whether the transaction is Independent or Coordinated.

ã State – The state that the transactor is in. It can be one of the following: 

– N ot Started – An initial state, when the transactor has not run any user

– Arriving – This state pertains to Coordinated transactors only. At least 
user has arrived at the sync point, but not all users have arrived.

– Active – The transactor is running at least one user.

– Inactive – The transactor is not running any users.

ã U sers – The number of users in the Arriving or Active states.

ã Start T im e – The time the transactor first entered the Active state.

ã Active T im e – The total amount of time the transactor has been in the Active 
state.

ã Transactions – The number of transactions that are scheduled by the 
transactor, but not necessarily completed by the user. 

ã Target Rate – The rate that you set for the transactor when you inserted it
the schedule.

ã Actual Rate – The rate that the transactions are actually running. LoadTest 
calculates this rate by dividing Transactions by the Active T ime.

The Target Rate specifies the number of started transactors, but the Actual Rate 
calculates the number of completed transactions. Because the transactions take 
some time to complete, the Actual Rate will approach, but will not reach, the 
Target Rate. H owever, over time and enough transactions, the Actual Rate 
should become close to the Target Rate.
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ã % Late – The percent of transactors that were unable to begin running at the 
desired time. 

For coordinated transactors, this usually means that not enough users are 
available to run the transactors. You may want to run the schedule again with 
more users. 

For independent transactors, this usually means that the time it takes to run one 
transaction is longer than the time between two transactions. 

If too many transactors are late, then the target transaction rate will not be 
maintained or the transactor will not accurately simulate peaks in the transaction 
rate.

Displaying the Group Views

The Group views show the status of all user groups that you defined in the schedule. 
Both Group views show the same information, but the Schedule view shows the 
information by user group, and the Computer view shows the information by 
computer.

To display a Group view:

1 . Click M onitor → Groups.

2 . Select one of the groups:

– Schedule – A list of the user groups in a schedule. The following figure 
shows the Schedule view:

– Com puter – A list of the user groups assigned to the same computer. T
following figure shows the Computer view:
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The Group views contain the following information:

ã Type – The type of users in the group, either VU , GU I, or Mixed. A Mixed us
group appears in a Computer view when a computer runs both GU I and vir
user groups.

ã Tota l – The total number of users in the group.

ã Active – The number of users in the group currently running.

ã Suspended – The number of virtual users in the group that are suspended

ã Abnorm al – The number of users that terminated without completing all of
their assigned tasks.

ã N orm al – The number of users that completed their tasks successfully.

Displaying the Users in a Group
To display the users in the groups:

1 . Click the user in the left column. 

2 . Click the right mouse button to display the shortcut menu.

3 . Click See users.

Filtering and Sorting Views

This section discusses how to customize a view. For example, you can sort us
various ways, or you can filter users and groups so that only certain information
displayed.

Sorting the Users Displayed in a User View
While displaying a user view, you may want to see the users in a particular order
example, you can sort the users alphabetically, or you can sort them in the ord
which they started.

To change the order in which the users are displayed:

1 . Click M onitor → U ser.

2 . Select one of the user views:

– Full – Contains complete information about all users.

– Com pact – Contains summary information about all users.

– Results – Contains information about the success and failure rate of ea
VU  emulation command.
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– Source – Displays the line number and the name of the source file bein
executed.

– M essage – Similar to the Compact user view, but also displays the first
20 letters of text from the VU  display library routine. 

3 . Select a column under the Schedule or Com puter heading:

4 . Click the right mouse button. The shortcut menu appears:

5 . Select the order to sort by:

– Schedule O rder – The order in which the user group appears in the 
schedule.

– Execution O rder – The order in which the users are started.

– Schedule Groups – Alphabetical listing of schedule groups.

– Com puter Groups – Alphabetical listing of computer groups.
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Filtering a User View
When you display a user view, you can filter users so that only certain users appear. 
This is useful if your schedule contains many users and you want to focus on the 
progress of a few of these users.

Including and Excluding Selected Users
For example, you can select certain users and include or exclude them from a view. 
To change which users are displayed in a user view:

1 . Click M onitor → U ser.

2 . Select the user view you want to filter.

3 . Select a single row or consecutive rows by clicking on the number in the first 
row.

4 . Click the right mouse button to display the shortcut menu.

5 . Click Filter users. 

– If you click Include, only the users that you selected are displayed. 

– If you click Exclude, all users except those that you selected are display

Filtering a User by Value
You can filter a user on any value that will stay constant during the run, such a
name of its group, the type of script it is running, or the name of the computer
running on.

N O TE: The current sort order is unavailable. In this example, Execution 
Order is unavailable because it is the sort order being used.
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For example, you might be running a test with 200 virtual users in the Accounting 
user group, 300 virtual users in the Data Entry user group, and 500 virtual users in 
the Sales user group. You want to see only the Data Entry users. You can filter the 
group so that LoadTest displays only the group with the “Data Entry” value. 

To filter a user by value:

1 . Click M onitor → U ser.

2 . Select the user view that you want to filter.

3 . Click the Schedule, Group or Type heading, and click the right mouse button
in any cell in the view. N ote that even if you click a cell in another column, t
column whose heading you clicked remains highlighted. You can filter only
the values on the highlighted column.

4 . Click Filter users → By Value. 

5 . Select a string in the String box, and click either Include or Exclude.

6 . Click O K.

Filtering a Group View
If the Group view displays many columns, you can filter out some columns to 
provide more room to view the columns that you want to see. You can filter a gr
on any value that will stay constant during the run, such as the name of the us
group or the type of script.

To filter a Group view:

1 . Click M onitor → Groups.

2 . Select the group view that you want to filter.

3 . Click the Group or Type heading, and click the right mouse button to displa
the shortcut menu.
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4 . Select Filter by Value from the shortcut menu. 

5 . Select a string in the String box, and click either Include or Exclude.

6 . Click O K .

Restoring the Default Views
If you have zoomed in on a histogram bar, filtered a view, or changed the widths of 
a column in a view, you may want to restore the bar or views to their original settings.

To restore a view to its original setting:

1 . Display the view that you want to restore.

2 . Click View → Reset.

Changing the Value of a Shared Variable

You can change the value of a shared variable when you are monitoring a schedule. 
To change the value of a shared variable:

1 . Click M onitor → Shared Variable.
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2 . Double-click the variable name, or click the right mouse button and select 
Change Value from the shortcut menu. 

3 . If the shared variable is read only, type a new value in the Value of box. 

If the shared variable is being dynamically updated, however, you cannot simply 
type in a new value. By the time you read the value, determine the new value, 
and change it, a virtual user may have modified the value. If this occurs, your 
change is lost. Instead:

– Type an operand in the Value of box. 

– U nder O perators, choose an operator. If you choose the subtract (-) or
divisor (/) operators, the order for operations is:

existing value - new value

existing value / new value

For example, assume the shared variable has a current value of 6. If you ty
in the Value of box and click the - operator, the new value of the shared variab
is 2, because 6 - 4 =  2.

4 . Click O K.

Displaying the Virtual Users Waiting on a Shared Variable
If your scripts contain shared variables, you can see the virtual users waiting on
shared variable.

To display the virtual users waiting on a shared variable:

1 . Double-click the variable name, or click the right mouse button.

2 . Click See U sers from the shortcut menu.

The virtual users are displayed in a Compact user view.
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Debugging a VU Script

You may encounter problems when you are monitoring a schedule. LoadTest 
provides you with tools that enable you to debug a VU  script. When you debug a 
script, it is a good idea to run the schedule with just one user, correct the script, and 
then run the schedule as usual. 

To debug a script:

1 . Click M onitor → Script . LoadTest displays a list of users that are running scripts.

2 . Click the virtual user that is running the script you want to display, and then 
click O K . 

3 . The Script view appears:

Select the choice that you want:

– Single Step – Steps through a VU  script one emulation command at a tim
allowing you to see what happens at each command. To use this choice
suspend a user. This is useful for pinpointing problems.
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– M ulti-step – Steps through a VU  script multiple emulation commands a
time. To use this choice, first suspend the user. Then you can select a
number of commands to execute at a time. 

– Suspend – Suspends a virtual user at the beginning of the next emulati
command.

– Resum e – Allows a suspended virtual user to resume its progress throu
script.

– Term inate – Ends the virtual user’s execution of a script.

– Break O ut – Moves a virtual user out of the following three states:

Waiting on a shared variable

Waiting on a response

VU  delay function

Changing Monitor Defaults

When you monitor a schedule, you can set which views are displayed automati
how often the views are refreshed, and whether toolbars are displayed automa
when you run a schedule. You can even configure the Custom histogram, and
change its colors, as described in the next section.

To change monitoring defaults:

1 . Click Tools → O ptions. 

2 . Click the M onitor tab. 
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3 . U nder D efault views, select the check boxes for the views and toolbars that you 
want displayed when you run a schedule.

4 . Select Always show script for 1  user runs if you always want to see the Script 
view for a one-user run. This is typically used to test a schedule and debug it. 

5 . Click O K .
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Configuring Custom Histograms
By default, the Custom histogram is identical to the Standard histogram. H owever, 
unlike the other histograms, you can configure the Custom histogram. You can 
configure the groups, create new groups, and change the colors that designate a 
group.

To configure the groups:

1 . Click Tools → O ptions. The O ptions dialog box appears.

2 . U nder State H istogram , select Custom , and then click the Configure button. 
The State Groupings dialog box appears:

From this box, you can assign states to and remove states from a group, add an 
entire group and assign states to it, or delete an entire group. The following 
sections discuss how to do this.

3 . Select the D isplay unassigned states check box to display unassigned states in 
an Other bar of the Custom histogram. If you clear this box, unassigned states 
are ignored, and the Other bar is not displayed.

Assigning States to a Group
To assign a state to a Custom H istogram group:

1 . In the State Groupings dialog box, select a group from the Current State 
Grouping box. 

2 . In the U nassigned States box, click the state you want to add to the group. You 
can assign a state to only one group.
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3 . Click the right arrow.

4 . Click O K .

The state is assigned to the group.

Removing States from a Group
To remove a state from a Custom Histogram group:

1 . In the State Groupings dialog box, select a group from the Current State 
Grouping box. 

2 . In the Grouping members box, click the state you want to remove from the 
group.

3 . Click the left arrow.

4 . Click O K .

The state is removed from the group.

Adding a Group
To add an entire group to the Custom histogram:

1 . In the State Groupings dialog box, click the Add Grouping button. 

2 . Type the name of the new group.

3 . Click O K .

4 . Click the states you want to add to the group. To select more than one state, hold 
down the CTRL key while you click.

5 . Click the single right-arrow key. The states are added to the Grouping m em bers 
box. 

6 . To assign a color to the state group, click the Color button, click a color, and then 
click O K .

7 . Click O K .

The new group is added to the Custom histogram.
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Deleting a Group
To delete a group from the Custom histogram:

1 . In the State Groupings dialog box, select the group you want to delete from the 
Current State Grouping box.

2 . Click the D elete Grouping button. 

3 . Click O K .

The group is deleted, and all states that were in the group are now unassigned.

Controlling the Schedule During a Run

LoadTest provides a variety of ways to help you control a schedule while it is 
running. For example, you can suspend a schedule to change settings or examine its 
progress.

Suspending and Resuming Virtual Users in a Schedule
While a schedule is running you can suspend and resume all virtual users in the 
schedule, or you can suspend and resume individual virtual users. This is useful if a 
problem occurs during the run and you want to investigate it.

To suspend and resume all virtual users in the schedule:

ã Click Run → Suspend or Run → Resume.

To suspend or resume individual virtual users:

1 . Click M onitor → U sers.

2 . Select the user row that you want to suspend.

3 . Click the right mouse button.

4 . Select Suspend or Resum e.
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Stopping a Schedule
You can stop the execution of a schedule. This is useful if there is a serious problem 
and you do not want to wait for the test to finish.

To stop a run:

1 . Click Run → Stop.

2 . U nder Action, click the option that you want:

– Abort – Stops the run and does not save any results. Click this option if 
do not plan to run any reports or look at any U ser Error, U ser Output,
U ser Log files through the LogViewer.

– Process Results – Stops the run but saves the results so that you can r
reports, and look at any U ser Error, U ser Output, or U ser Log files throu
the LogViewer.

– Save and Run Reports – Stops the run, saves the results, and produces
reports, just as if your run completed normally. 

– Clean-up time – The amount of time allowed from the time you reques
termination until LoadTest forces the termination of the run.

N O TE: When you abort a large multiuser schedule that includes 
multiprocessor Master or Agent computers, choose a Clean-up time of 60 
seconds or more to allow users (sqa7svui processes) time to exit on their 
own. The default Clean-up time of 1 second often causes the Master to 
terminate many user processes at once, and can result in leftover sqa7svu
processes. Although not harmful, they clutter the process table. They can 
killed individually using Task Manager, or all at once by logging off.
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Analyzing Results
This chapter explains how to use LoadTest reports to analyze performance data. 
It includes the following topics:

ã About LoadTest reports

ã Running a report and viewing log files

ã Printing a report

ã Printing report output

ã Copying a report or its output within LoadTest

ã Renaming a report or report output

ã Deleting a report or report output

ã Exporting report output

ã Comparing the output of Performance reports

ã Customizing reports

ã Changing report defaults

ã Types of reports
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About LoadTest Reports

If your schedule has completed successfully, LoadTest automatically runs Status and 
Performance reports against the data in the log and displays the report output . The 
following figure shows output from a Status and a Performance report:

After you have examined the output from these reports, you can save it or delete it.

If you save the output, LoadTest gives it the default names of Status 1 and 
Performance 1, and saves it under the logs in the repository. To view the output 
again, click File → O pen → Report O utput, and select Performance 1 and Status 1.

If you delete the output, you can re-create it by running the Status and Performance 
reports against the same log. Simply click Run → Report → Perform ance (or 
Status), select the build and log folder that contain the log, and then select the log.

In addition to the Status and Performance reports, LoadTest provides various types 
of reports designed to analyze the results of a schedule run. For example, you can 
determine how long it took for a virtual user to execute a command, and how 
response times varied with different schedule runs. You can also define new reports.
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 The following table summarizes the types of LoadTest reports:

Use this 
report

To do this For information, 
see 

Performance Display the response times, and calculate the mean, 
standard deviation, and percentiles for each 
response time in the schedule run. 

The output groups responses by command ID and 
shows only responses that passed. In contrast, 
Response report output shows each command ID 
individually and shows passed and failed responses.

Performance on page 
9-44

Compare Compare the response times measured by 
Performance reports. After you have generated 
output from several Performance reports, use the 
Compare report to compare a specific field.

Compare on page 
9-40

Response Display individual response times and whether a 
response has passed or failed. This report is useful 
for looking at data points for individual responses as 
well as trends in the data.

The output shows each command ID individually 
and the status of the response In contrast, 
Performance report output groups responses by 
command ID and shows only passed responses.

You can right-click on the report output, select a 
computer that was in the run, and graph the 
resource monitoring statics for that computer. 
These are the same statistics that you display when 
you monitor a schedule.

Response on page 
9-46

Status Obtain a quick summary of which commands 
passed or failed. The output displays the status of all 
VU  emulation commands and SQABasic timer 
commands. If you have failures, you may want to 
run the Analog report.

Status on page 9-48

Analog Examine errors in your run. The output shows the 
“conversation” between the virtual user and the 
server. If you access a database, the output shows 
the database errors, as well as the number of rows 
that you expect to receive versus the number 
returned from the server. If you need further 
information, run a Trace report.

Analog on page 
9-38
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Running a Report and Viewing Log Files

LoadTest automatically runs the Performance and Status reports at the end of a 
successful schedule run. H owever, you may also want to view the log files, which are 
the “raw” result files before you run reports on them. Or you may want to run ot
reports. This section describes how to view log files and how to run different rep

Viewing the Log Files
The Rational LogViewer shows log files for each virtual user, as well as a log file
the entire schedule run. The log files are:

ã A Schedule Log file, which contains the compilation and run messages that
saw when you ran the schedule

ã A U ser Error file, which lists warnings and errors that occurred during the 
schedule run

ã A U ser Output file, which lists messages that the VU  script wrote to standa
output

ã A U ser Log file, which lists the data for each VU  emulation command execu
as well as any messages coded in the script with the VU  log_msg library 
routine

Trace Examine any failures in detail. The output formats 
raw data from the logs, without performing 
statistical analysis. It provides information 
including the timestamps from each VU  emulation 
command and SQABasic timer command, and the 
counts of data sent and received.

Trace on page 9-49

U sage View cumulative response time and summary 
statistics, as well as throughput information for VU  
emulation commands only.

Usage on page 9-52

 (Continued) 

Use this 
report

To do this For information, 
see 
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To display these log files: 

1 . Click View → Report Bar. The report bar appears:

2 . LoadTest displays the log of the last schedule you ran. If necessary, click 
Change Log to view the log files from a previous schedule run.

3 . Click the LogViewer button. The LogViewer appears.

4 . To display the Schedule Log file, right-click Schedule Start (near the top of the 
Log Event column), and click Schedule Log File.

To display a U ser Log file, right-click a user group, and select a file:

For more information about the LogViewer and how it relates to GU I users, see the 
Using Rational Robot manual.
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Running a Report from the Report Bar
The quickest way to run a report is to click its name on the report bar.

To run a report from the report bar:

1 . Click View → Report Bar. The report bar appears:

2 . LoadTest displays the log of the last schedule you ran. If necessary, click Change 
Log to report on a log from a previous schedule run.

3 . Click one of the report buttons, such as Perf or Status, to run the report.

LoadTest displays the report output. After you have examined the output, you can 
save it or delete it.

To run a different report on the log, click another report button.

Running a Report from the Menu Bar
Although LoadTest lets you run reports quickly from the report bar, you can run 
only one report of each type against a log. You may want to run a number of reports. 
For example, assume you have defined some new Performance reports, and you 
want to run each report. You run these reports from the menu bar.

To run a report from the menu bar:

1 . Click Run → Report, and select the type of report to run. A dialog box similar 
to the following appears:

N O TE: You can customize the report bar by populating it with your own reports. 
Click Tools → O ptions, and then click the Reports tab. For more information, 
see Changing the Reports that Run from the Report Bar on page 9-37.
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2 . From the Reports list, select the Performance report that you want to run.

3 . LoadTest displays the build, log folder, and log of your most recent schedule run. 
You can change this information, if necessary. 

4 . Click O K .

LoadTest runs the report against the log and displays the report output. After you 
have examined the report output, you can save it or delete it.

Printing a Report

To print a report:

1 . At the menu bar, click File → O pen, and then select a report. 

2 . Click File → Print .

3 . If necessary, modify the Properties dialog box for the printer that you have 
chosen.
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Printing Report Output

To print report output:

1 . Click File → O pen → Report O utput , and double-click a report output.

2 . LoadTest displays the report output. O ptionally, to add a header, click View → 
Settings, and then click the Edit Graph Labels tab. For more information, see 
Changing a Graph’s Labels on page 9-33.

3 . Click File → Print .

4 . If necessary, modify the Properties dialog box for the printer that you have 
chosen.

Copying Report Output to the Clipboard

LoadTest displays Compare, Performance, Response, and Status report output in 
graphs and tables. You can copy the table portion onto the clipboard, and then paste 
it into another application such as Excel, Word, or Paint.

To copy a table into another application:

1 . Click File → O pen → Report O utput, and select the rows that you want to copy.

2 . Click Edit  → Copy. LoadTest copies the table to the clipboard. 

3 .  O pen the application that you want to paste the table into. 

4 . Click the application’s Paste command. LoadTest pastes the table into the 
application. 

Copying a Report or Its Output within LoadTest

LoadTest lets you copy reports and report output. 

Copying a report is useful if, for example, you have defined a rather complex re
and you want to modify one option. Although you can define another report fro
scratch, it is much easier—and safer—to copy the report and then change tha
option. With this method, you can be sure that you have modified only that op

Copying graphical report output is useful if you want to change the report outp
settings. For example, you may want to change the format of the output graph 
bar to stack. Or you may want to filter the output. By copying the output and th
changing the settings of the copy, you can preserve both the original and the cha
output.
9 -8



Copying a  Report o r Its O utput with in  LoadTest

al 
To copy a report or report output:

1 . Click View → Asset Browser. 

2 . Select the item that you want to copy. The reports are located in the Reports 
folder. The report output is in the Builds folder.

In this example, the Asset Browser displays:

–  Four reports—the Default Analog Report, the Default Performance 
report, Performance Data Entry, and Performance--Stable Load.

– Two report outputs—Performance 1 and Status 1.

3 . Click Edit → Copy.

4 . Type a new name for the copy. (Otherwise, LoadTest adds a 1 to the origin
name, as shown in the dialog box.) Then, click O K.
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Renaming a Report or Report Output

After you have defined a number of reports, you might want to rename them. For 
example, you might adopt a new naming convention for reports, or you might want 
to standardize your naming conventions.

To rename a report or report output: 

1 . Click View → Asset Browser.

2 . Select the item that you want to rename. The reports are located in the Reports 
folder. The report output is in the Builds folder.

In this example, the Asset Browser displays:

– Four reports—the Default Analog Report, the Default Performance rep
Performance Data Entry, and Performance--Stable Load.

– Two report outputs—Performance 1 and Status 1.

3 . Click Edit → Renam e.
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Deleting a Report or Report Output

After you have defined a number of reports, you may find that some of them are no 
longer useful. You can delete both reports that you have defined and the default 
reports, which come with LoadTest. 

Be careful about deleting default reports, however. The default reports affect all 
projects in the repository. Deleting a default report deletes it from other projects, as 
well as from your own project. Therefore, before you delete a default report, make 
sure that people in other projects, as well as people in your project, do not use the 
report.

LoadTest also lets you delete report output. This is useful if you run reports 
frequently and accumulate report output that you no longer need. 

To delete a report or its output:

1 . Click View → Asset Browser.

2 . Select the item that you want to delete. The reports are located in the Reports 
folder. The report output is in the Builds folder.

In this example, the Asset Browser displays:

– Four reports—the Default Analog Report, the Default Performance rep
Performance Data Entry, and Performance--Stable Load.

– Two report outputs—Performance 1 and Status 1.
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3 . Click Edit  → D elete.

4 . LoadTest asks you to confirm your deletion. Click Yes or N o.

Exporting Report Output

The Performance, Status, Compare, and Response reports display data graphically. 
You can export this graphic data to a .csv file for further processing.

To export report output:

1 . Click File → O pen → Report O utput , and then double-click a Performance, 
Status, Compare, or Response report output.

2 . Click File → Export to File.

3 . Select a folder. The default folder is the Rational Test 7 folder. 

4 . Enter a file name for the exported data. The default file name is the type of 
report.

5 . Click Save.

N O TE: To restore a default report that you have deleted, click Tools → 
O ptions, click the Reports tab, and then click the Restore D efaults button.
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Comparing the Output of Performance Reports

When you run schedules with a different number of users or with other different 
options, you often want to compare the output. You can run two Performance 
reports and visually scan the two Performance report outputs. H owever, a much 
more precise method is to run a Compare report on the two Performance report 
outputs.

Running a Compare report lets you focus on one column of a Performance report 
and compare it across different schedule runs. 

A Compare report can compare the output of up to seven Performance reports. 

To run a Compare report:

1 . Click Run → Report → Compare.

This example shows only the default Compare report, but if you have defined 
other Compare reports, LoadTest displays them as well.

2 . Select the Compare report that you want to run, and then click O K .
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The following dialog box appears, which lets you select the output that you want 
to compare:

3 . Select the Base performance output  from the list. N ote that the report output 
is stored under the logs, so you can click the plus signs on the left of the 
hierarchy to expand the list.

4 . Click the Set Base button. LoadTest lists this output in the Base performance 
output  box. 

5 . Click the Performance report output that you want, and then click the Add 
button, or simply double-click the Performance output. This adds the report 
output to the compare list. 

The following dialog box shows a report that uses the output from a ten-user 
run as the base, and compares a fifteen-user run and a twenty-user run to that 
base:
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6 . Click O K  to run the Compare report.

7 . Click File → Save (or File → Save As) to save the report output.

Customizing Reports

LoadTest lets you customize reports for your particular testing requirements. 

You can customize a report by:

ã Filtering the data. For example, you can filter the report so that it contains only 
one user group, only certain scripts, and only certain command IDs. 

ã Change a report’s advanced options. For example, you can modify a Resp
report so that extremely long responses are not included in the output. 

ã Change a graph’s type and appearance. For example, you can display a gra
a line graph or a bar graph. 

After you have customized a report and saved it, you can use it repeatedly to qu
analyze the data that you need.
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Filtering Report Data
LoadTest provides a set of reports with default settings and options. You can, 
however, filter the reports so that only certain data appears in the output. 

For example, the Performance report output on page 9-2 contains information from 
many command IDs, and the graph is rather complex. To see fewer command IDs, 
you can zoom in on the graph, as explained on page 9-32. Alternately, you can right-
click the report output, click Settings, and then click Select Command ID s. 

H owever, instead of filtering the report output, it is much easier to simply filter the 
report beforehand so that the output contains only the information you are 
interested in. 

You can filter a report so it includes only certain users, only certain scripts, or only 
certain commands.

The following example explains how to filter a Performance report so that its output 
shows only information about the Data Entry user group.

1 . Click File → N ew, and select a report. In this case, select the Performance report. 

 

2 . Since you want to filter the users, click Change Filters.
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3 . Select the build, schedule, and log that you want to run the report on, and then 
click N ext .

N O TE: If you are filtering users, you should generally select the log with the 
largest number of users. This ensures that your report will filter all of the users. 
For example, if you select U sers 1 0  # 0 1 , only 10 users are filtered—even if you 
run the report against 15 or 20 users. However, if you select the log with the 
largest number of users (U sers 2 0  # 0 3 ) you can run the report against any of the 
logs shown, and all of the users will be filtered. 
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4 . Because you are filtering a user group, click Select U sers. Then select the Data 
Entry user group, and click >  to move the user group to the Selected column. 

To select an individual user, click the plus sign next to the user group, which 
expands it to show the individual users. Then, select one or more users in the 
Available list and click > , or click > >  to add all of the users. You can also 
double-click a user in the Available list to add it to the Selected list. 

To remove users from the selected list, make your selection and click <  or < < . 

When you finish selecting the users, click N ext .

N O TE: Clicking All U sers is not the same as clicking Select U sers and then 
moving all of the users to the Selected column. Clicking All U sers produces a 
report that selects all users—no matter which log you run against the report. 
Moving all of the users into the Selected column filters only the users in that log. 
For example, assume that your log contains 20 users, and you move them all i
the Selected column. If you run that report against a 200-user log, the report wil
include only the 20 users that you filtered. However, if you click All U sers, the 
report will include all users. 
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5 . The following dialog box appears, which lets you select the scripts that you want 
to include. Because you have filtered the users, this list includes only the scripts 
that the Accounting users run:

– To select all scripts, without filtering, click All Scripts. 

– To select a script, click Select Scripts. Then select a script, and click >  to
move it to the Selected column. 

When you finish selecting the scripts, click N ext.
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6 . The following dialog box appears, which lets you select the command IDs that 
you want to include:

– To select all command IDs, without filtering, click All Commands. 

– To select a particular command ID, click Select Commands. Then select a 
command, and click >  to move it to the Selected column. 

7 . When you finish selecting the commands, click Finish.

The following window appears. From this window, you can change the filte
again, change the advanced options, run the report immediately, or save it
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8 . To save the report, click Save.

9 . Type a new name for the report, and then click O K .

The next time you open a Performance report, LoadTest displays the report that you 
have defined.

N O TE: It is a good idea to select a name that reflects the items being filtered. 
This lets you quickly identify a report.

N O TE: The previous example shows how to define a report that filters data. 
H owever, you can also filter the output after you run a report. When the output is 
displayed, click View → Settings, and then click the Select Command ID s or 
Response Range tabs. For more information, see Filtering Command IDs that 
Appear in a Graph on page 9-33.
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Setting Advanced Options
All LoadTest reports have advanced options, which determine how the report output 
is calculated and displayed. The specific advanced options are different for each 
report. To “fine tune” a report, you can change the advanced options. 

To see the advanced options for a report:

1 . Click File → N ew, and then click a report.

2 . U nder Advanced O ption Summary, click the Change O ptions button.

3 . The Advanced Options dialog box appears.

The following table summarizes each advanced option, and lists the reports tha
the option:

N O TE: For more information about advanced options, see advanced report 
options, setting in the LoadTest Help index.

This advanced option Is in these reports

Graph – Display the report output as a graph, a table, or 
both, change the type of graph displayed, change the 
labels for the graph axes, and add headers and footers.

Status, Performance, Response, 
Compare

Response Range – Include only responses that fall 
between a maximum and minimum time. The default 
includes all response times. However, you may want to 
set a maximum response time to eliminate outliers. If 
you change this option for one report, change the other 
reports too, so that the output reflects the same 
information. For more information, see Eliminating 
Outliers on page 9-24.

Status, Performance, Response, 
Compare

Response Types – Include only HTTP responses or 
responses with timers. The default includes all 
responses. The Status and Response reports also let you 
filter responses that contain verification points.

Status, Performance, Response

Sort M ethod – Sort command IDs numerically or in the 
order in which they were run. The default is to sort 
command IDs alphabetically. 

Status, Performance, Response 
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Stable Load – Specify a number of users that must be 
logged on before results are reported. The default is to 
report results when any number of users are logged on. 
You may want to change this option so that a certain 
number of users, or all users, must be logged on. For 
more information, see Reporting on a Stable Load on page 
9-25.

If you change this option for one report, change the 
other reports, too, so that the output reflects the same 
information.

Status, Performance, Response

Time Period – Report on a specific portion of the 
schedule run. The default is to report on the entire run.

Status, Performance, Response

Calcula tion – Change how response times are 
calculated. Generally, the default is adequate. The 
default measures the time from the end of the last send 
command until the last byte of the response is received. 
If you change this option for one report, change the 
other reports, too, so that the output reflects the same 
information.

Performance, Response

Response Status – Include only passed responses, or 
only failed responses. The default is to include all 
responses. Generally, the default is adequate.

Trace, Response

Summary – Summarize data by user, script, command 
ID (Status), or run (U sage). The default for the Status 
report is detailed by command ID; the default for the 
U sage report is by run.

Status, U sage

O ptions – Report only failed commands and display 
only certain nonprintable characters in your report. The 
default is to include only failed commands and no 
unprintable characters. You may want to include both 
passed and failed commands in your reports so that you 
can see the failed commands in context. For more 
information, see Including Passed and Failed Commands on 
page 9-25.

Analog

Percentiles – Change how the response times are 
grouped. Generally, the defaults of 50, 70, 80, 90, and 95 
are adequate.

Performance

 (Continued) 

This advanced option Is in these reports
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Eliminating Outliers
Report output often contains a few values, called outliers, that are completely out of 
the normal range. For example, suppose you run a Performance report on 1000 
users. Your response time ranges from 2 to 7 seconds. H owever, the response for one 
command ID is 30 seconds—far more than normal. Since this occurs only once, a
it is a nonrepresentative time, you want to eliminate it from the report output 
because it skews the data.

The following steps show how to eliminate outliers:

1 . Click File → N ew → Perform ance Report.

2 . U nder Advanced O ption Summary, click the Change O ptions button.

3 . The Advanced Options dialog box appears. Click the Response Range tab.

4 . U nder M axim um Limit, click the Specified maximum  box, and enter a limit; 
for example, 29 seconds. This eliminates any response that is more than 2
seconds.

5 . Click Save, and save the report under a descriptive name such as Perform ance-
-29  Sec O utliers.

Timestamps – Omit timestamps from the report. When 
you omit timestamps, reports with the same emulation 
activity but different repetitions are identical.

Trace

Command Types – Include only SQL, HTTP, 
TU XEDO, IIOP, or socket commands; only 
testcase commands; or commands that include 
timers. The default is to include all VU  emulation 
commands.

Trace 

Script Filters – Include only certain line numbers or 
VU  command counts. The default is to include all 
emulation commands.

Trace

Environment Variables – Include only certain types of 
VU  environment variables. The default is to include all 
environment variables.

Trace

 (Continued) 

This advanced option Is in these reports
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N ow that you have defined the Performance--29 Sec Outliers report, you can run it 
immediately or save it. The next time you open a Performance report, LoadTest 
displays this report along with the default Performance report.

Reporting on a Stable Load
It is useful to limit your report so that it includes only times when you have a stable 
load. For example, you are probably not interested in response times when only a few 
users have logged on to the system, or when most of the users have logged off. 

To define a Performance report that includes information only when the load is 
stable:

1 . Click File → N ew → Perform ance Report .

2 . U nder Advanced O ption Summary, click the Change O ptions button.

3 . In the Advanced Options dialog box, click the Stable Load tab.

4 . Select All U sers, or select Custom  num ber of users, and enter a number.

5 . Click O K . The Performance Report window appears.

6 . Click Save and save the report under a descriptive name, such as Perform ance-
-Stable Load.

N ow that you have defined the Performance--Stable Load report, you can run it 
immediately or save it. The next time you open a Performance report, LoadTest 
displays this report along with the default Performance report.

Including Passed and Failed Commands
It is often useful to include passed commands as well as failed commands in an 
Analog report. 

For example, assume you are running a schedule with 20 virtual users. O f these 20 
users, 17 users pass and three users fail. The three users fail when they modify a 
certain record.

N O TE: The previous example shows how to eliminate outliers in a Performance 
report. You can also eliminate outliers in Status, Response, and Compare reports.

N O TE: The previous example shows how to define a stable load in a 
Performance report. You can also define a stable load in Status and Response 
reports.
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When you examine the failed commands only, it is tempting to conclude that 
something is wrong with that particular record—perhaps the record does not exis
in the database. However, to get a clear overall picture, you need to look at the p
commands as well as the failed commands. It could be that the 17 users who p
also tried to modify the record. In that case, the flaw does not lie with the record i
but with the logic of your script.

To include both passed and failed commands in an Analog report:

1 . Click File → N ew → Analog Report.

2 . U nder Advanced O ption Summary, click the Change O ptions button.

3 . In the Advanced Options dialog box, select the Include success and fa ilure 
messages check box.

4 . Click O K. The Analog Report dialog box appears.

5 . Click Save and save the report under a descriptive name, such as Analog--
Passed and Failed Com m ands.

N ow that you have defined the Analog--Passed and Failed Commands report
can run it immediately or save it. The next time you open an Analog report, Load
displays this report along with the default Analog report.

Reporting on a Particular Command ID
The default Response report can look confusing because it contains informatio
about every command ID. This information is useful for assessing trends in the 
However, you may also want to report on a particular command ID or a small gr
of command IDs, and display the report in a line histogram, which is easy to re

The following steps show how to filter on a command ID, and how to display th
command ID as a line histogram:

1 . Click File → N ew → Response Report.

2 . U nder Filters, click the Change Filters button.

3 . Select the log that you want to run the report on, and click N ext.

4 . Because you are filtering on a command ID, check the Selected command ID s 
box and then click N ext. 

5 . A list of command IDs appears. Click the arrow buttons to move the appropr
command ID to the Selected column, and then click Finish. 

6 . U nder Advanced O ption Summary, click the Change O ptions button.

7 . The Advanced Options dialog box appears. Click the Graph tab.

8 . U nder Graph type, click Line H istogram , and then click O K.
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9 .  The Response Report dialog box appears. Click Save and save the report under 
a descriptive name, such as Response--Accounting Com m and ID s.

N ow that you have defined the Response--Accounting Command IDs report, you 
can run it immediately or save it. The next time you open a Response report, 
LoadTest displays this report along with the default Response report.

Mapping Computer Resource Usage onto Response Time
Monitoring computer resources is essential in performance testing. If you have a 
performance problem, you need to determine whether it is caused by a large number 
of users or by a hardware bottleneck. The Response report lets you overlay computer 
resource statistics over response time. If your response time increases, you can 
determine whether this was caused by a computer resource problem.

LoadTest needs to be set up to collect the information on computer resources before 
you can report on computer resources. Therefore, when you run a schedule, be sure 
to select the M onitor resources check box.

The following procedure shows how to create a report that maps computer resources 
onto response time. 

1 . Click File → N ew → Response Report.

2 . Right-click on the graph, and click Show Resources. 

3 . Select the computer you want to report on.
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4 . Select the check boxes you want to report on. N ote that these boxes correspond 
to the resource monitoring categories that you can see when you monitor a 
schedule.

5 . Click O K . A graph of computer recourses is superimposed on the Response 
report.

Defining a Compare Report
Defining a Compare report is similar to defining other reports. One useful Compare 
report defines the 90th percentile data and uses absolute, rather than relative, data 
values. To define this report:

1 . Click File → N ew → Com pare Report .

2 . U se the options under Compare field to select the field of the Performance 
report outputs that you want to compare. 

– M ean – Compares the mean value of the response times.

– Standard D eviation – Compares the standard deviation for the respons
times.

– Percentile – Compares the response times based on the percentile tha
select. The percentile must be in the Performance report. For example
the Performance reports calculate the 50, 70, 80, 90, and 95 percentile
Compare report must use one of these percentiles. 

This example shows how to define a Compare report for the 90th percentil
click the Percentile box and enter 90 . 
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3 . U se the options under Style to compare response times relative to the base 
performance output, or compare response times by their absolute values.

– Value relative to base report – Compares the response times relative to
the base performance output. With this option, the first column in the 
report (the base performance output) is always 1, and the other column
relative to that number. So, for example, if the base lists a response tim
2.5, and another output lists the response time as 5, the Compare repor
them as 1 and 2. 

– Absolute data va lues – The indicated response times appear in the repo
So, for example, if the base lists a response time as 2.5, and another o
lists the response time as 5, the Compare report lists them as 2.5 and 

This example shows how to define a Compare report for the absolute value
click Absolute data va lues. 

4 . The Weighted section lets you decide whether to weigh the response times
occur most frequently. 

– Individual sam ple data  – The response times are not weighed. Therefo
a command ID that occurs ten times and a command ID that occurs 1
times will have an equal influence on the response times statistics.

– W eighted by count of base report sam ples – The response times are 
weighted to reflect the frequency of occurrence of the command ID to
which they correspond. Therefore, command IDs that occur more 
frequently will have more influence on the response time statistics, and
command IDs that occur less frequently will have less influence on the
statistics.

5 . To change the Advanced options, click the Change button.

6 . When you have completed your modifications, click Save to save your new 
report. 

7 . In the Save As dialog box, type a descriptive name:

N O TE: For more information about advanced options, see Setting Advanced 
Options on page 9-22 and advanced report options, setting in the LoadTest Help 
index.
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You have now defined a new Compare report. When you run this report, you select 
the Performance report outputs that you want to compare.

Changing a Graph’s Appearance or Type
LoadTest displays the Compare, Performance, Response, and Status reports as 
graphs as well as reports. The Settings dialog box lets you change the type of graph 
that appears and enhance its display. 

To change the type or appearance of a graph:

1 . Click File → O pen → Report O utput , and double-click a report output.

2 . Click View → Settings.

From this dialog box, you can change the appearance of a graph, change the labels of 
a graph, and filter information such as the command IDs. In a Performance report, 
you can also change the response range that appears in the graph. The following 
sections describe how to do this.

N O TE: The previous figure shows the Settings dialog box for Performance 
reports. The dialog box for other reports is slightly different.
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Changing a Graph’s Appearance
LoadTest lets you control a graph’s format and appearance. You can display or
information about selected points and datasets without affecting the graph’s da
The following figure shows a stack graph with a header, background grid, and 
various other options:

To change a graph’s appearance: 

1 . Click the graph that you want to change.

2 . Click View → Settings. The Settings dialog box appears. 

3 . Select any of the following check boxes:

– Log Scale – Scales any graphical display type to its logarithmic equivale

– Inverted Axes – Switches the relative positions of the graph’s axes.

– Show D ataset Label – Applies the data set labels to the graph.

– D isplay Legend – Displays a color-coded legend for all displayed graphic
components (not available on the Response report). 

– D isplay Grid – Displays a grid that is useful for visual comparisons (not 
available on the Pie graph). 

Background  
g rid

Color-coded 
legend

x,y axes labels

H eader

Footer

Point in form ation
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4 . When you finish making changes, click Apply.

5 . Click O K  to close the dialog box.

Displaying and Clearing Data Point Information
When working with graphs, you may want to display the value of a specific point in 
a graph. To display information about a data point:

ã Move the mouse pointer to the desired area of the graph, and click CTRL-SH IFT-
BU T TO N 1 .

To clear data point information:

ã Right-click the graph, and then click Clear Point Inform ation.

Changing a Graph’s Type
When working with graphs, you can change the type of graph that LoadTest displays.

To change a graph’s type:

1 . Click the graph that you want to change.

2 . Click View → Settings. The Report Output Settings dialog box appears.

3 . Select the type of graph that you want and click Apply.

4 . Click O K to close the dialog box.

Enlarging and Rotating a Graph
By clicking combinations of Shift/Control keys and mouse buttons, you can furthe
manipulate a graph’s appearance:

To do this Click this button And then

Enlarge a graph’s size. CT RL-BU T TO N 1  BU T T O N 2 Drag the mouse toward the bott
of the graph.

Change a graph’s position.SH IFT-BU T TO N 1  BU T T O N 2 Move the mouse to reposition t
graph.

Zoom in on a graph’s axes.SH IFT-BU T TO N 1 Draw a box around the area to 
zoom, then release BU TT O N 1 .

Zoom in on a graph’s data.CT RL-BU T TO N 1 Draw a box around the area to 
zoom, then release BU TT O N 1 .
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Changing a Graph’s Labels
When working with a Status, Performance, or Compare graph, you can change the 
labels of the graph.

To change a graph’s labels:

1 . Click the graph that you want to change.

2 . Click View → Settings. The Settings dialog box appears.

3 . Click the Edit Graph Labels tab. This tab lets you assign or modify labels for
graph’s x and y axes, as well as for its header and footer.

4 . Type the labels that you want.

5 . Optionally, to change the font, style, or size of the axis labels, header, or fo
click the Select button. Choose the appropriate settings, and click O K to close 
the Font dialog box. 

6 . Click Apply.

Filtering Command IDs that Appear in a Graph
LoadTest lets you to filter report data before you create the report output. However
you can also filter command IDs that appear in a graph after you have created the 
report output. This feature is useful if you create a graph that is rather complex
you want to examine portions of it in more detail.

To filter the command IDs in a graph:

1 . Click the graph that you want to change.

2 . Click View → Settings. The Settings dialog box appears.

Rotate the view of a graph 
(stack and pie graphs 
only).

BU T TO N 1  BU TT O N 2 Move the mouse up and down to 
change the inclination angle.

Move the mouse left and right to 
rotate the graph (stack only).

Reset a graph to its 
original size.

the lowercase letter “r” not applicable

 (Continued) 

To do this Click this button And then
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3 . Select the command IDs that you want to appear in the output, and click <  to 
move them to the Available column.

4 . Click Apply.

For information about defining a report that filters command IDs, see Filtering Report 
Data on page 9-16.

Editing the Properties of a Report or Report Output
A report’s properties are stored in the repository. These properties include the n
of the report, a description of the report, who created the report, and when the r
was created. 

Most of these properties are added automatically. However, you may want to a
description of the report or the report output. To do this, you edit the report 
properties.

To edit the properties of a report or report output:

1 . Click the report or report output whose properties you want to edit.

2 . Click File → Properties. The Report Properties (or Report Output Propertie
dialog box appears:

3 . Click the tab that you want to edit. 

4 . Add a description of the report or the report output, and click O K.
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Changing Report Defaults

LoadTest automatically generates Performance and Status reports at the end of a 
schedule run. In addition, you can click a report on the report bar, and LoadTest will 
run the report that you click.

You can change the reports that LoadTest generates at the end of a run. For example, 
you can have LoadTest automatically display a U sage report in addition to the 
Performance and Status reports. Or you can have LoadTest generate a Performance 
report that you have defined instead of the default Performance report.

You can also change the reports that LoadTest runs when you click the report bar 
button. For example, instead of having LoadTest run the default Performance 
report, you can have it run a Performance report that you have defined.

The following sections explain how to change the reports generated at the end of a 
run and how to change the reports that are generated when you click a report on the 
report bar.

Changing the Reports that Run Automatically
LoadTest automatically displays Performance and Status reports at the end of the 
schedule run. H owever, you can change the reports that LoadTest displays. 

To change the reports that LoadTest displays at the end of a schedule run:

1 . Click Tools → O ptions, and then click the Reports tab.
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2 . To delete a report, click its name in the Automatic Reports at End of Run list, 
and then click the D elete button.

3 . To add a report, click the Add button.
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Select the type of report that you want to add. 

LoadTest lists the default report as well as any other reports that you have 
defined. Click the report that you want LoadTest to display.

4 . After you have finished adding and deleting reports, click O K. 

At the end of a schedule run, LoadTest displays the reports that you have selected.

Changing the Reports that Run from the Report Bar
The report bar lets you run reports by simply pressing a button. This bar 
automatically runs the default reports. H owever, you may have defined a new report 
that you want to run instead of the default reports.

The following example shows how to customize the report bar so that when you 
click the Perf  button, the Performance--Data Entry report runs instead of the default 
Performance report:

1 . Click Tools → O ptions, and then click the Reports tab. The Options dialog box 
appears. The Report Bar Buttons area lists the reports that appear automatically 
at the end of a schedule run. 

2 . Click Change next to the report that you want to change. In this example, you 
are changing the Performance report. 
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3 . The dialog box displays both the default Performance report and any 
Performance reports that you have defined:

 

4 . Click Perform ance--D ata  Entry, and click O K .

The next time you click the Perf  button, LoadTest runs the Performance--Data 
Entry report.

Types of Reports

The following sections describe each LoadTest report in detail, and give an example 
of each type of report.

Analog
U se Analog reports to identify the differences between expected and actual responses 
in a virtual user script.

The report output shows the commands sent, and the rows and errors received, 
during the run. The output displays all client/server traffic related to each VU  
emulation command.

N O TE: To reset the report bar so that it generates the default reports, click Tools 
→ O ptions, click the Reports tab, and then click the Reset Report Bar button.
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The following figure shows an example of Analog report output:

What’s in Analog Report Output?
Analog report output contains the following information:

H eader and trailer lines, which show you which virtual user generated the data. In 
the following example, the header and trailer lines show data from the first virtual 
user in the Accounting user group, Accounting[1]: 

==> Start of data for input log file Accounting[1] <== 
==> End of data for input log file   Accounting[1] <== 

Inside the header and trailer lines, the Analog report shows data on each emulation 
command that a virtual user executed. For example:

*** cmd[cmdID]: script = scrname(cmdcnt), source = srcname(srcline) ***

Syntax Meaning

<<<

<<*

***

< < <  Indicates that the command recorded and played back 
successfully. 

< < * Indicates that an error occurred during recording and the same 
error occurred during playback.

*** Indicates that no error occurred during recording but an error 
occurred during playback. 

cmd The name of the VU  emulation command.

cmdID The command ID.
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Compare
The Compare report compares the response times measured by Performance 
reports. After you have generated output from several Performance reports, you can 
use a Compare report to compare the values of a specific field.

You can compare output that shows different numbers of users. You can also 
compare output from runs on different system configurations.

A Compare report can compare the output from one base report and up to six other 
Performance reports.

What’s in Compare Report Output?
A Compare report can compare report output in a number of ways. It can compare 
the output absolutely, or it can compare the output relative to the base report that 
you select. In addition, the response times can be weighted, so that command IDs 
that occur frequently have more influence, or they can be unweighted, so that each 
command ID has equal influence.

There are four versions of the Compare report, and the following sections explain 
each one. In each report, the same Performance reports are used as input; the only 
difference is in the type of Compare report.

Absolute Compare Reports
Absolute Compare reports display the actual values of the response times, in seconds. 
The final line of the output gives the arithmetic sum of the response times.

scrname The name of the script.

cmdcnt The number of VU  emulation commands that have been executed in 
that script.

source In most cases, this is the same as the script. H owever, if a script calls 
another script, or if a VU  script contains an include file, the calling script 
or the file that contains the include directive is displayed.

srcline The source line.

 (Continued) 

Syntax Meaning
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The following figure shows the last few lines of an absolute Compare report output:

 

To define an absolute Compare report:

1 . Click File → N ew → Compare Report .

2 . U nder Style, click Absolute data  va lues.

3 . U nder W eighted, click Individual sample data .

4 . Click Save, and save the report under a descriptive name.

Weighted Absolute Compare Reports
Weighted absolute Compare reports weigh response times by their frequency of 
occurrence and are useful for comparing “total” response times.

The weight applied is equal to the number of valid responses for that comman
in each output. If the command IDs in the output have a different number of 
responses, LoadTest uses the smallest non-zero number as the weight. 

The weighted absolute value is the product of this weight and the absolute valu
the response time. The final line of the weighted absolute Compare report give
arithmetic sum of the weighted response times for each output.

The following figure shows the last few lines of a weighted absolute Compare re
output:
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To define a weighted absolute Compare report:

1 . Click File → N ew → Compare Report .

2 . U nder Style, click Absolute data  va lues.

3 . U nder W eighted, click W eighted by count of base report sam ples.

4 . Click Save, and save the report under a descriptive name.

Relative Compare Reports
Relative Compare reports list the “base” response time as 1.00 and the other res
times relative to that base. 

The final line of the output gives the geometric mean of the relative response t
for each output. To determine the geometric mean, LoadTest multiplies the 
response times, and then takes a root of the product that is equal to the numb
response times. For example, if there are five response times, LoadTest multip
them together and takes the fifth root of the product.

Mathematically, the geometric mean of a set of values x1, x2, ..., xk is expressed as:

The following figure shows the last few lines of a relative Compare report outp

To define a relative Compare report:

1 . Click File → N ew → Compare Report.

2 . U nder Style, click Value relative to base report.

3 . U nder W eighted, click Individual sample data .

4 . Click Save, and save the report under a descriptive name.

x1x2...xk( )1 k/
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Weighted Relative Compare Reports

This report is the same as the relative Compare report, except that it also lists the 
weighted geometric mean. 

The weighted geometric mean differs from the geometric mean in that it takes into 
account the frequency with which the different command IDs occur. Thus, 
frequently used command IDs have a greater influence on the weighted geometric 
mean than infrequently used ones, in contrast to the geometric mean, where all 
command IDs have equal influence. 

The weight applied when calculating the weighted geometric mean for each 
command ID equals the number of valid responses for that ID in each file being 
compared. If the number of valid responses for a command ID differs among the 
files, the smallest non-zero count is used as its weight.

Mathematically, the weighted geometric mean of a set of values x1, x2, ..., xk having 
frequencies (weights) f1, f2, ..., fk, where f1 +  f2 +  ... +  fk =  N , is expressed as:

The following figure shows the last few lines of a weighted relative Compare report 
output:

To define a weighted relative Compare report:

1 . Click File → N ew → Compare Report .

2 . U nder Style, click Value relative to base report.

3 . U nder W eighted, click W eighted by count of base report sam ples.

4 . Click Save, and save the report under a descriptive name.

x1
f1x2

f2...xk
fk( )

1 N⁄
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N/A and Undefined Responses
Occasionally, you might see the strings n/a and Undefn in the output of a 
Compare report. The following table describes when LoadTest displays these 
strings:

Performance
U se Performance reports to display the response times observed during the schedule 
run. Performance report output displays the response times for the selected 
commands. It also provides the mean, standard deviation, and percentiles for 
response times.

Performance reports use the same input data as Response reports, and provide 
similar data sorting and filtering. H owever, Performance reports group responses 
with the same command ID, while Response reports shows each command ID 
individually. 

The following figure shows an example of Performance report output. The graph 
plots the seconds of response time against preset percentiles. Thus, this graph shows 
15 bars for each percentile category, because a total of 15 commands are graphed. 
The MIN  category shows the minimum response time for each command ID. The 
50th category shows the 50th percentile of time for each command ID. (H alf of the 
command IDs had a shorter response time and half had a longer response time.) The 
MAX category shows the maximum response time for each command ID. 

If this occurs The Compare report output will 

A command ID is in the base report but 
does not exist in the other report output.

List n/a  for that command ID.

A command ID is in the report output but 
does not occur in the base report.

Ignore that command ID.

You are producing a relative report, and 
some command IDs have a response time 
of 0.

List the response time as 0  in the base report, 
and list the other results corresponding to that 
command ID as U ndefn.

All the response times for a report output 
are listed as n/a  or U ndefn.

List the geometric mean or sum as n/a .
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What’s in Performance Report Output?
Performance report output contains the following information:

ã Cm d ID  – The command ID associated with the response.

ã N U M  – The number of responses for each command ID.

ã M EAN  – The arithmetic mean of the response times of all responses for ea
command ID.

ã STD  D EV  – The standard deviation of the response times of all responses f
each command ID.

ã M IN  – The minimum response time of all responses for each command ID

ã 5 0 th, 7 0 th, 8 0 th, 9 0 th, 9 5 th – The percentiles of the response times of all 
responses for each command ID. So, for example, if the 95th percentile of 
N e002 is 0.53, 95% of the responses are less that 0.53 seconds. 

ã M AX  – The maximum response time of all responses for each command I

To display the total response time in the graph and in the last line of the repor
output follow these steps:

1 . Click File → O pen → Report O utput, and select the output from a 
Performance report. 
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2 . Right-click on the graph and select Settings.

3 . Click the Select Commands ID s tab, and select TO TAL.

Response
Response reports display individual response times. Response reports use the same 
input data as Performance reports, and provide similar data sorting and filtering. 
H owever, Response report output shows each command ID individually, while 
Performance report output groups responses with the same command ID. 

Response reports are useful for the following:

ã Checking the trend in the response time. The Response report shows the 
response time versus the elapsed time of the schedule run. The response time 
should be clustered around one point rather than getting progressively longer or 
shorter. If the trend changes, check that you have excluded login and setup time 
in your results. The worst case is that you might need to change your test design.

ã Checking any spikes in the response time. If the response time is fairly flat 
except for one or two spikes, you may want to investigate the cause of the spikes. 

ã Filtering the data so that it contains only one command ID, and then graphing 
that command ID as a histogram.

ã Optionally, checking the resources used by a computer in the run. To see the 
resources used, right-click on the Response report output and select a computer. 

The following figure shows an example of Response report output. The graph plots 
each virtual user versus the response time, in milliseconds. Thus, this graph shows 
that the first user in the accounting group (Accounting 1) executed two commands. 
This graph contains many short lines, which resemble dots, and indicate that the 
response times for all the users are quite short. The longer a line is on the X axis, the 
longer the response time, because the X axis graphs the response time.
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What’s in Response Report Output?
Typically, Response report output contains two sections, one for expected responses 
and one for unexpected responses. The responses within each section are sorted by 
command ID, and within each command ID, responses are sorted by the ending 
timestamp.

Response report output contains the following information:

ã Cm d ID  – The command ID associated with the response.

ã Ending TS – The ending timestamp of the response. This timestamp 
corresponds to the value of VU  language read-only variable _lr_ts for the 
response. The timestamp is the interval ending timestamp as defined by th
Time Period report option.

ã Response – The response time in milliseconds.

ã Status – Displays P or F to indicate whether the response passed or failed.

ã U ser – The virtual user corresponding to the response.

ã Script – The name of the script corresponding to the response. 
9 -4 7



Analyzing  Resu lts

is 

hose 

out 

.

Status
Status reports show how well the responses you actually received during playback 
correspond with the responses that you expected to receive. If the response you 
received is the same or is expected, LoadTest considers that it has passed; otherwise, 
LoadTest considers it failed.

The following figure shows an example of Status report output. The graph plots the 
command number against the number of times the script ran, and displays 
commands that passed in green, and commands that failed in red. Thus, this graph 
shows that command 1 (command ID Add N e01) ran 24 times and did not fail, and 
command 6 (command ID Calcul001) ran 8 times and did not fail.

What’s in Status Report Output?
Status report output contains the following information:

ã Cm d ID  – The command ID associated with the response.

ã N U M  – The number of responses corresponding to each command ID. Th
number is the sum of the numbers in the Passed and Fa iled columns.

ã Passed – The number of passed responses for each command ID (that is, t
that did not time out).

ã Failed – The number of failed responses for each command ID that timed 
(that is, the expected response was not received).

ã % Passed – The percentage of responses that passed for that command ID

ã % Failed – The percentage of responses that failed for that command ID.
9 -4 8
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The last line of the report output lists the totals for each column.

Trace
Trace reports list the activity of a run and examine in detail unusual or unexpected 
events. This report formats raw data from the schedule run without performing 
statistical analysis.

Trace report output displays the actual timestamps from the emulation, the counts 
of data sent and received, and the environment variable settings (if recorded). To 
display the actual data sent or received, run an Analog report.

The following figure shows an example of Trace report output:

What’s in Trace Report Output?
Trace report output contains the following information:

ã Tota l N umber of U sers Emulated – The number of virtual and GU I users in
the schedule run.

ã N umber of U sers in Report – The number of users that appear in the outpu
If you have filtered users, this number is different that the total number of u
emulated. 

ã LoadTest Release – The release of the LoadTest system that you used whe
recording.

ã T im e of Schedule Run – The time that the schedule started to run. 

ã T im e of D ay Reference for T imestamps – The time that the schedule starte
to run, given as the number of seconds since 00:00:00 GMT, January 1, 19
you have a U N IX computer available, the U N IX ctime(3) library routine 
converts this and other timestamps into time-of-day format.
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For each user, the Trace report lists the following information:

ã A line indicating the user that is being reported. In this example, the user is 
Data_Entry[1], or the first user in the Data Entry user group.

ã Default environment variable values and environment variable changes taking 
place on each virtual user during playback. The changes correspond to 
environment control commands executed during the schedule run. 

For each script, the Trace report lists the following information:

ã A script header, which lists the user, the release, and the name of the script.

ã Beginning tim estam p – The time, in milliseconds (since the beginning of th
schedule run), at the start of execution of each script.

ã Login T im estam p – Recorded for each user. This corresponds to the time wh
the user’s login status changed to ON .

ã Emulation commands executed during the schedule run. A three-line hea
appears if any emulation commands are included. The Trace report gives 
following information for each emulation command:

– Src Line – The line number of the command in the source file.

– Cm d Count – A running tally of the number of emulation commands 
executed in a script. This column shows 0 for SQABasic timers.

– Clnt – The value of the Server_connection environment variable 
associated with each SQL, HTTP, or socket emulation command.

– Attached to Server – For TU XEDO sessions that start with a 
tux_tpinit emulation command, this line appears.

– Com m and – The emulation command that was executed. If an HTTP 
response was read from cache and not from the network, the report ou
shows http_nrecv(c) (rather than http_nrecv).

– Com m and ID  – The command ID associated with the command

N O TE: U nless you set the record level to ALL during recording, most 
environment variable values are not recorded, and thus do not appear in the Tr
report. The default record level is ESSEN TIAL. For more information, see 
Changing the Record Level Value on page 7-46.
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– Count – These values depend on the type of emulation command. For S
emulation commands, this is generally the number of rows processed.
HTTP and socket commands, this is generally the number of bytes 
processed. For TU XEDO emulation commands, this is a code which c
be 0 (buffer neither sent nor received), 1 (buffer sent but not received)
(buffer not sent but received), or 3 (buffer sent and received).

– First T im estamp – The time, in milliseconds, that the command started
executing, relative to the beginning of the schedule run. In the Trace 
example, sqlexec started executing 37.322 seconds after the schedule
began running.

– Last T imestamp – The time, in milliseconds, that the command stoppe
executing, relative to the beginning of the schedule run. In the Trace 
example, sqlexec stopped executing 38.103 seconds after the schedu
began running. 

– Stat – Whether the emulation command passed or failed.

– Server n ("server_name") disconnected – Indicates that the server 
connection has been closed.

– Ending T im estam p – The time, in milliseconds, that the script stopped 
executing, relative to the beginning of the schedule run. This value is 
reported for each script. The duration of the script is also reported.

– Logout T im estam p – The time, in milliseconds, that the user’s login statu
changed from ON  to OFF.
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Usage
U sage reports display data on all VU  emulation commands and responses. The 
report output describes throughput and user characteristics during the schedule run.

The following figure shows an example of U sage report output:

What’s in Usage Report Output?
U sage report output contains a section on cumulative statistics and a section on 
summary statistics.

Cumulative Statistics
ã Active T im e – The sum of the active time of all users. The active time of a virt

user is the time the user spent thinking (including delays after the user’s fir
recorded command), executing commands, and waiting for responses.

ã Inactive T ime – The sum of the inactive time of all users and scripts. The 
inactive time of a virtual user is the time before the user’s first emulation 
command (including overhead time needed to set up and initialize the run),
possibly, inter-script delay (the time between the last emulation command
the previous script and the beginning of the current script).

ã Passed Com m ands – Total number of passed sqlexec, sqlprepare, 
sql*_cursor, TU XEDO, http_request, sock_send, and emulate 
commands executed.

ã Failed Com m ands – Total number of failed sqlexec, sqlprepare, 
sql*_cursor, TU XEDO, http_request, sock_send, and emulate 
commands executed.
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ã Passed Responses – Total number of responses to input commands that we
matched by passing receive commands (sqlnrecv, sqllongrecv, 
http_nrecv, http_recv, sock_nrecv, and sock_recv). This is not the 
same as the total number of expected receive commands, since a respons
be matched by an arbitrary number of receive commands. A response is 
considered expected if all receive commands used to match it have an exp
status.

ã Failed Responses – Total number of responses that were matched by failin
VU  receive emulation commands. This is not the same as the total numbe
unexpected receive commands, since a response may be received by an ar
number of receive commands. A response is considered unexpected if any
receive commands used to match it have an unexpected status.

ã Average Throughput – Four measurements of average throughput are 
provided: passed command throughput, failed command throughput, pass
response throughput, and failed response throughput. This represents the
throughput of an average user.

ã T im e Spent W aiting – Total time spent waiting for responses, given both in
seconds and as a percentage of active time. Time spent waiting is the elap
time from when the input command is submitted to the server until the se
receives the complete response. The time an http_request spends waiting 
for a connection to be established is counted as time spent waiting.

ã T im e Executing Com m ands – Total time spent in executing sqlexec, 
sqlprepare, sql*_cursor,TU XEDO, and emulate commands. This 
measurement is provided both in seconds and as a percentage of active time
time spent executing SQL commands is defined as the elapsed time from w
the SQL statements are submitted to the server until these statements ha
completed. The time spent executing TU XEDO commands is defined as t
time to execute the specific ATMI primitive until it succeeds or fails.

ã T im e Spent in Input – Total time spent sending user input to the server. Th
measurement is provided both in seconds and as a percentage of active time
time spent by http_request and sock_send commands in sending input
to the server is reported as time spent in input.

ã T ime Spent Thinking – Total time spent thinking, both in seconds and as a
percentage of active time. The time spent thinking for a given command is
elapsed time from the end of the preceding emulation command until the 
current emulation command is submitted to the server. This definition of th
time corresponds with that used during the run only if the environment varia
Think_def in the script has the default LR (last received), which assumes 
think time starts at the last received data timestamp of the previous respon
9 -5 3
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If any SQL emulation commands were executed, the U sage report output includes:

ã Rows Received – N umber of rows received by all reported sqlnrecv 
commands.

ã Received Rows/Sec – Average number of rows received per second. Derived
dividing the number of rows received by the active time

ã Average Rows/Response – Average number of rows in the passed and failed
responses. Derived by dividing the number of rows received by the numbe
passed and failed responses.

ã Average Think T ime – Average think time in seconds for sqlexec and 
sqlprepare statements only.

ã SQ L Execution Com m ands – N umber of sqlexec commands reported.

ã Preparation Com mands – N umber of sqlprepare commands reported.

ã Rows Processed – N umber of rows processed by all reported sqlexec 
commands.

ã Processed Rows/Sec – Average number of rows processed per second. Deriv
by dividing the number of rows processed by the active time.

ã Avg Rows/Execute Cm d – Average number of rows processed by each 
sqlexec command. Derived by dividing the number of rows processed by 
number of sqlexec commands reported.

ã Avg Row Process T ime – Average time in milliseconds for processing a row b
an sqlexec command. Derived by dividing the time spent on sqlexec 
commands by the number of rows processed.

ã Avg Execution T ime – Average time in milliseconds to execute an sqlexec 
command. Derived by dividing the time spent on sqlexec commands by the 
number of sqlexec commands.

ã Avg Preparation T im e – Average time in milliseconds to execute an 
sqlprepare command. Derived by dividing the time spent on sqlprepare 
commands by the number of sqlprepare commands.

If any HTTP emulation commands were executed, the U sage report output 
includes:

ã Passed H TTP Connections – N umber of successful HTTP connections 
established by all reported http_request commands.

ã Failed H TTP Connections – N umber of HTTP connection attempts that faile
to establish a connection for all reported http_request commands.
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ã H TTP Sent Kbytes – Kilobytes of data sent by reported http_request and 
commands.

ã H TTP Received Kbytes – Kilobytes of data received by reported http_nrecv 
and http_recv commands.

ã Sent Kbytes/Connection – Kilobytes of data sent by reported http_request 
and commands per connection. Derived by dividing the kilobytes of data sen
the number of successfully established HTTP connections.

ã Passed Connections/M in – N umber of successful HTTP connections 
established per minute. Derived by dividing the number of successful HTT
connections by the active time.

ã Avg Connect Setup T im e – Average time, in milliseconds, required to establis
a successful HTTP connection. Derived by dividing the total connection tim
for all recorded http_request commands by the number of successful 
connections.

ã H TTP Sent Kbytes/Sec – Kilobytes of data sent per second. Derived by dividin
the kilobytes of data sent by all recorded http_request and commands by 
the active time.

ã H TTP Recv Kbytes/Sec – Kilobytes of data received per second. Derived by 
dividing the kilobytes of data received by all recorded http_nrecv and 
http_recv commands by the active time.

ã Recv Kbytes/Connection – Kilobytes of data received by reported 
http_nrecv and http_recv commands per connection. Derived by 
dividing the kilobytes of data received by the number of successfully establis
HTTP connections.

If any socket emulation commands were executed, the U sage report output inc

ã Passed socket Connections – N umber of successful socket connections 
established by all reported sock_connect functions.

ã Socket Sent Kbytes – Kilobytes of data sent by reported sock_send 
commands.

ã Socket Received Kbytes – Kilobytes of data received by reported 
sock_nrecv and sock_recv commands.

ã Passed Connections/M in – N umber of successful socket connections 
established per minute. Derived by dividing the number of successful sock
connections by the active time.

ã Socket Sent Kbytes/Sec – Kilobytes of data sent per second. Derived by 
dividing the kilobytes of data sent by all recorded sock_send commands by 
the active time.
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ã Socket Recv Kbytes/Sec – Kilobytes of data received per second. Derived by
dividing the kilobytes of data received by all recorded sock_nrecv and 
sock_recv commands by the active time.

If any TU XEDO emulation commands were executed, the U sage report outpu
includes:

ã Tuxedo Execution Com m ands – N umber of TU XEDO commands reported

ã Avg Execution T ime – Average time in milliseconds to execute a TU XEDO 
command. Derived by dividing the time spend on TU XEDO commands by 
number of TU XEDO commands.

If any start_time emulation commands were executed, the U sage report out
includes:

ã stop_tim e Com m ands – N umber of stop_time commands reported.

ã stop_time Cmds/M in – N umber of stop_time commands per minute. 
Derived by dividing the number of stop_time commands by the active time

ã start_tim e Com mands – N umber of start_time commands reported.

ã Avg Block T im e – Average response time in seconds for reported stop_time 
commands. Derived by dividing the sum of the response times for all 
stop_time commands by the number of stop_time commands. The 
response time of a stop_time command is the elapsed time between it and 
associated start_time command.

If any emulate emulation commands were executed, the U sage report output
includes:

ã Passed em ulate Com m ands – N umber of emulate commands that report a
passed status.

ã Passed emulate T ime Spent – Total time spent, from when the passed 
emulate commands start to where they end.

ã Failed emulate Com mands – N umber of emulate commands that report a 
failed status.

ã Failed em ulate T ime Spent – Total time spent, from when the failed emulate 
commands start to where they end.

If any testcase emulation commands were executed, the U sage report outpu
includes:

ã Passed testcase Commands – N umber of testcase commands that report 
a passed status.
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ã Failed testcase Commands – N umber of testcase commands that report a
failed status.

Summary Statistics
ã D uration of Run – Elapsed time from the beginning to the end of the run. T

beginning of the run is the time of the first emulation activity among all use
and scripts, not just the ones you have filtered for this report. Similarly, the 
of the run is the time of the last emulation activity among all users and scri

ã Passed Com m ands, Fa iled Commands, Passed Responses, Fa iled 
Responses – Identical to their counterparts in Cumulative Statistics on page 9-52.

ã Tota l Throughput – Four measurements of total throughput are provided: 
passed command throughput, failed command throughput, passed respon
throughput, and failed response throughput. The total throughput of pass
commands is obtained by dividing the number of passed commands by the 
duration, with the appropriate conversion of seconds into minutes. Thus, i
represents the total passed command throughput by all selected users at t
applied workload, as opposed to the throughput of the average user. The t
failed command, and the total passed and failed response throughputs are
calculated analogously.

These throughput measurements, as well as the script throughput, depend
the user and script selections. For example, if only three users from a ten-
run are selected, the throughput would not represent the server throughpu
ten-user workload, but rather the throughput of three selected users as pa
ten-user workload. As a guideline, the summary throughput measurement
most meaningful when all users and scripts are selected.

ã N um ber of U sers – N umber of virtual users in the schedule run.

ã N um ber of stop_tim e Cm ds – N umber of stop_time commands in the 
schedule run.

ã N um ber of Completed Scripts – Scripts are considered complete if all activitie
associated with the script are completed before the run ends.

ã N um ber of U ncompleted Scripts – N umber of scripts that have not finished
executing when a run is halted. Scripts can be incomplete if you halt the ru
set the schedule to terminate after a certain number of users or scripts. 

ã Average N um ber of Scripts Com pleted per U ser – Calculated by dividing the 
number of completed scripts by the number of users.

ã Average Script D uration for Completed Scripts – Average elapsed time of a 
completed script. Calculated by dividing the cumulative active time of all us
and scripts by the number of completed scripts.
9 -5 7
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ã Script Throughput for Com pleted Scripts – N umber of scripts-per-hour 
completed by the server during the run. Calculated by dividing the numbe
completed scripts by the duration of the run, with the conversion of secon
into hours. This value changes if you have filtered users and scripts. 

If any stop_time emulation commands were executed, the U sage report outp
includes:

ã Avg N um ber of stop_time Commands – Calculated by dividing the number 
of stop_time commands by the number of users.

ã Average start_time/stop_time D uration – Average response time in seconds
for reported stop_time commands. Derived by dividing the sum of the 
response times for all stop_time commands by the number of stop_time 
commands. The response time of a stop_time command is the elapsed time
between it and its associated start_time command.

ã stop_tim e Com m and Throughput for a ll U sers – N umber of stop_time 
commands executed per minute during the schedule run. Derived by divid
the number of stop_time commands by the duration of the run.

If any emulate emulation commands were executed, the U sage report output
includes:

ã Passed em ulate Com m ands – N umber of emulate commands that report a
passed status.

ã Passed emulate T ime Spent – Total time spent, from when the passed 
emulate commands start to where they end.

ã Failed emulate Com mands – N umber of emulate commands that report a 
failed status.

ã Failed em ulate T ime Spent – Total time spent, from when the failed emulate 
commands start to where they end.

If any testcase emulation commands were executed, the U sage report outpu
includes:

ã Passed testcase Commands – N umber of testcase commands that report 
a passed status.

ã Failed testcase Commands – N umber of testcase commands that report a
failed status.
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Working With Toolbars
Each component of Rational Robot has two default toolbars:

ã Standard – Contains buttons for choosing the most frequently used comma
for that component.

ã Tools – Contains buttons for choosing other components. 

LoadTest has two additional toolbars: Schedule and Run.

All toolbar buttons correspond to menu commands. Click a toolbar button to 
immediately access the menu command. The toolbar buttons are dynamic. Th
means that some toolbar buttons are enabled only when you select related me
or toolbar commands.

Viewing Information About Toolbar Buttons

There are several ways to view information about a toolbar button and its 
corresponding menu command:

ã To see the name of the button in a yellow ToolTip, point to the button and
pause.

ã To see a brief description in the status bar, point to the button or menu 
command.

ã To see more detailed information about the button or menu command, do
of the following:

– Point to the button or menu command and press F1 . 

– Click the H elp Pointer icon on the right side of the Standard toolbar, an
then point to the button or menu command and click the mouse butto
A-1
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Displaying Toolbars

To display or hide a toolbar:

ã Click View → Toolbars, and then click the name of the toolbar you want to 
display or hide.

A check mark appears in front of the name of each displayed toolbar.

Anchoring and Floating Toolbars

The Standard and Tools toolbars are anchored (docked) within each compone
main window below the menu bar. However, you can drag an anchored toolbar 
within a window and make it a floating (undocked) toolbar, which you can posit
and resize independently of the main window. When you do this, the toolbar 
remains visible even when you minimize a component or when the componen
hidden behind another application. You can also drag a floating toolbar and an
it inside of the window.

Floating toolbars are always on top of all other windows. This ensures that the
never hidden. The following figure shows a floating toolbar and an anchored too

D rag the bar to  create a float ing toolba r.

D rag the t it le ba r to  m ove a float ing toolba r. D rag  the 
too lbar to  a m enu  bar to anchor it .

D rag an edge or corner to  change the too lbar’ s shape.

Anchored toolbar

Floating too lbar
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Setting Toolbar Options

To set the toolbar options:

1 . Click View → Toolbars → Customize, or right-click a toolbar and click 
Custom ize. 

2 . In the Toolbars tab, select or clear the appropriate check boxes:

Show ToolT ips – Displays a ToolTip when you point to a button and pause

Cool Look – Changes the appearance of the toolbar buttons so that they ha
borders. It does not change the behavior of the buttons.

Large Buttons – Changes the size of the toolbar buttons.

3 . Click O K. 

Adding, Deleting, and Moving Toolbar Buttons

To add, delete or move a toolbar button:

1 . Click View → Toolbars → Customize, or right-click a toolbar and click 
Custom ize.

2 . Click the Commands tab. 

3 . To add a button, click a menu name from the Categories list. Each name in the 
list represents a menu in the menu bar. Click a button to see its description. 
the button to the toolbar. Make sure you release the mouse button within 
toolbar.

4 . To delete a button, drag it anywhere outside the toolbar. 

5 . To move a button, drag it to a new location.

6 . Click O K. 
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Creating Your Own Toolbar

To create a custom toolbar that contains just the buttons you want:

1 . Click View → Toolbars → Customize, or right-click a toolbar and click 
Custom ize.

2 . Click the Toolbars tab.

3 . Click N ew.

4 . Type the name for the new toolbar and click O K .

5 . Click the Com m ands tab.

6 . Click a menu name from Categories.

7 . Click a button to see its description. Drag the button to the new toolbar. Make 
sure you release the mouse button within the new toolbar.

8 . Repeat steps 6 and 7 until you have finished adding buttons.

9 . Click O K . 

Resetting and Deleting Toolbars

To restore a default toolbar to its original configuration or to delete a custom toolbar:

1 . Click View → Toolbars → Customize, or right-click a toolbar and click 
Custom ize. 

2 . In the Toolbars tab, do one of the following:

– To reset a default toolbar to its original configuration, highlight the toolb
in the list and click Reset.

– To delete a custom toolbar, highlight the toolbar in the list and click D elete.

The name of this button changes depending on the type of toolbar that is 
selected.

3 . Click O K. 
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Configuring Master and Agent Computers
If your schedule runs a large number of users, you must set certain system 
environment variables for the run to complete successfully.

Running More Than 245 Users

If your schedule runs more than 245 users total, you must change two settings in the 
N uTCRACKER operating environment on the Master computer. To run more than 
245 users on an N T Agent computer, you must make the same changes on that 
Agent.

To change these settings:

1 . Click Start → Settings → Control Panel → N utcracker.

2 . Click the N uTC 4  O ptions tab.

3 . Select Sem aphore Settings from the Category list.

4 . Change M ax N umber of Semaphores to N  +  S  +  10, where N  is the number 
of users you want to run and S  is the number of shared variables used by VU  
scripts in the schedule.

5 . Repeat for M ax N umber of Semaphores Per ID .

6 . Click O K .

7 . Click Restart  Later.

8 . Restart N T.
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Running More Than 1000 Users

If your schedule runs more than 1000 users total, you must create an environment 
variable that sets the minimum shared memory size on the Master computer. To run 
more than 1000 users on an N T Agent computer, you must make the same changes 
on that Agent.

To create and set this environment variable:

1 . Click Start → Settings → Control Panel → System .

2 . Click the Environment tab.

3 . Create an environment variable named TEST7_LTMASTER_SHM_MINSZ, and 
set its value to 700 * N , where N  is the number of users you want to run.

On the Master computer, N  is the total number of users for the entire run. On 
the Agent computer, N  is the number of users that run on that Agent. 

4 . Click Set, then click O K .

5 . Restart N T.

Running More Than 1000 Users on One NT Computer

If your schedule runs more than 1000 users on an N T computer, you must create 
and set a system environment variable on each N T computer running more than 
1000 users.

To create and set this environment variable:

1 . Click Start → Settings → Control Panel → System .

2 . Click the Environment tab.

3 . Create an environment variable named TEST7_LTMASTER_NTUSERLIMIT, 
and set its value to the number of users you want to run. 

4 . Click Set, then click O K .

5 . Restart LoadTest (on the Master computer) or the PerformanceStudio Agent 
(on the Agent computer) for the new setting to take effect on that computer.
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Running More Than 24 Users on a UNIX Agent

If your schedule runs more than 24 users on a U N IX Agent computer, you must set 
the following system environment variables:

Controlling TCP Port Numbers

The psmstr_v and psmstr_s network services have been added to control the ports 
on the Master computer to which the Agent communication software connect. 
These network services allow tests to be run with Master and Agent computers on 
different networks separated by a firewall by controlling the ports at which the 
listening Master server processes bind to.

In a PerformanceStudio run involving Agents there are multiple socket connections 
between the Master and each Agent.

System Environment Variable Value

Total LoadTest processes (N PROC, 
MAXU P)

The number of virtual users on the Agent+  5.

Total open files (N FILE, N IN ODE) (6 * N ) +  (open_files * N ) +  (connections * N )

N  is the number of virtual users on the Agent.
open_files is the number of files explicitly 
opened within scripts.
connections is the number of connections open 
concurrently.

Total shared memory (SH MALL) 724 +  5609N  +  16S  +  13G  +  group_names 
bytes

N  is the number of virtual users on the Agent.
S  is the total number of shared variables in all 
the scripts in the schedule.
G  is the total number of user groups in the 
schedule.
group_names is the is the total length of all user 
group names in the schedule.

Semaphore set IDs (SEMMN I, 
SEMMAP)

1

Total semaphores (SEMN S) The number of virtual users on the Agent 

Semaphores per set (SEMMSL) The number of virtual users on the Agent 
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Connections made from the Master to the Agent are always made to a single well-
known port, on which the PerformanceStudio Agent is listening. This port defaults 
to 8800. 

There are two connections made from each Agent to the Master, one to a Master 
server process named sqa7vsrv and another to a Master server process named 
sqa7ssrv. These two server processes each listen on a separate port. They do not bind 
to a specific port, but instead let the Master’s operating system choose a port 
dynamically. The Master then communicates these port values to the Agent du
run initialization. (N ote that all Agents connect to the same two ports on the 
Master.) It is these two dynamically chosen ports on the Master which cause fire
administration problems because which two ports will be used cannot be determ
in advance.

Control is achieved using the optional presence of network services (the traditi
TCP/U DP network services defined in an /etc/services file, not to be confused 
an N T service). On N T, the services file is found in 
Drive\WIN N T\system32\drivers\etc\services. There is one entry per line, listing 
service name, the port number, and the protocol (TCP or U DP).

Specifically, control over the ports is provided as follows:

sqa7vsrv binds to the port (in priority order):

1 . The value of the TCP service named psmstr_v, if defined.

Otherwise,

2 . A port dynamically chosen by the system.

sqa7ssrv binds to the port (in priority order):

1 . The value of the TCP service named psmstr_s, if defined.

Otherwise,

2 . A port dynamically chosen by the system.

N ote that the ports defined by these two services are independent. That is, th
not need to be adjacent, nor related to the well-known PerformanceStudio Age
port of 8800. They do need to be unique. We suggest using the ports 8801 and
if they are not used for some other service on the Master.

For example, if you want the ports on the Master to be 8801 and 8802, add two
to the services file:

psmstr_s8801/tcp# PerformanceStudio Master S server
psmstr_v8802/tcp# PerformanceStudio Master V server
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Setting  U p IP A liasing
In addition, the psagent network service has been added to control the port at which 
the PerformanceStudio Agent listens. If the well-known Agent port of 8800 is 
already in use by another application on one or more Agent computers, an alternate 
port needs to be specified using the psagent service.

The psagent service is put in the services file in the same way that the network 
services psmstr_v and psmstr_s are put in the file. The difference is that the psagent 
service must be defined on the Master and all Agents used in the testing run, and 
must be identical for all systems. The Agents must be rebooted after altering the 
service file.

For example, if you want the Agent to list on port  8888, add a line to the services file 
on both the Master and the Agent:

psagent8888/tcp# PerformanceStudio Agent

Setting Up IP Aliasing

LoadTest provides IP aliasing, which allows many IP addresses to be assigned to the 
same physical system. Every virtual user can be assigned a different IP address to 
realistically emulate your user community. The requests generated by these virtual 
users receive responses back from the Web server with timing characteristics and 
validation recorded intact.

To use IP aliasing on any particular computer, the system administrator must set up 
the IP addresses on that system. 

For Windows N T, this can be done with the Settings → Control Panel → N etwork 
→ Protocols → TCP/IP Protocol → Properties → Advanced → IP Addresses → 
Add button. 

For U N IX, this can be done with the ifconfig (1) command line utility. See the 
ifconfig manual pages for specific details appropriate to that operating system. To 
set up large numbers of IP addresses it is convenient to use a Perl or U N IX shell 
script. An example Korn shell script for this purpose named ipalias_setup can 
be found in the bin directory of U N IX Agent installs. (You must have root privileges 
to set up IP aliases with ifconfig.)

Be careful when assigning IP addresses to a computer for obvious reasons, such as 
conflicting with existing IP addresses as well as routing considerations. We 
recommend that IP addresses be assigned by a qualified network administrator. 

After IP Aliasing is set up, simply open a schedule, click the Runtim e button, and 
select the Enable IP Aliasing check box.
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If IP Aliasing is selected in the schedule, at the beginning of a run LoadTest software 
on each computer (Master or Agent) queries the system for all available IP addresses. 
Each VU  user scheduled to run on that computer is assigned an IP address from that 
list, in round-robin fashion. In other words, if there are more VU  users on a 
computer than IP addresses, an IP address is assigned to multiple VU  users. If there 
are fewer VU  users than IP addresses, some IP addresses are not used. This approach 
optimizes the distribution of IP addresses regardless of the number of users 
scheduled on any particular computer, and frees you from involvement or worry 
about matching IP addresses to specific users.
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Standard Datapool Data Types
This appendix contains:

ã A table of standard data types

ã A table of minimum and maximum ranges for the standard data types

Standard Data Type Table

Data types supply datapool columns with their values. You assign data types to 
datapool columns when you define the columns in the Datapool Specification 
dialog box. 

The standard data types listed in the following table are included with your Rational 
Test software. U se these data types to help populate the datapools you create.

The standard data types (plus any user-defined data types you create) are listed in 
the Datapool Specification dialog box under the heading Type. Type and the other 
datapool column definitions (such as Length and Interval) referenced in the 
following table are some of the definitions you set in this dialog box.

N ote that related data types (such as cities and states) are designed to supply 
appropriate pairings of values in a given datapool row. For example, if the 
Cities - U .S. data type supplies the value Boston to a row, the State Abbrev. - U .S. 
data type supplies the value MA to the row.
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Standard data type name Description Examples

Address - Street Street numbers and names. N o period after 
abbreviations.

20 Maguire Road
860 S Los Angeles St 8th Fl
75 Wall St 22nd Fl

Cities - U .S. N ames of U .S. cities. Lexington
Cupertino
Raleigh

Company N ame Company names (including designations 
such as Co and Inc where appropriate).

Rational Software Corp
TSC Div Harper Lloyd Inc
Sofinnova Inc

Date - Aug 10, 1994 Dates in the format shown.

The day portion of the string is always two 
characters. Days 1 through 9 begin with a 
blank space.

To include the comma ( , ) as an ordinary 
character rather than as the .csv file delimiter, 
the dates are enclosed in double quotes when 
stored in the datapool. 

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
01011900 and M aximum  to 12312050.

Oct 8, 1997
Jun 17, 1964
N ov 10, 1978

If the comma is the delimiter, 
the values are stored in the 
datapool as follows:

"Oct 8, 1997"
"Jun 17, 1964"
"N ov 10, 1978"

Date - August 10, 1994 Dates in the format shown.

The day portion of the string is always two 
characters. Days 1 through 9 begin with a 
blank space.

To include the comma ( , ) as an ordinary 
character rather than as the .csv file delimiter, 
the dates are enclosed in double quotes when 
stored in the datapool.

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
01011900 and M aximum  to 12312050.

October 8, 1997
June 17, 1964
N ovember 10, 1978

If the comma is the delimiter, 
the values are stored in the 
datapool as follows:

"October 8, 1997"
"June 17, 1964"
"N ovember 10, 1978"
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Date - MM/DD/YY Dates in the format shown. 

You can only specify a range of dates in the 
same century (that is, the year in M aximum  
must be greater than the year in M inimum ).

To include the slashes ( / ) as ordinary 
characters rather than as the .csv file 
delimiter, the dates are enclosed in double 
quotes when stored in the datapool.

To set a range of dates from January 1, 1900 
through December 31, 1999, set M inimum  to 
010100 and M aximum  to 123199.

10/08/97
06/17/64
11/10/78

If the slash is the delimiter, 
the values are stored in the 
datapool as follows:

"10/08/97"
"06/17/64"
"11/10/78"

Date - MM/DD/YYYY Dates in the format shown. 

To include the slashes ( / ) as ordinary 
characters rather than as the .csv file 
delimiter, the dates are enclosed in double 
quotes when stored in the datapool.

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
01011900 and M aximum  to 12312050.

10/08/1997
06/17/1964
11/10/1978

If the slash is the delimiter, 
the values are stored in the 
datapool as follows:

"10/08/1997"
"06/17/1964"
"11/10/1978"

Date - MMDDYY Dates in the format shown. 

You can only specify a range of dates in the 
same century (that is, the year in M aximum  
must be greater than the year in M inimum ).

To set a range of dates from January 1, 1900 
through December 31, 1999, set M inimum  to 
010100 and M aximum  to 123199.

100897
061764
111078

Date - MM-DD-YY Dates in the format shown. 

You can only specify a range of dates in the 
same century (that is, the year in M aximum  
must be greater than the year in M inimum ).

To set a range of dates from January 1, 1900 
through December 31, 1999, set M inimum  to 
010100 and M aximum  to 123199.

10-08-97
06-17-64
11-10-78

 (Continued) 
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Date - MMDDYYYY Dates in the format shown. 

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
01011900 and M aximum  to 12312050.

10081997
06171964
11101978

Date - MM-DD-YYYY Dates in the format shown. 

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
01011900 and M aximum  to 12312050.

10-08-1997
06-17-1964
11-10-1978

Date - YYYY/MM/DD Dates in the format shown. 

To include the slashes ( / ) as ordinary 
characters rather than as the .csv file 
delimiter, the dates are enclosed in double 
quotes when stored in the datapool.

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
19000101 and M aximum  to 20501231.

1997/10/08
1964/06/17
1978/11/10

If the slash is the delimiter, 
the values are stored in the 
datapool as follows:

"1997/10/08"
"1964/06/17"
"1978/11/10"

Date - YYYYMMDD Dates in the format shown. 

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
19000101 and M aximum  to 20501231.

19971008
19640617
19781110

Date, Julian - DDDYY Dates in the format shown. DDD is the total 
number of days that have passed in a year. 
For example, January 1 is 001, and February 
1 is 032.

To set a range of dates from January 1, 1900 
through December 31, 1999, set M inimum  
to 00100 and M aximum  to 36599.

28197
16964
31478

Date, Julian - DDDYYYY Dates in the format shown. DDD is the total 
number of days that have passed in a year. 
For example, January 1 is 001, and February 
1 is 032.

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
0011900 and M aximum  to 3652050.

2811997
1691964
3141978

 (Continued) 
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Date, Julian - YYDDD Dates in the format shown. DDD is the total 
number of days that have passed in a year. 
For example, January 1 is 001, and February 
1 is 032.

To set a range of dates from January 1, 1900 
through December 31, 1999, set M inimum  to 
00001 and M aximum  to 99365.

97281
64169
78314

Date, Julian - YYYYDDD Dates in the format shown. DDD is the total 
number of days that have passed in a year. 
For example, January 1 is 001, and February 
1 is 032.

To set a range of dates from January 1, 1900 
through December 31, 2050, set M inimum  to 
1900001 and M aximum  to 2050365.

1997281
1964169
1978314

Float - X.XXX Positive and negative decimal numbers in the 
format shown.

Set Length to the number of decimal places 
to allow (up to 6).

Set M inimum  and M aximum  to the range of 
numbers to generate.

To generate numbers with more than 9 digits 
(the maximum allowed with the Integers - 
Signed data type), use the Float - X.XXX data 
type and set D ecimals to 0.

243.63918
-95.99
155075028157503

Float - X.XXXE+ N N Positive and negative decimal numbers in the 
exponential notation format shown.

Set Length to the number of decimal places 
to allow (up to 6).

Set M inimum  and M aximum  to the range of 
numbers to generate.

4.0285177E+ 068
-3.2381443E+ 024
8.8373255E+ 119

Gender Either M or F, with no following period. M
F

H exadecimal H exadecimal numbers. 1d6b77
ff
3824e7d
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Integers - Signed Positive and negative whole numbers. This is 
the default data type.

To include negative numbers in the list of 
generated values, set M inimum  to the lowest 
negative number you want to allow.

Maximum range: 

ã M inimum  =  -999999999 (-999,999,999)
ã M aximum  =  999999999 (999,999,999)

For larger numbers, use a float data type.

If you do not specify a range, the default 
range is 0 through 999,999,999.

U se this data type to generate unique data in 
a datapool column (for example, when you 
need a “key” field of unique data). You can 
also use Read From File and user-defined 
data types to generate unique data.

1349
-392993
441393316

N ame - Middle Masculine and feminine middle names. 

If the middle name is preceded by a field with 
masculine or feminine value (such as a 
masculine or feminine first name), the 
middle name is in the same gender category 
as the earlier field.

Richard
Theresa
Julius

N ame - Prefix (e.g., Mr) Mr or Ms, with no following period.

If the name prefix is preceded by a field with 
masculine or feminine value (such as a 
masculine or feminine gender designation), 
the name prefix is in the same gender 
category as the earlier field.

Mr
Ms

N ames - First Masculine and feminine first names. 

If the first name is preceded by a field with 
masculine or feminine value (such as a 
masculine or feminine name prefix), the first 
name is in the same gender category as the 
earlier field.

Richard
Theresa
Julius

N ames - Last Surnames. Swidler
Larned
Buckingham

 (Continued) 
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N ames - Middle Initial Middle initials only, with no following 
period.

B
M
L

Packed Decimal A number where each digit is represented by 
four bits. Digits are non-printable.

N ote that commas and other characters that 
may be used to represent a packed decimal 
number may cause unpredictable results 
when the datapool file is read.

N on-printable digits.

Phone - 10 Digit Telephone area codes, appropriate 
exchanges, and numbers.

7816762400
4123818993
5052658498

Phone - Area Code Telephone area codes. To generate correct 
area code lengths, set Length to 3.

781
412
505

Phone - Exchange Telephone exchanges. To generate correct 
exchange lengths, set Length to 3.

676
381
265

Phone - Suffix Four-digit telephone numbers (telephone 
numbers without area code or exchange). To 
generate correct telephone number suffix 
lengths, set Length to 4.

2400
8993
8498

Random Alphabetic String Strings of random upper case and lower case 
letters.

Length determines the number of characters 
generated.

AQSEFuOZU IU IpAGsEM
DESieAiRFiEqiEIDiicEw
edEIDiIcisewsDIEdgP

Random Alphanumeric 
String

Strings of random upper case and lower case 
letters and digits. 

Length determines the number of characters 
generated.

AYcH I8WmeMeM0AK4
H Sk9vGAQ U 79esDE
7Eeis93k4ELXie7S32siDI4E
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Read From File Assigns values from an ASCII text file to the 
datapool column. For example, you could 
export a database column to a text file, and 
then use this data type to assign the values in 
the file to a datapool column.

You can use this data type to generate unique 
data. You can also use the Integers - Signed 
and user-defined data types to generate 
unique data.

For information about using this data type, 
see Creating a Column of Values Outside Rational 
Test on page 6-48.

Any values in an ASCII text 
file.

Space Character An empty string. ""

State Abbrev. - U .S. Two-character state abbreviations. MA
CA
N C

String Constant A constant with the value of Seed. The 
datapool column is filled with this one 
alphanumeric value.

1234
AAA
1b1b

Time - H H .MM.SS Times in the format shown. H ours range 
from 00 (midnight) through 23 (11 pm).

To set a range of times from midnight to 
2 pm, set M inimum  to 0 and M aximum  to 
140000.

00.00.00 (midnight)
11.14.38
21.44.19

Time - H H :MM:SS Times in the format shown. H ours range 
from 00 (midnight) through 23 (11 pm).

To include the colons ( : ) as ordinary 
characters rather than as the .csv file 
delimiter, the dates are enclosed in double 
quotes when stored in the datapool.

To set a range of times from midnight to 
2 pm, set M inimum  to 0 and M aximum  to 
140000.

00:00:00 (midnight)
11:14:38
21:44:19

If the colon is the delimiter, 
the values are stored in the 
datapool as follows:

"00:00:00" (midnight)
"11:14:38"
"21:44:19"

Time - H H MMSS Times in the format shown. H ours range 
from 00 (midnight) through 23 (11 pm).

To set a range of times from midnight to 
2 pm, set M inimum  to 0 and M aximum  to 
140000.

000000 (midnight)
111438
214419

 (Continued) 

Standard data type name Description Examples
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D ata  Type Ranges
Data Type Ranges

These are the minimum and maximum ranges for the standard data types:

Zip Code - 5 Digit Five-digit U .S. postal zip codes. To generate 
the correct zip code lengths, set Length to 5.

02173
95401
84104

Zip Code - 9 Digit N ine-digit U . S. postal zip codes. 021733104
954012694
841040190

Zip Code - 9 Digit with Dash N ine-digit U .S. postal zip codes with a dash 
between the fifth and sixth digits.

02173-3104
95401-2694
84104-0190

Zoned Decimal Zoned decimal numbers. 3086036
450
499658196

 (Continued) 

Standard data type name Description Examples

Type of range Limitation

Maximum hours 23

Maximum minutes 59

Maximum seconds 59

Maximum two-digit year 99

Maximum four-digit year 9999

Maximum months 12

Minimum six-digit date 010100 (January 1, 00)

Maximum six-digit date 123199 (December 31, 9999)

Minimum eight-digit date 01010000 (January 1, 0000)

Maximum eight-digit date 12319999 (December 31, 9999)

Minimum negative integer (Integers - Signed) -999999999 (-999,999,999)
C-9



Standard  D atapool D ata  Types
Maximum positive integer (Integers - Signed) 999999999 (999,999,999)

Maximum decimal places (Float data types) 6

Male/Female title Mr, Ms

Gender designation M, F

 (Continued) 

Type of range Limitation
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Glossary
action object – In TestFactory, an object in the application map that represents
action to which a control in the application responds. Typical actions are mous
left-click, mouse right-click, and mouse left-double-click; the corresponding act
objects in the application map are LeftClick, RightClick, and LeftDoubleClick.

ActiveX  control – A reusable software control that takes advantage of Object Link
and Embedding (OLE) and Component Object Modeling (COM) technologies
Developers can use ActiveX controls to add specialized functions to application
software development tools, and Web pages. Robot can test ActiveX controls in
applications.

actual results – In a functional test, the outcome of testing an object through a 
verification point in a GU I script. Actual results that vary from the recorded base
results are defects or intentional changes in the application. See also baseline results.

Adm inistrator – See Rational Administrator. 

Agent computer – In LoadTest, a computer that has the Rational Agent softwar
installed and that plays back a virtual user or GU I script. In a LoadTest schedu
you can identify the Agent computer on which to run a script. See also Rational Agent.

API recording – In Robot, a virtual user recording method that captures API cal
between a specific client application and a server. These calls are captured on 
client computer. 

application m ap – In TestFactory, a hierarchical list of controls and actions in th
application-under-test, as well as the states of the application-under-test and th
transitions between those states. An application map can include U I objects an
action objects, as well as TestFactory objects such as Pilots, Test Suites, and s

application-under-test – The software being tested. See also system-under-test.

Asset Browser – A window that displays testing resources such as builds, querie
scripts, schedules, reports, report output, and logs. The Asset Browser is availa
TestManager and LoadTest. 

AU T – See application-under-test.
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autom ated testing – A testing technique in which you use software tools to repla
repetitive and error-prone manual work. Automated testing saves time and ena
reliable, predictable, and accurate testing process.

AutoPilot – In TestFactory, a tool for running scripts, Test Suites, and Pilots. T
scripts and Test Suites can run on your local computer or on computers in the
Lab. The Pilots run on your local computer, and the scripts they generate can ru
your local computer or on computers in the Test Lab.

base state – In TestFactory, the known, stable state in which you expect the 
application-under-test to be at the start of each script segment. See also script segment.

baseline results – In a functional test, the outcome of testing an object through
verification point in a GU I script. The baseline results become the expected sta
the object during playback of the script. Actual test results that vary from the bas
results are defects or intentional changes in the application. See also actual results.

best script – In TestFactory, an optimized script generated by a Pilot. A best sc
contains the fewest number of script segments that provide the most coverage 
source code or user interface in the application-under-test. 

breakpoint – A feature of the Robot debugger. When you assign a breakpoint t
line of code, and then run the script in the debugger environment, the script s
executing at that line of code. Control returns to you, and the breakpoint line i
displayed. From here you can view variables, perform other debugging activities
continue executing the script. 

build – A version of the application-under-test. Typically, developers add new 
features or enhancements to each incremental build. As team members test a
they enter defects against those features that do not behave as expected. You 
TestManager to define and manage builds. 

built-in data  test – A data test that comes with Robot and is used with the Obje
Data verification point. A data test uses a specific property of the object, in 
conjunction with other parameters, to determine the data to capture. Although
built-in data tests cannot be edited, renamed, or deleted, they can be copied an
edited, and they can be viewed. See also custom data test.

ClearQ uest – See Rational ClearQuest. 

client/server – An architecture for cooperative processing in which the software
tasks are split between server tasks and client tasks. The client computer send
requests to the server, and the server responds.

code coverage – In TestFactory, the percentage of code that is tested by a scrip
This percentage is based on the portion of the code that a script touches, relat
all code in the application-under-test. A Pilot can use code coverage to determin
best script for a run. See also UI coverage.
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com m and ID  – In LoadTest’s VU  language, an identifier for a command. Robot
automatically assigns a unique command ID, composed of an alphanumeric p
and a three-digit number, to each emulation command. Because command ID
appear in both the virtual user script and the LoadTest report output, they enabl
to determine the relationship between an emulation command and its respons
times.

com m and ID  prefix – In LoadTest, a prefix for a unique emulation command ID
The prefix defaults to the script name (up to the first seven characters). Howev
you can define the prefix in the Generator tab of the Virtual U ser Record Optio
dialog box.

custom  data  test – A customer-defined data test used with the Object Data 
verification point. A data test uses a specific property of the object, in conjunctio
with other parameters, to determine the data to capture. Custom data tests ar
created within your organization and are stored in the repositories that were ac
when they were created. They can be edited, renamed, and deleted. See also built-in 
data test.

data  test – A test that captures the data of an object with the Object Data verifica
point. See also built-in data test and custom data test.

datapool – A source of test data that GU I scripts and virtual user scripts can dr
from during playback. You can automatically generate datapools using TestMan
or you can import datapool data from other sources such as your database. 

dependency – In LoadTest, a method of coordinating an object in a schedule w
an event. For example, if the script Query is dependent upon the script Conne
then Connect must finish executing before Query can begin executing. See al
event.

distributed architecture – Architecture in which computer systems work togethe
and communicate with each other across LAN , WAN , or other types of networ
A client/server system is an example of distributed architecture.

distributed functional test – In LoadTest, a test that uses multiple Agent compute
to execute multiple GU I scripts written in the SQABasic language. 

dynam ic load balancing selector – A type of selector in a LoadTest schedule. Item
in the selector, such as scripts, are executed according to a weight that you set

em ulation com m ands – VU  language statements or commands that emulate cli
activity, evaluate the server’s responses, and perform communication and timin
operations. LoadTest stores the results of emulation commands in a log file, w
you can view from the LogViewer. 
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em ulation functions – VU  language functions that emulate client activity and 
evaluate the server’s responses. U nlike emulation commands, emulation func
do not perform communication and timing operations, and they are not logged

environm ent control com m ands – VU  language commands that let you control 
virtual user’s environment by changing the VU  environment variables. For exam
you can set the level of detail that is logged or the number of times that virtual u
attempt to connect to a server.

event – An item in a LoadTest schedule upon which another item is dependen
For example, if the script Connect sets an event and the script Query depends o
event, Connect must finish executing before Query can begin executing. See a
dependency.

external script – A script that runs a program created with any tool. You plan an
run external scripts in TestManager.

fixed user group – In LoadTest, a group that contains a scalable number of use
When you create a fixed user group, you indicate the maximum number of user
you will run in the group. Typically, you use fixed user groups in functional test
which do not add a workload to the system.

flow control statem ents – In the VU  and SQABasic languages, statements that 
you add conditional execution structures and looping structures to a script. 

functional test – A test to determine whether a system functions as intended. 
Functional tests are performed on GU I objects and objects such as hidden 
DataWindows and Visual Basic hidden controls. 

Grid Com parator – The Robot component for reviewing, analyzing, and editing
data files for text and numeric verification points in grid formats. The Grid 
Comparator displays the differences between the recorded baseline data and t
actual data captured during playback.

GU I script – A type of script written in the SQABasic language. It contains GU I 
actions such as keystrokes and mouse clicks. Typically, a GU I script also conta
verification points for testing objects over successive builds of the application-un
test.

GU I user – The type of user that is emulated when a GU I script is executed. 
Only one GU I user at a time can run on a computer.

hidden object – An object that is not visible through the user interface. H idden 
objects include objects with a visible property of False and objects with no GU I
component.

ID E – Integrated Development Environment. This environment consists of a se
integrated tools that are used to develop a software application. Examples of ID
supported by Robot include Oracle Forms, PowerBuilder, Visual Basic, and Ja
Glossary-14
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Im age Com parator – The Robot component for reviewing and analyzing bitma
image files for Region Image and Window Image verification points. The Image
Comparator displays differences between the recorded baseline image and the
image captured during playback. The Image Comparator also displays unexpe
active windows that appear during playback.

instrum entation – In TestFactory, the process of inserting code coverage coun
into the application-under-test. These counters record how much code is exec
during a script run. See also object code instrumentation and source code instrumentation.

load – See workload.

load balancing – See workload balancing. 

LoadTest – See Rational LoadTest.

log – A repository object that contains the record of events that occur while pla
back a script or running a schedule. A log includes the results of all verification po
executed as well as performance data that can be used to analyze the system’s
performance.

LogViewer – See Rational LogViewer.

low-level recording – A recording mode that uses detailed mouse movements a
keyboard actions to track screen coordinates and exact timing. During playbac
actions occur in real time, exactly as recorded.

m anual script – A set of testing instructions to be run by a human tester. The 
script can consist of steps and verification points. You create manual scripts in 
TestManager.

M aster com puter – A computer that executes LoadTest. From this computer, y
create, run, and monitor schedules. When the run is finished, you use it to ana
test results.

m ix-ins – See Pilot mix-ins.

network recording – In Robot, a virtual user recording method that records pack
level traffic. This traffic is captured on the wire. 

next available selector – In LoadTest schedules, a selector that distributes each i
such as a script, delay, or other selector to an available computer or virtual user
type of selector is used in a GU I schedule. The next available selector parcels o
items sequentially, based on which computers or virtual users are available.
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object – An item on a screen, such as a window, dialog box, check box, label, o
command button. An object has information (properties) associated with it and
actions that can be performed on it. For example, information associated with 
window object includes its type and size, and actions include clicking and scroll
In some development environments, a term other than object is used. For example, 
the Java environment uses component, and the HTML environment uses element.

object code instrum entation – In TestFactory, the process of inserting code 
coverage counters into the executable file of the application-under-test. These
counters record how much of the program a script tests. See also instrumentation and 
source code instrumentation.

O bject-O riented Recording®  – A script recording mode that examines objects in
the application-under-test at the Windows layer. Robot uses internal object nam
identify objects, instead of using mouse movements or absolute screen coordi

O bject Properties Comparator – The Robot component that you use to review,
analyze, and edit the properties of objects captured by an Object Properties 
verification point. The Object Properties Comparator displays differences betw
recorded baseline data and the actual data captured during playback.

O bject Scripting com mands – A set of SQABasic commands for accessing an 
application’s objects and object properties. You add Object Scripting command
manually when editing a script.

O bject Testing®  – A technology used by Robot to test any object in the applicati
under-test, including the object’s properties and data. Object Testing lets you t
standard Windows objects and IDE-specific objects, whether they are visible in
interface or hidden.

O CI  – Object Code Insertion. The Rational technology used in TestFactory to 
instrument object code and measure how much of the application-under-test a 
tests. See also code coverage and object code instrumentation.

perform ance test – A test that determines whether a multi-client system perform
within user-defined standards under varying loads. Performance tests are alway
from a schedule in LoadTest.

Pilot – In TestFactory, a tool for generating scripts automatically. 

Pilot m ix-ins – In TestFactory, a list of Pilots that are executed on a random ba
during the run of a lead Pilot. Mix-ins are useful for randomly testing multiple ar
of the application-under-test. To make tests more realistic, you can combine mi
and scenarios. 

Pilot scenario – An ordered list of Pilots that are executed during the run of a Pi
A Pilot scenario is useful for testing U I objects that need to be exercised in a spe
order. To make tests more realistic, you can combine scenarios and mix-ins.
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project – A collection of data, including test assets, defects, requirements, and 
models, that can facilitate the development and testing of one or more softwar
components. 

proxy recording – In Robot, a virtual user recording method that captures the cli
server conversation on the network wire rather than on the client computer. P
recording allows Robot to capture network packets that are not visible to it dur
network recording — for example, if the client and server are in different netwo
segments.

query – A request for information stored in the repository. A query consists of a fi
and several visible attributes — the columns of data to display, the width of the
column, and the sort order.

random  selector – A type of selector in a LoadTest schedule. Items in the selec
such as scripts, are randomly executed. Random selectors can be with replace
where the odds are the same, or without replacement, where the odds change
each iteration. 

Rational Adm inistrator – The component for creating and maintaining repositori
projects, users, groups, computers, and SQL Anywhere servers.

Rational Agent – The LoadTest software that resides on a shared network drive
runs on each computer where testing occurs. The entries specified in a schedu
back on the Agent computer, which reports on their progress and status as the
See also Agent computer.

Rational ClearQ uest – The Rational product for tracking and managing defects a
change requests throughout the development process. With ClearQuest, you 
manage every type of change activity associated with software development, 
including enhancement requests, defect reports, and documentation modifica

Rational LoadTest – The Rational Test component for running performance, 
stress, scalability, multi-user, and distributed functional tests on multiple Agent
connected by a network. With LoadTest, you can initiate test runs and monitor 
from a master computer that manages the test process. LoadTest is available o
Rational Suite PerformanceStudio.

Rational LogViewer – The Robot component for displaying logs, which contain th
record of events that occur while playing back a script or running a schedule. A
the component from which you start the four Comparators.

Rational Perform anceArchitect – The Rational component that lets you test the
performance of COM/DCOM applications. With Rational PerformanceArchitec
you can create a Rose sequence or collaboration diagram, convert it to a virtua
script, and then use Rational Suite PerformanceStudio to edit the script and ru
performance tests.
Glossary-1 7
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Rational repository – A database that stores application testing information, such
test requirements, scripts, and logs. All Rational Suite TestStudio and Rational S
PerformanceStudio products and components on your computer update and 
retrieve data from the same connected repository. A repository can contain eith
a Microsoft Access or a Sybase SQL Anywhere database.

Rational RequisitePro – The Rational product for organizing, managing, and 
tracking the changing requirements of your system.

Rational Robot – The Rational product for recording, playing back, debugging, a
editing scripts. 

Rational SiteCheck – The Robot component for managing your intranet or Wor
Wide Web site. You can use SiteCheck to visualize the structure of your Web s
and you can use it with Robot to automate Web site testing.

Rational Synchronizer – The Rational tool that ensures the consistency of data 
across several Rational products.

Rational TestAccelerator – An agent application that executes scripts. TestFacto
uses computers running TestAccelerator as remote machines on which to run
automated distributed tests.

Rational TestFactory – The Rational Test component for mapping an applicatio
under-test and generating scripts automatically. TestFactory is available in Rat
Suite TestStudio and Rational Suite PerformanceStudio.

Rational TestM anager – The Robot component for managing the overall testin
effort. You use it to define and store information about test documents, 
requirements, scripts, schedules, and sessions.

Report Layout Editor – The TestManager component for customizing the layout
reports.

repository – See Rational repository. 

RequisitePro – See Rational RequisitePro. 

Robot – See Rational Robot.

scalable user group – In LoadTest, a group that contains a varying number of use
When you create a scalable user group, you assign it a percentage of the total 
workload. Assume you have a scalable user group that is 50 percent of the work
If you run a test with 10 users, the group will contain 5 users. If you run a test w
100 users, the group will contain 50 users.

scenario – In LoadTest, a modular group of scripts and other items in a schedule
is used by more than one user group. A scenario can contain scripts, delays, a
synchronization points. 
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scenario – See Pilot scenario.

schedule – In LoadTest, structure that you create to specify how scripts should
played back. A schedule can contain GU I scripts and virtual user scripts, and c
indicate the number of times to repeat a script and the computer on which the s
will run. In performance testing, a schedule is used to create a workload. In 
distributed functional testing, a schedule is used to distribute scripts among va
computers.

script – A set of instructions used to navigate through and test an application. Y
can generate scripts in a variety of ways. You can use Robot to record scripts us
functional testing and performance testing. You can also use TestManager to c
and manage manual scripts, and to manage external scripts created with a third
testing tool. A script can have properties associated with it, such as the purpose 
script and requirements for the script. See also external script, GUI script, manual script, 
and virtual user script.

script outline – In TestFactory, the readable version of a script. A script outline 
contains a description of the actions that Robot performs while running the scr

script segment – In TestFactory, a section of a script that tests a particular 
element of product functionality. A Pilot generates a script segment by starting
application-under-test in a base state, navigating through the part of the produc
you are testing, and returning the application-under-test to the base state. See
base state.

seed – An initial number fed to a random number generator. U sing the same s
produces the same series of random numbers. In LoadTest, you use seeds to ge
think times.

selector – An item that you insert in a LoadTest schedule to indicate how often 
in what order to run scripts. 

sequentia l selector – In a LoadTest schedule, a type of selector that executes e
script, delay, or other item in the same order in which it appears in the schedu

session – In virtual user recording, one or more scripts that you record from the t
you begin recording until the time you stop recording. Typically, the scripts in a
session represent a logical flow of tasks for a particular user, with each script 
representing one task. For example, a session could be made up of three scrip
login, testing, and logout. In TestFactory, a session is the period of time that the 
TestFactory application or a window is open.

shared variable – An integer variable that multiple scripts and multiple virtual use
can read and write to. You can see the value of a shared variable while monitor
LoadTest schedule. For example, you can set a shared variable as a flag to end
playback session. Each script can check the flag to see if the session should end.
that flag is set, exit tasks can be performed.
Glossary-1 9
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shell script – A script that calls or groups several other GU I scripts and plays th
back in sequence. Shell scripts provide the ability to create comprehensive test
then store the results in a single log.

SiteCheck – See Rational SiteCheck.

source code instrum entation – In TestFactory, the process of inserting code int
the source code of the application-under-test. This code measures how much 
source code a script tests. See also instrumentation and object code instrumentation.

SQ ABasic – The Robot scripting language for recording GU I actions 
and verifying GU I objects. SQABasic contains most of the syntax rules and cor
commands that are contained in the Microsoft Basic language. In addition, 
SQABasic has commands that are specifically designed for automated testing. 
See also VU .

stable load – In LoadTest, a condition that occurs when a specified number of 
virtual users have logged on to the system-under-test and are active. When the
load criterion is met, LoadTest begins measuring the load.

streak – When running a virtual user schedule in LoadTest, a series of success
failures for emulation commands. You can see a streak while monitoring a sche

structura l test – A test to determine whether the structure of a Web site is consis
and complete. A structural test ensures that an application’s interdependent ob
are properly linked together. You perform a structural test using SiteCheck.

synchronization point – In LoadTest, a place where emulated virtual users stop a
wait until all other synchronized users reach that point. When all users reach th
synchronization point, they are released and continue executing. 

Synchronizer – See Rational Synchronizer. 

system  tuning – In LoadTest, the process of optimizing a system’s performance
changing hardware resources and software configuration parameters while usi
constant workload.

system -under-test – The system being tested. This includes the computers and
software that can generate a load on the system, networks, user interfaces, CPU
memory. See also application-under-test.

test assets – The resources that facilitate the planning or development phases
the testing effort. Examples of test assets include scripts, schedules, sessions, 
documents, and test requirements.

test development – The process of developing tests to verify the operation of a 
software application. This includes creating scripts that verify that the applicatio
under-test functions properly. Test development lets you establish the baselin
expected behavior for the application-under-test.
Glossary-20
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test docum ents – Test plans, project schedules, resource requirements, and an
other documents that are important to your project. You develop your test 
documents using your own word processing or scheduling program; you then
reference the name and location of the document in TestManager. This lets 
members of the test and development team locate documents quickly.

Test Lab – A collection of computers on which TestAccelerator is running. In 
TestFactory, you can distribute the scripts associated with a Pilot, a Test Suite, o
AutoPilot to run on computers in the Test Lab. See also Rational TestAccelerator. 

Test Suite – In TestFactory, a tool for running a collection of scripts as a group.

TestAccelerator – See Rational TestAccelerator. 

TestFactory – See Rational TestFactory.

TestM anager – See Rational TestManager.

Text Com parator – The Robot component for reviewing, analyzing, and editing
data files for text and numeric verification points in any format except grids. Th
Text Comparator displays the differences between the recorded baseline resul
the actual results.

think tim e – In virtual user and GU I scripts, think times are delays that simulate
user’s pauses to type or think while using an application. With virtual user scrip
LoadTest calculates the think time at runtime, based on think time VU  environm
variables that are set in the script. You can set a maximum think time in Robot. W
GU I scripts, Robot uses the actual delays captured between keystrokes, menu
choices, and other actions.

transaction – In LoadTest, a logical unit of work performed against a server. Fo
example, submitting a search query or submitting a completed form to a Web s
are both transactions.

transaction rate – In LoadTest, the playback speed calculated as a function of 
number of transactions per unit of time. For example, if a script contains one 
transaction, and each script is started at half-second intervals, your transaction
would be 2 per second. 

transactor – In LoadTest, an item that you insert in a LoadTest schedule to indi
the number of user-defined transactions that a virtual user performs in a given
period.

U I coverage – In TestFactory, the percentage of objects in the application map 
are tested by a Pilot-generated script. This percentage is the proportion of U I ob
that the script touches, relative to all U I objects available to the Pilot. A Pilot can
U I coverage to determine the best script for a run. See also code coverage.
Glossary-2 1
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U I object properties – Attributes of object classes and U I objects that TestFacto
uses to map applications and generate scripts.

unexpected active window – A window that appears during script playback that 
interrupts the script playback process and prevents the expected window from b
active. For example, an error message generated by the application-under-tes
unexpected active window. You can view unexpected active windows in the Im
Comparator.

user group – In LoadTest, a collection of users that execute similar tasks and 
generate the same basic workload. Accountants and data entry operators are ex
of user groups.

verification – The process of comparing the test results from the current build of
software to its baseline results. 

verification point – A point in an SQABasic script that confirms the state of one 
more objects. During recording, a verification point captures object information
from the application-under-test and stores it as the baseline. During playback,
verification point recaptures the object information and compares it to the base
In a manual script, a verification point is a question about the state of the applica
under-test.

virtua l user – In LoadTest, a type of user that is emulated when a virtual user sc
is executed. A computer can run multiple virtual users simultaneously.

virtual user script – A type of script written in the VU  language. Virtual user scrip
contain client/server requests and responses as well as user think times.

VU  – The Robot scripting language for recording a client’s requests to a server
VU  provides most of the syntax rules and core commands available in the C 
programming language. In addition, VU  has emulation commands and functio
that are specifically designed for automated performance testing. See also SQABasic.

wait state – A delay or timing condition that handles time-dependent activities.

workload – In LoadTest, the set of all activities that users perform in an actual 
production setting of the system-under-test. You can use LoadTest to emulate
workload.

workload balancing – In LoadTest, the act of distributing activities so no one syste
or device becomes a bottleneck.

workload m odel – In LoadTest, the workload model is represented as a schedu
You can play back this schedule and analyze the response times.
Glossary-22
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A
Abnormal_term_cnt. See schedules, setting runtime 

information

access order of datapool rows 6-4, 6-17

starting row number 6-18

addresses data type C-2

Agent computers 1-5, 7-6, 7-7

changing settings of 7-37

checking 7-60

controlling port numbers B-3

copying compiled VU  scripts to 7-37

copying files to Master 7-37

location of scripts and datapool files 7-38

monitoring resources of 8-21, 9-3, 9-27

monitoring status of 8-21

Oracle 7-41

preferred user view 8-12

removing files from 7-37

running schedule items on next available 1-10, 
2-20, 7-15

Sybase 7-41

TU XEDO 7-42

AIX Agents 7-41

Analog reports 3-12, 3-14, 9-3, 9-38

including passed and failed responses 9-23, 9-25

analyzing results 2-15, 9-2

API recording 3-2, 3-4

monitoring feedback during 4-7

starting applications 3-25

applications, starting when recording 3-25

ASCII text files 6-48

Asset Browser

copying reports with 9-8

deleting reports with 9-11

opening schedule through 7-29

renaming reports with 9-10

viewing schedule through 7-50

Authentication Datapool 3-29

features 3-32

modifying with Robot during recording 3-31

modifying with TestManager 3-30

when to modify 3-30

automatic protocol filtering 3-17

automatic timing

blocks 2-13, 5-4

emulation commands 5-1

automatically generating values for user-defined data 
types 6-39

autonaming virtual user scripts and sessions 3-25

axes, inverting in graphs 9-31

B
blocks 2-13, 5-4

adding during recording 5-5

nesting 5-6

reporting average time 9-56
Index-1
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C
cached responses, in H TTP scripts 3-20

checking

Agent computers 7-60

schedules 7-59

cities data type C-2

Cleanup_time. See schedules, terminating

client computers

associating with a server 3-8

defining for network or proxy recording 3-27

performance tests and 1-8

removing 3-29

response times 1-11, 2-1

selecting for network recording 3-4

think time distribution and 2-14

client requests

monitoring during recording 4-7

recording 1-6, 4-3

client/server pairs

deleting 3-34, 3-35

identifying for proxy recording 3-8

reassociating with a proxy 3-35

columns in datapools

adding 6-20, 6-22

assigning data types to 6-28

assigning values from a text file 6-48, C-8

configuring through the script 6-18

defining 6-19

deleting 6-33

editing column definitions, in Robot 6-21

editing column definitions, in TestManager 6-32

editing values, in Robot 6-23

editing values, in TestManager 6-34

example of column definition 6-30

field values and 6-45

including or excluding 6-18

length of 6-29

maximum number 6-4, 6-13, 6-20, 6-26, 6-48

names correspond to script variables 6-19, 6-27, 
6-48

setting numeric ranges in 6-29

setting unique values in 6-28, 6-29

unique 6-43

values supplied by data types 6-9

command IDs 3-23

filtering 9-16, 9-33

grouping Status report output by 9-23

in Trace reports 9-50

prefix 3-10

prefix for all commands 3-10

sorting in reports 9-22

TU XEDO prefixes 3-23

comments 2-13

adding to scripts during editing 5-12

adding to scripts during recording 5-12

Compact user view 8-12, 8-13

preferred with Agent computers 8-12

sorting users in 8-27

company names data type C-2

Compare reports 9-3, 9-13, 9-40

absolute comparison 9-40

defining 9-28

graphing 9-22, 9-30

N /A and U ndefined responses 9-44

relative comparison 9-42

setting response ranges 9-22, 9-24

weighted absolute comparison 9-41

weighted relative comparison 9-43

Computer view 8-21

computers

defining for network or proxy recording 3-27

distributing users among 7-8, 7-36

monitoring resources of 2-18, 7-67, 8-21, 9-3, 
9-27

removing 3-29
Index-2
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Repository entry optional 7-7

running users on 7-6, 7-7

selecting a network interface card 3-5

See also Agent computers, Master computers

configuration tests 1-10, 2-10

connections in virtual user recording 3-17, 4-11

constant value data type C-8

contained scripts 4-17, 4-21

contention tests 1-3, 1-9

controlling port numbers B-3

copying

compiled VU  scripts to Agent computers 7-37

datapools 6-35

files from Agent 7-37

graphs 9-8

report output 9-8

reports 9-8

user-defined data types 6-42

virtual user scripts 4-25

CPU  delays, think time 3-16

creating

datapools outside Rational Test 6-44

datapools, in Robot 6-13

datapools, in TestManager 6-25

user-defined data types 6-11

credit card numbers 6-31

.csv datapool files 6-3, 6-36

.csv exported report output 2-18, 9-12

cursors 6-4

disabling wrapping for unique row retrieval 6-43

persistent 6-16

private vs. shared 6-16

starting row number 6-18

wrapping 6-16

custom histograms 8-6

adding groups to 8-37

assigning states to 8-36

deleting groups from 8-38

removing states from 8-37

customer support xv

customizing

histograms 8-36

reports 9-15, 9-22

views 8-27

D
data correlation 3-21

data types

assigning to a datapool column 6-28

copying 6-42

creating 6-11

deleting 6-42

determining which data types you need 6-10

editing values in 6-38

importing user-defined 6-41

list of standard data types C-1

minimum and maximum values C-9

renaming 6-41

role of 6-9

standard and user-defined 6-9

DATAPOO L_CON FIG

editing 6-14

role of 6-14

datapools 6-6

access order 6-4, 6-17

accessing from GU I and virtual user scripts 6-24

adding commands to virtual user scripts 6-13

assigning data types to 6-28

Authentication Datapool 3-29

copying 6-35

creating in Robot 6-13

creating in TestManager 6-25

creating outside Rational Test 6-44

cursors 6-4
Index-3
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data types 6-9

deleting 6-35

deleting columns from 6-33

editing column definitions, in Robot 6-21

editing column definitions, in TestManager 6-32

editing values, in Robot 6-23

editing values, in TestManager 6-34

example of column definition 6-30

example of value generation 6-32

exporting 6-37

files 6-3, 6-36

finding data types for 6-10

generating data, in Robot 6-20, 6-22

generating data, in TestManager 6-26

importing from another project 6-37

importing from outside Rational test 6-35

limits 6-4

maximum number of columns 6-4, 6-13, 6-20, 
6-26, 6-48

naming 6-16

numeric ranges in 6-29

persistent cursors 6-16

planning 2-13, 2-21, 6-6

populating with values, in Robot 6-20, 6-22

populating with values, in TestManager 6-26

private user access to 6-16

renaming 6-35

role of 6-2, 6-5

row access order 6-4, 6-17

script generation option 3-10

setting unique values in 6-28, 6-29

shared user access to 6-16, 7-63

starting row number 6-18

structure 6-45

unique row retrieval 6-43

where stored 6-3

dates

Julian C-4, C-5

setting ranges C-2, C-3, C-4

dates data types C-2, C-3, C-4

debugging virtual user scripts 8-33

decimal numbers 6-29, C-5

default reports

deleting 9-11

restoring 9-12

default settings

for users 7-38

monitor 8-31, 8-34

recording 3-1

reports 9-35

delays 2-8, 7-19, 7-54

deleting from schedules 7-33

inserting into script 7-20

setting in schedule 7-10, 7-20

suppressing 7-63

types of 7-20

deleting

client/server pairs 3-34

datapool column definitions 6-33

datapools 6-35

items from schedules 7-33

proxy computers 3-35

report output 9-11

reports 9-11

schedules 7-51

script from a session 4-22

scripts 4-25

sessions 4-25

user-defined data types 6-42

dependencies 7-52

setting 7-54

directives in datapools 6-18

overriding 6-17
Index-4
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distributed functional tests 1-10, 2-19, 7-7

identifying requirements 2-20

scheduling 2-20

vs. performance tests 2-2

DLB_FREQ. See dynamic load balancing selectors

DLB_TIME. See dynamic load balancing selectors

dynamic data correlation 3-21

dynamic load balancing selectors 7-17

E
editing

datapool column definitions, in Robot 6-21

datapool column definitions, in TestManager 
6-32

datapool values, in Robot 6-23

datapool values, in TestManager 6-34

DATAPOO L_CON FIG 6-14

default monitor settings 8-34

default user settings 7-38

in-line 7-33

schedules 7-31, 7-34

scripts 7-29

user group properties 7-34

user options 7-34

user-defined data type definitions 6-39

user-defined data type values 6-38

empty string data type C-8

emulate VU  emulation commands 9-56, 9-58

emulated users. See GU I users, virtual users, users

emulation commands 3-10

associating with block and timer names 5-5

automatically timed 5-1

displaying success or failure of 8-12, 8-14, 8-27

environment variables. See system environment 
variables, VU  environment variables

error files

copying to Master 7-37

displaying 8-18, 8-33, 9-4

location on Agent 7-38

removing from Agent 7-37

events 7-52

displaying state of 8-12

how set with multiple iterations 7-53

setting 7-10, 7-12, 7-53

Excel, creating datapool files with 6-46

excluding datapool columns 6-18

executables 7-12, 7-54

deleting from schedules 7-33

monitoring 8-11

replacing 7-33

executing schedules 4-15, 7-66

execution order of users 7-62

Execution_list. See schedules, setting runtime 
information

exponential notation data type C-5

exporting

datapools 6-37

report output 2-18, 9-12

schedules 7-57

F
feedback during virtual user script recording 3-26, 

4-3, 4-7, 4-9

fields in datapools. See columns in datapools

FIELDTBLS system environment variable 7-42

FIELDTBLS32 system environment variable 7-43

file location

session files 4-2

virtual user scripts 4-2
Index-5
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file types

.csv (datapool files) 6-3, 6-36

.csv (report output) 2-18, 9-12

.s (scripts) 4-2

.spc (datapool specification files) 6-3, 6-36

.wch (session) 4-2

files

copying to Master 7-37

datapool file location 6-3

location on Agent 7-38

removing from Agent 7-37

Schedule Log 9-4

total open B-3

U ser Error 8-18, 8-33, 9-4

U ser Log 8-18, 8-33, 9-4

U ser Output 9-4

filtering

group views 8-30

protocols 3-16, 3-17, 4-11

report data 9-16, 9-33

user views 8-29

firewalls, controlling port numbers B-3

first names data type C-6

FLDTBLDIR system environment variable 7-42

FLDTBLDIR32 system environment variable 7-43

float data types C-5

floating point numbers 6-29, C-5

floating toolbars

VU  Insert 4-5

VU  Record 4-5

FTP protocol 3-19

Full user view 8-12, 8-16

sorting users in 8-27

functional tests. See distributed functional tests

G
gender data type (M, F) C-5

generating

values in datapools, example 6-32

values in datapools, in Robot 6-20, 6-22

values in datapools, in TestManager 6-26

generating virtual user scripts 4-4

from a session 4-17

manual protocol filtering 4-11

problems with 4-5

recording options 3-17

global datapool directives 6-17

graphs

changing formats 9-32

copying 9-8

data point information 9-32

modifying labels 9-33

resource monitoring 8-23

grids, displaying in graphs 9-31

Group views 8-26

groups

adding to custom histograms 8-37

deleting from custom histograms 8-38

filtering 8-30

GU I histograms 8-5, 8-7

GU I scripts

datapools and 6-24

recording 2-22

setting pass criteria for 7-61

SQABasic language and 1-4

See also scripts

GU I scripts and datapools 6-24

associating variable names and datapool columns 
6-19, 6-48

datapool access shared with virtual user scripts 
6-24
Index-6
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GU I users 1-6, 7-8

Agent computers and 1-5

including in performance tests 1-8

inserting executable in group 7-12

next available selectors 1-10, 2-20, 7-15

synchronizing 5-7

H
help desk xv

hexadecimal data type C-5

histograms

custom 8-6, 8-36

GU I 8-5, 8-7

H TTP 8-5, 8-8

IIOP 8-6, 8-9

SQL 8-5, 8-8

standard 8-5, 8-6

zooming in on bars 8-9

hotline support xv

H P-U X Agents 7-41

H TTP histograms 8-5, 8-8

H TTP scripts

cached responses 3-20

dynamic data correlation 3-21

enabling IP aliasing 7-64

keep-alives 3-20

partial responses 3-20

redirects 3-20

H TTP VU  emulation commands

reporting 9-24, 9-52, 9-53, 9-54

response from cache 9-50

I
icon for Virtual U ser Recorder 3-26, 4-9

IIOP

assigning prefix to emulation commands 3-24

emulation commands in Trace reports 9-24

including original IORs in iiop_bind 3-24

IIOP histograms 8-6, 8-9

iiop_bind emulation command 3-24

IME 6-11, 6-13, 6-27, 6-30

importing

datapools from another project 6-37

datapools from outside Rational Test 6-35

sessions 4-16

user-defined data types 6-41

including datapool columns 6-18

Input Method Editor 6-11, 6-13, 6-27, 6-30

inserting columns in a datapool 6-20, 6-22

integer data type C-6

interface card, selecting for network recording 3-5

IP aliasing 7-64

iterations

displaying schedule 8-4

setting in schedule 7-10

J
Japanese characters 6-10, 6-13

Java applets 3-19

job classes. See scenarios

Jolt protocol 3-18

Julian date data types C-4, C-5

K
Kanji characters 6-13

Katakana characters 6-13

keep-alives, in H TTP scripts 3-20

keys in unique datapool rows 6-42
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L
last names data types C-6

LD_LIBRARY_PATH  system environment variable 
7-41, 7-42

legends, displaying in graphs 9-31

LIBPATH  system environment variable 7-41, 7-42

library source files 4-20

literal value data type C-8

load tests, about 1-8

LoadTest 1-1

basic concepts 1-3

hardware and software environment 1-12

logging into 1-14

total processes B-3

uses 1-2

log levels, setting 2-5, 7-45, 8-19

log scale, displaying in graphs 9-31

logging into LoadTest 1-14

login information

Authentication Datapool 3-29

automatic detection 3-29

user ID and password 3-29

logs 7-66

copying to Master 7-37

displaying 8-18, 8-33, 9-4

folder name 7-67

location on Agent 7-38

naming 7-67

removing from Agent 7-37

running reports against 9-17, 9-18

LogViewer 2-15, 7-61, 9-4

M
manual protocol filtering 3-17, 4-11

mapping

clients and servers for proxy recording 3-8

illustration of proxy mapping 3-6

proxy computer with a server 3-8

resource usage onto response time 9-27

Master computers 1-5, 7-37, B-3

monitoring resources of 8-21, 9-3, 9-27

monitoring status of 8-21

running schedules on 1-6

TU XEDO 7-42

maximum response time 2-18, 9-44

mean response time 2-18, 9-44

median response time 2-18, 9-44

memory

minimum shared for large user runs B-2

response from cache 9-50

total shared for large user runs B-3

Message user view 8-12, 8-16, 8-28

Microsoft Excel, creating datapool files with 6-46

middle initials data type C-7

middle names data type C-6

minimum response time 2-18, 9-44

missing passwords 4-4, 4-5

monitoring computer resources 2-18, 8-21, 9-3, 9-27

setting option to allow 7-67

monitoring proxies 3-34

monitoring schedules 8-1

changing default settings 8-34

Compact user view 8-12, 8-13, 8-27

Computer view 8-21

Full user view 8-12, 8-16, 8-27

Group views 8-26

Message user view 8-12, 8-16, 8-28

Results user view 8-12, 8-14, 8-27

Script view 8-18
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setting update rates 7-67

Shared Variables view 8-17

Source user view 8-12, 8-15, 8-28

Sync Points view 8-19

Transactor views 8-25

multi-byte characters 6-10, 6-11, 6-13, 6-27, 6-30

N
N _users. See schedules, running

names data types

company names C-2

first names C-6

last names C-6

middle initials C-7

middle names C-6

titles (Mr, Ms) C-6

naming

report output 9-10

reports 9-10

scripts 3-25

sessions 3-25

nesting blocks in virtual user scripts 5-6

network interface card, selecting for network 
recording 3-5

network recording 3-2, 3-4

defining a client or server computer for 3-27

filtering protocols 3-16

identifying the client and server 3-4

selecting a network interface card 3-5

starting applications 3-25, 3-26

network services B-3

next available selectors 1-10, 2-20, 7-15

N LSPATH  system environment variable 7-42

N ormal_term_cnt. See schedules, setting runtime 
information

numbers data type C-6

N uTCRACKER settings, changing when running 
large numbers of users B-1

O
Oracle

client name required 3-23

login information 3-31

proxy recording and 3-7

setting system environment variables 7-41

ORACLE_H OME system environment variable 7-41

outliers 2-18, 9-22, 9-24

output files

copying to Master 7-37

displaying 9-4

location on Agent 7-38

removing from Agent 7-37

P
packed decimal data type C-7

partial responses, in H TTP scripts 3-20

passwords

modifying in Robot 3-31

modifying in TestManager 3-30

supplying 3-29, 4-4, 4-5

PATH 7-41

PATH  system environment variable 7-41

Performance reports 2-15, 2-17, 9-3, 9-44

automatically run 9-4

comparing output of 9-40

filtering data 9-16

graphing 9-22, 9-30

setting response ranges 9-22, 9-24

setting response time calculation 9-23

setting response time percentiles 9-23

setting response type 9-22

setting stable loads 2-5, 9-23, 9-25
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setting time period for 9-23

sorting command IDs 9-22

performance tests 1-7, 2-2

clients 1-11, 2-1

database servers 1-12

including GU I users in 1-8

recording scripts for 4-3

TU XEDO servers 1-12

vs. distributed functional tests 2-2

Web servers 1-12

PerformanceStudio Authentication 3-30

PERMU TE. See random without replacement 
selectors

persistent datapool cursors 6-4, 6-16

starting row number 6-18

phone numbers data types C-7

planning

datapools 6-6

distributed functional tests 2-19

performance tests 2-2

virtual user recording 3-1

virtual user scripts 2-11

playing back virtual user scripts

pacing 3-15

verifying SQL return codes 3-13

populating datapools

example 6-32

in Robot 6-20, 6-22

in TestManager 6-26

port numbers B-3

prefixes

autonaming virtual user scripts and sessions 3-25

command ID 3-10, 3-23

TU XEDO command ID 3-23

printing

report output 9-8

reports 9-7

schedules 7-57

private datapool cursors 6-16

processes

total LoadTest B-3

properties

report 9-30, 9-34

report output 9-34

schedule 7-32

session 4-18

properties of scripts 1-4, 7-30

accessing from session properties 4-19

defining 2-11, 4-21

status when re-recording scripts 4-24

status when re-recording sessions 4-23, 4-24

protocols

converting 4-14

filtering 3-16, 3-17, 4-11

Java applets 3-19

Jolt 3-18

selecting for virtual user scripts 3-18

socket 3-19

TU XEDO definition 3-19

proxy computers 3-6

associating with a server 3-8

computer shutdown and 3-32

creating 3-8

deleting 3-35

monitoring 3-34

reassociating with a client/server pair 3-35

redefining after proxy service is stopped 3-33

status 3-34
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proxy recording 3-2, 3-6, 3-7

client/server relationships 3-6

computer shutdown and 3-32

creating a proxy computer 3-8

defining a client or server computer for 3-27

filtering protocols 3-16

identifying client/server pairs 3-8

starting applications 3-25, 3-26

proxy service

computer shutdown and 3-32

starting 3-32

stopping 3-32

R
random alphabetic string data type C-7

random alphanumeric string data type C-7

random datapool access 6-4, 6-17

random numbers 7-48

random value seed 6-30

random with replacement selectors 7-16

generating random numbers for 7-63

random without replacement selectors 7-16

generating random numbers for 7-63

ranges in dates C-2, C-3, C-4

Rational technical support xv

Read From File data type 6-48, C-8

unique values 6-50

record levels

for Trace reports 9-50

setting 2-5, 7-46

recording GU I scripts 2-22

recording methods

API recording 3-4

network 3-4

proxy 3-6

setting 3-2

recording options 3-1

changing 4-18

filtering protocols 3-16

proxy 3-7

script generation 3-17

setting 3-1, 3-7

setting recording method 3-2

recording virtual user scripts 2-12, 4-3

cancelling 4-9

feedback 3-26, 4-3, 4-7, 4-9

recording a single script in a session 4-3

recording methods 3-2

values recorded 6-19

records in datapools. See rows in datapools

redirects, in H TTP scripts 3-20

regenerating scripts from a session 4-17

release times 5-7, 5-10

ranges 5-10

staggering 2-14, 7-27

renaming

datapools 6-35

report output 9-10

reports 9-10

schedules 7-51

user-defined data types 6-41

report output

Analog 9-39

Compare 9-40

comparing 9-13

copying 9-8

default names of 9-2

deleting 9-11

exporting 2-18, 9-12

Performance 9-44

printing 9-8

properties of 9-34

renaming 9-10
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Response 9-46

Status 9-48

Trace 9-49

U sage 9-52

reports 9-2

Analog 3-12, 3-14, 9-3, 9-38

changing default settings 9-35

changing graph formats 9-32

changing reports that run automatically 9-35

Compare 9-3, 9-13, 9-40

copying 9-8

customizing 9-15, 9-22

deleting 9-11

displaying grids 9-31

displaying legends 9-31

displaying log scales 9-31

filtering data 9-16, 9-33

filtering with block names 5-5

inverting axes 9-31

Performance 2-15, 2-17, 9-3, 9-44

printing 9-7

properties of 9-30, 9-34

renaming 9-10

Response 2-16, 2-17, 9-46

restoring default 9-12, 9-38

running from menu bar 9-6

running from report bar 9-6

saving 8-39

setting response time calculations 9-23

setting response type 9-22

setting stable loads 2-5, 9-23, 9-25

setting time period for 9-23

sorting command IDs 9-22

Status 9-3, 9-48

Trace 9-4, 9-49

types of 9-3

U sage 9-4, 9-52

requests

cancelling recorded 4-9

monitoring during recording 4-7

recording 1-6, 4-3

re-recording

sessions 4-22

virtual user scripts 4-24

resource monitoring 2-18, 8-21, 9-3, 9-27

setting option to allow 7-67

Response reports 2-16, 2-17, 9-46

graphing 9-22, 9-30

including passed or failed responses 9-23

resource monitoring 9-3, 9-27

setting response ranges 9-22, 9-24

setting response time calculations 9-23

setting response type 9-22

setting stable loads 9-23, 9-25

setting time period for 9-23

sorting command IDs 9-22

response times

reporting on 2-18, 9-23

standard deviation 2-18, 9-44

restoring default reports 9-12, 9-38

restoring Robot during virtual user recording 4-2

result files

changing information in 7-46

copying to Master 7-37

location on Agent 7-38

removing from Agent 7-37

Results user view 8-12, 8-14

sorting users in 8-27

rewinding the datapool cursor 6-16

Robot, restoring during virtual user recording 4-2

row access order 6-4, 6-17

rows in datapools

access order 6-4, 6-17

maximum number 6-4
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records and 6-45

starting row number 6-18

unique 6-43

Run_time. See schedules, setting runtime information

running

applications 3-25

reports 9-6

schedules 1-6, 2-15, 2-23, 4-15, 7-66

schedules. See also monitoring schedules

S
saving schedules 7-58

scenarios 7-10, 7-54

deleting from schedules 7-33

replacing 7-33

Schedule Log files, displaying 9-4

schedules 7-2

changing logs in 7-67

checking 7-59

creating 7-3

deleting 7-51

deleting items from 7-33

displaying views of 8-4

editing 7-31, 7-32, 7-34

execution order of users 7-62

exporting 7-57

inserting an executable 7-12

inserting scripts 7-8

inserting selectors 7-13, 7-18

inserting synchronization point 2-14

inserting transactors 7-21, 7-22

minimum requirements for running 7-10, 7-59

monitoring 8-1

opening 7-28

percent done 8-3

printing 7-57

renaming 7-51

replacing items in 7-33

reporting on portion of 9-23

results 7-66

running 2-15, 2-23, 4-15, 7-66

saving 7-58

setting delays in 7-10, 7-20

setting maximum time for run 7-63

setting number of users 7-66

setting pass or fail criteria 7-61

setting runtime information 7-60

synchronization points and 5-9

synchronizing items in 5-10, 7-19, 7-25, 7-52

terminating 7-64, 7-67, 8-39, 9-57

time in run 8-3

scientific notation data type C-5

scope of a synchronization point 5-11

script generation options 3-17

adding SQ L return codes to scripts 3-13

changing 4-18

command ID prefix 3-10

datapool commands 3-10

display number of rows retrieved 3-12

display retrieved rows in scripts 3-11

playback pacing 3-15

think time vs. CPU  delays 3-16

script properties 1-4, 7-30

accessing from session properties 4-19

defining in Robot 4-21

status when re-recording scripts 4-24

status when re-recording sessions 4-23, 4-24

Script view 8-18

emulation commands temporarily unavailable in 
8-19
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scripts 1-4

as runtime users 1-4

changing number 7-47

deleting from schedules 7-33

editing 7-29

grouping into scenarios 7-10

initializing timestamps for 7-63

inserting delays 7-10, 7-20

inserting into schedule 7-8

inserting synchronization point 2-14

iterations 7-10

limiting number 7-48

replacing 7-33

reporting active times of 9-52

reporting inactive times of 9-52

runtime errors in 2-15

setting dependencies 7-54

setting events 7-52

syntax errors in 2-15

types of 1-4

variable names and datapool column names 6-27

where stored on Agent 7-38

Seed flags 7-49

seeds 7-49

base 7-63

for random selectors 7-63

for users 7-48

random datapool values 6-30

selectors 7-13

deleting from schedules 7-33

dynamic load balancing 7-17

inserting into schedule 7-18

next available 1-10, 2-20, 7-15

random 7-16

sequential 7-15

semaphores, changing maximum number of B-1, B-3

sequential datapool access 6-4, 6-17

unique row retrieval and 6-44

sequential selectors 7-15

servers

associating with a client 3-8

associating with a proxy 3-8

changing 2-10

defining for network or proxy recording 3-27

performance tests 1-12

removing 3-29

response times 1-11, 2-1

selecting for network recording 3-4

testing 2-6

think time distribution and 2-14

session files 4-1

regenerating scripts from 4-17

where stored 4-2

session ID 3-21

where stored 3-21

sessions 1-5

autonaming 3-25

contents of 4-15

creating schedule from 7-4

deleting 4-25

finding the session name for a script 4-22

importing 4-16

properties of 4-18

recording 4-1

regenerating scripts from 4-17

removing a script from 4-22

re-recording 4-22, 4-23

scripts within 4-17, 4-21

splitting into multiple scripts 2-12, 4-15, 4-16

uses for 4-15

where stored 4-2

shared datapool cursors 6-4, 6-16

shared memory B-2, B-3
Index-1 4



Index
shared variables

changing value of 8-31

displaying users waiting on 8-32

initializing 7-55

viewing values of 8-17

SH LIB_PATH  system environment variable 7-41, 
7-42

shuffle datapool access 6-4, 6-17

unique row retrieval and 6-44

socket protocols 3-19

changing 4-14

socket VU  emulation commands, reporting 9-52, 
9-53, 9-55

Solaris Agents 7-41

sorting users 8-27

Source user view 8-12, 8-15

sorting users in 8-28

space data type C-8

.spc datapool specification files 6-3, 6-36

SQABasic language 1-4

in GU I scripts 1-4

monitoring 8-11

SQL histograms 8-5, 8-8

SQL return codes, comparing during virtual user 
recording and playback 3-13

SQL Server login information 3-31

SQL VU  emulation commands, reporting 9-24, 9-52, 
9-53

stable loads

planning 2-5, 2-16, 2-17

setting in reports 2-5, 9-23, 9-25

staggering release times 2-14, 7-27

standard data types

list of C-1

minimum and maximum values C-9

role of 6-9

when to use 6-10

standard deviation of response times 2-18, 9-44

standard histograms 8-5, 8-6

start scripts 7-47

setting maximum initialization time for 7-63

Start_group_size. See schedules, setting runtime 
information

start_time VU  emulation commands 2-14

reporting on 9-58

Start_time. See schedules, setting runtime information

starting applications 3-25

starting proxy service 3-32

state abbreviations data type C-8

states

assigning to custom histograms 8-36

removing from custom histograms 8-37

Status reports 9-3, 9-48

automatically run 9-4

data summary style 9-23

graphing 9-22, 9-30

setting response ranges 9-22, 9-24

setting response type 9-22

setting stable loads 9-23, 9-25

setting time period for 9-23

sorting command IDs 9-22

stop_time VU  emulation commands 2-14

reporting on 9-56

stopping

proxy service 3-32

recording 4-4

street names data type C-2

stress tests 1-8, 2-9, 7-26

string constant data type C-8

structure of datapools 6-45

support, technical xv

survey utility.See schedules, monitoring

suspending virtual users 8-34, 8-38

Sybase

login information 3-31

setting system environment variables 7-41
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synchronization points 2-14, 5-7, 5-10, 7-25, 7-27, 
8-19

deleting from schedules 7-33

displaying state of 8-19

example of 5-8

inserting into schedules 2-14, 5-9, 5-10, 7-25

inserting into script 2-14, 5-9, 5-10

multiple 5-9

number of users waiting 8-19, 8-20

release time ranges 5-10

releasing 8-20

releasing users from 5-7, 5-10, 7-27, 8-19

replacing 7-33

scope of 5-11

timeout 5-10, 7-28, 8-20

synchronizing items in schedules

delays 7-19

events and dependencies 7-52

synchronization points 5-10, 7-25

system environment variables 7-41, 7-44

T
Task_dir. See schedules, running

Task_term_cnt. See schedules, terminating

Task_ts_init. See schedules, setting runtime 
information

tasks. See scripts

technical support xv

Telnet protocol 3-19

terminating schedules 7-64, 7-67, 8-39, 9-57

planning 2-5

terminating users 8-34

abnormal 8-3, 8-13, 8-14, 8-27

normal 8-3, 8-27

TEST7_LTMASTER_N TU SERLIMIT system 
environment variable B-2

TEST7_LTMASTER_SHM_MIN SZ system 
environment variable B-2

testcase VU  emulation commands 9-56, 9-58

tests 1-7

configuration 1-10

contention 1-3, 1-9

distributed functional 1-10, 2-19

load 1-8

performance 1-7, 2-2

stress 1-8, 2-9, 7-26

text files, assigning values to a datapool column 6-48, 
C-8

think time

CPU  delays and 3-16

distribution 2-14

maximum 3-16

setting 3-15

threshold between think time and CPU  delays 3-16

throughput 9-53, 9-57

time data types C-8

timeout values, for synchronization points 5-10

timers 5-1

adding during editing 5-3

adding during recording 5-2

times

client response 1-11, 2-1

reporting active 9-52

reporting inactive 9-52

server response 1-11, 2-1

setting maximum initialization 7-63

setting maximum schedule run 7-63

standard deviation of response 2-18, 9-44

suppressing delays 7-63

think 2-14, 3-15, 3-16

think time distribution 2-14

timestamps

in Trace reports 9-50

initializing for scripts 7-63

omitting from Trace report 9-24

TN S_ADMIN  system environment variable 7-41
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toolbars

VU  Insert 4-5

VU  Record 4-5

working with A-1

Total_term_cnt. See schedules, setting runtime 
information

TPIN IT request message 3-19

Trace reports 9-4, 9-49

including command types 9-24

including passed or failed responses 9-23

including VU  environment variables 9-24

omitting timestamps 9-24

Transaction reports. See Response reports

transactions 2-11

automatically timing in blocks 2-13, 5-4

performing during recording 4-4

transactors 7-21, 7-54, 8-25

displaying information about 8-25

inserting into schedule 7-22

truncating emulation command ID prefixes 3-11

TU XEDO

command ID prefixes 3-23

defining a connection 3-19

emulation commands in Trace reports 9-24

emulation commands in U sage report 9-52, 
9-53, 9-56

performance testing 1-12

setting system environment variables 7-42

U
U .S. cities data type C-2

U .S. state abbreviations data type C-8

unique datapool rows

guidelines for 6-42

Read From File data type and 6-50

setting unique values 6-28

user-defined data types and 6-12

update rates, when monitoring schedules 7-67

usage directives for datapools 6-18

U sage reports 9-4, 9-52

data summary style 9-23

U ser Error files

displaying 8-18, 8-33, 9-4

user groups 2-11, 7-5

changing information about 7-35

changing number of users 7-36

deleting from schedules 7-33

displaying information about 8-26

editing properties of 7-34

fixed 7-6

inserting into schedules 7-5

planning 2-4

replacing 7-33

scalable 7-6

temporarily disabling 7-48, 7-62

user IDs

modifying list of, in Robot 3-31

modifying list of, in TestManager 3-30

supplying 3-29

U ser Log files

displaying 8-18, 8-33, 9-4

U ser Output files

displaying 9-4

user settings, changing 7-38

U ser_term_mode. See schedules, terminating

user-defined data types

automatically generating values for 6-39

copying 6-42

creating 6-11

deleting 6-42

editing definitions of 6-39

editing values in 6-38

importing 6-41

renaming 6-41
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role of 6-9

unique values 6-12

when to use 6-10

userlists. See user groups

users 8-3

abnormal termination 8-3, 8-14, 8-27

active 8-3

changing number of 7-36

combining GU I and virtual 7-8

displaying information about 8-5

distributing among computers 7-8, 7-36

execution order 7-62

filtering 8-29

GU I 1-6

limiting number of scripts run by 7-48

normal termination of 8-3, 8-27

percentage executing schedule 8-5

reporting active times of 9-52

reporting inactive times of 9-52

seeds for 7-48

setting number of 7-6

setting termination counts for 7-65

sorting 8-27

starting at different times 7-47

terminating 8-34

total number in run 8-3

virtuaI 1-6

users. See also GU I users, virtual users

V
values supplied during recording 6-19

variable names and datapool column names 6-19

variable names, and datapool column names 6-27, 
6-48

verifying SQL return codes 3-13

VIEWDIR system environment variable 7-43

VIEWDIR32 system environment variable 7-43

VIEWFILES system environment variable 7-43

VIEWFILES32 system environment variable 7-43

viewing

datapool values, in Robot 6-23

datapool values, in TestManager 6-34

user-defined data type values 6-38

views

Compact user 8-12, 8-13, 8-27

Computer 8-21

customizing 8-27

Full user 8-12, 8-16, 8-27

Message user 8-12, 8-16, 8-28

restoring default 8-31

Results user 8-12, 8-14, 8-27

Script 8-18

Shared Variables 8-17

Source user 8-12, 8-15, 8-28

Sync Points 8-19

Virtual U ser Recorder 4-7

after recording 4-9

during API recording 4-7

icon 3-26, 4-9

virtual user scripts

adding datapool commands to 3-10

adding number of rows retrieved to 3-12

adding retrieved rows to 3-11

autonaming 3-25

blocks 2-13, 5-4

cancelling 4-9

changing recording options 4-18

command ID prefixes in 3-10

comments in 2-13, 5-11

copying 4-25

copying code from one script to another 4-20

datapool access shared with GU I scripts 6-24

debugging 8-33

deleting 4-23, 4-25
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distinguishing think time and CPU  delays 3-16

generating after recording 4-4

generating from a session

improving readability 3-10, 5-5

list of, in a session 4-17, 4-21

manual protocol filtering 4-11

maximum think time 3-16

methods of recording 3-2

modifying connect line of 2-10

overwriting 4-24

planning 2-11

playback rate 3-15

properties 4-20

recording 2-12, 4-3

recording options for 3-1

regenerating from a session 4-17

removing from a session 4-22

re-recording 4-24

script generation options 3-17

session associated with 4-22

splitting 2-12, 4-15, 4-16

SQL return code verification 3-13

stopping recording 4-4

think time in 3-15

updating on Agent 7-37

user groups 2-11

variable names and datapool column names 6-19

VU  language and 1-4

where stored 4-2

See also scripts

virtual users 1-6, 7-8

changing log level 7-45

changing record levels of 7-46

determining number supported 2-6

incrementally loading 2-7

pacing 3-15

resuming suspended 8-34

running large numbers B-1

setting limit for large user runs B-2

setting number of 7-66

suspended 8-3, 8-27

suspending 8-34, 8-38

synchronizing 5-7

think time 3-15

think time vs. CPU  delays 3-16

VU  display library routine 8-12, 8-16, 8-28

VU  environment variables

in Trace reports 9-24

Log_level 7-39

Record_level 7-46

VU  Insert toolbar 4-5

VU  language 1-4

in virtual user scripts 1-4

VU  Record toolbar 4-5

W
watch files. See session files

Web

performance testing 1-12

structural testing of 1-7

Windows N T Agents 7-41

workloads 2-2

adding to system-under-test 1-5, 1-8

designing 2-4

planning stable 2-5, 2-16, 2-17

reporting on stable 2-5, 9-23, 9-25

WorkStation Listener information 3-19

wrapping the datapool cursor 6-16

WSDEVICE system environment variable 7-43

WSLH OST system environment variable 7-42

WSLPO RT system environment variable 7-42

WSN ADDR system environment variable 7-42
Index-1 9



Index
Z
Zap_mode. See schedules, setting runtime 

information

zip code data types C-9

zoned decimal data type C-9
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