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I N T R O D U C I N G  R A T I O N A L  C L E A R Q U E S T
Welcome to Rational ClearQuest
ClearQuest is a customizable defect and change request 
management system designed for the dynamic environment of 
software development. With ClearQuest, you can manage every 
type of change activity associated with software development, 
including enhancement requests, defect reports, and 
documentation modifications. 

ClearQuest shortens development cycles by unifying your entire 
team in the process of managing software change:

■ Development engineers can identify and prioritize action 
items that pertain to their section of code. 

■ Test engineers can track the status and resolution of change 
requests to verify software quality. 

■ Project leaders and managers can get information at a glance 
to help them allocate development resources, streamline work 
flow, and accurately determine release dates. 

■ Administrators can integrate ClearQuest with existing tools 
and customize it to fit your organization’s workflow. 

This guide provides an overview of how to use ClearQuest on the 
job and a brief example of how your ClearQuest administrator can 
customize ClearQuest to fit your workflow. For instructions on 
how to install ClearQuest, see the Installing Rational ClearQuest 
guide that came with your product. 
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What is ClearQuest? 

ClearQuest consists of several components that work in a 
client-server environment. 

Component Used by Use to

ClearQuest Everyone Submit, modify, and track change requests, and 
to analyze project progress by running queries, 
charts, and reports.

See this guide and ClearQuest Help. 

ClearQuest Web Everyone Access ClearQuest across multiple platforms 
through Netscape Navigator® or Microsoft’s 
Internet Explorer.® You can submit change 
requests and run queries, charts, and reports.

See this guide and Installing Rational 
ClearQuest. 

ClearQuest 
Designer 

ClearQuest 
Administrator

Customize ClearQuest, manage ClearQuest 
schemas and databases, and administer users 
and user groups.

See this guide, Administering Rational 
ClearQuest, and ClearQuest Designer Help. 

ClearQuest 
Import Tool 

ClearQuest 
Administrator

Import data including records, history, and 
attachments from other change request systems. 

ClearQuest 

Export Tool

ClearQuest 
Administrator

Export ClearQuest data from one ClearQuest 
user database to another user database that 
uses a different schema. 

ClearQuest 
Maintenance Tool 

Everyone Set up and connect to the schema repository 
during installation and when you upgrade to a 
new ClearQuest version.

Rational E-mail 
Reader 

ClearQuest 
Administrator 

Configure your e-mail settings to enable 
ClearQuest users to submit and modify records 
by e-mail. 

See Chapter 9, “Administering ClearQuest 
E-mail,” in the Administering Rational ClearQuest 
guide. 
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Ready-to-use change request management 

ClearQuest includes several schemas that provide ready-to-use 
change request management processes and integration with 
various Rational Software products. You can use ClearQuest 
schemas as is or customize them to fit your company’s processes. 
For a list of ClearQuest schemas, see “Choosing a ClearQuest 
schema” on page 35. 

Support for your development environment

ClearQuest provides the following support for your 
software-development environment:

■ Supports Microsoft Access® (included with ClearQuest), 
Microsoft SQL Server,® Sybase SQL Anywhere (included with 
ClearQuest), and Oracle relational databases.

■ Integrates with Rational ClearCase and Microsoft Visual 
SourceSafe so you can associate change requests directly with 
changes in your evolving software. 

■ Integrates with Rational TeamTest, VisualTest, Purify, 
PureCoverage, and Quantify, allowing you to submit change 
requests to ClearQuest directly from these testing tools.

■ Includes Seagate’s Crystal Reports Professional EditionTM so you 
can create custom reports from ClearQuest data. 

■ Allows you to integrate with other standard Windows tools, such 
as Microsoft Excel and Word through an advanced COM 
interface. 

■ Provides access to Rational Unified Process through the 
ClearQuest Help > Rational Extended Help menu. 
Welcome to Rational ClearQuest  7



Where to get more information

ClearQuest includes the following documentation:

Everyone
Start Here

ClearQuest 
Administrators

Introducing Rational ClearQuest

ClearQuest online Help Release Notes
Installing Rational ClearQuest
Administering Rational ClearQuest
ClearQuest Designer Tutorial
ClearQuest Designer online Help
ClearQuest API Reference 

ClearQuest 
Users
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I N T R O D U C I N G  R A T I O N A L  C L E A R Q U E S T
On the job with ClearQuest
This chapter is for all ClearQuest users. It introduces the basic 
concepts of using ClearQuest, including information on how to: 

■ Submit a change request
■ Work with change request records
■ Track change request records
■ Gather project metrics

If you’re reading this chapter as a ClearQuest administrator, look 
for the ClearQuest Designer icon next to suggestions on how you 
can customize ClearQuest to fit your company’s processes. 
Be sure to read “Administering and customizing ClearQuest” on 
page 21. 

Note: The examples in this chapter show the DefectTracking 
schema and SAMPL database that are included with ClearQuest. 
This represents only one model for using ClearQuest. For more 
information, see “Choosing a ClearQuest schema” on page 35. 
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Getting started

To start using ClearQuest:

1 Select Rational ClearQuest from the Start menu. 

2 You can use the ClearQuest built-in user name (admin) to get 
started. You do not need to type a password. 

As a ClearQuest administrator, you use ClearQuest Designer to 
set up user login accounts and to define user access privileges. See 
Chapter 6, “Administering users” in the Administering Rational 
ClearQuest guide. 

3 Select the SAMPL database to experiment with a working user 
database that already contains many change request records.

During installation, your administrator will create and configure 
user databases for your site. Their names will appear in the 
drop-down list of databases. 

Select a database

Type your user name
and password
10  Introducing Rational ClearQuest



Getting around in ClearQuest

The ClearQuest main window consists of a Workspace, a Query 
Builder, and a Record form. 

The Public Queries folder in the Workspace contains the queries, 
charts, and reports that are included in ClearQuest, as well as any 
that your ClearQuest administrator creates. You can drag any 
query, chart, or report to your Personal Queries folder and modify 
it to suit your needs. 

More information? Select Help > Contents > Getting around ClearQuest. 

The Workspace lists the
queries, charts, and

reports that are available

Double-click a query
to locate records

in the database

The Query Builder displays the results of a query. Click a record 
to display its data in the Record form below. 

Use the Record form to
view and modify records

Scroll through multiple
records from the same
query or type a record

number to locate
On the job with ClearQuest  11



Submitting a change request

You begin using ClearQuest by submitting a change request. This 
creates a record in the user database that everyone on the team 
can track as your software development and testing evolves.

To submit a change request, click  in the toolbar. 

Use the various tabs on the Submit Defect dialog to describe the 
change request in detail, including attaching code fragments and 
other supporting information. Some tabs contain fields that are 
mandatory. For example, the Headline field requires a short 
sentence describing the problem, and you must select a value for 
the Severity field. 

You can save frequently used field values as default so you don’t 
have to re-enter them each time you submit a change request. Fill 
in the fields you want to save and select Values > Save as Default. 

Note: You can also submit a change request directly to 
ClearQuest from Rational TeamTest, Purify, PureCoverage, 
Quantify, and Visual Test. 

Fields labeled in red
are mandatory

Record form tabs with
a red X contain

mandatory fields

Save field values
as default and load

them the next time you
submit a change request
12  Introducing Rational ClearQuest



As ClearQuest administrator, you can create additional record 
types and customize record forms, including adding tabs and fields 
and defining their behavior. See Chapter 5, “Customizing a 
schema” in the Administering Rational ClearQuest guide. 

More information? Select Help > Contents > Working with records. 

Receiving automatic e-mail notification

Your ClearQuest administrator can configure ClearQuest to 
automatically send e-mail to various team members when a 
change request is submitted or changed. To take advantage of 
automatic e-mail notification, all ClearQuest users must set up 
their e-mail options. Select View > E-mail Options. 

More information? Select Help > Contents > Using ClearQuest > Setting 
up e-mail notification. 

ClearQuest’s Email_rule record type makes it easy to define the 
rules for sending automatic e-mail notification to ClearQuest 
users. The Email_rule record type is part of the E-mail package 
included in every ClearQuest schema. You can also use the 
Rational E-mail Reader to configure your e-mail settings so that 
ClearQuest users can submit and modify records by e-mail.

More information? In ClearQuest Designer, select Help > Contents > 
Using e-mail features. Read Chapter 9, “Administering ClearQuest 
E-mail” in the Administering Rational ClearQuest guide.
On the job with ClearQuest  13



Working with change request records 

You work with change request records by moving them through 
various stages, or “states.” In each state, you can perform actions 
such as modifying the record or moving it to another state. The 
Actions menu lists the actions that you can perform on the record 
while it is in any given state. 

Here’s an example of a typical workflow: 

Assigning a change request 

A change request record usually starts out in the Submitted state. 
The first thing to do is to assign the change request to the 
engineer responsible for that section of code. 

The Assign action changes the state of the record to Assigned. 

The exact process of working with records, including the states the 
record can be in and the actions available in each state, depends 
on the ClearQuest schema you are using and any customizations 
you have made to it. See “Customizing a schema” on page 24. 

Select
Actions > Assign . . .

. . . then fill in the
information on each tab

of the record form

The record is in the Submitted state
14  Introducing Rational ClearQuest



Modifying a change request

Not all actions change the state of a change request. You can select 
Actions > Modify to change some information on a change request 
without actually changing its state. 

Opening and resolving a change request

If you’re the engineer assigned to the change request, you begin 
work by selecting Actions > Open. This changes the record’s state to 
Opened; now the rest of the team can see that you’re working on 
the problem. 

When you finish your work, select Actions > Resolve to change the 
record’s state to Resolved. 

In this example, the ClearQuest administrator has configured 
ClearQuest to send an automatic e-mail notification to the Quality 
Assurance team as part of the Resolve action. A quality assurance 
engineer can then verify that the problem is fixed and change the 
record state to Closed. 

As a ClearQuest administrator, you can restrict actions to specific 
user groups. For example, you might allow everyone on the team 
to resolve a change request, but restrict the Verify action to 
members of the Quality Assurance group. 

When you change the
record state to Resolved,

you must fill in
the Resolution field
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Tracking change request records

It’s easy for everyone on your team to track change request records 
as they move through your system. 

Using public queries

ClearQuest includes ready-to-use queries that help you locate 
records by project or component, by assigned engineer, by level of 
severity, and so on. For example, when you discover a defect in 
your software, you can check to see if the defect has already been 
submitted. Select Public Queries > All Defects to display all the records 
in the database, or use the Keyword search query to locate records 
containing a specific word in the Headline or Description field. 

During a session of submitting new defects, you can select 
Query > RecentlySubmitted to see a list of the defects you have 
submitted since you logged in.

Public queries are included in the various ClearQuest schema 
packages. See the “ClearQuest schemas and packages” appendix 
in the Administering Rational ClearQuest guide.

Double-click Keyword
search and type
a keyword in the

Dynamic Filters dialog

The Result set tab
displays all the records

for the query

These records are the result of the a keyword search
for records containing the word sale
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Modifying queries

To modify a query, first drag the query to your Personal Queries 
folder and then use the Query editor and Display editor tabs. 

Building a new query

To build a new query from scratch or from an existing query, select 
Query > New Query. The ClearQuest Query Wizard steps you through 
the process of building a query.

More information? Select Help > Contents > Working with queries.

As a ClearQuest administrator, you can save queries to the Public 
Queries folder and can assign this privilege to other users. 
See Chapter 6, “Administering users” in the Administering 
Rational ClearQuest guide. 

Select the Query editor
tab to change the

filtering criteria
for a query

Select the Display editor
tab to set up how the

query results are
displayed

Drag a query to your
Personal Queries folder

before modifying it
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Gathering project metrics

ClearQuest provides predefined charts and reports that show the 
status of your project at a glance. You can modify these charts and 
reports to fit your own needs. 

Using ClearQuest charts

ClearQuest charts display record data graphically: Distribution 
charts show the current status of data, while trend and aging 
charts show historical information. 

For example, you can see how the workload is distributed among 
the engineers on your team by running a distribution chart that 
displays the defects assigned to each engineer. Or, you can see the 
defect records graphed by state and severity.

There are two ways to modify the contents of a chart: Select 
Edit > Properties to define how the data is displayed, or use the 
Query editor tab to filter the records included in the chart.

Double-click a chart
to open it

Right-click in the chart
to display the

Shortcut menu,
and select Drill Down

to show more detail

Chart data is also displayed in tabular form

Drag a chart to your
Personal Queries folder

before modifying it
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Creating reports from ClearQuest data

ClearQuest includes reports and report formats that you can use 
to create reports from ClearQuest data. To create a report on the 
current query results set, first run a query such as All Defects, 
then click to open the Create Report dialog.

This creates a report in the selected format from the data in the 
query result set. Click to export the report output to another 
format, such as HTML or Excel.

Select a report format

ClearQuest displays
the data in the report
format you selected
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To create a new report that you can reuse, run a query that you 
want to create a report from, and then select Query > New Report. 

Select a report format and then associate the format with a query. 

This creates a report from the query data you selected. You can 
save this report in your Personal Queries folder and run it at any 
time. 

You can use Crystal Reports Professional Edition to create new 
report formats. You can save these formats in your Personal 
Queries folder and use them to format ClearQuest reports.

More information? See Help > Contents > Working with reports.

Now you’re ready to put ClearQuest to work. Remember that 
ClearQuest Help contains detailed information to assist you every 
step of the way. For context-sensitive Help, click  and then 
click the item you want information about. 

Be sure to read the following chapter, “Administering and 
customizing ClearQuest.”

Select a record type

Select a report format

Select a query
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I N T R O D U C I N G  R A T I O N A L  C L E A R Q U E S T
Administering and customizing ClearQuest 
This chapter is for ClearQuest administrators. It begins with an 
overview of ClearQuest databases and schemas, and then provides 
a brief example of how to perform the primary task of an 
administrator—customizing a ClearQuest schema to fit your 
process.

Note: For complete information about administering ClearQuest, 
including a description of how to get your ClearQuest users up and 
running, see the Administering Rational ClearQuest guide that 
came with your ClearQuest product. 

Overview of ClearQuest databases and schemas

A ClearQuest schema contains the metadata that defines the 
process for how your ClearQuest users work with records. It 
includes:

■ Record type definitions
■ Forms used to submit and modify a record 
■ Field definitions and behavior
■ States a record can be in 
■ Actions used to modify or change the state of a record 
■ Hooks written in Visual Basic ScriptTM or Perl that further 

customize fields and actions. 

ClearQuest stores schemas in a schema repository. A ClearQuest 
installation usually consists of one schema repository and one or 
more user databases. You can use a separate database for each 
project, or group several projects together in one database. If you 
want to generate reports and charts across a group of projects, you 
21



should put the projects in the same database. Projects that share a 
database must use the same schema.

Note: ClearQuest includes several predefined schemas that you 
can use as is or customize to fit your procedures. For a list of these 
schemas, see “Choosing a ClearQuest schema” on page 35. 

Here’s an example of how a schema repository with two schemas 
can work with several different user databases: 

Note: Once a database is associated with a schema, it can only be 
upgraded with newer revisions of that same schema. It cannot use 
older revisions of the schema or a completely different schema. 

In the above example, you can:

■ Upgrade the databases for projects X, Y, or Z with newer 
revisions of the DefectTracking schema. 

■ Upgrade the Test database with newer revisions of myschema. 
■ Apply any revision of the DefectTracking schema or the 
myschema schema to a new database.

More information? For a complete description of how to work with 
schemas and databases, see Chapter 4, “Working with ClearQuest 
schemas” in the Administering Rational ClearQuest guide. 

DefectTracking schema
rev 1
rev 2

.

.

.
rev 25

Schema Repository

Database for project X

Database for project Y

Database for project Z

Test database

myschema schema
rev 1

.

.

.
rev 10

You can upgrade these
databases with newer

revisions of the
DefectTracking

schema

You can upgrade this
database with newer

revisions of the
myschema schema
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Starting ClearQuest Designer

To start ClearQuest Designer:

1 Select ClearQuest Designer from the Start menu. 

ClearQuest provides a default User Name (admin) that you can 
use to get started. You do not need to type a password. The admin 
user account is set up with the access privileges you need to 
perform all ClearQuest administrator functions. To change the 
admin account, select Tools > User Administration, then select the 
admin user and click Edit. 

More information? See Chapter 6, “Administering users” in the 
Administering Rational ClearQuest guide. 

2 ClearQuest Designer displays the Open Schema dialog. 
Check out a schema if you are planning to modify it; otherwise 
click Cancel to continue. 

More information? In ClearQuest Designer, select Help >Tutorial. 

Select a schema

Click to check out
a schema

Click to check out a
schema

Click to start ClearQuest
Designer without

checking out a schema
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Customizing a schema

This section provides a brief example of how to customize a 
schema to fit a workflow process. Suppose you have a simple 
defect record with only two states (Submitted and Closed) and 
three actions (Submit, Modify, and Resolve). The process of 
working with this record is shown in the state model below: 

The defect record begins in the Submitted state; from there you 
select Actions > Resolve to change the record state to Closed, or 
Actions > Modify to modify the record without changing its state. The 
record form looks like this: 

The process of working with a record, along with the record form 
and fields is defined by the ClearQuest schema. 

Submitted Closed

Resolve

= State

= Action

When the record is in
the Submitted state . . .

. . . you can modify or
resolve the defect
24  Introducing Rational ClearQuest



In this example, you modify the process of working with the defect 
record by adding an Opened state so that the state model looks 
like this: 

To customize the schema to fit this new process, you will: 

■ Add a new state, Opened, between the Submitted and Closed 
states.

■ Add a new action, Open, that changes the state of the record 
from Submitted to Opened.

■ Add a field, planned_fix_date, to the record form.
■ Define the behavior of the planned_fix_date field. 
■ Create a Visual Basic hook that automatically fills in the 

planned_fix_date field.

Submitted

Open

Opened

Resolve

Closed

Resolve

= State

= Action
Administering and customizing ClearQuest  25



Checking out the schema

To customize a schema, you must first check it out of the schema 
repository. Select File > Open Schema. For complete instructions on 
working with schemas, including setting up a test database to test 
your schema customizations, see Chapter 4, “Working with 
schemas,” in the Administering Rational ClearQuest guide. 

Adding a new state

The ClearQuest Designer State Transition Matrix shows the 
various states that a record can be in and the actions that move 
the record from one state to another. In this example, it shows that 
the Resolve action changes the record from the Submitted state to 
the Closed state. 

To add a new state, open the State Transition Matrix and then 
select Edit > Add State. 

More information? Look up states, adding in the ClearQuest 
Designer Help index. 

Double-click to open the
State Transition Matrix

Click Edit > Add State
and type Opened
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Adding a new action

The Actions grid shows all of the actions that can be performed on 
a record. To add a new action, you first add the action to the 
Actions grid and then associate it with the appropriate states. 

This adds the Open action to the ClearQuest Actions menu. Now, 
when the record is in the source state (Submitted), you can select 
Actions > Open to move the record to the destination state (Opened). 

You should also modify the existing Resolve action to add Opened 
as a legal source state. 

More information? Look up actions, adding to record type in the 
ClearQuest Designer Help index. 

Double-click to open
the Actions grid

Type Open, then
right-click it and select

Action Properties
from the popup menu

In the State tab, select
Submitted as the source
state and Opened as the

destination state

Right-click any field in a grid 
and select What’s This?  to get 
more information
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Look at the State Transition Matrix again. It now shows that the 
Open action moves the record from the Submitted state to the 
Opened state, as intended. 

You can see how the State Transition Matrix implements the state 
model. 

In the Submitted state, you can select Actions > Open to change the 
state to Opened. In both the Submitted state and the Opened 
state, you can select Actions > Resolve to change the record to 
Closed. 

More information? Look up state transitions in the ClearQuest 
Designer Help index. 

Double-click to open the
State Transition Matrix

The new Open action
moves the record from

Submitted to Opened

Submitted

Open

Opened

Resolve

Closed

Resolve

= State

= Action
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Creating a new field 

Now, create a new field for the record form called planned_fix_date 
that lets you enter the date when you expect to resolve the defect. 

To create a new field, open the Fields grid. The Fields grid shows 
all of the fields on the record form, their type, and their default 
values. 

More information? Look up fields, adding in the ClearQuest 
Designer Help index. 

Double-click to open
the Fields grid

Type planned_fix_date
in the Field Name

column

Right-click the Type
column and select

Date_Time from the
drop-down menu
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Defining the behavior of the new field

The Behaviors grid shows how fields behave when the record is in 
each state. You can define whether a field is read-only, mandatory, 
or optional in each state, or define default behavior for all states. 
You can also create a use-hook behavior that restricts user access 
to the field.

Open the Behaviors grid, then right-click and use the popup menu 
to define the behavior of the planned_fix_date field. 

More information? Look up fields, behaviors in the ClearQuest 
Designer Help index. 

Double-click to open
the Behaviors grid

The record form contains
these fields

Right-click to define
the behavior of the

planned_fix_date field
in each state
30  Introducing Rational ClearQuest



Adding the new field to the record form

After creating a field, you must add it to the record form. To add 
the planned_fix_date field to the record form, open the Defect 
form. In the Workspace, select Record Types > Defect > Forms > Defect. 

When you finish, close the form window.

More information? Look up forms, modifying in the ClearQuest 
Designer Help index. 

Drag the planned_fix_date 
field onto the form . . . 

Double-click to open
the Defect record form

You can use the Text Box
Property Sheet to

change the properties
of a text box.

Use the Controls Palette to add controls such as
check boxes and option buttons to a form

. . . then right-click the text box 
and select Properties from the 
popup menu
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Creating an action hook

Hooks are triggers for pieces of code that ClearQuest executes at 
specified times to more fully implement your process. ClearQuest 
provides many common hooks that you can easily modify to suit 
your needs.You can also use the ClearQuest application 
programming interface (API) to write hook code in Microsoft 
VBScript or Perl. 

ClearQuest supports four types of hook code:

■ Field hooks provide a way to validate the contents of a field or to 
assign field values. 

■ Action hooks implement tasks at key points in the life cycle of a 
record. 

■ Record scripts allow you to associate a hook with a control, such 
as a push-button or shortcut menu option, on a single record.

■ Global scripts allow you to reuse hook code in other hooks.

In this example, you modify the predefined 
ACTION_INITIALIZATION hook for the Open action so that it 
initializes the value of the planned_fix_date field. 

This opens the ClearQuest Script Editor. 

Double-click Actions
to open the Actions grid

Right-click the
Initialization column for

the Open action and
select Scripts > Basic
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Use the ClearQuest Script Editor to edit the 
ACTION_INITIALIZATION hook so that it initializes the value 
of the planned_fix_date field to the current date + three days. 

More information? Look up hooks, overview in the ClearQuest 
Designer Help index. Read Chapter 7, “Using hooks to customize 
your workflow,” in the Administering Rational ClearQuest guide.

Checking in the schema

At any time while working on a schema, you can select 
File > Test Work to test your work in progress. This upgrades the test 
database with your latest changes, providing a quick way to test 
your work in the ClearQuest client before checking in the schema. 

When you’re satisfied that your schema changes are working 
correctly, select File > Check in to check the schema into the schema 
repository. Once the schema is checked in, you can use it to 
upgrade your user database. Select Database > Upgrade Database. 
ClearQuest prompts you to back up the schema repository and the 
database before upgrading. 

More information? Read Chapter 4, “Working with schemas,” in 
the Administering Rational ClearQuest guide. 

Add these lines
to the script
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Working with the new record form 

After upgrading the user database with the customized schema, 
the defect record form works like this: 

The Open action changes the state of the record to Opened and 
automatically fills in the planned_fix_date field. 

. . . click Open
to change the record

state to Opened

With the record is in
the Submitted state . . .

The record state
changes to Opened

The planned_fix_date
field is filled in
automatically
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Choosing a ClearQuest schema 

Below is a list of the predefined schemas that are included in 
ClearQuest. ClearQuest schemas are made up of various packages 
that provide specific functionality. You can add individual 
packages to an existing ClearQuest schema or to your own 
customized schema. For a complete description of ClearQuest 
schemas and packages, see your Administering Rational 
ClearQuest guide. 

Now, you’re ready to begin using ClearQuest Designer. Remember 
that ClearQuest Designer Help contains detailed information to 
assist you every step of the way. For context-sensitive Help, 
click  and then click the item you want information about. 

Schema Description

AnalystStudio Compatible with Rational Suite Analyst Studio. 
Contains customization for use with Rational 
RequisitePro. 

Blank Contains only system fields. Use this schema to 
create a schema from scratch. 

Common Contains metadata that is common to all of the 
ClearQuest schemas. 

DefectTracking Contains the fields necessary to start using 
ClearQuest to track defects in a 
software-development environment.

DevelopmentStudio Compatible with Rational Suite 
DevelopmentStudio. Contains fields and rules 
that work with Rational Purify, Quantify, and 
PureCoverage.

Enterprise For use with Rational Suite EnterpriseStudio. 
Contains fields and hooks that work with all 
Rational products.

TestStudio Compatible with Rational Suite TestStudio. 
Contains fields and rules that work with Rational 
TeamTest, RequisitePro, Purify, Quantify, and 
PureCoverage. 
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