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Preface

Rational Suite ContentStudio is a content management environment and Web application

deployment solution that supports the life cycle of Web application development.

About This Manual

This manual is for ContentStudio site managers or administrators who are responsible for

installing, configuring, and licensing the ContentStudio system environment.

Rational Suite ContentStudio is composed of many point products and additional components.

As a result, installing it is a complex process. To succeed, you must follow the instructions in the

order given. Any deviations may lead to unpredictable installation failures.

Using Rational Suite ContentStudio Documentation

The documentation for this product consists of the following:

➤ Introducing Rational Suite ContentStudio
➤ Installing Rational Suite ContentStudio
➤ Rational Suite ContentStudio Release Notes
➤ Rational Suite ContentStudio Sample Application Guide
➤ Using the Rational Suite ContentStudio Console (online help)

➤ Using the Rational Suite ContentStudio Administration Utility (online help)
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Using Vignette Documentation

The Vignette V/5 documentation, which is available only online, describes some features that are

not available in ContentStudio:

➤ Personalization server

➤ Observation Manager

➤ TCL page generation

➤ Multi-Channel Server

➤ Solaris platform support

➤ Web server support (other than IIS)

You can ignore these manuals entirely:

➤ Visitor Services Guide
➤ Java Extension Programmer’s Guide and Reference
➤ Net Perceptions Recommendation Engine
➤ Resonate Central Dispatch User’s Guide
➤ Internationalization Guide

To identify which sections of the documentation you can ignore, consult the table.

Vignette Manual Sections or Chapters to Ignore

Administration Guide ➤ In Chapter 4: Viewing OMS Information, Viewing MCS
Information, and Viewing MCS Process Information

➤ In Chapter 8: Obtaining Process Status—Solaris only

➤ Chapter 11

➤ Appendix D

➤ Appendix F

Security Guide ➤ In Chapter 2: The OMS and MCS information in

Configuring Security for the CMS, CDS, or MCS

➤ In Chapter 6: Specifying Securing Web Servers and Security
for Multiple, Remote Web Servers

Production Center Guide In Chapter 7: Keywords and the Keyword Manager

Template Cookbook Chapter 6 and Chapter 9
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Using Rational Suite Team Unifying Products Documentation

The ContentStudio documentation refers to manuals that are available on the CD titled Rational
Solutions for Windows: Online Documentation.

One manual that is not available on that CD is Developing Software with ClearCase. The

information in this manual is available in the online help for ClearCase LT.

Typographical Conventions

This manual uses the following typographical conventions:

➤ cs-home-dir represents the directory into which Rational Suite ContentStudio has been

installed. By default, this directory is drive:\Program Files\Rational\ContentStudio.

➤ Bold is used for names the user can enter; for example, all command names, file names, and

branch names.

➤ Italic is used for variables, document titles, glossary terms, and emphasis.

➤ A monospaced font is used for examples. Where user input needs to be distinguished

from program output, bold is used for user input.

➤ Key names and key combinations are capitalized and appear as follows: SHIFT, CTRL+G.

Technical Support

If you have any problems with the software or documentation, please contact Rational Technical

Support via telephone, fax, or electronic mail as described below. For information regarding

support hours, languages spoken, or other support information, click the Technical Support link

on the Rational Web site at www.rational.com.

Your Location Telephone Facsimile Electronic Mail

North America 800-433-5444

toll free or

408-863-4000

Cupertino, CA

408-863-4194

Cupertino, CA

781-676-2460

Lexington, MA

support@rational.com
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Europe, Middle

East, and Africa

+31-(0)20-4546-200

Netherlands

+31-(0)20-4546-201

Netherlands

support@europe.rational.com

Asia Pacific 61-2-9419-0111

Australia

61-2-9419-0123

Australia

support@apac.rational.com
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11 Before You Install

Before you install Rational Suite ContentStudio on one host or four hosts, you must complete the

prerequisite installations described in this chapter.

1.1 Rational Suite ContentStudio Configuration

The configuration for ContentStudio varies on the basis of your needs and organization

requirements. We break the configuration into three categories: clients hosts, development

environment hosts, and production environment hosts.

Client hosts access the development environment. You typically have a client host for each

ContentStudio user. The configuration of the client machines depends on the needs of the user.

Clients can be as minimal as a browser client or as powerful as a full Windows client with all the

tools. After a development environment is installed and configured, you can install client

software on the hosts of development team members. For more information, see Chapter 4,

Installing Client Software.

Development environment hosts support the ContentStudio components used to develop and

manage the Web application. The Web servers that run an application that your site visitors

access are not considered development environment hosts. For more information, see Determine
the Host Configuration for Your Development Environment on page 2.

Production environment hosts (target Web servers) run the Web application in the development

environment. Using the Rational NetDeploy agent, the target Web servers receive copies of

HTML pages, files (graphics, movies, sound) or code (JAR files, JSPs, and so on) from the

development environment and store them for execution. For more information, refer to

Chapter 5, Installing and Configuring the Rational NetDeploy Agent.
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Figure 1 shows how this environment may be configured.

Figure 1 Rational ContentStudio Environment

Determine the Host Configuration for Your Development Environment

There are many ways to configure your development environment for Rational Suite

ContentStudio. The typical and recommended configuration for most groups uses four host

machines. At a minimum, one host can be used to run all the servers; we recommend this type

of configuration only for evaluation purposes or for a small production group.

The typical configuration includes the following hosts:

➤ Database server and databases host (DB_Host)

Firewall

Servers

Clients

CMS

ContentStudio

Development environment Production environment

CMS
database

ClearCase

Web server C

Web server B

Web server A

ContentStudio
Console

ClearQuest V/5 tools Web browser

ClearQuest
database
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This machine contains:

➣ database server software (Oracle or Microsoft SQL Server)

➣ Vignette CMS database (including the Rational Suite ContentStudio Server tables)

➣ Rational ClearQuest schema repository database

➣ Rational ClearQuest user database

➣ Rational Requisite Pro database

➤ Vignette CMS components host (CMS_Host)

This machine contains:

➣ database client software (Oracle or Microsoft SQL Server)

➣ Vignette CMS server

➣ ODBC connection to the CMS database (if SQL Server is used)

➣ Microsoft IIS

➣ Vignette V5 Tools

➣ Vignette development CDS (including development APE, ASP page generator)

➤ Rational ClearCase LT VOB server host (CCASE_Host)

This machine contains:

➣ Rational ClearCase LT server

➣ Rational ClearCase LT VOBs (admin VOB, content VOB, code VOBs)

➣ Rational Suite ContentStudio client (for Rational Suite Content Studio licensing)

➤ Rational Suite ContentStudio server host (CS_Host)

This machine contains:

➣ database client software (Oracle or Microsoft SQL Server)

➣ ODBC connection to the CMS database

➣ Rational Suite ContentStudio Server (Page Generator and Rational NetDeploy)

➣ Java Runtime Environment (JRE)

➣ Microsoft IIS (required for the live CDS)

➣ Vignette live CDS (including live APE and ASP page generator)

➣ Tomcat

➣ Rational Suite Team Unifying Platform

➣ FLEXlm server (optional)

For the one-host installation, these host names refer to the same physical machine; all software

mentioned above is installed on that host.

Detailed instructions for the installation of this software are in Chapter 2 and Chapter 3. The

remainder of this chapter takes you though specific steps you need to perform before you can

install the Rational Suite ContentStudio software.
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1.2 Overview of the Preinstallation Steps
1. Install the Correct Operating System on All Hosts

2. Set Up the IIS Environment

3. Install Database Software and Create Empty Databases

4. Configure Licensing

1.3 Install the Correct Operating System on All Hosts

For the one-host installation, install Windows 2000 Server running Service Pack 1 (SP1) or

Windows NT Server 4.0 running Service Pack 6a (SP6a) on the server host.

NOTE: Wherever Windows 2000 Server is mentioned, Advanced Server can also be installed in its

place.

For a four-host installation, install any of the operating systems listed for the specific server host.

All target Web server hosts running the Rational NetDeploy agent must be running

Windows 2000 Server (SP1) or Windows NT 4.0 Server (SP6a).

The client hosts must be running Windows 2000 Professional (SP1), Windows NT 4.0 (SP6),

Windows 98, or Windows Me.

Applicable Operating Systems

DB_Host Windows operating system required by the database vendor

CMS_Host Windows 2000 Server (SP1) or Windows NT 4.0 Server (SP6a) with

Internet Explorer 5.0 or Microsoft Scripting Engine 5.x
CCASE_Host Windows operating system required for Rational ClearCase LT

(see release notes)

CS_Host Windows 2000 Server (SP1) or Windows NT 4.0 Server (SP6a)
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1.4 Set Up the IIS Environment

The CMS_Host and the CS_Host must be set up for IIS. The way in which you install IIS depends

on whether you have Windows NT 4.0 Server or Windows 2000 Server.

This section explains the interaction of the IIS installation with the Windows NT Service Pack

installation and with Windows 2000. It also describes how to access the IIS Internet Services

Manager.

Windows 2000 Server

IIS 5.0 is usually installed by default when you install Windows 2000 Server. To verify that IIS is

installed, click Start>Settings>Control Panel and then double click Add/Remove Windows
Components. If Internet Information Services is not included in the list of existing programs,

you must install it from the Windows 2000 CD.

Windows NT Server

The V/5 components that you install in later steps require Service Pack 6a (SP6a) for

Windows NT Server 4.0 to be installed on your system. Because the installation of IIS 4.0

overwrites several files from the Service Pack, you must reinstall SP6a after you install IIS to

ensure correct system operation.

To check if IIS 4.0 is installed, click Start>Programs>Windows NT 4.0 Option Pack>Microsoft
Internet Information Server>Internet Service Manager to access the Internet Service Manager

window. If IIS is not installed, you must install IIS using the Windows NT 4.0 Option Pack.

NOTE: If you perform a custom installation of IIS, you need to also be sure to install the World

Wide Web Server.

1.5 Install Database Software and Create Empty Databases

The task of creating a new database usually involves identifying the DBMS Server, determining

a storage location of the database, creating a database owner, and optionally creating database

users.
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Before you install any database software, note the product-specific information in this section.

SQL Server

WARNING: Vignette requires a nondefault sort order of dictionary-order, case-sensitive for SQL

Server. If you do not know whether this option is set, you must reinstall SQL Server following

the instructions in Install SQL Server on page 6.

In Microsoft Sequel Server, Rational Suite Content Studio “databases” map to databases. The

concept of a Database User has two levels. First, you need a server login (that is, the username

and password). Next, to access a particular database, you need to be set up as a user of that

database. One complication here is that MSS permits you to give that user a different name than

the associated login.

Microsoft Sequel Server (MSS) comes in three versions: Desktop, Standard, and Enterprise. The

difference between these versions is in the number of connections supported, and in scalability.

Standard runs on Windows NT 4.0 Server and Windows 2000 Server; Enterprise runs on

Windows NT 4.0 Enterprise Server and Windows 2000 Advanced Server (and Data Centre). You

need to install either the Standard or Enterprise version (depending on which type of Windows

server you have).

Install SQL Server

On DB_Host:

1. Click Install Components. (Follow the procedures in the vendor installation guide.)

2. You must perform a Custom Install so that you can choose a sort order of Dictionary order,
Case Sensitive. Other than this, select all the installation defaults.

Create Empty Product Databases

Follow the instructions below to first create an empty database for the Vignette CMS, then the

ClearQuest Schema database, and then the ClearQuest User database.

On DB_Host:

1. Open SQL Server Enterprise Manager and select the Server Host hostname, where hostname
is the name of the host machine in a single server install or the name of DB_Host in a four

server install.
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2. Select the Databases folder and click Action>New Database. Use the name suggested below

corresponding to the database you are creating. We will use this name throughout the

installation documentation. Click OK.

3. Create a SQL Server userID (not a Windows User), with SQL Server Authentication, and

choosing the database name from Step #2 as the Default Database, using the following steps.

a. Open the Security folder and click Logins then right-click New Login.

Enter the UID Name. Use the name suggested below corresponding to the database you

created. We will use this name throughout the installation documentation.

Click SQL Server Authentication.

Enter a Password. We suggest rational.

b. Click on the Database Access tab.

Select Permit for the database created in Step #2 and enable the following access:

Click OK, confirm the password then exit SQL Server Enterprise Manager.

Install the SQL Server 7.0 Client

The client installation must be performed on both CMS_Host and CS_Host.

For a machine to access the SQL Server, you must install Microsoft Data Access Components

(MDAC). Most likely, each client already has these components. (If you can create an MSS Data

Source in the ODBC administrator, you have them.) MDAC (though not necessarily the latest

version) is available on the Microsoft Sequel Server CD as \x86\other\mdac_type.exe.

Perform a custom install from the SQL Server CD to install Client Connectivity and the

Management Tools.

CMS database CMSsystem
ClearQuest Schema DB CQschema
ClearQuest User DB CQrequests

CMS database vignette_sql
ClearQuest Schema DB cqadmin
ClearQuest User DB cquser

CMS database public, db_ddladmin, db_datareader, db_datawriter
ClearQuest Schema DB public, db_owner
ClearQuest User DB public, db_owner
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Oracle 8i (8.1.16) Server

Install Oracle Server

There is nothing special to do when installing Oracle 8i on DB_Host. In general, accept the

defaults offered, and note any names or values that you provide to the setup script.

1. Install a supported version of Oracle.

Create Empty Product Databases

On DB_Host:

Follow the instructions below to create empty databases for the Vignette CMS , the ClearQuest

Schema database, and the ClearQuest User database .

1. Create an Oracle System ID.

2. At a SQL*Plus prompt, type the following sequence of commands:

create tablespace CMSSYSTEM logging datafile 'disk:file\filename' size 200M;
alter user CMSSYSTEM default tablespace CMSSYSTEM;
alter user CMSSYSTEN temporary tablespace temp;
alter user CMSSYSTEM quota unlimited on CMSSYSTEM;
grant CONNECT to CMSSYSTEM;
grant RESOURCE to CMSSYSTEM;

ClearQuest schema: tablespace name and user CQSCHEMA, roles CONNECT and RESOURCE
ClearQuest user DB: tablespace name and user CQREQUESTS, roles CONNECT and

RESOURCE

3. Start the Oracle listener.

Install the Oracle 8i Client

The client installation must be performed on both CMS_Host and CS_Host.

If you are setting up a Rational Suite ContentStudio machine (client or server) to connect to an

ORACLE database on another server, you must install the Oracle client tools. These are available

on the ORACLE installation CD.
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1.6 Configure Licensing

Rational Suite ContentStudio uses Rational common licensing. For details about how Rational

Common licensing works, refer to the manual Administering Licenses for Rational Software.

Rational Suite ContentStudio is available with either floating or node-locked licenses.

Floating Licenses

If you purchased floating licenses, you need to install a FLEXlm server to administer them. For

a one-host installation, you can install FLEXlm server on that host. For the four-host installation,

we recommend that you install FLEXlm server on CS_Host. If you already have Rational

products and FLEXlm server, you can continue to use that server for your Rational Suite

ContentStudio License.

To install FLEXlm server to administer floating licenses, insert the CD titled Rational Solution for
Windows. In the Rational Software Setup program, click Installation option panel, and then click

Install license server.

After you install the FLEXlm server, you can request your floating licenses by using Rational

AccountLink. AccountLink is available on the Rational Web site www.rational.com/accountlink.

You need the License Key Certificate shipped in the Rational Suite Media Kit to complete the

information required for AccountLink. AccountLink will validate your request, and send your

keys as an attachment to an e-mail message. Then you can use the Rational License Key

Administrator to import the attachment as a file into the license server.

Node-Locked Licenses

If you purchased node-locked licenses, you do not need to install a FLEXlm license server.

However, you need to request a node-locked license for each client host as well as the

CCASE_Host and CS_Host and then run the License key administrator to import the key for

each of those hosts.
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Vignette CMS Server Licenses

To install the Vignette software according to the instructions in subsequent chapters, you will

need an additional license key and a CD-ROM key. To obtain these keys, send an e-mail message

to one of the addresses below. In the message, please specify that you are requesting your

ContentStudio Vignette CMS server keys, and include your account number. You can find your

account number in the upper left corner of the License Key Certificate shipped in the Rational

Suite Media Kit. You will receive your Vignette license key by return e-mail.

1.7 Installation Tables

The installation procedure is complex and requires you to enter a large amount of data. You must

enter some of the values in multiple steps. To aid with your installation, the suggested values and

Your Location Telephone Facsimile Email

North America

(East Coast) and

South America

+1 (800) 433 5444

toll free

+1 (781) 676 2460

Massachusetts

license@rational.com

North America

(West Coast) and

Central America

+1 (800) 433 5444

toll free

+1 (408) 863 4001

California

license@rational.com

Europe, Middle

East, and Africa

+31 20 4546 200

Netherlands

+31 20 4546 202

Netherlands

license@europe.rational.com

Asia Pacific (Japan) +61 2 9419 0111

Australia

+61 2 9419 0123

Australia

license@japan.rational.com

Asia Pacific

(Korea)

+82 2 556 9420

Korea

+82 2 556 9426

Korea

 license@apac.rational.com

Asia Pacific

(Mainland China,

Hong Kong,

Taiwan)

+61 2 9419 0111

Australia

+61 2 9419 0123

Australia

 license@china.rational.com

Asia Pacific +61 2 9419 0111

Australia

+61 2 9419 0123

Australia

license@apac.rational.com
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some defaults used in the installation steps are included in the following tables. Use the tables to

record information specific to your installation and configuration, mapping suggested names to

the names you are using. Shaded table cells reuse information that you’ve already supplied in

another cell.

Table 1 The Four Hosts

Description (Mnemonic) Suggested Name Your Name

Database Host (db-host) DB_Host

Vignette CMS Host (cms-host) CMS_Host

Rational ClearCase LT Host (ccase-host) CCASE_Host

Rational Suite ContentStudio Host (cs-host) CS_Host

Table 2 Vignette-related Information  (Part 1 of 2)

Description (Mnemonic)  Suggested Name Your Name

Vignette Development CDS

(dev-cds)

devCDS

Vignette Development ASP

(dev-asp)

devASP

Vignette Live CDS (live-cds) livCDS

Vignette Live ASP (live-asp) livASP

Web server Doc Root

(doc-root)
C:\Inetpub\wwwroot

Directory name for Dev

CDS (devcds-dir-name)

devCDS

Directory name for Dev

ASP (devasp-dir-name)
devASP

Directory name for Live

CDS (livcds-dir-name)
livCDS
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Directory name for Live

ASP (livasp-dir-name)
livASP

Doc root for Development

CDS Web Server

doc-root\devcds-dir-name

C:\Inetpub\wwwroot\devCDS

Doc root for Development

ASP Web Server

doc-root\devasp-dir-name, that is

C:\Inetpub\wwwroot\devASP

Doc Root for Live CDS Web

Server

doc-root\livcds-dir-name, that is

C:\Inetpub\wwwroot\livCDS

Doc Root for Live ASP Web

Server

doc-root\livasp-dir-name, that is

C:\Inetpub\wwwroot\livASP

Anonymous User Account

for development CDS, ASP

IUSR_cms-host, that is

IUSR_CMS_Host

Anonymous User Account

for live CDS, ASP

IUSR_cs-host, that is

IUSR_CS_Host

Web Server Host cms-host, that is CMS_Host

Data Source Name

(db-source)

vignetteODBC

DB URL jdbc:odbc:db-source, that is

jdbc:odbc:vignetteODBC

V/5 Business Platform

Login/Password

admin/admin

Metafile path for

Development CDS

c:\vignette\Inst-CMSsystem\
working\cds-dev-cds\metafiles

Metafile path for Live CDS c:\vignette\Inst-CMSsystem\
working\cds-live-cds\metafiles

Project Manager Base

Project

test

FLEXlm server host cs-host, that is CS_Host

Table 2 Vignette-related Information  (Part 2 of 2)

Description (Mnemonic)  Suggested Name Your Name
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Table 3 ClearCase-related Information

Description (Mnemonic) Suggested Name Your Name

ClearCase Content VOB content

ClearCase View cs_pagegenerator

ClearCase View prefix cs_deployment

ClearCase Label prefix CS_DEPLOYED

ClearCase Views directory c:\ClearCaseStorage\Views

ClearCase Admin VOB projects

Table 4 Database-related Information

Description (Mnemonic) Suggested Name Your Name

Host db-host, that is DB_Host

SQL Authentication

Login/Password

vignette_sql/rational

Oracle databases password RATIONAL

SQL Default CMS Database CMSsystem

Oracle CMS DB User and

Tablespace Name

CMSSYSTEM

SQL Physical ClearQuest

Schema Database Name

CQschema

Oracle ClearQuest schema

User and Tablespace Name

CQSCHEMA

Physical ClearQuest User

Database Name

CQrequests

Oracle ClearQuest User DB

User and Tablespace Name

CQREQUESTS
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Table 5 Miscellaneous Information

Description (Mnemonic) Suggested Name Your Name

Rational Installation

Directory (ratl-dir)

c:\Program Files\Rational

CS Logging Directory ratl-dir\ContentStudio\logs

JRE Install Directory

(default)

ratl-dir\common\java\jre

Tomcat Install Directory

(default)

ratl-dir\ContentStudio\tomcat

ClearQuest Designer

username/password

admin/(none)

ClearQuest User Database RSCS

Proxy URL /contentstudio/proxy

Table 6 Port Numbers  (Part 1 of 2)

Description Suggested Port Number Your Port Number

Development CDS Port 80

Development ASP Port 81

Dispatch Service (bob) Port,

CMS Port

30210

Request Service (vhs) Port 30211

Placement Agent Port, Dev and

Live CDS

3737 (four host Dev CDS)

3737 (four host Live CDS)

3737 (one host Dev CDS)

3739 (one host Live CDS)
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Cache Manager (cmd) Port 3738 (four host Dev CDS)

3738 (four host Live CDS)

3738 (one host Dev CDS)

3740 (one host Live CDS)

Page Generator (ctlv) Port 4738 (four host Dev CDS)

4738 (four host Live CDS)

4738 (one host Dev CDS)

4740 (one host Live CDS)

Template Manager (tmd) Port 4739 (four host Dev CDS)

4739 (four host Live CDS)

4739 (one host Dev CDS)

4741 (one host Live CDS)

CDS Port 8080

ASP Port 8081

Tomcat Port 8088

Target Web site 90

Table 7 Rational NetDeploy Agent Information

Description (Mnemonic) Suggested Name Your Name

Target Web site path doc-root\targetsite, that is

C:\Inetpub\wwwroot\targetsite

Table 6 Port Numbers  (Part 2 of 2)

Description Suggested Port Number Your Port Number
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22 One-Host Installation

At a minimum, one host can be used to run all Rational Suite ContentStudio servers. We

recommend this type of configuration only for evaluation purposes or for a small production

group.

2.1 Overview of the Installation Procedure

Before you begin the one host installation, you must complete the prerequisite installation steps

described in Chapter 1, Before You Install.

To install ContentStudio, you first install, configure, and license all server components, and then

install, configure, and license all client components. Here is an overview of this installation:

1. Configure IIS

2. Install and Configure Vignette V/5 Server Components

3. Install and Configure ClearCase LT Server

4. Install and Configure ContentStudio Server

5. Install Rational Suite Team Unifying Platform

6. Configure ClearQuest

7. Optionally, Configure RequisitePro Database

8. Verify Operational Status
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9. Refer to Chapter 4, Installing Client Software for the details of the client installation procedure.

10. Refer to Chapter 5, Installing and Configuring the Rational NetDeploy Agent for the details of

installing and configuring the Rational NetDeploy agent on your target Web servers.

The remaining sections in this chapter explain how to perform Step #1 through Step #8.

2.2 Configure IIS

You must configure IIS 4.0 or later to:

➤ Set up IIS virtual Web services for the Vignette components

➤ Configure Web server properties

➤ Set permissions for virtual services folders

Set Up IIS Virtual Web Services for the Vignette Components

You need to set up four Web virtual services for development CDS, live CDS, development ASP,

and live ASP. You also need to assign different port numbers for each of these services. Make sure

that the port numbers you select are not currently in use by another Web service.

To Configure Virtual Services with IIS

1. In Windows Explorer, navigate to drive:\Inetpub. Create new folders for each of the Web

virtual services. The default server uses drive:\Inetpub\wwwroot. We recommend these

directory names:

➣ drive:\Inetpub\wwwroot\devCDS
➣ drive:\Inetpub\wwwroot\livCDS
➣ drive:\Inetpub\wwwroot\devASP
➣ drive:\Inetpub\wwwroot\livASP

2. Start Internet Service Manager.

3. Open the Internet Information Server folder and under Internet Information Server locate

the host on which you are configuring IIS.
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4. Right-click the host name and click New>Web Site. In the WebSite Creation Wizard for the

Web Site Description, create Web sites using the information provided below.

NOTE: The Default Web server uses port 80. This port number conflicts with the development

CDS port recommended above. Delete the Default Web server after you create the

development CDS.

a. Enter the Web site description. Click Next.

b. Accept the default, All Unassigned in the Enter the IP address to use for this Web site
box.

c. Enter the port number. Click Next.

d. Enter the path and allow anonymous access to the Web site. Click Next.

e. For IIS with Windows 2000, select Allow Read, Run scripts, and Execute access, and for

IIS with Windows NT 4.0, select Read Access, Script Access, and Execute Access; then

click Finish.

5. After creating the Web sites, you must enable buffering. Use the Internet Services Manager

to enable buffering for each of the new Web sites.

a. Select each one of the new folders that you have created for the Web sites and right-click

to open the Properties window.

b. Click the Home Directory tab; then click Configuration and click the App Options tab

in the Application Configuration dialog box. Click Enable buffering.

c. Click OK and OK again.

Configure Web Server Properties

Configure Web server properties for the two IIS Virtual Servers CDSs defined previously.

NOTE: IIS 5 differs from IIS 4 with respect to selections. IIS 5 uses pull-down lists and IIS 4

employs option buttons. Naming conventions for tabs and fields remain identical or are very

similar in both versions.

Web site description Port Path

Development CDS 80 drive:\Inetpub\wwwroot\devCDS

Development ASP 81 drive:\Inetpub\wwwroot\devASP

Live CDS 8080 drive:\Inetpub\wwwroot\livCDS

Live ASP 8081 drive:\Inetpub\wwwroot\livASP
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1. Click Development CDS and right-click to select Properties.

2. Determine the Anonymous User Account by clicking the Directory Security tab. Click Edit
next to Anonymous Access and Authentication Control, and then click the Edit next to

Allow Anonymous Access.

You will see the Anonymous User Account IUSR_ hostname. You will need to refer to this

name later in this IIS configuration. Click Cancel to return to the Properties window.

3. Click the Home Directory tab.

In the Application Setting box, if using IIS 5.0, enable Execute Permissions: Scripts and
Executables. If using IIS 4.0, enable Permissions: Execute (Including Scripts).

a. Create two application mappings: one for .html and one for .htm. To do this, select

Configuration.

b. Click the Application Mappings tab. Click Add. Enter the following:

NOTE: Leave Script Engine check box selected. Click OK.

4. Click the Documents tab. Move default.htm to the top of the list. If default.htm isn’t in the

list, add it and then move it to the top of the list.

5. Close the Internet Service Manager and click Yes to save console settings.

6. Repeat Step #1 through Step #5 for Live CDS.

Set Permissions for Virtual Services Directories

7. Select Security and click Permissions. In the Directory Permissions window, note whether

there is an entry for the Web server anonymous user whose name you found through the IIS

Management (for example: IUSR_hostname).

8. If the Web server anonymous user is listed go to Step #9, otherwise continue with this step

to add the user:

a. Click Add to open the Add Users and Groups dialog box.

Executable Extension

drive:\Winnt\system32\inetsrv\ssinc.dll .htm

drive:\Winnt\system32\inetsrv\ssinc.dll .html
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b. Select the name of the Web server host (for example: web02) from List Names From: and

click Show Users to display all configured users on this Web server.

c. Select the Internet Server anonymous access user whose name you found through the IIS

Management Console (for example: IUSR_web02).

d. Click Add. Then click OK to return to Directory Permissions.

9. In Windows 2000, select the anonymous user and from the Permissions list box select

Modify. In Windows NT 4.0, select the anonymous user and set the Type of Access to

Change (to provide read, write, delete, and execute permissions).

10. On Windows NT, select both options: Replace Permissions on Subdirectories and Replace
Permissions on Existing Files. Click OK. (Windows 2000 will set these options by default.)

11. When prompted if you want to replace security information on all existing subdirectories,

click Yes.

12. Return to Windows Explorer and repeat the steps above for the remaining virtual servers.

13. Click My Computer>Control Panel>Services and click World Wide Web Publishing
Service. Stop and then start it.

14. Close Services.

15. Configure ODBC Connection to CMS Database

The database environments that V/5 CMS supports are Microsoft SQL Server 7.0 and Oracle

8.1.16i.

Using the CMS database that you created using instructions in Chapter 1, Before You Install:

For MS SQL Server 7.0

1. Open the Data Sources (ODBC) Administrator in the Control Panel.

2. Click the System DSN tab. Perform the following steps to create a system DSN that will

allow for connections to the database, whatever its location.

3. Click Add and select SQL Server, then click Finish.

a. In the Create a New Data Source to SQL Server dialog box, supply a name, description,

and server. We suggest the following:

Name vignetteODBC
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Click Next.

b. Select With SQL Server authentication...

Select Connect to SQL server to obtain default settings...

Click Next.

c. Select Change the default database to: CMSsystem. Click Next. Click Finish.

d. Click Test Data Source to verify.

e. Click OK and OK again.

For Oracle 8.1.16i

1. Create a System DSN in the ODBC Data Sources Administrator (in Control Panel) that will

allow for connections to the database, whatever its location. Perform the following steps:

2. Click Add and select Oracle ODBC Driver, then click Finish.

a. In Oracle* ODBC Driver Setup, supply the following:

b. Click OK.

2.3 Install and Configure Vignette V/5 Server Components

The following sections provide the procedures for installing Vignette V/5 Server components.

Description enter a description

Server DB_Host

Login ID vignette_sql
Password rational

Data Source Name vignetteODBC
Description enter a description

Service Name DB_Host
User ID CMSSYSTEM
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Install V/5 Base Platform

You must install the Base Platform software on each system on which you will create a CMS

and/or a CDS. If you are configuring a Web server on a host that is remote from its CDS, you

must install this software on that host.

To perform this part of the installation, insert the CD titled Rational Suite ContentStudio Vignette
Content Management Server.

1. In the V/5 Content Management Server 5.5 window, click Install Software.

2. Click e-Business Platform Base Installation.

3. In the Vignette V/5 Base Platform 5.5 Setup box, click Next.

4. In the License Agreement dialog box, click Yes.

5. In the View Release Notes dialog box, answer as you prefer.

6. In the Select Components dialog box, select all and click Next.

7. In the Choose Destination Location dialog box, take the default and click Next.

8. In the Select Program Folder dialog box, take the defaults and click Next.

9. In the Confirm Destination dialog box, click Next.

10. After files are updated, click Finish.

11. Exit.

Apply the Vignette 5.5.1 Patch

The Vignette 5.5.1 Patch is required to run ContentStudio. This patch is available on the CD titled

Rational Suite ContentStudio Integrations. Perform the following steps:

1. Insert the CD and navigate to \ContentStudio\misc\updates\Vignette.

2. Double-click ss55-551.exe.

3. From the Install Shield Wizard, click Next.
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4. Click Yes on the License Agreement dialog box.

5. In the Choose Destination Location dialog box, take the default and click Next.

6. Click Finish.

Create and Configure a New CMS

The content management server (CMS) is the control center for V/5 Platform software, storing

its information in the system database (CMS system in our example). The CMS processes

production management information for a site. Only one CMS can be configured per instance of

V/5 platform software. Admin and guest user IDs are created during installation. For details, see

the Vignette V/5 Platform Installation and Configuration Guide.

1. Start the Platform Manager. Click Start>Programs>Vignette e-Business Platform
5.5>Platform Manager.

2. In the Vignette V/5 e-Business Platform Configuration box, click Create a new Content
Management Server and then click OK.

3. In the V/5 e-Business Platform: New CDS wizard:

a. In the Contact and License Information pane, complete all of the fields. You must have

previously requested the CD Key and License Key through email using the instructions

in Chapter 1.

b. In the Local Host Information pane, take the default value in the Name for this Host
field, which is your host name.

c. In the Assign Instance Name pane, provide a name for the platform instance. We

recommend CMSsystem.

d. In the Server Host and Ports pane, take the default values:

e. In the Database Type pane, select the vendor and version you are using.

Host hostname.domain-name
Dispatch Service (bob) Port 30210

Request Service (vhs) Port 30211
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f. In the Database Server and Login pane, take the defaults for these fields, which were

specified in a previous step:

g. In the Secure Database Setup pane, click Use the Login configured with the system
database.

h. In the Auto Start CMS pane, click Start the CMS if the system is rebooted.

i. Click Finish.

Create and Configure a Development CDS

If you are still in the V/5 e-Business Platform Manager, begin at Step #4.

1. To start the Platform Manager, click Start>Programs>Vignette e-Business Platform
5.5>Platform Manager.

2. Click Configure an Existing Content Management Server.

3. In the V/5 e-Business Platform Login box, use the recommended values:

4. Select Content Management Server (CMS), right-click and then click New Content
Delivery Server (CDS).

5. In the V/5 e-Business Platform: New CMS wizard:

a. In the CDS type pane, click Development, then click Next.

b. In the Assign Name pane, provide a name. We recommend devCDS. Click Next.

c. In the Docroot Manager Host and Ports pane, take the default values, then click Next.

Data Source Name vignetteODBC

Data User Login vignette_sql

Database User Password rational

Location hostname.domain-name:port (the default port is 30210)

Userid admin
Password admin

Host hostname.domain-name
Placement Agent 3737

Cache Manager (cmd) Port 3738
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d. In the Docroot Information pane, specify the path from a previous step:

drive:\Inetpub\wwwroot\devCDS, then click Next.

e. In the Cached Pages pane, click Web Server, then click Next.

f. In the Auto Start CDS pane, click Start the CDS if the system is rebooted, then click

Next.

g. In the Initial Docroot Manager Startup pane, click Start the Docroot Manager now,

then click Next.

h. Click Finish.

Create and Configure a Development APE

Use the application engine (APE) to associate a Web server with the CDS, so that the CDS can

begin serving pages. For details, see the Vignette V/5 Platform Installation and Configuration Guide.

1. In V/5 e-Business Platform Manager, select the development CDS name, right-click and then

click Application Engine>New Application Engine.

2. In the V/5 e-Business Platform: New Application Engine wizard:

a. In the Application Engine Host and Ports pane, take the default values:

b. In the Initial Application Engine Startup pane, click Start the Application Engine now.

c. Click Finish.

3. Select the APE that you created. Right-click and then click Enable COM extensions. Click

Finish.

Associate the Web Server

You must associate one or more Web servers for each CDS. When you associate multiple Web

servers with a CDS, make sure that all Web servers use the same doc root. For more information,

see the Vignette V/5 Platform Installation and Configuration Guide.

1. In V/5 e-Business Platform Manager, select the named development CDS, right-click and

click Associate Web Server.

Host Name hostname.domain-name
Page Generator (ctlv) Port 4738

Template Manager (tmd) Port 4739
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2. In the V/5 e-Business Platform: Associate Web Server wizard:

a. In the Host Confirmation pane, click Next.

b. In the Assign Name pane, provide a name. We recommend devCDS.

c. In the Web Server Type pane, click your server type (for example, Internet Information
Server 5.0.)

d. In the Web Server Instance pane, click Development CDS.

e. In the Secure Web Server Setup pane, click No.

f. In the Directory Information pane, take the defaults for these fields:

g. In the Web Server Startup pane, click Restart the Web Server now.

h. Click Finish.

Select ASP Generator for the Development APE

If the IIS instance that will act as an ASP Page Generator uses SSL to communicate with the V/5

platform Web server module (if CDS-CMS communication needs to be secure), you need to

configure certain V/5 variables before you create the ASP Page Generator. For more information,

see Vignette V/5 Platform Installation and Configuration Guide.

1. In Platform Manager, select the development APE name; right-click and then click Add ASP
Page Generator.

2. In the V/5 e-Business Platform: Add an ASP Page Generator wizard:

a. In the Host Confirmation pane, click Next.

b. In the Web Server Instance pane, click Development ASP and click Next.

c. In the Web Server Protocol Setup pane, click No, then click Next.

d. In the Web Server Host and Port pane, take the defaults:

Docroot drive:/Inetpub/wwwroot/devCDS

Metafiles Path drive:/Vignette/Inst-CMSsystem/working/cds-dev

CDS/metafiles/

Dynamic Pages Path Leave blank

Host Name hostname.domain-name
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Then click Next.

e. In the Directory Information pane, take the default:

Then click Next.

f. In the ASP Page Generator Startup pane, click Restart the Web Server.

g. Click Finish.

h. Exit the Platform Manager.

Create and Configure a Live CDS

1. Select Content Management Server (CMS), right-click and then click New Content Delivery
Server (CDS).

2. In the V/5 e-Business Platform: New CDS wizard:

a. In the CDS type pane, click Live, then click Next.

b. In the Assign Name pane, provide a name. We recommend livCDS. Click Next.

c. In the Docroot Manager Host and Ports pane, take the defaults:

Click Next.

d. In the Docroot Information pane:

Click Next.

e. In the Cached Pages pane, click Web Server, then click Next.

Port 81

Template Cache drive:\Inetpub\wwwroot\devASP

Host hostname.domain-name
Placement Agent (pad) Port 3739

Cache Manager (cmd) Port 3740

Docroot drive:\Inetpub\wwwroot\livCDS
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f. In the Auto Start CDS pane, click Start the CDS if the system is rebooted, then click

Next.

g. In the Initial Docroot Manager Startup pane, click Start the Docroot Manager now.

h. Click Finish.

Create and Configure a Live APE

1. In Platform Manager, select the named live CDS, right-click and click Application
Engine>New Application Engine.

2. In the V/5 e-Business Platform: New Application Engine wizard:

a. In the Docroot Manager Host and Ports pane, take the defaults:

Click Next.

b. In the Initial Application Engine Startup pane, click Start the Application Engine now.

c. Click Finish.

3. Select the APE that you created. Right-click and click Enable COM extensions. Click Finish.

Associate the Web Server

1. In Platform Manager, select the live CDS name, right-click and click Associate Web Server.

2. In the V/5 e-Business Platform: Associate Web Server wizard:

a. In the Host Confirmation pane, click Next.

b. In the Assign Name pane, provide a name. We recommend livCDS.

c. In the Web Server Type pane, click your server type (for example, Internet Information
Server 5.0.)

d. In the Web Server Instance pane, click Live CDS.

e. In the Secure Web Server Setup pane, click No.

Host Name hostname.domain-name
Page Generator (ctlv) Port 4740

Template Manager (tmd) Port 4741
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f. In the Directory Information pane, take the defaults:

g. In the Web Server Startup pane, click Restart the Web Server.

h. Click Finish.

Select ASP Generator for the Live APE

1. In V/5 e-Business Platform Manager, select the live APE (ape-1 under LivCDS), right-click

and click Add ASP Page Generator.

2. In the V/5 e-Business Platform: Add an ASP Page Generator wizard:

a. In the Host Confirmation pane, click Next.

b. In the Web Server Instance pane, click Live ASP, then click Next.

c. In the Web Server Protocol Setup pane, click No, then click Next.

d. In the Web Server Host and Port pane, take the defaults, then click Next.

e. In the Directory Information pane, take the default, then click Next.

f. In the ASP Page Generator Startup pane, click Restart the web server.

g. Click Finish.

3. Close Platform Manager.

Setting Service Dependencies

When you install the CMS and CDS on the same Windows NT host as the database, certain

services will not start properly until the database is running. The following services are

Docroot drive:/Inetpub/wwwroot/livCDS

Metafiles Path drive:/Vignette/Inst-CMSsystem/working/cds-livCDS

/metafiles/

Dynamic Pages Path Leave blank

Host Name hostname.domain-name
Port 8081

Template Cache drive:\Inetpub\wwwroot\livASP
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dependent on the database service: CMS Dispatch Service (bob), CDS Template Manager (tmd)

and the Vignette watchdog (vwd). To prevent service failure, all of these services must start after

the database starts. Set the dependencies for start sequence by entering commands in a

Windows NT Prompt window.

For more information, see the Vignette V/5 e-Business Platform Tools Installation Guide.

1. Open a command prompt window and change to this directory:

drive:\vignette\5.5\bin\winnt

2. In the Windows registry, look for this key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

Be careful when navigating through the registry. Do not make any changes to it.

3. Locate the keys of form given below. (These keys were created by the Vignette installation.)

The service name includes the process name (for example, bob, tmd, or vwd), the version

number, site name, and the port (for CMS).

➣ bob 5.5 inst-mysite
➣ inst-mysite 5.5 _cds-devCDS_ape_tmd_tmd-1
➣ inst-mysite 5.5 _cds-liveCDS_ape_tmd_tmd-1

If you used the suggested names in the instructions, these are the keys:

➣ bob 5.5 inst-CMSsystem
➣ inst-CMSsystem 5.5 _cds-devCDS_ape_tmd_tmd-1
➣ inst-CMSsystem 5.5 _cds-livCDS_ape_tmd_tmd-1

4. In the command prompt window, for each of the keys, enter the following command on a

single line:

bob –update –name "key-name" –depends DB-service

where key-name is the name of the key, and DB-service is either MSSQLServer or

OracleServiceORCL, depending on your database vendor.

For example, for the keys listed in Step #2 and a SQL Server database, these are the

commands:

bob –update –name "bob 5.5 inst-CMSsystem" –depends MSSQLServer
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bob –update –name "inst-CMSsystem 5.5 _cds-devCDS_ape_tmd_tmd-1" –depends
MSSQLServer

bob –update –name "inst-CMSsystem 5.5 _cds-livCDS_ape_tmd_tmd-1" –depends
MSSQLServer

5. Close the command prompt window.

6. Reboot the machine.

7. After you log back in, click Start>Programs>Administrative Tools>Event Viewer to

confirm that no errors occurred.

Install V/5 Platform Tools

Install V/5 Tools using the instructions in Install V/5 Platform Tools in Chapter 4 on page 92.

Install V/5 Development Center

Install V/5 Development Center using the instructions in Install V/5 Development Center in

Chapter 4 on page 92.

Configure Vignette Global.asa sample Template

The Vignette Global.asa sample template must be launched for Rational Suite ContentStudio

page generation to work. The Global.asa sample is a Vignette system template with global

Vignette variable definitions. Vignette installs the Global.asa sample template in the Samples
subproject.

To launch the Global.asa sample template:

1. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Tools.

a. In the Business Platform Login dialog box, take the defaults:

Location hostname:30210.domain-name
User ID admin

Password admin
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b. Click Window>Production Center>Project Manager.

2. Select the Global.asa sample template located in the Base Project >Applications>Samples
project folder, right-click, and click Launch.

3. In the Confirm Launch dialog box, click Immediately. The file now appears with a status of

Live .

Verify That Development and Live CDS/APE Are Running

To ensure that files will launch from a Web browser, and that the file object exists in the

development and live CDS, perform the following steps:

1. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Tools.

2. In the Business Platform Login dialog box, take the defaults:

3. Click Window>Production Center>Project Manager.

4. In the Project Manager dialog box, click Base Project.

5. Then click File>New Project.

6. Enter a new project name (we recommend test).

7. Select the new project name. Click File>Submit File.

8. Select a file that you want to display in your browser, for example any .gif, or .html file.

When prompted, enter the name of the directory (we recommend /test). Then click OK. The

selected file appears with a status of Ready to Launch.

9. Right-click the file name and click Preview to display the file.

If you are prompted to select a default Web browser, click OK. In the Preferences dialog box,

click Add and enter the browser name [IE], and browse for the browser location for

[...\iexplore.exe]. Click OK.

10. Verify that the new file object is in the development CDS. In Windows Explorer, look for this

file: drive:\Inetpub\wwwroot\devCDS\test\your-file.

Location CMS_Host.domain-name
User ID admin

Password admin
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11. After previewing, right-click the file name and click Launch.

12. In the Confirm Launch dialog box, click Immediately. The file now appears with a status of

Live .

13. Verify that the new file object is in the live CDS. In Windows Explorer, look for this file:

drive:\Inetpub\wwwroot\livCDS\test\your-file.

2.4 Install and Configure ClearCase LT Server

The procedure in this section installs Rational ClearCase LT. For more information, see the

chapter in the manual Installing Rational Suite. If you want to install full ClearCase, follow the

instructions in ClearCase Product Family Installation Notes.

Install ClearCase LT Server

To install ClearCase LT Server, insert the CD titled Rational Solutions for Windows.

1. In the Rational Software Setup dialog box, click Next.

2. In the Select Installation Option dialog box, click Install Rational ClearCase LT Server.
Click Next.

3. In the License Agreement dialog box, click Yes, I accept this agreement, then click Next.

4. In the Setup Confirmation dialog box, click Typical, then click Next.

5. In the Update Shared Components dialog box, click Next.

6. In the Confirmation dialog box, click Next.

Please wait while ClearCase  LT Server files are copied.

7. In the Restart Windows dialog box, select the Restart check box and click Finish.

8. After the machine reboots, login using the same credentials in order to complete the

ClearCase installation.
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When the ClearCase Setup Wizard starts, you will not be able to proceed if you are logged in as

Local Administrator. You must logoff and login as a member of the ClearCase primary group

with administrative privileges to run this wizard. Restart the wizard from

Start>Programs>Rational ClearCase LT Server>Rational ClearCase LT Server Setup Wizard.

Configure ClearCase LT Server

1. Click Next in the Welcome dialog box.

2. In the Create the ClearCase LT Storage Directory pane, take the default:

drive:\ClearCaseStorage

3. Complete the field in the Create ClearCase LT Source VOB pane:

4. In the Create Initial Clearcase LT Project pane, take the default in the Starting Project Title
field.

5. In the Will UNIX ClearCase LT Clients Use this Server pane, click No.

6. In the ClearCase LT Summary pane, click Finish.

7. Close the wizard.

NOTE: ClearCase LT will not be properly licensed until ContentStudio licenses are configured in

Configure ContentStudio Licenses on page 38.

2.5 Install and Configure ContentStudio Server

Install ContentStudio Server

Insert the CD titled Rational Suite ContentStudio Integrations. In the Rational Software Setup

Wizard, perform these steps:

1. In the Rational Software Setup dialog box, click Next.

Source VOB Name content

Import Source files (Clear the check box.)
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2. In the Select Installation Option dialog box, click Install Rational Product. Click Next.

3. In the Select and Install Licensing Option dialog box, click Install Product Before
Licensing. Click Next.

4. In the Choose Product to Install dialog box, click Rational Suite ContentStudio Server.
Click Next.

5. In the License Agreement dialog box, click Yes. Click Next.

6. In the Setup Configuration dialog box, click Typical, then click Next.

(See the Rational Suite ContentStudio Release Notes for information about any incompatibility

messages you receive.)

7. In the Confirmation dialog box, click Next.

Please wait while Rational Suite installs ContentStudio Server.

8. In the Restart Windows dialog box, click Restart. Click Finish to restart your computer.

After the machine reboots, you must login using the same credentials in order for the

installation to complete.

After setup completes, the Rational Suite ContentStudio Administration Utility will start

automatically.

Configure ContentStudio Server

In the Administration Utility, perform the following steps:

1. Complete these fields on the ClearCase tab:

VOB Name content
View Name cs_pagegeneration  (default)

View Prefix cs_deployment  (default)

Label Prefix CS_DEPLOYED (default)

Views Directory drive:\ClearCaseStorage\Views (does not yet exist)

Admin VOB Name projects
Use Shadow Directories
check box

(See the online help for more information.)
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2. Complete the fields on the ContentStudio tab:

3. Complete these fields on the V/5 tab:

4. Click OK to close the ContentStudio Administration Utility.

Create and Assign CS_ROLE for ContentStudio Users

1. From V/5 Tools (Start>Programs>Vignette e-Business Platform 5.5>Platform Tools),

perform the following steps:

2. Under Admin Center, click User Manager.

3. From the User Manager window, click File>New Role to create a new role for CS_ROLE.

NOTE: For additional information, see the online help for V/5 Admin.

4. On the Users tab, click admin, then right click Details. On the Roles tab, click CS_ROLE to

assign the new role to the admin user.

5. Create any new users who will need to log in to ContentStudio Console and add assign the

CS_ROLE to those users as well.

DB URL jdbc:odbc:vignetteODBC
DB UserID For SQL: vignette_sql; For Oracle: CMSSYSTEM
DB Password rational
Tomcat Fields leave blank

Logging Dir drive:\Program Files\Rational\ContentStudio\logs

CMS Host CMS_Host
CMS Port # 30210
CMS UserID admin
CMS Password admin
DB URL jdbc:odbc:vignetteODBC
DB Userid For SQL: vignette_sql; for Oracle: CMSSYSTEM
DB Password rational
CDS Host CS_Host
CDS Port # 8080
CDS DocRoot drive:\Inetpub\wwwroot\livCDS
CS Role CS_ROLE
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Configure ContentStudio Licenses

You must configure the software to use either node locked or floating licenses. Follow the

appropriate instructions below:

Configure Node Locked Licenses

1. Click Start>Programs>Rational Suite ContentStudio Server>Rational License
KeyAdministrator.

2. Click License>Go to Rational AccountLink.

3. On the Account Link page, click Get License Keys and follow the steps.

4. Account Link will send your license keys by e-mail. Open the message and save the

attachment. We recommend storing it in drive:\temp\license_for_hostname.

5. Click License>Import License Key(s) and select your license file.

6. In the Confirm Import pane, click Import, then click OK.

Configure Floating Licenses

1. Click Start>Programs>Rational Suite ContentStudio Server>Rational License Key
Administrator.

2. Click Point to FLEXlm license server to get my licenses. Click Next.

3. Click Settings>Service Configuration. Click Use License Server and enter the name of the

FLEXlm server host that you set up in Chapter 1. Click OK.

Configure CMS Database for ContentStudio

You must and add the required Rational Suite ContentStudio tables to the CMS database created

in Chapter 1. To do this, the ContentStudio tables must have the same owner as the Vignette

tables. Steps are listed below for Oracle and for Microsoft SQL.

Configuring Microsoft SQL Server

1. Click Start>Programs>MicroSoft SQL Server 7.0>Enterprise Manager.
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2. Expand Microsoft SQL Server, expand SQL Server Group then click DB_Host.

3. In the SQL Server Enterprise Manager, click Tools>SQL Server Query Analyzer.

4. Click File>Connect.

In the Connect to SQL Server dialog box, complete the fields:

5. Select the CMS system database created earlier (CMSsystem) from the DB drop-down box.

6. Click File>Open navigate to the script file: drive:\Program
Files\Rational\ContentStudio\db_scripts\RSCSinitdb.mss.sql, then click Open.

7. Click Query>Execute.

You will see “Query Batch completed” in the bottom of the window.

8. Quit Query Analyzer and then Enterprise Manager.

Configuring Oracle

1. Start SQL*Plus Worksheet, connecting as the ORACLE schema user (default CMSSYSTEM)

that has been created in Chapter 1, Before You Install.

2. Click Worksheet>Run Local Script. This command runs the script file in drive:\Program
Files\Rational\ContentStudio\db_scripts\RSCSinitdb.ora.sql.

Configure JRE and Tomcat

JRE 1.3 and Tomcat 3.2.1 are required to enable the servers for Rational Suite ContentStudio Page

Generator and Rational NetDeploy. The following are the default installation directories:

➤ For JRE, drive:\Program Files\Rational\common\java\jre
➤ For Tomcat, drive:\Program Files\Rational\ContentStudio\tomcat

Click Use SQL Server
Authentication

Click DB_Host

Login Name vignette_sql
Password rational
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Modify Tomcat Port Information

When installed by Rational Suite ContentStudio, Tomcat uses the TCP/IP port 8088 for its

communication with the Web server. This setting is in the file

drive:\Program Files\Rational\ContentStudio\tomcat\conf\server.xml. If another TCP/IP

service uses this port, you must change the setting.

Establish Tomcat as a Service

The Tomcat service should run as a domain user account with full ClearCase privileges. You can

change the UID the Tomcat service runs as by performing the following steps:

1. Open a command prompt window.

2. Change to the directory drive:\Program Files\Rational\ContentStudio\tomcat\bin

3. Install jk_nt_service. To do so, enter a command of this form:

jk_nt_service -i name-of-service path-to-wrapper-properties

Given the defaults used in this section, the command would be as follows:

jk_nt_service -i Tomcat "drive:\Program Files\Rational\ContentStudio\tomcat\conf\wrapper.properties"

4. Start the services applet:

On Windows 2000, click Start>Programs>Administrative Tools>Services.

On Windows NT 4.0, double-click the services applet in Control Panel.

5. Locate the Tomcat service in the list of services, and double-click the entry.

6. Set the Startup Type to Automatic, then

on Windows 2000, click the Log on tab and then click This Account.

on Windows NT 4.0, in the section Log On As, click This Account.

7. Enter the appropriate User ID and Password information either directly into the fields or by

browsing. UserID must be entered in the form domain-name\user-name. To browse on

Windows 2000, click Browse; on Windows NT 4.0, click the ... button.

NOTE: The user identity for the Tomcat service must be a member of the ClearCase primary

group.
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8. Start the service by clicking the Start button.

9. Check the application log in the Windows Event Viewer to verify that the Tomcat service has

started successfully.

For more information on setting up Tomcat as a service, see the document

NT-Service-howto.html, which is located in

drive:\Program Files\Rational\ContentStudio\tomcat\doc.

Install Rational Suite Team Unifying Platform

The Team Unifying Platform edition of Rational Suite is designed for teams that need to share

artifacts, but do not require the productivity tools available in other editions of Rational Suite. in

particular, Team Unifying Platform will install ClearCase LT and ClearQuest.

To install Rational Suite Team Unifying Platform, insert the CD titled Rational Solutions for
Windows. The Rational Software Setup Wizard starts.

1. In the Rational Software Setup dialog box, click Next.

2. In the Select Installation Option dialog box, click Install Rational Product and click Next.

3. In the Select and Install Licensing Option dialog box, click Install Product Before
Licensing and click Next.

4. In the Choose Product to Install dialog box, click Rational Suite Team Unifying Platform
and click Next.

5. In the License Agreement dialog box, click Yes and click Next.

6. In the Setup Configuration dialog box, click Typical and click Next.

7. In the Update Shared Components dialog box, click Next.

8. In the Software Use dialog box, click Administrator and click Next.

9. In the Confirmation dialog box, click Next.

Please wait while Rational Suite installs Team Unifying Platform.

10. In the Restart Windows dialog box, click Restart. Click Finish to restart your computer.
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After the machine reboots, you must login using the same credentials in order for the

installation to complete.

2.6 Configure ClearQuest

Configuring ClearQuest involves creating a schema repository, adding the ContentStudio

package to the schema, creating a user database, and installing the V/5 package templates.

Create a Schema Repository

You must have installed ClearQuest and created empty vendor databases (as instructed in

Chapter 1, Before You Install), before you create the ClearQuest Schema Repository. The Schema

Repository is the master database in which ClearQuest stores schemas.

You will need the manual Installing Rational ClearQuest, which is available in print as part of the

media kit. In Chapter 3, Installing ClearQuest for an administrator, the section Creating ClearQuest
Databases explains how to create a schema repository using the ClearQuest Maintenance Tool.

Create the schema repository now using the empty database you created.

Add the ContentStudio Package to a ClearQuest Schema

You need to use the ContentStudio package to configure content change requests. For more

information, see Content Change Requests in ClearQuest in the manual Introducing Rational Suite
ContentStudio.

1. Start the ClearQuest Designer and log in. The user name is admin; leave the password field

blank.

2. In the Open Schema wizard:

a. In step 1 of 2, click Check out a schema to edit or continue editing previously saved
work.

Click on the Schema [Enterprise]. Click Next.
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b. In step 2 of 2, type a comment. Click Finish.

3. In the ClearQuest Designer, click Package>Package Wizard.

a. In the Package Wizard install/select package screen, click More Packages.

b. In Install Packages dialog box, click ContentStudio. Click OK.

c. In the Package Wizard install/select package screen, click ContentStudio.

d. Click Finish.

4. In the ClearQuest Designer, click Edit>Record Type Family Members.

a. In the Add/Remove Record Type Family Member pane:

➣ Click Record Type Families: All_CS_Requests

➣ In Available Record Types, click Defect and Enhancement Request.

b. Click Add and click Close.

5. Click File>Check In, type a comment, and click OK.

Create a User Database

You must have installed ClearQuest and created empty vendor databases as instructed in

Chapter 1, Before You Install), before you create the ClearQuest User Database. The User Database

stores data entered by the ClearQuest client and Web users. You can create as many user

databases as you need.

You will need the manual Installing Rational ClearQuest, which is available in print as part of the

media kit. In Chapter 3, Installing ClearQuest for an administrator, the section Creating ClearQuest
Databases, explains how to create a user database using the ClearQuest Designer.

Create a User database now using the empty database created in Chapter 1 and the information

below:

Logical database name RSCS
Schema Enterprise schema version 2
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Install V5_Package Templates

Installing the V/5 Package installs the Vignette templates and establishes CSVgnCQSvc as a

service.

1. Modify your system path variable to include Vignette. Add the following directory:

drive:\vignette\5.5\bin\winnt.

2. IMPORTANT: Restart your machine so that updated path information will be used for the

remaining steps.

3. Open a command prompt window.

4. Change to this directory drive:\Program Files\Rational\ContentStudio\cq_integration.

5. To install the V/5 integration with ClearQuest, enter a command of this form:

install_v5_package CMS-hostname:port CMS-username:CMS-password

Given the defaults used in this section, the command would be as follows:

install_v5_package CMS_Host:30210 admin:admin

6. Establish CSVgnCQSvc as a service.

a. Change to this directory:

drive:\Program Files\Rational\ContentStudio\bin

b. Execute a command of this form using any domain user:

CSVgnCQSvc -i domain-name\domain-userid domain-password

7. Verify the ContentStudio Administration Utility parameters for ClearQuest Integration.

Start the ContentStudio Administration Utility.

a. Click Start>Programs>Rational Suite ContentStudio Server>Rational Suite
ContentStudio Administration Utility and click the ClearQuest tab and complete the

boxes.

b. Complete these fields on the ClearQuest tab.

CQ UserID admin
CQ Password Leave blank.

CQ DB Name RSCS (name of ClearQuest User database)
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Assigning Permission to Run as Server

The user assigned in Step #6 requires “run as server” permission. If the service does not start, you

can verify user permissions as follows.

1. In Windows 2000, click Start>Programs>Administrative Tools>Services and in

Windows NT, open the Control Panel and click Services. Locate the service ContentStudio
Vgn to CQ synchronizer.

2. Double-click the ContentStudio Vgn to CQ synchronizer service and click the Logon tab.

Enter password and confirm password for the user. Click Apply. The message that appears

indicates that the Logon as Service right has been set.

3. Start the service.

ClearQuest Administration

1. Click Start>Programs>Rational Suite Team Unifying Platform> Rational ClearQuest to
start ClearQuest and log in as admin. Leave the password blank.

2. Select the User database that you created (RSCS).

3. Click Actions>New.

4. In Choose Record Type... pane, click CS_V5_Connection and click OK.

5. In Submit CS_V5_Connection pane, complete these fields:

The ClearQuest database is now set up.

CMS Host Name CMS_Host
CMS Port Number 30210
User Name admin
Password admin
CDS Host Name CMS_Host (host for the development CDS

CDS Port Number 80 (port for the development CDS)

Proxy Url /contentstudio/proxy  (default)

Default Project Path >Base Project>Content Studio
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2.7 Configure RequisitePro Database

RequisitePro is an optional component. If you plan to use it, you must configure a database.

For more information on configuring a RequisitePro database, see Installing RequisitePro which is

available on the Rational Solutions for Windows: Online Documentation CD.

2.8 Verify Operational Status

Check to see that your ContentStudio installation is functioning properly.

Verify ContentStudio Console Login

1. Log in from ContentStudio Console from the desktop where ContentStudio Client is

installed.

2. If log in fails, verify that the Tomcat service is started.

3. If Tomcat is stopped, check Windows Event Viewer for Tomcat error messages.

Verify ClearQuest Integration

1. On any host where ClearQuest client is installed, click Start>Programs>Rational Suite
Team Unifying Platform> Rational ClearQuest to start ClearQuest and log in.

2. Click Actions>New to open the Choose Record Type dialog box. Click

ContentChangeRequest and click OK.

3. In Submit Content Change Request dialog box, complete the Headline, Owner, and the

Description boxes. For information about each box, right-click to display a shortcut menu

and click Help.

CS Server hostname
User ID admin

Password admin
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4. Click OK to submit the content change request to the ClearQuest database.

5. Run the V5 Tasks to Assign query in the CS User Queries folder. This query retrieves all

unassigned V/5 Tasks (content change requests) that the current user owns or that have no

assigned owner.

6. Select the content change request that you want to assign and click Actions>Assign.

7. Complete the information on the V/5 Task tab in the Assign Content Change Request dialog

box.

➣ To select the name of your CMS server, click CMS.

➣ To select a V/5 owner, click Assignee.

➣ Verify that the information in the Project Path box is correct. This is where the

corresponding V/5 project task will be stored.

8. Click Apply.

9. Start Vignette from any host where V/5 Tools are installed and click Start Programs Vignette

Verify that it was created in Vignette task view.

10. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Tools.

a. In the Business Platform Login dialog box, take the defaults:

b. Click Window>Production Center>Task View.

11. Verify that there is an entry in the Task View window for the Content Change Request that

was submitted and assigned using the ClearQuest client.

Location hostname
User ID admin

Password admin
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33 Four-Host Installation

Rational Suite ContentStudio can be installed on four server hosts; this installation is intended

only for production purposes.

Database server is DB_Host.

Vignette CMS server is CMS_Host.

Rational ClearCase LT server is CCASE_Host.

Rational ContentStudio server is CS_Host.

3.1 Overview of the Four-Host Installation Procedure

Before beginning the installation for the four-host model, you must complete the steps in

Chapter 1, Before You Install. This section provides an overview of the four-host installation.

An empty database for the CMS has already been created on Database server (DB_Host). If this

has not yet been done, refer to the Chapter 1, Before You Install for instructions.

1. Install and Configure Vignette Server Components

➣ Configure IIS

➣ Create new CMS

➣ License CMS

➣ Create development CDS

➣ Create development APE
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➣ Create ASP Page Generator for development APE

➣ Install V/5 tools

➣ Verify the development CDS

➣ Configure IIS to create live CDS

➣ Create live CDS

➣ Create live APE

➣ Create ASP Page Generator for live APE

➣ Verify live CDS

2. Install and Configure ClearCase Host

➣ Install ContentStudio Client

➣ License ClearCase LT server

3. Install and Configure ContentStudio Host

➣ Install ContentStudio Server

➣ Install Rational Suite Team Unifying Platform

➣ Insert ContentStudio database into the CMS database

➣ Configure ClearQuest Package for ClearQuest master schema

➣ Configure ClearQuest user database for V/5_Package

➣ Configure Requisite Pro database

➣ Configure JRE and Tomcat

➣ Rerun ContentStudio Server Administration Utility

➣ Verify that four-host environment is functional

4. Refer to Chapter 4, Installing Client Software for the details of the client installation procedure.

5. Refer to Chapter 5, Installing and Configuring the Rational NetDeploy Agent for the details of

installing and configuring the Rational NetDeploy agent on your target Web servers.

The remaining sections in this chapter explain how to perform Step #1 through Step #3.

3.2 Install and Configure Vignette Server Components

You need to install and configure the Vignette server components for the CMS, the development

CDS, development APE and development ASP on of the CMS server (CMS_Host). You then

need to install and configure the live CDS, live APE, and live ASP on the ContentStudio Server

(CS_Host)
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Configure IIS

You must configure IIS 4.0 or later to:

➤ Set up IIS virtual Web services for the Vignette components

➤ Configure Web server properties

➤ Set permissions for virtual services folders

Set Up IIS Virtual Web Services for Vignette Components

On CMS_Host, you need to set up two Web virtual services for development CDS and the

development ASP. You must assign different port numbers for these services. Make sure that the

port numbers you select are not currently in use by another Web service.

To Configure Virtual Services with IIS

1. In Windows Explorer, navigate to drive:\Inetpub. Create new folders for each of the Web

virtual services. The default server uses drive:\Inetpub\wwwroot. We recommend these

directory names:

➣ drive:\Inetpub\wwwroot\devCDS
➣ drive:\Inetpub\wwwroot\devASP

2. Start Internet Service Manager.

3. Open the Internet Information Server folder and under Internet Information Server locate

the host on which you are configuring IIS.

4. Right-click the host name and click New>Web Site. In the WebSite Creation Wizard for the

Web Site Description, create Web sites using the information provided below.

NOTE: The Default Web server uses port 80. This port number conflicts with the development

CDS port recommended above. Delete the Default Web server after you create the

development CDS.

Web site description Port Path

Development CDS 80 drive:\Inetpub\wwwroot\devCDS
Development ASP 81 drive:\Inetpub\wwwroot\devASP
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a. Enter the Web site description. Click Next.

b. Accept the default, All Unassigned in the Enter the IP address to use for this Web site
box.

c. Enter the port number. Click Next.

d. Enter the path and allow anonymous access to the Web site. Click Next.

e. For IIS with Windows 2000, select Allow Read, Run scripts, and Execute access, and for

IIS with Windows NT 4.0, select Read Access, Script Access, and Execute Access; then

click Finish.

5. After creating the Web sites, you must enable buffering. Use the Internet Services Manager

to enable buffering for each of the new Web sites.

a. Select each one of the new folders that you have created for the Web sites and right-click

to open the Properties window.

b. Click the Home Directory tab; then click Configuration and click the App Options tab

in the Application Configuration dialog box. Click Enable buffering.

c. Click OK and OK again.

Configure Web Server Properties

On CMS_Host:

Configure Web server properties for the IIS Virtual Servers development CDS defined in Set Up
IIS Virtual Web Services for Vignette Components.

NOTE: IIS 5 differs from IIS 4 with respect to selections. IIS 5 uses pull-down lists and IIS 4

employs option buttons. Naming conventions for tabs and fields remain identical or are very

similar in both versions.

1. Click Development CDS and right-click to select Properties.

2. Determine the Anonymous User Account by clicking the Directory Security tab. Click Edit
next to Anonymous Access and Authentication Control, and then click the Edit next to

Allow Anonymous Access.
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You will see the Anonymous User Account IUSR_ hostname. You will need to refer to this

name later in this IIS configuration. Click Cancel to return to the Properties window.

3. Click the Home Directory tab.

In the Application Setting box, if using IIS 5.0, enable Execute Permissions: Scripts and
Executables. If using IIS 4.0, enable Permissions: Execute (Including Scripts).

a. Create two application mappings: one for .html and one for .htm. To do this, select

Configuration.

b. Click the Application Mappings tab. Click Add. Enter the following:

NOTE: Leave Script Engine check box selected. Click OK.

4. Click the Documents tab. Move default.htm to the top of the list. If default.htm isn’t in the

list, add it and then move it to the top of the list.

5. Close the Internet Service Manager and click Yes to save console settings.

Set Permissions for Virtual Services Directories

1. Using Windows Explorer, open the Properties window of the Web servers’ home directory

drive:\Inetpub\wwwroot\folder-name for each of the virtual services created for

development CDS and development ASP. Follow this procedure for each of the virtual

services.

2. Select Security and click Permissions. In the Directory Permissions window, note whether

there is an entry for the Web server anonymous user whose name you found through the IIS

Management (for example: IUSR_hostname).

3. If the Web server anonymous user is listed go to Step #4, otherwise continue with this step

to add the user:

a. Click Add to open the Add Users and Groups dialog box.

b. Select the name of the Web server host (for example: web02) from List Names From: and

click Show Users to display all configured users on this Web server.

Executable Extension

drive:\Winnt\system32\inetsrv\ssinc.dll .htm

drive:\Winnt\system32\inetsrv\ssinc.dll .html
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c. Select the Internet Server anonymous access user whose name you found through the IIS

Management Console (for example: IUSR_web02).

d. Click Add. Then click OK to return to Directory Permissions.

4. In Windows 2000, select the anonymous user and from the Permissions list box select

Modify. In Windows NT 4.0, select the anonymous user and set the Type of Access to

Change (to provide read, write, delete, and execute permissions).

5. On Windows NT, select both options: Replace Permissions on Subdirectories and Replace
Permissions on Existing Files. Click OK. (Windows 2000 will set these options by default.)

6. When prompted if you want to replace security information on all existing subdirectories,

click Yes.

7. Return to Windows Explorer and repeat the steps above for the remaining virtual servers.

8. Click My Computer>Control Panel>Services and click World Wide Web Publishing
Service. Stop and then start it.

9. Close Services.

Configure ODBC Connection to CMS Database

On CMS_Host, configure OBDC Connection for the CMS Database on DB_Host. Prior to this,

you should have created an empty CMS database on host DB_Host called CMS system during

Chapter 1, Before You Install.

The database environments that V/5 CMS supports are Microsoft SQL Server 7.0 and Oracle

8.1.16i.

Using the CMS database that you created using instructions in Chapter 1, Before You Install:

For MS SQL Server 7.0

1. Open the Data Sources (ODBC) Administrator in the Control Panel.

2. Click the System DSN tab. Perform the following steps to create a system DSN that will

allow for connections to the database, whatever its location.

3. Click Add and select SQL Server, then click Finish.



3 - Four-Host Installation 55

a. In the Create a New Data Source to SQL Server dialog box, supply a name, description,

and server. We suggest the following:

Click Next.

b. Select With SQL Server authentication...

Select Connect to SQL server to obtain default settings...

Click Next.

c. Select Change the default database to: CMSsystem. Click Next. Click Finish.

d. Click Test Data Source to verify.

e. Click OK and OK again.

For Oracle 8.1.16i

1. Create a System DSN in the ODBC Data Sources Administrator (in Control Panel) that will

allow for connections to the database, whatever its location. Perform the following steps:

2. Click Add and select Oracle ODBC Driver, then click Finish.

a. In Oracle* ODBC Driver Setup, supply the following:

b. Click OK.

Name vignetteODBC
Description enter a description

Server DB_Host

Login ID vignette_sql
Password rational

Data Source Name vignetteODBC
Description enter a description

Service Name DB_Host
User ID CMSSYSTEM
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Install V/5 Base Platform

On CMS_Host:

You must install the Base Platform software on each system on which you will create a CMS

and/or a CDS. If you are configuring a Web server on a host that is remote from its CDS, you

must install this software on that host.

To perform this part of the installation, insert the CD titled Rational Suite ContentStudio Vignette
Content Management Server.

1. In the V/5 Content Management Server 5.5 window, click Install Software.

2. Click e-Business Platform Base Installation.

3. In the Vignette V/5 Base Platform 5.5 Setup box, click Next.

4. In the License Agreement dialog box, click Yes.

5. In the View Release Notes dialog box, answer as you prefer.

6. In the Select Components dialog box, select all and click Next.

7. In the Choose Destination Location dialog box, take the default and click Next.

8. In the Select Program Folder dialog box, take the defaults and click Next.

9. In the Confirm Destination dialog box, click Next.

10. After files are updated, click Finish.

11. Exit.

Apply the Vignette 5.5.1 Patch

On CMS_Host:

The Vignette 5.5.1 Patch is required to run ContentStudio. This patch is available on the CD titled

Rational Suite ContentStudio Integrations. Perform the following steps:

1. Insert the CD and navigate to \ContentStudio\misc\updates\Vignette.
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2. Double-click ss55-551.exe.

3. From the Install Shield Wizard, click Next.

4. Click Yes on the License Agreement dialog box.

5. In the Choose Destination Location dialog box, take the default and click Next.

6. Click Finish.

Create and Configure a New CMS

On CMS_Host:

The content management server (CMS) is the control center for V/5 Platform software, storing

its information in the system database (CMS system in our example). The CMS processes

production management information for a site. Only one CMS can be configured per instance of

V/5 platform software. Admin and guest user IDs are created during installation. For details, see

the Vignette V/5 Platform Installation and Configuration Guide.

1. Start the Platform Manager. Click Start>Programs>Vignette e-Business Platform
5.5>Platform Manager.

2. In the Vignette V/5 e-Business Platform Configuration box, click Create a new Content
Management Server and then click OK.

3. In the V/5 e-Business Platform: New CDS wizard:

a. In the Contact and License Information pane, complete all of the fields. You must have

previously requested the CD Key and License Key through email using the instructions

in Chapter 1.

b. In the Local Host Information pane, take the default value in the Name for this Host
field, which is your host name.

c. In the Assign Instance Name pane, provide a name for the platform instance. We

recommend CMSsystem.

d. In the Server Host and Ports pane, take the default values:

Host hostname.domain-name
Dispatch Service (bob) Port 30210

Request Service (vhs) Port 30211
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e. In the Database Type pane, select the vendor and version you are using.

f. In the Database Server and Login pane, take the defaults for these fields, which were

specified in a previous step:

g. In the Secure Database Setup pane, click Use the Login configured with the system
database.

h. In the Auto Start CMS pane, click Start the CMS if the system is rebooted.

i. Click Finish.

Create and Configure a Development CDS

On CMS_Host:

The CDS works closely with a Web server in delivering site content. Note that all CDSs within a

single V/5 platform software configuration share the same CMS and system database. For

details, see Vignette V/5 Platform Installation and Configuration Guide.

If you are still in the V/5 e-Business Platform Manager, begin at Step #4.

1. To start the Platform Manager, click Start>Programs>Vignette e-Business Platform
5.5>Platform Manager.

2. Click Configure an Existing Content Management Server.

3. In the V/5 e-Business Platform Login box, use the recommended values:

4. Select Content Management Server (CMS), right-click and then click New Content
Delivery Server (CDS).

5. In the V/5 e-Business Platform: New CMS wizard:

a. In the CDS type pane, click Development, then click Next.

Data Source Name vignetteODBC

Data User Login vignette_sql

Database User Password rational

Location hostname.domain-name:port (the default port is 30210)

Userid admin
Password admin
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b. In the Assign Name pane, provide a name. We recommend devCDS. Click Next.

c. In the Docroot Manager Host and Ports pane, take the default values, then click Next.

d. In the Docroot Information pane, specify the path from a previous step:

drive:\Inetpub\wwwroot\devCDS, then click Next.

e. In the Cached Pages pane, click Web Server, then click Next.

f. In the Auto Start CDS pane, click Start the CDS if the system is rebooted, then click

Next.

g. In the Initial Docroot Manager Startup pane, click Start the Docroot Manager now,

then click Next.

h. Click Finish.

Create and Configure a Development APE

Use the application engine (APE) to associate a Web server with the CDS, so that the CDS can

begin serving pages. For details, see the Vignette V/5 Platform Installation and Configuration Guide.

1. In V/5 e-Business Platform Manager, select the development CDS name, right-click and then

click Application Engine>New Application Engine.

2. In the V/5 e-Business Platform: New Application Engine wizard:

a. In the Application Engine Host and Ports pane, take the default values:

b. In the Initial Application Engine Startup pane, click Start the Application Engine now.

c. Click Finish.

3. Select the APE that you created. Right-click and then click Enable COM extensions. Click

Finish.

Host hostname.domain-name
Placement Agent 3737

Cache Manager (cmd) Port 3738

Host Name hostname.domain-name
Page Generator (ctlv) Port 4738

Template Manager (tmd) Port 4739



60 Installing Rational Suite ContentStudio

Associate the Web Server

You must associate one or more Web servers for each CDS. When you associate multiple Web

servers with a CDS, make sure that all Web servers use the same doc root. For more information,

see the Vignette V/5 Platform Installation and Configuration Guide.

1. In V/5 e-Business Platform Manager, select the named development CDS, right-click and

click Associate Web Server.

2. In the V/5 e-Business Platform: Associate Web Server wizard:

a. In the Host Confirmation pane, click Next.

b. In the Assign Name pane, provide a name. We recommend devCDS.

c. In the Web Server Type pane, click your server type (for example, Internet Information
Server 5.0.)

d. In the Web Server Instance pane, click Development CDS.

e. In the Secure Web Server Setup pane, click No.

f. In the Directory Information pane, take the defaults for these fields:

g. In the Web Server Startup pane, click Restart the Web Server now.

h. Click Finish.

Select ASP Generator for the Development APE

If the IIS instance that will act as an ASP Page Generator uses SSL to communicate with the V/5

platform Web server module (if CDS-CMS communication needs to be secure), you need to

configure certain V/5 variables before you create the ASP Page Generator. For more information,

see Vignette V/5 Platform Installation and Configuration Guide.

1. In Platform Manager, select the development APE name; right-click and then click Add ASP
Page Generator.

2. In the V/5 e-Business Platform: Add an ASP Page Generator wizard:

Docroot drive:/Inetpub/wwwroot/devCDS

Metafiles Path drive:/Vignette/Inst-CMSsystem/working/cds-dev

CDS/metafiles/

Dynamic Pages Path Leave blank
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a. In the Host Confirmation pane, click Next.

b. In the Web Server Instance pane, click Development ASP and click Next.

c. In the Web Server Protocol Setup pane, click No, then click Next.

d. In the Web Server Host and Port pane, take the defaults:

Then click Next.

e. In the Directory Information pane, take the default:

Then click Next.

f. In the ASP Page Generator Startup pane, click Restart the Web Server.

g. Click Finish.

h. Exit the Platform Manager.

Install V/5 Platform Tools

On CMS_Host:

Install V/5 Tools using the instructions in Install V/5 Platform Tools in Chapter 4 on page 92.

Install V/5 Development Center

On CMS_Host:

Install V/5 Development Center using the instructions in Install V/5 Development Center in

Chapter 4 on page 92.

Host Name hostname.domain-name
Port 81

Template Cache drive:\Inetpub\wwwroot\devASP
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Verify that the Development CDS and APE Are Running

On CMS_Host:

To ensure that files will launch from a Web browser, and that the file object exists in the

development and live CDS, perform the following steps:

1. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Tools.

2. In the Business Platform Login dialog box, take the defaults:

3. Click Window>Production Center>Project Manager.

4. In the Project Manager dialog box, click Base Project.

5. Then click File>New Project.

6. Enter a new project name (we recommend test).

7. Select the new project name. Click File>Submit File.

8. Select a file that you want to display in your browser, for example any .gif, or .html file.

When prompted, enter the name of the directory (we recommend /test). Then click OK. The

selected file appears with a status of Ready to Launch.

9. Right-click the file name and click Preview to display the file.

If you are prompted to select a default Web browser, click OK. In the Preferences dialog box,

click Add and enter the browser name [IE], and browse for the browser location for

[...\iexplore.exe]. Click OK.

10. Verify that the new file object is in the development CDS. In Windows Explorer, look for this

file: drive:\Inetpub\wwwroot\devCDS\test\your-file.

Configure IIS to Create Live CDS

On CS_Host, you must configure IIS as follows:

Location CMS_Host.domain-name
User ID admin

Password admin
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➤ Set up virtual services for the live CDS, live APE, and live ASP Page Generator

➤ Configure Web server properties

➤ Set permissions for virtual services directories

Set Up IIS Virtual Web Services for Vignette Live CDS and Live APE
Components

On CS_Host, you need to set up two Web virtual services for the live CDS and the live ASP. You

also need to assign different port numbers for these services. Make sure that the port numbers

you select are not currently in use by another Web service.

To Configure Virtual Services with IIS

1. In Windows Explorer, navigate to drive:\Inetpub. Create new folders for each of the Web

virtual services. The default server uses drive:\Inetpub\wwwroot. We recommend these

directory names:

➣ drive:\Inetpub\wwwroot\livCDS
➣ drive:\Inetpub\wwwroot\livASP

2. Start Internet Service Manager.

3. Open the Internet Information Server folder and under Internet Information Server locate

the host on which you are configuring IIS.

4. Right-click the host name and click New>Web Site. In the WebSite Creation Wizard for the

Web Site Description, create Web sites using the information provided below.

a. Enter the Web site description. Click Next.

b. Accept the default, All Unassigned in the Enter the IP address to use for this Web site
box.

c. Enter the port number. Click Next.

d. Enter the path and allow anonymous access to the Web site. Click Next.

Web site description Port Path

Live CDS 8080 drive:\Inetpub\wwwroot\livCDS
Live ASP 8081 drive:\Inetpub\wwwroot\livASP
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e. For IIS with Windows 2000, select Allow Read, Run scripts, and Execute access, and for

IIS with Windows NT 4.0, select Read Access, Script Access, and Execute Access; then

click Finish.

5. After creating the Web sites, you must enable buffering. Use the Internet Services Manager

to enable buffering for each of the new Web sites.

a. Select each one of the new folders that you have created for the Web sites and right-click

to open the Properties window.

b. Click the Home Directory tab; then click Configuration and click the App Options tab

in the Application Configuration dialog box. Click Enable buffering.

c. Click OK and OK again.

Configure Web Server Properties

Configure Web server properties for the IIS Virtual Servers live CDS defined in Set Up IIS Virtual
Web Services for Vignette Live CDS and Live APE Components.

NOTE: IIS 5 differs from IIS 4 with respect to selections. IIS 5 uses pull-down lists and IIS 4

employs option buttons. Naming conventions for tabs and fields remain identical or are very

similar in both versions.

1. Click Live CDS and right-click to select Properties.

2. Determine the Anonymous User Account by clicking the Directory Security tab. Click Edit
next to Anonymous Access and Authentication Control, and then click the Edit next to

Allow Anonymous Access.

You will see the Anonymous User Account IUSR_ hostname. You will need to refer to this

name later in this IIS configuration. Click Cancel to return to the Properties window.

3. Click the Home Directory tab.

In the Application Setting box, if using IIS 5.0, enable Execute Permissions: Scripts and
Executables. If using IIS 4.0, enable Permissions: Execute (Including Scripts).

a. Create two application mappings: one for .html and one for .htm. To do this, select

Configuration.
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b. Click the Application Mappings tab. Click Add. Enter the following:

NOTE: Leave Script Engine check box selected. Click OK.

4. Click the Documents tab. Move default.htm to the top of the list. If default.htm isn’t in the

list, add it and then move it to the top of the list.

5. Close the Internet Service Manager and click Yes to save console settings.

Set Permissions for Virtual Services Directories

On CS_Host:

1. Using Windows Explorer, open the Properties window of the Web servers’ home directory

drive:\Inetpub\wwwroot\folder-name for each of the virtual services created for live CDS

and live ASP. Follow this procedure for each of the virtual services.

2. Select Security and click Permissions. In the Directory Permissions window, note whether

there is an entry for the Web server anonymous user whose name you found through the IIS

Management (for example: IUSR_hostname).

3. If the Web server anonymous user is listed go to Step #4, otherwise continue with this step

to add the user:

a. Click Add to open the Add Users and Groups dialog box.

b. Select the name of the Web server host (for example: web02) from List Names From: and

click Show Users to display all configured users on this Web server.

c. Select the Internet Server anonymous access user whose name you found through the IIS

Management Console (for example: IUSR_web02).

d. Click Add. Then click OK to return to Directory Permissions.

4. In Windows 2000, select the anonymous user and from the Permissions list box select

Modify. In Windows NT 4.0, select the anonymous user and set the Type of Access to

Change (to provide read, write, delete, and execute permissions).

Executable Extension

drive:\Winnt\system32\inetsrv\ssinc.dll .htm

drive:\Winnt\system32\inetsrv\ssinc.dll .html
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5. On Windows NT, select both options: Replace Permissions on Subdirectories and Replace
Permissions on Existing Files. Click OK. (Windows 2000 will set these options by default.)

6. When prompted if you want to replace security information on all existing subdirectories,

click Yes.

7. Return to Windows Explorer and repeat the steps above for the remaining virtual servers.

8. Click My Computer>Control Panel>Services and click World Wide Web Publishing
Service. Stop and then start it.

9. Close Services.

Install V/5 Base Platform

On CS_Host:

You must install the Base Platform software on each system on which you will create a CMS

and/or a CDS. If you are configuring a Web server on a host that is remote from its CDS, you

must install this software on that host.

To perform this part of the installation, insert the CD titled Rational Suite ContentStudio Vignette
Content Management Server.

1. In the V/5 Content Management Server 5.5 window, click Install Software.

2. Click e-Business Platform Base Installation.

3. In the Vignette V/5 Base Platform 5.5 Setup box, click Next.

4. In the License Agreement dialog box, click Yes.

5. In the View Release Notes dialog box, answer as you prefer.

6. In the Select Components dialog box, select all and click Next.

7. In the Choose Destination Location dialog box, take the default and click Next.

8. In the Select Program Folder dialog box, take the defaults and click Next.

9. In the Confirm Destination dialog box, click Next.

10. After files are updated, click Finish.



3 - Four-Host Installation 67

11. Exit.

Apply the Vignette 5.5.1 Patch

On CS_Host:

The Vignette 5.5.1 Patch is required to run ContentStudio. This patch is available on the CD titled

Rational Suite ContentStudio Integrations. Perform the following steps:

1. Insert the CD and navigate to \ContentStudio\misc\updates\Vignette.

2. Double-click ss55-551.exe.

3. From the Install Shield Wizard, click Next.

4. Click Yes on the License Agreement dialog box.

5. In the Choose Destination Location dialog box, take the default and click Next.

6. Click Finish.

Configure ODBC Connection for the CMS Database

On CS_Host, you must configure OBDC Connection for the CMS Database on DB_Host.

The database environments that V/5 CMS supports are Microsoft SQL Server 7.0 and Oracle

8.1.16i.

Using the CMS database that you created using instructions in Chapter 1, Before You Install:

For MS SQL Server 7.0

1. Open the Data Sources (ODBC) Administrator in the Control Panel.

2. Click the System DSN tab. Perform the following steps to create a system DSN that will

allow for connections to the database, whatever its location.

3. Click Add and select SQL Server, then click Finish.
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a. In the Create a New Data Source to SQL Server dialog box, supply a name, description,

and server. We suggest the following:

Click Next.

b. Select With SQL Server authentication...

Select Connect to SQL server to obtain default settings...

Click Next.

c. Select Change the default database to: CMSsystem. Click Next. Click Finish.

d. Click Test Data Source to verify.

e. Click OK and OK again.

For Oracle 8.1.16i

1. Create a System DSN in the ODBC Data Sources Administrator (in Control Panel) that will

allow for connections to the database, whatever its location. Perform the following steps:

2. Click Add and select Oracle ODBC Driver, then click Finish.

a. In Oracle* ODBC Driver Setup, supply the following:

b. Click OK.

Create and Configure a Live CDS

On the CS_Host:

Name vignetteODBC
Description enter a description

Server DB_Host

Login ID vignette_sql
Password rational

Data Source Name vignetteODBC
Description enter a description

Service Name DB_Host
User ID CMSSYSTEM
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1. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Manager to open

Vignette V/5 e-Business Platform Configuration dialog.

2. Click Create a connection to a Content Management Server on another host.

3. In the Connect to Remote CMS wizard, in the CMS Information pane, enter the requested

information. Click Next.

4. In the Host Identification pane, enter the name for the CS_Host (accept the default). Click

Finish.

5. Select Content Management Server (CMS), right-click and then click New Content Delivery
Server (CDS).

6. In the V/5 e-Business Platform: New CDS wizard:

a. In the CDS type pane, click Live, then click Next.

b. In the Assign Name pane, provide a name. We recommend livCDS. Click Next.

c. In the Docroot Manager Host and Ports pane, take the defaults:

Click Next.

d. In the Docroot Information pane:

Click Next.

e. In the Cached Pages pane, click Web Server, then click Next.

f. In the Auto Start CDS pane, click Start the CDS if the system is rebooted, then click

Next.

g. In the Initial Docroot Manager Startup pane, click Start the Docroot Manager now.

h. Click Finish.

CMS CMS_Host:30210
User admin
Password admin

Host hostname.domain-name
Placement Agent (pad) Port 3737

Cache Manager (cmd) Port 3738

Docroot drive:\Inetpub\wwwroot\livCDS
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Configure a Live APE

1. In Platform Manager, select the named live CDS, right-click and click Application
Engine>New Application Engine.

2. In the V/5 e-Business Platform: New Application Engine wizard:

a. In the Docroot Manager Host and Ports pane, take the defaults:

Click Next.

b. In the Initial Application Engine Startup pane, click Start the Application Engine now.

c. Click Finish.

3. Select the APE that you created. Right-click and click Enable COM extensions. Click Finish.

Associate the Web Server

1. In Platform Manager, select the live CDS name, right-click and click Associate Web Server.

2. In the V/5 e-Business Platform: Associate Web Server wizard:

a. In the Host Confirmation pane, click Next.

b. In the Assign Name pane, provide a name. We recommend livCDS.

c. In the Web Server Type pane, click your server type (for example, Internet Information
Server 5.0.)

d. In the Web Server Instance pane, click Live CDS.

e. In the Secure Web Server Setup pane, click No.

f. In the Directory Information pane, take the defaults:

g. In the Web Server Startup pane, click Restart the Web Server.

Host Name hostname.domain-hame
Page Generator (ctlv) Port 4738

Template Manager (tmd) Port 4739

Docroot drive:/Inetpub/wwwroot/livCDS

Metafiles Path drive:/Vignette/Inst-CMSsystem/working/cds-livCDS

/metafiles/

Dynamic Pages Path Leave blank
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h. Click Finish.

Select ASP Generator for Live APE

1. In V/5 e-Business Platform Manager, select the live APE (ape-1 under LivCDS), right-click

and click Add ASP Page Generator.

2. In the V/5 e-Business Platform: Add an ASP Page Generator wizard:

a. In the Host Confirmation pane, click Next.

b. In the Web Server Instance pane, click Live ASP, then click Next.

c. In the Web Server Protocol Setup pane, click No, then click Next.

d. In the Web Server Host and Port pane, take the defaults, then click Next.

e. In the Directory Information pane, take the default, then click Next.

f. In the ASP Page Generator Startup pane, click Restart the web server.

g. Click Finish.

3. Close Platform Manager.

Configure Vignette Global.asa sample Template

On CMS_Host, launch the Global.asa sample template.

The Vignette Global.asa sample template must be launched for Rational Suite ContentStudio

page generation to work. The Global.asa sample is a Vignette system template with global

Vignette variable definitions. Vignette installs the Global.asa sample template in the Samples
subproject.

To launch the Global.asa sample template:

1. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Tools.

Host Name hostname.domain-name
Port 8081

Template Cache drive:\Inetpub\wwwroot\livASP
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a. In the Business Platform Login dialog box, take the defaults:

b. Click Window>Production Center>Project Manager.

2. Select the Global.asa sample template located in the Base Project >Applications>Samples
project folder, right-click, and click Launch.

3. In the Confirm Launch dialog box, click Immediately. The file now appears with a status of

Live .

Create and Assign CS_ROLE for ContentStudio Users

On CMS_Host:

1. From V/5 Tools (Start>Programs>Vignette e-Business Platform 5.5>Platform Tools),

perform the following steps:

2. Under Admin Center, click User Manager.

3. From the User Manager window, click File>New Role to create a new role for CS_ROLE.

NOTE: For additional information, see the online help for V/5 Admin.

4. On the Users tab, click admin, then right click Details. On the Roles tab, click CS_ROLE to

assign the new role to the admin user.

5. Create any new users who will need to log in to ContentStudio Console and add assign the

CS_ROLE to those users as well.

Verify Live CDS and APE are Operational

On CMS_Host, verify that the development and live CDS/APE are operational.

To ensure that files will launch from a Web browser, and that the file object exists in the

development and live CDS, perform the following steps:

Location hostname:30210.domain-name
User ID admin

Password admin
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1. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Tools.

2. In the Business Platform Login dialog box, take the defaults:

3. Click Window>Production Center>Project Manager.

4. In the Project Manager dialog box, click Base Project.

c. Navigate into the subproject folder created earlier (test) to locate your file.

5. After previewing, right-click the file name and click Launch.

6. In the Confirm Launch dialog box, click Immediately. The file now appears with a status of

Live .

7. Verify that the new file object is in the live CDS. In Windows Explorer on CS_Host, look for

the file drive:\Inetpub\wwwroot\livCDS\test\your-file.

If the file object is in the live CDS, the Vignette services are operational.

3.3 Install and Configure ClearCase Host

On CCASE_Host:

NOTE: ClearCase requires IE 4.0 (with SP1) or later be present before you install. You will need to

install IE from the Windows Option Pack CD if it isn’t already on this machine.

The procedure in this section installs Rational ClearCase LT. For more information, see the

chapter in the manual Installing Rational Suite. If you want to install full ClearCase, follow the

instructions in ClearCase Product Family Installation Notes.

Install ClearCase LT Server

To install ClearCase LT Server, insert the CD titled Rational Solutions for Windows.

Location CMS_Host.domain-name
User ID admin

Password admin
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1. In the Rational Software Setup dialog box, click Next.

2. In the Select Installation Option dialog box, click Install Rational ClearCase LT Server.
Click Next.

3. In the License Agreement dialog box, click Yes, I accept this agreement, then click Next.

4. In the Setup Confirmation dialog box, click Typical, then click Next.

5. In the Update Shared Components dialog box, click Next.

6. In the Confirmation dialog box, click Next.

Please wait while ClearCase  LT Server files are copied.

7. In the Restart Windows dialog box, select the Restart check box and click Finish.

8. After the machine reboots, login using the same credentials in order to complete the

ClearCase installation.

When the ClearCase Setup Wizard starts, you will not be able to proceed if you are logged in as

Local Administrator. You must logoff and login as a member of the ClearCase primary group

with administrative privileges to run this wizard. Restart the wizard from

Start>Programs>Rational ClearCase LT Server>Rational ClearCase LT Server Setup Wizard.

Configure ClearCase LT Server

1. Click Next in the Welcome dialog box.

2. In the Create the ClearCase LT Storage Directory pane, take the default:

drive:\ClearCaseStorage

3. Complete the field in the Create ClearCase LT Source VOB pane:

4. In the Create Initial Clearcase LT Project pane, take the default in the Starting Project Title
field.

5. In the Will UNIX ClearCase LT Clients Use this Server pane, click No.

6. In the ClearCase LT Summary pane, click Finish.

Source VOB Name content

Import Source files (Clear the check box.)
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7. Close the wizard.

NOTE: ClearCase LT will not be properly licensed until ContentStudio licenses are configured in

License Rational Suite ContentStudio Software on page 79.

Install ContentStudio Client

On CCASE_Host:

You must be logged in as Local Administrator to install the ContentStudio client. Insert the CD

titled Rational Suite ContentStudio Integrations.

1. When the Rational Software Setup Wizard starts, click Next.

2. In the Select Installation Option dialog box, click Install Rational Product. Click Next.

3. In the License Option dialog box, click Install Product Before Licensing. Click Next.

4. In the Choose Product to Install dialog box, click Rational Suite ContentStudio Client.
Click Next.

5. Choose to accept the Rational Software license agreement in the License Agreement dialog

box. If you choose not to accept the license agreement, the Setup program terminates. Click

Next.

6. In the Setup Configuration dialog box, click Typical. Click Next.

7. In the Upgrade Compatibility dialog box, click Next.

(See the Rational Suite ContentStudio Release Notes for information about any incompatibility

messages you receive.)

8. In the Restart Windows dialog box, click Restart and click Finish to restart your computer

to run Rational Suite ContentStudio Client.

License ClearCase LT Server

On CCASE_Host:
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You must configure the software to use either node locked or floating licenses. Follow the

appropriate instructions below:

Configure Node Locked Licenses

1. Click Start>Programs>Rational Suite ContentStudio Server>Rational License
KeyAdministrator.

2. Click License>Go to Rational AccountLink.

3. On the Account Link page, click Get License Keys and follow the steps.

4. Account Link will send your license keys by e-mail. Open the message and save the

attachment. We recommend storing it in drive:\temp\license_for_hostname.

5. Click License>Import License Key(s) and select your license file.

6. In the Confirm Import pane, click Import, then click OK.

Configure Floating Licenses

1. Click Start>Programs>Rational Suite ContentStudio Server>Rational License Key
Administrator.

2. Click Point to FLEXlm license server to get my licenses. Click Next.

3. Click Settings>Service Configuration. Click Use License Server and enter the name of the

FLEXlm server host that you set up in Chapter 1. Click OK.

3.4 Install and Configure ContentStudio Host

Install ContentStudio Server

On CS_Host:

Insert the CD titled Rational Suite ContentStudio Integrations. In the Rational Software Setup

Wizard, perform these steps:

1. In the Rational Software Setup dialog box, click Next.
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2. In the Select Installation Option dialog box, click Install Rational Product. Click Next.

3. In the Select and Install Licensing Option dialog box, click Install Product Before
Licensing. Click Next.

4. In the Choose Product to Install dialog box, click Rational Suite ContentStudio Server.
Click Next.

5. In the License Agreement dialog box, click Yes. Click Next.

6. In the Setup Configuration dialog box, click Typical, then click Next.

(See the Rational Suite ContentStudio Release Notes for information about any incompatibility

messages you receive.)

7. In the Confirmation dialog box, click Next.

Please wait while Rational Suite installs ContentStudio Server.

8. In the Restart Windows dialog box, click Restart. Click Finish to restart your computer.

After the machine reboots, you must login using the same credentials in order for the

installation to complete.

After setup completes, the Rational Suite ContentStudio Administration Utility will start

automatically.

Configure ContentStudio Server

On CS_Host:

In the Administration Utility, perform the following steps:

1. Complete these fields on the ClearCase tab:

VOB Name content
View Name cs_pagegeneration  (default)

View Prefix cs_deployment  (default)

Label Prefix CS_DEPLOYED (default)

Views Directory drive:\ClearCaseStorage\Views (does not yet exist)

Admin VOB Name projects
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2. Complete the fields on the ContentStudio tab:

3. Complete these fields on the V/5 tab:

4. Click OK to close the ContentStudio Administration Utility.

Create the ClearCase Views Directory (drive:\ClearCaseStorage\Views) you specified on the

ClearCase tab in Step #1.

Install Rational Suite Team Unifying Platform

On CS_Host:

The Team Unifying Platform edition of Rational Suite is designed for teams that need to share

artifacts, but do not require the productivity tools available in other editions of Rational Suite. in

particular, Team Unifying Platform will install ClearCase LT and ClearQuest.

To install Rational Suite Team Unifying Platform, insert the CD titled Rational Solutions for
Windows. The Rational Software Setup Wizard starts.

Use Shadow Directories
check box

(See the online help for more information.)

DB URL jdbc:odbc:vignetteODBC
DB UserID For SQL: vignette_sql; For Oracle: CMSSYSTEM
DB Password rational
Tomcat Fields leave blank

Logging Dir drive:\Program Files\Rational\ContentStudio\logs

CMS Host CMS_Host
CMS Port # 30210
CMS UserID admin
CMS Password admin
DB URL jdbc:odbc:vignetteODBC
DB Userid For SQL: vignette_sql; for Oracle: CMSSYSTEM
DB Password rational
CDS Host CS_Host
CDS Port # 8080
CDS DocRoot drive:\Inetpub\wwwroot\livCDS
CS Role CS_ROLE
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1. In the Rational Software Setup dialog box, click Next.

2. In the Select Installation Option dialog box, click Install Rational Product and click Next.

3. In the Select and Install Licensing Option dialog box, click Install Product Before
Licensing and click Next.

4. In the Choose Product to Install dialog box, click Rational Suite Team Unifying Platform.

5. For the ClearCase LT host, enter the name of CCASE_Host, and click Next.

In the License Agreement dialog box, click Yes and click Next.

6. In the Setup Configuration dialog box, click Typical and click Next.

7. In the Update Shared Components dialog box, click Next.

8. In the Software Use dialog box, click Administrator and click Next.

9. In the Confirmation dialog box, click Next.

Please wait while Rational Suite installs Team Unifying Platform.

10. In the Restart Windows dialog box, click Restart. Click Finish to restart your computer.

After the machine reboots, you must login using the same credentials in order for the

installation to complete.

License Rational Suite ContentStudio Software

On CS_Host:

You must configure the software to use either node locked or floating licenses. Follow the

appropriate instructions below:

Configure Node Locked Licenses

1. Click Start>Programs>Rational Suite ContentStudio Server>Rational License
KeyAdministrator.

2. Click License>Go to Rational AccountLink.

3. On the Account Link page, click Get License Keys and follow the steps.
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4. Account Link will send your license keys by e-mail. Open the message and save the

attachment. We recommend storing it in drive:\temp\license_for_hostname.

5. Click License>Import License Key(s) and select your license file.

6. In the Confirm Import pane, click Import, then click OK.

Configure Floating Licenses

1. Click Start>Programs>Rational Suite ContentStudio Server>Rational License Key
Administrator.

2. Click Point to FLEXlm license server to get my licenses. Click Next.

3. Click Settings>Service Configuration. Click Use License Server and enter the name of the

FLEXlm server host that you set up in Chapter 1. Click OK.

Configure CMS Database for ContentStudio

On CS_Host:

You must and add the required Rational Suite ContentStudio tables to the CMS database created

in Chapter 1. To do this, the ContentStudio tables must have the same owner as the Vignette

tables. Steps are listed below for Oracle and for Microsoft SQL.

Configuring Microsoft SQL Server

1. Click Start>Programs>MicroSoft SQL Server 7.0>Enterprise Manager.

2. Expand Microsoft SQL Server.

3. Right click SQL Server Group and click New SQL Server Registration.

4. In the Register SQL Server Wizard, click Next.

5. From the list of available servers, click DB_Host and click Next.

6. To select and authentication mode, click the SQL server login...

7. Click Login automatically... and type the login name and password.

Login Name vignette_sql
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8. Click Add the SQL Service(s) to an existing SQL Server Group and click Next.

9. Click Finish.

10. Select the CMS system database created earlier (CMSsystem) from the DB drop-down box.

11. Click File>Open navigate to the script file: drive:\Program
Files\Rational\ContentStudio\db_scripts\RSCSinitdb.mss.sql, then click Open.

12. Click Query>Execute.

You will see “Query Batch completed” in the bottom of the window.

13. Quit Query Analyzer and then Enterprise Manager.

Configuring Oracle

1. Start SQL*Plus Worksheet, connecting as the ORACLE schema user (default CMSSYSTEM)

that has been created in Chapter 1, Before You Install.

2. Click Worksheet>Run Local Script. This command runs the script file in drive:\Program
Files\Rational\ContentStudio\db_scripts\RSCSinitdb.ora.sql.

Configure JRE and Tomcat

On CS_Host:

JRE 1.3 and Tomcat 3.2.1 are required to enable the servers for Rational Suite ContentStudio Page

Generator and Rational NetDeploy. The following are the default installation directories:

➤ For JRE, drive:\Program Files\Rational\common\java\jre
➤ For Tomcat, drive:\Program Files\Rational\ContentStudio\tomcat

Modify Tomcat Port Information

When installed by Rational Suite ContentStudio, Tomcat uses the TCP/IP port 8088 for its

communication with the Web server. This setting is in the file

drive:\Program Files\Rational\ContentStudio\tomcat\conf\server.xml. If another TCP/IP

service uses this port, you must change the setting.

Password rational
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Establish Tomcat as a Service

The Tomcat service should run as a domain user account with full ClearCase privileges. You can

change the UID the Tomcat service runs as by performing the following steps:

1. Open a command prompt window.

2. Change to the directory drive:\Program Files\Rational\ContentStudio\tomcat\bin

3. Install jk_nt_service. To do so, enter a command of this form:

jk_nt_service -i name-of-service path-to-wrapper-properties

Given the defaults used in this section, the command would be as follows:

jk_nt_service -i Tomcat "drive:\Program Files\Rational\ContentStudio\tomcat\conf\wrapper.properties"

4. Start the services applet:

On Windows 2000, click Start>Programs>Administrative Tools>Services.

On Windows NT 4.0, double-click the services applet in Control Panel.

5. Locate the Tomcat service in the list of services, and double-click the entry.

6. Set the Startup Type to Automatic, then

on Windows 2000, click the Log on tab and then click This Account.

on Windows NT 4.0, in the section Log On As, click This Account.

7. Enter the appropriate User ID and Password information either directly into the fields or by

browsing. UserID must be entered in the form domain-name\user-name. To browse on

Windows 2000, click Browse; on Windows NT 4.0, click the ... button.

NOTE: The user identity for the Tomcat service must be a member of the ClearCase primary

group.

8. Start the service by clicking the Start button.

9. Check the application log in the Windows Event Viewer to verify that the Tomcat service has

started successfully.
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For more information on setting up Tomcat as a service, see the document

NT-Service-howto.html, which is located in

drive:\Program Files\Rational\ContentStudio\tomcat\doc.

3.5 Configure ClearQuest

Configuring ClearQuest involves creating a schema repository, adding the ContentStudio

package to the schema, creating a user database, and installing the V/5 package templates.

Create a Schema Repository

On CS_Host (using the empty ClearQuest master database created on DB_Host):

You must have installed ClearQuest and created empty vendor databases (as instructed in

Chapter 1, Before You Install), before you create the ClearQuest Schema Repository. The Schema

Repository is the master database in which ClearQuest stores schemas.

You will need the manual Installing Rational ClearQuest, which is available in print as part of the

media kit. In Chapter 3, Installing ClearQuest for an administrator, the section Creating ClearQuest
Databases explains how to create a schema repository using the ClearQuest Maintenance Tool.

Create the schema repository now using the empty database you created.

Add the ContentStudio Package to a ClearQuest Schema

On CS_Host:

You need to use the ContentStudio package to configure content change requests. For more

information, see Content Change Requests in ClearQuest in the manual Introducing Rational Suite
ContentStudio.

1. Start the ClearQuest Designer and log in. The user name is admin; leave the password field

blank.

2. In the Open Schema wizard:
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a. In step 1 of 2, click Check out a schema to edit or continue editing previously saved
work.

Click on the Schema [Enterprise]. Click Next.

b. In step 2 of 2, type a comment. Click Finish.

3. In the ClearQuest Designer, click Package>Package Wizard.

a. In the Package Wizard install/select package screen, click More Packages.

b. In Install Packages dialog box, click ContentStudio. Click OK.

c. In the Package Wizard install/select package screen, click ContentStudio.

d. Click Finish.

4. In the ClearQuest Designer, click Edit>Record Type Family Members.

a. In the Add/Remove Record Type Family Member pane:

➣ Click Record Type Families: All_CS_Requests

➣ In Available Record Types, click Defect and Enhancement Request.

b. Click Add and click Close.

5. Click File>Check In, type a comment, and click OK.

Create a User Database

On CS_Host:

You must have installed ClearQuest and created empty vendor databases as instructed in

Chapter 1, Before You Install), before you create the ClearQuest User Database. The User Database

stores data entered by the ClearQuest client and Web users. You can create as many user

databases as you need.

You will need the manual Installing Rational ClearQuest, which is available in print as part of the

media kit. In Chapter 3, Installing ClearQuest for an administrator, the section Creating ClearQuest
Databases, explains how to create a user database using the ClearQuest Designer.
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Create a User database now using the empty database created in Chapter 1 and the information

below:

Install V5_Package Templates

On CS_Host:

Installing the V/5 Package installs the Vignette templates and establishes CSVgnCQSvc as a

service.

1. Modify your system path variable to include Vignette. Add the following directory:

drive:\vignette\5.5\bin\winnt.

2. IMPORTANT: Restart your machine so that updated path information will be used for the

remaining steps.

3. Open a command prompt window.

4. Change to this directory drive:\Program Files\Rational\ContentStudio\cq_integration.

5. To install the V/5 integration with ClearQuest, enter a command of this form:

install_v5_package CMS-hostname:port CMS-username:CMS-password

Given the defaults used in this section, the command would be as follows:

install_v5_package CMS_Host:30210 admin:admin

6. Establish CSVgnCQSvc as a service.

a. Change to this directory:

drive:\Program Files\Rational\ContentStudio\bin

b. Execute a command of this form using any domain user:

CSVgnCQSvc -i domain-name\domain-userid domain-password

7. Verify the ContentStudio Administration Utility parameters for ClearQuest Integration.

Start the ContentStudio Administration Utility.

Logical database name RSCS
Schema Enterprise schema version 2
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a. Click Start>Programs>Rational Suite ContentStudio Server>Rational Suite
ContentStudio Administration Utility and click the ClearQuest tab and complete the

boxes.

b. Complete these fields on the ClearQuest tab.

Assigning Permission to Run as Server

The user assigned in Step #6 requires “run as server” permission. If the service does not start, you

can verify user permissions as follows.

1. In Windows 2000, click Start>Programs>Administrative Tools>Services and in

Windows NT, open the Control Panel and click Services. Locate the service ContentStudio
Vgn to CQ synchronizer.

2. Double-click the ContentStudio Vgn to CQ synchronizer service and click the Logon tab.

Enter password and confirm password for the user. Click Apply. The message that appears

indicates that the Logon as Service right has been set.

3. Start the service.

ClearQuest Administration

On CS_Host:

1. Click Start>Programs>Rational Suite Team Unifying Platform> Rational ClearQuest to
start ClearQuest and log in as admin. Leave the password blank.

2. Select the User database that you created (RSCS).

3. Click Actions>New.

4. In Choose Record Type... pane, click CS_V5_Connection and click OK.

5. In Submit CS_V5_Connection pane, complete these fields:

CQ UserID admin
CQ Password Leave blank.

CQ DB Name RSCS (name of ClearQuest User database)

CMS Host Name CMS_Host
CMS Port Number 30210
User Name admin
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The ClearQuest database is now set up.

3.6 Configure RequisitePro Database

RequisitePro is an optional component. If you plan to use it, you must configure a database.

For more information on configuring a RequisitePro database, see Installing RequisitePro which is

available on the Rational Solutions for Windows: Online Documentation CD.

3.7 Verify That Four-Host Environment is Operational

Check to see that your ContentStudio four-host installation is functioning properly.

Test Log in ContentStudio Console

On CS_Host:

1. Click Start>Programs>Rational Suite ContentStudio Server> Rational Suite
ContentStudio Console

2. Log in to the CS_Host:

3. If log in fails, verify that the Tomcat service is started on CS_Host.

4. If Tomcat is stopped, check Windows Event Viewer for Tomcat error messages.

Password admin
CDS Host Name CMS_Host (host for the development CDS

CDS Port Number 80 (port for the development CDS)

Proxy Url /contentstudio/proxy  (default)

Default Project Path >Base Project>Content Studio

CS Server CS_Host
User ID admin

Password Admin
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Verify ClearQuest Integration

On CS_Host:

1. On any host where ClearQuest client is installed, click Start>Programs>Rational Suite
Team Unifying Platform> Rational ClearQuest to start ClearQuest and log in.

2. Click Actions>New to open the Choose Record Type dialog box. Click

ContentChangeRequest and click OK.

3. In Submit Content Change Request dialog box, complete the Headline, Owner, and the

Description boxes. For information about each box, right-click to display a shortcut menu

and click Help.

4. Click OK to submit the content change request to the ClearQuest database.

5. Run the V5 Tasks to Assign query in the CS User Queries folder. This query retrieves all

unassigned V/5 Tasks (content change requests) that the current user owns or that have no

assigned owner.

6. Select the content change request that you want to assign and click Actions>Assign.

7. Complete the information on the V/5 Task tab in the Assign Content Change Request dialog

box.

➣ To select the name of your CMS server, click CMS.

➣ To select a V/5 owner, click Assignee.

➣ Verify that the information in the Project Path box is correct. This is where the

corresponding V/5 project task will be stored.

8. Click Apply.

9. Start Vignette from any host where V/5 Tools are installed and click Start Programs Vignette

Verify that it was created in Vignette task view.

10. Click Start>Programs>Vignette e-Business Platform 5.5>Platform Tools.

a. In the Business Platform Login dialog box, take the defaults:

Location hostname
User ID admin

Password admin
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b. Click Window>Production Center>Task View.

11. Verify that there is an entry in the Task View window for the Content Change Request that

was submitted and assigned using the ClearQuest client.
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44 Installing Client Software

Rational Suite ContentStudio client software can be installed on the server host for the one-host

installation and can be installed on any number of desktop clients in the four-host installation

model.

4.1 Overview of the Client Installation Procedure

Read Chapter 1, Before You Install before you begin to install client software. Here is an over view

of the procedure:

1. Install Rational Suite ContentStudio Console.

2. Install Rational Suite Team Unifying Platform.

3. License Rational Suite ContentStudio.

4. Install Vignette clients.

4.2 Install and Configure Rational Suite ContentStudio Console

You need the CD titled Rational Suite ContentStudio Integrations.

1. The Rational Software Setup Wizard starts when you insert the CD. Click Next.

2. In the Select Installation Option dialog box, click Install Rational Product. Click Next.
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3. In the License Option dialog box, click Install Product Before Licensing. Click Next.

4. In the Choose Product to Install dialog box, click Rational Suite ContentStudio Client.
Click Next.

5. Choose to accept the Rational Software license agreement in the License Agreement dialog

box. If you choose not to accept the license agreement, the Setup program terminates. Click

Next.

6. In the Setup Configuration dialog box, click the Typical configuration option. Click Next.

7. In the Restart Windows dialog box, click Restart and click Finish to restart your computer

to run Rational Suite ContentStudio Client.

4.3 Install Rational Suite Team Unifying Platform

To install Rational Suite Team Unifying Platform, insert the CD titled Rational Solutions for
Windows. The Rational Software Setup Wizard starts.

1. In the Rational Software Setup dialog box, click Next.

2. In the Select Installation Option dialog box, click Install Rational Product and click Next.

3. In the Select and Install Licensing Option dialog box, click Install Product Before
Licensing and click Next.

4. In the Choose Product to Install dialog box, click Rational Suite Team Unifying Platform
and click Next.

5. In the License Agreement dialog box, click Yes and click Next.

6. In the Setup Configuration dialog box, click Typical and click Next.

7. In the Update Shared Components dialog box, click Next.

8. In the Software Use dialog box, click Administrator and click Next.

9. In the Confirmation dialog box, click Next.

Please wait while Rational Suite installs Team Unifying Platform.

10. In the Restart Windows dialog box, click Restart. Click Finish to restart your computer.



4 - Installing Client Software 93

After the machine reboots, you must login using the same credentials in order for the

installation to complete.

4.4 License Rational Suite ContentStudio

Rational Suite ContentStudio uses Rational common licensing. There are two types of licenses:

floating and node-locked.

If you have purchased floating licenses, ask your administrator for the name of the FLEXlm

server.

To start the Rational License Key Administrator, click Start>Programs>Rational Suite
ContentStudio Client>Rational License Key Administrator. This utility runs when the Rational

Suite installation completes. In the License Key Administrator Wizard, click Point to a FLEXlm
license server to get my licenses, and follow the instructions. When prompted, enter the

FLEXlm server name from your administrator.

If you have purchased node-locked licenses, ask your administrator for your account number.

You will then need to request a license from Rational Account Link at

www.rational.com/accountlink. Follow the instructions. Account Link sends your key by

e-mail. After you receive it, save the attachment as a file on your disk.

To start the Rational License Key Administrator, click Start>Programs>Rational Suite
ContentStudio Client>Rational License Administrator. This utility runs when the Rational

Suite installation completes. In the License Key Administrator Wizard, click Import a Rational
License file, and follow the instructions. When prompted, enter the name of the file from

Account Link.

4.5 Install Vignette Clients

The Vignette clients include the V/5 Platform Tools, V/5 Development Center, and online

documentation.
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Install V/5 Platform Tools

NOTE: To install the V/5 client on Windows 2000 server or Windows NT server, you must have

local administrator privileges.

To install Install V/5 Tools, insert the CD titled Rational Suite ContentStudio: Tools, Vignette Content
Management Server.

1. In the Vignette V/5 Tools dialog box, click Install Software.

2. Provide information to the Vignette V/5 Setup wizard:

a. In the Welcome dialog box, click Next.

b. In the License Agreement dialog box, click Yes.

c. In the Choose Destination Location dialog box, take the default:

drive:\Program Files\Vignette\Tools\5.5

Click Next.

d. In the Setup Type dialog box, click Next.

e. In the Select Program Folder dialog box, click Next.

f. In the Setup Complete dialog box, click Finish.

For more information, see the Vignette V/5 e-Business Platform Tools Installation Guide.

Install V/5 Development Center

NOTE: To install the V/5 client on Windows 2000 server or Windows NT server, you must have

local administrator privileges.

Insert the CD titled Rational Suite ContentStudio: Tools Development Center.

1. In the Vignette V/5 Development Center dialog box, click Install Development Center.

2. In the Vignette V/5 Setup Wizard:

a. In the Welcome dialog box click Next.
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b. In the License Agreement dialog box, click Yes.

c. In the Select Program Folder dialog box, click Next.

d. In the Setup Complete dialog box, click Finish.

For more information, see the Vignette V/5 e-Business Platform Tools Installation Guide.

Install Online Manual for V/5 CMS

You need the CD titled Rational Suite ContentStudio: Online Manuals, Content Management Server.

In the Vignette e-Business Platform 5.5 Online Manuals Setup Wizard:

1. In the Welcome dialog box, click Next.

2. In the License Agreement dialog box, click Yes.

3. In the Choose Destination Location dialog box, click Next.

4. In the Select Program Folder dialog box, click Next.

5. In the Start Copying Files dialog box, click Next.

6. In the Setup Complete dialog box, click Finish.

Install Online Manual for V/5 Development Center

You need the CD titled Rational Suite ContentStudio: Online Documentation Development Center.

In the Vignette Development Center Online Manuals Setup Wizard:

1. In the Welcome dialog box, click Next.

2. In the License Agreement dialog box, click Yes.

3. In the Start Copying Files dialog box, click Next.

4. In the Setup Complete dialog box, click Finish.
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55 Installing and Configuring the
Rational NetDeploy Agent

The Rational NetDeploy agent must be installed and configured on all target Web servers for

ContentStudio deployments.

5.1 Overview of the Rational NetDeploy Agent Installation

Here is an overview of this installation:

1. Create the target Web server.

2. Copy files from the CD titled Rational Suite ContentStudio Integrations.

3. Configure JRE.

4. Configure Tomcat.

5. Configure use of shadow directory on all target Web servers.

For secure deployments only, you need to configure the Redirector on target Web servers. See

Configure the Redirector on page 101.
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Create the Target Web Server

1. In Windows Explorer, locate C:\Inetpub. Create new directories for the target Web site. The

default server uses C:\Inetpub\wwwroot. We recommend this path:

C:\Inetpub\wwwroot\targetsite

2. Start Internet Service Manager.

➣ On Windows NT 4, click Start>Programs>Windows NT 4.0 Option Pack>Microsoft
Internet Information Server>Internet Service Manager.

➣ On Windows 2000, click Start>Programs>Administrative Tools>Internet Services
Manager.

3. Expand the Internet Information Services folder and locate the Web server on which you are

configuring IIS. Create your target Web server. We recommend the following defaults.

4. To create a Web site, right-click the host name and click New>Web Site.

5. In the WebSite Creation Wizard:

a. Enter the Web site description. Click Next.

b. Accept the default, All Unassigned, in the Enter the IP address to use for this Web site
box.

c. Enter a TCP Port number that is unique for the host. Click Next.

d. Enter the path. Leave the Allow anonymous access to the Web site check box selected.

Click Next.

e. Select the Allow Read, Script, and Execute Access check boxes and click Finish.

Web Site Description Target Site
Port {90
Path C:\Inetpub\wwwroot\targetsite
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Copy Files from the Rational Suite ContentStudio Integrations CD

To install and configure the NetDeploy agent, you must copy the JRE and Tomcat files from the

CD titled Rational Suite ContentStudio Integrations to exactly the same directories on the target

Web server.

1. On all target Web servers, create two directories:

drive:\Program Files\Rational\common\java\jre
drive:\Program Files\Rational\ContentStudio\tomcat

2. Insert the CD titled Rational Suite ContentStudio Integrations:

a. Copy the JRE files from CD-drive:\common\java\jre to

drive:\Program Files\Rational\common\java\jre on the target Web server.

b. Copy the Tomcat files from CD-drive:\ContentStudio\tomcat to
drive:\Program Files\Rational\ContentStudio\tomcat on the target Web server.

3. Delete the file drive:\Program Files\Rational\ContentStudio\tomcat\webapps\
ContentStudio\web-inf\web.xml.

4. On the target Web server, rename the file

drive:\Program Files\Rational\ContentStudio\tomcat\webapps\
ContentStudio\web-inf\webtarget.xml to web.xml.

Configure JRE

To configure the JRE, on each target Web server, you must modify the system path to include

drive:\Program Files\Rational\common\java\jre\bin.

Configure Tomcat

When you use the Tomcat files from the CD titled Rational Suite ContentStudio Integrations,

Tomcat is preconfigured to use the TCP/IP port 8088 for its communication with the

ContentStudio server. This setting is in the file drive:\Program Files\Rational\ContentStudio\
tomcat\conf\server.xml. If another TCP/IP service on your target Web server uses this port,

you must change the setting.
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To configure Tomcat on each target Web server, you must create these environment variables:

Establish Tomcat as a Service

The Tomcat service should run as a domain user account with full ClearCase privileges. You can

change the UID the Tomcat service runs as by performing the following steps:

1. Open a command prompt window.

2. Change to the directory drive:\Program Files\Rational\ContentStudio\tomcat\bin

3. Install jk_nt_service. To do so, enter a command of this form:

jk_nt_service -i name-of-service path-to-wrapper-properties

Given the defaults used in this section, the command would be as follows:

jk_nt_service -i Tomcat "drive:\Program Files\Rational\ContentStudio\tomcat\conf\wrapper.properties"

Reenter the password information into the password fields.

4. Start the services applet:

On Windows 2000, click Start>Programs>Administrative Tools>Services.

On Windows NT 4.0, double-click the services applet in Control Panel.

5. Locate the Tomcat service in the list of services, and double-click the entry.

6. Set the Startup Type to Automatic, then

on Windows 2000, click the Log on tab and then click This Account.

on Windows NT 4.0, in the section Log On As, click This Account.

7. Enter the appropriate User ID and Password information either directly into the fields or by

browsing. UserID must be entered in the form domain-name\user-name. To browse on

Windows 2000, click Browse; on Windows NT 4.0, click the ... button.

NOTE: The user identity for the Tomcat service must be a member of the ClearCase primary

group.

8. Start the service by clicking the Start button.

TOMCAT_HOME drive:\Program Files\Rational\ContentStudio\tomcat
JAVA_HOME drive:\Program Files\Rational\common\java\jre
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9. Check the application log in the Windows Event Viewer to verify that the Tomcat service has

started successfully.

For more information on setting up Tomcat as a service, see the document

NT-Service-howto.html, which is located in

drive:\Program Files\Rational\ContentStudio\tomcat\doc.

The Web server target is now configured to accept nonsecure deployment tasks from the Rational

Suite ContentStudio server. You must define this Web server and port (8088) as part of your

topology by using ContentStudio Console. If you are planning to deploy to a target Web server

outside a firewall, you must enable SSL for secure communications to your target Web and

configure your target Web server to use the Redirector. After you configure your target Web

server with SSL, follow the procedure in Configure the Redirector

Configure Use of a Shadow Directory

In the ContentStudio Administration Utility, click the ClearCase tab. In the Netdeploy section,

review the options that you have set for Use Shadow Directories. Clicking the Use Shadow

Directories checkbox enables a shadow directory for all deployment tasks. For more information

on using shadow directories for deployments, see Introducing Rational Suite ContentStudio.

5.2 Configure the Redirector

To ensure secure deployments, you must configure the Redirector. The procedure in this section

pertains to the target Web servers only, not to the Rational Suite ContentStudio server.

1. In the registry, create a series of registry keys with this name:

HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Jakarta Isapi
Redirector\1.0

2. Add the following string values pairs for the key 1.0 created in Step #1:

extension_uri /jakarta/isapi_redirect.dll
log_file drive:\Program Files\Rational\ContentStudio

\tomcat\logs\isapi.log

For your log level (can be debug, info, error or emerg)

log_level debug



102 Installing Rational Suite ContentStudio

3. Start the Internet Service Manager and add a new virtual directory to service, JSP and Servlet

requests for the IIS Web site that you have already created on your target Web server:

a. Right-click the target Web site and click New>Virtual Directory to access the Virtual

Directory Creation Wizard.

b. Enter the Alias name for the virtual directory must be jakarta. Click Next.

c. The directory path must be the directory in which you placed isapi_redirect.dll. (In our

example, it is in drive:\Rational\ContentStudio\tomcat\bin.) Click Next.

d. Assign Read and Execute access. Click Next.

4. Use the Internet Service Manager to define an ISAPI filter:

a. Right-click the target Web site and click Properties.

b. Click the ISAPI Filters tab and click Add.

c. In the Filter Name box, enter jakarta. In the Executable box, enter

drive:\Program Files\Rational\ContentStudio\tomcat\bin\isapi_redirect.dll. Then

click OK.

5. Use the Internet Service Manager to restart IIS.

a. Click the target Web site and click Stop.Then click the target Web site and click Start.

a. Right-click the target Web site; then click Properties.

b. Click the ISAPI Filters tab.

c. Verify that the jakarta filter is marked with a green arrow.

worker_file drive:\Program Files\Rational\ContentStudio\tomcat\
conf\workers.properties

worker_mount_file drive:\Program File\Rational\ContentStudio\tomcat
\conf\uriworkermap.properties
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