ALM Cookbook
This document is incomplete. It is intended to assist field support, sales support or knowledgeable CQ admins to develop CQ ALM infrastructure for their team. The document begins with an Interview to help identify what information is needed, and provides links to that information. Each section has a Building Blocks section (which enumerates the various elements) and a Functionality section which describes the way these can be thought about. 
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CQALM Practices Customer Interview
All questions are Project related
1) Is there a CQ ALM Practice that seems similar to what you want to do?

a. Are you looking for suggested Practice or process?

i. ToDo Practice

ii. OpenUp Practice

iii. Per Kroll’s Practices Library:  Not yet developed for CQ ALM http://rupository.svl.ibm.com:3000/wikis/IBM%20Practice%20Library/#core.default.nav_view.extend-ibm/guidances/supportingmaterials/intro_to_business_objectives_F0B438F5.html
1. Continuous Integration 

2. Iterative Development 

3. Risk-Value Lifecycle

4. Test Driven Development

5. Test Management

6. Two-Level Project Planning

7. Whole Team

2) Do you currently have a process that we could implement

a. Is it similar to anyone of the practices listed above?

i. Note: we only have OpenUp and ToDo at this time.  We are looking to develop the remainder)

3) Will you be tracking Deliverables using UCM Integration or some other content manager or not?

a. If so, do you prefer a more agile or a more governed process?

i. If Yes to deliverables, then we want to explore  the following in Project step:

1. ALMProject->SetDefault

2. ALMProject->DefaultRequest

3. ALMProject->DefaultTask

b. If no deliverables (as in BH Issue tracking)

i. We might consider as needed 

1. ALMRequest only

2. ALMRequest and ALMTask only

3. ALMRequest, ALMTask and ALMActivity

Security Policy

4) What are your security needs?

a. Are there people whom you do not want to see any data in the database but you want to send them emails with some of the data?

i. Add them to CQ Database but do not include them in any CQ User Groups associated with ALMSecurityPolicies

b. Are there groups of people using the same database that you do not want to see each other’s data?

i. Add them to ALMSecurityPolicy ->ratl_context_groups (CQ User Groups)

c. Are there groups of people that you want to see other people’s data but you do not want them to make any changes to it?

i. Add them to ALMRoles associated with this ALMProject

Roles

5) What are the Roles in your process

a. Are there any Practices which have Roles similar to the ones you envision?

i. If so, let’s use those RoleLabels to develop Approved Actions

ii. You can Mashup ApprovedActions from OOTB Practice Roles

b. Will you including CQ User Groups of Users or will you be specifying individuals as Members?

c. We will return to ALMRoles in the ALMWorkConfiguration section.

Record types

6) What Types of ALMRequests, Tasks and Activities will you be using?

a. Look at the OOTB Practices to identify similarities with the Customer’s process

b. When you CreateTask from an ALMRequest, is that Task likely to be the same Type as the Request.

c. For a given ALMTask Type will there be a typical set of ALMActivities?

i. Examples might be ‘Development’, ‘Test’, etc

1. ALMWorkConfiguration->PrimaryChildren

ii. Are you likely to have additional Activities per Task beyond the initial set? If so, what Type might that be? Example might be ‘Development’

1. ALMWorkConfiguration->SecondaryChildres

d. Are there additional Activity->Types that you will want but they are not the majority cases?

i. Create additional ALMWorkConfigurations but do not include them in an ALMWorkConfiguration->Type=’ALMTask’->Primary/SecondaryChildren

e. Are there groups of Users that should be selectable as the Owner of an ALMTask or ALMActivity?

i. Choose an ALMWorkConfiguration->ALMRole or Roles for this ALMActivity->Type

f. Is there one individual who will be responsible for an ALMTask or Activity if no one else is for this Project?

i. Choose an ALMRole whose Primary is that person

ii. For ALMTask the ALMWorkConfiguration->ALMRole->Primary is the default ALMTask->Owner when the ALMRequest->CreateTask  Action is executed

iii. For ALMActivity the ALMWorkConfiguration->ALMRole->Primary->ratl_mastership is the default ALMActivity->ratl_mastership when the ALMTask->CreateActivity  Action is executed. (There is no ALMActivity->Owner set in the Submitted State)

g. If adopting the non-deliverables Top Down Agile model (see Deliverables section above)

i. If you want to only support ALMRequests, create no ALMWorkConfigurations for ALMTask Record Types

ii. If you want to only support ALMRequests and ALMTasks but nop ALMActivities, create no ALMWorkConfigurations for ALMActivity ALMRecord Types

Categories
7) For Categories (Products, features etc)

a. Are there certain Categories which can be subdivided into SubCategories and some which cannot?

i. Those Categories with no SuperCategories are presented first when an ALMRequest is Submitted

ii. Clicking Drill Down presents reusable SubCategories which may be associated with one or more SuperCategories

b. Do you do Component Based Development?

i. Every Component Project should be associated with a Component Category which has no SuperCategories

c. Can your Categories be typed themselves?

i. Category->CategoryTypeLabel is used to help subselect Categories when submitting Requests and doing Category Drill Down.

d. Is your development process sufficiently predictable that 

i. When a Request->Category is selected, there is more often than not a Project currently active for that Category?  If so, Set Category->CurrentProject

ii. When a Request->Project is set, there is more often than not a Phase currently active for that Project?  If so, Set Project->CurrentPhase

iii. When a Request->Phase is set, there is more often than not an Iteration currently active for that Phase?  If so, Set Phase->CurrentIteration

e. Who should be Owner of this Category?

i. Project Administrator

Your Project 

8) For your Project which of the following best describe it

a. If you do Component based development

i. Each Component should have its own Project referencing a Category with no SuperCategories and its own ReleaseLabel

ii. Each Component’s Project should have the overall Product’s Project as its SuperProject

b. Who should be Owner of this Project?

i. Project Administrator

c. If you are adopting the Bottom-up Agile model with Deliverables as describe in Deliverables/non-Deliverables section 

i. Set only ALMProject->DefaultRequest with General Request for 2 record Agile process

ii. If preferring 1 record Agile process Set ALMProject->DefaultRequest with General Request and ALMProject->DefaultTask with General Task and associate Request with General Task.

iii. Choose ALMProject SetDefault Action to auto set the Task->Request for 2-record and Activity->Task for 1 record Agile processes

Labels for best practices

9) Which of the following match the sets provided with OOTB Practices

a. ResolutionCodeLabels

i. Associated with an ALMRecord Type on the ResolutionCodes

b. StatusLabels

i. Associated with Phases, Iterations and BTBuilds

c. PhaseLabels

i. Associated with Projects on Phases

d. IterationLabels

i. Associated with Phases (see above)

e. ReleaseLabels

i. Associated with Projects

f. TypeLabels

i. Types have TypeIndicators which refer to a field on the ALMRecord that the Type applies to

1. ALMRequest->Type or Severity

2. ALMTask->Type or Priority

3. ALMActivity->Type

4. BTBuild->ALMBuildType or ALMBuildStatus

Creating Queries

10) Creating Queries

a. The ToDo Process (My Project and REST folders) has a set of queries posted on the wiki

i. Triage

1. Looks for Opened ALMRequests with no Tasks

ii. DevLead

1. Looks for Opened Tasks Owned by Devlead

2. or Activated Tasks with no Activities

3. or Submitted ‘Dev’ Activities that are not Opened and Owned by someone

iii. TestLead

1. Looks for Activated Tasks with Submitted ‘Test’ Type Activities needing to be Opened and Owner set

iv. Dev

1. Looks for non-Doc-related ‘Dev’ Type Opened or Activated Activities Owned by <Dev> associated with Activated Tasks

v. ReleaseEngineer

1. Query in General folder Find Last Baseline for a Project 
vi. Tester w Build  There are Dynamic and static Project-based versions of many of the same queries in the My Project and REST folders.  The REST versions are designed to be used by CQ 7.1 Falcon Shortcuts executed as RSS feeds in Notes 8 or other RSS feeds.
1. Looks for Activities associated with ALMBaselines for which there is a Build which has a BTBuildStatus=’Passed’, Owned by <Tester> and for which there sibling Activities of Type=’Test’ that are not Completed themselves

2. This query takes advantage of 2 positive case filters that enable an Exists with Nested select simulation using the CQ Query editor:

a. It looks for Tasks that have one or more Activities reflecting fixes that are in a Baseline of work from which a build with a Status=’Passed’was created

b. It then revisits that Task and looks fo the 2nd positive case which is a sibling Activity of the Activity described in step 1 whose Type is ‘Test’ and which is not Completed itself

vii. Completing Tasks

1. Looks for Tasks that are Activated, , Owned by <TestLead> for which there are one or more Completed Activities.

2. These are the Tasks that may be candidates for Completion themselves.

3. There is a new BuildForge script that is capable of finding Tasks for which all Activities are Completed only.

viii. Requestor

1. Looks for Opened Request Owned by <Requestor> where one or more Associated Tasks are Completed
SecurityPolicy choices
Building Blocks

	
	For this scenario:
	Follow this approach:

	a
	There doesn’t need to be a separation of data between the users – everyone is “one big happy family”
	One Security Policy for all users including ‘ALL’ Project

	b
	Expecting essentially the same set of users to be working on different versions of the same project
	One Security Policy per Category

	c
	Expecting turnover of users from project to project
	One Security Policy per Project (Category and Release)

	d
	Doing componentized development, where there are different projects for each component with potentially different release schedules, but the security context needs to span an offering and all of it’s different components
	One Security Policy per Offering and its Components

	e
	There are users who require simply notification of events but do not need to see the records themselves
	Users not in Security Policy (email notification)

	f
	Users are able to see the records but do not need to make modifications to them
	Users in SecurityPolicy but not Role->Members (See but not do)


· One Security Policy for all users including ‘ALL’ Project

· One Security Policy per Category

· One Security Policy per Project (Category and Release)

· One Security Policy per Offering and its Components

· Users not in Security Policy (email notification)

· User needs to request being added to NotifyList of any records or Owner of record needs to know to add them.

· Users in SecurityPolicy but not Role->Members (See but not do)

· We need a decision table support.  What is the situation that the customer would take this option

· Use Case approach

· A series of questions that we can present to users

· Workspace ACLs need to be explored

Functionality
· Implements CQ SecurityContext

·   Refers to CQ User Group(s)
· ALMAdmins can Submit and Modify SecurityPolicy records

· Only CQ Users with Security_Admin privileges can set ratl_context_groups
· Permits people to see records

· Protected records

· Request, Task, Activity, Build, Baseline, Comment, Category, Project, Phase, Iteration, Role, WorkConfig
· Unprotected records
· Reference-Type field values in Query filters
· Non-ALM Records 

· UCM, Requirements, CQTM, etc
· All Components and their Offerings should share a SecurityPolicy
· SubProjects, SuperProjects, CompositeBaselines, SubCategories,SuperCategories must share SecurityPolicy
· There needs to be a SecurityPolicy Named ’Everyone’
· Refers to all CQ User Groups

· Used for Tasks referring to ‘ALL’ Project  produced when Triage Rejects Requests
· SecurityPolicies  with multiple ratl_context_groups (?)
· different SecurityPolicies with overlapping ratl_context_groups(?)
· ratl_context_groups with overlapping sets of users(?)
Roles 

Building Blocks

	
	Concept
	Used when:

	a
	Role Labels
	In all Roles for setting standard sets of ApprovedActions across all Projects

	b
	ApprovedActions
	Establishing Project Roles by defining which Actions can be done for Tasks, Activities 

	c
	
	

	d
	
	

	e
	
	

	f
	
	


· People

· Members

· User Groups

· Primary

· Approved Actions

· Duplicating Record Actions of other Roles

· Duplicating Members in other Roles

Functionality

· Roles and ALMAdmins
· ALMAdmins records
· Modifiable only by ALMAdmin->Members
· Members not subject to Role restrictions

· Only individuals able to change …Label, ResolutionCode, Role, WorkConfig, SecurityPolicy records.
· Projects
· RoleLabels
· RoleLabel->ApprovedActions provide CQ database-wide archetypal permissions which are inherited by Roles where they can be changed by 
· In order to indicate hierarchies of Roles, we can add the Members of the upper level to the Members of the lower level.
· Alternatively we can add the ApprovedActions of the lower level to the ApprovedActions of the upper level.

· The determinant is whether the Role->Primary should be from the upper or lower level. If from the upper, add the Members/Groups of the upper level to the Members/Groups of the lower level.
· Owner->ratl_mastership sets record ratl_mastership
· Role->Primary is used to set the default Owner for a Task 
· Role->Primary is used to set the record ratl_mastership when there is no Owner (Activity in Submitted State)
· Requests are not effected by Roles since the Submitter is, by default, the Owner.
· Role->Groups are best used when there are relatively static sets of users.
· Constrained sets of ApprovedActions vs Add All Actions

· Role-related reduced sets of ApprovedActions can be used to simplify queries.

· If a limited set of individuals are permitted to Open or Complete Tasks, queries and reports can focus on the relationship between Requests and Tasks rather than Requests and Activities when it comes to determining the status of a Project.
Work Configurations

Building Blocks
· Primary Children

· Secondary Children

· Role

· As Owner Choices

· Primary As default Owner (Opened Task)

· Primary As default mastership (Submitted Activity)

· Approved Actions by record type

 
Functionality
a. Project
b. Record_type
i. Roles and Children settings are variable by Project, Record_type and TypeLabel
c. Type

i. To change the Type of a WorkConfig record there are 3 scenarios that should be considered
1. You want the new Type to replace the old Type in every case for every Project in the CQ ALM database
a. Rename the TypeLabel.

b. This will adjust all related Types and WorkConfigs and all Request, Task and Activity records that reference that Type as well.

c. You need to notify users that the values in their Query filters and reports have changed.
2. You want the new Type to be used without changing those records that have used it to date in a given Project but you want no more records to be submitted with the old Type
a. Obsolete the WorkConfiguration record(s) for that Project that refer to the old Type. 
b. You want to create a new TypeLabel and Type for all applicable record types
c. Create ALMWorkConfigurations for all Record Types and Types for all records that referenced the old  Type..
3. You want the new Type to be used without changing those records that have used it to date in all Projects but you want no more records to be submitted with the old Type for any Project

a. Obsolete the TypeLabel, Type and WorkConfiguration records
d. Role

i. Members and Groups provide Task and Activity Owner choices and Primary choices

ii. Primary set as Task->Owner when Task is Opened (initial State)

iii. Primary set as Task->ratl mastership when Activity is Submitted (initial State)
iv. Approved Actions by record type

e. Primary Children

f. Secondary Children 

Queries 
Building Blocks


· Queries as the equivalents of CQ schema hooks: the Software of ALM

· Sorting in CQMS

· Sequencing (etc) by first and last History Actions

· Filtering on 2-tier relationships

· Queries used to sequence Request->Tasks and Task->Activities

· “Dot variable” querying

· ALMWorkItem Family

· Explain query unique keys and stateful and stateless

Functionality
a. Think of Queries as the equivalents of CQ schema hooks: the Software of ALM

b. Sorting in CQMS

i. History.action_timestamp is only timestamp that works correctly for CQMS and only if you have UTC timestamp enabled. (CQ Doc)

ii. History is a set of records not a set of Values in a multi value or Reference_List field.
iii. Filtering on a History value isolates the record or set of History records to include in selection
c. Sequencing (etc) by first and last History Actions

i. Filtering on first or last History record restricts History values to those associated with First or Last History record only for a given record

ii. For initial creation of a record in CQALM Add ANDed filter of (History.action_name in ('Copy_Record','Import') OR History.old_state = 'no_value')
iii. For last Action Add ANDed filter ‘History.expirationTimestamp IS NULL 

c> Note: if you want to further qualify that the last Action was of a certain type you can add an additional filter of History.<field> <Operator> some value

iv. Add Display field History.action.timestamp and Sort on this to get global UTC timestamp sort for every record in a query’s Result Set
c> The Timestamp used is the value on the first or last record.  The latter might be more useful if checking for Completion of a record.

v. You can additionally query on other values if you know there would not be more than one History record that would qualify.  In ALM many of the Actions can be done more than once such as the Complete Action which might be done once, then a ReOpen may occur and Complete may be done again.

d. Filtering on 2-tier relationships

e. Queries used to sequence Request->Tasks and Task->Activities

f. “Dot variable” querying

g. ALMWorkItem Family

h. Explain query unique keys and stateful and stateless

i. ID for Stateful

c> For Request, Task, Activity, Project and BTBuild, the value looks like ‘BHAL000000003’

ii. Unique Key(s) for Stateless

c> Type has 3 concatenated keys

a. RecordType (and ALM field not to be confused with the CQ generic field record_type which indicates the current records CQ type

i. ALMRequest
ii. ALMTask
iii. ALMActivity
iv. BTBuild
b. TypeLabel (the actual Type value)

i. TypeLabels created in your db

c. TypeIndicator (the field on the RecordType that this TypeLabel applies to)

i. ‘Type’ (as in ALMRequest->Type)
ii. ‘Severity’ (as in ALMRequest->Severity)

iii. ‘Priority’ (as in ALMTask->Priority)
i. Unique Keys for ALM records (Note: where one record is referred to by another, the unique key of the referred to record is the value you see when selecting a value for the referring record.  Ex: Iteration refers to ALMPhase and ALMIterationLabel.  The ALMPhase unique key is Project and PhaseLabel, Project’s unique key is ID.  So the unique key of Iteration is Project->ID, PhaseLabel->Name and IterationLabel->Name). See CQ Designer for other related record info.)

i. Stateful records with Unique ID

c> ALMRequest

d> ALMTask

e> ALMActivity

f> ALMProject

a. Name (uniqueness enforced by ALM hook) 

b. Category and Release (Concatenated uniqueness enforced by ALM hook)

g> BTBuild (Part of Deployment Tracking CQ Package)

ii. Stateless records with Name as unique key

c> ALMAdmin

d> ALMCategory

e> ALMCategoryTypeLabel

f> ALMIterationLabel

g> ALMPhaseLabel

h> ALMReleaseLabel

i> ALMResolutionCodeLabel

j> ALMRoleLabel

k> ALMSecurityPolicy

l> ALMStatusLabel

m> ALMTypeLabel

iii. Stateless records with concatenated keys

c> ALMBaseline (PVOB_OrLocation and Name)

d> ALMPhase (ALMProject and PhaseLabel)

e> ALMIteration (Phase and IterationLabel)

f> ALMResolutionCode (ALMRecordType and ALMResolutionCodeLabel)

g> ALMRole (Project and RoleLabel)

h> ALMType (ALMRecordType, TypeLabel and TypeIndicator)

a. ALMRecordType is the CQ record_type referred to by an ALM or BTBuild record. “record_type” is a CQ reserved word.  In the case of an ALMType record, the CQ record_type is ‘ALMType’. In the case of an ALMRequest, the record_type is ‘ALMRequest’.) 

i> ALMWorkConfiguration (ALMProject and ALMType)

iv. Stateless records with dbid as unique key

j. ALMComment

Projects, Categories and Releases

Building Blocks

· Default Request

· Default Task

· Phases

· Instead of Projects

· Category

· Drill Down on Request

· No Project associated in any way.

· Reporting Tags (New)

· Release

· SuperProject-SubProject

· SuperCategory-SubCategory

· Composite Baselines-Baselines ComposedOf

Functionality
a. Default Request

b. Default Task

c. Phases

a. Instead of Projects

d. CategoryTypeLabels and Categories
a. CategoryTypeLabels determine Category types

b. Changing the Category value builds a set of choices for the current Category’s SubCategories

c. For Example in a system with only the following Categories and all Categories using the same SecurityPolicy or the User being in both SecurityPolicy->Groups:

d. ‘ClearQuest’

i. No SuperCategories

ii. CategoryTypeLabel = ‘Product’

iii. SecurityPolicy = ‘SP_ALM’

e. ‘Finance’

i. No SuperCategories

ii. CategoryTypeLabel = ‘Process’
iii. SecurityPolicy = ‘SP_ALM’

f. Alternate Case:

i. Category = ‘Finance’ has a SecurityPolicy = ‘SP_Issue’ and User is in SecurityPolicy = ‘SP_Issue’ but not in ‘SP_ALM’

a. In this case a Request against ClearQuest Project may be created and it must be associated with a Project 

b. The Project will not be visible on the Request though it has been added and when the Request is Submitted, the Request will not be visible.

c. This allows requests to be submitted across visibility boundaries but not to be viewable once it has crossed that boundary without the proper SecurityPolicy  Group membership.

g. ‘ FinancePkg’ 

i. SuperCategory = ‘Finance’

ii. CategoryTypeLabel = ‘Package’

h. ‘FinanceComponent’
i. SuperCategory = ‘Finance’

ii. CategoryTypeLabel = ‘Component’

i. When I Submit a Request or click the Request->ClearPath button I will see the set of all Categories that themselves have no SuperCategories
i. This means I will see 2 values

a. ‘ClearQuest’

b. ‘Finance’

j. If I choose CategoryTypeLabel = ‘Product’, I will see only ‘ClearQuest ‘ in the Category Choice list.

k. If I choose CategoryTypeLabel = ‘Issue’, I will see only ‘Finance ‘ in the Category Choice list.

l. With Category still set to ‘Finance’ if I then click the ‘Drill into Category’ button and check the Category Choice list, CategoryTypeLabel will be blank and I will see
i. FinancePkg (a Category with  CategoryTypeLabel = ‘Package’)
ii. FinanceComponent (a Category with CategoryTypeLabel = ‘Component’)

m. If I choose CategoryTypeLabel =  ‘Package’, I will see only ‘FinancePkg ‘ in the Category Choice list.

n. If I choose CategoryTypeLabel =  ‘Component’, I will see only ‘FinanceComponent ‘ in the Category Choice list.

o. How can you use this to simplify your choices?

p. Componentized development is also supported

i. Let’s say that ‘Offerings’ are Customer installable Products that are comprised of code that is explicitly included as well as code that is included by virtue of being part of a Component that is itself included in the Offering.

ii. Both Offerings and Components have their own Categories and Releases and therefore their own Projects which may be Category->CurrentProjects which can be automatically assigned when that Request->Category is selected or when a Project->SetDefault Action is executed  during a CQ session.

q. Let’s say you have two types of person entering records in your CQALM database.

i. Developer who is knowledgeable about problems in both External Products (CQALM Categories) and the Components that are used to build those Products as well as released and yet to be release Products

ii. Tech Support who represents customers who will only know about the Products not about the Components and who would only report problems with Release Products. 


If the Categories were Typed to accommodate those two groups

a. Developers could choose Categories of all types

b. Tech Support would only have to choose Categories for Released installable Products.
r. Categories with no SuperCategories 

i. These are the only Category choices that appear when you first Open a Request or following a Request->ClearPath Button Click.

ii. CategoryTypeLabel choices are provided to refine and reduce those lists.

iii. When doing Componentized development, both Installable Products and Components that comprise installableProducts should be Categories with no SuperCategories.

s. No Project associated in any way.

e. Reporting Tags (New)

f. Release

g. SuperProject-SubProject

i. These relationships show how Projects relate to each other

ii. A typical example would be an Offering composed of  many Components.  The Offering Project would be a SuperProject of all of the Component Projects

h. CompositeBaselines show how Baselines of different Projects are gathered into one Baseline.

i. Composite Baselines-Baselines ComposedOf

Baselines and Builds

Building Blocks

Functionality
Types

Building Blocks

· TypeIndicator 
· CQ Fieldname vs ‘Type’
Functionality

Models

Building Blocks

· 3-record Model (Standard)

· 2-record model (Triage and DevLead Roles combined)

· record model (no Triage or DevLead)

· Switching between models

· Combining Models

Functionality

· 3-record Model (Standard)

· Request (Triage creates Tasks)
· Task (Optional if Request is Withdrawn before Triage) (DevLead creates Activities). Queries need to filter on Tasks needing to be Activated, Activities to be Created and Activities to be Opened
· Activity (Optional if Task work is not delegated)

· 2-record model (Triage and DevLead Roles combined)
· Upper tier (Request-Task). No UCM deliverables
· Lower tier (Task-Activity)

Task with Project->DefaultRequest

Activity (Optional if Task work is not delegated)

UCM deliverables


[image: image1]
· 1-record model (no Triage or DevLead)

· Request only (non-delegated work)
· Task only (Lower tier 2-record non-delegated work) with Project->DefaultRequest
· Activity only with Project->DefaultRequest and DefaultTask and UCM deliverables


[image: image2]
· Switching between models

Cleaning up old model’s records

· Combining Models

Query and reporting implications

Testing  

(Following under development)

Building Blocks

· Detecting when all Activities/Tasks are Completed
Functionality

A Dev can fill these in on a Dev Activity, Test can fill them in on a Test Activity and each Activity would Stay Opened/Activated until there is a value in ValidatedIn or NoPlan ToTestInBuilds That is one approach 
Hmm, that won't work for my 'Ready for QA' fix though which depends on the Dev Activity being completed

The issue is if QA then subsequent fail their task I need a new dev Activity for the "Ready for QA" fix to work for that Task 
I would say the UCM process is that when you Deliver but before you COmplete the Delivery, CC gives you the chance to do FVT testing. If it passes (VIB filled in) then Dev COmpletes Delivery and that Completes the Activity 
I am referring to Functional Testing by the Dev not Systems Testing by Test right? 
ok - but what happens if dev are happy with their testing and complete the Activity but then it subsequently fails QA? 
If QA fails during SVT/Integration testing, then Dev needs a new Activity 
Ok, thats what I was hoping you would say 
Models

g. Standard model with separate Triage, Lead and Resolution Roles

h. b. Medium (2-record) Model

Component Based Development
Building Blocks

· Sub/SuperCategories

· Sub/SuperProjects

· Category Types

· True Component development vs single VOB development
Functionality
a. Component based development can be accomplished by a combination of sub and super categories and Projects with a CurrentProject
b. Component base development has two parts

i. The Component

ii. The consuming Offering

c. A problem may be reported by a customer against an Offering since customers should not know about the Components that make up the Offering

d. Development and internal testers will know about Components having problems and they will want to report problems

e. The Request->Category is Optional.  People reporting problems agains Components would not enter a Category, theyt would just choose a Component’s Project for the Request. Project is Mandatory
f. Offering Categories would have a CurrentProject and when a problem or rfe is reported, the Project would be auto set

g. Categories that are associated with Component Projects would be SubCategories of one or more Offering Projects that consume the Components.

h. The Component’s Project may have the Offering’s Project as its SuperProject

i. When a Task is generated, it takes the Request->Project by Default.  If the Request is filed against the Offering, this may not be the only Task that is entered because though the Offering needs new improved functionality, the work may need to be done on the Component.  Conversely, it does no good tyo fix the problem in the Component if the Comp[onent is not included in the Offering.  This means that there will need to be two Tasks, one to track the fixes to the Component and another Task to trackj the inclusion of the work done on the Component in the Offering.

j. An Example:

i. The ALM Packages are a separate development effort whose output (the ALM Packages) is included in the ClearQuest Offering

ii. The ALM Packages are SubCategories of the ClearQuest->CQ Packages Category.

iii. The ClearQuest Category has as a CurrentProject the Clearquest 7.1 Project

iv. The ALMWork and ALMProject packages are released together usually and therefore could be considered SubCategories of the CQ ALM 1.2 or 1.3 etc Project

v. The CQ ALM Category may have a CurrentProject and each of the Packages ALMProject and ALMWork may also have their own CurrentProject

vi. When a Task is generated, the Project can be changed to match the CQ ALM Project or the ALMWork or ALMProject Projects.  Activities generated under those Tasks will be associated with the Component Projects.

vii. The Sub and SuperProject indicates alignment of deliverables between the Offering and the Component Projects

RTC-RQM-ALM

Building Blocks
· ALMRequest->Story WI

· ALMTask->Task WI

· ALMActivity->Type->WI Type

Functionality

Cleanup by Admin

Building Blocks

· Sequence of deleting records 

Functionality
Working across the WAN with Eclipse

a. Due to smaller faster records,ALM is able to work efficiently across the WAN.

b. This is not recommended for large monolithic-type CQ record designs due to performance issues, but CQ ALM works efficiently across the WAN

c. There are 2 areas that are slower than is desired

i. When logging on to CQ, it will take an extended period of time (measured in seconds)

ii. When drilling down into Query folders, it will take longer than expected

Working with ALM embedded in new and pre-existing CQ database

Building Blocks

Functionality
a. ALM databases can be created by CQ 7.1 Maintenance Tool

i. Menu->Schema Repository->Create

ii. Define DB (If using non-Access you must create database shells forSchema Repo and User DBs

iii. Create Sample Database->Schema to Use->ALM

1. ‘SAMPL’ is only permitted value

iv. Sample data will be loaded reflecting the Open Up scenario

v. Here is the 7.0.1 version of that functionality.  CQ 7.1 provides it OOTB

vi. https://submit.boulder.ibm.com/webapp/iwm/tools/querytool/summaryReport.do
b. ALMPackages can be used to create a new database using CQDesigner

i. No Sample data will be loaded

c. ALM Packages (Project and Work) can be added to existing CQ database.

i. Due to there being preexisting Default records in preexisting CQ databases, creating ALM records will take longer than expected the first time it is attempted in a CQ session.  This is not due to CQ ALM, but rather large numbers of record types of any kind will be impacted by there being a lot of legacy record types.  This is a first time per login issue not a general processing issue.

d. Sample data can be Imported to implement the ToDo scenario in any of the three methods created above

e. Here is a zipAttachment with queries also. (Note: Link is accessible only within IBM.  Need to attach zip file if distributing to customers.)

i. http://pokgsa.ibm.com/home/r/w/rwmyers/web/shared/ALMToDoScenario/ToDo.zip
ii. Modify the ToDo_UserInfo.txt file replacing 

a. databases       = SAMPL 

2. with your logical database name if you have not created the schema using the OOTB approach.

Making schema changes in CQ Designer

Building Blocks

Functionality
a. Base Actions

b. Fields with Prefix/Suffix

c. Tabs with Prefix/Suffix and new field Form Controls

d. Export integrating customizations and reapplying changes 

e. When is a schema change the best alternative?

i. A group has a concept that has not been conceptualized in ALM

1. Idea of  a geographical affiliation

ii. First idea

1. Use Category drill down

2. Top level Category (Category with no SuperCategories)  is most closely identified with the Project

3. 2nd level is a concatenated geographical Hub-Country Category whose SuperCategory is all of the Top level Categories

4. 3rd level is a set of sub Categories that themselves have no subcategories which can be used to set the Request Category and which have all of the Hub-Country Categories as SuperCategories

5. The CategoryDataPath which keeps track of the Category Drill down can be used to query for Hub-Country combinations

iii. 2nd idea

1. Add a record called “HubCountryLabel” with 2 fields “Hub” and “Country”.

2. Add a Reference List field called “HubCountries” to the Request, Task and Activity records that refers to the “HubCountryLabel “ record. Also add a PC Control to those 3 records on a Tab named something that would not be chosen by the ALM development team (Pre/Suffix)

Pushing Back

Building Blocks

· Commenting vs direct updating

· Reject (etc) process

· Duplicate Process

· Question and Response

· Commenting with no Response required

· Owner only person to directly update a record, all others Comment

· Placing yourself on NotifyList Direct updating or via Comment Request

Functionality
a. ALMRequest Actions

i. Reject_Request
1. The ResolutionCode with ALMRecordType = ‘ALMTask/ALMActivity’ and ResolutionCodeType = ‘Reject_Request’
ii. WorksAsDesigned
1. The ResolutionCode with ALMRecordType = ‘ALMTask/ALMActivity’ and ResolutionCodeType = ‘WorksAsDesigned’
iii. Unreproducible
1. The ResolutionCode with ALMRecordType = ‘ALMTask/ALMActivity’ and ResolutionCodeType = ‘Unreproducible
iv. MarkAsDuplicate/DuplicateComplete
1. Uses Comment with Duplicate ALMRequest
v. The Process

b. ALMTask and ALMActivity

i. Complete  w ResolutionCode= <ALM Task/Activity><your push back terms>

c. Commenting as an explanation for the Pushing Back

i. Comments are generated automatically when the Request Push back Actions are executed

ii. Comments  are used to explain Push back on Tasks or Activities

iii. Comments are used to indicate that a record is a Duplicate without big footing someone else’s Record.

Debugging

Added to the ALM record as an ALMAdmin->Member. (This allows you to do all actions making it easier to test) but is not useful for Role debugging
Practices

Building Blocks

· RUP

· OpenUp

· Rational Best Practice

· ToDo

· Iterative Development

· Scrum

· Requirements

· Requirements Management

· Shared Vision

· Use-Case Driven Development

· Business Transformation Analysis

· Design

· Evolutionary Design

· Web 2.0 Practice

· Implementation

· Design Driven Implementation

· Test Driven Development

· Architecture

· Component Based Software Architcture

· Enterprise Data

· Evolutionary Architecture

· SOA SOMA Practice

· SOA WBM
Functionality

Activity may be Opened and/or Activated





Optional Roles: Submitter/Tester. 


Triage is performed by Dev in 1-record Model


Release Engineer role may be performed by Dev or by RE.


ProjectAdmin Completes Project and DefaultRequest/Task





Project->SetDefault





Activity





Request





Task





Release








Task/Activity may be Opened and/or Activated. ProjectAdmin Role Completes Project and DefaultRequest. There is no DefaultTask








Optional Roles: Submitter/Test Lead/Tester/Release Engineer. Triage is performed by Lead in 2-record Model





Project->SetDefault





Complete Tasks











Activity








Request








Task








Release








Category








Project





Resolution Owner (aka Dev)


Modify/Completes �Activity





Lead


Submit Task


Optional: Create Activities





Medium (2-record) Model (Integrated Triage)





Category





Project





Resolution Owner


Submit and Edit Activities


Complete �Activity





Agile (1-record) Model (Integrated Triage/Lead/Dev)
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