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Chapter 1. Scenario: Connecting WebSphere Application
Server Liberty profile to WebSphere MQ on Windows

By connecting to WebSphere® MQ, Java™ EE applications on WebSphere
Application Server Liberty profile can consume and work with messages from
WebSphere MQ. Starting with an existing WebSphere MQ installation, this scenario
leads you through the key tasks required to install and connect WebSphere
Application Server Liberty profile on the same Windows computer.

This scenario was developed using a sample WebSphere MQ installation, and uses
sample applications to demonstrate the use of WebSphere Application Server
Liberty profile connected to WebSphere MQ. If you want to try the scenario, you
can set up a copy of the sample installation as described in the scenario. You can
use the sample applications provided with the scenario to verify your progress
through each stage.

Notes

This scenario applies to the use of WebSphere Application Server Version
Liberty profile Version 8.5.5 with WebSphere MQ version 7.5.

This scenario was developed and tested with WebSphere Application
Server Version Liberty profile Version 8.5.5 and WebSphere MQ version 7.5.

Optional information to help you learn while implementing the solution
The scenario contains blocks of optional information marked by Why? or
What else?. You do not need to read this information to complete the
scenario, but might choose to learn more:

Why? Describes why you are instructed to do something. For example:

Why am I doing this?
You use the Scope property to set the level at which the
activation specification is visible. The cell scope is the highest
level, giving the activation specification the greatest visibility.

What else?
Describes what else you might do, or want to learn about, related to
what you are reading in the main window. For example:

What else might I do or be interested in?
You can also create activation specifications at other levels.
For example, if you have multiple servers you might create
an activation specification for each server, using the server
scope, so that you can specify different settings to be used for
each server.

Tip: Some “Why?” and “What else?” information provides links that
would take you to information resources outside the scenario. To complete
a scenario, you do not need to follow such links; they are provided only as
optional aids for your learning.

Related information:
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This scenario in IBM Knowledge Center
This scenario in the Scenarios and Patterns information center

Product web page
WebSphere Application Server product web page

Library page
WebSphere Application Server library page

Product web page
WebSphere MQ product web page

Library page
WebSphere MQ library page
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Chapter 2. Planning the solution

You can connect WebSphere Application Server Liberty Profile to WebSphere MQ.
Review the topics in this section to understand what is covered in this scenario,
the reasons why a business might want to follow the scenario, the user roles
involved, and an overview of the solution proposed by the scenario.

Assumptions
This scenario makes several assumptions about your system, such as the version of
the products that you are using.

This scenario applies to the use of WebSphere Application Server Liberty Profile
version 8.5.5 with WebSphere MQ version 7.5 This scenario was developed by
using WebSphere MQ version 7.5 with Fix Pack 1.

This scenario assumes the following points:
v You are using the Windows operating system.
v You do not have security configured for WebSphere MQ. This scenario does not

describe security configuration. However, if you do have security configured for
WebSphere MQ you should still be able to complete the scenario.

v You use graphical user interfaces of WebSphere MQ, rather than the
command-line equivalents.

Business overview
A company wants to add a Java EE application on the WebSphere Application
Server Liberty profile to consume and process messages from an existing
messaging infrastructure that is provided by WebSphere MQ.

To date, company A has a business solution that uses WebSphere MQ for its
messaging infrastructure. Business users interact with a stand-alone client
application, for example to register an order, which sends a message into the
infrastructure. Such messages are transported by the infrastructure for processing
by some separate WebSphere MQ application, possibly in a different business unit.
The client application waits for a reply message to provide the business user with
an appropriate response.

Changes to the business model of the company mean that the current method of
processing messages is inadequate. In addition, processing is not implemented in a
standards-based way that can best be developed for the future. The company
recognizes that the dynamic business needs of today are driving IT departments to
implement standards-based computing. The company wants to use
standards-based programming to provide updated methods of processing before
the messages are returned to business users. The company decides that they want
to use the Java Message Service (JMS), the Java EE standard for messaging, which
provides a standard API for applications that implement enterprise messaging with
application portability. The company also recognizes that the Java EE standard
streamlines application development, and with these standards they can create
reusable, platform-independent modules.

© Copyright IBM Corp. 2013 3



The new company model also focuses on reducing development and maintenance
costs, shortening development schedules, and significantly improving time to
productivity. The development environment must be easy to use, collaborative, and
dynamic so that the most frequent tasks can be completed more quickly and with
less effort.

The company decides to add a Java EE application on the Liberty profile to
consume and process messages in the solution. The Liberty profile is a dynamic
WebSphere Application Server profile, available on WebSphere Application Server
Version 8.5.5 and later that enables the server to provision only the features that
are required by the applications that are deployed to the server. This dynamic
profile minimizes the server startup time and memory footprint. Any new features
can be added without needing to restart the server. This ability is important in a
development environment, where application capabilities are built up iteratively,
classes are modified, resources are added, and problems are fixed. Code and
configuration changes are easy to make and reflected immediately in the
development environment. The combination of the Liberty profile and the new
WebSphere Application Server Developer Tools for Eclipse provides a rich
experience for developers; focusing on Java EE web and mobile tools, and
integration of the Liberty profile for the debug and test server environment.
Developers can now develop, assemble, test, and publish web applications by
using lightweight tools to lightweight development run time environments.
Continuing the development-centric focus of the Liberty profile, configuration of
the server is now through a simple XML file, which is easy to author, maintain in a
version control system, and share.

With the Liberty profile, the company appreciates that as their business demands
increase, they can take advantage of the latest standards and programming models
that the Liberty profile supports, or even scale up their business capability by
adopting higher-performance features or editions of WebSphere Application Server.
The tools and capabilities of the Liberty profile make it easy to deploy web
applications to other WebSphere Application Server production environments
without change.
Related information:

WebSphere Application Server features and benefits web page

Liberty profile overview

Installing the Liberty profile developer tools and (optionally) the Liberty profile

User roles and interactions
Roles used throughout these scenarios, with interactions between roles for scenario
tasks.

Although roles to develop the solution are listed, this scenario focuses on
deploying a solution that connects WebSphere Application Server to WebSphere
MQ.

Develop the solution

Develop the software aspects of the solution.

Software Architect
The Software Architect is responsible for dividing the required function
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between the components that make up a software solution. This person
works with the specifications and standards used by existing IT systems,
and determines where enhancements or new components must be written
by the Developer.

Developer
The Developer is responsible for creating and testing the software
components and linking them together. In some cases the Developer might
need information from the Administrator, for example if the Developer
must use an existing queue name in their software code. After the
Developer finishes creating the software components, the Developer gives
those components to the Administrator for deployment.

Deploy the solution

Deploy the solution for production use, by installing, configuring, and testing the
components that provide the solution.

Administrator
The Administrator installs and configures the components that support the
solution, in this case WebSphere MQ and WebSphere Application Server.
The business might have a different Administrator for each product, or one
Administrator might perform installation and configuration for all
components. If the Administrators are different they might need to
exchange information. For example, in this scenario the WebSphere MQ
administrator must give the name of the queue and queue manager to the
WebSphere Application Server administrator. The Administrator also
deploys the software components given to them by the Developer.

Test Implementer
The Test Implementer runs the tests to validate the solution and that the
solution is ready for production use. For example, can the solution be
started, stopped, backed up, and recovered after a system failure as well as
be maintained?
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Technical solution
This scenario describes one way of connecting WebSphere Application Server
Liberty Profile to an existing WebSphere MQ system, by using JMS, JCA and JNDI.

Overview: Initial IT configuration
Company A has an existing IT configuration that uses WebSphere MQ for its
messaging infrastructure. This scenario describes adding WebSphere Application
Server Liberty Profile to that initial messaging infrastructure.

The initial IT configuration includes several components that an administrator
configures or uses, as shown in Figure 2 on page 9:

JMS application
A stand-alone application that business users interact with, for example to
register an order. The application uses the Java Message Service (JMS) for
asynchronous messaging.

Figure 1. User role interactions to deploy the solution
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Why am I doing this?

v JMS is the Java EE messaging standard that is widely supported.
JMS-based applications are therefore portable across many
messaging products.

v JMS provides a level of abstraction from the details of the
messaging layer, simplifying the application development process.

v JMS provides asynchronous communication, enabling applications
to run without having to wait for a reply, unlike tightly coupled
systems such as remote procedure call (RPC).

v Applications that use JMS do not directly specify details to access
resources. Instead, they look up and use administered JMS objects
such as a connection factory and a destination.

What else might I do or be interested in?
For some situations, other messaging standards might be more
suitable than JMS. For example IBM® Message Service Clients for C,
C++ and .NET, also known as XMS, are APIs that provide similar
benefits to JMS for non-Java applications. XMS is therefore more
suitable if you are using the .NET platform, or you want to integrate
existing C++ applications with newer Java EE applications.

The application uses point-to-point messaging to send messages to a queue
in the infrastructure and processes reply messages, to provide the business
user with an appropriate response.

Why am I doing this?
In this messaging model, an application sends a message to a queue,
and another application receives the message from the queue and
acknowledges receipt of the message. This model is the simplest form
of messaging because it involves only two endpoints. This model is
also the most appropriate for the scenario sample application: a single
client requests information from a single server.

What else might I do or be interested in?
In the alternative messaging model, publish/subscribe, a publisher
publishes a message to a message topic. Subscribers subscribe to the
topic to receive messages. The publisher and subscriber do not have
any information about each other, and the message is received by
zero or more recipients.

Queue manager sampleQM
The WebSphere MQ queue manager that provides the initial messaging
infrastructure. It hosts the queue that the JMS application works with.

Q1 [Message queue]
The WebSphere MQ queue that the JMS application sends messages to.
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JNDI namespace
A Java Naming and Directory Interface (JNDI) namespace is used to hold
JMS administered objects, which applications can use to connect to
WebSphere MQ and access destinations to send or receive messages.

Why am I doing this?
JNDI is part of Java EE, and provides a standard way for applications
to access various types of naming and directory services, for the
retrieval of application components. For example, you can use JNDI
to access a naming service on a file system to retrieve the location of
a printer object, or to access a directory service on an LDAP server to
retrieve a user object which contains ID and password information.
JNDI therefore enhances the portability of JMS-based applications,
and makes it easier to integrate those applications with each other
and into existing systems. For JMS messaging, you use JNDI to store
objects that represent the target destination of a message, or the
connection factory that creates the connection between your
application and its messaging destination.

Any application or process with access to the JNDI namespace can use the
same administered objects. The properties of the administered objects can
be changed in JNDI, with all the applications or processes able to benefit
from those same changes.

Initial context
An initial context defines the root of the JNDI namespace. To use
WebSphere MQ Explorer to create and configure administered
objects, you first add an initial context that defines the root of the
JNDI namespace. Similarly, a JMS application first obtains an initial
context, before it can retrieve administered objects from the JNDI
namespace.

Connection factory, myCF
A JMS connection factory object defines a set of standard
configuration properties for connections. An application uses a
connection factory to create a connection to WebSphere MQ.

Destination, myQueue
A JMS destination can be a topic or a queue. In this scenario, the
destination is a queue, and identifies the WebSphere MQ queue
that applications send messages to, or from which an application
receives messages, or both. An application looks up the destination
in the JNDI namespace to create a connection to the WebSphere
MQ queue.
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Tip: This scenario was developed by using a sample version of the initial IT
configuration described. If you want to try out the scenario, you can either follow
the instructions to configure WebSphere Application Server Liberty Profile to
communicate with your own WebSphere MQ, or set up a copy of the sample IT
configuration as described in “Creating a sample initial IT configuration” on page
14.

Overview: The delivered logical topology
The company adds a Java EE application on WebSphere Application Server Liberty
Profile to consume and work with messages from an existing messaging
infrastructure provided by WebSphere MQ.

The delivered IT configuration includes several components that an administrator
configures or uses, as shown in Figure 3 on page 11.

Figure 2. Initial IT configuration. The initial IT configuration includes an initial context, added for the WebSphere MQ
Explorer to connect to the root of the JNDI namespace. The JNDI namespace includes a connection factory, added for
the sample JMS application to use to connect to WebSphere MQ, and a destination, added for the sample JMS
application to connect to the WebSphere MQ queue. That WebSphere MQ queue has also been added into the initial
IT configuration for use by the sample JMS application.
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WebSphere MQ as a messaging provider for WebSphere Application Server Liberty
Profile

The WebSphere MQ messaging provider in WebSphere Application Server
Liberty Profile makes JMS messaging available to WebSphere Application
Server Liberty Profile by using the existing capabilities in the WebSphere
MQ environment.

Why am I doing this?
WebSphere Application Server Liberty Profile can interact with
WebSphere MQ destinations to send and receive messages in the
same way as any JMS application in the WebSphere MQ environment.

Java EE application
The application consumes and works with messages on the WebSphere
MQ queue, Q1. This application runs on a server of the WebSphere
Application Server Liberty Profile that has been created and connected
with WebSphere MQ.

The sample application in this scenario provides a message-driven bean
(MDB) as an asynchronous message consumer. When a message arrives at
the queue, the MDB automatically processes the message without the
application having to explicitly poll the queue.

Why am I doing this?
MDBs are activated by the EJB container in WebSphere Application
Server Liberty Profile on receipt of a message. A typical MDB
performs messaging functions, and calls one or more session beans to
perform business logic. Because of this separation of function, you
can easily change and reuse units of business logic without affecting
the messaging function of the application.

Server A program in WebSphere Application Server Liberty Profile that provides
the execution environment for Java EE application programs.

WebSphere Application Server Liberty Profile JNDI namespace
WebSphere Application Server Liberty Profile includes a name server
which provides access to the following JMS administered objects through
the Java Naming and Directory Interface (JNDI). The use of JNDI, the
connection factory, and the destination, are the same as described for the
initial IT configuration in “Overview: Initial IT configuration” on page 6.

Activation specification
A JMS activation specification can be associated with one or more
MDBs and provides the configuration necessary for them to listen
for messages arriving at a destination. Activation specifications
process inbound messages to the MDB.

Why am I doing this?
Activation specifications are part of the Java EE Connector
architecture (JCA) 1.5 standard. JCA 1.5 provides a standard
way to integrate JMS providers, such as WebSphere MQ, with
Java EE application servers such as WebSphere Application
Server Liberty Profile.
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Connection factory, myCF
A JMS connection factory object defines a set of standard
configuration properties for connections. An application uses a
connection factory to create a connection to WebSphere MQ.

If your application uses an MDB, as the sample application does,
the connection factory is used for outbound messages only;
inbound messages are received by the activation specification.

Destination, myQueue
A JMS destination can be a topic or a queue. In this scenario, the
destination is a queue, and identifies the WebSphere MQ queue
that applications send messages to, or from which an application
receives messages, or both. An application looks up the destination
in the JNDI namespace to create a connection to the WebSphere
MQ queue.

Figure 3. Delivered logical topology. The high-level logical topology diagram for new software functions delivered by
integrating WebSphere Application Server Liberty Profile into the initial WebSphere MQ messaging infrastructure. This
delivered logical topology shows the new functions as new or extended logical components, integrated with the
software functions and products from the initial logical topology.
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Production physical topology and product mapping
The production physical topology specifies the recommended operational
environment (machines, operating systems, and software products) for running the
applications and services of the solution.

Node Operating system and hardware Software

Host 1 (runtime node) v Windows Server 2008, Standard or
Enterprise Edition. You can use
Windows 7, or for 32-bit
environments, Windows Vista or
Windows XP Professional, but
these operating systems are not
supported for production use of
WebSphere Application Server
Liberty Profile.

v Intel EM64T, AMD Opteron, or for
32-bit environments, Intel Pentium
processor at 2.33 GHz or faster

v 1 GB physical memory

v 3 GB free disk space

v WebSphere MQ

v WebSphere Application Server
Liberty Profile

Prerequisite software:

v Java Runtime Environment
supported by WebSphere
Application Server Liberty Profile.
The minimum versions of Java is
listed here

Figure 4. Production physical topology
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Chapter 3. Implementing the solution

Implementing the solution in this scenario involves connecting WebSphere
Application Server Liberty profile to WebSphere MQ, which provided the initial
messaging infrastructure for a company.

Before you begin

The starting point for this scenario is an existing, verified, WebSphere MQ
installation as the initial messaging infrastructure.

If you want to try out the scenario, you can either follow the instructions to add
WebSphere Application Server Liberty profile to your own WebSphere MQ, or set
up a copy of the sample messaging infrastructure as described in “Creating a
sample initial IT configuration” on page 14.
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About this task

After connecting WebSphere Application Server Liberty profile to WebSphere MQ,
you can use the connection by deploying a Java EE application to run on
WebSphere Application Server Liberty profile. This scenario describes use of a
sample Java EE application that is deployed onto WebSphere Application Server
Liberty profile and used to verify the solution.

Creating a sample initial IT configuration
This scenario was developed by using a sample initial IT configuration. Follow the
instructions to set up the sample initial IT configuration to try out the scenario in
the same way as it was originally developed.

Installing WebSphere MQ
To complete this scenario, you must have a functioning WebSphere MQ messaging
network. This task provides basic instructions to install WebSphere MQ if you do
not already have it installed on your system.

Figure 5. Delivered logical topology, including WebSphere Application Server Liberty profile. The high-level logical
topology diagram for new software functions delivered by integrating WebSphere Application Server Liberty profile into
the initial WebSphere MQ messaging infrastructure. This delivered logical topology shows the new functions as new or
extended logical components, integrated with the software functions and products from the initial logical topology.
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Before you begin
v You must have local administrator authority when you are installing. Define this

authority through the Windows facilities.
v Ensure that the machine name does not contain any spaces.
v Ensure that you have sufficient disk space, up to 600 MB, to fully install

WebSphere MQ for Windows.
v Determine whether any WebSphere MQ users are defined on Windows 2000 or

later domain controllers.

Why am I doing this?
WebSphere MQ checks that only authorized users can access queue
managers or queues. When a user attempts such access, WebSphere MQ
uses its own local account to query information about the user. However,
domain controllers that run on Windows 2000 or later can be configured
such that WebSphere MQ cannot use local accounts to make these queries.
In this situation, you must provide WebSphere MQ with a special account
to use. This account is necessary when both of the following conditions
apply:
– Any domain controller on your network is running on Windows 2000 or

later
– Local user accounts are not authorized to query the group membership

of the domain user accounts

If you require a special account, refer your domain administrator to the
instructions in Creating and setting up domain accounts for WebSphere
MQ in the WebSphere MQ information center.

If you want to investigate the requirements for installing WebSphere MQ in more
detail, see System Requirements for IBM MQ.

About this task

This task describes the basic steps to install the WebSphere MQ 7.5.0.1 refresh pack
on the Windows 7 Professional (SP1) operating system. This refresh pack is a full
installation image that contains WebSphere MQ 7.5.0 and Fix Pack 1 combined.

The installation programs contain links to further information if you require it
during the installation process. The installation process has four parts:
1. Use the Launchpad to check and install software requirements, specify network

information, and start the WebSphere MQ installation wizard.
2. Use the WebSphere MQ installation wizard to install the software, and start the

Prepare WebSphere MQ wizard.
3. Use the Prepare MQ wizard to start the WebSphere MQ service and start the

Default Configuration wizard.
4. Optionally, use the Default Configuration wizard to create objects for verifying

the installation by using the Postcard application that is supplied with
WebSphere MQ.

Procedure
1. Click Setup.exe file in the root of the installation folder to start the installation

process.
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2. Use the buttons on the left of the Launchpad to review and, if necessary,
modify the software requirements and network configuration.

3. On the WebSphere MQ Installation page of the Launchpad, select the
installation language, and then click Launch IBM WebSphere MQ Installer to
start the WebSphere MQ installation wizard.

4. Click I accept the terms in the license agreement, and then click next.
5. Click Typical, and then click Next. Then, click Install. The following features

are installed:
v WebSphere MQ Server
v WebSphere MQ Explorer: a graphical interface for administering and

monitoring WebSphere MQ resources
v WebSphere MQ Development Toolkit
v Java and .NET Messaging and Web Services

At the end of the process, the WebSphere MQ Setup window displays the
message Installation Wizard Completed Successfully. Click Finish; the
Prepare WebSphere MQ wizard starts automatically.

6. Follow the instructions in the Prepare WebSphere MQ wizard.

Why am I doing this?
The Prepare WebSphere MQ wizard helps you to configure WebSphere
MQ files and a user account for your network. You must run the wizard
to configure the WebSphere MQ Service before you can start any queue
managers.

a. On the first page of the wizard, click Next. The wizard performs some
configuration and displays status messages, and then displays the
WebSphere MQ Network Configuration page. The contents of the page
varies according to your use of domain controllers.

b. Follow the instructions for network configuration then click Next to
continue through the wizard until the wizard displays the Completing the
Prepare WebSphere MQ Wizard page.

c. Select Launch WebSphere MQ Explorer and choose whether to start
Notepad to view the release notes, and then click Finish. WebSphere MQ
Explorer starts.

7. Optional: If you want to use the WebSphere MQ Postcard application to verify
your installation, create the default configuration.
a. If the Content page is not already displayed, click Window > Show View >

MQ Explorer - Content to display it.
b. Click Create the Default Configuration. The WebSphere MQ Default

Configuration window is opened.
c. Click Set up Default Configuration. The Default Configuration Wizard is

opened.
d. Click Next and Next again to move through the information pages.
e. On the Select Options page, clear both Allow remote administration of the

queue manager and Join the queue manager to the default cluster, and
then click Next.
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Why am I doing this?
This scenario assumes that you have one machine on which you are
installing WebSphere Application Server and WebSphere MQ. You
therefore do not need to administer the queue from another machine.
Clustering is not described in this scenario.

f. On the summary page, click Finish. The Default Configuration Wizard is
closed. In the WebSphere MQ Default Configuration window, the following
message is displayed: "Default configuration is partially complete."

g. Click Close.
8. If you created a default configuration, verify your installation by using the

Postcard application that is supplied with WebSphere MQ.
a. If the Content page is not already displayed, click Window > Show View >

MQ Explorer - Content to display it.
b. Click Launch Postcard to open the Postcard - Sign On window.
c. Click Help in this and other Postcard application windows to view

instructions about running the Postcard application.

Note: Running the Postcard application on a non-default configuration
automatically creates a queue that is called postcard on your queue manager.
You can delete this queue after you use the postcard application.

Results

WebSphere MQ is installed and you are ready to configure objects such as queues
and queue managers.

If there were problems during installation, use the .log files in the C:\Documents
and Settings\userID\Local Settings\Temp directory for Windows XP or
C:\Users\userID\AppData\Local\Temp for Windows Vista or later, and the
amqmsccw.txt and amqmjpse.txt files in the installation directory, to investigate.
The default installation directory is C:\Program Files\IBM\WebSphere for Windows
32-bit operating system or C:\Program Files (x86)\IBM\WebSphere for Windows
64-bit operating system.

What to do next

Follow the instructions in “Configuring the JNDI namespace and administered
objects” to configure WebSphere MQ for use by the sample application.
Related information:

Launchpad instructions

Configuring WebSphere MQ with the Prepare WebSphere MQ Wizard

Installing the WebSphere MQ Server

Configuring the JNDI namespace and administered objects
Define to WebSphere MQ an initial context for the JNDI namespace, then define in
the namespace the administered objects that the sample application can use.
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About this task

Before an application can retrieve administered objects from a JNDI namespace, an
administrator must first create the administered objects. The administrator can use
the WebSphere MQ JMS administration tool or WebSphere MQ Explorer to create
and maintain administered objects in a JNDI namespace.

This scenario demonstrates the following aspects:
v Use of a JNDI namespace that is in a local file system. A file system is used

because it is the simplest JNDI mechanism for a sample scenario.

What else might I do or be interested in?
The JNDI namespace can be on a file system, Lightweight Directory Access
Protocol (LDAP) server, or on another JNDI implementation. If you want to
use a JNDI namespace on an LDAP server or another JNDI
implementation, you must configure the JNDI namespace and modify the
sample application to reference the JNDI namespace, as required by the
implementation.

v Use of WebSphere MQ Explorer to create administered objects in the JNDI
namespace. The JMS application can look up the administered objects to connect
to WebSphere MQ and access MQ destinations with which to send or receive
messages.

In this task, you create the following objects in WebSphere MQ:
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Procedure
1. Start WebSphere MQ Explorer, if it is not already started, by clicking Start >

All Programs > IBM WebSphere MQ > WebSphere MQ Explorer.

Figure 6. Objects created in WebSphere MQ
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2. Create a queue manager to use for the sample application.
a. Right-click Queue Managers and click New > Queue Manager. The Create

Queue Manager wizard starts.
b. In the Queue manager name field type sampleQM.

What else might I do or be interested in?
You can choose a different name for the queue manager, but you must
remember to use it in later configuration steps, in place of sampleQM.

Note: The name must have no more 48 characters, from the following
set:
v Uppercase or lowercase A-Z
v Numerics 0-9
v Period (.)
v Forward slash (/)
v Underscore (_)
v Percent sign (%

Names are case-sensitive. Objects of the same type must have different
names. For example, two queues cannot have the same name, but a
queue manager and a queue can.

c. In the Dead-letter queue field type SYSTEM.DEAD.LETTER.QUEUE. This field is
the name of the dead-letter queue that is automatically created when you
create the queue manager.

Why am I doing this?
A dead-letter queue stores messages that cannot be delivered to their
correct destination, for example because the queue is full. All queue
managers must have an associated dead-letter queue.

d. Leave the other fields empty and click Finish, or if that button is disabled,
click Next. The Finish button is disabled if the port number conflicts with
an existing queue manager, for example the queue manager that is created
as part of the default configuration. You must continue through the wizard
to change the default port number.

e. If you clicked Next, continue to accept the defaults and click Next on each
page until you get to the final page of the wizard, when the Finish button
becomes available. Change the specified port number, for example to 1415,
and click Finish.

WebSphere MQ opens a window while the queue manager is created and
started.

3. Add an initial context for the JNDI namespace then connect WebSphere MQ
Explorer to that context

20 Connecting Liberty V8.5.5 to MQ V7.5



Why am I doing this?
Before you can use WebSphere MQ Explorer to create and configure JMS
administered objects, you must add an initial context to define the root of
the JNDI namespace in which the administered objects are
stored.Whenever you want to use WebSphere MQ Explorer to create or
manage administered objects in the JNDI namespace, you must connect
MQ Explorer to the initial context of the JNDI namespace.

a. In the MQ Explorer - Navigator pane, right-click JMS Administered
Objects, then click Add Initial Context. This action displays the
“Connection details” page.

b. Under “Where is the JNDI namespace located?”, click File system.
c. In the Bindings directory field, type C:\JNDI-Directory.

Why am I doing this?
This value matches the JNDI namespace location that is specified in
the sample JMS application. If you must specify a different JNDI
directory, you must modify the application to match.

If the directory does not exist on your system, the window displays the
message Specified location does not exist or is not readable. Click
Browse to open a file system window, navigate to Local Disk (C:), then
click Make New Folder to create the JNDI-Directory folder. Click OK.
Click Next.

d. On the User preferences page, leave the default settings.

Why am I doing this?

v Context nickname: The location of the JNDI namespace is used as
the nickname to display the initial context in WebSphere MQ
Explorer.

v Connect immediately on finish: This option connects WebSphere
MQ Explorer to the JNDI namespace when you finish creating the
initial context so that you can create administered objects
immediately.

v Automatically reconnect to context on startup: This option is not
selected because usually you do not need WebSphere MQ Explorer
to automatically reconnect to the initial context every time that you
close and reopen WebSphere MQ Explorer.
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What else might I do or be interested in?
If you routinely use WebSphere MQ Explorer to create or manage
administered objects in the JNDI namespace, you can select the
Automatically reconnect to context on startup check box to cause
WebSphere MQ Explorer to automatically reconnect to the initial
context whenever WebSphere MQ Explorer is started. This option
saves you having to manually connect WebSphere MQ Explorer to the
initial context.

Click Finish to create and display the initial context.
4. Create a connection factory administered object.

Why am I doing this?
A connection factory administered object defines a set of standard
configuration properties for connections. An application uses a connection
factory to create a connection to WebSphere MQ.

a. In the MQ Explorer - Navigator pane, expand JMS Administered Objects,
and then expand the initial context, labeled file:/C:/JNDI-Directory/.

b. Right-click Connection Factories, then select New > Connection Factory.
This action opens the New Connection Factory wizard

c. In the Name field, type myCF

Why am I doing this?
The sample JMS application contains code that looks up a connection
factory with the name myCF. If you must use a different name, you
must modify the application to match.WebSphere MQ is used for the
messaging provider because the sample application uses point-to-point
messaging

Click Next.
d. Leave the type of connection factory as Connection Factory because this

option is the most flexible for general JMS use.

Why am I doing this?
A domain-independent connection factory enables JMS applications to
use both point-to-point messaging and publish/subscribe messaging,
especially if you want the JMS application to perform both types of
messaging under the same transaction.

What else might I do or be interested in?
If a JMS application is intended to use only point-to-point messaging
or only publish/subscribe messaging, you can select the specific
messaging domain when you create the connection factory and a
domain-specific (queue or topic) connection factory is created.

e. Leave the support for XA transactions as cleared.
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Why am I doing this?
The sample application does not use XA-compliant transactions.

What else might I do or be interested in?
WebSphere MQ JMS supports XA-compliant transactions in bindings
mode. If you want the sample application to use XA-compliant
transactions, you must modify the sample application.

Click Next.
f. Leave the transport as Bindings.

Why am I doing this?
The sample JMS application that uses the connection factory runs on
the same computer as the queue manager, so can use Bindings mode
transport. This option means that the JMS application connects directly
to the queue manager, and offers a performance advantage over the
alternative client mode.

Click Next, then Next again.
g. On the Change properties page, select Connection from the menu on the

left, then in the Connection pane select sampleQM as the Base queue
manager.

Why am I doing this?
The base queue manager is the queue manager that the application
connects to. Leave this value blank if you want the application to be
able to connect to more than one queue manager.

h. Click Finish. WebSphere MQ opens a window to show that the object was
created successfully. Click OK to close the window.

5. Create a destination administered object.

Why am I doing this?
A destination administered object identifies the WebSphere MQ queue that
applications send messages to, or from which an application receives
messages, or both. An application looks up the destination in the JNDI
namespace to create a connection to the WebSphere MQ queue.

What else might I do or be interested in?
In publish/subscribe messaging, the destination identifies a topic rather
than a queue.

a. In the MQ Explorer - Navigator pane, expand JMS Administered Objects,
and then expand the initial context, labeled file:/C:/JNDI-Directory/.

b. Right-click Destinations, and then click New > Destination.... The New
Destination wizard is opened.
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c. In the Name field, type myQueue. Leave the Type as Queue.

Why am I doing this?
The sample JMS application contains code that looks up a destination
with the name myQueue. The sample JMS application uses
point-to-point messaging, so requires a destination of type queue.
Destinations of type topic are used for publish/subscribe messaging.

d. Select Start wizard to create a matching MQ Queue.

Why am I doing this?
The destination object needs a matching WebSphere MQ queue, and it
is convenient to use WebSphere MQ Explorer to create both together.
When you complete the New Destination wizard, the Create an MQ
Queue wizard opens, with many of the destination details mapped to
the WebSphere MQ queue.

Click Next.
Click Next again.

e. On the “Change properties” page, click Select next to Queue manager.
Select the sampleQM queue manager that you created earlier, and then
click OK.

f. Specify Q1 as the name of the WebSphere MQ queue.

What else might I do or be interested in?
You can choose a different name for the queue, but you must
remember to use it in later configuration steps, in place of Q1.

Note: The name must have no more 48 characters, from the following
set:
v Uppercase or lowercase A-Z
v Numerics 0-9
v Period (.)
v Forward slash (/)
v Underscore (_)
v Percent sign (%

Names are case-sensitive. Objects of the same type must have different
names. For example, two queues cannot have the same name, but a
queue manager and a queue can.

g. Click Finish. A window is opened, which indicates the object is created
successfully. Click OK. The Create an MQ Queue wizard starts.
If the wizard does not start, you might not have selected the Start wizard to
create a matching MQ Queue check box in an earlier step. In the MQ
Explorer - Navigator pane, expand the sampleQM queue manager,
right-click Queues, then select New > Local Queue.

6. Create the WebSphere MQ Queue Q1.
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Why am I doing this?
The destination administered object that is created earlier represents a
WebSphere MQ queue. This queue is where the JMS messages are stored.

a. Click Next to accept the sampleQM queue manager that you specified
earlier.

b. Click Next.
c. Click Finish to create the WebSphere MQ Queue by using the information

from the destination administered object that you created earlier. WebSphere
MQ Explorer opens a window with the message that the object was created
successfully.

d. Click OK.

The new queue Q1 is now visible in the Queues section under the queue
manager.

Results

You have now created the WebSphere MQ objects that are required to use the
sample JMS application.

What to do next

Follow the steps in “Running the sample JMS application” to verify your
configuration.
Related information:

JMS connection factories

Creating a destination

Running the sample JMS application
Run the sample stand-alone JMS application to send and receive messages through
WebSphere MQ, and verify that you configured WebSphere MQ correctly for use
with the sample application.

Before you begin

Download the sample application package. Click the following link and save the
file to your computer: sampleJMSApp.zipsampleJMSApp.zip (in online information
center), then extract the contents. The package contains a sample JMS application
.jar file and batch files for running the application.
v The sample sampleJMSApp.jar file and the .cmd files must be in the same

directory.
v The .cmd files use environment variables to set the class path for running the

JMS application. When running the JMS application, if you see a Java
java.lang.NoClassDefFoundError, you might need to adjust the class path line in
the command file.
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About this task

The JMS application comprises a requester client, which sends the initial message,
and a responder client, which receives the message and sends a reply. The
supplied batch files perform the following actions:
v runresponder.cmd opens a command prompt window in which the responder

client starts then waits for a message.
v runrequester.cmd opens a separate command prompt window in which the

requester client starts then sends a request message and receives a reply.

With two command prompt windows, you can see the actions of the requester and
responder separately and more clearly.

Procedure
1. Double-click the runresponder.cmd file. In the command prompt window,

labeled Responder window, the responder client starts then waits for a
message.

> Connection factory located in JNDI.
> Destination located in JNDI.
> Creating connection to QueueManager.
> Created connection.

> Waiting for message.

2. Double-click the runrequester.cmd file. In the Requester window, observe the
requester messages. In the Responder window, observe the updated responder
messages; the message it received (from the requester client) and the reply
message that it sent.

Results

In the command prompt window, labeled Requester window, the requester client
shows the connection status, the message it sent, then the reply message that it
received from the responder client:

> Connection factory located in JNDI.
> Destination located in JNDI.
> Creating connection to QueueManager.
> Connection created.

> Sending stock request for ’BakedBeans’
> Sent Message ID=ID:414d5120514d5f4c33344c3238482020c3cd094d20002b02

> Received Message ID=ID:414d5120514d5f4c33344c3238482020c3cd094d20002902 for ’B
akedBeans - 15 tins in stock’

> Closing connection to QueueManager.
> Closed Connection.
--------------------------------------------------------
In this window, observe the messages sent through WebSphere MQ:
- The request message sent
- The reply message received
-----
When ready, press any key to close this window
Press any key to continue . . .

In the Responder window, observe the updated responder messages; the message
it received (from the requester client) and the reply message that it sent:

> Connection factory located in JNDI.
> Destination located in JNDI.
> Creating connection to QueueManager.
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> Created connection.

> Waiting for message.

> Received Message ID=ID:414d5120514d5f4c33344c3238482020c3cd094d20002b02 for ’B
akedBeans’

> Sending Reply Message ’BakedBeans - 15 tins in stock’
> Sent Message ID=ID:414d5120514d5f4c33344c3238482020c3cd094d20002902

> Closing connection to QueueManager.
> Closed connection.
--------------------------------------------------------
In this window, observe the updated responder messages
- The request message received (from the requester)
- The reply message sent
-----
When ready, press any key to close this window
Press any key to continue . . .

The messages that are shown in the two command windows verify that the
requester and responder clients of the sample application can communicate with
each other through WebSphere MQ.

What to do next

Follow the instructions in “Obtaining the WebSphere MQ Resource adapter” to
download the WebSphere MQ resource adapter.

Obtaining the WebSphere MQ Resource adapter
To connect to WebSphere MQ from the Liberty profile, the WebSphere MQ
Resource adapter must be used. The Liberty profile does not contain the
WebSphere MQ Resource adapter. It must be obtained separately.

About this task

To connect to WebSphere MQ from the Liberty Profile, the WebSphere MQ
Resource adapter must be used. The Liberty profile does not contain the
WebSphere MQ Resource adapter. It must be obtained separately.

Procedure
1. To download the WebSphere MQ Resource adapter, see Obtaining the

WebSphere MQ Resource Adapter for WebSphere Application Server Liberty
Profile. The file download has a file name in the format V.R.M.F-WS-MQ-Java-
InstallRA.jar

2. Install the WebSphere MQ Resource adapter.
a. In a command prompt, navigate to the folder where WebSphere MQ

Resource adapter is located, and then enter the command: java -jar
7.5.0.1-WS-MQ-Java-InstallRA.jar The following message is displayed:

LICENSE INFORMATION

The Programs listed below are licensed under the following terms and conditions in addition to those of
the IBM International License Agreement for Evaluation of Programs (IBM form number Z125-5543-05).

Program Name: IBM WebSphere MQ V7.5 - 06/2013
Before you can use, extract, or install IBM WebSphere MQ V7.5 -
06/2013, you must accept the terms of IMPORTANT: READ CAREFULLY and
additional license information. Please read the following license
agreements carefully.
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The license agreement is separately viewable using the
--viewLicenseAgreement option.

Press Enter to display the license terms now, or ’x’ to skip.

b. Press Enter to display the license terms. This message is displayed:
By choosing the "I Agree" option below, you agree to the terms of the

license agreement and non-IBM terms, if applicable. If you do not
agree, select "I do not Agree".

Select [1] I Agree, or [2] I do not Agree:

c. Press 1 to agree to the license agreement. The following message is
displayed:

Enter directory for product files or leave blank to accept the default value.
The default target directory is H:\Liberty\WMQ

Target directory for product files?

d. Enter the directory to install the files to, or press Enter without entering any
value to install the default location as displayed. After the files are installed
to the requested location, a confirmation message is displayed:

Extracting files to H:\Liberty\WMQ\wmq
Successfully extracted all product files.

Results

Within the selected directory, a new directory that is called wmq is created. Within
this directory, the following files are installed:

jboss-jmsra-ds.xml
WAS_CE_jmsra_deployment_plan.xml
WAS_CE_jmsra_ivt_deployment_plan.xml
wmq.jmsra.ivt.ear
wmq.jmsra.rar

What to do next

Follow the instructions in either “Option 1: Installing and configuring the Liberty
profile by using the command line” or “Option 2: Installing and configuring the
Liberty profile by using the Graphic User Interface” on page 36 to install and
configure WebSphere Application Server Liberty profile.

Option 1: Installing and configuring the Liberty profile by using the
command line

In Option 1, you install the Liberty profile by extracting the distribution image.
You then configure the server by editing the server configuration file in a text
editor.

Before you begin

This option assumes that you have finished your configuration of WebSphere MQ
and you have got the WebSphere MQ Resource Adapter. Make sure that you have
finished the following tasks:
v Create an initial IT configuration by “Creating a sample initial IT configuration”

on page 14

28 Connecting Liberty V8.5.5 to MQ V7.5



v Obtain the WebSphere MQ Resource Adapter by “Obtaining the WebSphere MQ
Resource adapter” on page 27

Installing WebSphere Application Server Liberty profile
Install WebSphere Application Server Liberty profile by extracting the distribution
image. At the end of this task, you are ready to configure WebSphere Application
Server Liberty profile to communicate with WebSphere MQ.

Before you begin

Ensure that your system meets the operating system and Java requirements for
using the Liberty profile. See http://www.ibm.com/support/docview.wss?rs=180
&uid=swg27028175.

About this task

Install WebSphere Application Server by extracting the archive file. The
distribution image is packaged as a self-extracting archive file. Running the
self-extracting archive file installs the Liberty profile so that you are then ready to
create a server.

Procedure
1. Obtain a copy of the archive file:

a. For the no-charge developer edition (with no IBM support), you can
download the archive file from the WASdev community download page.
Download both the WebSphere Application Server Liberty profile and the
extended content for the Liberty profile.

b. For all other editions, you can use the archive file that is included with each
edition of WebSphere Application Server version 8.5.5. For detailed
installation instructions, see Installing Liberty in the WebSphere Application
Server product documentation.

c. You can also download an edition-specific Liberty profile archive file,
including the developer edition with IBM support, from Passport
Advantage online.

2. Use the interactive installation wizard to extract the distribution image to your
preferred directory. Open a command prompt and navigate to location of the
distribution image, and then run java -jar filename.jar, where the filename is
the file name of the distribution image you get from last step. The file name of
the image is in the form of wlp-edition-runtime-version.jar

What else might I do or be interested in?
To extract the distribution image by accepting the license terms and
conditions silently, run java -jar filename.jar --acceptLicense.To view
all available options, run java -jar filename.jar --help.

3. Optional: Set the JAVA_HOME property for your environment. You can use the
following command to set the JAVA_HOME property, and to add the Java /bin
directory to the path:

set JAVA_HOME=C:\Progra~1\Java\JDK16
set PATH=%JAVA_HOME%\bin;%PATH%

The Liberty profile runtime environment searches for the java command in this
order; JAVA_HOME property, JRE_HOME property, and system PATH property.
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What to do next

Follow the instructions in “Creating a Liberty profile server” to create a Liberty
profile server to communicate with WebSphere MQ.

Creating a Liberty profile server
Create a Liberty profile server in the command prompt.

Procedure
1. Open a command prompt and navigate to the wlp\bin in the directory where

the distribution image was extracted.
2. Create a server that is called SCENARIO. In the command prompt, type server

create SCENARIO.

Results

The server is created.

What to do next

Configure your server to connect to the WebSphere MQ messaging provider. See
“Configuring WebSphere Application Server Liberty profile”

Configuring WebSphere Application Server Liberty profile
Configure the Liberty server to communicate with WebSphere MQ.

Before you begin
v You must have the WebSphere MQ Resource adapter. If not, follow the

instruction in “Obtaining the WebSphere MQ Resource adapter” on page 27.
v You must already have a Liberty profile server on which to deploy a messaging

application that uses JMS. If not, follow the instructions in “Creating a Liberty
profile server.”

About this task

To configure the server, edit the wlp\usr\servers\SCENARIO\server.xml file in a
text editor. Alternatively, you can download the sample server.xml to the
wlp\usr\servers\SCENARIO directory. Click the following link and save the file:
server.xml server.xml (in online information center). You must edit the location of
the WebSphere MQ Resource adapter and the WebSphere MQ native libraries.

Procedure
1. Add the features to the feature manager in the server.xml file. In the

server.xml file, add the following features into the feature manager section.
<featureManager>

<feature>jsp-2.2</feature>
<feature>wmqJmsClient-1.1</feature>
<feature>jndi-1.0</feature>
<feature>osgiconsole-1.0</feature>
<feature>servlet-3.0</feature>
<feature>jmsMdb-3.1</feature>

</featureManager>
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Why am I doing this?
Adding the wmqJmsClient-1.1 feature enables the Liberty server to load
the necessary WebSphere MQ bundles that enable you to define the
WebSphere MQ JMS resources. For example, the connection factory and
activation specification properties provide client libraries to connect to the
WebSphere MQ network.

2. Specify the location of the WebSphere MQ Resource adapter. Add the following
entry to the server.xml file:

<variable name="wmqJmsClient.rar.location" value="/path to wmq rar/wmq.jmsra.rar"/>

Where the value attribute specifies the absolute path to the WebSphere MQ
Resource adapter file that was downloaded, wmq.jmsra.rar.

3. Add the connection factory definitions to the server.xml file. In the server.xml
file, add the following entry:

<jmsQueueConnectionFactory jndiName="jms/replyCF" connectionManagerRef="ConMgr6">
<properties.wmqJms

hostName="localhost"
port="1414"
channel="SYSTEM.DEF.SVRCONN"

/>
</jmsQueueConnectionFactory>
<connectionManager id="ConMgr6" maxPoolSize="2"/>

Note: If you are using another port rather than 1414 for your queue manager
sampleQM, use the port number that is used. This port number is displayed in
WebSphere MQ Explorer under Queue managers > sampleQM > Advanced >
Listeners.

Why am I doing this?

v The value of jndiName is used in the sample MDB application code; if
you want to use a different JNDI name you must change the MDB to
match, then redeploy the application.

v The channel is the name of the WebSphere MQ channel to use for
communication. If you do not have a specific channel that you want to
use, specify the default channel that is created when you created the
queue manager, SYSTEM.DEF.SVRCONN.

4. Create a queue.
<jmsQueue id="MDBQ2">

<properties.wmqJms baseQueueName="Q1"/>
</jmsQueue>

Why am I doing this?
The baseQueueName is the name of queue that is used by the destination
myQueue.

5. Create an activation specification.
<jmsActivationSpec id="sampleMDB/pishopExampleReplyMDB/PiShopReplyMDB">

<properties.wmqJms
destinationRef="MDBQ2"
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destinationType="javax.jms.Queue"
port="1414"

/>
</jmsActivationSpec>

Note: If you are using another port rather than 1414 for your queue manager
sampleQM, use the port number that you use. This port number is displayed in
WebSphere MQ Explorer under Queue managers > sampleQM > Advanced >
Listeners, in the Port column in the LISTENER.TCP row.

Why am I doing this?

v The id is the path of executable file in sampleMDB.
v The value of destinationRef must be the same as the value of id of

jmsQueue you created.
v The JMS objects that are created in the Liberty server are separate from

the JMS objects that are created in WebSphere MQ.

6. Configure JMS applications to connect in the BINDING mode.
To allow the JMS applications to connect by using the shared memories or in
BINDING mode to WebSphere MQ, you must have both the Liberty profile and
WebSphere MQ deployed on the same server. To allow JMS applications to
connect in BINDING mode, use the <nativeLibraryPath> element in the
server.xml file to specify the location of the WebSphere MQ native libraries.

<wmqJmsClient nativeLibraryPath="C:\Program Files\IBM\WebSphere MQ\java\lib"/>

If you are using Windows 64-bit operating system, the default location of
WebSphere MQ native library is C:\Program Files (x86)\IBM\WebSphere
MQ\java\lib.

What to do next

Follow the instructions in “Deploying the sample application to the Liberty
profile” to deploy the sample MDB application.

Deploying the sample application to the Liberty profile
Deploy the sample message driven bean (MDB) application to verify that
WebSphere Application Server Liberty profile is communicating with WebSphere
MQ.

Before you begin

Download the sample application. Click the following link and save the file to the
computer that hosts WebSphere Application Server Liberty profile:
sampleMDB.earsampleMDB.ear (in online information center).

About this task

The sample MDB application, sampleMDB.ear, is designed to use the objects that
you created earlier in WebSphere Application Server Liberty profile. The MDB
application uses these objects to send a message to WebSphere MQ, for receipt by
the sample JMS application requester client that you used in “Running the sample
JMS application” on page 25.
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The following diagram shows a message traveling from the sample JMS client to
WebSphere MQ, and then on to WebSphere Application Server Liberty profile,
where it is passed to the MDB running within WebSphere Application Server
Liberty profile. A response message travels from the MDB to WebSphere MQ, and
then on to the JMS client.

Procedure
1. Add the downloaded sampleMDB.ear file to ${server.config.dir}\apps folder.

The default location for ${server.config.dir} is wlp\usr\servers\SCENARIO.
2. Add the configuration of the sampleMDB.ear file to the server.xml. Add the

following statement to the server.xml file.
<application type="ear" id="PiShopReplyMDB" name="PiShopReplyMDB" location="sampleMDB.ear" />

3. Save the server.xml file.

Results

The MDB application is deployed to the Liberty profile.

What to do next

Follow the instructions in “Verifying the solution” to run the sample applications
and verify that the message is passed between the two products.

Verifying the solution
Run the sample JMS and message drive bean (MDB) applications to verify that
WebSphere MQ and the application can communicate with each other.

Before you begin

You must have configured WebSphere Application Server Liberty profile and
WebSphere MQ as described in “Configuring WebSphere Application Server
Liberty profile” on page 30 and “Configuring the JNDI namespace and
administered objects” on page 17.

Figure 7. A message traveling from the sample JMS client to WebSphere MQ, then onward to the MDB on WebSphere
Application Server Liberty Profile
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About this task

In “Running the sample JMS application” on page 25, you ran the supplied JMS
sample application to verify that the requester and responder clients of the
application could communicate through WebSphere MQ. In “Deploying the sample
application to the Liberty profile” on page 32, you installed an MDB application. In
this task, you run the requester application as before, but the reply comes from the
MDB application instead of the previous responder application, verifying that
messages are being passed between WebSphere MQ and WebSphere Application
Server Liberty profile.

Figure 8.
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Procedure
1. If WebSphere Application Server Liberty profile is not already started, open a

command prompt window, and navigate to wlp\bin, and then input the
command server start servername.

2. Check the log file in wlp\usr\servers\SCENARIO\logs\messages.log for details.
If the following error message is displayed, open WebSphere MQ Explorer and
expand IBM WebSphere MQ > Queue Managers, then right click sampleQM,
and then click Properties > Communication. Select Disabled in Channel
authentication records list.

JMSCMQ0001: WebSphere MQ call failed with compcode ’2’ (’MQCC_FAILED’) reason ’2035’ (’MQRC_NOT_AUTHORIZED’).

If exceptions are shown or the following error message is displayed in the log
file:

The message endpoint for the PiShopReplyMDB message-driven bean cannot be activated because the
sampleMDB/pishopExampleReplyMDB/PiShopReplyMDB activation specification is not available.

In this case, try the following things:
v Check the parameter names in your server.xml with the sample

configuration file the sample configuration file (in online information center).
v Check the attribute values in your server.xml to make sure they meet the

requirements described in “Configuring WebSphere Application Server
Liberty profile” on page 30.

3. Double-click the runrequester.cmd batch file in the sample package. This
command file opens a Command Prompt window then runs the sample JMS
requester client, which sends a message to WebSphere MQ. The
runrequester.cmd file uses environment variables to set the class path for
running the JMS application. If you see a Java
java.lang.NoClassDefFoundError, you might need to adjust the class path line
in the command file.

Results

The sample requester application sends the same request message as before, but
the response now comes from the MDB application. The following output, showing
sent and received messages, is displayed in the requester application Command
Prompt window:

> Connection factory located in JNDI.
> Destination located in JNDI.
> Creating connection to QueueManager.
> Connection created.

> Sending stock request for ’BakedBeans’
> Sent Message ID=ID:414d512073616d706c65514d202020206beeb6512001ad02

> Received Message ID=ID:414d512073616d706c65514d202020206beeb6512001bb02 for ’From MDB: BakedBeans -
15 tins in stock. Expected delivery time 1 day’

> Closing connection to QueueManager.
> Closed Connection.
--------------------------------------------------------
In this window, observe the messages sent through WebSphere MQ:
- The request message sent
- The reply message received
-----
When ready, press any key to close this window
Press any key to continue . . .
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You have finished implementing the solution, and verified that WebSphere
Application Server Liberty profile can connect to WebSphere MQ for the successful
transmission of messages.

Option 2: Installing and configuring the Liberty profile by using the
Graphic User Interface

In Option 2, install WebSphere Application Server Liberty profile by using the
Installation Manager. Then configure the server by using the Liberty profile
developer tools.

Before you begin

You must have completed the configuration of WebSphere MQ. For instruction on
how to do this, see “Creating a sample initial IT configuration” on page 14. You
must have downloaded the WebSphere MQ Resource adapter. For instructions on
how to do this, see “Obtaining the WebSphere MQ Resource adapter” on page 27.

Installing WebSphere Application Server Liberty profile
Install WebSphere Application Server Liberty profile by using the IBM Installation
Manager.

Before you begin

Your system must meet the operating system and Java requirements for using the
Liberty profile. See http://www.ibm.com/support/docview.wss?rs=180
&uid=swg27028175.

About this task

Install the IBM Installation Manager. Then install the WebSphere Application
Server Liberty profile by using the IBM Installation Manager.

Procedure
1. If IBM Installation Manager is not already installed, install it.

a. Extract the Installation Manager archive file.
b. Switch to Installation Manager archive directory and double-click the

install.exe file.
c. In the Install Packages window, select the version number, for example

Version 1.5.2, and then click Next.
d. Click I accept the terms in the license agreement, and then click Next.

e. In Installation Manager Directory field, type the file path. The file path is
the location where you want to install IBM Installation Manager.

f. Click Next, and then click Install. A progress bar is displayed, which
shows that the installation is in progress.

When the installation is complete, a window is displayed, indicating that IBM
Installation Manager is installed.

2. Click Restart Installation Manager in the lower right of the window.
Alternatively, you can click Start > All Programs > IBM Installation Manager
> IBM Installation Manager to start Installation Manager.

3. In the “IBM Installation Manager” window, click File > Preference, and then
click Add Repository. In the “Add Repository” window, browse to the
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repository.config file of your WebSphere Application Server Liberty profile
repository folder. Then, click OK to confirm adding the repository.

4. In the Preference window, click Test Connections. If successful, the following
message is displayed:

All the selected repositories are connected.

5. Click OK to close the Preference window.
6. In the “IBM Installation Manager” window, click Install.
7. Select the version number of WebSphere Application Server Liberty profile, to

complete this scenario, you must use Version 8.5.5.0 or later, and then click
Next.

8. Click I accept the terms in the license agreement, and then click Next.
9. Specify the installation root directory for the product binary files. If you use

Windows 64-bit operating system, choose whether you use the 32-bit or 64-bit
architecture. Then, click Next.

10. Select both Embeddable EJB Container and JPA Client and Extended
Programming Models, and then click Next.

11. Review the summary information, and click Install.
a. If the installation is successful, the program displays a message, which

indicates that installation is successful.

Note: The program might also display important post-installation
instructions as well.

b. If the installation is not successful, click View Log File to troubleshoot the
problem.

12. Click Finish.
13. Click File > Exit to close Installation Manager.

Results

WebSphere Application Server Liberty profile is installed.

What to do next

Follow the instructions in “Installing IBM WebSphere Application Server Developer
Tools” to install the developer tools.

Installing IBM WebSphere Application Server Developer Tools
Install IBM WebSphere Application Server Developer Tools for Eclipse into an
existing Eclipse workbench.

Before you begin
v Install Eclipse 4.2.2 for Java EE Developers.
v If you have an earlier version of IBM WebSphere Application Server Developer

Tools for Eclipse that is installed on your computer, you must uninstall it before
you start this task.

v You must be connected to the internet.

Procedure
1. Start your Eclipse IDE for Java EE Developers workbench.
2. Locate the installation files from your Eclipse workbench.

a. Click Help > Eclipse Marketplace.
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b. In the Find field, type Liberty Profile.
c. In the list of results, locate the IBM WebSphere Application Server V8.5.5

Liberty Profile Developer Tools Beta, and then click Install. If the
Uninstall button is displayed rather than the Install button, you have other
version of WebSphere Application Server Developer Tools installed. In that
case, click Uninstall to uninstall the other version, and then repeat Step 2.

What else might I do or be interested in?
Alternatively, you can install from WASdev website:
a. Open your web browser to https://ibmdw.net/wasdev/downloads/,

and click Download under WebSphere Application Server Developer
Tools for Eclipse.

b. Drag the Install icon onto the Eclipse toolbar.

3. On the Confirm Selected Features page, expand the parent nodes and select
the features that you want to install. When you are finished, click Next.

4. On the “Review Licenses” page, click I accept the terms of the license
agreement, and then click Finish. The installation process starts.

Note: During the installation, a Security Warning dialog box might open and
display the following message:

Warning: You are installing software that contains unsigned content. The authenticity or validity of this
software cannot be established. Do you want to continue with the installation?

You can safely ignore the message and click OK to continue.
5. When the installation process is completed, restart the workbench.

Results

The IBM WebSphere Application Server Developer Tools are installed. You are
ready to use the tools to create and configure a server on the liberty profile.

What to do next

Follow the instructions in “Creating a Liberty profile server” to create a Liberty
profile server to communicate with WebSphere MQ.

Creating a Liberty profile server
Create a Liberty profile by using the WebSphere Application Server Developer
tools.

Procedure
1. Start your Eclipse IDE for Java EE Developers workbench.
2. In the Java EE view, click the Servers tab.
3. Right-click in the Servers field, and then click New > Server. The Define a

New Server window is displayed.
4. Select WebSphere Application Server V8.5 Liberty Profile from the server list,

and then click Next.
5. In the “Liberty Profile Runtime Environment” window, browse to the root of

your Liberty profile installation folder. By default, the installation folder is
C:\Program Files\IBM\WebSphere\Liberty.
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6. If the JRE you want to use is not listed in the window, click Configure JREs
and follow the instructions to configure it. Then, click Next.

7. In the “New Liberty Profile Server” window, enter a server name in the Server
name field. For example, SCENARIO. Then, click Finish. The name of the server
that you just created is displayed in the Servers field.

Results

A server is created in the Liberty profile.

What to do next

Configure your server to connect to the WebSphere MQ messaging provider. See
“Configuring WebSphere Application Server Liberty profile”

Configuring WebSphere Application Server Liberty profile
Through the WebSphere MQ messaging provider in the Liberty profile, Java
Message Service (JMS) messaging applications can use your WebSphere MQ
system as an external provider of JMS messaging resources.

Before you begin
v You must have downloaded the WebSphere MQ Resource Adapter. If not, follow

“Obtaining the WebSphere MQ Resource adapter” on page 27 to get it.
v You must already have created a Liberty profile server on which to deploy a

messaging application that uses JMS. If not, follow “Creating a Liberty profile
server” on page 38 to create one.

About this task

You configure the server by using the developer tools for Eclipse.

Procedure
1. Start your Eclipse IDE for Java EE Developers workbench.
2. Click the Servers tab, and then expand the server that you just created. Then,

double-click Server Configuration. The server.xml file is displayed in the
main window.

3. Click Design tab to switch to the design view.
4. Add features to the server configuration.

a. In the main window, expand Server Configuration, and then click Feature
Manager.

b. Click Add in the right of the main window.
c. Add the wmqJmsClient-1.1 feature. Enter wmqJmsClient-1.1 in the “Select

the features to enable” window, and then click OK.
d. Using the same method to add jndi-1.0, osgiconsole-1.0, servlet-3.0,

and jmsMdb-3.1.
5. Specify the location of the WebSphere MQ Resource Adapter.

a. Click Server Configuration in the main window, and then click Add.
b. Enter Variable Declaration, and then click OK.
c. In the Name field, enter wmqJmsClient.rar.location; in the Value filed,

enter the full path of your wmq.jmsra.rar file that is obtained in
“Obtaining the WebSphere MQ Resource adapter” on page 27.
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6. Add the connection factory definitions.
a. Click Server Configuration in the main window, and then click Add.
b. Enter JMS Queue Connection Factory, and then click OK.
c. In the JNDI name field, enter jms/replyCF.
d. Click New next to Connection manager reference.
e. Click JMS Queue Connection Factory again, and click Add.
f. Enter WebSphere MQ JMS Queue Connection Factory, and then click OK.
g. Enter the following information:

Channel
The name of the WebSphere MQ channel to use for
communication.

If you do not have a specific channel that you want to use, specify
the default channel that is created when you created the queue
manager, SYSTEM.DEF.SVRCONN.

Tip: To display the default channel in WebSphere MQ Explorer,
click the Show System Objects icon at the upper right of the MQ
Explorer - Content pane.

Host name
The name of your machine.

Port The port number of the WebSphere MQ queue manager
sampleQM.

This port number is displayed in WebSphere MQ Explorer under
Queue managers > sampleQM > Advanced > Listeners, in the
Port column in the LISTENER.TCP row.

7. Create a queue.
a. Click Server Configuration in the main window, and then click Add.
b. Enter JMS Queue, and then click OK.
c. In the Id field, enter MDBQ2; in the JNDI name field, enter MDBQ.
d. Click JMS Queue, and then click Add.
e. Enter WebSphere MQ JMS Queue, and then click OK.
f. In the Base queue name field, enter Q1.

8. Create an activation specification.
a. Click Server Configuration in the main window, and then click Add.
b. Enter JMS Activation Specification, and then click OK.
c. In the Id field, enter sampleMDB/pishopExampleReplyMDB/PiShopReplyMDB.
d. Click JMS Activation Specification, and then click Add.
e. Enter WebSphere MQ JMS Activation Specification, and then click OK.
f. Enter the following information:

Destination
MDBQ2

Port The port number of the WebSphere MQ queue manager
sampleQM.

This port number is displayed in WebSphere MQ Explorer under
Queue managers > sampleQM > Advanced > Listeners, in the
Port column in the LISTENER.TCP row.
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9. Configure JMS applications to connect in the BINDING mode.
a. Click Server Configuration in the main window, and then click Add.
b. Enter WebSphere MQ Messaging, and then click OK.
c. In the Native library path field, enter the location of the WebSphere MQ

native libraries. If you are using 32-bit operating system, the default path
is C:\Program Files\IBM\WebSphere MQ\java\lib; if you are using 64-bit
operating system, the default path is C:\Program Files
(x86)\IBM\WebSphere MQ\java\lib.

10. Click File > Save to save the configurations.

What to do next

Follow the instructions in “Deploying the sample application to the Liberty
profile” to deploy the sample MDB application.

Deploying the sample application to the Liberty profile
After you deploy the sample message driven bean (MDB) application, you can use
it to verify that WebSphere Application Server Liberty profile is communicating
with WebSphere MQ.

Before you begin

Download the sample application. Click the following link and save the file to the
machine that hosts WebSphere Application Server: sampleMDB.earsampleMDB.ear
(in online information center).

About this task

The sample MDB application, sampleMDB.ear, is designed to use the objects that
you created earlier in WebSphere Application Server Liberty profile. The MDB
application uses these objects to send a message to WebSphere MQ, for receipt by
the sample JMS application requester client that you used in “Running the sample
JMS application” on page 25.

The following diagram shows a message traveling from the sample JMS client to
WebSphere MQ, and then on to WebSphere Application Server Liberty profile,
where it is passed to the MDB running within WebSphere Application Server
Liberty profile. A response message travels from the MDB to WebSphere MQ, and
then on to the JMS client.
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Procedure
1. Copy the sampleMDB.ear file to ${server.config.dir}\apps folder. The default

location for ${server.config.dir} is C:\Program Files\IBM\WebSphere\
Liberty\usr\servers\SCENARIO.

2. Add the configuration of the sampleMDB.ear file to the server.xml.
a. Click Server Configuration in the main window, and then click Add.
b. Enter Application, and then click OK.
c. In the Id field, enter PiShopReplyMDB.
d. Click Browse next to Location field.
e. Click Relative Path in the left panel and sampleMDB.ear on the right

panel. Then, click OK.
f. Select Automatically start.

3. Click File > Save to save the configurations.

Results

The MDB application is deployed to the Liberty profile.

What to do next

Follow the instructions in “Verifying the solution” to run the sample applications
and verify that messages can be passed between the two products.

Verifying the solution
Run the sample JMS and message drive bean (MDB) applications to verify that
they can communicate with each other.

Before you begin

You must have configured WebSphere Application Server Liberty profile and
WebSphere MQ as described in “Configuring WebSphere Application Server
Liberty profile” on page 39 and “Configuring the JNDI namespace and
administered objects” on page 17

Figure 9. A message traveling from the sample JMS client to WebSphere MQ, then onward to the MDB on WebSphere
Application Server Liberty Profile
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About this task

In “Running the sample JMS application” on page 25, you ran the supplied JMS
sample application to verify that the requester and responder clients of the
application could communicate through WebSphere MQ. In “Deploying the sample
application to the Liberty profile” on page 41, you installed an MDB application. In
this task, you run the requester application as before, but the reply comes from the
MDB application instead of the previous responder application, verifying that
messages are being passed between WebSphere MQ and WebSphere Application
Server Liberty profile.

Procedure
1. Start your Eclipse IDE for Java EE Developers workbench.

Figure 10.
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2. Start the server. Click the Servers tab, and then right click the server name, and
then click start. The following message is displayed in the console:

Launching SCENARIO (WebSphere Application Server 8.5.5.0/wlp-1.0.3.20130510-0831) on IBM J9 VM, version
pwa6460sr13ifx-20130303_02 (SR13) (en_GB)

[AUDIT ] CWWKE0001I: The server SCENARIO has been launched.
[AUDIT ] CWWKZ0058I: Monitoring dropins for applications.
[AUDIT ] CWWKZ0001I: Application sampleMDB started in 0.383 seconds.
[AUDIT ] CWWKF0011I: The server SCENARIO is ready to run a smarter planet.

If the following message is displayed, click HTTP Endpoint and change the
value of Port and Secure port, and then start the server again until the message
is no longer displayed.

Several ports (9080,9443) required by WebSphere Application Server V8.5 Liberty Profile at localhost are
already in use. The server might be running in another process, or a system process might be using the port.
To start this server you will need to stop the other process or change the port numbers.

If the following error message is displayed in the console, open WebSphere MQ
Explorer and expand IBM WebSphere MQ > Queue Managers, then right click
sampleQM, and then click Properties > Communication. Select Disabled in
Channel authentication records list.

JMSCMQ0001: WebSphere MQ call failed with compcode ’2’ (’MQCC_FAILED’) reason ’2035’ (’MQRC_NOT_AUTHORIZED’).

3. Double-click the runrequester.cmd batch file in the sample package. This
command file opens a Command Prompt window then runs the sample JMS
requester client, which sends a message to WebSphere MQ. The
runrequester.cmd file uses environment variables to set the class path for
running the JMS application. If you see a Java
java.lang.NoClassDefFoundError, you might need to adjust the class path line
in the command file.

Results

The sample requester application sends the same request message as before, but
the response now comes from the MDB application. The following output, showing
sent and received messages, is displayed in the requester application Command
Prompt window:

> Connection factory located in JNDI.
> Destination located in JNDI.
> Creating connection to QueueManager.
> Connection created.

> Sending stock request for ’BakedBeans’
> Sent Message ID=ID:414d512073616d706c65514d202020206beeb6512001ad02

> Received Message ID=ID:414d512073616d706c65514d202020206beeb6512001bb02 for ’From MDB: BakedBeans -
15 tins in stock. Expected delivery time 1 day’

> Closing connection to QueueManager.
> Closed Connection.
--------------------------------------------------------
In this window, observe the messages sent through WebSphere MQ:
- The request message sent
- The reply message received
-----
When ready, press any key to close this window
Press any key to continue . . .

In the console of your Eclipse, the following message is displayed:
Example MDB invoked
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You have finished implementing the solution, and verified that WebSphere
Application Server Liberty profile can connect to WebSphere MQ for the successful
transmission of messages.
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing 2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
Software Interoperability Coordinator, Department 49XA
3605 Highway 52 N
Rochester, MN 55901
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement, or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM's future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs.

If you are viewing this information softcopy, the photographs and color
illustrations may not appear.
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Programming interface information
Programming interface information, if provided, is intended to help you create
application software for use with this program.

However, this information may also contain diagnosis, modification, and tuning
information. Diagnosis, modification and tuning information is provided to help
you debug your application software.

Important: Do not use this diagnosis, modification, and tuning information as a
programming interface because it is subject to change.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corporation in the United States, other countries,
or both. If these and other IBM trademarked terms are marked on their first
occurrence in this information with a trademark symbol (® or ™), these symbols
indicate U.S. registered or common law trademarks owned by IBM at the time this
information was published. Such trademarks may also be registered or common
law trademarks in other countries. A current list of IBM trademarks is available on
the Web at Copyright and trademark information (www.ibm.com/legal/
copytrade.shtml).
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Sending your comments to IBM

We appreciate your input on this publication. Feel free to comment on the clarity,
accuracy, and completeness of the information or give us any other feedback that
you might have.

Use one of the following methods to send us your comments:
v Send an email to ibmkc@us.ibm.com
v Use the form on the web here: www.ibm.com/software/data/rcf/

When you send information to IBM, you grant IBM a nonexclusive right to use or
distribute your comments in any way it believes appropriate, without incurring
any obligation to you.

Include the following information:
v Your name and address
v Your email address
v Your telephone or fax number
v The publication title and order number
v The topic and page number related to your comment
v The text of your comment

IBM or any other organizations will only use the personal information that you
supply to contact you about the issues that you submit.

Thank you for your participation.
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