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IBM WEBSPHERE APPLICATION SERVER V6.1 FEATURE PACK FOR EJB 3.0– LAB EXERCISE 

Configuring the Application Server Toolkit for EJB 3.0
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What this exercise is about 

The objective of this lab is to demonstrate the process of configuring the Application Server Toolkit (AST) 
V6.1 as a development environment for applications that use the Enterprise Java Beans (EJB) 3.0 

Application Server Feature Pack for EJB 3.0, then create and deploy a simple enterprise application that 
includes an EJB 3.0 module. 

specification. You will step through the process of setting up the AST for use with the WebSphere 

This will enable you to use the Application Server Toolkit to work with, modify, and add to the sample 
application if you want. 

Lab requirements 

•	 This exercise assumes that WebSphere Application Server V6.1 with the Feature Pack for EJB 3.0 is 
already installed and an application server profile is already created with administrative security 
enabled. 

•	 Lab source files (the Labfiles61EJB3 directory) must be downloaded and extracted. This directory is 
included in the archive file that contained this document (WASv61_EJB3_Labs.zip). The exercise uses 
<LAB_FILES> to refer to the directory in which you have extracted the archive file. 
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What you should be able to do 

At the end of this lab you should be able to: 

•	 Configure the Application Server Toolkit to develop EJB 3.0 artifacts 

•	 Package an enterprise application with EJB 3.0 modules for deployment to a local WebSphere
 
Application Server installation
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Exercise instructions 

Security note: For the purposes of this exercise, it is assumed that administrative security has been enabled, 
and that a user with the name wsdemo and password password has full administrative rights. If a different 
administrator exists on your system, replace the sample user credentials with the actual user credentials when 
necessary. 

For the purposes of this exercise, it is assumed that a profile was created using the default port values. If 
different port numbers are used on your system, substitute port numbers as necessary. 

For the purposes of this exercise, the following directory locations are assumed. If different locations are in use 
in your environment, replace the sample paths with the actual path on your system 

Location Windows® UNIX®/Linux® 

WebSphere Application Server C:\WebSphere\AppServer\ /opt/WebSphere/AppServer 
installation 

Lab files location C:\Labfiles61EJB3 var/tmp/Labfiles61EJB3 
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Part 1: Prepare the Environment 

____ 1. Verify that server1 is stopped 

__ a. Navigate to the profile’s bin directory in a command prompt. 

cd c:\WebSphere\AppServer\profiles\AppSrv01\bin 

cd /opt/WebSphere/AppServer/profiles/AppSrv01/bin 

__ b. Use the serverStatus command to verify that the application server is stopped. 

serverStatus.bat server1 –username wsdemo
 

-password password
 

./serverStatus.sh server1 –username wsdemo
 

-password password
 

__ c. If the server status indicates STARTED, then stop the server: 

stopServer.bat server1 -username wsdemo
 

-password password
 

./stopServer.sh server1 -username wsdemo
 

-password password
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Part 2: Prepare the Application Server Toolkit 

____ 1. Launch the Application Server Toolkit 

__ a. Open a command prompt. 

__ b. Navigate to the directory where you have installed the Application Server Toolkit 

cd c:\IBM\AST
 

cd /opt/IBM/AST
 

__ c. Start the AST and specify a workspace to use for this exercise, using the paths shown below, or 
another path of your choice. 

ast.exe –data c:\LabFiles61EJB3\workspace
 

./ast –data var/tmp/LabFiles61EJB3/workspace 

__ d. Close the “Welcome” tab. 

____ 2. Ensure that the AST is configured to compile Java 5.0 code. 

__ a. Select Window > Preferences…. 

__ b. Expand Java in the left menu. 

__ c. Click Compiler. 
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__ d. Ensure that the Compiler compliance level is set to 5.0 as shown below. 

__ e. Click OK. 

__ f. You may be prompted to perform a “full build”. There is no code in this workspace yet, so it will 
have no effect. Click Yes. 

____ 3.	 Define a local test server instance that uses WebSphere Application Server V6.1 with the Feature 
Pack for 3.0 installed. By defining a local test server before creating any projects, you will ensure 
that j2ee.jar from the server’s installation will be included on the build path of any project that you 
create. This is important because the AST must have visibility to this file, or it will not be aware of 
EJB 3.0. 

__ a. Switch to the J2EE Perspective by selecting Window > Open Perspective > J2EE. If J2EE is 
not shown in this menu, select Other… and then J2EE. 
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__ b. In the lower panel, click the Servers tab. 

__ c. Right-click in the lower panel and select New > Server from the contextual menu as shown 
below. 

__ d. In the resulting window, click Installed runtimes….
 

__ e. Click Add… in the “Installed Server Runtimes” window.
 

__ f. Select IBM > WebSphere Application Server V6.1 in the “New Server Runtime” window
 

__ g. Click Next.
 

__ h. In the “Name” field, enter WebSphere Application Server V6.1 with EJB 3.0.
 

__ i. In the “Installation directory” field, enter the location of the WebSphere Application Server 
installation that has had the Feature Pack for EJB 3.0 installed. (For example, 
c:\WebSphere\AppServer). You can also use the Browse… button to locate this directory. 

__ j. Click OK. 

__ k. You will be returned to the “Installed Server Runtime Environments” window. Select WebSphere 
Application Server V6.1 with EJB 3.0. 

__ l. Click OK. 

__ m. Ensure that the “Server runtime:” field now reads WebSphere Application Server V6.1 with 
EJB 3.0 and click Next. 

__ n. In the “WebSphere Server Settings” window, select the profile that you want to use for the server 
runtime. If you have created only one profile, it will already be selected. 

__ o. Clear the Run Server with resources within the workspace check box. This will run the server 
using resources that are on the server, not within the workspace. 
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__ p. Ensure that Security is enabled on this server is checked (if security is in fact enabled on that 
server) and provide your administrative username and password. The window should now look 
like the window shown below (allowing for differences in profile name and user ID information). 

__ q. Click Finish. 
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____ 4. Create an enterprise application project named EJB3CounterSample. 

__ a. Select File > New > Project…. 

__ b. Expand J2EE and select Enterprise Application Project. 

__ c. Click Next. 

__ d. Enter a project name of EJB3CounterSample.
 

__ e. In the “Target runtime” field, select WebSphere Application Server V6.1 with EJB 3.0.
 

__ f. Click Finish.
 

__ g. EJB3CounterSample should now appear in the Project Explorer panel.
 

____ 5. Add a Web module. 

__ a. Right-click on EJB3CounterSample in the Project Explorer and select New > Dynamic Web 
Project. 

__ b. Type counter in the “Project name:” field. 

__ c. Ensure that Add project to an EAR is selected and that the EAR project name is 
EJB3CounterSample. 

__ d. Click Next.
 

__ e. Click Next again.
 

__ f. Set the context root to ejb3sample/
 

__ g. Click Finish.
 

____ 6.	 Import EJBCount.jsp and web.xml from the sample application provided in the Lab files download. 
This is the same sample application that is installed into the “samples” directory by the feature pack 
installer. 

__ a. Expand counter in the Project Explorer.
 

__ b. Right-click WebContent, and select Import….
 

__ c. Expand General and click File system.
 

__ d. Click Next.
 

__ e. Set the “From directory” to c:\Labfiles61EJB3\EJB3Counter\WebApplication (or its equivalent 
if you expanded the download to a different location) 

__ f. Expand WebApplication and WEB-INF, then check the box next to web.xml. 

__ g. Check the box next to EJB3Count.jsp in the right-side panel. 

__ h. Click Finish. 

__ i. When asked if you want to overwrite existing files, click Yes to all. 
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____ 7. Create a utility JAR project. This will become the EJB module for your enterprise application. 

Note: The AST has not been enhanced to understand EJB 3.0, and assumes that all EJB projects are EJB 
1 or 2 projects. To develop EJB 3.0 modules in the Application Server Toolkit, you must create them as 
Java projects or utility projects, not as EJB projects. This prevents the AST from adding a J2EE 1.4 EJB 
deployment descriptor to the project. After creating the project, you will also need to hand-edit the 
application deployment descriptor to include the module. 

__ a. Right-click on EJB3CounterSample in the Project Explorer and select New > Project….
 

__ b. Expand J2EE and select Utility Project.
 

__ c. Click Next.
 

__ d. Enter EJB3Beans as the project name.
 

__ e. Ensure that Add project to an EAR is selected and that the EAR project name is
 
EJB3CounterSample.
 

__ f. Click Finish.
 

____ 8. Import the sample code into the EJB3Beans project. 

__ a. Expand EJB3Beans in the Project Explorer. 

__ b. Right-click src and select Import…. 

__ c. Expand General and select File system. 

__ d. Click Next. 

__ e. Set the “From directory” to c:\Labfiles61EJB3\EJB3Counter (or its equivalent if you expanded 
the download to a different location) 

__ f. Expand EJB3Counter and check the box next to com. 

__ g. Click Finish. You should now see a package named com.ibm.websphere.ejb3sample.counter 
in the “src” folder 

____ 9. Import persistence.xml from the sample application into the EJB3Beans project. persistence.xml 
defines the data source that will be used for JPA persistence, and the entity classes for which it will 
be used.
 

__ a. Expand EJB3Beans in the Project Explorer.
 

__ b. Expand src.
 

__ c. Right-click META-INF and select Import….
 

__ d. Expand General and select File system.
 

__ e. Click Next.
 

__ f. Set the “From directory” to c:\Labfiles61EJB3\EJB3Counter\EJB3Beans\META-INF (or its
 
equivalent if you expanded the download to a different location)
 

__ g. Check the box next to persistence.xml.
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__ h. Click Finish. You should now see persistence.xml in the META-INF folder in the Project Explorer 

____ 10. Manually edit the application deployment descriptor to include a reference to the EJB 3.0 project. 

__ a. Expand EJB3CounterSample in the Project Explorer. 

__ b. Expand META-INF. 

__ c. Double-click application.xml to open it in the deployment descriptor editor. 

__ d. Click the Source tab in the deployment descriptor editor. 

__ e. Locate the closing tag </application>, and add the following line immediately above it, to identify 
EJB3Beans.jar as an EJB module: 

<module id="EJB3Module"><ejb>EJB3Beans.jar</ejb></module>
 

__ f. Select File > Save to save the edited deployment descriptor. 

__ g. Close the deployment descriptor. 

____ 11. Import the Derby database from the sample application 

__ a. Right-click EJB3CounterSample in the Project Explorer and select Import…. 

__ b. Expand General and select File system. 

__ c. Click Next. 

__ d. Set the “From directory” to c:\Labfiles61EJB3\EJB3Counter\Database (or its equivalent if you 
expanded the download to a different location) 

__ e. Expand Database and check the box next to database (note the case differences). 

__ f. Click Finish. You should now see a folder named database in the EJB3CounterSample project. 
This is the embedded Derby database that is used by the JPA entity. 

____ 12. Import the WebSphere Application Server configuration files from the sample application. 

Note: These configuration files get applied to the application server when the application is deployed to 
the server. They will create JDBC resources for accessing the database, and a Host Alias for the Web 
application. These resources will not be available until the server is restarted. 

__ a. Expand EJB3CounterSample in the Project Explorer. 

__ b. Right-click META-INF and select Import…. 

__ c. Expand General and select File system. 

__ d. Click Next. 

__ e. Set the “From directory” to c:\Labfiles61EJB3\EJB3Counter\META-INF (or its equivalent if you 
expanded the download to a different location) 

__ f. Expand META-INF and check the box next to ibmconfig. 

__ g. Click Finish. You should now see a folder named ibmconfig in the EJB3CounterSample project. 
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Part 3: Deploy the application to WebSphere Application Server 

____ 1. Add your enterprise application project to the server. 

__ a. Click on the Servers tab in the lower panel. 

__ b. Right-click on the server you created earlier and select Add and Remove Projects…. 

__ c. Click on EJB3CounterSample. 

__ d. Click Add. The project should move to the column on the right, as shown below. 

__ e. Click Finish. 

____ 2. Publish the application to your server. 

__ a. Right-click on the server and select Start, and wait for the server’s status to change to “Started”. 

__ b. Right-click on the server again and select Publish from the contextual menu as shown below. 
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__ c. Verify that the server’s state is now “Synchronized”. 
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Part 4: Test the application 

In this section you will test the sample application that you built and deployed. 

____ 1. Launch a Web browser and navigate to http://localhost:9080/ejb3sample/counter. 

____ 2. Verify that you see a page titled “EJB 3.0 and JPA 1.0 Counter Sample”. 

____ 3. Click the Increment button to increment the counter using a JPA entity, and verify that the counter 
is incremented. This establishes that all parts of the application have been packaged and installed 
correctly. 

____ 4. Note in the console log displayed in the AST that you see, in addition to messages written by the 
Entity and by the session bean, you also see messages that are written by the AuditInterceptor 
class. This Interceptor was written to log the name of each method that is called. Inspect 
AuditInterceptor.java for details. 

What you did in this exercise 

In this exercise you configured the Application Server Toolkit to support development of EJB 3.0 modules. 
To do so, you created a server configuration to use a WebSphere Application Server with the Feature 
Pack for EJB 3.0 installed, and configured the AST to use the resources provided by the Feature Pack for 
EJB 3.0. 

You also created a new enterprise application, and modified it to run under WebSphere Application Server 
V6.1 with the Feature Pack for EJB 3.0. You created the EJB module as a Utility JAR project to prevent 
the addition of a J2EE 1.4 EJB deployment descriptor, and then modified the application deployment 
descriptor to include this module as an EJB module. 

You then deployed this application to WebSphere Application Server using the publishing function of the 
AST, and verified that the configuration and packaging were correct by running the sample application. 

You are now ready to use the AST to modify and add to the sample application to further your EJB 3.0 
learning experience. 
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