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What this exercise is about 

The objective of this lab is to provide you with an understanding of the WebSphere Adapter for JDBC and 
outbound request processing. 

Lab requirements 

• WebSphere Integration Developer V7.0 installed 

• WebSphere Process Server V7.0 test environment installed 

• WebSphere Adapter for JDBC V7.0 installed 

• Sample code in the directory C:\Labfiles70\JDBC (Windows) or /tmp/LabFiles70/JDBC (Linux) 

What you should be able to do 

At the end of this lab you should be able to: 

Install and deploy the Adapter for JDBC and integrate it into an SCA application for use with outbound 
request processing. This exercise demonstrate one scenario which is creating business objects for user-
defined insert/update/delete SQL statements and executing the batch of SQL statements using EXECUTE 
operation . 
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Introduction 

This lab introduces you to the WebSphere Adapter for JDBC and the processing of outbound requests to a 
table in a database. It uses a JDBCTEST Derby database that contains a CUSTOMER table. In the lab, 
you import the JDBC Adapter into WebSphere Integration Developer and run External Service to input 
connection information, create a service description, and discover objects existing in the specified 
database. Then, you continue to assemble an SCA application, wiring together a stand-alone reference 
and the EIS import file. To test your application, you use the WebSphere Test Environment and 
Component Test, exercising various outbound requests, such as create, delete, retrieve, and retrieveAll. 

Exercise instructions 

Some instructions in this lab can be Windows operating-system specific. If you plan on running the lab on 
an operating-system other than Windows, you need to run the appropriate commands, and use 
appropriate files (.sh or .bat) for your operating system. The directory locations are specified in the lab 
instructions using symbolic references, as follows: 

Reference variable Windows location AIX® or UNIX® 

location 

<LAB_NAME> JDBCOutbound 

<WID_HOME> C:\Program Files\IBM\WebSphere\ID\7.0 

<WPS_HOME> <WID_HOME>\runtimes\bi_v70 

<JDBCADAPTER_HOME> <WID_HOME>\Resource Adapters\JDBC_7.0.0.0\ 

<LAB_FILES> C:\Labfiles70 /tmp/Labfiles70 

<TEMP> C:\temp /tmp 

Windows users note: When directory locations are passed as parameters to a Java™ program such as 
EJBdeploy or wsadmin, it is necessary to replace the backslashes with forward slashes to follow the Java 
convention. For example, C:\LabFiles70\ is replaced by C:/LabFiles70/. 

Note that the previous table is relative to where you are running WebSphere Integration Developer. 
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Instructions if using a remote server for testing 

Note that the previous table is relative to where you are running WebSphere Integration Developer. The 
following table is related to where you are running the remote test environment: 

Reference variable Example: Remote 
Windows test server 

location 

Example: Remote 
z/OS® test server 

location 

Input your values for the 
remote location of the test 

server 

<SERVER_NAME> server1 sssr011 

<WAS_HOME> C:\Program 
Files\IBM\WebSphere\AppServer 

/etc/sscell/AppServer 

<HOSTNAME> localhost mvsxxx.rtp.raleigh.ibm.com 

<SOAP_PORT> 8880 8880 

<TELNET_PORT> N/A 1023 

<PROFILE_NAME> AppSrv01 default 

<USERID> N/A ssadmin 

<PASSWORD> N/A fr1day 
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Part 1: Create the JDBCTEST database using Derby 

In this part you are going to the JDBCTEST database along with the CUSTOMER and ADDRESS table for 
user data. 

If you choose to run the JDBC inbound lab first, then you only need to create additional table, ADDRESS 
for this exercise. If you choose to run JDBC Outbound Hierarchy BO lab first, then you can skip this 
section and proceed to Part 2. 

If you are using a remote testing environment on z/OS, it is recommended to create the Derby 
databases on your Windows machine and then FTP the data files to the z/OS environment. Be sure to 
upload the files in the /log and /seg0 directories in binary format, and the “service.properties” file in ASCII 
format. You used a directory on the host called /tmp/LabFiles70/DerbyDB. Also be sure to use the 
CHMOD command to change all the files to 777. 

____ 1.	 Start Derby ij command 

Note: The Derby embedded driver that is being used in the lab, supports a connection from only one JVM 
at a time. You can have either the server running and connected to the JDBCTEST database, or the 
vendor GUI tool connected to the JDBCTEST database; but not both at the same time. 

__ a. Open a command prompt window, navigate to this subdirectory, and run Derby’s interactive 
JDBC scripting tool. 

<WPS_HOME>\derby\bin\embedded>ij 

____ 2.	 Using the command line, create the JDBCTEST database if it does not already exist. If you have 
already completed the JDBCOutbound lab, the database, tables, and triggers are the same. You 
can skip to step7, where you add records to the CUSTOMER table. 

__ a. Type in this script to create JDBC database as user ‘Wbidemo’ and password ‘Wbi15Demo1’ in 
the Console view. 

connect ‘jdbc:derby:databases\JDBCTEST;create=true;user=Wbidemo;password=Wbi15Demo1’; 

____ 3. Enter SQL to create two tables: CUSTOMER and ADDRESS tables for user data. 

NOTE: For your convenience, these SQL code snippets can be found in 
<LAB_FILES>\JDBC\snippets\EVENTSTORESQL.txt 

__ a. Paste this into the command window: 

CREATE TABLE CUSTOMER
 
(
 

pkey VARCHAR(10) NOT NULL PRIMARY KEY,
 
LName VARCHAR(20),
 
FName VARCHAR(20),
 
ccode VARCHAR(10)
 

);
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NOTE: For your convenience, these SQL code snippets can be found in 
<LAB_FILES>\JDBC\snippets\CUSTOMERSQL.txt 

__ b. Paste this into the command window: 

CREATE TABLE ADDRESS
 
(
 

addrid VARCHAR(10) NOT NULL PRIMARY KEY,
 
custid VARCHAR(10),
 
city VARCHAR(20),
 
zipcode VARCHAR(10)
 

); 

NOTE: For your convenience, these SQL code snippets can be found in 
<LAB_FILES>\JDBC\snippets\ADDRESSSQL.txt 

____ 4. Disconnect and exit the ij command window 

Note: You must exit the ij command window, before starting the server as the Derby “embedded” 
database driver used in this lab allows for only one JVM connection at a time. 

Rememer that if you are using a remote test environment for this lab, you need to FTP the Derby database 
files to the remote system, as explained at the beginning of this section. 
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Part 2: Set up the development environment 

In this part, you start WebSphere Integration Developer, using a new workspace, import RAR file and set 
up the WebSphere Process Server to be used as the WebSphere Test Environment (WTE). 

____ 1. Start WebSphere Integration Developer V7.0 with a new workspace. 

__ a. From the start menu select Start > Programs ���� IBM WebSphere Integration Developer ����
IBM WebSphere Integration Developer 7.0 ���� IBM WebSphere Integration Developer V7.0 

__ b. When prompted enter <LAB_FILES>\JDBC\Outbound\UserDefinedSQL for your workspace 
and click OK 

__ c. When WebSphere Integration Developer V7.0 opens, close the Getting Started page 
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Part 3: Create the JDBC Outbound application 

In this part you run External Service to discover objects and create the necessary SCA artifacts, and 
assemble the adapter into an SCA application. 

NOTE: If you are using a remote test environment on z/OS, you first need to enable your Derby 
database for network access using these steps: 

On the host, login to the system using telnet. 

In order to allow connections to the network server, you need to edit the 
/<WPS_HOME>/cloudscape/db2j.properties file. Delete the ‘#’ (pound sign) to uncomment this line: 

db2j.drda.host=0.0.0.0
 

Navigate to /<WPS_HOME>/derby/bin/networkServer 

Issue the command ./startNetworkServer.sh 

Keep this telnet window open during the next few steps; this window shows when a connection has been 
successfully made from WebSphere Integration Developer to the database server. 

**NOTE that there are security concerns with enabling the network server for Derby in this manner. Read 
the information in the db2j.properties file regarding these security concerns to determine if your installation 
allows for the use of the network server for Derby. If not, you can continue doing the lab using the 
integrated test client in WebSphere Integration Developer instead of your remote test environment. 

____ 1.	 In the Business Integration Perspective, run the External Service wizard. A Business Integration 
project is created for you during this process. 

__ a. From the top Menu bar, select Window > Open Perspective > Other … > Business 
Integration (default) click OK 

____ 2.	 From within the Business Integration Perspective, select File > New > External Service. This 
opens an External Service wizard that helps you obtain a service which establishes connectivity with 
other systems. The wizard provides four connectivity options – Adapters, Java, Registers, and 
Messaging 

__ a. Expand Adapters, select JDBC, and click Next 
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____ 3. Highlight IBM WebSphere Adapter for JDBC (IBM: 7.0.0.0) and click Next 

____ 4. Adapter Import screen: 

In this step, you will import a connector resource adapter archive from the file system into your WebSphere 
Integration Developer workspace. The adapter RAR file already exists under <JDBCADAPTER_HOME>. 

__ a. The default Connector file is selected which is shipped along with WebSphere Integration 
Developer 

__ b. Accept the default name for Connector project, CWYBC_JDBC. You can change it to any other 
name, but for this lab, you can leave the default name. 

__ c. For Target server, ensure that WebSphere Process Server V7.0 is selected 

____ 5. Add any external dependencies your adapter has to the imported project. These are dependencies 
that the adapter can have on the JDBC applications (adapter–specific). 

2010 May, 03 IBM WebSphere Adapter for JDBC V7.0 – Lab exercise Page 8 of 29 

WBPMv70_IEA_AdapterJDBCOutboundUserDefinedSQLLab.doc 



        

                

  

                
                  

          

 

    

            

        

 

© Copyright IBM Corporation 2010. All rights reserved 

__ a. Click Add and browse to the location of c:\<WPS_HOME>\derby\lib and select the derby.jar. If 
you are using a remote test environment on z/OS, you also need to select db2jcc.jar and 
db2jcc.license.jar. The db2jcc.jar file is sometimes located in directory \derby\lib\otherJars. 

__ b. Click Next 

____ 6. Select the type of processing the adapter performs at runtime 

__ a. Select Outbound and click Next 
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____ 7.	 Complete the Connection Configuration for Discovery Agent Configuration panel to connect to the 
JDBCTEST database and discover the available services. To connect to the database, these 
information are necessary: username, password, database URL and JDBC driver class. Check the 
driver manual for the appropriate values for driver URL and driver class. 

__ a. From the left panel, expand Generic JDBC and select 1.0 

__ b. From the right panel, enter/select these following values 

1) JDBC Driver type: Other 

2) JDBC Driver classname: org.apache.derby.jdbc.EmbeddedDriver 

3) Database URL: jdbc:derby:<WPS_HOME>derby\databases\JDBCTEST 

__ c. Enter valid user ID and password values, for example 

Username: Wbidemo
 
Password: Wbi15Demo1
 

NOTE If you are using a remote test environment, use a valid user ID and password for the remote 
system and enter these values for DatabaseURL and JdbcDriverClass 
DatabaseURL: jdbc:db2j:<WPS_HOME>\runtimes\bi_v70\derby\databases\JDBCTEST 
JdbcDriverClass: com.ibm.db2j.jdbc.DB2jDriver 

If using a remote test environment on z/OS use these values 
DatabaseURL: jdbc:db2j:net://<HOST_NAME>:1527//<remote_derbydb_path>/JDBCTEST 
JdbcDriverClass: COM.ibm.db2os390.sqlj.jdbc.DB2SQLJDriver 
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__c. Click Next. 

____ 8. Complete the Find and Discover Enterprise Services panel 

__ a. Click the Edit Query button 

__ b. In the Query Filter Properties window that opens up, check Create a batch SQL business 
object to build user-defined insert, update and delete statement check box, 

__ c. You can enter the number of user-defined queries that you want to enter. In this exercise, there 
is only one user-defined query so keep the default value. 

__ d. Click OK. 
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__ e. Click Run Query button. A connection is made to the Derby JDBCTEST database and lists the 
tables, stored procedures, etc, sorted by schema name. It also lists ‘Batch SQL statements’ as a 
top level node for creation of user-defined insert/update/delete BOs. 
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__ f. Expand Batch SQL Statements and highlight Batch SQL Statements 1, click button. 

__ g. It opens up a window for setting the Configuration Parameters for Batch SQL Statement 1. 

__ h. Enter the name for the Batch SQL Statements as BatchSQL and this statement in the SQL 
Statements property separated by a semicolon. 

insert into Customer values (?,?,?,?);
 
update Address set addrid=? where custid=?;
 
delete from Customer where pkey=?;
 

__ i. Check Generate Parameters 
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__ j. Enter dummy values for the Sample value for each parameter value and click Validate to verify if 
the user-defined statement is validated. 

__ k. Click Ok 
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__ l. Click Next 

____ 9. Complete the Configure Objects panel 

__ a. Leave the default value for Namespace. Note the Operations is not available as there is only one 
operation Execute for user defined SQL statements. 

__ b. Note that Business Graph is optional - It determines if you want to generate business graph or 
not. If the property is checked then business graphs is generated. By default, the property is 
checked. 

__ c. Click Next 

____ 10. Complete Publishing Object Configuration Properties 

__ a. Specify the security crendentials 

1) Uncheck JAAS alias option and select Other to define the data source JNDI name 

__ b. Leave the default “With module for use by single application” option in this exercise. 

__ c. Under Connection properties 

1) Leave the default “Specify predefined XA Datasource” 

2) Database Vendor is pre-populated with value Other (If you were using DB2, Oracle, or 
MSSQLServer, you see those values instead as specific adapter processing is available 
with those specific databases.) 

3) Enter jdbc/Derby XA for JDBC for XA Data source JNDI name 
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Note: If you are using a remote test environment, the values for databaseURL and JdbcDriverClass 
should match the values provided earlier during the External Service wizard, not what is pictured below. 
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__ d. Click Advanced for additional properties options 

1) Optional for logging and tracing 

a) Enter any numeric value for Adapter ID. This property identifies the adapter 
instance in log and trace files and for PMI events. The adapter ID is used with an 
adapter-specific identifier, MyAdapterRA, to form the component name used by 
Log and Trace Analyzer. 

b) If you set the property to disguise user data as “XXX’, the adapter will replace user 
data with a string of X's when writing to log and trace files. For inbound processing, 
this property is retrieved from the resource adapter properties. For outbound 
processing, it is retrieved from the managed connection factory properties. 

__ e. Click Next 

____ 11. Complete Publishing Properties panel 

__ a. A business integration module has not yet been created. You can define the module here also. 

1) Select the New button Select the radio button “Create a module project” from new 
Integration Project pop up window. 

2) Enter in the name JDBCOutUserDefinedSQL for the Module Name 

3) Accept the defaults and click Finish
 

__ b. Leave the default JDBCOutboundInterface for the Name value.
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__ c. Click Finish 

____ 12. Verify the result as given below 

__ a. Save your work by selecting File -> Save from the top menu, or using the shortcut key sequence 
Ctrl + S. Close the file. 

____ 13. Release the connection to the Derby database by using Switch Workspace 
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Note: Switch Workspace is a way to release the existing connection to the Derby database from the 
External Service process. In the next part, you will start the WebSphere Process Server and it needs a 
connection to the database to create and retrieve records. This step is necessary only because you are 
using the Derby embedded driver in this exercise which supports a connection from a single JVM. 

__ a. From the top menu bar, select File > Switch Workspace and select the same workspace from 
which you have been working. 
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Part 4: Create J2C authentication alias and configure data sources 

Note: This section is optional for outbound lab, you can skip this section and go to Part 5. 

In this part,create a J2C Authentication Alias which is required for connection to the database. Also create 
the JNDI data source name that is used by the Adapter to configure itself to the endpoint. Then use the 
WebSphere Test Environment and Component Test to test the SCA application by retrieving several 
records from the CUSTOMER table in the JDBCTEST database. 

____ 1. Switch to Servers view by selecting Windows � Show View � Servers. 

____ 2. Set the authentication alias from the administrative console 

__ a. In the Servers tab in the lower-right corner pane, right click the Server and then select Start 

__ b. When the server status is Started, right click the Servers, and then select Administration 
����Run Administrative console 

__ c. Log in to the administrative console by clicking the “Log in” button 

__ d. Click Security ���� Global Security 

__ e. On the right, expand Java Authentication and Authorization Service under the Authentication 
heading. 
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__ f. Click J2C authentication alias. It gives the list of existing aliases. 

1) Click New and enter these following values
 

a) User ID: Wbidemo
 

b) Password: Wbi15Demo1
 

__ g. Click Ok and save the changes 

____ 3. Create a JDBC Provider to which is used to create data source 

__ a. From administrative console, click Resources � JDBC ���� JDBC Providers 

__ b. On the right, click New and choose these following values 

1) Database type: Derby
 

2) Provider type: Derby JDBC Provider
 

3) Implementation type: XA data source
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__ c. Click Next and review the summary of changes.
 

__ d. Click Finish and save the changes.
 

____ 4. Create JDBC data source 

__ a. On the right, click Data Sources under Additional Properties heading 

__ b. Click New to set a data source and enter these following values 

1) Data source name: Derby JDBC Driver XA DataSource 

2) JNDI name: jdbc/Derby XA for JDBC 

__ c. Click Next to Step 2 

__ d. In Database specific properties for the data source, enter JDBCTEST as database name 

__ e. Click Next to Step 3 

__ f. Set the Component-managed authentication alias to the one created in the earlier section. 

__ g. Click Next and view the Summary 
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__ h. Click Finish and save the changes. 

____ 5. Test the JDBC Data Source connection 

__ a. Check the box next to Derby JDBC Driver XA DataSource and click Test connection from the 
top of the screen. 

__ b. You should see this success message on the top of the screen 

____ 6. Release the connection to the Derby database by using Switch Workspace 

__ a. From the top menu bar, select File > Switch Workspace and select the same workspace from 
which you have been working. 
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Part 5: Test the application using the WebSphere test environment and 
component test 

This lab is using the Derby embedded database driver which allows a connection from only a single JVM 
at a time. ij.bat, the External Service process, and a running Server configured with an application that 
connects to the database, each are an active connection. This means you can have only one of these 
active connections to the database at a time. For example, in this part, you will start the server and run 
several tests creating and retrieving records from the database. You are not able to use ij.bat to view the 
database, while the server is active. You need to first stop the server. 

____ 1. In the Servers tab in the lower-right corner pane, right click the Server and then select Start 

____ 2. Add the project to the server for the WebSphere Test Environment. 

__ a. Start the server by right click Server and select Start. 

__ b. Right click the server in the server view and select Add and remove projects … 

__ c. In the Add and Remove Projects dialog, select the JDBCTestOutboundUserDefinedSQLApp 
project from the Available projects panel. 
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__ d. Click Add > to add it to the Configured projects panel. Click Finish 

____ 3.	 Use the Test Component to test the application. The create scenario is to create a record in the 
database. 

__ a. Right click the JDBCTestOutboundUserDefinedSQL module and select Test����Test 
Component 

__ b. In JDBCTestOutboundUserDefinedSQL_Test, switch to the Configurations tab, if you see 
JDBCOutboundInterface underneath Emulators, right click, and remove it. You might not see 
anything under Emulators. You want to connect to and drive the real JDBCTEST database and 
not have Test Component emulate for you. 

__ c. Switch back to the Events tab 
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1) Under Detailed Properties, choose executeBatchSQLBG as this is the only operation. 

2) Under Initial request parameters, enter these following values 

a) Enter the values for each parameter. You do not see SQL statements here because 
SQL statements can not be change, and those statements are not stored as 
attributes. 
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__ d. In the 
Choose a deployment location dialog, select the WebSphere Process Server V7.0 server. 
Select Finish 

__ e. In the Events window you should see that Invoke has returned. 

____ 4. Check the data in the EIS to ensure it matches expected values 

__ a. Stop the Server by right clicking WebSphere Process Server V7.0 and select Stop. 

__ b. From the ij command window, connect to JDBCTEST database with user name as Wbidemo 
and password as Wbi15Demo1. 
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__ c. After ran SQL statements in this exercise, this is the result you should see from JDBCTEST 
database. 

1) Table Customer 

a) New record of pkey as 110, lname as Walker, fname as Jane, and ccode as 
Office. 

b) Existing record which has pkey as 100 has been deleted from the table. 

2) Table Address 

a) Addrid value in record which has custid as 100 is changed to 110 from 100. 

____ 5. Disconnect the database and exit. 

____ 6. Exit the Test Component panel, remove the JDBCTestOutboundUserDefinedSQL project from the 
server, and stop the server. 
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What you did in this exercise 
•	 In this exercise, you learned how to create a business object for user-defined insert/update/delete 

statements by using the Execute operation to process the records based on your user-defined SQL 
statements. 
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