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This module covers “Recording an HTTP Test” for IBM Rational Performance Tester 

versions 8.0 and higher.
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This presentation covers seven topics. It gives an overview of Rational 

Performance Tester and outlines the supported environments. It provides you with 

information on how to prepare the test environment, how to record a performance 

test, how to create a new schedule and add a test to the schedule. Finally, it takes 

you through the steps on how to run the performance schedule and how to view the 

test logs and reports. When you complete this module, you will know how to 

successfully record and run a Rational Performance Tester HTTP Test.
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Rational Performance Tester is a performance testing tool used to identify the presence 

and cause of system performance bottlenecks. The IBM Rational performance testing 

portfolio of tools will help you quickly create script less tests with no programming 

knowledge. Rational Performance Tester also helps you accurately emulate large 

population user transactions with minimal hardware and run large scale performance tests 

to validate application scalability.
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This slide covers the system requirements for Rational Performance Tester V8.0.
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Preparing the test environment will cover four topics. Launching Rational Performance 

Tester from the Windows Start menu, creating a new workspace for your Rational 

Performance Tester projects, creating a new performance test from a recording and 

creating a new performance schedule.
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If you accepted the defaults during the installation, Rational Performance Tester V8.0 is 

located in the IBM Software Delivery Platform group in the Windows->Start menu. To 

launch Rational Performance Tester, go to Start -> All Programs -> Software 

Development Platform -> IBM Rational Performance Tester – Full Eclipse. Note that 

in Rational Performance Tester V8.0, there are two options to launch Rational 

Performance Tester. The first option is  IBM Rational Performance Tester and the 

second option is IBM Rational Performance Tester – Full Eclipse. To fully take 

advantage of Rational Performance Tester and the Eclipse features, the Full Eclipse option 

is recommended.
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The first time you launch Rational Performance Tester, you are prompted to create a new 

workspace. By default, the location is set to the folder located in the user’s profile. You 

have an option to change this to another location by clicking the Browse button. When 

finished, click OK. Note that just like all other Eclipse-based products, the Rational 

Performance Tester workspace should be created on your local machine. Network 

workspace is not supported. 
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After creating a new workspace, the Rational Performance Tester workbench is displayed 

with the Rational Performance Tester perspective. The Performance Tester perspective is 

a collection of views. By default, the Test Navigator view is located in the upper left of the 

workbench. The Test Navigator view lists the Projects, Tests, Schedules, Datapools and 

Results. The Main view shows the selected Test, Schedule or Result. For example, when 

you double-click the test in the Test Navigator view, the test opens in the Main view. This is 

the default perspective of Rational Performance Tester. You can customize the Rational 

Performance Tester perspective to display the views that you want to access quickly or to 

hide the views that you do not need.
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Before creating a performance test or schedule, a performance test project must be 

created. To create a new Rational Performance Tester project from the File menu, select 

New -> Performance Test Project. A New Performance Test Project window will 

appear. In the Project name field, type the name of the new project. Project names cannot 

contain certain special characters like back or forward slashes, open or closed brackets, 

asterisks, colons, or question marks. If the ‘Use default location’ is checked, the project is 

created inside the workspace. The workspace and the project can be in different locations. 

When complete, click Next. 
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Your test assets such as Agents, Datapools, Results, Schedules and Tests can be 

organized in folders within the project. On this screen, you have the option to create 

folders for organizing your test assets. Select the folders you want to create in the new 

project. You can modify the folder name by clicking on it. When complete, click Finish.

Page 10 of 36



RPT_HTTP_Recording.ppt

After the new project is created, the “Create New Test From Recording” wizard is started. 

A window labeled “Create New Test From Recording” will appear. From this window, you 

can select the type of recording you want. For a new HTTP recording, select the ‘Create 

Test From New Recording’ radio button and ‘RPT HTTP Recording’ from the list of 

recorders and click Next. Note that you can also get to the “Create New Test From 

Recording” wizard from the Rational Performance Tester File menu by clicking File -> New 

-> Test from Recording.
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The “Select location for Test Suite” window will appear. From this window, you can select 

the location where you want to create your tests. Select the ‘Tests’ folder from the list, 

enter the test file name then click Next.
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On this window, you can specify Client Digital Certificate if needed. Rational Performance 

Tester supports the use of Digital Certificates. If Client Digital Certificate is being used, 

select the ‘Use Client Digital Certificate’ check box, browse to the location of the PKCS12 

file and enter the pass Phrase. For this exercise, you will not use the Client Digital 

Certificate option. Click Finish to start the recording.
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The Initializing Recorder window will come up. You can expand this window to see the 

details by clicking the ‘Details’ button.
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It is recommended to remove page history cache files for better automatic page 

identification by Rational Performance Tester. You should also remove cookies associated 

with the application. Follow the instructions on this page to do so. It is also important to 

wait for the pages to load completely to ensure better automatic page recognition. Any 

extra waiting time is removed during playback for the recorded session.
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When complete, enter the URL of the application into the address bar of the browser and 

hit Enter. For this exercise, you will record a test against the www.ibm.com Web page. 
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Type ‘Rational Performance Tester’ into the Search field then click the ‘Search’ button. 

Behind the scenes, Rational Performance Tester captures the HTTP requests that the 

browser sends to the IBM Web site and the responses that the Web server sends back by 

routing the traffic to port 1080. 
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After the Search results page is completely loaded, stop the recording by closing the 

browser.
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After closing the browser, the recording is stopped and Rational Performance Tester will 

generate the test from the recording. When the test generation is complete, the Confirm 

Open Editor will come up. If you select ‘Remember my decision’ then click ‘Yes’, Rational 

Performance Tester will open the test in the editor and will remember your decision for the 

next time.
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When the Test generation is completed, the test is displayed in the Rational Performance 

Tester editor. You can edit the test in the editor by selecting the page you want to edit and 

then select the appropriate buttons in the editor such as Add, Insert, Rename and so on. 

For this exercise, leave the test as-is.
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You can run the Rational Performance Tester test by right-clicking the test and choosing 

Run as Test. However, running as a test, you can only run as one virtual user and the 

logging level cannot be modified. In order to run the Performance Tests with multiple 

virtual users, a Performance Schedule is needed. To create a new performance schedule, 

go to the File menu and choose File -> New -> Performance Schedule.
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The “Performance Schedule” creation wizard will start. You can specify which folder you 

want to create your schedules in. Select the Schedules folder under your project, enter the 

name of the schedule and then click Next.
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The next window in the wizard is the Schedule Options window. From this window, you 

can specify the number of users, number of ramp stages and number of groups for the 

schedule. Click Finish to create the new schedule. These options can also be modified 

after the schedule is created.
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After the wizard is completed, the new schedule is displayed in the editor window with one 

User Group as you specify in the schedule options. You can add more user groups from 

the editor window if needed.
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At this point, you do not have any tests in your schedule. You will need to add the test that 

you created earlier into User Group 1 that you have in your schedule. To add a Test to 

your schedule, right-click User Group 1 -> Add -> Test.
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The Select Tests window will come up. Select the test that you want to add to the schedule 

then click OK.
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The schedule will open with the added test. Note that the added test is in italic and the 

asterisk in front of the schedule name indicates that the schedule has not been saved. You 

need to save the schedule before running it. To save the schedule, click the Save button 

on the menu or click File ->Save.
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After saving the schedule, you can run the schedule by right-clicking the schedule and 

choosing Run As -> Performance Schedule. You can also run the schedule by selecting 

the schedule and then clicking the ‘Play’ button on the menu.
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The schedule is run by first generating code and then running the Performance Schedule. 

You can click the ‘Run in Background’ button to have the schedule running in the 

background and continue performing other tasks in Rational Performance Tester.
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During playback, the statistical data is displayed in the performance report. You can also 

monitor the page performance, page throughput and so on during playback. The green bar 

above the graph indicates which stage the execution is in. In the screen capture, Rational 

Performance Tester is in the “Running” stage.
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When the schedule execution is completed, the Performance Test Run is generated. You 

can view the available reports (Summary, Response versus Time, Page Performance and 

so on) by selecting the appropriate tabs.
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Beside the Reports, you can display the test log to view the detailed events, verdicts and 

verification points results of the test run. To display the test log, right-click the Performance 

Test Run Results and choose Display Test Log.
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The test log is displayed with Verdict Summary, Verdict Lists and so on. To view the 

detailed events, click the Events tab from the test log view.
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On the Events tab, you can expand each user to view the individual pages that each user 

requested and the corresponding responses from the server.
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This module provided an overview of Rational Performance Tester. It covered some basic 

information you need to get started with Rational Performance Tester. It also provided you 

with steps to record a performance test, create a performance schedule, add the test to 

the schedule, run the schedule and view test logs and reports.
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