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IBM BUSINESS MONITOR 7.5 – LAB EXERCISE 

IBM Business Monitor V7.5 - Clips and Tacks –
 

Business process monitoring lab
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What this exercise is about 

The objective of this lab is to show you how to monitor a business process which was developed in 
WebSphere Business Modeler, implemented in IBM Integration Designer and deployed to IBM Business 
Process Manager. 

This lab will provide solutions that you can import into Modeler and IBM Integration Designer, so then you 
can concentrate on building the monitor model, deploying it, running tests, and viewing monitored data in 
the dashboards. 

Lab requirements 

List of system and software required for the student to complete the lab: 
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•	 WebSphere Business Modeler V7.0.0.4. 

•	 IBM Integration Designer V7.5. 

•	 IBM Business Monitor V7.5 – Toolkit Installation on IBM Integration Designer including the Monitor 
Model editor and Monitor Server. 

What you should be able to do 

At the end of this lab you should be able to: 

•	 Use Modeler to export the business measures model and process model. 

•	 Use IBM Integration Designer to implement the monitor model, and deploy it to the server. 

•	 Define a business space dashboard to view monitored data. 

Introduction 

In this lab you will learn how to deploy a monitor model from end to end using WebSphere Business 
Modeler, IBM Integration Designer, and IBM Business Monitor. This lab will show you the basic procedure 
for creating and implementing a simple model. 

The model used in this lab is the ClipsAndTacks model. In this lab you will create monitoring constructs 
in support of two KPIs: 

•	 Average order fulfillment is three days or less 

•	 Percentage of shipped orders is greater than 90% 

You will also create situation events when the average order fulfillment time is greater than three days, and 
when the percentage of orders shipped is less than 85%. 

For dimensional analysis, you will create a Location dimension which allows you to drill down on country 
and city. You will also add an Order Status metric, which shows orders as 'New', 'Cancelled' or 'Shipped', 
and you will create a dimension based on order status so that you can drill down on this value. And you 
will add measures for average order price, sum of order price for all orders, and order count. 

Here is a diagram of the ClipsAndTacks process model: 
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This is the ordering process for the Clips and Tacks company. In this process, orders are received and 
optionally submitted to a review process. Orders which pass all checks are shipped to the customer. Other 
orders may be cancelled. 

In this lab you will use Modeler and import a process model which was created for you. You will select 
processing time and decision percentage monitored values in the business measures model in Modeler. 
Then you will export the process model and monitor model to IBM Integration Designer. You will import a 
solution file that contains the process implementation. Then you will complete the implementation of the 
monitor model. You will deploy the monitor model, run process instances, and view results in the business 
space dashboard. Finally, you will export monitored values back to Modeler. 

URL cheat sheet 

These URLs might be helpful to you as you exercise this lab. Note that the port numbers in the URL of 
your installation may be different depending on your configuration. 

• Server administrative console 

https://localhost:9043/ibm/console 

• Business space dashboard 

https://localhost:9443/BusinessSpace 
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Part 1: Import the model into Modeler 

Instead of building the process model from scratch, you will import the model into WebSphere Business 
Modeler. You will review the process model and the business measures model. 

____ 1. Start WebSphere Business Modeler and setup the environment. 

__ a. Start WebSphere Business Modeler, and when prompted point to a new workspace such as 
c:\workspaces\clipsmodel 

__ b. Close the Getting Started tab. 

__ c. Click Modeling > Mode > WebSphere Process Server. 

__ d. Click the icon in the toolbar to apply the four pane layout. 

____ 2. Import the supplied Modeler project. 

__ a. Right click in the Project Tree, and then select Import… 

__ b. Select WebSphere Business Modeler project (.mar, .zip)
 

__ c. Click Next.
 

__ d. For source directory, browse to the folder containing the supplied mar file, for example,
 
c:\Labfiles75\ClipsAndTacksBPEL 

__ e. For files, select CATOrderMgmt.mar.
 

__ f. Click Finish.
 

____ 3. Review the process. 

__ a. In the Project Tree, navigate to CATOrderMgmt > Processes > Order Handling, then double 
click the process to open the editor. In the editor, you can review the diagram which represents 
the process model. Notice that there are various tasks, decisions, human tasks, and a business 
rule. 
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__ b. For each task in the diagram, click the task, then click the Attributes tab and review the 
information. For implementation details, click the Technical Attributes View tab. You will see 
these implementations: 

1) Check Order Handling Policy for Automatic Approval – rule group. Click the Business Rules 
tab and you will find that a business rule is used to check the order price and require 
manual approval if it is greater than or equal to $750. 

2) Review Order – human task
 

3) Ship Order to Customer – human task
 

4) Check Customer Account Status – java
 

5) Cancel Order and Send Notification – java
 

6) Update Order Database – java 
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Part 2: Create the business measures model in Modeler 

In this section you will create the business measures model in Modeler. You will select monitored values 
for decision percentages and processing times. You will also add aggregate measures, dimensions, and 
KPIs. 

If you want to skip this section, a solution has been provided. You can import the supplied Modeler MAR 
file and then proceed to the next section. Refer to Appendix 1, and then proceed to the next section. 

____ 1. Select monitored values 

__ a. In Modeler, to open the business measures tab, select Window > Business Measures 

__ b. Click the white background of the process diagram. 

__ c. Click the Business Measures tab, then click the Monitored Values tab. 

__ d. On this tab is a list of all the elements in the process, including the decisions and tasks. If you 
select any of these items, then the corresponding business metrics are created automatically in 
the Business Performance Indicators tab. Select '% Per Branch' for the three decisions. Also 
select 'Processing Time' for the process and the six tasks. 

__ e. On the Business Performance Indicators tab, review the metrics that were created based on your 
monitored values selections. 

2011 September, 27 IBM Business Monitor 7.5 – Lab exercise Page 6 of 47 

ClipsAndTacks 



        

              

  

 

                 
                 

                  
   

                 
       

                   
 

                   

 

                
 

© Copyright IBM Corporation 2011. All rights reserved 

____ 2.	 Create a dimension for location. Since you want to perform dimensional analysis by country and 
city, then you need to add the Location dimension. You cannot specify a two level dimension in 
Modeler, so you will just create a single level here, and then you will complete the implementation in 
the Monitor toolkit. 

__ a. On the Business Performance Indicators tab, double click the first aggregate metric in the list. 
This opens the Business Measures Details window. 

__ b. On the Business Measure Details tab, select the check box to specify the dimensions that will be 
available. 

__ c. Click the Add button, then highlight the default name of the dimension and change it to Location. 

__ d. Leave the Business Measures Details window open. You will be adding metrics using this 
window. 
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____ 3. Create a KPI for average process duration. 

__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button. 

__ b. Change the name to Average Process Duration KPI 

__ c. For type, select KPI. 

__ d. On the Business Measure Details tab set the following values: type duration, target 3 days, range 
Good 1 to 3 days, range Too long 3 to 5 days, time period repeating yearly, specify an alert with 
default name 

1) Select the check box to specify a target 

2) Target type – Duration 

3) Target value – 3 Days 

4) Select the check box to specify a range 

5) Select button for range Actual Value 

6) Add range 'Good' with start value 1 day and end value < 3 days 

7) Add range 'Too long' with start value 3 days and end value < 5 days 
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8) Select the check box to specify an alert
 

9) Add an alert and take the default name 'Average Process Duration KPI Alert'
 

10) Select the check box to specify how to calculate the KPI
 

11) Select the button to based the KPI on a metric and aggregation function
 

12) Set the instance metric to aggregate to 'Order Handling Processing Time'
 

13) Set the aggregation function to Average.
 

14) Select the check box to specify a time period 

15) Select button for time period Repeating 

16) Set period type to Yearly, and base period on 'Period in progress' 
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____ 4. Create a KPI for percentage of orders shipped. 

__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button.
 

__ b. Change the name to Percentage of Orders Shipped KPI
 

__ c. For type, select KPI.
 

__ d. On the Business Measure Details tab set the following values: type number, target 90, range 
Low 0 to 85, range Good 85 to 90, range Great 90 to 100, specify an alert with default name 

__ e. You would normally select how to calculate the KPI, but for this KPI you will leave this to the 
developer to determine 

__ f. No time period is required. 

____ 5. Create a measure to track the total order count. 

__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button. 

__ b. Change the name to Order Count 

__ c. For type, select Aggregate metric. 

__ d. On the Business Measure Details tab set the following values: function count, instance metric 
'Order Handling Processing Time'. Note that you could select any instance metric in the model to 
count and this aggregation will work fine. 

____ 6. Create a measure to count shipments. 

__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button.
 

__ b. Change the name to Ship Count
 

__ c. For type, select Aggregate metric.
 

__ d. On the Business Measure Details tab set the following values: function average, do not specify 
an instance metric since you are not sure how to calculate this so just leave it up to the 
developer. 

____ 7. Create a measure to count declined orders. 
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__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button. 

__ b. Change the name to Decline Count 

__ c. For type, select Aggregate metric. 

__ d. On the Business Measure Details tab set the following values: function average, do not specify 
an instance metric since you are not sure how to calculate this so just leave it up to the 
developer. 

____ 8.	 Create a metric for price so that you can use that metric as a source for aggregations that will 
average the order prices and total the order prices. 

__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button. 

__ b. Change the name to Price 

__ c. For type, select Instance metric. 

__ d. On the Business Measure Details tab set the following values: template 'Business Item Input', 
process element 'Order Handling', attribute 'Order.TotalPrice(Input) 

____ 9. Create a measure to sum order price. 

__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button. 

__ b. Change the name to Sum Order Price 

__ c. For type, select Aggregate metric. 

__ d. On the Business Measure Details tab set the following values: function sum, instance metric 
'Price', take the default dimension 'Location'. 

____ 10. Create a measure to average order price. 

__ a. In the Business Measures navigator on the left of the Business Measure Details window, click 
the Add button. 

__ b. Change the name to Average Order Price 

__ c. For type, select Aggregate metric. 

__ d. On the Business Measure Details tab set the following values: function average, instance metric 
'Price' 

____ 11.	 Click OK. 

____ 12.	 Press Ctrl-S to save your work. 
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Part 3: Export to IBM Integration Designer 

In this section you will export the business process and the business measures model to IBM Integration 
Designer. 

____ 1. Export to IBM Integration Designer. 

__ a. Right click in the Project Tree on CATOrderMgmt, then select Export then on the next panel 
select WebSphere Integration Developer. 

__ b. Click Next. 

__ c. Browse to a target directory. Select 'Export entire project and related projects'. 

__ d. Click Next. 

__ e. Take the defaults on this panel including the recommended export option.
 

__ f. Click Next.
 

__ g. On the next panel select 'Export business measures as a monitor model or models'. Also select
 
'Export to a single monitor model…'. 
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__ h. Click Finish. 

____ 2. This creates two project interchange files at the specified target location. 

__ a. Process file - CATOrderMgmt_<timestamp>.zip 

__ b. Business measures file – CATOrderMgmt_Monitor_<timestamp>.zip 

____ 3. Close WebSphere Business Modeler. 
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Part 4: Import the process into IBM Integration Designer and implement 
the activities 

In this section you will import the process from Modeler into IBM Integration Designer. Normally, then you 
would implement the various activities in the process, but to save some time you will import a solution 
which already has the implementation for the activities. Using the best practice approach, Modeler has 
automatically created three separate projects, one for the process (CATOrderMgmt), one for the 
implementation (CATOrderMgmt_impl) and one for a library of common elements (CATOrderMgmt_lib). 

____ 1.	 Start IBM Integration Designer and setup the environment. 

__ a. Start IBM Integration Designer, and when prompted point to a new workspace such as 
c:\workspaces\clipsbpm 

__ b. Close the Welcome tab. 

__ c. By default, you are in the Business Integration perspective. 

____ 2.	 Import the process. 

__ a. In the Business Integration view, right click then select Import… 

__ b. Navigate to Other > Project Interchange then click Next. 

__ c. For the .zip file, browse to the process output file from Modeler, for example, 
'CATOrderMgmt_2008-06-15T10.12.26.zip'. Note that the timestamp in your file name will be 
different. 

__ d. You should see three projects listed, so click Select All. 

__ e. Click Finish. 

__ f. A migration panel is shown, click Next. Click Next. Click Next. Click Finish. 

__ g. You should see a message indicating that the migration was successful. Click OK. 

__ h. You should see three projects listed in the Business Integration view, one for the process 
(CATOrderMgmt), one for the implementation (CATOrderMgmt _impl) and one for a library of 
common elements (CATOrderMgmt _lib): 

____ 3.	 At this point, you could add the implementations for the human tasks, business rule, and Java code. 
However, to save some time, you will import the solution which has already been updated with the 
implementations. 

__ a. In the Business Integration view, right click then select Import… 

__ b. Navigate to Other > Project Interchange then click Next. 

__ c. For the .zip file, browse to the supplied file, for example, 
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c:\Labfiles75\ClipsAndTacksBPEL\CATOrderMgmt_ProcessSolution_PI.zip 

__ d. Select all projects. 

__ e. Click Finish. Click OK to confirm overwrite. 

__ f. If you see errors in the problems view, then try to clean the workspace by selecting Project > 
Clean … > select 'Clean all projects' , then click OK. 

__ g. If you want to review the implementation, in the Business Integration view, navigate to 
CATOrderMgmt_impl > Integration Logic. You will find three Java implementations. 

1) CheckCustomerAccountStatusImpl – Java is used to calculate the credit amount for the 
customer. When you run an instance of the business process, you will enter the old credit 
rating and old credit amount. This routine calculates a new credit rating which is a random 
number between 500 and 800. It calculates a new credit amount which is based on an 
adjustment to the old credit amount, using this formula: newAvailCredit = oldAvailCredit 
+((newRating-oldRating)*0.1). 

2) The other two Java implementations just print messages to the log. 

__ h. If you want to review the BPEL process, in the Business Integration view, navigate to 
CATOrderMgmt > Integration Logic > Processes > processes\orderhandling, then double 
click OrderHandling to open the BPEL editor. This is a summary of the flow: 

1) Check Order Handling Policy for Automatic Approval. Implemented as a business rule. If 
Order.totalPrice < 750, go to Check Customer Account Status, else go to Review Order 

2) Check Customer Account Status. Implemented as Java to calculate a new credit amount. If 
Order.totalPrice > new credit amount, go to Review Order else go to Ship Order to 
Customer. 

3) Review Order. Implemented as a human task. If ReviewOrder.OrderStatus is APPROVED 
then go to Ship Order to Customer else if ReviewOrder.OrderStatus is DECLINED go to 
Cancel Order and Send Notification. 

4) Ship Order to Customer. Implemented as a human task. Goes to Update Order Database. 

5) Cancel Order and Send Notification. Implemented as Java to print messages to the log. 
This is the end of the flow. 

6) Update Order Database. Implemented as Java to print messages to the log. This is the end 
of the flow. 
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Part 5: Verify that the BPEL process emits monitor events 

When you export the process from Modeler, the events that are required for monitoring are already 
selected to be emitted. Monitor will need events for the process and the invoke activities in the process. 
Modeler decisions become links in BPEL, so Monitor also needs events for the flow element in BPEL. 

____ 1. In the Business Integration view, navigate to CATOrderMgmt > Integration Logic > Processes > 
processes\orderhandling, then double click OrderHandling to open the BPEL editor. 

____ 2. Click the white backbround of the process. Make sure that you click outside of the flow element 
which is the large rectangle that contains the receive, reply and invoke elements . Then click the 
Properties tab, then click the Event Monitor tab. Note that all process events are selected. 

____ 3. Click inside the flow element OrderHandling_Flow, and note on the Event Montor tab that all the 
events are selected. 

____ 4. Select each invoke in the BPEL diagram and note on the Event Monitor tab that all the events are 
selected. 

____ 5. Here is a screen capture that shows the small yellow flags that indicate that the events are selected 
for the components. There are flags on the receive activity and each of the six invoke activities. The 
flag in the upper left in the diagram represents the flow. The flag in the upper right menu item ‘Order 
Handling’ represents the process. So there are nine flags in total. 
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Part 6: Import the business measures into IBM Integration Designer and 
implement the monitor model 

In this section you will import the business measures from Modeler into IBM Integration Designer. This 
section shows you how to complete the implementation of the monitor model. 

If you want to skip this section, a solution has been provided. You can import the supplied project 
interchange file and then proceed to the next section. Refer to Appendix 2, and then proceed to the next 
section. 

____ 1.	 Switch to the Business Monitoring Perspective 

__ a. In the upper right corner, click the perspective icon and select Business Monitoring. 

____ 2.	 Import the business measures from Modeler. 

__ a. In the Project Explorer view, right click then select Import… 

__ b. Navigate to Other > Project Interchange then click Next. 

__ c. For the .zip file, browse to the business measures output file from Modeler, for example, 
'CATOrderMgmt_Monitor_2008-06-15T10.12.26.zip'. Note that the timestamp in your file name 
will be different. 

__ d. You should see one project listed, so select it. 

__ e. Click Finish. 

__ f. You should see the new project CATOrderMgmt_Monitor listed in the Business Integration view. 
Note that it has a red 'x' marker because there are errors due to missing elements in the monitor 
model. 

____ 3.	 Open the Order Handling Monitor monitor model. 

__ a. In the Project Explorer navigate to CATOrderMgmt_Monitor > Monitor Models and double click 
‘Order Handling_Mon.mm’ 

____ 4.	 Review the monitor model. In the Monitor Details Model tab, you see there is a monitoring context 
for the process and one monitoring context for each activity in the process. On the inbound events 
for the process and activities, the correlation information is already setup. There are also termination 
triggers setup for you. And notice the metrics and stopwatches that are in the model for calculation 
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of the processing times and decision percentages. On the KPI Model tab, you see the two KPI's 
along with triggers for alerts. One of the KPI's needs implementation details so it has a red marker. 
In the dimensional model tab, you see the measures in the Order Handling Cube. Several 
dimensions have red markers because they need implementation details. On the Visual Model tab, 
you see there are two SVG diagrams installed, one for the process and one for the KPI context 
(Order Handling and Order Handling KC). On the Event Model tab, expand the listing for 
/CATOrderMgmt_lib/businessitems/businessitems.xsd, and you will see the business item schema 
definitions which are located in the process library CATOrderMgmt_lib. 

____ 5. Click the KPI Model tab. 

____ 6. In the KPI model, update Average Process Duration KPI Trigger 1. This trigger is used to fire the 
situation event when the process duration is too long. 

__ a. For Trigger condition, enter this expression: 

Average_Process_Duration_KPI ge dayTimeDuration('P3DT1H') 

____ 7. In the KPI model, update Percentage of Orders Shipped KPI Trigger 1. This trigger is used to fire 
the situation event when the percentage of shipped orders is too small. 

__ a. In the trigger source table, click Add 

__ b. Select Recurring wait time, then click OK. This will default to 1 minute. 

__ c. For Trigger condition, enter this expression: 

Percentage_of_Orders_Shipped_KPI < 85 

____ 8.	 Press Ctrl-S to save your work. 

____ 9.	 In the KPI model, update the KPI Percentage of Orders Shipped KPI. In order to calcuate the 
percentage of orders shipped you will create a KPI for the number of shipped orders, and you will 
create another KPI for the total number of orders, then you can determine the percentage by 
dividing the shipped orders by the total orders. 

__ a. In the details model, create a new trigger Shipped Order Trigger 

1) Right click in the Monitor Details Model navigator on the Order Handling monitoring 
context, and select New > Trigger 

2) Enter name: Shipped Order Trigger, click OK 
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3) In trigger sources, click Add, then select Other source type, navigate to Order Handling > 
Ship Order to Customer > Ship Order to CustomerEXIT, click OK 

__ b. In the details model, create a new trigger Cancelled Order Trigger 

1) Right click in the Monitor Details Model navigator on the Order Handling monitoring 
context, and select New > Trigger 

2) Enter name: Cancelled Order Trigger, click OK 

3) In trigger sources, click Add, then select Other source type, navigate to Order Handling > 
Cancel Order and Send Notification > Cancel Order and Send NotificationEXIT, click OK 

__ c. In the details model, create a new metric Order Status 

1) Right click in the Monitor Details Model navigator on the Order Handling monitoring 
context, and select New > Metric 

2) Enter name: Order Status, enter type: String, click OK 

3) Select 'A value is required for this metric', since a dimension will use this metric and that 
requires a value for dimensional analysis. 

4) For Default value, enter 'New' with the quotation marks. 

5) In Metric value expressions, click Add. In the trigger cell, enter trigger type Cancelled Order 
Trigger. In the expression cell, enter 'Cancelled' with the quotation marks. 

6) In Metric value expressions, click Add. In the trigger cell, enter trigger type Shipped Order 
Trigger. In the expression cell, enter 'Shipped' with the quotation marks. 

__ d. In the KPI model, create a new KPI Shipped Orders. You will use the key metric to count all 
incoming instances, then filter it by the order status so you only count shipped orders. You will 
also filter it by the process state, so only completed process instances are counted. 

1) In the KPI model navigator, right click Order Handling KC and select New > KPI. 

2) Enter name Shipped Orders, click OK. 
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3) Set the type to decimal. 

4) Select 'Keep track of historical values for this KPI' 

5) For KPI value, select 'Base this KPI on a metric and an aggregation function' 

6) For monitoring context, browse to Order Handling 

7) For metric, browse to Order Handling Instance ID. 

8) For aggregation function, select Count 

9) For data filter, click Add, then browse to Order Handling > Order Status, then click OK. In 
the values cell, enter 'Shipped' with the quotation marks. 

__ e. In the KPI model, create a new KPI Total Orders. You will use the key metric to count all 
incoming instances. 

1) In the KPI model navigator, right click Order Handling KC and select New > KPI.
 

2) Enter name Total Orders, click OK.
 

3) Set the type to decimal.
 

4) Select 'Keep track of historical values for this KPI'
 

5) For KPI value, select 'Base this KPI on a metric and an aggregation function'
 

6) For monitoring context, browse to Order Handling
 

7) For metric, browse to Order Handling Instance ID. 

8) For aggregation function, select Count 

__ f. Finalize the KPI, Percentage of Orders Shipped KPI 

1) In the KPI model navigator, select the KPI Percentage of Orders Shipped KPI
 

2) For KPI Value, select 'Write an expression to calculate this KPI based on existing KPIs'
 

3) For KPI Calculation, enter:
 

(Shipped_Orders div Total_Orders) * 100
 

____ 10. Press Ctrl-S to save your work. 
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____ 11.	 Create the shipped percentage situation event which will use the built-in ActionServicesEvent 
definition. This event contains a field called BusinessSituationName which is a required field for the 
outbound situation event. Then you will define an outbound event which is fired by the trigger. In this 
outbound event, you will provide a value for the field BusinessSituationName which will be used 
later when configuring action manager in the server administrative console. 

__ a. Click the KPI Model tab
 

__ b. Right click in the navigator on Order Handling KC, select New > Outbound Event
 

__ c. For name, enter Shipped Percentage Event
 

__ d. Select the check box for 'Configure this event to generate an alert in the dashboards'
 

__ e. For trigger, browse to Order Handling KC > Percentage of Orders Shipped KPI Trigger 1
 

__ f. Click OK
 

__ g. Notice that the extension name defaults to the ActionServicesEvent.
 

__ h. In the Outbound Event Content, navigate to Percentage of Orders Shipped KPI Trigger 1 >
 
Extended Data > BusinessSituationName, and notice that the expression is already set. 

____ 12.	 Press Ctrl-S to save your work. 

____ 13.	 Create the order processing time situtation event. You will create an event definition containing a 
field called BusinessSituationName which is a required field for the outbound situation event. You 
will also create a field to store the average processing time to display in the alert. Then you will 
define an outbound event which is fired by the trigger. In this outbound event, you will provide a 
value for the field BusinessSituationName which will be used later when configuring action manager 
in the server administrative console, and you will supply the data source for the average processing 
time in the event. 

__ a. Create an event definition for average order processing time. 

1) In Project Explorer, right click CATOrderMgmt_Monitor and select New > Event 
Definition…(cbe) 

2) For file name, enter LateAverageOrderShippedEvent.cbe
 

3) Click Finish
 

4) The Event Definition Editor for LateAverageOrderShippedEvent opens.
 

5) Double click the hierarchical icon next to the label Parent.
 

6) On the Select Event Definition Dialog double click event.
 

7) Event is now shown as the parent of LateAverageOrderShippedEvent
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8) On the event definition, click the icon for Add Extended Data . This adds a row to the 
Extended Data table. 

9) For the new data element, change the Extended Data name from 'data1' to 
'BusinessSituationName' by clicking on data1 and typing the new name. 

10) For the new element, change the type to string. Do this by clicking on 'noValue' and then 
you are given a drop down box. 

11) On the event definition, click the icon for Add Extended Data. This adds a second row to 
the Extended Data table. 

12) For the second data element, change the Extended Data name to 
AverageOrderProcessingTime 

13) For the second element, change the type to string. 

14) Press Ctrl-S to save your work. 

__ b. Create the outbound event Order Fulfillment Event 

1) Click the KPI Model tab 

2) Right click in the navigator on Order Handling KC, select New > Outbound Event 

3) For name, enter Order Fulfillment Event 

4) Select the check box for 'Configure this event to generate an alert in the dashboards' 

5) For trigger, browse to Order Handling KC > Average Process Duration KPI Trigger 1 

6) Click OK 

7) In Event Type Details, for extension name, browse to CATOrderMgmt_Monitor > 
LateAverageOrderShippedEvent.cbe > LateAverageOrderShippedEvent, then click OK. 

8) In the Outbound Event Content, navigate to Average Process Duration KPI Trigger 1 > 
Extended Data > BusinessSituationName, and notice that the expression is already set. 
For AverageOrderProcessingTime, set the expression to 

xs:string(Average_Process_Duration_KPI div xs:dayTimeDuration('P1D')) 

This will display the average process duration in day units. 

____ 14. Press Ctrl-S to save your work. 

____ 15. Click the Dimensional Model tab. 
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____ 16.	 In the navigator, locate Order Handling > Order Handling Cube. All of the dimensional work will be 
performed in this cube. 

____ 17.	 Delete Decline Count, Order Count, and Ship Count. You can get this information using the built-
in function Instances Count in the Dimensional view of the dashboard, and then creating a 
dimension on order status which is a metric which identifies new orders, shipped orders and 
cancelled orders. 

____ 18.	 Create dimension Order Status. This will be useful for drilling down in the Dimensional view of the 
dashboard to aggregate instances by their order status. 

__ a. Right click in the Dimensional Model navigator on Order Handling Cube, then select New > 
Dimension. 

__ b. Name it Order Status and click OK. 

__ c. Right click Order Status in the navigator, then select New > Dimension Level 

__ d. Name it Order Status, then click Browse next to Source Metric, and navigate to Order Handling > 
Order Status, then click OK. 

__ e. Click OK. 

____ 19.	 You want a multi-level dimension called Location which will allow you to drill down on country and 
then city within country. To enable Location, you need to create metrics for country and city, then 
you can complete the Location dimension to reference the metrics. 

__ a. In the monitor details model, create metric Country 

1) Right click in the Monitor Details Model navigator on Order Handling, and select New > 
Metric 

2) Enter name: Country, enter type: String, click OK 

3) Select 'A value is required for this metric', since a dimension will use this metric and that 
requires a value for dimensional analysis. 

4) For default value, enter an empty string (two single quotation marks) 

5) In Metric Value Expressions, click Add. In the expression cell, use content assist to navigate 
to the event ‘Check Order Handling Policy for Automatic Approval ENTRY’ and select 
Country in the Input data in the Customer record. 

Check_Order_Handling_Policy_for_Automatic_Approval/Check_Order_Handling_Policy_for_A 
utomatic_ApprovalENTRY/Input/Customer/Country 

__ b. In the monitor details model, create metric City 

1) Right click in the Monitor Details Model navigator on Order Handling, and select New > 
Metric 

2) Enter name: City, enter type: String, click OK 
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3) Select 'A value is required for this metric', since a dimension will use this metric and that 
requires a value for dimensional analysis. 

4) For default value, enter an empty string (two single quotation marks) 

5) In Metric Value Expressions, click Add. In the expression cell, use content assist to navigate 
to the event ‘Check Order Handling Policy for Automatic Approval ENTRY’ and select City 
in the Input data in the Customer record. 

Check_Order_Handling_Policy_for_Automatic_Approval/Check_Order_Handling_Policy_for_A 
utomatic_ApprovalENTRY/Input/Customer/City 

__ c. In the Dimensional model, update the Location dimension using the two metrics. 

1) In the Dimensional Model, navigate to the Order Handling Cube > Location. Notice that 
there is a dimension level called Location underneath the dimension Location. 

2) Right click the dimension level underneath the Location dimension and select delete. This 
will delete the dimension level, but the dimension will remain. 

3) Right click dimension Location, then select New > Dimension Level 

4) Name it Country, then click Browse next to Source Metric, and navigate to Order Handling > 
Country, then click OK. 

5) Click OK. 

6) Right click Location in the Dimensional Model navigator, then select New > Dimension 
Level 

7) Name it City, then click Browse next to Source Metric, and navigate to Order Handling > 
City, then click OK. 

8) Click OK. 

9) In the navigator you should see Location listed with two sub-levels as follows: 

____ 20. Press Ctrl-S to save your work.
 

____ 21. Select Project > Clean…, then select 'Clean all projects', then click OK.
 

____ 22. Check for any errors in the Problems view. You should resolve any errors before continuing.
 
Warnings and informational messages may be present but these will not be a problem. 
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Part 7: Generate and publish the model to the server 

In this section you will use IBM Integration Designer to publish the monitor model to the monitor server. 

____ 1.	 You should first verify that the 'valid from date' in the process matches the monitor model. This can 
be a problem if you imported the process solution but did not import the monitor solution. But it is a 
good practice to verify the 'valid from date' in any case. 

__ a. In Project Explorer, expand CATOrderMgmt_Monitor > Monitor models > Order 
Handling_Mon.mm and open it by double clicking on it. 

__ b. In the monitor details model, navigate to Order Handling > Order Handling, then scroll to find 
the first inbound event that is in the list. Then click it to select it. 

__ c. In the details page, check the filter condition and look for 'processTemplateValidFrom' and note 
the exact date and time that is listed. 

__ d. Switch to the Business Integration perspective. 

__ e. In the Business Integration view, navigate to CATOrderMgmt > Integration Logic > Processes 
> processes\orderhandling, then double click OrderHandling to open the BPEL editor. 

__ f. Click the white background canvas outside of the box that surrounds the flow. 

__ g. Click Properties > Details, then verify that the date and time listed is the same as the 
processTemplateValidFrom date and time in the monitor model. Note that the process valid from 
time is adjusted by the time zone offset, so compare them after adjusting for the time zone. In 
this example, the monitor model shows GMT time 19:39:57, but the process shows 13:39:57 
because it is GMT minus 6 hours, so these times match after accounting for the time zone 
adjustment. 
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__ h. If the date or time is different on the process, then update it to match the one in the monitor 
model. 

__ i. Press Ctrl-S to save your work. 

____ 2. Open the Business Monitoring perspective. 

____ 3. In Project Explorer, expand CATOrderMgmt_Monitor > Monitor models > Order 
Handling_Mon.mm. Right click and then select Generate Monitor JEE Projects from the pop-up 
menu 

____ 4. Select Finish. 

____ 5. A progress dialog shows the status of the operation and it closes when the operation is complete. 
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If 
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean… > 
select 'Clean all projects', then click OK. 

____ 6. Click the Servers tab, and make sure that your server is started. If not then right click and select the 
Start option to start the server. This may take a few minutes to complete. 

____ 7. Right click in the servers view, then select Add and Remove Projects…. 

____ 8. Click to move CATOrderMgmt_implApp, CATOrderMgmtApp and Order 
Handling_MonApplication, from the list of available projects to the list of configured projects. 

____ 9. Click Finish. 

____ 10. A progress message is displayed in the lower right corner of the window. 

____ 11. When the publishing is complete, the applications should show started in the Servers view: 

____ 12.	 If you are using the integrated server within IBM Integration Designer, then you do not need to setup 
Monitor data security, since the administrative user is automatically authorized to all models. If you 
are using a different server, then you should open the administrative console, navigate to Security 
> Monitor Data Security, then add the model, role and user information to a resource group. 
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Part 8: Configure action manager for business situation events 

This section shows you how to configure action manager to create alerts based on business situation 
events defined in the monitor model. The alerts will be visible in the Alert view on your dashboard. 

You do not need an LDAP server to test the situation events. When you configure the notification template, 
you can specify a dashboard login rather than a user registry. 

In this section, you will use the administrative console to configure the alerts. However, you could also 
create business user alerts using the Alert Manager widget in the dashboard. In a production environment, 
an end user could use the alert manager widget to manage the business user alerts; however, an IT 
administrator would manage the modeled alerts in the administrative console. 

____ 1. Start the administrative console. 

__ a. In the Servers view, right click the Monitor server and select Run administrative console. 

__ b. Enter 'admin' without the quotation marks for both user ID and password. 

____ 2. Verify the federated repository service provider URL. 

__ a. In the administrative console, navigate to Applications > Monitor Services > Monitor Action 
Services > Configuration > Federated Repositories. 

__ b. In the Service provider URL field, type the URL of the federated repositories server that is used 
to connect to the user registry. For a stand-alone server, this value might be localhost:2809. 
For a network deployment environment, this field must be set to the deployment manager host 
name plus the deployment manager BOOTSTRAP_ADDRESS port (separated by a colon). To 
determine the bootstrap port, in the WebSphere Application Server administrative console, click 
Servers > Server Types > WebSphere application servers > server1. Under Communications, 
click Ports. 

__ a. To save the settings you entered, click Apply or OK. 

__ b. To make these changes effective, stop and restart the IBM Business Monitor server. 

____ 3. Add a template for shipped percentage alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Services > Monitor Action 
Services > Template Definitions > Notifications. 

__ b. Click New.
 

__ c. Enter AlertShip as Template name and a description.
 

__ d. Select Dashboard Alert.
 

__ e. Select User id.
 

__ f. For the To field, enter admin. This user ID is the one that will receive the alert, so you must log 
into the dashboard with this user ID. 

__ g. Enter a subject, such as 'Percentage of shipped orders'
 

__ h. Enter the body, such as 'Percentage of shipped orders is less than 85.'
 

__ i. Click OK.
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____ 4. Add a template for order processing time alerts. 

__ a. In the administrative console, navigate to Applications > Monitor Services > Monitor Action 
Services > Template Definitions > Notifications. 

__ b. Click New. 

__ c. Enter AlertTime as Template name and a description.
 

__ d. Select Dashboard Alert.
 

__ e. Select User id.
 

__ f. For the To field, enter admin. This user ID is the one that will receive the alert, so you must log
 
into the dashboard with this user ID. 

__ g. Enter a subject, such as 'Order processing time'. 

__ h. Enter the body, and you can optionally enter a substitution variable as shown below. For the 
actual alert that is sent, the average order processing time from the event payload will be 
substituted for %AverageOrderProcessingTime% in the body. For example: 

The average order processing time is %AverageOrderProcessingTime% days. 

__ i. Click OK. 

____ 5. Add the binding from the situation event to the action type for shipped percentage. 

__ a. In the administrativeconsole, navigate to Applications > Monitor Services > Monitor Action 
Services > Installed Situation Event Bindings. 

__ b. Click New. 

__ c. Enter the situation event name that you defined in the model. In this lab, you created a business 
situation name as follows: 

Shipped Percentage Event 

__ d. This must match exactly the value in the BusinessSituationName field in the outbound event. 
You may want to copy/paste from the model, but do not copy the quotation marks. Here is a 
screen capture from the model showing the Shipped Percentage Event attributes: 

__ e. Enter a description, then click Apply. 
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__ f. Click Add. 

__ g. Enter a binding name such as AlertShip, then select the template AlertShip. 

__ h. Click OK. 

__ i. Notice that you now have one action defined for this situation event. If you had other action 
templates defined then you could add more actions to this event. So then you could send a 
notification for this situation to multiple destinations including email, alerts, and web services. 

__ j. Click OK. 

____ 6. Add the binding from the situation event to the action type for order processing time. 

__ a. In the administrativeconsole, navigate to Applications > Monitor Services > Monitor Action 
Services > Installed Situation Event Bindings. 

__ b. Click New. 
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__ c. Enter the situation event name that you defined in the model. In this lab, you created a business 
situation name as follows: 

Order Fulfillment Event 

__ d. . This must match exactly the value in the BusinessSituationName field in the outbound event. 
You may want to copy/paste from the model, but do not copy the quotation marks. Here is a 
screen capture from the model showing the Order Fulfillment Event attributes: 

__ e. Enter a description, then click Apply.
 

__ f. Click Add.
 

__ g. Enter a binding name, then select the template AlertTime, then click OK.
 

__ h. Click OK. 

____ 7.	 In the administrative console, navigate to Applications > Monitor Services > Monitor Action 
Services > Installed Situation Event Bindings. You should see the two bindings that you created. 
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Part 9: Run events to exercise the model 

In this section you will use the business process choreographer explorer to run process instances. 

There are five different paths to take through the model. For each path, here are sample data elements that 
will invoke the listed path: 

a. Approve without review, account in good standing, ship 
i. Start instance: rating – 800, available credit – 800, total price – 20 
ii. Ship task: no required elements 

b. Approve without review, account not in good standing, approve the order, ship 
i. Start instance: rating – 800, available credit – 100, total price – 200 
ii. Review task: order status – APPROVED 
iii. Ship task: no required elements 

c. Approve without review, account not in good standing, decline the order 
i. Start instance: rating – 800, available credit – 100, total price – 200 
ii. Review task: order status – DECLINED 

d. Do not approve without review, approve the order, ship 
i. Start instance: rating – 10, available credit – 10, total price – 900 
ii. Review task: order status – APPROVED 
iii. Ship task: no required elements 

e. Do not approve without review, decline the order 
i. Start instance: rating – 10, available credit – 10, total price – 900 
ii. Review task: order status – DECLINED 

In order to see an alert in the alerts view of the dashboard, you will need the number of shipped orders to be 
less than 85 percent of the total number of orders. An easy way to achieve this is to process one DECLINED 
order, then before you add any other process instances, go to the dashboard section of this document and 
create a dashboard to view the alerts. 

In the procedure below, you will use the Process Choreographer Explorer to start instances of the business 
process. If you start an instance of a business process, you may see an error similar to: “The business 
category ‘Process’ does not exist”. This could happen because you have business categories enabled on the 
server but you do not have the ‘Process’ category defined. To fix the problem you have two options: 

a.	 In the administrative console, select Servers > Server Types > WebSphere application servers 
> server1. Under Business Integration > Human Task Manager. Under Additional Properties 
> Custom properties. Change the value of ‘BusinessCategoryEnabled’ to false, restart the 
server. 

b.	 In the administrative console, select Servers > Server Types > WebSphere application servers 
> server1. Under Business Integration > Business Space Configuration > REST service 
endpoint registration. For types ‘Process services’ and ‘Task services’ select ‘Business 
Process Choreographer REST services’. Click OK. A server restart is not required. In 
Business Space, create a space using template ‘Configure Work Baskets and Business 
Categories’. Open the space, select the ‘Business Categories’ tab, then use the category 
widgets to create a business category with identifier ‘Process’. 

____ 1.	 In the Servers view, right click server IBM Business Monitor Server v7.5 > Launch > BPEL 
Process Choreographer Explorer 

____ 2.	 Click Process Templates > Currently Valid 
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____ 3. Select Order Handling, then click Start Instance 

____ 4. In the following data entry page, enter a unique value for the process name, then enter values for 
the fields in the various business objects listed. You can use just one line item for OrderItems, The 
values for Rating, AvailableCredit, and TotalPrice determine which paths the process will take. See 
the introduction to this section for more information. 

____ 5. Click the Submit button. 
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____ 6.	 Select Task Instances > My To-do's. Here you will find either the Review Order task or the Ship 
Order to Customer task, depending on the values that you entered when you started the process 
instance. 

____ 7.	 To complete a task, select the check-box for it, then click 'Work on'. You will be given a page to 
enter values for the task. You should enter the values in the section for the task output message. 

__ a. For the ship task, you can just press the Complete button, since the data elements are not 
required values for this process. 

__ b. For the review task, you should enter 'APPROVED' or 'DECLINED' (without the quotation marks) 
into the OrderStatus field. The other fields are optional for this process, so you can choose to not 
enter them to save time. Then press the Complete button. 

__ c. This screen capture shows the review task and the string 'APPROVED' (without the quotation 
marks) has been entered in the OrderStatus field. 
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Part 10: Create a dashboard in business space 

In this section you will configure a dashboard in business space. 

____ 1. Create the dashboard. 

__ a. The default browser is 'Internal Web Browser', but you should not use this one since some 
standard functions are not provided that you may need. Select Window > Preferences > General 
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK. 

__ b. In IBM Integration Designer, in the servers view, right click and select Launch > Business 
Space 

__ c. When prompted, enter the user ID and password. You must log in with 'admin' so that you can 
view the alerts which were setup in action manager to be sent to this particular user ID. 

__ d. Click in the Actions menu to create a new space 

__ e. Enter a name such as Dashboard, and select the Business Monitoring template. 

__ f. Click Save. 
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__ g. On the new space, click the Operational tab. 

____ 2.	 Use the Alerts widget to view the alerts. There are two alerts defined in the model, one for shipped 
percentage and one for order processing time. The latter is based on a processing time greater that 
3 days, so it will be difficult to test here, unless you use the KPI Manager widget to reduce the 
target. The former can be tested easily by ensuring that the number of shipped orders is less than 
85 percent of the number of total orders. 

__ a. You can click an alert in the list, then you will see a pop-up showing the details of the alert. 

__ b. On the widget menu you can select 'Send Widget…' to send a screen capture of the alerts as an 
attachment to a human task. 

____ 3. Use the Instances widget to view the monitored instances. 

__ a. Click the 'Edit Page' link to enter edit mode. 

__ b. To configure the Instances widget, hover the mouse over the right corner of the widget 

and then click the down arrow. Select 'Edit Settings…'. 

__ c. Click the Show/Hide tab, and select monitoring context 'Order Handling'. 

Click button >> to move all the fields to the Selected box. Also, 
click button 'Set as default' which will make this the default monitoring context to display. 
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__ d. Then click OK. You should see a list of monitoring context instances for the events that you just 
processed. 

__ e. Click 'Finish Editing' to save your changes. 

____ 4. Use the KPIs widget to show key performance indicators. 

__ a. Click KPIs tab in the business space. 

__ b. To configure the KPIs widget, hover the mouse over the right corner of the widget and then click 
the down arrow. Select 'Edit Settings…'.
 

__ c. On the tab 'KPIs', select the KPIs to display for the Order Handling model.
 

__ d. Click OK. 
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__ e. In the lower left corner, you can select different display formats for the KPI. 

__ f. The Status column displays icons which represent the value of the KPI relative to the target and 
ranges. Initially this is blank, but you can use the KPI Manager widget to configure them. 

__ g. Click 'Finish Editing' to save your changes. 

__ h. On the widget menu you can select 'Send Widget…' to send a screen capture of the KPIs as an 
attachment to a human task. 

____ 5. Export values to Modeler. Note that you must have some completed monitoring context instances 
for this, so make sure that you have started and completed some process instances before 
exporting the values.
 

__ a. Click Export Values tab in the business space.
 

__ b. Select the Order Handling model.
 

__ c. Click Preview Data to see the data that will be exported.
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__ d. Click Export. 

__ e. The XML is displayed in a browser window, click File > Save page as… or Save as…, then 
select your destination folder and click Save. The file is stored by default as exportvalues.xml. 

__ f. Open WebSphere Business Modeler, and point to the workspace containing your model. 

__ g. In the project tree, navigate to CATOrderMgmt > Processes > Order Handling, and select it
 

__ h. Right click Order Handling, then select Import…
 

__ i. Select WebSphere Business Monitor results (.xml), then click Next.
 

__ j. Browse to the folder containing the exportvalues.xml file.
 

__ k. Select exportvalues.xml, then click Next.
 

__ l. Click 'Display Possible Updates' to see the update summary.
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__ m. Click Finish. 

__ n. Double click the process in the project tree to open the process diagram. Browse the process 
diagram to see the updated values for the six decision percentages. 

__ o. To check the updated process duration time, click the background of the diagram, click the 
Properties tab, click the More tab, select the check box for Duration, click Apply. 

__ p. Select the Duration tab and note the new processing time. 
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__ q. To check the updated task duration times, click one of the tasks in the diagram, click the 
Attributes tab, then click the Duration tab. 
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What you did in this exercise 

In the lab, you imported the model into WebSphere Business Modeler and reviewed the process model. 
You created the business measures model. 

You exported the process model and business measures model to IBM Integration Designer, and imported 
the implemented process solution. 

You completed the implementation of the monitor model. 

You deployed the process and the monitor model, and ran process instances.
 

Finally, you created a dashboard in business space and exported monitored values back to Modeler.
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Appendix 1 – Import the solution into Modeler 

A solution has been provided so that you do not have to build the business measures model from scratch. 
This section shows you how to import the MAR project into WebSphere Business Modeler. After importing 
the project then you can review the business measures model and then proceed to the section to export 
the projects to IBM Integration Designer. 

____ 1. Import the supplied Modeler project. 

__ a. In Modeler, right click in the Project Tree, then select Import… 

__ b. Select WebSphere Business Modeler project (.mar, .zip) 

__ c. Click Next. 

__ d. For source directory, browse to the folder containing the supplied mar file, for example, 
c:\Labfiles75\ClipsAndTacksBPEL 

__ e. For files, select CATOrderMgmt_Solution.mar. 

__ f. Click Finish. 

__ g. If you have the original project previously loaded, then you need to select the option to replace 
elements 

____ 2. To open the business measures tab, select Window > Business Measures 

____ 3. Open the Order Handling process, click the process diagram background, then select the Business 
Measures tab. On this tab you can review the business measures that have been previously 
created. 

____ 4. Now you can proceed to the section to export the projects from Modeler to IBM Integration 
Designer. 
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Appendix 2 – Import the solution into the monitor model editor 

A solution has been provided so that you do not have to build the monitor model from scratch. This section 
shows you how to import the monitor model project into IBM Integration Designer. After importing the 
model then you can proceed to the section to publish the model to the server. 

____ 1.	 Import the monitor model project into IBM Integration Designer. 

__ a. In the Business Integration view, right click then select Import… 

__ b. Navigate to Other > Project Interchange then click Next. 

__ c. For the .zip file, browse to the supplied file, for example,
 

__ d. c:\Labfiles75\ClipsAndTacksBPEL\CATOrderMgmt_MonitorSolution_PI.zip
 

__ e. You should see one project listed, so select it.
 

__ f. Click Finish.
 

____ 2.	 Expand the project in the Project Explorer view, then expand the Event Definitions and you will see 
the events listed. Expand Monitor Models and you will see the model listed. 

Now you can proceed to the section to generate and publish the model to the server. 
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