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IBM BUSINESS MONITOR 7.5 – LAB EXERCISE 

IBM Business Monitor V7.5
 

User defined functions lab
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What this exercise is about 

The objective of this lab is to show you how to use user defined functions in the monitor model. You will 
review the Java project that contains the user defined functions. You will edit the monitor model and add 
expressions which reference the user defined functions. You will also use the instances view to see the 
results in the dashboard. 

Lab requirements 

List of system and software required for the student to complete the lab. 

• Rational Application Developer or WebSphere Integration Developer V7.5. 

• IBM Business Monitor V7.5 – Toolkit installation including the monitor model editor and Monitor server 

What you should be able to do 

At the end of this lab you should be able to: 
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•	 Use Rational Application Developer or WebSphere Integration Developer to edit the monitor model to 
add references to user defined functions. 

•	 Define a dashboard to view monitoring context instances. 

Introduction 

In this lab you will build on the Clips And Tacks model which is described in another lab document titled 
'IBM Business Monitor V7.5 Clips And Tacks business activity monitoring lab'. You will import the full Clips 
And Tacks model, then update the monitor model, deploy the changed model and submit events to the 
monitor model. 

The user defined functions have been created for you so you can just import them into the workspace. 

In the monitor model, you will define a new metric to track the cost of the ordering process. You will use an 
existing metric 'Order Fulfillment Duration' which is the duration of the order process. You will use a user 
defined function to calculate the cost of the process using the order fulfillment duration as an input 
parameter. The cost function could retrieve the average unit cost from a database or another system, but 
for simplicity in this lab, the Java function is implemented using a random number generator. 

Useful URLs 

The following URLs may be helpful to you as you exercise this lab. Note that the port numbers in the URL 
of your installation may be different depending on your configuration. 

•	 Server administrative console 

https://localhost:9043/ibm/console 

•	 Business space dashboard 

https://localhost:9443/BusinessSpace 
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Part 1: Import the Clips and Tacks monitor model 

In this section, you will import the Clips and Tacks monitor model into the workspace. 

____ 1. Start Rational Application Developer or WebSphere Integration Developer and setup the 
environment. 

__ a. Start Rational Application Developer or WebSphere Integration Developer, and when prompted 
point to a new workspace such as c:\workspaces\ClipsAndTacks 

__ b. Close the Welcome tab. 

__ c. Open the Business Monitoring perspective. Select Window > Open Perspective > Business 
Monitoring.
 

__ d. If it asks you to Confirm Enablement, then click OK.
 

____ 2. Import the ClipsAndTacks project interchange file. 

__ a. Right click in the Project Explorer view, and then select Import > Import… 

__ b. Select Other > Project Interchange, click Next. 

__ c. For the .zip file, browse to the location containing the file, for example, 
c:\Labfiles75\UDF\ClipsAndTacks_PI.zip
 

__ d. Click Select All
 

__ e. Click Finish.
 

____ 3.	 Expand the project in the Project Explorer view, then expand the Event Definitions and you will see 
the new events listed. Expand Monitor Models and you will see the new ClipsAndTacks model 
listed. 
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Part 2: Import the user defined function project 

In this section you will use Rational Application Developer or WebSphere Integration Developer to import 
the project interchange containing the cost functions. 

____ 1. Switch to the Java EE perspective. 

__ a. Click Window > Open Perspective > Other… 

__ b. Click Show all, then select Java EE 

__ c. Click OK 

____ 2. Import the cost function project interchange file. 

__ a. Right click in the Project Explorer view, and then select Import > Import… 

__ b. Select Other > Project Interchange, click Next. 

__ c. For the .zip file, browse to the location containing the file, for example,
 
c:\Labfiles75\UDF\CostFunction_PI.zip
 

__ d. Click Select All
 

__ e. Click Finish.
 

__ f. You will see the costFunctions project in the Enterprise Explorer and there will be some errors. 

____ 3. Update the build path for the project 

__ a. In the Enterprise Explorer, right click the project costFunctions and select Properties. 

__ b. Select ‘Java Build Path’ on the left. 

__ c. Click tab Libraries on the right. 

__ d. Select the entry ‘com.ibm.wbimonitor.xml.expression.runtime.jar…’ 

__ e. Click Edit…. 

__ f. Browse to 
<server_path>\plugins\com.ibm.wbimonitor.xml.expression\com.ibm.wbimonitor.xml.expression.r 
untime.jar 

__ g. Click Open 

__ h. Click OK on the properties page. 

____ 4.	 Check for any errors in the Problems view. You should resolve any errors before continuing. 
Warnings and informational messages may be present but these will not be a problem. 
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Part 3: Review the user defined functions and create the jar file 

In this section you will review the user defined functions that you imported in the previous section. Then 
you will export a jar file which will be imported into the monitor model. 

____ 1.	 Expand the costFunctions project in the Enterprise Explorer. 

____ 2. Double click CostFunctions.java to open the Java editor.
 

____ 3. Notice the annotations in the file to specify the user defined functions to Monitor.
 

____ 4. You will use the cost1 function in the monitor model. 

____ 5. Take a look at the code in the cost1 function. It receives a parameter which is the number of days 
duration for order fulfillment. It multiplies the duration by a random number between 0 and 1, then 
multiplies that by 10. It returns this number as a decimal number, which is the calculated cost for the 
supplied duration. This is a simple example for the lab, but you could easily reference a database or 
web service to retrieve the cost. Notice the Java types which are used for the function, argument 
and return types. Since you are implementing a Java method that will be used as an XPath function, 
you need to be aware of the mappings from Java to XML data types. Refer to the Information 
Center for all the available data types and mappings. 

____ 6.	 There is another function cost2 which is defined in this file, but it will not be used in the monitor 
model. There is also another file MoreCostFunctions.java which contains other cost functions. This 
file will be imported into the model to show how multiple files can be referenced in the workspace. 

____ 7.	 Export the user defined functions to a jar file. 

__ a. Right click the costFunctions folder (not the CostFunctions.java) in the Enterprise Explorer, and 
select Export… 

__ b. Select Java > Jar file, and click Next. 

__ c. For the JAR file, click Browse… and navigate to a destination such as c:\temp. 
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__ d. Then specify a name for the jar file, such as costFunctions.jar, and click Save.
 

__ e. Click Finish.
 

__ f. You may get a popup indicating warnings, but this is fine, so just click OK.
 

____ 8. Check for any errors in the Problems view. You should resolve any errors before continuing. 
Warnings and informational messages may be present but these will not be a problem. 
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Part 4: Import the user defined functions into the monitor model 

In this section you will import the user defined functions jar into the monitor model. 

____ 1. Switch to the Business Monitoring perspective. 

__ a. Click Window > Open Perspective > Business Monitoring 

__ b. Click OK 

____ 2. Define an external function library. 

__ a. Right click the ClipsAndTacks project in the project explorer, then select External Function 
Libraries… 

__ b. Click Add External JARs… 

__ c. Navigate to the location of your function jar, for example, c:\temp\costFunctions.jar, then click 
Open 

__ d. Click OK. 

____ 3. Define the cost functions to the monitor model. 

__ a. Double click ClipsAndTacks > Monitor Models > ClipsAndTacks.mm in the project explorer. 

__ b. The monitor model editor opens. 

__ c. On the Monitor Model Details tab, notice the area for user defined XPath functions: 
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__ d. Click Edit…
 

__ e. You should see a list of the function files in the library.
 

__ f. You need to assign a prefix to each namespace. 

__ g. Check the box next to ‘http://cost.functions.com/expression’ (do not select the one with ‘more’ in 
the namespace), then type a name for the function prefix down below, for example, costMain. 
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__ h. Check the box next to ‘http://more.functions.com/expression’ (make sure that you select the one 
with ‘more’ in the namespace), then type a name for the function prefix down below, for example, 
costOther. 

__ i. Click Finish, then you should see the two listings on the Monitor Model Details tab in the user 
defined functions list. 

__ j. Now the functions are available for use in the monitor model.
 

__ k. Press Ctrl-S to save your work.
 

__ l. Check for any errors in the Problems view. You should resolve any errors before continuing.
 
Warnings and informational messages may be present but these will not be a problem. 
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Part 5: Add expressions that reference user defined functions 

In this section you will use Rational Application Developer or WebSphere Integration Developer to edit the 
monitor model. You will create a new metric and add expressions which use the cost functions. You will be 
calculating the cost based on the order fulfillment duration metric which is already defined in the model. 
Since the order fulfillment duration metric is calculated based on two triggers, one for the order shipment 
and one for the order cancellation, you will use the same triggers to fire the calculation of this cost metric. 

____ 1. If not already open, switch to the Business Monitoring perspective. 

____ 2. Double click the monitor model ClipsAndTacks.mm in the project explorer to open the model 
editor. 

____ 3. Create a new metric in the monitor model for order fulfillment cost. 

__ a. In the model navigator in the model editor, right click 'ClipsAndTacks MC', then select New > 
Metric. 

__ b. For name, enter: Order Fulfillment Cost 

__ c. For ID, accept default: Order_Fulfillment_Cost 

__ d. For type, select: Decimal 

__ e. Click OK 

__ f. For Metric Value Expressions, click Add 

__ g. In the first row of the Metric Value Expressions table, select the cell under column Trigger, then a 
button is shown, then click the button and select Trigger type > ClipsAndTacks MC > Ship Order 
to Customer Trigger, click OK 

__ h. In the first row of the Metric Value Expressions table, select the cell under column Expression, 
then bring up content assist by pressing Ctrl-space. Expand Functions and notice that your cost 
user defined functions are listed here with the prefixes costMain and costOther that you defined 
earlier: 

__ i. Select costMain:cost1 and it is added to the expression. 

28 September 2011 IBM Business Monitor 7.5 – Lab exercise Page 10 of 17 

User defined functions 



        

              

    

                     
                    

                 
        

 

        

 

        

                  
                 

    

                 
                 

 

        

 

                 
              

 

© Copyright IBM Corporation 2011. All rights reserved 

__ j. Now you need to define the integer duration input to the function. There is a metric in the model, 
Order Fulfillment Duration, that you can use, but it is type duration so you will also need to use a 
function to convert the duration to an integer number of days. Use content assist, or type the 
expression manually so that it looks like this: 

costMain:cost1(fn:days-from-duration(Order_Fulfillment_Duration)) 

__ k. Press Ctrl-S to save your work. 

__ l. For Metric Value Expressions, click Add 

__ m. In the second row of the Metric Value Expressions table, select the cell under column Trigger, 
then a button is shown, then click the button and select Trigger type > ClipsAndTacks MC > 
Cancel Trigger, click OK 

__ n. In the second row of the Metric Value Expressions table, select the cell under column 
Expression. Use content assist, or type the same expression as above so that it looks like this: 

costMain:cost1(fn:days-from-duration(Order_Fulfillment_Duration)) 

__ o. Press Ctrl-S to save your work. 

____ 4. Check for any errors in the Problems view. You should resolve any errors before continuing. 
Warnings and informational messages may be present but these will not be a problem. 
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Part 6: Publish the model to the server 

In this section you will use Rational Application Developer or WebSphere Integration Developer to publish 
the monitor model to the monitor server. 

____ 1. In Project Explorer, expand ClipsAndTacks � Monitor models � ClipsAndTacks.mm. Right click 
over ClipsAndTacks.mm and then select Generate Monitor JEE Projects from the pop-up menu 

____ 2. If you have already generated the ClipsAndTacks model for another lab, then you may need to 
select 'overwrite existing projects'. Then click Finish. 

____ 3. A progress dialog shows the status of the operation and it closes when the operation is complete. 
Check for errors in the Problems view. There may be warnings, but there should not be any errors. If 
you see errors, then try to perform a clean to see if the errors can be removed: Project > Clean… > 
select 'Clean all projects', then click OK. 

____ 4. Click the Servers tab, then right click and select the Start option to start the server IBM Business 
Monitor Server V7.5. This may take a few minutes to complete. 

____ 5. Right click in the servers view, then select 'Add and Remove Projects…'. 

____ 6. Click Add to move the ClipsAndTacksApplication from the list of available projects to the list of 
configured projects. Click Finish. Note: If the application is already in the list of configured projects, 
then you may have run another lab and published this application already, so in that case, cancel 
this window and select the 'Publish' option from the server menu. 

____ 7. A progress message is displayed in the lower right corner of the window. After a few moments the 
application status in the server view should change from stopped to started. 

____ 8. If you are using the integrated server within WebSphere Integration Developer or Rational 
Application Developer, then you do not need to setup Monitor data security, since the administrative 
user is automatically authorized to all models. If you are using a different server, then you should 
open the administrative console, navigate to Security > Monitor Data Security, then add the 
model, role and user information to a resource group. 
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Part 7: Run events to exercise the model 

Rather than installing an application to create the events that you want to monitor, you are going to use a 
program to simulate the submission of events from the application. 

The supplied program is 'BatchCBEWriter61' and it will submit the events to the Common Event Infrastructure. 
Look for the program in \Labfiles75\BatchCBEWriter. This program reads XML files which represent the 
common base events for the model. 

____ 9.	 Update BatchCBEWriter61.bat to point WAS_HOME to the monitor server home, for example 'set 
WAS_HOME=C:\IBM\WebSphere\AppServer'. If you are using the integrated monitor server in 
WebSphere Integration Developer, the path would be <WID_WTE_HOME>\runtimes\bi_v7. If you 
are using the integrated monitor server in Rational Application Developer, the path would be 
<RAD_WTE_HOME>\runtimes\base_v7. 

____ 10.	 Update config.properties, setting the serverName and portNumber. You can find the port number by 
browsing the server log and finding 'bootstrap port'. For example, check for the log at 
C:\IBM\WebSphere\AppServer\profiles\WBMon01\logs\server1\SystemOut.log . For the integrated 
server in WebSphere Integration Developer, the path would be 
<WID_WTE_HOME>\runtimes\bi_v7\profiles\qmwps\logs\server1\SystemOut.log. For the integrated 
server in Rational Application Developer, the path would be 
<RAD_WTE_HOME>\runtimes\base_v7\profiles\WBMonSrv\logs\server1\SystemOut.log. Here is an 
example of the config.properties settings: 

__ a. connect.serverName = localhost 

__ b. connect.portNumber = 2809 

____ 11.	 Open a command window, then change directory to the folder containing BatchCBEWriter61, for 
example, type this command 

__ a. cd \Labfiles75\BatchCBEWriter 

____ 12.	 Run commands to load the common base events to the server. 

__ a. batchcbewriter61 -Dsource.filename=allevents.xml 

__ b. It prompts you for user identity and password 

____ 13.	 When you run BatchCBEWriter61, you should see results such as: 
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Part 8: Create a dashboard 

In this section you will build a dashboard in business space. 

____ 1. Create the dashboard. 

__ a. The default browser is 'Internal Web Browser', but you should not use this one since some 
standard functions are not provided that you may need. Select Window > Preferences > General 
> Web browser > select 'Use external Web browser'. Select an external browser. Click OK. 

__ b. In WebSphere Integration Developer, in the servers view, right click and select Launch > 
Business Space 

__ c. When prompted, enter your user ID and password.
 

__ d. Click in the Actions menu to create a new space
 

__ e. Enter a name such as Dashboard, and select the Business Monitoring template. 

__ f. Click Save. 
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____ 2. Configure the instances widget.
 

__ a. On the new space, click the Operational tab.
 

__ b. Click the 'Edit Page' link to enter edit mode. 

__ c. To configure the Instances widget, hover the mouse over the right corner of the widget 

and then click the down arrow. Select 'Edit Settings…'. 

__ d. Click the Show/Hide tab, and select monitoring context 'ClipsAndTacks MC'. 

Click button >> to move all the fields to the Selected box. Also, 
click button 'Set as default' which will make this the default monitoring context to display. 

__ e. Then click OK. You should see a list of monitoring context instances for the events that you just 
processed. 

__ f. Notice the new metric Order Fulfillment Cost. For shipped or cancelled orders, you see that the 
cost1 function has been used to calculate the cost based on the Order Fulfillment Duration. 
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What you did in this exercise 

In the lab, you imported user defined functions into a monitor model, and you created a cost metric which 
referenced the functions in expressions. 

Then you published the model to the monitor server. 

You used the supplied program to simulate the submission of events from the monitored application. 

You configured dashboards to view the new cost metric in the instances widget. 
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