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CS05: IBM CICS TG plug-ins for use with CICS Explorer 
 
Current Version: v1.0, April 2009 
Author: Rob Jones (rcjones@uk.ibm.com), IBM UK, Hursley 
 

Description 
 
This SupportPac provides a Gateway daemons view and a CICS connections view in the 
CICS TG perspective of the CICS Explorer.  
 
You can view the status and activity of one or more Gateway daemons running on the 
z/OS platform. Use the Gateway daemons view to see an overall status of one or more 
Gateway daemons. Use the CICS connections view to see the connectivity between CICS 
servers and one or more Gateway daemons.  
 
Switching to the CICS TG perspective gives fast access to the new views. Each view 
includes the attributes considered to be immediately useful. You can add further 
attributes or remove existing attributes as you require. You can see the full set of 
attributes in the Properties window, the attributes are grouped into predefined categories. 
  
The ability to create a composite perspective is a powerful feature of the CICS Explorer. 
The views provided by the CICS TG plug-ins for CICS Explorer can be added to other 
perspectives. The CICS TG perspective can be customized to add other CICS Explorer 
views. 
 

System Requirements  
 
IBM CICS Explorer SupportPac V1.2 (CICS Explorer V0.5.2) or later: 

• SupportPac CS1J (Windows)   
• SupportPac CS1O (Linux) 

 
CICS Transaction Gateway for z/OS  

• V7.2 
• V7.1 with PK57718 (UK38084) 

 
CICS TG configurations 

• remote mode 
• one or more Gateway daemons 
• EXCI and IPIC CICS connections 
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Skill level required 
 
CICS Transaction Gateway for z/OS System Administrator 

Supplied files 
 

• cs05.zip  - IBM CICS TG plug-ins for CICS Explorer package 
• cs05.pdf   - IBM CICS TG plug-ins for CICS Explorer documentation 

Preparation 
 
Download the file cs05.zip and unzip the contents to a known location, e.g. 
C:\temp\cs05. The target folder will contain: 
 

• Licenses - sub-folder including the license agreement 
• cics-tg.site.zip – a Software Update local archive “site” containing the 

IBM CICS TG plug-ins for CICS Explorer (do NOT unzip this file) 
• CTGConnection.properties – a sample configuration file  

 

Configuration and Installation 
 
Three steps must be completed in order to use the CICS TG plug-ins for CICS Explorer. 
 

1. You must define a statistics API protocol handler before a Gateway daemon can 
be viewed using CICS Explorer.  

2. The details for the statistics API protocol handler of each Gateway daemon must 
be included within the CTGConnection.properties file. This file must be copied 
into the CICS Explorer folder. 

3. The CICS TG plug-ins must be installed using the Software Update facility of the 
CICS Explorer. 

 

CICS Transaction Gateway configuration 
To use the CICS TG plug-ins for CICS Explorer, the statistics API hostname and port 
number of each Gateway daemon are required. The API hostname and port number must 
be defined for each Gateway daemon as a “statsapi” protocol handler. The protocol 
handler is defined in the GATEWAY section of the CICS TG configuration file.  
 
For example: 

 
protocol@statsapi.handler=com.ibm.ctg.server.RestrictedTCPH
andler 
protocol@statsapi.parameters=connecttimeout=2000;port=4148;
bind=myzos1.company.com;maxconn=5; 
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The statistics API port number can be overridden by specifying the “-statsport” switch on 
the ctgstart command. Typically, this is specified using the CTGSTART_OPTS 
environment variable on the CTGBATCH STDENV DD-card: 

 
CTGSTART_OPTS=-statsport 48148 

 
The statistics API port used by a Gateway daemon is reported by the informational log 
message CTG6524I, found in the Gateway daemon JES log. For example: 
 
CTG6524I Successfully started handler for the statsapi: 
protocol on port 4148 

CICS Explorer configuration 
Since the CICS TG plug-ins for CICS Explorer utilizes the Gateway daemon statistics 
API port, the connection details for each Gateway daemon are required. These details 
must be provided in a file named “CTGConnection.properties” and located in 
the CICS Explorer program folder.  
 
Customize the supplied sample configuration file (using a suitable text editor) to specify 
the name, statistics API hostname and port number for each Gateway daemon. The 
syntax of each line must be in the form: 
 
com.ibm.ctg.gateway.<name>=<hostname>:<port> 
 
… where <name> is an arbitrary label for a Gateway daemon and must be unique only 
within this file. <hostname> and <port> are the values identified or configured under the 
topic “CICS Transaction Gateway configuration”. Duplicate <name> entries will be 
ignored. 
 
For example, to configure access to four Gateway daemons named CTGRED1, 
CTGRED2, CTGBLU1 and CTGBLU2, specify the following lines: 
 
# My CICS Transaction Gateway daemons  
com.ibm.ctg.gateway.CTGRED1=myzos1.company.com:4148 
com.ibm.ctg.gateway.CTGRED2=myzos1.company.com:4149 
com.ibm.ctg.gateway.CTGBLU1=myzos2.company.com:4150 
com.ibm.ctg.gateway.CTGBLU2=myzos2.company.com:4151 
 
Comment lines are denoted by the pound or hash symbol (“#”) prefix. This convention is 
a simple method for temporarily excluding entries from the configuration. For example, 
the following entry for CTGOLD1 is ignored: 
 
#com.ibm.ctg.gateway.CTGOLD1=myzos3.company.com:4100 
 



CS05: CICS TG plug-ins for CICS Explorer 

 Page 4 

When you have completed the customization of the CTGConnection.properties 
file, you must copy it to the CICS Explorer program folder (Figure 1). 
 

 
Figure 1 CTGConnection.properties location 

 
Note: The CTGConnection.properties must be located within the current working 
directory of the CICS Explorer. If you start CICS Explorer using a shortcut on Windows, 
be sure to set the “Start in” location of the shortcut to the CICS Explorer directory. For 
the installation shown in Figure 1, this is “E:\CICS_Explorer”. On Linux, launch 
the CICS Explorer directly via the cicsexplorer executable, or create a shell script to 
ensure the current working directory is correct. 
 

Installation or Update 
 
For a new installation or an update you must to add the “update site” file (cics-
tg.site.zip) to the CICS Explorer.  
 
1. To install or update the CICS TG plug-ins for CICS Explorer, start the CICS Explorer 
and select Help->Software Updates. The “Software Updates and Add-ons” panel is 
displayed.  
 
2. Select the “Available Software…” tab, and click “Add Site…”. The Add Site window 
is displayed (Figure 2).  
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Figure 2 Software Updates... Add site 

 
 
3. Click “Archive…” and navigate to the folder that contains the “cics-
tg.site.zip” file (Figure 3).  
 

 
Figure 3 Software Updates... Repository archive 

 
4. Select the cics-tg.site.zip file and click “Open”. When you return to the “Add 
Site” window, click “OK”.  
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The “IBM CICS TG plug-ins for CICS Explorer” is displayed in the “Available 
Software” tab of the “Software Updates and Add-ons” panel (Figure 4): 
 

 
Figure 4 Software Updates and Add-ons 

 
If you are performing a fresh installation of the CICS TG plug-ins into CICS Explorer 
follow step 5a.  
If you are performing an update, follow step 5b.  
 
5a. Install. Select “IBM CICS TG plug-ins for CICS Explorer” and click “Install…”. 
After some processing, the “Install” panel is displayed (Figure 5): 
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Figure 5 Software Updates... Install 

Proceed to step 6. 
 
5.b Update. Use the Installed Software tab, select “IBM CICS TG plug-ins for CICS 
Explorer” and click “Update” (Figure 6).   
 

 
Figure 6 Software Updates... Update 

 
Provided that a new version of the CICS TG plug-ins for CICS Explorer has been added 
in steps 1-4, the “Available Updates” window shows the details of the update (Figure 7): 
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Figure 7 Software Updates... Available Updates 

Proceed to step 7. 
 
6. Before you can install, you must accept the license agreement. Click next and review 
the license. The license is supplied in the SupportPac “Licenses” sub-folder. If you 
accept, select the appropriate option, and select “Finish” (Figure 8). 
 

 
Figure 8 Install... Review Licenses 
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7. Click “Finish” to continue with the installation. The final “Software Updates” window 
recommends that CICS Explorer is restarted (Figure 9): 
 

 
Figure 9 Software Updates... restart 

 
8. Click “Yes” to complete the installation. CICS Explorer is restarted, and the CICS TG 
plug-ins are available.  

 

Usage 
 
When you have successfully installed the CICS TG plug-ins for CICS Explorer, provided 
the “CTGConnection.properties” file in the CICS Explorer program folder and 
restarted the CICS Explorer, start your CICS SM connection as usual. The CICS Explorer 
CICS SM perspective is displayed. Before any CICS TG information is displayed, the 
connection to CICS SM connection must be active. 

CICS TG perspective 
CICS TG plug-ins for CICS Explorer provides a “CICS TG” perspective in addition to 
the CICS Explorer default perspective “CICS SM”. To switch to the “CICS TG” 
perspective, select the Window->Open perspective->Other… menu. From the “Open 
Perspective” window, select “CICS TG” and click OK (Figure 10). 
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Figure 10 Open Perspective window 

 
Note: The CICS TG plug-ins for CICS Explorer installs a “perspective shortcut” to the 
Open perspective menu of the CICS SM perspective (Figure 11):  
 

 
Figure 11 CICS TG Perspective shortcut 

 
This shortcut might become visible only after selecting “Reset Perspective” on the CICS 
SM perspective. An alternative is to use the “Open perspective” option. 

CICS TG views 
Switching to the CICS TG perspective shows the “Gateway daemons” and “CICS 
connections” views stacked on the central pane and the “Properties” pane below. The 
navigator pane matches the default CICS SM perspective.  
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Gateway daemons view 
The Gateway daemons view shows one line per Gateway daemon defined in the 
CTGConnection.properties file.  
 
A Gateway daemon shows a status of UNAVAILABLE when any of the following are 
true: 

• the Gateway daemon is not running 
• the Gateway daemon is unreachable 
• the host name or port number defined for the Gateway daemon in the 

CTGConnection.properties file is incorrect 
• the statistics API protocol handler definition of the Gateway daemon does not 

match the definition in the CTGConnection.properties file, or is missing  
 
If a Gateway daemon status is UNAVAILABLE, the Name attribute is taken from the 
CTGConnection.properties file rather than the job name. 

CICS connections view 
Switching to the CICS connections view shows one line per CICS connection from each 
active Gateway daemon.  
 
A CICS server that is connected to a Gateway daemon using the EXCI protocol does not 
appear on the CICS connections view until at least one request has been sent to that CICS 
server.  
 
A CICS server that is connected to a Gateway daemon using the IPIC protocol always 
appears on the CICS connections view. However, until at least one request has been sent 
to that CICS server, only values for the Name and Server attributes are available. 
 
Note: If no data appears in the Gateway daemons or CICS connections view, select a 
node in the navigator panel. As the IBM CICS TG plug-ins in this SupportPac are not 
integrated with the CICS Explorer connection management or navigation functionality, 
there is no explicit “connect to Gateway daemon” option. However, selecting any node in 
the CICSplex navigation panel will trigger connection to all the defined Gateway 
daemons. 

Fully Customizable  
The CICS TG perspective and its views are fully customizable. Any CICS Explorer 
resource view might be added to the CICS TG perspective using the “Operations”, 
“Administration” menus, or using the Window->Show view->Other…  “Show view” 
window. 
 
Alternatively, the CICS TG resource views can be added to the CICS SM perspective 
using the Window->Show view->Other…  “Show view” window. The Gateway daemons 
and CICS connections views can be found under the “CICS TG” category. 
 



CS05: CICS TG plug-ins for CICS Explorer 

 Page 12 

The Gateway daemons and CICS connections views provide a default selection of 
attributes. The CICS TG perspective has been designed with EXCI connections in mind. 
However, connection attributes applicable to IPIC connections are available for use in a 
customized view. Further attributes can be added or existing attributes removed from a 
view to suit the needs of the user. 

Help capabilities 
Context sensitive help is included with the CICS TG plug-ins for CICS Explorer. Select 
either of the CICS TG views in the central pane, or a particular attribute on the 
“Properties” pane and then press F1. A help panel is displayed containing either a 
description of the selected view, or a description of the selected attribute. 
 

Limitations 
 
The connectivity with Gateway daemons is not integrated with the CICS Explorer 
connection management facilities or navigator panel. Therefore, it is not possible to limit 
the “scope” of information displayed by the CICS TG views by making a selection on the 
navigator panel. 
 
The filter functionality for the Gateway daemons and CICS connections views is not 
implemented.  
 
Support for CICS Transaction Gateway for Multiplatforms is not included in this 
SupportPac. 
 
The SupportPac includes only English language labels and help information. 
 

Further details 
 
For further information on the IBM CICS Explorer, including links to the CS1J or CS1O 
SupportPacs, refer to: 
  
http://www.ibm.com/software/htp/cics/explorer 
 
For access to all available CICS SupportPacs, refer to: 
 
http://www.ibm.com/support/docview.wss?uid=swg27007241 
 
For general information on the IBM CICS Transaction Gateway portfolio, refer to: 
 
http://www.ibm.com/software/htp/cics/ctg 
 
For further information on the IBM CICS Transaction Gateway for z/OS, refer to: 
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http://www.ibm.com/software/htp/cics/ctg/zos/about/index.html 
 
For details of the APAR PK57718 for CICS TG for z/OS V7.1, that is required for 
interoperation with this SupportPac, refer to:  
http://www.ibm.com/support/docview.wss?uid=swg1PK57718 


