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Installation and configuration for the Data Modeler for Notes 
 
This document provides an installation and configuration guide for Sun & Son’s Data 
Modeler for Notes. The Data Modeler permits Cognos ReportNet or Cognos 8 BI to access 
data held in IBM Lotus Domino Databases. The Data Modeler employs a Notes based, 
Graphical Wizard to generate hidden Notes Views and associated XML data models, then 
inserts these elements into target Notes databases to be used for Cognos reporting.  
 
Updates in Build 1.002.000: 
 
New configuration options are available in the settings page of the Data Modeler. These 
options include “Language”, “Cognos Version”, and disabling “Show Sample Values” for 
databases that are not full text indexed.  
 
The Data Modeler for Notes can stage data externally to optimize access to very large 
quantities of Notes documents in a secondary repository.  
 
Data Modeler Support for NSFDB2 is now available on a limited availability basis; please 
contact support@sunandson.com for more information. 
 
Intended audience for this documentation: 
The roles and privileges associated with the installation and configuration of the Data 
Modeler for Notes are listed below.  They may be attributed to one or more persons 
depending on the needs of your organization. 
 
1.  Domino Systems Administrator –  

§ Access to create databases 
§ Authority to sign databases with Server ID 
§ Ability to create/modify groups in the Domino Directory 
§ Access to delegate IDs used to read and access data for reporting 
§ Set up an ODBC Data Source 

 
2.  Cognos ReportNet or Cognos 8 BI Administrator – 

§ Ability to set up a Cognos Data Source  
§ Ability to install NotesSQL directly on the server that is retrieving data 

from Notes Databases. 
§ Access to create Projects and Models in Framework Manager and 

publish the report Packages 
§ Access to create a Test Report in Query Studio 
 

 
3. Report Designer/Data Modeler – 

 
§ Knowledge of the target Domino Database Application and how data is 

stored in it Ability to set up a Cognos Data Source  
§ Ability to set up a Cognos Data Source  
§ Designer Access to target Domino databases 
§ Access to create Projects and Models in Framework Manager and 

publish the report Packages 
§ Access to create a create Reports in CRN or Cognos 8 
§ Enhance the Data Structure in Framework Manager 

 

mailto:support@sunandson.com
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Components and Prerequisites  
 
Required Components: 
 

1. Cognos ReportNet or Cognos 8 BI 
2. Lotus Notes/Domino 6.5 or higher – platform independent 
3. Lotus NotesSQL (3.02g) – must reside on Windows server 

4. Data Modeler for Notes – configuration database supplied as a NSF file 
(DataModeler.nsf) 

5. Sample Domino Database “DMSample.nsf” (used in examples presented in this 
documentation) 

 
For details on other types of deployments consult the Data Modeler for Notes Best Practices 
Guide. 
 
Cognos ReportNet or Cognos 8 BI Server Specifics: 

1. Install and configure Cognos ReportNet or Cognos 8 BI on Windows server 
2. Install & configure Notes Administrator client 6.5 or later with Admin Notes ID (if not 

installed on Administrator Workstation) 
3. Install NotesSQL (3.02g) 

Consult the official Cognos documentation Cognos installation details. 
 
Administrator Workstation Requirements and Prerequisites: 

1. Install Cognos Framework Manager 
2. Configure Framework Manager to point to CRN server 
3. Install and configure Notes Administrator client (if not already installed on Server) 

 
Data Modeler for Notes Installation and Configuration Steps 
 
The remainder of this documentation is dedicated to the following tasks: 

A. Install and Register the Data Modeler Database 
B. Run the Wizard in the Data Modeler for a target Notes Database 
C. Set up an ODBC Data Source 
D. Set up a Cognos Data Source 
E. Create a Project in Framework Manager and Publish the Data Model Package 

to Cognos Connection 
F. Create a Test Report in Query Studio 

G. Enhance the Data Structure in Framework Manager 
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A.  Install and register the Data Modeler Database 

1.  The Data Modeler for Notes is contained in a Notes database which can be installed on a 
Domino server or on a local Notes client.  This documentation assumes that the database is 
installed on the Domino server.  Should you choose to install the Data Modeler on a 
separate administrative client, consult the Data Modeler Best Practices guide to insure 
proper implementation.   

Choose an Installation Notes User ID that has rights to create Groups in the Domino 
Directory (Public Name and Address Book). Use this ID for the Data Modeler for Notes 
installation.  

Create a folder named Cognos under the server Data directory and copy the files 
“DataModeler.nsf” and “DMSample.nsf” from the Data Modeler for Notes distribution CD to 
that folder. (e.g E:\Lotus\Domino\Data\Cognos\DataModeler.nsf where E: is the data drive).  
Once copied, right click each file to open the file Properties.  Uncheck the “Read-only” 
attribute.  
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2. Sign the Data Modeler database with the server’s ID.  Login to Notes Administrator 
Client with Administrator’s ID.  Navigate to installation server by clicking Files > Server in 
the top menu.  Open the Files tab and highlight the Data Modeler database.  In the right 
pane under Tools, click Database > Sign…  Choose the Active Server’s ID, then OK. 

 

  

 

3.  In the Notes Administrator’s Client check that the Administrator has rights to access the 
server’s Domino Directory (Public Name and Address Book) and has Group creator/modifier 
rights. 

Open the Domino Directory on the installation server and create the Group “CRNData 
Modeler”.  Add the names of all the Notes users who will be using the Data Modeler to 
configure connections to Notes databases. It is not necessary to add the names of all the 
users that will just be viewing data through Cognos. Save the Group document and close 
the Directory. 

 

4.  Open the Data Modeler for Notes database using the File > Database > Open command 
on the install server.  If you are prompted to create cross certificate, the database was not 
properly signed in step 1 and this step must first be completed before continuing. Bookmark 
the database or position it on your Notes Desktop where you can find it later.  
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5.  When you open the database, you will be presented with the notice of registration. Click 
the close button to dismiss this notice. 

 

 

6.  Next, click on the Register link in the database navigator. 
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7.  Enter your information and license key. Your name and email address must match 
exactly the information you submitted when you purchased the Data Modeler.  Check “I 
have read and agree to the terms of the software license”.  Click Register. 
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If you have not checked the software agreement box you will get the following error. Check 
and resubmit. 

 

 

 

If you have not completed the registration correctly you will receive the following prompt. 
Check your registration information to ensure that your name and email address match your 
original order information.  If this error persists contact your licensed Data Modeler support 
center. 

 

 

 

If you have registered the product correctly you will see a Thank You message. 

 

 

 

If you have not purchased a license key, click cancel.  You may use the database in 
evaluation mode for 30 days.  
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8.  With the database open, select File >Database > Access Control from the Notes menu.  
Add the Administrator’s name to the Access Control list with Manager Access and the right 
to ‘delete documents’ checked.  Add the Group you created in step 3, CRNData Modeler.  
Give the group Editor Access with all additional right boxes checked.                                               

Modify the –Default- entry to No Access.  The Data Modeler is shipped with –Default- as 
‘Manager’ for installation purposes.  Click OK. 

 

 
 
 
9.  The Data Modeler writes hidden views to the Target Domino databases from which you 
will be gathering data for Cognos CRN or Cognos 8.  For this reason the person running the 
Data Modeler must have a minimum of ‘Designer’ access to each Target Domino database.  
We recommend adding the CRNData Modeler group with Designer access to the ACL of each 
target database.  Database processing will not complete if this level of access has not been 
set.  If your security policy requires, you may remove the group once the Target Database 
has been processed. 
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B.  Run the Data Modeler Wizard on a Target Notes Database 
When the Data Modeler processes a target database, it creates hidden views in the 
database and exports an XML file that is referenced by Cognos CRN or Cognos 8.  
 
1.  Open the Data Modeler database, if not currently open.  Click “Settings” action or choose 
“Settings” from the navigator. You must do this step prior to running the Database Wizard. 

 

 
 
 

2. Verify or override the default configuration and click “Save and Close”.  

Cognos Version – Select the version of Cognos you will be creating data models for. 
Changing this setting allows you to rerun existing data models for different versions of 
Cognos. 

XML Model Export Path - The default path is C:\temp, if the path does not exist it will 
created. 

Show Sample Values – When set to Yes, preview data will be displayed to assist you in 
selecting fields to be used in the data model. A Notes full text index is required to 
display these sample values. If you will be creating a data model of a Notes database 
that does NOT have a full text index or slow performance on updating views you wish to 
set this to “No”. 
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3.  Click the “New Database Wizard” action button to begin processing for a Notes database. 
 

 
 
 
4.  At the Step 1 of 4 screen, click the “Select Database” button to select a database. 
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5.  Select a database using the Choose Database dialog.  The database can be located on 
local or on any server you have access to.   

 
 
6.  Once a database is selected the three fields will be set with default values.  The example 
above shows the Sample Databases which ship with the product.  Package Name and 
Connection Name default to the Database name with spaces and other restricted characters 
removed.  Package Name is a name your users will see when they select Data Packages 
from Cognos. Connection Name is the name for the ODBC Data Connection you will create.  
You may wish to modify these names for logical grouping of packages or connections.  This 
is especially true for deployments with multiple packages or multiple uses of the same 
database within one deployment. There is no inherent issue with using the default values. 
The XML file uses the connection name. However, be careful to remove illegal XML 
characters (such as “&”) in the names you use in these fields. Make a note of the names 
that you do use. You will be referring back to these names later.  
 
If you do not have Designer access to the Target database, you will be warned when you 
click “Next”. You will not be prevented from running the wizard without Designer access to 
the target database, but changes will not be written to the target database and the data 
collection will not function. You will have to rerun the wizard after modifying the ACL to 
actually make the data in the target database available. All of the settings from the previous 
run of the wizard will be saved. 
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Note: Do not click the check box “We will be staging data externally” unless you are using 
this advanced feature. This option allows for data staging to an external DBMS. For more 
information on this feature consult the Data Modeler for Notes Best Practices Guide 
 
Click “Next”.  

 
 
7.  The Step 2 of 4 screen in the Wizard shows a list of all of the Notes forms defined for the 
selected database.  Select only those forms that define meaningful data sets which will be 
used as Cognos as query subjects. Avoid including all forms in a single database unless all 
are significant to the reporting you would like to do.  

Select the forms you want to publish by clicking the corresponding check boxes. Click 
“Next”. 
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8.  The Step 3 of 4 screen presents one screen for each form you selected. You must 
complete Step 3 for each form selected in Step 2. In the example below, the Expense Item 
form is displayed.  The left hand box displays all of the Fields defined on that Form.  We will 
select the Notes Fields we want to expose to Cognos reporting. To the right of each field 
name, we show data type and sample values (in parentheses) from randomly selected 
documents. A full text index is required for this feature to work. This Feature can be 
disabled in the Settings of the Data Modeler database for DBs that don’t have a full text 
index or have slow database views. 

 Select the data elements you want to publish by checking the corresponding check boxes 
and click ‘Add’.  The selected data elements will show in the right hand box. 

Note: The display box shows a list of the Field Names extracted from the design of the 
Notes Database and not the corresponding Field Labels that appear to the end user when 
using the Notes form or view. For this reason it is important that the person configuring the 
connection to the Notes Data is familiar with the source Notes Application. 

Note: Rich Text Fields and encrypted fields are not available for selection. 
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Note: The button “Show Advanced Options” will allow you to add custom elements or 
specify a View Selection Formula that can further constrain the document selection. Consult 
the Best Practices Guide for more information on the implementation of this feature. 

 

 

9.  The Data Modeler creates a special hidden view in the selected database for each form 
selected.  The view will have a selection formula for that form and column definitions for 
each of the selected data elements.  The order and sorting of the data elements is designed 
to optimize the performance of SQL queries against the database views.   

To move a data element (Notes field in this case) up or down, select the data element and 
click the “Move Up” or “Move Down”.  To sort a data element, select it, click the Ascending 
or Descending radio button and click Apply.  You will see an indication of sort order in 
parentheses next to the data element name, (A) or (D).  Sorted data elements should be 
moved to the top, so that they become the left-most columns in the created view. Sorts are 
additive (just like in a Notes view). 
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10.  You may want to show more user-friendly labels for the selected data elements.  It is 
advised to use the same field labels that the end users are accustomed to seeing in the 
Notes Form. To override a data element name (Notes Field name as defined by the 
Database Design), select a data element, type the new value under Label and click Apply.  
You will see the label in parentheses next to the data element name. 
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11.  Entries in a multi-value field will concatenate by default. To show each value of a multi-
value field as a separate row, you must click the Multi-value radio button while the field is 
selected and click Apply. This field will then display (M) next to the field name. This also 
makes this column sorted ascending. 
 
If you plan on using this feature it is recommended that you consult the Data Modeler for 
Notes Best Practices Guide to insure that your implementation produces the intended result. 
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12.  When finished, click Next.  Repeat steps 7 – 11 for each selected form.  At any point, 
you may select Back to change your configuration before continuing. 

 
 

13.  The Step 4 of 4 screen presents a summary of the changes.  Click Next to continue 
processing.  Based on the complexity of the data selected, the process may take few 
minutes. 

 

 
 
As mentioned earlier, for each form selected, a corresponding hidden view is created in the 
Target database with the name “($nsql<FormName>)”.  You can view the view using the 
Domino Designer.  Additionally, a Cognos ReportNet Model XML file is written to your XML 
export path.  The Notes view and XML file are very tightly linked.  If you are tempted to  
modify the $nsql* views, you must also modify the XML file correspondingly.  (This is not 
recommended unless you have a full understanding of the complete process.)   
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14. The Summary screen summarizes the processing that has been completed.  You may 
print this screen by selecting the Print button.  Click “Close”. 
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15.  Documents are written to the Data Modeler database storing your configuration.   

 
 
At any point you may rerun the Wizard to fine tune your settings for a database already 
processed by opening the database document and clicking “Re-run Wizard”. Each time the 
Wizard is run, the XML is file is overwritten and re-attached to the Wizard document. The 
attachment is an archive of the generated XML file. The actual XML file in use is coped to 
the file structure. 
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C.  Set up an ODBC Data Source 
Install NotesSQL on the Cognos server that will poll data from the Domino Server.  The 
Cognos server also requires a Notes Client or Domino Server installation and a copy of the 
Notes ID file that you intend to use to access data via NotesSQL. Restart the server before 
continuing. 

1.  Go to the Windows Control Panel, open Administrative Tools. Data Sources (ODBC).  
Click the “System DSN” tab and click Add. 

 

2.  Scroll down and highlight the “Lotus NotesSQL Driver (*.nsf)” item and click “Finish”. 

 
 
 
3.  Enter your Data source name exactly as you defined the Connection Name in the Wizard 
step 1 field three.  Enter any meaningful Description.  Use the pull downs for Domino server 
and Database to select the Notes database you used with the Data Modeler.  Click 
“Options”, then click “Add User”. Make sure that you specify the Domino Server by name. If 
you do not see your server in the drop down list verify that you do not have multiple 
notes.in files pointing to the Server. 
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4.  Click Options > Add User.  Browse to the Notes ID file which has at least Editor access to 
the database.  Then click “Next”. 

 

 
 
 
5.  Enter the Notes ID Password for the ID file.  Click OK. 
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6. Your Data Source will appear in the System DSN tab.   

 

 
 
 
7.  Click the Connection Pooling tab. Double click on the Lotus NotesSQL Driver and Verify 
that connection pooling is disabled. DO NOT turn on Connection Pooling! Connection 
Pooling it can cause Cognos 8 to become extremely unstable when accessing Notes. 
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D.  Set up a Cognos data source 

1.  Before continuing, ensure that NotesSQL is installed on the CRN or Cognos 8 server, and 
that the ODBC connection is configured.  From a web browser on the Administrator’s 
workstation, open Cognos Connection at http://<yourcrnserver>/crn.  Click the Welcome 
page tab.  Click the Directory link under Tools in CRN, in Cognos 8 Tools > Directory. 

Note: Screen shots displayed here are from Cognos Report Net, Cognos 8 is slightly 
different and some commands may only be available from the Menu instead of being 
available on a Right click. 

 
 
 

2.  Click Data Sources. 
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3.  Click the New Data Source icon (cylinder) on the tool bar on the upper right of the 
screen. 

 

 
 
 

4.  Under Name enter the Connection Name exactly as you defined it in the Data Modeler.  
Enter a meaningful Description or Screen tip if you wish.  Click “Next”. 
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5.  Select ODBC (Windows only) option in the Type pull-down and click “Next”. 

 

 
 
 

6.  Under ODBC data source, enter the Connection Name exactly as you defined it in the 
Data Modeler.  Scroll down to the bottom of the screen and click the “Test the connection” 
link. 
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7.  Click the Test button.  You should see Succeeded in the View the Results – Test the 
connection dialog.  If not, go back and verify that the Connection Name exactly matches the 
name used in the ODBC configuration and that the ODBC connection is properly configured.  
Click Close, Close again, and Finish.  Your Data Source should appear in the list.  Close the 
Cognos Connection browser. 
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E.  Create a Project in Framework Manager and Publish the 
ReportNet Package 

 

1.  Open Cognos Framework Manager.  Click Create a new project. 

 
 
2.  Under Project name enter the Package Name you defined in the Data Modeler.  Click OK.  
When prompted to Select Language, select the default (English) and click OK. 

 
 
3.  Select Cognos ReportNet Model under Select Import Source.  Click Next. 
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4.  Click the Open Folder icon. 

 

 
 
5.  Navigate to Data Modeler output files.  (The default is C:\temp in less it was changed in 
Step B 2)  Select All Files (*.*) under Files of type so that XML files will be displayed.  Select 
the XML file with your Package Name and click Open.  You will see your file path under 
Select Cognos ReportNet model.  Click Next. 
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6.  Check all displayed objects and click Next. 

 
 

7.  Verify the objects were imported. Click Finish. 
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8.  In Project Viewer, highlight your Data Source. In the Properties area, verify that Query 
Processing is set to Limited Local.  Type ctrl-S to save your project. 

 

 
 
9.  Right click your data source > Test Data Source.   
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You should see that the data source was tested successfully.  Click “OK”. If the test is 
unsuccessful refer to the Troubleshooting guide in the Data Modeler Best Practices 
documentation.  

 
 
10.  In the Project View, expand your Model.  Right click on the first Query Subject and 
select “Test Query Subject”. 

 
 
11.  Confirm that the Test Result displays valid data.  Click Close and repeat for each Query 
Subject.  If successful, you have verified that the data source and connections are properly 
configured.  If the test is unsuccessful, refer to the Troubleshooting guide in the Data 
Modeler Best Practices documentation. 
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12.  Right click on the Packages item and click “Create”, “Package”. 

 
 
 

13.  Under Name enter your Package Name as you identified it in the Data Modeler.  Click 
“Next”. 
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14.  Ensure that all objects are checked and click “Next”. 

 

 
 
 
15.  Click Next in the Add Security dialog.  In the Select Function Lists screen, click Finish.  
Click Yes in the success notification dialog. 
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16.  In the Select Location Type screen, uncheck Enable model versioning. Click Publish.  If 
you receive a message warning that your existing package will be overwritten, click Yes.  If 
you receive a message warning that the administrative access list is empty, click OK. 

 

 
 
17.  At the finish screen, click Finish.  Close Framework Manager 

 
 

Your Data Model is now complete.  You are now ready to start generating reports.
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F.  Create a Test Report in Query Studio 

 

1.  From a browser on the Administrator’s workstation, open Cognos Connection at 
http://<yourcrnserver>/crn or http://<yourcrnserver>/c8.  Click the Query Studio link. 

 

  
 
 
2.  Click the link to the Package you published in Framework Manager.  
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3.  Expand the Package and expand the first Query Subject.  Drag the Query Subject 
(Expense Item in this example) into the central work area. 

 
 
4.  Verify that all data elements are displayed  correctly.  Click the Undo button and repeat 
steps 3 and 4 for any additional Query Subjects. 
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5.  You are now ready to start creating professional reports from your Notes data using 
Cognos Query Studio and Cognos Report Studio.  Please refer to Cognos ReportNet or 
Cognos 8 documentation to get started and fully utilize these powerful tools. 
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G.  Enhance the Data Structure in Framework Manager 

This section illustrates one of the powerful capabilities of data modeling using Framework 
Manager, the ability to join Query Subjects.  In the example using the sample Travel 
Expense database, we have created reports which merge data from Travel Authorizations 
and Expense Items.  If done directly in Notes, this feature would require a significant 
modification to the data structure. 

 

1.  Start Framework Manager and click the link for the Project we created, in this case 
TravelExpenseTracking. 

 
 
 
2.  Click the Object Diagram link under TravelExpenseTracking in the center panel.   
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3.  Displayed is the Data Model as an entity relationship model.  Note that several data 
element names are prefixed with ‘HIDDEN’.  These elements were created by the Data 
Modeler.  Since NotesSQL shows all data from Notes Views as string data type, the Data 
Modeler hides these values and exposes newly computed elements of the correct data type 
for numeric and date fields in Notes.   

We have moved the Query Subjects around on the screen by dragging them by their title 
bars. 

 
 
4.  AuthNum is a common data element to all three tables.  Since we placed this element at 
the top of each list and sorted it, it will act as a index value.  We will be creating join 
relationships from the Travel Authorization table to the Expense Item and Reservation 
tables.   

Right click on the AuthNum element in the Travel Authorization table and select Create 
Relationship. (In Cognos 8 this is not available on the Right click, use the menu options 
instead. 
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5.  Click the Open Folder icon above the empty Query subject box on the right. 

 

 
 
6.  Select Expense Item and click OK. 
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7.  You will see that Framework Manager created a relationship between AuthNum in the 
Travel Authorization Query Subject and AuthNum in the Expense Item Query Subject.  We 
have modified the relationship to be 0…1 on the Travel Authorization side.  Note that the 
operation of the relationship is explained under Relationship impact.  Click OK. 
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8.  The relationship is shown on the main Framework Manager screen.  Repeat the process 
to create the same relationship between the Travel Authorization and Reservation tables. 

 
 
9.  When both relationships are set, expand Packages in the Project Viewer.  Right click on 
the TravelExpenseTracking package and select Publish Packages. 
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10.  Click Publish at the Select Location Type screen. 

 
 
11.  Click OK when you are warned that the package already exists.  If you see another 
warning that the administrative access list is empty, click OK again.  Then click Finish. 
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12.  Press <control> S or save button to save your project and close Framework Manager. 

13.  Open Cognos Connection and launch Query Studio.  Select the TravelExpenseTracking 
package.  Expand the Travel Authorization Query Subject, select the AuthNum and 
TrvDestinations Query Items and drag them into the workspace. 

 
 
14.  Now expand the Expense Item Query Subject and drag the ExpDate Query Item to the 
right of TrvDestinations in the workspace (the right border of that column will be 
highlighted).  Now do the same with the ExpDescrip and Amount Query Items. 
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15.  Select the column headers for AuthNum and TrvDestinations.  Click the Group icon on 
the toolbar. 
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16.  Select the ExpDate column by clicking the column header and click the Group icon. 
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17.  We have quickly created a simple report which demonstrates how easy it is to merge 
data from different document types.  The same approach can be used to merge data from 
different Notes databases or from Notes and relational data sources. 

 
 
18.  Now is a good time to further explore the capabilities of Query Studio and Report 
Studio.  The Travel Expense data model we have created is available to any reports you 
want to create. 
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