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QMF Visionary Tutorial 
About the QMF Visionary Tutorial  
The QMF Visionary Tutorial is a set of exercises that demonstrate how to create and 
deploy business analysis applications, called QMF Visionary worlds. You use QMF 
Visionary Studio to create worlds. You can then deploy your worlds within a client/server 
environment. 

A QMF Visionary world is a graphic display of related data driven by dynamic SQL 
queries. A world consists of scenes, rather than traditional forms or reports. As your end 
user navigates from scene to scene in a world, data displays can change according to 
context. Data is continually updated to what is current in the database.  

In this tutorial, you create two QMF Visionary worlds based on the scenario that the 
Vice President of Human Resources for Acme Corporation wants to present employee 
information dynamically. Traditional reports, such as printed organization charts, are 
static. They contain data that rapidly becomes out of date and is difficult to navigate to 
find specific information. QMF Visionary worlds, however, are dynamic: data is retrieved 
from the database every time you access the world, and you can easily navigate the 
data without losing its context.  

This tutorial demonstrates how to use three of QMF Visionary's data layout formats: an 
organization chart, a matrix, and a simple form. QMF Visionary has many other data 
layout formats; read the DB2 QMF Visionary Developer's Guide for a description of 
each.  

You should have basic knowledge of databases and SQL to use this tutorial.  

The exercises in this tutorial are cumulative; you should complete them in order.  

The tutorial contains the following exercises:  

• Getting Started with QMF Visionary  

• Creating an Organization Chart  

• Adding Detail to the Organization Chart  

• Creating a Navigable Employee Matrix  

• Publishing Your Employee Matrix  
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Software Dependencies  
To use this tutorial, you need the following software:  

• QMF Visionary Version 8.1, QMF Visionary Developer package 

• ODBC, version 3.510.4202.0 or later  

• ODBC Data Source Administrator  

• Microsoft Access 2000  

See the ReadMe file for QMF Visionary for system requirements.  

Configuring the ODBC Data Source 
You must configure an ODBC data source for the vis_employee database installed by 
the tutorial.  

To configure an ODBC data source 

1. Choose Start ► Settings ► Control Panel.  
2. Double-click ODBC Data Sources to launch the ODBC Data Source 

Administrator (Probably in Administrative Tools).  
3. Click the System DSN tab to display the System DSN page.  
4. Click Add to display the Create New Data Source dialog box.  
5. Select the Microsoft Access Driver and click Finish.  
6. In the ODBC Microsoft Access Setup dialog box, type access_employee in the 

Data Source Name box.  
7. Click Select.  
8. In the Open Database dialog box, select vis_employee.mdb from 

Drive:\directory\Tutorial, where Drive:\directory is the location of your QMF 
Visionary installation. By default, this directory is C:\Program Files\IBM\QMF 
Visionary.  

9. Click OK to select the database.  
10. Click OK to define the data source.  
11. Close the ODBC Data Source Administrator.  
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Tips  
Use the QMF Visionary Studio online help to obtain more information about interface 
elements.  

Related Reading  
• DB2 QMF Visionary Getting Started Guide 

• DB2 QMF Visionary Developer's Guide  

These manuals are available in PDF format on the QMF Visionary installation CD-ROM. 
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Tutorial Exercise 1 
Getting Started with QMF Visionary 
In this exercise, you become familiar with QMF Visionary Studio, and create a custom 
workbook to use in subsequent exercises. Workbooks are useful when creating queries. 
A workbook is a filtered view of database objects. The default workbook shows all 
objects in the database. A custom workbook provides a filtered view of the database; 
you include only the information relevant to your world.  

Workbooks can display the following database objects:  

• Tables. Any tables in the database, including system tables.  

• Data types. Built-in data types.  

• Views. Restricted or modified presentations of the data in one or more tables.  

• Routines. Built-in functions and procedures.  

• Synonyms. Tables or views with alternative names.  

Important: You must configure the data source before you start the tutorial. See the 
Configuring the ODBC Data Source section for instructions.  

Exercise Steps 

1. Start QMF Visionary Studio and connect to a data source.  
2. Tour QMF Visionary Studio.  
3. Look at the default workbook.  
4. Close and disable the default workbook.  
5. Create a custom workbook.  
6. Save the workbook.  
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Start QMF Visionary Studio and connect to a data source 

When you start QMF Visionary Studio, you can choose a data source to which QMF 
Visionary Studio connects.  

To start QMF Visionary Studio and connect to a data source 

1. From the Windows Start menu, choose Programs ► QMF Visionary ► QMF 
Visionary Studio.  

2. In the Select Data Source dialog box, select access_employee from the list.  
3. If the Select Data Source dialog box does not appear in QMF Visionary Studio, 

choose File ► Connect to display it. 
4. Type your user name and password in the Login Name and Password boxes 

(Can probably just leave both blank). 
5. Click OK. 

 
2 

 

Tour QMF Visionary Studio 

Look at the parts of QMF Visionary Studio and move them around or adjust their sizes 
to fit your needs.  

When you start QMF Visionary Studio, by default the following QMF Visionary Studio 
components appear:  

• World Manager. Allows you to manage the organization of worlds (on the 
Worlds page) and open data sources (on the Workbooks page). By default, 
QMF Visionary Studio creates a new world when you start it.  

• Scene editor. Allows you to edit and test your scene. By default, when you start 
it, QMF Visionary Studio creates an empty scene belonging to the new world.  

• Palette Manager. Allows you to add graphic objects to a scene.  

• Object Inspector. Allows you to edit the properties and events of objects.  

• Formula bar. Allows you to edit the value of the object property selected in the 
Object Inspector.  

• Output window. Displays information and error messages when you connect to 
a database, run a query, or compile a scene.  
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You can close or hide these components; use the View menu to display them.  

 

 

 

Formula BarWorld Manager Object Inspector

Output Window Scene Editor Palette Manager 
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Look at the default workbook 

QMF Visionary Studio displays the default workbook every time you connect to a data 
source. The default workbook has the same name as the data source and contains all 
the objects in the database.  

To view the contents of the default workbook 

1. Click the Workbooks tab at the bottom of the World Manager.  
2. Click the expander buttons to look at the contents of the access_employee data 

source.  
Notice that along with the vis_employee table, all other tables in your database, 
including system tables (if you have any), are listed, making the workbook seem 
crowded.  
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Close and disable the default workbook 

Because you are going to create a custom workbook, close the default workbook and 
prevent QMF Visionary Studio from loading it the next time you start QMF Visionary 
Studio.  

To close and disable the default workbook 

1. Right-click the workbook name in the World Manager and select Close.  
2. Choose Tools ► QMF Visionary Options.  
3. In the QMF Visionary Options dialog box, click the Login tab.  
4. On the Login page, uncheck the Create and load a default workbook when a 

connection is established check box.  
5. Click OK.  
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Create a custom workbook 

Some databases contain thousands of tables that are not relevant to your application. 
Custom workbooks allow you to work with a subset of tables, views, and routines in a 
database.  

In the other exercises in this tutorial you use data from only the vis_employee table. 
Therefore, create a custom workbook that contains one table: vis_employee.  

To create a workbook 

1. Choose File ► New ► Workbook. The Workbook wizard appears.  
2. Click Next on the first page of the Workbook wizard.  
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3. On the Data Source Selection page, select access_employee from the open 
connections list and click Next.  

 

4. On the Object Type Selection page, uncheck the Procedures box and click 
Next.  

5. On the Function Type Selection page, click Next.  
6. On the Tables, Views, and Synonyms Selection page, use the arrow button to 

move vis_employee from the Data source list to the Workbook list.  
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7. Click Finish.  
The new workbook appears on the Workbooks page of the World Manager with 
the name Workbook1.  
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Save the workbook 

Save your QMF Visionary workbook as a file named employee.vwb.  

To save the workbook 

1. Choose File ► Save Workbook.  
2. Select a location, such as C:\Program Files\IBM\QMF Visionary\Tutorial.  
3. Name the workbook employee and click Save.  

Exercise Summary 

In this exercise, you connected to the access_employee data source and customized 
your QMF Visionary Studio environment by creating a custom workbook containing the 
vis_employee table.  
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Tutorial Exercise 2 
Creating an Organization Chart 
This exercise demonstrates how easy it is to create a simple world in QMF Visionary to 
display your data effectively.  

When you look at an organization chart that is printed on many pieces of paper, it is 
difficult to follow the hierarchy to the group or employee you are most interested in. 
Often, you have to flip through many pages to find the page you want. Also, most 
organizations change frequently, and the content of an organization chart quickly 
becomes obsolete.  

With QMF Visionary, you create an organization chart as part of a QMF Visionary world. 
A QMF Visionary organization chart is dynamic, in both presentation and content. A 
QMF Visionary organization chart uses expander buttons on every parent object to 
display or hide child objects in the hierarchy, allowing you to easily navigate to the 
relevant information. Additionally, a QMF Visionary organization chart is always 
accurate because it is recreated from the database when you access it.  

In this exercise, you become familiar with the basic tasks of creating a QMF Visionary 
world: planning a world, presenting the information, previewing the world, and saving it.  

Exercise Steps  

1. Plan your world.  
2. Create the database query.  
3. Specify how information is presented.  
4. Add information to the organization chart.  
5. Modify the font of the label.  
6. Add a scene title.  
7. Look at your world in the World Manager.  
8. Save your world.  
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Plan your world 

The plan for your world is called a storyboard. A storyboard is the equivalent of a 
pictorial outline of the application you want to create with QMF Visionary. You can use 
any method to create a storyboard: for example, using pencil and paper, or Microsoft 
PowerPoint.  

The storyboard for this exercise contains an organization chart representing all the 
employees in Acme Corporation.  

To create the storyboard  

1. Draw a basic organization chart with two levels: a supervisor and three 
subordinates. Label each box with the word name.  

2. Add Acme Corporation Organization Chart above the chart.  

Your completed storyboard should look like the following illustration.  

 

 

 

 

 

Acme Corporation Organization Chart

name 

name 

name name
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Create the database query 

To specify the information to display in your QMF Visionary world, you first create a 
query.  

In this step, you use the Simple Query wizard to specify the following information about 
the query that supplies data for the organization chart:  

• The table from which to retrieve the data  

• Which columns from the table to retrieve  

• Whether to return individual records or a summary of records  

• The name of the query  

To create a query with the Simple Query wizard 

1. Choose File ► New ► Query.  
2. In the New Query dialog box, select Simple Query Wizard, make sure the 

workbook is employee, and click OK.  
The first page of the Simple Query wizard appears.  
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3. From the Table/view list, select the vis_employee table.  
4. Click the right double arrow button to move all fields to the Selected fields list.  
5. Click Next to display the Summarize Records page.  
6. Make sure Return individual records is selected and click Next.  
7. Type Employee Orgchart in the What do you want to name the query? box 

and click Finish.  
8. Click Yes to execute the query and view all the records retrieved by the query in 

the Query editor.  

 
You should see 15 records.  

9. Close the Query editor window.  
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Specify how information is presented 

QMF Visionary worlds contain one or more scenes. A scene is a visual display of 
information similar to a presentation slide, except contents in a scene can be linked to 
data stored in a database. A scene can also contain static graphics, such as text and 
images, and navigation, such as jumps to other scenes.  

Scenes contain two types of information: static and dynamic. Static information, such as 
a scene title, appears only once in the scene. Dynamic data appears when the scene is 
run by QMF Visionary. Running a scene includes executing the query and retrieving the 
results, as well as calculating values for some of the properties you defined in the 
scene.  

You add dynamic data from the database using a layout, which formats the data from 
the database in meaningful ways. When you insert a layout, you choose a specific 
layout format. QMF Visionary provides many different layouts that you can customize to 
accommodate your data. For more information about QMF Visionary layouts, see the 
DB2 QMF Visionary Developer's Guide.  

To add a layout to your scene, use the Scene Editor. The Scene editor has two modes: 
design mode and runtime mode. You use design mode to add to and edit your scene. 
You use runtime mode to test your scene. You change between the modes by clicking 
the buttons at the bottom of the editor.  

For this exercise, you use the organization chart layout. An organization chart portrays a 
parent-child relationship between data, which in this case is the relationship between 
the supervisor ID and the employee ID.  

To insert a layout into the scene 

1. Click the Design Mode button at the bottom of the Scene Editor to make sure 
you are in the correct mode, and then click in the scene.  

2. On the Layout palette on the Palette Manager, double-click the Organization 
Chart layout (you might have to scroll down the palette to see it). The Step 2 
page of the Layout wizard appears.  
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3. From the list of queries, select Employee Orgchart and click Next. The Step 3 
page of the Layout wizard appears.  

 

4. From the Parent field list, select superid (which represents the supervisor ID).  
5. From the Child field list, select empid (which represents the employee ID).  
6. In the Size of child objects relative to parent objects box, change the value to 

1.  
7. From the Label field list, select lastname so that the employee's last name is 

displayed as text on the chart.  
8. Click Finish.  

The Data Template Selector and Editor appear at the bottom of the Scene Editor.  

9. Click the Runtime Mode button to view your results.  

 
Notice the expander buttons on the bottom of some of the boxes; click them to 
show more of the chart.  

10. Click the Design Mode button to continue.  



© Copyright IBM Corp. 2004; Copyright Rocket Software Inc., 1998-2004 Page 17 

 

 
4 

 

Add information to the organization chart 

In the Data Template Editor, you see the template for each data point.  

 

The template represents how each retrieved record is displayed at runtime. For the 
organization chart layout, this template consists of a rectangle, its label, a horizontal 
line, and a connector line. Each of these objects has properties that you can modify. If 
you modify objects in the Data Template editor, at runtime you see those changes for 
every data point. Notice the Variables toolbar at the top of the Scene Editor. You select 
the type of variable in the left list, then the specific variable in the right list. Variables 
include all columns returned by queries. 

You will edit the label for each data point in the layout to display the first name as well 
as the last name for each employee. In the Layout wizard, you specified that the label 
show the value of the lastname column. You now add the firstname column. To do so, 
you modify the label's Value property using the Object Inspector.  
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When you edit the Value property, include a blank space between the first and last 
name. The format for this text string is:  

=column_name+" "+column_name 

You use an equals sign to indicate that the value is calculated (constants do not use an 
equals sign). Include quotation marks around any blank spaces, punctuation, or literal 
text.  

To add the first name to the label 

1. In the Data Template Editor, click the word Label to see its properties in the 
Object Inspector. If the Object Inspector is not open, display it by right-clicking 
the word Label and selecting Properties.  
Notice that the name of the object in the Object Inspector is Text1.  

 

2. In the Value cell, add firstname+" "+ between the equals sign and lastname to 
produce the following string:  
    =firstname+" "+lastname 

Notice that the value of the Value cell also appears in the Formula bar above the 
editor window. You can edit values in the formula bar as well as in the Object 
Inspector.  

3. View your changes in runtime mode.  
Notice that some employee names are too long: for example, Dennis Coleman.  

 

4. Return to design mode.  
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Modify the font of the label 

As you can see in runtime mode, the name of the employee does not always fit in the 
organization chart box. To fix this problem, you will reduce the font size of the Text1 
object. You will also edit the font properties so that the font remains the same size at a 
greater zoom level (this will be important in Exercise 2).  

Tip: You could use other methods in QMF Visionary Studio to make the names fit: for 
example, by enlarging Text1.  

To reduce the font size of the Text1 object 

1. In the Data Template Editor, click the Text1 object to see its properties in the 
Object Inspector.  

2. Click the expander button in front of the word Font to see its properties.  

3. Change the value of the Size property from 10 to 8.  

4. Change the value of the Fixed Size property to True.  
5. View your changes in runtime mode.  

Notice that the names now fit in the chart.  

 

6. Return to design mode.  
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Add a scene title 

Add a title to the scene in the upper windows of the Scene Editor. The scene title is 
static text, and it appears only once in the scene. When you add static objects in the 
Scene editor, make sure they do not overlap the layout for the dynamic data. The layout 
is bounded by a dotted line.  

To add static text to the scene 

1. Click in the upper window of the Scene Editor.  
2. From the Primitives palette on the Palette Manager, double-click Text.  
3. Move the cursor over the selected text object until it is a four-headed arrow, and 

then drag the object so that it is directly above the layout.  

4. Type Acme Corporation Organization Chart in the text object.  
5. Widen the text object to fit the text by dragging its handles with the double arrow 

cursor.  
6. View your change in runtime mode.  

 

7. Return to design mode.  
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Look at your world in the World Manager 

Click the Worlds tab of the World Manager to look at the Worlds page and see the 
elements in your world.  

 

Notice the following attributes of your world:  

• Scene1 has one level, which has one layout (Organization Chart1).  

• The Organization Chart1 layout has one data template, which is linked to the 
Employee Orgchart query.  

• Data Template1 has one level, which contains the five organization chart 
objects.  

• Level1 contains a Text1 object, which is the chart title.  

• There is one query, Employee Orgchart.  

You can use the Worlds page to perform the following actions:  

• Double-click an object name to select it for editing.  

• Double-click a scene, data template, or query to open its corresponding editor 
window.  

• Right-click any element to access menu options.  
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Save your world 

Save your QMF Visionary world as a file named Orgchart.vwx. Because QMF 
Visionary allows concurrent development, you must save each QMF Visionary world in 
a different directory. 

To save your world 

1. Choose File ► Save World.  
2. Select a location, such as C:\Program Files\IBM\QMF Visionary 

\Tutorial\orgchart (you will have to create the orgchart subdirectory).  
3. Name the world Orgchart and click Save.  

Exercise Summary 

In this exercise, you have become familiar with using QMF Visionary Studio.  

You have completed the following tasks:  

• Defined a query  

• Specified a layout  

• Edited an object in the Data Template editor  

• Added static text in the Scene editor  

• Previewed your scene in runtime mode  

• Looked at the structure of your world in the World Manager  

• Saved your world  
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Tutorial Exercise 3 
Adding Detail to the Organization Chart 
This exercise demonstrates how easy it is to customize the standard layouts QMF 
Visionary provides to meet your business needs.  

To add more information about each employee to a printed organization chart, you will 
have more pieces of paper and a harder time navigating. Also, the more information you 
display, the more quickly it can become obsolete.  

In QMF Visionary, one way you can add more information to your organization chart is 
with a second level of detail. A level of detail is a view of data associated with a zoom 
level. As you zoom in, fewer data points are displayed, and more screen area is 
available for showing details. Your users can move to the second level to see the 
additional information when they click the zoom button and then click the scene. QMF 
Visionary allows you to empower the user to choose how much information to see.  

In this exercise you use the Data Template Editor to edit your world.  

Exercise Steps  

1. Add to the storyboard.  
2. Add a level of detail.  
3. Add the information you want to display.  
4. Add a picture.  
5. Map the Picture object to the location of the employee photos.  
6. Increase the zoom percentage to display all the data.  
7. Delete the horizontal line.  
8. Review and save your world.  
9. Close the world.  
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Add to the storyboard 

The storyboard for this exercise adds to the storyboard you created in Exercise 1. The 
second level of detail contains the employee name, title, address, and photo.  

To complete the storyboard 

1. Below the original scene, draw a box containing an employee name, title, 
address, and photo. The box could have dotted lines to differentiate it from the 
main scene.  

2. Add dotted lines from one of the employee boxes in the main scene to the 
corners of the second level to indicate the link between them.  

Your completed storyboard should look like the following illustration.  

 

 

 

 

 

 

 

 

 

Acme Corporation Organization Chart

name 

name

name 

name 
title 
address

photo

Second level of detail

name
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Add a level of detail 

When you add a level of detail to the data template, you work with the same layout. 
Level2 then looks identical to Level1; however, its objects are distinct and can have 
different properties. After you edit object properties for Level2, when you zoom in on the 
organization chart, the second level has larger boxes with more information.  

Tip: You could add access to more information in other ways using QMF Visionary 
Studio: for example, by adding a jump to another scene.  

After you create another level of detail, you can view and modify it by clicking the 
corresponding Level tab on the left side of the Data Template editor, or by clicking the 
corresponding Level object in the Data Template selector.  
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To add a level of detail  

1. Click anywhere in the Data Template Editor window.  
2. Choose Insert ► Level of Detail.  
3. Click Yes to use the same objects in the second level as in the first.  

The Data Template editor displays Level2, which looks identical to Level1.  

 

4. Click the Level1 tab to make sure both levels look the same, and then return to 
Level2.  

5. Look at the Worlds page of the World Manager.  

Notice that Level2 is below DataTemplate1 and contains the same five objects 
as Level1.  
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Add the information you want to display 

To display the name, title, and address of the employee in this level of detail, you need 
to include data from these columns: firstname, lastname, title, address, city, state, 
and zipcode.  

You associate the columns you want to display with the Value property of the Text1 
object (the label).  

Tip: You can copy the text for the Value property from this tutorial and paste it into the 
Value cell.  

To edit the label text 

1. In the Data Template Editor, click the word Label to see its properties in the 
Object Inspector.  

If you have trouble selecting the Text1 object, you can choose Text1 from the list 
box at the top of the Object Inspector.  

2. Click the Value cell.  
3. In the Formula bar, add the following string after the existing string:  

    +newline+title+newline+address+newline+city+", "+state+" "+zipcode 

 

4. Click the Runtime Mode button to view your changes.  

Notice that runtime mode shows Level1; you must zoom in to see Level2.  
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5. Use the Zoom in tool (  ) on the toolbar to see the second level of detail.  

Notice that you cannot see the whole address for some employees: for example, 
Alana Aries. You will solve this problem in a later step.  

 

6. Click the Design Mode button to return to design mode.  
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Add a picture 

To add the employee's photo to the second level of detail, you first add a Picture object 
to the box (Rectangle1), in the Data Template Editor. The Picture object is a 
placeholder for the actual employee images that will be retrieved from the database. 
You map the value of a database column to the Picture object in the next step.  

To add a picture object 

1. From the Primitives palette of the Palette Manager, double-click the Picture 
object.  

The Picture object appears on top of Rectangle1.  

2. Click the Picture object and then press the down arrow key to move it 0.1 inch.  
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Map the Picture object to the location of the employee photos 

The filenames of the photos are stored in the image column, while the actual photos are 
stored on the file system. To link the Picture object to the photo, you map its 
ImageSource property to a concatenation of the directory where the photos are stored 
and the filename stored in the image column.  

To map the Picture object to the image column 

1. While in the Data Template Editor, click the Picture1 object so that its properties 
are displayed in the Object Inspector.  

2. Type the following string in the ImageSource property value cell:  

    =concat('Drive:\path\Tutorial\Images\',image)  

Drive:\path represents where QMF Visionary is installed on your computer. The 
default location is C:\Program Files\IBM\QMF Visionary. The single quotation 
marks around the directory indicates that it is a string, in contrast to image, which 
is a column name. 

 

3. View your changes in runtime mode.  

Notice that you can now see the employee pictures, although, they obscure part 
of the address.  

 

4. Return to design mode.  
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Increase the zoom percentage to display all the data 

As you saw in runtime mode, the Rectangle1 object is not large enough to display all 
the text and the employee photos.  

In this step, you edit the zoom percentage of Rectangle1 to make it larger. The default 
zoom percentage for Level2 is 200%. To have enough room for all the data you want to 
display, change the zoom percentage to 300%. This means you do not see Level2 until 
the zoom percentage is at 300% or greater, which requires two clicks of the Zoom in 
tool. To see Level2 after only one click of the Zoom in tool, you need to change the 
ClickZoomFactor property of the scene to 300%.  

Tip: You could use other methods in QMF Visionary Studio to solve this problem: for 
example, you could change the height and width properties of the Rectangle1 object in 
Level2.  

To edit the zoom property of the level 

1. In the Worlds page of the World Manager, right-click the Level2 folder under the 
DataTemplate1 folder and choose Edit Level Transitions.  

 

2. In the Level-of-Detail Transition Editor dialog box, change the value in the Level2 
cell from 200 to 300.  

3. Click OK.  
4. Click in a blank part of the upper window of the Scene Editor (or choose Scene1 

from the list at the top of the Object Inspector).  

5. In the Object Inspector, change the ClickZoomFactor property to 300%.  
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6. View your changes in runtime mode.  

Notice how large the box is when you zoom once to 300%, and that you can now 
see all the data and the photos.  

 

7. Return to design mode.  

 
7 

 

Delete the horizontal line 

The horizontal line detracts from the employee photo; delete it.  

To delete the line 

1. Click the horizontal line on Rectangle1 (in Level2) to select it and press Delete.  

If you have trouble selecting the line, double-click Line1 under the Level2 folder 
on the Worlds page of the World Manager.  

2. View your changes in runtime mode.  

Notice that the line is gone.  

 

3. Return to design mode.  
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Review and save your world 

Review your world by looking at it on the Worlds page of the World Manager.  

 

Notice that Level2 no longer has the same five objects as Level1: Level2 does not have 
a Line1 object, and it has a Picture1 object.  

Save the world.  
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Close the world 

You are finished working with this world. In the next exercise, you create a new world. 
To close this world, right-click the world name in the World Manager and select Close.  

Exercise Summary 

In this exercise, you have seen how easy it is to modify a QMF Visionary world to add 
complexity without losing ease of navigation.  

You have completed the following tasks:  

• Added a level of detail  

• Added and edited objects  
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Tutorial Exercise 4 
Creating a Navigable Employee Matrix  
This exercise demonstrates how to add navigation and other advanced features to a 
QMF Visionary world.  

In the previous exercise, you used a level of detail to display more information in the 
same scene. In this exercise, you create a world in which you display more information 
by navigating between two scenes with a wormhole. A wormhole is a portal that allows 
you to move from a source scene to a destination scene, typically by clicking the 
wormhole. A wormhole also acts as a window onto the destination scene; it allows you 
to view some or all of the contents of the destination scene. A wormhole differs from an 
ordinary link in that it can pass information from one scene to another.  

In this exercise, you will give your user a choice, and the user's response will affect the 
data displayed in the destination scene. QMF Visionary enables you to capture user 
information (or other information, such as a query result) and pass it to other parts of 
your world with parameters. Parameters are variables that can be assigned values and 
can be of the following types:  

• Global. Available to all scenes in a world. You do not use global variables in this 
exercise.  

• Scene. Available only for the scene for which it is defined; passed from one 
scene to another by a wormhole or event action.  

• Query. Set at runtime before a query is executed; simplifies the process of 
changing query criteria.  

In this exercise, the wormhole passes a value to a scene parameter. The scene 
parameter then passes that value to the query parameter, which sets the value of a 
column in the query's WHERE clause. 

 

 

In the world you create in this exercise, the wormhole passes an employee ID to the 
scene parameter, which passes it to the query parameter. The query for Scene2 selects 
the record corresponding to the value of the employee ID. Therefore, when your user 
passes through the wormhole to Scene2, Scene2 displays information about the 
employee the user clicked in Scene1.  

wormhole 
in Scene1 

scene 
parameter 

query 
parameter

query for 
Scene2 record 

value value value
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The first several steps in this exercise are similar to steps you performed in previous 
exercises to create queries and format the display of data; subsequent steps involve 
more advanced features of QMF Visionary. Scene1 of this world contains wormholes 
that display a portion of Scene2. Scene2 contains the data about each employee. The 
strategy in this exercise is to first construct Scene2 and then complete Scene1.  

Exercise Steps  

1. Create the storyboard.  
2. Create a new world.  
3. Define the query and query parameter for Scene2.  
4. Create Scene2 and insert a layout.  
5. Add text objects to Scene2.  
6. Associate data with the text objects.  
7. Add a tooltip to Text1.  
8. Add a scene parameter to Scene2.  
9. Set the query parameter to be the value of the scene parameter.  
10. Add the Exit button to Scene2.  
11. Add the Calculator button to Scene2.  
12. Define the query for Scene1.  
13. Insert a layout into Scene1.  
14. Add a wormhole to Scene1.  
15. Set the value of the scene parameter.  
16. Review and save your world.  

 



© Copyright IBM Corp. 2004; Copyright Rocket Software Inc., 1998-2004 Page 36 

 

 
1 

 

Create the storyboard 

The storyboard for this world contains two scenes. Scene1 is a group of rectangles in a 
matrix pattern that act as windows to display content from Scene2. Each rectangle is a 
wormhole to Scene2; when you click a rectangle, you go to Scene2.  

Scene2 displays the name, title, and job description of the employee whose box you 
clicked in Scene1. The employee's accrued vacation hours are shown as a tooltip when 
you place the cursor over the employee name. Scene2 has a button to return to Scene1 
and a button to launch the Microsoft calculator applet so you can convert vacation hours 
to vacation days.  

To create the storyboard 

1. Draw Scene1 as a matrix of three by two boxes, each displaying an employee 
name and title.  

2. Draw Scene2 as two boxes, one above the other, the first displaying an 
employee name and title and the second displaying a job description.  

3. Draw an arrow from a box in Scene1 to Scene2. (Each box is a wormhole; this 
storyboard represents only one of them). Label the arrow Wormhole.  

4. Add two buttons below the job description in Scene2, labeled Exit and 
Calculator.  

5. Draw an arrow from the Exit button to Scene1. Label the arrow Exit wormhole.  
6. Draw a calculator.  
7. Draw an arrow from the Calculator button to the calculator. Label the arrow 

Launch application.  

8. Draw a tooltip box next to the employee name in Scene2. Write Vacation hours 
inside the box. Label the box Tooltip.  
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Your completed storyboard should look like the following illustration. 
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Create a new world 

If you have shut down QMF Visionary Studio, perform the following tasks:  

1. Start QMF Visionary Studio. 
A new world called World1 appears in the World Manager, along with Scene1 for 
that world.  

2. Click the Workbooks tab in the World Manager and then choose File ► Open to 
open your workbook.  

3. In the Open dialog box, select employee.vwb and click Open.  

If you have not shut down and restarted QMF Visionary Studio, choose File ► New ► 
World to create a new world. A new world appears in the World Manager, and a new 
scene appears in the Scene Editor.  

To close a world you are not currently working on, right-click the world name in the 
World Manager and choose Close World.  

Scene 1: Matrix Scene 1: Job Description 

name 
title 

name 
title 

name 
title 

name 
title 

name 
title 

name 
title 

name 
title 

job description 

Exit Calculator 

Vacation hours

Tooltip

Exit 
wormhole 

Wormhole

Launch 
application 

Calculator 
applet 



© Copyright IBM Corp. 2004; Copyright Rocket Software Inc., 1998-2004 Page 38 

 

 
3 

 

Define the query and query parameter for Scene2 

Before you create Scene2, you will create its query and query parameter.  

Unlike the queries you have created previously in this tutorial, the query for Scene2 
uses an SQL WHERE clause that filters the data to return specific information instead of 
every row. The query should return the record whose employee ID matches the one you 
clicked in Scene1. Therefore, you specify that the query return a record in which the 
value of the empid column is equal to a query parameter. In addition to the empid 
column, the query must return the columns whose data you want to display: firstname, 
lastname, title, vacation, and jobdesc.  

Because this query contains a filter, you use the Advanced Query wizard to create it. 
You also create the query parameter as part of the process of defining the filter. When 
you create the query parameter, you specify its data type as integer, because that is 
the data type of the empid column (you can see information about the empid column 
on the Workbooks page of the World Manager). You also specify that the default value 
is 1, which corresponds to the employee with an ID of 1.  

Tip: A good naming convention for parameters is to indicate what type of parameter it is 
in the name. For example, you could preface query parameters with Q_, scene 
parameters with S_, and global parameters with G_.  

To define the query and query parameter for Scene2 

1. Choose File ► New ► Query.  
2. Select the Advanced Query wizard from the New Query dialog box and click OK.  
3. Move the following fields from the available list to the selected list: empid, 

firstname, lastname, title, vacation, and jobdesc. Click Next.  
4. Leave No selected on the additional information page and click Next.  
5. Click the Yes, filter the rows based on additional criteria button and then click 

Next.  

6. On the search constraint page, click the Column button (  ) to select a column.  
7. Select vis_employee.empid in the Choose Column dialog box and click OK.  

The text vis_employee.empid appears in the criteria box.  
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8. Click Define Parameter and fill in the following information in the Query 
Parameters dialog box:  

Parameter name: Q_empid  

Data type: Integer 

Description: employee ID  

Has default value: 1  

9. Click Set and then OK.  

10. Type = after vis_employee.empid in the criteria box.  

 

11. Click the Column button again, select Q_empid in the Choose Column dialog 
box, and click OK.  

The criteria should be vis_employee.empid=Q_empid.  

12. Click Next.  
13. Click Next to return individual records.  

14. Name the query JobDescription and click Finish.  
15. Click Yes to view the query results.  

Notice that the only record retrieved is for Alana Aries, who has the employee ID 
of 1.  

16. Close the Query editor.  
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Create Scene2 and insert a layout 

Add a second scene and insert a Simple Form layout that is mapped to the 
JobDescription query. A Simple Form layout is often used to display information for a 
query that returns only one row.  

The Simple Form layout does not contain any objects; you will add objects to it in the 
next step.  

To create Scene2 and insert a layout 

1. Choose File ► New ► Scene.  
2. In the New Scene dialog box, click OK to accept the name Scene2.  

A new Scene Editor window appears, titled Scene: Worldn.Scene2.  

3. Double-click Simple Form on the Layouts palette of the Palette Manager.  
4. Select the JobDescription query and click Finish.  

A blank Data Template editor window appears.  
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Add text objects to Scene2 

To display data in Scene2, add two text objects to the blank Simple Form layout. Use 
the Object Inspector to modify the font and size of the text displayed, and add a border 
to the text object.  

To add and format text objects to Scene2 

1. While in the Data Template editor (the bottom frame of the Scene Window), 
double-click Text on the Primitives palette of the Palette Manager.  
A text object appears. Notice that it is called Text1 in the Object Inspector.  

2. In the Object Inspector, change the following properties of Text1:  

Width: 2.0  

Height: 0.5  

AutoHeight: False  

AutoWidth: False  

3. Expand the Frame property of Text1, expand LineStyle, and change Pattern to 
Solid.  
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4. Expand Font and then change Size to 8.  
5. Right-click Text1 and select Copy and then right-click a blank portion of the data 

template and select Paste.  
The second text object appears on top of the first. Notice that it is called Text2 in 
the Object Inspector.  

6. If it is not already selected, select Text2. If you have trouble selecting it, double-
click Text2 on the Worlds page of the World Manager.  

7. Move Text2 below Text1 using the crossed-arrow cursor.  

8. Change the Height property of Text2 to 1.5.  
Your text objects should look like the following illustration.  
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Associate data with the text objects 

The Text1 object is what you will see through the wormhole in Scene1. The text it will 
display is the employee name and title. Text2 will contain the job description. To map 
columns to a text object, you edit its Value cell in the Object Inspector.  

Tip: You can copy the text for the Value properties from this tutorial and paste it into the 
corresponding Value cell.  

To map columns to the text objects 

1. Edit the Value property of Text1 to the following string:  

=firstname+" "+lastname+newline+title 

2. Edit the Value property of Text2 to the following string:  
=jobdesc 

3. Click the Runtime Mode button to view your changes.  
Notice that the employee displayed is Alana Aries, whose employee ID is 1. This 
is the default value of the query parameter.  

 

4. Click the Design Mode button to return to design mode.  
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Add a tooltip to Text1 

You will add a tooltip to Text1 to display the words Vacation Hours: and the number of 
accrued vacation hours for the employee. To create a tooltip for an object, you assign a 
value to its ToolTipText property.  

To add a tooltip to display vacation hours 

1. On the Worlds page of the World Manager, double-click Text1 so that its 
properties are displayed in the Object Inspector.  

 

2. Edit the value of the ToolTipText cell to the following string:  
="Vacation Hours: "+vacation 

3. Move to runtime mode and place the cursor over Text1.  
Notice that Alana Aries has 81 hours of vacation time.  

4. Return to design mode.  
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Add a scene parameter to Scene2 

The scene parameter links the wormhole you will add in Scene1 to the query parameter, 
Q_empid, in Scene2. The value of the scene parameter determines what data is 
displayed in Scene2. When the user clicks a wormhole, the scene parameter passes 
the employee ID associated with that employee to the query parameter, and then the 
query returns the data for that employee. The scene parameter should have the same 
data type as the query parameter.  

To insert a scene parameter 

1. Choose Insert ► Scene Parameter.  
2. In the Insert Scene Parameter dialog box, fill in the following information:  

Name: S_empid  

Data type: integer  

Has default value: 3  

3. Click OK.  
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Set the query parameter to be the value of the scene parameter 

To pass a value from the scene parameter to the query parameter, you set the value of 
the query parameter equal to the scene parameter.  

To set the scene parameter equal to the query parameter 

1. Select Form1.QueryParameters1 from the Object Inspector's list box.  

 

2. From the Variables type list, choose Scene Parameters, and from the Variables 
list, choose S_empid.  

3. Click the link button, and then the Q_empid cell in the Object Inspector.  
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4. View Scene2 in runtime mode.  
Notice that the employee displayed is now Dennis Coleman, whose employee ID 
is 3. This is the default value of the scene parameter, which now sets the query 
parameter.  

 

5. Return to design mode.  

 
10 

 

Add the Exit button to Scene2 

The Exit button uses an event action to send you back through the wormhole to 
Scene1. An event action is a procedure automatically executed in response to a 
specified event. You associate an event, such as a mouse click, with an action, such as 
jumping to another scene. To set the event action, you use the Events page for the 
button in the Object Inspector.  

To add the Exit button 

1. Click in the Data Template editor for Scene2.  
2. Double-click Button on the Controls palette of the Palette Manager.  

Notice that Button1 applears in the Object Inspector.  

3. Move the button below the Text2 object.  

4. Change the Caption property of Button1 to Exit in the Object Inspector.  
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5. Click the Events tab at the bottom of the Object Inspector.  

 

6. Double-click the Click event.  
7. In the Object Behavior dialog box, select Exit wormhole from the Action list.  
8. Click OK.  
9. View the Exit button in runtime mode.  

 

10. Click the Exit button.  
Notice that the Exit button does not work; it only sends you back through the 
wormhole if you have entered the scene through the wormhole.  

11. Return to design mode.  
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Add the Calculator button to Scene2 

You add the Calculator button to enable users to convert vacation hours to vacation 
days. The Calculator button uses an event action to launch the Microsoft Calculator 
applet.  

To add the Calculator button 

1. Double-click Button on the Controls palette of the Palette Manager.  
2. Move the new button (Button2 in the Object Inspector) below the Text2 object 

and to the right of the Exit button.  

 

3. Change the Caption property of the button to Calculator in the Object Inspector.  
4. Right-click the Calculator button and choose Behavior.  

Notice that this action has the same effect as double-clicking the Click event in 
the Object Inspector, which you performed in the previous step.  

5. In the Object Behavior dialog box, select Launch another application from the 
Action list.  

6. Click Browse to open the Open Executable Files dialog box.  
7. Find the calculator executable and click OK. The calculator executable is 

typically in one of the following locations:  

• Windows NT: C:\WINNT40\system32\Calc.exe  

• Windows 98 or 2000: C:\Windows\Calc.exe  
8. Click OK to close the Object Behavior dialog box.  
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9. View the Calculator button in runtime mode.  

 

10. Click the Calculator button.  
Notice that the Calculator applet appears.  

11. Return to design mode.  
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Define the query for Scene1 

Scene1 does not contain its own data, but only wormholes showing a portion of the data 
in Scene2. Therefore, you do not map any columns to any objects in Scene1. However, 
you do need a query for Scene1. Although queries usually supply columns that are 
displayed in the layout, in this case the query supplies the column (empid) that is used 
in a scene parameter.  

Scene1 displays a portion of the possible versions of Scene2, as shown in the following 
illustration.  

 

 

 

 

 

 

 

 

 

 

Use the Simple Query wizard to define a query with the values listed in the following 
table.  

Wizard Options  Value  
Name of table vis_employee 
Fields to select empid 
Individual or summarized records Individual records 
Name of query Matrix 
Execute the query Yes 
 

Scene2 

Scene1 

Wormhole 
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Insert a layout into Scene1 

For this step, you insert a matrix layout into Scene1. Unlike the organization chart 
layout, the matrix layout does not have a label to display data. To display data in a 
matrix, you add other objects, such as text objects, or, as in this exercise, a wormhole.  

The default matrix rectangle size is one inch square. This size, however, is not wide 
enough to display the employee name and is higher than necessary. Therefore, you will 
change the default size of the matrix box in the Layout wizard. The default matrix is four 
columns wide; however, because you make the rectangles wider, you will change the 
columns to three.  

To insert the matrix layout into Scene1 

1. Click the Worldn.Scene1 button on the Scene Editor Window taskbar (below the 
Scene Editor).  

2. Double-click Matrix on the Layouts palette of the Palette Manager. 
3. Select the Matrix query in the Layout wizard and click Next.  

The Step 3 page of the Layout wizard appears.  

4. Change Cell width to 2.0 and Cell height to 0.5.  

 

5. Change the number of columns to 3.  
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6. Click Finish.  
The Data Template editor for the matrix layout appears.  
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Add a wormhole to Scene1 

You will add a wormhole to Scene1 and specify Scene2 as the wormhole destination. 
You will also specify how to enter the wormhole: either by clicking it with the pointer (the 
default) or by using the Wormhole tool. In this exercise, choose the default action.  

To add a wormhole 

1. Click anywhere in the Data Template editor for Scene1.  
2. Double-click Wormhole on the Portals page of the Palette Manager.  
3. In the Wormhole dialog box, select Scene2 as the destination scene and click 

OK.  
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4. Change the size of the wormhole to be the same as the matrix rectangle by 
editing the following properties in the Object Inspector:  

Width: 2.0  

Height: 0.5  

5. View Scene1 in runtime mode.  
Notice that the content displayed through each wormhole is the same.  

 

6. Return to design mode.  

Tip: If you do not see the employee name and title through the wormholes, you should 
make sure that the SceneCenter property of the wormhole is 0,0. You can also try 
moving the text objects in Scene2 until you see the name and title.  
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Set the value of the scene parameter  

To pass a value through a wormhole, you use the scene parameter you created in Step 
8. Wormholes carry information from their source scenes to their destination scenes 
using parameters. Each wormhole has a scene parameter as a child object. You added 
the wormhole to the scene in the Data Template Editor, so that is where you will set the 
scene parameter.  

To set the scene parameter value 

1. Click anywhere in the Data Template editor for the matrix layout.  
2. Select Wormhole1.SceneParameters1 from the Object Inspector list box.  

 

3. Select matrix from the Variables type list and empid from the Variables list.  
4. Click the link button and then click the S_empid cell in the Object Inspector.  

The value =empid appears in the S_empid cell.  

5. View Scene1 in runtime mode.  
Notice that each wormhole now displays different data.  

 

6. Click a wormhole to travel to Scene2.  
7. Click the Exit button to return to Scene1.  
8. Return to design mode.  
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Review and save your world 

Review your world by looking at it on the Worlds page of the World Manager.  

 

Notice the following attributes of your world:  

• There are two scenes.  

• Scene1 has one layout, Matrix1, which has a data template that is linked to the 
Matrix query.  

• The data template for Scene1 contains two objects: Rectangle1 and 
Wormhole1.  

• Wormhole1 is linked to Scene2.  

• Scene2 has a local scene parameter, S_empid.  

• Scene2 has one layout, Form1, which is linked to the JobDescription query.  

• The Form1 layout contains four objects: two text objects and two buttons.  

• There are two queries.  

Save your world with the name Matrix, in a new directory called matrix.  
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Exercise Summary 

In this exercise you learned about some of the QMF Visionary features you can use to 
enable navigation and user input, as well as how to add controls to your application.  

You performed the following tasks:  

• Added a wormhole and a control linked to an event action to move from one 
scene to another  

• Added a control to launch an application  

• Added a tooltip that displays data from a database column  

• Used scene and query parameters to allow the user to specify what information 
to retrieve from the database  
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Tutorial Exercise 5 
Publishing Your Employee Matrix 

This exercise demonstrates how to publish your QMF Visionary world so that users can 
access it.  

After you complete your world, you publish it. After you publish it, however, you can 
easily modify and republish your world as your business requirements change.  

When you publish a world, QMF Visionary gives you options so that you can configure 
your world for your business needs. Typically, you consult database and system 
administrators about which options to choose.  

You use the Publish wizard to specify the following attributes for the world:  

• Choose to deploy it. Deploys the world within a client/server environment (local 
or networked drive). This option has a two-tier architecture: the database server 
and the client. On the client computer, you must define the data sources for your 
world. In this exercise, you publish your world to a local drive. 

• Filename. The name of the published world, with a .vis extension.  

• Which scene to display. Determines which scene a user sees first. 

• Authentication method. Controls access to the database. You have the 
following options:  
o Anonymous access. The end-user does not log in to the database. Instead, 

you supply a user name and password, and your users are not prompted for 
individual logins. In this exercise, you use anonymous access.  

o Require login. The end-user must login to the database. The user name and 
password for every user must be valid for every database accessed by the 
world, or the user is denied access. 

• Connection options. The maximum number of connections that can be opened 
by each user for each database. Two connections are usually sufficient unless 
the world has multiple layouts in a single scene.  

• Limit on the number of returned rows. If any of the queries in a world could 
result in a large number of returned rows, you should consider limiting their 
number.  

Depending on the options you choose, you might need to specify other information. For 
more information, see the DB2 QMF Visionary Developer's Guide.  

To publish a world 

1. If necessary, open the Matrix world.   
2. Choose Tools  Publish World. The Publish wizard appears. 
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3. On the Deployment page, click To a local or networked drive and then click 
Next.  

4. On the Name page, select a directory for your world, name it Matrix.vis, leave 
Scene1 as the first scene, and click Next.  

5. On the Database Access page, click Allow anonymous access and click Next.  
6. On the Login Information page, type your user name and password.  
7. Click Test Connection to test the connection.  
8. If the connection succeeds, click OK and then click Next. If the connection fails, 

check your user name and password. 
9. On the Connection Options page, click Next to accept the default of two 

connections.  
10. On the Dataset Limits page, click Next to accept the default of 1000 rows.  
11. On the Testing page, click Next to test your world.  
12. On the Summary page, click Finish. Your published world is displayed. 

Exercise Summary 

In this exercise, you converted your QMF Visionary world to an application suitable for 
end users and explored some of the options available when you publish a world. 


