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About this book

This book describes how to use the QMF"" for Windows® and QMF for
WebSphere® applications.

Who should read this book
This book is intended for all QMF for Windows or QMF for WebSphere users.

Conventions and terminology used in this book

This book uses the following highlighting conventions:

* Boldface type indicates commands or user interface controls such as names
of fields, folders, icons or menu choices.

* Monospaced type Used for system messages and command syntax. indicates
examples of text that you enter exactly as shown such as commands and
system messages.

e Italic type indicates variables that you should replace with a value,
identifies publications, emphasizes significant words and specifies optional
steps in a task.

Service updates and support information

To find service updates and support information, including software FixPaks,
PTFs, Frequently Asked Questions (FAQs), technical notes, troubleshooting
information, and downloads, refer to the following address:

www.ibm.com/software/data/qmf/support.html

Where to find information
The DB2 Information Management Web site provides current product
documentation that you can view, print, and download. To locate publications
with the most up-to-date information, refer to the following:

www.ibm.com/software/data/qmf/library.html

An IBM® Redbook that covers QMF for Windows is available, refer to the
following:

www.ibm.com/software/data/qmf/support.html

© Copyright IBM Corp. 2004 ix



Accessibility features

Accessibility features help a user who has a physical disability, such as
restricted mobility or limited vision, to use a software product successfully.
The major accessibility features in QMF for Windows enable users to:

* Use assistive technologies such as screen readers and screen magnifier
software.

* Operate specific or equivalent features using only the keyboard.

For more information on accessibility for the QMF for Windows and QMF for
WebSphere applications see [Appendix A, “Accessibility,” on page 281|

How to order DB2 QMF books

To order hard copies, contact your IBM representative or visit the IBM
Publications Center on the world wide web at:

http:/ /www.elink.ibmlink.ibm.com/applications/public/applications
/publications/cgibin/pbi.cgi. Or, you can call 1-800-879-2755 in the United
States or any of its territories.

How to send comments

Your feedback is important in helping to provide the most accurate and
high-quality information. If you have any comments about this book, go to
http:/ /www.ibm.com/software/data/qmf/support.html, and click on
Feedback.

X  Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



Summary of Changes

Several modifications to the documentation have been made to QMF for

Windows for Version 8.1:

Table 1. Chapter 4 - Revisions and enhancements

Chapter 4 - Defining servers

Revision or enhancement

Description

OLAP query support

Support has been added for multidimensional OLAP
(Online Analytical Processing) queries. This includes
an OLAP Query Wizard, which helps users to create
OLAP queries; filtering options to customize the data
that is presented in the OLAP query results view;
dynamic formatting of the query results using
extended grouping options, and improved
navigation tools including the Database Explorer,
Query Results Explorer, and the Layout Designer.

Query Results Explorers

The Query Results Explorer is a dockable tool
window that displays the query results in a tree
structure. For relational and OLAP query results,
users can drag columns to and from nodes and
branches of the tree to restructure the appearance of
the query results view.

Database Explorer

The Database Explorer is a dockable window used
for viewing and accessing the QMF objects that
reside on each database server that has been defined
in the SDF. Branches in the Database Explorer tree
list the servers in the SDF, the user’s most recently
used servers, and a user’s most recently used objects.
An additional branch lists any user-specified QMF
objects. A filtering option allows user to specify
which objects are included in the lists.

The Database Explorer window opens with QMF for
Windows and remains open for the entire session,
which makes it a convenient starting point for most
QMF for Windows functions.

© Copyright IBM Corp. 2004
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Table 1. Chapter 4 - Revisions and enhancements (continued)

Chapter 4 - Defining servers

Revision or enhancement

Description

Object Analyzer

The Object Analyzer works with the Database
Explorer and provides information about the
references that an object has on other objects. The
objects referenced by a selected object are listed in
the Database Explorer tree under the selected object.
For tables, the columns are listed. These dependent
objects (or tables) are accessible and can be run or
displayed directly from the Database Explorer.

Extended Grouping Options

Multiple levels of grouping can be defined on both
axes in the query results view. For relational and
OLAP query results users can:

* Group data columns on the vertical axis and
display results with or without summaries.

¢ Group data columns on the horizontal axis and
display results with or without summaries.

* Select columns for grouping using drag-and-drop
operations directly in the query results view, or in
the new Query Results or Layout Designer
windows.

Layout Designer

The Layout Designer is a dockable tool window that
contains a high-level visual representation of the
columns included in the query results. The Layout
Designer window provides a visible work area on
which users can change the appearance of relational
and OLAP query results. From the Layout Designer,
users can change the order of columns in the query
results view, and specify which columns will be
grouped and summarized.

Create queries using prompted
and diagram interfaces

Users can create the SQL statements for queries
using two new interfaces. The diagram interface
helps users build queries visually using diagrams.
The prompted interface helps users build queries
using dialogs.

Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere




Table 1. Chapter 4 - Revisions and enhancements (continued)

Chapter 4 - Defining servers

Revision or enhancement

Description

Spatial Map Document

Spatial data maps are now viewed in a window
where users access to map functions has been
streamlined with the following enhancements:

* Drop-down menu for map objects
* Property and history information for map layers

* Toolbar now contains new map icons with tooltips
to explain functionality

 Ability to save data maps to a file
* Easy export of spatial data maps to procedures

* Export of spatial data maps as a bitmap or
windows enhanced meta file graphics file

Catalog

An option has been added that enables QMF for
Windows administrators to specify that, for certain
database servers, users must use the default QMF for
Windows catalog located on the database server.
This option ensures that resource limits established
for users cannot be thwarted.

Long name support for
catalogs

QMF for Windows now supports catalogs that store
objects with short or long names. This support
includes the ability to automatically convert short
name catalog tables to long name catalog tables.
Note: Converting to long name catalogs is not
required even if the version of DB2 uses long names.

Set User Information

An option has been added to allow users to specify
user information only once during a QMF for
Windows session. Once this feature is enabled, the
same user ID and password can be used to connect
to every database server. For users who use the same
ID and password for every server, this will eliminate
repeated prompting for the same information.

Glossary A glossary has been added to the manual to define
common terms.
Toolbar The toolbar contains new and redesigned icons for

more intuitive access to features and functions.

IBM ObjectREXX

A chapter has been added for IBM ObjectREXX to
differentiate between procedures and ObjectREXX
procedures.

Summary of Changes ~ Xiii
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Chapter 1. Introduction

DB2 QMF for Windows and DB2 QMF for WebSphere are part of the DB2
Query Management Facility (QMF) query and reporting tool set for IBM’s
DB2 relational database management system.

* QMF for Windows, the backbone of the tool set, provides extensive query
and reporting capabilities for novice to expert users.

* QMF for Windows Report Center enables users to launch established,
centrally-shared queries and reports; and send the results to spreadsheets,
desktop databases and browsers.

* QMEF for WebSphere extends query and reporting capabilities to users from
their platform-independent web browsers.

* QMEF for WebSphere Report Center allows users to view QMF reports from
their web browsers.

¢ The QMF for Windows Administrator application is used to configure and
manage the query environment for all the DB2 QMF for Windows and DB2
QMF for WebSphere applications.

Extensive query and reporting capabilities
The query and reporting features of QMF for Windows and QMF for
WebSphere include:

* a Database Explorer that enables users to easily discover the items that
have been saved on the database server

* online analysis of query dependencies, including OLAP analysis

¢ the ability to build powerful queries without knowing SQL using the
diagram or prompted interfaces

* support for DB2 UDB V8 functionality including DB2 Cube Views, long
names, Unicode, and enhancements to SQL

* extensive drag and drop capabilities for restructuring the appearance of
query results

* comprehensive query results formatting options including a robust
expression language that allows users to conditionally format query results
by retrieved column values

* the ability to add calculated columns to the query results and group data
columns on both axes with or without summaries

¢ charts and other complex visuals for displaying query results

* simple step-by-step guidance to create traditional text-based reports or
state-of-the-art reports with rich formatting

© Copyright IBM Corp. 2004 1



* query results can be sent to other applications
* API commands that developers can use in any application

Prerequisites

Operating system

Supported operating systems
+ Microsoft®Windows 98

e Microsoft Windows ME

* Microsoft Windows NT 4.0

e Microsoft Windows 2000

* Microsoft Windows XP

* Microsoft Windows Server 2003

Add-in applications

The following add-in applications are supported by QMF for Windows and
can be installed when QMF for Windows is installed.

¢ Microsoft Excel Version 7.0 or later

¢ Lotus 1-2-3 Version 97 or later

These add-in applications are included with the installation media.

Connectivity

Below are the connectivity types supported by QMF for Windows and QMF
for WebSphere. See Installing and Managing QMF for Windows for detailed
information.

TCP/IP

The Microsoft TCP protocol installed with the Windows operating system
should work with any product that provides a WinSock interface.

SNA

IBM Personal Communications Version 4.1 or later should work with any
product that provides a Win CPI-C interface.

obBC

Most ODBC Version 2.x or Version 3.x drivers are acceptable.

CLI

IBM DB2 Universal Database runtime client Version 6.1 or later.

2 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



Other functionality

IBM ObjectREXX
IBM ObjectREXX for Windows Version 1.0.2.3 or later

Natural language query

EasyAsk software is required in order to perform natural language queries.
This software is available at www.easyask.com

Database servers

QMF for Windows and QMF for WebSphere can connect to a wide range of
DB2 UDB databases.

Supported DB2 UDB databases

DB2 UDB for z/0S

DB2 Server for VSE & VM

DB2 Universal Database and DB2 Common Server
DB2 Parallel Edition

DB2 Information Integrator

Note: The DB2 QMF for Windows license controls the DB2s where you can

install and connect to QMF for Windows.

Chapter 1. Introduction
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Chapter 2. QMF for Windows interface

This chapter describes the QMF for Windows interface. It includes:
* Selecting the database server from the SDF
* Specifying user information

¢ Menu options

Selecting the database server from the SDF

The QMF for Windows server definition file (SDF) is an initialization (.ini) file
that contains the technical information that QMF for Windows needs in order
to connect users to database servers. Your QMF for Windows administrator is
responsible for creating, configuring, maintaining and distributing the SDF for
the QMF for Windows users.

Each database server that you are allowed to access is configured in the SDF.
When configuring the database servers in the SDF, your QMF for Windows
administrator assigned each database server a descriptive name that identifies
the database. For example, Purchasing Database instead of the more
technically correct name DB2P_01_PURCH.

When you open QMF for Windows the database servers that are available for
you to use are listed in the Explorer window. You can select any of the
database servers listed.

In some installations, you can have more than one SDEF, each having different
configurations of available database servers.
View or select the SDF
To view the SDF that you using or select a different SDF to use:
1. Select View --> Options.
2. The Options window opens.
3. Select the General page.
4

. The Server Definition file field displays the name of the SDF that you are
currently using.

5. Use the down arrow to see the list of available SDFs or use the browse
button to select a different SDF.
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Specifying user Information

Each time QMF for Windows connects to a database server on your behalf, it
must supply a user ID and password. The user ID and password specifies
what database security options are in effect and what functions can be
performed. You must supply the user ID and password.

You supply QMF for Windows with your user ID and password using the Set
User Information window. QMF for Windows will automatically open this
window the first time you connect to a database server. Subsequently, QMF
for Windows may or may not request user ID and password on every
connection to the database server depending on the options you have
selected.

You can open the Set User Information window and specify a user ID and
password at any time before making a connection to the database server.

There are some database servers that do not require a user ID and password.
If a database server does not require a user ID and password, it must be
configured as such by your QMF for Windows Administrator in the SDF. If
the database server is configured to not require a user ID and password, you
will not be prompted for user information.

To specify user information
1. Select Query -->Set User Information.
The Set User Information window opens.
2. Type your user ID and Password for the server.

Note: The user ID and password are case sensitive. For example type your
User ID and password in uppercase letters if they are set up that
way. Some types of database servers treat user IDs and passwords
as case sensitive; while, others do not.

The user ID and password cannot be the same as your local or network
user ID and password.

3. Optional: Type the account number used track system usage by certain
criteria such as department or user ID. Ask your database administrator to
find out if your system uses accounts.

4. Optional: Check the Remember this password check box to remember
server passwords across QMF for Windows sessions.

* If you are logged on to Windows, the Set User Information dialog box
contains the Remember this password check box. If this check box is
selected, then the password for that server is stored in the Windows
password list. Whenever you are logged on to Windows, QMF for
Windows retrieves the password without a prompt.
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* If you are not logged on to Windows or if you are logged on as a
different user, QMF for Windows prompts you for a user ID and
password.

Note: If you check the Remember this password check box, anyone who
can log on to your Windows account can access your database
servers with your (server) user ID and password.

5. Check the Use this information for every server I connect to check box to
apply the user information entered on the Set User Information dialog box
when connecting to any database server. This option is useful if the
current user ID and password, and optional account information, are used
at all database servers.

6. Click OK.
QMF for Windows stores this information for accessing the server.

Changing passwords

You can change your password for a database server using the Set User
Information window if the database server you are connecting to supports
this feature and your user ID has permission as granted by the QMF for
Windows administrator.

Note: This feature is supported by DB2 for OS/390, Version 5 and later.

Procedure to change password
1. Click Change.
2. Type the new password in the New password field.
3. Re-type the new password in the Confirm new password field.
4. Click OK.
The password is changed.

Specifying accounting Information
The database server uses accounting strings to track and charge-back system
usage. Ask your database administrator to find out if your system uses
accounting strings.

Use the same ID and password for every database server

Check the Use this information for every server I connect to check box to use
the most recently entered ID and password when connecting to all database
servers. If checked, QMF for Windows will use the same user ID and
password for all connections to all database servers unless you open the Set
User Information window and make a change
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Menus

Three drop-down menus are available when you first open QMF for

Windows:
* File
* View
* Help

Each main menu and its corresponding menu options is described below.

File menu

New

Opens the New window where you can select the type of query document

that you want to create.

Table 2. Options on File Menu

Field

Description

Query

To create a new SQL query. You select Query if you will be
creating the query by typing the SQL statements in the
window directly or using one of the interfaces. The
available interfaces include the prompted, diagram, or
natural views.

OLAP Query

To create an OLAP query. OLAP queries can only be run
against database servers that support DB2 Cube Views.

Form

Contains the formatting instructions that QMF for Windows
uses to generate a report from query results.

Procedure

A set of commands used to run queries, print reports,
import and export data, and perform other functions with a
single command.

List

A list of objects (query, form, procedure or table) based on a
filter, such as an object owner, object name, or object type.

Job

A file used to schedule and run unattended procedures. A
job file can store a user ID, encrypted password, and
substitution variables.

Map

Create a new spatial data map document

Layout

Create a new visual representation of the data in a layout
document that includes many chart variations

Visual Report

Create a new report document using the visual report
interface
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Open

Opens an Open file window where you can select from a list of available files,

the file that you want to open. The list of available files that you can open in

OMF for Windows includes:

* query files (*.qry)

* queries saved in the prompted view files (*.pq)
* natural query files (*.nq)

* OLAP query files (*.0q)

» form files (*.frm)

* procedure files (*.prc)

* object list files (*.ol)

* map files (*.spm)

* job definition files (*.jdf)

+ Layout files(*.vly)

* Visionary World files (*.vis)

* Visual report(*.vr) files

» IXF files (*.ixf)

* dbase III files (*.dbf)

¢ Web Query Markup Language files(*.wqml)

Open from server

Select this option to open an existing query, form, or procedure, or list file that

has been saved on the database server

Draw query
Select this option to create a query document based on the query type and

tables you specify.

Note: This menu command is the same as the DRAW command in host QMF.

Table 3. Fields on Draw Query Window

Field Description
Server The database server where the tables for the query are
stored

Chapter 2. QMF for Windows interface

9



Table 3. Fields on Draw Query Window (continued)

Field

Description

Query type

The type of query to create:
e SELECT

— create an SQL SELECT statement for the tables
Note: More than one table can be selected for an
SELECT statement.

* UPDATE

— create an SQL UPDATE statement for the table.
Note: Only one table can be selected for an UPDATE
statement.

e INSERT

— create an SQL INSERT statement for the table.
Note: Only one table can be selected for an INSERT
statement.

Owner

The table owner (in the correct format for identifiers) for
the query

Name

The table name (in the correct format for identifiers) for the
query

Identifier

The correlation ID for a table in the query
Note: If left blank, a correlation ID is generated
automatically.

Tables

The table or tables to include in the query
Note: More than one table can be specified for a SELECT
statement.

Only one table can be specified for an UPDATE or INSERT
statement.

Table Editor

Select this option to search for and edit rows in a table. Select File--> Table
Editor or List--> Edit to use the Table Editor.

Table 4. Fields on Table Editor Window

Field

Description

Server

The database server where the table is stored

Table owner

The user who created the table

Table name

The table to search for
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Table 4. Fields on Table Editor Window (continued)

Field Description

Save Mode Indicates whether to save changes with each row or when
changes are complete:

* Immediate

The table will be updated at the server immediately after
each change.

* End

The table will be updated at the server after you finish
entering all changes.

Note: If you select "End” as the save mode, other users
are prevented from making changes to the table until the
final changes are committed.

Edit Click Edit to update a table in the database.

List Tables Click List Tables to open the Tables dialog box that lists the
tables owned by the specified owner. Select a table from the
list and click OK to edit the table.

Optional: The Set User Information dialog box opens when
you click List Tables if you are not connected to the
database. Use this dialog box to provide required user
connectivity information to the database.

Edit If you know the table name, click Edit to open the Edit
Table dialog box. Use this dialog box to search for, update,
insert or delete a row for the owner and server

Import data
Select this option to import data from an *.ixf or dBASE file into a new query

document.

Recently Used files
Use this option to open local files that were accessed recently.

1. Click File--> Recent Files.
The Recent Files menu opens.
2. Select a file from the list of files.

The file data opens in a new dialog box.
Note: There is no toolbar button for the Recent Files menu option.

Recently Used objects
Select this option to open objects on the server that were accessed recently.

The format of the most recently accessed object is:
SERVER:0BJECT_TYPE:OWNER.NAME
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1. Click File--> Recent Objects.
The Recent Objects menu opens.

2. Select the object from the list of objects.
The object data opens in a new dialog box.

Note: There is no toolbar button for the Recent Objects menu option.

Terminate connections
Select this option to end the connection to the server.

Exit
Select this option to close QMF for Windows.

View menu

Natural
Click Natural to display the active query in the natural query view. This

command is only available if the active query was created or saved as a
natural query and EasyAsk software is installed.

Prompted
Click Prompted to display the active query in the prompted query view. This

command is only available if the active query was created or saved in the
prompted view.

SQL
Click SQL to view the SQL statements for all queries, including queries

created using the diagram, natural or prompted views.

Diagram

Click Diagram to display the active query in the diagram query view. This
command is only available if the active query was created or saved in the
diagram view.

Results
Click Results to view the query results in the active window. This command is

only available if there are query results available and the active window
currently displays a query in the SQL, prompted, or diagram views.

Parameters
Displays the parameters returned by running a stored procedure. This

command is only available if the stored procedure has input or output
parameters.
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Result Set List
Lists the result sets returned by running a stored procedure. Up to four result

sets can be listed. Click on the number or the name of the result set that you
want to display. This command is only available if the query results are from
running a stored procedure.

More Result Sets
Opens the Results Sets window where all the result sets from running a

stored procedure are listed. You can select the result set that you want to
display. This command is only available if the query results are from running
a stored procedure.

Resource Limits
Select Resource Limits to view the resource limits that have been specified for

your user ID. Resource limits are set by the QMF for Windows Administrator.
They control users access to database servers and resource usage.

The following types of limits and controls can be set by the QMF for
Windows Administrator:

¢ Timeouts

* Limits

* SQL verbs

¢ Options

* Save data

* Binding

* Object tracking
* LOB options

¢ Report Center

Although the majority of resource limits set up for the database server are
display-only, you can set certain limits while running a query, as described in
"Setting your own row limit.”

Setting your own row limit: Prior to submitting a query that you suspect
will be time consuming or resource consuming, you can specify the maximum
number of rows to retrieve. QMF for Windows will cancel the query when it
reaches this row limit.

Note: The Maximum Rows To Fetch and Maximum Bytes to Fetch
parameters specified by the System Administrator for your resource
limits group take precedence over the row limit parameter you specify
here.

1. Select Query--> Set Row Limit.
The Set Row Limit dialog box opens.
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2. In the Enter the maximum number of rows to retrieve for this query
field, type the maximum number of rows that the query can return.
Optional: Type a zero indicate no limit.

3. Click OK.

The row limit is applied the next time you run the query.

Note: Rows retrieved in excess of the specified row limit are retained and
they can be viewed.

Connections
Click View--> Connections to open the Connection Information dialog box.

This dialog box lists the servers and the number of connections between QMF
for Windows and the database servers. You can open this dialog box at any
time, even while working in QMF for Windows.

Table 5. Fields on Connections Window

Field Description
Servers and This dialog box lists the servers connected to QMF for
Connections Windows and identifies the number of connections that

QMF for Windows has to each server.

Show details Click Show Details to obtain detailed information on each
connection to a server in the Servers and Connections list.

The Connection Details dialog box opens. This dialog box
provides information about the server connection, the user
ID, the connection state, connection statistics, and the
method of connectivity

Global variables
Displays all local global variables. Click View--> Global Variables to open the

Global Variables dialog box. Certain global variables are system-level,
meaning you cannot change them. These global variables report on the state
of the system; automate selections during procedures (such as exporting data
in a specific format); supply values for substitution variables in a procedure;
and pass information between procedures.

Table 6. Fields on Global Variables Dialog Box

Field Description

Name The name of the global variable. Each global variable has a
prefix. For example, global variables prefixed with AO are
system-level variables and cannot be changed; while, many
global variables prefixed with QW are QMF for Windows
variables that can be set.

Value The value held by the global variable.
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Toolbars

Click View--> Toolbars to open the Toolbars window. The Toolbars window
lists the toolbars available to QMF for Windows. Check or uncheck the
toolbars that you want to use.

Toolbars are initially docked at the top of each window, although, you can
grab on to the toolbar and move the toolbar around the screen.

Table 7. Fields on Toolbars Window

Field

Description

Main toolbar

Check the Main toolbar check box to make the options on
the Main toolbar available.

Query toolbar

Check the Query toolbar check box to make the options on
the Query toolbar available when you work with a query.

Natural query toolbar

Check the Natural Query toolbar check box to make the
options on the Natural Query toolbar available when you
work with a natural query.

Note: EasyAsk software must be available for this option.

Job toolbar

Check the Job toolbar check box to make the options on
the Job toolbar available when you work with a job.

Query Results toolbar

Check the Query Results toolbar check box to make the
options on the Query Results toolbar available when you
work with query results.

Procedure toolbar

Check the Procedure toolbar check box to make the options
on the Procedure toolbar available when you work with a
procedure.

Form toolbar

Check the Form toolbar check box to make the options on
the Form toolbar available when you work with a form.

List toolbar

Check the List toolbar check box to make the options on
the List toolbar available when you work with a list.

Map toolbar

Click Map toolbar to make the options on the Map toolbar
available when you work with spatial data.

OLAP Query

Click OLAP toolbar to make the options on the OLAP
toolbar available when you work with OLAP queries.

Visual Reports toolbar

Click Visual Reports toolbar to make the options on the
Visual Reports toolbar available when you work with
visual reports.

Layout toolbar

Click Layout toolbar to make the options on the Layout
toolbar available when you work with visionary data.

Formatting toolbar

Click Formatting toolbar to make the Formatting toolbar
available when you are formatting columns in the query
results.
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Table 7. Fields on Toolbars Window (continued)

Field Description

Command toolbar Click Command toolbar to make the Command toolbar
available when you are using the command line.

Documents toolbar Click Documents toolbar to make the Documents toolbar
available where you can see all the documents that you
currently have open in the active window.

Command bar
Use the command bar to run a procedure at a server directly from any QMF

window. You can type a command or select a command from the Run
command drop-down list. You can select the associated server to run the
command from the at server drop-down list.

Control Bar
Select View--> Control Bar to show or hide the following:

* Explorer Bar
* Status Bar

* Layout Designer

Explorer Bar
Select View--> Control Bars--> Explorer Bar to display or hide the Explorer

Bar. The Explorer Bar is a dockable tools windows that opens in the left pane
of the window but can be moved.

The tools that use the Explorer Bar are the Database Explorer, the Query
Results Explorer and the Visual Reports Explorer as well as the Object
Analyzer.

Status bar
Select View--> Control Bars--> Status Bar to display or hide the status bar at

the bottom of every window.

The status bar displays information and messages and provides status
information for queries.

Layout Designer
Select View--> Control Bars--> Layout Designer to display or hide the Layout

Designer dockable window. The Layout Designer window opens in the
bottom of the screen but can be moved. You use the Layout Designer when
you work with query results.

16 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



Options [General tab]

Click View--> Options, then click the General tab to set general options for
QMF for Windows, such as specifying which server definition file (SDF) will

be used.

Table 8. Fields on Options - General

Field

Description

Server definition file

The server definition file (SDF) contains the technical
information QMF for Windows need to connect users to
database servers. Your QMF for Windows administrator
creates, maintains and distributes the SDF. The SDF that
you are using is displayed in this field.

If you have multiple SDFs, you can select another SDF by
typing the name of a SDF, or browsing with the browse
button.

Display recently used
servers first

Check this check box to display the most recently used
servers from the SDF first in the Database Explorer
window. If this check box is not checked, the servers are
listed as they were configured in the SDF.

Filter

Click this button to open the Filter Servers window where
you can select the database servers from the SDF that will
be included in the selection list. By default all database
servers that were configured in the SDF will be included in
the selection lists.

Enable extensions for
spatial data

Check the Enable extensions for spatial data check box to
work with spatial data.

This check box controls whether information will be
gathered for the location, shape of, and relationships among
business data and geographic data, including map data,
and stored in industry standard files known as shapefiles

(*.spm).

With shape files, spatial data can be interchanged with
other applications or databases that recognize this format.

User Interface language

Use this field to specify the language for the QMF for
Windows user interface. You can select the language from a
drop down list of supported languages.

Options [Appearance tab]
Click View--> Options, then click the Appearance tab to set appearance

options. The Appearance options specify the strings that will be used for
displaying and entering null and default values. You can also specify the data
orientation that will be used for query results and reports, as well as whether
coloring in text editors will be enabled.
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Table 9. Fields on Options - Appearance

Field Description

Special values + Display null values as

— Type the string QMF for Windows uses to display null
values that are retrieved from the database server.

¢ Enter null values as

— Type the string to use when entering null values in
query results and in the Edit Table dialog box.

¢ Enter default values as

- Type the string to use when entering default values in
query results and in the Edit Table dialog box.

Data Orientation in * Left-to-Right
query results and

Select this radio button to specify that the data
reports

orientation in query results and reports will read from
left to right.

* Right-to-Left
Select this radio button to specify that the data

orientation in query results and reports will read from
right to left.

* Based on Operating System

Select this radio button to specify that the data
orientation in query results and reports will be based on
what has been specified for the operating system. If the
operating system is bidi-enabled, data will display in a
right-to-left direction. If the operating system is not
bidi-enabled, data will display in a left-to-right direction.

Enable coloring in text | Check this check box to enable coloring in text editors. by
editors checking this check box, the text that you type when
creating SQL queries will be color enhanced. For example,
SQL verbs will appear blue, while clauses are black. You
can make changes to the coloring specification using the
Formatting bar.

Options [Network tab]
Click View--> Options, then click the Network tab to set network options.

The network options specify the connectivity-specific timeout limits for all
database servers that use DRDA over TCP/IP, CLI, ODBC, or CPI-C
connectivity. In addition, if you will access any database server using DRDA
over SNA connectivity, you must specify the CPI-C services DLL that QMF for
Windows will use in the Provider DLL field
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Table 10. Fields on Options - Network

Field

Description

TCP

Use these fields to specify the timeouts for all database
servers to which QMF for Windows connects using TCP/IP.

Warning

The number of seconds that can elapse before a user is
notified and given the opportunity to cancel a
communication request that has not completed.

Cancel

The number of seconds that can elapse before QMF for
Windows automatically cancels a communication request
that has not completed and returns an error.

CLI Timeouts

Use these fields to specify the timeouts for all database
servers to which QMF for Windows connects using CLI

Warning

The number of seconds that can elapse before a user is
notified and given the opportunity to cancel a
communication request that has not completed.

Cancel

The number of seconds that can elapse before QMF for
Windows automatically cancels a communication request
that has not completed and returns an error.

ODBC

Use these fields to specify the timeouts for all database
servers to which QMF for Windows connects using ODBC.

Warning

The number of seconds that can elapse before a user is
notified and given the opportunity to cancel a
communication request that has not completed.

Cancel

The number of seconds that can elapse before QMF for
Windows automatically cancels a communication request
that has not completed and returns an error.

CPI-C

Use these fields to specify the timeouts for all database
servers to which QMF for Windows connects using TCP/IP.

Warning

The number of seconds that can elapse before a user is
notified and given the opportunity to cancel a
communication request that has not completed.

Cancel

The number of seconds that can elapse before QMF for
Windows automatically cancels a communication request
that has not completed and returns an error.
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Table 10. Fields on Options - Network (continued)

Field

Description

CPI-C Provider DLL

Use this field to specify the name of the Provider DLL that
QMF for Windows will use to access CPI-C services. You
can use the Browse icon to search for available Provider
DLLs. For information about what Provider DLLs you
should use contact your QMF for Windows Administrator.

Options [LOBSs]

Click View--> Options,

then click the LOBs tab to specify how to handle

retrieving and saving LOB data.

DB2 Universal Database has a LOB data type that is able to store
non-traditional data such as text files, multimedia files, images, video,
photograph, and sound files. A LOB is a database entry containing a file that
is stored on the database server. LOBs are large and use a large amount of

resources.

If the database being accessed contains tables with LOB fields, the QMF for
Windows Administrator can prevent access to these tables using the resource

limits for your user ID.

Table 11. Fields on Options - LOBs

Field Description
Override LOB options if | Check this check box to specify that you will override the
possible LOB options that have been specified by your QMF for

Windows Administrator for your resource limits group.
Your QMF for Windows Administrator must have given
your resource limits group permission to override the LOB
options. If you do not have permission to override LOB
options, this check box is not available.

Lob Retrieval Options

You use this field to specify what large object data (LOB)
data you will be retrieving. There are four choices:

¢ Disable LOB columns
Select this radio button to disable LOB data retrieval. By

selecting this option, you will not be able to query any
table that contains LOB data.

* Disable LOB data retrieval
Select this radio button to disable LOB data retrieval but
allow access to the other columns in the tables that
contain LOB data. By selecting this option, you can query
tables that contain LOB data and get result data for all
columns except those that contain LOBs
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Table 12. Fields on Options - LOBs

Field

Description

Retrieve LOB data on demand

Select this radio button to specify that you will query
tables that contain LOB data and you want your result
data to be returned for all columns including those that
contain LOB objects. However, you want to select the
LOB objects that will be displayed in the contents of the
query results.

Unless otherwise specified, all users of QMF for
Windows can query tables that contain LOBs. To
conserve resources, QMF for Windows stores retrieved
LOB data in a file. Pointers to the LOB data objects are
displayed in the query results. You click on the pointer to
view the LOB object.

Retrieve LOB data automatically

Select this radio button to specify that you will query
tables that contain LOB data and you want your result
data to be returned for all columns, including those that
contain LOB objects. All result data is automatically
displayed in the contents of the query results. This
option can potentially consume a large amount of
resources and time.

LOB Saving Option

You use this field to specify what large object data (LOB)
data you can save. There are two choices:

Disable LOB data

Select this radio button to disable saving LOB data on
the database server.

Enable LOB data

Select this radio button to allow saving LOB data on the
database server.

Maximum LOB column
size (KB):

Use this field to specify the maximum size of a LOB
column, in kilobytes, up to 2G (the maximum LOB size).
The default is 0, no maximum. If you query a table with
LOB data that is larger than the maximum, the LOB data
will not be returned for display.

Options [Traces tab]

Click View--> Options, then click the Traces tab to activate tracing. You can
select one or more components about which information will be gathered

during processing.
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Note: Use tracing only when you are diagnosing a problem, because tracing
can impact performance. Technical support will help you set up the
tracing logs and tracing methods.

More than one component can be selected for tracing.

Table 13. Fields on Options - Traces Window

Field

Description

Trace file

The name of the file that will be used to store the trace data
that is gathered. Click the browse button to select the trace
file to use.

DDM

Check the DDM check box to trace DDM operations, which
is this is the most frequent type of tracing used. DDM
tracing can be used only for a DRDA connection to DB2.

DDM tracing identifies the packages, the SQL sent and
returned from DB2, and displays query results in English
and hex format.

TCP

Check the TCP check box to apply tracing to operations
executed under a TCP/IP connection to DB2.

CPI-C

Check the CPI-C check box to apply tracing to operations
executed under a CPI-C connection to DB2. DRDA over
SNA uses CPI-C when making the connection to the server.

CLI

Check the CLI check box to apply tracing to operations
executed under a CLI connection to DB2.

Embedded SQL

Check the Embedded SQL check box to apply tracing to
embedded SQL operations. Embedded SQL are SQL
statements that are embedded within a host language
program and are prepared (via the BIND process) before
the program is executed.

SQLAM

Check the SQLAM check box (SQL Application Manager)
to apply tracing to SQLAM operations.

SQLAM is a function that represents an application to the
remote relational database manager. The SQL application
manager can be present in both an application requester
and an application server.

REXX

Check the REXX check box (REstructured eXtended
eXecutor) to apply tracing to IBM ObjectREXX operations.

IBM Object REXX, an interpreted, structured, procedural
script programming language allows programs and
algorithms to be written in a clear, structured way.

Internet Mail

Check the Internet Mail check box to apply tracing to
Internet Mail operations.
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Table 13. Fields on Options - Traces Window (continued)

Field Description

Messages Check the Messages check box to apply tracing to the
informational and error messages issued during a process.

Options [Web Update]
Click View--> Options, then click the Web Update tab to check for software

application updates, such as modifications, on the QMF Resource Center on
the Web. You can download and apply and updates from the Web page.

Table 14. Fields on Options - Web Update

Field Description

Enable Web update Check the Enable Web update check box to check for
updates to QMF for Windows at the frequency specified in
the Check for update every __ days field. If the Enable
Web update feature is selected, the procedure to check for
Web updates will be performed on startup.

The following message displays if an update is found:

A new version of the product is available.
Do you want to see more details?

If you choose to see more details, your browser opens at
the QMF for Windows Resource Center.

Check for update every |Type the number of days between checking for updates to
days QMF for Windows in the Check for update every __ days
field. The default is one day from the last update.

Display message if Check the Display message if unable to check check box
unable to check to receive a message if there are problems checking for an
update, such as Web communication, no Internet
connection, or firewall prohibitions.

A message similar to the following is issued if there was a
problem checking for Web updates, such as from a firewall
or communications issues:

AN UNEXPECTED ERROR OCCURRED WHILE CHECKING FOR UPDATES.

Options [Database Explorer]
Click View--> Options, then click the Database Explorer tab to specify the

default options that will be used by the Database Explorer. These options
specify what branches to display in the tree, how many objects will be
included in the branches and whether objects will be run or displayed when a
user double clicks on them.
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Table 15. Fields on Options - Database Explorer

Field

Description

Display

Use this field to select the branches that are included in the
Database Explorer tree. Check one or more of the following
check boxes:

* Favorites

Check this check box to include a Favorites branch in the
Database Explorer tree. You can choose to include any
QMF object in this folder.

* Recently Used Servers

Check this check box to include a Recently Used Servers
branch in the Database Explorer tree. QMF for Windows
will list and keep track of the servers that you have used
in the most recent order. The number of servers listed is

specified in the Recent List Entries field.

* Recently Used Objects

Check this check box to include a Recently Used Objects
branch in the Database Explorer tree. QMF for Windows
will keep track of and list the QMF for Windows objects
that you have used in the most recent order. The number
of objects listed is specified in the Recent List Entries
field.

» All Servers
Check this check box to include an All Servers branch in
the Database Explorer tree. QMF for Windows will list all
of the database servers that have been configured in the
SDF that you are using

Recent List Entries

Use these fields to specify the number of entries that will
be included in the Recently Used Servers and Recently
Used Objects branches of the Database Explorer tree.

¢ Servers

Use this field to specify the number of servers that will
be included in the Recently Used Servers branch of the
Database Explorer tree. You can include up to 8 servers.

* Objects
Use this field to specify the number of objects that will

be included in the Recently Used Objects branch of the
Database Explorer tree. You can include up to 8 objects.

24 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere




Table 15. Fields on Options - Database Explorer (continued)

Field Description

Default Action for Use these fields to select the action that QMF for Windows
Queries and Procedures | will perform when you double-click on a object that is
included in the Database Explorer tree. Your choices are:

¢ Run object

Select this radio button to run the object that is selected
in the Database Explorer tree.

* Display object
Select this radio button to display the object that is
selected in the Database Explorer tree.

Customizing the toolbar

You can customize the toolbar to display particular buttons.

Adding buttons to the toolbar

Follow these steps to add buttons to the toolbar, such as for job-specific
functions.

1. Double-click the gray area surrounding the toolbar.
The Toolbars dialog box opens.

2. Check the check box for a toolbar.

3. Click Customize.
The Customize Toolbar dialog box opens.

4. In the Available toolbar buttons list box, select the button to add to the
selected toolbar.

5. Click Add.
The button is added to the toolbar.

6. Optional: Repeat steps 4 and 5 for each button you want to add to the
selected tool bar.

7. Click Close.
8. Click OK.
The Toolbars dialog box closes and the buttons are added to the toolbar.

Moving buttons on the toolbar
Follow these steps to rearrange buttons on the toolbar.
1. Double-click on the gray area surrounding the toolbar.
The Toolbars dialog box opens.
2. Select a toolbar.
3. Click Customize.
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The Customize Toolbar dialog box opens.
4. Select the button to move from the Current toolbar buttons list box.
5. Click the Move Up or Move Down button to reposition the button on the

toolbar.
6. Click Close.
7. Click OK.

The dialog box closes and the buttons appear in their new locations.

Removing buttons from the toolbar
Follow these steps to remove buttons from the toolbar.
1. Double-click on the gray area surrounding the toolbar.
The Toolbars dialog box opens.
2. Select a toolbar.
3. Click Customize.
The Customize Toolbar dialog box opens.
4. Select a button from the Current toolbar buttons list box.
5. Click Remove.
The button is removed from the Current toolbar buttons list box.
6. Click Close.
7. Click OK.

The dialog box closes and the buttons are removed from the toolbar.
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Chapter 3. Queries

A query is a request for information from a database. To request information
from a relational database, your query is constructed using Structured Query
Language (SQL) statements. With QMF for Windows you can create the SQL
statement that will query a relational database in any of the following ways:

e write your own SQL statements

* create SQL statements visually using diagram interface

* create SQL statements using the prompted interface

* create SQL statements using a natural language such as EasyAsk

* use the Database Explorer to find and select queries that have been saved
on the database server

Query menu

The Query menu becomes available when you create a new query or open an
existing query. Menu options vary depending on how you choose to build
your query.

In addition to selecting commands from the main Query menu, you can

right-click in the active query window to open a context sensitive menu that

includes the most frequently used menu commands for working with queries.
Run

Select Query--> Run to run the active query.

Prepare

Select Query--> Prepare to invoke the PREPARE SQL command. This command
instructs DB2 to evaluate the query for the most efficient execution and then
devise a plan for its execution.

The Prepare option is available for queries only in the SQL view.

The Set User Information dialog box opens after you select the PREPARE
option. Type a valid user ID and password to prepare the query on the
database.

During this operation:
* resource limits are retrieved
* internal calculations are performed

* a path is devised to best run the query
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e the run time is estimated
¢ the number of returned rows is estimated
e 1o data is sent to the client’s database

If successful, an empty results set will be returned that shows all columns
selected for the query.

Note: An error message displays if the PREPARE function determines that the
query contains errors. The message provides details of the error
condition.

Later, when you run the prepared query, the prepared plan will be executed
instead of developing a plan at run time.
Cancel

Select Query--> Cancel to cancel the active query at the database server.

Note: This command is disabled for queries in the prompted or diagram
formats.
Uppercase

Select Query--> Uppercase to type all new text in uppercase automatically
until you deselect this option. No existing text will be modified.

Reformat SQL text

Select Query--> Reformat to reformat the SQL text to polish its appearance.
The result is:

* text will be rearranged appropriately
* SQL keywords will be capitalized
* queries will be shortened to 79 characters per line, or less

Note: This is a requirement for saving a query at a database server.

Comment

Select Query--> Comment to add a comment to a line in a query. A
commented line is typically a line of text that describes what the SQL will do
in a specific section of code. Commented text is usually internal commentary.

Note: The commented text will not be included when the query runs.

The COMMENT option places two dashes (--) at the beginning of a line in the
query, such as:

SELECT * FROM Q.STAFF
--USE THIS ONLY FOR MONTH-END REPORTS
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Uncomment

Select Query--> Uncomment to remove the commented line or lines. Once a
line is uncommented it will be read when the SQL query is run.

This option removes the comment flag, two dashes (--), from the beginning of
a line in the query, such as:

SELECT * FROM Q.STAFF
USE THIS ONLY FOR MONTH-END REPORTS

Expression Builder

Select Query--> Expression Builder to access a submenu, or palette, of SQL
elements for building an SQL expression. The Expression Builder palette
contains common elements such as:

* operators (+, -, ¥, /)
« CONCAT

* 0

* constant

* column name

* special register

* function

* case expression
Note: Connect to the server before you use the Expression Builder.

A template for each expression element you select is inserted into the query
document. This provides the fundamental structure for you to substitute
parameters for the query in place of the <expression>. For example,

CASE <expression> WHEN <expression> THEN <result-expression> ELSE
<result-expression> END

Note: This command is disabled for queries in the prompted or diagram
formats.

Set server

Select Query--> Set server to determine which database server will be used to
run the active query.

Note: Only databases to which you have access will be listed.

Set user information

Select Query--> Set user information to set your database server user ID, and
password for the active prompted query. Setting an accounting string is
optional.
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Note: You can change this information to run a query at an alternate server or
at a server on which you require a higher level of authority.

Set row limit

Select Query--> Set row limit to specify the maximum number of rows to
retrieve from the database server for the active query. This option reduces
runaway queries and can be implemented at peak times.

Note: This limit is superseded by row limits defined by DB2 and the resource
limits group to which you belong, as defined by the System
Administrator.

Set font

Select Query--> Set font to change the font for the query. The entire text of
the query changes when you select a new font.

Note: The font used for query results does not change when this option is
selected.

Note: This command is disabled for queries in the prompted or diagram
formats.

Bind Package

Select Query--> Bind Package to bind a package for a static query. This
option becomes available after you type an SQL statement.

This operation enables distributed SQL to run at any DB2 database. A package
must be bound at the database server that contains the active SQL statement
as a static query.

Note: You need permission to access the database before binding the SQL to
the server. When you select this option the Set User Information dialog
box opens for you to provide a user ID and password for the selected
server.

The Bind Static Package contains fields for the Collection 1D, Package name,
Owner ID, Delimiters, Isolation Levels, and input variables, if any.

For bound packages, host variables are used in place of each substitution
variable in the SQL statement because a substitution variable cannot always
be directly replaced by a host variable. Substitution variables provide direct
text substitution in the query statement before the query is executed at the
database server. Host variables are sent as part of the query to the database
server. Refer to the documentation for your database server for rules on where
and how host variables can be used in queries.
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Add

The SQL is bound at the server under the specified collection ID and package
name. A consistency token and section number are assigned during the bind.
The following message displays following the bind:

The query will now be run via static SQL.
You must save this query in order to continue running it via SQL in the future.

Static queries are run directly from the server and system resources are not
consumed as when you run a query on an ad hoc basis.

Note: A query bound at a server cannot be changed. It displays as a
read-only SQL statement. Select Query-->Revert To Dynamic SQL to
update the query.

The Add command is only available when you are creating a query using the
prompted or diagram interfaces. The options that are available depend on the
elements of the query that you are creating. The Add options are:

Add--> Table
Use this option to add a table to the query.

Add--> Join Condition
Use this option to specify the type of join condition that will be applied when
you are using multiple tables in the query.

Add--> Column
Use this option to add a column or column expression to the query.

Add--> Sort Condition
Use this option to add a sort condition that will control how information is

sorted in the results of the query.

Add--> Row Condition
Use this option to add a row condition that will control how many rows can

be returned in the results of the query.

Revert to dynamic SQL

Select Query-->Revert To Dynamic SQL to convert the static query back to an
ad hoc ("dynamic”) query. This enables you to edit and run a query after
binding the package for it. It also enables you to provide substitution values
at run time.

The following message displays when you select this option:
Do you want to delete the package from the server as well?

A secondary delete-confirmation message displays.
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Confirm stored procedure parameters

Select Query--> Confirm Stored Procedure Parameters to confirm the input
and output parameters that are sent to the database when running the stored
procedure, such as the name of the program and the number of parameters
expected.

This option displays when you type a CALL statement in a query window to
run a DB2 stored procedure. With this option, QMF for Windows receives
information about the parameter data types, modes, and values from the CALL
statement, as well as the database server catalog.

Follow these steps to confirm the parameters for a stored procedure:
1. Select the server where the stored procedure is saved.

2. Select File--> New--> SQL Query.

3. Type a CALL statement.

The Confirm stored procedure parameters option on the Query menu
becomes available.

4. Select the Confirm stored procedure parameters option.
5. Select Query--> Run.

The Confirm Stored Procedure Parameters dialog box opens. Confirm or
update the name, data type, mode, and value of each parameter being
sent.

Note: An error message similar to the following displays if the statement
contains errors:

An error occurred while running the query.
The CALL statement contains an invalid or unsupported syntax.

Use the Database Explorer to select an existing query

Use the Database Explorer to view, access, and analyze QMF objects that
reside on the database servers that have been defined in the SDF. When the
Explorer Bar is enabled, the (dockable) Database Explorer window opens
along with QMF for Windows and it remains open for the entire session.

Navigating the Database Explorer tree
The Database Explorer displays in a tree structure the QMF objects that are
stored on the database servers to which you have access. The Database
Explorer tree contains four branches:

Favorites
The Favorites branch lists the QMF objects that you have selected for

inclusion. You can move any QMF object listed in the Database Explorer
branches to the Favorites folder by selecting the object and dragging it to the
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folder. You can also right-click on the QMF object and select Add to Favorites
from the context menu. The Add to Favorites window opens where you can
add the object to your Favorites branch.

Recently used Objects
The Recently Used Objects branch lists the database objects that you have

used during your the QMF for Windows session in the order that you have
used them. QMF for Windows keeps track of your object usage during the
session. The list is updated each time that you use an object. You can specify
the number of QMF objects that are included in the list by clicking the
Options icon. The Database Explorer Options window opens.

Recently Used Servers
The Recently Used Servers branch lists the database servers that you have

used during your last QMF for Windows session in the order that you have
used them. QMF for Windows keeps track of your server usage during the
session. The list is updated each time QMF for Windows is restarted. You can
specify the number of servers that are included in the list by clicking the
Options icon. The Database Explorer Options window opens.

All Servers
The All Servers branch lists all the database servers that have been defined in

the SDF. You can expand each database server by clicking the (+) to the left of
the server name. QMF for Windows retrieves and lists all the QMF objects
that are stored on that database server. To select what objects should be
included in the list, click the Filter icon. The Filters window opens

Using the Database Explorer
You can use the database Explorer to:

¢ Run or display a QMF object by double clicking on the object listed in any
of the branches of the Database Explorer tree. By default, double clicking on
the OMF object will display the object. To run the object by double clicking,
you must open the Database Explorer Options window where you can
change the default from Display to Run.

* Right-click on any database server listed in the Database Explorer tree and
open a context menu. From the context menu you can select Set Filters to
open the Filters window where you specify which QMF objects will be
included in the database server branch in the Database Explorer tree. You
can select New Document which opens a New query document window
where you can select an icon that represents the type of new QMF object
that you want to create. You can also choose to Refresh the list of objects
that are available for the selected database server.

* You can right-click on any object listed in the Database Explorer tree and
open a context menu. From the context menu you can Open, Run, Delete,
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Rename, Copy or Refresh the object. If applicable to the selected object, you
can access the Draw, Display Map, Register in Information Catalog, and
Properties functions.

You can view all of a QMF object’s dependencies on other objects from the
Database Explorer tree. All query objects, including procedures, listed in all
of the Database Explorer branches, have a single child node that is labeled
References. Expand the query object by clicking the (+) to the left, and then
expand the branch References by clicking its (+) expand icon. The QMF for
Windows object analyzer is invoked. An analysis is triggered to determine
the selected object’s dependencies. All reference objects will display beneath
the References nodes. All operations that can be performed on objects listed
in the Database Explorer branches, can also be performed on these objects.

If you select a table, the QMF for Windows object analyzer will list the
columns. The child node name is Columns. Expand the table object by
clicking the (+) to the left, and then expand the branch Columns by clicking
its (+) expand icon. The QMF for Windows object analyzer is invoked. An
analysis is triggered to determine the selected table’s columns. All table
column names will display beneath the Columns branch.

Creating a new query

Select File--> New to create a new query. The query window opens. You can
choose what method you will use to create your query. Your choices are:

Type the SQL statements directly in the active query window

Select View --> Prompted to create a query’s SQL statement using a series
of dialogs that will prompt you for the various elements of your query
Select View --> Diagram to create a query’s SQL statements using the
visual method of diagrams

Select View --> Natural to create a query’s SQL statements using a natural
language. This option is only available if you have EasyAsk installed.

Type the SQL statements in the Query window

To type the SQL statements for a query you must first open a new query

document. To open a new query document select New --> Query. The query
window opens. You can type the SQL statements directly in the active query
window.

You can change the font and vary the color of the text of the SQL statements
that you type in two ways:

* Use the Formatting bar

To open the Formatting bar, select View--> Toolbars. From the toolbar
window, check the Formatting bar check box.

* Select Query--> Set Font.
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The Font dialog box opens.

The prompted view of a query

Tables

You can build simple to complex queries using the prompted query interface.
Select New --> Query, then View --> Prompted to start building a query
using the prompted query interface. The Prompted query interface has five
sections where you specify the elements of your query. The five sections are:

Tables where you specify the tables that will be used in the query.

Join Conditions where you specify the join conditions for tables, if you are
using multiple tables in the query.

Columns where you specify what columns will be included in the query
results

Sort Conditions where you specify how the rows in the query results will
be sorted.

Row Conditions where you can specify conditions that will limit the rows
that are returned in the query results.

In each section you can add, edit, delete and move through the entries using
the icons located for each in the upper right hand corner.

You use the Tables dialog to specify the tables that you want to include in the
query. You can specify one or more tables. If you specify more than one table,
the Join Conditions dialog opens automatically.

Select Query --> Add --> Tables or click the icon in Tables List box to add one
or more tables to the query.

Table 16. Tables dialog

Field Description

Table Owner The owner identifier of the table that you want to

include in the query. You can use patterns to select
objects from a list of matching objects.

 Use the percent character (%) to match a string of
any length containing any characters. For example,
to list all tables with a name beginning with the
letter A, enter A%.

* Use the underscore character (_) to match a single
character. For example, to list all tables with an
owner that has the letter A in the second position,
enter _A%.
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Table 16. Tables dialog (continued)

Field

Description

Table Name

The name of the table that you want to include in the
query. You can use patterns to select objects from a
list of matching objects. See Table Owner for
information on matching objects.

Add from List

Lists the tables that are on the database server.

Join Conditions

You can add more than one table to a query. When you add an additional

table to a query using the Tables dialog, the Join Conditions dialogs open

automatically. There are two Join Conditions dialog windows:

* The Join Tables dialog, where you specify what type of join will link the
tables, such as an inner join or left, right or full outer join.

* The Join Columns dialog, where you specify the columns from each table

that will be joined

The Join Tables dialog box contains the following fields:

Table 17. Join Tables Dialog

Field

Description

Select a table to join into
the query

Lists the tables selected for the query. This table will be
joined to another table based on the join condition.

Select the type of join to
perform

Select the type of join condition that will be used to
connect the table listed to the previously selected table.
You have four choices:

e Inner Join

¢ Right Outer Join
* Left Outer Join

e Full Outer Join

Inner join

Only rows with matching values in both tables will be
included in the results set. An INNER join is implicit if
you do not specify any other join operator.

Note: An inner join compares every row of the left table
with every row of the right table keeping only the rows
where the join-condition is true. The resulting table may be
missing rows from either or both of the joined tables.
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Table 17. Join Tables Dialog (continued)

Field Description

Left Outer join All rows in the left table, with matching rows from the
right table, will be included.

Outer joins include the rows produced by the inner join as
well as the missing rows, depending on the type of outer
joins. A Left outer join includes the rows from the left
table that were missing from the inner join.

Right Outer join All rows in the right table, with matching rows from the
left table, will be included.

Outer joins include the rows produced by the inner join as
well as the missing rows, depending on the type of outer
joins. A Right outer join includes the rows from the right
table that were missing from the inner join.

Full Outer join All rows from both tables will be included

For a FULL OUTER (or FULL) join, the join condition is a
search condition in which the predicates can only be
combined with AND. In addition, each predicate must
have the form’expression = expression’, where one
expression references only columns of one of the operand
tables of the associated join operator, and the other
expression references only columns of the other operand
table. The values of the expressions must be comparable.

Each full join expression in a FULL OUTER join must
include a column name or a cast function that references a
column. The COALESCE and VALUE functions are
allowed.

Outer joins include the rows produced by the inner join as
well as the missing rows, depending on the type of outer
joins. A Full outer join includes the rows from both tables
that were missing from the inner join.

Continue Click Continue to join the tables. The Join Columns dialog
box opens.

Join Columns
Use the Join Columns dialog box to specify the columns that will used to link

the tables. The columns from the current table that you are adding to the
query and the columns from each table that is already included in the query
are listed. Select a column from each list box with the same data type
(NUMERIC, DATE, TIME, or CHARACTER). Rows that have equal values in those
columns will be joined.
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The Join Columns dialog box contains the following fields:

Table 18. Join Columns Dialog

Field Description

list.

Columns of Lists all the columns that are included in the table that you
are adding to the query. Select one column from this list.
Note: Select a column with matching data types from each

list.

list.

Available columns to join | Lists all the columns from the table or tables that are
already included in the query. Select one column from this

Note: Select a column with matching data types from each

Columns

You use the Columns dialog to specify what columns will be included in the
query results. By default, all the columns from a table that is included in the
query are included in the query results. In the case where you have multiple
tables included in the query, all the columns from each table will be included.

Select Query --> Add --> Columns or click the icon in Columns list box to
specify the columns that will be included.

The following fields are available:

Table 19. Columns Dialog

Field

Description

Table

Lists the tables that are included in the query. If there
are two or more tables, each table is prefixed by a
letter, such as Q.STAFF(A) and Q.INTERVIEW(B).

Column

Lists the columns for each table in the query

Type

Lists the data type (character, numeric or time) for
each column, such as:

SMALLINT NOT NULL

Label

Lists any labels associated with the column.

Labels on columns are implemented as system
column headings or column text. Column headings
are used when displaying or printing query results.

Comments

Lists any comments associated with the table, such
as:

Employee identification number
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Table 19. Columns Dialog (continued)

Field

Description

Or, enter an expression here

Use this field to enter a conditional expression that

will determine whether a column is included in the
query results. You can use the Expression Builder to
help you build the expression.

The Expression Builder offers a palette of common
elements used to create SQL expressions, such as
column names, constants, functions, and operators.
When you click the Expression Builder buttons,
templates for expression elements are inserted into
the expression fields.

You can invoke the Expression Builder by:
1. pressing Alt + .

2. clicking the browse icon to the right of the input
field

Summary function

Apply the summary function to the column.

QMF for Windows provides a number of summary
functions, including AVERAGE, COUNT, MAXIMUM, MINIMUM,
and SUM. The summary function must be compatible
with the data type of the column.

New column name

A new column name for a column that will be used
in the query results. Usually, this is simpler name
than the column name defined in the database.

Select a column from the Column list box, then type
a new column name in the New column name field.
The column will be renamed in the query results,
such as SHIFTEND from A.ENDTIME.

Sort Conditions

Sort condition control how to sort the rows that will be included in the query
results. Rows can be sorted in ascending (A-Z) or descending (Z-A) order.

If you sort your rows by more than one column, the first column is ordered
first, then the second column is ordered within the sort order defined for the

first column.

There are several methods by which to specify a sort condition:

* From the Columns in the results set list, select a column included in the

query

* From the Other available columns list, select a column that was not selected
from the tables in the query
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* From the Or, enter a sort condition field, type a sort condition

Select Query --> Add --> Sort Conditions or click the icon in Sort Conditions
list box to open the Sort Conditions dialog box and specify the sort
conditions.

Table 20. Sort Conditions Dialog

Field Description
Columns in result set Lists the columns that will be included in the query
results.

* You can select one or more columns if you are
adding a sort condition

* You can select only one column if you are changing
a sort condition

Other available columns List columns that will not be included in the query
results but are available in the table that was queried.
You can select any of these columns for the sort.

Or, enter a sort condition Type a condition by which columns should sort.

Expression Builder The Expression Builder offers a palette of common
elements used to create SQL expressions, such as
column names, constants, functions, and operators.
When you click the Expression Builder buttons,
templates for expression elements are inserted.

You can invoke the Expression Builder by:
1. pressing Alt + .

2. clicking the browse icon to the right of the Enter a
sort condition field

Sort direction Apply an ascending (lowest-to-highest) or descending
(highest-to-lowest) sort order to the columns selected.

The first column is used for the primary sort;
subsequent columns will sort within the first.

Row Conditions
Use can specify row conditions to limit the rows that are returned in the
query results. Without row conditions, all qualifying rows will be returned
from the query.

Select Query --> Add --> Row Conditions or click the icon in Row Conditions

list box to open the Row Conditions dialog box and specify the row
conditions.
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Table 21. Row Conditions Dialog

Part of the row condition

Function

Connector

An "And"” or "Or” statement that links one row
condition with another. These radio buttons are
available only when a row condition has been
added to the query.

Left side

Select the column from the list box to examine for
inclusion in the query results

Operator

Select the Is or Is Not radio button to determine the
relationship between the left- and right sides of the
row. Also, select the operation to be applied to the
row condition from the Operator drop-down menu.
The available operators are:

* Equal To

* Less Than

* Less Than or Equal to

* Greater than

* Greater than or Equal to
* Between

* Starting with

¢ Ending with

* Containing

e Null

* Equal in area to

e Larger than
* Larger than or equal to

Right side

Type the condition for which to check the rows.
Only rows that meet this condition will be selected
for the query
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Table 21. Row Conditions Dialog (continued)

Part of the row condition Function

Expression Builder Use the Expression Builder for building SQL
expressions for the prompted query.

The Expression Builder offers a palette of common
elements used to create SQL expressions, such as
column names, constants, functions, and operators.
When you click the Expression Builder buttons,
templates for expression elements are inserted into
the associated SQL query window or prompted
query window.

You can invoke the Expression Builder by:
1. pressing Alt + .

2. clicking the browse icon to the right of the Enter
a sort condition field

The diagram view of a query

You can build simple to complex queries visually using the diagram query
interface. Select New --> Query, then View --> Diagram to start building a
query using the diagram query interface.

There are two main sections in the diagram query window:

* The top section which displays the tables that are included in the query as
diagrams

¢ The bottom section which lists the columns from the tables that will be
included in the query results

In creating a query using the diagram interface you can specify one or more
of the following elements:

* You must specify the Tables that will be used in the query.

* If you are using more than one table, you must specify the Join Conditions
that will link the tables.

* You can specify what Columns will be included in the query results. By
default, all columns in all the tables are included in the query results.

* You can apply Sort Conditions control how the rows in the query results
will be sorted.

* You can specify Row Conditions that will limit the rows that are returned
in the query results.

Tables
You can add a table to the query in one of two ways:
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* Right-click in any empty space of the top section of the diagram window. A
context menu opens. Click Add table. The Tables window opens.

* Select Add --> Tables. The Tables window opens.

In the Tables window specify the table owner and name. You can use the Add
from List button to open the Table List window where you can select a table
from the list of tables available on the database server. The Tables window is
the same window that is used to add tables from the prompted query
interface. Refer to [“Tables” on page 35|for more information on the fields in
the Tables window.

A diagram of the table that you have specified or selected appears in the top
section of the diagram window. All the columns that are included in the table
are listed in the diagram. All the columns in the table are also listed in the
bottom section of the diagram window.

You can include multiple tables in your query. You would follow the same
procedure for including tables. However, when you add multiple tables to a
query, you must specify how to link the tables using join conditions.

Join Conditions

When you include more than one table in a query you must specify how the
tables will be linked. Those specifications are called the join conditions. From
the diagram interface, there are several ways to specify the join conditions:

* When you add a table to the query, the Join Tables window and the Join
Columns windows open automatically in sequence. You use these windows
to specify the type of join will be applied to the tables and what columns
will joined. These windows are the same as those used to specify join
conditions when you creating queries using the prompted interface. Refer to
[‘Join Conditions” on page 36| for more information on the fields in these
windows.

* Use the drag and drop method. Select a column from one table and drag it
to a column in another table. A connecting line is drawn from the column
in the first table to the column in the second table.

* Select Add --> Join Conditions. The Join Tables window opens followed by
the Join Columns window. These windows are the same as those used to
specify join conditions when you creating queries using the prompted
interface. Refer to[“Join Conditions” on page 36| for more information on
the fields in these windows.

You can change the join conditions or delete a join condition by right clicking
on the line that joins the table diagrams in the top section of the window. A
context menu opens offering you two choices:

* Select Remove join to remove the join condition that connects the two
tables. You must have a least one join condition to link the tables.
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* Select Change join to change the join condition. The Join Tables window
opens., followed by the Join Columns window where you can make
changes to the join conditions.

Columns

The columns for each table that is included in the query are listed in each
table’s diagram. In addition, all of the columns from all of the tables are listed
in the bottom section of the diagram window. The name of the column is
specified in Field and the table the column belongs to is specified in Table.

Unless otherwise specified, all the columns listed in the bottom section of the
diagram interface will be included in the query results.

You can specify whether a column is included in the query results in one of
two ways:

* Using the Include check box in the bottom section of the window. If this
check box is checked, the column is included in the query results. If
unchecked, the column is not included in the query results.

* From the top section of the window, right-click on a column name in the
table diagram. A context menu opens. Select Remove column to exclude the
column from the query results. The column is removed from the display in
the bottom section of the window. It remains in the table diagram. Select
Add column to include the column back in the query results. The column is
added back to the display in the bottom section of the window. A column
name is never removed from the table diagram in the top section of the
window. The table diagrams always shows you what columns are available
in the table, the bottom displays shows you want columns will be included
in the query results.

Sort conditions

You specify sort conditions for the rows that are returned in the query results
using the bottom section of the diagram window. You can specify the sort
order and key sequence for each column that is included in the query results.

To select the sort order for a column, click in the Sort order field for one or
more of the columns. Click on the arrow to select one of the sorting choices.
You can choose:

* ascending to sort in ascending (A-Z) order
* descending to sort in descending (Z-A) order
* not sorted to not have the column’s contents considered in the sort

The key sequence determines in what order the columns are sorted. Click in

the Key Sequence field for each column and specify a number. The number
"1" specifies that this column is first in the sort order.
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Display Name
You can change the name of a column in the query results. For example, the

name of a column in a table may be "PRODID" and you would like the name
to appear as the name of the product, "Lamps” in the query results.

To change the name of the column in the query results:
* Type the new name in the Display name field in the bottom section of the
diagram window.
Aggregation
You can apply an aggregation code to column to summarize the contents in
the query results.

To select an aggregation code to apply to the column, click in the Aggregation
field for one or more of the columns. Click on the arrow to select one of the
ways to summarize the contents of the column. You can choose:

* (none)

* average

* count

* maximum

* minimum

* sum
Row conditions

Use can specify row conditions to limit the rows that are returned in the
query results. Without row conditions, all qualifying rows will be returned
from the query.

You use the following fields in the bottom section of the diagram window to
specify the row conditions:

* Row Conditions and ors
e Additional row conditions
* Include duplicate rows

Row conditions and ors

Use this field to specify simple conditions that apply to the specific column.
You can use any of the valid SQL operators. For example, enter "=1" in a row
condition for a numeric column. This will specify that only those rows with a
value of "1” in this column will be included in the query results.

Additional row conditions
Use this field to add additional row conditions. You have the choice of adding

the conditions using an And or Or operator. You can type any valid SQL
expression using connectors and columns.
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Include duplicate rows
Check this check box to specify that duplicate rows will be included in the

query results.

Running queries
1. Select one of the following options:

* create a query by typing in the SQL statements directly in the active
window

* open an existing query
* create a query using the prompted interface
* create a query using the diagram interface
2. Click Query--> Run or click the Run query con.
The query runs and the query results are returned.

Switching between query views

You can switch between different views of a query.

1. From the diagram view, select View--> Prompted to view your query from
the prompted interface.

2. From the prompted view, select View--> Diagram to view your query
from the diagram interface.

3. From the SQL view, select View--> Diagram to view your query from the
diagram interface or View--> Prompted to view your query from the
prompted interface.

4. From the prompted or the diagram views, select View--> SQL to view the
SQL statements that have been created for your query.

Note: If you are creating your query using the diagram or prompted
views, and you switch to view the SQL statements, you cannot
make changes to the SQL statements and then return to the
prompted or diagram views. Once you make a change to the SQL
statements you cannot go back to the original view.

EasyAsk

Select File--> New--> Natural Query to create a query using the EasyAsk
program. This option is only available if EasyAsk is installed.

EasyAsk is a natural language, English-only, search interface that transforms
your basic search request into a comprehensive advanced search for relevant
information in documents and relational databases. EasyAsk returns precise
answers in the format that best suits your needs.
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You can ask questions in English without learning complex database
languages, such as SQL. With EasyAsk, you can access information stored in
any database that supports SQL. EasyAsk translates your plain-English
request into SQL and displays the answer in a number of useful formats, such
as:

 graphs
* spreadsheets
* OLAP pivot tables

* native formats of multiple, third-party reporting tools

Note: EasyAsk translates questions written in English into SQL; other
languages are not supported.

Table 22. EasyAsk Options

Option Description

Open Dictionary Select the Open Dictionary option to open an
existing dictionary. A dictionary is a compilation of
definitions used to translate everyday
English-languages into SQL.

Query Builder Select the Query Builder option to open a window
for entering questions for EasyAsk to answer.

View Interpretation Select the View Interpretation option to review
EasyAsk’s interpretation of a question. This option
displays the actual SQL generated for the question
and provides a means to view a modified English
translation of your question.

Dictionary Editor Select the Dictionary Editor option to customize a
dictionary by adding, editing, and removing
definitions.

Dictionary Map Select the Dictionary Map option to obtain a

graphical view of the tables contained in the
EasyAsk dictionary that illustrates the relationships
between the tables.

Set Date Select the Set Date option to set date parameters,
such as:

* defines the word today as any date

e affects the meaning of other time-sensitive
references, such as "last month” or "this quarter”

* provides ability to query as-of a certain date

* provides the ability to specify the last month of
the fiscal year in your application
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Table 22. EasyAsk Options (continued)

Option

Description

Construction Kit

Select the Construction Kit option to set dictionary

parameters such as:

* creates an EasyAsk dictionary for your ODBC
data source

¢ adds or deletes tables, columns and defined
values to or from an existing dictionary

Dictionary Properties

Select the Dictionary Properties option to customize
settings for the current dictionary, such as:

* general properties
e dialect properties
* security properties

* search properties

Draw queries

Select File--> Draw Query to create an SQL query automatically by specifying
the tables to query and the query type, which can be a SELECT, UPDATE or
INSERT query. The SQL statement is built automatically and it references the
names and data types of all columns in the selected table or tables.

You can edit the SQL statement prior to running it.

Drawing SQL queries - by table name
1. Select File--> Draw Query.

The Draw Query dialog box opens.

2. Specify the server where the tables are stored.

3. Select the query type:

Table 23. Query types

Query type Result
SELECT Retrieve rows from one or more tables
UPDATE Change information in a table.

Note: Select only one table. Otherwise, this message
displays:

You cannot draw an Update or Insert query for
more than one table at a time. Remove all but one
of the tables from the table 1ist.
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Table 23. Query types (continued)

Query type

Result

INSERT

Add new rows to a table
Note: Select only one table. Otherwise, this message

displays:

You cannot draw an Update or Insert query for
more than one table at a time. Remove all but one
of the tables from the table Tist.

4. Type the table owner and name.

5. Click Add.
6. Click OK.

This creates and displays an SQL query for the selected tables. You can

edit the SQL.

Drawing SQL queries - by matching patterns
1. Select File--> Draw Query.
The Draw Query dialog box opens.
2. Specify the server where the tables are stored.

3. Select the query type:

Table 24. Select Query Type

Query Type

Result

SELECT

Retrieve rows from one or more tables

UPDATE

Change information in a table.
Note: Select only one table. Otherwise, this message
displays:

You cannot draw an Update or Insert query for
more than one table at a time. Remove all but one
of the tables from the table list.

INSERT

Add new rows to a table
Note: Select only one table. Otherwise, this message

displays:

You cannot draw an Update or Insert query for
more than one table at a time. Remove all but one

of the tables from the table 1ist.

4. Type a pattern to locate the table.

Patterns enable you to search for table names from a list of matching
tables. There are two types of search patterns:
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* Percent

Use the percent character (%) to match a string of any length
containing any characters. For example, to list all tables with a name
beginning with the letter A, enter A%.

¢ Underscore

Use the underscore character (_) to match a single character. For
example, to list all tables with an owner that has the letter A in the
second position, enter _A%.

Click Add from List.

Select a table from the list.

Click OK.

Type a unique identifier for the table.
Click Add.

The table is added to the query.

10. Click OK.

The SQL for the selected table or tables is created and displayed. You can
edit the SQL.

© 0N o O

Variables in SQL queries

Variables are a small part of the computer program code that can be modified
while the program is running. In this way, the same program can be used for
several actions.

QMF for Windows has two kinds of variables:
* substitution variables, which are used in SQL queries

* global variables, which are system-level variables, described in the chapter,
Working with Global Variables

Substitution variables

Substitution variables are used in QMF objects for substituting variables to
strings at run time. This feature enables you to substitute a part of an SQL
statement and make it more generic. Substitution variables are active only
while the object (query, procedure or form) is running. As a result, only one
object can access the substitution variable. The variable will not exist after the
object is executed.

A substitution variable is special text in a query that begins with an
ampersand character (&). A substitution variable and can contain up to 18

alphabetic, numeric or special characters suchas A !'$ ~{}? @ # % \ or _.

A substitution variable can appear anywhere in a query. The value of the
substitution variable can be anything used in a query (except a comment). For
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example, you can use a substitution variable in place of a column name,
search condition, subquery, or any specific value.

Example
You will be prompted for a customer number each time you run the following

query:
SELECT ORDERNO, SALESREPNO, PRODNO, QUANTITY, &CUSTNO AS CUSTOMER#
FROM Q.SALES

When you run the query and supply customer number at the prompt, the
query will retrieve only those records that are associated with the specified
customer number. Later you can launch the query and provide a different
customer instead of writing a separate query.

Task
The following sample query illustrates how to use a substitution variable:

1. Open a query.
2. Type this SQL statement:
SELECT * FROM Q.STAFF WHERE DEPT >= &MIN_DEPT
3. Select Query--> Run.
The Enter Substitution Variable Values dialog box opens.
4. Type 50 in the Value field.
5. Click OK.

Try experimenting with substitution variables by replacing values in the
SELECT and FROM clauses. See what results your queries return.

Saving and opening queries

You can save queries on your PC, on a file server, or at a database server. A
query is saved in the format that is currently being used to view the query.
For example, if the query is being viewed in the prompted interface, it will be
saved in the prompted format. If the query is being viewed in the diagram
interface, it will be saved in the diagram format. If the SQL statements are
being viewed, then the query will be saved in the SQL format. A saved query
opens in the format in which it has been saved.

Saving queries to files
1. Create a query.
2. Select File--> Save.
3. Type the query name.
4. Click OK.
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Opening saved SQL query files
1. Select File--> Open.
The Open dialog box opens.
2. Select the file to open.
3. Click OK.

Saving SQL queries at the database server
Queries saved at the server so they are accessible to other users.
1. Open a query.
2. Select File--> Save at Server.
The Save Query dialog box opens.
3. Type an owner and a name.
4. Check the Share the object with other users check box.
5. Click OK.

Opening queries saved at the database server
You can open queries that have been saved at the database server.
1. Click File--> Open From Server.
The Open From Server dialog box opens.

2. Type a server, owner, and name.
3. Click OK.
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Chapter 4. OLAP queries

For database servers that support DB2 Cube Views, you request information
from the server using an OLAP query. OLAP queries are multidimensional
queries that can present your data in a wide variety of views. Using QMF for
Windows you can:

* Open existing OLAP queries using the Database Explorer
* Create new OLAP queries using the OLAP Query Wizard
* Work with the OLAP query results using the OLAP Query Results Explorer

Open OLAP queries using the Database Explorer

Use the Database Explorer to view, access, and analyze OLAP queries. When
the Explorer Bar is enabled, the Database Explorer window opens along with
QMF for Windows and it remains open for the entire session.

The Database Explorer displays in a tree structure the QMF objects that are
stored on the database servers. The Database Explorer includes the same
branches regardless of whether the server is a relational database server or
one that supports DB2 Cube Views.

The Database Explorer does list different dependency information for OLAP
queries. For OLAP queries the dependencies are:

* Cube

* Dimension

* Measure

To open an existing OLAP query, expand and collapse database server
branches until you find the OLAP query that you want to open. Queries that
have been been created and saved as OLAP queries are identified with a
unique icon containing a small cube in front of the query name.

Open the OLAP query by double clicking on the query or right-clicking on

the query to open a context menu where you would select Run to run the
query. The query results are returned in the active window.
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Create new OLAP queries using the OLAP Query Wizard
The OLAP Query Wizard helps you build an OLAP query. The OLAP Query
Wizard has the following steps:
* Open the OLAP Query Wizard
* Select a database server

* Specify how the list of cubes on the database server will be presented to
you

* Select the cube that will be included in the OLAP query

Open the OLAP query Wizard
From the QMF for Windows main window, select File--> New--> OLAP
Query to Open the OLAP Query Wizard.

Select a server

Use the OLAP Query Wizard Select a Server dialog to select the database
server where the cubes that will used in the OLAP query reside.

1. Select a server from the list.
2. Click Next.
The OLAP Query Wizard Sort Cube List by dialog opens.

Sort Cube List by

Cubes are stored on the database server by schema and by model. You can
choose how those cubes are presented to you for selection in the next step of
the OLAP Query Wizard.

1. Select the sorting method to use.

Select the Schema radio button to sort cubes by schema, which is the cube
name or the owner of the object.

Select the Model radio button to sort cubes by model.
2. Click Next.
The OLAP Query Wizard Select a Cube dialog opens.

Select a Cube

The cubes that reside on the database server are presented in a tree structure
based on the sort criteria you specified in the previous step. Use the OLAP
Query Wizard Select a cube dialog to select the cube to use for the OLAP

query.

1. Select the cube to use.
If you sorted by Schema on the OLAP Query Wizard: Cube List Filters
dialog box, the cube is shown in server, name, then cube order.

If you sorted by Model on the OLAP Query Wizard: Cube List Filters
dialog box, the cube is shown in server, model, then cube order.

2. Click Finish.
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The OLAP query is run on the database server. The results are returned in
the active window.

Work with the OLAP Query Results Explorer

After you run an OLAP query, the results are returned in the active window.
The OLAP Query Results Explorer opens in the Explorer window. Once you
have query results you have several options: one of which is to make changes
to the query results as they appear in the active window.

* Use the Filter options to exclude data from the OLAP query
* Use the Query Results Explorer, Layout Designer, drag and drop, and menu
commands to format the query results
Filtering Options
You can use the Filters dialog to select which cube dimensions will be

included in the OLAP query. With this option you can choose to exclude data
from the OLAP query.

The Filters dialog box lists the dimensions defined for the cube. Each
dimension of a cube has one or more attributes. By checking or unchecking a
check box you can choose to include or exclude the attribute’s or entire
dimension’s data from being included in the OLAP query.

Select values to include in results
You cannot de-select an entire dimension, and you need to select at least one

value for each dimension.

Procedure
1. Use the OLAP Query Wizard to select a cube, run the OLAP query and
return results.

2. Open the Filter dialog by:
* selecting Results--> Filter from the main menu

* right-clicking on a dimension or attribute in the Query Results Explorer
tree to open a context menu then select Filter

¢ click on the Filters icon in the toolbar

The Filters dialog opens.
3. Click the (+) to expand the dimension.

4. Uncheck the check box next to each dimension item you want to filter out
from the OLAP query.

Note: You cannot filter out an entire dimension.
5. Click OK.
The OLAP query is rerun and results are returned recalculated.

Chapter 4. OLAP queries 55



Additional Filter Options
There are two additional filtering options:

¢ Filter out

* Filter Everything but

The Filter out and the Filter Everything but options are available from
context menu that opens in the OLAP query results when you right click on a
cell in a column. If you select Filter out, the cell of the column is filtered out
of the query results. If you select Filter Everything but, then all the cells of
the column are filtered out from the query results except for the one that you
selected.

Formatting the OLAP query results
You can use the following to format the OLAP query results:
* OLAP Query Results Explorer
* Layout Designer
* Drag and drop
* Menu commands

OLAP Query Results Explorer

The OLAP Query Results Explorer opens in the Explorer window when the
results of the OLAP query are returned. The OLAP Query Results Explorer
displays the OLAP query results in a tree structure.

You can use the OLAP Query Results Explorer to move around, discover and
easily modify the structure of the OLAP query results. You can select columns
to summarize, group like information, and change the order of result columns
dynamically in the active window.

The OLAP query re-runs each time you make changes to the query results
using the OLAP Query Results Explorer.

Navigating the Query Results Explorer tree
The Query Results tree has the following branches:

e Cube
* Layout

Cube: The name of this branch is name of the cube that was selected for the
OLAP query. It list the dimensions and measures that were used in the OLAP
query. As you make changes to the query results in the active window, this
branch remains unchanged. It serves as the source.
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Layout: This branch lists the columns as they currently appear in the active
window. As you make changes to the OLAP query results in the active
window, the changes are reflected in this branch of the tree. There are three
nodes in the Layout branch:

¢ Top Dimensions

Lists the dimensions that you have selected to be summarized along the top
of the query results.

* Side Dimensions

Lists the dimensions that you have selected to be summarized along the left
side of the query results.

* Measures

Dynamically lists and relists the query results measures as they appear after
each move that you make using the Query Results Explorer or the Layout
Designer.

Working with the OLAP Query Results Explorer
There are two ways of working in the OLAP Query Results Explorer:

° using a context menu

¢ drag and drop

You can right-click on any measure listed in Layout branch to open a context
menu. From the context menu you can:

* Apply formatting to whole columns and unique formatting to cells within
columns in the query results

* Apply grouping to columns in the query results
* Remove columns from the query results

Many of the commands that are available from the context menu are also
available from the Results menu in the main menu bar or from the context
menu that opens when you right click in the open space of the query results.
Each command is discussed in detail later in this chapter.

Drag and Drop: From the OLAP Query Results Explorer tree you have the
following drag and drop capabilities:

* You can remove columns from the query results by selecting the column
from the Measures branch and dragging it to the Cube dimensions branch.
The measure (column) is removed from the query results.

* You can return the measure to the query results by selecting the column
from the Cube Dimensions branch and dragging it to the Measures branch.
You can drop the column any where in the query results.

* You can rearrange the order of columns in the query results by selecting a
measure in the Data Columns branch and dragging it to a new position.
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* You can select any measure branch and drag it to the Top Groups branch.
The column will be summarized and placed across the top of the query
results.

* You can select any column in the Data Columns branch and drag it to the
Side Groups branch. The column will be summarized and placed as the
first column to the left of the query results.

* An entire dimension must be selected for the side group. For example, you
cannot select the MARKET_STATE characteristic alone; instead, you need to
select the entire MARKET dimension.

* Remove the side group by dragging the dimension from the side
dimensions branch in the layout designer to the Dimensions branch of the
object tree.

Layout Designer: Another tool that is available to change the OLAP query
results in the active window is the Layout Designer. The OLAP Query Results
Explorer and the Layout Designer work together. Any changes made with one
are dynamically incorporated by the other.

Layout Designer

The Layout Designer and the OLAP Query Results Explorer share much of
the same functionality. You can access the same context menu and perform
similar drag and drop moving of columns. These two tools work together and
any changes you make with one are incorporated by the other. You would
select which tool to use based on your preference of working with trees or
working with a more visual representation of the query results.

There is one difference. With the Layout Designer you can choose to work
offline, that means you can make changes to the query results and they are
not immediately applied in the query results active window.

Depending on the complexity of the query results, applying each change
dynamically can consume excessive time and system resources. By working
offline, you can make all the changes, see how the query results will look in
the Layout Designer window, without the changes actually occurring. This
saves system resources. When you have made all the changes, then you can
check the Enable online mode check box to update the view of the query
results in the active window.

Menu commands

You can use any of the following menu commands to format the OLAP query
results.

Copy
Use the Copy option to copy data for a measure or dimension directly to the

clipboard.
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Font and Format
You can apply extensive formatting options to the OLAP query results. The

formatting options are the same as for relational query results and the details
are covered in the chapter on Query Results.

Grouping and aggregation

The Grouping and Aggregation options are not available from the Results
menu, or from the context menu. Instead, the grouping and aggregation
options are defined by the administrator when creating the OLAP cubes using
a third-party product.

Drill down
Use the Drill Down option to view detailed data for a dimension and its

corresponding measures.

Procedure:

1. Right-click on a rolled-up (summary) dimension in the OLAP query
results, or the Layout Designer, or OLAP Query Results Explorer.

2. Select Drill Down from the context menu.

Detailed information rather than summary information is revealed for the
dimension.

Drill up
Use the Drill up option to view summary data for a dimension and its

corresponding measures.

Procedure:

1. Right-click on a dimension on the OLAP query results, or the Layout
Designer or the OLAP Query Results Explorer that does not have
summary information.

2. Select Drill up from the submenu.

Summary information is revealed for the dimension.

Remove from Layout
Use the Remove from Layout option to remove a column from the OLAP

query results. The column is removed from the layout but not from accessible
query results.

Procedure: To remove a column from the query results layout:

1. Right-click on a column in the OLAP query results, or the Layout Designer
or the OLAP Query Results Explorer.

2. Select the Remove from Layout option from the submenu.
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Note: Notice that the column has been removed from the OLAP query
results, the Layout Designer, and the Layout section of the Query
Results Explorer.

To return the column to the layout:

1. Select the column from the Dimensions or Measures branches of the OLAP
Query Results Explorer tree.

2. Drag the selected column to the Layout branch of the OLAP Query Results
Explorer tree.
The column is returned in the OLAP query results, the Layout Designer,
and the Measures node of the Layout branch in the OLAP Query Results
Explorer tree.
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Chapter 5. Query results

Overview

After you run a query, the results are returned in the active window. Once
you have query results you have several options, one of which is to make
changes to the query results as they appear in the active window.

Query Results Explorer

The Query Results Explorer opens in the Explorer window when the results of
the query are returned. The Query Results Explorer displays the query results
in a tree structure.

You can use the Query Results Explorer to move around, discover and easily
modify the structure of the query results. You can select columns to
summarize, group like information, and change the order of result columns
dynamically in the active window.

Navigating the Query Results Explorer tree
The Query Results tree has the following branches:
¢ Result Set
¢ Layout

Result Set branch
This branch lists the columns that are in the query results as they were

returned from the query. As you make changes to the query results in the
active window, this branch remains unchanged. It serves as the source.

Layout
This branch lists the columns as they currently appear in the active window.

As you make changes to the query results in the active window, the changes
are reflected in this branch of the tree. There are three nodes in the Layout
branch:

* Top Groups
Lists the columns that you have selected to be summarized along the top of
the query results.

* Side Groups

Lists the columns that you have selected to be summarized along the left
side of the query results.

e Data Columns
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Dynamically lists and relists the query results columns as they appear after
each move that you make using the Query Results Explorer or the Layout
Designer.
Working with the Query Results Explorer

There are two ways of working in the Query Results Explorer:

* using a context menu

* drag and drop

You can right-click on any column listed in Layout branch to open a context

menu. From the context menu you can:

* Apply formatting to whole columns and unique formatting to cells within
columns

* Apply grouping to columns in the query results

* Add columns to the query results based on expressions

* Remove columns from the query results

* Resort the rows in the query results based on different criteria

Many of the commands that are available from the context menu are also
available from the Results menu in the main menu bar or from the context
menu that opens when you right click in the open space of the query results.
Each command is discussed in detail later in this chapter.

Drag and Drop

From the Query Results Explorer tree you have the following drag and drop

capabilities:

* You can remove columns from the query results by selecting the column
from the Data Columns branch and dragging it to the Result Set branch.
The column is removed from the query results.

* You can return the column to the query results by selecting the column
from the Results Set and dragging it to the Data Columns branch. You can
drop the column any where in the query results.

* You can rearrange the order of columns in the query results by selecting a
column in the Data Columns branch and dragging it to a new position.

* You can select any column in the Data Columns branch and drag it to the
Top Groups branch. The column will be summarized and placed across the
top of the query results.

* You can select any column in the Data Columns branch and drag it to the
Side Groups branch. The column will be summarized and placed as the
first column to the left of the query results.

Note: Data in the query results can be grouped by columns on the vertical
axis, and related values by columns can be grouped on the horizontal
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axis. This is known as pivot or ACROSS functionality. You can define
multiple levels of grouping on both axes.

Layout Designer
Another tool that is available to change the query results in the active

window is the Layout Designer. The Query Results Explorer and the Layout
Designer work together. Any changes made with one are dynamically
incorporated by the other.

Using the Layout Designer

Another tool that is available to change the query results in the active
window is the Layout Designer. Using the Layout Designer you can:

* select columns to summarize vertically
 select columns to summarize horizontally

* change the order of columns in the query results

The Layout Designer does not open automatically when query results are
returned to the active window. You must open the Layout Designer. Select
View --> Control Bars --> Layout Designer to open the Layout Designer

window.

Dynamically updating query results

The Layout Designer and the Query Results Explorer share much of the same
functionality. You can access the same context menu and perform similar drag
and drop moving of columns. These two tools work together and any changes
you make with one are incorporated by the other. You would select which
tool to use based on your preference of working with trees or working with a
more visual representation of the query results.

There is one difference. With the Layout Designer you can choose to work
offline, that means you can make changes to the query results and they are
not immediately applied in the query results active window.

Depending on the complexity of the query results, applying each change
dynamically can consume excessive time and system resources. By working
offline, you can make all the changes, see how the query results will look in
the Layout Designer window, without the changes actually occurring. This
saves system resources. When you have made all the changes, then you can
check the Enable online mode check box to update the view of the query
results in the active window.

Navigating the Layout Designer window
The Layout Designer window consists of three sections:

* Drag column here to create top groups
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Lists the columns that will be summarized across the top of the query
results.

* Drag column here to create side groups

Lists the columns that will be summarized in a column placed to the left of
the first column of the query results.

* Columns workspace
Lists the columns as they currently appear in the query results.

There are two ways of working in the Layout Designer:
* using a context menu
* drag and drop

Using the context menu
You can right-click on any column heading listed in Columns workspace to

open a context menu. From the context menu you can:

* Apply formatting to whole columns and unique formatting to cells within
columns

* Apply grouping to columns in the query results
* Add columns to the query results based on expressions
* Remove columns from the query results

* Resort the rows in the query results based on different criteria

Many of the commands that are available from the context menu are also
available from the Results menu in the main menu bar or from the context
menu that opens when you right click in the open space of the query results.
Each command is discussed in detail later in this chapter.

Drag and drop

From the Layout Designer you have the following drag and drop capabilities:

* You can remove columns from the query results by selecting the column
from the Columns workspace and dragging it to the Result Set branch of
the Query Results Explorer. In order to remove columns from the Layout
Designer by drag and drop the Query Results Explorer must be open. The
column is removed from the query results.

* You can return the column to the query results by selecting the column
from the Results Set branch of the Query Results Explorer and dragging it
to the Columns workspace. You can drop the column any where in the
query results. In order to return columns to the Layout Designer by drag
and drop the Query Results Explorer must be open.

* You can rearrange the order of columns in the query results by selecting a
column in the Columns workspace and dragging it to a new position.
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* You can select any column in the Columns Workspace and drag it to the

Drag column here to create top groups section. The column will be
summarized and placed across the top of the query results.

* You can select any column in the Columns Workspace and drag it to the

Drag column here to create side groups section. The column will be
summarized and placed in a column to the left of the query results.

Note: Data in the query results can be grouped by columns on the vertical

axis, and related values by columns can be grouped on the horizontal
axis. This is known as pivot or ACROSS functionality. You can define
multiple levels of grouping on both axes.

Formatting the query results

You can choose to apply a wide range of formatting options to the query
results. There are two ways of applying formatting options:

Formatting bar

You can apply many of the formatting options using the Formatting bar.
You can set the type and size of the font; specify a font style of bold or
italic; select text and background color; and specify alignment, data format
and precision.

Layout Properties window

From this window you can set all the formatting properties including
conditional formatting.

Formatting Bar

The Formatting bar enables you to quickly apply many formatting options to
the query results.

You open the Formatting bar by selecting View --> Toolbars and checking the
Formatting bar check box. The Formatting bar opens in the top of the
window.

To apply formatting, select a cell or a column in the query results and then
select the formatting option from the Formatting bar that you want to apply.

Layout Properties window

From the Layout Properties window you can set all the formatting options
that are available for the query results. The options are divided into the
following groups:

* General
* Font
* Format

e Conditional
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You can apply formatting options to entire columns, individual cells, column
headings, and summary cells. The Layout Properties window includes a tree
that will help you to navigate the query results, and select the cells or

columns for formatting.

General Options
Table 25. General Options

Field

Description

Heading

Displays the name of the column that you have
selected for formatting. You can type a new
heading for the column in this field. The new
name will appear in the query results.

Grouping and Aggregation

Displays the aggregation specifications that will
be applied to the column. If none have been
specified, this field is not available.

Width (in pixels)

Specifies the width of the column in pixels. You
can change the width by typing a new number
in the text box or selecting a number from the
drop-down list.

Source

Displays the source for the data that is in the
column that you have selected. If the column
contents is the result of an expression, the
conditional expression that was used is
displayed.

Font options
Table 26. Font Options

Field Description

Font The name of the font, such as Arial or Times
Roman

Font style The style of the font, such as bold or italic

Size The point size of the font

Script The type of script being used, for example

Western.

Foreground color

The color of the text, such as dark blue

Background color

The color the text is against, such as a gray
background

Sample

A rendering of the current formatting
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Table 26. Font Options (continued)

Field

Description

Set as default

Press the Set As Default button to set the
current font attributes as the default for
subsequent query results.

Note: The default will remain in effect until you

choose a new font or change the default.

Reset to default

Click the Reset To Default button to reset the
font formatting attributes to the default setting

Format options

The available Format options vary depending on whether you selected a
column with character, numeric, date or time data.

Table 27. Format options

Field

Description

Format

For numeric data:
* Asis

e Currency

* Decimal

* Scientific

* Percent

* User Currency

For character data:
* Asis

* Hexadecimal

* Binary

For date and time data:

* Asis

* the month, day and year (date)

* the hour, minute, and second (time)

¢ with the separator symbol that you choose

Sample

Shows a snapshot of the column format.

Horizontal alignment

From the drop-down list, select how to align
data horizontally in the column. Options are:

o left
* right

* center
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Table 27. Format options (continued)

Field Description

Vertical alignment From the drop-down list, select how to align
data vertically in the column. Options are:

* top
* center

* bottom

Options For numeric data:

* Check the Thousands separator check box to
place a thousands separator in numeric values
(the symbol is taken from Windows settings).

* Select the format for Negative numbers from
the drop-down list.

* Select the format for Decimal places from the
drop-down list.

For character data:

e Check the Wrap text check box to wrap the
contents of the cell to the next line within the
cell.

For Time and Date data:

* Select the Separator symbol to format date
data, such as a slash (/) for date data. An
example is: 03/25/02. Select the symbol to
format time data, such as a colon (:). An
example is: 12:03:02.

* Check the 12 hour mode check box to display
time in a 12-hour interval, such as 03:12:30
PM or 10:05:07 AM. If this check box is
unchecked, time is displayed in 24-hour
format (such as 15:12:06).

Set as default Press the Set As Default button to set the
current format attributes as the default for
subsequent query results.

Note: The default will remain in effect until you
change the default.

Reset to default Click the Reset To Default button to reset the
format attributes to the default setting

Conditional options
You can specify conditional formatting options for each detail, summary and

grand total cell in a column. Based on an expression, each cell in the column
can be formatted differently. For example, within a column, you could specify
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that if a cell’s contents equals 0, then display the cell with a red background
and if value is 100, display the cell with a blue background.

To set conditional formatting follow these steps:

1. From the Columns tree in the Layout Properties window, click on the
Detail branch to apply conditional formatting to the detail cells of the
column, the Summary branch to apply conditional formatting to the
summary cells, or the Grand Total branch to apply conditional formatting
to the grand total cell of the column.

2. With the appropriate branch selected, click the Add icon. The control fields
Condition name and Condition Expression become available.

3. You must give each conditional expression that you create a name. Type
the name of the expression in the Condition name field. A branch is
automatically created in the tree using the condition name.

4. Each condition must have an expression. Type the expression in the
Condition Expression field. You must follow the rules for building
conditional formatting expressions.

5. After you have created the expression, select the Font or the Format page
of the Layout Properties window to specify the formatting that will be
applied to any cell in the column that meets the conditions set in the
expression.

Table 28. Conditional options

Field Description

Condition name Use this field to specify a unique name for the
conditional expression. A branch in the Layout
Properties tree is created using this name.

Condition expression Use this field to specify the conditional
expression. You must follow the rules for
building conditional formatting expressions.

The expression language supports constant
expressions, expressions defined as variables
sourced on other columns in the result set (&1,
&2, for example), numeric operators (such as +,
-, *, /), character operators (+, CONCAT),
numeric and character functions (such as MIN,
MAX, AVG, SQRT, CONCAT, SUBSTR), and a
set of logical and relational operators (such as >,
<, =, =)

Note: For more information on the expression
language refer to QMF for Windows online help.
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Adding Calculated Columns to the query results

A calculated column is a column of data that is created and added to the
query results. The contents of the new column is based on an expression that
you define. The expression can use data from other columns, constants and
variables.

You use the Calculated Columns window to add a calculated column to the
query results. You can open the Calculated Columns window by:

* right clicking outside the query results in the active window and selecting
Add Calculated Column from the context menu

* right clicking on a column in the Result Set branch of the Query Results
Explorer tree and selecting Add Calculated Column before from the
context menu

The expression used to calculate the value of the added column is saved with
the query. The calculated column will be included in the query results each
time the query is run.

Table 29. Calculated Columns dialog

Field Description

Name Use this field to specify the name for the new
column as it should appear in the query results.

Expression Use this field to specify the conditional
expression. You must follow the rules for
building conditional formatting expressions.

The expression language supports constant
expressions, expressions defined as variables
sourced on other columns in the result set (&1,
&2, for example), numeric operators (such as +,
-, *, /), character operators (+, CONCAT),
numeric and character functions (such as MIN,
MAX, AVG, SQRT, CONCAT, SUBSTR), and a
set of logical and relational operators (such as >,
<, =, 1=5)

Note: For more information on the expression
language refer to QMF for Windows online help.

Grouping and aggregation

Purpose

You use the grouping and aggregation options to organize the query results
into logical or summarized groupings.
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You can, for example,
* Roll up data in a report by department
* Average departmental commissions

No aggregation
Select a column, then select Results--> Grouping and Aggregation--> No
Aggregation to remove any aggregation or summary formatting from the
selected column.

Top group with summaries

Select a column, then select Results--> Grouping and Aggregation--> Top
group with summaries to:

* group data ACROSS on the query results by the selected column
* present query results data for the other columns selected for the query

¢ provide a summary line for each row

Data in the query results can be grouped by columns on the vertical axis.
Related values by columns can be grouped on the horizontal axis, which is
known as pivot or ACROSS functionality. You can define multiple levels of
grouping on both axes. Grouping can be performed by drag-and-drop
operations on the columns in the query results, within the layout designer, or
within the query results explorer.

For example, select the Top group with summaries option, then specify to
group data by EDLEVEL (Education Level). The query results will be
reformatted so that the EDLEVEL column spans the other columns in the
result set. A summary line for each row in the query results is added in the
All values column.

Table 30. Top group with summaries option

05 11 All values

TEMPIDNAME | ADDRESSTEMPID NAME| ADDRESS TEMPID NAME| ADDRESS

125 FOX BOSTON 125 FOX |BOSTON
460 IDE EL PASO |460 IDE EL PASO
475 TILL |SEQUIM |[475 TILL |SEQUIM

Top group with no summaries

Select a column, then select Results--> Grouping and Aggregation--> Top
group with no summaries to:

* group data ACROSS on the query results by the selected column
* present query results data for the other columns selected for the query
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For example, select the Top group with no summaries option, then specify to
group data by DISP (Disposition). The query results will be reformatted so
that the DISP column (HIRE or NO HIRE) spans the other columns in the
result set.

Table 31. Top group with no summaries option

HIRE NOHIRE
TEMPID INTDATE MANAGER | TEMPID INTDATE | MANAGER
410 2002-02-02 JACOBS
460 2002-10-01 | MALVICHI
475 2002-12-02 | HJORDIS

Side group with summaries

Select a column, then select Results--> Grouping and Aggregation--> Side
group with summaries to:

* aggregate data in the query results by the selected column
* present query results data for the other columns in the query

Note: The column selected for the side group moves to the left of the query
results, and groups like data accordingly.

For example, select the Side group with summaries option, then specify to
group data by JOB. The query results will be reformatted so that jobs are
listed along the left side of the query results, and data specific to that job is
grouped with each job.

Note: A blank summary line is included as the last row in each group for you
to add summary information.

Also, you can drill-down (+) to view detailed data or roll up (-) to view
summary data.

Things to note in the example below:

* JOB is the column by which data is grouped; jobs are listed in the left
column of the query results

* the numbered columns in the first row represent the sequence of the
columns in the table

Table 32. Side group with summaries option
1 2 3 4 5 6
JOB ID NAME DEPT YEARS SALARY
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Table 32. Side group with summaries option (continued)

(+) MGR 10 SANDERS 20 7 18357.22
(+) SALES 20 PROVENCAL |20 8 18000.06
(-) CLERK 110 NGAN 15 5 12508.20
120 NAUGHTON |38 12954.75
130 MOORE 42 6 10505.90
142 HUME 57 11 14252.75

Side group with no summaries

Select a column, then select Results--> Grouping and Aggregation--> Side
group with no summaries to:

* aggregate data in the query results by the selected column
* present query results data for the other columns in the query

Note: The column selected for the side group moves to the left of the query
results, and groups like data accordingly.

For example, select the Side group with no summaries option, then specify to
group data by JOB. The query results will be reformatted so that jobs are
listed along the left side of the query results, and data specific to that job is
grouped with each job.

Note: You can drill-down (+) to view detailed data or roll up (-) to view
summary data.

Things to note in the example below:

* JOB is the column by which data is grouped; jobs are listed in the left
column of the query results

* the numbered columns in the first row represent the sequence of the
columns in the table

Table 33. Side group with no summaries option

1 2 3 4 5 6

JOB ID NAME DEPT YEARS SALARY

(+) MGR 10 SANDERS 20 7 18357.22
15 SWEENEY 21 10 25000.00
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Table 33. Side group with no summaries option (continued)

(+) SALES 20 PROVENCAL |20 8 18000.06

202 BAILEY 19 20 30000.00

(-) CLERK 110 NGAN 15 5 12508.20

120 NAUGHTON |38 12954.75

130 MOORE 42 6 10505.90

142 HUME 57 11 14252.75

250 BEAUSSET 63 2 40000.00

Count

Select a column, then select Results--> Grouping and Aggregation--> Count
to create a summary row at the bottom of the query results showing the
number of values in the column.

First

Select a column, then select Results--> Grouping and Aggregation--> First to
create a summary row at the bottom of the query results showing the first
value in the column.

Last

Select a column, then select Results--> Grouping and Aggregation--> Last to
create a summary row at the bottom of the query results showing the last
value in the column.

Maximum

Select a column, then select Results--> Grouping and Aggregation-->
Maximum to create a summary row at the bottom of the query results
showing the maximum value in the column.

Minimum
Select a column, then select Results--> Grouping and Aggregation-->
Minimum to create a summary row at the bottom of the query results
showing the minimum value in the column.

Sum

Select a column, then select Results--> Grouping and Aggregation--> Sum to
create a summary row in the query results showing the sum of the values in
the column.

Note: This option calculates interim summaries and overall summaries if
another column is selected for grouping with summaries.
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Cumulative sum

Select a column, then select Results--> Grouping and Aggregation-->
Cumulative Sum to display the values in the column as a cumulative sum,
which is a rolling sum. Each value is added to the value in the row below it.
A cumulative summary is presented at the end.

For example, here is a list of values:

18357.50
18171.25
17506.75

54,035.50

Results from a cumulative sum of these values are:

18357.50
36528.75
54035.50

108,921.75

Average

Select a column, then select Results--> Grouping and Aggregation--> Average
to create a summary row showing the average of the values in the column.

Standard deviation

Select a column, then select Results--> Grouping and Aggregation-->
Standard Deviation to create a summary row showing the standard deviation
of the values in the column. The standard deviation is a statistic that tells you
how tightly all the various examples are clustered around the mean in a set of
data.

Percentage of group
Select a column, then select Results--> Grouping and Aggregation-->
Percentage of Group to display the values in the column as a percentage of
the group’s total, with a summary row showing the sum of the percentages.
Percentage of group identifies how each value in the group contributes to the
whole. For example a salary of $1,000 is 10% of a total salary of $10,000.

Percentage of total

Select a column, then select Results--> Grouping and Aggregation-->
Percentage of Total to display the values in the column as a percentage of the
column total, with a summary row showing the sum of the percentages.

Cumulative percentage of group

Select a column, then select Results--> Grouping and Aggregation-->
Cumulative Percentage of Group to display the values in the column as a
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percentage of the group total. A summary row at the bottom of the query
results shows the sum of the percentages. For example, DEPT 42 earns 0.42%
in commissions.

Cumulative percentage of total

Select a column, then select Results--> Grouping and Aggregation-->
Cumulative Percentage of Total to display the values in the column as a
percentage value of the group total and a percentage value of the column
total. A summary row at the bottom of the query results shows the sum of the
percentages.

For example, within DEPT 42, Wheeler earns 44.60% of the commissions, while
Williams earns 55.40%, and Fraye earns no commission. Overall, this DEPT 42
earns 5.75% in commissions for the company.

Reset formatting

Select Results --> Reset formatting to remove all the formatting options that
you have specified for the query results.

Select Results --> Reset all to reset all the formatting that has been applied to
the query results, including changes to font, format, as well as summaries or
aggregation.

Autofit

Select Results--> Autofit to adjust all columns and rows or selected columns
and rows to fit the cell size, row size or column size.

Sort

Select Results--> Sort to specify sorting criteria for the query results. You can
sort data in ascending or descending order, or develop a multi-level sorting
scheme.

Sort ascending

Select Results--> Sort Ascending to reorder the data in the query results in
lowest-to-highest order (such as 1 - 10), based on the column you are selecting
for your sort.

Sort descending

Select Results--> Sort Descending to reorder the data in the results in
highest-to-lowest order (such as 10 - 1), based on the column you are selecting
for your sort.
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Multi-level sort

To set-up a multi-level sort you select the first column as the primary column
for sorting, the type of sort, and the method of sorting (ascending or
descending). Once you enter this information, you can select a second column
which will be a second column to sort by. You can repeat this for as many
columns as you have in the query results.

For example, select NAME as the primary sort, to be sorted in ascending order,
then select DEPT for the secondary sort, and specify to sort the data in
ascending or descending order within the primary (NAME) sort.

Go-to

Select Results--> Go to to navigate the rows in the query results.

In the Go to field, type the number of rows or the percentage of the results to
advance in the query results.

The Go to value determines whether to go to:
* a specific row in the query results
* a row relative to the current row

* a row located at a specific percentage of the result set

The Go to value works in conjunction with the Absolute row; Relative to
current row; and Percent of result set fields.

Absolute row

1. Select Results--> Go to.
2. Type a number in the Go to field.
This is the number of the row you want to go to.
3. Select the Absolute row radio button.
4. Click OK.

The query results will reposition so that the go-to row will be the first row
listed.

Relative to current row

1. Select Results--> Go to.
2. Type a number in the Go to field.

This value represents the number of rows you want to go beyond the
current row.

3. Select the Relative to current row radio button.
4. Click OK.
The query results will reposition to the designated row.
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For example, if you are on row 3002 and you enter 27 in the Go to field,
the query results will be repositioned, starting with row number 3029.

Note: You cannot enter a negative value.

Percent of result set

1. Select Results--> Go to.

2. Type a number in the Go to field.
This is the percentage to advance through the query results set, starting
with row number one.

3. Select the Percent of result set radio button.

4. Click OK.
For example if the query results set contains 33 rows and you enter 25 in

the Go to field, you advance to the eighth row because this row is 25% of
the query results.

Display chart

Select Results--> Display chart to define the layout for the chart being created
from the query results. See [Chapter 7, “Visualizing data,” on page 111| for
more information.

Display map

Select File -->New --> Map to visualize query results in the map form using a
map application. See [Chapter 7, “Visualizing data,” on page 111| for more
information.

LOB overview

Purpose
QMF for Windows can retrieve large objects (LOBs) from a database, save

LOBs to a database, export LOB data to your PC, and insert data types such
as text, graphics, audio, video, mixed media, and photo images.

You can retrieve a LOB from a database then edit the LOB in an application
that supports the file type you retrieved. For example, you can edit a bitmap
in Microsoft Paint (R), as long as Paint is installed on your computer. LOBs
are stored in QMF for Windows tables and you manipulate the LOBs as you
would any other type of data stored in a QMF for Windows table.

LOBs are supported by DRDA, CLI, and ODBC connections. For each server,
LOB support is determined by which connection is used. For example, a
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DRDA connection does not support LOBs for all UPB servers. For a UPB
server, however, LOBs are supported by a CLI connection.

Because LOBs consume a significant amount of memory, DB2 provides three
data types to store these data objects as strings of up to two gigabytes. These
include:

Features

Binary large objects (BLOBS)
Single-byte character large objects (CLOBs)
Double-byte character large objects (DBCLOBs)

LOBs can be:

retrieved from a database and exported to a PC
inserted as files (such as bitmaps and .gifs) into query results
edited in the associated application

stored in QMF for Windows tables in a database by calling the LOB in the
same manner as any other type of data

retrieved through a CLI connection only

edited, viewed, and exported as an .ixf, .txt, or .htm file

Note: Exporting as an .ixf file is recommended.
included in HTML reports
saved to the database

Retrieving LOBs from a database

Procedure
1. Run the query or procedure that calls the table where the LOB is stored on

the database.
The table with the LOB data is retrieved from the server.

Note: Each cell in the column containing LOB data is identified with the
label, <LOB Tocator>.

If status bar at the bottom of the window displays the message, A11 rows
retrieved, more LOB data to retrieve, it means that transferring LOB
data can be resource-intensive. By default, QMF for Windows returns LOB
locators that refer back to the actual data on the database. The LOB data
will be retrieved on demand or when a function requires it.

Optional: Select View--> Options.
The Options dialog box displays.
a. Click LOBs to change the default options for retrieving LOBs.
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b. Check the Override LOB options, if possible check box to make
changes to the LOB options.

Note: This option is available only if your database administrator has
granted override authority to you.

View and edit LOB data

You can update the LOB on the server only if you are in edit mode.

Follow these steps to view or edit LOB data:

1.

7.

Double-click on a cell labeled <LOB Tocator>.

The Column LOB Type Associations dialog box opens. Use this dialog box
to specify the Windows file format of the data.

Click the Mapping button.
The File Extension Mapping dialog box opens.
Select the file extension for the LOB at the File Extension column.

For example, if the mapping value is bitmap, change the file extension
from LOB to .bmp.

Note: Certain applications display specific file extensions. Refer to the
manual for your application to determine which files are supported.

Click OK
The Column LOB Type Associations dialog box opens.
Click OK.

The Column LOB Type Associations dialog box closes and the LOB opens
in the designated application.

Click OK.

A message box indicates how many rows in the database will be affected
by the operation.

The LOB locators column now contains icons that correspond to the
application, such as for bitmaps.

Select Results” Save to Database to save the query to the server.

Exporting LOB data

Purpose
Use this option to export LOB data retrieved from the database.

Map the file extensions before you export LOB data retrieved from the
database (see|“View and edit LOB data”), then the export is similar to
exporting ordinary data, but with LOB option specifications.
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For example, you can export a LOB as a bitmap, then save it as an HTML file
(-htm) in the Export Data dialog box.

For most LOB data, an HTML form may make the most sense because the file
can be displayed as an HTML address for HTML reports and web pages. For
more sophisticated web pages, use the HTML Form capabilities in QMF for

Windows.

Procedure

Follow these steps to export LOB data into an .ixf, .txt or .html file:

1. Select Results--> Save to File.
The Export Data dialog box opens.

2. Type a file name.

3. Select a file type, such as .ixf, .txt or .htm, in the Save as Type list box.

4. Click Options.
The Export Text/DEL Options (General tab) dialog box opens.

5. Click the LOBs tab.
The Export Text/Del Options (LOB tab) dialog box opens.

6. Choose a directory and a naming convention for your LOB data (database
name).

7. Click OK.
The Export Data dialog box opens.

8. Click Save to save the file to the specified directory.
When opened, the text file displays the LOB query results information that
was exported from the query results. The HTML file displays an active
link.

9. Click the LOB link to display the LOB data in the selected application.

Start cell contents

Purpose

Select Results--> Start Cell Contents to open a LOB (large object) in a cell on
the query results.

Procedure
1. Select a cell containing a LOB value.
2. Select Results--> Start Cell Contents.
The Column LOB Type Associations dialog box opens.
3. Select one of the following options to make a connection between the LOB

and the application used to open it:
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* Select the File Extension radio button to select the executable file to
open the application associated with the LOB, such as .txt for Notepad.

Note: Use this option when all the LOBs have the same format.

* Select the Mapping Column radio button to map the LOBs individually
to their applications.

Note: Use this option if LOBs have different formats.

Follow these steps:
a. Select a column from the drop-down list.
b. Click Mapping.
The File Extension Mapping dialog box opens.

c. Select the file extension from the file formats listed in the column
from the LOB Type Associations dialog box.

Note: This applies only if a file name is associated with the cell.

Retrieve all LOB values

Purpose

Select Retrieve all LOB values to retrieve all large object data files that are
included in the query results.

The label for all cells with LOB data will change from <LOB Tocator> to <LOB
value> to indicate that you can view or hear LOB data, among other options,
depending on LOB type).

Note: Before you retrieve the LOB values, create associations between the
LOB and its executable with the Results--> Column LOB Associations
option.

Column LOB associations

Purpose
Use Results--> Column LOB Type Associations to select the executable to
open the LOB.
Procedure
1. Select a column containing LOB data.
2. Select Results--> Column LOB Associations.

3. Select one of the following options select which executable will be used to
open the LOB:
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¢ Select the File Extension radio button to select the executable file to
view and edit the LOB.

Note: Use this option when all the LOBs have the same format.

* Select the Mapping Column radio button to individually specify which
application will be mapped to each LOB.

Follow these steps:
a. Select the mapping column from the drop-down list.
b. Click Mapping.
The File Extension Mapping dialog box opens.
C. Select the file extension from the LOB Type Associations dialog box.

Note: This option applies only if a file name is associated with the
cell.

Table 34. LOB type options

Field Description

File Extension The file extension of the LOB in the cell, from the
Windows System Registry.

Mapping column The column containing mapping values and extensions.

Save to database

Select Results--> Save to Database to save the query results to a table on the
database server.

Note: You can run a query at a database server and save the query results to
a table at a different database server.

The Save Data dialog box opens with three tabbed pages:

* At the General page, identify the database server, table owner, table name,
comment, and table space for the data being saved

* At the Options page, identify how to save the data
* Optional: At the ROWIDs page, specify ROWID information

Note: This command is available only when you are viewing query results.

Save to file

Select Results--> Save to File to save the query results to a file with the file
name, location, and format you specify.
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This option is available only when you are viewing query results. You can
save query results in various formats, such as .txt, .ixf, .html, .csv, .dbf, and
.Spm.

Optional: You can select a CCSID from the CCSID drop-down list if you are
exporting the query results as a .txt, .csv or .htm file. This helps ensure
operability between the exported files and other applications.

Send to

Select Results--> Send To to send the current document to the specified
application or target in your Send To: folder.

Editing tables from the query results view

You can edit tables directly from the query results view.

Deleting a row from a table
You can delete rows from tables in the query results view.
1. Run a query.
2. Select a row.
3. Select Edit--> Delete.
The row is deleted.

Updating columns in the table
You can update columns in a table from the query results view.
1. Run a query.
2. Double-click on a cell.
3. Type a new value.
4. Press Enter.
The table is updated.

Zoom
Use the Zoom option to edit a cell in the query results.
Procedure

1. Click on a cell.

2. Press Shift+F2 or click the right mouse button and select Zoom from the
context menu.

The Zoom dialog box opens.
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Fields

As is
This option displays the data as it appears in the cell in the query results.

Advanced
Click Advanced to expand the dialog box with advanced zoom/edit options.

Note: This button is disabled for cells with numeric data.

When Advanced is enabled, the Zoom dialog box expands with additional
fields to display the data in hexadecimal or binary format. The Zoom dialog
box displays samples of the data in three different formats:

e Asis
* Hexadecimal

* Binary

Hexadecimal
Select the Hexadecimal radio button to display the As is data in hexadecimal

format. You can edit the hexadecimal values in the As is or Advanced
sections of the Zoom dialog box. Changes are reflected in the As is field.

Binary

Select the Binary radio button to display the As is data in binary format. You
can edit the binary values in the As is or Advanced sections of the Zoom
dialog box. Changes are reflected in the As is field.
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Chapter 6. Reports

Overview

There are two types of reports:
* Classic reports

Character based reports that are created using forms.
* Visual Reports

Robust reports containing graphics and rich-formatted text created visually
using layout templates

You begin the process of creating either type of report with the Report
Wizard. The Report Wizard opens when you have query results in the active
window and you:

* Select Results--> Display Report from the main menu.

* Right click in the free space next to the query results, open the context
menu and select Results--> Display Report.

Using the Report Wizard

You begin the process of creating a report with the Report Wizard. The Report
Wizard helps you find the dialogs you need to create a new or open an
existing report. The process flows as follows:

1. You specify that you are creating a new report or opening an existing
report stored in a file or saved on the database server.

2. If you are opening an existing report stored in a file or saved on the
database server, the dialogs that you need to open the existing report are
presented to you. Based on your input, the Report Wizard opens the
existing report.

3. If you are creating a new report, then you specify whether you will be
creating a classic report or a visual report. Based on your input, the Report
Wizard opens the dialogs that you need to create the report.
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Table 35. Report Wizard

Field

Description

Report Wizard Type page

* Select Create a new report to create a new classic
or visual report. The Report Wizard New Report
page opens.

* Select Use an existing report stored at a server to
open an existing report that has been saved at the
database server. The Report Wizard Open from
Server page pens.

* Select Use an existing report stored at a file to open
an existing report that has been stored in a file. The
Report Wizard Open from file page opens.

Report Wizard New Report
page

* Select Create a visual report to create a new visual
report. Specify whether the new report will be
generated using the formatting that has been
applied to the current query results or very basic,
default formatting. The report opens in the Visual
Report window.

* Select Create a classic report to create aa new
classic report. Specify whether the new report will
be generated using the formatting that has been
applied to the current query results or very basic,
default formatting. The report opens.

Report Wizard Open from
Server

Specify the database server, the owner and the name
of the visual report or a form for a traditional report
that you want to open. You can use the List button to
search the database to see a list of the visual reports
or forms that are on the database server.

Report Wizard Open from file

Specify the name of the file or use the Browse button
to search for the file.

Classic Reports

Classic Reports are created by combining query results with formatting from a
form. Forms contain the formatting instructions that are applied to the query
results to create a classic report.

Create a new classic report

Follow these steps to create a new classic report:

1. Select Query--> Run to run a query and obtain query results.

2. Select Results--> Display Report from either the main menu or a context

menu.

The Report Wizard opens.
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3. Select Create a new report from the Report Wizard Type page. Select
Create a classic report from the Report Wizard New Report page.

4. Since this is a new classic report, and there is no assigned form or
formatting instructions, you must specify how the report will be
generated. You can select Generated based on the current query to
generate the report based on the way the query results currently are
formatted or you can select Default to generate the report based on a very
basic set of default formatting options. The classic report opens.

5. When the classic report opens, the Form menu becomes available. Use the
Form menu commands to specify the formatting options that you want for
the report.

6. When you have completed specifying the form formatting options that
will be applied to the query results to create a classic report, you can:

* print the report

* convert the report to a Visual Report
* convert the report to HTML

* change or update the data source

* export the report

* save the report

* save the form

Form menu

Edit
Select Form--> Edit to specify the formatting options that will be included in
the form.

Refresh from Query
Select Form--> Refresh from Query to update the report that is in the active

window.

Check
Select Form--> Check to check the form for errors and warnings.

Perform check on OK
Select Form--> Perform check on OK to validate the form automatically when

you click OK in the Form dialog box. If the form is valid, the change is
applied.

Convert to Visual Report
Select Form--> Convert to Visual Report to convert the classic report to a

visual report. QMF for Windows takes the query results used to create the
classic report and based on the formatting specified in the associated form,
creates a visual report.
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Convert to HTML form
Select Form--> Convert to HTML Form to convert the classic report to an

HTML file. When the HTML file is opened, you will see the classic report as it
was formatted using the query results and the associated form.

View in Web browser
Select Form--> View in Web Browser to view the classic report in your

default Web browser. This command is only available after you have
converted the report to HTML.

Data Source
Select Form--> Data Source to select or change the data source that is used to

create the classic report.

Set server
Select Form--> Set Server to open the Set Server dialog box to select a

database server.

Set user information
Select Form--> Set User Information to specify your user ID, password, and

optional accounting string that will be used to connect to the database server.

Set font
Select Form--> Set Font to change the display font attributes of the text you

selected or all the text in the classic report.

Display Chart
Select Form--> Display Chart to display the data source that was used to
create the classic report in a chart.

Specifying the formatting options in a Form

You specify the formatting options that are saved in the Form using the Form
window. You can open the Form window by selecting Form--> Edit. The Form
window has the following pages:

* Main

* Breaks

e Calculations
e Columns

* Conditions
e Details

* Final

« HTML

* Options

* Page
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Main
Select the Main tab on the Form dialog box to define the primary components
of a form, including form headings, footings, and breaks.

Typically, most formatting changes are made on other tabs on the Form dialog
box and the formatting attributes are reflected on the Main tab.

Num: The value in the Num field identifies the column number. This
number is used to resolve variable references, and to determine how query
result columns map to report columns.

The first column in the query results is column number 1, the second column
in the query results is column number 2, and so on.

Heading: Type the column name to be printed on the report.

Usage: Select a usage code to extract summary information about the data in
a column, such as total summary information at the end of a column, or
partial summaries at control breaks in a table.

The usage codes that are available depend on the data in the column and the
type of summary. Refer to the online help for more information about usage
codes.

Indent: Specify the number of blank spaces to the left of the column. The
range is between 0 and 999.

Width: Specify the width of column. The range is 1 and 32767.

If the column is too narrow for numeric data, it is replaced with asterisks.

If the column is too narrow for character or date/time data, it is truncated
(based on the alignment specified). To correct this, you can use a wrapping
edit code to have the data wrap within the column width.

Edit: Select an edit code to control how data is formatted in a report. Edit
codes are available for character, date, graphic, numeric, time, timestamp data.
Also, user-defined edit codes can be created. Refer to the online help for more
information about edit codes.

Seq: Specify a number to adjust the sequence of columns in the report.

If two columns have the same sequence number, they appear in the report in
column number order, defined in the Num field.
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Note: The sequence number is ignored in reports using the ACROSS usage
code or if you check the Automatic reordering of report columns?
check box on the Form Options dialog box.

Breaks
Select the Breaks tab on the Form dialog box to specify characteristics,

content, and placement of up to six subtotal lines in a report, along with
break heading text and break footing text.

1 of 6: Specify up to six break levels for the report.

New page for break: Check this check box to start a new page in the report
when the current break level starts.

Blank lines before heading: Specify the number of blank lines before the
first break heading line. The range is between 0 and 999.

Repeat detail heading: Check this check box to repeat the detail heading
with the current break level.

Blank lines after heading: Specify the number of blank lines after the last
break heading line. The range is between 0 and 999.

Alignment: Select how to align the heading text. Choices are: LEFT, RIGHT,
CENTER or APPEND (merge with heading on previous line).

Text: Type the text that appears in the break heading.

You can insert form variables into text fields to produce information on the
report based on certain conditions and where the form variables appear on

the report.

Table 36. Form Variables

Form Variable Use this variable to...

&ROW display the row number

&DATE display the current date

&TIME display the current time

&PAGE displays the current page number

&COUNT displays the number of rows retrieved or printed since
the last break at the same level

&CALCid identifies a form calculation expression to use, where
’id” is the ID number of the expression

&n displays the value of a column, where 'n’ is the column
number
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Table 36. Form Variables (continued)

Form Variable Use this variable to...

&an displays the aggregation of a column, where 'n’ is the
column number, and ‘a’ is an aggregation variable:

* AVG

* COUNT
* CPCT
- CSUM
* FIRST
* LAST
* MAX
* MIN

* PCT

* STDEV
« SUM
* TCPCT
* TPCT

The aggregation is based on the rows retrieved or
printed since the last break at the same level.

Optional: Use the Text field to specify a global variable, which is a variable set
prior to a QMF for Windows session that is in effect for the duration of the
session.

Optional: Use the Text field to an HTML variable, which formats data for

HTML presentation. You can place these variables in any section of a form:

* &IMAGEn, which places the contents of column '’ inside an HTML image
reference tag, making graphic files visible in reports.

* &LINKn, which places the contents of column 'n” inside an HTML link tag,
which is used to add links to other HTML pages.

* &MAILTOn, which places the contents of column 'n’” inside an HTML mail
to tag for an email link.

* &ANCHOR~N, which places an anchor point at the location of the variable
value. These anchors are referenced from within the report, such as the top
of the page or the beginning of a break section.

* &REFn, which places the text contained in the DSQQW_HTML_REFTXT (a
global variable, which contains text that appears in a report; the default =
"BACK TO’) into an HTML reference tag, and is used to create links to
anchors created with the &ANCHORn variable in the report.
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Hint:

Refer to the online help for a chart that explains where form variables can
appear in a report.

New page for footing: Check this check box to start a new page in the
report when the current break level ends

Blank lines before footing: Specify the number of blank lines before the first
break footing line. The range is between 0 and 999 or BOTTOM (which is
treated as a zero when producing reports in QMF for Windows).

Put summary at line: Specify the line number where the break summary is
placed vertically in the break footing lines. The range is between 1 and 999.
Specify NONE if you do not want a break summary line.

Blank lines after footing: Specify the number of blank lines after the last
footing line. The range is between 0 and 999.

Break footing text: Specify the text for the break footing:

* Line: specify the line number where the text is placed vertically in the
break footing

* Alignment: select the alignment option, which controls where the text is
placed horizontally on the line, and can be LEFT, RIGHT, CENTER,
APPEND, or the number of a specific position in the line. ’APPEND’
indicates that text is placed immediately following the previous line of text.

* Text: type the text that appears in the break footing.
Calculations
Select the Calculations tab on the Form dialog box to define report calculation

expressions.

Note: You must have IBM’s ObjectREXX installed on your machine to use
form calculations.

ID: Specify a number, between 1 and 999, that identifies the calculation
expression.

Expression: Type a valid ObjectREXX expression, up to 50 characters.
Form variables cannot be used in this field.

Pass nulls?: Specify whether to pass the expression to ObjectREXX for
evaluation when a variable in the definition has a null value.

94 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



Width: Specify the width used to format the result of the calculated
expression when used as a variable in the form.

Edit: Specify the edit code, which is used to format the result of this
calculated expression when used as a variable in the form. See the online help
for more information about Edit Codes.

Columns
Select the Columns tab on the Form dialog box to control the appearance and

formatting of columns in the report. Definable characteristics include column
heading, column usage, indentation, width, edit code, and sequence.

Num: specify the number to identify the column. This number is used to
resolve variable references, and to determine how query result columns
map to report columns.

Heading: type the text of the column heading on the report

Usage: specify a usage code to collect summary information about the data
in a column, such as total summary information at the end of a column, or
partial summaries at control breaks in a table.

The usage codes that are available depend on the data in the column and
the type of summary.

See the online help for more information about Usage Codes.

Indent: specify the number of blank spaces to indent to the left of the
column. The range is between 0 and 999.

Width: specify the width of the column. The range is between 1 and 32767.
If the column is too narrow for numeric data, it is replaced with asterisks.
If the column is too narrow for character or date/time data, it is truncated
(based on the alignment specified). To avoid this, you can use a wrapping

edit code to have the data wrap within the column width. See the online
help for more information about Edit Codes.

Edit: specify an edit code, which controls how data is formatted in a report.
Edit codes are available for character, date, graphic, numeric, time,
timestamp data. Also, user-defined edit codes can be created. See the online
help for more information on Edit Codes.

Seq: specify the sequence number for the columns in the report.

If two columns have the same sequence number, they appear in the report
in column number order, in the Num field.

Note: The sequence number is ignored in reports using the ACROSS usage

code or if you check the Automatic reordering of report columns?
check box on the Form Options dialog box.
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Conditions
Select the Conditions tab on the Form dialog box to define conditional

formatting constraints, such as suppressing records that do not meet certain
characteristics.

ID: Specify a number between 1 and 999 to identify the conditional
expression.

Expression: Type a valid ObjectREXX expression, up to 50 characters. An
expression that evaluates to 1 is considered true; anything else is considered
false.

You can use form variables in this field.

Pass nulls?: Specifies whether or not to pass the expression to ObjectREXX
for evaluation when a variable in the definition has a null value.

Details tab
Select the Details tab on the Form dialog box to define report detail headings

and body text. This is where you can combine or replace tabular data with
free-form text to create form letters or address labels.

Enable: Specify when to enable the detail variation:
* YES indicates that the variation is always selected for formatting.
* NO indicates that the variation is never selected for formatting.

You can conditionally enable the variation by referring to a Form Conditions
expression using the Cnn and Enn specifications.

Include column headings with detail heading: Check this check box to
display column headings with detail headings.

Detail heading text: Specify the lines of detail heading text:

* Line: specify where the text appears vertically in the detail heading. You do
not have to start with line 1 and you do not have to specify consecutive
line numbers.

* Alignment: specify where the text is placed horizontally on the line.

Valid alignment values are LEFT, RIGHT, CENTER, APPEND, or the
number of a specific position in the line. If you specify APPEND, the text is
placed immediately following the previous line of text.

» Text: type the text that appears in the detail heading.
You can use form variables in this field.

New page for detail block: Check this check box to start a new page in the
report for the detail block.
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Blank lines after block: Specify the number of blank lines after the last
detail block line. The range is between 0 and 999.

Repeat detail heading: Check this check box to repeat the detail heading
before each occurrence of the detail block.

Put tabular data at line: Specify where the tabular data line is placed
vertically in the detail block. The range is between 1 and 999. If you do not
want a tabular data line, specify NONE.

Keep block on page: Check this check box to keep the detail block on one
page.

If you check this check box and a detail block is too long to fit on one page,
QMF for Windows will start the detail block on a new page. If you do not
check this check box, detail blocks can split across two or more pages.

Detail block text: Specify the lines of detail block text:
* Line: this number specifies where the text is placed vertically in the detail

block. You do not have to start with line 1 and you do not have to specify
consecutive line numbers.

* Alignment: specify where the text is placed horizontally on the line. Valid
alignment values are LEFT, RIGHT, CENTER, APPEND, or the number of a
specific position in the line. If you specify APPEND, the text is placed
immediately following the previous line of text.

+ Text: type the text that appears in the detail block.

You can use form variables in this field.

Final
Select the Final tab on the Form dialog box to define the content and

placement of your report’s final text. For example, you can include final text
and summary data at the end of the report.

New page for final text: Check the New page for final text check box to
start a new report page for the final text.

Put final summary at line: Specify where the final summary line is placed
vertically in the final text lines. The range is between 1 and 999. If you do not
want a final summary line, specify NONE.

Blank lines before text: Specify the number of blank lines before the first
and final text line. The range is between 0 and 999 or the word BOTTOM,

which is treated as a zero when producing reports in QMF for Windows.

Final text: Specify the lines of final text:
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* Line: specify where the final text is placed vertically. You do not have to
start with line 1 and you do not have to specify consecutive line numbers.

* Alignment: specify where the text is placed horizontally on the line. Valid
alignment values are LEFT, RIGHT, CENTER, APPEND, or the number of a
specific position in the line. If you specify APPEND, the text is placed
immediately following the previous line of text.

 Text: type the text that appears at the bottom of the report.

HTML
Select the HTML tab on the Form dialog box to define the content and

placement of HTML tags and formatting in HTML reports.
Note: This tab is enabled only for HTML forms.

<HEAD> associated tags: Specify the HTML tags added to the <HEAD>
section of the report.

<BODY> tag extensions: Specify the HTML extensions added to the
<BODY> tag of the report.

Column heading line prefix: Specify the HTML tags that appear before each
column heading line. For example, to make a heading bold, you would place
a <B> tag here.

Column heading line suffix: Specify the HTML tags that appear after each
column heading line. For example, to close off a bold heading, you would
place a </B> tag here.

Tabular data line prefix: Specify the HTML tags that appear before each
tabular data line. For example, to make a line italic, you would place a <I>
tag here.

Tabular data line suffix: Specify the HTML tags that appear after each
tabular data line. For example, to close off an italic line, you would place a
</I> tag here.

Page separator: Specify the HTML tags that appear as a page separator. For
example, you could use a horizontal rule <HR> tag to separate pages.

Include tabular data as HTML table: Check this check box to display the
results grid in HTML format. Separate data, such as comments, are displayed
in a separate table from the HTML format table.

Save as user defaults: Check this check box to save these settings as the
default user settings for future HTML reports.
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Reset: Click Reset to reset all values in the Form HTML dialog box to their
original settings. A submenu with three options opens.

¢ User Defaults: select this option to reset values to those saved by the user

* Product Defaults: select this option to reset values to QMF for Windows
values

¢ Clear Values: select this option to resets values to spaces

Options
Select the Options tab on the Form dialog box to define miscellaneous options
that control the appearance of the report.

Detail spacing: Specify the number of lines for the spacing between tabular
data lines or detail blocks. This value must be a number between 1 and 999.

Line wrapping width: This field applies only to forms created using the ISPF
version of QMF (host QMF).

Specify the number of characters at which to wrap the columns in the report.
The range is between 0 and 999 or the word NONE.

Note: This value is ignored for reports produced in QMF for Windows.

Report text line width: For reports, specify the width of the final text, detail
heading text, detail block text, and break text in a report. The range is
between 1 and 32767, or the words DEFAULT or COLUMNS.

For DEFAULT, break footing text and final footing text use the full width of
all columns up to the first summary column. For COLUMNS, all text areas
use the full width of all columns.

Number of fixed columns in report: Specify the number of columns that
remain in place when you scroll reports horizontally on the screen or break
reports onto multiple pages when printing. The range is between 1 and 999,
or the word NONE.

Outlining for break columns: Check this check box to display the value in
columns with the BREAK usage code when the value changes.

Default break text (*): Check this check box to generate break footing text in
breaks for which you did not indicate break footing text.

The default break text consists of one asterisk for the highest numbered break

level text, two asterisks for the next-highest numbered break level text, and so
on.
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Function name in column heading when grouping: Check this check box to
add the name of the summarization function to the heading of the aggregated
columns, if a report has summarized columns and you use the GROUP usage
code to suppress the tabular data lines.

Column wrapped lines kept on a page: This field applies only to forms
created using the ISPF version of QMF (host QMF).

Check this check box to split wrapped columns between two pages, if you
specified column wrapping for one or more columns.

Note: This value is ignored for reports produced in QMF for Windows.

Across summary column: Check this check box to display the automatically
generated ACROSS summary column, which produces additional columns
that summarize (total) across the specified columns.

Automatic reordering of report columns: Check this check box to
automatically reorder the columns in a report when you specify a BREAK or
GROUP usage code, or one of the aggregating usage codes.

If selected, the columns are reordered so that BREAK columns are to the far
left, GROUP columns are to the left after BREAK columns, all non-aggregated
columns are to the left after BREAK and GROUP columns, and all aggregated
columns are to the far right.

Page renumbering at the highest break level: Check this check box if a
printed report should begin a new page beginning with the number 1
whenever the value in the control column when the highest break level
changes.

Note: The highest break level is the one with the lowest number.

Column heading separator: Check this check box to display a row of dashed
lines between the column headings and the tabular data lines.

Across heading separator: Check this check box to mark columns in
ACROSS reports with dashed lines and arrows.

Break summary separator: Check this check box to display a row of equal
signs between the tabular data lines and the break summary.

Final summary separator: Check this check box to display a row of equal
signs between the tabular data lines and the final summary.

Place LOB contents inline: Optional: Check this check box to display LOB
contents in-line in the contents of the form.
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Page
Select the Page tab on the Form dialog box to define the content and
placement of the page heading and page footing on your report.

Blank lines before heading: Specify the number of blank lines before the
first page heading line. The range is between 0 and 999.

Blank lines after heading: Specify the number of blank lines after the last
page heading line. The range is between 0 and 999.

Page heading text: Type each line of page heading text.
* Line: specify where to place the final text vertically. You do not have to
start with line 1 and you do not have to specify consecutive line numbers.

* Alignment: specify where place the text horizontally on the line. Valid
alignment values are LEFT, RIGHT, CENTER, APPEND, or the number of a
specific position in the line. If you specify APPEND, the text is placed
immediately following the previous line of text.

+ Text: type the final text that appears in the page heading on the report.

You can use form variables in this field.

Blank lines before footing: Specify the number of blank lines before the first
page footing line. The range is between 0 and 999.

Blank lines after footing: Specify the number of blank lines after the last
page footing line. The range is between 0 and 999.

Page footing text: Specify each line of text printed in the page footing at the

bottom of the page:

* Line: specify where to place the final text vertically. You do not have to
start with line 1 and you do not have to specify consecutive line numbers.

* Alignment: specify where to place the text horizontally on the line. Valid
alignment values are LEFT, RIGHT, CENTER, APPEND, or the number of a
specific position in the line. If you specify APPEND, the text is placed
immediately following the previous line of text.

* Text: type the page footing text that appears at the bottom of the report.

Saving forms

You can save the forms that are used to create a classic report on your PC, on
a file server, or at a database server. You can also choose to save forms with
or without their data source.

When you save a form, you are only saving the formatting options for a set of
query results. When you open the form, you will need to supply the query
results. That means you must run a query again and select the form in order
to create the classic report.
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You can save both the data source and the form. If you choose this option you
are saving both elements that are used to create the report. When you open a
form that has been saved with both the data source (query results) and the
form (formatting options), QMF for Windows finds the data source, runs the
query, applies the formatting from the form, and presents the report. If you
choose this option, the same data source is always used with the form.

Saving a form with the data source
To save both the data source and the form:

1. Select Form-->Data Source.
2. Check the Always use this object when opening this document check box.

3. Click OK. The Data Source window closes and you can continue working
with the form and formatting the report. When you have finished, you
save the report following the same steps as you would if you were just
saving the form.

Saving a form to a file
1. Select File--> Save.

The Save As dialog box opens if the form has not been saved.
2. Specify the name of the file and the location where it will be saved.
3. Click OK.

Opening saved form files
1. Select File--> Open.

The Open dialog box opens.
2. Select the file to open.
3. Click OK.

Saving forms at the database server
Forms saved at the server can be made accessible to other users. If you want

to share your forms with other users, save them at the database server.
1. Select File--> Save at Server.
The Save Form dialog box opens.
2. Type an owner and a name.
3. Optional: Type comments in the Comment field.

4. Optional: Check the Share object with other users check box to share the
saved form with others.

5. Optional: Check the Register the object in the Information Catalog check
box to register the object in the Information Catalog in DB2 Warehouse
Manager.

Registering the object allows the object to be listed in and launched from
the DB2 Warehouse Information Catalog.
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6. Click OK.

Opening saved forms at the database server
You can open forms that have been saved at the database server.

1. Select File--> Open from Server.
The Open From Server dialog box opens.
2. Type a server, owner, and name.
3. Optional: Click List Objects to browse for a form.
4. Click OK.

Printing forms
You can print reports.
1. Open a form.
2. Select File--> Print Report.
3. Click OK.

Exporting forms
You can export a report to a file.
1. Open a form.
2. Select File--> Export Report.
The Export Report dialog box opens.

3. Type the name of the file where you want the report stored. Forms are
exported in .txt format.

4. Click OK.

Visual Reports

Visual reports are robust reports containing graphics and rich-formatted text.
You create these reports visually using layout templates.
Create a new visual report
Follow these steps to create a new visual report:
1. Select Query--> Run to run a query and obtain query results.

2. Select Results--> Display Report from either the main menu or a context
menu.

The Report Wizard opens.

3. Select Create a new report from the Report Wizard Type page. Select
Create a visual report from the Report Wizard New Report page.

4. Since this is a new visual report you must specify how the report will be
generated. You can select Generated based on the current query to
generate the report based on the way the query results currently are
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formatted or you can select Default to generate the report based on a very
basic set of default formatting options. The Visual report window opens.

5. When the visual report opens, the Report menu becomes available. You
can use the Report menu commands to help you in designing the visual
report.

6. Using the Report--> Insert command select an element to insert in a
section of the report. Assign properties to the element.

7. When you have completed creating the visual report, you can:
* print the report
* change or update the data source
 export the report
* save the report

Working in the visual report window
The Visual Report window is divided into three sections:
* Explorer
* Design
* Properties
Visual Report Explorer

When you open a Visual Report, the Visual Report Explorer opens in the
Explorer Bar. The Visual Report Explorer is a dockable tool window that
displays in a tree structure the visual report that is active in the Design Pane.
The tree includes two main branches:

* Data Source branch displays information about the data source for the
report

* Report branch displays information about the active visual report in the
design pane.

Data Source branch
This branch of the tree displays information about the data source that is used

for the visual report. It identifies the name and location of each data item that
will be used in the report. There are three nodes in the Data Source branch:

* The Columns node which displays the column names of the data that will
be used. These are the columns names from the query results.

* The Variables node displays information identifying the variables that will
be used in the report.

* The Linked Pictures node displays information identifying the graphics
(pictures) that will be used in the report.

Report branch

This branch of the tree displays information about the active visual report that
is in the Design pane. There are three nodes in the Report branch:
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* The Embedded Pictures node displays the names of the graphic files
(pictures) that have been inserted in the report.

* The Groups node displays any grouping and aggregation that has been
specified and will be applied to the columns of the report.

* The Sections node displays information about each section of the report as
it is being designed in the design window. There are four Sections nodes:

1. The Page Heading node lists each element that has been inserted for the
page heading.

2. The Detail node lists each element that has been inserted for the report
page. There are multiple detail nodes. One for each page of the report.

3. The Report Footing node lists the elements that have been inserted for
the report footings.

4. The Page Footing node lists the elements that have been inserted for
each page footing for the report.

Visual Report design pane

You use the design pane to design the visual report. There are four sections of
the design pane each directly associated with a section of the report. The four
sections are:

* Page Heading
* Detail

* Report Footing
¢ Page Footing

Page Heading
Use this section to design the heading of each page of your report. You can

insert a picture, text, line or label in the page heading. The properties of each
element that you insert in the page heading are displayed in the Properties
pane. You can modify the elements in the page heading section directly in the
design pane or by modifying the elements properties in the Properties pane.

Detail

Use this section to design each page of your report. You can insert a picture,
text, line or label on the page The properties of each element that you insert
in the page are displayed in the Properties pane. You can modify the elements
in the page section directly in the design pane or by modifying the elements
properties in the Properties pane.

Report Footing
Use this section to design the report footing of your report. The report footing

appears at the end of the last page of your report. You can insert a picture,
text, line or label in the report footing The properties of each element that you
insert in the page are displayed in the Properties pane. You can modify the
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elements in the report footing section directly in the design pane or by
modifying the elements properties in the Properties pane.

Page Footing
Use this section to design the page footing of your report. The page footing

appears at the bottom of each page of your report. You can insert a picture,
text, line or label in the report footing The properties of each element that you
insert in the page are displayed in the Properties pane. You can modify the
elements in the page footing section directly in the design pane or by
modifying the elements properties in the Properties pane.

Visual Report properties pane
The Properties pane lists the different properties that you can apply to:
* each section of the design pane.

The sections of the design pane are Page Heading, Detail, Report Footing,
and Page Footing.

* each element that you can insert in the sections of the design pane
The elements that you can insert are Labels, Text boxes, Pictures and Lines.

You can modify the properties of the design pane sections and elements from
the Properties pane. The properties of some of the elements can also be
changed in the design pane.

Properties

Name: This property names the section of the design pane that you have
selected or the element that you have inserted in a section of the design pane.
The Name property appears for each section of the design pane and for each
type of element (label, text, picture, line) that can be inserted. You can change
the name of the section or element by typing text directly in the Name
property’s corresponding text box. The name that you type in the Name
properties text box is used to identify the design pane section or the element
in the design pane.

Visible: Use this property to show or hide a section of the design pane or an
element in a section of the design pane. The Visible property applies to
sections and for the label, text, and picture elements. Select from the drop
down menu Yes for the section or the element to appear in the design pane or
No for it to be hidden. Hiding a section or an element does not remove it
from the report.

Keep on Page: Use this property to keep a section of the design pane in the
report. The Keep on Page property only applies to the sections of the design
pane. Select from the drop down menu Yes to keep the section in the report or
No to remove the section.

106 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



Height: Use this property to increase or decrease the height of a section in
the design pane or an element in a section to the size specified. For example,
if the measure value you have selected is inches, a value of 2 will change the
size of the element to be 2 inches tall. Enter the value in the text box and click
Enter to change the size of the element. The Height property appears for each
section and the elements Label, Text box, and Picture.

Background color: Use this property to specify the color of a section in the
design pane or an element’s background. Click the browse button that is part
of the text box. A color pallet window opens where you can select the
background color. This property is available for all the sections and the
elements Label, Text box, and Picture.

Place at the end of the page: Use this property to specify that a footing be
placed at the very bottom of a page. Unless otherwise specified the footing is
placed a few lines after the detail text ends.

Left: Use this property to align the left side of the element to a specific
position in the section of the design pane. For example, if the measure value
you have selected is inches, a value of 1 will align the left side of the element
to one inch from the left hand edge of the page. Enter the value in the text
box and click Enter to move the element. The Left property appears for each
type of element (label, text, picture, line) that can be inserted.

Top: Use this property to align the top side of the element to a specific
position in the section of the design pane. For example, if the measure value
you have selected is inches, a value of 1 will align the top side of the element
to one inch from the top edge of the page. Enter the value in the text box and
click Enter to move the element. The top property appears for each type of
element (label, text, picture, line) that can be inserted.

Width: Use this property to increase or decrease the width of the element to
the size specified. For example, if the measure value you have selected is
inches, a value of 2 will change the size of the element to be 2 inches wide.
Enter the value in the text box and click Enter to change the size of the
element. The Width property appears for each type of element (label, text,
picture, line) that can be inserted.

Background Type: Use this property to specify the transparency of the
element’s background. Select from the drop down menu Opaque for the
background of the element to be solid. That means any underlying elements
will not be visible behind the top element. Select Transparent for the
background of the element to be see through. Underlying elements can then
be visible. This property is available for the elements Label, Text box, and
Picture.
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Border Type: Use this property to specify the type of border that will
surround the element. Select one line type from the drop down menu. Your
choices are Solid, for a solid line, Dash for a line of all dashes, Dot for a line
of all dots, Dash Dot for a line of alternating dashes and dots, or Dash Dot
Dot for a line that repeats the dash dot dot pattern. This property is available
for the elements Label, Text box, and Picture

Border Color: Use this property to specify the color of the border that will

surround the element. Click the browse button that is part of the text box. A
color pallet window opens where you can select the background color. This

property is available for the elements Label, Text box, and Picture.

Border Width: Use this property to specify the width of the border that will
surround the element. Select from the drop down menu Thin for the thinnest
line or a specific point of 1 to 6. This property is available for the elements
Label, Text box, and Picture.

Font: Use this property to specify the font that will be used for any text in
the report that is associated with the element. The Font window opens. This
property is available for the elements Label and Text box.

Wrap: Use this property to specify whether text will be wrapped. Select from
the drop down menu Yes for the text of the element to be wrapped around to
the next line or No for the text to be truncated if it cannot fit in the element
container This property is available for the elements Label and Text Box.

Can Grow: Use this property to specify whether the size of the element will
expand to fit the content. Select from the drop down menu Yes to allow the
element to be expandable, or No to keep the element the specified size
regardless of the content. This property is available for the elements Label and
Text box.

Outline: Use this property to specify that when there are multiple rows with
the same value, the value will only be displayed once until a break occurs or
value changes. Select from the drop down menu Yes to allow the element to
be outlined, or No to not outline. This property is available for the elements
Label and Text box.

Vertical Alignment: Use this property to specify how the text in the element
will be aligned. Select from the drop down menu Top to align the text at the
top of the element container, select Center to align the text in the center of the
element container or Bottom to align the text at the bottom of the element
container. This property is available for the elements Label and Text box.

Horizontal Alignment: Use this property to specify how the text in the
element will be aligned. Select from the drop down menu left to align the text

to the left of the element container, select Center to align the text in the center

108 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



of the element container or Right to align the text to the right of the element
container. This property is available for the elements Label and Text box.

Control: Use this property to specify that the Label element will be
associated with another element that has been defined in the section. When
associated, both elements move together. Select from the drop down menu
one of the existing elements in the section where the Label has been placed.
This property is available only for the Label element.

Caption: Use this property to specify the text for the Label element. You can
type any text in the text box. Other property specifications will effect the
amount of text that will be allowed. This property is available only for the
Label element.

Expression: Use this property to specify an expression that will be evaluated
to fill the content of this text box element. Click the browse button to open the
Expression window where you can build the expression This property is
available for the Text Box element.

Format: Use this property to specify the format of the text that appears in the
element. Click the browse button to open the Expression window where you
can build the expression This property is available for the Text Box element.

Source: Use this property to specify where a picture will be located. Click
the browse button to open Picture Source window where you specify the
location of the picture and whether it will be embedded or linked to by the
report. This property is available for the Picture element.

Stretch: Use this property to specify how the picture will be resized to fit
within the element container. Select from the drop down menu Yes to resize
the picture and change the aspect ratio. Select No to keep the picture as is, no
resizing occurs. If the picture is larger than the container then it will be
truncated. If the picture is smaller, than there will be no change. Select Zoom
to resize the picture without changing the aspect ratio. This property is
available for the Picture element.

Length: Use this property to specify the length of the line in the Line
element. Enter the value in the text box and click Enter to change the length
of the line. The length property only applies to the Line element.

Orientation: Use this property to specify the orientation of the line. Select
from the drop down menu Vertical to position the line from the top of the
page to the bottom of the page. Select Horizontal to position the line from one
side of the page to the other side. This property is available only for the Line
element.
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Style: Use this property to specify the style of the line. Select one line type
from the drop down menu. Your choices are Solid, for a solid line, Dash for a
line of all dashes, Dot for a line of all dots, Dash Dot for a line of alternating
dashes and dots, or Dash Dot Dot for a line that repeats the dash dot dot
pattern. This property is available only for the Line element.

Color: Use this property to specify the color of the line. Click the browse
button that is part of the text box. A color pallet window opens where you
can select the background color. This property is available only for the Line
element.

Inserting elements in the visual report
First Paragraph
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Chapter 7. Visualizing data

There are three ways of visualizing data:
* Simple Charts

* Spatial Maps

* Complex Visuals

Simple Charts

Select Results--> Display chart to define the layout for the chart being created
from the query results.

Overview

You can display query results in a graphical format using Lotus 1-2-3 or
Microsoft Excel for charting, or view them in a browser.

The Java charting component is installed with QMF for Windows; however,
you need to install the Microsoft Excel or Lotus 1-2-3 application separately to
display charts. You can use the charting application to further customize your
chart after it is created by QMF for Windows.

Charts have a standard set of characteristics, regardless of the application
used to create and display them:

* A horizontal line displays along the bottom of the chart. This is the
Category axis, also known as the X-axis.

Values of any data type, taken from one or more columns in the query
results or report, are plotted along the X-axis.

* There is a vertical line along the left of the chart. This is known as the
Value axis, also known as the Y-axis.

Numeric values, that are taken from one or more columns in the query
results, are plotted along the Y-axis.

Labels can be defined for the X- and Y-axes to describe the plotted values. A
legend is displayed on the side of the chart. It contains the column headings
for each column plotted on the Y-axis. A chart title displays above the chart.

Charting rules
The following conditions apply when creating charts from query results or

from a report:
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1. If the query results or report used to create the chart contains group or
break columns, the columns will appear on the X-axis of the chart;
otherwise, the first column on the left appears on the X-axis.

2. The remaining columns with numeric data types appear on the Y-axis.

Table 37. Chart elements

If there are
none, use the
first column.

Category axis | Value axis
columns columns Legend Title

Query Results | All group All remaining | Value axis Value specified
columns. numeric column on the Chart

columns headings Options dialog

If there are box
none, use the
first column.

Report All BREAK or |All remaining | Value axis FORM.PAGE
GROUP numeric column names | heading text or
columns. columns the value

specified on the
Chart Options
dialog box

Chart options

Purpose

Select Results--> Display chart to define graphical attributes for charts
created from query results or reports.

Procedure

1. Run the query or procedure.
2. Select Results--> Display Chart.
The Chart Options dialog box opens.

3. Select the charting application from the Application drop-down menu.

Supported applications include:

* Java

e Lotus 1-2-3, Version 97 or later

e Microsoft Excel, Version 7.0 or later

4. Select the type of spreadsheet to create from the Type drop-down menu.

Supported types include:

* Area

* Area (Stacked Percentage)
* Area (Stacked)

* Bar
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* Bar (Stacked Percentage)

* Bar (Stacked)

e Column

* Column (Stacked Percentage)
* Column (Stacked)

* Line

* Line (Stacked Percentage)

* Line (Stacked)

e Line (Stacked) With Markers
* Line (With Markers)

* Pie

* Scatter

Note: The Java chart application does not support all available chart
types. If you select an unsupported chart type, the closest
supported type will be substituted automatically.

. Select the source for the title of the chart. Select one of the following
options:
a. Select the Report page heading radio button if you are creating a

chart from a report (not directly from the query results). This option
uses the report page heading as the chart title, by default.

Note: This option is not available if you are creating a chart from the
query results.

b. Select the Text radio button to type the text of the report title.
. Type a label in the Category (X) axis field.

This is the label for the horizontal axis on the report. This setting will not
affect which columns will appear on the Category axis; all group or break
columns will be used, or the first column will be used if there are no
group or break columns.

. Type a label in the Value (Y) axis field.

This is the label for the vertical axis on the report. This setting does not
affect which columns will appear on the Value axis; all columns with a
numeric data type that do not appear on the Category axis will be used.

. Use the Left, Top, Width, and Height fields to define the attributes of the
chart.

. In the Units drop-down list, select the unit type to correspond with the
chart dimensions.

Options are:

¢ Centimeters
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¢ Inches
* Percentage of screen size
10. Click OK.
The exported chart data displays in a browser or spreadsheet application
using the chart attributes defined here.
Axes

Use the Chart -->Axes window to define which columns in the query results
are plotted on the Category (X) and Value (Y) axes in a chart.

Procedure
1. Click Axes on the Chart Options dialog box.

The Chart Axes dialog box opens.
2. Select a column to plot on the chart from the Available columns list box.

3. Click Add to add the column to the Category (X) axis pane or Value (Y)
axis pane.

This column will be plotted on the chart.

4. Optional: Select a column from the Category (X) axis pane or Value (Y)
axis pane and click Remove.

This column will not be plotted on the chart.
5. Optional: Use the Up and Down arrows to order the values on the axes.
6. Click OK.

You return to the Chart Options dialog box.

Spatial maps

Purpose

Select File -->New --> Map to visualize query results in the map form using a
map application.

The Map option enables you to view data from DB2 in a map rather than
through conventional means such as in a chart, report, or browser. Only tables
having a column with type of GEO can be rendered as a map in QMF for
Windows.

The maps, composed of layers of spatial data, enable you to visualize
connections between tables, such as the geographic distribution of customers
for a branch of a bank. Rather than submitting a query and creating a report,
you can specify the layers (for example, a branch layer and a customer layer)
and view the clustering.

Two things happen when you select the Map option:
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1. Information will be gathered for the location, shape of, and relationships
among business data and geographic data, including map data.

2. This information will be stored in industry standard files known as shape
files (.spm).

With shape files, spatial data can be interchanged with other applications or
databases that recognize this format.

An error message will be sent if the Map option is selected for a table that
does not contain Geo data.

Complex visuals

Use the Layout Wizard to display query result data in a variety of complex
visual formats.

With query results in the active window, you can open the Layout Wizard:
* Select Results --> Display Layout
* Select File -->New --> Layout

Layout Wizard
The Layout Wizard helps you build complex visuals in a four step process:
1. Step 1

From the Layout Wizard Step 1 window, select the type of layout that you
want to use for your data. The types of layouts are listed in the Category
list box. Each layout Category has several different styles. The styles that
are available for the category are listed in the Styles list box. You can
choose from the following: categories:

¢ Chart

Pie Chart, Bar Chart, Column Chart, Scatter Chart, XY Chart, Stock
Chart, Candlestick Chart, Timeline Chart, Event Band Chart and
Multivariate Chart

* Hierarchy
Cluster Graph, Organization Chart, and Tree Chart
* Map
Linear
e Pattern
Spiral and Horizon
2. Click Next. The Layout Wizard Step 2 window opens.
3. Step 2

From the Layouts Wizards Step 2 window you specify the dimensions of
the layout that you have selected. You must specify the width of the
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layout in the Width field, and the height in the Height field. If you are
creating a pie chart you specify the Radius. Optionally you can specify a
title in the Title field.

4. Click Next. The Layout Wizard Step 3 window opens.
5. Step 3

From the Layouts Wizards Step 3 window you specify the parameters that
pertain to specific types of layouts. The fields that are displayed are
different for each type of chart or layout that you select. For information
on the fields refer to the QMF for Windows online help.

6. Click Next. Next is available only if there is a step 4. Not all layouts
require a step 4. The Layout Wizard Step 4 window opens.

7. Step 4

The fields that you specify in Step 4 different for each type of chart or
layout that you select. For information on the fields refer to the QMF for
Windows online help.

8. Click Finish.
The Layout Wizard completes its processing. The query results that you
specified as the data source are displayed in the layout that you selected.
format.
Working with the finished layout
There are many things you can do with the finished layout:
* Print the layout

Right click on the layout and from the context menu, select Print. You can
also select Results --> Print.

» Edit the Layout

* Change the data source

* Refresh the contents

 Edit the layout using QMF Visionary studio

* Move the layout around in the window using the Select, Grab, Pan and
Center commands.

* Using the View menu, you can change your view of the layout with the
Zoom in and out commands.
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Chapter 8. Procedures

You can create, edit, and run procedures from QMF for Windows. Procedures
are sets of commands that enable you to run queries, print reports, import
and export data, as well as perform other functions with a single RUN
command.

You can store procedures at the database server or save procedures to a local
file or on a file server. All commands issued through procedures are governed
by your resource limits.

About procedures

A procedure is a QMF for Windows object that contains procedure commands
instead of SQL commands. While SQL manipulates data, procedure
commands manipulate QMF objects (tables, queries, forms, and even other
procedures). Procedures automate actions that are typically accomplished by
clicking buttons and making menu selections.

You can use a procedure to list a set of queries to be run, data to be saved,
reports to be created, for example, and to run them all at once. Procedures can
take advantage of sophisticated data and object management.

Procedures are sets of commands used to:
° run queries

* print reports

* import data

* export data

* perform other functions

QMEF for Windows procedures differ from IBM ObjectREXX procedures, which
handle simple and complex calculations, logic, column definitions, detail
variations, and conditions in QMF for Windows. IBM ObjectREXX is required
to use REXX calculations. Refer to[“Calculations” on page 139| for more
information.

Procedure menu

Run
Select Procedure--> Run to run the active procedure.
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Close all result windows

Select Procedure--> Close all result windows to close all result windows
generated by the procedure when the procedure ends.

Close intermediate result windows

Select Procedure--> Close intermediate result windows to suppress all result
windows while the procedure is running and display result windows only
when the procedure ends.

Uppercase

Select Procedure--> Uppercase to format the procedure in uppercase text. The
font attribute will remain in uppercase until you de-select this option.

Note: Existing text will not be reformatted into uppercase, even if you
highlight the text then select the Uppercase option.

Comment

Select Procedure--> Comment to comment out a line in a procedure. For
example, you can comment out a line that describes a part of the procedure.
The commented text will not be included when the procedure runs.

This option inserts two dashes (--) at the beginning of a commented line. The
text after the dashes will be ignored when the procedure runs.

The last line will be ignored in the example below:

SET GLOBAL (DSQQW_RPT_USE_PS=0 DSQQW_RPT_FONT=TERMINAL,
+DSQQW_RPT_FONT SZ=5, DSQQW_RPT ORIENT=1

RUN QUERY YEAREND.ACCT

PRINT REPORT

--USE EOY FORM ONLY

Uncomment

Select Procedure--> Uncomment to remove the dashes from the commented
line or lines. Once you uncomment a line, it will be read when the procedure
runs.

This option removes the comment (two dashes) from the beginning of a
commented line in the procedure. For example,

SET GLOBAL (DSQQW_RPT_USE_PS=0 DSQQW_RPT_FONT=TERMINAL,
+DSQQW_RPT_FONT SZ=5, DSQQW_RPT ORIENT=1

RUN QUERY YEAREND.ACCT

PRINT REPORT

USE EOY FORM ONLY

Set server

Select Procedure--> Set server to select the database server for running the
procedure.
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Set user information

Select Procedure--> Set user information to set the database server user ID,
password, and optional accounting string for the procedure.

Set font
Select Procedure--> Set font to change the font style for the selection.

Creating a procedure

Creating procedures

Select File--> New--> Procedure to create a procedure. A new procedure
query document opens. Write the procedure, then select Procedure--> Run to
submit the procedure.

Running the procedure at a database server

1. Open a new procedure document and type a set of commands, or open an
existing procedure from a file or the database server.

2. Select Procedure--> Run.

Saving procedures

You can save procedures on your PC, on a file server, or at a database server.

Saving procedures to files
1. From an open procedure, select File--> Save.
The Save As dialog box opens if the procedure has not been saved.
2. Type the name of the file where you want the procedure stored.
3. Click OK.

The procedure is saved.

Opening a saved procedure file
1. Click File--> Open.
The Open dialog box opens.
2. Select the procedure file to open.
3. Click OK.
The selected procedure opens in a new procedure document.
Saving a procedure to the database server
1. Open a procedure.
2. Select File--> Save at server.
The Save Procedure dialog box opens.

3. Type an owner and a name.
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8.

Check the Specify whether to share the saved procedure with other users.
Optional: Type a comment.

Optional: Check the Share the object with other users check box to enable
other uses to use the procedure.

Optional: Check the Register the object in the Information Catalog check
box to register the object in the Information Catalog.

When checked, the object is registered with the Information Catalog in
DB2 Warehouse Manager.

Click OK.

Opening saved procedures at the database server
You can open procedures that have been saved at the database server.

1.

Click File--> Open from Server.

The Open From Server dialog box opens.
Type a server, owner, and name.

Click OK.

Printing procedures

You can print the text of a procedure.

Previewing a procedure
1. Open a procedure.

The procedure commands appear.

2. Select File--> Print Preview.

Printing a procedure
1. Open a procedure.

The procedure commands appear.

2. Select File--> Print.

Procedure reference

Line continuation

If a command extends over multiple lines, type a plus sign (+) as a
continuation character in the first column of each additional line.

Comments
Enter two hyphens (--) at the beginning of a line in a procedure to include
comments. All text following the hyphens through the end of the line is
commented and is not interpreted by QMF for Windows.
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Substitution variables

You can use substitution variables to parameterize a procedure. Each time you
submit a procedure, it is scanned for substitution variables. You need to
provide values for all substitution variables before you run the procedure.
Values for substitution variables can come from:

a RUN PROC command
global variables
the Enter Substitution Variables dialog box

The Enter Substitution Variables Values dialog box opens when you run a
dynamic query that contains substitution variables. Use this dialog box to
provide values for these substitution variables. QMF for Windows
substitutes the values into the query and then sends the query request to
the database server.

Provide the following information at the Enter Substitution Variables Values
dialog box:

— Name

The name of the substitution variable. You cannot modify the variable
name.

— Value

The value to use for this substitution variable. QMF for Windows
substitutes the value for each variable in the SQL statement before it
sends the statement to the database server.

Note: Enclose character values in quotation marks.

Current objects

Many procedure commands operate on named objects in the database or
current objects in temporary storage.

Current query object: The current query object is the most recently
activated SQL or prompted query document.

Current form object: The current form object is the most recently activated
form document.

Current procedure object: The current procedure object is the most recently
activated procedure document.

Current report object: The current report object is a synonym for the
current form object.

Current data object: The current data object is the most recently activated
SQL or prompted query document with query results.
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Reading syntax diagrams

The procedure command syntax diagrams are read from left to right, top to
bottom. Each command starts with ">>" and ends with "<<". If a command is
continued from one line to the next, the first line ends with ">" and the next
line begins with ">".

A command can have two types of parameters:

1. Positional parameters, which must be placed in a certain position within a
command.

2. Keyword parameters, which are assigned a value and can be placed in
any order within a command.

The first keyword parameter used in a command must be preceded by a
left parenthesis.

All parameters must be 80 characters or less. All parameters are separated
by commas. A right parenthesis is not required, but can be used to end the
command.

Required parameters
Parameters are on the main path if they are required.
>>-- CONNECT TO ServerName =-------— oo oo oo <<

When one parameter is on the main path with others listed below, you must
choose at least one from the list.

>>-= DISPLAY === QUERY === mmmmm s oo oo <<
+- FORM ---+
+- PROC ---+
+- REPORT -+

Optional parameters

When a parameter is shown below the main path, it is optional. When all
parameters are shown in a list below the main path, you can specify a single
parameter or none at all.
>>-- ERASE ------ommmm ObjectName ==-==c-mmmmm oo <<
+- QUERY -+
+- FORM --+
+- PROC --+
+- TABLE -+

Sometimes two values are separated by a forward slash (/). This indicates
that one of the two values must be entered:

+- ( CONFIRM = YES/NO -+
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Procedure commands
BOTTOM command

The BOTTOM command scrolls to the last row of a query result set. This
command is equivalent to the FORWARD MAX command.

Syntax
>>c o BOTTOM == o m o m e e e e e e <<

CONNECT command

The CONNECT command will establish a connection to a database server.
Subsequent procedure commands will run at the specified server. The running
procedure’s server will also be changed to the specified server. No immediate
action is taken upon any other current objects within the procedure. However,
subsequent commands which affect those objects may result in additional
processing.

Example
Assume query Q1 has been run but not completed at server X. The CONNECT

TO "SERVER Y' command is then issued, connecting to server Y. Next, the SAVE
DATA AS T1 command is issued.

Query Q1 is not immediately affected by the CONNECT command to server Y,
but the SAVE DATA command requires completion (or cancellation) of query Q1
at server X. Once the data object is completed, the server for query Q1 is
changed to Y, and the data is saved in table T1 at server Y.

Syntax
>>-- CONNECT TO ServerName -----------mmmmm oo oo <<

Parameters
Table 38. CONNECT Command Parameter

Parameter Description

ServerName The name of a database server.
Note: Enclose the server name in quotes if the name
includes spaces.

Example
CONNECT TO SERVERI1

CONVERT command

The CONVERT command will convert a prompted query to a new SQL query.
The original query (whether a named object in the database or a temporary
object) is unaffected by this operation.
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Syntax
For a target object in the database:

>>-- CONVERT -------omoomn QueryName ==------mcmme e <<
+- QUERY -+

For a temporary target object:
>>-- CONVERT QUERY ===m=mmm e e e e e e e e e e e e e e <<

Example
CONVERT QUERY

DISPLAY command

The DISPLAY command will display an object in temporary storage or an
existing object that was saved in the database. DISPLAY for an object in
temporary storage will act only upon the current object; there is no way to
DISPLAY an object from temporary storage that is not the current object.

For example, consider the following procedure:
DISPLAY QUERY Q1

DISPLAY QUERY Q2

DISPLAY FORM F1

DISPLAY QUERY

After this procedure runs, query Q2 is the active window, and is the current
query object. Query Q1 is inaccessible from any command accessing
temporary storage. F1 is the current form object and is accessible from a
command accessing the current form object in temporary storage. For
example, DISPLAY FORM would display F1.

Syntax
For a target object in the database:

>>-- DISPLAY ------ommmm- ObjectName =—---===-—-mmmm - <<
+- QUERY -+
+- FORM --+
+- PROC --+
+- TABLE -+

For a temporary target object:

>>== DISPLAY === QUERY === oo oo e e e e e e <<
+- FORM ---+
+- PROC ---+
+- REPORT -+

Example

DISPLAY QUERY USER1.QUERY1
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DRAW command

The DRAW command creates a basic query for a table based on the description
of the table in the database.

Syntax
>>-- DRAW TabTeName === oo e e e e e e <<
+- ( === TYPE = --- SELECT ----- +
+- INSERT -+
+- UPDATE -+
+- IDENTIFIER = CorrName -+
Parameters
Table 39. DRAW Command Parameters
Parameter Description
TableName The name of the table for which to create a query.
TYPE Specifies the type of SQL query to create. The default is
SELECT.
IDENTIFIER Specifies the correlation name to be associated with the table
in the resulting query. It is ignored when TYPE=INSERT. There
is no default.

Example
DRAW Q.STAFF (TYPE=SELECT

ERASE command

The ERASE command removes a query, form, procedure, or table from the
database.

Syntax

>>-- ERASE ------mmmmme- ObjectName —--==--- - m oo e <<
+- QUERY -+ +- ( CONFIRM = YES/NO -+

+- TABLE -+

Parameters
Table 40. ERASE Command Parameters

Parameter Description

ObjectName The name of the object to remove from the database.

CONFIRM Specifies whether or not to display a confirmation dialog
before removing the object. If CONFIRM is not specified or
is NO, the corresponding resource limit is used.

Chapter 8. Procedures 125




Example
ERASE QUERY USERI1.QUERY1

EXPORT command
The EXPORT command copies objects from the database or temporary storage

to a file.

Syntax

For a target object in the database:

>>-- EXPORT --- QUERY --- ObjectName TO FileName --------=---—-—---oo--- <<
+- PROC --+ +- ( CONFIRM = YES/NO -+

>>-- EXPORT FORM ObjectName TO FileName ---------=--mmmmmmmmm oo >

D e e e e e e <<

+- ( --- CONFIRM = YES/NO =--=-=--=-- +

+- LANGUAGE = ENGLISH/SESSION -+

>>-- EXPORT TABLE ObjectName TO FileName -----=---=mmmmmmmmmm oo >
+- ( --- CONFIRM = YES/NO -+
+- DATAFORMAT = IXF -+

For a temporary target object:

>>-- EXPORT --- QUERY --- TO FileName =-=-==--—c-cmmmm e - <<
+- PROC --+ +- ( CONFIRM = YES/NO -+
>>-- EXPORT FORM TO FileName =====m=mmmmm oo oo m oo <<
+- ( --- CONFIRM = YES/NO -----=----- +

+- LANGUAGE = ENGLISH/SESSION -+

>>-- EXPORT DATA TO FileName ===-===== - <<
+- ( --- CONFIRM = YES/NO -+
+- DATAFORMAT = QMF/IXF/TEXT/HTML/CSV -+
+- QUTPUTMODE = BINARY/CHARACTER/PC -+
+- LOBSINFILE = YES/NO -+
+- LOBSTO = pathl;path2; -+
+- LOBFILE = basefilel;basefile2; -+

>>-- EXPORT REPORT TO FileName =---=-==-m=mmmmmmmmmmmmmmmomooomme e <<
+- ( --- CONFIRM = YES/NO --+
+- DATAFORMAT = QMF/HTML/TEXT -+
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Parameters

Table 41. EXPORT Command Parameters

Parameter

Description

ObjectName

The name of the object to export from the database.

FileName

The name of the file to which to export the object.

CONFIRM

Specifies whether or not to display a confirmation dialog
before replacing an existing file. If CONFIRM is not
specified or is NO, the corresponding resource limit is used.

LANGUAGE

Specifies whether a form is exported in English or in the
current session language. A form that is exported in English
can be run in any NLF session. A form exported in the
session language can only be run in a session of the same
language. The default value is provided by the
DSQEC_FORM_LANG global variable.

DATAFORMAT

Specifies the file format of the exported data. If you omit
this parameter, the DSQQW_EXP_DT_FRMT global variable
supplies the format to be used.

The file format can be:
* 0 = Text format

e 2 = HTML format

* 3 =CSV format

* 4 = [FX format

If you specify IXF, the DSQQW_EXP_OUT_MDE global
variable can be set to either ’0” for character mode
System /370 IXF or "1 for PC/IXF.

For Reports

QMEF format is not supported in the Windows environment.
HTML format adds the <PRE> tag. TEXT is for a text-based
file.

OUTPUTMODE

Specifies the output format of the data.

LOBSINFILE

Specifies whether or not LOBs are included in the exported
data.

LOBSTO

Specifies the location to save the LOBs.

LOBSFILE

Specifies the base name of the exported LOBs.

Example

EXPORT QUERY USER1.QUERY TO C:\Queries\queryl.qry
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FORWARD command

The FORWARD command scrolls forward in a query result set. MAX is the only
acceptable parameter for this command, making it equivalent to the BOTTOM
command.

Syntax
>>== FORWARD MAX == mm oo e e eecem e mcmmemeeas <<

Example
FORWARD MAX

IMPORT command

The IMPORT command copies data from a file into temporary storage or to the
database.

Syntax
For a target object in the database:

>>-- IMPORT --- QUERY --- ObjectName FROM FileName --------------ccocouuon >
+- PROC --+

+- ( --- CONFIRM = YES/NO ---+
+- COMMENT = Text ---+
+- SHARE = YES/NO ---+

>>-- IMPORT FORM ObjectName FROM FileName -----------cmmmmmmmmmmmmmm oo >
D e e e e <<
+- ( --- CONFIRM = YES/NO ------------- +
+- COMMENT = Text ------------- +
+- LANGUAGE = ENGLISH/SESSION -+
+- SHARE = YES/NO -----cc-eaann +
>>-- IMPORT TABLE ObjectName FROM FileName --=--=--===---ommmmmmmmmmmm oo >
P e e e e e e <<
+- ( --- CONFIRM = YES/NO ----=----- +
+- COMMENT = Text ---------- +

+- ACTION = REPLACE/APPEND -+

For a temporary target object:

>>-- IMPORT --- QUERY --- FROM FileName =--===-=mo- oo <<
+- PROC --+
+- FORM --+
+- DATA --+

+- LOBSFROM = pathl;path2; -+
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Parameters
Table 42. IMPORT Command Parameters

Parameter Description

ObjectName The name of the object to import into the database.
FileName The name of the file from which to import the object.
CONFIRM Specifies whether to display a confirmation dialog before

replacing an existing object. If CONFIRM is not specified or is
set to NO, the corresponding resource limit is used.

COMMENT Specifies a comment with the imported object. Enclose the
text in quotes.

SHARE Specifies whether or not other users are allowed to use the
imported object.

LANGUAGE Specifies whether a form is imported in English or in the
current session language. A form that is imported in English
can be run in any NLF session. A form that is imported in
the session language can only be run in a session of the
same language. The default value is provided by the
DSQEC_FORM_LANG global variable.

ACTION Specifies whether or not to replace the entire database table
or append data to the existing table.

LOBSFROM Specifies the location of the LOB.

Example

IMPORT QUERY FROM C:\Queries\queryl.qry

PRINT command

The PRINT command prints a copy of an object in temporary storage or from
the database.

Syntax
For a target object from the database:

>>-- PRINT --------mmm-- ObjectName =-=-=-=-—-—m oo <<
+- QUERY -+ +- PRINTER = Printer -+

+- TABLE -+

For a temporary target object:

>-= PRINT === QUERY ==mmmm oo oo e e o e e e e e e - <<
+- PROC --+ +- PRINTER = Printer -+
+- TABLE -+

>>-— PRINT REPORT === mmm oo oo o e oo e <<
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P e e e T e <<
+- ( --- DATETIME = YES/NO =--n-mmnmm- +
+- PAGENO = YES/NO ---=-----=-- +
+- PRINTER = Printer ---------- +
+- FORM = ==~ FORM ---=--oo-- +
+- FormName -------- +
+- COPIES = NumChars ---------- +
+- TYPEFACE = Fontname -------- +
+- SIZE = NumChars ------------ +
+- BOLD = YES/NO =----=-nmmomn- +
+- ITALIC = YES/NQ =-mmmmmmmmmm +
+- CHARSET = ANSI/DEFAULTS/SYMBOL/SHIFTJIIS/GB2312/ ------- +
HANGUEL/CHINESEBIG5/0EM/JOHAB/HEBREW/ -------- +
ARABIC/GREEK/TURKISH/THAI/EASTEUROPE/ --=----- +
RUSSTAN/MAC/BALTIC/ ==-==mmm e +
+- ORIENTATION = PORTRAIT/LANDSCAPE =-mmmmmmmmmmmmm e e +
+- USEFORMPS = YES/NQ ---------- +
+- LENGTH = NumChars/CONT/AUTO -+
+= CONT ---mmmmmmme +
+- WIDTH = NumChars/CONT/AUTO --+

Parameters

Table 43. PRINT Command Parameters

Parameter Description

ObjectName The name of the object to print.

DATETIME Specifies whether or not to include the current date and
time in the page footing. When you print a report, the date
and time are printed in the page footing unless you specify
DATETIME=NO or include the &DATE or &TIME variables in the
page text in the form. If included, the date and time are
formatted according to the current Windows regional
settings.

PAGENO Specifies whether or not to include page numbers in the
page footing. When you print a report, page numbers are
printed in the page footing unless you specify PAGENO=NO or
include the &PAGE variable in the page text in the form.

PRINTER Specifies the name of the printer on which to print the object
or report.

FORM Specifies which form to use when generating the report. You
can specify the keyword FORM to use the current form
object, or specify the name of a form saved in the database.

COPIES Specifies the number of copies to print when printing the
object.

TYPEFACE Specifies the font typeface to use when printing the object.

SIZE Specifies the font size to use when printing the object.
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Table 43. PRINT Command Parameters (continued)

Parameter

Description

BOLD

Specifies whether or not to use bold text when printing the
object.

ITALIC

Specifies whether or not to use italic text when printing the
object.

CHARSET

Specifies the character set to use when printing the object.

ORIENTATION

Specifies the paper orientation of the printed object.

USEFORMPS

Specifies whether or not to use the Windows form
associated with the object.

LENGTH

Specifies the LENGTH of the printed object, which is one of
the following:

* The maximum number of lines to print on each page
(from 1 to 999)

* CONT (to cause continuous printing without page breaks)

* AUTO

If LENGTH is omitted, the values of the DSQQW_RPT_LEN_TYP
and DSQQW_RPT_NUM_LINES global variables are used.

WIDTH

Specifies the WIDTH of the printed object, which is one of
the following:

* The maximum number of characters to print on each line
(from 1 to 999)

* CONT (to cause continuous printing without page breaks)

* AUTO

When you print a report, lines longer than WIDTH are
formatted on a subsequent page.

Example
PRINT QUERY

PRINT REPORT (LENGTH=60, DATETIME=NO

RESET GLOBAL ALL command

The RESET GLOBAL ALL command deletes the names and values of global
variables that have been set using the SET GLOBAL command.

Syntax
>>-- RESET GLOBAL (Variablel, Variable2 ... =----m-mmmmmmommomamaen <<
or

>>-- RESET GLOBAL ALL
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Parameters

Table 44. RESET GLOBAL ALL Command Parameters

Parameter

Description

VariableName

Specifies the names of the variables to be deleted. You can
name up to 10 variables previously set by the SET GLOBAL
command.

ALL deletes the names and values of all variables previously
set by the SET GLOBAL command. Even if you do not have
several global variables defined, or you do not remember
the names of your global variables, you can use this
parameter to reset all global variables at one time.

Variables prefixed with DSQ are restricted, and cannot be
deleted.

Note: You can use global variables in queries, procedures,
and forms, but not in the DB2 Table Editor.

When you issue the RESET GLOBAL ? command, you are
prompted to fill in the names of the variables you want to
reset.

On the Global Variable List dialog, you can reset a variable
by positioning your cursor on the line you want to delete
and pressing Delete.

For example, to delete the values for all global variables that
were previously set, type:

RESET GLOBAL ALL

To delete the values only for the variables named DEPT and
LOCATION, type:

RESET GLOBAL (DEPT LOCATION

Example

RESET GLOBAL (Variablel, Variable2

or

RESET GLOBAL ALL

RUN command

The RUN command executes procedures or queries from temporary storage or

from the database.

Syntax

To run a target object from the database:

132 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere




*+- QUERY -+ +- ( --- 8&Variable = Value ----+
+- CONFIRM = YES/NO ------ +
+ FORM = =-= FORM —--c=o- N

+- FormName -+
+- ROWLIMIT = NumRows----- +

To run a temporary target object:

>>-— RUN QUERY === mm e e e e e e e e - <<
+- ( --- &&Variable = Value ----+
+- CONFIRM = YES/NO ------ +
+- FORM = --- FORM ------- +

+- FormName -+ |
+- ROWLIMIT = NumRows/NO -+

>>-= RUN PROC == ==mmmmmmm e e e e e e e e e e e e e <<
+- ( &&Variable = Value ... -+

Parameters
Table 45. RUN Command Parameters

Parameter Description
ObjectName The name of the query or procedure to run.
&&Variable Assigns a value to a variable in the query or procedure that

is being run. The variable name can be from 1 to 17
characters long and the value can be from 1 to 55 characters
long. You can specify any number of variables and values
on the RUN command.

You will be prompted to provide values for each variable in
the query or procedure if you did not provide values on the
RUN command, and the variable was not a global variable.

Once a global variable is set, the variable can be used for an
entire QMF for Windows session. A global variable can be
used in a query, form, or procedure.

When you include variable assignments in a procedure, you
must use two ampersands (&&) to prevent variable
substitution before the procedure is run.

CONFIRM Specifies whether or not to display a confirmation dialog
before replacing or changing an object as a result of this
command. If CONFIRM is not specified or is set to NO, the
corresponding resource limit is used.
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Table 45. RUN Command Parameters (continued)

Parameter Description

FORM Specifies a form to use when generating a displayed report
using the data retrieved by the query. You can specify the
keyword FORM to use the current form object, or specify the
name of a form saved in the database.

ROWLIMIT Specifies the maximum number of rows to retrieve for the
query.

Example
RUNQUERY USER1.QUERY1 (&&Varl=10
SAVE command

The SAVE command stores the contents of an object in temporary storage into
the database.

Syntax
>>-- SAVE --- QUERY --- AS ObjectName ----------oommmmmm oo <<
+- PROC --+ +- ( --- COMMENT = Text ---+
+- CONFIRM = YES/NO -+
+- SHARE = YES/NO ---+
>>-- SAVE FORM AS ObjectName ------=--ommm oo <<
4= (=== COMMENT = Text =-----=--=-n= +
+- CONFIRM = YES/NO ----------- +
+- SHARE = YES/NO ---------m-m-- +
+- LANGUAGE = ENGLISH/SESSION -+
>>-- SAVE DATA AS TableName -------—-mmmmmm oo <<
+- ( --- COMMENT = Text ---------- +
+- CONFIRM = YES/NO -------- +
+- METHOD = REGULAR/FAST -------- +
+- SCOPE = NumChars -------- +
+- ROWIDADD = YES/NO -------- +
+- ROWIDNAME = Text --------- +
+- ROWIDDISP = ALWAYS/BYDEFAULT -------- +
+- ROWIDDISPnnn = EXCLUDE/CONVERT/ALWAYS/BYDEFAULT+
+- ACTION = REPLACE/APPEND -+
Parameters

Table 46. SAVE Command Parameters

Parameter Description

ObjectName The name to assign to the object (query, form, procedure, or
table) when it is saved.
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Table 46. SAVE Command Parameters (continued)

Parameter Description

COMMENT Specifies a comment with the saved object. Enclose the text
in quotes.

CONFIRM Specifies whether or not to display a confirmation dialog
before replacing or changing an object as a result of this
command. If CONFIRM is not specified or is set to NO, the
corresponding resource limit is used.

SHARE Specifies whether or not other users are allowed to use the
saved object.

LANGUAGE Specifies whether or not a form is saved in English or in the
current session language. A form that is saved in English
can be run in any NLF session. A form that is saved in the
session language can only be run in a session of the same
language. The default value is provided by the
DSQEC_FORM_LANG global variable.

METHOD Specifies the method of saving the data.

* Regular save: Sends data from the client back to the
database server to be inserted into the table.

* Fast saved: Reruns the query at the server and inserts the
results directly into the table.

SCOPE Specifies the commit scope of the data.

ROWIDADD Specifies whether or not to add the Row ID column to the
table.

ROWIDNAME Specifies the name to assign to the new Row ID column.

ROWIDDISP Specifies the disposition of the new Row ID column.

ROWIDDISPnnn Specifies the disposition of existing Row ID columns.

ACTION Specifies whether or not to replace the entire database table
or append data to the existing table.

Example

SAVE QUERY AS USER1.QUERY1 (CONFIRM=NO

SEND TO command

The SEND TO command exports reports and data from the database or
temporary storage and sends the reports and data to the specified target or
application in your Send To folder.

Syntax

For a temporary target object:
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>>-= SEND DATA TO Target -----=--=mmmmmmmmmmmomommmmommmmmmmomomoommmmo- <<

>>-= SEND REPORT TO Target --------mmmmmmommmmmmooooooommoocoooomooee <<
+- DATAFORMAT = HTML -+

Parameters
Table 47. SEND TO Command Parameters

Parameter Description

Target The name of the file to export the object to. Targets
containing space characters must be enclosed in single or
double quotes.

DATAFORMAT Specifies the file format of the exported data or report. If
you omit this parameter, the DSQQW_EXP_DT_FRMT global
variable supplies the format to be used.

This parameter can be set to:
* 0 = Text format

* 2 = HTML format

* 3 = CSV format

* 4 = IXF format

If you specify IXF, the DSQQW_EXP_OUT_MDE global
variable can be set to ‘0" for character mode System /370
IXF or "1” for PC/IXF data.

Example
SEND DATA TO "Excel Shortcut"

SET GLOBAL command

The SET GLOBAL command sets the values of existing global variables or
creates new variables and values. Any new global variables created exist for
the entire QMF for Windows session (unless you delete them manually).

Syntax

>>-- SET GLOBAL ( VariableName = Value, ... =======-mmmmmmmmmmmmmeeeo <<
Parameters

Table 48. SET GLOBAL Command Parameters

Parameter Description

VariableName The name of the global variable to set or create. Global

variable names can be from 1 to 17 characters long.
Variables prefixed with DSQ are restricted, and cannot be
created or deleted.
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Table 48. SET GLOBAL Command Parameters (continued)

Parameter Description

Value The value for the global variable. The value can be from 1 to
55 characters long. The values of variables prefixed with
DSQ are restricted.

Example
SET GLOBAL (Varl=abc, Var2=def

SHOW command

The SHOW command displays objects from temporary storage and is similar to
the DISPLAY command.

e The SHOW QUERY, SHOW FORM, and SHOW PROC commands activate the current
query, form or procedure window.

¢ The SHOW REPORT command is a synonym for the SHOW FORM command.
¢ The SHOW GLOBALS command opens the Global Variables dialog box.

Syntax
Syntax
>>-= SHOW === FORM == mmm o mm o e e o e e e e e e e e <<
+- PROC ----+
+- REPORT --+
+- GLOBALS -+
>>-= SHOW QUERY === m e e e e e e e e e <<
+- ( --- VIEW = SQL/PROMPTED/NATURAL/RESULTS/STATUS/ ----+
+- RESULTSET = NumChars ----------- +
Parameters

Table 49. SHOW Command Parameters

Parameter Description

VIEW Specifies the appearance of the target query.

RESULTSETS Specifies the maximum number of characters in the result
set.

Example

SHOW QUERY

WINDOWS command

The WINDOWS command activates the target Windows application, document, or
URL.

Syntax
>>-- WINDOWS CommandLing ==-====-mmmm oo oo e <<
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Parameters
Table 50. WINDOWS Command Parameters

Parameter Description

CommandLine An application command line, document name, or URL to
launch. The command is launched and execution of the
procedure continues without waiting for completion of the
command.

Example
WINDOWS

c:\programs\notepad.exe

Sample procedure

The following sample procedure demonstrates how to display, run, and print
a report using a query and a form. It also creates a new query based on a
table, runs that query, exports the data to a file, and saves the data in a table
at a different database server.

SET GLOBAL (TABLE=SMITH.PAYROLL

DISPLAY QUERY SMITH.PAYROLL_QUERY

RUN QUERY (FORM=SMITH.PAYROLLFORM

PRINT REPORT

DRAW SMITH.PAYROLLTABLE (TYPE=SELECT

RUN QUERY

EXPORT DATA TO C:\TEMP\EXP1.IXF (DATAFORMAT=IXF

CONNECT TO 'SERVERC'

SAVE DATA AS SMITH.DATASAVE
SHOW REPORT
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Chapter 9. ObjectREXX procedures

IBM ObjectREXX (Restructured Extended Executor) is an interpreted script
language (programming language) developed by IBM, which is available for
the mainframe and Windows environments. It is designed for ease of learning
and use and to make programming accessible to non-programmers. It offers
powerful character-manipulation, automatic data typing, manipulation of
words, numbers, and names, and debugging capabilities.

In QMF for Windows procedures, IBM ObjectREXX (ObjectReXX) handles
simple and complex calculations, logic, column definitions, detail variations,
and conditions.

ObjectREXX functions have the following syntax:

function-name ([[expression] [,] [expression] [,] ...])

where 0 to n expression arguments can exist (1 is the maximum number of
comma-separated expressions allowed by ObjectREXX).

You can add programming logic in a procedure by including ObjectREXX
code for IF/THEN/ELSE, SELECT, CALL, looping, form calculations, and
other features.

Note: IBM ObjectREXX must be installed to create procedures with
ObjectREXX logic.

Requirements

You can add ObjectREXX functionality directly to forms. The following form
components require access to ObjectREXX in order to perform the calculations
and logic for the report formatting.

Calculations

Select Form--> Edit, then select the Calculations tab to enter an ObjectREXX
expression containing user-defined usage codes and form variables in the
Expression field.

Note: ObjectREXX for Windows Version 1.0 or later, must be installed;

otherwise, an error message is issued when you display a report
containing ObjectREXX expressions.
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Column definitions

Follow these steps to create an ObjectREXX expression that will define
columns dynamically from form data in other columns.

1.
2.
3.

Select Form--> Edit.

Click the Columns tab.

Click Add.

The Column dialog box opens.

Type the name for the new column in the Heading field.

Optional: Provide additional information about the column in the Usage
code, Edit code, Indent, Width, Heading Alignment, Sequence, and Data
alignment fields.

Enter the ObjectREXX expression in the Definition field.

Optional: Check the Pass nulls check box to pass the definition to
ObjectREXX for evaluation when a variable in the definition has a null
value.

Note: ObjectREXX for Windows Version 1.0 or later, must be installed;

otherwise, an error message is issued when you display a report
containing ObjectREXX expressions.

Conditions
Select Form--> Edit, then select the Conditions tab to define logical criteria in
the Expression field. This information will be used to select the detail
variation for a row.

Note: ObjectREXX for Windows Version 1.0 or later, must be installed;

otherwise, an error message is issued when you display a report
containing ObjectREXX expressions.

Task

Follow these steps to create a procedure with logic:

1.

4.

Select File--> New--> Procedure.

A procedure document opens.

Type an ObjectREXX comment line as the first line of the procedure.
An ObjectREXX comment line begins with /* and ends with */.

Type the procedure command in uppercase letters and enclose the
commands with single quotation marks.

Type the ObjectREXX commands in the procedure.

Note: Object REXX commands are run locally, not at the database server.
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ObjectREXX calculations

ObjectREXX has a special function that performs sophisticated calculations.
For example:

1. Open a default form.

2. Select Form--> Edit.

3. Click the Calculations tab.
4

. Type the ObjectREXX expression for the form in the Expression field, such
as:

&6 +&7
&SUM6 +&SUM7

5. Click the Columns tab.
6. Select the row on which the calculation operation will be performed.
7. Select the CALC usage code for that row in the Usage field.

Complex ObjectREXX calculations

To use complex ObjectREXX calculations, you need to write a full program in
ObjectREXX and call it from the CALC. For example, a complex ObjectREXX
program could divide two values, compare the result to another value and
place a comment or value in the report based on the comparison.

The following is an example of CALC syntax for a complex ObjectREXX
calculation:

PROG(&6,&7,.03)
where PROG is the REXX program.

Column definitions
ObjectREXX offers a column definition function, by which new columns can

be created interactively in the original query.
1. Create a report.

Select the default form.

Select Form--> Edit.

Click the Columns tab.

Click on a row.

Click Add.

The Column dialog box opens.

o0 pwN

~

Type the name for the new column in the Heading field.

8. Optional: Provide additional information about the column in the Usage
code, Edit code, Indent, Width, Heading Alignment, Sequence, and
Data alignment fields.
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Note: You can embed an ObjectREXX function in the Definition field to
call an ObjectREXX program.

9. Type the ObjectREXX expression in the Definition field.

10. Optional: Check the Pass nulls check box to pass the definition to
ObjectREXX for evaluation when a variable in the definition has a null
value.

Conditions and detail variations
Conditions and detail variations can be incorporated into an ObjectREXX

program.

e Conditions define the situations under which an action will occur, such as
printing a message.

* Detail variations specify the action that will occur when the condition is met.

A set of simple conditions is presented below:
1. Select a default form.
2. Select Form--> Edit.
3. Click the Conditions tab and define the conditions, such as:

&7/86>.03
&7/86<.03

Click the Details tab.

Select Yes from the Enable drop-down list.

Check the Include column headings with detail headings check box.
Type the number of blank lines in the Blank lines after block field.
Type the text for the detail block in the Detail Block Text field.

Click 2 of 2.

10. Select Yes from the Enable drop-down list.

11. Check the Include column headings with detail headings check box.
12. Type the number of blank lines in the Blank lines after block field.
13. Type the text for the detail block in the Detail Block Text field.

© 0N o gk
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Chapter 10. Object lists

Collections of QMF objects can be viewed using lists. Lists can be created for
particular types of objects or objects owned by a person or group. For
example, a list of queries owned by the Accounting department can be
developed, saved, and restricted to members of this department.

Objects
QMF for Windows recognizes four types of objects:
* Queries (SQL queries and prompted queries)
¢ Forms

* Procedures
e Tables

You can use the List window to view the objects based on the object name,
owner, and type.
Listing objects
1. Select File--> New List.
The List window opens.
2. Specify an owner and a name.

Optional: You can use patterns to select objects from a list of matching
objects.

* Use the percent character (%) to match a string of any length containing
any characters. For example, to list all tables with a name beginning
with the letter A, enter A%.

* Use the underscore character (_) to match a single character. For
example, to list all tables with an owner that has the letter A in the
second position, enter _A%.

3. Check the object types to include:
* Queries
* Forms
* Procedures
* Tables
4. Click Refresh List.
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List window commands

Right-click an object in the List window to display a sub-menu that is
identical to the List menu.

Display object
Select List--> Display to open the selected object for viewing. This option is
available for queries, forms, procedures, and tables.

Run object
Select List--> Run to run the selected object.

Note: This option is available for queries and procedures.

Draw object
Select List--> Draw to create a query based on the selected table. You can

draw an SQL SELECT, UPDATE, or INSERT query, or a prompted query.
Note: This option is available for tables.

Edit object
Select List--> Edit to open the Table Editor for editing a table.

Note: This option is available for tables.

Properties

Select List--> Properties to display the properties of the object, including
comments, attributes, and historical usage information.

Note: This option is available for queries, forms, procedures, and tables.

Using the Database Explorer

The Database Explorer is a dockable Window tool in which the objects in the
List document display as leaf nodes, such as a node for servers (as defined in
the Server Definition File) and Favorites.

Right-click on a node, before you expand the node (+), and select Filter from
the submenu. Use the Filter dialog box to specify filter options for the node.

Creating lists

You can create lists to serve as collections of objects. For example, you could
create a list of all inventory-related queries, forms, procedures, and tables to
keep your work in one place. Once the list is created, you can add and
remove objects from the list and save the list for future use.
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Adding objects to lists
You can add objects to an existing list.

1.
2.

Select File--> Open to open a list.

At the top of the List window, specify information for the objects you
want to add to the list, such as identifying the Object Owner, Object Name,
and Object Type.

Click Add to List.
The objects matching the owner and name are added to the list.
Select File--> Save As to save the list.

The Save As dialog box opens. The Save as type field is set to the file type
*.0l, which is for Object List Files. Save the object list, then open this
custom list when using QMF for Windows.

Removing objects from lists

You can remove unrelated objects from lists by opening a list and selecting
List--> Remove From List.

The object is removed from the list, but is not deleted from the database.

Saving lists to files

1.
2.
3.
4,

Open a list.

Select File--> Save.

Type the name of the file where you want the list stored.
Click OK.

Opening saved list files

1.

Click File--> Open.

The Open dialog box opens.

Select the file that you want to open.
Click OK.
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Chapter 11. Static queries

A static query is an SQL query that has been passed to a database server and
bound into a package. When a static query runs, the database server uses the
SQL text bound in the package instead of the SQL text currently appearing in
the query window. Static queries are more resource efficient than dynamic
queries.

Note: You cannot edit static queries.

Creating static queries

1. Select Query--> Bind Package.
The Bind Static Package dialog box opens.
2. Click the Package tab.
3. Enter a collection ID and package name, and change any other options.

4. Optional: Click the Input Variables tab if the query contains any
substitution variables.

5. Replace the substitution variables with host variables.
6. Click OK.

Note: After you bind a query, save the query to a file or to the database
server.

Replacing substitution variables

When you bind a package, you must specify a host variable to use in place of
each substitution variable in the SQL text. However, a substitution variable
cannot always be directly replaced by a host variable. Substitution variables
provide direct text substitution in the query text before the text is sent to the
database server. Host variables are sent as part of the query to the database
server. Refer to the documentation for your database server for rules on where
and how host variables can be used in queries.

After you specify a relationship between a substitution variable and a host
variable, QMF for Windows remembers the relationship, and suggests it in
future queries, making binding packages simpler.

The valid data types for host variables are:
* CHAR(n)
* VARCHAR(n)
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« INTEGER

« SMALLINT
 FLOAT

+ DECIMAL(p,s)
« DATE

.« TIME

« TIMESTAMP

Procedure
1. Select the Input Variables tab on the Bind Static Package dialog box.
2. Specify the variable type for each host variable.
3. Click OK.

Running static queries

You run static queries the same way as you run other queries. See
[Database Explorer to select an existing query” on page 32.|
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Chapter 12. Table Editor

Use the table editor to search for, add, edit, or delete data stored in tables
without writing SQL statements.

About the Table Editor
The table editor gives you flexibility in editing and searching through data.

Searching for rows using the table editor
1. Select File--> Table Editor.
The Table Editor dialog box opens.

2. Select the server on which the table resides.

3. Specify a table owner and table name.

Note: You can use patterns to select table names from a list of matching

tables.

Use the percent character (%) to match a string of any length containing
any characters. For example, to list all tables with a name beginning
with the letter A, enter A%.

Use the underscore character (_) to match a single character. For
example, to list all tables with an owner that has the letter A in the
second position, enter _A%.

4. Click List Tables.

The Tables dialog box opens.
5. Select a table from the list.

The Table Editor dialog box opens.
6. Select a Save Mode.

Immediate

The table is updated at the database server immediately after each
change.

End

The table is updated at the database server after you finish entering all

changes. Other users will not be able to make changes to the table while
you are making your changes.

7. Click Edit.
The Edit Table dialog box opens.
8. Type search conditions:
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* For a simple search
Type search values in the Value column.
* For an advanced search

Type search criteria in the Additional search criteria field to specify
more complex search conditions.

Note: You can enter any valid SQL predicate in this field.
9. Click Start Search.
The first matching row is displayed in the Value column.

Adding a row
1. Open the Edit Table dialog box.
2. Enter information for the new record.
3. Click Insert Row.
The new row is added to the table.
4. Click OK.

Changing a row
1. Open the Edit Table dialog box.
2. Search for the row you want to change.
3. Click Next Row until you locate the row to be changed.
4. Edit the data in the Value column.
5. Click Update Row.
The row is updated.
6. Click OK.

Deleting a row
1. Open the Edit Table dialog box.
2. Search for the row that you want to delete.
3. Click Next Row until you locate the row to be deleted.
4. Click Delete Row.
The row is deleted.
5. Click OK.

Editing tables from the query results view

You can edit tables directly from the query results view.

Deleting a row from the query results view
You can delete individual rows from tables in the query results view.

1. Run a query.
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2. Select a row from the query results view.
3. Select Edit--> Delete.

Updating columns from the query results view
You can update individual columns in the query results view.
1. Run a query.
2. Double-click a cell.
3. Type a new value.
4. Press Enter.
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Chapter 13. Data distribution

Query results data can be exported to other databases and applications.

Exporting methods

There are three methods to export data from QMF for Windows into other

applications:

* Exporting the data into a TXT, CSV, IXE, HTML, or shape file

* Saving the query results to a table

* Adding query results directly into a Microsoft Excel or Lotus 1-2-3

spreadsheet
Exporting data to files

1. Run the query.

2. Select Results--> Save to File.
The Export Data dialog box opens.

3. Select one of the following output file types from the Save as type field:
e TXT

You can produce a text file, with a .txt extension. This is a standard
ASCII file with optional string and column delimiters (as specified in
the Export Text/DEL Options dialog box).

* HTML
You can produce an .htm type file (HTML). This is an HTML file that
can be viewed by any web browser. All of the HTML tags are
automatically generated in the file and it is prepared to be published on
your Internet or intranet web site. The options you choose on the Export
HTML Options dialog box control the appearance of the exported data.

» IXF

You can produce an .ixf type file. An IXF export preserves all database
information, including column headings and data types. It is typically
used to transfer information from one database to another.

- CSV

You can produce a .csv type file. A CSV export is similar to a text
export, using a comma as the column delimiter. This format is most
commonly used by spreadsheet applications.

e DBF

You can produce a .dbf file, which is a dBASE III file, part of the
popular database management system. The dBASE format for storing
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data has become a de facto standard, and is supported by nearly all
database management and spreadsheet systems. Even systems that do
not use the dBASE format internally are able to import and export data
in dBASE format.

SPM (map file)
You can produce a SPM file, which enables you to view data from DB2
in a map rather than through conventional means such as in a chart,

report, or browser. Only tables having a column defined as GEO type
can be rendered as a map in QMF for Windows.

4. Click Options.
One of the following dialog boxes opens:

The Export Text/DEL Options dialog box opens for TXT output options
The Export HTML Options dialog box opens for HTML output options
The Export IXF Options dialog box opens for IXF output options

The Export CSV Options dialog box opens for CSV output options

The Export dBASE Options dialog box opens for DBF and SHP output
options

5. Select the options for the export file.
6. Click OK.
7. Click OK.

Importing data
You can import data that has been saved in an IXF file. Once data is imported
into a query window, it can be saved to a database server, exported to a new
file, or used for reports. PC/IXF and character mode System/370IXF files are
supported.

1. Select File--> Import Data.

The Import Data dialog box opens.

2. Select the file you want to import.
3. Click OK.
The imported data opens in a new query window.

IXF messages
The IXF Messages dialog box displays when you export or import data

successfully into an IXF format file.
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Table 51. IXF Import/Export Confirmation

Field

Description

Messages

The messages section of the IXF Messages dialog box
displays detailed data and process information when
importing or exporting from an IXF file. For example, it
could provide information about the number of rows that
were imported or exported, which rows were rejected, and
which data was truncated.

The edit box is read-only; however, you can select and copy
these messages.

OK

Click OK to close the dialog box.

Sample messages

Sample messages are presented below:

The H record in the PC/IXF file has product
"DB202.00, date "20011025 time "160300",
single CCSID "0" and double CCSID "0O".

The C record in the PC/IXF file has column name "ID",
data type "INTEGER",
single CCSID "0", and double CCSID "0"

The T record in the PC/IXF file has a name "STAFF",
qualifier "Q", and source "TEST".

The application is beginning to export data to file
c:\temp.IXF.

The row 5 is rejected.
The data in (1,3) is truncated.
The data in (4,3) is truncated

Number of rows rejected = 1.
Number of data truncated = 2.
Number of rows exported = 10.

The application has completed processing. "26" rows
were exported from the file c:\temp.IXF.

Saving data to a database server
You can save imported query results to a database table.

1. Open the imported query results.
2. Select File--> Save Data.
The Save data dialog box opens.

3. Select a database server, enter a table owner and name, or choose other

options.
4. Click OK.
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Using the Microsoft Excel add-in

The 32-bit version of QMF for Windows includes an add-in for Microsoft
Excel 7.0 or later. This enables you to run QMF for Windows and export
query results directly into a spreadsheet. The appropriate add-in is
automatically installed if you choose the "Typical” installation option, or if

you choose the "Custom” installation option and select the Microsoft Excel
Add-In.

1. Run a query in QMF for Windows.

The query results open in the query results grid.

Select the data you want to return to Excel.

Select Results--> Display Chart.

Select Microsoft Excel from the Application drop-down list.

Specify the chart type, chart title, chart labels, and other charting options.
Click OK.

Microsoft Excel opens and displays the exported spreadsheet.

SIS EE SRR

Using the Lotus 1-2-3 add-in

The 32-bit version of QMF for Windows includes an add-in for Lotus 1-2-3
that enables you to run QMF for Windows from 1-2-3 and return query results
directly into a spreadsheet. This add-in is installed if you choose the "Typical”
installation option, or if you choose the "Custom” installation option and
select the Lotus 1-2-3 Add-In option.

1. Run a query in QMF for Windows.

The query results display in the query results grid.

Select the data you want to return to Lotus 1-2-3.

Select Results--> Display Chart.

Select Lotus 1-2-3 from the Application drop-down list.

Specify the chart type, chart title, chart labels, and other charting options.
Click OK.

Lotus 1-2-3 opens and displays the exported spreadsheet.

SIS EE AN

Using sample applications

Several sample applications and integration solutions are available for QMF
for Windows. To find out more, visit the IBM web site:

http://www.ibm.com/qgmf
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Building an application using the QMF for Windows API

You can build your own applications using QMF for Windows. Refer to the
API online help for a complete listing of all the API functions and their
effects. Also, visit the IBM web site for programming examples:

http://www.ibm.com/qmf
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Chapter 14. Job files

You can schedule and run procedures using job files. Job files store procedure
parameters and use the Microsoft Windows scheduler to run the procedures at
the time and date you specify. Job files allow you to schedule lengthy or
resource-intensive queries to run at more convenient times.

You can create job files and store them locally or at the database server.

Job menu

Set server

Select Job--> Set Server to select the database server that contains the
procedure you want to run.

Set user information

Select Job--> Set User Information to set your database server user ID and
password.

Optional: Specify an accounting string that the database server uses to track
system usage.

Optional: Check the Remember this password check box to have QMF for
Windows use the password specified in the Password or New Password
fields across multiple QMF for Windows sessions. If unchecked, QMF for
Windows uses the password only for the duration of the current session.

Optional: Check the Use this information for every server I connect to check
box to use the same user ID and password entered in the User ID and
Password fields for connecting to all database servers. If this check box is
checked QMF for Windows will use the same user ID and password for all
connections unless you open the Set User Information dialog box and make a

change.

Run
Select Job--> Run to run the job in a separate QMF for Windows instance,
which leaves the current session available to perform other tasks.

Test

Select Job--> Test to run the scheduled task at the same time that QMF for
Windows runs the SQL for that task. Both transactions are performed in the
same instance, but in separate windows.
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Schedule

Select Job--> Schedule to open the Schedule Job dialog box. Use this dialog
box to schedule the job using the Microsoft Windows Scheduler.

View scheduled tasks
Select Job--> View Scheduled Tasks to open the Scheduled Tasks dialog box
and review the command used to launch the job, the comment associated
with the job, the creator, the last used date, the edit code, and the trigger
count.

Creating job files
1. Select File--> New Job.
A new job document opens.

2. Specify job-specific information, such as server, user ID, password,
procedure name, or procedure file.

3. Optional: Define a variable to be used in place of a substitution variable.
4. Select File--> Save to save the job file locally or at the database server.

Saving a job files
You can save job files locally or at a database server.
1. Select File--> Open to open a job file.
2. Select File--> Save As.
The Save As dialog box opens.
3. Specify a location and file name.
4. Click OK.

Saving a job file to a server
You can save a job file to a database server.
1. Select File--> Open to open a job file.
2. Select File--> Save At Server.

Running job files
You can run job files that have been saved locally or at a database server.
1. Select File--> Open to open a job file.
2. Select Job--> Run.
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Scheduling job files

You can schedule job files to run unattended using the Microsoft Windows
scheduler.

Note: Save your user ID and password with the job file to schedule a job file
that has been saved locally, but be aware that, although your password
is saved as encrypted text, it could be vulnerable to discovery.

1. Select File--> Open to open a job file.
2. Select Job--> Schedule.
The Schedule Job dialog box opens.
3. Specity the scheduling information for the job file.
4. Click OK.
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Chapter 15. QMF for Windows Report Center

Use QMF Report Center to produce custom reports by using shared QMF
objects (queries, forms, procedures, and tables). With quick access to these
objects, you can specify data format preferences and produce custom reports
that can be viewed and manipulated in a variety of applications. The QMF
Report Center is a simple user interface that launches centrally-shared queries
and QMF reports and sends the results to spreadsheets, desktop databases,
browsers, or to a printer. QMF Report Center

QMF Report Center application is installed along with QMF for Windows and
QMF for Windows Administrator.

Features

The following are some features of QMF for Windows Report Center:

* Queries and reports can be stored and run against multiple DB2 UDB
database servers.

* Results can be viewed, formatted, and saved.

* Lists of favorite reports can be created and sent to the Favorites folders on
your desktop in various formats, such as Lotus 1-2-3, Microsoft Excel,
Microsoft Access, or as .txt files.

* Administrators can set governing limits based on schedules and user
groups to restrict users from running large reports at specific times and
days.

¢ Administrators can control who has access to queries and reports, which
leaves distribution and central control over the reports with the
administrator

Definitions

Table 52. Key Definitions for QMF Report Center

Term Definition

Query A description of a result set of data to retrieve from a
database server

Note: Queries cannot be created or modified in QMF
Report Center.

Table A collection of stored data. You interact with tables by
running queries
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Table 52. Key Definitions for QMIF Report Center (continued)

Term Definition

Form Contains the formatting instructions for generating a
report from the query results

Procedure A set of commands for running queries, printing
reports, importing and exporting data, and performing
other functions

Getting acquainted with QMF Report Center

Navigation tips
* Right-click on any object or folder to open a subfolder

* Click the plus symbol (+) next to any folder to open the first level of
contents

* Press Shift while you click + to open all subfolders for a folder

Directory structure

The QMF Report Center window contains a tree-like structure of available
Favorites, DB2 servers, Public Favorites, objects, and a Recycle Bin.

Each type of object has an icon, such as an icon for a query or database
server. Click on the icon for an object type to view the objects for each server
and view all other available servers.

Favorites
Your Favorites folder contains reports based on objects that reside on a server.

You can create reports by copying objects to your Favorites folder. The objects
are not physically located on your hard drive; instead, the reports point to
objects on the server.

Note: No one else can access objects in your Favorites folders because you are
the owner of these folders.

DB2 servers
This part of the tree lists all DB2 servers that are in your server definition file

(SDF).
Note: Servers that you cannot access may still be listed.

Reports
This part of the tree lists, by server name, all available objects to which you

have access.
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Public favorites
The Public Favorites folder resides on a server and contains reports, along

with your Favorites folders. Any user can access Public favorites; whereas,
only you can access objects in your Favorites folders because you are the
owner of these folders.

Recycle Bin
The Recycle Bin contains items that you delete from your Favorites folder.

Deleted items remain in the Recycle Bin until you empty the bin. The Recycle
Bin acts as an "undo” feature because you can move items out of the bin and
back to your Favorites.

* Deleting items from QMF Report Center
Select an item, then select Edit--> Delete.
¢ Emptying the Recycle Bin
Select Report--> Empty Recycle Bin.

Note: Items will be deleted permanently from QMF Report Center.
* Restoring items to QMF Report Center
Drag the item from the Recycle Bin to another location.

Working with folders and favorites

Folders group reports and QMF objects. Folders are named according to object
owner names. You can perform the same operations on folders that you do on
reports, such as running reports and defining report properties.

Note: When you perform an operation at a top-level folder the operation is
applied to every report contained in the folder.

To run the reports within a folder consecutively, click on the folder, then select
Report--> Run.

QMEF Report Center contains two top-level folders where you can store
reports. The folders contain reports that point to objects on servers. The actual
objects are not contained within your Favorites folders.

* Your Favorites folders reside locally. You are the only one who can access
the folders and the contents within the folders.

* A Public Favorites folder resides on each server and can be accessed by all
authorized users.

You may have access to several Public Favorites folders at several different
servers, depending on your resource limits.

Note: There is only one Public Favorites folder on each server.
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When you copy QMF objects to your Favorites folders and Public Favorites
folders, the folders are renamed automatically to include the object type and
owner name. When you copy an entire object type (for example, a folder
containing procedures) from a server, the server name is also included in the
new folder name.

Adding reports to Favorites
You can add any object or report from a server to your Favorites folders, or to

the Public Favorites folder on a server (with permission from your system
administrator).

Adding reports to your Favorites folders

Select one of the following options:
* Select the report then select Report--> Add to Favorites
* Select the report then drag the report to your Favorites folder

The report is added to the top of your Favorites folder with the following
naming convention:

Objecttype OWNERNAME.OBJECT NAME

For example:
Query QMFGUEST."SELECT"

Adding reports to a Public Favorites folder on a server

Select a report than drag the report a Public Favorites folder on a server. You
can add reports from your Favorites folders or from another server.

Note: After you add or modify a report in a Public Favorites folder, select
Report--> Save changes to Public Favorites to save the updates at the
server.

Connecting to a server

Follow these steps to connect to a server to fetch reports.

1. Click the plus symbol (+) to the left of the DB2 server to list the servers.
2. Click the + next to a server.

3. Provide user information at the Set User Information dialog box.

A dialog box opens showing that QMF Report Center is connecting to the
server and retrieving information.

4. Click the + next to a folder. Folders are available for the following object
types:
* DB2 Forms
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e Public Favorites
¢ QMF Forms

* QMF Procedures
* QMF Queries

e Tables

5. Click + next to a top-level folder to list the individual objects within a
folder.

Working with reports and objects

Reports are based on queries and forms, and contain certain formatting and
output specifications. Reports that are contained in your Favorites folder point
to objects that reside on the server.

All items in your Favorites folder and in the Public Favorites folders on each
server are considered reports. You can manipulate formatting and display
options for reports.

You do not modify a QMF object. Instead, you modify its link. Because
reports are based on objects, properties of objects also apply to reports.

You can create reports from objects that reside on a server, but they are not
saved to the server. This allows you to create one-time, ad hoc reports. After
creating a report from objects on a server, you can save the report to your
Favorites folders.

Creating reports

You can create reports from reports in your Favorites folders and from QMF
objects that reside on a server.

Create reports locally
Follow this step to create a report locally:

1. Connect to the server that contains the object you will base the report on.
2. Select an object, then drag the object to your Favorites folder.

You can now run the report or define report properties unique to the
report.

Create reports from the server
Select one of these options to create reports from the server:

* Right-click on an object then click Run

* Right-click on an object, then click Properties. The Report Properties dialog
box opens. Change the properties associated with the report, then click
Run.
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If you select this method to create a report, you are prompted to save the
report in your Favorites folder. Your report will not be saved if you skip
this step.

* Modify report properties, then use the first option

Note: Reports that are created from objects that reside on the server are not
saved to the server.
Running reports

You can run reports from your Favorites folders or from objects located on the
server.

1. Optional: Select the report or object, then select Report--> Properties.
The Report Properties dialog box opens.

2. Optional: Define properties. See [“Properties” on page 172]

You can set properties for formatting, output, procedures, variables,
miscellaneous, schedule, security, and email for objects that reside in your
Favorites folders and objects on the server.

3. Click Run.
4. Provide your user ID and password.
5. Click OK.

The report is processed.

If you checked the View report after publishing check box at the Report
Properties--> Output tab, the report opens in the application you specified in
the Select output application field.

The query results display in the format specified in the Report--> Properties
dialog box. By default, it will point to a text (.txt) application. Other format
options include:

* Web browser (.htm)

o Text (.txt)

* Mi crosoftWord (.doc)

* Lotus®Word Pro® (Iwp)
* Microsoft Excel (.xls)

e Lotus 1-2-3 (.123)

* Microsoft Access (.mdb)

e Printer

Running multiple reports

To run multiple reports, you can repeat the procedure for running reports
while you are in your Favorites folder.
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You can also run a report by:

* Selecting the report, then choosing Report--> Run
* Right-clicking on the report, then choosing Run

¢ Double-clicking on the report name

You can run reports in separate memory so you can continue to work in the
QMF Report Center while reports are running. To do this, check the Run as a
separate process check box on the Miscellaneous tab of the Report Properties
dialog box.

If you checked the View report after publishing check box on the Output tab
of the Report Properties dialog box, the report opens in the application you
specified.

Printing reports
You can print QMF Report Center reports from the output application or
directly from QMF Report Center.

Procedure
1. Select one of the following options:

* Select the report, right-click, and select Properties
* Select the report, then select Report--> Properties
The Report Properties window opens.
2. Click the Output tab.
3. Select a printer from the drop-down list.
4. Click Options.
5. Specify the printing options.
6. Click OK.
Scheduling reports

You can schedule the reports and folders in your Favorite folder to run at a
specific date and time, or at regular intervals.

The QMF Report Center scheduler is based on the Windows scheduler. Make
sure the Windows scheduler is running and you have authority to use the
scheduler. You will be notified if the Windows scheduler is not running when
you try to schedule jobs.

Note: If you are using an NT machine that does not have the Windows
scheduler, only the user whose name was identified as the log-on

account for running the "AT" scheduler can schedule jobs.

Check with your system administrator to determine which account is
set up on your computer.
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Procedure
Select one of the following options to schedule reports if you have the

Windows scheduler and the authority to use it:

Option 1

1. Select Tools--> Set User Information.

The Set User Information dialog box opens.
Provide user ID and password information.
Check the Remember this password check box.
Click OK.

Select one of the following options:

a ks

* Select the report and select Report--> Properties

* Select the report, right-click, then select Properties
6. Click the Schedule tab.

The Schedule page opens in the Report Properties window.
7. Select schedule options.
8. Click OK.

The scheduled jobs run as a separate process. This enables you to keep
working in QMF Report Center while scheduled jobs are running.

Note: If you set up a daily and monthly schedule in which reports will run
once a day, two separate jobs are entered (one for the weekly schedule
and one for the monthly schedule).

Viewing scheduled reports
You can view the schedule for scheduled reports.

Procedure

Select View--> Scheduled jobs to open the QMF Scheduled Jobs dialog box.
Viewing report history

You can display a chronological list of all reports run in Report History.

Report History contains data about the run date and time, report name,
output application, file location, and size of a report run.

Procedure
Select View--> Report history to open the Report History dialog box, which

lists the date, report, application, file location, and file size of the reports that
were run.

Renaming reports and folders
You can rename reports and folders contained in your Favorites folder.

Note: You cannot rename QMF objects.
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Procedure
Option 1

1. Select the report or folder.

2. Right-click on the report.

3. Select Rename.

4. Type the new name for the report or folder.
5. Press Enter.

Option 2

1. Select the report or folder.

2. Select Edit--> Rename.

3. Type the new name for the report or folder.
4. Press Enter.

Moving reports, objects, and folders

You can move reports, objects, and folders on a server and within your
Favorites folders.

Procedure
1. Select one of the following options:

* Select the item, right-click, and select Cut
¢ Select the item, then select Edit--> Cut
2. Select one of the following options:
* Right-click on the location, then select Paste
* Right-click on the location, then select Edit--> Paste

Note: Dragging an item does not move the item from one location to another.
Instead, dragging makes a copy of the item, except when you are
working in your Favorites folders.

Copying reports, objects, and folders

You can copy reports, objects, and folders from a server or within your
Favorites folders.

Copy and paste reports from a server
1. Select one of the following options to copy the item:

* Drag the item from its current location to another location
* Select the item, right-click, then select Copy
* Select the item, then select Edit--> Copy

2. Select one of the following options to paste the item:

* Right-click on the folder to which you want to copy the item then
select Paste

Chapter 15. QMF for Windows Report Center 171



* Right-click on the location, then select Edit--> Paste

A message confirms that the item has been pasted and the item is added to
the bottom of the current folder.

Copy within Favorites folders
Use the copy and paste method described in[“Copy and paste reports from a|

lserver” on page 171|to copy reports within your Favorites folders.

Note: Dragging reports within your Favorites folders only moves the reports
from one folder to another.
Deleting reports, objects, and folders

Objects and reports that you delete from your Favorites folders are sent to the
Recycle Bin and can be recovered. However, objects and reports that you
delete from the server are deleted permanently.

Note: You may be prohibited from deleting items from the server.

Procedure
Select one of the following options:

* Select the item, right-click, then select Delete
¢ Select the item, then select Edit--> Delete

A delete-confirmation message is issued for objects and reports being deleted
from a server.

Note: The task scheduler must be running for you to delete a report that has
scheduled jobs or remove the report from the Recycle Bin.

Menu options

Report menu

Run
Select Report--> Run to run the report.

Properties
1. Select a report at a server.

2. Select Report--> Properties to open the Report Properties window.

In this window, you can provide the following report information:
* General

* Formatting

* Output
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* Procedure

* Variables

* Miscellaneous
* Schedule

* Security

* Global variables

Note: The Formatting, Output, and Procedures tabs are disabled for queries
that do not use the SQL SELECT statement because they do not return
data (non-SELECT SQL verbs).

REPORT PROPERTIES - FAVORITES

A hidden menu with two options is available from the Properties window.
The menu becomes enabled when you select a report from your Favorites
folder, select Properties, than right-click on any page in the Properties
window.

* Report Comments

Select this option to open the Report Comments dialog box and work with
comments for the report.

 Edit local query

Select this option to open the Query Text dialog box where you can modify
the SQL for a local query.

REPORT PROPERTIES - GENERAL TAB

The General page of the Report Properties window opens when you select
Report--> Properties, then click the General tab.

Table 53. General Options

Field Description

Report name This field display report name information, such as:

* The QMEF object type followed by
OBJECTOWNER.OBJECTNAME, such as:

QUERY Q.STAFF

* the report description if the selected report is in your
Favorites folder

Server Type the name of the server on which the report resides,
or select a server from the drop-down list.
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Table 53. General Options (continued)

Field

Description

Object type

This field identifies the type of object with which your are
working. This can be a query, table, or procedure. You
cannot edit this field directly. To select another object, click
Select to open the Object Filter dialog box.

View QMF Object text

Check this check box to display the SQL for of the QMF
object.

REPORT PROPERTIES - FORMATTING TAB

The Formatting page of the Report Properties window opens when you select
Report--> Properties, then click the Formatting tab.

Note: Select the No formatting (data only) radio button to use Microsoft
Excel, Lotus 1-2-3, or Microsoft Access as the output application.

Table 54. Formatting Options

Field

Description

No formatting (data
only)

Select the No formatting radio button to return raw data
to the file

Include column headers

Check this check box to add labels to report columns.

Default QMF formatting

Select this radio button to return data in the default QMF
format, which includes column headers and a horizontal
line to separate the headers and data.

QMF formatting from
form

This field displays the form that will be used for data
formatting.

Select form

Click Select Form to open the Form Filter dialog box to
specify an object owner and object name of the form to use
for the report. The Select a Form dialog box opens and
lists the forms available to use for data formatting.

Run

Click Run to run the SQL

REPORT PROPERTIES - OUTPUT TAB

The Output page of the Report Properties window opens when you select
Report--> Properties, then click the Output tab.

Note: Select the No formatting (data only) radio button on the Formatting
page of the Report Properties window to use Microsoft Excel, Lotus
1-2-3, or Microsoft Access as the output application.
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Table 55. Output Options

Field

Description

Select output application

Select or browse for the application for which
you want to format the report.

For Microsoft Excel, Lotus 1-2-3, and Microsoft
Access applications and the printer option, click
Options to define specific output options.

MICROSOFT EXCEL

Select Microsoft Excel from the Select output
application drop-down list, then click Options.
The Report Output Options dialog box opens.
* Select or enter a sheet name

Select a sheet name from the drop-down list
or type a new sheet name in the text box for
the Microsoft Excel worksheet.

* Use the QMF object name
Check this check box to use the object name
as the report name.

* Append the above name with

Select the date format from the drop-down
list to use as a suffix for the report name.

¢ Include column names

Check this check box to display column
headers in the formatted report.

* Output range

Click the Output range text box to launch
Microsoft Excel. The Output range dialog box
opens.

Click the cell in the spreadsheet where the
results should be written. The output range
will be updated to the specified cell position.

Click Data Options to specify additional
formatting options for graphing and grouping
data.

Note: Data Options is disabled if you selected
Default QMF formatting or QMF formatting
from the Properties--> Formatting tab.
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Table 55. Output Options (continued)

Field

Description

LOTUS 1-2-3

Select Lotus 1-2-3 from the Select output
application drop-down list, then click Options.
The Report Output Options dialog box opens.
* Select or enter a sheet name

Select a sheet name from the drop-down list
or type a new name in the text box for the
Lotus 1-2-3 worksheet.

This option is not available if the Use the
OQMF object name check box is checked.

* Use the QMF object name

Check this check box to use the object name
as the report name.

* Append the above name with

Select the date format from the drop-down
list to use as a suffix for the report name.

¢ Include column names

Check this check box to display column
headers in the formatted report.

* Output range

Click the Output range text box to launch
Lotus 1-2-3. The Output range dialog box
opens.

Click the cell in the spreadsheet where the
results should be written. The output range
will be updated to the specified cell position.

Click Data Options to specify additional
formatting options for graphing and grouping
data.

Note: Data Options is disabled if you selected
Default QMF formatting or QMF formatting
from the Properties--> Formatting tab.
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Table 55. Output Options (continued)

Field

Description

MICROSOFT ACCESS

Select Microsoft Access from the Select output
application drop-down list, then click Options.
The Report Output Options dialog box opens.

¢ Select or enter a table name

Select a table name from the drop-down list
or type a new name in the text box for the
Microsoft Access table.

This option is not available if the Use the
QMF object name check box is checked.

* Use the QMF object name

Check this check box to use the object name
as the table name.

* Append the above name with

Select the date format from the drop-down
list to use as a suffix for the table name.

* Overwrite existing data in table

Check this check box to replace existing data
in the named table with data from the most
recent report.

* Select or enter a report name (optional)

Optional: Select or enter a report name to
view a predefined Microsoft Access report
when the database opens.

This option is useful when you want to view
the report after it runs. Click Data Options to
specify additional formatting options for
graphing and grouping data.

Note: Data Options is disabled if you
selected Default QMF formatting or QMF
formatting from the Properties--> Formatting
tab.
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Table 55. Output Options (continued)

Field

Description

PRINTER

Select a printer

Select an installed printer from the
drop-down list, or click Options to select
from other printers.

Number of Copies

Type the number of copies of the report to
print.

Font Options

Select the font type and size for data in the
report, or click Options to choose other font
options.

Orientation

Select the Portrait radio button to print the
page with the short edge on top. Select the

Landscape radio button to print the page
with the long edge at the top.
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Table 55. Output Options (continued)

Field

Description

Page Width

Three options are available to control the
width of the report page:

— Fit to printer page: Select this radio button
to size the page width or length to fit the
size of the printed page.

— Characters: Select this radio button, then
type the number of character lines for the
page size. The page size will be restricted
to this number of lines.

— Continuous: Select this radio button to
print continuous pages, without page
breaks, or to wrap text for page width

Page Length

— Fit to printer page: Select this radio button
to size the page width or length to fit the
size of the printed page.

— Lines: Select this radio button, then type
the number of character lines for the page
size. The page length will be restricted to
this number of lines.

— Continuous: Select this radio button to
print continuous pages without page
breaks or wraps.

Other Options
— Include date and time: Check this check

box to include a date and time stamp on
the report.

— Include page number: Check this check
box to include a page number on the
report.

Margin (inches)

Set the top, bottom, left and right margins for

the report by using the up and down arrow

keys or by typing the value in the input field.
Margins are measured in inches.

REPORT PROPERTIES - PROCEDURE TAB

The Procedures page of the Report Properties window opens when you select
Report--> Properties, then click the Procedure tab.
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Table 56. Procedure Options

Field

Description

This procedure produces no output

Check this check box to indicate that there is no
output, such as report results, produced from
this procedure. Instead, the procedure will run
and a subsequent action will take place.

The procedure uses the
DSQQW_PROC_OUTPUT
substitution variable

Select this radio button if the procedure uses
the DSQQW_PROC_OUTPUT substitution
variable. The variable is used to export data to
the location you specify in the output location.
The output location is passed to the procedure
using this substitution variable.

The syntax EXPORT REPORT TO
&DSQQW_PROC_OUTPUT substitution
variable must be included in the procedure.
Substitution variables will not display in the
Properties dialog box for the report.

Publish to a temporary file, in the
following directory

Select this radio button to specify the filename
to which the procedure will send output.

Use the temporary directory of the
machine running this report

Check this check box to use the machine’s
temporary directory to save the report.

Start file name with

Optional: Type the prefix for the file. This option
is used with the Publish to a temporary file, in
the following directory option.

End file name with

Optional: Select a date format to use as a suffix
for the file name.

Select RANDOM use assigned suffixes and
avoid overwriting existing report names.

This option is used with the Publish to a
temporary file, in the following directory
option.

Extension

Optional: Select one of the following file formats
to use for the temporary file:

* .CSV
e htm
o txt

Publish to a specific file

Select this radio button to browse for a filename
where the report will be saved

View output after running

Check this check box to open the report after it
is produced.
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REPORT PROPERTIES - VARIABLES TAB

The Variables page opens when you select Report--> Properties, then click the
Variables tab.

The Variable name field lists the variables defined for the report.You can
present values for each variable.

1.
2.
3.

Type a value for the variable in the Variable value field.

Optional: Select the Variable value field.

Optional: Click List of values to open the Variable Values List dialog box.

a. Type a value for the variable in the text box at the top of the dialog
box.

b. Click Add.

c. Optional: Click Remove to delete values from the variable values list.

d. Optional: Click Move Up or Move Down to resequence the values in
the list.

e. Optional: Click the User can type in their own values when the report
is run check box if the user can provide alternate values for the
variable when the report is run.

f. Click OK.

The Variable value field is updated as follows, indicating that multiple
values have been defined for the variable:
<List Value>

Check the Hide this value check box to hide the value of the variable
when you run the report.

Optional: Click Clear Values to delete all values defined for the variables.
Optional: Click Calculated date to define which date to put on the report
when you run the report or schedule the report in the report scheduler.

This is similar to a date wizard. For example, you can use the Calculated
date function when you run a report on Mondays, but you want to use the
previous Friday’s date on the report. The Calculated date function will
determine the correct date each time you run the report, or pass in the
correct date for a scheduled report.

Note: Use this feature only for queries that accept dates as substitution
values.
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The Date Substitution Value dialog box opens.

Table 57. Date Substitution Values

of days prior to the
current date to use for
the report date

Group box Description Task Notes
Calculated By days Select this radio button | Type a number in the
date to specify the number |Number of days prior

to current date field or
select a number from
the drop-down list

By days of the
week

Select this radio button
to specify the day of
the week, whether in
the current month, or
the last month, to use
for the report.

* Last occurrence in
current month:
Select this radio
button, then select a
day to pass to the
report, such as the
September 24, which
is the last Tuesday
of this month.

* First occurrence in
current month:
Select this radio
button, then select a
day to pass to the
report, such as
September 3, which
is the first Tuesday
of the current
month.

* Last occurrence in
previous month:
Select this radio
button, then select a
day to pass to the
report, such as
August 26, which is
the last Tuesday of
the previous month.

* First occurrence in
previous month:
Select this radio
button, then select a
day to pass to the
report, such as
August 6, which is
the first Tuesday of
the previous month.
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Table 57. Date Substitution Values (continued)

Group box

Description

Task

Notes

By month

Select this radio button
to specify the month
to use for the report,
and whether to use the
first day or last day of
the specified month on
the report.

Select By first day of
month, then select a
number from the
Month prior to
current drop-down list
to calculate the date
for the first day of the
prior x number of
months.

For example, select the
By first day of the
month radio button
and type 6 in the
Month prior to
current field, to print
March 1 on a report if
the current month is
September.

For example, select the
By last day of month
radio button and type
2 in the Month prior
to current field, to
print July 31 on a
report if the current
month is September.

By quarter

Select this radio button
to specify the quarter
and the day during
that quarter to use on
the report.

1. Select the By
quarter radio
button.

2. Select the first,
second, third or
fourth quarter from
the From
beginning of
drop-down list.

3. Select the first
month of the fiscal
year from the
Fiscal year starts
drop-down list.
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Table 57. Date Substitution Values (continued)

Group box

Description

Task

Notes

Date format
options

Date format

This field controls how
the date will be
formatted on the
report.

Select the format in
which to display the
date on the report
from the Date format
drop-down list.

Date separator

This field defines the
symbol used to
separate the elements
of the date (year,
month, and day).

Select a date separator
symbol from the Date
separator drop-down
list.

Use PC date as
current date

Use the current date
set on your PC

Select the Use PC date
as current date radio
button to use the date
stored on the PC as
the current date on the
report.

Use DB2 date as
current date

Use the current date
set on the DB2 system
(to account for time
zones)

Select the Use DB2
date as current date
radio button to use the
date from DB2 as the
current date; this
enables users to use
the correct date, based
on their time zones

Sample date

Click View Sample
to see an example
of how the date
will display.

Current PC
date

In the lower-right
corner of the Date
Substitution Value
dialog box,
displays the current
date you have set
on your PC

REPORT PROPERTIES - MISC TAB

The Miscellaneous page of the Report Properties window opens when you
select Report--> Properties, then click the Miscellaneous tab.
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Table 58. Miscellaneous Options

Field

Description

Run as a separate process

Check this check box to run reports in a
separate instance of QMF Report Center, which
allows you to continue working within QMF
Report Center.

Suppress informational messages

Check this check box to hide informational
messages

Suppress error messages

Check this check box to hide error messages
while reports are running

Limit the number of rows returned

Type a number in this field to control the
number of rows returned to the report, which
preserves system resources, especially at peak
times.

Send an email message whenever I
run the report

Check this check box to send an email
notification each time the report is run.

Send an email message whenever
the scheduler runs a report

Check this check box to send an email
notification each time the report is run through
the report scheduler.

Attach report output to the email

Check this check box to include the report
output in the email notification.

Note: For reports produced at the folder level,
this option will attach report output for all
reports contained under the folder.

Properties

Click Properties to open the Internet Mail
Wizard where you provide addressing and
routing information for the email.

REPORT PROPERTIES - SCHEDULE TAB

The Schedule page of the Report Properties window opens when you select a
query in the Favorites folder, select Report--> Properties, then click the

Schedule tab.
Table 59. Schedule Options

Field Description

Job ID This field displays the number of each
scheduled job. The number is assigned
automatically and cannot be edited.

Interval This field displays the frequency with which

the job is run, as specified in the Recurrence
field.
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Table 59. Schedule Options (continued)

Field

Description

Days of week

This field displays the day or days on which
the job is scheduled to run, as specified in the
Days of week to run field.

Optionally, this field may be blank or contain
<Customized> if the job has been edited using
Microsoft’s Task Scheduler (R), indicating that
QMEF Report Center is not able to display the
job details.

Days of month

This field displays the calendar day of the
month on which the job is scheduled to run, as
specified in the Days of month to run field.

Time This field displays the time, in a 24-hour time
format, at which the job is scheduled to run on
the specified days.

Time Type the hour and minute at which to run the

report, using a 24-hour time format.

Days of week to run

Check the check box next to each day on which
the report is scheduled to run.

Optional: Check the Select all check box to
select all days of the week.

Days of month to run

Check the check box for the day or days during
the month when the job is scheduled to run.

Optional: Check the Select all check box to
select all days of the month.

Recurrence

* Today only

Select this radio button to run the job today
only

* Once for the days marked

Select this radio button to run the job only
once on the days indicated in the Days of
week to run or Days of month to run field

* Every time for the days marked

Select this radio button to run the job on the
day or days selected in the Days of week to
run field or in the Days of month to run
field
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Table 59. Schedule Options (continued)

Field

Description

Set Variable Values

Click Set Variable Values to open the Variable
Input for Sched Job dialog box where you
specify variables to be used with the scheduled
report.

Edit Variable Values

Click Edit Variable Values to open the Variable
Input for Scheduled Job dialog box where you
can modify the values for a variable.

Note: Select the report name to activate this
command button.

REPORT PROPERTIES - SECURITY TAB

The Security page of the Report Properties window opens when you select the
Public Favorites folder and you select Report--> Properties, then click the

Security tab.

Use this page to define security information for users or groups of users who
can access objects in the Public Favorites folder.

Table 60. Security Options

Field

Description

User ID

Select the name of the user or user group to
which you are assigning permission to the
current object. Authorized users and their
permissions are displayed in the text box below.

Add

Click Add to add the selected user, in the User
ID field, to the authorized users for the current
object.

Add All

Click Add All to add all of the users in the
drop-down list to the authorized users for the
current object.

Remove

Click Remove to remove the selected user or
group of users from the authorized users.
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Table 60. Security Options (continued)

Field

Description

Permissions

* Read

Check the Read check box to allow the user
or user group to view the current Public
Favorites and run the objects in it.

* Write
Check the Write check box to allow the user
or user group to modify properties of the
current object and add reports and folders if
the selected item is a folder.

e Administer

Check the Administer check box to allow the
user or group of users to grant or revoke
access to the current object.

Take ownership

Click Take ownership to grant ownership of
the current object to the user or user group.
Note: This option may not be available,
depending on your resource limits.

Use these settings for all reports
under this folder

Check this check box to apply the security
settings to all reports and subfolders contained
in the current folder

REPORT PROPERTIES - GLOBAL VARIABLES TAB

The Global Variables page of the Report Properties window opens when you
select Report--> Properties, then click the Global Variables tab.

The following are rules for global variables:

 If a global variable is set at the main folder level, then the global variable is
set for each report in the folder when the folder is run.

* If a global variable is set at the report level, it becomes the default for the
report. If a folder is run and the folder has the same global variable value
as the report, then the report value is used.

* If a global variable is set at the sub-folder level and a global variable has
been set from the folder being run or from the individual reports, then the
global variable for the sub-folder is ignored.
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Table 61. Global Variables Options
Field Description

Variable Name Type the name of the global variable in the
highlighted text box.

Global variable names must be unique, they are
not case-sensitive, and they can begin with an
ampersand (&).

Variable Value Type the value for the variable in the
highlighted box.

Add Click Add to add a global variable.

Remove Click Remove to remove a global variable.

Run Click Run to run the SQL.

Add to Favorites
Select Report--> Add to Favorites to add a pointer in your Favorites folder to

the selected table, procedure, or query on a server.

The report will be added to the top of your Favorites folder with the
following naming convention:

Objecttype OWNERNAME.OBJECT NAME

For example:
Query QMFGUEST."SELECT"

Create shortcut
Select Report--> Create shortcut to create a shortcut (.qrs file) to a report in

your Favorites at a specific location.

You can create a shortcut to reports in your Favorites folder. The shortcut
enables you to access a report by launching QMF Report Center and locating
the report using the shortcut.

Follow these steps to create a shortcut:

1. Select a report.

Drag the report to your Favorites folder.

Select Report--> Create shortcut.

Specify the filename and location for the shortcut.
Click OK.

The file extension .qrs is added to the filename.

a kN

6. Double-click the shortcut to launch the report.
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QMF for Windows opens, runs the report, then closes. The report remains
open.

Note: Shortcuts are launched when the report name is found.

Save changes to Public Favorites
Select Report--> Save changes to Public Favorites to save report changes in

the Public Favorites folder.

New Report linked to locally saved query
Select Report--> New Report linked to locally saved query to create a report

by selecting a query saved locally on your network or workstation.
1. Select the Favorites folder.
2. Select Report--> New Report linked to locally saved query.
The Locate the QMF for Windows query to link to dialog box opens.
3. Select the query.
The query is added to the Favorites folder.

Note: Only the SQL and server information are used. Other options saved
with the .qry file are ignored.

Editing SQL in QMF Report Center

Follow these steps to edit SQL for a report in QMF Report Center. This is the
only situation where SQL can be edited by QMF Report Center.

1. Locate the report on your local machine.
2. Double-click on the report.

3. Edit the QMF object text.

4. Save the changes.

New folder
Select Report--> New folder to create a folder within the current folder.

Empty recycle bin
Select Report--> Empty Recycle Bin to remove the deleted items from the
Recycle Bin.

Exit
Select Results--> Exit to exit from QMF Report Center.
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Edit menu

Cut
Select Edit--> Cut to remove an item from the active document.

Optional: Select Edit--> Paste to paste the item at another location.

Copy
Select Edit--> Copy to copy the item, then select Edit--> Paste to paste the

copied item at another location.

Paste
Select Edit--> Paste to paste the item, that was copied or cut, at the insertion

point.

Delete
Select Edit--> Delete to delete an item and add it to the Recycle Bin. QMF

objects that reside on a server are not added to the Recycle Bin.

Rename
Select Edit--> Rename to change the name of the item.

View/Change Server
Select the Edit--> View/Change Server option to view or edit the server

associated with the report without initializing the report at the server.

The View/Change Server dialog box opens.
Table 62. View/Change Server

Field Description

Current server This field displays the name of the server the report runs
on

Available Servers The Available Servers list box lists the servers available to
run the report

The list of servers is disabled when:

¢ the report is in the Public Favorites folder and you do not have permission
to run the report, and

* the report is a locally-bound, server-dependent static query

Note: Because the query is not initialized to determine if it is static, you
can change the server but it will fail to run.
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View menu

QMF Names
Select View--> QMF Names to display the name view of tables, forms,

procedures, and queries. This option toggles with the QMF Comments option.

The QMF Name is taken from the "Save As” name when the report was
created.

QMF Comments
Select View--> QMF Comments to display the comment view of tables, forms,

procedures, and queries. This option toggles with the QMF Names option.
The QMF Name view displays for objects that do not have comments.

Objects on the server can have comments that include descriptive information
about the object. These comments are assigned to the object when the object is
created. You cannot modify comments.

Comments are displayed for the current level and all levels below. For
example, if you select QMF queries, all owners and objects contained within
QMF queries are displayed with comments.

Note: Retrieving comments can be a time-consuming process. To save
resources, you can view comments for a particular object, rather than
viewing comments for all objects of the same type.

QMF Object text
Select View--> QMF Object text to open the Query Text dialog box, which

displays the object name and the SQL for the object. For example:

Table: DB2ADMIN.MAX_T
Select * from DB2ADMIN.MAX T

Note: You cannot edit the QMF object text using this function unless it is a
local query (.qry) that has not been statically bound to a server.

Report Comments
Select View--> Report Comments to open the Report Comment dialog box

where you can view or type comments for the report.

Filter options
Select View--> Filter options to specify display options for the object. You can

filter by any of the following for the object owner and object name:
* Tables

* QMF queries

* QMF procedures

* QMF forms
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* Public favorites
* DB2 forms

Server filter options
Select the View--> Server filter options option to select the servers to hide

from the QMF Report Center directory tree. The Select Servers to Hide dialog
box opens and it lists the servers included in the SDF (Server Definition File).

Check the check box next to each server you want to hide, or click Select All
or Clear All. You can run reports against hidden servers.

Text size
Select View--> Text size to specify the relative display size of text in QMF

Report Center.

Scheduled jobs
Select View--> Scheduled jobs to view, edit, delete, and set properties for

scheduled reports.

The QMF Scheduled Jobs dialog box opens. The dialog box provides
information about scheduled jobs, including the report name, interval, day of
the week, day of the month, time, type of object, server, and QMF object
name.

* Select Report--> Properties, then click the Schedule tab to define schedule
information for a job

See [“Scheduling reports” on page 169 for more information about
scheduling jobs.

* Click Edit to open the Schedule Job dialog box where you can work with
job execution information.

Report history
Select View--> Report history to open the Report History dialog box, which

provides details for reports run, in chronological order.

The history captured for the report includes the date run, the report name, the
application, the file location, and the file size.

Table 63. Report History command buttons

Click this button To do this

Clear Selected Click Clear Selected to clear a specific history file
from the overall report history

Delete Files Click Delete Files to delete all history files for the
report

View Report Select a history file, then click View Report to open
the report
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Activity log

Select an object then select View--> Activity log to open all activities in
chronological order. The activity log contains detailed information on reports
run and errors encountered during QMF Report Center operations.

Refresh
Select View--> Refresh to obtain an updated view of the directory tree, which

will reflect any recent changes made to objects on the server. If the Prompt me
with this filter every time check box is checked on the Filter Options dialog
box, the Filter Options dialog box opens each time you click Refresh.

Tools menu

Set user information
Select a server, then select Tools--> Set user information to log in as another

user, or specify account information.

The Set User Information dialog box opens.
1. Type the user ID in the User ID field.
2. Type the password in the Password field.

3. Optional: Check the Remember this password check box to retain the
password.

4. Optional: Type an account number in the Account field to type an
accounting information string that the database server uses to track system
usage. The use of accounting string information is determined by your
database administrator.

5. Optional: Check the Use this information for ever server I connect to
check box to use the user information entered on the Set User Information
window for connecting to all database servers.

If this check box is checked, QMF for Windows will use the same user 1D
and password for all connections unless you open the Set User
Information dialog box and uncheck the check box.

Run QMF for Windows
Select Tools--> Run QMF for Windows to open QMF for Windows while

QMF Report Center remains active.

Note: You must have permission to use QMF for Windows in your resource
limits.

Export favorites
Select your Favorites folder, then select Tools--> Export Favorites to export a

report in your Favorites folders to a .qrs file.
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The Export Favorites dialog box opens. A message prompts you to export
subreports contained in subfolders. Check the When importing overwrite
existing favorites check box on the Export Favorites dialog box to overwrite
objects of the same name. Click Yes.

The Export dialog box opens. Specify where to export the Favorites folder.

Import favorites

Select Tools--> Import Favorites to import a .qrf file (Favorites file) to your
Favorites folders. The Import dialog box opens. Specify the location of the

import file.

Options

Select Tools--> Options to set optional parameters for QMF Report Center.
The Global Options window opens.

ACTIVITY LOG

Select Tools--> Options then click the Activity Log tab to open the Activity

Log page.

Table 64. Global Options - Activity Log

Field

Description

Enable activity tracking

Check this check box to record all QMF Report Center
activity and error messages in the log file,
QMF_RCLOG.txt.

Location of activity log

Specify the full path and directory for the activity log
file.

Optional: Click Select to browse for the location.

Delete log Click Delete log to delete the activity log. A new log is
created the next time you perform a task in QMF
Report Center.

View log Click View log to display the activity log file in your

default text viewer.
Note: Do not edit this file.

CREATING FAVORITES

Select Tools--> Options then click the Creating Favorites tab to open the

Creating Favorites page.
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Table 65. Global Options - Creating Favorites

Field

Description

Prompt only if a conflict
occurs

Check this check box to hide informational messages
when the report runs unless a conflict requires action

Suppress all error messages

Check this check box to hide error messages when the
report runs

View report after publishing

Check this check box to open the finished report

Overwrite file if it already
exists

Check this check box to replace an report in your
Favorites folder

Select output application

Select the application from the drop-down list with
which to view or modify reports.

Click Options to provide more information about the
output application. The Options command button is
available if you selected Microsoft Excel, Lotus 1-2-3,
Microsoft Access or a printer as the output application.
See [‘Options” on page 195| for more information about
output application options.

Publish to a temporary file,
in the following directory

Select this radio button to save the report to a
temporary file in the selected directory.

Use the temporary directory
of the machine running this
report

Check this check box to save the report to the
temporary directory of the machine from which the
report is being run.

Start file name with

Type the prefix used with the filename, if applicable.

End file name with

Select a date format that will be used as a suffix to the
filename.

Select "Random” for QMF Report Center to generate a
unique filename so that previous reports are not
overwritten.

Publish to

Select this radio button to specify the filename to use
for the report

Optional: Click Select to browse for the filename.

A dialog box opens where you can specify a filename
based on the application you selected in the Select
output application field.
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Table 65. Global Options - Creating Favorites (continued)

Field

Description

Select the type of formatting
for your report

Specify how to return data to the report:
* No formatting (data only)

Select this radio button to return raw, unformatted
data to the file

— Include column headers

Check this check box to add labels to report
columns

* Default formatting

Select this radio button to return data in the default
QMF format, which includes column headers and a
horizontal line to separate headers and data

CREATING FOLDERS

Select Tools--> Options then click the Creating Folders tab to open the

Creating Folders page.

Table 66. Global Options - Creating Folders

Field

Description

Prompt only if a conflict
occurs

Check this check box to hide informational messages
unless a conflict requires action

Suppress all error messages

Check this check box to hide error messages for objects
in the new folder

Prompt for variable values
prior to running reports

Check this check box to prompt for variable input for
each underlying report in a folder

Do not display any of the
reports being run

Check this check box to produce the report without
opening it. Instead, you can view the report by
selecting View--> Report history.

Continue running
subsequent reports if an
error occurs

Check this check box to continue running other reports
in this folder even if errors occur

MISCELLANEOUS

Select Tools--> Options then click the Miscellaneous tab to open the

Miscellaneous page.
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Table 67. Global Options - Miscellaneous

Field Description

Display ‘Save As’ dialog Check this check box to open the ‘Save As’ dialog box
every time you make changes to QMF objects residing
on a server.

Display "Security for Check this check box to be prompted with a reminder
Scheduled Job” dialog to set user and password information when you
schedule a new job.

Display “Internet Mail Check this check box to open the first page of the
Wizard” introductory page |Internet Mail Wizard when you select Report
Properties--> Miscellaneous, then click Properties.

Display "About to send Check this check box to be prompted with a message
email’ message for folders |each time you run a folder for which you selected the
Attach all underlying report output to email message
option on the Miscellaneous dialog box. The message
indicates the number of reports contained in the folder
and gives you the option of canceling the email

messages.

Display ‘Report formatting | Select this option to be prompted to enter variable

variable’ prompt values for reports using Microsoft Excel or Lotus 1-2-3
as the output application so column headers can be
retrieved.

Display "Unique columns Select this option to be prompted with a message that

needed for grouping’ you can only select unique columns when setting

warning grouping options in the Data Grouping and Charting

options for Microsoft Excel or Lotus 1-2-3.

Help menu

Contents
Select Help--> Contents to display the table of contents for the online help

system.

About
Select Help--> About to display QMF Report Center copyright information.

Associating forms with objects

Forms contain formatting for QMF query results. Forms need to be associated
with a query or table.
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Procedure

Option 1
Drag a form from the server on top of a query or table in your Favorites
folders. The form is associated with the object automatically.

Option 2
1. Select an object in your Favorites folders.
2. Right-click and select Properties.
3. Click the Formatting tab to open the Formatting page.
4

. Select the QMF formatting from form radio button to open the Form
Filter dialog box.

5. Type information in the Object owner and Object name fields to locate
the form. You can use wildcards.

The Select a Form dialog box opens.
Select a form.

Click OK.

Click Run to run the report.

Click OK.

The Save as dialog box opens.

© © N o

10. Specify save options.

Copying reports, objects, and folders
You can copy reports, objects, and folders from a server or within your
Favorites folders.

Copy from a server

There are several ways to copy an item from a server:
* Drag the item from its current location to another location
* Select the item, right-click, then select Copy
* Select the item, then select Edit--> Copy

Paste to server
Right-click on the location to paste the item, then select Edit--> Paste.

A confirmation dialog box opens, and the item is added to the bottom of the

selected folder.
Copy within your Favorites folders

Use the copy and paste method described in the|“Copy from a server”|section

to copy reports within your Favorites folders.
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Note: Reports are moved, not copied, if you drag reports within your

Favorites folders.

Moving reports, objects, and folders

You can move reports, objects, and folders on a server and within your
Favorites folders.

Procedure

Option 1

1.

ok wbn

Select the item.

Right-click.

Select Edit--> Cut.

Right-click on the location where the object is being copied.
Select Paste.

Option 2

1.

2.
3.
4.

Select the item.

Select Edit--> Cut.

Right-click on the location where the object is being copied.
Select Edit--> Paste.

Note: When you drag an item, you make a copy of the item, except when
you work in your Favorites folders.

Deleting reports, objects, and folders

Reports and folders deleted from your Favorites folders are sent to the
Recycle Bin. Objects and reports deleted from the server are deleted
permanently.

Note: You may not have permission to delete items from the server.

Procedure
Select one of these options to delete reports, objects, or folders:

* Select the item, right-click, then select Delete
¢ Select the item, the select Edit--> Delete

Note: The task scheduler must be running to delete a report with scheduled

jobs and then remove it from the Recycle Bin.
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Copying tables on a server

You can copy tables between locations on a server, and you can copy tables
between servers. When you copy a table, you only copy the data, not the table
itself.

Procedure
Select one of these options to copy tables on a server:

* Drag the table (the folder or the individual tables) to the Tables object
section of another server

* Select the table, right click, and select Copy
* Select the table and select Edit--> Copy

The Save Data dialog box opens.

Refreshing objects

Refresh objects periodically because objects on a server can change while you
are using them.

Procedure

Select an object on a server, then select View--> Refresh. The Object Filter
dialog box opens. Click OK.

Note: All options are inactive when you refresh an object because you are
refreshing the view for the object and all objects below the current
level. Alternatively, all options are active when you refresh a server.

Tips and time-savers

To run reports simultaneously
Group all reports that can be run simultaneously into a folder. Instead of
running each report individually select the folder, then select Report--> Run.
All reports in the folder are run consecutively.

To run reports as a separate process
Check the Run as a separate process check box on the Report Properties-->
Miscellaneous page to run reports in the background while you continue to
work.

To limit rows returned

You can limit the number of rows of data that are returned to your report to
reduce processing time.

1. Select Report--> Properties.
2. Click the Miscellaneous tab.
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3. Type a number in the Limit the number of rows returned field.
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Chapter 16. APIs

This chapter describes how an application can access the queries stored in the
QMF query repository and manipulate them. QMF for Windows has a set of
application programming interfaces (APIs) that enable the application to
execute these functions.

What is an API?

An API contains pre-defined functionality that the application can use to
execute a function without any knowledge on how the function is performed.
An API has well-defined inputs and outputs but the process is transparent.
An API is useful when dealing with device drivers for hardware or software
packages.

Most programming languages designed for Windows can access the APIs. The
method by which this is done varies between programming languages, but all
languages have a way of calling the APIs. Once the APIs are included in the
programming language environment, using them is like a regular function in
the program.

Any programming language that accesses the Windows API can access the
QMEF for Windows AP], including IBM Visual Age for Java.

You do not need extra middleware to develop an application using an AP],
beyond the middleware required for the end-user. This means that there are
no special prerequisites for developers. The basic middleware is the
middleware necessary for the network environment, the installation of QMF
for Windows on the computer, and the programming language used. The
same thing happens with the final application that you distribute to your
users. The only middleware necessary for the application to run is the
middleware for the network and QMF installed within the environment.

Blocking calls

QMF for Windows API functions are synchronous. When an API is called in
an application, it blocks, or does not return, until the requested action
completes. The code just below the line calling the API will not be executed
until the API completes its function. This implementation is simplifies
programming in the client application. However, if the application is
single-threaded, it will not be able to respond to user input or perform screen
refreshes while it is waiting for a QMF for Windows API function to return.
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The QMF for Windows API responds to one function call at a time from a
client. If the client application is multi-threaded, you must:

* wait for one function call to complete before making another, or

* create multiple instances of the QMF for Windows API (one instance for
each thread using the API)

If it is necessary for the application to be synchronous, the programmer has to
create a new thread within the application and call the API from the new
thread. The new thread will then be blocked, but all other threads will
continue to execute normally. The programmer has to manage the timing and
execution of the threads.

When developing multi-threaded applications, note that the QMF for
Windows API responds to one function call to complete before making
another, or create multiple instances of the QMF for Windows API (one for
each thread using the API).

Unit of work

Each instance of the QMF for Windows API object represents a single "unit of
work,” and can connect to a single database server. To connect to multiple
database servers simultaneously, you need to create multiple instances of the
QMEF for Windows API object, one instance for each database server. To
connect to multiple database servers serially (one after the other) using the
same QMF for Windows API object, call Commit() or Rollback() and then
InitializeServer(). Calling these functions ends the current unit of work, and
subsequent calls start a new unit of work.

Governing

One of the key features of QMF for Windows is its ability to govern, or
oversee, your use of database resources based on the resource limits
established by your system administrator. The QMF for Windows API
enforces all resource limits except warning level limits. When you reach a
cancel limit, QMF for Windows generates an error indicating that the current
action has been disallowed by your system administrator.

Database connections

Each instance of the QMF for Windows API object creates and uses a single
connection to the database for all database activity that is subject to a
subsequent rollback or commit, including opening a query, fetching data, and
executing SQL statements.

If you create more than one query in a given instance of the QMF for
Windows API object by calling InitializeQuery() two or more times, the
queries will share the same single connection. QMF for Windows creates and
uses a second connection to the database to handle administrative database
activity (such as retrieving QMF information) when you call:

204 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



* n DeleteQMFObject()

* n GetQMFODbjectInfo()

* n GetQMFODbjectInfoEx()
* n GetQMFODbjectList()

* n GetQMFODbjectListEx()
* n GetQMFQueryText()

* n SaveQMFQuery()

This second connection is necessary to support a consistent rollback and
commit mechanism for client applications.

The QMF for Windows API object handles these connections automatically to
the database; however, if your system administrator has established a limit for
the number of connections allowed, note that each instance of the QMF for
Windows API object may use two connections.

Controlling QMF for Windows with APls
The following steps describe how to work with the API to control QMF for
Windows:
1. Create an instance of the QMF for Windows API object.

If you are using Microsoft Visual Basic, add a reference to the QMF for
Windows type library, gnfwin.t1b. Then use the Dim statement:

Dim QMFWin As New QMFWin

Or, use the CreateObject statement:

Dim QMFWin As Object
Set QMFWin = CreateObject("QMFWin.Interface")

If you are using Microsoft Visual C++ and MFC, create a wrapper class for
the QMF for Windows API object from the QMF for Windows type library
gmfwin.tle. Then use the CreateDispatch(() function:

COleException e;
IQMFWin QMFWin;
QMFWin.CreateDispatch("QMFWin.Interface", &e);

Note: If you are using a different development environment, refer to your
product documentation on how to complete this step.

2. Select the DB2 server you want to use and call InitializeServer() to
initialize a connection to the database.

Note: You cannot initialize a server until a user ID and password are
validated by DB2. You can have QMF for Windows prompt for the
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user and password, or you can prompt for user information in your
application and pass them as parameters in the InitializeServer()
function call.

3. Select the query you want to run using InitializeQuery(). If the query
contains variables, use the SetVariables() function to set the variable
values.

4. Open or execute the query. Use the Open() function to open the query’s
cursor for SELECT statements. Use the Execute() function to execute the
SQL for non-SELECT statements.

5. If the query is a SELECT statement, fetch rows of data by repeatedly calling
FetchNextRow(). To fetch more than one row at a time, use
FetchNextRows(), or use CompleteQuery() to direct QMF for Windows to
fetch all of the rows.

6. If the query is a SELECT statement, close the query using the Close()
function.

7. Terminate the unit-of-work using the Commit() or Rollback() functions.

QMF for Windows APIs

APl example

AddDecimalHostVariable()

short AddDecimalHostVariable(long QueryID, short Type, short Precision,
short Scale, const VARIANT& Value)

Description

This function applies the data in Value to a variable in the static SQL
statement initialized with QueryID. You call this function for each variable in
the statement. QMF for Windows does not match values to variables, so you
need to call this function in the same order as the variables in the SQL
statement.

Parameters

Table 68. AddDecimalHostVariable() Parameters

Name Description
QueryID The ID of the query as returned from InitializeStaticQuery().
Type The SQL data type of the value to be passed to the database

server. This value influences the conversion of Value from a
VARIANT data type to the value actually passed. The only valid
value for AddDecimalHostVariable() is 484 (RSDT_DECIMAL).

Precision The precision of the decimal value.
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Table 68. AddDecimalHostVariable() Parameters (continued)

Name Description

Scale The scale of the decimal value.

Value The data value to substitute in the statement. To specify a null
value, set the type of the variant to VT_EMPTY.

Return Value

Zero if successful, nonzero if unsuccessful. If the return value is nonzero, you
can call GetLastErrorString() or GetLastErrorType() for additional error
information.

Additional information
For additional information about the APIs for QMF for Windows, see the
online help for QMF for Windows. The online help discusses APIs in detail,
and lists the APIs by name, description, parameters, and return values.
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Chapter 17. Global variables

Global and substitution variables

Global variables stay active while the QMF instance (session) is active, or stay
active permanently by updating the Windows registry. Substitution variables,
however, stay active only during execution of the object.

Global variables are associated with QMF for Windows and the operating
system’s registry (if you update the registry to make global variables
permanent). Substitution variables are associated with QMF objects.

Because global variables are active while QMF for Windows is active, the
variables will have the same value until the instance of QMF for Windows is
finished. The global variable can be accessed by all QMF objects. Different
instances of QMF cannot see the global variables for another instance.

There are two types of global variables:
* user-defined global variables
* pre-loaded (system) global variables

A global variable can be used in a query, form, or procedure. You can update
global variables by selecting View--> Global Variables.

The global variables provided by QMF for Windows are stored in the
Windows registry. The system administrator can view and edit the system
global variables before installation. Global variables can be exported to all
users by copying the variables from one system to another after installation to
keep the variables in sync. The global variables are located in the following
path in the Registry:
HKEY_CURRENT_USER\SOFTWARE\IBM\RDBI\GlobalVariables
Global variables in procedures

1. Create or open a procedure.
2. Type global information in the procedure, such as:

SET GLOBAL(MY_GLOBAL=20
3. Optional: Add multiple variables, such as a string of variables:

SET GLOBAL(MY_GLOBAL=20,START_DATE=&DATE,DEPARTMENT=&DEPT

This example lists each variable and uses the SET GLOBAL command only
for the first time:
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SET GLOBAL(MY_GLOBAL=20,
START_DATE=&DATE,
+DEPARTMENT=&DEPT

4. Type the following command as the last line in the procedure:
RESET GLOBAL ALL

Note: This command resets the user variables.

Updating the registry

You can create global variables for the current work session. These are known
as user-defined variables. These variables are lost when you close QMF for
Windows because the variables are session variables.

Follow these steps to retain user-defined global variables:
1. Open the Windows Registry.
2. Go to the following location in the registry:
HKEY_CURRENT_USER\SOFTWARE\IBM\RDBI\Options
3. Select Edit--> New--> DWORD Value.
4. Label the DWORD, SaveGlobals.
5. Type a1 for the SaveGlobals global variable.
The user-defined variables will be retained between sessions.

After you update the registry, the global variables that you create will be
stored in the Windows Registry and will be kept from one instance to another.

You can add your own global variables manually or during a procedure.

Note: You cannot add a global variable with a DSQ prefix because these
global variables are pre-loaded with QMF for Windows.

Also, you cannot change the value of a global variable with a DSQAO
prefix.

User-defined global variables

The user-defined global variables are global variables used for executing
queries, procedures or forms. In a query or procedure, no dialog box opens
for you to enter a value if you created a user-defined global variable. Instead,
the value specified for the global variable will be used.

Adding variables manually
Follow these steps to create global variables manually:
1. Select View--> Global Variables.
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2. Click Add.
The Add Global Variable dialog box opens.
3. Type the global variable name and its value.

Global variable names must be between 1-17 characters. Global variable
values must be between 1-55 characters.

Note: You cannot prefix the name of a new global variable with DSQ
because this is the prefix for system global variables.

4. Click Add.

Adding global variables in procedures
Follow these steps to add a global variable in a procedure:
1. Create or open a procedure.
2. Add global information to the procedure such as:
SET GLOBAL(MY_GLOBAL=20
3. Optional: Add multiple variables, such as:
* With a string of variables:
SET GLOBAL(MY_GLOBAL=2,START_DATE=&DATE,DEPARTMENT=&DEPT

* With a list of each variable that uses the SET GLOBAL command only
for the first line:

SET GLOBAL(MY_GLOBAL=2,
+START_DATE=&DATE,
+DEPARTMENT=&DEPT

4. Type the following command as the last line in the procedure:
RESET GLOBAL ALL

Editing a global variable
Click Edit to change the name or value of a user-defined global variable.

Deleting a global variable
Click Delete to remove a user-defined global variable.

System global variables

QMF for Windows has a set of global variables that is pre-loaded with the
product. Select View--> Global Variable to view the system global variables.

Note: Tooltips are available for each global variable defined for QMF for
Windows.

Restrictions

Because system global variables are hard-coded into a procedure, you cannot
change or delete status information for the system global variable. Under
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some circumstances, however, you can change the value of the system global
variable. You cannot change the name of a system global variable.

The global variables defined for host QMF are recognized by QMF for
Windows, but may not apply to QMF for Windows. Any references to queries,
forms or procedures to QMF host global variables that are not supported by
QMF for Windows are ignored. Only the variables listed below are used and
are accessible by QMF for Windows. If QMF for Windows does not recognize
a global variable it will be used as a substitution variable at run time.

Global variables prefixed with DSQQW are QMF for Windows global
variables. All other global variables prefixed with DSQ are supported by
QMEF for Windows and host QMF.

Viewing variable values
Follow these steps to view the values for a global variable:
1. Select View--> Global Variables.
2. Click on a global variable.

Note: You cannot view the value for system-level global variables that are
prefixed with DSQAO.

The following message is issued if you try to change a system-level
global variable:

You cannot set the value of [ 1.
3. Click OK.
The Change Global Variable Value dialog box opens.
4. Select a variable from the drop-down list.
5. Click OK.

For example, select one of the following global variable values for the
DSQEC_FORM_LANG global variable:

0 - Use NLF Tanguage when saving forms
1 - Use English language when saving forms

Naming convention
The naming convention for global variables is:

DSQCC_XXXXXXXXX

where DSQcc can be one of the following category identifiers:

Table 69. Global Variable Naming Convention

Identifier Description

DSQAO State information (controls administrative objects)

212 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



Table 69. Global Variable Naming Convention (continued)

Identifier Description

DSQCP Table Editor information

DSQDC Display information for QMF for Windows

DSQEC Command and procedure execution information
DSQQW Environment information specific to QMF for Windows

State information variables

Global variable names prefixed with DSQAOQO provide state information about
QMF for Windows.

Note: None of these variables can be modified by the SET GLOBAL command.

Table 70. State Information Global Variables

Global variable Length Description

DSQAO_BATCH 1 Batch or interactive mode. The value
can be 1 (interactive session) or 2 (batch
session).

See /Batch command parameter.

DSQAO_CONNECT_ID The ID used to connect to the current
database.
DSQAO_CURSOR_OPEN |1 Status of current query’s database

cursor. Value can be:

e 1 = cursor is open

* 2 = cursor is closed
DSQAO_DBCS 1 DBCS support status. Value can be:
* 1 = DBCS support

e 2 = DBCS support is not present

DSQAO_NLF_LANG 1 National language ID.
DSQAO_NUM_FETCHED |10 Rows fetched by current query object.
DSQAO_OBJ_NAME 18 Name of current QMF object (query,

form or procedure).
Note: This value is blank if there is no
current object.

DSQAO_OB]_OWNER 8 Owner of current QMF object (query,
form or procedure).

Note: This value is blank if there is no
current object.

DSQAO_QMF_RELEASE |2 Application release number.
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Table 70. State Information Global Variables (continued)

Global variable Length Description

DSQAO_QMF_VER_RLS |10 Application version and release
number, such as QMF V8RI1.

DSQAO_QRY_SUBTYPE 1 Subtype of current query. Value can be:

* 1=5QL query
* 3 = prompted query

DSQAO_QUERY_MODEL |1 Model of current query. Value can be 1
(relational).
DSQAO_SYSTEM_ID 1 Operating system (OS). Values can be:

* 6 = Windows 3.x
e 7 = Windows 95 or Windows 98
¢ 8 = Windows 2000 and Windows NT

Table Editor variables

Global variable names prefixed with DSQCP control the operation of the
Table Editor. You can also modify these variables with the SET GLOBAL
command.

Table 71. Table Editor Global Variables

Global variable Length Description

DSQCP_TEDFLT 1 Default character for a column in
QMF Table Editor. The default value
is "+’. You can also set this value at
the Options dialog box.

DSQCP_TENULL 1 Default character for a NULL
character for a column in QMF Table
Editor. The default value is ’-’. You
can also set this value at the Options
dialog box.

Display information variables

Global variable names prefixed by DSQDC control how QMF for Windows
displays information. You can also modify these variables with the SET
GLOBAL command.

Table 72. Display Information Global Variables

Global variable Length Description
DSQDC_CURRENCY 18 Custom currency symbol for DC
edit code.
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Table 72. Display Information Global Variables (continued)

Global variable

Length

Description

DSQDC_DISPLAY_RPT

1

Display a report after RUN QUERY.
The value can be:

* 0 = the default, do not display a
report

* 1 = automatically display the
report with the form

DSQDC_LIST_ORDER

Default sort order for objects in
List window.

The value for the first character can
be:

* 1 = default order.

* 2 = sort by object owner

* 3 = sort by object name

* 4 = sort by object type

The value for the second character
can be:

e A = sort in ascending order. This
is the default.

¢ D = sort in descending order

Note: The default value is 1A.

Command and procedure variables

Global variable names prefixed with DSQEC control how QMF for Windows
executes commands and procedures. You can also modify these variables with

the SET GLOBAL command.

Table 73. Command and Procedures Global Variables

Global variable Length Description
DSQEC_FORM_LANG 1 Default NLF language for saving or
exporting a form. Value can be:
¢ 0 = presiding NLF language
* 1 = English. This is the default.
DSQEC_NLFCMD_LANG 1 Expected NLF language for

commands in procedures. Value
can be:

* 0 = presiding NLF language.
This is the default.

* 1 = English
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Table 73. Command and Procedures Global Variables (continued)

Global variable Length Description

DSQEC_RESET_RPT 1 Prompt when handling an
incomplete data object. Value can
be:

¢ 0 = complete the data object
without prompting

* 1 = prompt the user to complete
the data object

¢ 2 = reset the data object without
prompting

DSQEC_SHARE 1 Default value for sharing saved
objects. Value can be:

¢ 0 = do not share the object
* 1 = share the object

Windows environment variables

Global variable names prefixed with DSQQW are specific to the QMF for
Windows connections. You can also modify these variables with the SET
GLOBAL command.

Table 74. Windows Environment Global Variables

Global variable Length Description

DSQQW_AUTOMATION 1 Indicates whether the current instance
of QMF for Windows was started to
service OLE automation requests
(value is 1) or to service the user
interface (value is 0).
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Table 74. Windows Environment Global Variables (continued)

Global variable

Length

Description

DSQQW_CONNECTIONS

1

Use server connections while running
a procedure. This setting controls the
number of server connections for
procedures.

* 0 = minimize the number of
connections. This is the default.

Specifying a value of 0 can force
QMF for Windows to reset or
complete a data object before
continuing the execution of a
procedure.

If set to 0, you specify a linear
connection, which means that the
first query must complete before
the next is run. These queries are
run in a series.

e 1 = all: a new connection for each
RUN QUERY command

If set to 1, subsequent connections
are opened so the queries are run
in parallel (at the same time).

Note: This global variable is designed
to be used with
DSQQW_FST_SV_DATA (by which
the query will be PREPARED only on
RUN QUERY.

DSQQW_DQ

Double-quote character

DSQQW_EXP_DT_FRMT

Format for EXPORT DATA. Value can
be:

* 0 = text. This is the default.

e 2 =html

* 3 = csv (comma-separated value)
° 4 =ixf

For the EXPORT command, you can
export the report to a file name with
a file type of .qmf, .html or .txt.
Note: In a procedure (with a .txt file
type), if no options are specified as
delimiters, the default is spaces.
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Table 74. Windows Environment Global Variables (continued)

Global variable

Length

Description

DSQQW_EXP_OUT_MDE

1

IXF mode for procedures. Value can
be:

* 0 = System/370 character mode
IXE. This is the default.

e 1=PC/IXF

DSQQW_FST_SV_DATA

Use 'Fast Save” mode for SAVE DATA.
Value can be:

¢ 0 = do not use fast mode. This is
the default.

¢ 1 = use fast mode

DSQQW_HTML_REFTXT

55

Text for &REF form variable. The
default is ‘Back To’.

DSQQW_PROC_OUTPUT

Report Center will pass the path
name and file name to a procedure
that uses &DSQQW_PROC_OUTPUT.

EXPORT REPORT TO
&DSQQW_PROC_OUTPUT

Alternatively:

EXPORT DATA TO &DSQQW_PROC_OUTPUT

DSQQW_QUERY_LANG

Subtype of query created by DISPLAY
QUERY when no query object exists.
Value can be:

¢ 0 =SQL. This is the default.
* 1 = prompted

DSQQW_QUERY_PREP

Prepare the query on a RUN command
instead of running. This option
invokes the PREPARE SQL command.

DB2 will check the query syntax and
the existence of every object
associated with the query. Internal
calculations will be performed, but no
data will be sent to the client.

This option can be used to validate
queries with complicated calculations
or ones that will return significant
data. Value can be:

* 0=No
* 1=Yes
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Table 74. Windows Environment Global Variables (continued)

Global variable

Length

Description

DSQQW_RPT_COPIES

10

Number of copies for PRINT REPORT.
The default is 1.

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used. If it
is set to 2, the global variable settings
are used.

DSQQW_RPT_FONT

55

Font for PRINT REPORT. The default is
‘Courier New'.

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used. If it
is set to 2, the global variable settings
are used.

DSQQW_RPT_FONT_BD

Bold attribute for PRINT REPORT. The
default is 0.

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used; if it
is set to 2, the global variable settings
are used.

DSQQW_RPT_FONT_IT

Italic attribute for PRINT REPORT. The

default is 0.

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used; if it
is set to 2, the global variable settings
are used.

DSQQW_RPT_FONT_SZ

Font size for PRINT REPORT. The
default is 10.

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used; if it
is set to 2, the global variable settings
are used.

DSQQW_RPT_LEN_TYP

Type of page length for PRINT REPORT.

The value can be:

0 = fit the length of the printed
page. This is the default.

* 1 = specify an explicit number of
lines

* 2 = specify a continuous report
with no page breaks

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used; if it
is set to 2, the global variable settings
are used.
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Table 74. Windows Environment Global Variables (continued)

Global variable

Length

Description

DSQQW_RPT_NUM_CHR

10

Number of characters across a printed
page for PRINT REPORT. This has an
effect only when
DSQQW_RPT_WID_TYP is 1. The
default value is 80.

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used; if it
is set to 2, the global variable settings
are used.

DSQQW_RPT_NUM_LNS

10

Number of lines down a page for
PRINT REPORT. This has an effect only
when DSQQW_RPT_LEN_TYP is 1.
The default value is 60.

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used; if it
is set to 2, the global variable settings
are used.

DSQQW_RPT_ORIENT

Page orientation for PRINT REPORT.
The value can be:
* 0 = portrait. This is the default.

* 1 = landscape

Note: If DSQQW_RPT_USE_PS is set to 1,
the Page Setup options are used; if it
is set to 2, the global variable settings
are used.

DSQQW_RPT_USE_PS

Set of page formatting options (page
length, page length) for PRINT REPORT.
The value can be:

* 0 = use the values specified on the
PRINT REPORT command or in
global variables

* 1 = use the values specified in the
form document’s page setup. This
is the default.

Note: If this value is set to 1, the
Page Setup options are used; if it is
set to 2, the global variable settings
are used.
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Table 74. Windows Environment Global Variables (continued)

Global variable

Length

Description

DSQQW_RPT_WID_TYP

1

Type of page width for PRINT REPORT.
The value can be:

* 0 = fit the width in the printed
page. This is the default.

* 1 = specify an explicit number of
characters.

Note: If this value is set to 1, the
Page Setup options are used; if it is
set to 2, the global variable settings
are used.

DSQQW_SHOW_QUERY

View of a query for SHOW QUERY. The
value can be:

* 0 = SQL or prompted view. This is
the default.

* 1 = results view

DSQQW_STRIP_SPACE

Remove trailing spaces from objects
retrieved from server. The value can
be:

* 0 = retain trailing spaces

* 1 = remove trailing spaces. This is
the default.

DSQQW_SV_DATA_C_S

10

Rows to insert before commit for SAVE
DATA. Value can be:

* 0 = all rows. This is the default.

e n = where n equals an explicit
number of rows

DSQQW_UEDIT_DLL

55

DLL implementing user edit routines.
The default value is rsuedit.d11

DSQQW_PROC_WNDWS

Procedure results options. The values
are:

* 0 = leave the most recent objects
open at the end of the procedure

For example, leave the most recent
query and form open at the end of
the procedure, but not the most
recent procedure.

* 1 = leave all objects open at the
end of the procedure
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Chapter 18. Command line

Use the command line to type a command and select the server at which to
execute the command.

Activate the command line
1. Select View--> Command bar.
The command line is available at the top of all windows.
2. Optional: Type a command in the Run command field.
3. Optional: Select a recent command from the Run command drop-down list
box.
4. Select the server at which to run the command at the At server field.

The At server drop-down list lists the servers defined in your server
definition file (SDF).

Running commands automatically

Settings and actions can be defined to take effect when QMF for Windows is
started. These parameters are defined on the QMF for Windows command
line. They can be used to preset settings or to run unattended sessions.

For help on adding command line parameters to an icon or start menu, refer
to your operating system’s help facility.

Command line parameters

The command line parameters are listed and described below.

Table 75. Command Line Parameters

Parameter Description

ObjectName The QMF for Windows file (query, procedure, job, or
form) that opens when you start QMF for Windows.

/IProcName:procedurename The name of the procedure, which is stored at a
database server, to run after QMF for Windows starts.

Specify the /IServer parameter if the server is different
from the server at which the procedure was created.

/IProcFile:procedurefile The location and name of a locally-stored procedure
file to run after starting QMF for Windows.
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Table 75. Command Line Parameters (continued)

Parameter

Description

/1587’2)81’5581’061’1’11171’16

The server where the startup procedure is stored, as
specified on the /IProcName parameter.

/IObject:" ObjectOwner"."
ObjectName"

The name of an object stored at a database server that
will be retrieved after starting QMF for Windows.

You also need to specify the /IServer parameter.

/Run

Start an opened or retrieved object.

This parameter is used in conjunction with the
/IUserID and /IPassword parameters.
Note: This parameter ignores forms and jobs.

/IDisplay

An opened or retrieved object.

If the /IRun or /IDisplay parameters are not specified,
then the /IDisplay parameter will be used.

/IUserID:userID

The user ID to use when running an object specified
with any of the following parameters:

» /IProcName
» /IProcFile

* ObjectName
¢ /IObject

The /IUserID:userID parameter is used in conjunction
with the /IPassword parameter.

/IPassword:password

The user’s password specified with the /[UserID
parameter.

Note: The /IPassword parameter includes the user’s
password in plain text.

/Batch

End the current session and close the application after
running the object specified on the command line.
Note: This parameter suppresses all warnings and
error messages.

&wvariablename-variablevalue

Define or update global variable values for a
procedure or query. Multiple variables can be
defined.

Note: The value sent to the procedure must be
enclosed in double quotes (" ").

/ICatalogUserID

The user ID to use when connecting to an ODBC data
source. It is used in conjunction with the
/ICatalogPassword parameter.
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Table 75. Command Line Parameters (continued)

Parameter

Description

/ICatalogPassword

The user’s password, as specified with the

/ICatalogUserID parameter. This parameter is used
when accessing ODBC data sources.

ICatalogUserID The the user ID for the catalog server associated with

the /IServer parameter.

The ICatalogUserID parameter is used in conjunction
with the /ICatalogPassword parameter.

ICatalogPassword The user password associated with the

/ICatalogUserID parameter.
Note: The /ICatalogPassword parameter includes the
user’s password in plain text.

Sample task

Follow these steps to use the command line:

1. Create a procedure.

For example,

run query ObjectTracking (form=ObjectTrackingForm
export report to c:\gmftrack.rep
windows notepad c:\gmftrack.rep

This example executes a query called ObjectTracking using the form called
ObjectTrackingForm for report generation. The procedure exports the
report to a file called qmftrack.rep at the local system in the c:\directory.
Then, in the Windows Notepad c:\gmftrack.rep line of the procedure, the
saved report file is opened using Notepad.

Save the procedure at the server or as a local file.
For example,

c:\procedurel.prc

Run the procedure.

Type the following command in the Run command field if the procedure
was saved at the server:
"C:\Program Files\IBM\QMF for Windows\gmfwin.exe" /IServer:DB2AIX
/IProcname:DB2INST1.Procedurel /IUserID:db2instl
/IPassword:db2instl
Type the following command in the Run command field if the procedure
was saved locally:
"C:\Program Files\IBM\QMF for Windows\gmfwin.exe" /IServer:DB2AIX

/IProcfile:"c:\Procedurel.prc" /IUserID:db2instl
/IPassword:db2instl
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Command line indirection

Instead of typing all parameters directly on the command line, you can place
some or all of the parameters in a file, then reference the file on the command
line, preceded by an ampersand (@).

For example, if the file C:\Temp\options text contains:

/CollectionID:QMF81
/BIND

specify this command line:
rsadmin.exe sdf.ini /Server:"Server 1" @C:\Temp\options.tex

this is equivalent to specifying this command line:
rsadmin.exe sdf.ini /Server:"Server 1" /CollectionID:QMF81 /Bind

For example, the following command line creates a server named, "Test
Server” in the server definition file sdf.ini, with RDB name "TEST”, using a
TCP/IP connection to host name "db2test.ibm.com” and port number 446. All
other parameters have default values:

rsadmin.exe sdf.ini /Server:"Test Server" /CollectionID:QMF81 /Bind

This command line defines a new server named "Test Server” in the server
definition file named "sdf.ini", using a TCP/IP connection to IP address
"127.0.0.1" and port number 446. It also sets "QMF81" as the collection ID for
the server, creates any of the QMF for Windows database objects that do not
exist (using default statements), binds the QMF for Windows packages, and
grants EXECUTE authority on those packages to PUBLIC:

rsadmihn.exe sdf.ini /Server:"Test Server" /RDBName:TEST /HostName:127.0.0.1
/PortNumber:446 /CollectionID:QMF81 /CreateObjects /Bind /Grant:PUBLIC
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Chapter 19. Expression Builder

About the Expression Builder

Use the Expression Builder to build SQL expressions for SQL and prompted
queries.

The Expression Builder contains a palette of common elements used for
creating SQL expressions. Examples of these elements include column names,
constants, functions, and operators. When you click a button on the
Expression Builder palette, a template for the expression element is inserted
into the SQL query window or prompted query window. The end-result is a
framework on which you can build the SQL or prompted query.

When you are through building the expression, click outside of the Expression
Builder window or press Esc to close the window.

Opening the Expression Builder
To invoke the Expression Builder from an SQL query:
* select Query--> Expression Builder
¢ click the Expression Builder icon on the toolbar
s press Alt + .

For a prompted query, click the icon to open the Expression Builder:

¢ on the Columns dialog box, next to the Enter an expression field

* on the Sort Conditions dialog box, next to the Enter a sort condition field
* on the Row Conditions dialog box, next to the Right side set of fields

Available expressions

The following are a few examples of the SQL expressions that are available in
the Expression Builder.

Note: The SQL Reference publication for your database type and version is
the authoritative source for the syntax of SQL expressions. Refer to this
documentation for more information about how to code SQL.

Table 76. SQL Expressions

SQL Expression Description

+ Insert a template for adding two expression elements
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Table 76. SQL Expressions (continued)

SQL Expression

Description

Insert a template for subtracting two expression elements

*

Insert a template for multiplying two expression elements

/ Insert a template for dividing two expression elements

CONCAT Insert a template for concatenating two string expression
elements

0 Group together different parts of an expression

constant>> Display a submenu of constants to insert, such as:

* Integer

* Decimal

* Floating point
* Character

* Graphic

column name>>

Display a list of all columns in all tables referred to by the
current query

Select one or more of the columns and press Enter to insert
the selected names into the expression.

special register>>

Display a submenu of SQL special registers to insert, such as:
¢ CURRENT DATE

¢ CURRENT TIME

* CURRENT TIMESTAMP

+ CURRENT SQLID

* USER
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Table 76. SQL Expressions (continued)

SQL Expression

Description

function>>

Display a tree view containing SQL column and scalar
functions. The functions are organized into related groups,
and each group is displayed under a different branch of the
tree.

To insert a reference to a function in the expression, select the
function in the tree and click Enter.

The two branches that display at the top of the tree have a

special purpose:

¢ Favorite Functions lists the functions that used most
frequently.

Add a function to your favorites by right-clicking on the
function and selecting Add to Favorites. Remove a
function from your favorites by right-clicking on the
function and selecting Remove from Favorites.

* Recently Used Functions lists the ten functions most recently
used.

Use this feature to enter the same function references
repeatedly, in the same expression or in a different
expressions.

After you select a function, the display area below the tree
view displays the function reference template that will be
inserted.

When you right-click on a function and select View
Reference from the submenu, a Web browser opens and
provides IBM reference documentation for the function.
Note: This option requires an active Internet connection.

case expression>>

Insert an SQL case expression:
¢ Simple
CASE <expression> WHEN <expression> THEN
<result-expression> ELSE <result-expression> END
* Searched

CASE WHEN <search-condition> THEN
<result-expression> ELSE <result-expression> END
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Chapter 20. DB2 Intelligent Miner™ Scoring

About Intelligent Miner Scoring

Use the IBM Intelligent Miner Scoring (IM Scoring) functions to import certain
types of mining modules into a DB2 table, apply the models to data within
DB2, and obtain scoring results.

Scoring results are obtained after the model is applied. Scoring results differ
based on the type of model that is applied. IM Scoring includes functions that
retrieve the values in the scoring results. The scoring functions require DB2
Universal Database, Version 8.1 or higher because DB2 UDB Version 8.1
implements the REC2XML function that is used for scoring.

IM Scoring, Version 8.1, extends the capabilities of DB2 to include data mining
functions. Mining models continue to be built using the IBM DB2 Intelligent
Miner for Data application, which produces PMML (predictive model markup
language) modules; whereas, with the mining application mode functions are
integrated into DB2.

Additional references

For further descriptions of the mining functions, see IBM Intelligent Miner
Scoring V7.1 Administration and Programming for DB2 at
http://www/ibm.com/software/data/iminer/scoring/Tibrary.html, and "Using
the Intelligent Miner for Data V6.1 at
http://www.ibm.com/software/data/iminer/fordata/library.html.

Available scoring functions

The functions, implemented as DB2 user-defined functions (UDFs), apply the
mining models to data held in DB2 tables and retrieve the results.

The administrator, who is responsible for data mining activities, creates the
following functions during installation. Then, the administrator uses the IM
Scoring functions to provide the mining modules to other uses.

The definitions of the functions refer to mining modules in DB2, but QMF for
Windows does not provide functions to create those models.

QMF for Windows provides the following Intelligent Miner Scoring functions:
* Q.PredictClusterID

* Q.PredictClusConf

* Q.PredictClusScore
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¢ Q.PredictClass
* Q.PredictClassConf
* Q.PredictValue

Clustering
The functions Q.PredictClusterID, Q.PredictClusConf and
Q.PredictClusScore are based on a mining technique called clustering. This
data mining technique discovers sets of rows with common characteristics, or
clusters, so that the rows are possibly homogeneous inside a cluster and
possibly heterogeneous between two clusters.

This technique is typically used for customer segmentation and profiling. It
divides customers into groups, based on parameters such as usage patterns,
cross-selling opportunities, and demographic data.

Classification

The functions Q.PredictClass and Q.PredictClassConf are based on the
classification technique. This technique groups records into predefined classes,
in order to predict a class based on other input fields.

This technique is typically used for risk analysis.

Numeric value prediction

The function Q.PredictValue is based on numeric value prediction. This is
similar to the classification technique; however, Q.PredictValue returns
numbers that could possibly be in a continuous value range.

This technique is typically used for risk analysis.

IM Scoring example

The following example is of a simple query that uses IM Scoring:

SELECT A.Name
Q.PredictClass('DemoBanking',
REC2XML(2, 'COLATTVAL',"",
A.Type, A.Age, A.Siblings, A.Income)
) As RiskClass
FROM BankCustomers A

This query refers to the arbitrary table BankCustomers, which contains
information about the customers of a bank. For each customer, the scoring
function computes a value that might be a classification of credit risk. This
prediction is implemented by the scoring function Q.PredictClass. The first
argument, "‘DemoBanking’, is the name of a mining module. The second
argument is the input data, constructed by REC2XML.
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The query results contain simple values such as:

Table 77. Sample IM Scoring Query Results

Name Risk class
Joe Padeni high
Susan Sztuba high
Callie Atchue low

The Q.PredictClass function returns a VARCHAR. In the example, it
produces a "high” or "low” value. A mining model contains the patterns and
formulas needed to predict clusters, classes, or numeric values. These patterns
are read by the UDF in order to compute predictions.

Q.PredictClusterID

Description
This function obtains, from the query results data, the cluster ID that is
produced when you apply a clustering model. This identifies the particular
cluster in the clustering model that is the best match for this data.

Format
Q.PredictClusterID(ModelName VARCHAR(256), Values VARCHAR(32672))
Parameters
Table 78. Q.PredictClusterlD Parameters
Name Description
ModelName The name of a model in the default table that

contains clustering models.

Values A string that contains the input arguments
required by the model. This value is produced by
the DB2 function REC2XML.

Return value
This function returns the cluster ID as data type INTEGER.

Q.PredictClusConf

Description
This function obtains the confidence from the query results data that is
produced when you apply a clustering model. This is a value between 0.0 and
1.0. This value expresses the probability that the predicted cluster is the best
match against the other clusters.
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Format
Q.PredictClusConf(ModelName VARCHAR(256), Values VARCHAR(32672))

Parameters
Table 79. Q.PredictClusConf Parameters

Name Description

ModelName The name of a model in the default table that
contains clustering models.

Values A string that contains the input arguments
required by the model. This value is produced by
the DB2 function REC2XML.

Return value
This function returns the clustering score as data type DOUBLE.

Q.PredictClusScore

Description
This function obtains the clustering score from query results data that is
produced when you apply a clustering model. The score is an expression of
how closely the data matches the predicted cluster.

* Demographic clustering: a score value close to 1.0 indicates a good match.

* Neural clustering: a score value close to 0.0 indicates a good match.

Note: The score value may indicate a good match even when the confidence
returned by PredictClusConf is low. This happens if the data matches
another cluster that is very close to the first one.

Format
Q.PredictClusScore(ModeTName VARCHAR(256), Values VARCHAR(32672))

Parameters
Table 80. Q.PredictClusScore Parameters

Name Description

ModelName The name of a model in the default table that
contains clustering models.

Values A string that contains the input arguments
required by the model. This value is produced by
the DB2 function REC2XML.

Return value
This function returns the clustering score as data type DOUBLE.
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Q.PredictClass

Description

This function obtains the predicted class from query results data that is
produced when you apply a classification model. This identifies, within the
model, the particular class that matches the data.

Format

Q.PredictClass (ModeTlName VARCHAR(256), Values VARCHAR(32672))

Parameters

Table 81. Q.PredictClass Parameters

Name

Description

ModelName

The name of a model in the default table that
contains clustering models.

Values

A string that contains the input arguments
required by the model. This value is produced by
the DB2 function REC2XML.

Return value

This function returns the predicted class as data type VARCHAR.

Q.PredictClassConf

Description

This function obtains the classification confidence value from results data that
is produced when you apply a classification model. The confidence is a value
between 0.0 and 1.0 that expresses the probability that the class is predicted

correctly.

Format

Q.PredictClassConf(ModelName VARCHAR(256), Values VARCHAR(32672))

Parameters

Table 82. Q.PredictClassConf Parameters

Name

Description

ModelName

The name of a model in the default table
containing clustering models.

Values

A string that contains the input arguments
required by the model. This value is produced by
the DB2 function REC2XML.
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Return value

This function returns the confidence value as data type DOUBLE.

Q.PredictValue

Description

This function obtains the predicted value from query results data that is
produced when you apply a regression model. This value is calculated
according to relations that are established by the model.

Format

Q.PredictValue(ModeTName VARCHAR(256), Values VARCHAR(32672))

Parameters

Table 83. Q.PredictValue Parameters

Name

Description

ModelName

The name of a model in the default table that
contains clustering models.

Values

A string that contains the input arguments
required by the model. This value is produced by
the DB2 function REC2XML.

Return value

This function returns the predicted value as data type DOUBLE.
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Chapter 21. IBM DB2 Spatial Extender

Description

The IBM DB2 Spatial Extender (Spatial Extender) stores, accesses, manages,
and analyzes spatial data that you can query. The Spatial Extender works with
spatial visualization tools. This enables you to gather spatial data, such as
geographic data, and attach non-spatial business data attributes to it.

IBM DB2 Spatial Extender is incorporated into the IBM DB2 Universal
Database. Spatial data consists of values that denote the location of objects
and areas with respect to one another.

An estimated 80% of all data has embedded spatial characteristics. This data
can be exploited to formulate queries containing relevant parameters.

Business applications

Business decisions can be achieved by adding the location factor to queries.
You can combine relevant spatial data with business data in the same RDBMS
to better manage your data within DB2. Spatial data can aid you in answering
basic business issues, such as:

* Where to build new offices based on costs and statistics, but also the
proximity of competitors and potential clientele?

* Which customers live inside and outside sales areas?

* Whether the center of a sales area is too far away from most of the
customers in the area?

* What extent your sales areas overlap with those of competitors?

* Which customers own homes valued at over $400,000 that are within one
mile of an earthquake fault?

¢ Combine spatial data with business data in the same RDBMS to better
manage your data within DB2

Features

* Generate and analyze spatial and business information, and store and
manage this data using a single SQL interface.

* Control whether information will be gathered for the location, shape of, and
relationships among business data and geographic data, including map
data.
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Import census data in common spatial formats, such as well-known text,
well-known binary, or shape format

Ability to save spatial data maps to a file

Export spatial data maps to procedures or as graphics files (as .bmp or .emf
files)

Use SQL extensions to handle complex data types and allow applications to
store and manipulate objects directly inside the DB2 database

Make these data more SQL accessible

Perform SQL querying of spatial data or joining this data with conventional
business data stored any DB2 database

Work with visualization tools to provide visual map renderings of spatial
data

Implement spatial data modeling
Work with multiple data types
Support popular industry formats, such as ESRI shape files (.spm)

User interface

The QMF for Windows uses a unique user interface for spatial maps:

Spatial maps display in a separate window

A drop-down menu is available for map objects

Property and history information can be obtained for map layers
Map icons are available along with informational tooltips

Prerequisites

DB2 Spatial Extender, version 7.2 or higher

Licensed copy of DB2 Universal Database Enterprise Edition (EE) version
7.2, or a licensed copy of DB2 Universal Database Enterprise-Extended
Edition (EEE) version 7.2 for Windows NT, Windows 2000 or AIX®

Microsoft Windows NT (R), Microsoft Windows 2000 (R), or IBM AIX,
32-bit or 64-bit environment for UNIX® platforms, Sun Solaris, Linux on
Intel and zSeries, HP-UX

A visualization too, such as ESRI ArcExplorer, ArcView GIS, Arcinfo,
ArcView, BusinessAnalyst, or ArcIMS

Integration with QMF for Windows

Save As dialog box

Select File--> Save as. The Save As dialog box opens. Select *.spm as the
extension in the Save as type field.

238 Getting Started with DB2 QMF for Windows and DB2 QMF for WebSphere



Invoking the visualization component

You can invoke the visualization component, which renders the shape files

(*.spm) visually.
File menu

1. Select File--> Open.
The Open dialog box opens.

2. Select the map file, or type the name of the file in the File name field, if

you know it.

3. Optional: Select Map Files (*.spm) from the Files of type field.

4. Click OK.

The Display Map window opens.

Map menu

Use the Map menu to control the attributes and view of a spatial map.

Add Layer

Select Map--> Add Layer to add a layer to the spatial map. The Add Layer

dialog box opens.

Note: You can select this option only if there is at least one result set open

that contains spatial data, which means that the layer must have a
column with GEO spatial data, as defined in the database.

Table 84. Add layer dialog box

Field

Description

From File

Select this radio button to select a shape file
from a file.

1. Select the From File radio button.

The Add Layer dialog box refreshes with an

input field for Name.

2. Type the name of the file in the Name field.

3. Click Add.
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Table 84. Add layer dialog box (continued)

Field

Description

From Database

Select this radio button to select a shape file
from a database.

1. Select the From Database radio button.
The Add Layer dialog box refreshes with
entry fields for Server, Owner, Name, and
Type.

2. At the Server field, select the server from the
drop-down list.

3. At the Owner field, type the name of the
owner of the shape file.

4. At the Name field, type the name of the
object owner.

5. At the Type field, select one of the following
shape object types from the drop-down list:
* Query
* Table

6. Click Add.

7. Optional: Click List Objects.

The Objects at [Owner] dialog box opens.
Use the List Objects dialog box to view a list
of objects matching your entries for server,
owner, name, or type.

8. Optional: Click Properties from the Objects at
[Owner] dialog box.

The [Owner Properties] dialog box opens.
Use this dialog box to review historical detail
for the object.

From Open Document

Select this radio button to add a layer from an
open spatial document. The Add Layer dialog
box is refreshed, and a list box opens where you
can select the layer.

List Objects

Click List Objects at the Add Layer dialog box to open the Objects at [Server]
dialog box. This control is available only if you are adding a layer from a

database.

Table 85. Objects at [Server]

Field

Description

Server

Select the server from the drop-down list.
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Table 85. Objects at [Server] (continued)

Field Description

Owner Type the owner name of the shape file

Name Type the name of the shape file.

Type Select the object type, either table or query.
Comment Review or type a comment associated with the

object.

Refresh List

Click Refresh List to repaint the Objects at
[Server] dialog box

OK

Click OK to select the object and close the
dialog box

Cancel

Click Cancel to return to the previous dialog
box without making any changes

Properties

Click Properties to open the [Object] Properties
dialog box, which provides various information
about the object, including a comment (that can
be updated), attributes, usage summary, and
number of times the object has been accessed

Properties

Click Properties at the Objects at [Server] dialog box to obtain detailed
information for the object. The [Server] Properties dialog box opens.

Table 86. [Server] Properties dialog box

Field

Description

Comment

A comment associated with the object. You can
type information in this field.

Shared with other users

This check box indicates whether the object is
shared with other users
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Table 86. [Server] Properties dialog box (continued)

Field

Description

Attributes

Various attributes associated with the object,
including:

Level

The internal level of the object.
Type

The type of the object.
Subtype

The subtype of the query object, either SQL or
prompted, or of the table object either T (for
table) or V (for view).

Restricted

Specifies whether the object is shared or
restricted.

Model
Specifies the internal object model of the

object. For prompted queries, this is always
REL. For all other objects, it is unused.
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Table 86. [Server] Properties dialog box (continued)

Field Description

Usage Summary The type of usage summary statistics, such as:

* Show First Used
Click this radio button to view details about
when the object was first used. The bottom
half of this group box is updated.

* Show Last Used
Click this radio button to view details about
when the object was last used. The bottom
half of this group box is updated.

* Show last modified
Click this radio button to view details about
when the object was last modified. The
bottom half of this group box is updated.

* Date, usage information
From Usage Summary

e Time
From Usage Summary

* User ID
From Usage Summary

* SQLID
From Usage Summary, the CURRENT SQLID
of the person who first used, last used, or last
modified the object, such as DB2ADMIN

* Environment

From Usage Summary, the environment (such
as Windows, TSO, or CICS), in which the
object was first used, last used, or last
modified

* Mode

From Usage Summary, the mode (Online or
batch) in which the object was first used, last
used, or last modified

¢ Command

From Usage Summary, the command (such as
IMPORT) that was used when the object was
first used, last used, or last modified

Number of times * Number of times used

* Number of times run

* Number of times cancelled
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Run History

Click Run History on the [Server] Properties dialog box to obtain summary
history for the object. The [Object] Run History dialog box lists each time the
object has run, if detailed object tracking is enabled in the QMF for Windows
Administrator for your resource limits group.

History information is available for the user ID, date, start time, end time,

success flag, and byte count.

Table 87. [Object] Run History dialog box

Field Description

User ID The user ID associated with the object, when it
was run

Date The date on which the object was run

Start Time The time at which the object was submitted to
run

End Time The time at which the object completed running

Success A code indicating the final result of the run

Byte Count The number of bytes retrieved by running the
object (if the object is a query)

Display

Click Display on the Object [Run History] dialog box to obtain detailed run

history for the object.
Table 88. Run Detail dialog box

Field Description

Date The date on which the object was run

User ID The user ID associated with the object, when it
was run

Start Time The time at which the object was submitted to
run

SQL ID The SQL ID, such as DB2ADMIN, which is the
CURRENT SQL ID of the person who first used,
last used, or last modified the object, from the
Usage Summary

End Time The time at which the object completed running

Environment Environment, such as Windows, which is the
environment (Windows, TSO, CICS) in which
the object was first used, last used, or last
modified, from Usage Summary
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Table 88. Run Detail dialog box (continued)

Field

Description

Row count

The number of rows retrieved by running the
query. This object is zero when the object is run
from QMF for Windows.

Mode

The online or batch mode in which the object
was run

Byte Count

The number of bytes retrieved by running the
object (if the object is a query)

CPU time

The amount of CPU time consumed by running
the object. This value is zero when the object is
run from QMF for Windows.

Result

The final result of the run, indicating whether it
completed successfully or if it was cancelled
prematurely. Some of the results that may be
displayed can occur only when the object is run
from host QMFE.

SQL text

The actual SQL text run for the query. SQL text
is tracked only if the Enable SQL text tracking
resource limit is enabled in QMF for Windows
Administrator, for your resource limits group.

Delete Layer

Select Map--> Delete Layer to delete a layer on the spatial map immediately.

Note: No delete-confirmation message is issued before QMF for Windows

deletes the layer.

Layer Properties

Select Map--> Layer Properties to work with the attributes of the mapping
points on the layer. One of the following dialog boxes opens, depending on

the type of layer.
* Point Layer Properties

Table 89. Point Layer Properties dialog box

Field

Description

Name

The name of the layer
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Table 89. Point Layer Properties dialog box (continued)

Field Description

Style Select one of the following radio buttons:

* Image, which enables the Image attributes
and controls how the points appear on the
spatial map, as a circle, square, triangle, or
Cross.

* Symbol, which enables the Symbol attributes
and control the font, angle, and character of
points on the spatial map.

Size The point size of the image or symbol.

Color The color of the image or symbol, as selected
from the color palette.

* Polygon Layer Properties
Table 90. Polygon Layer Properties dialog box

Field Description
Name The name of the layer
Color The color of the polygons in this area
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Table 90. Polygon Layer Properties dialog box (continued)

Field

Description

Style

Select one of the following styles:
* Solid, presents the polygon as a solid shape

 Transparent, presents the polygon as an
outline

* Horizontal, fills the polygon with horizontal
lines, in the selected color

* Vertical, fills the polygon with vertical lines,
in the selected color

* Upward diagonal, which fills the polygon
with vertical, diagonal lines in the selected
color (going from bottom-right to top-left)

* Downward diagonal, which fills the polygon
with vertical, diagonal lines in the selected
color (going from top-right to bottom-left)

* Cross, which fills the polygon with a
horizontal and vertical grid pattern, in the
selected color

* Diagonal cross, which fills the polygon with a
left and right diagonal grid pattern, in the
selected color

 Light gray fill, by which other aspects of
other layers in the map become visible in the
polygon by the addition of light gray fill

* Gray fill, by which other aspects of other
layers in the map become visible in the
polygon by the addition of gray fill

 Dark gray fill, by which other aspects of
other layers in the map become visible in the
polygon by the addition of dark gray fill

Border

Check this check box to display a border
between the polygon and other features within
the map

Color

The color of the border separating the polygon
and other features within the map, if the Border
check box is selected.

Thickness

The point size of the border separating the
polygon and other features within the map, if
the Border check box is selected.
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* Line Layer Properties

Table 91. Line Layer Properties dialog box

Field Description

Name The name of the layer

Color The color of the line surrounding the boundaries
of the polygon

Style The type of line, such as solid, dashed, dotted,
and other variations

Thickness The point size of the line

Layer Labels

Select Map--> Layer Labels to work with the attributes of labels associated
with features of the layer. The Layer Labels dialog box opens.

Table 92. Layer Labels dialog box

Field

Description

Layer name

The name of the layer

Display labels

Check this check box to display labels for the
selected column in the layer. The check box is
enabled when you select a column from the
Column drop-down list.

Column A column associated with the layer. Select a
column from the drop-down list.
Placement Select one of the following options to determine

how to place the labels for the layer:
* on feature
* above feature

* below feature

A feature is a specific point on the layer.

Vertical alignment

Select one of the following options to determine
how the labels will be placed vertically on the
layer:

* top
¢ center
* baseline

* bottom
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Table 92. Layer Labels dialog box (continued)

Field Description

Horizontal alignment Select one of the following options to determine
how the labels will be placed horizontally on the
layer:

o left

* right

* center

Font Specify the font style for the layer’s labels from
the Font dialog box

Zoom In
Select Map--> Zoom In to magnify an area of the layer. The cursor changes to

a magnifying glass with a (+). Move the cursor to the area you want to view
in detail, then click on that spot.

Zoom Out
Select Map--> Zoom Out to obtain a high-level view of the layer or to reset

the view after zooming in to the layer.

The cursor changes to a magnifying glass with a (-). Move the cursor to the
area you want to view, then click on that spot.

Zoom to Fit
Select Map--> Zoom to Fit to fit the map to the work area.

Zoom to Current Layer
Select Map--> Zoom to Current Layer to view the selected layer. You can

toggle between layers by selecting a different layer, then selecting Map-->
Zoom to Current Layer.

The image is adjusted to fit your work area.

Pan
Select Map--> Pan to drag the map image left to right, or up and down, to

obtain different views of the layer.

The cursor changes to a hand when you select this option. Place the hand
over the map image, click the mouse, then hold down the main mouse button
to shift the image.

Identify
Select Map--> Identify to obtain detailed information about a point on the

spatial map.
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Select the Identify option, then hover over on the map. Place the cursor over
the area about which you would like additional information. The cursor
changes to a pointer with an "I” symbol. Click that area. The Identify Results

dialog box opens.

Table 93. Identify Results dialog box

Field

Description

Location

An output field that identifies the coordinates of
the location (X and Y axes)

Range

Specify the range, or radius, for which you want
information, such as an area of 30-degrees
beyond the selected location.

The Identify Results dialog is refreshed with
identifying information for all features within
the specified range.

Note: The larger the range, the more features
will be identified.

For example, by specifying a range of 1 within
all visible layers, information is collected for two
customers of a bank, including information
regarding their checking accounts, average daily
balance, and the main roads surrounding their
homes.

Layers

Select the layers for which you want identifying
information. Choices are:

* visible layers
¢ selected layers

* all layers in the spatial map

Features

The individual layers included in the results,
within the specified radius. The Query Results
Explorer pane provides a tree-view of the layers
and associated categories of data within each
layer

Attributes

The detailed information available for the
selected layers, for the specified range and layers

Export

Select Map--> Export to export the map file to another location. The Save As
dialog box opens. Specify the directory path, file name, and file type, then

click Save.

Note: The file will be exported as an image file, as a *bmp (bitmap) or a
Windows enhanced metafile (*.emf) file type.
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Refresh

Select Map--> Refresh to redraw and refresh the contents of the spatial map.

Map Properties

Select Map--> Properties to define general settings for the spatial map

application.

Table 94. Map Properties dialog box

Field

Description

Scrollbars on map

Check this check box to add vertical and
horizontal scrollbars on the spatial map work
area.

Escape key

Specify the action to take when pressing the
Escape key. Choices are:

 Ignore
* Stop drawing layer
e Stop drawing map

Border style

Specify the type of border to use on the spatial
map to delineate features. Choices are:

* None
e Flat
* 3-D

Background color

Select, from the color palette, the background
color that will fill the background area of the
map

Export Map to Procedure

Select Map--> Export Map to Procedure to generate the SQL for the spatial
map, in a procedure document. The original spatial map is retained.

Layers

Select Map--> Layers to view the layers selected for the spatial map.

Display Map

Select File--> New--> Map to open the Map window. The window displays

spatial data and the corresponding layers used to build the data. This window

has two panes: the Query Results Explorer (layers list), and the map.

Layers list

The left side of the Map window contains an Query Results Explorer that lists
the layers belonging to the map. Each layer corresponds to a shape file in the
file system, including temporary files.
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For each layer created from an existing shape file, the label for each layer will
be the label of the shape file.

Table 95. Layers List Controls

Control Description

Add Display the Add Layer dialog box, where you can add a
layer by selecting a result set that contains spatial data,
a query or table, or a shape file.

Remove Remove the selected layer from the right pane display.

Result Map

The right side of the Display Map dialog box contains the spatial data
developed from the selected layers (from the selected queries, tables, or shape
files).

Procedure commands

The SPATIAL command performs spatial operations from a procedure. The
SPATIAL commands are listed below.

Note: In many of the following procedures, an error occurs if the current data
object does not contain exactly one column with a spatial data type.

Also, in many of the following procedures, an error occurs if the
current visualization specification is empty.

Table 96. Procedure Commands

Procedure Description

SPATIAL RESET Remove all layers from the current
visualization specification

SPATIAL ADD Export the current data object to a temporary
shape file and add the shape file, as a new
layer, to the current visualization specification.

SPATIAL EXPORT TO file-name Invoke the ESRI component to visualize the
(DATAFORMAT- layers in the specification and export the
JPG|BMP|GIF]|...,CONFIRM=YES|NO image to a file with a specific file name and

data format.

The CONFIRM option controls whether an
"overwrite” confirm message is issued if the
file exists.

SPATIAL DISPLAY Display the Visualize Spatial Data dialog box
to view the layers in the specification. The
procedure is suspended until the user closes
the dialog box.
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Table 96. Procedure Commands (continued)

Procedure

Description

EXPORT DATA

Accept the following values for the
DATAFORMAT option:

* DBF
* SPM

This function is similar to the EXPORT FORMAT
command and the Export Data dialog box.

IMPORT DATA

This procedure works with shape files. This
function is similar to the IMPORT DATA
command and the Import Data dialog box.
The type of data that is being imported is
determined by the file extension, where .spm
is a shape file, and anything else is an .ixf file
(which maintains backward compatibility).
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Chapter 22. IBM DB2 Warehouse Manager

With QMF for Windows you can register QMF for Windows objects, such as
spreadsheets, reports, and queries, in the DB2 Warehouse Manager
Information Catalog. This allows the object to be listed in and launched from
the DB2 Warehouse Information Catalog.

Methods to register objects
There are two methods to register QMF for Windows objects:
* Saving an object at the database server

* Selecting an object from an object list

Saving an object at the database server

Procedure
1. Select File--> Save at Server when you save the object for the first time.

2. Provide owner, name and other information about the object.
3. Check the Register the object in the Information Catalog check box.
4. Click OK.

The Save Query dialog box expands with options for registering objects in
the Information Catalog.

Field descriptions
1. Register immediately

Select this radio button to send an immediate registration request to the
DB2 Warehouse Manager when the object is saved. The object is registered
in Information Catalog when the object is saved at the database server.

Provide the following information:
* Catalog

The name of the DB2 Warehouse Manager Information Catalog to which
the object will be registered. Your DB2 Warehouse Manager Information
Catalog administrator can give you this information.

e User ID

The user ID that you are using to register the object. This can be the
same as your database user ID.

e Password

The password that you are using to register the object. The password
can be the same as your database password.
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2. Register later

Select this radio button to bundle the object registration information into a
tag file to wait for registration by your DB2 Warehouse Manager
Information Catalog administrator.

Provide the following information:

* Tag file
Type or browse for the location and file name of the tag file that
contains the registration information of the object being saved. Your DB2

Warehouse Manager Information Catalog administrator can provide
location and file name information.

Windows generates a tag file in the specified folder. The DB2 Warehouse
Manager Information Catalog administrator uses the Information
Catalog to import the tag file and register the object.

Selecting an object from an object list

Procedure
You can select multiple QMF for Windows objects to be registered

simultaneously in the Information Catalog.
1. Select multiple objects from an object list.
2. Select List--> Register in Information Catalog.

The Register Objects in the Information Catalogs dialog opens. Select a
registration option, as described in the section, ]”Saving an object at thel
|database server” on page 255.|
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Chapter 23. Database Explorer

Use the Database Explorer to view, access, and analyze QMF for Windows
objects that reside on the database servers that have been defined in the SDFE.
When the Explorer Bar is enabled, the (dockable) Database Explorer window
opens along with QMF for Windows and it remains open for the entire
session.

The Database Explorer displays, in an object tree structure, the QMF for
Windows objects that are stored on the database servers that are configured in
the current SDF. The object tree contains four branches for Favorites, Recently
Used Objects, Recently Used Servers, and All Servers.

The Database Explorer is a quick launching pad for accessing the servers and
objects with which you have most recently worked, which saves time and

effort in locating them. The Database Explorer also contains a branch for your
favorite servers or objects so that you can do your own work more efficiently.

Features

With the Database Explorer, you can:

* obtain instant information about the servers and the objects that are
available on the servers

* run objects

* expand or collapse servers and nodes

* filter objects by object owner and object name

* add objects to the Favorites folder

* work with recently-used objects and recently-used servers

The All Servers branch lists the database servers that have been defined in
the SDF. You can expand each database server by clicking the (+) to the left of
the server name. QMF for Windows retrieves and lists the QMF objects that
are stored on that database server. Click the Filter icon to select which
objects should be included in the list. The Filters window opens.

The Recently Used Objects branch lists the database objects that you used
during your last QMF for Windows session in the order that you used them.
QMF for Windows keeps track of your object usage during the session. The
list is updated each time each time that you use an object. You can specify the
number of QMF objects that are included in the list by clicking the Options
icon. The Database Explorer Options window opens.
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Opening and Closing the Database Explorer

The Database Explorer opens when you start QMF for Windows if you select
View --> Explorer Bar, or you select the Explorer icon. The Database Explorer
will open automatically each time you start QMF for Windows.

The Database Explorer closes when you de-select View --> Explorer Bar or
you click the Explorer icon. The Database Explorer will not open until you
select it.

Favorites

Use the Favorites folder to drag the objects that you use most frequently, or to
create sub-folders for these objects. You can drag objects from different servers
to the Favorites node or to a Favorites folder.

This enables you to work from a single folder.

Recently Used Objects

Objects that you have accessed recently are added automatically to the
Recently Used Objects node of the Database Explorer. This enables you to
reselect an object directly from the database server. You can double-click on
the object to run it, or right-click on the object to view a sub-menu.

Note: The Set User Information dialog box opens if a User ID and Password
are required.

Recently Used Servers

The Recently Used Servers node of the Database Explorer automatically lists
the database servers that you have used during your last QMF for Windows
session in the order that you used them. QMF for Windows keeps track of
your server usage during the session. The list is updated each time you restart
QMF for Windows.

You can specify the number of servers that are included in the list by clicking
the Options icon. The Database Explorer Options window opens.

You can also enter filtering information to filter by object owner and object
name by clicking the Filter icon.

A series of dialog boxes opens. The Set User Information dialog box opens if a
User ID and Password are required to access the database server. Additionally,
the Set User Information dialog box opens if a User ID and Password are
required to access the objects on the database server.
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Right-click on the object, then select Run from the sub-menu to run the object.

All Servers

Select the All Servers node on the Database Explorer to view the database
servers that are defined in the server definition file (SDF).

The SDF is an initialization (.ini) file that contains the technical information
that QMF for Windows requires for connecting end-users to database servers.

The Administrator determines who has access to database servers, based on
user authority and user resource limits. Therefore, the servers listed under the
All Servers node may not be accessible by all users.

Running Objects
1. Select a node on the Database Explorer.
2. Right-click on the icon.
3. Select Run from the sub-menu.
4

Optional: Provide a substitution variable value if the Enter Substitution
Variable Values dialog box opens.

Creating and Deleting Folders
You can create and delete folders only at the Favorites node of the Database
Explorer.

Creating Folders

1. Right-click on the Favorites node on the Database Explorer.
2. Select New Folder from the sub-menu.
3. Specify the folder name.
4. Drag items to the folder.

Deleting Folders
1. Right-click on a folder in the Favorites node on the Database Explorer.

2. Select Delete Folder from the sub-menu.

Retrieving the Object’s References
Select this option to obtain the references for an object, such as:
* the tables and columns selected for a query
* the queries used in a procedure
¢ the columns defined for a table
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When you select References, QMF for Windows performs an instant analysis to
determine the tables, columns, and queries associated with the query or
procedure.

Follow these steps to view the references for an object:

1. Expand the node for queries or procedures on the Database Explorer tree.
2. Expand the node for the object.

3. Expand the node to obtain the References.
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Chapter 24. QMF for WebSphere

Overview

DB2 QMF for WebSphere is part of the DB2 Query Management Facility
(QMEF) toolset for IBM’s DB2 relational database management system. QMF
for WebSphere extends query and reporting capabilities to users via their web
browsers. There are three QMF for WebSphere applications:

* QMEF for WebSphere
* QMF for WebSphere Report Center
* QMF for WebSphere Administrator

For more information on using QMF for WebSphere Administrator, see DB2
QMF for Windows and DB2 QMF for WebSphere Installing and Managing Guide.

Using QMF for WebSphere

QMF for WebSphere has the same look and feel as QMF for Windows and
includes much of the same functionality. You can refer to the chapters in this
document for additional information on common functionality.

To use QMF for WebSphere, open a web browser and go to:
http://host:port/QMFWebSphere/Pages/QMFWebSphere. jsp

where host is the host name of the WAS server machine and port is the port on
which the QMF for WebSphere application is configured to listen.

Connecting to a database server

You can connect to any of the database servers that have been configured in
the distributed server definition file (SDF). All QMF for WebSphere users use
the same SDF. The SDF includes the technical information QMF for
WebSphere needs to connect to the database servers and control resource
usage. The SDF is created, maintained and distributed by the person who is
responsible for configuring your QMF query environment.

The database servers that are available for you to use are listed in the All
Servers branch of the Database Explorer tree when you open QMF for
WebSphere.

Specifying user information

You must specify user information for every connection to the database server.
The Set User Information window is used to specify user information.
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Whenever QMF for WebSphere connects to a database server, the Set User
Information window opens requesting a user ID and password.

QMF for WebSphere opens the Set User Information window and requires
that you specify a user ID and password at least once during the QMF for
WebSphere session for each database server to which you will connect. For all
subsequent connections to the specific database server, QMF for WebSphere
will use the same user ID and password.

Fields

Server: The name of a database server that QMF for WebSphere is
connecting to.

User ID: The user ID that you want to use to connect to the database server.
The user ID is validated by the database server for authorization. User IDs are
case sensitive.

Password: The password associated with user ID you typed in the User ID
field. Passwords are validated by the database server for authorization.
Passwords are case sensitive.

Remember this password: Check this check box to have the password
specified in the Password field saved across QMF for WebSphere sessions.
Unchecked, the password is only saved for the duration of the current QMF
for WebSphere session.

Specifying multiple user IDs and passwords
If you are connecting to a database server that uses a catalog that resides on a
different database server, the Set User Information window will request user
ID and password information for both database servers.

1. In the first User ID field, type the user ID that you want QMF for
WebSphere to use to connect to the primary database server. In the
Password field, specify the password associated with the user ID that you
typed in the User ID field.

2. In the second User ID field, type the user ID that you want QMF for
WebSphere to use to connect to the database server where the catalog
resides. In the Password field, specify the password associated with the
User ID that you typed in the User ID field.

3. Click OK.
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Queries

Using QMF for WebSphere you can query a database server in one of the
following ways:

* write your own SQL statements
* create SQL statements using the prompted interface
¢ create an OLAP query using the QLAP query Wizard

* use the Database Explorer to find and select queries that have been saved
on the database server

* run a procedure
* create a list and select an object from the list

Query menu

The Query menu becomes available when you create a new query or open an
existing query. You can access the query menu commands from the main
menu or from the Actions window. You can use the menu commands for all
queries to:

Run
Select Query--> Run to run the active query.

Save at Server
Select Query--> Save at Server to save the query at the database server.

Save to File
Select Query--> Save to File to save the query as a file located on your local

or network drive.

Convert to SQL
Select Query--> Convert to SQL to see the SQL statements that were created

for your query. This menu choice is only available when you are working
with the prompted query interface.

Use the Database Explorer to select an existing query

The Database Explorer opens in the Explorer window when QMF for
WebSphere opens. You can use the Database Explorer to view, access, and
analyze QMEF objects that reside on the database servers that have been
defined in the SDF.

Navigating the Database Explorer tree
The Database Explorer displays in a tree structure the QMF objects that are

stored on the database servers to which you have access. The Database
Explorer tree contains four branches:

Favorites: The Favorites branch lists the QMF objects that you have selected
for inclusion. You can move any QMF object listed in the Database Explorer
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branches to the Favorites folder by selecting the object and dragging it to the
folder. You can also right-click on the QMF object and select Add to Favorites
from the context menu. The Add to Favorites window opens where you can
add the object to your Favorites branch.

Recently Used Objects: The Recently Used Objects branch lists the database
objects that you have used during your the QMF for WebSphere session in the
order that you have used them. QMF for WebSphere keeps track of your
object usage during the session. The list is updated each time that you use an
object. You can specify the number of QMF objects that are included in the list
by selecting View--> Options and clicking the Database Explorer Options

page.

Recently Used Servers: The Recently Used Servers branch lists the database
servers that you have used during your last QMF for WebSphere session in
the order that you have used them. QMF for WebSphere keeps track of your
server usage during the session. The list is updated each time QMF for
WebSphere is restarted. You can specify the number of servers that are
included in the list by clicking View--> Options and clicking the Database
Explorer Options page.

All Servers: The All Servers branch lists all the database servers that have
been defined in the SDF. You can expand each database server by clicking the
(+) to the left of the server name. QMF for WebSphere retrieves and lists all
the QMF objects that are stored on that database server. To select what objects
should be included in the list, right-click on a database server in list and
select Filter from the context menu. The Filters window opens

Using the Database Explorer

You can use the database Explorer to:

* Run or display a QMF object by double clicking on the object listed in any
of the branches of the Database Explorer tree. By default, double clicking on
the OMF object will run the object. To display the object by double clicking,
you must select View--> Options and select the Database Explorer page
where you can change the default from Run to Display.

* Right-click on any database server listed in the Database Explorer tree and
open a context menu. From the context menu you can select Set Name
Filter or Set Type Filter to open the Filters windows where you specify
which QMF objects will be included in the database server branch in the
Database Explorer tree. You can select New Document and choose to create
a new Query, OLAP query or Procedure. You can also choose to Refresh
the list of objects that are available for the selected database server.

* You can right-click on any object listed in the Database Explorer tree and
open a context menu. From the context menu you can Open, Run, Delete,
and Rename the object. If applicable to the selected object, you can access
the add the object to your Favorites folder or view Properties.
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* You can view all of a QMF object’s dependencies on other objects from the
Database Explorer tree. All query objects, including procedures, listed in all
of the Database Explorer branches, have a single child node that is labeled
References. Expand the query object by clicking the (+) to the left, and then
expand the branch References by clicking its (+) expand icon. The Object
Analyzer is invoked. An analysis is triggered to determine the selected
object’s dependencies. All reference objects will display beneath the
References nodes. All operations that can be performed on objects listed in
the Database Explorer branches, can also be performed on these objects.

* If you select a table, the Object Analyzer will list the columns. The child
node name is Columns. Expand the table object by clicking the (+) to the
left, and then expand the branch Columns by clicking its (+) expand icon.
The Object Analyzer is invoked. An analysis is triggered to determine the
selected table’s columns. All table column names will display beneath the
Columns branch.

Type the SQL statements in the Query window

To type the SQL statements for a query you must first open a new query
document. To open a new query document select Create --> SQL Query. The
query window opens. You can type the SQL statements directly in the active
query window.

Expression Builder

You can use the Expression Builder to help you build conditional expressions
that can be included in the SQL statements for your query. Click the
Expression Builder to access a submenu, or palette, of SQL elements for
building an SQL expression. The Expression Builder palette contains common
elements such as:

* operators (+, -, ¥, /)
« CONCAT

* 0

* constant

* column name

* special register

* function

* case expression

A template for each expression element you select is inserted into the query
document. This provides the fundamental structure for you to substitute
parameters for the query in place of the <expression>. For example,

CASE <expression> WHEN <expression> THEN <result-expression> ELSE
<result-expression> END
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Note: This command is disabled for queries in the prompted or diagram
formats.

The prompted view of a query

You can build simple to complex queries using the prompted query interface.
Select Create --> Prompted Query to start building a query using the
prompted query interface. The Prompted query interface has five sections
where you specify the elements of your query. The five sections are:

* Tables where you specify the tables that will be used in the query.

* Join Conditions where you specify the join conditions for tables, if you are
using multiple tables in the query.

* Columns where you specify what columns will be included in the query
results

* Sort Conditions where you specify how the rows in the query results will
be sorted.

* Row Conditions where you can specify conditions that will limit the rows
that are returned in the query results.

In each section you can add, edit, delete and move through the entries using
the icons located for each in the upper right hand corner.

Tables
You use the Tables dialog to specify the tables that you want to include in the

query. You can specify one or more tables. If you specify more than one table,
the Join Conditions dialog opens automatically.

Click the icon in Tables List box to add one or more tables to the query.

Table 97. Tables dialog

Field Description

Table Owner The owner identifier of the table that you want to
include in the query. You can use patterns to select
objects from a list of matching objects.

¢ Use the percent character (%) to match a string of
any length containing any characters. For example,
to list all tables with a name beginning with the
letter A, enter A%.

¢ Use the underscore character (_) to match a single
character. For example, to list all tables with an
owner that has the letter A in the second position,
enter _A%.

Table Name The name of the table that you want to include in the
query. You can use patterns to select objects from a
list of matching objects. See Table Owner for
information on matching objects.
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Table 97. Tables dialog (continued)

Field

Description

Add from List

Lists the tables that are on the database server.

Join Conditions

You can add more than one table to a query. When you add an additional
table to a query using the Tables dialog, the Join Conditions dialogs open
automatically. There are two Join Conditions dialog windows:

* The Join Tables dialog, where you specify what type of join will link the
tables, such as an inner join or left, right or full outer join.

* The Join Columns dialog, where you specify the columns from each table

that will be joined

The Join Tables dialog box contains the following fields:

Table 98. Join Tables Dialog

Field

Description

Select a table to join into
the query

Lists the tables selected for the query. This table will be
joined to another table based on the join condition.

Select the type of join to
perform

Select the type of join condition that will be used to
connect the table listed to the previously selected table.
You have four choices:

* Inner Join

* Right Outer Join
* Left Outer Join

» Full Outer Join

Inner join

Only rows with matching values in both tables will be
included in the results set. An INNER join is implicit if
you do not specify any other join operator.

Note: An inner join compares every row of the left table
with every row of the right table keeping only the rows
where the join-condition is true. The resulting table may be
missing rows from either or both of the joined tables.

Left Outer join

All rows in the left table, with matching rows from the
right table, will be included.

Outer joins include the rows produced by the inner join as
well as the missing rows, depending on the type of outer
joins. A Left outer join includes the rows from the left
table that were missing from the inner join.
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Table 98. Join Tables Dialog (continued)

Field

Description

Right Outer join

All rows in the right table, with matching rows from the
left table, will be included.

Outer joins include the rows produced by the inner join as
well as the missing rows, depending on the type of outer
joins. A Right outer join includes the rows from the right
table that were missing from the inner join.

Full Outer join

All rows from both tables will be included

For a FULL OUTER (or FULL) join, the join condition is a
search condition in which the predicates can only be
combined with AND. In addition, each predicate must
have the form’expression = expression’, where one
expression references only columns of one of the operand
tables of the associated join operator, and the other
expression references only columns of the other operand
table. The values of the expressions must be comparable.

Each full join expression in a FULL OUTER join must
include a column name or a cast function that references a
column. The COALESCE and VALUE functions are
allowed.

Outer joins include the rows produced by the inner join as
well as the missing rows, depending on the type of outer
joins. A Full outer join includes the rows from both tables
that were missing from the inner join.

Continue

Click Continue to join the tables. The Join Columns dialog
box opens.

Joining Columns: Use the Join Columns dialog box to specify the columns
that will used to link the tables. The columns from the current table that you
are adding to the query and the columns from each table that is already
included in the query are listed. Select a column from each list box with the
same data type (NUMERIC, DATE, TIME, or CHARACTER). Rows that have equal
values in those columns will be joined.
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The Join Columns dialog box contains the following fields:

Table 99. Join Columns Dialog

Field Description

list.

Columns of Lists all the columns that are included in the table that you
are adding to the query. Select one column from this list.
Note: Select a column with matching data types from each

list.

Available columns to join [ Lists all the columns from the table or tables that are
already included in the query. Select one column from this

Note: Select a column with matching data types from each
list.

Columns

You use the Columns dialog to specify what columns will be included in the
query results. By default, all the columns from a table that is included in the
query are included in the query results. In the case where you have multiple
tables included in the query, all the columns from each table will be included.

Select Query --> Add --> Columns or click the icon in Columns list box to
specify the columns that will be included.

The following fields are available:

Table 100. Columns Dialog

Field

Description

Table

Lists the tables that are included in the query. If there
are two or more tables, each table is prefixed by a
letter, such as Q.STAFF(A) and Q.INTERVIEW(B).

Column

Lists the columns for each table in the query

Type

Lists the data type (character, numeric or time) for
each column, such as:

SMALLINT NOT NULL

Label

Lists any labels associated with the column.

Labels on columns are implemented as system
column headings or column text. Column headings
are used when displaying or printing query results.

Comments

Lists any comments associated with the table, such
as:

Employee identification number
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Table 100. Columns Dialog (continued)

Field

Description

Or, enter an expression here

Use this field to enter a conditional expression that

will determine whether a column is included in the
query results. You can use the Expression Builder to
help you build the expression.

The Expression Builder offers a palette of common
elements used to create SQL expressions, such as
column names, constants, functions, and operators.
When you click the Expression Builder buttons,
templates for expression elements are inserted into
the expression fields.

You can invoke the Expression Builder by:
1. pressing Alt + .

2. clicking the browse icon to the right of the input
field

Summary function

Apply the summary function to the column.

A number of summary functions, including AVERAGE,
COUNT, MAXIMUM, MINIMUM, and SUM. The summary
function must be compatible with the data type of the
column.

New column name

A new column name for a column that will be used
in the query results. Usually, this is simpler name
than the column name defined in the database.

Select a column from the Column list box, then type
a new column name in the New column name field.
The column will be renamed in the query results,
such as SHIFTEND from A.ENDTIME.

Sort Conditions

Sort condition control how to sort the rows that will be included in the query
results. Rows can be sorted in ascending (A-Z) or descending (Z-A) order.

If you sort your rows by more than one column, the first column is ordered
first, then the second column is ordered within the sort order defined for the

first column.

There are several methods by which to specify a sort condition:

e From the Columns in the results set list, select a column included in the

query

e From the Other available columns list, select a column that was not selected
from the tables in the query
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* From the Or, enter a sort condition field, type a sort condition

Click the icon in Sort Conditions list box to open the Sort Conditions dialog
box and specify the sort conditions.

Table 101. Sort Conditions Dialog

Field

Description

Columns in result set

Lists the columns that will be included in the query
results.

* You can select one or more columns if you are
adding a sort condition

* You can select only one column if you are changing
a sort condition

Other available columns

List columns that will not be included in the query
results but are available in the table that was queried.
You can select any of these columns for the sort.

Or, enter a sort condition

Type a condition by which columns should sort.

Expression Builder

The Expression Builder offers a palette of common
elements used to create SQL expressions, such as
column names, constants, functions, and operators.
When you click the Expression Builder buttons,
templates for expression elements are inserted.

You can invoke the Expression Builder by:
1. pressing Alt + .

2. clicking the browse icon to the right of the Enter a
sort condition field

Sort direction

Apply an ascending (lowest-to-highest) or descending
(highest-to-lowest) sort order to the columns selected.

The first column is used for the primary sort;
subsequent columns will sort within the first.

Row Conditions

Use can specify row conditions to limit the rows that are returned in the
query results. Without row conditions, all qualifying rows will be returned

from the query.

Click the icon in the Row Conditions list box to open the Row Conditions
dialog box and specify the row conditions.
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Table 102. Row Conditions Dialog

Part of the row condition

Function

Connector

An "And” or "Or” statement that links one row
condition with another. These radio buttons are
available only when a row condition has been
added to the query.

Left side

Select the column from the list box to examine for
inclusion in the query results

Operator

Select the Is or Is Not radio button to determine the
relationship between the left- and right sides of the
row. Also, select the operation to be applied to the
row condition from the Operator drop-down menu.
The available operators are:

* Equal To

* Less Than

* Less Than or Equal to

* Greater than

* Greater than or Equal to
* Between

e Starting with

* Ending with

* Containing

e Null

* Equal in area to

* Larger than
* Larger than or equal to

Right side

Type the condition for which to check the rows.
Only rows that meet this condition will be selected
for the query
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Table 102. Row Conditions Dialog (continued)

Part of the row condition

Function

Expression Builder

Use the Expression Builder for building SQL
expressions for the prompted query.

The Expression Builder offers a palette of common
elements used to create SQL expressions, such as
column names, constants, functions, and operators.
When you click the Expression Builder buttons,
templates for expression elements are inserted into
the associated SQL query window or prompted
query window.

You can invoke the Expression Builder by:
1. pressing Alt + .

2. clicking the browse icon to the right of the Enter
a sort condition field

Global variables

QMF for WebSphere supports global variables in much the same way as QMF
for Windows. See the Global Variable chapter in this book for more

information.

Create new OLAP queries using the OLAP Query Wizard

For database servers that support DB2 Cube Views, you request information
from the server using an OLAP query. OLAP queries are multidimensional
queries that can present your data in a wide variety of views. You use the
OLAP Query Wizard to help you build an OLAP query. The OLAP Query
Wizard has the following steps:

* Open the OLAP Query Wizard

* Select a database server

* Specify how the list of cubes on the database server will be presented to

you

* Select the cube that will be included in the OLAP query

Open the OLAP query Wizard
Select Query--> OLAP Query to Open the OLAP Query Wizard.

Select a server

Use the OLAP Query Wizard Select a Server dialog to select the database
server where the cubes that will used in the OLAP query reside.

1. Select a server from the list.

2. Click Next.

The OLAP Query Wizard Sort Cube List by dialog opens.
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Sort Cube List by
Cubes are stored on the database server by schema and by model. You can

choose how those cubes are presented to you for selection in the next step of
the OLAP Query Wizard.

1. Select the sorting method to use.
Select the Schema radio button to sort cubes by schema, which is the cube
name or the owner of the object.
Select the Model radio button to sort cubes by model.
2. Click Next.
The OLAP Query Wizard Select a Cube dialog opens.

Select a Cube
The cubes that reside on the database server are presented in a tree structure

based on the sort criteria you specified in the previous step. Use the OLAP
Query Wizard Select a cube dialog to select the cube to use for the OLAP

query.
1. Select the cube to use.

If you sorted by Schema on the OLAP Query Wizard: Cube List Filters
dialog box, the cube is shown in server, name, then cube order.

If you sorted by Model on the OLAP Query Wizard: Cube List Filters
dialog box, the cube is shown in server, model, then cube order.

2. Click Finish.
The OLAP query is run on the database server. The results are returned in
the active window.
Saving and opening queries

You can save queries on your PC, on a file server, or at a database server. A
query is saved in the format that is currently being used to view the query.
For example, if the query is being viewed in the prompted interface, it will be
saved in the prompted format. If the SQL statements are being viewed, then
the query will be saved in the SQL format. A saved query opens in the format
in which it has been saved.

Saving queries to files
1. Create a query.

2. Select Query--> Save to file.
3. Type the query name.
4. Click OK.

Opening saved SQL query files
1. Select Open--> From File.

The Open dialog box opens.
2. Select the file to open.
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3. Click OK.

Saving SQL queries at the database server
Queries saved at the server so they are accessible to other users.

1. Open a query.

2. Select Query--> Save at Server.
3. Type an owner and a name.
4

. Check the Share the object with other users check box to share the query
with others.

5. Click OK.

Opening queries saved at the database server
You can open queries that have been saved at the database server.

1. Click Open--> From Server.

The Open From Server dialog box opens.
2. Type a server, owner, and name.
3. Click OK.

Working with query results
After you run a query, the results are returned in the active window. Once
you have query results you have several options:

* Use the Query Results Explorer to change the query results in the active
window by applying extensive formatting options

* Create a classic or visual report
* Create a chart

* Save the query results

Query Results Explorer

The Query Results Explorer opens in the Explorer window when the results of
the query are returned. The Query Results Explorer displays the query results
in a tree structure. The tree structure looks very similar for both SQL and
OLAP queries with the exception of the branch names.

You can use the Query Results Explorer to move around, discover and easily
modify the structure of the query results. The formatting options available to
you depend on the type of query that was run to create the results.

Working with the Query Results Explorer
There are two ways of working in the Query Results Explorer:

* using a context menu
* drag and drop
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You can change the order of columns in the query results by dragging and
dropping columns to and from branches in the Query Results tree. You can
also add or delete columns to and from the query results by dragging and

dropping to and from branches in the Query Results tree.

You can right-click in the Query Results tree to open different context menus.
Using some of the options from the context menu you can:

* Apply formatting to whole columns and unique formatting to cells within
columns

* Apply grouping to columns in the query results

* For SQL queries, you can add columns to the query results based on
expressions

* Remove columns from the query results

The functionality of the Query Results Explorer in QMF for WebSphere is very
similar to its functionality in QMF for Windows. See the Query Results
chapter for more information on what you can do with the Query Results
Explorer.
Create a classic or visual report
There are two types of reports:
* Classic reports
Character based reports that are created using forms.
* Visual Reports

Robust reports containing graphics and rich-formatted text created visually
using layout templates

You begin the process of creating either type of report with the Report
Wizard. The Report Wizard opens when you have query results in the active
window and you:

* Select Results--> Display Report from the main menu.
* Select Results--> Display Report from the Actions window.

Using the Report Wizard
You begin the process of creating a report with the Report Wizard. The Report

Wizard helps you find the dialogs you need to create a new or open an
existing report. The process flows as follows:

1. You specify that you are creating a new report or opening an existing
report stored in a file or saved on the database server.

2. If you are opening an existing report stored in a file or saved on the
database server, the dialogs that you need to open the existing report are
presented to you. Based on your input, the Report Wizard opens the
existing report.
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3. If you are creating a new report, then you specify whether you will be
creating a classic report or a visual report. Based on your input, the Report
Wizard opens the dialogs that you need to create the report.

Table 103. Report Wizard

Field

Description

Report Wizard Type page

* Select Create a new report to create a new classic
or visual report. The Report Wizard New Report
page opens.

* Select Use an existing report stored at a server to
open an existing report that has been saved at the
database server. The Report Wizard Open from
Server page pens.

* Select Use an existing report stored at a file to
open an existing report that has been stored in a
file. The Report Wizard Open from file page opens.

Report Wizard New Report
page

* Select Create a visual report to create a new visual
report. Specify whether the new report will be
generated using the formatting that has been
applied to the current query results or very basic,
default formatting. The report opens in the Visual
Report window.

* Select Create a classic report to create aa new
classic report. Specify whether the new report will
be generated using the formatting that has been
applied to the current query results or very basic,
default formatting. The report opens.

Report Wizard Open from
Server

Specify the database server, the owner and the name
of the visual report or a form for a traditional report
that you want to open. You can use the List button to
search the database to see a list of the visual reports
or forms that are on the database server.

Report Wizard Open from file

Specify the Name of the file or use the Browse button
to search for the file.

Create a new classic or visual report
Follow these steps to create a new classic or visual report:

1. Select Query--> Run to run a query and obtain query results.

2. Optional: Use the Query results Explorer and the formatting options to
format the query results in the active window. When either the classic or
visual report is created, the formatting that is applied to the report is taken
from the query results or the default report specifications.

3. Select Results--> Display Report from either the main menu or a context

menu.
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The Report Wizard opens.

4. Select Create a new report from the Report Wizard Type page. Select
Create a classic report or Create a visual report from the Report Wizard
New Report page.

5. Since this is a new report, and there is no assigned form or formatting
instructions, you must specify how the report will be generated. You can
select Generated based on the current query to generate the report based
on the way the query results currently are formatted or you can select
Default to generate the report based on a very basic set of default
formatting options. The report opens.

6. When the report opens, you cannot edit the contents or the formatting of
the report. You can:

* Export the report

* Change the data source of the report
* Change the default report options.

* Print the report

* Save the report

Create a chart

You can display the query results as a chart. All numeric data columns in the
query results can be charted. You can specify the type of chart and different
charting options for each set of query results.

To display the query results as a chart:
1. Open the Chart window.

The Chart windows opens. The numeric data columns of the query results
are charted according to the default chart options.

2. Optional: To change the type of chart or the appearance of the chart, click
the Options button which is located at the bottom of the window.

3. Optional: To open a new window that includes just the chart, click the
New window button. A separate browser window opens.

QMF for WebSphere Report Center

QMEF for WebSphere Report Center is used to view reports that were created
and saved on the database server using QMF for Windows Report Center.

To use QMF for WebSphere Report Center, open a web browser and go to:
http://host:port/QMFWebSphere/Pages/RcMain. jsp

where host is the host name of the WAS server machine and port is the port on
which the QMF for WebSphere application is configured to listen.
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Opening a report
QMEF for WebSphere Report Center uses a tree structure to organize and
display reports and QMF objects that are available for your use.

Expand or collapse branches from the tree to find your report. Select or
double click on the report to open.

Navigating the tree
The QMF for WebSphere Report Center tree consists of three main branches:
 Favorites
e DB2 Servers
* Recycle Bin

Favorites
The Favorites branch lists reports and folders of reports that you have

selected and placed in the folder. The reports and folders reside on your
machine’s local hard drive or on a network drive. The actual entry in your
Favorites folders points to the object on the database server that is used to
create the report. That object does not actually reside in your Favorites folder,
it remains safely on the database server. The entry in your Favorites folder
also contains the instructions as to how the report will be formatted.

DB2 UDB Servers
Each database server that has been configured in the server definition file

(SDF) is by default displayed as a branch under the DB2 UDB servers branch.
The SDF used is configured and distributed by your QMF for Windows
Administrator.

Each database server branch lists the objects (could be contained in folders)
that have been created and saved to that database server and a Public
Favorites folder that is created when QMF for WebSphere Report Center and
QMEF for WebSphere are installed.

There is only one Public Favorites folder on a database server, however, it can
contain many subfolders. The Public Favorites folders list the reports that
have been saved to the database server by one or more users of QMF for
WebSphere Report Center. Your view of the Public Favorites folders (what
reports are listed and that you can access) is dictated by security permissions
that are specified using the QMF resource limits and security permissions
specified when the report was created. Reports that reside on the Public
Favorites folders point to an object that is used to retrieve data from a
database server to create a report.

Your access to the objects on a database server is dictated by the permissions
granted to your user ID and password as well as security permissions that are
specified by the QMF for Windows Administrator using the QMF resource
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limits. If you can access an object (query, table, procedure) from the Report
Center tree based on the permissions granted to user ID, then you can run the
object and obtain query results. The query results are formatted using default
formatting. By directly running an object from a database server you are
creating an "ad-hoc” report. In order to save those query results, you must
save them as a report in either the personal Favorites or the Public Favorites
(if you have permission) folders. Saved reports point to the objects that were
used to create them, and the formatting that is to be applied to the query
results.

Specify user information

Before connecting to a database server, you must specify your user ID and
password. You use the Set User Information window to specify a user ID and
password that QMF for WebSphere Report Center will use for the current
connection to the database server.

QMF for WebSphere Report Center always opens the Set User Information
window requesting user ID and password information before making any
connection to a database server. For each database server that you connect to,
you can specify a unique user ID and password.
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Appendix A. Accessibility

Software accessibility features help individuals with physical disabilities, such
as restricted mobility or limited vision, to use their computers.

QMF for Windows accessibility features include:
 Standard keyboard equivalents

* Standard keyboard navigation

* Operating system accessibility

* Assistive technology products

¢ Navigation concepts

QMF for WebSphere accessibility features include:
* Standard keyboard navigation

* Operating system accessibility

* Assistive technology products

¢ Navigation concepts

QMF for Windows accessibility features

Standard keyboard equivalents

The keyboard is the most frequently used alternative for performing mouse
functions. Keyboard equivalents use keyboard keys to perform mouse actions
instead of using a mouse. For example, QMF for Windows supports the
following keyboard equivalents:

* Shortcut, or accelerator keys, to perform the most frequently used functions
in pull-down menus without going to the menu. For example:

— Ctrl+S to save
— Ctrl+P to print
— Ctrl+R to run a query

Shortcuts display in the pull-down menu next to its function.

* Mnemonics, or access keys, are available to perform each function on a
menu or dialog box. A mnemonic for a function is the underlined character
in the function name. For example, press...

- F to open the File menu
- O to open the Open dialog box
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Use ALT to activate the mnemonic and move the keyboard focus.

For more information, refer to the Microsoft Windows Keyboard Design
Guide for a complete list of standard keyboard equivalents.

Standard keyboard navigation

"Keyboard navigation” refers to using keys instead of a mouse to move from
item to item on your screen. The movement is usually in the order specified
by the operating system or your application.

QMF for Windows follows the standards with regard to the typical keys used

for keyboard navigation such using TAB and SHIFT+TAB to move between

controls, and arrow keys to move up, down, and sideways between items.
Operating system accessibility

The Windows operating system has a set of accessibility options that enable
individuals with disabilities to customize system-wide settings. Individuals
can set these options with the Accessibility Wizard on the Control Panel.

QMF for Windows:
* Inherits settings from the Microsoft Windows operating system

* Does not interfere with keyboard accessibility features built into the
Windows operating system

* Complies with the IBM Software Accessibility Checklist.

For more information, please go to:

http://www.ibm.com/able/accesssoftware.html

Assistive technology products

QMEF for Windows supports assistive technology products, such as screen
readers and voice synthesizers.

Note: QMF for Windows requires special navigation when using a screen
reader with query results. See "Navigation in QMF for Windows" for
more information.

Navigation in QMF for Windows

Table 104. Navigation Concepts

To... Do the following...

Obtain online help Press F1 or Alt+H.
Note: In online help, use Tab to jump from link
to link, then press Enter to open the link.
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Table 104. Navigation Concepts (continued)

To... Do the following...
Add object or condition 1. Tab to a pane, such as in the Prompted Query
dialog box.
2. Tab to the "Add" icon.
3. Press spacebar to display the "Add" dialog
box.
Select multiple objects 1. Tab to the list box.
2. Press Shift+Arrow to select rows.
3. Press Shift+Enter to add the objects.
View object properties in an object | 1 Select the object from the object list.
list 2. Press Alt+Enter.
Use screen reader for query Option 1
results 1. Run the query.
- or - 2. Press Alt+R to open the Results menu.
3. Select Save to File.
Use brqwsgr to display query 4. Select HTML file (*.htm) for Save as Type.
results in high-contrast mode for
the visually impaired 5. Open the *htm file in browser.
Option 2
1. Run the query.
2. Press Alt+R to open the Results menu.
3. Select Display Report.
4. Select the form type.
5. Press OK.
6. Press Alt+O to open the Form menu.
7. Select Convert to HTML form.
8. Check the Include tabular data as HTML
table check box.
9. Press OK.
10. Press Alt+O to open the Form menu.
11. Select View in Web browser
Option 3.
1. Run the query.
2. Press Alt+R to open the Results menu.
3. Select Save to File.
4. Select CSV file (*.csv) for Save as type.
5. Open the *.csv file in Microsoft Explorer or

Lotus 1-2-3.
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Table 104. Navigation Concepts (continued)

To... Do the following...

Edit (editable) rows in list box 1. Tab to the list box, such as the Global
Variables dialog box.

2. Press the spacebar or move the arrow key to
select the row.

Press F2 to activate edit mode.
Use Tab to move between columns and rows.

Press Enter to accept edits.

S o

Press Tab to exit the listbox and move to the
next control in the dialog.

Edit query results Press Alt+E for the Edit menu.

Select Find. The Find dialog box opens.
Type the search text

Press Enter.

Press Esc to close the Find dialog box.
Press Enter to edit the cell.

o gk wbdE

Change font for query results Run the query

Press Ctrl+A to select all
Press Alt+R to display the Results menu

P wbdhPE

Press F to display the font dialog box

QMF for WebSphere accessibility

Standard keyboard navigation

"Keyboard navigation” refers to using keys instead of a mouse to move from
item to item on your screen, usually in the order specified by the operating
system or your application.

QMEF for WebSphere follows the standards with regard to the common keys
used for keyboard navigation such using TAB and SHIFT+TAB to move
between controls, and arrow keys to move up, down, and sideways between
items.

Operating system accessibility
Your operating system has a set of accessibility options that enable individuals
with disabilities to customize system-wide settings to further enhance and
improve their ability to use their computer. QMF for WebSphere inherits and
does not interfere with the keyboard accessibility features that are set for the
operating system.
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Assistive technology products

QMF for WebSphere supports assistive technology products, such as screen
readers and voice synthesizers, to deliver information in a more accessible
manner.

Keyboard navigation in QMF for WebSphere

Table 105. Navigation Concepts

To... Do the following...

Move focus through each element |Press TAB to move forward or SHIFT+TAB to
move in the opposite direction.

Emulate clicks on a link Use the TAB key to jump from link to link, then
press the Enter key.

Emulate clicks on a button Use the TAB key to jump from button to button,
then press the key.

Within a dialog, activate the Press the Enter key.
default action

Within a dialog, cancel the action |Press the Esc key.

Move focus to the command line | Press the ALT+C keys.

Move focus to the main menu Press the left ALT key. Navigate through the
menu commands using the arrow keys.

Open context menus Press the Context menu key if you have an
extended keyboard. You can also press the right
Ctrl key to open a context menu. Navigate
through the menu commands using the arrow
keys.
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Appendix B. Object Analyzer

Determining dependencies

The Object Analyzer provides information about the dependencies an object
has on other objects, such as queries that are referenced by a procedure. The
analysis is based on the retrieval and parsing of an object (based on the
current user and substitution values), the determination of which objects are
referenced, and an analysis performed on all referenced objects.

The Object Analyzer analysis is triggered when you expand the Dependencies
node on the Database Explorer tree. This analysis will return dependency
information, as described in the next section.

Displaying dependencies

Objects displayed in the Database Explorer tree have a single child node that
is labeled, Dependencies.

When you expand the Dependencies node on the Database Explorer tree, an
analysis will be triggered to determine the selected object’s dependencies, as
described above. After the analysis, all referenced objects will display beneath
the Dependencies nodes and all operations that can be performed on regular
objects can be performed on objects in the Dependencies node.
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Appendix C. Notices

This information was developed for products and services offered in the
U.S.A. IBM may not offer the products, services, or features discussed in this
document in other countries. Consult your local IBM representative for
information on the products and services currently available in your area. Any
reference to an IBM product, program, or service is not intended to state or
imply that only that IBM product, program, or service may be used. Any
functionally equivalent product, program, or service that does not infringe
any IBM intellectual property right may be used instead. However, it is the
user’s responsibility to evaluate and verify the operation of any non-IBM
product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give
you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation

North Castle Drive
Armonk, NY 10594-1785
US.A.

For license inquiries regarding double-byte (DBCS) information, contact the
IBM Intellectual Property Department in your country or send inquiries, in
writing, to:

IBM World Trade Asia Corporation
Licensing

2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any
other country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE
IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY
OR FITNESS FOR A PARTICULAR PURPOSE. Some states do not allow
disclaimer of express or implied warranties in certain transactions, therefore,
this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will
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be incorporated in new editions of the publication. IBM may make
improvements and/or changes in the product(s) and/or the program(s)
described in this publication at any time without notice.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the
purpose of enabling: (i) the exchange of information between independently
created programs and other programs (including this one) and (ii) the mutual
use of the information which has been exchanged, should contact:

IBM Corporation

J46A /G4

555 Bailey Avenue

San Jose, CA 95141-1003
US.A.

Such information may be available, subject to appropriate terms and
conditions, including in some cases, payment of a fee.

The licensed program described in this information and all licensed material
available for it are provided by IBM under terms of the IBM Customer
Agreement, IBM International Program License Agreement, or any equivalent
agreement between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments
may vary significantly. Some measurements may have been made on
development-level systems and there is no guarantee that these measurements
will be the same on generally available systems. Furthermore, some
measurement may have been estimated through extrapolation. Actual results
may vary. Users of this document should verify the applicable data for their
specific environment.

All statements regarding IBM’s future direction or intent are subject to change
or withdrawal without notice, and represent goals and objectives only.

This information is for planning purposes only. The information herein is
subject to change before the products described become available.
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Trademarks

The following terms are trademarks of the IBM Corporation in the United

States or other countries or both:

AIX

C/370

CICS

COBOL/370

DataJoiner

DB2

DB2 Information Integrator

DB2 Universal Database

Distributed Relational
Database Architecture

DRDA

GDDM

IBM

IBMLink

IMS

iSeries
MVS
0S/390
Parallel Sysplex
PL/1

QMF
RACF
S/390
SQL/DS
VM/ESA
VSE/ESA
VTAM
WebSphere
z/0S
zSeries

Java or all Java-based trademarks and logos, and Solaris are trademarks of
Sun Microsystems, Inc. in the United States, other counrtries, or both.

Microsoft, Windows, Windows NT, and the Windows logo are trademarks of
Microsoft Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and

other countries.

Other company, product, and service names may be trademarks or service

marks of others.
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Glossary
A

accelerators. Functions, also known as shortcut
keys, available on pull-down menus to select an
option via the keyboard rather than a mouse.

access keys. (mmnemonics): An underlined
character that performs each menu or dialog
function.

accessibility. Software and hardware
accessibility features help those with physical
disabilities to use their computer.

accessibility options. Options available through
the Accessibility Wizard in the Windows
operating system used to deliver information in a
more accessible manner.

ad hoc query. A query that has not been named
or saved; it has been submitted and executed "on
the fly."

aggregation. Data that is the result of applying
a process to combine data elements. Data that is
taken collectively or in summary form.

B

bind. A process that compiles one or more
DBRMs into an application plan.

C

column. Contains the values that have the same
data type in the database. A value is similar to a
field in a record. A value is the smallest unit of
data that you can manipulate with SQL. The two
basic components of the column definition are
the name and the data type.

CPI-C. (Common Programming Interface for
Communications): Provides a
cross-system-consistent and easy-to-use
programming interface for applications that
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require program-to-program communication.
CPI-C defines a single programming interface to
the underlying network protocols across many
different programming languages and
environments.

csv. (Comma Separated Values): A file format
used as a portable representation of a database.
Each line is one entry or record and the fields in
a record are separated by commas. Commas may
be followed by arbitrary space and/or tab
characters which are ignored. If field includes a
comma, the whole field must be surrounded
with double quotes.

D

DB2 Warehouse Manager. A graphical
environment for creating and managing
high-performance, scalable DB2 data warehouses.

DB2 Warehouse Manager includes the
Information Catalog, which enables users and
Administrators to directly register information in
the catalog--from QMF for Windows--such as
spreadsheets, reports, queries, and other relevant
information that will be shared.

dbf. (dBase database file): A file format for
exporting a database file.

decimal delimiter. A character or string used to
separate or mark the start of and end of items of
data in a database, text file, or in source code. A
decimal delimiter uses a period or comma to
delimit this data.

default resource limits group. When the system
administrator does not assign a user to a
resource limits group or when there are no active
schedules in the resource limits group to which a
user is assigned, the user is assigned to the
default resource limits group <Default>
automatically.
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DRDA. (Distributed Relational Database
Architecture): A set of protocols that software
developers can follow to develop connectivity
solutions between heterogeneous RDBMs. DRDA
coordinates communication between an
application requester (such as QMF for
Windows) and an application server (such as
DB2), by defining what must be exchanged and
how it must be exchanged.

dynamic query. A query whose SQL text is
passed to a database server each time it is
executed. Dynamic queries can contain
substitution variables.

dynamic SQL. A set of facilities which allow
the development of generalized programs; these
programs, in contrast to static SQL programs, can
accept actual SQL statements at execution time
and prepare and execute them.

E

edit codes. Codes that determine how a column
is formatted in a report. You use different edit
codes depending on the type of data you want to
format. Some edit codes include: character, date,
graphic, numeric, time, timestamp, and
user-defined.

embedded SQL. SQL statements are embedded
within a host language program and are
prepared (via the BIND process) before the
program is executed.

Expression Builder. A utility that assists in
building expressions for SQL queries and
prompted queries. The Expression Builder
presents a palette of common elements used to
create SQL expressions such as column names,
constants, functions, and operations. When you
click the Expression Builder buttons, templates
for expression elements are inserted into the
corresponding SQL query window or prompted
query expression window.

F

form. An object that contains the specifications
for printing or displaying a report or chart. The

resulting report is based on certain default
choices made by QMF about the format of the
report. You can modify forms by specifying
break information, calculations, column
alignment, grouping and aggregations, and other
attributes.

G

global variable. Used for executing queries,
procedures, or forms. In a query or procedure,
no dialog box displays for the user to enter a
value if a user-defined global variable has been
created. The value specified for that global
variable will be used instead.

governing. Establishes certain limits and
controls for database and communication
resources.

H

high-contrast mode. A system setting by which
visually impaired users can view the screen.

host variable. Host variables enable you to use
the same static query to retrieve different data.
To retrieve different data, you do not need to
rebind a package for the static query; instead,
you supply different values for the host variables
in the query.

Database servers specify rules for where host
variables can appear in a query. Refer to
documentation for your database server for these
rules.

Host variables must have a specific data type. A
value that you provide for a host variable must
conform to that variable’s data type.

HTML. A platform independent programming
code file. Contains unformatted ASCII text
instructions used by a Web browser on the World
Wide Web. Invented by Tim Berners-Lee,
formerly of CERN-Geneva.

Information Catalog. Included in the DB2
Warehouse Manager, and enables users and
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Administrators to directly register information in
the catalog--from QMF for Windows--such as
spreadsheets, reports, queries, and other relevant
information that will be shared

Information Catalog Manager. A component of
DB2 Warehouse Manager that: populates the
catalog through metadata interchange with Data
Warehouse Center and other analytical and
reporting tools; enables users to register shared
information objects directly; provides direct
navigation or searching across objects to find
relevant information; displays metadata about
the object; launches tools used to render the
information for the end-user.

Intelligent Miner Scoring. A tool that is
implemented as database extenders. Your
applications score records--segment, classify, or
rank the subject of those records--based on a set
of predetermined criteria expressed in a data
mining model. The mining model and the
scoring logic are isolated from the application.

ixf. (Integration Exchange Format): A file format
used to import or export data.

J

job. A file used to schedule and run unattended
procedures. A job file can store a user ID,
encrypted password, and substitution variables.

K

keyboard equivalents. Keystrokes necessary to
perform mouse functions using the keyboard.

keyboard navigation. A method of using the
keyboard instead of the mouse to move from
item to item on your screen.

L

large object. (LOB): A database entry containing
a file that is stored within the database. LOBs
can contain text files, multimedia files, or
virtually any type of object.

linear procedure. Any procedure that does not
begin with an IBM Object REXX comment. A
linear procedure can run QMF commands,
comments, blank lines, RUN commands, and
substitution variables.

list. To display data in an ordered format. For
example, the LIST command in BASIC displays
lines of a program. A list is any ordered set of
data.

LOB. (Large Object): A sequence of bytes
representing bit data, single-byte characters,
double-byte characters, or a mixture of single-
and double-byte characters. A LOB can be up to
2 GB-1 byte in length.

LOB values may or may not be stored inline
with other row data in the database. In either
case, LOBs have the full transactional support of
the database server. A database table stores a
LOB locator which points to the LOB value
which may be in a different storage space.

M

matching patterns. A character (such as % or _)
used in a query, form or table name instead of a
specific character.

Use the percent character to match a string of
any length containing any characters. Use the
underscore character to match a single character.

mnemonics. (access keys): An underlined
character that performs each menu or dialog
function.

N

natural query. A query written in
conversational English, such as, "Show me all the
managers who work 45 hours or more.” The
query is converted to SQL and run normally at
the database. You must have EasyAsk installed
on your machine to use natural queries.

neural clustering. (Used in Intelligent Miner
Scoring): A technique that employs a type of
neural network called the Kohonen feature map
that clusters together similar data records and
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defines the typical attributes of an item that falls
in a given cluster or segment. It discovers
associations, sequential patterns, and similar time
sequences and creates predictive or classification
models of the data. It performs deviation
detection by relying heavily on statistical analysis
and visualization. The visualization techniques
are useful for detecting deviations that hold for a
rather small subset of the data, while it uses
statistics to measure their significance.

o)

object. A query, form, procedure, or table.

object list. Tree-structured representations of
the database objects available on the server.
Which objects can be viewed depends upon your
resource limits. Objects can be added and
removed from the object list; also, the objects can
be saved and shared with other users.

object tracking. An option that keeps a detailed
record whenever a specific object is used, and
identifies the time the object was run, who ran it,
and the results.

ODBC. (Open Database Connectivity): A
standard for accessing different database
systems. There are interfaces for Visual Basic,
Visual C++, SQL and the ODBC driver pack
contains drivers for the Access, Paradox, dBase,
Text, Excel and Btrieve databases.

An application can submit statements to ODBC
using the ODBC flavor of SQL. ODBC then
translates these to whatever flavor the database
understands. ODBC is based on Call-Level
Interface and was defined by the SQL Access
Group.

OLAP. (On-line analytical processing) OLAP
queries perform complex calculations, trend
analyses and modeling, derived from end-user
requirements. OLAP queries can be used to
perform ad hoc analyses of data in
multidimensions.

P

procedure. An object containing QMF
commands. A procedure can be run with a single
RUN command.

A procedure is a set of commands that enable
you to run queries, print reports, import and
export data, and perform other functions with a
single command.

procedure comments. Text that is not part of
the actual commands that are executed when
you run a procedure. Use comments within the
procedure to store information for future
reference about the procedure.

Procedure comments begin with two hyphens (-
-) and can continue to the end of the line on
which they appear. You can include as many
comments as you want in a procedure. A
procedure’s comments, including the hyphens,
are ignored by QMF for Windows until you
remove the hyphens (uncomment) or remove the
comments.

procedure continuation lines. Each line of a
procedure typically contains a single command.
You can, however, continue a command over
multiple lines by placing a plus sign (+) in the
first column of each additional line.

procedure with logic. Any QMF procedure
beginning with an IBM Object REXX comment.
In a procedure with logic, you can perform
conditional logic, make calculations, build
strings, and pass commands back to the host
environment.

prompted query. A query that is built based on
the user’s responses to a set of dialog windows.
Prompted queries are the recommended method
for writing and editing queries if you are not
familiar with SQL syntax.

Q

query. A request for a specific result set of
information from a database. You can work with
an SQL query, a prompted query or a natural

query.
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query comments. Text that is not part of the
SQL code executed by the database server. Use
comments in the query to store information
about the query for future reference.

Query comments begin with two hyphens (- -)
and can continue to the end of the line on which
they appear. The query comments and hyphens
are ignored by QMF for Windows and the
database server at which you run the query. For
example:

SELECT ID, NAME --names of the columns used
FROM Q.STAFF -- the table containing these
columns

quoting characters. Characters used for
character values and identifiers. Legal characters
are the apostrophe (') and the quotation mark (").
Different quoting characters must be assigned for
character values and identifiers.

R

resource limits. Limits and controls that govern
the use of database and communication
resources. These include setting schedules,
time-outs, limits, authorization to SQL verbs,
binding and object tracking privileges, LOB
options, Report Center, and other options.

resource limits group. Users belonging to a
group for which certain restrictions and
permissions have been defined for schedules,
time-outs, limits, SQL verbs, options, save data,
binding, object tracking, LOB options, and the
Report Center.

resource limits group schedule. The days and
times during which the schedule for a resource
limits group is active or inactive. The schedule
includes parameters for time-outs, limits, SQL
verbs, miscellaneous options, binding, save data,
object tracking, LOB options, and Report Center.

restricted object. An object that is available
only to its owner. Queries, forms, tables, and
procedures are all objects.

results grid. The results of an SQL query,
prompted query, or procedure. A preview of the

results before the data is saved to a form,
exported, or saved as a chart.

REXX. (Restructured Extended Executor): IBM
Object REXX, an interpreted, structured,
procedural script programming language that
allows programs and algorithms to be written in
a clear structured way.

It was designed so that it would be truly easy to
use for both professionals and casual users and
was designed to work in several diverse
application areas -- such as personal
programming, command processing, application
macro processing and application prototyping --
where different languages are typically used. It
is, however, designed to be platform-
independent.

S

screen reader. An assistive technology product
used to deliver information in a more accessible
manner to those who cannot use a mouse.

security. Techniques for ensuring that data
stored in a computer cannot be read or
compromised. Most security measures involve
data encryption and passwords. Data encryption
is the translation of data into a form that is
unintelligible without a deciphering mechanism.
A password is a secret word or phrase that gives
a user access to a particular program or system.

server. A computer system that processes
database queries, such as those from QMF for
Windows.

server definition file. (SDF): An initialization
file created and maintained by QMF for
Windows Administrator that defines server,
connection, resource limits, and other crucial
information for QMF for Windows to connect to
the database server. The SDF is updated each
time a database server s added, updated or
deleted.

shared object. An object that is available to all

users. Queries, forms, tables, and procedures are
all objects.
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shortcut keys. Functions, also known as
accelerator keys, available on pull-down menus
to select an option via the keyboard rather than a
mouse.

shp. (Shape File format): A file format for
spatial data, which is exported data represented
in multiple layers, such as in a topographical
map.

SNA. (Systems Network Architecture): A set of
network protocols developed by IBM. Originally
designed in 1974 for IBM’s mainframe
computers, SNA has evolved over the years so
that it now also supports peer-to-peer networks
of workstations.

spatial data. Any information about the location
and shape of, and relationships among,
geographic features. This includes remotely
sensed data as well as map data.

special characters. Any characters that are not
included in the list of regular characters,
including:

* A through Z (uppercase)

* 0 through 9

. #

© %

- @

SQL query. (Structured Query Language): A
standardized language for defining and
manipulating data in a relational database. SQL
is used to write queries in descriptive phrases.

static query. An SQL query that has been
previously passed to a database server and
bound into a package.

When a static query is executed, the database
server uses the SQL text bound into the package,
rather than the SQL text currently appearing in
the query window. Static queries are more
resource efficient than dynamic queries, but static
queries cannot be edited.

static SQL. SQL statements, embedded within a
program, that are prepared during the program

preparation process, before the program is
executed. After being prepared, the SQL
statement does not change (although variable
values that are specified by the statement might
change).

stored procedure. A group of SQL statements
that form a logical unit and perform a particular
task. Stored procedures are used to encapsulate a
set of operations or queries to execute on a
database server. For example, operations on an
employee database (hire, fire, promote, lookup)
could be coded as stored procedures executed by
application code. Stored procedures can be
compiled and executed with different parameters
and results, and they may have any combination
of input, output, and input/output parameters.
Stored procedures are supported by most
DBMSs, but there is a fair amount of variation in
their syntax and capabilities.

string delimiter. A character or string used to
separate or mark the start of and end of items of
data in a database, text file, or in source code. A
string delimiter uses an apostrophe or quote to
delimit this data.

substitution variable. A variable in a procedure
or query whose value is specified by a global
variable or a run-time variable. Or, it is a
variable in a form whose value is specified by a
global variable.

Substitution variables must begin with an
ampersand (&) and can contain up to 18
characters, which can be alphabetic, numeric or
one of the following characters: [ ! $~ { } ? @
# %\

-

table. A collection of stored data under the
control of the relational database manager,
consisting of a fixed number of rows and
columns. You can interact with tables by running
queries or by using the table editor.

table editor. A tool used to search for, add, edit
or delete table data without writing QMF
statements.
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TCP/IP. (Transmission Control Protocol/Internet
Protocol): The suite of communications protocols
used to connect hosts on the Internet. TPC/IP
uses several protocols, the two main ones being
TCP and IP. TCP/IP is built into the UNIX
operating system and is used by the Internet,
making it the de facto standard for transmitting
data over networks.

txt. (Text): A text-only file format (.txt).

U

usage code. Codes that control how data is
summarized, such as at the end of a column or
as a partial summary at the control breaks in a
table. Which usage codes are available depend
on the data in the column and the type of
summary.

\'

variable. A data element that specifies a value
that can be changed. A variable is a symbol or
name that stands for a value.

voice synthesizer. An assistive technology
product used to deliver information in a more
accessible manner to those who cannot use a
mouse.

w

WinCPI-C. (Windows Common Programming
Interface for Communications): A portable
application programming interface (API), that
enables peer-to-peer communications among
programs in an SNA environment.

CPI-C enables application programs distributed
across a network to work together. By
communicating with each other and exchanging
data, they can accomplish a single processing
task, such as querying a remote database.

WYSIWYG. (What You See is What You Get): a
method by which the content of a document or
form appears as it has been formatted, such as
displaying a custom font style or aggregation
and grouping.
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Index

A

about
accounting string 7
API 203
chart options 112
command bar 223
current objects 121
DB2 Warehouse Manager 255
expression builder 39, 42, 227,
270, 273
forms 90
global variables 209
host variables 147
Information Catalog 255
inner joins 36, 267
intelligent miner scoring 231
job files 159
linear procedures 117
LOB 78
Object REXX 139
outer joins 37, 267, 268
QMF for Windows 1
QMF Report Center 163
replacing variables 147
reports 88, 167
spatial extender 237
SQL 27
static queries 147
substitution variables 50, 147,
209
system global variables 211
table editor 10, 149
absolute row
go-to 77
query results 77
accelerator keys
accessibility 281
access keys
accessibility 281
accessibility
accelerator keys 281
access keys 281
add object 283
assistive technology 282
edit
rows 284
features 281
mnemonics 281
object properties 283
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accessibility (continued)

online help 282
operating system 282
query results

edit 284

font 284
screen reader 283
select multiple objects 283
shortcut keys 281
software 281
standard

keyboard equivalents 281
visually impaired 283

accessing
recent
files 11
objects 11
accounting string
about 7
specify 7
add
buttons
toolbar 25

global variables 210
procedure 211
objects
list 145
reports
favorites 166
row
table editor 150
add object
accessibility 283
add-in
applications
Lotus 1-2-3 2
Microsoft Excel 2
versions 2
Lotus 1-2-3 156
Microsoft Excel 156
advanced options
zoom edit 85
aggregation
OLAP 59
side group
no summaries 73
summaries 72

top group
no summaries 71

aggregation (continued)
top group (continued)
summaries 71
all

columns
autofit 76
TrOWS
autofit 76
API
about 203

additional information 207
blocking calls 203
build applications 157
control
QMF for Windows 205
database connections 204
example 206
governing 204
unit of work 204
using 203
application
LOB associations 82
QMF for Windows

APl 157
as-is
zoom edit 85
ascending

sort results 76
assistive technology
accessibility 282
QMF for Windows 282
screen reader 282
voice synthesizer 282
associate
forms with objects 198
autofit
all
columns 76
rows 76
cell 76
column 76
query results 76
row 76
available
column 40, 271
average
column value
query results 75

301



binary
format
zoom edit 85
bind package
query menu 30
blocking calls
API 203
bottom
command 123
browser
visually impaired 283
build
applications
API 157
reports 88

C

calculations
ObjectREXX 141
cancel
query menu 28
cell
autofit 76
change
passwords 7
row
table editor 150
chart
about 112
options 112
check
form menu 89
on OK
form menu 89
classification
intelligent miner scoring 232
CLI
connectivity 2
trace options 22
close
all result windows
procedure menu 118
intermediate result windows
procedure menu 118
clustering
intelligent miner scoring 232
column
autofit 76
available 40, 271
count
query results 74
cumulative
percentage of group 75
percentage of total 76

column (continued)
cumulative (continued)
sum 75
LOB associations 82
maximum value 74
minimum value 74

paste

format 76
value

average 75
values

percentage of group 75
percentage of total 75
standard deviation 75
summary row 74
column definitions
ObjectREXX 140
command
bottom 123
connect 123
convert 123
display 124
draw 125
erase 125
export 126
forward 128
import 128
prepare 27
print 129
procedure 120
reset global all 131
run 27,132, 263
save 134
send to 135
set global 136
show 137
windows 137
command and procedure
global variables 215
command bar
about 223
execute commands 223
parameters 223
run command 16
use 225
view menu 16
working from 223
comment
procedure menu 118
query menu 28
report 192
view
objects 192
comments
procedure 120

complex calculations
ObjectREXX 141
compliance
operating system
QMF for Windows 282
confirm
stored procedure parameters
connect
CLI 2
command 123
ODBC 2
server 166
SNA 2
TCP/IP 2
terminating 12
to server
QMF Report Center 166
view 14
view menu 14
conventions
manual ix
convert
command 123
HTML
form menu 90
copy
dimension 58
folders 171, 199
from server 199
measure 58
objects 171, 199
reports 171, 199
tables
on server 201
within Favorites 199
count
query results 74

CPI-C
options 18
trace options 22
create

job files 160
linear procedure 119
list 144
procedure

logic 140

with logic 140
reports 167

from server 167

locally 167

QMF Report Center 167
SQL queries 48, 49, 119
static queries 147
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cumulative
percentage of group
column 75
percentage of total
column 76
query results 76
sum
column 75
query results 75
current objects

about 121
customize
toolbar 25
D
data types
host variables 147
database
connections
API 204
retrieve
LOB 79
security
set 6
database server
eligible 3
open
saved form 103
save
form 102
object 256

date substitution values
description 182, 183, 184
DB2
servers
QMF Report Center 164
warehouse manager
use 255
DB?2 spatial extender
work with 237
DB2 Warehouse Manager
about 255
DDM
trace options 22
default values
enter 18
definition
linear procedures 117
definitions
QMF Report Center 163
delete
folders 172, 200
global variables 211
objects 172, 200
reports 172, 200

delete (continued)
row
query results view 84, 150
table editor 150
scheduled job 193

descending
sort results 76
description
date substitution values 182,
183, 184

miscellaneous properties 185
schedule options 185, 186, 187
details
show 14
Dictionary
Construction Kit
EasyAsk 48
Editor
EasyAsk 47
Map
EasyAsk 47
Properties
EasyAsk 48
dimension
copy 58
directory structure
QMF Report Center 164
disabled
accessibility 281
operating system 282
display
chart
form menu 112
results menu 112
command 124
information
global variables 214
map
layers list 251
spatial extender 251
null values 18
object 144
list window 144
distribute data
export to applications 153
export to databases 153
draw
command 125
object 144
list window 144
queries 48
draw query
file menu 9
identifier 10
server 9

drill down
OLAP 59

dynamic SQL
revert to 31

E

EasyAsk
Dictionary Construction Kit 48
Dictionary Editor 47
Dictionary Map 47
Dictionary Properties 48
Open Dictionary 47
Query Builder 47
Set Date 47
View Interpretation 47
edit
copy 191
cut 191
delete 191
form menu 89
global variables 211
LOB 80
menu 191
object 144
list window 144
paste 191
query results
accessibility 284
rename 191
row
accessibility 284
scheduled job 193
select server 191
server 191
tables
query results view 84, 150
eligible
database servers 3
embedded SQL
trace options 22
enter
default values 18
null values 18
sort condition 40, 271
sort direction 40, 271
erase
command 125
ESRI visualization
spatial extender 239
example
intelligent miner scoring 232
exclusions
operating system 2
exit
file menu 12
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export
command 126
data
features 153
to files 153
favorites 194
LOB 80
reports 103
expression builder
about 39, 42, 227, 270, 273
functions using 39, 40, 42, 270,
271, 273
open 227
SQL expressions 227
Expression Builder
SQL query 29, 42, 273
extension
map column 83

F

favorites
add
reports 166
folder
QMF Report Center 164
QMF Report Center 165
report properties 173
features
accessibility 281
export data 153
LOB 79
QMF Report Center 163
file extension
LOB 83
file menu
draw query 9
server 9
exit 12
import data 11
new
form 8
job 8
list 8
object 8
procedure 8
open 9
open from server
form 9
list file 9
procedure 9
query 9
recent
files 11
objects 11
spatial extender 239

file menu (continued)
table editor 10
terminate connections 12
filter
object 192
server 193
first summary row
query results 74
folders
copy 199
QMF Report Center 165
font
options 66
query results
accessibility 284
set 90
form
about 90
column definitions
ObjectREXX 141
conditions
ObjectREXX 140, 142
detail variations
ObjectREXX 142
new 8
object 143
open 9
from server 9
save
to file 102
form calculations
ObjectREXX 139
form menu
check 89
check on OK 89
convert to HTML 90

display
chart 112
edit 89
select query 90
set
font 90
server 90

user information 90
web browser 90
format
binary 85
hex 85
OLAP 58
options
query results 61
report 174
query results 275
forward
command 128

G

general options
report 173, 174
special values
display null values 18
enter default values 18
enter null values 18
view menu 17
global variables
about 209
add 210
procedure 211
command and procedure 215
delete 211
display information 214
edit 211
naming convention 212
state information 213
table editor 214
update
registry 210
user-defined 210
view
variable values 212
view menu 14
Windows environment 216
work with 209
go-to
absolute row 77
percent of result set 77
query results 77
relative to current row 77
governing
API 204
grouping
OLAP 59
side group
no summaries 73
summaries 72
top group
no summaries 71
summaries 71

H

hex
format
zoom edit 85
hide
server 193
hide column
OLAP 59
history details
report 193
host variables
about 147
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host variables (continued)
data types 147

IBM ObjectREXX
requirements 3
trace options 22

identifier
draw query 10

import
command 128
favorites 195
import data
file menu 11
IXF
messages 154
procedure 154
Information Catalog

about 255
initialize

object 191
insert

query type 10
integration

spatial extender 238
intelligent miner scoring
about 231
example 232
functions
Q.PredictClass 235
Q.PredictClassConf 235
Q.PredictClusConf 233
Q.PredictClusScore 234
Q.PredictClusterID 233
Q.PredictValue 236
scoring functions 231
classification 232
clustering 232
numeric value prediction 232
internet mail
trace options 22
IXF
messages
import data 154
J

job
toolbar 15

job files
about 159
create 160
new 8
query menu 159
run 160

job files (continued)
save
to file 160
to server 160
schedule 161
work with 159
join condition
left outer 37, 267, 268
prompted queries 36, 267

K

keyboard design
Microsoft 282

L

last summary row
query results 74
launch
QMF for Windows 194
layers list
display map 251
limit
rows returned 201
line continuation
procedure 120
linear procedures
about 117
create 119
list
add
objects 145
create 144
menu 144
new 8
object 143
remove
objects 145
save
to files 145
window
display object 144
draw 144
edit object 144
run object 144
work with 143
list file
open 9,145
from server 9
LOB
about 78
associations
application 82
column 82
column associations 82
edit 80

LOB (continued)
export 80
features 79
file extension 83
procedure
export 81
retrieve
from database 79
retrieve all values 82
types associations 83
view 80
log on
database security 6
password 6
QMF for Windows 6
remember password 6

user ID 6
logic

ObjectREXX 139
Lotus 1-2-3

add-in 156

output

QMF Report Center 176
use add-in 156

M
main
toolbar 15
manual
conventions ix
terminology ix
map
column
extension 83
save as 238
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