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Taskmaster Window 

This chapter examines the Taskmaster Window and its components - its menus and 
toolbars, and the special functions you can call upon with the click of your mouse. 

9 Chapter 3 introduces but does not investigate windows such as the Operations window 
and Task Monitor (Chapter 4), and the Job Monitor and Station Monitor (Chapter 5).  

9 Similarly, Chapter 3 introduces but does not explore the Taskmaster Administrator. 
Reflecting both the scope of this topic and its importance, Chapter 6 deals exclusively 
with the Taskmaster Administrator’s tabs, settings and procedures.  
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 Taskmaster’s 1040EZ training application supplies this chapter of the Windows & 
Dialogs Reference with numerous examples and illustrations. To access this application, 
follow the instructions on Page 5. And don’t hesitate to experiment freely with 1040EZ as 
you devise ways to take full advantage of the Taskmaster Window and its many tools.  
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Taskmaster Window – with  

Operations Window and Job Monitor 
 

9 The illustration above depicts the Taskmaster Window when two essential components 
are active: 

• The Operations window holds the Job-Task shortcut icons that allow authorized 
individuals – operators, supervisors and Administrators – to initiate a job’s task 
activity. Chapter 4 describes this window   

• The Batch Information Table of the Job Monitor is an up-to-the-minute list of all 
batches in the processing queue. Taskmaster’s Job Monitor Manager permits 
supervisory personnel to open and maintain multiple Job Monitors. For a 
complete explanation, see Chapter 5. 
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Taskmaster Window 
The Taskmaster Window is the center of an application’s administrative and workflow 
activities. 

 
Taskmaster Window 

As Administrator, you’ll use this window and the tabs of the Taskmaster Administrator 
window (Chapter 6) to design and test an application’s workflows, jobs and tasks - and to 
install your Application Security program. 

You’ll use the Taskmaster Window and its Station Monitor window (Chapter 5) to 
review the status of each participating workstation. 

You, your supervisors, and your operators will use the Taskmaster Window and its 
Operations window (Chapter 4) to initiate and monitor a workflow’s jobs and tasks, and 
the batches they process. 

In addition, special menu items and toolbar icons allow you to: 

• Communicate with workstations and users in the Datacap network (Page 31). 

• Initiate task processing from “remote” workstations (Page 80). 

• Generate Log files detailing network activity (Page 70). 

Upcoming pages examine the structure and components of the basic Taskmaster 
Window. 
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Accessing the Taskmaster Window 
Application Security (Chapter 6) places strict limits on personal access to a Taskmaster 
application. With proper authorization, however, you can access the Taskmaster Window 
from your Windows Start button or from your desktop. 

 Alert! The steps below assume that Taskmaster Server Service is in place and available 
to an application’s Taskmaster Clients. For a full explanation, see Chapter 2. 

To Access Taskmaster from the Start Button…. 
Step Action 

1. Click on the Start button in the lower left-hand corner of your Windows 
screen. 

2. Select Datacap Taskmaster from the Programs directory, followed by 
Applications. 

3. From the list of pre-defined applications, select 1040EZ. This is a sturdy 
training application – easy to use and nearly impossible to abuse! 

4. Click once on the 1040EZ Client option (again, assuming that Taskmaster 
Server Service is up and running): the User ID & Password dialog will 
appear on your screen. 

 

5. To meet the initial requirements of Application Security, enter your User ID 
and Password in the User ID & Password dialog, and press the OK button: 
the Taskmaster Window will appear, along with its Operations  window.  

To access Taskmaster from your Desktop 
To access Taskmaster from your desktop, double-click to open the Datacap Taskmaster 
folder, the Applications folder, and the 1040EZ folder (or the folder for your 
application!). Double-click on the 1040EZ Client icon (not the 1040EZ Serverless 
icon), and carry out Step #5 above. 
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Taskmaster Window–Basics  
The Taskmaster Window defines, initiates and supervises every aspect of an application’s 
workflow. The chart below illustrates the window’s components–and its scope. 

Title Bar

Menu Bar

Toolbar

DATA AREA

Operations
 Window

Task
Monitor

Job
 Monitor

Station
Monitor

Taskmaster
Administrator

Status Bar

Taskmaster Window  

Title Bar. Information in the title bar identifies the Taskmaster Window. If the 
Operations window or Job Monitor is active, the Title Bar displays the application’s 
name (see the opposite page). 

Data Area. Jump down to the Data Area for a moment. The Taskmaster Window 
functions in three modes–and its structure changes in response to the current mode. 

• In an operating mode, the Operations window or Task Monitor dominates the 
Data Area (Chapter 4). 

• In a supervisory mode, the Job Monitor and Station Monitor track workflow and 
workstation activity (Chapter 5).  

• In an administrative mode, the Taskmaster Administrator defines workflows, 
jobs and tasks, and sets up Application Security (Chapter 6). 

Menu Bar.  The makeup of the Menu Bar changes in response to changes in mode (see 
the examples on the next page.) In its operating mode, when the Operations window is 
active, the Taskmaster Window has seven menus. In its supervisory mode, when the Job 
Monitor is active, the Menu Bar has eight menus. The contents of individual menus 
change, too. An “empty” Taskmaster Window has only two items in the File menu and 
six in the View menu. When the Operations window is active, the File menu has six 
items and the View menu has eleven. (For complete explanations of all menus and menu 
items – in all modes - see Page 9.) 
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Toolbar. Most icons in the toolbar of the Taskmaster Window duplicate menu items. As 
a result, the toolbar’s makeup changes according to the window’s mode. You can also 
customize a toolbar by adding or removing icons available for that mode. (For 
explanations of the icons, see Page 31.) 

Status Bar.  The Status Bar identifies: the user and workstation; the server’s response 
time to requests from this client (in milliseconds); and the Settings file (.ini) with 
specifications for the Taskmaster Client you’re running.  
 

 
Taskmaster Window–with Operations Window 
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Taskmaster Window–with Job Monitor  
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Menus of the Taskmaster Window 
The sections below describe the fully-expanded menus of the Taskmaster Window. If 
applicable, the overview of a menu highlights the changes that occur in response to 
changes in the Taskmaster Window’s mode. 

In addition, descriptions of individual menu items (Page 11) identify any links to icons of 
the window’s toolbar. 

File Menu 

Overview 
The File menu of an empty Taskmaster Window has two core functions:  

• Message Font gives you a chance to review or modify the default font and type 
size of the Taskmaster Message Pad. 

• Exit closes the Taskmaster application. 

In the window’s operating mode–when the Operations window is active–the menu adds 
four workflow items to the core functions: 

• Run Tasks initiates tasks represented by a Job-Task shortcut you’ve highlighted 
in the Operations window (illustrated on the next page.) 

• Remove removes a highlighted Job-Task shortcut from the Operations 
window…after an appropriate warning. 

• Properties accesses a highlighted icon’s Shortcut Properties dialog (Chapter 6), 
and a list of the shortcut’s Job-Task permissions. 

• Unload Tasks closes the windows and dialogs associated with a task that is not 
active at the moment. 

In the window’s supervisory mode–when the Job Monitor or Station Monitor is active–
the menu provides items the Administrator can use to format printouts of the tables these 
windows contain: 

• Print, Print Preview and Print Setup retrieve standard Windows printing 
dialogs. 

• Page Setup formats the tables before they are printed, according to the 
Administrator’s specifications. 

• Header/Footer governs the generation of a report’s header and footer 
information.  
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File Menu 

 
File Menu–Operating Mode 

 

 
File Menu–Supervisory Mode 
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Items of the File Menu 
The table below describes all items of the complete File menu.  

Item Keyboard Windows Description 

Message Font n/a All Accesses the Windows Font Selection dialog. 

You can use this dialog to modify the Message 
Pad’s font, type size and format. 

Run Tasks Enter Operations Initiates the Job/Task Combination represented 
by the shortcut icon you’ve highlighted in the 
Operations window (see the illustration on the 
previous page.) 

If the icon represents one task assigned to one 
job, selecting Run Tasks begins task 
processing. 

If the highlighted icon represents a task 
assigned to multiple jobs within the 
application, the Select Job to Run dialog will 
appear (Chapter 4). 

Remove Tasks Del Operations Removes the highlighted shortcut from the 
Operations window’s Data Area. 

Taskmaster will first ask you if you’re sure you 
want to delete the icon. Pressing the Yes button 
removes the icon but does not delete the 
associated Job/Task Combination(s) from the 
workflow.  

However, they are now more difficult to reach: 
you have to use the Run Task item in the 
Databases menu (Page 25) or the Run Task 
toolbar icon (Page 35). 

Properties Alt + Enter Operations Accesses the Shortcut Properties dialog of a 
shortcut icon you’ve highlighted in the 
Operations window. 

This dialog lists the Job/Task Combinations 
represented by the shortcut (Chapter 6).  

The   toolbar icon duplicates this 
function. 

Unload Tasks Ctrl + U Operations Closes Taskmaster operations directly 
associated with any tasks that have stopped 
processing. 

The   toolbar icon duplicates the 
functions of this item. 
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 File Menu (continued)  
Item Keyboard Windows Description 

Print Ctrl + P Job Monitor, 
Station Monitor 

Accesses the Windows Print dialog. 

Note: The settings in the Print dialog reflect 
the host computer’s most recent use of 
Windows technology to print a document. Be 
sure to check these settings carefully before 
printing Job Monitor or Station Monitor 
tables. For details, see Chapters 5. 

Print Preview n/a Job Monitor, 
Station Monitor 

Turns over the Data Area to the Windows Print 
Preview window.  

This window can be exceptionally helpful as 
you consider alternative report formats.  

Print Setup n/a Job Monitor, 
Station Monitor 

Accesses the Windows Print Setup dialog. 

Again, the settings in this dialog are those of 
the host computer’s most recent printing 
“event” and may have no relevance to the 
generation of a supervisory report. 

Page Setup n/a Job Monitor, 
Station Monitor 

Accesses a highly specialized version of the 
Windows Page Setup dialog. 

The dialog deals exclusively with a report’s 
table format. For more information, see 
Chapters 5.  

Header/Footer n/a Job Monitor, 
Station Monitor 

Accesses a Windows Header/Footer dialog. 

This dialog has a single focus: you can use it to 
review and modify the Header and Footer 
portions of a supervisory report (Chapter 5). 

Exit n/a All Closes Taskmaster Client. 

If you are operating in a “serverless” mode, 
selecting this item also closes Taskmaster. 

If you are operating in client/server mode, 
Taskmaster Server Service remains active after 
the client signs off. 
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Taskmaster Window: Full Menu Bar 

View Menu 

Overview 
Like the File menu, the contents of the View menu of the Taskmaster Window change 
according to the window’s mode. But the View menu is even more fluid. 

When the Data Area of the Taskmaster Window is empty, the View menu contains items 
in four categories: 

Customize accesses the Customize Toolbar dialog: you can use this dialog to review 
the makeup of the window’s primary toolbar, and to assemble additional, special-
purpose toolbars (Page 44). 

Status Bar is a toggle switch that displays or hides the window’s Status bar. 

Operations, Job Monitor and Station Monitor retrieve their respective windows 
and place them in the Taskmaster Window’s Data Area. 

Job Monitor Manager accesses a dialog that you can use to define and install 
multiple Job Monitors (Chapter 5). 

When the Station Monitor is active in the Data Area of the Taskmaster Window, the 
View menu adds two categories: demagoguery 

Zoom In, Zoom Out and 100% alter the magnification of the Station Monitor’s 
appearance within the Data Area. 

Find and Find Again are tools you can use to find entries in a large table. 

The Job Monitor employs all items above, and adds three more: 

Filter accesses the Job Monitor Filter. This powerful device lets you filter a long list 
of batch transactions which are awaiting processing or have completed their cycles, 
according to parameters you supply (Chapter 5). You can also use the tools of the 
Job Monitor Manager to define filters.  

New Monitor places a second, duplicate Job Monitor within the Data Area. If the 
list of batches in the Batch Information Table grows suddenly and significantly, a 
second Job Monitor with the same data can help. Usually, however, you’re better off 
using the Job Monitor Manager to plan, test and employ multiple Job Monitors.  

When a Job Monitor or Station Monitor is active, the View menu adds a formatting 
category with four items. These allow you to “freeze” and un-freeze a column or rows of 
the Information Table which a prominent component of each (Chapter 5). 
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Items of the View Menu 

The table below describes the items of the complete View menu.  

Item Windows Keyboard Icon Description 

Customize All n/a n/a Accesses the Customize Toolbar dialog. 

Settings in this dialog determine the 
makeup of the Taskmaster toolbar 
currently in use, and of any toolbars you 
add (Page 40). 

Status Bar All n/a n/a Toggles the Taskmaster Window’s 
Status bar on and off.   

Operations All except 
Operations 

Ctrl + O 
 

Retrieves the Operations window 
(Chapter 4). 

Job Monitor All except Job 
Monitor 

Ctrl + J 
 

Retrieves the Job Monitor (Chapter 5). 

Station Monitor All except 
Station 
Monitor 

Ctrl + S 
 

Retrieves the Station Monitor (Chapter 
5). 

Job Monitor 
Manager… 

All n/a n/a Accesses the application’s Job Monitor 
Manager, which you can use to set up 
and install multiple Job Monitors – each 
with a different purpose and scope 
(Chapter 5).  

Large Icons Operations n/a n/a Displays “large” shortcut icons in the 
Data Area of the Operations window, 
with a title below each icon (Chapter 4). 

Note: These formatting options are also 
available if you right-click on the icon.  

Small Icons Operations n/a n/a Displays significantly smaller icons in 
the Data Area of the Operations, with 
titles next to the icons. 

List Operations n/a n/a Lists small icons and their titles along 
the left side of the Data Area.  

Details Operations n/a n/a Lists small icons, with titles and 
descriptions, along the left side of the 
Data Area. 
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View Menu (continued)  
Item Windows Keyboard Icon Description 

Arrange Icons Operations n/a n/a Three settings that position a set of 
Large Icons or Small Icons within the 
Data Area of the Operations window. 

These items have no effect if the icons 
are in a List or Details structure (above). 

      Line Up  
      Icons 

Operations n/a n/a Places the icons in one or more rows.  

      Align to Top Operations n/a n/a Places all icons in a row at the top of the 
Data Area. 

      Auto- 
      Arrange 

Operations n/a n/a A toggle-switch that places all icons in a 
row at the top of the Data Area and locks 
them in place. 

Zoom In Job Monitor, 
Station Monitor 

n/a 
 

Increases the magnification of data in 
the tables of the Job Monitor and 
Station Monitor. 

Zoom Out Job Monitor, 
Station Monitor 

n/a 
 

Decreases the magnification of tables in 
the Job Monitor and Station Monitor. 

100% Job Monitor, 
Station Monitor 

n/a 
 

Returns the magnification to a standard 
“100%.” 

Freeze Columns Job Monitor, 
Station Monitor 

n/a n/a “Freezes” the data in columns you’ve 
highlighted in the window’s Information 
Table. 

Freezing is a temporary display measure 
you can employ to control the range of  
scrolling to columns and rows. 

Unfreeze 
Columns 

Job Monitor, 
Station Monitor 

n/a n/a Releases a column you’ve previously 
frozen. 

Freeze Rows Job Monitor, 
Station Monitor 

n/a n/a Freezes the data in rows you highlight. 

Unfreeze Rows Job Monitor, 
Station Monitor 

n/a n/a Releases previously frozen rows.  
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View Menu (continued)  
Item Windows Keyboard Icon Description 

Filter Job Monitor Ctrl + R 
 

Accesses the Job Monitor Filter. 

Often, the list of batch transactions in 
the Job Monitor grows quickly. The Job 
Monitor Filter uses search-and-select 
parameters you provide to revise the 
list’s order, or to limit its content.  

For a full explanation, see Chapter 5. 

New Monitor Job Monitor n/a 
 

Adds a Job Monitor to the Data Area. 

This “new” Job Monitor is an 
independent window and is dominant 
when it first appears. Details are in  
Chapter 5. 

Find Job Monitor, 
Station Monitor 

Ctrl + F n/a Accesses the Find dialog (Chapter 5). 

If you select a column heading in the 
table of the Job Monitor or the Station 
Monitor and enter a “key” value, this 
helpful device will take you right to the 
applicable row. 

Find Again Job Monitor, 
Station Monitor 

F3 n/a Repeats the most recent Find operation 
(above) from your current location 
within the table of the Job Monitor or 
Station Monitor. 
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Record Menu 

Overview 
The Record menu is part of the Menu Bar when a Job Monitor or Station Monitor is the 
active component of the Taskmaster Window’s Data Area – or when the Batch Selection 
dialog appears during processing. 

The menu contains the same set of navigational tools for all three: First Record, 
Previous Record, Next Record and Last Record move you swiftly from row to row 
within a table. 

In addition, the Refresh item has two sub-menu options: 

• Update View “refreshes” a table by adding new information about job and task 
processing in the case of the Job Monitor or Batch Selection dialog, or about the 
Station Monitor’s client/server connections. 

• Change Timeout gives you a chance to change the timing of Taskmaster’s 
automatic updates to the Information Tables in these essential processing 
components of the Taskmaster Window. 

 

 
Items of the Station Monitor’s Record Menu 

The Station Monitor’s Record menu includes only the items in the illustration above. 
However, when the Job Monitor and its closely related Batch Selection dialog are active, 
the list expands considerably (see the illustrations on the next page.) 

9 These functions add significantly to the value of the data in the Batch Information Tables. 
Upcoming pages introduce each item in the complete Record menu. Chapter 4 closely 
examines all elements of the Batch Selection dialog; Chapter 5 explores the Station 
Monitor and Job Monitor.  

Confidential and Proprietary Information of Datacap Inc. Page 3–17 
Copyright © 2006 Datacap Inc. 



Record Menu 

 

  
                               Record Menu: Job Monitor 
 

 
                             Record Menu – Batch Selection Dialog 

Page 3–18 Confidential and Proprietary Information of Datacap Inc. 
 Copyright © 2006 Datacap Inc. 



Chapter 3: Taskmaster Window 

Items of the Record Menu 
The table below describes all items of the Record menu.  

Item Window/Dialog Keyboard Description 

Execute Batch Selection Ctrl + E Initiates batch processing by the Job/Task 
Combination in the highlighted row of the Batch 
Information Table. 

Status Change/ 
Rollback 

Job Monitor, 
Batch Selection 

Ctrl + R Accesses the Status Change/Rollback dialog 
(Chapter 5). 

An authorized Supervisor or Administrator can use 
this dialog to roll back a batch to an earlier task, or 
to change its processing status. 

Change 
Properties 

Job Monitor, 
Batch Selection 

Ctrl + P Accesses the Change Operator/Priority dialog 
(Chapter 5) 

An authorized Supervisor or Administrator can use 
this dialog to assign a different operator to the 
batch, or to change the Priority rating of the 
current Job/Task Combination. 

Batch Attributes Job Monitor, 
Batch Selection 

Ctrl + B Accesses the Batch Attributes dialog. 

The fields of this dialog provide current, 
processing information about the batch (Chapter 
5). 

Batch History Job Monitor, 
Batch Selection 

Ctrl + H Accesses the Batch History dialog and the data it 
contains about the progress of the batch through 
the workflow (Chapter 5). 

Change Custom 
Field Properties 

Job Monitor Ctrl + M Accesses the Custom Field Properties dialog. 

This dialog allows you to change the properties of 
a field in the row you have highlighted…in a 
column you have added to the Batch Information 
Table (Chapter 5). 

Delete Job Monitor, 
Batch Selection 

Del Allows an authorized Supervisor or Administrator 
to delete information about a listing in the Batch 
Information Table, or to delete the batch and all its 
files, along with the listing data (Chapter 4 and 
Chapter 5). 

New Batch Batch Selection Ctrl + 
Shift + N 

Creates a new batch, places the batch in the 
processing queue of the job’s Scan task, and 
assigns a Pending status to the batch (Chapter 4). 

This option is available only for tasks built upon a 
Batch Creation Task Module. See the Workflow 
Development and Operations Manual for details. 
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 Record Menu (continued)  
Item Window/Dialog Keyboard Description 

Execute Pending 
Batch(s) 

Batch Selection Ctrl + 
Shift + P 

Gives an operator the chance to intervene 
manually by directing Taskmaster to process 
certain batches with a Pending status (Chapter 4.) 

Cancel Batch 
Selection Mode 

Batch Selection Ctrl + 
Shift + C 

Closes the Batch Selection dialog without taking 
any other action, and returns you to the Job-Task 
shortcuts in the Operations window. 

First Record Job Monitor, 
Station Monitor, 
Batch Selection 

n/a Moves your cursor to the first row of the 
Information Table. 

Previous Record Job Monitor, 
Station Monitor, 
Batch Selection 

n/a Moves your cursor to row above.  

Next Record Job Monitor, 
Station Monitor, 
Batch Selection 

n/a Moves your cursor to row below. 

Last Record Job Monitor, 
Station Monitor, 
Batch Selection 

n/a Moves your cursor to the table’s final row. 

Refresh Job Monitor, 
Station Monitor, 
Batch Selection 

 Taskmaster automatically updates data in the 
tables of the Job Monitor, Station Monitor and 
Batch Selection dialog, according to a default 
schedule. The items in the Refresh sub-menu 
allow you to refresh the listing manually, or 
change the schedule. 

      Update View Job Monitor, 
Station Monitor, 
Batch Selection 

F5 Updates the table with information from 
Taskmaster’s Admin or Engine databases. 

This option duplicates the role of the Refresh  
toolbar icon.  

      Change  
      Timeout 

Job Monitor, 
Station Monitor, 
Batch Selection 

n/a Accesses the Change Timeout dialog (Chapter 5). 

You can use this dialog to change the timing of the 
automatic updates. 

This option duplicates the role of the Refresh 
Timeout toolbar icon 
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Settings Menu 

Overview 
The Settings menu has two segments.  

• The first has seven items, each leading to a tab of the Taskmaster Administrator 
(pictured below.) The table on the next page introduces you to the Taskmaster 
Administrator and its tabs; Chapter 6 provides a comprehensive examination of 
their structures, components and use. 

• The General selection at the bottom of the Settings menu leads to the four tabs of 
the Taskmaster Settings dialog: Databases, Advanced, Background and Log 
Options. The table on the next page introduces this dialog and its tabs; full 
explanations begin on Page 52. 

 
 

 
Taskmaster Administrator–Workflow Tab 

Job Properties
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Items of the Settings Menu 
The table below describes the items of the Settings menu.  

9 The    icon opens the Taskmaster Administrator at the tab you worked with most   
recently. This menu does not include keyboard combinations. 

Item Description 

Workflow Retrieves the Workflow tab of the Taskmaster Administrator. 

Settings in this tab set up an application’s Workflow Hierarchies. A typical 
hierarchy consists of a workflow with a well-defined focus; a Main job 
made up of core tasks to process documents and pages – and the data they 
contain; and special-purpose child jobs.   

The example on the previous page highlights the structure of the 
1040EZ_Rules workflow, and the tasks of the workflow’s 1040EZ Rules job. 
Note carefully that the 1040EZ_Rules workflow has two other jobs.  

Chapter 6 examines the Workflow tab and shows you how to set up a 
Workflow Hierarchy.     

Modules Retrieves the Modules tab of the Taskmaster Administrator. 

This tab lists the processing modules that are the design and operating 
foundations for a workflow’s tasks. For more about the critical role of a Task 
Module, see Chapter 6. 

Groups Retrieves the Groups tab of the Taskmaster Administrator. 

The Groups tab establishes Users Groups, determines which users belong to 
a group, and assigns Job-Task permissions to the group. 

Along with the Users, Stations and Shortcuts tabs, settings in this tab 
construct an application’s Security program. For details of the Groups tab, 
see Chapter 6. For a full explanation of Taskmaster Security, see the 
Administrator’s Guide. 

Users Retrieves the Users tab of the Taskmaster Administrator. 

This tab establishes Security codes and parameters for individuals who will 
be working with an application.  For more about this tab, see Chapter 6, and 
the Administrator’s Guide. 

Stations Retrieves the Stations tab of the Taskmaster Administrator. 

This tab assigns Security codes and Job-Task permissions for workstations 
hosting a Taskmaster Client. For more about the Stations tab, see Chapter 6. 
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 Settings Menu (continued)  
Item Description 

Shortcuts Accesses the Shortcuts tab of the Taskmaster Administrator. 

The Shortcuts tab assembles a set of jobs and tasks, and assigns the set to a 
shortcut icon (Chapter 6). This icon can then appear in the Operations 
window.  

QA Retrieves the QA tab of the Taskmaster Administrator. 

If a workflow contains special Quality Assurance (QA) jobs and tasks, the 
QA tab determines which User Group (above) can carry out a QA job–and 
when.  Chapter 6 shows you how to use this tab. 

General The General item is a sub-menu with three sub-items, each leading to a tab 
of the Taskmaster Settings dialog (Page 52). 
 

You can use the 
 

  toolbar icon to access this dialog. 

      Databases Retrieves the Databases tab of the Taskmaster Settings dialog.  

This tab identifies the Data Source Name (DSN) of the application’s 
Engine database, and its Admin database. For more about this tab, see Page 
52. 

      Advanced Accesses the Advanced tab of the Taskmaster Settings dialog. 

Despite its name, the settings in this tab control basic Taskmaster 
processing features. For details, see Page 60. 

      Background Accesses the Background tab of the Taskmaster Settings dialog. 

You can use this tab to provide an alternative background color or image 
for the Data Area of the Taskmaster Window (Page 63). 

      Log Accesses the Log tab of the Taskmaster Settings dialog. 

The Log tab contains default settings governing the generation and display 
of Log files (Page 65). 
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Taskmaster Administrator – Users Tab 

 

 
Taskmaster Settings Dialog – Databases Tab 

Page 3–24 Confidential and Proprietary Information of Datacap Inc. 
 Copyright © 2006 Datacap Inc. 



Chapter 3: Taskmaster Window 

Database Menu 

Overview 
Directly or indirectly, items in the Database menu govern access to the application’s 
Engine and Admin databases. These are administrative items and can be accessed only if 
the current User has the applicable administrative privileges (Chapter 6). 

• Login allows the Administrator to sign on to an application by entering any 
previously-defined User ID and Password combination (Chapter 6). This simple 
procedure gives the Administrator a chance to test these elements of Application 
Security. Logoff instantly clears the Data Area of the Taskmaster Client with 
which you are working. 

• Change Password lets the Administrator re-define a user’s Password and 
Authentication, on-the-spot, without need for the Users tab of the Taskmaster 
Administrator. 

• Admin Roam and Engine Roam direct the application to an alternative Admin 
or Engine database. 

• Run Task lists your application’s Job/Task Combinations. An authorized 
Administrator or Supervisor can initiate a task from this list without turning to 
the icons of the Operations window.  

Items of the Database Menu 
The table below describes the items of the Database menu.  

9 Items in the Database menu are available when any window or dialog is active in the 
Taskmaster Window’s Data Area.  There are no keyboard combinations for these 
options. 

Item Description 

Login Accesses the User ID & Password dialog. 

This is a very helpful tool when you are testing new or modified User 
Definitions (Chapter 6).   

Logoff Closes the Taskmaster Client with which you are working, and the 
Taskmaster Window. 

Change 
Password 

Retrieves the Change Password dialog. 

This is a handy tool when you are setting up an application and need to 
change an individual’s User Password. 
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 Database Menu (continued)  
Item Description 

Admin Roam Connects Taskmaster to an alternative Admin database.  

This item is available only if: 

• The configuration includes multiple Admin databases; 

• The Enable Roaming feature has been selected in the Databases tab of 
the Taskmaster Settings dialog (Page 52). 

Engine Roam Connects Taskmaster to another Engine database. 

Again, this item is available only if: 

• The configuration includes multiple Engine databases; 

• The Enable Roaming feature has been selected in the Databases tab of 
the Task Settings dialog (Page 52). 

Run Task Accesses the Run Task dialog. 

An Administrator can use this dialog to select and test one or more tasks. For 
details, see Page 68. 
 

The  
 

  toolbar icon accesses this dialog as well. 
 

 
                               Taskmaster Window–Run Task Dialog 
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Tools Menu 

Overview 
Like those of the Database and Settings menus, items of the Tools menu are 
administrative: 

• Log Viewer and Log to File determine the ways in which the application 
generates and displays logs of the client’s Taskmaster activity. 

• Open Chat Window and Send Message initiate and manage communications 
with members of your Datacap network. 

• The three Remote Station items permit the Administrator to process workflow 
tasks from a workstation other than the station on which this Taskmaster Client 
resides. 

• Components info provides details about this Taskmaster Client, and about its 
supporting Taskmaster Server Service.  

 

 
Tools Menu 
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Tools Menu 

Items of the Tools Menu 
The table below describes the items of the Tools menu.  

Item Windows Keyboard Icon Description 

Log Viewer All n/a  

 

Activates the Datacap Log Viewer. 

The Log Viewer displays and 
continuously updates information about 
the client’s performance and its 
connections with Taskmaster Server 
Service. For details, see Page 70 

Log to File All n/a  
 

A toggle switch directing Taskmaster to 
add log data to a file. 

This option is available only if Enable 
Log File has been selected in the Log 
tab of the Taskmaster Settings dialog 
(Page 25). 

Open Chat 
Window 

All n/a  
 

Retrieves the Chat dialog. 

Any authorized user can use this dialog 
to open or participate in a Chat Room 
discussion (Page 46). 

Send Message All n/a  
 

Accesses the Send Message dialog. 

The Send Message dialog allows an 
authorized user to formulate a brief 
message and distribute it to clients in the 
Datacap network (Page 46). 

 

 

 
Log Viewer – with sample data 
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 Tools Menu (continued)  
Item Windows Keyboard Icon Description 

Start Task on 
Remote Station 

All n/a  Allows an Administrator to initiate a 
task on a remote client (Page 81). 

Stop Processing on 
Remote Station 

All n/a n/a Directs the remote station to halt 
processing after it finishes with the 
current batch.  

Shut down Remote 
Station 

All n/a n/a Closes the remote station’s operations 
after it processes the current batch. 

Components 
Information 

All n/a n/a Retrieves the Components Information 
dialog.  

In addition to version and release 
information about Taskmaster Server 
Service and Taskmaster Client, this 
dialog lists and describes the DLL 
components of each. 

 

 
Components Information Dialog – with sample client data 
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Windows Menu 

Windows Menu 
The upper segment of this menu includes standard Windows display options (illustrated 
below). 

The lower segment lists any active, windows. 
 

  

Help Menu 
Items in the Help menu link you to three sources of Taskmaster information. 

Item Windows Keyboard Icon Description 

Help Topics All n/a  
 

Connects you to the Taskmaster Help 
Index and Browser. 

Session Information All n/a  
 

Retrieves the Session Information 
dialog. 

This dialog contains facts about the 
Taskmaster Client you’re running, and 
about its connections to Taskmaster 
Server Service. 

About TM Client All n/a  
 

Displays additional facts about 
Taskmaster Client, and about your 
Datacap configuration. 
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Taskmaster Window–Toolbar Icons 
Three important concepts govern the makeup of the Taskmaster Window’s toolbar. 

Fluidity. The toolbar’s contents change according to the role of the Taskmaster 
Window and the identity of the window or dialog that is active in its Data Area. 

Client specificity. The format and layout of the toolbar in any environment is client-
specific, and governed by settings in the Taskmaster Client’s tmclient.ini file. This 
file resides in the tmclient folder of the on the host computer’s Datacap directory. 

Customization.  The tmclient.ini file initially provides default configurations for the 
toolbar. When Taskmaster Client is first installed on a computer: 

• The empty Taskmaster Window includes 14 toolbar icons. 

• When the Station Monitor is active, there are 18 icons. 

• When the Job Monitor is active, there are 12 icons. 

• When the Operations window is active, the toolbar contains 12 icons. 

But these are Taskmaster’s default configurations. As Administrator, you can 
customize any configuration, adding or removing icons to enhance a user’s 
performance. 

As an example, compare the default layout of the Job Monitor’s toolbar - the one that’s 
in place when the Job Monitor is active – with the toolbar of the Station Monitor (both 
are illustrated on the next page). 

The Station Monitor’s configuration has additional icons. As the next few pages explain, 
some are particularly relevant to the Station Monitor’s activities and would be of little 
value to the Job Monitor. 

But for other icons, this distinction may not be so clear. Consider the Station Monitor’s 
three “magnification” icons. These tools instantly increase or decrease the type size of 
data in the window’s Station Information Table (Chapter 5).  

However, an early decision when you set up an administrative Taskmaster Client might 
well center on this question: When the Job Monitor is active, should the toolbar of the 
Taskmaster Window also include the magnification icons? (In the case of the 1040EZ 
application, the Job Monitor’s does include these icons!)    

Modifying default configurations and adding new toolbars are straightforward 
procedures. But before you review the steps involved (Page 40), spend a few moments 
with the full inventory of toolbar icons. To begin, close any windows or dialogs in the 
Data Area of the Taskmaster Window, and select Customize from the View menu. The 
Toolbars tab of the Customize Toolbar dialog will appear on your screen (illustrated on 
Page 33). 
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Help Menu 

 

 

 
Taskmaster Window – with Job Monitor 

 

 

 

 

Station Monitor Toolbar ConfigurationMagnification icons 

Job Monitor Toolbar Configuration 

Taskmaster Window – with Station Monitor 

The Customize Toolbar dialog has two tabs (illustrated on the next page.). The Toolbars 
tab identifies the toolbars which are active when the Taskmaster Window is in its current 
state. When the Data Area is empty, the File toolbar supplies the window’s icons. (If you 
open the Customize Toolbar dialog when the Operations window is active, this tab 
identifies one toolbar - the Operations toolbar.) 
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File 
configuration 

Customize Toolbar Dialog –Toolbars Tab 
File Toolbar

A Taskmaster toolbar consists of icons, of course, and icons fall into categories. To view 
all icons available for inclusion in the File toolbar, and the category to which they 
belong, go to the Categories tab (below). There are fourteen icons in the File category, 
and the default configuration of the File toolbar includes all fourteen.  
 

 

  File category 

Customize Toolbar Dialog – Categories Tab 
File Toolbar  
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Help Menu 

Now study the icons which are part of the Taskmaster Window’s default Operations 
configuration, keeping an eye on the icons in the File category as well (on the previous 
page). In this environment, the default toolbar features twelve icons. But only one is 
actually from the Operations category; the rest are File icons. (The other Operations 
icons are placed strategically among the menus of the Taskmaster Window, and are 
available for customization.)  

Operations category icon 
 
 

 

Operations 
configuration 

Customize Toolbars Dialog – Categories Tab 
Operations Toolbar

The default Station Monitor configuration employs all five icons in the Monitor 
category, as well as thirteen icons from the File category:  
 

 

Station 
Monitor 
configuration 

Customize Toolbars Dialog – Categories Tab 
Station Monitor Toolbar  
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Finally, the compact Job Monitor configuration adds two icons from the Job Monitor 
category, which have been set aside just for its use. The default icons also include two 
from the Monitor category, and eight from the File category. 

  

 
               Customize Toolbars Dialog – Categories Tab 

                                               Job Monitor Toolbar

Icons of the Taskmaster Window 
The table below describes the icons in each category. Explanations of “Toolbar 
Placement” in the Description/Default Placement column indicate the default 
placements of the icon in specific toolbar configurations. 

Category Icon Title Icon Menu Item Description/Default Placement 

File    These are the core icons of the 
Taskmaster Window Toolbar.  

 Operations 

 

View/Operations Retrieves the Operations window 
(Chapter 4). 

Default placement: File, Operations 

 Job Monitor 

 

View/Job 
Monitor 

Retrieves the Job Monitor (Chapter 5). 

Default placement: File, Operations, 
Station Monitor  

 Station Monitor 

 

View/Station 
Monitor 

Retrieves the Station Monitor (Chapter 
5). 

Default placement: File, Operations. 
Job Monitor 

Job Monitor 
configuration 
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 Toolbar Icons (continued)  
Category Icon Title Icon Menu Item Description 

File 
(continued) 

Taskmaster 
Administrator   

Settings/Tab Opens the Taskmaster Administrator 
(Chapter 6). 

Default placement: File, Operations,  
Job Monitor, Station Monitor 

 General 
Settings 

 

Settings/General Accesses the tabs of the Taskmaster 
Settings dialog (Page 52). 

Default placement: File, Operations,  
Job Monitor, Station Monitor 

 Run Task 

 

Database/Run 
Task 

Opens the Run Task dialog (Page 68). 

Default placement: File, Operations,  
Job Monitor, Station Monitor 

 Log Viewer 

 

Tools/Log 
Viewer 

Display or hides the Taskmaster Log 
Viewer (Page 72). 

Default placement: File, Operations, 
Station Monitor 

 Log File 

 

Tools/Log File Starts or stops log entries to a Log file 
(Page 78). 

Default placement: File, Operations, 
Station Monitor 

 Send Message 

 

Tools/Send 
Message 

Accesses the Send Message dialog. 

You can use this dialog to compose, 
distribute and respond to e-mail 
communications within your Datacap 
network. For details, see Page 46. 

Default placement: File, Station 
Monitor 

 Chat 

 

Tools/Open Chat 
Window 

Opens a Datacap Chat Room (Page 49). 

Default placement: File, Station 
Monitor 

 Run Task – 
Remote 
Station  

Tools/Start Task 
(Remote) 

Accesses the Start Task on Remote 
Workstation dialog. 

An Administrator can use this dialog to 
initiate workflow processing on another 
Taskmaster Client (Page 81). 

Default placement: File, Station 
Monitor 
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 Toolbar Icons (continued)  
Category Icon Title Icon Menu Item Description 

File 
(continued) 

Session 
Information  

Help/Session 
Info 

Displays information about this 
Taskmaster Client and the application’s 
Engine and Admin databases.  

Default placement: File, Operations,  
Job Monitor, Station Monitor 

 Program 
Information  

Help/About TM 
Client 

Provides more facts about the client. 

Default placement: File, Operations,  
Job Monitor, Station Monitor 

 Help 
 

Help/Help 
Topics 

Accesses Taskmaster Help. 

Default placement: File, Operations,  
Job Monitor, Station Monitor 

Operations    Icons in Operations category appear 
only in the Operations toolbar 
configuration or next to menu items. 

 Shortcut 
Properties  

File/Properties Opens the Shortcut Properties dialog 
of a highlighted shortcut icon (Chapter 
6). 

Default placement: Operations 

 Remove 
Shortcut 
Components 

 
File/Remove Removes a highlighted shortcut icon 

from the Operations window’s Data 
Area. 

Default placement: Operations 

 Run Tasks 

 
File/Run Tasks Activates the Run Tasks dialog for a 

shortcut icon you’ve highlighted.  

Default placement: None 

 Large Icons 
 

View/Large 
Icons 

Displays larger versions of an 
application’s shortcut icons in the 
Operations window’s Data Area. 

Default placement: None 

 Small Icons 
 

View/Small 
Icons 

Displays smaller versions of an 
application’s shortcut icons in the 
Operations window’s Data Area. 

Default placement: None 
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 Toolbar Icons (continued)  
Category Icon Title Icon Menu Item Description 

Operations 
(continued)  

List: Icons 
 

View/List Displays small shortcut icons as a list 
along the left side of the Operations 
window’s Data Area. 

Default placement: None 

 Details: Icons 

 
View/Details Lists small shortcut icons and their 

descriptions along the left side of the 
Operations window’s Data Area. 

Default placement: None 

 Unload All 
Tasks  

File/Unload 
Tasks 

Closes procedures and windows 
associated with the most recent task 
activity. 

Default placement: Operations 

Monitor    The Monitor category supplies icons to 
the Job Monitor and Station Monitor 
toolbar configurations. 

Note: the Batch Selection dialog uses 
the Job Monitor toolbar configuration. 

 Refresh 

 

Record/Refresh/
Update View 

Updates the Information Table of the 
Job Monitor or Station Monitor. 

Default placement: Job Monitor, 
Station Monitor 

 Change Timeout 

 

Record/Refresh/
Change 
Timeout 

Accesses the Change Timeout dialog. 

The settings in this dialog determine 
the rate at which Taskmaster 
automatically update the tables of the 
Station Monitor or Job Monitor.  

 Default placement: Job Monitor, 
Station Monitor 

 Zoom In 

 

View/Zoom In Increases magnification of rows in the 
tables of the Station Monitor or Job 
Monitor. 

Default placement: Station Monitor 

 Zoom Out 

 

View/Zoom 
Out 

Decreases magnification of rows in the 
tables of the Station Monitor or Job 
Monitor. 

Default placement: Station Monitor 
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 Toolbar Icons (continued)  
Category Icon Title Icon Menu Item Description 

Monitor 
(continued)  

100% Zoom 

 

View/100% Restores magnification of rows in the 
tables of the Station Monitor, Job 
Monitor or Batch Selection dialog to 
the Taskmaster default. 

Default placement: Station Monitor 

Job Monitor    The Job Monitor category contains 
icons available only to the Job 
Monitor toolbar configuration.  

 Filter 

 

View/Filter Retrieves the Job Monitor Filter. 

You can use this dialog to limit the 
scope of a Batch Information Table for 
the Job Monitor  or Batch Selection 
dialog (Chapter 5). 

Default placement: Job Monitor 

 Second Monitor 

 

View/New 
Monitor 

Opens a second, independent Job 
Monitor within the Data Area of the 
Taskmaster Window.  

Default placement: Job Monitor 
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Customizing Toolbars 
Although Taskmaster allows you to modify the structure and contents of the Taskmaster 
Client’s toolbar, the scope of any changes is intentionally small. You can “hide” icons in 
a toolbar, or you can assemble special purpose toolbars from existing icons and place 
them strategically within the Taskmaster Window. 

 Taskmaster Security automatically determines the availability of the toolbar’s icons. In 
most environments, for example, operators do not have permission to access the tabs of 
the Taskmaster Administrator. As a result, when a Scan operator first signs on, the 
toolbar displays the icons in the File and Operations categories, but a number of the 
icons are grayed out, including the icon that activates the Taskmaster Administrator. 

To review or modify the composition of a toolbar–or to add a new toolbar–you’ll use the 
tabs of the Customize Toolbar dialog. To access this dialog, select Customize from the 
View menu: the Toolbars tab will appear on your screen. 

Customize Toolbar Dialog 
The Customize Toolbar dialog (illustrated on the next page) has two roles: it provides 
information about the principal toolbar configurations of this Taskmaster Client, and lets 
you modify or add to those configurations. 

The components of this dialog include: 

Component Description 

Title Bar Identifies the principal toolbar configuration…the set of icons 
that will appear when a particular window is active in the Data 
Area of the Taskmaster Window. 

In the illustration, the Title Bar indicates “Customize 
Operations” because the Operations window is active.  

Toolbars Tab Lists properties of the primary toolbar configuration associated 
with the active window and any configurations you’ve added. 

This tab also sets up additional configurations and restores the 
default settings of primary configurations. 

Categories Tab Lists the icons of the categories that makeup the toolbar 
configuration (Page 35). The Operations configuration, for 
example, includes icons in the File and Operations categories.  

The Categories tab also assigns icons to new, toolbars (Page 44). 

OK Button Confirms additions or changes to toolbar configurations and 
closes the Customize Toolbar dialog. 
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Customize Toolbar Dialog–Toolbars Tab 

 Customize Toolbar Dialog (continued)  
Component Description 

Cancel button Closes the Customize Toolbar dialog without including additions 
or changes to toolbar configurations. 

Apply button Adds new or modified toolbar specifications to the application’s 
Admin database.  

Help Button Links you to Taskmaster Help. 

 

9 The Customize Toolbar dialog has a subtle role that extends beyond the limits of its tabs. 
Opening this dialog “freezes” the icons in the Taskmaster Window toolbar. If you drag 
an icon from the toolbar into the window’s Data Area, the icon disappears. It remains 
hidden unless you press the Reset button on the Toolbars tab. Such a step affects the 
toolbar only when this window is active. 

If the scope of a client’s activity is limited and well-defined, hiding icons can produce a 
more efficient toolbar.     
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Customize Toolbar Dialog–Toolbars Tab 

In the example on the next page, the Toolbars field of the Toolbars tab identifies two 
toolbar configurations. The first is the standard Operations configuration and includes 
icons in the File and Operations categories. 

But what about the Tasks configuration?  This is a special-purpose toolbar, assembled by 
the application’s Administrator to help her operators. It is concise, easy to find and easy 
to use…and appears only when the Operations window is active. Instructions for putting 
together such a toolbar are just as easy: you’ll find them on Page 44. For now, spend a 
moment with the fields and functions of the Toolbars tab. 

Field/Function Description 

Toolbars The names of toolbar configurations associated with the active 
window in the Taskmaster Window. 

Unless you add a special-purpose toolbar, this field will have one 
entry. 

Toolbar Name The name of a toolbar configuration you’ve highlighted in the 
Toolbars field. 

If you select the principal toolbar configuration, the field is only for 
display. If you select any another configuration, the field is active. 

Show Tooltips A check box which, if activated, directs Taskmaster to display the 
title of an icon when a user’s cursor approaches. 

Cool Tool A check box which, if activated, eliminates borders between icons 
and reduces their button-like appearance. 

Large Buttons A check box which, if activated, increases the size and brilliance of 
the toolbar’s icons. 

New button Access the New Toolbar dialog. 

You can use this dialog to set up a toolbar (Page 44).   

Reset button If you remove icons from a principal toolbar, pressing this button 
returns the toolbar to its default configuration.   

Delete button If you highlight a configuration in the Toolbars field, the Reset 
button becomes the Delete button. You can remove the 
configuration with this button. 
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                                             Customize Toolbar Dialog–Toolbars Tab 
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Customize Toolbar Dialog–Categories Tab 

The Categories tab identifies the icon categories of a toolbar configuration, as well as the 
icons in each category. 

The tab can also assign specific icons in these categories to a toolbar you’re constructing. 
In the example on the next page, the Tasks toolbar is firmly in place but the 
Administrator is working on yet another (Toolbar 3).  

The table below describes the fields and functions of the Categories tab. 

Field/Function Description 

Categories The icon categories contributing icons to this toolbar configuration. 

In the example, icons of the Taskmaster Window toolbar when the 
Operations window is active come from two categories: File and 
Operations.     

This field does not list toolbars just because they are toolbars and 
not icon categories. 

Buttons The icons in a category you’ve highlighted. 

Alert! Dragging an icon from this field to the Data Area of the 
Taskmaster Window automatically sets up a toolbar. You can 
expand the toolbar by dragging other icons from this field to the 
toolbar. 

Description A brief description of an icon you select from the Buttons field or  
from a toolbar. 

To Set up a Toolbar 

To assemble a special-purpose toolbar for this Taskmaster Client, take the following 
steps. 

Step Action 

1. Sign on to Taskmaster from this client. 

2. Decide which toolbar configuration is to include the toolbar. Perhaps, for 
example, the toolbar is to appear when the Data Area of the Taskmaster 
Window is empty, or when the Operations window is active, etc. 

3.  Format the Data Area accordingly. 

4. Select Customize from the View menu: when the Customize Toolbar dialog 
appears on your screen, go to the Categories tab. 

5. Highlight the icon Category containing the initial icon you’re going to place 
in the new toolbar. 
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To Assemble a Toolbar (continued)  

Step Action 

6. Drag the icon from the category’s Buttons field into the Data Area of the 
Taskmaster Window: Taskmaster will automatically create a toolbar with this 
icon in it. 

7. Drag any additional icons from the Buttons field to the toolbar. 

8. Return to the Toolbars tab: the new toolbar will be listed as Toolbar(n) in the 
Toolbars field. 

9. Highlight this title and press the New button. When the New Toolbar dialog 
appears, enter the name of the toolbar and press the OK button. 

 

 
       Customize Toolbar Dialog–Categories Tab  

 

 
Customize Toolbar Dialog–Toolbars Tab 
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Taskmaster Window–Supporting Functions 
The following sections describe the supporting functions of the Taskmaster Window, 
including: 

Communications: e-mails and Chat Rooms within the Datacap network (below). 

General Settings: modifications to Taskmaster default settings for database 
identities and Data Source Names; the length of the processing timeout period; and 
alternative formats for the Data Area of a client’s Taskmaster Window (Page 63). 

Database Roaming: establishing connections to alternative Engine and Admin 
databases (Page 82). 

Job/Task Testing: testing tasks from the Taskmaster Window (Page 68). 

Client Logs: the definition and generation of logs and log files (Page 70). 

Processing on Remote Workstations: task processing on “remote” clients (Page 
81). 

9 Very important! These functions are “administrative privileges.” The User Definitions 
and User Group Definitions of individuals responsible for these procedures must include 
the applicable privileges. For details, see Chapter 6. 

Communications 
You can use the Open Chat Window and Send Message items of the Tools menu (or 
their corresponding icons) to set up communications with members of your Datacap 
network. 

Network E-mail 
To compose and send a message to one or more connected clients, select Send Message 
from the Tools menu (or click on the Send Message icon) to access the Send Message 
dialog. 

 

 
Send Message Dialog 
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The Send Message dialog has these fields and settings: 

Field/Setting Description 

Message Text The wording of a message from you to other members of the 
Datacap  network. 

To: The recipients of the message. 

      Private A radio button indicating that you will be sending the 
message only to Users and Stations you highlight in the list 
below.  

      Broadcast A radio button indicating that the message is to go to all to 
Users and Stations in the list. 

Stations/Users A list of workstations currently connected to Taskmaster 
Server Service, and the users who signed on.  

• This list is for display only if you have selected the 
Broadcast option above. 

• If you choose Private, you must highlight one or 
more recipients in the list. 

Send button Sends the message to your audience. 

When the message arrives, Taskmaster will display it 
prominently on the user’s screen. 

Cancel button Cancels the message and closes the Message dialog. 
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To compose and send a message, take these steps: 

Step Action 

1. Click on the Send Message icon or select Send Message from the Tools 
menu of the Taskmaster Window: the Send Message dialog will appear on 
your screen. 

 

2. Enter the wording of the e-mail in the Message Text field. 

3. To distribute the message to all connected users, click on the Broadcast radio 
button and press the Send button. To limit distribution to one or more users, 
first activate the Private radio button. Then highlight the applicable 
connections. 

4. Press the Send button. 

9  The message will appear automatically as soon as a targeted user signs on to his or her 
Taskmaster client.  

 

 
Message Alert! 
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Chat Rooms 
The Chat dialog is a give-and-take bulletin board for messages between members of the 
network. To access this dialog, select Chat from the Tools menu or press the Chat 
Room icon on the toolbar.  
 

 
Chat Dialog–Message Mode 

The Chat dialog has these fields and settings: 

Field/Setting Description 

Inbound Messages and comments from other participants in the Chat 
Room. 

Outbound The wording of a message or comment you plan to distribute. 

To: The identity and scope of your audience. 

Private A radio button indicating that you will be sending your 
message only to selected users and stations.  

Broadcast A radio button indicating that the message is to go to all 
members of the network who are involved in the Chat Room. 

Stations/Users A list of workstations currently connected to Taskmaster 
Server Service (Chapter 2), and the users who signed on.  

• This list is for display only if you have selected the 
Broadcast option above. 

• If you choose Private, you must highlight one or 
more names in the list. 
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 Chat Room Dialog (continued)  
Field/Setting Description 

Reply to Last Sends your response directly to the issuer of the most recent 
message to appear in the Inbound field. 

Send button Adds your message to the Inbound field of one or more Chat 
Room participants. 

Close button Closes the Chat dialog. 

 

 
Chat Dialog–Inbound/Outbound Mode 

 Only authorized users can send and receive Chat Room messages (Chapter 6). 

To set up and participate in a Taskmaster Chat Room, take these steps: 

Step Action 

1. Send a message (Page 46) to participants, announcing the Chat Room, and 
reminding everybody to keep their Chat dialogs open until the chat is over.      

2. Select Open Chat Window from the Tools menu or click on the Chat icon. 

3. When the Chat dialog appears on your screen, enter a message in the 
Outbound field. 

4. Select a Private list of Chat Room’s participants from the signed-on users 
and stations, or Broadcast your thoughts to everybody. 

5. Press the Send button.  
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To Conduct a Chat Room (continued)  

Step Action 

6. Keep the conversation open as long as comments are pertinent and 
appropriate. 

7. To end your participation, press the Close button. 
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General Taskmaster Settings 
The General item at the bottom of the Settings menu (or its corresponding toolbar icon) 
has four sub-items–each leading to a tab of the Taskmaster Settings dialog:  

• The Databases tab specifies Connection Strings to the application’s Admin and 
Engine databases 

• The Advanced tab controls a number of miscellaneous settings, including the 
time that Taskmaster is to wait between batches.  

• The Background tab gives you a chance to brighten the look of the Taskmaster 
Window’s Data Area with a color or image of your choice. 

• The settings of the Log tab determine the content and location of log tracking 
application events. 

Taskmaster Settings Dialog: Databases Tab 
The Databases tab of the Taskmaster Settings dialog is a helpful source of information 
about two essential “Data Sources” – the Admin and Engine databases. 

9 By default, these are Access databases (.mdb). As a result, the syntax of the Data Source 
values in the Data Source(s) fields is similar to the value below. For the 1040EZ 
application’s Admin database, it is the name and path of the Access database:  

C:\Datacap\1040EZ\process\1040Admin.mdb 
 

 
Taskmaster Settings dialog – Databases tab 

If you highlight a database listing and click on the Properties button, the Connection 
Property dialog will appear (illustrated on the next page.) 
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Connection Property dialog 

The Connection Property dialog will list the Connection String that will link the 
application’s Taskmaster shortcut icons to this database. Here, for example, is the 
complete Connection String for the 1040EZ Taskmaster Client shortcut icon (with 
special formatting and bold type for emphasis): 

C:\Datacap\tmclient\tmclient.exe  
-ad"PROVIDER=MSACCESS;DSN=C:\Datacap\1040EZ\process\1040Adm.mdb; 
CATALOG=;DBNTA=;"  
-ed"PROVIDER=MSACCESS;DSN=C:\Datacap\1040EZ\process\1040Eng.mdb; 
CATALOG=;DBNTA=;" 

For a complete explanation of Connection Strings, see Appendix A of the Taskmaster 
Administrator’s Guide.) 

 9 Taskmaster releases before Taskmaster 6.2 use ODBC Data Source Names instead of 
Connections Strings. 

When the Taskmaster Application Wizard generates a new application, the wizard 
automatically assigns a value to the Connection Property for each database, similar to the 
value in the illustration above. (For more about this wizard, see the Taskmaster 
Application Wizard Guide.) 

Occasionally, an application relies on multiple databases – duplicate Admin or Engine 
databases. Under these circumstances, you’ll use this tab to add the DSN Connection 
String portions and determine their precise roles (Page 59). 

The table on the following page describes the fields and functions of this tab. 
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 Taskmaster Settings Dialog–Databases Tab 
Field Description 

Admin Database Area This area identifies and locates the application’s Admin 
database, and any duplicate Admin databases available to 
the application for database roaming. 

The buttons in this area display the details of a particular 
Data Source and help you add Data Source details for a 
duplicate database.  

     Data Source(s) The name and path of the application’s Admin database file 
(.mdb).  

These values are elements of the Connection String.   

      Add button Accesses the Select Administrator Database dialog (Page 
56). 

You can use this dialog to add Connection String and 
Security parameters for a duplicate Admin database. 

      Remove button Removes a Data Source value from the Data Sources field. 

      Properties button Opens the Connection Property dialog. 

This dialog displays the Connection String property of the 
Data Source you’ve highlighted. For the 1040EZ Admin 
database – and Access database - for example, the value is: 

PROVIDER=MSACCESS;DSN=C:\Datacap\1040EZ\
process\1040Adm.mdb;CATALOG=;DBNTA=; 

Engine Database Area This area identifies and locates the application’s principal 
Engine database, and any other Engine databases the 
application can turn to. 

The fields and button in this area are the same as those of the 
Admin Database area (above) except that they deal with the 
application’s Engine database rather than its Admin 
database. 
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 Databases Tab (continued)  
Field Description 

Enable Roaming A check box, which, if activated, allows the application 
to switch from one Admin (or Engine) database to 
another. 

This check box is available only if there are multiple 
Data Sources in the Admin Data Source field or the 
Engine Data Source field. 

Very important! To manually designate an alternative 
database before Taskmaster runs, you can highlight the 
duplicate database and select the Admin Roam (or 
Engine Roam) item of the Database menu (Page 25).  

Auto Admin/Auto Engine A check box which, if activated, directs Taskmaster to 
switch automatically to an alternative Admin (or 
Engine) database. 

This is an unusual feature with limited scope: be sure to 
study its ramifications carefully before selecting it. 

 
 
 

 
Taskmaster Settings Dialog–Databases Tab 

Database Roaming Enabled
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 Databases Tab (continued)  
Field Description 

Auto Engine A check box which, if activated, directs Taskmaster to 
switch automatically to an alternative Engine database if 
the current database does not include batches awaiting 
processing. 

This advanced feature can distribute work for added 
reliability. 

ODBC Manager button Links you to the ODBC Data Source Administrator. 

This button is available only if Taskmaster is operating 
in a serverless mode. (For a full explanation of the role 
of the ODBC Data Source Administrator, see Chapter 
2.) 

OK Button Confirms new or modified settings in the Databases tab 
and closes the Taskmaster Settings dialog. 

Cancel button Closes the Taskmaster Settings dialog. 
 

Adding Data Source Information 

A Taskmaster application can access a database only if its Data Source parameters appear 
in the applicable Data Source field in the Databases tab, and in the Connection 
Properties dialog. 

9 Very important! You cannot add a Data Source for a second database unless: 

• Your User Definition allows you to work with additional databases and their 
Data Source specifications (Chapter 6). 

• The second Admin or Engine database includes a unique index value. Index 
values are in the adminfo table of the Admin database and the enginfo table of 
the Engine database. 

• You take the steps outlined on Page 59 to insert the Connection String portion of 
the second database’s Data Source into the Connection String of your 
application’s Taskmaster Client shortcut icon, with the correct syntax. 
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To add Data Source parameters for a second database, take these steps: 

Step Action 

1. Press the Add button in the Engine Database or Admin Database Source area. 

 

      Click here 

2. When the Select Administrator Database dialog appears (in this example), 
select the applicable Database Type from the drop-down list. 

 

Click on this 
button. 

3. Use the Ellipsis button (…) to locate and select the database file –  the 
1040admR database in the example below. 

 

      1040admR 
         database 

4. Press the OK button when you return to the Select Administrator Database 
dialog. 
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To Add Data Source Parameters for a Second Database (continued)  

Step Action 

5. Confirm that the new Data Source is listed in the Data Source(s) field. 

 

6. Select the Enable Roaming option to test the Manual Roaming feature. 

7. Close and re-open the Taskmaster Settings dialog. 

8. Select Admin Roam (or Engine Roam) from the Taskmaster Window’s 
Database menu (Page 25).  

9. Highlight the new Data Source and press the Properties button. 

 

10. Copy the Connection String value in the Connection Property dialog. 
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To Add Data Source Parameters for a Second Database (continued)  

Step Action 

11. Right-click on the application’s Taskmaster Client shortcut icon. 

 

12. Select Properties from the icon’s options to access the 1040EZ Client 
Properties dialog (in this example.) 

13. Insert the new database’s Data Source value into the dailog’s Target field. 

 

14. Close the dialog. 

9 Be sure to insert the Connection String portion of the database’s Data Source after the 
Connection String for the first Admin database (in this case) but before the Connection 
String for the Engine database. 

Below is what the icon’s Connection String looks like after you add a Data Source for a 
second Admin database, and insert the Connection String value in the Connection 
Properties dialog – with bold type and special formatting for emphasis. Pay particular 
attention to comma (,) that precedes the PROVIDER ACCESS; parameter 

C:\Datacap\tmclient\tmclient.exe  
-ad"PROVIDER=MSACCESS;DSN=C:\Datacap\1040EZ\process\1040Adm.mdb;  
CATALOG=;DBNTA=;,PROVIDER=MSACCESS; 
DSN=C:\Datacap\1040ez\process\1040admR.mdb;"  
-ed"PROVIDER=MSACCESS;DSN=C:\Datacap\1040EZ\process\1040Eng.mdb;  
CATALOG=;DBNTA=;" 

    New Data 
          Source 

9 Your application will not retain Data Sources for additional databases unless you expand 
the client’s shortcut icon Connection String. 
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Taskmaster Settings Dialog: Advanced Tab 
The Advanced tab of the Taskmaster Settings dialog contains important housekeeping 
details: 

• The top section identifies the application with which the client is working.  

• Items in the middle section define certain aspects of the client’s behavior as the 
workflow progresses. 

• The lower section governs a Taskmaster Client’s behind-the-scenes operations, 
as well as elements of its interface with operators, Supervisors and 
Administrators. 

 
Taskmaster Settings Dialog–Advanced Tab 

The table below describes the fields and functions of the Advanced tab. 

Field/Function Description 

Application Title The name of the Taskmaster application that is to appear in the 
Taskmaster Window’s Title Bar. 

Prompt between Batches A check box which, if activated, directs Taskmaster to display 
an end-of-task dialog when a task finishes with a batch. 

These messages ask if the operator is finished with the batch 
(OK or Hold) and if the operator wants to continue running the 
same task (Yes or No). 

Message Timeout The length of the period (in seconds) that Taskmaster is to wait 
for a response, before taking the default action. 

Sleep Timeout The length of the period (in seconds) Taskmaster will wait 
before looking for a new batch to process. 
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 Taskmaster Settings Dialog–Advanced Tab (continued)  
Field/Function Description 

Write into Debug Table A check box which, if activated, directs Taskmaster to save 
“audit” information to the Debug table of the Engine 
database…details of when a batch is processed, for example, or 
a batch status changed in Job Monitor from the current station.  

Continue on Abort If not checked, directs Taskmaster to stop further processing if 
the current batch aborts. 

If checked, directs Taskmaster to select and process the next 
batch.  

Sequential Job Creation A check box which, if activated, directs Taskmaster to create 
batches automatically for unattended “batch creation” tasks. 

This feature is only used with special tasks such as 
Taskmaster’s VScan task. Be sure to consult your Datacap 
Support Specialist before selecting this option. 

Enable Icon on the 
Taskbar when Hidden 

A check box which, if activated, automatically places a 
Taskmaster Client icon in a workstation’s Windows taskbar. 

This unusual response occurs if Taskmaster was opened by 
another program rather than from an icon on the user’s desktop, 
or selections from the Start button’s options (Page 5).     

Animation A check box which, if activated, animates the display in the 
About Taskmaster Client and Session Information dialogs. 

Sounds A check box which, if activated, permits the use of sound to 
mark various Taskmaster events. 

Pressing the > button accesses the Windows Sounds dialog. 
You can use this dialog to provide the client with audio 
responses. 

Task Instances Options in this drop-down list determine how and when 
Taskmaster can “unload” software objects for the tasks it runs.  

You must select one option. 

      Unload if new task 
      module 

Allows Taskmaster to unload task objects when it starts to 
process a task with a Task Module that’s different from the last 
task.  

In the case of the 1040EZ application, for example, each task – 
VScan, PageID, Recognize and Export – employs a different 
module. As a result, Taskmaster can unload the current task’s 
objects as soon as it takes up another task.  

This decreases chances for memory leaks if the processing 
computer’s memory is not large enough to handle objects for all 
tasks.   
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 Taskmaster Settings Dialog–Advanced Tab (continued)  
Field/Function Description 

      Leave running Ensures that Taskmaster will retain components of all tasks 
without interruption.  

This can be very efficient if the application is handling just a 
few tasks, and memory is sufficient for the objects of all tasks. 

      Unload periodically Uses a continuum to indicate how often Taskmaster should 
unload objects of each task.  

The designation of “every batch” results in maximum safety but 
minimum speed, and is recommended if memory leaks are 
possible. 

 

 
Advanced Settings – Task Instances 
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Taskmaster Settings Dialog: Background Tab 
Selections in the Background tab can provide welcome relief from the bleak grayness of 
Taskmaster’s windows and dialogs.  

The tab’s settings focus only on the color and texture of the Taskmaster Window’s Data 
Area. However, because so much takes place in and around this dominant field, a 
background with more warmth or excitement can be satisfying indeed. 

In the extreme example below, an operator placed a Gray Marble square in the center of 
a Data Area with a yellow background. (If the operator had selected the Tile option 
instead, the Gray Marble texture would cover the entire area.) 
 

 
Taskmaster Settings Dialog – Background Tab 
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The fields and functions of the Background tab include: 

Field/Function Description 

Predefined Backgrounds Five alternative textures you can overlay on the Data 
Area.  

When you select a texture, it appears first in the Preview 
field. None is Taskmaster’s default specification.  

Background Image A check box which, if selected, activates the 
accompanying field.  

You can use this field and the Ellipsis button (…) to 
specify the name and pathway of a Bitmap file (.bmp) 
containing an image which is to appear in the 
Taskmaster Window’s Data Area. In response to your 
selection of a Display mode (below), Taskmaster will 
paint the image across the Data Area, or set it in the 
middle.  

If you select this option, the Predefined Backgrounds 
field is no longer available. 

Display Radio buttons indicating if an image or texture you select 
will be spread across the Data Area (Tile) or occupy a 
central but more limited position (Centre).  

This setting governs the placement of an image or a 
texture. 

Background Color The color of the Data Area itself. 

Clicking on the Ellipsis button accesses the Colors 
palette. You can use this dialog to review standard colors 
or to create your own. 

OK button Applies your specifications to the Taskmaster Window’s 
Data Area.  

Alert! If you’re unhappy with the new look, click on the 
General option in the Settings menu, then go right to the 
Background tab to make further changes. 

Cancel button Returns you to the Taskmaster Window without 
modifying the Data Area. 
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Taskmaster Settings Dialog: Log Tab 
Settings in the Log tab of the Taskmaster Settings dialog govern the way a Taskmaster 
Client tracks, displays and stores details of its activities as part of a specific Taskmaster 
application–and as a component of a Datacap network. 

Logs come in two forms:  

• Log Viewer displays an up-to-the-minute, ever-changing list of events, errors and 
problems. 

• Log files (.log) store log information. Specifications in the Log tab determine the 
content of logs covering a client’s activity; specifications in a Task Definition’s 
Task Settings dialog govern the content of a log covering a task’s activity as it 
processes a batch (Chapter 6.)  

Datacap Taskmaster Installation includes default settings for the Log tab of the 
Taskmaster Settings dialog. If you modify these settings, the change affects only the 
Taskmaster Client with which you are working. 

For more about the nature, format and content of Taskmaster Client logs, see Page 70. 
 

 
Taskmaster Settings Dialog–Log Tab 

The table at the top of the next page describes the fields and functions of this tab. Page 70 
shows you how to take full advantage of a Taskmaster log.  
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 Task Settings Dialog–Log Tab 
Field/Function Description 

Use Common Log A check box which, if activated, directs the client to use 
“shared” Taskmaster logging procedures.  

9 Two important points: 
• Use of the common log prevents you from accessing 

this file while the application is open and the client is 
active. As an alternative, you can use the application 
log options (below) to set up a file just for this 
application. 

• Taskmaster can update a Log file only if you have 
selected the Log to File item in the Tools menu, or the 
Enable Log File option in the Log tab. 

Severity A pointer you use to indicate the nature of events and activities 
the log is to include. 

Placing the pointer at the None end of its range means the log 
will only record sign-in, sign-off and networking events. 
Moving the pointer towards All adds to the log’s scope. 

Show Date A check box which, if activated, directs Taskmaster to include 
the date of a logged event or activity. 

Show Time  A check box which, if activated, includes the time of a logged 
event or activity. 

Show Severity A check box which, if activated, includes the severity of each 
event or activity. 

Enable Log File A check box which, if activated, directs Taskmaster to store log 
details in an application Log file as well as in a common Log 
file (if you have selected the Use Common Log option.) 

Maintaining an application Log file allows you to open the file 
while the client is active.  

File Name The name and location of the application Log file. 

Overwrite Old File A check box which, if activated, directs this Taskmaster Client 
to overwrite existing log data with new data each time the client 
signs on. 

This is an important option: if you do not select it, a Log file 
can grow quickly to an unmanageable size. 

Flush Buffer after Each 
Message 

A check box which, if activated, directs Taskmaster to save the 
contents of the Log file each time a new line is added.  
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Signing on as a Different User 
After you have signed on to an application as an Administrator, you can use the Login 
item in the Database menu to sign on as another user as long as:  

• You enter a legitimate User ID and Password (Chapter 6) 

• Taskmaster Security has authorized the station from which you are working.  

When you select Login, the standard User ID & Password dialog appears. As you can 
see, the User ID and Password field require entries; Station ID, on the other hand, is a 
display field.  Be careful: the User ID and Password fields are case-sensitive. 

 
User ID & Password  

In the example above, if the Administrator signs on as scan1, a new Taskmaster Window 
appears with an updated version of the Operations window: instead of a full range of 
shortcut icons, the Operations window now contains just the Scan task icon. To return to 
the Administrator’s Operations window, take the same steps, using your Administrative 
security codes. 

 

 
Taskmaster Window–Operations  

Note: This can be a very helpful tool when you are setting up and testing security 
parameters and codes (Chapter 6).  
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Testing Job/Task Operations: the Run Task Dialog 
All standard configurations of the Taskmaster Window’s toolbar include the Run Task 
icon. Pressing this icon (or selecting Run Task from the Databases menu) retrieves the 
Run Task dialog.   
 

 
 

 
Run Task Dialog 

The Run Task dialog is a tool you can use to test Job/Task Combinations…the jobs 
which make up a workflow, and the tasks assigned to those jobs.  

• Highlighting a pair in the Selected Tasks field and pressing the Run button 
initiates that Job/Task Combination. 

• Your designation of a Batch Selection Mode determines the way in which a task 
will retrieve batches from its queue during testing. 

 Taskmaster Security limits access to this icon to an application’s Administrator, and to 
other personnel whom you authorize. For more information, see the Taskmaster 
Administrator’s Guide. 

9 You’ll use the Workflow tab of the Taskmaster Administrator to define Workflow 
Hierarchies consisting of workflows, jobs and tasks. Chapter 6 provides an introduction 
to this tab, and a review of all tabs of the Taskmaster Administrator. Chapter 6 of the 
Guide to Taskmaster Rules shows you how to assemble, install and test a Workflow 
Hierarchy.  
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The table below describes the fields and functions of the Run Task dialog. 

Field/Function Description 

Selected Tasks A list of the Job/Task Combinations you intend to test. 

Each row identifies one of the application’s jobs, and a 
task assigned to that job.  

To include a pair in the Selected Tasks list, highlight it 
in the Available Tasks list and press the Select button. 

Available Tasks A complete list of the application’s Job/Task 
Combinations. 

< Select button Adds a Job/Task Combination you’ve highlighted in the 
Available Tasks list to the list of Selected Tasks. 

Once you take this step, the task is eligible for 
processing from the Run Task dialog. 

Remove > button  Removes a Job/Task Combination from the Selected 
Tasks list. 

Remove All >> button  Removes all Job/Task Combinations from the Selected 
Tasks list. 

Run button Initiates processing of a task you highlight in the 
Selected Tasks list.  

Cancel button Closes the Run Task dialog. 

Batch Selection Mode These options determine how Taskmaster is to select a 
batch when you test the highlighted task. 

      Auto Taskmaster will automatically run the next batch in the 
task’s queue. 

      Manual The Batch Selection dialog (Chapter 4) will appear as 
soon as you click on the Run button; Taskmaster will 
not proceed until you select a batch. 

      Manual for Hold Only The Batch Selection dialog will display only those 
batches in the queue with a “Hold” status. 

This allows an operator to review problem batches 
before taking action.  
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To test a Job/Task Combination using the Run icon, or the Run Tasks item in the 
Databases menu, take these steps: 

Step Action 

1. In the Taskmaster Window, press the Run icon, or select the Run Tasks item 
in the Databases menu: the Run Task dialog will appear on your screen. 

2. From the list of Available Tasks, highlight one or more Job/Task 
Combinations. 

3. Press the < Select button to move the listing to the Selected Tasks field. 

4. Choose a Batch Selection Mode. 

5. Highlight a Job/Task Combination in the Selected Tasks field. 

6. Press the Run button. 

7. If you have specified Manual as the Batch Selection Mode, choose a batch 
from the Batch Selection dialog and double-click on the listing to begin 
processing. 

 

Client Logs and Log Viewer 
A client log tracks a Taskmaster Client’s activity. 

According to specifications you supply, a log can contain minimal information about the 
client–messages noting sign-on and sign-off, for example–or a detailed record of events, 
conditions, problems and solutions. 

Log information comes in two forms. Client data deals exclusively with the client’s 
performance, while common data covers the client’s interaction with the other 
components of your Taskmaster configuration. 

9 Alert! You can set up a third type of log – a task log such as scan.log. Task logs contain 
details of a task’s activity as it processes a particular batch and usually ends up in the 
batch itself. For more about these logs, see Chapter 6 of the Guide to Taskmaster Rules.  

The client logs are available in two formats: 

Display. The Log Viewer window (pictured on the next page) displays and 
continuously updates client or common log information.  

Log file. Taskmaster can store log information in a client Log file covering the 
client’s activity; in a common Log file covering the client’s involvement with all 
system components; or in Log files of both types.  
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Log Viewer 

The content of a log can vary substantially–again, according to specifications you supply. 
The simplest of logs notes when the client becomes active and when it closes down. At 
the other extreme are logs tracking every aspect of a client’s workflow activities and its 
network participation. 

Client log settings are in three locations.   

Taskmaster Window: Settings menu. If you select General - at the bottom of the 
window’s Settings menu -  then Log Options from the sub-menu, the Log tab of the 
Task Settings dialog will appear on your screen (Page 65). You can use this tab to 
designate the name and location of a client Log file, and to indicate the scope of its 
content. For instructions, see Page 78.  

 

Select this 
item. 

Taskmaster Window: Tools menu. The log section of the Tools menu (Page 27) has 
two On/Off switches. Clicking on Log Viewer (or its corresponding toolbar icon) 
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opens or closes the Log Viewer. Clicking on Log to File (or its corresponding toolbar 
icon) directs Taskmaster to add information to the client Log file you identified in the 
Log Options tab of the Taskmaster Settings dialog. Clicking again limits the file’s 
contents to a record of events up until the client closed. 

Log Viewer: Options menu. Settings accessible from the Log Viewer establish a 
common Log file and determine its contents. For details, see Page 79.  

Log Viewer–Menus 
The Log Viewer window displays current, up-to-the-minute log information. To activate 
this window, select Log Viewer from the Tools menu or click on the Log Viewer icon. 

Information in the Data Area dominates this window. Nevertheless, the Log Viewer’s 
menus contribute measurably to its effectiveness. The following table describes the items 
in these menus. 

 Menus of the Log Viewer 
Item Keyboard Description 

File  These items transfer Log Viewer data to a client Log file, 
and close this window.    

      Save as Alt + S Opens the Save Log as dialog. 

As a default, Taskmaster lists the file you designated in 
the Log Options tab of the Taskmaster Settings dialog 
(Page 65).  

      Save Selection n/a Opens the Save Log as dialog. 

This item allows you to add specific lines in the Log 
Viewer’s Data Area to a client Log file you specify. 

      Exit Alt + X Closes the Log Viewer. 

Edit  These items locate and process specific listings. 

      Copy Ctrl + C Copies selected lines in the Log Viewer’s Data Area. 

      Select All Ctrl + A Selects all data currently displayed in the Log Viewer. 

      Undo Selection n/a Releases highlighted listings. 

      Clear Log n/a Deletes all current listings in the Log Viewer’s Data 
Area. 

      Find Ctrl + F Retrieves the Find Text dialog and gives you the ability 
to search the Log Viewer’s listings.   

View  Checking an item in this menu adds a particular 
specification to each listing in the Log Viewer’s Data 
Area.   
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 Log Viewer Menus – (continued)  
Item Keyboard Description 

      Show Date n/a Includes the dates of the events, errors and conditions 
listed in the Log Viewer’s Data Area. 

      Show Time n/a Includes the time of each event, error or condition listed 
in the Log Viewer’s Data Area. 

      App ID n/a Displays the identifying codes of the Taskmaster 
applications generating listings in the Log Viewer. 

Severity n/a Displays a code ranking the “severity” of each event, 
error or condition listed in the Log Viewer. 

These codes range from “0” (No Ranking) to “9” (Most 
Severe). They measure the importance and impact of a 
listing rather than the nature of any related problems. 

      Message ID n/a Displays the identifying code Taskmaster assigns to each 
Log Viewer listing.  

      Autoscroll n/a Automatically displays the Log Viewer’s most recent 
listings in its Data Area. 

Alert!  This is a convenient tool if you are interested in 
late-breaking developments, but an annoyance if you’re 
trying to concentrate on a specific listing. Be sure to turn 
off Autoscroll when you conducting a search or 
reviewing results. 

      Status Bar n/a Displays or hides a Status Bar. 

Options  Items in this menu determine just how you’re going to 
use the Log Viewer–and distribute its data. 

      Common Log  
      File 

n/a Accesses the Common Log File dialog. 

You can use this dialog to set up a temporary channel 
connecting the Log Viewer to a common Log file. Then, 
if you activate the Write to Log File option (below), 
Taskmaster will extract data from the Log Viewer and 
place it in the Log file. 

Alert! When the Log Viewer closes, the channel closes.  
When the Log Viewer re-opens, the channel remains 
closed. 

For more about common Log files, see Page 79.  

      Write to Log  
      File 

n/a Directs Taskmaster to copy data from the Log Viewer to 
a Log file you designated using this menu’s Common 
Log File procedures (above.) 
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 Log Viewer Menus – (continued)  
Item Keyboard Description 

      Log Content     
      options  

 The options below determine the Log Viewer’s content. 
You must select one. 

      Full Log n/a Displays a complete set of log data, generated to comply 
with your selections from the View menu (above). 

      Filter Log n/a Displays log data that’s been filtered according to 
parameters you provide using the Filter Options item 
(below). 

      Processes n/a Limits the log data to a list of executable files (.exe) that 
are the sources of the Log Viewer’s information. 

      Filter Options n/a Accesses the Log Filter dialog. 

You’ll use this dialog to enter parameters for a filtered 
log. This option is available only if you have selected 
Filter Log above. 

Help n/a Displays About Log Viewer information. 
 

 

 
Log Viewer, showing 

Time, Message Type, Severity, Message 
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Log Viewer Filters 
The Log Viewer’s filtering mechanism accepts two parameters: 

• You can specify the severity of events and conditions to be reported. 

• You can include (and exclude!) messages generated by certain types of activities, 
and designated according to their Application IDs.  

As a preliminary step, takes these steps to get a list showing all messages, with their 
Severity Codes and Application IDs prominently displayed: 

Step Action 

1. From the Options menu of the Taskmaster Window, select Log Viewer; the 
Log Viewer window will appear on your screen. 

2. In the View menu, turn off Autoscroll. 

3. Select Full Log from the Options menu. 

4. From the View menu, select App ID and Severity. 

5. As you scroll through the messages, decide which Application IDs and  
Severity Codes are to serve as the filter’s criteria. 

To filter the messages in the Log Viewer’s Data Area, select Filtered Log from the 
Options menu. This will activate the Filter Options item at the bottom of the menu. 
Select this item to access the Log Filter dialog: 
 

 
Log Filter Dialog 
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The Log Filter dialog has these fields: 

Field/Function Description 

Severity Range Severity Codes defining a From…To range. 

The Log Viewer automatically covers all events, conditions 
and errors within the scope you defined in the Log Options 
tab of the Taskmaster Settings dialog (Page 65).  To limit 
this coverage, enter an integer between “0” and “9” in both 
fields. 

Application IDs A list of the Application IDs representing Taskmaster  
applications. 

   …to be shown Directs the Log Viewer to include only those messages 
generated by applications you designate in this field.  

To specify multiple applications, separate each code with a 
comma. 

   …to be skipped. Directs the Log Viewer to exclude certain applications.  

OK button Confirms the filtering criteria you’ve entered, closes this 
dialog, and updates the Log Viewer with filtered 
information. 

Cancel button Closes this dialog and returns you to the Log Viewer. 
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Log Viewer Displays 
To generate and display Log Viewer information, take these steps: 

Step Action 

1. From the Options menu of the Taskmaster Window, select Log Viewer; the 
Log Viewer window will appear on your screen. 

2. Select Full Log from the Log Viewer’s Options menu. 

3. Choose specific items from the View menu to determine the Log Viewer’s 
content. 

4. To filter a listing, select Filtered Log from the Options menu: click on Filter 
Options to access the Log Filter dialog. 

 

5. Enter your filtering criteria and press the OK button. 

 

 
Filtered Log 
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Client Log Files 
You can use the facilities of the Taskmaster Window to create and maintain two types of 
Log files: 

• A client Log file records messages associated with the activity of the Taskmaster 
Client. 

• The more comprehensive, common Log file adds messages about the client’s 
relationships with other components of a Datacap configuration. 

Procedures for setting up a common Log file are on Page 79. To define a client Log file: 

Step Action 

1. Open the Taskmaster Window. 

2. Select General from the Settings menu, then Log Options: the Log tab of the 
Taskmaster Settings dialog will appear on your screen. 

 

3. Do not select Use Common Log. 

4. Indicate the Severity of the events and conditions the log is to track. 

5. Indicate if messages are to include Dates, Times and Severity codes. 

6. Check the Enable Log File option: enter the File Name and location. 

7. If Taskmaster is to overwrite previously log data whenever you sign on, select 
Overwrite Old File. 

8. If Taskmaster is to clear memory after each message, activate Flush Buffer.  

9. Press the OK button. 
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Common Log Files 
Defining and generating a common Log file is a process that takes place in two phases. 
The first phase authorizes the use of a common Log file; the second phase supplies 
additional criteria for the log’s contents and its generation. 

A Word of Caution. Defining and generating a common Log file is a temporary venture. 
The file’s definition unravels, and the file closes, as soon as you turn off the Log Viewer. 

Phase 1: Authorizing a Common Log 

Take steps to authorize the creation of a common Log file.   

Step Action 

1. Open the Taskmaster Window. 

2. Select General from the Settings menu, then Log Options: the Log tab of the 
Taskmaster Settings dialog will appear on your screen. 

 

Select this 
option. 

3. Select the Use Common Log option. 

4. Indicate the Severity of the events and conditions the common log is to track. 

5. Indicate if the file’s listings are to note Date, Time and Severity. 

6. Select the Enable Log File but do not enter a File Name (you’ll add the File 
in Phase 2.) 

7. Turn on the Log to File option in the Tools menu of the Taskmaster 
Window. 
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Phase 2: Common Log Specifications 

To begin this phase, select Log Viewer from the Tools menu. When the Log Viewer 
appears, select Common Log File from the Options menu to access the Common Log 
File dialog.  

You’ll use the settings in this dialog to provide the file with the additional specifications 
described in the table below. 
 

 
Common Log File Dialog 

Setting Description 

File Name The name and location of the common Log file. 

This is a required entry. 

Write incoming messages to 
the file 

A check box which, if activated, adds information about 
events and activities to the Log file.   

Use Filter Directs Taskmaster to employ the filtering criteria in the 
Log Filter dialog when generating the file. 

To access the Log Filter dialog, press the Edit Filter button. 
The settings in this dialog are identical to those described 
on Page 75. 

Rollover by Size A check box which, if activated, directs Taskmaster to 
close the file after it reaches a size indicated in the 
accompanying field. Taskmaster will rename the file, and 
open a new file with the original name.  

Truncate Existing File A check box which, if activated, directs Taskmaster to 
erase the contents of the existing log before starting a new 
log. 

FileOpen Header Line A check box which, if activated, directs Taskmaster to add 
a “header” line to the beginning of the log. 

FileClose Header Line A check box which, if activated, directs Taskmaster to add 
a “footer” line to the end of the log. 

Page 3–80 Confidential and Proprietary Information of Datacap Inc. 
 Copyright © 2006 Datacap Inc. 



Chapter 3: Taskmaster Window 

Processing on Remote Workstations 
If multiple Taskmaster Clients are active on the Datacap network, you can run a task on 
a client other than your own if you have previously provided the client and workstation 
with proper authorization (Chapter 6). 

To run a task on another client, select Start Task from Remote Station from the Tools 
menu. From the list in the Station ID/User field of the dialog, select the remote 
Taskmaster Client (in the example, there is only one additional client). Then place the 
applicable Job/Task Combinations in the Selected Tasks field. Press the Run button to 
initiate the task(s). 
 

 
Start Task on Remote Station Dialog 

To terminate processing, select Stop Running from Remote Station. When the Stop 
Running dialog appears, select the client and press the Stop button. 
 

 
Stop Running Task on Remote Station 

Follow the same procedures to Shut Down a Remote Station. 
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Database Roaming 
An application that employs database roaming can move between multiple Engine 
databases and Admin databases as it creates, selects and processes batches. This can be a 
highly efficient procedure if the workflow’s Scan task runs more than one scanner, and 
each scanner places batches in a different location. 

In the example below, the Administrator has set up a subsidiary Engine database and 
provided it with a Data Source (Page 56): 1040engR contains backup batch processing 
details. (This feature typically roams between Engine databases.) 
   

 

Second Admin 
database 

Taskmaster Settings Dialog – Databases Tab 

The Enable Roaming option becomes available only if there is more than one listing in 
the Admin Database(s) or the Engine Database(s) field of the Databases tab.  

9 Defining, testing and implementing database roaming requires a good deal of planning. 
Before you begin… 

• Review descriptions Database Roaming parameters and requirements on Page 52. 

• Consult your Datacap Implementation Specialist.. 
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