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About this document

This document provides installation and upgrade information about IBM FileNet Rendition Engine 
(RE). 

Topics in this document apply specifically to FileNet P8 Rendition Engine installation tasks. 
Information about preparing the FileNet P8 Platform environment before you start these 
installation tasks is in the Plan and Prepare Your Environment for IBM FileNet P8 document. 

To download these documents from the IBM FileNet support Web site, see “Access IBM FileNet 
documentation, compatibility matrices, and fix packs” on page 16.

Intended audience
This document is intended for software professionals who install IBM FileNet P8 Platform 
components. IBM recommends that an IBM FileNet Certified Professional (FCP) perform the 
installation. For more information about the FCP program, contact your IBM service 
representative.
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Typographical conventions
This document uses the following typographical conventions:

Convention Usage Example

Bold Platform-specific headings Start the application server.

WebSphere

Refer to IBM WebSphere documentation for 
more information.

WebLogic

Refer to BEA WebLogic documentation for 
more information.

Gray bold Clickable items, such buttons, 
and tabs.

Click OK.

Menu paths or breadcrumb 
trails.

Select Start > Settings > Control Panels > 
Display > Screen Saver. 

Italics Variables that require user-
supplied values

The calculation is: number of object stores * 
16 + number of concurrent users.

Document titles You are reading the IBM FileNet P8 Platform 
Installation and Upgrade Guide.

Monospace Text that has to be typed by 
the user 

Copy the file by entering the following 
command:

COPY filename

Code samples Find the following text in the web.xml file:

<context-param><param-name>uploadDir</
param-name><param-value>/opt/FileNet/AE/
Upload1</param-value> </context-param>

Display text, such as prompts 
and error messages

Are you sure you want to delete this 
object?
You do not have permission to delete this 
object.

Elements such as filenames, 
properties, classes and so on, 
whose meaning might get 
confused in regular text. 

Open the filed file.

Enter a value for the new property.

Select the senior class.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Acronyms
This document uses the following IBM FileNet product names and acronyms. 

Product Name Acronyms

Application Engine AE

Content Engine CE

Content Search Engine CSE

Enterprise Manager EM

Global Configuration Data GCD

Image Services Resource Adapter ISRA

Process Engine PE

Rendition Engine RE

“Text with 
quotation 
marks”

User-interface fields that do 
not use initial capitalization 
and document headings 
referenced within a document

See the “Part number” field for the part 
number.

For more information, see “Typographical 
conventions” on page 10. 

UPPERCASE Case-sensitive text, where 
uppercase text is required.

Copy the file by entering the following 
command:

COPY filename

Convention Usage Example
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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About IBM FileNet documentation
By default, this document is distributed as part of the IBM FileNet P8 help system, but it is also 
available as a downloadable document from the IBM support Web site. Newer versions of IBM 
FileNet P8 documentation are sometimes re-released with other events, such as fix pack releases 
or documentation refreshes. To ensure that you have the latest revision of a document, compare 
the document part number of your document to the document part number of the document that is 
posted on the support Web site: 

www.ibm.com/support/docview.wss?rs=3278&uid=swg27010422

For example, the last two digits of “GC31-5585-05” indicate that the specified document has been 
revised five times after the original publishing, which is designated by 00.

Copy Web documents into the help system and make them searchable 
The IBM FileNet P8 help system is designed so that you can download updated copies of this 
document and copies of other IBM FileNet documents into the IBM FileNet P8 help system and 
index them so that they can be retrieved by a search in the help system. However, to search the 
IBM FileNet P8 help system, it must be installed as a Web site on a Web server that supports 
Java™ applications. 

For more information, see the following topics in the IBM FileNet P8 Platform Installation and 
Upgrade Guide:

• “IBM FileNet Web site documents.” 

• “Install IBM FileNet P8 Platform documentation.”

• “Update Documentation Search Index.”

Links to additional information
To help you locate additional information about a topic, this document includes links to:

• Other locations in this document

• External Web sites 

• Topics in the FileNet P8 help system

Because this document is included in the default FileNet P8 help system, the links to the FileNet 
P8 help topics work only when you view this document from within the help system. If you view 
this document from outside of the help system, the links to FileNet P8 help topics do not work.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE

http://www.ibm.com/support/docview.wss?rs=3278&uid=swg27010422


 About IBM FileNet documentation
Gather reference documentation

13
Gather reference documentation
Following are two tables with information about the IBM FileNet P8 documents that are available 
as part of the FileNet P8 release. To download these documents from the IBM FileNet support 
Web site, see “Access IBM FileNet documentation, compatibility matrices, and fix packs” on page 16. 

Installation reference documents
Consider having one or more of the following documents (or help topics) nearby for reference 
purposes during the installation of IBM FileNet P8 Platform. 

Document or help topic name... Refer to this document...

IBM FileNet P8 Platform Installation and 
Upgrade Guide

For information about how to install IBM FileNet P8 
Platform in your environment. 

Plan and Prepare Your Environment for 
IBM FileNet P8

To confirm the target environment is ready for a 
FileNet P8 installation or upgrade. 

IBM FileNet Workplace XT Installation 
and Upgrade Guide

For information about how to install and upgrade 
Workplace XT in a FileNet P8 environment.

IBM FileNet P8 Hardware and Software 
Requirements

To confirm that the target environment has at least 
the minimum supported levels of software from 
independent software providers.

IBM FileNet P8 Compatibility Matrix To confirm that the version of FileNet P8 to be 
installed is compatible with at least the minimum 
supported levels of other FileNet products that are 
or will be used with FileNet P8.

IBM FileNet P8 Release Notes To familiarize yourself with the new features and 
known issues associated with the FileNet P8 
release.

IBM FileNet P8 Non-English Support 
Guide

For information about how FileNet P8 supports non-
English environments.

IBM FileNet P8 High Availability 
Technical Notice

For information about how to set up FileNet P8 
using clusters, farms and other high-availability 
software and hardware.

IBM FileNet P8 Performance Tuning 
Guide

For critical tuning information required to make 
deployments of all sizes and levels of complexity 
work efficiently before going into production. 

Attention This guide provides many specific 
recommendations for making performance-related 
choices that are either difficult or impossible to 
change once the system goes into production.

IBM FileNet P8 Troubleshooting Guide For troubleshooting tips associated with a FileNet 
P8 Installation. 
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE
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Other available documentation
Review the list of remaining FileNet P8 documents that you can download from the FileNet 
support Web site.   

IBM FileNet P8 help topic: 
Administration > Enterprise-wide 
Administration > FileNet P8 Security > 
Users and Groups

For a complete list of the user and group roles, 
accounts, and responsibilities required to install, 
configure, and maintain a FileNet P8 system.

IBM FileNet P8 help topic: 
Administration > Enterprise-wide 
Administration > Shutdown and Startup

For information about how to shut down and start 
up FileNet P8 and any expansion products. 

Document name Refer to this document...

IBM FileNet P8 System Overview For a technical summary of the FileNet P8 
architecture, including a overview of features and 
capabilities.

IBM FileNet P8 Disaster Recovery 
Technical Notice

For information about potential options and solutions 
involved in a FileNet P8 disaster recovery plan.   

IBM FileNet P8 Process Task Manager 
Advanced Usage Technical Notice

For information about properties found under the 
Advanced tab in Process Task Manager.

IBM FileNet P8 Version Tools 
Technical Notice

For information about the set of versions tools that are 
installed with FileNet P8 Platform and that identify the 
levels of Application Engine, Content Engine, and 
Process Engine in a FileNet P8 environment.

IBM FileNet P8 Security Help Extract For security-related information from the FileNet P8 
help system in PDF format. 

IBM FileNet Rendition Engine 
Installation and Upgrade Guide

For information about how to install and upgrade 
Rendition Engine in a FileNet P8 environment. 

IBM FileNet P8 eForms Installation 
and Upgrade Guide

For information about how to install and upgrade 
eForms in a FileNet P8 environment.

IBM FileNet Connector for SharePoint 
Web Parts Installation and Upgrade 
Guide

For information about how to install and upgrade IBM 
FileNet Connectors for SharePoint Web Parts in a 
FileNet P8 environment.

IBM FileNet Connector for SharePoint 
Document Libraries Installation and 
Upgrade Guide

For information about how to install and upgrade IBM 
FileNet Connectors for SharePoint Document 
Libraries in a FileNet P8 environment.

Document or help topic name... Refer to this document...
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IBM FileNet P8 Portlets for 
WebSphere Installation and Upgrade 
Guide

For information about how to install and upgrade 
FileNet P8 Portlets for WebSphere in a FileNet P8 
environment.

IBM FileNet Process Analyzer 
Installation and Upgrade Guide

For information about how to install and upgrade 
Process Analyzer in a FileNet P8 environment.

IBM FileNet Process Simulator 
Installation and Upgrade Guide

For information about how to install and upgrade 
Process Simulator in a FileNet P8 environment.

IBM FileNet Records Manager 
Installation and Upgrade Guide

For information about how to install and upgrade 
Records Manager in a FileNet P8 environment.

IBM FileNet Business Activity Monitor 
Installation and Configuration Guide

For information about how to install and configure 
Business Activity Monitor in a FileNet P8 environment.

IBM FileNet Content Federation 
Services Installation and Upgrade 
Guide

For information about how to install and upgrade 
Content Federation Services in a FileNet P8 
environment.

IBM FileNet Content Federation 
Services for Image Services Planning 
and Configuration Guide

For information about how to configure Image 
Services for document federation. 

IBM FileNet Content Federation 
Services for Content Manager 
OnDemand Planning and 
Configuration Guide

For information about how to configure Content 
Manager for OnDemand for document federation. 

IBM FileNet Content Management 
Widgets Installation Guide

For information about how to install Content 
Management Widgets in a FileNet P8 environment.

Document name Refer to this document...
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Autonomy K2 software documentation for configuring the FileNet P8 Content 
Search Engine
Autonomy (formerly Verity) K2 software, which underlies the optional CSE component, installs 
with a large body of documentation that is not included in the general FileNet P8 documentation. 
For details on how to access this documentation, see the "Configure Content Engine for Content-
Based Retrieval" topic in the IBM FileNet P8 Platform Installation and Upgrade Guide.

Access IBM FileNet documentation, compatibility matrices, and fix 
packs
To access documentation, compatibility matrices, and fix packs for IBM FileNet products: 

1. Navigate to the Product Documentation for FileNet P8 Platform support page.

(www.ibm.com/support/docview.wss?rs=3247&uid=swg27010422).

2. Select a PDF file or click a Document Link icon, whichever is appropriate.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE

http://www.ibm.com/support/docview.wss?rs=3247&uid=swg27010422


 Customer support
Feedback

17
Customer support
For information about contacting customer support: 

1. Navigate to the FileNet Product Family support page: 

(http://www.ibm.com/software/data/content-management/filenet-product-family/support.html). 

2. Click IBM FileNet Support Communications, or search for a particular support topic under 
“Enter search terms”. 

Feedback
Your feedback helps us to provide quality information. Send your comments about this publication 
or any other IBM FileNet documentation by e-mail to comments@us.ibm.com. Be sure to include 
the name of the product, the version number of the product, and the name and part number of the 
book (if applicable). If you are commenting on specific text, include the location of the text (for 
example, a chapter and section title, a table number, a page number, or a help topic title).
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Plan and prepare for installation

The topics in this section explain the process for planning for and performing the required 
prerequisite tasks for a FileNet Rendition Engine installation. Review all of the topics in the 
following sections carefully before you begin.

Rendition Engine is a software server responsible for transforming documents into another format, 
such as PDF or HTML. The Rendition Engine software is based on the Liquent product. To install 
and configure the Liquent components on the Rendition Engine server and Content Engine server 
follow the instructions in this document. 

For more information about Liquent, see the FileNet P8 Help topic FileNet P8 Administration > 
Enterprise-wide Administration > Publishing > Publishing Overview > About Rendition Engine.

NOTE  For DITA Open Toolkit rendition engine installation and configuration information, see the 
FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide Administration > Publishing.

Plan the installation
This section lists details that will help you prepare your environment for the installation of 
Rendition Engine. In many cases, the items you see listed are links to more detailed information. 
Please review this information thoroughly before you start to set up a Rendition Engine or 
required third-party software.

Before you begin to install IBM FileNet Rendition Engine, perform the following planning activities:

• Retrieve updates to IBM FileNet P8 documentation and software, see “Access IBM FileNet 
documentation, compatibility matrices, and fix packs” on page 16.

• Read “Install and configure Rendition Engine” on page 53 to become familiar with the tasks you 
will perform when you set up your IBM FileNet Rendition Engine software.

• See “Use the installation worksheet” on page 21 for more information on an available Worksheet 
to record information that will be needed during installation.

NOTE  Follow the planning, installation, and configuration tasks in the order presented in these 
topics. If you do otherwise, or you install FileNet P8 components on machines containing 
components for existing FileNet P8 systems, you might encounter unforeseen problems or be 
required to perform additional installation steps. See the IBM FileNet P8 Platform Troubleshooting 
Guide. To download this document from the IBM support page, see “Access IBM FileNet 
documentation, compatibility matrices, and fix packs” on page 16.
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Plan your deployment 

Cluster deployment
Cluster deployments can be used for load balancing or to provide high availability. Refer to the 
IBM FileNet P8 Platform High Availability Technical Notice for details on how to set up your IBM 
FileNet RE system using clusters, farms, and other high availability software and hardware.
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Definition of roles 
The tasks in this guide as well as the rows in the “Installation and upgrade worksheet” referenced 
in “Use the installation worksheet” on page 21 are organized by administrative roles, listed below.

Your organization may have different roles, and some of the responsibilities of listed roles will vary 
from those assigned by default in this documentation.

Installation administrator (IA)
• Responsible for coordinating the information described in this worksheet. The information 

itself will require the input from the other roles. See “Use the installation worksheet” on page 21.

• Runs IBM FileNet installation programs during initial installation.

• Runs the Domain Manager tool during initial installation.

• Launches Enterprise Manager during initial installation.

• Runs IBM FileNet Upgrade programs during upgrades.

The role of IA is usually filled by an IBM FileNet Certified Professional (FCP).

For tasks assigned to the IA, see“Installation Administrator tasks” on page 23.

IT administrator (ITA)
• Responsible for the networking and operating systems issues required by IBM FileNet P8.

• Responsible for those security configurations not assigned to the SA.

• Responsible for providing the information in the rows in the Installation and Upgrade 
Worksheet with a value of ITA in the Role column.

For tasks assigned to the ITA, see “IT Administrator tasks” on page 24.

Security administrator (SA)
• Responsible for configuring the directory servers required by IBM FileNet P8, including 

Content Engine, Application Engine, CFS Federation Administration application.

• Creates and maintains directory server user and group accounts

• Decides on configuration parameters required to connect

• Responsible for providing the information in the rows in the Installation and Upgrade 
Worksheet with a value of SA in the Role column.

For tasks assigned to the Security Administrator, see “Security Administrator tasks” on page 41.

Database administrator (DBA)
• Creates, configures, maintains database installations and database/tablespaces.
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• Responsible for creating database accounts needed by FileNet P8.

• Might have responsibilities regarding the JDBC datasources

• Responsible for providing the information in the rows in the Installation and Upgrade 
Worksheet with a value of DBA in the Role column.

For tasks assigned to the Database Administrator, see “Database Administrator tasks” on page 44.

Use the installation worksheet
This planning and preparation guide includes a link to an associated Installation and Upgrade 
Worksheet, which is a spreadsheet file. You can enter information into the worksheet while you 
perform the preparation tasks for your FileNet P8 Platform environment. Information you collect in 
the worksheet will be used to complete various FileNet P8 installation, upgrade, and configuration 
tasks.

For more information, see “Installation and upgrade worksheet” on page 87.

Here are some things to know about the worksheet:

• The rows in the worksheet correspond to field names, properties, and parameters that must be 
entered in the course of installing or upgrading FileNet P8 Platform components.

• Each row of the worksheet is designated for a particular administrator role. Review the rows in 
the worksheet before you begin your preparation tasks.

• The Installation and Upgrade Worksheet is designed to be customized. You can sort the 
worksheet by different columns to get a specific view of the information that each 
administrator is expected to provide. Note that only some of the rows assigned to each 
administrator will apply for a particular installation. For example, some rows are specific to 
platform type, application server vendor type, database type, and so forth. Each row is also 
specific to a FileNet P8 component or add-on product. Work with your installation 
administrator or IBM services representative to determine the rows that are relevant for your 
installation. If these individuals provide you with variations of this table, use such variations 
instead to collect your data.
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Perform Required Preparation Tasks
ATTENTION  In addition to the preparation tasks listed below, follow the plan and prepare 
instructions in the Plan and Prepare your Environment for IBM FileNet P8 guide for the component 
you are installing. 

To prepare your environment for a Rendition Engine installation

Perform the required preparation tasks:

• “Installation Administrator tasks” on page 23

• “IT Administrator tasks” on page 24

• “Security Administrator tasks” on page 41

• “Database Administrator tasks” on page 44
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Installation Administrator tasks
The items below are the required tasks for the Application Installer Administrator.

Complete the installation worksheet for your environment
If you are using the Installation and Upgrade Worksheet for your environment, fill out the 
worksheet with the relevant information as described in “Installation and upgrade worksheet” on 
page 87.

Verify the contents of the installation package
The following is a brief description of the contents of the RE installation package:

• Installer (folder) - Contains the setup.exe file used to install RE.

• Resources (folder) - Contains the Oracle-repository.sql script and the 
IBMFileNetRenditionEngineLicense.xml file used during the installation.

• Readme.htm - Contains information about the RE documentation.

Plan for non-English environment installation
By default Rendition Engine supports English and Japanese Windows operating systems. 

Authoring in other languages
In order to publish documents that are authored in other languages, you must add support for the 
language on the Rendition Engine server using the "Regional and Language Options" control 
panel application. This adds language fonts and support to allow Rendition Engine to correctly 
render PDF and HTML documents.

See Microsoft Windows operating system help for further information on adding additional 
language support.
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IT Administrator tasks
The items below are the required tasks for the Information Technology (IT) administrator.

Rendition Engine server

Ensure minimum required disk space and temp space for installation 
See the IBM FileNet P8 4.5 Hardware and Software Requirements.

Microsoft Office locale
Before installing Microsoft Office, if you set the Regional Option to non-US/English for your 
operating system, bookmark extraction will not work properly when rendering a document. Any 
non-US/English Regional Option settings should be made after Microsoft Office has been 
installed.

Operating system considerations

(Windows 2003 64-bit only) Install Microsoft .NET Framework version 2.0 for 64-bit 
operating systems
If you are installing Rendition Engine on a 64-bit Windows machine you must install .NET 
Framework version 2.0 for 64-bit operating systems before installing Rendition Engine. See your 
Windows documentation for more information. 

Network considerations
• Ensure TCP/IP settings. Verify TCP/IP configuration settings on the RE server.

• Ensure communication. Make sure the RE server can communicate with the database server 
and the Content Engine (CE) server, and that the CE server can communicate with the RE 
server.

• Ensure availability of required port numbers. Several port numbers are required by the various 
FileNet P8 components. For a list, see “FileNet P8 port numbers” on page 89. 

Collocation considerations
• For performance reasons, unless you plan to install more than one Rendition Engine in your 

environment, FileNet recommends that you install Rendition Engine and Content Engine on 
separate servers. This will spread the performance load between the publishing servers.

Hard drive considerations
• You must install Rendition Engine on a server that has an NTFS drive partition.

If you don’t install RE on an NTFS partition you won’t be able to complete the task “Set security 
on the VistaTempDir shared folder.” on page 59. 

Liquent Vista Domain considerations
• When you first run the Rendition Engine installation program, you create a new Liquent Vista 

domain—an administrative entity that’s used to manage Rendition Engine services. For each 
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subsequent execution of the Rendition Engine installation program on a machine, you can join 
an existing Liquent Vista domain or create another Liquent Vista domain.

(Windows 2003 Server) Uninstall Internet Explorer Enhanced Security 
Configuration. 
On Windows 2003 Server you must uninstall the Internet Explorer Enhanced Security 
Configuration to be able to use the Jobs tab in Domain Manager to monitor jobs. 

1. Navigate to Start > Settings > Control Panel.

2. Double-click Add/Remove Programs.

3. Select Internet Explorer Enhanced Security Configuration and click Change/Remove.

4. Follow the screen prompts to remove the software. At the final screen, click Finish.

5. Close the Add/Remove Programs Window.

(Windows 2003 SP1) Set the Data Execution Prevention performance option to 
essential Windows programs and services only.
Before installing Rendition Engine on a server running Windows 2003 SP1, you must log on to the 
server with the default administrator account and set the Data Execution Prevention performance 
option to essential Windows programs and services only. 

1. Right-click My Computer and choose Properties. 

2. Select the Advanced tab.

3. Under Performance, click Settings. 

4. Select the Data Execution Prevention tab.

5. Click Turn on essential Windows programs and services only.

Configure the server's operating system to optimize programs.
1. On the Desktop, right-click My Computer and choose Properties. 

2. Select the Advanced tab

3. Under Performance, click Settings. 

4. Select the Advanced tab.

5. Choose Programs for both best performance settings.
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Install and configure authoring applications
IT Administrator Tasks

Before you install the Rendition Engine (RE) software you should install all supported authoring 
applications that will be used to create and render publication documents. Install and configure 
these applications on each RE server you plan to use. With the applications installed, the RE 
installation wizard can copy RE specific Word and WordPerfect macros to the appropriate 
locations.  

CAUTION  Use the FNRE_Admin account created in “Users required for Rendition Engine installation” 
on page 42 when installing the authoring applications.

To render documents accurately, RE requires each authoring application to run cleanly, without 
problems, and without dialogs or prompts. Therefore, after you install each authoring application, 
start the application to confirm that it runs properly without dialogs opening, including the 
registration dialogs. In addition, a number of these applications require configuration before the 
software can use them for IBM FileNet publishing.

These applications require configuration: 

• Microsoft® Word

• Microsoft Excel

• Microsoft Power Point 

• Microsoft Visio

• Microsoft Project

• WordPerfect

CAUTION  Before installing Microsoft Office, if you set the Regional Option to non-US/English for 
your operating system, bookmark extraction will not work properly when rendering a document. 
Any non-US/English Regional Option settings should be made after Microsoft Office has been 
installed.

NOTE  For a complete list of supported applications, see IBM FileNet P8 Hardware and Software 
Requirements.

Perform these steps on each Rendition Engine server. See the steps below for any of the 
applications that apply to your environment.

To enable TIF to PDF conversion

By default, TIF and TIFF files are configured to use different rendering plugins. The MS Doc 
Imaging plugin (for Microsoft Office Document Imaging) is specified for TIF, while the Imaging 
plugin (included with Rendition Engine) is specified for TIFF.

If you plan to publish TIF images to PDF you must perform either of the following:

• Install the Microsoft Office Document Imaging office tool. This is not installed by default for 
Office 2007. 

• Change the TIF content type plugin specified in the Domain Manager to use the one specified 
by for TIFF.
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To configure Microsoft Word 2007

1. Before you install Rendition Engine, ensure the following folders contain no files:

\MS_Office_home\Microsoft Office\Office Version\Startup

\MS_Office_home\Microsoft Office\Office Version\XLStart

\Documents and Settings\local adminstrator\Application Data\Microsoft\Word\Startup

2. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. Access the Web Options configuration.

MS Word 2003

i. In Microsoft Word, choose Tools > Options. 

ii. On the General tab click Web Options. 

MS Word 2007

iii. In Microsoft Word, click the Microsoft Office Button.

iv. Click Word Options. 

v. Click Advanced.

vi. Scroll down to General, and click Web Options.

b. Select the Files tab.

c. Check the Use long file names whenever possible item.

Perform this wherever the MS Office applications reside — on the Rendition Engine server 
and on each client machine from which source documents are added and rendering is 
initiated. By default, MS Office 2003 and MS Office XP have it set.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

d. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

3. Configure Microsoft Word publishing requirements.

a. In Microsoft Word, click the Microsoft Office Button, and then click Word Options.

b. Click Popular.

c. Under Top options for working with Word, set ScreenTip style to Don’t show ScreenTips.
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d. Select the Display tab and clear the following options:

• Printing options

– Print background colors and images

– Print hidden text

– Update fields before printing

– Update linked data before printing

e. Select the Proofing tab and clear the following options:

• When correcting spelling and grammar in Word

– Check spelling as you type

– Use contextual spelling

– Mark grammar as you type

– Check grammar with spelling

f. Select the Save tab and clear the following options:

• Save documents

– Set Save files in this format to Word 97-2003 Document (*.doc)

– Uncheck Save AutoRecover info every:

g. Select the Advanced tab and clear the following options:

• Editing options

– Typing replaces selected text

– When selecting, automatically select entire word

– Allow text to be dragged and dropped

– Use CTRL + Click to follow hyperlink

– Automatically create drawing canvas when inserting AutoShapes

– Use smart paragraph selection

– Use smart cursoring

– Keep track of formatting

• Cut, copy and paste options

– Show Paste Options buttons

– Use smart cut and paste

• Show document content

– Show background colors and images in Print Layout view
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– Show text animation

– Show Smart tags

– Show field codes instead of their values

• Display

– Show all windows in the taskbar

• Print

– Print in background

– Print XML tags

– Print field codes instead of their values

– Scale content for A4 or 8.5 x 11" paper sizes

• Save

– Allow background saves

• Preserve fidelity when sharing this document

– Embed Smart Tags

• General

– Provide feedback with animation

– Confirm file format conversion on open

– Update automatic links at open

h. Select the Trust Center tab.

i. Under Microsoft Office Word Trust Center, click Trust Center Settings.

ii. Click Privacy Options, and then uncheck Sign up for the Customer Experience 
Improvement Program.

To configure Microsoft Excel 2007

1. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. Access the Web Options configuration.

MS Excel 2003

i. In Microsoft Excel, choose Tools > Options. 

ii. On the General tab click Web Options. 

MS Excel 2007

i. In Microsoft Excel, click the Microsoft Office Button.
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ii. Click Excel Options. 

iii. Click Advanced.

iv. Scroll down to General, and click Web Options.

b. Select the Files tab.

c. Check the Use long file names whenever possible item.

Perform this wherever the MS Office applications reside — on the Rendition Engine server 
and on each client machine from which source documents are added and rendering is 
initiated. By default, MS Office 2003 and MS Office XP have it set.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

d. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

2. Configure Microsoft Excel publishing requirements.

a. In Microsoft Excel, click the Microsoft Office Button, and then click Excel Options.

b. Select the Formula tab and clear the following options:

• Error Checking

– Enable background error checking

c. Select the Save tab and perform the following:

• Save workbooks

– Set Save files in this format to Excel 97-2003 Workbook (*.xls)

– Uncheck Save AutoRecover info every:

d. Select the Advanced tab and clear the following options:

• Cut, copy and paste options

– Show Paste Options buttons

– Show Insert Options buttons

• Display

– Show all windows in the Taskbar

– Show function ScreenTips

• General

– Provide feedback with animation
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– Ask to update automatic links

– Scale content for A4 or 8.5 x 11" paper sizes

e. Select the Trust Center tab.

i. Under Microsoft Office Excel Trust Center, click Trust Center Settings.

ii. Click Privacy Options, and then uncheck Sign up for the Customer Experience 
Improvement Program.

To configure Microsoft PowerPoint 2007

1. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. Access the Web Options configuration.

MS PowerPoint 2003

i. In Microsoft PowerPoint, choose Tools > Options. 

ii. On the General tab click Web Options. 

MS PowerPoint 2007

iii. In Microsoft powerPoint, click the Microsoft Office Button.

iv. Click PowerPoint Options. 

v. Click Advanced.

vi. Scroll down to General, and click Web Options.

b. Select the Files tab.

c. Check the Use long file names whenever possible item.

Perform this wherever the MS Office applications reside — on the Rendition Engine server 
and on each client machine from which source documents are added and rendering is 
initiated. By default, MS Office 2003 and MS Office XP have it set.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

d. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

2. Configure Microsoft PowerPoint publishing requirements.

a. In Microsoft PowerPoint, click the Microsoft Office Button, and then click PowerPoint 
Options.
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b. Select the Proofing tab and clear the following options:

• When correcting spelling and grammar in PowerPoint

– Check spelling as you type

– Use contextual spelling

c. Select the Save tab and perform the following:

• Save presentations

– Set Save files in this format to PowerPoint Presentation 97-2003

– Uncheck Save AutoRecover info every:

d. Select the Advanced tab and clear the following options:

• Editing options

– When selecting, automatically select entire word

– Allow text to be dragged and dropped

• Cut, copy and paste options

– Use smart cut and paste

– Show Paste Options buttons

• Display

– Show all windows in the Taskbar

• Slide Show

– Show menu on right mouse click

– Show popup toolbar

– Prompt to keep ink annotations when exiting

– End with black slide

• Print

– Print in background

• General

– Provide feedback with sound

e. Select the Trust Center tab.

i. Under Microsoft Office PowerPoint Trust Center, click Trust Center Settings.

ii. Click Privacy Options, and then uncheck Sign up for the Customer Experience 
Improvement Program.
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To configure Microsoft Word 2003 or earlier

1. Before you install Rendition Engine, ensure the following folders contain no files:

MS_Office_home\Microsoft Office\Office Version\Startup

MS_Office_home\Microsoft Office\Office Version\XLStart

2. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. In Microsoft Word, choose Tools > Options. 

b. On the General tab click Web Options. 

c. Select the Files tab.

d. Check the Use long file names whenever possible item.

Perform this wherever the MS Office applications reside — on the Rendition Engine server 
and on each client machine from which source documents are added and rendering is 
initiated. By default, MS Office 2000 has this Web Options check box cleared, while MS 
Office 2003 and MS Office XP have it set.

Be aware that under MS Office 2000, if you open an MS Word document that has this Web 
Options check box cleared, that setting will be used during the publishing operation even if 
the Web Options check box in your client Office 2000 application is set by default. This 
override does not occur with MS Office 2003 or MS Office XP.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

e. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

3. Configure Microsoft Word publishing requirements.

a. In Microsoft Word, choose Tools > Options

b.  Select the View tab and clear the following options:

• Show

– Startup Task Pane 

– Status Bar 

– Screen Tips 

– Smart Tags 

– Animated Text 
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– Windows in Taskbar 

– Field Codes 

• Formatting Marks

– Hidden Text 

– All 

• Print and Web Layout Options

– Background Colors and Images (2003)

c. Select the General tab and clear the following:

• Provide feedback with animation 

• Confirm conversion at Open 

• Update automatic links at Open 

• Mail as attachment 

• Automatically create drawing canvas when inserting AutoShapes 

• Allow starting in reading layout (2003)

d. Select the Edit tab and clear the following:

• Editing options

– Typing replaces selection 

– Drag-and-drop text editing 

– Use smart cursoring (2003)

– Use smart paragraph selection 

– Use CTRL + Click to follow hyperlink 

– When selecting, automatically select entire word 

– Keep track of formatting 

– Show paste Options buttons 

• Cut and paste options

– Smart cut and paste 

e. Select the Print tab and clear the following:

• Printing Options

– Update fields 

– Allow A4/Letter paper resizing 

– Background printing 
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• Include With Document

– Field Codes 

– Hidden Text 

– XML Tags (2003)

– Background Colors and Images (2003)

f. Select the Save tab and clear the following:

• Allow fast saves 

• Allow background saves 

• Save AutoRecover info every: 

• Embed smart tags 

g. Select the Spelling & Grammar tab and clear the following:

• Spelling

– Check spelling as you type

– Always suggest corrections

• Grammar

– Check grammar as you type

– Check grammar with spelling

h. Select the Track Changes tab and perform the following:

• Set Use Balloons (Print and Web Layout) to Never. (2003)

• Clear Use Balloons in Print and Web Layout. (XP)

To configure Microsoft Excel 2003 or earlier

1. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. In Microsoft Excel, choose Tools > Options. 

b. In the General tab click Web Options. 

c. Select the Files tab.

d. Check the Use long file names whenever possible item.

Perform this wherever the MS Office applications reside — on the Rendition Engine server 
and on each client machine from which source documents are added and rendering is 
initiated. By default, MS Office 2000 has this Web Options check box cleared, while MS 
Office 2003 and MS Office XP have it set.
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Be aware that under MS Office 2000, if you open an MS Word document that has this Web 
Options check box cleared, that setting will be used during the publishing operation even if 
the Web Options check box in your client Office 2000 application is set by default. This 
override does not occur under MS Office 2003 or MS Office XP.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

e. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

2. Configure Microsoft Excel publishing requirements.

a. In Microsoft Excel, choose Tools > Options.

b. Select the View tab and clear the following options:

• Startup Task Pane 

• Status Bar 

• Windows in Taskbar 

c. Select the General tab and clear the following:

•  Function tooltips 

d. Select the Edit tab and clear the following:

• Show Paste Options buttons 

• Show Insert Options buttons 

• Ask to update automatic links 

• Provide feedback with Animation 

e. Select the International tab and clear the following:

• Allow A4/Letter paper resizing 

f. Select the Save tab and clear the following:

• Save AutoRecover info every: 

g. Select the Error Checking tab and clear the following:

• Enable background error checking 

• List Data Validation (2003)
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To configure Microsoft PowerPoint 2003 or earlier

1. Configure Microsoft Office hyperlinks.

Perform these changes to ensure that hyperlinks are treated correctly on publishing.

a. In Microsoft PowerPoint, choose Tools > Options. 

b. In the General tab click Web Options. 

c. Select the Files tab.

d. Check the Use long file names whenever possible item.

Perform this wherever the MS Office applications reside — on the Rendition Engine server 
and on each client machine from which source documents are added and rendering is 
initiated. By default, MS Office 2000 has this Web Options check box cleared, while MS 
Office 2003 and MS Office XP have it set.

Be aware that under MS Office 2000, if you open an MS Word document that has this Web 
Options check box cleared, that setting will be used during the publishing operation even if 
the Web Options check box in your client Office 2000 application is set by default. This 
override does not occur under MS Office 2003 or MS Office XP.

This setting is used to ensure that the Liquent-based Rendition Engine properly converts 
MS Word and MS Excel documents containing hyperlinks, external links, image links, etc.

e. Clear the Update links on save item.

This ensures that hyperlinks are not updated but kept relative. If this is not done, a 
document with an HTML link would point to the location where the source document was 
copied during publishing.

NOTE This change will take effect on all installed Microsoft Office applications.

2. Configure Microsoft PowerPoint publishing requirements.

a. In Microsoft PowerPoint, choose Tools > Options.

b. Select the View tab and clear the following options:

• Startup Task Pane 

• Slide Layout task pane when inserting new slides 

• Status Bar 

• Windows in Taskbar 

• Prompt to keep ink annotations when exiting (2003) 

• Popup menu on right mouse click (2000)

• Show menu on right mouse click (2003)

• Show popup menu button (2000)

• Show popup toolbar (2003)
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• End with blank slide 

c. Select the General tab and clear the following:

• Provide feedback with sound to screen elements 

d. Select the Edit tab and clear the following:

• Show Paste Options buttons 

• Use smart cut and paste 

• When selecting, automatically select entire word 

• Drag-and-drop text editing 

e. Select the Print tab and clear the following:

• Background printing 

f. Select the Save tab and clear the following:

• Allow fast saves 

• Save AutoRecover info every: 

g. Select the Spelling and Style tab and clear the following:

• Check spelling as you type 

• Always suggest corrections 

To configure Microsoft Project 

1. In Microsoft Project, choose Tools > Options.

2. Select the View tab and clear the following options:

• Project Screentips

3. Select the General tab and clear the following:

• Show startup Task Pane 

• Advice from Planning Wizard 

• Automatically add new resources and tasks 

4. Select the Edit tab and clear the following:

• Ask to update automatic links 

5. Select the Scheduling Options tab and clear the following:

• Show scheduling messages 

6. Select the Spelling Options tab and clear the following:

• Always suggest 
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7. For 2003, select Help > Customer Feedback Options and perform the following:

a. Select No, I don't wish to participate.

b. Click OK.

To configure Microsoft Visio 

1. In Microsoft Visio, choose Tools > Options.

2. Select the Save tab and clear the following options:

• Prompt for document properties 

• Save preview with file 

• Show XML file save warnings (XP) 

• Show file save warnings (2003) 

• Show XML file open warnings (XP) 

• Show file open warnings (2003) 

3. Select the Spelling tab and clear the following: 

• Check spelling as you type 

• Ignore words with number should be checked 

4. For 2003, select Help > Customer Feedback Options and perform the following:

a. Select No, I don't wish to participate.

b. Click OK.

To configure WordPerfect

For information on these options, see your WordPerfect documentation.

1. In Corel WordPerfect, choose Tools > Settings.

2. Click Environment. 

3. In the Environment Settings screen select the Prompts tab and clear the following:

• Confirm deletion of table formulas

• [Beep] On hyphenation

4. Select the Interface tab and perform the following:

• Clear Quick Tips

• Check [Save workspace (documents and windows layout)] Never

5. Click OK.

6. Click Files. 
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7. In the Files Settings screen, select the Document tab and clear the following:

• Timed document backup every 

• Use enhanced file dialogs 

8. Click OK and Close to close the Settings dialog box.

9. Clear the following:

• Tools > Proofread > Prompt-As-You-Go

10. Select the following:

• Tools > Proofread > Off

11. Choose Tools > Workplace Manager... and clear the following:

• Show at Startup 

To disable the Corel Office DAD components

For WordPerfect Office, you must disable the Corel Office DAD system tray icons and remove 
CorelCentral from the Startup folder.

1. In the Windows System tray, right-click any of the DAD icons.

2. Clear Display DAD on Startup.

3. Select Exit DAD.
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Security Administrator tasks
The items below are the required tasks for the Security Administrator.

Security authentication considerations
Check required user account privileges. For installing, configuring, and running Rendition Engine, 
you must use specific user and group accounts with particular access privileges. See “Users 
required for Rendition Engine installation” on page 42.
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Users required for Rendition Engine installation
Security Administrator Tasks

NOTE Under Windows® Active Directory authentication, FileNet P8 supports only security groups, 
not distribution groups. Supported groups can have a scope of domain local (as long as they are 
in the same domain as Content Engine), global, or universal.

The following table lists the user accounts needed for installing Rendition Engine, including the 
minimum permissions required.

Role/Account Description

FNRE_Admin A local or domain user account that must be 
added directly to the local Administrators group 
on all Rendition Engine servers.

NOTE  Use this account both when installing 
Rendition Engine and when installing and 
configuring the authoring applications used to 
render documents.

Permissions: Local administrator privileges on the 
machine where Rendition Engine is installed.

GCD_admin GCD administrator user. A FileNet P8 Platform 
user that is part of the GCD administrators. 

You will need this user when you configure the 
Rendition Engine Connection on CE. See 
“Configure Rendition Engine connections on Content 
Engine” on page 60.

re_db_user (SQL_login) (Microsoft SQL Server only) Any SQL Server user 
with SQL Server's "Database Creators" server 
role.

This user will be created as part of the Microsoft 
SQL Server installation and is a safer alternative 
to using SQL Server's SA or SYS users, which will 
also satisfy the configuration requirements.

See “To configure Microsoft SQL Login for Rendition 
Engine” on page 46.

re_db_user (VISTAUSER) (Oracle Server only) This user will be created as 
part of the Oracle Server installation. See “To 
create an Oracle database” on page 49.

.

For a complete list of the user and group roles, accounts, and responsibilities required to install, 
configure, and maintain a FileNet P8 system, see the FileNet P8 Help topic FileNet P8 
Administration > Enterprise-wide Administration > Security > Users and groups > FileNet P8 Platform user 
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE



 Security Administrator Tasks
Users required for Rendition Engine installation

43
and group security help and the Plan and Prepare your Environment for IBM FileNet P8 guide topic 
“Create Directory Server Accounts.”
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Database Administrator tasks
The items below are the required tasks for the database administrator.

Database considerations 
For a checklist version of these considerations, see “Database Considerations” on page 93.

If you plan to collocate the RE database with CE or PE databases, you should use the supplied 
database instance (Microsoft SQL Server) or database (Oracle) for these components. For more 
information, see IBM FileNet P8 Platform Installation and Upgrade Guide and the tasks Install 
Microsoft SQL Server for FileNet P8 or Install Oracle Server for FileNet P8.

If you plan to install and configure a standalone database instance (Microsoft SQL Server) or 
database (Oracle) for RE, follow the instructions in this guide.

All platforms
• Determine your local vs. remote database engine preference. The database engine is local if it 

is installed on a server where you will also be installing Content Engine, Process Engine and/
or Rendition Engine software. The database is remote if it is on a server where no Content 
Engine, Process Engine or Rendition Engine software is installed.

• Determine what type of database engine you want to use. Rendition Engine supports only 
Microsoft SQL Server and Oracle. 

• Determine the Purge and Archive intervals for the RE database.

By default, the RE database is set to autogrow. To keep the database size down, RE is set up 
to archive the content of the database daily and to purge the archived content weekly. These 
intervals can be modified using the Domain Manager interface. See “(Optional) Set the Rendition 
Engine Purge and Archive Intervals.” on page 58.

Microsoft SQL Server
• Determine whether you want to use a dedicated or shared database. 

– You can assign Rendition Engine a dedicated instance. You can use the default instance or 
a named instance of your choice.

– Rendition Engine can share a Microsoft SQL Server instance with Content Engine or 
Process Engine. 

– Rendition Engine must have its own database, separate from Content Engine and Process 
Engine. 

NOTE  There is no need to create an SQL database before you install Rendition Engine 
software. The Rendition Engine installer will prompt for appropriate database information 
and will create the necessary database.

– Remote Microsoft SQL connections for Rendition Engine are handled by Microsoft Data 
Access Components, which is installed by default on Rendition Engine servers. There is 
no need to install the Microsoft SQL client software on the Rendition Engine server.
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• Create a SQL Login account for Rendition Engine purposes. Under Microsoft SQL Server, you 
must ensure that an SQL Login account exists before you install the first Rendition Engine. 
See “To configure Microsoft SQL Login for Rendition Engine” on page 46.

Oracle
• Determine whether you want to use a dedicated or shared database.

– Rendition Engine can have a dedicated Oracle database service or share a database 
service with Content Engine, Process Engine, or non-FileNet applications. 

– Rendition Engine must have its own tablespace, separate from Content Engine and 
Process Engine. 

NOTE  This tablespace will be created by executing an Oracle SQL script prior to installing 
the first Rendition Engine. See “To create an Oracle database” on page 49.

• Database client software requirements. For Rendition Engine, if the database is remote, you 
must install database client software on the Rendition Engine server. See “Prepare Oracle 
Client” on page 51. 

NOTE  While the Content Engine also requires installation of the database client software, that 
installation and configuration will have already been completed during installation of the 
FileNet P8 system.

• To create a valid user and tablespace for RE, you will run the Oracle-repository.sql script on the 
database server as part of “Prepare Oracle Server” on page 48 before you perform the 
installation tasks. 
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Prepare Microsoft SQL Server
Database Administrator Tasks

If you plan to collocate the RE database with CE or PE databases, you should use the existing 
database instance for these components. For more information, see the Plan and Prepare Your 
Environment for IBM FileNet P8, task Prepare Microsoft SQL Server.

If you plan to install and configure a standalone database instance for RE, follow the instructions 
in this task.

NOTES

• Install Microsoft SQL Server on the server where Rendition Engine software will be installed 
as a local database or on a separate server as a remote database. 

• Database creation for Rendition Engine will be handled automatically when you install and 
configure Rendition Engine.

• You do not need to install Microsoft SQL client software on the Rendition Engine server.

• (Microsoft SQL Server 2000) Verify that the required Microsoft SQL Server 2000 Service Pack 
is available. See the IBM FileNet P8 Hardware and Software Requirements. 

• Record the values for the following settings as you work through the database installation. 
This information must be entered during subsequent installations. 

– Server name.

– Instance (e.g., P8_inst).

– TCP/IP port number assigned. 

To install and configure Microsoft SQL Server

FileNet Rendition Engine does not require any specific configuration settings when you install 
Microsoft SQL Server. Refer to the Microsoft SQL Server 2000/2005 installation instructions. 

To configure Microsoft SQL Login for Rendition Engine

On the Microsoft SQL database computer, use Microsoft SQL Server Enterprise Manager to 
create a Microsoft SQL Login (re_db_user (SQL_login)).

1. Start the Microsoft SQL Enterprise Manager.

2. Expand the Microsoft SQL Server Server name[\Instance name] node. 

3. Expand the Security folder, right-click Logins and select New Login....

4. In the SQL Server Login Properties screen, under the General tab, perform the following:

a. In the Name field, enter a name for the re_db_user (SQL_login) user.

b. In the Password field, enter a password for the new SQL user.

c. Verify that the default database for the login is “master.”
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5. Grant the SQL login created in the step above the Database Creators server role.

a. In the SQL Server Login Properties screen, select the Server Roles tab.

b. Under Server Roles, check Database Creators.

6. Using the SQL Query Analyzer, validate that you can successfully log on to the SQL database 
using this user name and password. 
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Prepare Oracle Server
Database Administrator Tasks

If you plan to collocate the RE database with CE or PE databases, you should use the existing 
database for these components. For more information, see the Plan and Prepare Your 
Environment for IBM FileNet P8, task Prepare Oracle Server.

If you plan to install and configure a standalone database for RE, follow the instructions in this 
task.

A database is local if it is on a machine where you will also be installing Rendition Engine. A 
database is remote if it is on a machine where no Rendition Engine is installed. 

NOTES

• Perform this task on the UNIX®, Linux®, or Windows server that will host the Oracle database 
to be used by the Rendition Engine.

• Make sure that the server that will host the database satisfies all pre-installation requirements 
specified in the Oracle installation documentation.

• If the server where you install the Oracle database will also host an installation of Rendition 
Engine, the machine must meet the Rendition Engine requirements listed in IBM FileNet P8 
Hardware and Software Requirements.   

• Refer to IBM FileNet P8 Hardware and Software Requirements for operating-system service 
pack and Oracle version and patch set requirements. The Oracle patch-installation procedure 
may be less complicated if you do it before you create any databases.

• If your Oracle database will be remote, after you complete the procedures in this topic, you 
must also complete the procedures in “Prepare Oracle Client” on page 51 on each machine 
where you will install Rendition Engine.

• FileNet suggests that you record the values for the following settings as you work through the 
database installation. This information must be entered during subsequent installations.

– Global Database Service Name

– Oracle temporary tablespace name

– Oracle data tablespace name

– Oracle index tablespace name (optional)

To install an Oracle database engine

FileNet Rendition Engine does not require any specific configuration settings when you install 
Oracle. Refer to Oracle installation instructions. 

You do not need to create a tablespace as part of the installation. This will be handled in “To create 
a tablespace for Rendition Engine” on page 50. 

During installation, select Enterprise Edition or Custom to install the necessary components (if you 
don't need all the components in the Enterprise Edition).
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If you selected Custom you must, at a minimum, install the following components:

• Oracle 10g

– Oracle 10g Server

– Oracle Net Services

• Oracle Net Listener

– Oracle 10g Development Kit

• Oracle Call Interface (OCI)

– (Windows) Oracle Windows Interfaces

• Oracle Services for Microsoft Transaction Server

– Oracle 10g Documentation (recommended) 

• Oracle 11g 

– Oracle 11g Server

– Oracle Net Services

• Oracle Net Listener

– Oracle 11g Development Kit

• Oracle Call Interface (OCI)

– (Windows) Oracle Windows Interfaces

• Oracle Services for Microsoft Transaction Server

– Oracle 11g Documentation (recommended) 

To create an Oracle database

Oracle documentation describes several ways to create a database, for example the Database 
Configuration Assistant (DBCA).

When you create the database, specify the following settings:

• Server process type

NOTE  “Dedicated Server Mode” offers better performance than “Shared Server Mode.”

• Database character set

Choose a database character set as specified in “IBM FileNet P8 Database Character Sets” in 
the Plan and Prepare Your Environment for IBM FileNet P8.
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To create a tablespace for Rendition Engine

You will use the Oracle-Repository.sql script to create a user and tablespaces for use by Rendition 
Engine. The tablespaces are for the exclusive use of Rendition Engine and should not be shared 
with any other FileNet P8 component.

1. Log on to the Oracle server as an Oracle administrative user. 

2. Access the IBM FileNet Rendition Engine installation package.

3. Navigate to \Resources.

4. Copy the Oracle-Repository.sql script locally, and open it for editing.

Several parameters in the script can be modified to meet specific business requirements. The 
following table shows those parameters and the default values. Make a note of the actual 
values that are assigned. 

Specifically, note the user name and the password that is assigned when the script is run. 
That user name and password must be supplied later when you install the Rendition Engine 
software.

Parameter Default Value (If modified) Actual Value 
Assigned

data tablespace VISTADAT1

index tablespace VISTAIND1

user name re_db_user 
(VISTAUSER)

password none (assigned at 
runtime)

 

5. Run the modified Oracle-Repository.sql script. 

Supply the required password for the re_db_user (VISTAUSER) when prompted.
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Prepare Oracle Client
Database Administrator Tasks

The procedure in this task describes how to install the Oracle Client software to prepare for the 
installation of Rendition Engine.

NOTES

• (Windows 2003 64-bit only) If you are using Windows 64-bit system for your Rendition Engine 
you must install the 32-bit Oracle Client, not the 64-bit client.

• Install Oracle Client on servers that will host Rendition Engine if the database will be remote 
from the Rendition Engine server.

• Make sure that the machine where you will install Oracle Client satisfies all the pre-installation 
requirements specified in the Oracle installation documentation.

• Refer to IBM FileNet P8 Hardware and Software Requirements for operating-system service 
pack and Oracle version and patch set requirements.

To install the Oracle client

The following procedure describes the minimum options for installing Oracle Client. Consult the 
Oracle installation documentation for complete instructions and pre-installation requirements.

1. Log on with an appropriate local account to install and configure the Oracle Client software.

NOTE FileNet strongly recommends that you log on to the machine locally (not through a 
Windows domain) to install the Oracle Client software. 

2. If the machine where you are installing Oracle Client does not use DNS to resolve host names, 
place in its hosts file the IP address of the machine where the Oracle database is installed.

3. Launch the Oracle Client installation.

4. From the Available Products dialog, click Oracle Client.

5. From the Installation Types dialog box, click Runtime, and proceed with the installation.

6. After the installation completes, click Next Installation. 

7. On the Installation Types dialog box, click Custom and select Oracle Windows Interfaces from 
the list in the Available Product Components Dialog box, then proceed with and complete the 
installation.

8. Using Oracle Net Configuration Assistant, test the connection to the Oracle database server 
with the user name and password created in “To create a tablespace for Rendition Engine” on 
page 50. 

9. Install all required Oracle patches, as specified in the IBM FileNet P8 Hardware and Software 
Requirements. To download this guide from the IBM support page, see “Access IBM FileNet 
documentation, compatibility matrices, and fix packs” on page 16. 
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Install database drivers on Content Engine
Database Administrator Tasks

CAUTION  This task is only required if your CE and RE are using different databases. 

Rendition Engine might be configured to use a different database brand than the CE/object store 
(i.e. MS SQL Server versus DB2). In this case you must configure CE with the corresponding 
JDBC driver for the RE database such that the RE client software running on the CE application 
server can access the RE database. 

The procedure for installing the JDBC driver for the RE database is identical to the procedure for 
installing the JDBC for the CE. Use the steps specified in the “Configure WebSphere for Content 
Engine,” “Configure WebLogic for Content Engine,” or “Configure JBoss for Content Engine” tasks 
of the Plan and Prepare Your Environment for IBM FileNet P8 document.
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Install and configure Rendition Engine

This installation section contains the following major topics:

• Task 1 “Install Rendition Engine” on page 54.

• Task 2 “Configure Rendition Engine connections on Content Engine” on page 60.

• Task 3 “Set the site preferences on the Application Engine to use path-based URLs” on page 62.

• Task 4 “Enable word processing macros for rendering” on page 63.

• Task 5 “Install Rendition Engine software updates” on page 65.

• Task 6 “(Optional) Verify installation” on page 66.
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Task 1: Install Rendition Engine
This procedure covers the installation and initial configuration of the Rendition Engine.

WARNING  If you enter invalid database user credentials and complete the Rendition Engine 
installation, you must correct these using the Domain Manager before you attempt to use 
Rendition Engine. For more information, see the FileNet P8 Help topic FileNet P8 Administration > 
Enterprise-wide Administration > Publishing > How to... > Change the Rendition Engine database 
password.

CAUTION  If this is an upgrade you can’t use a database that was used for an earlier version of the 
Rendition Engine software. You must create and identify a new database.

NOTES  

• This task covers installation of the first RE in a Liquent Vista domain, and installation of a 
second and consecutive RE in the same domain to increase publishing throughput. If you 
intend to install more than one Rendition Engine in your environment, make sure that each 
installation is completed and that RE is configured before you start the next installation.For 
more information about adding additional RE servers to a Liquent Vista Domain, see the 
FileNet P8 Platform Performance Tuning Guide. 

• During the installation, you might be prompted to install additional Microsoft software. 
Specifically, if the .NET Framework 1.1 or XML Parser 4.0 software is not already on your 
server, the Rendition Engine installer will do that installation. See “Setup Status” on page 57.

• After installing RE you should confirm that the necessary macros have been installed to the 
external applications you plan to use for rendering. For information and procedures, see 
“Enable word processing macros for rendering” on page 63.

NOTE If you install a word processing applications after you have installed Rendition Engine 
you must update the application with the required macro files. See “To update applications 
installed after Rendition Engine” on page 64.

To install Rendition Engine

1. Log on to the Rendition Engine server as the FNRE_Admin user.

NOTE  Unless otherwise directed use this FNRE_Admin account to install and configure all the 
Publishing components.

2. If it isn’t already running, start the Print Spooler Windows service. 

3. Start the Rendition Engine installation wizard.

a. Access the IBM FileNet Rendition Engine installation package.

b. Launch the installation program (\Installer\setup.exe).

4. Complete the installation screens as follows:

For information on parameter values, see “Installation and upgrade worksheet” on page 87.
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HINT With the Data > Filter > AutoFilter command enabled, as it is by default in the shipping 
worksheet file (p8_worksheet.xls), perform the following steps to quickly see only the 
installation properties you must specify for the Rendition Engine installation program:

• Click the AutoFilter drop-down arrow in the "Installation or Configuration Program" column header 
and select RE installer.

• Click the AutoFilter drop-down arrow in the "Setup Type" column header, select Custom, and 
specify: Setup Type contains "Installation."

NOTE  If you are performing an upgrade, make sure the Setup Type contains “Upgrade.”

In this screen... Perform this action...

Customer Information Enter a value in the User Name and Company Name fields, 
select the Anyone who uses this computer (all users) option.

License Agreement Review and accept the license agreement.

Choose Destination 
Location

Accept the default installation location or click Browse to select 
another location (RE_install_path). 

Default:

C:\Program Files\FileNet\RenditionEngine\Liquent

NOTES  

• The installation program creates a directory at the selected 
location and installs the Rendition Engine software in this 
directory.

• In addition to the directory above, the installer will create 
the following folder and install a few components in there:

C:\Program Files\Common Files\Liquent

RPS License File Browse to and select the RPS license file. 

NOTE  The license file IBMFileNetRenditionEngineLicense.xml is 
located on the IBM FileNet Rendition Engine installation package 
in the \Resources folder. 

RPS User Information Enter the required information for the RPS User (FNRE_Admin).

• Domain: This field defaults to the domain your server is a 
member of or to the server name of a standalone machine.

• User: Enter the name of the FNRE_Admin user. 

NOTE  The User field defaults to the user account with 
which you logged in to the server.

• Password: Enter the FNRE_Admin password in the password 
field.

• Confirm Password: Confirm the FNRE_Admin password.
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RPS Database Type Choose SQL Server or Oracle. 

Depending on your choice, you will be prompted for additional 
information appropriate on that database type.

NOTE  MSDE and MS Access are not supported for Rendition 
Engine even though they are available in the installer interface.

(SQL Server) SQL 
Server Database 
Information 

WARNING If you enter invalid database user credentials and 
complete the Rendition Engine installation, you must correct 
these using the Domain Manager before you attempt to use 
Rendition Engine. For more information, see the FileNet P8 
Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Change the Rendition 
Engine database password.

Enter the database information:

• Machine: Enter or browse for the machine name where the 
SQL Server database will be created. If you plan to use a 
named instance rather than the default instance, you must 
enter this value: 

db server name\instance name

• Catalog (Database): Enter the database name to be created 
for Rendition Engine use.

CAUTION  If this is an upgrade, you cannot use a database 
that was used for an earlier version of Rendition Engine 
software. You must identify a new database.

• User: Enter the re_db_user (SQL_login) user name.

• Password: This is the re_db_user (SQL_login) user’s 
password.

In this screen... Perform this action...
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5. When the Rendition Engine installation has completed, check the install log files to verify that no 
errors occurred.

The log files are available at:

C:\Temp\LiquentServicesInstall.log 

C:\Temp\VistaInstall.log 

(Oracle) Oracle 
Database Information 

WARNING  If you enter invalid database user credentials and 
complete the Rendition Engine installation, you must correct 
these using the Domain Manager before you attempt to use 
Rendition Engine. For more information, see the FileNet P8 
Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Change the Rendition 
Engine database password.

NOTE There is a warning on this screen that you must already 
have the Vista database tables created. All necessary tables 
were created when you executed the Oracle-repository.sql script 
earlier. See “To create a tablespace for Rendition Engine” on 
page 50. 

The user name and password requested here are the ones you 
assigned when you ran that script.

Enter the database information:

• Service: Enter the Oracle service name to use with 
Rendition Engine. 

CAUTION  If this is an upgrade, you cannot use a database 
that was used for an earlier version of Rendition Engine 
software. You must identify a new database.

• User: Enter the name of the re_db_user (VISTAUSER).

• Password: Enter the password of the re_db_user 
(VISTAUSER).

Start Copying Files Confirm your selections.

Setup Status The progress bar indicates the status of your installation.

NOTE  At this stage the installer will check for required 
Microsoft software (.NET Framework 1.1 or XML Parser 4.0). If 
the required software is not installed, the Rendition Engine 
installer will perform the necessary installations.

Follow the instructions in the installation wizards that the 
Rendition Engine installer launches.

In this screen... Perform this action...
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6. Reboot your server and, log back on using the FNRE_Admin account.

CAUTION  Before rebooting, use the Windows Task Manager or the application bar to verify 
that the IBM FileNet Rendition Engine 4.5.0 - InstallShield Wizard application has exited. This 
might take a few moments.

7. (Windows 2003 64-bit only) Manually register the CDIntf300.dll.

For rendering on a Windows 2003 64-bit system to work, you must manually register the 
printer driver by executing the following from a command line: 

cd C:\WINDOWS\SysWOW64
regsvr32 CDIntf300.dll

8. Create a Java Repository on the Content Engine server.

NOTE  Perform this step on the first Rendition Engine server in each Liquent Vista domain 
only. Additional RE servers will use the settings of the Liquent Vista domain they connect to.

a. On the Rendition Engine server, navigate to Start > Programs > Liquent > Domain Manager 
to launch the Domain Manager.

b. Select File > Add Repository… menu, and click Yes in the confirmation pop-up to verify that 
you intend to add a repository to this domain.

c. In the "New Repository Properties" dialog box, complete the following fields:

• Machine: Enter the CE Machine name in the "machine" entry field.

• Platform (drop-down): Select "java" in the "Platform" drop-down list.

• Notify Port: Keep the default value or type in a new value.

• Event Port: Keep the default value or type in a new value.

• Admin Port: Keep the default value or type in a new value.

• File Transfer Port: Keep the default value or type in a new value. 

• Job Queue Port: Keep the default value or type in a new value. 

CAUTION  Make sure the port numbers are unique and are not clashing with existing CE 
ports. These ports are used by the publishing handler on the CE. For a list of the default 
values, see “FileNet P8 port numbers” on page 89.

d. Confirm the new repository by selecting File > Save and clicking Yes in the confirmation pop-
up to verify that you intend to make these changes to the database.

9. (Optional) Set the Rendition Engine Purge and Archive Intervals.

To keep the size of your database down, you should configure RE to regularly purge the RE 
database of old data. You can also keep the default values to archive data once a day, and 
purge the archived data once a week.

a. On the Rendition Engine server, navigate to Start > Programs > Liquent > Domain Manager 
to launch the Domain Manager.

b. In the Configuration tab, right-click the Domain node and select Properties.
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c. In the General tab of the Domain Properties dialog box, set the Purge Age (Default: 7 days) 
and Archive Age (Default: 1 day) intervals to suit your environment.

10. Set security on the VistaTempDir shared folder.

NOTE  Perform this step on all Rendition Engine servers in each Liquent Vista domain.

a. On the Rendition Engine server, use Windows Explorer to navigate to:

RE_install_path\SharedTemp 

b. Right-click the \SharedTemp folder and select Properties.

c. In the SharedTemp Properties screen, verify that the \SharedTemp folder is shared using the 
share name “VistaTempDir.” If not, select the Sharing tab and select Share this folder. 

d. Select the Security tab and click Advanced. 

e. In the Access Control Settings for SharedTemp screen, clear Allow inheritance 
permissions, and then click Remove in the security confirmation pop-up.

f. In the Access Control Settings for SharedTemp screen, click Add. 

g. In the Select User or Group screen, for the Look in field, keep the local server name or 
select the correct domain.

h. Select the proper Rendition Engine user account (FNRE_Admin).

i. In the Permission Entry for SharedTemp, give the account all access rights.

j. In the Access Control Settings for SharedTemp screen, click OK.

k. In the SharedTemp Properties screen, click OK.

11. (If you have added a second or consecutive Rendition Engine to your Liquent Vista domain) 
Restart the BusinessServiceServer service.

Every time a Rendition Engine is added to the FileNet P8 Platform domain, you must manually 
restart the BusinessServiceServer services on every Rendition Engine connected to the 
Liquent Vista domain.
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Task 2: Configure Rendition Engine connections on 
Content Engine
This topic covers the required configuration steps to enable publishing on the Content Engine.

NOTE  (Upgrades) Perform this if you have created a new database or tablespace with a new 
name and/or administrative user. See “Create a new Rendition Engine database” on page 72.

To create a Liquent Rendition Engine Connection 

Creating a Liquent Rendition Engine connection is accomplished using Enterprise Manager. 

1. Set up Rendition Engine Connection (REC) on the Content Engine.

a. Launch Enterprise Manager as a GCD_admin. See “Authentication Requirements” on page 94.

b. Right-click the Enterprise Manager [p8 domain] node and select Properties.

c. In the Enterprise Manager [p8 domain] Properties screen, select the Publishing tab.

d. Verify that the Enable Dispatcher checkbox is checked.

e. In the Select Rendition Engine Connection Field, click New. 

The Create Rendition Engine Connection wizard opens.

In this screen... Perform this action...

Specify the Site Select the site you want to associate with this connection.

Name and Describe the 
Rendition Engine 
Connection

Enter a name and description for your new connection.

Configure the Database Enter the specifics for connecting to the Rendition Engine 
Database. MSSQL default port address is 1433. Username 
is the database connection username.

Database Type: Select MSSQL or Oracle 

Database Server Name: Enter the name of the database 
server.

Database Name: Enter the database name (Microsoft SQL 
Server) or the Service name (Oracle).

Database Server Port: Enter the server port used by the 
database. For default ports, see “FileNet P8 port numbers” on 
page 89.

Username: Type in the re_db_user (SQL_login) (Microsoft 
SQL Server) or re_db_user (VISTAUSER) name (Oracle). See 
“To create an Oracle database” on page 49.

Click Create. 
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f. In the Enterprise Manager [p8 domain] Properties screen, click Apply to save your changes. 

g. The newly created Rendition Engine Connection will now be listed in the "Select Rendition 
Engine Selection" list box.

h. Click Properties next to the connection to set the password and Connection State. 

i. In the Rendition Engine Connection Properties screen, select Set Password and enter the 
password. Click OK, and OK again to set it. 

j. In the Rendition Engine Connection Properties screen, Connection State drop-down list, 
select Enabled. 

k. Click Apply, and then click OK to save the changes, and click OK to close the Enterprise 
Manager [p8 domain] Properties screen.
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Task 3: Set the site preferences on the Application 
Engine to use path-based URLs
NOTE  (Upgrades) This task is not required on an upgrade. However, you should verify that your 
settings are valid.

In order to view HTML publication documents, you must first configure the path-based URL 
parameter. 

When Publishing a document to HTML, the resulting HTML publication document will in most 
cases contain references to graphics or other files that are required to correctly display the 
document. If you choose not to use path-based URLs the references in the HTML code can not be 
resolved and the HTML publication documents will not display correctly.

PDF publication documents are self contained and do not require the use of path-based URLs.

To configure the path-based URL parameter

1. Sign in to Workplace as a user assigned the Application Engine Administrators access role. 

2. Choose Admin > Site Preferences.

3. Under General Settings > Application section, set Use path based URLs to Yes.

4. Click Apply to save the setting.

5. Click Exit.
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Task 4: Enable word processing macros for rendering
To enable word processing macros for rendering

In order to support Liquent rendering functionality, such as bookmarking and preserving links, 
Microsoft Word, Corel WordPerfect and Adobe FrameMaker require additional macro files. 
Provided the applications are installed prior to installing Liquent, the macro files are automatically 
copied to the appropriate directories by the Liquent installer.

Complete this section to confirm, and if necessary, enable the macro files. Also, if you install a 
word processing applications after Liquent has been installed, this section describes the process 
for updating the application with the required macro files.

1. Confirm and enable the Microsoft Word macro

a. Open Microsoft Word.

NOTE  Perform this procedure on each Rendition Engine server.

When Word opens, you receive a security warning about the file cdmacros.dot.

Word 2003

i. Select the option Always Trust macros from this publisher.

ii. Click Enable Macros to allow the macro to run when Word opens.

iii. Choose Tools > Templates and Add-Ins.

iv. Under Global templates and add-ins, click cdmacros.dot and at the bottom of the dialog 
box, confirm that the full path for the template is 

root:\Program Files\Microsoft Office\Office version\STARTUP

v. If the path is incorrect, click Remove to remove the currently loaded cdmacros.dot 
template, and then click Add to add the cdmacros.dot template with the correct directory 
path.

Word 2007

i. Click the Options button.

ii. Select the option Trust all documents from this publisher, and click OK.

iii. Click the Microsoft Office Button, click Word Options, and then click Add-Ins.

iv. Click cdmacros.dot and at the bottom of the dialog box, confirm that the full path for the 
template is 

root:\Program Files\Microsoft Office\Office version\STARTUP

v. If the path is incorrect, consult with Microsoft documentation on how to correct it.

b. Close Microsoft Word.
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2. Confirm and enable Corel WordPerfect

NOTE  Perform this procedure on each Rendition Engine server.

In Windows Explorer, navigate to \Program Files\WordPerfect Office12\Macros\WPWin and 
confirm that the following macro files exist:

• espsdtoc.wcm

• espsdtoc11.wcm

• espsdtoc12.wcm

• espsdtoc2k.wcm

• espsdtoc9.wcm

• espsrsym.wcm

• espsrsym11.wcm

• espsrsym12.wcm

• espsrsym2k.wcm

• espsrsym9.wcm

• generate.wcm

• removehf11.wcm

• removehf12.wcm

• removehf2k.wcm

3. Confirm and enable Adobe FrameMaker

In Windows Explorer, navigate to \Program Files\Adobe\FrameMaker7.1 and confirm that the 
following macro file exists:

• esfmdde.dll

To update applications installed after Rendition Engine

1. In the Domain Manager application, choose File > Configure Applications.

The Configure Applications dialog box opens.

NOTE  A check mark to the left of the check box indicates that the application has been 
updated with the required macro files, and no further action is required.

2. If the box isn’t checked (the macro(s) isn’t installed), check the check box next to the application 
and click OK.

3. Choose File > Save to save your changes.

4. Reopen the dialog box and confirm that a check mark appears to the left of the check box of the 
application you updated.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE



Task 5: Install Rendition Engine software updates
To install the Rendition Engine software updates

65

IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE

Task 5: Install Rendition Engine software updates
Perform the procedure in this topic for each Rendition Engine instance to install software updates 
(mod release, fix pack, or interim fix).

To install the Rendition Engine software updates

1. To obtain the latest Rendition Engine software updates, and to determine whether additional 
interim fixes are needed, contact your service representative.

2. Open the readmes for the Rendition Engine software updates and perform the installation 
procedures in the readmes on each Rendition Engine instance.
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Task 6: (Optional) Verify installation
Successfully completing all the steps below confirms that the basic functionality of RE is working 
and that the application has been correctly installed and configured.

For more information about the RE user interface and the procedures you are working on, use the 
Help links in the RE user interface to access context-sensitive help.

For a more extensive description of how to start using RE past this simple functionality test. See 
the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide Administration > Publishing and 
the Publishing Designer help located at Workplace > Advanced Author Tools > Publishing Designer.

For more details on adding and publishing documents using Workplace, refer to the Workplace 
help topic FileNet P8 Documentation > Workplace > Workplace User Help > Manage Documents.

To verify RE installation

1. Create Publishing Templates.

The FileNet P8 Platform publishing feature is delivered with default style templates for both 
PDF and HTML renditions. You will use those default style templates for this procedure. 

For more information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Create publishing templates.

2. Add and publish a test document.

This procedure shows you how to add and publish a test document to verify that you have 
correctly installed and configured the publishing components. 

For more information, see the FileNet P8 Help topic FileNet P8 Administration > Enterprise-wide 
Administration > Publishing > How to... > Publish your first document.
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Plan and prepare for upgrade

This section, Plan and prepare for upgrade, provides instructions for preparing your system to 
upgrade IBM FileNet Rendition Engine. 

Plan the Upgrade
Information for upgrading the Rendition Engine from the 3.5.x release to the 4.5 release is 
covered in this topic. The upgrade involves uninstalling and reinstalling the software. 

• You will reinstall Rendition Engine on the existing Rendition Engine servers.

• Rendition Engine 4.5 and later does not use the publishing plugin. This component is 
uninstalled as part of the CE upgrade.

NOTES  You should plan and test the upgrade on a test system first. Verify the upgrade is 
successful by running functionality and stress tests. After successful verification, perform the 
production upgrade. 

Before you begin the upgrade
• Be sure to read the “What’s New” topic in the IBM FileNet P8 Platform Release Notes. Many of 

the new features may be interesting for your implementation of FileNet P8 Platform. To 
download this guide from the IBM support page, see “Access IBM FileNet documentation, 
compatibility matrices, and fix packs” on page 16.

• Make sure the site has restorable backups of system and data, in case you need to back out of 
the upgrade. For details on what to back up for FileNet P8 components, see the FileNet P8 
Help topic Enterprise-wide Administration > Back up and Restore FileNet P8.
IBM FILENET RENDITION ENGINE INSTALLATION AND UPGRADE GUIDE



 Perform required preparation tasks
To prepare your environment for a Rendition Engine installation

68
Perform required preparation tasks
In addition to the general requirements for FileNet Rendition Engine 4.5 that are listed in “Plan and 
prepare for installation” on page 18, the following requirements apply when you upgrade an existing 
RE 4.0 system to version 4.5. 

ATTENTION  In addition to the preparation tasks listed below, follow the plan and prepare 
instructions in the Plan and Prepare your Environment for IBM FileNet P8 guide for the 
components you are installing. 

To prepare your environment for a Rendition Engine installation

Perform the required preparation tasks for the components you plan to install:

• “Installation Administrator tasks” on page 69

• “IT Administrator tasks” on page 70

• “Security Administrator tasks” on page 71

• “Database Administrator Tasks” on page 72

In addition, if you are using the Installation and Upgrade Worksheet for your environment, all 
administrators should fill out the worksheet with the relevant information as described 
in.“Installation and upgrade worksheet” on page 69.
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Installation Administrator tasks
The items below are the required tasks for the Application Installer Administrator.

Database or directory services migration
This guide does not address migrations to different databases or directory services. To migrate 
from one database to another (for example, from a Microsoft SQL Server database engine to 
Oracle), you must contact your service representative. 

Before you begin the upgrade
• Make sure no users or processes are accessing the FileNet P8 system.

• Complete any pending publishing jobs.

• Disable scheduled automated backups.

• Disable virus scanning.

Requirements for upgrades
The upgrades described in the guide assume that you will:

• retain your basic platform configuration from the previous release. 

• make no changes to user or group definitions during the upgrade.

• apply only the necessary supported software updates and patches, as noted in this guide and 
in the IBM FileNet P8 Hardware and Software Requirements document.
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IT Administrator tasks
The items below are the required tasks for the Information Technology (IT) administrator.

Network considerations
Ensure the availability of required port numbers. For a composite list of port numbers required for 
FileNet P8 4.5, see “FileNet P8 port numbers” on page 89.

Independent software vendor (ISV) applications
If you plan to upgrade the native applications used by Rendition Engine, you must do this before 
you reinstall Rendition Engine.

Content Engine considerations
• Ensure that you have the necessary local administrator user accounts and passwords to 

perform configuration tasks on the Content Engine server.

• Verify that all object stores you want to use for publishing are configured with the publishing 
add-ons. 

NOTE  In RE 4.5, publishing is configured per site rather than per object store. Object stores 
that will be used for publishing must be configured with the Publishing addons. By default, 
these are added when you create an object store, custom stores that aren't configured with 
these add-ons may exist. If necessary you can manually add the add-ons using FileNet 
Enterprise Manager. 

• The publishing templates are upgraded as part of the CE upgrade. 

CAUTION  If your current publishing templates use VBScript Event Actions, these must be 
rewritten in Java before they can be used for RE 4.5. Furthermore, the Java class must be 
located on the server; it cannot be on a client and streamed to the server for execution as for 
CE 3.5.x. The rewrite must be done after the upgrade and before you start using RE. For more 
information on how to rewrite the event actions in Java, see the FileNet P8 Help topic FileNet 
P8 Administration > Content Engine Administration > Events and subscriptions > How to... > Work with 
event actions.
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Security Administrator tasks
The items below are the required tasks for the Security Administrator.

Rendition Engine
• Ensure that you have the necessary local administrator user accounts and passwords to run 

the upgrade program on the Rendition Engine. See “Users required for Rendition Engine 
installation” on page 42.

• Verify the security settings for the Rendition Engine temporary directory. 
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Database Administrator Tasks
The items below are the required tasks for the database administrator.

Updating database software
Update to the appropriate database patches before you upgrade Rendition Engine. 

Oracle clients
Ensure you have applied appropriate Oracle patches to Oracle clients and servers. Be sure that 
clients remote to an Oracle database engine have the same patches as the database server. 
Oracle clients include any machines remote from the Oracle database server where Rendition 
Engine software is installed. Install all required Oracle patches, as specified in the IBM FileNet P8 
Hardware and Software Requirements. To download this guide from the IBM support page, see 
“Access IBM FileNet documentation, compatibility matrices, and fix packs” on page 16.

Create a new Rendition Engine database
When you upgrade, you cannot use an existing Rendition Engine database. You will need to 
identify a new database (SQL Server) or tablespace (Oracle) for use by the 4.5 version of 
Rendition Engine. You cannot use existing databases or tablespace after the upgrade. 

To create your new database or tablespace

• For Microsoft SQL server, the database will be created by the installer.

• For Oracle, you must create an Oracle user and associated tablespaces (includes temp) 
before you install RE. 

When creating your new database or tablespace you have the following options:

• Use the same name and administrative user as the previous version.

Delete the old database or tablespace before you run the installer and create a new one with 
the same name and administrative user as part of the upgrade procedure. For information, see 
“(Optional) Remove the existing RE database.” on page 76 and (Oracle) “To create an Oracle 
database” on page 49.

• Use a new name for the new database or tablespace.

NOTE  If you use a new name for your database or tablespace you must reconfigure your 
Content Engine connection as part of the upgrade. See Task 2 “Configure Rendition Engine 
connections on Content Engine” on page 60. 

– (Microsoft SQL Server) Configure the new database using a new name.

– (Oracle) Configure the new tablespace with a new name and a new re_db_user 
(VISTAUSER) user.

CAUTION  If you choose to create new databases using new names, you must modify the 
entries in the Oracle-Repository.sql script with the new information. See “To create an Oracle 
database” on page 49.
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Upgrade and configure Rendition Engine

This upgrade section contains the following major topics:

• Task 1 “Uninstall previous version of Rendition Engine” on page 74.

• Task 2 “Upgrade Rendition Engine” on page 80.
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Task 1: Uninstall previous version of Rendition Engine
Before you can install the 4.5 version of Rendition Engine, you must uninstall the previous version 
of the software.

Depending on your currently installed version of Rendition Engine, perform one of the following:

• “To remove Rendition Engine version 4.0 software” on page 74.

• “To remove Rendition Engine version 3.5 software from a Rendition Engine or Publishing Plug-in 
server” on page 77.

To remove Rendition Engine version 4.0 software

You must uninstall the Rendition Engine software, remove the local printer ports, and remove 
native application macros before upgrading (re-installing) the publishing components for 4.5.

1. Back up your existing installation.

Rendition Engine does not require backup. In case you need to roll back to the previous 
version of the FileNet P8 Platform and Rendition Engine, you need only reinstall the previous 
version of the software.

NOTE  Some Rendition components such as publishing templates and publishing style 
templates are located on a Content Engine (CE) server and were backed up as part of the 
preparation for CE upgrade.

2. Log on to the Rendition Engine server as FNRE_Admin.

3. Stop the BusinessServiceServer Windows service prior to uninstalling the software. 

a. Navigate to Start > Settings > Control Panel.

b. Double-click Administrative Tools.

c. Double-click Services.

d. Double-click BusinessServiceServer.

e. Click the Stop button. 

4. Remove the Rendition Engine software.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Select FileNet P8 Rendition Engine 4.0.0 and click Change/Remove.

d. Follow the screen prompts to remove the software. At the final screen, click Finish.

e. Close the Add/Remove Programs Window.

5. Remove the printers.

a. Navigate to Start > Settings > Control Panel. Double-click Printers and Faxes.

b. If the Liquent XML Printer is listed in the Printers and Faxes window, delete it.
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c. If the Liquent PDF Printer is listed in the Printers and Faxes window, delete it.

d. On the Printers and Faxes window, select File > Server Properties.

e. On the Print Server Properties dialog box, select the Ports tab and delete the local ports that 
point to:

Drive:\Program Files\Liquent\filenet\liquent.xml 

Drive:\Program Files\Liquent\filenet\ESPS.PS

f. Select the Drivers tab and remove (if it exists) the printer driver Liquent XML Printer.

6. Verify removal of native application macros.

If the following Microsoft Word macro is present on the Rendition Engine server, remove it:

• cdmacros.dot 

If any of the following Word Perfect macros are present on the Rendition Engine server, 
remove them:

• espsdtoc.wcm

• espsdtoc11.wcm

• espsdtoc12.wcm

• espsdtoc2k.wcm

• espsdtoc9.wcm

• espsrsym.wcm

• espsrsym11.wcm

• espsrsym12.wcm

• espsrsym2k.wcm

• espsrsym9.wcm

• generate.wcm

• removehf11.wcm

• removehf12.wcm

• removehf2k.wcm

7. Reboot the server.

8. Verify that the Vista software has been removed.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Verify that the FileNet P8 Rendition Engine 4.0.0 entry and the Vista entry have been 
removed. 
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d. If the Vista entry is still there, remove it.

i. Select the Vista entry and click Change/Remove. 

ii. Follow the screen prompts to remove the software. 

iii. At the final screen, click Finish, and reboot the server.

e. Verify that all files are removed from C:\Program Files\Liquent and C:\Program Files\Common 
Files\Liquent. 

NOTE If there are files in these directories, delete them manually.

f. Verify that the LIQUENT key has been removed.

i. Select Start > Run.

ii. Type Regedit.

iii. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE.

iv. Verify that the LIQUENT key has been removed. 

NOTE  If the LIQUENT key is there, delete it.

g. Reboot the server.

9. (Optional) Remove the existing RE database.

If you want to use the same database name as with your previous installation, you must first 
remove the existing RE database.

When you upgrade, you cannot use an existing Rendition Engine database or tablespace. You 
will need to identify a new database (SQL Server) or tablespace (Oracle) using the same 
name or a different name for use by the 4.5 version of Rendition Engine. For information, see 
“Create a new Rendition Engine database” on page 72.
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To remove Rendition Engine version 3.5 software from a Rendition Engine or Publishing Plug-in 
server

You must uninstall the existing Liquent RenderPerfect software, remove the local printer ports, 
and remove native application macros from all Rendition Engine servers before upgrading (re-
installing) the publishing components for 4.5.

NOTE  The publishing plug-in components are uninstalled as part of the CE 4.5 upgrade and do 
not need to be removed.

1. If the RE server has SQL Server or SQL Server Client software installed, to prevent it from 
loosing SQL Server and SQL Server Client files when running the RE uninstallation, apply patch 
P8RE-3.5.1-000.001 before continuing.

2. Back up your existing installation.

Rendition Engine does not require backup. In case you need to roll back to the previous 
version of the FileNet P8 Platform and Rendition Engine, you need only reinstall the previous 
version of the software.

NOTE  Some Rendition components such as publishing templates and publishing style 
templates are located on a Content Engine (CE) server and were backed up as part of the 
preparation for CE upgrade.

3. Stop the BusinessServiceServer Windows service prior to uninstalling the software.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Administrative Tools.

c. Double-click Services.

d. Double-click BusinessServiceServer.

e. Click the Stop button.  

4. Remove the Rendition Engine software.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Select FileNet P8 Rendition Engine 3.0.0a/3.5.1 and click Change/Remove.

d. Follow the screen prompts to remove the software. At the final screen, click Finish.

e. Close the Add/Remove Programs Window. 

5. Remove the printers.

a. Navigate to Start > Settings > Control Panel. Double-click Printers and Faxes.

b. If the Liquent XML Printer is listed in the Printers and Faxes window, delete it.

c. If the Liquent PDF Printer is listed in the Printers and Faxes window, delete it.

d. On the Printers and Faxes window, select File > Server Properties.
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e. On the Print Server Properties dialog box, select the Ports tab and delete the local ports that 
point to:

Drive:\Program Files\Liquent\filenet\liquent.xml 

Drive:\Program Files\Liquent\filenet\ESPS.PS

f. Select the Drivers tab and remove the printer driver Liquent XML Printer.

6. Verify removal of native application macros.

If the following Microsoft Word macro is present on the Rendition Engine server, remove it:

• cdmacros.dot 

If any of the following Word Perfect macros are present on the Rendition Engine server, 
remove them:

• espsdtoc.wcm

• espsdtoc11.wcm

• espsdtoc12.wcm

• espsdtoc2k.wcm

• espsdtoc9.wcm

• espsrsym.wcm

• espsrsym11.wcm

• espsrsym12.wcm

• espsrsym2k.wcm

• espsrsym9.wcm

• generate.wcm

• removehf11.wcm

• removehf12.wcm

• removehf2k.wcm

7. (If you uninstalled an RE version prior to 3.0.0a/3.5.1) Run the Vista cleanup tool.

If the version of RE you uninstalled in Step 4 above was prior to 3.0.0a/3.5.1, you must run the 
cleanup tool provided with the  IBM FileNet Rendition Engine installation package to prepare 
your environment for a new RE installation.

a. Launch the cleanup tool.

On your RE installation media (versions prior to 3.0.0a/3.5.1):

\Resources\Liquent\Unsupported Apps\Xtent2.0\VistaCleanUtility.exe

On your RE 4.0.0 installation media:

\Resources\Liquent\Unsupported Apps\Vista2.x\VistaClean.exe
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b. Click the Cleanup button.

c. Click OK to close the program when it has completed.

8. Reboot the server.

9. Verify that the Vista software has been removed.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Verify that the FileNet P8 Rendition Engine 3.0.0a/3.5.1 entry and the Vista entry have been 
removed. 

d. If the Vista entry is still there, remove it.

i. Select the Vista entry and click Change/Remove. 

ii. Follow the screen prompts to remove the software. 

iii. At the final screen, click Finish, and reboot the server.

e. Verify that all files are removed from C:\Program Files\Liquent and C:\Program Files\Common 
Files\Liquent. 

NOTE If there are files in these directories, delete them manually.

f. Verify that the LIQUENT key has been removed.

i. Select Start > Run.

ii. Type Regedit.

iii. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE.

iv. Verify that the LIQUENT key has been removed. 

NOTE  If the LIQUENT key is there, delete it.

g. Reboot the server.

10. (Optional) Remove the existing RE database.

The RE upgrade includes the creation of a new database for RE use. If you want to use the 
same database name as your previous installation, you must first remove the existing RE 
database.

CAUTION  (Oracle) If you choose to create new databases using new names, you must modify 
the entries in the Oracle-Repository.sql script with the new information. See “To create an Oracle 
database” on page 49.
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Task 2: Upgrade Rendition Engine
1. Verify that all requirements in “Plan the Upgrade” on page 67 and its sub tasks have been met.

Make sure you complete all required database tasks in “Database Administrator Tasks” on 
page 72. Of special interest is “Create a new Rendition Engine database” on page 72.

2. (Optional) Upgrade native applications.

If you plan to upgrade the native applications used by Rendition Engine, you must do this 
before you install Rendition Engine. See “Independent software vendor (ISV) applications” on 
page 70. 

a. Install or upgrade your native applications.

b. Configure your newly upgraded native applications. Perform “Install and configure authoring 
applications” on page 26.

3. Install the 4.5 version of Rendition Engine.

Complete the following tasks listed in “Install and configure Rendition Engine” on page 53 to install 
Rendition Engine. 

• Task 1 “Install Rendition Engine” on page 54.

• Task 2 “Configure Rendition Engine connections on Content Engine” on page 60. 

NOTE  Perform this if you have created a new database or tablespace with a new name 
and/or administrative user. See “Create a new Rendition Engine database” on page 72.

• Task 3 “Set the site preferences on the Application Engine to use path-based URLs” on page 62.

NOTE  This task is not required on an upgrade. However, you should verify that your 
settings are valid.

• Task 4 “Enable word processing macros for rendering” on page 63.

• Task 5 “Install Rendition Engine software updates” on page 65.

• Task 6 “(Optional) Verify installation” on page 66.
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Remove software

This topic includes:

• “Remove a Rendition Engine from a Liquent Vista domain” on page 82

• “Remove Rendition Engine software from a Rendition Engine” on page 83.
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Remove a Rendition Engine from a Liquent Vista 
domain
To uninstall an existing Rendition Engine 4.5.0, you must first remove the server from the Liquent 
Vista domain and then uninstall the software. 

1. Log on to the Rendition Engine server as FNRE_Admin.

2. Launch the Domain Manager application.

3. Select the Configuration tab in the left navigation pane. Then expand Domain and Repositories 
to view the server machines in the domain. 

4. Click the machine name to be removed from the Liquent Vista domain. 

5. Select Delete from the Edit menu.

6. Confirm the deletion and select Save from the File menu.
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Remove Rendition Engine software from a Rendition 
Engine
To complete the uninstallation, you must uninstall the Rendition Engine software, remove the local 
printer ports, and remove native application macros. 

1. Log on to the Rendition Engine server as FNRE_Admin.

2. Stop the BusinessServiceServer Windows service prior to uninstalling the software. 

a. Navigate to Start > Settings > Control Panel.

b. Double-click Administrative Tools.

c. Double-click Services.

d. Double-click BusinessServiceServer.

e. Click the Stop button. 

3. Remove the Rendition Engine software.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Select FileNet P8 Rendition Engine 4.5.0 and click Change/Remove.

d. Follow the screen prompts to remove the software. At the final screen, click Finish.

e. Close the Add/Remove Programs Window

4. Remove the printers.

a. Navigate to Start > Settings > Control Panel. Double-click Printers and Faxes.

b. If the Liquent PDF Creator is listed in the Printers and Faxes window, delete it.

c. If the Liquent PDF Printer is listed in the Printers and Faxes window, delete it

d. On the Printers window, select File > Server Properties.

e. On the Print Server Properties dialog box, select the Ports tab and, if present, delete the 
local port that points to:

RE_install_path\ESPS.PS

f. Select the Drivers tab and remove the printer driver Amyuni Document Converter 300, if 
present.

5. Verify removal of native application macros.

If the following Microsoft Word macro is present on the Rendition Engine server, remove it:

• cdmacros.dot 
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If any of the following Word Perfect macros are present on the Rendition Engine server, 
remove them:

• espsdtoc.wcm

• espsdtoc11.wcm

• espsdtoc12.wcm

• espsdtoc2k.wcm

• espsdtoc9.wcm

• espsrsym.wcm

• espsrsym11.wcm

• espsrsym12.wcm

• espsrsym2k.wcm

• espsrsym9.wcm

• generate.wcm

• removehf11.wcm

• removehf12.wcm

• removehf2k.wcm

6. Reboot the server.

7. Verify that the Liquent services software has been removed.

a. Navigate to Start > Settings > Control Panel.

b. Double-click Add/Remove Programs.

c. Verify that the FileNet P8 Rendition Engine 4.5.0 entry and the Liquent services entry have 
been removed. 

d. If the Liquent services entry is still there, remove it.

i. Select the Liquent services entry and click Change/Remove. 

ii. Follow the screen prompts to remove the software. 

iii. At the final screen, click Finish, and reboot the server.

e. Verify that all files are removed from RE_install_path and C:\Program Files\Common 
Files\Liquent. 

NOTE If there are files in these directories, delete them manually.

f. Verify that the LIQUENT key has been removed.

i. Select Start > Run.

ii. Type Regedit.
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iii. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE.

iv. Verify that the LIQUENT key has been removed. 

NOTE  If the LIQUENT key is there, delete it.

g. Reboot the server.
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Appendixes

The appendixes section contains the following major topics:

• “Installation and upgrade worksheet” on page 87.

• “FileNet P8 port numbers” on page 89.
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Installation and upgrade worksheet
The Installation and Upgrade Worksheet is a comprehensive spreadsheet that contains 
properties, parameters, and field names for installation, upgrade, and initial configuration of P8 
Platform components and add-on products. Administrators who are preparing the environment for 
installation or upgrade of IBM FileNet P8 Platform can use the worksheet during their preparation 
tasks to record the appropriate values and provide them to the administrator who will run the 
installation or upgrade.

You can access the worksheet through the following link:

Installation and Upgrade Worksheet

or on the IBM product documentation page. To download this and other IBM FileNet product 
documentation from the IBM web site, see “Access IBM FileNet documentation, compatibility matrices, 
and fix packs” on page 16.

Worksheet organization
Review the following considerations about the organization of the worksheet:

• The two highlighted columns, “Property or Parameter” and “ENTER YOUR VALUE HERE”, 
provide the simplest view of the requirement. The others add clarifying information and help 
you sort the rows usefully.

• For descriptions of the non-obvious properties and parameters in the worksheet, see the 
installation glossary in the Plan and Prepare Your Environment for IBM FileNet P8 document.

• The “Role” column uses the following acronyms for Administrator roles:

– TA: Information Technology Administrator 

– ASA: Application Server Administrator 

– DBA: Database Administrator

– SA: Security Administrator
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Optimizing the worksheet
The worksheet provides all possible properties, parameters, and field names for installation, 
upgrade, and initial configuration of P8 Platform components as well as add-on products. Only a 
small subset of these rows will apply to a particular installation or administrator role as part of that 
installation. For example, a database administrator who is only working with DB2 can receive a 
smaller spreadsheet with rows that have been sorted for the Admin Role of DBA, and the 
independent software vendor of DB2.

You may receive a simplified or more focused variation of this spreadsheet that is appropriate to 
your environment or role. Work with your install team and your IBM services representative to 
make the best use of this tool.

HINT  With the Data > Filter > AutoFilter command enabled, as it is by default in the shipping 
worksheet file (p8_worksheet.xls), perform the following actions to quickly see only the installation 
properties you must specify for a given installer or configuration program:

• Click the AutoFilter drop-down arrow in the "Installation or Configuration Program" column 
header and select the program you are interested in (for example, RE installer).

• Click the AutoFilter drop-down arrow in the "Setup Type" column header, select Custom, and 
specify: Setup Type contains "Installation." 

• Click the AutoFilter drop-down arrow in all other column headers and select (All).
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FileNet P8 port numbers
The table below lists the default port numbers used by Rendition Engine. 

Rendition Engine Ports

Liquent notify port 2868

Liquent event port 2869

Liquent admin port 2870

Liquent file transfer port 2871

Liquent job queue port 2872

Microsoft SQL Server 1433

Oracle 1521
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Notices
Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in other countries.
Consult your local IBM representative for information on the products and services currently available in
your area. Any reference to an IBM product, program, or service is not intended to state or imply that
only that IBM product, program, or service may be used. Any functionally equivalent product, program,
or service that does not infringe any IBM intellectual property right may be used instead. However, it is
the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or
service.

IBM may have patents or pending patent applications covering subject matter described in this
document. The furnishing of this document does not grant you any license to these patents. You can send
license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property
Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome, Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES CORPORATION
PROVIDES THIS PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some
states do not allow disclaimer of express or implied warranties in certain transactions, therefore, this
statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically
made to the information herein; these changes will be incorporated in new editions of the publication.
IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for convenience only and do not in
any manner serve as an endorsement of those Web sites. The materials at those Web sites are not part of
the materials for this IBM product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes appropriate without
incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose of enabling: (i) the
exchange of information between independently created programs and other programs (including this
one) and (ii) the mutual use of the information which has been exchanged, should contact:
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BM Corporation
46A/G4
55 Bailey Avenue
an Jose, CA 95141-1003
.S.A.

uch information may be available, subject to appropriate terms and conditions, including in some cases,
ayment of a fee.

he licensed program described in this document and all licensed material available for it are provided
y IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or
ny equivalent agreement between us.

ny performance data contained herein was determined in a controlled environment. Therefore, the
esults obtained in other operating environments may vary significantly. Some measurements may have
een made on development-level systems and there is no guarantee that these measurements will be the
ame on generally available systems. Furthermore, some measurements may have been estimated through
xtrapolation. Actual results may vary. Users of this document should verify the applicable data for their
pecific environment.

nformation concerning non-IBM products was obtained from the suppliers of those products, their
ublished announcements or other publicly available sources. IBM has not tested those products and
annot confirm the accuracy of performance, compatibility or any other claims related to non-IBM
roducts. Questions on the capabilities of non-IBM products should be addressed to the suppliers of

hose products.

ll statements regarding IBM’s future direction or intent are subject to change or withdrawal without
otice, and represent goals and objectives only.

his information contains examples of data and reports used in daily business operations. To illustrate
hem as completely as possible, the examples include the names of individuals, companies, brands, and
roducts. All of these names are fictitious and any similarity to the names and addresses used by an
ctual business enterprise is entirely coincidental.

OPYRIGHT LICENSE:

his information contains sample application programs in source language, which illustrate programming
echniques on various operating platforms. You may copy, modify, and distribute these sample programs

any form without payment to IBM, for the purposes of developing, using, marketing or distributing
pplication programs conforming to the application programming interface for the operating platform for
hich the sample programs are written. These examples have not been thoroughly tested under all

onditions. IBM, therefore, cannot guarantee or imply reliability, serviceability, or function of these
rograms.
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IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business
Machines Corporation in the United States, other countries, or both. If these and other IBM trademarked
terms are marked on their first occurrence in this information with a trademark symbol (® or ™), these
symbols indicate U.S. registered or common law trademarks owned by IBM at the time this information
was published. Such trademarks may also be registered or common law trademarks in other countries. A
current list of IBM trademarks is available on the Web at ″Copyright and trademark information″ at
www.ibm.com/legal/copytrade.shtml.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, other
countries, or both.

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other countries, or
both.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other company, product, and service names may be trademarks or service marks of others.
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