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ibm.com and related resources

Product support and documentation are available from ibm.com.

Support and assistance

Product support is available on the Web. Click Support from the product Web site
at:

FileNet Content Manager Support
http://www.ibm.com/software/data/content-management/filenet-content-
manager/support.html

Information center

You can view the product documentation in an Eclipse-based information center
that you can install when you install the product. By default, the information
center runs in a Web server mode that other Web browsers can access. You can also
run it locally on your workstation. See the information center at
http://logos.svl.ibm.com:8092/help/index.jsp.

PDF publications

You can view the PDF files online using the Adobe Acrobat Reader for your
operating system. If you do not have the Acrobat Reader installed, you can
download it from the Adobe Web site at http://www.adobe.com.

See the following PDF publications Web sites:

Product Web site

Product Documentation for FileNet
P8 Platform

http://www.ibm.com/support/docview.wss?rs=3278
&uid=swg27010422

How to send your comments
Your feedback is important in helping to provide the most accurate and highest
quality information.

Send your comments by using the online reader comment form at
https://www14.software.ibm.com/webapp/iwm/web/signup.do?lang=en_US
&source=swg-rcf.

Consumability survey

You are invited to tell IBM how to improve the consumability of software
products. If you want to help IBM make IBM® FileNet® P8 easier to use, take the
Consumability Survey at http://www.ibm.com/software/data/info/
consumability-survey/.
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Contacting IBM
To contact IBM customer service in the United States or Canada, call
1-800-IBM-SERV (1-800-426-7378).

To learn about available service options, call one of the following numbers:
v In the United States: 1-888-426-4343
v In Canada: 1-800-465-9600

For more information about how to contact IBM, see the Contact IBM Web site at
http://www.ibm.com/contact/us/.
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Planning and preparing for installation

This topic explains how to plan for an installation of IBM FileNet Rendition Engine
software.

Rendition Engine is a software server responsible for transforming documents into
another format, such as PDF or HTML. The Rendition Engine software is based on
the Liquent Enterprise Services (LES 3.1.1) product. To install and configure the
Liquent components on the Rendition Engine server and Content Engine server
follow the instructions in this document.

For more information about Liquent, see the IBM FileNet P8 Help topic System
Administration → Enterprise-wide Administration → Publishing → Publishing
Overview → About Rendition Engine.

For DITA Open Toolkit Rendition Engine installation and configuration
information, see the IBM FileNet P8 Help topic System Administration →
Enterprise-wide Administration → Publishing.

Planning the installation
This section lists details that will help you prepare your environment for the
installation of IBM FileNet Rendition Engine. Review this information thoroughly
before you start to set up a Rendition Engine or required third-party software.

Before you begin to install IBM FileNet Rendition Engine, perform the following
planning activities:
v Retrieve updates to IBM FileNet P8 documentation and software, see “ibm.com

and related resources” on page v.
v Read “Installing and configuring Rendition Engine” on page 27 to become

familiar with the tasks you will perform when you set up your IBM FileNet
Rendition Engine software.

v See “Using the installation and upgrade worksheet” on page 3 for more
information on an available Worksheet to record information that will be needed
during installation.

Important: Follow the planning, installing, and configuring tasks in the order
presented in these topics. If you do otherwise, or you install FileNet P8
components on machines containing components for existing FileNet P8 systems,
you might encounter unforeseen problems or be required to perform additional
installation steps. See the IBM FileNet P8 Troubleshooting Guide. To download this
document from the IBM support page, see “ibm.com and related resources” on
page v.

Planning your deployment

Cluster deployment
Cluster deployment can be used for load balancing or to provide high availability.
Refer to the IBM FileNet P8 High Availability Technical Notice for details on how to
set up your IBM FileNet Rendition Engine system by using clusters, farms, and
other high availability software and hardware.

© Copyright IBM Corp. 2001, 2009 1



Definition of installation roles
The tasks in this guide and the rows in the Installation and Upgrade Worksheet are
organized by administrative roles. Your organization might have different roles,
and some of the responsibilities of listed roles will vary from those assigned by
default in this documentation.

Installation administrator
v Runs IBM FileNet P8 installers during initial setup.
v Runs the Configuration Manager tool during initial setup, followed by launching

IBM FileNet Enterprise Manager.
v Runs IBM FileNet P8 Upgrade programs during upgrades.
v Abbreviated as IA. Responsible for coordinating the information described in

this worksheet. The information itself will require the input from the other roles.

The role of IA is usually filled by an IBM FileNet Certified Professional (FCP).

Information technology administrator
v Responsible for the networking and operating systems settings required by IBM

FileNet P8.
v Responsible for performing certain security configurations.
v Abbreviated as ITA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of ITA in the Role column.

Security administrator
v Responsible for configuring the directory servers required by IBM FileNet P8

components, including Content Engine and Application Engine.
v Creates and maintains directory server user and group accounts.
v Abbreviated as SA. Responsible for providing the information in the rows in the

Installation and Upgrade Worksheet with a value of SA in the Role column.

Database administrator
v Creates, configures, maintains database installations and database/tablespaces.
v Responsible for creating database accounts needed by IBM FileNet P8.
v For purposes of this documentation, the database administrator is expected to

have responsibilities regarding the JDBC data sources.
v Abbreviated as DBA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of DBA in the Role column.

Application server administrator
v Responsible for providing the application servers required by IBM FileNet P8.
v Responsible for application server administrative accounts.
v Abbreviated as ASA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of ASA in the Role column.

IBM FileNet P8 administrator
v This role designation actually refers to the administrator or administrators who

perform regular maintenance of Content Engine, Process Engine Application
Engine, / Workplace™ or Workplace XT™.

v The administrator who logs on to Enterprise Manager using the gcd_admin
account or an object_store_admin account is considered an IBM FileNet P8
administrator.
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v Abbreviated as P8A. Responsible for providing the information in the rows of
the Installation and Upgrade Worksheet with a value of P8A in the Role column.

Email Administrator
v Creates an email account that will be used to configure the Notification Tab of

the Process Task Manager so that Process Engine can send email notifications to
end users. (Required only if you use this feature.)

v Abbreviated as EA.

Using the installation and upgrade worksheet
The Installation and Upgrade Worksheet is a Microsoft Excel spreadsheet
(p8_worksheet.xls) that describes the properties and parameters required to
completeIBM FileNet P8 installation, upgrade, and configuration programs, and
provides a way to record the values you assign to these properties and parameters.

Administrators who are preparing the environment for installation or upgrade of
IBM FileNet P8 components should use the worksheet during their preparation
tasks to record the appropriate values and provide them to the Installation
Administrator who will run the installation or upgrade programs.

Some of the features of the Installation and Upgrade Worksheet are:
v ″Instructions″: describes the worksheet and includes a button that runs the

Customize Worksheet macro.
v The two highlighted columns, ″Property or Parameter″ and ″ENTER YOUR

VALUE HERE″, provide the simplest view of the requirement. The others add
identifying information and help you sort and filter the rows usefully.

v The Role column assigns each row to an administrator and uses the following
acronyms:
– ITA: Information Technology Administrator
– ASA: Application Server Administrator
– DBA: Database Administrator
– SA: Security Administrator
– P8A: IBM® FileNet® P8 Administrator

v Property definitions are contained in the column titled ″Description″.
v Some rows, though not all, contain a hyperlink in the PPG Links column. Click

this hyperlink to run a query against the IBM Information Center, which opens
with the Search Results pane showing the topics that contain the words in the
query phrase. Browse the search results until you have enough information to be
able to enter a value in the Worksheet row.

Running the Customize Worksheet macro
The Customize Worksheet macro lets you extract only those rows that describe
your environment.

To run the Customize Worksheet macro:
1. Open the Installation and Upgrade Worksheet (p8_worksheet.xls) and click the

Instructions worksheet (also called a tab).
2. Scroll down until you see the button representing the Customize Worksheet

macro. Click the button.
3. Select the components and options that describe the environment you are

preparing for IBM FileNet P8.
v Installation or Upgrade
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v FileNet P8 Components
v Application Server type
v Operating system
v Database type
v Directory Server type
v Number of object stores (adds new sets of rows for creating additional data

sources)
v Name of customized sheet

4. Click OK. The macro copies the rows that fulfill your selection criteria into a
new worksheet with the name you entered. Enter the values for your
environment into this new worksheet.

5. Click the name of the new worksheet at the bottom of the Excel window. Add
your preparation values into this new worksheet.

6. Notice that the new worksheet has buttons at the top titled Show Installer
View and Show Full View, depending on its state. The Show Installer View
displays only those columns that you need while running installation or
configuration programs.

Autofiltering and sorting the Worksheet
There are several ways to organize the Worksheet to make finding properties and
entering values easier.

AutoFiltering is a quick way to display only those rows that meet a certain criteria.
To use AutoFilter:
1. Make sure AutoFiltering is enabled. (Select the entire row with the column

headers, then click Data > Filter > Autofilter.) AutoFilter arrows will appear to
the right of the column labels.

2. Click the AutoFilter arrow in the ″Installation or Configuration Program″
column header and select the program you are interested in (for example, PE
installer).

3. Click the AutoFilter arrow in the ″Setup Type″ column header, select Custom,
and specify Setup Type contains Installation.

4. For a custom AutoFilter, click the AutoFilter in any column header, select
Custom, and specify Setup Type contains ″Installation″.

5. To turn off AutoFiltering in a column, click the column’s AutoFilter arrow and
select (All).

To reorder rows alphabetically, do a Sort:
1. Click anywhere in a column, for example, Column A ″Role″.

The only possible values in the Role column are ASA, SA, DBA, ITA, and P8A.
Sorting on Role therefore groups the rows by this attribute, in alphabetical
order. Several other columns also have a limited number of possible values
which means they can be usefully sorted.

2. Click the Sort Ascending icon in Excel’s toolbar, or use the Data > Sort menu
command. The rows sort on Role.
Sorting the Worksheet reassigns row numbers. Therefore, if you refer to rows
by number, you should be aware that these numbers will likely change if you
change the sort order.
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Performing required preparation tasks

Important: In addition to the preparation tasks listed below, follow the plan and
prepare instructions in the Plan and Prepare Your Environment for IBM FileNet P8
document for the components you are installing.

To prepare your environment for a Rendition Engine installation, perform the
required preparation tasks for the components that you plan to install.

Installation administrator tasks

The items below are the required tasks for the installation administrator.
v Complete the installation worksheet for your environment

If you are using the Installation and Upgrade Worksheet for your environment,
complete the worksheet with the relevant information as described in “Using the
installation and upgrade worksheet” on page 3.

v Verify the contents of the installation package
The following is a brief description of the contents of the IBM FileNet Rendition
Engine installation package:

Installer (folder)
Contains the P8RE451.exe file used to install Rendition Engine.

Resources (folder)
Contains the Oracle-repository.sql script and the
IBMFileNetRenditionEngineLicense.xml file used during the installation.

Readme.htm
Contains information about the Rendition Engine documentation.

Planning for non-English environment installation
By default IBM FileNet Rendition Engine supports English and Japanese
Windows® operating systems.

Authoring in other languages

In order to publish documents that are authored in other languages, you must add
support for the language on the Rendition Engine server by using the Regional
and Language Options control panel application. This adds language fonts and
support to allow Rendition Engine to correctly render PDF and HTML documents.

See Microsoft® Windows operating system help for further information on adding
additional language support.

Information technology administrator tasks

The Information Technology administrator must prepare the network and
operating systems, and carry out certain security configurations to prepare your
environment.

Rendition Engine server
v Ensure minimum required disk space and temporary space for installation See

the IBM FileNet P8 Hardware and Software Requirements document.
v Microsoft Office locale
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Before you install Microsoft Office, if you set the Regional Option to
non-US/English for your operating system, bookmark extraction will not work
properly when rendering a document. Any non-US/English Regional Option
settings should be made after Microsoft Office has been installed.

v Copy installation software to the Rendition Engine server. Access the IBM
FileNet Rendition Engine installation package and copy the content to a location
on the Rendition Engine server. For example, create the following directory, and
copy the installation files to it: C:\RE_installation_software.

Operating system considerations
Install Microsoft .NET Framework version 2.0 for the Windows 2003
64-bit operating system

If you are installing IBM FileNet Rendition Engine on a 64-bit Windows machine
you must install Microsoft .NET Framework version 2.0 for 64-bit operating
systems before you install Rendition Engine. See your Windows documentation for
more information.

Network considerations
v Verify the TCP/IP configuration settings on the Rendition Engine server.
v Ensure communication. Make sure the Rendition Engine server can communicate

with the database server and the Content Engine server, and that the Content
Engine server can communicate with the Rendition Engine server.

v Ensure availability of required port numbers. Several port numbers are required
by the various IBM FileNet P8 components. For a list, see “FileNet P8 port
numbers,” on page 49.

Collocation considerations

For performance reasons, unless you plan to install more than one Rendition
Engine in your environment, you should install Rendition Engine and Content
Engine on separate servers. This configuration will spread the performance load
between the publishing servers.

Hard drive considerations

You must install Rendition Engine on a server that has an NTFS drive partition to
be able to complete the task “Installing Rendition Engine” on page 27.

Liquent Vista Domain considerations

When you first run the Rendition Engine installation program, you create a new
Liquent Vista domain--an administrative entity that is used to manage Rendition
Engine services. For each subsequent execution of the Rendition Engine installation
program on additional server machines, you can join an existing Liquent Vista
domain or create another Liquent Vista domain.

Adding inbound rules to the Windows firewall (Windows):

On Windows 2003 and 2008 Server, you must configure inbound rules in the
Windows firewall to allow the following Rendition Engine ports access.
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Rendition Engine ports

Port description

Liquent notify port 2868

Liquent event port 2869

Liquent admin port 2870

Liquent file transfer port 2871

Liquent job queue port 2872

Microsoft SQL Server 1433

Oracle 1521

Uninstalling Internet Explorer enhanced security configuration (Windows 2003
Server):

On Windows 2003 Server, you must uninstall the Internet Explorer Enhanced
Security Configuration to be able to use the Jobs tab in Domain Manager to
monitor jobs.
1. Click Start → Settings → Control Panel.
2. Double-click Add and Remove Programs.
3. Click Add/Remove Windows Components.
4. Uncheck Internet Explorer Enhanced Security Configurationand click Next.

Follow the screen prompts to remove the software.
5. At the final screen, click Finish.
6. Close the Add and Remove Programs window.

Uninstalling Internet Explorer Enhanced Security Configuration (Windows 2008
Server):

On Windows 2008 Server, you must uninstall the Internet Explorer Enhanced
Security Configuration to be able to use the Jobs tab in Domain Manager to
monitor jobs.
1. Click Start → Admin tools → Service Manager → Configure IE ESC link.
2. Verify that the setting for Administrators and for Users is turned Off.
3. Click OK.
4. Close the Service Manager window.

Reducing data execution prevention:

Before you install IBM FileNet Rendition Engine on a server running Windows
2003 SP1 or 2008, you must log on to the server with the default administrator
account and set the Data Execution Prevention performance option to essential
Windows programs and services only.

To set the Data Execution Prevention performance option to Essential Windows
programs and services only:
1. Click Start → Control Panel → System

2. Click the Advanced System Settings link and select the Advanced tab.
3. In the Performance group, click Settings.
4. Select the Data Execution Prevention tab.
5. Click Turn on DEP for essential Windows programs and services only.
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6. Click OK.

Configuring the server’s operating system to optimize programs:

To configure the server’s operating system to optimize programs:
1. Click Start → Control Panel → System

2. Click the Advanced System Settings link and select the Advanced tab.
3. In the Performance group, click Settings.
4. Select the Advanced tab.
5. In the Processor Scheduling group, select Programs.
6. (Windows 2003) In the Memory Usage group, select Programs.
7. (Windows 2008) In the Adjust for best performance of group, select Programs.
8. Click OK.

Turning off user access control (Windows 2008):

On Windows 2008 Server, you must turn off User Access Control.
1. Click Start → Administrative Tools → System Configuration

2. On the Tools page, scroll down and select Disable UAC/Disable User Access
Control (requires reboot).

3. Click Launch, and then close the command prompt window.
4. Click OK to reboot the server.

Installing and configuring authoring applications

Before you install Microsoft Office:
v Copy the contents of the Microsoft Office CD-ROM to a local drive and install

Microsoft Office from this location.
v If you set the Regional Option to non-US/English for your operating system,

bookmark extraction will not work properly when rendering a document.
Configure non-US/English Regional Option settings after you have installed
Microsoft Office.

Before you install the IBM FileNet Rendition Engine software you should install all
supported authoring applications that will be used to create and render publication
documents. Install and configure these applications on each Rendition Engine
server you plan to use. With the applications installed, the Rendition Engine
installation wizard can copy Rendition Engine specific Microsoft Word and Corel
WordPerfect macros to the appropriate locations.

Important: Use the FNRE_Admin account created in “Users required for Rendition
Engine installation” on page 19 when installing the authoring applications.

Perform these steps on each Rendition Engine server.
1. Install Microsoft components.
2. Install Corel WordPerfect, Adobe FrameMaker, and any other rendering

components. For a complete list of supported applications, see IBM FileNet P8
Hardware and Software Requirements.

3. Confirm that the authoring application launches and runs without user
intervention.
To render documents accurately, Rendition Engine requires each authoring
application to run cleanly, without problems, and without dialogs or prompts.
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After you install each authoring application, start the application to confirm
that it runs properly without dialogs opening, including the registration
dialogs.
a. Launch Microsoft Office components. When the Microsoft Office application

has launched and registered itself, press ALT+F11 to load and register the
Microsoft Visual Basic for Applications (VBA) editor.

b. Launch Corel WordPerfect, Adobe FrameMaker, and any other rendering
components you have installed.

Enabling TIF to PDF conversion:

By default, TIF and TIFF files are configured to use different rendering plugins.
The MS Doc Imaging plugin (for Microsoft Office Document Imaging) is specified
for TIF, and the Imaging plugin (included with IBM FileNet Rendition Engine) is
specified for TIFF.

If you plan to publish TIF images to PDF you must do either of the following:
v Install the Microsoft Office Document Imaging office tool. This is not installed by

default for Office 2007.
v Change the TIF content type plugin specified in the Domain Manager to use the

one specified by for TIFF.

Configuring Microsoft Word 2007:

Before you install IBM FileNet Rendition Engine, ensure that the following folders
contain no files:
v \MS_Office_home\Microsoft Office\Office Version\Startup

v \MS_Office_home\Microsoft Office\Office Version\XLStart

v \Documents and Settings\local adminstrator\Application
Data\Microsoft\Word\Startup

To configure Microsoft Word 2007:
1. Configure Microsoft Office hyperlinks:

Perform these changes to ensure that hyperlinks are treated correctly on
publishing.
a. In Microsoft Word, click the Microsoft Office button.
b. Click Word Options.
c. Click Advanced.
d. Scroll down to General tab, and click Web Options.
e. Select the Files tab.
f. Check the Use long file names whenever possible item.

Perform this on the IBM FileNet Rendition Engine server and on each client
machine where Microsoft Office applications reside and from which source
documents are added and rendering is initiated.
This setting is used to ensure that the Rendition Engine properly converts
Microsoft Word and Excel documents containing hyperlinks, external links,
image links, and other links. By default, Microsoft Office 2003 and Microsoft
Office XP have it set.

g. Clear the Update links on save item.
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This ensures that hyperlinks are not updated but kept relative. If this is not
done, a document with an HTML link would point to the location where
the source document was copied during publishing.

Important: This change will take effect on all installed Microsoft Office
applications.

2. Configure Microsoft Word publishing requirements:
a. In Microsoft Word, click the Microsoft Office button, and then click Word

Options.
b. Click Popular.
c. Under Top options for working with Word, set ScreenTip style to Don’t

show ScreenTips.
d. Select the Display tab and clear the following Print options:
v Print background colors and images

v Print hidden text

v Update fields before printing

v Update linked data before printing

e. Select the Proofing tab and clear the following When correcting spelling
and grammar in Word options:
v Check spelling as you type

v Use contextual spelling

v Mark grammar as you type

v Check grammar with spelling

f. Select the Save tab and clear the following Save documents options:
v Set Save files in this format to Word 97-2003 Document (*.doc)

v Uncheck Save AutoRecover info every.
g. Select the Advanced tab and clear the following options:

Option category Clear the following

Editing v Typing replaces selected text

v When selecting, automatically select
entire word

v Allow text to be dragged and dropped

v Use CTRL + Click to follow hyperlink

v Automatically create drawing canvas
when inserting AutoShapes

v Use smart paragraph selection

v Use smart cursoring

v Keep track of formatting

Cut, copy and paste v Show Paste Options buttons

v Use smart cut and paste

Show document content v Show background colors and images in
Print Layout view

v Show text animation

v Show Smart tags

v Show field codes instead of their values

Display v Show all windows in the taskbar
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Option category Clear the following

Print v Print in background

v Print XML tags

v Print field codes instead of their values

v Scale content for A4 or 8.5 x 11″ paper
sizes

Save v Allow background saves

Preserve fidelity when sharing this
document

v Embed Smart Tags

General v Provide feedback with animation

v Confirm file format conversion on open

v Update automatic links at open

h. Select the Trust Center tab.
1) Under Microsoft Office Word Trust Center, click Trust Center Settings.
2) Click Privacy Options, and then uncheck Sign up for the Customer

Experience Improvement Program.

Configuring Microsoft Excel 2007:

To configure Microsoft Excel 2007:
1. Configure Microsoft Office hyperlinks:

Perform these changes to ensure that hyperlinks are treated correctly on
publishing.
a. In Microsoft Excel, click the Microsoft Office button.
b. Click Excel Options.
c. Click Advanced.
d. Scroll down to General, and click Web Options.
e. Select the Files tab.
f. Check the Use long file names whenever possible item.

Perform this on the IBM FileNet Rendition Engine server and on each client
machine where Microsoft Office applications reside and from which source
documents are added and rendering is initiated.
This setting is used to ensure that the Rendition Engine properly converts
Microsoft Word and Excel documents containing hyperlinks, external links,
image links, and other links. By default, Microsoft Office 2003 and Microsoft
Office XP have it set.

g. Clear the Update links on save item.
This ensures that hyperlinks are not updated but kept relative. If this is not
done, a document with an HTML link would point to the location where
the source document was copied during publishing.

Important: This change will take effect on all installed Microsoft Office
applications.

2. Configure Microsoft Excel publishing requirements:
a. In Microsoft Excel, click the Microsoft Office button, and then click Excel

Options.
b. Select the Formula tab and clear the following options:
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v Error Checking
– Enable background error checking

c. Select the Save tab and perform the following:
v Save workbooks

– Set Save files in this format to Excel 97-2003 Workbook (*.xls)

– Uncheck Save AutoRecover info every

d. Select the Advanced tab and clear the following options:

Option category Clear the following

Cut, copy and paste Show Paste Options buttons

Show Insert Options buttons

Display Show all windows in the Taskbar

Show function ScreenTips

General Provide feedback with animation

Ask to update automatic links

Scale content for A4 or 8.5 x 11″ paper
sizes

e. Select the Trust Center tab.
1) Under Microsoft Office Excel Trust Center, click Trust Center Settings.
2) Click Privacy Options, and then uncheck Sign up for the Customer

Experience Improvement Program.

Configuring Microsoft PowerPoint 2007:

To configure Microsoft PowerPoint 2007:
1. Configure Microsoft Office hyperlinks:

Perform these changes to ensure that hyperlinks are treated correctly on
publishing.
a. In Microsoft PowerPoint, click the Microsoft Office button.
b. Click PowerPoint Options.
c. Click Advanced.
d. Scroll down to General, and click Web Options.
e. Select the Files tab.
f. Check the Use long file names whenever possible item.

Perform this on the IBM FileNet Rendition Engine server and on each client
machine where Microsoft Office applications reside and from which source
documents are added and rendering is initiated.
This setting is used to ensure that the Rendition Engine properly converts
Microsoft Word and Excel documents containing hyperlinks, external links,
image links, and other links. By default, Microsoft Office 2003 and Microsoft
Office XP have it set.

g. Clear the Update links on save item.
This ensures that hyperlinks are not updated but kept relative. If this is not
done, a document with an HTML link would point to the location where
the source document was copied during publishing.

Important: This change will take effect on all installed Microsoft Office
applications.
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2. Configure Microsoft PowerPoint publishing requirements:
a. In Microsoft PowerPoint, click the Microsoft Office button, and then click

PowerPoint Options.
b. Select the Proofing tab and clear the following options:
v When correcting spelling and grammar in PowerPoint

– Check spelling as you type

– Use contextual spelling

c. Select the Save tab and perform the following:
v Save presentations

– Set Save files in this format to PowerPoint Presentation 97-2003.
– Uncheck Save AutoRecover info every.

d. Select the Advanced tab and clear the following options:

Option category Clear the following

Editing When selecting, automatically select
entire word

Allow text to be dragged and dropped

Cut, copy and paste Use smart cut and paste

Show Paste Options buttons

Display Show all windows in the Taskbar

Slide Show Show menu on right mouse click

Show popup toolbar

Prompt to keep ink annotations when
exiting

End with black slide

Print Print in background

General Provide feedback with sound

e. Select the Trust Center tab and perform the following:
1) Under Microsoft Office PowerPoint Trust Center, click Trust Center

Settings.
2) Click Privacy Options, and then uncheck Sign up for the Customer

Experience Improvement Program.

Configuring earlier versions of Microsoft Word:

Before you install IBM FileNet Rendition Engine, ensure that the following folders
contain no files:
v MS_Office_home\Microsoft Office\Office Version\Startup

v MS_Office_home\Microsoft Office\Office Version\XLStart

To configure earlier versions of Microsoft Word:
1. Configure Microsoft Office hyperlinks:

Perform these changes to ensure that hyperlinks are treated correctly on
publishing.
a. In Microsoft Word, navigate to Tools → Options.
b. On the General tab, click Web Options.
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c. Select the Files tab.
d. Check the Use long file names whenever possible item.

Perform this on the IBM FileNet Rendition Engine server and on each client
machine where Microsoft Office applications reside and from which source
documents are added and rendering is initiated.
This setting is used to ensure that the Rendition Engine properly converts
Microsoft Word and Excel documents containing hyperlinks, external links,
image links, and other links. By default Microsoft Office 2003 and Microsoft
Office XP have it set.

e. Clear the Update links on save item.
This ensures that hyperlinks are not updated but kept relative. If this is not
done, a document with an HTML link would point to the location where
the source document was copied during publishing.

Important: This change will take effect on all installed Microsoft Office
applications.

2. Configure Microsoft Word publishing requirements:
a. In Microsoft Word, navigate to Tools → Options.
b. Select the View tab and clear the following Show options:
v Startup Task Pane

v Status Bar

v Screen Tips

v Smart Tags

v Animated Text

v Windows in Taskbar

v Field Codes

c. Select the View tab and clear the following Formatting Marks options:
v Hidden Text

v All

d. Select the View tab and in the Print and Web Layout group, clear the
Background Colors and Images (2003) option.

e. Select the General tab and clear the following options:
v Provide feedback with animation

v Confirm conversion at Open

v Update automatic links at Open

v Mail as attachment

v Automatically create drawing canvas when inserting AutoShapes

v Allow starting in reading layout (2003)
f. Select the Edit tab and clear the following Editing options:
v Typing replaces selection

v Drag-and-drop text editing

v Use smart cursoring (2003)

v Use smart paragraph selection

v Use CTRL + Click to follow hyperlink

v When selecting, automatically select entire word

v Keep track of formatting

v Show paste Options buttons
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g. Select the Edit tab and in the Cut and paste options group, clear the
following Smart cut and paste option.

h. Select the Print tab and clear the following Printing options:
v Update fields

v Allow A4/Letter paper resizing

v Background printing

i. Select the Print tab and clear the following Include With Document options:
v Field Codes

v Hidden Text

v XML Tags (2003)

v Background Colors and Images (2003)

j. Select the Save tab and clear the following options:
v Allow fast saves

v Allow background saves

v Save AutoRecover info every

v Embed smart tags

k. Select the Spelling & Grammar tab and clear the following options:
v Check spelling as you type

v Always suggest corrections

v Check grammar as you type

v Check grammar with spelling

l. Select the Track Changes tab and perform the following:
v Set Use Balloons (Print and Web Layout) to Never (2003)
v Clear Use Balloons in Print and Web Layout (XP)

Configuring earlier versions of Microsoft Excel:

To configure earlier versions of Microsoft Excel:
1. Configure Microsoft Office hyperlinks:

Perform these changes to ensure that hyperlinks are treated correctly on
publishing.
a. In Microsoft Excel, navigate to Tools → Options.
b. On the General tab click Web Options.
c. Select the Files tab.
d. Check the Use long file names whenever possible item.

Perform this on the IBM FileNet Rendition Engine server and on each client
machine where Microsoft Office applications reside and from which source
documents are added and rendering is initiated.
This setting is used to ensure that theRendition Engine properly converts
Microsoft Word and Excel documents containing hyperlinks, external links,
image links, and other links. By default, Microsoft Office 2003 and Microsoft
Office XP have it set.

e. Clear the Update links on save item.
This ensures that hyperlinks are not updated but kept relative. If this is not
done, a document with an HTML link would point to the location where
the source document was copied during publishing.
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Important: This change will take effect on all installed Microsoft Office
applications.

2. Configure Microsoft Excel publishing requirements:
a. In Microsoft Excel, navigate to Tools → Options .
b. Select the View tab and clear the following options:
v Startup Task Pane

v Status Bar

v Windows in Taskbar

c. Select the General tab and clear the Function tooltips option.
d. Select the Edit tab and clear the following:
v Show Paste Options buttons

v Show Insert Options buttons

v Ask to update automatic links

v Provide feedback with Animation

e. Select the International tab and clear the Allow A4/Letter paper resizing
option.

f. Select the Save tab and clear the Save AutoRecover info every option.
g. Select the Error Checking tab and clear the following:
v Enable background error checking

v List Data Validation (2003)

Configuring earlier versions of Microsoft PowerPoint:

To configure earlier versions of Microsoft PowerPoint:
1. Configure Microsoft Office hyperlinks:

Perform these changes to ensure that hyperlinks are treated correctly on
publishing.
a. In Microsoft PowerPoint, navigate to Tools → Options.
b. On the General tab click Web Options.
c. Select the Files tab.
d. Check the Use long file names whenever possible item.

Perform this on the IBM FileNet Rendition Engine server and on each client
machine where Microsoft Office applications reside and from which source
documents are added and rendering is initiated.
This setting is used to ensure that theRendition Engine properly converts
Microsoft Word and Excel documents containing hyperlinks, external links,
image links, and other links. By default, Microsoft Office 2003 and Microsoft
Office XP have it set.

e. Clear the Update links on save item.
This ensures that hyperlinks are not updated but kept relative. If this is not
done, a document with an HTML link would point to the location where
the source document was copied during publishing.

Important: This change will take effect on all installed Microsoft Office
applications.

2. Configure Microsoft PowerPoint publishing requirements:
a. In Microsoft PowerPoint, navigate to Tools → Options.
b. Select the View tab and clear the following options:
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v Startup Task Pane

v Slide Layout task pane when inserting new slides

v Status Bar

v Windows in Taskbar

v Prompt to keep ink annotations when exiting (2003)
v Popup menu on right mouse click (2000)
v Show menu on right mouse click (2003)
v Show popup menu button (2000)
v Show popup toolbar (2003)
v End with blank slide

c. Select the General tab and clear the Provide feedback with sound to screen
elements option.

d. Select the Edit tab and clear the following:
v Show Paste Options buttons

v Use smart cut and paste

v When selecting, automatically select entire word

v Drag-and-drop text editing

e. Select the Print tab and clear the Background printing option.
f. Select the Save tab and clear the following:
v Allow fast saves

v Save AutoRecover info every

g. Select the Spelling and Style tab and clear the following:
v Check spelling as you type

v Always suggest corrections

Configuring Microsoft Project:

To configure Microsoft Project:
1. In Microsoft Project, navigate to Tools → Options.
2. Select the View tab and clear the Project Screentips option.
3. Select the General tab and clear the following:
v Show startup Task Pane

v Advice from Planning Wizard

v Automatically add new resources and tasks

4. Select the Edit tab and clear the Ask to update automatic links option.
5. Select the Scheduling Options tab and clear the Show scheduling messages

option.
6. Select the Spelling Options tab and clear the Always suggest option.
7. For 2003, select Help → Customer Feedback Options and perform the

following:
a. Select No, I don’t wish to participate.
b. Click OK.

Configuring Microsoft Visio:

To configure Microsoft Visio
1. In Microsoft Visio, navigate to Tools → Options.
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2. Select the Save tab and clear the following options:
v Prompt for document properties

v Save preview with file

v Show XML file save warnings (XP)
v Show file save warnings (2003)
v Show XML file open warnings (XP)
v Show file open warnings (2003)

3. Select the Spelling tab and clear the following:
v Check spelling as you type

v Ignore words with number should be checked

4. For 2003, select Help → Customer Feedback Options and perform the
following:
a. Select No, I don’t wish to participate.
b. Click OK.

Configuring Corel WordPerfect:

For information on these options, see your Corel WordPerfect documentation.

To configure Corel WordPerfect:
1. In Corel WordPerfect, navigate to Tools → Settings.
2. Click Environment.
3. In the Environment Settings screen, select the Prompts tab and clear the

following:
v Confirm deletion of table formulas

v [Beep] On hyphenation

4. Select the Interface tab and perform the following:
a. Clear Quick Tips.
b. Check [Save workspace (documents and windows layout)] Never.

5. Click OK.
6. Click Files.
7. In the Files Settings screen, select the Document tab and clear the following:
v Timed document backup every

v Use enhanced file dialogs

8. Click OK and Close to close the Settings dialog box.
9. Navigate to Tools → Proofread and clear the Prompt-As-You-Go option.

10. Navigate to Tools → Proofread and select the following: Off

11. Navigate to Tools → Workplace Manager and clear the Show at Startup
option.

Disabling the Corel Office DAD components:

For WordPerfect Office, you must disable the Corel Office DAD system tray icons
and remove CorelCentral from the Startup folder.

To disable the Corel Office DAD components:
1. In the Windows System tray, right-click any of the DAD icons.
2. Clear Display DAD on Startup.
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3. Select Exit DAD.

Security administrator tasks

The items below are the required tasks for the security administrator.

Security authentication considerations

Check required user account privileges. For installing, configuring, and running
IBM FileNet Rendition Engine, you must use specific user and group accounts with
particular access privileges. See “Users required for Rendition Engine installation.”

Users required for Rendition Engine installation

Restriction: Under Windows Active Directory authentication, IBM FileNet P8
supports only security groups, not distribution groups. Supported groups can have
a scope of domain local (as long as they are in the same domain as Content
Engine), global, or universal.

The following table lists the user accounts needed for installing IBM FileNet
Rendition Engine, including the minimum permissions required.

Role/Account Description

FNRE_Admin A local or domain user account that must be
added directly to the local Administrators
group on all Rendition Engine servers.

Use this account both when installing
Rendition Engine and when installing and
configuring the authoring applications used
to render documents.

Permissions: Local administrator privileges
on the machine where Rendition Engine is
installed.

GCD_admin GCD administrator user. A FileNet P8
Platform user that is part of the GCD
administrators.

You will need this user when you configure
the Rendition Engine Connection on Content
Engine. See “Configuring Rendition Engine
connections on Content Engine” on page 29.

re_db_user (SQL_login) Microsoft SQL Server only: Any SQL Server
user with SQL Server’s Database Creators
server role.

This user will be created as part of the
Microsoft SQL Server installation and is a
safer alternative to using SQL Server’s SA or
SYS users, which will also satisfy the
configuration requirements.

See “Configuring Microsoft SQL login for
Rendition Engine” on page 22.
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Role/Account Description

re_db_user (VISTAUSER) (Oracle Server only) This user will be created
when running the Oracle-Repository.sql
script as part of the Oracle Server
installation. See “Creating an Oracle
database” on page 24.

For a complete list of the user and group roles, accounts, and responsibilities that
are required to install, configure, and maintain a FileNet P8 system, see the IBM
FileNet P8 Help topic FileNet P8 Administration → Enterprise-wide
Administration → Security → Users and groups → FileNet P8 Platform user and
group security help and the Plan and Prepare Your Environment for IBM FileNet P8
guide topic “Create Directory Server Accounts”.

Database administrator tasks

The items below are the required tasks for the database administrator.

Database options
If you plan to collocate the IBM FileNet Rendition Engine database with Content
Engine or Process Engine databases, you should use the supplied database instance
(Microsoft SQL Server) or database (Oracle) for these components. For more
information, see IBM FileNet P8 Platform Installation and Upgrade Guide and the
tasks “Install Microsoft SQL Server for FileNet P8” or “Install Oracle Server for
FileNet P8”.

If you plan to install and configure a standalone database instance (Microsoft SQL
Server) or database (Oracle) for Rendition Engine, follow the instructions in this
guide.

All platforms
v Determine your local or remote database engine preference. The database engine

is local if it is installed on a server where you will also be installing Content
Engine, Process Engine, and/or Rendition Engine software. The database is
remote if it is on a server where no Content Engine, Process Engine, or Rendition
Engine software is installed.

v Determine what type of database engine you want to use. Rendition Engine
supports only Microsoft SQL Server and Oracle.

v Determine the Archive and Purge intervals for the Rendition Engine database.
By default, the Rendition Engine database is set to autogrow. To keep the
database size down, Rendition Engine is set up to archive the content of the
database daily and to purge the archived content weekly. These intervals can be
modified by using the Domain Manager interface. See “Installing Rendition
Engine” on page 27.

Microsoft SQL Server

Determine whether you want to use a dedicated or shared database.
v You can assign Rendition Engine a dedicated instance. You can use the default

instance or a named instance of your choice.
v Rendition Engine can share a Microsoft SQL Server instance with Content

Engine or Process Engine.
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v Rendition Engine must have its own database, separate from Content Engine
and Process Engine.

Tip: There is no need to create an SQL database before you install Rendition
Engine software. The Rendition Engine installer will prompt for appropriate
database information and will create the necessary database.

v Remote Microsoft SQL Server connections for Rendition Engine are handled by
Microsoft Data Access Components, which is installed by default on Rendition
Engine servers. There is no need to install the Microsoft SQL Server client
software on the Rendition Engine server.

Create a SQL Login account for Rendition Engine purposes. Under Microsoft SQL
Server, you must ensure that an SQL Login account exists before you install the
first Rendition Engine. See “Configuring Microsoft SQL login for Rendition
Engine” on page 22.

Oracle

Determine whether you want to use a dedicated or shared database.
v Rendition Engine can have a dedicated Oracle database service or share a

database service with Content Engine, Process Engine, or non-FileNet P8
applications.

v Rendition Engine must have its own table space, separate from Content Engine
and Process Engine. This table space will be created by executing an Oracle SQL
script before you install the first Rendition Engine. See “Creating an Oracle
database” on page 24.

Database client software requirements. For Rendition Engine, if the database is
remote, you must install database client software on the Rendition Engine server.
See “Preparing Oracle client” on page 24.

Tip: Even though Content Engine also requires installation of the database client
software, that installation and configuration was completed during installation of
the FileNet P8 system.

To create a valid user and table space for Rendition Engine, you will run the
Oracle-repository.sql script on the database server as part of “Preparing Oracle
server” on page 22 before you perform the installation tasks.

Preparing Microsoft SQL Server

If you plan to collocate the IBM FileNet Rendition Engine database with Content
Engine or Process Engine databases, you should use the existing database instance
for these components. For more information, see the Plan and Prepare Your
Environment for IBM FileNet P8, task “Prepare Microsoft SQL Server”.

If you plan to install and configure a standalone database instance for Rendition
Engine, follow the instructions in this task.

Important:

v Install Microsoft SQL Server on the server where Rendition Engine software will
be installed as a local database or on a separate server as a remote database.

v Database creation for Rendition Engine will be handled automatically when you
install and configure Rendition Engine.
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v You do not need to install Microsoft SQL Server client software on the Rendition
Engine server.

v (Microsoft SQL Server 2000) Verify that the required Microsoft SQL Server 2000
Service Pack is available. See the IBM FileNet P8 Hardware and Software
Requirements.

v Record the values for the following settings as you work through the database
installation. This information must be entered during subsequent installations.
– Server name.
– Instance (for example, P8_inst).
– TCP/IP port number assigned.

Installing and configuring Microsoft SQL Server:

IBM FileNet Rendition Engine does not require any specific configuration settings
when you install Microsoft SQL Server. Refer to the Microsoft SQL Server
installation instructions.

Configuring Microsoft SQL login for Rendition Engine:

On the Microsoft SQL Server database computer, use Microsoft SQL Server
Enterprise Manager to create a Microsoft SQL Login (re_db_user (SQL_login)).

To configure Microsoft SQL Login for IBM FileNet Rendition Engine:
1. Start the Microsoft SQL Enterprise Manager.
2. Expand the Microsoft SQL Server Server name[\Instance name] node.
3. Expand the Security folder, right-click Logins and select New Login.
4. In the SQL Server Login Properties screen, under the General tab, perform the

following:
a. In the Name field, enter a name for the re_db_user (SQL_login) user.
b. In the Password field, enter a password for the new SQL user.
c. Verify that the default database for the login is “master”.

5. Grant the SQL login created in the previous step the Database Creators server
role:
a. In the SQL Server Login Properties screen, select the Server Roles tab.
b. Under Server Roles, check Database Creators.

6. Use the SQL Query Analyzer to validate that you can successfully log on to the
SQL database by using this user name and password.

Preparing Oracle server

If you plan to collocate the IBM FileNet Rendition Engine database with Content
Engine or Process Engine databases, you should use the existing database for these
components. For more information, see the Plan and Prepare Your Environment for
IBM FileNet P8, task “Prepare Oracle Server”.

If you plan to install and configure a standalone database for Rendition Engine,
follow the instructions in this task.

A database is local if it is on a machine where you will also be installing Rendition
Engine. A database is remote if it is on a machine where no Rendition Engine is
installed.
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v Perform this task on the UNIX®, Linux®, or Windows server that will host the
Oracle database to be used by the Rendition Engine.

v Make sure that the server that will host the database satisfies all pre-installation
requirements specified in the Oracle installation documentation.

v If the server where you install the Oracle database will also host an installation
of Rendition Engine, the machine must meet the Rendition Engine requirements
listed in IBM FileNet P8 Hardware and Software Requirements.

v Refer to IBM FileNet P8 Hardware and Software Requirements for operating-system
service pack and Oracle version and patch set requirements. The Oracle
patch-installation procedure might be less complicated if you do it before you
create any databases.

v If your Oracle database will be remote, after you complete the procedures in this
topic, you must also complete the procedures in “Preparing Oracle client” on
page 24 on each machine where you will install Rendition Engine.

v Record the values for the following settings as you work through the database
installation. This information must be entered during subsequent installations.
– Global Database Service Name (ORACLE_SID)

– Oracle temporary table space name

– Oracle data table space name

– Oracle index table space name (optional)

Installing an Oracle database engine:

IBM FileNet Rendition Engine does not require any specific configuration settings
when you install Oracle. Refer to Oracle installation instructions.

You do not need to create a table space as part of the installation. This will be
handled in “Creating a table space for Rendition Engine” on page 24.

During installation, select Enterprise Edition or Custom to install the necessary
components (if you don’t need all the components in the Enterprise Edition).

If you selected Custom you must, at a minimum, install the following components:
v Oracle 10g

– Oracle 10g Server
– Oracle Net Services

- Oracle Net Listener
– Oracle 10g Development Kit

- Oracle Call Interface (OCI)
– (Windows) Oracle Windows Interfaces

- Oracle Services for Microsoft Transaction Server
– Oracle 10g Documentation (recommended)

v Oracle 11g
– Oracle 11g Server
– Oracle Net Services

- Oracle Net Listener
– Oracle 11g Development Kit

- Oracle Call Interface (OCI)
– (Windows) Oracle Windows Interfaces

- Oracle Services for Microsoft Transaction Server
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– Oracle 11g Documentation (recommended)

Creating an Oracle database:

Oracle documentation describes several ways to create a database, for example the
Database Configuration Assistant (DBCA).

When you create the database, specify the following settings:
v Server process type

Tip: Dedicated Server Mode offers better performance than Shared Server Mode.
v Database character set

Choose a database character set as specified in “IBM FileNet P8 Database
Character Sets” in the Plan and Prepare Your Environment for IBM FileNet P8.

Creating a table space for Rendition Engine:

Use the Oracle-Repository.sql script to create a table space for IBM FileNet
Rendition Engine.

Important: The table spaces are for the exclusive use of Rendition Engine and
should not be shared with any other FileNet P8 component.

To create a table space for Rendition Engine:
1. Log on to the Oracle server as an Oracle administrative user.
2. Access the IBM FileNet Rendition Engine installation package.
3. Navigate to \Resources.
4. Copy the Oracle-Repository.sql script locally, and open it for editing.

You can modify several parameters in the script to meet specific business
requirements. The following table shows those parameters and the default
values. Make a note of the actual values that are assigned and of the user name
and the password that you assign when running the script. That user name and
password must be supplied later when you install the Rendition Engine
software.

Parameter Default Value
(If modified) Actual Value
Assigned

data table space VISTADAT1

index table space VISTAIND1

user name re_db_user (VISTAUSER)

password none (assigned at runtime)

5. Run the modified Oracle-Repository.sql script.
6. Supply the required password for the re_db_user when prompted.

Preparing Oracle client

The procedure in this task describes how to install the Oracle Client software to
prepare for the installation of IBM FileNet Rendition Engine.

Important:

v (Windows 2003 64-bit only) When installing Rendition Engine in a Windows
64-bit system you must install the 32-bit Oracle Client, not the 64-bit client.
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v Install Oracle Client on servers that will host Rendition Engine if the database
will be remote from the Rendition Engine server.

v Make sure that the machine where you will install Oracle Client satisfies all the
pre-installation requirements specified in the Oracle installation documentation.

v Refer to IBM FileNet P8 Hardware and Software Requirements for operating-system
service pack and Oracle version and patch set requirements.

Installing the Oracle client:

The following procedure describes the minimum options for installing Oracle
Client. Consult the Oracle installation documentation for complete instructions and
pre-installation requirements.

To install the Oracle client:
1. Log on with an appropriate local account to install and configure the Oracle

Client software.

Recommendation: You should log on to the machine locally (not through a
Windows domain) to install the Oracle Client software.

2. If the machine where you are installing Oracle Client does not use DNS to
resolve host names, you must add the IP address of the machine where the
Oracle database is installed to the host file on the Oracle Client machine.

3. Start the Oracle Client installation.
4. From the Available Products dialog box, click Oracle Client.
5. From the Installation Types dialog box, click Runtime, and proceed with the

installation.
6. After the installation completes, click Next Installation.
7. On the Installation Types dialog box, click Custom and select the following

from the list in the Available Product Components dialog box, then complete
the installation.
v Network Utilities (same as oracle net)

v SQL* Plus

v JDBC/OCI Interfaces

v Oracle Windows Interfaces

8. Use the Oracle Net Configuration Assistant to create a Local Net Service Name
configuration to the Oracle database. Then test the connection to the Oracle
database server with the user name and password created in “Creating a table
space for Rendition Engine” on page 24.

Tip: Enter the Oracle Service Name (Oracle 10g) or ORACLE_SID (Oracle 9i)
when prompted.

9. Install all required Oracle patches, as specified in the IBM FileNet P8 Hardware
and Software Requirements. To download this guide from the IBM support page,
see “ibm.com and related resources” on page v.

Installing database drivers on the Content Engine server

Important: This task is only required if your IBM FileNet Content Engine and
Rendition Engine are using different databases.

Rendition Engine might be configured to use a different database brand than the
Content Engine object store. For example, Rendition Engine might use Microsoft
SQL Server and Content Engine DB2®. In this case, you must configure Content
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Engine with the corresponding JDBC driver for the Rendition Engine database to
allow the Rendition Engine client software running on the Content Engine
application server to access the Rendition Engine database.

The procedure for installing the JDBC driver for the Rendition Engine database is
identical to the procedure for installing the JDBC for the Content Engine. Use the
steps specified in the “Configure WebSphere for Content Engine”, “Configure
WebLogic for Content Engine”, or “Configure JBoss for Content Engine” tasks of
the Plan and Prepare Your Environment for IBM FileNet P8 document.
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Installing and configuring Rendition Engine

This topic explains how to install Rendition Engine.

Installing Rendition Engine

Important: If you enter invalid database user credentials and complete the
Rendition Engine installation, you must correct these by using the Domain
Manager before you attempt to use Rendition Engine. For more information, see
the IBM FileNet P8 Help topic FileNet P8 Administration → Enterprise-wide
Administration → Publishing → How to... → Change the Rendition Engine
database password.
v This task covers installation of the first Rendition Engine in a Liquent Vista

domain, and installation of a second and consecutive Rendition Engine in the
same domain to increase publishing throughput. If you intend to install more
than one Rendition Engine in your environment, make sure that each installation
is completed and that Rendition Engine is configured before you start the next
installation. For more information about adding additional Rendition Engine
servers to a Liquent Vista Domain, see the IBM FileNet P8 Performance Tuning
Guide.

v During the installation, you might be prompted to install additional Microsoft
software. Specifically, if the .NET Framework 1.1 or XML Parser 4.0 software is
not already on your server, the Rendition Engine installer will do that
installation. See “Installing Rendition Engine.”

v After installing Rendition Engine you should confirm that the necessary macros
are installed to the external applications you plan to use for rendering. For
information and procedures, see “Enabling word processing macros for
rendering” on page 30.

v If you install a word processing applications after you have installed Rendition
Engine you must update the application with the required macro files. See
“Updating applications installed after Rendition Engine” on page 31.

Installing Rendition Engine
Install the IBM FileNet Rendition Engine software.

Copy the IBM FileNet Rendition Engine installation files from the installation
media to a local directory on the Rendition Engine server.

To install Rendition Engine:
1. To access the worksheet file, p8_worksheet.xls, that contains the parameter

values to specify in the Records Manager installation, see ″Using the
installation and upgrade worksheet″ section. In the worksheet file, verify that
the Data → Filter → AutoFilter command is enabled.

2. Log on to the Rendition Engine server as the FNRE_Admin user. Unless
otherwise directed use the FNRE_Admin account to install and configure all
the Publishing components.

3. If it is not already running, start the Print Spooler Windows service.
4. Run the Rendition Engine installer:

a. Access the IBM FileNet Rendition Engine installation files from the local
directory on the Rendition Engine server.
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b. Start the installation program: \Installer\P8RE451.exe and complete the
installation screens.

Tip: As part of the install the installer will check for required Microsoft
software (.NET Framework 1.1 or XML Parser 4.0). If the required software
is not installed, the Rendition Engine installer will perform the necessary
installations. Follow the instructions in the installation wizards that the
Rendition Engine installer launches.

5. When the Rendition Engine installation has completed, check the installation
log files to verify that no errors occurred. The log files are available at:
v C:\Temp\LiquentServicesInstall.log

v C:\Temp\VistaInstall.log

6. Reboot your server and then log back on using the FNRE_Admin account.

Important: Before rebooting, use the Windows Task Manager or the
application bar to verify that the IBM FileNet Rendition Engine 4.5.1
InstallShield Wizard application has completed. This might take a few
moments.

7. Hide rendering in the Domain Manager
a. On the Rendition Engine server, navigate to Start → Programs → IBM

FileNet P8 Platform → Domain Manager to start the Domain Manager.
b. Select File → Show/Hide Rendering , and select Hide.
c. Enter the password and click OK, then click Yes in the confirmation

window to verify that you intend to make these changes to the database.
8. Windows 2003 64-bit only: Manually register the CDIntf300.dll.

For rendering on a Windows 2003 64-bit system to work, you must manually
register the printer driver by executing the following from a command line:
cd C:\WINDOWS\SysWOW64
regsvr32 CDIntf300.dll

9. Create a Java™ Repository on the Content Engine server:
Perform this step on the first Rendition Engine server in each Liquent Vista
domain only. Additional Rendition Engine servers will use the settings of the
Liquent Vista domain they connect to.
a. On the Rendition Engine server, navigate to Start → Programs → IBM

FileNet P8 Platform → Domain Manager to start the Domain Manager.
b. Select File → Add Repository, and click Yes in the confirmation window to

verify that you intend to add a repository to this domain.
c. Add the required information in the New Repository Properties dialog

box.
d. Confirm the new repository by selecting File → Save and clicking Yes in

the confirmation window to verify that you intend to make these changes
to the database.

10. Optional: Set the Rendition Engine Purge and Archive Intervals:
To keep the size of your database down, you should configure Rendition
Engine to regularly purge the Rendition Engine database of old data. You can
also keep the default values to archive data once a day, and purge the
archived data once a week.
a. On the Rendition Engine server, navigate to Start → Programs → IBM

FileNet P8 Platform → Domain Manager to start the Domain Manager.
b. In the Configuration tab, right-click the Domain node and select

Properties.
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c. In the General tab of the Domain Properties dialog box, set the Purge Age
(Default: 7 days) and Archive Age (Default: 1 day) intervals to suit your
environment.

11. Set security on the VistaTempDir shared folder:
Perform this step on all Rendition Engine servers in each Liquent Vista
domain.
a. On the Rendition Engine server, use Windows Explorer to navigate to

RE_install_path\SharedTemp.
b. Right-click the \SharedTemp folder and select Properties.
c. In the SharedTemp Properties screen, verify that the \SharedTemp folder is

shared using the share name VistaTempDir. If not, select the Sharing tab
and select Share this folder.

d. Select the Security tab and click Advanced..
e. In the Access Control Settings for SharedTemp screen, clear Allow

inheritance permissions, and then click Remove in the security
confirmation window.

f. In the Access Control Settings for SharedTemp screen, click Add.
g. In the Select User or Group screen, for the Look in field, keep the local

server name or select the correct domain.
h. Select the proper Rendition Engine user account (FNRE_Admin).
i. In the Permission Entry for SharedTemp screen, give the account all access

rights.
j. In the Access Control Settings for SharedTemp screen, click OK.
k. In the SharedTemp Properties screen, click OK.

12. If you have added a second or consecutive Rendition Engine to your Liquent
Vista domain, restart the BusinessServiceServer service.

Every time a Rendition Engine is added to the IBM FileNet P8 Platform domain,
you must manually restart the BusinessServiceServer services on every Rendition
Engine connected to the Liquent Vista domain.

Configuring Rendition Engine connections on Content Engine

This topic covers the required configuration steps to enable publishing on the IBM
FileNet Content Engine.

To create a Liquent Rendition Engine Connection:
1. To access the worksheet file, p8_worksheet.xls, that contains the parameter

values to specify in the Records Manager installation, see ″Using the
installation and upgrade worksheet″ section. In the worksheet file, verify that
the Data → Filter → AutoFilter command is enabled.

2. Set up Rendition Engine Connection (REC) on the Content Engine.
a. Start Enterprise Manager as a GCD_admin.
b. Right-click the Enterprise Manager [p8 domain] node and select Properties.
c. In the Enterprise Manager [p8 domain] Properties screen, select the

Publishing tab.
d. Verify that the Enable Dispatcher checkbox is checked.
e. In the Select Rendition Engine Connection field, click New and complete

the Create Rendition Engine Connection wizard.

Installing and configuring Rendition Engine 29



f. In the Enterprise Manager [p8 domain] Properties screen, click Apply to
save your changes. The newly created Rendition Engine Connection will
now be listed in the Select Rendition Engine Selection list box.

g. Click Properties next to the connection to set the password and Connection
State.

h. In the Rendition Engine Connection Properties screen, select Set Password
and enter the password.

i. Click OK twice to set the password.
j. In the Rendition Engine Connection Properties screen, Connection State

drop-down list, select Enabled.
k. Click Apply and OK to save the changes, then click OK to close the

Enterprise Manager [p8 domain] Properties screen.

Setting the site preferences on the Application Engine to use
path-based URLs

(Upgrades) This task is not required on an upgrade. However, you should verify
that your settings are valid.

In order to view HTML publication documents, you must first configure the
path-based URL parameter.

When publishing a document to HTML, the resulting HTML publication document
will in most cases contain references to graphics or other files that are required to
correctly display the document. If you choose not to use path-based URLs the
references in the HTML code cannot be resolved and the HTML publication
documents will not display correctly.

PDF publication documents are self-contained and do not require the use of
path-based URLs.

To configure the path-based URL parameter:
1. Sign-on to Workplace as a user assigned the IBM FileNet Application Engine

Administrators access role.
2. Choose Admin → Site Preferences.
3. Under General Settings → Application, set Use path based URLs to Yes.
4. Click Apply to save the setting.
5. Click Exit.

Enabling word processing macros for rendering

In order to support Rendition Engine rendering functionality, such as bookmarking
and preserving links Corel WordPerfect and Adobe® FrameMaker require
additional macro files. Provided the applications are installed before you install
Rendition Engine, the macro files are automatically copied to the appropriate
directories by the Rendition Engine installer.

Complete this section to confirm, and if necessary, enable the macro files. Also, if
you install a word processing applications after Rendition Engine has been
installed, this section describes the process for updating the application with the
required macro files.
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To enable word processing macros for rendering:
1. Confirm and enable Corel WordPerfect:

Perform this procedure on each Rendition Engine server.
a. In Windows Explorer, navigate to \Program Files\WordPerfect

Office12\Macros\WPWin.
b. Confirm that the following macro files exist:
v espsdtoc.wcm

v espsdtoc11.wcm

v espsdtoc12.wcm

v espsdtoc2k.wcm

v espsdtoc9.wcm

v espsrsym.wcm

v espsrsym11.wcm

v espsrsym12.wcm

v espsrsym2k.wcm

v espsrsym9.wcm

v generate.wcm

v removehf11.wcm

v removehf12.wcm

v removehf2k.wcm

2. Confirm and enable Adobe FrameMaker:
a. In Windows Explorer, navigate to \Program Files\Adobe\FrameMaker7.1.
b. Confirm that the esfmdde.dll macro file exists.

Updating applications installed after Rendition Engine

To update applications installed after IBM FileNet Rendition Engine:
1. In the Domain Manager application, navigate to File → Configure Applications.

The Configure Applications dialog box opens.
2. Select the check box next to the application and click OK to install the macros.

Tip: A selected check box is means that the application has been updated with
the required macro files, and no further action is required.

3. Select File → Save to save your changes.
4. Reopen the dialog box and confirm that a check mark appears to the left of the

check box of the application you updated.

Installing Rendition Engine software updates

Perform the procedure in this topic for each IBM FileNet Rendition Engine instance
to install software updates (modification release, fix pack, or interim fix).

To install the Rendition Engine software updates:
1. To obtain the latest Rendition Engine software updates, and to determine

whether additional interim fixes are needed, contact your IBM service
representative.
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2. Open the readme files for the Rendition Engine software updates and perform
the installation procedures in the readme files on each Rendition Engine
instance.

Verifying Rendition Engine installation (Optional)

Successfully completing all the following steps confirms that the basic functionality
of IBM FileNet Rendition Engine is working and that the application has been
correctly installed and configured.

Tip: For more information about the Rendition Engine user interface and the
procedures you are working on, use the Help links in the Rendition Engine user
interface to access context-sensitive help.

For a more extensive description of how to start using Rendition Engine past this
simple functionality test, see the IBM FileNet P8 Help topic System
Administration → Enterprise-wide Administration → Publishing and the
Publishing Designer help located at FileNet P8 Documentation → User Help →
Actions, preferences, and tools → Tools → Publishing Designer.

For more details on adding and publishing documents by using Workplace, refer
to the Workplace help topic FileNet P8 Documentation → User Help → Actions,
preferences, and tools → Actions → Documents.

To verify Rendition Engine installation:
1. Create Publishing Templates.

The IBM FileNet P8 Platform publishing feature is delivered with default style
templates for both PDF and HTML renditions. You will use those default style
templates for this procedure.
For more information, see the IBM FileNet P8 Help topic FileNet P8
Administration → Enterprise-wide Administration → Publishing → How to... →
Create publishing templates.

2. Add and publish a test document.
This procedure shows you how to add and publish a test document to verify
that you have correctly installed and configured the publishing components.
For more information, see the IBM FileNet P8 Help topic FileNet P8
Administration → Enterprise-wide Administration → Publishing → How to... →
Publish your first document.
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Planning and preparing for upgrade

This topic explains how to plan for an upgrade of your IBM FileNet Rendition
Engine software.

Planning the upgrade
Information for upgrading the IBM FileNet Rendition Engine from the 3.5.x release
to the 4.5 release is covered in this topic. The upgrade involves uninstalling and
reinstalling the software.
v You will reinstall Rendition Engine on the existing Rendition Engine servers.
v Rendition Engine 4.5 and later does not use the publishing plug-in. This

component is uninstalled as part of the Content Engine upgrade.

You should plan and test the upgrade on a test system first. Verify the upgrade is
successful by running functionality and stress tests. After successful verification,
perform the production upgrade.

Before you begin the upgrade
v Be sure to read the “What’s New” topic in the IBM FileNet P8 Release Notes®.

Many of the new features might apply to your implementation of IBM FileNet
P8 Platform. To download this guide from the IBM support page, see “ibm.com
and related resources” on page v.

v Make sure the site has restorable backups of system and data, in case you need
to back out of the upgrade. For details on what to back up for FileNet P8
components, see the IBM FileNet P8 Help topic Enterprise-wide Administration
→ Back up and Restore FileNet P8.

Performing required preparation tasks

In addition to the general requirements for IBM FileNet Rendition Engine 4.5.1 that
are listed in “Planning and preparing for installation” on page 1, the following
requirements apply when you upgrade an existing Rendition Engine system to
version 4.5.1.

In addition to the preparation tasks listed below, follow the plan and prepare
instructions in the Plan and Prepare Your Environment for IBM FileNet P8 guide for
the components that you are installing.

To prepare your environment for a Rendition Engine installation, perform the
required preparation tasks for the components you plan to install.

In addition, if you are using the P8 Worksheet for your environment, all
administrators should complete the worksheet with the relevant information as
described in “Using the installation and upgrade worksheet” on page 3.

Installation administrator tasks
The items below are the required tasks for the Application Installer Administrator.
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Database or directory services migration

This guide does not address migrations to different databases or directory services.
To migrate from one database to another (for example, from a Microsoft SQL
Server database engine to Oracle), you must contact your service representative.

Before you begin the upgrade
v Make sure no users or processes are accessing the IBM FileNet P8 system.
v Complete any pending publishing jobs.
v Disable scheduled automated backups.
v Disable virus scanning.

Requirements for upgrades

The upgrade procedures described in the guide are written with the assumption
that you will:
v retain your basic platform configuration from the previous release.
v make no changes to user or group definitions during the upgrade.
v apply only the necessary supported software updates and patches, as noted in

this guide and in the IBM FileNet P8 Hardware and Software Requirements
document.

Information technology administrator tasks
The items below are the required tasks for the information technology
administrator.

Network considerations

Ensure that the required port numbers are available. For a composite list of port
numbers required for IBM FileNet P8 4.5, see “FileNet P8 port numbers,” on page
49.

Independent software vendor (ISV) applications

If you plan to upgrade the native applications used by IBM FileNet Rendition
Engine, you must do this before you reinstall Rendition Engine.

Content Engine considerations
v Ensure that you have the necessary local administrator user accounts and

passwords to perform configuration tasks on the Content Engine server.
v Verify that all object stores you want to use for publishing are configured with

the publishing add-ons.
In Rendition Engine 4.5.1, publishing is configured per site rather than per object
store. Object stores that will be used for publishing must be configured with the
Publishing add-ons. By default, these are added when you create an object store,
custom stores that aren’t configured with these add-ons might exist. Manually
add the add-ons by using the IBM FileNet Enterprise Manager if required.

v The publishing templates are upgraded as part of the Content Engine upgrade.

Important: If your current publishing templates use VBScript Event Actions,
these must be rewritten in Java before they can be used for Rendition Engine
4.5.1. Furthermore, the Java class must be located on the server; it cannot be on a
client and streamed to the server for execution as for Content Engine 3.5.x. The
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rewrite must be done after the upgrade and before you start using Rendition
Engine. For more information on how to rewrite the event actions in Java, see
the IBM FileNet P8 Help topic System Administration → Content Engine
Administration → Events and subscriptions → How to... → Work with event
actions.

Security administrator tasks

The items below are the required tasks for the Security Administrator.

IBM FileNet Rendition Engine
v Ensure that you have the necessary local administrator user accounts and

passwords to run the upgrade program on the Rendition Engine. See “Users
required for Rendition Engine installation” on page 19.

v Verify the security settings for the Rendition Engine temporary directory.

Database administrator tasks

The items below are the required tasks for the database administrator.

Updating database software

Update the appropriate database patches before you upgrade IBM FileNet
Rendition Engine.

Oracle clients. Ensure that you have applied appropriate Oracle patches to Oracle
clients and servers. Be sure that clients remote to an Oracle database engine have
the same patches as the database server. Oracle clients include any machines
remote from the Oracle database server where Rendition Engine software is
installed. Install all required Oracle patches, as specified in the IBM FileNet P8
Hardware and Software Requirements. To download this guide from the IBM support
page, see “ibm.com and related resources” on page v.

Creating a new Rendition Engine database

When you upgrade, you cannot use an existing IBM FileNet Rendition Engine
database. You will need to identify a new database (Microsoft SQL Server) or table
space (Oracle) for use by the 4.5.1 version of Rendition Engine. You cannot use
existing databases or table space after the upgrade.
v For Microsoft SQL Server, the database will be created by the installer.
v For Oracle, you must create an Oracle user and associated table spaces (includes

temp) before you install Rendition Engine.

When creating your new database or table space you have the following options:
v Use the same name and administrative user as the previous version.

Delete the old database or table space before you run the installer and create a
new one with the same name and administrative user as part of the upgrade
procedure. For information, see “Uninstalling previous version of Rendition
Engine” on page 37 or (Oracle) “Creating an Oracle database” on page 24.

v Use a new name for the new database or table space.
If you use a new name for your database or table space you must reconfigure
your Content Engine connection as part of the upgrade. See “Configuring
Rendition Engine connections on Content Engine” on page 29.
– (Microsoft SQL Server) Configure the new database with a new name.
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– (Oracle) Configure the new table space with a new name and a new user. See
“Users required for Rendition Engine installation” on page 19.

Important: If you choose to create new databases that uses new names, you
must modify the entries in the Oracle-Repository.sql script with the new
information. See “Creating an Oracle database” on page 24.
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Upgrading and configuring Rendition Engine

This topic explains how to upgradeIBM FileNet Rendition Engine software.

Uninstalling previous version of Rendition Engine

If you are upgrading from IBM FileNet Rendition Engine version 3.5 or 4.0, before
you can install IBM FileNet Rendition Engine version 4.5.1, you must uninstall the
previous version of the software.

When upgrading from IBM FileNet Rendition Engine version 4.5, the installer
uninstalls the existing IBM FileNet Rendition Engine software.

Removing Rendition Engine version 4.0 software

You must uninstall the IBM FileNet Rendition Engine software, remove the local
printer ports, and remove native application macros before upgrading
(re-installing) the publishing components for 4.5.

To remove version Rendition Engine 4.0 software:
1. Back up your existing installation.

Rendition Engine does not require backup. In case you need to roll back to the
previous version of the IBM FileNet P8 Platform and Rendition Engine, you
need only reinstall the previous version of the software.
Some Rendition Engine components such as publishing templates and
publishing style templates are located on a Content Engine server and were
backed up as part of the preparation for Content Engine upgrade.

2. Log on to the Rendition Engine server as FNRE_Admin.
3. Stop the BusinessServiceServer Windows service before uninstalling the

software:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Administrative Tools.
c. Double-click Services.
d. Double-click BusinessServiceServer.
e. Click the Stop button.

4. Remove the Rendition Engine software:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Add or Remove Programs.
c. Select FileNet P8 Rendition Engine 4.0.0 and click Remove.
d. Follow the screen prompts to remove the software. At the final screen, click

Finish.
e. Close the Add or Remove Programs window.

5. Remove the printers:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Printers and Faxes.
c. If the Liquent XML Printer is listed in the Printers and Faxes window, delete

it.
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d. If the Liquent PDF Printer is listed in the Printers and Faxes window, delete
it.

e. On the Printers and Faxes window, select File → Server Properties.
f. On the Print Server Properties dialog box, select the Ports tab and delete the

local ports that point to:
v Drive:\Program Files\Liquent\filenet\ESPS.PS

v Drive:\Program Files\Liquent\filenet\liquent.xml

g. Select the Drivers tab and remove (if it exists) the printer driver Liquent
XML Printer.

6. Verify removal of native application macros:
a. If the Microsoft Word macro cdmacros.dot is present on the Rendition

Engine server, remove it.
b. If any of the following Word Perfect macros are present on the Rendition

Engine server, remove them:
v espsdtoc.wcm

v espsdtoc11.wcm

v espsdtoc12.wcm

v espsdtoc2k.wcm

v espsdtoc9.wcm

v espsrsym.wcm

v espsrsym11.wcm

v espsrsym12.wcm

v espsrsym2k.wcm

v espsrsym9.wcm

v generate.wcm

v removehf11.wcm

v removehf12.wcm

v removehf2k.wcm

7. Reboot the server.
8. Verify that the Vista software has been removed:

a. Navigate to Start → Settings → Control Panel.
b. Double-click Add or Remove Programs.
c. Verify that the IBM FileNet Rendition Engine 4.0.0 entry and the Vista entry

have been removed.
d. If the Vista entry is still there, remove it:

1) Select the Vista entry and click Change/Remove.
2) Follow the screen prompts to remove the software.
3) At the final screen, click Finish , and reboot the server.

e. Verify that all files are removed from C:\Program Files\Liquent and
C:\Program Files\Common Files\Liquent. If there are files in these
directories, delete them manually.

f. Verify that the LIQUENT key has been removed:
1) Select Start → Run.
2) Type Regedit.
3) Navigate to HKEY_LOCAL_MACHINE\SOFTWARE.
4) Verify that the LIQUENT key has been removed. If the LIQUENT key is

there, delete it.
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g. Reboot the server.
9. Optional: Remove the existing Rendition Engine database.

If you want to use the same database name as with your previous installation,
you must first remove the existing Rendition Engine database.
When you upgrade, you cannot use an existing Rendition Engine database or
table space. Instead, identify a new database (Microsoft SQL Server) or table
space (Oracle) with the same name or a different name for use by the 4.5
version of Rendition Engine. For information, see “Creating a new Rendition
Engine database” on page 35.

Removing Rendition Engine version 3.5 software from a
Rendition Engine or publishing plug-in server

You must uninstall the existing Liquent RenderPerfect software, remove the local
printer ports, and remove native application macros from all IBM FileNet
Rendition Engine servers before upgrading (re-installing) the publishing
components for 4.5.1.

Tip: The publishing plug-in components are uninstalled as part of the Content
Engine 4.5.1 upgrade and do not need to be removed.

To remove Rendition Engine version 3.5 software from a Rendition Engine or
Publishing Plug-in server:
1. If the Rendition Engine server has SQL Server or SQL Server Client software

installed, to prevent it from loosing SQL Server and SQL Server Client files
when running the Rendition Engine uninstallation, apply patch
P8RE-3.5.1-000.001 before continuing.

2. Back up your existing installation.
Rendition Engine does not require backup. In case you need to roll back to the
previous version of the IBM FileNet P8 Platform and Rendition Engine, you
need only reinstall the previous version of the software.
Some Rendition Engine components such as publishing templates and
publishing style templates are located on a Content Engine server and were
backed up as part of the preparation for Content Engine upgrade.

3. Stop the BusinessServiceServer Windows service before uninstalling the
software:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Administrative Tools.
c. Double-click Services.
d. Double-click BusinessServiceServer.
e. Click the Stop button.

4. Remove the Rendition Engine software:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Add or Remove Programs.
c. Select FileNet P8 Rendition Engine 3.0.0a/3.5.1 and click Change/Remove.
d. Follow the screen prompts to remove the software. At the final screen,

click Finish.
e. Close the Add or Remove Programs window.

5. Remove the printers:
a. Navigate to Start → Settings → Control Panel.
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b. Double-click Printers and Faxes.
c. If the Liquent XML Printer is listed in the Printers and Faxes window,

delete it.
d. If the Liquent PDF Printer is listed in the Printers and Faxes window,

delete it.
e. On the Printers and Faxes window, select File → Server Properties.
f. On the Print Server Properties dialog box, select the Ports tab and delete

the local ports that point to:
Drive:\Program Files\Liquent\filenet\ESPS.PS

Drive:\Program Files\Liquent\filenet\liquent.xml

g. Select the Drivers tab and remove (if it exists) the printer driver Liquent
XML Printer.

6. Verify removal of native application macros:
a. If the Microsoft Word macro cdmacros.dot is present on the Rendition

Engine server, remove it.
b. If any of the following Word Perfect macros are present on the Rendition

Engine server, remove them:
v espsdtoc.wcm

v espsdtoc11.wcm

v espsdtoc12.wcm

v espsdtoc2k.wcm

v espsdtoc9.wcm

v espsrsym.wcm

v espsrsym11.wcm

v espsrsym12.wcm

v espsrsym2k.wcm

v espsrsym9.wcm

v generate.wcm

v removehf11.wcm

v removehf12.wcm

v removehf2k.wcm

7. If you uninstalled a Rendition Engine version before 3.0.0a/3.5.1, run the Vista
cleanup tool.
If the version of Rendition Engine you uninstalled in “Removing Rendition
Engine version 4.0 software” on page 37 was before 3.0.0a/3.5.1, you must run
the cleanup tool provided with the IBM FileNet Rendition Engine installation
package to prepare your environment for a new Rendition Engine installation.
a. Start the cleanup tool:
v On your Rendition Engine installation media (versions before

3.0.0a/3.5.1): \Resources\Liquent\Unsupported Apps\Xtent2.0\
VistaCleanUtility.exe

v On your Rendition Engine 4.0.0 installation media: \Resources\Liquent\
Unsupported Apps\Vista2.x\VistaClean.exe

b. Click the Cleanup button.
c. Click OK to close the program when it has completed.

8. Reboot the server.
9. Verify that the Vista software has been removed:

40 Installation and Upgrade Guide: Installation and Upgrade Guide



a. Navigate to Start → Settings → Control Panel.
b. Double-click Add or Remove Programs.
c. Verify that the IBM FileNet Rendition Engine 3.0.0a/3.5.1 entry and the

Vista entry have been removed.
d. If the Vista entry is still there, remove it:

1) Select the Vista entry and click Change/Remove.
2) Follow the screen prompts to remove the software.
3) At the final screen, click Finish , and reboot the server.

e. Verify that all files are removed from C:\Program Files\Liquent and
C:\Program Files\Common Files\Liquent. If there are files in these
directories, delete them manually.

f. Verify that the LIQUENT key has been removed:
1) Select Start → Run.
2) Type Regedit.
3) Navigate to HKEY_LOCAL_MACHINE\SOFTWARE.
4) Verify that the LIQUENT key has been removed. If the LIQUENT key is

there, delete it.
g. Reboot the server.

10. Optional: Remove the existing Rendition Engine database.
The Rendition Engine upgrade includes the creation of a new database for
Rendition Engine use. If you want to use the same database name as your
previous installation, you must first remove the existing Rendition Engine
database.
(Oracle) If you choose to create new databases that uses new names, you must
modify the entries in the Oracle-Repository.sql script with the new
information. See “Creating an Oracle database” on page 24.

Upgrading native applications
Install the IBM FileNet Rendition Engine software.

If you plan to upgrade the native applications used by Rendition Engine, you must
do this before you install Rendition Engine. See “Information technology
administrator tasks” on page 34.
1. Install or upgrade your native applications.
2. Configure your newly upgraded native applications. Perform the task

“Installing and configuring authoring applications” on page 8.

Upgrading Rendition Engine
Upgrade the IBM FileNet Rendition Engine software.

Copy the IBM FileNet Rendition Engine installation files from the installation
media to a local directory on the Rendition Engine server.

To upgrade Rendition Engine:
1. To access the worksheet file, p8_worksheet.xls, that contains the parameter

values to specify in the Records Manager installation, see ″Using the
installation and upgrade worksheet″ section. In the worksheet file, verify that
the Data → Filter → AutoFilter command is enabled.
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2. Log on to the Rendition Engine server as the FNRE_Admin user. Unless
otherwise directed use the FNRE_Admin account to install and configure all
the Publishing components.

3. If it is not already running, start the Print Spooler Windows service.
4. Run the Rendition Engine installer:

a. Access the IBM FileNet Rendition Engine installation files from the local
directory on the Rendition Engine server.

b. Start the installation program: \Installer\P8RE451.exe and complete the
installation screens.

Tip: As part of the install the installer will check for required Microsoft
software (.NET Framework 1.1 or XML Parser 4.0). If the required software
is not installed, the Rendition Engine installer will perform the necessary
installations. Follow the instructions in the installation wizards that the
Rendition Engine installer launches.

5. When the Rendition Engine installation has completed, check the installation
log files to verify that no errors occurred. The log files are available at:
v C:\Temp\LiquentServicesInstall.log

v C:\Temp\VistaInstall.log

6. Reboot your server and then log back on using the FNRE_Admin account.

Important: Before rebooting, use the Windows Task Manager or the
application bar to verify that the IBM FileNet Rendition Engine 4.5.1
InstallShield Wizard application has completed. This might take a few
moments.

7. Hide rendering in the Domain Manager
a. On the Rendition Engine server, navigate to Start → Programs → IBM

FileNet P8 Platform → Domain Manager to start the Domain Manager.
b. Select File → Show/Hide Rendering , and select Hide.
c. Enter the password and click OK, then click Yes in the confirmation

window to verify that you intend to make these changes to the database.
8. Windows 2003 64-bit only: Manually register the CDIntf300.dll.

For rendering on a Windows 2003 64-bit system to work, you must manually
register the printer driver by executing the following from a command line:
cd C:\WINDOWS\SysWOW64
regsvr32 CDIntf300.dll

9. Create a Java Repository on the Content Engine server:
Perform this step on the first Rendition Engine server in each Liquent Vista
domain only. Additional Rendition Engine servers will use the settings of the
Liquent Vista domain they connect to.
a. On the Rendition Engine server, navigate to Start → Programs → IBM

FileNet P8 Platform → Domain Manager to start the Domain Manager.
b. Select File → Add Repository, and click Yes in the confirmation window to

verify that you intend to add a repository to this domain.
c. Add the required information in the New Repository Properties dialog

box.
d. Confirm the new repository by selecting File → Save and clicking Yes in

the confirmation window to verify that you intend to make these changes
to the database.

10. Optional: Set the Rendition Engine Purge and Archive Intervals:
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To keep the size of your database down, you should configure Rendition
Engine to regularly purge the Rendition Engine database of old data. You can
also keep the default values to archive data once a day, and purge the
archived data once a week.
a. On the Rendition Engine server, navigate to Start → Programs → IBM

FileNet P8 Platform → Domain Manager to start the Domain Manager.
b. In the Configuration tab, right-click the Domain node and select

Properties.
c. In the General tab of the Domain Properties dialog box, set the Purge Age

(Default: 7 days) and Archive Age (Default: 1 day) intervals to suit your
environment.

11. Set security on the VistaTempDir shared folder:
Perform this step on all Rendition Engine servers in each Liquent Vista
domain.
a. On the Rendition Engine server, use Windows Explorer to navigate to

RE_install_path\SharedTemp.
b. Right-click the \SharedTemp folder and select Properties.
c. In the SharedTemp Properties screen, verify that the \SharedTemp folder is

shared using the share name VistaTempDir. If not, select the Sharing tab
and select Share this folder.

d. Select the Security tab and click Advanced..
e. In the Access Control Settings for SharedTemp screen, clear Allow

inheritance permissions, and then click Remove in the security
confirmation window.

f. In the Access Control Settings for SharedTemp screen, click Add.
g. In the Select User or Group screen, for the Look in field, keep the local

server name or select the correct domain.
h. Select the proper Rendition Engine user account (FNRE_Admin).
i. In the Permission Entry for SharedTemp screen, give the account all access

rights.
j. In the Access Control Settings for SharedTemp screen, click OK.
k. In the SharedTemp Properties screen, click OK.

12. If you have added a second or consecutive Rendition Engine to your Liquent
Vista domain, restart the BusinessServiceServer service.

Every time a Rendition Engine is added to the IBM FileNet P8 Platform domain,
you must manually restart the BusinessServiceServer services on every Rendition
Engine connected to the Liquent Vista domain.

Configuring Rendition Engine connections on Content Engine

This topic covers the required configuration steps to enable publishing on the IBM
FileNet Content Engine.

Perform this if you have created a new database or table space with a new name
and/or administrative user. See “Creating a new Rendition Engine database” on
page 35.

To create a Liquent Rendition Engine Connection:
1. To access the worksheet file, p8_worksheet.xls, that contains the parameter

values to specify in the Records Manager installation, see ″Using the
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installation and upgrade worksheet″ section. In the worksheet file, verify that
the Data → Filter → AutoFilter command is enabled.

2. Set up Rendition Engine Connection (REC) on the Content Engine.
a. Start Enterprise Manager as a GCD_admin.
b. Right-click the Enterprise Manager [p8 domain] node and select Properties.
c. In the Enterprise Manager [p8 domain] Properties screen, select the

Publishing tab.
d. Verify that the Enable Dispatcher checkbox is checked.
e. In the Select Rendition Engine Connection field, click New and complete

the Create Rendition Engine Connection wizard.
f. In the Enterprise Manager [p8 domain] Properties screen, click Apply to

save your changes. The newly created Rendition Engine Connection will
now be listed in the Select Rendition Engine Selection list box.

g. Click Properties next to the connection to set the password and Connection
State.

h. In the Rendition Engine Connection Properties screen, select Set Password
and enter the password.

i. Click OK twice to set the password.
j. In the Rendition Engine Connection Properties screen, Connection State

drop-down list, select Enabled.
k. Click Apply and OK to save the changes, then click OK to close the

Enterprise Manager [p8 domain] Properties screen.

Enabling word processing macros for rendering

In order to support Rendition Engine rendering functionality, such as bookmarking
and preserving links Corel WordPerfect and Adobe FrameMaker require additional
macro files. Provided the applications are installed before you install Rendition
Engine, the macro files are automatically copied to the appropriate directories by
the Rendition Engine installer.

Complete this section to confirm, and if necessary, enable the macro files. Also, if
you install a word processing applications after Rendition Engine has been
installed, this section describes the process for updating the application with the
required macro files.

To enable word processing macros for rendering:
1. Confirm and enable Corel WordPerfect:

Perform this procedure on each Rendition Engine server.
a. In Windows Explorer, navigate to \Program Files\WordPerfect

Office12\Macros\WPWin.
b. Confirm that the following macro files exist:
v espsdtoc.wcm

v espsdtoc11.wcm

v espsdtoc12.wcm

v espsdtoc2k.wcm

v espsdtoc9.wcm

v espsrsym.wcm

v espsrsym11.wcm
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v espsrsym12.wcm

v espsrsym2k.wcm

v espsrsym9.wcm

v generate.wcm

v removehf11.wcm

v removehf12.wcm

v removehf2k.wcm

2. Confirm and enable Adobe FrameMaker:
a. In Windows Explorer, navigate to \Program Files\Adobe\FrameMaker7.1.
b. Confirm that the esfmdde.dll macro file exists.

Updating applications installed after Rendition Engine

To update applications installed after IBM FileNet Rendition Engine:
1. In the Domain Manager application, navigate to File → Configure Applications.

The Configure Applications dialog box opens.
2. Select the check box next to the application and click OK to install the macros.

Tip: A selected check box is means that the application has been updated with
the required macro files, and no further action is required.

3. Select File → Save to save your changes.
4. Reopen the dialog box and confirm that a check mark appears to the left of the

check box of the application you updated.

Installing Rendition Engine software updates

Perform the procedure in this topic for each IBM FileNet Rendition Engine instance
to install software updates (modification release, fix pack, or interim fix).

To install the Rendition Engine software updates:
1. To obtain the latest Rendition Engine software updates, and to determine

whether additional interim fixes are needed, contact your IBM service
representative.

2. Open the readme files for the Rendition Engine software updates and perform
the installation procedures in the readme files on each Rendition Engine
instance.

Verifying Rendition Engine upgrade (Optional)

Successfully completing all the following steps confirms that the basic functionality
of IBM FileNet Rendition Engine is working and that the application has been
correctly upgraded and configured.

For more information about the Rendition Engine user interface and the
procedures you are working on, use the Help links in the Rendition Engine user
interface to access context-sensitive help.

For a more extensive description of how to start using Rendition Engine past this
simple functionality test, see the IBM FileNet P8 Help topic FileNet P8
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Administration → Enterprise-wide Administration → Publishing and the
Publishing Designer help located at Workplace → Advanced Author Tools →
Publishing Designer.

For more details on adding and publishing documents by using Workplace, refer
to the Workplace help topic FileNet P8 Documentation → Workplace → Workplace
User Help → Manage Documents.

To verify Rendition Engine installation:
1. Create Publishing Templates.

The IBM FileNet P8 Platform publishing feature is delivered with default style
templates for both PDF and HTML renditions. You will use those default style
templates for this procedure.
For more information, see the IBM FileNet P8 Help topic FileNet P8
Administration → Enterprise-wide Administration → Publishing → How to... →
Create publishing templates.

2. Add and publish a test document.
This procedure shows you how to add and publish a test document to verify
that you have correctly installed and configured the publishing components.
For more information, see the IBM FileNet P8 Help topic FileNet P8
Administration → Enterprise-wide Administration → Publishing → How to... →
Publish your first document.
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Removing software

This topic explains how to remove IBM FileNet Rendition Engine software.

Removing a Rendition Engine from a Liquent Vista domain

To uninstall an existing IBM FileNet Rendition Engine 4.5.1, you must first remove
the server from the Liquent Vista domain and then uninstall the software.
1. Log on to the Rendition Engine server as FNRE_Admin.
2. Start the Domain Manager application.
3. Select the Configuration tab in the left navigation pane.
4. Expand Domain and Repositories to view the server machines in the domain.
5. Click the machine name to be removed from the Liquent Vista domain.
6. Select Delete from the Edit menu.
7. Confirm the deletion and select Save from the File menu.

Removing Rendition Engine software from a Rendition Engine

To complete the uninstallation, you must uninstall the IBM FileNet Rendition
Engine software, remove the local printer ports, and remove native application
macros.
1. Log on to the Rendition Engine server as FNRE_Admin.
2. Stop the BusinessServiceServer Windows service before uninstalling the

software:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Administrative Tools.
c. Double-click Services.
d. Double-click BusinessServiceServer.
e. Click the Stop button.

3. Remove the Rendition Engine software:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Add or Remove Programs.
c. Select FileNet P8 Rendition Engine 4.5.1 and click Change/Remove.
d. Follow the screen prompts to remove the software. At the final screen,

click Finish.
e. Close the Add or Remove Programs window.

4. Remove the printers:
a. Navigate to Start → Settings → Control Panel.
b. Double-click Printers and Faxes.
c. If the Liquent PDF Creator is listed in the Printers and Faxes window,

delete it.
d. If the Liquent PDF Printer is listed in the Printers and Faxes window,

delete it.
e. On the Printers and Faxes window, select File → Server Properties.
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f. On the Print Server Properties dialog box, select the Ports tab and delete
the local ports that point to: RE_install_path\ESPS.PS

g. Select the Drivers tab and remove (if it exists) the printer driver Amyuni
Document Converter 300.

5. If any of the following Word Perfect macros are present on the Rendition
Engine server, remove them:
v espsdtoc.wcm

v espsdtoc11.wcm

v espsdtoc12.wcm

v espsdtoc2k.wcm

v espsdtoc9.wcm

v espsrsym.wcm

v espsrsym11.wcm

v espsrsym12.wcm

v espsrsym2k.wcm

v espsrsym9.wcm

v generate.wcm

v removehf11.wcm

v removehf12.wcm

v removehf2k.wcm

6. Reboot the server.
7. Verify that the Liquent software has been removed:

a. Navigate to Start → Settings → Control Panel.
b. Double-click Add or Remove Programs.
c. Verify that the IBM FileNet Rendition Engine 4.5.1 entry and the Liquent

entry have been removed.
d. If the Liquent services entry is still there, remove it.

8. Verify that all files are removed from RE_install_path and C:\Program
Files\Common Files\Liquent. If there are files in these directories, delete them
manually.

9. Verify that the LIQUENT key has been removed:
a. Select Start → Run.
b. Type Regedit.
c. Navigate to HKEY_LOCAL_MACHINE\SOFTWARE.
d. Verify that the LIQUENT key has been removed. If the LIQUENT key is

there, delete it.
10. Reboot the server.
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Appendix. FileNet P8 port numbers

The table below lists the default port numbers used by IBM FileNet Rendition
Engine.

Rendition Engine ports

Port description

Liquent notify port 2868

Liquent event port 2869

Liquent admin port 2870

Liquent file transfer port 2871

Liquent job queue port 2872

Microsoft SQL Server 1433

Oracle 1521
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Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

IBM World Trade Asia Corporation
Licensing
2-31 Roppongi 3-chome,
Minato-ku
Tokyo 106-0032, Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law:
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION ″AS IS″ WITHOUT WARRANTY OF ANY KIND, EITHER
EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS
FOR A PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply
to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.
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IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs.
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Each copy or any portion of these sample programs or any derivative work, must
include a copyright notice as follows:

© (your company name) (year). Portions of this code are derived from IBM Corp.
Sample Programs. © Copyright IBM Corp. _enter the year or years_. All rights
reserved.

Portions of this product are:
v Copyright © 2000-2007 The Apache Software Foundation. All Rights Reserved.
v Document Viewer © 1991-2007 MS Technology, Inc. Charlotte, NC. All Rights

Reserved.
v Copyright 1994-2007 EMC Corporation. All Rights Reserved
v Copyright ©1998-2003 The OpenSSL Project. All Rights Reserved.
v Oracle® Outside In Viewer Technology, Copyright © 1992, 2007, Oracle. All

Rights Reserved.
v Copyright © 1996-1999 by Scott Hudson, Frank Flannery, C. Scott Ananian. All

Rights Reserved.
v Copyright 1994-2007 W3C (Massachusetts Institute of Technology, European

Research Consortium for Informatics and Mathematics, Keio University). All
Rights Reserved.

This product is Built on Eclipse (http://www.eclipse.org).

Trademarks
This topic lists IBM trademarks and certain non-IBM trademarks.

IBM, the IBM logo, and ibm.com® are trademarks or registered trademarks of
International Business Machines Corporation in the United States, other countries,
or both. If these and other IBM trademarked terms are marked on their first
occurrence in this information with a trademark symbol (® or ™), these symbols
indicate U.S. registered or common law trademarks owned by IBM at the time this
information was published. Such trademarks may also be registered or common
law trademarks in other countries. A current list of IBM trademarks is available on
the Web at ″Copyright and trademark information″ at http://www.ibm.com/legal/
copytrade.shtml.

The following terms are trademarks or registered trademarks of other companies:

Adobe, Acrobat, Portable Document Format (PDF), PostScript®, and all
Adobe-based trademarks are either registered trademarks or trademarks of Adobe
Systems Incorporated in the United States, other countries, or both.

Intel®, Intel logo, Intel Inside®, Intel Inside logo, Intel® Centrino®, Intel Centrino
logo, Celeron®, Intel® Xeon®, Intel SpeedStep®, Itanium®, and Pentium® are
trademarks or registered trademarks of Intel Corporation or its subsidiaries in the
United States and other countries.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both.
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Microsoft, Windows, and the Windows logo are trademarks of Microsoft
Corporation in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Other company, product, or service names may be trademarks or service marks of
others.
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